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1. Prerequisites

Hardware requirements

Processor 3 Ghz (2 Ghz min.)
RAM 16 Gb (8 Gb min.)
Display Resolution 1920 x 1080 pixels

For the planner’s computer:

A powerful graphics card with 2 video outputs provides
optimal response times.

Two 24-inch or larger screens. Direct Planning offers fea-
tures where two screens greatly improve the ergonomics
of the workstation; for example, viewing the schedule on
the left screen and a list of jobs on the right screen.

Disk Space .

10 GB for a “complete” installation on the workstation
where the planning database is stored (automated SQL
Server Express installation)

200 MB for “minimal” installation on user workstations

Software requirements

Operating System .

Client workstations: Windows 10
Server: Windows Server 2012, 2016 and 2019 (The Win-
dows server may not be a domain controller).




Misc. Microsoft .NET Framework 4.8 component has to be installed
on your computer. Upon installation of Direct Planning, if it is
not the case, you'll be automatically redirected to the down-
load page.

To install Microsoft SQL Server on Microsoft Windows 11, you
must first modify the workstation registry.

1. Go to the page Computer\HKEY_LOCAL_MACHINE\
SYSTEM\CurrentControlSet\Services\stornvme\Parameters\
Device.

2. On the Modify menu, point to New, then select Mul-
ti-string value. Name it ForcedPhysicalSectorSizelnBytes.

3. Modify the new value, typing “* 4095". Select OK and
close the Registry Editor.

Remarque :
- Windows Server 2012 and 2012 R2 will no longer be supported by Microsoft on October
10, 2023.

You must be have access to the following information :

* The path of the directory where the VLA license file is stored

* The network identifier of the station to setup

* The Windows login of the station user

= The name of the database server where the schedule is located (for network installations)



2. Preparing the license

Launch Volume Licence Administration (VLA), connect to the license directory, select the Direct Planning
Configuration and click on Configuration detail:

[ - _ —
.28 Volume Licence Administration 1.1 S — . @‘m
File 7
Directory of licences ° 2 | |\\\ro|upc12‘\vla_\mlumesoﬂware ||::

| ¥l Documentation |- Apply for a licence

[Z] New configuration |57 Configuration detail
Product

T

| Config | Description | Wb perm. user | Mb temp. user | Temp. end dat |
T R R g - - = . —!

1 DirectPlanning Configuration 0/ 05

Close

Version : 1.1.0.6680 .:

When replacing an existing station, select the line of the replaced machine and click the Modify button.

To add another station, you must have a free licensing slot available (permanent or temporary) and click
the Add button:

& — =
=8 Configuration of licences for DirectPlanning 3.0 E@g
Configuration #: | 1 | |DirectF‘Ianning Configuration | Modify name [ Options ]
Status of licence: |\|’E|Iid licence | [ See licence ] [ New licence ‘ [ # Define access password ]

Permanent accreditations 1/10
Temporary accreditations 0/5 Expires on: 31/12/2018
List of accreditations |3] Excel export ~ E Add @ Modify 3¢ Delete | Toggleto.. ~

Permanent ‘ Temporary

Type | Machine | Window User name

, Site UserNbr  Lastuse Modification = Modification
(= VSW-PDT podupo.. Dupond Piems

Tours [
75 o]
( Enable VSW mode Save and qui | [ Cancel |




A named license is assigned to a machine/user pair.

Populate all white fields . Please note that if the machine and Windows login fields are invalid, the li-
cense will not work.

-

.28 Creation of a named licence. . S— — M
Joentifier :
Machine: @ [vsw-ro1 | Date of creation: i 1
Windows login: @ |p dupond | Bate;glld e | =L
| @ Popord | End daie of accreditation: | Bl 18
Bt ﬂ |F‘iema | Total number of uses: |:|
Site: ﬂ |Tour5 |
Related type of licence: @ Pemanent () Temporary
Save and qut | [ canesl




3. Creating users

When adding a new station, the latter does not always allow to open the schedule with modify access.
Either because this is a read-only license or because the schedule is reserved by another user.

It is therefore recommended to anticipate this potential blocking by creating the user before the instal-
lation, while it is available for modification.

User management is performed via the List of users menu.

ADMINISTRATION o]

This menu is available from the ribbon, under the Configuration > Users tab

a

Users

& List of users = O >
|4 o 5] Export Excel ~ S New ||| 57 Modify (5,
[1 Seeinactive
L | | | L [E3
# |Llogin | MHame i Fisrt name !Ame.ss level |.ﬁ.|:.tive| Diefault display |
{0 admin Administrateur Super user IE Planning

Because no user have yet been created, this list is still empty except for you, the administrator. Click on
New to create users:

i & Creation: User - g
User ‘ Options utilisateur I Allowed display modes | User configurable lists |

ldentification Set password

|dentifier ® New password I:l ®

Login | ‘ Confirm password l:l

Name | ‘

Fisrt name | ‘

Email H| |

[V] Utilisateur sctif

Schedule access level Privileges
(7) Super-user | Configure schedule
) Access for modification | Use scheduling {if active licence)
21 Access for restricted modification ® | Manage technical data @

@ioces etz | Manage calendars

| Manage entities
SaveandClose | [ Cancel

The first tab User allows to enter basic information about the user. It consists of 4 zones.




@ User credentials: Identifier (automatic and non-editable), Login (required and non-editable), Surname
(required and editable), Forename (optional and editable), Email (optional and editable) and Active
user (checked and editable).

@ User password (required and editable).

® Direct Planning access level:

Super-user (admin): Always created automatically for any new schedule, it cannot be deleted. It
is strongly recommended to modify the associated default password (admin) when creating the
schedule.

He has all privileges (@), and none of them can be waived from him.
Only he can grant the same rights to another user.

Users with Access for modification rights can schedule jobs and modify the schedule.
Their privileges (@) are those granted by the administrator.

Users with Access for restricted modification rights have no privileges (®).
It typically designates a production operator reporting a progress status to the planning manager
or an operator updating certain flags after receiving material or tools.

This type of access allows to:
- Update the declaration of production (performed quantity and duration)
- Modify flags (except notes)
- Create user alerts in job details (Declaration of production tab)
- Modify job description and configurable areas

Among other things, it does not allow to modify:
- Anything regarding the placement of jobs in the schedule
- The planned quantity and duration
- Technical elements

Caution: Creating users with access for restricted modification requires to enable the automatic
import function in the Configuration > General configuration > Automatic import menu.

@p

rivileges granted to users (see above).
Configure schedule: allows users to access the Configuration tab, notably to manage users.

Use scheduling: the scheduling function is no longer maintained. The corresponding privilege is
therefore outdated and will be removed from the next version of Direct Planning.

Manage technical data: unchecking this box allows users to view (but NOT modify) the resources
(project mode), sections/machines, working units.

Manage calendars: unchecking this box allows users to view (but NOT modify) the characteristics
of calendars (standard days, standard weeks, machine operating times). More information about
these notions in section 5.5 Managing calendars.

Manage entities: unchecking this box allows users to view (but NOT modify) entities.



"
,l Creation: User

User | Options utilisateur | Alowed display modes | User configurable lists |

[ |Upon schedule opening, automatically move to current date and time (rather than moving to the most recently used date).
[ PLantomatic updating of a schedule opened for consultation (if user inactive for some time).

[ |Jpon schedule automatic update, sutomatically mowve to current date and time.

The second tab, User options allows the definition of opening and positioning options in the schedule.
Users can modify these setting under File > User options > For this schedule.

f j Creation: User

| User | Options utiisateur | Allowed display modes | User configurable lists

Select the user's default display mode: Planning -

Select the display modes this user will have acoess fo:
e Planning

Earliness/Lateness verfication
[ S=le= view by customer/praduct

..[¥] By defautt

The third tab, Allowed display modes allows to select the display modes available to selected users.
This option is useful to display only the relevant sections/machines.

-
_l Creation: User

| User IDptiuns utiisateur | Alowed display modes | User corfigurable fists |

Select the configurable lists this user will have access to:

o Milling planning
Processing planning
Finishing planning
it List of jobs on alert

L] [ —

Similarly, the User configurable lists tab is used to filter the lists of jobs available to users. In the same
fashion, the objective is to select the relevant lists to their usage. More information about configurable
lists in the next section.

When you are done creating/modifying users, click on Save and close.



Simultaneous usage in modification by multiple users

If your login benefits from the modification authorisation, you open the schedule systematically in mo-
dification.

1. If nobody has opened the schedule in modification before you, you habe the access in modification.
If you do not have any modification to make, or if you have finished them, you can switch to consul-

tation mode :
FE 9 ™ (g
File Home Edit Display Planning assistance Status Data Calendars Confisuration {
Your access mode Modificatl'on Q
Status of schedule Currently medified by MARTIN Daniel E, Switch to consultation mode
E Notification K

2. If another user is already making modifications :
* This user will be notified of your connection attempt
* You will be connected to the schedule in consultation
* You will be notified when the access in modification will be freed and available again
* You will then be able to use the Status tab to Switch to consultation mode



4. Installing Direct Planning

Start the Direct Planning setup program and follow the on-screen directions.

When choosing the type of installation, select “Full” to install the database server station and “Minimum”
to install a client station.

()

" Setup - DirectPlanning 3 —

Type of installation.
Choose the installation type that best suits your needs.

Select an installation type :

Full ; DirectPlanning 3 and a dedicated instance of Microsoft SQL Server 2012
() Express. This installation is required if you want to save a schedule locally on this
computer.

® Minimurm : DirectPlanning 3 anly. This installation is sufficient to view or edit a
schedule located on another computer,

< Back ’ \ Cancel

When the setup completes, you can launch Direct Planning 3.



5. Reqgistering the Direct Planning license

Caution: You may have to launch Direct Planning with administration rights (right-click on shortcut and
select Run as administrator).

After the first start, Direct Planning is in trial version, valid for 30 days from the installation date.
This screen acts as a reminder each time you start Direct Planning and the software is not registered.
You can also display this screen by selecting About in the “? “ menu.

? About DirectPlenning 3.- u

-

Di;m: Planning

DirectPlanning & 3.4.0. 6890

4| Undabe note

-

1w direciplapning.com
§) Facebook
I) Tuather

License is wrong or not registered.

[0207] The evaluation periad of DirectPlanning is cver.
Rlease contact Volume Soffwane to gek this product or to extend your
evaluation period,

[ Enter licence ’ [ Request a license by email

Copyrght & volume Software
Ribbon basaed on the weork of Josgé Manugl MeEnéndez Poo [waww. mensndezpag.caml.

'I"I'aliq. this softwaes is protecied by copreight lews awf by interatonsl cowertions . Anp sspreductior or pediad or full destrbeizn
i fortidd=n, Amyens not respestng thess condtions @il be goly of mfongenant ofiesce srd wil = loble b proascstion.

[ systam. information | l Close }

A When the 30 day trial expires, running your software requires a license.
Click on Enter License or Request a license by email to activate Direct Planning.

Direct Planning can be activated by entering a local activation key or by connecting to license server

(explained later).



Entering an activation key

r@ Station cunﬁguraﬁun : ﬂ‘
Stationkey: |L¥33 |D5ZY ER2E |OPLB |E6X1A [Lhm'ﬁp‘fmrm ]
@ Local activation keys - | Mewlicense.. |
Description: |
Status - |
™1 Connect to & named licence server. | Lirghc:.. |

Write down or copy your station key, and transmit it to Volume Software to obtain an activation key.
When you receive your activation key, click on New license... to enter it manually or paste it:

13" Enter new activation key ﬂ

Station key - |L¥o3 |Dsz¥ |ER2B |OPIB |8X1A

Activation Key :




Connecting to a license server

Volume Licence Administration (VLA) must first be installed and configured (please refer to the docu-

mentation of this product).

Click on Connect to a named license server:

r v
.5_’\ Station configuration h“ ﬂ

Sttionkey: |LY93 |D5ZY |ER2B |OPLE |8X1A [P E -
71 Local activation keys : Mew licanse
Description |
Status : |
@ Connect to a named licence server, Link:...
License status ;

License is wrong or not registered.
[0207] The evaluation period of DirectPlanning iz over.
Please contact Volume Software to get this product or to extend your evaluation period.

Close I
Select On the computer. You can enter the
computer name directly or search foritonthe F——-mmm
network via the dropdown menu. ' x
I Check validity of this file J
Valid file
Function test
Name of machine : VOLUPC12
\indows login : f.catheln Cheek licence for this pair
Save and et | [ cened |

Save and Quit: Direct Planning is now registered.

<« Click on to search for the
Named licence server file. Two but-
tons can also be used to check the
validity of the selected file as well as
the license for the Machine/Login
pair.

schedule.

Each scheduleisidentified with a number (the creation sequence) and a designation.
Open the dropdown menu to select the desired schedule and click on Open this




6. Opening the schedule

To open a schedule, click on File > Open and follow these steps:

Selection of media type to open

what do you want to do?

@ Open a schedule

71 Open a demonstration schedule

7) Open a Direct Planning 3 (.dpl2, .mdpl2) file
) Import @ Direct Planning 1.2 schedule (dpl)

Welcome in the schedule open wizard.

Select Open a schedule

Selection of host computer

Selection of host computer

{Open a schedule located:
) On my computer (VOLUPC12)

Please select the computer hosting the schedule you want to open.

@ On computer;

Selection of schedule

Please select the schedule to open.

Number and name of schedule [23} ”Derno schedule




