Aide sur l'aide

IMPORTANT : Les fichiers d'aide sont régulièrement ré-actualisés sur la bande de mise à jour (répertoire aide) que vous recevez chaque mois.

Sommaire

Trucs et astuces

Comment faire une recherche évoluée ?

Comment faire une recherche à l'intérieur d'un document ?

Lorsque je clique sur un lien, je perd le sujet sur lequel j'étais. Comment y remédier ?

A quoi servent les fichiers chw ?

Je ne retrouve plus les favoris que j'ai créés - Les favoris que j'ai créés ne fonctionnent plus. Pourquoi ?

Ces informations vous ont-elles aidé ?

Trucs & astuces

L'onglet Rechercher est le moyen le plus sûr de retrouver une information dans l'aide en ligne.

Les termes recherchés apparaissent en surbrillance (en fonction de votre navigateur), facilitant leur repérage au sein des documents trouvés.

Singulier - Pluriel

Cependant, dans certains cas de figure, le terme recherché n'apparaît pas en surbrillance.

Si vous recherchez un terme susceptible d'apparaître au singulier comme au pluriel, mettez les 2 orthographes dans le critère de recherche, reliés par l'opérateur OR : par exemple : barème OR barèmes

Caractères accentués

Vous avez toujours intérêt à respecter les accents dans les critères de recherche.

Tous les termes, avec ou sans accents, seront retrouvés et affichés en surbrillance.

L'inverse n'est pas vrai : si vous ne mettez pas d'accent dans votre critère de recherche, seuls les termes non accentués seront retrouvés.

Par exemple, si vous recherchez le mot Réclamation, précisez l'accent : outre les documents où le terme apparaît accentué, vous retrouverez aussi les documents où il est question du programme et de la table (non accentués).

Majuscules - Minuscules

Aucune répercussion - vous pouvez entrez vos critères de recherche sous les 2 formes ou une combinaison des 2.

Expressions

Vous avez intérêt à mettre les expressions entre guillemets.

Par exemple, si vous recherchez des articles sur la sous-traitance, indiquez "sous-traitance" comme critère de recherche : ceci éliminera les sujets portants sur les sous-devis ou les sous-familles, par exemple.

Comment faire une recherche évoluée ?

Le mode de recherche le plus évolué est dans l'onglet Rechercher.

Vous pouvez combiner plusieurs termes de recherche avec les opérateurs AND, OR, NEAR, NOT.

En outre, vous pouvez "empiler" les recherches de la façon suivante :

  • Faites une première recherche

  • Cochez la case "Rechercher les résultats précédents"

  • Lancez une deuxième recherche : cette 2ème recherche sera faite non pas sur l'ensemble du fichier d'aide, mais uniquement sur le résultat de la 1ère recherche.

  • Vous pouvez relancer ce processus autant de fois que vous le souhaitez.

  • Pensez à décocher la case "Rechercher les résultats précédents" une fois que vous voulez revenir à un mode de recherche standard !

Comment faire une recherche à l'intérieur d'un document ?

Cette méthode est similaire à la recherche que l'on fait dans un éditeur de texte.

  • Faites un simple clic dans le corps du document pour lancer la recherche à partir du début.
    <ou>
    Faites un double-clic à l'endroit à partir duquel vous voulez lancer la recherche.

  • Faites Ctrl F (F comme Find - Chercher)

  • Entrez votre critère de recherche puis faites Entrée.

Lorsque je clique sur un lien, je perd le sujet sur lequel j'étais. Comment y remédier ?

Lorsque vous cliquez sur un lien à partir d'un sujet, le sujet source disparaît pour faire place au sujet cible.

2 possibilités :

  1. Après avoir lu le sujet cible, cliquez sur Page précédente pour revenir au sujet source.

  2. Avant de cliquer sur le lien, cliquez et maintenez enfoncée la touche shift (majuscules) : le sujet cible s'affichera dans une fenêtre de votre explorateur Internet.
    Cette méthode présente l'avantage de pouvoir laisser ouverte la fenêtre du sujet cible.
    Vous pouvez ainsi laisser simultanément ouvertes plusieurs fenêtres de sujets cibles.

A quoi servent les fichiers chw ?

Dans le répertoire contenant les fichiers d'aide, il existe des fichiers ayant comme extension .chw.

Ce sont des fichiers contenant les index.

Vous pouvez les supprimer sans problème, ils se recréeront la prochaine fois que vous sélectionnerez l'onglet Index.

Je ne retrouve plus les favoris que j'ai créés - Les favoris que j'ai créés ne fonctionnent plus. Pourquoi ?

Les favoris sont stockés dans un fichier binaire, propre à l'utilisateur, et commun à tous les fichiers d'aide au format chm (qu'il s'agisse des fichiers d'aide de Volume Software ou d'autres fichiers d'aide propres à Windows, Word, Excel, ...) :

C:\Documents and Settings\XYZ\Application Data\Microsoft\HTML Help\hh.dat où XYZ représente votre login.

Il existe donc un fichier hh.dat par utilisateur de cette machine, et chaque fichier hh.dat contient ses propres favoris.

Chaque favori est enregistré avec le chemin d'accès et le nom du fichier chm auquel il se rapporte.

C'est pourquoi l'onglet Favoris ne montre que les signets se rapportant au fichier d'aide en cours.

Vous pouvez très bien créer des favoris et les conserver de façon durable même si vous avez installé des nouvelles versions de l'aide Volume.

La seule contrainte est que vous devez toujours utiliser vos fichiers d'aide dans le même répertoire.

Si certains favoris n'apparaissent plus dans l'onglet des favoris (ou ne fonctionnent plus), c'est vraisemblablement parce que vous les avez créés alors que les fichiers d'aide étaient dans un autre répertoire.

Si le fichier hh.dat contient des favoris indésirables que vous ne voulez pas supprimer un par un, la solution radicale consiste à le supprimer tout simplement (après avoir fait une copie de sécurité !).

ATTENTION : ce geste entraîne la perte de tous les favoris de tous les fichiers d'aide, et non pas seulement ceux de l'aide Volume Software !

Le fichier hh.dat se recréera automatiquement au premier lancement de n'importe quelle aide au format chm.

Le fichier hh.dat est recréé avec des valeurs par défaut (taille et position de la fenêtre, visibilité du volet gauche, etc...).

Si le volet gauche (onglets Sommaire, Index, Recherche, Favoris) n'est plus visible, cliquez sur le bouton Afficher situé en haut à gauche de la fenêtre.

Ces informations vous ont-elles aidé ?

J Oui

L Non : Envoyez-moi un mail !


Accueil

Logo Volume Software

Aide en ligne du 14/03/2014 à 09:45

ATTENTION : TRES IMPORTANT !

Tout changement d'option doit être validé par le chef de projet Volume Software.

Retrouvez la dernière version de l'aide en ligne sur la bande ou le CD de mise à jour !


Généralités

Pour la mise en oeuvre du paramétrage, nous vous recommandons de lire le document Parametrage

Voir aussi la page sur les paramètres généraux de configuration

Saisie simplifiée des notes

Notes communes à plusieurs programmes

Notes pour construire un critère de sélection sur un article via l'interrogation simplifiée des articles

Optimisation du temps de chargement sous GENERO

Conventions d'écriture

alpha3[5] ou A3[5] fait référence au cinquième caractère de la valeur alpha 3.

alpha2[12,18] ou A2[12,18] fait référence aux caractères 12 à 18 de la valeur alpha 2.

Les paramètres suivants sont reconnus par tous les programmes.

Ils sont facultatifs : s'ils ne sont pas renseignés, une valeur par défaut leur est affectée.

Ils peuvent se présenter dans n'importe quel ordre.

-B | Activation du mode BATCH
-C | Types de notes Indique les types de commentaires utilisés. On peut forcer les types utilisables en les précisant après le paramètre de la façon suivante : -C(longueur code)(code)(longueur code)(code) etc Exemple : -C2AR3BLV2FA signifie que seuls les types de note AR, BLV, et FA seront utilisables par le programme.
-dAAMM | Année et mois en cours (compteurs pour numéros de commande) Par défaut, la date du système est prise.
-D | Indique les différents TIC utilisés. On peut forcer les types utilisables en les précisant après le paramètre de la façon suivante : -D(longueur code)(code)(longueur code)(code) etc Exemple : -D2BL3FAB3COM signifie que seuls les types de BL, FAB, et COM seront utilisables par le programme.
-H | Menu CAB
-l (l comme lock) | (l minuscule) Temps d'attente sur un lock
-I (i comme imprime) | (i majuscule) Nombre d'exemplaires à imprimer 00 ouverture de fenêtre pour demander le nombre de copies 12 pour 12 copies
-o | Base On Line
-Q | Mode debug Informix Mode spécial explain VSW qui ajoute des TOP dans le fichier sqexplain.out
-r | Utilisé pour les rééditions, ce code n' est pas traité par la fonction init_glb, mais doit être testé dans le programme
-t | Mode trace La présence de cette option active le mode trace.
-T | Nom du device de lancement (tty)
-u | Nom de l'utilisateur Détermine le paramètre de type USE. Par défaut, le paramètre utilisé sera USE DEF.
-UGROUPE | Groupe utilisateur Utilisé uniquement dans menu.
-V | Ce paramètre permettra l'appel à v_stk0 à la place de f_v_stk0. Indiquer sur 3 caractères le code paramètre de la visualisation des stocks. De façon implicite le type sera #VI
-Wn | Choix périphérique de sortie par défaut. -W1 imprimante 1 -W2 imprimante 2 -W3 imprimante 3 -W4 imprimante 4 -We Ecran Wf Fichier (-Wfnom_de_fichier) Wv Vide -W suivi d'un espace : les périphériques sont définies dans des notes du paramètre de lancement commençant par W comme suit : Caractère 1 et 2 : -W Caractères 3 à 5 : Code utilisateur (Paramètre USE) Caractères 6 à x : Code paramètre périphérique
-x | Imprimante utilisateur
-X | Imprimante du paramètre -X suivi d'un code paramètre imprimante : imprimante de l'utilisateur Exemple : -XFAC enverra l'impression vers l'imprimante définie par le paramètre #LP FAC -X suivi d'un espace : les imprimantes sont définies dans des notes du paramètre de lancement commençant par X comme suit : Caractère 1 et 2 : -X Caractères 3 à 5 : Code utilisateur (Paramètre USE) Caractères 6 à 8 : Code paramètre imprimante (#LP XXX)
-Y | Base transactionnelle (non géré)
-Z | Paramètre de lancement Type et code du paramètre de lancement de programme (généré automatiquement par la fonction de lancement de programme)

Notes communes à plusieurs programmes

Sauf indication contraire, les notes sont communes à tous les programmes.

ATTENTION : Il y a plusieurs groupes de notes, faites défiler l'écran pour les voir tous.

Construire un critère de sélection sur un article via l'interrogation simplifiée des articles

Actuellement, certains programmes permettent de lancer la construction d'un complément de sélection sur la table des articles (mat) via l'écran de saisie détaillée.

Il est désormais possible d'utiliser à la place l'interrogation simplifiée.

CRI_MAT_SIMPLIFIE

21 Utiliser l'interrogation simplifiée pour la construction d'un complément de sélection des articles (mat) (O/N, N par défaut)

23,28 Type et code du paramètre de lancement de la saisie simplifiée des articles

Ce paramètre permet de récupérer les notes de paramétrage ainsi que les options de fonctionnement (-O) spécifiques à la saisie simplifiée. Ceux-ci peuvent également être forcés sur le paramètre de lancement courant (voir ci-dessous)

OPTIONS_SAISIE_MAT

21,60 Options de fonctionnement liées à l'interrogation simplifiée des articles

IMPORTANT :

Ces options s'ajoutent à celles saisies sur le paramètre de lancement de la saisie simplifiée des articles.

Si, dans la note CRI_MAT_SIMPLIFIE, vous avez paramétré le type et code du paramètre de lancement de la saisie simplifiée des articles associée, cette note est optionnelle.

Vous pouvez mettre 20 options par ligne (par bloc de 2 caractères) :

ef Saisie des libellés étrangers avec le code fournisseur. Si cette option n'est pas activée, la saisie des libellés étrangers est faite avec le code client.

go Permet de gérer l'emplacement des outillages dans la saisie simplifiée des articles. L'emplacement est géré via le programme de liens entre les tables.

N.B. : Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

o1 Autorise la saisie des matières fournitures fantômes Voir #CF MAM

o2 Autorise la saisie des produits et semi-ouvrés Voir #CF MAP

o3 Autorise la saisie des outillages Voir #CF MAO

o4 Autorise la saisie des pièces de maintenance Voir #CF MAN

o5 Autorise la saisie d'un nouveau type de produit. Saisie de qualité matière (mp_mp = Q)

rf Recherche (F7) d'un outil, d'une forme. Voir les notes CODE_LIEN_TABLES et _SUP_REQ_OUTIL.

Les notes suivantes sont prioritaires par rapport à celles saisies sur le paramètre de lancement de la saisie simplifiée des articles associé.

Si, dans la note CRI_MAT_SIMPLIFIE, vous avez paramétré le type et code du paramètre de lancement de la saisie simplifiée des articles associée, ces notes sont optionnelles.

INT_SIMP_FAM_OBLIG

21 Famille obligatoire pour l'interrogation simplifiée (O/N, N par défaut)

CODE_LIEN_TABLES

21,23 Code paramètre du lien à utiliser (type #LI) pour la recherche d'un outil/forme (voir l'option rf ci-dessus)
Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser.

TITRE_SAISIE_SIMPLE

21,60 Titre de la fenêtre de saisie simplifiée

_SUP_REQ_OUTIL

21,60 Complément de requête pour la recherche d'un outil/forme (voir l'option rf ci-dessus)

_SUP_REQ_MAC_OUTIL

21,60 Complément de sélection pour la recherche des machines liées aux outils (voir l'option rf ci-dessus)

_SUP_REQ_INT_SIMP

21,60 Supplément de requête sur l'interrogation simplifiée des articles

Notes pour la recherche de matières par F7

Ces notes sont accessibles à tous les programmes utilisant la recherche de matière par F7.

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

21,23 Type du paramètre de lancement de la visualisation v_mat (normalement #VI)

21,23 Code du paramètre de lancement de la visualisation v_mat

où X peut prendre les valeurs suivantes : (la valeur 5 n'est pas prévue).

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Q Recherche sur la qualité

T Recherche orientée Transformateurs

SMATn

7,60 Complément de sélection utilisé dans le cas où la visualisation est utilisée en tant que recherche d'article

où n = Type de recherche du code article par F7, à savoir :

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Q Recherche sur la qualité

T Recherche orientée Transformateurs

ATTENTION

Dans le cadre de la recherche d'articles par visualisation, ce critère peut être ignoré en fonction de #CF RMP A1[41]

Par défaut, on prend le complément de sélection SMAT1 du paramètre de lancement du programme en cours d'utilisation (par exemple, la saisie des devis dans le cas d'une recherche faite sur une LCO)

Il existe 2 autres moyens d'affiner la recherche de matières / articles / produits par F7 :

1) Via le paramètre #CF RMP :

A1[1] définit l'ordre de tri

Les notes commençant par Sn permettent un complément de sélection appliqué à toutes les recherches.

2) Pour la saisie de commande, #CF CDE A1[48] définit le type de recherche.

TYPE_RECH_F7_MAT

Paramétrage du type de recherche effectuée par le F7 matière

21 Type de recherche du code article

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Q Recherche sur la qualité

T Recherche orientée Transformateurs

22 Ouverture d'une fenêtre de saisie de critère de recherche (O/N, N par défaut)

23,40 Nom de la zone sur laquelle est effectuée l'interrogation

Zones de saisie d'un article d'une table :

mp_code

mp_qualite_matiere

lc_prod

etc.

Zones de saisie d'un article d'un TSC :

TSC_XXX_G

où XXX représente le code du TSC

Zones de saisie d'un article d'une LCO :

LCO_YYY_M

où YYY représente le code de la LCO

Le nom de la zone sur laquelle se trouve le curseur peut être visualisé en cliquant sur le point d'interrogation du menu, puis Informations fenêtre, rubrique Zone.

Dans certains cas, le nom de la zone à utiliser est le nom final et non celui de l'écran des informations fenêtre.
Par exemple, dans le tableau de détail de la saisie simplifiée des articles, le nom de la zone à saisir doit être utilisé (le nom du champ paramétré sur la note commençant par COL_ART).

41,46 Type et code du paramètre de la visualisation à utiliser pour afficher le résultat de la recherche (dans le cas de la recherche par visualisation) (Non renseigné si car.21 = 5 pour cdef)
Voir #CF/RMP A1[5]
Par défaut : Type et code du paramètre de visualisation renseignés dans les notes TYPE_ACC_VISU_MAT_X (où X représente le type de recherche d'article).

Autres notes, triées par ordre alphabétique

ACCES_LCK

21 Clé de lock

Le but est d'empêcher 2 personnes différentes de lancer simultanément des programmes traitant des mêmes données.

Exemple : édition des dossiers de fabrication pendant la génération.

Le nom du lock peut contenir des constantes et / ou des variables.

Les variables doivent être délimitées par des %.

Le nom du lock est limité à 15 caractères.

Par exemple, %PAR_ACH% sera remplacé par le code acheteur du fichier paramètre.

Dans l'exemple ci-dessous, si le code acheteur est 123, le nom du fichier lock sera BES_123_VL.

Exemple

ACCES_LCK BES_%PAR_ACH%_VL

EDITION_NUM_

A VERIFIER

13,14 Numéro de l'édition sur 2 caractères. Exemple : 01

21,23 Code imprimante (de type #LP). Exemple : OEX

25 Numéro de l'imprimante. Exemple : 1

31,60 Destinataire de la copie. Exemple : Atelier A

_ENVOI_PROG_AFTER

21,26 Type et code du paramètre du programme à lancer

Exemple

_ENVOI_PROG_AFTER #VIBES

_ENVOI_PROG_AFTER #FBACH

En sortie de ce programme , on lancera le #VIBES

Quand celui-ci sera terminé, on lancera le #FBACH

ATTENTION : si une note _ENVOI_PROG_AFTER est paramétrée sur #VIBES, le programme paramétré sera lancé en sortie du #VIBES

On aura alors :

Lancement du #VIBES

Lancement du(des) programmé(s) paramétré(s) sur le #VIBES

Lancement du #FBACH

ETIQ_RECH_FEFCO

Note accessible à tous les programmes qui impriment des étiquettes

Méthode de recherche du code FEFCO

1 On prend le FEFCO sur le premier élément de la nomenclature (seul code existant lors de la création de cette note)

Lors de l'édition des étiquettes de production, le code FEFCO et son libellé sont pris dans les données de la fiche matière.

Malheureusement, dans le cas d'une génération des articles par le devis, ces informations ne sont pas renseignées pour les ensembles (elles sont présentes sur les éléments).

Ce développement a pour but de paramétrer une méthode de recherche de ce FEFCO pour les ensembles dans le cas où cette donnée n'est pas renseignée.

FORCE_NB_ETIQ_PF

A VERIFIER

Forcer le respect du nombre d'exemplaires sur le TSC 250 du PF (O/N, N par défaut)

Pour les étiquettes de production

GESTION_NOM_DOC_MAIL

Cette note est utilisable dans les programmes d'édition AR, BL, Facture, Ordre dAchat de Transport

21 Mise à jour de la table envoi_fax_email avec le nom du document édité (O/N, N par défaut)

Complément du paramétrage sur #CF EFM

Voir la gestion d'envoi de mails via des scripts.

INFO_C_DEFAUT

Cette note peut être mise sur le paramètre de lancement de tout programme utilisant la recopie de TSC.

A Création des TSC par défaut

[autres valeurs] Pas de création des TSC par défaut

INIT_ARTICLE_AVEC_0

O En saisie d'un code article, (fonction f_s_article), retourne le code article par défaut (000000000000000) si rien n'est saisi.

Essentiellement appelée par les devis onduleurs pour saisir un article de référence.

[autres valeurs] non

MAJ_CORRESPONDANT

Voir la page dédiée aux notes Fax / Mail

NOM_AIDE_LIGNE

Accès à l'aide en ligne

21,60 Nom du document sur le module (sans espace)

Exemple

aide_saisie_article.docx

Voir la page dédiée

NOTES_GROUPEES

Saisie unifiée des notes dans les programmes VoluPack

21,23 Type de note à inclure dans la saisie des notes groupées, lorsque NTS GRP est déclaré.

Voir le chapitre dédié

OBJET_DOCUMENT

Voir la page dédiée aux notes Fax / Mail

_PARAM_RATT_TOOLBAR

21,26 Type et code du lanceur de référence rattaché

Pour la personnalisation des boutons sous GENERO

Exemple : #SACDE

RECH_SUR_CONTENEUR

21 Recherche sur conteneur (O/N, N par défaut) Voir la note _SUP_REQ_CONTENEUR

REGROUP_STOCK_ART

21 Utilisation du regroupement de stock (O/N, N par défaut

Paramètre nécessaire : TSC RGP

Ne pas mettre en place dans la correction des stocks.

CETTE FICHE NE CONCERNE QU'UN PROTOTYPAGE

Cette note peut être utilisée dans tous les programmes exploitant la fonction rechll (recherche par lot - lieu).

Dans un premier temps, elle ne concerne que la saisie des BL et la visualisation des mouvements de stock.

Pouvoir sur un produit visualiser son stock, ainsi que ceux des produits ayant le même code de regroupement.

La livraison pourra être faite sur un autre produit

REPERTOIRE

Répertoire de stockage des éditions dans un fichier

Exemple : REPERTOIRE /u/atlas/editions

Si le nom de fichier saisi lors de l'édition dans un fichier est dev1212, le système stockera le fichier dans /u/atlas/editions/dev1212

SCDE1

7,60 Complément de sélection sur la table d'entête des commandes clients

Cette note est accessible à tous les programmes utilisant la recherche de commandes clients, notamment (mais non exclusivement) :

la saisie de commandes clients

l'édition des AR

la saisie des BL

SCLI1

7,60 Complément de sélection pour la recherche des tiers (F7).

Cette note est accessible à tous les programmes utilisant la recherche de tiers.

Dans le devis standard, cette note permet également de contrôler la validité de saisie des champs tiers.

SFAB1

7,60 Complément de recherche sur les dossiers de fabrication.

Cette note est accessible à tous les programmes utilisant la recherche de dossiers de fabrication.

_SUP_ORDER_BY_CLI

21,60 Complément de tri pour la recherche des tiers.

Cette note est accessible à tous les programmes utilisant la recherche de tiers

_SUP_REQ_CONTENEUR

21,60 Complément de sélection sur les tables conteneur_info et conteneur_produit

Exemple

and cni_rgt1 = 'LUM'

and cnp_lot like '10%'

Voir aussi la note RECH_SUR_CONTENEUR

Cette note peut être utilisée dans tous les programmes exploitant la fonction rechll (recherche par lot - lieu).

La fonction de recherche des stocks par lot/lieu est faite actuellement, soit à partir de la table des mouvements de stocks, soit à partir de la table stk_lot_lieu (#CF ATL A4[43,44]).

Sur option, cette fonction calcule le stock physique à partir des tables conteneur_info et conteneur_produit uniquement pour les articles gérés en stock lot-lieu-conditionnement (mp_param[17]= 2).

Cette option est utilisable dans les programmes de correction de stocks, dans l'édition des AR pour la réaffectation des stocks Non VEndables, dans les visus à condition de ne calculer que le stock physique&

Cette option est à insérer dans les notes du paramètre de lancement du programme.

IMPORTANT :

Dans les programmes où le complément de sélection sur stk0 est en dur sur les champs s0_lot, s0_rgt1, s0_rgt2, il sera remplacé automatiquement par les champs cnp_lot, cni_rgt1, cni_rgt2.

_SUP_REQ_CRI_F7_

Complément de sélection par type de paramètre

Permet une sélection de plusieurs codes de paramètres par cases à cocher.

17,19 Type de paramètre sur lequel porte la sélection

exemple : RG1 pour sélectionner un ou plusieurs dépôts

21,60 Complément de sélection pour l'affichage de la liste des dépôts à prendre en compte

_SUP_REQ_F7_

Complément de sélection sur la recherche de paramètre par F7

13,15 Type de paramètre (RG1, QA, UNI, TVA, &)

21,60 Complément de sélection sur la table par02

Permet d'ajouter un complément de sélection dans la fonction f_rechpara (recherche de paramètres), en fonction du type de paramètre à rechercher et du paramètre de lancement.

Actuellement, il y a certaines recherches qui utilisent déjà un complément de sélection (codé dans le source) : ce complément est prioritaire sur le nouveau paramétrage.

Exemples

_SUP_REQ_F7_RG1 and p2_code matches "A*"

_SUP_REQ_F7_TVA and (p2_code = "5D" or

_SUP_REQ_F7_TVA p2_code = "5E")

ATTENTION : il existe aussi des _SUP_REQ_F7_CDE, _SUP_REQ_F7_ECH, etc. (liste non exhaustive).

Pensez à relancer une recherche avec _SUP_REQ_F7* en critère.

TITRE_DOCUMENT

Voir la page dédiée aux notes Fax / Mail

TSC_EDITION_PF

A VERIFIER

21,23 Code TSC d'édition du code PF

Exemple

ZCCode edit. PF :N Z<<<< Code edit. PF

#CCode edit. PF

Pour les étiquettes de production

TYPE_RECH_F7_CLI

Utilisable dans tout programme utilisant la recherche des tiers

Cette note est recherchée en priorité :

1) dans le paramètre de lancement (c'est ici)

2) dans le #CF CLI

3) dans le #CF ATL

Elle permet de spécifier le type et le code du programme de visualisation des tiers que l'on souhaite utiliser pour visualiser le résultat de la recherche des tiers par la fonction F7 dans tous les programmes.

21,26 Type et code du paramètre du programme de visualisation des tiers à utiliser pour visualiser le résultat de la recherche de tiers par la touche F7.

VALID_FAXMAIL_EDIT

Voir la page dédiée aux notes Fax / Mail

VALID_FAXMAIL_REEDIT

Voir la page dédiée aux notes Fax / Mail

VALID_FAXMAIL_VALID

Voir la page dédiée aux notes Fax / Mail

VISUNOM_AFF_DES_ART

Cette note peut être paramétrée dans tout programme appelant la fonction f_visunomenclature()

21 O Afficher le libellé du produit dans la visualisation des nomenclatures.

Toute autre valeur saisie ou l'absence de la note signifie que le libellé du produit sera masqué.

Optimisation du temps de chargement du menu sous GENERO

Le temps de chargement du menu GENERO est plus rapide qu'auparavant. Ceci est dû à 2 améliorations :

1) Le programme de chargement du menu a été optimisé.

2) En affichant le menu, le système l'enregistre sur le serveur au format XML.

Ainsi, lors des prochains affichages du menu, le système lira le fichier XML, ce qui ne prend que 2 secondes maximum.

Le menu est enregistré pour une société et un utilisateur donnés, sous la forme suivante : Menu_[soc]_[login].4sm dans le répertoire menu du serveur.

Par exemple, le menu de l'utilisateur Dupond de la société VSW sera sauvegardé sous le nom suivant : Menu_VSW_Dupond.4sm

Lorsque vous modifiez un menu, vous avez 2 possibilités afin que vos changements soient pris en compte :

1) Soit vous supprimez le(s) fichier(s) concerné(s) dans le répertoire menu du serveur,

2) Soit vous cliquez sur le bouton Rafraîchir du menu.

Le fonctionnement du mode Paramètre reste inchangé, il ne gère pas de fichier XML.

Il n'y a aucun paramétrage à mettre en Suvre pour bénéficier de ces améliorations.


Contrôle des champs dans la fiche tiers

Voir aussi : page récapitulative sur les contrôles de champs.

Le contrôle des champs est paramétrable à 3 niveaux, définis ci-dessous par ordre de priorité :

Niveau |
A | notes commençant par #CC du paramètre VAS (validité adresse)
B | notes de type #CC sur le tiers par défaut (00000C, 00000F, 00000P ou à défaut 000000) (SAUF pour les adresses secondaires)
C | notes commençant par #CC du paramètre de lancement du programme cli

Selon qu'il s'agit de notes commençant par #CC (niveaux A/C) ou de notes de type #CC (niveau B), la position des paramètres change comme l'indique le tableau ci-après :

Pour les TSC, voir tableau séparé plus bas.

Pour les champs du tiers

Position des paramètres |  | Objet
Niveaux A - C | Niveau B
4 | NON | Type de tiers (Non applicable aux notes de type #CC) C Client P Prospect F Fournisseur
5,22 | 1,18 | Nom du champ à contrôler Tous les champs de la table cli. (Exemple : cl_vil, cl_qualite, etc ...) Chaque caractère du champ cl_param présent dans la fiche tiers (exemple : cl_param4, cl_param17, …)
23 | 19 | Type de contrôle de saisie : N Pas de contrôle (par défaut) W Warning (avertissement non bloquant si la zone n'est pas saisie) B Bloquant (saisie obligatoire) I Interdit (on ne doit rien saisir dans ce champ) C Consultation (le curseur ne passe pas sur le champ) M Masquer (le champ n'est pas affiché)
24 | 20 | Génération d'une trace dans la table evt_trans pour le transfert en comptabilité (trace et_entite type T, et_type_action = Création, Modification ou Suppression) O Toute modification de ce champ (ou création pour le champ cl_code) entraîne une trace. N On ne garde aucune trace des modifications de ce champ (valeur par défaut). Non utilisé pour les adresses secondaires. Voir #CF ATL A2[31,33]
25 | 21 | Génération d'une trace dans la table evt_trans pour le transfert des forces de vente (trace type X). O Toute modification de ce champ (ou création pour le champ cl_code) entraîne une trace. N On ne garde aucune trace des modifications de ce champ (valeur par défaut).
26 | 22 | Génération d'une trace dans la table evt_trans pour le transfert CAO (trace type G). O Toute modification de ce champ (ou création pour le champ cl_code) entraîne une trace. N On ne garde aucune trace des modifications de ce champ (valeur par défaut).
27 | 23 | Type de contrôle à la modification du champ : N Pas de contrôle W Warning B Bloquant
28 | 24 | Type de donnée du champ C Donnée Commune (par défaut) S Donnée Société Lors de la modification d'une donnée société, un enregistrement de type H est créé dans la table evt_trans.
29 | 25 | Saisie de la valeur zéro. Ne doit être utilisé que pour les valeurs numériques O Oui -Le zéro est significatif (par défaut) N Non - Le zéro n'est pas significatif.

Pour les TSC

Permettre dans la saisie simplifiée de contrôler les champs associés à une information complémentaire (TSC) en paramétrant le contrôle (#CC) au même niveau que les colonnes (COL_ART).

Remarques :

• Pour une zone de TSC donnée, si aucun contrôle de champ n'est paramétré au niveau du paramétrage des colonnes, on utilise le contrôle paramétré sur l'information complémentaire elle-même (TSC, note commençant par Z, caractère 18)

• Pour une zone de TSC donnée, si un contrôle de champ est paramétré à N (pas de contrôle) au niveau du paramétrage des colonnes, le contrôle du champ est alors désactivé (même s'il existe un contrôle bloquant au niveau du paramétrage du TSC).

• Le contrôle de champ paramétré au niveau du paramétrage des colonnes est prioritaire à celui renseigné au niveau du TSC.

Car. | Objet
5,22 | Nom du champ à contrôler : TSC sous la forme TSC_CCC_Z où CCC = Code TSC Z = Zone TSC Le paramétrage du nom du champ doit être le même que celui présent dans la note commençant par COL_ART
23 | Type de contrôle de saisie N Pas de contrôle Désactivation du contrôle paramétré au niveau de la TSC W Warning (avertissement non bloquant si la zone n'est pas saisie) B Bloquant (saisie obligatoire) I Interdit (on ne doit rien saisir dans ce champ) V Avertissement si valeur modifiée (l'ancienne valeur est restaurée) Valeur par défaut : Contrôle paramétré au niveau du TSC
24 | Inutilisé dans le cadre d'un contrôle de champ TSC en saisie simplifiée d'article
25 | Valeur zéro significative - uniquement pour les valeurs numériques O Oui. Le zéro est significatif. N Non. Le zéro n'est pas significatif (considéré comme valeur nulle) (par défaut).


Saisie des tiers

O Avec regroupement BL

N Sans regroupement BL

1 Sans regroupement commande, Sans regroupement BL

2 Avec regroupement commande, Sans regroupement BL

3 Sans regroupement commande, Avec regroupement BL

4 Avec regroupement commande, Avec regroupement BL

5 Réf. regroupement facture, entête de commande

6 Réf. regroupement commande, entête de commande

Saisie des tiers cli

Options Valeur alpha 2 Valeur alpha 3 Notes du paramètre de lancement Paramètres associés Code Tiers par défaut Contrôle de la qualité tiers

Nouvelle fonction de saisie des domiciliations bancaires 1 et 2.

Voir aussi cl_param.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code client

Exemple : -N[ec_cli]

Options triées

ap

Contrôle du code APE

Voir aussi les paramètres GAP et DAP.

Si cette option est activée, le programme contrôle si le code APE existe dans la table ape.

Le F7 de recherche du code APE est autorisé même si cette option n'est pas activée.

Le libellé du code APE est affiché en bas de l'écran si cette option est activée.

as

En création d'adresse secondaire, par (F9), on met des blancs. (par défaut : on propose l'adresse principale du client.)

ca

Le CA facture est remplacé par le CA commercial sur l'édition statistique

cc

Permet de saisir un même code comptable pour plusieurs clients différents

cl

Les clients sont interdits

cn

Affichage et numérotation du code comptable en fonction du code adresse validité

co

Force l'édition des correspondants sur l'édition abrégée et les étiquettes

cs

Activation du mode consultation uniquement

Cette option active également le mode consultation des adresses secondaires

ds

Désactivation des contrôles liés au site de production rattaché à l'utilisateur courant

Par défaut, si l'utilisateur est lié à un site de production, la saisie ne peut se faire que sur des clients liés au même site de production.

Tableau de bord du multisite

en

Edition non condensée

es

Edition seulement (pas de modification possible)

f2

Ouverture de la 2ème fenêtre pour sélection de critères en interrogation et édition

fo

Les fournisseurs sont interdits

gc

Géocodage du tiers

ib

Message d'avertissement non bloquant si le code IBAN n'est pas correct

ic

Désactive la génération automatique du code comptable

id

Entrée dans la saisie d'un tiers par le numéro de TVA intracommunautaire appelé ID

mc

Mise à jour du code échéance, du mode de règlement et du titre et nom du correspondant des commandes clients - Spécifique

mi

Interdiction de modifier le code comptable si celui-ci est géré automatiquement lors de la création

na

Numérotation automatique des clients (F12) (Compteur : type = N, aamm = 9999 et cpt = 9999NNNN)

nc

Edition du nom du correspondant principal sur les étiquettes

nl

Ouverture automatique de la fenêtre de saisie de nom long de client

pa

Zone cl_param en modification via touche de fonction

Sur option, tous les champs du cl_param de la fiche tiers sont en consultation.

Via une touche (Ctrl+MAj+P), on accède en modification à toutes les zones du cl_param comme à l'ancienne méthode.

pf

Contrôle que le code de validité adresse de l'adresse principale est bien une adresse de facturation.

Ce contrôle est effectué en fonction de alpha1[4] du code de validité adresse

O (c'est une adresse de facturation) Accepté

W (ce n'est pas une adresse de facturation) Accepté après warning

B (ce n'est pas une adresse de facturation) Refusé

ATTENTION Le code de validité adresse à blanc est accepté

po

Edition abrégée avec présentation précédente (Client, nom, adresse complète, correspondant)

pr

Les prospects sont interdits

rc

Concatène le code client avec le radical comptable

rn

Pas de contrôle de saisie du RIB

r2

Représentant mis à jour automatiquement sur cli2

Si on modifie le code représentant d'un client, on peut répercuter la modification sur ses adresses secondaires.

- Soit sur toutes les adresses secondaires,

- soit sur les adresses secondaires ayant déjà un code représentant,

- soit sur les adresses ayant comme code représentant celui modifié depuis la fiche client principale…

… selon la réponse de l'utilisateur

sn

Contrôle que le code de validité adresse des adresses secondaires n' est pas une adresse de facturation. ce contrôle est effectué en fonction de alpha1[4] du code de validité adresse

O (c'est une adresse de facturation) Refusé

W (ce n'est pas une adresse de facturation) Refusé sans warning

B (ce n'est pas une adresse de facturation) Accepté

sr

Pas d'ouverture automatique de la saisie du RIB

tc

Supprime l'édition du titre du (des) correspondant(s) sur les étiquettes

te

Imprime le nom de la société sur les étiquettes, sinon, imprime 2 lignes blanches

uc

Unicité client commun au groupe - Voir la note _SUP_REQ_CL_CLIGR2

vc

Permet d'avoir accès à la fonction F16 de visualisation des commandes. Voir alpha2[12,17]

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique
Caractères 6 à 11 | Type et code de paramètre de la configuration de saisie des tarifs
Caractères 12 à 17 | Type et code du paramètre de lancement de la visu de commande Option -Ovc nécessaire
Caractères 18 à 23 | Type et code du paramètre de configuration de saisie des remises en tableau.
Caractères 24 à 29 | Type et code du paramètre de lancement de la visualisation des tiers

Valeur alpha 3

Caractère 1 | Activation de la recopie inter société des clients (O/N, N par défaut)
Caractères 2 à 4 | Site de production pris par défaut pour le risque client Tableau de bord du multisite

Valeur alpha 4

Caractères 1 à 10 | Libellé affiché sur la fiche client pour la zone cl_zpar
Caractères 11 à 13 | Type des paramètres saisissables dans la zone cl_zpar

Notes

Notes pour la recopie inter société des clients

AVEC_CONFIRMATION | 21 Affichage des messages de confirmation (O/N, O par défaut)
PREFIXE_CODE_CIBLE | 21 Préfixe à insérer avant le code client
SRECOP | 21 à 60 Complément de select
COP_IS_CLI2 | 21 Recopie des adresses secondaires (O/N, O par défaut)
COP_IS_CLI3 | 21 Recopie des notes sur cli3 (O/N, O par défaut)
COP_IS_LIB_ETR | 21 O/N Recopie des libellés étrangers (O/N, O par défaut)
COP_IS_INFO_C | 21 Recopie des infos complémentaires (O/N, O par défaut)
COP_IS_CONS_DAT_CR | 21 Conserver la date de création du client source (O/N, N par défaut)
COP_IS_PREFIX_EXIST | 21 Si le client est déjà préfixé, on ne rajoute pas le préfixe (O/N, O par défaut)
COP_IS_PREFIX_6CAR | 21 Comportement lorsqu'un préfixe est paramétré et que le code source fait déjà 6 caractères O Recopie sans préfixe (par défaut) N Pas de recopie

Autres notes, triées

#CC

Contrôle des champs dans la fiche tiers

AFF_EVENEMENT_

Cette note est prioritaire sur celle du #CF EVT.

CODE_TIERS_DEFAUT

Paramétrage du code client par défaut

21,26 Code de la fiche client par défaut pour cette saisie

31,36 Code de la fiche fournisseur par défaut pour cette saisie

41,46 Code de la fiche prospect par défaut pour cette saisie.

Si le code paramétré n'existe pas, ou si il n'est pas paramétré, on conserve le mécanisme actuel:

client par défaut 00000C

fournisseur par défaut 00000F

prospect par défaut 00000P

si ces derniers n'existent pas, tiers par défaut 000000

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

FENETRE_AUTO_CLIENT

21,23 Type de notes à afficher juste après la saisie du code client, en saisie de commande.

FORCAGE_CPT_CODEF

21 Remplacement de la zone de cl_cpt par le contenu de la zone cl_codef (O/N)

à utiliser conjointement avec la note ci-dessous FORCAGE_VAL_ZONE_cl

FORCAGE_VAL_ZONE_cl

FORCAGE_VAL_ZONE_c2

Lors de la recopie inter société de client, forcer certaines zones avec des valeurs

21,38 Nom de la zone à modifier

Note FORCAGE_VAL_ZONE_cl : table cli

Note FORCAGE_VAL_ZONE_c2 : table cli2

Exemples : cl_codp, cl_param pour forcer toute la zone, cl_param[12] pour forcer le car.12

39,60 Valeur de la zone (peut-être vide pour effacer le contenu de la zone)

Voir ci-dessus la note FORCAGE_CPT_CODEF

Existe aussi pour la recopie inter société de produits.

LANCEMENT_DEMON_CRM

21,26 Type et code du paramètre de lancement du programme demon_crm

Attention : il faut activer Oup (un seul passage) dans demon_crm

LANCEMENT_V_CDE_TAR0

21,26 Type et code du paramètre de lancement de la visu des commandes

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

MASQUE_REGRP_CDE_BL

21,60 Modes de regroupement commande/BL à masquer dans la fiche client

Chaque caractère saisi correspond au code du mode de regroupement qui sera masqué dans l'onglet Facturation de la fiche Client. Mémo

Exemple

MASQUE_REGRP_CDE_BL ON3

Dans cet exemple, on masquera les modes O, N et 3 (voir mémo ci-dessus)

Si cette note n'est pas trouvée dans le paramètre de lancement, elle sera recherchée sur le #CF ATL.

Cette note peut-être utilisée dans tous les programmes utilisant l'écran G_cli.

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions

Paramétrage équivalent au –C

Exemple

3CLI2QA

Voir #CF EVT.

NOTES_GROUPEES

Saisie simplifiée des notes

RACINE_XXX

où XXX = CLI pour les clients, PRO pour les prospects, FOU pour les fournisseurs

Définition des racines autorisées pour la numérotation automatique

12 à 60 Liste des racines possibles séparées par un espace

Exemple : RACINE_FOU F G H :

La numérotation fournisseur commencera par F, G, ou H.

Le F sera la racine par défaut car il apparaît en première position.

Ces notes sont lues en priorité dans le paramètre de lancement du programme cli.

A défaut, elles sont lues dans #CF ATL.

SUP_E_LIB_ETR

21,60 Supplément de requête dans l'édition de la fiche client sur lib_etr.

_SUP_REQ_CDE1

Supplément de requête sur la table des entêtes des commandes clients - Spécifique

EX : and ec_num matches "04*"

_SUP_REQ_CL_CLIGR2

21,60 Complément de requête sur la table cli concernant le code client commun au groupe

Voir l'option Ouc

_SUP_REQ_GEOCODAGE

21,60 Complément de requête sur table cli pour géocodage

Ce supplément de requête peut servir à éviter de géocoder des adresses inutilement.

_SUP_REQ_GEOCODAGE2

21,60 Complément de requête sur table cli2 pour géocodage

_SUP_SQL_LIBETR_MAT

21,60 Complément de sélection sur la table des articles

Cette note est prioritaire sur celle de #CF/CLI.

Exemple

and mp_qualite not in ("DEV", "INA")

TARIF_TRANCHES_HT

Permet la saisie des montants de port par tranches de HT depuis la fiche tiers par la touche F25

La saisie des tranches doit être faite impérativement avec les dates de début et de fin et le code devise

La zone 17 des données diverses du client indique le type de tranche : H pour les tranches de HT

Nécessite paramètre TAR #FG

21 à 26 Type et code du paramètre de configuration de la saisie des tarifs pour les montants de port par tranches de HT.

TARIF_TRANCHES_POIDS

Permet la saisie des montants de port par tranches de poids depuis la fiche tiers par la touche F25.

La saisie des tranches doit être faite impérativement avec les dates de début et de fin et le code devise.

La zone 17 des données diverses du client indique le type de tranche : P pour les tranches de poids

Nécessite paramètre TAR #FP

21,26 Type et code du paramètre de configuration de la saisie des tarifs pour les montants de port par tranches de poids.

VOLUEDIT_TIERS

21,26 Type et code du paramètre de lancement de l'édition VoluEdit

Paramètres associés

#CF SFA | Paramétrage assurance crédit. Caractère 8 de la fiche société
#CF VAL | Paramétrage visualisation écritures du compte client. Caractère 22 de la fiche société
#CF CLI | Configuration gestion des clients Utilisée pour Client - prospect - fournisseur, Client - prospect, Client - fournisseur, Client
#CF FOU | Configuration gestion des fournisseurs Utilisée pour Prospect - fournisseur, Fournisseur
#CF PRO | Configuration gestion des prospects Utilisée pour Prospect
#CF STC | Statistiques clients

Codes Tiers par défaut

000000 | Tiers en général par défaut
00000C | Client par défaut
00000P | Prospect par défaut
00000F | Fournisseur par défaut

Contrôle de la qualité tiers

Les notes de type #QT sur les tiers peuvent faire suite aux notes commençant par N- du paramètre QT.

Caractères 1 à 60

Message affiché indiquant pourquoi il est impossible de saisir des devis, des commandes, des BL, etc.

Nouvelle fonction de saisie des domiciliations bancaires 1 et 2.

La domiciliation bancaire 1 du 1er écran de la fiche client est sur 20 caractères seulement.

Pour saisir les 32 caractères de cette zone ainsi que la domiciliation bancaire 2 (30 caractères), il faut appuyer sur la touche F7 sur le champ Domicil. banc. 1.

Permission de saisie et de modification sur le champ cl_rib (Relevé d'identité bancaire)

Action ACC - CL_RIB

Action MOD - CL_RIB

Permission de saisie et de modification sur le champ cl_domb1 (Domiciliation bancaire 1)

Action ACC - CL_DOMB1

Action MOD - CL_DOMB1

Permission de saisie et de modification sur le champ cl_domb (Domiciliation bancaire 2)

Action ACC - CL_DOMB

Action MOD - CL_DOMB

Permission de saisie et de modification sur le champ cl_edit (Code édition des traites)

Action ACC - CL_EDIT

Action MOD - CL_EDIT

Permission de saisie et de modification sur le champ cl_trac (Code gestion des traites acceptées)

Action ACC - CL_TRAC

Action MOD - CL_TRAC

Modification de base de données : table cli

La colonne cl_domb1 passe de char(20) à char(32).

La colonne cl_domb passe de char(20) à char(30).


v_cli Visualisation des tiers

La liste est triée par ordre alphabétique.

(1) Les syntaxes d'origine des 2 tables sont utilisables pour les champs dont le nom varie d'une table à l'autre.

Par exemple, client_id_societe et client_id_etablissem ramèneront les mêmes valeurs,

de même que libc_client_dev et libc_client_devise.

cl_adr1 c2_adr1

cl_adr2 c2_adr2

cl_adr3 c2_adr3

cl_annul c2_annul

cl_code c2_code

cl_code_bic c2_code_bic

cl_code_domb1 c2_code_domb1

cl_codp c2_codp

cl_corres c2_corres

cl_corres_civilite c2_corres_civilite

cl_cpt c2_cpt

cl_dev c2_devise (1)

cl_domb1 c2_domb1

cl_domb2 c2_domb2

cl_ech c2_ech

cl_email c2_email

cl_exp c2_exp

cl_geo c2_geo

cl_iban c2_iban

cl_id_societe c2_id_etablissem (1)

cl_incoterm c2_tport (1)

cl_insee c2_insee

cl_langue c2_langue

cl_latitude c2_latitude

cl_longitude c2_longitude

cl_mrg c2_mrg

cl_nom c2_nom

cl_pays c2_pays

cl_port_dest c2_port_dest

cl_qual c2_qual

cl_qualif_appel c2_qualif_appel

cl_reml c2_reml

cl_repr c2_repr

cl_rib c2_rib

cl_siret c2_siret

cl_soc c2_soc

cl_telcop c2_telcop

cl_telex c2_telex

cl_telph1 c2_telph1

cl_telph2 c2_telph2

cl_titre c2_titre

cl_tolerance_liv c2_tolerance_liv

cl_tournee_liv c2_tournee_liv

cl_transitaire c2_transitaire

cl_transp c2_transp

cl_trsp c2_trsp

cl_tx_commission c2_tx_commision

cl_validite_adr c2_validite_adr

cl_vil c2_vil

cl_zpar_adresse c2_zpar_adresse

cl_zparnum c2_zparnum

ainsi que leurs dérivés (libc, libl, etc.)

v_cli Visualisation des tiers

Options

Oca | Suppression des blancs à la fin des zones lors de l'extraction dans un fichier Voir le descriptif du fichier généré
Ocl | Code langue égal par défaut au code langue du client saisi
Oli | Libellé 1 dans la saisie des libellés étrangers égal au libellé de l'article
Opv | Remplacement des points-virgules des zones par des blancs lors de l'extraction dans un fichier Voir le descriptif du fichier généré
-Ovv | Visualisation vide La présence de cette option indique que l'on veut accéder à l'écran de visualisation des articles même si la recherche ne retourne aucun enregistrement.

Valeur alpha 2

Paramétrage des options

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 8 | Lancement de la visualisation sans écran de sélection (O/N, N par défaut)
Caractère 10 | Mode de visualisation E Edition (lancement du programme en batch) F Fichier (lancement du programme en batch) V Mode écran (est disponible ici) X Mode Excel (est disponible ici)
Caractères 15 à 17 | Longueur maximale d'une ligne d'édition (ex : 80). Au-delà de cette longueur, la ligne sera découpée.
Caractères 31 à 33 | Type du paramètre de configuration de saisie des remises en tableau. Exemple #CF
Caractères 34 à 36 | Code du paramètre de configuration de saisie des remises en tableau. Exemple REM, RE1, RE2, etc.

Valeur alpha 4

Caractère 5 | Autoriser le rafraîchissement de l'écran de visualisation (O/N, N par défaut)
Caractère 8 | Accès au détail du tiers O Accès en consultation au détail du tiers M Accès en modification à la fiche tiers N Pas d'accès au détail du tiers Voir les notes PARAM_ACCES_CLIENT, PARAM_ACCES_PROSPECT, PARAM_ACCES_FOURNIS
Caractère 20 | Accès à la saisie des informations complémentaires (TSC) O Accès en visualisation seule M Accès en modification N Pas d'accès

Notes

CF_MAJ_FLAG_INFO_C | Voir page dédiée
_CSEL | Affichage de la colonne de sélection (colonne de droite) Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement. Voir la note LCT_MULTI_CONFIG ci-dessous.
DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_SAE | 21,60 Complément de sélection sur la table action_evt Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activation du transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
GRW_CONFIG | Active les éditions avec Genero Report Writer 21,23 Code paramètre de type GRW (configuration des éditions) 24,26 Code paramètre de type GRV (configuration des variables additionnelles dans le catalogue)
GRW_MAX_LIGNES | Configuration pour bloquer le nombre de lignes à l'édition 21 Par type de sortie N Toutes les sorties (par défaut) I Sortie sur imprimante directe 22 Pour le type de blocage N Pas de blocage C Sur confirmation (avec messages de confirmation paramétrable, voir ci-dessous la note GRW_LIGNES_MSG_) B Blocage 23,26 Nombres de lignes autorisées Exemple GRW_MAX_LIGNES IB100 Bloque à 100 lignes pour les sorties sur imprimante directe
GRW_LIGNES_MSG_X | Configuration des messages pour le blocage avec confirmation X peut prendre les valeurs 1 à 4 Messages par défaut : Ligne 1 : Attention Ligne 2 : Voulez-vous réellement éditer plus de n lignes ? Ligne 3 : Ligne 4 : 21,60 Texte de la ligne de message Exemple GRW_LIGNES_MSG_1 Attention GRW_LIGNES_MSG_2 Plus de 100 lignes GRW_LIGNES_MSG_3 ??? GRW_LIGNES_MSG_4
GRW_LIGNES_SPECIF | Masquage de lignes lors de l'édition par GRW 21 Masquer les lignes de totalisation (O/N, Non par défaut) 22 Masquer les lignes de séparation (O/N, Non par défaut) 23 Masquer les lignes non remplies (O/N, Non par défaut)
LCT_MULTI_CONFIG | 21,26 Type et code du paramètre de configuration des actions/programmes pour la sélection multiple (#RP) Permet, entre autres, de mettre à jour : - le représentant (voir code action 011 dans la note LCT_MULTI_PARAM_) - le gestionnaire (voir code action 012 dans la note LCT_MULTI_PARAM_)
MAJ_FLAG_INFO_C | Voir page dédiée
PARAM_ACCES_CLIENT | 21 à 26 Type et code du paramètre de lancement de la saisie des clients
PARAM_ACCES_FOURNIS | 21 à 26 Type et code du paramètre de lancement de la saisie des fournisseurs
PARAM_ACCES_PROSPECT | 21 à 26 Type et code du paramètre de lancement de la saisie des prospects Utilisation de la touche F27 pour accéder à VoluGold Nécessite que A4[27] = O pour activer la touche F27
S | 3,60 Critère de sélection sur la table cli2 Exemple and c2_validite_adr = "FAC"
VOLUEDIT_TIERS | Touche F22 : 21 à 26 Type et code du paramètre pour l'édition de la fiche tiers par VoluEdit

Ordres de tri disponibles

1 | n_cod us | CODE TIERS
2 | n_cpf us | CODE C/F/P
3 | n_nom us | NOM DU TIERS
4 | n_rep us | REPRESENTANT / COMMERCIAL
5 | n_cdp us | CODE POSTAL / DEPARTEMENT
6 | n_act us | ACTIVITE
7 | n_cat us | CATEGORIE
8 | n_geo us | SECTEUR GEOGRAPHIQUE
9 | n_par us | ZONE PARAMETREE
10 | n_sui us | CODE DE SUIVI D'AFFAIRE
11 | n_qual | CODE QUALITE DU TIERS
12 | n_cligr | CODE DU CLIENT GROUPE
13 | n_nomabr | NOM ABREGE DU CLIENT

Listes des noms de zones autorisés

C orrespondants

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Toutes les zones du package Tiers

Package Adresses secondaires

Toutes les zones du package client

Ce package un peu particulier permet d'afficher les informations de la table cli ou de la table cli2 dans la même colonne sans distinction de l'origine des données.

Pour chaque ligne de visualisation, ce package affiche les données de la table cli2 si elles sont disponibles, sinon celle de la table cli.

Les variables de ce package commencent par client_ (on remplace le préfixe cl_ ou c2_ par client_).

Exemples

client_vil affichera le contenu de c2_vil ou de cl_vil.

libc_client_ech affichera le libellé court du code c2_ech ou du code cl_ech.

Liste des champs communs aux tables cli et cli2 et leur correspondance

Ne pas utiliser le préfixe client_pour les champs n'ayant pas d'équivalence dans les 2 tables.

+ les zones suivantes :

insee | Code INSEE de la commune (_cl.cl_insee)
lib_insee | Nom de la commune INSEE (insee.in_lib)
date_du_jour | La date du jour du traitement (Today)
using | Voir #VI
cl_nom_abrege |
pays_iso_2 | Code ISO du pays sur 2 caractères
flag_annulation | Tiers annulé : 1, 0 sinon
date_time_std | Date + heure au format YYYY-MM-DD hh:mm:ss
devise_iso | Code ISO du code devise de l'adresse principale (cl_dev) Pour la génération du fichier INFACTO
langue_iso | Code ISO du code langue de l'adresse principale (cl_langue) Pour la génération du fichier INFACTO

Descriptif du fichier généré (INFACTO)

Champs de la fiche client

Action

Identification société

Raison Sociale

ID client dans le système métier

Pays

Forme juridique

Device

Capital social

Numéro R.C.S.

Lieu d'enregistrement

N° de TVA Intra Communautaire

Siège social

Nom de la société 1

Nom de la société 2

Adresse 1

Adresse 2

Adresse 3

Adresse 4

Ville

Code postal

Pays

Autres

Langue

Téléphone

Email contact

Nombre d'exemplaires à imprimer

Paramétrage de v_cli pour génération INFACTO

Options Oca et Opv

Alpha2 = NN

Notes

# -- Sélect particuliers --

# --- Selection --

S and cl_soc="IN"

S and cl_code != "000000"

S and cl_code != "00000C" and cl_code != "00000P"

S and cl_param[11,11] = "O"

S and cl_cpf = "C"

S and cl_annul = "N"

# --- COLONNES FICHIER ---

F Code action*using*1***

F Raison Sociale*cl_nom*30***

F Code Client*cl_code*6***

F Code Pays*pays_iso_2*3***

F Forme Juridique*libl_cl_qual*25***

F Code Devise*devise_iso*3***

F Capital Social*using*1***

F Numéro R.C.S.*using*1***

F Lieu d'enregistrement*using*1***

F Identification TVA*cl_siret*18***

F Nom de la société 1*cl_nom*30***

F Nom de la société 2*using*1***

F Adresse 1*cl_adr1*30***

F Adresse 2*cl_adr2*30***

F Adresse 3*using*1***

F Adresse 4*using*1***

F Ville*cl_vil*25***

F Code Postal*cl_codp*5***

F Code Pays*pays_iso_2*3***

F Code Langue*langue_iso*3***

F Téléphone*cl_telph1*20***

F Email*cl_email*60***

F NB exemplaires*cl_nbfac*3*<<&**

# -- Séparateur

4 null ;

# -- Fichier par défaut --

N./edi/clients_infacto


Edition des étiquettes tiers

Edition des étiquettes tiers eti_tiers

Options

-Oii | Initialisation de l'imprimante à chaque ligne d'étiquettes
-Oas | Edition des adresses secondaires seulement

Valeur numérique 1

Marge gauche pour les lignes en caractères condensés (1 par défaut)

Valeur numérique 2

Marge gauche pour les lignes en caractères larges (1 par défaut)

Notes

C

Paramétrage des colonnes
3 à 32 Position de chaque colonne d'étiquette par groupe de 3 chiffres
(Exemple 001041081 pour 3 colonnes commençant en positions 1, 41 et 81)

L

-

(début d'une nouvelle ligne)

(rester sur la même ligne)

3 à 20 Champ
51 à 54 Options de format :

'utilisation de certaines fontes, en fonction de l'imprimante utilisée, peut engendrer des décalages au niveau du cadrage. Il est recommandé dans ce cas, d'éditer l'ensemble des lignes dans une même fonte (en particulier pour Large et Condensé).

O

3 à 60 Complément de tri sous la forme [colonne1],[colonne2],…
Attention : les colonnes sélectionnées doivent correspondre à celles de la table cli2 (Adresses secondaires clients)
Exemple : c2_pays, c2_codp, c2_nom

_SUP_REQ_CLI

20,60 Complément de sélection sur la table client (cli)

_SUP_REQ_CLI2

21,60 Complément de sélection sur la table des adresses secondaires (cli2)


Statistiques clients

Statistiques clients stat_cli

Généralités

3 scénarios sont possibles :

  1. Progression

  2. Palmarès

  3. Détail mensuel

Ces 3 scénarios sont paramétrés en alpha2[4,12] et pointent par défaut vers les paramètres #CF SC1, 2, 3

Chaque scénario définit :

  • Le titre 1 et la configuration 1 (sans rupture)

  • Le titre 2 et la configuration 2 (avec rupture paramétrée en alpha2[1,3])

Si les scénarios ne sont pas trouvés, les valeurs suivantes sont prises par défaut :

Scénario 1 (progression) : valeurs par défaut

Titre 1 | Option | Config 1 par défaut | Config 2 par défaut
PROGRESSION DU C.A. COMMERCIAL | -Occ | BADFJHLNabc | BADFJHLN
PROGRESSION DU POIDS COMMANDE | -Opo | Bakmqosuabc | BAkmqosu
PROGRESSION DE LA SURFACE COMMMANDEE | -Osf | Balnrptvabc | BAlnrptv
PROGRESSION DU POIDS FACTURE | -Op2 | BA57(9[<abc | BA57(9[<
PROGRESSION DE LA SURFACE FACTUREE | -Os2 | BA68)0]>abc | BA68)0]>
PROGRESSION DU C.A. |  | BACEIGKMabc | BACEIGKM

Le titre 2 est identique au titre 1 auquel on ajoute PAR suivi du libellé correspondant à la rupture paramétrée en alpha2[1,3].

Exemple : PROGRESSION DU C.A. COMMERCIAL PAR REPRESENTANT (option –Occ positionnée et alpha21[1,3] = REP).

Scénario 2 (palmarès) : valeurs par défaut

Titre 1 | Option | Config 1 par défaut | Config 2 par défaut
PALMARES DU C.A. COMMERCIAL | -Occ | BADPRTabc | BADPRT
PALMARES DU POIDS COMMANDE | -Opo | BAkwyVabc | BakwyV
PALMARES DE LA SURFACE COMMANDEE | -Osf | BAlxzWabc | BalxzW
PALMARES DU POIDS FACTURE | -Op2 | BA5+*.abc | BA5+*.
PALMARES DE LA SURFACE FACTUREE | -Os2 | BA6-/,abc | BA6-/,
PALMARES DU C.A. |  | BACOQSabc | BACOQS

Le titre 2 est identique au titre 1 auquel on ajoute PAR suivi du libellé correspondant à la rupture paramétrée en alpha2[1,3].

Exemple : PALMARES DU C.A. COMMERCIAL PAR REPRESENTANT (option –Occ positionnée et alpha2[1,3] = REP).

Scénario 3 (détail mensuel) : valeurs par défaut

Titre 1 | Option | Config 1 par défaut | Config 2 par défaut
DETAIL MENSUEL DU C.A. COMMERCIAL | -Occ | BAU | BAU
DETAIL MENSUEL DU POIDS COMMANDE | -Opo | BAX | BAX
DETAIL MENSUEL DE LA SURFACE COMMANDEE | -Osf | BAY | BAY
DETAIL MENSUEL DU POIDS FACTURE | -Op2 | BA; | BA;
DETAIL MENSUEL DE LA SURFACE FACTUREE | -Os2 | BA: | BA:
DETAIL MENSUEL DU C.A. |  | BAU | BAU

Le titre 2 est identique au titre 1 auquel on ajoute PAR suivi du libellé correspondant à la rupture paramétrée en alpha2[1,3].

Exemple : DETAIL MENSUEL DU C.A. COMMERCIAL PAR REPRESENTANT (option –Occ positionnée et alpha2[1,3] = REP).

Options

Occ | CA Commercial
Opo | Poids commandé
Osf | Surface commandée
Op2 | Poids facturé
Os2 | Surface facturée
Of2 | Ouverture de la deuxième fenêtre pour la sélection des critères
Oex | Saisie d'un exercice décalé dans le détail mensuel
Opl | On n'édite pas le libellé de la rupture
Ops | Pas de saut de page à la rupture
Out | On édite uniquement le total de la rupture
Ocf | Force les cumuls dans état autre que le 2ème
Oep | Edition des prospects autorisée
Oef | Edition des fournisseurs uniquement
Opz | Si prévision sur mois à zéro, on ne va pas prendre la prévision sur l'enregistrement prévision annuelle.
Ol0 | L'édition des lignes à 0 n'est conditionnée que par le CA de l'année en cours.
Ocd | Edition des CA par rapport au CA commandé
Omm | Affiche les montants en milliard
OU3 | Dans l'édition du détail mensuel des statistiques client, mettre sous la colonne U (détail mensuel), le détail de l'année N - 1 Ne fonctionne que pour le détail mensuel Attention : cette option s'écrit tout en majuscules.

Valeur numérique 1

Longueur de l'exercice pour la colonne Prévision mois (par défaut 12)

Valeur alpha 2

Caractères 1 à 3 | Type de rupture. Les types suivants sont possibles : GEO Secteur géographique CAT Catégorie client ACT Secteur activité ORG Origine contact REP Représentant (valeur par défaut) TOU Code tournée PAR Type paramétré en alpha1[31,33] et libellé en alpha1[16,30] de #CF CLI PA2 Type paramétré en alpha3[16,18] et libellé en alpha3[1,15] de #CF CLI PA3 Type paramétré en alpha3[34,36] et libellé en alpha3[19,33] de #CF CLI
Caractères 4 à 6 | Scénario 1 - Par défaut, SC1
Caractères 7 à 9 | Scénario 2 - Par défaut, SC2
Caractères 10 à 12 | Scénario 3 - Par défaut, SC3

Notes

S

2,60 Complément de requête sur la table cli
Conseil : mettez au minimum le complément suivant : S and cl_code != "#SOC"
Voir aussi so_options(10)

Paramètres associés

#CF CLI

alpha1[1,15] Libellé de la zone paramétrable cl_domb2 du fichier cli (affiché à l'écran)
alpha3[37,51] Libellé de la zone numérique paramétrée 4 (affiché à l'écran)
alpha4[1,10] Libellé de la zone paramétrée adresse (affiché à l'écran)
alpha4[11,13] Type du paramètre de la zone paramétrée adresse (inutilisé)


Utilitaire de recalcul des statistiques clients

Utilitaire de recalcul des statistiques clients st_clin

A lancer si un problème a empêché le calcul des statistiques clients.

Les statistiques ainsi recalculées sont visibles par le F11 sur la fiche client.

Options triées

Oec | Les escomptes d'entête de commande sont pris en compte pour le calcul du CA commandé
Of2 | Ouverture automatique de la seconde fenêtre de recherche lors de la saisie du critère de recherche client
Ofa | Recherche le poids et la surface unitaire sur la fiche article
Ofl | Force la recherche du poids et de la surface unitaire sur la ligne de commande quelque soit le paramétrage de l'article
Orc | Les remises lignes et entête des commandes sont prises en compte pour le calcul du CA commandé

Valeur alpha 2

Caractères 1 à 6 | Type et code du paramètre de lancement du programme d'édition des statistiques client stat_cli.4ge
Caractères 7 à 8 | Mois de début de calcul
Caractères 9 à 12 | Année de début de calcul
Caractères 13 à 14 | Mois de fin de calcul
Caractères 15 à 18 | Année de fin de calcul

Valeur alpha 3

Caractères 1 à 30

Nom du fichier trace à générer (avec chemin complet)

Notes

S

2,60 Complément de requête

Paramètres nécessaires

UNI

Valeur numérique 1


Statistiques fournisseurs

Statistiques fournisseurs stat_fou

Options

Ola | Prise en compte des dimensions de la ligne d'achat pour le calcul de la conversion de quantité
Omc | Traitement sur le mois (et année) en cours
Ore | On tient compte des remises dans le calcul du CA
Orf | On tient compte des remises sur facture dans le calcul du CA
Osd | Sélection des commandes d'achat à recalculer via la date de commande et non le numéro ATTENTION : Cette option est incompatible avec le paramétrage d'un folioteur paramétré en A2[1].
-B | Mode batch
-Z | 3,5 Type du paramètre de lancement (du présent programme) 6,8 Code du paramètre de lancement (du présent programme)

Valeur alpha 2

Caractère 1 | Folioteur (blanc par défaut)
Caractère 2 | Choix du traitement C sur les commandes F sur les factures


Importation des tiers à partir d'un fichier texte

Importation des tiers à partir d'un fichier texte imp_tiers

Ce programme permet, lors d'une installation d'un nouveau client par exemple, de récupérer la table tiers de son ancien système, par le biais de la génération d'un fichier texte avec séparateurs.

Remarques

  • Certaines zones doivent obligatoirement apparaître dans le fichier à importer et être non nulles
    (cl_soc, cl_code, cl_cpf, cl_nom).

  • Le nombre de champs paramétrés doit être le même que le nombre de champs dans le fichier à importer.

  • Attention à ne pas intégrer des codes contenant des minuscules ou autres caractères pouvant poser problème lors d'une sélection (", :, *, <, > etc.)

  • Si la zone du fichier à importer est plus longue que la zone correspondante de la table cli, elle sera tronquée à l'importation.

  • Un rapport de traitement est écrit avec les enregistrements traités et les éventuelles anomalies pour les enregistrements non intégrés.

Valeur alpha 2

Caractère 1 | Suppression préalable du tiers avant importation O Suppression de l'ancien tiers N Mise à jour de l'ancien tiers (conserve les champs non importés) X Si le tiers existe déjà, aucune modification n'est effectuée (création uniquement).
Caractère 2 | Séparateur de champ - facultatif S'il n'est pas renseigné les champs paramétrés doivent être marqués par une position de début et de fin dans le fichier.
Caractère 3 | 1 contrôle unicité sur code SIRET Par défaut : à blanc Doit être paramétré dans une note commençant par C (voir ci-dessous) ayant obligatoirement la structure suivante : CnnOcl_siret où nn représente le numéro de zone dans le fichier à intégrer.
Caractères 4 à 9 | Tiers de référence pour les valeurs par défaut (exemple 00000F)
Caractère 10 | Code société à importer obligatoirement dans le fichier (O/N, N par défaut) Si N le code société du tiers sera celui de la société en cours.
Caractère 11 | Code tiers à importer obligatoirement dans le fichier (O/N ; N par défaut) Si N le code tiers sera automatique. Voir paramètre #CF ATL pour la racine, la longueur de la racine let longueur du folio.
Caractère 12 | Code type de tiers à importer dans le fichier (O/C/P/F, O par défaut) O le type de tiers est obligatoire C le type de tiers sera toujours un Client P le type de tiers sera toujours un Prospect F le type de tiers sera toujours un Fournisseur
Caractère 13 | Tiers à créer (O/N, O par défaut) O Le tiers sera créé s'il n'existe pas. N Le tiers ne sera pas créé s'il n'existe pas.
Caractère 14 | Tiers à annuler par le code qualité (O/N, n par défaut) O Le tiers sera annulé par le code qualité et non pas par le champ annulation. N Le tiers sera annulé le champ annulation.
Caractères 15 à 17 | Code qualité tiers si annulation par code qualité
Caractère 18 | Vérification du code usine O Le code usine est testé avec les caractères 4 à 10 des lignes de données. N Pas de contrôle du code usine
Caractère 19 | Concaténation des champs adresse O Les champs cl_adr1, cl_adr2 et cl_adr2 sont concaténés à partir de plusieurs zones du fichier. Dans le paramétrage, n'indiquer que le champ cl_adr1, le programme remplira automatiquement les 3 champs adresses cl_adr1, cl_adr2 et cl_adr3. N Pas de concaténation Exemples C05Ocl_adr1 02160245 C06Ncl_adr1 02460275 C07Ncl_adr1 02760305
Caractère 20 | Importation du nom du tiers obligatoire (O/N, O par défaut)
Caractère 21 | Contrôle du code IBAN (O/N, N par défaut)

Valeur alpha 3

Caractères 1 à 60

Nom du fichier à intégrer (avec chemin).

Notes

C | Champ importé 2,3 Clé du champ (C01, C02 …). Les numéros doivent obligatoirement se suivre. 4 Champ obligatoire (O/N, N par défaut) 5,22 Nom du champ. Tous les champs de la table cli. TSC_CL_XXX_N (pour importer les champs qui n'existent pas dans la table cli) où XXX représente le code TSC et N représente la zone. Le TSC doit exister dans la base avant de commencer l'import. cl_param_XX où XX correspond à l'indice du caractère du champ cl_param. 23,26 Position de départ s'il n'y a pas de séparateur. 27,30 Position de fin s'il n'y a pas de séparateur. 31 Correspondance avec un paramètre (O/N, N par défaut) Non applicable pour le champ cl_param_XX 32,34 Type de paramètre (exemple FAM) Non applicable pour le champ cl_param_XX
RACINE | 8,10 Type de racine CLI Racine Client PRO Racine Prospect FOU Racine Fournisseur 21,25 Racine (exemple F pour fournisseur). Voir la longueur de la racine et du folio dans # #CF ATL
S | 2,60 Supplément de requête au fichier cli
_SUP_REQ_TEMP | 21,60 Complément de requête sur la table temporaire Exemple _SUP_REQ_TEMP where temp_ligne.donnees[1,7]="MACONTR"

Exemple de notes

RACINE_FOU F

C01Ocl_cpt 00070016

C02Ocl_qualite 00170018O#QA

C03Ocl_nom_abrege 00190033

C04Ocl_nom 00390068

C05Ocl_adr1 01990228

C06Ncl_adr2 02590288

C07Ncl_adr3 02990328

C08Ocl_codp 03990406

C09Ocl_vil 04090433

C10Ncl_pays 04490451OPAY

C11Ncl_langue 04550455OLAN

C12Ocl_telph1 04560475

C13Ocl_telcop 04960515

C14Ocl_siret 05360553

C15Ocl_geo 05560561OGEO

C16OTSC_CL_SAL_F 05620564

C17OTSC_CL_SAL_G 05650568

C18Ocl_dev 05690573

C19Ocl_trsp 05760577OTRS

C20Ocl_incoterm 05980601OPOR

C21Ocl_port_dest 06020621

C22Ocl_mrg 06300633OMRG

C23Ocl_annul 06680668

Autres paramètres

PAY | Note CORRES_IMPORT_TIERS
#CF TRA | Mettre en place la traçabilité sur la table cli - A2[46,50]


Export des tiers vers Side Trade

Export des tiers vers Side Trade tr_client_side_trade

Génération de 4 fichiers de données pour qu'ils soient traités par SIDE TRADE

Génération fichier trace + anomalie

Chaque fichier de données est écrasé à chaque utilisation du programme (le fichier précédent est historisé et aura pour extension .01, etc…)

Tous les fichiers fonctionnent en mode historisé (20 fichiers max.)

Notes

FICHIER_TR_CLIENT | 21 60 Emplacement + nom fichier export clients
FICHIER_TR_ADRESSES | 21 60 Emplacement + nom fichier export adresses
FICHIER_TR_UTIL | 21 60 Emplacement + nom fichier export utilisateurs
FICHIER_TR_CONTACTS | 21 60 Emplacement + nom fichier export contacts
FICHIER_ERREUR | 21 60 Emplacement + nom fichier d'anomalies
FICHIER_TRACE | 21 60 Emplacement + nom fichier trace événements
FICHIER_LOCK_ST | 21 60 Emplacement + nom fichier de lock SIDE TRADE
FICHIER_LOCK_VS | 21 60 Emplacement + nom fichier de lock VOLUME
FICHIER_LOCK | 21 60 Emplacement + nom fichier de lock garantissant l'exécution d'un programme à la fois
_SUP_REQ_CLI | 21 60 Complément de requête sur cli
_SUP_REQ_CLI2 | 21 60 Complément de requête sur cli2
_ORDER_BY_CLI | 21 60 Ordre de tri sur la sélection
CONST_STN_CLI | 21 30 Constante STN du fichier client
CONST_STN_ADR | 21 30 Constante STN du fichier adresses
CONST_STN_UTC | 21 30 Constante STN du fichier utilisateur
CONST_STN_CTC | 21 30 Constante STN du fichier contacts

Paramètres nécessaires

DEV A1[1,3] | Code ISO de la devise pour interface SIDE TRADE
PAY A1[16,18] | Code ISO du pays pour interface SIDE TRADE
LAN A1[2,4] | Code ISO de la langue pour interface SIDE TRADE
REP A3[1,15] | Code secteur commercial pour interface SIDE TRADE
FAB A4[1,15] | Code assistante commerciale pour interface SIDE TRADE
.PO A1[2,16] | Code potentiel client pour interface SIDE TRADE
QT A3[1,15] | Code qualité tiers pour interface SIDE TRADE
CAT A1[4,18] | Code catégorie du tiers pour interface SIDE TRADE
TCO A1[1,30] | Code fonction du contact pour interface SIDE TRADE
ECH A4[1,3] ECH A4[4,5] | Délai de paiement pour interface SIDE TRADE Fin de mois pour interface SIDE TRADE
CIV A1[1,3] | Code civilité pour interface SIDE TRADE
VAS A1[9,9] | Type d'adresse pour interface SIDE TRADE
MRG A1[22,24] | Code moyen de règlement pour interface SIDE TRADE


Outil de contrôle identifiant TVA client

Outil de contrôle identifiant TVA client outil_verif_client_tva

Ce programme est permet d'éditer une liste des clients dont le code identifiant TVA est incorrect.

Notes

_SUP_REQ_CLI | 21, 60 Complément de requête sur la table cli
_SUP_REQ_CLI2 | 2,1 60 Complément de requête sur la table cli2
NOM_FIC_TRACE | 21, 60 Nom du fichier trace contenant la liste


Outil de vérification des liens articles / emplacements

Outil de vérification des liens articles / emplacements outil_liens_article_emplacement

Voir la fiche d'installation

Notes

CODE_FAMILLE | 21,23 Code famille d'outil à prendre en compte (un code famille par ligne) Par défaut : OUT
CODE_VALIDITE | 21,23 Code validité d'outil à prendre en compte (un code validité par ligne) Par défaut : REE
FIC_ANOMALIE | 21,60 Chemin de sortie pour le fichier des anomalies rencontrées
FIC_TRACE | 21,60 Chemin de sortie pour le fichier de trace des traitements effectués
_SUP_SQL_MAT | 21,60 Complément de sélection pour la recherche des outils à vérifier

Paramètres nécessaires

#CF OUT A1[4,6] | Code de liens entre tables pour la saisie des emplacements rattachés à l'outil. Outil > Emplacement
#CF OUT | Note _SUP_REQ_OUTIL
#LI A1[1,3] | Code lien réciproque Emplacement > Outil

Liste des anomalies vérifiées et des traitements effectués

Liste des anomalies possibles

Contrôle du lieu de rangement

Lieu de rangement non saisi.

Le lieu de rangement n'est pas saisi sur l'outil

Lieu de rangement de niveau 1 inexistant.

Le lieu de rangement de niveau 1 saisi sur l'outil n'existe pas (voir les paramètres de type RG1)

Lieu de rangement lieu 1/lieu2/lieu 3 inexistant.

Le lieu de rangement de niveau 1/2/3 saisi sur l'outil n'existe pas (voir le programme de saisie des lieux de rangements : lieu_rgt.4ge)

Contrôle de la possibilité de stocker l'outil :

Ce lieu est mono-référence et n'est pas disponible pour cet outil.

Lieu de rangement mono-référence déjà utilisé par un autre outil (X)

Le lieu de rangement saisi sur l'outil est déclaré comme étant mono-référence et est déjà utilisé par un autre outil.

Lieu de rangement mono-référence utilisé par N outils.

Le lieu de rangement saisi sur l'outil est déclaré comme étant mono-référence mais est utilisé actuellement sur N outils différents.

Le lieu de rangement a atteint sa capacité maximum et ne peut pas être utilisé.

Le lieu de rangement multi-références saisi sur l'outil a atteint sa capacité maximum et est déjà utilisé par d'autres outils (il n'est donc pas utilisable avec l'outil courant).

Le lieu de rangement a dépassé sa capacité maximum (N).

Le lieu de rangement multi-références saisi sur l'outil a dépassé sa capacité maximum.

Liste des traitements possibles (trace)

Zone multi-lieux non saisie, mise à N par défaut (article mono-emplacement).

La zone multi-lieux (mat.mp_multi_lieux) n'est pas saisie sur l'outil, on la met dans ce cas à la valeur par défaut « N » (outil mono-emplacement).

Lieu de rangement mono-référence associé à l'outil.

Le lieu de rangement saisi sur l'outil est déclaré comme étant mono-référence mais n'est pas associé à l'outil l'utilisant (zone lieu_rgt_e.lre_art_mono_ref non renseigné), on met à jour la zone dans la table des lieux de rangement si le lieu de rangement n'est pas déjà utilisé par un autre outil.

Création du lien outil/emplacement.

Aucune anomalie rencontrée : l'outil est déclaré comme étant multi-emplacements mais le lien entre les tables outil (mat) et lieu de rangement (lieu_rgt_e) n'existe pas, on créé donc le lien entre l'outil et le lieu de rangement saisi sur l'outil. On met ensuite à jour les informations sur le lieu de rangement (voir message ci-dessous)

Mise à jour des informations sur le lieu de rangement.

Aucune anomalie rencontrée : on recalcule le nombre d'utilisation du lieu de rangement et on met à jour les informations de ce dernier (recalcul de la quantité, mise à jour éventuelle de la disponibilité du lieu de rangement).


Mise à jour des données diverses des articles

Mise à jour des données diverses des articles update_param

Cet outil permet de mettre à jour les données diverses des articles.

Pour mettre à jour vos données diverses, vous devrez :

sélectionner l'article ou le type d'article concerné,

indiquer l'indice de la donnée concernée,

renseigner la nouvelle valeur de l'indice.

Options

Of2

Ouverture de la fenêtre


Saisie des articles

Fonctionnalités

1/ Permettre, lors de la validation d'un article en saisie simplifiée, de créer automatiquement un paramètre de type .PP (protection palette) correspondant aux informations saisies.

2/ Permettre, suite à la création du paramètre de protection palette, de créer automatiquement le tarif calculé à partir des informations saisies sur l'article.

Remarques

" Le code du paramètre .PP est construit avec les 3 derniers caractères du code article.

" Le code article est enregistré en A1[1,15] du paramètre créé.

" Le libellé court du paramètre est construit automatiquement avec les éléments suivants :

o F ou C (Fond/Couvercle)

o Longueur (calée à gauche)

o x

o Largeur (calée à gauche)

" Le libellé long du paramètre reprend les 25 premiers caractères de la désignation de l'article (par défaut : libellé court du paramètre).

" Si le paramètre existe mais annulé, il est automatiquement réactivé.

" Le tarif peut être créé automatiquement avec la règle de calcul suivante :

o Valeur du tarif = Tarif (¬/kg) * Grammage (g/m²) * Surface (m²)

" Le paramétrage de configuration de la saisie de tarif est utilisé pour construire les valeurs par défaut (voir aide en ligne : #CF/TA1)

o Borne inférieure par défaut : 0

o Borne supérieure par défaut : 999 999 999

" Les éléments suivants doivent être saisis ou paramétrés pour que le tarif puisse être créé :

o Longueur (mat.mp_lon) et largeur (mat.mp_lar) du produit

o Code fournisseur chez le client (mat.mp_foucli)

o Grammage et tarif par kilo (voir ci-dessous)

o Code paramètre de catégorie de tarif (voir ci-dessous)

MAJ_GACHES_VALEURS 0000000005 000000.003 0000000010

MAJ_GACHES_VALEURS 0000000001 000000.003 0000000060

MAJ_GACHES_VALEURS 0000000001 0000000000

Mettre en place automatiquement les gâches suivantes :

Gâche fixe : 5

Gâche variable : 0.003

Si la valeur du tarif en vigueur est strictement inférieure à 10

Gâche fixe : 1

Gâche variable : 0.003

Si la valeur du tarif en vigueur est supérieure ou égale à 10 et strictement inférieure à 60

Gâche fixe : 1

Gâche variable : 0

Si la valeur du tarif est supérieure ou égale à 60

Exemples

VL01_TABLE info_c

V01_JOINTURE and ic_type = "T"

VL01_JOINTURE and ic_cle matches "%1*"

VL01_JOINTURE and ic_ts = "202"

VL01_MESSAGE l'article %1 est présent dans un triplet

VL01_MESSAGE article phase gamme

VL02_TABLE mat

VL02_JOINTURE and mp_code = "%1"

VL02_JOINTURE and p2_type = "QA"

VL02_JOINTURE and p2_code = mp_qualite

VL02_JOINTURE and p2_alph[1,1] = "N"

VL02_MESSAGE Erreur mat par02

Saisie des articles mat

Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Codes articles par défaut Zone type Mécanique Paramètres associés

Accès à la GED

Recherche de matières par F7 Saisie simplifiée des articles Interrogation simplifiée des articles

Voir aussi l'outil qui permet de mettre à jour les données diverses de l'article.

Voir aussi le programme de contrôle des compteurs en cas d'anomalie.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

à partir du caractère 3 : Code article

Exemple : -N[lc_prod]

-N_DUP

à partir du caractère 7 : Code du code produit à dupliquer. Géré automatiquement par le programme appelant

Le programme appelant peut être v_mat,avec la note RECOPIE_ARTICLE qui indique le type et le code du paramètre de lancement du programme de saisie d'article.

Ce passage d'argument n'entre pas dans le cadre des touches Ctrl J / Ctrl K.

-N_CREAT

Accès direct en création

Le passage de cet argument en paramètre du programme permet d'accéder directement à la saisie des articles en mode création. A la fin de cette saisie (après création ou annulation), on sort du programme (pour revenir à celui appelant, par exemple la visu des articles, avec l'option Ovv).

Options triées

-V

Permet l'appel à v_stk0 ou à v_triplet à la place de f_v_stk0

Indiquer sur 3 caractères le code paramètre de la visualisation des stocks ou des triplets.

De façon implicite, le type sera #VI

O18

Sur le F18, on demande le code article à rechercher

O1f

Création de l'article avec le 1er folioteur si saisie d'un code racine sans aucun folioteur et de l'article avec les 2 folioteurs si saisie d'un code racine incluant le 1er folioteur

L'option Odf doit être activée (Numérotation avec double folioteur).

L'option Odf permet de codifier automatiquement les articles en utilisant une numérotation avec folioteur double.

Si l'option n'est pas activée, seul l'article avec les 2 folioteurs sera créé.

Si l'option est activée, l'article avec le 1er folioteur sera créé si le code racine saisi est sans folioteur et l'article avec les 2 folioteurs sera créé si le code racine saisi inclus le 1er folioteur.

La position de début de la racine devait toujours se trouver en position 1 du code article.

Maintenant, la position de début de la racine peut être paramétrée en A3[33].

Oa1

Numérotation avec folioteur simple (table cpt_a, type A).

(Voir option Odf pour folioteur double)

Par défaut : Racine = 11 caractères, Folioteur = 3 caractères

Si la longueur de la racine n'est pas respectée, elle est complétée avec des zéros

La longueur de la racine est donnée par alpha3[1,2] du paramètre de lancement

La longueur du folioteur est donnée par alpha3[3,4] du paramètre de lancement

La longueur de la racine ne peut pas être à zéro

Si la longueur de la racine est à 99, la racine est considérée comme de longueur variable

Oa2

Ajout d'un caractère paramétrable (alpha3[29]) à la fin du code article après la saisie de celui-ci

Oa5

Affichage du résultat de la formule stockée dans les notes du coefficient de conversion

Oaa

Création de code article en automatique dans la saisie simplifiée

Permettre de créer un code article en manuel malgré cette potion : permission MAT_CCA

voir notes commençant par CODIF_ART.

Oal

Affichage des lieux de rangement

Oav

Actualisation automatique des variantes d'impression à la validation de l'écran Ctrl-G

Voir les notes commençant par LCT_ACTUAL_VAR_IMP.

Ocd

Contrôle de doublon en création d'article sur les zones

Famille, Sous-famille, Longueur, Largeur, Grammage et Couleur.

Ocr

Mise en place d'un code TSC de modification manuelle des pointages

Ce TSC permet, dans la saisie des devis, de demander confirmation avant le recalcul de pointages afin de ne pas écraser les pointages modifiés manuellement.

Voir la note TSC_MODIF_POINTAGES

Voir aussi la note SAISIE_POINTAGES

Ocs

Consultation exclusive du produit

Oct

Contrôle de saisie sur les données techniques en complément de A3[1] de LIB DT1..8 et LIB AT1..2

3 valeurs : B bloquant, W warning, N aucun

Odf

Numérotation avec folioteur double (table cpt_a, type A)

XXXXX-0002/01 racine-folioteur1/folioteur2

La racine représente un code client.

La racine-0002 représente le produit correspondant au client.

La racine-0002/01 représente l'article d'indice 1 du produit.

Avant de créer un indice il faut créer le produit qui sera affecté de l'indice 01

Par défaut : Racine = 5 caractères, Folioteur1 = 4 caractères, Folioteur2 = 2 caractères

Si la longueur de la racine n'est pas respectée, elle est complétée avec des zéros

La longueur de la racine est donnée par alpha3[1,2] du paramètre de lancement

La longueur du folioteur1 est donnée par alpha3[3,4] du paramètre de lancement

La longueur du folioteur2 (indice) est donnée par alpha3[23] du paramètre de lancement

La longueur de la racine ne peut pas être à zéro

Si la longueur de la racine est à 99, la racine est considérée comme de longueur variable

Oee

Edition étiquettes

Oef

Saisie des libellés étrangers avec le code fournisseur

Si cette option n'est pas activée, la saisie des libellés étrangers est faite avec le code client.

Oen

Edition non condensée

Oes

Edition seule. Le paramétrage des colonnes est alors indiqué dans le paramètre de lancement !!!

(et non pas dans le #CF MAT.)

Of1

Le code famille est égal aux caractères 1, 2 ,3 du code produit

Of2

Ouverture de la 2ème fenêtre pour sélection de critères en interrogation et édition

(la 2ème fenêtre est aussi accessible par F8)

Ofi

Le changement de code famille est interdit

Ofm

Le code famille est égal au caractère 2, 3, 4 du code produit

Ofo

Le code famille est obligatoire

Oge

Permet la saisie du GENCOD et de l'ITF14

Ogo

Permet de gérer l'emplacement des outillages dans la saisie simplifiée des articles

L'emplacement est géré via le programme de liens entre les tables.

Ogs

Active la gestion de la fiche matière en fonction du site de production

Tableau de bord du multisite

Ohi

Visualisation de l'historique du produit à la place des commandes par la touche F13

Oim

Paramétrage imprimerie (forme uniquement)

Ola

Affichage du libellé correspondant à l'affectation. Concaténation des 3 zones suivantes

article de niveau 1 de l'affectation

article de niveau 2 de l'affectation

nature d'intervention de l'affectation

Ole

Impression de la référence spécifique client (libellé étranger) quand celle-ci existe, avec la désignation de l'article.

Impression sous la forme référence spécifique désignation

Olf

La longueur du radical en numérotation automatique doit toujours être de longueur fixe

Olo

Saisie obligatoire de la longueur et du poids

Olt

Edition des lignes de totalisation édition abrégée avec paramétrage dans #CF MAT zone alpha2

Omd

Mise à jour de la désignation dans les nomenclatures

Ne fonctionne que pour les articles dont le mp_param[7] = A.

Omf

Conserve les marges fixes dans la mise à jour des tarifs

On1

Mise à jour de la table nom1 pour tous les articles

Mettre à jour le libellé de nomenclature, table nom1, lors de la modification du libellé de la fiche article.

Jusque là, cela n'était fait que pour les articles dits de référence, mp_param[7] = A.

ATTENTION, option Omd obligatoire.

Ono

Le code normalisé est obligatoire

Onr

Non réinitialisation des données précédemment saisies

Permet d'enchaîner des saisies de produits en récupérant les données précédemment saisies, si les zones de l'entête (famille, sous-famille, codes statistiques 1,2,3 et 4) sont identiques.

Voir aussi l'option Ori.

Oo1

Autorise la saisie des matières fournitures fantômes Voir #CF MAM

Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

Oo2

Autorise la saisie des produits et semi-ouvrés Voir #CF MAP

Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

Oo3

Autorise la saisie des outillages Voir #CF MAO

Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

Oo4

Autorise la saisie des pièces de maintenance Voir #CF MAN

Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

Oo5

Autorise la saisie d'un nouveau type de produit. Saisie de qualité matière (mp_mp = Q)

Les options Oo1 à Oo5 sont exclusives. On ne peut en positionner qu'une seule.

Ood

Tri des éditions par ordre de désignation

Opa

Zone mp_param en modification via touche de fonction

Sur option, tous les champs du mp_param de la fiche matière sont en consultation.

Via une touche (Ctrl+MAj+P), on accède en modification à toutes les zones du mp_param comme à l'ancienne méthode.

Opm

Saisie frais et pertes en valeurs et non en %

IMPORTANT : si le paramètre -Opm est indiqué, il faut le mettre aussi en saisie des mouvements des stocks

Opr

Edition du prévu dans les statistiques. (Actuellement il n'est pas saisi)

Orc

En recopie d'article par F15, on recopie les notes après confirmation

Orf

Recherche (F7) d'un outil, d'une forme

Voir la note commençant par CODE_LIEN_TABLES

Voir la note commençant par _SUP_REQ_OUTIL

Org

Demande de confirmation de l'édition des règles de gestion de stock de l'article

Ori

Permet de recopier les notes, tarifs, info_c et remises

Nécessite les option Onr et Oss.

Orl

Recopie des libellés étrangers lors du F15

Orn

En recopie d'article par F15, on recopie également les notes

Orp

F7 papier sur code matière (Critères de sélection adaptés à la recherche des papiers)

NE PLUS UTILISER. Voir alpha3[5]

Orr

Recopie des remises lors de la recopie d'article par la touche F15

Ort

Recopie des tarifs lors de la recopie d'article par la touche F15

Voir la note CONFIR_COPIE_TARIF.

Os1

Le code sous-famille est égal aux caractères 4, 5, 6 du code produit

Osa

Saisir la codification de l'article à recopier dans la nouvelle société

Osf

Le code sous-famille est égal aux caractères 5, 6, 7 du code produit

Osi

Le changement de code sous-famille est interdit

Osl

Saisie d'un slash obligatoire pour contrôler la saisie d'indice dans le code article

Oso

Le code sous-famille est obligatoire.

Oss

Accès direct à la saisie simplifiée de matière / produit

Voir le chapitre consacré à la saisie simplifiée d'articles.

Otl

Activation de la saisie des liens entre tables (accessible par la touche F29)

Voir la note commençant par CODE_LIEN_TABLES

Ovs

Edition de la valeur du stock sur la dernière colonne

Ozu

Zone mp_des2 en majuscule (zone upshift)

Permet de saisir la zone mp_des2 en majuscules.

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique (à blanc si pas de mot de passe)
Caractère 6 | SPECIFIQUE. Ordre de tri des articles en affichage. (1 à 4)
Caractères 7 à 12 | Type et code du paramètre de la visualisation à utiliser pour le CTRL-P
Caractère 13 | Copie du niveau 1 de nomenclature et gamme associée lors de la recopie par F15 N pas de copie (par défaut) T copie systématique Q Question posée à l'utilisateur
Caractères 14 à 19 | Code du client de la nomenclature à recopier. (lié au caractère 13) Par défaut : #SOC
Caractères 20 à 22 | Type du paramètre de lancement pour l'accès à la nomenclature (dt0) par F19 (par défaut #FB)
Caractères 23 à 25 | Code du paramètre de lancement pour l'accès à la nomenclature (dt0) par F19 (par défaut DT0)
Caractères 26 à 31 | Type et code du paramètre de lancement pour la configuration de la saisie des tarifs par la touche F6
Caractère 32 | L'accès à la nomenclature par F17 doit-il être réalisé avec le client principal associé à l'article ? (O/N, N par défaut)
Caractères 33 à 35 | Type paramètre du programme d'édition d'étiquettes (#ED par défaut) Touche F22
Caractères 36 à 38 | Code paramètre du programme d'édition d'étiquettes (ETA par défaut) Touche F22
Caractère 39 | Le code langue dans les libellés étrangers est égal à celui du client (O/N, N par défaut)
Caractère 40 | Le libellé article dans les libellés étrangers est égal à celui de l' article (O/N, N par défaut) Uniquement en recopie inter société !
Caractère 41 | Contrôle la référence de remplacement [espace] Affiche juste un bandeau rouge et ne bloque pas la saisie W Affiche un message avec confirmation et ne bloque pas la saisie B Affiche un message avec confirmation et bloque la saisie Uniquement en recopie inter société !
Caractère 42 | Paramétrage du comportement pour un article ayant un code source de 15 caractères et des préfixes paramétrés. O l'article est recopié sans préfixe (comportement par défaut) N l'article n'est pas recopié Uniquement en recopie inter société !
Caractère 43 | Recopie des notes O/N (O par défaut). Uniquement en recopie inter société !
Caractère 44 | Recopie des libellés étrangers (O/N, N par défaut). Uniquement en recopie inter société !
Caractère 45 | Recopie des infos complémentaires (O/N, O par défaut). Uniquement en recopie inter société !
Caractère 46 | Reprise de la date de création de l'article recopié pour la date de création du nouvel article (O/N, N par défaut) O date de création nouvel article = date de création article recopié N date de création nouvelle article = date du jour Uniquement en recopie inter société !
Caractère 47 | Test d'existence du préfixe pour sa recopie. O/N (N par défaut) O Si le premier caractère du code de l'article recopié est égal au préfixe, alors on ne rajoute pas le préfixe. N Le préfixe est systématiquement ajouté s'il existe.
Caractères 48 à 53 | Type et code du paramètre de configuration de saisie des remises en tableau par la touche F26.
Caractère 54 | Recopie des liens de nomenclatures dans la recopie inter - société des articles (O/N) Les codes articles composants sont préfixés avec le même préfixe que le code article composé.
Caractère 55 | Mise à jour des codes familles/sous-familles dans les tarifs. O Les codes familles/sous-familles sont toujours modifiés dans les tarifs N Les codes familles/sous-familles ne sont jamais modifiés dans les tarifs (défaut) C Les codes familles/sous-familles ne sont modifiés dans les tarifs que sur confirmation de l'utilisateur
Caractère 56 | Recopie des tarifs lors de la recopie inter-sociétés (O/N, N par défaut) Voir la note _SUP_REQ_COPIE_TAR0

Valeur alpha 3

Caractères 1 à 2

Longueur de la racine du code (voir -Oa1 et -Odf) Par défaut 5

Caractères 3 à 4

Longueur du folioteur (voir -Oa1)

Longueur du folioteur 2, dans le cadre du double folioteur (voir -Odf)

Caractère 5

Type de recherche du code article par F7

1 Recherche Normale (désignation, famille, etc;) (valeur par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Q Recherche sur la qualité

T Recherche orientée Transformateurs

Caractère 6

Mode de saisie de tarif

1 Saisie en mode simple sans tiers (par défaut)

2 Saisie en tableau par la touche F6

3 Saisie simplifiée par la touche F24 ou F36 puis F6

4 Saisie des tarifs si le code fournisseur est renseigné (sinon, mode 3)

Caractères 7 à 9

Paramètre du code catégorie pour la saisie de tarif type 2

Caractères 10 à 12

Code tarif par défaut (utilisé dans la fonction F6 en création des tarifs type 2)

Caractère 13

Type de recherche code normalisé par F7 (champ mp_afnor)

[espace] Pas de contrôle

1 Recherche fichier articles

2 Recherche fichier ECMA

Caractères 14 à 22

Affectation automatique des champs en partant de la fin du code saisi. Voir alpha4[13,60]

14 - Poids (O/N/D/F) N par défaut

15 - Longueur (O/N/D/F) N par défaut

16 - Largeur (O/N/D/F) N par défaut

17 - Hauteur (O/N/D/F) N par défaut

18 - Client (O/N/D/F) N par défaut

19 - Famille (O/N/D/F) N par défaut

20 - Sous-famille (O/N/D/F) N par défaut

21 - Réservé pour usage futur

22 - Réservé pour usage futur

Si l'un de ces caractères est positionné à O, le champ associé qui est extrait du code article, est trouvé en partant de la fin du code article saisi (et non pas en partant du début).

Exemple On souhaite bâtir une codification où le code article a une longueur variable, mais où les 4 derniers caractères représentent toujours le poids.

Code OBC30B1200 Poids = 1200

Code OC601350 Poids = 1350

Paramétrage : alpha3[14] = O, alpha4[23,26] = 0104

Ajout du 06/04/2012 :

Pour chacun de ces caractères, on peut dorénavant paramétrer les lettres D et F.

D Seul l'indice de départ sera calculé à partir de la fin du code, l'indice de fin reste celui paramétré

F: Seul l'indice de fin sera calculé à partir de la fin du code, l'indice de début reste celui paramétré.

Ces nouveaux paramètres permettent alors de récupérer des valeurs de taille variable&

Exemple

On veut récupérer le code client dans les articles PS#SOC0001 (#SOC) et PSCLIENT0001 (CLIENT).

A318] = F

A4[39,40] = 03 (indice de départ du code)

A4[41,42] = 05 (valeur à soustraire de la longueur du code pour obtenir l'indice de fin)

On obtient alors :

pour PS#SOC0001

Longueur du code = 10

Indice de départ = 3

Indice de fin : 5 caractères avant la fin (10 -5 + 1) = 6

On récupère donc #SOC

pour PSCLIENT0001

Longueur du code = 12

Indice de départ = 3

Indice de fin : 5 caractères avant la fin (12 -5 +1) = 8

On récupère donc CLIENT

Caractère 23

Longueur du folioteur 1, dans le cadre du double folioteur (voir -Odf)

Caractères 24 à 26

Code de validité à affecter à l'article d'indice précédent (Fonctionne avec-Odf)

Si à blanc, pas de traitement sur l'article d'indice précédent

Caractère 27

Premier séparateur lors de la codification avec double folioteur (-Odf). Par défaut : signe moins

Saisir le signe moins ou laisser à blanc

Caractère 28

Deuxième séparateur lors de la codification avec double folioteur (-Odf). Par défaut : slash

Saisir un slash ou laisser à blanc

Caractère 29

Caractère venant se concaténer à la fin du code article si le paramètre -Oa2 est positionné

Caractères 30 à 32

Code du mot de passe

Pour la gestion des variantes de production (F9 sur saisie des matières simplifiées).

Caractère 33

Position de début de la racine du code article (voir -Odf). Par défaut 1

Valeur alpha 4

Caractères 1 à 12 | Types de commandes à interdire dans l'historique des articles
Caractères 13 à 60 redéfinis ci-après : | Affectation automatique des champs Poids, Longueur, Largeur, Hauteur, Client, Famille, Sous-famille En fonction du code article saisi, on affecte automatiquement le contenu de ces zones Aucun paramétrage supplémentaire n'est nécessaire
Caractères 13 à 17 | Multiplicateur du poids. Exemple code CB090, multiplicateur = 0.001, zone poids = 0.090
Caractères 18 à 22 | Multiplicateur des dimensions. Exemple code CB090100200, multiplicateur = 10, zone longueur = 1000, zone largeur = 2000
Caractères 23 à 26 | Position du poids dans le code article
Caractères 27 à 30 | Position de la longueur dans le code article
Caractères 31 à 34 | Position de la largeur dans le code article
Caractères 35 à 38 | Position de la hauteur dans le code article
Caractères 39 à 42 | Position du code client dans le code article
Caractères 43 à 46 | Position du code famille dans le code article
Caractères 47 à 50 | Position du code sous-famille dans le code article
Caractères 51 à 60 | Réservé pour usage futur

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

ATTENTION : voir aussi #CF RMP

Autres notes

ACCES_CONSULT_STOCK

21,26 Type et code du paramètre de lancement du programme de consultation des stocks

ACCES_FICHE_CLIENT

21,26 Type et code du paramètre de lancement de la fiche client (#SA CLI)

ACCES_FICHE_FOUCLI

21,26 Type et code du paramètre de lancement de la fiche fournisseur (#SA FOU)

ACCES_GESTION_OUTIL

21,26 Type et code du paramètre de lancement de la gestion des outillages

ACCES_HISTO_ACHATS

21,26 Type et code du paramètre de lancement de la visualisation des commandes fournisseurs à utiliser pour l'historique des achats

ACCES_HISTO_VENTES

21,26 Type de paramètre de lancement de la visualisation des commandes clients à utiliser pour l'historique des ventes

ACCES_VOLUEDIT

21,26 Type et code du paramètre de lancement de voluedit_fiche_produit (#VE PRD)

27 Lancement automatique de l''édition, avec demande de confirmation

C A la création de la fiche article uniquement

T Systématiquement

N Jamais (par défaut)

AFF_EVENEMENT_

Cette note est prioritaire sur celle du #CF EVT.

BORNES_DONNEE_TEC_

Contrôles des valeurs saisies par rapport à des bornes minimum/maximum

19 Numéro de donnée technique (1 à 4)

21,30 Valeur minimum (999999.999)

32,41 Valeur maximum (999999.999)

Ce fonctionnement est valable pour les programmes suivants

Saisie des commandes d'achat (cdef)

Saisie des inventaires (inventaire)

Saisie des devis multi-métiers (devis_standard)

Saisie des matières (ici)

Visualisation des besoins matières (v_cde_5)

Le paramétrage de contrôle sera recherché dans l'ordre suivant

1. Famille de la qualité matière

2. Type de commande d'achat (saisie des commandes d'achat uniquement)

3. Paramètre de lancement du programme (ici)

#CC

Contrôle des champs dans la fiche article

#CC_

Contrôle des champs de saisie des libellés étrangers

5,20 Contrôle pour l'affichage / la saisie des champs

LIB_ETR : Ecran de saisie des libellés étrangers

21,38 Nom du champ sur lequel le contrôle s'effectue :

le_libelle

le_libpar1

le_libelle2

39 Type de contrôle à effectuer

N Pas de contrôle (par défaut).

W Le champ doit être saisi (anomalie non bloquante).

B Le champ doit être saisi (anomalie bloquante).

CODE_ARTICLE_DEFAUT

21,35 Code article par défaut à utiliser pour la création d'un nouvel article en saisie simplifiée

36 Recopie des composants de la nomenclature de l'article par défaut (O/N, N par défaut)

Voir le chapitre consacré à la saisie simplifiée d'articles.

Option Oss nécessaire

CODE_LIEN_TABLES

21, 23 Code paramètre du lien à utiliser (type #LI)

Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser.

Voir option Orf

CODE_TSC_VAR_PRINC

Code TSC utilisé pour l'identification de la variante principale

Le numéro de variante utilisé sera enregistré dans la zone numérique 1 de ce TSC, sur l'article principal.

CODIF_ART*

Codification automatique d'articles

CODIF_DES*

CODIF_DE2*

Construction de la désignation pour la création en automatique

Voir le chapitre consacré à la saisie simplifiée d'articles.

COL_ART*

Saisie simplifiée d'articles

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

CONFIG_GENERE_PF

21,26 Type et code du paramètre de configuration de génération des PF

Option Oss nécessaire

Dans le #CF GPF : paramétrer A3[6] ainsi que la note _SUP_REQ_REF_CLI.

CONFIR_COPIE_TARIF

21 Affichage d'un message de confirmation avant la recopie des tarifs lors de la recopie d'article par la touche F15 (O/N, N par défaut).

Voir l'option Ort.

CONTROLE_CREA_MAT

Lors de la création d'un article, on vérifie qu'aucun autre article ayant les mêmes famille, sous-famille, dimensions et qualité matière n'existe déjà.

21 Code du contrôle :

N Non bloquant (valeur par défaut)

W Warning

B Bloquant

CONTROLE_LIEUX_RGT

Contrôle des lieux de rangement lors de la saisie (O/N, O par défaut)

CREER_ACTION_AUTO

21,23 Code action automatique à générer lors de la création d'un outil

Lors de la création d'un outil en saisie simplifiée d'article, permet de générer une action automatique de suivi d'outillage.

CREER_NOM_DOUANIERE

21 Création de la nomenclature douanière dans le TSC 270 lors de la création d'un nouveau code article.

La récupération du code nomenclature douanière se base sur le paramétrage de configuration du devis onduleur. Voir la note NOMENCLATUREDEB dans le paramètre #CF DKP.

Remarque : Le type de produit correspond au code sous-famille de la composition si celle-ci est saisie (mat.mp_qualite_matiere).

CREER_PARAMETRE_PP

Dans le cadre de la saisie simplifiée des articles :

- Création automatique d'une protection palette (.PP)

- Création automatique d'un tarif

Option Oss nécessaire

Voir le chapitre consacré à la saisie simplifiée d'articles

Cliquez ici pour afficher / masquer les fonctionnalités et les remarques.

21 Activation de la création automatique d'un paramètre de type .PP correspondant aux informations saisies (O/N, N par défaut)

22 Type de protection palette - Pas de valeur par défaut

F Fond

C Couvercle

Les caractères suivants concernent le paramétrage de création du tarif :

23,32 Grammage utilisé pour le calcul du poids (g/m²) - Obligatoire, pas de valeur par défaut

33,42 Tarif en euros par kilo (¬/kg) - Obligatoire, pas de valeur par défaut

43,48 Type et code du paramètre de la configuration de la saisie des tarifs

On recherche la note _CODES_CATEGORIES dans ce paramètre.

Par défaut : on prend celui qui est indiqué en A2[26,31].

CRI_MAT_SIMPLIFIE

OPTIONS_SAISIE_MAT

INT_SIMP_FAM_OBLIG

CODE_LIEN_TABLES

TITRE_SAISIE_SIMPLE

_SUP_REQ_OUTIL

_SUP_REQ_MAC_OUTIL

_SUP_REQ_INT_SIMP

Tous les programmes utilisant la construction d'un complément de sélection sur la table des articles (mat) via l'écran de saisie détaillée peuvent utiliser ces notes décrites dans les généralités.

CTRL_DOUBLON_RGT

21 Contrôle si un lieu RG1 est déjà affecté à un code papier quelque soit RG2 et/ou RG3 dans le cas d'une utilisation en mono-référence. Voir l'option Ogb dans r_bob

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

FAM_SFM_DEF_COLART

Codes famille et sous-famille par défaut pour le mode interrogation de la saisie simplifiée des articles

Le tableau de détail est rempli dès l'accès à la fenêtre de saisie simplifiée en fonction des notes COL_ART paramétrées pour ces codes familles/sous-famille.

21,23 Code famille

24,26 Sous-famille

FENETRE_AUTO_MAT

Ouverture automatique d'une fenêtre de notes en saisie matières (si existence d'un type de note paramétré)

21,23 Type de notes mugissantes (saisies dans mat3)

24 Modification des notes autorisée (O/N, O par défaut)

FORCAGE_VAL_ZONE_mp

Lors de la recopie inter société de produit, forcer certaines zones avec des valeurs

21,38 Nom de la zone à modifier (table mat)

Exemples : mp_lon, mp_param pour forcer toute la zone, mp_param[20] pour forcer le car.20

39,60 Valeur de la zone (peut-être vide pour effacer le contenu de la zone)

Existe aussi pour la recopie inter société de clients.

INT_SIMP_FAM_OBLIG

21 Famille obligatoire pour l'interrogation simplifiée (O/N, N par défaut)

Voir en bas de page le paragraphe de paramétrage

LANCEMENT_V_CDE_TAR0

21,26 Type et code du paramètre de lancement de la visu des commandes

LCT_ACTUAL_VAR_IMP

Option -Oav nécessaire

21 à 26 Type et code du paramètre de lancement du programme d'actualisation des variantes d'impression (RS_var_imp.42r)

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

LIBELLE_TECHNIQUE_1

Libellé technique 1 (remplace le libellé Largeur)

Cette note est lue en priorité sur #CF GEA.

LIBELLE_TECHNIQUE_2

Libellé technique 2 (remplace le libellé Longueur)

Cette note est lue en priorité sur #CF GEA.

MAJ_GACHES_TARIF

Mise à jour des gâches en automatique

Lors de la validation de la saisie d'un article (création et/ou modification, saisie normale et simplifiée) :

Permettre de mettre à jour automatiquement les gâches fixes (mat.mp_dt3) et variables (mat.mp_dt4) selon la valeur du tarif en vigueur.

21 Activation de la mise à jour des gâches à la validation de la saisie

N Désactivée (par défaut)

C En création uniquement

M En création et modification

22 [vide]

23,28 Type et code du paramètre de configuration de recherche des tarifs

Important : Si la configuration du tarif n'est pas renseignée, on appliquera automatiquement les gâches par défaut (si renseignées, voir ci-dessous)

29 [vide]

30,32 Code du tarif à rechercher (doit correspondre à un paramètre de type TAR)

Par défaut : Code tarif du fournisseur chez le client de l'article (cli.cl_tar de mat.mp_foucli)

MAJ_GACHES_VALEURS

Mise à jour des gâches en automatique

21,30 Gâche fixe à appliquer

31 [vide]

32,41 Gâche variable à appliquer

42 [vide]

43,52 Valeur du tarif en deçà duquel les gâches s'appliquent

Important : Si cette valeur n'est pas précisée, il s'agit des valeurs de gâches par défaut.

Ce sont ces valeurs qui seront appliquées si aucun tarif en vigueur n'est trouvé.

Par exemple, s'il n'est pas saisi ou si le paramétrage de configuration de recherche des tarifs n'est pas renseigné. Voir MAJ_GACHES_TARIF)

Cliquez ici pour afficher / masquer des exemples.

MAJ_RECOPIE

13,30 Nom de la zone à mettre à jour (table mat ou TSC)

Champ de la table mat : voir la liste ci-après

TSC_XXX_Y

XXX : Code du TSC

Y : Zone de TSC (Codes A à G)

31,60 Valeur de mise à jour (ne pas mettre de valeur correspond à la valeur nulle)Important : Aucune vérification n'est faite quant aux valeurs paramétrées.

Exemples

MAJ_RECOPIE mp_qualite ATT

La zone de qualificatif article (mp_qualite) de l'article créé par recopie aura pour valeur ATT.

MAJ_RECOPIE TSC_207_G

La zone alphanumérique de 30 caractères du TSC 207 sur l'article créé par recopie sera effacée (valeur nulle).

MAJ_TSC*

Alimentation automatique des TSC à partir des zones de la fiche article

8,60 nom_zone_origine*code_TSC*nom_zone_info_c*

Exemples

MAJ_TSC*mp_fam*TES*ic_char3_1*

MAJ_TSC*mp_sfm*TES*ic_char3_2*

MAT_SITE_XXXXXXX

Remarques pour les 4 notes suivantes

En gestion multi-sites, permet de saisir des formats plaques selon le code site.

L'écran de saisie des lieux de rangement par site sera utilisé pour cette nouvelle fonctionnalité (F25 sur saisie des articles)

Ces nouvelles colonnes sont masquées par défaut.

Pour chacune des nouvelles colonnes, il est possible de modifier le titre et le format d'affichage.

Tableau de bord du multisite

MAT_SITE_LONGUEUR

21 Afficher la colonne de saisie de la longueur selon le site (O/N, N par défaut)

23,49 Titre de la colonne. Par défaut : Longueur

51,60 Format d'affichage de la colonne. Par défaut : #####&.&&& (000009.999)

Tableau de bord du multisite

MAT_SITE_LARGEUR

Afficher la colonne de saisie de la largeur selon le site (O/N, N par défaut)

Titre de la colonne. Par défaut : Largeur

Format d'affichage de la colonne. Par défaut : #####&.&&& (000009.999)

Tableau de bord du multisite

MAT_SITE_HAUTEUR

Afficher la colonne de saisie de la hauteur selon le site (O/N, N par défaut)

Titre de la colonne. Par défaut : Hauteur

Format d'affichage de la colonne. Par défaut : #####&.&&& (000009.999)

Tableau de bord du multisite

MAT_SITE_GRAMMAGE

Afficher la colonne de saisie du grammage selon le site (O/N, N par défaut)

Titre de la colonne. Par défaut : Grammage

Format d'affichage de la colonne. Par défaut : ###&.&&& (0009.999)

Tableau de bord du multisite

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions

Paramétrage équivalent au C

Exemple

3CLI2QA

Voir #CF EVT.

NOTES_GROUPEES

Saisie simplifiée des notes

PARAM_LCT_PRG_VS

21,26 Type et code du paramètre de configuration de lancement de programmes (#BAxxx)

Ce programme se lancera lors de la validation de la saisie d'un article (touche F10).

PREFIXE_CODE_CIBLE

Préfixe de recopie des articles inter société suivant le code société

21,23 code société

25 préfixe

Exemple

PREFIXE_CODE_CIBLE AUC A

REINIT_DATE_FIN_VAL

21,23 Réinitialisation automatique de la date de fin de validité lorsque la validité change.

Valeur de la validité avant changement

25,27 Valeur de la validité après changement

Le caractère * (astérisque) est géré et accepte toutes les validités.

Exemples

REINIT_DATE_FIN_VAL PER FAB

REINIT_DATE_FIN_VAL INA DEV

REINIT_DATE_FIN_VAL PER F

SAISIE_POINTAGES

Accès à la saisie des pointages ECMA/FEFCO

M Accès en modification

C Accès en consultation

S Accès en mode simulation

N Pas d'accès (par défaut)

Voir l'option Ocr.

SRECOP

8 à 60 : Complément de requête sur la table mat pour la recopie inter-société (doit commencer par un "and")

_SUP_REQ_CODE_PDT

21, 60 Complément de select

Par ex. and mp_fam = 'PIG''

_SUP_REQ_COPIE_TAR0

21,60 Complément de sélection des tarifs à recopier lors de la recopie inter-sociétés

Voir aussi A2[56]

_SUP_REQ_INT_SIMP

21,60 Supplément de requête sur l'interrogation simplifiée des articles

Exemple

and mp_fam = "PLA"

_SUP_REQ_MAC_OUTIL

21,60 Complément de sélection pour la recherche des machines liées aux outils

Voir option Orf

La même note existe sur le TEN pour le devis multi-métiers et dans la visualisation des devis multi-métiers.

_SUP_REQ_MP_PARAM_22

21,60 Supplément de requête sur les tables cde1 et cde2

Exemple

and ec_tyc != "PRX"

_SUP_REQ_NOM0_VISNOM

21,60 Complément de requête sur la table mat. <VF>

Ce complément de requête intervient dans la visualisation de nomenclature.

Ce complément de requête a priorité sur celui du paramètre #CF ATL.

_SUP_REQ_OUTIL

21,60 Complément de requête pour cette recherche

Voir option Orf

_SUP_REQ_RECH_LIEN

21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

_SUP_REQ_RECOP_NOTES

21,60 Complément de sélection sur la table mat3

Uniquement sous GENERO

Exemple

_SUP_REQ_RECOP_NOTES and mc_type != "REC"

TITRE_SAISIE_SIMPLE

21, 60 Titre de la fenêtre de saisie simplifiée

TYPE_INTERROGATION

21,30 Mode d'interrogation

NORMALE Interrogation par l'écran détaillé (valeur par défaut)

SIMPLIFIEE Interrogation par l'écran simplifié

Voir en bas de page le paragraphe de paramétrage

TYPE_RECOPIE_SUISTK

21 Type de recopie de la zone de suivi en stock

N : L'état de suivi en stock de l'article cible est le même que celui de l'article source (par défaut).

G : Une demande est faite à l'utilisateur au démarrage de la recopie inter-société

(Article suivi en stock : O/N, celui-ci sera le même pour tous les articles cibles, toutes sociétés cibles confondues)

A : Une demande est faite à l'utilisateur pour chaque article source traité (l'état de suivi en stock sera le même pour toutes les sociétés cibles, pour l'article cible courant)

S : Une demande est faite à l'utilisateur pour chaque article source et société cible traitée (l'état de suivi en stock pourra être différent pour 2 sociétés cibles distinctes et pour le même article source)

V

Vérifications avant suppression d'un article

(Pour info : le même type de vérification est effectué dans par01).

Lors d'une annulation logique ou physique d'un article, des vérifications sont effectuées à partir de ce paramétrage.

Ce paramètre est recherché en priorité dans cet ordre :

1) Paramètre de lancement du programme mat

2) Sous-famille

3) Famille

2 Type d'annulation

P Physique

L Logique

3 à 4 Numéro identifiant la vérification (sous la forme 01, 02, ...)

5 Caractère souligné (_)

Paramétrage des noms des tables où effectuer les vérifications

6 à 10 TABLE (mot-clé)

21 à 60 Nom de la table

Paramétrage des jointures à effectuer

6 à 13 JOINTURE (mot-clé)

21 à 60 Jointure (Le caractère %1 sera remplacé par le code article).

Paramétrage du complément de sélection à effectuer

6 à 15 COMPSELECT (mot-clé)

21 à 60 Complément de sélection

Paramétrage du message à afficher si l'annulation est bloquée

6 à 15 MESSAGE (mot-clé)

21 à 60 Message à afficher (Le caractère %1 sera remplacé par le code article).

Cliquez ici pour afficher / masquer des exemples

VERIF_AFFECTATION

Contrôle de l'affectation (zone mp_affect) en saisie de matière (normale ou simplifiée)

N Pas de contrôle (valeur par défaut)

W Message d'avertissement avec validation

C Fenêtre de confirmation

B Contrôle bloquant (par défaut)

Liste des zones de la table des articles (mat) pouvant être mises à jour

Voir les notes commençant par MAJ_RECOPIE

Les noms de zone sont triés par ordre alphabétique.

Nom de la zone | Type de la zone | Description
mp_affect | Alphanumérique | Ordre de fabrication par défaut
mp_at1 | Alphanumérique | Donnée technique alphanumérique 1
mp_at2 | Alphanumérique | Donnée technique alphanumérique 2
mp_cli | Alphanumérique | Code client principal
mp_coefdiv_ffix | Numérique | Coefficient diviseur de frais fixes
mp_cptv | Alphanumérique | Compte de vente
mp_devis | Alphanumérique | Numéro de devis
mp_entite | Numérique | Numéro d'entité
mp_foucli | Alphanumérique | Code fournisseur principal
mp_gencod | Alphanumérique | Code gencode
mp_gestionnaire | Alphanumérique | Code gestionnaire
mp_itf14 | Alphanumérique | Code ITF14
mp_minfou | Numérique | Minimum de commande fournisseur ou de fabrication
mp_pa | Numérique | Prix d'achat
mp_pr | Numérique | Prix de revient
mp_pr_fixe | Numérique | Prix de revient fixe
mp_pv | Numérique | Prix de vente
mp_pv2 | Numérique | Prix de vente dans l'unité d'utilisation
mp_qtemini_cdeclt | Numérique | Quantité minimum pour une commande client
mp_qualite | Alphanumérique | Qualificatif d'article
mp_rgt1 | Alphanumérique | Zone de rangement 1
mp_rgt2 | Alphanumérique | Zone de rangement 2
mp_rgt3 | Alphanumérique | Zone de rangement 3
mp_sdevis | Numérique | Numéro de sous-devis
mp_site_prod | Alphanumérique | Site de production
mp_smaxi | Numérique | Stock maximum
mp_smini | Numérique | Stock minimum

Codes articles par défaut

ATTENTION Ne pas utiliser les codes commençant par 6 zéros, car ceux-ci sont réservés pour créer des articles par défaut

- 000000000000000 | ARTICLE (1er Niveau)
- 00000000000000P | PRODUIT (2ème Niveau)
- 00000000000000M | MATIERE (2ème Niveau)
- 00000000000000F | FOURNITURE (2ème Niveau)
- 000000000000FAM | FAMILLE (3ème Niveau)
- 000000000FAMSFM | FAMILLE-SOUS_FAMILLE (4ème Niveau)
- 0000000000000NR | PRODUIT NON REFERENCE
- 0000000000000L | Pour Fabrical. Création auto

Les articles par défaut niveaux 1 à 4 servent pour la création des articles

Zone type en Mécanique

FAB | Pièces standards
PC | Pièces de commerce
MAT | Matière

[blanc] est considéré comme identique à MAT

Paramétrage fonction rec_dmp() : (interrogation par F7 du fichier matière)

Paramètres associés

#CF MAT | Paramétrage édition tout confondu
#CF MAM | Paramétrage édition matières, fournitures et fantômes
#CF MAP | Paramétrage édition produits et semi-ouvrés
#CF MAO | Paramétrage édition outillages
#CF MAN | Paramétrage édition pièces de maintenance
#CF STM | Paramétrage édition des statistiques
#CF RMP | Paramétrage des ordres de tris sur la fiche article
USE | Paramétrage des droits de l'utilisateur alpha2[20] Autorisation de passer outre le blocage du code validité de la fiche article

Saisie simplifiée des articles

Option Oss

Option Oaa

alpha3[6]

notes commençant par COL_ART

notes commençant par CODIF_ART

note commençant par TITRE_SAISIE_SIMPLE

Interrogation simplifiée des articles

Utilisation des notes TYPE_INTERROGATION et INT_SIMP_FAM_OBLIG

Cette nouvelle fonctionnalité présente l'intérêt de permettre une interrogation par TSC.

Opérateurs gérés :

 | Chaînes | Dates | Numériques | Observation
!= X <> X | Oui | Oui | Oui | Si X non précisé, teste par rapport à NULL
< X | Oui | Oui | Oui | Si X non précisé, teste par rapport à NULL
> X | Oui | Oui | Oui | Si X non précisé, teste par rapport à NULL
<= X | Oui | Oui | Oui | Si X non précisé, teste par rapport à NULL
>= X | Oui | Oui | Oui | Si X non précisé, teste par rapport à NULL
X : Y | Oui | Oui | Oui | Compris entre X et Y (X et Y sont impératifs)
* et ? | Oui | Non | Non | Ressemblant à &.

  • La saisie ne gère pas les instructions SQL tels que AND, OR, BETWEEN, etc

  • La saisie ne traite qu'un seul opérateur de comparaison par champs de saisie, les autres sont considérés comme faisant partie de la valeur de comparaison.


v_mat Visualisation des articles

Le paramétrage du nom de la colonne est le suivant :

NOM0_in_[colonne de la table]

où in est un indice (caractères 15,16 de la note))

et colonne de la table peut prendre les valeurs suivantes :

des_n0_pcsant désignation du code composant

n0_epai épaisseur/hauteur du composant

n0_gf gâche fixe

n0_gv gâche variable

n0_larg largeur du composant

n0_long longueur du composant

n0_marq marque

n0_pcsant code composant

n0_prix le prix

n0_qte coefficient de nomenclature

n0_rep code repère

n0_seq numéro de séquence

nom_n0_cli nom du client

v_mat Visualisation des articles

Ce programme permet aussi de générer une commande en saisissant un minimum d'information.

Le paramétrage à mettre en oeuvre est repéré par la mention Génér.cde :

Dans ce programme, 4 notes commençant par SSC et 3 nouvelles zones

Paramétrage également dans v_edi_cde et dans #CF SSC (voir ce chapitre pour un récapitulatif de tout le paramétrage).

Cette nouveauté est également disponible dans v_pro_stk.

NOUVEAU au 29/11/2011 : Historisation des indicateurs du devis multi-métiers

Options Valeur alpha 2 & 3 Tris Notes Noms de zones autorisés

Touche de fonction F16 (régularisation des stocks). Voir #CF STK pour le paramétrage du type de mouvement de régularisation.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : code article Exemple : -N[mp_code]
-N_FOU | Action : affiche toutes les matières liées au code fournisseur Caractères 3 et suivants : code fournisseur Exemple : -N_FOU[cl_code]
-N_CLI | Action : affiche toutes les matières liées au code client Caractères 3 et suivants : code client Exemple : -N_CLI[cl_code]

Options

-N

Possibilité de passer un code article en argument

Oae

Lors de la demande d'une génération de commande d'achat, faire celle-ci sur le code ensemble associé au produit sélectionné dans la visualisation

Ocf

Génération automatique des commandes d'achats à la validation de la visualisation des matières (sur demande de confirmation)

Ocl

Code langue égal par défaut au code langue du client saisi

Oda

En configuration multi-site, l'application prend par défaut le lieu de déstockage dans le paramètre SIT.

Avec cette option, on inverse les priorités, c'est-à-dire que le lieu de déstockage de l'article est pris en priorité sur la fiche article.

La note C_FAM_ART_DES_SIT permet d'exclure des codes familles que l'on préfère mettre en priorité sur le lieu du paramètre SIT.

Tableau de bord du multisite

Oef

Libellés étrangers avec le code fournisseur (mp_foucli)

En l'absence de cette option, les libellés étrangers affichés seront ceux relatif au code client (mp_cli).

Cette option n'est prise en compte que si l'option Omm est active.

Oim

Option imprimerie

Oli

Libellé 1 dans la saisie des libellés étrangers égal au libellé de l'article

Omm

Mise à jour en masse des fiches articles

Cette option change le fonctionnement classique du programme de visualisation des articles et n'est pas compatible avec certaines options. Par exemple, l'écran de sélection sera toujours celui de la saisie simplifiée.

Voir l'option Oef et la note PARAM_COL_ART.

Dans le cadre des actions à réaliser sur une sélection multiple, paramétrer aussi :

- la note _CSEL (ici, dans le paramètre de lancement, pour faire apparaître la colonne de sélection)

- dans le #RP, les notes commençant par LCT_MULTI_ (la note LCT_MULTI_PARAM_ fait référence au code action ACT015).

Opa

Prendre en compte les produits asynchrones présents dans la nomenclature de l'ensemble pour le calcul des quantités de stocks (colonnes de visualisation commençant par stock_ens_)

Oqa

Prise en compte de la quantité dans l'unité d'achat pour la recherche du tarif

Oqr

Permet de lancer un calcul en automatique des seuils d'alertes et stock minimum

Paramétrer la note PARAM_GEST_STK

Nouvelle action (Ctrl K) : Règles de gestion par lieu. Voir l'action 018.

Pour consulter les seuils d'alerte et les quantités de réapprovisionnement par lieu pour l'article sélectionné.

Voir le nouveau mode de calcul des seuils d'alerte et de quantité de réapprovisionnement dans le programme de gestion des paramètres de stock.

Osq

Active la saisie multi-unités de la quantité lors de la génération de commande d'achat

(même option que pour le programme de saisie des commandes fournisseurs)

Otl

Activation de la saisie des liens entre tables (accessible par la touche F29)

Voir la note commençant par CODE_LIEN_TABLES

Ovv

Visualisation vide

La présence de cette option indique que l'on veut accéder à l'écran de visualisation des articles même si la recherche ne retourne aucun enregistrement. Dans cette visualisation vide, la configuration d'une action CTRL-J permet d'accéder directement à la saisie des articles en mode création.

Le paramètre de lancement de la saisie des articles doit avoir l'argument-N_CREAT.

A utiliser avec les notes LCT_PROG_

Valeur alpha 2

Caractères 21 à 26 | Type et code du paramètre de configuration de saisie des remises en tableau. Exemple #CF RE1 ou #CF RE2 (mais pas #CF REM, réservé à la recherche des remises)
Caractères 27 | Type de recherche des stocks des colonnes stocks prévisionnels paramétrables (stock_pf_nn et stock_ens_nn) 0 Par lot 1 Par lieu 3 Par lieu-lot (Valeur par défaut) Facultatif - Voir la note ZONE_LL_STOCK_NUM_
Caractères 28 à 30 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 31 | Saisie des frais et pertes en valeur (O/N, N par défaut) Par défaut : Saisie des frais et pertes en pourcentage
Caractère 32 | Marge fixe ? (O/N, N par défaut)
Caractère 33 | Numéro de la donnée technique de la fenêtre tri (1 par défaut)
Caractères 34 à 39 | Paramètre de configuration de saisie des tarifs Ne pas confondre avec la note CONFIG_TARIF_ACHAT pour la recherche de tarif.
Caractères 40 à 42 | Type paramètre pour la zone lc_par_tyc de la ligne de commande Exemple NI pour les commandes de type FBM
Caractère 43 | O on demande l'article à rechercher sur le F18 N sur l'article en cours de consultation
Caractères 49 à 60 | Type de commandes à interdire dans l'historique des articles

Valeur alpha 3

Caractères 1 à 60

Titre de la visualisation

Valeur alpha 4

Caractère 5 | Touche F5 (O/N) : Rafraîchissement (réactualisation) de l'écran
Caractère 8 | Autorisation d'accès à la touche de fonction N Touche de fonction non autorisée. O Touche de fonction autorisée et accès en consultation. M Accès à la saisie simplifiée en modification.
Caractère 17 | Touche F17 (O/N) Génération des FBI
Caractère 19 | Activation de la fonction de génération d'une commande d'achat à partir d'une matière (ligne de visualisation, touche F19)
Caractère 22 | Saisie simplifiée de commandes – Soumis à option payante CDE 9
Caractère 23 | Autorisation d'accès à la touche de fonction de recopie d'article (O/N, N par défaut) Voir la note RECOPIE_ARTICLE
Caractère 30 | Autorisation de la touche F30 pour la visu des commandes clients (O/N) - Paramétrage dans la note LANCEMENT_V_CDEM
Caractère 31 | Autorisation de la touche F31 pour la visu des commandes fournisseurs (O/N) - Paramétrage dans la note LANCEMENT_V_CDEF
Caractère 33 | Accès à la visualisation simplifiée des articles (O/N, N par défaut) - A4[8] = M
Caractère 37 | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]
Caractère 44 | Autorisation du CTRL-K

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Autres notes

ACCES_CDE_TYC_

Paramètre de lancement de la saisie des commandes

15,17 Type de commande

21,26 Type et code du paramètre de lancement de la saisie des commandes

Exemple

ACCES_CDE_TYC_FBI #SAFBI

Sur le programme de saisie des commandes, il faut définir le contrôle du code blocage (note CBACON)

ACCES_VOLUEDIT

21 à 26 Type et code du paramètre de lancement de voluedit_fiche_produit (#VEPRD)

ALERTE_STOCK_NUM_

Permet de limiter l'affichage aux lignes de produits en alerte uniquement (avec les modes visualisation, édition et/ou fichier)

18,19 Numéro correspondant au numéro de restriction de stock (paramétré sur la note RESTRIC_STOCK_NUM_
ATTENTION : la note RESTRIC_STOCK_NUM_ doit être déclarée avant ALERTE_STOCK_NUM_.

21 Type d'affichage des lignes de produits en alertes

N Affichage de toutes les lignes de produits (par défaut)

M Affichage uniquement des lignes dont le stock physique (PF/Ensemble) est inférieur au stock minimum

A Affichage uniquement des lignes dont le stock physique (PF/Ensemble) est inférieur au stock d'alerte

CBAFBI

7,9 Code blocage automatique à positionner en saisie des lignes de commande, dans le cas où les FBI associées à la ligne de commande ont été modifiées, rendant leur actualisation automatique impossible

On doit avoir une seule ligne de note.

7,9 Code blocage

Exemple

CBAFBIFBI

#CC_

Contrôle pour l'affichage / la saisie des champs

5,20 MAT_GEN_CDEF : Ecran de génération d'une commande

21,38 Nom du champ sur lequel le contrôle s'effectue

gm_client

gm_client_adl

gm_sitp

gm_commentaire

39 Type de contrôle à effectuer

N Pas de contrôle (par défaut).

W Le champ doit être saisi (anomalie non bloquante).

B Le champ doit être saisi (anomalie bloquante).

I Le champ n'est pas accessible en saisie.

M Le champ est masqué

40 Le zéro est-il significatif pour une zone numérique ?

O Le zéro est considéré comme une saisie correcte.

N Le zéro est considéré comme une saisie incorrecte (équivalent à aucune saisie) (par défaut).

C_FAM_ART_DES_SIT

21,23 Code famille du produit

Cette note facultative fonctionne avec l'option Oda.

Exemple

C_FAM_ART_DES_SIT XYZ

Pour la famille XYZ, le lieu de destockage sera en priorité celui du paramètre SIT.

CF_MAJ_FLAG_INFO_C

Voir page dédiée

CLIPPED_LIGNE_EF

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

CODE_LIEN_TABLES

21, 23 Code paramètre du lien à utiliser (type #LI)

Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser.

COMPTEUR_TYC_

Paramètre du compteur de la saisie des commandes

14,16 Type de commande

21,22 Compteur

Exemple

COMPTEUR_TYC_FBI 1

CONFIG_TARIF_ACHAT

21,26 Type de paramètre de la configuration de recherche de tarif

Utilisé lors de la génération des commandes fournisseur

La recherche de tarif fournisseur n'est pas exécutée si ce paramétrage n'est pas saisi.

CRI_MAT_SIMPLIFIE

OPTIONS_SAISIE_MAT

INT_SIMP_FAM_OBLIG

CODE_LIEN_TABLES

TITRE_SAISIE_SIMPLE

_SUP_REQ_OUTIL

_SUP_REQ_MAC_OUTIL

_SUP_REQ_INT_SIMP

Voir, dans la page Généralités, le chapitre intitulé

Construire un critère de sélection sur un article via l'interrogation simplifiée des articles.

CRITERE_REINITIALIS

21 Activer le bouton de réinitialisation des critères de la visu (O/N, N par défaut)

CRITERE_SAUVEGARDE

21 Sauvegarde des critères à chaque validation ou annulation (O/N, N par défaut)

_CSEL

Affichage de la colonne de sélection (colonne de droite)

Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement. Voir #RP

EDITION_AR_FBI

21,26 Type et code du paramètre de lancement de l'édition des AR de FBI

FAM_SFM_DEF_COLART

Codes famille et sous-famille par défaut pour le mode interrogation de la saisie simplifiée des articles

Le tableau de détail est rempli dès l'accès à la fenêtre de saisie simplifiée en fonction des notes COL_ART paramétrées pour ces codes familles/sous-famille.

21,23 Code famille

24,26 Sous-famille

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

FORMULE_CONV_TARIF

Numéro de formule de conversion tarif (1 par défaut)

GEN_CDEF_ADA

21 Saisie de l'adresse d'envoi du fournisseur

O Affiche la zone de saisie pour l'adresse d'envoi

N N'affiche pas la zone de saisie

GEN_CDEF_ADF

21 Saisie de l'adresse de facturation

O Affiche la zone de saisie pour l'adresse de facturation

N N'affiche pas la zone de saisie

GENERATION_CDEF

21,26 Type de paramètre de la génération des commandes d'achats

GESTION_OUTILLAGE

21 Gestion des lieux de rangement (O/N, N par défaut)

Voir l'option Ogo dans la saisie des articles.

INV_LONG_LAR_MAT

21 Inverser la largeur et la longueur dans l'écran de filtre (O/N, N par défaut)

O Format : largeur x longueur

N Format : longueur x largeur (Par défaut)

L'option Oim (mode Imprimerie) est obligatoire.

LANCEMENT_V_CDEF

21,26 Type et code paramétrage de lancement de la visualisation des commandes fournisseurs (touche F31)

LANCEMENT_V_CDEM

21,26 Type et code du paramètre de lancement de la visualisation des commandes clients (touche F30)

LANCEMENT_V_STK_LL

21,26 Type et code paramètre de la visualisation des stocks par lots-lieux

LCT_MULTI_CONFIG

21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP

Voir exemple dans la doc du #RP

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

MAJ_FLAG_INFO_C

Voir page dédiée

OPTION_CDE_TYC_

Options de lancement de la saisie des commandes

16,18 Type de commande

21,60 Options de lancement pour la saisie des commandes type FBI

Options disponibles :

c2 Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne
Un des deux codes doit être saisi.

cr Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne.
Un des deux codes doit être saisi.
Si les deux sont saisis, ils doivent être différents

dl Prise en compte du délai labo dans le calcul de la date de fin de fabrication
Fonction f_caldates()

dr Contrôle des délais de réapprovisionnement des accessoires
Fonction f_caldates()

g5 Génération automatique des besoins matières. Nouvelle gestion à partir du devis standard

m1 Mise à jour du prix de revient de la ligne de commande avec celui de la fiche article

ny Numérotation annuelle des commandes

r1 Le code représentant de l'entête de commande est initialisé avec celui du code adresse de réception

r2 Le code représentant de la ligne de commande est initialisé avec celui du code adresse de livraison

rd Initialise le couple devis / sous-devis avec celui de la fiche article

sr Pas de mise à jour du stock résultant

tr Prise en compte du fichier tarifs

t3 Recherche de tarif en utilisant la date de livraison proposée
Cette option positionne automatiquement l'option Otr

uv Utilisation de l'unité de vente pour calculer le prix de vente issu du fichier mat/prod et le prix du mouvement de stock

Exemple

OPTION_CDE_TYC_FBI r1r2

PARAM_CDE_TYC_

Paramètre du type de note historique de la revue de contrat

15,17 Type de commande

21,23 Type de note historique de la revue de contrat

Exemple

PARAM_CDE_TYC_FBI RCH

PARAM_COL_ART

21,26 Type et code du paramètre où l'on va chercher les notes de type COL_ART si celles-ci ne sont pas renseignées dans les notes de la famille et de la sous-famille. Cette note n'est prise en compte qu'en présence de l'option Omm.

PARAMETRE_SAISIE_MAT

21,26 Type et code du paramètre pour le lancement du programme de saisie des articles (F8)

Exemple #SAPF

PARAM_GENERER_CDE

21,26 Type et code du paramètre de configuration de transfert en commande (par défaut : #CF TDC)

Voir la fonction Historisation des indicateurs du devis multi-métiers

PARAM_GEN_FBI

Paramètre de la génération des FBI

21 Demande de confirmation de la génération de la FBI (O/N, N par défaut)

22 Accès à la commande après la génération de la FBI (O/N, N par défaut)

23,28 Client par défaut pour la génération de la FBI

Si renseigné, il est utilisé

Sinon, on prend celui de la fiche article

Si ce dernier est vide, on prend #SOC

29,31 Type de liaison de l'entête de commande client (Paramètre LIE) - Facultatif

Exemples

PARAM_GEN_FBI OO#SOC

PARAM_GEN_FBI OO#SOC CTR

PARAM_GEST_STK

Type et code paramètre de lancement du programme de gestion des paramètres de stock

Cette note est obligatoire avec l'option Oqr.

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

Voir la fonction Historisation des indicateurs du devis multi-métiers

RECOPIE_ARTICLE

21,26 Type et code du paramètre de lancement du programme de saisie des matières à lancer pour la recopie

Autorisation d'utiliser cette fonction : A4[23]

Passage d'argument dans la saisie des articles : -N_DUP[mp_code)

RESTRIC_STOCK_NUM_

19,20 Numéro permettant de créer plusieurs restrictions différentes

21,60 Complément de sélection sur la tables des stocks (stk0) à prendre en compte pour ce numéro de restriction

SEP_VISU_TYPE_F_CHAR

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

_SITE_PROD_POUR_CDEF

21,23 Site de production par défaut (alimentera la zone gen_cdef.gf_ecf1)

Voir aussi _TYPE_NOTE_PROD

Tableau de bord du multisite

SSC_COMPTEUR_EDC_REF

21,29 Code racine du compteur alphanumérique (type N) - Génér.cde

Cette note a priorité sur celle du #CF SSC.

SSC_PARAM_CONFIG

21,26 Type et code du paramètre de configuration de saisie simplifiée de commande (par défaut : #CFSSC) - Génér.cde

SSC_PARAM_EDI_CDE

Saisie simplifié de commande en mode utilisateur - Génér.cde

Cette note a priorité sur celle du #CF SSC.

21,26 Type et code du paramètre de lancement de la visualisation des commandes EDI

27 Ouverture de la visualisation EDI avec génération automatique de la commande

O A la validation de l'écran de saisie simplifiée de commande, on lance automatiquement la génération de la commande via la visualisation EDI. Les écrans et messages éventuels sont affichés à l'écran.

N A la validation de l'écran de saisie simplifiée de commande, on accède à la visualisation EDI. C'est à l'utilisateur de confirmer la génération de commande via la touche de fonction de génération (F12) (par défaut).

SSC_PARAM_RECH_TAR

21,26 Type et code du paramètre de configuration de recherche de tarif - Génér.cde

Cette note a priorité sur celle du #CF SSC.

STOCKER_ELEMENT_PRU

Stocker les éléments de calcul du PRU (indicateurs) dans la table d'historisation du prix de revient (hist_pr)

La présence d'un type conditionne la création de l'enregistrement d'historisation correspondant.

21 Type d'enregistrement d'historisation des indicateurs pour les indicateurs a à o

22 Type d'enregistrement d'historisation des indicateurs pour les indicateurs p à D

23 Type d'enregistrement d'historisation des indicateurs pour les indicateurs E à S

24 Type d'enregistrement d'historisation des indicateurs pour les indicateurs T à Z

Voir la fonction Historisation des indicateurs du devis multi-métiers

_SUP_REQ_CDE_FAB

21,60 Complément de requête sur la table cde2 pour limiter les lignes prises en compte dans le calcul de la quantité restante à fabriquer

Pour la nouvelle colonne qte_a_fabriquer : somme des quantités restantes à fabriquer (lc_qtelan – lc_qtefab)

_SUP_REQ_CDE_LIV

21,60 Complément de requête sur la table cde2 pour limiter les lignes prises en compte dans le calcul de la quantité restante à livrer

Pour la nouvelle colonne qte_a_livrer : somme des quantités restantes à livrer (lc_qtecde – lc_qteliv_reelle)

_SUP_REQ_CDE_RCP

21,60 Complément de requête sur la table cdf2 pour limiter les lignes prises en compte dans le calcul de la quantité restante à recevoir

Pour la nouvelle colonne qte_a_recevoir : somme des quantités restantes à recevoir (lf_qtecde – lf_qteliv)

_SUP_REQ_CONSO_STK0

21,60 Complément de sélection des mouvements de stocks de sortie (stk0) pour la recherche de la consommation des 12 derniers mois

Exemple : and s0_typ = "NOR"

_SUP_REQ_NOM0_

15,16 N° d'indice

21,60 Complément de requête pour la recherche de l'indice dans la table nom0

Paramétrage du nom des colonnes disponibles

_SUP_REQ_NOM_FAB

21,60 Complément de requête sur la table cde4 pour limiter les lignes prises en compte dans le calcul de la quantité restant à fabriquer dans la nomenclature

_SUP_REQ_NOM_LIV

21,60 Complément de requête sur la table cde4 pour limiter les lignes prises en compte dans le calcul de la quantité restant à livrer dans la nomenclature

_SUP_REQ_NOM0_VALID

21,60 Complément de sélection sur la table nom0 lors de la vérification de la validité des composants

Une vérification de la validité des composants est faite lors de l'action Génération FBI.

Exemple

# Complément de sélection pour la validité d'un composant

_SUP_REQ_NOM0_VALID and n0_pcsant not like "I%"

_SUP_REQ_NOM0_VALID and n0_pcsant not like "A%"

_SUP_REQ_RECH_LIEN

21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

SUP_REQ_RG1_SITE_USE

21 Limiter le traitement aux lieux de rangement du site de l'utilisateur (O/N, N par défaut)

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF STK.

Tableau de bord du multisite

_SUP_REQ_STK_DER_ENT

21,60 Complément de requête sur la recherche sur la table stk0 de la date de dernière entrée en stock (der_entree)

_SUP_REQ_STK_DER_SOR

21,60 Complément de requête sur la recherche sur la table stk0 de la date de dernière sortie de stock (der_sortie)

_TAR_XX_CONFIG

_TAR_XX_CODE_TAR

_TAR_XX_TIERS

_TAR_XX_DATE

_TAR_XX_QTE

_TAR_XX_COMP_SEL

_TAR_XX_SITE

_TAR_XX_DEFAUT

Afficher sur chaque ligne de visualisation divers tarifs que l'on peut paramétrer librement.

Voir la page dédiée à ces notes.

TEXT_LIBRE_1_V_T_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

_TIT_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_VISU_TYPE_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage

_TYPE_NOTE_PROD

Type de note à prendre ne compte pour alimenter la zone premiere_ligne_de_note

Voir aussi _SITE_PROD_POUR_CDEF

TYC_GENERATION_FBI

21,23 Type de commande (TYC) des commandes de fabrication à générer

Par défaut : FBI

TYPES_NOTES_EDITEES

Dans certaines visus (comme v_cdem), on peut éditer les notes de l'enregistrement en cours.

De plus, lors de la saisie simplifiée des articles, il est possible (par F7 dans la zone désignation) de spécifier des libellés complémentaires sur l'article (notes de type #LC).

But : permettre l'impression de ces notes via le menu édition

21,23 Type de notes à éditer 1

24,26 Type de notes à éditer 2

27,29 Type de notes à éditer 3

30,32 Type de notes à éditer 4

33,35 Type de notes à éditer 5

36,38 Type de notes à éditer 6

39,41 Type de notes à éditer 7

42,44 Type de notes à éditer 8

45,47 Type de notes à éditer 9

48,50 Type de notes à éditer 10

51,53 Type de notes à éditer 11

54,56 Type de notes à éditer 12

57,59 Type de notes à éditer 13

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

ZONE_LL_STOCK_NUM_

Le nom de la zone de la table temp_lot_lieu peut être changé

19,20 Numéro de la restriction

21,41 Zone de la table temp_lot_lieu qui sera retournée pour les colonnes stock_pf_nn et stock_ens_nn

sphy_lot_lieu Stock physique du lot ou du lieu ou du lieu-lot (Zone par défaut)

sdisp_lot_lieu Stock disponible du lot ou du lieu ou du lieu-lot

scdef_lot_lieu Stock en commande du lot ou du lieu ou du lieu-lot

sres_lot_lieu Stock réserve du lot ou du lieu ou du lieu-lot

Facultatif - Voir A2[27] et note RESTRIC_STOCK_NUM_

Ordres de tris disponibles

Voir les notes commençant par O

1 | CODE ARTICLE | cod
2 | DESIGNATION ARTICLE | des
3 | CODE FAMILLE | fam
4 | CODE SOUS-FAMILLE | sfm
5 | CODE CLIENT | cli
6 | CODE FOURNISSEUR | fou
7 | CODE AFNOR | afn
8 | CATEGORIE ARTICLE | lib
9 | LARGEUR | lar
10 | DONNEE TECHNIQUE (A-B) | dtn
11 | CENTRE DE COUT | cdc
12 |  | lpt
13 | CODE ARTICLE NIVEAU 1 | an1
14 | CODE ARTICLE NIVEAU 2 | an2
15 | NUMERO DE DEVIS | dev
16 | LONGUEUR | lon
17 | HAUTEUR | hau
18 | DONNEE TECHNIQUE ALPHA 1 | at1
19 | DONNEE TECHNIQUE ALPHA 2 | at2
20 | GRAMMAGE | poi
21 | LIEU RANGEMENT 1 | rg1
22 | LIEU RANGEMENT 2 | rg2
23 | qualité matière | mp_qualite_matiere
24 | code statistique 1 | mp_cs1
25 | code statistique 2 | mp_cs2
26 | code statistique 3 | mp_cs3
27 | code statistique 4 | mp_cs4

Listes des noms de zones autorisés

Les rubriques pouvant être mises en variables sont soulignées

Package Matières/Articles/Produits

les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

les noms de zone peuvent être préfixés de qm_ pour accéder aux informations de la fiche qualité matière des articles

(informations de la fiche mat de la zone mat.mp_qualite_matiere de l'article visualisé)

Exemples

qm_mp_des Désignation de la qualité matière

qm_libc_mp_qualite Libellé court de la qualité article de la qualité matière

qm_nom_mp_cli Nom du client associé à la qualité matière

Packages conteneur_info et conteneur_produit.

Autres zones

Noms de zones CIC

Table nom0 : voir la note _SUP_REQ_NOM0_

Package tiers (fiche client de l'article)

Fiche client associée à la table conteneur produit (le lot) : remplacer le préfixe cl_ par lot_cl_

Package cde1 (entêtes de commandes clients)

Package cde2 (lignes de commandes clients)

Package conteneur_prod_det

Package stk_rg (Règles de gestion de stockage et de réapprovisionnement par lieu de rangement) (option Oqr requise)

Liste des noms de zones autorisées (CIC)

Autres zones

using | Voir #VI
a_commander | si stock dispo > 0 alors Quantité à commander = Stock mini si stock dispo <= 0 alors Quantité à commander = Stock dispo - stock mini
code_art_niv1 lib_code_art_niv1 | Code de l'article niveau 1 Désignation de l'article niveau 1
code_art_niv2 lib_code_art_niv2 | Code de l'article niveau 2 Désignation de l'article niveau 2
coefconv1 | Coefficient de conversion de la fiche matière
coefconv5 | Résultat du calcul de la formule N° 5 du coefficient de conversion.
conso_12_mois | Consommation de l'article pendant les 12 derniers mois (Total des sorties de stock) Pas de tri pour cette colonne. Pas de cumul pour cette colonne
conso_24_mois | Consommations sur les 24 derniers mois
conso_n | Consommations sur l'année en cours (tient compte de l'exercice)
conso_n1 | Consommations sur l'année en cours 1 (tient compte de l'exercice)
conso_n2 | Consommations sur l'année en cours 2 (tient compte de l'exercice)
cotes_refoulage | Les cotes de refoulage (figurant dans les informations complémentaires associées au CIC de N01 à N20).
date_der_mvt | Date du dernier mouvement réel
date_premier_mvt | Date du premier mouvement de stock de l'article Pas de tri pour cette colonne Pas de cumul pour cette colonne
date_std | Date au format paramétré par le using
date_time_std | Date + heure au format YYYY-MM-DD hh:mm:ss
der_entree | Date de la dernière entrée réelle
der_sortie | Date de la dernière sortie réelle
diff_qte_ua_client | Différence entre le stock physique client dans l'unité d'achat et le stock physique dans l'unité d'achat. Voir plus bas qte_ua_client
dispo_immediat | Stock disponible - stock réserve
flag_annulation | Valeur indiquant si l'article est annulé (1) ou non (0)
gen_cdef_ok | Une génération de commande d'achat a été faite sur la ligne courante Cette colonne est temporaire, elle ne sert qu'à indiquer qu'une génération de commande d'achat a été effectuée. Une fois la visualisation relancée, elle est réinitialisée à blanc.
gen_edi_cde_ok gen_edi_cde_ref gen_lig_edi_cde | Zones concernant la génération d'une commande à partir de la visu d'un produit Génér.cde La commande EDI a été générée correctement pour le produit courant Référence de commande EDI (edc_ref) générée pour le produit courant Ligne de commande EDI (edc_lig) générée pour le produit courant
gen_fbi_ok | Une génération de FBI a été faite sur la ligne courante Cette colonne est temporaire, elle ne sert qu'à indiquer qu'une génération de FBI a été effectuée. Une fois la visualisation relancée, elle est réinitialisée à blanc.
lc_par_tyc libc_lc_par_tyc libl_lc_par_tyc | Zone paramétrée associée au type de commande Libellé court de lc_par_tyc Libellé long de lc_par_tyc
lib_le_libelle | Voir en dessous de la zone ref_produit
lib_le_libelle2 | Voir en dessous de la zone ref_produit
metrage_restant | Métrage restant (stock physique * métrage)
moyenne_6_mois | Consommation moyenne de l'article sur les 6 derniers mois
nom_abrege_mp_cli | Nom abrégé du client (cl_nom_abrege)
poids_restant | Poids restant (stock physique X poids)
prix_unitaire | Prix unitaire (mp_pamp/mp_sphy)
pump_article | Prix unitaire moyen pondéré de l'article
qte_a_fabriquer | Somme des quantités restantes à fabriquer (lc_qtelan – lc_qtefab)
qte_a_livrer | Somme des quantités restantes à livrer (lc_qtecde – lc_qteliv_reelle)
qte_a_recevoir | Somme des quantités restantes à recevoir (lf_qtecde – lf_qteliv)
qte_client_disp | Stock disponible en quantités client
qte_client_phy | Stock physique en quantités client
qte_client_res | Stock réserve en quantités client
qte_tot_colis | Nombre de PF par caisse Si le conteneur n'a qu'une seule ligne de détail, alors la quantité sera affichée, sinon la zone sera vide et l'utilisateur devra passer par la fonction Détail du conteneur. Voir #CF CAB A1[3]
qte_ua | Quantité physiquement en stock dans l'unité d'achat
qte_ua2 | Quantité physiquement en stock dans l' unité d'achat Cette zone est alimentée uniquement si FAM A3[33] est différent de N.
qte_ua3 | Quantité physique en stock dans l'unité paramétrée sur la 3ième formule de conversion
qte_ua_client | Stock physique client dans l'unité d'achat. Voir plus haut diff_qte_ua_client
reffou_produit | Référence produit le fournisseur chez le client
libfou_le_libelle | Libellé étranger 1 pour le fournisseur chez le client
libfou_le_libelle2 | Libellé étranger 2 pour le fournisseur chez le client
ref_produit | Référence saisie dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y a pas de client saisi dans la fiche matière, affiche la première référence trouvée dans les libellés étrangers.
ref_produit_sd | Référence saisie dans les libellés étrangers pour le client saisi dans la fiche matière, mais n'affiche rien si il n'y a pas de client saisi dans la fiche matière.
ref_produit_des | Référence saisie dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y pas de client saisi dans la fiche matière ou s'il n'y a pas de référence saisie pour ce client, le programme affiche la désignation de la fiche matière.
lib_le_libelle | Libellé saisi dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y a pas de client saisi dans la fiche matière, affiche le premier libellé trouvé dans les libellés étranger.
lib_le_libelle_sd | Libellé saisi dans les libellés étrangers pour le client saisi dans la fiche matière, mais n'affiche rien s'il n'y a pas de client saisi dans la fiche matière.
lib_le_libelle_des | Libellé saisi dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y a pas de client saisi dans la fiche matière ou si il n'y a pas de libellé saisi pour ce client, le programme affiche la désignation de la fiche matière.
lib_le_libelle2 | Libellé 2 saisi dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y a pas de client saisi dans la fiche matière, affiche le premier libellé 2 trouvé dans les libellés étranger.
lib_le_libelle2_sd | Libellé 2 saisi dans les libellés étrangers pour le client saisi dans la fiche matière, mais n'affiche rien s'il n'y a pas de client saisi dans la fiche matière.
lib_le_libelle2_des | Libellé 2 saisi dans les libellés étrangers pour le client saisi dans la fiche matière S'il n'y pas de client saisi dans la fiche matière ou si il n'y a pas de libellé 2 saisi pour ce client, le programme affiche la désignation de la fiche matière.
stock_ens_nn | Stock de l'ensemble - Voir l'option Opa où nn représente un numéro de restriction, voir note RESTRIC_STOCK_NUM_ La variable stock_ens_nn est alimenté comme suit : Si le produit courant est un produit simple : stock_ens_nn = stock_pf_nn Si le produit courant est un ensemble monté/monté extérieur : stock_ens_nn = stock_pf_nn + nombre d'ensembles réalisables avec le stock de chacun des composants Si le produit courant est un ensemble appairé non monté : stock_ens_nn = nombre d'ensembles réalisables avec le stock de chacun des composants
stock_pf_nn | Stock du produit fini où nn représente un numéro de restriction, voir note RESTRIC_STOCK_NUM_
qte_nom_a_fabriquer | Somme des quantités restant à fabriquer dans la nomenclature (nc_qtecde – nc_qtefab)
qte_nom_a_livrer | Somme des quantités restant à livrer dans la nomenclature (nc_qtecde – nc_qteliv_reelle)
libfou_le_client | Code fournisseur retrouvé dans les libellés spécifiques
libfou_nom_client | Nom du fournisseur retrouvé dans les libellés spécifiques
ref_produit_sd | Référence du produit pour le client de la fiche article. Si l'article n'est pas associé à un client, la colonne reste vide (sans valeur par défaut) Cf. colonne ref_produit
lib_le_libelle_sd | Libellé 1 du produit pour le client de la fiche article. Si l'article n'est pas associé à un client, la colonne reste vide (sans valeur par défaut) Cf. colonne lib_le_libelle
lib_le_libelle2_sd | Libellé 2 du produit pour le client de la fiche article. Si l'article n'est pas associé à un client, la colonne reste vide (sans valeur par défaut) Cf. colonne lib_le_libelle2
reffou_produit_sd | Référence du produit pour le fournisseur de la fiche article. Si l'article n'est pas associé à un fournisseur, la colonne reste vide (sans valeur par défaut) Cf. colonne reffou_produit
libfou_le_libelle_sd | Libellé 1 du produit pour le fournisseur de la fiche article. Si l'article n'est pas associé à un fournisseur, la colonne reste vide (sans valeur par défaut) Cf. colonne libfou_le_libelle
libfou_le_libelle2_sd | Libellé 2 du produit pour le fournisseur de la fiche article. Si l'article n'est pas associé à un fournisseur, la colonne reste vide (sans valeur par défaut) Cf. colonne libfou_le_libelle2
TAR_XX | à utiliser conjointement avec les notes commençant par _TAR_XX
COMPO_LAIZE_nn_SSS | Afficher les différentes laizes disponibles dans une composition. Ces colonnes affichent les laizes selon le site de production. Si le site ne contient pas de laize spécifique, alors la laize dites multisite sera affichée. où nn est un nombre compris entre 01 et 16 (Numéro de laize). où SSS est un code site de production.

Liste des noms de zones autorisés (CIC)

Informations complémentaires associées au CIC

Pour la compréhension des zones paramétrables figurant ci-dessous, voir l'aide en ligne du paramètre CIC.

Nom de zone | CIC | Type
infoc_cic_dv1 infoc_cic_dv2 infoc_cic_dv3 infoc_cic_dv4 infoc_cic_dv5 | DV1 DV2 DV3 DV4 DV5 | Date
infoc_cic_dp1 infoc_cic_dp2 infoc_cic_dp3 infoc_cic_dp4 | DP1 DP2 DP3 DP4
infoc_cic_nv1 infoc_cic_nv2 infoc_cic_nv3 infoc_cic_nv4 infoc_cic_nv5 | NV1 NV2 NV3 NV4 NV5 | Numérique
infoc_cic_nc1 infoc_cic_nc2 infoc_cic_nc3 infoc_cic_nc4 infoc_cic_nc5 | NC1 NC2 NC3 NC4 NC5
infoc_cic_np1 infoc_cic_np2 infoc_cic_np3 infoc_cic_np4 infoc_cic_np5 infoc_cic_np6 infoc_cic_np7 infoc_cic_np8 | NP1 NP2 NP3 NP4 NP5 NP6 NP7 NP8
infoc_cic_ns1 infoc_cic_ns2 infoc_cic_ns3 infoc_cic_ns4 infoc_cic_ns5 infoc_cic_ns6 infoc_cic_ns7 infoc_cic_ns8 infoc_cic_ns9 | NS1 NS2 NS3 NS4 NS5 NS6 NS7 NS8 NS9
infoc_cic_nr1 infoc_cic_nr2 infoc_cic_nr3 infoc_cic_nr4 infoc_cic_nr5 infoc_cic_nr6 infoc_cic_nr7 infoc_cic_nr8 | NR1 NR2 NR3 NR4 NR5 NR6 NR7 NR8
infoc_cic_nq1 infoc_cic_nq2 infoc_cic_nq3 infoc_cic_nq4 infoc_cic_nq5 infoc_cic_nq6 infoc_cic_nq7 | NQ1 NQ2 NQ3 NQ4 NQ5 NQ6 NQ7
infoc_cic_pv1 infoc_cic_pv2 infoc_cic_pv3 infoc_cic_pv4 infoc_cic_pv5 | PV1 PV2 PV3 PV4 PV5 | Paramètre
infoc_cic_cv1 infoc_cic_cv2 infoc_cic_cv3 infoc_cic_cv4 infoc_cic_cv5 | CV1 CV2 CV3 CV4 CV5 | Chaîne de caractères

Historisation des indicateurs du devis multi-métiers

Lors de la génération d'une FBI à partir de la visualisation des articles (action F17), permet d'historiser les indicateurs du récapitulatif des coûts du devis multi-métiers (table hist_pr).

Remarques :

• Ce fonctionnement est lié à l'option payante PRO/4 (Détail de récapitulatif des coûts)

• Le devis associé à l'article de la FBI doit être valide (date du jour comprise dans les dates de validité du devis)

• Les indicateurs sont calculés à partir des valeurs actuelles du devis, ce dernier n'est pas recalculé avant l'historisation.

Paramétrage

Option payante PRO/4 (Détail de récapitulatif des coûts=

A4[17] = O

Note STOCKER_ELEMENT_PRU

Note OPTION_CDE_TYC_ L'option rd est obligatoire pour le stockage des indicateurs dans la table d'historisation des prix de revient.

Note PARAM_INDICATEURS, prioritaire sur les 3 notes _VAR_INDIC_ / _FOR_INDIC_ / _TIT_INDIC_, décrites dans le #CF REC

Voir aussi

Note PARAM_GENERER_CDE


Importation des articles

Importation des articles imp_prod

Ce programme permet d'importer un ou des champs dans la table mat par le biais d'un fichier texte avec séparateurs.

Valeur alpha 2

Caractère 1 | Anciens produits à supprimer (O/N, N par défaut)
Caractère 2 | Séparateur de champ : non obligatoire depuis la version S'il n'est pas renseigné, les champs paramétrés doivent être marqués par une position de début et de fin dans le fichier.
Caractères 3 à 17 | Article de référence pour les valeurs par défaut
Caractère 18 | Code société à importer obligatoirement dans le fichier (O/N, N par défaut) Si N, le code société de l'article sera celui de la société en cours.

Valeur alpha 3

Caractères 1 à 60

Nom complet du fichier à importer

Exemple : /home/imports/import.txt

Notes

C

Paramétrage des champs à importer

1,3 Clé du champ (commence forcément par un C) (exemple C01, C02, ...)

4 Champ obligatoire (O/N, N par défaut)

5,22 Champ, qui peut être sous 2 formes :

Nom du champ (même dénomination que dans la table mat)

TSC_MP_XXX_N, où XXX représente le code TSC et N représente la zone.

Les champs TSC serviront à importer des champs qui n'existent pas dans la table mat.

Les dates (zones A et B des TSC) doivent être sous la forme AAAAMMJJ sans séparateur.

23, 26 Position de départ s'il n'y a pas de séparateur.

27, 30 Position de fin s'il n'y a pas de séparateur.

31 Correspondance avec un paramètre (O/N, N par défaut)

32 34 Type de paramètre (exemple FAM)

Exemples

C01Omp_code 00070024

C02Omp_des 00250064

C03Omp_date 00650072

C04OTSC_MP_TRA_G 00730084

C05OTSC_MP_TR2_A 00850092

C06OTSC_MP_TR2_G 00930104

C07Omp_fam 01050108OFAM

C08Omp_uv 01090111OUNI

C09OTSC_MP_202_C 01120124

C10Omp_poids 01250137

C11OTSC_MP_202_E 01380150

C12Omp_sfm 01510154OSFM

C13OTSC_MP_PLA_G 00010006

S

2,60 Supplément de requête au fichier articles

Paramètres nécessaires

FAM PAP | Note CORRES_IMPORT_MAT
#CF TRA | Traçabilité des articles


v_libetr Visualisation des libellés étrangers

Ordres de tris disponibles

1 | n_fam | CODE FAMILLE
2 | n_sfm | CODE SOUS-FAMILLE
3 | n_prd | CODE ARTICLE
4 | n_cli | CODE CLIENT
5 | n_lan | CODE LANGUE
6 | n_lp1 | REFERENCE ARTICLE CLIENT
7 | n_li2 | LIBELLE 2
8 | n_lib | LIBELLE
9 | n_fop | FOURNISSEUR PRINCIPAL ARTICLE
10 | n_clp | CLIENT PRINCIPAL ARTICLE

Listes des noms de zones autorisés

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

+ les zones suivantes :

using | Voir #VI
le_soc | Code société
le_prod | Code article
le_client | Code client dans les libellés étrangers
nom_le_client | Nom du client dans les libellés étrangers
le_langue | Code langue dans les libellés étrangers
libc_le_langue | Libellé court langue dans les libellés étrangers
libl_le_langue | Libellé long langue dans les libellés étrangers
le_libpar1 | Référence étrangère article
le_libelle | Libellé article étranger
le_libelle2 | Libellé article étranger 2


Statistiques articles

Statistiques articles sta_mat

Options

-Oac | Permet d'éditer les statistiques de consommations et d'achats matières
-Ole | Impression de la référence spécifique client (libellé étranger) quand celle-ci existe, avec la désignation de l'article Impression sous la forme référence spécifique - désignation

Valeur numérique 1

Nombre de décimales des quantités. Par défaut, 2

Valeur numérique 2

Nombre de décimales des montants. Par défaut, 2

Valeur alpha 2

Caractères 1 à 60

Paramétrage état (NOOOOON par défaut) Touche F6
Pour chacune des 7 possibilités, les valeurs possibles sont O ou N
1) Edition du prévu
2) Edition ligne détail article
3) Edition total article
4) Edition total sous-famille
5) Edition total famille
6) Edition total général
7) Cumuls des quantités

Valeur alpha 3

Titre état. Par défaut :

STATISTIQUES ARTICLES

STATISTIQUES MATIERES (option –Oac)

Valeur alpha 4

Paramétrage des colonnes d'édition | ABCDEFGHIJ par défaut pour les articles ABCDKMLN par défaut pour les matières (option –Oac)
A | Code matière - produit
B | désignation matière - produit
C | Année
D | Mois
E | Quantité
F | CA au prix d'achat
G | CA au prix de revient
H | CA au prix de vente
I | Marge en valeur et % au prix d'achat
J | Marge en valeur et % au prix de revient
K | Quantité achetée
L | Quantité consommée
M | Prix acheté
N | Prix des consommations


Consommation matière

Consommation matière c_mat

Mise à jour des consommations matières (mat4) avec les mouvements de stock

Options

-Oaa

Les articles annulés logiquement ne sont pas pris en compte
Les TMV doivent être correctement paramétrés .

Valeur alpha 2

Caractère 1

Visualisation des traitements (O/N, O par défaut)


v_mat4 Visualisation des statistiques articles

Ordres de tris disponibles

1 | n_fam | CODE FAMILLE
2 | n_sfm | CODE SOUS-FAMILLE
3 | n_prd | CODE ARTICLE
4 | n_ann | ANNEE
5 | n_moi | MOIS
6 | n_cli | CODE CLIENT
7 | n_fou | CODE FOURNISSEUR

Listes des noms de zones autorisés

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

using | Voir #VI
m4_soc | Code de la société
m4_produit | Code de l'article
m4_ann | Année
m4_mois | Mois
m4_qte_p | Quantité vendue prévue
m4_ca_pa_p | CA en prix d'achat prévu
m4_ca_pr_p | CA en prix de revient prévu
m4_ca_pv_p | CA en prix de vente prévu
m4_qte_r | Quantité vendue prévue
m4_ca_pa_r | CA en prix d'achat réalisé
m4_ca_pr_r | CA en prix de revient réalisé
m4_ca_pv_r | CA en prix de vente réalisé
m4_qte_ar | Quantité achetée réalisée
m4_prix_ar | Prix des achetées réalisées
m4_qte_cr | Quantité consommée réalisée
m4_prix_cr | Prix des consommations réalisées
m4_qte_ar2 | Quantité achetées réalisées (U.A.)
m4_prix_ar2 | Prix achetées real. (U.A.)
m4_qte_cr2 | Marge % Vente - Achat prévue
marge_qte_vr_p | Marge quantité Vente - Revient prévue
marge_p_c_vr_p | Marge % Vente - Revient prévue
marge_qte_va_r | Marge quantité Vente - Achat réalisée
marge_p_c_va_r | Marge % Vente - Achat réalisée
marge_qte_vr_r | Marge quantité Vente - Revient réalisée
marge_p_c_vr_r | Marge % Vente - Revient réalisée
ecart_qte | Ecart quantité (R.- P.)
ecart_ca_pa | Ecart CA prix d'achat
ecart_ca_pr | Ecart CA prix de revient
ecart_ca_pv | Ecart CA prix de vente
pu_ca_achat_ua | Prix unitaire achat
pu_ca_conso_ua | Prix unitaire consommation
pu_ca_achat_uu | Prix unitaire achat
pu_ca_conso_uu | Prix unitaire consommation
format | Longueur x Largeur


Paramétrage de l'édition des fiches produit

Paramétrage de l'édition des fiches produit efp_param

Notes

E

Paramétrage des colonnes d'édition

Echamp*colonne_depart*longueur*using*casse*fin_ligne*

champ : champ que l'on veut imprimer. On a accès à
Tous les champs de la table mat (+ libellés long et court des codes)
Tous les champs de la table cli (+ libellés long et court des codes)
Tous les champs de la table lib_etr (+ libellés long et court des codes)
Tous les champs de la table ecma (+ libellés long et court des codes)
Les TSC et notes associés au produit et au client
Une zone de texte libre
colonne_depart : Numéro de la colonne où on doit afficher le champ
longueur : Nombre de caractères à afficher
using: Format des zones numériques et dates
casse : Mise en forme du champ (possibilité de cumuler les formats)
G gras / S souligné / I italique / C condensé / L large
fin_ligne : O changement de ligne après le champ
N le champ suivant sera imprimé sur la même ligne
Méthode de paramétrage des champs
Accès aux champs de la table cli : cl_soc, cl_code, etc.
Accès aux champs de la table mat : mp_soc, mp_code, etc.
Accès aux champs de la table lib_etr : le_soc, le_prod, etc.
Accès aux champs de la table ecma : kma_soc, kma_code, etc.
Accès aux libellés long des codes : libl_cl_pays, etc.
Accès aux libellés court des codes : libc_cl_pays, etc.
Accès aux TSC
TSC_MP_TOT_F Accès à la zone ic_char3_1 du TSC TOT sur l'article
TSC_CL_FOU_A Accès à la zone ic_date1 du TSC FOU sur le client
TSC_MP_PAL_FL Accès au libellé long du code paramétré dans le TSC PAL de l'article dans la zone ic_char3_1
TSC_MP_PAL_HC Accès au libellé court du code paramétré dans le TSC PAL de l'article dans la zone ic_char3_2
Accès aux notes
NTS_MP_FAC_3 Imprime les 3 premières lignes de notes de type FAC de l'article
NTS_CL_EXP Imprime toutes les lignes de notes (maximum 30) de type EXP du client
Champs spéciaux
tirets imprime un tiret
saut_de_ligne passe à la ligne suivante
saut_de_page passe à la page suivante
CORRES_DT Imprime le nom du premier correspondant ayant la fonction DT
nom_mp_fou Imprime le nom du fournisseur de la fiche article
today Imprime la date du jour
Recherche entre plusieurs champs
[champ1,champ2 etc.]: la syntaxe employant les crochets permet de rechercher le champ dans le champ1 puis dans le champ2 si le champ1 n'est pas renseigné.

L

Paramétrage des codes articles associés
Lmp[numéro]*zone_de_stockage_du_code*
Numéro : : Valeur entière pour identifier l'article lié
zone_de_stockage_du_code : Emplacement dans la base où on va chercher le code article.
Exemples
mp_qualite_matiere : Le code article lié est dans la zone mp_qualite_matiere
TSC_MP_TOT_G : Le code article lié est stocké dans la zone ic_char30 du TSC TOT de l'article
NTS_MP_ART : Le code de l'article lié est sur la première ligne de note de type ART de l'article

Pour les articles liés, on peut paramétrer par les lignes de notes commençant par E, tous les champs de la table mat ainsi qu'aux TSC et notes associés.

Exemples

Emp_des[1]... affiche la désignation de l'article lié 1

ETSC_MP_NBP_C[3] ... affiche la zone ic_num1 du TSC NBP de l'article lié 3

ENTS_MP_CND_3[2] ... affiche les 3 premières lignes de notes de type CND de l'article lié 2

ATTENTION Les lignes de notes E et L doivent forcément finir par un astérisque.


Edition des fiches produit

Edition des fiches produit efp

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[lc_prod]

Options

-Oim

Mode imprimerie

Valeur alpha 2

Caractères 1 à 3

Fiche produit par défaut


Editions des fiches produit

Avant, les notes saisies n'étaient pas sauvegardées, et c'était les mêmes pour toutes les fiches éditées en même temps.

Cette évolution permet de sauvegarder les notes dans mat3 rattachées à un code article.

Ainsi, les notes sont spécifiques à chaque fiche produit et conservées pour une éventuelle réédition.

Si notes est coché, la fenêtre de saisie des notes s'ouvrira et l'utilisateur pourra ajouter, modifier ou supprimer des notes.

Cette fenêtre s'ouvrira pour chaque produit.

Si notes est décoché, la fenêtre de saisie des notes s'ouvrira en consultation uniquement pour les produits ayant des notes.

Cette option permet dans la fenêtre Fiche Spécification de masquer les champs concernant les dimensions.

Edition des fiches produit fspe_sof

Options triées

Ocd | Masquer les champs concernant les dimensions La note TYPE_NOTE_FSPE est obligatoire. Plus d'info
Ode | Cette option remplace le libellé Dimensions client de l'écran de sélection des critères à éditer par Dimensions extérieures, et le libellé Format client/Customer Size par Dimensions extérieures/Outer Size à l'édition.
Odg | Edition de la désignation de la gamme à la place de la liste des machines
Odp | Active l'édition de toutes les phases de passages
Ofc | Fiche spécifique C, pour afficher les informations sur le triplet pour certaines zones
Ofs | Edition de la fiche de spécification article
Oft | Edition de la fiche technique article
Ool | Edition de l'ancienne version de la fiche RC Article
Orc | Edition de la nouvelle version de la fiche RC Article
Ovd | Ne pas afficher l'écran de détail des zones à éditer Les valeurs prise en compte sont celles paramétrées dans la notes ZONES_A_EDITER (ou bien celles par défaut)

Valeur alpha 2

Caractère 1

Edition de la note contractuelle composition (O/N)

Notes

CODE_MACHINE_FLEXO

21,26 Code machine entraînant le type de flexo Haute Définition

Cette ligne de note entraîne l'apparition de la ligne de type de flexo.

Si la machine paramétrée n'est pas trouvée sur la gamme, la case Flexo Standard sera cochée, sinon Flexo Haute Définition.

LIGNE_1_BDP

LIGNE_2_BDP

21,60 Contenu du texte à éditer

Note cumulative

Attention l'édition ne prendra pas plus de 250 caractères.

Explications

En bas de la page de la fiche produit, il y a deux lignes de commentaire qui étaient mis dans le fond de page de l'édition APIC.

Maintenant, ces deux lignes sont paramétrables.

Les deux lignes concernées sont celles-ci :

Les emballages se conforment aux niveaux de qualité admissibles et tolérances applicables définis par SOFPO.

La durée de stockage des emballages mécanisés ne doit pas excéder 3 mois conformément aux recommandations de la fiche pratique USFO 1.

S'il n'y a rien de paramétré, ces deux lignes s'éditeront par défaut.

LIGNE_SUIVI_PAR_1

21,60 1ère ligne de note du cadre inférieur gauche

LIGNE_SUIVI_PAR_2

21,60 2ème ligne de note du cadre inférieur gauche

_SUP_REQ_MAT

21,60 Complément de select sur mat

Exemple : and mp_anu = "O"

TYPE_NOTE_FSPE

21,23 Type de note lié à la fiche de spécification

Obligatoire si l'option Ofs est active.

ZONES_A_EDITER

21,28 Zones à éditer de l'écran de validation

21 Edition des dimensions client (O/N, N par défaut)

22 Edition du poids brut (O/N)

N par défaut pour la société 004

O par défaut pour les autres sociétés

23 Edition du traitement onduleuse (O/N, N par défaut)

24 Edition du détail de composition (O/N, N par défaut)

25 Edition de l'épaisseur (O/N, O par défaut)

26 Edition des tests (O/N, N par défaut)

27 Edition du conditionnement (O/N, O par défaut)

28 Edition des notes (O/N, N par défaut)

29 Edition de la surface brute (O/N, N par défaut)

30 Edition des informations de qualité (O/N, N par défaut)


Mise à jour automatique des validités d'articles

Mise à jour automatique des validités d'articles maj_validite

Ce module sert à modifier le code validité d'un produit et de tous ses composés dans la nomenclature.

Ainsi, si l'on modifie le code validité d'un papier, on modifiera également les codes validités des compositions utilisant ce papier, des qualités utilisant les différentes compositions et ainsi de suite jusqu' aux ensembles.

On peut démarrer la chaîne de modification n'importe où et saisir ainsi un papier, une composition, une qualité, un produit ou une plaque.

Valeur alpha 2

Caractère 1 | Identifiant des produits de type papier (Premier caractère du code article). Par défaut : X
Caractère 2 | Identifiant des produits de type composition (Premier caractère du code article). Par défaut : C
Caractère 3 | Identifiant des produits de type qualité (Premier caractère du code article). Par défaut : Q
Caractère 4 | Identifiant des produits de type produit/plaque (Premier caractère du code article). Par défaut : P
Caractère 5 | Identifiant des produits de type ensemble (Premier caractère du code article). Par défaut : E

Notes

_SUP_REQ_MAT | 21 à 60 Complément de requête sur la table mat pour la recherche d'articles. Exemple : and mp_code[1,4] = "XPAP" (ne recherche que les produits de type papier)
VALIDITE_CIBLE_PDT | 21 à 23 Code validité source (saisi par l'utilisateur) 25 Type de produit 27 à 29 Code validité cible Exemple PER_P_FAO On modifie le code validité d'un papier. Le nouveau code est PER. Le paramétrage ci-dessus indique que les codes validités de tous les produits (type P) liés à ce papier seront modifiés en FAO (et non en PER). La mise en place de ce paramétrage est obligatoire.

Remarques

  • Les caractères « _ » (souligné) sont facultatifs.

  • Les types de produits doivent être les mêmes que ceux paramétrés dans la zone Alpha 2.

  • Il n'est nécessaire de paramétrer que les types de produits ascendants au type de produit saisi.
    Ainsi, si l'on saisit une qualité, il n'est pas nécessaire de paramétrer les types de produits papier, composition et qualité.


Création d'un indice de produit

Création d'un indice de produit cre_indice_produit

Ce programme permet la création d'un indice de produit, d'ajouter des commentaires sur l'indice…

Options

-Ovp

On duplique depuis la version précédente. Sinon, c'est depuis la version d'origine (celle qui est saisie).

Valeur alpha 2

Caractères 1 à 3 | Mot de passe facultatif
Caractères 4 à 6 | Code qualité à mettre à jour pour le produit source (zone mp_qualite)
Caractères 7 à 9 | Code qualité à mettre à jour pour le produit destination (zone mp_qualite)
Caractère 10 | Caractère alphanumérique de représentation de l'indice (exemple : A)
Caractères 11 à 12 | Position début indice (03 <= valeur <= 15)
Caractères 13 à 14 | Position fin indice (03 <= valeur <= 15)
Caractères 15 à 17 | Type de notes pour la saisie des commentaires de l'indice (exemple : IND)

Notes

_SUP_REACTUALISE_TSC

21,60 Complément de requête sur les TSC à réactualiser

_SUP_REC_PRODUIT

21,60 Complément de requête pour la recherche de la fiche maître

TSC_CCC_Z

où CCC = Code du TSC et Z = Zone du TSC
21 à 50 Valeur précise à stocker dans la zone Z du TSC
Exemple
TSC_60X_A 28/09/2002
pour mettre à jour la zone A (ic_date1) du TSC 60X, avec la valeur 28/09/2002


Importation des tarifs

Importation des tarifs importation_tarif

Importation de tarifs dans tar0 à partir d'un fichier à plat.

Le séparateur est le point-virgule.

Notes

CHAMP_FICHIER

CTRL_CHAFIC_UNICITE

Définition de la structure des lignes de fichiers à intégrer

21,38 Nom du champ de destination dans VoluPack - Obligatoire

On peut saisir tous les champs de la table tar0.

41,43 Cas 1 (sans séparateur de champ) : Position de début de champ - Obligatoire.

Cas 2 (avec séparateur de champ) : Position séquentielle du champ -Obligatoire.

45,47 Cas 1 (sans séparateur de champ) : Longueur du champ - Obligatoire.

Cas 2 (avec séparateur de champ) : non applicable.

Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique.

Fonctionne avec la note CHAMP_FICHIER)

O chaque nom de champ doit être unique (par défaut)

N pas de contrôle

CONFIGURATION_TARIF

21,26 Paramètre de configuration des tarifs. Par défaut #CF TAR

ATTENTION : Ne laissez pas la valeur par défaut, car ce n'est pas le paramètre de recherche des tarifs que ce programme exploite, mais le paramètre de saisie des tarifs (#CF TA1 ou autre, à l'exclusion de #CF TAR).

EXTENSION_FICHIER

21,60 Extension du/des fichier(s) de tarifs à importer, sans le caractère point (unl par défaut)

NOM_REPERTOIRE

21,60 Nom du répertoire des fichiers à importer. Les fichiers sont d'extension .unl.

Ne pas mettre de slash à la fin du nom du répertoire.

Les extensions sont les suivantes :

[fichier].unl : Fichier d'importation

[fichier].err : Fichier d'anomalie

[fichier].log : Fichier de trace

[fichier].[extension].01, .02, … : Fichiers historisés

REPERTOIRE_LOG

21,60 Répertoire de destination des fichiers de logs et des rapports d'erreur

SEPARATEUR_FICHIER

21 Caractère indiquant la séparation entre 2 champs sur chaque ligne des fichiers à intégrer

- Cette note n'est prise en compte qu'en présence de notes CHAMP_FICHIER.

- En présence de notes CHAMP_FICHIER, si aucun séparateur de champs n'est défini, alors les champs sont paramétrés sur des positions fixes.

- Si vous spécifiez un séparateur de champs, il doit y avoir un séparateur de champ après le dernier champ pour que celui-ci soit pris en compte.

VALEUR_DEFAUT_CHAMP

21,38 Nom du champ – Obligatoire

On peut saisir tous les champs de la table tar0.

41,60 Valeur par défaut - Obligatoire

Paramètres utilisés

#CFTA1 ou tout autre type et code indiqué dans la note CONFIGURATION_TARIF

A2[9,11] Type de catégorie de tiers.

Structure du fichier à importer

N° | Champ | Type | Equivalence tar0
01 | Société | char(3) | tr_soc
02 | Clé | serial | tr_cle (mettre 0)
03 | Code tarif | char(3) | tr_tar
04 | Code client | char(6) | tr_cli
05 | Article | char(15) | tr_mat
06 | Famille | char(3) | tr_fam
07 | Sous-famille | char(3) | tr_sfm
08 | Catégorie du client | char(3) | tr_cat
09 | Valeur/Ajout au tarif de base | char(1) | tr_va
10 | Valeur 1 | decimal(10,2) | tr_val
11 | Valeur 2 | decimal(10,2) | tr_val2
12 | Date de début de plage de date | date | tr_datd
13 | Date de fin de plage de date | date | tr_datf
14 | Borne inférieure de plage de quantité | decimal(12,3) | tr_binf
15 | Borne supérieure de plage de quantité | decimal(12,3) | tr_bsup
16 | Devise | char(3) | tr_devise
17 | Unité | char(3) | tr_unite
18 | Prix net (O/N) | char(1) | tr_prixnet
19 | Ligne de note 1 | char(60) | tr_note_1
20 | Ligne de note 2 | char(60) | tr_note_2
21 | Valeur avant l'Euro | decimal(10,2) | tr_val_av_euro
22 | Devise avant le passage à l'Euro | char(3) | tr_devise_av_euro
23 | Bascule Euro effectuée (O/N) | char(1) | tr_bascule_euro


Saisie des tarifs multicritères

cl_act Code secteur d'activité

cl_cat Code catégorie

cl_geo Code secteur géographique

cl_orig Code origine

cl_repr Code représentant

cl_suiv Code suivi d'affaire

mp_fam Code famille

mp_foucli Code fournisseur chez le client

mp_libre Code catégorie

mp_mp Type d'article

mp_sfm Code sous-famille

tr_adr Code adresse

tr_binf Borne quantité inférieure d'application du tarif

tr_bsup Borne quantité supérieure d'application du tarif

tr_cat Code catégorie

tr_char Rubrique paramétrable

tr_cli Code client

tr_commentaire Commentaires

tr_datd Date de début d'application du tarif

tr_datf Date de fin d'application du tarif

tr_devise Code devise

tr_fam Code famille

tr_feuille_bobine Classe

tr_fixe Valeur fixe

tr_mat Code article

tr_note_1 Ligne de note 1

tr_note_2 Ligne de note 2

tr_num_binf Borne numérique inférieure d'application du tarif

tr_num_bsup Borne numérique supérieure d'application du tarif

tr_prixnet Prix net

tr_sfm Code sous-famille

tr_tar Code tarif

tr_unite Code unité

tr_va Type de tarif

tr_val Valeur

tr_val2 Valeur 2

Saisie des tarifs multicritères tar0

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_ART | Caractères 7 et suivants : code article Exemple : -N_ART[tr_mat]
-N_CLI | Caractères 7 et suivants : code client Exemple : -N_CLI[tr_cli]

Options triées

-B | Mode batch
Oac | Affiche une fenêtre avec la liste des clients concernés lors de la mise à jour des tarifs Cette fenêtre s'ouvre avant la demande de confirmation. Il est donc possible après cette fenêtre de ne pas appliquer la nouvelle tarification.
Oav | Augmentation du tarif par valeur Permet, lors de la mise à jour directe des tarifs, d'appliquer une valeur plutôt qu'un pourcentage.
Obo | Affiche en consultation un écran avec borne
Obp | Permet d'effectuer la mise à jour des prix de cession avec le PAMP de la fiche article Voir les notes MAJ_PRIX_CESSION et _SUP_REQ_MAJ_PRX_CES Nécessite la permission MEN TAR_MAJ_C
Ode | Interrogation et listes par désignation matière. Incompatible avec Ost.
Odt | Utilisation des dates d'application
Ofa | Interrogation et listes par famille
Ofs | Permet, lors de la mise à jour des tarifs, de sélectionner les familles et les sous familles des articles même si le tarif n'est pas saisi par famille - sous famille.
Oni | Non initialisation de l'écran après une validation (le dernier enregistrement reste affiché pour modification et validation suivante)
Opl | Utilisation des plages de quantité
Osf | Interrogation et listes par sous-famille
Ost | Affiche en consultation un écran type Standard. Incompatible avec Ode.
Otd | Accès direct à la saisie en tableau sans utiliser le menu
Otf | Tri figé : pas d'ouverture de fenêtre de tri
Oth | Affiche en consultation un écran type THIBAULT

Valeur alpha 2

[Rien au 04/11/2003]

Valeur alpha 3

Caractères 1 à 3 | Type de paramètre pour la zone Catégorie Tiers (tr_cat). Par défaut : CAT Mettre adr pour un code adresse de tiers au lieu d'un code paramètre Ce paramètre a priorité sur celui de la configuration de saisie des tarifs.
Caractères 4 à 18 | Code article (valeur par défaut dans la fenêtre de saisie des tarifs)
Caractères 19 à 21 | Code tarif (valeur par défaut dans la fenêtre de saisie des tarifs)
Caractères 22 à 27 | Type et code paramètre de la configuration de saisie des tarifs. à blanc par défaut Ceux-ci sont utilisés pour récupérer le type paramètre de la zone Rubrique paramétrable (alpha3[45,47]) et lancer la saisie des tarifs en tableau.

Valeur alpha 4

Caractères 1 à 60

Titre de l'édition des tarifs

Notes

ACCES_V_TAR0_EDIT | 21,26 Type et code du paramètre de lancement de la visualisation des tarifs en mode édition
ACCES_V_TAR0_VISU | 21,26 Type et code du paramètre de lancement de la visualisation des tarifs en mode visualisation
BATCH_TARIF_DATES | 21,28 Date de changement de tarif (date du jour par défaut) 30,37 Date de fin de validité du tarif (date de fin de validité du tarif en cours par défaut). Saisir une date au format JJMMAA ou JJMMAAAA ou la chaîne today pour la date du jour. Voir la note MAJ_PRIX_CESSION.
BATCH_TARIF_VALEUR | 21 Calcul du nouveau tarif basé sur le PAMP de la fiche article (O/N, O par défaut) 22 Tarif arrondi à la valeur supérieure (O/N, N par défaut). 23 Nombre de décimales de l'arrondi du tarif (0/1/2, 0 par défaut). 24 Opération appliquée pour le calcul du tarif M Ajout à la valeur initiale du montant paramétré en caractères 25 à 37. P Application à la valeur initiale du pourcentage paramétré en caractères 25 à 37. 25,37 Montant ou pourcentage à appliquer au tarif initial. Peut être positif ou négatif, mais non nul. Voir la note MAJ_PRIX_CESSION.
#CC_G_TAR0 | 21,40 Champs obligatoires de l'écran G_tarif_maj_crit de la mise à jour des tarifs (Directe) Cliquez ici pour afficher / masquer la liste des champs obligatoires triés par ordre alphabétique
#CC_G_TARIF_MAJ_CRIT | 21,40 Champs obligatoires de l'écran G_tarif_maj_crit de la mise à jour des tarifs (Historisée, Prolongation et Purge) Pour la liste des champs obligatoires, voir ci-dessus la note #CC_G_TAR0.
CSMAT | 6,60 Complément de sélection sur fiche article Exemple CSMAT and mp_at1[1,4] = "ATOS"
/E/ | 4,60 Définition des zones. Chaque champ doit se terminer par un astérisque. 1) N° identifiant le champ 2) Libellé du champ 3) Longueur du champ 4) Nombre de décimales, pour les champs numériques Voir le tableau ci-dessous pour le détail
MAJ_PRIX_CESSION | 21,23 Code tarif des prix de cession à mettre à jour (exemple #CE) 24,26 Code environnement des prix de cession à mettre à jour Cette note entièrement paramétrée est obligatoire pour l'utilisation de l'option Obp. Il est possible de paramétrer plusieurs fois cette note pour mettre à jour les tarifs dans différents environnements en mode batch. Voir les notes commençant par BATCH_TARIF. En mode manuel, seule la 1ère ligne de note est prise en compte.
NOM_FICHIER_UNLOAD | Répertoire et nom du fichier d'export de la table des tarifs Le code société, la date sous la forme YYYYMMDD et l'heure sous la forme HHMMSS seront ajoutés au nom du fichier.
_SUP_REQ_MAJ_PRX_CES | 21,60 Supplément de requête sur la table tar0 pour filtrer les prix de cession à mettre à jour.

Tableau des zones utilisables dans les notes commençant par /E/

Identifiant | Libellé | Longueur | Nb de décimales | Pour info : nom de la zone (table tar0 ou autres)
01 | Code client | 6 |  | tr_cli
02 | Nom du client | 30 |  | nom_tr_cli
03 | Code produit | 15 |  | tr_mat
04 | Désignation du produit | 40 |  | mp_des
05 | Code tarif | 3 |  | tr_tar
06 | Libellé du tarif | 10 |  | libc_tr_tar
07 | Code famille | 3 |  | tr_fam
08 | Libellé de la famille | 10 |  | libc_tr_fam
09 | Code sous-famille | 3 |  | tr_sfm
10 | Libellé de la sous-famille | 10 |  | libc_tr_sfm
11 | Code catégorie du client | 3 |  | tr_cat
12 | Libellé de la catégorie du client | 10 |  | libc_tr_cat
13 | Type de valorisation (V, A, C, %, F, L) | 1 |  | tr_va
14 | Valeur | 12 | 2 | tr_val
15 | Date d'application de début | 8 |  | tr_datd
16 | Date d'application de fin | 8 |  | tr_datf
17 | Borne inférieure de quantité | 15 | 3 | tr_binf
18 | Borne supérieure de quantité | 15 | 3 | tr_bsup
19 | Tarif Feuille ou tarif Bobine) | 1 |  | tr_feuille_bobine
20 | Prix fixe | 12 | 2 | tr_fixe
21 | Prise en compte du prix fixe (O/N) | 1 |  | tr_ajout_pr_fixe
22 | Variable paramétrable | 3 |  | tr_char
23 | Borne numérique inférieure | 15 | 3 | tr_num_binf
24 | Borne numérique supérieure | 15 | 3 | tr_num_bsup

Paramètres associés

#CF TAR | Configuration de la recherche des tarifs
#CF TA1 | Configuration de la saisie des tarifs


v_tar0 Visualisation des tarifs

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[mp_code]

Options

-N | Tarifs du code article à visualiser Exemple -NR00066D
Ora | Rafraîchissement automatique

Valeur alpha 2

Caractère 14 | Mode condensé (O/N, O par défaut)
Caractères 31 à 33 | Type paramètre de la zone Catégorie de tiers (tr_cat) Par défaut : CAT. Mettre adr pour un code adresse de tiers au lieu d'un code paramètre
Caractères 34 à 39 | Type et code paramètre de la configuration de saisie des tarifs Ceux-ci sont utilisés pour récupérer le type paramètre de la zone "Rubrique paramétrable" (alpha3[45,47). Par défaut : à blanc

Valeur alpha 4

Caractère 8 | Touche F8 autorisée (visu des tarifs) N Pas d'accès à la touche F8 O Accès à la touche F8 en consultation uniquement M Accès à la touche F8 avec les droits de modification
Caractère 44 | Touche CONTROL-K : Lancement paramétrable multiple de programmes/actions activé (O/N, N par défaut) Cette action nécessite la présence de la note _CSEL (voir ci-dessous)

Notes

S | 3,60 Complément de sélection pour la sélection des tarifs
CLIPPED_LIGNE_EF | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
_CSEL | Affichage de la colonne de sélection (colonne de droite) Cette colonne permet de sélectionner des lignes pour lesquelles on veut par exemple éditer le devis. Voir #RP
LCT_MULTI_CONFIG | 21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ Plus de détail dans le #RP
SEP_VISU_TYPE_F_CHAR | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
TEXT_LIBRE_1_V_T_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
TITRE_VISU_TYPE_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

Ordres de tris disponibles

1 | tar0.tr_tar | Code Tarif
2 | tar0.tr_cli | Code Tiers
3 | tar0.tr_mat | Code Article
4 | tar0.tr_fam | Code Famille
5 | tar0.tr_sfm | Code Sous-famille
6 | tar0.tr_cat | Catégorie tiers
7 | tar0.tr_devise | Code devise
8 | tar0.tr_prixnet | Prix net
9 | mat.mp_des | Désignation article
10 | mat.mp_des2 | Désignation complémentaire
11 | lib_etr.le_libpar1 | Référence article client
12 | lib_etr.le_libelle | Libellé spécifique
13 | lib_etr.le_libelle2 | Complément libellé
14 |  | Date de début de tarif décroissant
15 |  | Date de fin de tarif décroissant

Liste des noms de zones utilisables

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Toutes les zones du package Tiers

Table des tarifs : toutes les zones de la table + les suivantes :

nom_tr_cli | Nom du tiers (tr_cli)
des_tr_mat | Désignation de l'article
libc_tr_tar | Libellé court de tr_tar
libl_tr_tar | Libellé long de tr_tar
libc_tr_fam | Libellé court de tr_fam
libl_tr_fam | Libellé long de tr_fam
libc_tr_sfm | Libellé court de tr_sfm
libl_tr_sfm | Libellé long de tr_sfm
libc_tr_cat | Le libellé dépend de alpha2[31,33] du paramètre de lancement (voir ci-dessus) Si alpha2[31,33] = adr : Nom de l'adresse principale du tiers si la catégorie tiers n'est pas renseignée Nom de l'adresse secondaire du tiers si la catégorie tiers est renseignée Si autre : Libellé court du code catégorie tiers
libl_tr_cat | Le libellé dépend de alpha2[31,33] du paramètre de lancement (voir ci-dessus) Si alpha2[31,33] = adr : Nom de l'adresse principale du tiers si la catégorie tiers n'est pas renseignée Nom de l'adresse secondaire du tiers si la catégorie tiers est renseignée Si autre : Libellé long du code catégorie tiers
libc_tr_char | Libellé court de la rubrique paramétrable
libl_tr_char | Libellé long de la rubrique paramétrable
ref_produit | Référence produit (champ le_lib_par1)
lib_le_libellé | Libellé étranger 1
lib_le_libellé2 | Libellé étranger 2
nom_tr_adr | En rapport avec la nouvelle zone tr_adr Nom de l'adresse principale du tiers si le code adresse du tiers n'est pas renseigné. Nom de l'adresse secondaire du tiers si le code adresse du tiers est renseigné.
using | Voir #VI


Saisie des remises multicritères

Saisie des remises multicritères rem0

Options

-Odt | Utilisation des dates d'application
-Opl | Utilisation des plages de qte
-Oni | Non initialisation de l'écran après une validation (le dernier enregistrement reste affiché pour modification et validation suivante, ce qui permet des saisies rapides).

Valeur alpha3

Caractères 22 à 27

Type et code du paramètre de configuration de saisie des remises. Exemple #CF RE1, RE2, RE3, etc.

Voir aussi

#CF REM | Configuration de la recherche des remises
#CF XXX | Configuration de la saisie des remises


v_rem0 Visualisation des remises

Ordres de tris disponibles

1 | n_rem | CODE REMISE
2 | n_cli | CODE TIERS
3 | n_mat | CODE ARTICLE
4 | n_fam | CODE FAMILLE
5 | n_sfm | CODE SOUS-FAMILLE
6 | n_cat | CATEGORIE TIERS

Listes des noms de zones autorisés

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

using | Voir #VI
rm_soc | Code de la société
rm_cle | Cle unique
rm_rem | Code remise
rm_cli | Code tiers
rm_mat | Code article
rm_fam | Code famille
rm_sfm | Code sous-famille
rm_cat | Code catégorie tiers
rm_taux | Taux de remise
rm_datd | Date de début d'application
rm_datf | Date de fin d'application
rm_binf | Borne inférieure de la plage
rm_bsup | Borne supérieure de la plage
rm_note_1 | 1ère ligne de note
rm_note_2 | 2ème ligne de note
rm_anu | Annulé (O/N)
nom_rm_cli | nom du tiers (rm_cli)
des_rm_mat | désignation de l'article
libc_rm_tar | Libellé court de rm_rem
libl_rm_tar | Libellé long de rm_rem
libc_rm_fam | Libellé court de rm_fam
libl_rm_fam | Libellé long de rm_fam
libc_rm_sfm | Libellé court de rm_sfm
libl_rm_sfm | Libellé long de rm_sfm
libc_rm_cat | Libellé court de rm_cat
libl_rm_cat | Libellé long de rm_cat


Types de paramètres

Types de paramètres par01

On distingue 2 catégories de types de paramètre.

Types de paramètre Client commençant par & et types de paramètre Volume Software ne commençant pas par &.

La création et l'annulation des types de paramètre Client sont libres.

Par contre, la création et l'annulation des types de paramètre Volume Software nécessitent la saisie d'un mot de passe.

Options

Ocs | Accès à la saisie des types de paramètre en consultation uniquement
Oto | Edition de la totalité des types paramètres

La touche CONTROL-P permet de saisir des notes pour spécifier des contrôles à faire avant de pouvoir annuler des paramètres (par le programme par02).

Possibilité d'appeler un autre programme en lui passant un argument, par touche Ctrl J (voir #RP).

L'argument sera passé sous la forme -N[p2_type].

Notes sur le type de paramètre

V

Vérification avant suppression d'un type de paramètre.

Lors d'une annulation logique ou physique d'un code paramètre, des vérifications sur la base sont effectuées à partir d'un paramétrage basé sur le type du paramètre.

Exemple Lors de la suppression d'un représentant, on va vérifier qu'il n'est pas utilisé dans l'entête d'une commande, sur une fiche client, etc.

Dans le cas où le code est utilisé, la suppression logique ou physique est interdite.

(Pour info : on retrouve le même fonctionnement au niveau des articles).

Une aide à la saisie de ces notes est accessible par la touche F8, lorsque le caractère 1 de la ligne de note est V.

Les caractères 1 à 20 sont à saisir en majuscules et les caractères 21 à 60 en minuscules.

2 Type d'annulation

P Physique

L Logique

3 à 4 Numéro identifiant la vérification (sous la forme 01)

5 Caractère souligné (_)

Paramétrage des noms des tables où effectuer les vérifications

6 à 10 TABLE

21 à 60 Nom de la table

Exemples

cli, cde1, etc.

Paramétrage des jointures à effectuer

6 à 13 JOINTURE

21 à 60 Jointure (exemple : and ec_rep = )

La jointure se fera toujours sur le code paramètre.

Il ne faut donc pas remplir la zone située après le =.

Exemple

Si la vérification se fait sur le représentant 099, la requête and ec_rep = sera automatiquement complétée par 099.

Paramétrage du complément de sélection à effectuer

6 à 15 COMPSELECT

21 à 60 Complément de sélection

Exemple

and ec_tyc = "FB2"


Codes de paramètres

Codes de paramètres (par02)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-P | Action : modification Caractères 3 et suivants : type et code du paramètre Exemple : -N[REP|ec_rep]
-NF | Action : saisie des sous-familles Caractères 3 et suivants : code famille Exemple : -NF[p2_code]

Voir aussi

Généralités

Gestion de la saisie simplifiée des paramètres

Nouvelles zones dans la table des paramètres

Visualisation des paramètres

Table des codes de paramètres


v_par02 Visualisation des paramètres

Options

Ovv

Visualisation vide

Le but est de pouvoir afficher la visu vide (si aucun résultat), ceci afin de permettre quand même la possibilité de créer un paramètre avec l'action du F1.

Action F1 : En priorité on prend la note TYPE_A_INSERER

Si la note n'existe pas, alors on prend le type de paramètre éventuellement saisi dans le supplément de requête (s'il est unique).

Sinon une fenêtre de sélection d'un paramètre s'ouvrira.

Oxd

Cacher le cadre détail des visualisations

Plus d'info dans l'aide du #VI

Oxs

Ne pas passer par l'écran de sélection

Plus d'info dans l'aide du #VI

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Edition des lignes détail (N)
Caractère 4 | Active la fenêtre de sélection (O/N, O par défaut)
Caractère 31 | Affichage de la réglette (O/N)

Valeur alpha 3

Titre de la visualisation

Valeur alpha 4

Caractère 1 | Touche F1 (O/N) Insertion (les champs à saisir sont paramétré dans le F6 du par01 de ce paramètre)
Caractère 2 | Touche F2 (O/N) Suppression
Caractère 5 | Touche F5 (O/N) Visualisation de l'aide
Caractère 6 | Visualisation des sous-familles (O/N/M, N par défaut) O Accès en consultation M Accès en modification N Fonction indisponible
Caractère 8 | Touche F8 (O/N) Modification simplifiée du paramètre (les champs à saisir sont paramétré dans le F6 du par01 de ce paramètre)
Caractère 9 | Touche F9 (O/N) Affichage de la réglette de positionnement
Caractère 12 | Touche F12 (O/N) Visualisation détail paramètre
Caractère 14 | Pour le type de paramètre ECH, permet de calculer l'échéance
Caractère 15 | Touche F15 : Accès autorisé à la touche de recopie de paramètre (O/N, N par défaut)
Caractère 29 | Permettre l'accès à la saisie des liens entre tables Action Lien tables, associée à la combinaison de touches Control+Shift+F5 (F29) O Accès en consultation uniquement M Accès en modification N Action non disponible (par défaut) Voir la note CODE_LIEN_TABLES
Caractère 38 | Touche CONTROL-C (O/N)
Caractère 46 | Touche CTRL+N – Accès à la saisie des notes M Accès en modification O Accès en consultation N Accès interdit
Caractère 47 | Autoriser la touche CTRL-O (O/N, N par défaut) Cette touche/action permet d'accéder à la visualisation de la traçabilité.
Caractère 51 | Touche CONTROL-T (O/N)
Caractère 56 | Touche CONTROL-Z (O/N)

Notes

CODE_LIEN_TABLES | Code paramètre de liens entre tables à utiliser pour la saisie Voir A4[29] Doit correspondre à un paramètre de type #LI (optionnel). Par défaut : Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser.
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
NTS_NPAR02/#01/…. | Afficher les notes issues des tables notes (ligne de commande…) en indiquant le type de note. Les notes de la table par02note sont particulières car il n'y a pas de type de note. Adaptation du paramétrage des colonnes NTS_ afin de visualiser les notes la table par02note NTS_ : Mot clé standard NPAR02 : Mot clé pour la recherche des notes sur la table par02note du paramètre en cours. / : séparateur # : 1 caractère représentant le caractère par lequel va commencer la ligne de note 01 : Le numéro de ligne à recherche dans les notes
TYPE_A_INSERER | 21,23 Type du paramètre par défaut si visu vide (option Ovv) Dans le cas contraire on prend le type de paramètre de la ligne courante.

Noms de zones autorisés

par02 | Toutes les zones de la table
p1_lib | Libellé du type paramètre
p1_cat | Catégorie du type paramètre
p1_mod | Autorisation de modifier
nom_programme | Nom du programme associé au paramètre (extension incluse)
nb_utilisations | Nombre de fois où le programme a été utilisé (exécuté)
date_prem_util | Date de première utilisation
date_dern_util | Date de dernière utilisation
using | Voir #VI
p2_alph_id_if | id est l'indice de début if est l'indice de fin On affiche donc la zone p2_alph du caractère id au caractère if Exemple : p2_alph_01_10
p2_com_id_if | id est l'indice de début if est l'indice de fin On affiche donc la zone p2_com du caractère id au caractère if Exemple : p2_com_01_10
p2_alph3_id_if | id est l'indice de début if est l'indice de fin On affiche donc la zone p2_alph3 du caractère id au caractère if Exemple : p2_alph4_01_10
p2_alph4_id_if | id est l'indice de début if est l'indice de fin On affiche donc la zone p2_alph4 du caractère id au caractère if Exemple : p2_alph4_01_10


Gestion de la saisie simplifiée des paramètres

Gestion de la saisie simplifiée des paramètres gestion_param_saisie_simplifie

Notes

_SUP_REQ_NOTES | 21,60 Complément de requête sur la table notes
CODE_PARAM_DEFAUT | 23 Code paramètre correspondant au type de paramètre courant pour '’initialisation des valeurs par défaut en création

Voir aussi les notes de paramétrage de la saisie simplifiée des paramètres.


Saisie des affaires

Saisie des affaires affaire

Ce programme est opérationnel à partir de la V. 4.0.188.2

Il permet d'accéder à la saisie des affaires (jusque-là, la saisie des affaires n'était accessible que via le programme de saisie des devis et la saisie des actions).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3et suivants : N° d'affaire - Ligne d'affaire

Exemple : -N[l2_num_affaire|-|l2_lig_affaire]

Options

Ocs

Accès en consultation seule

Cette option sera utilisée dans le cadre d'un appel au programme de saisie des affaires en argument (-N)

Valeur alpha 2

A2[1,3]

Type d'enregistrement

Pour le moment, le seul type possible est DEV (valeur par défaut)

Appel à partir d'un autre programme (touche Ctrl-J)

#RP

Syntaxe : -N[l2_num_affaire|-|l2_lig_affaire]

Types d'actions possibles :

AF clé numéro d'affaire - ligne d'affaire

CL clé code client (table cli)

EC clé numéro de commande (table cde1)

FI clé devis - sous-devis - entité (table fle_imp)

L2 clé devis - sous-devis (table fle_2)

LC clé numéro de commande - Ligne de commande ( table cde2)

MP clé code produit (table mat)


Interface AV-DATA pour l'outillage

Interface AV-DATA pour l'outillage interface_avdata

Cliquez ici pour accéder au site Internet de PCTOPP avec la description des fichiers.

La structure du fichier généré peut être récupérée à l'adresse suivante : http://www.pctopp.com/download/AV Disponibilite materiaux (fr).pdf

But : Permettre d'envoyer à PC-TOPP la disponibilité des outillages via le fichier AV-DATA.

Interface PC-TOPP pour la disponibilité /non disponibilité des outillages.

2 modes de fonctionnement côté PC-TOPP.

Mode 1 : on peut envoyer le fichier partiellement. Le flag de disponibilité est envoyé dans le fichier de transfert.

Mode 2 : envoi du tableau complet des outils non disponibles.
Tout outil non présent dans le fichier est considéré comme disponible (information Steffen).
Dans ce mode, le lieu de rangement n'est pas actif.

L'interface traite tous les outils (via complément de requête sur la table des articles).

Pour chaque outil, on vérifie s'il est disponible ou non, via la validité de l'article (QA A1[20]).

Mise à jour du flag Outil disponible ou non envoyé à PC-TOPP.

S'il est disponible, la date de disponibilité est laissée à blanc puisque l'outil est disponible à l'instant T.

S'il n'est pas disponible, alors on vérifie la date de la prochaine entrée prévisionnelle en stock de cet outil (via les mouvements de stock) :

S'il y a une date de disponibilité prévisionnelle, elle est envoyée à PC-TOPP, sinon, l'outil est déclaré non disponible et sans date de disponibilité prévisionnelle.

Il n'y a plus que 2 valeurs possibles pour le type d'outil (normalisation PCTOPP) :

S Cliché (par défaut) (anciennement C)

T Forme (anciennement F)

La valeur du type d'outil est récupérée de façon hiérarchique :

1. Couple Famille/Sous-Famille de l'outil (A1[49])

2. Paramètre Sous-Famille (SFM) de l'outil (SFM A1[49])

3. Paramètre Famille (FAM) de l'outil ( FAM A3[55])

4. Par défaut : S

Valeurs numériques

1

Nombre de jours à déduire de la date du jour pour la recherche de la date de disponibilité des outillages indisponibles

Par défaut 0

La date de disponibilité des outillages indisponibles est recherchée dans les mouvements de stock d'entrée prévisionnelle et d'entrée en commande dont la date du mouvement est supérieure à la date du jour.

Un nombre de jours à déduire de la date du jour peut être paramétré en N1.

Saisir 1 pour inclure la date du jour dans la date de recherche.

Saisir 2 pour inclure la date de la veille dans la date de recherche.

etc.

Valeur alpha 2

A2[1,3] | Code du TSC donnant la date de disponibilité de la forme
A2[4,6] | Code du TSC donnant la date de disponibilité du cliché

Notes triées

ATTENTE_LIB_PCTOPP | 21,24 Durée de l'attente, en secondes, entre chaque test de la présence du verrouillage PCTOPP. Par défaut : 10
ATTENTE_LIB_VSW | 21,24 Durée de l'attente, en secondes, avant la suppression du verrouillage VoluPack. Par défaut : 0
FICHIER_AV_DATA | 21,60 Nom du fichier cible à créer
FICHIER_ERREUR | 21,60 Nom du fichier contenant les erreurs de transfert
FICHIER_LOCK_PCTOPP | 21,60 Nom du fichier de verrouillage posé par PCTOPP lors de la lecture
FICHIER_LOCK_VS | 21,60 Nom du fichier de verrouillage posé par VOLUPACK lors de l'écriture
FICHIER_TRACE | 21,60 Nom du fichier de l'historique
FICHIER_UNICITE_EXE | 21,60 Nom du fichier empêchant que l'on lance l'interface plus d'une fois
HISTORISATION | Activation de l'historique des fichiers trace et erreurs (La présence de la note active l'historisation)
_SUP_REQ_OUTIL | 21,60 Complément de sélection pour la recherche des outils à envoyer à PCTOPP (table mat) Exemple : and mp_code matches "FB*"
_SUP_REQ_STK0 | 21,60 Complément de sélection pour la recherche du mouvement de stock d'entrée prévisionnel de l'outil (Recherche de la date de disponibilité) Exemple : and s0_typ = "EO"
TRONQUER_CODE_OUTIL | Troncature des codes outils 21,22 Caractère de début à prendre en compte pour la récupération du code outil. Par défaut : 1 23,24 Caractère de fin à prendre en compte pour la récupération du code outil. Par défaut : 15 Il s'agit ici du paramétrage par défaut pour la troncature des codes outils. Le paramétrage sur la configuration des outillages est prioritaire.


Cette fonctionnalité permet d'avoir une interface claire et explicite pour effectuer le paramétrage des différentes configurations de saisie des tarifs.

Celle-ci est accessible depuis l'écran de saisie des tarifs et le programme par02. Elle permet de modifier une configuration de saisie des tarifs existante, d'en créer une nouvelle à partir d'une configuration existante, ou de la configuration par défaut.

Permissions

Les codes actions sont triés par ordre alphabétique.

Liste des codes actions

ACC | Accès aux champs
CMA | Création / Modification / Annulation d'enregistrements
MEN | Accès aux fonctions
MOD | Modifications de champs
ONG | Onglets
TOU | Touches
WIN | Applications Windows

Liste des arguments du code action ACC

ACT_EVT_EC | Possibilité de modifier les actions et les événements associés au type d'origine : Entête de commande
ACT_EVT_LC | Possibilité de modifier les actions et les événements associés au type d'origine : Ligne de commande
ACT_EVT_L2 | Possibilité de modifier les actions et les événements associés au type d'origine : Devis/Sous-devis
ACT_EVT_FI | Possibilité de modifier les actions et les événements associés au type d'origine : Entité de sous-devis
ACT_EVT_AF | Possibilité de modifier les actions et les événements associés au type d'origine : Affaire
ACT_EVT_CL | Possibilité de modifier les actions et les événements associés au type d'origine : Client
ACT_EVT_MP | Possibilité de modifier les actions et les événements associés au type d'origine : Produit fini
AIDE | Accès aide en ligne
C2_DOMB2 | Zone paramétrable du client de l'adresse secondaire
C2_NOM | Raison sociale du client de l'adresse secondaire
C2_SIRET | Code SIRET du client de l'adresse secondaire
CL_TX_COMM | Accès au taux de commission des représentants pour le client de l'adresse secondaire
CCF_DATE_CRE | Cadencements de fabrication : Date de commande
CCF_DATE_FIN | Cadencements de fabrication : Date de fin de fabrication
CCF_QTELAN | Cadencements de fabrication : Quantité lancée
CCF_RECOPIE | Cadencements de fabrication : Recopie de la ligne
CCF_REGROUPE | Cadencements de fabrication : Regrouper en cadencement
CCF_STATUT_PRD | Cadencements de fabrication : Statut du produit
CCF_TYPE_CAD | Cadencements de fabrication : Type de cadencement
CCF_VALID_PRD | Cadencements de fabrication : Ligne de cadencement validée
CL_CPT | Code comptable
CL_CRED | Accès à la zone Montant autorisation (cl_cred)
CL_DOMB | Domiciliation bancaire 2 du client principal
CL_DOMB1 | Domiciliation bancaire 1 du client principal
CL_DOMB2 | Zone paramétrable du client principal
CL_ECH | Code échéance client
CL_EDIT | Edition des traites
CL_MRG | Mode règlement client
CL_NOM | Raison sociale du client principal
CL_QUALITE | Qualité
CL_RIB | R.I.B
CL_SIRET | Code SIRET du client principal
CL_TRAC | Gestion traites acceptées
CL_TX_COMM | Accès au taux de commission des représentants pour le client principal
CRIT_OPTI_CND | Accès au choix du critère d'optimisation du conditionnement du devis onduleur (option PRO 12) La valeur par défaut du critère d'optimisation peut être paramétrée sur le TSC 210 du produit par défaut
DEBLOCAGE_CDF | Déblocage d'une commande d'achat Permission sur les actions de changement de code blocage manuel - Dans la saisie des commandes d'achat, sur l'écran des lignes, onglet blocage (action F6) - Dans la visualisation des commandes d'achat (action F49).
DON_030_CAN_IN | Permission d'accès à la zone Cannelure inversée de l'écran d'architecture automatique
DON_035_CAN_IN | Permission d'accès à la zone Cannelure inversée de l'écran d'architecture étudiée
DON_048_FOR_RD | Sélection des retraits et débords dans le calcul du conditionnement
EC_DATC | Date création commande
EC_ECH | Code échéance commande
EC_EXP | Exportation
EC_MRG | Mode règlement commande
LC_LIEU_RGT1 | Zone lieu intermédiaire de la revue de contrat
MP_PARAM | Données diverses
MP_QUALITE | Validation produit FAB
MSTK_RGT | Lieu
NOM_LONG | Nom long
NOM_LONG_2 | Nom long
PARAM_TRI_VISU | Accès aux 2 fonctions suivantes dans tous les programmes de visu : - Mettre à jour le paramétrage de tri par défaut (notes commençant par O) - Masquer la fenêtre de tri (A2[2] = N)

Liste des arguments du code action CMA

PAR02_CODE | Code paramètre
PAR02_TYPE | Type paramètre
DOSSIER_FAB | Création de dossier de fabrication

Liste des arguments du code action MEN

ACT001 | Scénario 1 (modification de la zone mp_qualite) Voir #RP, Actions à réaliser sur une sélection multiple.
ACT002 |
ACT003 |
ACT004 |
ACT005 | Passage du code actif à inactif pour les paramètres actifs Voir #RP, Actions à réaliser sur une sélection multiple.
ACT006 | Annulation logique du paramètre inactif Voir #RP, Actions à réaliser sur une sélection multiple.
ACT007 | Passage du code inactif à actif pour les paramètres inactifs Voir #RP, Actions à réaliser sur une sélection multiple.
ACT008 | Suppression d'articles Voir #RP, Actions à réaliser sur une sélection multiple.
ACT009 | Suppression de tiers Voir #RP, Actions à réaliser sur une sélection multiple.
ACT010 | Saisie d'un BL avec une liste de ligne de commande ayant la même adresse de livraison Voir #RP, Actions à réaliser sur une sélection multiple.
ACT011 | Mise à jour du représentant depuis la visu des tiers Voir #RP, Actions à réaliser sur une sélection multiple.
ACT012 | Mise à jour du gestionnaire depuis la visu des tiers Voir #RP, Actions à réaliser sur une sélection multiple.
ACT013 | Suppression de plusieurs devis à partir de la visualisation des devis multi-métiers Voir #RP, Actions à réaliser sur une sélection multiple.
ACT014 | Modifier l'état de l'affrètement de 1 à 2 dans la préparation des affrètements Voir #RP, Actions à réaliser sur une sélection multiple.
ACT015 | Mise à jour en masse des fiches articles Voir #RP, Actions à réaliser sur une sélection multiple.
ACT016 | Enchaîner le déblocage et l'édition d'une liste de commandes d'achat à partir de la visualisation des commandes d'achat Voir #RP, Actions à réaliser sur une sélection multiple.
ACT017 | Mise à jour de l'ordre de transport dans la visu des commandes clients Voir #RP, Actions à réaliser sur une sélection multiple.
ACT018 | Mise à jour de la fiche matière avec le nouveau seuil d'alerte et la quantité de réappro dans la visu des matières (option Oqr) Voir #RP, Actions à réaliser sur une sélection multiple.
ACT019 | Saisie simplifiée de commande multi-produits Voir #RP, Actions à réaliser sur une sélection multiple.
ACT020 | Facturer plusieurs commandes Voir #RP, Actions à réaliser sur une sélection multiple.
ACT021 | Intégrer dans fab2 uniquement les événements sélectionnés Voir #RP, Actions à réaliser sur une sélection multiple.
ANNUL_LIB_ETR | Autoriser l'annulation des libellés étrangers (action F2) (O/N, N par défaut)
ASO_ANN | Annulation action outil
ASO_CRE | Création action outil
ASO_MOD | Modification action outil
BLV_ANN | Annulation bordereau livraison
BLV_EDI | Edition bordereau livraison
BLV_EDI_BGR | Edition bordereau groupage livraison
BLV_INT | Interrogation bordereau livraison
BLV_SAI | Saisie bordereau livraison
BLV_V_QST | Editer un BL en définitif même si la quantité livrée est supérieure à la quantité commandée (avec ou sans la tolérance selon le paramétrage) - Voir l'option Ovq dans l'édition de BL -
BORTRANS_SAI | Saisie bordereau transport
BR_CDE_LIG_D | Désolde ligne depuis BR (option Ods dans bon_de_retour)
C2_CRE | Permission de créer une adresse secondaire pour un tiers (O/N, N par défaut)
CAB_SAI | Saisie CAB changement état palette
CDE_ANN | Annulation de commande
CDE_INT | Interrogation commande
CDE_LIG_ANN | Annulation de la ligne de commande déjà planifiée Voir la note CTRL_LIG_CDE_PLANI dans la saisie de commande client.
CDE_LIG_DESOL | Désolde de. Utilisé dans cde, v_cde et v_cdem la ligne de commande la ligne de nomenclature la ligne de cadencement
CDE_LIG_SOLDE | Solde de. Utilisé dans cde, v_cde et v_cdem la commande la ligne de commande la ligne de nomenclature la ligne de cadencement
CDE_MAJ_PV | Mise à jour des prix de vente des commandes
CDE_REAFFRET | Ré-affrètement commande
CDE_SAI | Saisie de commande
CDE_SOLDE | Solde commande
CLI_ANN | Annulation du tiers
CLI_CRE | Création de tiers
CLI_EDI | Edition tiers
CLI_INT | Interrogation tiers
CLI_MOD | Modification de tiers
CLI_SAI | Saisie de tiers
CLI_SIT | Situation tiers
CO_CRE | Permission de créer un correspondant pour un tiers (O/N, N par défaut)
COMPO_CRE | Création de composition
COMPO_INT | Interrogation composition
COMPO_MOD | Modification composition
COMPO_RECALC | Recalcul toutes compositions
COMPO_SUB | Substitution composition
DATE_MAJ | Accès pour la mise à jour des dates pour fusion EDI (accès refusé par défaut) Voir v_edi_cde, A4[24] et note _SUP_REQ_MAJ_DATE
DEV_ANN | Annulation de devis
DEV_CRE | Création de devis
DEV_MOD | Modification de devis
DEV_REGEN_PF | Menu permettant de lancer la régénération des PF sur un seul ou sur un ensemble de sous-devis Voir 1. TPR note PARAM_REGENERE_PF 2. TPR A4[24,29] 3. Devis standard, paramètre de lancement, A2[49,54]
DT0_ANN | Annulation données techniques
DT0_EDI | Edition données techniques
DT0_INT | Interrogation données techniques
DT0_REA | Réactualiser coûts données techniques
DT0_SAI | Saisie donnée technique
EDKP_A | Edition devis technique3
EDKP_C | Edition devis commercial
EDKP_F | Edition devis technique2
EDKP_T | Edition devis technique
EDKP_V | Edition Force de Vente
EPU_VP | Epuration VoluPack
FAC_MEM | Mémorisation facture
FAC_RED | Réédition facture
G_STD_ANN | Annulation de gamme
G_STD_EDI | Edition gamme
G_STD_INT | Interrogation gamme
G_STD_SAI | Saisie de gamme
LABO_MOD | Modification contrôle laboratoire
MAC_ANN | Annulation machine
MAC_EDI | Edition machine
MAC_INT | Interrogation machine
MAC_SAI | Saisie de machine
MAT_ANN | Annulation mat/produit
MAT_CCA | Autorisation de créer un code article en manuel malgré l'option Oaa
MAT_CRE | Création matière/produit
MAT_EDI | Edition matière/produit
MAT_INT | Interrogation matière/produit
MAT_MOD | Modification matière/produit
MAT_REC | Recopie matière/produits
MAT_SAI | Saisie matière/produit
MAT_TARIFS | Mise à jour des tarifs matière / produit
MEN_CONSTRUIRE | Accès au mode construction du menu Par défaut, cette permission est désactivée. Voir les notes commençant par MENU_ dans le paramètre USE
MEN_CRE_ENTREE | Création d'une nouvelle entrée - Réactivation d'une entrée désactivée Par défaut, cette permission est activée. Voir les notes commençant par MENU_ dans le paramètre USE
MEN_SUP_ENTREE | Suppression d'une entrée désactivée - Désactivation d'une entrée Par défaut, cette permission est désactivée. Voir les notes commençant par MENU_ dans le paramètre USE
PAR02_ANN | Annulation physique de paramètre
PAR02_EDI | Edition paramètre
PAR02_INT | Interrogation paramètre
PAR02_REC | Recopie de paramètres inter société
PAR02_SAI | Saisie de paramètre
PARAM_SAI_TAR | Aide au paramétrage de la saisie des tarifs (O/N, N par défaut) Plus d'info
POSTE_ANN | Annulation d'opération
POSTE_COHEREN | Vérifier cohérence opérations
POSTE_EDI | Edition opération
POSTE_INT | Interrogation opération
POSTE_SAI | Saisie opération
POSTE_TARIFS | Mise à jour des tarifs / opérations
POSTE_TECH | Mise à jour technique / opérations
PREPAFFRET_ET2 | Modifier un affrètement dont l'état est à 2 ou 3 Voir la note _CSEL dans la préparation des affrètements.
QUAL_CRE | Création qualité carton
QUAL_MOD | Modification qualité carton
SFAC_C/M | Création / Modification autorisées agréments
STK_ANN | Annulation stock
TARIF_SLIB_ETR | Autoriser l'accès aux tarifs (action F6) (O/N, N par défaut)
TAR_MAJ_C | Mise à jour des prix de cession Voir l'option Obp dans la saisie des tarifs.
TAR_MAJ_D | Maj tarif directe
TAR_MAJ_H | Maj tarif historisée
TAR_MAJ_P | Maj tarif prolongation
TAR_MAJ_U | Maj tarif duplication en Euro
TAR_MAJ_R | Maj tarif purge

Liste des arguments du code action MOD

BLV_IG

Modifier le BL existant

Attention : ne pas confondre avec la permission MOD BLV1_BL (ci-dessous) qui n'est activée qu'après un contrôle sur la qualité du tiers.

Ce contrôle est donc spécifique et n'est actif que dans certains cas.

La permission BLV_IG, elle, est indépendante.

BLV1_BL

Modifier le BL suite au contrôle sur la qualité du tiers

BLV2_SOLDE_AUT

Solde automatique de. Utilisé dans blv

la ligne de commande

la ligne de nomenclature

la ligne de cadencement

BLV2_DESOL_AUT

Désolde automatique de. Utilisé dans blv

la ligne de commande

la ligne de nomenclature

la ligne de cadencement

BLV2_SOLDE

Solde manuel de. Utilisé dans blv

la ligne de commande

la ligne de nomenclature

la ligne de cadencement

BLV2_DESOLDE

Désolde manuel de. Utilisé dans blv

la ligne de commande

la ligne de nomenclature

la ligne de cadencement

BRD_RAPPRO

Modifier le rapprochement d'une ligne de réception

Il est également possible d'attribuer la valeur Ignoré au rapprochement d'une ligne de réception, ce qui permet ainsi de déclarer une ligne de BRC non-facturable.

C2_DOMB2

Zone paramétrable du client de l'adresse secondaire

C2_NOM

Raison sociale du client de l'adresse secondaire

C2_SIRET

Code SIRET du client de l'adresse secondaire

C2_TX_COMM

Accès au taux de commission des représentants pour le client de l'adresse secondaire

CCF_DATE_CRE

Cadencements de fabrication : Date de commande

CCF_DATE_FIN

Cadencements de fabrication : Date de fin de fabrication

CCF_QTELAN

Cadencements de fabrication : Quantité lancée

CCF_RECOPIE

Cadencements de fabrication : Recopie de la ligne

CCF_REGROUPE

Cadencements de fabrication : Regrouper en cadencement

CCF_STATUT_PRD

Cadencements de fabrication : Statut du produit

CCF_TYPE_CAD

Cadencements de fabrication : Type de cadencement

CCF_VALID_PRD

Cadencements de fabrication : Ligne de cadencement validée

CDE1_CDE

Modifier la commande suite au contrôle sur la qualité du tiers

CDE2_REGEN

Empêcher de régénérer un besoin en modification de commande

Le message de confirmation se transforme en message d'avertissement sans donner le choix à l'utilisateur.

CL_DOMB

Domiciliation bancaire 2 du client principal

CL_DOMB1

Domiciliation bancaire 1 du client principal

CL_DOMB2

Zone paramétrable du client principal

CL_EDIT

Edition des traites

CL_NOM

Raison sociale

CL_QUALITE

Qualité

CL_RIB

R.I.B

CL_SIRET

Code SIRET

CL_TRAC

Gestion traites acceptées

CL_TX_COMM

Accès au taux de commission des représentants pour le client principal

CLI_DISTANCE

Permission de modifier la zone distance kilométrique dans la fonction d'affichage des itinéraires

CLIENT_DEV_OND

Modification du code client d'un devis onduleur. Option Omc

CPAL_DEV_OND

Modifier le code palette utilisé dans le conditionnement

Le code palette doit être affiché par la note AFFICHER_CODE_PAL dans le devis onduleur.

DESOLDE_FAB

Désolde de la fabrication de commande

DEVIS_MARGES

Permission de modification sur le tableau de saisie des marges dans le devis standard

DO_AFF

Création/Affectation d'une affaire depuis l'écran d'entête du devis onduleur

Voir la note CONFIG_AFF

EC_C1

Permission de modifier la zone paramétrable ec_c1

EC_ECH

Code échéance commande

EC_EXP

Exportation

EC_MRG

Mode règlement commande

EF_C1

Permission de modifier la zone paramétrable ef_c1

EXPED_LIG_ADL

Contrôle d'autorisation de modification de l'adresse de livraison de la ligne de groupage

EXPED_LIG_DEP

Contrôle d'autorisation de modification du lieu de destockage de la ligne de groupage

EXPED_LIG_INT

Contrôle d'autorisation de modification du lieu intermédiaire de la ligne de groupage

FACF1_TF_MOINS

Dans le contrôle des factures fournisseurs, il est autorisé de mettre une date égale au mois en cours ou une date postérieur à la date en cours. Selon la comptabilité utilisée, il est parfois nécessaire d'enregistrer des factures à une date inférieure au mois en cours pour les factures reçues en début du mois mais concernant les achats du mois dernier.

Cette permission permet à un utilisateur ou un groupe d'utilisateurs de saisir une date facture antérieure d'un mois uniquement par rapport à la date de top fin de mois.

FI_TYP_ENT

Modification du type d'entité (autorisée par défaut)

Voir la note LISTE_TEN_AUTORISES dans le TEN.

LC_DELCLI

Modification des dates en saisie de commande

LC_DELDEP

Modification des dates en saisie de commande

LC_DELFAB

Modification des dates en saisie de commande

LC_DELREP

Modification des dates en saisie de commande

LC_PRX

Prix ligne de commande

LC_REM

Pourcentage de remise sur la ligne de commande (lc_rem)

MP_PARAM

Données diverses

MP_QUALITE

Validité composition commerciale

NOM_LONG

Nom long

NOM_LONG_2

Nom long

SEL_LIGNE_AFFR

Suppression de la ligne d'affrètement de l'écran des affrètements en cours

SOLDE_FAB

Solde de la fabrication de commande

Liste des arguments du code action ONG

PREPAFFRET_AAF | Accès à affréter
PREPAFFRET_AFF | Accès gestion affrètement
PREPAFFRET_ATT | Accès en attente
PREPAFFRET_GB | Accès suivi affrètement
PREPAFFRET_REL | Accès reliquats
PREPAFFRET_SEL | Accès sélection

Liste des arguments du code action TOU

BLV1_CTRL_F

C-F sur entête BL

BLV1_CTRL_N

C-N sur entête BL

BLV1_CTRL_O

C-O sur entête BL

BLV1_F11

F11 sur entête BL

BLV1_F12

F12 sur entête BL

BLV1_F2

F2 sur entête BL

BLV1_F20

F20 sur entête BL

BLV1_F22

F22 sur entête BL

BLV1_F31

F31 sur entête BL

BLV1_F34

F34 sur entête BL

BLV1_F6

F6 sur entête BL

BLV1_F9

F9 sur entête BL

BLV2_CTRL_B

C-B sur ligne BL

BLV2_CTRL_F

C-F sur ligne BL

BLV2_CTRL_MJ_R

CTRL-MAJ-R sur ligne BL pour la gestion des retours dans la saisie des BL

BLV2_CTRL_N

C-N sur ligne BL

BLV2_CTRL_O

C-O sur ligne BL

BLV2_CTRL_R

Création d'une ligne de retour de palette consignée dans la saisie des BL

BLV2_F11

Détail textile (permet d'accéder au détail textile de la ligne de bon de livraison)

BLV2_F13

F13 sur ligne BL

BLV2_F16

F16 sur ligne BL

BLV2_F17

F17 sur ligne BL

BLV2_F19

F19 sur ligne BL

BLV2_GEN_CDE

F23 dans exped_affretements pour générer une commande depuis une ligne d'expédition

BLV2_F2

F2 sur ligne BL

BLV2_F20

F20 sur ligne BL

BLV2_F22

F22 sur ligne BL

BLV2_F29

F29 sur ligne BL

BLV2_F30

F30 sur ligne BL

BLV2_F31

F31 sur ligne BL

BLV2_F33

F33 sur ligne BL

BLV2_F8

F8 sur ligne BL

BLV2_F9

F9 sur ligne BL

BLVN_F9

F9 correction stock

BLV_QTE_FACT

Saisie quantité facturée

BORTRANS_ANN

Annulation bordereau tr

BORTRANS_CHAUF

Validation chauffeur bordereau transport

BORTRANS_COMPT

Validation comptable bordereau transport

BORTRANS_EDI

Edition bordereau transport

CBF_ACC_ACH

Dans le cadre du nouvel écran de visualisation des BL et factures : accès aux achats

Voir la note ACCES_ACHAT dans le #CF ATL - Voir aussi le #CF CBF

CBF_ACC_BL

Dans le cadre du nouvel écran de visualisation des BL et factures : accès aux bons de livraison

Voir la note ACCES_BL dans le #CF ATL - Voir aussi le #CF CBF

CBF_ACC_BR

Dans le cadre du nouvel écran de visualisation des BL et factures : accès aux bons de retour

Voir la note ACCES_BR dans le #CF ATL - Voir aussi le #CF CBF

CBF_ACC_FAC

Dans le cadre du nouvel écran de visualisation des BL et factures : accès aux factures

Voir la note ACCES_FACTURE dans le #CF ATL - Voir aussi le #CF CBF

CDE1_CTRL_B

C-B sur entête commande

CDE1_CTRL_E

C-E sur entête commande

CDE1_CTRL_F

C-F sur entête commande

CDE1_CTRL_G

C-G sur entête commande

CDE1_CTRL_N

C-N sur entête commande

CDE1_CTRL_O

C-O sur entête commande

CDE1_CTRL_W

C-W sur entête commande

CDE1_CTRL_Y

C-Y sur entête commande

CDE1_F11

F11 sur entête commande

CDE1_F12

F12 sur entête commande

CDE1_F13

F13 sur entête commande

CDE1_F14

F14 sur entête commande

CDE1_F15

F15 sur entête commande

CDE1_F16

F16 sur entête commande

CDE1_F17

F17 sur entête commande

CDE1_F18

F18 sur entête commande

CDE1_F19

F19 sur entête commande

CDE1_F20

F20 sur entête commande

CDE1_F21

F21 sur entête commande

CDE1_F22

F22 sur entête commande

CDE1_F29

F29 sur entête commande

CDE1_F31

F31 sur entête commande

CDE1_F32

F32 sur entête commande

CDE1_F34

F34 sur entête commande

CDE1_F36

F36 sur entête commande

CDE1_F6

F6 sur entête commande

CDE1_F8

F8 sur entête commande

CDE1_F9

F9 sur entête commande

CDE2_CTRL_B

C-B sur ligne commande

CDE2_CTRL_E

C-E sur ligne commande

CDE2_CTRL_F

C-F sur ligne commande

CDE2_CTRL_G

C-G sur ligne commande

CDE2_CTRL_N

C-N sur ligne commande

CDE2_CTRL_O

C-O sur ligne commande

CDE2_CTRL_P

C-P sur ligne commande

CDE2_CTRL_U

C-U sur ligne commande

CDE2_CTRL_W

C-W sur ligne commande

CDE2_CTRL_Y

C-Y sur ligne commande

CDE2_F6

F6 sur ligne commande

CDE2_F8

F8 sur ligne commande

CDE2_F9

F9 sur ligne commande

CDE2_F11

F11 sur ligne commande

CDE2_F12

F12 sur ligne commande

CDE2_F13

F13 sur ligne commande

CDE2_F14

F14 sur ligne commande

CDE2_F15

F15 sur ligne commande

CDE2_F16

F16 sur ligne commande

CDE2_F17

F17 sur ligne commande

CDE2_F18

F18 sur ligne commande

CDE2_F19

F19 sur ligne commande

CDE2_F20

F20 sur ligne commande

CDE2_F21

F21 sur ligne commande

CDE2_F22

F22 sur ligne commande

CDE2_F23

F23 sur ligne commande

CDE2_F25

F25 sur ligne commande

CDE2_F26

F26 sur ligne commande

CDE2_F27

F27 sur ligne commande

CDE2_F28

F28 sur ligne commande

CDE2_F29

F29 sur ligne commande - Modifier le code produit d'une ligne de commande existante

CDE2_F30

F30 sur ligne commande

CDE2_F31

F31 sur ligne commande

CDE2_F31_MOD

Accès en modification aux cadencements de livraison dans la saisie des commandes, sur la zone de saisie du code article (par défaut, accès en consultation uniquement)

CDE2_F32

F32 sur ligne commande

CDE2_F33

F33 sur ligne commande

CDE2_F34

F34 sur ligne commande

CDE2_F37

F37 sur ligne commande

CDE2_F39_CER

Touche F39 pour récapitulatif des coûts en environnement réel (commandes de types CD2/CD1)

Voir les notes RCP_ACCES_ORIGINES et RCP_LIB_ORIGINE_ dans le TYC.

CDE2_F39_CEV

Touche F39 pour récapitulatif des coûts en environnement prévisionnel (commandes de types CD2/CD1)

CDE2_F39_PRP

Touche F39 pour récapitulatif des coûts en environnement prévisionnel (commandes de types FBI/FB2)

CDE2_F39_PRR

Touche F39 pour récapitulatif des coûts en environnement réel (commandes de types FBI/FB2)

CDE2_F39_REV

Accès à la visualisation des coûts de l'origine REV

CDE2_F39_RER

Accès à la visualisation des coûts de l'origine RER

CDE2_RC_F15

F15 sur revue contrat

CDE2_RC_F16

F16 sur revue contrat

CDE2_RC_F23

F23 sur revue contrat

CDE2_RC_F6

F6 sur revue contrat

CDE2_RC_F9

F9 sur revue contrat

CDE_ACCES_BL

Accès au BL via commande

CDE_REED_BL

Réédition BL via commande

CDE_REED_FAC

Réédition fac via commande

CDF1_CTRL_O

CTRL-O sur l'entête de commande fournisseur - GENERO uniquement

CDF2_CTRL_O

CTRL-O sur la ligne de commande fournisseur - GENERO uniquement

CDF4_CTRL_O

CTRL-O sur la ligne de cadencement fournisseur - GENERO uniquement

CLI_NUMAUTO

Numérotation auto tiers

CLI_STATS

Statistiques tiers

CLI_TARIFS

Mise à jour des tarifs tiers

CLI_TARIFS_F30

Mise à jour des tarifs tiers

COMPO_RCP

Recopie composition

COMPO_SUP

Suppression composition

COMPO_TARIFS

Saisie des tarifs/composition

DATE_MAJ_STK_P

Modification date mise à jour stock prévisionnel (permet de modifier la date du mouvement de stock en gestion des mouvements prévisionnels)

DON_005_F13

Accès à la remise de prix

DON_020_D_F8

Touche F8 pour passer de l'architecture automatique à l'architecture étudiée (sur l'écran des produits finis).

Par défaut, l'action n'est pas autorisée.

Si l'action est autorisée, une confirmation sera demandée avant de passer en architecture étudiée.

DON_050_F13

Forçage groupabilité

DON_080_F8_DEV

Touche F8 pour récapitulatif des coûts en environnement prévisionnel

DON_080_F8_DER

Touche F8 pour récapitulatif des coûts en environnement réel

DP0_FAB0_F1

Insertion dune ligne d'OF (touche F1) (O/N, O par défaut si la permission est absente)

DP0_FAB0_F2

Suppression d'une ligne d'OF (touche F2) (O/N, O par défaut si la permission est absente)

ECMA_CTRL_O

Autorisation de la touche CTRL-O sur le code ECMA/FEFCO

ECMA2_CTRL_O

Autorisation de la touche CTRL-O sur le libellé du FEFCO dessus/dessous

ENT_DEV_F26

Contrôle d'autorisation touche F26 sur entité du devis multi-métiers

Voir la note MAJ_ENTITES_DEVIS sur le TEN

ENT_DEV_F27

Contrôle d'autorisation touche F27 sur entité du devis multi-métiers

Voir la note MAJ_ENTITES_FAB sur le TEN

ENT_DEV_F29

Mise à jour des entités ---> Variantes de quantité

Mise à jour d'informations des sous-devis et entités des variantes de quantité

ENT_DEV_SUP

Autorisation de supprimer des entités. Voir aussi SOU_DEV_SUP

EXCEL

Autorisation d'utiliser la touche Génération de fichier Excel depuis les visus

ainsi que la touche Génération de fichier Excel depuis valst

Rappel : cette génération est soumise à l'option payante WIN 3 pour les visus, et WIN 4 pour valst.

EXPED_F6

Suppression d'un affrètement qui contient au moins sur une de ses lignes un BL validé en définitif (touche F6 sur l'entête de groupage)

EXPED_LIG_F2

Contrôle d'autorisation d'annulation de la ligne de groupage (Touche F2)

FOR_PO_CTRL_O

Autorisation de la touche CTRL-O sur la formule de calcul de pointage du FEFCO dessus/dessous

F_SAI_CADF_F2

Saisie des cadencements de fabrication, on peut annuler une ligne de cadencement

F_SAI_CADF_F14

Saisie des cadencements de fabrication, on peut solder une ligne de cadencement

F_SAI_TAR_F2

Autorisation de suppression des tarifs

G_ECMA_CTRL_O

Autorisation de la touche CTRL-O sur la gamme applicable du FEFCO dessus/dessous

G_STD_D_CTRL_O

Autorisation de la touche CTRL-O sur la ligne de gamme standard - GENERO uniquement

G_STD_E_CTRL_O

Autorisation d'autorisation de la touche CTRL-O sur l'entête de gamme standard

IGNORER_ERREUR

Autoriser l'action Ignorer de la fenêtre d'erreur VoluPack

INVOICE

Re-transfert INVOICE (permet d'exécuter un re-transfert du fichier INVOICE)

LIG_BL_FACT

Ligne de BL facturable ou non (bouton de bascule de la ligne de BL à facturer ou non sur un BL définitif F13)

MAC_EFF

Effectifs standard / machines

MAC_TAUX_HIST

Taux historisation / Machines

MAC0_CTRL_O

Autorisation de la touche CTRL-O sur la machine standard

MAC2_CTRL_O

Autorisation de la touche CTRL-O sur la cadence ou le temps de la machine standard

MAC4_CTRL_O

Autorisation de la touche CTRL-O sur le taux horaire de la machine standard

MAJ_PO_CTRL_O

Autorisation de la touche CTRL-O sur la majoration par profil carton pour le calcul de pointage du FEFCO dessus/dessous

MAT_CONTRAINTES

Saisir des contraintes

Pour les devis transformateurs, ou boîte pliante, contrôler, lors de la saisie du fournisseur, que celui-ci respecte certaines contraintes techniques. Option payante BAS 30

MAT_NUMAUTO

Numéro. auto mat/produit

MAT_RGTSIT

Lieux de rangement/site mat/produit

MODIF_CDE3_LXP

C-N en modification

MODIF_PARAM

Touche F8 pour l'accès à la modification des paramètres dans la visu des paramètres

MODIF_TARIF

Modifier un tarif dans la saisie des produits (Actions > Tarifs-Remises > Accès tarifs F6)

MSTK_CRE

Entrée en stock

MSTK_CTRL_B

C-B sur maj_stk - Interrogation des stocks lot/lieux

MSTK_CTRL_N

C-N sur maj_stk

MSTK_CTRL_O

C-O sur maj_stk - Mode TEST

MSTK_CTRL_P

C-P sur maj_stk - Consultation des mouvements de stock

MSTK_CTRL_Z

C-Z sur maj_stk - Lancement de programme

MSTK_F1

F1 sur mmaj_stk - Insertion de stock

MSTK_F2

F2 sur maj_stk - Suppression de stock

MSTK_F6

F6 sur maj_stk - Regroupement de palette

MSTK_F8

F8 sur maj_stk - Consultation des mouvements de stock

MSTK_F9

F9 sur maj_stk - Eclatement de palette

MSTK_F11

F11 sur maj_stk - Visualisation des mouvements de stocks du lieu

MSTK_F12

F12 sur maj_stk - Visualisation des mouvements de stocks du lot

MSTK_F13

F13 sur maj_stk (Refente bobine/plaque)

MSTK_F14

F14 sur maj_stk (Découpe bobine/plaque)

MSTK_F15

F15 sur maj_stk (Répartition palettes)

MSTK_F16

F16 sur maj_stk - Saisie des excédents

MSTK_F17

Faire une déclaration de montage dans la correction de stock

MSTK_F19

Transfert de lot via une action F19 dans la saisie des corrections de stocks (O/N, N par défaut)

Voir les notes TMV_TRANSFERT_LOT, CTRL_PRD_TRANSF_LOT et SUP_REQ_RECH_LOT.

MSTK_F30

F30 sur maj_stk - Consultation du stock disponible

MSTK_SUP

Sortie du stock

NOTES_

Permissions sur les saisies de notes

NOTES_CC Notes sur les tiers (table cli3)

NOTES_FN_M Notes sur les devis onduleurs (table note_ldev)

NOTES_FN_O Notes sur les devis multi-métiers (table note_ldev)

NOTES_KB Notes sur les bons de livraison (table blv3)

NOTES_KC Notes sur les commandes clients (table cde3)

NOTES_KF Notes sur les commandes fournisseurs (table cdf3)

NOTES_MC Notes sur les articles (table mat3)

NOTES_NN_A Notes sur les articles (table notes)

NOTES_NN_B Notes sur les bordereaux de transport (table notes)

NOTES_NN_C Notes sur les types de paramètre (table notes)

NOTES_NN_D Notes sur les commandes (table notes)

NOTES_NN_E Notes sur les devis (table notes)

NOTES_NN_F Notes sur les factures clients (table notes)

NOTES_NN_G Notes sur les gammes standards (table notes)

NOTES_NN_H Notes sur les tiers (table notes)

NOTES_NN_I Notes sur les sous-familles (table notes)

NOTES_NN_J Notes sur les groupages/affrètements (table notes)

NOTES_NN_K Notes sur les affaires (table notes)

NOTES_NN_L Notes sur les contrôles laboratoire (table notes)

NOTES_NN_M : Notes sur les machines (table notes)

NOTES_NN_N Notes sur les non-conformités interne ou réclamations clients (table notes)

NOTES_NN_O Notes sur les demandes d'achat (table notes)

NOTES_NN_P Notes sur les permissions (table notes)

NOTES_NN_Q Notes sur les actions d'outillages (table notes)

NOTES_NN_R Notes sur les bons de réception/retour (table notes)

NOTES_NN_S Notes sur les correspondants (table notes)

NOTES_NN_T Notes sur les triplets (table notes)

NOTES_NN_U : Notes sur le suivi des dates (table notes)

NOTES_NN_V Notes sur les variantes (table notes)

NOTES_NN_W : Notes sur la nomenclature du devis multi-métiers (table notes)

NOTES_NN_X Notes sur les références multiples du devis multi-métiers (table notes)

NOTES_NN_Y Notes sur le descriptif de roulage du devis multi-métiers (table notes)

NOTES_NN_Z Notes sur les codes ECMA/FEFCO (table notes)

NOTES_NN_£ Notes sur les motifs de qualificatif/surveillance (table notes)

NOTES_NN_$ Notes sur les actions (table notes)

NOTES_NN_& Notes sur les factures fournisseurs (table notes)

NOTES_NN_3 Notes sur les remises de prix (table notes)

NOTES_NN_4 Notes sur les tarifs transporteurs (table notes)

NOTES_NN_5 Notes sur les lignes d'impression multiple du devis multi-métiers (table notes)

NOTES_NN_@ : Notes sur le détail des couleurs du devis multi-métiers (table notes)

ODV_DEV_CTRL_M

Dans la saisie du devis onduleur, permettre de modifier le code client et/ou le code adresse secondaire

POSTE_EFF

Effectifs / opérations

POSTE_TX_HIST

Taux historisation/ Opérations

RAZ_QTELIV_VAL

Permission de mettre à zéro la quantité livrée validée de la ligne de nomenclature (F23 dans v_cdem)

Cette possibilité de RAZ existe aussi dans la fenêtre de visualisation de la nomenclature (Touches F15+F23) (cde).

SBS_CTRL_O

C-O sur saisie atelier

SBS_CTRL_T

C-T sur saisie atelier

SBS_CTRL_Z

C-Z sur saisie atelier

SBS_F6

F6 sur saisie atelier

SBS_F8

Proposer l'OF en cours du salarié (option Ooc dans sbs)

SBS_F13

F13 sur saisie atelier

SBS_F17

F17 sur saisie atelier

SBS_F18

Visualisation de l'état d'avancement

SBS_F19

Edition du devis associé à l'ordre de fabrication

SBS_F21

F21 sur saisie atelier

SOU_DEV_MAJ

Mise à jour des sous-devis

Mise à jour d'informations des sous-devis et entités des variantes de quantité

SOU_DEV_SUP

Autorisation de supprimer des devis/sous-devis. Voir aussi ENT_DEV_SUP

VACTIONEVT_F14

Touche F14 dans la visu des actions/événements pour l'épuration des enregistrements annulés logiquement

V_CDE5_F8

Visualisation tarifs (permet de visualiser les tarifs)

VCDEM_F14

Permission sur touche F14 (facturable/non facturable)

VCDEM_F31_MOD

Accès en modification aux cadencements de livraison dans la visualisation des commandes (avec option Omc)

Si la permission n'existe pas, l'accès est en modification par défaut, sinon l'accès est soumis à la valeur de la permission.

Oui : Modification

Non : Consultation uniquement

Pwd : Sur saisie d'un mot de passe

VDEV_ACCES_DEV

Accès devis via la visu

VDEV_EDIT_DEV

Edition devis via la visualisation

VECMA_F8

Touche F8 pour l'accès à la saisie des codes ECMA/FEFCO depuis la visu des codes ECMA/FEFCO

V_EDI_BRC_F17

Permet de rapprocher les bobines d'une ligne de commande fournisseur, de générer le BRU et le BRC

Voir option Oga dans v_edi_brc.

V_EDI_CDE_STATUT

Exclusion commande via statut.(permet de passer d'un message non transférable en gestion commerciale)

V_FAB0_F6

Touche F6 pour marquer le dossier de fabrication comme généré

VFAC_CTRL_F

C-F sur visu factures

VFAC_CTRL_N

C-N sur visu factures

VFAC_F6

F6 sur visu factures

VFAC_F8

F8 sur visu factures

VFAC_F9

F9 sur visu factures

VFAC_F12

F12 sur visu factures

VFAC_F13

F13 sur visu factures

VFAC_F15

F15 sur visu factures

VFAC_F16

F16 sur visu factures

VFAC_F17

F17 sur visu factures

VFAC_F29

F29 sur visu factures

VFAC_F34

F34 sur visu factures

V_GB_F21

Autorisation touche F21 dans v_groupage_bl

V_STK0_F13

Consommation entrée normale (permet de saisir la consommation d'entrée normale)

V_STK0_F15

Modification affectation des mouvements de stock déjà intégrés (v_stk0, option Oam)

VIPOSTES_F8

Saisie des opérations élémentaires en modification

TOU/VPAR01_F8

Accès à la saisie des types de paramètres en visu des types de paramètres.

Liste des arguments du code action WIN

ACTION_1

Voir étude Picador


Suivi des actions outillage

Suivi des actions outillage G_gestion_outils

Permettre de gérer la saisie, la modification et la suppression des actions de suivi d'outillage.

Dans le cas des actions créées automatiquement, seule la visualisation du détail est accessible.

Cliquez ici pour afficher / masquer une copie d'écran.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code outil

Exemple : -N[fi_num_forme]

Options

Oga

Permet d'activer la gestion des achats : le numéro de commande d'achat doit exister dans VoluPack

Notes triées

ACCES_FICHE_OUTIL | 21,26 Type et code du paramètre de lancement de la saisie des outillages
ECRAN_DE_DEMARRAGE | 21,25 Ecran de démarrage - Ce paramètre n'est pas encore opérationnel LISTE FICHE SUIVI UTILE
_SUP_ORDER_BY_ACM | 21,60 Complément de tri sur la table action_mat Par défaut, le tri se fait par date d'action décroissante et numéro d'action. Exemple : acm_date_fin desc, acm_num
_SUP_REQ_LST_OUTILS | 21,60 Complément de requête pour la liste d'outils (table mat) - Ce paramètre n'est pas encore opérationnel
_SUP_REQ_RECH_CDEF | 21,60 Complément de sélection pour la recherche de commande fournisseur (table cdf1)
_SUP_REQ_RECH_CFAB | 21,60 Complément de sélection pour la recherche de commande de fabrication (table cde1)
_SUP_REQ_RECH_LCFAB | 21,60 Complément de sélection pour la recherche de commande de fabrication (table cde2)
_SUP_REQ_RECH_MAC0 | 21,60 Complément de sélection pour la recherche de machine (table mac0)
_SUP_REQ_RECH_OUTIL | 21,60 Complément de sélection pour la recherche de code outil (table mat)

Paramètres nécessaires

ASO | Action de suivi d'outillage
#CF OUT | Configuration des outillages

Gestion des permissions

Activer les permissions suivantes :

MEN ASO_CRE Autorisation de créer une action de suivi d'outillage manuelle ou automatique (Oui / Non / sur mot de Passe)

MEN ASO_MOD Autorisation de modifier une action de suivi d'outillage manuelle

MEN ASO_ANN Autorisation de supprimer une action de suivi d'outillage manuelle ou automatique

A propos de la recopie d'outils

Il existe actuellement 2 type de liens #LI

1. Un lien outil/machine (un outil peut être utilisé sur telle machine et inversement, une machine peut être utilisée avec tel outil).

2. Un lien outil/lieux de rangement (un outil est stocké dans le lieu de rangement et inversement, le lieu de rangement a en stock l'outil).

Dans le premier cas, pas de problèmes, l'outil nouvellement créé par recopie peut tout à fait être utilisé sur les mêmes machines que l'outil source, les liens peuvent donc être recopiés.

Par contre, dans le deuxième cas, l'outil nouvellement créé par recopie ne peut pas forcément être stocké dans les mêmes lieux de rangement que l'outil source puisque ceux-ci peuvent ne plus être disponible (exemples : le lieu de rangement est au maximum de sa capacité avec l'outil source, le lieu de rangement est mono-référence, etc.).

Dans ce cas, la recopie des liens ne doit pas être faite (c'est à l'utilisateur d'aller sur l'outil cible et de sélectionner les lieux de rangement manuellement).


Saisie des objectifs

Saisie des objectifs sai_obj

Objectif :gérer des objectifs en fonction de critères.

Un objectif peut se créer :

à un niveau primaire

à un niveau secondaire, et générer ensuite l'objectif primaire associé

En général, on saisit les objectifs annuels, puis éventuellement les pourcentages ou les objectifs mensuels.

Des touches de fonction permettent de compléter la saisie en fonction de ce qui a été fait.

On peut créer plusieurs paramètres de lancement, en fonction des objectifs à créer.

Valeur alpha 2

Caractère 1 | Initialisation du tableau des pourcentages mensuels O En création, initialisation des pourcentages N Pas d'initialisation (par défaut)
Caractère 2 | 1 rapport du nombre de jours ouvrés du mois sur le nombre de jours ouvrés de l'année, inscrit dans le calendrier FLASH_CAL, pour la partie COMMERCIALE. 2 Initialisation à partir des notes de type POURCENTAGE_MOIS

Notes triées

COMPENS_ECART | 21,22 Mois sur lequel seront imputés les écarts
EXERCICE_DEBUT | 21,30 Date début exercice (JJ/MM/YYYY) En cas d'absence des notes EXERCICE, on considère que l'objectif porte sur l'année calendaire.
EXERCICE_FIN | 21,30 Date fin exercice (JJ/MM/YYYY) En cas d'absence des notes EXERCICE, on considère que l'objectif porte sur l'année calendaire.
LIB_OBJECTIF | 13 Numéro objectif (1 à 5) 21 Objectif en Cumul ou en Moyenne (C/M) 22,32 libellé
OBJ_PRIMAIRE | 21Type (Client, Société, Paramètre) 22,24 Paramètre (REP, FAM, ...) 26,60 Libellé
OBJ_SECONDAIRE | 21 Type (Client, Société, Paramètre) 22,24 Paramètre (REP, FAM, ...) 26,60 Libellé Exemples OBJ_SECONDAIRE CCLI Obj. Client (Type C, Code CLI) OBJ_SECONDAIRE PREP Obj. Représentant (Type P , Paramètre REP) OBJ_SECONDAIRE PGEO Obj. Géographique (Type P, Paramètre GEO) OBJ_SECONDAIRE PART Obj. Article (Type P, Code ART pour saisie article, cas particulier) OBJ_SECONDAIRE SCLI Obj. Société (Type S, Code CLI La société est considérée comme le client #SOC)
POURCENTAGE_MOIS | 21,22 Numéro de mois (de 1 à 12) 23,27 Pourcentage du mois sur l'année

Les touches de fonction

F8

L'activation de cette touche sur une des colonnes objectif, permet de calculer l'objectif annuel de celui-ci par somme de ses objectifs mensuels.

F9

L'activation de cette touche sur une des colonnes objectif, permet de calculer les objectifs mensuels de celui-ci par applications des pourcentages sur l'objectif annuel.

F11

L'activation de cette touche permet de générer ou régénérer un objectif primaire par la somme de ses objectifs secondaires.

Exemple : après avoir saisi un objectif secondaire pour le représentant 100 et un secteur géographique Centre pour le représentant 100 et un secteur géographique Ouest. La touche F11 crée un objectif primaire pour le représentant 100

F12

F12 L'activation de cette touche permet de vérifier la cohérence entre l'objectif primaire et ses objectifs secondaires (pas d'écart entre les objectifs).

Exemple : si saisie de 2 objectifs secondaires sur secteur géographique pour le représentant 100 et saisie de 3 objectifs secondaires sur client pour le représentant 100.

La cohérence vérifie que la somme des objectifs secondaires secteur géographique est identique à la somme des objectifs secondaires client et à celle de l'objectif primaire du représentant.

F13

L'activation de cette touche permet de recalculer les pourcentages mensuels par rapport entre les objectifs mensuels et l'objectifs annuel de l'objectif 1

(possibilité dans ce cas de création d'écart)

F14

L'activation de cette touche permet d'imputer les différents écarts (par somme algébrique) sur les différents objectifs du mois indiqué dans la note COMPENS_ECART.

F20

L'activation de cette touche permet de calculer les 5 objectifs annuels par somme de leurs objectifs mensuels respectifs

(Idem F8 mais pour tous les objectifs annuels)

F21

L'activation de cette touche permet de calculer tous les objectifs mensuels par application des pourcentages sur leurs objectifs annuels respectifs

(idem F9 mais pour tous les objectifs)


Importation des stocks

Exemple 1

CHAMP_FICHIER_01 v0_date | Date
CHAMP_FICHIER_02 v0_lot | Commande fournisseur
CHAMP_FICHIER_03 v0_article | Code article
CHAMP_FICHIER_04 format | Format de l'article
CHAMP_FICHIER_05 v0_prix | Prix unitaire
CHAMP_FICHIER_06 v0_qte | Quantité inventoriée
CHAMP_FICHIER_07 v0_rgt2 | Emplacement
CHAMP_FICHIER_08 v0_cli | Code client

Exemple 2

CHAMP_FICHIER_01 v0_date | Date
CHAMP_FICHIER_02 v0_lot | Commande fournisseur
CHAMP_FICHIER_03 v0_article | Code article
CHAMP_FICHIER_04 v0_prix | Prix unitaire
CHAMP_FICHIER_05 v0_qte | Quantité inventoriée
CHAMP_FICHIER_06 v0_rgt1 | Code magasin
CHAMP_FICHIER_07 v0_cli | Code client
CHAMP_FICHIER_08 v0_rgt2 | Emplacement

Exemple 3

CHAMP_FICHIER_01 v0_date | Date
CHAMP_FICHIER_02 v0_lot | Commande client
CHAMP_FICHIER_03 v0_article | Code article
CHAMP_FICHIER_04 v0_qte | Quantité inventoriée
CHAMP_FICHIER_05 v0_prix | Prix unitaire
CHAMP_FICHIER_06 autre | Nom client
CHAMP_FICHIER_07 v0_rgt2 | Emplacement

CONSTANTE_FICHIER v0_rgt1 001

CONSTANTE_FICHIER v0_rgt1 PF1

Importation des stocks importation_stock

Alimentation de la table de préparation des inventaires stk_inv_0 à partir d'un fichier texte paramétrable.

Le module d'inventaire a été modifié pour tenir compte des nouveaux champs des tables

stk_inv_0 (v0_date, v0_prix, v0_cli et v0_fou) et

stk_inv_1 (v1_date, v1_prix, v1_cli et v1_fou).

Les 4 nouveaux champs de la table stk_inv_0 ne sont ni visualisables, ni modifiables, ni éditables.

Lorsque le module génère le stock inventorié à partir des bordereaux de saisie, les valeurs de ces 4 nouveaux champs sont mises dans la table stk_inv_1.

Les 4 nouveaux champs de la table stk_inv_1 ne sont pas éditables.

Lorsque le module génère les mouvements de stock de régularisation, les valeurs de ces 4 nouveaux champs sont utilisées pour initialiser le mouvement de stock (s0_datm, s0_prix, s0_cli et s0_fou de la table stk0).

Les valeurs de ces 4 nouveaux champs ne doivent pas être à nul, à zéro ou à blanc sinon l'initialisation du mouvement de stock se fera comme auparavant.

Valeurs numériques

1

Nombre de lignes par bordereau. Facultatif. Par défaut : 100

Options

Opr

Importation des stocks PROPHEE : permet de transcodifier le champ v0_lot de Prophée vers Volupack

Attention : il n'y a pas de notion de n° de ligne de commande dans PROPHEE - Vérifier les modes de valorisation (perte du couple n°de commande - n° de ligne)

Valeur alpha 2

1,3 | Code environnement (EVI). Obligatoire. Exemple : INV
4,6 | Code opérateur (OPR). Obligatoire. Exemple : DUP
7,10 | Racine des bordereaux. Compteur alphanumérique de type B. Facultatif. Exemple : INV
11 | Séparateur de champ. Obligatoire. Exemple : | (pipe)
12 | Racine des TSC d'importation des commandes clients PROPHEE. Obligatoire si option Opr. Exemple : O
13 | Racine des TSC d'importation des commandes fournisseurs PROPHEE. Obligatoire si option Opr. Exemple : P

Notes triées

CHAMP_FICHIER_ | 15,16 Numéro du champ. Obligatoire 21,38 Nom du champ. Obligatoire Champs autorisés : v0_article Code article v0_rgt1 Lieu de rangement de niveau 1 v0_rgt2 Lieu de rangement de niveau 2 v0_rgt3 Lieu de rangement de niveau 3 v0_lot Numéro du lot Lots client et fournisseur VOLUME sous la forme Lot commande : XXXXXXXX Lot commande-ligne : XXXXXXXX-999 Lots commande PROPHEE sous la forme Lot client : C/XXXX/99999999 Lot fournisseur : 99999999 v0_qte Quantité inventoriée v0_emplacement Descriptif emplacement v0_commentaire Commentaire v0_id_conteneur Identifiant du conteneur v0_date Date de la quantité inventoriée sous la forme jj/mm/aaaa v0_prix Prix de la quantité inventoriée v0_cli Code client v0_fou Code fournisseur format Format de l'article si option-Opr Format sous la forme 9999 x 9999 MM autre Autre champ Cliquez ici pour afficher / masquer des exemples.
CONSTANTE_FICHIER | 21,38 Nom du champ. Obligatoire Champs autorisés : v0_rgt1 Lieu de rangement de niveau 1 v0_rgt2 Lieu de rangement de niveau 2 v0_rgt3 Lieu de rangement de niveau 3 v0_lot Numéro du lot v0_emplacement Descriptif emplacement v0_commentaire Commentaire v0_id_conteneur Identifiant du conteneur 41,60 Constante du champ. Obligatoire Cliquez ici pour afficher / masquer des exemples.
NOM_FICHIER | 21,60 Nom du fichier des stocks à importer. Obligatoire

Paramètres nécessaires

#CF INV | A1[1] = O (oui)
EVI | A1[1] Type de commande de l'environnement (Client, Fournisseur)


Intégration de fichiers d'ordres de chargement

Intégration de fichiers d'ordres de chargement tr_groupage

Ajout du champ gb_site_prod char(3) dans la table groupage_bl

Options

Oar | Demande d'arrêt du programme
Olg | Ligne groupage depuis la séquence d'arrêt On récupère les numéros de lignes de groupage depuis la zone séquence d'arrête (zone 9) lue dans le fichier.
Otv | Le code transporteur est pris dans les caractères 74 à 79. Le code transporteur transmis par le système externe est le code VoluPack.
Oup | Arrêt du programme après un passage

Valeur alpha 2

1,4 | Nombre de minutes s'écoulant entre deux exécutions du programme (temporisation).
5 | Récupération du lieu de rangement intermédiaire de gestion (O/N, N par défaut)

Notes

FIC_GROUPAGE | 21,60 Nom + emplacement du fichier à intégrer
FIC_LOCK | 21,60 Nom + emplacement du fichier de lock garantissant l'unicité du traitement Plus d'infos
FIC_LOCK_GROUPAGE | 21,60 Nom + emplacement fichier lock fichier groupage Plus d'infos
FIC_LOCK_VS | 21,60 Nom + emplacement du fichier de lock posé par VoluPack Plus d'infos
FIC_TRACE | 21,60 Nom + emplacement du fichier trace
FIC_ANOMALIE | 21,60 Nom + emplacement du fichier d'anomalies
FIC_ARRET | 21,60 Nom + emplacement du fichier d'arrêt du programme

Paramètres nécessaires : tables de correspondances

TRS | alpha1[8,10]
POR | alpha1[18,20]
SIT | alpha1[46,50]

Structure d'une ligne

Zone | Caractères | Contenu
01 | 1 | Statut
02 | 2,4 | Code société
03 | 5,12 | Numéro de groupage
04 | 13,20 | Numéro de commande
05 | 21,23 | Ligne de commande
06 | 24,26 | Séquence de commande
07 | 27,29 | Ligne de cadencement Si différent de 0, la ligne de cadencement doit exister et ne doit pas être annulée.
08 | 30,34 | Site. Si le code site retourné n'est pas renseigné, il est identique au code site passé en paramètre. Tableau de bord du multisite
09 | 35,37 | Séquence d'arrêt
10 | 38,55 | Code client - Seuls les caractères 48 à 55 sont utilisés. Si les caractères 48 à 55 ne sont pas renseignés : Le code client est celui de la commande Le code adresse de livraison est celui de la ligne de commande si celle-ci n'est pas cadencée de la ligne de cadencement si elle est cadencée.
11 | 56,73 | Adresse de livraison : non renseignée
12 | 74,91 | Code transporteur Si l'option Otv est activée, le code transporteur est pris dans les caractères 74 à 79. Si elle n'est pas activée, on prend les caractères 84 à 91. Le code transporteur transmis par le système externe est le code VoluPack.
13 | 92,101 | Date de présentation
14 | 102,105 | Heure de présentation demandée
15 | 106,115 | Métrage linéaire
16 | 116,119 | Nombre de palettes
17 | 120,130 | Poids
18 | 131,141 | Quantité prévue
19 | 142,156 | Coût du chargement prévu
20 | 157,157 | Solde total ou partiel (T/P)
21 | 158,167 | Type de port
22 | 168,177 | Type de transport
23 | 178,187 | Type de véhicule
24 | 188,199 | ID véhicule
25 | 200,200 | Code annulation
26 | 201,218 | Magasin de départ
27 | 219,230 | Lieu de rangement. Non utilisé
28 | 231,240 | Date création affrètement
29 | 241,244 | Heure création affrètement
30 | 245,304 | Note sur la ligne de groupage


Gestion des devises

Gestion des devises devise

Voir aussi le paramètre DEV

Options

-Oim

Importation automatique sans passer par le menu.

Valeur alpha 2

Caractères 1 à ?

Nom complet du fichier d'importation. OBLIGATOIRE

Valeur alpha 3

Caractère 1 | Type de fichier pour l'importation des taux de change. Un seul format défini au 20/03/2003, de type 1 : 1ère ligne : Date sous la forme AAAAMMJJ Lignes suivantes : Caractères 1 à 3 : Devise Caractères 4 à 13 : Cours de la devise, sous la forme +EEEDDDDDD où EEE est la partie entière et DDDDDD est la partie décimale (précision de 6 chiffres après la virgule). Le résultat lu est donc divisé par 1 000 000.
Caractère 2 | M : Mise à jour du cours de la devise Autres valeurs ignorées, pas de valeur par défaut


Saisie des lieux de rangement

Saisie des lieux de rangement lieu_rgt

Ce module permet la gestion des emplacements multi-niveaux.

Les emplacements définis permettent de gérer, au niveau des transferts de stocks, le contrôle de la saisie des lieux sur trois niveaux.

Ce contrôle n'est effectif que dans le module de transfert des stocks.

so_options[26] doit être = O (permet le contrôle lors de la saisie des transferts).

L'option BAS 22 (Gestion des emplacements des produits finis) doit être activée.

Cette définition de la liste des emplacements existants permet :

  • Le contrôle de la saisie des lieux sur trois niveaux.

  • La gestion de propriétés propres à chaque lieu de rangement
    L'emplacement est-il vide ? (Oui/Non)
    Peut-il y avoir plusieurs références sur un emplacement ?

  • La gestion d'une table de détail stock par emplacement - article.

Options

Otl

Accès à la visualisation des liens entre tables (Touche F29)

Valeur alpha 2

Caractères 1 à 5

Mot de passe obligatoire

Valeur alpha 3

Caractères 1 à 3

Code Phase de traitement. Valeurs autorisées : SAI, GEE, GED (voir tableau ci-dessous)

Ce code détermine le traitement qui sera réalisé par le programme.

Notes

CODE_LIEN_TABLES

21,23 Code paramètre du lien à utiliser (type #LI)

Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser.

(si un seul code compatible existe, on le sélectionne automatiquement).

La table fille paramétrée doit être lieu_rgt_e (#LI A4[1,18])

SUP_ORDER_BY

Complément de tri pour l'édition

Exemple

order by lre_rgt1, lre_rgt2

_SUP_REQ_RECH_LIEN

21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

_SUP_SQL_REC_MAT

Complément de sélection pour la visualisation des éléments matières liés au lieu de rangement actuel (Lieu de rangement de la fiche article = Lieu de rangement saisi)

Remarque : Cette fenêtre de visualisation d'articles liés apparaît si la table fille du lien entre tables concerne la fiche article (table mat) et si aucun lien n'est trouvé dans la table liens_tables.

Les différentes phases de traitement sont :

SAI | Création / Modification / Annulation / Interrogation / Edition des emplacements
GEE | Génération Emplacements Entête. Cette fonction permet de générer, dans la table des lieux, tous les lieux existants dans la table des stocks. Elle commence par effacer tous les emplacements existants et les lignes correspondantes dans la table lieu_rgt_d. Elle met les emplacements par défaut en mono - référence et vide.
GED | Génération Emplacements Détails. Mise à jour de la table des détails emplacements à partir des emplacements déclarées dans la table des emplacements.


Société

Société soc

Voir aussi so_options.

La zone so_compta (champ code compta) permet d'indiquer le type de comptabilité.

Voir aussi le Transfert des factures fournisseurs en comptabilité, A2[3]

A | AMI
B | AGRESSO
C | CIMM
D | LD Compta
E | SETEC
F | FININFOR
G | SAGE 500
H | Variante de CCMX
I | SAARI Major
J | SAGE 100
K | SAGE 100 Grande Bretagne
L | LUMIERE
M | AI-COMPTA
N | Comptage
O | COTRE
P | PN
Q | QUADRA
R | REEL
S | SYBEL
T | TOTEM
U | EURINFO
V | VOLUCOMPTA (alias VALC)
W | L I B R E - L I B R E - L I B R E - L I B R E
X | CCMX
Y | COBYS
Z | JDE
1 | Sage 1000 ou Ciel
2 | Comptabilité ALTAI
3 | Comptabilité MAGIC
4 | Comptabilité SAP Type 3
5 | ANAEL (JDV par défaut = VTF) (JDA par défaut = ACI)
6 | VENICE Génère des fichiers au format texte pour y être importés dans une application comptable. Cela concerne les factures éditées pour les clients. #CF TRF A4[15,16] = EM


Intégration du suivi de production Direct Planning 2

Intégration du suivi de production Direct Planning 2 int_export_dp2

Ce programme est opérationnel à partir de la V. 4.1.23.2

Permet d'intégrer le suivi de production Direct Planning version 2.

Importation des fichiers d'export créés par Direct Planning 2 et mise à jour de la table fab_1_etat.

Options

Oar | Demande d'arrêt du programme (si celui-ci tourne en continu).
Ocd | Conserver les fichiers de données (ne supprime pas les fichiers d'export de Direct Planning).
Of0 | Ne pas prendre en compte fab0 pour la recherche du composant. Le rechercher sur la ligne de commande.
Oun | Le programme ne fait qu'une seule boucle de traitement.

Valeur alpha 2

A2[1,4]

Délai d'attente entre chaque boucle de traitement (en minutes)

A2[5,6]

Numéro d'entité pour l'OF dans la structure Direct Planning (de 1 à 10)

A2[7]

Méthode de calcul de la quantité planifiée sur le prévu :

1 La quantité planifiée représente celle à planifier, que l'on aura divisée par le nombre de tâches identiques.

2 La quantité planifiée est calculée en fonction celle à planifier et des durées de tâches, temps prévu de réglage et passage.

3 Récupération de la quantité prévue de Direct Planning

Notes

DELAI_TACHE_DEBUT | 21,23 Les tâches dont la date de début est antérieure à la date du jour moins le nombre de jours ne sont pas traitées. Exemple DELAI_TACHE_DEBUT 365 On exclut les tâches dont la date de début date d'un an et plus.
DELAI_TACHE_FIN | 21,23 Les tâches dont la date de fin est antérieure à la date du jour moins le nombre de jours ne sont pas traitées.
FIC_LCK_EXP_DPL | 21,60 Nom du fichier de verrouillage Direct Planning. Empêche VSW (VoluPack) de travailler en parallèle sur ce fichier.
FIC_LCK_EXP_GEN | 21,60 Nom du fichier de verrouillage général La présence de ce fichier empêche le lancement du programme en simultané.
FIC_LCK_EXP_VSW | 21,60 Nom du fichier de verrouillage VSW (VoluPack) Empêche Direct Planning de travailler en parallèle sur ce fichier.
FIC_NOM_EXP_ARR | 21,60 Nom du fichier d'arrêt pour interrompre la scrutation.
FIC_NOM_EXP_LINK | 21,60 Nom du fichier des liens exportés de Direct Planning vers VoluPack.
FIC_NOM_EXP_TASK | 21,60 Nom du fichier des tâches exportées de Direct Planning vers VoluPack.
FIC_REP_EXP | 21,60 Nom du répertoire contenant les fichiers.


Notes sur les gammes

Table g_std_n

Paramètres annexes

devis_tc Ovg | Valorisation de la gamme
devis_tc Ogf | Utilisation de la formule sur gamme
devis_tc Ofg | Contrôle faisabilité gamme
g_std Ogf | Gestion de la formule sur la gamme
#CF DEG A3[27,29] | Code de l'environnement de travail

Notes sur l'entête de la gamme

CODE_UTILISATION

21,23 Code utilisation (STD par défaut)

Notes de la gamme

CF

pour les formules (logique polonaise)

3,4 Numéro du contrôle pour cette gamme

6,60 Formule à associer aux valeurs

CM

pour les messages

3,4 Numéro du contrôle pour cette gamme

5 Type de contrôle

B Bloquant si le contrôle CV correspondant n'est pas respecté

W Warning si le contrôle CV correspondant n'est pas respecté

N Pas de contrôle

6,60 Message explicatif apparaissant en cas de rejet de la gamme.

Pour chacun des contrôles, on définit un message explicatif qui apparaîtra lorsque la gamme sera rejetée.

Le lien avec le contrôle est réalisé via le numéro de contrôle qui doit être en correspondance avec le code contrôle.

Il est possible de définir plusieurs lignes de messages pour un contrôle.

Tous ces messages seront référencés dans le récapitulatif des messages avec un numéro de phase égal à 99.

CV

pour les valeurs

3,4 Numéro du contrôle pour cette gamme

5 Espace

6 Code contrôle. Possibilité de le laisser à blanc pour un contrôle unique sans utiliser la formule

7 Espace

8 N pour contrôle numérique, A pour contrôle alphanumérique

9 Espace

10,11 Code calcul

12,18 Paramétrage code calcul

19 Espace

20,21 Test

= égal

!= différent

> supérieur

>= supérieur ou égal

< inférieur

<= inférieur ou égal

M matches (commande SQL)

!M not matches (commande SQL)

22 Espace

23,60 Valeur qui sera comparée avec le résultat du code calcul

DFPF

6,8 Délai de fabrication (en nombre de jours)

10,20 Borne inférieure de quantité

30,40 Borne supérieure de quantité


Saisie des gammes et des nomenclatures

Saisie des gammes et des nomenclatures dt0

Voir aussi #CF DT0

ATTENTION

Le mot de passe de l'annulation physique est paramétré en #FB DT0 A2[1,5]. Or, la valeur alpha 2 est aussi utilisée pour le paramétrage des colonnes d'édition.

Si vous voulez utiliser le mot de passe ET le paramétrage des colonnes d'édition, vous devez appliquer l'une des règles suivantes :

  1. Utilisez un autre paramètre que #FB DT0 comme paramètre de lancement de ce programme.
    Créez un #FB DT0 juste pour stocker le mot de passe.

  2. Si vous tenez absolument à garder #FB DT0 comme paramètre de lancement, créez un autre paramètre pour "déporter" certains paramètres, dont le paramétrage des colonnes d'édition : par exemple #XX DT0, que vous passez en argument dans le -Z, ce qui donne, dans notre exemple -Z#XXDT0.
    Attention : si vous choisissez de déporter le paramétrage, tous les paramètres déportables sont logés à la même enseigne :
    soit ils sont tous déportés, soit aucun ne l'est. Les paramètres déportables sont surlignés en jaune.

  3. Ou alors acceptez que le mot de passe soit composé des codes des 5 premières colonnes d'édition...

La méthode 2 est recommandée pour éviter les conflits de paramétrage (il y a aussi un conflit potentiel en alpha 4).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action : initialisation, par défaut : 100 Caractères 3 et suivants : Nombre de niveaux Exemple : -N25
-S | Action : initialisation Caractères 3 et suivants : Code client nomenclature Exemple : -S[ec_cli]
-P | Action :édition Caractères 3 et suivants : Code produit Exemple : -P[lc_prod]

Valeurs numériques

N1 | inutilisée ?
N2 | Nombre de décalages maximum - La valeur du #CF DT0 a priorité sur celle-ci.

Options triées

-G | Utilisation du type de gamme
-Nx | Indique le nombre de niveaux inférieurs accessible. X représente le nombre de niveaux.
-P | Indique le code produit de la nomenclature à lancer directement sans passer par le menu -P[Produit_nomenclature]
-S | Indique le nom du client spécifique à utiliser si on utilise l'option -P -S[nom_client]
-Z | Type et code pour l'accès à certains paramètres : (voir le § ATTENTION en tête de ce document)

an

Chargement et affichage de la nomenclature en mode interrogation

cd

Le mode de valorisation par défaut est : Avec le coefficient diviseur de frais fixe. Option uc obligatoire

cg

Calcul automatique gamme

cm

Calcul en heures - centièmes

cs

Consultation des données techniques

ei

Edition des infos complémentaires

el

Edition des libellés étrangers de l'article. Voir note LIB_ETR

ep

Edition du prix de vente sur l'édition échancrée

es

Edition seule

fa

Ouverture automatique de la fiche d'instruction en création de ligne de gamme

fx

Si un article est rencontre plusieurs fois dans une nomenclature, les composantes fixes des différents coûts ne sont comptabilisées qu'une seule fois en tout.

gi

Problème de valorisation avec les matières avec une gamme de sous-traitance.

gs

Utilisation des gammes standards

Permet de ne pas accéder à la gestion des gammes dans la saisie de la nomenclature

gv

Gestion gâche variable

hi

F11 : Historique des prix de revient (Sans cette option : historique des articles commandés)

hm

Calcul en heures - minutes

il

Ignore la multiplication par longueur et par largeur sur le prix de l'article.

im

Gestion imprimerie

ur l'écran figurent la passe fixe et la passe variable

LM

(Option à écrire en majuscules) Type de présentation du numéro d'OF

ls

Affichage d'un libellé stock

md

Modification interdite de la désignation, code famille et code sous-famille

Pour les nouvelles installations, il faut mettre ce paramètre par défaut

na

Numérotation automatique des produits.

Le client #SOC permet de saisir des pièces standard (fichier matière).

Le code #SOC doit exister au fichier client.

Les produits standards doivent avoir le type FAB.

ng

Edition des notes des gammes

np

Recopie automatique des notes de l'opération dans les notes de la gamme en création uniquement

pm

Prix moyen pondéré

pr

Tous les articles saisis doivent être référencés dans le fichier article

pv

Calcul à partir du prix dans l'unité de vente

re

Non utilisation repère

rl

Recopie Nomenclature avec remplacement des huit premiers caractères de chaque article

(qui doivent correspondre a un numéro de commande) de la nomenclature par un numéro de commande.

rp

Recalcul du prix de revient dans la fiche article.

Nécessite que :

la donnée technique 7 de la fiche article contienne le % de port

la donné e technique 8 de la fiche article contienne le coût de main d'oeuvre

rq

Prise en compte du type de remontée des opérations unitaires ou par quantité de nomenclatures

Utilisation de la zone unitaire ou multiplicateur des opérations pour le calcul du coût du produit

Ne fonctionne qu'au 1er niveau, c'est à dire sur le 1er sous-ensemble

t1

F11 : quantité et prix en réalisé

td

Le taux horaire utilisé pour la valorisation des gammes peut, si paramétré comme tel sur l'opération, être la somme de trois taux :

- le taux horaire de l'opération

- le taux horaire de la machine associée à l'opération

- le taux horaire du salarié société ( #SOC )

Cette option permet donc d'utiliser la valorisation standard des opérations [ f/f_recvalo.4gl ].

Le code environnement est en A4[16,18].

Sans cette option, le taux horaire retenu pour valoriser les gammes est uniquement celui de l'opération.

uc

Propose deux modes de valorisation de la nomenclature

Avec ou Sans l'utilisation du coefficient diviseur de frais fixes.

Ces modes sont libellés

Avec répartition des frais fixes

Sans répartition des frais fixes (par défaut)

On bascule d'un mode à l'autre via F17.

L'utilisation de l'option Ocd permet de proposer l'option par défaut Avec répartition des frais fixes.

Le coefficient diviseur issu de la fiche article peut être modifié dans la nomenclature via F18.

xa

Calcul au Prix d'Achat

xb

Calcul au Prix selon le Type de valorisation

xr

Calcul au Prix de revient

xv

Calcul au Prix de vente

Valeur alpha 2

A2[1,5] | Mot de passe pour la suppression physique
<OU> |
A2[1,60] | Paramétrage des colonnes à éditer Les valeurs du #CF DT0 ont priorité sur celles-ci. Valeurs par défaut : ABCDEFGPHIJKLMQRS Valeurs par défaut pour l'imprimerie (option Oim) : ABDENOPHIJKLMQR A Niveau B Séquence C Repère D Qte. Uni. E Qte. Tot. F Largeur G Longueur H Cout Mat. V. I Ct Prep. J Cout Real. K Prep. Niv. L Real. Niveau M Date N P.F. O Passe V. P Ct Mat F. Q Total Fixe R Total Variable S TOTAL T T. Matiere U T. Cout M.O. V T. Cout S.T. W TOTAL COUT X Largeur Y Longueur Z Epaisseur

Valeur alpha 3

A3[1,60]

Titre de l'écran

Valeur alpha 4

A4[1,60] | Définition des options sous forme O/N (valeurs par défaut : N) 1 Edition des cumuls 2 Tri 3 Edition des lignes détail 7 Utilisation du paramétrage du code langue - N'est plus utilisé autres codes ?
<OU> |
A4[1,12] | Contient les TYC à interdire dans l'historique des articles
A4[13,15] | Code qualité article à utiliser pour la création d'article par F12
A4[16,18] | Code environnement à utiliser dans le cas où l'option Otd est active.

Notes

3 | Séparateur de champs par type 3 b1 8 b2
E | 2,60 Liste des colonnes à éditer
N | 2,60 Complément de requête sur mat3 (note sur articles) Exemple : N and mc_type = NOM pour éditer les notes de type NOM uniquement
O | Tri 2 colonne de tri 3,60 formule de tri
S | 2,60 Complément de critère de sélection
T | 2,60 Tri par défaut
LIB_ETR | Paramétrage des colonnes à éditer pour les libellés étrangers. Seulement si l'option -Oel est présente. Notes pour récupérer le code de la zone à éditer et la longueur. Formes possibles : LIB_ETR le_libpar1 (forme 1) LIB_ETR le_libpar1*10 (forme 2) LIB_ETR le_libpar1*10* (forme 3)
_SUP_SQL_INFO_C | 21 à 60 Complément de sélection pour la recopie des TSC d'un produit vers un autre (touche F12)
CODES_INTERDITS | 21 à 35 Portion de code produit dont la création est interdite dans la nomenclature

Remarque sur les requêtes SQL

1) Comment retrouver les composants d'une nomenclature pour lesquels il n'y a pas de fiche article ?

select n0_pcsant from nom0

where n0_soc = "société"

and not exists (select mp_code from mat

where mp_soc = "société"

and mp_code = n0_pcsant)

group by n0_pcsant

order by n0_pcsant

Attention : Requête longue !

2) Comment retrouver les composants d'une nomenclature pour lesquels il n'y a pas de fiche article ?

select n1_prod from nom1

where n1_soc = "société"

and not exists (select mp_code from mat

where mp_soc = "société"

and mp_code = n1_prod )

group by n1_prod

order by n1_prod

Attention : Requête longue !


Cas d'emploi d'un produit

Cas d'emploi d'un produit cas_emp

Il faut positionner un index sur la colonne n0_pcsant de la table nom0 pour que ce programme soit efficace.

Options

Ocd

Pose la question de la mise à jour du coefficient diviseur de frais fixes

Valeur alpha 2

Caractère 1 | Code client édité 1 Code client de la nomenclature [Valeur par défaut] 2 Code client principal de la fiche article
Caractère 2 | Libellé du client édité 1 Libellé du client de la nomenclature [Valeur par défaut] 2 Libellé du client principal de la fiche article
Caractère 3 | Libellé composant ou composé 1 Libellé de la nomenclature [Valeur par défaut] 2 Libellé de la fiche article
Caractère 4 | Edition de la qualité article (O/N, N par défaut)
Caractère 5 | Edition du code qualité du composant (O/N, N par défaut)
Caractère 6 | Edition de la quantité (O/N, N par défaut)
Caractère 7 | Edition du code qualité du composé (O/N, N par défaut)
Caractère 8 | Edition du code mp_param[22] du composé (O/N, N par défaut)
Caractère 9 | Edition du libellé dump_param[22] du composé (O/N, N par défaut)
Caractère 10 | Edition de la colonne Niveau (O/N, N par défaut)

Notes

_SUP_REQ_SUR_MAT

21 à 60 Supplément de requête sur la table mat. Exemple and mat.mp_anu = "N"


Saisie des gammes standard (Industries graphiques)

Saisie des gammes standards (Industries graphiques) g_std

Voir aussi les notes sur les gammes

Voir aussi le programme de visualisation

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme.

Le programme appelant peut alors passer les paramètres suivants :

-N

Code gamme. Le passage d'un code gamme permet d'accéder directement en modification ou en consultation sur la fiche de ce code gamme.

Options

-C | Paramétrage standard des types de note à saisir Exemple : -C3ACH, pour saisir des notes de type ACH Remarque : Type de note obligatoire pour l'activation de la recopie des notes saisies sur la gamme vers les notes sur le besoin matière
Ocs | Consultation seule
Ogf | Gestion du code formule sur les gammes Voir les notes sur les gammes
Omr | Saisie de gamme standard sur machine de référence uniquement
Opa | Accès au code machine non autorisé
Opd | Accès au code difficulté non autorisé

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique
Caractère 6 | Contrôle de la suppression des gammes et des phases (Voir A2[7]) Code gamme supprimé ou code gamme de la phase supprimée présent dans le TSC 200 (zone ic_char3_1) des produits et des lignes de commande. N Pas de contrôle (Valeur par défaut) W Contrôle avec message d'avertissement C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 7 | Visualisation des produits et des lignes de commande utilisant le code gamme supprimé ou le code gamme de la phase supprimée (Voir A2[6]) (O/N, N par défaut)

Valeur alpha 3

Colonnes paramétrables pour édition détaillée. Par défaut, ABNOP

Valeur alpha 4

Colonnes paramétrables pour édition abrégée. Par défaut, ABNOP

Liste des colonnes disponibles pour les valeurs alpha 3 & 4

A | Code gamme
B | Désignation gamme
C | Couleur mini
D | Couleur maxi
E | Colisage
F | Libellé court du colisage INUTILISE
G | Libellé long du colisage INUTILISE
H | Code jonction
I | Libellé court de la jonction INUTILISE
J | Libellé long de la jonction INUTILISE
K | Code découpe
L | Libellé court de la découpe INUTILISE
M | Libellé long de la découpe INUTILISE
N | Code phase
O | Code opération
P | Libellé opération
Q | Code difficulté
R | Libellé court code difficulté
S | Libellé long code difficulté
T | Code machine
U | Libellé de la machine
V | Type (calage - roulage)
W | Libellé zone alpha 1
X | Libellé zone alpha 2
Y | Libellé zone alpha 3
Z | Libellé zone alpha 4
a | Libellé plage 1
b | Libellé plage 2
c | Libellé plage 3
d | Libellé plage 4
e | Code TTR
f | Libellé court du TTR
g | Libellé long du TTR
h | Zone paramétrée
i | Code formule
j | Libellé court du TTR
k | Libellé long du TTR
l | Libellé long du TTR
m | Libellé court du type de machine
n | Libellé long du TTR
o | Largeur minimum du papier sens travers
p | Largeur maximum du papier sens travers
q | Hauteur minimum du papier sens machine
r | Hauteur maximum du papier sens machine
s | Largeur minimum d'impression sens travers
t | Largeur maximum d'impression sens travers
u | Hauteur minimum d'impression papier sens machine
v | Hauteur maximum d'impression sens machine
w | Prise de pince minimum sens travers
x | Prise de pince maximum sens travers
y | Prise de pince minimum sens machine
z | Prise de pince maximum sens machine
0 | Machine de rattachement
1 | Libellé machine de rattachement
2 | Machine fictive (O/N)
3 | Centre de coût
4 | Libellé centre de coût
5 | Machine de référence
6 | Libellé machine de référence
7 | Délai de sécurité
8 | Site
9 | Libellé long du site
, | Libellé court du code site


Saisie des opérations (Industries graphiques)

ch_annul Annulé (O/N)

ss_cadence Cadence

ss_ch Coût horaire

ss_cletarifaire Clé tarifaire

ss_cortps Correction pour calcul du temps

ss_dif Code difficulté

ss_ff Type de frais

ss_formule_cad Formule cadence

ss_formule_tps Formule temps

ss_g_fix Gâche fixe

ss_g_var Gâche variable

ss_mac Code machine

ss_march Marge sur coût horaire machine ou Marge commerciale

ss_marps Marge sur taux des personnes supplémentaires

ss_num Clé serial

ss_ope Code opération

ss_param Zone de paramétrage

ss_persup Nombre de personnes supplémentaires

ss_pvch Prix de vente machine

ss_pvps Prix de vente des personnes supplémentaires

ss_sec Code section

ss_secana Section analytique ou centre de coût

ss_soc Code société

ss_sop Code sous-opération

ss_tps Temps standard

ss_ttr Type de TTR

ss_txps Taux horaire des personnes supplémentaires

ss_ucad Unité de cadence

ss_uqte Unité quantité

ss_utilisation Utilisation

A noter que si aucun champ du cadre Opérations ou Personnes supplémentaires n'est accessible, alors le cadre correspondant sera totalement masqué.

Saisie des opérations (Industries graphiques) l_postes

Voir aussi o0_param

Voir aussi Opérations élémentaires et dépendances

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de série de l'opération

Exemple : -N[f1_oper]

Options triées

Ocs | Consultation seule
Oga | Gestion bascule saisie gâche fixe - variable (ou exclusif) selon OP standard (P fixe, R variable)
Oma | Mise à jour des machines avec confirmation (Fenêtre F9)
Omg | Mise à jour machine dans les gammes standards (Fenêtre F9)
Omo | Mise à jour des opérations élémentaires Permet de mettre à jour des opérations élémentaires de même codes secteur, opération, sous opération, difficulté, dépendances … lorsque l'on modifie une des dépendances ou la gâche ou la cadence ou le temps de l'opération.
Omp | Possibilité de saisir des opérations sur des machines physiques à condition que la machine de référence de cette machine physique soit elle-même.
Oms | Mise à jour des machines sans confirmation (Fenêtre F9)
Opa | Aucune modification du code machine. Ni en création ni en modification. Le code machine doit être renseigne dans l'opération standard.
Opm | Modification du code machine non autorisée en modification d'opération élémentaire
Opd | Modification du code difficulté non autorisée
Opf | Modification du code formule non autorisée (Fenêtre F9)
Ose | Le code section doit être contrôlé

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour annulation physique
Caractères 6 à 11 | Type et code du paramètre de lancement de la saisie des tarifs sur la clé tarifaire

Notes

#CC_ENTETE

Possibilité de rendre inaccessibles certaines zones

21,38 Nom du champ sur lequel le contrôle s'effectue.

Liste des champs, triés par ordre alphabétique

39 Type de contrôle à effectuer :

N pas de contrôle (par défaut)

W le champ doit être saisi (non-bloquant)

B le champ doit être saisi (bloquant)

I le champ n'est pas accessible en saisie

40 Le zéro est-il significatif pour une zone numérique ?

O Le zéro est considéré comme une saisie correcte.

N Le zéro est considéré comme une saisie incorrecte (équivalent à aucune saisie) (par défaut).

Paramètres associés

#CF POS

Edition liste des postes imprimerie


Saisie des opérations (Industries mécaniques)

Saisie des opérations (Industries mécaniques) pos

Voir aussi o0_param

Voir aussi Opérations élémentaires et dépendances

Options

-Oob | Edition avec 6 décimales du temps alloue par opération (par défaut édite avec 4 décimales)
-Oto | Détermination d'un type d'opération (R ou P) si le temps de préparation est non nul et le temps alloué est nul alors le type = P (préparation - calage), sinon il est toujours égal à R (Réalisation - roulage). (Sans l'option le type d'opération est à blanc (ope0.o0_rp))
-Opv | Coût horaire utilisé = coût horaire de vente (sinon par défaut coût horaire de revient)
-Orn | Recopie des notes en même temps que la fiche opération par F15

Valeur alpha2

(paramétrage des colonnes d'édition)

A | Code opération
B | Code machine
C | Code section
D | Libellé
E | Prix de revient
F | Marge
G | Prix de vente
H | Taux Horaire (prix utilisé)
I | Temps d'attente et/ou de transit
J | Temps de préparation
K | Temps alloue
L | Forfait
M | Sous-traitance
N | Code du centre de coût
O | Zone paramétrée
P | Potentiel de charge d'une opération
Q | Nombre de postes
R | Coefficient de productivité
S | Nombre de personnes par postes
T | Cadence (1/ temps alloue)
U | Prix au 1000
V | Prix du calage
W | Taux historisé du mois en cours
X | Liste des taux de l'année en cours

Valeur alpha3

Caractères 1 à 5

Mot de passe de l'annulation physique


Saisie des machines (Industries graphiques)

Saisie des machines (Industries graphiques) machine

L'accès aux zones N° ordre et Actif est conditionné aux notes DROIT_ACCES_M0_ORDRE et DROIT_ACCES_M0_ACTIF dans le paramètre USE.

Options

-N | Code machine - Appel de la saisie des machines à partir de la visualisation des machines
Ocs | Consultation seule
Oei | Edition des infos complémentaires
Otl | Saisie des liens par tables

Notes

CODE_LIEN_TABLES | 21, 23 Code de lien par défaut (type #LI) entre les tables machine (mac0) et pli (par02) La même note existe au niveau du TMC où elle est prioritaire.
DECIMALES_GRAMMAGE | 21 Nombre de décimales à saisir et/ou à afficher dans les valeurs de grammages minimum/maximum. 0 à 3, 0 par défaut
PARAM_VISU_OPE_ELE | 21,26 Type et code du paramètre de lancement de la visualisation des opérations élémentaires
_SUP_REQ_RECH_LIEN | 21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

Compatibilité entre le vernis et la machine

Dans le devis standard, il est possible de tester la compatibilité entre le vernis et la machine.

Pour pouvoir utiliser un vernis spécifique sur une machine, le vernis doit être défini dans les TSC CV1 et/ou CV2, sur le code machine (zones F, G et / ou H).

Sur chaque machine, on peut donc associer 6 vernis différents.

Le contrôle n'est effectué que si le code machine ET le code vernis est renseigné.

Saisie des plis possibles

Dans la fenêtre de saisie des plis possibles, onglet Détail :

A1[1]

Participation du couple machine/code pli en cours de saisie à l'optimisation

O Le couple machine/code pli participe à l'optimisation (par défaut).

N Le couple machine/code pli ne participe pas à l'optimisation.

Notes sur les machines

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement du programme machine, mais des notes sur les machines !

FORMAT_PAL_INTERDIT

Note de type FPI sur la machine

21,28 Première valeur de format palette interdit

30,37 Deuxième valeur de format palette interdit

• Un format palette interdit saisi dans les notes de la machine est valable dans les deux sens
Exemple : Si le format palette interdit 800 x 900, le format 900 x 800 l'est également.

• Un format palette non trouvé dans la liste des formats interdits est considéré comme autorisé par défaut

Notes pour l'optimisation du conditionnement dans le devis onduleur

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement du programme machine, mais des notes sur les machines !

Notes de type CDT sur la dernière machine (hors PAC) de la gamme.

SUPREQSCHEMAPAL | 21,60 Complément de sélection sur par02 concernant le schéma de palettisation Voir la hiérarchie de recherche de cette note dans le paragraphe Optimisation du conditionnement dans le devis onduleur.
DEPASSEMENTLARGEUR DEPASSEMENTLONGUEUR FORMATPALETTE FORMATPALPLAQUE HAUTEURMAXPALETTE HAUTEURPALCARREE HAUTEURPALETTE HPALCARTONNIER NBMAXPILES NPALETTES RETRAITLARGEURMAX RETRAITLONGUEURMAX | Ces notes et leur hiérarchie de recherche sont décrites dans l'aide du don, au paragraphe Optimisation du conditionnement dans le devis onduleur.

Sélection des retraits et débords dans le calcul du conditionnement

Permet de sélectionner les valeurs de retraits maximum et dépassements (débords) autorisés de la palette parmi :

• Les valeurs par défaut (paramètre de lancement)

• Les valeurs saisies sur le couple gamme/machine

• Les valeurs saisies sur le client

• Les valeurs forcées dans l'écran de sélection (action F12 sur écran de conditionnement)

Les notes utilisées sont les suivantes :

DEPASSEMENTLONGUEUR

DEPASSEMENTLARGEUR

RETRAITLONGUEURMAX

RETRAITLARGEURMAX

Elles sont recherchées dans le paramètre de lancement du devis onduleur si si l'option Ocm est inactive.

Elles sont recherchées dans le paramètre de lancement de la saisie des machines (ici) si l'option Ocm est active.

Remarques

• La sélection des valeurs forcées et la modification de ces valeurs sont soumises à la permission d'accès ACC/DON_048_FOR_RD.

• Les valeurs client seront saisies sur les TSC #VR et #VD, au niveau de l'adresse secondaire si elle est saisie, puis sur l'adresse principale.

• Les valeurs forcées seront saisies sur l'écran de sélection puis enregistrées sur les TSC #VR et #VD , au niveau du code produit fini.

• Le choix des valeurs à prendre en compte sera saisi sur l'écran de sélection (cases à cocher) puis enregistré sur le TSC #VD, au niveau du code produit fini.

• Par défaut, si aucune sélection n'a encore été faite par l'utilisateur, l'ordre de sélection des valeurs est le suivant :

o Valeurs client/adresse livraison ou client/adresse principale (si saisies)

o Valeurs machine (si saisies et option Ocm)

o Valeurs par défaut

• Les valeurs machines ne sont accessibles que si l'option Ocm est paramétrée.
Attention : Ce paramétrage prend également en compte d'autres zones de calcul en plus des quatre zones de retraits/débords : hauteur palette, hauteur de la palette carrée, formats possibles de palettes. Ces dernières valeurs sont prises en compte si elles existent sur la machine, même si le calcul se fera sur les valeurs de retraits/débord par défaut, client ou forcées.


Saisie des machines (Industries mécaniques)

Saisie des machines (Industries mécaniques) machm

Options

-Opv

Coût horaire utilisé = coût horaire de vente (sinon par défaut coût horaire de revient)


Saisie des calendriers

Saisie des calendriers cal_emp

A2[48] permet de définir s'il s'agit d'un calendrier Employé (valeur par défaut) ou d'un calendrier Client.

Options

Ohc | Gestion en Heures - Centièmes (par défaut)
Ohm | Gestion en Heures - Minutes
Osa | Désactive l'obligation de saisir les plages par ordre Sans l'option, il n'est pas possible de saisir la plage 2 sans saisir la plage 1. Voir alpha4[1,3]

Les options Ohc et Ohm sont exclusives.

Si, par erreur, vous positionnez les deux, alors le système prendra en compte la dernière option que vous avez déclarée.

Valeurs numériques

1

Ecart en nombre de jours par rapport à la date du jour, permettant de définir la Date de début proposée par défaut dans chaque création - modification de calendrier.

Valeur par défaut : -10

Si on met 0, la sélection du calendrier proposé commence à la date du jour.

Si on met -7, la sélection du calendrier proposé commence une semaine plus tôt, par rapport à la date du jour.

2

Ecart en nombre de jours par rapport à la date du jour, permettant de définir la Date de fin proposée par défaut dans chaque création - modification de calendrier.

Valeur par défaut : 60

Si on met 60, la sélection du calendrier proposé finit deux mois plus tard, par rapport à la date du jour.

Valeur alpha 2

Définition des valeurs des plages horaires par défaut.

Elles doivent être indiquées dans l'unité de gestion de temps choisie ci-dessus (en Heures - Centièmes ou Heures - Minutes).

Les plages inutilisées doivent être à blanc, et non pas à zéro.

Les plages inutilisées doivent être les dernières : si vous avez 2 plages, vous ne pouvez pas utiliser par exemple les plages 1 et 3. Vous devez utiliser les plages 1 & 2, et laisser à blanc les plages 3 et 4.

La chronologie doit être respectée :

Plage1Début < Plage1Fin < Plage2Début < Plage2Fin < Plage3Début < Plage3Fin < Plage4Début < Plage4Fin

Certaines de ces plages peuvent être allouées à une fonctionnalité bien précise selon certains clients.

Cette demande sous-entend que certains contrôles puissent être désactivés par paramétrage (Option Osa).

A2[1,5] | Plage 1 - Heure de début
A2[6] | (inutilisé)
A2[7,11] | Plage 1 - Heure de fin
A2[12] | (inutilisé)
A2[13,17] | Plage 2 - Heure de début
A2[18] | (inutilisé)
A2[19,23] | Plage 2 - Heure de fin
A2[24] | (inutilisé)
A2[25,29] | Plage 3 - Heure de début
A2[30] | (inutilisé)
A2[31,35] | Plage 3 - Heure de fin
A2[36] | (inutilisé)
A2[37,41] | Plage 4 - Heure de début
A2[42] | (inutilisé)
A2[43,47] | Plage 4 - Heure de fin
A2[48] | Type de calendrier E calendrier Employé (par défaut) C calendrier Client

Valeur alpha 4

A4[1] | Contrôle de précédence entre la plage 2 et la plage 1 (O/N, O par défaut) Voir option Osa
A4[2] | Contrôle de précédence entre la plage 3 et la plage 2 (O/N, O par défaut) Voir option Osa
A4[3] | Contrôle de précédence entre la plage 4 et la plage 3 (O/N, O par défaut) Voir option Osa


Saisie des employés

Saisie des employés emp

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 à 8 : Code employé

Exemple : -N[em_code]

Options triées

-Ocx | Génération du fichier d'interface CCMX
-Opc | Pas de contrôle matricule en double
-Opv | Coût horaire utilisé = coût horaire de vente (sinon par défaut coût horaire de revient)

Notes du paramètre de lancement - Interfaçage CCMX

P_INTERFACE_CCMX_FIC | 21 à 60 Nom du fichier d'interface CCMX
P_INTERFACE_CCMX_RUB | 21 à 24 Numéro de la rubrique CCMX
P_INTERFACE_CCMX_CCC | Note apparemment supprimée (pour conversion des centres de coût) 21 à 28 Centre de coût VOLUME 29 à 34 Centre de coût CCMX

Descriptif du fichier d'interface CCMX généré

Caractères 1 à 5 | Numéro de matricule
Caractères 6 à 9 | Numéro de rubrique CCMX
Caractères 10 à 14 | Pourcentage temps
Caractères 15 à 20 | Date de début de période
Caractères 21 à 26 | Date de fin de période
Caractères 27 à 32 | Axe analytique

Renseignements divers

Mise à jour de la répartition des temps de travail par fonction et centre de coût (caractère 25 de la fiche société. Payante)

Voir TTR alpha1[32]


v_emp Visualisation des employés

Liste des ordres de tris disponibles

Voir les notes commençant par O

1 | CODE EMPLOYE
2 | NOM ET PRENOM EMPLOYE
3 | NOM ET PRENOM EMPLOYE
4 | MATRICULE
5 | DENOMINATION EMPLOYE
6 | QUALIFICATION EMPLOYE
7 | CODE CALENDRIER EMPLOYE
8 | TYPE
9 | FONCTION

Noms de zones autorisés, triés par ordre alphabétique

Table emp

Nom des zones | Zones associées
em_adr1 |
em_adr2 |
em_anul |
em_cal | libc_em_cal - libl_em_cal
em_ch |
em_chv |
em_code |
em_codp |
em_cu |
em_den | libc_em_den - libl_em_den
em_fonction |
em_libre |
em_marge |
em_matric |
em_nom |
em_of |
em_phase |
em_plage lib_em_plage | Code plage de travail de l’employé 1 Journée 2 Matin 3 Après-midi 4 Nuit
em_prenom |
em_qual | libc_em_qual - libl_em_qual
em_section | lib_em_section
em_soc |
em_tel |
em_tpsdu |
em_type |
em_ville |

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

using - Voir #VI


Saisie des libellés des centres de coût

Saisie des libellés des centres de coût g_ccout

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code centre de coût

Exemple : -N[m0_ccout]

Options

-Ocs

Consultation seulement

Valeur alpha 2

Caractères 1 à 5

Mot de passe pour l'annulation physique

Valeur alpha 3

Edition détaillée (colonnes paramétrables) Par défaut : AB

Valeur alpha 4

Edition abrégée (colonnes paramétrables) Par défaut : AB

Codes des colonnes

A | Code centre de coût
B | Libellé du centre de coût
C | Code type
D | Libellé court du type
E | Libellé long du type
F | Numéro de Rang
G | Code unité d'œuvre
H | Libellé court de l'unité d'œuvre
I | Libellé long de l'unité d'œuvre
J | Clé de répartition
K | Libellé de la cle de répartition
L | Fixe ou variable
M | Code du niveau de centre de coût
N | Libellé court du code du niveau de centre de coût
O | Libellé long du code du niveau de centre de coût


Saisie des taux horaires des centres de coût

Saisie des taux horaires des centres de coût taux_cout

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code centre de coût

Exemple : -N[m0_ccout]

Options

Ocs | Consultation seulement
Oub | Autorise la valeur nulle (ou blanc) dans la zone utilisation du tarif. Par défaut, cette zone est obligatoire.

Valeur alpha 2

Caractères 1 à 5

Mot de passe pour l'annulation physique

Valeur alpha 4

Colonnes paramétrables pour les éditions détaillée et abrégée

Par défaut : ABCDEFGHIJKL (soit toutes les colonnes disponibles)

Codes des colonnes

A | Année
B | Code centre de coût
C | Libellé centre de coût
D | Etiquette
E | Libellé court étiquette
F | Libellé long étiquette
G | Code utilisation
H | Libellé court utilisation
I | Libellé long utilisation
J | Applicabilité (mois début mois fin)
K | Taux
L | Unité


Saisie des budgets

Saisie des budgets ccout

Voir le ramme g_ccout


Saisie des pointages ECMA / FEFCO

Saisie des pointages ECMA / FEFCO pointages_ecma

Ce programme est disponible à partir de la V. 4.1.43.2

Voir aussi le programme de saisie et édition des codes FEFCO / ECMA.

Nouvelle saisie des pointages ECMA/FEFCO

Fonctionnalités

Permettre via un nouveau programme de saisir ou de simuler les pointages ECMA / FEFCO.

Remarques

• Ce programme utilise la nouvelle saisie des pointages ECMA/FEFCO

• Ce programme peut être utilisé via le lancement paramétrable des programmes (Control-J) via l'utilisation des arguments à passer en paramètres (-N_)

• L'utilisation de ce programme nécessite un code article ou un code qualité carton afin d'avoir un support pour le calcul des pointages.
Un article de simulation peut être créé et utilisé par défaut.
ATTENTION : Le calcul des pointages met à jour des informations complémentaires sur l'article (ou qualité carton). Les articles par défaut ne doivent donc en aucun cas être utilisés car les pointages mis à jour seraient alors recopiés lors de la création d'un autre article.

• La nouvelle saisie des pointages ECMA/FEFCO utilise le type de devis paramétré dans la configuration VoluPack (#CF ATL A3[12]) :

• K Mode onduleur (don)

Les informations du code ECMA dessous sont affichées.

La position de la patte est affichée.

• C Devis onduleur (odv)

• Autres valeurs Mode transformateur
Les informations du code ECMA dessous ne sont pas affichées.
La position de la patte n'est pas affichée.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_ART | Code article Exemple -N_ART[mp_code]
-N_ECM | Code ECMA/FEFCO dessus Codes ECMA/FEFCO dessus-dessous Exemples -N_ECM[kma_code] -N_ECM[up_ecma_dessus|-| up_ecma_dessous]
-N_QUA | Code qualité carton Exemple -N_QUA[mp_qualite_matiere]
-N_LON | Longueur finie Exemple -N_LON[lc_long]
-N_LAR | Largeur finie Exemple -N_LAR[lc_larg]
-N_HAU | Hauteur finie Exemple -N_HAU[lc_haut]
-N_PRO | Profil carton Exemple -N_POS[p2_code]
-N_CDE | Numéro de commande-Ligne de commande Numéro de commande-Ligne-Séquence Exemples -N_CDE[lc_num|-|lc_lig+&&&] -N_CDE[nc_num|-|nc_lig+&&&|-|nc_seq+&&&]
-N_POS | Position de la patte de jonction Exemple -N_POS[up_position_patte]
-N_DEV | Numéros de devis-Sous-devis-Entité (mode transformateur uniquement Exemples -N_DEV[l2_devis|-|l2_sdevis+&&&] -N_DEV[fi_devis|-|fi_sdevis+&&&|-|fi_entite+&&&]

Remarques à propos du passage d'argument

• Les données associées aux codes passés en argument sont chargés automatiquement si la donnée correspondante n'est pas passée elle-même en argument.
Exemple : Si le code article est passé en paramètre (-N_ART), le format fini de celui-ci est récupéré sauf si ce dernier est passé en argument (-N_LON, -N_LAR, -N_HAU).

• Le code profil carton est récupéré par défaut à partir du code qualité carton (famille ou sous-famille selon le paramétrage saisi sur #CF ATL A2[17]).

• Par défaut et systématiquement en mode transformateur, le code ECMA/FEFCO dessous est égal au code ECMA/FEFCO dessus.

• En mode transformateur, la position de patte n'est pas utilisée.

• Mode transformateur : Si un devis cohérent est passé en paramètre, les autres données sont chargées automatiquement et remplacent les données passées en argument.

Exemple pour un devis transformateur (multi-métiers) : -N_DEVD3120001-001-001

Passage du devis D3120001, sous-devis 1 et entité 1 :

 L'article sera celui de l'entité (fle_imp.fi_prod_ent)

 La qualité carton sera le support de l'entité (fle_imp.fi_c_papier)

 Le format fini sera celui de l'entité (fle_imp.fi_lon_fini, fle_imp.fi_lar_fini, fle_imp.fi_hau_fini)

 Le profil carton sera celui associé à la qualité carton

 La position de patte sera réinitialisée à blanc

IMPORTANT : A la validation de la saisie, les données spécifiques de l'entité seront mises à jour (zones fle_imp.fi_z1 à fle_imp.fi_z12) ainsi que le format ouvert (fle_imp.fi_lon_ouv et fle_imp.fi_lar_ouv) si celui-ci n'est pas forcé.

• Mode onduleur : Si un produit fini cohérent est passé en paramètre, les autres données sont chargées automatiquement et remplacent les données passées en argument. Passer en argument une ligne de commande cartonnier est équivalent à passer l'article de la ligne de commande.

Exemple pour un produit fini : -N_ARTP131200010110

Passage du PF P131200010110 :

 L'article sera le produit fini

 La qualité carton sera récupérée dans la nomenclature (SUPREQQUACAR)

 L'architecture sera récupérée dans la nomenclature (SUPREQREFARC)

 Les codes ECMA/FEFCO dessus/dessous seront ceux de l'architecture (TSC 020/030)

 Le format fini sera celui de l'architecture (mat.mp_lon, mat.mp_lar, mat.mp_hau)

 Le profil carton sera celui de l'architecture (TSC 040)

 La position de patte sera celle de l'architecture (TSC 050).

Options

Oco

Mode consultation

Les données d'entête sont saisissables selon le contexte (voir ci-dessous)

Les tableaux sont accessibles uniquement en consultation.

Ocr

Mise en place d'un code TSC de modification manuelle des pointages

Ce TSC permet, dans la saisie des devis, de demander confirmation avant le recalcul des pointages afin de ne pas écraser les pointages modifiés manuellement.

Voir la note TSC_MODIF_POINTAGES

Ose

Saisie des données d'entête autorisée

Si cette option est activée :

Tous les champs d'entête sont modifiables.

Si cette option n'est pas activée :

Seuls les champs d'entête non passés à la fonction de saisie sont modifiables

Exemple : Si un code ECMA/FEFCO dessus est passé en argument à la fonction, celui-ci n'est plus modifiable.

IMPORTANT : Les données existantes associées à un code passé en paramètre ne seront pas modifiables.

Exemple : Si un code produit est passé en argument à la fonction et que le format fini de celui-ci est renseigné, le format fini ne sera alors plus modifiable.

IMPORTANT : Lors de l'appel direct à la fonction de saisie des pointages (saisie des devis, saisie des besoins matière), les données d'entête ne sont pas modifiables.

Osi

Mode simulation

• Les données d'entête sont saisissables selon le contexte

• Les tableaux sont accessibles en modification

• Les pointages sont recalculés sans demande de confirmation

• Les données modifiables et les pointages modifiés manuellement ne sont pas enregistrés

• Si aucun code article ou qualité n'est passée en argument, le code article est automatiquement initialisé avec le code article de simulation si ce dernier est paramétré.

Notes

Le paramétrage saisi sur le paramètre de lancement du programme en cours est prioritaire sur celui saisi sur la configuration ECMA/FEFCO (#CF KMA).

ARTICLE_SIMULATION

21,35 Code article utilisé pour la simulation

Ce code servira de support pour la simulation des pointages

RAPPEL : Un article par défaut ne doit pas être utilisé comme article de simulation.

ASSURE_MODIF_FEFCO

21 Lors d'un appel en consultation, permettre de passer en modification via une action dédiée (O/N, N par défaut)

FORCE_CALC_PROD_GEN

21 Forcer le recalcul systématique des pointages pour les articles génériques (O/N, O par défaut)

MAJ_SURFACE_POIDS

21 Mise à jour des poids et surfaces brutes/nettes sur l'article (ou qualité carton) courant lors de la validation des pointages (O/N, N par défaut)

Remarques :

• Ce paramétrage n'est valable que pour une saisie directe des pointages sur un article (ou qualité carton). Il est ignoré lors de l'utilisation de la saisie via un devis, par exemple.

• Si l'article courant est associé à un devis, une demande de confirmation est faite avant de mettre à jour.

PAS_DE_MSG_RECALCUL

21 Pas de demande de confirmation avant le recalcul des pointages suite à une modification manuelle (O/N, N par défaut )

Remarque : En mode simulation (-Osi), la demande de confirmation n'est jamais affichée.

_SUP_SQL_F7_ARTICLE

21,60 Complément de sélection sur la table mat pour la recherche de l'article

_SUP_SQL_F7_QUALITE

21,60 Complément de sélection sur la table mat pour la recherche de la qualité carton

TSC_MODIF_POINTAGES

21,23 Code TSC de stockage d'une modification manuelle effectuée sur les pointages (doit correspondre à un paramètre de type TSC)

TYPE_COUTEAU

21,23 Code paramètre de type de couteau par défaut (doit correspondre à un paramètre de type CP)

TYPE_REFOULEUR

21,23 Code paramètre de type de refouleur par défaut (doit correspondre à un paramètre de type CP)


Export de la comptabilité VoluCompta vers SAP

Export de la comptabilité VoluCompta vers SAP interface_sap_compta

Génération de 4 fichiers

  1. Echéancier clients (Customer Open Items) (DCO_FI_FI003-01_)

  2. Echéancier fournisseurs (Vendor Open Items) (DCO_FI_FI003-02_)

  3. Balance générale (G/L Balance Sheet) (DCO_FI_FI004-01_)

  4. Balance analytique (G/L P & L) (DCO_FI_FI004-02_)

Options

O01 | Pas de génération du fichier Customer Open Items
O02 | Pas de génération du fichier Vendor Open Items
O03 | Pas de génération du fichier G/L Balance Sheet
O04 | Pas de génération du fichier G/L P & L

Valeur alpha 2

1,40

Nom de la base de données de comptabilité VOLUCOMPTA

Exemple : main

Notes

NOM_FICHIER_CLI_SAP | 21,60 Nom du fichier de transcodification des comptes clients VOLUCOMPTA en SAP. Obligatoire
NOM_FICHIER_COU_SAP | 21,60 Nom du fichier de transcodification des centres de coût VOLUCOMPTA en SAP Obligatoire
NOM_FICHIER_CPT_01 | 21,60 Nom du fichier Customer Open Items à générer. Facultatif CustomerOpenItems_file si non renseigné Le fichier est préfixé avec DCO_FI_FI003-01_ et suivi de l'extension .csv
NOM_FICHIER_CPT_02 | 21,60 Nom du fichier Vendor Open Items à générer. Facultatif VendorOpenItems_file si non renseigné Le fichier est préfixé avec DCO_FI_FI003-02_ et suivi de l'extension .csv
NOM_FICHIER_CPT_03 | 21,60 Nom du fichier G/L Balance Sheet à générer. Facultatif GLBalanceSheet_file si non renseigné Le fichier est préfixé avec DCO_FI_FI004-01_ et suivi de l'extension .csv
NOM_FICHIER_CPT_04 | 21,60 Nom du fichier G/L P & L à générer. Facultatif GLPL_file si non renseigné Le fichier est préfixé avec DCO_FI_FI004-02_ et suivi de l'extension .csv
NOM_FICHIER_FOU_SAP | 21,60 Nom du fichier de transcodification des comptes fournisseurs VOLUCOMPTA en SAP. Obligatoire
NOM_FICHIER_GEN_SAP | 21,60 Nom du fichier de transcodification des comptes généraux VOLUCOMPTA en SAP. Obligatoire
_SUP_REQ_TIERS_01 | 21,60 Complément de sélection sur la table tiers de la génération du fichier Customer Open Items. Facultatif
_SUP_REQ_HISTO_01 | 21,60 Complément de sélection sur la table histo de la génération du fichier Customer Open Items. Facultatif
_SUP_REQ_ECHEAN_01 | 21,60 Complément de sélection sur la table echean de la génération du fichier Customer Open Items. Facultatif
_SUP_REQ_TIERS_02 | 21,60 Complément de sélection sur la table tiers de la génération du fichier Vendor Open Items. Facultatif
_SUP_REQ_HISTO_02 | 21,60 Complément de sélection sur la table histo de la génération du fichier Vendor Open Items. Facultatif
_SUP_REQ_ECHEAN_02 | 21,60 Complément de sélection sur la table echean de la génération du fichier Vendor Open Items. Facultatif
_SUP_REQ_BALCPT_03 | 21,60 Complément de sélection sur la table balcpt de la génération du fichier G/L Balance Sheet. Facultatif Par défaut : and (balcpt.ccompte between "1" and "59999999" or balcpt.ccompte between "8" and "85999999" or balcpt.ccompte between "9" and "95999999")
_SUP_REQ_ANAHISTO_04 | 21,60 Complément de sélection sur la table anahisto de la génération du fichier G/L P & L. Facultatif Par défaut : and (anahisto.ccompte between "6" and "79999999" or anahisto.ccompte between "86" and "89999999" or anahisto.ccompte between "96" and "99999999")
NOM_FIC_ANOMALIE_01 | 21,60 Nom du fichier d'anomalie de la génération du fichier Customer Open Items. Facultatif
NOM_FIC_ANOMALIE_02 | 21,60 Nom du fichier d'anomalie de la génération du fichier Vendor Open Items. Facultatif
NOM_FIC_ANOMALIE_03 | 21,60 Nom du fichier d'anomalie de la génération du fichier G/L Balance Sheet. Facultatif
NOM_FIC_ANOMALIE_04 | 21,60 Nom du fichier d'anomalie de la génération du fichier G/L P & L. Facultatif


Export des clients vers SAP

Export des clients vers SAP interface_sap_cli

Notes

NOM_FICHIER_CLI_01 | 21,60 Nom du fichier 01. Le nom que vous indiquez ici sera préfixé avec DCO_FI_FI0001-01_ Par défaut : CustomerGeneralData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_CLI_02 | 21,60 Nom du fichier 02. Le nom que vous indiquez ici sera préfixé avec DCO_FI_FI0001-02_ Par défaut : CustomerCompagnyData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_CLI_03 | 21,60 Nom du fichier 03. Le nom que vous indiquez ici sera préfixé avec DCO_FI_FI0001-03_ Par défaut : CustomerBankData_file.csv (avec le même préfixe que ci-dessus)
NOM_FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie (optionnel)
_SUP_REQ_CLI | 21,60 Complément de requête sur la table cli (optionnel)

Paramètres nécessaires

ECH | Note CODE_ECH_EFFICIAL (code échéance)
MRG | Note CODE_MRG_EFFICIAL (mode de règlement)


Export des fournisseurs vers SAP

Export des fournisseurs vers SAP interface_sap_fou

Notes

NOM_FICHIER_FOU_01 | 21,60 Nom du fichier 01. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM002-01_ Par défaut : VendorGeneralData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_FOU_02 | 21,60 Nom du fichier 02. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM002-02_ Par défaut : VendorCompagnyData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_FOU_03 | 21,60 Nom du fichier 03. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM002-03_ Par défaut : VendorPurchasingData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_FOU_04 | 21,60 Nom du fichier 04. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM002-04_ Par défaut : VendorBankData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_FOU_05 | 21,60 Nom du fichier 05. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM002-05_ Par défaut : VendorPartnersData_file.csv (avec le même préfixe que ci-dessus)
NOM_FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie (optionnel)
_SUP_REQ_CLI | 21,60 Complément de requête sur la table cli (optionnel)

Paramètres nécessaires

ECH | Note CODE_ECH_EFFICIAL (code échéance)
MRG | Note CODE_MRG_EFFICIAL (mode de règlement)


Export des matières et stocks vers SAP

Export des matières et stocks vers SAP interface_sap_mat

Notes

NOM_FICHIER_MAT_01 | 21,60 Nom du fichier 01. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM001-01_ Par défaut : MaterialGeneralData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_MAT_02 | 21,60 Nom du fichier 02. Le nom que vous indiquez ici sera préfixé avecDCO_MM_MM001-02_ Par défaut : MaterialPlantData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_MAT_03 | 21,60 Nom du fichier 03. Le nom que vous indiquez ici sera préfixé avecDCO_MM_MM001-03_ Par défaut : MaterialDescriptionData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_MAT_04 | 21,60 Nom du fichier 04. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM001-04_ Par défaut : MaterialUnitOfMeasureData_file.csv (avec le même préfixe que ci-dessus)
NOM_FICHIER_MAT_05 | 21,60 Nom du fichier 05. Le nom que vous indiquez ici sera préfixé avec DCO_MM_MM001-05_ Par défaut : StockManagementData_file.csv (avec le même préfixe que ci-dessus)
NOM_FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie (optionnel)
_SUP_REQ_MAT | 21,60 Complément de requête sur la table mat (optionnel)
_SUP_REQ_STOCK_LL | 21,60 Complément de requête sur la table stk_lot_lieu (optionnel)

Paramètres nécessaires

FAM

Note CODE_T023_EFFICIAL : 21,29 Code équivalent T023 alimente la zone 6 du fichier 01

Note CODE_T025_EFFICIAL :21, 24 Code équivalent T025 alimente la zone 23 du fichier 02

Note CODE_T134_EFFICIAL :21,24 Code équivalent T134 alimente la zone 3 du fichier 01 et du fichier 02


Formules de calcul

Exemple de note sur formule

#IENNBVA7A4141 MC1 AKBA3

Caractères | Valeur | Description
3 à 5 | ENN | Code LCO à mettre à jour
6 | B | Code de la zone LCO Zone alphanumérique 2
7,15 | VA7A4141 | Code calcul qui donnera la valeur à mettre à jour sur le LCO Alpha[41] du paramètre VER/Type de vernis recto
16,18 |  |
19 |  |
20,34 |  |
35,43 | MC1 | Code calcul qui donnera la valeur interdisant la mise à jour Code machine recto
44 | A | Type de variable calculée Le code calcul va ramener une valeur alphanumérique
45,60 | KBA3 | Valeur à comparer au résultat du code calcul défini ci-dessus Code machine KBA3, si le code calcul ramène comme code machine recto KBA3, la valeur de LCO ne sera pas mise à jour.

LCO de génération auto de transport (Mise en place)

Zone LCO | Type de donnée | Vérification | Description | Forçage possible | Zone calculée de formule
A | Alpha (1) | Type paramètre (NTR) | Nature du transport |  |
B | Alpha (2) | Type paramètre (POR) | Type de port |  |
G | Alpha (3) | Type paramètre (O/N) | Forçage des informations |  |
1 | Numérique (1) |  | Nombre de trajets | Oui | Dimension 1 (fs_num_1)**
2 | Numérique (2) |  | Poids transporté | Oui | Dimension 2 (fs_num_1)**
 |  |  | Quantité livrée |  | Dimension 3 (fs_num_3)**
M | Alpha (matière) | Code matière (mat) | Code palette Zone obligatoire |  |
F | Alpha (fournisseur) | Code client (cli) | Code transporteur |  |

LCO de génération auto de transport (Forçage)

Zone LCO | Type de donnée | Vérification | Description | Forçage possible | Zone calculée de formule
A | Alpha (1) | Type paramètre (O/N) | Forçage des informations |  |

Remarques

  • Le code palette est obligatoire, le transport ne sera pas généré (ou supprimé s'il existe déjà) si cette zone n'est pas saisie.
    De même si le nombre de trajets n'est pas saisi et que la formule ne permet pas de le calculer (dimension 1).

  • Si le poids n'est pas saisi sur la LCO, il sera calculé automatiquement lors du calcul du transport, sinon il sera considéré comme étant forcé.

  • Si le forçage des informations saisies sur la LCO n'est pas actif, les valeurs calculées sur la formule (dimensions 1 & 2) sont prioritaires aux valeurs renseignées sur la LCO.

Formules de calcul formules

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Code phase-Code formule-Type formule

Exemple : -N[[ul_phase|-|ul_formule|-|ul_quoi]

Options

-Oco

Mode consultation

Valeur alpha 2

A2[1]

Recopie des notes lors de la création d'une formule par recopie de la formule précédente

O Les notes sont recopiées systématiquement.

N Les notes ne sont pas recopiées.

C Les notes sont recopiées selon la réponse donnée à la demande de confirmation.

[Autre] Les notes sont recopiées si l'écran des notes a été ouvert sur la formule précédente (par défaut).

Lors de la création d'une formule par recopie de la formule précédente, permettre de recopier les notes systématiquement ou sur confirmation.

Par défaut, le fonctionnement actuel est inchangé : il faut ouvrir l'écran de saisie des notes sur la formule précédente pour valider la recopie des notes.

Voir aussi : ul_param[12]

Voir aussi | Données diverses des formules : ul_param
 | Codes calculs du devis
 | Formules figées [ Sommaire, Codes et formules de calcul du devis
 | Table des formules
 | Table des notes sur les formules
 | Table des formules de calcul des pointages / dimensions
 | NDF Nature de frais, s'applique à la zone % de frais dans l'écran de saisie des formules
 | Opérations élémentaires et dépendances
v_formules | Visualisation des formules

Pour le devis mécanique standard - Dans la zone de formulation

L Longueur

l largeur

H Hauteur - épaisseur

G Grammage - poids

D Quantité totale devisée

Q Quantité du niveau immédiatement supérieur

La touche F9 donne accès à l'écran de saisie des dépendances. Chaque couple de zone est découpé ainsi :

  1. code calcul dépendance

  2. paramétrage de la dépendance
    Caractère 1 Méthode de recherche
    Caractères 2 à 4 Code du TSC
    Caractère 5 Zone TSC

Méthodes de recherche

1 | Client du devis
2 | Produit devis
3 | Produit entité
4 | Papier entité
5 | Machine impression 1
6 | Machine impression 2
7 | Machine de l'opération
8 | Matière de la formule
9 | Info. sous-devis
A | Info. entité
B | ECMA - FEFCO entité
C | Recherche machine sur les LCO de la formule
D | Matière saisie en sous-traitance (nouvelle méthode de recherche)

Notes sur les formules

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

#I (dièse I)

(I comme Isabelle)

Possibilité de mettre à jour les valeurs saisissables sur les LCO

3,5 Code LCO

Si caractère 6 = % ( le signe pourcent) :

IMR Mise à jour du code machine d'impression recto de l'entité en cours (fle_imp.fi_mac_imp)

IMV Mise à jour du code machine d'impression verso de l'entité en cours (fle_imp.fi_mac_imp2)

FMR Mise à jour du forçage de la machine d'impression recto de l'entité en cours (fle_imp.fi_mac_forcee_r)

FMV Mise à jour du forçage de la machine d'impression verso de l'entité en cours (fle_imp.fi_mac_forcee_v)

Remarque : le code calcul utilisé doit ramener une valeur alphanumérique de 1 caractère :

O Oui

N Non

M Manuel

A Automatique

S Sous-traitance

C Choix

6 Code de la zone

% Mise à jour d'une zone autre que celle d'une LCO (la liste des zones pouvant être mises à jour sera figée)

7,15 Code calcul définissant la valeur de mise à jour

<ou bien>

7,13 Mot-clé %FOR_QT : La zone de la LCO sera mise à jour à partir de la formule de calcul QT/n de la formule courante, où n représente le numéro de formule à utiliser (1 à 10), voir ci-dessous.

14,15 Numéro de la formule de calcul à utiliser pour mettre à jour la zone de la LCO :

1 Formule QT/1 (V1)

2 Formule QT/2 (V2)

3 Formule QT/3 (V1)

4 Formule QT/4 (V2)

5 Formule QT/5 (V1)

6 Formule QT/6 (V2)

7 Formule QT/7 (V1)

8 Formule QT/8 (V2)

9 Formule QT/9 (V1)

10 Formule QT/10 (V2)

16,18 Code LCO interdisant la mise à jour (optionnel)

19 Code de la zone de la LCO interdisant la mise à jour (optionnel)

20,34 Valeur qui sera testée et qui empêchera la mise à jour de la LCO

35,43 Code calcul interdisant la mise à jour (optionnel)

44 Type de variable calculée

N Numérique

A Alphanumérique (par défaut)

45,59 Valeur comparée au résultat du code calcul interdisant la mise à jour

60 Mise à jour et/ou recherche de la LCO en cascade (entité puis entête)

N Pas de recherche en cascade (la LCO à mettre à jour et la LCO optionnelle interdisant la mise à jour doivent se exister sur l'entité (par défaut)

M Mise à jour de la LCO sur l'entité si elle existe. Sinon, mise à jour de la LCO sur l'entête si elle existe.

F Recherche de la LCO interdisant la mise à jour sur l'entité si elle existe.
Sinon, recherche de la LCO sur l'entête si elle existe.

2 Mode M + Mode F

Cliquez ici pour afficher / masquer un exemple

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

#J (dièse J)

(J comme Juliette)

Ce paramétrage est équivalent à celui de la note #I (ci-dessus), avec un paramètre supplémentaire permettant de définir l'opérateur de comparaison entre la valeur calculée (LCO ou code calcul) et la valeur paramétrée.

3,5 Code de la LCO à mettre à jour

6 Code de la zone

7,15 Code calcul pour la valeur de mise à jour

16 Type de désactivation. Obligatoire, pas de valeur par défaut

L Désactivation de la mise à jour via une LCO

17,19 Code de la LCO de désactivation de la mise à jour

20 Zone de la LCO de désactivation de la mise à jour

C Désactivation de la mise à jour via un code calcul

17,25 Code calcul interdisant la mise à jour

26 Type de variable calculée

N Valeur numérique

A Valeur alphanumérique (par défaut)

27,29 Opérateur de comparaison des valeurs

DES égal (=) (par défaut)

DE! différent de (!=)

DE< strictement inférieur à (<)

DE> strictement supérieur à (>)

D<= inférieur ou égal à (<=)

D>= supérieur ou égal à (>=)

30,44 Valeur qui sera testée et qui empêchera la mise à jour de la LCO

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

#T (dièse T)

(T comme Thérèse)

Possibilité de mettre à jour les valeurs saisissables sur les TSC

3,5 Code TSC

6 Code de la zone (tous codes sauf les dates)

7,15 Code calcul définissant la valeur mise à jour

16,18 Code TSC interdisant la mise à jour (optionnel)

19 Code de la zone TSC interdisant la mise à jour (optionnel) (tous codes sauf les dates)

20,34 Valeur qui sera testée et qui empêchera l'initialisation du TSC (optionnel)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

#V (dièse V)

(V comme Valérie)

Désactiver une formule à l'aide d'un code calcul

3, 4 Code de la dépendance de référence

5, 11 Paramétrage de la dépendance de référence

12 Type de zone (A : alpha, N : numérique)

13,15 Opérateur : DES, DE>, DE< ou DE!

16, 30 Valeurs : comme au niveau des LCO (DES0 pour désactiver si la valeur numérique est à NULL ou à blanc)

ou bien, pour comparer 2 dépendances :

16, 17 : Code de la dépendance à tester

18, 24 : Paramétrage de la dépendance à tester

25, 30 : inutilisés

31, 32 DC (code en dur pour spécifier que l'argument présent de 16 à 30 est une Donnée Calculée)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

#Y (dièse Y)

(Y comme Yolande)

Désactiver une formule à l'aide d'une valeur saisie sur une LCO

3,5 Code de la LCO sur 3 caractères

6 Identification de la rubrique (M,1,2,D, etc.)

7,9 DES, DE>, DE<, DE!. ATTENTION : On peut seulement DESACTIVER (pas de ACT, AC<, AC>)

10,22 Valeurs : Comme au niveau des LCO (DES# pour désactiver si la valeur est à NULL ou à blanc)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CALCUL_MARGE

21,22 Code calcul

23,29 Paramétrage du code calcul

Voir ul_param[4] = C

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CALCUL_MARGE_FIX

21,22 Code calcul pour la marge fixe

23,29 Paramétrage du code calcul

Voir ul_param[4] = C

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CALCUL_MARGE_VAR

21,22 Code calcul pour la marge variable

23,29 Paramétrage du code calcul

Voir ul_param[4] = C

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CALCUL_NB_PASSAGES

Prise en compte du nombre de passages

21,22 Code calcul pour la prise en compte du nombre de passages (MP)

23,29 Paramétrage du code calcul.

Nombre de passages :

• Recto (Car. 1 à 4 = 1997)

• Verso (Car. 1 à 4 = 1998)

Le résultat trouvé implique la prise en compte du nombre de passages : quantité multipliée par le nombre de passages

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CALCUL_NB_PASS_GF

Prise en compte du nombre de passages dans les gâches fixes

21,22 Code calcul pour la prise en compte du nombre de passage (MP)

23,29 Paramétrage du code calcul.

Nombre de passages :

• Recto (1997)

• Verso (1998)

Le résultat trouvé implique la prise en compte du nombre de passages : quantité de gâche fixe multipliée par le nombre de passages.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CODE_LCO_FORCAGE

21,23 Code LCO de forçage des informations de transport interne de sous-traitance

Cliquez ici pour afficher / masquer plus de détails sur les LCO de forçage.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CODE_LCO_SITES

21,23 Code LCO contenant les sites origine et destination du transport interne de sous-traitance

Tableau de bord du multisite

Le code LCO doit être paramétré ainsi :

Site d'origine : zone LCO A,Type de données alpha(1), Vérification sur le paramètre SIT

Site de destination : zone LCO B,Type de données alpha(2), Vérification sur le paramètre SIT

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CREER_ACT_EVT_AUTO

Création d'une action-événement en automatique lors du transfert du devis en commande

21,23 Type d'action (obligatoire).

EC Entête de commande

LC Ligne de commande

25,27 Code paramètre de type ETP (obligatoire).

29,31 Code paramètre de type EVT (obligatoire).

33 Niveau de priorité de l'action

1 Faible

2 Normal (par défaut)

3 Haute

34 Etat de l'action

A A faire (par défaut)

E En cours

T Terminée

X Abandonnée

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

CUMUL_GFO

CUMUL_GFS

CUMUL_GVO

CUMUL_GVS

Calcul des gâches - Voir aussi ul_param[11]

GF pour les gâches fixes, GV pour les gâches variables

O pour Opération, S pour Sous-traitance

21,23 Opération

24,26 Formule

27,29 Code LCO pour le coefficient 1 (facultatif - par défaut, coeff = 1)

30 Code zone LCO pour le coefficient 1

31,33 Code LCO pour le coefficient 2 (facultatif - par défaut, coeff = 1)

34 Code zone LCO pour le coefficient 2

35,37 Code LCO pour le nombre de poses (facultatif - par défaut, nb poses = 1) - Uniquement pour les gâches fixes

38 Code zone LCO pour le nombre de poses - Uniquement pour les gâches fixes

39,41 Code LCO pour le coefficient du nombre de poses (facultatif - par défaut, coeff = 1) - Uniquement pour les gâches fixes

42 Code zone LCO pour le coefficient du nombre de poses - Uniquement pour les gâches fixes

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

EFF_CCOUT_A_EXCLURE

Centre de coût à exclure du calcul de l'effectif nécessaire

Une ligne de note par centre de coût à exclure.

Ce paramétrage permet d'exclure un centre de coût uniquement sur la formule en cours de calcul.

La même note existe aussi sur le paramètre de lancement du devis standard. Les 2 notes sont complémentaires.

La même note existe aussi sur le paramètre de lancement de la Génération de dossiers imprimerie feuille / rotatives. Les 2 notes sont complémentaires

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

EXEC_CODE_CALCUL_MJ

Permettre le lancement du code calcul de mise à jour MJ à la fin de l'exécution d'une formule matière, opération et/ou sous-traitance, lors du calcul du devis (Touche F11).

21,27 Paramétrage du code calcul MJ

Exemple

1 2

123456789012345678901

EXEC_CODE_CALCUL_MJ 3

On met à jour le nombre de couleurs fi_co_recto avec le contenu de la valeur 1.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

FORMULE_COEFF_POSE

Gâches cumulatives - Coefficient de pose à faire intervenir entre l'unité de la phase précédente et l'unité de la phase en cours.

21,23 Code phase

24,26 Code formule

27 Type de formule

Ce paramétrage est utilisé pour incorporer au calcul de la quantité de l'opération un nombre de poses (dans un cas de refente, de découpe, etc).

Le nombre de poses sera le résultat du calcul (V1 uniquement) de la formule paramétrée sur cette ligne de note.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

GACHE_FIXE

Permet de récupérer la valeur de gâche fixe pour une opération de sous-traitance grâce à un code calcul

ul_param[22] = F impérativement.

21,22 Code calcul

23,29 Paramétrage du code calcul

30 Type d'appel

M Matière

O Opération

S Sous-traitance

Par défaut, le type d'appel sera renseigné avec celui de la formule courante.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

GACHE_FIXE_REEL

Permet de récupérer la valeur de gâche fixe pour le calcul d'une formule d'un devis de fabrication réel uniquement

21,22 Code calcul

23,29 Paramétrage du code calcul

30 Type d'appel

M Matière

O Opération

S Sous-traitance

Par défaut, le type d'appel sera renseigné avec celui de la formule courante.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

GACHE_VARIABLE

Permet de récupérer la valeur de gâche variable pour une opération de sous-traitance grâce à un code calcul

ul_param[22] = F impérativement.

21,22 Code calcul

23,29 Paramétrage du code calcul

30 Type d'appel

M Matière

O Opération

S Sous-traitance

Par défaut, le type d'appel sera renseigné avec celui de la formule courante.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

GACHE_VARIABLE_REEL

Permet de récupérer la valeur de gâche variable pour le calcul d'une formule d'un devis de fabrication réel uniquement

21,22 Code calcul

23,29 Paramétrage du code calcul

30 Type d'appel

M Matière

O Opération

S Sous-traitance

Par défaut, le type d'appel sera renseigné avec celui de la formule courante.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

MSG

5,60 Message à afficher suite à la vérification par la note VERIF_VAL_FORMULE

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

NUM4_NB_EXEMPLAIRES

21 Forcer l'unité de mesure de la dépendance numérique 4 au nombre d'exemplaires (O/N, N par défaut)

(indépendamment de l'unité de mesure de la quantité pliée).

Voir O/PLI/51 : Dépendance numérique 4 au nombre d'exemplaires.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

POUR_VAL_MAX_PERTE

21,26 Pourcentage maximum de perte

Si la perte (rapport entre la surface utilisée par le nombre de pose et la surface de la plaque) dépasse ce pourcentage, alors on valorise par rapport à la surface utilisée.

Utilisé dans le devis_tc avec CAR 2 M

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

RUBRIQUE_VOLUEDIT

Paramétrage rubrique sur formule pour voluedit_fle_cli

Rubrique paramétrée sur le code formule

21, 35 Libellé de la valeur paramétrée

36, 37 Code calcul de la valeur

38, 44

46, 59 using: par ex. ### ###.##

60 Type de valeur (A = Alphanumérique, N = Numérique)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

UNITE_FORMULE

21, 23 Unité de quantité. Initialiser l'unité de quantité (fo_unite) par l'unité paramétrée sur la formule

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

UTIL_BASCULE

La présence de cette note implique la prise en compte de la bascule sur cette formule (quantité multipliée par 2)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

UTIL_COEF_AMALGAME

La présence de cette note implique la prise en compte du coefficient de l'amalgame

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

UTIL_FAC_PEL

La présence de cette note implique la prise en compte du nombre de faces de pelliculage sur cette formule (quantité multipliée par 2 si nombre de faces est égal à 2)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

UTIL_NOMBRE_TOURNEES

La présence de cette note implique la prise en compte du nombre de tournées sur cette formule (quantité multipliée par le nombre de tournées)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

VERIF_VAL_FORMULE

Lancer une vérification de valeurs par le paramétrage d'une formule de calcul après la saisie de la LCO.

Voir le paragraphe concerné dans le devis standard.

21 Type de zone à vérifier (A = Alphanumérique, N = Numérique)

22,24 Code phase (de la formule de contrôle)

25,27 Code formule (de la formule de contrôle)

28 Type de contrôle

W Contrôle non bloquant

B Contrôle bloquant

N Pas de contrôle

Par défaut : on garde le fonctionnement actuel (Formule de contrôle, zone CAD/2, caractère 1).

Le message à afficher, si le contrôle est positif, est paramétré dans la note MSG.

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !

ZONE_LAIZE_MATIERE

Note sur formule de conversion d'unité

21,60 Zone correspondant à la laize matière, celle-ci pouvant venir :

- d'une valeur de LCO (paramétrage standard LCO_CCC_Z, où CCC correspond au code LCO et Z à la zone)

- ou d'une zone de table

Exemples :

LCO_FOR_1 : Zone numérique 1 de la LCO FOR saisie sur l'entité du devis

fi_lar_papier : Zone largeur du support de la table des entités (fle_imp)

Par défaut (sauf recherche sur LCO), on prend la largeur du support de l'entité (fi_lar_papier).

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement, mais des notes sur les formules !


Tarification transporteur

Tarification transporteur tro

Options triées

Ocs | Consultation seule
Ooo | Origine obligatoire
Oro | Unité référentielle obligatoire
Ot1 | Tri par département
Ot2 | Tri par département - quantité
Ot3 | Tri paramétrable dans les notes

Valeur alpha 2

A2[1]

Saisie obligatoire de la date de début de validité (N/O, N par défaut) - Facultatif

Notes

_SUP_SQL_ORDER_BY

21, 60 Complément de requête de type order by sur la table tro

Si l'option Ot3 est positionnée et que les notes ne sont pas renseignées, alors, le complément d'ordre est celui par défaut, à savoir :

to_transp, to_type, to_cp, to_x

Paramètres associés

#CF ATL | alpha4[49,51] doit être RG1 ou SIT
NTR |
UNI |
UTR |

Recherche des tarifs transporteur

Prise en compte du pays dans la recherche

Permettre de prendre en compte le code pays dans la recherche des tarifs transporteur.

Les tarifs transporteurs sans code pays renseigné sont systématiquement pris en compte.

Il peut donc être nécessaire de mettre à jour les codes pays des tarifs transporteur pour gérer plus efficacement ce nouveau fonctionnement.

Exemple : si le transport doit être effectué en Belgique avec le code postal 11, on recherchera les tarifs transporteurs avec le code pays Belgique ou sans code pays, et avec le code postal 11.

Donc si les tarifs transporteurs sans code pays correspondent à la France, la recherche des tarifs transporteurs retournera tous les tarifs correspondants à : Belgique/11 et France/11.

Pour éviter cela, il suffira de mettre à jour le code pays France sur les tarifs transporteur sans code pays.

Remarque : La recherche des tarifs transporteur est utilisée dans les programmes suivants :

G_blv : Saisie des bons de livraison

G_cde : Saisie des commandes

G_devis_mec : Saisie des devis mécanique

G_devis_standard : Saisie des devis multi-métiers

G_devis_tc : Saisie des devis transformateurs carton

G_offre_de_prix : Saisie des offres de prix

Voir aussi le #CF SIT


Saisie et édition des codes FEFCO / ECMA

Saisie et édition des codes FEFCO / ECMA ecma

Nouvelles fonctionnalités au 04/03/2011 :

- Mode consultation

- Gestion par onglets

Cliquez ici pour afficher / masquer une copie d'écran

Voir aussi le programme de saisie des pointages FEFCO / ECMA.

Nouvelles zones :

1/ Numéro d'ordre (ecma.kma_ordre, optionnel) : Ce champ permet de trier les codes ECMA dans la visualisation selon le numéro saisi.

2/ Actif (ecma.kma_actif, obligatoire) : Ce champ permet de définir l'ECMA comme étant actif ou inactif.
Dans le cas où le code ECMA/FEFCO est inactif, il ne sera pas saisissable (saisie des devis, fiche article, etc)

3/ Classe (ecma.kma_classe, optionnel) : Ce champ permet d'associer le code ECMA/FEFCO à une classe

4/ Sous-classe (ecma.kma_sclasse, optionnel) : Ce champ permet d'associer le code ECMA/FEFCO à une sous-classe (accessible uniquement si la classe est renseignée).

5/ Code de difficulté de calage (ecma.kma_code_diff_cal) : Ce champ peut être utilisé dans la saisie des devis via un code calcul.

6/ Code de difficulté de roulage (ecma.kma_code_diff_rou) : Ce champ peut être utilisé dans la saisie des devis via un code calcul.

Les images 2D et 3D sont désormais affichées dans le programme.

Elles sont situées dans le sous-répertoire /Fefco/2D et /Fefco/3D du répertoire des images du Fourj's GDC.

Le code normalisé (ecma.kma_codenor) définit le nom de l'image.

Paramétrage de ces nouvelles fonctionnalités

Options Ocs, Oog et Oop

Nouveaux paramètres de saisie : CDC et CDR

En utilisant le paramétrage du #RP, un programme peut appeler le programme de saisie.

Exemples

-N[kma_code]

-N[el_ecma_dessus|-|el_ecma_dessous]

Voir aussi

Code calcul RF, caractère 1 = D : caractère 2 = O/N

Code calcul VA, caractère 1 = L/M/N/O

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 à 10 : code ECMA / FEFCO

Le code peut être découpé en code_ecma_dessus et code_ecma_dessous quand le code passé contient un tiret.

Options

Ocs | Consultation seule
Ods | Saisie autorisée des données spécifiques
Omz | Possibilité de saisir des majorations à zéro
Ood | L'affichage des pointages FEFCO est réalisé par l'ordre de tri suivant : 1 Position patte 2 Sens dimension 3 Numéro de pointage Par défaut, il est réalisé dans l'ordre : 1 Sens dimension 2 Position patte 3 Numéro de pointage
Oog | Accès uniquement à l'onglet Gammes applicables Important : Cette option est réservée à l'appel au programme de saisie de code ECMA/FEFCO par un autre programme (-N)
Oop | Accès uniquement à l'onglet Pointages Important : Cette option est réservée à l'appel au programme de saisie de code ECMA/FEFCO par un autre programme (-N)
Ouv | Permet de traiter l'unicité des variables spécifiques et calculées

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique Ce mot de passe ne sera appliqué que si le paramètre de lancement est #SA KMA.
Caractères 6 à 8 | Code site de production par défaut pour l'interface ArtiosCAD Pas de valeur par défaut, ce code est récupéré en priorité sur le paramétrage de l'utilisateur courant. Voir aussi USE A3[10,12] et #CF VMC A1[3] Tableau de bord du multisite Permet de passer à l'interface ArtiosCAD (via Volume Media Center) un code site de production. L'ordre de priorité de la récupération du code site de production est le suivant : • Utilisateur courant • Paramètre de lancement Nécessite la version 1.2.1 de VMC, avec gestion de la compatibilité 1.1.6. Le même paramétrage existe pour le programme de test VMC.

Notes

FEFCO_IMG_xx

Avec xx un nombre entre 00 et 99

Voir la note TYPE_NTS_PARAM_ECMA dans le programme d'édition VoluEdit des ordres d'exécution.

21,60 Nom de l’image (note cumulative)

FEFCO_LIB_xx

Avec xx un nombre entre 00 et 99

Voir la note TYPE_NTS_PARAM_ECMA dans le programme d'édition VoluEdit des ordres d'exécution.

21,60 Libellé du FEFCO (note cumulative)

FEFCO_PAR_xx

Avec xx un nombre entre 00 et 99

Voir la note TYPE_NTS_PARAM_ECMA dans le programme d'édition VoluEdit des ordres d'exécution.

21,60 Condition pour l’utilisation du nom d’image et le libellé dans l’édition de l’ordre d’exécution.

21,23 Code paramètre .J2 : Position patte

24,26 Code paramètre .J4 : Prolongement patte dessus.

27,29 Code paramètre .J4 : Prolongement patte dessous.

Remarque : si une valeur d’un code paramètre est à blanc, on considère que toutes les valeurs sont autorisées.

FEFCO_DESSOUS_xx

Avec xx un nombre entre 00 et 99

Voir la note TYPE_NTS_PARAM_ECMA dans le programme d'édition VoluEdit des ordres d'exécution.

21,24 Permet de restreindre à un code FEFCO dessous.

_SUP_REQ_ALIM_MAJO

21,60 Complément de requête sur la table par02 permettant la gestion du remplissage automatique des profils carton en saisie des majorations

Lors de la saisie des pointages dans les fefco, il est possible d'ajouter une majoration dépendante du profil carton.

Lorsque cette fenêtre de saisie s'ouvre, elle est vide; et il faut ressaisir chaque code pour mettre la majoration.

Pour simplifier cette saisie, on a ajouté une touche de fonction permettant de pré-remplir le tableau avec les différents codes de profil carton de la base de données.

Pour permettre une personnalisation de cette fonctionnalité, il est possible de paramétrer un complément de sélection incluant l'ordre de tri (il n'y en a pas par défaut) sur le remplissage de cette liste.

Notes sur le code FEFCO (NTS ART)

ATTENTION ! Ce ne sont pas des notes sur le paramètre de lancement du programme ecma, mais des notes sur les FEFCO (NTS ART)

L'option -C3ART doit être ajoutée dans le paramètre de lancement.

COMPLEXITE_DECOUPE | 21,23 Code de complexité de découpe (.CD) Remarque : ce code est modifiable directement dans la saisie du devis simplifié
FAM_ET_SFM_ENS | 21,23 Code famille pour l'ensemble (FAM) 24,26 Code sous-famille pour l'ensemble
FAM_ET_SFM_PF | 21,23 Code famille pour le produit fini (FAM) 24,26 Code sous-famille pour le produit fini
POSITION_PATTE | 21,23 Code de position patte (.J2)
QUALITE_EMBALLAGE | 21,23 Code de qualité d'emballage (.CQ)

DOCUMENTATION FONCTIONNELLE

Généralités

Le module permet de définir :

• Les codes FEFCO utilisés par le client,

• Les formules de calcul des pointages,

• Les dimensions spécifiques devant être saisies par l'utilisateur dans le devis en fonction de chaque couple FEFCO dessus / dessous,

• Les formules de calcul des dimensions calculées (par exemple : la largeur de la caisse pliée, la longueur de la boite pliée, etc.),

• Les gammes standards applicables pour des couples FEFCO dessus / dessous.

Définition des formules de calcul

Code interne : Code interne du FEFCO

Libellé interne : Libellé du code interne du FEFCO

Code normalisé : Code normalisé du FEFCO

Libellé normalisé : Libellé du code normalisé du FEFCO

Type : Permet de classer les FEFCO par catégorie utilisable en tant que dépendance dans le devis (voir paramètre KMA)

Nb morceaux : Nombre de morceaux nécessaires pour réaliser la caisse

Formules de calcul : Les formules de calcul ne sont pas utilisés dans VoluPack.

Impératifs techniques : Les impératifs techniques ne sont pas utilisés dans VoluPack.

Définition du pointage

Objectif

L'objectif du calcul des pointages est de déterminer automatiquement le positionnement des pointages pour les architectures automatiques.

La valeur d'un pointage définit la distance entre ce pointage et le précédent.

Formules de calcul des pointages

Les formules doivent être écrites en notation polonaise post-fixée. Les résultats sont arrondis en fonction de #CF ATL A4[54].
On pourra vérifier le calcul des pointages sur l'écran pointage du devis.

La casse des variables est importante. Respectez les majuscules et les minuscules.

Les variables utilisables, référencées par des lettres, sont celles :

• définies sur la fiche article de la référence d'architecture

Code | Désignation | Libellé
a | L | Longueur
b | B | Largeur
c | H | Hauteur

• définies sur les informations complémentaires de la référence d'architecture par les TSC 060 à 069 (voir le fichier Excel des TSC)

Code | Désignation | Libellé
d | Rabat | 1-R
e | Rabat dessus | 2-R
f | Rabat dessous | 3-R
g | Dimension du couvercle | COU
h | Dimension du recouvrant | REC
i | Dimension du renfort | DR2
j | Dimension du rentrant | REN
S | Rabat écourté dessus | R-U
T | Rabat écourté dessous | R-O
U | Recouvrant dessus | R+U
V | Recouvrant dessous | R+O
 | Rabat dessous / tête 1 | 346
 | Rabat dessous / tête 2 | 347
 | Rabat dessous / face | 35R
 | Rabat dessous / face 1 | 358
 | Rabat dessous / face 2 | 359
 | Rabat sur tête | 4-R
 | Rabat sur face | 5-R
 | Angle double pli sur oreille | ADP
 | Dimension décalage pli face | DPF
 | Dimension décalage refoulage | DR
 | Dimension encoche / lumière | EL
 | Dimension encoche / refoulage | ER
 | Largeur double pli | LDP
 | Largeur lumière | LL
 | Largeur téton | LT
 | Longueur lumière | LL2
 | Longueur téton | LT2
 | Dimension lumière / bord | LB
 | Dimension lumière / refoulage | LR
 | Dimension oreille / lumière | OL
 | Taille encoche | TE
 | Dimension de la tenue de fond 1 | TF1
 | Dimension de la tenue de fond 2 | TF2
 | Dimension décalage côté | DC

• définies sur les informations complémentaires de la référence d'architecture par d'autres TSC

Code | Désignation
k | Taille de la patte

• définies par le profil carton

Code | Désignation
l | Majoration

La majoration applicable à chaque dimension spécifique est définie par profil carton (touche F8).

Dimensions calculées

Les dimensions calculées ne sont pas stockées mais calculées dynamiquement dans le devis.

Les variables utilisables pour les formules des dimensions calculées sont identiques à celles des formules de pointage, plus celles décrites ci-dessous.

• Dimensions de la caisse pliée pour les devis onduleurs (don)

Code | Désignation
BPC | Largeur caisse pliée
LPC | Longueur caisse pliée
EPA | Epaisseur caisse pliée

Les dimensions BPC, LPC, EPA sont utilisées pour le calcul automatique du conditionnement.

Dans le cas d'une architecture étudiée sans code FEFCO il est par définition impossible d'utiliser les formules des pointages FEFCO pour calculer les variables BPC, LPC et EPA.

On pourra saisir les formules de ces dimensions par profil carton au niveau du code jonction (voir paramètre .JE).

Les majorations sont intégrées directement dans la formule de calcul.

• Dimensions de la caisse pliée pour les autres devis onduleurs (devis_ondu, devis_standard, devis_tc, ...)

Code | Désignation
LAR | Largeur caisse pliée
LON | Longueur caisse pliée
EPA | Epaisseur caisse pliée

• Découpe de rabat

Code | Désignation
RRS | Recoupe de rabat supérieur
RRI | Recoupe de rabat inférieur

Ces dimensions seront automatiquement calculées lors de la saisie des dimensions L, B et H et contrôlées par rapport à des minima possibles par cannelure.

Le paramétrage des minima de recoupe par cannelure se trouve sur le paramètre de lancement du devis (voir note MINRECOUPERABAT).

Utilisé pour des FEFCO 0204

• Métrage de filet

Code | Désignation
FIL FI1 FI2 | Longueur de filet sur la forme de découpe

La longueur de filet permet le calcul du coût prévisionnel de l'outillage basé sur un coût au mètre linéaire de filet.

La longueur calculée est stockée dans le TSC 045 de l'architecture.

Les dimensions FIL, FI1, FI2 correspondent à une seule et unique dimension.

La formule de calcul de la longueur de filet pouvant être relativement longue, on utilisera les trois formules FIL, FI1, F2 bout à bout.

Code | Désignation
EAP | Epaisseur à plat
LAP | Longueur à plat avec patte
LBP | Longueur à plat sans patte

• Variables de pointage

Code | Désignation
m | Pointage sens hauteur 1
n | Pointage sens hauteur 2
o | Pointage sens hauteur 3
p | Pointage sens hauteur 4
q | Pointage sens hauteur 5
r | Pointage sens hauteur 6
s | Pointage sens hauteur 7
t | Pointage sens hauteur 8
u | Pointage sens hauteur 9
v | Pointage sens hauteur 10
w | Pointage sens hauteur 11
x | Pointage sens hauteur 12
y | Pointage sens hauteur 13
z | Pointage sens hauteur 14
A | Pointage sens hauteur 15
B | Pointage sens longueur / largeur 1
C | Pointage sens longueur / largeur 2
D | Pointage sens longueur / largeur 3
E | Pointage sens longueur / largeur 4
F | Pointage sens longueur / largeur 5
G | Pointage sens longueur / largeur 6
H | Pointage sens longueur / largeur 7
I | Pointage sens longueur / largeur 8
J | Pointage sens longueur / largeur 9
K | Pointage sens longueur / largeur 10
L | Pointage sens longueur / largeur 11
M | Pointage sens longueur / largeur 12
N | Pointage sens longueur / largeur 13
O | Pointage sens longueur / largeur 14
P | Pointage sens longueur / largeur 15

• Variables spécifiques

Code | Désignation
Q | Laize brute calculée
R | Coupe brute calculée
W | Laize nette calculée
X | Coupe nette calculée
Y | Epaisseur de la composition carton
Za | Nombre de poses sens hauteur caisse. Utilisé uniquement de la dimension [FIL]
Zb | Nombre de poses sens longueur + largeur caisse. Utilisé uniquement pour calcul de la dimension [FIL]

• Variables spécifiques au devis multi-métiers

Code | Désignation
ZL | Largeur du format ouvert/développé Si le format ouvert est forcé : Largeur du format ouvert fle_imp.fi_lar_ouv (entité) ou fle_dec.de_largeur_cahier (référence multiple) Si le format ouvert n'est pas forcé : Somme des pointages sens coupe (correspond à la somme des L dans la capture d'écran ci-dessus)
ZH | Hauteur du format ouvert/développé Si le format ouvert est forcé : Longueur du format ouvert fle_imp.fi_lon_ouv (entité) ou fle_dec.de_hauteur_cahier (référence multiple) Si le format ouvert n'est pas forcé : Somme des pointages sens laize (correspond à la somme des H dans la capture d'écran ci-dessus)
ZE | Epaisseur de la caisse pliée par défaut associé au profil carton courant Zone numérique 1 du paramètre de type PC

Dimensions spécifiques

Elle permettent d'indiquer sur chaque couple FEFCO la présence de dimensions spécifiques (par exemple : rabat).

La valeur de chacune d'elles sera imposée par le client et devra être saisie dans l'écran architecture du devis.

Définition de l'écran

SD (Sens dimensionnement)

Définit le type de pointage :

• L Longueur, Largeur (sens coupe)

• H Hauteur (sens laize)

• C Dimension calculée

• D Dimension spécifique

Posi. Patte (Position patte) - Voir paramètre .J2

Type Pointage. Définit le type de pointage couteau ou refouleur - Voir paramètre CP

Code Dimension. Permet de définir le nom de la dimension calculée. Utilisé uniquement si la valeur D a été saisie dans la colonne SD - Voir paramètre DC

Variable associée. Permet de définir le nom de l'alias utilisable dans les formules de pointages.

Formule. Permet de définir le mode de calcul à effectuer.

Exemple de définition du FEFCO 201 (Caisse américaine à rabats normaux)

L * B * H représentent les dimensions intérieures de la caisse.

SD | Posi. patte | N° | Type pointage |  | Code dimension |  | Var. assoc. | Formule | Commentaires
C |  | 1 |  |  | SUR | Surface nette | 1 | QR* | Laize brute calculée X coupe brute calculée
D |  | 1 |  |  | TAL | Talon | K | 40 | Taille de la patte de jonction
H |  | 1 | 3 | Refouleur |  |  |  | b2/l+ | (Largeur / 2) + majoration
H |  | 2 | 3 | Refouleur |  |  |  | cl+ | Hauteur + majoration
H |  | 3 | 2 | Couteau |  |  |  | b2/l+ | (Largeur / 2) + majoration
L |  | 4 | 3 | Refouleur |  |  |  | al+ | Longueur + majoration
L |  | 2 | 3 | Refouleur |  |  |  | bl+ | Largeur + majoration
L |  | 3 | 3 | Refouleur |  |  |  | al+ | Longueur + majoration
L |  | 4 | 3 | Refouleur |  |  |  | bl+ | Largeur + majoration
L |  | 5 | 2 | Couteau |  |  |  | k | Taille de la patte de jonction


Gestion des compositions

Gestion des compositions compo

Valorisation des compositions carton par site - à partir de la V. 4.1.41.3

Tableau de bord du multisite

La valorisation des compositions carton par site fonctionne uniquement si la gestion par site de production est activée (#CF/SIT A1[1] = O).

La valorisation des compositions par site de production est disponible uniquement avec le devis et la (ré-)génération de dossier pour les onduleurs.

Lors de la valorisation de la gamme dans le devis onduleur, la valorisation de la composition se fera par rapport au site de production du composant.

Gestion de la composition

La valorisation des compositions carton par site fonctionne suivant les règles suivantes :

– Calcul de la valorisation multi-sites de la composition en prenant les tarifs papier multi-sites (c'est-à-dire sans site).

– Calcul de la valorisation de la composition pour chaque site de production.
La valorisation sera calculée avec le tarif papier du site de production.
S'il n'existe pas de tarif, alors on prend celui du papier multi-sites (c'est-à-dire sans site).

Devis onduleur

Lors de la valorisation de la gamme, le calcul du prix de cession de chaque composition associée à un composant se fait selon le site de production du composant.

Le tarif de la composition sera calculé avec le tarif papier du site du composant.

S'il n'existe pas de tarif, alors on prend celui du papier multi-sites (c'est-à-dire sans site).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : Code composition Exemple : -N[fi_c_papier]
-c_a | Caractères 3 et suivants : Code composition destination Permet de créer une composition en recopiant une composition existante. -N[xxxx] obligatoire pour la composition existante Nota : la longueur maximum du code est de 15 caractères.
-c_b | Caractères 3 et suivants : Code composition destination Permet de créer une composition en recopiant une composition existante. -N[xxxx] obligatoire pour la composition existante Nota : la longueur maximum du code correspond au paramétrage en A4[9,10].

Valeurs numériques

1

Nombre de décimales dans les calculs grammage

2

Valeur par défaut pour le coefficient d'ondulation des papiers médian

Dans ce programme permettant de décrire les plaques cartons ondulées, on doit préciser pour chaque papier le coefficient d'ondulation des cylindres cannelés (paramètre de type CAN)…

Sauf qu'il n'y a pas de cylindres pour les papiers médians (intermédiaires).

Cette valeur étant obligatoire, on permet de mettre une valeur par défaut (généralement = 1) pour initialiser cette zone qui ne veut pas dire grand-chose pour ces papiers.

Options triées

Oc2 | Famille Composition commerciale figée par paramétrage Sous-famille = caractère 2 du code composition
Occ | Calcul de la consommation de la colle en fonction des cannelures au mètre linéaire Voir la note CANNELURE_METRE_REF Voir aussi la note CAN_ML_SIT_ dans le paramètre CAN.
Oce | En mode recalcul batch, on conserve l'épaisseur de la composition
Ode | Le taux de déchet sur la composition n'est plus compris dans la valorisation. On ne compte que la revente déchets.
Oen | Exclusion de la valorisation de la composition négoce
Ofa | Famille composition commerciale figée par paramétrage Sous-famille dépend de la structure du carton, du grammage de la composition (paramétrage)
Ogs | Gestion de traitement spécifique ROSSMANN (estampille, …)
Ohi | En recalcul batch, on historise les tarifs
Oil | Initialisation du Libellé court qualité carton par le code qualité Prend le pas sur la paramétrage indiqué en A4[17,20] (Début et fin libellé court qualité carton).
Olh | Homogénéisation des libellés composition
Omn | Modification de la qualité passée en -N
Ono | Le code normalisé est initialisé de la même façon que le libellé court PC-TOPP
Opl | Composition plastique
Oqh | Homogénéisation de la qualité
Orp | Recopie du prix de cession de la qualité carton vers le PF
Org | Recalcul grammages
Osq | Ne pas mettre à jour la zone qualité article lors d'un substitution de composition2 Cette option ne sert à rien si le caractère 11 de la note PARSUB = N (pas de mise à jour)
Oul | Contrôle l'unicité du libellé court de la composition (écran 2)

Valeur alpha 2

Caractères 1 à 3 | Code environnement 1 (TSC 385)
Caractères 4 à 6 | Code environnement 2 (TSC 386)
Caractères 7 à 9 | Code environnement 3 (TSC 387)
Caractères 10 à 12 | Code environnement 4 (TSC 388)
 | Codes environnements 5 à 8 : voir A2[37] et suivants ci-dessous.
Caractère 13 | Mode de contrôle du grammage à 0 : N pas de contrôle (valeur par défaut) B contrôle bloquant W contrôle non bloquant avec message d'alerte C contrôle avec demande de confirmation de l'action à mener
Caractères 14 à 23 | Réservés
Caractères 24 à 26 | Code de validité à utiliser (paramètre de type QA) pour la mise à jour de la composition en cas de problème de valorisation
Caractère 27 | Vérification des laizes papier N Aucune vérification W Demande de confirmation B Contrôle bloquant Les laizes disponibles saisies doivent se trouver sur chacun des papiers de la composition. Les laizes disponibles sur les papiers sont saisies sur les TSC suivants : Laizes : TSC 340 à 345, ic_num1 à ic_num3, soit 18 laizes possibles Laizes mono-pose : TSC 350 à 352, ic_num1 à ic_num3 soit 9 laizes possibles
Caractères 28 à 30 | Code validité de la composition commerciale créée par la recopie Obligatoire en recopie de composition commerciale (Touche F15)
Caractère 31 | Autorisation de modifier la famille de la composition commerciale (O/N, N par défaut)
Caractère 32 | Autorisation de modifier la sous-famille de la composition commerciale (O/N, N par défaut) O Autorisation de modification de la sous-famille de la composition commerciale N Affichage seul. Modification non autorisée. La famille et la sous-famille sont déterminées automatiquement (création/modification de la compo). (Par défaut.)
Caractère 33 | Autorisation de modifier la famille de la composition technique (O/N, N par défaut)
Caractère 34 | Autorisation de modifier la sous-famille de la composition technique (O/N, N par défaut) O Autorisation de modification de la sous-famille de la composition technique N Affichage seul. Modification non autorisée. La famille et la sous-famille sont déterminées automatiquement (création/modification de la compo). (Par défaut.)
Caractère 35 | Autorisation de modification de la famille de l'article (P*) (O/N, N par défaut) Si N : affichage seul
Caractère 36 | Autorisation de modification de la sous-famille de l'article (P*) (O/N, N par défaut) Si N : affichage seul
Caractères 37 à 39 | Code environnement 5 (TSC 389)
Caractères 10 à 42 | Code environnement 6 (TSC 391)
Caractères 43 à 45 | Code environnement 7 (TSC 392)
Caractères 46 à 48 | Code environnement 8 (TSC 393)

Valeur alpha 3

Caractères 1 à 3 | Famille article cartonnier. Par défaut : PLA
Caractères 4 à 6 | Sous-famille article cartonnier. Par défaut : PLA
Caractères 7 à 9 | Unité d'achat article cartonnier. Par défaut : %PL
Caractères 10 à 12 | Unité de vente article cartonnier. Par défaut : %M2
Caractères 13 à 15 | Formule de conversion article cartonnier. Par défaut : CEN
Caractères 16 à 20 | Mot de passe pour la valorisation
Caractères 21 à 24 | Préfixe des composants papiers dans la nomenclature de la composition
Caractères 25 à 28 | Préfixe des composants colles dans la nomenclature de la composition
Caractères 29 à 32 | Préfixe des composants déchets dans la nomenclature de la composition
Caractères 33 à 35 | Code qualité papier invalide bloquant
Caractères 36 à 38 | Code qualité papier invalide non bloquant
Caractères 39 à 41 | Code qualité papier valide
Caractères 42 à 44 | Code statistique 1 par défaut des articles cartonniers - Facultatif
Caractères 45 à 47 | Code statistique 2 par défaut des articles cartonniers - Facultatif
Caractères 48 à 50 | Code statistique 3 par défaut des articles cartonniers - Facultatif
Caractères 51 à 53 | Code statistique 4 par défaut des articles cartonniers - Facultatif

Valeur alpha 4

Caractères 1 à 3 | Famille de la composition commerciale
Caractères 4 à 6 | Famille de la composition technique
Caractères 7 à 8 | Longueur minimum de la composition
Caractères 9 à 10 | Longueur maximum de la composition
Caractères 11 à 12 | Longueur version
Caractères 13 à 14 | Longueur radical
Caractères 15 à 16 | Longueur chrono
Caractères 17 à 18 | Début libellé court qualité carton (pour attribution du code PC-TOPP)
Caractères 19 à 20 | Fin libellé court qualité carton (pour attribution du code PC-TOPP)
Caractère 21 | Contrôle que la qualité initiale dans le fichier pour le produit est bien celle actuelle du produit (O/N, O par défaut)

Notes triées

CANNELURE_METRE_REF

21,25 Cannelure au mètre linéaire de référence

Voir la note Occ.

Voir aussi la note CAN_ML_SIT_ dans le paramètre CAN.

#CC

5,22 Nom de la zone (colle_rh)

23 Saisie obligatoire (O/N, N par défaut)

CODE_QUA_C_CREER_D

21,23 Code validité de la composition commerciale lors de la création d'une composition commerciale à partir d'une existante.

Ce code est de type QA. Voir QA A1[37]

Voir la note ACCES_CREER_COMPO dans le devis onduleur.

CODE_SITE_DEF

21,23 Code site - Tableau de bord du multisite

CS

3,60 Complément de sélection sur mat pour les substitutions

ETUDE

Paramétrage des numéros d'étude à traiter ou à exclure lors des substitutions

Caractère 7 : Etude à exclure (E) ou à prendre en compte (P)

Caractères 8 à 17 : Numéro d'étude

FAMENS

Paramétrage des familles d'ensemble à traiter ou à exclure lors des substitutions

Caractère 7 : Famille à exclure (E) ou à prendre en compte (P)

Caractères 8 à 17 : Code famille

FIC_FIC_IMPORT

REP_FIC_IMPORT

Pouvoir exécuter une substitution de composition à partir d'un fichier

Le fichier est construit ainsi :

Code produit;Ancien code composition;Nouveau code composition

Nouvelle entrée au menu : Substitution depuis un fichier

Utilisation des autorisations actuelles pour la gestion des substitutions.

On n'a pas besoin d'utiliser la table des substitutions.

21,60 Nom du fichier d'importation des compositions à substituer

21,60 Répertoire où se situe le fichier d'importation des compositions à substituer

MOTPASSE

9,13 Mot de passe pour le lancement des substitutions de composition

PARSUB

Paramétrage de la gestion de substitution de composition

Caractère 7 : Contrôle que le nouveau code composition n'est pas présent dans l'ancien code (O/N, O par défaut)

Caractère 8 Contrôle que l'ancien code composition n'est pas présent dans le nouveau code (O/N, O par défaut)

Caractère 9 : Contrôle que les compositions ont le même profil (O/N, O par défaut)

Caractère 10 : Contrôle que l'ancien code composition n'est pas présent comme ancien code (O/N, O par défaut)

Caractère 11 : Mise à jour (O/N, N par défaut)

Caractère 12 : Contrôle des numéros d'étude (O/N, N par défaut)

Caractère 13 : Contrôle que l'ancien et le nouveau code composition ne sont pas identiques

Caractère 14 : Contrôle les familles d'ensemble (O/N, N par défaut)

SUP_MAJ_GLOBALE

17,60 Complément de sélection sur la table mat pour le recalcul batch

TSCIND

Paramétrage du TSC contenant le numéro d'indice à mettre à jour

Caractères 7 à 9 : code du TSC

Caractère 10 : code de la zone du TSC contenant l'indice à mettre à jour

Caractère 11 : code de la zone du TSC contenant la date à mettre à jour

Caractère 12 : Indice par défaut à initialiser

Exemple

TSCIND270FAA

On met à jour le TSC 270.

Caractère 10 : La zone F du TSC 270 (char3_1) contiendra l'indice à mettre à jour. Si la zone est à blanc, on prendra la valeur indiquée en caractère 12 pour l'initialiser (ici, on initialisera avec l'indice A; à la prochaine exécution, l'indice A deviendra B et ainsi de suite)

Caractère 11 : La zone A du TSC 270 (date_1) sera mise à jour avec la date du jour.

Paramètres nécessaires

#CF ATL A3[32] | Libellé du système de planification affiché
TSC MAP | Coefficient de majoration sur le code papier
PC | Notes CADENCE_BASE LAIZE_MOY LAIZE_DI LAIZE_DI_2


Intégration du fichier OSYS

Intégration du fichier OSYS importe_osys

Intégration du fichier OSYS au format texte

Valeur alpha 2

A2[1] | Type de format du fichier (1 par défaut)
A2[2] | Délimiteur (; par défaut)

Notes

HISTO_DIR | 21,60 Répertoire pour l'historique
NOM_FICHIER_OSYS | 21,60 Nom du fichier OSYS à intégrer (nom avec répertoire)

Paramètres nécessaires

TTR | Note commençant par C
PHA A3[52,54] | Code Phase par défaut


Transfert des compositions vers OMP

Transfert des compositions vers OMP tr_compo

Il permet de transférer les qualités/compositions carton à OMP (système de planification), via la construction d'un fichier xml.

Ce fichier est posté sur un répertoire sur le serveur pour être récupéré par OMP.

Valeurs numériques

1

Nombre de décimales dans les calculs grammage

Valeur alpha 2

A2[1,2]

Longueur maximum de la composition (15 par défaut)

Notes

FIC_ANOMALIE | 21,60 Nom du fichier anomalie
FIC_COMPO | 21,60 Nom du fichier de transfert sans extension. Le fichier en sortie sera automatiquement horodaté, et portera l'extension .xml
FIC_LOCK | 21,60 Nom du fichier lock (ce fichier indique qu'un traitement est déjà en cours du côté VoluPack).
FIC_TRACE | 21,60 Nom du fichier trace
SUP_REQ_MAC0 | 21,60 Complément de requête des machines autorisés à être transmises vers OMP Nota : cette note est cumulative
SUP_REQ_MAT | 21,60 Complément de requête sur la table mat

Paramètre nécessaire

compo

Option Oil


Optimisation du conditionnement

Cette fonctionnalité est accessible à partir du devis_tc et du devis standard.

Ce module permet la saisie et l'optimisation du conditionnement sur palette pour le devis transformateur.

Il est accessible par F22 depuis le devis : Ecrans 2 & 3

Il est composé de deux fichiers :

optimise_palet.4gl module de saisie et d' optimisation du conditionnement (indépendant des tables du devis)

dtc_interface_palet module de chargement et de sauvegarde des informations de palettisation pour le devis TC.

Sommaire

Particularités

Paramètres de lancement

TSC utilisés

LCO utilisée

Stockage du code palette

Formule de calcul des dimensions pliées (FEFCO)

Autres paramètres utilisés

Conditions supplémentaires d'ouverture de la saisie

Transfert sur le produit fini des infos de palettisation

Saisie des tarifs pour les articles palettes

Mise en place de la phase EMP

Particularités

Pour certains paramètres, le devis_tc fait appel au TPR tandis que le devis standard fait appel au TEN.

Paramètres de lancement

Options

Oau (devis_tc - devis_standard)

Oic (devis tc)

Opa (devis_tc - devis_standard)

Notes sur le paramètre de lancement (devis_tc - devis standard)

DEPASSEMENT_LARGEUR

DEPASSEMENT_LONGUEUR

HAUTEUR_MAX_PALETTE

HAUTEUR_PALETTE

MESS_AVERTISSEMENT

TSC utilisés

TSC | TIC | Zone(s) | Désignation
210 | DEV/CLI MAT | ic_num1 char3_1 | Nombre d'articles par colis Code du type de colisage (.SC)
218 | CLI | ic_num1 ic_num2 ic_num3 | Longueur de la palette (en mm) Largeur de la palette (en mm) Hauteur de bois de la palette (en mm)
220 | DEV/CLI MAT | ic_num1 ic_num2 ic_num3 ic_char3_1 ic_char30 ic_char3_2 | Nombre d'articles conditionnés par charge Nombre de palettes utilisées par charge Nombre de gerbages Type de palette utilisée (.TP) Mode de gestion de la palette (.MG) Schéma de palettisation (.SP)
224 |  | ic_char3_1 ic_num1 ic_num2 | Dépassement autorisé ou interdit Dépassement dans la longueur Dépassement dans la largeur
225 | DEV/CLI MAT | ic_num1 ic_num2 ic_num3 | Longueur d'encombrement de la charge (en mm) Largeur d'encombrement de la charge (en mm) Hauteur d'encombrement de la charge (en mm)
226 | DEV/CLI MAT | ic_num1 ic_num2 ic_num3 | Longueur du PF plié (en mm) Largeur du PF plié (en mm) Epaisseur du PF plié (en mm)
227 à 229 | DEV/CLI MAT | ic_char3_1 ic_char30 ic_char3_2 | Code des protections palette (.PP)
230 | DEV/CLI MAT | ic_char3_1 | Code du type de cerclage (.CE)
250 | DEV/CLI | ic_num1 ic_char3_1 ic_char3_2 | Nombre d'étiquettes par palette Type des étiquettes palettes Position des étiquettes sur la palette
255 | DEV/CLI | ic_num1 ic_char3_2 | Nombre de caisses témoins Position des caisses témoins sur la palette
290 cf note ci-dessous | MAT (sur code palette) | ic_char3_1 ic_char30 | Type de palette (.TP) Mode de gestion de la palette (.MG)
FOR | DEV | Ic_char3_1 | Forçage O/N des contraintes de conditionnement

Le TSC 290, saisi sur le code palette, est utilisé dans l'optimisation du conditionnement pour rechercher les palettes.

Le système va parcourir tout le fichier des articles (avec les compléments de requête CPAL sur #CF DEG) et retenir les codes palettes pour lesquels le type de palette (.TP du TSC 290) et le mode de gestion (.MG du TSC 290) sont ceux inscrits sur l' écran de recherche optimisée du conditionnement.

L'absence de notes CPAL sur #CF DEG augmente considérablement les temps de traitement !

Le TSC 220 contient aussi ces informations , mais il est mis en oeuvre uniquement sur les produits finis .

LCO utilisée

LCO JON (fc_a1) Code du type de jonction

Paramétrage du type de jonction dans la zone alpha1[1,3] de la LCO JON

Utiliser de préférence le paramètre par défaut .JE

Stockage du code palette

  • Le code palette est stocké dans la table fle_emb sous la référence :Devis-sous devis-entité-phase 1-num_liv 0

  • Lors de l'enregistrement du code palette, on supprime toutes les occurrences devis-sous devis-entité de la table fle_emb.

  • Cela implique de ne pas utiliser l'ancienne saisie du conditionnement avec la nouvelle.

  • Lors de la génération (F30), le code palette est stocké dans la nomenclature du PF créé.

Formule de calcul des dimensions pliées (FEFCO)

Code sens | C (calculé)
Code dimension calculée | DC LON (longueur PF plié) LAR (largeur PF plié) EPA (épaisseur PF plié)

Autres paramètres utilisés

.ET | Type d'étiquette
.EP | Position des étiquettes ou caisses témoins sur la palette

Conditions supplémentaires d'ouverture de la saisie

TPR alpha1[30] = O (gestion du conditionnement pour ce type d'entité)

Sur le PF, les dimensions, le code FEFCO, le code qualité matière et l'indicateur de jonctionnement doivent être saisis.

La hauteur du PF n'est testée que si, sur le FEFCO, la cote mini et / ou la cote maxi sont différentes de zéro.

Transfert sur le produit fini des infos de palettisation

#CF GPF alpha2[8] = O (Recopie des TSC de palettisation)

Saisie des tarifs pour les articles palettes

F6 sur le client #SOC : Code du tarif : #CE (type : TAR)

Type du tarif : code sur #CF DEG alpha3[27,29] (environnement de calcul du devis)

Le code du tarif doit être identique au code de l'environnement de valorisation du devis

Mise en place de la phase EMP

Cette phase est générée automatiquement.

Sur le paramètre de configuration générale du devis (code en A2[1,3] ou #CF DEG par défaut) : alpha 1[48] : génération automatique de la phase EMP (O/N, N par défaut)

Les phases EMC et EMF peuvent aussi être générées automatiquement.

Formule matière de la phase permettant la valorisation de la palette : code PAL par exemple :


Devis standard

Dans lécran de saisie de la nomenclature, on peut sur option, suite à la saisie du code produit, ramener automatiquement toute sa nomenclature (prise sur la table nom0).

On met à jour alors les informations de la table fle_nom.

Attention, linsertion automatique de la nomenclature ne fonctionne que si lon crée une nouvelle ligne (en fin de tableau).

Cela ne fonctionne pas en insertion de ligne par le F1 !

Edition via VoluEdit :

1) Ajouter dans le document une nouvelle feuille.

2) Dans la fenêtre des propriétés de la feuille, cocher la case Commande système.

Puis, dans l'onglet Exemplaires, cocher la case Cette feuille est une pièce annexe, dans le but de lancer le programme de CAO une seule fois par document, et non pas à chaque saut de page.

Une fois la fenêtre des propriétés fermée, la feuille est alors coloriée en jaune pale.

3) Créer un cadre. Taper le chemin du programme VoluPicador, suivi des paramètres suivants :

/p [=nom imprimante] (le nom de l'imprimante est facultatif)

/f=nom de l'étude picador

On obtient par exemple la ligne :

c:\program files\volume software\volupicador\volupicador.exe /p /f=[TSC_MP_071_C30].des

Le programme VoluPicador est lancé à chaque nouvelle édition, puis stoppé immédiatement une fois son travail terminé.

Devis multi-métiers devis_standard

Valeurs numériques | Options triées | Valeurs alpha
Notes triées |  | Paramètres nécessaires
Alimentation du devis standard depuis le code produit |  | Codes TSC liés à l'outil (mat)
Contrôle des valeurs saisies |  | Optimisation du conditionnement
Méthode de construction du code ECMA |  | Gestion des versions de produits
Décomposition des prix des éléments (revient/vente standard) |  | Temps de calcul du devis
Ouverture contextuelle des informations complémentaires (TSC) |  | Récapitulatif des coûts (#CF REC)

Intégration du devis TC dans le devis multi-métiers : cette fonctionnalité n'est disponible que sous GENERO.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis-Numéro d'entité

Exemples:

-N[l2_devis]

-N[l2_devis|-|l2_sdevis+&&&]

-N[fi_devis|-|fi_sdevis+&&&|-|fi_entite+&&&]

Valeurs numériques

1 | Numéro du compteur (nul par défaut) Il faut créer des compteurs par défaut si on utilise les numéros de compteur. Le compteur numéro 9999 est réservé à une numérotation particulière. Le folioteur sur 4 après l'année et le mois n'est remis à zéro qu'en début d'année.
2 | Non utilisée

Options triées

Oaa

Pas d'arrondi de la coupe si la matière est achetée - Intégration du devis TC dans le devis multi-métiers

Oac

Accès direct à la saisie du conditionnement

IMPORTANT : Cette option est réservée à l'appel de la saisie des devis multi-métiers avec un numéro de sous-devis passé en argument (-N)

REMARQUE : Cette option est compatible avec les devis créés via la saisie du devis transformateur carton (TC).

Voir la note PARAM_SAISIE_DEVIS dans la déclaration de production.

Oad

Eclatement des amalgames uniquement sur entité 99

Oae

Accès direct au menu d'édition lorsqu'un devis est validé par la touche F6

Oaf

Adresse de facturation saisie sur la zone paramétrée

Oai

Aide à l'imposition

Oan

Pas de re-numérotation des entités

Oap

Affichage du prix du papier même fonctionnement que pour le devis

Oar

Accès au récapitulatif pour un appel avec -N

Les options Oar, Oav et Odp sont incompatibles entre elles. Elles sont réservées à des appels à la saisie des devis avec passage du numéro de devis (-N).

Oas

Activation des recherches et alertes de similitude - Intégration du devis TC dans le devis multi-métiers

Oau

Ouverture automatique du conditionnement - Intégration du devis TC dans le devis multi-métiers

Oav

Accès direct à la saisie du récapitulatif du prix (variantes)

Les options Oar, Oav et Odp sont incompatibles entre elles. Elles sont réservées à des appels à la saisie des devis avec passage du numéro de devis (-N).

Obe

Boucle sur le menu des éditions - GENERO uniquement

Permet de boucler sur le menu des éditions afin de les enchaîner.

ATTENTION !

Cette option permet de rester dans le menu Edition pour manuellement enchaîner plusieurs éditions (Edition Technique Simplifiée, Technique détaillée, etc ...).

Elle ne permet pas d'éditer tous les sous-devis en une seule fois.

Obr

Batch de recalcul des devis

Permet de recalculer en mode batch tous les sous-devis sélectionnés via un complément SQL.

Le complément de sélection des sous-devis à recalculer est obligatoire.

Par défaut, cette option affiche le récapitulatif des sous-devis recalculés à la fin du traitement.

Pour désactiver cet écran, il suffit de paramétrer l'envoi du récapitulatif dans un fichier trace.

Voir les notes

_SUP_REQ_REACTUAL

REACTUAL_FIC_TRACE

REACTUAL_DATES_VAL

_SUP_ORDER_BY_RECAP

Obt

Bornes de tarifs au mètre carré - Intégration du devis TC dans le devis multi-métiers

Oca

Création automatique des articles du devis et changement de type

Occ

Le numéro du devis est créé avec le compteur des commandes

Ocm

Calcul du conditionnement par métrage linéaire plancher

Oco

Consultation

Ocp

Génération des notes de contrepartie en Euro

Ocr

Confirmation avant recalcul des pointages modifiés manuellement

Voir la note TSC_MODIF_POINTAGES

Oct

Gestion des contraintes fournisseurs

Option payante BAS 30

Si le fournisseur est saisi, on vérifie que les contraintes techniques sur la qualité sont respectées.

Si ce n'est pas le cas, un message d'erreur est affiché, mais on peut quand même imposer ce fournisseur.

Si aucun fournisseur n'est saisi, on recherche en automatique les fournisseurs qui respectent ces contraintes et qui ont un tarif pour cette qualité.

Si on en trouve plusieurs, on peut afficher une liste de sélection.

A la validation de l'écran, si aucun fournisseur n'est saisi, on vérifie qu'il existe au moins un fournisseur qui respecte les contraintes.

Dans le cas contraire, la validation du devis est interdite.

Cette fonctionnalité est gérée par les notes suivantes :

RECH_FOU_CONT

CHOIX_FOU_CONT

_SUP_REQ_FOU_CONT

EXCLUS_CONT_TARIF

VERIF_CONTRAINTE_ACT

FORCER_FOU_CONTRAINT

INVERSION_FORMAT

Voir aussi la note CODE_BESOIN_SMC :

C'est sur cette note qu'est indiqué le mode de recherche du tarif des matières.

Attention, on ne doit rechercher le tarif que pour le fournisseur, recherche avec le type C uniquement.

Ocv

Ouverture automatique du conditionnement après sa réinitialisation lors de la création d'une variante de quantité

L'option Orc est obligatoire.

Odc

Double lancement du calcul du devis par la touche F11

Odd

Désactivation du décalage des numéros de références et d'entités en cas de suppression

Les numéros de référence et les numéros d'entités sont fixés à la création et ne changent plus.

Voir la note ETAT_DEVIS_FAB_MOD et USE A2[29]

Ode

Libellé d'entité repris de l'entête en automatique

Odf

Saisie des dossiers de fabrication - Permission CMA DOSSIER_FAB

Odj

Si aucune gamme trouvée et problème d'ouverture, on retente la recherche avec un FEFCO en 2 morceaux

Intégration du devis TC dans le devis multi-métiers

Odp

Accès direct à la visualisation du détail des phases

Les options Oar, Oav et Odp sont incompatibles entre elles. Elles sont réservées à des appels à la saisie des devis avec passage du numéro de devis (-N).

Odr

Accès à l'ancienne saisie du descriptif de roulage

Oec

Edition de la confirmation de commande

Oef

Effectif

Ofa

Le deviseur est un fabricant (FAB)

Off

Saisie d'un dossier de fabrication

Ofg

On inclut le contrôle de faisabilité gamme dans le contrôle des gammes - Intégration du devis TC dans le devis multi-métiers

Ofj

On force la saisie du colisage et de la jonction - Intégration du devis TC dans le devis multi-métiers

Ofr

Lors du passage d'un mode de réapprovisionnement S (Stock interne) à C (à Commander), alimenter automatiquement les informations Impression/Plaque à partir des informations Découpe.

Cette option n'est active que dans l'entité Transformateur/Carton (TRFCAR).

Ogc

Génération de la commande

Ogp

Génération des PF autorisée

Ogv

Génération automatique de l'OF à la sortie en validation de la fiche de fabrication

Oia

Récupération des données d'une étude Artios CAD et mise à jour des zones correspondantes dans l'entité courante du devis

UNIQUEMENT SOUS GENERO (G_devis_standard).

Oin

Insertion automatique de la nomenclature pour mettre à jour la table fle_nom

Explications

Oip

Initialisation format papier au format tirage

Oma

Transfert du tableau des marges

Omd

Mise à jour de la date de livraison proposée du dossier (cde2.lc_delrep) à partir de la date de livraison saisie sur le devis

La date de fin de fabrication du dossier généré (fab0.f0_delp) est également mise à jour.

Omf

Mise à jour de la date de fin de fabrication du dossier (cde2.lc_delfab) à partir de la date de livraison saisie sur le devis

La date de fin de fabrication du dossier généré (fab0.f0_delp) est également mise à jour

Omg

Pas d'affichage des gammes non retenues - Intégration du devis TC dans le devis multi-métiers

Oml

Mise à jour des libellés de la commande (cde1.ec_texte, cde2.lc_lib) à partir de la première ligne de désignation du devis

Voir aussi #CF DEG A4[45 à 48]

Omq

Mise à jour de la quantité lancée du dossier à partir de la quantité saisie sur le devis

La quantité lancée du dossier généré (fab0.f0_qtel) est également mise à jour

Omr

Message de remise à zéro du conditionnement - Intégration du devis TC dans le devis multi-métiers

Oms

Génération de mouvements de stock

Omu

Accès direct à la saisie des références multiples

IMPORTANT : Cette option est réservée à l'appel de la saisie des devis multi-métiers avec un numéro de sous-devis passé en argument (-N)

Voir aussi : v_fle A4[23] et A4[24]

Ona

Mise à jour automatique de la nomenclature - Intégration du devis TC dans le devis multi-métiers

Onc

Affichage automatique des notes du client du devis

Voir la note AFF_NOTES_CLI_DEVIS

Ony

Numérotation annuelle des fiches de fabrication...

... et des numéros de devis

Ooc

Ouverture du conditionnement après la saisie du colisage - Intégration du devis TC dans le devis multi-métiers

Oot

Obligation de saisir un tiers existant

Lors de la saisie d'un devis, si le code tiers saisi n'existe pas, le programme propose de créer un nouveau prospect

Pour ne pas faire cette proposition, on ajoute une nouvelle option.

Opa

Nouvelle saisie du conditionnement - Intégration du devis TC dans le devis multi-métiers

Ope

Accéder à l'écran de saisie du prix par élément du devis transformateur carton (en remplacement de celui du devis multi-métiers)

Remarques

• L'écran du prix par élément est accessible depuis l'écran de récapitulatif du prix (Shift-F3 puis F8).

• Cet écran remplace celui du prix par élément du devis multi-métiers.

• L'écran de saisie du prix par élément du devis multi-métiers se base sur les références multiples.

• L'écran de saisie du prix par élément du devis transformateur carton se base sur les entités.

Opf

Activation de l'intégration des données à partir de la fiche produit. Voir A2[13,18] et #CF IPF A1[2]

Opf

Alimentation du devis avec la fiche produit

(voir Alimentation du devis standard depuis le code produit en bas de cette fiche)

Opl

Active la fonction d'alimentation de cde5 (besoins matière) pour le carton plat

Opp

Si l'article est suivi en stock et non générique, le mode de réapprovisionnement est automatiquement "sur stock"

Intégration du devis TC dans le devis multi-métiers

Opr

Pas de recalcul après la recherche de gamme - Intégration du devis TC dans le devis multi-métiers

Oqa

Activation de la modification automatique des quantités des sous-devis

Or2

La recherche des tarifs se fera à partir de la famille/sous-famille du papier - Intégration du devis TC dans le devis multi-métiers

Or3

La recherche des tarifs se fera à partir de la famille/sous-famille du papier.

La quantité sera ajustée en fonction de l'unité d'achat - Intégration du devis TC dans le devis multi-métiers

Or4

La recherche des taris se fait d'après le paramètre de configuration de recherche de tarif (voir A2[35,37])

Intégration du devis TC dans le devis multi-métiers

Or5

La recherche des tarifs se fait d'après le paramètre de configuration de recherche de tarif (voir A2[35,37]) mais la quantité correspond à la surface exprimée au cent mètres carrés - Intégration du devis TC dans le devis multi-métiers

Orb

Recherche spécifique pour la boîte pliante

Permet l'ouverture d'une fenêtre de recherche avec le format produit A x B x H.

Orc

Réinitialisation du conditionnement lors de la modification d'une donnée technique (nombre de pages, qualité matière, données FEFCO), de la quantité du devis/de l'entité et lors de la création des variantes

Incompatible avec les options Ort et Orq

Ord

Permet de déclencher le recalcul du devis dans le cas d'une recopie

Ore

Annulation des reliquats de stocks (sorties réserves)

Remarque : cette option est équivalente à l'option Oar sur la saisie des commandes.

Orf

Recopie de devis par F24 depuis le numéro du devis d'origine

Org

Remise à zéro automatique des données de la gamme - Intégration du devis TC dans le devis multi-métiers

Voir aussi les options Orw, Orx, Ory.

Orp

Affichage de l'écran de réservation papiers (F15)

Orq

Réinitialisation du conditionnement lors de la modification de la quantité d'une entité du devis

Incompatible avec l'option Orc

Ors

Si le carton est pris sur stock, on fera une recherche dans le stock de la plaque optimale par le programme de recherche de matière optimisée. Voir #CF SMC

Ort

Réinitialisation du conditionnement lors de la modification d'une donnée technique dans une entité du devis (nombre de pages, qualité matière, données FEFCO)

Incompatible avec l'option Orc

Orv

Recherche actuelle F7 remplacée par visualisation des devis

Orw

Réinitialisation des données de la gamme à la génération d'une variante de quantité

Permettre de séparer l’option de réinitialisation de la gamme (Org) en trois options distinctes : Orw, Orx, Orz.

Orx

Réinitialisation des données de la gamme à la modification d'une donnée technique

Permettre de séparer l’option de réinitialisation de la gamme (Org) en trois options distinctes : Orw, Orx, Orz.

Ory

Réinitialisation des données de la gamme à la sélection d'une nouvelle gamme

Permettre de séparer l’option de réinitialisation de la gamme (Org) en trois options distinctes : Orw, Orx, Orz.

Orz

Remise à zéro de la quantité

Sans l'option : Lors du calcul d'une opération, la quantité est remise à zéro si le temps total est à zéro.

Avec l'option : Lors du calcul d'une opération, la quantité n'est pas remise à zéro si le temps total est à zéro

De plus, cette option n'est prise en compte que pour les formules d'opération pour lesquelles les gâches cumulatives sont désactivées (ul_param[24] = O ou pas de gestion des gâches cumulatives)

Osa

Saisie du numéro d'affaire obligatoire après la saisie du code client, en création de devis Voir aussi #CF AFF

Osc

Suppression du contrôle de cohérence sur la saisie du nombre de poses - Intégration du devis TC dans le devis multi-métiers

Osf

Utilisation du suivi d'affaire pour récupérer l'expéditeur du fax/email (par défaut, on utilise le deviseur)

Osl

Saisie des notes sur LCO (F13)

Osr

Pas de mise à jour du stock résultant

Ost

Site de production sur entité devis feuille - Tableau de bord du multisite

Osw

Appel du programme de schéma Windows

Otd

Initialisation du transport par le reste à livrer

Ote

Test du devis

Oth

Pas de contrôle de la largeur par rapport à la longueur (par défaut, la largeur de la boîte ne peut pas être supérieure à la longueur)

Intégration du devis TC dans le devis multi-métiers

Otr

Accéder uniquement aux informations complémentaires (TSC) des références multiples de l'entête du devis

Oup

Utilisation des pointages FEFCO - Intégration du devis TC dans le devis multi-métiers

Ouv

On utilise l'unité de vente pour calculer le prix de vente issu du fichier mat / prod et le prix du mouvement de stock

Ova

Validation automatique de la fenêtre de gestion de fax/email

Ovc

Contrôle du calcul du conditionnement - Intégration du devis TC dans le devis multi-métiers

Ovg

Création d'un enregistrement dans VoluGold lors de l'enregistrement d'un devis en création

Ovm

La recherche de gamme inclut la valorisation - Intégration du devis TC dans le devis multi-métiers

Ovn

Contrôle de la validité des PF

Un ensemble est constitué de plusieurs PF, dont certains peuvent être non valides.

Lors du passage du devis en commande, on peut maintenant vérifier la validité des PF grâce à cette option.

Si un des composants n'est pas valide, le passage en commande de l'ensemble est refusé avec un message d'avertissement.

Ovq

Contrôle de l'existence et des validités des articles après la saisie du numéro de devis/sous-devis

(contrôle de l'article d'entête, des articles et qualités des entités) - Nécessite #CF DEG A1[5]

Les contrôles ne sont effectués que si un code est saisi.

Permet, après la saisie du numéro de devis/sous-devis, de contrôler l'existence et les validités des articles saisis dans le sous-devis : code produit d'entête (fle_2.l2_code_prod), produits (fle_imp.fi_prod_ent) et qualités (fle_imp.fi_c_papier) des entités.

Oxm

Ecran de saisie fax/email

Ozz

Boucle de saisie des notes

Valeur alpha 2

devis_standard A2[1,3]

Code paramètre de la configuration générale du devis (par défaut : DEG)

devis_standard A2[4,6]

Code paramètre de la configuration du récapitulatif du devis (par défaut : DER)

devis_standard A2[7,12]

Type et code du paramètre de la (ré)génération de produit fini. Par défaut : #CF GPF

Ce paramétrage n'est utilisé que si rien n'a été paramétré en TPR A4[24,29]

devis_standard A2[13,18]

Type et code du paramètre à lire pour l'alimentation du devis avec la fiche produit

Les type et code du paramètre de configuration d'intégration des produits finis sont récupérés dans l'ordre suivant :

1. TPR A4[50,55]

2. Devis standard, paramètre de lancement, A2[13,18] (ici)

3. par défaut, #CF IPF

(voir Alimentation du devis standard depuis le code produit en bas de cette fiche)

devis_standard A2[19]

Réservé

devis_standard A2[20,25]

Type et code du paramètre de lancement du programme exécuté par F28 (appel à un programme externe, généralement enccde)

devis_standard A2[26,28]

Code du paramètre passé en argument au programme exécuté par F28

devis_standard A2[29,31]

Type de note par défaut pour la nomenclature

devis_standard A2[32,34]

Type de paramètre pour l'accès aux autres éditions

devis_standard A2[35,37]

Code tarif par défaut du sous-devis

devis_standard A2[38]

Préfixe par défaut pour le numéro de devis

Exemple : Si D est le préfixe par défaut, les numéros de devis seront créés sous la forme DAMMXXXX où A représente l'année en cours, MM le mois en cours et XXXX un compteur variable.

On peut aussi utiliser le compteur paramétré en valeur numérique 1.

Pour copier le devis commercial en dossier de fabrication : #CF TDC A1[9]

devis_standard A2[39]

N'EST PLUS UTILISE - REMPLACE PAR #CF OPT A1[21]

Mode de visualisation des messages de traces pour de devis optimisé

devis_standard A2[40,42]

Pourcentage d'acceptation des solutions d'optimisation par rapport à la solution optimale trouvée

(50% par défaut) - Entité Feuillet/Dépliant uniquement

Exemple : Si la solution optimale trouvée a un coût de 1500 et que le pourcentage d'acceptation est de 50%, les solutions dont le coût est supérieur à 2250 seront automatiquement rejetées.

devis_standard A2[43,45]

Type de note par défaut pour les références multiples (DEV par défaut)

devis_standard A2[46,48]

Type de note par défaut à afficher dans le détail du descriptif de roulage (DEV par défaut)

devis_standard A2[49,54]

Type et code du paramètre de configuration de (ré)génération batch des PF (accessible à partir du menu Fichier du devis multi-métiers)

Nécessite la permission MEN/DEV_REGEN_PF

Les type et code du paramètre de configuration de (ré)génération batch des PF sont récupérés dans l'ordre suivant :

1. TPR note PARAM_REGENERE_PF

2. TPR A4[24,29]

3. Devis standard, paramètre de lancement, A2[49,54] (ici)

4. par défaut, #CF GPF

devis_standard A2[55]

Vérification de cohérence et mise à jour de la saisie du nombre de références

N Pas de vérification de cohérence (par défaut)

Aucune mise à jour du nombre de références sur l'entête

Aucune mise à jour du nombre de références sur les entités

V Vérification de cohérence (demande de confirmation si incohérence détectée)

Si confirmation :

Aucune mise à jour du nombre de références sur l'entête

Mise à jour systématique du nombre de références sur les entités

C Vérification de cohérence (demande de confirmation si incohérence détectée)

Si confirmation :

Mise à jour sur confirmation du nombre de références sur l'entête

Mise à jour systématique du nombre de références sur les entités

O Vérification de cohérence (demande de confirmation si incohérence détectée)

Si confirmation :

Mise à jour systématique du nombre de références sur l'entête

Mise à jour systématique du nombre de références sur les entités

S Vérification de cohérence (aucune demande de confirmation si incohérence détectée)

Si incohérence détectée :

Mise à jour systématique du nombre de références sur l'entête

Mise à jour systématique du nombre de références sur les entités

Voir aussi TIM A1[4] (Pas de mise à jour du nombre de références sur l'entité)

devis_standard A2[56]

Activation de la nouvelle saisie du détail des matières, opérations et sous-traitance (O/N, N par défaut)

devis_standard A2[57]

Edition de tous les sous-devis ou du sous-devis courant uniquement ?

S Edition du sous-devis courant (par défaut)

D Edition de tous les sous-devis

C Edition de tous les sous-devis sur demande de confirmation (la question n'est posée que si le devis a plus d'un sous-devis)

devis_standard A2[58]

Ouverture automatique de la saisie du détail de l'entête du devis

N Non (par défaut)

C En création

T Systématique

devis_standard A2[59]

Reprise des informations de l'adresse principale lors de la création d'une adresse secondaire

O Oui (par défaut)

N Non

C Demande de confirmation

Valeur alpha3

devis_standard A3[1,3]

Site de production par défaut de l'entête de devis

Voir aussi #CF SIT et USE A3[10,12]

Tableau de bord du multisite

devis_standard A3[4]

Autoriser la saisie d'un client temporaire (O/N, O par défaut)

devis_standard A3[5,10]

Type et code du paramètre de la configuration de recopie des informations complémentaires client (TSC)

Recopie des informations complémentaires (TSC) saisies sur le client du sous-devis courant vers des informations complémentaires (TSC ou LCO) sur le sous-devis ou l'entité.

Remarques :

• La recopie des informations complémentaires client se fait lors de la recopie d'une entité (génération d'une entité de référence ou recopie d'une entité existante)

• Si la valeur existe sur le sous-devis ou l'entité cible, la recopie n'est pas faite

• Cette fonctionnalité est une reprise de celle existante dans la saisie du devis transformateur carton
(devis_tc A3[1,6])

devis_standard A3[11]

Le F7 sur le produit présente uniquement les articles du client ET les articles qui ne sont pas associés à un client.

O Complément de recherche sur le F7

N Pas de complément (par défaut)

devis_standard A3[12,14]

Type de notes pour la gestion des stocks excédentaires

Ce paramètre a été déplacé dans la note TYPE_NOTES_EXCEDENT du #CF TDC.

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes du paramètre TEN sont prioritaires sur celles-ci.

Autres notes, triées

ACCES_MAT_REFERENCE

21,26 Type et code du paramètre de lancement d'accès à la saisie de la fiche article

Soumis à autorisation, voir USE A2[28].

AFF_EVENEMENT_

Cette note est prioritaire sur celle du #CF EVT.

AFF_NOTES_CLI_DEVIS

21,59 Liste des types de notes clients à afficher à la validation de la saisie de l'entête du devis

13 types de 3 caractères par ligne

Voir l'option Onc

ARTIOS_DECONNECTE

21 Utiliser l'interface ArtiosCAD en mode déconnecté (O/N, N par défaut)

ARTIOS_RECONNEXION

21 Reconnexion systématique à VMC avant chaque étude ArtiosCAD à traiter en réactualisation des images ArtiosCAD

ARTIOS_TEMPO

21,23 Temps d'attente entre chaque demande d'actualisation d'étude Artios (en secondes)

ASSURE_MODIF_FEFCO

21 Active la sécurisation de l'accès aux pointages en la proposant en consultation par défaut (O/N, N par défaut)

Dans la saisie des devis, il est possible d'accéder aux pointages par Ctrl+E.

Actuellement, cette fenêtre de saisie est modifiable et les données présentées peuvent être extrêmement sensibles.

Pour éviter que l'utilisateur ne valide par mégarde des modifications involontaires, on ajoute une possibilité de paramétrage permettant d'ouvrir la fenêtre des pointages en consultation seule en ayant dans le menu Actions un bouton permettant de passer en mode modification.

ATTENTION : Il n'y a pas de raccourci clavier pour passer en mode modification.

Cette possibilité existe dans le devis multi-métiers, le devis transformateur carton ondulé, et tous les devis en général.

BORNES_DONNEE_TEC_

Contrôles des valeurs saisies par rapport à des bornes minimum/maximum

19 Numéro de donnée technique (1 à 4)

21,30 Valeur minimum (999999.999)

32,41 Valeur maximum (999999.999)

Ce fonctionnement est valable pour les programmes suivants

Saisie des commandes d'achat (cdef)

Saisie des inventaires (inventaire)

Saisie des devis multi-métiers (ici)

Saisie des matières (mat)

Visualisation des besoins matières (v_cde_5)

Le paramétrage de contrôle sera recherché dans l'ordre suivant

1. Famille de la qualité matière

2. Type de commande d'achat (saisie des commandes d'achat uniquement)

3. Paramètre de lancement du programme (ici)

CBACON

7,9 Code blocage automatique à contrôler

Permet d'alimenter les codes blocages automatiques lors du transfert du devis en commande.

#CC_

Contrôle des champs - Intégration du devis TC dans le devis multi-métiers

Voir la page récapitulative

CHEMIN_IMAGE_ARTIOS

21,30 Chemin d'accès aux images ArtiosCad (Répertoire de création des images 2D des études sur configuration Artios)

CHOIX_FOU_CONT

21 Dans la recherche, si plusieurs fournisseurs respectent les contraintes techniques, doit-on afficher la liste pour effectuer un choix ? (O/N) Dans le cas où on n'affiche pas, aucun fournisseur ne sera proposé. Voir l'option Oct.

CODE_BESOIN_SMC

21,23 Code paramètre pour le paramétrage général des besoins - SMC par défaut

C'est sur paramétrage qu'est indiqué le mode de recherche du tarif des matières.

Attention, on ne doit rechercher le tarif que pour le fournisseur, recherche avec le type C uniquement.

CODE_BLOCAGE_AUTO

Codes blocages

21,23 Code blocage automatique

24,41 Champ d'action du code blocage :

F11_ENTETE Activation après le calcul sur l'écran principal du devis (F11)

F11_MARGES Activation après le calcul sur l'écran du tableau des marges (F11)

F23_ENTETE Activation après le lancement du calcul optimisé sur l'écran principal du devis (F23)

F26_ENTETE Activation après le lancement du transfert en commande sur l'écran principal du devis (F26)

F26_GEN_DOS Activation à la création du dossier de fabrication (transfert du devis en commande sur l'écran principal du devis, touche F26)

F30_GEN_PF Activation avant la génération des PF (F30 sur entête/entité du sous-devis)
BLD A1[3,5] = 007

PRIX_REMIS Activation après la saisie du prix remis (écran de saisie des marges et écran de saisie des variantes)

SAI_DEVIS Activation après la saisie du numéro de sous-devis - Voir la gestion des versions de produits

SEL_DEVIS Activation après la saisie du numéro de sous-devis à recopier - Voir la gestion des versions de produits

VAL_ENTETE Activation à la validation de l'écran principal du devis (F10, F9, F6)

VAL_MARGES Activation à la validation de l'écran du tableau des marges (F10)

PRIX_NEGOCIE Activation après la saisie/modification du prix négocié
(écran de saisie des marges et écran de saisie des variantes)
Voir la note FORMULE_RECH_MARGES dans #CF DER.

CODE_NON_JONCTION

21,23 Code paramètre (de type .JE) correspond à la valeur Sans jonctionnement

Intégration du devis TC dans le devis multi-métiers

CODE_SANS_COLISAGE

21,23 Code paramètre (de type .SC) correspond à la valeur Sans colisage

Intégration du devis TC dans le devis multi-métiers

CONF_TAR_PX_NEGOCIE

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser

27,29 Code tarif à utiliser lors de la recherche :

#D# Code tarif du devis (zone l2_bareme) ( par défaut)

#C# Code tarif du client (zone cl_tar)

XXX Code tarif spécifique (où XXX est un code tarif existant pour le type de paramètre TAR)

Remarques :

- Si ce paramétrage n'est pas mis en place, aucune recherche de tarif ne sera effectuée pour alimenter le prix négocié.

- Si aucun tarif n'est trouvé, le prix négocié n'est pas mis à jour.

- Dans le cas où la recherche de tarif pour le prix négocié est activée, le paramétrage de forçage du prix négocié par le prix remis est automatiquement désactivé (voir #CF DER A2[39]), ainsi que le paramètre équivalent utilisé dans le transfert de devis en commande (voir #CF TDC A1[30]).

- Attention : l'unité de saisie du tarif (UNI) doit correspondre à l'unité de remise de prix du devis (QRP)

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

COPIE_NOTES_MAT_DEV

21,23 Type de notes article à recopier vers le devis (source)

24,26 Type de notes devis pour la recopie des notes d'articles (cible)

DEPASSEMENT_LARGEUR

21,24 Dépassement autorisé dans la largeur de la palette (en mm)

Intégration du devis TC dans le devis multi-métiers

Voir aussi le TSC 224 ainsi que la page dédiée à l'optimisation du conditionnement.

DEPASSEMENT_LONGUEUR

21,24 Dépassement autorisé dans la longueur de la palette (en mm)

Intégration du devis TC dans le devis multi-métiers

Voir aussi le TSC 224 ainsi que la page dédiée à l'optimisation du conditionnement.

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

DOCUMENT_PLI

Permet d'ouvrir un document Windows associé au code pli saisi sur la ligne de décomposition de la feuille (touche Control-W).

21,60 Chemin d'accès au document Windows associé au pli

Il est possible d'utiliser les caractères réservés suivants pour remplir le nom de fichier à l'exécution

?01 Réservé

?02 Code client

?03 Devis_Sous devis_Entité

?04 Code pli

Cette note est recherchée dans l'ordre de priorité suivant :

1. sur le code pli

2. sur le type d'entité

3. paramètre de lancement de la saisie des devis (ici)

EDITION_DEVIS_

15 Numéro de menu d'édition

1 Edition technique simplifiée

2 Edition technique détaillée

3 Edition du dossier de fabrication

4 Edition des schémas d'imposition

5 Edition commerciale

6 Edition de l'offre client

7 Accès au lanceur d'éditions

21,26 Type et code du paramètre de lancement de l'édition

27,60 Titre pour le menu du lancement des éditions

EFF_CCOUT_A_EXCLURE

21,28 Centre de coût à exclure du calcul de l'effectif nécessaire

Une ligne de note par centre de coût à exclure.

Ce paramétrage permet d'exclure un centre de coût pour toutes les opérations du devis calculé.

La même dote existe au niveau des formules : les 2 notes sont complémentaires.

ETAT_DEVIS_FAB_MOD

21,23 Code état des sous-devis de fabrication après mise à jour de la commande

Voir l'option Odd et USE A2[29].

EXCLUS_CONT_TARIF

Dans la vérification des contraintes techniques, faut-il contrôler la présence d'un tarif pour la qualité (O/N, N par défaut)

ATTENTION !!! Inversion du O/N

O On NE contrôle PAS.

N On contrôle

Voir l'option Oct.

FORCER_FOU_CONTRAINT

Dans le cas où un fournisseur est saisi mais qu'il ne respecte pas les contraintes techniques

C Demande de confirmation si l'on doit imposer ce fournisseur (valeur par défaut)

B Message indiquant que ce fournisseur ne respecte pas les contraintes (pas de forçage)

W Message indiquant que ce fournisseur ne respecte pas les contraintes, ce fournisseur est forcé

N Pas de message, le fournisseur est forcé.

Voir l'option Oct.

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

HAUTEUR_MAX_PALETTE

Utilisé dans l'optimisation du conditionnement

21,24 Hauteur maxi de la palette (en mm)

Intégration du devis TC dans le devis multi-métiers

HAUTEUR_PALETTE

Utilisé dans l'optimisation du conditionnement

21,24 Hauteur par défaut de la palette (en mm)

Intégration du devis TC dans le devis multi-métiers

INITIALISE_COPIE

Initialisation de zones après la recopie (ou génération, version, etc.) d'un sous-devis ou d'une entité

17 _ ou [blanc] selon la présence du caractère 18

18 Type de copie concerné par le paramétrage

C Copie

V Version

R Renouvellement

E Entité

G Génération

T Tous les types (par défaut) (la zone sera initialisée avec la valeur paramétrée quel que soit le contexte de la recopie)

21,38 Nom de la zone à initialiser : Toutes les zones des tables fle_2 et fle_imp.

40,60 Valeur d'initialisation de la zone

null : La zone sera vidée

[autre] : La zone sera mise à jour avec la valeur paramétrée

Exemples

INITIALISE_COPIE l2_num_affaire null

INITIALISE_COPIE l2_lig_affaire null

Les zones liées au numéro d'affaire seront vidées quel que soit le contexte de la recopie.

INITIALISE_COPIE_G l2_site 001

Le site de production sera initialisé à 001 lors d'une génération de sous-devis.

INSERT_ARTIOS

La mise à jour des données non figées est paramétrée par environnement dans l'application Volume Media Center.

Cette note est dont périmée.

INVERSION_FORMAT

21 Inversion du format (O/N, N par défaut)

Remplace le paramétrage utilisé sur le TEN A2[29].

Voir l'option Oct.

LCO_NB_POSES_SM

21,23 Code LCO nombre de poses Sens Machine

LCO_NB_POSES_ST

21,23 Code LCO nombre de poses Sens Travers

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

MASQUER_ZONE_

Masquer des groupes de saisie dans l'écran d'entête du devis <VF>

14,19 Code écran

ENTETE Entête du devis

SAIREC Saisie du récapitulatif de prix

21 Type de zone

G Groupe de saisie (groupbox)

23,40 Nom de la zone

Si le code écran = ENTETE

TARIF Groupe de saisie Tarif

LIVRAISON Groupe de saisie Livraison

SUIVI Groupe de saisie Suivi du devis

ETAT Groupe de saisie Etat du devis

Si le code écran = SAIREC

ENTETE Groupe de saisie Entête

MATIERE Groupe de saisie Matière

OPERATION Groupe de saisie Opérations

SOUS_TRAITANCE Groupe de saisie Sous-traitance

FRAIS Groupe de saisie Frais supplémentaires

PRIX_DEVISE Groupe de saisie Prix devisé

NEGOCIATION Groupe de saisie Négociation

MESS_AVERTISSEMENT

Utilisé dans l'optimisation du conditionnement

21 Type du message d'avertissement de non respect des contraintes client

N pas de message (par défaut)

W warning uniquement

B message bloquant

Intégration du devis TC dans le devis multi-métiers

MODE_REAP_AUTORISE

21,60 Liste des modes de réapprovisionnement autorisés

Les modes disponibles sont les suivants :

S Stock interne

C à Commander

F Fabrication

B Fabristock

E Externe

Il faut lister les lettres des modes que l'on souhaite avoir à disposition dans les zones correspondantes.

Les modes non listés n'apparaîtront pas.

En l'absence de cette note, tous les modes sont disponibles.

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions

Paramétrage équivalent au C

Exemple

3CLI2QA

Voir #CF EVT.

OBJET_DOCUMENT

21,23 Type de document (DEV)

25,60 Objet du document pour le fax/email

PARAM_GENERER_CDE

21,26 Type et code du paramètre de configuration de transfert en commande (par défaut : #CF TDC)

Cette note est recherchée en priorité sur le TPR

PARAM_GENERE_OF

21,26 Type et code du paramètre de lancement de la génération des dossiers de fabrication

PARAM_REGENERE_OF

21,26 Type et code du paramètre de lancement de la régénération des dossiers de fabrication

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

PARAM_LCT_FORMULES

21,26 Type et code du paramètre de lancement de la saisie des formules

PARAM_RECH_VISU

21,26 Type et code de paramètre de lancement de la recherche par visualisation des devis

La note F7_RECHVISU est créée sur le paramètre de lancement de ce programme, puis effacée à l'issue du F7 lorsque l'utilisateur a choisi un devis/sous-devis.

PAS_DE_MSG_RECALCUL

21 Recalcul automatique des pointages sans message de confirmation

O Pas d'affichage du message de confirmation

N Affichage (Valeur par défaut)

RACINE_PRO

12,60 Liste des racines autorisées pour la numérotation automatique des prospects, séparés par un espace

Dans le cas où ces notes ne sont pas définies ici, elles seront recherchées sur #CF ATL.

Exemple : RACINE_PRO 02 03 04 : la numérotation prospect commencera par 02, 03, ou 04 (le 02 sera la racine par défaut car il apparaît en première position).

REACTUAL_FIC_TRACE

21,60 Chemin d'accès au fichier trace récapitulatif des sous-devis recalculés

(devis correctement réactualisés et devis réactualisés en anomalies)

Voir l'option Obr

REACTUAL_DATES_VAL

Réactualisation automatique des dates de validité des sous-devis recalculés (O/N, N par défaut)

Voir l'option Obr

RECH_FOU_CONT

21 Si aucun fournisseur n'est saisi, doit-on rechercher ceux qui respectent les contraintes techniques et possèdent un tarif pour la qualité demandée ? (O/N) Voir l'option Oct

RECOPIE_TSC_ART_REF

Permet de recopier un TSC d'un article sur ce même article appelé en références multiple de l'entité d'un devis

21,23 Type de TSC à recopier

REP_ETUDES_ARTIOS

Le répertoire d'accès aux études ArtiosCAD est paramétré par environnement dans l'application Volume Media Center.

Cette note est donc périmée.

RETRAITLARGEURMAX

21,24 Retrait autorisé dans la largeur de la palette (en mm)

Permet de gérer le retrait maximum lors du calcul du conditionnement (pour éviter de mettre un PF trop petit sur une trop grande palette).

Intégration du devis TC dans le devis multi-métiers

RETRAITLONGUEURMAX

21,24 Retrait autorisé dans la longueur de la palette (en mm)

Permet de gérer le retrait maximum lors du calcul du conditionnement (pour éviter de mettre un PF trop petit sur une trop grande palette).

Intégration du devis TC dans le devis multi-métiers

RUN_PROG_DEM_ACHAT

21,26 Type et code de paramètre de lancement du programme de demande d'achat

Permet de générer une demande d'achat à partir d'un devis via la touche F32.

STOCKAGE_NUM_ETUDE

21,27 Stockage du numéro d'étude sous la forme LCO_nnn où nnn = type de LCO

Permet d'appeler une application Windows (VoluPicador) afin de visualiser une étude CAO.

Dans la saisie des articles, le numéro d'étude est enregistré dans le TSC 071.

Plus d'info

_SUP_ORDER_BY_RECAP

21,60 Complément de tri pour l'affichage des sous-devis recalculés - GENERO

(uniquement quand le mode batch B est désactivé)

Par défaut : Code client, code produit du devis, numéro de devis, numéro de sous-devis

Voir l'option Obr

_SUP_REQ_DEVIS

21,60 Complément de sélection pour la recherche de devis (Entête)

_SUP_REQ_FFA

21,60 Complément de sélection pour la recherche de fiches de fabrication (Entête)

_SUP_REQ_FEFCO

21, 60 Complément de requête sur la recherche des codes FEFCO

Ce paramétrage est valable pour les paramètres de lancement de tous les programmes utilisant la recherche des FEFCO / ECMA.

Le devis multi-métiers utilise les codes ECMA pour définir les contours des étiquettes, des plis, etc.

Pour un secteur multi-activité, il est utile de cibler la recherche selon l'activité.

_SUP_REQ_FLE_MAR_RCP

21,60 Complément de sélection pour le calcul du total des prix de revient de l'écran des marges (table fle_mar)

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FLE_OPE_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FLE_TRA_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FOU_CONT

21,60 Supplément de requête pour la recherche des fournisseurs respectant les contraintes techniques Voir l'option Oct

_SUP_REQ_PRODUIT_FIN

21,60 Complément de sélection pour la recherche et le contrôle d'un produit fini

Ce complément est utilisé lors de l'interrogation par F7, ainsi que sur le contrôle du champ.

_SUP_REQ_REACTUAL

21,60 Complément de sélection des sous-devis à recalculer

Voir l'option Obr

_SUP_REQ_SIT_CAL_CES

21,40 Code de la zone indiquant le site à prendre en compte

Par exemple : fi_sit - Tableau de bord du multisite

(on comparera le site du tarif (tr_site) avec le site de fle_imp (fi_sit)

_SUP_REQ_TRANSPORT

21,60 Complément de sélection pour la recherche de transporteur (Entête)

_SUP_SQL_IMG_ARTIOS

21,60 Complément de sélection des devis/sous-devis/entités à prendre en compte pour la réactualisation des images ArtiosCAD

La sélection peut se faire sur les tables fle_2 et fle_imp

_SUP_SQL_PRODUIT_FAB

21,60 Complément de sélection des entités concernées par la réactualisation des images ArtiosCAD (produits fabriqués)

_SUP_SQL_REGENERE_PF

21,60 Complément de sélection sur la table d'entête des devis (fle_2) pour la régénération des produits finis

Exemple : (sélection des devis déjà transférés en commande)

and l2_dossier is not null

autres compléments

Voir les notes du paramètre TEN

_TIT_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_DOCUMENT

21,23 Type de document (DEV)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TITRE_ECRAN_ENTETE

21,60 Titre de l'écran de saisie d'entête

TITRE_ECRAN_GAMME

21,60 Titre de l écran de saisie des gammes

TITRE_LIGNE_DETAIL

21,60 Titre de la fenêtre de détail de la ligne de commande

Permet de paramétrer le libellé du titre de la fenêtre de détail de ligne de commande (F8 sur ligne de commande).

TSC_MODIF_POINTAGES

21,23 Code TSC pour l'enregistrement de la modification d'un ou plusieurs pointages (détail FEFCO, Control-E)

Par défaut : MPT - Voir l'option Ocr.

TSC_TARIF_CLIENT

21,23 Code TSC de saisie du tarif client (TSC sur le client du devis)

24 Zone TSC de saisie du tarif client

F Zone char3_1

G Zone char30

H Zone char3_2

TYPE_NOTE_PHASE

21,23 Type de note sur la phase à afficher dans l'écran fle_gam_opt

TYPE_NOTE_REFERENCE

21,23 Type de note complémentaire pour les références multiples (un type de note par ligne)

TYPE_NOTE_ROULAGE

21,23 Type de note à prendre en compte dans la saisie des notes du descriptif de roulage

(un type de note possible par ligne de paramétrage)

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

VERIF_CONTRAINTE_ACT

Vérification des contraintes actives

O On ne vérifie que pour les fournisseurs/qualité ayant des contraintes actives

N Les fournisseurs qui auront des contraintes inactives ou qui n'auront pas de contrainte seront considérés comme respectant les contraintes.

Voir l'option Oct.

VOLUOPTIMIX

21,60 Chemin et nom de l'application VoluOptimix sous Windows

Permet de saisir l'emplacement de VoluOptimix sous Windows afin de simplifier l'installation et de permettre de fonctionner avec TSE.

En l'absence de paramétrage, VoluOptimix sera recherché dans le répertoire système de Windows.

Le séparateur est le double backslash.

Si le chemin dépasse 40 caractères, vous pouvez créez plusieurs notes : le programme les concaténera.

Exemple

VOLUOPTIMIX D:\\Program Files\\Volume Software\\

VOLUOPTIMIX VoluOptimix\\VoluOptimix

Comme on le voit dans l'exemple, l'extension exe est facultative.

Fin des notes triées

Gestion des versions de produits

Cette fonctionnalité est disponible à partir de la V. 4.0.170.2

But

Permettre de gérer les versions de produits dans la saisie du devis multi-métiers.

  • La création des versions de produits se fait après sélection d'un sous-devis d'origine, en choisissant l'option Version de dans la zone correspondante au mode de copie.

  • Une fois le sous-devis d'origine renseigné, une fenêtre permet de sélectionner les produits nécessitant une nouvelle version.

  • Pour chaque nouvelle version créée, on stocke dans une information complémentaire (#VE) le code produit d'origine et le numéro de version.
    Le code validité du produit d'origine peut alors être automatiquement mis à jour (ex : obsolète)

  • Un nouveau code blocage automatique peut être mis en place sur un devis lorsqu'un ou plusieurs produits ont un code validité incompatible avec la saisie de devis. Ce code blocage peut être activé à la saisie d'un sous-devis ou lors de la sélection d'un sous-devis à recopier.

  • Lorsqu'un sous-devis est bloqué par une version de produit obsolète, un écran permet de visualiser les produits obsolètes avec leur dernière version de produit disponible.

Paramétrage

devis_standard

Note CODE_BLOCAGE_AUTO

21,23 Code blocage automatique de type BLD

24,41 Champ d'action du code blocage

SAI_DEVIS Activation après la saisie du numéro de sous-devis

SEL_DEVIS Activation après la saisie du numéro de sous-devis à recopier

BLD A1[3,5] = 005

Contrôle de la validité des articles.

Le blocage est activé si au moins un article a une validité incompatible avec la saisie de devis (voir paramètre QA ci-dessous)

BLD A1[13]

Autorisation de blocage / déblocage en consultation de devis (O/N, N par défaut)

BLD A2[7]

Blocage de la modification du devis (O/N, N par défaut)

(si le devis est bloqué, celui-ci n'est accessible qu'en consultation).

BLD A2[8]

Blocage de la sélection du devis pour recopie (O/N, N par défaut)

(si le devis est bloqué, il ne pourra pas être sélectionné comme devis source à recopier dans la saisie des devis).

BLD note TYPE_DE_BLOCAGE

21,23 Type de blocage : VER, seul type existant à ce jour (05/10/2010), indiquant un blocage pour les versions de produits.

Ce paramétrage permet d'activer le détail de visualisation des produits obsolètes/nouvelles versions lors de l'accès à un sous-devis bloqué.

QA A1[34]

Possibilité d'empêcher l'utilisation de l'article dans un sous-devis (N/W/B)

TPR

Note PARAM_GEN_VERSIONS

21,26 Type et code du paramètre de la génération des versions de produits

Par défaut, les types et code du paramètre de configuration de la génération des versions de produits sont ceux de la configuration de la génération des produits finis, soit :

" TPR A4[24,29]

" Paramètre de lancement du devis, A2[49,54]

Par défaut : #CF GPF

#CF GPF

21,23 Note CODE_MAJ_QA_VERSION

Code validité à mettre en place sur les produits obsolètes après génération d'une nouvelle version de produit.

TSC #VE

Informations de version

TSC #VN

Informations de version

Paramètres nécessaires (triés)

Ce tableau regroupe l'ensemble des paramètres du devis. Il n'est pas exhaustif.

D'autres paramètres sont regroupés dans un chapitre séparé, lorsqu'ils sont communs à une fonction particulière (exemple : Gestion des versions de produits)

Lorsqu'un paramètre est propre au devis optimisé, la mention (devis optimisé) peut être indiquée.

Opérations élémentaires et dépendances

(formules)

ul_param[13] = X : Le coefficient de conversion n'est pas pris en compte (Coefficient = 1)

ul_param[22] Gâche de finition

Notes sur les formules : EXEC_CODE_CALCUL_MJ

Pour permettre le lancement d'un code calcul de mise à jour (MJ) à la fin de l'exécution d'une formule matière, opération et/ou sous-traitance, lors du calcul du devis (Touche F11).

Nouvelles formules figées

MIMF7 Calcul du papier adapté pour le Multibande - Cette formule existait déjà. Voir les caractères 12 et 13.

MPAP50 Calcul du papier pour des gardes blanches (non imprimées)

MPLA50 Calcul des plaques Recto - devis standard

MPLA51 Calcul des plaques Verso - devis standard

MPLA52 Plaques vernis recto - devis standard

MPLA53 Plaques vernis verso - devis standard

OGAR50 Collage des gardes

OIMF50 Réglage recto - devis standard

OIMF51 Réglage verso - devis standard

OIMF52 Calage des plaques recto - devis standard

OIMF53 Calage des plaques verso - devis standard

OIMF54 Calage des changements de plaque recto - devis standard

OIMF55 Calage des changements de plaque verso - devis standard

OIMF56 Lavages recto - devis standard

OIMF57 Lavages verso - devis standard

OIMF58 Roulage roto ou recto feuille - devis standard

OIMF59 Roulage verso - devis standard

OIMF60 Réglage vernis hors ligne recto - devis standard

OIMF61 Réglage vernis hors ligne verso - devis standard

OIMF62 Calage des plaques vernis recto - devis standard

OIMF63 Calage des plaques vernis verso - devis standard

OIMF66 Lavages vernis recto - devis standard

OIMF67 Lavages vernis verso - devis standard

OIMF68 Roulage recto vernis- devis standard

OIMF69 Roulage verso vernis - devis standard

OIMF70 Temps de séchage avant bascule

OIMF74 Changement de plaques en repiquage recto

OIMF75 Changement de plaques en repiquage verso

OMAD50 Calage Massicotage droit - devis standard

OMAD51 Coupe Massicotage droit - devis standard

OMAD52 Calage refente du papier destiné à des gardes blanches (non imprimées)

OMAD53 Refente du papier destiné à des gardes blanches (non imprimées)

OPLA50 Copie plaques recto - devis standard

OPLA51 Copie plaques verso - devis standard

OPLA52 Traceur - devis standard

OPLI50 Calage plieuse

OPLI51 Pliage

Codes calculs

nouveaux

ou

modifiés

PG Paramètres généraux - Valeur du temps de séchage avant bascule (devis optimisé)

RF - Information référence multiple

IE - Informations entité - Code modifié : Si caractère 1 = 3, on regarde le caractère 2.

MH - Infos machine - nouveaux codes 5, 6, 7, N, O, P

MP - Impression multi-passages

TC - TSC, caractère 1 J

#CF AFF

Gestion des affaires (nouveau paramètre de configuration)

#CF ATL

A1[35] La laize des bobines est saisie dans la zone mp_lon ou mp_lar (devis optimisé)

A2[11] Numéro automatique des prospects avec folioteur

A2[12,13] Longueur de la racine (pour la numérotation automatique des prospects)

A2[14,15] Longueur de la racine (pour la numérotation automatique des prospects)

A2[17] Type de profil carton

A4[16,23] Libellé du code (FEFCO, ECMA, ...) sur écran du devis

Note RACINE_PRO (recherchée en priorité sur le paramètre de lancement du devis standard)

#CF CAR

A1[4] La laize correspond à la zone mp_lar de la fiche article.

#CF CDE

A1[23,25] Type de mouvement de stock en sortie normale

A1[26,28] Type de mouvement de stock en sortie réserve

A1[29,31] Type de mouvement de stock en entrée prévisionnelle

A1[36,38] Type de mouvement de stock en entrée prévisionnelle

#CF CLI

Configuration des tiers

Entre autres :

A1[36] à A1[38] Gestion des représentants

#CF DEG

Toutes les zones, et notamment les suivantes :

A1[6] Mise à zéro de valeurs numériques 1 et 2 en génération de devis

A1[7] Mise à zéro de valeurs alphanumérique 1 et 2 en génération de devis

A1[16] Affichage du message Il existe n entités. Une autre ? à la fin de la saisie d'une entité.

A1[35] = O pour initialiser correctement la dimension engagée utilisé dans le calcul du pliage (devis optimisé)

A1[45] I La lecture des gâches de finition passe par la formule IMF GF (gâche fixe) et IMF GV (gâche variable).

A3[60] Possibilité de mettre à jour le format fini des entités avec le format fini saisi sur l'entête du devis.

A4[9] Activation de l'utilisation des LCO contextuelles dans le devis.

Il faut aussi paramétrer des notes commençant par CONTEXTE_LCO sur le paramètre LCO.

A4[20] Mode de fonctionnement du conditionnement

A4[21] Accès au nouvel écran des phases

A4[22] Prise en compte de la date de début de validité pour la recherche du taux dans les centres de coûts

A4[23] Vérification de l'appartenance d'un produit à un client dans l'écran des références multiples du devis standard

A4[27] Recopie du numéro d'affaire/ligne lors de la recopie d'un devis/sous-devis

A4[28] Pas d'application du facteur multiplicateur (paramétré en caractère 6 dans les codes calculs)

A4[29] Pas d'accès à la commission du représentant dans le devis multi-métiers (zone masquée)

A4[32] Recopie des informations clients (Code et adresse secondaire) lors de la recopie de devis

A4[33] Utilisation des gâches cumulatives

A4[34] Interdiction de suppression d'un devis, d'une entité ou d'une ligne de nomenclature lorsque le devis a été transféré en commande

A4[35] Mode de recopie des références multiples lors de la recopie d'entité

A4[36] Niveau du contrôle sur la cohérence entre la pagination issue des plis saisis et de la pagination totale de l'entité (devis optimisé)

A4[37] La quantité traitée dans le pliage est en nombre d'exemplaires ou en mètres linéaires.

Note FORMULE_CONV_UNITE

Note MAJQTE

Note CDEVTYP

Note TPS_ATT_SECHAGE_BASC (devis optimisé)

#CF DER

A2[39] Initialisation des prix négociés par les prix remis

A2[40] Exclusion du port client

A2[42] Pas d'accès à l'écran de récapitulatif

A2[43] La marge sur le prix de vente des références multiples est reprise automatiquement à partir de celle saisie sur le sous-devis.

Notes TITRE_LIGNE_FRAIS_1 et TITRE_LIGNE_FRAIS_2

#CF GPF

(ou tout autre paramètre de configuration défini en A2[7,12])

A2[2] Génération des séquences de commande (existait déjà)

A2[3] Génération de la nomenclature (existait déjà)

A2[12] Valeur figée du mp_param[25] généré pour les articles de type référence multiple (article générique)

A2[13] Génération des références multiples

A2[14] Ouverture d'écran de saisie d'informations article

Notes REMPLIR_ZONE_REFERENCE et CODIF_REFERENCE

A2[16] Génération des produits composants en multi-références

A2[17] Recopie d'article vers une autre société

A2[21] Article suivi en stock

A2[23] Génération du code produit de l'entité

A2[24] Valeur figée du mp_param[25] généré pour les articles de type affiche (article générique)

A3[5] Mise à jour uniquement pour la fiche de conditionnement

Note RECOPIE_ART_SOC

Note REMPLIR_ZONE_ : Le type de clé du TSC (zone cible) n'est plus figé à MP.

Note CODIF_COMPO_NOM : ajout du champ folio_nom

#CF IPF

Nouveau paramétrage pour l'Alimentation du devis standard depuis le code produit

A1[1] Ouverture d'un écran de vérification d'intégration des données

Notes REMPLIR_ZONE_ENTETE et REMPLIR_ZONE_ENTITE

A1[2] Alimentation du devis par les informations du produit (non générique)

#CF OPT

Configuration de l'optimisation du devis

#CF RAS

(ou tout autre paramètre de configuration défini dans la note RECOPIE_ART_SOC du #CF GPF (ou de tout autre paramètre de configuration défini en A2[7,12]))

Configuration de la recopie d'article vers une autre société

#CF SMC

N1 : Tolérance laize en millimètres

N2 : Tolérance coupe en millimètres

A1[10,11] Nombre maximum de matières optimales à afficher lors de la recherche

A1[21] Mode de calcul du nombre de poses bobines (devis optimisé)

A1[22]Critère de sélection automatique sur les familles feuilles et bobines (devis optimisé)

A1[23] Mode affichage imprimerie (devis optimisé)

#CF SMC A2[20] Forçage de l'utilisation du nombre de poses saisies dans l'entité du devis

Note LIB_COUPE_ et LIB_LAIZE_ (devis optimisé)

Voir aussi TEN note CODE_PAR_CONF_SMC

#CF TDC

(ou tout autre paramètre de configuration défini dans la note PARAM_GENERER_CDE)

Transfert du devis en commande : tout le paramétrage (nouveau)

#F1

Formats finis standards. N1 et N2 Largeur et longueur du format (en mm)

#F2

Diamètres standards du mandrin. N1 et N2 Diamètres intérieur et extérieur du mandrin (en mm)

#F3

Pourcentage de marge standard (saisie des variantes)

#LI

Liens entre tables

Valeurs alpha 3 et 4 (devis optimisé)

Notes LIBELLE_NUM7 à LIBELLE_NUM10 (devis optimisé)

#MA

Matrices de saisie - Voir aussi le programme matrice

Note LIB_COL_1_TAB_SEL

AFE

Etape d'affaire (libellé uniquement - pas de paramétrage)

CND

Toute la zone alpha 1

DPC

A1[8,10] Code unité de quantité

EAF

Etat d'affaire (libellé uniquement - pas de paramétrage)

ENR

Sens d'enroulement des bobines d'étiquettes - Pas de paramétrage particulier

EVT

A1[4] Saisie obligatoire des affaires en création d'action

Voir aussi la note _SUP_ORDER_BY_ACT dans le programme prospect

FAB

A1[1] Filtre de recherche sur le type de fabricant

GMA

Note DPC_ASSOCIE

LCO

Notes CONTEXTE_LCO pour l'ouverture contextuelle des LCO

LIB

LIB XXX, où xxx représente le code statistique : CS1, CS2, CS3 ou CS4

Libellés des codes statistiques

Note LIBELLE_CODE_STAT_

MRD

Motif de refus du devis

NDF

Nature de frais A1[1]

PHA

A1[22] Participe à l'éclatement de l'amalgame - Voir aussi note INFOS_PHASE_REF_ sur TEN

A1[24] Afficher une ligne de totalisation pour cette phase dans la saisie du tableau des phases

A1[25,27] Type de phase (utilisé dans l'optimisation des phases, touche F23) (devis optimisé)

Le paramétrage de la brochure sans couture se faisait précédemment avec le code SCO.

Ce code a été normalisé et est devenu BSC.

Nouveaux codes

GAR Gardes (imprimées et blanches)

JAQ Jaquette

Note EXCLUE_DETAIL_PHASE

PLI

Types de pli : tout le paramétrage (utilisé aussi dans le devis optimisé)

QA

A1[20] Qualité de l'outil

QAF

Qualificatif d'affaire (libellé uniquement - pas de paramétrage)

REP

Représentants

Entre autres :

A4[29] Le représentant est un représentant externe (agence)

A4[30,35] Code tiers du représentant externe

SCA

Scénario d 'affaire (libellé uniquement - pas de paramétrage)

SCE

A1[8] Utilisation des modules d'optimisation

SUI

Suivi d'affaire. Le paramétrage est le même que pour le code FAB.

Il est donc nécessaire de recopier tout le paramétrage de FAB vers SUI.

TDE

A1[1,5] Mot de passe

TDF

Type de finition (devis optimisé)

TEN

Tout le paramétrage sauf la plage A1[3,30]

et plus particulièrement, pour le devis optimisé :

A1[31,33] Nouveaux codes

GAB Garde blanche

JAQ Jaquette

A2[28] Type d'optimisation de devis

A2[42] - A2[43] - A2[44]

A2[45] Possibilité d'interdire la saisie des plis complexes et manuels en type de pli principal

A2[46] Accès interdit à la saisie du détail de la nomenclature multi-niveaux

A2[47] Optimisation du papier

A4[12] Mode de calcul pour la recherche de matière optimisée

A4[16] Modification du paramétrage

A4[52] Active le réajustement de laize automatique

A4[53] Récupération de la référence créée sur l'entête après la recopie de l'entité par défaut

Notes

Note LIB_NB_REFERENCES

Toutes les notes commençant par OPT_OPE_

Toutes les notes REC_MACHINE

_SUP_REQ_PLI

TITRE_ECRAN_BANDES

Toutes les notes commençant par TRT_MAC_

CODE_PAR_CONF_SMC

CODE_ECRAN_ENTITE

TYPE_PALETTE_DEF et MODE_GESTION_DEF Intégration du devis TC dans le devis multi-métiers

TIM

Types d'imposition

TMC

A4[6] Type de machine (Impression Rotative, Feuille, Superposée, Encarteuse, Plieuse, etc.)

Les libellés alpha 1 , alpha 2 et alpha 3 sont figés selon le type de machine (devis optimisé)

Note CODES_CONTROLE_FACO

TOL

N1 et N2 : Pourcentages de tolérance mini et maxi

TPI

TPI A1[1] : Face de passage (Type de passage d'impression)

TPR

A1[1,8] Numéro de devis par défaut à utiliser lors d'une recopie/génération

A1[9,11] Type de produit

A1[21,23] Type de produit (devis optimisé)

A1[49] En devis mono-référence, les ensembles sont situés sur les lignes de niveau 1 de la nomenclature (et non sur le devis).

A2[6] Initialisation automatique de la quantité en création d'entité

A2[7] Type d'automatisme à mettre en oeuvre pour initialiser par défaut la zone de collage de la ligne de référence multiple

A2[8] Saisie d'un devis de type PLV

A2[9] Un seul sous-niveau est autorisé dans la saisie de nomenclature

A4[8,10] Code d' entité par défaut (correspond à un TEN par défaut)

A4[11] Gestion de la nomenclature multi-niveaux

A4[12] Gestion des références multiples Ouverture automatique de la saisie du FEFCO / ECMA après le champ hauteur de l'écran de références multiples

A4[13] Ouverture automatique de la saisie du FEFCO / ECMA après le champ hauteur de l' écran de références multiples

A4[14] Accès au détail de ligne pour un article non générique dans l'écran des références multiples

A4[15] Cacher les lignes de totalisation dans l'écran de visualisation de détail des phases (Accès par F18).

A4[16] Ouverture automatique de la saisie des références multiples après la saisie de la quantité du devis.

A4[17] Dans la saisie de la nomenclature, activer la vérification du nombre de pages saisies au total par rapport au nombre de page sur le devis.

A4[21] Non-ouverture de l'écran des phases

A4[22] Recalcul automatique à la création d'une variante de quantité

A4[23] Proratisation des quantités des références multiples si la quantité du devis ou d'une entité est modifiée

A4[24,29] Type et code du paramètre de la configuration de la génération de produit (a priorité sur celui du paramètre de lancement, en A2[7,12]).

A4[30] Ouverture automatique de la saisie des références multiples après la saisie du nombre de références dans l'écran des entités

A4[31] Ouverture automatique de la saisie des LCO lors du premier calcul d'une entité

A4[32] Gestion des références multiples en saisie de devis mono-référence

A4[33] Ouverture automatique de la saisie des lignes complémentaires après la saisie de la nomenclature sur l'entête du devis (devis optimisé)

A4[34] Le cassage est autorisé pour ce type de processus (devis optimisé)

A4[35] L'épaisseur du dos de l'ouvrage déterminée par l'optimisation est sauvegardée dans l'entité de type COU (devis optimisé)

A4[36] Mise à jour de la pagination et du format fini de l'entête à partir de la saisie faite sur l'écran entité (devis optimisé)

A4[37] Sauvegarde du devis initial dans la nomenclature

Notes :

BLANC_TETE

BLANC_PIED

BLANC_BARBE

BLANC_PLI

DEPASSANT

FOR_POIDS_TRANSPORT

LIBELLE_REFERENCES

LIB_REF_ECMA

LIB_REF_FORMAT

LIB_DESIGNATION_1

LIB_DESIGNATION_2

LIB_ZONE_PAR_CHAR_1

LIB_ZONE_PAR_CODE_1

LIB_ZONE_PAR_CODE_2

LIB_ZONE_PAR_NUM_1

LIB_ZONE_PAR_NUM_2

LIB_ZONE_PAR_NUM_3

LISTE_TEN_AUTORISES

PARAM_GENERER_CDE (cette note est prioritaire sur celle du paramètre de lancement du devis standard)

TITRE_ECRAN_ROULAGE

TITRE_SAI_NOTES_NIV

TITRE_SAI_NOTES_REF

TITRE_SAI_NOTES_ROU

TYP_ZONE_PAR_CODE_1

TYP_ZONE_PAR_CODE_2

TYP_ZONE_TDF

VE_DOC_CLI

VE_DOC_DET

VE_DOC_SIM

TSC D01 à D07

(devis optimisé)

Margeur de couverture (Contrôle par rapport au format ouvert de la couverture) D01 D02 D07

Margeur de cahier (Contrôle par rapport au format fini de l'intérieur + rognes) D03 D04

Trilatéral en ligne (Contrôle par rapport au format fini de l'ouvrage) D05 D06

Epaisseur de la piqûre (Contrôle par rapport à l'épaisseur de l'ouvrage) D07

UNI

Unité d'utilisation pour le calcul du transport

A1[11] T Recherche sur formule RT uniquement dans l'immédiat

A1[12,14] Code phase

A1[15,17] Code formule

A1[18] Rubrique poids

USE

A2[8] à A2[18] Autorisations diverses

A2[25] Autorisation de modifier les gâches fixe et variable et l'unité de la gâche dans les détails matières utilisées et opérations à réaliser

A2[26] Autorisation de modifier la cadence, le temps standard et le code forçage dans le détail opérations à réaliser

A2[42] et A2[43] pour le transfert du devis en commande

A2[51] Autorisation de désactiver la numérotation automatique (numérotation manuelle)

A2[56] Autorisation de lancer la génération automatique des notes

A2[58] Soit l'écran de paramétrage de l'optimisation s'affiche, soit les paramètres par défaut sont utilisés (devis optimisé)

A2[59] Passage en mode expert dans le devis optimisé

A3[13,15] Code deviseur par défaut pour l'utilisateur

VER

Type de vernis (hors ligne / en ligne) A1[1]

Pour le test de compatibilité entre le vernis et la machine, voir l'explication dans le programme machine.

A1[17] Vernis acrylique, offset ou UV (devis optimisé)

Alimentation du devis standard depuis le code produit

Permet d'alimenter un devis depuis les données de la fiche produit.

En création de devis (ou modification de code produit sur l'entête du devis), une fenêtre s'ouvre automatiquement (si -Opf) après le champ code produit.

Le code produit ne doit pas être un code produit générique !

En modification de devis (et sans changement de code produit), on peut mettre à jour les données par la touche F31.

On peut alimenter alors les tables fle_2, fle_imp, fle_com et info_c selon le paramétrage.

Si une entité globale (ex : façonnage) existe par défaut, on ne la détruit pas : on la recopie après la création des nouvelles entités physiques.

Méthode de construction du code ECMA

L'ordre correspond à l'ordre de recherche du code ECMA.

Si aucun code ECMA n'existe avec la première méthode de recherche, on recherche avec la deuxième méthode, etc.

1 Le code ECMA est paramétré sur le type d'entité

2 Le code ECMA est construit en concaténant le type d'entité (TEN) et le code pli principal (PLI)

3 Le code ECMA est paramétré sur le pli

Codes TSC liés à l'outil (mat)

Entité | Libellé | Zone | Code TSC | Code zone | Type
Boîte pliante / Transformateur carton | Code ECMA | fi_ecma | mp_afnor |  |
Boîte pliante / Transformateur carton | Longueur du format fini | fi_lon_fini | D31 (*) | ic_num1 | C
Boîte pliante / Transformateur carton | Largeur du format fini | fi_lar_fini | D31 (*) | ic_num2 | D
Boîte pliante / Transformateur carton | Hauteur du format fini | fi_hau_fini | D31 (*) | ic_num3 | E
Boîte pliante / Transformateur carton | Longueur hors tout | fi_lon_ouv | 41U | ic_num1 | C
Boîte pliante / Transformateur carton | Largeur hors tout | fi_lar_ouv | 41U | ic_num2 | D
Boîte pliante / Transformateur carton | Double coupe (sens travers) | fi_pli_dblc | D35 | ic_num1 | C
Boîte pliante / Transformateur carton | Double coupe (sens machine) | fi_fini_dblc | D35 | ic_num2 | D
Boîte pliante / Transformateur carton | Nombre de poses | fi_nb_poses | 300 | ic_num3 | E
Boîte pliante / Transformateur carton | Format de tirage (sens travers) | fi_lar_tir | 301 | ic_num1 | C
Boîte pliante / Transformateur carton | Format de tirage (sens machine) | fi_lon_tir | 301 | ic_num2 | D
Etiquette feuille / bobine | Code ECMA |  | DE1 | ic_char3_1 | F
Etiquette feuille / bobine | Nombre de poses de front |  | DE1 | ic_num1 | C
Etiquette feuille / bobine | Nombre de poses d'avance |  | DE1 | ic_num2 | D
Etiquette feuille / bobine | Bord de rive |  | DE2 | ic_num1 | C
Etiquette feuille / bobine | Format de tirage sens laize |  | DE2 | ic_num3 | D
Etiquette feuille / bobine | Espace entre étiquette avance |  | DE3 | ic_num1 | C
Etiquette feuille / bobine | Espace entre étiquette laize |  | DE3 | ic_num2 | D
Etiquette feuille / bobine | Format de tirage sens avance |  | DE4 | ic_num2 | D

(*) Si D31 NON renseigné, on prend mp_lon, mp_lar, mp_hau

Contrôle des valeurs saisies

Objectif

Cette fonctionnalité permet de contrôler 2 valeurs issues d'un calcul de formule et d'afficher un message (bloquant ou non) si ce contrôle n'est pas vérifié.

Cette vérification est accessible dans les 3 cas suivants :

  • après la saisie de certains champs d'entités

  • après n'importe quel champ de LCO

  • lors du calcul d'une phase (Opération / Matière / Sous-traitance)

Restrictions

ATTENTION : Les caractères 5 et 6 du paramétrage de la formule sont réservés pour une mise en place du coefficient multiplicateur.

Vous aurez sans doute besoin de désactiver cette fonction en positionnant #CF DEG alpha4[28] à O (Oui).

Principe de fonctionnement

Le paramétrage du contrôle est enregistré dans une formule de contrôle.

Vous enregistrez vos formules de contrôle via le même programme que celui qui gère les formules de calcul : formules

Dans les explications qui suivent, nous parlerons donc de formules de contrôle et non pas de formules de calcul !

Il convient de ne pas confondre ces 2 notions !

En outre, bien que techniquement possible, l'utilisation d'une formule de contrôle à des fins de formule de calcul (et vice-versa) n'est pas du tout recommandée !!!

Par convention, les formules de contrôle seront de préférence codées #MS XXX.

(MS comme message, car le but de ces formules de contrôle est de déclencher l'affichage d'un message d'erreur).

Paramétrage (1/2)

Note VERIF_VAL_FORMULE sur les paramètres suivants :

TEN

LCO

Notes sur les formules de calcul

Paramétrage (2/2) : création / modification d'une formule de contrôle

Dans la saisie des paramètres, créez une phase de type PHA et de code #MS avec un libellé du type Messages de contrôle.

Accédez au programme de saisie des formules

Entrez une nouvelle formule de contrôle (de type #MS XXX)

Entrez le code O (Opération)

Entrez un libellé (du type "Vérification ...")

Accédez à l'écran des dépendances par la touche F9

Paramétrez la formule de contrôle en fonction des indications du tableau suivant :

Codes calculs v1

Variables à prendre en compte pour calculer la valeur 1 (15 codes calculs possibles)

Codes calculs v2

Variables à prendre en compte pour calculer la valeur 2 (15 codes calculs possibles)

Formule QT/1

ou QT/3, QT5, QT7, QT9

Formule de calcul pour la valeur 1

Formule QT/2

ou QT/4, QT/6, QT/8, QT10

Formule de calcul pour la valeur 2

Formule CAD1

Type de comparaison entre la valeur 1 et la valeur 2

!= Affichage d'un message d'anomalie si la valeur 1 est différente de la valeur 2

> Affichage d'un message d'anomalie si la valeur 1 est supérieure de la valeur 2

>= Affichage d'un message d'anomalie si la valeur 1 est supérieure ou égale à la valeur 2

< Affichage d'un message d'anomalie si la valeur 1 est inférieure de la valeur 2

<= Affichage d'un message d'anomalie si la valeur 1 est inférieure ou égale à la valeur 2

= Affichage d'un message d'anomalie si la valeur 1 est égale à la valeur 2

Formule CAD2

Caractère 1 : Type de contrôle

W Contrôle non bloquant (la saisie continue)

B Contrôle bloquant (la saisie est bloquée sur le champ en anomalie) [Par défaut]

N Pas de contrôle

Caractère 2 : Type des zones à comparer

A Comparaison sur des valeurs alphanumériques

N Comparaison sur des valeurs numériques

Caractère 3 : Formule à utiliser pour calculer la valeur 1

1 La valeur 1 est calculée avec la formule QT/1 (par défaut)

3 La valeur 1 est calculée avec la formule QT/3

5 La valeur 1 est calculée avec la formule QT/5

7 La valeur 1 est calculée avec la formule QT/7

9 La valeur 1 est calculée avec la formule QT/9

Caractère 4 : Formule à utiliser pour calculer la valeur 2

2 La valeur 2 est calculée avec la formule QT/2 (par défaut)

4 La valeur 2 est calculée avec la formule QT/4

6 La valeur 2 est calculée avec la formule QT/6

8 La valeur 2 est calculée avec la formule QT/8

0 La valeur 2 est calculée avec la formule QT/10

Notes sur la formule de contrôle

Caractères 1 à 3 : MSG

Caractères 5 à 60 Message à afficher lorsque le contrôle décrit ci-dessus n'est pas vérifié.

Les lignes sont cumulées pour construire un message de 750 caractères maximum.

Saisir /n pour insérer un retour à la ligne.

A noter que les valeurs 1 et 2 sont toujours affichées indépendamment du paramétrage du message à afficher.

Pour afficher les valeurs dans le message de contrôle, il suffit de renseigner les libellés de valeurs numérique 1 et 2 dans la fiche formule, comme dans cet exemple (Massicot & Fen./Gau. ?)

Remarques

S'il s'agit d'un champ alpha, seul le 1er code calcul (a) est pris en compte aussi bien pour v1 que pour v2.

En outre, puisque ce code calcul est le seul, il est inutile de le préciser dans les champs Formule QT 1 et 2.

Voir le paramétrage standard des formules et la liste habituelle des codes calculs.

Le code VA est doté de 2 nouvelles possibilités pour le caractère 1 :

B : Accéder à la valeur du champ alphanumérique saisi au moment du contrôle

C : Accéder à la valeur du champ numérique saisi au moment du contrôle

Exemple

Pour l'entité BOI (Boîte), on veut paramétrer un contrôle sur la Machine d'impression recto en sortie du champ fi_mac_imp.

1) Créez une note sur l'entité BOI, comme suit :

1 2 3 4

12345678901234567890123456789012345678901234567890

VERIF_VAL_FORMULE fi_mac_imp #MSCOU

2) Si ce n'est déjà fait, dans la saisie des paramètres, créez la phase PHA #MS (aucun paramétrage particulier)

3) Dans la saisie des formules, créez la formule de contrôle #MS COU (tel qu'indiqué dans la note VERIF_VAL_FORMULE) comme suit :

4) F9 pour accéder à l'écran des dépendances où vous entrez les informations suivantes :

5) Ctrl N pour accéder aux notes où vous entrez le message suivant :

Le paramétrage est terminé. Pour le tester :

Dans l'écran des entités, entrez un nombre exagéré de couleurs recto par rapport à la machine AV3 :

Dès que vous validez sur le champ Machine, le message d'erreur suivant apparaît :

Champs à la sortie desquels il est possible d'effectuer une vérification

Champs particuliers

Sur l'écran d'entête de devis

F6_ENTETE : Vérifications lancées au F6 (Validation et sortie du devis)

F11_ENTETE : Vérifications lancées au F11 (Calcul du devis)

F23_ENTETE : Vérifications lancées au F23 (Calcul optimisé)

Sur tous les écrans d'entité

F6_ENTITE : Vérifications lancées au F6 (Validation et sortie du devis)

F10_ENTITE : Vérifications lancées au F10 (Validation de l'entité)

F11_ENTITE : Vérifications lancées au F11 (Calcul de l'entité)

F23_ENTITE : Vérifications lancées au F23 (Calcul optimisé)

Sur l'écran de saisie des LCO (F13)

F10_SAILCO : Vérifications lancées au F10 (Validation de la saisie des LCO)

Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
fi_sit | Site de production | l | l | l | l | l
fi_accessoires | Présence d'accessoires | l | l |  |  | l
fi_jonction | Présence de jonctionnement |  |  |  |  | l
fi_cgt_r | Nombre de changement de plaques au recto | l | l | l | l |
fi_cgt_teinte_r | Nombre de changement de teintes au recto | l | l | l | l |
fi_cgt_teinte_v | Nombre de changement de teintes au verso | l | l | l | l |
fi_cgt_v | Nombre de changement de plaques au verso | l | l | l | l |
fi_co_recto | Nombre de couleurs recto | l | l | l | l |
fi_co_verso | Nombre de couleurs verso | l | l | l | l | l
fi_collage | Présence de collage | l |  |  |  |
fi_conditionnement | Présence de conditionnement |  |  | l | l |
fi_contre_collage | Présence de contre-collage | l |  |  |  | l
fi_c_papier | Support/Qualité/Papier | l | l | l | l | l
fi_dorure | Présence de dorure | l | l | l | l |
fi_equerre | Présence de massicot | l | l |  |  | l
fi_fenetrage | Présence de fenêtrage | l |  |  |  |
fi_foulage | Présence de foulage |  | l | l | l |
fi_gaufrage | Présence de gaufrage | l | l | l | l |
fi_hau_fini | Hauteur du produit fini | l | l |  |  | l
fi_lar_fini | Largeur du produit fini | l | l | l | l | l
fi_lar_ouv | Largeur produit ouvert (ou largeur hors tout ECMA/FEFCO) |  |  |  |  | l
fi_lar_papier | Largeur du papier | l | l | l | l | l
fi_lar_tir | Largeur du produit ouvert | l | l | l | l | l
fi_lon_fini | Longueur du produit fini | l | l | l | l | l
fi_lon_ouv | Largeur produit fini ouvert (ou longueur hors tout ECMA/FEFCO) |  |  |  |  | l
fi_lon_papier | Longueur du papier | l | l |  | l | l
fi_lon_tir | Longueur du produit ouvert | l | l | l | l | l
fi_mac_forcee_r | Forçage de la machine d'impression au recto | l | l | l | l |
fi_mac_forcee_v | Forçage de la machine d'impression au verso | l | l | l | l |
fi_mac_imp | Machine d'impression au recto | l | l | l | l |
fi_mac_imp2 | Machine d'impression au verso | l | l | l | l |
fi_manuel | Présence d'opérations manuelles | l |  | l | l | l
fi_nb_decoupe | Présence de découpe | l | l | l | l |
fi_nb_references | Nombre de références | l | l | l | l | l
fi_numerotage | Présence de numérotage |  | l | l | l |
fi_perfo | Présence de perforation |  | l | l | l |
fi_perso | Autres (personnalisation) | l | l | l | l | l
fi_pliage_mach | Présence de pliage machine |  | l |  |  |
fi_quadri_r | Présence de quadrichromie au recto | l | l | l | l |
fi_rainage | Présence de rainage |  | l |  |  |
fi_tot_page | Nombre total de pages |  | l |  |  |
fi_transfert | Présence de poudrage |  | l | l | l |
fi_type_pellic | Type de pelliculage | l | l | l | l |
fi_type_vernis_r | Type de vernis au recto | l | l | l | l |
fi_type_vernis_v | Type de vernis au verso | l | l | l | l |
fi_type_verso | Type d'impression verso |  |  | l |  |
fi_vernis_hl | Type de vernis hors-ligne | l | l | l | l |
Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR

Décomposition des prix des éléments (revient/vente standard)

EN COURS DE DÉVELOPPEMENT

1) Saisie et calcul dans le devis

2) Scénarios, VoluEdit, Transfert en commande

Fonctionnalités

Permettre de décomposer les prix de revient et les prix de vente standard de chaque élément d'un devis, via des natures de regroupement.

Cette décomposition du prix est accessible à partir de la saisie des prix par éléments :

Récapitulatif du prix (shift-F4) > Prix des éléments (F8) > Décomposition du prix (shift-F6).

Remarques

  • Ce fonctionnement se base sur la table des frais de premier établissement (fle_frais)

  • Il s'agit d'une décomposition de prix par élément :
    si le devis concerne un ensemble, c'est la décomposition des prix pour l'ensemble qui sera affichée.

  • Deux natures de regroupement sont gérées par défaut :
    NDR/#CF : Tous les prix de Calage Fixe non concernés par une nature de regroupement spécifique
    NDR/#RV : Tous les prix de Roulage Variable non concernés par une nature de regroupement spécifique

  • Ces deux natures de regroupement spécifiques doivent être créées via la gestion des paramètres.

  • Les natures de regroupement sont saisissables sur les formules.

  • Les frais spécifiques (transport, stockage, financier, divers) peuvent être intégrés dans des natures de regroupement ou directement parmi les autres natures de regroupement (via une proratisation).

Paramétrage

#CF DER

A2[54] Gestion de la décomposition des prix (O/N, N par défaut)

A2[55] Vérification de la saisie des prix remis (B, W, N, C)

Note CODE_NDR_TRANSPORT Code nature de regroupement pour les frais de transport

NDR

Nouveau paramètre : Nature de regroupement

SDP

Nouveau paramètre : Scénario de décomposition des prix

TSC SDP

Indique le code scénario de décomposition des prix

TYC

Note DECOMPOSITION_PRIX Activation de la décomposition des prix pour le type de commande (O/N, N par défaut)

voluedit_fle_cli

Permet d'accéder aux informations de la décomposition des prix saisie dans le devis multi-métiers (table fle_frais)

A4[38 à 41] Titres multi-lignes

Notes commençant par _SUP_REQ_DECPX_ Complément de sélection sur la table de décomposition des prix (fle_frais).

Temps de calcul des devis

Les paramètres suivants influent sur les calculs :

TPR A2[13] Recalcul du sous-devis courant avant l'ouverture de l'écran de récapitulatif

TPR A4[22] Recalcul automatique à la création d'une variante de quantité

TEN A2[30] Recalcul automatique lors de la validation de l'entité par la touche F9 ou F10

TEN A2[31] Recalcul automatique lors de la validation de l'entité par la toucheF6

#CF DEG A1[1] Configuration du F11 (calcul du devis)

#CF DEG A3[9] Recalcul du récapitulatif devis à chaque calcul d'entité.

O On recalcule tout le récapitulatif à chaque calcul d'une entité (par défaut) - Gain de sécurité

N Le recalcul complet n'est fait qu'au recalcul du sous-devis - Gain de performance

Il est impératif de faire un calcul final sur l'entête du devis (ou bien cliquer sur PRU pour forcer ce calcul)

#CF DEG A3[50] Permet de demander si l'on doit relancer le calcul du devis avant de quitter le devis par F6.

#CF DER A2[45] Recalcul du sous-devis courant avant l'ouverture de l'écran de récapitulatif (préconisé : C (Confirmation))

Ouverture contextuelle des informations complémentaires (TSC)

Permet d'ouvrir automatiquement la saisie des informations complémentaires selon la valeur saisie sur certains champs.

Remarques

• Cette fonctionnalité n'est accessible que pour le nouveau mode de saisie des TSC (so_options[29] = O)

• Cette fonctionnalité est disponible dans les écrans suivants :

o Saisie des références multiples sur l'entité

o Saisie des lignes d'impressions multiples

• La saisie des TSC sur les lignes d'impressions multiples est désormais possible.
Le type (info_c.ic_type) est 4 et la clé (info_c.ic_cle) de la forme DDDDDDDD-SSS-EEE-003-PPP-VVV où :

o DDDDDDDD = Numéro de devis

o SSS = Numéro de sous-devis

o EEE = Numéro d'entité

o 003 = Type d'enregistrement ligne d'impression multiple (figé)

o PPP = Numéro de passage

o VVV = Numéro de vernis

Paramétrage

#CF DEG A4[55] | Activation de l'utilisation des TSC contextuelles dans le devis Ouverture automatique sur les zones paramétrées dans les notes des TSC
#CF DEG note TOUCHE_CONTEXTE_TSC | Combinaison de touches déclenchant l'ouverture contextuelle de TSC Nom du champ pour lequel la combinaison de touche est active
USE A2[60] | Accéder en modification à la saisie des TSC si le devis est en consultation
so_options[29] | Utilisation du nouveau mode de saisie des TSC
TSC note CONTEXTE_TSC | Nom du champ où ouvrir la fenêtre de saisie contextuelle des TSC Critère d'ouverture de la fenêtre


Saisie des matrices

Saisie des matrices matrice

Ce programme est utilisé dans le cadre du devis standard optimisé, pour la mise en oeuvre des décompositions prioritaires.

Le paramétrage a été entièrement refait le 11/04/2013 en V. 4.1.29.2

Options

Oco

Mode consultation

Valeur alpha 2

A2[1,3] | Type de matrice associée à cette saisie DEC Décompositions prioritaires (seul type autorisé à ce jour - 11/04/2013)
A2[4,6] | Critère de matrice associée à la saisie (doit correspondre à un paramètre de type #MA) Si A2[1,3] = DEC, le critère par défaut est DEC.

Paramètres nécessaires

#MA | Matrice de saisie
TPR A2[19,21] | Critère de matrice associée à ce type de processus (doit correspondre à un paramètre de type #MA) Par défaut : DEC


Notation des formules de calcul

Notation des formules de calcul f_cal_regle

Opérateurs

Les opérateurs suivants sont disponibles :

Opérateurs mathématiques de base

+ | plus
- | moins
* | multiplié
/ | divisé

Opérateurs spéciaux

> | maximum entre deux valeurs
< | minimum entre deux valeurs
[ | entier inférieur de la valeur
] | entier supérieur de la valeur
: | logarithme décimal
é | exponentiel
² | Racine carrée Exemple : 25² : Racine carrée de 25 = 5

Priorité des opérateurs

é : [ ] * / > < + -

Ecriture des formules

Deux notations sont possibles :

  • la polonaise post fixée (opérateur après les opérandes)

  • la notation mathématique normale (les parenthèses sont utilisées pour marquer les priorités entre les opérations).

Quelle que soit la notation utilisée on peut saisir des valeurs décimales utilisant, soit le point, soit la virgule comme séparateur décimal.

Postfixée | Mathématique | Commentaires
10 | 10 | Valeur constante 10
1 2+ | 1+2 |
3 4+5* | (3+4)*5 |
Ab+cd-* | (a+b)*(c-d) |
A 2.35/ | a/2.35 | Possibilité d'utiliser les décimaux
a b> | a>b | Renvoi le max entre a et b
ab+c> | (a+b)>c | Renvoi le max entre (a+b) et c
2: | :2 | Logarithme décimal de 2
1.850[ | [1.850 | Renvoi l'entier inférieur de 1.850 soit 1

Expressions conditionnelles (type IF~THEN~ELSE)

Pour des formules plus évoluées, il est possible d'intégrer des expressions conditionnelles.

Soit EXP une expression mathématique

Soit OP un opérateur de comparaison

Soit VAL un opérande numérique de comparaison

Soit R1 et R2 les deux résultats possibles.

Si la formule EXP OP VAL est vérifiée, on obtiendra en résultat R1, sinon on obtiendra R2.

La syntaxe est la suivante : EXP#OPVAL?R1;R2

Les opérateurs de comparaisons sont les suivants :

> | supérieur à
< | inférieur à
>= | supérieur ou égal à
<= | inférieur ou égal à
= | égal à
!= | différent de

Notes

R1 et R2 peuvent êtres des expressions mathématiques, des numériques ou des variables de l'interpréteur.

R2 peut elle-même être une expression conditionnelle.

La taille maximale de l'ensemble est de 60 caractères

Les expressions acceptent les deux types de notation : polonaise postfixée et mathématique

Exemples

Soit a une cadence générique

Soit x un coefficient de dégradation de cette cadence, pouvant varier avec les conditions techniques (i.e. différentes opérations élémentaires)

On dispose d'une formule de base d'écrivant la cadence réelle : a/(1+x)

Si x = 0 | Cadence optimale
Si x = 0.2 | Dégradation légère de la cadence
Si x = 0.4 | Dégradation majeure de la cadence

Exemple 1

On souhaite pouvoir traduire le fait que si le coefficient de dégradation atteint le valeur de 0.5, alors la cadence atteint une valeur minimale plancher de 3000 passages par heure.

Soit la formule suivante :

SI x >= 0.5

ALORS formule = 3000

SINON formule = a/(1+x)

Elle s'écrira :

x#>=0.5?3000;a/(1+x)

Exemple 2

Si l'on souhaite toutefois spécifier qu'au-delà d'un coefficient de 0.8 la cadence chute à une valeur plancher de 2400 passages par heures alors on écrira :

x#>=0.8?2400; x#>=0.5?3000;a/(1+x)

Programmes concernés

Formule des pointages FEFCO (ecma)

Facturation barème dans les commandes (cde)

Formules de calcul (formule)

Visualisations (v_cdem, …)

Devis ondulé (devis_ondu)

Décompte de paie (dpaie)

et tous autres programmes utilisant f_cal_regle() comme interpréteur.

Notes

Fonction de conversion des formules : f_convertformule.4gl

Fonctions de gestion des expressions conditionnelles : f_expcondition.4gl

ATTENTION : coef_conv() dispose de son propre interpréteur et n' utilise pas f_cal_regle().


Saisie des offres de prix

Saisie des offres de prix offre_de_prix

Options

Odd | Désactivation du décalage des numéros d'entités en cas de suppression Les numéros d'entités sont fixés à la création et ne changent plus.
Ony | Numérotation annuelle

Valeur numérique 1

Compteur

Valeur alpha 3

Caractères 1 à 3

Type d'offre par défaut

Notes

PARAM_RECH_VISU | 21 à 23 Type et code du paramètre de lancement de la recherche par visualisation des devis
_SUP_REQ_RECH_OFFRE | 21 à 60 Complément de sélection pour la recherche d'offre

Paramètres nécessaires

Par. | Objet | Paramètres lus
REP | Représentant | valeur numérique 1
TYO | Type d'offre | alpha1[1,3] - alpha4[1,60]
TPR | Type de processus | alpha3[2] - alpha4[1,6] - alpha4[7]
TEN | Type d'entité de fabrication | alpha3[2] - alpha4[1,6] (même paramétrage que TPR)


Devis imprimeries feuille et rotative

Devis imprimeries feuille et rotative devis

Options Valeur numérique 1 Valeur alpha 2 Paramètres associés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis-Numéro d'entité

Exemples:

-N[l2_devis]

-N[l2_devis|-|l2_sdevis+&&&]

-N[fi_devis|-|fi_sdevis+&&&|-|fi_entite+&&&]

Valeur numérique 1

Numéro de compteur des commandes clients (voir –Ogc)

Options triées

Oad

Eclatement autorisé seulement sur le sous-devis 99

A partir de l'écran devis, la touche F27 permet l'éclatement des amalgames de toutes les entités.

Une nouvelle entité est générée pour chaque ligne d'amalgame.

TSC / #AM (sur sous-devis) : InfoC / Zone "C" (ic_num1) = 1 si transfert effectué

Ce TSC est généré automatiquement par le programme. Pas de saisie ni d'affichage

Voir aussi PHA, alpha1[22]. TSC, alpha1[5]. LCO, alpha1[41]

Oaf

Adresse de facturation saisie sur la zone paramétrée

Oai

Active l'aide à l'imposition

Oan

Pas de renumérotation des entités

Oap

Permet de ramener le prix du papier à la sélection du papier comme dans le devis

Oar

Accès au récapitulatif pour un appel avec -N

Oca

Activation de la création automatique des articles et du changement de type de sous-devis depuis la fenêtre de visualisation globale du devis (devis feuilles - F15) par la touche F30.

Le code article est composé du code du client et de la valeur du compteur X

La désignation est reprise sur la première désignation du sous-devis

La famille est à saisir et sera commune à tous les articles du devis

La sous-famille est paramétrée sur le TPR du sous-devis alpha1[31,48]

Les 3 premières données diverses dépendent de alpha2[1,2] du paramètre NTR du sous-devis

Si sous-devis N° 1, variable, livrable et facturable VNN

Sinon, si monté ou (non monté et sur emballé), variable, non livrable, non facturable VOO

Sinon, variable, livrable, non facturable VNO

Les notes de type #LC sont composées de la désignation de la qualité matière de la première entité et des notes de type DEV sur le sous-devis.

Le libellé étranger est composé de la deuxième désignation du sous-devis.

Oco

Consultation seule

Ocp

Génération des notes de contrepartie en Euro

Odc

Double lancement du calcul du devis par la touche F11

Ode

La désignation de l'entête du devis est recopiée dans la désignation de l'entité.

Oec

Ajout de l'option Edition d'une confirmation de commande dans le menu Edite

Oef

Calcul du taux horaire d'une opération, paramétrée comme telle, par sommation du taux horaire de l'opération avec le taux horaire de la machine associé à l'opération et le taux horaire du salarié société (#SOC)

Sans cette option, la taux horaire est celui de l'opération.

ATTENTION Le code environnement doit être positionné : #CF DEG alpha3[27,29]

Oep

Exécution d'un programme par appui sur la touche F23 depuis le premier écran

Le programme exécuté est paramétré dans alpha2[20,28]

Ofa

Le code deviseur du premier écran devient code du fabricant

Off

Fiche de fabrication

Oga

Activation de la mise à jour automatique de quantités des sous-devis.

Cette mise à jour est accessible lors de la modification de la quantité d'un sous-devis ou dans la fenêtre de détails des prix accessible par F15 sur le sous-devis. N'existe plus ?

Ogc

Possibilité de générer une commande client lors de la validation de la fiche de fabrication (F6)

La commande client aura le même numéro que la fiche de fabrication

Le numéro de la fiche de fabrication utilise le même compteur que les commandes clients.

Voir aussi Valeur numérique 1

La valeur alpha3[37] du paramètre de configuration générale du devis doit obligatoirement être à N

La valeur alpha4[3,5] du paramètre de configuration générale du devis doit contenir le type de la commande à générer (FB2 par défaut).

Nécessite –Off

Ogp

Autorise la génération des produits finis par F30

Ogv

Lancement de la génération/régénération à la suite du recalcul de validation finale

Oip

Initialisation format papier au format tirage

Oma

Transfert des marges de la fiche de fabrication dans le détail prix de la ligne de commande

Voir le paramètre GMA, note commençant par DPC_ASSOCIE

Voir le paramètre DPC, alpha1[8,10]

But : lors de l'ouverture de la commande depuis la fiche de fabrication, transférer les marges dans le détail prix de la ligne de commandes.

Pour ce faire, un code DPC, détail prix de la commande, est associé à chaque GMA, codes des groupes de marges la fiche de fabrication génératrice.

A la fin de la génération, le prix de revient, le prix de vente, le mille + et le mille -, dans les trois devises, ainsi que la marge de la ligne de commande sont remis à jour.

Le prix de revient est égal à la somme des prix de revient des DPC.

Le prix de vente est égal à la somme des prix de vente des DPC.

Le mille + et le mille - sont affectés avec la valeur du mille + du devis.

Un GMA ne peut être transféré que sur un seul est unique DPC.

Mais un DPC peut recevoir plusieurs GMA, ce qui se traduit à l'affichage par plusieurs lignes pour le DPC.

Omd

Mise à jour de la date de livraison proposée du dossier (cde2.lc_delrep) à partir de la date de livraison saisie sur le devis

La date de fin de fabrication du dossier généré (fab0.f0_delp) est également mise à jour.

Omf

Mise à jour de la date de fin de fabrication du dossier (cde2.lc_delfab) à partir de la date de livraison saisie sur le devis

La date de fin de fabrication du dossier généré (fab0.f0_delp) est également mise à jour.

Oml

Mise à jour des libellés de la commande (cde1.ec_texte, cde2.lc_lib) à partir de la première ligne de désignation du devis

Voir aussi #CF DEG A4[45 à 48]

Omq

Mise à jour de la quantité lancée du dossier à partir de la quantité saisie sur le devis

La quantité lancée du dossier généré (fab0.f0_qtel) est également mise à jour.

Oms

Génération des mouvements de stock. Nécessite -Ogc

Onc

Affichage automatique des notes client

Ony

Numérotation annuelle des fiches de fabrication

Oqa

Activation de la modifications automatiques des quantités des sous-devis

Ord

Permet de déclencher le recalcul du devis dans le cas d'une recopie

Orf

Activation de la recopie totale / partielle du devis par la touche de fonction F24 lorsque le curseur est sur le champ de saisie du N° de devis. Aucun sous-devis ne doit être enregistré.

Orp

Sur touche F15 sur écran entités, affichage de la fiche de réservation des papiers secondaires

Ors

Accès à la recherche optimale de plaque

Sur le devis_car, permet, en tapant S dans la zone du mode de réappro, d'accéder à la recherche de matière optimisée.

Voir #CF SMC. : valeurs numériques 1 et 2, et alpha1[10,11]

Pour ce qui est du grammage retourné :

Si la matière est générique (mp_param[25] = O), on prend le poids directement sur la matière (mp_poids).

Dans le cas contraire, on recherche le poids sur la qualité matière (lecture sur mp_qualite_matiere).

Orv

Activation de la recherche par la visualisation des devis (devis_car)

Nécessite note de type PARAM_RECH_VISU (voir ci-dessous)

Nécessite des noms de colonnes commençant par LCO dans la visu du devis feuille / carton.

Orz

Pas de remise à zéro de la quantité quand le temps total est égal à zéro (formule automatique sur opération)

Osl

Autorise la saisie des notes sur LCO lors du CTRL-N sur F13 (Ligne complémentaire)

Ouverture d'une fenêtre spécifique.

Osr

Pas de mise à jour du stock résultant. Nécessite -Ogc

Ost

Gestion du site de production (fle_2 et fle_imp) sur devis (pour devis)

Tableau de bord du multisite

Osw

Appel du programme de schéma Windows

Ouv

On utilise l'unité de vente pour calculer le prix de vente issu du fichier matière / produit et le prix du mouvement de stock. Nécessite –Ogc

Ova

Validation automatique de la fenêtre de gestion de fax/email

Oxm

Mise en œuvre du fax / mail

Ozz

Boucle sur l'écran de saisie des notes (NTS) tant que l'utilisateur ne presse pas DEL

Valeur alpha 2

Caractères 1 à 3 | Code paramètre de la configuration générale du devis (#CF DEG)
Caractères 4 à 6 | Code paramètre de la configuration du récapitulatif du devis (#CF DER)
Caractères 7 à 12 | Type et code paramètre de la configuration de la génération des produits finis. Par défaut #CFGPF
Caractères 20 à 25 | Type et code du paramètre de lancement du programme exécuté par F23
Caractères 26 à 28 | Code du paramètre passé en argument au programme du F23

Notes triées

AFF_NOTES_CLI_DEVIS | 21,23 Type de notes clients à afficher dans le devis
LCO_NB_POSES_SM | 21,23 Code LCO pour sauvegarder le nombre de poses sens machine Créer les TSC EHO (entraxe horizontal) et EVE (entraxe vertical)
LCO_NB_POSES_ST | 21,23 Code LCO pour sauvegarder le nombre de poses sens travers Créer les TSC EHO (entraxe horizontal) et EVE (entraxe vertical)
OBJET_DOCUMENT | 21,23 Type de document (DEV) 25,60 Objet du document pour le fax/email
PARAM_GENERE_OF | 21,26 Type et code du paramètre de lancement de la génération des dossiers de fabrication
PARAM_REGENERE_OF | 21,26 Type et code du paramètre de lancement de la re-génération des dossiers de fabrication
PARAM_RECH_VISU | 21 à 26 Type et code du paramètre de lancement de la visualisation des devis
STOCKAGE_NUM_ETUDE | 21,27 Numéro d'étude
_SUP_REQ_FEFCO | Complément de requête sur la recherche des codes FEFCO
SUP_REQ_MAC_IMP | 21,60 Complément de requête pour la recherche de machines d'impression Exemple and m0_typmac = "IMP"
TITRE_DOCUMENT | 21,23 Type de document (DEV) 25,60 Titre du document pour la fenêtre de gestion du fax/email. Celui-ci sera suivi de la mention N° et de la clé du document.
TITRE_ECRAN | 21,60 Titre de l'écran
TYPE_NOTE_PHASE | 21 à 23 Type de note à afficher Dans l'écran des phases du devis, affichage des 2 premières lignes de notes de la phase

Paramètres associés

#CF DER | Configuration du récapitulatif du devis
#CF DEG | Configuration générale du devis feuille
SCE | Scénario de calcul du devis feuille


Devis transformateurs carton ondulé

Devis transformateurs carton ondulé devis_tc

Options Valeur alpha 2 Paramètres associés Notes Optimisation du conditionnement

Voir aussi : Les codes calculs des devis - Les types de machines et les contrôles des possibilités machines.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-n

Action : recalcul

Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis

Exemples:

-n[l2_devis]

-n[l2_devis|-|l2_sdevis+&&]

Options triées

Oaa

On n'arrondit pas la coupe si la matière est achetée (fi_pap_stk = C)

Oac

Affichage du code et du libellé carton sur le deuxième écran du devis_tc et le troisième écran du devis_tc

Oae

Affichage du code FEFCO sur le deuxième écran du devis. N'EST PLUS UTILISE DANS LE DEVIS TC.

Oal

Accès aux libellés directement après modification du code FEFCO ou du code matière dans le second écran.

Oap

Ne pas tenir compte du mode de gestion en stock de la matière

Oas

Active la recherche de similitudes et la présentation des devis trouvés.

Lors de la création ou de la modification d'un devis, on prévient l'utilisateur qu'il existe dans la base un ou plusieurs devis similaires à celui qu'il est entrain de traiter La recherche s' effectue après la saisie du nombre de couleurs en création et après la saisie des champs FEFCO, qualité, dimensions et nombre de couleurs en modification.

Oau

Ouverture automatique de la fenêtre de détermination du conditionnement lors de la modification des caractéristiques du produit fini (nécessite l'option -Opa)

Obt

Les bornes des tarifs matières sont saisies en m² (par défaut elles sont au 100m²)

Oc2

Le pourcentage de commission du représentant est pris dans la valeur numérique 2 de la fiche représentant.

Ocg

Contrôle de génération d'article avant suppression

Oco

Consultation

Ocp

Contrôle du prix remis par rapport aux dates de validité du devis

Régénération automatique des tarifs lorsque le prix remis est modifié (Produit du devis déjà généré)

Ocr

Confirmation avant recalcul des pointages modifiés manuellement

Voir la note TSC_MODIF_POINTAGES

Odc

Double calcul du devis

Odd

Active la désignation du sous-devis à la place de la désignation du produit

Odj

(double jonction) Permettre le passage sur un FEFCO 2 morceaux

Odq

Permet de ne pas mettre à jour la désignation qualité par défaut

Oef

Le taux horaire utilisé pour la valorisation des opérations peut, si paramétré comme tel sur l'opération, être la somme de trois taux :

> le taux horaire de l'opération

> le taux horaire de la machine associée à l'opération

> le taux horaire du salarie société (#SOC)

Cette option permet donc d'utiliser la valorisation standard des opérations [ f/f_recvalo.4gl ].

Sans cette option, le taux horaire retenu pour valoriser les opérations est uniquement celui de opération.

ATTENTION Le code environnement doit être positionné : #CF DEG alpha3[27,29]

Off

Fiche de fabrication. Les formats papiers seront issus directement du fichier matière sans modification

Ofg

Utilisation des contrôles de faisabilité gamme lors de la recherche automatique de gamme

Voir les notes sur les gammes

Ofj

Forcer la saisie du code jonction et du colisage (pas de valeur par défaut)

La taille de la patte se calcule à partir de données spécifique sur le code ECMA (variable k).

Si on ne trouve rien, on la récupère sur la note TP du paramètre .JE

Ofn

On force la nature de transport à NOR quelque soit les valeurs de la fiche client.

Oga

Pas de confirmation de la génération automatique de l'entité

Option périmée. Remplacée par #CF DEF A1[26]

Ogf

La recherche de gamme inclut la valorisation Option inutile

Voir les notes sur les gammes

Ogp

Génération des produits finis (touche F30 autorisée)

Oic

Ouverture automatique de la fenêtre de détermination du conditionnement lors de la modification du code matière du produit fini en création rapide de variantes par F15 (nécessite -Opa et -Oau)

Olc

Ouverture de la fenêtre LCO en automatique à la validation de l'entité

Omg

Passage en double jonction : Ne pas afficher la présentation des gammes non retenues avant de proposer le passage en 2 morceaux

Omr

Affiche un message d'avertissement lors de la RAZ du conditionnement

Ona

Active la mise à jour automatique de la nomenclature

Permet de mettre à jour la nomenclature, lorsque le coefficient de nomenclature est modifié dans le devis.

Ne fonctionne que pour des ensembles n'étant pas déjà utilisés dans des commandes.

Onc

Autorise l'affichage automatique des notes client dans la saisie du devis

Voir les notes commençant par AFF_NOTES_CLI_DEVIS

Ooa

Création automatique de la variante 1 avec l'option 00 lorsqu'aucune variante n'a encore été saisie

Ooc

On ouvre automatiquement la fenêtre de conditionnement après avoir renseigné le colisage

Initialisation du type de colisage et du nombre d'articles / colis en fonction de la réponse sur colisage.

Si le colisage est à N, on force le nombre de produits par palette à zéro et le code de colisage à SAN.

(.SC XXX avecA1[1] = N (sans colisage))

Opa

Utilisation de la fenêtre de détermination automatique du conditionnement

Ope

Activation du calcul du prix par élément

Opf

Aucun calcul possible dans le premier écran du devis_tc. Option périmée

Opg

Interdit la recopie d'un devis quand le devis source porte sur un PF déjà généré (non générique)

Opr

Pas de recalcul du devis à la validation de l'écran de récapitulatif du devis

Opt

Permet d'inhiber le message Mise à jour des lignes de transport ?. La réponse Oui et systématiquement proposée.

Or0

Recalcul complet de l'entité sur le troisième écran si le type de tarif est modifié ou en passant sur le tarif lui même s'il est non bloqué.

Or1

Recopie automatique du premier sous devis valide du devis source saisie

(pas de demande de confirmation, pas de saisie du sous-devis)

Or2

La recherche des tarifs se fera à partir de la famille / sous famille du papier

Or3

la recherche des tarifs se fera à partir de la famille sous famille du papier.

La quantité sera ajustée en fonction de l'unité d'achat.

Or4

La recherche du tarif se fait d'après le paramètre de configuration de recherche de tarifs indiqué en alpha2[13,15] (#CF TAR par défaut).

Or5

La recherche des tarifs se fait d'après le paramètre #CF TAR mais la quantité correspond à la surface exprimée aux 100m²

La recherche des tarifs se fait d'après le paramètre de configuration de recherche de tarifs indiqué en A2[13,15] (#CF TAR par défaut).

Cependant, la quantité correspondra à la surface exprimée aux 100m²

Ora

Régénération automatique des codes produits et plaques

Voir la note commençant par CODE_EVT_PLAQUE.

Org

Remise à zéro de la gamme si modification de certaines zones sur l'entité

Ord

On lance directement la réactualisation des devis sans passer par le menu.

Orm

Recalcul du pourcentage/montant de la marge commercial en cas de modification du prix remis devise

Orp

Le port fixe de l'élément est le port fixe de l'ensemble divisé par le nombre d'éléments de l'ensemble

Ors

Si la carton est pris sur stock on fera une recherche dans le stock de la plaque optimale

Nécessite le paramètre #CF SMC (valeurs 1 et 2)

Orz

Pas de remise à zéro de la quantité si le temps total, dans la formule standard ### #AU, est à zéro.

Permet d'avoir des opération où la quantité est calculée mais pas le temps total et surtout le coût total.

Permet l'utilisation des opérations fictives intermédiaires sans perturbation du coût.

Osc

Permet d'inhiber le contrôle exigeant que le nombre de poses saisi soit un multiple du nombre de poses précédent.

Osd

Obligation de saisir la désignation de l'entité. Option périmée

Osl

Saisie des notes sur LCO (F13)

Osp

Active la saisie du code produit pour la variante et l'entité. Option périmée

Ote

Activation du mode test

Oth

Désactive le test Longueur > Largeur

Oup

Utilise les pointages pour le calcul du développé

Ova

Validation automatique de la fenêtre de gestion de fax/email

Validation automatique des fax / emails à envoyer sans passer par la fenêtre de gestion des fax / emails

Ovc

Vérification du conditionnement (s'il a été calculé) avant un choix de gamme, calcul de devis ou sous-devis

Ovg

La recherche de gamme inclut la valorisation

Voir les notes sur les gammes

Oxm

Ecran de saisie fax / email

Ozn

Dans le devis par défaut s'il n'y a pas de ligne de transport on crée automatiquement une ligne avec la quantité commandée.

Cette option permettra de mettre la zone géographique dans la nature de transport

Ozz

Boucle sur l'écran de saisie des notes tant que l'utilisateur ne presse pas DEL

Fin des options triées

Valeur alpha 2

Caractères 1 à 3 | Code paramètre de la configuration générale du devis.(#CF DEG)
Caractères 4 à 6 | Code paramètre de la configuration du récapitulatif du devis. (#CF DER)
Caractères 7 à 12 | Type et code du paramètre de configuration de la génération de produit fini (#CFGPF)
Caractères 13 à 15 | Paramètre de configuration de recherche de tarifs (TAR par défaut). Information à vérifier
Caractères 16 à 18 | Site de production - Tableau de bord du multisite
Caractères 19 à 24 | Code du mot de passe de la réactualisation des devis et de la réactualisation des prix remis et des prix contrôlés des devis (Paramètre PWD) - GENERO - .0.145.2 Facultatif - Si non renseigné, le mot de passe est volum.
Caractères 25 à 27 | Code du mot de passe pour la suppression du devis (paramètre PWD)

Valeur alpha 3

Caractères 1 à 6

Type et code du paramètre de configuration de recopie des TSC (#CF TCD)

Permet selon le paramétrage de recopier des données contenues dans les TSC de la fiche client sur les TSC ou sur les LCO du devis.

Plus qu'une recopie, c'est une initialisation. Effectivement, si la donnée cible est déjà renseignée, rien ne se passe. On ne recopie une valeur que si la zone cible est vide (ou inexistante).

Valeur alpha 4

Caractère 10 | Devis à options (O/N)
Caractère 11 | Message d'avertissement lors de la sortie de l'écran des gammes par la touche Echap (O/N, O par défaut) - PARAMETRE SUPPRIME
Caractère 12 | Prise en compte du nombre de morceaux FEFCO dans la recherche du tarif carton (spécifique option Or5)

Notes triées

#CC_RECAP_DEVIS

Contrôle de la modification de valeurs sur l'écran de récapitulatif

Cette note est recherchée en priorité sur le paramètre USE.

21,38 Nom du champ à contrôler

Le numéro correspond à celui de la capture décran

fi_typ_ent Type d'entité (1)

fi_tot_page Appairage (2)

fi_ecma Code FEFCO (3)

fi_c_papier Code carton (4)

fi_grammage Grammage du papier (5)

fi_pap_bloque Prix papier bloqué (6)

fi_p_papier Prix du papier (7)

l2_p_pv Port (8)

l2_m_ma % de marge commerciale (9)

l2_m_pv Montant de marge commerciale (10)

l2_remis_devise Prix remis en devise (11)

39 Type de contrôle

B Contrôle bloquant si aucune valeur saisie

W Avertissement si aucune valeur saisie

I Message bloquant si valeur saisie

V Avertissement si valeur modifiée (la valeur initiale est restaurée)

41 Valeur zéro significative (O/N, N par défaut)

#R

3,60 Complément de recherche pour la liste des devis à réactualiser.

L'écran de sélection multi-critère n'est pas affiché.

Exemple : and l2_type_dev != "STD" and l2_client = "9999"

#S

3,60 Complément de requête pour la recherche optimisée de matière

Si cette note n'est pas trouvée ici, elle est recherchée par défaut sur #CF SMC.

AFF_NOTES_CLI_DEVIS

21,23 Type de notes client

ASSURE_MODIF_FEFCO

21 Active la sécurisation de l'accès aux pointages en la proposant en consultation par défaut (O/N, N par défaut)

Dans la saisie des devis, il est possible d'accéder aux pointages par Ctrl+E.

Actuellement, cette fenêtre de saisie est modifiable et les données présentées peuvent être extrêmement sensibles.

Pour éviter que l'utilisateur ne valide par mégarde des modifications involontaires, on ajoute une possibilité de paramétrage permettant d'ouvrir la fenêtre des pointages en consultation seule en ayant dans le menu Actions un bouton permettant de passer en mode modification.

ATTENTION : Il n'y a pas de raccourci clavier pour passer en mode modification.

Cette possibilité existe dans le devis multi-métiers, le devis transformateur carton ondulé, et tous les devis en général.

CODE_EVT_PLAQUE

Code événement pour la régénération automatique (par exemple TBE)

Voir #CF GEA - Nécessite l'option Ora

CODE_NON_JONCTION

Permet de ne pas ouvrir la fenêtre des LCO quand il n'y a pas de jonction et de mettre à jour directement la LCO de la jonction

21,23 Code jonction

CODE_SANS_COLISAGE

21,23 Code colisage signifiant Sans colisage Par exemple : SAN

DEPASSEMENT_LARGEUR

21,24 Dépassement autorisé dans la largeur de la palette (en mm)

Voir aussi le TSC 224 ainsi que la page dédiée à l'optimisation du conditionnement.

DEPASSEMENT_LONGUEUR

21,24 Dépassement autorisé dans la longueur de la palette (en mm)

Voir aussi le TSC 224 ainsi que la page dédiée à l'optimisation du conditionnement.

HAUTEUR_MAX_PALETTE

Utilisé dans l'optimisation du conditionnement

21,24 Hauteur maxi de la palette (en mm)

HAUTEUR_PALETTE

Utilisé dans l'optimisation du conditionnement

21,24 Hauteur par défaut de la palette (en mm)

LIB_PARAM_22_x

où x = code type de produit (mp_param[22]) (Valeurs reconnues : P R E N O M)

21,60 Libellé à afficher pour chaque type de produit

Exemple : LIB_PARAM_22_M Produit monté

MESS_AVERTISSEMENT

Utilisé dans l'optimisation du conditionnement

21 Type du message d'avertissement de non respect des contraintes client

N pas de message (par défaut)

W warning uniquement

B message bloquant

MODE_CONDITIONNEMENT

Paramétrer les différents mode de fonctionnement du conditionnement du devis pour les ensembles

SEPARE : Toutes les entités sont conditionnées systématiquement séparément

QUESTION_APPAIRE :

Pour les ensembles appairés, on demande si les entités sont conditionnées séparément.

Pour les ensembles montés, le conditionnement se fait uniquement sur la première entité.

QUESTION_MONTE :

Pour les ensembles montés, on demande si les entités sont conditionnées séparément.

Pour les appairés le conditionnement se fait sur chaque entité.

OBJET_DOCUMENT

21,23 Type de document (DEV)

25,60 Objet du document pour le fax/email

OPT_COUT_TRANSPORT

21,22 Numéro de l'option sur laquelle inclure le coût de transport

Important : Si cette option est mise en place, le coût de transport ne sera plus imputé sur le prix de revient du devis.

PAS_DE_MSG_RECALCUL

21 Recalcul automatique des pointages sans message de confirmation

O Pas d'affichage du message de confirmation

N Affichage (Valeur par défaut)

REACTUAL_DATES_VAL

Réactualisation des dates de validité du devis (O/N, N par défaut)

RECALCUL_NVAR_F15

Mode de recalcul

O Recalcul uniquement des nouvelles variantes F15

N Recalcul de tout le devis (par défaut)

Lors de la création de variantes de quantité, qualité ou de couleurs, par la touche F15, ne recalculer, sur option, que celles que l'on vient de créer et pas tout le devis.

RETRAITLARGEURMAX

21,24 Retrait autorisé dans la largeur de la palette (en mm)

Permet de gérer le retrait maximum lors du calcul du conditionnement (pour éviter de mettre un PF trop petit sur une trop grande palette).

RETRAITLONGUEURMAX

21,24 Retrait autorisé dans la longueur de la palette (en mm)

Permet de gérer le retrait maximum lors du calcul du conditionnement (pour éviter de mettre un PF trop petit sur une trop grande palette).

SANS_RECALCUL_GAMME

Interdit le re-calcul du devis après le choix de la gamme

La seule présence de cette note produit son effet.

Pas de paramétrage à partir du caractère 21.

STOCKAGE_NUM_ETUDE

21,60 Numéro d'étude

_SUP_ORDER_BY_RECAP

Complément de tri pour l'affichage de la liste des devis réactualisés

Liste des champs possibles :

l2_devis Numéro de devis

l2_sdevis Numéro de sous-devis

l2_client Code client

l2_code_prod Code produit du devis

l2_pxcc_avant Prix au mille avant recalcul

l2_pxcc_apres Prix au mille après recalcul

l2_remis Prix remis

Par défaut, lordre de tri est :

l2_client

l2_code_prod

l2_devis

l2_sdevis

_SUP_REQ_FEFCO

21, 60 Complément de requête sur la recherche des codes FEFCO

_SUP_REQ_MATIERE

21, 60 Complément de requête. Par ex : and mp_code matches "Q*"

_SUP_REQ_REACTUAL

21,60 Complément de recherche pour la liste des devis à réactualiser

L'écran de sélection multi-critère est affiché.

Ce complément de recherche s'ajoute à la sélection validée par l'utilisateur.

Exemple : and l2_type_dev != "STD"

TITRE_DOCUMENT

21,23 Type de document (DEV)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TRI_CHOIX_GAMME

21 Ordre de tri sur la fenêtre de choix de la gamme

1Tri par type de gamme (par défaut)

2 Tri par valorisation

TSC_MODIF_POINTAGES

21,23 Code TSC pour l'enregistrement de la modification d'un ou plusieurs pointages (détail FEFCO, Control-E)

Par défaut : MPT - Voir l'option Ocr.

TYPE_COUTEAU

21,23 Code paramètre du type de couteau pour un refouleur (paramètre CP)

TYPE_REFOULEUR

21,23 Code paramètre du type de pointage pour un refouleur (paramètre CP)

Paramètres associés

#CF DER | Configuration du récapitulatif du devis.
#CF DEG | Configuration générale du devis feuille
#CF SMC | Configuration générale de la saisie des matières consommées. Seuls la tolérance laize, la tolérance coupe et le nombre maximum de matières optimales sont utilisés.
SCE | Scénario de calcul du devis : alpha1[1,3]
TPR | Palette par défaut et mode de gestion par défaut


Devis transformateurs carton plat

Devis transformateurs carton plat devis_car

Voir Devis imprimeries feuille et rotative


Devis onduleur

Le calcul actuel de marge est standard et ne donne pas satisfaction pour le multi-niveau.

La marge à appliquer à un devis chapeau est une marge pondérée en fonction des marges de chacun des composants du chapeau.

Le PF "Pc" est composé de ka PF "Pa" et de kb PF "Pb".

Pa a un devis Da. Dans ce devis, on calcule la base marge unitaire BMa(_MA + _VM) ramenée à l'unité.

On calcule également le montant de la marge M¬a(%MA + %VM) ramenée à l'unité.

De même pour Pb et les autres composants Pc.

Dans le devis en cours de calcul pour le produit Pc, on va appliquer un forçage de marge (%VM) à Pc en calculant une moyenne pondérée des marges des différents produits composant Pc.

Pc est composé de Kca Pa et de Kcb Pb, la marge pondérée est :

((Kca * M¬a) + (Kcb * M¬b) + & + (Kcn * M¬n))

((Kca * BMa) + (Kcb * BMb) + & + (Kcn * BMn))

Dans l'exemple :

Pa : P111200010110

Pb : P1111200010120

M¬a= 15.4664/100=0.154666¬

M¬b=5.0594/100=0.050594¬

BMa=1854.60/5000=0.37092¬

BMb=6960.60/5000=1.39212

VMc=(0.154666+0.050594) / (0.37092+1.39212) = 0.20526 / 1.76304 = 11.64%

On va alors simuler le forçage de marge dans l'action de service %VM.

Via paramétrage, le ou les types de notes qui s'affichent dans l'écran de gamme de fabrication dans le tableau récapitulatif du triplet peuvent être personnalisés par rapport aux types de notes paramétrées pour l'application.

Si le paramétrage n'est pas présent, par défaut les notes affichées seront celle configurées au niveau du lanceur (comme actuellement -C).

En revanche, si les types de notes personnalisées pour l'écran de gamme de fabrication sont mises en place, alors seules ces notes s'afficheront, celles configurées dans le lanceur seront ignorées.

Devis onduleur don

Accès à la GED

Voir aussi

#CF DKP

TSC SKM (Skip Feed)

Codes calcul des valeurs des dépendances

Quantités en entrée des actions de service

Codes calcul des caractéristiques des actions de service

Optimisation du conditionnement dans le devis onduleur

Contrôle des mini/maxi ouverture/poussée pour une pose sur la machine

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Sur les écrans d'architectures étudiée et automatique, l'accès à la zone Cannelure inversée peut être conditionné par une permission.

Permission d'accès à la zone Cannelure inversée de l'écran d'architecture étudiée : ACC - DON_035_CAN_IN

Permission d'accès à la zone Cannelure inversée de l'écran d'architecture automatique : ACC - DON_030_CAN_IN

Par défaut, l'accès est autorisé.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Action : recalcul

Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis

Exemples:

-N[kp_de_ndemcli]

-N[lc_dev|-|lc_sdev+<<&]

Options triées

-N

Numéro de devis à recalculer

Exemple -N04030001

O1d

Dimensions avec 1 décimale dans l'écran de l'architecture étudiée

O7p

Dans l'écran de conditionnement, récupération des protections palettes, en fonction de dimensions saisies

Oad

Prise en compte des TSC saisis sur l'adresse secondaire lorsqu'il n'y a pas de liste de TSC paramétrée (Note commençant par LISTE_TSC_COND) en création d'article.

En création d'article et lorsqu'il n'y a pas de liste de TSC paramétrée (Note commençant par LISTE_TSC_COND), les TSC pris en compte pour la mise à jour des TSC de l'article créé sont ceux de l'adresse principale.

Cette option permet de prendre en compte les TSC de l'adresse secondaire.

Si le TSC n'est pas présent sur l'adresse secondaire, le module prendra le TSC de l'adresse principale.

Oao

Gestion des appels d'offres

Voir les notes AO_CONFIGURATION, DC_REFEMBCLI_DEFAUT et DS_REFEMBCLI_DEFAUT

Oas

Activer la recherche automatique d'architectures existantes

Oca

Active l'option de calcul des poids et surfaces des ensembles - A VERIFIER

Ocb

Recalcul batch du devis

Voir les notes commençant par

_SUP_REQ_DEVIS

_SUP_REQ_MAT

NOM_FIC_MODE_TRACE

Occ

Ajout de la variante de quantité du camion complet

Le but est de pouvoir créer une offre avec la quantité camion du produit fini 1 de l'offre 1 en automatique.

Après l'utilisation de l'action Variante de quantité, on enregistre sur le TSC 21A :

en ic_num_3, la quantité camion si elle est différente de 0

en ic_char3_1, l'offre de la variante de quantité du camion complet

Si la quantité du camion complet est modifiée sur l'offre de référence (fenêtre 048 conditionnement), l'offre du camion complet sera supprimée puis recalculée.

Ocd

Calcul des déchets basé sur les TSC

Oce

Désactiver l'affichage des message Plusieurs cas d'emploi

Ocg

Gestion des consommables génériques

Ocm

Optimisation du conditionnement en fonction de la gamme retenue

Cette option permet aux notes sur les machines d'être prioritaires sur les mêmes notes paramétrées ici.

Ces notes sont regroupées dans un paragraphe séparé.

Oco

Consultation uniquement

Ocp

Améliore la recherche de la palettisation en prenant en compte dans le calcul la plus grande largeur d'encombrement (palette ou encombrement).

Ocr

Demande de confirmation pour le recalcul de pointages après la saisie de l'architecture automatique

Voir la note commençant par TSC_MODIF_POINTAGES

Odc

Saisie des devis concepteurs

Remarque : Cette option est incompatible avec l'option Ods : Saisie des devis onduleurs simplifiés.

Voir les notes

CODE_COMPLEXE_DEC_

DC_TYPE_NOTE_PF

DC_TYPE_NOTE_TRIPLET

DC_REFEMBCLI_DEFAUT

DC_EDITION_AUTO_VAL

Odd

Initialiser le code FEFCO dessous avec celui du code FEFCO dessus sans interdire la saisie du code FEFCO dessous.

Ode

La référence de l'entête du devis est recopiée dans la référence emballage client.

Odn

Saisie de la nomenclature

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Odp

Saisie simplifiée des devis papeterie

Voir les notes commençant par DP

Voir aussi les notes _SUP_SQL_CLIENT et _SUP_SQL_NUM_DEMCLI

Ods

Saisie des devis onduleurs simplifiés

Option payante PRO 11

Voir aussi les notes DS_EDITION_AUTO_VAL et DS_REFEMBCLI_DEFAUT, ainsi que AS A1[37].

Les produits des notes suivantes doivent avoir des sous familles renseignées :

COPREFEMBKP

COPPF

Il faut renseigner les notes NTS ART suivantes, sur les FEFCO qui sont utilisés par le devis simplifié.

Odx

Prise en compte des dimensions extérieures saisies sur l'architecture dans le devis concepteur pour le calcul du conditionnement (dimensions du produit fini plié)

Oep

Affichage de l'écran des pointages après validation du devis architecture étudiée

Oex

Mode expert (pour les contrôles de possibilité machine)

Ofa

Détermination automatique des famille / sous-famille en fonction de la gamme

Nécessite un TSC 270 paramétré comme suit :

ic_char3_2 Flag de forçage de la famille / sous-famille (O/N, N par défaut)

Nécessite des notes de type FSF sur code gamme associé au PF pour axe technique

(saisi sur le TSC 200, char3_1) :

Caractères 1 à 4 FAM=

Caractères 5 à 7 Nouveau code famille pour mise à jour

Caractères 8 à 11 SFM=

Caractères 12 à 14 Nouveau code sous-famille pour mise à jour

Ofd

Alimenter automatiquement le FEFCO du dessous avec celui du dessus

Interdire la saisie de FEFCO dessous

Ofi

Le couple famille/sous-famille des produits finis est identique à celui de l'ensemble.

Ofp

Force le calcul du conditionnement sur une palette à la base.

Sans cette option, par défaut, le calcul se fait sur une palette à la base et si le calcul de conditionnement ne retient aucun schéma possible, il passe automatiquement au calcul à deux palettes à la base.

Ofv

Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût

Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.

Ogc

Ecran des gammes avant l'écran du conditionnement

Ogo

Ne pas tenir compte du coût des outillages pour déterminer la gamme du devis

Ogp

Gestion des plaques dans le devis

Ogr

Gestion des remises de prix. Permet d'accéder aux remises de prix depuis le devis

Ohc

Hauteur palette en fonction de la coupe

Oin

Inversion saisie et affichage Laize Coupe

Ole

Ne pas recopier le libellé étranger lors de la recopie du devis

Olg

Active la limitation de la gamme en fonction du site de production. Tableau de bord du multisite

Seules les gammes dont la zone site de production est identique au code site de production courant sont affichées

Olo

Lors de la génération du devis de fabrication, la désignation et le libellé client de l'ensemble sont obligatoires

Oma

Active la mise à jour des données de l'architecture étudiée par l'interface ARTIOS lors de la saisie du numéro d'étude

Omc

Permet la modification du code client d'un devis onduleur

Nécessite la permission MOD CLIENT_DEV_OND

Omp

Lors du recalcul du devis, ne pas mettre à jour le prix remis si un prix négocié a été saisi

Omr

Mise à jour lieu de rangement sur l'ensemble suite au recalcul de la gamme

Omt

Mise à jour du flag de transfert des lignes de commandes lors du passage de l'article à l'état FAB. Fonction F22

Onc

Affichage automatique des notes du client du devis

Voir la note AFF_NOTES_CLI_DEVIS

Ond

Suppression du contrôle du code nomenclature douanière

Si cette option est activée, le code nomenclature douanière n'est plus contrôlé dans l'écran de saisie complémentaire du PF (Touche F22).

Onv

Non valorisation de la composition même si celle-ci est valorisable, si la gamme saisie ne possède pas de machine de type onduleuse ou extrudeuse

Oog

Gérer les quantités de l'offre via l'écran des gammes

Oot

Réactualisation des données de palettisation des ordres de transport

La logistique doit être activée (#CF LOG A1[1] = O)

Opi

Active la gestion de la palettisation intermédiaire (voir TSC PI1)

Oqo

Recalcul des prix de cession dans le cadre du multi-niveaux, avec la quantité de l'offre et utilisation des coefficients de nomenclature

Permet de recalculer les prix de cession, en multi-niveaux, des différents PF, en tenant compte de la quantité de l'offre "mère" et des différents coefficients de nomenclature.

Orc

La référence de l'entête du devis est recopiée dans la référence emballage client

Orp

Accès à l'écran de remise de prix

Osd

Sortie définitive de la saisie des devis lors de l'appui sur la touche F6

Rappel : si cette option est désactivée, la touche F6 permet de retourner sur le premier écran du devis

Osi

Schéma de palettisation imposé

Rechercher palettisation en tenant compte du code palettisation renseigné sur le devis

Osm

La surface du produit montée est égale à la somme des surface des produits qui le composent.

Osr

Active la non prise en compte des rives mini dans les calculs du devis

Oti

Traçabilité sur la table des informations complémentaires (info_c)

L'option payante (BAS, 4) doit être activée.

Otm

Traçabilité sur la table des articles (mat)

L'option payante (BAS, 10) doit être activée.

Ovc

SPECIFIQUE - Contrôle des composants de niveau inférieur avant passage en fabrication

Ovm

Simuler le forçage de marge dans l'action de service %VM

Infos

Oxm

Gestion du fax email automatique

Valeur alpha 2

Caractères 1 à 3

Code environnement à prendre en compte pour la valorisation des taux horaires.

Caractère 4

Modification des données techniques autorisée sur l'onduleuse (O/N, N par défaut)

Caractères 5 à 10

Type et code du paramètre de lancement de l'édition

Caractères 11 à 16

Type et code du paramètre de lancement de l'édition de la nomenclature (F18)

Caractères 17 à 19

Code environnement pour les prix de cession matière

Caractères 20 à 25

Type et code du paramètre de lancement de la fiche client

Caractère 26

Mode de codification des articles FAB

1 Si ancien symbole, alors ancien code client (cl_telex[1,6])

Ancien symbole (mp_remp)

sinon : Chrono sur 6 chiffres

2 Si client #SOC et ancien symbole, alors Ancien symbole

sinon : Chrono sur 6 chiffres

3 R + code client (cl_code) ou code groupe (cl_cligr) si renseigné sur la fiche client

+ compteur A à Z puis AA à ZZ puis AAA à ZZZ, etc.

4 R + code client (cl_code) + compteur A à Z puis AA à ZZ puis AAA à ZZZ, etc.

5 Nouvelle méthode de création de devis fabriqué (passage en 99).

Le code ensemble et les codes produits sont saisissables lors du passage en 99,

par l'ouverture d'une fenêtre spécifique.

6 R + Racine fixe + Chrono sur 6 caractères. SPECIFIQUE

Voir note RACINE_FIXE_CRE_ART

Sinon : Chrono sur 6 chiffres

7 Codification selon l'appairage et le code famille

Pour l'article de référence : RccccXX00

où cccc est un compteur alpha numérique sur 4 caractères

et XX un code défini selon le type d'appairage

Pour les composants : PccccXX00

où cccc est un compteur alpha numérique sur 4 caractères

rt XX un code défini selon le code famille du composant.

Voir les notes FAM_ASSOCIE_MONTE

Voir la note CODIFICATION_ART_99 dans le paramètre type FAM.

Caractère 27

La référence emballage client de l'entête du devis est recopiée dans la référence emballage interne (O/N)

Caractère 28

Code nomenclature douanière obligatoire (O/N, N par défaut)

Caractères 29 à 34

Type et code du paramètre de lancement de la fiche de spécification

Nécessite également que QA A1[11] soit renseigné.

Caractère 40

Permet d'alerter l'utilisateur des erreurs ou anomalies de saisie sur les champs concernant coupe, laize et nombre de poses. Valeurs possibles :

N pas d'option (par défaut)

W affichage de messages non bloquants

B affichage de messages bloquants

Caractère 41

Utilisation du schéma de palettisation 4T3

Caractère 42

Utilisation du schéma de palettisation 8T3

Caractères 43 à 45

Type de la zone de la fiche client pour le contrôle des marges prix remis et prix négocié de lécran de remise de prix. Obligatoire

Types autorisés :

GEO Secteur géographique

CAT Catégorie

ACT Secteur d'activité

ORG Origine

ZP Zone paramétrée 1

ZP2 Zone paramétrée 2

ZP3 Zone paramétrée 3

Caractères 46 à 48

Code site de production associé à cette saisie de devis -Tableau de bord du multisite

Ce paramétrage sert à renseigner le code site de production créateur du devis.

Remarques :

" Par défaut, on prend le code site de production associé à l'utilisateur qui a créé le devis, paramétré en USE A3[10,12].

" Doit correspondre à un paramètre de type SIT.

Caractères 49 à 51

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

Caractères 52 à 57

Type et code du paramètre de lancement de dossiers de fabrication (#FBGDF)

Caractère 58

Choix du site en fonction de la gamme (O/N) - Tableau de bord du multisite

Valeur alpha 3

Caractères 1 à 6 | Type et code du paramètre de lancement du programme des remises de prix
Caractères 7 à 9 |
Caractère 10 | Masquer l'ensemble lié au produit lors de l'affichage des produits utilisés par les outils N On affiche l'ensemble lié au produit (par défaut) O On n'affiche pas l'ensemble lié au produit.
Caractère 11 | Ne pas afficher automatiquement la fenêtre Complément de conditionnement (O/N, N par défaut) N affiche automatiquement O n'affiche pas automatiquement. Accès via F8.
Caractère 12 | Gestion de la cannelure inversée en interne (O/N, O par défaut)
Caractère 13 | Avoir la possibilité de saisir des informations techniques O la zone Présence information technique s'affiche N la zone Présence information technique ne s'affiche pas (par défaut)
Caractère 14 | Contrôle de la surface minimum requise sur la qualité N par défaut B bloquant W warning C demande de confirmation Initialement, ce contrôle était en A3[12] mais il a été déplacé ici en raison d'un conflit.
Caractère 15 | La certification de produit doit être égale à la certification de la composition commerciale.
Caractère 16 | Accès à l'écran des règles de gestion par lieu d'un article O Accès en consultation M Accès en modification N Pas d'accès, par défaut

Notes

Il y a plusieurs catégories de notes. Faites défiler l'écran pour les voir toutes.

ATTENTION : certaines notes ont été regroupées lorsqu'elles font partie d'une même entité logique : elles apparaissent dans des tableaux séparés.

Les autres notes figurent dans le tableau général des notes, après ces tableaux.

Notes pour la nouvelle modélisation des données techniques

Permettre de rattacher entre elles toutes les données techniques relatives à un produit fini de façon à en faciliter et en fiabiliser l'utilisation et donc les mises à jour d'architectures identiques pour plusieurs produits finis.

L'utilisation d'une architecture existante dans le devis entraînera la recopie sur le nouveau produit fini des informations rattachées à l'architecture.

De même, la modification d'une architecture entraîne la mise à jour de tous les produits finis utilisant cette même architecture.

L'activation de cette nouvelle fonction se fait par le biais de la note MDT_ACTIVATION dans le paramètre #CF DKP.

_SUP_REQ_RECH_ARC

21,60 Complément de sélection sur la table des matières (mat) pour la recherche de codes architectures (F7 sur code architecture)

_SUP_REQ_ARC_EXI_A

21,60 Complément de sélection sur la table des matières (mat) et sur des champs paramétrables (TSC) pour la recherche d'architectures automatiques similaires

Voir le paramétrage associé à cette recherche ci-dessous

_SUP_REQ_ARC_EXI_E

21,60 Complément de sélection sur la table des matières (mat) et sur des champs paramétrables (TSC) pour la recherche d'architectures étudiées similaires

Voir le paramétrage associé à cette recherche ci-dessous

_SUP_REQ_ORDRE_TRSP

21, 80 Supplément de requête sur la table des ordres de transport pour la réactualisation des données de palettisation des ordres de transport

Exemple

_SUP_REQ_ORDRE_TRSP and otr_num_cde matches "06*"

MDT_TYPE_NOTE_HISTO

21,23 Type de la note d'historisation

Si aucun type de note n'est paramétré, l'historisation de la modification d'une donnée liée à l'architecture ne sera pas enregistrée

Exemple : HIS

MDT_VALIDITE_PF

21,23 Code validité (Type de paramètre QA) à mettre en place lors de la mise à jour des produits finis utilisant l'architecture en cours de modification.

Exemple : FMO

_SUP_SQL_MDT_VAL_PF

21 60 Complément de sélection sur la table des produits (mat) permettant d'exclure des produits finis utilisant l'architecture en cours de modification de la mise à jour du code validité

Exemple : and mp_qualite = "FAB"

MDT_PARAM_VISU_OFS

21,26 Type et code du paramètre de lancement de la visualisation des ordres de fabrication en cours liés aux produits finis utilisant l'architecture en cours de modification

MDT_RECOPIE_NOTE

21,23 Type de note placée sur le produit fini créateur à recopier lors de la mise à jour des produits finis utilisant l'architecture en cours de modification.

Il est possible de paramétrer un type de note à recopier par ligne.

Attention : les notes du type paramétré sur le produit fini cible seront effacées avant d'être recopiées du produit créateur.

MDT_RECOPIE_TSC

21,23 Code TSC placé sur le produit fini créateur à recopier lors de la mise à jour des produits finis utilisant l'architecture en cours de modification.

Il est possible de paramétrer un code TSC à recopier par ligne.

Attention : le TSC du code paramétré sur le produit fini cible sera effacé avant d'être recopié du produit créateur.

Paramétrage de recherche de codes architectures similaires

Outre un complément de sélection sur la table des matières, il est possible de construire un complément de sélection se basant sur les valeurs saisies par l'utilisateur sur l'architecture en cours de création.

Liste des champs paramétrables :Il s'agit ici d'indiquer les zones sur lesquelles faire la recherche.

%kp_etude% | Numéro d'étude
%kp_fefco_sur% | FEFCO dessus
%kp_fefco_sou% | FEFCO dessous

Liste des valeurs de champs paramétrables :Il s'agit ici d'indiquer comme élément de recherche les valeurs saisies sur l'architecture en cours de création.

%LONG% | Longueur
%LARG% | Largeur
%HAUT% | Hauteur
%COMPO% | Code composition
%CLIENT% | Code client
%ETUDE% | Numéro d'étude
%FEFCO_SUR% | Code FEFCO dessus
%FEFCO_SOU% | Code FEFCO dessous

Exemples

1) Recherche d'un code architecture automatique :

_SUP_REQ_ARC_EXI_A and mp_qualite = "FNV"

_SUP_REQ_ARC_EXI_A and mp_lon = %LONG%

_SUP_REQ_ARC_EXI_A and mp_lar = %LARG%

_SUP_REQ_ARC_EXI_A and mp_hau = %HAUT%

_SUP_REQ_ARC_EXI_A and %kp_fefco_sur% = %FEFCO_SUR%

_SUP_REQ_ARC_EXI_A and %kp_fefco_sou% = %FEFCO_SOU%

La recherche se fera sur la table mat pour les dimensions de l'architecture à rechercher (longueur, largeur et hauteur), et sur la table des informations complémentaires pour les codes FEFCO dessus et dessous.

2) Recherche d'un code architecture étudiée :

_SUP_REQ_ARC_EXI_E and mp_qualite = "FNV"

_SUP_REQ_ARC_EXI_E and mp_lon = %LONG%

_SUP_REQ_ARC_EXI_E and mp_lar = %LARG%

_SUP_REQ_ARC_EXI_E and mp_hau = %HAUT%

_SUP_REQ_ARC_EXI_E and %kp_etude% = %ETUDE%

_SUP_REQ_ARC_EXI_E and %kp_fefco_sur% = %FEFCO_SUR%

_SUP_REQ_ARC_EXI_E and %kp_fefco_sou% = %FEFCO_SOU%

La recherche se fera sur la table mat pour les dimensions de l'architecture à rechercher (longueur, largeur et hauteur), et sur la table des informations complémentaires pour le numéro d'étude et les codes FEFCO dessus et dessous.

Remarque importante

Si la recherche d'architecture (recherche par F7 ou recherche de codes architectures similaires) se fait via un complément de sélection sur le code validité de l'architecture (Exemple : and mp_qualite = "FNV"), il peut être utile de créer un index sur cette zone sur la table des matières (mat) afin d'améliorer les temps de réponse.

La syntaxe est la suivante :

create index [Nom de l'index] on mat (mp_qualite, mp_soc)

Optimisation du conditionnement dans le devis onduleur

L'option Ogc permet de choisir la gamme avant le conditionnement.

L'option Ocm permet d'optimiser le conditionnement en fonction de la gamme retenue.

On prend alors les éléments techniques suivant la dernière machine de transfo de la gamme.

Un complément de requête sur les schémas de palettisation (SUPREQSCHEMAPAL) permet d'en interdire certains.

Ce complément peut être paramétré à 3 endroits différents, et dans cet ordre de priorité :

sur la dernière machine de transformation de la gamme

sur le paramètre de lancement (donc ici)

sur le paramètre de configuration générale du devis.

Un nouveau contrôle de hauteur palette en fonction du schéma de palettisation est maintenant applicable.

Dans le cas où le calcul de conditionnement ne retient aucun schéma possible avec 1 palette à la base, le système recherche automatiquement un schéma avec 2 palettes à la base.

Actuellement, la hauteur palette est déterminée en fonction de la laize plaque onduleuse. On peut maintenant le faire sur option (Ohc) avec la coupe.

Lors de la génération de l'OF, on impose le format palette en fonction des dimensions de la plaque à conditionner.

Voir aussi

Schéma de palettisation : A3[1,9] et A4[1,3]

#CF DKP, note REP_IMG_SCHEMA_PAL

Hiérarchie de recherche des notes ci-dessous

  1. Ces notes sont d'abord recherchées sur le paramètre de lancement du devis onduleur (donc ici).

  2. On va ensuite les rechercher sur la famille du PF
    Celles qui y sont trouvées vont remplacer celles précédemment trouvées.

  3. On va ensuite les rechercher sur le lieu de rangement 1.
    Celles qui y sont trouvées vont remplacer celles précédemment trouvées.

  4. Si option Ocm est active, on va les rechercher sur la machine de transformation.
    Celles qui y sont trouvées vont remplacer celles précédemment trouvées.

DEPASSEMENTLARGEUR

21,60 Dépassement autorisé dans le sens de la largeur de la palette pour le calcul du conditionnement.

Exprimé en mm, il représente le dépassement total et non le dépassement à chaque bout de la palette.

Exemple : DEPASSEMENTLARGEUR 0050

DEPASSEMENTLONGUEUR

21,60 Dépassement autorisé dans le sens de la longueur de la palette pour le calcul du conditionnement.

Exprimé en mm, il représente le dépassement total et non le dépassement à chaque bout de la palette.

Exemple : DEPASSEMENTLONGUEUR 0050

FORMATPALETTE

Formats possibles des palettes (maxi 200)

21,28 Longueur (en millimètres)

30,37 Largeur (en millimètres)

39 Test sur longueur si utilisation de 2 palettes pour le conditionnement (O/N, N par défaut)

41,44 Hauteur par défaut (optionnel)

46,49 Hauteur maximum (optionnel)

51,54 Poids maximum (optionnel)

Exemples

FORMATPALETTE 01200.00 00800.00 O

FORMATPALETTE 01200.00 01000.00 N

FORMATPALPLAQUE

Données de palettisation

21,24 Borne inférieure pour la coupe (en mm)

26,29 Borne supérieure pour la coupe

31,34 Borne inférieure pour la laize

36,39 Borne supérieure pour la laize

41,44 Longueur palette

46,49 Largeur palette

51 Nombre de palettes à la base

Ce paramétrage n'est valable que pour le calcul du conditionnement pour les commandes cartonnier, en génération d'OF.

HAUTEURMAXPALETTE

21,60 Hauteur maxi des palettes (en mm). Attention, bois de palette compris !

Exemple : HAUTEURMAXPALETTE 2000

HAUTEURPALCARREE

Hauteur de la palette carrée

21,24 Hauteur de la palette carrée

25,28 Delta (valeur absolue) entre largeur et longueur pour définir une palette carrée

HAUTEURPALETTE

21,60 Hauteur par défaut des palettes (en mm). Attention, bois de palette compris !

Exemple : HAUTEURPALETTE 1800

HPALCARTONNIER

Hauteur par défaut des palettes (en mm) et hauteur maxi des palettes (en mm) pour les produits cartonnier en fonction de la laize de la plaque (CARTONNIERS uniquement).

21,24 Hauteur palette

26,29 Hauteur maxi palette

31,34 Laize mini

36,39 Laize maxi

Exemples

HPALCARTONNIER 1200 1500 0000 0400

HPALCARTONNIER 1500 1800 0401 0500

HPALCARTONNIER 2000 2200 0501 9999

NBMAXPILES

21,60 Nombre maxi de piles par palette

Exemple : NBMAXPILES 0012

NPALETTES

Nombre de palettes par unité de conditionnement à utiliser en fonction de la plus grande dimension du produit (CARTONNIERS uniquement)

21,24 Nombre de palettes

26,29 Dimension à partir de

31,34 Dimension jusqu'à

Exemples

NPALETTES 0001 0000 1300

NPALETTES 0002 1300 2000

NPALETTES 0003 2000 9999

RETRAITLARGEURMAX

21,60 Retrait maximum autorisé dans le sens de la largeur de la palette

Exprimé en mm, il représente le retrait max total et non à chaque bout.

Exemple : RETRAITLARGEURMAX 0500

RETRAITLONGUEURMAX

21,60 Retrait maximum autorisé dans le sens de la longueur de la palette

Exprimé en mm, il représente le retrait max total et non à chaque bout.

Exemple : RETRAITLONGUEURMAX 0500

Autres notes, triées par ordre alphabétique

ACCES_CREER_COMPO

Depuis l'écran architecture (030 et 035), après la saisie d'une composition commerciale existante, via l'action Modification composition, il est possible de créer une nouvelle composition commerciale ayant pour code "Q + code du PF" par recopie de celle saisie précédemment.

Cette action est disponible uniquement si le numéro d'offre est différent de 99.

21,26 Type et code du paramètre de lancement de la gestion des compositions

Voir la note CODE_QUA_C_CREER_D dans la gestion des compositions

AFFICHER_CODE_PAL

21 Afficher le code palette dans le conditionnement (O/N, N par défaut)

Par défaut, le code palette n'est pas modifiable.

Il est possible de le modifier via la permission CPAL_DEV_OND dans MOD.

AFF_NOTES_CLI_DEVIS

Il est possible de faire apparaître automatiquement une fenêtre de consultation des notes clients à la validation d'un entête de devis.

21,59 Liste des types de notes clients à afficher à la validation de la saisie de l'entête du devis.

13 types de 3 caractères par ligne.

Cette note est prioritaire ici. Si elle n'est pas trouvée ici, elle sera recherchée sur le #CF DKP.

Elle nécessite l'option Onc.

AO_CONFIGURATION

Type et code du paramètre de configuration de la gestion des appels d'offres. Voir l'option Oao.

Si ce paramétrage existe, les notes commençant par AO_ seront prises sur celui-ci.

ARCHITECTUREDEFAUT

21 Indicateur Architecture par défaut lors de la création d'un produit fini (A, E ou N).

ARTIOS_DECONNECTE

21 Utiliser l'interface ArtiosCAD en mode déconnecté (chargement des données à partir des fichiers XML) (O/N, N par défaut)

ARTIOS_MAJ_SURFACE

21 Mise à jour de la surface en retour d'ArtiosCAD

O La surface est mise à jour avec la valeur que retourne ArtiosCAD (par défaut)

N La surface n'est pas mise à jour avec la valeur que retourne ArtiosCAD
mais recalculée à partir des dimensions retournées par ArtiosCAD.

CALCUL_ZONE_ARTIOS

Calcul sur une zone au retour d'Artios

21,45 Zone cible mise à jour lors de l'intégration Artios

Il doit s'agir d'une zone cible VoluPack définie dans la configuration Artios de VMC (voir capture d'écran ci-dessus) : TSC ou zone figée VoluPack.

Important : S'il s'agit d'une zone figée VoluPack, le mot-clé devis_onduleur ne doit pas être saisi.

Exemples

TSC_MP_202_E

complexe_decoupe

47 Opérateur

+ Addition

- Soustraction

* Multiplication

/ Division

49,60 Valeur opérande

Exemple

1 2 3 4 5

12345678901234567890123456789012345678901234567890

CALCUL_ZONE_ARTIOS TSC_MP_202_E / 1000

La valeur provenant d'Artios qui a pour zone cible la TSC 202, zone numérique 3 sur le produit fini sera divisée par 1000.

CODE_COMPLEXE_DEC_

19 Code présence de découpe sur la gamme

O Découpe

N Pas de découpe

I Indifférent

21,23 Code complexité de découpe correspondant au code présence (doit correspondre à un type paramètre .CD)

Voir l'option Odc - Devis concepteur

CODE_PAL_PLAN_PAL_

19 Premier caractère du plan de palettisation

21,26 Code de palettisation par défaut

CODE_TARIF_RECH_PRIO

Met à jour des données de la table kp_recap_tot à partir du tarif sur l'ensemble pour les différentes offres,

et en interdit la modification.

Dans le recalcul batch, met à jour des données de la table kp_recap_tot pour les différentes offres à partir du tarif sur l'ensemble.

21,23 Code tarif de recherche (paramètre TAR)

24,29 Type et code du paramètre de recherche de tarif (#CFTAR par défaut)

CODE_VALIDITE_FNV

21,23 Code paramètre de validité de fabrication non validée

Exemple : FNV

CONDIT_INFO_COMP

21,23 Information complémentaire du conditionnement

CONDIT_INFO_COMP_1

21,23 Information complémentaire 1 du conditionnement

Par souci de compatibilité avec l'existant, cette note est identique à la note CONDIT_INFO_COMP ci-dessus.

Si les 2 notes sont paramétrées par erreur, c'est celle qui est paramétrée en deuxième qui est prise en compte.

CONDIT_INFO_COMP_2

21,23 Information complémentaire 2 du conditionnement

CONDIT_INFO_COMP_3

21,23 Information complémentaire 3 du conditionnement

CONDIT_INFO_COMP_4

21,23 Information complémentaire 4 du conditionnement

CONDIT_INFO_COMP_5

21,23 Information complémentaire 5 du conditionnement

CONDIT_INFO_COMP_6

21,23 Information complémentaire 6 du conditionnement

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

Pour créer ou affecter une affaire, 2 procédés :

1) Action Saisie de l'affaire (MAJ+F4)

2) Depuis l'écran d'entête du devis onduleur

Nécessite la permission (MOD DO_AFF)

Si l'utilisateur n'a pas la permission, alors il pourra uniquement consulter les différentes zones associées à l'affaire.

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

CONFIG_PRIX_CESSION

21,23 Type paramètre de la configuration des prix de cession

24,26 Code paramètre de la configuration des prix de cession

COPPF

21,35 Référence PF par défaut pour copie

Exemple : COPPF PPFDEF001

COPREFARCBE

21,35 Référence d'architecture Bureau d'étude par défaut pour copie

Exemple : COPREFARCBE AARCBEDEF001

COPREFARCSTD

21,35 Référence d'architecture standard par défaut pour copie

Exemple : COPREFARCSTD AARCSTDDEF001

COPREFEMBKP

21,35 Référence ENSEMBLE par défaut pour copie

Exemple : COPREFEMBKP RREFENDEF001

COPREFIMP

21,35 Référence d'impression par défaut pour copie

Exemple : COPREFIMP IIMPDEF001

COPREFPRE

21,35 Référence de pré-impression par défaut pour copie

Exemple : COPREFPRE YREFPREDEF01

CTRL_OUTIL_MACHINE

21 Type de contrôle entre l'outillage et la machine

N Pas de contrôle (valeur par défaut)

B Contrôle bloquant

C Contrôle avec demande de confirmation

W Contrôle en warning

Voir aussi la note LIEN_OUTIL_MACHINE

CTRL_SURFACE_MINI

21 Contrôle de la surface minimum requise lors de la validation du prix

N par défaut

B bloquant

W warning

C demande de confirmation

23,33 Valeur de la surface minimum

DC_EDITION_AUTO_VAL

21 Lancement automatique de l'édition à la validation du devis

N Pas d'édition (par défaut)

C Edition à la création de devis

2 Edition systématique à la validation

Voir l'option Odc - Devis concepteur

DC_REFEMBCLI_DEFAUT

21,40 Référence emballage client par défaut pour la création des devis concepteurs (architectures étudiées)

Voir l'option Oao

Pas de valeur par défaut

Voir l'option Odc - Devis concepteur

DC_TSC_TRIPLET_RP

Saisie des informations complémentaires (TSC) sur triplet dans le tableau de la gamme

C Sur la phase de réglage si le curseur est dans la colonne Temps
Sur la phase de passage dans tous les autres cas (par défaut)

R Systématiquement sur la phase de réglage

P Systématiquement sur la phase de passage

DC_TYPE_NOTE_PF

21,23 Type de note pour la saisie des commentaires article

Voir l'option Odc - Devis concepteur

DC_TYPE_NOTE_TRIPLET

21,23 Type de note pour la saisie de la première ligne de commentaire sur le triplet PF/Gamme/Phase

Voir l'option Odc - Devis concepteur

DEVIS_PAR_DEFAUT

Devis - sous-devis par défaut

Sous la forme XXXXXXXX-YYY

XXXXXXXX = numéro de devis

YYY = numéro de sous-devis

DN_INFO*

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Colonnes à afficher dans le tableau des informations d'article

Chacun des 4 champs doit être suivi d'un astérisque

1) Libellé de la rubrique

2) Zones possibles

mp_* : Toutes les zones de mat

TSC_[CodeTSC]_[ZoneTSC]

le_libpar1 : Référence client

le_libelle : Libellé spécifique 1

le_libelle2 : Libellé spécifique 2

3) Format (using)

4) Code langue à employer

Ce paramétrage est recherché dans l'ordre de priorité suivant :

Famille/Sous-famille

Famille

Paramètre de lancement

DN_PAR_LCT_

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Ce paramétrage est également utilisé lors de la l'ajout d'un composant dans la nomenclature.

12 Type d'association (par ordre de priorité)

S Code famille et Code sous-famille

On utilisera le paramètre de lancement renseigné en caractères 21 à 26 si les codes famille/sous-famille sont égaux à ceux paramétrés en caractères 14 à 19.

Car.14,16 Code famille (doit correspondre à un paramètre de type FAM)

Car.17,19 Code sous-famille (doit correspondre à un paramètre de type SFM ou à une sous-famille hiérarchique)

F Code famille

On utilisera le paramètre de lancement renseigné en caractères 21 à 26 si le code famille est égal à celui paramétré en caractères 14 à 16.

Car.14,16 Code famille (doit correspondre à un paramètre de type FAM)

T Type d'article

On utilisera le paramètre de lancement renseigné en caractères 21 à 26 si le type d'article est égal à celui paramétré en caractère 14.

Car.14 Type d'article

M Matière

P Produit fini

S Semi-fini

F Fourniture

X Fantôme

O Outils

T Maintenance

K Kit

Q Qualité

A Type d'architecture

On utilisera le paramètre de lancement renseigné en caractères 21 à 26 si le type d'architecture est égal à celui paramétré en caractère 14.

Car.14 Type d'architecture

A Automatique

E Etudiée

D Automatique/Etudiée (création de composant uniquement)

D Défaut

On utilisera le paramètre de lancement renseigné en caractères 21 à 26 si aucune des associations précédentes n'a été trouvée.

Car.14,19 [vides]

13 Inutilisé

14,19 selon le caractère 12, voir ci-dessus.

21,26 Type et code du paramètre de lancement à utiliser pour l'accès et/ou la création de composant

DP_CREER_DEVIS_ENV

Saisie simplifiée des devis papeterie

L'option Odp doit être activée.

Lors de la création d'une nouvelle référence papeterie, créer automatiquement les demandes clients dans les autres environnements que celui en cours.

Une ligne de note par couple d'environnement opération/matière pour lequel une demande client doit être créée.

21,23 Code environnement opération (doit correspondre à un paramètre de type ETI)

24,26 Code environnement matière (doit correspondre à un paramètre de type ETI)

DP_REFEMBCLI_DEFAUT

Saisie simplifiée des devis papeterie

L'option Odp doit être activée.

21,60 Référence emballage client par défaut

Remarque : Valeur obligatoire pour la saisie des devis papeterie. Pas de valeur par défaut.

DP_VISU_DEVIS_ENV

Saisie simplifiée des devis papeterie

L'option Odp doit être activée.

Ouvrir la visualisation des demandes client associées à la nouvelle référence papeterie créée

Nécessite la ligne de note DP_CREER_DEVIS_ENV ci-dessus.

21,26 Type et code du paramètre de lancement de la visualisation des devis onduleurs

DS_EDITION_AUTO_VAL

21 Lancement automatique de l'édition à la validation du devis

Voir l'option Ods

N Pas d'édition (par défaut)

C Edition à la création de devis

2 Edition systématique à la validation

DS_REFEMBCLI_DEFAUT

21,35 Référence emballage client par défaut pour la création des devis simplifiés (architectures automatiques)

Voir l'option Ods - Voir l'option Oao

Pas de valeur par défaut

DUREEVALIDITE

Durée de validité de l'offre (en jours)

21,60 Nombre de jours

Exemple : DUREEVALIDITE 60

ECART_PRIX_RVT_NEG

21 Contrôle du prix négocié par rapport au prix de revient

B Contrôle bloquant

W Contrôle non bloquant

C Demande de confirmation

N Pas de contrôle (par défaut)

22 [rien]

23,28 Pourcentage d'écart minimum autorisé entre le prix négocié et le prix de revient (si aucune valeur n'est saisie, pas de contrôle sur le prix minimum)
Exemple :
Prix de revient : 1100
Pourcentage d'écart minimum : 5%
Le prix négocié ne devra pas être inférieur à 1100 – (1100 * 5%) = 1045.

29 [rien]

30,35 Pourcentage d'écart maximum autorisé entre le prix négocié et le prix de revient (si aucune valeur n'est saisie, pas de contrôle sur le prix maximum)
Exemple :
Prix de revient : 1100
Pourcentage d'écart maximum : 15%
Le prix négocié ne devra pas être supérieur à 1100 + (1100 * 15%) = 1265.

ENCRE_SUR_CLICHE

Contrôle pour obliger la saisie d'un cliché pour une encre, 3 cas possibles :

0 (par défaut) pas de contrôle.

1 une encre ou plus, au moins un cliché mettre sur le TSC. (Bloquant)

2 pour chaque encre, il faut un cliché. (Bloquant)

Le but est de pouvoir tester s'il y a le bon nombre de clichés dans la fenêtre des gammes par rapport aux encres insérées. On pourra aussi tester le nombre de formes par rapport à la découpe choisie dans l'architecture du devis.

Attention : Contrôle ne pouvant être fait que sur l'offre 99.

EPAISSEURMAXPAQUET

Epaisseur maxi du paquet pour la scie à panneaux (en fonction du type de produit)

21,23 Type de produit

24,27 Epaisseur maxi du paquet (mm)

Exemples

L 10

V 12

FAM_ASSOCIE_MONTE_N

21,23 Code famille - Ensemble non monté - Obligatoire si A2[26] = 7

FAM_ASSOCIE_MONTE_E

21,23 Code famille - Ensemble monté à l'extérieur - Obligatoire si A2[26] = 7

FAM_ASSOCIE_MONTE_O

21,23 Code famille - Ensemble monté - Obligatoire si A2[26] = 7

FICTIFACHETE

ATTENTION : Cette note était auparavant dans #CF DKP

21,35 Code du produit fictif (composant générique)

Paramétrage d'un produit fictif (composant générique).

Il sera inséré automatiquement dans la nomenclature au moment de la valorisation des composants lorsque le produit en ligne de devis est un produit acheté (mp_param[5] = A).

La valorisation du composant se fait avec le prix de cession de l'accessoire.

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

GESTION_CODE_STAT_n

GESTION_CODE_STAT_1

GESTION_CODE_STAT_2

GESTION_CODE_STAT_3

GESTION_CODE_STAT_4

où n peut prendre les valeurs 1 à 4

21 Affichage du code statistique 1

O Oui

C Consultation (par défaut)

N Zone cachée

22 Zone obligatoire (O/N, N par défaut)

23,24 Numéro de l'offre à contrôler. 00:pour contrôler pour toutes les offres

HAUTEUR_CAMION

21,25 Hauteur du camion pour le calcul du conditionnement, en millimètres (par défaut : 2500)

Cette note fait partie d'un ensemble de 3 notes :

LARGEUR_CAMION

LONGUEUR_CAMION

HAUTEUR_CAMION

HAUTPOIDSMAXPALETTE

Hauteur par défaut, hauteur max et poids max par type de produit (sous-famille composition commerciale).

21,23 Sous-famille

24,27 Hauteur palette par défaut (en mm)

28,31 Hauteur max palette (en mm)

32,35 Poids max palette en KG

HISTORISATION

Paramétrage des TSC à historiser

21,21 Type d'article (Q C A I P F X Y Z°

2,4 Code du TSC

IMPRESSIONDEFAUT

Indicateur Impression par défaut lors de la création d'un produit fini

21 Indicateur (O ou N)

INDICATEURJONCTION

21,60 Code dimension spécifique permettant de positionner l'indicateur de jonction par défaut.

Exemple : INDICATEURJONCTION PJ

KSC_COMMENTAIRE_PF

21,26 Code complément de paramétrage pour la création automatique de note avec code utilisateur et date.

Doit correspondre à un code paramètre de type KSC.

Remarque : la note commençant par COMMENTAIRE présente sur le paramétrage de type KSC ne sera pas prise en compte dans l'utilisation courante. Le commentaire qui sera inséré dans les notes sera celui saisi dans l'écran de saisie des informations complémentaires PF (F22).

LARGEUR_CAMION

21,25 Largeur du camion pour le calcul du conditionnement, en millimètres (par défaut : 2400)

Si cette valeur est renseignée, elle écrase celle de la valeur numérique 1 du #CF LOG.

Cette note fait partie d'un ensemble de 3 notes :

LARGEUR_CAMION

LONGUEUR_CAMION

HAUTEUR_CAMION

LCT_PARAM_VISU_CDE

21,26 Type et code du paramètre de lancement de la visu de commande

Voir aussi la note _SUP_REQ_CD2_ALERTE

LIEN_MACHINE_PROFIL

Voir le paragraphe Contrôle des mini/maxi ouverture/poussée pour une pose sur la machine en bas de page.

LIEN_OUTIL_MACHINE

21,23 Code du lien (paramètre #LI), pour la relation entre les outillages et les machines (table liens_tables)

Voir aussi la note CTRL_OUTIL_MACHINE.

LISTE_TSC_COND

21,60 Chaîne de codes TSC (à la suite) relatifs au conditionnement.

(ne pas insérer d'espace entre les codes TSC)

Voir aussi l'option Oad.

LONGUEUR_CAMION

2125 Longueur du camion pour le calcul du conditionnement, en millimètres (pas de valeur par défaut)

Cette note fait partie d'un ensemble de 3 notes :

LARGEUR_CAMION

LONGUEUR_CAMION

HAUTEUR_CAMION

MAGASIN_USINE_DEF

21,23 Magasin usine par défaut

MAJDATEVALIDITE

Mode de mise à jour de la date de validité de l'offre lors de chaque calcul.

N Aucune mise à jour (valeur par défaut)

1 Mise à jour date de début de validité

2 ?

MDT_MAJ_INDICE_PF

21 Mise à jour par incrémentation automatique de l'indice PF (TSC 270 sur produit fini, zone F:char3_1)

A Incrémentation alphabétique

A -> B -> ... -> Z -> AA

AA -> AB -> ... -> AZ -> BA -> ... -> BZ -> CA -> ... -> ZZ -> AAA

AAA -> AAB -> ... -> AAZ -> ABA -> ... -> AZZ -> BAA -> ... -> ZZZ

Remarque : ZZZ est la valeur maximale. Une fois cette limite atteinte, l'incrémentation est désactivée.

N Incrémentation numérique

1 -> 2 -> ... -> 999

Remarque : *** apparaîtra s'il y a dépassement de capacité (Indice > 999)

[blanc] Aucune mise à jour

METHODE_CAL_DECHETS

21 Méthode de calcul de la valorisation des rachats de déchets

N Méthode par défaut (par défaut)

A Le calcul de la quantité de déchet se fait par la différence entre la surface en entrée onduleuse et la surface réelle

MINRECOUPERABAT

Paramétrage des mini de recoupe de rabat par profil de cannelure.

21,23 Profil cannelure

24,27 Mini de recoupe de rabat (mm)

Exemples

MINRECOUPERABAT E 5

MINRECOUPERABAT B 5

MINRECOUPERABAT K 9

MINRECOUPERABAT BAK 13

NOM_FIC_MODE_TRACE

21,60 Nom du fichier résultant du mode trace. Par défaut : recalcul_devis.tra

Pour le recalcul batch des devis - Option Ocb indispensable.

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions (paramétrage équivalent au -C)

Exemple : 3CLI2QA

Voir : Gestion des actions événements depuis le devis onduleur.

OBJET_DOCUMENT

21,23 Type de document (DEV)

25,60 Objet du document pour le fax/email

OPE_PALETTISATION

21,23 Code opération de palettisation

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

PREFIXE_CODE_COMPO

21,60 Préfixe ajouté automatiquement lors de la saisie d'un code composition

Sauf si l'on passe par la fonction de recherche F7.

Voir aussi la note SUFFIXE_CODE_COMPO

RACINE_FIXE_CRE_ART

21, 28 Racine fixe. SPECIFIQUE. voir A2[26] = R

REP_ETUDES_ARTIOS

21,60 Emplacement des études ARTIOS si différent de celui configuré dans le programme Windows Interface_ARTIOS.exe

Cette note n'est pas destinée à GENERO.

ROGNE_PAR_DEFAUT

21,23 Rogne par défaut

RUN_VISU_TARIF

21,26 Type et code du paramètre de lancement de la visualisation des tarifs

Exemple #VITAR

SOUS_FAM_INJECTION

21 à 23 Code sous famille de l'injection plastique.

Paramétrer un code sous-famille pour l'injection plastique (exemple INJ)

Dans le traitement du programme, si le code sous famille de la composition technique est identique au code paramétré alors le programme exécutera un traitement spécifique pour l'injection plastique.

SUFFIXE_CODE_COMPO

21,60 Suffixe ajouté automatiquement lors de la saisie d'un code composition

Sauf si l'on passe par la fonction de recherche F7.

Voir aussi la note PREFIXE_CODE_COMPO

_SUP_ORDER_BY_DEV

Complément de tri pour la recherche de devis

Si cette note n'est pas trouvée ici, elle est recherchée sur #CF DKP.

Les champs accessibles en complément sont :

kp_de_ndemcli Numéro de devis

kp_de_ldemcli Libellé interne du devis

kp_de_ccliliv Code client livré

kp_de_nrefembcli Référence client

kp_de_lrefembcli Libellé client

kp_de_qrefembdem Quantité

mp_qualite Code validité d'article

Exemple de tri par ordre de devis descendant

_SUP_ORDER_BY_DEV kp_de_ndemcli desc

_SUP_REQ_ACCESSOIRE

21,60 Complément de requête pour recherche des accessoires dont le poids et la surface doivent être intégrés dans les poids et surfaces de l'ensemble.

Exemple

"and n0_pcsant[1] = P"

Na pas fonfondre avec la noet _SUP_REQ_ACC dans le #CF DKP, qui concerne la recherche des accessoires dans la nomenclature des produits.

_SUP_REQ_CD2_ALERTE

21,60 Complément de requête sur la table cde2

Voir aussi la note LCT_PARAM_VISU_CDE

_SUP_REQ_COMPO

21,60 Complément de requête pour interrogation du code composition

Ex. : and mp_des matches "SIT*"

_SUP_REQ_COMPOSANTS

21,60 Complément de requête pour la recherche des composants à prendre en compte dans le calcul du prix de cession de l'article.

_SUP_REQ_DEVIS

21,60 Supplément de requête sur le devis (tables KP_offre ou KP_demcli)

Pour le recalcul batch des devis - Option Ocb indispensable.

_SUP_REQ_FEFCO

21, 60 Complément de requête sur la recherche des codes FEFCO

_SUP_REQ_MAT

21,60 Supplément de requête sur la table mat

Pour le recalcul batch des devis - Option Ocb indispensable.

_SUP_REQ_MAT_PLAQUE

21, 60 Supplément de requête pour la recherche des plaques

_SUP_REQ_MP_PARAM_22

21,60 Supplément de requête sur les tables cde1 et cde2

Exemple

and ec_tyc != "PRX"

_SUP_REQ_PF_ENS

21,60 Complément de sélection de recherche des produits composant l'ensemble

Ce complément de sélection entraîne également la vérification de la saisie du code article composant.

Ce complément de sélection est prioritaire et remplace celui de la note SUPREQPF du #CF DKP (il n'est pas complémentaire).

_SUP_REQ_QUA_CAR

21, 60 Supplément de requête pour limiter la recherche de la composition commerciale (F7) dans les écrans

030 (Architecture automatique)

035 (Architecture étudiée)

Attention, il existe aussi des notes SUPREQQUACAR (sans les caractères soulignés) dans :

#CF CAR

#CF DKP

#CF ODV

_SUP_REQ_RECH_DEVIS

21,60 Complément de requête sur la recherche du devis standard

Utilisable dans tous les modules utilisant la fonction kp_rec_kp_demcli : don, edon, voluedit_devis_ondu, v_don

Cette note ne s'appliquait qu'à la recherche par F7 d'un N° de devis; désormais, elle s'applique également au contrôle de saisie du N° de devis .

SUPREQSCHEMAPAL

21,60 Complément de sélection sur par02 concernant le schéma de palettisation

Voir Optimisation du conditionnement dans le devis onduleur

_SUP_SQL_CLIENT

21,60 Complément de sélection des clients autorisés pour la saisie des devis

Ce paramétrage est valable pour tous les modes de saisie des devis (saisies simplifiée, concepteur, papeterie et saisie normale).

_SUP_SQL_MAT_DN

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

21,60 Complément de sélection pour la recherche de composant à ajouter à la nomenclature.

Par défaut : Complément de sélection pour l'affichage de la nomenclature (où les zones commençant par n0_ sont remplacées par mp_). Voir note ci-dessous _SUP_SQL_NOM0_DN.

_SUP_SQL_NOM0_DN

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

21,60 Complément de sélection pour l'affichage de la nomenclature.

Ce complément permet de limiter les composants devant apparaître dans l'arbre de nomenclature.

_SUP_SQL_NUM_DEMCLI

21,60 Complément de sélection pour la recherche des numéros de demandes client

Ce paramétrage est valable pour tous les modes de saisie des devis (saisies simplifiée, concepteur, papeterie et saisie normale)

SURFACEMINI

21,30 Surface mini en M2 de l'ensemble.

Si la surface devisée est inférieure à cette surface mini, le deviseur en est averti.

_TIT_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_DOCUMENT

21,23 Type de document (DEV)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TITRE_F_S3VAL2D

Titre de la fenêtre de saisie des dimensions de la palettisation (dans la détermination du conditionnement)

TOL_UNI_COUPE

21, 25 Tolérance unitaire de la coupe. Utilisée pour la tolérance des plaques

TOL_UNI_LAIZE

21, 25 Tolérance unitaire de la laize. Utilisée pour la tolérance des plaques

TSC_CTRL_SUPP_OFFRE

Paramétrer les TSC à contrôler pour la suppression des offres incompatibles avec celle retenue

21 Type d'article des TSC à contrôler

X Produit fini

A Référence d'architecture

I Référence d'impression

P Référence de pré-impression

Q Qualité carton

C Composition carton

Y Palette

Z Coiffe

22,24 Code TSC à contrôler

25 Zone TSC à contrôler

TSC_MODIF_POINTAGES

21,23 Code TSC sur produit architecture utilisé pour définir si un pointage a été modifié manuellement par l'utilisateur (MPT par défaut) L'option Ocr doit être activée

Principe de création & suppression du TSC

1) Si un pointage est modifié (écran de saisie des pointages : 040), la zone alphanumérique 3/1 (ic_char3_1) sera mise à jour avec la valeur O

2) Après confirmation de recalcul des pointages, le TSC est supprimé

TYPENOTEERREUR

21,23 Type de note pour collecter les erreurs lors de la recherche de gamme

TYPE_NTS_TRIPLET

21,60 Types de notes du triplet dans la gamme

(longueur code)(code)(longueur code)(code) etc.

Exemple : 3MES3ABF

Nota : cette note est cumulative.

Infos

UNITE_TARIF_TRANSP

21,22 Code unité des tarifs

ML Restriction aux tarifs de type mètre linéaire (seul code disponible au 27/07/2005)

VALIDITEARTICLE

21,60 Code validité article pour la création des articles par l'offre de vente.

Egalement utilisé pour le contrôle de modification des articles.

Le code paramètre n'est pas contrôlé.

Exemple : VALIDITEARTICLE DEV

VALIDITEENSPASOK

21,60 Code validité ensemble si tous les PF n'ont pas le même code validité.

Exemple : VALIDITEENSPASOK FNV

VALIDITEFAB

21,60 Code validité article pour la création des articles par l'offre de vente de FAB

Egalement utilisé pour le contrôle de modification des articles.

Le code paramètre n'est pas contrôlé.

Exemple : VALIDITEFAB FAB

VALIDITES_NOM_FAB

Codes validité d'articles autorisés pour le passage en FAB, séparés par une virgule

Exemple : FAB,REE

Si les codes sont saisis sur plusieurs lignes, les lignes (exceptée la dernière) doivent se terminer par une virgule.

Exemple :

FAB,

REE

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

Codes calcul des valeurs des dépendances, triés par ordre alphabétique

Pour chaque code, la valorisation se fait pour la GAMME et / ou pour le SERVICE. Cette mention est indiquée dans la 2ème colonne (G/S).

Si le S (Service) est en minuscules, il y a des conditions. Voir dans le paramétrage.

CB

G

Coupe brute onduleuse (en mm)

Pas de paramétrage

CG

G

Récupération du coefficient géométrique dans les notes

Voir les notes COEFF_GEOMETRIE du #CF DKP

CL

G

Chute de laize

Pas de paramétrage

CO

G

Présence d'un consommable générique

Caractères 1 à 3 : Type de consommable générique

CT

G

Constante paramétrée

Caractères 1 à 7 : Valeur de la constante retournée

Cette constante peut être numérique ou alpha.

Exemple :

O pour toujours retourner O

N pour toujours retourner N

DC

G

Calcul d'une dimension calculée

Caractères 1 à 3 : Code dimension calculée à calculer

DD

Différence en valeur absolue entre la longueur et la largeur

Pas de paramétrage

DS

G

Recherche de la valeur d'une dimension spécifique

Caractères 1 à 3 : Code de la dimension spécifique à chercher

DT

G

Donnée technique - TSC 510 du triplet calculé en dynamique (Ouverture, Poussée, Nombre de poses, Surface)

Caractères 1 à 3 : Code valeur à renvoyer

POU Poussée en mm

OUV Ouverture en mm

POS Nombre de poses

SUR Surface en m2

EM

Code environnement matière

Pas de paramétrage

LB

G

Laize brute onduleuse

Pas de paramétrage

LC

G

Rapport Coupe / Laize

Pas de paramétrage

LO

G

Laize optimale onduleuse

Pas de paramétrage

MD

G/S

Magasin de départ

N0

G

Présence d'un composant particulier dans la nomenclature

Caractère 1 : nomenclature de quel article

Q Composition commerciale

C Composition technique

A Référence d'architecture

I Référence d'impression

P Référence de pré-impression

X Produit fini

Caractères 2 à 7 : Chaîne de caractères débutant le code du composant

OI

G

Recherche d'une valeur dans les contraintes d'impression. Plusieurs paramétrages :

Nombre de fois où une contrainte d'impression apparaît.

Retour : Valeur numérique

Exemple : Nombre de changements de teinte-cliché

Caractère 1 à 2 : NC ( Nombre Code)

Caractères 3 à 5 : Code contrainte d'impression à rechercher

Présence d'un code contrainte d'impression ?

Retour : O/N

Caractères 1 à 2 : PC ( Présence Code)

Caractères 3 à 5 : Code contrainte d'impression à rechercher

Présence d'au moins un code d'une famille de contrainte d'impression ?

On définit la famille de contrainte d'impression par .CI A2[1,3].

Retour : O/N

Exemple : T-C : Teinte - Cliché

Caractères 1 à 2 : PF ( Présence Famille)

Caractères 3 à 5 : Famille contrainte d'impression à rechercher

Somme des valeurs numériques 2 de tous les codes appartenant à une famille d'option d'impression

On définit la famille de contrainte d'impression par .CI A2[1,3].

Retour : 0, 1, 2, 3, 4, 5, etc...

Exemple : FLX (Fléxo)

Caractères 1 à 2 : S2 ( Nombre de couleurs)

Caractères 3 à 5 : Famille contrainte d'impression à rechercher

Le premier code trouvé appartenant à une famille de contrainte d'impression.

La recherche s'effectue dans un ordre croissant sur la valeur numérique 1 de la fiche paramètre contrainte d'impression (Type paramètre .CI).

On définit la famille de contrainte d'impression par .CI A2[1,3].

Retour : Un code contrainte d'impression

Exemple : T-C : Teinte - Cliché

Caractères 1 à 2 : CF ( Code Famille )

Caractères 3 à 5 : Famille contrainte d'impression dans laquelle on doit rechercher

Caractère 6 [à blanc] : Si pas trouvé : Retour N

0 : Si pas trouvé : Retour 0-0

OO

G

Option onduleuse - Plusieurs paramétrages :

Somme des Valeurs numériques saisies sur code option onduleuse

Retour : Valeur numérique

Caractères 1 à 2 : VN ( Valeur numérique)

Caractères 3 à 5 : Code option onduleuse à rechercher

Nombre de fois ou une option onduleuse apparaît.

Retour : Valeur numérique

Exemple : Nombre de bandes d'arrachage ou Nombre de bandes de renfort

Caractères 1 à 2 : NC (Nombre Code)

Caractères 3 à 5 : Code option onduleuse à rechercher

Présence d'un code option onduleuse ?

Retour : O/N

Caractères 1 à 2 : PC (Présence Code)

Caractères 3 à 5 : Code option onduleuse à rechercher

Présence d'au moins un code d'une famille d'option onduleuse ?

On définit la famille d'option onduleuse par .OO A2[1,3]

Retour : O/N

Exemple : TSU : Traitement de Surface

Caractères 1 à 2 : PF (Présence Famille)

Caractères 3 à 5 : Famille option onduleuse a rechercher

Le premier code trouvé appartenant a une famille d'option onduleuse.

La recherche s'effectue dans un ordre croissant sur la valeur numérique 1 de la fiche paramètre options onduleuse (Type paramètre .OO).

Exemple : Trouver le type de traitement de surface utilisé.

En principe il n'y en a qu'un.

On définit la famille d'option onduleuse par .OO A2[1,3]

Exemple : TSU : Traitement de Surface

Retour : Un code d'option onduleuse

Caractères 1 à 2 : CF (Code Famille)

Caractères 3 à 5 : Famille option onduleuse dans laquelle on doit rechercher.

OP

G

Option de palettisation - Plusieurs paramétrages :

Nombre de fois où une option palettisation apparaît.

Retour : Valeur numérique

Caractères 1 à 2 : NC (Nombre Code)

Caractères 3 à 5 : Code option palettisation à rechercher

Présence d'un code option palettisation ?

Retour : O/N

Caractères 1 à 2 : PC (Présence Code)

Caractères 3 à 5 : Code option palettisation à rechercher

Présence d'au moins un code d'une famille d'option palettisation ?

On définit la famille d'option palettisation par .PP A2[1,3].

Retour : O/N

Exemple : FIL : Présence Film

Caractères 1 à 2 : PF ( Présence Famille )

Caractères 3 à 5 : Famille option palettisation à rechercher

Le premier code trouvé appartenant a une famille d'option palette.

La recherche s'effectue dans un ordre croissant sur la valeur numérique 1 de la fiche paramètre option palette (Type paramètre .PP).

On définit la famille d'option palettisation par .PP A2[1,3].

Retour : Un code d'option palette

Caractères 1 à 2 : CF (Code Famille)

Caractères 3 à 5 : Famille option palette dans laquelle on doit rechercher.

PC

G/S

Poids du PF pour la quantité dans la commande

Pas de paramétrage

PP

G

Présence pré-print

Pas de paramétrage

QR

G/S

Quantité roulée (Quantité sortie exprimée dans l'unité compatible avec la cadence)

Pas de paramétrage

QS

G

Quantité par série

Pas de paramétrage

RE

Mode de réapprovisionnement (Synchrone/Asynchrone)

Pour les articles cartonniers : toujours synchrone

Pour les autres articles : voir le paramétrage du code réapprovisionnement (REA)

RF

G

Regroupement FEFCO

Voir TSC 030 zone ic_char30

RP

Représentant

Caractère 1 : choix de la zone alpha (1 à 4)

Caractères 2 à 3 : début de la zone à récupérer

Caractères 4 à 5 : fin de la zone à récupérer

Exemple : RP42325 : notion d'agent externe/interne, stockée en REP A4[23,25]

SC

G

Structure carton

Retour : La structure de carton (SF, DF, DD ou TC) telle qu'elle est saisie sur le profil carton.

On recherche le code profil carton dans le TSC 310 ic_char3_1.

Avec ce code, on recherche la structure carton dans PC A1[1,3].

L'existence de la structure carton est vérifiée dans le paramètre STC.

N si anomalie quelconque

Pas de paramétrage

ST

Surface totale du PF

La surface unitaire nette est dans le TSC 202.

SU

G

Surface unitaire brute ou nette onduleuse

Caractère 1 : Surface brute ou nette

B brute

N nette (non géré)

Caractère 2 : La surface est exprimée en

M millimètres carrés

[espace] mètres carrés

TJ

G

Type de jonction

Renvoit la famille de jonction (voir .JE). Si pas de jonction, renvoitSAN.

Le code jonction est stocké dans le TSC 050, zone ic_char3_1.

TS

G/s

TSC direct d'une référence

Si Car.1 à 5 = I110C et que le nombre de couleurs a été forcé dans le TSC 51B du triplet, alors le code calcul se base sur Car.1 à 5 = T51BC.

Caractère 1 : TSC de quel article

A Référence d'architecture

C Composition technique

I Référence d'impression

M Machine saisie sur la gamme

P Référence de pré-impression

Q Composition commerciale

T Triplet article/gamme/phase

X Produit fini (seul cas pour la valorisation Service)

Y Palette

Z Coiffe

Caractères 2 à 4 : TSC

ATTENTION : Ne pas utiliser pour les données (article/gamme/phase). TSC 510.

Les données du TSC 510 sont créées après la valorisation de la gamme.

Caractère 5 : Code de la zone de stockage

Caractère 6 : Dépendance obligatoire Oui/Non

VC

S

Recherche d'une valeur d'une caractéristique d'action de service

Caractères 1 à 3 : Code de la caractéristique à chercher

VF

VG

VH

G

G

G

Existence d'une occurrence paramétrée dans la première valeur alpha d'un TSC

Existence d'une occurrence paramétrée dans la deuxième valeur alpha d'un TSC

Existence d'une occurrence paramétrée dans la troisième valeur alpha d'un TSC

Caractère 1 : TSC de quel article

A Référence d'architecture

C Composition technique

I Référence d'impression

M Machine saisie sur la gamme

P Référence de pré-impression

Q Composition commerciale

T Triplet article/gamme/phase

X Produit fini (seul cas pour la valorisation Service)

Y Palette

Z Coiffe

Caractères 2 à 4 : TSC

Caractères 5 à 7 : Occurrence recherchée

ZO

G/s

Accès à des zones de la base de données - Plusieurs paramétrages :

Caractère 1 = A : Accès à la table article (mat)

Caractère 2 : De quel article s'agit-il ?

A Architecture

C Composition technique

F Forme de découpe

I Impression

P Pré-impression

Q Composition commerciale (Valorisation Service)

R Référence d'emballage (ensemble)

X Produit fini (Valorisation Service)

Y Palette

Z Coiffe

Caractères 3 à 6 : De quelle zone s'agit-il ?

Zones alphanumériques

CODE Code article

FAM Famille (mp_fam)

SFM Sous-famille (mp_sfm)

LIBR Catégorie (mp_libre)

COUL Couleur (mp_coul)

MP22 Gestion des appairages

Zones numériques

DT1 Donnée technique 1 (mp_dt1)

DT2 Donnée technique 2 (mp_dt2)

DT3 Donnée technique 3 (mp_dt3) - Gâche fixe

DT4 Donnée technique 4 (mp_dt4) - Gâche variable

DT5 Donnée technique 5 (mp_dt5)

DT6 Donnée technique 6 (mp_dt6)

DT7 Donnée technique 7 (mp_dt7)

DT8 Donnée technique 8 (mp_dt8)

HAU Hauteur (mp_hau)

LON Longueur (mp_lon)

LAR Largeur (mp_lar)

POID Poids unitaire (mp_poids)

TAR0 Tarif en vigueur (issu du fichier tarif)

Caractère 1 = C : Accès à la table client (cli) ou adresse secondaire (cli2)

Caractère 2 : [Espace]

Caractères 3 à 6 : De quelle zone s'agit-il ?

Zones alphanumériques

CODE Code client (cl_code)

CODP Code postal (cl_codp ou c2_codp)

CODC Code postal client (cl_codp)

VIL Ville (cl_vil ou c2_vil)

VILC Ville (cl_vil)

PAY Code pays (cl_pays ou c2_pays)

PAYC Code pays (cl_pays)

LANG Code langue (cl_langue ou c2_langue)

LANC Code langue (cl_langue)

DEV Code devise (cl_dev ou c2_devise)

DEVC Code devise (cl_dev)

GEO Code secteur géographique (cl_geo)

GEOC Code secteur géographique (cl_geo ou c2_geo)

CAT Code catégorie (cl_cat)

ACT Code activité (cl_act)

ORIG Code origine contact (cl_orig)

MRG Code Mode de règlement (cl_mrg ou c2_mrg)

MRGC Code Mode de règlement (cl_mrg)

ECH Code échéance (cl_ech ou c2_mrg)

ECHC Code échéance (cl_ech)

REPR Code représentant (cl_repr)

QUAL Code qualité client (cl_qualite)

TRAN Code transporteur (cl_transp ou c2_transp)

TRAC Code transporteur (cl_transp)

ZPAR Zone paramétrée (cl_zpar)

TLIV code tournée de livraison (c2_tournee_liv ou cl_tournee_liv)

Zones numériques

DELC Délai de consignation (cl_delai_consigne)

REML Pourcentage de remise ligne (cl_reml)

REMG Pourcentage de remise globale (cl_remg)

ESC Taux d'escompte (cl_esc)

ZPAN Distance avec le client (cl_zparnum ou c2_zparnum)

ZPAC Distance avec le client (cl_zparnum)

Caractère 1 = F : Accès à la table FEFCO (ecma)

Caractère 2 : De quel FEFCO s'agit-il ?

U FEFCO dessus

O FEFCO dessous

ATTENTION : Si cette dépendance est utilisé pour un coût supplémentaire associé a un PF, le caractère 2 doit être défini en minuscule.

Caractères 3 à 6 : De quelle zone s'agit-il ?

Zones alphanumériques

TYPE Type de FEFCO (kma_type)

Zones numériques

NMOR Nombre de morceaux (kma_type)

Caractère 7 :

0 : Si zone non remplie : retour numérique : 0 ou retour alpha : N

O : Si zone non remplie : retour numérique : -888 ou retour alpha : ###

Quantités en entrée des actions de service

AX

A% X + B

Caractères 1 à 3 : caractéristique donnant la valeur de A

Caractères 4 à 6 : caractéristique donnant la valeur de X

Caractères 7 à 9 : caractéristique donnant la valeur de B

Exemple

Couverture de frais

2% du prix du PF + 150 F

CC

Calcul sur 2 caractéristiques d'une action de service

Caractères 1 à 3 : Code de la première caractéristique à chercher

Caractères 4 à 4 : Opérateur

+ Addition

- Soustraction

* Multiplication

/ Division

Caractères 5 à 7 : Code de la deuxième caractéristique à chercher

Exemple

Stocker. Nombre de palettes * Durée en mois (NPA * DUR)

où NPA = code caractéristique donnant le nombre de palettes

et DUR = code caractéristique donnant la durée de stockage.

Exemple

Consommer outil.

Quantité en entrée = montant / quantité d'amortissement

CP

Valeur d'une caractéristique calculé avec la valeur numérique 1 d'un paramètre)

Caractères 1 à 3 : Code caractéristique donnant la valeur de la première caractéristique

Caractères 4 à 6 : caractéristique donnant le code du paramètre

Caractères 7 à 9 : Type du paramètre à rechercher

Caractères 10 à 10 : Opérateur

+ Addition

- Soustraction

* Multiplication

/ Division

CQ

Calcul sur 2 caractéristiques d'une action de service et multiplication par la quantité de PF ou de palettes ou d'UC (unités de conditionnement)

Caractères 1 à 3 : Code de la première caractéristique à chercher

Caractères 4 à 4 : Opérateur

+ Addition

- Soustraction

* Multiplication

/ Division

Caractères 5 à 7 : Code de la deuxième caractéristique à chercher

Caractères 8 à 8 : Multiplicateur

X : Coef. nomenclature REF/PF (par défaut)

Y : Coef. nomenclature PF/Palette

Z : 1 / Nombre d'unités de conditionnement

Caractère 9 : D pour la quantité demandée

L pour la quantité de livraison

Exemple

Pré-imprimer

Quantité en entrée = montant de la sous-traitance / quantité d'amortissement X quantité de PF.

Exemple

Stocker

Quantité en entrée = Prix (par mois/palette) X durée stockage X nombre de palettes / nombre d'unités de conditionnement

CT

Coût transport

Pour l'intégration du calcul des tarifs transporteurs dans le devis

Caractères 1 à 3 : caractéristique donnant la distance kilométrique

Caractères 4 à 6 : caractéristique donnant le type de transport

Caractères 7 à 9 : caractéristique donnant le type de véhicule

Caractère 10 : D pour la quantité demandée

L pour la quantité de livraison

FI

Valeur d'une caractéristique multipliée par la valeur alpha3[1,4] d un paramètre divisée par 30

Caractères 1 à 3 : Code caractéristique donnant la valeur de la première caractéristique

Caractères 4 à 6 : caractéristique donnant le code du paramètre

Caractères 7 à 9 : Type du paramètre à rechercher

Exemple

Financer

Quantité en entrée = prix de revient (caractéristique PR) X nombre de jours du financement (ECH A3[1,4]).

VC

Valeur numérique d'une caractéristique d'une action de service

Caractères 1 à 3 : Code de la caractéristique à chercher

Exemple

Toutes les actions de service pour lesquelles la quantité est égale à une des caractéristiques.

VT

Volume transporté

Caractères 1 à 4 : Hauteur maxi du camion en mm (Par ex. 2500)

Caractères 5 à 7 : Code caractéristique donnant la hauteur de la palette.

Caractères 8 à 10: Code caractéristique donnant le nombre de palettes

Contrôle des mini/maxi ouverture/poussée pour une pose sur la machine

Permet de paramétrer les valeurs mini/maxi travers (ouverture) et machine (poussée) par machine et par profil pour exactement une pose.

Permet de paramétrer les valeurs mini/maxi travers et machine par machine pour exactement une pose.

Cliquez ici pour afficher / masquer une copie d'écran.

Remarques

" La saisie des valeurs mini/maxi pour un couple machine/profil cannelure se fera par la saisie des liens entre les tables (avec détail) :

o Les valeurs mini/maxi dans le sens travers pour une pose ou plus (contrôle machine 001) seront saisies respectivement dans les zones numériques 1 et 2 du détail.

o Les valeurs mini/maxi dans le sens travers pour exactement une pose (contrôle machine 001) seront saisies respectivement dans les zones numériques 5 et 6 du détail.

o Les valeurs mini/maxi dans le sens machine pour une pose ou plus (contrôle machine 001) seront saisies respectivement dans les zones numériques 3 et 4 du détail.

o Les valeurs mini/maxi dans le sens machine pour exactement une pose (contrôle machine 001) seront saisies respectivement dans les zones numériques 7 et 8 du détail.

" La saisie des valeurs mini/maxi par défaut pour une machine et exactement une pose se fera dans les informations complémentaires (TSC) sur la machine :

o Les valeurs mini/maxi dans le sens travers (contrôle machine 001) seront saisies respectivement dans les zones numériques 1 et 2 du TSC ST1.

o Les valeurs mini/maxi dans le sens machine pour exactement une pose (contrôle machine 002) seront saisies respectivement dans les zones numériques 1 et 2 du TSC SM1.

" Exemples de paramétrages fournis :

o Annexe 1 : Lien entre les machines (mac0) et les profils carton (PC)

o Annexe 2 : Information complémentaire de saisie des valeurs mini/maxi par défaut dans les sens travers / machine pour exactement une pose sur la machine (TSC ST1 & SM1)

IMPORTANT : Le principe de récupération des valeurs mini/maxi fonctionne dans l'ordre suivant :

Si le nombre de poses sur la machine est égal à 1 :

1. Couple machine/profil cannelure, zones numériques 5, 6, 7 ou 8

2. TSC ST1/SM1 sur la machine

3. Couple machine/profil cannelure, zones numériques 1, 2, 3 ou 4

4. Machine

Si le nombre de poses sur la machine est supérieur à 1 :

1. Couple machine/profil cannelure, zones numériques 1, 2, 3 ou 4

2. Machine

Paramétrage

devis onduleur (ici) note LIEN_MACHINE_PROFIL | 21,23 Code lien (#LI) entre la table machine et la table des paramètres (de type PC : profil carton). Par défaut : on prend le code lien renseigné sur le type de machine contrôlée (TMC).
machine, option Otl | Saisie des liens entre tables
machine, note CODE_LIEN_TABLES | 21,23 Code de lien entre tables par défaut pour ce type de machine. Remarque : ce code paramètre est pris par défaut pour les contrôles machines 001 et 002 (si aucun code n'est renseigné sur le paramètre de lancement du devis)
TMC, note CODE_LIEN_TABLES | 21,23 Code de lien entre tables par défaut pour ce type de machine. Remarque : ce code paramètre est pris par défaut pour les contrôles machines 001 et 002 (si aucun code n'est renseigné sur le paramètre de lancement du devis)

ANNEXES - Paramètre nécessaire à mettre en place

[ANNEXE 1] #LI Lien entre les machines et les profils (type paramètre PC)

#LI A1[4] = O (oui) | La saisie du détail est possible.
#LI A1[5] = O (oui) | Le lien est pris en compte lors de la recopie de machine.
#LI A2[1,60] = Liens entre MACHINES et PROFILS CANNELURE |
#LI A3[1,18] = mac0 | Table mère : machines
#LI A4[1,18] = par02 | Table fille : paramètres
#LI A4[19,21] = PC | Type de paramètre : Profil carton
#LI note TITRE_SAI_CODE_PERE = Machine |
#LI note TITRE_SAI_LIB_PERE = Désignation |
#LI note TITRE_SAI_CODE_FILS = Profil carton |
#LI note TITRE_SAI_LIB_FILS = Libellé |
#LI note LIBELLE_NUM1 = Mini (travers) >= 1 pose | Valeur minimum dans le sens ouverture pour le contrôle machine 001, pour une pose ou plus. Correspond au sens travers dans la saisie des machines
#LI note LIBELLE_NUM2 = Maxi (travers) >= 1 pose | Valeur maximum dans le sens ouverture pour le contrôle machine 001, pour une pose ou plus. Correspond au sens travers dans la saisie des machines
#LI note LIBELLE_NUM3 = Mini (machine) >= 1 pose | Valeur minimum dans le sens poussée pour le contrôle machine 002, pour une pose ou plus. Correspond au sens machine dans la saisie des machines
#LI note LIBELLE_NUM4 = Maxi (machine) >= 1 pose | Valeur maximum dans le sens poussée pour le contrôle machine 002, pour une pose ou plus. Correspond au sens machine dans la saisie des machines
#LI note LIBELLE_NUM5 = Mini (travers) = 1 pose | Valeur minimum dans le sens ouverture pour le contrôle machine 001, pour exactement une pose. Correspond au sens travers dans la saisie des machines
#LI note LIBELLE_NUM6 = Maxi (travers) = 1 pose | Valeur maximum dans le sens ouverture pour le contrôle machine 001, pour exactement une pose. Correspond au sens travers dans la saisie des machines
#LI note LIBELLE_NUM7 = Mini (machine) = 1 pose | Valeur minimum dans le sens poussée pour le contrôle machine 002, pour exactement une pose. Correspond au sens machine dans la saisie des machines
#LI note LIBELLE_NUM8 = Maxi (machine) = 1 pose | Valeur maximum dans le sens poussée pour le contrôle machine 002, pour exactement une pose. Correspond au sens machine dans la saisie des machines

[ANNEXE 2] Information complémentaire (TSC) pour la saisie des valeurs mini/maxi par défaut dans le sens travers

Caractère 1 = Z (notes commençant par Z)

Car. | TSC ST1 - Mini/Maxi Sens Tra. 1 pos |  | TSC SM1 - Mini/Maxi Sens Mac. 1 pos
 | Car.2 = C (Val. numérique 1) | Car.2 = D (Val. numérique 2) | Car.2 = C (Val. numérique 1) | Car.2 = D (Val. numérique 2)
3,17 | Mini (tra.) : Valeur minimum ... | Maxi (tra.) : Valeur maximum ... | Mini (mac.) : Valeur minimum ... | Maxi (mac.) : Valeur maximum ...
 | ...dans le sens ouverture pour le contrôle machine 001, pour exactement une pose. Correspond au sens travers dans la saisie des machines. |  | ...dans le sens poussée pour le contrôle machine 002, pour exactement une pose. Correspond au sens machine dans la saisie des machines.
18 | N (pas de contrôle)
19,23 | inutilisé
24 | Z (zone affichée)
25,41 | inutilisé
42,56 | MINI (TRA.) : | MAXI (TRA.) : | MINI (MAC.) : | MAXI (MAC.) :
57,59 | inutilisé

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Options Odn et Ovn

Notes

_SUP_SQL_NOM0_DN

_SUP_SQL_MAT_DN

DN_PAR_LCT_

DN_INFO*

Exemple de paramétrage

Soit les lignes de notes suivantes sur le paramètre de lancement de la saisie de la nomenclature du devis onduleur :

Car. 1 à 20 Car. 21 à 26 Explication

DN_PAR_LCT_A:A #SASDS | Utiliser le paramètre de lancement #SA/SDS pour les composants utilisant une architecture automatique
DN_PAR_LCT_A:E #SASDE | Utiliser le paramètre de lancement #SA/SDE pour les composants utilisant une architecture étudiée
DN_PAR_LCT_A:D #SADEV | Utiliser le paramètre de lancement #SA/DEV pour les composants utilisant une architecture indéfinie
DN_PAR_LCT_T:K #SADEV | Utiliser le paramètre de lancement #SA/DEV pour les composants de type Kit (mat.mp_mp = K)
DN_PAR_LCT_F:OUT #SAOUT | Utiliser le paramètre de lancement #SA/OUT pour les composants dont le code famille est OUT
DN_PAR_LCT_D #SAPRO | Utiliser le paramètre de lancement #SA/PRO par défaut

Dans l'exemple ci-dessus, l'ordre de recherche des paramètres de lancement sera le suivant :

1. Famille : OUT

2. Type d'article : Kit

3. Type d'architecture : A/E

4. Défaut

Ainsi :

Si le code famille de l'article sélectionné est OUT, alors on utilise le paramètre de lancement #SA/OUT.

Sinon : Si le type de l'article sélectionné est K (Kit), alors on utilise le paramètre de lancement #SA/DEV.

Sinon : Si le type d'architecture de l'article sélectionné est A, alors on utilise le paramètre de lancement #SA/SDS.

Sinon : Si le type d'architecture de l'article sélectionné est E, alors on utilise le paramètre de lancement #SA/SDE.

Sinon : On utilise le paramètre de lancement #SA/PRO.

Remarque : Le type d'architecture D (Automatique/Etudié) est utilisé uniquement lors de l'ajout d'un composant à la nomenclature.

Cette valeur permet par exemple de créer un composant via la saisie des devis normale plutôt que par la saisie simplifiée (Architecture automatique) ou concepteur (Architecture étudiée). Voir exemple ci-dessous.


Devis onduleur

Dans la recopie du sous-devis, si l'opérateur répond OUI à la question Conserver la désignation du sous-devis source, les désignations de l'ensemble (Produit commençant par E) et du produit fini (Produit commençant par P) sont initialisées avec la désignation de l'ensemble et du produit fini source.

Si l'opérateur répond NON, elles sont initialisés avec le libellé de l'entête du devis.

Les libellés du libellé étranger sont initialisés avec les libellés de l'entête du devis.

Les 2 caractères de cette note permettent d'initialiser la désignation de l'ensemble et du produit fini avec la désignation de l'ensemble et du produit fini source dans le cas où l'opérateur a répondu NON à la question.

Les libellés du libellé étranger sont initialisés avec ceux de l'ensemble et du produit fini source.

Devis onduleur devis_ondu

Voir les TSC pointages refouleurs

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action: Recalcul Caractères 3 et suivants : numéro de devis Exemple : -N[XXX]
-n | Action : consultation du devis Caractères 3 et suivants : numéro de devis-numéro de sous-devis Exemple : -n[lc_dev|-|lc_sdev+<<&]
-nd | Action : consultation du sous-devis Caractères 3 et suivants : numéro de devis-numéro de sous-devis Exemple : -nd[lc_dev|-|lc_sdev+<<&]

Options triées

Oaf

Pas de mise à jour famille / sous-famille en automatique si celles-ci sont déjà saisies.

Pour l'ensemble, l'option -Ogf ne doit pas être activée.

Oam

Gestion des autorisation de modification (interdiction de modifier un composant si devis non créateur du composant)

Ocb

Lancement du traitement de recalcul batch

Ocd

Dans le conditionnement, recherche d'un code cerclage par défaut selon le triplet

schéma de palettisation

code famille

code sous-famille

Oce

Désactivation du contrôle mode expert mais on garde la gestion

Oco

Consultation

Ocs

Saisie de notes de traçage sur les coûts supplémentaires

Oct

Autorise la saisie des changements de tarif

Inhibe la mise à jour des dates des tarifs dans le re-calcul batch.

Dans l'écran des réponses client du devis, dans le tableau des tarifs, on peut prévoir les changements de tarifs.

Pour ce faire, on saisit la date de changement et le tarif qui devra être appliqué à partir de cette date.

La date de changement doit être strictement supérieure à la date de début de validité du devis et strictement inférieure à la date de fin de validité du devis.

On ne peut saisir le tarif à appliquer que si la date de changement est saisie.

Si la date de changement est saisie, le nouveau tarif doit aussi l'être.

Oda

Remise à zéro du code jonction dans le cadre de la détection de la double-jonction.

Passage en automatique en double - jonction sans demande de confirmation.

Nécessite des notes de type JONCTION_AUTORIS_DJ

Ode

Debug écran

Odf

Debug fichier

Odr

Mettre à jour la date de réponse client avec la date du jour lors de la modification des prix de vente

Ods

Saisie des devis onduleurs simplifiés - Option PRO 11 nécessaire

Oex

Mode expert pour les contrôles de possibilités machine. Voir TSC 320

Ogf

Saisie manuelle des codes familles et sous-familles sur l'écran offre

Oip

Initialisation des prix remis, sinon valeur nulle

Ole

Mise à jour de la table lib_etr pour le sous-devis 99

Oms

Initialisation affichage des messages

Omw

Affichage des messages en Warning lors des contrôles machines

Onc

Saisie de la concurrence par offre nc pour niveau de concurrence

Onp

On ne recalcule pas le nombre de pose principalement pour le recalcul batch du devis

Oog

Pilotage de la quantité de l'offre via l'écran des gammes

Stockage de la quantité de base de l'offre (ic_num1) et de la quantité de palettes complètes de l'offre (ic_num2) dans le TSC QPC de l'ensemble de l'offre (Type de clé = A)

L'option Oog est incompatible avec l'option Opc.

Op2

Palettisation des ensembles montés – fenêtre identique à celle des composants

Opc

Calcul de la quantité de palettes complètes de l'offre sans mise à jour de la quantité de l'offre

Stockage de la quantité de base de l'offre (ic_num1) et de la quantité de palettes complètes de l'offre (ic_num2) dans le TSC QPC de l'ensemble de l'offre (Type de clé = A)

L'option -Opc est incompatible avec l'option Oog.

Ope

Palettisation des ensembles montés

Opp

En mode expert permettre d'accéder par l'écran de navigation au mode pre-print

Ora

Possibilité de saisir les prix dans l'écran récapitulatif

Orc

La référence de l'entête du devis est recopiée dans la référence emballage client

Ore

Recalcul batch du devis avant édition

Org

Initialisation recherche gamme systématique

Orp

Demande du recalcul de la largeur de patte si changement de celle-ci

Orr

Activation de la RAZ du prix remis lors de la RAZ de la gamme

Oso

En saisie d'accord d'une offre on propose la suppression des offres incompatibles

Ot1

Génération des tarifs (F13 sur le 1er écran) avec la quantité de palettes complètes au lieu de la quantité de base de l'offre

Celle-ci est stockée dans le ic_num2 du TSC QPC de l'ensemble de l'offre (Type de clé = A).

Cette option doit être accompagnée de l'option Oog ou de l'option Opc.

Ota

Active la traçabilité automatique de la table info_c

Ote

Test devis

Otm

Activation de la traçabilité sur le devis onduleur.

Nécessite la mise en place de l'option payante générale sur la traçabilité de la table mat.

(option BAS 10)

Otv

Mise à jour des tarifs sur les variantes d'impression

Ova

Validation automatique de la fenêtre de gestion de fax/email

Ovq

Initialisation variante quantité à partir des sous-devis

Ovt

Force la date de fin de validité des tarifs créés au 31/12/2100. Existe aussi dans v_odv

Owg

Affichage des messages Warning sur la gamme retenue

Oxm

Ecran de saisie fax/email

Valeur alpha 2

Caractères 1 à 3 | Environnement de valorisation
Caractères 5 à 10 | Type et code du paramètre de lancement de l'édition
Caractères 11 à 16 | Type et code du paramètre de lancement de l'édition de la nomenclature
Caractères 17 à 22 | Type et code du paramètre de lancement de la visu des nomenclatures
Caractères 23 à 28 | Type et code du paramètre de lancement de la saisie tarif

Valeur alpha 3

Caractères 1 à 6 | Type et code du paramètre de lancement pour actualisation des variantes d'impression
Caractère 7 | Paramétrage d'attribution des racines pour la création des offres de ventes 1 Méthode 1 : Code basé sur le code client + 1 chrono. EXXXXXYYY XXXXX Code client sur 5 caractères YYY Chrono 000 à 999, A00 à A99, B00 à B99, etc. 2 Méthode 2. EXYYYYY X Code du service ( saisi ) YYYYY Chrono 00000 à 99999 attribué en auto si non saisi
Caractère 8 | Historiser les solutions de palettisation (O/N, N par défaut)
Caractère 9 | Lors du passage du devis en fabrication, la zone référence devis (od_de_lvotrefdev) est mise à jour avec la référence de l'ensemble.

Notes triées

ACCES_AUTO_ECRAN_PTG

21 Accès automatique à l'écran des pointages (O/N)

CONTROLE_ECART_CDT

Contrôles des écarts entre les zones saisies dans l'écran de conditionnement et les TSC imposés clients. Nécessite le TSC 218

21 Mode de contrôle

B Bloquant

W Warning

N Pas de contrôle

COUL_FOND_PAL_ENS

Couleur de fond pour l'écran de palettisation de l'ensemble monté

DS_COUL_OPTION_IMP

Options d'impression par défaut selon le nombre de couleurs saisis dans le devis simplifié

21,22 Nombre de couleurs

23,25 Code d'option d'impression à mettre en place lorsque le nombre de couleurs du devis simplifié correspond au nombre de couleurs paramétré en caractères 21 à 22.

Correspond à un type de paramètre .OI

DS_EDITION_AUTO_VAL

21 Lancement automatique de l'édition à la validation du devis

N Pas d'édition (par défaut)

C Edition à la création de devis

2 Edition systématique à la validation

DS_PARAM_LCT_DEVIS

21,26 Type et code du paramètre de lancement de la saisie des devis en mode normal

DS_REFEMBCLI_DEFAUT

21,40 Référence emballage client par défaut (od_demcli.od_de_nrefembcli)

Remarque : Valeur obligatoire pour la saisie des devis simplifiés, pas de valeur par défaut

EMETTEUR_FAX_EMAIL

21,26 Type et code de l'émetteur du fax / email

FENETRE_AUTO_CLIENT

Permet d'afficher automatiquement les notes du type paramétré concernant le client, lors de la validation de l'écran principal

21,23 Type de notes

HAUTEUR_CAMION

21,25 Hauteur du camion pour le calcul du conditionnement, en millimètres (par défaut : 2500)

HAUTEUR_ENCOMBREMENT

21,24 Hauteur maximum de l'encombrement palette pour calcul automatique du gerbage en fonction de la hauteur de l'encombrement calculé

JONCTION_AUTORIS_DJ

21,23 Code jonction autorisé dans le cas de la double - jonction

LARGEUR_CAMION

21,25 Largeur du camion pour le calcul du conditionnement, en millimètres (par défaut : 2400)

LONGUEUR_CAMION

21,25 Longueur du camion pour le calcul du conditionnement, en millimètres (pas de valeur par défaut)

LCT_ACTUAL_VAR_CDT

21 à 26 Type et code du paramètre de lancement de l'actualisation des variantes de conditionnement (#SAVCC)

OBJET_DOCUMENT

21,23 Type de document (DEV)

25,60 Objet du document pour le fax/email

QUESTION_RAZ_GAMME

21 Pour le recalcul par la touche F9/F11 :

O Fenêtre de confirmation de l'écrasement de la gamme

N Ecrasement de la gamme sans confirmation

Pour le batch de recalcul de devis :

O Pas d'écrasement de la gamme

N Ecrasement de la gamme

RECAL_PTG_SDEV_99_E

Architecture étudiée, sous-devis 99

RECAL_PTG_SDEV_99_A

Architecture automatique, sous-devis 99

RECAL_PTG_SDEV_XX_A

Architecture automatique, sous-devis autre que 99

21 à 22 O On force le calcul sans message de confirmation

N On ne calcule pas les pointages (sans message de confirmation)

QO On pose la question du recalcul avec Oui par défaut

QN On pose la question du recalcul avec Non par défaut.

RECAL_PTG_SDEV_XX_E

Architecture étudiée, sous-devis autre que 99

RETRAIT_LARGEUR_MAX

21 à 24 Retrait maximum autorisé dans le sens largeur en millimètres

Permet de gérer les retraits maximum autorisés dans le sens largeur lors de la détermination automatique du conditionnement par le devis.

RETRAIT_LONGUEUR_MAX

21 à 24 Retrait maximum autorisé dans le sens longueur en millimètres

Permet de gérer les retraits maximum autorisés dans le sens longueur lors de la détermination automatique du conditionnement par le devis.

RUN_V_CDEM_VERSION

21, 26 Type et code du paramètre de lancement de la visu de commande

_SUP_REQ_FEFCO

21, 60 Complément de requête sur la recherche des codes FEFCO

SUP_REQ_MAT_QUALITE

21 à 60 Supplément de requête sur mat pour la vérification de la qualité du code ensemble et de ses éléments, permet de vérifier la présence des articles dans une liste d'éléments à ne pas traiter.

Ce supplément de requête ne sert que pour le recalcul batch.

Exemple

and mp_qualite = "FIN"

_SUP_REQ_MP_PARAM_22

21,60 Supplément de requête sur les tables cde1 et cde2

Exemple

and ec_tyc != "PRX"

SUP_REQ_PAL_ENS

21,60 Complément de requête sur la table mat pour la recherche des palettes pour un ensemble monté

Cette note est utilisée dans l'écran Saisie de la palettisation de l'ensemble.

SUP_REQ_RECALCUL

21,60 Complément de requête pour le recalcul batch des devis

TITRE_DOCUMENT

21,23 Type de document (DEV)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TYPE_DESIGN_DEST

Désignation de l'ensemble et du produit fini

Utilisé dans la recopie du sous-devis

Explications

21 Type de désignation de l'ensemble destination (1/2, 1 par défaut) - Facultatif

1 Libellé de l'entête du devis

2 Désignation de l'ensemble source

22 Type de désignation du produit fini destination (1/2, 1 par défaut) - Facultatif

1 Libellé de l'entête du devis

2 Désignation du produit fini source

VERIF_OUTIL_CODE_QA

21, 23 Valeur du code paramètre validité (Type QA) pour la mise à jour des produits externes au sous-devis courant utilisant des outils internes au sous-devis courant

VERIF_OUTIL_SUP_OUT

21, 60 Complément de sélection pour la recherche des outils internes au sous-devis courant

Table concernée : mat. Exemple : and mp_mp = "O"

VERIF_OUTIL_SUP_PDT

21, 60 Complément de sélection pour la recherche des produits externes au sous-devis courant utilisant des outils internes au sous-devis courant

Table concernée : mat. Exemple : and mp_qualite = FAB

VERIF_OUTIL_TSC

21, 23 Code TSC utilisé pour la saisie des codes outils

25, 25 Zone de recherche des TSC

A TSC saisi sur l'article

T TSC saisi sur le triplet

2: TSC saisi sur l'article et/ou sur le triplet (par défaut)

Important : Cette précision peut permettre d'optimiser le traitement et d'éviter des recherches inutiles.

Remarque : Il peut y avoir plusieurs lignes de paramétrage de TSC de saisie d'outil (une ligne par TSC).

Pour pouvoir utiliser des formules de calcul liées aux options d'impression avec une valeur numérique paramétrable : voir le paramètre .OI, alpha3[1,6].


Devis reliure

Devis reliure devis_bru - devis_rel

Options

Oco | Consultation uniquement
Off | Fiche de fabrication. La numérotation des fiches de fabrication commence à 5001
Ocf | Recalcul même sur une fiche de fabrication. Actif si -Off actif.
Otx | Utilisation des taux horaires du fichier opération
Opi | L'écran de prix (bru_8) sera inactif
Osd | La fiche de fabrication est créée sans devis
Oms | Génération automatique des mouvements de stocks
Osr | Pas de mise à jour du stock résultant
Ouv | Utilise l'unité de vente pour calculer le prix de vente issu du fichier matière et le prix du mouvement de stock
Oca | Lorsque l'on modifie le carton dans la fiche de fabrication (on renseigne en fait le carton réellement utilisé), on recalcule alors le prix de ce dernier en tenant compte de son unité d'achat. Cette option n'est active que si l'option -Off (fiche de fabrication) est active.

Paramètres associés

#CF DRE Configuration du devis reliure

Pour pouvoir modifier manuellement le code article de la garde feuille, créer un paramètre de type TGC, dont le code est sur 3 caractères, où alpha1[20] = O


Devis sérigraphie

Devis sérigraphie devis_ser

Reprendre le paramétrage du devis_Carton Ondulé.


Devis industries mécaniques

Devis industries mécaniques devis_mec

Options

Oco | Consultation seulement
Ocv | Calcul de variante
Ofg | Saisie d'un code formule par ligne de gamme (Code phase figée #DM)
Ofo | Saisie d'un code formule par ligne de nomenclature (Code phase figée #DM)
Ogg | Gestion Greleg pour la saisie des nomenclatures
Oop | Ouverture automatique de la fenêtre de port dans le calcul de la variante
Orn | Recopie les notes des opérations en création de gamme
Osf | Evite la saisie du format (épaisseur, largeur, Longueur) en saisie de nomenclature
Otg | Copie de gamme et de nomenclature lors de la saisie du code article
Oth | Théorique enlève l'obligation L >= l
Ovp | Multiplie le prix par la largeur, longueur, hauteur
Oxm | Ouverture automatique de l'écran de gestion des fax/emails en création de devis

Notes

DEVIS_MODELE

21 à 32 Numéro du devis modèle au format 00000000-0

Paramètres associés

#CF DMR Configuration du récapitulatif du devis

#CF DMG Configuration générale du devis mécanique

Zones utilisables par la création de formules

D | Quantité devisée
G | Grammage
H | Hauteur
L | Longueur
L | Largeur
a,b,c,d,e,f,g,h | Données techniques 1.8
Q | Quantité du niveau immédiatement supérieur à la ligne de nomenclature en cours.


Edition du devis imprimeries et carton plat

Edition du devis imprimeries et carton plat fle_edi

Voir aussi l'édition via VoluEdit

Options triées

-Ocp | Gestion de la contrepartie
-Off | Devis de fabrication (sous-devis 99). Si cette option est absente, il s'agit d'un devis feuille.
-Ofi | Fiche de fabrication Pour une raison inconnue, l'édition actuelle des code FEFCO inverse les dimensions spécifiques j et k lors du calcul des pointages => Cela provoque une inversion à l'édition. Cette option permet de spécifier que l'on désire utiliser l'ordre normal j, k.
-Ojk | Ordre logique dans le calcul des pointages
-Osw | Appel du programme de schéma Windows

Valeur alpha 2

1,3 | Paramètre de configuration générale du devis Par défaut : DEG. Le type est systématiquement #CF
4,6 | Paramètre de configuration du récapitulatif du devis Par défaut : DER. Le type est systématiquement #CF
7 | Type du libellé à afficher en bas de l'écran des phases
8 | Type de devis figé à l'édition (B, C, F, K, R et T)

Paramètres associés

Note : La structure de ces 4 paramètres est identique.

Vous demandez une édition | simplifiée | détaillée
du devis feuille (option Off absente) | #CF EDS | #CF EDD
du devis de fabrication (option Off présente) | #CF EFS | #CF EFD


Edition de la fiche de fabrication imprimeries et carton plat

Edition de la fiche de fabrication imprimeries et carton plat fle_f

Options

-Ofi

Obligatoire pour la fiche de fabrication


Edition du devis reliure

Edition du devis reliure edi_bru

Options

-Ocl | Edition client (obligatoire)
-Ocp | Edition de la contrepartie en Francs si la devise société est en Euros.
-Oag | Edition des champs spécifiques A (nombre de cahiers à perforer, surpiqûre, nombre de coins et nombre de tranches dorées)


Edition du devis industries mécaniques

Edition du devis industries mécaniques mec_edi

Options

-Orc | Edition d'un récapitulatif par devis - sous-devis
-Otg | Edition d'une ligne de totalisation si édition de la gamme.
-Oed | Pas d'édition détaillée
-Oes | Pas d'édition simplifiée
-Oeg | Pas d'édition échancrée avec gamme
-Oen | Pas d'édition échancrée sans gamme

Valeur alpha 1

Caractères 1 à 30

Paramétrage des colonnes nomenclatures
Par défaut : ABFJG
A Niveau de nomenclature (1 à 7)
B Séquence (Phase / Composant / libellé)
C Epaisseur
D Largeur
E Longueur
F Prix de revient unitaire devise
G Quantité
H Valeur total de la ligne de nomenclature (P.V)
I Date de création
J Taux de marge devise
K Prix d'achat fichier article (Unité Achat)
L Code unité d'achat fichier article (U/A)
M Libellé court Unité d'achat Fichier Article
N Taux de frais Fichier Article
O Taux de perte Fichier Article
P Prix de Revient Fichier Article (Unité Achat)
Q Taux de Marge Fichier Article
R Prix de Vente Fichier Article (Unité Achat)
S Prix de Vente Fichier Article (Unité Utilisation)
T Code Unité de Vente (ou Utilisation) (U/V)
U Libellé court Unité de vente Fichier Article
V Prix de Vente unitaire devise
W Total P.R. de la ligne de nomenclature
X Total P.V. hors gamme de la ligne de nomenclature
Y Total P.R. Matière de la ligne de nomenclature
Z Total P.R. Sous-traitance de la ligne de nomenclature
a Total P.R. Port de la ligne de nomenclature

Caractères 31 à 60

Paramétrage des colonnes gammes

Par défaut : ABCDEFGHI

A Type de gamme

B Numéro de phase

C Code Opération

D Libellé opération

E Temps de préparation

F Temps de réalisation

G Coût forfaitaire

H Coût total préparation

I Coût total réalisation

J Coût total de la p

K Cadence de la phase

Valeur alpha 2

Caractère 1 | Edition des notes d'entête (D) O/N
Caractère 2 | Edition des notes de nomenclature O/N
Caractère 3 | Edition des notes de gamme O/N
Caractère 4 | Edition des notes de récapitulatif (CV) O/N
Caractère 5 | Edition des notes de livraison O/N

Paramètres associés

#CF EMD | Paramétrage de l'édition détaillée du devis
#CF EMS | Paramétrage de l'édition détaillée du devis


Edition du devis onduleur

Edition du devis onduleur edon

Cliquez ici pour voir l'édition VoluEdit.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-n_

car. 3-13 Offre à éditer (devis/sous-devis)

car.14 Type d'édition

A Edition fiche technique 2 (détaillée)

C Edition commerciale

F Edition fiche technique 1 (simple)

T Edition technique

V Edition force de vente

Options triées

Ocf

Pas de contrôle phase financier

Oec

Sélection des devis avec écran complet

Ofv

Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût

Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.

Oin

Inversion laize coupe

Omn

Eclatement du multi-niveaux dans le récapitulatif de l'édition technique du devis

Dans le récapitulatif de l'édition technique du devis, le prix de revient des articles multi-niveaux est intégré aux matières.

Cette potion permet d'éclater le prix de revient des articles multi-niveaux en matière, en façonnage variable et fixe et en actions de service.

Opl

Plastique

Opr

Prix remis dans l'édition du devis à la place du prix négocié

Valeur alpha 2

Caractères 1 à 3 | Code devise (EUR par défaut)
Caractères 4 & 5 | L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S
Caractères 6 à 10 | SPECIFIQUE Longueur du camion
Caractères 11 à 15 | SPECIFIQUE Largeur du camion

Valeur alpha 3

Caractère 1

Type d'édition à lancer

T : Techn. 1 (Edition technique des devis)

F : Techn. 2 (Edition de la fiche technique)

A : Techn. 3 (Edition du devis sous APPIC)

V : Force vente (Edition du devis force de vente sous APPIC)

C : Commerciale (Edition commerciale des devis)

Valeur alpha 4

Caractères 1 à 6

Type et code du paramètre de lancement de l'édition du devis

Notes triées

CHOIX_CODE_IMPRIM_A | 21 à 23 Code imprimante sélectionnée pour l'édition du devis APPIC (type A).
CHOIX_CODE_IMPRIM_C | 21 à 23 Code imprimante sélectionnée pour l'édition du devis commercial (type C).
CHOIX_CODE_IMPRIM_F | 21 à 23 Code imprimante sélectionnée pour l'édition du devis technique 2 (type F).
CHOIX_CODE_IMPRIM_T | 21 à 23 Code imprimante sélectionnée pour l'édition du devis technique & offre client (type T).
CHOIX_CODE_IMPRIM_V | 21 à 23 Code imprimante sélectionnée pour l'édition du devis force de vente (type V).
ENVIRONNEMENT_MARGE | Code d'environnement pour la recherche des marges contributives Exemple : STD (valeur par défaut) edon_new
FICTIFACHETE | 21,35 Code du produit fictif (composant générique)
LIBELLE_TEE_CDV | 21,50 Libellé Niveau Chef des Ventes edon_new
LIBELLE_TEE_CONSEIL | 21,50 Libellé Niveau conseillé edon_new
LIBELLE_TEE_DIR_EXP | 21,50 Libellé Directeur Exploitation edon_new
LIBELLE_TEE_RRV | 21,50 Libellé Niveau RRV edon_new
PAR_LCT_PRG_PAR_DEV PAR_LCT_PRG_PAR_DEVT PAR_LCT_PRG_PAR_DEVF PAR_LCT_PRG_PAR_DEVA PAR_LCT_PRG_PAR_DEVV PAR_LCT_PRG_PAR_DEVC | Lancement pour chaque devis édité un programme avec numéro de devis en argument idem avec modèle technique 1 idem avec modèle technique 2 idem avec modèle technique 3 idem avec modèle force de vente idem avec modèle commercial 21,26 Type et code du paramètre de lancement
_QRP_KGS | 21 à 23 Paramètre de l'unité de quantité de remise de prix pour les kgs. Ex : MIL, CEN
_QRP_M2 | 21 à 23 Paramètre de l'unité de quantité de remise de prix pour les m2. Ex : MIL, CEN
SN | 3,60 Supplément de requête pour la recherche des notes
SOUS_FAM_INJECTION | 21,23 Sous-famille injection
_SUP_REQ_CDE1 | 21,60 Complément de sélection sur la tables d'entête de commandes (cde1) pour la recherche des commandes (marges contributives) Ex : and ec_tyc = "CD2" edon_new
_SUP_REQ_CDE2 | 21,60 Complément de sélection sur la tables d'entête de commandes (cde1) pour la recherche des commandes (marges contributives) Exemple : and lc_delrep > "01/01/2003" edon_new


Edition des offres du devis mécanique

Edition des offres du devis mécanique mec_cn

Spécifique

Options

-j | + nombre de jours de validité sur 3 caractères (Exemple -j090)
-n | + numéro du devis à éditer (Exemple -n92040055)
-r | Réédition
-n ou -N | Devis
-D | Destinataire fax/email
-Oxm | Envoi automatique des fax/emails


Edition des offres du devis imprimeries

Edition des offres du devis imprimeries fle_c

#ED DPC | Edition de devis commercial
#ED DEA | Edition confirmation technique
#ED DPT | Edition devis partie technique
#ED DPP | Edition devis données production

Options

-Odc | Edition devis commercial (obligatoire pour le VOL_0521 - voir #CF 521)
-Oes | Edition commercial simplifiée (à gérer en spécifique dans le report)
-Oct | Edition d'une confirmation technique (obligatoire pour le VOL_0522 si le report est différent de l'édition client)
-Opt | Edition devis partie technique
-Odp | Edition devis données de production
-Odu | Code devis unique dans la liste des devis / sous-devis
-Old | Saisie liste N° de devis / sous-devis (50). Incompatible avec -Osd.
-Ope | L'édition édite uniquement un récapitulatif sous-devis. Il n'est pas nécessaire de traiter les entités. Cette option depend du report, elle n'est en aucun cas obligatoire. Elle permet uniquement d'optimiser les temps de traitement. Elle peut être positionnée si le report client ne traite pas le type de ligne ENTITE.
-Off | Restreint l'édition aux sous-devis 99
-Ops | N'édite qu'une offre de prix par numéro de devis
-Oer | Editions et rééditions confondues
-Osd | Edition de tous les sous-devis du devis passé en paramètre (ne fonctionne pas si l'option -Old est activée).
-Oxm | Fax / Mail automatique Voir les notes VALID_FAX* dans les généralités.

Valeur alpha 2

Caractère 1

Automatisation du nom de fichier lors de l'édition dans un fichier. Le nom du fichier est constitué des caractères 3 à 8 du numéro de devis et du numéro de sous-devis sur 2 caractères, avec l'extension dev.
Exemple devis 95120012, sous-devis 2. Nom du fichier 12001202.dev

Notes

EC | Texte qui apparaîtra sur l'entête de l'édition du devis client L'édition de ces notes doit être prévue dans le report.
PC | Texte qui apparaîtra sur le pied de page de l'édition du devis client L'édition de ces notes doit être prévue dans le report.
PHRASE_ENTETE | 21 à 60 Phrase éditée en entête de l'offre de prix. La première ligne correspond au premier mot de la phrase (« Bonjour, » ou « Monsieur », …) 10 lignes au maximum.
PHRASE_PIED | 21 à 60 Phrase éditée en pied de l'offre de prix. La dernière ligne correspond au dernier mot de la phrase (« Bonne réception. » ou « Cordialement », …) 10 lignes maximum.
VALID_FAXMAIL_EDIT VALID_FAXMAIL_REEDIT VALID_FAXMAIL_VALID | Voir les notes dédiées au Fax/Mail

Paramètres associés

Ajout de l'édition des notes NTS de type DIV.

Attention : ces notes doivent être saisies sur les entités. Seules les notes de la première variante seront éditées.


Edition du devis R

Edition du devis R edi_ondu

Options triées

-n ou –N | Les 11 caractères suivants sont réservés au N° du devis à éditer.
O03 (zéro trois) | SPECIFIQUE Coefficient de frais généraux et marge. Incompatible avec –O04
O04 (zéro quatre) | SPECIFIQUE Clichés et formes. Incompatible avec –O03
Obp | Pas d'édition du bas de page
Obr | Calcul en fonction des poids et surface brute
Ocp | Calcul des PV/kg et PV/m2 avec le prix remis
Oea | Edition de l'annexe détail accessoires
Opc | Edition de la quantité de palettes complètes au lieu de la quantité de base de l'offre Celle-ci est stockée dans le ic_num2 du TSC QPC de l'ensemble de l'offre (Type de clé = A).
Oxm | Envoi automatique des fax / email Voir les notes VALID_FAX* dans les généralités.

Fin des options triées

Notes

SUPREQACCANN | 21,60 Complément de select sur les tables nom0 ou mat déterminant les accessoires à éditer dans l'annexe.
SE | 3,60 Supplément de requête pour les demandes d'écrans
SN | 3,60 Supplément de requête pour la recherche des notes
VALID_FAXMAIL_EDIT VALID_FAXMAIL_REEDIT VALID_FAXMAIL_VALID | Voir les notes dédiées au Fax/Mail


Batch de réactualisation des coûts pour le devis onduleur

Batch de réactualisation des coûts pour le devis onduleur rcp_batch_don

Il permet de réactualiser les coûts générés sur une ligne de commande sur plusieurs environnements : prévisionnel (CEV/PRP) et réel (CER/PRR).

Il permet, lors de la réactualisation via l'offre fictive, d'enregistrer les indicateurs de récapitulatif des coûts calculés sur la ligne de commande au niveau de l'historique du prix de revient (hist_pr).

Remarques :

• Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients / Récapitulatif des coûts)

• Le récapitulatif des coûts peut être réactualisé via le recalcul d'une offre de vente fictive, faisant appel à la saisie des devis onduleurs (par défaut), ou via un recalcul simplifié à partir des tables du devis associé à la ligne de commande.

Réactualisation des indicateurs via l'offre fictive uniquement :

• Les indicateurs d'environnement CEV sont enregistrés dans le type M de l'historique de prix de revient (hist_pr)

• Les indicateurs d'environnement CER sont enregistrés dans le type N de l'historique de prix de revient (hist_pr)

Valeurs numériques

1

Méthode de réactualisation - Voir aussi #CF REC, note METHODE_2_ECART_QTE.

1 Récupération des coûts sur l'offre de vente associée à la ligne de commande et mise à jour des coûts de la commande via une proratisation à la quantité commandée

2 Construction d'une offre de vente fictive à la quantité commandée à partir de l'offre de vente associée à la ligne de commande (par défaut)

3 Réactualisation des indicateurs des commandes et factures associées uniquement (sans recalcul du détail des coûts)

4 Méthode de réactualisation optimisée
Cette méthode est équivalente à la méthode 2, mais une seule exécution du devis onduleur est réalisée au lieu d'une exécution par offre de vente à réactualiser.

5 Cumul des coûts des ordres de fabrication ayant participé à la livraison

• Cette méthode de calcul utilise la table de picking des palettes (remplie lors de l'édition définitive des bons de livraison) et lié à l'option payante LIV/9

• Lors du calcul du prix de revient réel d'un ordre de fabrication (programme cpr), le récapitulatif des coûts présent sur les lignes de commandes livrées depuis cet OF est supprimé (CEV/CER). Lors de cette suppression, un flag est mis en place sur la ligne de commande permettant d'indiquer au batch de réactualisation que cette ligne de commande doit être recalculée (TSC _RC)

• Le récapitulatif des coûts d'une ligne de commande (CEV/CER) correspond au cumul des coûts des ordres de fabrication ayant participé à la livraison ramenés à la quantité pickée sur cet OF :

o Cumul des coûts PRP ---> Coûts de la ligne de commande CEV (prévisionnel)

o Cumul des coûts REV ---> Coûts de la ligne de commande CER (réel)

• Seules les lignes de commandes réellement livrées sont prises en compte lors de la réactualisation des coûts avec la méthode de calcul 5.

• Si le récapitulatif des coûts n'est pas trouvé sur un des OF ayant participé à la livraison, on considère que la ligne de commande est en anomalie, le flag de réactualisation (TSC _RC) est alors laissé à O (à recalculer) et un message indiquant l'OF posant problème est affiché.

2

non utilisée

Valeur alpha 2

A2[1]

Type de recherche du code article par F7

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Q Recherche par composition carton

T Recherche transformateur

A2[2]

Type de recherche du code normalisé (AFNOR)

1 Recherche fichier article

2 Pas de contrôle (par défaut)

A2[3]

Ouverture automatique de la deuxième fenêtre de critère de sélection client (O/N, N par défaut)

A2[4]

Ouverture automatique de la deuxième fenêtre de critère de sélection article (O/N, N par défaut)

A2[5]

Imprimerie / Mécanique

O Imprimerie

N Mécanique (par défaut)

A2[6]

Prise en compte du TSC de la ligne modifiée (TSC _RC=

O On ne prend en compte que les lignes de commandes modifiées depuis la dernière réactualisation (valeur du TSC _RC = O)

N On ne prend pas en compte la valeur du TSC _RC.
Toutes les lignes de commandes sélectionnées sont systématiquement réactualisées (par défaut).

Notes

CHEMIN_FIC_TRACE | 21,60 Chemin d'accès au fichier de trace de la réactualisation des indicateurs de rentabilité
CODE_BLOCAGE_RCP | Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS. Voir le paramètre #CF REC pour plus d'info. Remarques : Ce code blocage peut également être mis en place à la saisie de la ligne de commande. La zone alphanumérique de 30 caractères du TSC _RC est mise à jour avec l'état des indicateurs.
METHODE_2_ECART_QTE | Réactualisation du récapitulatif des coûts dans le devis onduleur. Cette note est recherchée en priorité ici, sur le paramètre de lancement. Si elle n'est pas trouvée, elle est recherchée sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS ci-dessous (par exemple #CF REC). Voir le paramètre #CF REC pour plus d'info.
PARAM_CALCUL_DEVIS | 21,26 Type et code du paramètre de lancement de la saisie des devis pour la réactualisation du récapitulatif des coûts (le mode batch est positionné automatiquement)
PARAM_INDICATEURS | 21,26 Type et code paramètre de configuration du récapitulatif des coûts
_SUP_SQL_CDE1 | Complément de sélection sur les entêtes de commandes (table cde1)
_SUP_SQL_CDE2 | Complément de sélection sur les lignes de commandes (table cde2)
_VAR_INDIC_ _FOR_INDIC_ _TIT_INDIC* _HIS_INDIC* | Ces notes seront recherchés en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS. Voir le paramètre #CF REC pour plus d'info.

Paramètres nécessaires

#CF REC | Configuration du récapitulatif des devis
TSC _RC | Permet de savoir si une ligne de commande a été modifiée


Batch de réactualisation des coûts pour le devis multi-métiers

Batch de réactualisation des coûts pour le devis multi-métiers rcp_batch_devis

Ce programme est opérationnel à partir de la V.4.0.141.2

Fonctionnalités

  • Réactualiser les coûts générés sur une ligne de commande sur plusieurs environnements : prévisionnel (CEV/PRP) et réel (CER/PRR).

  • Enregistrer les indicateurs de récapitulatif des coûts calculés sur la ligne de commande au niveau de l'historique du prix de revient (hist_pr).

  • Mettre en place un code blocage automatique lors de la réactualisation d'une ligne de commande lorsque les indicateurs de rentabilité client n'ont pas pu être calculés (offre de vente associée au produit non trouvée, calcul du devis impossible).

Remarques

  • Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients/Récapitulatif des coûts)

  • Le récapitulatif des coûts est réactualisé via un recalcul simplifié à partir des tables du devis associé à la ligne de commande.

  • Les indicateurs d'environnement CEV sont enregistrés dans le type M de l'historique de prix de revient (hist_pr)

  • Les indicateurs d'environnement CER sont enregistrés dans le type N de l'historique de prix de revient (hist_pr)

  • Le code blocage peut également être mis en place à la saisie de la ligne de commande.

  • La zone alphanumérique de 30 caractères du TSC _RC est mise à jour avec l'état des indicateurs (voir ci-dessous).

  • Le calcul de l'environnement réel n'est effectué que si des paramètres de configuration spécifiques sont renseignés (voir note commençant par CONFIG_DEG_DER_REEL).

Valeur alpha 2

A2[1]

Type de recherche du code article par F7

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Q Recherche par composition carton

T Recherche transformateur

A2[2]

Type de recherche du code normalisé (AFNOR)

1 Recherche fichier article

2 Pas de contrôle (par défaut)

A2[3]

Ouverture automatique de la deuxième fenêtre de critère de sélection client (O/N, N par défaut)

A2[4]

Ouverture automatique de la deuxième fenêtre de critère de sélection article (O/N, N par défaut)

A2[5]

Imprimerie / Mécanique

O Imprimerie

N Mécanique (par défaut)

A2[6]

Prise en compte du TSC _RC

O On ne prend en compte que les lignes de commandes modifiées depuis la dernière réactualisation (valeur du TSC _RC = O)

N On ne prend pas en compte la valeur du TSC _RC.
Toutes les lignes de commandes sélectionnées sont systématiquement réactualisées (par défaut).

Notes du paramètre de lancement

CODE_BLOCAGE_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

CONFIG_DEG_DER_PREV

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement prévisionnel - Par défaut : DEG

24,26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement prévisionnel - Par défaut : DER

CONFIG_DEG_DER_REEL

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement réel

Pas de valeur par défaut

24,26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement réel

Pas de valeur par défaut

DS_DOUBLE_CALCUL

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info..

DS_GESTION_EFFECTIF

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

DS_RAZ_QUANTITES

21 Activer la remise à zéro des quantités des opérations si le temps total est à zéro (O/N, O par défaut)

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_HIS_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

LISTE_TYC_CALC_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

_SUP_SQL_CDE1

Complément de sélection sur les entêtes de commandes (table cde1)

_SUP_SQL_CDE2

Complément de sélection sur les lignes de commandes (table cde2)

_SUP_REQ_FLE_OPE_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FLE_TRA_RCP

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_TIT_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

Exemple de paramétrage

Sur le paramètre de lancement du devis #SA DE2

PARAM_INDICATEURS #CFRCP

Dupliquer le paramètre de lancement #SA DE2 sur #CF RCP

Sur #SA DE2, suppression des notes commençant par FOR_INDIC, TIT_INDIC & VAR_INDIC

Sur #CF RCP, conserver que les notes commençant par FOR_INDIC, TIT_INDIC & VAR_INDIC

Paramétrage Récap. Coûts #CF RCP

LL Récapitulatif des coûts

LC Coûts

#________ Définition de la table recap_cout

# Variables

_VAR_INDIC_a SOMME_X_MAT_CAR

_VAR_INDIC_b SOMME_X_MAT_NEG

_VAR_INDIC_c SOMME_X_MAT_ENC

_VAR_INDIC_d SOMME_X_XXX_AUT

_VAR_INDIC_e SOMME_V_OPE_DIF

_VAR_INDIC_f cout_transport

_VAR_INDIC_g SOMME_X_MAT_PAL

_VAR_INDIC_h SOMME_X_MAT_STO

_VAR_INDIC_i SOMME_X_MAT_PET

_VAR_INDIC_j SOMME_V_MAT_GEN

_VAR_INDIC_k SOMME_V_MAT_FIN

_VAR_INDIC_l SOMME_V_MAT_CAP

_VAR_INDIC_m SOMME_X_MAT_CON

_VAR_INDIC_n l2_c_pv

_VAR_INDIC_o prix_remis_devis

_VAR_INDIC_x surf_uni_nette_m2

_VAR_INDIC_y poids_uni_ensemble

_VAR_INDIC_z qte_devis

# Formules

_FOR_INDIC_01 02 a

_FOR_INDIC_02 02 b

_FOR_INDIC_03 02 ab+

_FOR_INDIC_04 02 c

_FOR_INDIC_05 02 d

_FOR_INDIC_06 02 e

_FOR_INDIC_07 02 cd+e+

_FOR_INDIC_08 02 f

_FOR_INDIC_09 02 g

_FOR_INDIC_10 02 fg+

_FOR_INDIC_11 02 ab+ cd+e+ fg+ + +

_FOR_INDIC_12 02 hi+j+k+l+m+

_FOR_INDIC_13 02 n

_FOR_INDIC_14 02 ab+ cd+e+ fg+ hi+j+k+l+m+ n+ + + +

_FOR_INDIC_15 02 1 ab+ o/ - 100 *

_FOR_INDIC_16 02 o

_FOR_INDIC_31 02 x

_FOR_INDIC_32 02 tx*

_FOR_INDIC_33 03 zy*

# Présentation

_TIT_INDIC*_____Quantité*qte_devis*#########&***

_HIS_INDIC*F*hp_z1****

_TIT_INDIC*_____Surface unitaire*FOR_31*#######&.&&&*N*

_TIT_INDIC*_____Surface total*FOR_32*#######&.&&&*N*

_HIS_INDIC*F*hp_z2****

_TIT_INDIC*_____Poids total*FOR_33*#########&.&&*N*

_HIS_INDIC*F*hp_z3****

_TIT_INDIC*Carton / Support*FOR_01*#########&.&&***

_HIS_INDIC*F*hp_z4****

_TIT_INDIC*Negoce*FOR_02*#########&.&&***

_HIS_INDIC*F*hp_z5****

_TIT_INDIC*>> Total Mat. Prem.*FOR_03*#########&.&&***

_TIT_INDIC*Encre*FOR_04*#########&.&&***

_HIS_INDIC*F*hp_z6****

_TIT_INDIC*Mat.Aux.*FOR_05*#########&.&&***

_HIS_INDIC*F*hp_z7****

_TIT_INDIC*Opérations ROC*FOR_06*#########&.&&***

_HIS_INDIC*F*hp_z8****

_TIT_INDIC*>> Total fabrication*FOR_07*#########&.&&***

_TIT_INDIC*Transport*FOR_08*#########&.&&***

_HIS_INDIC*F*hp_z9****

_TIT_INDIC*Palette / Conditionnement*FOR_09*#########&.&&***

_HIS_INDIC*F*hp_z10****

_TIT_INDIC*>> Coût logistique*FOR_10*#########&.&&***

_TIT_INDIC*>>>> P. R. usine*FOR_11*#########&.&&***

_TIT_INDIC*Frais*FOR_12*#########&.&&***

_HIS_INDIC*F*hp_z13****

_TIT_INDIC*Commission*FOR_13*#########&.&&***

_HIS_INDIC*F*hp_z11****

_TIT_INDIC*>>>> P. R. Complet*FOR_14*#########&.&&***

_TIT_INDIC*Marge / T.Matière*FOR_15*#########&.&&*N*

_TIT_INDIC*Prix négocié*FOR_16*#########&.&&***

_HIS_INDIC*F*hp_z12****

Ajouter

# Reprise des paramètres par défaut.

LISTE_TYC_CALC_RCP AVOCD1CD2FADFBIFB2

_SUP_REQ_FLE_TRA_RCPand 1=1

_SUP_REQ_FLE_OPE_RCPand 1=1

Réactualisation des coûts #UT RCP

LL Réactualisation des coûts

LC Coûts

A1 G_rcp_batch_devis.42r

A2[6] N

PARAM_INDICATEURS #CFRCP

CONFIG_DEG_DER_PREV DG2DR2

_SUP_SQL_CDE1 and 1=1

_SUP_SQL_CDE2 and 1=1

DS_DOUBLE_CALCUL O

DS_GESTION_EFFECTIF O

TSC réactualisation des coûts TSC _RC

LL Réactualisation Coût

LC Réact. C

TIC*

ZFRéact. Coût ? N01.ON

Saisie des commandes clients Notamment

#_______ Indicateurs (recap_coup)

PARAM_INDICATEURS #CFRCP

CONFIG_DEG_DER_PREV DG2DR2

AUTORISE_TOUCHE_F51 O

DS_DOUBLE_CALCUL O

DS_GESTION_EFFECTIF O

Visualisation de l'historique #VI HIS

LL Visualisation de l'historique

LC Historique

A1 G_pr_hi.4ge

A2 A

Zones historique ZHA

ZHF*Z1*qte_devis

ZHF*Z2*Surface total*

ZHF*Z3*Poids total*

ZHF*Z4*Support*

ZHF*Z5*Negoce*

ZHF*Z6*Encre*

ZHF*Z7*Mat.Aux.*

ZHF*Z8*Opérations ROC*

ZHF*Z9*Transport*

ZHF*Z10*Palette*

ZHF*Z11*Commission*

ZHF*Z12*Prix négocié*

ZHF*Z13*Frais*

Cube prix de revient

Ajout de l'option -Oip sur #SA RFC #SA RFT

Configuration du cube

#CF RFX

A1[2] = O

CDE_MES_001_VAR_z F_hp_z1 --# Quantité

CDE_MES_003_VAR_x F_hp_z2 --# Surf. TOT

CDE_MES_004_VAR_y F_hp_z3 --# Poids TOT

CDE_MES_005_VAR_a F_hp_z4 --# Support

CDE_MES_006_VAR_b F_hp_z5 --# Negoce

CDE_MES_008_VAR_c F_hp_z6 --# Encre

CDE_MES_009_VAR_d F_hp_z7 --# Mat. Aux

CDE_MES_010_VAR_e F_hp_z8 --# Opération

CDE_MES_012_VAR_f F_hp_z9 --# Transport

CDE_MES_013_VAR_g F_hp_z10 --# Palette

CDE_MES_016_VAR_h F_hp_z13 --# Frais

CDE_MES_017_VAR_n F_hp_z11 --# Commis.

CDE_MES_020_VAR_o F_hp_z12 --# Prix NEG

CDE_MES_002 =xz/ --# Surf. UNI

CDE_MES_007 =ab+ --# T. Mat. 1ere

CDE_MES_011 =cd+e+ --# T. fabrication

CDE_MES_014 =fg+ --# Logistique

CDE_MES_015 =ab+cd+e+fg+++ --# P.R. Usine

CDE_MES_018 =ab+cd+e+fg+++h+ --# P.R. Complet

CDE_MES_019 =1 ab+ o/ - 100 * --# Marge / T.Matière

Procédure d'installation

Sur VoluPack

Paramètrage + recalcul complet

Sur ReflexClient

  • Effacer les données (onglet Synchro Cube / Effacer les donner.

  • Désinstaller RFX

  • Télécharger RFX 2.6.5 + Framword 4 Full

  • Administrateur des bases (Démarrer / réflexclient / Administrateur des bases), cliquer sur Mise à jour des bases dans serveur puis client.

  • Saisir la licence avec prix de revient

  • Ajouter l'option PR à base existante (administration des bases > onglet serveur > Administrer le serveur), cliquer sur Cube PR + Modification Option.

  • Lancer ReflexClient (admin / admin) - fichier synchoniser les news. Administration utilisation / modifier les users et cocher cube PR.

  • Lancer Reflexclient (cube/cube). Synchronisation des cubes > configuration.

  • Onglet configuration par cube

  • Sélectionner prix de revient --> configuration avancée

  • Onglet Mesure Simple ERP --> Activation auto.

  • Reprendre les mesures et agencer les mesures

  • Rajouter la marges pour les listes et décocher dispo dans le cube

  • Mesure calculée, marge = A-B/A %, A = mesure 20, B = mesure 07.

  • Si la remise à jour Reflex est finie côté VoluPack synchroniser les cubes.


Intégration EDI JDE

Intégration EDI JDE G_integrer_edi_jde

Il permet de mettre à jour le code statut EDI des lignes de commandes d'achats après réception à JDE.

L'accès à la traçabilité se fait via l'option payante ACH 03.

Le fichier doit être sous le format suivant :

Caractères 1 à 3 : code société

Caractères 4 à 11 : Numéro de commande d'achat

Caractères 12 à 14 : Numéro de ligne de commande d'achat

Caractères 15 à 17 : Code statut EDI renvoyé par JDE

Valeur alpha 2

Caractères 1 à 60

Nom du fichier JDE à intégrer (avec chemin)

Valeur alpha 3

Caractères 1 à 60

Nom du fichier trace d'intégration (avec chemin)


Liste des devis (Industries graphiques)

Liste des devis (Industries graphiques) l_dev

Options

Odc | Le critère sur date porte sur la date de décision et non plus sur la date de création du devis
Otd | Totalisation du prix total des devis
Otp | Totalisation du total devis mais lorsque pour un même devis on trouve plusieurs fois le même produit, on fait la moyenne des sous-devis correspondants
Off | Restriction aux fiches de fabrication
Ofa | Le code deviseur devient code fabricant
Orp | Edition d'un saut de page par rupture deviseur / signataire
Ost | Gestion du site de production (fle_2 et fle_imp) sur devis (pour devis) Tableau de bord du multisite

Valeur alpha 2

(paramétrage des colonnes nomenclatures)

Notes

S

Complément de sélection

La liste des tables accessibles dépend du paramétrage.


Par défaut, la table fle_dec n'est pas lue dans la visu.

Il existe maintenant deux moyens d'avoir les infos de cette table.

1- L'utilisateur renseigne dans sa sélection au moins un champ concernant cette table (les nouvelles zones sont regroupées en bas de l'écran de sélection).

2- S'il existe un complément de requête (voir la note _SUP_REQ_FLE_DEC)

On affiche dans le résultat une ligne par référence.

Si l'utilisateur ne veut afficher que la première référence, il lui suffit de renseigner le complément de sélection.

v_fle Visualisation des devis feuille/carton

Ce programme permet aussi de transférer en commande les devis créés via le devis multi-métiers (et lui seul).

Les paramètres impliqués portent la mention Devis -> Cde. Voir aussi le paragraphe dédié.

A noter que les paramètres comportant cette mention ne sont pas tous dédiés au transfert au transfert en commande.

Ce fonctionnement utilise l'option payante CDE 10.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro de devis - numéro de sous-devis Exemples : -N[l2_devis] -N[l2_devis|-|l2_sdevis+<<&]
-N_CLI | Caractères 3 et suivants : code client Exemple : -N_CLI[cl_code]
-N_AFF | Caractères 3 et suivants : numéro d'affaire - numéro de ligne d'affaire Exemples : -N_AFF[l2_num_affaire] -N_AFF[l2_num_affaire|-|l2_lig_affaire]

Options triées

Ocb

Ouverture d'une fenêtre de sélection pour le filtrage des devis par valeur du statut et/ou code blocage

Si cette option est activée, seuls les devis ayant au moins un code blocage seront sélectionnés.

Occ

Utiliser le type de compteur des commandes (C) pour la création du nouveau numéro de commande

Si cette option n'est pas mise en place, on utilise le type de compteur des devis (D).

Odc

Double lancement du calcul du devis Devis -> Cde

Option équivalente à l'option Odc sur la saisie des devis multi-métiers

Odd

Désactivation du décalage des numéros de références et d'entités en cas de suppression Devis -> Cde

Les numéros de références et d'entités sont fixés à la création et ne changent plus.

Option équivalente à l'option Odd sur la saisie des devis multi-métiers

Oef

Effectif Devis -> Cde

Option équivalente à l'option Oef sur la saisie des devis multi-métiers

Off

Recherche sur devis de fabrication uniquement

Onf

Recherche en excluant les devis de fabrication

Ora

Rafraîchissement automatique

Ore

Annulation des reliquats de stocks (sorties réserves) Devis -> Cde

Option équivalente à l'option Oar sur la saisie des commandes

Option équivalente à l'option Ore sur la saisie des devis multi-métiers

Orv

Recherche actuelle F7 remplacée par visualisation des devis

Orz

Remise à zéro de la quantité Devis -> Cde

Option équivalente à l'option Orz sur la saisie des devis multi-métiers

Osr

Pas de mise à jour du stock résultant Devis -> Cde

Option équivalente à l'option Osr sur la saisie des devis multi-métiers

Osw

Appel du programme de schéma Windows

Ote

Test de devis Devis -> Cde

Option équivalente à l'option Ote sur la saisie des devis multi-métiers

Ouv

On utilise l'unité de vente pour calculer le prix de vente issu du fichier mat/prod et le prix du mouvement de stock Devis -> Cde

Option équivalente à l'option Ouv sur la saisie des devis multi-métiers

Ovn

Contrôle de la validité des PF

Un ensemble est constitué de plusieurs PF, dont certains peuvent être non valides.

Lors du passage du devis en commande, on peut maintenant vérifier la validité des PF grâce à cette option.

Si un des composants n'est pas valide, le passage en commande de l'ensemble est refusé avec un message d'avertissement.

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 8 | Lancement de la visualisation sans écran de sélection (O/N, N par défaut)
Caractère 10 | Mode de visualisation E Édition F Fichier (Nom du fichier à paramétrer dans les notes) V Mode écran X Mode Excel
Caractères 11 à 16 | Type et code du paramètre de la configuration de la génération des produits finis Génération des produits à partir de la visualisation - Permet de générer/régénérer des produits à partir de la visualisation des devis feuille/carton. Ce fonctionnement utilise l'option payante CDE/10. Ordre de priorité de recherche du paramètre de configuration de la génération des produits : 1. Paramètre de lancement de la visualisation des devis (ici-même) 2. Type de processus du sous-devis en cours de visualisation : TPR A4[24,29] 3. Paramètre de lancement de la saisie des devis (voir note ACCES_DEVIS plus bas) 4. Paramètre par défaut : #CF GPF
Caractères 17 à 19 | Type de note pour la nomenclature (par défaut : DEV)
Caractères 20 à 30 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 31 | Type de visualisation N Visualisation des sous-devis /entités respectant la sélection (valeur par défaut) 2 Visualisation des sous-devis complets dont au moins une entité respecte la sélection 3 Visualisation des sous-devis dont toutes les entités respectent la sélection (sauf entité 99)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES DEVIS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 5

Accès au rafraîchissement des données de la visualisation

N Pas d'accès au rafraîchissement des données de la visualisation en cours

O Recalcul complet des données de la visualisation en recalculant la visualisation avec les critères saisis

M Recalcul de la visualisation sans recalcul des devis sélectionné à la première demande
(Maintien de la sélection originale)

Caractère 6

Autorisation d'accès à l'action de blocage/déblocage (F6) (O/N, N par défaut)

Caractère 9

Mise à jour de l'état/qualificatif du sous-devis sélectionné

Mise à jour de l'état/qualificatif du devis sélectionné (tous les sous-devis)

Touche activée (F9) (O/N, N par défaut)

Caractère 12

Accès en consultation à la nomenclature des devis multi-métiers (O/N, N par défaut)

Caractère 13

Caractère 14

Permettre la création d'un devis par recopie

Action Créer un devis par recopie, associée à la combinaison de touches Shift+F2 (F14)

O Création de devis par recopie sans accès au nouveau devis

M Création de devis par recopie avec accès au nouveau devis

N Action non disponible (par défaut)

Voir la note ACCES_DEVIS

Caractère 15

Touche F15 Devis (O/N)

Caractère 16

Touche F16 Edition du devis (O/N)

Caractère 17

Suivi des dates

Caractère 18

Touche F18 Génération de besoins (cde5) - Voir #CF TDC

Caractère 19

Autorisation d'accès au détail des phases (touche de fonction F19)

O Accès en consultation uniquement

M Accès en modification

N Pas d'accès (par défaut)

Caractère 21

Mise à jour de l'état/qualificatif de la ligne d'affaire sélectionnée (tous les sous-devis liés à cette ligne d'affaire)

Mise à jour de l'état/qualificatif de l'affaire sélectionnée (tous les sous-devis liés à ce numéro d'affaire)

Touche activée (F21) (O/N, N par défaut)

Caractère 22

Autorisation d'accès au récapitulatif du prix (touche de fonction F22)

O Accès en consultation uniquement

M Accès en modification

N Pas d'accès (par défaut)

Caractère 23

Autorisation d'accès à la fonction F23 (Shift-F11)

Accès à la saisie des références multiples sur l'entête du sous-devis

O Accès en consultation uniquement

M Accès en modification

N Pas d'accès à la saisie des références multiples (par défaut)

Voir l'option Omu dans le devis multi-métiers.

Caractère 24

Autorisation d'accès à la fonction F24 (Shift-F12)

Accès à la saisie des références multiples sur l'entité du sous-devis

O Accès en consultation uniquement

M Accès en modification

N Pas d'accès à la saisie des références multiples (par défaut)

Voir l'option Omu dans le devis multi-métiers.

Caractère 26

Touche F26 pour génération du devis en commande

Caractère 30

Activation de la génération des produits (Touche F30) (O/N, N par défaut)

Voir A2[11,16]

Caractère 31

Accès à la saisie des actions (touche F31)

O En consultation

M En modification

N Accès indisponible (par défaut)

Caractère 36

Accès à la touche de fonction F36 (Récapitulatif des coûts)

Voir la note PARAM_INDICATEURS et les notes _FOR_INDIC_, _TIT_INDIC_ et _VAR_INDIC_

Caractère 38

Touche CONTROL-C Calculatrice (O/N)

Caractère 43

Accès au lancement paramétrable de programmes avec arguments (O/N, N par défaut) Voir #RP

Caractère 44

Touche CONTROL-K : Lancement paramétrable multiple de programmes/actions activé (O/N, N par défaut)

Cette action nécessite la présence de la note _CSEL (voir ci-dessous)

Caractère 47

Touche CONTROL-O : Visualisation de la traçabilité sur fle_2 (O/N, N par défaut)

Caractère 51

Touche CONTROL-T Visualisation des touches (O/N)

Caractère 56

Touche CONTROL-Z Lancement de programmes (O/N)

Notes

ACCES_DEVIS

21,26 Type et code du paramètre de lancement de la saisie des devis-multi-métiers Devis -> Cde

Important : Obligatoire pour l'action de création d'un devis par recopie (voir A4[14])

Cette note permet de récupérer le paramétrage utilisé pour la création du nouveau numéro de devis (numéro de compteur, préfixe du compteur, etc.)

ACCES_EDITION_DEVIS

21,26 Type et code du paramètre d'accès à l'édition du devis (#EDED1)

ARTIOS_DECONNECTE

21 Utiliser l'interface ArtiosCAD en mode déconnecté (O/N, N par défaut)

La note AUTORISE_TOUCHE_F52 est nécessaire pour visualiser les études Artios.

CODE_BESOIN_SMC

21,23 Code paramètre de configuration des sorties matières consommées

Le type de paramètre est figé à #CF.

Paramétrage optionnel, par défaut : SMC

CODE_LIEN_TABLES

21,23 Code de lien à utiliser pour la recherche de liens entre les tables mat (outils) et mac0 (machines).

Code utilisé dans la recherche d'outils. Correspond à un code paramètre de type #LI

CONFIG_DEG_DER_DEVIS

Configuration du devis Devis -> Cde

21,23 Code paramètre de la configuration générale des devis (le type paramètre est forcé à #CF)

Par défaut : DEG. Equivaut à A2[1,3] du paramètre de lancement de la saisie des devis multi-métiers

24,26 Code paramètre de la configuration de récapitulatif des devis (le type paramètre est forcé à #CF)

Par défaut : DER. Equivaut à A2[4,6] du paramètre de lancement de la saisie des devis multi-métiers

_CSEL

Affichage de la colonne de sélection (colonne de droite)

Cette colonne permet de sélectionner des lignes pour lesquelles on veut par exemple éditer le devis. Voir #RP

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

F7_RECHVISU

12,60 Numéro de devis puis un tiret puis numéro de sous-devis.

Attention, cette note est automatiquement créée puis supprimée par le devis standard à l'occasion d'un F7 permettant de rapatrier le devis/sous-devis.

Elle est donc citée ici à titre informatif uniquement mais vous n'avez pas à la créer manuellement.

_FLCO_

Permettre d'accéder aux informations d'un article (mat) saisi sur une LCO du devis et/ou de l'entité

Cette fonctionnalité partage son fonctionnement avec l'accès existant aux informations d'un article saisi sur une TSC.

Au total, il est possible d'accéder à 5 fiches matières différentes saisie sur TSC et/ou LCO.

7 Numéro de la fiche à charger (1 à 5)

9 Origine de la LCO (D = Entête de devis, E = Entité de devis)

11,13 Code LCO sur laquelle est saisi le code produit à charger (la zone LCO est obligatoirement M, Matière).

Dans les notes commençant par V, D, E, F, pour afficher une valeur de la fiche article chargé via ce paramétrage, il suffit de préfixer la zone article (mp_*) par le numéro de fiche (1 à 5).

Exemple : 1_mp_des, 2_mp_foucli, …

_FOR_INDIC_

_TIT_INDIC_

_VAR_INDIC_

Edition du récapitulatif des coûts

21,60 Paramétrage des formules de calcul des indicateurs

21,60 Paramétrage des indicateurs

21,60 Paramétrage des variables de calcul des indicateurs

Ces 3 notes existent aussi sur le #CF REC où elles sont prioritaires.

Le #CF REC peut être remplacé par tout autre paramètre dont le nom est indiqué dans la note PARAM_INDICATEURS.

LCT_MULTI_CONFIG

21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

LIBC_BLOCAGE

21,30 Libellé court pour le blocage

Par défaut : Bloqué

LIBC_DEBLOCAGE

21 30 Libellé court pour le déblocage

Par défaut : Débloqué

LIBL_BLOCAGE

21 45 Libellé long pour le blocage

Par défaut : Bloqué

LIBL_DEBLOCAGE

21 45 Libellé long pour le déblocage

Par défaut : Débloqué

PARAM_GENERER_CDE

21,26 Type et code du paramètre de configuration du transfert du devis en commande. #CF TDC par défaut Devis -> Cde

27 Contrôle des dates de validité du devis à transférer (O/N, O par défaut)

La même note existe dans le devis-multi-métiers.

PARAM_INDICATEURS

Accès au récapitulatif des coûts

A4[36] doit être = O.

Voir aussi les notes _FOR_INDIC_, _TIT_INDIC_ et _VAR_INDIC_

21,26 Type et code paramètre de configuration du récapitulatif des coûts (#CF/REC)

Si renseigné, les notes _FOR_INDIC_, _TIT_INDIC_ et _VAR_INDIC_ du #CF REC sont prioritaires.

REACTUAL_DATES_VAL

21 Réactualisation automatique des dates de validité (O/N, N par défaut) Devis -> Cde

STATUT_CODE_BLOCAGE

Permettre de voir les codes blocages avec un statut particulier

T Tous les codes blocages (par défaut)

B Codes blocages avec statut bloqué

N Codes blocages avec statut débloqué

_SUP_ORDER_BY_RECAP

21,60 Complément de tri (order by) de réactualisation du devis Devis -> Cde

Par défaut : code client, code produit du devis, numéro de devis, numéro de sous-devis

_SUP_REQ_DEBLOCAGE

Complément de requête sur la table tracabilite_e

_SUP_REQ_FLE_DEC

21,60 Complément de sélection sur la table fle_dec

Ce complément permet d'avoir accès aux zones de la table fle_dec, voir la liste des noms de zone autorisés, table fle_dec, plus d'info.

Permet aussi de faire une sélection sur les références multiples.

Exemple

_SUP_REQ_FLE_DEC and de_ligne=1

_SUP_REQ_FLE_DEC and de_num_feuille = 0

_SUP_REQ_MAC_OUTIL

21,60 Complément de sélection pour la recherche des machines liées aux outils

La même note existe sur le programme de saisie des produits (G_mat)

_SUP_REQ_OUTIL

21,60 Complément de sélection pour la recherche d'outil

Exemple

and mp_mp = "O"

_SUP_REQ_REACTUAL

21,60 Complément de sélection de réactualisation du devis (table fle_2) Devis -> Cde

_SUP_REQ_RECH_LIEN

21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

_VAR_

Pouvoir dans les zones variables (_VAR) avoir les valeurs de la table recap_cout

Même principe que dans le devis standard pour les notes _VAR_INDIC.

6 Lettre à utiliser comme variable (structure classique des visus)

11,60 Code de la zone (cumul dans la table recap_cout pour le devis et le sous-devis.

Voir les codes possibles dans les caractères 14 à 60 de la note _VAR_INDIC dans le devis standard.

Exemples

_VAR_a l2_qtedev

_VAR_c SOMME_X_MAT_CAR

_VAR_d SOMME_X_MAT_PAL

_VAR_e SOMME_X_MAT_PET

_VAR_f SOMME_X_MAT_ENC

_VAR_g SOMME_X_XXX_AUT

_VAR_h SOMME_V_OPE_DIF

_VAR_i SOMME_F_OPE_IDF

_VAR_j SOMME_X_MAT_GEN

_VAR_k SOMME_X_MAT_FIN

_VAR_l SOMME_X_MAT_CAP

_VAR_m l2_remis

_VAR_n cout_transport

_VAR_q SOMME_X_MAT_STO

Transfert en commande des devis créés par le devis multi-métiers

Voir la remarque en haut de page.

La liste ci-dessous est un rappel du paramétrage existant dans la saisie des devis multi-métiers servant notamment lors du transfert du devis en commande.

Ceci peut inclure le recalcul du devis si celui-ci est paramétré pour être effectué avant la génération des commandes, voir le #CF TDC.

Le reste du paramétrage de la saisie des devis multi-métiers reste valable mais n'est pas pris en compte ou n'est pas utilisé lors du transfert en commande à partir de la visualisation.

Paramétrage à mettre en oeuvre dans le devis multi-métiers :

A2[38] Préfixe par défaut pour le numéro de devis

COPIE_NOTES_MAT_DEV

CODE_BLOCAGE_AUTO

CONF_TAR_PX_NEGOCIE

ETAT_DEVIS_FAB_MOD

_VAR_INDIC_

_FOR_INDIC_

_TIT_INDIC*

Tris possibles

01 | Code client
02 | Devis
03 | Sous-devis
04 | Entité
05 | Référence devis client
06 | Quantité devisée
07 | Site de production
08 | Numéro d'affaire (Colonne l2_num_affaire de la table fle_2)
09 | Ligne d'affaire (Colonne l2_lig_affaire de la table fle_2)
10 | Tri sur le produit d'entête de devis
11 | Tri sur le produit d'entité de devis
12 | Code représentant (fle_2.l2_representant)
13 | Date de livraison (fle_2.l2_dat_liv)

Liste des noms de zones autorisés

Zones : entités

Zones : sous-devis

Zones : phases - gammes

Toutes les zones de la table affaire

Toutes les zones du package Tiers

Autres zones

Zones de la table fle_dec - En savoir plus

Package Matières/Articles/Produits

Les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

On peut aussi accéder aux informations des articles d'entête (fle_2.l2_code_prod) et d'entité (fle_imp.fi_prod_ent).

Exemples

mp_fam devient mpl2_fam (entête de sous-devis) et mpfi_fam (entité de sous-devis)

Les libellés courts et longs suivent le même raisonnement (libl_mpl2_fam et libl_mpfi_fam)

Pour les autres zones (remplacer XX par l2 ou fi) :

lib_leXX_libelle

lib_leXX_libelle2

libfou_leXX_libelle

libfou_leXX_libelle2

lib_mpXX_afnor_art

lib_mpXX_afnor_ecma

lib_mpXX_cdc

lib_mpXX_code_origine

lib_mpXX_prod_generique

lib_mpXX_qualite_matiere

nom_abrege_mpXX_cli

nom_mpXX_cli

nom_mpXX_foucli

XXref_produit

XXreffou_produit

Si le nom de la colonne commence par LCO_, le résultat proviendra d'une info complémentaire devis. Syntaxe d'appel

Les types de paramètres des zones alpha 1 et 2 sont définis sur le paramètre LCO en A1[1,3] et A1[4,6].

Entités

Les zones sont triées en ordre alphabétique.

La colonne lib signifie que les libellés court et long sont disponibles.

Par exemple : fi_fam (code famille) : libc_fi_fam (libellé court de la famille) et libl_fi_fam (libellé long de la famille).

La colonne cum indique que la zone peut être cumulée.

La colonne for indique que la zone est utilisable dans une formule de calcul.

Il manque des croix dans les colonnes cum et for. Merci de me les signaler.

Zone | Libellé | lib | cum | for
fi_1000_rou | Prix du 1000 de roulage |  |  |
fi_accessoires | Présence d'accessoires |  |  |
fi_bascule | Couleurs basculables ? |  |  |
fi_bat | Présence du client au bon à tirer |  |  |
fi_blanc_barbe |  |  |  |
fi_blanc_droite | Valeur de blanc de côté droit |  | X | X
fi_blanc_gauche | Valeur de blanc de côté gauche |  | X | X
fi_blanc_pied |  |  |  |
fi_blanc_pli |  |  |  |
fi_blanc_tete |  |  |  |
fi_bord_max | Largeur bord de rive maximum |  | X | X
fi_bord_min | Largeur bord de rive minimum |  | X | X
fi_c_papier, des_fi_c_papier | Code papier (ou carton), Désignation du papier utilisé dans l'entité |  |  |
fi_calage_1 | Prix du premier calage |  |  |
fi_calage_s | Prix des calages suivant |  |  |
fi_cassage_mach |  |  |  |
fi_cgt_r | Nombre de changements de plaques recto |  |  |
fi_cgt_r_r | Nombre de repiquages recto |  |  |
fi_cgt_teinte_r | Changement de teinte recto |  | X | X
fi_cgt_teinte_v | Changement de teinte verso |  | X | X
fi_cgt_v | Nombre de changements de plaques verso |  |  |
fi_cgt_v_r | Nombre de repiquages verso |  |  |
fi_co_recto | Nombre de couleurs au recto |  |  |
fi_co_verso | Nombre de couleurs verso |  |  |
fi_collage | Présence de collage |  |  |
fi_conditionnement | Présence de conditionnement |  |  |
fi_contre_collage | Présence de contre-collage |  |  |
fi_couleur_pap | Couleur du papier | X |  |
fi_coupe_dec |  |  |  |
fi_coupe_plaq_net | Coupe plaque nette |  |  |
fi_cs1 | Code statistique 1 | X |  |
fi_cs2 | Code statistique 2 | X |  |
fi_cs3 | Code statistique 3 | X |  |
fi_cs4 | Code statistique 4 | X |  |
fi_d_entite | Désignation entité |  |  |
fi_d_papier | Désignation précise du papier (ou carton) |  |  |
fi_depassant |  |  |  |
fi_devis | Code devis |  |  |
fi_dorure | Présence de dorure |  |  |
fi_ecma | Code ECMA/FEFCO |  |  |
fi_enc_r | Pourcentage d'encrage recto |  |  |
fi_enc_v | Pourcentage d'encrage verso |  |  |
fi_entcop | Numéro de l'entité copiée |  |  |
fi_entite | Code entité |  |  |
fi_epreuve | Epreuve |  |  |
fi_equerre | Equerrage papier ? |  |  |
fi_fam | Code famille | X |  |
fi_fenetrage | Présence de fenêtrage |  |  |
fi_feu_pap | Nombre de feuilles de papier (calculé) |  |  |
fi_feu_pap_hg | Nombre de feuilles papier hors gâche |  | X | X
fi_fin_pression | Valeur de fin de pression |  | X | X
fi_fini_dblc | ECMA Espacement des poses en X |  |  |
fi_fini_dblc_max | Espace avance maximum |  | X | X
fi_fini_dblc_min | Espace avance minimum |  | X | X
fi_fini_par1 |  |  |  |
fi_fini_par2 |  |  |  |
fi_fonds_perdus | Fonds perdus |  |  |
fi_forcage_nbp | Nombre de poses forcé (O/N) |  |  |
fi_fou_impose | Fournisseur imposé |  |  |
fi_foulage | Présence de foulage |  |  |
fi_fournisseur, nom_fi_fournisseur | Code fournisseur, Nom du fournisseur |  |  |
fi_ft_impo | Le format papier est-il impose ? |  |  |
fi_gache_fix_fac | Gâche fixe de façonnage |  | X | X
fi_gache_for_fac | Gâche de façonnage forcée |  |  |
fi_gache_var_fac | Gâche variable de façonnage |  | X | X
fi_gaufrage | Présence de gaufrage |  |  |
fi_grammage | Grammage papier ou carton |  |  |
fi_grattage | Présence de grattage |  |  |
fi_hau_fini | Hauteur produit fini (ou hauteur ECMA/FEFCO) |  |  |
fi_laize_dec |  |  |  |
fi_laize_plaq_net | Laize plaque nette |  |  |
fi_lar_fini | Largeur du produit fini (ou large ECMA/FEFCO) |  |  |
fi_lar_ouv | Largeur produit ouvert (ou largeur hors tout ECMA/FEFCO) |  |  |
fi_lar_papier | Largeur papier commande |  |  |
fi_lar_tir | Largeur format tirage |  |  |
fi_lon_fini | Longueur produit fini (ou longueur ECMA/FEFCO) |  |  |
fi_lon_ouv | Longueur produit finis ouvert (ou longueur hors tout ECMA/FEFCO) |  |  |
fi_lon_papier | Longueur papier commande |  |  |
fi_lon_tir | Longueur format tirage |  |  |
fi_m_trav | Est-ce un même travail sur une autre entité ? |  |  |
fi_mac_forcee_r | Machine d'impression forcée au recto |  |  |
fi_mac_forcee_v | Machine d'impression forcée au verso |  |  |
fi_mac_imp | Machine d'impression recto |  |  |
fi_mac_imp2 | Machine d'impression verso |  |  |
fi_manuel | Présence d'opérations manuelles |  |  |
fi_maquette | Maquette |  |  |
fi_mode_tirage | Mode de tirage (aucun, Normal, Amalgame ou Suivant) |  |  |
fi_nb_cl_commune | Nombre de couleurs commune recto/verso |  | X | X
fi_nb_cl_fle_r | Nombre de couleurs d'impression flexo recto |  | X | X
fi_nb_cl_fle_v | Nombre de couleurs d'impression flexo verso |  | X | X
fi_nb_cl_off_r | Nombre de couleurs d'impression offset recto |  | X | X
fi_nb_cl_off_v | Nombre de couleurs d'impression offset verso |  | X | X
fi_nb_cl_ser_r | Nombre de couleurs d'impression sérigraphie recto |  | X | X
fi_nb_cl_ser_v | Nombre de couleurs d'impression sérigraphie verso |  | X | X
fi_nb_cl_typ_r | Nombre de couleurs d'impression typo recto |  | X | X
fi_nb_cl_typ_v | Nombre de couleurs d'impression typo verso |  | X | X
fi_nb_decoupe | Présence de découpe |  |  |
fi_nb_feu | Nombre de tournée (F). Surface unitaire en m2 (O) |  |  |
fi_nb_poses | Nombre de poses (carton) |  |  |
fi_nb_references | Nombre de références |  | X | X
fi_nb_teintes_r | Nombre de recherche de teintes recto |  | X | X
fi_nb_teintes_v | Nombre de recherche de teintes verso |  | X | X
fi_nb_volets | Nombre de volets |  | X | X
fi_nbp_haup_hauc |  |  |  |
fi_nbp_haup_larc |  |  |  |
fi_nbp_larp_hauc |  |  |  |
fi_nbp_larp_larc |  |  |  |
fi_num_forme | Numéro de forme |  |  |
fi_num_ordo | Numéro d'ordonnancement |  |  |
fi_num_plan_cao | Numéro de plan CAO |  |  |
fi_num1 | Zone paramétrée numérique 1 |  | X | X
fi_num2 | Zone paramétrée numérique 2 |  | X | X
fi_num3 | Zone paramétrée numérique 3 |  | X | X
fi_num4 | Zone paramétrée numérique 4 |  | X | X
fi_num5 | Zone paramétrée numérique 5 |  | X | X
fi_num6 | Zone numérique 6 |  | X | X
fi_num7 | Zone numérique 7 |  | X | X
fi_num8 | Zone numérique 8 |  | X | X
fi_num9 | Zone numérique 9 |  | X | X
fi_numerotage | Présence de numérotage |  |  |
fi_optimisable | Entité optimisable |  |  |
fi_ozalids | Nombre d ozalids a fournir au client |  |  |
fi_p_papier | Prix de revient du papier |  |  |
fi_page_feu | Nombre de pages a la tournée |  |  |
fi_pap_bloque | Prix papier bloqué ? |  |  |
fi_pap_stk | Papier sur stock, en commande ou client |  |  |
fi_pds_pap | Poids papier (calculé) |  |  |
fi_pds_pap_hg | Poids papier hors gâche |  | X | X
fi_per_contour | Périmètre de contour |  | X | X
fi_perfo | Présence de perforation |  |  |
fi_perso | Présence de personnalisation |  |  |
fi_photocompo | Photocomposition |  |  |
fi_photogravure | Photogravure |  |  |
fi_pli_dblc | ECMA Espacement des poses en Y |  |  |
fi_pli_par1 |  |  |  |
fi_pli_par2 |  |  |  |
fi_pliage_mach |  |  |  |
fi_pos_reperes | Position gamme de contrôle (P, F, D, G, A) (ECMA) |  |  |
fi_pose_sm | Nombre de poses format impression (Sens machine = LAIZE) |  |  |
fi_pose_st | Nombre de poses format impression (Sens travers = COUPE) |  |  |
fi_poses_inverse | Utilisation des poses inversées |  |  |
fi_pr_recto | Nombre de couleurs primaires au recto |  |  |
fi_pr_verso | Nombre de couleurs primaires verso |  |  |
fi_prise_pinces | Valeur de prises de pinces |  | X | X
fi_prod_ent, des_fi_prod_ent | Code produit de l'entité, Désignation du produit de l'entité |  |  |
fi_qteent | Quantité devisée (niveau entité) |  |  |
fi_quadri_r | Quadrichromie au recto |  |  |
fi_rainage | Présence de rainage |  |  |
fi_reperes | Largeur de la gamme de contrôle (ECMA) |  |  |
fi_resp_sens_pap | Respect sens papier (O/N) |  |  |
fi_resp_sens_pose | Respect du sens de pose |  |  |
fi_sdevis | Code sous-devis |  |  |
fi_sfm | Code sous-famille | X |  |
fi_tot_page | Nombre total de pages de l'entité. |  |  |
fi_tours_fxr | Nombre de tours fixe (gâche fixe) au recto / Surface U nette cm2 |  |  |
fi_tours_fxv | Nombre de tours fixe (gâche fixe) verso / Volume total (Ond) |  |  |
fi_tours_gcr | Nombre de tours gâche comprise recto / Surface totale en cm2(O |  |  |
fi_tours_gcv | Nombre de tours gâche comprise verso |  |  |
fi_tours_hgr | Nombre de tours hors gâche recto / Surface U brute en cm2 (O) |  |  |
fi_tours_hgv | Nombre de tours hors gâche verso / Poids total (O = Ondule) |  |  |
fi_transfert | Présence de transfert |  |  |
fi_typ_ent | Type de l'entité (COUverture, CAHier, ...) | X |  |
fi_type | Type de devis (F, Feuille C, Carton) |  |  |
fi_type_dimension | Cotes extérieures/intérieures |  |  |
fi_type_imbric | Type d'imbrication |  |  |
fi_type_pellic | Type de pelliculage | X |  |
fi_type_pre_presse |  |  |  |
fi_type_vernis_r | Type de vernis au recto | X |  |
fi_type_vernis_v | Type de vernis au verso | X |  |
fi_type_verso | Type du verso (Retournement, Délaminage) |  |  |
fi_typons | Nombre de jeux de typons fournis par le client |  |  |
fi_ve_recto | Pourcentage de vernissage recto |  |  |
fi_ve_verso | Pourcentage de vernissage verso |  |  |
fi_vernis_hl | Type de vernis hors-ligne | X |  |
fi_z1 | Carton : Rentrée de patte 1 roto : Nombre de pages (forcé) |  |  |
fi_z2 | Carton : Rentrée de patte 2 roto : Largeur finie (en mm) |  |  |
fi_z3 | Carton : Petite patte 1 roto : Hauteur finie (en mm) |  |  |
fi_z4 | Carton : Petite patte 2 |  |  |
fi_z5 | Carton : Petite patte 3 |  |  |
fi_z6 | Carton : Petite patte 4 |  |  |
fi_z7 | Carton : Patte de collage |  |  |
fi_z8 | Carton : Petite patte 5 |  |  |
fi_z9 | Carton : Petite patte 6 |  |  |
fi_z10 |  |  |  |
fi_z11 |  |  |  |
fi_z12 |  |  |  |
fi_zpar | Zone paramétrée |  |  |
fi_zpar2 | Zone paramétrée 2 |  |  |
fi_zpar3 | Zone paramétrée 3 |  |  |

Sous-devis

Les zones sont triées en ordre alphabétique.

La colonne lib signifie que les libellés court et long sont disponibles.

Par exemple : l2_devise (code devise) : libc_l2_devise (libellé court de la devise) et libl_l2_devise (libellé long de la devise).

La colonne cum indique que la zone peut être cumulée.

La colonne for indique que la zone est utilisable dans une formule de calcul.

Il manque des croix dans les colonnes cum et for. Merci de me les signaler .

Zone | Libellé | lib | cum | for
l2_a_calculer | Devis à calculer |  |  |
l2_adr_liv | Adresse de livraison |  |  |
l2_adresse | Code adresse d'envoi du devis |  |  |
l2_anul | Devis annulé |  |  |
l2_bareme | Tarif du devis | X |  |
l2_c_ma | Commission |  |  |
l2_c_mon | Base de calcul de la commission |  |  |
l2_c_pv | Montant de la commission |  |  |
l2_cde_marche | Présence d'une commande de marché |  |  |
l2_civilite | Civilité du correspondant | X |  |
l2_client, nom_l2_client | Code client, Nom du client |  |  |
l2_code_prod, des_l2_code_prod | Code produit, Désignation |  |  |
l2_cop_ren | Copie, Renouvellement, Génération (C, R, G) |  |  |
l2_corres | Correspondant |  |  |
l2_dat_liv | Date de livraison |  |  |
l2_date_cde | Date de transfert en commande |  |  |
l2_date_deb_marche | Date de début de marché |  |  |
l2_date_dec | Date de décision client |  |  |
l2_date_dev | Date de dernière modification du devis |  |  |
l2_date_edi | Date d'édition interne |  |  |
l2_date_fax |  |  |  |
l2_date_fin_marche | Date de fin de marché |  |  |
l2_date_rem | Date d'édition de la remise de prix |  |  |
l2_desdev1 | Désignation devis (ligne 1) |  |  |
l2_desdev2 | Désignation devis (ligne 2) |  |  |
l2_dev_cop | Devis d'origine |  |  |
l2_devis | Code devis |  |  |
l2_devise | Code devise (DEV) | X |  |
l2_deviseur | Code du deviseur | X |  |
l2_dossier | Numéro de dossier |  |  |
l2_edit_offre | Devis à éditer sur l'offre |  |  |
l2_env_matiere | Code d'environnement Matière | X |  |
l2_env_operation | Code d'environnement Opération | X |  |
l2_etat | Etat du devis | X |  |
z1_l2_etat | Valeur numérique 1 associé au code état |  |  |
l2_etat_avancement | Etat d'avancement du devis |  |  |
l2_etude | Code étude |  |  |
l2_fabricant | Fabricant | X |  |
l2_frais |  |  |  |
l2_frais_1 | Frais de clichés |  | X | X
l2_frais_1_negocie | Frais de clichés négociés |  | X | X
l2_frais_1_pr | Prix de revient des frais de clichés |  | X | X
l2_frais_1_pv | Prix de vente des frais de clichés |  | X | X
l2_frais_2 | Frais d'outils |  | X | X
l2_frais_2_negocie | Frais d'outils négociés |  | X | X
l2_frais_2_pr | Prix de revient des frais d'outils |  | X | X
l2_frais_2_pv | Prix de vente des frais d'outils |  | X | X
l2_m_1_ma | Marge matière ligne paramétrée 1 |  |  |
l2_m_1_pr | PR matière ligne paramétrée 1 |  |  |
l2_m_1_pv | PV matière ligne paramétrée 1 |  |  |
l2_m_2_ma | Marge matière ligne paramétrée 2 |  |  |
l2_m_2_pr | PR matière ligne paramétrée 2 |  |  |
l2_m_2_pv | PV matière ligne paramétrée 2 |  |  |
l2_m_f_ma | Marge matière fixe |  |  |
l2_m_f_pr | PR matière fixe |  |  |
l2_m_f_pv | PV matière fixe |  |  |
l2_m_ma | Marge supplémentaire |  |  |
l2_m_ma_bloque |  |  |  |
l2_m_pr | Base de calcul de la marge supplémentaire |  |  |
l2_m_pv | Montant de la marge supplémentaire |  |  |
l2_m_t_ma | Marge total matière |  |  |
l2_m_t_pr | PR total matière |  |  |
l2_m_t_pv | PV total matière |  |  |
l2_m_v_ma | Marge matière variable |  |  |
l2_m_v_pr | PR matière variable |  |  |
l2_m_v_pv | PV matière variable |  |  |
l2_mil | Prix du 1000 + |  |  |
l2_mille_negocie | Prix au mille négocié |  | X | X
l2_motif libc_l2_motif libl_l2_motif | Qualificatif d'état du devis Libellé court du motif devis Libellé long du motif devis | X |  |
l2_nb_fab_marche | Nombre de fabrication de marché |  | X | X
l2_nb_liv | Nombre de livraisons |  |  |
l2_nb_references | Nombre de références |  | X | X
l2_num_cahier | Numéro de cahier des charges |  |  |
l2_num_conception | Numéro de conception |  |  |
l2_num_forme | Numéro de forme |  |  |
l2_num_plan_cao | Numéro de plan CAO |  |  |
l2_o_1_ma | Marge opération ligne paramétrée 1 |  |  |
l2_o_1_pr | PR opération ligne paramétrée 1 |  |  |
l2_o_1_pv | PV opération ligne paramétrée 1 |  |  |
l2_o_2_ma | Marge opération ligne paramétrée 2 |  |  |
l2_o_2_pr | PR opération ligne paramétrée 2 |  |  |
l2_o_2_pv | PV opération ligne paramétrée 2 |  |  |
l2_o_f_ma | Marge opération fixe |  |  |
l2_o_f_pr | PR opération fixe |  |  |
l2_o_f_pv | PV opération fixe |  |  |
l2_o_t_ma | Marge total opération |  |  |
l2_o_t_pr | PR total opération |  |  |
l2_o_t_pv | PV total opération |  |  |
l2_o_v_ma | Marge opération variable |  |  |
l2_o_v_pr | PR opération variable |  |  |
l2_o_v_pv | PV opération variable |  |  |
l2_p_ma | Marge sur port |  |  |
l2_p_pr | Prix de revient port |  |  |
l2_p_pr_f | Part fixe du prix de revient port |  |  |
l2_p_pv | Prix de vente port |  |  |
l2_pour | Prix pour |  |  | X
l2_prix_negocie | Prix négocié |  | X | X
l2_px_ma | Marge globale sur devis |  |  |
l2_px_pr | PR devise |  |  | X
l2_px_pv | PV devise |  |  |
l2_qtedev | Quantité devisée |  |  | X
l2_refcli | Référence client |  |  |
l2_remis | Prix remis |  |  |
l2_representant | Code représentant | X |  |
l2_s_f_ma | Marge sous-traitance fixe |  |  |
l2_s_f_pr | PR sous-traitance fixe |  |  |
l2_s_f_pv | PV sous-traitance fixe |  |  |
l2_s_v_ma | Marge sous-traitance variable |  |  |
l2_s_v_pr | PR sous-traitance variable |  |  |
l2_s_v_pv | PV sous-traitance variable |  |  |
l2_sce_calcul | Scénario de calcul | X |  |
l2_sdev_cop | Sous-devis d'origine |  |  |
l2_sdevis | Code sous-devis |  |  |
l2_signature | Signataire | X |  |
l2_site | Site de production | X |  |
l2_suiv | Suivi d'affaire | X |  |
l2_taux_devise | Taux de change de la devise |  |  |
l2_tit_corres | Titre du correspondant | X |  |
l2_tol_maxi | Tolérance de quantité maximum |  |  |
l2_tol_mini | Tolérance de quantité minimum |  |  |
l2_transporteur, nom_l2_transporteur | Code du transporteur, Nom du transporteur |  |  |
l2_type_dev | Type de devis | X |  |
l2_type_finition | Type de finition | X |  |
l2_type_port | Type de port | X |  |
l2_type_prix | Type de remise de prix | X |  |
l2_type_prod | Type de produit | X |  |
l2_validite_deb |  |  |  |
l2_validite_fin |  |  |  |
l2_z1 | Zone paramétrée 1 (voir doc) |  |  |
l2_z2 | Zone paramétrée 2 (voir doc) |  |  |
l2_zchr1 | Zone paramétrée alphanumérique 1 |  |  |
l2_znum1 | Zone paramétrée numérique 1 |  | X | X
l2_znum2 | Zone paramétrée numérique 2 |  | X | X
l2_znum3 | Zone paramétrée numérique 3 |  | X | X
l2_zpar1 |  |  |  |
l2_zpar2 | Zone paramétrée code 2 |  |  |
l2_renouvellement | Sous-devis en renouvellement ou retirage |  |  |
l2_representatif | Sous-devis intégrable au C.A. prévisionnel |  |  |

Phases / gamme

ga_tot_mat | Total matière (Francs)
ga_ope | Temps opération
ga_tot_ope | Total opération (Francs)
ga_tot_str | Total sous-traitance (Francs)
ga_total | Total des phases
nb_ent | Nombre d'entité du sous-devis
using | Voir #VI

Autres zones

code_blocage libc_blocage libl_blocage | Code blocage Libellé court Libellé long
code_statut_blocage libc_statut_blocage libl_statut_blocage | Code de statut/déblocage BLO Bloqué DEB Débloqué [Autre] Motif de déblocage Libellé court Libellé long
val_statut_blocage | Statut actuel du blocage 1 Bloqué 0 Débloqué [Valeurs < 0] Débloqué avec motif
code_motif_deblocage libc_motif_deblocage libl_motif_deblocage | Code motif de déblocage Libellé court du code motif de déblocage (MDB) Libellé long du code motif de déblocage (MDB)
login_deblocage | Login de l'utilisateur ayant effectué le déblocage (Traçabilité)
date_deblocage | Date à laquelle a été effectué le déblocage (Traçabilité)
heure_deblocage | Heure à laquelle a été effectué le déblocage au format HH :MM (Traçabilité)
delai_dec_ouv | Délai de décision en jours ouvrés
delai_dec_non_ouv | Délai de décision en jours non ouvrés
delai_edi_ouv | Délai d'édition en jours ouvrés
delai_edi_non_ouv | Délai d'édition en jours non ouvrés
presence_dossier | Affichage d'un astérisque sur chaque ligne d'édition concernant un sous-devis si un numéro de dossier est présent. Affichage du nombre total de dossiers présents pour la sélection sur les lignes de totalisation. Colonne cumulable et utilisable dans les calculs (1=présence de dossier, 0=absence de dossier).

Afficher les libellés paramétrables correspondant aux valeurs des champs de présence sur références multiples.

Chaque libellé (court ou long) est récupéré pour le couple [champ de présence concerné]/[valeur courante] sur le paramétrage du type de processus (TPR).

Si aucun paramétrage n'est trouvé pour le champ de présence concerné, les libellés sont ceux correspondant aux valeurs par défaut H/L/S/N :

Libellés courts : H/L, Lig, Ss-T., Non

Libellés longs : Hors ligne, En ligne, Sous-traité(e), Non

libc_de_dorure | libl_de_dorure | Libellés court et long associés à la valeur courante de présence de dorure
libc_de_gaufrage | libl_de_gaufrage | Libellés court et long associés à la valeur courante de présence de gaufrage
libc_de_fenetrage | libl_de_fenetrage | Libellés court et long associés à la valeur courante de présence de fenêtrage
libc_de_foulage | libl_de_foulage | Libellés court et long associés à la valeur courante de présence de foulage
libc_de_rainage | libl_de_rainage | Libellés court et long associés à la valeur courante de présence de rainage
libc_de_transfert | libl_de_transfert | Libellés court et long associés à la valeur courante de présence de transfert/poudrage
libc_de_vignette | libl_de_vignette | Libellés court et long associés à la valeur courante de présence de vignette
libc_de_hologramme | libl_de_hologramme | Libellés court et long associés à la valeur courante de présence d'hologramme
libc_de_braille | libl_de_braille | Libellés court et long associés à la valeur courante de présence de braille


Transfert du devis en commande

Transfert du devis en commande tr_l_devis

Ancien programme tr_i_devis

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-NC | Caractères 4 à 9 : code client Exemple : -NCC00948
-ND | Caractères 4 à 15 : Numéro de devis et de sous-devis (permettant de récupérer le code client) Exemple : -NDN3040008/1

Valeur numérique 1

Numéro du compteur (nul par défaut). (Voir #SA CDE)

Options

Les options en majuscules sont en fin de liste.

-Oa

Numérotation automatique des codes produits (+ génération automatique dans mat)

Incompatible avec la génération de produits (-O5)

-Ob

On prend toujours le code représentant dans la fiche client

-Oc

Contrôle code client commande avec code client fichier matières / produits

-Od

Suivi de date (F16) sur entête commande

-Oe

Création automatique de l'entête de la commande à partir de la commande par défaut

-Of

MAJ famille et sous-famille de la ligne de commande (traitement spécial pour les lignes facturables uniquement :
Prendre la famille et la sous-famille de la 2ème ligne de commande si FB1, ou de la 1ère ligne de commande si FB2)

-Og

Génération du dossier après demande de confirmation

-Oh

Met dans la zone correspondant de la commande le correspondant utilisé dans le devis

-Oi

Transfert de frais matière en commande

Génère une ligne de commande avec le produit défini sur la formule

Cette ligne sera rattachée à la ligne de commande précédente (si ce n'est pas une ligne de frais)

-Oj

On conserve la désignation du devis sans reprendre celle du produit

-Ok

gl_faconnage_90 = true ?

-Ol

Recopie des dates de livraison sur les lignes suivantes

-Om

MAJ prix de vente et unité de vente du fichier matières / produits (active la touche F11)

-On

Les différentes adresses sont prises sur le devis

-Oo

Création automatique d'une copie du devis de base (si différent de PRO)

Le sous-devis généré porte le N° 99. Il sera utilisé en tant que fiche de fabrication

-Op

Transfert du prix revient (base négociation) ---> prix_client

-Oq

On prend l'adresse de facturation sur la zone paramétrée du devis l2_zpar1

-Or

Référence automatique (= numéro de commande)

-Os

En création d'adresse secondaire, par (F9), on met des blancs (par défaut on propose l'adresse principale du client)

-Ot

L'unité par défaut est pré-paramétrée

-Ou

Utilisation de l'unité de vente pour calculer le prix de vente issu du fichier mat/prod et le prix du mouvement de stock

-Ov

Réactualisation du sous-devis 99 à la création

-Ow

non utilisée

-Ox

Demande d'édition de l'aR dans la foulée. Voir zone alpha 3

-Oy

Déduction de la remise dans la mise à jour des statistiques commandes

-Oz

Déduction de l'escompte dans la mise à jour des statistiques commandes

-O0

non utilisée

-O1

non utilisée

-O2

Renseigne le poids en Kg dans la ligne de commande

(en partant de l'hypothèse que le poids était stocké en décagrammes)

-O3

Elimine certains frais dans tout le devis (à utiliser avec l'option -Oi) (voir notes du paramètre de lancement).

L'élimination de ces frais se fait une fois qu'ils ont été transférés, ce qui permet de ne les facturer qu'une fois

-O4

gl_recalcul_devis = true ?

-O5

Lance la génération des PF au moment du transfert en commande du devis

-O6

Recopie ligne de commande inter société (si sur une même base) (voir lignes de notes)

-O7

En recopie inter société, le lc_prxcli de la source devient le lc_prx de la cible

-O8

En recopie inter-société de lignes de commandes, on met à jour les quantités lancées

-O9

Le code devise est pris sur la fiche client et non sur l'entête du devis

-OA

Active le compteur annuel des commandes

-OB

Génération automatique des besoins en matières (table CDE5)

Voir #CF SMC, alpha2[6,12]

Voir CIC, chaînes C10 & C11

-OC

Mise en place de la recopie des cadencements de livraison lors de la recopie inter-société des lignes de commandes. Nécessite -O6

-OD

Transfert du prix de vente non margé pour l'article X

OG

Affichage du menu de lancement de la production (Génération ou régénération du dossier - Lancement du dossier - Edition de la fiche de fabrication) au 1er lancement et utilisation des choix du 1er lancement pour les autres lancements

Voir option Og - Celle-ci affiche le menu à chaque lancement.

-OI (i majuscule)

Gestion des frais sans rattachements au devis de la ligne de commande

(inclus l'option –Oi)

-OM

Transfert des marges du sous-devis dans le détail prix de la ligne de commande

-ON

Alimentation des CIC N54 (poids net) et N55 (surface nette) de l'article passé en commande à partir des données du devis.

ATTENTION : la mise en place de cette option active automatiquement l'option O2.

-OO

Activation de la gestion des options

-OV

Permet de réactualiser le devis 99 lorsqu'il a été généré par le transfert du devis en commande.
Si l'option n'est pas positionnée, le recalcul du devis n'est pas fait.

Valeur alpha 2

Transfert de type de note devis (note_ldev) vers type de note en commande (cde3)

On définit sur 6 caractères le transfert de notes à effectuer. Les 3 premiers caractères indiquent le type de note du devis à transférer, les trois caractères suivants indiquent le type de note de la ligne de commande où sont transférées les notes.

S'il y a plusieurs types à transférer, on définit tous les 6 caractères les types de notes à transférer.

Si, dans les 6 caractères, un des types définis est à blanc, alors pas de transfert de notes.

Exemple

0 10 20 60

!----+----!----+----!--[...]--!-

Valeur alpha 2 <021OE3022OE4NORNOR [...] >

xxx+++xxx+++xxx+++xxx+[...]+++

( )( )( )

Légende

xxx | Types de notes devis à transférer
+++ | Types de notes commande destination
( ) | Tous les 6 caractères : Couples des types à interfacer. (xxx ---> +++)

Ici, les notes de type 021 du devis à transférer seront recopiées dans les notes de type OE3 de la commande de destination

Les notes de type 022 du devis à transférer seront recopiées dans les notes de type OE4 de la commande de destination

Les notes de type NOR du devis à transférer seront recopiées dans les notes de type NOR de la commande de destination

Valeur alpha 3

Caractères 1 à 6 | Type et code du paramètre de lancement des AR
Caractères 7 à 12 | Type et code du paramètre de lancement du programme devis
Caractères 13 à 18 | Type et code du paramètre de configuration pour le recalcul du devis
Caractères 19 à 24 | Type et code du paramètre de configuration de la génération des PF (en standard : #CF GPF)
Caractères 25 à 27 | TYC par défaut des commandes générées
Caractère 28 | Génération du cadencement avec le tableau du transport du devis (Control-B) (O/N, O par défaut) Il faut activer l'option 43 de la fiche société (Gestion des cadencements de livraison avec stocks).
Caractère 29 | Mise à jour des cadencements de livraison : Code de validation d'administration des ventes Il faut activer l'option 43 de la fiche société (Gestion des cadencements de livraison avec stocks). O Validation (par défaut) N Aucune validation
Caractère 30 | Mise à jour des cadencements de livraison : Code de validation de la production Il faut activer l'option 43 de la fiche société (Gestion des cadencements de livraison avec stocks). O Validation (par défaut) N Aucune validation
Caractère 31 | Mise à jour des cadencements de livraison : Code de validation de la logistique Il faut activer l'option 43 de la fiche société (Gestion des cadencements de livraison avec stocks). O Validation (par défaut) N Aucune validation
Caractères 32 à 34 | Code de qualification du cadencement Il faut activer l'option 43 de la fiche société (Gestion des cadencements de livraison avec stocks).

Notes

DEL_FRAIS_MAT | Recherche de la famille dans les familles de produits pour lesquels les frais doivent être éliminés. 15,17 Code famille
PARAM_GEN_DOS | 21,26 Type et code du paramètre de lancement de la génération des dossiers Par défaut : #FBGDF
PARAM_REG_DOS | 21,26 Type et code du paramètre de lancement de la régénération des dossiers Par défaut : #FBRGD
PARAM_LAN_DOS | 21,26 Type et code du paramètre de lancement de la saisie des dossiers Par défaut : #FBDOS
PARAM_EDI_FIC_FAB | 21,26 Type et code du paramètre de lancement de l'édition des fiches de fabrication Par défaut : #EDFFA
PREFIXE_CODE_CIBLE | 21 à 23 Code identifiant de la société 25 Préfixe à apposer au code généré pour la société identifiée
TITRE_ENTETE_DATE | 21 28 Titre de date commande de l'entête Par défaut : Date cde
TITRE_ENTETE_LIBELLE | 21 36 Titre de libellé de l'entête Par défaut : Libellé commande
TITRE_ENTETE_NUMERO | 21 36 Titre de numéro de l'entête Par défaut : Numéro commande
TITRE_ENTETE_TYPE | 21 36 Titre de type de commande de l'entête Par défaut : Type de commande
TYC_POSSIBLES | 21 à 60 Liste des TYC autorisés en recopie de lignes inter société (chaque TYC doit être sur 3 caractères)

Options sur tr_i_devis

-Oa | Numérotation automatique des codes produits (+ génération automatique dans mat)
-Oc | Devis carton
-Oi | Devis imprimerie
-Op | Transfert en plusieurs fabrications
-Os | En création d'adresse secondaire, par (F9), on met des blancs (par défaut on propose l'adresse principale du client)
-Or | Si la référence n'est pas saisie, elle est automatiquement alimentée avec le numéro de commande.

Valeur numérique 1 sur tr_i_devis

Numéro du compteur (nul par défaut). Voir #SA CDE

Valeur alpha 2 sur tr_i_devis

Transfert de type de note devis (note_ldev) vers type de note en commande (cde3)

On définit sur 6 caractères le transfert de notes à effectuer. Les 3 premiers caractères indiquent le type de note du devis à transférer, les trois caractères suivants indiquent le type de note de la ligne de commande où sont transférées les notes.

S'il y a plusieurs types à transférer, on définit tous les 6 caractères les types de notes à transférer.

Si, dans les 6 caractères, un des types définis est à blanc, alors pas de transfert de notes.

Exemple

0 10 20 60

!----+----!----+----!--[...]--!-

Valeur alpha 2 <021OE3022OE4NORNOR [...] >

xxx+++xxx+++xxx+++xxx+[...]+++

( )( )( )

Légende

xxx | Types de notes devis à transférer
+++ | Types de notes commande destination
( ) | Tous les 6 caractères : Couples des types à interfacer. (xxx ---> +++)

Ici, les notes de type 021 du devis à transférer seront recopiées dans les notes de type OE3 de la commande de destination.

Les notes de type 022 du devis à transférer seront recopiées dans les notes de type OE4 de la commande de destination.

Les notes de type NOR du devis à transférer seront recopiées dans les notes de type NOR de la commande de destination.


Epuration des devis (Imprimeries, carton plat et mécanique)

Epuration des devis (Imprimeries, carton plat et mécanique) epu_dev

Options

-Oim | Epuration des devis feuilles
-Ost | Supprime les devis même s'il ont été transférés en commande. Sinon, les devis transférés sont supprimés uniquement si la commande n'existe plus.
-Ogr | Annulation groupée. L'annulation d'un devis se fait si chaque sous-devis répond au critère de sélection; sinon, aucun sous-devis n'est annulé. ATTENTION Cette option nécessite l'option -Oim

Valeur numérique 1

Nombre de jours de rétention par défaut des devis.

Date du jour - nombre de jour de rétention = date limite d'épuration à partir de laquelle les devis ne seront pas épurés.

Valeur alpha2

Caractères 1 à 5

Mot de passe. à blanc si pas de mot de passe.

Notes

S

3,60 Complément de sélection sur la table fle_2 (doit commencer par and)

Possibilité de saisir 98 numéros de devis

Sélection multicritère (avec le type devis et le code client)

Les tables suivantes sont épurées :

atmp

fle_2

fle_tra

meca_gam0

meca_nom0

meca_nom1

meca_note

note_ldev


Epuration des offres de vente

Epuration des offres de vente epu_don

Options

aucune

néant

Valeurs numériques

1 | Nombre de jours X. Obligatoire
2 | Nombre de jours Y. Obligatoire

Valeur alpha 2

A2[1,6] | Type et code du paramètre de lancement de l'offre de vente - obligatoire, doit exister
A2[7,9] | Motif de décision du client - obligatoire, doit exister
A2[14] | Mode test (O/N, N par défaut)
A2[15] | Affichage de la liste des références inutilisées (O/N, N par défaut) Un ensemble/référence (recherché selon le complément de sélection SUPREQREFKP du paramètre #CF/DKP) est considéré comme inutilisé si : • Le produit est associé à un numéro de devis/sous-devis (mat.mp_devis/mat.mp_sdevis) • Le produit n'est utilisé dans aucune offre de vente • Le produit n'est utilisé dans aucune ligne de commande

Notes

SD

3,60 Supplément de requête dans kp_demcli


Batch épuration des devis

Batch épuration des devis epu_odv

Traitement réalisé

Recherche de tous les devis (table od_demcli), avec application du complément de requête (Notes commençant par SD)

Pour chaque devis à traiter :

Si le devis a fait objet d'un accord

si pas épuration des devis acceptés alors

devis suivant

Si le devis a déjà été épuré (refus avec motif dédié à l'épuration automatique)

devis suivant

Le devis par défaut (00000000) n'est pas épuré.

Si le devis est référencé comme devis par défaut d'un client alors

devis suivant

Si une offre du devis contient un ensemble (E) ou un produit (P) ayant une validité à ne pas épurer alors

devis suivant

Si le devis est utilisé par un autre processus alors

devis suivant

Si le devis a au moins un sous-devis 99 alors

devis suivant

Si le devis contient au moins une offre en dehors de la période d'épuration

devis suivant

Si le devis n'a pas d'offre

le devis est supprimé (od_demcli et tables filles)

La table od_demcli est mise à jour (refus, motif de refus automatique, date)

Pour chaque offre du devis à épurer

Epuration offre

Table od_etat (table des états de l'offre)

Table od_1etat (table des frais de premier établissement)

Table od_seqact (table des coûts supplémentaires)

Table od_carseq (table des caractéristiques des coûts supplémentaires)

Table od_s_op (table des résultats de calcul de gamme)

Table od_s_co (table des résultats de calcul de matière)

Table note_ldev (table des commentaires)

Epuration de l'article E

Si ensemble utilisé dans au moins une ligne de commande client non annulée

Pas de suppression

Pour chaque composant de l'ensemble

Suppression du composant (P) (table mat et toutes les tables liées)

Suppression de l'ensemble (E) (table mat et toutes les tables liées)

Table od_recap_tot (stockage des récap de calcul)

Table od_recap_pf_cs (stockage des récap de calcul des coûts supplémentaires)

Table od_offre (table des offres)

Les traitements étant assez longs, il est conseillé de traiter mois par mois dans un premier temps.

Il est préférable de lancer le programme en mode batch (-B).

Le système génère un fichier trace : epu_odv.out (dans le répertoire de lancement du programme)

Valeurs numériques

1

Nombre de jours de rétention (on n'épure que les offres dont la date de fin de validité est dépassée de plus de X jours)

Valeur alpha 2

A2[1,6] | Type et code du paramètre de lancement du module devis. Sert à récupérer certains paramétrages du devis. Exemple : #SADEV
A2[14] | Mode simulation (O/N, N par défaut) En mode simulation, aucune épuration n'est réalisée. Mettre N pour lancer l'épuration.
A2[15] | O Refus automatique, sans épuration Il faut alors que le motif de refus devis RAU (Refus automatique, type de paramètre MOT) soit créé. N Epuration automatique Il faut alors que le motif de refus devis EPU (Epuration automatique, type de paramètre MOT) soit créé. Mettre N pour lancer l'épuration.
A2[16] | O Epuration des devis même s'ils ont été acceptés N Pas d'épuration des devis qui ont été acceptés Préférer le mode N.

Notes

REPERTOIRE_EPU_ODV | 21,60 Répertoire de destination du fichier trace Remarque : La chaîne saisie ne doit pas finir par / (slash), ce caractère étant ajouté automatiquement avec le nom du fichier (epu_odv.out).
SD | 21,60 Supplément de requête sur la table od_demcli pour restreindre les devis à épurer.
SUP_REQ_MAT_QUALITE | 21,60 Supplément de requête sur la table mat pour exclure des qualités Exemple and mp_qualite = "FIN"


Edition de la liste des devis reliures

Edition de la liste des devis reliures l_dev_bru

Options

Sans option | Sélectionne uniquement les devis (la numérotation des devis : ????xxxx comprise entre : ????0001 < ????xxxx < ????4999 )
-Odf | Sélectionne les devis et les fiches de fabrication
-Off | Sélectionne uniquement les fiches de fabrications (la numérotation des fiches de fabrication : ????xxxx comprise entre : ????5000 < ????xxxx < ????9999 )


Recherche d'une fiche de fabrication

Recherche d'une fiche de fabrication main_rfich

Affiche une liste de fiche de fabrication

Recherche par le titre, le numéro de fiche, le numéro de devis, le code client


Edition - Envoi des commandes carton, cartes à dos par fax

Edition - Envoi des commandes carton, cartes à dos par fax fax_cdef

Ce module permet d'éditer et d'envoyer des commandes carton et cartes à dos par fax

Valeur alpha2

Nom du programme d'envoi de fichier texte sur le fax (programme SEDIR).

Exemple /usr/fax/bin/posefax

Valeur alpha3

Paramètre à passer au programme dont le nom a été indiqué dans la valeur alpha 2

(options conseillées -p 0 -e 200 -r 3 )

Complément d'information sur le programme posefax de SEDIR

posefax | Cette commande permet de déposer un document dans la file d'attente d'émission
Syntaxe | posefax nom_document numéro_destinataire

Voici la liste des options que l'on peut mettre dans la valeur alpha 3 (fax_cdef envoie lui même le nom du document et le numéro du destinataire).

-d yymmdd

Pour préciser la date d'envoi

-h hhmm

Pour préciser l'heure d'envoi

-p priorité

Modifie la priorité de la requête d'émission (0 très prioritaire, 5 le moins prioritaire).

-e nb_essais

Nombre d'essais voulus

-r delai_de_reessai

Ecart temps en minutes entre deux essais

-t

Demande de ticket de retour

Ticket de retour

Si cette option est précisée, un numéro vous est donné, qui correspond au nom du fichier qui sera créé sur le répertoire de réception des tickets lorsque le document sera émis ou abandonné.

Exemple posefax test 32495166 -t

On vous répond 6351

Tant que le document est en file d'attente, le ticket de retour n' est pas donné

Puis deux possibilités :

  • Le document est émis : Le spooler crée un fichier 6351-p sur le répertoire de réception des tickets, ce fichier contient le mot OK

  • Le document est abandonné : Le spooler crée un fichier 6351-p qui contient la phrase ABANDON:B,si B est le motif d'abandon


Tarif carton

Tarif carton ccar

Notes saisies sur le paramètre de lancement = codes fournisseurs à traiter (chaque ligne de note doit commencer par F)

Pour le calcul des tarifs voir aide en ligne sur devis reliure


Edition de la fiche de fabrication

Edition de la fiche de fabrication edi_bruf

Options

-Off

Edition fiche de fabrication (obligatoire)


Edition des offres de prix

Edition des offres de prix prx

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[ec_num]

Options

-Oal | Prise en compte de l'adresse de livraison de l'entête de la PRX
-Oaf | Prise en compte de l'adresse de facturation de l'entête de la PRX
-Oad | Prise en compte de l'adresse de devis du fichier client (écran F8)
-Oar | Prise en compte de l'adresse de l'accusé de l'entête de la PRX
-Ocp | Edition de la contrepartie

Notes

S | Complément de select sur les entêtes de commandes et lignes de commandes ATTENTION Une seule clause par ligne Exemple S and ec_tyc = "RES" S and lc_fam = "IMP" et non pas S and ec_tyc= "RES" and lc_fam = "IMP"
ORBER_BY | 21, 60 Paramétrage de l'ordre de tri pour l'édition sur les lignes de commande. La liste des champs ne doit comporter que des champs de la table cde2. Exemple ORDER_BY lc_prx, lc_prod


Transfert des offres en commandes

Transfert des offres en commandes tr_l_cde

Valeur numérique 1

Numéro du compteur (nul par défaut). Voir cde

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[ec_num]

L'option Ost est activée automatiquement.

Options triées

O01 | Aide de type 1 sur saisie référence Référence = Numéro commande
O02 | Aide de type 2 sur saisie référence Référence = Client - Nombre commandes
O03 | Aide de type 3 sur saisie référence Référence = Client - Millésime de la commande - Nombre commandes
Oas | En création d'adresse secondaire, par (F9), on met des blancs (par défaut on propose l'adresse principale du client.)
Oco | Transfert de toutes les notes de la proposition
Odl | Ouverture d'une fenêtre en création d'entête pour saisir les dates lc_delcli, lc_delrep, lc_delfab.
Odm | Possibilité par F12 de modifier les dates de livraison de toutes les lignes (mêmes dates pour toutes les lignes)
Odo | Saisie non obligatoire des 3 dates de livraison saisies sur l'entête
Oe4 | Déduction de l'escompte entête dans le calcul du CA commandé
Ony | Numérotation annuelle des commandes
Or4 | Déduction des remises entête et lignes dans le calcul du CA commandé
Ost | Gestion des articles standard et hors standard
Ot1 | Recopie des TSC de l'entête de la PRX
Ot2 | Recopie des TSC des lignes de la PRX
Oxm | Ouverture auto de la fenêtre de gestion des fax/emails à la validation de la commande

Valeur alpha 2

Caractères 1 à 6 | Type et code du paramètre de lancement de la saisie de commande
Caractères 7 à 12 | Type et code du paramètre de lancement pour l'édition de l'AR
Caractères 13 à 18 | Type et code du paramètre de lancement pour la ré-édition de l'AR

Notes

ART_STD_HORS_STD

21 à 23 TYC des commandes standard et hors standard générées. Obligatoire

24 à 26 Mode Franco de port de la commande hors standard générée. Obligatoire

27 à 29 Delta en jours à ajouter aux délais de la commande PRX pour obtenir les délais de la commande standard générée. 0 par défaut. Facultatif

30 à 32 Delta en jours à ajouter aux délais de la commande PRX pour obtenir les délais de la commande hors standard générée. 0 par défaut. Facultatif

33 à 38 Type et code du paramètre d'édition des AR des commandes standard et hors standard générées. Facultatif

39 Flag de suppression de la commande PRX après la génération des commandes standard et hors standard (O/N)


Etat des propositions en attente

Etat des propositions en attente prx_ed1

Valeur numérique 1

Nombre de décimales des quantités

Options

-q | Est utilisé pour passer au programme d'édition les critères d'édition. Le dernier mot de la requête, doit aussi se terminer par -q Exemple prx_ed1.4ge -sMPR -d8809 -qcde2.ec_afa <> 0-q
-OST | Configuration standard Colonnes d'édition = BDAGEHJPQRC
-ONS | Configuration type non standard (type Lemercier) Colonnes d'édition = BDFGEHJPQRC
-Ocd | N'édite pas de total commande
-Ocl | N'édite pas de total client
-Oee | Sélection écran simplifié
-Oes | Déduction de l'escompte
-Oge | N'édite pas de total général
-Old | N'édite pas de ligne détail
-Ore | Déduction de la remise
-Osl | Saut de ligne entre chaque ligne de commande
-One | Edition des notes d'entête
-Onl | Edition des notes de ligne

Valeur alpha 2

Paramétrage des colonnes entête et ligne de commande

Valeur alpha 3

Titre de l'état

Valeur alpha 4

Caractères 1 à 3 | Type de note éditée
Caractères 4 à 5 | Largeur maximale de la colonne Libellé du produit à éditer
Caractères 6 à 7 | Largeur maximale de la colonne Adresse livr. à éditer
Caractères 8 à 9 | Largeur maximale de la colonne Ville livr. à éditer
Caractères 10 | Tri par défaut (1 à 2) 1 Client, date, offre, ligne 2 Offre, ligne

Notes

S

Complément de select sur les tables cde1 et cde2
Exemple
Sand ec_sold = O
S and lc_fam = PAP
Attention, si le complément est sur plusieurs lignes, elles sont concaténées sans ajout de blanc entre chacune d'entre elles


Edition des demandes de tarif

Edition des demandes de tarif de_ta

Ce programme sert à simuler des demandes de prix sur tarif.

Options

-Obr | Edite le total HT au lieu du total TTC dans l'édition
-Orm | Prise en compte du fichier remises
-Ost | Saisie standard
-Otr | Prise en compte du fichier tarifs
-Ose | Saisie des lignes de commande type SECF.
-Oth | Saisie des lignes de commande type T (Standard). Pas de saisie de remise
-Oht | Saisie de commandes TTC ou HT, la confirmation du type de saisie est demandée à l'utilisateur au lancement du programme
-Ott | Saisie toujours TTC
-Otl | Visualisation total ligne et du prix unitaire
-Opu | Recherche du tarif sur prix de vente de base (mp_pv) Affichage du prix unitaire de vente de l'article Possibilité de le modifier Calcul du tarif à partir de ce nouveau prix
-Otp | F11 total produit seulement

Valeur alpha 2

[Pas de paramètres]

Valeur alpha 3

[Pas de paramètres]

Valeur alpha 4

[Pas de paramètres]

Notes

[Pas de paramètres]


Mise à jour de l’OTIF en mode Batch

Mise à jour de l'OTIF en mode Batch outil_otif

Ce programme est utilisable à partir de la V. 4.1.46.2

OTIF = On Time In Full

Voir aussi : #CF OTI

Notes

CODE_NTS_TRACE | 21,23 Code paramètre de type NTS. Sauvegarde le fichier trace dans une note formatée lié à la traçabilité des appels de programmes (table numéro 28)
FICHIER_TRACE | 21,60 Nom et répertoire du fichier de trace de la mise à jour de l'OTIF.
_SUP_REQ_OTIF_BL | 21,60 Supplément de requête pour les BL à exclure lors de la recherche des BL rattachés à la ligne de commande.
_SUP_REQ_OTIF_CDE | 21,60 Supplément de requête pour les commandes qui vont être mises à jour.

Le but est de calculer les indicateurs de l'OTIF.

Cet outil peut être utilisé pour mettre à jour les anciennes lignes de commandes déjà soldées.

Lors du solde de la ligne de commande commerciale, les zones suivantes sont mises à jour.

Ces zones sont dans la table cde2.

Zone

Utilisation

lc_otif_calcule

L'OTIF a été calculé pour cette ligne de commande.

Cette colonne est à 1 pour toutes les lignes de commande pour lesquelles l'OTIF a été calculé, c'est à dire les lignes de commandes livrables et soldées en livraison.

Dans tous les autres cas, elle est égale à 0.

Utile pour le calcul du pourcentage de l'OTIF avec ReflexClient.

lc_ot_flag

ON TIME

Cette colonne contient un indicateur booléen traduisant le fait qu'on est en respect (1) ou pas (0) sur le délai.

Il suffit d'un BL en avance ou en retard par rapport aux tolérances de délai pour qu'on soit en non-respect.

lc_ot_nbj_retard

Nombre de jours de retard ou d'avance

Cette colonne contient :

– zéro : si les BL associés à cette ligne de commande sont tous dans la plage de date (date mini, date maxi) induite par la tolérance de livraison.

– un nombre positif décrivant le nombre de jours de retard du BL le plus en retard.
Ce nombre de jours de retard se mesure par rapport à la date maxi de la tolérance et non par rapport à la date de livraison attendue.
Si on a un BL avec 1 jour de retard et un autre avec 3 jours de retard, on retient la valeur 3.

– un nombre négatif décrivant le nombre de jours en avance (par rapport à la date mini de tolérance livraison).

Les retards sont prioritaires, autrement dit, le nombre de jours d'avance n'apparaît que dans la mesure où il n'existe aucun autre BL en retard.

lc_if_flag

IN FULL

Cette colonne contient un indicateur booléen traduisant le fait que l'on est en respect (1) ou pas (0) sur les quantités livrées.

La somme des quantités livrées sur l'ensemble des BL associés à cette ligne de commande est comparée à la plage de quantités mini et maxi induite par la quantité commandée et la tolérance quantitative.

lc_if_qte_excedent

Quantité en excédent

Cette colonne contient :

– zéro : si la quantité livrée se situe dans la plage de tolérance quantitative.

– une valeur positive représentant la quantité livrée en trop au-delà de la quantité tolérée maxi.

– une valeur négative représentant la quantité livrée manquante en deçà de la quantité tolérée mini.

lc_otif_valide

OTIF de la ligne de commande.

Contient (1) si la ligne de commande respecte le délai et la quantité et (0) sinon.


Saisie des factures SBI

Jusqu'à présent, pour saisir les factures SBI, il fallait attendre le numéro de facture fourni par le client.

Maintenant, en activant l'option Osi, on peut saisir des factures provisoires.

Cela permet de préparer la facture avec un numéro généré automatiquement en attendant le numéro de facture définitif.

Lorsque le client communique le numéro de facture définitif, il suffit d'ouvrir la facture provisoire et via l'action Création facture réelle (touche F12), l'application demandera de saisir le numéro communiqué par le client.

Une fois cette action faite, la facture provisoire est supprimée et la facture définitive est créée.

Ensuite, il faut suivre les démarches habituelles pour faire le calcul de la facture.

Nota : les factures provisoires sont exclues des programmes de calcul de facture.

Par défaut, lorsque la facture est dite simulée (ou provisoire) la case En attente est cochée et bloquée contre toute modification.

Saisie des factures SBI sbi

Saisie des factures SBI (SELF BILLING INVOICE)

Options

Ocs | Mode consultation seule
Oit | Initialisation des colonnes (qté facturée, prix unitaire facturé et date de livraison) du tableau des BL lors de la saisie
Osi | Créer des factures simulées Cette option permet par exemple de préparer la facture en attendant le numéro de facture définitif fourni par le client. Plus d'info
Otf | Pas de top fin de mois

Valeur alpha 2

A2[1,3] | Code paramètre du TOP de fin de mois
A2[7,8] | Mot de passe pour le top de fin de mois
A2[9,11] | Nombre de jours en moins par rapport à la date du jour pour le début de l'intervalle. Cet intervalle sert à pré-remplir le tableau des BL à facturer.
A2[12,14] | Nombre de jours en moins par rapport à la date du jour pour la fin de l'intervalle. Cet intervalle sert à pré-remplir le tableau des BL à facturer.

Notes

CODE_CLIENT_DEFAUT | Code client. Ce paramètre permet d'initialiser le code client de l'entête de la facture SBI.
_SUP_REQ_LST_BLV | 21,60 Complément de requête pour le pré-remplissage du tableau des BL à facturer. Ce complément porte sur les tables suivantes : blv1, blv2 et cde2.


Saisie des commandes clients

Exemple de paramétrage :

LIGPARCFDates Cli. : *lc_delcli*8*dd/mm/yy*

LIGPARCFFab. : *lc_delfab*8*dd/mm/yy*

LIGPARCFLiv. : *b1_datl*8*dd/mm/yy*

LIGPARCFFac. : *fe_date*8*dd/mm/yy*

Saisie des commandes clients cde

Valeurs numériques 1 et 2 Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes du paramètre de lancement

Saisie du détail du prix Paramètres associés Contrôle laboratoire - blocage laboratoire REVUE DE CONTRAT

Transfert de commande sur un autre site Accès à la GED Initialisation du qualificatif Réactualisation du récapitulatif des coûts

Voir aussi #CF CDE et TYC

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action : saisie Caractères 3 et suivants : Numéro de commande Exemple : -N[ec_num]
-NC | Action : saisie/programme appelant : commandes, par défaut Caractères 3 et suivants : Numéro de commande Exemple : -NC[lc_num]
-ND | Action : saisie/programme appelant : devis multi-métiers, transfert en commande Caractères 3 et suivants : Numéro de commande Exemple : -ND[l2_dossier]

Valeurs numériques

1 | Numéro du compteur (nul par défaut). Il faut créer des compteurs par défaut si on utilise les numéros de compteur. Le compteur numéro 9999 est réservé à une numérotation particulière. Le folioteur sur 4 après l'année et le mois n'est remis à zéro qu' en début d'année.
2 | Numéro du compteur de commande fournisseur

Exemple 1 | Numéro de compteur = 1 pour la saisie des commandes cpt.cp_soc = XXX cpt.cp_typ = C cpt.cp_num = 1 cpt.cp_aamm = 9999 cpt.cp_cpt = 99990000 Les commandes sont numérotées à partir du numéro 1 de chaque mois.
Exemple 2 | Numéro de compteur = 2 pour la saisie des propositions cpt.cp_soc = XXX cpt.cp_typ = C cpt.cp_num = 2 cpt.cp_aamm = 9999 cpt.cp_cpt = 99994999 Les propositions sont numérotées à partir du numéro 5000 de chaque mois.

Options triées

O01

Aide de type 1 sur saisie référence. Référence = Numéro commande

O02

Aide de type 2 sur saisie référence. Référence = Client - Nombre commandes

O03

Aide de type 3 sur saisie référence. Référence = Client - Millésime de la commande - Nombre commandes

O22

Le passage dans la visualisation des dossiers en cours se fait d'après le numéro de dossier de rattachement

O2r

Utilise le champ ec_suiv pour contenir un code représentant supplémentaire

Oa1

Contrôle cohérence prix entre une CD1 et sa CDA d'origine

L'option Ovc doit être paramétrée pour les contrôles en saisie de CD1.

Explications

Pour une CD1 avec produit asynchrone : on récupère le prix sur la CDA d'origine et ce prix est non modifiable.

Pour une CD1 avec produit synchrone : on ne récupère pas le prix de la CDA d'origine. Le prix est saisissable et modifiable.

C'est le premier produit constituant l'ensemble qui détermine si l'on est dans le cas d'un article synchrone ou asynchrone.

Oa5

Accès automatique à la saisie des besoins après génération automatique des besoins matières - Voir TYC A4[42].

Oaa

Affichage de la désignation de l'article en bas de l'écran.

Cette option ne doit pas être utilisé si l'option Oal est déjà positionnée.

Oac

Affectation de commande d'achat sous la forme constante commande-ligne/1 lors d'une séquence d'ensemble à zéro.

Oad

Saisie adresse de livraison dans la fenêtre de saisie des dates de livraison.

Uniquement sur les lignes de commande

Oae

Code édition AR de la commande mis à éditer O

si modification de la quantité commandée

ou si modification du délai répondu

ou si modification de l'adresse de livraison

ou si modification de la laize ou de la coupe pour les articles cartonniers

ou si modification des informations complémentaires

OaE

Code de l'édition de l'AR mis à éditer si le prix ou le montant de la remise a été modifié sur la ligne de commande.

(S'utilise avec l'option 0ae)

Oaf

Actualisation des FBI générées en édition d'accusés de réception.

Cette option fonctionne avec alpha1[34] du TYC de la commande.

(Génération de FBI en édition d'accusés de réception). Elle doit être à O.

Si modification, modification automatique des FBI générées : mise à jour de la quantité commandée, de la quantité lancée, de la date de fin de fabrication prévue et passage à 2 du code génération dossier, si le dossier est déjà généré.

Si annulation, annulation automatique des FBI générées.

Passage à 2 du code génération dossier si le dossier a déjà été généré.

OaF

Code de l'édition de l'AR mis à éditer si le code de qualification de l'appel a été modifié sur la ligne de commande.

S'utilise avec l'option Oae

Oal

Affichage du libellé de la ligne de commande en bas de l'écran

Oan

Forcer l'annulation des FBI même si celles-ci ont été modifiées manuellement

Lors d'une suppression de commande CD2, les FBI liées ne sont pas supprimées si elles ont été modifiées manuellement (quantité, délai de fabrication, tolérance de livraison, qualificatif d'appel).

Cette option permet de passer outre ce contrôle.

Elle ne sert que si le type de modification est une annulation.

Oap

Annulation des prévisions de stock (entrées prévisionnelles) lorsqu'on solde

une commande

ou une ligne de commande

ou une ligne de nomenclature

ou une ligne de cadencement

Entrée prévisionnelle de fabrication

de la ligne de commande

ou de la ligne de nomenclature

Entrée prévisionnelle de livraison du lieu intermédiaire

de la ligne de commande

ou de la ligne de nomenclature

ou de la ligne de cadencement

Oar

Annulation des reliquats de stock (sorties réservées) lorsqu'on solde :

- une commande

- ou une ligne de commande

- ou une ligne de nomenclature

- ou une ligne de cadencement

Recréation des reliquats de stock (Sorties réservées) lorsqu'on désolde une ligne de commande ou une ligne de nomenclature

Oas

En création d'adresse secondaire, par (F9), on met des blancs.

(par défaut on propose l'adresse principale du client.)

Oau

Edition automatique des AR (même après modification de la commande)

Option nécessaire pour le fonctionnement de alpha4[2]

Oav

Cette option permet d'enlever la vérification sur le contrôle de cohérence entre le client de la commande et celui de la commande de rattachement. Si on ne met pas cette option, il est impossible de choisir une commande de rattachement possédant un code client différent du code client de la commande.

Oba

Gestion des barèmes

L'option payante CDE-8 (Saisie des barèmes) doit être activée.

L'option société 39 (Gestion des prix au mille +) doit être positionnée.

Les options One, Ose, Oth et Ov1 sont interdites.

Obc

Ne pas mettre à jour les besoins, si ceux-ci ne sont pas encore générer par la visualisation des dossiers

Nouvelle gestion des besoins, #CF ATL A4[57]

Obd

Blocage délai

Lors de la charge, si celle-ci est incomplète car hors calendrier, alors mettre en place le code blocage Forçage délai

Obl

Autorise la modification du délai répondu sur les lignes de commande portant sur des ensembles dont un élément a déjà été livré.

En l'absence de cette option, l'utilisateur peut être bloqué en saisie de FB2.

Ce blocage est un fonctionnement assez spécifique concernant très certainement les clients générant des FBI à partir des commandes commerciales.

Oc0

Conservation du tarif de la ligne en reliquat

Oc1

Conservation de la remise de la ligne en reliquat

Oc2

Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne

L'un des 2 codes doit être saisi

Oc3

Pour le contrôle du conditionnement, utiliser l'unité de conditionnement mp_cond

Oca

Affichage du LxBxH en saisie de lignes de commandes

Ocb

Concatène le code client avec le radical comptable

(équivalent à l'option Orc de la saisie des clients)

Occ

Contrôle autorisation de modification de champs dans le cas où la remontée de la production sur le dossier a déjà commencé. Voir alpha3[12] du TYC ainsi que les notes commençant par CSP et CMC

Ocd

F11 Contrôle date (sur date commande uniquement)

Ocf

Fige le code client spécifié en alpha3[1,6]. Il devient alors impossible à modifier

Ocg

Affectation du correspondant de l'adresse de facturation comme correspondant de la commande.

Och

Recherche automatique de la plage horaire de la date de départ avec le calendrier client

Oci

Affichage des stocks de l'article d'indice précédent

Voir #CF ATL, notes commençant par PARAM_INDICE_ART_X

Ocl

Synchronisation du cadencement de livraison avec la revue de contrat

Avec cette option, on synchronise certaines données de la revue de contrat avec celles de la première ligne de cadencement de livraison (et inversement).

Ces données sont les suivantes :

les 4 dates (demandée, proposée, client et fabrication)

la tolérance quantité livrée

l'adresse de livraison (si so_options[19] = O)

l'adresse de facturation (si so_options[37] = O)

Ocm

Gestion d'un compteur manuel

Permet de gérer un compteur sans tenir compte de l'année et du mois

Incompatible avec l'option Ony (numérotation annuelle)

Ocn

Recopie automatique des notes article (d'un type donné paramétré en A3[16,18]), vers les notes de ligne de commande client (d'un type paramétré en A3[19,21]).

Voir la note NTS

Oco

Saisie à chaque ligne de commande du taux de commission représentant (sans passer par F8)

Ocp

Ouverture automatique d'une fenêtre de création si le code client saisi n'existe pas.

Cette option est désactivée par l'option Opi.

Ocr

Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne

L'un des 2 codes doit être saisi. Si les 2 sont saisis, ils doivent être différents

Ocs

Active la prise en compte du nom du correspondant sur l'adresse d'AR

Oct

Saisie du code TVA sur

La première ligne si TYC différent de FB1

La deuxième ligne si TYC = FB1

si nouvelle ligne et duplication du code TVA de cette ligne à chaque création de ligne

Ocu

Touche Ctrl U activée sur les lignes de commandes.

Affichage d'un tableau type Ctrl Z avec possibilité de saisir des notes sur l'entête de commande ou d'accéder à l'entête de commande.

Voir les notes de type ACCES_DEPUIS_CDE_PST

Ocv

Si la commande est valide (possède une ligne non annulée), on interdit la modification du code client de l'entête par la touche F8.

Oda

En configuration multi-site, l'application prend par défaut le lieu de déstockage dans le paramètre SIT.

Avec cette option, on inverse les priorités, c'est-à-dire que le lieu de déstockage de l'article est pris en priorité sur la fiche article.

La note C_FAM_ART_DES_SIT permet d'exclure des codes familles que l'on préfère mettre en priorité sur le lieu du paramètre SIT.

Tableau de bord du multisite

Odb

Ne pas relancer la génération du besoin, dans le cas de la seule modification du délai, et que les besoins déjà existant ont été ignorés (état à N)

Odc

Initialisation de la date de création du flash à la date de la commande

Odd

Permet de ramener en saisie de ligne de commande pour une FB1 le code de l'article de la ligne précédente.

Ode

Saisie des trois dates de la ligne de commande par une fenêtre en fin de ligne

Odf

La date du mouvement d'entrée prévisionnelle est égale au délai de fabrication (à la place du délai répondu)

ODF

Devis de fab : visualise le sous-devis 99 au lieu du sous-devis lc_sdev

Odi

les dates de livraison lc_delcli, lc_delrep, lc_delfab ne sont pas initialisées avec les dates de la ligne précédente.

Odl

Ouverture d'une fenêtre en création d'entête pour saisir les dates lc_delcli, lc_delrep, lc_delfab

Odm

Possibilité par F12 de modifier les dates de livraison de toutes les lignes (mêmes dates pour toutes les lignes)

Odo

Saisie facultative des 3 dates de livraison (si option Ode ou Odl)

Odr

Conserve le détail du calcul de la remise dans le fichier note (enregistrement 1 du type note #RE)

Odt

Délai pris sur la ligne de commande de rattachement (articles facturables uniquement)

Odu

Le prix retourné de la fenêtre F7 prix est divisé par la quantité commandée de la ligne de commande

Odv

Contrôle de la date de validité des PF

Cette option permet de vérifier la date de validité des PF par rapport à la date de la commande.

Le contrôle se fait dans l'ordre suivant :

– On vérifie la date de fin de validité positionnée sur le TSC 330.

– Si aucune date n'est trouvée sur le TSC 330, on prend celle qui est sur la fiche article (date de fin de validité).

– Si aucune date n'est présente alors l'article est considéré comme valide.

Oe4

On ne tient pas compte de l'escompte dans la mise à jour du CA en commande

Oea

Enchaînement automatique entête - lignes

Oeb

Force la génération des factures ou avoirs (FAD ou AVO) lors de la génération de la DEB associée.

Conditions de la génération

Factures intracommunautaires

TYC de rattachement FAD ou AVO

Produit facturable uniquement

Oec

Le lieu de niveau 1 pour les mouvements de stock est le site de production saisi en entête et non celui de la fiche article

Tableau de bord du multisite

Oef

Passer en paramètre à l'édition de facture le numéro de commande courant

Oei

L'accès au menu Edition (de facture) est interdit

Oen

Saisie uniquement des ensembles livrables et facturables et des frais

Oer

Demande de confirmation de l'édition ou de la réédition de l'AR que l'on vient de modifier

Ofa

Pouvoir saisir des produits non cartonniers (frais par exemple) dans la saisie des commandes cartonnier (FB2).

L'option Otc est obligatoire.

Ofc

Recherche sur produit des lignes du contrat

Cette option permet de modifier la recherche d'un produit (F7).

La fenêtre de recherche habituelle fait place à une autre fenêtre :

On visualise les lignes de contrat auquel est rattachée la commande en cours avec code produit, libellé, prix et quantités.

L'ordre de priorité est le suivant :

1) Saisie des commandes clients, option Ofc (ici)

2) LIE A1[6]

3) #CF CDE A1[48]

Ofe

La touche de fonction F13 sur les lignes de commande se comportera de la même manière que le F14 sur la saisie de l'entête de commande. La touche F13 permettra donc de positionner à facturer la totalité de la commande.

Ofm

Ouverture fenêtre pour mise à jour du mouvement de stock dans le cas d'un changement d'état du mouvement

Ofo

Saisie du prix de la forme sur la ligne de commande

La saisie est paramétrée sur la sous-famille ou la famille.

La recherche se fait d'abord sur la sous-famille de la ligne de commande, puis sur la famille de la ligne de commande.

La saisie est faite en fin de ligne.

En création de ligne de commande, la touche DEL n'est pas autorisée.

Le prix de la forme doit être différent de 0.

Ofr

Affichage de la fenêtre des commandes non soldées.

Si cette option est absente, toutes les commandes correspondants à la sélection seront soldées.

Ofs

Maj famille et sous-famille avec la famille et la sous-famille de la ligne 1 si FB1

Oft

En modification de commande, les quantités sont reportées dans la FBI par delta sans tenir compte du code de tolérance de livraison.

Ofu

Force l'ouverture d'une fenêtre de saisie de paramètre après la saisie de la quantité d'une ligne de commande pour valider ou modifier l'unité de vente.

Og5

Génération automatique des besoins en matières (table cde5)

Voir A1[14] de QA XXX où XXX est le code qualité de l'article

Voir #CF SMC,A2[6,12]

Voir CIC, chaînes C10 et C11

Voir TYC A4[42]

Ogc

Gestion des contrats

Cette option doit apparaître sur tous les paramétrages de saisie de commande pour lesquels des commandes de type contrat ou rattachés à un contrat seront saisies (CTR, CD2, etc).

Voir #CF CDE A3[57]

Ogd

Spécifique

Ogl

Conserve le numéro de la ligne de rattachement lors de la copie de ligne par CONTROL-G

Ogp

Recréation d'une entrée prévisionnelle de fabrication en désolde

de ligne de commande

ou de ligne de nomenclature

Ogr

Gestion du reliquat de commande

Ogs

Annulation des mouvements de réservation généré par gen_stk lorsque l'on annule une commande ou une ligne de commande.

Ogt

Lors de la recopie d'une ligne de commande, pouvoir conserver le tarif de la ligne source, sinon il est recalculé

Ogz

Ouverture de la fenêtre calcul transport pour (spécifique G)

Ohp

Historisation des tarifs et des priorités de calcul. Nécessite le paramètre NTS #TR

Oht

Saisie de commandes TTC ou HT, la confirmation du type de saisie est demandée à l'utilisateur au lancement du programme

Oil

Interdiction de saisie ou de modification sur la première ligne d'une FB1

Oip

Inversion du prix de vente et du prix public (nécessite Otc)

Olc

Ne reconstruit pas le libellé de la ligne de commande en modification des dimensions

Ola

Saisie de la quantité lancée pour les articles achetés et livrables

Lors de la saisie d'une commande de production, pour les articles fabriqués ou faisant l'objet d'une déclaration de production, une fenêtre permettant la saisie de la quantité lancée s'ouvre automatiquement.

Cette option permet l'ouverture de cette fenêtre pour les articles achetés et livrables.

Old

Lien entre devis et commande

Nécessaire pour paramétrer #CF ATL A3[12]

Ole

Gestion de l'adresse de livraison au niveau de l'entête de commande même si so_options[19] = O.

Olg

ATTENTION ! OPTION SUPPRIMEE !!!

Remplacée par la note LISTE_GROUPAGE

Oli

Active l'autorisation de recopie de la ligne 1 pour une FB1

Oll

Visualisation de la date et de la ville de livraison en saisie de ligne de commande

OLM

Numéro d'ordre annuel sur 8 caractères AA00XXXX. Lors de la mise à jour de fab0, ce numéro d'ordre devient AAXXXX-LL (LL est le numéro de ligne de commande).

Olr

Recopie de la référence client dans la note de revue de contrat. Voir A3[53,55]

Ols

Chargement du libellé produit de la ligne de commande avec le libellé spécifique (Article - Client - Pays - Langue)

Olt

Options pour les articles cartonniers : Si l'option est positionnée, l'ordre des dimensions affichées dans le libellé de la ligne de commande tient compte de alpha1[44] du TYC de la commande.

Si 1 Longueur - Largeur (valeur par défaut)

Si 2 Largeur - Longueur

Om1

Mise à jour du prix de revient de la ligne de commande avec celui de la fiche article lors de la création d'une nouvelle ligne ou de la modification de la quantité d'une ligne existante

Om2

Recalcul du prix de revient de la ligne de commande lors de la modification de la quantité commandée en proratisant de l'ancienne valeur en fonction de l'ancienne et la nouvelle quantité commandée

Quand la valorisation des PF se fait par rapport au Prix de Revient Usine (PRU) hors transport calculé dans le devis, cette donnée n'est pas stockée, donc pas utilisable telle quelle dans la valorisation des stocks : on la mémorise dans la zone Prix de revient de la ligne de commande.

Donc, lors de la génération d'une ligne de commande à partir du devis, ce PRU est stocké dans le prix de revient en le proratisant en fonction de la quantité devisée et de la quantité commandée.

Le problème se produit lors de la modification de la quantité commandée dans le programme de saisie des commandes client où, dans ce cas, le prix de revient de la ligne de commande est recalculé en fonction du prix de revient de la fiche produit commandée (Option Om1).

Oma

Met à jour :

le libellé

le taux de remise

le code TVA

la longueur,la largeur, la hauteur et le poids

la famille et la sous-famille

l'unité de vente

le prix

le taux de commission

les 4 codes statistiques

de la ligne de commande.

Omc

Autorisation de modifier le code client si l'OF a été généré

Omd

OBLIGATOIRE Mise à jour de la quantité en stock par différence

Ome

Gestion du modèle d'étiquette dans les commandes

Affichage du modèle d'étiquette et du nom de l'expéditeur afin de pouvoir modifier ces deux données sur la commande.

Nécessite la création d'un TSC _ET

Omf

Mise à jour de la famille et de la sous-famille de la ligne 1 d'une FB1 avec la famille et la sous-famille de la 1ère ligne de commande non annulée

Omg

Met à jour les informations complémentaires de la ligne de commande

Omi

Modification du code article impossible

Oml

Réinitialisation du code de tolérance de livraison sur les lignes de la commande

Omm

OBLIGATOIRE Pas de mise à jour du mouvement de stock dans le cas d'un changement d'état du mouvement

Omn

Réinitialisation des notes lors du changement du code article

Omp

Le détail du prix est saisi avec une marge dans la fenêtre F7 prix

Omq

Mise à jour de la quantité commandée de la ligne de commande avec la somme des quantités à livrer du cadencement de livraison

Recherche et suppression des lignes de cadencement de livraison du même contrat et du même article si

- l'option Gestion des cadencements de livraison avec stocks est activée (so_options[43] = O)

- TYC A1[22] est différent de N

- un numéro de contrat est saisi sur l'entête de commande.

Voir aussi les notes suivantes dans le TYC :

SUP_REQ_CDE1_CAD_CTR

SUP_REQ_CDE2_CAD_CTR

SUP_REQ_CDE8_CAD_CTR

Omr

Recopie info de commande inter-societé (libellé + représentant) à partir de la référence

Omt

Modification automatique du code TVA Oui par défaut

Omu

Permet de saisir le prix de la ligne de commande en devise de la commande, en Euros et en devise société. (Seulement en entrée du champ prix de la ligne et si la devise de la commande est différente de la devise société)

Ona

Numérotation automatique des produits

Onc

Consultation des notes du client de l'entête de commande

One

Ne pas utiliser. Saisie commande négoce (Pour démo CE)

Incompatible avec la gestion des barèmes (option Oba)

Ong

Saisie des notes groupées sur les lignes de commande.

Onm

Numérotation manuelle (Pas d'attribution automatique du numéro de commande) F11 sur numéro de commande

Onp

Affichage des notes de l'article en saisie des lignes de commande.

Le type de notes doit être paramétré.

Voir les notes TYPE_NOTE_ART_AFF

Ont

Recopie des notes saisies sur le tarif et la remise dans les notes de la ligne de commande, sur les types de notes TYPE_NOTE_TARIF et TYPE_NOTE_REMISE

Il est désormais possible de saisir deux lignes de notes sur les tarifs et les remises

Il est également possible de recopier ces lignes de notes dans les notes de la ligne de commande (les notes proviennent du tarif trouvé sur la ligne de commande)

Par extension, on peut éditer ces notes dans la visualisation des tarifs et remises

La saisie des notes se fait soit directement dans l'écran, soit par CONTROL-N (saisie des tarifs ou remises par tableau).

Voir aussi alpha4[3]

Ony

Numérotation annuelle des commandes et mise à jour des statistiques client (table cli4) à partir de la date de la commande. Option interdite pour les commandes de type fabrication.

Incompatible avec l'option Ocm (compteur manuel)

Ood

Pas de contrôle d'obligation de saisie de dates si la quantité commandée est à 0

Oof

Ouverture systématique d'une fenêtre pour la saisie du code TVA

Ooj

Permet de récupérer la répartition réelle de la charge journalière à la place des clés de répartition sur le #CF CHA ou le .SE

Op1

Écran dédié de la saisie de commande papeterie

Voir aussi

La même option dans le programme d'édition VoluEdit

Les notes commençant par PAP, les notes LIB_DET, SAISIE_ADL, ACR_SLIG_DEC

#CF ATL note MODE_PAPETERIE

QRP A1(2 à 6)

Les tables cde9_e et cde9_l

Opa

Demande d'actualisation du prix de la ligne de commande avec le nouveau prix devisé.

Opc

Si l'option est positionnée, on va chercher le poids dans le CIC N54, sinon on prend le poids de la ligne de commande.

Opd

Gestion automatique du prix devisé sur la ligne de commande

Dans la saisie de ligne de commandes, il est désormais possible de remplir le prix de vente avec le prix devisé de la variante correspondante de quantité la plus proche.

Le devis est pris sur l'article.

Créer des notes commençant par PC_QTE sur #CF CDE

Incompatible avec l'option Opz

Opf

Cette option a été modifiée le 16/12/2010 (V.4.0.181.2)

ermettre de contrôler la saisie d'un article suivant le complément de sélection paramétré pour la recherche via la touche F7 (interrogation).

Le produit saisi sur la ligne de commande doit correspondre au complément de sélection de l'interrogation (F7).

Le type de complément de recherche article est récupéré sur les paramètres suivants (par ordre de priorité) :

1. Paramètre de lancement (ici)

2. Paramètre de liaison (LIE A1[6])

3. Configuration de la saisie de commande (#CF CDE A1[48])

Le complément de sélection proprement dit (notes commençant par SMAT) est récupéré sur le paramètre de lancement.

Opg

Pas de contrôle de présence du groupage si la quantité commandée est à 0

Opi

Interdire la saisie d'un commande client pour un prospect

Cette option désactive automatiquement l'option Ocp.

Opl

Activation de l'affichage détaillé

Permet d'afficher un écran d'infos détaillées (correspond au F16 en revue de contrat) en lieu et place d'un message d'information lorsque la commande est déjà planifiée.

Opm

Interdiction de modifier la zone paramétrée de l'entête de commande

Opn

Pour les articles non cartonniers et appairés, alimentation du poids de la ligne de commande par la somme des poids des articles composant sa nomenclature.

Opo

On oblige l'utilisateur à remplir la zone paramétrée sur l'entête de commande.

Opp

Pertinence par rapport à la quantité par palette

Ce contrôle se base sur la quantité par palette (TSC 220 ic_num1).

Si la quantité demandée (ou retenue dans le cas d'un premier contrôle validé - voir option Opq) n'est pas un multiple de la quantité par palette, alors on propose une quantité adaptée.

Si la zone TSC 220 ic_num1 n'est pas renseignée, ce contrôle n'est pas effectué.

Opq

Pertinence par rapport à la quantité idéale

On contrôle que la quantité saisie est un multiple d'une quantité dite "idéale".

Cette quantité idéale correspond au champ de la table mat : mp_qteeco.

Dans le cas contraire, on propose une quantité multiple de la quantité idéale.

Si le champ mp_qteeco n'est pas renseigné, on ne fait pas de contrôle.

Opr

Mise à jour du prix et de l'unité de vente de la fiche article (F12) - Voir aussi TYC notes FALF12

Opt

Remise de prix devis onduleur

Voir les notes commençant par REM_PRIX_DEVIS_ONDU

La table kp_recap_tot doit être présente dans la base de données.

Opu

Recherche du tarif sur prix de vente de base (mp_pv)

Affichage du prix unitaire de vente de l'article

Possibilité de le modifier

Calcul du tarif à partir de ce nouveau prix

Opy

Possibilité de désactiver le contrôle sur la quantité fabriquée lors du changement du TYC de la commande.

A NE METTRE EN PLACE QUE SI PAS DE GESTION DE LA PROD !

Opz

Prix du devis si prix du tarif à 0 sinon prix du tarif

Incompatible avec l'option Opd

#CF TAR A1[41] = O

Oqa

Quantité de la CDA au lieu de la CD1 pour la recherche du prix de vente des CD1 dans les tarifs

Oqc

Mise à jour automatique de la quantité de la ligne de cadencement de livraison avec la quantité de la ligne de commande modifiée

Permet de mettre à jour la ligne de cadencement de livraison non livrée suite à la modification de la quantité de la ligne de commande.

Remarques :

Cette option ne fonctionne que sur les cadencements de livraison uniques (une seule ligne de cadencement de livraison sur la ligne de commande) non encore livrées (quantités livrées et facturées à zéro sur la ligne de cadencement de livraison).

L'annulation de la ligne de commande est interdite une fois la quantité de la ligne de commande modifiée.

Oqd

Saisie du qualificatif de l'appel de livraison dans la fenêtre de saisie des dates de livraison.

Uniquement sur les lignes de commande

Voir QAL A2[13]

Oqi

On prend comme ligne de commande de rattachement le numéro de ligne de commande d'origine, lors de la saisie de l'appel de livraison.

Or1

Le code représentant de l'entête de commande est initialisé avec celui de l'adresse de réception

Or2

Le code représentant des lignes de commande est initialisé avec celui de l'adresse de livraison

Or3

Initialisation de la zone représentant à blanc

La zone représentant est habituellement initialisée en fonction du client.

Sur option, on l'initialise à blanc.

Or4

On ne tient pas compte de la remise ligne et de la remise d'entête dans la mise à jour du CA en commande

Ora

Evite le recalcul automatique du délai répondu après la saisie de la date de départ

Orb

Dans la revue de contrat, les dates (livraison demandée, livraison proposée, départ et fin de fabrication) sont recopiées depuis la première ligne.

Sans cette option, les dates sont celles de la ligne précédente.

Exemple

On saisit la quatrième ligne de commande: les dates de la revue de contrat seront celles de la première ligne.

Si l'option n'est pas paramétrée, les dates seront celles de la troisième ligne.

Orc

Initialisation du code représentant et de son taux de commission sur les lignes de commande lors du changement de code client.

Ord

Initialise le couple devis / sous-devis avec celui de la fiche article

Ore

Interdit de saisir une remise ou un escompte sur la commande

Orf

Facture corrective au taux de change de la facture de rattachement

Orl

Recopie de la zone mp_rgt1 dans lc_p2

Orm

Prise en compte du fichier remises

Orn

Recopie du poids dans la nomenclature

Oro

Positionner l'OF à régénérer si le code de qualification de l'appel a été modifié sur la ligne de commande

Orp

Non recopie du Grammage figurant sur la fiche article dans la zone poids de la ligne de commande. En effet, sans cette option, si l'utilisateur a saisi un grammage de 300 g/m2 sur la fiche article, il obtient un poids unitaire de 300 Kg sur la ligne de commande. S'il livre 1000 unités de ce produit, il obtiendra une ligne de livraison de 300000 Kg !!! (Ce qui en plus d'être faux peut déclencher une anomalie "Decimal or money value exceed maximum précision" )

Orr

Recopie de la zone mp_remp dans lc_p3

Ors

Transfert automatique des stocks restant au solde / désolde de commande

Nécessite des notes commençant par _SQL_REAFFECT et REAFFECT.

Ort

Force la recherche de tarifs lors d'une modification de quantité sur un prix net

Orv

Recherche automatique de la variante de devis la plus proche par rapport à la quantité lancée de la ligne de commande.

Dans la saisie de ligne de commandes, il est désormais possible de remplir le numéro de sous-devis avec le numéro de la variante correspondante de quantité la plus proche. Le devis est pris sur l'article.

Avec cette option, il est également possible de créer les besoins matières en reprenant les informations sur la variante de devis trouvée.

Nécessite, dans #CF CDE, des notes de type PC_QTE_INF_VARIANTE et PC_QTE_SUP_VARIANTE.

Voir aussi #CF SMC : alpha2[18] et notes de type CODE_LCO_REFOULE

Orw

Accès à un document externe par la touche Ctrl W dans l'entête de commande

Voir les notes PARAM_TYP_DOCUMENT et DEF_TYP_DOCUMENT dans la saisie de commande et dans la visu de commande.

Osa

Recherche le site de production en priorité sur la produit via son lieu de rangement

Tableau de bord du multisite

Voir aussi : RG1 A1[12], Type de lieu de rangement ou de magasin

RG1 A1[29,31], Code site d'appartenance

Si l'option n'est pas positionnée, le site de production est pris sur la commande commerciale.

Osd

Possibilité par F16 de saisir des groupes de dates sur l'entête et les lignes de commandes

Le libellé est paramétrable (type PHS, code groupe) Utilisé par la fonction f_suiv_date

Ose

Saisie des lignes de commande type SECF. La zone lc_rem contient le total de la remise, lc_long contient une remise supplémentaire. Tous les articles doivent exister dans le fichier article.

Incompatible avec la gestion des barèmes (option Oba)

Osf

Saisie du type pré-facture

Osh

Possibilité de saisir les heures liées aux quatre dates de la revue de contrat

Osl

Saisie directe des lignes sans passer par l'entête de commande

IMPORTANT : Cette option ne peut être utilisée qu'avec un numéro de commande passé en argument (-N).

Elle ne doit pas être mise en place manuellement : elle est ajoutée automatiquement lors de l'accès à la saisie de la commande générée lors du transfert en commande de plusieurs devis.

Osm

Saisie des matières consommées pour les cartonniers - Voir TYC A4[42].

Osp

Visualisation du poids et de la surface en saisie de ligne de commande

Osr

Pas de mise à jour du stock résultant lors de la mise à jour des stocks

Ost

Saisie standard

OST

A NE PLUS UTILISER Traitement standard : numéro d'ordre = numéro de commande.

Dans fab0, on ajoute le numéro de ligne (AAMMXXXXLL).

Ot2

Visualisation Montant HT ligne, Unité de vente, Code TVA

Ot3

Recherche de tarif en utilisant la date de livraison proposée.

Cette option positionne automatiquement l'option Otr

Ot9

Recherche de tarif en utilisant la date indiquée en A4[22] au lieu de la date commande

Cette option positionne automatiquement l'option Otr.

Ota

Activation de la création automatique de tarifs en ligne de commande. Voir FAM alpha3[40,42]

Le paramétrage de la création de tarif sur la ligne de commande est en #CF TAR alpha3[1,58].

Otc

Article avec tarif cartonnier (mp_param[29] = 1)

Otd

Tarif recalculé si modification de la date de livraison demandée

Ote

Saisie simplifiée des commandes de type TEXTILE

Oth

Saisie des lignes de commande type THIBAULT (Standard) : pas de saisie de remise

Incompatible avec la gestion des barèmes (option Oba)

Oti

Affichage de tous les types de commande en interrogation. Seuls les types de commande acceptés en création sont autorisés en modification.

Otk

Utilisation des tables du devis onduleur pour récupérer le tarif devisé

Otl

Visualisation total ligne et du P.U

Otm

Réservé Volume Software

Oto

Recopie tolérance de livraison de la ligne précédente

Si cette option est activée et qu'une ligne précédente non annulée existe, la tolérance de livraison est initialisée avec la tolérance de livraison de la plus grande ligne précédente non annulée.

Si cette option est activée et qu'aucune ligne précédente non annulée existe, la tolérance de livraison est initialisée avec la tolérance de livraison du client.

Si cette option n'est pas activée, la tolérance de livraison est initialisée avec la tolérance de livraison du client.

Otp

F11 Total produit seulement

Otr

Prise en compte du fichier tarifs

Ott

Saisie toujours TTC

Otx

Désactive l'affichage de la fenêtre de confirmation de mise à jour du taux de commission du représentant sur le détail de la ligne de commande

Ouo

Code unité de vente et code unité de vente au plus ou moins obligatoires

Our

Les remises de l'entête et des lignes doivent être toutes signées de la même façon

Voir aussi l'option Osr dans facn.

Le taux de remise de l'entête peut être à 0 ou positif, mais pas négatif.

Si le taux de remise de l'entête est à 0 :

les taux de remise des lignes de la commande peuvent être :

à 0 et négatifs

ou à 0 et positifs

mais pas à 0, négatifs et positifs.

Si le taux de remise de l'entête est différent de 0 :

les taux de remise des lignes de la commande peuvent être :

à 0 et positifs

mais pas négatifs.

Ouv

Utilisation de l'unité de vente pour calculer le prix de vente issu de la table mat et le prix du mouvement de stock.

Ov1

Ecran de saisie de commande VOLUPRIM

Incompatible avec la gestion des barèmes (option Oba)

Ova

Validation automatique des fax/emails à envoyer sans passer par la fenêtre de gestion des fax/emails

Ovc

Permet de contrôler qu'une commande de type CD1 est toujours rattachée à une CDA

(elle ne peut être rattachée à elle-même).

En saisie de ligne de commande : vérifie que l'article saisi correspond à un des articles de la commande CDA de rattachement.

Ovd

Vérification de l'antériorité de la date de fin de fabrication par rapport à la date de livraison prévue des appels de livraison correspondants.

Ovl

Visualisation d'une ligne paramétrable en bas de l'écran. Voir les notes commençant par LIGPAR.

Cette option ne doit pas être utilisé conjointement avec les options Otl ou Ot2.

Ovn

Contrôle de la validité des PF

Ovs

Option temporaire

Désactive le CONTROL-B actuel et le remplace par l'appel à la visu simplifiée des stocks.

En version 4J's > 3.5, cette option est inutile, car la touche F37 est visible dans l'ascenseur des boutons de fonction.

Ovt

Saisie tarifs autorisée (F25) sinon visualisation

Oxm

Ecran de saisie fax/email

Ozp

A la création, recopie du contenu de la zone paramétrée du fichier client dans la zone paramétrée de l'entête de commande.

(cl_zpar dans ec_c1)

Ozr

Recopie de la zone paramétrée du code représentant (alpha4[9,11]) dans la zone paramétrée de l'entête de commande

Ozz

Boucle en saisie de note sur la fenêtre de choix de type de note

Valeur alpha 2

cde A2[1,10] | ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?
cde A2[11,60] | TYC autorisés. Si cette zone est à blanc, pas de contrôle Contrôle du TYC saisi dans l' entête de la commande Il est possible de contrôler le TYC saisi lors de l'enregistrement de la commande.

Valeur alpha 3

cde A3[1,6]

Client par défaut

cde A3[7,9]

TYC par défaut

cde A3[10,14]

Mot de passe annulation logique.

cde A3[15]

Demande mot de passe d'annulation logique entête et ligne (F2)

[espace] Pas de demande du mot de passe

N Pas de demande du mot de passe

O Demande du mot de passe

cde A3[16,18]

Type de note article source. Nécessite l'option Ocn

cde A3[19,21]

Type de note ligne de commande destination. Nécessite l' option Ocn

cde A3[22,27]

Type et code du paramètre de lancement de l'édition AR

cde A3[28,33]

Type et code du paramètre de lancement de la réédition AR

cde A3[34,39]

Type et code du paramètre de configuration de saisie des tarifs

cde A3[40,45]

Type et code du paramètre de lancement de l'édition des étiquettes à la sortie de l'entête

cde A3[46,51]

Type et code du paramètre de lancement de la création de prix de revient

cde A3[52]

Type d'écran de saisie du détail de prix de la ligne de commande

0 Détail de prix standard. Le détail de prix est stocké dans la table des notes (cde3)

1 Détail de prix avec prix de revient et marge. Quantité saisie sans décimale.
Le détail de prix est stocké dans la table détail de prix (cde7)

2 Détail de prix avec prix de revient et marge. Quantité saisie avec décimales.
Le détail de prix est stocké dans la table détail de prix (cde7)

3 Détail de prix standard avec quantité sans décimale.
Le détail de prix est stocké dans la table détail de prix (cde7).
Autorise la saisie des barèmes. Voir le paramètre DPC.

4 Détail de prix standard avec quantité avec décimales.
Le détail de prix est stocké dans la table détail de prix (cde7).
Autorise la saisie des barèmes. Voir le paramètre DPC

7 Ecran de saisie F7 détail prix standard avec marge, prix de revient et quantités avec décimales, totalisation dans l'unité de la ligne de commande. Stocké dans cde7

cde A3[53,55]

Type de notes de l'écran de revue de contrat (exemple RC)

cde A3[56,58]

Type de notes de l'historique de revue de contrat (exemple RCH)

cde A3[59]

Mode d'accès aux frais d'expédition

O Consultation uniquement

N Consultation et modification

cde A3[60]

Fenêtre de confirmation pour la saisie de commande pour un prospect

O Ouverture de la fenêtre de confirmation

N Pas de fenêtre de confirmation

Valeur alpha 4

cde A4[1] | Mode d'accès aux cadencements de livraison O Consultation uniquement N Consultation et modification.
cde A4[2] | Flag demande de confirmation d'édition AR en automatique N Pas de demande de confirmation O Demande de confirmation (Valeur par défaut) L'option Oau doit être positionnée (Edition AR en automatique)
cde A4[3] | Type d'interface lors de la recopie des notes tarif G Affichage automatique de la saisie des notes groupées (valeur par défaut) T Affichage automatique des notes du type créé par la copie (option Ont doit être activée) N Pas d'affichage automatique des notes L'affichage automatique nécessite l'option Ont
cde A4[4] | Type d'interface lors de la recopie des notes (option cn) G Affichage automatique de la saisie des notes groupées (valeur par défaut) T Affichage automatique des notes du type créé par la copie N Pas d'affichage automatique des notes
cde A4[5,10] | Type et code du paramètre de lancement de la visualisation de facture
cde A4[12,14] | Type du paramètre pour la recherche des programmes à proposer dans le menu paramétré des éditions.
cde A4[15] | Contrôle que la ligne n'est pas déjà facturée N Pas de contrôle (valeur par défaut) W Contrôle non bloquant B Contrôle bloquant
cde A4[16] | La touche F13 doit-elle solder la ligne de commande ? (O/N, N par défaut)
cde A4[17] | Type de contrôle de modification de commande lorsque celle-ci est soldée et facturée entièrement N Pas de contrôle (valeur par défaut) W Contrôle non bloquant B Interdiction de modification
cde A4[18,20] | Code site de production par défaut associé à cette saisie de commande Tableau de bord du multisite
cde A4[21] | Action sur la date de commande O Modifie la date de commande ainsi que la date client à la date du jour quand le TYC passe de PRX à CD2. N Laisse intacte la date de commande ainsi que la date client (par défaut)
cde A4[22] | Type de date utilisé par la recherche de tarif (option Ot9) - Facultatif 1 Date commande (ec_datc) (Valeur par défaut) 2 Date du jour 3 Date client (ec_date_client) 4 Date de début de validité (ec_date_deb_val) 5 Date de fin de validité (ec_date_fin_val) 6 Date livraison demandée (lc_delcli) 7 Date livraison proposée (lc_delrep) 8 Date de fin de fabrication (lc_delfab) 9 Date de départ (lc_deldep)
cde A4[23] | Type de contrôle d'autorisation de modification du prix de la ligne de commande si celle-ci a une ligne de cadencement de fabrication avec un statut à 1 ou 3 ou 5 N Pas de contrôle W Warning C Confirmation B Bloquant Uniquement si so_options[44] = O Voir la note _SUP_REQ_CDE_CAD_FAB.
cde A4[24,28] | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
cde A4[29] | Saisie obligatoire du centre dominant (lc_p1) en saisie lignes (O/N, O par défaut)
cde A4[30] | Mode de contrôle de la surface commandée N Pas de contrôle W Message de confirmation (non bloquant) B Message bloquant Voir la note SURFACE_MINI dans le #CF CAR
cde A4[31] | Contrôle de la présence de groupage en cas de modification de la ligne de commande. B Bloquant W Warning C Demande de confirmation N Pas de contrôle
cde A4[32] | Contrôle de la présence d'une réclamation client pour le produit (ou l'un de ses composants) saisie sur la ligne de commande N Pas de contrôle W Affichage d'un message d'avertissement B Affichage d'un message bloquant
cde A4[33] | Type de contrôle de conditionnement Voir CND, valeur numérique 1 N pas de contrôle (valeur par défaut) B contrôle bloquant + message W Message informatif C Message + confirmation Attention le contrôle est fait sur le champ mp_uv (Code unité de vente) de la fiche article.
cde A4[34] | Comportement à adopter s'il existe des commandes rattachées à la ligne que l'on désire annuler : O On valide l'annulation sans avertir l'utilisateur M On valide l'annulation et on informe l'utilisateur de la présence de commandes rattachées C On informe l'utilisateur de la présence de commandes rattachées et on lui demande confirmation de l'annulation (valeur par défaut) N On interdit l'annulation en informant l'utilisateur.
cde A4[35] | Contrôle de la similitude des sites de production de l'entête de commande et du produit commandé. N pas de contrôle (défaut) W Message C Demande de confirmation B Bloquant Tableau de bord du multisite
cde A4[36] | Contrôle de cohérence entre les valeurs du cadencement de livraison et de la revue de contrat 0 pas de contrôle 1 contrôle par rapport à la première ligne non annulée des cadencements de livraison 2 contrôle par rapport à la première ligne non annulée et non soldée des cadencements de livraison Voir QAL A2[13]
cde A4[37,39] | Site de production pris par défaut pour le risque client Tableau de bord du multisite
cde A4[40] | Inutilisé ?
cde A4[41] | Contrôle si l'unicité du quadruplet article/ date/ adresse/ client est respectée B Contrôle bloquant + message W Message d'avertissement C Message avec confirmation N Pas de contrôle (par défaut)
cde A4[42,44] | Code environnement pour barème
cde A4[45,47] | Code TYF pour la création de l'entête de commande d'achat
cde A4[48,53] | Type et code recherche tarif
cde A4[54] | Code calcul délai. Paramétrage évolutif en fonction des besoins 1 Délai initial du client (par défaut)
cde A4[55] | Saisie obligatoire de la date en cadencement de livraison (O/N)
cde A4[56] | Saisie obligatoire de la quantité en cadencement de livraison (O/N)
cde A4[57] | Message indiquant qu'il existe un affrètement pour la même date et la même destination que celles de la ligne de commande en cours (à la création) Type d'alerte B bloquant W Avertissement C confirmation N pas de message (valeur par défaut)
cde A4[58] | Contrôle que le dossier de fabrication est soldé en livraison (N par défaut) N pas de contrôle B contrôle bloquant W contrôle d'avertissement C Contrôle avec de demande de confirmation de l'action à mener
cde A4[59] | Accès en consultation seule à la saisie des cadencements de fabrication (O/N, N par défaut) Voir la fiche d'installation
cde A4[60] | Nombre de décimales à afficher pour les quantités (de 0 à 3) - 3 par défaut 0* pas de décimale (ex : 5444333222111) 1* 1 décimale (ex : 44333222111,9) 2* 2 décimales (ex : 4333222111,99) 3* 3 décimales (par défaut) (ex : 333222111,999) A 0 décimale avec séparateur (ex : 4 333 222 111) B 1 décimale avec séparateur (ex : 333 222 111,9) C 2 décimales avec séparateur (ex : 33 222 111,99) D 3 décimales avec séparateur (ex : 3 222 111,999)

Notes triées

ACCES_DEPUIS_CDE_PST

Accès à l'entête depuis les lignes de commande via CTRL-U

21 Autorise la re-direction vers l'entête de commande (O/N)

22 Autorise la re-direction vers les notes sur l'entête de commande (O/N)

Voir l'option Ocu

ACCES_DEVIS

Accès à l'offre 99 du devis en consultation

21,26 Type et code du paramètre de lancement de devis_ondu (en consultation). Exemple #SA DEV

ACR_SLIG_DEC

21,26 Type et code du paramètre de lancement de l'édition des AR

Utilisé également pour la papeterie

ACTION_AUTO_FACTURE

21,23 Code action automatique de facturation à générer (Type de paramètre ASO)

AFF_EVENEMENT_

Cette note est prioritaire sur celle du #CF EVT.

AFFICHE_F11_TYPE_FB2

21 Affichage de l'historique restreint au client de la commande + affichage du prix client (O/N)

AFF_MES_AVER_SOR_RES

21 Affichage d'un message d'avertissement qu'aucun mouvement de stock de sortie réserve n'a été créé (O/N, N par défaut)

_AFF_TSC_220_ZONE_C

21 Affichage du TSC 220 Zone C du cadencement de livraison (O/N, N par défaut)

ARRONDI_PRIX_PUBLIC

Possibilité d'arrondir le prix public de la ligne de commande (0 à 2 décimales maxi) avant l'arrondi en fonction de la devise de la commande

21 Nombre de décimales du prix public de la ligne de commande (0 à 2)

0 Prix public sans décimale

1 Prix public avec 1 décimale

2 Prix public avec 2 décimales

AUTORISE_TOUCHE_F51

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21 Visualisation des commandes uniquement : Autorisation de la touche F51 : Détail des coûts (O/N, N par défaut)

CAD_LIV_CDE_SOLDEE

Interdire la création d'une nouvelle ligne de cadencement de livraison sur une ligne de commande soldée

N Pas d'interdiction (création possible)

W Message d'avertissement (création possible)

C Demande de confirmation avant création d'une nouvelle ligne

B Message bloquant (création impossible) (par défaut)

CA_JOURNALIER_MAX

21,60 Montant maximum que le CA total d'une journée ne pourra pas dépasser

Voir aussi la note _SQL_CA_JOURN_MAX et le code blocage 040

CBA

Définition des codes blocage

CBACON définit les codes blocage automatiques à contrôler en saisie de lignes de commande.

CBAFBI définit le code blocage automatique à positionner en saisie de lignes de commande.
Ce code permet de vérifier que les FBI générées n'ont pas été modifiées manuellement.
Si c'est le cas, alors leur actualisation automatique est impossible.

7 à 9 Code blocage

Exemple CBACONLAB pour le code blocage automatique laboratoire

CD1_HORS_PLAGE_TYC

Numérotation des appels de livraison générés par les CDA.

Nécessite TYC alpha4[1,3]

21 Création du numéro de l'appel de livraison en utilisant le compteur paramétré (O/N, N par défaut)

C_FAM_ART_DES_SIT

21,23 Code famille du produit

Cette note facultative fonctionne avec l'option Oda.

Exemple

C_FAM_ART_DES_SIT XYZ

Pour la famille XYZ, le lieu de destockage sera en priorité celui du paramètre SIT.

CODE_BESOIN_SMC

21,23 Code paramètre pour le paramétrage général des besoins

SMC par défaut

CODE_BLOCAGE_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_CODES_VALID_APL_

21 Code validation administration des ventes par défaut (O/N, O par défaut)

22 Code validation production par défaut (O/N, O par défaut)

23 Code validation Iogistique par défaut (O/N, O par défaut)

CODE_NTS_COPIE_MAT3

à partir du caractère 21, par groupes de 3 caractères, sans séparateur :

jusqu'à 13 codes de type NTS des notes sur ligne de commande à recopier dans les notes de l'article

Caractères 21 à 23, 24 à 26 ... 57 à 59

CODE_TARIF_RECH_PRIO

Dans la recherche des tarifs standard, permet de rechercher un tarif avec un code particulier en priorité.

Si rien de trouvé, on ne change rien à la recherche standard.

21,23 Code tarif de recherche (paramètre TAR)

24,29 Type et code du paramètre de recherche de tarif (#CFTAR par défaut)

CONFIG_DEG_DER_DEVIS

21,23 Code paramètre de la configuration générale du devis

Facultatif. DEG si non renseigné

24,26 Code paramètre de la configuration du récapitulatif du devis

Facultatif. DER si non renseigné

CONFIG_DEG_DER_PREV

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement prévisionnel. Par défaut : DEG

24,26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement prévisionnel. Par défaut : DER

CONFIG_DEG_DER_REEL

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement réel. Pas de valeur par défaut

24 26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement réel. Pas de valeur par défaut

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

CONSERV_PRX_MOD_PROD

21 Conservation du prix saisi sur la ligne de commande dans le cas d'une modification du produit par la touche F29 (O/N)

CONTRAINTES_MOD_PROD

21 Contrôle si produit générique (O/N, O par défaut)

Si O, le mp_param[25] du produit doit être à O

22 Contrôle si mouvements de stock physiques (O/N, N par défaut)

Si O, la ligne de commande ne doit pas avoir de mouvements de stock physiques ou normaux (état à N).

Seuls les mouvements prévisionnels sont autorisés.

CONTROLE_C1_ZPAR

21 Type de contrôle entre la zone ec_c1 de l'entête et la zone cl_zpar du client

N Pas de contrôle (Valeur par défaut)

F Contrôle non bloquant avec message d'avertissement

B Contrôle bloquant avec message d'avertissement

Ce contrôle n'est actif que pour les commandes de type CD1 ou les articles non synchrones.

CONTROLE_QTE_DELAI

21 Contrôle de la quantité saisie par rapport à la quantité disponible en stock

B (Bloquant) Contrôle de type bloquant en fin de ligne

W (Warning) Contrôle de type avertisseur en fin de ligne

N (Non) Pas de contrôle

COPIE_CDE

11,16 Type et code du paramètre de lancement de la saisie de commande (cocde).

Exemple : #TRCDE

Le caractère 11 doit être impérativement un dièse.

Le numéro de commande en cours est passé en argument avec un -N.

L'appui sur Ctrl G lance la copie de commande.

CTGNOT

Possibilité de recopie des notes par CONTROL-G

7 à 60 Types de notes à recopier (maximum 18 types de 3 caractères chacun)

Une seule ligne de note sera prise en compte.

Exemple : TEX (pour les notes de types textile)

CTRL_LIG_CDE_PLANI

21 Type de contrôle lors de l'annulation d'une ligne de commande déjà planifiée et/ou semi-produit

C Demande de confirmation (par défaut)

W Warning

B Bloquant

N Sans contrôle

La permission (MEN) CDE_LIG_ANN est requise.

CTRL_OBJET_ACTION

21 La zone objet/commentaire est-elle obligatoire ?

N Non, pas de contrôle (par défaut)

B Oui, contrôle Bloquant

W Warning affiché en bas de l'écran

C Demande de confirmation

Ce paramétrage est pris en priorité sur le paramètre de lancement, puis sur le paramétrage de configuration des actions et événements (#CF/EVT)

DELAI_LABO_FIN_FAB

Prise en compte des délais du laboratoire dans le calcul de la date de fin de fabrication

DEF_TYP_DOCUMENT

Pour l'ouverture automatique de documents

Nécessite l'option Orw

21 Définition du nom du document

1 construit avec le N° de commande (valeur par défaut)

2 saisi

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

DS_DOUBLE_CALCUL

21 Activer le double calcul du devis multi-métiers lors de la réactualisation des coûts (O/N, N par défaut)

Cette note est recherchée en priorité dans le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

DS_GESTION_EFFECTIF

21 Activer la gestion de l'effectif du devis multi-métiers lors de la réactualisation des coûts (O/N, N par défaut)

Cette note est recherchée en priorité dans le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

DS_RAZ_QUANTITES

21 Activer la remise à zéro des quantités des opérations si le temps total est à zéro (O/N, O par défaut)

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

EDITION_AR_FBI

Edition des AR des FBI

21 à 26 Type et code du paramètre de l'édition d'AR des FBI. Exemple #ED FBI

ETAT_DEVIS_BAREME

21,23 Code état du devis issu des barèmes par défaut (paramètre ETD)

L'option Oba doit être activée.

Facultatif. ATT si non renseigné

ETAT_DEVIS_MODIF

21,23 Code état du devis commercial après validation des notes de demande de modification

Voir aussi USE A2[29]

ETATS_CADENCEMENTS

21,23 Code état de création des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : CRE

24,26 Code état de modification des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : MOD

27,29 Code état de livraison non soldée des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : LNS

30,32 Code état de validation des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : VAL

Si cette note n'existe pas, elle est recherchée dans le #CF ATL.

FENETRE_AUTO_CLIENT

Affichage automatique de notes saisies sur l'entête de commande et la fiche client :

Juste en sortie du champ N° de commande sur l'entête de la commande, une fenêtre s'ouvre automatiquement avec les notes d'un type déterminé (ces notes proviennent de l'entête de commande et de la fiche client).

Ne gère que l'affichage sur l'entête de commande d'un type de note saisie sur la fiche client.

21,23 Type de notes saisies sur la fiche client à afficher (on ne peut saisir qu'un seul type de note).

24 Ouverture de la saisie des notes en modification

O Modification (par défaut)

N Consultation uniquement

FENETRE_AUTO_ENT_CDE

Affichage automatique de notes saisies sur l'entête de commande et la fiche client :

Juste en sortie du champ N° de commande sur l'entête de la commande, une fenêtre s'ouvre automatiquement avec les notes d'un type déterminé (ces notes proviennent de l'entête de commande et de la fiche client).

Ne gère que l'affichage sur l'entête de commande d'un type de note saisie sur l'entête de commande.

21,23 Type de notes saisies sur la commande à afficher (on ne peut saisir qu'un seul type de note).

24 Ouverture de la saisie des notes en modification

O Modification (par défaut)

N Consultation uniquement

FIC_TRACE_MAJ_PV_CDE

Chemin et nom du fichier de trace de la mise à jour des prix de vente des commandes. Obligatoire

3 lignes de notes maxi

FORCAGE_DATE_ECH_CON

21 Forçage des dates d'échéance en mode consultation (O/N, N par défaut)

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

GST_PRIX_FORCE

21 Gestion du prix forcé (O/N, N par défaut)

Voir le TSC PCD.

_HIS_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_INTER_SAISIE_CP_VIL

21 Saisie du code postal et de la ville dans la fenêtre de cadencement de livraison

N Saisie (Valeur par défaut)

O Pas de saisie

JOURS_APRES_DATE_LIV

21,23 Définit la borne supérieure de la plage de dates sur laquelle on va chercher les commandes à livrer.

24,32 Code calendrier. Si le code calendrier est renseigné, alors le calcul de la borne supérieure de la plage de dates ne prendra en compte que les jours ouvrés. Sinon, on prend en compte tous les jours sans exception.

Voir la note _SUP_CDE_A_LIVRER

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF CDE.

JOURS_AVANT_DATE_LIV

21,23 Définit la borne inférieure de la plage de dates sur laquelle on va chercher les commandes à livrer.

24,32 Code calendrier. Si le code calendrier est renseigné, alors le calcul de la borne inférieure de la plage de dates ne prendra en compte que les jours ouvrés. Sinon, on prend en compte tous les jours sans exception.

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF CDE.

Voir la note _SUP_CDE_A_LIVRER

Exemple

JOURS_AVANT_DATE_LIV5 #SOC

JOURS_APRES_DATE_LIV5 #SOC

Avec ce paramétrage, la recherche s'effectuera sur la page de dates suivantes :

- 5 jours ouvrés précédant la date de livraison proposée sur le calendrier de code #SOC

- 5 jours ouvrés suivant la date de livraison proposée sur le calendrier de code #SOC

LANCE_TR_L_CDE

21 à 26 Type et code du paramètre de lancement de tr_l_cde

LARGEUR_CAMION_MLP

21,24 Largeur du camion (en mm) pour le calcul du métrage linéaire

LCO_SOUS_DEVIS_PRIO

Forcer la variante utilisée par une LCO sur l'entité du devis

21 à 23 Code de la LCO définissant la priorité du sous-devis

(LCO GDF par défaut)

Dans la recherche du prix de la ligne de commande par la variante de devis, il est désormais possible de forcer la variante utilisée par un LCO sur l'entité du devis. Le prix de la ligne de commande sera celui de la variante forcée.

LCO alpha1[16] de la variante prioritaire doit être égal à O (Oui).

LCT_AUTO_VALIDATION

Numéro du programme paramétré dans le Control-J à exécuter automatiquement à la validation des lignes de commande

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

Touche Ctrl J pour appeler un autre programme en lui passant des arguments. Voir #RP

LIB_DET

Pour la papeterie - Voir l'option Op1

21,60 Libellé de description de chaque ligne de découpe (note cumulative).

Accès aux zones des tables cde1, cde2, mat, cde9_e et cde9_l + date modif.

Les noms des champs sont encadrés par des crochets [ ]

Un saut de ligne se fera avec <br/>.

Le using est précédé du +.

Exemples

LIB_DET Description : [mp_des]<br/>

LIB_DET Date de modification : [date_modif+dd/mm/yyy]

LIGPAR

Possibilité de définir des champs avec l'option Ovl

8 à 60 Paramétrage de la ligne d'affichage sous la forme LLL*CCC*TTT*UUU*SL*

LLL Libellé affichable à l'écran

CCC Champs disponibles

1) Liste des champs disponibles (en bas de cette page).

2) Les TSC, avec la même syntaxe d'appel que pour les visus

Exemple d'affichage de TSC : LIGPAR_RC Info Livraison*TSC_LC_LI_60F_G*30**

3) Les NTS, avec la même syntaxe d'appel que pour les visus

TTT Taille de la zone

UUU using

SL Saut de ligne (O/N, N par défaut)

Exemples

LIGPAR MLP*m_lineaire_plancher*3*###*

LIGPAR MTT HT *mtt_total_ht_vente*14*--- --- --&.&&*

LIGPAR P.U HT *prix_unitaire_ht_vente*14*--- --- --&.&&*

LIGPAR TVA *zc1_lc_tva*6*--&.&&*

LIGPAR_RC

10,60 Possibilité de définir des champs visualisables en bas de l'écran de revue de contrat avec l'option Ovl

Même paramétrage que LIGPAR ci-dessus

Cette note est disponible dans tout programme appelant la revue de contrat : cde, labo, v_cdem

LIGPARCF

9,60 Lors du Ctrl F, affichage d'une ligne paramétrable d'informations en bas d'écran, sous la forme LLL*CCC*TTT*UUU*

LLL Libellé affichable à l'écran

CCC Liste des champs visualisables

lc_delcli Date de livraison souhaitée

lc_delrep Date de livraison proposée et accusée

lc_delfab Date de fin de fabrication

lc_delrea Date de réalisation

lc_date_solde Date du solde de la ligne de commande

b1_datl Date de livraison

fe_date Date de facturation

TTT Taille de la zone

UUU Using de la zone

Cliquez ici pour afficher / masquer un exemple.

Cette note est utilisable dans les programmes utilisant la fonction f_visblfac, notamment :

aid_fac - v_cdem - v_cde - v_groupage_bl - v_jbl - v_jdv

LISTE_GROUPAGE

Remplace l'ancienne option Olg.

Liste des groupages concernant une ligne de commande (O/N, N par défaut)

LISTE_TYC_CALC_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

MAJ_CDO_LIG_ENTETE

Mise à jour du centre dominant

21 Mise à jour du centre dominant des lignes avec celui de l'entête (O/N, N par défaut)

22 Centre dominant de l'entête obligatoire (O/N, N par défaut)

23 Centre dominant de la ligne non saisissable (O/N, N par défaut)

O il est non saisissable

N il est non non saisissable, autrement dit il est saisissable.

MAJ_REP_LIG_ENTETE

Mise à jour du code représentant

21 Mise à jour du code représentant des lignes avec celui de l'entête (O/N, N par défaut)

22 Code représentant de l'entête obligatoire (O/N, N par défaut)

23 Code représentant de la ligne non saisissable (O/N, N par défaut)

O il est non saisissable

N il est non non saisissable, autrement dit il est saisissable

MAJ_STK_DEPUIS_VS

21 à 26 Type et code paramètre pour lancer le programme de mise à jour des stocks depuis ce récapitulatif

METHODE_2_ECART_QTE

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note est recherchée en priorité ici, sur le paramètre de lancement.

Si elle n'est pas trouvée, elle est recherchée sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS (par exemple #CF REC).

Voir le paramètre #CF REC pour plus d'info.

MODIF_PRIX_CREATION

21 Interdire la modification du prix et de la remise en création de ligne - Par défaut, la modification est autorisée.

0 ou N Modification autorisée uniquement si le prix est à 0

1 ou O Modification autorisée

2 Modification interdite (même si le prix est à 0)

MODIF_REM_CREATION

21 Peut-on modifier la remise lors de la création d'une ligne de commande (O/N, O par défaut)

_MSG_CDES_ACTIVES

Affecter un devis valide pour permettre la production

Notes liées : _SUP_DEV_ACTIFS, _MSG_DEVIS_ACTIFS_1, _MSG_DEVIS_ACTIFS_2, _MSG_CDES_ACTIVES, _SUP_CDES_ACTIVES

21,60 Libellé définissant les commandes comptées

_MSG_DEVIS_ACTIFS_1

Affecter un devis valide pour permettre la production

Notes liées : _SUP_DEV_ACTIFS, _MSG_DEVIS_ACTIFS_1, _MSG_DEVIS_ACTIFS_2, _MSG_CDES_ACTIVES, _SUP_CDES_ACTIVES

21,60 1ère ligne paramétrable du message pour l'utilisateur au cas où aucun devis actif n'est trouvé.

(sera affiché : aucun devis actif trouvé pour le produit)

_MSG_DEVIS_ACTIFS_2

Affecter un devis valide pour permettre la production

Notes liées : _SUP_DEV_ACTIFS, _MSG_DEVIS_ACTIFS_1, _MSG_DEVIS_ACTIFS_2, _MSG_CDES_ACTIVES, _SUP_CDES_ACTIVES

21,60 2ème ligne paramétrable du message pour l'utilisateur au cas où aucun devis actif n'est trouvé.

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions

Paramétrage équivalent au C

Exemple

3CLI2QA

Voir #CF EVT.

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table cde3

Obligatoire. Exemple : TEX

24,26 Type de mouvement des sorties réserves du TEXTILE

Obligatoire. Exemple : SR

27,29 Type de mouvement des entrées prévisionnelles du TEXTILE

Obligatoire. Exemple : EP

NTS

Possibilité de définir des types de notes à importer en plus du paramétrage disponible sur la valeur alpha3

A utiliser avec l'option Ocn

4,6 Type de notes à importer

7,9 Type de notes à créer

NUM_COMPTEUR_CD1_HP

21 à 24 Numéro du compteur pour les appels de livraison en génération automatique par compteur

Si non renseigné, utilisation du compteur des commandes

OBJET_DOCUMENT

21,23 Type de document (ACR)

25,60 Objet du document pour le fax/email

Dans le texte, on peut mettre des zones de table entre crochets ([zone])

Tables disponibles selon le type de document :

b_ret_rec_e / blv1 / cde1 / cdf1 / cli / cli2 / fac0 / fle_2 / groupage_bl

PAP_INIT_DTECH

Pour la papeterie - Voir l'option Op1

21 Initialisation des données techniques par rapport à la dernière commande client/produit standard (O/N, N par défaut)

PAP_RECOP_ELT_TECH

Pour la papeterie - Voir l'option Op1

21 Recopie des éléments techniques à chaque ligne d'une même découpe (O/N, N par défaut)

PAP_D_MANDRIN_MERE

Pour la papeterie - Voir l'option Op1

21,28 Diamètre du mandrin mère en mm (par défaut 3600 mm)

PAP_TOL_BOB_MERE

Pour la papeterie - Voir l'option Op1

21,23 Tolérance de découpe du mandrin mère en pourcentage (par défaut : consommation totale)

PARAM_CALCUL_DEVIS

21,26 Type et code du paramètre de lancement de la saisie du devis onduleur pour la réactualisation du récapitulatif des coûts

Le mode batch est positionné automatiquement.

Voir aussi la note PARAM_INDICATEURS.

PARAM_CONSULT

21,26 Type et code du paramètre de lancement du programme de qualité carton en mode consultation (#SA QUA par défaut).

Cette note est accessible dans tous les programmes exploitant la fonction f_visu_nomenclature : cde, blv, v_cdem, v_jbl

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

PARAM_EDIT_FACTURE

21,26 Type et code du paramètre d'édition des factures. Par défaut : #EDFAC

PARAM_EDITION_FS

Edition des fiches de spécification depuis la visu de la nomenclature

21 à 26 Type et code de l'édition des fiches de spécifications.

PARAM_EDI_FIC_FAB

21,26 Type et code du paramètre de lancement de l'édition de la fiche de fabrication

Facultatif - #EDFFA par défaut

PARAM_GEN_DOS

21,26 Type et code du paramètre de lancement de la génération du dossier

Facultatif - #FBGDF par défaut

PARAM_INDICATEURS

21,26 Type et code du paramètre de configuration du récapitulatif des coûts

PARAM_LAN_DOS

21,26 Type et code du paramètre de lancement du lancement du dossier

Facultatif - #FBDOS par défaut

PARAM_LCT_VISU_BES

21,26 Type et code du paramètre de lancement de la visualisation des besoins matière

Dans la visualisation des besoins matière, voir la note XCLI1.

Cette note existe aussi dans le transfert du devis en commande.

Cette visualisation ne sera traitée que s'il existe des besoins matière pour cette commande. : voir la note _SUP_REQ_VISU_BES

PARAM_MSG_ORDRSP

21,26 Type et code du paramètre de lancement de l'interface ORDRSP

PARAM_RECH_REMISE

21,26 Type et code du paramètre de configuration de recherche des remises (par défaut, #CF REM)

PARAM_RECH_TARIF

21,26 Type et code du paramètre de configuration de recherche des tarifs (par défaut, #CF TAR)

PARAM_REF_CLIENT

Nouvelle zone de référence d'entête commande cliente plus grande <VF>

Dans la saisie des commandes clients et/ou lors du transfert d'un devis en commande, via paramétrage, il est possible de saisir une deuxième référence client (ec_ref_2) sans contrainte de clé unique jusqu'à 30 caractères.

La première référence peut être masquée pour ne laisser que la deuxième référence visible dans les écrans.

Cette nouvelle zone est accessible dans les éditions VoluEdit et dans les visualisations.

ATTENTION : Ne mettre les caractères 21 ET 22 à N (simultanément) qu'en transfert de devis en commande ou en consultation !!!

21 Afficher ou Masquer la référence client 2 (ec_ref_2) (champs plus grand)

O Afficher

Dans ce cas, la référence client (ec_ref) est systématiquement renseignée avec le numéro de commande (ec_num).

N Masquer (par défaut)

22 Afficher ou Masquer la référence client (ec_ref)

O Afficher (valeur par défaut si la note n'est pas créée, ou qu'elle est créée avec les car. 21 et 22 vides)

N Masquer (valeur par défaut si la note est créée, ou qu'elle est créée avec le car. 21= O)

23, 24 Type d'aide sur saisie référence (facultatif)

01 Référence = Numéro de commande

02 Référence = Client Nombre de commandes

03 Référence = Client Millésime de la commande Nombre de commandes

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF ATL.

PARAM_REG_DOS

21,26 Type et code du paramètre de lancement de la régénération du dossier

Facultatif - #FBRGD par défaut

PARAM_TYP_DOCUMENT

21, 23 Code du paramètre du document (voir paramètre de type WIN)

Nécessite l'option Orw

PAR_LCT_GEN_CAD_FAB

21,26 Type et code du paramètre de lancement de la génération des cadencements de fabrication

PROD_MULTI_NIV_OK

Supprimée - Remplacée par _SUP_REQ_PROD_MN_OK

21,60 Liste des racines des produits autorisés

En multi-niveaux, on peut saisir un produit P* au même titre que les R*, même s'il n'a pas de nomenclature.

QUALIFICATIF_APPEL

Qualificatif d'appel de livraison pour la nouvelle ligne créée par un appel.

21 à 23 Code qualificatif d'appel de livraison

RAIS_PROSPECT_OBL

21 En saisie de prospect de manière rapide, pouvoir rendre obligatoire les zones Représentant et Raison sociale.

O La raison sociale du prospect est obligatoire

N La raison sociale du prospect est facultative (par défaut)

REAFFECT_ETAT

21 Code état des mouvements générés (N ou 2, N par défaut)

REAFFECT_NVE_VEN

Paramétrage des mouvements générés au DESOLDE

21 à 23 = type du mouvement de sortie (SN par défaut)

24 à 26 = type du mouvement d'entrée (EN par défaut)

27 à 29 = lieu de rangement 1 en entrée (USI par défaut)

30 à 35 = lieu de rangement 2 en entrée (VEN par défaut)

REAFFECT_VEN_NVE

Paramétrage des mouvements générés au SOLDE

21 à 23 = type du mouvement de sortie (SN par défaut)

24 à 26 = type du mouvement d'entrée (EN par défaut)

27 à 29 = lieu de rangement 1 en entrée (USI par défaut)

30 à 35 = lieu de rangement 2 en entrée (NVE par défaut)

RECOPIE_TSC_CDE_DEF

21 Recopie des TSC de la commande par défaut (00000000) (O/N, N par défaut)

Pour qu'un TSC soit recopié il faut qu'il soit recopiable (voir TSC A1[6])

REMPLIR_LC_P3_AVEC

Possibilité de définir le mode d'alimentation de la zone lc_p3

Attention, cette ligne de note cohabite mal avec l'option Orr

20 à 60 Nom du champ alimentant lc_p3

Liste des champs utilisables :

mp_remp, le_libpar1, le_libelle, le_libelle2

REM_PRIX_DEVIS_ONDU

Paramétrage de la remise de prix devis onduleur. Option Opt indispensable

21,26 Type et code paramètre du recalcul batch du devis.

28,34 Pourcentage d'écart de prix de revient autorisé sous la forme 9999.99

36,38 Code blocage automatique d'écart de prix de revient (018) Exemple ECA

40,42 Code blocage automatique d'absence de tarif (019) Exemple ABS

44,46 Code blocage automatique de différence entre le tarif ou le prix du contrat et le prix saisi (020) Exemple DIF

REPR_PROSPECT_OBL

21 Le représentant du prospect est obligatoire (O/N, N par défaut)

RUN_VISU_CDEF

21,26 Type et code du paramètre de lancement d'accès à la visualisation des commandes d'achat (action Visualisation cde achat)

S_F2_CONF_CAD_FAB

21,60 Complément de requête sur la table cde_cad_fab permettant de conditionner la demande de confirmation de suppression des cadencements de fabrication à la présence des lignes respectant ce critère

Lors de la suppression d'une commande ou d'une ligne de commande, les cadencements de fabrication sont tous supprimés, quelque soit la ligne de cadencement de fabrication.

On ajoute donc une demande de confirmation auprès de l'utilisateur pour qu'il prenne conscience de cette suppression.

ATTENTION : Si aucune note de complément de sélection n'est paramétrée, il n'y aura pas de messages de confirmation.

SAISIE_ADL

Pour la papeterie - Voir l'option Op1

21 Saisie de l'adresse de livraison par ligne de découpe.

O saisie de l'adresse de livraison

N adresse de livraison non saisissable et initialiser par celle de l'entête de commande (par défaut)

SCDE1

7,60 Complément de sélection sur la table d'entête des commandes clients

Cette note est accessible à tous les programmes utilisant la recherche de commandes clients, notamment (mais non exclusivement) :

La saisie de commandes clients

L'édition des AR

La saisie des BL

_SQL_CA_JOURN_MAX

21,60 Complément de requête sur les tables cde1 et cde2 pour filtrer les lignes de commande à prendre en compte pour calculer le CA d'une journée

Voir la note CA_JOURNALIER_MAX et le code blocage 040.

_SQL_REAFFECT_NVE

21,60 Complément de sélection pour la recherche des excédents (surplus) de production à réaffecter (Option Ors)

Pour la recherche des mouvements au DESOLDE de commande

_SQL_REAFFECT_VEN

21,60 Complément de sélection pour la recherche des excédents (surplus) de production à réaffecter (Option Ors)

Pour la recherche des mouvements au SOLDE de commande

_SUP_ART_NON_ACTIF

21,60 Complément de requête permettant de définir les articles pour lesquels on ne contrôlera pas si le devis associé est actif

_SUP_CDE8_VALORISE

21,60 Complément de requête sur la table cde8 permettant de restreindre les cadencements de livraison revalorisés lors du changement du prix de la ligne de commande.

Lors de la génération des lignes de cadencements de livraison lors de la saisie d'une ligne de commande client, les zones li_montant et li_surface ne sont pas alimentées.

Lors de la modification du prix de la ligne de commande, on revalorise maintenant les cadencements de livraison non facturés.

Pour faciliter la mise en place, il est possible de paramétrer des compléments de sélection sur les cadencements de livraison qui seront revalorisés.

Exemple

_SUP_CDE8_REVALORISE and li_type_liv = ‘APP'

_SUP_CDE_A_LIVRER

Complément de requête sur la table cde2 pour la recherche de commandes à livrer dans le même département sur une plage de date donnée

La plage de dates est définie dans les notes JOURS_AVANT_DATE_LIV et JOURS_APRES_DATE_LIV.

Lorsque l'on saisit une nouvelle adresse de livraison ou une nouvelle date de livraison proposée, un contrôle est effectué à la validation de la revue de contrat pour vérifier s'il y a déjà une livraison prévue dans le même département (2 premiers caractères du code postal), à une date approchant celle saisie.

Si des lignes de commande respectant ces critères sont trouvées, une fenêtre apparaît pour les lister, et l'utilisateur peut, s'il le souhaite, sélectionner une de ces lignes pour que la commande en cours de saisie soit livrée à la même date.

Pour activer cette fonctionnalité, il est nécessaire de paramétrer la plage de dates sur laquelle on veut effectuer la recherche de commandes à livrer, ainsi que le complément de requête.

Remarques

Ces 3 notes seront recherchées sur le paramètres #CF CDE si elles ne sont pas trouvées ici (sur le paramètre de lancement).

Si l'une des notes n'est pas paramétrée, alors la fonctionnalité ne sera pas active.

_SUP_CDES_ACTIVES

Affecter un devis valide pour permettre la production

Notes liées : _SUP_DEV_ACTIFS, _MSG_DEVIS_ACTIFS_1, _MSG_DEVIS_ACTIFS_2, _MSG_CDES_ACTIVES, _SUP_CDES_ACTIVES

21,60 Complément de requête sur cde2 définissant les lignes à compter pour aider l'utilisateur à choisir son devis actif (cas où il y en a plusieurs retrouvés)

_SUP_DEV_ACTIFS

Affecter un devis valide pour permettre la production

Notes liées : _SUP_DEV_ACTIFS, _MSG_DEVIS_ACTIFS_1, _MSG_DEVIS_ACTIFS_2, _MSG_CDES_ACTIVES, _SUP_CDES_ACTIVES

Lors de l'utilisation d'un même composant dans différents ensembles, il arrive au bout d'un certain temps que le devis créateur du composant ne soit plus actif.

Dans ce cas, le prix de la ligne de commande et les informations relatives à la production sont faux.

Pour retrouver un fonctionnement correct et pour avoir une définition du terme devis actif, on met en place un contrôle par complément de sélection paramétrable.

Dans le cas où le contrôle retrouve plusieurs devis actifs, il est aussi possible de paramétrer un complément de sélection sur les lignes de commandes pour compter celles qui sont actives.

21,60 Complément de sélection déclenchant le contrôle de devis actif (si non paramétré, il n'y aura pas de contrôle).

Ce complément porte sur les tables fle_2 et mat (de l'ensemble = l2_code_prod) et doit commencer par and.

Attention : Ce complément défini les devis actifs et non pas les devis à rejeter !

_SUP_REQ_CCF_DATE

21,60 Complément de sélection sur la table cde_cad_fab

Selon ce complément de sélection , on ouvrira en automatique la saisie de suivi des dates à la validation de chaque ligne.

On peut donc ouvrir la fenêtre selon le statut des cadencements de fabrication.

_SUP_REQ_CDE_CAD_FAB

21,60 Supplément de requête sur la table des cadencements de fabrication cde_cad_fab

Sert au contrôle d'autorisation de modification du prix de la ligne de commande si celle-ci a une ligne de cadencement de fabrication avec un statut à 1 ou 3 ou 5. Voir A4[23]

_SUP_REQ_CDE_OTR

21,60 Complément de requête sur les tables cde1 et cde2 pour la création ou non d'ordre de transport2

_SUP_REQ_COPIE_CDE2

21,60 Supplément de requête sur les lignes de commandes (cde2) pour éventuellement exclure certaines lignes de la recopie

_SUP_REQ_ES_CAD_FAB

21,60 Supplément de requête des entrées de stock des cadencements de fabrication (table stk0)

Voir aussi _SUP_REQ_SS_CAD_FAB

_SUP_REQ_F7_CDE

21,60 Complément de requête pour la recherche de commande

_SUP_REQ_FLE_OPE_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FLE_TRA_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_MAJ_PV_CDE

21,60 Complément de sélection de la mise à jour des prix de vente des commandes (cde1 et cde2). Obligatoire

_SUP_REQ_MAJ_PV_CD1

21,60 Complément de sélection de la mise à jour des prix de vente des commandes CD1 (cde1 et cde2). Obligatoire

_SUP_REQ_MOD_ANN_EVT

21,60 Complément de sélection sur la table evt

Avant d'annuler une commande ou une ligne de commande, le module contrôle si toutes les lignes de la commande ou la ligne de commande n'ont pas de saisie d'événements d'atelier (table evt), de temps (table fab2), de matières (table fab3) ou d'achats extérieurs (table fab5).

Pour le contrôle des événements d'atelier, un complément de sélection peut être paramétré.

Si le contrôle doit être désactivé, il suffit de paramétrer la ligne ci-dessous :

_SUP_REQ_MOD_ANN_EVT and ev_soc = XXX

_SUP_REQ_MOD_ANN_FB5

21,60 Complément de sélection sur la table fab5

Avant d'annuler une commande ou une ligne de commande, le module contrôle si toutes les lignes de la commande ou la ligne de commande n'ont pas de saisie d'événements d'atelier (table evt), de temps (table fab2), de matières (table fab3) ou d'achats extérieurs (table fab5).

Pour le contrôle des achats extérieurs, un complément de sélection peut être paramétré.

Si le contrôle doit être désactivé, il suffit de paramétrer la ligne ci-dessous :

_SUP_REQ_MOD_ANN_FB5 and f5_soc = "XXX"

_SUP_REQ_NOM0_VALID

21,60 Complément de requête sur nom0

_SUP_REQ_PROD_MN_OK

21,60 Complément de requête sur code article (table mat)

_SUP_REQ_RECLAM

21,60 Complément de requête sur les réclamations clients

Par exemple : pour que le message informant que le produit fait l'objet d'une réclamation client n'apparaisse que lorsque la réclamation est en cours (non soldée).

_SUP_REQ_RELIQ_CDE1

21 à 60 Complément de requête sur cde1 pour la recherche du reliquat

_SUP_REQ_RELIQ_CDE2

21 à 60 Complément de requête sur cde2 pour la recherche du reliquat

_SUP_REQ_SS_CAD_FAB

21,60 Supplément de requête des sorties de stock des cadencements de fabrication (table stk0)

Voir aussi _SUP_REQ_ES_CAD_FAB

_SUP_REQ_STK0

21 à 60 Complément de requête sur stk0 pour la recherche de stock.

Exemple

and s0_rgt1 not in ("AAA", "BBB")

_SUP_REQ_STK0_OUT_E

21,60 Complément de recherche sur la table stk0 lors de la recherche de mouvement de type "Entrée" pour la disponibilité des outillages

Exemple

_SUP_REQ_STK0_OUT_E and s0_typ = "EOU"

_SUP_REQ_STK0_OUT_S

21,60 Complément de recherche sur la table stk0 lors de la recherche de mouvement de type "Sortie" pour la disponibilité des outillages

Exemple

_SUP_REQ_STK0_OUT_S and s0_typ = "SOU"

_SUP_REQ_STK_MOD_PRD

21,60 Complément de requête sur la table stk0 lors de la recherche de mouvements à supprimer

_SUP_REQ_TRSCDESITLF

21,60 Lors du transfert de commande sur un autre site, il y a un contrôle vérifiant qu'il n'existe pas de lignes de commande avec une quantité livrée, facturée, ou à facturer. Cela concerne aussi des lignes de frais.

Ce complément de requête sur la table cde2 permet d'exclure de ce contrôle les lignes de frais.

_SUP_REQ_TSC_COPLIG

Complément de sélection des informations complémentaires à prendre en compte lors de la recopie d'une ligne de commande

Cette note est prioritaire sur celle de #CF CDE.

Exemple

Complément de sélection permettant de ne pas recopier les codes blocages saisis sur la ligne de commande source :

and ic_ts[1,2] != "RC"

_SUP_REQ_TSC_PDT_ADL

21,60 Complément de sélection pour la recherche des informations complémentaires (TSC) contenant les couples client/adresse secondaire de livraison.

Ces informations complémentaires seront saisies sur les produits.

Exemple

and ic_ts[1,2] = "AL"

Par défaut, on prend ce complément de sélection sur le paramètre de configuration de la saisie de commandes (#CF CDE).

Les TSC concernés doivent être paramétrés ainsi :

Zone F (ic_char3_1) : Saisie de l'adresse secondaire

Zone G (ic_char30) : Saisie du code client

_SUP_REQ_VISU_BES

21,60 Complément de requête pour la recherche d'existence de besoins matières.

Cette note existe aussi dans le transfert du devis en commande.

Exemple

_SUP_REQ_VISU_BES and uc_etat = 'A'

Voir la note PARAM_LCT_VISU_BES.

_SUP_STK0_VISU_LL

21,60 Complément de sélection sur stk0 dans la recherche des stocks par lot lieux

Exemple : and stk0.s0_rgt1 != "XXX"

_SUP_TAB_AFF_STK0

Supplément de requête sur la table temporaire tab_aff_stk0

Les champs de cette table sont :

prod_aff_stk0 Code ensemble ou PF

code_aff_stk0 Numéro lot + Code lieu

sdisp_aff_stk0 Stock disponible

sphy_aff_stk0 Stock physique

scdef_aff_stk0 Stock en commande

sres_aff_stk0 Stock réserve

sdispi_aff_stk0 Stock disponible immédiat

Pour un supplément de requête sur le code article de la ligne de commande, la variable p_lc.lc_prod doit être utilisée.

Exemple

_SUP_TAB_AFF_STK0 and sphy_aff_stk0 > 0

_SUP_TAB_AFF_STK0 and sres_aff_stk0 = 0

_SUP_TAB_AFF_STK0 and prod_aff_stk0 != p_lc.lc_prod

But de cette note

Ouverture automatique de la visualisation simplifiée des stocks (Touche F37)

La visualisation simplifiée des stocks est ouverte juste après la saisie de la quantité commandée si celle-ci a été modifiée.

Pour que la visualisation simplifiée des stocks soit ouverte :

l'option payante BAS-13 doit être activée

le supplément de requête ci-dessus doit être paramétré

la requête sur la table temporaire tab_aff_stk0 doit trouver au moins 1 enregistrement

_SUP_TAB_VISU

Supplément de requête sur la table temporaire tab_visu

Les champs de cette table sont :

code_visu Numéro lot + Code lieu

sdisp_visu Stock disponible

sphy_visu Stock physique

scdef_ visu Stock en commande

sres_visu Stock réserve

sdispi_visu Stock disponible immédiat

_TIT_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_DOCUMENT

21,23 Type de document (ACR)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TITRE_ENTETE

TITRE_ENTETE_DATE

TITRE_ENTETE_EC1

TITRE_ENTETE_LIBELLE

TITRE_ENTETE_MENU

TITRE_ENTETE_NUMERO

TITRE_ENTETE_TYPE

Ces notes permettent de paramétrer les titres.

21,28 Titre de date commande de l'entête

21,60 Libellé du champ Site de production - Tableau de bord du multisite

21,36 Titre de libellé de l'entête

21,40 Titre du menu dans l'entête

21,36 Titre de numéro de l'entête

21,36 Titre de type de l'entête

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage

TNAC

Possibilité de paramétrer les types de commande non acceptés en création de commandes
5 à 60 TYC non acceptés en création de commandes

Exemple TNACCD1CD2 Pas de création de commandes pour les TYC CD1 et CD2

TOL_SOUMISE_A_BLOCAG

21,59 Liste des tolérances de quantité (paramètre TOL)

Les codes sont inscrits par valeur de 3 caractères. 13 codes possibles.

Voir le code blocage 037 ainsi que BLO A3[7].

TSC_CCL_A_RECOPIER

Recopie des TSC du client livré

21 à 23 Code du TSC à recopier

TSC_CLI_A_RECOPIER

Recopie des TSC saisies sur le client principal de la commande

21 à 23 Code du TSC à recopier

Le préfixe utilisé pour les codes blocage se paramètre en #CF CDE, alpha3[37,38]

TSC_CLI_MSG_ORDRSP

21,23 TSC client contenant le paramétrage de lancement de l'interface ORDRSP

TSC_FAD_A_RECOPIER

21 à 23 Code du TSC à recopier (exemple : PAL)

Pour recopier tous les TSC saisis sur la commande de rattachement, mettre le symbole *.

TSC_MAT_A_RECOPIER

Recopie des TSC saisies sur l'article de la commande

En création de ligne de commande, il est possible de recopier des TSC saisies sur l'article de la commande

21 à 23 Code du TSC à recopier

Voir #CF CDE alpha3[37,38]

TSC_PRIX_A_LA_TONNE

Mise en place un blocage de la commande suite à la vérification du prix à la tonne par rapport à une fourchette de prix paramétrée

Voir le code blocage 027

Les bornes de prix paramétrées sont recherchés dans l'ordre suivant :

Sur une information complémentaire saisie sur l'article de la ligne de commande

Sur une information complémentaire saisie sur le client de l'entête de commande

Sur une note saisie sur le couple famille/sous-famille

Sur une note saisie sur la sous-famille

Sur le paramétrage du code blocage

21,23 Code TSC de saisie des bornes de prix à la tonne

24 Zone TSC de saisie de la borne inférieure du prix à la tonne
Par défaut : C (zone numérique 1)

25 Zone TSC de saisie de la borne supérieure du prix à la tonne
Par défaut : D (zone numérique 2)

TYP_NOTE_EXCEDENT

Type de la note correspondant à l'excédent. Ex : ARE

TYPE_COUTEAU

13 Code couteau

ATTENTION Ces deux colonnes sont indissociables :

CIC associés P41 à P60 (Paramétrés comme les CIC N01 à N20)

TYPE_LIAISON_CTR

21,23 Type de liaison (Paramètre LIE, zone Lié de l'entête de commande) au contrat utilisé pour la génération automatique des commandes de TYC CD1. La commande de TYC CD1 sera liée au contrat par ce type de liaison paramétré et par le numéro du contrat.

TYPE_NOTE_ART_AFF

21,23 Type de notes à afficher

24 Affichage permanent O/N, N par défaut)

Les notes n'apparaîtront que sur les nouvelles lignes de commande.

L'option Onp permet d'afficher automatiquement des notes dont le type est paramétré via la note TYPE_NOTE_ART_AFF.

En cas d'absence de notes de ce type sur l'article, on étend ce mécanisme en cascade avec la sous-famille puis la famille.

Les notes sont paramétrées sur le paramètre SFM pour la sous-famille et FAM pour la famille comme suit.

Exemple

TYPE_NOTE_ART_AFF #CC

Sur la famille palette (FAM PAL) : note #CC, avec la ligne de notes à afficher, indiquée dans les caractères 4 à 60.

TYPE_NOTE_CLI_AFF

Ouverture des notes sur le client à la création et validation de l' entête de commande.

21 à 23 Type de note à afficher ; par défaut : AR

_TYPE_NOTE_JDE_

21,23 Type de note - SPECIFIQUE

En fonction de certains types de note paramétrés, si les notes sont modifiées sur l'entête de commande ou sur la ligne , la commande est mise à re transférer.

La ligne de commande doit être non soldée, non annulée.

La FBI rattachée est également mise à jour si elle est livrable (non soldée).

TYPE_NOTE_REMISE

21 à 23 Type de note où les lignes de notes sur remise seront copiées

Nécessite l'option Ont

TYPE_NOTE_TARIF

21 à 23 Type de note où les lignes de notes sur tarif seront copiées

Nécessite l'option Ont

TYPE_NOTES_CLIENT

21, 23 Type de notes client

TYPE_NOTES_INTERNE

21, 23 Type de notes interne

TYPE_REFOULEUR

Saisie des pointages dans l'écran de saisie des refoulages (ajout d' une colonne)

15 code refouleur

TYPE_TOTAL_FACTURES

21 Type d'affichage du total des factures dans le CONTROL-F

H HT

T TTC (Valeur par défaut)

_TYPE_TSC_CAD

21 Type du TSC du cadencement de livraison

1 Ligne de cadencement de livraison (par défaut)

2 Ligne de commande si article générique ou article si article non générique

UNICITE_CDE_DAT_LIV

Nombre de jours de tolérance en + ou en -

Permet de fixer des tolérances sur la date de livraison pour le contrôle de l'unicité du quintuplet : client - produit - adresse de livraison - quantité - date de livraison

UNICITE_CDE_TOL_QTE

Pourcentage de la quantité commandée en +ou en -

Permet de fixer des tolérances sur la quantité de livraison pour le contrôle de l'unicité du quintuplet : client - produit - adresse de livraison - quantité - date de livraison

UNITE_SURFACE_FEFCO

21,23 Unité de calcul de la surface du FEFCO (Code dimension SUR)

M2 : surface unitaire calculée en mètre carré

MM2 : surface unitaire calculée en millimètre carré (valeur par défaut)

Utilisé pour la mise à jour du poids de la ligne de commande par la saisie des besoins (#CF SMC A2[3] et A2[5])

UNVENT_AU_BAREME_DEF

21,23 Unité de vente au plus des barèmes par défaut

L'option Oba doit être activée.

Facultatif

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

VERIF_DELAI_REAP_ACC

Contrôle si le stock d'accessoires nécessaires pour la ligne de commande est suffisant.

Si insuffisant, contrôle si le délai de réapprovisionnement de ces accessoires est suffisant pour la date demandée

VERIF_PLANIFICATION

Contrôle si la ligne de commande est déjà planifiée ou produite en cas de modification

VERIF_PRIX_SAISI

21 Contrôle du prix saisi par rapport au tarif sur la ligne de commande

N Pas de contrôle

W Contrôle en warning

B Contrôle bloquant

C Contrôle avec demande de confirmation

VISU_PLANIFICATION

Permettre l'accès à la visualisation de l'état en production depuis les commandes (revue de contrat et interrogation)

VISU_GROUPAGE_BL

21,26 Type et code du paramètre de lancement de la visualisation des groupages BL

On passera en argument le N° de commande sur 8 caractères et le N° de ligne sur 3 caractères.

Contrôle d'existence d'autres commandes en livraison sur la même plage de dates dans un même département

Pour chaque code département, on peut désormais définir un type de contrôle différent en DEP A1[25] :

N Aucun contrôle

O Contrôle standard (tel qu'il fonctionne actuellement)

L Contrôle restreint sur le même lieu intermédiaire, sinon sur la même adresse de livraison d'un même client.

X Contrôle restreint sur le même regroupement d'adresses de livraison.
En effet, si plusieurs adresses secondaires se trouvent physiquement proches, on désormais les indiquer comme étant regroupées sous une adresse de livraison commune dans un nouveau TSC RAL rattaché à la fiche client ou à l'adresse secondaire.

On peut également préciser via le TSC CLV rattaché à la fiche client si l'on souhaite que la fonctionnalité soit active ou non pour un client donné. Si l'on désactive la fonctionnalité, aucun contrôle ne sera effectué sur l'existence d'autres commandes clients livrées dans le département sur la plage de date concernée.

Sur l'écran de visualisation des commandes clients trouvées par le contrôle effectué, un indicateur indique désormais s'il existe au moins un groupage BL rattaché à cette ligne de commande. Une action permet également d'accéder directement à la visualisation des groupages BL rattachés à cette ligne de commande (touche F9).

VISU_STK_DEPUIS_VS

21, 26 Type et code paramètre pour lancer le programme de visualisation des stocks depuis ce récapitulatif

VISU_STK_EC_PARAM

Accès à la visualisation des mouvements de stock d'une commande depuis son entête (CTRL B)

21, 26 Type et code paramètre de la visualisation des stocks

VISU_STK_EC_SQL

21,60 Complément de sélection pour la visualisation des stocks

VSTK0SIMP_COUL_NEG

21,60 Couleur des chiffres s'ils sont négatifs dans la visualisation simplifiée des stocks.

Par défaut : couleur rouge

Le paramétrage est le même que pour les styles et/ou les visus.

Fin des notes triées

Saisie du détail du prix

Il s'agit d'une saisie améliorée de notes en faisant F7 sur la zone prix

Une fenêtre est alors ouverte dans laquelle on peut saisir en tableau

  • Un code paramètre (paramètre DPC). Ce code paramètre ramène le libellé

  • Une quantité

  • Un prix

  • Une unité de vente

Au F10, le total des prix saisis est retourné et affiché dans la zone prix.

Les lignes saisies sont mémorisées dans les notes liées à la ligne de commande (note de type #dp en minuscules).

Paramètres de configuration associés

#CF CDE | Gestion des zones paramétrées
TYC | Types des commandes clients
USE | Gestion des droits des utilisateurs
#CF ATL | Configuration générale Atlas

Sur la fiche société, possibilité de saisir des frais d'expédition par la touche F29 par le caractère 30 des options (sur entête de commande).

A la validation de l'entête de la commande ou après le dernier champ de la ligne de commande, lancement automatique de certaines touches de fonction : paramètre TYC, notes commençant par FA

Contrôle de cohérence de la date client, de la date proposée, des dates de départ et de fin de fabrication : paramètre TYC, notes commençant par COH_DATE

Contrôle de l'accès aux champs : paramètre TYC, notes commençant par #CA

Contrôle laboratoire blocage laboratoire

Positionner un blocage laboratoire en automatique lors de la création des lignes de commandes clients.

En effet, avant de pouvoir être livrées, certaines fabrications nécessitent un contrôle laboratoire particulier.

Cette fonctionnalité permet de positionner en automatique un code blocage laboratoire pour empêcher l'édition des ordres de chargement correspondants et donc la livraison de la marchandise tant que celle-ci n'a pas été libérée par le laboratoire.

Cette fonctionnalité est activée dans 3 modules :

  1. Dans la saisie des commandes clients, lorsqu'une nouvelle ligne est créée dans une commande de type FBI ou FB2.

  2. Dans l'édition des accusés de réception, lorsque l'édition d'une commande client déclenche la génération d'une commande client de type FBI.

  3. Dans le profil de stock, lorsque une commande de type FBI est générée (Touche F12).

Pour qu'un blocage laboratoire soit positionné, les conditions suivantes doivent être remplies :

  1. Le contrôle laboratoire doit être activé. #CF LAB, alpha1[1] = O.

  2. Le blocage laboratoire doit être activé. #CF LAB alpha1[2] = O.

  3. La commande doit être de type FBI ou FB2.

  4. Si le client est pris en compte, celui-ci doit être soumis au blocage laboratoire. #CF LAB alpha1[3] = O.
    Champ ic_char3_1 du TSC XXX (#CF LAB alpha1[4,6]) saisi sur les clients = O.

  5. Si la commande est de type FBI, le code qualité ou le type estampille de l'architecture du produit de la ligne doit déclencher un blocage laboratoire.
    Code qualité : Champ ic_char30 du TSC 045
    Paramètre .CQ XXX, alpha1[11]     = O.
    Type estampille : Champ ic_char3_1 des TSC XXX (#CF LAB, notes commençant par COMP_SELECT_ESTAMP)
    TES     XXX, alpha1[1] = O.

Voir aussi

édition des AR, A3[7,9]

les notes de CBACON

le paramétrage de labo

#CF CDE, alpha3[37,38]

le paramètre BLO

le paramètre TES

Si la commande est de type FB2, le code qualité du produit de la ligne pour les produits cartonniers doit déclencher un blocage laboratoire.

Code qualité : Champ ic_char30 du TSC 045

Paramètre .CQ XXX, alpha1[11] = O.

Le déblocage peut se faire de 2 manières :

  1. Dans la fenêtre de la revue de contrat de la saisie des commandes clients, la touche F6 sur un code blocage permet de changer l'état du blocage (Bloqué à débloqué ou Débloqué à bloqué).

  2. Dans la fenêtre de la revue de contrat de la saisie des contrôles laboratoire (Touche F17), la touche F6 sur un code blocage permet de changer l'état du blocage (Bloqué à débloqué ou Débloqué à bloqué).

Initialisation du qualificatif

Le qualificatif de la revue de contrat est initialisé avec le type d'appel paramétré dans les caractères 21 à 23 de la note commençant par QUAL_APPEL_LIV_TDC du TYC de la commande lorsque celui-ci n'est pas renseigné.

Le qualificatif de la 1ère ligne de l'écran des cadencements de livraison est initialisé avec le type d'appel paramétré dans les caractères 21 à 23 de la note commençant par QUAL_APPEL_LIV_TDC du TYC de la commande lorsque celui-ci n'est pas renseigné.

L'option -Oqd permet d'accéder au qualificatif de la revue de contrat.

L'option -Ocl permet de synchroniser les cadencements de livraison avec la revue de contrat.

Le A4[36] du paramètre de lancement permet de synchroniser la revue de contrat avec la 1ère ligne de cadencement de livraison.

En modification des cadencements de livraison, le qualificatif n'est plus modifiable dans le cas où le précédent qualificatif ne mettait pas à jour les stocks et le nouveau qualificatif les met à jour.

Paramétrage à mettre en oeuvre pour l'initialisation du qualificatif

cde option Ocl

Synchronisation du cadencement de livraison avec la revue de contrat

Avec cette option, on synchronise certaines données de la revue de contrat avec celles de la première ligne de cadencement de livraison (et inversement).

Ces données sont les suivantes :

les 4 dates (demandée, proposée, client et fabrication)

la tolérance quantité livrée

l'adresse de livraison (si so_options[19] = O)

l'adresse de facturation (si so_options[37] = O)

cde option Oqd

Saisie du qualificatif de l'appel de livraison dans la fenêtre de saisie des dates de livraison.

Uniquement sur les lignes de commande

cde A4[36]

Contrôle de cohérence entre les valeurs du cadencement de livraison et de la revue de contrat

0 pas de contrôle

1 contrôle par rapport à la première ligne non annulée des cadencements de livraison

2 contrôle par rapport à la première ligne non annulée et non soldée des cadencements de livraison

QAL A2[13]

Gérer la sortie réserve en saisie de commande client (cf paramétrage du type de mouvement en QAL A2[1,3] (O/N, O par défaut)

QAL A2[14]

Gérer l'entrée prévisionnelle sur lieu intermédiaire en saisie de commande client (cf paramétrage du type de mouvement en QAL A2[4,6] (O/N, O par défaut)

TYC note INIT_TOL_QAL_LIGNE

Initialisation des tolérances

21 Initialisation du code tolérance quantité (TOL) de la ligne de commande en saisie de commandes clients avec celui du client
(O/N, O par défaut)

22 Initialisation du code tolérance délai (QAL) de la ligne de commande en saisie de commandes clients avec celui du client
(O/N, O par défaut)

TYC note QUAL_APPEL_LIV_TDC

Type d'appel de livraison pour alimenter la table cde8

Transfert de commande sur un autre site

La commande d'origine génère une commande interne et une commande d'achat.

3 TSC sont utilisés pour stocker le numéro de commande.

TSC LCO Ligne de Commande Origine

TSC LCC Ligne de Commande Client

TSC LCF Ligne de Commande Fournisseur

Pour chacun de des 3 TSC, on utilise la zone alpha de 30 caractères.

Chaque commande "connaît" les 2 autres commandes :

Commande d'origine

TSC LCC : commande interne générée

TSC LCF : commande d'achat générée

Commande interne générée

TSC LCO : commande d'origine

TSC LCF : commande d'achat générée

Commande d'achat générée

TSC LCO : commande d'origine

TSC LCC : commande interne générée

Voir aussi la note SUP_REQ_TRSCDESITLF

Réactualisation du récapitulatif des coûts

Dans la saisie et/ou la visualisation des commandes clients, permettre de visualiser et de réactualiser le récapitulatif des coûts dans l'environnement Devis multi-métiers.

Remarques :

" Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients/Récapitulatif des coûts).

" Le récapitulatif des coûts est réactualisé via un recalcul simplifié à partir des tables du devis associé à la ligne de commande.

" Les indicateurs d'environnement CEV sont enregistrés dans le type M de l'historique de prix de revient (hist_pr)

" Les indicateurs d'environnement CER sont enregistrés dans le type N de l'historique de prix de revient (hist_pr)

" Le calcul de l'environnement réel n'est effectué que si des paramètres de configuration spécifiques sont renseignés (voir note commençant par CONFIG_DEG_DER_REEL).

Les notes suivantes doivent être paramétrées :

AUTORISE_TOUCHE_F51

CONFIG_DEG_DER_PREV

CONFIG_DEG_DER_REEL

PARAM_INDICATEURS

Si la note PARAM_INDICATEURS n'est pas paramétrée, les notes suivantes seront recherchées ici (paramètre de lancement de la saisie de commande).

Si elle est paramétrée, elle indique le paramètre de configuration (généralement #CF REC) où rechercher ces notes :

_VAR_INDIC_

_FOR_INDIC_

_TIT_INDIC*

CODE_BLOCAGE_RCP

LISTE_TYC_CALC_RCP

_SUP_REQ_FLE_TRA_RCP

_SUP_REQ_FLE_OPE_RCP

Liste des champs disponibles dans les notes LIGPAR et LIGPAR_RC

La liste est triée par ordre alphabétique.

Pour champ, il est précisé s'il est accessible dans la note LIGPAR ou LIGPAR_RC, ou les 2.

LIGPAR LIGPAR_RC des_article_long (concaténation mp_des et mp_des2)

LIGPAR LIGPAR_RC ec_devise, libc_ec_devise, libl_ec_devise

LIGPAR LIGPAR_RC ec_ref_cderat

LIGPAR LIGPAR_RC ec_sold

LIGPAR --------- ge_annul Code annulation

LIGPAR --------- ge_code_gamme Code gamme

LIGPAR --------- ge_colisage Colisage (Oui/Non/Indifférent)

LIGPAR --------- ge_decoupe Découpe (Oui/Non/Indifférent)

LIGPAR --------- ge_delai_securite Délai de sécurité pour la gamme

LIGPAR --------- ge_des_gamme Désignation de la gamme

LIGPAR --------- ge_expert Gamme utilisée en devis expert

LIGPAR --------- ge_jonction Jonction (Oui/Non/Indifférent)

LIGPAR --------- ge_max_couleur Nombre max de couleurs

LIGPAR --------- ge_min_couleur Nombre mini de couleurs

LIGPAR --------- ge_site Site de la gamme

LIGPAR LIGPAR_RC lc_bareme, libc_lc_bareme, libl_lc_bareme

LIGPAR LIGPAR_RC lc_delcli

------ LIGPAR_RC lc_delfab

LIGPAR LIGPAR_RC lc_delrep

LIGPAR LIGPAR_RC lc_fam

LIGPAR LIGPAR_RC lc_gen_dos_fab

LIGPAR LIGPAR_RC lc_haut

LIGPAR LIGPAR_RC lc_larg

LIGPAR --------- lc_lib

LIGPAR LIGPAR_RC lc_lieu_rgt1, libc_lc_lieu_rgt1, libl_lc_lieu_rgt1

LIGPAR LIGPAR_RC lc_long

LIGPAR LIGPAR_RC lc_p3

LIGPAR LIGPAR_RC lc_prx

LIGPAR LIGPAR_RC lc_prx_au_moins

LIGPAR LIGPAR_RC lc_prx_au_plus

LIGPAR LIGPAR_RC lc_prx_moins_dev

LIGPAR LIGPAR_RC lc_prx_moins_euro

LIGPAR LIGPAR_RC lc_prx_plus_dev

LIGPAR LIGPAR_RC lc_prx_plus_euro

LIGPAR LIGPAR_RC lc_qtecde

------ LIGPAR_RC lc_qtefac

LIGPAR LIGPAR_RC lc_qualif_appel, libc_lc_qualif_appel, libl_lc_qualif_appel, libs_lc_qualif_appel

------ LIGPAR_RC lc_rstafa

LIGPAR LIGPAR_RC lc_rstfab

------ LIGPAR_RC lc_rstfac

LIGPAR LIGPAR_RC lc_sfm

LIGPAR LIGPAR_RC lc_solde

LIGPAR LIGPAR_RC lc_surface

LIGPAR --------- lc_trsafa

LIGPAR LIGPAR_RC lc_tva, libc_lc_tva, libl_lc_tva, zc1_lc_tva

LIGPAR LIGPAR_RC lc_unvent, libc_lc_unvent, libl_lc_unvent, zc1_lc_unvent

LIGPAR LIGPAR_RC lc_unvent_au, libc_lc_unvent_au, libl_lc_unvent_au

LIGPAR LIGPAR_RC lieu_destockage

LIGPAR --------- m_lineaire_plancher

LIGPAR LIGPAR_RC mp_cond, libc_mp_cond, libl_mp_cond

LIGPAR LIGPAR_RC mp_fam

LIGPAR LIGPAR_RC mp_param_22

LIGPAR LIGPAR_RC mp_sbes

LIGPAR LIGPAR_RC mp_scdef

LIGPAR LIGPAR_RC mp_sdisp

LIGPAR LIGPAR_RC mp_sfm

LIGPAR LIGPAR_RC mp_sphy

LIGPAR LIGPAR_RC mp_sres

LIGPAR --------- mtt_total_ht_vente

LIGPAR --------- poids_total

LIGPAR --------- prix_au_colis

LIGPAR --------- prix_unitaire_ht_vente

LIGPAR LIGPAR_RC qte_fab_fbi

LIGPAR LIGPAR_RC qte_raf_cda

LIGPAR LIGPAR_RC qte_ral_cda

LIGPAR LIGPAR_RC qte_tot_cda

LIGPAR LIGPAR_RC quantite_initiale_sap

LIGPAR LIGPAR_RC ref_client

LIGPAR --------- sphy_sit Stock physique d'un lieu rattaché au site (ec_c1)


Copie des commandes clients

Copie des commandes clients cocde

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande

Exemple : -N[ec_num]

TYC A1[9] doit être = O.

Valeurs numériques

1

Numéro du compteur (nul par défaut)

Options

Oas | En création d'adresse secondaire par (F9) on met des blancs. Par défaut, on propose l'adresse principale du client.
Oci | Client initialisé à blanc (pas d'initialisation avec le client de la commande à recopier) Cela oblige l'utilisateur à le saisir.
Oco | Transfert de toutes les notes de la commande
Ocr | S'il y a modification du TYC en FAD ou AVO, la commande de rattachement sera initialisée avec la commande de rattachement de la commande initiale.
Oic | Prise en compte des informations du client dans tous les cas
Olf | L'adresse livraison des lignes est toujours celle de l'entête de commande créée (au lieu de celle des lignes de commande copiées).
Omd | Autorise la modification des dates de livraison dans l'entête
Omp | Mise à jour de la zone paramétrée (ec_tour) de l'entête de commande avec la valeur paramétrée en A2[1,3].
Omt | Modification du TYC autorisé Une fenêtre s'ouvre afin de pouvoir changer le TYC
Ond | Modification autorisée du numéro de devis (+ sous devis et entité) ATTENTION VALABLE UNIQUEMENT POUR CHANGER UNE COMMANDE DE TYPE FAD EN AVO ET INVERSEMENT
Ony | Prise en compte de la numérotation annuelle
Opr | Pas de calcul de la référence client
Oun | Force le nombre de copies à 1.

Valeur alpha 2

Caractères 1 à 3

Valeur mise dans la zone paramétrée (ec_tour) de l'entête de commande si le paramètre mp est positionné.

Notes

CTGNOT | Possibilité de ne copier que quelques types de notes (avec la paramètre co) 7 à 60 Types de notes à recopier (18 Maxi) Une seule ligne de notes sera prise en compte; si pas de ligne, tous les types de notes seront recopiés
MAJ_CDO_LIG_ENTETE | Mise à jour du centre dominant 21 Mise à jour du centre dominant des lignes avec celui de l'entête (O/N, N par défaut) 22 Centre dominant de l'entête obligatoire (O/N, N par défaut) 23 Centre dominant de la ligne non saisissable (O/N, N par défaut) O il est non saisissable N il est non non saisissable, autrement dit il est saisissable
MAJ_REP_LIG_ENTETE | Mise à jour du code représentant 21 Mise à jour du code représentant des lignes avec celui de l'entête (O/N, N par défaut) 22 Code représentant de l'entête obligatoire (O/N, N par défaut) 23 Code représentant de la ligne non saisissable (O/N, N par défaut) O il est non saisissable N il est non non saisissable, autrement dit il est saisissable


Utilitaire d'enchaînement de commandes

Utilitaire d'enchaînement de commandes enccde

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[ec_num]

Options

-Osl

Sélection de la ligne de commande

Notes

Caractères 1 à 30 :

Libellé de l'option du menu

Possibilité de lancer de 1 à 5 programmes avec une seule option du menu

31 à 36 Type et code du paramètre de lancement du programme 1

37 à 42 Type et code du paramètre de lancement du programme 2

43 à 48 Type et code du paramètre de lancement du programme 3

49 à 54 Type et code du paramètre de lancement du programme 4

55 à 60 Type et code du paramètre de lancement du programme 5

Exemples

1 à 30 : Saisie des commandes clients

31 à 36 : #SACDE

1 à 30 : Calcul et édition du prix de revient

31 à 36 : #FBCPR

37 à 42 : #EDPRV


Etat d'avancement d'une commande

Etat d'avancement d'une commande cde_maj_avancement

Saisie de l'état d'avancement d'une commande (lc_p1) par code barre.

On saisit au code barre le numéro de commande puis l'état d'avancement de celle-ci.

Le paramètre lc_p1 est ensuite sauvegardé automatiquement.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande-Numéro de ligne de commande

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+<<&]

Valeur numérique 1

Numéro de ligne de commande par défaut

Valeur alpha2

Caractères 1 à 3 | Type de paramètre Etat d'avancement de la commande
Caractères 4 à 6 | Type de paramètre Lieu


Transfert SYLOGI des commandes

Transfert SYLOGI des commandes sylogi_cde

Notes

Paramétrage d'horizon

Paramétrage d'un horizon de sélection des commandes à transférer lorsque celles-ci comportent au moins une machine de sous-traitance dans une des gammes.

Ce paramétrage d'horizon est prioritaire sur le paramétrage de l'horizon pays/département

NB_JOUR_STR

30 à 35 Nombre de jours de l'horizon de transfert pour les commandes ayant de la sous-traitance


Intégration EDI des commandes, appels de livraison et prévisions de livraison

Dans v_edi_cde

les options Ogb et Obl permettent de générer des commandes en automatique.

paramétrer entre autres les notes suivantes :

CTRL_PRIX_0_TYC_ Contrôle du prix à zéro

FICHIER_TRACE_GB Trace de la génération automatique de commande

_SUP_REQ_LIB_INVRPT Complément de sélection pour la recherche de référence sur transfert EDI via les libellés étrangers

TYPE_MVT_ Type du mouvement

TSC_POUR_ENREG_MVT Code du TSC qui va enregistrer le type du mouvement sur la ligne du bon de livraison

S Complément de requête sur la table edi_cde

Ici (dans integrer_edi_cde), un paramétrage minimum est requis pour l'intégration des inventaires.

A2[1,4] Délai d'attente entre chaque boucle (en minutes)

Les valeurs alpha 3 et 4 sont à prendre dans ce tableau, et non pas dans les tableaux "standards" plus bas dans ce document.

Options pour l'intégration de INVRPT

Oti

Intégrer tous les fichiers reçus du client qui peuvent être en doublon.

Le but est de pouvoir intégrer différents types de mouvements dans edi_cde.

Pour ensuite créer des commandes et des bons de livraisons avec différents TMV.

Légende pour les valeurs alpha 3 et 4

O Obligatoire

D Défaut et obligatoire

F Facultatif

Valeur alpha 3 pour l'intégration de INVRPT

On récupère les enregistrements INVREC 5, 6, 7, et 10 du fichier ETU_EDI_format fichiers EDI INVRPT

A3[5] | Référence article client (EAN) edc_ref_art_cli (O)
A3[6] | Code article fournisseur VoluPack edc_prod (ODF)
A3[7] | Libellé article edc_lib_prod (ODF)
A3[10] | Quantité edc_qtecde (O)
A3[11] | On force la valeur par défaut du champ edc_type_reap. (S/A, A par défaut).
A3[12] | On récupère le lieu de stockage sur le TSC LDE de la fiche client (zone F) (O/N, N par défaut).
A3[13] | On récupère la date de fichier pour la mettre dans la date de livraison (O/N, N par défaut).

Valeur alpha 4 pour l'intégration de INVRPT

On récupère les enregistrements INVDET 6, 8, 9 et 10 du fichier ETU_EDI_format fichiers EDI INVRPT

A4[6] | Code article client edc_prod_cli (O)
A4[8] | Nombre palette edc_nb_emb_ident (F)
A4[9] | Quantité par palette edc_qte_art_uc (F)
A4[10] | code site edc_c1 (OD)
A4[30] | Doit-on rechercher le code article VoluPack à partir du libellé étranger ? O Oui (par défaut) N Non. La recherche se fait sur la zone mp_gencod C Initialisation du champ edc_prod (zone 9 du fichier EDI) avec le champ edc_prod_cli (champ 8 du fichier)
A4[40] | L'heure de réception est-elle obligatoire (O/N, O par défaut)

Notes pour l'intégration de INVRPT

FIC_XXXXXXXX

Toutes les notes commençant par FIC

GEN_CDE_AUTO

21,26 Type et code du paramètre de lancement de la visualisation des messages EDI de commande et génération de commande

Permet de générer en automatique les commandes liées au dernier import.

_SUP_REQ_LIB_INVRPT

21, 60 Complément de sélection pour la recherche de référence sur transfert EDI via les libellés étrangers

Le mot clé %PRODUIT% peut être utilisé : il sera remplacé à l'exécution de la requête par le code produit utilisé au moment du transfert.

Exemple : and le_libelle2 = %PRODUIT%

A partir du moment où un complément de sélection est paramétré, la zone de recherche n'est plus précisée (and [zone de lib_etr] = [produit utilisé dans l'interface EDI]).

Dans ce cas, il est nécessaire de l'ajouter manuellement au complément de sélection grâce au mot clé %PRODUIT% (and [zone] = %PRODUIT%).

TYPE_MVT_A_INTEGRER

Si cette note est utilisée, la zone N° du message est différente dans l'EDI.

(Voir tableau de construction de INVRPT)

21,22 Type du fichier à transférer

24,28 Type du mouvement à transférer

30 Valeur positive/négative du mouvement O/N (N par défaut)

O Mouvement négatif

Exemple : Une annulation de consommation

>>>>>>>>>> FIN DU PARAGRAPHE DEDIE A L'INTEGRATION DES FICHIERS INVRPT <<<<<<<<<<

Intégration EDI des commandes, appels de livraison et prévisions de livraison integrer_edi_cde

Voir aussi la fiche d'installation EDI

Voir la table edi_cde

NOUVEAU au 07/03/2014

Génération d'un fichier ORDERS via l'intégration d'un fichier à plat paramétrable

Le programme integrer_edi_cde est capable de générer, en amont, un fichier ORDERS à partir d'un fichier texte paramétrable.

Le paramétrage de cette nouvelle fonctionnalité est décrit dans une page séparée.

NOUVEAU au 27/01/2014

On utilise ce programme pour intégrer les inventaires (fichiers INVRPT) dans VoluPack.

La note GEN_CDE_AUTO permet de créer en automatique des commandes après l'intégration du fichier EDI en utilisant la visualisation des messages EDI.

Cliquez ici pour afficher / masquer ce paragraphe.

Les caractéristiques des différentes versions de fichiers EDI intégrés sont indiquées dans le tableau suivant.

Fichier | Version | Particularités
ETU_EDI_format fichiers EDI ORDERS | ORDERS V1 |
 | ORDERS V5 | Idem version 1 avec nouvelles zones : Zone paramétrée 3 (CDELIG 73) Code lieu de facturation (CDELIG 74) Lieu de facturation (CDELIG 75)
ETU_EDI_format fichiers EDI DELFOR | DELFOR V2 | Unique version
ETU_EDI_format fichiers EDI DELINS | DELINS V3 | Unique version
ETU_EDI_format fichiers EDI CALDEL | CALDEL V4 | Première version
 | CALDEL V6 | Idem version 4 avec nouvelle zone : N° de l'identifiant transport (CDEENT 34)
 | CALDEL V7 | Idem version 6 avec nouvelles zones : Qualifiant date (CDELIG 20) Code de routage de l'UM (CDELIG 21)
 | CALDEL V8 | Idem version 7 avec nouvelles zones Date début enlèvement (CDELIG 22) Heure d'enlèvement au plus tôt (CDELIG 23) Date fin enlèvement (CDELIG 24) Heure d'enlèvement au plus tard (CDELIG 25)
ETU_EDI_format fichiers EDI INVRPT | INVRPT | Intégration des inventaires envoyés par le client Voir le paragraphe dédié ci-dessous.

Options triées

Oar

Arrêt du traitement

Ocg

Type CALDEL version 8

Dans les messages de type CALDEL, pour chaque ligne de commande (message de type CDELIG), on génère un enregistrement de type CALDE1 dans la table edi_cde pour la quantité inscrite dans la ligne de commande.

Si la ligne porte sur un produit sur lequel on a indiqué la palettisation (x produits par palette), alors on génère plusieurs enregistrement de type CALDE1, chacun correspondant à une palette de x produits; le nombre de palette étant déduit de la quantité commandée et de la palettisation.

La palettisation est indiquée sur le TSC 123 (pour les ensembles montés) ou sur le TSC 220.

On recherche sur le TSC 123 en priorité; si on ne trouve rien, on continue sur le TSC 220, sinon on fait comme avant, un CALDE1 par ligne de commande.

Exemple

Le produit X a une palettisation de 5 produits par palette.

On reçoit une ligne de commande de 24 pour ce produit.

Sans cette option, on génère un enregistrement de CALDE1 pour une quantité de 24.

Avec cette option, on génère 5 enregistrement de CALDE1 (4 avec une quantité de 5 et 1 avec le reliquat de quantité, c'est-à-dire 4).

Odc

Recherche des tarifs avec la date client (zone edc_date_client)

Odl

Recherche des tarifs à la date de livraison

Ogc

Cette option permet de créer en automatique des commandes après l'intégration du fichier EDI en utilisant la visualisation des messages EDI de commande et génération de commande.

Nécessite la note GEN_CDE_AUTO.

Ogd

Gestion des doublons sur les messages de type CALDEL

Lors de l'intégration d'un message de type CALDEL, si celui-ci existe déjà avec les critères suivants :

- Site à livrer (edc_code_ean_cli, edc_pt_dechar_cli) - Tableau de bord du multisite

- Produit (edc_prod_cli)

- Date de livraison (edc_del_cli)

Si le message existe avec la même quantité il sera ignoré (création avec le statut annulation).

Intégrer ce message avec un statut particulier (Z, 1 à 9) qui signifiera dans la visualisation que c'est un doublon.

Aucune action ne pourra être menée sur ce statut.

Remarque : le doublon ne sera créé qu'une seule fois.

Le premier doublon sera créé avec le statut 1, le deuxième (pour la même clé, avec une quantité différente) avec le statut 2, &

Oip

Intégration partielle

Ne rejeter que les messages en anomalie et faire le traitement des messages corrects.

Ne pas rejeter le fichier entier.

Orl

Affichage dune ligne de récapitulatif en anomalie

Ajouter en fin d'anomalie sur un message de type :

CDEENT, les informations contenant les colonnes edc_ref, edc_cli et edc_nom_cli

CDELIG, les informations contenant les colonnes edc_ref, et edc_prod_cli

Ot3

Récupération du tarif sur la date de livraison pour les messages de version 3 ou 4

Otf

Lancement du programme en tâche de fond

Oti

Intégration des fichiers INVRPT envoyés par le client

Oup

Arrêt du traitement après un seul passage

Valeurs alpha : généralités

Cliquez ici pour ouvrir le tableau Excel EDI de paramétrage des zones dans VoluPack.

Valeur alpha 2

Caractères 1 à 4

Délai d'attente entre chaque boucle (en minutes)

Valeur par défaut : 1 minute

Le programme multiplie la valeur par 60 pour obtenir des secondes.

Caractère 12

Paramétrage de la zone 12 CDEENT

I on ignore ce qui est saisi dans cette zone et on impose sa recherche dans VoluPack avec le code client EAN (récupéré de la zone 11 CDEENT).

Remarque : si pas de paramétrage, on récupère la zone saisie; si elle est vide, on fait la recherche dans VoluPack avec le code client EAN.

Caractères 13 à 21

Voir le tableau Excel EDI de paramétrage des zones dans VoluPack.

Valeur alpha 3

Caractères 5 à 10

Intégration des fichiers INVRPT envoyés par le client

Caractère 10

Libellé du produit (O/D/d)

Le libellé du produit (edc_lib_prod) est récupéré du fichier.

O Le libellé est obligatoire.

D Le libellé est obligatoire. Si le libellé n'est pas renseigné dans le fichier, on récupère la valeur par défaut sur la désignation du produit.

d Le libellé est facultatif. Si le libellé n'est pas renseigné dans le fichier, on récupère la valeur par défaut sur la désignation du produit.

Caractères 11 à 13

Intégration des fichiers INVRPT envoyés par le client

Caractère 20

Récupération du qualifiant date, zone 20 sur une ligne de type CDELIG, à partir du fichier reçu (O/N, N par défaut)

Valeur alpha 4

Caractères 6 à 10

Intégration des fichiers INVRPT envoyés par le client

Caractère 30

Doit-on rechercher le code article VoluPack à partir du libellé étranger ?

O Oui (par défaut)

N Non. La recherche se fait sur la zone mp_gencod

C Initialisation du champ edc_prod (zone 9 du fichier EDI) avec le champ edc_prod_cli (champ 8 du fichier)

Caractère 31

Contrôle cohérence client principal

N Non (par défaut)

W anomalie warning

B anomalie bloquante

Caractère 32

Doit-on rechercher le client principal sur l'adresse de livraison (O/N, N par défaut)

Messages de type DELINS

Caractère 40

L'heure de réception est-elle obligatoire (O/N, O par défaut)

Caractères 41 à 46

Type et code du paramètre de configuration de la recherche de tarif (par défaut #CFTAR)

Caractères 47 à 49

Type de refoulage par défaut (code de type CP)

Cette valeur n'est renseignée que dans le cas d'un produit cartonnier n'ayant pas de refoulage.

Caractères 50 à 52

TSC de l'adresse de facturation du client - Facultatif

Dans l'intégration des messages CALDEL Version 4, l'adresse de facturation (edc_adf) est alimentée avec l'adresse de facturation de la fiche du client du message (cl_adrf).

Sur le paramètre de lancement, le TSC de l'adresse de facturation du client peut être renseigné.

Si celui-ci n'est pas paramétré, le mode d'alimentation reste inchangé.

Si celui-ci est paramétré, on lit ce TSC pour le client du message pour rechercher son adresse de facturation.

Si le TSC n'est pas présent, le mode d'alimentation reste inchangé.

Si le TSC est présent, c'est la valeur du champ ic_char3_1 qui est utilisée pour alimenter le champ edc_adf même si la valeur est blanc.

Notes triées

CODE_NTS_ANOMALIE

21,23 Code paramètre de type NTS

Sauvegarde le fichier anomalie dans une note formatée lié à la traçabilité des appels de programmes (table numéro 28).

CODE_NTS_TRACE

21,23 Code paramètre de type NTS

Sauvegarde le fichier trace dans une note formatée lié à la traçabilité des appels de programmes (table numéro 28).

COMPTEUR_EDC_REF

Lors de l'intégration de messages EDI PEUGEOT (type CALDEL), toutes les références commande client (EDC_REF) sont identiques, ce qui posait un problème d'intégration, car cette information sert de clé au traitement (intégration et génération de commande).

Dans ce cas, cette référence sera désormais dans la zone libellé commande client, et la zone actuelle référence client ne sera pas transmise.

Elle sera alimentée automatiquement lors de l'intégration par un compteur alphanumérique.

21,29 Code racine du compteur alphanumérique (type K)

30 Longueur du folioteur

Exemple

Car.21 à 29 = PEUG

Car.30 = 5

Cela donnera un code PEUG00001, PEUG00002, PEUG00003...

FIC_ANOMALIE

FIC_ANOMALIE_N

21,60 Nom du fichier d'anomalie sur une seule ligne

où N est le numéro d'environnement VoluPack

FIC_ARRET

FIC_ARRET_N

21,60 Nom du fichier d'arrêt sur une seule ligne (option Oar)

où N est le numéro d'environnement VoluPack

FIC_EDI

FIC_EDI_N

21,60 Nom du fichier de transfert sur une seule ligne

où N est le numéro d'environnement VoluPack

L'éventuel astérisque contenu dans le nom du fichier permet d'intégrer dans le même traitement tous les fichiers ressemblant à ce nom.

Exemples

FIC_EDI E:/VOLUPACK/SCA/edi/aviexp.in

On intègre ce fichier.

FIC_EDI E:/VOLUPACK/SCA/edi/aviexp*.in

On intègre tous les fichiers de ce répertoire commençant par aviexp et se terminant par .in

FIC_HISTO

FIC_HISTO_N

21,60 Nom du fichier de transfert pour l'historique

où N est le numéro d'environnement VoluPack

FIC_LOCK

FIC_LOCK_N

21,60 Nom du fichier de verrouillage général sur une seule ligne Plus d'infos

où N est le numéro d'environnement VoluPack

FIC_LOCK_EDI

FIC_LOCK_EDI_N

21,60 Nom du fichier de verrouillage EDI sur une seule ligne Plus d'infos

où N est le numéro d'environnement VoluPack

FIC_LOCK_VS

FIC_LOCK_VS_N

21,60 Nom du fichier de verrouillage Volume sur une seule ligne Plus d'infos

où N est le numéro d'environnement VoluPack

FIC_TRACE

FIC_TRACE_N

21,60 Nom du fichier de trace sur une seule ligne

où N est le numéro d'environnement VoluPack

GEN_CDE_AUTO

21,26 Type et code du paramètre de lancement de la visualisation des messages EDI de commande et génération de commande.

Permet de générer en automatique les commandes liées au dernier import.

Nécessite l'option Ogc.

NOTE_SUR_UV

21, 40 Nom de la note paramétrée sur le code unité de vente pour retrouver les unités de quantité et de poids correspondantes du client.

QUALITES_EXCLUES

Exclure certains articles dont le code validité contient une certaine valeur

21 à 23 Code qualité à exclure

_SUP_REQ_LIB_xxxxxx

_SUP_REQ_LIB_CALDEL

_SUP_REQ_LIB_DELFOR

_SUP_REQ_LIB_DELINS

_SUP_REQ_LIB_ORDERS

_SUP_REQ_LIB_INVRPT

21, 60 Complément de sélection pour la recherche de référence sur transfert EDI via les libellés étrangers

Le mot clé %PRODUIT% peut être utilisé : il sera remplacé à l'exécution de la requête par le code produit utilisé au moment du transfert.

Exemple : and le_libelle2 = %PRODUIT%

A partir du moment où un complément de sélection est paramétré, la zone de recherche n'est plus précisée (and [zone de lib_etr] = [produit utilisé dans l'interface EDI]).

Dans ce cas, il est nécessaire de l'ajouter manuellement au complément de sélection grâce au mot clé %PRODUIT% (and [zone] = %PRODUIT%).

Remarque pour l'ORDERS : le mot clé %ART_CLI% correspond à la zone edc_prod_cli (code produit client)

TYC_PAR_DEFAUT

21,60 TYC par défaut. Exemple : CD2

TYPE_MVT_A_INTEGRER

Intégration des fichiers INVRPT envoyés par le client

Paramètres associés

Contrôle des zones | TYC alpha3[49] pour connaître les TYC possibles en EDI (Manuel, EDI, Tous)
TYC généré par une CDA | TYC CDA, alpha4[1,3]
UNI | Lecture des paramètres UNI en utilisant les compléments sur les notes afin d'établir la liste des correspondances d'unités entre Volume Software et le client EDI.
TSC CAL | Adresse de livraison réservée CALDEL (O/N) (utilisé aussi dans cde et v_edi_cde)


Génération d’un fichier ORDERS via l'intégration d'un fichier à plat paramétrable

Génération d'un fichier ORDERS via l'intégration d'un fichier à plat paramétrable integrer_edi_cde

Cette fonctionnalité du programme integrer_edi_cde est opérationnelle à partir de la V. 4.1.46.2.

Nécessite l'option CDE-14.

Cette nouvelle fonctionnalité permet de traduire un fichier à plat paramétrable dans le format ORDERS (version 5).

A l'aide de la note TRAD_CHAMP, on décrit la structure du fichier à traduire. Une valeur par défaut peut-être paramétrée via la note TRAD_VALDEF.

Remarques

– le paramétrage du traducteur et de l'intégration des fichiers doivent être à l'image du paramétrage de la saisie de commande.
Autrement dit, toutes les zones obligatoires lors de la saisie de commande, le sont aussi lors de la traduction du fichier.
S'il y a un décalage des zones obligatoires, la génération de commande ne se fera pas.

– Les zones suivantes sont et seront toujours obligatoires.
Soit elles seront présentes dans le fichier à traduire, soit elles seront en valeur par défaut. Voici la liste des zones obligatoires :

o Le code client

o L'article

o La quantité

o La date de livraison

o Le type de commande

o Les codes EAN (COD_EAN_CLI_1 (zone 11), COD_EAN_CLI_2 (zone 19) et COD_EAN_CLI_3 (zone 22)

o Le code usine

o Le site de production (si #CF SIT A1[1] = O)

A la fin de la traduction :

– le fichier à traduire sera renommé avec l'extension .HIS.

– Le fichier traduit sera automatiquement intégré.

Nota : si la traduction du même fichier se fait deux fois, celui-ci sera intégré deux fois, car le numéro de message est généré automatiquement à chaque traduction.

Par conséquent, le numéro de message précédent ne sera pas annulé et sera recréé.

Notes triées

COMPTEUR_EDC_REF

Lors de l'intégration de messages EDI PEUGEOT (type CALDEL), toutes les références commande client (EDC_REF) sont identiques, ce qui posait un problème d'intégration, car cette information sert de clé au traitement (intégration et génération de commande).

Dans ce cas, cette référence est désormais dans la zone libellé commande client, et la zone actuelle référence client n'est pas transmise.

Cette note fait partie du paramétrage "de base" du programme intégrer_edi_cde.

Elle est alimentée automatiquement lors de l'intégration par un compteur alphanumérique.

Note obligatoire si la note FIC_TRAD ou FIC_TRAD_N est présente.

21,29 Code racine du compteur alphanumérique (type K)

30 Longueur du folioteur

Exemple

Car.21 à 29 = PEUG

Car.30 = 5

Cela donnera un code PEUG00001, PEUG00002, PEUG00003...

CTRL_CHAFIC_UNICITE

21 Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique).

Fonctionne avec la note CHAMP_FICHIER)

O chaque nom de champ doit être unique (par défaut)

N pas de contrôle

FIC_TRAD

FIC_TRAD_N

21,60 Nom du fichier à traduire dans le format ORDERS (version 5).

où N est le numéro d'environnement VoluPack.

L'éventuel astérisque contenu dans le nom du fichier permet de traduire dans le même traitement tous les fichiers ressemblant à ce nom.

Remarques :

– Les fichiers traduits seront déposés dans le répertoire défini via la note FIC_EDI (ou FIC_EDI_N).

– La présence de cette note active la traduction du ou des fichiers dans le format ORDERS (version 5).

- Note cumulative

_SUP_REQ_LIB_ORDERS

21,60 Complément de sélection pour la recherche de référence sur transfert EDI via les libellés étrangers.

Le mot clé %PRODUIT% peut être utilisé : il sera remplacé à l'exécution de la requête par le code produit utilisé au moment du transfert.

Exemple

and le_libelle2 = %PRODUIT%

A partir du moment où un complément de sélection est paramétré, la zone de recherche n'est plus précisée (and [zone de lib_etr] = [produit utilisé dans l'interface EDI]).

Dans ce cas, il est nécessaire de l'ajouter manuellement au complément de sélection grâce au mot clé %PRODUIT% (and [zone] = %PRODUIT%).

Remarque pour l'ORDERS

mot clé %PRODUIT% : correspond à la zone edc_ref_art_cli (référence article client)

mot clé %ART_CLI% : correspond à la zone edc_prod_cli (code produit client) (disponible uniquement pour l'ORDERS)

Pour les autres EDI :

mot clé %PRODUIT% : correspond à la zone edc_ref_art_cli (code produit client)

Cette note fait partie du paramétrage "de base" du programme intégrer_edi_cde.

TRAD_CHAMP

Définition de la structure des lignes de fichiers à traduire dans le format orders.

Note obligatoire si présence de la note FIC_TRAD ou FIC_TRAD_N

21,38 Nom du champ (voir la liste des champs disponibles ci-dessous).

41,43 Cas 1 (sans séparateur de champ) : Position de début de champ - Obligatoire.

Cas 2 (avec séparateur de champ) : Position séquentielle du champ -Obligatoire.

45,47 Cas 1 (sans séparateur de champ) : Longueur du champ - Obligatoire.

Cas 2 (avec séparateur de champ) : non applicable.

TRAD_CPT_NUM_MSG

Génération du numéro de message sur 14 caractères (note obligatoire)

21,29 Code racine du compteur alphanumérique (type 1)

30 Longueur du folioteur

Exemple

Car.21 à 29 = MSG

Car.30 = 5

Cela donnera un code MSG00001, MSG00002, MSG00003...

TRAD_DEBUT_FIC

21,24 Début du fichier à traduire (numéro de ligne du fichier). Par défaut : 1

TRAD_EAN_DEST

21,33 Code destinataire de l'entête du message.

Note obligatoire si présence de la note FIC_TRAD ou FIC_TRAD_N.

TRAD_EAN_EMETTEUR

21,33 Code émetteur de l'entête du message.

Note obligatoire si présence de la note FIC_TRAD ou FIC_TRAD_N.

TRAD_SEPARATEUR

21 Caractère indiquant la séparation entre deux champs sur chaque ligne des fichiers à traduire (facultatif si absence de séparateur).

TRAD_VALDEF

21,38 Valeur par défaut d'un champ

Nom du champ (voir la liste des champs disponibles ci-dessous).

41,60 Valeur par défaut.

Deux possibilités

– Soit une constante :

(exemple : TRAD_VALDEF LIB_CDE_CLI CDE VIA ORDERS).

– Soit initialisée par un champ :

(exemple : TRAD_VALDEF LIB_CDE_CLI NUM_CDE_CLI).
Par conséquent la zone LIB_CDE_CLI sera initialisée par la valeur contenue dans NUM_CDE_CLI (numéro de commande client)

Liste des champs disponibles

Ces champs reprennent la structure du fichier ORDERS V5.

Nom du champ | Description du champ | Zone CDEENT | Zone CDELIG
TYC | Type de commande | 5 |
NUM_CDE_CLI | Numéro de commande client | 6 | 5
LIB_CDE_CLI | Libellé de commande client | 7 |
DATE_CDE_CLI | Date commande client | 8 |
NUM_CDE_REF | Numéro de commande réf. | 9 |
DATE_CDE_REF | Date commande réf. | 10 |
COD_EAN_CLI_1 | Code EAN client (BY) | 11 |
CODE_CLI | Code client | 12 |
NOM_CLI | Nom client | 13 |
NOM_CONTACT | Nom du contact | 14 |
TEL_CONTACT | Tél. contact | 15 |
FAX_CONTACT | Fax contact | 16 |
USI_DEST | Usine destinataire | 17 |
SITE_PROD | Site de production | 18 |
COD_EAN_CLI_2 | Code EAN client (BY) | 19 |
COD_ACR | Code accusé de réception | 20 |
LIEU_ACR | Lieu d'accusé de réception | 21 |
COD_EAN_CLI_3 | Code EAN client (ST/DP) | 22 |
COD_LIV | Code lieu de livraison | 23 |
LIEU_LIV | Lieu de livraison | 24 |
COD_EAN_CLI_4 | Code EAN client (IV) | 25 |
COD_LIEU_FAC | Code lieu de facturation | 26 |
LIEU_FAC | Lieu de facturation | 27 |
MODE_SOUMI_TVA | Mode de soumission TVA | 28 |
DEVISE | Devise | 29 |
COND_PAIEMENT | Condition de paiement | 30 |
ECHEANCE | Echéance | 31 |
REMISE_ENTETE | Remise entête | 32 |
COND_LIVRAISON | Condition de livraison | 33 |
TYPE_TRANSPORT | Type de transport | 34 |
TEXTE_F_LIBRE_1 | Texte en format libre | 35 |
TEXTE_F_LIBRE_2 | Texte en format libre | 36 |
TEXTE_F_LIBRE_3 | Texte en format libre | 37 |
LIG_CDE_CLI | Ligne de commande client |  | 6
REF_ART_CLI | Réf. Art client (EAN) |  | 7
COD_ART_CLI | Code Art client |  | 8
COD_ART_FOU | Code Art fournisseur (VP) |  | 9
LIB_ETR_ART | Libellé étranger de l'article |  | 10
QUANTITE | Quantité |  | 11
TOL_QUANTITE | Tolérance de quantité |  | 12
PRIX | Prix |  | 13
REMISE_LIGNE | Remise ligne |  | 14
UNITE_VENTE | Unité de vente |  | 15
DATE_LIV | Date livraison |  | 16
H_LIV_PLUS_TOT | Heure de livraison au plus tôt |  | 17
H_LIV_PLUS_TARD | Heure de livraison au plus tard |  | 18
TOLERANCE_DELAI | Tolérance délai |  | 19
COD_LIV_LIG | Code lieu de livraison |  | 20
LIEU_LIV_LIG | Lieu de livraison |  | 21
COD_CONSI_LIG | Code lieu de consignation |  | 22
LIEU_CONSI_LIG | Lieu de consignation |  | 23
TEXT_LIBRE_LIG_1 | Texte en format libre |  | 24
LONGUEUR_COUPE | Longueur coupe |  | 25
LARGEUR_LAIZE | Largeur laize |  | 26
HAUTEUR | Hauteur |  | 27
REFOULAGE_1 | Refoulage 1 |  | 28
TYPE_REFOULAGE_1 | Type de refoulage 1 |  | 29
REFOULAGE_2 | Refoulage 2 |  | 30
TYPE_REFOULAGE_2 | Type de refoulage 2 |  | 31
REFOULAGE_3 | Refoulage 3 |  | 32
TYPE_REFOULAGE_3 | Type de refoulage 3 |  | 33
REFOULAGE_4 | Refoulage 4 |  | 34
TYPE_REFOULAGE_4 | Type de refoulage 4 |  | 35
REFOULAGE_5 | Refoulage 5 |  | 36
TYPE_REFOULAGE_5 | Type de refoulage 5 |  | 37
REFOULAGE_6 | Refoulage 6 |  | 38
TYPE_REFOULAGE_6 | Type de refoulage 6 |  | 39
REFOULAGE_7 | Refoulage 7 |  | 40
TYPE_REFOULAGE_7 | Type de refoulage 7 |  | 41
REFOULAGE_8 | Refoulage 8 |  | 42
TYPE_REFOULAGE_8 | Type de refoulage 8 |  | 43
REFOULAGE_9 | Refoulage 9 |  | 44
TYPE_REFOULAGE_9 | Type de refoulage 9 |  | 45
REFOULAGE_10 | Refoulage 10 |  | 46
TYPE_REFOULAGE_10 | Type de refoulage 10 |  | 47
REFOULAGE_11 | Refoulage 11 |  | 48
TYPE_REFOULAGE_11 | Type de refoulage 11 |  | 49
REFOULAGE_12 | Refoulage 12 |  | 50
TYPE_REFOULAGE_12 | Type de refoulage 12 |  | 51
REFOULAGE_13 | Refoulage 13 |  | 52
TYPE_REFOULAGE_13 | Type de refoulage 13 |  | 53
REFOULAGE_14 | Refoulage 14 |  | 54
TYPE_REFOULAGE_14 | Type de refoulage 14 |  | 55
REFOULAGE_15 | Refoulage 15 |  | 56
TYPE_REFOULAGE_15 | Type de refoulage 15 |  | 57
REFOULAGE_16 | Refoulage 16 |  | 58
TYPE_REFOULAGE_16 | Type de refoulage 16 |  | 59
REFOULAGE_17 | Refoulage 17 |  | 60
TYPE_REFOULAGE_17 | Type de refoulage 17 |  | 61
REFOULAGE_18 | Refoulage 18 |  | 62
TYPE_REFOULAGE_18 | Type de refoulage 18 |  | 63
REFOULAGE_19 | Refoulage 19 |  | 64
TYPE_REFOULAGE_19 | Type de refoulage 19 |  | 65
REFOULAGE_20 | Refoulage 20 |  | 66
TYPE_REFOULAGE_20 | Type de refoulage 20 |  | 67
TYPE_RAINAGE | Type de rainage |  | 68
LONGUEUR_PALETTE | Longueur palette |  | 69
LARGEUR_PALETTE | Largeur palette |  | 70
HAUTEUR_PALETTE | Hauteur palette |  | 71
TYPE_PALETTE | Type de palette |  | 72
ZONE_PARAM_3 | Zone paramétrée 3 |  | 73
COD_LIEU_FAC_LIG | Code adresse de facturation |  | 74
LIEU_FAC_LIG | Lieu de facturation |  | 75

Exemple de fichier CSV avec séparateur point-virgule

Paramétrage | Description
-Otfupt3 QUALITES_EXCLUES DEV FIC_EDI D:/tmp/edi/*.csv FIC_LOCK D:\tmp\edi\edi_cde_lock FIC_LOCK_EDI D:\tmp\edi\edi_cde_lock_edi FIC_LOCK_VS D:\tmp\edi\edi_cde_lock_vs FIC_ARRET D:\tmp\edi\edi_cde_arret FIC_ANOMALIE D:\tmp\edi\ano\edi_cde_anomalie FIC_TRACE D:\tmp\edi\trace\edi_cde_trace | Paramétrage de la partie intégration d'un fichier EDI (Rappel).
# -------------- Traducteur # Activation FIC_TRAD D:\tmp\edi\trad\*.csv COMPTEUR_EDC_REF ORDERS 8 TRAD_CPT_NUM_MSG MSGTEST 6 TRAD_SEPARATEUR ; TRAD_EAN_EMETTEUR EANEMET001 TRAD_EAN_DEST DEST001 | Paramétrage obligatoire pour l'activation de la traduction d'un fichier à plat.
# --- Description du fichier TRAD_CHAMP CODE_CLI 001 TRAD_CHAMP COD_LIV 002 TRAD_CHAMP COD_CONSI_LIG 003 TRAD_CHAMP COD_ART_FOU 004 TRAD_CHAMP QUANTITE 005 TRAD_CHAMP DATE_LIV 006 TRAD_CHAMP PRIX 007 | Description du fichier à plat.
# --- Zones obligatoires - Valeurs par défaut TRAD_VALDEF TYC CD2 TRAD_VALDEF COD_EAN_CLI_1 EAN1 TRAD_VALDEF COD_EAN_CLI_2 EAN2 TRAD_VALDEF COD_EAN_CLI_3 EAN3 TRAD_VALDEF USI_DEST KI TRAD_VALDEF SITE_PROD P1 TRAD_VALDEF LIB_CDE_CLI NUM_CDE_CLI | Valeurs par défaut. Rappel : les zones TYC, CODE_EAN_CLI_1, CODE_EAN_CLI_2, CODE_EAN_CLI_3, USI_DEST sont obligatoires. Ces zones ne sont pas présentes dans le fichier, alors on les initialise par des valeurs par défaut.

Exemple de fichier CSV sans séparateur point-virgule

Paramétrage | Description
-Otfupt3 QUALITES_EXCLUES DEV FIC_EDI D:/tmp/edi/*.txt FIC_LOCK D:\tmp\edi\edi_cde_lock FIC_LOCK_EDI D:\tmp\edi\edi_cde_lock_edi FIC_LOCK_VS D:\tmp\edi\edi_cde_lock_vs FIC_ARRET D:\tmp\edi\edi_cde_arret FIC_ANOMALIE D:\tmp\edi\ano\edi_cde_anomalie FIC_TRACE D:\tmp\edi\trace\edi_cde_trace | Paramétrage de la partie intégration d'un fichier EDI (Rappel).
# -------------- Traducteur # Activation FIC_TRAD D:\tmp\edi\trad\*.txt COMPTEUR_EDC_REF ORDERS 8 TRAD_CPT_NUM_MSG MSGTEST 6 TRAD_EAN_EMETTEUR EANEMET001 TRAD_EAN_DEST DEST001 | Paramétrage obligatoire pour l'activation de la traduction d'un fichier à plat.
# --- Description du fichier TRAD_CHAMP CODE_CLI 001 006 TRAD_CHAMP COD_LIV 007 003 TRAD_CHAMP COD_CONSI_LIG 010 003 TRAD_CHAMP COD_ART_FOU 013 015 TRAD_CHAMP QUANTITE 028 005 TRAD_CHAMP DATE_LIV 033 010 TRAD_CHAMP PRIX 043 010 | Description du fichier à plat.
# --- Zones obligatoires - Valeurs par défaut TRAD_VALDEF TYC CD2 TRAD_VALDEF COD_EAN_CLI_1 EAN1 TRAD_VALDEF COD_EAN_CLI_2 EAN2 TRAD_VALDEF COD_EAN_CLI_3 EAN3 TRAD_VALDEF USI_DEST KI TRAD_VALDEF SITE_PROD P1 TRAD_VALDEF LIB_CDE_CLI NUM_CDE_CLI | Valeurs par défaut. Rappel : les zones TYC, CODE_EAN_CLI_1, CODE_EAN_CLI_2, CODE_EAN_CLI_3, USI_DEST sont obligatoire. Ces zones ne sont pas présentes dans le fichier, alors on les initialise par des valeurs par défaut.


Génération des messages EDI d'avis d'expédition

Génération des messages EDI d'avis d'expédition edi_cde_aviexp

Ce programme gère des messages EDI de type AVIEXP V1 à V5 : ETU_EDI_format fichiers EDI AVIEXP

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de BL

Exemple : -N[b1_blv]

Options

-Oce

Si type de véhicule non saisi (dans BL), on prend le code TE, sinon on prend TVE A1[13,15] (avec le code véhicule saisi) (exemple : SR pour semi_remorque).

Si cette option n'est pas positionnée :

Si type de véhicule non saisi (dans BL), on prend le code TE, sinon on prend le code paramètre saisi (type de véhicule).

Omb

Autorise la création d'un fichier EDI contenant plusieurs BL (désactive l'attente de la suppression de l'ancien fichier EDI).

Oo2

Si la commande n'est pas d'origine EDI (table edi_cde), alors les champs edc_prod et edc_prod_cli sont initialisés avec le champ lc_prod.

Valeur alpha 2

1,4

Délai d'attente en minutes

Valeur par défaut : 1

Le programme multiplie la valeur par 60 pour obtenir des secondes.

Valeur alpha 3

1

Numéro de version du fichier AVIEXP généré

1 AVIEXP initial

2 = V1 + Numéro identification transport

3 = V2 + Qualifiant date

4 = V3 + Site de production - Tableau de bord du multisite

+ Référence article VP

+ Ligne de commande client

+ Numéro de commande VP

+ Ligne de commande VP

+ Solde de la ligne de commande VP

5 attente

Notes

FIC_AVIEXP | 21,60 Nom du fichier de transfert
FIC_AVIEXP_HISTO | 21,60 Répertoire et nom du fichier historique de transfert des messages de type AVIEXP Facultatif. Si celui-ci n'est pas paramétré, le nom du fichier historique AVIEXP a le même nom que le nom du fichier AVIEXP paramétré sur la note FIC_AVIEXP. Le nom du fichier historique AVIEXP est suivi de l'extension .HIS.
FIC_HISTO_AVIEXP | 21,60 Répertoire et nom des fichiers d'historisation de transfert des messages de type AVIEXP Facultatif. Si celui-ci n'est pas paramétré, le nom des fichiers d'historisation AVIEXP a le même nom que le nom du fichier AVIEXP paramétré sur la note FIC_AVIEXP. Le nom des fichiers d'historisation AVIEXP est suivi d'un compteur.
FIC_LOCK | 21,60 Nom du fichier de verrouillage général Plus d'infos
FIC_LOCK_AVIEXP | 21,60 Nom du fichier de verrouillage EDI Plus d'infos
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume Plus d'infos
FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_TRACE | 21,60 Nom du fichier de trace
NOM_DU_SHELL | 21,60 Nom du fichier de commande à exécuter en fin de traitement
NOTE_SUR_UV | 21,40 Nom de la note paramétrée sur le code unité de vente pour retrouver les unités de quantité et de poids correspondantes du client.

Paramètres associés

TVE | TVE A1[13,15] - Code EDI du code véhicule pour fichier AVIEXP
UNI | Note dont le nom est paramétré dans les notes commençant par NOTE_SUR_UV


Génération des messages EDI d'accusé de réception de commande

Génération des messages EDI d'accusé de réception de commande edi_cde_rep_cli

Ce programme génère des messages EDI de type ORDRSP en V1 ou en V2 : ETU_EDI_format fichiers EDI ORDRSP

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande

Exemple : -N[ec_num]

Valeurs numériques

1 | Compteur chrono
2 | Numéro de version

Options

Oar | Arrêt du programme en tâche de fond
Otf | Le programme tourne en tâche de fond
Oup | Arrêt du programme en tâche de fond après un seul passage

Valeur alpha 2

1,4

Délai d'attente en minutes

Le programme multiplie la valeur par 60 pour obtenir des secondes.

Valeur par défaut : 1 seconde

Notes triées

FIC_ANOMALIE

21,60 Nom du fichier d'anomalie

FIC_ARRET

21,60 Nom du fichier dont l'existence arrête le programme

FIC_LOCK

21,60 Nom du fichier de verrouillage général Plus d'infos

FIC_LOCK_ORDRSP

21,60 Nom du fichier de verrouillage EDI Plus d'infos

FIC_LOCK_VS

21,60 Nom du fichier de verrouillage Volume Plus d'infos

FIC_ORDRSP

21,60 Nom du fichier de transfert

FIC_ORDRSP_HISTO

21,60 Répertoire et nom du fichier historique de transfert de la génération des messages ORDRSP Facultatif

Possibilité de paramétrer le répertoire et le nom du fichier historique ORDRSP.

Si celui-ci n'est pas paramétré, le nom du fichier historique ORDRSP a le même nom que le nom du fichier ORDRSP paramétré sur la note FIC_ORDRSP.

RAPPEL

Si version 1, le nom du fichier historique ORDRSP est suivi de l'extension .HIS.

Si version 2, le nom du fichier historique ORDRSP est suivi du code client, puis de l'extension .HIS.

FIC_TRACE

21,60 Nom du fichier de trace

NOM_DU_SHELL

21,60 Nom du shell à lancer en fin de traitement

SUP_REQ_CLI

21,60 Supplément de requête pour la recherche sur la table edi_cde

SUP_REQ_EDI

FIC_HISTO_ORDRSP

21,60 Racine du nom du fichier d'historisation de transfert de la génération des messages ORDRSP

Le nom du fichier de transfert est composé de la racine suivie d'un compteur si version 1.

Le nom du fichier de transfert est composé de la racine suivie du code client puis d'un compteur si version 2.


Calcul du risque

Calcul du risque risque_detail

Options

-B

Mode batch.

Odc

Enchaînement de l'édition du détail du carnet de commandes après le recalcul

Les options Odc et Oed doivent être utilisées séparément.

Oed

Enchaînement de l'édition du risque client après le recalcul.

Les options Odc et Oed doivent être utilisées séparément.

Omc

Mise à jour de la CRM

Mise à jour du montant encours et du montant plafond des fiches clients de ReflexClient CRM

Le montant encours est le risque de la semaine courante.

Le montant plafond est la somme des autorisations (Permanente, temporaire et supplémentaire) de la semaine courante.

La mise à jour est faite dans la phase de recalcul du risque détail.

L'option Opr (Pas de recalcul du risque détail) ne doit pas être positionnée.

Pour rappel, le calcul du risque client peut modifier la qualité tiers des clients et répercuter cette modification dans les fiches clients de ReflexClient CRM.

La mise à jour de la qualité tiers des fiches clients de ReflexClient CRM est faite par la traçabilité.

Cette mise à jour ne dépend pas de l’option Omc.

L'option Opr ne doit pas être positionnée.

Opr

Pas de recalcul du risque détail

Valeur alpha 2

Caractères 1 à 6

Type et code du paramètre de lancement du programme d'intégration des données comptables

Ce programme (int_cpt en standard) est appelé avec le paramètre -B afin d'être exécuté en mode batch.

Paramètres nécessaires

#CF SFA | Assurance crédit
Voir aussi | Calcul du risque


Transfert des commandes vers JDE

Transfert des commandes vers JDE tr_jde_cde

Cette interface permet de transférer les commandes à affréter vers JDE.

Les critères de transfert sont les suivants :

  • le solde,

  • les codes blocages de la revue de contrat,

  • les types de commandes (par complément de requêtes),

  • l'édition de l'accusé de réception,

  • la génération des commande de type FB2.

Cette interface peut être lancée en mode batch.

Elle s'exécute à l'infini en tâche de fond.

Un autre batch est nécessaire pour la stopper.

Options

-Oar | Demande de l'arrêt du traitement en batch
-Oup | Exécution d'une seule boucle en traitement batch
-Osi | Mode Simulation (les lignes de commandes ne sont pas marquées comme transférées)

Valeur alpha 2

Caractères 1 à 4

Durée d'attente entre 2 cycles en traitement batch

Notes

FICHIER_JDE | 21, 60 Nom du fichier de transfert
FICHIER_ERREUR | 21, 60 Nom du fichier des erreurs
FICHIER_TRACE | 21, 60 Nom du fichier trace
FICHIER_LOCK_JDE | 21, 60 Nom du fichier lock posé par JDE
FICHIER_LOCK_VS | 21, 60 Nom du fichier lock posé par Volupack
FICHIER_ARRET | 21, 60 Nom du fichier arrêt créé lors de la demande d'arrêt (option –Oar)
FICHIER_LOCK | 21, 60 Nom du fichier lock qui permet l'unicité du lancement du programme
SUP_REQ_CDE1 | 21, 60 Supplément de requête sur la table cde1. exemple : and ec_tyc not in ("FAD","AVO")
SUP_REQ_CDE2 | 21, 60 Supplément de requête sur la table cde2. exemple : and lc_num matches "03*"
SUP_ORDER_CDE | 21, 60 Complément d'order by
LARGEUR_CAMION | 21, 60 Largeur du camion en millimètre
METRE_LINEAIRE_MAXI | 21, 60 Nombre de mètre linéaire maximum
TYPE_NOTE | 21, 23 Type de note. Ces types de notes sont recherchées sur la ligne de commande puis sur le client.

Paramètres nécessaires

QT | alpha1[20] alpha1[21,23]
TRS | alpha1[8,10]
SIT | alpha1[46,50]
RG1 | alpha1[40] alpha2[1,12]
POR | alpha1[18,20]
QA | alpha1[16] alpha1[17,19]
QAL | alpha1[5]
BLO | alpha2[11] alpha2[12] alpha4[12,14]


Outil de création des mouvements prévisionnels de stock des commandes clients

Outil de création des mouvements prévisionnels de stock des commandes clients outil_mvts_cde

Fonctionnement

Cet outil créé les mouvements de livraison prévisionnelle et de fabrication prévue des commandes clients.

Mouvement de livraison prévisionnelle (TYC[3] ou TYC3[51] = R : Sortie réserve)

Pour que l'outil crée le mouvement de stock :

  • l'article de la ligne de commande doit être suivi en stock

  • le mouvement ne doit pas déjà être créé

  • la ligne de commande ne doit pas être soldée (lc_solde = N)

  • la quantité commandée doit être supérieure à la quantité réellement livrée

Mouvement de fabrication prévue (TYC[36] ou TYC3[52] = P : Entrée prévisionnelle)

Pour que l'outil crée le mouvement de stock :

  • l'article de la ligne de commande doit être suivi en stock

  • le mouvement ne doit pas déjà être créé

  • la ligne de commande doit avoir du reste à fabriquer (lc_rstfab = O)

  • la quantité lancée doit être supérieure à la quantité déjà fabriquée

Options

-B

Mode Batch

Oc8

Création des mouvements de livraison prévisionnelle des lignes de cadencement de livraison des commandes clients (Table cde8)

Nécessite QAL A2[1,3]. Voir aussi la note SUP_REQ_CDE8

Si l'option Oc8 n'est pas activée, les mouvements de livraison prévisionnels sont créés à partir des lignes de commande.

Si l'option Oc8 est activée, les mouvements de livraison prévisionnels sont créés à partir des lignes de cadencement de livraison des lignes de commande.

Si la ligne de commande n'a pas de cadencement de livraison, le mouvement de livraison prévisionnel est créé à partir de la ligne de commande.

Le type de mouvement de livraison prévisionnelle peut être paramétré sur le qualificatif de l'appel de livraison (Paramètre QAL-li_qua).

Osi

Simulation. Pas de création des mouvements de stock et de mise à jour de la ligne de commande.

Osr

Pas de mise à jour du stock résultant des mouvements de stock

Ouv

Utilisation de l'unité de vente de la ligne de commande en plus du coefficient de conversion du fichier article pour calculer le prix du mouvement de stock

Par défaut, seul le coefficient de conversion est utilisé.

Cette option concerne uniquement les mouvements d'entrée prévisionnelle de fabrication.

Notes

SUP_REQ_CDE1 | 21,60 Supplément de requête sur la table cde1. Obligatoire en mode batch. EX : and ec_tyc = "CD2"
SUP_REQ_CDE2 | 21,60 Supplément de requête sur la table cde2. Obligatoire en mode batch. EX : and lc_prod matches "P*"
SUP_REQ_CDE8 | 21,60 Supplément de requête sur la table cde8. Obligatoire en mode batch. EX : and li_rgt = "USI"

Paramètres nécessaires

QAL A2[1,3] | Type de mouvement de stock de sortie réserve
#CF CDE A1[1,12] | Configuration de commande


Commandes : mise à jour multicritère du prix unitaire

Commandes : mise à jour multicritère du prix unitaire cde_maj_prix

Options

Oe4 | Prise en compte des escomptes
Or4 | Prise en compte des remises

Valeur alpha 2

A2[1,3]

Code du mot de passe de la mise à jour du prix de vente des commandes clients (Paramètre PWD) - GENERO - .0.145.2

Facultatif - Si non renseigné, le mot de passe est volum.

Autres paramètres

UNI

Valeur numérique 1


Intégration des données des propriétaires

Intégration des données des propriétaires integration_donnees_prp

Ce programme est opérationnel à partir de la V. 4.0.195.2

Actions :

l'intégration crée un point de livraison (Adresse secondaire) ou le met à jour s'il existe déjà.

l'intégration crée un produit ou le met à jour s'il existe déjà.

l'intégration crée une ligne de commande.

pour chaque donnée du propriétaire.

Options

-B | Mode batch
Oar | Arrêt du programme en tâche de fond
Osi | Mode simulation. Les données des propriétaires ne sont pas intégrées.
Oup | Arrêt du programme en tâche de fond après un seul passage

Valeur alpha 2

A2[1,4] | Délai d'attente en minutes - Facultatif - 1 minute par défaut
A2[5,7] | Code TSC adresse secondaire - Obligatoire Utilisé pour stocker le code client et le code adresse de livraison du client final du propriétaire Cette information permettra de savoir si le point de livraison doit être créé ou mis à jour.
A2[8,10] | Code TSC client - Obligatoire - Utilisé pour créer l'article Le TSC contiendra la racine et la longueur du chrono de l'article à créer.
A2[11,16] | Code client par défaut du point de livraison - Obligatoire - Utilisé pour créer le point de livraison
A2[17,19] | Code adresse par défaut du point de livraison - Obligatoire - Utilisé pour créer le point de livraison
A2[20,34] | Code article par défaut - Obligatoire - Utilisé pour créer l'article

Notes pour la gestion de l'intégration

FIC_ANOMALIE | 21,60 Nom du fichier des anomalies - Obligatoire
FIC_ARRET | 21,60 Nom du fichier d'arrêt - Obligatoire
FIC_INTEGRER | 21,60 Nom du fichier des données des propriétaires à intégrer - Obligatoire
FIC_INTEGRER_REP | 21,60 Répertoire du fichier des données des propriétaires à intégrer - Facultatif
FIC_INTEGRER_REP_HIS | 21,60 Répertoire historique du fichier des données des propriétaires à intégrer - Facultatif
FIC_LOCK | 21,60 Nom du fichier du lock général posé par le programme - Obligatoire
FIC_LOCK_EXT | 21,60 Nom du fichier du lock posé par un programme externe - Obligatoire
FIC_LOCK_VS | 21,60 Nom du fichier du lock posé par le programme qui peut être utilisé par un programme externe - Obligatoire
FIC_TRACE | 21,60 Nom du fichier de trace - Obligatoire

Notes

CHAMP_FICHIER

CTRL_CHAFIC_UNICITE

21,38 Nom du champ - Obligatoire

Liste des champs, triés par ordre alphabétique

adr1_livree Adresse 1 du client livré

adr2_livree Adresse 2 du client livré

adr3_livree Adresse 3 du client livré

code_adl_prp Code adresse de livraison du client final du propriétaire

code_article_prp Code article du propriétaire

code_client_prp Code client du client final du propriétaire

code_client_vp Code client propriétaire pour RLV

code_ean13 Code EAN13 de l'article du propriétaire

commentaire_client Commentaire client

contact Contact du client livré

cp_livre Code postal du client livré

delai_client Délai client

des_article Désignation de l'article du propriétaire

fax Fax du client livré

mail Mail du client livré

modele_etiquette Modèle d'étiquette

nb_etiquettes Nombre d'étiquettes

nb_prd_par_pal Nombre de produits par palette

no_bt_prp Numéro de BT du propriétaire

no_cde_prp Numéro de commande du propriétaire

no_lig_cde_prp Numéro de ligne de la commande du propriétaire

no_seq_lig_cde_prp Numéro de séquence de la ligne de commande du propriétaire

nom_client_livre Nom du client livré

pays_livre Code pays du client livré

poids_brut Poids brut

qte_transferee Quantité transférée

telephone Téléphone du client livré

unite_achat Code unité d'achat

unite_vente Code unité de vente

ville_livree Ville du client livré

41,43 Position de début du champ - Obligatoire

45,47 Longueur du champ - Obligatoire

Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique.

Fonctionne avec la note CHAMP_FICHIER)

O chaque nom de champ doit être unique (par défaut)

N pas de contrôle

MAJ_FLAG_INFO_C

21 Etat de mise à jour

F Flag (Demande de transfert)

D Déflag (Transfert)

22,24 Code TSC LISA

25 Type de clé du TSC LISA

26,28 Valeur du flag

29,60 Clé du TSC LISA

Paramètres nécessaires

TSC IAC | Code TSC adresse secondaire
TSC ICL | Code TSC client
TSC _LI | TSC LISA
TYC FBE | TYC de la commande générée
#CF SSC | Notes SSC_COMPTEUR_EDC_REF SSC_DELAI_OBLIGATOIR SSC_ECRAN_SAISIE SSC_INIT_ZONE_ADL SSC_INIT_ZONE_DELCLI SSC_INIT_ZONE_P3 SSC_PARAM_EDI_CDE SSC_TYP_TYC SSC_ZONE_INIT_QTE
#CF TRA | Paramétrage de la traçabilité des tables adresses secondaires (cli2) articles (mat) informations complémentaires (info_c) libellés étrangers (lib_etr)


Edition des accusés de réception des commandes

Nous avons paramétré les pourcentages suivants :

POURCENTAGE_QTE_DW à 70 et POURCENTRAGE_QTE_DT à 85.

Un client fait une commande d'un produit fini XXXX d'une quantité de 2000.

Nous avons en stock 6000 unités de ce produit fini.

Lors de l'accusé de réception une fenêtre s'ouvre pour nous demander si nous souhaitons le positionner dans à retraiter. Nous répondons Oui.

Une fenêtre de picking s'ouvre pour choisir la quantité que l'on souhaite prendre.

C'est la quantité que l'on retraite qui déclenche une action ou pas.

Le premier seuil correspond au pourcentage de la quantité totale du produit en commande.

Soit 70% de 2000 qui font 1400.

A ce moment-là, l'ordre de transport aura la date de mise à disposition initialisée

à la date du jour de la saisie. Et cela est valable jusqu'au deuxième seuil.

Le deuxième seuil se déclenchera à 85% de 2000. Si la quantité prise dans le picking

atteint 1700 ou plus, alors l'ordre de transport aura en plus de la date de mise

à disposition renseignée, l'état de l'OT mis sur à affréter.

Edition des accusés de réception des commandes acr

Options Valeur numérique 1 Valeur alpha 2 Valeur alpha 3 Générations automatiques Paramètres associés Notes

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : N° de commande

Exemples : -N[ec_um]       -N[b2_cde]

Valeur numérique 1

Numéro du compteur (nul par défaut) (Voir #SA CDE)

Options triées

O02

(Lettre O puis chiffres 0 et 2)

Texte de l'entête de commande des FBI générées. Par défaut, le texte est le suivant :

SUITE A APPEL DE LIVRAISON Numéro de la commande - Numéro de la ligne de la commande (par défaut)

Si l'option est positionnée, le texte est le suivant :

SUITE A COMMANDE Type de la commande- Numéro de la commande - Numéro de la ligne de la commande

Oad

Réponse automatique "NON" pour le transfert vers à détruire

Oca

Utilisation spécifique (comportement différent entre cartonnage et cartonnerie) (Ex : TSC différents)

Ocl

Sélection des lignes de commandes à éditer

Ocm

Gestion d'un compteur manuel

Permet de gérer un compteur sans tenir compte de l'année et du mois

Incompatible avec l'option Ony (numérotation annuelle)

Ocp

Autorise l'affichage de la contrepartie

Ocu

SPECIFIQUE Edition des coordonnées de la société en entête

Odc

On prend les dates délais sur la ligne de commande pour initialiser les dates délais des FBI générées au lieu de la date délai répondu.

Odm

Edition de la date de dernière modification.

En présence de cette option, la date de dernière modification est éditée sur l'ACR en cas d'annule et remplace.

En l'absence de cette option, c'est la date du jour qui est éditée.

Voir le TSC MOC

Oea

Edite les lignes annulées (nécessite Ola)

Oee

Génération d'un événement dans evt_trans pour chaque commande éditée (entité = A, clé = numéro de commande). L'événement n'est généré qu'en édition. Incompatible avec -Oel

Oef

Pour chaque commande, une édition de la fiche de fabrication sera lancée.

Oel

Génération d'un événement dans evt_trans pour chaque ligne de commande éditée (entité = A, clé = numéro de commande + ligne). L'événement n'est généré qu'en édition. Incompatible avec -Oee

Oen

L'état des mouvements de transfert des réaffectations des stocks non vendables est mis à N au lieu de 2
(2 étant la valeur par défaut)

Oep

Exécution d'un programme paramétré recevant en argument Nx où x = N° de la commande

Ce programme est paramétré en alpha2[20,25]. (Code et type du paramètre)

Ce module est exécuté pour chaque commande dont on éditera un accusé de réception

Ofa

Seules les lignes de fabrication seront éditées (mp_param[21] différent de I)

Ofs

Force la recherche des stocks à réaffecter dans la table stk0

(ne recherche plus dans la table stk_lot_lieu)

Nécessite l'option Ors

Oim

Force la lecture du devis pour chaque ligne de commande. Il s'agit d'un paramètre d'optimisation

Ol0

Les lignes de commande à zéro (quantité commandée = 0) ne sont pas traitées

Ol1

Edition de la ligne 1 des commandes de type FB1

Ol2

On prend les informations sur la fiche article pour calculer le poids et la surface.

Ola

Prise en compte des commandes et des lignes de commande annulées dans les traitements mais pas dans l'édition

Olc

On prend les informations sur la ligne de commande pour calculer le poids et la surface

Olf

Initialisation du lieu intermédiaire de la FBI avec le lieu de déstockage de la CD2 et désolde de la FBI

La commande doit être synchrone et le lieu de déstockage doit être différent du magasin usine.

Le lieu de déstockage ne doit pas faire partie de la liste des lieux de déstockage exclus.

Le magasin usine est paramétré dans #CF ATL A3[35,37].

Voir l'option Oli

Oli

Initialisation du lieu intermédiaire de la FBI avec le lieu de déstockage de la CD2

La commande doit être synchrone et le magasin doit être externe.

Olp

Limitation du picking (affichage des stocks concernant le lot)

(option identique à celle trouvée dans les bons de livraison)

Omc

Active ou désactive la mise à jour de la ligne de commande sur la fiche matière

Omf

Remise à jour des mouvements de stocks créés par la génération des FBI en modification

One

Régénération du dossier de fabrication (f0_gener = 2) si un code blocage édition AR sur la ligne de commande est bloqué, si l'AR n'a pas été édité et si l'OF a été généré.

La racine du code TSC de stockage des codes blocages de la revue de contrat doit être renseignée (#CF CDE A3[37,38])

Ony

Numérotation annuelle des numéros de commande

Incompatible avec l'option Ocm (numérotation manuelle)

Ooa

Désactive l'édition de la ligne des accessoires (spécifique K)

Ooc

Désactive l'édition de la ligne des couleurs (spécifique K)

Oof

Désactive l'édition de la ligne FEFCO (spécifique K)

Ool

Désactive l'édition de la ligne libellé composition (spécifique K)

Ooo

Edition des options onduleuse/extrudeuse

Oot

Ne pas générer d'ordre de transport en réédition de l'AR

Opa

Prise d'excédent automatique

Dans la gestion des excédents, si la quantité excédentaire est inférieure à la quantité commandée, alors on prend automatiquement tous les excédents sans poser de question

Attention, l'option Opl doit être activée !

Opf

Les lignes de facturable uniquement (frais par exemple) déjà facturées ne sont pas traitées dans l'AR.

Permet la gestion des commandes ouvertes donnant lieu à des rééditions multiples de l'AR.

Attention : ce paramètre n'est pas actif pour les FAD et les AVO, sinon on ne peut plus rééditer un AR de FAD.

Opi

Ouverture de l'écran de picking pour le choix des palettes

Opl

Afficher le picking des excédents par lot

Permet d'afficher une ligne par lot

Opo

Le poids de la FBI n'est pas positionné à 0.

Opp

Préparation au planning

Voir FAM note PRODUIT_GEN_FBI

Opx

Permet d’éditer des AR de type PRX

Or2

Référence de l'entête de commande des FBI générées

Par défaut : Numéro de la commande générée

Si l'option est positionnée : Numéro de la commande d' origine - Numéro de la ligne de la commande d'origine

Or2 et Or3 sont incompatibles. Si vous positionnez les 2 malgré tout, c'est Or3 qui l'emportera.

Or3

Référence à la commande client des FBI généré par l'édition des AR du type

Numéro de commande - numéro de ligne de commande - numéro de séquence

Exemple 98122001-1-20

Or2 et Or3 sont incompatibles. Si vous positionnez les 2 malgré tout, c'est Or3 qui l'emportera.

Orf

réaffectation dans NVE/ARE avec num fbi de la zone s0_affect

Orl

Lors de la réaffectation des stocks (option -Ors) il est possible de réaffecter le lot du mouvement de transfert en entrée du lieu à transférer Nouveau lot : numéro commande, "-", ligne commande

Ors

Ré-affectation des stocks non vendables. Permet, lors de l'édition des AR, de détecter un stock présent sur un lieu donné, puis de le transférer vers un autre lieu. Nécessite un suivi par lot / lieu multi-niveaux et la gestion des stocks à la palette. Complément de paramétrage en A2[26, 46].

Voir aussi la note NB_JOUR_STK_NVE.

Orv

Mise à jour des zones prix de revient société, euro et devise avec le PAMP de l'article et de la zone marge de la ligne de commande pour les articles négoces

mp_param[5] doit être égal à A).

Utile pour établir un état de marge brute simplifié (on ne tient pas compte des éléments de frais supplémentaires : transport, frais de service, etc...) pour les sociétés qui ne travaillent qu'en négoce.

Osr

On ne met pas à jour les stocks résultants

Osm

Réalise l'édition de l'AR Sans Modification dans la base de données

Ne pas activer cette option sans une étude préalable de la part de Volume Software.

Cette option permet d'éviter les blocages des envois Fax/Mail

Elle permet de faire l'édition sans qu'aucune donnée de la base ne soit modifiée (Sans Modification).

Cette option nous permet donc de nous affranchir des locks.

ATTENTION

Cette option ne doit être positionnée QUE dans le cas de ré-éditions lancées en mode Batch (cas typique des envois Fax/Mail) sinon vous courez le risque de ne pas générer vos stocks ni vos FBI.

Ost

Active la sous-traitance du produit entre sites - Tableau de bord du multisite

Otg

Majoration de la quantité lancée en génération des FBI (pour les onduleurs)

Prend en compte la tolérance quantitative de la revue de contrat

si inexistante, les TSC de majoration sur le client (CIC N72 et N73)

si inexistants, la règle de surproduction USFO (TSC TS1 à TS5 du client).

Otn

Edition du montant total net avant déduction des remises et escompte

Voir aussi A3[32]

Oxm

Envoi automatique des fax/email

Voir les notes VALID_FAX* dans les généralités.

Valeur alpha 2

Caractères 1 à 6 | Client FBI par défaut (#SOC si non renseigné)
Caractères 7 à 9 | Type de note de trace FBI (FBI si non renseigné)
Caractère 10 | Visualisation d'un état de l'édition des AR. Type d'état 0 Toutes les commandes (par défaut). 1 Uniquement les commandes éditées. 2 Uniquement les commandes en anomalie (bloquée, etc.) 3 Aucune commande
Caractère 11 | Choix du client pour la génération de commandes à l'édition de l'aR 1 On prend le client saisi caractères 1 à 6 2 On prend le client de la commande commerciale
Caractères 12 à 19 | NON UTILISES
Caractères 20 à 25 | Type et code du paramètre exécutant le programme de l'option -Oep
Caractères 26 à 28 | Lieu 1 où l'on effectue la recherche du stock. Nécessite l'option Ors
Caractères 29 à 34 | Lieu 2 où l'on effectue la recherche du stock. Nécessite l'option Ors
Caractères 35 à 40 | Lieu 2 où l'on transfère le stock. Nécessite l' option Ors
Caractères 41 à 43 | Type de mouvement de transfert en sortie. Nécessite l'option Ors Valable pour les stocks à retraiter Pour les stocks à détruire, le paramétrage est en alpha3[16,21].
Caractères 44 à 46 | Type de mouvement de transfert en entrée. Nécessite l'option Ors Valable pour les stocks à retraiter Pour les stocks à détruire, le paramétrage est en alpha3[16,21].
Caractères 47 à 52 | Lieu 2 pour le transfert d'un stock à détruire. Cette option est associée à l'option -Ors
Caractère 53 | Mise en place d'un rapport détaillé (O/N, N par défaut)
Caractères 54 à 59 | Type et code du paramètre de lancement du programme de profil de stock appelable par CONTROL-P sur une ligne de détail du rapport

Valeur alpha 3

Caractères 1 à 6 | Type et code du paramètre de lancement du programme à exécuter à chaque commande (Edition de la fiche de fabrication)
Caractères 7 à 9 | Code blocage automatique laboratoire. Exemple LAB Voir le programme cde pour plus d'informations sur le contrôle laboratoire
Caractères 10 à 12 | Type de note historique de la revue de contrat. Exemple RCH Voir le programme cde pour plus d'informations sur le contrôle laboratoire
Caractères 13 à 15 | Code blocage FBI multi niveaux. so_options[41] doit être = O
Caractères 16 à 18 | Type de mouvement de transfert en sortie pour les stocks à détruire Pour les stocks à retraiter, le paramétrage est en alpha2[41,46}.
Caractères 19 à 21 | Type de mouvement de transfert en entrée pour les stocks à détruire Pour les stocks à retraiter, le paramétrage est en alpha2[41,46}.
Caractères 22 à 24 | Type de notes pour les excédents A RETRAITER Voir les notes NOTES_EXCEDENTS_ARE
Caractères 25 à 27 | Type de notes pour les excédents A DETRUIRE Voir les notes NOTES_EXCEDENTS_ADE
Caractères 28 et 29 | Racine du TSC pour les excédents A RETRAITER - Facultatif Si renseigné, la racine doit être sur 2 caractères Le TSC concerné doit avoir les caractéristiques suivantes : ic_type = C (Commande) ic_cle = [Numéro de commande]-[Ligne de commande-Séquence de la ligne de commande ic_ts = Racine du TSC des excédents A RETRAITER ou A DETRUIRE suivie d'un chrono sur 1 caractère (1 à 9) ic_num1 Nombre de palettes ic_num2 Quantité par palette ic_num3 Quantité totale ic_char30 [Numéro de lot][espace][espace][Lieu de niveau 1][espace][Lieu de niveau 2] Si le nombre de TSC à générer est supérieur à 9, seuls les 9 premiers TSC sont générés. Un message d'avertissement est affiché.
Caractères 30 et 31 | Racine du TSC pour les excédents A DETRUIRE - Facultatif Si renseigné, la racine doit être sur 2 caractères Le TSC concerné doit avoir les caractéristiques indiquées ci-dessus (voir caractères 28 et 29)
Caractère 32 | Edition du montant total net incluant les remises et escomptes (O/N, N par défaut) O On édite ce montant. N On édite le montant total net avant remises et escomptes. Ce paramètre n'est pris en compte qu'en présence de l'option Otn.

Possibilité de générer sur la nomenclature du produit (table cde4)

Des sorties réserves | #CF CDE alpha1[26,28] = Type de sortie réserve par défaut TYC alpha1[3] = R TYC alpha2[4,6] = Type de sortie réserve du TYC
Des sorties normales | #CF CDE alpha1[23,25] = Type de sortie normale par défaut TYC alpha1[3] = O TYC alpha2[1,3] = Type de sortie normale du TYC
Des entrées normales | #CF CDE alpha1[36,38] = Type d'entrée normale par défaut TYC alpha1[3] = E TYC alpha2[16,18] = Type d'entrée normale du TYC

Possibilité de générer des FBI sur la nomenclature du produit (table cde4) avec génération d'entrées prévisionnelles

TYC alpha1[34] | O, Génération des FBI
REA alpha2[1] | S où X = Zone réapprovisionnement de la fiche article (voir aide en ligne du paramètre REA)
#CF CDE alpha1[29,31] | Type d'entrée prévisionnelle par défaut
TYC alpha1[3] | P, TYC alpha2[13,15] = Type d'entrée prévisionnelle du TYC

Notes triées

CODE_ISO_1

Code ISO 1 - SPECIFIQUE

CODE_ISO_2

Code ISO 2 - SPECIFIQUE

CODE_TSC_ED_REED_AR

21, 23 Code TSC Date et heure édition et réédition de l'AR - Facultatif

Exemple : AVE

Spécifique

EDIT_COMPOSITION

21 Edition de la composition (O/N) SPECIFIQUE

FORMAT_EDITION

SPECIFIQUE

FORMULE_ENTETE

21 à 60 Formule de politesse à imprimer dans l'entête SPECIFIQUE

Caractères "///" pour continuer sur la ligne suivante

FORMULE_FIN_CDE

21 à 60 Formule de politesse à imprimer en fin de commande SPECIFIQUE

Remarque Une note (caractères 21 à 60) peut être terminée par les caractères ///, la ligne suivante sera ainsi comprise dans la ligne de note actuelle.

FORMULE_PIED

21 à 60 Notes de type formule de politesse à éditer en pied de page SPECIFIQUE

Les lignes de notes peuvent être cumulées en utilisant les caractères "///"

Exemple : Veuillez trouver ci-joint ///

l'accusé de&

donnera à l'impression : Veuillez trouver ci-joint l'accusé de&

GENERER_EDI_ORDERS

21,26 Type et code de lancement du programme generer_edi_cde

ex : #TRORD

Permet de générer un fichier ORDERS depuis la chaîne de commande client.

La génération est déclenchée à l'édition de l'AR.

INFO_LIVRAISON

21 Informations de livraison - SPECIFIQUE

1 Date de fabrication si commande de type CDA ou CDI ou FBI ou Date de livraison si commande d'un autre type, Nom et Ville de livraison (par défaut)

2 Date de livraison, Nom et Ville de livraison

LIBELLE_IMPRESSION

21 Libellé impression - SPECIFIQUE

1 Libellé spécifique 2 (par défaut)

2 Plan et Nombre couleurs

LIEUX_DESTOCK_EXCLUS

21,23 Lieu de déstockage exclus

20 notes maximum (20 lieux exclus)

L’option Olf doit être activée.

MESSAGE_ERR_IMP_n

Gestion envoi fax mail

21,60 Message d'erreur si l'imprimante choisie ne comporte pas le script.

Il y aura une demande de confirmation de l'action.

n varie de 1 à 4, car on peut paramétrer 4 lignes de messages.

N

SPECIFIQUE

Caractère 2

1 Notes sur client société (#SOC)

2 Notes sur entête de commande

3 Notes sur ligne de commande

4 Notes sur article

5 Notes sur client (adresse d'accusé de réception)

6 Notes sur client (adresse de livraison)

Caractères 3 à 60 Types de notes (codés sur 3 caractères, Exemple LIG#QA)

NA

Génération de notes typées automatiques (20 maximum)

Ces notes sont générées une seule fois lors de l'édition ou de la réédition.

Elles pourront être éditées sur le module spécifique du client.

3,5 Type de note

6,60 Libellé

NB_JOUR_STK_NVE

21,24 Nombre de jours

Lors de l'édition de l'accusé de réception d'une commande client, si l'option Ors est activée, il est possible de réaffecter du stock non vendable.

Cette note permet de réaffecter en automatique les stocks non vendables si l'âge de ces stocks est inférieur ou égal au nombre de jours paramétré ici et si la quantité en stock est inférieure ou égale à la quantité commandée.

Si le stock est réaffecté en automatique, l'utilisateur sera averti par un message.

Si une de ces conditions n'est pas respectée, alors le cycle par défaut sera suivi (demande de passer le stock à retraiter, etc.).

NOTES_EXCEDENTS_ADE

21,60 Texte d'introduction paramétrable qui sera inséré dans les notes de type A DETRUIRE (voir alpha3[25,27])

Ces notes sont visibles dans la visualisation des commandes clients, grâce à la note NOTES_NOM_EXCEDENT

NOTES_EXCEDENTS_ARE

21,60 Texte d'introduction paramétrable qui sera inséré dans les notes de type A RETRAITER (voir alpha3[22,24])

Ces notes sont visibles dans la visualisation des commandes clients, grâce à la note NOTES_NOM_EXCEDENT

NUMERO_QUALITE_DOC

21 à 60 Numéro de qualité document SPECIFIQUE

Pouvoir paramétrer le numéro de qualité document dans l'édition des accusés de réception de commande.

OBJET_FAX_EMAIL

21 à 60 Objet du fax ou de l'email par défaut SPECIFIQUE

N'apparaîtra que si aucun objet n'a été mis par défaut dans l'édition concernée.

ORDER_BY_LIGNES

21,60 Paramétrage de l'order by

Exemple : order by lc_fam, lc_sfm

Par défaut : order by lc_lig

ORDRE_GROUPE_LIGCDE

21,22 Code du groupe

23,24 Ordre d'apparition

PARAM_EDIT_PROFORMA

SPECIFIQUE

21,26 Type et code du paramètre de lancement du calcul de la proforma

Si cette ligne de note n'est pas trouvée, l'édition utilisera le paramètre #ED-FAS (permet de conserver le fonctionnement existant).

Si cette ligne de note est trouvée, mais sans type ni code du paramètre de lancement , alors ce calcul ne sera pas fait (permet de désactiver ce fonctionnement).

POURCENTAGE_QTE_DT

21,26 Pourcentage par rapport à la quantité de l'OT (valeur haute de l'intervalle)

L'OT devient à affréter si la quantité à retraiter est supérieure ou égale à la quantité résultante de ce pourcentage.

La date et l'heure de mise à disposition sont initialisées à la date et l'heure de la création de l'OT.

La note POURCENTAGE_QTE_DW est nécessaire, ainsi que l'option Ors.

Exemple

POURCENTAGE_QTE_DW

21,26 Pourcentage par rapport à la quantité de l'OT (valeur basse de l'intervalle)

L'OT reste en attente mais la date et l'heure de mise à disposition sont initialisées à la date et l'heure de création de l'OT.

La note POURCENTAGE_QTE_DT est nécessaire, ainsi que l'option Ors.

PRIX_UNITE_NOTE

21 Prix de vente, Unité de vente et ligne de note - SPECIFIQUE

1 Prix de vente, Unité de vente et 1ère ligne de note (par défaut)

2 Prix de vente, Unité de vente et Refouleurs si commande de type FB2 ou AVP ou 1ère

RECOPIE_PALETTE_TSC

21 Activation de la recopie du code palette nomenclature vers un TSC de la ligne de commande FBI (O/N)

Nécessite la note SUPREQPAL sur #CF CAR

RECOPIE_TSC_FBI

21 Activation de la recopie des TSC article vers la ligne de commande FBI (O/N)

REFERENCE_COMMANDE

21 Référence de la commande - SPECIFIQUE

1 Référence de la commande de rattachement si commande de type CD1 (par défaut)

2 Référence de la commande

SUPREQACC

21 à 60 Supplément de requête sur la table mat SPECIFIQUE

_SUP_REQ_CDE_OTR

21,60 Complément de requête sur les tables cde1 et cde2 pour la création ou non d'ordre de transport

_SUP_REQ_EXCEDENT

21,60 Complément de requête sur les excédents (porte sur la table stk0)

_SUP_REQ_FBI_FAM_SFM

21,60 Complément de requête sur les lignes de commandes à sélectionner pour générer la FBI

_SUP_REQ_INTERD_PICK

21,60 Complément de select sur la table lieu_rgt_e limitant le choix des palettes à sélectionner

_SUP_REQ_MAJ_DIM_ART

21,60 La ligne de commande est mise à jour seulement si le produit en question satisfait ce complément de requête

_SUP_REQ_TABLE_CDE1

21,60 Supplément de requête sur la table des entêtes de commande (Table cde1)

_SUP_REQ_TABLE_CDE2

21,60 Supplément de requête sur la table des lignes de commande (Table cde2)

TEXTE_FIN_CDE

21 à 60 Texte à imprimer en fin de commande SPECIFIQUE

TSC_A_RECOPIER

21 à 23 Codes TSC à recopier (une ligne de note par code TSC)

TSC_PALETTE_DEST

21 à 23 Code à utiliser lors de la recopie du code palette nomenclature

TYPE_LIAISON_CTR

21 à 23 Code paramètre du type de liaison contrat

La zone LIE <ec_type_liaison> de la FBI prendra pour valeur ce type de liaison.

La zone référence <ec_ref_liaison> prendra comme valeur le numéro de contrat.

TYPE_NOTE_CDE_LIG

21 à 60 Types de notes sur ligne de commande SPECIFIQUE

TYPE_NOTE_CDE3_LIG

21 à 60 Types de notes sur ligne de commande à éditer SPECIFIQUE

TYPE_NOTE_CLI3

21 à 60 Types de notes sur adresse secondaire ou principale sur site de production à éditer

Tableau de bord du multisite

TYPE_NOTE_CLI3_ADA

21 à 60 Types de notes sur adresse d'accusé de réception du client à éditer SPECIFIQUE

TYPE_NOTE_DEVIS

21 à 60 Types de notes sur entité de devis à éditer SPECIFIQUE

TYPE_NOTE_E_CDE_ENT

21 à 60 Types de notes sur entête de commande SPECIFIQUE

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI

21 à 60 Types de notes sur adresse principale du client

A éditer dans la partie entête du corps SPECIFIQUE

TYPE_NOTE_E_CLI_ADA

21 à 60 Types de notes sur adresse de facturation du client SPECIFIQUE

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI_ADL

21 à 60 Types de notes sur adresse de livraison du client SPECIFIQUE

A éditer dans la partie entête du corps

TYPE_NOTE_MAT

21 à 60 Types de notes sur article SPECIFIQUE

TYPE_NOTE_MAT3

21 à 60 Types de notes sur article à éditer SPECIFIQUE

TYPE_NOTE_P_CDE_ENT

21 à 60 Types de notes sur entête de commande SPECIFIQUE

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI

21 à 60 Types de notes sur adresse principale du client SPECIFIQUE

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADA

21 à 60 Types de notes sur adresse de facturation du client SPECIFIQUE

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADL

SPECIFIQUE

21 à 60 Types de notes sur adresse de livraison du client

A éditer dans la partie pied du corps

TYPE_NOTE_RC

21 à 23 Type de note de revue de contrat SPECIFIQUE

VALID_FAXMAIL_EDIT

VALID_FAXMAIL_REEDIT

VALID_FAXMAIL_VALID

Voir les notes dédiées au Fax/Mail

Paramètres associés

NTS EDC

Libellé long : Notes commerciales

Une édition commerciale simplifiée peut être obtenue en créant des notes de type EDC sur une entité de sous-devis.

Cette fonction est accessible depuis les programmes blv_ed1, acr, facn et dco_c


Edition des ordres d'exécution

Entête

A Adresse du client

B Adresse de livraison du client

C Adresse de facturation du client

D Numéro de commande

E Date de la commande

F Référence de la commande

G Ligne Texte de la commande

H Mode de règlement

I Libellé de l'échéance

J Nom du représentant

K Montant du port taxable

L Taux de TVA du port taxable

M Mode de Transport

N Nom du transporteur

O Nom du suivi d'affaire

P Vérifier - Décalage ?

Q Montant du port exonéré

R Code et nom du client de la commande

Ligne de commande

a Code produit

b Libellé du produit

c Quantité commandée

d Quantité livrée

e Prix unitaire

f Valeur (quantité commandée * prix unitaire / unité vente)

g Délai client

h Délai répondu

i Délai de fabrication

j Quantité lancée

k Référence de l'article chez le client

l Poids unitaire de la ligne de commande

m Poids de la ligne de commande (quantité lancée * poids unitaire)

Edition des ordres d'exécution - oex / oexp / voluedit_oex / voluedit_oex_tc

05/01/2012 - Cette page regroupe désormais l'aide pour :

l l'édition des ordres d'exécution (oex)

l l'édition paramétrable des ordres d'exécution (oexp)

l l'édition VoluEdit des ordres d'exécution pour les onduleurs (voluedit_oex)

l l'édition VoluEdit des ordres d'exécution pour les transformateurs (voluedit_oex_tc)

Toutes les autres pages d'aide sur les ordres d'exécution ont été supprimées.

Pour savoir si un paramètre est applicable à votre programme, consultez la colonne du milieu (OND, TRA, ...)

Paramètre | Indication | Le paramètre est utilisable dans
Options, valeurs numériques et alpha, notes | OND | Edition VoluEdit pour les onduleurs
 | TRA | Edition VoluEdit pour les transformateurs
 | SPE | Spécifique à un ou plusieurs clients
 | aucune | Toutes les éditions

Variables disponibles pour le nombre de copies conditionné (GRW)

Ces variables ne sont disponibles qu'avec les éditions Genero Report Writer.

nb_copie_gen_01

Nombre total de machines différentes utilisées dans la gamme (TSC 200) de l'OF en cours

Cette variable peut être paramétrée sur la note NB_COPIES du paramètre GRW.

Voir la note SUP_REQ_GRW_MACGAM

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande-Numéro de ligne-Flag d'édition

Exemples :

-N[lc_num]

-N[lc_num|flag]

-N[lc_num|-|lc_lig+<<&]

-N[lc_num|-|lc_lig+<<&|flag]

où flag peut prendre les valeurs suivantes :

O Edition de l'OF

N Réédition de l'OF

* Edition ou réédition de l'OF

R Edition de l'OF lancée par la saisie manuelle ou CAB des bons de réception (à vérifier)

Valeurs numériques

1 | Délai d'attente en secondes entre chaque réveil de ce programme, en mode autonome. Par défaut : 0 seconde
2 | Délai d'attente en secondes entre chaque lancement d'édition en mode autonome. Par défaut : 0 seconde

Options

Oac

TRA

Ajout, au niveau de la ligne de commande de fabrication, du groupe multilignes de l'amalgame sur les commandes (fonctionnement pour les commandes de type FB1)

Oad

TRA

Ajout, au niveau de la ligne de commande de fabrication, du groupe multilignes de l'amalgame sur les devis (fonctionnement avec la table fle_amalg)

Oae

OND

Supprime la création de l'étiquette correspondant à la palette incomplète si cette dernière n'est pas nécessaire.

Attention : Cette option n'est prise en compte que si l'option Oep est positionnée.

Oam

TRA

Ajout du groupe Article du mouvement (Détail de stock)

Oar

En mode autonome, arrêt du démon

Nécessite la note MODE_AUTONOME paramétrée à O.

Oav

Edition du contrôle carton avant celui de l'OF

Ob0

Edition des besoins de la séquence 0 en nomenclature

Lors de l'édition des besoins dans le cadre d'une édition par nomenclature, les besoins générés sur la ligne de commande ne sont jamais édités car il y a une jointure avec le numéro de séquence.

Cette option permet donc d'éditer ces besoins.

Obe

TRA

Désactive le rapport d'édition sans utiliser le mode batch -B

Obl

Pas d'édition pour les codes blocages P et R

Obm

TRA

Edite la liste des besoins matières de toutes les entités par entité. A chaque entité, les données se répètent.

L'option Ome est obligatoire.

Voir la note ORDRE_GROUPE_ENTITE.

Obp

Contrôle état besoin plaque

Oca

OND

Utilisation spécifique (comportement différent entre cartonnage et cartonnerie)

(Exemple : TSC différents)

Ocd

TRA

Le numéro de devis/sous-devis sélectionné n'est plus égal au numéro de devis/sous-devis saisi sur la ligne de commande mais égal au numéro de commande

Oce

Demande de confirmation édition étiquettes en mode d'édition de la fiche de fabrication

Ocl

TRA

Edition des cadencement de livraison pour chaque entité

Ocs

TRA

Edition des cadencements de livraison à chaque entité

Effectue la jointure entre les cadencements de livraison et les séquences lors de l'édition des lignes de cadencements.

L'édition des ordres d'exécution permet d'éditer les différentes lignes de cadencement associées à la ligne de la commande.

Dans le cas où on édite ces lignes lors de l'édition de la nomenclature, elles sont répétées autant de fois qu'il y a d'éléments dans la nomenclature.

Pour éviter cela, on met en place une option pour faire le lien entre ces tables.

Odc

TRA

Pas de recherche de la dernière commande du produit

La recherche de la dernière commande du produit est très longue.

Si cette option est positionnée, cette recherche n'est plus faite.

Odf

SPE

SPECIFIQUE - Accès aux tables du devis feuille et cde5

Voir les notes commençant par _SUP_REQ_FLE.

Odm

TRA

Suppression des doublons dans l'édition des matières (fle_mat)

Odn

TRA

Ajout du groupe Information du devis dans le groupe nomenclature

Oeb

Contrôle de l'état du besoin négoce

Oec

TRA

Ajout du groupe Etat de la commande (Détail de stock)

Oee

TRA

Création et édition d'étiquette par produit d'entité

Oei

On édite les étiquettes intercalées entre les OF

Oen

OND/TRA

Edition d'une étiquette neutre pour la dernière palette - Voir aussi la note TYC_OPTION_EN

Oeo

OND

Éditer des étiquettes plaques en sortie d'onduleuse

Attention : option incompatible avec l'option -Oen.

Une seule édition à la fois.

Les étiquettes générées sont de type OEP.

Le nombre de plaques par pile est stocké sur le profil carton, alpha3[5,8].

Les données d'ouverture, poussée et nombre de poses sont sur le TSC 510 du triplet.

Zones spécifiques des étiquettes :

p_etp.etp_specif_3 = ouverture

p_etp.etp_specif_4 = poussee

p_etp.etp_specif_5 = nb_pose

p_etp.etp_specif_6 = nb_plaque_pile

Oep

Edition des étiquettes de production

Of1

TRA

Edition des lignes de facturation des commandes de type FB1 (lc_lig > 1)

L'option Ote doit être activée

Ofl

Utilisation de la zone f0_lance du 1er OF de la commande à éditer comme indicateur d'édition ou de réédition

Si cette option n'est pas déclarée, on utilise la zone ec_oe.

Oi1

Applique la même imprimante de sortie des étiquettes pour chaque dossier sélectionné

(1 seule demande de choix d'imprimante étiquettes)

Oli

TRA

Reprendre les informations de l'entité du devis parmi la liste des entités du devis de l'OF.

Ols

Verrou pour empêcher l'édition simultanée des fiches de fabrication

Le fichier créé est FIC_LOCK_OEX_GENERAL (non paramétrable)

Ome

TRA

Mettre le groupe Entités Devis en multilignes

Permet l'ajout des zones Besoin matière dans la zone Entités du devis dans le catalogue VoluEdit.

Omi

Oblige les étiquettes à s'éditer sur la même imprimante que l'OF

Omn

Pour VolEtiquette, transfert des fichiers en mode NFS

One

OND/TRA

Nettoyage des étiquettes avant régénération

Opc

TRA

Une page par cadencement de fabrication de type enregistrement E

Voir l'option Osc et la note _SUP_REQ_CCF_E

Ope

TRA

Active le saut de page par entité

Option Ome obligatoire

Opi

Dans le cas de la création des étiquettes (option Oep ou Oeo), et si non demande de confirmation de l'édition (option Oce), cette option ne lance pas l'impression des étiquettes (qui est la valeur par défaut), mais la création est bien réalisée.

Opr

SPE

SPECIFIQUE - Edition du document Prélèvements (dans le report)

Ora

Gestion de la rupture par article (saut de page)

Permet également l'impression de notes sur la famille de l'article au bas de la commande fournisseur

Orc

Remplissage de la table canal_comm

Ord

TRA

Restriction de la recherche des achats associée à une matière au dossier de fabrication

Ore

OND

Permet de rechercher les encres et leur coefficient de nomenclature sur la nomenclature de l'impression du PF

Sans cette option, les encres sont recherchées sur des TSC.

Orp

SPE

SPECIFIQUE - Traitement des prélèvements en réédition d'OF

Permet de traiter les prélèvements en réédition d'OF, si un OF n'a pas déjà donné lieu à un prélèvement en édition d'OF.

Ors

TRA

N'édite que les lignes de cadencement de livraison rattachées à la ligne éditée.

Osc

TRA

Un saut de page par type de cadencement de fabrication de type E et type de cadencement (GLO, IMP, FAC, &)

Voir l'option Opc et la note _SUP_REQ_CCF_E

Osd

TRA

Forçage du sous devis à 99 dans toutes les recherches sur un devis

Ose

TRA

Utilisation du groupe multilignes détail de stock.

Le stock est recherché par rapport à l'entête de commande

Osl

TRA

Utilisation du groupe multilignes détail de stock.

Le stock est recherché par rapport à la ligne de commande

Osm

OND

Saut de page si changement de site dans la liste des machines

Tableau de bord du multisite

Ost

Sélection en tableau des OF à éditer ou à rééditer

Otc

Autorisation du transfert CARTEC

Ote

TRA

Edition des notes de type TEXTILE de la table cde3

Oti

OND/TRA

Gestion des titres des groupes multilignes

Pensez aux caractères 20 à N de la valeur alpha 4.

Otl

OND

Affichage du tableau des stocks lot lieux en statique sur plusieurs pages si nécessaire

Ots

OND

Edite les OF dans l'ordre où ils ont été saisis

ATTENTION : Cette option implique l'option Ost.

Lors de la saisie des critères des OF à éditer ou à rééditer, il existe une saisie sous forme de liste des numéros d'OF.

L'édition des OF se fait par ordre croissant des numéros de dossiers sans s'occuper de l'ordre de saisie, la demande du client est donc d'avoir une option pour permettre de trier ces éditions dans l'ordre où les OF ont été saisis.

Ott

OND/SPE

Cette option active la gestion des TSC Cliché/Forme/Mylar/Encre du triplet Article/Gamme/Phase et désactive les variables Cliché/Forme/Encre des Données techniques dans le catalogue VoluEdit.

Oup

En mode autonome, un seul passage effectué

Ovd

OND/TRA

Edition par VoluEdit

Ove

Edition d'étiquettes par VolEtiquette

Valeur alpha 2

A2[1] |  | Edition d'un OE par ligne de commande (O/N, N par défaut)
A2[2] |  | Edition de la société en entête (O/N, O par défaut)
A2[3] |  | Edition d'un OE pour une ligne particulière (O/N, N par défaut)
A2[4] |  | Lancement du programme paramétré en A4[1,6] (O/N/Q, N par défaut) O On lance le programme sans poser de question. N On ne pose pas de question, on ne lance pas le programme. Q Une question sera posée (une seule fois) pour lancer ce programme supplémentaire Le programme supplémentaire ne doit pas lancer d'édition VoluEdit.
A2[5] | TRA | Ne pas prendre en compte la ligne de rattachement (O/N, N par défaut) N Lecture de la ligne de commande rattachée. O Lecture de la ligne de commande sélectionnée (on ne prend plus en compte la ligne de commande rattachée).

Valeur alpha 3

A3[1,4] | TRA | Largeur camion (pour le calcul du métrage linéaire)
A3[1,60] |  | Titre de l'édition. Par défaut : Ordres d'exécution

Valeur alpha 4

Pour oexp, la valeur alpha 4 contient le paramétrage des colonnes.

A4[1,6]

Type et code du paramètre de lancement du programme complémentaire

Voir A2[4] et la note ARGUMENT_PROG_SUPP.

A4[7]

Visualisation d'un état de l'édition des AR. Type d'état

0 Toutes les commandes (valeur par défaut)

1 Uniquement les commandes éditées

2 Uniquement les commandes en anomalie (bloquées, etc.)

A4[8,13]

Type et code du paramètre de lancement de l'édition des papiers supplémentaires

A4[14]

Temporisation en secondes avant de lancer le programme paramétré en A4[8,13] ci-dessus.

Si non renseigné ou non numérique : On considère que le programme appelé n'est pas une édition VoluEdit
(donc cette temporisation n'a aucune raison d'être)

Si renseigné à 0 : On considère que le programme appelé est une édition VoluEdit
(donc fermeture de la session VoluEdit par le programme appelant)
mais on enchaîne les programmes sans attendre.

Si renseigné à X secondes : On considère que le programme appelé est une édition VoluEdit
(donc fermeture de la session VoluEdit par le programme appelant)
et on attend X secondes avant de lancer le programme appelé.

Si le programme appelant n'est pas une édition VoluEdit, ce paramètre est sans effet.

A4[15,19]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

A4[20]

OND

Activation titre groupe Dossiers de fabrication (O/N, N par défaut)

A4[21]

OND

Activation titre groupe Dossiers de fabrication - gammes (O/N, N par défaut)

A4[22]

OND

Activation titre groupe Etat du stock par lot - lieux (O/N, N par défaut)

A4[23]

OND

Activation titre groupe Machines (O/N, N par défaut)

A4[24]

OND

TRA

ONDuleurs : Activation titre groupe Nomenclature du PF (O/N, N par défaut)

TRAnsformateurs : Activation titre groupe Lignes d'impression multiple (O/N, N par défaut)

A4[25]

Affichage des composants (O/N/U, N par défaut)

O Édite l'ensemble et ses composants

N Édite seulement l'ensemble

U Édite seulement les composants

A4[26]

TRA

Activation titre groupe Cadencement de fabrication de type E (O/N, N par défaut)

A4[27]

TRA

Activation titre groupe Frais de premier établissement - Voir NDF

A4[28]

TRA

Activation titre groupe Détail besoin matière (O/N, N par défaut) - Voir #CF-ATL A1[44]

A4[29]

TRA

Activation titre groupe Tableau complémentaire devis feuille (fle_com) (O/N, N par défaut)

A4[30]

TRA

Activation titre groupe Besoin matière (O/N, N par défaut)

A4[31]

TRA

Activation titre groupe Amalgame de la commande (O/N, N par défaut)

A4[32]

TRA

Activation titre groupe Séquence de commande de rattachement (O/N, N par défaut)

A4[33]

TRA

Activation titre groupe Nomenclature Matières devis (O/N, N par défaut)

A4[34]

TRA

Activation titre groupe Nomenclature Gammes devis (O/N, N par défaut)

A4[35]

TRA

Activation titre groupe Nomenclature Opérations devis (O/N, N par défaut)

A4[36]

TRA

Activation titre groupe Nomenclature Sous-traitance devis (O/N, N par défaut)

A4[37]

TRA

Activation titre groupe Matières devis (O/N, N par défaut)

A4[38]

TRA

Activation titre groupe Gamme devis (O/N, N par défaut)

A4[39]

TRA

Activation titre groupe Opération devis (O/N, N par défaut)

A4[40]

TRA

Activation titre groupe Sous-traitance devis (O/N, N par défaut)

A4[41]

TRA

Activation titre groupe Amalgame devis (O/N, N par défaut)

A4[42]

TRA

Activation titre groupe Détail du stock (O/N, N par défaut)

A4[43]

TRA

Activation titre groupe Entités du devis (O/N, N par défaut)

A4[44]

TRA

Activation titre groupe Décomposition forme (O/N, N par défaut)

A4[45]

TRA

Activation titre groupe Cadencements de livraison (O/N, N par défaut)

A4[46]

TRA

Activation titre groupe Références multiples des entités du devis (O/N, N par défaut)

A4[47]

TRA

Activation titre groupe Textile (O/N, N par défaut)

A4[48]

TRA

Activation titre groupe Références multiples de l'entête du devis (O/N, N par défaut)

A4[49]

TRA

Activation titre groupe Matières commandées (O/N, N par défaut)

A4[50]

TRA

Activation titre groupe Stock lot lieu Matières commandées (O/N, N par défaut)

A4[51]

TRA

Activation titre groupe Carton 1 (O/N, N par défaut) - Spécifique

A4[52]

TRA

Activation titre groupe Carton 2 (O/N, N par défaut) - Spécifique

A4[53]

TRA

Activation titre groupe Carton 3 (O/N, N par défaut) - Spécifique

A4[54]

TRA

Activation titre groupe Carton 4 (O/N, N par défaut) - Spécifique

A4[55]

TRA

Activation titre groupe Papiers (O/N, N par défaut)

A4[56]

TRA

Activation titre groupe Achat papier (O/N, N par défaut)

A4[57]

TRA

Activation titre groupe Libellés étrangers de la qualité matière (O/N, N par défaut)

A4[58]

TRA

Activation titre groupe Nomenclature des références multiples sur entête de devis

A4[59]

TRA

Activation titre groupe Nomenclature des références multiples sur entité de devis

A4[60]

TRA

Activation titre groupe Ligne commande facturation FB1 (O/N, N par défaut)

Notes triées

ALIM_ETP_ADR_LIV

TRA

21,30 Code de la zone d'alimentation du code adresse de livraison des étiquettes de production générées

ec_fab_adl Code adresse de livraison de l'entête de la commande de fabrication

lc_fab_adl Code adresse de livraison de la ligne de la commande de fabrication

ec_rat_adl Code adresse de livraison de l'entête de la commande commerciale
(celle qui est rattachée à la commande de fabrication)

lc_rat_adl Code adresse de livraison de la ligne de la commande commerciale
(celle qui est rattachée à la commande de fabrication).

PS : Il est possible de spécifier plusieurs fois la note, le programme recherchera alors le code adresse sur la zone spécifiée sur la première ligne. S'il ne trouve pas de code adresse, il ira alors chercher ce code sur la ligne suivante et ainsi de suite.

ARGUMENT_PROG_SUPP

21,60 Argument à passer au programme complémentaire

Le paramètre de lancement du programme complémentaire est indiqué en A4[1,6].

Par défaut c'est le couple numéro de commande / ligne de commande

Exemple

lc_prod (produit de la ligne de commande)

ATTENTE_VOLETIQ

17,25 Durée de la synchronisation pour VolEtiquette en mode transfert

CHEMIN_BMP_ARTIOS

TRA

21,60 Chemin d'accès aux images générées par Volume Media Center (VMC) pour VoluEdit

Seul le répertoire doit être précisé, le nom du fichier est construit en automatique.

CODE_SITE_EDITION

21,23 Code site de production

Tableau de bord du multisite

CONF_VOLUEDIT_ETIQ

21,26 Type et code du paramètre de configuration de l'édition VoluEdit des étiquettes de production

DATE_BASCULE

TRA

21,30 Date de bascule de nouveau / renouvellement de l'article (VoluEdit)

Format : JJ/MM/AAAA

Utilisée pour les variables Nouveau / Renouvellement et Référence antérieure

Exemple

DATE_BASCULE 09/09/1999

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

ETIQPROD_IMP

21,23 Imprimante pour édition automatique des étiquettes de production. Code ETP par défaut

24 Demande de choix de l'imprimante des étiquettes ou imprimante auto

O automatique

N demande (défaut)

FIC_ANOMALIE

Fonctionnement avec la table canal_comm

21,60 Nom du fichier d'anomalie

FIC_LOCK_EXECUTION

21,60 Nom du fichier de lock empêchant plusieurs exécutions simultanées

FIC_TRACE

Fonctionnement avec la table canal_comm

21,60 Nom du fichier de trace

FORCE_SEQUENCE

TRA

Ce paramètre doit être conforme à l'option Oaf de la génération des commandes fournisseur.)

21,23 OUI ou NON

OUI si inexistante, la séquence est forcée à 1 dans la recherche de la commande fournisseur.

NON la séquence n'est pas forcée (par défaut)

GEN_FICHIER_DOSFAB

21,26 Type et code du paramètre de lancement du programme de génération de dossier de fabrication

IMPRIMANTE_OEX

21,23 Imprimante forcée pour l'OF pour ne pas utiliser X qui interdit le chaînage des impressions OF étiquettes si l'imprimante des étiquettes est différente de celle définie dans le X.

Valeur par défaut si l'imprimante paramétrée n'existe pas en #LP : OEX.

INTERFACE_TABLE_CAO

21,26 Type et code du paramètre de lancement de l'interface avec une table CAO

LIB_ETR_CODE_QC_CDEF

TRA

21 Récupérer uniquement le libellé étranger du fournisseur rattaché à la commande (O/N, N par défaut)

Si N : on récupère tous les libellés étrangers de tous les fournisseurs de l'article.

MAT_ORD

9,60 Order by de remplacement sur la table mat

MODE_AUTONOME

Fonctionnement avec la table canal_comm

21 Edition des fiches de fabrication en mode autonome (daemon) (O/N)

Les fiches de fabrication à éditer en mode autonome sont recherchées dans cette table.

_NB_COPIES

_NB_COPIES_AVEC_CDF

_NB_COPIES_SANS_CDF

_NB_COPIES_CDF_NEG

_NB_COPIES_CDF_AUT

SPE

SPECIFIQUE - 21,23 Nombre de copies des OF

- avec commande fournisseur

- sans commande fournisseur

- avec commande fournisseur réceptionnée des articles négoce

- avec commande fournisseur réceptionnée des articles non négoce

NOTE_TEXTILE

TRA

21,23 Type de note du TEXTILE de la table cde3. Obligatoire. Exemple : TEX

NUM_CODIF_ETUDE

TRA

21,22 Numéro de la codification de l'étude

01 Codification avec étude fle_2 et numéro d'entité

Composer le numéro d'étude :

Le numéro d'étude du devis 98020135 = A\AB013501 ! (01 est le numéro de l'entité)

Selon les deux premiers caractères du devis (année) : 98 : A\A 99 : B\B 00 : C\C 01 : D\D &

Selon les deux caractères suivant (mois) 01 : A 02 : B 03 : C 04 : D &

02 le nom du schéma sera de la forme

numéro de plan ".ARD.voluedit"

Exemple :

408051997. voluedit.bmp

Si le numéro de plan est inexistant, le nom sera de la forme

" devis. "numéro de devis ". "numéro de sous devis ". "entite ".voluedit "

Exemple :

devis.D0801202.1.1.voluedit.bmp

03 le nom du schéma sera de la forme

"artios.image . "numéro de plan".ARD.voluedit"

Exemple:

artios.image.408051997.ARD.voluedit.bmp

Si le numéro de plan est inexistant, le nom sera de la forme

"devis".numéro de devis.numéro de sous devis.entite.code ecma/fefco."voluedit"

Exemple:

devis.D0801202.1.1.0201.voluedit.bmp

[autre] le numéro d'étude est celui de fle_2

ORD

4,60 Complément de tri sur les lignes de commande

ORDRE_GROUPE_ENTITE

TRA

Ordre des cadres

21,22 Code du groupe multi-lignes

01 Gammes devis

02 Décomposition forme

03 Matière devis

04 Produit de l'entité

05 Première palettisation

06 Références multiples entités

07 Besoin matière

23,24 Numéro d'ordre du groupe multi-ligne

Exemple de changement d'ordre

ORDRE_GROUPE_ENTITE 0601

ORDRE_GROUPE_ENTITE 0102

ORDRE_GROUPE_ENTITE 0703

Les données du groupe Références multiples entités s'afficheront en premier, ensuite celles de la gamme devis, puis celles de besoin matière, puis celles de décomposition forme, etc.

Voir l'option Obm.

PARAM_ED_OEX_AUTO

Fonctionnement avec la table canal_comm

Jusqu'à 10 notes de ce type sont permises.

Attention à l'ordre des notes !

Lors de la première édition de l'OF, seule la première ligne est considérée comme première édition.

Les lignes suivantes sont traitées en tant que rééditions.

En conséquence, si l'option Opr (gestion des prélèvements) doit être présente sur un des paramètres de lancement, il est indispensable que ce soit sur la première ligne.

21,26 Type et code du paramètre de lancement de l'édition des fiches de fabrication (mode document papier)

S_CDE1

7,60 Complément de select sur cde1

ATTENTION : ce complément de sélection ne commence pas par AND.

S_CDE2 ou

SEL

OND

7,60 Complément de select sur cde2

ATTENTION : ce complément de sélection ne commence pas par AND.

SEL et S_CDE2 font double emploi et utilisent la même variable.

S_FAB0

7,60 Complément de select sur fab0

ATTENTION : ce complément de sélection ne commence pas par AND.

S_GSTD

OND

8,60 Supplément de requête pour la sélection des opérations de la gamme (g_std_d)

(Groupe multilignes des machines)

S_MAT

7,60 Complément de select sur mat

ATTENTION : ce complément de sélection ne commence ni par AND ni par OR.

Exemple

S_MAT mp_fam in ("CAR", "OND")

S_MAT and mp_qualite = "FAB"

S_STK0

OND

8,60 Supplément de requête pour la sélection des stocks par lot lieu (stk0)

(Groupe multilignes des stocks)

S_REQ_FAB0_MULTILIG

OND

21,60 Complément de requête sur le groupe multilignes fab0

_SUP_REQ_CCF_E

TRA

21,60 Complément de requête pour les cadencements de fabrication de type enregistrement E

Voir les options Opc et Osc

_SUP_REQ_CDE_CAD_FAB

TRA

21,60 Complément de sélection sur la table cde_cad_fab

_SUP_REQ_CDE1_RF_ANT

TRA

21,60 Supplément de requête sur les entêtes de commande client pour la recherche de la référence antérieure

Exemple

and ec_tyc in ("FB1", "FB4")

_SUP_REQ_CDE4

TRA

21,60 Complément de sélection sur la table de la nomenclature des lignes de commande (cde4)

Utilisé notamment dans la gestion de la PLV

_SUP_REQ_CDE5_BES

21,60 Complément de select sur la table cde5

_SUP_REQ_FAB0_ACCES

SPE

SPECIFIQUE - 21,60 Complément de requête SQL sur la table fab0

(recherche des accessoires liés à la commande)

_SUP_REQ_FLE_COMBI3

TRA

21,60 Complément de sélection sur les lignes d'impression multiple (table fle_combi)

_SUP_REQ_FLE_DEC

TRA

21,60 Complément de requête sur la table fle_dec

_SUP_REQ_FLE_GAM

TRA

21,60 Complément sur la table fle_gam (phases opératoires)

_SUP_REQ_FLE_IMP

TRA

21,60 Complément de requête sur la table fle_imp

_SUP_REQ_FLE_MAT

TRA

21,60 Complément sur la table fle_mat (détail des calculs matières)

_SUP_REQ_FLE_NOM

TRA

21,60 Complément de sélection sur la table fle_nom

_SUP_REQ_FLE_OPE

TRA

21,60 Complément sur la table fle_ope (détail des opérations)

_SUP_REQ_FLE_STR

TRA

21,60 Complément sur la table fle_str (sous-traitance)

SUP_REQ_GRW_MACGAM

21,60 Complément de sélection sur g_std_d et mac0

Permet de filtrer les machines que l'on ne souhaite pas.

Voir les variables disponibles dans GRW : nb_copie_gen_01

_SUP_REQ_MACHINE_n

TRA

21,60 Supplément de requête sur la table fle_ope (avec devis/sous-devis/entité) pour la machine n

où n peut prendre les valeurs 1 à 5

_SUP_REQ_MAT_CDEES

TRA

21,60 Complément de requête sur cdf2 pour groupe multilignes des matières commandées

_SUP_REQ_NOM0_PF

TRA

21,60 Complément de select sur nom0 (sur plusieurs lignes si nécessaire)

_SUP_REQ_NOMREFMULTI

TRA

21,60 Supplément de requête pour la lecture des références multiples

_SUP_REQ_PACK_CDE5

TRA

21,60 Supplément de requête sur la table cde5

_SUP_REQ_PAPIERS

TRA

21,60 Complément de requête sur fle_com pour le parcours des papiers

Exemple

and fc_lcom matches PA*

_SUP_REQ_RECH_LL

TRA

21,60 Supplément de requête à la fonction rech_ll pour la recherche de la quantité disponible en stock de la ligne de commande amalgame (VoluEdit)

Utilisé pour la variable Quantité disponible en stock

Exemple

_SUP_REQ_RECH_LL and s0_rgt1 = "PAS"

_SUP_REQ_REFMULTI

TRA

21,60 Complément de sélection sur la table fle_dec

_SUP_REQ_SITE

OND/TRA

Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur

Tableau de bord du multisite

21,39 Nom de la colonne sur laquelle on fera le contrôle du site.

Exemple : l2_site, ec_c1, b1_sitp, …

Le site de production est inscrit sur le paramètre USE, en A3[10,12].

_SUP_REQ_STK0

TRA

21,60 Complément sur la table stk0

Exemple

and s0_etat_bes = "T"

_SUP_REQ_STK0_BES

21,60 Complément de sélection sur le contrôle du besoin négoce

Exemple

and s0_typ = "BES"

TYC_OPTION_EN

21,59 Liste des TYC pour lesquels l'édition d'une étiquette neutre doit être effectuée (équivalent à l'option Oen)

Saisie des TYC par bloc de 3 caractères.

Exemple : FBIFB2

Remarques :

L'option Oen n'est pas obligatoire.

A partir du moment où cette ligne de note est paramétrée, l'édition de l'étiquette neutre n'est activée que si le TYC est présent sur la ligne de note.

TYPE_NOTE_CDE3_LIG

TYPE_NOTE_CLI3

TYPE_NOTE_DEVIS_ACC

TYPE_NOTE_DEVIS_CND

TYPE_NOTE_DEVIS_FAB

TYPE_NOTE_MAT3

TYPE_NOTE_MAT3_ACC

TYPE_NOTE_PHASE_ACC

SPE

21,60 Types de notes à éditer - SPECIFIQUE

TYPE_NTS_PARAM_ECMA

OND

21,23 Type de note sur la saisie des FEFCO qui contient le paramétrage pour le nom du fichier et/ou libellé du FEFCO.

Ceci permet d'ajouter 2 nouvelles variables dans le catalogue.

Ces variables sont initialisées selon le paramétrage sur le FEFCO dessus (voir les notes commençant par FEFCO_ dans le programme ecma).

DansVoluEdit, ces variables apparaissent dans le groupe des données techniques :

Nom_du_fichier_ECMAFEFCO_parametre_img_fefco_param

Libelle_ECMAFEFCO_parametre_img_fefco_param

Codes sources des clés TSC pour l'édition VoluEdit

Code |  | Libellé | Disponibilité
T/[TMC] | OND | Triplet Article / Gamme / (Phase selon type machine) où TMC représente le code machine. Par lecture du par02, on sélectionne les TSC sur toutes les machines sauf l'onduleuse traitée séparément. Seule la dernière phase d'une suite d'opérations sur une même machine est prise en compte. Si non trouvé, lecture sur le PF Exemple T/OND Triplet PF / Gamme / Phase sur la dernière phase de l'onduleuse | Liste des machines Voir TMC A4[3]

Codes sources des clés TSC et Notes pour l'édition VoluEdit

Code

OND/TRA

Libellé

Disponibilité

CAS01

OND/TRA

Cascade numéro 1

  • Séquence ligne de commande de rattachement (NC_RAT)

  • Ligne de commande de rattachement (LC_RAT)

  • Code article (MP)

  • Code article de l'ensemble (MP_ENS)

  • Code client + adresse de livraison ligne de commande (CL/LIL

  • Code client (CL)

Liste des machines

Voir TMC A4[3]

CAS02

OND

Cascade numéro 2

  • Triplet article / gamme / phase (T/TMC)

  • Article (MP)

  • Ensemble (MP/ENS)

Liste des machines

Voir TMC A4[3]

CAS03

OND/TRA

Cascade numéro 3

  • Ligne de commande de rattachement

  • Code article (MP/ENT)

  • Code article (MP)

  • Code client + adresse de livraison ligne de commande

  • Code client

CAS04

Cascade numéro 4

  • Triplet

  • Article

  • Adresse de livraison client

  • Client principal

Syntaxe

VE_VAR Libellé*TSC_CAS04_CCC_Txx*Format*

Exemple

VE_VAR test*TSC_CAS04_17D_C30*I

CL

OND/TRA

Code client

Entête de l'ordre d'exécution - Sous-devis

CL/ACR

OND/TRA

Adresse de l'accusé de réception

Entête de l'ordre d'exécution

CL_DEV

TRA

Adresse du devis

Sous-devis

CL/FAC

OND/TRA

Adresse de facturation

Entête de l'ordre d'exécution

CL/FIN

OND/TRA

Client final de la commande (adresse principale ou secondaire)

CL/LIL

OND

Adresse de livraison de la ligne de commande

CL/LIV

OND/TRA

Adresse de livraison

Entête de l'ordre d'exécution - Sous-devis

EC

OND/TRA

Entête de commande

Entête de l'ordre d'exécution

EC/RAT

OND/TRA

Entête de commande de rattachement

Entête de l'ordre d'exécution

EC1

TRA

TSC relatifs au code ECMA de la nomenclature

EC2

TRA

TSC relatifs au code ECMA de l'entité du devis

EF

TRA

Notes sur l'entête de commande fournisseur

FI

TRA

Devis, sous-devis, entité

Entité

FI/LIM

TRA

Lignes d'impression multiple

FI/MAT

TRA

Notes sur les formules matières

FI/OPE

TRA

Notes sur les formules opérations

FI/STR

TRA

Notes sur les formules sous-traitance

FI/REF

TRA

Liste des références

GA

TRA

Notes dans les gammes du devis

GA/LIM

TRA

Ligne d'impression multiple dans la gamme devis

La note NUM_PASS_LIEE doit être paramétrée sur chaque phase.

L1

TRA

Devis (vérifier)

L2

TRA

Sous-devis (vérifier)

LA

TRA

Ligne de commande d'amalgame (FB1)

Entête de l'ordre d'exécution - Amalgames

LC

OND/TRA

Ligne de commande

Entête de l'ordre d'exécution

LC/RAT

OND/TRA

Ligne de commande de rattachement

Entête de l'ordre d'exécution

LF

TRA

Notes sur les lignes de commande fournisseur

MP

OND/TRA

Code article principal

Entête de l'ordre d'exécution - Sous-devis

MP/AML

TRA

Code article de l'amalgame

Entête de l'ordre d'exécution

MP/ARC

OND

Code article de l'architecture (conception)

Entête de l'ordre d'exécution

MP_CFE

TRA

Produit d'une ligne de cadencement de type E (affiche)

Entête de l'ordre d'exécution

MP_CFL

TRA

Produit d'une ligne de cadencement de type L

Entête de l'ordre d'exécution

MP/COM

OND

Code article de la composition

Entête de l'ordre d'exécution

MP/DEC

OND/TRA

Code article de la découpe

Entête de l'ordre d'exécution

MP/ENS

OND/TRA

Code article de l'ensemble

Entête de l'ordre d'exécution

MP/ENT

TRA

Produit de l'entité du devis

Entête de l'ordre d'exécution

MP/IMP

OND/TRA

Code article de l'impression

Entête de l'ordre d'exécution

MP/PAL

OND/TRA

Code article de la palette

Entête de l'ordre d'exécution

MP/PL1

TRA

Code article de palettisation (CIC C24) de la 1ère référence multiple de l'entité

Entête de l'ordre d'exécution

MP/PRE

OND

Code article de la pré-impression

Entête de l'ordre d'exécution

MP/QUA

OND/TRA

Code article de la qualité

MP/REF

TRA

Code article multi-références

Entête de l'ordre d'exécution

MP/RF0

TRA

Code article du produit référence multiple de l'entête du devis

Entête de l'ordre d'exécution

MP/RF1

TRA

Notes de la première référence multiple de l'entête

Entête de l'ordre d'exécution

NC/RAT

TRA

Séquence de la nomenclature de commande de rattachement

Entête de l'ordre d'exécution

REF

TRA

Liste des références

Entête du devis

Codes sources des clés LCO pour l'édition VoluEdit

Code | TRA | Libellé | Disponibilité
FI | TRA | Devis, sous-devis, entité | Entête de commande
L2 | TRA | Sous-devis | Sous-devis
LI | TRA | Devis, sous-devis, entité sur la ligne de commande | Ligne de commande
LI/SPE | TRA | SPECIFIQUE LCO, surface carton et métrage linéaire, codification étude pour Picador sur l'entité |


v_cdem Visualisation des commandes client

Passage d'une commande d'un site de production sur un nouveau site.

Sur les visu, on y accède par le F12 : entête de commande, puis par la touche F21 : Transfert

A ce niveau, une fenêtre de sélection du nouveau TYC (le nouveau TYC doit être de type sous-traitant) et du nouveau site (de sous-traitance) apparaît.

La modification du TYC de la commande initiale entraîne simultanément la création d'une commande client pour le site sous-traitant et la création d'une commande d'achat pour le site donneur d'ordre.

On retrouve ces deux commandes rattachées à la commande initiale sur les TSC LCC (lien commande client) et LCF (lien commande fournisseur) de cette dernière.

Les quantités lancées de chaque ligne de commande sont remises à zéro.

Les entrées en stocks prévisionnelles sont alors supprimées.

En marge des tables cde1 et cde2, il est désormais possible de lancer des actions en utilisant les données issues des tables cde9_e et cde9_l.

des_article_long (concaténation mp_des et mp_des2)

ec_devise, libc_ec_devise, libl_ec_devise

ec_ref_cderat

ec_sold

lc_bareme, libc_lc_bareme, libl_lc_bareme

lc_delcli

lc_delrep

lc_gen_dos_fab

lc_haut

lc_larg

lc_lieu_rgt1, libc_lc_lieu_rgt1, libl_lc_lieu_rgt1

lc_long

lc_p3

lc_prx

lc_prx_au_moins

lc_prx_au_plus

lc_prx_moins_dev

lc_prx_moins_euro

lc_prx_plus_dev

lc_prx_plus_euro

lc_qtecde

lc_qualif_appel, libc_lc_qualif_appel, libl_lc_qualif_appel, libs_lc_qualif_appel

lc_rstfab

lc_solde

lc_tva, libc_lc_tva, libl_lc_tva

lc_unvent, libc_lc_unvent, libl_lc_unvent

lc_unvent_au, libc_lc_unvent_au, libl_lc_unvent_au

lieu_destockage

mp_cond, libc_mp_cond, libl_mp_cond

mp_sbes

mp_scdef

mp_sdisp

mp_sphy

mp_sres

qte_fab_fbi

qte_raf_cda

qte_ral_cda

qte_tot_cda

quantite_initiale_sap

ref_client

sphy_sit Stock physique d'un lieu rattaché au site (dont le code site est lu sur la zone ec_c1)

zc1_lc_tva

zc1_lc_unvent

On veut afficher 2 colonnes :

Amortissement : cumul des totaux matières des phases AM, formules AM1/AM2/AM3

Report : cumul des totaux opérations des couples de phases/formules OF1/REP, OFB/REB et OF2/RE2

Deux compléments de sélections de phases/formules sont mettre en place :

Amortissement
_SUP_SQL_SOMME_1 | and (ga_phase = "AM" | Prise en compte de la phase AM
_SUP_SQL_SOMME_1 | and fm_formule in ("AM1","AM2","AM3")) | Prise en compte des formules AM1, AM2 et AM3 de la phase AM
Report
_SUP_SQL_SOMME_2 | and ( |
_SUP_SQL_SOMME_2 | (ga_phase="OF1" and fo_formule="REP") or | Prise en compte de la formule REP de la phase OF1
_SUP_SQL_SOMME_2 | (ga_phase="OFB" and fo_formule="REB") or | Prise en compte de la formule REB de la phase OFB
_SUP_SQL_SOMME_2 | (ga_phase="OF2" and fo_formule="RE2")) | Prise en compte de la formule RE2 de la phase OF2

Deux variables calculées seront nécessaires :

_VAR_a | SOMME_TOTMATDEV_1 | Calcul de la somme des formules matières du sous-devis associé à la ligne de commande en prenant en compte le complément de sélection n°1 et mise en place dans la variable a
_VAR_b | SOMME_TOTOPEDEV_2 | Calcul de la somme des formules opérations du sous-devis associé à la ligne de commande en prenant en compte le complément de sélection n°2 et mise en place dans la variable b
_CALC_01 |  | Mise en place de la variable a dans la colonne calculée n°1
_CALC_02 |  | Mise en place de la variable b dans la colonne calculée n°2

Deux colonnes seront affichées dans la visualisation :

V | Amortissement*CALC_01*10*######&.&&** | Affichage de la variable calculé n°1 dans une colonne Amortissement
V | Report*CALC_02*10*######&.&&** | Affichage de la variable calculé n°2 dans une colonne Report

v_cdem Visualisation des commandes client

Valeurs numériques Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Tri Noms de zones autorisés

Accès à la GED Gestion des trains de cadencements de fabrication Visualisation des commandes sans coût matière

Tableau de bord des indicateurs de rentabilité Réactualisation du récapitulatif des coûts

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Argument : code client Exemple : -N[cl_code]
-N_ART | Argument : code article Exemple : -N_ART[lc_prod] Le numéro est passé comme argument par le programme v_stk_lot_lieu (voir A4[11])
-N_C | Argument : numéro de commande - numéro de ligne de commande Exemples : -N_C[f0_cde] -N_C[f0_cde|-|f0_lig+<<&]
-N_CT | Argument : numéro de contrat - numéro de ligne de contrat Exemples : -N_CT[lc_num] -N_CT[lc_num|-|lc_lig+<<&]
-N_FD | Argument : numéro de forme de découpe - code client Exemples : -N_FD[fi_num_forme] -N_FD[fi_num_forme|CLIENT:|l2_client]
-N_LIN | Argument : Numéro de lot industriel (appel depuis le programme de visualisation des lots industriels) Exemple : -N_LIN[lin_lot_indus]
-N_LPF | Argument : Numéro de lot industriel pour en visualiser les produits en fabrication (appel depuis le programme de visualisation des lots industriels)
-N_RC | Argument : numéro de réclamation client Exemple : -N_RC[rcd_num_rec]
-N_RL | Argument : référence de liaison Exemple : -N_RL[l2_dossier]
-N_TC | Argument : code client pour les tarifs Exemple : -N_TC[cl_code]
-N_TM | Argument : code produit pour les tarifs Exemple : -N_TM[mp_code]

Valeurs numériques

1 | La valeur numérique 1 permet de travailler au 1000, et plus généralement à toute valeur paramétrée (au 10, au 10000 etc.). Les champs faisant référence à des valeurs au 100 gardent leur appellation d'origine. Exemple : Si valeur numérique 1 = 1000 : pv_100_kg_std désignera le prix de vente aux 1000 kg. pv_100_m2_std désignera le prix de vente aux 1000 m2. etc.
2 | Numéro du compteur de commande fournisseur

Options triées

Oas

En création d'adresse secondaire, on propose des blancs

Oba

Gestion des barèmes

L'option payante CDE-8 (Saisie des barèmes) doit être activée.

L'option société 39 (Gestion des prix au mille +) doit être positionnée.

Ocb

Ouverture d'une fenêtre de sélection pour le filtrage des lignes de commande par valeur du statut et/ou code blocage.

Ocd

Ouverture de la fenêtre de sélection des dépôts (RG1)

Permet de filtrer les commandes avec présence de stock sur les dépôts sélectionnés.

Ocf

Accès aux informations de cadencements de fabrication

Ocg

Active la création des groupage

Attention : active automatiquement les options alpha2[28], alpha2[39] et alpha2[55]

Pour la visu des séquences des lignes de commande.

Oct

Relance le calcul des tarifs pour les lignes de commandes et n'affiche que les lignes dont le tarif a été modifié.

Oda

Accès au suivi des dates

Voir la note AUTORISE_TOUCHE_F

Odf

Date du mouvement d'entrée prévisionnelle est égale au délai de fabrication

(à la place du délai répondu)

Oeo

Active l'édition des OF

Permet d'éditer les OF des commandes éditées sur v_cdem.

Les numéros d'OF relatifs aux commandes sélectionnées sont insérés dans la table canal_comm :

l'édition des OF se fait lorsque un programme de type oex est lancé en mode batch qui va scruter le contenu de la table canal_comm et lancer l'édition des OF.

Paramétrage nécessaire dans oex (y compris voluedit_oex) :

MODE AUTONOME O

PARAM_ED_OEX_AUTO #VEXXX (type d'édition à exécuter)

Ofm

Ouverture d'une fenêtre pour la mise à jour des mouvements de stock en cas de changement d'état du mouvement

Ogp

Recréation d'une entrée prévisionnelle de fabrication en désolde

de ligne de commande

ou de ligne de nomenclature

Ogt

Gestion des trains de cadencements de fabrication

Oh1

Rechercher systématiquement l'historique de prix de revient sur la ligne de commande 1

Ohp

Gestion de plusieurs types d'enregistrement hist_pr sur la même ligne de commande

Oi8

Limite la sélection aux commandes ayant des cadencements de livraison. Avec cette option, les commandes sans cadencement sont ignorées.

Oi9

Limite la sélection aux commandes ayant des cadencements de fabrication. Avec cette option, les commandes sans cadencement sont ignorées.

Ol8

Accès à la ligne de cadencement seulement (Touche F31)

L'option Oli est obligatoire et l'option Oq8 n'est pas autorisée.

Ola

Lancement de la visualisation de la planification

avec la clé suivante : [Numéro de commande]-[Numéro de ligne de référence d'amalgame]

Oli

Permet la visualisation des lignes de cadencement de livraison sans utiliser le tri

Voir les notes commençant par TYPE_NOTE_LIGNE_CAD

Permet de visualiser la première ligne de note d'une ligne de cadencement

Nom de la colonne : note_cad

Si l'option n'est pas activée, l'appel de la saisie des BL est fait avec 0 dans la ligne de cadencement de livraison.

Si l'option est activée, l'appel de la saisie des BL est fait avec la ligne de cadencement de livraison de la ligne visualisée.

Dans la saisie des BL , l'adresse de livraison, l'adresse de facturation et le lieu de rangement de l'entête du bon de livraison seront renseignés avec ceux de la ligne de cadencement de livraison passée en paramètre.

Olq

Détail du stock par lieux ou par lieux/lots limité à la quantité restant à livrer

La quantité restant à livrer est à 0 si la ligne est soldée ou si la ligne n'est pas soldée et que la quantité est négative.

Elle correspond au reliquat de livraison (Quantité commandée - Quantité déjà livrée)

Omc

Accès aux cadencements de livraison en mode modification

Nécessite la permission TOU VCDEM_F31_MOD

Omd

Mise à jour des mouvements de stock par différence

Omm

Pas de mise à jour des mouvements de stock en cas de changement d'état du mouvement

Omp

Exclut de la sélection les lignes de commandes pour lesquelles la quantité mouvementée calculée est négative (seules les Mouvementée Positives demeurent)

ATTENTION : Nécessite l'option Opd.

Omq

Ouverture de la fenêtre de saisie du motif de qualificatif d'appel de livraison

Ona

Numérotation annuelle pour le compteur des bons de préparation

Onc

Afficher les notes du client principal après la ligne de totalisation client

Si pas de totalisation, le fonctionnement reste le même qu'aujourd'hui.

Voir aussi A2[52].

Onl

Saisie des notes des lignes de commande uniquement

Lorsque cette option est présente, l'action de saisie des notes dirige automatiquement l'utilisateur vers la saisie des notes pour la ligne de commande sélectionnée.

En l'absence de cette option, un écran de sélection permet de choisir le type de notes que l'on souhaite saisir.

Onm

Il est possible de visualiser le prix de la précédente commande passée pour l'article concerné.

Si ce prix est inchangé et qu'on ne souhaite pas remplir cette colonne, positionner cette option.

Op1

Visualisation des commandes en mode papeterie

Opa

Prendre en compte les produits asynchrones présents dans la nomenclature de l'ensemble pour le calcul des quantités de stocks (colonne de visualisation commençant par stock_ens_)

Opd

Plage de dates

Opt

Permet de ne pas afficher la ligne de total général

Oq8

Modification du total des quantités commandées des cadencements de livraison (Touche F31)

Seule la quantité commandée de la ligne de commande est mise à jour.

L'option Omc est obligatoire et l'option Ol8 n'est pas autorisée.

NE PAS UTILISER AVEC LES APPAIRAGES

Orc

Edition du récapitulatif des cadencements de livraison de la ligne de commande

En mode édition, permet un récapitulatif des cadencements de livraison associés à la ligne de commande

Si une seule ligne de cadencement, alors pas d'affichage du récapitulatif.

Les zones affichées sont :

Le qualificatif, la date de livraison, la quantité livrée, le code postal et la ville, le lieu de rangement

Orf

Facture corrective au taux de change de la facture de rattachement

Orl

Restriction au lot des colonnes code_lieu et stock_lieu

Option inutile si commande de type FB2.

Si autre type, contrôle si produit de type synchrone / asynchrone.

Voir aussi alpha2[30]

Ors

Transfert automatique des stocks restant au solde / désolde de commande

Nécessite des notes commençant par _SQL_REAFFECT et REAFFECT.

Orv

Recalcule la visualisation après l'action de modification de la commande par F21.

Permet aussi le recalcul automatique pour le F34 de la visualisation de commandes.

Osa

Solde automatique des lignes de commande visualisées

Voir les notes AUTORISE_TOUCHE_F48 et SOLDE_AUTO_AVEC_MES

Osc

Edition des colonnes de stocks sur les lignes de contrats

Voir les notes commençant par _SUP_REQ_STK0_CTR

Attention : cette option conditionne la disponibilité de certaines zones concernant les contrats : dans la liste des noms de zone autorisés, ces zones portent en mention particulière rappelant cette contrainte.

Osd

Somme des quantités livrées et fabriquées des dossiers de rattachement

Ost

Remplacer la consultation des stocks du CONTROL-P par un accès à un autre programme de stock (maj_stk, &)

Voir les notes VISU_STK_DEPUIS_VS et VISU_PLANIFICATION

Otc

Gestion du tarif cartonnier

Ote

Solde des commandes de type TEXTILE

Otz

Affiche toutes les zones de tri même si elles se répètent

Ouv

Unité de vente pour calculer le prix de vente issu de la table mat et le prix du mouvement de stock

Ovd

Visualisation directe des commandes

Permet de lancer la visualisation directe en se basant sur les compléments de sélection du paramètre de lancement sans passer par l'écran de sélection.

Ovs

Visualisation simplifiée

Valeur alpha 2

Caractère 1

Second écran de sélection (N)

Caractère 2

Choix de l'ordre du tri (O/N)

Caractère 3

Pas d'édition des lignes détail (O/N)

Caractère 4

Mécanique - Imprimerie (O/N)

N Mécanique

O Imprimerie

Caractères 5 à 9

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

Caractère 10

Lancement en Batch (E/F)

E Edition

F Fichier (Nom du fichier à paramétrer dans les notes)

Caractère 11

Type d'écran de saisie F7 détail prix (1 à 6)

1 Ecran de saisie F7 détail prix standard. Stocké dans cde3

2 Ecran de saisie F7 détail prix avec marge. Stockée dans cde3

3 Ecran de saisie F7 détail prix avec marge, prix de revient et quantités saisies sans décimales
Stocké dans cde7

4 Ecran de saisie F7 détail prix avec marge, prix de revient et quantités saisies avec décimales
Stocké dans cde7

5 Ecran de saisie F7 détail prix standard avec quantités saisies sans décimales. Stocké dans cde7

6 Ecran de saisie F7 détail prix standard avec quantités saisies avec décimales. Stocké dans cde7

7 Ecran de saisie F7 détail prix standard avec marge, prix de revient et quantités avec décimales, totalisation dans l'unité de la ligne de commande. Stocké dans cde7

Caractère 12

Edition des notes saisies sur le client adresse livraison de la ligne de commande (O/N)

Caractère 13

Possibilité d'accéder directement au sous menu

E d' édition

F d'édition dans un fichier

Caractère 14

Edition en mode condensé (sauf entête) (O/N, N par défaut)

Caractères 15 à 17

Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350

Permet d'éditer une même ligne sur plusieurs lignes

Caractère 18

Mode d'accès au cadencement de livraison

O en mode Visu (par défaut)

N en mode modification de commande

Caractère 19

Accès à la table fab_1_etat (O/N, N par défaut)

Caractère 20

Sélection de la ligne de commande même si celle-ci n'a pas d'enregistrement dans la table fab_1_etat dans le cas d'une visualisation avec accès à la table fab_1_etat (O/N, N par défaut)

Le caractère 19 doit être à O

Caractère 21

Accès aux OF de niveaux inférieurs (O/N, N par défaut)

Le caractère 19 doit être à O

Caractère 22

Edition de la liste des accessoires (O/N) (édition uniquement)

Remarque : paramétrer le complément de sélection des accessoires.

Caractère 23

A utiliser lors d'édition des PRX.

O Exclut les lignes de commande PRX dont la commande de transfert est facturée

N Non (par défaut)

Caractères 24 à 27

Largeur du camion. A utiliser pour les palettes

Caractère 28

Sélection de la ligne de commande même si celle-ci n'a pas de nomenclature dans le cas d'une visualisation avec le détail de la nomenclature (O/N)

Caractère 29

Gestion des ensembles montés (O/N, N par défaut)

A2[29] prend le pas sur A2[55] en visualisation écran.

A2[29] et A2[55] sont incompatibles avec la note DETAIL_NOM_ECRAN.

Caractère 30

Edition de la liste des stocks par lieux ou par lieux/lots (O/N)

4 présentations sont possibles :

  1. Tableau stock trié par lieux de niveau 1 (fonctionnement par défaut)
    Edition d'un tableau non paramétrable à 2 colonnes, code du lieu et stock du lieu, après l'édition de la ligne de détail.

  2. Colonnes stock triées par lieux de niveau 1
    Edition de 2 colonnes, code du lieu et stock du lieu, dans la ligne de détail
    Nécessite le paramétrage des colonnes code_lieu et stock_lieu pour le type E
    Les données éditées sont identiques au mode 1, seul la présentation change
    Il y aura autant de lignes de détail éditées que de lieux de niveau 1 ayant du stock pour l'article

  3. Colonnes stock triées par lieux de niveau 1 et 2
    Edition de 3 colonnes, code des lieux 1 et 2 et stock du lieu 2, dans la ligne de détail
    Nécessite le paramétrage des colonnes code_lieu, code_lieu2 et stock_lieu pour le type E
    Il y aura autant de lignes de détail éditées que de couples lieux 1/lieux 2 ayant du stock pour l'article

  4. Colonnes stock triées par lots et lieux de niveau 1, niveau 2
    Edition de 4 colonnes, code des lieux 1 et 2 et stock du lieu 2 et lot, dans la ligne de détail
    Nécessite le paramétrage des colonnes code_lieu, code_lieu2, stock_lieu et numero_lot pour le type E
    Il y aura autant de lignes de détail éditées que de triplets lots/lieux 1/lieux 2 ayant du stock pour l'article

Les valeurs de stocks peuvent être modifiées par les options Orl et Olq.

Ces données ne sont disponibles qu'en mode Edition.

Caractère 31

Déduction escompte (O/N)

Caractère 32

Déduction remise (O/N)

Caractère 33

Lignes annulées (O/N)

Caractère 34

Edition des notes saisies sur la ligne de commande (O/N)

Caractère 35

Edition d'un libellé entre ligne (O/N)

Caractère 36

Edition d'un entête société (O/N)

Caractère 37

Saisie des notes possible (O/N)

Caractère 38

Saisie des matières consommées (O/N)

Caractère 39

Détail nomenclature (O/N)

Caractère 40

(O/N) Annulation des reliquats de stock (Sorties réservées) lorsqu'on solde :

- une commande

- ou une ligne de commande

- ou une ligne de nomenclature

- ou une ligne de cadencement (O/N)

Recréation des reliquats de stock (Sorties réservées) lorsqu'on désolde une ligne de commande ou une ligne de nomenclature ou une ligne de cadencement

Caractère 41

Mise à jour stock résultant (O/N, O par défaut)

Caractère 42

Type d'enregistrement de la table hist_pr (hp_type = C, F ...)

Caractères 43 et 44

N° de la zone prix de revient de la table hist_pr (hp_zn = 01 à 15)

Caractère 45

Ouverture automatique de la 2ème fenêtre critère sélection client (O/N)

Caractère 46

Ouverture automatique de la 2ème fenêtre critère sélection article (O/N)

Caractère 47

Type de recherche du code article par F7

1 Recherche Normale (désignation, famille, etc ...) (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Q Recherche par composition carton (qualité)

T Recherche Transformateur

Caractère 48

Type de recherche du code normalisé (AFNOR) par F7

1 Recherche fichier articles

2 Pas de contrôle (par défaut)

Caractère 49

Type de visualisation

[blanc] Standard

S Standard

H Standard + Historique

E Enregistrés

F Facturés

Caractère 50

Type d'historique (hp_type = C, F ...)

Caractère 51

Edition des notes saisies sur l'entête de commande (O/N)

Caractère 52

Edition des notes saisies sur le client adresse principale (O/N)

Caractère 53

Edition des notes saisies sur l'article (O/N)

Caractère 54

Edition de l'adresse livraison (O/N)

Caractère 55

Edition du détail nomenclature (O/N)

A2[29] prend le pas sur A2[55] en visualisation écran.

A2[29] et A2[55] sont incompatibles avec la note DETAIL_NOM_ECRAN.

Caractère 56

Edition montant et quantité (O/N)

N Montant en devise et quantité en unité

O Montant en kilodevise et quantité en milliers

Caractère 57

Prise en compte des commandes clients de type FAD/AVO non rattachées à un dossier/sous-dossier (O/N) A utiliser pour le BATCH et type de visualisation = F

N Prise en compte des commandes clients

O Pas de prise en compte des commandes clients

Caractère 58

Pas de prise en compte des commandes fournisseurs (O/N)

A utiliser pour le BATCH et type de visualisation = F

N Pas de prise en compte des commandes fournisseurs

O Prise en compte des commandes fournisseurs

Caractère 59

Prise en compte des commandes clients de type FAD/AVO rattachées à un dossier/sous-dossier

A utiliser pour le BATCH et type de visualisation = F

N Prise en compte des commandes clients

O Pas de prise en compte des commandes clients

Caractère 60

Type d'écran de saisie commande

1 Ecran de saisie commande STANDARD

2 Ecran de saisie commande VOLUPRIM

Valeur alpha 3 : Titre de la visualisation

VISUALISATION DES COMMANDES CLIENTS

Valeur alpha 4 : Paramétrage des touches de fonction

Caractère 1

Visualisation de la traçabilité (option payante CDE, 3)

E visualisation traçabilité en-tête commande

L visualisation traçabilité ligne de commande (valeur par défaut)

Q visu d'après choix utilisateur (en-tête ou ligne)

Caractère 2

Caractère 3

Caractère 4

Caractère 5

Caractère 6

Touche F6 (O/N) Visualisation du tableau des lignes

Caractère 7

Touche F7 (O/N) Visualisation du tableau F7 détail prix

Caractère 8

Touche F8 (O/N) Visualisation de l'écran détail ligne

Caractère 9

Touche F9 (O/N) Visualisation des matières consommées pour les cartonniers

Caractère 10

Caractère 11

Touche F11 (O/N) Visualisation des commandes du client

Caractère 12

Touche F12 (O/N) Visualisation de l'écran détail entête

Caractère 13

Touche F13 (O/N) Solde la commande - Solde ou non la ligne de commande

Caractère 14

Touche F14 (O/N) Mise à l'état facturable ou non facturable de la commande

Caractère 15

Touche F15 (O/N) Visualisation de l'écran détail nomenclature

Caractère 16

Touche F16 (O/N) Visualisation des quantités fabriquées

Caractère 17

Touche F17 (O/N) Visualisation des statistiques client

Caractère 18

Touche F18 (O/N) Visualisation de l'encours crédit client

Caractère 19

Touche F19 (O/N) Visualisation de la fiche article

Caractère 20

Touche F20 (O/N) Visualisation des informations complémentaires

Caractère 21

Touche F21 (O/N) Modification de la commande

Caractère 22

Touche F22 Bascule pour le transfert vers PC-TOPP

Caractère 23

Touche F23 (O/N) Mise à 0 de la quantité livrée validée de la ligne de nomenclature

Nécessite permission TOU - RAZ_QTELIV_VAL

Caractère 24

Touche F24 (O/N) Mise à l'état facturable ou non facturable de la ligne de commande

Caractère 25

Touche F25 (O/N) Rafraîchissement de la visualisation après mise à jour sur une sélection multiple

Caractère 26

Touche F26 (O/N) Appel du programme paramétré dans la note VISU_PLANIFICATION

Caractère 27

Touche F27 (O/N) Visualisation des OF associes à la ligne de commande

Caractère 28

Touche F28 (O/N) Visualisation des commandes associées au contrat courant

Voir la note RUN_VISU_CDE_CONTRAT

Caractère 29

Touche F29 (O/N) Visualisation des frais d'expédition

Caractère 30

Accès à la visualisation de la nomenclature multi-niveaux

Caractère 31

Touche F31 (O/N) Visualisation des cadencements de livraison

Caractère 32

Touche F32 (O/N) Appel de la visualisation des commandes fournisseurs

Caractère 33

Touche F33 (O/N) Appel de la visualisation de fab_1_etat (commande en production)

ou Appel du programme paramétré dans la note VISU_PLANIFICATION

Caractère 34

Touche F34 (O/N)

Appel de la visualisation des commandes de type CD1 pour les commandes de type CDA

Appel de la visualisation des commandes de type FBI pour les commandes de type CD2

etc...

Voir les notes commençant par RUN_VISU_TYPE_RATT et RUN_VISU_CD1

Caractère 35

Caractère 36

Caractère 37

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Caractère 38

Touche CONTROL-C (O/N) Calculatrice

Caractère 39

Touche CONTROL-E (O/N) Visualisation des articles du client

Caractère 40

Touche CONTROL-F (O/N) Visualisation des BL et des factures.

Le format est paramétré dans la note USING_CTRL_F du #CF ATL.

Caractère 41

Autorise la touche de fonction CTRL-G qui génère le groupage à partir des lignes pointées

Caractère 42

Validation de la ligne de cadencement de livraison

Touche accessible sur le tableau des lignes uniquement.

Voir la note AUTORISE_TOUCHE_F42

Caractère 43

Touche CONTROL-J (O/N) Appel de programmes

Caractère 44

Touche CONTROL-K (O/N) Action à réaliser sur une sélection multiple

Caractère 45

Caractère 46

Touche CONTROL-N (O/N) Visualisation des notes

Caractère 47

Caractère 48

Touche CONTROL-P (O/N) Visualisation du pied de commande

ou lancement du programme paramétré dans la note VISU_STK_DEPUIS_VS.

Caractère 49

Caractère 50

Caractère 51

Touche CONTROL-T (O/N) Visualisation des touches

Caractère 52

Caractère 53

Caractère 54

Accès à l'ouverture automatique de documents Windows (O/N, N par défaut)

ermet l'ouverture de documents Windows à partir de la ligne de visualisation de commande

Ce paramètre équivaut à l'option Orw sur la saisie de commande.

Permission identique à la saisie de commande : TOU CDE1_CTRL_W

Voir les notes PARAM_TYP_DOCUMENT et DEF_TYP_DOCUMENT

Caractère 55

Caractère 56

Touche CONTROL-Z (O/N) Lancement de programmes

Caractère 57

Permet de ne pas traiter les lignes de commande avec qte_lot2 = 0 (O/N)

Caractère 58

Autorisation de la touche de fonction F38 (O/N) - Solde / Désolde de la fabrication de commande

Les permissions MOD/SOLDE_FAB et MOD/DESOLDE_FAB sont nécessaires.

Si la ligne de commande en cours est soldée en fabrication, l'action se nomme Désolde fabrication.

" Si la ligne de commande en cours n'est pas soldée en fabrication, l'action se nomme Solde fabrication.

Solde de fabrication voir note sur paramètre USE : SOLDE_DESOLDE

Caractère 59

Autorisation de la touche F39 pour blocage/déblocage de commande

Caractère 60

Touche F40 (O/N) : Consultation du détail du textile

Notes

ACCES_CONSULT_STOCK

21,26 Type et code du paramètre de lancement du programme de consultation des stocks

ACCES_DEVIS

21,26 Type et code du paramètre de lancement de la saisie des devis de fabrication (devis/sous-devis associé à la ligne de commande en cours)

ACCES_DEVIS_COM

21,26 Type et code du paramètre de lancement de la saisie des devis commerciaux

ACCES_VISU_CDE

Lancement d'une nouvelle visualisation de commande, liée à la commande (ou la ligne de commande) en cours

21,26 Type et code du paramètre de lancement de la nouvelle visualisation de commande

27 Clé à prendre en compte dans la nouvelle visualisation de commande

E Entête de commande

L Entête et ligne de commande (par défaut)

ACCES_VISU_CDE_LIBC

21,60 Libellé court de l'action de lancement d'une nouvelle visualisation (menu des actions, F33/Control-Shift-F9)

Par défaut, on prend le libellé court du paramètre de lancement de la nouvelle visualisation de commande

ACCES_VISU_CDE_LIBL

21,60 Libellé long de l'action de lancement d'une nouvelle visualisation (commentaire de l'action, F33/Control-Shift-F9)

Par défaut, on prend le libellé long du paramètre de lancement de la nouvelle visualisation de commande

ACTION_OUTIL_AUTO

21,23 Code action automatique à créer au solde de la fabrication (Type de paramètre ASO)

Permet de créer une action automatique de suivi d'outillage au solde de la fabrication (touche F38).

AFF_EVENEMENT_

Cette note est prioritaire sur celle du #CF EVT.

AFF_MES_AVER_ENT_PRE

21 Affichage d'un message d'avertissement qu'aucun mouvement de stock d'entrée prévisionnelle n'a été créé (O/N, N par défaut)

AFF_MES_AVER_SOR_RES

21 Affichage d'un message d'avertissement qu'aucun mouvement de stock de sortie réserve n'a été créé (O/N, N par défaut)

ALIM_DEFAUT_LI4

21 Mode d'alimentation des colonnes li4_...

N Pas d'alimentation par défaut [valeur par défaut]

O Alimenté par les cadencements de la ligne de commande si pas de nomenclature.

P Alimenté par les cadencements de la ligne de commande si l'article commandé est non appairé ou monté

ARTIOS_DECONNECTE

21 Utiliser l'interface ArtiosCAD en mode déconnecté (O/N, N par défaut)

AUTORISE_TOUCHE_F37

Visualisation simplifiée des stocks

AUTORISE_TOUCHE_F41

21 Autorisation de la touche F41 (Suivi des dates) (O/N, N par défaut)

Nécessite l'option Oda

AUTORISE_TOUCHE_F42

21 Autorisation de la touche F42 (O/N) (validation du cadencement)

AUTORISE_TOUCHE_F43

21 Autorisation de la touche F43 (O/N, N par défaut)

F43 : Génération du dossier de fabrication (gestion des barèmes)

AUTORISE_TOUCHE_F44

21 Génération des bons de livraison autorisée (O/N, N par défaut)

Voir aussi la note PARAMETRE_SAISIE_BL.

AUTORISE_TOUCHE_F45

21 Accès au correspondant

AUTORISE_TOUCHE_F47

Accès au devis lié (renseigner la note CONFIG_DEG_DER_DEVIS)

AUTORISE_TOUCHE_F48

Autorisation de la touche F48 (O/N, N par défaut)

Solde automatique des lignes de commande. Voir option Osa

AUTORISE_TOUCHE_F49

21 Accès à la revue de contrat

O autorise en visu uniquement

N accès interdit

M autorise en visu et modification

AUTORISE_TOUCHE_F50

Accès à la génération des dossiers (voir la note PARAM_GEN_DOS)

AUTORISE_TOUCHE_F51

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21 Visualisation des commandes uniquement : Autorisation de la touche F51 : Détail des coûts (O/N, N par défaut)

AUTORISE_TOUCHE_F53

21 Type d'accès à l'action Produits à qualifier/surveiller

O Accès en consultation uniquement

M Accès en modification

N Pas d'accès à la fonction

Voir #CF ATL A3[60]

AUTORISE_TOUCHE_F54

21 Modification de l'alerte de la ligne de commande ou de nomenclature (N/O, N par défaut)

Permet de basculer l'alerte de B (Bloquée) à D (Débloquée) ou l'inverse.

Si l'alerte est à N, elle n'est pas modifiable.

Voir les nouvelles zones lc_alerte et nc_alerte (disponibles en visu, en édition VoluEdit et dans la traçabilité)

Voir #CF ATL A3[60]

AUTORISE_TOUCHE_F55

21 Modification du pré-solde de la ligne de commande ou de nomenclature (N/O, N par défaut)

Permet de basculer le pré-solde de N (Non) à O (Oui) ou l'inverse.

Voir les nouvelles zones lc_pre_solde et nc_pre_solde (disponibles en visu, en édition VoluEdit et dans la traçabilité)

Voir #CF ATL A3[60]

AUTORISE_TOUCHE_F56

Autorisation d'accès à la visualisation des commandes rattachées (O/N, N par défaut)

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

AUTORISE_TOUCHE_F57

Autorisation d'accès à la saisie des cadencements de fabrication

N Pas d'accès

O Accès en consultation seule

M Accès en modification

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

AUTORISE_TOUCHE_F58

Autorisation d'accès à la création de commande commerciale

AUTORISE_TOUCHE_F59

Autorisation d'accès à la saisie des actions événements (Ctrl A)

CDE_RAT_ENS_MONTE

Données de rattachement pour les FBI liées à des ensembles montés

21 Récupérer les données de la commande commerciale rattachée lorsque la commande courante est une FBI associée à un ensemble monté

N Jamais (par défaut)

E Lorsque l'ensemble est monté à l'extérieur uniquement (mp_param[22] = E)

M Lorsque l'ensemble est monté en interne uniquement (mp_param[22] = M)

2 Lorsque l'ensemble est monté à l'extérieur ou en interne (mp_param[22] = E ou M)

Permet de remplacer certaines zones de la ligne de commande par celle de la ligne de commande de rattachement lorsque celle-ci concerne un ensemble monté (en interne, à l'extérieur ou les deux) et que la commande en cours de visualisation est la commande de fabrication (FBI).

IMPORTANT : Seules les zones suivantes sont concernées :

" Code produit de la ligne de FBI (lc_prod), remplacé par le code produit de la ligne de commande commerciale rattachée

" Quantité commandée de la ligne de FBI (lc_qtecde), remplacée par la quantité commandée de la ligne de commande commerciale rattachée

" Quantité lancée de la ligne de FBI (lc_qtelan), remplacée par la quantité commandée de la ligne de commande commerciale rattachée

" Quantité livrée de la ligne de FBI (lc_qteliv), remplacée par la quantité livrée de la ligne de commande commerciale rattachée

ATTENTION : Toutes les autres zones sont inchangées et conservent les données correspondantes à la ligne de commande de FBI.

CF_MAJ_FLAG_INFO_C

Voir page dédiée

CHGT_SITE_STR_CDE

Transfert d'une commande d'un site de production vers un site de sous-traitance - Explications

Tableau de bord du multisite

21, 23 Code TYF pour la création de l' entête de commande d'achat

24, 29 Type et code recherche tarif

30 Code calcul délai. Paramétrage évolutif en fonction des besoins

1 Délai initial du client (par défaut)

CLIENT_NOMENCLATURE

Recherche du code client de la nomenclature

21 à 26 Code client

CODE_BLOCAGE_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

CONF_CRE_ENT_PRE

21 Affichage d'un message d'avertissement qu'aucun mouvement de stock d'entrée prévisionnelle n'a été créé (O/N, N par défaut)

CONFIG_AFF

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

Par défaut #CF/AFF

CONFIG_EVT

21,23 Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements

Par défaut #CF/EVT

CONFIG_DEG_DER_DEVIS

Paramétrage de la configuration générale des devis

21,23 Code paramètre de la configuration générale du devis
Facultatif. Par défaut : DEG

24,26 Code paramètre de la configuration du récapitulatif du devis
Facultatif. Par défaut : DER

CONFIG_DEG_DER_PREV

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement prévisionnel. Par défaut : DEG

24,26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement prévisionnel. Par défaut : DER

CONFIG_DEG_DER_REEL

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21,23 Configuration générale de devis utilisée pour le calcul de l'environnement réel. Pas de valeur par défaut.

24,26 Configuration de récapitulatif de devis utilisée pour le calcul de l'environnement. Pas de valeur par défaut.

_CSEL

Affichage de la colonne de sélection (colonne de droite)

Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement. Voir #RP

DEF_TYP_DOCUMENT

21 Définition du nom du document

1 Le nom du document est le numéro de commande en cours de visualisation (par défaut)

2 Le nom du document est saisissable par l'utilisateur

Voir aussi A4[54] et la note PARAM_TYP_DOCUMENT

DETAIL_NOM_ECRAN

21 Affichage du détail nomenclature à l'écran (O/N)

Fonctionnement identique au A2[55], qui est géré pour l'édition.

L'option société 15 doit être activée.

A2[29] et A2[55] ne sont pas compatibles avec cette note.

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

DS_DOUBLE_CALCUL

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.Cette note est recherchée en priorité dans le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

DS_GESTION_EFFECTIF

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

DS_RAZ_QUANTITES

21 Activer la remise à zéro des quantités des opérations si le temps total est à zéro (O/N, O par défaut)

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

EDAR (pour l'édition)

Pouvoir éditer l'AR suite à F21

5,7 Code site (correspond à la zone au ec_c1)

8 : (2 points)

9,14 Type et code du lanceur de l'édition d'AR

Tableau de bord du multisite

EDIT_ACCUSES_RECEPT

Pour lancer l'édition des AR de toutes les commandes sélectionnées après la validation de la visualisation (fonctionne également pour le mode Edition).

21,26 Type et code du paramètre de lancement de l'édition des AR

EDITION_BON_PREP

21,26 Type et code du paramètre de lancement du programme d'édition des bons de préparation

ETAT_DEVIS_BAREME

21,23 Code état du devis issu des barèmes par défaut (paramètre ETD)

L'option Oba doit être activée. Par défaut : ATT - Facultatif

ETATS_CADENCEMENTS

21,23 Code état de création des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : CRE

24,26 Code état de modification des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : MOD

27,29 Code état de livraison non soldée des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : LNS

30,32 Code état de validation des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : VAL

Si cette note n'existe pas, elle est recherchée dans le #CF ATL.

FENETRE_SEL_CAD_LIV

21 Lors du solde/désolde de livraison, afficher la fenêtre de sélection des cadencements (O/N, O par défaut)

_FOR_INDIC_

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_HIS_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

LCT_MULTI_CONFIG

21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple (#RPxxx).

En conjonction avec le #RP, cette note est utilisée pour :

- la gestion des trains de cadencements de fabrication (paragraphe dédié en bas de ce chapitre)

- la visualisation des commandes sans coût matière avec réactualisation des indicateurs de rentabilité client (paragraphe dédié en bas de ce chapitre)

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Remarques à propos de la papeterie

Plus de détail dans le #RP

L_SUP_REQ_ACC

Complément de sélection pour la liste des accessoires (alpha2[22])

21 à 60 Complément de requête (table nom0). Exemple : and n0_pcsant matches "ACC*"

L_SUP_REQ_LOT_LIEUX

21 à 60 Complément de requête pour les colonnes suivantes :

code_lieu, stock_lieu, qte_lot1_lieux et qte_lot2_lieux

LIBC_BLOCAGE

21,30 Libellé court blocage (par défaut : Bloqué) - Agit sur les zones libc_blocage et libl_blocage

LIBC_DEBLOCAGE

21,30 Libellé court blocage (par défaut : Débloqué) - Agit sur les zones libc_blocage et libl_blocage

LIBL_BLOCAGE

21,45 Libellé long blocage (par défaut : Bloqué)

LIBL_DEBLOCAGE

21,45 Libellé long blocage (par défaut : Débloqué)

LIEU2_A_EXCLURE_DSOL

21, 23 Code lieu 2 à exclure du

LIEU2_A_EXCLURE_REAF

21, 23 Code lieu 2 à exclure du lieu 2 de la réaffectation des stocks

LIGPARCF

Dans la visualisation des BL et facture d'une ligne de commande (CONTROL-F), permet d'afficher une ligne paramétrable d'informations

Voir le paramétrage dans cde.

LIGPAR_RC

10,60 Possibilité de définir des champs visualisables en bas de l'écran de revue de contrat avec l'option Ovl

Paramétrage de la ligne d'affichage sous la forme suivante LLL*CCC*TTT*UUU*SL*

LLL Libellé affichable à l'écran

CCC Liste des champs visualisables :

Cliquez ici pour afficher / masquer la Liste des champs visualisables (triée par ordre alpha)

Les TSC, avec la même syntaxe d'appel que pour les visus.

Exemple d'affichage de TSC : LIGPAR_RC Info Livraison*TSC_LC_LI_60F_G*30**

TTT Taille de la zone

UUU using

SL Saut de ligne (O/N, N par défaut)

Cette note est disponible dans tout programme appelant la revue de contrat : cde, labo, v_cdem

LISTE_ETATS_CADENC

21,60 Liste des états de cadencements prédéfinis

Explications dans le paramètre ECA.

LISTE_TYC_CALC_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

MAJ_FLAG_INFO_C

Voir page dédiée

MAJ_STK_DEPUIS_VS

Touche F8 à partir de la visu simplifiée (F37)

21,26 Type et code du paramètre de lancement de la correction des stocks

MODIF_ETATS_CADENC

21 Choix de l'état de cadencement (O/N, N par défaut)

Explications dans le paramètre ECA.

_NB_DER_LIGNE_EDITEE

21,22 Nombre de "dernières" lignes à éditer

NB_REFERENCES_DEVIS

21 La famille fait-elle l'objet d'un calcul du nombre de références devis dans v_cdem ?

O Le calcul sera fait

N Le nombre de références devis sera toujours à 0.

Valeur par défaut : Si famille FRA, le nombre de références devis sera toujours à 0, sinon il sera calculé.

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table cde3- Obligatoire. Exemple : TEX

24 Code d'édition des notes du TEXTILE de la table cde3 (Type NTS) (N/O). Obligatoire

NOTES_ACTION_EVT

21,60 Liste des codes NTS accessibles en saisie de notes pour les actions

Paramétrage équivalent au C

Exemple

3CLI2QA

Voir #CF EVT.

NOTES_NOM_EXCEDENT

[Pas de paramétrage à partir du caractère 21]

La seule présence de cette note permet d'afficher les lignes d'introduction et le détail du picking

Les lignes d'introduction sont définies dans les notes NOTES_EXCEDENTS_ARE et NOTES_EXCEDENTS_ADE définies sur le paramètre de lancement de acr.

Attention : alpha2[39] et alpha2[55] doivent être positionnés à O (oui).

Ne pas oublier d'indiquer les types de notes dans le C.

NUM_CPTEUR_BON_PREP

Numéro de compteur pour les bons de préparation

_OPTION_LIB_MACHINE

Editer le libellé d'une machine d'un type particulier si cette machine est présente dans la gamme de fabrication de l'article

ATTENTION, OPTION SPECIFIQUE, NE DOIT PAS ETRE UTILISEE SANS UNE CONFIRMATION DE VSW

21 à 23 type machine

ORDRE_MULTISELECT

Respecter l'ordre de sélection

O Respecter l'ordre de sélection

N Fonctionnement actuel (par défaut)

Ce nouveau paramétrage permet, lors de l'utilisation du CTRL K, de respecter l'ordre de sélection pour les différents traitements.

Sans ce paramétrage, l'ordre de traitement correspond à l'ordre de la visualisation.

La note _CSEL est nécessaire.

Exemple d'utilisation

Lors de la création d'un BL depuis l'action ACT010 du CTRL K, les lignes de BL seront affichées dans l'ordre de sélection.

OUTIL_LCO_FOR_ACT

Générer un fichier de certificat de conformité

Cette note et la suivante existent aussi dans le programme de génération de fichiers Preactor.

Voir aussi les notes OUTIL_LCO_FOR_DES et _SUP_REQ_CERTIF_DE

Zones utilisables

21,40 Nom de la zone à tester pour activer la recherche de l'outil sur la LCO FOR

41,60 Valeur à tester pour activer la recherche de l'outil sur la LCO FOR

OUTIL_LCO_FOR_DES

Générer un fichier de certificat de conformité

Voir la note OUTIL_LCO_FOR_ACT ci-dessus pour plus d'info.

21,40 Nom de la zone à tester pour désactiver la recherche de l'outil sur la LCO FOR

41,60 Valeur à tester pour désactiver la recherche de l'outil sur la LCO FOR

PARAM_CALCUL_DEVIS

21,26 Type et code du paramètre de lancement de la saisie du devis onduleur pour la réactualisation du récapitulatif des coûts

Le mode batch est positionné automatiquement.

Voir aussi la note PARAM_INDICATEURS.

PARAM_CONSULT

21,26 Type et code du paramètre de lancement du programme de qualité carton en mode consultation (#SA QUA par défaut).

Cette note est accessible dans tous les programmes exploitant la fonction f_visu_nomenclature : cde, blv, v_cdem, v_jbl

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

Permet d'aller chercher sur le paramètre de lancement de qte_prod (alpha2[1,3]) le type de mouvement associé aux entrées en production.

PARAM_EDI_FIC_FAB

21,26 Type et code du paramètre de lancement de l'édition de la fiche de fabrication

Facultatif - #EDFFA par défaut

PARAM_EDITION_FS

Edition des fiches de spécification depuis la visu de la nomenclature

21 à 26 Type et code de l'édition des fiches de spécifications.

PARAM_GEN_DOS

21 26 Type et code du paramètre de lancement de la génération du dossier

Facultatif - #FBGDF par défaut

PARAM_INDICATEURS

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

PARAM_LAN_DOS

21 26 Type et code du paramètre de lancement du lancement du dossier

Facultatif - #FBDOS par défaut

PARAM_RECH_TARIF

Paramétrage de la recherche de tarif

(pour accès à la visu depuis les tarifs client et tarifs produit)

21,26 Type et code du paramètre de recherche des tarifs (ex : #CFTAR)

27 Recherche tarif sur date de livraison (idem option Ot3 en saisie de commande) (O/N)

PARAM_REF_CLIENT

Nouvelle zone de référence d'entête commande cliente plus grande <VF>

Dans la saisie des commandes clients et/ou lors du transfert d'un devis en commande, via paramétrage, il est possible de saisir une deuxième référence client (ec_ref_2) sans contrainte de clé unique jusqu'à 30 caractères.

La première référence peut être masquée pour ne laisser que la deuxième référence visible dans les écrans.

Cette nouvelle zone est accessible dans les éditions VoluEdit et dans les visualisations.

ATTENTION : Ne mettre les caractères 21 ET 22 à N (simultanément) qu'en transfert de devis en commande ou en consultation !!!

21 Afficher ou Masquer la référence client 2 (ec_ref_2) (champs plus grand)

O Afficher

Dans ce cas, la référence client (ec_ref) est systématiquement renseignée avec le numéro de commande (ec_num).

N Masquer (par défaut)

22 Afficher ou Masquer la référence client (ec_ref)

O Afficher (valeur par défaut si la note n'est pas créée, ou qu'elle est créée avec les car. 21 & 22 vides)

N Masquer (valeur par défaut si la note est créée, ou qu'elle est créée avec le car. 21= O)

23, 24 Type d'aide sur saisie référence (facultatif)

01 Référence = Numéro de commande

02 Référence = Client Nombre de commandes

03 Référence = Client Millésime de la commande Nombre de commandes

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF ATL.

PARAM_REG_DOS

21 26 Type et code du paramètre de lancement de la régénération du dossier

Facultatif - #FBRGD par défaut

PARAMETRE_SAISIE_BL

21,26 Type et code du paramètre de la saisie des bons de livraison

Voir aussi la note AUTORISE_TOUCHE_F44.

PARAM_TYP_DOCUMENT

21,23 Code du paramètre de document (doit correspondre à un type de paramètre WIN)

Voir aussi A4[54] et la note DEF_TYP_DOCUMENT

PAR_LCT_GEN_CAD_FAB

21,26 Type et code du paramètre de lancement de la génération des cadencements de fabrication

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

QUALIFICATIF_APPEL

21, 23 Qualificatif d'appel pour la nouvelle ligne

Voir aussi les notes TYPE_NOTES_CLIENT et TYPE_NOTES_INTERNE

QUALITE_CARTON

21 Préfixe des qualités carton

RDAR (pour la ré-édition)

Voir EDAR

REAFFECT_ETAT

21 Code état des mouvements générés (N ou 2, N par défaut)

REAFFECT_NVE_VEN

Paramétrage des mouvements générés au DESOLDE

21 à 23 = Type du mouvement de sortie (SN par défaut)

24 à 26 = Type du mouvement d'entrée (EN par défaut)

27 à 29 = Lieu de rangement 1 en entrée (USI par défaut)

30 à 35 = Lieu de rangement 2 en entrée (VEN par défaut)

REAFFECT_VEN_NVE

Paramétrage des mouvements générés au SOLDE

21 à 23 = Type du mouvement de sortie (SN par défaut)

24 à 26 = Type du mouvement d'entrée (EN par défaut)

27 à 29 = Lieu de rangement 1 en entrée (USI par défaut)

30 à 35 = Lieu de rangement 2 en entrée (NVE par défaut)

REFERENCES_OUTIL

Références de l'outil

21 Edition des références de l'outil (O/N, N par défaut)

22 Numéro du critère de saisie (Note _CRIT_CHAR_) de l'outil (1 à 9)

23,25 Code TSC permettant d'identifier les notes TEST_IC_PROD_LIG_ dans lesquelles sont paramétrées le complément de sélection des références de l'outil.
Si ce code n'est pas spécifié, on conserve le fonctionnement précédent.

RESTCDE8

Restreindre le CTRL-F au cadencement de livraison (O/N)

RESTRIC_ENTREE_PROD

21 à 60 Compléments de requête pour les entrées de stock

RESTRIC_SORTIE_PROD

21 à 60 Compléments de requête pour les sorties de stock

RESTRIC_STOCK_NUM_

19,20 Numéro permettant de créer plusieurs restrictions différentes

21,60 Complément de requête sur la table stk0

S'utilise avec les zones suivantes:

stock_physique_pf_nn

stock_phys_pf_lot_nn

stock_dispo_pf_nn

stock_ens_nn

stock_liv_nn

Exemple :

RESTRIC_STOCK_NUM_01 and s0_rgt2[1,3]=VEN

permet l'utilisation des zones suivantes :

stock_physique_pf_01

stock_phys_pf_lot_01

RUNCDE

Pour pouvoir modifier une commande par F21, il faut renseigner le paramètre de lancement pour chaque TYC.

8,10 Code TYC de la commande (si on ne trouve pas de paramétrage pour le TYC de la commande, on recherche ave le code TYC = ###).

Si gestion par site (caractère 15 = :)

12,14 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite

15 : (2 points)

16,21 Type et code du paramètre de lancement de la saisie de commande

Si pas de gestion par site (caractère 15 différent de :)

12,17 Type et code du paramètre de lancement de la saisie de commande

RUN_VISU_CD1

Paramétrage de lancement de la visualisation des commandes clients pour les commandes de type CD1 à partir des commandes de type CDA (activation par alpha4[34])

21,23 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite

24 : (2 points)

25,30 Type et code du lanceur de la visu de CD1

32 Restriction des commandes CD1 visualisées

A Restriction sur le code article.

C Restriction sur le numéro de commande (par défaut).

L Restriction sur le numéro de ligne de commande.

Cette note peut être remplacée par la note RUN_VISU_TYPE_RATT qui n'est pas limitée aux CDA / CD1.

RUN_VISU_CDE_CONTRAT

21,26 Type et code du paramètre de lancement de la visualisation des commandes associées au contrat courant (touche F28)

RUN_VISU_CDEF

Paramétrage de lancement de la visualisation des commandes fournisseurs (alpha4[32] : activation)

21 à 26 Type et code du paramètre (ex : #VICDF)

RUN_VISU_CDE_RAT

Visualisation des commandes rattachées

21,26 Type et code du paramètre de visualisation des commandes rattachées

27 Type de rattachement :

E Sélection des lignes de commande rattachées à l'entête de commande en cours

L Sélection des lignes de commande rattachées à la ligne de commande en cours (par défaut)

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

RUN_VISU_TYPE_RATT

Possibilité de paramétrer le type de visu cible sur le F34

(activation par alpha4[34])

Avant, cette touche n'était active que pour les CDA (et on pointait vers une visu de CD1).

(Voir la note commençant par RUN_VISU_CD1, toujours opérationnelle)

Maintenant, on paramètre le TYC de rattachement avec son TYC rattaché.

2 cas de figure peuvent se présenter.

1) Vous gérez les sites, le paramétrage est le suivant :

21,23 Code TYC

24,26 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite

27 : (2 points)

28,33 Type et code du lanceur de la visu de commande rattachée au TYC

Voir aussi la note _SUP_REQ_EC_TYC.

35 Restriction des commandes CD1 visualisées. Applicable uniquement aux commandes CDA et CD1

A Restriction sur le code article.

C Restriction sur le numéro de commande (par défaut).

L Restriction sur le numéro de ligne de commande.

2) Vous ne gérez pas les sites, le paramétrage est le suivant (la zone ec_c1 est utilisée) :

21,23 Code TYC

24,29 Type et code du lanceur de la visu de commande rattachée au TYC

Voir aussi la note _SUP_REQ_EC_TYC.

35 Restriction des commandes CD1 visualisées. Applicable uniquement aux commandes CDA et CD1

A Restriction sur le code article.

C Restriction sur le numéro de commande (par défaut).

L Restriction sur le numéro de ligne de commande.

Exemple pour lancer une visu de la FBI depuis une visu de CD2

Sur le paramètre de lancement de la visu de CD2 :

RUN_VISU_TYPE_RATT CD2 :#VIFBI

Sur le paramètre de lancement de la visu de FBI (#VI FBI) :

##### Appel depuis une CD2

TYC_EQUIVALENCE_CD1 FBI

TYC_EQUIVALENCE_CDA CD2

Les zones nc_numfbi et nc_ligfbi on été rajoutées dans le dictionnaire.

S

Permettre de construire un critère de sélection sur les zones concernant les commandes précédentes

Le calcul de ces zones est maintenant effectué lors de la recherche, cela peut engendrer des temps de réponse plus longs avant l'ouverture de la fenêtre de préparation de la visualisation (barre de progression).

Par contre, le temps de préparation sera dans ce cas réduit (déplacement du calcul de la préparation à la recherche).

Ces notes commençant par S fonctionnent de la même manière que celles décrites dans le #VI.

Code zone | Colonne correspondante | Description
temp_visu.tv_pv_1 | pv_1 | Prix de vente de la précédente commande dans l'unité de prix de la ligne de commande
temp_visu.tv_date_pv_1 | date_pv_1 | Date de livraison de la précédente commande
temp_visu.tv_pv_2 | pv_2 | Prix de vente de l'avant-dernière commande dans l'unité de prix de la ligne de commande
temp_visu.tv_pv_3 | pv_3 | Prix de vente de l'avant-avant-dernière commande dans l'unité de prix de la ligne de commande
temp_visu.tv_qte_1 | qte_1 | Quantité commandée de la précédente commande dans l'unité de prix de la ligne de commande
temp_visu.tv_qte_2 | qte_2 | Quantité commandée de l'avant-dernière commande dans l'unité de prix de la ligne de commande
temp_visu.tv_qte_3 | qte_3 | Quantité commandée de l'avant-avant-dernière commande dans l'unité de prix de la ligne de commande

Exemple de paramétrage d'un complément de sélection

S and temp_visu.tv_pv_1 != (select cde2.lc_prx from cde2

S where cde2.lc_soc = "001"

S and cde2.lc_num = temp_visu.tv_num_cde

S and cde2.lc_lig = temp_visu.tv_lig_cde)

SEP_VISU_TYPE_F_CHAR

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

SOLDE_AUTO_AVEC_MES

Affichage des messages des anomalies rencontrées lors du solde automatique des lignes de commande (O/N, N par défaut)

Voir option Osa

_SQL_REAFFECT_NVE

21 à 60 Supplément sql pour recherche des mouvements au DESOLDE de commande

_SQL_REAFFECT_VEN

Transfert automatique des stocks restant au solde/désolde de commande

Nécessite l'option -Ors

21 à 60 Supplément sql pour recherche des mouvements au SOLDE de commande

SSC_CODE_SITE

21,23 Code site à prendre en compte par la génération de commande, si celui-ci n'est pas renseigné par le programme appelant.

Met à jour la zone edi_cde.edc_c1

Tableau de bord du multisite

Cette note est prioritaire sur celle du #CF SSC. Génér.cde

SSC_DELAI_OBLIGATOIRE

Le délai est-il obligatoire (O/N, N par défaut)

Cette note est prioritaire sur celle du #CF SSC.

SSC_LCO_DEVIS_PRIO

21,23 Code de la LCO définissant la priorité du sous-devis (LCO GDF par défaut)

Dans la recherche du prix de la ligne de commande par la variante de devis, il est désormais possible de forcer la variante utilisée par un LCO sur l'entité du devis. Le prix de la ligne de commande sera celui de la variante forcée.

LCO A1[16] de la variante prioritaire doit être égal à O (Oui).

Cette note est prioritaire sur celle du #CF SSC. Génér.cde

SSC_PRX_DEV_TARIF_0

21 Récupération du prix sur le devis associé au produit si la recherche de tarif ne retourne pas de valeur (O/N, N par défaut)

Cette note est prioritaire sur celle du #CF SSC. Génér.cde

STATUT_CODE_BLOCAGE

Permettre de voir les codes blocages dans un statut particulier

21 Codes blocages à voir

T Tous (par défaut)

B Statut Bloqué

N statut Non bloqué

22,23 Mode de rafraîchissement après l'action Blocage/Déblocage (Touche F39)

O Rafraîchissement de la ligne uniquement.

N Rafraîchissement de toute la visualisation.

_SUP_REQ_1ERE_CDF

21,60 Complément de requête sur les tables cdf1 et cdf2 à appliquer sur la recherche de la première ligne d'achat affectée à la ligne de commande client

Ce complément peut aussi contenir l'instruction order by pour spécifier un ordre de recherche.

_SUP_REQ_CCF_DATE_PL

21,60 Complément de sélection sur la table cde_cad_fab concernant la date de planification - Voir _SUP_REQ_NB_CCF_

_SUP_REQ_CCF_QTEFAB

21,60 Complément de sélection sur la table cde_cad_fab concernant la somme des quantités fabriquées - Voir _SUP_REQ_NB_CCF_

_SUP_REQ_CCF_QTELAN

21,60 Complément de sélection sur la table cde_cad_fab concernant la somme des quantités lancées - Voir _SUP_REQ_NB_CCF_

_SUP_REQ_CDE1_CA_C

21,60 Complément de sélection sur la table cde1 pour le calcul du chiffre d'affaire du contrat (recherche des sommes des factures associées au contrat courant)

_SUP_REQ_CDE2_CA_C

21,60 Complément de sélection sur la table cde2 pour le calcul du chiffre d'affaire du contrat (recherche des sommes des factures associées au contrat courant)

_SUP_REQ_CERTIF_DE

21,60 Complément de requête sur la table fle_dec pour la certification

Voir les notes OUTIL_LCO_FOR_ACT et OUTIL_LCO_FOR_DES

_SUP_REQ_CRI_F7_

Voir le détail de cette note dans les généralités

_SUP_REQ_DATE_MAG

21,60 Complément de requête sur les champs de la table fab_1_etat

Ce complément de recherche ne sert que pour la recherche de la zone date_mag.

_SUP_REQ_EC_TYC

21,60 Complément de requête sur la zone ec_tyc

Permet de réaliser des visus de CD2 / FBI de la même façon que les visus de CDA / CD1

Pour cela, le morceau de requête ec_tyc = "CD1" (qui était en dur dans la requête) est remplacé par le complément de requête paramétré sur cette note.

Le complément de requête concerne les tables cde1 et cde2.

Par défaut, le complément de requête est : and ec_tyc = "CD1" pour conserver le même mode de fonctionnement qu'auparavant en l'absence de paramétrage.

Voir les noms de zones se terminant par _cda.

Exemples

_SUP_REQ_EC_TYC and ec_tyc = "CD1" quand on est en visu de CDA

_SUP_REQ_EC_TYC and ec_tyc = "FBI" quand on est en visu de CD2

Voir aussi la note RUN_VISU_TYPE_RATT

_SUP_REQ_ES_CAD_FAB

21,60 Complément de requête des entrées de stock des cadencements de fabrication (table stk0)

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

_SUP_REQ_FAB_1_ETAT

21,60 Complément de sélection sur la table fab_1_etat

_SUP_REQ_FAC1_CA_C

21,60 Complément de sélection sur la table fac1 pour le calcul du chiffre d'affaire du contrat (recherche des sommes des factures associées au contrat courant)

_SUP_REQ_FLE_OPE_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FLE_TRA_RCP

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_SUP_REQ_FRAIS_TECH

21,60 Supplément de requête sur la table cde2 pour le calcul des frais techniques

_SUP_REQ_GROUPAGE

21,60 Complément de sélection (Table groupage_bl)

Ex : and gb_no_groupage matches "04*"

_SUP_REQ_NB_CCF_

Cadencements de fabrication. Voir les notes commençant par _SUP_REQ_CCF

17,18 Numéro du complément de sélection

21,60 Complément de sélection sur la table cde_cad_fab concernant le nombre de cadencements.

_SUP_REQ_PAR02_CA_C

21,60 Complément de sélection sur la table par02 pour le calcul du chiffre d'affaire du contrat (recherche des sommes des factures associées au contrat courant)

_SUP_REQ_PLAGE_ENT

Complément de requête sur la table stk0 pour les mouvements d'entrée

_SUP_REQ_PLAGE_FAB2

Complément de requête sur la table fab2 utilisé pour le calcul de la somme des temps de production

_SUP_REQ_PLAGE_SOR

Complément de requête sur la table stk0 pour les mouvements de sortie

_SUP_REQ_RAL_CDE8

21,60 Complément de sélection sur la table cde8 pour calculer le reste à livrer des ensembles

Exemple

and li_qua != "SAP"

_SUP_REQ_REC_CDE8

21,60 Complément de requête sur cde8 pour l'édition du récapitulatif cadencement

_SUP_REQ_REF_OUTILS

Supplément de requête sur les tables amal et mat pour la recherche des références de l'outil

_SUP_REQ_SS_CAD_FAB

21,60 Complément de requête des sorties de stock des cadencements de fabrication (table stk0) <>

Ce paramétrage a été créé dans le cadre de la gestion des commandes de fabrication par référence, mais il est utilisable indépendamment.

_SUP_REQ_STK0_CTR

21,60 Complément de sélection sur la table stk0 pour la recherche des stocks associés au contrat courant (nécessite l'option -Osc et au moins une colonne de stock contrat paramétré)

_SUP_REQ_STK0_DATE

21 à 60 Complément de requête SQL pour la recherche de la date de dernière entrée en magasin sur stk0.

Exemple and s0_typ = "FR"

_SUP_REQ_STK0_PLAGE

Complément de requête sur la table stk0 pour la sélection des mouvements de stock dans une plage de dates

_SUP_REQ_TEMPS_FAB1

21,60 Complément de sélection pour le calcul de la somme des temps prévus de l'ordre de fabrication

_SUP_SQL_SOMME_

16,20 Numéro de complément SQL (indiqué par NNN dans la note _VAR_)

21,60 Complément de requête à associer à un calcul de somme.

Les tables accessibles sont (selon la méthode de calcul AAA définie dans la note _VAR_) :

fle_mat/fle_gam

fle_ope/fle_gam

fle_str/fle_gam

Cliquez ici pour afficher / masquer des exemples.

_SUP_STK0_VISU_LL

21,60 Complément de sélection sur stk0 dans la recherche des stocks par lot lieux

Exemple : and stk0.s0_rgt1 != "XXX"

TEST_IC_PROD_LIG_

Sélection par TSC des produits commandés

18,20 Code du TSC recherché sur les produits

21,60 Complément de sélection sur table info_c

_TIT_INDIC*

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_ENTETE_

TITRE_BLOC_

TITRE_ENTETE_DATE

TITRE_ENTETE_EC1

TITRE_ENTETE_NUMERO

TITRE_ENTETE_LIBELLE

TITRE_ENTETE_TYPE

TITRE_BLOC_ENTETE

TITRE_BLOC_LIGNE

TITRE_ENTETE_LIGNE

21,60 Changer les libellés de certains champs afin d'adapter l'écran aux commandes, appels d'offre, ...

Si ces paramètres sont absents ou pas renseignés, une valeur par défaut est utilisée.

Libellé de champs date

Libellé du champ Site de production - Tableau de bord du multisite

Libellé de champs numéro

Libellé de champs libellé

Libellé de champs type

Libellé de bloc entête

Libellé de bloc ligne

Libellé de champs ligne

TITRE_VISU_TYPE_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

TPS_AVANT_RAFRAICHIR

21,25 Temps d'inactivité avant rafraîchissement

0 pas de rafraîchissement

Valeur minimum : 10 secondes

TYC_EQUIVALENCE_CD1

Paramétrage du TYC équivalent au TYC CD1

21 à 23 Code de paramètre (par défaut : CD1)

TYC_EQUIVALENCE_CDA

Paramétrage du TYC équivalent au TYC CDA

21 à 23 Code de paramètre (par défaut : CDA)

TYP_MVT_STK_SOLD_ENT

21, 23 Type de mouvement d'entrée historisation outillage pour le solde de fabrication

TYP_MVT_STK_SOLD_SOR

21, 23 Type de mouvement de sortie historisation outillage pour le solde de fabrication

TYPE_NOTE_BLO_RC

21,23 Type de note de revue de contrat

Si cette note est renseignée et si on solde la fabrication/réception et si la quantité du cadencement est supérieure à la quantité fabriqué/réceptionnée totale, un code blocage automatique (039) sera positionné sur la revue de contrat.

TYPE_NOTE_LIGNE1

21,26 Type de la note lue pour afficher la colonne note_ligne1

Il s'agit de la première ligne de note sur la commande.

TYPE_NOTE_LIGNE_CAD

21,23 Type de note à afficher. Exemple : LIV

Nécessite l'option -Oli

TYPE_NOTE_LIGNE_CLI

21 à 23 Type de note à récupérer sur l'adresse de livraison

TYPE_NOTES_CLIENT

21, 23 Type de notes client

Voir la note QUALIFICATIF_APPEL

TYPE_NOTES_INTERNE

21, 23 Type de notes interne

Voir la note QUALIFICATIF_APPEL

TYPE_TOTAL_FACTURES

21 Type d'affichage du total des factures dans le CONTROL-F

H HT

T TTC (Valeur par défaut)

UNITE_SURFACE_FEFCO

21,23 Unité de calcul de la surface du FEFCO (Code dimension SUR)

M2 : surface unitaire calculée en mètre carré

MM2 : surface unitaire calculée en millimètre carré (valeur par défaut)

Utilisé pour la mise à jour du poids de la ligne de commande par la saisie des besoins (#CF SMC A2[3] et A2[5])

_VAR_

Permettre de paramétrer des colonnes dont la valeur est la somme des matières (fle_mat), des opérations (fle_ope) et/ou de la sous-traitance (fle_str, fixe et/ou variable) du sous-devis associé à la ligne de commande en cours de visualisation.

6,10 Code de la variable calculée. Voir aide en ligne du paramètre #VI

11,16 SOMME_

17,60 Méthode de calcul de la somme sous la forme :AAA_NNN où :

AAA est la méthode de calcul :

TOTMATDEV : Somme des totaux des formules matières (fm_total) du devis associé à la ligne de commande

TOTOPEDEV : Somme des totaux des formules opérations (fo_total) du devis associé à la ligne de commande

TOTSTRFIXDEV : Somme des totaux des formules sous-traitance fixe (fs_total_f) du devis associé à la ligne de commande

TOTSTRVARDEV : Somme des totaux des formules sous-traitance variable (fs_total_v) du devis associé à la ligne de commande

NNN est le numéro de complément SQL à prendre en compte (paramétrage optionnel, voir la note _SUP_SQL_SOMME_)

_VAR_INDIC_

Réactualisation du récapitulatif des coûts dans l'environnement Devis multi-métiers

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

VISU_PLANIFICATION

Active la touche F26 qui lance l'état de fabrication (f_visu_fab_1_etat)

21,26 Type et code du paramètre de lancement du programme de visualisation sur un point de commande (remplace VISU_STK_DEPUIS_VS).

Exemples

#FBSDP (dp0)

#VIADO (v_fab1)

#EDEAT (v_eat)

Voir option Ost

VISU_STK_DEPUIS_VS

Touche F9 à partir de la visu simplifiée (F37)

21,26 Type et code du paramètre de lancement de la visualisation des stocks

27,44 Nom de la colonne à utiliser dans le critère de recherche :

s0_prod (par défaut)

s0_cli

s0_cde

Voir option Ost

ZONE_LL_STOCK_NUM_

21,41 Restriction des stocks

Liste des ordres de tris disponibles

Voir les notes commençant par O

01 | c_cli (tri sur code client)
02 | c_rep (tri sur code représentant)
03 | d_cde (tri sur date de commande)
04 | n_cde (tri sur numéro de commande)
05 | t_cde (tri sur type de commande)
06 | c_art (tri sur code article)
07 | c_fam (tri sur code famille)
08 | c_sfm (tri sur code sous-famille)
09 | d_rep (tri sur date de livraison proposée ou sur zone historique date 1)
10 | z_par (tri sur code zone paramétrable)
11 | n_lig (tri sur numéro ligne de commande)
12 | s_aff (tri sur code suivi affaire)
13 | t_art (tri sur type article)
14 | m_reap (tri sur code réapprovisionnement)
15 | c_foucli (tri sur code fournisseur)
16 | c_cligr (tri sur code client groupe)
17 | c_cat (tri sur code catégorie client)
18 | s_geo (tri sur code geographique)
19 | s_act (tri sur code secteur activité)
20 | c_orig (tri sur code origine)
21 | c_ape (tri sur code APE)
22 | c_prod (tri sur zone libre)
23 | s_rep (tri sur semaine de livraison)
24 | m_rep (tri sur mois de livraison)
25 | h_dep (tri sur code département)
26 | n_dos (tri sur numéro dossier rattachement)
27 | n_sdos (tri sur numéro ligne dossier rattachement)
28 | h_z3 (tri sur zone historique numérique 3)
29 | h_z4 (tri sur zone historique numérique 4)
30 | t_marge (tri sur marge)
31 | h_z11 (tri sur zone historique numérique 11)
32 | z_cl_zpar (tri sur zone paramétrée 1)
33 | t_lie (tri sur type liaison)
34 | d_fab (tri sur date de fin de fabrication)
35 | z_lcp3 (tri sur code zone paramétrable 3)
36 | c_cli_liv (tri sur client)
37 | c_adr_liv (tri sur adresse de livraison)
38 | c_pos_liv (tri sur code postal de livraison)
39 | n_vil_liv (tri sur ville de livraison)
40 | c_pay_liv (tri sur pays de livraison)
41 | c_rep_ent (tri sur code représentant entête)
42 | c_rep_cli (tri sur code représentant commande)
43 | c_ada (tri sur code adresse réception)
44 | c_adl (tri sur code adresse livraison)
45 | c_adf (tri sur code adresse facturation)
46 | d_dep (tri sur date de départ au plus tard)
47 | c_sfm_comcar (tri sur code sous-famille)
48 | c_dev (tri sur code devise)
49 | c_lieu_rgt1 (tri sur code lieu de rangement 1 - Fenêtre Revue de contrat)
50 | c_nc_rgt1 (tri sur code lieu de rangement 1)
51 | c_tournee_liv (tri sur code tournée de livraison)
52 | c_delcli_m (tri sur date de livraison souhaitée - yyyymm) - Le tri se fait sur l'année et le mois.
53 | c_delrep_m (tri sur date de livraison proposée - yyyymm)
54 | c_deldep_m (tri sur date de départ au plus tard - yyyymm)
55 | c_delfab_m (tri sur date de fin de fabrication - yyyymm)
56 | c_delcli_s (tri sur date de livraison souhaitée - yyyyww) - Le tri se fait sur l'année et la semaine.
57 | c_delrep_s (tri sur date de livraison proposée - yyyyww)
58 | c_deldep_s (tri sur date de départ au plus tard - yyyyww)
59 | c_delfab_s (tri sur date de fin de fabrication - yyyyww)
60 | c_dat_cadense (tri sur date de livraison)
61 | c_ec_ref (tri sur référence en-tête de commande)
62 | semaine_commande (par semaine de la date de commande)
63 | mois_commande (par mois de la date de commande)
64 | Code statistique 1
65 | Code statistique 2
66 | Code statistique 3
67 | Code statistique 4
68 | Tri et rupture sur la date de départ de la ligne de cadencement de livraison (Colonne li_date_depart de la table cde8
69 | Tri sur le numéro de ligne de cadencement (colonne li_lig_cad).
70 | Libellé du produit fini (mp_des)
71 | Catégorie du client final (cli.cl_cat de cde1.ec_cli_final)
72 | Référence client de l'article (lib_par1, le_lib_par1)
73 | li_date_dem (Cadencement de livraison - Date demandée par le client)
74 | li_datliv (Cadencement de livraison - Date de livraison)

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Les zones avec possibilité de totalisation (O/N) sont affichées en bleu.

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Package Tiers

Les noms de zones de la fiche client final sont accessibles en préfixant les zones cl_ avec f_

Par exemple, le nom du client final sera f_cl_nom.

Package Adresses secondaires

Les noms de zones de la fiche adresse secondaire du client final sont accessibles en préfixant les zones c2_ avec f_

Par exemple, le code postal du client final sera f_c2_codp.

Package Cadencements de Fabrication - Autres zones

Package Définition générale du devis (fle_2)

Les noms de zones peuvent être préfixés ccf_ pour les cadencements de fabrication (sans les cumuls). Autres zones

Package Entités de Devis (fle_imp)

Les noms de zones peuvent être préfixés ccf_ pour les cadencements de fabrication (sans les cumuls). Autres zones

Les noms de zones peuvent être préfixées avec certif_ dans le cadre du certificat de conformité. Autres zones

Package Décomposition de la feuille (fle_dec)

Les noms de zones peuvent être préfixées avec certif_ dans le cadre du certificat de conformité. Autres zones

Packages des commandes d'achats entête (cdf1) et lignes (cdf2)

Entête commande (y compris pour les commandes de rattachement et les commandes de marché)

Ligne commande (y compris pour les commandes de rattachement et les commandes de marché)

Commandes fournisseurs

Nomenclature ligne commande

Blocages

Cadencements de livraisons de la ligne de commande et de la ligne de nomenclature

Fiche article qualité carton

Fiche article composition technique carton

Historique

Fiche devis reliure

Dossier de rattachement

Sommes des quantités pour toutes les lignes ayant le même code produit et le même dossier de rattachement que la ligne en cours

FEFCO - ECMA

Autres

Blocage laboratoire

Montants dans la devise de la société

Montants dans la devise EURO

Montants dans la devise de la commande

Fiche Tiers livraison

Type de visualisation = E (Enregistrés) - SPECIFIQUE Consulter VSW

Type de visualisation = F (Facturés) - SPECIFIQUE Consulter VSW

Matière au PUMP - SPECIFIQUE Consulter VSW

Ligne de commande rattachée

Groupages BL

Récapitulatif (KP_recap_tot)

Etat de fabrication

Zones pour les cadencements de fabrication

Zones du certificat de conformité

Package Commandes Papeterie (Entête)

Package Commandes Papeterie (Lignes)

Zones permettant de récupérer les codes clients utilisés par Efficial

Dossier de fabrication - Nomenclatures

Entête commande

Pour les zones des commandes de rattachement, remplacer ec_ par ec_rat_

Pour les zones des commandes de marché, remplacer ec_ par ec_marche_

Informations des commandes de type contrat

Package de l'entête de la commande contrat associée à la ligne de commande actuelle

ajouter les préfixes ctr_ec_, des_ctr_ec_, libc_ctr_ec_, libl_ctr_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

Package de l'entête de la commande contrat associée à la ligne de commande de rattachement actuelle

ajouter les préfixes ctr_rat_ec_, des_ctr_rat_ec_, libc_ctr_rat_ec_, libl_ctr_rat_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

Package de l'entête de la commande contrat associée à la ligne de commande de marché actuelle

ajouter les préfixes ctr_marche_ec_, des_ctr_marche_ec_, libc_ctr_marche_ec_, libl_ctr_marche_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court zone paramétrable
libl_ec_c1 | Libellé long zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
ville_ec_ada | Ville adresse réception
nom_ec_ada | Nom client adresse réception
ec_adf | Code adresse facturation
ville_ec_adf | Ville adresse facturation
ec_adl | Code adresse livraison
ville_ec_adl | Ville adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte dans la devise de la société
ec_acc_euro | Acompte dans la devise EURO
ec_acc_dev | Acompte dans la devise de la commande
ec_pnt | Port non taxable dans la devise de la société
ec_pnt_euro | Port non taxable dans la devise EURO
ec_pnt_dev | Port non taxable dans la devise de la commande
ec_pht | Port taxable dans la devise de la société
ec_pht_euro | Port taxable dans la devise EURO
ec_pht_dev | Port taxable dans la devise de la commande
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accusé de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facturé
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande
ec_date_deb_val | Date de début de validité du contrat (option -Osc obligatoire)
ec_date_fin_val | Date de fin de validité du contrat (option -Osc obligatoire)
ec_cli_final nom_ec_cli_final ville_ec_cli_final_adr | Code du client final de la commande Nom du client final de la commande Ville correspondante à l'adresse du client final de la commande (principale ou secondaire)
ec_tx_commission | Taux de commission de l'adresse de livraison de l'entête de commande

Ligne commande

Pour les zones des commandes de rattachement, remplacer lc_ par lc_rat_.

Pour les zones des commandes de marché, remplacer lc_ par lc_marche_.

Informations des commandes de type contrat

Package de la ligne de la commande contrat associée à la ligne de commande actuelle

ajouter les préfixes ctr_lc_, des_ctr_lc_, libc_ctr_lc_, libl_ctr_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

Package de la ligne de la commande contrat associée à la ligne de commande de rattachement actuelle

ajouter les préfixes ctr_rat_lc_, des_ctr_rat_lc_, libc_ctr_rat_lc_, libl_ctr_rat_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

Package de la ligne de la commande contrat associée à la ligne de commande de marché actuelle

ajouter les préfixes ctr_marche_lc_, des_ctr_marche_lc_, libc_ctr_marche_lc_, libl_ctr_marche_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

lc_soc

Code société

lc_num

Numéro commande

lc_lig

Numéro ligne commande

lc_prod

Code article

lib_lc_prod

Désignation article (Fiche article)

lc_fam

Code famille

libc_lc_fam

Libellé court code famille

libl_lc_fam

Libellé long code famille

lc_sfm

Code sous-famille

libc_lc_sfm

Libellé court code sous-famille

libl_lc_sfm

Libellé long code sous-famille

type_sfm_lc_sfm

Type de sous famille de la sous famille de la ligne de commande

lc_lib

Désignation article (Ligne commande)

lc_repr

Code représentant

libc_lc_repr

Libellé court code représentant

libl_lc_repr

Libellé long code représentant

lc_com

Taux commission représentant

lc_long

Longueur

lc_larg

Largeur

lc_dev

Numéro devis

lc_sdev

Numéro sous-devis

lc_cderat

Numéro dossier rattachement

lc_lcderat

Numéro ligne dossier rattachement

lc_qtecde

Quantité commandée

lc_qtelan

Quantité lancée

lc_qtefab

Quantité fabriquée

lc_qteliv

Quantité livrée facturable

lc_qteliv_reelle

Quantité réellement livré

lc_qteafa

Quantité à facturer

lc_qtefac

Quantité facturée

lc_solde

Ligne commande soldée

lc_prx

Prix unitaire vente dans la devise de la société

lc_prx_euro

Prix unitaire vente dans la devise EURO

lc_prx_dev

Prix unitaire vente dans la devise de la commande

lc_rem

Remise ligne (en %)

lc_p1

Code zone paramétrable 1

libc_lc_p1

Libellé court zone paramétrable 1

libl_lc_p1

Libellé long zone paramétrable 1

lc_p2

Code zone paramétrable 2

libc_lc_p2

Libellé court zone paramétrable 2

libl_lc_p2

Libellé long zone paramétrable 2

lc_p3

Code zone paramétrable 3

lib_lc_p3

Libellé zone paramétrable 3

lc_unvent

Code unité vente

libc_lc_unvent

Libellé court code unité vente

libl_lc_unvent

Libellé long code unité vente

zc1_lc_unvent

Valeur 1 code unité vente

lc_tva

Code TVA

libc_lc_tva

Libellé court code TVA

libl_lc_tva

Libellé long code TVA

zc1_lc_tva

Valeur 1 code TVA

lc_poids

Poids ligne commande

lc_delcli

Date de livraison souhaitée

lc_heure_cli_tot

Heure de début de la livraison souhaitée

lc_heure_cli_tard

Heure de fin de la livraison souhaitée

lc_delrep

Date de livraison proposée

lc_heure_rep_tot

Heure de début de la livraison proposée

lc_heure_rep_tard

Heure de fin de la livraison proposée

lc_deldep

Date de départ au plus tard

lc_heure_dep_tot

Heure de début de départ au plus tard

lc_heure_dep_tard

Heure de fin de départ au plus tard

lc_deldep_au_plus_tot

Date de départ au plus tôt. Ajout de la valeur 1 du paramètre <QAL><lc_qualif_appel> à la date de départ au plus tard (lc_deldep)

lc_delfab

Date de fin de fabrication

lc_heure_fab_tot

Heure de début de fin de fabrication

lc_heure_fab_tard

Heure de fin de fin de fabrication

lc_delrea

Date de réalisation (Non utilisée)

lc_delrea_aass

Semaine de réalisation (Format 9724)

lc_colis

Nombre colis

lc_prxcli

Prix client dans la devise de la société

lc_date_gener

Date de génération (pour les commandes générables)

lc_date_regener

Date de régénération (pour les commandes générables)

lc_prxcli_euro

Prix client dans la devise EURO

lc_prxcli_dev

Prix client dans la devise de la commande

lc_rstfac

Reste des factures à éditer

lc_rstbl

Reste des BL à éditer

lc_nummvt

Numéro mouvement de stock 1

lc_priorite

Niveau priorité ligne commande

libc_lc_priorite

Libellé court niveau priorité ligne commande

libl_lc_priorite

Libellé long niveau priorité ligne commande

lc_rstafa

Reste à facturer

lc_rstfab

Reste à fabriquer

lc_adl

Code adresse livraison

ville_lc_adl

codp_lc_adl

Ville de l'adresse de livraison

Code postal de l'adresse de livraison

lc_haut

Hauteur

lc_afacturer

Ligne commande à facturer

lc_nummvt2

Numéro mouvement de stock 2

lc_par_tyc

Code paramètre type de commande

libc_lc_par_tyc

Libellé court code paramètre type de commande

libl_lc_par_tyc

Libellé long code paramètre type de commande

lc_lot

Numéro de lot de la ligne de commande

lc_qualif_appel

Qualification de l'appel de livraison

libc_lc_qualif_appel

Libellé court qualification de l'appel de livraison

libl_lc_qualif_appel

Libellé long qualification de l'appel de livraison

lc_facrat

Numéro facture rattachement

lc_lfacrat

Numéro ligne facture rattachement

lc_unvent_au

Code unité vente au

libc_lc_unvent_au

Libellé court code unité vente au

libl_lc_unvent_au

Libellé long code unité vente au

zc1_lc_unvent_au

Valeur 1 code unité vente au

lc_prx_au_plus

Prix unitaire vente au plus dans la devise de la société

lc_prx_plus_euro

Prix unitaire vente au plus dans la devise EURO

lc_prx_plus_dev

Prix unitaire vente au plus dans la devise de la commande

lc_prx_au_moins

Prix unitaire vente au moins dans la devise de la société

lc_prx_moins_euro

Prix unitaire vente au moins dans la devise EURO

lc_prx_moins_dev

Prix unitaire vente au moins dans la devise de la commande

lc_marge

Pourcentage marge

lc_prx_revient

Prix unitaire revient dans la devise de la société

lc_prx_rvt_euro

Prix unitaire revient dans la devise EURO

lc_prx_rvt_dev

Prix unitaire revient dans la devise de la commande

lc_tolerance_liv

Code tolérance livraison

libc_lc_tolerance_liv

Libellé court tolérance livraison

libl_lc_tolerance_liv

Libellé long tolérance livraison

zc1_lc_tolerance_liv

zc2_lc_tolerance_liv

min_lc_tolerance_liv

max_lc_tolerance_liv

lib_lc_tolerance_liv

Ces zones sont expliquées dans le package des lignes de commandes clients.

lc_prx_rvt_reel

Prix unitaire revient réel dans la devise de la société

lc_prx_rvt_r_euro

Prix unitaire revient réel dans la devise EURO

lc_date_solde

Date de solde de la ligne de commande

lc_lieu_rgt1

Code lieu de rangement 1. Fenêtre Revue de contrat

libc_lc_lieu_rgt1

Libellé court code lieu de rangement 1

libl_lc_lieu_rgt1

Libellé long code lieu de rangement 1

lc_annu

Ligne commande annulée

lc_delcli_aamm

Mois de livraison client prévu (au format AAAAMM)

lc_delrep_aamm

Mois de livraison répondu prévu (au format AAAAMM)

lc_deldep_aamm

Mois date départ prévu (au format AAAAMM)

lc_delfab_aamm

Mois date fabrication prévu (au format AAAAMM)

lc_delcli_aass

Semaine de livraison client prévu (au format AAAASS)

lc_delrep_aass

Semaine de livraison répondu prévu (au format AAAASS)

lc_deldep_aass

Semaine date départ prévu (au format AAAASS)

lc_delfab_aass

Semaine date fabrication prévu (au format AAAASS)

lc_qte_en_retour

Quantité de retour client

qteliv_cda

qtefac_cda

qtecde_cda

Somme des quantités

livrées

facturées

commandées

d'une ligne de commande XXX rattachée à une commande ZZZ.

Ce rattachement s'effectue sur le numéro de commande ZZZ et sur le code article.

XXX et ZZZ peuvent prendre les valeurs suivantes :

XXX | ZZZ
CD1 | CDA
FBI | CD2

Le fonctionnement initial concernait les CD1 rattachées aux CDA.

Il a été étendu aux FBI rattachées aux CD2.

Cependant, les noms de zones sont restés inchangés et se terminent par _cda.

Voir la note _SUP_REQ_EC_TYC qui permet de définir le complément de requête sur la zone ec_tyc. En absence de cette note, c'est le TYC CD1 qui est pris en compte par défaut.

lc_qte_contrat

Quantité actuellement commandée pour la ligne de contrat

(somme des quantités commandées des lignes associées au contrat et produit courant)

(option -Osc obligatoire)

lc_cs1

libc_lc_cs1, libl_lc_cs1

Code statistique 1

Libellés court et long

lc_cs2

libc_lc_cs2, libl_lc_cs2

Code statistique 2

Libellés court et long

lc_cs3

libc_lc_cs3, libl_lc_cs3

Code statistique 3

Libellés court et long

lc_cs4

libc_lc_cs4, libl_lc_cs4

Code statistique 4

Libellés court et long

lc_sbi

indicateur Self Billing Invoice de la ligne de commande

lc_bareme

libc_lc_bareme

libl_lc_bareme

Code barème

Libellé court du code barème

Libellé long du code barème

lc_gen_dos_fab

Code génération du dossier de fabrication

lc_motif_mod_date

libc_lc_motif_mod_date

libl_lc_motif_mod_date

Code motif de modification de date de la revue de contrat

Libellé court

Libellé long

lc_tx_commission

Taux de commission de l'adresse de livraison de la ligne de commande

lc_alerte

Alerte de la ligne de commande (N/B/D)

lc_pre_solde

Pré-solde de la ligne de commande (N/O)

lc_adf

ville_lc_adf

codp_lc_adf

Code adresse de facturation de la ligne.

Ville de l'adresse de facturation de la ligne

Code postal de l'adresse de facturation de la ligne

lc_num_contrat

Numéro de contrat

lc_lig_contrat

Ligne de contrat

Commandes fournisseurs

lf_arc | Code AR
lf_date_arc | Date de l'AR
lf_delai_demande | Délai demandé
lf_qte_init | Quantité initiale de la commande
lf_prix_init | Prix initial de la commande dans la devise société
lf_prix_init_dev | Prix initial de la commande dans la devise de la commande
lf_prix_init_euro | Prix initial de la commande dans la devise EURO
lf_qteliv | Quantité Réceptionnée

Nomenclature ligne commande

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Numéro ligne commande
nc_seq | Numéro séquence
nc_prod | Code article
lib_nc_prod | Désignation article (Fiche article)
nc_coef_nom | Coefficient nomenclature
nc_qtecde | Quantité commandée nomenclature
nc_qteliv | Quantité livrée nomenclature
nc_qteliv_non_val | Quantité livrée non validée nomenclature
nc_qteliv_val | Quantité livrée validée nomenclature
nc_qtefab | Quantité fabriquée
nc_rgt1 | Code lieu rangement 1
libc_nc_rgt1 | Libellé court code lieu rangement 1
libl_nc_rgt1 | Libellé long code lieu rangement 1
nc_rgt2 | Code lieu rangement 2
nc_rgt3 | Code lieu rangement 3
nc_nummvt | Numéro mouvement de stock
nc_solde | Ligne nomenclature soldée
nc_reap | Code réapprovisionnement
libc_nc_reap | Libellé court code réapprovisionnement
libl_nc_reap | Libellé long code réapprovisionnement
nc_qte_contrat | Quantité actuellement commandée pour la ligne de nomenclature contrat (somme des quantités commandées des lignes de nomenclature associées au contrat et produit courant) (option -Osc obligatoire)
nc_alerte | Alerte de la ligne de nomenclature (N/B/D)
nc_pre_solde | Pré-solde de la ligne de nomenclature (N/O)
nc_numfbi | Numéro de commande de fabrication interne (FBI)
nc_ligfbi | Numéro de ligne de commande de fabrication interne (FBI)

Blocages

code_blocage | Code blocage de la ligne de commande
libc_blocage | Libellé court du code blocage (BLO) - Voir les notes LIBC_BLOCAGE et 3 suivantes.
libl_blocage | Libellé long du code blocage (BLO) - Voir les notes LIBC_BLOCAGE et 3 suivantes.
code_statut_blocage | Code de statut/déblocage BLO Bloqué DEB Débloqué ___ Motif de déblocage
libc_statut_blocage | Libellé court du code de déblocage (MDB)
libl_statut_blocage | Libellé long du code de déblocage (MDB)
val_statut_blocage | Statut actuel du blocage 1 Bloqué 0 Débloqué Valeur négatives : Débloqué avec motif

Remarque : Une ligne de commande peut contenir plusieurs codes blocages. Ceci entraîne le fait que ces colonnes ne sont pas compatibles avec l'affichage dans les zones de détail (Notes de type D).

Cadencements de livraison de la ligne de commande et de la ligne de nomenclature (cde8)

Enregistrements faisant directement référence à la ligne de commande (liés à la table cde2, avec li_seq = 0) : les noms de colonnes commencent par li_

Enregistrements faisant référence aux lignes de nomenclature (liés à la table cde4, avec li_seq = nc_seq) : les noms de colonnes commencent par li4_

li_soc | Code société
li_num | Numéro de commande
li_lig | Numéro de ligne de commande
li_seq | Numéro de séquence
li_lig_cad | Numéro de ligne de cadencement
li_datliv | Date de livraison
li_adr | Code de l'adresse du point de livraison
li_nom | Nom du client du point de livraison
li_adr1 | Première ligne d'adresse du point de livraison
li_adr2 | Seconde ligne d'adresse du point de livraison
li_cpos | Code postal du point de livraison
li_ville | Ville du point de livraison
li_pays | Code du pays du point de livraison
libl_li_pays | Libellé long du pays
libc_li_pays | Libellé court du pays
li_qteliv v_li_qtecde xx_ li_qteliv xx_v_li_qtecde | Quantité à livrer Valeur de la quantité cadencée xx_ li_qteliv = 0 si QAL A2[20] = N sinon li_qte_liv xx_v_li_qtecde = 0 si QAL A2[20] = N sinon v_li_qtecde
li_transp | Code du transporteur utilisé
nom_li_transp | Nom du transporteur
li_poids | Poids de la livraison
li_type | Type de livraison
poids_cde_li | Poids livré (li_poids * li_qteliv)
poids_tot_li | Poids total de la ligne de cadencement
li_date_dem | Date demandée par le client
li_type_liv | Type de livraison
li_rgt | Lieu de rangement
libl_li_rgt | Libellé long du lieu de rangement
libc_li_rgt | Libellé court du lieu de rangement
li_qua | Qualificatif de l'appel
libl_li_qua | Libellé long du qualificatif
libc_li_qua | Libellé court du qualificatif
li_ref_cli | Référence de l'appel client
li_date_appel | date de l'appel client
li_qte_liv_reel v_li_qteliv | Quantité livrée réelle Valeur de la quantité livrée
li_solde | Solde de livraison (O/N)
li_date_solde | date du solde
li_adr_fac | Code adresse de livraison
li_valid_adv | Code validation administration des ventes
li_valid_prod | Code validation production
li_valid_log | Code validation l0gistique
li_conf | Appel confirmation
li_nom_corres | Nom du correspondant
li_tco_corres | Titre du correspondant
libl_li_tco_correc | Libellé long du titre du correspondant
libc_li_tco_correc | Libellé court du titre du correspondant
li_civ_corres | Civilité du correspondant
libl_li_civ_corres | Libellé long de la civilité
libc_li_civ_corres | Libellé court de la civilité
li_annu | Ligne annulée (O/N)
li_qte_liv_fact | Quantité livrée facturable
li_date_depart | Date de départ
li_tolerance_liv | Tolérance de livraison
libl_li_tolerance_liv | Libellé long tolérance de livraison
libc_li_tolerance_liv | Libellé court tolérance de livraison
zc1_li_tolerance_liv zc2_li_tolerance_liv min_li_tolerance_liv max_li_tolerance_liv lib_li_tolerance_liv | Ces zones sont expliquées dans le package des cadencements de livraison prévisionnels.
li_num_mvt | Numéro de mouvement de stock 1 de la ligne de cadencement
li_num_mvt3 | Numéro de mouvement de stock 3 de la ligne de cadencement
li_mode_saisie | Mode de saisie de la ligne de cadencement
li_etat libl_li_etat libc_li_etat | Code état de la ligne de cadencement Libellé long du code état de la ligne de cadencement Libellé court du code état de la ligne de cadencement
li_date_etat | Date de l'état de la ligne de cadencement
li_qteral_ens | Reste à livrer de la ligne ou des lignes de cadencement de l'ensemble
v_li_qteral_ens | Valeur du reste à livrer de la ligne ou des lignes de cadencement de l'ensemble
li_tx_commission | Taux de commission de l'adresse de livraison de la ligne de cadencement de livraison de la ligne de commande
li_date_dern_bl_cad | Date du dernier bon de livraison de la ligne du cadencement de livraison de la ligne de commande
li_surface | Surface de la ligne de cadencement

Remarque : Si le cadencement n'existe pas, on affiche les informations de la ligne de commande.

Fiche article qualité carton

mp_qua_car_mp_code | Code de l'article
mp_qua_car_mp_des | Désignation de l'article
mp_qua_car_mp_fam | Code famille
libc_mp_qua_car_mp_fam | Libellé court de la famille
libl_mp_qua_car_mp_fam | Libellé long de la famille
mp_qua_car_mp_sfm | Code sous-famille
libc_mp_qua_car_mp_sfm | Libellé court de la sous-famille
libl_mp_qua_car_mp_sfm | Libellé long de la sous-famille
mp_qua_car_mp_lon | Longueur
mp_qua_car_mp_lar | Largeur
mp_qua_car_mp_hau | Hauteur
mp_qua_car_mp_poids | Poids

Fiche article composition technique carton

mp_com_car_mp_code | Code de l'article
mp_com_car_mp_des | Désignation de l'article
mp_com_car_mp_fam | Code famille
libc_mp_com_car_mp_fam | Libellé court de la famille
libl_mp_com_car_mp_fam | Libellé long de la famille
mp_com_car_mp_sfm | Code sous-famille
libc_mp_com_car_mp_sfm | Libellé court de la sous-famille
libl_mp_com_car_mp_sfm | Libellé long de la sous-famille
mp_com_car_mp_lon | Longueur
mp_com_car_mp_lar | Largeur
mp_com_car_mp_hau | Hauteur
mp_com_car_mp_poids | Poids

Historique (hist_pr)

La table hist_pr peut être mono-type d'enregistrement ou multi-types d'enregistrement.

Dans ce dernier cas, le nom de zone est précédé du type d'historique (un caractère pouvant prendre les valeurs A à Z et 0 à 9) et d'un tiret.

Exemple pour le code société

A-hp_soc

Dans le cas du multi-type, l'option Ohp est obligatoire.

hp_soc | Code société
hp_type | Type historique
hp_cde | Numéro dossier
hp_lcde | Numéro ligne dossier
hp_seq | Numéro de séquence du dossier
hp_datecde | Date dossier
hp_date | Date clôture dossier
hp_client | Code client
nom_hp_client | Nom client
hp_ref | Référence dossier
hp_dep | Code département
libc_hp_dep | Libellé court code département
libl_hp_dep | Libellé long code département
hp_repr | Code représentant
libc_hp_repr | Libellé court code représentant
libl_hp_repr | Libellé long code représentant
hp_produit | Code article
lib_hp_produit | Désignation article (Fiche article)
hp_fam | Code famille
libc_hp_fam | Libellé court code famille
libl_hp_fam | Libellé long code famille
hp_sfm | Code sous-famille
libc_hp_sfm | Libellé court code sous-famille
libl_hp_sfm | Libellé long code sous-famille
hp_z1 | Zone historique numérique 1
hp_z2 | Zone historique numérique 2
hp_z3 | Zone historique numérique 3
hp_z4 | Zone historique numérique 4
hp_z5 | Zone historique numérique 5
hp_z6 | Zone historique numérique 6
hp_z7 | Zone historique numérique 7
hp_z8 | Zone historique numérique 8
hp_z9 | Zone historique numérique 9
hp_z10 | Zone historique numérique 10
hp_z11 | Zone historique numérique 11
hp_z12 | Zone historique numérique 12
hp_z13 | Zone historique numérique 13
hp_z14 | Zone historique numérique 14
hp_z15 | Zone historique numérique 15
hp_c1 | Code zone paramétrable
libc_hp_c1 | Libellé court zone paramétrable
libl_hp_c1 | Libellé long zone paramétrable
hp_a1 | Zone historique alphanumérique 1
nom_hp_a1 | Nom tiers
lib_hp_a1 | Désignation article (Fiche article)
libc_hp_a1 | Libellé court zone historique alphanumérique 1
libl_hp_a1 | Libellé long zone historique alphanumérique 1
hp_d1 | Zone historique date 1
hp_num_fac | Numéro facture
hp_lig_fac | Numéro ligne facture
hp_libelle | Libellé libre
hp_cl2 | Code adresse de livraison
hp_annule | Code annulation
hp_cs1 libc_hp_cs1 libl_hp_cs1 | Code statistique 1 Libellé court du code statistique 1 Libellé long du code statistique 1
hp_cs2 libc_hp_cs2 libl_hp_cs2 | Code statistique 2 Libellé court du code statistique 2 Libellé long du code statistique 2
hp_cs3 libc_hp_cs3 libl_hp_cs3 | Code statistique 3 Libellé court du code statistique 3 Libellé long du code statistique 3
hp_cs4 libc_hp_cs4 libl_hp_cs4 | Code statistique 4 Libellé court du code statistique 4 Libellé long du code statistique 4
hp_var_prod | Code variante de production

Fiche devis reliure (Table bru)

libc_br_deviseur | Libellé court code deviseur (type VED)
libl_br_deviseur | Libellé long code deviseur (type VED)
libc_br_fabricante | Libellé court code fabricant (type FAB)
libl_br_fabricante | Libellé long code fabricant (type FAB)
libc_br_type_reliure | Libellé court type de reliure (type TRE)
libl_br_type_reliure | Libellé long type de reliure (type TRE)
br_gra_pap | Grammage papier
libc_br_qua_pap | Libellé court qualité papier (type QUA)
libl_br_qua_pap | Libellé long qualité papier (type QUA)
br_lar_bloc | Largeur bloc (en mm)
br_hau_bloc | Hauteur bloc (en mm)
br_epa_bloc | Epaisseur bloc (en mm)
br_lar_rel | Largeur reliure
br_hau_rel | Hauteur reliure
br_epa_rel | Epaisseur reliure
libc_br_impo | Libellé court code imposition (type 1PO)
libl_br_impo | Libellé long code imposition (type 1PO)
libc_br_couture | Libellé court type de couture (type CSC)
libl_br_couture | Libellé long type de couture (type CSC)
br_nbpages | Nombre de pages de l'ouvrage
br_c8 | Nombre de cahiers de 8 pages
br_c12 | Nombre de cahiers de 12 pages
br_c16 | Nombre de cahiers de 16 pages
br_c20 | Nombre de cahiers de 20 pages
br_c24 | Nombre de cahiers de 24 pages
br_c32 | Nombre de cahiers de 32 pages
br_c48 | Nombre de cahiers de 48 pages
br_c64 | Nombre de cahiers de 64 pages
br_cs | Nombre de cahiers supplémentaires
br_npcs | Nombre de pages des cahiers supplémentaires
br_k2 | Nombre de cartons de 2 pages
br_k4 | Nombre de cartons de 4 pages
br_k6 | Nombre de cartons de 6 pages
br_nb_gt | Nombre de gardes à prendre dans le texte
br_nb_gp | Nombre de gardes à plier
br_nb_gc | Nombre de gardes à coller
br_nb_gb | Nombre de gardes blanches
br_nb_gco | Nombre de gardes couleurs
br_pose_gco | Nombre de poses dans la feuille gardes couleurs
br_c_pc | Code papier crêpe
br_nb_ht_es | Nombre de hors textes à encarter dessus
br_nb_ht_ed | Nombre de hors textes à encarter dedans
br_nb_ht_cs | Nombre de hors textes à coller dessus
br_nb_ht_cd | Nombre de hors textes à coller dedans
br_nb_decour | Nombre de découronnements
libc_br_t_sig | Libellé court type signet (type TSI)
libl_br_t_sig | Libellé long type signet (type TSI)
br_c_sig | Code signet
libc_br_cou_sig | Libellé court couleur signet (type COU)
libl_br_cou_sig | Libellé long couleur signet (type COU)
libc_br_t_tra | Libellé court type tranchefile (type TTA)
libl_br_t_tra | Libellé long type tranchefile (type TTA)
br_c_tra | Code tranchefile
libc_br_cou_tra | Libellé court couleur tranchefile (type COU)
libl_br_cou_tra | Libellé long couleur tranchefile (type COU)
br_d_carton | Désignation carton
libc_br_t_dos | Libellé court type de dos (type DOS)
libl_br_t_dos | Libellé long type de dos (type DOS)
br_c_dos | Code du dos
br_mat_couv | Matière de recouvrement
br_c_housse | Code de la housse
libc_br_t_encol | Libellé court type encollage (type ENC)
libl_br_t_encol | Libellé long type encollage (type ENC)
br_c_encol | Code encollage
br_tit1 | Premier passage de titrage
br_tit2 | Deuxième passage de titrage
br_tit3 | Troisième passage de titrage
br_tit4 | Quatrième passage de titrage
br_tmc | Type de chaîne d'emboîtage
br_pas_col | Passure en colle (O/N)
br_nerfs | Nervurage
br_jaquette | Pose de jaquette
br_etiq | Etiquette (O/N)
br_bande | Bande (O/N)
br_c_emb_u | Code film pour emballage unitaire
br_c_emb_e | Code emballage étui
br_c_pal | Code palette
br_c_paq | Code film pour emballage paquet
br_c_cai | Code caisse
br_nb_cales | Nombre de cales
br_px_trans | Montant total du transport
br_visite | Visite (oui /non)
br_pr_mat | Prix de revient matière (unitaire)
br_ma_mat | Coefficient matière
br_pv_mat | Prix de vente matière (unitaire)
br_pr_ope | Prix de revient opération
br_ma_ope | Coefficient opération
br_pv_ope | Prix de vente opération
br_pr_tot | Prix de revient total
br_ma_tot | Coefficient global
br_pv_tot | Prix de vente total
br_com_cha | Commission + charge
br_total | Total
br_prix_prop | Prix proposé
br_prix_neg | Prix négocié
br_dossier | Numéro de fiche de fabrication
br_lien | Numéro de devis pour une fiche Numéro de fiche pour un devis
br_nb_c_perfo | Nombre de cahiers à perforer
br_nb_coins | Nombre de coins : 0, 2, ou 4
br_surpiquage | Surpiquage (oui / non)
br_pelliculage | Pelliculage (O/N)
br_nb_tranche_dore | Nombre de tranches à dorer
br_effectif_prevu | Effectif prévu pour la commande
br_date_reception | Date de réception sur la première ligne de réception
br_unvent | Code de l'unité de vente
libl_br_unvent | Libellé long de l'unité de vente
libc_br_unvent | Libellé court de l'unité de vente

Dossier de rattachement

dosrat_c1 | Code zone paramétrable
libc_dosrat_c1 | Libellé court zone paramétrable
libl_dosrat_c1 | Libellé long zone paramétrable
dosrat_suiv | Code suivi affaire
libc_dosrat_suiv | Libellé court code suivi affaire
libl_dosrat_suiv | Libellé long code suivi affaire
dosrat_fam | Code famille
libc_dosrat_fam | Libellé court code famille
libl_dosrat_fam | Libellé long code famille
dosrat_sfm | Code sous-famille
libc_dosrat_sfm | Libellé court code sous-famille
libl_dosrat_sfm | Libellé long code sous-famille
type_sfm_lc_lcderat | Type de sous famille de la sous famille de la ligne de rattachement
dosrat_repr | Code représentant
libc_dosrat_repr | Libellé court code représentant
libl_dosrat_repr | Libellé long code représentant
dosrat_prod | Code article
lib_dosrat_prod | Désignation article (Fiche article)
dosrat_ec_texte | Libellé commande
dosrat_qtecde | Quantité commandée
dosrat_qtefab | Quantité fabriquée
dosrat_qteliv | Quantité livrée
dosrat_qtefac | Quantité facturée
dosrat_qtelan | Quantité lancée

Sommes des quantités pour toutes les lignes ayant le même code produit et le même dossier de rattachement que la ligne en cours. A utiliser avec l' option -Osd.

somme_dosrat_qtecde | Somme des quantités commandées.
somme_dosrat_qteliv | Somme des quantités livrées.
somme_dosrat_qtefab | Somme des quantités fabriquées.
somme_dosrat_qtefac | Somme des quantités facturées.
dosrat_qtesnl | Somme des quantités fabriquées - Somme des quantités livrées

Valeur exprimée en devise société :

v_somme_dosrat_qtecde | Valeur de la somme des quantités commandées.
v_somme_dosrat_qteliv | Valeur de la somme des quantités livrées.
v_somme_dosrat_qtefab | Valeur de la somme des quantités fabriquées.
v_somme_dosrat_qtefac | Valeur de la somme des quantités facturées.
v_dosrat_qtesnl | Différence (Somme des quantités fabriquées - Somme des quantités livrées).

Devis - Sous-devis

lc_dev_lc_delrep

Délai répondu du devis dont est issue cette commande

FEFCO - ECMA

kma_nb_morceaux

Nombre de morceaux sur le code ECMA-FEFCO. Par défaut = 1 si non renseigné

Autres

using

Voir #VI

lot_contrat

Numéro de lot associé au contrat

Option -Osc obligatoire. Zone disponible uniquement en édition.

date_mag_contrat

Date de dernière entrée en magasin pour le lot associé au contrat

Option -Osc obligatoire. Zone disponible uniquement en édition.

stock_phys_contrat

Stock physique pour le lot associé au contrat (colonne cumulable)

Option -Osc obligatoire.

En mode E, cette colonne détaille les stocks physiques par lots du produit suivi en stock courant

Dans les autres modes (V/D/F), cette colonne affiche la somme des stocks physiques des lots du produit suivi en stock courant.

lieu1_rgt1 | Code lieu rangement 1. Numéro mouvement stock 1
lieu1_libc_rgt1 | Libellé court code lieu rangement 1. Numéro mouvement stock 1
lieu1_libl_rgt1 | Libellé long code lieu rangement 1. Numéro mouvement stock 1
lieu1_rgt2 | Code lieu rangement 2 - Numéro mouvement stock 1
lieu1_rgt3 | Code lieu rangement 3 - Numéro mouvement stock 1
lieu2_rgt1 | Code lieu rangement 1 - Numéro mouvement de stock 2
lieu2_libc_rgt1 | Libellé court code lieu rangement 1 - Numéro mouvement de stock 2
lieu2_libl_rgt1 | Libellé long code lieu rangement 1 - Numéro mouvement de stock 2
lieu2_rgt2 | Code lieu rangement 2 - Numéro mouvement de stock 2
lieu2_rgt3 | Code lieu rangement 3 - Numéro mouvement de stock 2
le_lib_par1 | Libellé spécifique article
le_libelle | Libellé spécifique article
le_libelle2 | Libellé 2 spécifique article
le_lib_par1_pf | Libellé spécifique du code produit en cours
le_libelle_pf | Libellé spécifique du code produit en cours
le_libelle2_pf | Libellé spécifique du code produit en cours
lib_par1 | Libellé spécifique article
qtesnl | Quantité stock non livrée
qteral | Quantité reste à livrer
qteraf | Quantité reste à facturer
qterafab | Quantité reste à fabriquer
qtelne_b | Quantité livrée BL non édités
qtelep_b | Quantité livrée BL édités provisoirement
qteled_b | Quantité livrée BL édités définitivement
qteedi_b | Quantité livrée BL édités provisoirement et définitivement
qteliv_type_nnn | Quantité livrée ventilée par type de livraison où nnn peut prendre plusieurs valeurs indiquées dans la fiche d'installation Mise à disposition et Consignation.
qteliv_b | Quantité livrée BL non édités et édités
dateliv_b | Date de livraison
dateliv_f | Date de la dernière livraison
qte_lot1 | Quantité produit dans lot (num cde)
qte_lot2 | Quantité de produit dans le lot de la commande (num cde-lig cde)
pdsral_n | Poids reste à livrer nomenclature
nb_pal_n | Nombre de palettes nomenclature
encombrement | Encombrement nomenclature
note_ligne1 | Première ligne de note dont le type est paramétré en alpha4[58, 60].
date_mag date_mag_date date_mag_heure | Date et heure prévisionnelle de l'entrée en magasin (dans fab_1_etat) Date uniquement - Voir la note _SUP_REQ_DATE_MAG Heure uniquement - Voir la note _SUP_REQ_DATE_MAG
somme_entree_lc_prod_lot | Somme des mouvements d'entrée en stock pour la ligne de commande
somme_sortie_lc_prod_lot | Somme des mouvements de sortie de stock pour la ligne de commande
somme_entree_nc_prod_lot | Somme des mouvements d'entrée en stock pour la ligne de nomenclature de commande
somme_sortie_nc_prod_lot | Somme des mouvements de sortie de stock pour la ligne de nomenclature de commande
code_lieu | Code du lieu du tableau des stocks par lieux En édition et si alpha2[30] du paramètre de lancement est à O et si la colonne stock_lieu est paramétrée
stock_lieu | Stock du lieu du tableau des stocks par lieux En édition et si alpha2[30] du paramètre de lancement est à O et si la colonne code_lieu est paramétrée
stock_reserve_pf | Stock réservé
stock_cdef_pf | Stock commande d'achat et fabrication
stock_dispo_immediat_pf | Stock disponible immédiatement
num_fac_1 | Numéro de la dernière facture de la ligne de commande Le numéro est précédé de F(acture) ou de A(voir)
date_fac_1 | Date de la dernière facture de la ligne de commande
num_fac_2 | Numéro de l'avant dernière facture de la ligne de commande Le numéro est précédé de F(acture) ou de A(voir)
date_fac_2 | Date de l'avant dernière facture de la ligne de commande
num_fac_3 | Numéro de l'avant-avant dernière facture de la ligne de commande Le numéro est précédé de F(acture) ou de A(voir)
date_fac_3 | Date de l'avant-avant dernière facture de la ligne de commande
etat_stk_pf | Etat du stock du PF : [blanc] stock physique >= stock d'alerte ou article non géré en stock ou article cartonnier A stock physique < stock d'alerte S stock physique < stock mini (sécurité) R stock physique <= 0
quantite_cde_pf |
qteafaprev | Quantité à facturer prévue (= Quantité à facturer de la ligne de commande + Somme des quantités des bons de livraisons facturables provisoires)
v_qteafaprev | Montant à facturer prévu en devise de commande
v_qteafaprev_pr | Montant du prix de revient à facturer prévu en devise de commande
v_qteafaprev_marge_pr | Montant à facturer marge prévisionnelle prévu en devise de commande
v_qteafaprev_prr | Montant prix de revient réel à facturer prévu en devise de commande
v_qteafaprev_marge_prr | Montant à facturer prévu marge réelle en devise de commande
v_qteafaprev_euro | Montant à facturer prévu en euros
v_qteafaprev_pr_euro | Montant prix de revient à facturer prévu en euros
v_qteafaprev_marge_pr_euro | Montant à facturer marge prévisionnelle prévu en euros
v_qteafaprev_prr_euro | Montant prix de revient réel a facturer prévu en euros
v_qteafaprev_marge_prr_euro | Montant à facturer marge réelle prévu en euros
v_qteafaprev_dev | Montant à facturer prévu en devise société
v_qteafaprev_pr_dev | Montant prix de revient à facturer prévu en devise société
v_qteafaprev_marge_pr_dev | Montant à facturer marge prévisionnelle prévu en devise société
quantite_liv_pf | Quantité livrée facturable du produit en cours
quantite_afa_pf | Quantité à facturer sur le produit en cours
quantite_reelle_pf | Quantité réellement livrée du produit en cours
quantite_fab_pf | Quantité fabriquée du produit en cours
quantite_contrat_pf | Quantité associée au contrat du produit en cours
semaine_commande | année et numéro de semaine de la date de commande (tri 62 par semaine)
mois_commande | année et numéro de mois de la date de commande (tri 63 par mois)
quantite_ralr_pf | quantité restant à livrer réelle
ml_plancher_ralr_pf | métrage linéaire restant à livrer réel
nb_palr_n | nombre de palettes restant à livrer réel
v_stock_dispo_lot_pf | Stock disponible du lot sur PF
qte_1 | Quantité commandée de la dernière commande
qte_2 | Quantité commandée de l'avant-dernière commande
qte_3 | Quantité commandée de l'avant-avant-dernière commande
qte_lot1_lieux | Quantité / lot / lieu Le lot recherché est celui du numéro de la commande (entête seule).
qte_lot2_lieux | Quantité / lot / lieu Le lot recherché est celui du numéro de la ligne de commande (entête + N° de ligne).
li_qteral | Reste à livrer de la ligne de cadencement.
v_li_qteral | Valeur du reste à livrer de la ligne de cadencement.
num_contrat | Numéro Volume de la commande contrat associée (la colonne ec_ref_liaison retourne sa référence, soit le numéro client de la commande)
num_contrat_rat | Numéro Volume de la commande de contrat associée à la commande rattachée
code_lieu2 | Code du lieu 2 du tableau des stocks par lieux ou par lieux/lots
numero_lot | Numéro du lot du tableau des stocks par lieux ou par lieux/lots
stock_mouvemente | Somme des mouvements d'entrée somme des mouvement de sortie sur une période donnée
tps_prod_fab2 | Somme des temps de production (somme des temps passés sur la période étudiée)
tps_prod_fab2_moyen | Division du stock_mouvemente par tps_prod_fab2
pr_fab0 | Colonne prix de revient (correspond à la zone fab0.f0_cr : coût réel)
frais_techniques | Frais techniques en devise Société Somme des montants en devise Société des lignes de commande des articles de type frais associées à la même commande Σ (lc_qtecde * lc_prx) / lc_unvent
frais_techniques_euro | Frais techniques en devise EURO Somme des montants en devise EURO des lignes de commande des articles de type frais associées à la même commande Σ (lc_qtecde * lc_prx_euro) / lc_unvent
frais_techniques_dev | Frais techniques en devise Commande Somme des montants en devise Commande des lignes de commande des articles de type frais associées à la même commande Σ (lc_qtecde * lc_prx_dev) / lc_unvent
nb_references_devis | Nombre de références du devis transféré en commande l2_nb_references de la table fle_2
Stock_phys_lot_depot | Stock physique du lot sur le dépôt courant
Stock_phys_art_depot | Stock physique de l'article sur le dépôt courant (tous lots confondus)
tps_prep_prevu_fab1 | Somme des temps de préparation prévus
tps_real_prevu_fab1 | Somme des temps de réalisation prévus
tps_ prevu_fab1 | Somme des temps prévus (préparation + réalisation)
stock_ens_nn | Stock de l'ensemble - Voir aussi l'option Opa (où nn représente un numéro de restriction, voir note RESTRIC_STOCK_NUM_ Cette variable est alimentée comme suit : si le produit courant est " Un produit simple stock_ens_nn = stock_pf_nn " un ensemble monté/monté extérieur stock_ens_nn = stock_pf_nn + nombre d'ensembles réalisables avec le stock de chacun des composants " un ensemble appairé non monté stock_ens_nn = nombre d'ensembles réalisables avec le stock de chacun des composants
stock_liv_nn | Quantité livrable en stock Voir la note RESTRIC_STOCK_NUM_ Cette zone tient compte du type du produit commandé (article non appairé, ensemble appairé, ensemble monté ou ensemble monté à l'extérieur) et du type de la commande (si on est sur une commande de fabrication, on calcule en prenant le lot en compte; sinon, on calcule tout le stock physique).
gen_grp_ok | Indique par un astérisque (*) que la génération du groupage a été faite sur la ligne de visualisation Zone disponible en visualisation uniquement
gen_blv_ok | Indique par un astérisque (*) que la génération du bon de livraison a été faite sur la ligne de visualisation Zone disponible en visualisation uniquement
gen_dos_fab_ok | Indique par un astérisque (*) que la génération du dossier de fabrication a été faite sur la ligne de visualisation Zone disponible en visualisation uniquement
qte_receptionnee | Somme des quantités réceptionnées des commandes rattachées à la ligne de commande et au produit en cours
ml_plancher_cde | Métrage linéaire commandé
num_lig | concaténation de lc_num et lc_lig sous la forme : lc_num-lc_lig (sur 3 caractères) ' 10120001-001
blv_num_cf | Numéro du bon de livraison du CONTROL-F
blv_lig_cf | Ligne du bon de livraison du CONTROL-F
blv_qte_cf | Quantité livrée de la ligne du bon de livraison du CONTROL-F
fac_num_cf | Numéro de la facture du CONTROL-F
fac_lig_cf | Ligne de la facture du CONTROL-F
fac_qte_cf | Quantité facturée de la ligne de la facture du CONTROL-F
blv_datl_cf | Date de livraison du BL
num_lig_cderat | Numéro de ligne de la commande de rattachement de la ligne de commande Format : cccccccc-lll
adxx_c2_yyyy adae_c2_yyy adle_c2_yyy adfe_c2_yyy adll_c2_yyy adfl_c2_yyy | Informations des adresses secondaires liées à une commande Adresse secondaire définie en entête de commande Adresse secondaire de livraison définie en entête de commande Adresse secondaire de facturation définie en entête de commande Adresse secondaire de livraison définie au niveau de la ligne de commande Adresse secondaire de facturation définie au niveau de la ligne de commande Exemple adae_c2_nom permet d'avoir le nom de l'adresse secondaire définie en entête de commande.
indicateur_solde | Ligne de commande soldée ? (0 = non, 1 = oui) Zone non visualisable, non cumulable, utilisable uniquement dans les formules de calcul.
delais_realise | Délai écoulé entre date de la prise de commande client (date de création de la ligne de commande) et la celle de la première livraison Voir les TSC DS / DS1 / DS2 / DS3 / DS4 / DS5
delais_realise_fac | Délai écoulé entre date de la prise de commande client (date de création de la ligne de commande) et celle de la dernière facture de la ligne de commande

Blocage laboratoire

La mise en place du contrôle laboratoire est expliquée dan le programme cde.

code_qualite | Code qualité de l'architecture du produit de la ligne de FBI ou du produit de la ligne de FB2 pour les produits cartonniers. Non renseigné pour les autres types de commande
libc_code_qualite | Libellé court code qualité
libl_code_qualite | Libellé long code qualité
code_estampille | Code estampille de l'architecture du produit de la ligne de FBI Non renseigné pour les autres types de commande
libc_code_estampille | Libellé court code estampille
libl_code_estampille | Libellé long code estampille

Montants dans la devise de la société

v_qtecde | Montant commandé
v_qtelan | Montant lancé
v_qtefab | Montant fabriqué
v_qteliv | Montant livré
v_qteafa | Montant à facturer
v_qtefac | Montant facturé
v_qtesnl | Montant stock non livré
v_qteral | Montant reste à livrer
v_qteraf | Montant reste à facturer
v_qterafab | Montant reste à fabriquer
v_qtelne_b | Montant livré BL non édités
v_qtelep_b | Montant livré BL édités provisoirement
v_qteled_b | Montant livré BL édités définitivement
v_qteedi_b | Montant livré BL édités provisoirement et définitivement
v_qteliv_b | Montant livré BL non édités et édités
v_client | Montant client
v_qtecde_n | Montant commandé nomenclature
v_qteliv_n | Montant livré nomenclature
v_qtelnv_n | Montant livré non validé nomenclature
v_qtelva_n | Montant livré validé nomenclature
v_qtecde_pr | Montant commandé prix revient prévisionnel
v_qteliv_pr | Montant livré prix revient prévisionnel
v_qteafa_pr | Montant à facturer prix revient prévisionnel
v_qtefac_pr | Montant facturé prix revient prévisionnel
v_qtecde_marge_pr | Montant commandé marge prévisionnelle
v_qteliv_marge_pr | Montant livré marge prévisionnelle
v_qteafa_marge_pr | Montant à facturer marge prévisionnelle
v_qtefac_marge_pr | Montant facturé marge prévisionnelle
v_qtecde_prr | Montant commandé prix revient réel
v_qteliv_prr | Montant livré prix revient réel
v_qteafa_prr | Montant à facturer prix revient réel
v_qtefac_prr | Montant facturé prix revient réel
v_qtecde_marge_prr | Montant commandé marge réelle
v_qteliv_marge_prr | Montant livré marge réelle
v_qteafa_marge_prr | Montant à facturer marge réelle
v_qtefac_marge_prr | Montant facturé marge réelle
marge_brute | Marge brute
pv_net | Prix de vente net dans l'unité de prix de la ligne de commande
v_pa | Montant commandé au prix achat
pamp_uni | PAMP
v_pamp | Montant commandé au PAMP
cout_prevu | Coût prévu
cout_realise | Coût réalisé
ca_contrat | Montant actuel du chiffre d'affaire pour la ligne de contrat courant (option -Osc obligatoire)
v_qte_contrat | Montant actuel commandé pour la ligne du contrat courant (option -Osc obligatoire)
v_qte_contrat_n | Montant actuel commandé nomenclature de contrat (option -Osc obligatoire)
v_qte_contrat_pr | Montant actuel commandé pour la ligne du contrat courant (prix de revient prévisionnel) (option -Osc obligatoire)
v_qte_contrat_marge_pr | Montant actuel commandé pour la ligne du contrat courant (marge prévisionnelle) (option -Osc obligatoire)
v_qte_contrat_prr | Montant actuel commandé pour la ligne du contrat courant (prix de revient réel) (option -Osc obligatoire)
v_qte_contrat_marge_prr | Montant actuel commandé pour la ligne du contrat courant (marge réelle) (option -Osc obligatoire)

Montants dans la devise EURO

v_qtecde_euro | Montant commandé
v_qtelan_euro | Montant lancé
v_qtefab_euro | Montant fabriqué
v_qteliv_euro | Montant livré
v_qteafa_euro | Montant à facturer
v_qtefac_euro | Montant facturé
v_qtesnl_euro | Montant stock non livré
v_qteral_euro | Montant reste à livrer
v_qteraf_euro | Montant reste à facturer
v_qterafab_euro | Montant reste à fabriquer
v_qtelne_b_euro | Montant livré BL non édités
v_qtelep_b_euro | Montant livré BL édités provisoirement
v_qteled_b_euro | Montant livré BL édités définitivement
v_qteedi_b_euro | Montant livré BL édités provisoirement et définitivement
v_qteliv_b_euro | Montant livré BL non édités et édités
v_client_euro | Montant client
v_qtecde_n_euro | Montant commandé nomenclature
v_qteliv_n_euro | Montant livré nomenclature
v_qtelnv_n_euro | Montant livré non validé nomenclature
v_qtelva_n_euro | Montant livré validé nomenclature
v_qtecde_pr_euro | Montant commandé prix revient prévisionnel
v_qteliv_pr_euro | Montant livré prix revient prévisionnel
v_qteafa_pr_euro | Montant à facturer prix revient prévisionnel
v_qtefac_pr_euro | Montant facturé prix revient prévisionnel
v_qtecde_marge_pr_euro | Montant commandé marge prévisionnelle
v_qteliv_marge_pr_euro | Montant livré marge prévisionnelle
v_qteafa_marge_pr_euro | Montant à facturer marge prévisionnelle
v_qtefac_marge_pr_euro | Montant facturé marge prévisionnelle
v_qtecde_prr_euro | Montant commande prix revient réel
v_qteliv_prr_euro | Montant livré prix revient réel
v_qteafa_prr_euro | Montant à facturer prix revient réel
v_qtefac_prr_euro | Montant facturé prix revient réel
v_qtecde_marge_prr_euro | Montant commandé marge réelle
v_qteliv_marge_prr_euro | Montant livré marge réelle
v_qteafa_marge_prr_euro | Montant à facturer marge réelle
v_qtefac_marge_prr_euro | Montant facturé marge réelle
marge_brute_euro | Marge brute
pv_net_euro | Prix de vente net dans l'unité de prix de la ligne de commande
ca_contrat_euro | Montant actuel du chiffre d'affaire pour la ligne de contrat courant (option -Osc obligatoire)
v_qte_contrat_euro | Montant actuel commandé pour la ligne du contrat courant (option -Osc obligatoire)
v_qte_contrat_n_euro | Montant actuel commandé nomenclature du contrat (option -Osc obligatoire)
v_qte_contrat_pr_euro | Montant actuel commandé de contrat (prix revient prévisionnel) (option -Osc obligatoire)
v_qte_contrat_marge_pr_euro | Montant actuel commandé pour la ligne du contrat courant (marge prévisionnelle) (option -Osc obligatoire)
v_qte_contrat_prr_euro | Montant actuel commandé pour la ligne du contrat courant (prix revient réel) (option -Osc obligatoire)
v_qte_contrat_marge_prr_euro | Montant actuel commandé pour la ligne du contrat courant (marge réelle) (option -Osc obligatoire)

Montants dans la devise de la commande

v_qtecde_dev | Montant commandé
v_qtelan_dev | Montant lancé
v_qtefab_dev | Montant fabriqué
v_qteliv_dev | Montant livré
v_qteafa_dev | Montant à facturer
v_qtefac_dev | Montant facturé
v_qtesnl_dev | Montant stock non livré
v_qteral_dev | Montant reste à livrer
v_qteraf_dev | Montant reste à facturer
v_qterafab_dev | Montant reste à fabriquer
v_qtelne_b_dev | Montant livré BL non édités
v_qtelep_b_dev | Montant livré BL édités provisoirement
v_qteled_b_dev | Montant livré BL édités définitivement
v_qteedi_b_dev | Montant livré BL édités provisoirement et définitivement
v_qteliv_b_dev | Montant livré BL non édités et édités
v_client_dev | Montant client
v_qtecde_n_dev | Montant commandé nomenclature
v_qteliv_n_dev | Montant livré nomenclature
v_qtelnv_n_dev | Montant livré non validé nomenclature
v_qtelva_n_dev | Montant livré validé nomenclature
v_qtecde_pr_dev | Montant commandé prix revient prévisionnel
v_qteliv_pr_dev | Montant livré prix revient prévisionnel
v_qteafa_pr_dev | Montant à facturer prix revient prévisionnel
v_qtefac_pr_dev | Montant facturé prix revient prévisionnel
v_qtecde_marge_pr_dev | Montant commandé marge prévisionnelle
v_qteliv_marge_pr_dev | Montant livré marge prévisionnelle
v_qteafa_marge_pr_dev | Montant à facturer marge prévisionnelle
v_qtefac_marge_pr_dev | Montant facturé marge prévisionnelle
marge_brute_dev | Marge brute
pv_net_dev | Prix de vente net dans l'unité de prix de la ligne de commande
pv_kg_std | Prix de vente au kilo
pv_kg_lc | Prix de vente au kilo de la ligne de commande
pv_kg_brut_std | Prix de vente au kilo (Poids brut)
pv_100_kg_std | Prix de vente au cent kilo
pv_100_kg_brut_std | Prix de vente au cent kilo (Poids brut)
pv_m2_std | Prix de vente au m2
pv_m2_lc | Prix de vente au m2 de la ligne de commande
pv_m2_brut_std | Prix de vente au m2 (Poids brut)
pv_100_m2_std | Prix de vente au cent m2
pv_100_m2_brut_std | Prix de vente au cent m2 (Poids brut)
surface_unitaire | Surface unitaire (Fiche article) (Largeur / 1000) * (Longueur / 1000)
surf_cde_202 | Surface de la ligne de commande (Surface unitaire * Quantité commandée) Surface unitaire = - Surface de la ligne de commande pour les cartonniers - TSC 202 Valeur 2 de la fiche article.
surface_uni_lc | Surface unitaire commandée
surface_uni | Surface unitaire commandée
surface_uni_brut | Surface unitaire commandée brute
surface_cde_lc | Surface commandée
surface_cde | Surface commandée
surface_cde_brut | Surface commandée brute
surface_liv_lc | Surface livrée
surface_liv | Surface livrée
surface_liv_brut | Surface livrée brute
surface_fab_lc | Surface fabriquée
surface_fab | Surface fabriquée
surface_fab_brut | Surface fabriquée brute
surface_fac_lc | Surface facturée
surface_fac | Surface facturée
surface_fac_brut | Surface facturée brute
poids_cde_202 | Poids de la ligne de commande (Poids unitaire * Quantité commandée) Poids unitaire = - Poids de la ligne de commande pour les cartonniers - TSC 202 Valeur 1 de la fiche article
poids_uni_lc | Poids unitaire commandé (lc_poids)
poids_uni | Poids unitaire commandé
poids_uni_brut | Poids unitaire brut commandé
poids_cde_lc | Poids commandé (lc_poids * qtecde)
poids_cde | Poids commandé
poids_cde_brut | Poids commandé brut
poids_liv_lc | Poids livré (lc_poids * qtecde)
poids_liv | Poids livré
poids_liv_brut | Poids livré brut
poids_fab_lc | Poids fabriqué (lc_poids * qtecde)
poids_fab | Poids fabriqué
poids_fab_brut | Poids fabriqué brut
poids_fac_lc | Poids facturé (lc_poids * qtecde)
poids_fac | Poids facturé
poids_fac_brut | Poids facturé brut
dates_heures_livraison | Dates et heures des jours livrables (2 maxi à partir de la date répondue de la ligne de commande)
code_pf | Code produit fini
lib_code_pf | Désignation produit fini (Fiche article)
largeur_pf | Largeur produit fini
longueur_pf | Longueur produit fini
quantite_ral_pf | Quantité restant à livrer du produit fini
stock_physique_pf stock_physique_pf_nn | Stock physique du produit fini. alpha2[28] = O et alpha2[39] = O Si le nom de la zone est suivi de _nn, alors la zone est soumise aux restrictions de la note RESTRIC_STOCK_NUM
stock_phys_pf_lot stock_phys_pf_lot_nn | Stock physique du produit fini du lot de la commande rattachée. alpha2[28] = O et alpha2[39] = O Si le nom de la zone est suivi de _nn, alors la zone est soumise aux restrictions de la note RESTRIC_STOCK_NUM Exemple : stock_dispo_pf_01
stock_dispo_pf stock_dispo_pf_nn | Stock disponible du produit fini Si le nom de la zone est suivi de _nn, alors la zone est soumise aux restrictions de la note RESTRIC_STOCK_NUM
qte_fab | Quantité fabriquée nomenclature
ml_plancher_ral_pf | Mètre linéaire de plancher du produit fini
volume_ral_pf | Volume produit fini restant à livrer
of_rattachement | Dossier de fabrication rattaché à la ligne de commande
tv_p_vente_n_kg | Prix de vente aux n KG (en FRANCS) (n paramétrable, voir valeur numérique 1)
tv_p_revient_n_kg | Prix de revient aux n KG (en FRANCS) (n paramétrable, voir valeur numérique 1)
ca_contrat_dev | Montant actuel du chiffre d'affaire pour la ligne de contrat courant (option -Osc obligatoire)
v_qte_contrat_dev | Montant actuel commandé pour la ligne du contrat courant (option -Osc obligatoire)
v_qte_contrat_n_dev | Montant actuel commandé nomenclature du contrat (option -Osc obligatoire)
v_qte_contrat_pr_dev | Montant actuel commandé pour la ligne du contrat courant (prix revient prévisionnel) (option -Osc obligatoire)
v_qte_contrat_marge_pr_dev | Montant actuel commandé pour la ligne du contrat courant (marge prévisionnelle) (option -Osc obligatoire)

Fiche Tiers livraison

livraison_cl_code | Code tiers
livraison_cl_nom | Nom tiers
livraison_cl_adr1 | Ligne 1 adresse rue
livraison_cl_adr2 | Ligne 2 adresse rue
livraison_cl_codp | Code postal
livraison_cl_vil | Adresse ville
livraison_cl_telph1 | Numéro téléphone 1
livraison_cl_telph2 | Numéro téléphone 2
livraison_cl_telcop | Numéro fax
livraison_cl_telex | Numéro télex
livraison_cl_pays | Code pays
livraison_libc_cl_pays | Libellé court code pays
livraison_libl_cl_pays | Libellé long code pays
livraison_cl_adrb | Code adresse livraison

NB Si le lieu de rangement 1 de la ligne de commande (fenêtre revue de contrat) est alimenté, l'adresse de livraison est alimentée avec le code client et le code adresse de livraison de celui-ci (alpha1[14,19] et alpha1[20,22] du paramètre <RG1><lc_lieu_rgt1>), sinon avec le code client et le code adresse de livraison de la ligne de commande (lc_adl)

Type de visualisation = E (Enregistrés) - SPECIFIQUE Consulter VSW

date_semaine | Semaine de livraison
date_mois | Mois de livraison
pv_100kg | Prix de vente aux 100 kg
pv_100m2 | Prix de vente aux 100 m2
pr_lc | Prix de revient dans l'unité de prix de la ligne de commande
pr_100m2 | Prix de revient aux 100 m2
marge_f | Marge en francs
marge_p | Marge en pourcentage
marge_cm_f | Marge sur coût matière en francs
marge_cm_100kg | Marge sur coût matière aux 100 kg
marge_cm_100m2 | Marge sur coût matière aux 100 m2
ca_r | Chiffre d'affaire avec RRR prévisionnel
pv_100kg_r | Prix de vente aux 100 kg avec RRR prévisionnel
pv_100m2_r | Prix de vente aux 100 m2 avec RRR prévisionnel
marge_f_r | Marge en francs avec RRR prévisionnel
marge_p_r | Marge en pourcentage avec RRR prévisionnel
marge_cm_f_r | Marge sur coût matière en francs avec RRR prévisionnel.
marge_cm_100kg_r | Marge sur coût matière aux 100 kg avec RRR prévisionnel.
marge_cm_100m2_r | Marge sur coût matière aux 100 m2 avec RRR prévisionnel.
pv_1 | Prix de vente de la précédente commande dans l'unité de prix de la ligne de commande
date_pv_1 | Date de livraison de la précédente commande
date_dernier_entree | Date de dernière entrée en magasin
pv_2 | Prix de vente de l'avant dernière commande dans l'unité de prix de la ligne de commande
pv_3 | Prix de vente de l'avant-avant dernière commande dans l'unité de prix de la ligne de commande
pa_lc | Prix d'achat dans l'unité de prix de la ligne de commande

Type de visualisation = F (Facturés) - SPECIFIQUE Consulter VSW

date_semaine | Semaine de facturation
date_mois | Mois de facturation
pv_100m2_f | Prix de vente aux 100 m2
pv_100kg_f | Prix de vente aux 100 kg
pv_100m2_f_r | Prix de vente aux 100 m2 avec RRR prévisionnel
pv_100kg_f_r | Prix de vente aux 100 kg avec RRR prévisionnel
ca_f_r | Chiffre d'affaire avec RRR prévisionnel
fl_qte | Quantité facturée pour la ligne de facture
mt_achat | Montant des achats issues des commandes fournisseurs rattachées

Matière au PUMP - SPECIFIQUE Consulter VSW

MCMP | Marge sur coût matière en francs
MCMP_100m2 | Marge sur coût matière aux 100 m2
PRCP | Prix de revient complet
PRCP_100m2 | Prix de revient complet aux 100 m2
marge_f_PRCP | Marge sur prix de revient en francs
marge_p_PRCP | Marge sur prix de revient en pourcentage
MCMP_r | Marge sur coût matière en francs avec RRR prévisionnel
MCMP_100m2_r | Marge sur coût matière aux 100 m2 avec RRR prévisionnel
marge_f_PRCP_r | Marge sur prix de revient en francs avec RRR prévisionnel
marge_p_PRCP_r | Marge sur prix de revient en pourcentage avec RRR prévisionnel.

Ligne de commande rattachée

devis_cderat | Devis ligne de commande rattachée
sdevis_cderat | Sous-devis ligne de commande rattachée
entite_cderat | Entité ligne de commande rattachée

Groupages BL

gb_soc | Code société
gb_no_groupage | Numéro groupage
gb_cde | Numéro commande
gb_ligcde | Ligne de commande
gb_ligseq | Ligne de séquence
gb_code_client | Code client
nom_gb_code_client | Nom client
gb_trans | Code transporteur
nom_gb_trans | Nom transporteur
gb_date_pres_dem | Date de présentation demandée
gb_heure_pres_dem | Heure de présentation demandée
gb_cout_charg_prev | Coût du chargement prévu
gb_poids_prev | Poids prévu
gb_qte_prev | Quantité prévue
gb_nb_pal_prev | Nombre de palettes prévues
gb_solde_prev | Solde total ou partiel
gb_groupage_edite | Groupage édité (O/N)
gb_annul | Code annulation
gb_adl | Adresse livraison
nom_gb_adl | Nom adresse livraison
codp_gb_adl | Code postal adresse livraison
vil_gb_adl | Ville adresse livraison
pays_gb_adl | Pays adresse livraison
libc_pays_gb_adl | Libellé court pays adresse livraison
libl_pays_gb_adl | Libellé long pays adresse livraison
gb_tport | Type de port
libc_gb_tport | Libellé court type de port
libl_gb_tport | Libellé long type de port
gb_trsp | Mode de transport
libc_gb_trsp | Libellé court mode de transport
libl_gb_trsp | Libellé long mode de transport
gb_preparateur | Code préparateur
libc_gb_preparateur | Libellé court code préparateur
libl_gb_preparateur | Libellé long code préparateur
gb_ligne_groupage | Ligne de groupage
gb_qte_reelle | Quantité réelle
gb_statut | Code statut
lib_gb_statut | Libellé code statut
gb_metr_lineaire | Métrage linéaire
gb_code_tarif | Code tarif
libc_gb_code_tarif | Libellé court code tarif
libl_gb_code_tarif | Libellé long code tarif
gb_type_vehicule | Type de véhicule
libc_gb_type_vehicule | Libellé court type de véhicule
libl_gb_type_vehicule | Libellé long type de véhicule
gb_etat_affret | Etat de l'affrètement
lib_gb_etat_affret | Libellé état de l'affrètement
gb_date_pres_reel | Date de présentation
gb_heure_pres_reel | Heure de présentation
gb_vehicule | Véhicule (Immatriculation, ...)
gb_date_dbt_chgt | Date de début de chargement
gb_heure_dbt_chgt | Heure de début de chargement
gb_date_fin_chgt | Date de fin de chargement
gb_heure_fin_chgt | Heure de fin de chargement
gb_quai | Quai affecté
libc_gb_quai | Libellé court quai affecté
libl_gb_quai | Libellé long quai affecté
gb_cariste | Cariste
libc_gb_cariste | Libellé court cariste
libl_gb_cariste | Libellé long cariste
gb_date_dep_usine | Date de départ de l'usine
gb_heure_dep_usine | Heure de départ de l'usine
gb_metr_reel | Métrage réel
gb_mag_depart | Magasin de départ
libc_gb_mag_depart | Libellé court magasin de départ
libl_gb_mag_depart | Libellé long magasin de départ
gb_lieu_rgt1 | Lieu intermédiaire
libc_gb_lieu_rgt1 | Libellé court lieu intermédiaire
libl_gb_lieu_rgt1 | Libellé long lieu intermédiaire
gb_blv | Numéro de bon de livraison
gb_ligblv | Ligne du bon de livraison
gb_cout_reel | Coût réel
gb_forcage_cout | Forçage du coût (O=Oui - N=Non)
gb_reponse_trans | Réponse du transporteur
gb_date_dem_trsft | Date de demande de transfert
gb_heure_dem_trsft | Heure de demande de transfert
gb_date_rep_trans | Date de réponse du transporteur
gb_heure_rep_trans | Heure de réponse du transporteur
gb_date_crea_aff | Date de création de l'affrètement
gb_heure_crea_aff | Heure de création de l'affrètement
gb_date_valid_def | Date de validation définitive
gb_devise_cout | Devise du coût
libc_gb_devise_cout | Libellé court devise du coût
libl_gb_devise_cout | Libellé long devise du coût
gb_zone_tarifaire | Zone tarifaire livrée
lib_gb_zone_tarifaire | Désignation zone tarifaire livrée
gb_unite_fact_cout | Unité de coût facturable
libc_gb_unite_fact_cout | Libellé court unité de coût facturable
libl_gb_unite_fact_cout | Libellé long unité de coût facturable
gb_qte_fact_cout | Quantité de coût facturable
gb_transfert_1 | Flag 1er transfert (O=Oui - N=Non)
gb_transfert_2 | Flag 2ème transfert (O=Oui - N=Non)
gb_site_prod | Site de production
libc_gb_site_prod | Libellé court site de production
libl_gb_site_prod | Libellé long site de production
gb_volume_tot | Volume total du groupage
gb_volume_lig | Volume de la ligne de groupage

Etat de fabrication

fab_1_etat

Toutes les zones de la table sont accessibles ainsi que les zones suivantes :

lib_f1e_ensemble Libellé composé

lib_f1e_composant Libellé composant

des_f1e_machine Désignation machine

des_f1e_mac_suiv Désignation machine suivante

Les quantités (à planifier, planifiée et produite) sont cumulables et utilisables dans les formules de calcul paramétrables.

Zones pour les cadencements de fabrication

Package Cadencements de Fabrication

Toutes les zones des packages Définition générale du devis et Entités du Devis en les préfixant de ccf_. Les cumuls ne sont pas gérés.

ainsi que les zones suivantes :

ccf_somme_qtelan_X_YYY | Somme des quantités lancées. Voir la note _SUP_REQ_CCF_QTELAN
ccf_somme_qtefab_X_YYY | Somme des quantités fabriquées. Voir la note _SUP_REQ_CCF_QTEFAB
ccf_date_planning_X_YYY | Dernière date de planification. Voir la note _SUP_REQ_CCF_DATE_PL
ccf_commentaire | Commentaire Preactor (60 caractères)
ccf_nb_cad_NN_X_YYY | Nombre de cadencements correspondant à un complément de sélection

NN = numéro de complément de sélection paramétré dans _SUP_REQ_NB_CCF_

X = type d'enregistrement (E ou L)

YYY = type de cadencement (ex : GLO). Si YYY = "XXX", alors on prend en compte tous les types de cadencements.

Voir la fiche d'installation

Zones du certificat de cnformité

Voir les notes OUTIL_LCO_FOR_* et la note _SUP_REQ_CERTIF_DE

Toutes les zones des packages fle_dec et fle_imp peuvent être utilisées en les préfixant de certif_

ainsi que les zones suivantes :

certif_fam_fi_c_papier certif_libc_fam_fi_c_papier certif_libl_fam_fi_c_papier | Famille du code papier Libellé court Libellé long
certif_sfm_fi_c_papier certif_libc_sfm_fi_c_papier certif_libl_sfm_fi_c_papier | Sous-famille du code papier Libellé court Libellé long
certif_outil | Code outillage (recherché avec le numéro de forme (fi_num_forme) et un cascading sur la LCO)
certif_qte_par_caisse | Quantité par caisse (recherche sur un TSC de la fiche de conditionnement CIC C24 et TSC 201)

Zones permettant de récupérer les codes clients utilisés par Efficial

Dans le programme de transfert de données à Efficial (efficial_phase_1), le code identifiant le destinataire de la facture est le résultat d'un calcul partant du code client et de l'adresse de livraison.

Afin de pouvoir transférer ce même code à d'autres organismes (Qualnet, Zoom), on implémente dans de nouvelles zones de la visualisation des commandes clients calculées à partir de ces mêmes données.

efficial_cli_ent_fac | Code Efficial calculé en fonction du code client et de l'adresse de facturation de l'entête de la commande
efficial_cli_ent_liv | Code Efficial calculé en fonction du code client et de l'adresse de livraison de l'entête de la commande
efficial_cli_lig_fac | Code Efficial calculé en fonction du code client et de l'adresse de facturation de la ligne de commande
efficial_cli_lig_liv | Code Efficial calculé en fonction du code client et de l'adresse de livraison de la ligne de commande
efficial_grp_ent_fac | Code Efficial calculé en fonction du code groupe du client et de l'adresse de facturation de l'entête de commande
efficial_grp_ent_liv | Code Efficial calculé en fonction du code groupe du client et de l'adresse de livraison de l'entête de commande
efficial_grp_lig_fac | Code Efficial calculé en fonction du groupe du client et de l'adresse de facturation de la ligne de commande
efficial_grp_lig_liv | Code Efficial calculé en fonction du groupe du client et de l'adresse de livraison de la ligne de commande

Dossiers de fabrication - Nomenclatures

f0_of | Numéro d'ordre de fabrication f0_of = lc_num-lc_lig
f0_cr | Coût réel
f0_gener | 0 = non généré, 1 = Généré, 2 = à générer à nouveau
f0_lance | Fabrication lancée (true/false)
f0_edite | Edité (true/false)
f0_clos | Dossier clôturé (0, 1, 5, 10 ou 15)
f0_cp_react | Coût de revient prévisionnel réactualisé

Gestion des trains de cadencements de fabrication

But : Regrouper certaines lignes de cadencements de fabrication en train.

Cela permet de les regrouper pour obtenir un gain de temps de production (réduction du temps de calage et/ou passage).

Dès la saisie d'un devis, on peut spécifier que les cadencements de fabrication font l'objet d'un regroupement en train.

Lorsque l'on génère une commande, cette information est reportée automatiquement (sur l'entête de la commande commerciale).

On peut la modifier manuellement.

Toutes les lignes de cadencement de fabrication issues d'une même commande commerciale sont regroupées, sur action de l'utilisateur dans un même train.

On accède à l'écran des trains via la visualisation de commande, par la touche CTRL-K (après avoir paramétré le lancement de l'action standard depuis la multi-sélection).

Dans la visu des commandes clients, si l'option de gestion des trains (Ogt) est activée, on peut sélectionner une liste de commande avec un numéro de train particulier.

Sur les écrans d'entête du devis, du transfert de devis en commande et d'entête de commande, on peut voir (et modifier) le flag de gestion des cadencements de fabrication par train dans le cas où la note GESTION_TRAIN_CADFAB est activée dans le #CF ATL.

Dans le cas contraire, la zone est forcée à N et elle n'est pas visible dans ces écrans.

Dans l'entête de commande, si le TYC A1[23] ne permet pas de gérer les cadencements de fabrication, alors la zone n'est pas accessible.

L'intégration dans PREACTOR n'est pas prévue dans ce développement.

Paramétrage

#CF ATL, note GESTION_TRAIN_CADFAB, car.21 = O (Oui)

v_cdem, option Ogt (Gestion des trains)

v_cdem, zones disponibles

Code calcul TP, caractère 1=T

#RP, Actions à réaliser sur une sélection multiple, action 2

Exemple

Dans la note LCT_MULTI_CONFIG, indiquez par exemple #RPVIT.

Dans le #RPVIT, paramétrez les notes suivantes :

LCT_MULTI_TITRE_01 Gestion des trains

LCT_MULTI_IMAGE_01 application_view_columns

LCT_MULTI_PARAM_01 ACT002[ec_num]

LCT_MULTI_REACT_01 O

Visualisation des commandes sans coût matière

Ce paramétrage permet de :

" visualiser les lignes de commandes sans coût matière

" réactualiser les indicateurs de rentabilité client d'une ligne de commande

" réactualiser les indicateurs de rentabilité client de plusieurs lignes de commandes

En amont de ce mode de visualisation :

Un code blocage automatique est positionné lorsque les indicateurs de rentabilité client n'ont pas pu être calculés (offre de vente associée au produit non trouvée, calcul de l'offre de vente impossible).

Ce code blocage peut être activé :

" lors de la saisie de la ligne de commande client

" lors de la réactualisation des indicateurs de rentabilité via le batch de réactualisation

Paramètre de lancement de la visualisation

A2[1,60] = selon vos besoins

A3[1,60] = VISUALISATION DES COMMANDES SANS COUT MATIERE

A4[25] = O Touche F25 (Rafraîchissement de la visualisation)

A4[43] = O Touche Control-J (Réactualisation de la ligne en cours

A4[44] = O Touche Control-K (Réactualisation après sélection des lignes

Notes sur le paramètre de lancement de la visualisation

Sélection des commandes à visualiser
S and ec_tyc in ("CD2","CD1","ATC") | Sélection des commandes de type CD2, CD1 et des avoirs de type ATC
S and (not exists ( S select * S from recap_couts S where rcp_soc = lc_soc S and rcp_origine = "CEV" S and rcp_numero = lc_num S and rcp_ligne = lc_lig S and rcp_categorie in ("GAM", "MAT")) | Sélection des lignes de commandes dont les indicateurs sont en anomalie ou non calculées (ni coût matière, ni coût gamme)
S or exists ( S select sum(rcp_cout) S from recap_couts S where rcp_soc = lc_soc S and rcp_numero = lc_num S and rcp_ligne = lc_lig S and rcp_categorie = "MAT" S and rcp_cout is not null S having sum(rcp_cout) = 0)) | Sélection des lignes de commandes avec des coûts matières mais dont la somme est égale à 0 (zéro)
Colonnes de la visualisation
V Clt*ec_cli*5**N*N* | Code client
V No Cde*lc_num*8*&&&&&&&&*N*N* | Numéro de commande
V Lig*lc_lig*2*#&*N*N* | Ligne de commande
V Produit*lc_prod*13**N*N* | Code produit
V Qté Cdée*lc_qtecde*7*### ##&*O*N* | Quantité commandée
V Sit*ec_c1*3**N*N* | Site de production
V A.C*TSC_LC_NU__RC_F*3* | Etat des indicateurs
V Etat*TSC_LC_NU__RC_G*30* | Etat du calcul des indicateurs
V Blo*code_blocage*3* | Code blocage sur la ligne de commande
V Statut du blocage*libl_statut_blocage*20* | Libellé long du statut du blocage
Détail de la visualisation
D Nom client : *nom_ec_cli*25** | Nom du client
D Réf Cde clt : *ec_ref*15** | Référence
D Libellé Pdt : *lib_lc_prod*40** | Libellé du produit
D Date Commande : *ec_datc*10*dd/mm/yyyy* | Date de commande
D FBI:*ec_texte*30** | Numéro de FBI
D Date Solde*lc_rat_date_solde*10*dd/mm/yyyy* | Date de solde
D ANNULEE*ec_annu*15** | Commande annulée
Ordre de tri de la visualisation
O01N**N*N** | Code client
O04N**N*N** | Numéro de commande
O11N**N*N** | Ligne de commande
Touches de fonction
AUTORISE_TOUCHE_F51 O | Autorise l'accès à la fonction F51 (Détail des coûts/Indicateurs de rentabilité client)
Lancement simple de programme
LCT_PROG_TITRE_001 Réactualisation des indicateurs LCT_PROG_IMAGE_001 g_detail LCT_PROG_PARAM_001 #UTRCT-N[lc_num|-|lc_lig+&&&] -B | Lancement du batch de réactualisation pour la ligne de commande en cours de sélection
Lancement multiple de programme
_CSEL | Activation de la colonne de sélection
LCT_MULTI_TITRE_01 Réactualisation des indicateurs LCT_MULTI_IMAGE_01 g_detail LCT_MULTI_PARAM_01 #UTRCT-N[lc_num|-|lc_lig+&&&] -B LCT_MULTI_REACT_01 O | Lancement du batch de réactualisation pour toutes les lignes de commandes qui seront sélectionnées par l'utilisateur
Configuration de calcul des indicateurs
PARAM_INDICATEURS #CFRCP | Paramétrage de configuration de calcul des indicateurs de rentabilité client
Paramètre de lancement de la saisie des devis
PARAM_CALCUL_DEVIS #SADA1 | Paramétrage de lancement de la saisie des devis (pour le recalcul)

Paramètre de lancement du batch de réactualisation des indicateurs

A2[6] = N Pas de prise en compte du TSC _RC

Notes sur le paramètre de lancement du batch de réactualisation des indicateurs

Sélection des commandes à réactualiser
S and ec_tyc in ("CD2","CD1","ATC") | Sélection des commandes de type CD2, CD1 et des avoirs de type ATC
Configuration de calcul des indicateurs
PARAM_INDICATEURS #CFRCP | Paramétrage de configuration de calcul des indicateurs de rentabilité client
Paramètre de lancement de la saisie des devis
PARAM_CALCUL_DEVIS #SADA1 | Paramétrage de lancement de la saisie des devis (pour le recalcul)

Visualisation des lignes de commandes sans coût matière -> Sélection des lignes de commandes à réactualiser (colonne de droite)

Visualisation des lignes de commandes sans coût matière -> Visualisation des lignes de commandes en anomalie (après réactualisation) :

Tableau de bord des indicateurs de rentabilité

Option Ohp

A2[3] = O

A2[42] = S

Notes de paramétrage pour le tableau de bord des indicateurs de rentabilité

S and ec_tyc = ec_tyc | Prise en compte de la table des lignes de commandes (cde2)
_VAR_a v_qtecde_dev | Définition des variables de calcul
_VAR_b N-hp_z4
_VAR_c N-hp_z5
_VAR_d N-hp_z6
_VAR_e N-hp_z7
_VAR_f N-hp_z8
_VAR_g surface_cde
_VAR_h lc_qtecde
_VAR_j poids_cde
_CALC_01 bc+ | Définition des formules de calcul
_CALC_02 bc+d+
_CALC_03 abc+-
_CALC_04 abc+-d-e-f-
_CALC_05 abc+-d-e-f-1000*g/
O20 1**N*N*** | Tri sur l'origine du client (cli.cl_orig)
O01 2**U*N*** | Tri sur le code client (cli.cl_code), en mode de cumul U (regroupement des lignes de commandes par code client, avec affichage des valeurs dans les colonnes de la visualisation)
E Region*libc_cl_orig *9**N*N* | Définition des colonnes à visualiser/éditer
E CLI*cl_code*6**N*N*
E Raison sociale*cl_nom*30**N*N*
E Agent*libl_cl_repr*20**N*N*
E MT HT*v_qtecde_dev*12*--------&.&&*O*N*
E POIDS*poids_cde*12*--------&.&&*O*N*
E SURFACE*surface_cde*12*--------&.&&*O*N*
E Matiere*CALC_01*12*--------&&&&*O*N*
E Conversion*N-hp_z6*12*--------&&&&*O*N*
E C.Direct*CALC_02*12*--------&&&&*O*N*
E C.Distrub*N-hp_z7*12*--------&&&&*O*N*
E C.Palettes*N-hp_z8*12*--------&&&&*O*N*
E DeltaP MAT*CALC_03*12*--------&&&&*O*N*
E Contribution*CALC_04*12*--------&&&&*O*N
D N Commande:*lc_num*8** | Définition des colonnes de détail pour la visualisation
D -*lc_lig*3*<<&*
D Ref cde Clt:*ec_ref*15**
D Date Cde:*ec_datc*10*dd/mm/yyyy*
F Origine*libl_cl_orig*12*** | Définition des colonnes à éditer dans un fichier
F Agn*cl_repr*3****
F NomAgn*libl_cl_repr*15***
F CLI*ec_cli*5*****
F Raison*cl_nom*30***
F MT HT*v_qtecde_dev*12*--------&.&&*O**
F MT TTC*v_qtecde_dev*12*--------&.&&*O**
F QTE*lc_qtecde*10*------&.&&*O**
F POIDS*poids_cde*10*------&.&&*O**
F SURFACE*surface_cde*10*------&.&&*O*
F Matiere*CALC_01*12*--------&.&&*O*
F Conversion*N-hp_z6*12*--------&.&&*O*
F C.Direct*CALC_02*12*--------&.&&*O*
F C.Distrub*N-hp_z7*12*--------&.&&*O*N*
F C.Palettes*N-hp_z8*12*--------&.&&*O*N*
F DeltaP MAT*CALC_03*12*--------&.&&*O*
F Contribution*CALC_04*12*--------&.&&*O*
F Cont/1000m² *CALC_05*12*--------&.&&*O*
F Date*ec_datc*8*dd/mm/yy***
F N° CDE*ec_num*8***
F Lig*lc_lig*4*###&*N*N*
F Référence*lc_prod*10***
F Désignation*lc_lib*40**
F Long*mp_lon*6*-----&*O**
F Larg*mp_lar*6*-----&*O**
F Haut*mp_hau*6*-----&*O**
F Code Famille*mp_fam*3***
F Famille*libl_mp_fam*30***
F Code ss Fam.*mp_sfm*3***
F ss Famille*libl_mp_sfm*30***
F Code CS1*mp_cs1*3***
F Lib.CS1*libl_mp_cs1*30***
F Code Secteur*mp_cs2*3***
F Secteur*libl_mp_cs2*30***
F Code ss Sect*mp_cs3*3***
F ss Secteur*libl_mp_cs3*30***
F Code CS4*mp_cs4*3***
F Code IP*libc_mp_cs4*10***
F Lib.CS4*libl_mp_cs4*30***
F Suiv*cl_suiv*3***
F NomSuiv*libl_cl_suiv*30***
F Type*ec_tyc*3***

Réactualisation du récapitulatif des coûts

Dans la saisie et/ou la visualisation des commandes clients, permettre de visualiser et de réactualiser le récapitulatif des coûts dans l'environnement Devis multi-métiers.

Remarques :

" Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients/Récapitulatif des coûts).

" Le récapitulatif des coûts est réactualisé via un recalcul simplifié à partir des tables du devis associé à la ligne de commande.

" Les indicateurs d'environnement CEV sont enregistrés dans le type M de l'historique de prix de revient (hist_pr)

" Les indicateurs d'environnement CER sont enregistrés dans le type N de l'historique de prix de revient (hist_pr)

" Le calcul de l'environnement réel n'est effectué que si des paramètres de configuration spécifiques sont renseignés (voir note commençant par CONFIG_DEG_DER_REEL).

Les notes suivantes doivent être paramétrées :

AUTORISE_TOUCHE_F51

CONFIG_DEG_DER_PREV

CONFIG_DEG_DER_REEL

PARAM_INDICATEURS

Si la note PARAM_INDICATEURS n'est pas paramétrée, les notes suivantes seront recherchées ici (paramètre de lancement de la saisie de commande).

Si elle est paramétrée, elle indique le paramètre de configuration (généralement #CF REC) où rechercher ces notes :

_VAR_INDIC_

_FOR_INDIC_

_TIT_INDIC*

CODE_BLOCAGE_RCP

LISTE_TYC_CALC_RCP

_SUP_REQ_FLE_TRA_RCP

_SUP_REQ_FLE_OPE_RCP


v_cde Consultation des commandes clients

Ce programme permet de visualiser les commandes avec 3 niveaux de visualisation

  1. Visualisation des entêtes des commandes sélectionnées

  2. Visualisation des lignes détail de la commande sélectionnée par la touche F8

  3. Visualisation du détail de la ligne détail sélectionnée par la touche F8

Options

Oar | Annulation des reliquats de stock (sorties réservées) lorsqu'on solde : - une commande - ou une ligne de commande - ou une ligne de nomenclature Recréation des reliquats de stock (Sorties réservées) lorsqu'on désolde une ligne de commande ou une ligne de nomenclature ou une ligne de cadencement
Oca | Pas de visualisation des commandes annulées
Oes | Critère de sélection écran simplifie
Ofd | Affichage si commande déjà facturée et délai
Oix | Visualisation des offres de prix (TYC = PRX)
Opx | Exclusion des commandes de TYC = PRX
Ose | Avec semaine 0
Osr | Pas de mise à jour du stock résultant
Ote | Solde des commandes de type TEXTILE
Ouv | Utilisation de l'unité de vente pour calculer le prix de vente issu de la table mat et le prix du mouvement de stock

Notes

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table cde3. Obligatoire. Exemple : TEX


v_cdemul Edition multiple des commandes clients

NON VISIBLE DANS VOLUAIDE

Options & valeurs alpha Notes Tri Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code client

Exemple : -N[cl_code]

Options

-Opt

Permet de ne pas afficher la ligne de total général

Valeur alpha 2

Caractère 1

Second écran de sélection (N)

Caractère 2

Choix de l'ordre du tri (O/N)

Caractère 3

Pas d'édition des lignes détail (O/N)

Caractère 4

Mécanique - Imprimerie (O/N)
N Mécanique
O Imprimerie

Caractères 5 à 7

Type de la commande principale (celui sur lequel on base la recherche)
Exemple CDA

Caractère 11

Type d'écran de saisie F7 détail prix (1 à 6)

1 Écran de saisie F7 détail prix standard - Stocké dans cde3

2 Écran de saisie F7 détail prix avec marge - Stocké dans cde3

3 Écran de saisie F7 détail prix avec marge, prix de revient et quantités saisies sans décimales - Stocké dans cde7

4 Écran de saisie F7 détail prix avec marge, prix de revient et quantités saisies avec décimales - Stocké dans cde7

5 Écran de saisie F7 détail prix standard avec quantités saisies sans décimales - Stocké dans cde7

6 Écran de saisie F7 détail prix standard avec quantités saisies avec décimales - Stocké dans cde7

7 Ecran de saisie F7 détail prix standard avec marge, prix de revient et quantités avec décimales, totalisation dans l'unité de la ligne de commande. Stocké dans cde7

Caractère 12

Edition des notes saisies (O/N) sur le client adresse livraison de la ligne de commande

Caractère 14

Edition en mode condensé (sauf entête)

Caractères 15 à 17

Longueur de la ligne éditable. Sert uniquement dans l'édition

Par défaut 350

Permet d'éditer une même ligne sur plusieurs lignes

Caractère 35

Edition d'un libellé entre ligne (O/N)

Caractère 36

Edition d'un entête société (O/N)

Caractère 45

Ouverture automatique de la 2ème (O/N) fenêtre critère sélection client

Caractère 46

Ouverture automatique de la 2ème (O/N) fenêtre critère sélection article

Caractère 47

Type de recherche code article par F7

1 Recherche normale (désignation, famille, etc.)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Caractère 48

Type de recherche code normalise par F7. Pas de contrôle

1 Recherche fichier articles

2 Recherche fichier ECMA

Caractère 54

Edition de l'adresse livraison (O/N)

Caractère 56

Edition montant et quantité (O/N)

N Montant en francs et quantité en unités

O Montant en kilofrancs et quantité en milliers

Caractère 60

Type d'écran de saisie commande (1/2)

1 Écran de saisie commande STANDARD

2 Écran de saisie commande VOLUPRIM

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES COMMANDES CLIENTS

Notes

SUP_REQ_CDE1 | 21 à 60 Supplément de requête sur cde1
SUP_REQ_CDE2 | 21 à 60 Supplément de requête sur cde2
SUP_REQ_MONT1_CDE1 | 21 à 60 Supplément de requête sur cde1 recherche amont 1
SUP_REQ_MONT1_CDE2 | 21 à 60 Supplément de requête sur cde2 recherche amont 1
SUP_REQ_MONT2_CDE1 | 21 à 60 Supplément de requête sur cde1 recherche amont 2
SUP_REQ_MONT2_CDE2 | 21 à 60 Supplément de requête sur cde2 recherche amont 2
SUP_REQ_AVAL1_CDE1 | 21 à 60 Supplément de requête sur cde1 recherche aval 1
SUP_REQ_AVAL1_CDE2 | 21 à 60 Supplément de requête sur cde2 recherche aval 1
SUP_REQ_AVAL2_CDE1 | 21 à 60 Supplément de requête sur cde1 recherche aval 2
SUP_REQ_AVAL2_CDE2 | 21 à 60 Supplément de requête sur cde2 recherche aval 2

Attention ! Les zones de table dans les suppléments de requête doivent être préfixées par le nom de la table.

Ordres de tris disponibles

Voir les notes commençant par O

01 | O_code_client (code client)
02 | O_num_cde_ppal (numéro de commande principale)
03 | O_lig_cde_ppal (ligne de commande principale)
04 | O_date_cde_ppal (date de commande principale)
05 | O_code_article (code article)

Liste des noms de zones autorisés

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Infos générales

Infos article ligne de commande

Pour les commandes principales

Pour les commandes amont1

Pour les commandes aval1

using - Voir #VI

Infos générales

cod_art | Code article d'un ligne de commande
cod_art_cli | Code article client
des_art | Désignation de l'article
cod_cli | Code client de la commande
nom_cli | Nom du client

Infos article ligne de commande

mp_smini | Stock mini
mp_smaxi | Stock maxi
mp_sdisp | Stock disponible
mp_sphy | Stock physique
mp_sres | Stock réservé
mp_sbes | Besoins - Non utilisé dans le calcul des besoins

Pour les commandes principales

num_cde_ppal | Numéro de commande principale
lig_cde_ppal | Numéro de ligne de commande principale
date_cde_ppal | Date de commande principale
date_appel_ppal | Date appel commande principale (lc_delrep)
type_cde_ppal | Type de commande principale
num_bl_ppal | Numéro de BL associé à la commande principale S'il existe plusieurs BL associés à la commande, on ne récupère que le premier.
bl_prov_ppal | Flag oui/non pour BL définitif/provisoire
num_fac_ppal | Numéro de facture associée à la commande principale (même remarque que pour les BL)
fac_edit_ppal | Flag oui/non pour facture éditée ou non
qte_cde_ppal | Quantité commandée sur une ligne de commande principale
qte_lan_ppal | Quantité lancée sur une ligne de commande principale
qte_fab_ppal | Quantité fabriquée sur une ligne de commande principale
qte_liv_ppal | Quantité livrée sur une ligne de commande principale
qte_fac_ppal | Quantité facturée sur une ligne de commande principale
ref_cde_cli_ppal | Zone lc_p3

Pour les commandes amont1

num_cde_am1 | Numéro de commande amont1
lig_cde_am1 | Numéro de ligne de commande amont1
date_cde_am1 | Date de commande amont1
date_appel_am1 | Date appel commande amont1 (lc_delrep)
type_cde_am1 | Type de commande amont1
num_bl_am1 | Numéro de BL associé à la commande amont1 S'il existe plusieurs BL associés à la commande, on ne récupère que le premier.
bl_prov_am1 | Flag oui/non pour BL définitif/provisoire
num_fac_am1 | Numéro de facture associée à la commande amont1 (même remarque que pour les BL)
fac_edit_am1 | Flag oui/non pour facture éditée ou non
qte_cde_am1 | Quantité commandée sur une ligne de commande amont1
qte_lan_am1 | Quantité lancée sur une ligne de commande amont1
qte_fab_am1 | Quantité fabriquée sur une ligne de commande amont1
qte_liv_am1 | Quantité livrée sur une ligne de commande amont1
qte_fac_am1 | Quantité facturée sur une ligne de commande amont1
ref_cde_cli_am1 | Zone lc_p3

Pour les commandes aval1

num_cde_av1 | Numéro de commande aval1
lig_cde_av1 | Numéro de ligne de commande aval1
date_cde_av1 | Date de commande aval1
date_appel_av1 | Date appel commande aval1 (lc_delrep)
type_cde_av1 | Type de commande aval1
num_bl_av1 | Numéro de BL associé à la commande aval1 S'il existe plusieurs BL associés à la commande, on ne récupère que le premier.
bl_prov_av1 | Flag oui/non pour BL définitif/provisoire
num_fac_av1 | Numéro de facture associée à la commande aval1 (même remarque que pour les BL)
fac_edit_av1 | Flag oui/non pour facture éditée ou non
qte_cde_av1 | Quantité commandée sur une ligne de commande aval1
qte_lan_av1 | Quantité lancée sur une ligne de commande aval1
qte_fab_av1 | Quantité fabriquée sur une ligne de commande aval1
qte_liv_av1 | Quantité livrée sur une ligne de commande aval1
qte_fac_av1 | Quantité facturée sur une ligne de commande aval1
ref_cde_cli_av1 | Zone lc_p3


Outil de génération du cadencement de livraison des commandes clients

Outil de génération du cadencement de livraison des commandes clients outil_generation_cde8

Cet outil génère les cadencements de livraison des commandes clients (Table cde8).

TYC A4[48] de la commande doit être à O ou A.

Aucun cadencement de livraison ne doit exister pour celle-ci.

Ligne de commande sans nomenclature

Une ligne de cadencement pour la ligne de commande est générée.

Les numéros de mouvement de stock (lc_nummvt et lc_nummvt3) de la ligne de commande sont stockés dans ceux de la ligne de cadencement (li_num_mvt et li_num_mvt3) puis remis à 0.

L'affectation des mouvements de stock est modifiée (EX : 05030010-001-000-001).

Le numéro de ligne de cadencement des lignes de bon de livraison est mis à 1.

Le numéro de ligne de cadencement des lignes de facture est mis à 1.

Ligne de commande avec nomenclature

Une ligne de cadencement pour la ligne de commande est générée.

Une ligne de cadencement pour chaque ligne de nomenclature est générée.

Les numéros de mouvement de stock (nc_nummvt et nc_nummvt3) de la ligne de nomenclature sont stockés dans ceux de la ligne de cadencement (li_num_mvt et li_num_mvt3) puis remis à 0.

L'affectation des mouvements de stock est modifiée (EX : 05030010-001-010-001).

Le numéro de ligne de cadencement des lignes de bon de livraison est mis à 1.

Le numéro de ligne de cadencement des lignes de facture est mis à 0.

Cet outil traite les commandes et les lignes de commande annulées.

En fin de traitement, le compte-rendu de la génération est visualisé.

Celui-ci est éditable (Touche F8).

PENSEZ A FAIRE UNE SAUVEGARDE DES TABLES CDE2, CDE4, CDE8, STK0, BLV2 et FAC1 AVANT DE LANCER L'OUTIL !

Options

-B | Mode batch
Osi | Simulation. Pas de génération de la table cde8

Notes

_CODES_VALID_APL_ | 21 Code validation administration des ventes par défaut (O/N, O par défaut) 22 Code validation production par défaut (O/N, O par défaut) 23 Code validation Iogistique par défaut (O/N, O par défaut
SUP_REQ_CDE1 | 21,60 Supplément de requête sur la table cde1. Obligatoire en mode batch EX : and ec_annu = "N"
SUP_REQ_CDE2 | Supplément de requête sur la table cde2. Obligatoire en mode batch EX : and lc_annu = "N"

Paramètres nécessaires

TYC A4[48]

Saisie des cadencements de livraison

O Oui

A Automatique

N Non (Valeur par défaut)


Etat des commandes

Etat des commandes cde_ed1

Options

-q | Permet de passer au programme d'édition les critères d'édition Le dernier mot de la requête doit aussi se terminer par –q Exemple 1 cde_ed1.4ge -qcde2.lc_afa <> 0-q Exemple 2 cde_ed1.4ge -qcde1.ec_sold = \"N\"-q Attention, ne pas mettre de and ou or
-ONS | Configuration type non standard (type Lemercier). Colonnes d'édition = BDFGEHJKLMNOPQRC
-Ocd | N'édite pas de total commande
-Ocl | N'édite pas de total client
-Oee | Sélection écran simplifiée
-Oes | Déduction de l'escompte
-Oge | N'édite pas de total général
-Old | N'édite pas de ligne détail
-Ops | N'édite pas les lignes de production seules (FBI FBP et FB1 ligne de commande 1)
-Ore | Déduction de la remise
-Osp | Saut de page entre chaque représentant
-Osl | Saut de ligne entre chaque ligne de commande
-Otd | N'édite pas de total délai répondu (le total délai n'est édité que si le type de tri par délai est choisi)
-One | Edition des notes d'entête de commande après chaque commande
-Onl | Edition des notes de lignes de commandes après chaque ligne de commande
-Ono | Edition du libellé Observations si notes, sinon le libellé Observations est toujours édité même si pas de notes Fonctionne avec les options –One et –Onl.
-Orc | Saut de page au changement de client
-Ori | Répétition des informations (code client, référence client, nom client, numéro de commande) même si pas de rupture
-Otn | Pas d'édition de ligne de tirets avant l'édition des notes et pas d'édition de ligne d'astérisques après les notes de ligne
-Odc | Restriction aux dossiers clos (f0_clos > 5)


Reste à facturer

Reste à facturer rst_afa

Options

-q | Est utilisée pour passer au programme d'édition les critères d'édition. Le dernier mot de la requête, doit aussi se terminer par -q Exemple rst_afa.4ge -sMPR -d8809 -qcde2.ec_afa <> 0-q
-Ocd | N'édite pas de total commande
-Odc | Date de livraison = délai client (Par défaut date de livraison = délai répondu)
-Odl | N'édite pas un total par mois de livraison et pas de tri sur la date de livraison
-Oes | Déduction de l'escompte
-Oge | N'édite pas de total général
-Ol0 | Pas d'impression des lignes à 0
-Ola | Impression des lignes avoirs
-Olc | N'édite pas une ligne par commande
-Old | N'édite pas de ligne détail
-Oln | Impression des lignes négatives
-Ore | Déduction de la remise
-Ocs | Impression d'un cumul par suivi d'affaire
-Ocr | Impression d'un cumul par représentant

Combinaisons d'options autorisées

-Ocdlc | Edition des lignes détail
-Olc | Edition des lignes détail avec un total par commande
-Oldcd | Edition d'une ligne par commande

4 possibilités de tri

Si édition sans total par mois de livraison

Tri par client, date commande et numéro commande

Tri par No commande

Si édition avec un total par mois de livraison

Tri par date livraison, client et numéro commande

Tri par Date livraison et No commande

(Ouverture d'une fenêtre pour demander le choix)

Calcul de la quantité restante à facturer

Si qteliv = 0 | qteraf = qtecde - qtefac
Si qteliv != 0 |
Si solde = N | qteraf = qtecde - qtefac
Si solde = O | qteraf = qteliv - qtefac


Chapitre inexistant

Désolé !

Ce chapitre n'est pas encore rédigé...

C'est urgent ? Envoyez-moi un mail !


Liste des estampilles

Liste des estampilles liste_estampille

Options

Ofe

Ajout de la table fab_1_etat dans la requête principale

Valeur alpha 2

Caractères 1 à 6 | Client nomenclature. Par défaut, #SOC
Caractère 7 | Référence architecture. Par défaut, N
Caractère 8 | Référence qualité. Par défaut, Q

Valeur alpha 3

Caractères 1 à 6

Type et code du paramètre d'imprimante

Notes

MACHINE_FAB_1_ETAT

21,26 Code machine à prendre en compte dans la requête principale (fab_1_etat)

Permet de paramétrer la liste des machines à prendre en compte pour l'édition des commandes estampillées.

Par défaut, le critère de date s'appuie sur la dernière machine utilisée (machine suiveuse non renseignée).

Une ligne de note par code machine à prendre en compte

L'option Ofe doit être active.

_SUP_REQ_CDE1

21,60 Supplément de requête à la table cde1

_SUP_REQ_CDE2

21,60 Supplément de requête à la table cde2

_SUP_REQ_FAB_1_ETAT

21,60 Supplément de requête à la table fab_1_etat

L'option Ofe doit être active.

Paramètres associés

PC, alpha1[1,3] (structure)


Edition de l'historique des charges

Edition de l'historique des charges edition_histo_charge

Notes

_SUP_REQ_CHARGE_ILOT

21 à 60 Supplément de requête sur la table charge_ilot


Génération des factures d'avoir à partir des mouvements de stock

Génération des factures d'avoir à partir des mouvements de stock gen_fad_mvts_stk

Ce programme est opérationnel à partir de la V. 4.0.182.2

Génération des FAD à partir des mouvements de stock

Seuls les mouvements d'entrée normale avec le code client renseigné seront traités.

Valeurs numériques

1 | Numéro du compteur (nul par défaut)
2 | inutilisée

Options

-B | Mode Batch
Omp | Sélection des mouvements de stock sur le mois précédent - Uniquement en Batch

Valeur alpha 2

A2[1,3] | TYC des commandes FAD - Le TYC de rattachement doit être à FAD - Obligatoire Exemple : FAD
A2[4,6] | TSC client - Obligatoire - Indique le mode de facturation des frais de stockage et le code article facturé. Exemple : FST
A2[7,9] | Type de note de la ligne de commande - Obligatoire Les notes de la ligne de commande de ce type de note contiendront le détail des mouvements de stock pris en compte Exemple : FST
A2[10,15] | Type et code de la recherche de tarif - Obligatoire
A2[16,18] | Code tarif des lignes de commande - Facultatif Exemple : FST
A2[19,26] | Date de début de sélection des mouvements de stock (JJMMAAAA) La date de début ne peut pas être supérieure à la date de fin. Obligatoire si mode Batch et pas d'option -Omp Inutilisée dans les autres cas
A2[27,34] | Date de fin de sélection des mouvements de stock (JJMMAAAA) La date de fin ne peut pas être inférieure à la date de début. Obligatoire si mode Batch et pas d'option Omp Inutilisée dans les autres cas

Notes

FIC_ANOMALIE | 21,60 Nom du fichier des anomalies Exemple gen_fad/gen_fad_ano.txt
FIC_TRACE | 21,60 Nom du fichier de trace Exemple gen_fad/gen_fad_tra.txt
_SUP_REQ_STK0 | 21,60 Supplément de requête de la table des mouvements de stock Supplément de requête à ajouter impérativement _SUP_REQ_STK0 and not exists(select ic_cle from info_c _SUP_REQ_STK0 where ic_soc = "SOC" _SUP_REQ_STK0 and ic_char30 = "LISA" _SUP_REQ_STK0 and ic_cle[1,15] = s0_prod _SUP_REQ_STK0 and ic_cle[16] = "-" _SUP_REQ_STK0 and ic_cle[17,21] = s0_num _SUP_REQ_STK0 and ic_type = "4" _SUP_REQ_STK0 and ic_ts = "_LI" _SUP_REQ_STK0 and ic_char3_1 = "T")

Paramètres nécessaires

TSC FST | (ou autre TSC indiqué en A2[4,6] Facturation des frais de stockage
Paramétrage de la mise à jour du flag d'informations complémentaires :
#CF STK A4[4] = O | Utilisation de la gestion des flag/deflag
TSC _LI | (ou autre TSC indiqué dans la note MAJ_FLAG_INFO_C du TMV (voir ci-dessous) TSC LISA
TMV | Note MAJ_FLAG_INFO_C Caractère 21 = F Caractères 22,24 = _LI Caractère 25 = 4 Caractères 26,28 = T Caractères 29,60 = [s0_prod+C15|-|s0_num+<<<<<]


Transfert des mouvements de stocks d'entrée et de sortie vers SAGE

Transfert des mouvements de stocks d'entrée et de sortie vers SAGE tr_stock_sage

Transfert des mouvements de stock d'entrée et de sortie vers SAGE

Si l'option Osi n'est pas activée et que le mouvement de stock est transféré, celui-ci est mis à l'état Transféré.

Une note rattachée au mouvement de stock commençant par TRF_STOCK_VERS_SAGE est créée avec le type de note paramétré en A2[6,8] du paramètre de lancement.

Par défaut, les mouvements de stock d'entrée sont rattachés à un bon de réception car ils sont générés par la réception des commandes d'achat.

L'option Osb est activée si les mouvements de stock d'entrée sont générés par la déclaration de production et donc pas rattachés à un bon de réception.

Valeurs numériques

N1 | Compteur chrono des numéros de pièce. Le type de chrono des numéros de pièce est s.
N2 | Délai d'attente en minutes. Le programme multiplie la valeur par 60 pour obtenir des secondes. Valeur par défaut : 1 seconde

Options

Oan | Ajout des zones 19 à 20 (Analytique)
Ocm | Pas de sélection sur le fichier des articles
Ode | Ajout des zones 14 à 18 (Devise)
Oen | Transfert des mouvements de stock d'entrée vers SAGE L'option Osn ne doit pas être activée.
Oif | Pas d'initialisation du fichier de transfert
Osb | Mouvements de stock d'entrée sans bon de réception Les mouvements de stock d'entrée sont générés par la déclaration de production. L'option Oen doit être activée.
Osi | Simulation. Les mouvements de stock ne sont pas mis à l'état Transféré.
Osn | Transfert des mouvements de stock de sortie vers SAGE. L'option Oen ne doit pas être activée.

Valeur alpha 2

A2[1,3] | Code journal du transfert des stocks vers SAGE. Obligatoire Exemple : ST
A2[4,5] | 4 5 Type de pièce du transfert des stocks vers SAGE. Obligatoire Exemple : OD
A2[6,8] | 6 8 Type de note du transfert des stocks vers SAGE. Obligatoire Exemple : SVS

Valeur alpha 3

A3[1,8] | Compte d'achat par défaut. Obligatoire - La recherche se fait d'abord sur SFM puis sur FAM. Exemple : 381309
A3[9,16] | Compte de consommation par défaut. Obligatoire - La recherche se fait d'abord sur SFM puis sur FAM. Exemple : 613090
A3[17,24] | Compte de stockage par défaut. Obligatoire - La recherche se fait d'abord sur SFM puis sur FAM. Exemple : 313090
A3[25,32] | Compte des frais d'approche. Obligatoire Exemple : 381900

Notes

FIC_ANOMALIE_STOCK | 21,60 Nom du fichier d'anomalie. Obligatoire
FIC_HISTO_STOCK | 21,60 Nom des fichiers d'historisation. Obligatoire
FIC_LOCK | 21,60 Nom du fichier de verrouillage général. Obligatoire
FIC_LOCK_STOCK | 21,60 Nom du fichier de verrouillage du fichier de transfert. Obligatoire
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume. Obligatoire
FIC_NOM_STOCK | 21,60 Nom du fichier de transfert. Obligatoire
FIC_TRACE_STOCK | 21,60 Nom du fichier de trace. Obligatoire
L1 | 3,60 Lignes de texte concaténées pour en faire une seule. La ligne sera mise en début du fichier de transfert. 180 caractères maxi Exemple : L1ge
SUP_REQ_MAT | 21,60 Supplément de requête sur les articles (table mat). Obligatoire en mode BATCH si le supplément de requête sur les mouvements de stock n'est pas renseigné.
SUP_REQ_STK0 | 21,60 Supplément de requête sur les mouvements de stock (table stk0) Obligatoire en mode BATCH si le supplément de requête sur les articles n'est pas renseigné.

Paramètres nécessaires

FAM | Notes (prioritaires sur celles du paramètre de lancement) COMPTE_ACHAT_SAGE COMPTE_CONSO_SAGE COMPTE_STOCK_SAGE
SFM | Notes (prioritaires sur les notes de FAM) COMPTE_ACHAT_SAGE COMPTE_CONSO_SAGE COMPTE_STOCK_SAGE


Intégration de mouvements de stock

Intégration de mouvements de stock G_integration_stock

Ce programme permet l'Intégration de mouvements de stock à partir d'un fichier texte paramétrable.

Note : pour ne pas mettre à jour le stock résultant, utilisez #CF ATL A4[48].

Options

Opp

Les entrées normales sont valorisées au PAMP de l'article au lieu du prix de vente

Notes

CHAMP_FICHIER CTRL_CHAFIC_UNICITE | 21,38 Nom du champ. Obligatoire. Tous les champs de la table stk0 41,43 Position de début du champ. Obligatoire 45,47 Longueur du champ. Obligatoire Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique. Fonctionne avec la note CHAMP_FICHIER) O chaque nom de champ doit être unique (par défaut) N pas de contrôle
CONSTANTE_FICHIER | 21,38 Nom du champ. Obligatoire. Tous les champs de la table stk0 41,60 Constante du champ. Obligatoire
FIC_ANOMALIE | 21,60 Nom du fichier des anomalies. Obligatoire
FIC_STOCK | 21,60 Nom du fichier stock à intégrer. Obligatoire
FIC_TRACE | 21,60 Nom du fichier de trace. Obligatoire
TMV_ENT_DEF | 21,23 Type de mouvement d'entrée par défaut. Facultatif
TMV_SOR_DEF | 21,23 Type de mouvement de sortie par défaut. Facultatif


Génération des messages EDI d'encours et d'inventaires

Génération des messages EDI d'encours et d'inventaires generation_invrpt_wiprpt

Selon les options activées, ce programme génère :

- un fichier des messages INVRPT (Inventory Report) à partir des stocks par lots/lieux (table stk_lot_lieu) - option Oir

Les stocks par lots - lieux ne sont pas regroupés.

Un enregistrement détail INVDET pour un stock par lots - lieux.

- un fichier des messages WIPRPT (Work in Progress Report) par client à partir des mouvements de stock (table stk0) - Option Owp

Les mouvements de stock ne sont pas regroupés.

Un enregistrement détail WIPREC pour un mouvement de stock.

Les fichiers suivants sont générés :

ETU_EDI_format fichiers EDI INVRPT

ETU_EDI_format fichiers EDI WIPRPT

L'historisation peut se faire dans un répertoire séparé.

Attention, pas de reprise automatique de l'existant !

Les fichiers d'historisation déjà présents devront être recopiés manuellement dans le répertoire d'historisation.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code client

Exemple : -N[ec_cli]

Options

-N | Code client
Oir | Génération des messages INVRPT
Owp | Génération des messages WIPRPT

Valeurs numériques

1 | Compteur chrono des messages INVRPT Le type de chrono des messages INVRPT est i.
2 | Compteur chrono des messages WIPRPT Le type de chrono des messages WIPRPT est w.

Valeur alpha 2

1,4 | Délai d'attente en minutes Le programme multiplie la valeur par 60 pour obtenir des secondes. Valeur par défaut : 1 seconde
5 | Numéro de version des messages INVRPT 1 INVRPT Version 1
6 | Numéro de version des messages WIPRPT 1 WIPRPT Version 1

Notes triées

FIC_ANOMALIE_INVRPT | 21,60 Nom du fichier d'anomalie de la génération des messages INVRPT
FIC_ANOMALIE_WIPRPT | 21,60 Nom du fichier d'anomalie de la génération des messages WIPRPT
FIC_HISTO_INVRPT | 21,60 Racine du nom du fichier d'historisation de transfert de la génération des messages INVRPT Le nom du fichier de transfert est composé de la racine suivie du code client puis d'un compteur.
FIC_HISTO_WIPRPT | 21,60 Racine du nom du fichier d'historisation de transfert de la génération des messages WIPRPT Le nom du fichier de transfert est composé de la racine suivie du code client puis d'un compteur.
FIC_LOCK | 21,60 Nom du fichier de verrouillage général Plus d'infos
FIC_LOCK_INVRPT | 21,60 Nom du fichier de verrouillage de la génération des messages INVRPT Plus d'infos
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume Plus d'infos
FIC_LOCK_WIPRPT | 21,60 Nom du fichier de verrouillage de la génération des messages WIPRPT Plus d'infos
FIC_RACINE_INVRPT | 21,60 Racine du nom du fichier de transfert de la génération des messages INVRPT Le nom du fichier de transfert est composé de la racine suivie du code client.
FIC_RACINE_WIPRPT | 21,60 Racine du nom du fichier de transfert de la génération des messages WIPRPT Le nom du fichier de transfert est composé de la racine suivie du code client.
FIC_TRACE_INVRPT | 21,60 Nom du fichier de trace de la génération des messages INVRPT
FIC_TRACE_WIPRPT | 21,60 Nom du fichier de trace de la génération des messages WIPRPT
SUP_REQ_STK0 | 21,60 Supplément de requête sur la table stk0 pour la génération des messages WIPRPT
SUP_REQ_STK_LOT_LIEU | 21,60 Supplément de requête sur la table stk_lot_lieu pour la génération des messages INVRPT

Paramètres associés

cde | Notes PARAM_MSG_ORDRSP et TSC_CLI_MSG_ORDRSP
edi_cde_aviexp | A3[1] = 4 (AVIEXP V4)


Consultation des stocks

Consultation des stocks consult_stock

Programme permettant de consulter les stocks d'un ou d'une liste de produit.

Cette consultation est accessible depuis un écran de présélection de type v_mat ou depuis une touche de fonction (F35) sur la saisie des produits (simplifiée ou normale) et sur la visualisation des commandes.

Le premier tableau présentant la liste des produits sélectionnés se construit exactement comme la visualisation des matières (v_mat).

Les colonnes sont toutes paramétrables.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Code produit

Exemple : -N[fi_prod_ent]

Options

Ocl | Code langue par défaut dans la saisie des libellés étrangers
Oli | Libelle par défaut dans les libellés étrangers égal au libellé article
Oxs | Ne pas passer par l'écran de sélection Plus d'info dans l'aide du #VI Note : contrairement aux autres programmes disposant de l'option OXs, ce programme ne dispose pas de l'option Oxd.

Valeur alpha 2

1 | Mode de recherche des stocks 1 Lieu (par défaut) 2 Lot_lieu
2,3 | Code numérique de restriction pour complément de sélection de la quantité en stock des affiches associées au code produit (tableau n°3 des affiches) 01 par défaut
4,5 | Code numérique de restriction pour complément de sélection de la quantité en stock des produits composants une affiche (tableau n°5 des articles) 01 par défaut

Valeur alpha 3

1,6

Type et code du paramètre de configuration des mouvements de stocks

Notes

ACCES_VOLUEDIT | 21,26 Type et code du paramètre de lancement de l'édition VoluEdit INUTILISE
CODE_LIEN_TABLES | 21,23 Code du lien entre tables (F29), tributaire d'une option non encore implémentée
RESTRIC_STOCK_NUM_xx | où xx = Code numérique correspondant au numéro de restriction utilisée pour la recherche des stocks 21,60 Complément de sélection pour la recherche de stock
_SUP_REQ_CONSO_STK0 | 21,60 Supplément de requête sur la table stk0 pour l'alimentation de la colonne conso_12_mois.
_SUP_REQ_RECH_LIEN | 21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)
TYPES_NOTES_EDITEES | 21,60 Types de notes éditées INUTILISE

Tous les champs paramétrables dans v_mat sont repris pour ce programme.

Deux nouveaux types de champs sont disponibles :

stock_physique_pf_XX : stock physique du produit avec restriction particulière.

stock_dispo_pf_XX : stock disponible du produit avec restriction particulière.

XX représente le numéro de restriction à appliquer pour cette colonne.


Interface VoluPalette

Interface VoluPalette volupalette

Ce programme remplace P1 P2 P3 (Entrée automatique en stock de PF).

Intégration d'un fichier de codes à barres dans la table cab_production.

Valeurs possibles du statut

Options

Ocf

Prise en compte du cadencement de fabrication

Explications au bas de cette page

Oed

Nouveau fonctionnement pour l'alimentation de la table cab_production à partir d'un fichier

Pour la gestion de palette hétérogène en quantité, alimentation d'un détail.

Nouvelle table cab_production_det

Le format de fichier est sous la forme de lignes d'entête et de lignes de détail

Le premier caractère n'est pas paramétré (c'est forcément E ou D).

Le fichier doit toujours commencer par une ligne de type Entête et se terminer par une ligne de type Détail.

Il doit toujours y avoir une ligne Détail après une ligne Entête.

La description des zones utilisables pour l'entête reste la même que celle utilisée pour le format simple (sans entête ni détail).

Le caractère 01 est réservé au type de ligne (E ou D).

Onp

Intégration en prenant compte du nombre de palettes renseigné dans le fichier FGDATA

Exemple

Enregistrement FGDATA : 3 palettes de 150, avec une quantité de dernière palette de 125

Avec l'option Onp, on créera dans la table d'intégration :

2 palettes de 150

1 palette de 125

soit 2 mouvements de stocks de fabrication à la fin de la déclaration de production.

Sans l'option Onp, on créera autant d'enregistrements que de palettes, soit :

1 palette de 150

1 palette de 150

1 palette de 125

soit 3 mouvements de stocks de fabrication à la fin de la déclaration de production.

Op1

Option papeterie (il peut être nécessaire de retrouver la commande commerciale par la laize de la bobine ou le format de la feuille)

Voir les notes COUPE et LAIZE

Voir aussi la note _USING_CONTENEUR dans #CF CAB

Oqn

Quantité palette négative

La seule quantité négative autorisée par l'interface VoluPalette est -9999.

Si cette option est paramétrée, toutes les quantités négatives sont autorisées.

Ore

Mode de reprise

Le fichier est construit différemment (sans OF et/ou sans produit).

Dans ce cadre, on intègre un fichier (module P1) qui ne contient pas d'OF et éventuellement pas de code produit non plus.

Le but est de pouvoir trouver un produit correspondant aux caractéristiques fournies dans le fichier si le produit-ci n'est pas inscrit dans le fichier.

En cas d'échec, il y a création automatique de ce produit.

Il faut ensuite trouver une commande de fabrication pour ce produit et la mettre à jour avec les quantités du fichier.

Dans le cas où l'on ne trouve pas de commande, il faut en générer une.

Une fois le fichier intégré, les enregistrements sont traités par le module d'entrée en stock (qte_prod, fonctionnement appelé "P2P3").

Valeur alpha 2

A2[1] | Numéro de palette obligatoire (O/N, O par défaut) Voir qte_prod option Otm
A2[2] | Suppression du fichier après traitement (O/N, N par défaut

Notes

ATTENTE_LIB_SERVICE

21,24 Temps en secondes d'attente de libération du verrou du programme externe

ATTENTE_LIB_VSW

21,24 Temps d'attente pour libérer le verrou du programme Volume

CODES_STATISTIQUES

Codes statistiques pour la génération du produit

21,23 CS1

24,26 CS2

27,29 CS3

30,32 CS4

COMPLETER_RGT2

La présence de cette note permet de remplir le lieu 2 de la table RGT2 avec des x s'il est vide.

Permettre de remplir le lieu de rangement 2 de la table cab_production avec uniquement des x si l'utilisation des préfixes palette est paramétrée sur le #CF ATL (A3[33] et A3[34]) et si les lieux de rangement 2 du fichier et par défaut ne sont pas renseignés.

FICHIER_CAB

21,60 Nom du fichier à traiter - Obligatoire

FICHIER_CAB_REP

21,60 Répertoire du fichier à traiter - Facultatif

FICHIER_ERREUR

21,60 Nom du fichier des erreurs

FICHIER_HIS_REP

21,60 Répertoire historique du fichier traité - Facultatif

FICHIER_LOCK_SERVICE

21,60 Nom du fichier de lock du programme externe

FICHIER_LOCK_VS

21,60 Nom du fichier de lock Volume Software

FICHIER_TRACE

21,60 Nom du fichier trace

FICHIER_UNICITE_EXE

21,60 Nom du fichier qui garantit l'exécution d'un programme à la fois

FORMAT_DATE_ACQUIS

21 Format de la date d'acquisition dans le fichier

1 JJ/MM/YYYY (par défaut)

2 YYYYMMJJ

FORMAT_HEURE_ACQUIS

21 Format de l'heure d'acquisition dans le fichier

1 HH.MM (par défaut)

2 HHMM

GESTION_ETAT_LIEU_2

21 Gestion de l'état du lieu 2 (O/N, O par défaut)

Voir aussi qte_prod, option Oie

HISTORISATION

Active l'historisation du fichier à traiter.

L'historisation consiste à faire une copie du fichier avec le même nom suivi de l'extension .his.

On ne conserve que le dernier fichier traité.

LIEU_RGT1_DEF

21,23 Lieu de rangement 1 par défaut

LIEU_RGT2_DEF

21,23 Lieu de rangement 2 par défaut

LISTE_TYC_INTERDIT

Interdire des OF en fonction du TYC

21,50 Possibilité de saisir 10 TYC, tous les 3 caractères.

OPTION_TYC_REPRISE

Options pour la recherche et la génération de commande

21,23 Code TYC

24,24 Numérotation annuelle O/N

25,26 Numéro de compteur pour la génération de commande

27,34 Numéro de la commande sur laquelle on s’appuiera pour la génération d’une nouvelle commande de fabrication

35,37 Code TVA pour la génération de commande. Il est obligatoire dans la ligne de commande. Il provient de la fiche matière, mais n’est pas toujours renseigné. Il sera le code par défaut.

Zones du fichier

Remarque concernant les notes où il est question d'indice de début et d'indice de fin

Les indices de début et de fin sont codés sur 2 caractères, soit :

21,22 Indice de début

23,24 Indice de fin

Sous GENERO, ces indices peuvent être codés à l'ancienne méthode (sur 2 caractères) ou à la nouvelle méthode (3 caractères).

21,23 Indice de début

24,26 Indice de fin

Le programme détecte automatiquement la méthode adoptée.

En revanche, vous ne pouvez pas mixer les 2 méthodes.

CODE_BARRES | Code à barres 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin Alimente la zone cb_cab
COMMENTAIRE | Déclaration de production - Alimentation depuis la table la table cab_production Commentaire 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
CONDITIONNEMENT | Code du conditionnement 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
COUPE | Pour la papeterie (option Op1) Coupe 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
DATE_ACQUISITION | Déclaration de production - Alimentation depuis la table la table cab_production Date d'acquisition (sous la forme 01/01/2011) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
DET_CODE_BARRES | 21,26 (ou 21,24) Code à barres ou numéro de palette
DET_NOMBRE_COLIS | 21,26 (ou 21,24) Nombre de colis
DET_NOMBRE_ART_COLIS | 21,26 (ou 21,24) Nombre d'articles par colis
DET_PAL_PRELEVEMENT | 21,26 (ou 21,24) Prélèvement (O/N)
ENTITE | Numéro d'entité 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
GRAMMAGE | Grammage 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
HEURE_ACQUISITION | Déclaration de production - Alimentation depuis la table la table cab_production Heure d'acquisition (sous la forme 09.25) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin La date et l'heure d'acquisition seront utilisées pour alimenter la zone de la table cab_production cb_datim_acq_cab.
LAIZE | Pour la papeterie (option Op1) Laize 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
LIEU_RGT1 | Lieu de rangement 1 (optionnel) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin Nécessite la note LIEU_RGT2
LIEU_RGT2 | Lieu de rangement 2 (optionnel) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin Nécessite la note LIEU_RGT1
LIG_CADENCEMENT | 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
LIGNE_OF | Numéro de ligne d'ordre de fabrication (obligatoire) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
MANDRIN | Diamètre du mandrin 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
NB_COLIS | Nombre de colis 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
NOMBRE_PALETTE | Nombre de palette (obligatoire avec option Onp) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
NUMERO_OF | Numéro d'ordre de fabrication (obligatoire) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin Le N° est de la forme 11070001-1-1-1 Le dernier représente le numéro de référence, mais ne sera pas utilisé. Alimente les zones suivantes : Numéro d'OF (cb_numero_cde) Ligne d'OF (cb_ligne_cde) Ligne de cadencement (cb_lig_cad) Numéro d'entité (cb_entite)
NUMERO_PALETTE | Numéro de palette (optionnel avec option Onp) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
PAL_PRELEVEMENT | Flag palette de prélèvement 21,22 (ou 21,23) Position de début 23,24 Position de fin Alimente la zone cb_pal_prelevement
PRESENTATION | Présentation (Bobine/Format) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
PRODUIT | Code produit VoluPack 21,22 (ou 21,23) Position de début 23,24 (ou 24,26) Position de fin Alimente la zone cb_pf
QTE_PAR_COLIS | Quantité par colis 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
QUALITE | Qualité 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
QUANTITE_DER_PALETTE | Quantité de la dernière palette (obligatoire avec option Onp) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
QUANTITE_PALETTE | Quantité par palette (obligatoire) 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin
TYPE_EVENEMENT | Type d'événement 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin Doit avoir pour valeur dans le fichier reçu de l'interface IMAGE : A pour un ajout (par défaut) D pour une annulation Permet de recevoir de l'interface IMAGE l'ordre d'annuler l'entrée d'une bobine faite par la déclaration de production. Il ne doit pas y avoir de mouvement autre qu'un mouvement d'entrée sur cette bobine à annuler. Une fois la bobine annulée, il ne sera plus possible de l'entrer de nouveau en stock. Cette note est dédiée à la papeterie.
TYPE_MVT | Déclaration de production - Alimentation depuis la table la table cab_production Type de mouvement 21,22 (ou 21,23) Indice de début 23,24 (ou 24,26) Indice de fin

Autres paramètres

qte_prod Option Orb

Lors du rebadgeage d'une étiquette, on remet à jour le stock sans annuler le mouvement de stock précédent.

On ne génère plus une anomalie de type 5.

Déclaration de production - Alimentation depuis la table la table cab_production

Ajout de nouvelles zones dans la table cab_production, alimentée par volupalette.

1) La zone cb_type_mvt, type de mouvement qui sera pris en compte en priorité dans la déclaration de production

2) La zone cb_commentaire, qui alimentera la table des notes (stk0_notes) liée au mouvement d'entré qui sera généré lors de la déclaration de production.

La zone cb_datim_acq_cab peut elle aussi être alimentée à partir d'un fichier.

Dans la déclaration de production, à partir de l'intégration de la table cab_production, on pourra initialiser la date du mouvement d'entré avec la date d'acquisition contenue dans la table.

Paramétrage

volupalette | Notes TYPE_MVT - COMMENTAIRE - DATE_ACQUISITION - HEURE_ACQUISITION - FORMAT_DATE_ACQUIS - FORMAT_HEURE_ACQUIS (voir ci-dessus dans les notes)
qte_prod A4[14,16] | Type de la note qui alimentera la table des notes sur stock (stk0_notes)
qte_prod Option Ocd | Dans le traitement de tâche de fond (option Otf), permet si elle est renseignée, de forcer la date du mouvement d'entrée avec la date cb_datim_acq_cab de la table cab_production.

Alimentation de la table cab_production - Nouvelles zones à transmettre pour prendre en compte les cadencements de fabrication

Spécifique • V. 4.0.195.2

Structure du fichier

Zones | Caractères | Explication
CODE_BARRES | 1 à 6 | numéro de code barre, numérique sur 6
NUMERO_OF | 7 à 24 | sous la forme 11070001-1-1-1-1
QUANTITE_PALETTE | 25 à 29 | quantité de la palette
NB_COLIS | 30 à 34 | nombre de colis
QTE_PAR_COLIS | 35 à 39 | Quantité par colis
PAL_PRELEVEMENT | 40 à 40 | Palette de prélèvement O/N
COMMENTAIRE | 41 à 42 | Commentaires (F)
DATE_ACQUISITION | 101 à 110 | Date d'acquisition dans EGEMIN (F)
HEURE_ACQUISITION | 111 à 114 | Heure d'acquisition dans EGEMIN (F)
PRODUIT | 115 à 129 | Code produit sur la palette
NUMERO_PALETTE | 131 à 132 | Numéro de palette (ne sera pas saisie)

Les zones de types (F) facultatives peuvent être omises.

Exemple de fichier cabprod.txt

00000110010323-1-1-1-1 001000000400025Otest de récupération de stock pour xxx entité 1 20110630 1215PS32618-0000066

00000210010324-1-1-1-1 001500000300050Ntest de récupération de stock pour xxx entité 1 20110630 1216PS32984-0000023

1ière ligne

Palette n° 1, commande 10010323-1, cadencement 1, entité 1, quantité de 100, 4 colis de 25, palette de prélèvement, date d'acquisition 30/06/2011 à 12H15, produit PS32618-0000066

Statut

Le code statut (variable cb_statut de la table cab_production) peut prendre les valeurs suivantes :

0 P1 est en attente de validation par VoluPack.
Le CAB a été lu en mode normal.
P2 doit contrôler le CAB et éventuellement transmettre l'information à P3 pour mise à jour des stocks.

1 Le CAB a été contrôlé et validé par VoluPack.
P1 peut débloquer la palette.
P3 peut mettre à jour les stocks.

2 Le CAB a été contrôlé et rejeté par VoluPack.
P1 bloque la palette.
P3 ne met pas à jour les stocks.
Ce statut ne peut être issu que d'un statut 1.

3 P1 a lu le CAB en mode dégradé et ne fait que transmettre l'information à VoluPack.
P1 a débloqué la palette.
P3 peut mettre à jour les stocks.

4 Le stock a été correctement mis à jour par P3.

5 Palette déjà déclarée.

6 Enregistrement non mis à jour par P2 mode connecté.

7 Enregistrement traité par P2 --> Demande de confirmation

P1 = Intégration du fichier externe

P2 = Contrôle

P3 = Entrée en stock


Saisie des mouvements de stock

Saisie des mouvements de stock stk0

Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes du paramètre de lancement Paramètres associés Contenu de la zone s0_integre

ATTENTION Pour la gestion par lieu, il faut mettre un index sur stk0 (s0_soc, s0_prod, s0_rgt1)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_ART

Caractères 3 et suivants : Code article

Exemple : -N_ART[s0_prod]

Permet de passer le code article en argument afin d'éviter l'écran de sélection. Utile dans le cas de l'utilisation avec le CTRL+J

Cela permet d'ouvrir la fenêtre de saisie d'un mouvement de stock en saisie, sauf si l'option Oco est activée.

Options triées

01

Ajout en auto de -1/1 et des zéros manquants

02

Ajout des zéros manquants

03

Ajout en auto de -1 et des zéros manquants

04

Ajout en auto des zéros manquants, du -1 et du / avec le premier niveau de l'OF

1e

Valorisation des mouvements d'inventaire lots/lieux au prix du 1er mouvement d'entrée normale

Voir la note _SUP_STK0_VAL_INV_1E

aa

Valorisation sans coefficient de conversion des mouvements de stock des articles achetés

af

Mise à jour ou non du prix d'achat idem Opa sauf produits finis

ao

Affectation obligatoire si sortie normale et numéro de commande client saisi

ap

Autorisation d'annulation physique

bm

Contrôle bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

bp

Permet la modification du prix unitaire en création de mouvements de stock

br

Message bloquant si stock résultant négatif

bt

Création de bordereaux de transfert de stock

cc

Attribution automatique du code client après saisie du numéro de commande

cf

Affichage automatique du client et du fournisseur principal

co

Consultation uniquement

cp

Active le recalcul du prix unitaire avec valorisation PAMP

cr

Création des reliquats après demande de confirmation lors d'une transformation

d'une EP en EN

d'une EC en EN

d'une SR en SN

da

Passage automatique de la date du mouvement à la date du jour en modification de l'état d un mouvement

(si passage de R à N, ou P à N, ou C à N). Cette modification est accompagnée d'une confirmation du mouvement).

dc

Suppression de la fenêtre de confirmation pour la modification de la date du mouvement de stock

de

Rupture par désignation produit

dr

Ouverture d'une fenêtre permettant la saisie de la date des mouvements de reliquats

ee

Edition étiquettes

em

Autorisation de modification de l'état des mouvements de stock

Par défaut, l'état des mouvements de stock n'est pas modifiable.

es

Edition seule

Dans ce cas, le paramétrage normalement lu sur #CF STK est lu en réalité sur le paramètre de lancement de stk0 (donc ici).

Par conséquent, la valeur alpha2 de stk0 telle qu'elle apparaît ici n'est pas prise en compte mais elle est substituée par celle du #CF STK.

fa

Rupture famille, sous-famille

ff

Force la recherche du stock résultant sur le mouvement précédent au lieu de le recalculer complètement

Voir aussi #CF ATL note SIMULATION_AN_SRES

L'option Obr permet de contrôler que le stock ne va pas devenir négatif suite à la création de ce mouvement.

Le calcul du stock résultant se fait dans tous les cas, même si le contrôle n'est pas paramétré et se fait soit en récupérant le stock résultant sur le mouvement physique précédent, soit en recalculant les stocks en fonction du suivi du stock résultant par mouvement de stock (voir #CF ATL A4[48]).

Pour les clients qui ne font pas ce contrôle et qui ne suivent pas le stock résultant par mouvement de stock, le recalcul du stock est inutile et peut être assez long…. Le but de ce nouveau paramétrage est donc d'obliger le programme à rechercher le stock résultant sur le mouvement physique précédent même si ce dernier risque de ne pas être à jour.

fp

TOP fin de période

Permet d'interdire de créer ou de modifier des lignes de BL concernant des articles stockés dont la date du BL est antérieure ou égale à ce TOP fin de période.

ft

Ouverture fenêtre tri (produit ou client / produit)

gi

Affectation des mouvements de stocks format GIE papier MR SSE-99999999

i2

Affichage de la couleur, du grammage, du format et du montant total

im

Imprimerie - Edition du format et du grammage si famille = PAP ou CAR

in

Interdiction de saisir des mouvements de sortie normale entraînant un stock négatif

it

Initialisation de l écran transfert pour éviter de saisir le même transfert 2 fois

la

Affichage du libellé correspondant à l'affectation. Concaténation des 3 zones suivantes :

Article de niveau 1 de l'affectation

Article de niveau 2 de l'affectation

Nature d'intervention de l'affectation

ld

En transfert de stock, si l'article mouvementé est stocké sur un lieu unique, on propose par défaut ce lieu en sortie

le

Affichage des libellés étrangers de l'article à la place du libellé fournisseur (le libellé client et prioritaire sur celui du fournisseur).

lo

Rupture sur numéro de lot en édition des mouvements

ma

Modification et annulation des mouvements automatiques interdites

mf

Conserve les marges fixes dans le fichier matière

ml

Option proche de Omn :

Mise à jour des mouvements de sortie réserve en mouvements de sortie normale pour les produits du niveau n+1 avec gestion des reliquats lors de la transformation d'une entrée prévisionnelle en entrée normale.

On fait la recherche des composants sur fab0 : on récupère tous les composants de l'OF (y compris ceux pour lesquels il n'y a pas de sortie réserve) : on permet de générer des mouvements de sortie normale même s'il n'y a pas eu de sortie réserve.

On permet aussi de modifier le lieu, la quantité et la date sur le mouvement à générer.

mn

Lors d'une transformation d'une entrée prévisionnelle (ou en commande) en entrée normale, tous les mouvements de sortie réserve des OF de niveau n+1 seront passés en sortie normale (avec gestion des reliquats).

Si l'option Ocr existe, les reliquats de sortie seront gérés.

Il y a visualisation de ces mouvements de sortie, et modification éventuelle avant validation.

Ceci n'est fait que lors d'une modification du type de mouvement

d'une EP en EN

d'une EC en EN

d'une SR en SN

mp

La modification du prix unitaire en modification d'un mouvement est autorisée après saisie d'un mot de passe paramétré en TMV A3[1,5].

Module de revalorisation paramétré en A4[24,29]

mr

Message d'avertissement non bloquant si le stock résultant est négatif (demande de confirmation).

mt

Permet d'accéder directement au menu de transfert des stocks

mx

Pas d'affichage de la fenêtre de confirmation de modification du prix dans le cas d'une transformation d'une sortie réserve en sortie normale

n1

Dans le cas ou le produit mouvementé est une nomenclature, on mouvemente aussi tous les produits N-1 de la nomenclature.

Le type de mouvement sera identique pour les composants et le composé.

Par exemple, si on fait une entrée pour le composé, on entrera les composants.

n2

Dans le cas où le produit mouvementé est une nomenclature, on mouvemente aussi tous les produits N-1 de la nomenclature.

Le type de mouvement pour les composants est l'inverse du composé.

Par exemple, si on fait une entrée pour le composé, on sortira les composants.

On indiquera le TMV opposé en TMV A2[15,17]).

na

Les notes saisies sur le mouvement seront attachées à l'article et non pas au mouvement.

nc

Utilisable uniquement avec Oof. Alimente automatiquement la zone note avec le libellé de la ligne de commande (affectation).

ne

Alimente automatiquement la zone note (ec_texte) avec le libellé de la commande. Nécessite l'option Oof.

ns

La saisie d'un code employé ramène automatiquement le nom et le prénom de l'employé sur la ligne de notes.

of

Contrôle l'existence du numéro d'OF.

ATTENTION, cette option est OBLIGATOIRE si on veut vérifier l'existence du dossier, contrôler qu'il est non clôturé, et positionner le dossier à calculer.

op

Ouverture automatique de la fenêtre de palettisation (nombre de palettes et nombre de PF par palette) à la saisie de la quantité.

pp

Initialisation du poids mouvementé dans s0_libre

Cette option est incompatible avec mp_param[30]), ainsi qu'avec la possibilité d'affecter un prix de vente à la zone s0_libre (TMV A2[48])

Si l'utilisateur a positionné un mode de gestion de s0_libre ET l'option Opp, la zone s0_libre contiendra le poids mouvementé (Opp prise en compte).

Si l'utilisateur a positionné un calcul de prix de vente, l'option Opp sera alors prise en compte pour ce type de mouvement (le calcul de prix de vente n'est alors pas effectué puisque Opp est effectif pour TOUS les mouvements).

pa

Met à jour le dernier prix d'achat dans mp_pa en fonction des entrées.

Lors d'un inventaire, le stock est valorisé au prix d'achat.

pc

Saut de page par code produit ou désignation selon paramétrage

pf

Saut de page par famille

pm

Prise en compte des frais et pertes en valeurs dans le fichier matières lors d'une modification du prix d'achat en saisie des entrées.

Les frais et les pertes sont recalculés à chaque modification du prix d'achat.

Option nécessaire au fonctionnement de l'option -Opm de la saisie des matières.

ps

Saut de page par sous-famille

qf

Mise à jour de la quantité fabriquée de la ligne de commande ou de la ligne de nomenclature de la ligne de commande ainsi que du numéro de mouvement de stock d'entrée prévisionnelle.

ql

Gestion des mouvements de retour de marchandises

Le type du mouvement de retour marchandises est paramétré en TMV A1[6].

rc

Edition du récapitulatif des TMV, si colonne k

rh

Saisie d'un numéro de BRH (gestion des bobines). Le BRH n'est pas obligatoire.

rp

F7 papier sur code matière (critères de sélection adaptés à la recherche des papiers)

ru

Saisie d'un numéro de BRU (gestion des bobines). Le BRU est obligatoire.

sd

Saisie de la date par défaut des mouvements lors de la première création

sn

Pour les mouvements de stock générés par l'option Omn, il n'y a pas mise à jour du stock résultant sur les mouvements de stocks associés au article de la Nomenclature de niveau N+1.

sp

Saisie du prix pour plusieurs unités possibles. Ouverture d'une fenêtre et le prix peut être saisi pour 3 unités différentes :

Unité d'achat

Unité d'utilisation

Unité paramétrée 3

Cette ouverture est automatique en création. Elle doit être activée par <F8> en modification

Paramétrage complémentaire : voir aide en ligne de type de paramètre FOR

Suppression de cette saisie pour une formule donnée

Arrondi du prix pour l'unité d'achat

Définition de l'unité paramétrée 3

sq

Saisie d'une quantité dans plusieurs unités possibles.

Ouverture d'une fenêtre permettant la saisie de la quantité dans 3 unités différentes :

Unité d'utilisation

Unité d'achat : Quantité dans l'unité d'achat = quantité dans l'unité d'utilisation * coef_conv(1)

Unité paramétrée 3 : Quantité dans l'unité 3 = quantité dans l'unité d'utilisation * coef_conv(3)

Cette ouverture est automatique en création. Elle doit être activée par <F8> en modification

Paramétrage complémentaire : voir aide en ligne de type de paramètre FOR

Suppression de cette saisie pour une formule donnée

Arrondi de l'unité d'utilisation

Définition de l'unité paramétrée 3

st

La quantité de mouvement n'est pas le stock résultant mais le cumul des quantités de mouvement de stock.

tr

Recherche du prix du mouvement dans les tarifs

En saisie manuelle des stocks, le prix affecté au mouvement est soit le prix d'achat, soit le prix de vente de la fiche article.

Le but de ce développement est de permettre la recherche systématique du prix du mouvement dans les tarifs.

Voir les notes CODE_TARIF_VOULU et TYPE_TARIF_VOULU

ty

Rupture en édition des mouvements sur le TMV

vm

Paramétrage du calcul de la colonne k (valeur). Si true, on prend pour les sorties le prix unitaire du mouvement.

wm

Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

wq

Message non bloquant si quantité négative

wr

Message non bloquant si stock résultant négatif

Valeur alpha 2

Caractères 1 à 5 | Mot de passe utilisé dans l'annulation physique des mouvements
Caractères 6 à 60 | Options de lancement accessibles par le menu
Caractère 6 | Recopie des notes au F15 (O/N) N par défaut
Caractère 7 | Affichage des mouvements annules en interrogation (O/N) N par défaut
Caractère 8 | Création de mouvements de régularisation de l'inventaire (O/N) N par défaut
Caractère 9 | Recopie des notes du mouvement d'entrée en commande ou d'entrée prévisionnelle ou de sortie réserve sur le mouvement de reliquat lors de la transformation du mouvement en entrée normale ou en sortie normale avec création du reliquat. Paramètre -Ocr (O/N) N par défaut
Caractère 10 | Affichage des mouvements de transfert ou de détail inventaire en interrogation (O/N) N par défaut

Valeur alpha 3

Caractère 1 | Type de transfert de lot (1/N) 1 par défaut
Caractère 2 | Type de transfert de lieu (0/N) 0 par défaut
Caractère 3 | Type de transfert de lot - lieu (2/N) 2 par défaut
Caractères 4 à 6 | Type de mouvement de sortie pour transfert
Caractères 7 à 9 | Type de mouvement d'entrée pour transfert
Caractères 10 à 12 | Type de mouvement de sortie pour régularisation de l'inventaire (par défaut, SOR)
Caractères 13 à 15 | Type de mouvement d'entrée pour régularisation de l'inventaire (par défaut, ENT)
Caractères 16 à 17 | Niveau de recherche pour les articles de remplacement.(voir -On1 et -On2) (par défaut égal 2)
Caractères 18 à 23 | Type et code du paramètre de lancement du programme d'édition d'étiquettes (#EDETA par défaut)
Caractères 24 à 29 | Code client départ des bordereaux de transfert de stock par défaut Voir en alpha4[5,10] l'équivalent arrivée
Caractères 30 à 32 | Code adresse départ des bordereaux de transfert de stock par défaut
Caractères 33 à 38 | Code transporteur des bordereaux de transfert de stock par défaut
Caractères 39 à 41 | Mode de transport des bordereaux de transfert de stock par défaut
Caractère 42 | Saisie entête bordereau de transfert de stock à chaque transfert O à tous les transferts (par défaut) N au premier transfert seulement
Caractères 43 à 45 | Type de note des bordereaux de transfert de stock par défaut Si type de note par défaut, le -C du paramètre de lancement est désactivé. Si pas de type de note par défaut, le -C du paramètre de lancement est activé.
Caractères 46 à 51 | Type et code paramètre pour l'édition d'un bordereau de réception après chaque entrée normale en stock
Caractère 52 | Contrôle de saisie des mouvements 1 On ne peut saisir des mouvements que sur des articles clients 2 On ne peut saisir des mouvements que sur des articles pas clients N Aucun contrôle (valeur par défaut) Les deux paramètres sont liés à la gestion d'un prix de vente
Caractères 53 à 58 | Type et code du paramètre de recherche des tarifs

Valeur alpha 4

Caractère 1 | Ouverture directe du menu transfert sans passer par la sélection lot, lieu, lot – lieu 1 Lot 2 Lieu 3 Lot - lieu
Caractères 2 à 4 | Type de mouvement par défaut (en saisie)
Caractères 5 à 10 | Code client arrivée par défaut sur les bordereaux de transfert des stocks
Caractère 11 | Le code adresse de départ = le code lieu niveau 1 de la sortie (départ) (O/N, N par défaut)
Caractère 12 | Le code adresse d'arrivée = le code lieu niveau 1 de l'entrée (arrivée) (O/N, N par défaut)
Caractère 13 | Confirmation de transfert (O/N, N par défaut)
Caractère 14 | Confirmation d'édition de bon de transfert (O/N, N par défaut)
Caractère 15 | Confirmation de création de bordereau (O/N, N par défaut)
Caractère 16 | Confirmation de saisie de notes (O/N, N par défaut)
Caractère 17 | Edition dans la foulée des bordereaux de transfert (O/N, N par défaut)
Caractère 18 à 23 | Type et code paramètre de l'édition du transfert - (par exemple edibts)
Caractères 24 à 29 | Type et code du paramètre pour le lancement de la revalorisation des stocks en aval (option Omp) (crinv.4ge -Osi)
Caractères 30 et 31 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 32 | Rechercher, selon un paramètre, le code saisi par l'utilisateur dans les références spécifiques des tiers. Si la recherche aboutit à plusieurs articles, ouvrir une fenêtre pour choisir. O Active la gestion des références spécifiques à la saisie du code article N Désactive la gestion des références spécifiques à la saisie du code article (défaut)
Caractère 33 | L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E
Caractère 34 | Sortie automatique du palettier 1 On se positionne directement sur le lieu 2 de l'entrée 2 On se positionne directement sur le lieu 2 de la sortie N Pas de sortie auto (valeur par défaut)
Caractère 35 | Saisie du lot (uniquement en gestion par Lieu) (O/N, O par défaut)
Caractère 36,38 | Lieu de rangement 1 par défaut pour la sortie
Caractère 39,44 | Lieu de rangement 2 par défaut pour la sortie
Caractère 45,47 | Lieu de rangement 1 par défaut pour l'entrée
Caractère 48,53 | Lieu de rangement 2 par défaut pour l'entrée
Caractère 54,59 | Type et code du paramètre pour le lancement de la localisation
Caractère 60 | Appel auto de la localisation des stocks après saisie du code produit (O/N, N par défaut)

Notes triées

@

Ces notes permettent de paramétrer plusieurs éditions de la manière suivante :

2 à 3 Numéro de l'édition (exemple 01, 02, 03)

4 à 5 10 = ligne titre, 99 = ligne configuration (paramétrage des colonnes d'éditions)

6 à 60 Titre de l'état pour ligne 10, paramétrage des colonnes pour 99

Exemples

@0110ETAT POUR MONSIEUR DUPOND

@0199ABCDEF

@0210ETAT POUR MONSIEUR DURAND

@0199ACFDEHKLM

CODE_TARIF_VOULU

21,23 Code des tarifs qui seront recherchés (par défaut : blanc)

Voir option Otr.

LIB_CONDITIONNEMENT

21,18 Libellé (de la zone s0_libre ?) dans l'écran de recherche

LIEUX_1_2_3

Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de

saisie manuelle (ici)

intégration des temps et matières (int_rtm)

visualisation des mouvements de stocks (v_stk0)

La recherche se fait :

1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F ….)

2 sur la sous-famille de l'article

3 sur la famille de l'article

4 sur le type de mouvement de stock

5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3)

13 Type d'article : P, S, M, F … Correspond au champ mp_mp de la table mat (si blanc : recherche globale)

21,23 Lieu de rangement 1 (magasin)

25,27 Lieu de rangement 2 (Emplacement)

29,31 Lieu de rangement 3 (Emplacement)

MVT_SOR_BOB_TRS_ANN

21,23 Type de mouvement de sortie de stock bobine

pour le transfert lors d'une annulation de mouvement de consommation

Voir en bas de cette page : Gestion de l'annulation d'une consommation de bobine.

MVT_ENT_BOB_TRS_ANN

21,23 Type de mouvement d'entrée de stock bobine

pour le transfert lors d'une annulation de mouvement de consommation

Voir en bas de cette page : Gestion de l'annulation d'une consommation de bobine.

MVT_SOR_PAP_TRS_ANN

21,23 Type de mouvement de sortie de stock papier

pour le transfert lors d'une annulation de mouvement de consommation

Voir en bas de cette page : Gestion de l'annulation d'une consommation de bobine.

MVT_ENT_PAP_TRS_ANN

21,23 Type de mouvement d'entrée de stock papier

pour le transfert lors d'une annulation de mouvement de consommation

Voir en bas de cette page : Gestion de l'annulation d'une consommation de bobine.

PARAM_LCT_LOT_INDUS

21,26 Type et code du paramètre de lancement de la saisie des lots industriels

POURCENT_PU_MAXI

21,26 Pourcentage (ex. 90 pour 90%) qui détermine la valeur maxi de la fourchette

POURCENT_PU_MINI

21,26 Pourcentage (ex. 4.3 pour 4,3%) qui détermine la valeur mini de la fourchette

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note est prioritaire sur celle du paramètre USE.

_SUP_STK0_VAL_INV_1E

21,60 Supplément de requête sur la table stk0 pour la valorisation des mouvements d'inventaire lots/lieux au prix du 1er mouvement d'entrée normale

Voir l'option O1e

Exemple

and s0_typ = "ENT"

_SUP_STK0_VISU_LL

21,60 Supplément de requête sur la table stk0 pour le F7 sur le numéro du lot

TYPE_TARIF_VOULU

Voir option Otr

21 Type de tarifs recherché :

A Tarif Achat, le tiers utilisé pour la recherche des tarifs est le fournisseur de la fiche matière, les bornes de quantités sont en unité d'achat (quantité du mouvement à laquelle on applique le coefficient de conversion).
On recherche le tarif sur le s0_fou, avec conversion de la quantité du mouvement

C Tarif Client (par défaut), le tiers utilisé pour la recherche des tarifs est le client de la fiche matière, les bornes de quantités sont en unité d'utilisation (quantité du mouvement sans prise en compte du coefficient de conversion).
On recherche le tarif sur s0_cli, sans conversion de la quantité du mouvement.

22 Numéro de la formule de conversion à appliquer pour la recherche du tarif Achat

Par défaut on prend la formule n°1

VISU_STK_PROD_PARAM

21,26 Type et code du paramètre de lancement du programme de visualisation des stocks

VISU_STK_PROD_SQL

21,60 Complément de sélection

Paramètres associés

#CF STK | Configuration de l'édition des stocks
FAM | Familles (Sortie des encres par codes barres) : alpha3[38] et notes de type LIB_QTE_STOCK
#CF ATL A4[1,15] | Libellé de la zone s0_libre
#CF NTS | Valeur numérique 1 : longueur de note (par défaut : 40)

Contenu de la zone s0_integre

B | Mouvements automatiques issus des BL
C | Mouvements automatiques issus des commandes clients
F | Mouvements automatiques issus des commandes fournisseurs
G | Mouvements automatiques issus de la génération de dossiers
H | Mouvements automatiques issus de la saisie des bons de réception
J | Mouvements automatiques issus de la saisie des quantités fabriquées
K | Réceptions de bobines (entrée de bobine)
L | Mouvements automatiques issus de l'édition des dossiers
M | Mouvements manuels
N | Mouvements manuels
O | Mouvements intégrés
R | Mouvements automatiques issus de la régénération de dossiers
R | Mouvements automatiques issus de la génération des besoins nets
S | Sorties de bobines (sortie de bobine et de papier si sortie)
 | OU (sortie de bobine et de papier et entrée de bobine et de papier si transfert)
U | Mouvements automatiques issus de la régularisation du stock physique.
V | Mouvements automatiques issus de l'intégration des événements d'ateliers (int_rtm)
W | Mouvements régularisation d'inventaire
X | Mouvements à épurer (Marquage par epu_stk_1.4ge)
Y | Mouvement de cumul généré par l'épuration des stocks en mode regroupement (epu_stk_1)
Z | Module de correction de stock (SPECIFIQUE à la gestion de stock par palette)

Gestion de l'annulation d'une consommation de bobine ou de papier

Lors de la fonction de modification de l'affectation sur un mouvement déjà intégré :

si seule l'annulation d'un mouvement de consommation d'une bobine est effectuée, si celle-ci se trouve dans un magasin différent de celui du mouvement, il y aura transfert du stock dans le magasin ou se trouve la bobine.

Exemple : La bobine est dans le magasin USI et on veut annuler un mouvement de consommation dans le magasin CON.

1) On crée un mouvement de consommation négatif.

2) On transfert le stock dans le magasin USI par 4 mouvements de stocks :

Sortie de la bobine du magasin CON

Sortie du papier du magasin CON

Entrée de la bobine dans le magasin USI

Entrée du papier dans le magasin USI

Attention : cette fonctionnalité permet aussi de changer l'affection du mouvement.

Dans ce cas, il n'y aura pas de mouvements de réintégration.

Le paramétrage se fait sur ces 4 notes, également accessibles dans la visualisation des mouvements de stocks.

MVT_SOR_BOB_TRS_ANN

MVT_ENT_BOB_TRS_ANN

MVT_SOR_PAP_TRS_ANN

MVT_ENT_PAP_TRS_ANN


Saisie des corrections de stocks gérés à la palette

Possibilité de remplacer le libellé Bobine par le libellé Plaque dans la découpe et la refente

Affichage de la longueur/coupe dans la découpe

Possibilité d'inverser largeur/laize avec longueur/coupe dans la découpe et la refente

Dans la découpe de bobine, on contrôle si la somme des laizes (Nb laizes X Laize) ne dépasse pas la laize de la bobine.

Dans la découpe de plaque, on contrôle si la somme des surfaces (Nb laizes X Laize X Coupe) ne dépasse pas la surface de la plaque (Laize plaque X Coupe plaque).

Dans la refente de bobine ou de plaque, on contrôle si la somme des laizes (Nb laizes X Laize) ne dépasse pas la laize de la bobine ou de la plaque.

Saisie des corrections de stocks gérés à la palette maj_stk

Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Permissions Paramètres associés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

code | Syntaxe | Ancienne syntaxe (reste valable)
-N_ART | Argument : code article Exemple : -N_ART[lc_prod] | -N_ART peut aussi s'écrire -N.
-N_CLI | Argument : code client Exemple : -N_CLI[ec_cli] | -N_CLI peut aussi s'écrire -S.
-N_DAT | Argument : date du mouvement Exemple : -N_DAT[lc_delcli] | -N_DAT peut aussi s'écrire -n.
-N_LOT | Argument : numéro de lot Exemple : -N_LOT[s0_lot] |
-N_MAG | Argument : lieu de rangement 1|lieu de rangement 2 Exemple : -N_MAG[s0_rgt1] Exemple : -N_MAG[s0_rgt1|s0_rgt2] |

Valeurs numériques

1 |
2 |
3 | Position de départ du numéro de palette dans le conteneur Dans le programme de correction manuelle des stocks, paramétrage du numéro de palette contenu dans le conteneur. Par défaut, le numéro de palette est égal au conteneur moins la racine. Ce numéro de palette set à alimenter la zone etp_num_palette de la table etiqprod. Ce paramétrage existe aussi dans le #CF CAB pour la déclaration de production.
4 | Position de fin du numéro de palette dans le conteneur

Options triées

Oaa

Valorisation sans coefficient de conversion des mouvements de stock des articles achetés

Oad

Correction de stock avec décimales

Oba

Validation automatique après la création d'un nouveau bordereau

Obr

Génération d'un bordereau de retour

Obt

Génération d'un bordereau de transfert

Oco

Consultation uniquement

Ocr

Prise en compte des commandes rattachées pour la recherche automatique des articles

Si l'option est activée, la saisie d''un numéro de lot de type CD2 ira rechercher tous les produits des lots de type FBI rattachés et les présentera en plus des produits liés à la CD2 elle-même.

Si l'option n'est pas activée, il faut saisir le numéro de lot de type FBI pour que la recherche présente les produits de la FBI (la saisie du numéro de lot de type CD2 ne présentera que le produit de la ligne et de la nomenclature de la ligne de la CD2 saisie)

Ode

Active l'option de gestion de déplacement de stock et d'éclatement

Permet de gérer uniquement le déplacement de stock et l'éclatement des palettes :

Empêche la correction des stocks en tant que tel (modification des quantités).

Reprend les fonctionnalités de l'option Oep

Odr

Désactive le rechargement automatique

Oec

Eclatement du nombre de palettes au chargement du tableau

L'option Ouc (Gestion des articles gérés en lots-lieux-conditionnements) ne doit pas être activée.

Oep

Limitation des fonctionnalités à l'éclatement de palettes par la touche F9.

Oes

Création des étiquettes palettes sans les éditer

L'option Oet est nécessaire, elle sera positionnée à true si le conteneur = le CAB. Voir #CF CAB A1[1]

Oet

Edition des étiquettes de production (si géré en spécifique)

Ofa

Fournisseur autorisé pour les bordereaux de transfert

Ofp

Contrôle de la date par rapport à celle inscrite dans le paramètre TOP de FIN

Ogb

Génération d'un bordereau de transfert avec une demande de confirmation

L'option Obt (Génération de bordereau de transfert) doit être activée.

L'option Obr (Génération de bordereau de retour) ne doit pas être activée.

Oie

Pas de contrôle sur magasin interne/externe

Oim

Mode de fonctionnement imprimeur

Oin

Inversion largeur/laize avec longueur/coupe dans la découpe et la refente - Voir l'option Opl - Plus d'info

La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.

Ola

Création de stock sur le lot de la commande fournisseur

Olm

Contrôle du lot mixte pour les Produits Finis achetés (nécessite l'option Ola)

Cette option spécifie que le lot saisi pour les articles achetés doit être un lot issu d'une commande d'achat.

Pour les produits finis achetés, ce lot peut aussi bien être un lot issu d'une commande client, donc l'option lot mixte effectue le contrôle de lot client si le contrôle de lot d'achat est négatif.

Opc

Pas de contrôle du lot en création de mouvement prévisionnel si l'article est un article acheté.

Opl

Le libellé Bobine est remplacé par le libellé Plaque dans la découpe et la refente - Voir l'option Oin

La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.

Opp

Les créations de lignes (entrées normales) sont valorisées au PAMP de l'article au lieu du prix de vente

Ore

Permet de réintégrer des éléments d'un produit monté lors de l'annulation d'un mouvement de stock de ce produit

Ori

Regroupement interdit pour lots différents

Orq

La quantité modifiée saisie est une quantité à retirer du stock.

Permet d'indiquer au programme de correction des stocks que la quantité modifiée saisie est une quantité à retirer (exemple : mise au rebut).

Dans ce fonctionnement, l'insertion d'un nouveau stock est désactivée (touche F1).

Ort

Regroupement bordereau de transfert

L'option Obt doit être activée (bon de transfert)

L'option Oba ne doit pas être active (validation automatique)

Osl

N'afficher que les mouvements de stocks dont le lieu de rangement 1 correspond au site de production de l'utilisateur

Tableau de bord du multisite

Osr

Pas de mise à jour du stock résultant

Osu

Seule la suppression est autorisée.

Ote

Passage en mode test

Ouc

Gestion des articles gérés en lots-lieux-conditionnements (mp_param[17] = 2)

L'option 40 de la fiche société doit être activée.

Fin des options triées

Valeur alpha 2

Caractères 1,3 | Type de mouvement de régularisation d'entrée Voir aussi les notes de type LISTE_TMV_CREATION et LISTE_TRF_TRANSFERT.
Caractère 4 |
Caractères 5,7 | Type de mouvement de régularisation de sortie
Caractère 8 | inutilisé
Caractères 9,11 | Lieu de rangement de niveau 1
Caractère 12 | inutilisé
Caractères 13,18 | Lieu de rangement de niveau 2
Caractère 19 | inutilisé
Caractères 20,22 | Type de port par défaut (facultatif)
Caractère 23 | inutilisé
Caractères 24,26 | Mode de transport par défaut (facultatif)
Caractère 27 | inutilisé
Caractères 28,33 | Code transporteur par défaut (facultatif)
Caractère 34 | inutilisé
Caractères 35,37 | Type de la zone paramétrable par défaut (facultatif)
Caractère 38 | inutilisé
Caractères 39,41 | Code de la zone paramétrable par défaut (facultatif)
Caractère 42 | inutilisé
Caractères 43,45 | Type de notes par défaut (obligatoire)
Caractère 46 | inutilisé
Caractères 47,49 | Type paramètre de lancement du module d'édition des bordereaux - (par exemple edibts)
Caractère 50 | inutilisé
Caractères 51,53 | Code paramètre de lancement du module d'édition des bordereaux - (par exemple edibts)
Caractère 54 | Saisie de la date de création des mouvements de stock O Saisie autorisée N Pas de saisie Si aucune date n'est saisie, on prend la date du jour.
Caractère 55 | Contrôle de la quantité par palette N Pas de contrôle (par défaut) W Contrôle avec message de warning C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 56 | Contrôle si l'article du lot client est un ensemble monté Possibilité de contrôler si une correction de stock est faite sur un produit appartenant à un lot dont l'ensemble est un ensemble monté (mp_param[22] = M). N Pas de contrôle (Valeur par défaut) W Contrôle avec message d'avertissement C Contrôle avec demande de confirmation B Contrôle bloquant
Caractères 57,59 | Type pour le regroupement utilisé dans les notes de bordereau de transfert Cette valeur sera enregistrée lors de la création des notes (table b_tr_n, zone btn_type) Par défaut : RGP
Caractère 60 | Création de bordereau de transfert sans saisie de quantité N Pas de contrôle. On prend la quantité initiale par défaut. W Message de warning. On prend la quantité initiale par défaut. C Demande de confirmation B Bordereau non créé. (par défaut) L'option Obt doit être positionnée.

Valeur alpha 3

Caractères 1,3 | Type de mouvement d'entrée pour le regroupement
Caractères 4,6 | Type de mouvement de sortie pour le regroupement
Caractères 7,9 | Type de mouvement d'entrée bobine pour la refente de bobines La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.
Caractères 10,12 | Type de mouvement d'entrée papier pour la refente de bobines La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.
Caractères 13,15 | Type de mouvement de sortie bobine pour la refente de bobines La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.
Caractères 16,18 | Type de mouvement de sortie papier pour la refente de bobines La découpe de plaque ne peut fonctionner que pour les produits gérés à la palette.
Caractères 19,21 | Type de mouvement de sortie bobine pour la découpe de bobines
Caractères 22,24 | Type de mouvement d'entrée papier pour la découpe de bobines
Caractères 25,27 | Type de mouvement de sortie papier pour la découpe de bobines
Caractères 28,30 | Type de mouvement d'entrée pour éclatement palette (ex : EPE)
Caractères 31,33 | Type de mouvement de sortie pour éclatement palette

Valeur alpha 4

Caractère 1 | Contrôle si le stock final du lot est négatif lorsque celui-ci est diminué (N/W/C/B, N par défaut) N Pas de contrôle W Contrôle avec message d'avertissement C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 2 | Contrôle si l'article du lot achat a la même qualité matière (O/N, N par défaut)
Caractère 3 | Contrôle si une ligne de stock existe déjà pour le même lot-lieu lors de la création d'une nouvelle ligne. N Pas de contrôle W Contrôle avec message d'avertissement C Contrôle avec demande de confirmation B Contrôle bloquant (par défaut).
Caractère 4 | Nombre de décimales à afficher pour les quantités (de 0 à 3) -> 3 par défaut 0 : Pas de décimale 1 : 1 décimale 2 : 2 décimales 3 : 3 décimales A : 0 décimale avec séparateur de milliers B : 1 décimale avec séparateur de milliers C : 2 décimales avec séparateur de milliers D : 3 décimales avec séparateur de milliers

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Notes triées

AIDE_SAISIE_OF

Méthode d'aide à la saisie des OF. Ce paramètre est prioritaire sur les autres.

Ajout du type 8

COMPLEMENT_LISTE_CRE

21,60 Complément de sélection des TMV pour la liste de création

COMPLEMENT_LISTE_SUP

21,60 Complément de sélection des TMV pour la liste de sortie

COMPLEMENT_LISTE_TRF

21,60 Complément de sélection des TRF pour le transfert

CTRL_PRD_TRANSF_LOT

Transfert de lot via F19 - Nécessite la permission TOU MSTK_F19

21 Type de contrôle si l'article différent de l'article du nouveau lot (N/B/W/C, C par défaut)

ETIQPROD_IMP

21,23 Paramétrage de l'imprimante pour édition automatique des étiquettes de production

GEST_A_RETRAITER

21,23 Code du stock à retraiter (Par exemple : ARE)

24 Code du contrôle effectué avant suppression d'une ligne de stock à retraiter

N pas de contrôle (par défaut)

W Warning : demande de confirmation avant suppression

B Bloquant : suppression impossible

LIEU_RETOUR

Pour générer des bordereaux de retour, il faut paramétrer le lieu déclenchant le bordereau.

Le contrôle se fait sur les lieux de rangement de niveau 1 et 2. Maximum 100 lieux.

12,14 Lieu de rangement de niveau 1

15,20 Lieu de rangement de niveau 2

Le bordereau de transfert peut être généré si

Le transfert s'effectue d'un lieu interne vers un lieu externe

Le transfert s'effectue vers un lieu interne paramétré

LISTE_TMV_CREATION

21 Paramétrage de la création

O Active la liste des TMV en entrée en stock

N Désactive la liste des TMV en entrée en stock

Si cette note est absente ou mal paramétrée, on garde le fonctionnement avec TMV d'entrée paramétré sur alpha2[1,3] (qui doit exister et être un mouvement d'entrée).

LISTE_TMV_SUPPRESS

21 Liste des TMV

O Active la liste des TMV de sortie de stock

N Désactive la liste des TMV de sortie de stock

Si cette note est absente ou mal paramétrée, on garde le fonctionnement avec TMV de sortie paramétré sur alpha2[5,7]. (qui doit exister et être un mouvement de sortie).

LISTE_TRF_TRANSFERT

21 Paramétrage du transfert

O Active la liste des TRF en transfert

N Désactive la liste des TRF en transfert

Si cette note est absente ou mal paramétrée, on garde le fonctionnement avec TMV d'entrée paramétré sur alpha2[1,3] et TMV de sortie paramétré sur alpha2[5,7].

MOTIF_DECHET_1

MOTIF_DECHET_2

MOTIF_DECHET_3

MOTIF_DECHET_4

21,23 Motif du déchet 1 (paramètre de type TRF)

21,23 Motif du déchet 2 (paramètre de type TRF)

21,23 Motif du déchet 3 (paramètre de type TRF)

21,23 Motif du déchet 4 (paramètre de type TRF)

Dans la correction de stock, pouvoir faire une déclaration de montage (des nappes par exemple)

Postulat de base

- Les produits à monter sont gérés en vrac.

- Les déchets sont gérés en vrac.

- Les produits montés sont gérés à la palette.

Fonction soumise à permission (touche MSTK_F17)

Les paramètres concernés sont les suivants :

Les notes TYPE_MVT_MONTAGE_E et TYPE_MVT_MONTAGE_S

RG1 A2[25,42] Lieux 1 et 2 pour le montage et les déchets

TRF A1[1,8] Types de mouvement et motif

_RACINE_NO_PALETTE

21,31 Racine du numéro de palette pour la recherche du dernier numéro lors de la création de nouvelles palettes.

Ne fonctionne que si #CF CAB A1[1]= O.

RECH_SUR_CONTENEUR

Voir explication dans les généralités

S

3,60 Supplément de requête sur la table stk0

SM

4,60 Supplément de requête sur la table mat

Le complément suivant est systématiquement rajouté à celui que vous paramétrez :

and mp_suistk = "O"

Par défaut, le supplément de requête est le suivant :

and mp_code[1] in ("E","P") and mp_suistk = "O" and mp_qualite != "DEV"

_SUP_REQ_CONTENEUR

Voir explication dans les généralités

SUP_REQ_CONT_INFO

Supplément de requête de la table conteneur_info

SUP_REQ_CONT_PRODUIT

Supplément de requête de la table conteneur_produit

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note est prioritaire sur celle du paramètre USE.

TAB_CTRL_LIG_NSOLDEE

21,26 Etat de stock interdit pour une ligne de commande non soldée

Exemple : NVE interdira tous les états de stock commençant par NVE.

TAB_CTRL_LIG_SOLDEE

21,26 Etat de stock interdit pour une ligne de commande soldée

Exemples : VE interdira tous les états de stock commençant par VE

ARE103 interdira le lieu de rangement N° 2 ARE103

SUP_REQ_MAX_CONT

21,60 Complément de requête pour la recherche du plus grand numéro de palette

Ce complément ne sera utilisé que si le #CF CAB A1[1] = O.

SUP_REQ_RECH_LOT

Transfert de lot via F19 - Nécessite la permission TOU MSTK_F19

21,60 Supplément de requête pour la recherche des lots

TMV_CREATION_DEFAUT

21,23 TMV par défaut si la liste d'entrée n'est pas activée

TMV_SUPPRESS_DEFAUT

21,23 TMV par défaut si la liste de sortie n'est pas activée

TMV_TRANSFERT_LOT

Transfert de lot via F19 - Nécessite la permission TOU MSTK_F19

21,23 Type de mouvement d’entrée pour le transfert de lot

24,26 Type de mouvement de sortie pour le transfert de lot

TRF_TRANSFERT_DEFAUT

21,23 TRF par défaut si la liste de transfert n'est pas activée

TYPE_MVT_MONTAGE_E

21,23 Type de mouvement pour une entrée de montage

Voir les notes MOTIF_DECHET_n

TYPE_MVT_MONTAGE_S

21,23 Type de mouvement pour une sortie de montage

Voir les notes MOTIF_DECHET_n

Paramétrage des permissions

Type de permission | Code permission | Définition
TOU | MSTK_CRE | Permission en création de mouvement d'entrée (F1)
TOU | MSTK_SUP | Permission en création de mouvement de sortie (F2)
ACC | MSTK_RGT | Permission en mouvement de transfert

Paramètres associés

so_options[13] | Gestion des lieux multi-niveaux
mp_param[17] | Mode de gestion de stock
#CF ATL alpha4[47] | 1 On affiche les libellés Nb de palettes et Qté/palette 2 On affiche les libellés Nb de colis et Qté/colis
TMV alpha1[1,2] | doit être = EN pour les entrées de régularisation doit être = SN pour les sorties de régularisation sinon message d'erreur et sortie de programme
TMV alpha2[18] | doit être = O sinon message d'erreur et sortie de programme
RG1 alpha1[33] | Mode de gestion du magasin P Palette V Vrac
RG1 alpha1[13] | Type de lieu de rangement I Interne E Externe
RG1 alpha1[14,19] | Code du tiers du bordereau
RG1 alpha1[20,22] | Code de l'adresse du tiers du bordereau
TRF | Le mouvement de sortie est paramétré en alpha1[1,3] Le mouvement d'entrée est paramétré en alpha1[5,7] ATTENTION : risque de confusion avec les mêmes paramètres, mais inversés, que l'on retrouve en alpha2 de maj_stk.
TOP FIN | Top fin de mois


Correction des mouvements prévisionnels

Correction des mouvements prévisionnels maj_stk_prev

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : code article Exemple : -N[lc_prod]
-n | Caractères 3 et suivants : date du mouvement Exemple : -n[lc_delcli]

Options triées

Oco | Consultation uniquement
Odr | Désactive le rechargement automatique
Oep | Transformation des mouvements prévisionnels d'entrée en mouvements réels d'entrée avec gestion du reliquat
Oim | Paramétrage imprimerie.
Opc | Pas de contrôle du lot en création de mouvement prévisionnel si l'article est un article acheté
Osp | Transformation des mouvements prévisionnels de sortie en mouvements réels de sortie avec gestion du reliquat
Osr | Pas de mise a jour du stock résultant
Ote | Mode test

Valeur alpha 2

Caractères 1 à 12 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 13 à 15 | Type de mouvement d'entrée normale de stock par défaut pour la transformation des mouvements d'entrée prévisionnelle. Le type de mouvement doit être une entrée normale. (Paramètre TMV, alpha1[1,2] = EN.)
Caractères 16 à 18 | Type de mouvement de sortie normale de stock par défaut pour la transformation des mouvements de sortie prévisionnelle. Le type de mouvement doit être une sortie normale. (Paramètre TMV, alpha1[1,2] = SN.)
Caractère 19 | ?
Caractères 20 à 22 | Code du paramètre de mot de passe Obligatoire pour activer la suppression de lignes multiples
Caractères 23 à 53 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 54 | Saisie de la date de création des mouvements (O / N / T, N par défaut) T : Possibilité de saisir la date pour chaque mouvement

Notes

COMP_SQL_CDE | 21,60 Complément de requête sur la commande
COMP_SQL_MAT | 21,60 Complément de requête sur la table mat. Cette note est obligatoire. S'il n'y a pas de complément à paramétrer, vous devez quand même paramétrer le complément suivant : COMP_SQL_MAT and 1=1
COMP_SQL_STK0 | 21,60 Complément de requête sur la table stk0
COMP_SQL_TMV | 21,60 Complément de requête sur le TMV Exemple COMP_SQL_TMV and p2_code = "R"


Génération automatique des avoirs

Génération automatique des avoirs à partir des mouvements de stocks gen_avo

Valeurs numériques

1

Numéro de compteur de commande (facultatif)

Options

-Oai | Affichage d'un rapport d'exécution à la fin de la génération
-Oif | Ignore les contrôle de cohérence : entre la famille de la ligne de commande et celle de l'article entre la sous-famille de la ligne de commande et celle de l'article et n'effectue pas les regroupements sur la famille et la sous-famille.
-Omc | Mise à jour de la quantité livrée sur la ligne de commande. On déduit la quantité retournée de la quantité déjà livrée.
-Opm | Pas de mise à jour de la zone mouvement intégré (s0_integre) du mouvement de stock

Notes

CR

3,60 Complément de requête sur la table stk0 - obligatoire. Le complément doit commencer par and.

Paramètres nécessaires

REP

Valeur numérique 1 (Pourcentage de commission du représentant)

La zone s0_integre est égale à T sur tous les mouvements intégrés.

Seuls les mouvements saisis en manuel sont traités.


Génération automatique des mouvements de stock à partir de la nomenclature

Génération automatique de mouvements de stock à partir de la nomenclature gen_stk

Génération automatique des mouvements de stock à partir de la nomenclature (Sorties normales ou en réserve pour les commandes et Sorties normales pour les BL)

Options

-Opm | MAJ des zones stock du fichier matières / produits (disponible, physique, réserve et valeur du stock) sans génération des mouvements de stock
-Opn | Génération du premier niveau seulement
-Ops | Génération des produits seulement
-Osr | Pas de MAJ du stock résultant
-Oss | Pas de sélection de mois à traiter
-Otl | Saisie d'un temps limite de traitement


Epuration logique des mouvements de stock antérieurs à une date

Epuration des mouvements de stock antérieurs à une date epu_stk_1

Principe d'épuration

Il s'agit d'une épuration logique des mouvements.

Pour avoir une épuration physique, utiliser l'option annulation physique du module de saisie des mouvements de stocks.

Préliminaires

  1. Seuls les mouvements de stock physiques (entrées, sorties et éventuellement inventaires) sont concernés.

  2. Les articles non suivis en stock sont également traités afin de permettre l'épuration des articles ayant changé de statut (passage de l'état suivi en stock à l'état non suivi en stock).

Traitement

Pour chaque article sélectionné (suite à une sélection multicritères), on contrôle l'existence d'un inventaire après la date d'épuration demandée.

Ce contrôle est impératif : à défaut, les stocks risquent d'être faux. Ce contrôle ne peut être supprimé que sur avis de Volume Software.

Cet inventaire peut être la résultante d'une création automatique d'inventaire par le programme crinv, c'est à dire sans l'obligation de réaliser un inventaire physique.

Si le contrôle est satisfait, l'article est traité. Tous les mouvements physiques antérieurs à la date d'épuration sont annulés logiquement, sauf les mouvements de stock sur un lot qui a toujours du stock à la date de traitement.

Annulation physique des mouvements

L'annulation physique des mouvements s'effectue via la transaction de saisie/modification manuelle des mouvements de stock.

Epuration par regroupement (Option Oer)

Il est possible, avant d'annuler logiquement les mouvements physiques, de conserver une trace des stocks par la création d'un mouvement cumulé par :

  • Article

  • Type de mouvement

  • Etat (Entrée, Sortie)

  • Lieu de rangement de niveau 1

  • Année du mouvement

  • Mois du mouvement

Dans le cas où l'épuration par regroupement est choisie, les inventaires ne sont pas annulés.

Options

-B | Mode batch
Ocd | Permet d'enlever le contrôle sur la date ATTENTION - REMARQUE IMPORTANTE : voir ci dessus le paragraphe Traitement.
Oer | Epuration des mouvements de stock par regroupement
Oim | Imprimerie

Valeur alpha 2

Caractères 1 à 5 | Mot de passe
Caractère 6 | N Les mouvements affectés à un dossier ne sont pas épurés. O On épure les mouvements sans contrôler leur affectation.
Caractère 7 | N Les mouvements non intégrés ne sont pas épurés. O On épure les mouvements sans contrôler s'il sont ou non intégrés.

Notes

DATE_LIMITE_EPU | 21,31 Date limite (optionnelle)
_SUP_REQ_MAT_BATCH | 21,60 Complément de requête sur la table mat en mode batch (obligatoire pour le mode batch)
TMV_A_EPURER | 21,23 Type de mouvement à épurer (à renseigner si l'option–Oer est activée)


Saisie des bordereaux de transfert de stock

Saisie des bordereaux de transfert de stock brd_trf

Options

Oas | Article suivi en stock
-Oea | Enchaînement automatique entête - lignes
-Oqt | Quantité obligatoire
-Opd | Poids obligatoire
-Opa | Nombre de palettes obligatoire

Edition des bordereaux


Edition des bordereaux de transfert de stock

Edition des bordereaux de transfert de stock edibts

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bordereau de transfert

Exemple : -N[bte_trf]

Options

Ocu | Edition des coordonnées de la société
Org | Permet d'avoir la rupture au numéro de groupage au lieu du numéro du bon de transfert. Cette option fonctionne uniquement avec VoluEdit (Ove)
Ove | Edition VoluEdit Option payante EVE 21

Valeur alpha 2

Caractères 1 à 3

Type pour le regroupement utilisé dans les notes de bordereau de transfert

Cette valeur sera enregistrée lors de la création des notes (table b_tr_n, zone btn_type)

Par défaut : RGP

Codes sources des clés TSC et Notes

EB | entête note
LB | ligne bordereau note
CL | client ligne de groupage
MP | produit de la séquence


Réception des matières (spécifique reliure)

Réception des matières (spécifique reliure) r_mat

Options

-Old | Le libellé des matières sera construit en concaténant le code signature et le libellé du dossier (et en tronquant s'il y en a trop)
-Osm | Cette option permet de réaliser des sorties au lieu des entrées
-Ocn | Cette option permet d'effectuer la recherche des dossiers seulement parmi les commandes non soldées
-On1 | Dans le cas ou le produit mouvementé est une nomenclature, on mouvemente aussi tous les produits N-1 de la nomenclature Le type de mouvement sera identique pour les composants et le composé (Exemple si on fait une entrée pour le composé, on entrera les composants)
-On2 | Dans le cas où le produit mouvementé est une nomenclature, on mouvemente aussi tous les produits N-1 de la nomenclature Le type de mouvement pour les composants est l'inverse du composé (Exemple si on fait une entrée pour le composé, on sortira les composants (sur le TMV caractères 15 à 17 zone alpha 2, on indiquera le TMV opposé)
-Ona | Lors de la création d'un article, on mettra le numéro du dossier dans le code afnor (mp_afnor)
-Ond | Si l'option im ou rn est active en création d'article, on mettra le numéro de commande dans le numéro de devis de la fiche article.
-Oge | Si l'option im ou rn est active, en création d'article, on mettra le code fabricant de la commande dans le gestionnaire de l'article.
-Oap | Si l'option im ou rn est active, en création d'article, on mettra le code AFNOR du produit de la première ligne de commande dans le code AFNOR de l'article à créer.

Valeur alpha 2

Caractères 1 à 3

Type du mouvement d'entrée


Transfert de stocks (spécifique reliure)

Transfert de stocks (spécifique reliure) chgt_stk

Transfert des stocks d'une nomenclature vers une nomenclature de même structure (à utiliser avec r_mat)

Options

-Osc

Pas de contrôle sur la validité du numéro de commande

Valeur alpha 2

Caractères 1 à 3 | Type mouvement d'entrée
Caractères 4 à 6 | Type mouvement de sortie


Interface mouvements de stock et d'inventaire partiel

## CR necessaire pour activer le RAZ systématique

_SUP_REQ_EXI_STK0 and s0_lot = 'PREVCLI'

_SUP_REQ_EXI_STK0 and s0_typ = 'SPQ'

_SUP_REQ_EXI_INFO_C and ic_ts in ('SEU')

##------------------- CONSTANTES---------------------------

CONSTANTE_FICHIER s0_typ SPQ

CONSTANTE_FICHIER s0_es E

CONSTANTE_FICHIER s0_cli DA0972

#CONSTANTE_FICHIER s0_rgt1 GEN

CONSTANTE_FICHIER s0_rgt2 I

CONSTANTE_FICHIER s0_lot PREVCLI

MAJ_FLAG_INFO_C FKPAAO [mp_code]

##-----------------DONNEES INTEGREES-----------------------

## 1er car/long champ/com

CHAMP_FICHIER s0_prod 001 015

CHAMP_FICHIER s0_rgt1 016 003

CHAMP_FICHIER s0_qte 019 013

CHAMP_FICHIER s0_prix 035 013

CHAMP_FICHIER s0_datm 048 010

CHAMP_FICHIER s0_lot 058 015

##CHAMP_FICHIER TSC_MP_AA_SEU_C ##MINI

##CHAMP_FICHIER TSC_MP_AA_SEU_D ##MAXI

##CHAMP_FICHIER TSC_MP_AA_SEU_E ##ALERTE

FIC_INTEGRER test.txt

FIC_INTEGRER_REP D:\KPA\KP\

FIC_INTEGRER_REP_HISD:\KPA\KP\

FIC_LOCK D:\KPA\KP\int.lck

FIC_LOCK_EXT D:\KPA\KP\intext.lck

FIC_LOCK_VS D:\KPA\KP\intvs.lck

FIC_ARRET D:\KPA\KP\int.arr

FIC_ANOMALIE D:\KPA\KP\int.ano

FIC_TRACE D:\KPA\KP\int.trace

#_SUP_REQ_CORRES_001 and le_libpar1 = "%CHAMP_FICHIER%"

#_SUP_REQ_CORRES_001 and le_prod in (select mp_code from mat

#_SUP_REQ_CORRES_001 where mp_soc = le_soc

#_SUP_REQ_CORRES_001 and mp_code = le_prod

#_SUP_REQ_CORRES_001 and mp_qualite in ("FAB","FNV"))

Interface mouvements de stock et d'inventaire partiel integrer_mvts_stock

Ce programme est opérationnel à partir de la V.4.0.176.2

Fonctionnalité

Intégration des mouvements de stock et d'inventaire partiel

Mouvements de stock d'entrée et de sortie

Type de mouvement de type E ou S

Ils sont intégrés tels quels.

Mouvements d'inventaire partiel

Type de mouvement de type V

Au 1er enregistrement du lot, du magasin de niveau 1 et du magasin de niveau 2 de l'article, le module calcule le stock théorique des magasins de niveau 3.

Pour chaque magasin de niveau 3 ayant un stock théorique différent de 0, le module crée un mouvement de sortie normale pour régularisation d'inventaire si celui-ci est positif ou un mouvement d'entrée normale pour régularisation d'inventaire si celui-ci est négatif.

Les types de mouvement pour régularisation d'inventaire sont paramétrés sur le TMV en A3[27,29] et A3[30,32].

Le mouvement est ensuite intégré avec comme type de mouvement celui paramétré sur le TMV en A3[30,32].

Les autres enregistrements du lot, du magasin de niveau 1 et du magasin de niveau 2 de l'article sont simplement intégrés avec comme type de mouvement celui paramétré sur le TMV en A3[30,32].

Options

Oar

Arrêt du programme en tâche de fond

Odl

Suppression des mouvements de stock

Voir la note _SUP_REQ_DELETE_MVT

Ohr

Horodatage des fichiers de trace et d'anomalie

Activer cette option désactive le système d'archivage précédent (fichiers numérotés de 1 à 20).

Le fichier d'anomalie est supprimé en fin de traitement si aucune anomalie n'a été rencontrée.

Opp

Les entrées normales sont valorisées au PAMP de l'article au lieu du prix de vente.

Ora

Affichage d'un rapport avant intégration

Nouvelles fonctionnalités :

• Intégrer des mouvements réserves

• Afficher un rapport avant l'intégration (possibilité d'annuler l'intégration)

• Annuler des mouvements de stocks existants avant l'intégration pour chaque produit intégré

• Rechercher une correspondance entre un champ VoluPack et un champ à intégrer
(exemple : correspondance entre une référence client et un code produit VoluPack)

• Mettre à jour des informations complémentaires (TSC) sur chaque produit intégré

Remarques

• Cette option est incompatible avec le mode batch (-B), elle est donc désactivée si ce dernier est paramétré.

• La partie inférieure du rapport est dédiée aux anomalies détectées lors de la lecture du fichier d'intégration.

• L'ouverture de cette fenêtre de rapport permet l'annulation de l'intégration en cas d'anomalies.

Paramétrage

Option Ora

A4[1]

Notes

_SUP_REQ_EXI_STK0

CHAMP_FICHIER

_SUP_REQ_CORRES_

Osa

Intégration des mouvements de stock Qualiac avec régularisation des mouvements générés dans VoluPack

N.B. : Cette option active automatiquement l'option Osq.

Les valeurs A3[6,8] et A3[9,11] doivent être renseignées.

Génère 2 lignes de mouvements de compensation (1 entrée, 1 sortie) par article/lot/lieu.

Osi

Simulation - Les mouvements de stock ne sont pas créés.

Osp

Suppression ou mise à jour des mouvements de réceptions prévisionnelles correspondant aux mouvements de réceptions réelles intégrées

Les mouvements de réceptions réelles sont intégrés à la date du jour.

Renseigner le TMV en A3[13,15].

Le Stock commande fournisseur de la fiche article correspondante (champ mp_scdef) est également modifié en conséquence.

Contrainte : La recherche du mouvement de réception prévisionnelle à supprimer ou modifier pour chaque ligne de mouvement à intégrer se fait sur le code article, la date du mouvement, et le lot.

Ces données doivent donc être identiques entre les mouvements de réception prévisionnelle et réelle.

Osq

Intégration des mouvements de stock Qualiac

Paramétrage associé

Options Osa, Osp, Osq

A3[5,15]

note _SUP_REQ_EXI_INFO_C

note _SUP_REQ_EXI_STK0

note CHAMP_FICHIER

note CONSTANTE_FICHIER

note MAJ_FLAG_INFO_C

note COMP_SEL_TMP_MVT_STK

Cliquez ici pour afficher / masquer un exemple de paramétrage.

Oup

Arrêt du programme en tâche de fond après un seul passage

Valeur alpha 2

A2[1,4]

Délai d'attente en minutes - Facultatif - 1 minute par défaut

Valeur alpha 3

A3[1] | Contrôler la validité du lot comme étant une commande client (O/N, O par défaut)
A3[2] | Lieux de rangement 2 et 3 obligatoires (O/N, O par défaut)
A3[3] | Initialiser le code client et le code commande du mouvement de stock par celui du lot, si ces 2 informations ne sont pas inscrites dans le fichier d'importation (O/N, O par défaut)
A3[4] | Intégrer uniquement les mouvements normaux (O/N, O par défaut) N On prend les mouvements de type N, P ou C en entrée de stock On prend les mouvements de type N, P en sortie de stock R On prend les mouvements de type R (réserve)
A3[5] | Annulation physique des mouvements - Interface Qualiac uniquement (Option Osq) O Annulation physique N Annulation logique, par défaut
A3[6,8] | Type de mouvement de sortie pour régularisation des mouvements de stock Ce paramètre est obligatoire en présence de l'option Osa.
A3[9,11] | Type de mouvement d'entrée pour régularisation des mouvements de stock Ce paramètre est obligatoire en présence de l'option Osa.
A3[12] | Nombre de lignes d'entête du fichier (ces lignes ne seront pas traitées)
A3[13,15] | Type de mouvement des mouvements de réceptions prévisionnelles à supprimer ou mettre à jour (obligatoire en présence de l'option –Osp)

Valeur alpha 4

A4[1]

Intégration des mouvements normaux/réserve (O/N/R, O par défaut) - Voir l'option Ora

N Non

Pour un mouvement d'entrée (TMV A1[1] = E)

Le type de mouvement (TMV A1[2]) doit être

N Mouvement normal

C Commande fournisseur

P Entrée prévisionnelle

Pour un mouvement de sortie (TMV A1[1] = S)

Le type de mouvement (TMV A1[2] doit être)

N Mouvement normal

P Sortie prévisionnelle

O Oui (par défaut) : Le type de mouvement (TMV A1[2]) doit être = N (Mouvement normal).

R Réserve : Le type de mouvement (TMV A1[2]) doit être = R (Mouvement réserve).

Notes

CHAMP_FICHIER

CTRL_CHAFIC_UNICITE

21,38 Nom du champ de destination dans VoluPack

• Tous les champs de la table stk0

• le champ nombre_palettes

• TSC sur l'article à intégrer, via la syntaxe habituelle : TSC_MP_AA_XXX_Y, où :

XXX : Code du TSC

Y : Zone du TSC

L'information complémentaire est créée ou mise à jour une seule fois à chaque nouveau code produit rencontré dans le fichier d'intégration.

41,43 Position de début de champ (obligatoire)

45,47 Longueur du champ (obligatoire)

49,51 Numéro d'indice du complément de sélection pour la recherche d'une correspondance entre une information à intégrer et une information VoluPack (voir ci-dessous)
Important : Limité au champ s0_prod et à la table lib_etr

Voir l'option Ora

IMPORTANT Le paramétrage CHAMP_FICHIER est utilisé après le paramétrage CONSTANTE_FICHIER lors de l'intégration.
Les valeurs saisies dans le fichier d'intégration sont donc prioritaires aux constantes définies dans le paramétrage.

Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique. Fonctionne avec la note CHAMP_FICHIER)

O chaque nom de champ doit être unique (par défaut)

N pas de contrôle

COMP_SEL_TMP_MVT_STK

21,60 Complément de sélection sur la table temporaire des mouvements de stock à intégrer (temp_mvt_stk)

CONSTANTE_FICHIER

21,38 Nom du champ - Obligatoire - Tous les champs de la table stk0 et le champ nombre_palettes.

41,60 Constante du champ - Obligatoire

FIC_INTEGRER

21,60 Nom du fichier à intégrer - Obligatoire

Possibilité d'intégrer plusieurs fichiers présents dans le répertoire (ils doivent être horodatés ou numérotés pour intégration dans l'ordre)

Exemple : mvts_stock_int*

FIC_INTEGRER_REP

21,60 Répertoire du fichier à intégrer - Facultatif

FIC_INTEGRER_REP_HIS

21,60 Répertoire historique du fichier à intégrer - Facultatif

FIC_LOCK

21,60 Nom du fichier du lock général posé par le programme - Obligatoire

FIC_LOCK_EXT

21,60 Nom du fichier du lock posé par un programme externe - Obligatoire

FIC_LOCK_VS

21,60 Nom du fichier du lock posé par le programme qui peut être utilisé par un programme externe - Obligatoire

FIC_ARRET

21,60 Nom du fichier d'arrêt- Obligatoire

FIC_ANOMALIE

21,60 Nom du fichier des anomalies - Obligatoire

FIC_TRACE

21,60 Nom du fichier de trace - Obligatoire

MAJ_FLAG_INFO_C

21 Etat de mise à jour

F Flag (demande de transfert)

D Déflag (transfert)

22,24 Code du TSC à créer/mettre à jour

25 Type de clé de TSC

26,28 Valeur de flag/déflag (zone ic_char3_1)

29,60 Paramétrage de construction de la clé de TSC, encadré par des crochets [ ]

Ce paramétrage peut être complété sur les lignes suivantes, à partir du caractère 21 (voir annexe pour des exemples)

La façon de construire la clé doit correspondre au type de clé.

Exemples

Pour un type de clé C (commande)

[ec_num]

[lc_num|-|lc_lig+<<<<<]

Pour un type de clé A (article)

[lc_prod]

_SUP_REQ_CORRES_

14,16 Numéro d'indice correspondant au champ pour lequel une correspondance existe

21,60 Complément de sélection pour la recherche de correspondance entre l'information du fichier d'intégration et une information VoluPack.

%CHAMP_FICHIER% : Mot-clé permettant, lors de l'exécution, d'insérer dans la requête la valeur du champ du fichier à intégrer.

Important : Limité au champ s0_prod et à la table lib_etr

Voir l'option Ora

_SUP_REQ_DELETE_MVT

21,60 Complément de requête pour la suppression des mouvements de stock

Obligatoire si l'option Odl est présente, sinon l'intégration est annulée.

Note : le programme ajoute le and pour la première ligne.

Exemple

_SUP_REQ_DELETE_MVT s0_soc = "001"

_SUP_REQ_DELETE_MVT and s0_typ = "CF"

_SUP_REQ_EXI_INFO_C

21,60 Complément de sélection des informations complémentaires (info_c) préalablement intégrées pour le produit et qui doivent être supprimés avant l'intégration de nouvelles informations.

Remarques :

• Ce paramétrage conditionne la suppression des informations complémentaires existantes (il est donc obligatoire si vous souhaitez supprimer les informations préalablement intégrées).

• Vous pouvez saisir and 1=1 pour une suppression sans complément spécifique.

• Le type de clé (ic_type), la clé (ic_cle) et le code TSC (ic_ts) sont déjà pris en compte dans le programme.

_SUP_REQ_EXI_STK0

21,60 Complément de sélection des mouvements de stocks (table stk0) préalablement intégrés pour le client et qui doivent être supprimés avant l'intégration de nouveaux mouvements

Remarques :

• Ce paramétrage conditionne la suppression des mouvements existants (il est donc obligatoire si vous souhaitez supprimer les mouvements préalablement intégrés).

• Vous pouvez saisir and 1=1 pour une annulation sans complément spécifique.

• Le code client (s0_cli) et le type de mouvement (s0_typ) sont déjà pris en compte dans le programme.

TRACE_MSG_CONTROLE

Désactivation de la trace de certains messages de contrôle

21,26 Code du contrôle

QTEPAL : Contrôle de la quantité et du nombre de palettes du mouvement
Le message correspondant à l'anomalie est le suivant:
La quantité et le nombre de palettes du mouvement ne sont pas renseignés ou à 0.

27 [rien]

28 Affichage du message dans le fichier de trace des anomalies (O/N, O par défaut)

Exemple de paramétrage de correspondance entre une information du fichier d'intégration (référence client) et une information VoluPack correspondante (code produit)

Intégration du code produit (stk0.s0_prod)

1 2 3 4 5

12345678901234567890123456789012345678901234567890

CHAMP_FICHIER s0_prod 001 015 00

Le champ saisi dans le fichier d'intégration est la référence client (lib_etr.le_libpar1)

1 2 3 4 5

12345678901234567890123456789012345678901234567890

_SUP_REQ_CORRES_001 and le_libpar1 = "%CHAMP_FICHIER%"

and le_prod in (select mp_code

from mat where mp_soc = le_soc

and mp_code = le_prod

and mp_qualite = "FAB")

Explication des 5 lignes précédentes :

On récupère le code produit de la table des libellés étrangers (lib_etr.le_prod) pour lequel la référence client (lib_etr.le_libpar1) est égale à la valeur du champ du fichier d'intégration (%CHAMP_FICHIER%).

Paramètres nécessaires

TMV A3[27,29] | Type de mouvement de sortie normale pour régularisation d'inventaire - Obligatoire
TMV A3[30,32] | Type de mouvement d'entrée normale pour régularisation d'inventaire - Obligatoire


Transfert d'emplacement de palette

Transfert d'emplacement de palette tran_empl_cab

NOUVEAU

A compter du 29/09/2011 (V.4.0.203.2), ce module permet une alimentation automatique à partir d'un fichier (option Otf).

Options

O22 | CAB transformateur sur 22 caractères
Oca | Afficher le code article. Sans cette option, le code article n'est pas affiché.
Ode | Mise à jour de l'emplacement du mouvement de stock de la dernière entrée de la palette transférée au lieu de créer un mouvement de stock de sortie de l'ancien emplacement, puis un mouvement de stock d'entrée sur le nouvel emplacement
Odi | Mise à jour de l'emplacement du mouvement de stock de la dernière entrée de la palette transférée si la date de la dernière entrée de celle-ci est égale ou supérieure à la date du dernier inventaire du produit sinon création d'un mouvement de stock de sortie de l'ancien emplacement, puis d'un mouvement de stock d'entrée sur le nouvel emplacement Option incompatible avec l'option Ode
Omt | Mode trace
On3 | On met à jour le lieu de niveau 3 avec la quantité de PF par palette
Ord | Lors du flashage d'un code à barres, l'emplacement entré est automatiquement renseigné par le lieu précisé en A3[17,25]. Par conséquent le transfert se fait automatiquement en un flashage de code à barres.
Osr | Pas de mise à jour du stock résultant
Ote | Paramètres communs pour la gestion par codes à barres
Otf | Tâche de fond, permet une alimentation automatique à partir d'un fichier Voir les notes dédiées en bas de cette page.

Valeur alpha 2

Nom du fichier trace (si option Omt)

Valeur alpha 3

A3[1,3]

Type de mouvement de sortie de transfert

A3[4,6]

Type de mouvement d'entrée de transfert

A3[7,9]

Type de mouvement de sortie d'erreur de localisation

A3[10,12]

Type de mouvement d'entrée d'erreur de localisation

A3[13]

Initialisation de l'emplacement de sortie avec le lieu d'emplacement de la palette (O/N, N par défaut)

A3[14]

Saisie du lieu de sortie (O/N, O par défaut)

Si N, alors A3[13] doit être à O.

A3[15]

Conserver l'affichage des informations concernant le dernier transfert (O/N, N par défaut)

A3[16]

Affichage de l'état de la palette (O/N, N par défaut)

Voir aussi #CF CAB A1[5] et valeur numérique 1

L'emplacement d'origine et l'emplacement de destination peuvent être saisis en 3 temps.

Emplacement d'origine (Saisie conditionnée) : Saisie du magasin, puis de l'emplacement 1, puis de l'emplacement 2.

Emplacement de destination : Affichage du magasin d'origine, puis saisie de l'emplacement 1, puis de l'emplacement 2. Pour le changement de magasin , il suffit de saisir un magasin dans l'emplacement 1.

La longueur de l'emplacement 1 est paramétrable.

A3[17,19]

Magasin. Facultatif. Par exemple : USI. Si le magasin n'est pas renseigné lors du transfert en automatique, le magasin d'origine sera conservé seul le lieu 2-3 changera.

Voir l'option Ord

A3[20,25]

Lieu de rangement. Par exemple : VLIV

Voir l'option Ord

Notes

PARAM_LCT_CHGT_ETAT | 21,26 Type et code du paramètre pour le lancement du programme de changement d'état (exemple : #FBCEP)
_STYLE_CAB | Paramètres communs pour la gestion par codes à barres
SUP_REQ_STK0_DER_ENT | 21,60 Supplément de requête sur la table des mouvements de stock (stk0) Celui-ci est utilisé pour rechercher la dernière entrée du même lot/article de la palette. Exemple SUP_REQ_STK0_DER_ENTand s0_rgt1 != "ROU"

Notes pour l'alimentation automatique à partir d'un fichier

L'option Otf doit être positionnée.

Notes

ATTENTE_LIB_SERVICE

21,60 Temps en secondes d'attente de libération du verrou du programme externe

ATTENTE_LIB_VSW

21,60 Temps d'attente pour libérer le verrou du programme Volume

FICHIER_ANOMALIE

21,60 Fichier d'anomalie

FICHIER_LOCK_SERVICE

21,60 Nom du fichier de lock du programme externe

FICHIER_LOCK_VS

21,60 Nom du fichier de lock Volume Software

FICHIER_TRACE

21,60 Fichier de trace

FICHIER_UNICITE_EXE

21,60 Nom du fichier qui garantit l'exécution d'un seul programme à la fois

LIEU_DELETE

21,29 Emplacement pour l'entrée en stock lors d'une action DELETE (lieu1 et lieu2)

LIEU_DROP

21,29 Emplacement pour l'entrée en stock lors d'une action DROP (lieu1 et lieu2)

Est pris en compte si le lieu dans le fichier n'est pas renseigné ou mal renseigné.

NOM_FIC

21,60 Nom du fichier à traiter.

Un astérisque dans le nom du fichier indique que l'on prend tous les fichiers qui commencent par les caractères situés avant l'astérisque.

Une fois traités, les fichiers sont déplacés dans le répertoire historisé.

POSITION_LIEU

Paramétrage de la position de début et de fin à prendre en compte sur le lieu (magasin + emplacement)

Ceci dans le but de ne pas prendre en compte l'emplacement dans l'alvéole que ne gère pas LGR dans VoluPack.

21 Caractères de début à prendre en compte (1 par défaut)

22 Caractères de fin à prendre en compte (9 par défaut)

24 Prise en compte de l'emplacement dans l'alvéole (O/N, N par défaut)

REP_FIC

21,60 Répertoire où se situe le fichier à charger pour l'alimentation du module

REP_HIS

21,60 Répertoire où doit être déplacé le fichier une fois traité.

REP_TRA

21,60 Nom du répertoire de stockage des fichiers trace, erreur, lock, etc.

Il se substitue au répertoire paramétrée dans REP_FIC

Descriptif du fichier d'import

Le séparateur est le pipe (|).

Seules les zones 1 à 3 sont utilisées pour cet interface.

1. Numéro palette

2. Action

3. Emplacement

4. Indice de position

5. Destination

6. Numéro de préparation

7. Largeur palette

8. Longueur palette

9. Hauteur palette

10. Classification

11. Code client

12. Nom client

13. Numéro OF

14. Numéro commande LGR

15. Numéro commande client

16. Code article

17. Référence article

18. Libellé article

19. Type conditionnement

20. Nombre de colis

21. Quantité par colis


Mouvements manuels de palette

Mouvements manuels de palette mvt_manuel_cab

Options

O22 | CAB transformateur sur 22 caractères
Oep | Affichage d'un message d'alerte de réédition des étiquettes des palettes modifiées Option On3 obligatoire
Ofd | Forçage de la date de mouvement
On3 | On met à jour le lieu de niveau 3 avec la quantité de PF par palette.
Oqr | La quantité saisie est la quantité restante (sinon c'est la quantité extraite)
Orp | Réintégration ou création d'une palette
Osr | Pas de mise à jour du stock résultant
Ote | Paramètres communs pour la gestion par codes à barres

Valeur alpha 3

Caractères 1 à 3

Lieu de rangement 1 par défaut

Caractères 4 à 9

Lieu de rangement 2 par défaut

Caractères 10 à 12

Type de mouvement par défaut

Caractère 13

Mode valorisation entrée - Pas de valeur par défaut

1 Les entrées sont valorisées selon le type de valorisation de l'article (mp_tval).

2 Prix de la dernière entrée

Caractères 14 à 16

Type de mouvement de stock de sortie normale d'éclatement de palette

Obligatoire si option -On3

EX : SEC

Caractères 17 à 19

Type de mouvement de stock d'entrée normale d'éclatement de palette

Obligatoire si option -On3

EX : EEC

Caractères 20 à 22

Type de mouvement de stock de sortie normale de repalettisation de palette

Obligatoire si option -On3

EX : SRP

Caractères 23 à 25

Type de mouvement de stock d'entrée normale de repalettisation de palette

Obligatoire si option -On3

EX : ERP

Caractère 26

Mode de contrôle de la quantité de la palette destinatrice

N Pas de contrôle même si la quantité de la palette destinatrice est supérieure à la quantité théorique par palette du PF

W Message d'avertissement si la quantité de la palette destinatrice est supérieure à la quantité théorique par palette du PF

C Demande de confirmation si la quantité de la palette destinatrice est supérieure à la quantité théorique par palette du PF

B Blocage si la quantité de la palette destinatrice est supérieure à la quantité théorique par palette du PF

Notes

AUT_MVT_PAL_ETAT_S AUT_MVT_PAL_ETAT_NS | Autorisation de mouvement de palettes soldées. Autorisation de mouvement de palettes non soldées. 21 Numéro de l'état de la palette d'origine : 0 sans état 1 à 9 idem paramétrage sur #CFATL (ex : 1-VEN / 2-NVE / 3-ARE / 4-ADE ...) 22 Autorisation Entrée (O/N) 23 Autorisation Sortie (O/N) 24 Autorisation Transfert vers état 0 (O/N) 25 Autorisation Transfert vers état 1 (O/N) 26 Autorisation Transfert vers état 2 (O/N) 27 Autorisation Transfert vers état 3 (O/N) 28 Autorisation Transfert vers état 4 (O/N) 29 Autorisation Transfert vers état 5 (O/N) 30 Autorisation Transfert vers état 6 (O/N) 31 Autorisation Transfert vers état 7 (O/N) 32 Autorisation Transfert vers état 8 (O/N) 33 Autorisation Transfert vers état 9 (O/N)
LIBELLE_QTE_SAISIE | 21,40 Libellé du champ Quantité saisie
_PAR_LOCALISATION | 21 à 26 Type et code du paramètre de lancement de la localisation
_STYLE_CAB | Paramètres communs pour la gestion par codes à barres
TITRE_ECRAN | 21,31 Titre de l'écran. Facultatif Mvt Manuel si non renseigné EX : Destruct
TITRE_FEN_VALIDATION | Titre de la fenêtre de validation. Facultatif Mvt Manuel si non renseigné EX : Sortie Destruction

Paramètres associés

#CF ATL | alpha3[33]
so_options | option 40


Changement d'état d'une palette

Changement d'état d'une palette change_etat_pal_cab

L'état 0 (zéro) correspond à une palette sans état.

L'état 1 correspond à une palette Vendable

L'état 2 correspond à une palette Non Vendable

L'état 3 correspond à une palette A Retraiter

L'état 4 correspond à une palette A Détruire

Options

O22 | Mode transformateur (CAB sur 22 caractères au lieu de 19 normalement)
Ocl | Change l'état palette d'un lot Si la palette saisie fait partie d'un lot de plusieurs palettes, l'application demandera si l'utilisateur souhaite changer l'état de toutes les palettes du même lot-lieu. Si l'utilisateur répond non, seul l'état de la palette saisie sera changé. Si la réponse est oui, l'état des n palettes sera changé. Dans la fenêtre de confirmation, l'application indique le nombre de palettes qui serait modifié.
Odt | Permet d’afficher le détail des palettes qui seront modifiées.
Omt | Mode trace dans le fichier est paramétré en alpha 2
On3 | MAJ du lieu de rangement 3 avec la quantité de PF par palette
Opp | Active la gestion du changement d'état de la palette de prélèvement
Osr | Mise à jour du stock résultant
Ote | Paramètres communs pour la gestion par codes à barres

Valeur alpha 2

Caractères 1 à 60

Chemin + Nom du fichier trace du programme (par ex. : u/tmp/change_etat.tra)

Valeur alpha 3

Caractères 1 à 3 | Sortie normale de changement d'état
Caractères 4 à 6 | Entrée normale de changement d'état

Notes

AUT_CHG_ETAT_PAL_S

AUT_CHG_ETAT_PAL_NS

Autorisation de changement d'état des palettes soldées

Autorisation de changement d'état des palettes non soldées

21 Numéro de l'état (0 à x selon #CFATL)

22 Autorisation Transfert vers état 0 (O/N)

23 Autorisation Transfert vers état 1 (O/N)

24 Autorisation Transfert vers état 2 (O/N)

25 Autorisation Transfert vers état 3 (O/N)

26 Autorisation Transfert vers état 4 (O/N)

27 Autorisation Transfert vers état 5 (O/N)

28 Autorisation Transfert vers état 6 (O/N)

29 Autorisation Transfert vers état 7 (O/N)

30 Autorisation Transfert vers état 8 (O/N)

31 Autorisation Transfert vers état 9 (O/N)

LIBERER_LOT

Au lieu de flasher un numéro de palette, l'utilisateur est invité à saisir le numéro du lot.

L'état des palettes qui sont dans ce lot sera changé après l'écran de confirmation.

Pour utiliser cette fonctionnalité, l'option Ocl doit être active.

La fonction F6 permet d'accéder à l'écran Libérer les lots.

21 Option Ocl obligatoire (O/N, N par défaut)

O L'application démarre avec l'écran libérer les lots.

N L'écran est celui du changement état d'une palette.
On accède à l'écran pour libérer les lots via la fonction F6.

22,26 État actuel de la palette : permet d'initialiser le champ par une valeur par défaut.
Facultatif - à paramétrer selon #CF ATL A3[34]

27,31 Nouvel état de la palette : permet d'initialiser le champ par une valeur par défaut.
Facultatif - à paramétrer selon #CF ATL A3[34]

Cette note est facultative.

Il est possible d'avoir accès à l'écran via la fonction F6 mais l'option Ocl reste obligatoire.

_STYLE_CAB

Paramètres communs pour la gestion par codes à barres

Paramètres nécessaires

#CF ATL

#CF ATL A3[33] = O

#CF ATL A3[34]= Longueur de l'état de palette


Variantes d'impression

Variantes d'impression var_imp

Options

-Oav

Actualisation des variantes d'impression
Si l'option est absente : création des variantes d'impression

Valeur alpha 2

Caractères 1 à 3 | Code du mot de passe
Caractère 4 | Type de variante de devis C Variante de conditionnement I Variante d'impression (par défaut)

Notes

SUP_REACTUALISE_TSC | 21 à 60 Complément de sélection sur les TSC à réactualiser
_SUP_REACTUAL_TARIF | 21 à 60 Complément de sélection sur les tarifs à réactualiser


Localisation de stock

Localisation d'un article sur les différents lieux de rangement localisation_stock

Permet d'afficher la localisation d'un article sur les différents lieux de rangement.

  • Ajout des touches d'aide à la saisie des CAB
    - F8 : CAB Palette de fabrication sur 19 caractères si option -O22 non activée
    - F8 : CAB Palette de fabrication sur 22 caractères si option -O22 activée
    - F9 : CAB Palette d'achat

  • Si l'article n'a pas la gestion des conteneurs (mp_param[17] différent de 1 et 2), la recherche se fait sur la table des mouvements de stock (stk0).

  • Un complément de requête peut être paramétré sur la table stk0 : note _SUP_REQ_STK0

  • Si l'article a la gestion des conteneurs (mp_param[17] = 1 ou 2), la recherche se fait sur les tables des conteneurs (conteneur_info et conteneur_produit).

  • Un complément de requête peut être paramétré sur les tables conteneur_info et conteneur_produit.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : code article Exemple : -N[lc_prod]
-n | Caractères 3 et suivants : numéro de lot Exemple : -n[s0_lot]

Options

-N | Suivi du code produit Passage d'un code produit en paramètre à partir d'un autre programme appelant
-n | Numéro du lot à visualiser
O22 | CAB transformateur sur 22 caractères
Oll | Localisation par Lot/Lieu (par défaut par Lieu) Dans ce cas, la colonne Date est remplacé par le lot.
Onp | Affichage du nombre de palettes au lieu de la quantité totale si gestion des conteneurs (mp_param[17] = 1 ou 2)
Ote | Paramètres communs pour la gestion par codes à barres

Notes

_STYLE_CAB | Paramètres communs pour la gestion par codes à barres
_SUP_REQ_CNT_INFO | 21,60 Complément de requête sur la table conteneur_info Exemples : _SUP_REQ_CNT_INFO and cni_rgt1 = "LUM" _SUP_REQ_CNT_INFO and cni_rgt2 = "VEN001"
_SUP_REQ_CNT_PRODUIT | 21,60 Complément de requête sur la table conteneur_produit Exemple : _SUP_REQ_CNT_PRODUITand cnp_lot = "05025605-001"
_SUP_REQ_MAT | Complément de requête sur mat
_SUP_REQ_STK0 | Complément de requête sur stk0


Gestion des paramètres de stock

Gestion des paramètres de stock gest_stk

La gestion des paramètres de stock a deux modes de fonctionnements

– Le mode par défaut (option Ogl non activée)
Gestion des seuils d'alerte et de quantité de réapprovisionnement par lieu de rangement (utilise la table stk_rg : sr_smini et sr_alerte).

– Le mode global (option Ogl activée)
La gestion des seuils d'alerte et de quantité de réapprovisionnement se fait depuis la fiche article (mp_smini et mp_alerte)

Apparition d'un nouveau mode de calcul (A2[11] = 3) des seuils d'alerte et de quantité de réapprovisionnement

Dans ce programme (Gestion des paramètres de stock)

Le seuil mini est égal à la somme des consommations de la période divisé par le nombre de mois sur la période, puis divisé par 30 pour obtenir une consommation par jour. Cette consommation par jour est multipliée par le délai de réapprovisionnement de la fiche matière.

La quantité de réapprovisionnement est égale au seuil mini multiplié par un coefficient (voir la note COEF_CALC_QTE_R)

Note : les deux valeurs seront proposées en nombre multiple du conditionnement.

La quantité de réapprovisionnement devra respecter le minimum de fabrication.

Le minimum de fabrication correspond à la quantité économique de fabrication (mp_qteeco).

Si elle n'est pas renseignée, la quantité sera calculée depuis une surface minimum paramétrée sur le paramètre de lancement et à l'aide du TSC 202 de l'article.

Dans le programme de visualisation des articles :

La nouvelle option Oqr permet de calculer les seuils d'alerte et les quantités de réapprovisionnement automatiquement (selon le paramétrage) en utilisant la gestion des paramètres de stock.

Une fois le calcul terminé, la visualisation affiche les anciennes valeurs (soit de la table stk_rg, soit de la table mat. zones: mp_smini et mp_alerte) et les nouvelles valeurs calculées (stocké dans des TSC via des CIC).

L'utilisateur peut sélectionner les lignes qu'il souhaite mettre à jour via l'action ACT018 (soumise à permission MEN ACT018) du Ctrl K.

Cette action met à jour les zones mp_smini et mp_alerte de la fiche matière.

Si le mode de fonctionnement de la gestion des paramètres de stock est par lieu de rangement, en plus de la table mat, la table stk_rg sera mise à jour (zones : sr_smini et sr_alerte).

Arguments d'appel

Les arguments d'appels ci-dessous ne sont pas à paramétrer. Ils sont documentés à titre indicatif.

Ils sont utilisés en automatique par la visualisation des articles pour transmettre via canal_comm le complément de sélection qui serait trop long pour un –N.

-nCSG | Lance le calcul des seuils d'alerte en mode global ( option Ogl) en récupérant un complément de sélection via canal_comm. -nCSGxxx avec xxx = code paramètre
-nCSD | Lance le calcul des seuils d'alerte selon le lieu de rangement en récupérant un complément de sélection via canal_comm. -nCSD avec xxx = code paramètre

Options triées

-B | Mode batch.
Oaj | La date de fin de période de sélection est initialisée à aujourd'hui (incompatible avec –OFM)
Ofm | La date de fin de période de sélection est initialisée à la fin du mois précédent. (incompatible avec –Oaj)
Oqb | Calcul des consommations moyennes par rapport aux livraisons. Les quantités utilisées sont celles des BL. Le nombre de sorties utilisé est le nombre de BL. Incompatible avec l'option -Orb.
Ogl | Calcul des stocks en globalité et mise à jour de l'article Voir explication en haut de page (mode par défaut / mode global)
Orb | Pas de restriction aux lignes de bon de livraison ATTENTION : Cette option est incompatible avec l'option –Oqb
Ox1 | Mode simulation : Les stocks sur les articles traités ne seront pas mis à jour
Ox2 | Stockage des valeurs calculées dans des informations complémentaires Fonctionne avec ou sans l'option Ogl

Valeur alpha 2

Caractères 1 à 3 | Nombre de jours de la période considérée. (date début = date fin – période)
Caractères 4 à 6 | Valeur du paramètre K (calcul du stock minimum de sécurité).
Caractère 7 | Si le délai moyen de réapprovisionnement n'est pas renseigné sur la fiche article, on le prend sur sa sous-famille, dans la valeur numérique 1 ou 2. 1 On le prend dans la valeur numérique 1 2 On le prend dans la valeur numérique 2
Caractères 8 à 10 | Constante en jour à ajouter au délai de sécurité de la gamme principale pour le calcul du délai moyen
Caractère 11 | Indice de la méthode 1 ou [vide] (par défaut) ancienne méthode 2 nouvelle méthode 3 Les quantités de réapprovisionnement et d'alerte sont proposées en un nombre multiple du conditionnement - Voir explication en haut de ce document

Notes

COEF_CALC_QTE_R | 21,23 Coefficient multiplicateur du seuil d'alerte pour déterminer la quantité de réapprovisionnement
QTE_MIN_FAB | 21,33 Quantité minium de fabrication (unité : surface).
_SUP_REQ_RGT1 | 21,60 Supplément de sélection sur par02 Permet de garder uniquement les lieux de rangement non annulés.
SUPREQSTK | 21 à 60 Supplément de requête (sur la table stk0) Dans le cas où l'option -Orb est mise en place, la recherche se fait sur toutes les lignes de stocks existantes, le paramétrage de ce complément de sélection peut donc s'avérer indispensable.
_SUP_REQ_STK0_JOUR | Complément de sélection pour le calcul du stock physique par jour (voir zone CIC/NP5)

Liste des CIC utilisés pour le stockage des données

DP1 Date de début de la période de référence

DP2 Date de fin de la période de référence

DP3 Date de début de la période de référence (par lieu de rangement)

DP4 Date de fin de la période de référence (par lieu de rangement)

NC1 Coefficient de couverture utilisé pour le calcul

NC2 Délai moyen utilisé pour le calcul

NC3 Ecart type

NC4 Délais moyen utilisé pour le calcul (par lieu de rangement)

NC5 Ecart type (par lieu de rangement)

NP1 Nombre de sorties sur la période

NP2 Consommation moyenne sur la période

NP3 Quantité maxi sortie sur la période

NP4 Total des consommations sur la période

NP5 Stock moyen sur la période (Moyenne arithmétique du stock journalier)

NP6 Taux de couverture sur la période

NP7 Taux de rotation sur la période

NP8 Consommation moyenne journalière pour la période

NQ1 Seuil d'alerte de la fiche article avant mise à jour (par lieu de rangement)

NQ2 Stock mini/sécu de la fiche article avant mise à jour (par lieu de rangement)

NQ3 Stock maxi de la fiche article avant mise à jour (par lieu de rangement)

NQ4 Stock mini calculé (par lieu de rangement)

NQ5 Stock de sécurité calculé (par lieu de rangement)

NQ6 Stock d'alerte calculé (par lieu de rangement)

NR1 Consommation moyenne par mois (par lieu de rangement)

NR2 Stock moyen sur la période (par lieu de rangement)

NR3 Taux de couverture sur la période (par lieu de rangement)

NR4 Taux de rotation sur la période (par lieu de rangement)

NR5 Consommation moyenne par jour (par lieu de rangement)

NR6 Quantité maxi sur la période (par lieu de rangement)

NR7 Quantité totale sur la période (par lieu de rangement)

NR8

NS1 Seuil d'alerte de la fiche article avant mise à jour

NS2 Stock mini/sécu de la fiche article avant mise à jour

NS3 Stock maxi de la fiche article avant mise à jour

NS4 Stock mini calculé

NS5 Stock de sécurité calculé

NS6 Stock d'alerte calculé

NS7 Quantité minimum de fabrication

NS8 Consommation moyenne mensuel


Inventaire des stocks bobine

Inventaire des stocks bobine inv_bob_pap

Ce programme est opérationnel à partir de la V. 4.1.30.2 <VF>

A partir d'un fichier listant de manière exhaustive les bobines présentes dans un lieu, ce programme réalise les mouvements de stocks nécessaires pour que le stock bobine et papier informatique corresponde à la liste des bobines fournie.

Valeurs numériques

1 | Nombres de bobines calculées selon la liste au-delà de laquelle une confirmation sera demandée avant la correction des stocks
2 | Ecart de poids en dessous duquel aucun mouvement de correction ne sera réalisé (exemple : Si ‘2', il n'y aura pas de mouvement de correction si le poids en stock pour la bobine n'est pas différent du poids donné dans le fichier à plus ou moins 2 kg)

Options

-f | Fichier liste des bobines à intégrer : si utilisation de cette option, la fenêtre de saisie du nom du fichier ne s'ouvrira pas.
-Osi | Simulation : Le programme listera les actions à effectuer mais ne génèrera pas les mouvements de stocks de correction.
-Osm | Fonctionnement sans menu : les options chargement du fichier et correction des stocks s'enchaîneront.

Valeur alpha 2

A2[1,3] | Type du mouvement de stock pour les entrées correctives de bobine
A2[4,6] | Type du mouvement de stock pour les sorties correctives de bobine
A2[7,9] | Type du mouvement de stock pour les entrées correctives de papier
A2[10,12] | Type du mouvement de stock pour les sorties correctives de papier
A2[13] | Caractère de délimitation des fichiers en entrée (si pas zones de taille fixe)
A2[14,19] | Type et code du paramètre de lancement du programme crinv qui recalculera les PAMP des mouvements générés
A2[20] | Mode de calcul du stock informatique par rapport au fichier d'entrée 1 : Stock informatique calculé par lieu
A2[21,28] | Date de comptage par défaut (si pas dans le fichier d'entrée) au format DDMMYYYY
A2[29,31] | Magasin par défaut (si pas dans le fichier d'entrée)
A2[32,46] | Code bobine par défaut pour la création des bobines listées mais non présentes dans VoluPack

Valeur alpha 3

A3[1,30

Nom du fichier contenant la liste des bobines (avec répertoire et extension)

Notes

_SUP_REQ_BOBINE | 21,60 Complément de requête sur la table mat définissant les articles bobine pour le calcul des stocks informatiques
_SUP_REQ_PAPIER | 21 60 Complément de requête sur la table mat définissant les articles papier pour le calcul des stocks informatiques

Notes

Paramétrage des zones d'un fichier de bobines sans caractère de séparation (taille fixe).

Si une même ligne du fichier contient plusieurs bobines, il faut les numéroter de 1 à x

(remarque : le code papier de la bobine x de la ligne peut être au même emplacement que le code papier de la bobine 1)

Pour toutes les notes suivantes :

ZONE_XXXXXX

21,29 Caractère de début

31,39 Caractère de fin

ZONE_BOB_1 | Code de la bobine 1 d'une ligne du fichier
ZONE_BOB_x | Code de la bobine x d'une ligne du fichier
ZONE_DATE_1 | Date de comptage de la bobine 1 d'une ligne du fichier
ZONE_DATE_x | Date de comptage de la bobine x d'une ligne du fichier
ZONE_LOT_1 | Lot de la bobine 1 d'une ligne du fichier
ZONE_LOT_x | Lot de la bobine x d'une ligne du fichier
ZONE_PAP_1 | Code papier de la bobine 1 d'une ligne du fichier
ZONE_PAP_x | Code papier de la bobine x d'une ligne du fichier
ZONE_QTE_1 | Poids de la bobine 1 d'une ligne du fichier
ZONE_QTE_x | Poids de la bobine x d'une ligne du fichier
ZONE_RGT1_1 | Code magasin de la bobine 1 d'une ligne du fichier
ZONE_RGT1_x | Code magasin de la bobine x d'une ligne du fichier
ZONE_RGT2_1 | Laize de la bobine 1 d'une ligne du fichier
ZONE_RGT2_x | Laize de la bobine x d'une ligne du fichier
ZONE_RGT3_1 | Lieu de rangement 3 de la bobine 1 d'une ligne du fichier
ZONE_RGT3_x | Lieu de rangement 3 de la bobine x d'une ligne du fichier

Notes

Paramétrage des zones d'un fichier de bobines avec caractère de séparation.

Si une même ligne du fichier contient plusieurs bobines, il faut les numéroter de 1 à x

(remarque : le code papier de la bobine x de la ligne peut-être dans la même zone que le code papier de la bobine 1)

COL_BOB_1 | 21,29 Numéro de la zone contenant le code de la bobine 1 de la ligne du fichier
COL_BOB_x | 21,29 Numéro de la zone contenant le code de la bobine x de la ligne du fichier
COL_DATE_1 | 21,29 Numéro de la zone contenant la date de comptage de la bobine 1 de la ligne du fichier
COL_DATE_x | 21,29 Numéro de la zone contenant la date de comptage de bobine x de la ligne du fichier
COL_LOT_1 | 21,29 Numéro de la zone contenant le lot de la bobine 1 de la ligne du fichier
COL_LOT_x | 21,29 Numéro de la zone contenant le lot de la bobine x de la ligne du fichier
COL_PAP_1 | 21,29 Numéro de la zone contenant le code papier de la bobine 1 de la ligne du fichier
COL_PAP_x | 21,29 Numéro de la zone contenant le code papier de la bobine x de la ligne du fichier
COL_QTE_1 | 21,29 Numéro de la zone contenant le poids de la bobine 1 de la ligne du fichier
COL_QTE_x | 21,29 Numéro de la zone contenant le poids de la bobine x de la ligne du fichier
COL_RGT1_1 | 21,29 Numéro de la zone contenant le magasin de la bobine 1 de la ligne du fichier
COL_RGT1_x | 21,29 Numéro de la zone contenant le magasin de la bobine x de la ligne du fichier
COL_RGT2_1 | 21,29 Numéro de la zone contenant la laize de la bobine 1 de la ligne du fichier
COL_RGT2_x | 21,29 Numéro de la zone contenant la laize de la bobine x de la ligne du fichier
COL_RGT3_1 | 21,29 Numéro de la zone contenant le lieu de rangement 3 de la bobine 1 de la ligne du fichier
COL_RGT3_x | 21,29 Numéro de la zone contenant le lieu de rangement 3 de la bobine x de la ligne du fichier


Régularisation de la quantité informatique en stock

Régularisation de la quantité informatique en stock regularisation_stock_cab

Procédure de mini-inventaire

Options

O22 | CAB transformateur sur 22 caractères CAB transformateur sur 19 caractères si option non activée
Oep | Affichage d'un message d'alerte de réédition des étiquettes des palettes modifiées Option On3 obligatoire
On3 | On met à jour le lieu de niveau 3 # avec la quantité de PF par palette
Osr | Pas de mise à jour du stock résultant
Ote | Paramètres communs pour la gestion par codes à barres

Valeur alpha 2

1,3 | Type de mouvement sortie normale en régularisation. Obligatoire, doit être de type sortie normale
4,6 | Type de mouvement entrée normale en régularisation. Obligatoire, doit être de type entrée normale

Notes

_STYLE_CAB

Paramètres communs pour la gestion par codes à barres


Valorisation des stocks à une date donnée

Pour les matières par exemple en unité d'achat à la tonne et en unité de vente à la feuille.

On commande des feuilles au fournisseur et on obtient un poids théorique en tonnes.

La réception se fait en feuille (ou en poids) avec un calcul théorique (poids en tonnes ou nombre de feuilles suivant la saisie.

Il est possible dans cette réception d'indiquer un poids réel.

Exemple : on réceptionne 10.000 feuilles, ce qui donne un poids théorique de 3.399 tonnes, mais en réalité le poids est de 3,5 tonnes.

Lors de la valorisation matières (prix en tonnes), la valeur se calcul par rapport au mouvement de stock d’entrée de la matière (la quantité est exprimée ici en feuilles), donc par rapport au poids théorique, soit ici 10.000 feuilles, qui donne 3,399 tonnes à multiplier par le prix de la matière.

Sur option, on veut que ces 10.000 feuilles soit valorisées au poids réel réceptionné, c'est-à-dire 3,5 tonnes.

Cette nouvelle valorisation ne se fait que pour les matières, et dans le cadre d’une valorisation par lot ou lot-lieux.

Les zones Stock en unité d'achat (zone z) et Valeur Stock sont donc impactées.

Les zones de quantité en MAD, … ne sont pas impactées.

Valorisation des stocks à une date donnée - Etat préparatoire d'inventaire valst

Voir aussi la page dédiée aux exports vers Excel

12 valorisations possibles

  • Selon le code valorisation du fichier article

  • en prix d'achat moyen pondéré

  • au dernier prix d'achat enregistré

  • au prix d'achat du fichier matière

  • au prix de revient du fichier matière

  • au prix de vente fichier

  • au prix de vente du fichier matière

  • au niveau des mouvements

  • au FIFO

  • au PRP de la dernière FBI

  • au coût matière

Valeurs numériques

1 | Type de format pour l'édition de la quantité, utilisé dans l'édition abrégée et les statistiques 0 ------------& 1 ----------&.& 2 ---------&.&& (valeur par défaut) 3 --------&.&&&
2 | Nombre de jours de dépassement pour la colonne valeur comptable (colonne :) (Par défaut 0)

Options triées

O1m

Valorisation avec le prix de la 1ère entrée en stock du lot

Pensez au paramétrage suivant :

A3[13] = 3 (Type de valorisation au prix d'achat)

A3[32] = 4 (Mode de valorisation du stock doit être par lot/lieu)

Note SUP_REQ_1_ENT_LOT

Oaa

Traite les articles annulés

Oam

Code ensemble associé au produit (colonne CW)

Si la table amal est présente, recherche du code composant dans l'amalgame

Occ

On valorise uniquement les lots (type valo 3) des dossiers qui ne sont pas clôturés

Dossier = Commande (caractères 1 à 8 du lot)

Oct

Numéro de l'OF qui a servi à fabriquer le lot (colonne ~) (tilde)

Initialisation de la colonne avec le numéro de commande et la ligne de commande du lot si la colonne n'est pas renseignée.

Ocf

Cas des cadencements de fabrication : Recherche le prix de vente du lot sur la ligne de commande associée au code produit mouvementé

Ocl

Etat des stocks clients. Si le dossier n'est pas clos et si aucune facture n'a été calculée sur ce dossier, les sorties de stocks ne sont pas prises en compte.

Ocr

Tri et rupture sur le code représentant du lot du mouvement de stock (Tri 14)

Odm

Force la prise des dimensions sur la fiche matière du produit mouvementé.

Oet

Environnement TVA de la FBI pris en compte

Ofp

Interdiction de lancer une valorisation dont la date est supérieure à la date du TOP de fin de période (TOP FIN)

Ogp

Gestion par palette. Si cette option est positionnée, le lieu de rangement 3 est interprété comme étant la quantité par palette. (Le titre de la colonne devient Qt/pal)

Ogs

Impression du total général sans impression des totaux intermédiaires

A3[6] doit être à O. Voir aussi A3[36]

Oim

Imprimerie

Oir

Tri sur la 2nde partie de rgt2. Valable pour les tris 8 et 9.

Cette option nécessite l'activation de la gestion des états palettes #CF ATL

Ola

Valorisation des lots au prix d'achat de la ligne de commande d'achat

Si la ligne de commande d'achat n'est pas trouvée, le lot sera valorisé au PAMP si la valeur du stock de l'article et son stock physique sont différents de 0.

Sinon, le lot sera valorisé au prix d'achat de l'article.

Pour valoriser les lots au prix d'achat de la ligne de commande d'achat, vous devez lancer une valorisation par lots ou par lots - lieux ou par lieux - lots au prix d'achat du fichier matière.

ATTENTION

Pour la valorisation de type R, si l'option Ola est positionnée en plus de l'option Olr :

1 - Recherche de la zone lc_prx_revient de la ligne de commande correspondant au lot.

2 - Recherche de la zone lf_prix de la commande fournisseur correspondant au lot.

3 - Si la commande fournisseur n'existe pas, on prend la zone mp_pr.

Olb

Le lot du papier est égal au numéro du BRU

Olc

On valorise uniquement les lots (type valo 3) des dossiers qui ne sont pas clôturés

Dossier = Commande (caractères 1 à 8 du lot) + ligne (caractères 10 à 12 du lot)

Olf

Prix sur ligne commande fournisseur

La commande fournisseur et sa ligne sont prises sur le champ s0_lot.

Olr

Pour les articles valorisés au prix de revient (Type de valorisation R)

Si la valorisation est par lot, lot - lieu ou lieu - lot, le prix de revient est cherché sur la ligne de commande (le prix de revient de la ligne de commande est le coût global de revient de la ligne de commande).

Pour les articles appairés, il y a proratisation en fonction du ratio prix de revient PF par rapport au prix de revient Ensemble.

La proratisation peut être faite en fonction du poids (Ovp) ou de la surface (Ovm).

Voir le paragraphe ATTENTION dans l'option Ola.

Olv

Valorisation des mouvements de stock au prix de vente du lot dans la valorisation par lieu (A3[32]=2)

Omj

Met à jour la zone prix unitaire dans le fichier des stocks pour tous les mouvements de sortie

Omp

Prise en compte des mouvements prévisionnels de stock

ATTENTION : ne peut pas être utilisée pour valoriser le stock.

Omt

Mise à jour de la table des stocks période (stk0_periode)

On2

Paramétrage des colonnes sur 2 caractères (voir valeur alpha 2)

Pour visualiser les données sur une colonne, ajouter un blanc. Exemple : A B BHX

Op1

Valorisation au prix d'achat du lot au lieu au prix d'achat de la fiche article

Utilisée si option Omt

Op2

Valorisation au prix de vente du lot au lieu au prix de vente de la fiche article

Utilisée si option Omt

Opa

Le poids unitaire est toujours pris dans la fiche article. (calcul du poids en stock, colonne <)

Opd

Affiche les poids et surface du stock avec les décimales

Sans cette option, il n'y a pas les décimales.

Ope

Calcul des prix de vente et de revient par élément

Opl

Le poids unitaire est toujours pris sur la ligne de commande (via le lot) pour la colonne "<"

Opn

Fonctionne avec l'option Ops (voir ci-dessus), le poids édité est le poids net (et non le poids brut)

Opr

Dans la valorisation au prix de revient de la dernière FBI, si la dernière FBI n'a pas de prix de revient, on prend le prix de revient de l'article

Ops

Les colonnes poids et surface sont issues des TSC 201 et 202 sur l'article. Il s'agira alors des poids et surfaces bruts (voir -Osn et -Opn ci-dessous)

Oqm

Permet de trier par qualité matière et code matière lorsque un tri par code matière est prévu

Oqr

Prise en compte du poids réel de la matière lors de sa réception, pour le calcul de la valorisation du stock

Plus d'info - Incompatible avec la note UTIL_S0_QTE_UNITE_2

Oqt

Tri Tiers - Qualité matière remplacé par Qualité matière - Tiers dans les tris 5 et 6

Nécessite l'option Oqm

Or2

Initialisation de la zone largeur de la fiche article (mp_lar) avec la zone largeur du mouvement de stock (s0_rgt2) pour le coef_conv

Ore

Dans le tri E,si cette option est paramétrée, le représentant est recherché sur l'entête de commande si celui-ci n'est pas renseigné sur la ligne de commande, puis sur le client de la commande si celui-ci n'est pas renseigné sur l'entête de commande.

Ori

Activation de la répétition des informations

Orv

Recalcul de la valeur du stock avec la quantité globale par le prix unitaire

Ne fonctionne qu'avec la valorisation au prix d'achat, de revient ou de vente de la fiche article.

Osa

La sélection multicritère sur la fiche article est réalisée via la grille de sélection article complète

Sans cette option, la sélection s'effectue simplement sur quelques zones

Osc

Numéro de lot (colonne X)

Suppression du cadencement de livraison du lot

Osn

Fonctionne avec l'option -Ops (voir ci-dessus), la surface éditée est la surface nette (et non la surface brute)

Osr

Proratisation du prix du lot via les prix de revient sans recalculer le prix de revient de l'ensemble

Ost

Prise en compte de la sous-traitance dans le calcul du FIFO module non standard

Ot1

Totalisation sur le lieu de rangement 1 uniquement si valorisation par lieux lots (A3[32]=5) et tri 8, 9, A ou F (A3[35])

Otd

Editer seulement les lots dont la période de consigne dépasse le délai maximum de consignation + un nombre de jours de tolérance de consignation

Otr

Lors de la valorisation au prix d'achat de la fiche article, on va rechercher ce prix d'achat dans les tarifs valides à la date de la valorisation selon une recherche simplifiée paramétrable

Voir les notes PARAM_VALO_TARIF et SUP_REQ_VALO_TARIF

Ots

Effectuer le tri en priorité sur le code site rattaché au magasin

Cette option est complémentaire du critère de tri paramétré en A3[35].

A utiliser avec la colonne EH : Code site rattaché au magasin

Tableau de bord du multisite

Ov0

Forcer la valeur à 0 si le stock est négatif.

Ova

Edite les articles qui ont le code non valorisé dans le fichier matière.

La valorisation sera toujours nulle même si un prix a été renseigné sur les mouvements.

Ovl

Pour les articles valorisés au prix de vente

Si la valorisation est par lot, lot - lieu ou lieu - lot, le prix de vente est cherché sur la ligne de commande

Pour les articles appairés

Il y a proratisation en fonction du ratio prix de revient PF par rapport au prix de revient Ensemble.

Ovm

Produits appairés valorisés au prorata des surfaces

Nécessite de valoriser au prix de vente ou au prix de revient

Utilisée si option Ovl ou Op2 ou Olr

Ovp

Permet de valoriser les éléments appairés au prorata de leur poids sur le poids de l'ensemble

Nécessite de valoriser au prix de vente ou au prix de revient

Utilisée si option Ovl ou Op2 ou Olr

Ovs

Affichage de la valeur de stock en édition non détaillée

Ovu

Lors de la recherche du prix sur le lot, si le lot n'existe pas, on prend le prix de vente

Valeur alpha 2

Paramétrage des colonnes d'édition - Voir les tableaux en bas de ce document

Valeur alpha 3

Caractères 1 à 30

Paramétrage des options de valorisation.

Caractère1

Valorisation mouvements d'inventaire uniquement (O/N, N par défaut)

Caractère 2

Etat préparatoire inventaire (O/N, N par défaut)

Caractère 3

Lieu de rangement niveau 1 seulement

O Oui (par défaut si pas de gestion par lieux, ou si gestion par lieux niveau 1)

N Non (par défaut si gestion par lieux niveaux 1, 2 et 3)

2 Si gestion des lieux 1, 2 et 3 le lieu 3 sera exclu.

Caractère 4

Valorisation lieux lots au prix du produit

O Oui Prix calculé avec tous les mouvements du produit

N Non (par défaut) Prix calculé avec seulement les mouvements du lieu ou du lot ou du lot lieu ou du lieu lot

Caractère 5

Edition quantités sur lignes de totalisation (O/N, N par défaut)

Caractère 6

Edition lignes de totalisation (O/N, O par défaut)

Caractère 7

Edition de lignes vides après chaque ligne

N Non (par défaut)

1 à 9 Nombre de lignes a éditer

Caractère 8

Le titre de l'état = ETAT PREPARATOIRE DES MVTS JOURNALIERS (O/N, N par défaut)

Caractère 9

On édite une ligne de tirets après chaque ligne éditée. (O/N, N par défaut)

Une ligne de tiret sera systématiquement éditée si l'option 2 est choisie

Caractère 10

Edition lignes total article si valorisation lieux lots (O/N, O par défaut)

Caractère 11

Mode de calcul standard du FIFO (O/N, O par défaut)

Caractère 12

Edition prix et valeur sur lignes total article au lieu sur lignes détail lieux, lots, lots lieux ou lieux lots (O/N, N par défaut)

Caractère 13

Type de valorisation

[blanc] pas de menu imposé

E Edition selon le type de valorisation de l'article

P Valorisation au PAMP

D Valorisation au dernier prix d'achat

A Valorisation au prix d'achat de la fiche article

R Valorisation au prix de revient de la fiche article

V Valorisation au prix de vente de la fiche article

M Valorisation au prix du mouvement

F Valorisation FIFO

Z Edition valorisée au PRP de la dernière FBI

C Edition valorisée au coût matière

Caractère 14

Si l'article est un ensemble monté, la famille et la sous famille sont celles du premier PF de la nomenclature (O/N, N par défaut)

Caractère 15

Prise en compte de la remise de l'entête de commande (lot) dans le calcul du prix de vente (O/N)

Caractère 16

Prise en compte de la remise de la ligne de commande (lot) dans le calcul du prix de vente (O/N)

Caractères 31 à 60

Paramétrage des ouvertures de fenêtre. Par défaut : [à blanc]

Caractère 31

Fenêtre SELECTION

[blanc] Saisie d'un critère de sélection

S Pas de saisie d'un critère de sélection

Caractère 32

Fenêtre VALORISATION

[blanc] Ouverture fenêtre VALORISATION

1 Valorisation globale

2 Valorisation par lieux

3 Valorisation par lots

4 Valorisation par lots lieux

5 Valorisation par lieux lots

Caractère 33

Valorisation globale ou par lieux ou par lots pour tous les articles

Facultatif si ouverture de la fenêtre VALORISATION

Obligatoire si pas d'ouverture de la fenêtre VALORISATION

[blanc] Si ouverture fenêtre VALORISATION

O Oui

N Non

Caractère 34

Fenêtre TYPE EDITION

[blanc] Ouverture fenêtre TYPE EDITION

1 Tous les stocks

2 Stocks positifs et négatifs

3 Stocks positifs

4 Stocks négatifs

5 Stocks positifs et à 0

6 Stocks à 0 et négatifs

7 Stocks à 0

Caractère 35

Fenêtre TRI

[blanc] Ouverture fenêtre TRI

1 Tri par code

2 Tri par désignation

3 Tri par famille / sous-famille / code

4 Tri par famille / sous-famille / désignation

5 Tri par client / code

6 Tri par fournisseur / code

7 Tri par longueur / largeur / grammage / code

8 Tri par lieu ou lot ou lieu lot ou lot lieu en fonction du flag 32, puis par code article

9 Tri par lieu ou lot ou lieu lot ou lot lieu en fonction du flag 32, puis par code client et par code article

A Tri par lieu ou lot ou lieu lot ou lot lieu en fonction du flag 32, puis par type de produit, par famille, par sous-famille et par code article. Le type de produit correspond à la sous famille de la compo technique.

B Tri sur catégorie de produit, lieu de rangement, type de produit, famille, sous-famille et code article

C Tri par famille/sous-famille de composition technique, Type, Code.
Ne pas utiliser la fenêtre de choix des ordres de tri.

D Tri par famille/sous-famille de composition commerciale, Type, Code.
Ne pas utiliser la fenêtre de choix des ordres de tri.

E Tri par code représentant du lot du mouvement de stock, le code client du lot du mouvement de stock et par code article.

F Tri par lieu ou lot ou lieu - lot ou lot - lieu en fonction du flag 32, puis par code client du mouvement de stock et par code article.

G Tri par client du mouvement, article, type de valorisation
(lieu, lot, lieu-lot, lot-lieu selon choix A3[31])
Ne pas utiliser ce code si on génère des mouvements d'inventaires car ceux-ci n'ont pas de code client, ce qui fausse l'état.

Caractère 36

Ouverture fenêtre détaillée (O/N, N par défaut)

[blanc] Ouverture fenêtre détaillée

O Avec détail

N Sans détail

Caractère 37

Fenêtre date de valorisation

[blanc] Ouverture fenêtre date de valorisation

J Valorisation des mouvements limités à la date du jour

S Valorisation de tous les mouvements

D Valorisation des mouvements limités à la date paramétrée en A3[39,46]

1 Valorisation des mouvements à la date du jour - 1 journée

Caractère 38

Fenêtre de saisie d'un critère de sélection lot / lieu de rangement sur les mouvements de stock si valorisation autre que globale (O/N, N par défaut)

Caractères 39 à 46

Date de valorisation (Format JJMMAAAA)

Obligatoire si fenêtre date de valorisation = D (A3[37])

Exemple : 31082005

Caractère 47

Mode de calcul de la colonne AK (valeur des actions de service)

1 Le calcul de la colonne AK se fait en proratisant le coût prévu pour chaque mouvement associé au lot en cours de valorisation. (Par défaut)

2 Le prix des actions de service est égal à la quantité du lot multipliée par le prix des actions de service du lot.

Caractère 48

Choix du prix de revient unitaire du lot

Vide : lc_prx_revient/quantité ligne

1 : lc_prx_rev_uni

Valeur alpha 4

Titre de l'état

Notes triées

Les notes pour l'alimentation de la table stk0_periode sont regroupées dans un tableau séparé, sous ce tableau.

AFFICHAGE_TOTAL_QTE

Affichage de la totalisation des colonnes

21 Affichage de la totalisation de la colonne quantité stock en UU

22 Affichage de la totalisation de la colonne quantité stock en UA

23 Affichage de la totalisation de la colonne Stock physique mise à disposition UU

24 Affichage de la totalisation de la colonne Stock physique mise à disposition UA

25 Affichage de la totalisation de la colonne Stock physique hors mise à disposition UU

26 Affichage de la totalisation de la colonne Stock physique hors mise à disposition UA

27 Affichage de la totalisation de la colonne Stock physique

28 Affichage de la totalisation de la colonne stock en unité UU paramétrée

29 Affichage de la totalisation de la colonne stock en unité UA paramétrée

CODE_AS

21,35 Code article recherché dans la table pour retrouver le code action de service

Valable uniquement pour les colonnes AK et AL

20 notes maximum peuvent être déclarées

CODES_ETATS_PALETTE_

Codes état palette

21,23 Code état VENDABLE

24,26 Code état NON VENDABLE

27,29 Code état A RETRAITER

30,32 Code état A DETRUIRE

Utilisée si option Omt

A3[3] (Lieu de rangement niveau 1 seulement) doit être à N sinon le code état est toujours VENDABLE et le lieu de rangement de niveau 2 est à blanc.

Exemple : VENNVEAREADE

COL

Remplacement des libellés des entêtes de colonnes dans le cas d'une gestion par colis et non par palette

Attention à la syntaxe : pas de caractère souligné (undescore), un espace avant et après le X

Caractères 5,6 : Colonne

Caractère 7 : [le signe "deux-points"]

Caractères 8,60 Titre de la colonne

Exemples

COL ? : Ce qui suit sur la ligne correspond au titre de la colonne libre 1

COL / : Ce qui suit sur la ligne correspond au titre de la colonne libre 2

COL # : Ce qui suit sur la ligne correspond au titre de la colonne libre 3

COL @ : Ce qui suit sur la ligne correspond au titre de la colonne Nb/pal

COL & : Ce qui suit sur la ligne correspond au titre de la colonne libre Qt/pal

COL ~ : Caractères 8 à 18 : Titre de la colonne ~ (11 car.max.)

COL AK: Caractères 8 à 48 : Titre de la colonne AK

COL AL: Caractères 8 à 48 : Titre de la colonne AL

COL CL: Caractères 8 à 23 : Titre de la colonne CL (16 car.max.)

Pour info : les colonnes 1, 2 et 3 qui faisaient référence aux colonnes libres ?, / et # font maintenant référence aux colonnes 1, 2 et 3 et doivent donc être remplacées par les colonnes ?, / et #

L'exemple suivant permet de remplacer Nb/pal par Nb/col et Qt/pal par Qt/col

1234567890123

COL @ :Nb/col

COL & :Qt/col

CR

4 à 60 Critère de sélection sur table mat

Exemples

CR and mp_code matches PRD*

CR and mp_suistk = O

CS

4 à 60 Critère de sélection sur table stk0

Exemple

CS and s0_rgt1 = CET

DELAI_CONSIGNE

21,60 Tolérance sur le délai maximum de consigne (en nombre de jours, 0 par défaut)

ENV_CALCUL

21,23 Code environnement pour le calcul du tarif de cession (STD par défaut)

LISTE_AS_A_DEDUIRE

21,35 Action de service à déduire

Concerne la colonne paramétrable 8.

Exemple

XASADM

N

Edition des notes

3, 5 Type de note à éditer

7,8 N° de ligne à lire

10,11 Longueur à éditer

13,14 Position du 1er caractère

Exemple

N BOB 01 30 10 permet d'éditer les 30 premiers caractères de la 1ère ligne de notes de type BOB saisie sur l'article à partir du 10ème caractère.

PARAM_COLONNES

21,60 Paramétrage des colonnes d'édition sur 1 ou 2 caractères (option On2)

Elles viennent en complément des colonnes d'édition paramétrées dans la valeur alpha 2.

Exemple : DJDKDLDMDNDODP

PARAM_VALO_TARIF

Recherche des tarifs - Voir l'option Otr

21 Quel tarif doit on prendre :

M On prend le plus cher (Maxi) [valeur par défaut]

m On prend le moins cher (mini)

22 Sur quel code produit la recherche de tarif s'effectue-t-elle ?

C On prend le code de l'article [Valeur par défaut]

Q On prend le code qualité matière de la fiche article

23 Sur quel client la recherche de tarif s'effectue-t'elle ?

C On prend le client de la fiche article

F On prend le fournisseur de la fiche article

[blanc] La recherche se fait tous clients confondus [Valeur par défaut]

25,27 Code du tarif recherché

Si non renseigné, la recherche se fera sur tous les codes confondus

POURC_VETUSTE

21,26 Pourcentage de décote à appliquer

PREFIXE_COMCAR

21 Caractère préfixant les articles de composition technique (par défaut : C)

PREFIXE_QUACAR

21 Caractère préfixant les articles de composition commerciale (par défaut : Q)

SUP_DATEn_REQn

Voir le tableau séparé

SUP_REQ_1_ENT_LOT

Complément de requête pour la recherche du 1er mouvement d’entrée sur le lot.

SUP_REQ_AGE_STOCK

21,60 Complément de requête sur stk0 et mat pour rechercher la dernière date de sortie

S'il n'y a pas de complément, la dernière date de sortie correspond à la dernier date de sortie sur l'article. Note cumulative

SUP_REQ_DATDERMVT

21,60 Complément de sélection de recherche de la date de dernier mouvement sur la table stk0 (doit commencer par un and)

Uniquement pour les colonnes AA (date dernière entrée) et AB (date dernière sortie).

Le complément est commun aux deux colonnes.

sup_req_fab

Attention : cette note s'écrit en minuscules

12,60 Complément de requête Déclaration de production

sup_req_fbi

Attention : cette note s'écrit en minuscules

12,60 Complément de requête FBI

_SUP_REQ_INIT_STK0_P

Complément de requête d'initialisation de la table stk0_periode

Utilisée si option Omt

Exemple : and spe_rgt1 = "USI"

_SUP_REQ_PR_ENSEMBLE

21,60 Complément SQL sur les tables mat et nom0 pour la recherche des composants à prendre en compte pour le calcul du PR de l'ensemble

Par défaut :

and n0_pcsant matches "P*"

SUP_REQ_QTE_FAB_CAD

21,60 Complément de requête pour le calcul de la quantité fabriquée du cadencement de fabrication (table stk0)

Utilisé pour calculer les colonnes DK et DO

Exemple

and s0_typ in ("FR")

SUP_REQ_QTE_LAN_CAD

21,60 Complément de requête pour le calcul de la quantité lancée du cadencement de fabrication

Utilisé pour calculer les colonnes DJ et DN

Exemple

and ((ccf_prod[1,2] = "AF"

and ccf_type_enr = "E"

and ccf_type_cad in ("IMP", "GLO"))

or (ccf_prod[1,2] != "AF"

and ccf_type_enr != "E"

and ccf_type_cad != "IMP"))

SUP_REQ_QTE_LIV_CAD

21,60 Complément de requête pour le calcul de la quantité livrée du cadencement de fabrication (table stk0)

Utilisé pour calculer les colonnes DL et DP

Exemple

and s0_typ in ("LCR")

SUP_REQ_QTES_SOR_NOR

21,60 Complément de requête pour le calcul de la somme des quantités de sortie normale entre la date pour taux de rotation et la date de valorisation

Utilisé pour le calcul de la colonne BU

SUP_REQ_RG1_SITE_USE

21 Limiter le traitement aux lieux de rangement du site de l'utilisateur qui lance la valorisation (O/N, N par défaut).

Tableau de bord du multisite

SUP_REQ_VALO_TARIF

21,60 Complément de recherche sur la table tar0 - Voir l'option Otr

TSC

Colonnes TSC éditables (10 maxi)

7 champs suivis d'un astérisque

type TSC

libellé

code TSC

code zone

longueur

using

numéro de colonne

Exemple

TSC*A*C/P*M38*ic_num3*4*####*14*

TYPE_DATEn_REQn

Voir le tableau séparé

TYPE_NOTE_DER_ENTREE

21,23 Type de Note de la dernière entrée (colonne BM)

UNITE_UTI_COLONNE_DW

21,23 Unité d'affichage de la colonne DW

Voir aussi la note FORMULE_CONV_YYY dans le paramètre UNI

UNITE_ACH_COLONNE_DX

21,23 Unité d'affichage de la colonne DX

Voir aussi la note FORMULE_CONV_YYY dans le paramètre UNI

USI

Using des colonnes

5,6 Colonne (4 , DW, …)

7 Séparateur :

8,60 Using à utiliser pour la colonne codifiée par les caractères 5 et 6

Exemple

--------&.&&&

Le paramétrage du using est valable pour les colonnes suivantes :

K, M, N, O, T, U, V, W, Y, a, b, c, z, 0, 4, +, à, é, è, ç,

BL, BN, BO, BP, BQ, BR, BS, BT, BU, BV, DG, DH, DI, DJ, DK, DL, DM, DN, DO, DP, DW, DX

UTIL_S0_QTE_UNITE_2

21 Possibilité d'utiliser pour l'unité d'achat la nouvelle zone quantité en unité 2 de la table des stocks (stk0.s0_qte_unite_2) (O/N)

Incompatible avec l'option Oqr

Voir aussi les options Opa et Oua dans la saisie des bons de réception.

Notes pour l'alimentation de la table stk0_periode

Ajout de 2 nouvelles zones date dans la table stk0_periode

Alimentation à l'identique de celle qui est faite pour la table stk_lot_lieu

SUP_DATE1_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock pour la mise à jour de la 1ère date de la table stk0_periode (spe_date1)
SUP_DATE1_REQ2 | 21,60 Supplément de la 2ième requête sur la table des mouvements de stock pour la mise à jour de la 1ère date de la table stk0_periode (spe_date1)
SUP_DATE2_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock pour la mise à jour de la 2ième date de la table stk0_periode (spe_date2)
SUP_DATE2_REQ2 | 21,60 Supplément de la 2ième requête sur la table des mouvements de stock pour la mise à jour de la 2ième date de la table stk0_periode (spe_date2)
TYPE_DATE1_REQ1 | 21 Type de date de la 1ère requête de la 1ère date de la table stk0_periode (spe_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus petite date des mouvements de stock (min(s0_datm)) 3 Sur la plus grande date des mouvements de stock (max(s0_datm)) (par défaut)
TYPE_DATE1_REQ2 | 21 Type de date de la 2ième requête de la 1ère date de la table stk0_periode (spe_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus petite date des mouvements de stock (min(s0_datm)) 3 Sur la plus grande date des mouvements de stock (max(s0_datm)) (par défaut)
TYPE_DATE2_REQ1 | 21 Type de date de la 1ère requête de la 2ième date de la table stk0_periode (spe_date2) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus petite date des mouvements de stock (min(s0_datm)) 3 Sur la plus grande date des mouvements de stock (max(s0_datm)) (par défaut)
TYPE_DATE2_REQ2 | 21 Type de date de la 2ième requête de la 2ième date de la table stk0_periode (spe_date2) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus petite date des mouvements de stock (min(s0_datm)) 3 Sur la plus grande date des mouvements de stock (max(s0_datm)) (par défaut)

Exemple

SUP_DATE1_REQ1 and s0_datm > "01/01/2001"

TYPE_DATE1_REQ1 1

SUP_DATE2_REQ1 and s0_datm < "21/12/2008"

TYPE_DATE2_REQ1 2

Valeur alpha2 - Paramétrage des colonnes d'édition

Le paramétrage des colonnes d'édition se fait sur 1 caractère ou sur 2 caractères (option -On2)

Si option On2, pour visualiser les données sur une colonne, ajouter un blanc. Exemple : A B BHX

Exemples d'éditions particulières

Inventaire valorisé à une date donnée #ED VSI

Valeur alpha2 | AB3z68
Valeur alpha3 | ONONNO ou ONNNNO (Caractère 1= O)

Etat préparatoire à l'inventaire #ED VSP

Valeur alpha2 | AB3-zt
Valeur alpha3 | NOONNO ou NONNNO (Caractère 2 = O)

Valeur alpha 2 : paramétrage des colonnes d'édition sur un caractère

Par défaut CEAB3r4z5678

(*) Zones issues du calcul de la valorisation de stock

Zones directement issues du fichier matière (hors calcul)

A | Code matière / produit
B | Désignation matière / produit
C | Code famille
D | Libellé famille
E | Code sous-famille
F | Libellé sous-famille
G | Prix d'achat
H | Prix de revient
I | Prix de vente
J | Code TVA
K | Stock physique
L | Valeur du stock
M | Stock mini
N | Stock maxi
O | Stock disponible
P | Code normalisé
Q | Prix de vente dans l'unité d'utilisation
R | Code fournisseur principal
S | Délai moyen d'approvisionnement fournisseur
T | Minimum commande fournisseur
U | Quantité économique de commande
V | Stock en commande fournisseur
W | Stock réserve
X | Numéro de lot (si option) Suppression du cadencement de livraison du lot
Y | Stock issu d'une simulation
Z | Classement A/B/C
a | Hauteur
b | Longueur
c | Largeur
d | Code conditionnement
e | Code couleur
f | Poids
g | Code unité d'achat
h | Libellé unité d'achat
i | Code unité de vente
j | Libelle unité de vente
k | Code formule de conversion
l | Code produit de remplacement
m | Taux de frais
n | Taux de perte
o | Taux de marge
p | Suivi en stock (O/N)
q | Type de valorisation
r | Date du dernier mouvement
s | Code matière ou produit (M/P)
t | Zone libre
u | Première zone de rangement du fichier matière (RG1)
v | Deuxième zone de rangement du fichier matière (RG2)
w | Troisième zone de rangement du fichier matière (RG3)
x | Valeur unitaire du stock (à la date de valorisation)
y | Code client principal (issu du fichier matière)
z (*) | Stock physique total dans l'unité d'achat à la date de valorisation
0 (*) | Quantité à commander Quantité à commander = stock maximum disponible Disponible = stock physique + stock en commande fournisseur - stock en réserve)
1 | Format (longueur x largeur) sans décimales
2 | Grammage (g/m2) sans décimales
3 | Date du dernier inventaire
4 (*) | Stock physique total dans l'unité d'utilisation à la date de valorisation
5 | Mode de valorisation paramétré, par défaut celui de la fiche article (P,D,V)
6 (*) | Prix en unité d'achat (à la date de valorisation)
7 (*) | Prix en unité d'utilisation (à la date de valorisation)
8 (*) | Valeur stock (à la date de valorisation)
9 | Nom du client principal (fichier matière)
- | Lieu de rangement RG1 du mouvement (si option)
% | Libellé du lieu RG1 (si option)
+ | Seuil d'alerte (fiche article)
= | Lieu de rangement RG2 du mouvement (si option)
& | Lieu de rangement RG3 du mouvement (si option)
? | Colonne libre 1 (voir paramétrage notes)
/ | Colonne libre 2 (voir paramétrage notes)
# | Colonne libre 3 (voir paramétrage notes)
( | Nom du fournisseur principal (fichier matière)
) | Note sur fichier article (voir paramétrage notes)
! | Référence client (Zone le_libpar1 de la table des libellés spécifiques)
: (*) | Valeur comptable stock (à la date de valorisation)
_ | Provision = valeur (à la date de valorisation) - valeur comptable (à la date de valorisation)
° | 1ere ligne de commentaires sur le mouvement d'entrée du papier
< | Poids en stock
> | Surface en stock (en m2)
. | Code client du LOT
, | Nom client du LOT
; | Libellé article du LOT
{ | Date de la dernière entrée
} | Date de la dernière sortie
[ | Donnée technique alpha 1
] | Donnée technique alpha 2
@ | Nombre de palettes (uniquement si gestion par palettes -Ogp)
â | Nombre de bobines
à (*) | Stock physique mise à disposition dans l'unité d'achat à la date de valorisation
é (*) | Stock physique mise à disposition dans l'unité d'utilisation à la date de valorisation
è (*) | Stock physique hors mise à disposition dans l'unité d'achat à la date de valorisation
ç (*) | Stock physique hors mise à disposition dans l'unité d'utilisation à la date de valorisation
$ | Prix au 100 Kgs (colonne 8 / colonne <) * 100
' | Type de produit (sous famille de la composition technique). A n'utiliser que pour le type de tri A
^ | Libellé du type de produit. A n'utiliser que pour le type de tri A
~ | Numéro de l'OF qui a servi à fabriquer le lot Initialisation de la colonne avec le numéro de commande et la ligne de commande du lot si la colonne n'est pas renseignée
* | Date de déclaration de production la plus ancienne pour l'OF qui a servi à fabriquer le lot
û | Référence commande client (lc_p3). Si lc_p3 vide : ec_ref - idem colonne Uc

Valeur alpha 2 : Paramétrage des colonnes d'édition sur 2 caractères

!!

(Deux points d'exclamation) Référence fournisseur du produit

Idem colonne ! mais pour le fournisseur de la fiche matière au lieu du client.

AA

Date de la dernière entrée du lot (disponible si valorisation par lot)

Voir la note SUP_REQ_DATDERMVT

AB

Date de la dernière sortie du lot (disponible si valorisation par lot

Voir la note SUP_REQ_DATDERMVT

AC

Nom du client livré

AD

Lieu (ville) de facturation du lot (disponible si valorisation par lot)

AE

Code postal de livraison du lot

AF

Code pays de livraison du lot

AG

Libellé du pays de livraison du lot

AH

Code postal de facturation du lot

AI

Code pays de facturation du lot

AJ

Libellé du pays de facturation du lot

AK

Code colonne de la valeur des actions de service (voir les notes commençant par COL)

AL

Code colonne de la différence entre la valeur du stock et la valeur des actions de service

(voir les notes commençant par COL)

AM

Famille de la composition technique (Code)

AN

Famille de la composition technique (Libellé)

AO

Sous-famille de la composition technique (Code)

AP

Sous-famille de la composition technique (Libellé)

AQ

Libellé étranger (le_libelle)

AR

Famille de la composition commerciale (Code)

AS

Famille de la composition commerciale (Libellé)

AT

Sous-famille de la composition commerciale (Code)

AU

Sous-famille de la composition commerciale (Libellé)

AV

Délai maximum de consigne pour le client

AW

Période actuelle de consigne de l'article

AX

Indicateur de dépassement du délai maximum de consigne

AY

Code famille de la commande du lot

AZ

Code sous famille de la commande du lot

BA

Libellé court de la famille de la commande du lot

BB

Libellé court de la sous famille de la commande du lot

BC

Libellé long de la famille de la commande du lot

BD

Libellé long de la sous famille de la commande du lot

BE

Code de la qualité matière

BF

Désignation de la qualité matière

BG

Code client du mouvement de stock

BH

Nom client du mouvement de stock

BI

Code représentant du mouvement de stock

BJ

Libellé court du code représentant du mouvement de stock

BK

Libellé long du code représentant du mouvement de stock

BL

Stock physique total dans l'unité d'utilisation à la date de fin du mois précédent la date de valorisation

BM

Note de la dernière entrée

BN

Stock théorique avant inventaire

BO

Différence valeur par article (entre date avant inventaire et date inventaire)

BN doit être activée.

BP

Différence quantité par article (entre date avant inventaire et date inventaire)

BN doit être activée.

BQ

valeur absolue de la différence valeur article

BN doit être activée.

BR

valeur absolue de la différence quantité article

BN doit être activée.

BS

Pourcentage écart quantité

BN doit être activée.

BT

Taux de rotation

Taux = Stock inventaire théorique à une date donnée - cumul des Sorties à une date donnée antérieure

La valeur provision = taux_rotation * prix unitaire moyen (pour dépréciation si taux de rotation positif sinon 0)

BU

Somme des quantités de sortie normale entre la date saisie et la date de valorisation

La colonne BT ou CU doit être activée.

BV

Valeur de la dépréciation

BT doit être activée.

BW

Nom abrégé du client

BX

Code statistique 1

BY

Libellé court du code statistique 1

BZ

Libellé long du code statistique 1

CA

Code statistique 2

CB

Libellé court du code statistique 2

CC

Libellé long du code statistique 2

CD

Code statistique 3

CE

Libellé court du code statistique 3

CF

Libellé long du code statistique 3

CG

Code statistique 4

CH

Libellé court du code statistique 4

CI

Libellé long du code statistique 4

CJ

Prix de vente dans l'unité du lot

CK

Libellé de l'unité de vente du lot

CL

Prix en unité d'utilisation avec 6 décimales (à la date de valorisation)

Remarque : Cette zone est issue du calcul de la valorisation de stock.

CM

Valeur du stock de mise à disposition à la date de valorisation

CN

Devis du lot

CO

Sous-devis du lot

CP

Solde de livraison

CQ

Solde de fabrication

CR

Validité article (mp_qualite)

CS

Libellé court de la validité article

CT

Solde de livraison de l'ensemble du lot

CU

Taux de rotation

Taux de rotation = Stock physique de l'article à la date de valorisation

X Nombre de jours de la période

/ Somme des consommations sur la période

Nombre de jours de la période = Nombre de jours entre la date de valorisation et la date pour taux de rotation

CV

Solde de fabrication de l'ensemble du lot

CW

Code ensemble associé au produit (s'il existe)

Si la table amal est présente, recherche du code composant dans l'amalgame

CX

Nombre de références associées à l'affiche

CY

Nombre de poses total de l'affiche

CZ

Référence de commande de liaison

DA

Code tolérance de livraison du lot

DB

Pourcentage de tolérance minimum du lot

DC

Pourcentage de tolérance maximum du lot

DD

Date client du lot

DE

Code adresse de livraison du lot

DF

Ville de livraison du lot

DG

Quantité commandée du lot

DH

Quantité fabriquée du lot

DI

Quantité livrée du lot

DJ

Quantité lancée du cadencement de fabrication

DK

Quantité fabriquée du cadencement de fabrication

DL

Quantité livrée du cadencement de fabrication

DM

Quantité commandée des PF de l'amalgame

DN

Quantité lancée des PF de l'amalgame

DO

Quantité fabriquée des PF de l'amalgame

DP

Quantité livrée des PF de l'amalgame

DQ

Grammage des bobines (mp_dt5)

DR

Code représentant de la fiche client

DS

Libellé coût du code représentant de la fiche client

DT

Libellé long du code représentant de la fiche client

DU

Affectation de la ligne de commande d'achat définie par le numéro de lot

Permet d'associer les matières à l'OF.

DV

Date de création de l'article

DW

Affichage de la colonne Quantité en stock dans une unité paramétrée

Voir la note UNITE_UTI_COLONNE_DW

DX

Affichage de la colonne Quantité en stock en unité 2 dans une unité paramétrée

Voir la note UNITE_ACH_COLONNE_DX

DY

Encours du lot (DH-DI)

DZ

Encours du cadencement de fabrication (DK-DL)

EA

Encours des PF de l'amalgame (DO-DP)

EB

Date de fabrication souhaitée du lot

EC

Désignation 2 du produit (mp_des2)

ED

date livraison souhaitée (cde2.lc_delcli)

EF

date réponse client (cde2.lc_delrep)

EG

date départ (cde2.lc_deldep)

EH

Code site rattaché au magasin

Voir l'option Ots.

Tableau de bord du multisite

Uc

Référence commande client (lc_p3). Si lc_p3 vide : ec_ref - idem colonne û

SA

Age du stock exprimé en jour (jour du traitement – date de la dernière sortie)

PR

Prix de revient unitaire (lc_prx_rev_uni)

TC

Libellé long de la catégorie du client

00

Stock âgé entre 0 et 3 mois

01

Stock âgé entre 0 et 4 mois

02

Stock âgé entre 4 et 6 mois

03

Stock âgé entre 3 et 6 mois

06

Stock âgé entre 6 et 9 mois

09

Stock âgé entre 9 et 10 mois

10

Stock âgé entre 10 et 11 mois

11

Stock âgé entre 11 et 12 mois

12

Stock âgé de 12 mois et plus


Saisie d'inventaire par bordereau

Si inventaire à la palette et écart positif, avant de générer le mouvement de régularisation d'entrée normale de l'unité de conditionnement, le programme vérifie si le lieu de rangement de l'unité de conditionnement de la table conteneur_info est différent de celui saisi dans le bordereau d'inventaire.

Si les lieux de rangement sont différents, un mouvement de régularisation de sortie normale de l'unité de conditionnement est généré.

Les lieux de rangement de niveau 1 et 2 sont issus de la table conteneur_info et le lieu de rangement de niveau 3, le numéro du lot et la quantité de la table conteneur_produit.

Ce mouvement permet de remettre le stock de l'unité de conditionnement à 0.

Avant de générer le mouvement, tous les enregistrements de l'unité de conditionnement du lieu de rangement de la table conteneur_info sont supprimés des tables stk_inv_0 et stk_inv_1.

Cette suppression est faite sans tenir compte de l'environnement.

Le programme génère ensuite le mouvement de régularisation d'entrée normale de l'unité de conditionnement.

Si les lieux de rangement sont identiques, le programme génère seulement le mouvement de régularisation d'entrée normale de l'unité de conditionnement

Saisie d'inventaire par bordereau inventaire

Fonctionnalités Options Valeurs numériques 1 et 2 Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes du paramètre de lancement

Intégration d'inventaire global

Fonctionnalités

Ce module permet de générer des mouvements de stock de régularisation d'après une saisie de l'inventaire par bordereau.

On pourra ensuite exécuter le module de création automatique d'inventaire (crinv.4ge)

Voir aide M:\Guides utilisateurs\Inventaires.doc

ATTENTION : Ce programme n'est pas utilisable pour la gestion des bobines.

#CF INV alpha1[1] indique si le mode de gestion des inventaires par environnement est activé (O/N).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

3,5 Code de l'environnement à prendre en compte

A utiliser avec l'option Osq (ne pose pas les questions de confirmation et la saisie du mot de passe)

Exemple :

Dans la visu des paramètres (v_par02), on paramètre les notes suivantes pour avoir la liste des environnements :

S and p2_type = 'EVI'

_CSEL

LCT_MULTI_TITRE_01 Inventaire théorique

LCT_MULTI_IMAGE_01

LCT_MULTI_PARAM_01 #SAXXX-N[p2_code]

Pour chaque ligne cochée, le programme va lancer le programme de génération de l’inventaire théorique paramétré dans le #SAXXX.

Valeurs numériques

1 | Pourcentage intervenant dans l'apparition d'un + ou d'un - dans le 3eme caractère du statut. Si la quantité inventoriée est supérieure de x % à la quantité théorique, un + apparaîtra. Si la quantité inventoriée est inférieure de x % à la quantité théorique, un apparaîtra.
2 | Ecart de quantité entre la quantité inventoriée et la quantité théorique. Utilisé uniquement pour la phase GBS-2

Options triées

O2b

Interdiction de saisir 2 bordereaux avec le même lieu mono - référence

Oas

Désactivation des contrôles interdisant la saisie de lots synchrones

Ocl

Affichage du code et nom du client du lot en saisie de bordereaux d'inventaire

Ocq

Le curseur est positionné sur la quantité

Utilisé uniquement pour la phase SAI

Oif

Intégration des fichiers d'inventaire global

Oil

Ne pas contrôler la validité des lieux de rangement 2 et 3

Oim

Mode imprimerie

Ola

Lors de la génération des mouvements de régularisation d'inventaire, le prix du mouvement de régularisation est égal au prix du lot c'est-à-dire au prix de la ligne de commande d'achat.

Cette option n'est valable qu'avec l'action REG.

Elle n'est actionnée que pour les environnements dont le type de commande est Fournisseur.

Ons

Aucun traitement des lignes non saisies :

Pour la génération automatique des régularisations de stock, le module inventaire génère des écarts entre le stock théorique (informatique) et le stock constaté.

Par défaut, si le stock constaté n'a pas été saisi, il est considéré égal à zéro et la régularisation d'inventaire ramène le stock à zéro.

Ce fonctionnement est correct en saisie d'inventaire de fin d'année par exemple (inventaire global).

Par contre, dans le cas par exemple d'un inventaire tournant, ce n'est pas satisfaisant.

L'option -Ons permet de ne pas prendre en compte les lignes pour lesquelles le stock constaté n'a pas été saisi.

Dans ce cas, aucune régularisation de stock n'est effectuée et le stock théorique n'évolue pas.

Op0

Valorisation au prix du dernier mouvement si prix du mouvement de régularisation à 0

Utilisée uniquement pour la phase REG

Opa

Gestion de stocks à la palette

Attention, EVI A1[6] est prioritaire sur ce paramètre.

Opp

Prix du mouvement pris sur la FBI

Ore

Prise en compte de la remise entête lors de la valorisation de l'écart de quantité au PV du lot.

Phase ED1, Modes LOT-LL1-LL3-LLC

Ori

Répéter toutes les informations sur chaque ligne

Orl

Prise en compte de la remise ligne lors de la valorisation de l'écart de quantité au PV du lot.

Phase ED1, Modes LOT-LL1-LL3-LLC

Osi

Simulation de l'intégration des fichiers d'inventaire global

Les mouvements de stock ne sont pas générés.

Osl

Aide à la saisie par lot (en présence de l'option Opa)

Option Osl seule : permet la saisie de l'inventaire sur des magasins gérés en vrac (pas de saisie de nombre de palettes, pas de saisie d'une quantité par palette, mais saisie d'une quantité totale).

Oso

Le curseur est placé sur le champ de saisie du numéro d'oF au lancement de l'aide à la saisie des bordereaux d'inventaire. Sinon, le curseur est placé sur le champ de saisie du numéro de lot.

Osp

Cette option a été ajoutée pour améliorer le temps de calcul du stock théorique

A utiliser avec précaution

Calcul du stock théorique par lieu et UC ou Lot/Lieu et UC.

Prise en compte de l'état du stock de la palette (champ cni_en_stock dans les tables conteneur_info et conteneur_poduit)

Si le calcul du stock théorique est demandé à une date antérieure aux derniers mouvements, ne pas positionner ce paramètre.

Exemple :

Derniers mouvements réels : 05/07/2003

Calcul du stock théorique au 30/06/2003

Osq

Ne pose pas les questions de confirmation et la saisie du mot de passe

Osr

Pas de mise à jour du stock résultant

Otc

Génération du Théorique à partir de la table de conteneurs

Il est possible de générer le théorique par conteneur en lisant les tables conteneur_info et conteneur_poduit si :

•cette option est activée.

• l'article est géré en stock par Lot/Lieu/Conditionnement

• la génération du théorique par environnement est activée (A2[1,3] = GTE)

Otl

Génération du théorique à partir de la table stk_lot_lieu pour les articles gérés en stock Lot/lieu (mp_param[17] = B) et uniquement en gestion par environnement (phase GTE)

Important : La mise à jour de la table stk_lot_lieu (programme maj_stk_lot_lieu) devra être lancée avant ce traitement.

Dans cette table ne sont présents que les mouvements de stock supérieurs au dernier inventaire.

Attention au complément de sélection L sur le type de paramètre EVI afin qu'il ne manque pas d'articles ou de lot ou d'emplacement.

Ovp

Proratisation au poids lors de la valorisation de l'écart de quantité au PV du lot.

Phase ED1, Modes LOT-LL1-LL3-LLC

Valeur alpha 2

Caractères 1 à 3

PHASE de traitement. Ce code détermine le traitement qui sera réalisé par le programme.

Voir le tableau ci-dessous.

Caractères 4 à 6

MODE de fonctionnement. Ce code relatif à la phase de traitement détermine un mode de fonctionnement particulier associé à la phase de traitement.

Voir le tableau ci-dessous.

Caractère 7

O Le lieu par défaut est celui de l'opérateur (voir paramètre OPR, valeur alpha 1)

Si le paramétrage est fait sur l'environnement (EVI), il sera prioritaire.

N Le lieu par défaut est celui de la fiche article. Valeur par défaut

Caractères 8 et 9

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

Caractères 10 à 17

Date du stock théorique.

Cette zone définit la date à laquelle le stock théorique déterminé par la Phase GTH ou GTG ou GTL doit être calculé.

Intérêt : Si l'inventaire a été réalisé le 31/12/95, la phase GTH/GTG/GTL peut très bien être lancée le 10/01/96, si la date du stock théorique est paramétrée au 31/12/95.

Si cette zone n'est pas remplie, le stock physique retenu est le stock physique du jour.

Caractères 18 à 20

Type de mouvement de stock de régularisation d'entrée.

Un mouvement de ce type est généré lors de la phase REG si, sur une ligne, l'écart constaté est positif.

Quantité Ecart = Quantité inventoriée - Quantité théorique > 0

Caractères 21 à 23

Type de mouvement de stock de régularisation de sortie.

Un mouvement de ce type est généré lors de la phase REG si, sur une ligne, l'écart constaté est négatif.

Quantité Ecart = Quantité inventoriée - Quantité théorique < 0

Caractère 24

Edition d'une ligne de tirets avant un changement d'article (pour la phase ED1)

Caractère 25

Edition d'une ligne de tirets avant un changement de lieu de niveau 1 (pour la phase ED1)

Caractère 26

Edition d'une ligne de tirets avant un changement de lieu de niveau 2 (pour la phase ED1)

Caractère 27

Edition d'une ligne de tirets avant un changement de lieu de niveau 3 (pour la phase ED1)

Caractère 28

Edition d'une ligne de tirets avant un changement de lot (pour la phase ED1)

Caractère 29

Edition d'une ligne de tirets avant changement d'identifiant conteneur (pour la phase ED1)

Caractères 30 à 37

Date de génération des mouvements de stock de régularisation.

Cette date est utilisée uniquement par la phase REG.

Si cette zone n'est pas remplie, la date retenue est la date du jour.

Caractères 38 à 40

Type de mouvement de stock de régularisation d'entrée normale de l'unité de conditionnement (Inventaire à la palette)

Un mouvement de ce type est généré lors de la phase REG si, sur une ligne, le stock théorique de l'unité de conditionnement est négatif.

Le mouvement généré est un mouvement d'entrée normale dont la quantité est égale à l'inverse du stock théorique de l'unité de conditionnement afin de remettre celui-ci à 0.

Quantité = - Quantité théorique

Caractères 41 à 43

Code opérateur. Obligatoire. Utilisé uniquement pour la phase GBS

Caractère 44

Type numéro bordereau. Obligatoire

1 Compteur sur 8

Car 1 à 8 : Folioteur sur 8

2 Compteur sur 7

Car 1 : Caractère 1 du lieu 1

Car 2 à 4 : Caractères 1 à 3 du lieu 2

Car 5 à 7 : Folioteur sur 3

Utilisé uniquement pour la phase GBS

Caractère 45

Saut de page avant chaque bordereau ( Pour la phase ED0)

L'édition doit être triée par bordereau.

Caractères 46 à 48

Delta à ajouter au numéro de bordereau pour la génération des bordereaux de saisie des articles en écart. Obligatoire

Utilisé uniquement pour la phase GBS-2

Caractère 49

Colonne Quantité à blanc si quantité à 0 (Pour la phase ED0)

Caractère 50

Foliotage des bordereaux de saisie d'inventaire (Page ### / ###) ( Pour la phase ED0)

Caractère 51

Re-génération du stock théorique (O/N). Uniquement pour la phase GSA

Caractères 52 à 54

Nombre maxi de lignes par bordereau

200 maximum et par défaut

Caractères 55 à 57

Type de mouvement de stock de régularisation de sortie normale de l'unité de conditionnement (Inventaire à la palette)

Un mouvement de ce type est généré lors de la phase REG si, sur une ligne, l'écart est positif et que le lieu de rangement de l'unité de conditionnement de la table conteneur_info est différent de celui saisi dans le bordereau d'inventaire.

Le mouvement généré est un mouvement de sortie normale dont les lieux de rangement de niveau 1 et 2 sont issus de la table conteneur_info et le lieu de rangement de niveau 3, le numéro du lot et la quantité de la table conteneur_produit.

Ce mouvement permet de remettre le stock de l'unité de conditionnement à 0.

Cliquez ici pour afficher / masquer des informations supplémentaires.

Caractère 58

Edition d'une ligne de totalisation après un changement d'article (Phase ED1)

Seules les colonnes F (Quantité théorique), G (Quantité saisie) et H (Ecart de quantité) sont totalisées.

Dans la colonne L (Désignation de l'article), le libellé Total article suivi du code article est édité.

Valeur alpha 3

Caractères 1 à 5 | Mot de passe permettant l'exécution des phases RAZ, GTH, GTG, GTL, REG. Le paramétrage de ce mot de passe est obligatoire et sans valeur par défaut.
Caractères 6 à 8 | Code langue nécessaire pour l'édition de la colonne des libellés étrangers (Phase ED1 - Voir colonne S)
Caractères 9 à 11 | Code pays nécessaire pour l'édition de la colonne des libellés étrangers (Phase ED1 - Voir colonne S)
Caractères 12 à 14 | Code environnement
Caractère 15 | Afficher le critère sélection sur la famille et sous-famille O Le critère de sélection est affiché N (ou vide) Le critère de sélection n'est pas affiché (par défaut)

Valeur alpha 4

Caractères 1 à 30

Définition des colonnes paramétrables des phases ED0 et ED1 :

Col

ED0

ED1

Définition

A

þ

þ

Code article

B

þ

þ

Lieu de rangement 1

C

þ

þ

Lieu de rangement 2

D

þ

þ

Lieu de rangement 3

E

þ

þ

Lot

F

þ

Quantité théorique.

Le nombre de décimales affichées sur l'état est paramétré sur l'unité de stockage saisie.

G

þ

þ

Quantité saisie.

Le nombre de décimales affichées sur l'état est paramétré sur l'unité de stockage saisie.

H

þ

Ecart de quantité.

Le nombre de décimales affichées sur l'état est paramétré sur l'unité de stockage saisie.

I

þ

Ligne issue de la génération du théorique ? (O/N)

J

þ

Ligne issue de la génération de la saisie ? (O/N)

K

þ

Code état.

Ce code est défini sur 3 caractères :

1 S quantité théorique non définie.

0 quantité théorique à 0.

V quantité théorique contient une valeur.

2 S quantité inventoriée non définie.

0 quantité inventoriée à 0.

V quantité inventoriée contient une valeur.

3 + quantité inventoriée supérieure à plus de x % de la quantité théorique.

voir valeur numérique 1

- quantité inventoriée inférieure à moins de x % de la quantité théorique.

voir valeur numérique 1

[blanc] Sinon

L

þ

þ

Désignation de l'article

M

þ

þ

Unité de stockage (d'utilisation).

N

þ

þ

Observation. Colonne vierge de 20 caractères.

O

þ

þ

Code famille.

P

þ

þ

Code sous-famille

Q

þ

þ

Type d'article (M, P, S, F, X, O, T, K)

R

þ

þ

Zone paramétrable du second écran de la fiche article (mp_libre)

S

þ

þ

Code article client (libellé étranger) pour les articles gérés par lot dont les numéros de lot sont générés dans les mouvements de stocks à partir des numéros de commande.

T

þ

Nombre de bobines (théorique)

U

þ

þ

Nombre de bobines (saisie)

V

þ

Nombre de bobines (écart)

W

þ

þ

Code environnement

X

þ

þ

Libellé long code environnement

Y

þ

þ

Libellé court code environnement

Z

þ

Unité de conditionnement (UC)

a

þ

þ

ED0 : Numéro de bordereau

ED1 : Ecart de quantité valorisé au prix de vente du lot ou de l'article

b

þ

þ

ED0 : Ligne du bordereau

ED1 : Valorisation de la quantité réelle

c

þ

þ

ED0 : Code opérateur

ED1 : Valorisation de la quantité théorique

d

þ

þ

ED0 : Type d'article saisi

ED1 : Ecart entre le nombre réel et le nombre théorique de palettes

e

þ

Unité de stockage saisie

f

þ

Emplacement

g

þ

Commentaire

h

þ

Unité de conditionnement (UC)

i

þ

þ

Code qualité de la matière

j

þ

þ

Désignation de la qualité de la matière

k

þ

þ

Longueur

l

þ

þ

Largeur

m

þ

þ

Hauteur

n

þ

þ

Grammage

o

Libellé étranger du produit avec le client v0_cli ou v1_cli (si on est sur la ligne ou non)

p

Poids de la ligne d'inventaire

q

PAMP de la ligne d'inventaire

On lit la zone mp_pamp de la fiche article puis on proratise en fonction de la quantité de la ligne d'inventaire par rapport à la quantité physique.

Si la zone mp_pamp est égale à zéro, on va lire le prix de l'article sur le dernier mouvement de sortie normale de celui-ci.

Un complément de requête sur la table stk0 est donc paramétrable pour rechercher cette information.

,

þ

Nom du client

@

þ

þ

Nombre théorique de palettes

-

þ

þ

Nombre réel de palettes

:

þ

Numéro de bordereau

!

þ

Ligne du bordereau

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes du paramètre EVI sont prioritaires sur celles-ci.

Autres notes du paramètre de lancement

S | Complément de select sur les tables stk_inv_1 ou mat pour la phase ED1 Exemple S and mp_mp = P Complément de select sur la table stk_inv_1 pour la phase GBS Exemple S and v1_rgt1 = "USI"
O (lettre O majuscule) | Définition du tri pour la phase ED1 Exemple O order by v1_rgt1, v1_article Définition de du tri pour la phase GBS Exemple O order by v1_rgt1, v1_article
T | Définit le titre sur l'édition pour la phase ED1
0 (chiffre 0) | Complément de select sur la table stk0 utilisé que pour les phases GTG, GTL et RTG Exemple 0 and s0_es = V
BORNES_DONNEE_TEC_ | Contrôles des valeurs saisies par rapport à des bornes minimum/maximum 19 Numéro de donnée technique (1 à 4) 21,30 Valeur minimum (999999.999) 32,41 Valeur maximum (999999.999) Ce fonctionnement est valable pour les programmes suivants Saisie des commandes d'achat (cdef) Saisie des inventaires (ici) Saisie des devis multi-métiers (devis_standard) Saisie des matières (mat) Visualisation des besoins matières (v_cde_5) Le paramétrage de contrôle sera recherché dans l'ordre suivant 1. Famille de la qualité matière 2. Type de commande d'achat (saisie des commandes d'achat uniquement) 3. Paramètre de lancement du programme (ici)
_CODE_EVI_AUTORISE | 21 à 23 Code d'environnement autorisé. Exemple : 001
CHAMP_FICHIER CTRL_CHAFIC_UNICITE | Paramétrage des champs du fichier à intégrer. Obligatoire si option Oif 21,38 Nom du champ Tous les champs de la table stk_inv_0 et le champ nombre_palettes 41,43 Position de début du champ 45,47 Longueur du champ Si le champ v0_prix est paramétré, il doit être exprimé en centimes d'euros. Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique. Fonctionne avec la note CHAMP_FICHIER) O chaque nom de champ doit être unique (par défaut) N pas de contrôle
CONSTANTE_FICHIER | Paramétrage des constantes des champs du fichier à intégrer. Obligatoire si option Oif 21,38 Nom du champ Tous les champs de la table stk_inv_0 et le champ nombre_palettes 41,60 Constante du champ Si le champ v0_prix est paramétré, il doit être exprimé en centimes d'euros.
FIC_INTEGRER | 21,60 Nom du fichier à intégrer - Obligatoire si option Oif Intégration d'inventaire global
FIC_INTEGRER_REP | 21,60 Répertoire du fichier à intégrer - Facultatif Intégration d'inventaire global
FIC_INTEGRER_REP_HIS | 21,60 Répertoire historique du fichier à intégrer - Facultatif Intégration d'inventaire global
FIC_LOCK | 21,60 Nom du fichier du lock général posé par le programme - Obligatoire si option Oif Intégration d'inventaire global
FIC_LOCK_EXT | 21,60 Nom du fichier du lock posé par un programme externe - Obligatoire si option Oif Intégration d'inventaire global
FIC_LOCK_VS | 21,60 Nom du fichier du lock posé par le programme qui peut être utilisé par un programme externe - Obligatoire si option Oif Intégration d'inventaire global
FIC_ANOMALIE | 21,60 Nom du fichier des anomalies - Obligatoire si option Oif Intégration d'inventaire global
FIC_TRACE | 21,60 Nom du fichier de trace - Obligatoire si option Oif Intégration d'inventaire global
_SUP_REQ_STK0 | 21,60 Complément de requête sur la table stk0
VALEUR_USING_ | Valeur du using 14, 16 Code édition ED0 Edition paramétrable des saisies d'inventaire par bordereau ED1 Edition paramétrable de la table de préparation des inventaires 18 Code colonne permettant l'utilisation d'un using paramétrable k Longueur l Largeur m Hauteur n Grammage 21, 60 Using paramétrable pour l'édition de la colonne Les colonnes d'édition étant de taille fixe, le code de mise en forme < (calage à gauche) ne peut pas être utilisé. Si le using paramétré est plus grand que la largeur de la colonne,il sera tronqué. S'il est plus court, il sera complété avec des blancs à gauche (calage à droite). Using par défaut : k Longueur ######&.&&& l Largeur ######&.&&& m Hauteur ######&.&&& n Grammage ####&.&&&

Phases et modes de traitement

La phase est paramétrée en alpha2[1,3] et le mode est paramétré en alpha2[4,6].

Phase

Mode

Descriptif

RAZ

BRD

Remise à zéro de la table de saisie des bordereaux. (Table stk_inv_0)

Ce module doit être exécuté avant le début de toute nouvelle période d'inventaire

INV

Remise à zéro de la table de préparation de l'inventaire. (Table stk_inv_1)

Ce module peut être exécuté après l'exécution de la phase REG afin de récupérer de la place disque.

Ce module est exécuté automatiquement au début des phases GTH, GTG ou GTL

SAI

GLO

Saisie des bordereaux d'inventaire pour les articles gérés en global

LI1

Saisie des bordereaux d'inventaire pour les articles gérés par lieu (mono niveau)

LI3

Saisie des bordereaux d'inventaire pour les articles gérés par lieu (multi niveaux)

LOT

Saisie des bordereaux d'inventaire pour les articles gérés par lot

LL1

Saisie des bordereaux d'inventaire pour les articles gérés par lot lieu (mono niveau)

LL3

Saisie des bordereaux d'inventaire pour les articles gérés par lot lieu (multi niveaux)

L3C

Saisie par Lieu 3 niveaux - Conditionnement

On ne s'occupe plus de l'ancienne gestion à la palette,

on désactive les options d'aide à la saisie,

et on impose la gestion des environnements.

LLC

Saisie par lot - Lieu - Conditionnement

GTH

(rien)

Génération du stock théorique (le stock physique informatique) dans la table de préparation de l'inventaire, uniquement pour les articles recensés par la saisie de l'inventaire par bordereaux.

Cette génération permet de réaliser des inventaires partiels (tournants), mais elle ne permet pas de détecter les articles non inventoriés.

Ce module doit être exécuté après la phase SAI.

Uniquement en mode SANS environnement.

GTE

(rien)

Génération du stock théorique (Stock physique informatique) dans la table de préparation de l'inventaire, uniquement pour les articles d'un environnement donné.

Cette génération permet de réaliser des inventaires partiels (tournants), mais elle ne permet pas de détecter les articles non inventoriés.

Cette phase peut être exécutée indifféremment avant ou après la phase SAI.

Uniquement en mode AVEC environnement.

GTG

(rien)

Génération du stock théorique (le stock physique informatique) dans la table de préparation de l'inventaire, pour tous les articles tenus en stock (Filtre possible par une sélection multicritère).

Cette méthode appliquée à tous les articles tenus en stock permet une détection efficace des articles non inventoriés dans la saisie par bordereaux.

Ce module peut être exécuté indifféremment avant ou après la phase SAI.

Note commençant par 0 (zéro) obligatoire.

Uniquement en mode SANS environnement.

GTL

(rien)

Génération du stock théorique (le stock physique informatique) dans la table de préparation de l'inventaire, uniquement pour les articles mouvementés d'un lieu de rangement donné.

Cette génération permet de réaliser des inventaires partiels (tournants), mais elle ne permet pas de détecter les articles non inventoriés.

Ce module peut être exécuté indifféremment avant ou après la phase SAI

Note commençant par 0 (zéro) obligatoire.

Uniquement en mode SANS environnement.

GBS

1

Génération des bordereaux de saisie à partir du stock théorique de tous les articles.

Cette phase doit être exécutée après la phase GTH ou GTE ou GTG ou GTL.

2

Génération des bordereaux de saisie à partir du stock théorique des articles en écart.

Cette phase doit être exécutée après la phase GTH ou GTE ou GTG ou GTL.

RTG

(rien)

Régénération du stock théorique. Elle permet de compléter la génération du stock théorique GTH ou GTG ou GTL pour une sélection d'articles donnée.

Elle permet également de remettre a jour le stock théorique pour une ensemble d'article donné.

Ce module optionnel doit être exécuté après la phase GTG ou GTH ou GTL

Note commençant par 0 (zéro) obligatoire.

GSA

(rien)

Génération des saisies. Ce module réalise la sommation des saisies réalisées sur les bordereaux d'inventaire. Le fruit de ces sommations permet de positionner l'inventorié par article (lieu ou lot ou lot lieu) dans la table de préparation de l'inventaire. On détermine également l'écart par rapport au théorique.

Ce module doit être exécuté après la phase GTH ou GTG ou GTL

REG

(rien)

Génération des mouvements de régularisation de stock. En fonction des écarts par rapport au stock théorique déterminés dans la phase GSA, ce module va créer les mouvements de stock de régularisation équivalents.

Ce module doit être exécuté après la phase GSA

Les TMV de régularisation doivent être correctement renseignés (alpha2[18,23]).

En outre, si so_options[40] = O, le TMV de régularisation de l'UC doit être correctement renseigné (alpha2[38,40]).

ED0

et

ED1

(rien)

ED0 Edition paramétrable des saisies d'inventaire par bordereau - stk_inv_0

ED1 Edition paramétrable de la table de préparation d'inventaire - stk_inv_1

Le mode de fonctionnement est inutile si l'utilisateur paramètre les colonnes en alpha 4.

Sinon, le choix d'un des modes ci-dessous conditionne les valeurs par défaut :

GLO

Edition en global

LI1

Edition par lieu de rangement de niveau 1

LI3

Edition par lieu de rangement sur 3 niveaux

LOT

Edition par lot

LL1

Edition par lot - Lieu niveau 1

LL3

Edition par lot - Lieu 3 niveaux

L3C

Edition par Lieu niveau 3 - Conditionnement

LLC

Edition par lot - Lieu 3 niveaux - Conditionnement

Intégration d'inventaire global

Elle se découpe en plusieurs phases :

1 - Epuration des bordereaux d'inventaire

2 - Epuration de l'état préparatoire d'inventaire

3 - Intégration des fichiers dans la table des bordereaux

4 - Génération de l'inventaire théorique des articles intégrés

5 - Génération de l'inventorié

6 - Génération des mouvements de stock de régularisation

La gestion des environnements doit être activée (#CF INV A1[1] = O).

A3[12,14] indique l'environnement d'inventaire, où la note commençant par 0 (zéro) permet un complément de sélection sur stk0.

L'option Oif déclenche l'intégration. L'option Osi permet une simulation sans mise à jour.

Les notes commençant par FIC_ permettent d'indiquer le fichier à intégrer ainsi que les verrous, traces et anomalies.

La note CHAMP_FICHIER permet d'indiquer les équivalences entre le fichier à intégrer et les champs de la table stk_inv_0.

La note CONSTANTE_FICHIER permet d'indiquer les constantes à intégrer dans la table stk_inv_0.


Saisie des inventaires par codes à barres

Saisie des inventaires par codes à barres saisie_inventaire_cab

Options

O22

CAB transformateur sur 22 caractères

Oai

Aide à l'inventaire - Utilisée avec l'option -Os2 (Scénario 2)

Si cette option est activée, on vérifie si l'emplacement de l'article (Couple lieu/article) de la palette inventoriée a plusieurs lots.

Si un seul lot dans l'emplacement, l'utilisateur doit scanner toutes les palettes.

Si plusieurs lots dans l'emplacement, on l'avertit qu'il y a plusieurs lots et on lui demande de resaisir le nombre de palettes.

Si le nombre de palettes ne correspond toujours pas au nombre de palettes en stock du triplet lot/lieu/article, on lui demande de scanner toutes les palettes.

Ola

Recherche automatique du lot

On3

Quantité de la palette mise dans le lieu de rangement de niveau 3

Os2

Inventaire en nombre de palettes au lieu de palette par palette

L'option Ola est obligatoire.

L'option Osm est interdite.

Le mode de fonctionnement (A2[1,3]) est obligatoirement LLC.

- L'utilisateur scanne la première palette.

- Il saisit le nombre de palettes. Si le nombre saisi ne correspond pas au nombre de palettes en stock du triplet lot/lieu/article, alors il doit scanner toutes les palettes.

Osm

Permet de saisir en masse des étiquettes Cab de palettes d'achats

Ote

Paramètres communs pour la gestion par codes à barres

Valeur alpha 2

Caractères 1 à 3 | Mode de fonctionnement de la phase : obligatoirement L3C ou LLC
Caractères 4 à 6 | Code environnement

Valeur alpha 3

Caractère 1 | Branchement souhaité après la saisie de la quantité 1 On re-saisit à partir du lieu 2 On repasse directement à la saisie du conditionnement si le lieu est le même
Caractère 2 | Saisie en aveugle (O/N, N par défaut)
Caractère 3 | Confirmation de la quantité (O/N, N par défaut)
Caractère 4 | Message d'avertissement de palette inconnue ou sans stock Obligatoire si option Os2
Caractère 5 | Code état des nouvelles palettes. Facultatif Les codes états sont paramétrés sur le paramètre #CF ATL

Notes

_STYLE_CAB

Paramètres communs pour la gestion par codes à barres


Création automatique de mouvement d'inventaire

Création automatique de mouvement d'inventaire crinv

Création automatique d'inventaire de stock des matières / produits sélectionnés en global, par lieu ou lot à une date saisie.

On ne peut sélectionner que les matières / produits suivis en stock et non annules logiquement.

L'inventaire de stock sera systématiquement créé.

Il n'y a pas de test s'il existe ou pas des mouvements après la date saisie de création d'inventaire.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Action : régularisation sans création d'inventaire

Caractères 3 et suivants : Code article

Exemple : -N[lc_prod]

Options triées

Ocu

Pour les articles dont le type de valorisation est P, l'inventaire est créé au CUMP

Si l'article est géré par lieu, par lot ou par lot – lieu, l'inventaire quantitatif est réalisé par lieu, par lot ou par lot - lieu, mais la valorisation (détermination du prix unitaire des inventaires) est calculée en global.

Oim

Imprimerie

Omr

Mise à jour du prix des entrées normales de régularisation pour les articles valorisés au CUMP (Avec option -Ocu uniquement)
On définit un mouvement de régularisation via le type de mouvement de stock

Type de paramètre TMV - alpha2[18] = O

Oms

Mise à jour du prix des sorties normales, uniquement pour les articles valorisés au PAMP

Ops

On tient compte du prix des mouvements de sortie pour valoriser l'inventaire

Fonctionne avec le paramètre -Ocu

Oq0

Pas de ligne de détail d'inventaire si la quantité est à 0.

Cette option n'est valide que dans les cas de création d'inventaires par lot, par lieu ou par lot - lieu.

Osa

La sélection multicritère sur la fiche article est réalisée via la grille de sélection article complète.

Sans cette option la sélection s'effectue simplement sur quelques zones

Osi

Sans création d'inventaire

Permet d'utiliser les options -Omr et -Oms pour réaliser des régularisations, mais sans création d'inventaire en final

Cette régularisation s'effectue de la date du dernier inventaire jusqu' au 31/12/2099 (autrement dit, traite tous les mouvements après le dernier inventaire ).

Cette option met également à jour la fiche article pour les zones

Valeur en stock (mp_pamp)

Stock physique (mp_sphy)

Cette option active en automatique l'option -Ocu et désactive l'option -Ops

Valeur alpha 2

Caractères 1 à 5 | Mot de passe
Caractère 6 | Permet de mettre à jour le prix du mouvement de régul (TMV A2[18]) (O/N, O par défaut) Lié à l'option –Omr
Caractère 7 | Fenêtre Type d'inventaire [blanc] Ouverture fenêtre Type d'inventaire 0 Inventaire selon le mp_param[17] de l'article 1 Inventaire en Global 2 Inventaire par Lieux 3 Inventaire par Lots 4 Inventaire par Lots-Lieux

Notes

_SUP_REQ_MAT

21,60 Complément de sélection sur table mat commençant par and.


Edition de suivi des stocks par lot/lieu

Edition de suivi des stocks par lot/lieu estk_s

Options triées

Oc3 | Edition du lieu 3 en dessous du code produit
Od3 | Edition d'un détail par lieu 3
Odi | Prise en compte des dimensions du lot dans la valorisation au prix de revient prévisionnel de la dernière FBI Utilisée si valorisation au prix de revient prévisionnel de la dernière FBI (A4[3,4] = RF)
Oee | Pas de déduction de l'escompte de l'entête de commande (lot) Utilisée si valorisation au prix d'achat de la dernière facture - A4[3,4] = AF au prix de vente du lot - A4[3,4] = VL
Oet | Environnement TVA de la FBI pris en compte Utilisée si valorisation au prix de revient prévisionnel de la dernière FBI
Ofo | Edition du format du produit
Oft | Edition d'un fichier trace de l'exécution
Oi0 | Edition des lignes sans valeur initiale
Ol0 | Edition des lignes à 0
Ole | Edition du libellé étranger
Om0 | Edition des lignes sans mouvement
Opa | Le prix de vente pour le calcul de la colonne Valeur est celui de la fiche article.
Opd | Prix unitaire par défaut si le prix unitaire calculé est à 0 Utilisée en cas de valorisation au prix d'achat du lot - A4[3,4] = AL au prix de revient du lot - A4[3,4] = RL au prix de vente du lot - A4[3,4] = VL
Ope | Prix de vente ou de revient par élément Utilisée en cas de valorisation au prix de revient du lot - A4[3,4] = RL au prix de vente du lot - A4[3,4] = VL
Opp | Valorisation des éléments appairés au prorata de leur poids sur le poids de l'ensemble Utilisée en cas de valorisation au prix de revient du lot - A4[3,4] = RL au prix de vente du lot - A4[3,4] = VL
Ops | Valorisation des éléments appairés au prorata de leur surface sur la surface de l'ensemble Utilisée en cas de valorisation au prix de revient du lot - A4[3,4] = RL au prix de vente du lot - A4[3,4] = VL
Ore | Pas de déduction de la remise de l'entête de commande (lot) Utilisée en cas de valorisation au prix d'achat du lot - A4[3,4] = AL au prix d'achat de la dernière facture - A4[3,4] = AF au prix de vente du lot - A4[3,4] = VL
Orl | Pas de déduction de la remise de la ligne de commande (lot) Utilisée en cas de valorisation au prix d'achat du lot - A4[3,4] = AL au prix d'achat de la dernière facture - A4[3,4] = AF au prix de vente du lot - A4[3,4] = VL
Os0 | Edition des lignes sans valeur finale
Otx | Edition du texte de l'entête de commande
Ova | La colonne valeur est à imprimer.
Ovi | Mode visu ATTENTION : quand cette options est activée, les paramètres de #VI deviennent prioritaires lorsqu'ils entrent en conflit avec les paramètres de ce programme. Par conséquent, vérifiez le paramétrage des valeurs alpha 3 et 4.
Oxd | Cacher le cadre détail des visualisations Plus d'info dans l'aide du #VI
Oxs | Ne pas passer par l'écran de sélection Plus d'info dans l'aide du #VI

Valeurs numériques

1 | Nombre de jours de décalage pour la date de début (mode batch)
2 | Nombre de jours de décalage pour la date de fin (mode batch)

Valeur alpha 2 - Paramétrage de l'édition des colonnes

A2[1] | Avec nom (O/N, O par défaut)
A2[2] | Avec code (O/N, O par défaut)
A2[3] | Avec lot (O/N, O par défaut)
A2[4] | Avec produit (O/N, O par défaut)
A2[5] | Avec stock début (O/N, O par défaut)
A2[6] | Avec stock entrée (O/N, O par défaut)
A2[7] | Avec stock sortie (O/N, O par défaut)
A2[8] | Avec stock fin (O/N, O par défaut)

Valeur alpha 3

A3[1,30]

Nom du fichier trace

Valeur alpha 4

A4[1]

Mode de recherche lots/lieux

G Recherche globale (produits)

0 Recherche des lots

1 Recherche des lieux

2 Recherche des lots/lieux (par défaut)

3 Recherche des lieux/lots

Remarque : Ce paramétrage est incompatible avec les options de gestion du lieu 3 (Oc3 et Od3)

A4[2]

Niveau de prise en compte des lieux de rangement2

1 Le lieu 1 est seul significatif

2 Le couple lieu 1/lieu 2 est significatif

3 Le triplet lieu 1/lieu 2/lieu 3 est significatif (par défaut)

Remarque : Ce paramétrage est incompatible avec les options de gestion du lieu 3 (Oc3 et Od3)

A4[3,4]

Mode de valorisation

AA Valorisation au prix d'achat de l'article

AF Valorisation au prix d'achat de la dernière facture

AL Valorisation au prix d'achat du lot

RA Valorisation au prix de revient de l'article

RF Valorisation au prix de revient prévisionnel de la dernière FBI

L'option Odi permet de prendre en compte les dimensions du lot lors du calcul du prix de revient prévisionnel

RL Valorisation au prix de revient du lot

VA Valorisation au prix de vente de l'article

VL Valorisation au prix de vente du lot (par défaut)

S1 Valorisation au prix d'achat de la dernière facture pour les entrées et au prix unitaire moyen pondéré pour les sorties

Notes

S_STK | 6,60 Complément de requête sur la table stk0
S | 2,60 Complément de requête sur la table mat Si le complément de requête contient une des zones de la table temporaire de la visu, alors il porte sur la table temporaire et non pas sur mat.
_SUP_REQ_RECH_FBI | 21,60 Complément de sélection pour la recherche de la dernière FBI Utilisé si valorisation au prix de revient prévisionnel de la dernière FBI Exemples and f0_cp > 0 and f0_qtel > 0
_SUP_REQ_RECH_LL | 21,60 Complément de sélection à appliquer à la recherche des lots/lieux Ce complément de requête peut être complété par les 4 compléments ci-dessous.
_SUP_REQ_RECH_LL_DEB | 21,60 Complément de requête à appliquer sur les données de stock initiales
_SUP_REQ_RECH_LL_ENT | 21,60 Complément de requête à appliquer sur les données d'entrée de stock
_SUP_REQ_RECH_LL_SOR | 21,60 Complément de requête à appliquer sur les données de sortie de stock
_SUP_REQ_RECH_LL_FIN | 21,60 Complément de requête à appliquer sur les données de stock finales

Liste des tris possibles

01 | Code Lieu 1
02 | Code Lieu 2
03 | Code Produit
04 | Numéro de Lot
05 | Quantité par palette
06 | Code client

Liste des noms de zones autorisés

Toutes les zones du package Tiers

Liste des noms de zones autorisés (table temporaire)

tps_lot | Lot
tps_lieu1 | Lieu de rangement 1
tps_lieu2 | Lieu de rangement 2
tps_lieu3 | Lieu de rangement 3
tps_produit | Produit
tps_client | Client

Liste des noms de zones autorisés (table temporaire) - Suite - Les zones suivantes sont cumulables et utilisables dans des calculs.

 | Valeur initiale | Valeur entrée | Valeur sortie | Valeur finale
Quantité du stock dans l'unité d'utilisation | tps_qte_deb | tps_qte_ent | tps_qte_sor | tps_qte_fin
Quantité du stock dans l'unité d'achat | tps_qte_ua_1_deb | tps_qte_ua_1_ent | tps_qte_ua_1_sor | tps_qte_ua_1_fin
Quantité du stock dans l'unité paramétrée dans la 3ème formule de conversion | tps_qte_ua_3_deb | tps_qte_ua_3_ent | tps_qte_ua_3_sor | tps_qte_ua_3_fin
Palette | tps_plt_deb | tps_plt_ent | tps_plt_sor | tps_plt_fin
Poids | tps_pds_deb | tps_pds_ent | tps_pds_sor | tps_pds_fin
Surface | tps_srf_deb | tps_srf_ent | tps_srf_sor | tps_srf_fin
Valeur | tps_val_deb | tps_val_ent | tps_val_sor | tps_valeur

ref_produit, reffou_produit | Référence produit pour le client du lot (ou du produit si recherche par lieux), pour le fournisseur chez le client du produit
lib_le_libelle, libfou_le_libelle | Libellé 1 pour le client du lot (ou du produit si recherche par lieux), pour le fournisseur chez le client du produit
lib_le_libelle2, libfou_le_libelle2 | Libellé 2 pour le client du lot (ou du produit si recherche par lieux), pour le fournisseur chez le client du produit


v_stk_lot_lieu Visualisation des stocks lots - lieux

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[mp_code]

Options

-N

Permet d'indiquer le code article sur 15 caractères

Oal

Visualisation par article/lieux 1 et 2

Permet de grouper les lignes de visualisation des stocks lots/lieux par code article et lieux de rangements 1 et 2 (le lieu de rangement 2 pouvant être la laize dans le cas des codes papiers).

Si option est activée :

• L'ordre de tri par défaut est figé à : code article, lieu 1, lieu 2 (il peut être modifié).

• Seules 4zones numériques sont accessibles via ce fonctionnement

sl_qte_phys (stock physique)

sl_qte_disp (stock disponible)

sl_qte_sor_res (quantité des sorties réserves)

sl_qte_enr_prev (quantité des entrées prévisionnelles).

• Seules ces 4 zones sont accessibles dans les formules de calcul de la visualisation.

• ATTENTION : les autres zones affichées sont celles correspondantes à la première ligne de stock trouvée pour l'article/lieux (seul le premier lot est affiché, les données relatives à la commande seront donc les premières trouvées)

Ore

Prise en compte de la remise entête lors de la valorisation de la quantité physique au PV du lot

Orl

Prise en compte de la remise ligne lors de la valorisation de la quantité physique au PV du lot

Orf

Rafraîchissement automatique de la visualisation

Ots

Mettre un trait entre chaque ligne en édition

Orv

Répéter l'affichage des valeurs en rupture en édition

Ovp

Proratisation au poids lors de la valorisation de la quantité physique au PV du lot

Ovs

Option mise en place pour utiliser cette visualisation à la place du CONTROL-B.

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)Par défaut N
Caractère 2 | Choix de l'ordre du tri (O/N, N par défaut)
Caractère 3 | Pas d'édition des lignes détail (O/N, N par défaut)
Caractère 10 | Mode de visualisation E Edition (lancement du programme en batch) F Fichier (lancement du programme en batch) V Mode écran (est disponible ici) X Mode Excel (est disponible ici)
Caractères 11 à 13 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Permet d'éditer une même ligne sur plusieurs lignes. Par défaut 1000
Caractère 14 | Type de recherche code article par F7 1 Recherche normale (Désignation, famille, etc ...) (par défaut) 2 Recherche sur les données techniques 3 Recherche spécifique papier Q Recherche sur la qualité carton T Recherche spécifique transformateur

Valeur alpha 3

Caractères 1 à 60

Titre de la visualisation

LISTE DES STOCKS LOTS LIEUX

Valeur alpha 4

Caractère 8 | Touche F8 (O/N) Affichage du détail de la ligne
Caractère 11 | Accès à la visualisation des commandes clients pour un produit (O/N, N par défaut) Voir la note RUN_VISU_CDC_ART
Caractère 12 | Accès à la visualisation des commandes fournisseurs pour un produit (O/N, N par défaut) Voir la note RUN_VISU_CDF_ART
Caractère 13 | Accès à la visualisation des commandes fournisseurs pour un produit et une laize (O/N, N par défaut) Voir la note RUN_VISU_CDF_ART_LAI
Caractère 19 | Touche F19 (O/N) Consultation du détail de l'article
Caractère 37 | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]
Caractère 38 | Touche CONTROL-C (O/N) Calculatrice
Caractère 48 | Touche CONTROL-P (O/N) Accès aux mouvements de stock
Caractère 51 | Touche CONTROL-T (O/N) Visualisation des touches
Caractère 56 | Touche CONTROL-Z (O/N) Lancement de programmes
Caractère 57 | Touche F37 (O/N) Visualisation simplifiée des stocks

Notes

CRIT_REGROUP

Regroupement de certaines données de la visualisation

Par exemple : le cas d'un article qui est dans un même magasin mais dans plusieurs emplacements différents.

Sans le regroupement, la visualisation affichera autant de lignes qu'il y a d'emplacements et de magasin différents.

Avec le regroupement par article et magasin (par exemple), la visualisation affichera autant de lignes qu'il y a de magasins différents.

21,60 Liste des zones à regrouper séparées par une virgule (note cumulative)

nom zone, nom zone, nom, zone, etc.

Exemple

CRIT_REGROUP article, rgt1

Regroupement par article et magasin

Liste des zones disponibles

article Code produit (sl_article)

lot Code lot (sl_lot)

rgt1 Lieu de rangement 1 (sl_rgt1)

rgt2 Lieu de rangement 2 (sl_rgt2)

rgt3 Lieu de rangement 3 (sl_rgt3)

cli Code client de la commande (ec_cli)

repr Code représentant de la fiche client (cl_repr)

fam Code famille (mp_fam)

sfm Code sous-famille (mp_sfm)

date1 Date 1 (sl_date1)

date2 Date 2 (sl_date2)

date3 Date 3 (sl_date3)

date4 Date 4 (sl_date4)

suiv Code suivi d'affaire (cl_suiv)

art_lot Code produit de la ligne de commande (lc_prod)

LIBELLE_DATE_n

21,40 Libellé de la date n. Facultatif. Date n par défaut

4 notes peuvent être définies :

LIBELLE_DATE_1

LIBELLE_DATE_2

LIBELLE_DATE_3

LIBELLE_DATE_4

MAJ_STK_DEPUIS_VS

21,26 Type et code du paramètre de lancement de la correction des stocks.

Si cette note n'est pas trouvée ici, elle sera recherchée dans le #CF STK.

MODE_DATE_CONSIGNE

21 Mode de valorisation

[blanc] Ouverture fenêtre date de valorisation

J Valorisation des mouvements limités à la date du jour

S Valorisation de tous les mouvements

D Valorisation des mouvements limités à la date paramétrée en [22,29]

22,29 Date de valorisation (prise en compte si caractère 21 = D) sous forme JJMMAAAA

RUN_VISU_CDC_ART

21,26 Type et code du paramètre de lancement de la visualisation des commandes clients pour un produit

Action Visu cdes clients - Art ou Touche F11

Voir l'option -N_ART dans v_cdem

RUN_VISU_CDF_ART

21,26 Type et code du paramètre de lancement de la visualisation des commandes fournisseurs pour un produit

Action Visu cdes four - Art ou Touche F12

Voir l'option -N_ART dans v_cdef

RUN_VISU_CDF_ART_LAI

21,26 Type et code du paramètre de lancement de la visualisation des commandes fournisseurs pour un produit et une laize

Action Visu cdes four - Art et laize ou Touche F13

Voir l'option -N_LAI dans v_cdef

_SUP_REQ_STK0_DERMVT

Complément de sélection sur la table stk0 utilisé pour récupérer la date de dernier mouvement

_TAR_XX_CONFIG

_TAR_XX_CODE_TAR

_TAR_XX_TIERS

_TAR_XX_DATE

_TAR_XX_QTE

_TAR_XX_COMP_SEL

_TAR_XX_SITE

_TAR_XX_DEFAUT

Afficher sur chaque ligne de visualisation divers tarifs que l'on peut paramétrer librement.

Voir la page dédiée à ces notes.

VISU_STK_DEPUIS_VS

21,26 Type et code du paramètre de lancement de la visualisation des stocks

Si cette note n'est pas trouvée ici, elle sera recherchée dans le #CF STK.

Ordres de tri

01 | art_sll article
02 | lot_sll numéro de lot
03 | rg1_sll lieu de rangement 1
04 | rg2_sll lieu de rangement 2
05 | rg3_sll lieu de rangement 3
06 | cli_sll sur client du lot
07 | rep_sll représentant
08 | fam_sll famille de l'article
09 | sfm_sll sous-famille de l'article
10 | dt1_sll Tri sur date 1
11 | dt2_sll Tri sur date 2
12 | sui_sll
13 | alt_sll (article du lot)
14 | dt3_sll Tri sur date 3
15 | dt4_sll Tri sur date 4

Critères de sélection possibles

Tous les champs des tables stk_lot_lieu, mat, cde1 et cde2

Liste des noms de zones autorisées (triés à l'intérieur de chaque table)

Les noms de zones autorisées dans les formules de calcul paramétrables sont indiqués en gras.

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Package Entête de commande fournisseur (cdf1)

Package Lignes de commande fournisseur (cdf2)

STOCK LOTS - LIEUX (TABLE STK_LOT_LIEU)

FICHE TIERS (TABLE CLI)

ENTETE COMMANDE (TABLE CDE1)

LIGNE DE COMMANDE (TABLE CDE2)

LIGNE DE NOMENCLATURE (TABLE CDE4)

Libellés étrangers et spécifiques

AUTRES ZONES

STOCK LOTS - LIEUX (TABLE STK_LOT_LIEU)

sl_article des_sl_article | Code article Désignation article (Fiche article)
sl_date1 | Date 1
sl_date2 | Date 2
sl_date3 | Date 3
sl_date4 | Date 4
sl_date_actualis | Date d'actualisation
sl_heure_actualis | Heure d'actualisation
sl_lot | Numéro lot
sl_mode_de_suivi | Mode de suivi
sl_nb_pal_phys | Nombre de palettes physiques
sl_qte_disp | Quantité disponible
sl_qte_ent_prev | Quantité entrée prévue
sl_qte_pal_phys | Quantité par palette physique
sl_qte_phys | Quantité physique
sl_qte_sor_res | Quantité sortie réserve
sl_rgt1 libc_sl_rgt1 libl_sl_rgt1 | Code lieu rangement 1 Libellé court Libellé long
sl_rgt2 | Code lieu rangement 2
sl_rgt3 | Code lieu rangement 3
sl_soc | Code société
sl_suivi_palette | Article suivi à la palette
sl_transfert_cube | Flag transfert Cube
sl_valeur | Valeur du stock physique
sl_le_libpar1_fou | Référence article pour l'article du stock lot-lieu (sl_article) et son fournisseur (mp_foucli)
sl_le_libelle_fou | Libellé spécifique pour l'article du stock lot-lieu (sl_article) et son fournisseur (mp_foucli)
sl_le_libelle2_fou | Complément libellé spécifique pour l'article du stock lot-lieu (sl_article) et son fournisseur (mp_foucli)
sl_le_libpar1_qualmat | Référence article pour la qualité matière de l'article du stock lot-lieu
sl_le_libelle_qualmat | Libellé spécifique pour la qualité matière de l'article du stock lot-lieu
sl_le_libelle2_qualmat | Complément libellé spécifique pour la qualité matière de l'article du stock lot-lieu

FICHE ARTICLE (TABLE MAT)

lib_mp_afnor_art | Désignation article
lib_mp_afnor_ecma | Désignation ECMA
lib_mp_cdc | Libellé centre de coût
lib_mp_remp | Désignation article remplacement
lib_qualite_matiere | Libellé article qualité matière
libc_mp_cond | Libellé court code conditionnement
libc_mp_coul | Libellé court code couleur
libc_mp_cs1 | Libellé court code statistique 1
libc_mp_cs2 | Libellé court code statistique 2
libc_mp_cs3 | Libellé court code statistique 3
libc_mp_cs4 | Libellé court code statistique 4
libc_mp_fam | Libellé court code famille
libc_mp_fconv | Libellé court code formule conversion
libc_mp_fconv2 | Libellé court code formule conversion 2
libc_mp_gestionnaire | Libellé court code gestionnaire
libc_mp_libre | Libellé court zone libre
libc_mp_qualite | Libellé court code qualité
libc_mp_reap | Libellé court code réapprovisionnement
libc_mp_rgt1 | Libellé court code lieu rangement 1
libc_mp_sfm | Libellé court code sous-famille
libc_mp_site_prod | Libellé court site de production
libc_mp_tva | Libellé court code TVA
libc_mp_ua | Libellé court code unité achat
libc_mp_uv | Libellé court code unité vente
libc_mp_uvente | Libellé court code unité vente 2
libl_mp_cond | Libellé long code conditionnement
libl_mp_coul | Libellé long code couleur
libl_mp_cs1 | Libellé long code statistique 1
libl_mp_cs2 | Libellé long code statistique 2
libl_mp_cs3 | Libellé long code statistique 3
libl_mp_cs4 | Libellé long code statistique 4
libl_mp_fam | Libellé long code famille
libl_mp_fconv | Libellé long code formule conversion
libl_mp_fconv2 | Libellé long code formule conversion 2
libl_mp_gestionnaire | Libellé long code gestionnaire
libl_mp_libre | Libellé long zone libre
libl_mp_qualite | Libellé long code qualité
libl_mp_reap | Libellé long code réapprovisionnement
libl_mp_rgt1 | Libellé long code lieu rangement 1
libl_mp_sfm | Libellé long code sous-famille
libl_mp_site_prod | Libellé long site de production
libl_mp_tva | Libellé long code TVA
libl_mp_ua | Libellé long code unité achat
libl_mp_uv | Libellé long code unité vente
libl_mp_uvente | Libellé long code unité vente 2
mp_abc | Classement ABC
mp_affect | Numéro affectation
mp_afnor | Code normalisé
mp_alerte | Stock alerte
mp_ana | Code analytique
mp_anu | Article annulé
mp_at1 | Donnée technique alphanumérique 1
mp_at2 | Donnée technique alphanumérique 2
mp_cdc | Code centre de coût
mp_cfrais | Taux frais
mp_cli | Code client
mp_code | Code article
mp_coefdiv_ffix | Coefficient diviseur frais fixe
mp_cond | Code conditionnement
mp_controle | Code contrôle qualité
mp_coul | Code couleur
mp_cperte | Taux perte
mp_cpta | Compte achat
mp_cptv | Compte vente
mp_cs1 | Code statistique 1
mp_cs2 | Code statistique 2
mp_cs3 | Code statistique 3
mp_cs4 | Code statistique 4
mp_date | Date enregistrement article
mp_delmoy | Délai moyen d'approvisionnement
mp_derent | Date dernière entrée stock
mp_derinv | Date dernier inventaire stock
mp_dermvt | Date dernier mouvement stock
mp_dersor | Date dernière sortie stock
mp_des | Désignation article
mp_des2 | Désignation complémentaire article
mp_devis | Numéro devis
mp_dt1 | Donnée technique numérique 1
mp_dt2 | Donnée technique numérique 2
mp_dt3 | Donnée technique numérique 3
mp_dt4 | Donnée technique numérique 4
mp_dt5 | Donnée technique numérique 5
mp_dt6 | Donnée technique numérique 6
mp_dt7 | Donnée technique numérique 7
mp_dt8 | Donnée technique numérique 8
mp_entite | Numéro entité
mp_etat_bes | Etat des besoins matières
mp_fam | Code famille
mp_fconv | Code formule conversion
mp_fconv2 | Code formule conversion 2
mp_foucli | Code fournisseur
mp_gencod | Code gencode
mp_gestionnaire | Code gestionnaire
mp_hau | Hauteur
mp_itf14 | Code ITF14
mp_lar | Largeur
mp_libre | Zone libre
mp_lon | Longueur
mp_marg | Taux marge
mp_minfou | Minimum commande fournisseur ou fabrication
mp_mp | Type article
mp_ndm | Numéro dernier mouvement stock
mp_pa | Prix achat
mp_pamp | Valeur stock
mp_param | Zone données diverses
mp_param_19 | mp_param[19]
mp_poids | Poids
mp_pr | Prix revient
mp_pr_fixe | Prix fixe
mp_pv | Prix vente
mp_pv2 | Prix vente dans l'unité utilisation
mp_qteeco | Quantité économique commande ou fabrication
mp_qtemini_cdeclt | Quantité minimum pour commande client
mp_qualite | Code qualité
mp_qualite_matiere | Code qualité matière
mp_reap | Code réapprovisionnement
mp_remp | Code article remplacement
mp_rgt1 | Code lieu rangement 1
mp_rgt2 | Code lieu rangement 2
mp_rgt3 | Code lieu rangement 3
mp_sbes | Stock besoins
mp_scdef | Stock en commande ou en fabrication
mp_sdevis | Numéro sous-devis
mp_sdisp | Stock disponible
mp_sfm | Code sous-famille
mp_site_prod | Site de production
mp_smaxi | Stock maxi
mp_smini | Stock mini
mp_soc | Code société
mp_sphy | Stock physique
mp_sres | Stock réserve
mp_ssim | Stock simulation
mp_suistk | Suivi en stock
mp_tva | Code TVA
mp_tval | Type valorisation
mp_ua | Code unité achat
mp_uv | Code unité vente
mp_uvente | Code unité vente 2
mp_z1 | Zone paramétrée 1
mp_z2 | Zone paramétrée 2
mp_z3 | Zone paramétrée 3
mp_z4 | Zone paramétrée 4
mp_z5 | Zone paramétrée 5
nom_mp_cli | Nom client
nom_abrege_mp_cli | Nom abrégé du client de la fiche produit
nom_mp_foucli | Nom fournisseur
zc1_mp_tva | Valeur 1code TVA
zc1_mp_ua | Valeur 1code unité achat
zc1_mp_uv | Valeur 1code unité vente
zc1_mp_uvente | Valeur 1code unité vente 2

FICHE TIERS (TABLE CLI)

Toutes les zones du package Tiers ainsi que les zones suivantes :

nom_cl_adra codp_cl_adra ville_cl_adra pays_cl_adra libc_pays_cl_adra libl_pays_cl_adra | Nom de l'adresse réception Code postal de l'adresse réception Ville de l'adresse réception Pays de l'adresse réception Libellé court du pays de l'adresse réception Libellé long du pays de l'adresse réception
nom_cl_adrb codp_cl_adrb ville_cl_adrb pays_cl_adrb libc_pays_cl_adrb libl_pays_cl_adrb | Nom de l'adresse de livraison Code postal de l'adresse de livraison Ville de l'adresse de livraison Pays de l'adresse de livraison Libellé court du pays de l'adresse de livraison Libellé long du pays de l'adresse de livraison
nom_cl_adrd codp_cl_adrd ville_cl_adrd pays_cl_adrd libc_pays_cl_adrd libl_pays_cl_adrd | Nom de l'adresse des offres de prix Code postal de l'adresse des offres de prix Ville de l'adresse des offres de prix Pays de l'adresse des offres de prix Libellé court du pays de l'adresse des offres de prix Libellé long du paysd e l'adresse des offres de prix
nom_cl_adrf codp_cl_adrf ville_cl_adrf pays_cl_adrf libc_pays_cl_adrf libl_pays_cl_adrf | Nom de l'adresse de facturation Code postal de l'adresse de facturation Ville de l'adresse de facturation Pays de l'adresse de facturation Libellé court du pays de l'adresse de facturation Libellé long du pays de l'adresse de facturation

ENTETE COMMANDE (TABLE CDE1)

codp_ec_ada | Code postal adresse réception
codp_ec_adf | Code postal adresse facturation
codp_ec_adl | Code postal adresse livraison
ec_acc | Acompte dans la devise de la société
ec_acc_dev | Acompte dans la devise de la commande
ec_acc_euro | Acompte dans la devise EURO
ec_ada | Code adresse réception
ec_adf | Code adresse facturation
ec_adl | Code adresse livraison
ec_afacturer | Commande à facturer
ec_annu | Commande annulée
ec_ar | Accusé de réception à éditer
ec_bl | Reste des BL à éditer
ec_c1 | Code zone paramétrable
ec_cderat | Numéro dossier rattachement
ec_cli | Code client
ec_conf | Fiche de conformité
ec_corres | Nom correspondant
ec_cr | Code remise
ec_ct | Code tarif
ec_datc | Date commande
ec_date | Date enregistrement commande
ec_date_client | Date client commande
ec_date_deb_val | Date de début de validité du contrat
ec_date_fin_val | Date de fin de validité du contrat
ec_devise | Code devise
ec_ech | Code échéance
ec_esc | Escompte (en %)
ec_exp | Code exportation
ec_fab | En fabrication
ec_fabricant | Code fabricant
ec_fact | Reste des factures à éditer
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_mrg | Mode règlement
ec_num | Numéro commande
ec_oe | Ordre d'exécution à éditer
ec_ord | Numéro ordre
ec_pht | Port taxable dans la devise de la société
ec_pht_dev | Port taxable dans la devise de la commande
ec_pht_euro | Port taxable dans la devise EURO
ec_pnt | Port non taxable dans la devise de la société
ec_pnt_dev | Port non taxable dans la devise de la commande
ec_pnt_euro | Port non taxable dans la devise EURO
ec_poids | Poids total commande
ec_portf | Port facturé
ec_pro | Pro forma
ec_prx | Demande de prix
ec_ref | Référence commande
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_rem | Remise globale (en %)
ec_rep | Code représentant
ec_rstafa | Reste à facturer
ec_soc | Code société
ec_sold | Commande soldée
ec_suiv | Code suivi affaire
ec_texte | Libellé commande
ec_titre | Titre correspondant
ec_tour | Code tournée
ec_tport | Type de port
ec_transp | Code transporteur
ec_trep | Taux commission représentant
ec_trsp | Mode de transport
ec_tvap | Code TVA port taxable
ec_tyc | Type commande
ec_type_liaison | Type liaison
ec_web_statut | Code statut pour les commandes WEB
libc_ec_c1 | Libellé court zone paramétrable
libc_ec_cr | Libellé court code remise
libc_ec_ct | Libellé court code tarif
libc_ec_devise | Libellé court code devise
libc_ec_ech | Libellé court code échéance
libc_ec_fabricant | Libellé court code fabricant
libc_ec_mrg | Libellé court mode règlement
libc_ec_rep | Libellé court code représentant
libc_ec_suiv | Libellé court code suivi affaire
libc_ec_titre | Libellé court titre correspondant
libc_ec_tour | Libellé court code tournée
libc_ec_tport | Libellé court type de port
libc_ec_trsp | Libellé court mode de transport
libc_ec_tvap | Libellé court code TVA port taxable
libc_ec_tyc | Libellé court type commande
libc_ec_type_liaison | Libellé court type liaison
libc_ec_web_statut | Libellé court code statut pour les commandes WEB
libc_pays_ec_ada | Libellé court pays adresse réception
libc_pays_ec_adf | Libellé court pays adresse facturation
libc_pays_ec_adl | Libellé court pays adresse livraison
libl_ec_c1 | Libellé long zone paramétrable
libl_ec_cr | Libellé long code remise
libl_ec_ct | Libellé long code tarif
libl_ec_devise | Libellé long code devise
libl_ec_ech | Libellé long code échéance
libl_ec_fabricant | Libellé long code fabricant
libl_ec_mrg | Libellé long mode règlement
libl_ec_rep | Libellé long code représentant
libl_ec_suiv | Libellé long code suivi affaire
libl_ec_titre | Libellé long titre correspondant
libl_ec_tour | Libellé long code tournée
libl_ec_tport | Libellé long type de port
libl_ec_trsp | Libellé long mode de transport
libl_ec_tvap | Libellé long code TVA port taxable
libl_ec_tyc | Libellé long type commande
libl_ec_type_liaison | Libellé long type liaison
libl_ec_web_statut | Libellé long code statut pour les commandes WEB
libl_pays_ec_ada | Libellé long pays adresse réception
libl_pays_ec_adf | Libellé long pays adresse facturation
libl_pays_ec_adl | Libellé long pays adresse livraison
nom_ec_ada | Nom adresse réception
nom_ec_adf | Nom adresse facturation
nom_ec_adl | Nom adresse livraison
nom_ec_cli | Nom client
nom_ec_transp | Nom transporteur
pays_ec_ada | Pays adresse réception
pays_ec_adf | Pays adresse facturation
pays_ec_adl | Pays adresse livraison
ville_ec_ada | Ville adresse réception
ville_ec_adf | Ville adresse facturation
ville_ec_adl | Ville adresse livraison
zc1_ec_tvap | Valeur 1 code TVA port taxable

LIGNE DE COMMANDE (TABLE CDE2)

codp_lc_adf | Code postal adresse facturation
codp_lc_adl | Code postal adresse livraison
lc_adf | Code adresse facturation
lc_adl | Code adresse livraison
lc_afacturer | Ligne commande à facturer
lc_annu | Ligne commande annulée
lc_cderat | Numéro dossier rattachement
lc_colis | Nombre de colis
lc_com | Taux commission représentant
lc_cs1 | Code statistique 1
lc_cs2 | Code statistique 2
lc_cs3 | Code statistique 3
lc_cs4 | Code statistique 4
lc_date_gener | Date de génération
lc_date_regener | Date de régénération
lc_date_solde | Date de solde de la ligne de commande
lc_delcli | Date de livraison souhaitée
lc_deldep | Date de départ
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (Non utilisée)
lc_delrep | Date de livraison proposée
lc_dev | Numéro devis
lc_entite | Numéro entité
lc_facrat | Numéro facture rattachement
lc_fam | Code famille
lc_gen_bl_auto | Génération automatique des BL
lc_haut | Hauteur
lc_heure_cli_tard | Heure de livraison souhaitée au plus tard
lc_heure_cli_tot | Heure de livraison souhaitée au plus tôt
lc_heure_dep_tard | Heure de départ proposée au plus tard
lc_heure_dep_tot | Heure de départ proposée au plus tôt
lc_heure_fab_tard | Heure de fin de fabrication au plus tard
lc_heure_fab_tot | Heure de fin de fabrication au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_larg | Largeur
lc_lcderat | Numéro ligne dossier rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_lib | Désignation article (Ligne commande)
lc_lieu_rgt1 | Code lieu de rangement 1
lc_lig | Numéro ligne commande
lc_ligne_a_epurer | Ligne à épurer
lc_long | Longueur
lc_lot | Numéro lot de la ligne de commande
lc_marge | Pourcentage marge
lc_mpl_prx_ini | Prix initial dans la devise de la société
lc_mpl_prx_ini_dev | Prix initial dans la devise de la commande
lc_mpl_prx_ini_eur | Prix initial dans la devise EURO
lc_mpl_qte_ini | Quantité commandée initiale
lc_num | Numéro commande
lc_nummvt | Numéro mouvement de stock 1
lc_nummvt2 | Numéro mouvement de stock 2
lc_nummvt3 | Numéro mouvement de stock 3
lc_p1 | Code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lc_par_tyc | Code paramètre type de commande
lc_poids | Poids ligne commande
lc_priorite | Niveau priorité ligne commande
lc_prixnet | Prix net
lc_prod | Code article
lc_prx | Prix unitaire vente dans la devise de la société
lc_prx_au_moins | Prix unitaire vente au moins dans la devise de la société
lc_prx_au_plus | Prix unitaire vente au plus dans la devise de la société
lc_prx_dev | Prix unitaire vente dans la devise de la commande
lc_prx_euro | Prix unitaire vente dans la devise EURO
lc_prx_moins_dev | Prix unitaire vente au moins dans la devise de la commande
lc_prx_moins_euro | Prix unitaire vente au moins dans la devise EURO
lc_prx_plus_dev | Prix unitaire vente au plus dans la devise de la commande
lc_prx_plus_euro | Prix unitaire vente au plus dans la devise EURO
lc_prx_revient | Prix unitaire revient dans la devise de la société
lc_prx_rvt_dev | Prix unitaire revient dans la devise de la commande
lc_prx_rvt_euro | Prix unitaire revient dans la devise EURO
lc_prx_rvt_r_euro | Prix unitaire revient réel dans la devise EURO
lc_prx_rvt_reel | Prix unitaire revient réel dans la devise de la société
lc_prxcli | Prix client dans la devise de la société
lc_prxcli_dev | Prix client dans la devise de la commande
lc_prxcli_euro | Prix client dans la devise EURO
lc_qte_contrat | Quantité commandée actuelle du contrat
lc_qte_en_retour | Quantité retournée par le bon de retour
lc_qteafa | Quantité à facturer
lc_qtecde | Quantité commandée
lc_qtefab | Quantité fabriquée
lc_qtefac | Quantité facturée
lc_qtelan | Quantité lancée
lc_qteliv | Quantité livrée facturable
lc_qteliv_reelle | Quantité réellement livrée
lc_qualif_appel | Qualification de l'appel de livraison
lc_ref_prod_cli | Référence produit du client
lc_rem | Remise ligne (en %)
lc_repr | Code représentant
lc_rstafa | Reste à facturer
lc_rstbl | Reste des BL à éditer
lc_rstfab | Reste à fabriquer
lc_rstfac | Reste des factures à éditer
lc_sbi | Code Facture SBI (Self Billing Invoice)
lc_sdev | Numéro sous-devis
lc_sfm | Code sous-famille
lc_soc | Code société
lc_solde | Ligne commande soldée
lc_tolerance_liv | Code tolérance livraison
lc_transfert_trans | Code transfert SYLOGI
lc_tva | Code TVA
lc_unvent | Code unité vente
lc_unvent_au | Code unité vente au
lc_var_prod | Code variante de production
lc_variante | Numéro variante retenue lors du transfert du devis
lc_volupilot_ok | Flag indiquant si la commande a été traitée par VoluPilot
lib_lc_p3 | Libellé zone paramétrable 3
lib_lc_prod | Désignation article (Fiche article)
libc_lc_cs1 | Libellé court code statistique 1
libc_lc_cs2 | Libellé court code statistique 2
libc_lc_cs3 | Libellé court code statistique 3
libc_lc_cs4 | Libellé court code statistique 4
libc_lc_fam | Libellé court code famille
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libc_lc_p1 | Libellé court zone paramétrable 1
libc_lc_p2 | Libellé court zone paramétrable 2
libc_lc_par_tyc | Libellé court code paramètre type de commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libc_lc_repr | Libellé court code représentant
libc_lc_sfm | Libellé court code sous-famille
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libc_lc_tva | Libellé court code TVA
libc_lc_unvent | Libellé court code unité vente
libc_lc_unvent_au | Libellé court code unité vente au
libc_pays_lc_adf | Libellé court pays adresse facturation
libc_pays_lc_adl | Libellé court pays adresse livraison
libl_lc_cs1 | Libellé long code statistique 1
libl_lc_cs2 | Libellé long code statistique 2
libl_lc_cs3 | Libellé long code statistique 3
libl_lc_cs4 | Libellé long code statistique 4
libl_lc_fam | Libellé long code famille
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
libl_lc_p1 | Libellé long zone paramétrable 1
libl_lc_p2 | Libellé long zone paramétrable 2
libl_lc_par_tyc | Libellé long code paramètre type de commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
libl_lc_repr | Libellé long code représentant
libl_lc_sfm | Libellé long code sous-famille
libl_lc_tolerance_liv | Libellé long code tolérance livraison
libl_lc_tva | Libellé long code TVA
libl_lc_unvent | Libellé long code unité vente
libl_lc_unvent_au | Libellé long code unité vente au
libl_pays_lc_adf | Libellé long pays adresse facturation
libl_pays_lc_adl | Libellé long pays adresse livraison
nom_lc_adf | Nom adresse facturation
nom_lc_adl | Nom adresse livraison
pays_lc_adf | Pays adresse facturation
pays_lc_adl | Pays adresse livraison
ville_lc_adf | Ville adresse facturation
ville_lc_adl | Ville adresse livraison
zc1_lc_tva | Valeur 1code TVA
zc1_lc_unvent | Valeur 1code unité vente
zc1_lc_unvent_au | Valeur 1code unité vente au
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

LIGNE DE NOMENCLATURE (TABLE CDE4)

lib_nc_prod | Désignation article (Fiche article)
libc_nc_reap | Libellé court code réapprovisionnement
libc_nc_rgt1 | Libellé court code lieu rangement 1
libl_nc_reap | Libellé long code réapprovisionnement
libl_nc_rgt1 | Libellé long code lieu rangement 1
nc_coef_nom | Coefficient nomenclature
nc_lig | Numéro ligne de commande
nc_ligfbi | Numéro ligne de FBI
nc_num | Numéro commande
nc_numfbi | Numéro FBI
nc_nummvt | Numéro mouvement de stock 1
nc_nummvt2 | Numéro mouvement de stock 2
nc_nummvt3 | Numéro mouvement de stock 3
nc_prod | Code article
nc_qte_contrat | Quantité commandée actuelle du contrat
nc_qtecde | Quantité commandée
nc_qtefab | Quantité fabriquée
nc_qteliv | Quantité livrée
nc_qteliv_non_val | Quantité livrée non validée
nc_qteliv_reelle | Quantité réellement livrée
nc_qteliv_val | Quantité livrée validée
nc_reap | Code réapprovisionnement
nc_rgt1 | Code lieu rangement 1
nc_rgt2 | Code lieu rangement 2
nc_rgt3 | Code lieu rangement 3
nc_rstfab | Reste à fabriquer
nc_seq | Numéro séquence de ligne de commande
nc_soc | Code société
nc_solde | Ligne nomenclature soldée

Libellés étrangers et spécifiques

le_libpar1 sl_le_libpar1 | Référence article du client (article principal)
le_libelle sl_le_libelle | Retourne le libellé spécifique du client s'il existe, sinon retourne blanc. (article principal) Retourne le libellé spécifique du client s'il existe, sinon retourne la désignation du produit. (article principal)
le_libelle2 sl_le_libelle2 | Complément du libellé spécifique (article principal)
ref_fou_qual_mat | le_libpar1 - Référence article du fournisseur de la qualité matière
lib_fou_qual_mat | le_libelle - Libellé spécifique de l'article du fournisseur de la qualité matière
lib2_fou_qual_mat | le_libelle2 - Complément du libellé spécifique de l'article du fournisseur de la qualité matière
le_libpar1_fou | Référence article pour l'article de la ligne de commande (lc_prod) et son fournisseur (mp_foucli)
le_libelle_fou | Libellé spécifique pour l'article de la ligne de commande (lc_prod) et son fournisseur (mp_foucli)
le_libelle2_fou | Complément libellé spécifique pour l'article de la ligne de commande (lc_prod) et son fournisseur (mp_foucli)
le_libpar1_qualmat | Référence article pour la qualité matière de l'article de la ligne de commande
le_libelle_qualmat | Libellé spécifique pour la qualité matière de l'article de la ligne de commande
le_libelle2_qualmat | Complément libellé spécifique pour la qualité matière de l'article de la ligne de commande

AUTRES ZONES

using | Voir #VI
qte_phys_pv_lot | Quantité physique valorisée au prix de vente du lot
today_date1 | Aujourd'hui - date 1 (Nombre de jours)
today_date2 | Aujourd'hui - date 2 (Nombre de jours)
today_date3 | Aujourd'hui - date 3 (Nombre de jours)
today_date4 | Aujourd'hui - date 4 (Nombre de jours)
cl_periode_consigne | Période actuelle de consigne de l'article
cl_depassement_delai_consigne | Indicateur de dépassement du délai maximum de consigne
TAR_XX | à utiliser conjointement avec les notes commençant par _TAR_XX

Amalgames

am_amal | Code de l'amalgame (identique au mp_code si enregistrement existant)
am_ref | Code de la référence
am_nb_poses | Nombre de poses de la référence dans l'amalgame (cumulable et utilisable dans les formules de calcul)
am_pourcent | Pourcentage occupé par la référence dans l'amalgame (cumulable et utilisable dans les formules de calcul)

Puisque cette table ne fait pas partie des critères de sélection, on ne prend en compte que le premier enregistrement trouvé dans la table.


v_stk0 Visualisation des mouvements de stock

Options Valeurs alpha Notes Tri Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : Code produit dont on veut visualiser les stocks Exemple : -N[mp_code]
-N_CP | Caractères 3 et suivants : Code produit que l'on peut utiliser ensuite dans les compléments de sélection (notes commençant par S) avec le mot clé _CRIT_PARAMETRE] Voir un exemple Exemples : -N[lc_prod] -N[nc_prod] -N[mp_code]
-N_LIN | Argument : Numéro de lot industriel (appel depuis le programme de visualisation des lots industriels) Exemple : -N_LIN[lin_lot_indus]

Options triées

aa

Valorisation sans coefficient de conversion des mouvements de stock des articles achetés

ab

Après le construct, remplace tous les and par des or

af

Idem option Opa sauf produits finis

am

Modification affectation des mouvements de stock déjà intégré

Accessible par l'action F15 depuis l'écran de consultation du mouvement de stock (Touche F9).

Nécessite la permission TOU V_STK0_F15.

Paramètres associés :

A2[30]

Notes MVT_SOR_PAP_TRS_ANN et MVT_ENT_PAP_TRS_ANN

La modification de l'affectation d'un mouvement de stock déjà intégré consiste à créer un mouvement de stock identique avec la quantité inversée et un mouvement de stock avec la nouvelle affectation et la quantité initiale.

Les dossiers sont mis à recalculer.

La création du mouvement de stock avec une nouvelle affectation et la quantité initiale peut être systématique ou sur confirmation.

ao

Affectation obligatoire si sortie normale et numéro de commande client saisi

ar

Pas d'allégement des ruptures à l'édition

as

Utilisation du s0_cde et s0_ligcde pour la récupération de la commande (lien vers les tables cde1 et cde2).

Option incompatible avec les options Ofc et Ocp

Si aucune des 3 options n'est présente, on recherche avec s0_lot.

bm

Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Voir aussi option Owm (message non bloquant)

br

Message bloquant si stock résultant négatif - Voir aussi option Owr (message non bloquant)

cc

Attribution automatique du code client après saisie du numéro de commande

ce

Consommation d'entrée normale

cf

Lancement automatique de la génération des commandes fournisseurs (gen_cdef)

Créer la note ACCES_GENCDEF

co

Consultation uniquement

cp

Utilisation du s0_cde et s0_prod pour récupérer le numéro de commande et de ligne (lien vers les tables cde1 et cde2)

Option incompatible avec les options Oas et Ofc

Si aucune des 3 options n'est présente, on recherche avec s0_lot.

cr

Création des reliquats après demande de confirmation lors :

- d'une transformation d'E-P en E-N

- d'une transformation d'E-C en E-N

- d'une transformation d'S-R en S-N

cs

Cumul des stocks par date/article/magasin

Ne sont listées que les lignes de cumuls (pas de détail des mouvements).

permet de ne pas avoir une ligne de visualisation/fichier par mouvement de stock.

Si aucun ordre de tri n'est défini, il est établi par défaut sur la date, puis le code article, puis le code magasin.

da

Passage automatique de la date du mouvement à la date du jour en modification de l'état d' un mouvement (si passage de R à N, ou P à N, ou C à N). Cette modification est accompagnée d' une confirmation du mouvement

dc

Suppression de la fenêtre de confirmation pour la modification de la date du mouvement de stock

dr

Ouverture d'une fenêtre permettant la saisie d'une date pour les mouvements de reliquat

dt

Détail des temps par type de machine

Voir les colonnes des temps par type de machine du lot du mouvement de stock

ec

SUPPRIMEE - Permet d' éditer le nom du correspondant principal du client

em

Autorisation de modification de l'état des mouvements de stock

Par défaut, l'état des mouvements de stock n'est pas modifiable.

eo

Suppression des sorties réserves de l'article consommé de toutes les entités de l'OF

L'option Oce doit être activée. L'option Ors ne doit pas être activée.

fa

Alimenter le fichier en sortie en mode Append

fc

Utilisation du s0_affect pour récupérer le numéro de commande et de ligne (lien vers les tables cde1 et cde2)

Nécessite que l'affectation soit au format 98100001-1/...

Option incompatible avec les options Oas et Ocp

Si aucune des 3 options n'est présente, on recherche avec s0_lot.

fd

On demande si l'on veut forcer la date de consommation (Par défaut c'est la date du jour)

L'option Oce doit être activée

<ou bien>

A4[22] = O

fp

TOP fin de période. Permet d'interdire de créer ou de modifier des lignes de BL concernant des articles stockes dont la date du BL est antérieure ou égale à ce TOP fin de période

gs

Gestion des besoins matières générés sur stock

i2

Affichage de la couleur, du grammage, du format et du montant total

im

Imprimerie - Edition du format et du grammage si famille = PAP ou CAR

in

Interdiction de saisir des mouvements de sortie normale entraînant un stock négatif.

l0

Pas d'affichage, d'édition ou d'extraction du mouvement de stock si le stock physique du lot-lieu du mouvement de stock à la date du jour du traitement (zone stock_lot_lieu_today) est égal à 0

la

Affichage du libellé correspondant à l'affectation. Concaténation des 3 zones suivantes :

Article de niveau 1 de l'affectation

Article de niveau 2 de l'affectation

Nature d'intervention de l'affectation

lf

Valorisation du mouvement de consommation au prix du lot d'achat, c'est à dire au prix de la ligne de commande fournisseur (ne fonctionne qu'avec l'option Oce).

ma

Modification et annulation des mouvements automatiques interdites

mc

Lancement de cde_maj_avancement. Voir les notes de type ACCES_CDE_MAJ_AV

mf

Conserve les marges fixes dans le fichier matière

mn

Lors d'une transformation d'une entrée prévisionnelle (ou en commande) en entrée normale, tous les mouvements de sortie réserve des OF de niveau n-1 seront passés en sortie réserve.

Si l'option Ocr existe, les reliquats de sortie seront gérés.

Visualisation de ces mouvements de sortie, ou modification éventuelle et validation

mp

La modification du prix unitaire en modification d'un mouvement est autorisée après saisie d'un mot de passe

mr

Message d'avertissement non bloquant si le stock résultant est négatif (demande de confirmation)

mx

Pas d'affichage de la fenêtre de confirmation de modification du prix si passage de sortie réserve à sortie normale

na

Les notes saisies sur le mouvement seront attachées à l'article et non pas au mouvement

nc

(Entrée normale en création) Utilisable uniquement s'il y a l'option Oof

Alimente automatiquement la zone note avec le libellé de la ligne de commande (affectation)

ne

Alimente automatiquement la zone note avec le libellé de la commande. Utilisable uniquement s'il y a l'option Oof

nf

Consultation ou modification des notes de la commande fournisseur associée au mouvement de stock en cours

np

En consommation d'entrée normale, création d'une nouvelle phase OF si l'article consommé est différent de l'article de l'OF

L'option Oce doit être activée.

Si l'OF n'a pas de consommation, le code produit de l'OF est remplacé par le code produit du mouvement de stock.

Si l'OF a déjà eu des consommations, la phase de l'OF du mouvement de stock est remplacée par la nouvelle phase de l'OF et celle-ci est créée dans l'OF.

o1

Ajout en auto de -1/1 et des zéros manquants

o2

Ajout des zéros manquants

o3

Ajout en auto de -1 et des zéros manquants

o4

Ajout en auto des zéros manquants, du -1 et du / avec le premier niveau de l'OF

of

Contrôle l'existence du numéro d'OF. ATTENTION ce paramètre est OBLIGATOIRE si on veut vérifier l'existence du dossier, contrôler qu'il est non clôturé, et positionner le dossier à calculer.

os

Permet de sélectionner les articles sans mouvements de stock.

pa

Met à jour le dernier prix d'achat dans mp_pa en fonction des entrées

Lors d'un inventaire, le stock est valorisé au prix d'achat

pi

Autorise la consommation de palette incomplète

pm

Prise en compte des frais et pertes en valeurs dans le fichier matières lors d'une modification du prix d'achat en saisie des entrées. IMPORTANT : si cette option est indiquée, il faut aussi la mettre en gestion des matières

pp

Initialise s0_libre avec la valeur du poids total mouvementé (cas de la modif par F9)

pq

Proratiser les consommations prévues en fonction de la quantité lancée des cadencements de fabrication

pr

Recalcule le prix de revient de l'ensemble en sommant les prix de revient des éléments de sa nomenclature

Voir la note _SUP_REQ_PR_ENSEMBLE

ps

Lors de la consommation d'une matière, si celle-ci n'est pas celle prévue, création systématique d'une nouvelle phase

qe

La quantité proposée est la quantité par palette du mouvement de stock d'entrée.

La quantité proposée n'est pas modifiable.

Une note est créée pour indiquer que l'entrée a été consommée.

L'option Oce doit être activée.

Le type de consommation des entrées normales doit être à O (A2[53] - Consommation par Lot-OF)

Voir la zone qte_deja_conso (Quantité déjà consommée sur le mouvement de stock d'entrée)

qf

Mise à jour quantité fabriquée de la commande (Entrée prévisionnelle --> Entrée normale en modification)

rp

F7 papier sur code matière (critères de sélection adaptés à la recherche des papiers)

rs

Gestion du reliquat de la 1ère sortie réserve annulée de l'article consommé de l'entité de l'OF

Voir A2[58]. L'option Oce doit être activée. L'option Oeo ne doit pas être activée.

rv

Recalcule la visualisation automatiquement après une action impliquant une modification de la sélection actuelle (exemple : transfert de stock)

sc

Inverse le mode de gestion de la zone solde client. Par défaut, cette zone est gérée pour un tri croissant de dates

Avec le paramètre, le tri se fera en ordre décroissant.

sn

Pour les articles de stock générés par l'option Omn, il n'y a pas mise à jour du stock résultant

Option Omn nécessaire

sp

Ouverture d'une fenêtre pour saisie du prix pour plusieurs unités

- pour 1 unité d'utilisation

- pour 1 unité d'achat (coef_conv(1)

- pour 1 unité numéro 3 paramétrable (coef_conv(3)

sq

Ouverture d'une fenêtre pour saisie d'une quantité dans plusieurs unités :

- unité d'utilisation

- unité d'achat ( coef_conv(1)

- unité numéro 3 paramétrable ( coef_conv(3)

wm

Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Voir aussi option Obm (message bloquant)

wq

Message non bloquant si quantité négative

wr

Message non bloquant si stock résultant négatif - Voir aussi option Obr (message bloquant)

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 4 | Mécanique - Imprimerie (O/N) N Mécanique O Imprimerie
Caractère 5 | Heures - Minutes (O/N) N Heures - Centièmes O Heures - Minutes
Caractère 6 | Modification des notes (O/N) N Non O Oui
Caractère 7 | Recopie des notes sur les (O/N) mouvements de reliquat N Non O Oui
Caractère 8 | Affectation GIE papier (O/N) N Non O Oui
Caractère 9 | Etat client (O/N) N Non O Oui
Caractère 10 | Edition en mode batch E On utilise le paramétrage Edition F On utilise le paramétrage Fichier
Caractère 11 | Ajout caractère 0D en fin ligne (O/N) N Non O Oui
Caractères 12 à 14 | Type paramètre de la saisie des tarifs (exemple #CF)
Caractères 15 à 17 | Code paramètre de la saisie des tarifs (exemple #TCL)
Caractères 18 à 20 | Type du mouvement de stock des sorties pour éclatement de palette Obligatoire si l'option Oce est actif et si le type de consommation des entrées normales est à O. Exemple : DEP
Caractères 21 à 23 | Type du mouvement de stock des entrées pour éclatement de palette Obligatoire si l'option Oce est active et si le type de consommation des entrées normales est à O Exemple : EEP
Caractère 24 | Permet de choisir le type de désignation de l'OF sur l'écran des consommations de la visu des stocks A désignation de l'article (f0_prod) (valeur par défaut) C désignation de l'entête de commande (f0_cde) L désignation de la ligne de commande (f0_cde, f0_lig)
Caractère 25 | Origine du numéro de commande et du numéro de ligne de commande d'achat Valeur par défaut : C C Numéro de commande d'achat = s0_cdefou Numéro de ligne de commande d'achat = s0_ligcde L Numéro de commande d'achat = s0_lot[1,8] Numéro de ligne de commande d'achat = s0_lot[10,12]
Caractères 26 à 29 | Largeur du camion (en cm) Exemple : 2400 Rappel Pour le calcul du métrage linéaire, les TSC suivants doivent être renseignés : TSC 220, ic_num1 : nombre de PF par palette TSC 220, ic_num3 : gerbage TSC 225, ic_num1 : longueur palette TSC 225, ic_num2 : largeur palette
Caractère 30 | Demande de génération du mouvement de stock avec la nouvelle affectation (O/N, N par défaut) Voir aussi l'option Oam.
Caractère 31 | Numéro de la donnée technique de la fenêtre tri (1 par défaut)
Caractères 32 à 34 | Type paramètre pour la zone lc_par_tyc de la ligne de commande Exemple NI pour les commandes de type FBM
Caractère 35 | Type de recherche article
Caractères 36 à 38 | Type paramètre pour le programme d'édition des étiquettes
Caractères 39 à 41 | Code paramètre pour le programme d'édition des étiquettes
Caractères 42 à 44 | Type de paramètre pour le programme de recalcule des mouvements de stock en aval lors de la modification du prix sur un mouvement d'entrée ou sortie normale (obligatoire si paramètre -Omp actif)
Caractères 45 à 48 | Code du paramètre pour le programme de recalcule des mouvements de stock en aval lors de la modification du prix sur un mouvement d'entrée ou sortie normale (obligatoire si paramètre -Omp actif)
Caractère 49 | Fait-on appel à des zones contenues dans la table des besoins matières (cde5) ?
Caractères 50 à 52 | Type du mouvement de stock des sorties pour consommation Exemple SC
Caractère 53 | Type de consommation des entrées normales L Consommation par Lot (Valeur par défaut) O Consommation par Lot-OF Facultatif si l'option Oce est active
Caractère 54 | Contrôle si le client de l'OF est identique à celui du mouvement de stock N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant Obligatoire si l'option Oce est active et si le type de consommation des entrées normales = O
Caractères 55 à 57 | Type du mouvement de stock des retours d'atelier. Exemple RA Facultatif si l'option Oce est active et si le type de consommation des entrées normales = O
Caractère 58 | Valeur par défaut de la suppression des sorties réserves (Si PAS d'option Ors) N Non O Oui Valeur par défaut de la suppression des sorties réserves (Si option Ors) N Non O Oui sans reliquat R Oui avec reliquat Obligatoire si l'option Oce est active et si le type de consommation des entrées normales = O
Caractère 59 | Contrôle si l'article de l'OF est identique à celui du mouvement de stock N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant Obligatoire si l'option Oce est active et si le type de consommation des entrées normales = O
Caractère 60 | Initialisation du client du mouvement E Le client du mouvement est initialisé avec le client du mouvement d'entrée O Le client du mouvement est initialisé avec le client de l'OF s'il est saisi. Si pas d'OF, le client est initialisé à blanc. NB : Ce caractère 60 est à initialiser uniquement si le caractère A2[53] = O.

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES MOUVEMENTS DE STOCK

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 6

Touche F6 (O/N) : Rafraîchissement (réactualisation) de l'écran

Caractère 8

Touche F8 (O/N) : Visualisation détail article

Caractère 9

Touche F9 (O/N) : Visualisation mouvement de stock

Caractère 11

Touche F11 (O/N) : Visualisation des lots

Caractère 12

Touche F12 (O/N) : Visualisation des lieux

Caractère 13

Touche F13 (O/N) : Consommation d'entrée normale

O Oui

N Non

R La touche est active. La visualisation se Recalculera après appui sur la touche F13.

Caractère 14

Touche F14 (O/N) : Visualisation inventaire par lots et/ou par lieux

Caractère 16

Touche F16 (O/N)

Réactualisation du stock physique par génération d'un mouvement de régularisation

Paramétrage à réaliser sur #CF STK

Caractère 18

Touche F18 (O/N) Consultation des stocks par G_consult_stock

Caractère 19

Touche F19 (O/N) pour accès à la visu de l'état de la commande en production.

Voir la note PARAM_DECLAR_PROD

Caractère 21

Accès autorisé à la fonction de transfert de stock (F21, Shift+F9) (O/N, N par défaut)

Caractère 22

Accès autorisé à la fonction d'une création de consommation d'un besoin matière en mode picking (O/N, N par défaut)

Voir les notes CONFIG_GST_STK et DETART_PICK_TMV_MVT.

La touche F22 permet, depuis la visualisation des mouvements des stocks, de créer un ou des mouvements de consommation d'une matière.

La nouvelle fonction F22 ne fonctionne que sur les stocks du type réserve (TMV A1[2] = R).

L'utilisateur pourra consommer de la matière sur différents lots ou lieux pour le mouvement de réserve sélectionné.

Caractères 23 à 36

L I B R E S L I B R E S L I B R E S L I B R E S L I B R E S L I B R E S L I B R E S

Caractère 37

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Caractère 38

Touche CONTROL-C (O/N)

Caractère 46

Touche CONTROL-N (O/N)

Caractère 48

Touche CONTROL-P (O/N) - Visualisation des mouvements de stock

Caractère 51

Touche CONTROL-T (O/N)

Caractère 56

Touche CONTROL-Z (O/N)

Notes triées

ACCES_CDE_MAJ_AV

21 à 26 Type et code de lancement de cde_maj_avancement (ex : #SAMAJ)

ACCES_CONSULT_STOCK

21 à 26 Type et code du paramètre de lancement du programme G_consult_stock

ACCES_GENCDEF

21 à 26 Type et code du paramètre de lancement de la génération des commandes fournisseurs (gen_cdef) - Voir aussi l'option Ocf.

Exemple : #SAGCF

ACCES_MVT_PE3

Tracer la vie d'une palette

21 Autoriser la recherche via la table pal_expedition_3 (O/N, N par défaut)

22 Traiter également les mouvement annulés (O/N, N par défaut)

Ajout d'un libellé paramétrable pour la saisie d'un conteneur (note LIB_CONDITIONNEMENT) et de l'aide à la saisie via la touche F7 lorsque l'on est sur le champ correspondant.

Si la gestion du stock détaillé par unité de conditionnement est activée (so_options[40] = O) et si le caractère 21 l'autorise, on réalise la procédure suivante :

1 Dans pal_expedition_3, on récupère :
- le numéro de mouvement de sortie de la palette expédition
- le numéro de mouvement d'entrée de la palette expédition

2 On recherche dans stk0 et mat les mouvements de stock correspondants pour le produit de cette palette.

3 Ajout dans la visu des enregistrements correspondants

Les mouvements annulés peuvent être ignorés en fonction du caractère 22.

ACCES_SAISIE_BL

21 à 26 Type et code du paramètre de lancement de la saisie des BL non appairés

31 à 36 Type et code du paramètre de lancement de la saisie des BL appairés

Cet accès par la touche F17 n'est possible que si l'affectation de la ligne de mouvement de stock correspond à un numéro de BL.

CLIPPED_LIGNE_EF

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

CODE_BESOIN_SMC

21,23 Code paramètre pour le paramétrage général des besoins (SMC par défaut)

CONFIG_GST_STK

Code du paramètre de configuration pour utiliser la fonction de création d'une consommation d'un besoin matière en mode picking (#CF GST ou autre, il n'y a pas de valeur par défaut).

Les notes du #CF GST correspond aux options de la visualisation des stocks.

Les notes sont prioritaires par rapport aux options si elles sont présentes.

Voir A4[22]

CONFIG_TARIF_BESOIN

21,26 Type et code du paramètre de la configuration des tarifs (par défaut #CFTAR)

CODES_TMV_TRANSFERT

21,23 Type de mouvement de sortie à créer lors pour un transfert de stock

24,26 Type de mouvement d'entrée à créer lors pour un transfert de stock

DETART_PICK_TMV_MVT

21,23 Code du paramètre TMV (obligatoire pour la fonction F22 : création d'un mouvement de consommation).

Type de mouvement de sortie normal pour la consommation de la matière.

Voir A4[22]

FIN_FIC_1_T_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

LIB_CONDITIONNEMENT

21,60 Libelle du champ palette/conteneur

Exemple

PALETTE N° :

Voir la note ACCES_MVT_PE3

LIEUX_1_2_3

Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de

saisie manuelle (stk0)

intégration des temps et matières (int_rtm)

visualisation des mouvements de stocks (ici)

La recherche se fait :

1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F ….)

2 sur la sous-famille de l'article

3 sur la famille de l'article

4 sur le type de mouvement de stock

5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3)

13 Type d'article : P, S, M, F … Correspond au champ mp_mp de la table mat (si blanc : recherche globale)

21,23 Lieu de rangement 1 (magasin)

25,27 Lieu de rangement 2 (Emplacement)

29,31 Lieu de rangement 3 (Emplacement)

_MENU_AUTO_PREC

21 Retour direct à la saisie d’un nouveau critère de visualisation (O/N : N par défaut)

Auparavant, lorsque l’utilisateur quittait l'écran de visualisation des stocks, le programme revenait automatiquement sur l’écran de sélection permettant ainsi de lancer une nouvelle visualisation.

Suite à la demande de certains clients, cette fonctionnalité avait été enlevée.

Cette note permet de la réactiver.

MVT_SOR_BOB_TRS_ANN

21,23 Type de mouvement de sortie de stock bobine

pour le transfert lors d'une annulation de mouvement de consommation

Voir dans la saisie des mouvements de stocks : Gestion de l'annulation d'une consommation de bobine ou de papier.

MVT_ENT_BOB_TRS_ANN

21,23 Type de mouvement d'entrée de stock bobine

pour le transfert lors d'une annulation de mouvement de consommation

Voir dans la saisie des mouvements de stocks : Gestion de l'annulation d'une consommation de bobine ou de papier.

MVT_SOR_PAP_TRS_ANN

21,23 Type de mouvement de sortie de stock papier

pour le transfert lors d'une annulation de mouvement de consommation

Voir dans la saisie des mouvements de stocks : Gestion de l'annulation d'une consommation de bobine ou de papier.

Voir aussi l'option Oam.

MVT_ENT_PAP_TRS_ANN

21,23 Type de mouvement d'entrée de stock papier

pour le transfert lors d'une annulation de mouvement de consommation

Voir dans la saisie des mouvements de stocks : Gestion de l'annulation d'une consommation de bobine ou de papier.

Voir aussi l'option Oam.

N

2,60 Nom du fichier par défaut lors de l'export dans un fichier

Le nom du fichier peut être rempli directement à partir du compteur grâce au mot-clé %cpt%

Exemple : Stock_visu_%cpt%.txt

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

A4[19] = O pour permettre l'accès à cette fonction.

REGROUP_STOCK_ART

Voir dans les généralités

S

Complément de requête sur la table stk0

Le mot-clé _CRIT_PARAMETRE sera remplacé automatiquement par le critère passé en paramètre à la visualisation.

Le but est de permettre d'utiliser dans le complément de sélection un critère passé en paramètre par –N_CP (appel à la visualisation des stocks depuis un programme tiers).

Par exemple :

Depuis la visualisation des temps, on fait appel à la visualisation des stocks de l'OF 09030405.

Le programme de visualisation des stocks est donc lancé avec le paramètre -N_CP:09030405

Le complément de sélection suivant est paramétré sur le programme de visualisation des stocks :

S and exists

S (select * from stk0 a

S where a.s0_soc = stk0.s0_soc

S and a.s0_anu = 'N'

S and a.s0_prod = stk0.s0_affect[12,26]

S and a.s0_num = to_number(substr(stk0.s0_affect,28,4))

S and a.s0_affect[1,8] = '_CRIT_PARAMETRE')

Le mot-clé _CRIT_PARAMETRE est alors automatiquement remplacé par 09030405.

SEP_VISU_TYPE_F_CHAR

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

_SUP_CONSO_FLE_MAT

21,60 Supplément de requête sur la table fle_mat

Utilisé pour la recherche du papier prévu et de la quantité prévue du dossier de fabrication

_SUP_CONSO_QTE_ENT

21,60 Complément de requête sur la table stk0 pour le calcul de la quantité consommable sur le lot

Voir option Oce et A2[53].

ATTENTION : L'utilisation du caractère ? dans ce complément de sélection est possible (mais doit être unique).

Ce caractère sera alors interprété comme étant le lieu de niveau 2 du mouvement d'entrée en stock sur lequel la consommation est saisie.

Don on peut mettre : "and s0_rgt2 = ?" si on veut tenir compte de ce niveau de lieu de rangement.

S'il a été paramétré "and s0_rgt2 = ?" et que le lieu de rangement 2 du mouvement d'entrée n'est pas renseigné, alors la recherche passera automatiquement en "and (s0_rgt2 is null or s0_rgt2 = '')"

_SUP_CONSO_QTE_SOR

21,60 Complément de requête sur la table stk0 pour le calcul de la quantité déjà consommée

Voir option Oce et A2[53].

ATTENTION : L'utilisation du caractère ? dans ce complément de sélection est possible (mais doit être unique).

Ce caractère sera alors interprété comme étant le lieu de niveau 2 du mouvement d'entrée en stock sur lequel la consommation est saisie.

Don on peut mettre : "and s0_rgt2 = ?" si on veut tenir compte de ce niveau de lieu de rangement.

S'il a été paramétré "and s0_rgt2 = ?" et que le lieu de rangement 2 du mouvement d'entrée n'est pas renseigné, alors la recherche passera automatiquement en "and (s0_rgt2 is null or s0_rgt2 = '')"

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note est prioritaire sur celle du paramètre USE.

_SUP_REQ_PR_ENSEMBLE

21,60 Complément de requête pour limiter les éléments pris en compte dans le recalcul du PR issus de la nomenclature de l'ensemble [tables nom0 et mat (fiche matière du PF, ce n'est pas la fiche matière de l'ensemble)].

Voir l'option Opr

_SUP_REQ_STK0_1ERMVT

Supplément de requête facultatif sur la table des mouvements de stock pour récupérer le prix du 1er mouvement de stock du lot du produit

Exemple

_SUP_REQ_STK0_1ERMVT and s0_typ in ("ENT")

_SUP_STK0_VISU_LL

21,60 Supplément de requête sur la table stk0 pour le F7 sur le numéro du lot

TEXT_LIBRE_1_V_T_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

TITRE_MENU

21 à 60 Titre du menu principal du programme v_stk0

TITRE_VISU_TYPE_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

TYPE_NOTE_CLI3_FOU

21 à 23 Type de note à prendre en compte dans la recherche de fournisseur par tarif (ex : ACH)

VISU_STK_PROD_PARAM

21 à 23 Type du paramètre de la visualisation des stocks de l'article (PF) par F9

24 à 26 Code du paramètre de la visualisation des stocks de l'article (PF) par F9

VISU_STK_PROD_SQL

21 à 60 Complément de sélection pour la visualisation des stocks

Ordres de tris disponibles

Voir les notes commençant par O

01 | s0_prod | code de l'article
02 | s0_num | numéro de mouvement de stock
03 | s0_datm | date de mouvement de stock
04 | s0_es | Entrée/Sortie/Valeur
05 | s0_typ | type de mouvement de stock
06 | s0_etat | état du mouvement
07 | s0_cli | code client du mouvement
08 | s0_fou | code fournisseur du mouvement
09 | s0_affect | numéro d'OF ou affectation
10 | s0_cdc | centre de coût
11 | s0_cde | numéro de commande client
12 | s0_cdefou | numéro commande fournisseur
13 | s0_lot | numéro de lot
14 | s0_rgt1 | lieu de rangement niveau 1
15 | mp_fam | code famille
16 | mp_sfm | code sous-famille
17 | mp_afnor | code AFNOR
18 | mp_libre | Catégorie article
19 | mp_lar | largeur
20 | mp_dt1 | donnée technique
21 | code_par_tyc | paramètre pour la zone lc_par_tyc
22 | code_art_niv1 | code de l'article niveau 1
23 | code_art_niv2 | code de l'article niveau 2
24 | mp_lon | longueur
25 | mp_poids | poids - grammage
26 | tct_sfm | sous-famille
27 | mp_qualite_matiere | qualité matière
28 | te_login | login traçabilité
29 | s0_rgt2 | lieu de rangement 2, hors état palette
30 | s0_adl | Adresse de livraison
31 | no_of_papier | Affectation papier
32 | s0_id_conteneur | Identifiant conteneur
33 | s0_employe | Code employé
34 | s0_datm | Date à l'année
35 | s0_datm | Date au mois
36 | s0_datm | Date à la semaine
37 | code_vt | Code article de version technique

Listes des zones paramétrables

Les zones avec possibilité de totalisation (O/N) sont affichées en bleu.

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Packages conteneur_info et conteneur_produit.

Package Cadencements de livraison prévisionnels

Package employés

Package tiers

Toutes les zones des tables cde1 et cde2 (voir les remarques dans les options Oas et Ofc)

Toutes les zones des tables cdf1 et cdf2

Toutes les zones des tables blv1 et blv2

Toutes les zones des tables bon_retour_cli1 et bon_retour_cli2

Toutes les zones de la table hist_pr

On formule le nom de colonne ainsi :

hp_t_item avec

hp Préfixe constant

t Type d'enregistrement

item Nom du champ

Exemple hp_V_z1 désigne le champs z1 au sein d'un enregistrement de type V

Mouvement de stock

Article du mouvement de stock

Article qualité carton de l'article du mouvement de stock

Article composition technique carton de l'article du mouvement de stock

Libellés de paramètres

Traçabilité (entête)

Consommations matières

Autres

Temps par type de machine du lot du mouvement de stock

Zones de la qualité matière de l'article mouvementé

Package standard

Mouvement de stock

s0_soc | Code de la société
s0_prod | Code de l'article
s0_ ? | Numéro de mouvement de stock
s0_datm | Date de mouvement de stock
s0_typ | Type de mouvement de stock
s0_es | E/S/V (Entrée /Sortie /Valeur)
s0_cli | Code client du mouvement
s0_fou | Code fournisseur du mouvement
s0_cde | Numéro de commande client
s0_cdefou | Numéro commande fournisseur
s0_prix | Prix unitaire
s0_frais | Frais - Port
s0_affect | Numéro d'OF ou affectation
s0_cdc | Centre de coût
s0_etat | Etat du mouvement (R/C/N)
s0_qte | Quantité mouvement
s0_qteclient | Quantité mouvement pour le client
s0_stkres | Stock résultant
s0_lot | Numéro de lot
s0_rgt1 | Lieu de rangement niveau 1
s0_rgt2 | Lieu de rangement niveau 2
s0_rgt3 | Lieu de rangement niveau 3
s0_integre | Ligne intégré en P.R. (O/N)
s0_ligcde | Ligne de commande fournisseur
s0_ligcad | Ligne de cadencement
s0_brc | Numéro de bon de réception
s0_libre | Zone libre
s0_anu | Annulé (O/N)
s0_id_conteneur | Unité de conditionnement (palette)
s0_conteneur_actif | Mouvement actif
s0_classe_mvt_vsw | Classe du mouvement
s0_id_cont_transf | Unité de conditionnement de transfert (palette)
lib_note | Première ligne de notes. Celle qui apparaît sur l'écran des mouvements.
s0_adl nom_s0_adl | Code adresse de livraison Raison sociale correspondante à l'adresse de livraison (par défaut, c'est la raison sociale du client du mouvement de stock, correspond à la colonne nom_s0_cli).
s0_lot_indus | Numéro de lot industriel
s0_date_deb | Date de début pour le lot industriel
s0_heure_deb | Heure de début pour le lot industriel L'heure est considérée comme une zone numérique, le point indiqué dans le format sera automatiquement remplacé par h (heure) Exemple : Si le format est &&.&&, la valeur 05.41 sera remplacée par 05h41 dans la visualisation.
s0_date_fin | Date de fin pour le lot industriel
s0_heure_fin | Heure de fin pour le lot industriel Pour le format, voir la remarque sur la zone s0_heure_deb ci-dessus.
s0_ssf libc_s0_ssf libl_s0_ssf | Code statut du produit semi-fini Libellé court Libellé long
s0_site_prod libc_s0_site_prod libl_s0_site_prod | Code site de production Libellé court Libellé long
s0_employe | Code employé Il est maintenant possible d'associer un code employé à un mouvement de stock. Ainsi, cela permet de connaître les quantités utilisées par chaque collaborateur.

Article du mouvement de stock

mp_mp | Type article (M/P/S/F/X)
mp_des | Désignation de l'article
mp_fam | Code famille
mp_sfm | Code sous-famille
mp_cond | Code conditionnement
mp_hau | Hauteur
mp_lon | Longueur
mp_lar | Largeur
mp_poids | Poids
mp_ua | Code unité d'achat
mp_uv | Code unité de vente
mp_pamp | Prix dans le mode de valorisation choisi
mp_pa | Prix d'achat
mp_pr | Prix de revient
mp_pv | Prix de vente (dans l'unité d'achat)
mp_pv2 | Prix de vente (dans l'unité de vente ou de stockage)
mp_fconv | Code formule de conversion
mp_suistk | Suivi en stock (O/N)
mp_tval | Type de valorisation
mp_dermvt | Date du dernier mouvement
mp_derinv | Date du dernier inventaire
mp_derent | Date de la dernière entrée
mp_dersor | Date de la dernière sortie
mp_smini | Stock mini
mp_alerte | Seuil d'alerte
mp_gestionnaire | Code du gestionnaire
mp_smaxi | Stock maxi
mp_sdisp | Stock disponible
mp_sphy | Stock physique
mp_sres | Stock réserve
mp_sbes | Besoins
mp_scdef | Stock en commande fournisseur
mp_ssim | Stock issue d'une simulation
mp_minfou | Minimum commande fournisseur
mp_abc | Classement A/B/C
mp_controle | Code contrôle de qualité
mp_reap | Code réapprovisionnement
mp_remp | Code produit de remplacement
lib_mp_remp | Libellé produit de remplacement
mp_foucli | Code fournisseur principal
mp_cli | Code client principal
mp_qteeco | Quantité économique de commande
mp_delmoy | Délai moyen d'approvisionnement
mp_ndm | Numéro dernier mouvement stock
mp_qualite | Code qualité
mp_afnor | Code normalisé
mp_libre | Zone libre
mp_dt1 | Donnée technique numérique 1
mp_dt2 | Donnée technique numérique 2
mp_dt3 | Donnée technique numérique 3
mp_dt4 | Donnée technique numérique 4
mp_dt5 | Donnée technique numérique 5
mp_dt6 | Donnée technique numérique 6
mp_dt7 | Donnée technique numérique 7
mp_dt8 | Donnée technique numérique 8
mp_at1 | Donnée technique alpha 1
mp_at2 | Donnée technique alpha 2
mp_affect | Numéro d'oF ou affectation
mp_cdc | Centre de coût
mp_coul | Code couleur
mp_rgt1 | Lieu de rangement niveau 1 de la fiche article
mp_rgt2 | Lieu de rangement niveau 2 de la fiche article
mp_rgt3 | Lieu de rangement niveau 3 de la fiche article
mp_qualite_matiere | Code qualité matière
mp_gencod | Code gencod
mp_itf14 | Code ITF14
mp_param_22 | zone mp_param[22]
mp_prod_generique lib_mp_prod_generique | Code article générique Désignation de l'article générique
mp_cs1, mp_cs2 mp_cs3, mp_cs4 | Codes statistique 1 à 4 de la fiche produit Ces zones peuvent être préfixées de libl_ et libc_ pour avoir les libellés long et court.

Article qualité carton de l'article du mouvement de stock

mp_qua_car_mp_code | Code de l'article
mp_qua_car_mp_des | Désignation de l'article
mp_qua_car_mp_fam | Code famille
libc_mp_qua_car_mp_fam | Libellé court de la famille
libl_mp_qua_car_mp_fam | Libellé long de la famille
mp_qua_car_mp_sfm | Code sous-famille
libc_mp_qua_car_mp_sfm | Libellé court de la sous-famille
libl_mp_qua_car_mp_sfm | Libellé long de la sous-famille
mp_qua_car_mp_lon | Longueur
mp_qua_car_mp_lar | Largeur
mp_qua_car_mp_hau | Hauteur
mp_qua_car_mp_poids | Poids

Article composition technique carton de l'article du mouvement de stock

mp_com_car_mp_code | Code de l'article
mp_com_car_mp_des | Désignation de l'article
mp_com_car_mp_fam | Code famille
libc_mp_com_car_mp_fam | Libellé court de la famille
libl_mp_com_car_mp_fam | Libellé long de la famille
mp_com_car_mp_sfm | Code sous-famille
libc_mp_com_car_mp_sfm | Libellé court de la sous-famille
libl_mp_com_car_mp_sfm | Libellé long de la sous-famille
mp_com_car_mp_lon | Longueur
mp_com_car_mp_lar | Largeur
mp_com_car_mp_hau | Hauteur
mp_com_car_mp_poids | Poids

Libellés de paramètres

libc_lc_p1 | Libellé court du paramètre saisi sur la zone lc_p1
libl_lc_p1 | Libellé long du paramètre saisi sur la zone lc_p1
libc_lc_p2 | Libellé court du paramètre saisi sur la zone lc_p2
libl_lc_p2 | Libellé long du paramètre saisi sur la zone lc_p2

Traçabilité (entête)

te_evenement | Code événement
te_date_heure date_te_date_heure heure_te_date_heure | Date et heure de l'événement idem te_date_heure mais au format date (sans heure donc pouvant accepter les usings de type date) idem te_date_heure mais sans la date (attention, c'est une chaîne de caractères sans using) Exemples Si te_date_heure donne 2010-09-29 19:54:35 date_te_date_heure avec format dd/mm/yyyy donnera 29/09/2010 date_te_date_heure avec format yyyymmdd donnera 20100929 heure_te_date_heure donnera toujours 19:54:35
te_login | Auteur de l'événement
te_transfere | Transféré (O/N)
te_type_par_lct | Type de paramètre de lancement du programme modifiant
te_code_par_lct | Code de paramètre de lancement du programme modifiant

Consommations matière

Toutes les zones de la table cde5 SAUF les zones suivantes :

uc_date_plus_tard Date de commande de matière première au plus tard

uc_longueur Longueur

uc_largeur Largeur

uc_hauteur Hauteur

uc_poids Poids

uc_tiers_liv Code du tiers livré

uc_tiers_liv_adr Adresse du tiers livré

AVEC les zones supplémentaires suivantes :

ville_uc_ada Ville de l'adresse d'envoi (libellé)

ville_uc_adf Ville de l'adresse de facturation (libellé)

Autres

using | Voir #VI
qte_ua | Quantité dans l'unité d'achat
format | Longueur x Largeur
poids_mvt_brut | Poids brut du mouvement de stock
poids_mvt_net | Poids net du mouvement de stock
surface_mvt_brut | Surface brute du mouvement de stock
surface_mvt_net | Surface nette du mouvement de stock
 | Ces 4 zones tiennent compte des différences entre les articles plaques cartonnier et les articles caisses. Pour les articles caisses, ces zones utilisent les TSC article suivants TSC 201 - Numérique 1 Poids brut unitaire TSC 201 - Numérique 2 Surface brute unitaire TSC 202 - Numérique 1 Poids net unitaire TSC 202 - Numérique 2 Surface nette unitaire
surface_mvt_reel | Surface réelle du mouvement de stock
poids_mvt | Poids du mouvement ( = Quantité du mouvement * Poids de l'article)
poids_plaque | Résultat du calcul en Kg = quantité en stock * longueur matière / 1000 (longueur en mm) * largeur matière / 1000 (largeur en mm ) * grammage matière / 1000 (grammage en g/m2)
surf_plaque | Résultat du calcul en m2 = quantité en stock * longueur matière / 1000 (longueur en mm ) * largeur matière / 1000 (largeur en mm )
poids_unitaire | Poids unitaire du mouvement ( = Zone libre / Quantité du mouvement)
qte_signee | Quantité du mouvement signée (<0 si une sortie)
nb_palette_rgt3 | Nombre de palettes. Uniquement si le lieu 3 correspond à la quantité par palette
inventaire | Quantité à l'inventaire
entree | Quantité mouvement en entrée
sortie | Quantité mouvement en sortie
sdisp_im | Stock disponible immédiatement (Physique - Réserve)
sdisp_im_r | Stock disponible immédiatement à la date du mouvement (Physique - Réserve)
sdisp_ter | Stock disponible à terme à une date donnée (Physique - Réserve + Commande)
stk_clifou | Code client du mouvement Si <> de 0 et code fournisseur = 0 ou Code fournisseur du mouvement Si <> de 0 et code client = 0 ou ?????? Si code client et code fournisseur <> de 0
stk_cdeclifou | Numéro commande client Si <> de 0 et numéro commande fournisseur = 0 ou numéro commande fournisseur Si <> de 0 et numéro commande client = 0 ou ???????? Si numéro commande client et numéro commande fournisseur <> de 0
der_pa | Dernier prix d'achat
valeur_mvt | Valeur du mouvement au prix du mouvement Quantité du mouvement * Prix du mouvement * Formule de conversion
valeur_mvt_signe | Idem valeur_mvt (< 0 si une sortie)
valeur_pamp | Valeur du mouvement au mode de valorisation de la fiche article
valeur_pa | Valeur du mouvement au prix d'achat article
valeur_pr | Valeur du mouvement au prix de revient article
valeur_pv | Valeur du mouvement au prix de vente article
valeur_der_pa | Valeur du mouvement au dernier prix d' achat article
valeur_cde_cli | Valeur du mouvement avec le prix de la commande Quantité du mouvement * Prix de la commande * Formule de conversion Attention Si la commande comporte plusieurs fois l'article, on prend le premier prix trouvé, même s'il est à zéro Si le mouvement de stock ne comporte pas de numéro de commande ou si la commande n'existe pas, on conserve le prix du mouvement.
valeur_cde_cli_coef5 | idem valeur_cde_cli avec multiplication par formule de conversion coef_conv(5) va chercher la formule dans les notes.
solde_client | Evolution du stock client à partir des mouvements Il vaut mieux avoir un tri par date croissant
solde_cli_phy | Différence entre le solde client et le stock physique
montant_cde | Valeur du mouvement s'il s'agit d'une entrée
bonus | Quantité du mouvement - quantité client
marge | Prix de vente - prix du mouvement
montant_marge | Marge * quantité client du mouvement * Formule de conversion
pourcent_marge | Prix de vente - prix du mouvement
montant_facture | Bonus * zone libre * Formule de conversion Cette zone n'est calculée que pour les sorties.
montant_facture2 | Quantité client du mouvement * zone libre * Formule de conversion Cette zone n'est calculée que pour les sorties.
qte_prevue | Cette zone est égale à la zone quantité client mais elle n'est calculée que pour les sorties
qte_prev | Cette zone est égale à la zone quantité client. Les cumuls sont signés et à la rencontre d'un inventaire, les cumuls sont remis à zéro.
qte_real | Cette zone est égale à la zone quantité mouvement. Les cumuls sont signes et a la rencontre d'un inventaire, les cumuls sont remis à zéro.
qte_ventil_1 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[50] du TMV est à O
qte_ventil_2 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[51] du TMV est à O
qte_ventil_3 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[52] du TMV est à O
qte_ventil_4 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[53] du TMV est à O
qte_ventil_5 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[54] du TMV est à O
qte_ventil_6 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[55] du TMV est à O
qte_ventil_7 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[56] du TMV est à O
qte_ventil_8 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[57] du TMV est à O
qte_ventil_9 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[58] du TMV est à O
qte_ventil_10 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[59] du TMV est à O
qte_ventil_11 | Contiendra la quantité du mouvement (s0_qte) si le flag alpha2[60] du TMV est à O
libc_s0_typ | Libellé court de s0_typ (TMV)
libl_s0_typ | Libellé long de s0_typ (TMV)
libc_s0_rgt1 | Libellé court de s0_rgt1 (RG1)
libl_s0_rgt1 | Libellé long de s0_rgt1 (RG1)
libc_mp_fam | Libellé court de mp_fam (FAM)
libl_mp_fam | Libellé long de mp_fam (FAM)
libc_mp_sfm | Libellé court de mp_sfm (SFM)
libl_mp_sfm | Libellé long de mp_sfm (SFM)
libc_mp_rgt1 | Libellé court de mp_rgt1 (RG1)
libl_mp_rgt1 | Libellé long de mp_rgt1 (RG1)
nom_s0_cli | Nom client du mouvement
nom_s0_fou | Nom fournisseur du mouvement
nom_mp_cli | Nom client principal
nom_mp_foucli | Nom fournisseur principal
lib_s0_cdc | Libellé centre de coût
lib_lf_cdc | Libellé centre de coût
lib_mp_cdc | Libellé centre de coût
nom_stk_clifou | Nom client Si code client <> de 0 et code fournisseur = 0 ou Nom fournisseur Si code fournisseur <> de 0 et code client = 0 ou blanc Si code client et code fournisseur <> de 0
lib_mp_afnor_art | Désignation code article AFNOR
lib_mp_afnor_ecma | Désignation code ECMA AFNOR
libc_mp_libre | Libellé court de mp_libre
libl_mp_libre | Libellé long de mp_libre
libc_mp_coul | Libellé court de mp_coul
libl_mp_coul | Libellé long de mp_coul
ref_produit, reffou_produit | Référence article pour le client, pour le fournisseur chez le client
lib_le_libelle, libfou_le_libelle | Libellé étranger 1 pour le client, pour le fournisseur chez le client
lib_le_libellé2, libfou_le_libelle2 | Libellé étranger 2 pour le client, pour le fournisseur chez le client
code_art_niv1 | Code de l'article niveau 1
lib_code_art_niv1 | Désignation de l'article niveau 1
code_art_niv2 | Code de l'article niveau 2
lib_code_art_niv2 | Désignation de l'article niveau 2
client_affect | Client du dossier d'affectation
nom_client_affect |
note | Première ligne de note de type [blanc] saisie sur le mouvement de stock
note1bis | Seconde partie (à partir du caractère 16) de la première ligne de note de type [blanc] du mouvement de stock
note2 | Deuxième ligne de note de type [blanc] saisie sur le mouvement de stock
lib_prod_ref | Libellé du produit (lf_lib) si la zone numéro de commande fournisseur est renseignée, (mp_des)sinon
code_prod_affect | Code produit correspondant à l'affectation
lib_prod_affect | Libellé du produit correspondant à l' affectation
nom_b1_cli | Nom client du bon de livraison
libc_b1_sitp | Libellé court de b1_sitp
libl_b1_sitp | Libellé long de b1_sitp
libc_b1_tport | Libellé court de b1_tport
libl_b1_tport | Libellé long de b1_tport
libc_b1_tvap | Libellé court de b1_tvap
libl_b1_tvap | Libellé long de b1_tvap
libc_b1_trsp | Libellé court de b1_trsp
libl_b1_trsp | Libellé long de b1_trsp
nom_b1_trans | Nom transporteur du bon de livraison
ville_b1_adrl | Ville adresse livraison du bon de livraison
dep_b1_adrl | Département adresse livraison du bon de livraison
ville_b1_adrf | Ville adresse facturation du bon de livraison
dep_b1_adrf | Département adresse facturation du bon de livraison
libc_b1_tvae | Libellé court de b1_tvae
libl_b1_tvae | Libellé long de b1_tvae
libc_b1_type_vehicule | Libellé court de b1_type_vehicule
libl_b1_type_vehicule | Libellé long de b1_type_vehicule
mp_lar_mm | Largeur * 10
mp_lon_mm | Longueur * 10
s0_qte_rame | Quantité mouvement / 500
s0_stkres_rame | Stock résultant / 500
valeur_cde_four | Valeur commande fournisseur
remise_cde_four | Valeur commande fournisseur - Valeur mouvement
premise_cde_four | Pourcentage remise_cde_four
stock_lot_today | Stock du lot du mouvement de stock à la date du jour du traitement
stock_lot_lieu_today | Stock du lot-lieu du mouvement de stock à la date du jour du traitement
tmv_code_operation | Code opération
lieu_stockage_hachette | SPECIFIQUE Code lieu de stockage
composant_hachette | SPECIFIQUE Code composant
unite_mesure_hachette | SPECIFIQUE Code unité de mesure
stock_resultant_hachette | SPECIFIQUE Solde du stock après événement
info_hachette | SPECIFIQUE Information complémentaire
date_time_std | Date + heure au format YYYY-MM-DD hh:mm:ss
flag_annulation | Valeur indiquant si l'article est annulé (1) ou non (0)
code_iso_pays_fou | Code ISO du pays du fournisseur
code_iso_devise | Code ISO de la devise
taux_dev_euro | Taux devise par rapport à l'euro
incoterm | Code INCOTERM
libc_ef_transport | Libellé court du transport
libl_ef_transport | Libellé long du transport
libc_ef_mrg | Libellé court du mode de règlement
libl_ef_mrg | Libellé long du mode de règlement
lf_lib_laize | Si famille du produit = PAP, alors la laize est concaténée au libellé
note_param | Permet de visualiser la première ligne de note saisie sur la ligne de commande Ligne de paramétrage : Le type de la note à afficher est défini dans la zone du format Exemple : D note_abf :*note_param*50*ABF*
b2_ligcad | Ligne de cadencement de livraison livrée
num_container_toshiba | Numéro palette d'expédition (s0_id_conteneur) si CAB sinon numéro palette (etp_num_palette)
num_palette_toshiba | Numéro de palette (etp_num_palette)
num_fournisseur_toshiba | Code fournisseur (cl_codef) du client livré (b1_cli)
fournisseur_toshiba | Nom fournisseur (cl_nom de #SOC) du client livré (b1_cli)
reference_toshiba | Référence Toshiba (le_libpar1) du produit livré (s0_prod)
qty_toshiba | Quantité de la palette (etp_nb_pf_pal)
lot_toshiba | Identifiant CAB de la palette (s0_id_conteneur) si CAB sinon numéro lot (s0_lot) de la commande
num_palette_toshiba_spec | SPECIFIQUE
mpeb_sdis | Stock disponible en équivalent boîte
mpeb_sphy | Stock physique en équivalent boîte
mpeb_sres | Stock réservé en équivalent boîte
mpeb_sbes | Stock besoin en équivalent boîte
mpeb_scdef | Stock en commande fournisseur et fabrication en équivalent boîte
ml_plancher_pf | Métrage linéaire correspondant à la quantité du mouvement
no_of_ent_sor_papier | Numéro d'OF des entrées et des sorties de consommation papier
qte_deja_conso | Quantité déjà consommée sur le mouvement de stock d'entrée
papier_prevu | Papier prévu du dossier de fabrication
des_papier_prevu | Désignation du papier prévu du dossier de fabrication
quantite_prevue | Quantité prévue du dossier de fabrication
largeur_prevue | Largeur prévue du dossier de fabrication
prix_1er_mvt_stock_lot | Prix du 1er mouvement de stock du lot du produit2
coefconv1 | Coefficient de conversion de la fiche matière
codp_b1_adrl | Code postal de livraison
reffou_qualite | Référence du produit chez le fournisseur de la matière première
qualite_le_libelle | Libellé étranger 1
qualite_le_libelle_2 | Libellé étranger 2
code_vt | Code article de version technique - voir aussi tri 37

Temps par type de machine du lot du mouvement de stock

où XXX = Type de machine

Nécessite l'option -Odt

TMC_XXX_TMC | Type de machine
TMC_XXX_LC | Libellé court du type de machine
TMC_XXX_LL | Libellé long du type de machine
TMC_XXX_SB | Surface brute du type de machine
TMC_XXX_TPP | Temps de préparation ou de calage prévu du type de machine
TMC_XXX_TRP | Temps de réalisation ou de roulage prévu du type de machine
TMC_XXX_TTP | Temps prévu du type de machine
TMC_XXX_TPR | Temps de préparation ou de calage réalisé du type de machine
TMC_XXX_TRR | Temps de réalisation ou de roulage réalisé du type de machine
TMC_XXX_TTR | Temps réalisé du type de machine

Zones de la qualité matière de l'article mouvementé

mp_qua_mat_mp_code | Code de la qualité matière de l'article mouvementé
mp_qua_mat_mp_des | Désignation de la qualité matière de l'article mouvementé
mp_qua_mat_mp_fam libc_mp_qua_mat_mp_fam libl_mp_qua_mat_mp_fam | Code famille de la qualité matière de l'article mouvementé Libellé court Libellé long
mp_qua_mat_mp_sfm libc_mp_qua_mat_mp_sfm libl_mp_qua_mat_mp_sfm | Code sous-famille de la qualité matière de l'article mouvementé Libellé court Libellé long
mp_qua_mat_mp_hau | Hauteur de la qualité matière de l'article mouvementé (peut être utilisée dans les formules de calcul)
mp_qua_mat_mp_lar | Largeur de la qualité matière de l'article mouvementé (peut être utilisée dans les formules de calcul)
mp_qua_mat_mp_lon | Longueur de la qualité matière de l'article mouvementé (peut être utilisée dans les formules de calcul)
mp_qua_mat_mp_poids | Poids de la qualité matière de l'article mouvementé (peut être utilisée dans les formules de calcul)


Edition des stocks par lot - lieu

Edition des stocks par lot - lieu edi_lot

VOL_1677 | #ED LIE Edition des lieux
 | VOL_1678
#ED VLL Edition des lots ou des lieux |

Options

-Oli | Edition uniquement des lieux. Supprimé le 01/09/1992
-Oll | Edition des lots ou des lieux. Supprimé le 01/09/1992

Valeur alpha 2

Caractères 1 à 30

Options d'édition accessibles par le menu
Valeurs par défaut ONOOOON

Caractère 1

Edition par lot (O/N/1/2)
O Lot
N Lieu
1 Lot/Lieu
2 Lieu/Lot

Caractère 2

Edition par lieu (O/N/1/2)
O Lieu
N Lot
1 Lieu/Lot
2 Lot/Lieu

Caractère 3

Edition des stocks = zéro (O/N)

Caractère 4

Edition des stocks < zéro (O/N)

Caractère 5

Edition des stocks > zéro (O/N)

Caractère 6

Edition par client (O/N)

Caractère 7

Edition par fournisseur (O/N)

Caractère 15

Client article au lieu client mouvement (O/N)

Caractère 16

Fournisseur. article au lieu fournisseur mouvement (O/N)

Caractères 31 à 40

Ordre de tri accessible par le menu tri
Valeurs par défaut 12354
Remarque Mettre 9 si pas de tri

Caractère 31

Ordre de tri de la famille (1 à 5 et 9)

Caractère 32

Ordre de tri de la sous famille (1 à 5 et 9)

Caractère 33

Ordre de tri du produit (1 à 5 et 9)

Caractère 34

Ordre de tri du lot ou lieu (1 à 5 et 9) ou lot / lieu ou lieu / lot

Caractère 35

Ordre de tri du client ou fournisseur (1 à 5 et 9)

Caractères 41 à 50

Ligne total accessible par le menu tri
Valeurs par défaut OOOOO

Caractère 41

Ligne total de la famille (O/N)

Caractère 42

Ligne total de la sous famille (O/N)

Caractère 43

Ligne total du produit (O/N)

Caractère 44

Ligne total du lot ou lieu (O/N/T/1/2/3/4)
T Autorisé si édition par lieux multi-niveaux
Edition de la ligne détail
Edition de tous les niveaux de totalisation
1 Autorisé si édition par lieux multi-niveaux
Edition de la ligne détail
Edition du dernier niveau de totalisation
2 Autorisé si édition par lieux multi-niveaux
Edition de la ligne détail
Edition des 2 derniers niveaux de totalisation
3 Autorisé si édition par lieux multi-niveaux et par lieux
Edition de la ligne détail
Edition du premier niveau de totalisation
Edition du dernier niveau de totalisation
Autorisé si édition par lieux multi-niveaux et par lots / lieux ou lieux / lots
Edition de la ligne détail
Edition des 3 derniers niveaux de totalisation
4 Autorisé si édition par lieux multi-niveaux et par lieux ou lots / lieux ou lieux / lots
Edition de la ligne détail
Edition du premier niveau de totalisation
Edition du dernier niveau de totalisation
O Si édition par lieux un seul niveau
Edition de la ligne détail
Edition du premier niveau de totalisation
Si édition par lieux multi-niveaux
Edition de la ligne détail
Edition du dernier niveau de totalisation
N Pas d'édition

Caractère 45

Ligne total du client ou fournisseur (O/N)

Caractères 51 à 60

Saut de page accessible par le menu tri
Valeurs par défaut NNNNN

Caractère 51

Saut de page de la famille (O/N)

Caractère 52

Saut de page de la sous famille (O/N)

Caractère 53

Saut de page du produit (O/N)

Caractère 54

Saut de page du lot ou lieu (O/N/T/1/2/3/4)
T Autorisé si édition par lieux multi-niveaux
Saut de page à chaque niveau de rupture
1 Autorisé si édition par lieux multi-niveaux
Saut de page au dernier niveau de rupture
2 Autorise si édition par lieux multi-niveaux
Saut de page aux 2 derniers niveaux de rupture
3 Autorise si édition par lieux multi-niveaux et par lieux
Saut de page au premier niveau de rupture
Saut de page au dernier niveau de rupture
Autorisé si édition par lieux multi-niveaux et par lots / lieux ou lieux / lots
Saut de page aux 3 derniers niveaux de rupture
4 Autorise si édition par lieux multi-niveaux et par lieux ou lots / lieux ou lieux / lots
Saut de page au premier niveau de rupture
Saut de page au dernier niveau de rupture
O Si édition par lieux un seul niveau
Saut de page au premier niveau de rupture
Si édition par lieux multi-niveaux
Saut de page au dernier niveau de rupture
N Pas de saut de page

Caractère 55

Saut de page du client ou fournisseur (O/N)

Valeur alpha 4

(avant le 01/09/92 les colonnes d'édition étaient en alpha2)

A | Numéro de lot
B | Lieu de rangement niveau 1 (RGT1)
C | Disponible unité d'utilisation
D | Réserve unité d'utilisation
E | En commande unité d'utilisation
F | Physique unité d'utilisation
G | Disponible unité d'achat
H | Réserve unité d'achat
I | En commande unité d'achat
J | Physique unité d'achat
K | Code coefficient de conversion U.U.--> U.A. (FOR)
L | Code famille
M | Libellé court famille
N | Libellé long famille
O | Code sous-famille
P | Libellé court sous famille
Q | Libellé long sous famille
R | Code produit
S | Désignation du produit
T | Code client
U | Nom du client
V | Code fournisseur
W | Nom du fournisseur
X | Lieu de rangement niveau 2 (RGT2)
Y | Lieu de rangement niveau 3 (RGT3)
Z | Code uniquement du lieu de rangement 1
a | Libellé court du lieu de rangement 1
b | Libellé long du lieu de rangement 1
c | Longueur
d | Largeur
e | Hauteur
f | Poids
g | Libellé article du LOT


Etat des alertes

Etat des alertes alerte

Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Noms de zones utilisables

Nouvelles fonctionnalités au 21/12/2011

Permettre de lancer l'édition des alertes en mode visualisation

Permettre de gérer les réapprovisionnements via le mode visualisation (touche F11)

Paramétrage

Option Ovi

A2[3]

A2[47] - A2[48] - A2[49] - A2[50,54]

Notes

ACCES_CDE_TYC_ / COMPTEUR_TYC / OPTION_CDE_TYC_ / PARAM_CDE_TYC_

CBAFBI / EDITION_AR_FBI / TYC_GENERATION_FBI

_SUP_REQ_MOD_ANN_EVT / _SUP_REQ_MOD_ANN_FB5

_SUP_REQ_STK_ENTPRE / _SUP_REQ_STK_LIVPRE / _SUP_REQ_STK_PRECLI

Notes spécifiques à la gestion des couleurs

Arguments d'appel à la visualisation des alertes

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_ART | Code article -N_ART[s0_prod]
-N_MAG | Lieu de rangement 1 -N_MAG[s0_rgt1]
-N_DAT | Date de début de période de calcul -N_DAT[s0_datm]

Valeurs numériques

1 | Nombre de jours à soustraire à la date du jour pour initialiser la date de calcul Par défaut : 0 (date du jour)
2 | Non utilisée

Options

Oas

Affichage du stock journalier même si tout est normal

Ocp

Déduction d'une consommation journalière prévisionnelle de l'article du stock disponible et indication sur l'état des alertes de cette déduction.

La note commençant par CONSO_PREV_ARTICLE est obligatoire

Ofp

Indication sur l'état des alertes qu'une fabrication prévisionnelle d'une ligne de commande FBI est bloquée par un code blocage.

La note commençant par FABRI_PREV_BLOCAGE est obligatoire

Omr

Alimentation automatique de la table des réapprovisionnements d'un article par dépôt externe (mat_reappro)

Remarque : Cette option est réservée à un usage interne (passage d'arguments). Elle ne peut pas être utilisée manuellement.

Voir la note GERER_DEPOT_EXTERNE.

Oqa

Quantité en unité d'achat pour le calcul du tarif utilisé lors de la génération de la commande d'achat

Voir les notes

CONFIG_TARIF_ACHAT

EDITION_CDE_ACHAT

FORMULE_CONV_TARIF

GENERATION_CDEF

SAISIE_CDE_ACHAT

_SITE_PROD_POUR_CDEF

TYF_GENERATION_ACH

Equivalent au paramétrage de génération des commandes d'achat sur v_mat.

Orv

Recalcule automatiquement les lignes de visualisation associées au produit en cours de sélection si une modification est détectée dans la gestion des réapprovisionnements

Permet, au retour de la gestion des réapprovisionnements, de recalculer automatiquement les lignes de visualisations correspondantes au produit courant.

Remarques :

• Les lignes associées au produit en cours de sélection sont recalculées si et seulement si une modification a été détectée dans l'écran de gestion des réapprovisionnements (accès à une FBI, génération d'une nouvelle FBI, modification d'une prévision client)

• L'action Rafraîchir (F9) permet toujours de recalculer entièrement la visualisation.

Osa

Affichage du stock affiche

Osr

Pas de mise à jour du stock résultant

Utilisée pour l'annulation / la création des mouvements de stocks Prévisions client.

Voir les notes

GR_STK_PRECLI_CLI

GR_STK_PRECLI_RGT1

GR_STK_PRECLI_RGT2

GR_STK_PRECLI_LOT

GR_TMV_STK_PRECLI

Les mouvements de stock sont modifiés comme suit :

Ancienne quantité = 0, Nouvelle quantité > 0
Création d'un mouvement de stock
Les informations du mouvement de stock sont récupérées sur le paramétrage (notes GR_STK_PRECLI_).

Ancienne quantité > 0, Nouvelle quantité = 0
Annulation des mouvements de stock existants

Ancienne quantité > 0, Nouvelle quantité > 0 et différente de l'ancienne quantité
Annulation des mouvements de stock existants
Création d'un mouvement de stock
Les informations du mouvement de stock sont récupérées sur le dernier mouvement annulé.

Ovi

Mode visualisation

Oxd

Cacher le cadre Détail des visualisations

Voir les notes commençant par D et LONGUEUR_MAX_DETAIL.

Valeur alpha 2

Caractère 1

Mise à jour de la fiche article (O/N, N par défaut)

Caractère 2

Lignes sans alerte (O/N, N par défaut)

Caractère 3

Règle de gestion des lieux de rangement des articles

N Prise en compte des règles spécifiques au couple article/lieux de rangement. Si aucune règle n'existe pour le couple, les seuils mini/maxi/alerte sont initialisés à zéro (par défaut)

O Prise en compte des règles spécifiques au couple article/lieux de rangement. Si aucune règle n'existe pour le couple, les seuils mini/maxi/alerte sont initialisés avec ceux de l'article

G Gestion en global. Les règles spécifiques au couple article/lieux de rangement sont ignorées. Important : Cette valeur est pour le moment la seule valeur possible pour la gestion des réapprovisionnements.

Caractère 4

Ouverture de l'écran de sélection du tri (O/N, O par défaut)

Caractère 5

Flag maximum (+ par défaut)

Caractère 6

Flag alerte (. par défaut)

Caractère 7

Flag sécurité (* par défaut)

Caractère 8

Flag rupture (# par défaut)

Caractère 9

Permettre les sélections multiples (O/N, O par défaut)

Caractère 10

Après la sortie de l'édition et/ou de la visualisation, retourner à l'écran de sélection en gardant les critères précédemment saisis (O/N, N par défaut)

Caractère 11

Numéro d'ordre du tri par gestionnaire(1 par défaut) Plus d'infos sur le tri

Caractère 12

Numéro d'ordre du tri par article(4 par défaut) Plus d'infos sur le tri

Caractère 13

Numéro d'ordre du tri par lieu de rangement (3 par défaut) Plus d'infos sur le tri

Caractère 14

Numéro d'ordre du tri par date de première alerte (2 par défaut) Plus d'infos sur le tri

Caractère 16

Saut de page par gestionnaire (O/N, N par défaut)

Caractère 17

Saut de page par article (O/N, N par défaut)

Caractère 18

Saut de page par lieu de rangement (O/N, N par défaut)

Caractère 19

Saut de page par date de première alerte (O/N, N par défaut)

Caractères 21,26

Date de calcul (au format jjmmaa)

Par défaut : Date du jour Nombre de jours paramétré en valeur numérique 1

Remarque : Si la date de calcul est renseignée via ce paramétrage, le nombre de jours paramétré en zone numérique 1 n'est pas utilisé.

Caractère 27

Type de calcul

T Toutes les alertes (par défaut)

N Les Nouvelles alertes

Caractères 28 à 33

Date édition (date jour par défaut) Format JJMMAA

Caractère 34

Type d'édition

P Stock physique (par défaut)

D Stock disponible

Caractères 35 à 36

Nombre de dates éditées (10 par défaut, 75 maximum) (Exemple 06)

Caractère 37

Edition flags / quantités

1 Edition des flags (par défaut)

2 Edition des quantités

3 Edition des flags, puis des quantités

4 Edition des quantités, puis des flags

Caractère 38

Numéro d'ordre du tri par famille (5 par défaut) Plus d'infos sur le tri

Caractère 39

Numéro d'ordre du tri par sous-famille (6 par défaut) Plus d'infos sur le tri

Caractère 40

Numéro d'ordre du tri par catégorie de produit (7 par défaut) Plus d'infos sur le tri

Caractère 41

Saut de page par famille (O/N, N par défaut)

Caractère 42

Saut de page par sous-famille (O/N, N par défaut)

Caractère 43

Saut de page par catégorie de produit (O/N, N par défaut)

Caractère 44

Edition des colonnes K, L, M, N, O sous la désignation longue de l'article (O/N, N par défaut)

Caractère 45

Numéro d'ordre du tri par code client de la fiche article (8 par défaut) Plus d'infos sur le tri

Caractère 46

Saut de page par code client de la fiche article (O/N, N par défaut)

Caractère 47

Prise en compte du calendrier client pour le mode visualisation des alertes

C Prise en compte du calendrier client (les jours non ouvrés ne sont pas affichés)

G Prise en compte du calendrier client (les jours non ouvrés sont affichés et grisés)

N Pas de prise en compte du calendrier client (par défaut)

Caractère 48

Demande de confirmation avant la génération d'une commande FBI (O/N, N par défaut)

Caractère 49

Demande de confirmation avant l'accès à la commande FBI générée (O/N, N par défaut)

Caractères 50 à 55

Code client par défaut pour les commandes FBI à générer

Si celui-ci n'est pas précisé, on utilise le code client associé à l'article.

Si aucun client n'est associé à l'article, on utilise le client société (#SOC).

Caractère 56

Afficher/Masquer les colonnes des dates sans événement

O Afficher les colonnes des dates sans événement (par défaut)

N Masquer les colonnes des dates sans événement

I L'action Masquer les dates sans événement (Control-M) n'est pas accessible.
Les colonnes des dates sans événements sont toujours affichées.

Valeur alpha 3

Titre de l'état des alertes

E T A T D E S A L E R T E S

Valeur alpha 4

Caractères 1 à 60

Paramétrage colonnes état des alertes (ADEFIJ par défaut)

A Code gestionnaire

B Libellé court gestionnaire

C Libellé long gestionnaire

D Code article

E Désignation article

F Code lieu de rangement

G Libellé court lieu de rangement

H Libellé long lieu de rangement

I Date alerte et / ou quantité alerte Voir A2[35,36] et A2[37]

J Première alerte après la date de la dernière alerte éditée

K Seuil d'alerte

L Seuil de sécurité

M Stock physique à la date d'édition de l'alerte

N Colonne Maximum (stock maximum)

O Stock Disponible à la date d'édition de l'alerte

P Raison sociale du client associé à l'article

Q Raison sociale du client associé à l'article (15 caractères)

R Désignation article (20 caractères)

S Quantité économique de lancement (sur le lieu si stock géré par lieu, sinon sur l'article)

T Affichage du format du produit (Longueur x Largeur)

U Affichage du libellé étranger

V Stock réserve

W Stock en commande

X Stock mini à commander

Y Code fournisseur

Z Délai

a Affichage de la zone 2 du libellé étranger

b Affichage zone le_libpar1 du lib_etr (réf. article client)

c Code famille

d Libellé court famille

e Libellé long famille

f Code sous-famille

g Libellé court sous-famille

h Libellé long sous-famille

i Code catégorie

j Libellé court catégorie

k Libellé long catégorie

l Code client

m Nom client

Notes

Voir aussi, sous ce tableau, les notes spécifiques à la gestion des couleurs pour la gestion des réapprovisionnements

Toutes les notes de configuration de saisie simplifiée de commande (#CF SSC) sont également paramétrables et prioritaires ici.

C1 - C2

3 à 60 Complément de sélection du calcul (C1 uniquement pour le batch)

E1 - E2

3 à 60 Complément de sélection de l'édition (E1 uniquement pour le batch)

Zones utilisables :

gest_cal Code gestionnaire

rgt1_cal Lieu de rangement

prod_cal Code article

date_cal Date de calcul (Début période)

fam_cal Code familles

fam_cal Code sous-famille

cat_cal Code catégorie

cli_cal Code client

ACCES_CDE_TYC_

15,17 Type des commandes à générer (commandes de fabrication ou commandes commerciales)

Doit correspondre au type de commande défini sur la note TYC_GENERATION_FBI ou TYC_GENERATION_CD2

21,26 Type et code paramètre de lancement de la saisie des commandes clients

CBAFBI

7,9 Recherche du code blocage automatique à positionner en saisie des lignes de commande, dans le cas où les FBI associées à la ligne de commande ont été modifiées, rendant leur actualisation automatique impossible.

Important : Une seule ligne de note possible.

CG

4,60 Complément de requête sur stk0

COMPTEUR_TYC

14,16 Type de commande (TYC) des commandes de fabrication à générer (doit correspondre au type de commande défini sur la note TYC_GENERATION_FBI)

21,22 Numéro de compteur

CONFIG_TARIF_ACHAT

21,26 Type et code paramètre de la configuration de recherche de tarif utilisée lors de la génération des commandes d'achat (#CF TAR).

La recherche de tarif fournisseur n'est pas exécutée si ce paramétrage n'est pas saisi.

Voir aussi l'option Oqa

CONSO_PREV_ARTICLE

21, 23 TSC de la consommation journalière prévisionnelle de l'article

Obligatoire. EX : CJP

24, 26 Type de mouvement de stock de livraison prévue

Le type de mouvement de stock est obligatoire et doit être une sortie réserve.

EX : LP

27, 27 Flag édité sur l'état des alertes pour indiquer qu'une consommation journalière prévisionnelle de l'article est déduite du stock disponible

Facultatif. Par défaut : astérisque. EX : C

D

3,60 Structure identique aux notes commençant par D dans les visualisations :

Les 9 champs suivants sont séparés par un astérisque et le dernier champ doit se terminer obligatoirement par un astérisque.

1) Le titre de la colonne

2) Le nom de colonne (voir la liste des noms de zones autorisés, dans les programmes concernés)

Plusieurs possibilités :

- Le nom du champ est indiqué en clair. Les zones disponibles sont les suivantes :

Les zones du package Articles / Matières / Produits

Les zones du package Tiers

Les zones spécifiques suivantes :

le_libpar1 : Référence client article

le_libelle : Libellé spécifique client 1

le_libelle2 : Libellé spécifique client 2

using : Using paramétré

- Le nom de la colonne commence par TSC_

- Le nom de la colonne commence par NTS_

3) La longueur de la colonne

4) using utilisé (zones numériques et les dates)

5) Non utilisable dans ce contexte

6) Non utilisable dans ce contexte

7) Non utilisé

8) Code langue du titre de la colonne. Ne fonctionne que si #CF ATL alpha1[18] = O.

9) Non utilisable dans ce contexte

Voir aussi la note LONGUEUR_MAX_DETAIL et l'option Oxd.

EDITION_AR_CD2

21,26 Type et code du paramètre de la réédition des AR des commandes commerciales CD2

Remarque : L'édition des AR est faite par la génération EDI.

Permet la réédition des AR des commandes commerciales CD2 après la modification de celle-ci via l'écran de gestion des réapprovisionnements.

EDITION_AR_FBI

21,26 Type et code paramètre de lancement de l'édition des accusés de réception des FBI

Obligatoire si gestion des nomenclatures multi-niveaux

EDITION_CDE_ACHAT

21,23 Type et code paramètre de lancement de l'édition des commandes d'achat

Si ce paramétrage est renseigné, l'édition de la commande d'achat s'ouvre une fois celle-ci créée (et après la saisie si celle-ci est paramétrée).

Voir aussi l'option Oqa

FABRI_PREV_BLOCAGE

21, 23 Type de mouvement de stock de fabrication prévisionnelle

Le type de mouvement de stock est obligatoire et doit être une entrée prévisionnelle

EX : FP

24, 26 Code blocage de la fabrication prévisionnelle

Obligatoire EX : FAB

27, 27 Flag édité sur l'état des alertes pour indiquer qu'une fabrication prévisionnelle d'une ligne de commande FBI est bloquée par un code blocage

Facultatif. R par défaut. EX : B

FORMULE_CONV_TARIF

21 Numéro de formule de conversion pour le tarif utilisé lors de la génération des commandes d'achat

Par défaut : 1

Voir aussi l'option Oqa

GENERATION_CDEF

21,26 Type et code paramètre de la génération des commandes d'achat

Ce paramétrage est obligatoire et doit lancer le programme gen_cdef.

Voir aussi l'option Oqa

GERER_DEPOT_EXTERNE

21 Gestion des dépôts externes

Voir l'option Omr.

N Non (par défaut)

M Oui, avec recalcul automatique des réapprovisionnements des dépôts externes

22 [inutilisé]

23,28 Type et code du paramètre de lancement de la visualisation des alertes utilisée pour le recalcul automatique des réapprovisionnements des dépôts externes.
Par défaut : Paramètre de lancement courant

Remarque : La visualisation utilisée pour le recalcul des réapprovisionnements des dépôts externes portera sur les codes magasins des dépôts externes.

ATTENTION : Si des compléments de sélection spécifiques sont saisis sur le paramètre de lancement courant, il sera peut-être nécessaire d'utiliser un autre paramètre de lancement (notamment si un complément porte sur le code magasin).

GERER_LIEU_RGT_2

Permet de désactiver la prise en compte du lieu de rangement 2

21 Gestion de l’emplacement (lieu de rangement 2) dans la rupture des lignes de visualisation (produit/magasin/emplacement) (O/N, O par défaut)

GR_CALENDRIER_REAP

21,29 Code calendrier utilisé pour le calcul de la date de réapprovisionnement (proposition d'une quantité dans la gestion des réapprovisionnements)

Par défaut : #SOC

La gestion des calendriers doit être activée (A2[47])

30 Type de calendrier

E Employé (par défaut)

G Générique

GR_CALENDRIER_VISU

21,29 Code calendrier utilisé pour afficher/cacher les jours non ouvrés dans la visualisation des alertes

Par défaut : #SOC

La gestion des calendriers doit être activée (A2[47])

30 Type de calendrier

E Employé (par défaut)

G Générique

GR_COULEUR_OFI_DBL

21,60 Couleur utilisée pour indiquer le fait que l'OF est supposé inutile à cause de réapprovisionnements lancés couvrant la totalité des besoins futurs pour au moins deux fois la quantité de réapprovisionnement

GR_COULEUR_OFI_SMAX

21,60 Couleur utilisée pour indiquer le fait que l'OF est supposé inutile à cause d'un dépassement de stock maximum

GR_COULEUR_RUPTURE

21,60 Couleur utilisée pour indiquer que la valeur du stock est en dessous du seuil de rupture

GR_COULEUR_STK_CLI

21,60 Couleur utilisée pour indiquer la date d'intégration du stock client

GR_OT_ACTIVER

21 Activation de la création des ordres de transport lorsque le magasin courant est réapprovisionné par un autre magasin (voir règles de gestion des stocks par lieux)

O Le réapprovisionnement passe systématiquement par une création d'ordre de transport

C Le réapprovisionnement passe au choix de l'utilisateur par une création d'ordre de transport ou par la génération d'une commande (fournisseur ou commerciale selon l'article)

N Le réapprovisionnement passe systématiquement par la génération d'une commande (fournisseur ou commerciale selon l'article) (par défaut)

GR_OT_TMV_ENTREE

21,23 Type de mouvement d'entrée prévisionnelle utilisé lors de la création d'un ordre de transport (doit correspondre à un paramètre de type TMV)

Entrée : Magasin courant --> Magasin de réapprovisionnement

GR_OT_TMV_SORTIE

21,23 Type de mouvement de sortie réserve utilisé lors de la création d'un ordre de transport

Sortie : Magasin de réapprovisionnement --> Magasin courant

GR_QTE_REAP_EXACTE

21 Réapprovisionnement à la quantité exacte (réapprovisionnement avec la quantité économique de commande) (O/N, N par défaut)

GR_STK_PRECLI_CLI

21, 26 Code client pour la création des mouvements de stock Prévisions client

Par défaut : Code client du produit en cours

GR_STK_PRECLI_RGT1

21, 23 Lieu de rangement 1 pour la création des mouvements de stock Prévisions client

Par défaut : Magasin en cours

GR_STK_PRECLI_RGT2

21, 26 Lieu de rangement 2 pour la création des mouvements de stock Prévisions client

Par défaut : Lieu de rangement 2 du produit en cours

GR_STK_PRECLI_LOT

21, 35 Numéro de lot pour la création des mouvements de stock Prévisions client

Pas de valeur par défaut

GR_TMV_STK_PRECLI

Type de mouvement de stock Prévisions client (doit correspondre à un paramètre de type TMV, paramétré comme étant une sortie réserve : TMV A1[1] = S et TMV A1[2] = R)

Ce paramétrage conditionne l'accès aux colonnes de la ligne Prévisions client de la gestion des réapprovisionnements.

GR_TSC_SEUILS

21,23 Code de l'information complémentaire (TSC) où est renseigné le seuil minimum sur l'article

Pas de valeur par défaut.

24 Zone TSC associé (seuil minimum)

Par défaut : C (ic_num1)

25,27 Code de l'information complémentaire (TSC) où est renseigné le seuil maximum sur l'article

Par défaut : Code TSC utilisé pour le seuil minimum (caractères 21 à 23)

28 Zone TSC associé (seuil maximum)

Par défaut : D (ic_num2)

29,31 Code de l'information complémentaire (TSC) où est renseigné le seuil d'alerte sur l'article

Par défaut : Code TSC utilisé pour le seuil minimum (caractères 21 à 23)

32 Zone TSC associé (seuil d'alerte)

Par défaut : E (ic_num3)

GR_TSC_STOCK_CLIENT

Prise en compte du stock client

Permet d'intégrer une quantité de stock client dans les stocks physique et disponible calculés dans la visualisation des alertes.

Ce stock client sera saisi dans une information complémentaire (TSC) sur l'article.

Remarques :

Le stock client est intégré aux stocks physique et disponible à la date saisie dans le TSC
(par défaut : au début de la période paramétrée).

La présence d'un stock client entraîne l'apparition d'une nouvelle ligne Dont stock client dans la gestion des réapprovisionnements.

21, 23 Code d'information complémentaire (TSC) où sera saisi le stock client ainsi que la date d'intégration

Pas de valeur par défaut, la présence de cette note entraîne la prise en compte du stock client.

24 Zone de saisie du stock client

C Zone numérique 1 (ic_num1) - Valeur par défaut

D Zone numérique 2 (ic_num2)

E Zone numérique 3 (ic_num3)

25 Zone de saisie de la date d'intégration du stock client

A Zone de date 1 (ic_date1) - Valeur par défaut

B Zone de date 2 (ic_date2)

INTEGRER_QTE_DEPOT

21 Intégration des quantités des propositions de réapprovisionnement des dépôts externes au stock disponible (O/N, O par défaut)

Remarque : La gestion des dépôts externes doit être activée.

Voir la note GERER_DEPOT_EXTERNE.

LONGUEUR_MAX_DETAIL

3,60 Longueur maximale du cadre Détail. Par défaut : 200

OPTION_CDE_TYC_

16,18 Type de commande (TYC) des commandes de fabrication à générer

Doit correspondre au type de commande défini sur la note TYC_GENERATION_FBI.

21,59 Liste des options de lancement de la saisie des commandes (par 2 caractères)
Options disponibles :

ny Numérotation annuelle des numéros de commande

sr Pas de mise à jour du stock résultant

r1 Le code représentant de l'entête de commande est initialisé avec celui du code adresse de réception

r2 Le code représentant de la ligne de commande est initialisé avec celui du code adresse de livraison

cr Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne (1 des 2 codes doit être saisi. Si les 2 sont saisis, ils doivent être différents)

c2 Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne (1 des 2 codes doit être saisi)

dl Prise en compte du délai labo dans le calcul de la date de fin de fabrication

dr Contrôle des délais de réapprovisionnements des accessoires

PARAM_CDE_TYC_

15,17 Type de commande (TYC) des commandes de fabrication à générer

Doit correspondre au type de commande défini sur la note TYC_GENERATION_FBI

21,23 Type de note d'historique de la revue de contrat

SAISIE_CDE_ACHAT

21,23 Type et code paramètre de lancement de la saisie des commandes d'achat

Si ce paramétrage est renseigné, la saisie de la commande générée s'ouvre une fois celle-ci créée.

Voir aussi l'option Oqa

_SITE_PROD_POUR_CDEF

21,23 Site de production par défaut pour les commandes d'achat à générer

Doit correspondre à un paramètre de type SIT. Tableau de bord du multisite

Voir aussi l'option Oqa

SSC_PARAM_CONFIG

21,26 Type et code du paramètre de configuration de saisie simplifiée de commande (génération des CD2 pour les produits synchrones).

Par défaut : #CF SSC

_SUP_REQ_ENSEMBLE

21,60 Complément de recherche de l'ensemble rattaché au produit fini en cours sur la table des articles (mat)

_SUP_REQ_MAT_CLIENT

21,60 Complément de sélection sur la table des articles utilisé lors de la recherche des codes articles associés à la référence client saisie dans l'écran de sélection

_SUP_REQ_MOD_ANN_EVT

21,60 Complément de sélection sur les tables fabrication (fab0) et événements atelier (evt), permettant de vérifier l'interdiction d'annulation d'une commande de fabrication (FBI)

Ce paramétrage correspond au paramétrage existant sur la saisie des commandes.

_SUP_REQ_MOD_ANN_FB5

21,60 Complément de sélection sur les tables fabrication (fab0) et remontées automatiques des temps (fab5), permettant de vérifier l'interdiction d'annulation d'une commande de fabrication (FBI)

Ce paramétrage correspond au paramétrage existant sur la saisie des commandes.

_SUP_REQ_OT_CDE2

21,60 Complément de sélection utilisée pour la recherche de la ligne de commande associée aux ordres de transport (produit non appairé)

Tables concernées

cde1 Entête de commande

cde2 Lignes de commande

Informations utilisées dans la recherche

lc_prod Code produit courant

lc_lieu_rgt1 Magasin courant

ec_c1 Magasin de réapprovisionnement

_SUP_REQ_OT_CDE4

21,60 Complément de sélection utilisée pour la recherche de la ligne de nomenclature de commande associée aux ordres de transport (produit appairé)

Tables concernées

cde1 Entête de commande

cde2 Lignes de commande

cde4 Lignes de nomenclature de commande

Informations utilisées dans la recherche

nc_prod Code produit courant

lc_lieu_rgt1 Magasin courant

ec_c1 Magasin de réapprovisionnement

_SUP_REQ_STK

21,60 Complément de sélection sur la table stk0 pour la recherche des stocks

_SUP_REQ_STK_AVEPRE

21,60 Complément de sélection sur la table stk0 pour afficher le message d'avertissement de présence de stocks antérieurs à la première date affichée

Remarques

• La présence de ce complément de sélection conditionne le contrôle de présence de mouvements de stocks antérieurs à la première date affichée

• Le mot-clé %MAG% peut être utilisé et sera remplacé à l'exécution par le code magasin associé à la ligne de visualisation courante.

_SUP_REQ_STK_ENTPRE

21,60 Complément de sélection sur la table stk0 pour calculer les quantités de la ligne Entrées prévues de la gestion des réapprovisionnements.

Important

Le mot-clé %MAG% sera remplacé automatiquement à l'exécution par le lieu de rangement en cours.

Exemple

and s0_rgt1 = "%MAG%"

_SUP_REQ_STK_LIVREA

21,60 Complément de sélection sur la table stk0 pour calculer le stock client (livraisons réalisées)

Remarques

• Ce complément de sélection n'est pris en compte que pour le type d'édition Stock Client.

• Les quantités de ces mouvements de stock seront ajoutées au stock client.

Important

Le mot-clé %MAG% sera remplacé automatiquement à l'exécution par le lieu de rangement en cours.

Exemple

and s0_rgt1 = "%MAG%"

Voir le paragraphe Alertes de réapprovisionnement sur le stock client plus bas.

_SUP_REQ_STK_LIVPRE

21,60 Complément de sélection sur la table stk0 pour calculer les quantités de la ligne Livraisons prévues (Commandes fermes) de la gestion des réapprovisionnements

Important

Le mot-clé %MAG% sera remplacé automatiquement à l'exécution par le lieu de rangement en cours.

Exemple

and s0_rgt1 = "%MAG%"

Voir le paragraphe Alertes de réapprovisionnement sur le stock client plus bas.

_SUP_REQ_STK_PRECLI

21,60 Complément de sélection sur la table stk0 pour calculer les quantités de la ligne Prévisions client de la gestion des réapprovisionnements

Important

Le mot-clé %MAG% sera remplacé automatiquement à l'exécution par le lieu de rangement en cours.

Exemple

and s0_rgt1 = "%MAG%"

Voir le paragraphe Alertes de réapprovisionnement sur le stock client plus bas.

_SUP_REQ_STK_STKPRE

21,60 Complément de sélection sur la table stk0 pour calculer le stock prévisionnel (disponible)

Important

Le mot-clé %MAG% sera remplacé automatiquement à l'exécution par le lieu de rangement en cours.

Exemple

and s0_rgt1 = "%MAG%"

Voir le paragraphe Alertes de réapprovisionnement sur le stock client plus bas.

TYC_ASSOCIE_OT

21,60 Type de la commande associée aux ordres de transport

Exemple : CDA

TYC_GENERATION_CD2

21,23 Type des commandes commerciales à générer (produits synchrones)

Par défaut : CD2

TYC_GENERATION_FBI

21,23 Type des commandes de fabrication à générer (produits asynchrones)

Par défaut : FBI

TYF_GENERATION_ACH

21,23 Type de commande d'achat à visualiser dans la gestion des réapprovisionnements (Ligne Entrées prévues)

Doit correspondre à un paramètre de type TYF.

Ce paramétrage active la gestion de la génération des commandes d'achat pour les articles achetés.

Voir aussi l'option Oqa

Alertes de réapprovisionnement sur le stock client

Permettre d'afficher la visualisation des alertes selon le stock client.

Ce fonctionnement s'appuie sur un nouveau type d'édition Stock Client.

Remarques

• Ce type d'édition s'ajoute aux types actuels : Stock Disponible et Stock Physique.

• Ce type d'édition nécessite obligatoirement le paramétrage du TSC contenant le stock client (note GR_TSC_STOCK_CLIENT).

• Les articles pour lesquels le TSC de stock client n'existe pas (ou la quantité n'est pas renseignée) ne sont pas pris en compte pour ce nouveau type d'édition.

• Le stock client est calculé comme suit :

[Stock client de base] – [Prévisions client] + [Livraisons prévues] + [Livraisons réalisées] avec :

[Stock client de base] : Stock client de base saisi dans le TSC paramétré (voir ci-dessus)

[Prévisions client] : Stock calculé à partir du complément _SUP_REQ_STK_PRECLI

[Livraisons prévues] : Stock calculé à partir du complément _SUP_REQ_STK_LIVPRE

[Livraisons réalisées] : Stock calculé à partir du complément _SUP_REQ_STK_LIVREA

ATTENTION

Cette nouvelle fonctionnalité entraîne une modification du paramétrage actuel pour les visualisations des alertes utilisant le TSC du stock client (voir ci-dessus).

Le complément de sélection principal (note commençant par CG) doit en effet prendre en compte les mouvements de stock client (prévisions client, livraisons prévues et réalisées).

Le calcul du stock disponible utilisera quant à lui la nouvelle note _SUP_REQ_STK_STKPRE (afin d'enlever les livraisons prévues, par exemple).

Exemple

Les lignes suivantes :

CG and s0_typ not in ("LP")

CG and s0_rgt2[1,2] not in ("NC")

deviendront :

_SUP_REQ_STK_STKPRE and s0_typ not in ("LP")

CG and s0_rgt2[1,2] not in ("NC")

Notes spécifiques à la gestion des couleurs pour la gestion des réapprovisionnements

Les lignes de paramétrages suivantes ne sont valables qu'à partir de la version 2.30 de Genero.

Celles-ci permettent de paramétrer les couleurs utilisées dans la fenêtre de gestion des réapprovisionnements.

Les couleurs peuvent soit être paramétrées avec leur code (red, orange, darkblue, etc.), soit par leur valeur hexadécimale précédée par le caractère # (#FF6666, #FFCC33, #00008B, etc.).

Exemple de site Internet permettant de construire ces codes hexadécimaux : http://www.jokconcept.net/codes-couleurs-hexdecimal.php

Par défaut, la couleur concerne la police de caractère.

Pour modifier la couleur du fond, faire suivre le code couleur par un espace suivi du mot-clé reverse.

Paramétrage des couleurs pour l'état du stock (Partie droite : Valeurs liées aux colonnes de dates)

GR_COULEUR_SECURITE | 21,60 Couleur utilisée pour indiquer que la valeur du stock est en dessous du seuil de sécurité
GR_COULEUR_ALERTE | 21,60 Couleur utilisée pour indiquer que la valeur du stock est en dessous du seuil d'alerte
GR_COULEUR_STOCK | 21,60 Couleur utilisée pour indiquer que la valeur du stock est suffisante
GR_COULEUR_DETAIL_D | 21,60 Couleur utilisée pour les lignes concernant le détail des mouvements de stocks ayant conduit à l'état actuel

Paramétrage des couleurs pour l'état du stock (Partie gauche : titres des lignes)

GR_COULEUR_ACTUEL | 21,60 Couleur utilisée pour les lignes concernant l'état actuel
GR_COULEUR_DETAIL_G | 21,60 Couleur utilisée pour les lignes concernant le détail des mouvements de stocks ayant conduit à l'état actuel
GR_COULEUR_PROPOSE | 21,60 Couleur utilisée pour les lignes concernant la proposition de réapprovisionnement
GR_COULEUR_FORCAGE | 21,60 Couleur utilisée pour les lignes concernant le forçage

Paramétrage des couleurs pour l'état des commandes de fabrication (FBI)

Remarque : La présence de ces couleurs indique que la commande de fabrication ne peut pas être annulée.

GR_COULEUR_FBI_STK | 21,60 Couleur utilisée pour indiquer que la commande de fabrication est lancée en fabrication
GR_COULEUR_FBI_PLAN | 21,60 Couleur utilisée pour indiquer que la commande de fabrication est planifiée
GR_COULEUR_FBI_EVT | 21,60 Couleur utilisée pour indiquer que des événements d'atelier sont saisis sur la commande de fabrication
GR_COULEUR_FBI_TPS | 21,60 Couleur utilisée pour indiquer que des temps sont saisis sur la commande de fabrication
GR_COULEUR_FBI_MAT | 21,60 Couleur utilisée pour indiquer que des matières sont saisies sur la commande de fabrication
GR_COULEUR_FBI_STR | 21,60 Couleur utilisée pour indiquer que des sous-traitances sont saisies sur la commande de fabrication

Exemple de paramétrage

C2 and mp_reap = "A"

C2 and mp_qualite in ("FNV","FAB","FMO")

E2 and rgt1_cal not in (select p2_code from par02 where

E2 p2_type ="RG1" and p2_anul="O")

E2 and rgt1_cal != "USI"

_SUP_REQ_STK_LIVPRE and s0_typ = "LCL"

_SUP_REQ_STK_PRECLI and s0_typ = "LP"

_SUP_REQ_STK_ENTPRE and s0_typ in ("FR", "FP")

# Codes couleurs pour les FBI

GR_COULEUR_SECURITE red

GR_COULEUR_ALERTE orange

GR_COULEUR_STOCK green

GR_COULEUR_DETAIL_G blue

GR_COULEUR_DETAIL_D blue

GR_COULEUR_ACTUEL green

GR_COULEUR_PROPOSE red

GR_COULEUR_FORCAGE black

# Génération des commandes de fabrication (FBI)

ACCES_CDE_TYC_FBI #SAFBI

COMPTEUR_TYC_FBI

OPTION_CDE_TYC_FBI dldrmdaf

PARAM_CDE_TYC_FBI RCH

EDITION_AR_FBI #EDFBI

Noms des zones utilisables en mode visualisation

Toutes les zones du package Articles / Matières / Produits

Toutes les zones du package Tiers

Autres zones

le_libpar1 Référence client de l'article

le_libelle Libellé spécifique client 1 de l'article

le_libelle2 Libellé spécifique client 2 de l'article

using

TSC_ Récupération d'un TSC

NTS_ Récupération d'une ligne de notes


La colonne stk_phy donne le stock physique. Cette colonne se calcule en 2 phases :

1. Calcul de la valeur initiale (stock physique à la date saisie de début de période)

2. Mise à jour de la valeur en fonction des mouvements pris en compte par la visualisation

Problème : La première phase ne tient pas compte du complément de sélection paramétré dans les lignes de note du paramètre de lancement, alors que la seconde phase le prend en compte.

Ceci nous donne des valeurs différentes en fonction de la date de début de période saisie.

Pour corriger cela, la première phase prend maintenant en compte le complément de requête paramétré, mais on a aussi mis en œuvre une option permettant de faire le calcul du stock physique sans tenir compte de ce complément de requête.

En supplément, nous avons remarqué que si l’utilisateur sélectionne un article seul, alors le programme se limite au lieu de rangement saisi dans la fiche matière associée. Nous avons donc mis une autre option permettant de désactiver ce fonctionnement.

v_prostk Visualisation des profils de stock

Ce programme permet aussi de générer une commande en saisissant un minimum d'information.

Le paramétrage à mettre en oeuvre est repéré par la mention Génér.cde :

Dans ce programme, 4 notes commençant par SSC et 3 nouvelles zones

Paramétrage également dans v_edi_cde et dans #CF SSC (voir ce chapitre pour un récapitulatif de tout le paramétrage).

Cette nouveauté est également disponible dans v_mat.

Valeurs alpha Notes Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[mp_code]

Valeur numérique 1

Nombre de jours à soustraire à la date du jour pour initialiser la date de recherche.

Options

Oae

Inhibe la gestion de l'exclusion des états du stock

Oar

Affichage des retards (mouvements non physiques antérieurs à la date de début de période)

Le profil des stocks montre l'évolution à venir du stock à partir d'une certaine date saisie.

Au premier mouvement de stock affiché, il y a un calcul des différentes quantités en stock (physique, disponible, prévu et réserve) ; mais cela ne permet pas de « voir » les retards, c'est-à-dire les mouvements non physiques datés d'avant la date demandée (si les délais demandés avaient été respectés, ces mouvements seraient annulés et transformés en mouvements normaux).

On ajoute donc une nouvelle option permettant de visualiser ces mouvements bien que leur date soit antérieure à la date saisie.

Odf

Rend la saisie de la date de début de période facultative

Osl

Désactive l'initialisation automatique du lieu de rangement avec celui de la fiche matière dans le cas d'une sélection sur un article unique

Explications

Oss

Spécifie que le calcul de la colonne stk_phy se fera sans tenir compte du complément de sélection paramétré dans les lignes de note commençant par S.

Attention : L'utilisation de cette option augmente les temps de calcul de la visualisation.

Voir les explications dans l'option Osl ci-dessus.

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (N)
Caractère 14 | Edition en condensé (O/N, O par défaut)
Caractère 31 | Flag Alerte (. par défaut)
Caractère 32 | Flag Sécurité (* par défaut)
Caractère 33 | Flag Rupture (# par défaut)
Caractère 34 | Pas de règle de gestion article (N par défaut)
Caractère 35 | Initialisation du lieu de rangement lors de la sélection avec le lieu par défaut de la fiche article N Dans tous les cas (par défaut) O Uniquement s'il existe au moins une règle de gestion de stock par lieu
Caractère 36 | Flag maximum (+ par défaut)
Caractères 41 à 46 | Type et code du paramètre pour le lancement de la visu des commandes
Caractère 47 | Demande de confirmation de la génération de la FBI (O/N, N par défaut)
Caractère 48 | Accès à la commande après sa génération (O/N, N par défaut)
Caractères 49 à 54 | Client par défaut pour la génération de la commande Si renseigné, il est utilisé. Sinon, on prend celui de la fiche article. Si ce dernier est vide, on prend #SOC.

Valeur alpha 3

Titre de la visualisation : PROFIL DE STOCK

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 8 | Touche F8 (O/N) Visualisation détail article
Caractère 9 | Touche F9 (O/N) Visualisation mouvement de stock
Caractère 14 | Touche F14 (O/N) Visualisation inventaire par lots et/ou par lieux
Caractère 18 | Touche F18 (O/N) Consultation des stocks par G_consult_stock
Caractère 37 | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]
Caractère 38 | Touche CONTROL-C (O/N)
Caractère 46 | Touche CONTROL-N (O/N)
Caractère 51 | Touche CONTROL-T (O/N)
Caractère 56 | Touche CONTROL-Z (O/N)

Notes triées

ACCES_CDE_TYC_

Paramètre de lancement de cde

15 à 17 Type de commande

21 à 26 Type et code du paramètre de lancement du programme de création de commande

Exemple ACCES_CDE_TYC_FBI #SAFBI

Sur le programme cde, il faut définir le contrôle du code blocage (note CBACON)

ACCES_CONSULT_STOCK

21 à 26 Type et code du paramètre de lancement du programme G_consult_stock

ACCES_VISU_STOCKS

21,26 Type et code du paramètre de lancement de la visu de stocks

CBAFBI

Recherche du code blocage automatique à positionner en saisie de lignes de commande, dans le cas ou les FBI associées à la ligne de commande ont été modifiées, rendant leur actualisation automatique impossible.

On doit avoir une seule ligne de note.

7 à 9 Code blocage.

COMPTEUR_TYC_

Paramètres de compteur de cde

14 à 16 Type de commande

21à 22 Compteur

EDITION_AR_FBI

21, 26 Type de paramètre de lancement de l'édition des AR de FBI

EXCLUS_AFF_ES_ETAT

Pouvoir exclure certains mouvements de stocks de l'affichage, mais en en tenant compte dans le cumul

21 à 22 Code s0_es, suivi du code s0_etat

Exemple

_EXCLUS_AFF_ES_ETAT SN

n'affichera pas les mouvements de sortie normale

(s0_es = S et s0_etat = N)

Pour que le cumul soit correct, il faut paramétrer aussi une totalisation.

Si on veut visualiser le stock disponible, il faut mettre une totalisation sur celui-ci afin de bien prendre en compte tous les mouvements, même ceux qui sont exclus.

LISTE_TSC_STK_LAIZE

Spécifique pour les onduleurs avec gestion des bobines

Liste des codes TSC utilisés pour stocker les valeurs minimum de stock par laize

Les valeurs de stock minimum sont recherchées dans des TSC

TSC XXX : Stock laize

La zone numérique 1 permet de stocker la laize bobine.

La zone numérique 2 permet de stocker la valeur minimum de stock.

Voir aussi le tri 05 et la zone stock_laize

OPTION_CDE_TYC_

Options de lancement de cde

16 à 18 Type de commande

21 à 60 Options de lancement pour saisie des commandes type FBI. Options disponibles :

ny Numérotation annuelle des commandes

sr Pas de maj du stock résultant

r1 Le code représentant de l'entête de commande est initialisé avec celui du code adresse de réception

r2 Le code représentant de la ligne de commande est initialisé avec celui du code adresse de livraison

cr Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne

Un des deux codes doit être saisi. Si les deux sont saisis, ils doivent être différents.

c2 Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne.

Un des deux codes doit être saisi.

dl Prise en compte du délai labo dans le calcul de la date de fin de fabrication - fonction f_caldates()

dr Contrôle des délais de réappro des accessoires - fonction f_caldates()

PARAM_CDE_TYC_

Paramètres de lancement de cde

15 à 17 Type de commande

21 à 23 Type de note historique de la revue de contrat.

RESTRIC_STOCK_NUM_

Possibilité de visualiser, d'éditer ou d'extraire différents stocks physiques de l'article

Pour chaque calcul de stock physique, un complément de requête peut être paramétré.

19,20 Numéro permettant de créer plusieurs restrictions différentes

21,60 Complément de requête sur la table stk0

Exemple

RESTRIC_STOCK_NUM_01 and s0_rgt2[1,3] = "VEN"

Complément de requête utilisé par la colonne stock_physique_pf_01

SSC_PARAM_CONFIG

21,26 Type et code du paramètre de configuration de saisie simplifiée de commande (par défaut : #CFSSC) - Génér.cde

SSC_COMPTEUR_EDC_REF

21,29 Code racine du compteur alphanumérique (type N) -Génér.cde

Cette note a priorité sur celle du #CF SSC.

SSC_PARAM_EDI_CDE

21,26 Type et code du paramètre de lancement de la visualisation des commandes EDI - Génér.cde

Cette note a priorité sur celle du #CF SSC.

SSC_PARAM_RECH_TAR

21,26 Type et code du paramètre de configuration de recherche de tarif - Génér.cde

Cette note a priorité sur celle du #CF SSC.

_SUP_REQ_MAT_CLIENT

21,60 Complément de select sur mat

SUP_REQ_RG1_SITE_USE

21 Limiter le traitement aux lieux de rangement du site de l'utilisateur (O/N, N par défaut)

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF STK.

Tableau de bord du multisite

_SUP_REQ_STK0

21,60 Complément de requête sur stk0 :Par ex. : and s0_rgt2 not matches 'PRI*'

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage

TYC_GENERATION_FBI

Type de commande (TYC) des commandes de fabrication à générer

Par défaut : FBI

Ordres de tris disponibles

(Notes commençant par O)

O

2,3 Définition de l'ordre de tri

01 Code article

02 Lieu de rangement

03 Date de mouvement

04 Code client

05 Tri par lieu de rangement 2

Spécifique pour les onduleurs avec gestion des bobines :Tri par laize bobine

4,60 Paramétrage séparé par des astérisques

Numéro de priorité pour le tri (de 1 à 5)

Titre du tri à afficher dans la fenêtre de sélection de l'ordre de tri

Ligne de rupture pour ce tri (O/N)

Saut de page pour ce tri (O/N)

Listes des noms de zones autorisés

Package mat : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Package cde1

Package cd2

stk0

stk_rg

Libellés pour les tables stk0, mat et stk_rg

Autres libellés

blv1

blv2

Valeurs calculées

Autres zones

Table stk0

Les libellés figurent dans un tableau séparé, plus bas.

s0_soc | Code de la société
s0_prod | Code de l'article
s0_num | Numéro de mouvement de stock
s0_datm | Date de mouvement de stock
s0_typ | Type de mouvement de stock
s0_es | E/S/V (Entrée /Sortie /Valeur)
s0_cli | Code client du mouvement
s0_fou | Code fournisseur du mouvement
s0_cde | Numéro commande client
s0_cdefou | Numéro commande fournisseur
s0_prix | Prix unitaire
s0_frais | Frais - Port
s0_affect | Numéro d'oF ou affectation
s0_cdc | Centre de coût
s0_etat | Etat du mouvement (R/C/N)
s0_qte | Quantité mouvement
s0_stkres | Stock résultant
s0_lot | Numéro de lot
s0_rgt1 | Lieu de rangement niveau 1
s0_rgt2 | Lieu de rangement niveau 2
s0_rgt3 | Lieu de rangement niveau 3
s0_integre | Ligne intégrée en P.R. (O/N)
s0_ligcde | Ligne de commande client
s0_ligcad | Ligne de cadencement
s0_brc | Numéro de bon de réception
s0_anu | Annulé (O/N)
s0_lot_indus | Numéro de lot industriel
s0_date_deb | Date de début pour le lot industriel
s0_heure_deb | Heure de début pour le lot industriel L'heure est considérée comme une zone numérique, le point indiqué dans le format sera automatiquement remplacé par h (heure) Exemple : Si le format est &&.&&, la valeur 05.41 sera remplacée par 05h41 dans la visualisation
s0_date_fin | Date de fin pour le lot industriel
s0_heure_fin | Heure de fin pour le lot industriel Pour le format, voir la remarque sur la zone s0_heure_deb ci-dessus.
s0_ssf libc_s0_ssf libl_s0_ssf | Code statut du produit semi-fini Libellé court Libellé long)
s0_site_prod libc_s0_site_prod libl_s0_site_prod | Code site de production Libellé court Libellé long

Table stk_rg

Les libellés figurent dans un tableau séparé, plus bas.

sr_rgt1 | Lieu
sr_smaxi | Stock maxi
sr_smini | Stock mini (sécurité)
sr_alerte | Seuil d'alerte
sr_gestionnaire | Code gestionnaire
sr_reap | Mode de réapprovisionnement
sr_qteeco | Quantité de réapprovisionnement
sr_rgt1_tr | Lieu de réapprovisionnement niveau 1
sr_rgt2_tr | Lieu de réapprovisionnement niveau 2
sr_rgt3_tr | Lieu de réapprovisionnement niveau 3
sr_smaxi | Stock maximum sur stock

Libellés pour les tables stk0, mat et stk_rg

libc_s0_typ | Libellé court type mouvement
libl_s0_typ | Libellé long type mouvement
nom_s0_cli | Nom client
nom_s0_fou | Nom fournisseur
lib_s0_cdc | Libellé centre de coût
libc_s0_rgt1 | Libellé court lieu rangement
libl_s0_rgt1 | Libellé long lieu rangement
libc_sr_rgt1 | Libellé court lieu rangement
libl_sr_rgt1 | Libellé long lieu rangement
libc_sr_gestionnaire | Libellé court de mp_gestionnaire
libl_sr_gestionnaire | Libellé long de mp_gestionnaire
libc_sr_reap | Libellé court de sr_reap
libl_sr_reap | Libellé long de sr_reap
libc_sr_rgt1_tr | Libellé court lieu rangement
libl_sr_rgt1_tr | Libellé long lieu rangement
libc_stk_rgt1 | Libellé court lieu rangement
libl_stk_rgt1 | Libellé long lieu rangement
libc_stk_gestionnaire | Libellé court de mp_gestionnaire
libl_stk_gestionnaire | Libellé long de mp_gestionnaire
libc_stk_reap | Libellé court de sr_reap
libl_stk_reap | Libellé long de sr_reap
nom_stk_clifou | Nom client Si code client <> de 0 et code fournisseur = 0 ou Nom fournisseur Si code fournisseur <> de 0 et code client = 0 ou blanc Si code client et code fournisseur <> de 0

Autres libellés

lib_le_libelle | Libellés étrangers du client du mouvement de stock
lib_le_libelle2 | Libellés étrangers du client du mouvement de stock
lib_le_reference | Libellés étrangers du client du mouvement de stock
lib_mpcli_le_libelle | Libellés étrangers du client de la fiche produit
lib_mpcli_le_libelle2 | Libellés étrangers du client de la fiche produit
lib_mpcli_le_reference | Libellés étrangers du client de la fiche produit

Table blv1

avec ses propres libellés

b1_soc | Code société
b1_blv | Numéro de bon de livraison
b1_cli | Code client
nom_b1_cli | Nom client
b1_ref | Référence du bon de livraison
b1_sitp | Code site de production
libc_b1_sitp | Libellé court site de production
libl_b1_sitp | Libellé long site de production
b1_tport | Type de port
libc_b1_tport | Libellé court type de port
libl_b1_tport | Libellé long type de port
b1_pht | Port taxable en devise société
b1_pht_euro | Port taxable en EURO
b1_pht_dev | Port taxable en devise
b1_tvap | Code TVA port taxable
libc_b1_tvap | Libellé court TVA port taxable
libl_b1_tvap | Libellé long TVA port taxable
zc1_b1_tvap | Valeur 1 code TVA port taxable
b1_trsp | Mode de transport
libc_b1_trsp | Libellé court mode de transport
libl_b1_trsp | Libellé long mode de transport
b1_trans | Code transporteur
nom_b1_trans | Nom transporteur
b1_tadr | Type d'adresse de livraison
b1_adrl | Code adresse livraison
nom_b1_adrl | Nom client de livraison
adr1_b1_adrl | Adresse 1 de livraison
adr2_b1_adrl | Adresse 2 de livraison
codp_b1_adrl | Code postal de livraison
telph1_b1_adrl | Téléphone 1 de livraison
telph2_b1_adrl | Téléphone 2 de livraison
telcop_b1_adrl | Télécopie de livraison
telex_b1_adrl | Télex de livraison
pays_b1_adrl | Code pays de livraison
libc_pays_b1_adrl | Libellé court pays de livraison
libl_pays_b1_adrl | Libellé long pays de livraison
copd_b1_adrl | Code postal adresse de livraison
ville_b1_adrl | Ville adresse livraison
b1_datl | Date bon de livraison
b1_adrf | Code adresse facturation
copd_b1_adrf | Code postal adresse facturation
ville_b1_adrf | Ville adresse facturation
b1_col | Nombre de colis total
b1_poids | Poids total
b1_montant | Coût en devise société
b1_montant_euro | Coût en EURO
b1_montant_dev | Coût en devise
b1_com | Observation
b1_edit | Bon de livraison édité
b1_embal | Type d'emballage
b1_cembal | Coût emballage en devise société
b1_cembal_euro | Coût emballage en EURO
b1_cembal_dev | Coût emballage en devise
b1_tvae | Code TVA emballage
libc_b1_tvae | Libellé court code TVA emballage
libl_b1_tvae | Libellé long code TVA emballage
zc1_b1_tvae | Valeur 1 code TVA emballage
b1_type_vehicule | Type de véhicule
libc_b1_type_vehicule | Libellé court type de véhicule
libl_b1_type_vehicule | Libellé long type de véhicule
b1_vehicule | Véhicule (Immatriculation)
b1_heure_depart | Heure de départ
b1_no_groupage | Numéro groupage
b1_date_chargem | Date de chargement
b1_lieu_rgt1 | Magasin destination
libc_b1_lieu_rgt1 | Libellé court magasin destination
libl_b1_lieu_rgt1 | Libellé long magasin destination
b1_ordre_chargt | Ordre de chargement
b1_devise | Code devise
libc_b1_devise | Libellé court code devise
libl_b1_devise | Libellé long code devise
b1_annu | Bon de livraison annulé
b1_transitaire | Code transitaire
nom_b1_transitaire | Nom transitaire
b1_poids_brut_tr | Poids but transporté

Table blv2

avec ses propres libellés

b2_soc | Code société
b2_blv | Numéro de bon de livraison
b2_lig | Numéro ligne de bon de livraison
b2_cde | Numéro de commande
b2_ligcde | Numéro de ligne de commande
b2_ligseq | Numéro de séquence ligne cde
b2_qte | Quantité livrée facturable
b2_qteliv | Quantité livrée
b2_poids | Poids
b2_nbcolis | Nombre de colis
b2_excolis | Nombre d'exemplaires
b2_nummvt | Numéro de mouvement de stock
b2_fact | Ligne de BL facturée (O/N)
b2_solde | Ligne de commande soldée (O/N)
b2_type_livraison | Type de livraison
b2_annu | Ligne de bon de livraison annulée

Valeurs calculées

stk_disp | Stock disponible résultant
stk_phy | Stock physique résultant
stk_res | Stock réserve résultant
stk_cdef | Stock en commande résultant
stk_rgt1 | Lieu de rangement de l'article si en global ou du lieu si en lieu
stk_smaxi | Stock maximum de l'article si en global ou du lieu si en lieu
stk_smini | Stock de sécurité de l'article si en global ou du lieu si en lieu
stk_alerte | Seuil d'alerte de l'article si en global ou du lieu si en lieu
stk_gestionnaire | Gestionnaire de l'article si en global ou du lieu si en lieu
stk_reap | Mode de réapprovisionnement de l'article si en global ou du lieu si en lieu
stk_qteeco | Quantité de réapprovisionnement de l' article si en global ou du lieu si en lieu
stk_clifou | Code client du mouvement Si <> de 0 et code fournisseur = 0 ou Code fournisseur du mouvement Si <> de 0 et code client = 0 ou ?????? Si code client et code fournisseur <> de 0
stk_cdeclifou | Numéro commande client Si <> de 0 et numéro commande fournisseur = 0 ou Numéro commande fournisseur Si <> de 0 et numéro commande client = 0 ou ???????? Si numéro commande client et numéro commande fournisseur <> de 0
stk_disp_immediat | stock disponible immédiatement

Autres zones

presence_fbi | Un * indique la présence de FBI non soldée pour l'article
format | Longueur x largeur
alerte_phy | Flag d'alerte sur stock physique
alerte_disp | Flag d'alerte sur stock disponible
using | Voir #VI
stock_laize | Spécifique pour les onduleurs avec gestion des bobines Valeur du stock minimum pour la laize bobine (zone s0_rgt2) en cours. Colonne non cumulable Voir aussi le tri 05 et la note LISTE_TSC_STK_LAIZE
mpeb_sdisp | Stock disponible en équivalent boîte
mpeb_sphy | Stock physique en équivalent boîte
mpeb_sres | Stock réservé en équivalent boîte
mpeb_sbes | Stock besoin en équivalent boîte
mpeb_scdef | Stock en commande fournisseur et fabrication en équivalent boîte
entree | Quantité du mouvement d'entrée
sortie | Quantité du mouvement de sortie
gen_edi_cde_ok gen_edi_cde_ref gen_lig_edi_cde | Zones concernant la génération d'une commande à partir de la visu d'un produit Génér.cde La commande EDI a été générée correctement pour le produit courant Référence de commande EDI (edc_ref) générée pour le produit courant Ligne de commande EDI (edc_lig) générée pour le produit courant
stock_physique_pf_nn | Stock physique de l'article Le _nn correspond au numéro de la restriction. Voir note commençant par RESTRIC_STOCK_NUM_ Ces nouvelles colonnes sont accessibles dans le dictionnaire des données. Elles ne sont pas vraiment cumulables. Elles représentent le stock physique de l'article. Par contre, on autorise le fait de les visualiser et de les éditer sur les lignes de totalisation.


Ruptures de stock

Etat des ruptures de stock rstk0

Options

-Oru | Edition des ruptures de stocks
-Obm | Edition des besoins matières
-Of2 | ouverture de la deuxième page
-On1 | Rupture niveau 1
-On2 | Rupture niveau 2

Valeur alpha2

(paramétrage des colonnes d'édition)

A | Code matière / produit
B | Désignation matière / produit
C | Code famille
D | Code sous-famille
E | Code type
F | Première zone de rangement
G | Deuxième zone de rangement
H | Troisième zone de rangement
I | Hauteur
J | Longueur
K | Largeur
L | Code conditionnement
M | Code couleur
N | Poids
O | Code unité d'achat
P | Code unité de vente
Q | Code produit de remplacement
R | Prix d'achat
S | Stock mini
T | Stock maxi
U | Stock disponible
V | Stock physique
W | Stock réserve
X | Code qualité
Y | Stock en commande fournisseur
Z | Stock à commander = stock maxi - stock mini - stock physique + stock en réserve - stock en commande Si le stock à commander est négatif, il est remis à zéro.
0 | Code fournisseur principal
1 | Seuil d'alerte
2 | Quantité à commander : si dispo > 0 => qté = mini si dispo <= 0 => qté = dispo - mini
3 | Disponible immédiatement Disponible - réserve
4 | Code client principal


Modification du PAMP par période dans les stocks

Modification du PAMP par période dans les stocks modif_pamp

Ce programme est utilisable à partir de la V. 4.1.29.2

Création des inventaires et modification du prix des mouvements

Le but est de modifier le PAMP d'un article durant une certain période dans les stocks afin de pouvoir récupérer en valeur un certain historique issu d'autres systèmes informatique.

Pour ce faire, ce programme va lire dans un fichier les différentes périodes à actualiser.

Une période se décompose au minimum d'un code article, une date de début de période et un PAMP à affecter. Il est aussi possible de donner une date de fin de la période.

S'il y a plusieurs périodes pour un même article sans date de fin précisée, la date de fin d'une période est par défaut la veille de la date de début de la période suivante.

Dans le cas de la modification du PAMP d'un code papier, le programme intègre aussi la mise à jour de toutes les bobines de ce papier (attention, cela peut provoquer des temps de réponse assez conséquents).

Le traitement d'une période se fait de la manière suivante :

1. Création d'un inventaire valorisé au nouveau PAMP à la veille du début de période

2. S'il y a une date de fin de période : modification du prix de tous les mouvements de stocks compris dans la période pour le passer au nouveau PAMP

3. A la fin du traitement, le programme exécute pour chaque article de la sélection le programme G_crinv qui doit être paramétré avec l'option « –Osi » pour corriger les mouvements passés après la dernière période et recalculer le PAMP en cours de l'article.

Remarque : Etant donné que le traitement peut concerner beaucoup d'articles (surtout si on inclut les bobines) et que tout traitement sur les stocks peut être assez long, il est possible d'avoir une demande de confirmation du traitement si ce dernier porte sur plus de X enregistrements (X est paramétrable dans la zone numérique 1 du paramètre de lancement)

ATTENTION : Il y a création d'un mouvement d'inventaire valorisé…

Cette action n'est pas sans conséquence sur la création des mouvements de stocks à venir (VoluPack ne créé les nouveaux mouvements de stocks qu'après le dernier inventaire); il faut donc ne corriger les PAMP que sur des périodes sur lesquelles il n'y a aura plus de mouvements de stocks à venir

Options

-f

Permet de spécifier le fichier des périodes à corriger sur la ligne de commande (prioritaire sur le nom de fichier paramétré en zone alpha 3).

Attention : Si utilisation de ce paramètre, la fenêtre de saisie du nom du fichier ne s'ouvrira pas.

-Osi

Mode Simulation

Exécute le traitement sans modifier les stocks ni créer les mouvements d'inventaire.

Seule une fenêtre décrivant les opérations qui auraient dû être faites va s'ouvrir.

-Osm

Mode Sans menu

Permet de lancer le traitement en mode interactif sans avoir à passer par les options du menu.

Valeur alpha 2

A2[1,3] | Type du mouvement de stock des inventaires qui seront générés
A2[4] | Caractère de séparation des zones si le fichier des périodes à traiter ne contient pas des zones de taille fixe
A2[5,10] | Type et code du paramètre de lancement du programme G_crinv devant contenir l'option –Osi à lancer pour le recalcul des PAMP des fiches corrigées

Valeur alpha 3

A3[1,60]

Nom du fichier à intégrer par défaut

Même si ce paramétrage existe, la fenêtre de demande du nom du fichier s'ouvrira.

Notes

_SUP_REQ_BOBINE | 21,60 Complément de requête permettant de retrouver les bobines affectées au papier qui seront ajoutées au traitement Exemple : and mp_fam = ‘BOB'
_SUP_REQ_PAPIER | 21,60 Complément de requête sur la table mat permettant de déterminer si l'article de la période est un papier. Exemple : and mp_fam = ‘PAP'
_SUP_REQ_STK0 | 21,60 Complément de requêtes sur la table stk0 permettant d'exclure certains mouvements du traitement (attention à ne pas exclure les mouvements physiques, sinon le traitement génèrera des erreurs) Exemple : and s0_etat not in (‘R','C','P')

Notes pour le paramétrage des zones d'un fichier de périodes sans caractère de séparation (taille fixe)

Si une même ligne du fichier contient plusieurs périodes, il faut les numéroter de 1 à x

(remarque : le code article de la période x de la ligne peut être au même emplacement que le code article de la période 1)

ZONE_ART_1 | 21,29 Caractère de début du code article de la période 1 d'une ligne du fichier 31,39 Caractère de fin du code article de la période 1 d'une ligne du fichier
ZONE_DEB_1 | 21,29 Caractère de début de la date de début de la période 1 d'une ligne du fichier 31,39 Caractère de fin de la date de début de la période 1 d'une ligne du fichier
ZONE_FIN_1 | 21,29 Caractère de début de la date de fin de la période 1 d'une ligne du fichier 31,39 Caractère de fin de la date de fin de la période 1 d'une ligne du fichier
ZONE_PMP_1 | 21,29 Caractère de début du PAMP à attribuer sur la période 1 d'une ligne du fichier 31,39 Caractère de fin du PAMP à attribuer sur la période 1 d'une ligne du fichier
ZONE_ART_x | 21,29 Caractère de début du code article de la période x d'une ligne du fichier 31,39 Caractère de fin du code article de la période x d'une ligne du fichier
ZONE_DEB_x | 21,29 Caractère de début de la date de début de la période x d'une ligne du fichier 31,39 Caractère de fin de la date de début de la période x d'une ligne du fichier
ZONE_FIN_x | 21,29 Caractère de début de la date de fin de la période x d'une ligne du fichier 31,39 Caractère de fin de la date de fin de la période x d'une ligne du fichier
ZONE_PMP_x | 21,29 Caractère de début du PAMP à attribuer sur la période x d'une ligne du fichier 31,39 Caractère de fin du PAMP à attribuer sur la période x d'une ligne du fichier

Notes pour le paramétrage des zones d'un fichier de périodes avec caractère de séparation

Si une même ligne du fichier contient plusieurs périodes, il faut les numéroter de 1 à x

(remarque : le code article de la période x de la ligne peut-être dans la même zone que le code article de la période 1)

COL_ART_1 | 21,29 Numéro de la zone contenant le code article de la période 1 de la ligne du fichier
COL_DEB_1 | 21,29 Numéro de la zone contenant la date de début de la période 1 de la ligne du fichier
COL_FIN_1 | 21,29 Numéro de la zone contenant la date de fin de la période 1 de la ligne du fichier
COL_PMP_1 | 21,29 Numéro de la zone contenant le PAMP à attribuer de la période 1 de la ligne du fichier
COL_ART_x | 21,29 Numéro de la zone contenant le code article de la période x de la ligne du fichier
COL_DEB_x | 21,29 Numéro de la zone contenant la date de début de la période x de la ligne du fichier
COL_FIN_x | 21,29 Numéro de la zone contenant la date de fin de période x de la ligne du fichier
COL_PMP_x | 21,29 Numéro de la zone contenant le PAMP à attribuer de la période x de la ligne du fichier

Exemple

Ce que l'on veut faire :

Pour le papier XP_FL127

Le PAMP du mois de janvier 2013 sera de 100

Le PAMP du mois de février 2013 sera de 150

A partir du 1er mars 2013, le PAMP sera à 175

Exemple de fichier texte avec séparateur et 2 périodes sur un même article par ligne :

XP_FL127 |01/01/2013|100.00|01/02/2013|150.00|

XP_FL127 |01/03/2013|175.00|


Outil de génération de numéro de conteneur

Outil de génération de numéro de conteneur outil_gen_num_conteneur

Cet outil est opérationnel à partir de la V. 4.0.203.2.

Ce programme génère les palettes dans conteneur_produit et conteneur_info depuis le stock.

Seul le stock configuré en mp_param[17] = 2 est traité.

Cela crée les mouvements de stock selon le type de mouvement configuré et la date choisie au lancement du programme.

Valeur alpha 2

A2[1,3] | Type de mouvement en stock. Paramètre obligatoire.
A2[4] | Suppression (O/N, N par défaut) O L'application supprime toutes les entrées ayant le numéro de palette paramétré ou à défaut celui par défaut (99xxxxxx) et les entrées dans stk0 ayant le TMV paramétré. N Aucune suppression

Notes

_DEBUT_ID_CONTENEURS | 21,60 Permet de définir un id palette initiale. Par défaut celui-ci est à 99000000. Par exemple on peut définir : 98000000. Le numéro doit commencer par deux chiffres suivi au minimum d'un troisième. (120)
_SUP_REQ_PR_ENSEMBLE | 21,60 Supplément de requête sur stk_lot_lieu et mat

Exemple de paramétrage

A2[1,3] | TES | TMV concerné : TES. Doit exister en tant que TMV
A2[4] | O | Au 2ème lancement, tout effacer si nécessaire
_DEBUT_ID_CONTENEURS98000000 |  | Le numéro des palettes est sous la forme 98xxxxxx.
_SUP_REQ_PR_ENSEMBLE and s1_rgt1 <> "EXP" |  | On ne traite pas les stocks côté EXPédition.

Déroulement

Au lancement de l'application, on saisit la date de mouvement.

Il s'agit de la date que l'on souhaite mettre pour les mouvements de stock. Une fois validée, les palettes sont générées.

En fin de traitement, une fenêtre récapitule ce qui a été créé. Les erreurs sont aussi affichées.


Outil de réintégration des mouvements de stock de fab0

Outil de réintégration des mouvements de stock de fab0 outil_mvts_fab

Cet outil réintègre les mouvements de stock de fab0.

Pour chaque mouvement de stock, on vérifie l'affectation (OF-Ligne/Entité/Phase).

L'affectation doit avoir 2 slashes.

Si l'affectation correspond à un OF et que la matière de cet OF et celle du mouvement de stock sont identiques, on ne fait rien.

Si l'affectation correspond à un OF et que la matière de cet OF et celle du mouvement de stock sont différentes :

- on supprime la ligne correspondant au mouvement de stock de fab3

- on retire la quantité et le coût du mouvement de stock des quantités et des coûts réalisés de fab0.

- on dé-clôture l'OF racine et ses fils s'il est clos

- on replace l'OF racine et ses fils à calculer et à éditer

- on remet l'affectation d'origine du mouvement de stock (OF-Ligne/Entité)

- on remet le mouvement de stock à intégrer (s0_integre = M)

Si l'affectation ne correspond pas à un OF :

- on dé-clôture l'OF racine et ses fils s'il est clos

- on replace l'OF racine et ses fils à calculer et à éditer

- on remet l'affectation d'origine du mouvement de stock (OF-Ligne/Entité)

- on remet le mouvement de stock à intégrer (s0_integre = M)

En fin de traitement, le compte-rendu de la réintégration est visualisé.

Celui-ci est éditable (Touche F8).

PENSEZ A FAIRE UNE SAUVEGARDE DES TABLES STK0, FAB0 et FAB3 AVANT DE LANCER L'OUTIL !!!

Options

-B | Mode batch
Osi | Mode simulation. Pas de réintégration des mouvements de stock de fab0

Notes

SUP_REQ

Supplément de requête. Obligatoire en mode batch

Exemple : and s0_affect matches "05*"


Calcul des stocks résultants

Calcul des stocks résultants calsr

Précision du 14/06/2012

Lorsque nous avons besoin de recalculer les stocks pour une ou plusieurs fiches matières, nous utilisons actuellement 2 outils :

1) G_calsr qui recalcule la zone stock résultant de chacun des mouvements de stock de l'article

2) G_dec_stk qui remet à jour la fiche matière en fonction des quantités issues du dernier mouvement de stock.

Si on veut être certain que le G_dec_stk soit correct, il est impératif de lancer d'abord le module G_calsr.

Mais , lorsque cet outil est lancé sur l'ensemble des produits d'une base de données, il peut se passer longtemps entre le moment où un produit est traité par le G_calsr, et le moment où il sera traité par le G_dec_stk.

Un moment suffisamment long pour qu'un nouveau mouvement de stock soit passé qui faussera complètement les données.

Pour pallier cet inconvénient, on instaure dans le G_calsr la mise à jour de la fiche article qui sera faite dès la fin de recalcul de ses mouvements de stock.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Code article

Exemple : -N[lc_prod]

Options

-B | Mode batch (nécessite l'option Ops)
Ods | Corrige les décalages de stocks au sein de la fiche matière après le recalcul des stocks
Oim | Mode imprimerie
Ops | Pas d'écran de sélection (nécessaire pour l'option -B)
Orp | Recalcul les quantités réserves et prévisionnelles de la fiche matière (nécessite Ods)

Valeur alpha 2

Caractères 1 à 5

Mot de passe éventuel

Notes

FICHIER_TRACE_ANO

Nom fichier trace à générer par la correction de la fiche matière

Le calcul se fait toujours à partir du dernier inventaire ou du premier mouvement normal saisi.


Liste et mise à jour des décalages de stock

Liste et mise à jour des décalages de stock dec_stk

ATTENTION Le calsr doit être lancé au préalable !

Options

-B | Mode batch (nécessite l'option Oma)
-Oim | Imprimerie
-Oma | Mise à jour si le programme est lance en mode batch (-B)
-Orp | Mise à jour des stocks en commande et réserve
-Of2 | Deuxième fenêtre de sélection

Notes

FICHIER_TRACE_ANO

Nom du fichier de trace à générer (peut être paramétré sur plusieurs lignes de notes)


Initialisation de la table stk_lot_lieu

Initialisation de la table stk_lot_lieu maj_stk_lot_lieu

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[lc_prod]

Options

Oar

Arrêt du programme en tâche de fond

Oee

Déduction de l'escompte de l'entête de commande client

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Opd

Prix de vente de la fiche article si le prix unitaire calculé est à 0

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Ope

Calcul du prix de vente par élément

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Opp

Valorisation au prorata du poids pour les ensembles appairés

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Ops

Valorisation au prorata de la surface pour les ensembles appairés

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Ore

Déduction de la remise de l'entête de commande client

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Orl

Déduction de la remise de la ligne de commande client

Utilisée dans le calcul de la valeur du stock physique au prix de vente du lot

Osp

On ne crée dans la table stk_lot_lieu que si l'on a un stock physique.

Ota

Boucle sur tous les articles - OPTION REMPLACEE PAR A2[5] = O

Otf

Le programme tourne en tâche de fond.

Oup

Arrêt du programme en tâche de fond après un seul passage

Ovl

Valorisation des FBI au prix de vente du lot

Lorsque les stocks par lots/lieux sont recalculés, la valeur en stock est elle aussi recalculée

Par défaut, cette valeur est obtenue en multipliant la quantité par le prix de vente du lot SAUF dans le cas des FBI où cette valeur est obtenue en multipliant la quantité par le prix de vente de la fiche article.

Cette nouvelle option permet la valorisation des FBI de la même manière que tous les autres types de commandes.

Valeur alpha 2

Caractères 1 à 4 | Délai d'attente, en minutes
Caractère 5 | Réinitialisation globale de la table stk_lot_lieu en mode BATCH (O/N, O par défaut)
Caractère 6 | Type de date de la 1ère requête de la 1ère date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE1_REQ1. Voir aussi le § d'explication plus bas.
Caractère 7 | Type de date de la 2ème requête de la 1ère date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE1_REQ2. Voir aussi le § d'explication plus bas.
Caractère 8 | Type de date de la 1ère requête de la 2ème date de la table stk_lot_lieu (sl_date2) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE2_REQ1. Voir aussi le § d'explication plus bas.
Caractère 9 | Type de date de la 2ème requête de la 2ème date de la table stk_lot_lieu (sl_date2) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE2_REQ2. Voir aussi le § d'explication plus bas.
Caractères 10 à 15 | Type et code du paramètre de lancement du programme à lancer pour chaque client traité Le programme (generation_invrpt_wiprpt) est lancé avec -N suivi du code client.
Caractère 16 | Type de date de la 1ère requête de la 3ème date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE3_REQ1. Voir aussi le § d'explication plus bas.
Caractère 17 | Type de date de la 2ème requête de la 3ème date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE3_REQ1. Voir aussi le § d'explication plus bas.
Caractère 18 | Type de date de la 1ère requête de la 4ème date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE4_REQ1. Voir aussi le § d'explication plus bas.
Caractère 19 | Type de date de la 2ème requête de la 4ème date de la table stk_lot_lieu (sl_date1) 1 Sur la date du mouvement de stock (s0_datm) 2 Sur la plus ancienne date des mouvements de stock (min(s0_datm)) 3 Sur la plus récente date des mouvements de stock (max(s0_datm)) (par défaut) Facultatif. Voir la note SUP_DATE4_REQ2. Voir aussi le § d'explication plus bas.

Notes

FIC_ARRET | 21,60 Nom du fichier d'arrêt
FIC_LOCK | 21,60 Nom du fichier de verrouillage
FIC_TRACE | 21,60 Nom du fichier trace
SUP_DATE1_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 1ère date de la table stk_lot_lieu (sl_date1). Facultatif - En liaison avec A2[6] Voir aussi le § d'explication plus bas.
SUP_DATE1_REQ2 | 21,60 Supplément de la 2ème requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 1ère date de la table stk_lot_lieu (sl_date1). Facultatif - En liaison avec A2[7] Voir aussi le § d'explication plus bas.
SUP_DATE2_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 2ème date de la table stk_lot_lieu (sl_date2). Facultatif - En liaison avec A2[8] Voir aussi le § d'explication plus bas.
SUP_DATE2_REQ2 | 21,60 Supplément de la 2ème requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 2ème date de la table stk_lot_lieu (sl_date2). Facultatif - En liaison avec A2[9] Voir aussi le § d'explication plus bas.
SUP_DATE3_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 3ème date de la table stk_lot_lieu (sl_date3). Facultatif - En liaison avec A2[16]
SUP_DATE3_REQ2 | 21,60 Supplément de la 2ème requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 3ème date de la table stk_lot_lieu (sl_date3). Facultatif - En liaison avec A2[17]
SUP_DATE4_REQ1 | 21,60 Supplément de la 1ère requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 4ème date de la table stk_lot_lieu (sl_date4). Facultatif - En liaison avec A2[18]
SUP_DATE4_REQ2 | 21,60 Supplément de la 2ème requête sur la table des mouvements de stock (stk0) pour la mise à jour de la 4ème date de la table stk_lot_lieu (sl_date4). Facultatif - En liaison avec A2[19]
SUP_REQ_MAT | 21,60 Complément de requête pour la recherche sur l'article
SUP_REQ_STK0 | 21,60 Complément de requête pour la recherche du stock

Paramètres associés

so_options[01] et so_options[05] doivent être = O.

Mise à jour des nouvelles colonnes sl_date1 et sl_date2 dans la table stk_lot_lieu

Le paramétrage se fait en alpha2[4,6] et dans les notes SUP_DATEn_REQx.

La mise à jour de chaque date se fait à l'aide de 2 requêtes paramétrables dans les notes du paramètre de lancement.

Les requêtes se font sur le couple article - lot.

Pour chacune des 2 dates :

Requête 1 (SUP_DATEn_REQ1)

Si elle n'est pas paramétrée, la date n'est pas mise à jour.

Si elle est paramétrée et qu'elle retourne une date, la date est mise à jour avec cette date.

Si elle est paramétrée et qu'elle ne retourne pas de date, on vérifie si la requête 2 est paramétrée.

Requête 2 (SUP_DATEn_REQ2)

Si elle n'est pas paramétrée, la date n'est pas mise à jour.

Si elle est paramétrée et qu'elle retourne une date, la date est mise à jour avec cette date.

Si elle est paramétrée et qu'elle ne retourne pas de date, la date n'est pas mise à jour.

Exemple

A2[6] = 3

SUP_DATE1_REQ1 and s0_es="E" and s0_anu = "N"

SUP_DATE1_REQ1 and s0_typ = "EN"

Avec ce supplément de requête, la requête ressemblera à ceci :

select max(s0_datm) from stk0 | A2[6] = 3 donc on prend la plus récente date des mouvements de stock
where s0_soc = "VSW" | Société concernée
and s0_prod = "E00243206" | Les requêtes se font systématiquement sur le couple article-lot.
and s0_lot = "02010172-001" | Les requêtes se font systématiquement sur le couple article-lot.
and s0_es="E" and s0_anu = "N" | Complément de requête SUP_DATE1_REQ1
and s0_typ = "EN" | Complément de requête SUP_DATE1_REQ1 (suite)


Outil de compression des mouvements de stock

Outil de compression des mouvements de stock compact_mvt_stock

Compression de la table stk0 en regroupant les mouvements de stock créés palette par palette en 1 seul mouvement, représentant la quantité de la totalité des palettes.

Seuls les mouvements affectés à une palette sont traités

C'est un programme "batch" s'appuyant sur un paramètre de lancement, qu'il faut impérativement configurer.

Il peut être exécuté soit en mode simulation, soit en mode réel avec maj.

Un fichier journal fournit un compte rendu de l'opération.

Pour recalculer les stocks résultants, il est nécessaire d'exécuter, après compactage, l'outil calsr

Options

-Otr | Traitement réel. Si non positionnée : mode simulation, sans mise à jour
-Ond | Journal non détaillé : N'imprime pas chaque opération dans le journal

Valeur alpha 2

Caractères 1 à 60

Répertoire d'enregistrement du journal. (/u/tmp/ par défaut)

Notes

_COMP_SQL_STK0

21 à 60 Complément de requête pour la sélection des mouvements. Paramétrage OBLIGATOIRE


Epuration des stocks

Epuration des stocks epu_stk_0

L'objectif de ce module est d'annuler logiquement les articles selon les règles suivantes :

  1. On ne traite que les articles suivis en stock.

  2. On ne traite que les articles dont le stock physique est à zéro.

  3. On ne traite que les articles ayant eu au moins un mouvement de stock.

  4. On ne traite que les articles qui n'ont aucun mouvement de stock après une date saisie au lancement du programme.

Bien entendu, ce module ne doit pas être laissé entre toutes les mains et le complément de select paramétrable est vivement conseillé.

Mode BATCH autorisé

Valeurs numériques

1

Nombre minimum de jours à conserver (par défaut 60)

Entraîne le calcul et la proposition d'une date limite pour l'épuration.

L'utilisateur peut modifier la date.

Valeur alpha 2

A2[1,5]

Mot de passe

Notes

S

Complément de select sur table mat


Transfert du stock papier vers OMP

Transfert du stock papier vers OMP tr_psdata

Il permet de transférer le stock papier à OMP (système de planification), via la construction d'un fichier xml.

On fait un enregistrement par couple produit/laize.

Ce fichier est posté sur un répertoire sur le serveur pour être récupéré par OMP.

Options

Odr | Si la laize est supérieure à 4 caractères, on prend les 4 caractères de droite.
Oga | Si la laize est supérieure à 4 caractères, on prend les 4 caractères de gauche.
Opa | Remplacer le code produit transféré par son code AFNOR correspondant.
Or3 | La laize se trouve sur le lieu de rangement 3.

Notes

CODE_PREFIX | 21,23Préfixe permettant de construire la clé du produit passé à l'interface (PAP par défaut)
ENV_CESSION | 21,23 Environnement de cession pour le calcul du prix de cession du papier
FIC_ANOMALIE | 21,60 Nom du fichier anomalie
FIC_LOCK | 21,60 Nom du fichier lock (ce fichier indique qu'un traitement est déjà en cours du côté VoluPack).
FIC_OMP | 21,60 Nom du fichier xml (sans extension)
FIC_TRACE | 21,60 Nom du fichier trace
SUP_REQ_MAT | 21,60 Complément de requête sur la table mat
SUP_REQ_RGT | 21,60 Complément de requête sur la table stk0 pour la recherche de stock
TYPE_NOTE_MAT | 21,23 Type de note sur la table mat3. La première ligne de note non vide sera envoyée dans l'interface.


Outil de contrôle du stock Bobine et Papier

Outil de contrôle du stock Bobine et Papier outil_stk_bob_pap

Ce programme est utilisable à partir de la V. 4.1.39.2.

But

2 contrôles sont effectués :

Sans l'option –Ot2, le programme contrôle par Papier, Lot (sur option), magasin et laize :

Le cumul des mouvements de stocks du papier

Le cumul des mouvements de stocks des bobines

Le cumul du stock des fiches matières bobines (si contrôle sans lot)

Avec l'option –Ot2, le programme contrôle que pour chaque mouvement de transfert et/ou de consommation il y a un mouvement de papier pour un mouvement de bobine.

Les différences sont corrigées après validation.

Il faut utiliser un complément de requête pour sélection les types de mouvements.

Options

Ot2

Pour chaque mouvement de transfert et/ou de consommation, contrôle qu'il y a un mouvement de papier pour un mouvement de bobine.

Notes

SUP_REQ_PAP | 21,60 Complément de sélection pour la recherche des mouvements de stock papier. Le complément porte sur la table stk0 dans tous les cas, et sur la table mat si l'option Ot2 est active.
SUP_REQ_BOB | 21,60 Complément de sélection pour la recherche des mouvements de stock bobines (table stk0 et mat) Incompatible avec l'option Ot2

Le code papier dans la table mat pour la bobine est le champ mp_afnor.


Création code papier et stock

Création code papier et stock cre_papier_stock

Ce programme est opérationnel à partir de la V. 4.0.170.2.

Lors de la consommation complète, après une phase de découpe, toutes les feuilles ainsi produites ne sont pas forcément consommées par la phase OFFSET ou autre.

On veut à cet instant entrer en stock ces palettes de feuilles.

On ne peut plus intervenir au niveau de la bobine car celle-ci n'existe plus.

Par ce nouveau module, on peut entrer en stock ce papier en saisissant :

  1. La qualité

  2. le format

  3. le poids

  4. la quantité (totale ou par palette)

  5. l'ordre de fabrication sur lequel on a consommé la bobine.

S'il n'existe pas de papier dans le format saisi, on crée un nouveau code papier.

On fait une entrée en stock de ce papier et on gère si nécessaire les conteneurs et les étiquettes.

Il sera aussi fait des mouvements de stock de régulation sur la qualité, afin d'enlever ces feuilles de la consommation de la bobine initiale sur l'ordre de fabrication, pour ne pas fausser le pris de revient.

Attention : vérifier le produit par défaut pour la création du papier :

1) Géré en lot lieu conditionnement (mp_param[17] = 2)

2) Géré à la palette (mp_param[40] = O)

Options

-H | Mode code à barres
Ocb | Affiche les écrans en mode code à barres et la saisie à la suite des OF avec les codes palettes Permet de rendre l'application en mode code à barres (avec l'option -H ci-dessus) Permet de créer un code papier et son stock d'une ou plusieurs palette sur un ou plusieurs OF. L'opérateur flashe un ou plusieurs OF à la suite. Via le code action FOF, il peut ensuite flasher un ou plusieurs numéros de palette en indiquant le poids et le nombre de feuille qu'elle contient. enfin, via le code action FIN, le poids total est distribué proportionnellement sur chaque OF. Le code LOF dans le champ numéro OF permet d'afficher la liste des OF flashés. Le code FOF dans le champ numéro OF permet d'aller dans le champ palette. Le code LPA dans le champ palette permet d'afficher la liste des palettes flashées. Le code FIN dans le champ palette permet de lancer les traitements. Voir aussi la note _STYLE_CAB
Oce | Création seule des étiquettes palettes sans les éditer Les options Opa et Oea sont obligatoires.
Oea | Gestion des étiquettes d'achat
Oen | Gestion des étiquettes neutres
Oia | Imprimante automatique pour les étiquettes
Opa | Gestion du papier à la palette
Osr | Mise à jour des stocks résultants

Valeur alpha 3

A3[1,3] | Type de mouvement d'entrée pour le papier
A3[4.6] | Type de mouvement de sortie pour le mouvement de régularisation de la qualité
A3[7,9] | Type de mouvement d'entrée pour le mouvement de régularisation de la qualité
A3[10] | Mode de saisie O saisie du format laize/coupe (par défaut) N saisie du format coupe/laize
A3[11,13] | Lieu de rangement 1 par défaut
A3[14,19] | Lieu de rangement 2 par défaut

Notes

ETIQACHAT_IMP | 21,23 Code imprimante pour édition automatique
_FOR_CONV_UNITE_2 | 21,23 Formule de conversion Exemple : F-K (feuilles en Kilos)
_ORDER_BY_RECH_LOT | Complément de tri sur la table des stocks pour la recherche du lot
_STRUCTURE_CONTENEUR | 21 Structure du conteneur 1 Structure standard : PACCCCCCCC-LLL-000-PPPP 2 Structure libre conteneur = CAB Voir le paramétrage de la racine et du format ci-dessous. 22,24 Racine du conteneur (exemple : B) 25,37 Format du numéro de palette (exemple : &&&&&&&&) Les conteneurs auront comme structure : P00000001
_STYLE_CAB | 21,60 Nom du style pour le mode CAB. Permet de mettre un style spécifique pour le mode CAB.
_SUP_REQ_PAPIER | 21,23 Supplément de requête pour la recherche de l'existence du papier dans le format (table matières)
_SUP_REQ_RECH_LOT | 21,60 Complément de requête sur la table des stocks pour la recherche du lot

Paramètres nécessaires

#CF CAR A1[4] | Correspondance de la laize avec la largeur de la fiche article N La laize correspond à la longueur O La laize correspond à la largeur (par défaut)
#CF DEG A4[16] | Les dimensions de l'article sont en mm. O Oui, elles sont en mm N Non, elles sont en cm (par défaut)
#CF GEA | Pour la génération du code papier


Intégration des sorties de bobines

Intégration des sorties de bobines integrer_edi_stk_bob

Ce programme est opérationnel à partir de la V. 4.0.170.2.

Intégration des sorties des bobines dans la table EDI des sorties des bobines (edi_stk_bobine) à partir d'un fichier.

Options

Oar | Arrêt du programme en tâche de fond
Osi | Simulation - La table EDI des sorties des bobines (edi_stk_bobine) n'est pas mise à jour.
Oup | Arrêt du programme en tâche de fond après un seul passage

Valeur alpha 2

A2[1] | Délimiteur du fichier - Facultatif - | (Pipe) par défaut
A2[2,5] | Délai d'attente en minutes - Facultatif - 1 minute par défaut

Notes

FIC_INTEGRER | 21,60 Nom du fichier à intégrer - Obligatoire
FIC_LOCK | 21,60 Nom du fichier lock général posé par le programme - Obligatoire
FIC_LOCK_EXT | 21,60 Nom du fichier lock posé par un programme externe - Obligatoire
FIC_LOCK_VS | 21,60 Nom du fichier lock posé par le programme qui peut être utilisé par un programme externe - Obligatoire
FIC_ARRET | 21,60 Nom du fichier arrêt - Obligatoire
FIC_ANOMALIE | 21,60 Nom du fichier anomalie - Obligatoire
FIC_TRACE | 21,60 Nom du fichier trace - Obligatoire

Paramètres nécessaires

#CF TRA

Traçabilité de la nouvelle table edi_stk_bobine - Paramétrer les notes suivantes :

TRACABILITE_TABLE

TRACABILITE_CHAMP

TAB_FLAG_77

Voir aussi

s_bob | Paragraphe sur la nouvelle fonction d'intégration de la table EDI des sorties des bobines (en haut de page)
v_edi_stk_bob | Visualisation de la table EDI des sorties des bobines

Format du fichier ESCADA

N° | Data Item | Max.Size & Type | (Units) Notes
1 | Message Type | 1A | 'U'
2 | Factory Roll Number | 7A | N° bobine interne VoluPack ( mp_code char(15))
3 | CEPI Roll Number | 16N – see note | N° bobine fournisseur Les zéros à gauche sont significatifs, il ne faut pas les supprimer. Exemple : 0000351843250087 (le_libpar1 char(20))
4 | Remaining Weight | 8N | Poids restant en Kg
5 | Remaining Length | 5N | Longueur restante
6 | Usage Type | 1A | Toujours 'S'
7 | Programme Number at Start of Usage | 4N | N° programme PcTopp, correspond à la zone s0_affect en jaune dans l'exemple suivant : Exemple H : 00H00 L : 001 P : 4575
8 | Format Number at Start of Usage | 2N | Heure de début de consommation : Ne pas en tenir compte
9 | Roll Stand Number | 2N | Code lanceur, correspond à la zone s0_affect en jaune dans l'exemple suivant Exemple H : 00H00 L : 001 P : 4575
10 | Date & Time of End of Usage | 14N | Date et heure de sortie - YYYYMMDDhhmmss Correspond à s0_datm pour la date et pour l'heure, correspond à la zone s0_affect en jaune dans l'exemple suivant Exemple H : 00H00 L : 001 P : 4575
11 | Stock Location | 3A | Lieu de rangement, ceci est une info, se baser sur le lieu de rangement VoluPack de la bobine à l'instant T.


Intégration des bobines

Intégration des bobines G_integrer_bobine

Options

Oar | Arrêt du transfert
Oup | Un seul passage sinon boucle toutes les 10 secondes

Valeur alpha 2

Caractère 1 | Le code société est il obligatoire (O/N, O par défaut) Si Non, on prend le code société courant.
Caractère 2 | I N U T I L I S E
Caractère 3 | Le numéro de bobine interne est-il obligatoire ? (O/N, O par défaut)
Caractère 4 | Le code rejet est-il obligatoire ? (O/N, N par défaut)
Caractère 5 | Le poids du rejet est-il obligatoire ? (O/N, N par défaut)
Caractère 6 | Le nom du rejet est-il obligatoire ? (O/N, N par défaut)
Caractère 7 | La date et l'heure sont-elles obligatoires ? (O/N, N par défaut)
Caractères 8 à 10 | L I B R E S - L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -L I B R E S -
Caractères 11 à 14 | Délai d'attente en minutes - Facultatif - 1 minute par défaut

Notes

COL_BOBINE_1_X | Paramétrer l'emplacement des champs nécessaires à VoluPack pour l'intégration des bobines à partir d'un fichier EDI 21,23 Caractère de début de la zone X dans la ligne de données 25,28 Caractère de fin de la zone X dans la ligne de données 31,60 Libellé de la zone affiché dans les messages Voir en bas de cette page la description du fichier.
FIC_ANOMALIE | 21,60 Nom du fichier anomalie
FIC_ARRET | 21,60 Nom du fichier arrêt
FIC_INTEGRER | 21,60 Nom du fichier à intégrer
FIC_LOCK | 21,60 Nom du fichier lock général posé par le programme
FIC_LOCK_EXT | 21,60 Nom du fichier lock posé par un programme externe
FIC_LOCK_VS | 21,60 Nom du fichier lock posé par le programme qui peut être utilisé par un programme externe
FIC_TRACE | 21,60 Nom du fichier trace
TYPE_PARAM_REJET | 21,23 Type de paramètre des codes rejets. Doit être créé en tant que type de paramètre. Par exemple : REJ

Paramètres nécessaires

#CF TRA | Note TRACABILITE_TABLE : ajout de la table edi_bobine Note TRACABILITE_CHAMP : tous les champs de la table edi_bobine
TSC BSD | Bobine Sens Déroulement

Description du fichier d'intégration

X | Valeur | Format
1 | Code société | 3 caractères max. Doit correspondre au code société VoluPack.
2 | Numéro de bobine fournisseur | 20 caractères max.
3 | Numéro de bobine interne | 15 caractères max.
4 | Code rejet | 3 caractères max. Voir la note TYPE_PARAM_REJET
5 | Poids de rejet | Maximum 9999999.999
6 | Nom du cariste | 30 caractères max.
7 | Date et heure du scan | Format AAMMJJHHMM


Réception de bobines et de palettes fournisseur par code-barres

Lors de la réception des bobines, le lieu de rangement 1 est automatiquement renseigné selon le type de papier et la laize de la bobine.

Le ou les magasins sont utilisés comme emplacement mono-référence.

Chaque magasin ne peut contenir qu'un type de papier et une quantité maximum de bobines.

Le type de papier peut être affecté à plusieurs magasins.

Cette option affecte un lieu de stockage selon la quantité disponible de chaque magasin.

Quand un magasin est plein, il passe au suivant.

Quand tous les magasins sont pleins, il affectera un magasin par défaut sans contrôle de quantité.

Nota : lors de l'affectation ou de la désaffectation d'un lieu, aucun mouvement de stock n'est généré.

Vous devez le faire manuellement.

Remarque : si vous affectez un magasin qui a du stock d'une autre bobine et si vous n'avez pas fait les mouvements de stock, celui-ci sera ignoré lors de la réception des bobines.

Réception de bobines et de palettes fournisseur par code-barres recep_bob_cab

Voir la fiche d'installation pour les bobines Voir la fiche d'installation pour les palettes

Ce programme a été initialement créé pour la réception des bobines par CAB.

Il a été ensuite adapté pour la réception des palettes.

Les paramètres spécifiques aux bobines sont surlignés en gris.

les paramètres spécifiques aux palettes sont surlignés en vert.

Valeurs numériques

N1 | Numéro de compteur des bons de réception BRU
N2 | Numéro de compteur des bons de réception BRC

Options

Ocf

Certification des bobines lors du rapprochement du BRU avec la commande d'achat

Ocx

Pas de confirmation édition OEX ou XX_OEX

Ogb

Gestion du magasin bobine en carré

+ d'info

Voir aussi :

les notes MAG_SURSTOCK et SUP_REQ_SEL_BOB_STK

le même paramétrage dans le programme de réception de bobines

(option Ogb et notes MAG_SURSTOCK et SUP_REQ_SEL_BOB_STK)

la nouvelle visu v_lieu_rgt

la note CTRL_DOUBLON_RGT dans la saisie des articles / matières / produits

Omt

Alimentation d'un fichier trace avec les principales informations effectuées

On1

Compteur bon de réception BRU annuel

On2

Compteur bon de réception BRC annuel

Orb

Contrôle de la racine de la bobine

Si cette option est activée, le module contrôlera si la racine de la bobine est identique à la racine paramétrée en #CF BOB A1[1,4].

Osm

Solde manuel des lignes de commande d'achat en fin définitive du bon de réception

Si cette option n'est pas activée, la ligne de commande est soldée automatiquement à la validation :

- du poids ou de la longueur de la bobine

- de la quantité de la palette

Si elle est activée, les lignes de commande rattachées au bon de réception sont soldées après confirmation de l'opérateur en fin définitive du bon de réception.

Osr

Pas de mise à jour du stock résultant

Ouc

Contrôle unicité commande fournisseur

Valeur alpha 2

A2[1,60]

Nom du fichier trace - Obligatoire si option Omt

Exemple : trace_recep_bob_cab

Valeur alpha 3

A3[1,3] | Type de mouvement de stock d'entrée normale de papier des bobines - Obligatoire. Exemple : RAR
A3[4,6] | Type de mouvement de stock d'entrée normale de bobine - Obligatoire. Exemple : RAB
A3[7] | Contrôle d'obligation de la référence BL du fournisseur - Facultatif N Pas de contrôle (par défaut) C Demande de confirmation W Message d'avertissement B Non autorisé
A3[8] | Contrôle de doublon de la référence BL du fournisseur - Facultatif N Pas de contrôle (par défaut) C Demande de confirmation W Message d'avertissement B Non autorisé
A3[9] | Confirmation du nombre de bobines réceptionnées en validation définitive Facultatif N Pas de confirmation (Par défaut) W Message d'avertissement C Demande de confirmation
A3[10] | Numéro de formule de conversion à utiliser pour convertir la quantité de bobine en quantité de commande d'achat (1 à 4). Facultatif. Voir #CF ATL A1[22]
A3[11] | Type de réception par défaut - Facultatif B Réception des bobines (Valeur par défaut) P Réception des palettes
A3[12,14] | Type de mouvement de stock d'entrée normale des palettes. Obligatoire. Exemple : ENP
A3[15] | Confirmation du nombre de palettes réceptionnées en validation définitive. Facultatif N Pas de confirmation (Valeur défaut) W Message d'avertissement C Demande de confirmation
A3[16] | Saisie du magasin (RG1) (O/N, N par défaut) ar défaut, le magasin est pris : 1 Sur la fiche de l'article format (mp_rgt1 et mp_rgt2) 2 Sur le paramètre de lancement
A3[17] | Saisie de l'emplacement (RG2) (O/N, N par défaut) ar défaut, l'emplacement est pris : 1 Sur la fiche de l'article format (mp_rgt1 et mp_rgt2) 2 Sur le paramètre de lancement

Notes

CONFIG_RECEP_BOBINE | 21,26 Type et code paramètre de la configuration de la réception des bobines et des palettes - Facultatif #CFBOB par défaut
_FOR_CONV_UNITE_2 | 21,23 Code formule Cette formule est appliquée au poids réel issu du CAB et met à jour la quantité en stock dans l'unité 2. (en Unité d'achat)
MAG_SURSTOCK | 21,23 Lieu de rangement 1 Magasin par défaut si tous les magasins affectés au code papier son plein. Obligatoire si option Ogb
POURCEN_QTE | 21,29 Pourcentage de tolérance quantité mini - Utilisé pour le solde automatique 31,39 Pourcentage de tolérance quantité maxi - Utilisé pour l'affichage du message de dépassement de quantité à réceptionner
RUN_EDIT_BR | 21,26 Type et code paramètre de lancement de l'édition des bons de réception
RUN_EDIT_OEX | 21,26 Type et code paramètre de lancement de l'édition de la fiche de fabrication
_SUP_REQ_B_REC_RET_E | 21,60 Supplément de requête sur la table des entêtes de réception des commandes fournisseur (b_rec_ret_e) - Obligatoire Utilisé pour rechercher un bon de réception (BRC) créé précédemment. Exemple : and 1=1
_SUP_REQ_CDF1 | 21,60 Supplément de requête sur la table des entêtes de commande fournisseur (cdf1) - Obligatoire Utilisé pour rechercher la commande fournisseur de la bobine ou de la palette réceptionnée. Exemple : and 1=1
SUP_REQ_SEL_BOB_STK | 21,60 Complément de requête sur stk0 pour les bobines Permet de vérifier dans les stocks s'il n'y a pas un autre produit dans l'emplacement. Si un autre article est présent dans le lieu de stockage, celui-ci sera ignoré. Obligatoire si option Ogb Note cumulative
_SUP_REQ_STK0 | 21,60 Supplément de requête sur la table des mouvements de stock (stk0) - Obligatoire Utilisé pour rechercher un bon de réception (BRU) créé précédemment. Exemple : and 1=1


Saisie par codes-barres des sorties et des entrées de bobines et de palettes

Saisie par codes-barres des sorties et des entrées de bobines et de palettes s_e_bob_cab

Voir la fiche d'installation pour les bobines Voir la fiche d'installation pour les palettes

Ce programme a été initialement créé pour les bobines.

Il a été ensuite adapté pour les palettes.

Les paramètres spécifiques aux bobines sont surlignés en gris,

tandis que les paramètres spécifiques aux palettes sont surlignés en vert.

Options

Odj

Sortie et entrée des bobines et des palettes à la date du jour

Par défaut, sortie et entrée des bobines et des palettes à la date d'hier

Omo

Déclaration de consommation de bobine en multi-OF

Permet de déclarer la consommation d'une ou plusieurs bobines sur un ou plusieurs OF.

L'opérateur flashe un ou plusieurs OF à la suite, chaque OF a sa propre quantité lancée.

Puis, via le code action FOF, il peut ensuite flasher un ou plusieurs numéros de bobine en indiquant le poids consommé de chacune d'elle.

Enfin, via le code action FIN, le poids total consommé est réparti proportionnellement à la quantité lancée par OF lors des mouvements de stock.

Le code LOF dans le champ numéro OF permet d'afficher la liste des OF flashés.

Le code FOF dans le champ numéro OF permet d'aller dans le champ numéro bobine

Le code LBO dans le champ numéro bobine permet d'afficher la liste des bobines flashées.

Le code FIN dans le champ numéro bobine permet de lancer les traitements.

Voir la note MULTIOF_CODE_PHASE

Omt

Alimentation d'un fichier trace avec les principales informations effectuées

Onp

Création d'une nouvelle phase de l'OF si l'article consommé est différent de l'article de l'OF.

Utilisé si consommation des bobines ou des palettes (A3[1] = C)

Opa

Prix de l'entrée et de la sortie au prix de la ligne de commande d'achat

Opb

Prix de la sortie normale du papier au prix de la sortie normale de la bobine

Utilisée si consommation des bobines (A3[1] = S/T/C/R)

Opr

Si réintégration des bobines (A3[1] = E ou R)

Saisie d'un poids restant de la bobine à réintégrer

Par défaut, saisie d'un diamètre restant de la bobine à réintégrer

Si consommation des bobines (A3[1] = C)

Saisie d'un poids consommé de la bobine consommée

Par défaut, saisie d'un diamètre consommé de la bobine consommée

Ops

Lors de la consommation d'une bobine, si le papier n'est pas celui prévu, création systématique d'une nouvelle phase

Oqi

Modification interdite

- du poids ou du diamètre restant en réintégration de bobines (A3[1] = R)

- de la quantité restante en réintégration de palettes (A3[1] = R)

Orc

Reliquat de consommation prévisionnelle de l'OF

Utilisée si consommation des bobines (A3[1] = S/C) ou des palettes (A3[1] = C)

Oro

Pas de RAZ du numéro d'OF - Utilisée si consommation des bobines (A3[1] = S/E/C) ou des palettes (A3[1] = C)

Si cette option n'est pas activée, le numéro d'OF est initialisé à chaque fois que celui-ci doit être saisi.

Si elle est activée, le numéro d'OF est initialisé une seule fois au lancement du programme.

Osd

Saisie de la date des mouvements de stocks

Osr

Pas de mise à jour du stock résultant

Otf

Tâche de fond, permet une alimentation automatique à partir d'un fichier

Voir les notes pour l'alimentation à partir d'un fichier.

Valeur alpha 2

A2[1,60]

Nom du fichier trace - Obligatoire si option Omt

Exemples

trace_s_e_bob_cab_cons (A3[1] = S/C)

trace_s_e_bob_cab_reint (A3[1] = E/R)

trace_s_e_bob_cab_trsft (A3[1] = T)

trace_s_e_pal_cab_cons (A3[1] = C)

trace_s_e_pal_cab_reint (A3[1] = R)

trace_s_e_pal_cab_trsft (A3[1] = T)

Valeur alpha 3

A3[1] | Type de saisie - Obligatoire S Consommation des bobines E Réintégration des bobines T Transfert des bobines ou des palettes sur le magasin de consommation C Consommation des bobines ou des palettes sur le magasin de consommation R Réintégration des bobines ou des palettes sur le magasin de stockage
A3[2] | Type de mouvement de sortie normale de stock de papier utilisé Obligatoire si consommation des bobines (A3[1] = S) ou transfert des bobines (A3[1] = T) 1 Celui de la bobine 2 Celui du paramètre de lancement
A3[3,5] | Type de mouvement de stock de sortie normale de papier Obligatoire si consommation des bobines (A3[1] = S) ou transfert des bobines (A3[1] = T) et type de mouvement de stock de sortie normale de papier utilisé à 2. Exemple : SM
A3[6,8] | Type de mouvement de stock de sortie normale de bobine Obligatoire si consommation des bobines (A3[1] = S) ou transfert des bobines (A3[1] = T) Exemple : BSC
A3[9] | Type de mouvement d'entrée normale de stock de papier utilisé - Obligatoire si réintégration des bobines (A3[1] = E/R) 1 Celui de la bobine 2 Celui du paramètre de lancement
A3[10,12] | Type de mouvement de stock d'entrée normale de papier Obligatoire si réintégration des bobines (A3[1] = E/R) et type de mouvement de stock d'entrée normale de papier utilisé à 2 Exemple : EM
A3[13,15] | Type de mouvement de stock d'entrée normale de bobine Obligatoire si réintégration des bobines (A3[1] = E/R) Exemple : BER
A3[16,18] | Type de mouvement de stock de reliquat de consommation prévisionnelle de l'OF Obligatoire si consommation des bobines (A3[1] = S/C) et option Orc Exemple : CPP
A3[19,21] | Magasin de consommation des bobines par défaut Obligatoire si transfert des bobines (A3[1] = T) Exemple : CON
A3[22] | Type de mouvement de stock d'entrée normale de consommation de papier utilisé Obligatoire si transfert des bobines (A3[1] = T) 1 Celui de la bobine 2 Celui du paramètre de lancement Exemple : 2
A3[23,25] | Type de mouvement de stock d'entrée normale de consommation de papier Obligatoire si transfert des bobines (A3[1] = T) et type de mouvement de stock d'entrée normale de consommation de papier utilisé à 2 Exemple : EMC
A3[26,28] | Type de mouvement de stock d'entrée normale de consommation de bobine Obligatoire si transfert des bobines (A3[1] = T) Exemple : EBC
A3[29,31] | Magasin de stockage des bobines par défaut Obligatoire si réintégration des bobines (A3[1] = R) Exemple : STK
A3[32] | Type de mouvement de stock de sortie normale de consommation de papier utilisé Obligatoire si consommation des bobines (A3[1] = C) ou réintégration des bobines (A3[1] = R) 1 Celui de la bobine 2 Celui du paramètre de lancement Exemple : 2
A3[33,35] | Type de mouvement de stock de sortie normale de consommation de papier Obligatoire si consommation des bobines (A3[1] = C) ou réintégration des bobines (A3[1] = R) et type de mouvement de stock de sortie normale de consommation de papier utilisé à 2 Exemple : SMC
A3[36,38] | Type de mouvement de stock de sortie normale de consommation de bobine Obligatoire si consommation des bobines (A3[1] = C) ou réintégration des bobines (A3[1] = R) Exemple : SBC
A3[39] | Type de sortie-entrée par défaut - Facultatif B Sortie-Entrée des bobines (Valeur par défaut) P Sortie-Entrée des palettes

Valeur alpha 4

A4[1,3]

Type de mouvement de stock de sortie normale du magasin de stockage des palettes

Obligatoire si transfert des palettes (A3[1] = T)

Exemple : SMS

A4[4,6]

Type de mouvement de stock d'entrée normale du magasin de consommation des palettes

Obligatoire si transfert des palettes (A3[1] = T)

Exemple : EMC

A4[7,9]

Magasin de consommation des palettes par défaut

Obligatoire si transfert des palettes (A3[1] = T)

Exemple : CON

A4[10,12]

Type de mouvement de stock de sortie normale du magasin de consommation des palettes

Obligatoire si consommation des palettes (A3[1] = C)

Exemple : SMC

A4[13,15]

Type de mouvement de stock de reliquat de consommation prévisionnelle de l'OF

Obligatoire si consommation des palettes (A3[1] = C) et option Orc

Exemple : CPP

A4[16,18]

Type de mouvement de stock de sortie normale du magasin de consommation des palettes

Obligatoire si réintégration des palettes (A3[1] = R)

Exemple : SMC

A4[19,21]

Type de mouvement de stock d'entrée normale du magasin de stockage des palettes

Obligatoire si réintégration des palettes (A3[1] = R)

Exemple : EMS

A4[22,24]

Magasin de stockage des palettes par défaut

Obligatoire si réintégration des palettes (A3[1] = R)

Exemple : STK

A4[25]

Saisie de l'emplacement en transfert des palettes (lieu2) (O/N, N par défaut)

! cette option n'est pas valable pour le transfert des bobines car le lieu 2 contient la laize.

A4[26,31]

Emplacement par défaut – Obligatoire

A4[32,34]

Type de mouvement de stock de sortie d'éclatement de la palette

Voir remarque ci-dessous

A4[35,37]

Type de mouvement de stock d'entrée d'éclatement de la palette

Lors de la consommation partielle d'une palette, il faut éclater la palette en différents mouvements de stocks.

Exemple

1 palette de 3000 feuilles.

Vous consommez 1000 feuilles.

Les mouvements suivants sont générés :

1 sortie éclatement de 3000 feuilles

1 entrée éclatement de 2000 feuilles (3000 – 1000)

1 entrée éclatement de 1000 feuilles

1 sortie consommation de 1000 feuilles affectée au dossier sur laquelle vous avez consommé la palette.

Notes

CONFIG_RECEP_BOBINE

21,26 Type et code paramètre de la configuration de la réception des bobines et des palettes - Facultatif

#CFBOB par défaut

LISTE_RGT_CONSO

21,23 Lieux de consommation autorisés

Utilisé si :

Transfert des bobines ou des palettes (A3[1] = T)

Consommation des bobines ou des palettes (A3[1] = C)

Exemple : CON

LISTE_RGT_STOCK

21,23 Lieux de stockage autorisés

Utilisé si réintégration des bobines ou des palettes (A3[1] = R)

Exemple : STK

MULTIOF_CODE_PHASE

21,60 Code phase sous la forme : /a/aaaaa

_SUP_REQ_AUTRE_PAP

21,60 Supplément de requête sur la table des mouvements de stock (stk0) permettant d'isoler les mouvements de réserve sur papier des autres réserves créées par la génération des dossiers - Facultatif

Utilisé si consommation des bobines ou des palettes (A3[1] = C) et option Orc

Le but est de permettre l'annulation et la recréation des réserves papier (Gestion des reliquats) dans le cas où le papier utilisé n'est pas le même que le papier prévu (Attention, la nouvelle réserve de papier sera générée sur le code papier prévu et non pas sur celui utilisé pour la production).

Exemples :

_SUP_REQ_AUTRE_PAP and s0_prod in (select mp_code

_SUP_REQ_AUTRE_PAP from mat

_SUP_REQ_AUTRE_PAP where mp_soc = s0_soc

_SUP_REQ_AUTRE_PAP and mp_anu = "N"

_SUP_REQ_AUTRE_PAP and mp_fam = "PAP")

_SUP_REQ_PAP_BOBINE

Supplément de requête sur la table des papiers des bobines (mat) permettant de contrôler le papier de la bobine

Exemple

_SUP_REQ_PAP_BOBINE and mp_fam = "PPO"

_SUP_REQ_PAP_PALETTE

Supplément de requête sur la table des papiers des palettes (mat) permettant de contrôler le papier de la palette

Exemple

_SUP_REQ_PAP_PALETTEand mp_fam = “PPO”

Notes pour l'alimentation automatique à partir d'un fichier

Ces notes nécessitent l'option Otf (tâche de fond).

ATTENTE_LIB_SERVICE | 21,24 Temps en secondes d'attente de libération du verrou du programme externe
ATTENTE_LIB_VSW | 21,24 Temps d'attente pour libérer le verrou du programme Volume
FICHIER_LOCK_SERVICE | 21,60 Nom du fichier de lock du programme externe
FICHIER_LOCK_VS | 21,60 Nom du fichier de lock Volume Software
FICHIER_TRACE | 21,60 Fichier de trace
FICHIER_ERREUR | 21,60 Fichier des erreurs
FICHIER_UNICITE_EXE | 21,60 Nom du fichier qui garantit l'exécution d'un seul programme à la fois
NOM_FIC | 21,60 Nom du fichier à traiter Un astérisque dans le nom du fichier indique que l'on prend tous les fichiers qui commencent par les caractères situés avant l'astérisque. Une fois traités, les fichiers sont déplacés dans le répertoire historisé.
REP_FIC | 21,60 Répertoire où se situe le fichier à charger pour l'alimentation du module
REP_HIS | 21,60 Répertoire où doit être déplacé le fichier une fois traité
EMPL_AUTORISE | 21,60 Liste les emplacements d'entrés autorisés pour mouvementer les bobines du magasin d'origine au magasin de consommation. Un emplacement par note. Note obligatoire si le type de saisie est T (A3[1]=T) Exemple EMPL_AUTORISE A81_B_1 EMPL_AUTORISE AB1_B_2


Gestion de la réception des bobines

Lors de la réception des bobines, le lieu de rangement 1 est automatiquement renseigné selon le type de papier et la laize de la bobine.

Le ou les magasins sont utilisés comme emplacement mono-référence.

Chaque magasin ne peut contenir qu'un type de papier et une quantité maximum de bobines.

Le type de papier peut être affecté à plusieurs magasins.

Cette option affecte un lieu de stockage selon la quantité disponible de chaque magasin.

Quand un magasin est plein, il passe au suivant.

Quand tous les magasins sont pleins, il affectera un magasin par défaut sans contrôle de quantité.

Nota : lors de l'affectation ou de la désaffectation d'un lieu, aucun mouvement de stock n'est généré.

Vous devez le faire manuellement.

Remarque : si vous affectez un magasin qui a du stock d'une autre bobine et si vous n'avez pas fait les mouvements de stock, celui-ci sera ignoré lors de la réception des bobines.

Gestion de la réception des bobines r_bob

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action : consultation Caractères 3 et suivants : numéro de série du bon de réception Exemple : -N[edr_serial]
-NG | Action : création Caractères 3 et suivants : numéro de série du bon de réception Exemple : -NG[edr_serial]
-D | le -N et le -NG peuvent être suivis de la date du bon de réception, précédée par un -D, sur la même ligne. Exemples : -N[edr_serial]-D[s0_datm] -NG[edr_serial]-D[s0_datm]

Valeurs numériques

1 | Heure de début de faction (en heures / minutes)
2 | Poids maximum autorisé

Options triées

Obm | Contrôle bloquant sur la date du mouvement qui doit être comprise dans le mois en cours
Ocb | Contrôle de date bloquant
Ocs | Mode consultation
Oe1 | Edition d'étiquettes sur les bobineaux (paramètre spécifique)
Oe2 | Edition d'étiquettes sur les bobineaux (paramètre spécifique)
Oel | Lancer l'édition des étiquettes à chaque ligne
Oep | Permettre l'entrée en stock du papier associé
Of7 | Lors de l'interrogation, limiter la liste aux papiers du fournisseur et numéro de BRU Voir alpha2[2,7] et les notes commençant par RACINE_PAPIER
Ofp | Contrôle de la date de saisie par rapport à la date de TOP fin de période
Ogb | Gestion du magasin bobine en carré + d'info Voir aussi : les notes MAG_SURSTOCK et SUP_REQ_SEL_BOB_STK le même paramétrage dans le programme de réception de bobine par code à barres (option Ogb et notes MAG_SURSTOCK et SUP_REQ_SEL_BOB_STK) la nouvelle visu v_lieu_rgt la note CTRL_DOUBLON_RGT dans la saisie des articles / matières / produits
Ogs | Type gestion stock sur papier bobine par défaut sinon papier réel
Oib | Interrogation des BRU par numéro
Ol1 | Laize bobine en cm au lieu de mm
Olb | Lot initialisé avec le numéro du BRU sinon à blanc
Olz | Stockage de la laize de la ligne de bobine dans le lieu de rangement de niveau 2 du mouvement de stock
Omr | Edition du métrage linéaire restant sur les étiquettes (paramètre spécifique)
Op1 | Poids bobine en kg au lieu de tonne
Opr | Edition du poids restant sur les étiquettes (paramètre spécifique)
Orl | Recopie des lieux en F13 sur les bobines
Osr | Pas de mise à jour du stock résultant des mouvements de stock
Ove | Active l'édition VoluEdit des étiquettes
Owm | Contrôle warning si la date n est pas dans le mois en cours

Valeur alpha 2

Paramétrage saisie des réceptions de bobine

Caractère 1 | Type de recherche articles 1 Code fournisseur de l'article 2 Code fournisseur des libellés spécifiques
Caractères 2 à 7 | Racine de l'article bobine - (obligatoire si option Of7) Voir alpha2[34] ==> Mode de codification des bobines Exemple BOB ou BOBINE
Caractères 8 à 9 | Longueur de la racine de l'article bobine Voir alpha2[34] ==> Mode de codification des bobines Exemple BOB + AAMM (Racine) + 99 (Folioteur) 07 BOB + No BRU (Racine) + 99 (Folioteur) 11 BOB (Racine) + 9999 (Folioteur) 03
Caractères 10 à 11 | Longueur du folioteur de l'article bobine Voir alpha2[34] ==> Mode de codification des bobines Exemple BOB + AAMM (Racine) + 99 (Folioteur) 02 BOB + No BRU (Racine) + 99 (Folioteur) 02 BOB (Racine) + 9999 (Folioteur) 04
Caractères 12 à 14 | Type de mouvement d'entrée normale de stock de bobine
Caractères 15 à 17 | Code libellé d'affichage dans le tableau papier 001 Libellé étranger si saisi. Sinon, libellé article + largeur saisie sur la fiche article
Caractère 18 | Code compteur K Compteur BRU H Compteur BRC
Caractères 19 à 33 | Code article bobine par défaut pour les créations de bobines (Exemple 000000000000BOB)
Caractère 34 | Mode de codification des bobines 1 Racine + AAMM + Folioteur 2 Racine + Numéro BRU + Folioteur 3 Racine + Folioteur 4 Codification manuelle (on garde quand même la racine)
Caractère 35 | Edition des bons avec demande de confirmation T Toujours J Jamais C En création M En modification N On ne lance pas l'édition
Caractère 36 | Edition des étiquettes avec demande de confirmation T Toujours J Jamais C En création M En modification N On ne lance pas l'édition
Caractère 37 | Contrôle unicité de la référence bobine chez le fournisseur N Non O Oui (Saisie en cours + Fichier articles) B BRU (Saisie en cours)
Caractère 38 | Mode de gestion des lieux de rangement 1 Lieu de rangement pris sur le papier réel 2 Lieu de rangement pris sur le paramètre de lancement
Caractères 39 à 41 | Lieu de rangement 1 par défaut (obligatoire si le mode de gestion du lieu est 2)
Caractères 42 à 47 | Lieu de rangement 2 par défaut
Caractères 48 à 53 | Lieu de rangement 3 par défaut
Caractère 54 | Type de libellé bobine 1 Libellé papier réel fournisseur 2 Libellé spécifique du papier réel fournisseur
Caractère 55 | Contrôle de la laize saisie par rapport au paramètre LAI (laizes standards) N Pas de contrôle W Warning si contrôle non bloquant B Contrôle bloquant
Caractères 56 à 57 | Contrôle du lieu de rangement 3 [blanc] = Pas de contrôle 01 Contrôle de l'emplacement physique de la bobine 02 Contrôle du dépassement de capacité du plot de bobines
Caractères 58 à 59 | Niveau maxi du lieu de rangement 3 01 à 99

Valeur alpha 3

Titre de l'écran papier. Le titre est centré par le programme.

Valeur alpha 4

Titre de l'écran bobine. Le titre est centré par le programme.

Notes

Tous les titres sont automatiquement centrés par le programme.

E1T1 | 5 à 19 Titre de la colonne Code papier (Code papier par défaut)
E1T2 | 5 à 54 Titre de la colonne Libellé (Libellé fournisseur par défaut)
E1T3 | 5 à 7 Titre de la colonne NB. de bobines (Bob par défaut)
E1T4 | 5 Titre de la colonne Ligne rapprochée (R par défaut)
E2T1 | 5 à 19 Titre de la colonne Code bobine (Numéro bobine par défaut)
E2T2 | 5 à 12 Titre de la colonne Poids (Poids par défaut)
E2T3 | 5 à 24 Titre de la colonne Référence bobine (No bobine fourn par défaut)
E2T4 | 5 à 12 Titre de la colonne Laize (Laize par défaut)
E2T5 | 5 à 19 Titre de la colonne Numéro de lot (Numéro lot par défaut)
E2T6 | 5 Titre de la colonne Ligne sortie (S par défaut)
CR | 5 à 60 Complément de sélection Ce complément de sélection dépend du type de recherche d'articles (alpha2[1]). Si alpha2[1] = 1 (Code fournisseur de l'article) : table mat Si alpha2[1] = 2 (Code fournisseur des libellés spécifiques) : tables mat et lib_etr Exemples : (1) CR and mp_code not matches BOB* CR and mp_fam != BOB (2) CR and le_prod not matches BOB*
MAG_SURSTOCK | 21,23 Lieu de rangement 1 Magasin par défaut si tous les magasins affectés au code papier son plein. (obligatoire si option Ogb)
RACINE_PAPIER | 21, 26 Racine des codes articles papiers (obligatoire si option Of7)
_SUP_REQ_RECH_PAP | 21,60 Complément de sélection sur la table des articles pour la recherche des papiers
SUP_REQ_SEL_BOB_STK | 21,60 Complément de requête sur stk0 pour les bobines Permet de vérifier dans les stocks s'il n'y a pas un autre produit dans l'emplacement. Si un autre article est présent dans le lieu de stockage, celui-ci sera ignoré. (obligatoire si option Ogb) Note cumulative
TYP_MVT_STK_ENT_PAP | 21, 23 Type de mouvement d'entrée normale pour le papier

Edition des étiquettes bobines

Pour une édition des étiquettes bobines, on utilise le catalogue étiquette de production, la concordance des champs est indiquée ci-dessous.

Table etiqprod | Equivalent
etp_soc | societe
etp_id_etiq | num_suiv("V")
etp_num_etiq_flot | 1
etp_max_etiq_flot | 1
etp_type_etiq | B
etp_origine_etiq | RBO
etp_modele_etiq | BOB
etp_nb_copie_etiq | 1
etp_num_cde | numero_bru
etp_lig_cde | 0
etp_num_bl_rec | numero_bru
etp_soc_emet | #SOC
etp_adr_emet |
etp_code_tiers | p_cl.cl_code
etp_code_ens | tab_bobine[enr_tab_bobine].code_bobine
etp_libelle_ens | tab_bobine[enr_tab_bobine].ref_bobine
etp_ref_ens_tiers | p_mp_pap_reel.mp_code
etp_lib_ens_tiers | p_mp_pap_reel.mp_code
etp_code_pf | tab_bobine[enr_tab_bobine].code_bobine
etp_libelle_pf | tab_bobine[enr_tab_bobine].ref_bobine
etp_ref_pf_tiers | p_mp_pap_reel.mp_code
etp_lib_pf_tiers | p_mp_pap_reel.mp_des
etp_longueur_pf | tab_bobine1[enr_tab_bobine].ml_bobine
etp_largeur_pf | tab_bobine[enr_tab_bobine].laize_bobine
etp_poids_brut_pf | tab_bobine[enr_tab_bobine].poids_bobine
etp_specif_1 | specif
etp_date_creation | date_bru


Gestion de la sortie des bobines

Seuls les enregistrements ayant le statut à A sont traités.

Si une erreur est rencontrée, le statut passera à E et le code erreur sera renseigné (Voir liste des codes erreurs ci-dessous).

Si aucune erreur n’a été rencontrée, une sortie de la bobine et une sortie du papier de la bobine seront générées et le statut passera à T.

L'option Oin doit être positionnée. Tester avec l'option Osi.

L'option Omr ou Opr est obligatoire.

L'option Osn est interdite.

Voir aussi le programme d'intégration des sorties de bobines (integrer_edi_stk_bob).

Liste des codes erreurs

001 Bobine inexistante

002 Bobine annulée

003 Bobine non suivie en stock

004 Bobine consommée entièrement

005 Papier de la bobine non renseigné

006 Papier inexistant

007 Papier annulé

008 Papier non suivi en stock

009 Papier consommé entièrement

010 Poids bobine restant > Poids bobine physique

011 Métrage bobine restant > Métrage bobine physique

012 Poids sortie > Stock physique papier

013 Longueur sortie > Stock physique papier

Gestion de la sortie des bobines s_bob

Nouvelle fonction d'intégration de la table EDI des sorties des bobines (edi_stk_bobine) en mode interactif (menu) ou en mode Batch

Valeur numérique 1

Heure de début de faction (en Heures / minutes)

Options triées

-B | Mode batch
Oar | Annulation des réserves bobines et papiers générées par g_bob
Obm | Contrôle bloquant sur la date du mouvement qui doit être comprise dans le mois en cours
Ocb | Contrôle de date bloquant
Ocw | Contrôle de date warning
Odj | Sortie bobines à la date du jour (sinon à la date d'hier)
Ofp | Contrôle de la date de saisie par rapport à la date de TOP fin de période
Ogb | OPTION SUPPRIMEE CAR OBLIGATOIRE DANS TOUS LES CAS Gestion de bobineaux
Oin | Intégration de la table EDI des sorties des bobines (edi_stk_bobine)
Omr | Saisie d'un métrage linéaire restant (obligatoire avec Osm)
Onp | En consommation de bobines, création d'une nouvelle phase OF si l'article consommé est différent de l'article de l'OF.
Opa | Prix de l'entrée et de la sortie papier au prix de la ligne de commande d'achat
Opb | Prix de la sortie normale du papier au prix de la bobine
Opr | Saisie d'un poids restant au lieu d'un diamètre restant
Ops | Lors de la consommation d'une bobine, si le papier n'est pas celui prévu, création systématique d'une nouvelle phase
Ora | En création, recopie de l'affectation de la ligne précédente
Orc | Reliquat de consommation prévisionnelle de l'OF (Papier) Voir A2[53,55] Voir aussi la note _SUP_REQ_AUTRE_PAP Incompatible avec l'option Osm.
Orl | Recherche de la longueur réelle de la bobine
Orp | Recherche du poids réel de la bobine au moment de la sortie
Osi | Simulation
Osm | Saisie de sorties de bobines multi-OF Incompatible avec l'option Orc.
Osn | Sorties négatives de bobines
Osr | Pas de mise à jour du stock résultant des mouvements de stock
Ove | Active l'édition VoluEdit des étiquettes
Owm | Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Valeur alpha 2

Paramétrage saisie des sorties des bobines

Caractère 1 | Type de mouvement de sortie normale de stock de papier utilisé 1 Celui de la bobine 2 Celui du paramètre de lancement
Caractères 2 à 4 | Type de mouvement de sortie normale de stock de papier Obligatoire si le type de mouvement de sortie normale de stock de papier utilisé est égal à 2
Caractère 5 | Type de mouvement d'entrée normale de stock de papier utilisé 1 Celui de la bobine 2 Celui du paramètre de lancement SERT POUR LES TRANSFERTS DES BOBINES
Caractères 6 à 8 | Type de mouvement d'entrée normale de stock de bobine SERT POUR LES TRANSFERTS DES BOBINES
Caractères 9 à 11 | Type de mouvement d'entrée normale de stock de papier (Obligatoire si le type de mouvement d'entrée normale de stock de papier utilisé est égal à 2) SERT POUR LES TRANSFERTS DES BOBINES
Caractères 12 à 15 | Diamètre du mandrin. Obligatoire
Caractères 16 à 22 | Densité de la bobine au format NNNNDDD (NNNN = partie entière et DDD = partie décimale) - Obligatoire Ne mettez pas de virgule, le programme divise la valeur paramétrée par 1000.
Caractères 23 à 25 | Type de mouvement de sortie normale de stock de bobine par défaut
Caractère 26 | Saisie code visa obligatoire (O/N, pas de valeur par défaut)
Caractères 27 à 28 | Contrôle du lieu de rangement 3 [blanc] = Pas de contrôle 01 = Contrôle de l'emplacement physique de la bobine 02 = Contrôle de la capacité d'un plot
Caractères 29 à 30 | Niveau maxi du lieu de rangement 3 : 01 à 99
Caractères 31 à 33 | Famille par défaut (Exemple BOB)
Caractères 34 à 36 | Type de mouvement de sortie normale de stock de papier SERT POUR LES TRANSFERTS DES BOBINES
Caractères 37 à 39 | Code type de mouvement de réception bobine pour retrouver le N° de bon de réception
Caractères 40 à 52 Caractères 40 à 46 Caractères 47 à 48 Caractères 49 à 50 Caractère 51 Caractère 52 | Permet de refendre une bobine en plusieurs bobineaux UNIQUEMENT SOUS GENERO Racine pour création code bobine Longueur racine Longueur folioteur Mode codification de la bobine Type libellé bobine 1 libellé du papier réel fournisseur 2 libellé spécifique du papier réel fournisseur
Caractères 53 à 55 | Type de mouvement de reliquat de consommation prévisionnelle de l'OF Obligatoire si option Orc Le type de mouvement de stock doit être une sortie réserve.
Caractère 56 | Vérification que le code papier et la laize issue de la bobine sont bien les mêmes que ceux issus de l'OF sélectionné (N/W/C/B, N par défaut)
Caractère 57 | Numéro de formule de conversion à utiliser pour convertir la quantité de bobine en quantité de papier (1 à 4) Facultatif

Valeur alpha 3

Titre de l'écran des sorties des bobines (saisie) - centré automatiquement

Valeur alpha 4

Titre de l'écran des sorties des bobines (annulation) - centré automatiquement

Notes triées

BOB_DEC_MVT_ENT_PAP

21,23 Type de mouvement d'entrée papier pour la découpe de bobines

BOB_DEC_MVT_SOR_PAP

21,23 Type de mouvement de sortie papier pour la découpe de bobines

BOB_REF_MVT_ENT_BOB

21,23 Type de mouvement d'entrée bobine pour la refente de bobines

BOB_REF_MVT_ENT_PAP

21,23 Type de mouvement d'entrée papier pour la refente de bobines

BOB_REF_MVT_SOR_PAP

21,23 Type de mouvement de sortie papier pour la refente de bobines

E1T1

5,19 Titre colonne Code bobine (Numéro bobine par défaut)

E1T2

5,7 Titre colonne TMV (TMV par défaut)

E1T3

5,14 Titre colonne Libellé (Libellé par défaut)

E1T4

5,12 Titre colonne Date de sortie (Date par défaut)

E1T5

5,30 Titre colonne Affectation (Affectation par défaut)

E1T6

5,14 Titre colonne Diamètre restant (Reste par défaut)

CR

5,60 Complément de requête sur stk0, mat, lib_etr

HEURE_DEBUT_JOURNEE

21,24 Heure de début de journée. Exemple : 0500

MVT_ENT_BOB_TRS_ANN

21,23 Type de mouvement d'entrée de stock bobine pour le transfert lors d'une annulation de mouvement de consommation

MVT_ENT_PAP_TRS_ANN

21,23 Type de mouvement d'entrée de stock papier pour le transfert lors d'une annulation de mouvement de consommation

MVT_SOR_BOB_TRS_ANN

21,23 Type de mouvement de sortie de stock bobine pour le transfert lors d'une annulation de mouvement de consommation

MVT_SOR_PAP_TRS_ANN

21,23 Type de mouvement de sortie de stock papier pour le transfert lors d'une annulation de mouvement de consommation

_SUP_REQ_AUTRE_PAP

21,60 Complément de sélection permettant d'isoler les mouvements de réserves sur papier des autres réserves créées par la génération des dossiers (porte sur la table stk0 et doit commencer par un and)

Voir l'option Orc.

Le but de ce développement complémentaire est de permettre l'annulation et le recréation des réserves papier (gestion des reliquats) dans le cas où le papier utilisé n'est pas le même que le papier prévu (attention, la nouvelle réserve de papier sera générée sur le code papier prévu et non pas sur celui utilisé pour la production).

Exemples

_SUP_REQ_AUTRE_PAP and s0_prod in (select mp_code

_SUP_REQ_AUTRE_PAP from mat

_SUP_REQ_AUTRE_PAP where mp_soc = s0_soc

_SUP_REQ_AUTRE_PAP and mp_anu = "N"

_SUP_REQ_AUTRE_PAP and mp_fam = "PAP")

_SUP_REQ_EDI_STK_B

21,60 Complément de requête sur la table edi_stk_bobine. Cette note est cumulative.

Via l'option Oin, on intègre les sorties des bobines enregistrées dans la table edi_stk_bobine dans les mouvements de stock. Celle-ci étant alimentée via l'EDI escala. Jusqu'à présent il n'était pas possible d'ajouter un complément de requête sur la table edi_stk_bobine. Maintenant via paramétrage on peut en ajouter un.

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note est prioritaire sur celle du paramètre USE.

_SUP_REQ_RECH_BOB

21,60 Complément de sélection sur la table des articles pour la recherche des bobines (N° interne)

_SUP_REQ_RECH_FOU

21,60 Complément de sélection sur la table des clients pour la recherche des fournisseurs

_SUP_REQ_RECH_PAP

21,60 Complément de sélection sur la table des articles pour la recherche des papiers

_SUP_REQ_TYPE_MVT

21,60 Complément de sélection sur le type de mouvement

Remarque

La saisie de l'affectation et du diamètre restant dépend du paramètre TMV, alpha2[12]

1 | Sortie pour consommation onduleuse. Saisie affectation (Heure - Minute - Lanceur - Visa) Heure 00 à 24 Minute 00 à 59 Code lanceur Type paramètre LNC Code visa Type paramètre VIS Saisie diamètre restant
2 | Mise au rebut Pas d'affectation ni de diamètre restant
3 | Retour fournisseur Pas d'affectation ni de diamètre restant
4 | Transfert en stock Pas d'affectation ni de diamètre restant
5 | Sortie pour pré-impression chez un sous-traitant Pas d'affectation ni de diamètre restant
6 | Sortie pour consommation par OF Saisie affectation (OF) Saisie diamètre restant
8 | Rebut partiel
9 | Saisie de l'OF et du lanceur


Gestion des entrées des bobineaux

Gestion des entrées de bobineaux e_bob

Options triées

Oae | Affectation de l'entrée bobine avec le numéro de dossier d'affectation de la dernière sortie
Obm | Contrôle bloquant sur la date du mouvement qui doit être comprise dans le mois en cours
Ocb | Contrôle bloquant sur la date
Ocw | Contrôle warning sur la date
Odj | Entrée bobineaux à la date du jour sinon à la date d'hier
Opr | Saisie d'un poids restant au lieu d'un diamètre restant
Osr | Pas de mise à jour du stock résultant des mouvements de stock
Owm | Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Valeur alpha 2

Caractère 1 | Type de mouvement d'entrée normale de stock de papier utilisé 1 Celui de la bobine 2 Celui du paramètre de lancement
Caractères 2 à 4 | Type de mouvement d'entrée normale de stock de papier (obligatoire si le type de mouvement d'entrée normale de stock de papier utilisé est égal à 2)
Caractères 5 à 8 | Diamètre du mandrin. Obligatoire
Caractères 9 à 15 | Densité de la bobine au format NNNNDDD (NNNN = partie entière et DDD = partie décimale) - Obligatoire Ne mettez pas de virgule, le programme divise la valeur paramétrée par 1000.
Caractères 16 à 18 | Type de mouvement d'entrée normale de stock de bobine par défaut
Caractères 19 à 20 | Contrôle du lieu de rangement 3 [blanc] = Pas de contrôle 1 Contrôle de l'emplacement physique de la bobine 2 Contrôle du dépassement de capacité du plot de bobines
Caractères 21 à 22 | Niveau maxi du lieu de rangement 3. 01 à 99
Caractères 23 à 25 | Famille par défaut (Exemple BOB)
Caractères 26 à 28 | Code libellé d'affichage dans le tableau papier 001 Libellé étranger si saisi. Sinon, libellé article + largeur saisie sur la fiche article
Caractère 29 | Bloquer la saisie du champ s0_rgt1 du lieu de rangement de niveau 2 (O/N, N par défaut)
Caractères 30 à 35 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 36 | Confirmation pour l'édition des étiquettes [blanc] Pas de confirmation T Toujours

Valeur alpha 3

Titre de l'écran des entrées des bobineaux (saisie). Le titre est automatiquement centré par programme.

Valeur alpha 4

Titre de l'écran des entrées des bobineaux (annulation). Le titre est automatiquement centré par programme.

Notes

E1T1 | 5 à 19 Titre colonne Code bobineau (Numéro bobineau par défaut)
E1T2 | 5 à 7 Titre colonne TMV (TMV par défaut)
E1T3 | 5 à 14 Titre colonne Libellé (Libellé par défaut)
E1T4 | 5 à 12 Titre colonne Date d'entrée (Date par défaut)
E1T5 | 5 à 30 Titre colonne Affectation (Affectation par défaut)
E1T6 | 5 à 9 Titre colonne Diamètre restant (Reste par défaut)
CR | 5 à 60 Complément de sélection sur les tables mat et lib_etr, introduit par and.

Saisie du diamètre restant

La saisie du diamètre restant dépend de TMV, alpha2[12].

1 | Sortie pour consommation onduleuse
6 | Sortie pour consommation par OF


Gestion des calendriers

Gestion des calendriers cal

Options triées

Ocd | Calcul du disponible sur rl_chc et non rl_chr
Oda | Saisie par date
Omc | Calcule le mois associé à la date saisie en fonction de la date et non plus en fonction de la semaine associée
Omo | Saisie par mois
Ose | Semaine 0 possible
Oss | Saisie par semaine

Valeur alpha 2

Caractères 1 à 60

Paramétrage des colonnes d'édition. Par défaut : ABCDEFMGHIJ

A Code Section

B Code Machine

C Code Postes

D Année

E Mois

F Semaine

G Date

H Potentiel

I Charge calculée

J Charge réalisée

K Charge allouée

L Charge disponible (potentiel - charge réalisée)

M Jour

N Libellé Section

O Libellé Machine

P Libellé Postes

Q Valeur

Valeur alpha 3

Caractère 1

Etiquette du calendrier (# ou N, N par défaut)

# Une fenêtre s'ouvrira systématiquement pour proposer des étiquettes calendriers au choix de 1 caractère ayant été saisies dans le fichier paramètre, avec le type ETI.


Génération du planning de charge à capacité infinie

Génération du planning de charge à capacité infinie gp_ch

Options

-Oim | Planning de charge pour imprimerie
-Ojp | Régénère la charge issue du prévu de fab2 (of/- phase(fab1)) dans le calendrier. A utiliser si un jalonnement a été réalisé via le module périmé j_tps -Ojp
-Osm | Calendrier généré par section / machine
-Osn | Calendrier généré par section
-Otr | Génération de la charge avec le temps restant
-Oja | On génère la charge uniquement sur les dossiers jalonnés
-Ogr | Activation du calcul des temps réalisés. Les temps réalisés sont générés, ainsi que les temps prévus.

Notes

S

Possibilité de saisir un critère de sélection supplémentaire
Par défaut, le calendrier génère par section / machine / opération et pour la mécanique


Etat de la charge

Etat de la charge chg0

La date de sélection est celle saisie en commande dans la zone date de fabrication.


Edition du planning de charge à capacité infinie et finie

Edition du planning de charge à capacité infinie et finie pl_ch

Options

-Ohm | Edition en heures – minutes
-Ogr | Activation du calcul des temps réalisés. Les temps réalisés sont générés, ainsi que les temps prévus.

Valeur alpha 3

Paramétrage de l'étiquette calendrier

Caractère 1

Etiquette du calendrier
Si #, alors une fenêtre s'ouvrira systématiquement pour proposer des étiquettes calendriers au choix de 1 caractère ayant été saisi dans le fichier paramètre, en code paramètre.(type paramètre = ETI)
Si nul, par défaut étiquette = N


Visualisation du planning de charge à capacité infinie et finie

Visualisation du planning de charge à capacité infinie et finie vp_ch

Options

-Oet | Ligne d'étoiles
-Ojp | Recherche les of dont la charge est issue du prévue généré dans fab2 (of/- phase(fab1)) A utiliser si un jalonnement a été réalisé via le module périmé j_tps.4ge et si la génération du planning de charge a été réalisée avec -Ojp.
-Ohm | Edition en heures - minutes
-Ose | Semaine 0 possible
-Osc | Permet d'activer le menu Capacité Finie / Infinie
-Otr | La charge a été générée avec le temps restant
-Ogr | Activation du calcul des temps réalisés. Les temps réalisés sont générés, ainsi que les temps prévus.

Valeur alpha3

Paramétrage de l'étiquette calendrier

Caractère 1

Etiquette du calendrier
Si #, alors systématiquement une fenêtre s'ouvrira pour proposer des étiquettes calendriers au choix de 1 caractère ayant été saisi dans le fichier paramètre, en code paramètre.(type paramètre = ETI)
Si nul, par défaut étiquette = N


Saisie et édition des éléments de base du plan directeur

Saisie et édition des éléments de base du plan directeur s_pld

Options

-Oar | Arrondi à la quantité supérieure sans précision
-Obm | Génération des besoins matières brut
-Ocd | Contrôle si la date saisie appartient à l'exercice et sinon oblige la saisie d'une date de l'exercice
-Ogv | Gestion gâche fixe (Spécifique O)
-Ohh | Calendrier (jalonnement) niveau (section / machine) (par défaut niveau (section / machine / opération))
-Oii | Calendrier (jalonnement) niveau (section) (par défaut niveau (section / machine / opération))
-Ojp | Génération de la charge en capacité infinie
-Ose | Semaine 0 possible ### plus possible
-Ovi | Permet de visualiser les coûts M.O. intermédiaire de chaque niveau, avec arrêt
-Ovv | On ne génère que la 1ère ligne de commande et on supprime dans fab0 les autres lignes la première ligne est toujours générée avec le client #SOC et le produit PRODUCTION
-Oxa | Calcul au prix d'achat
-Oxb | Calcul au prix selon le type de valorisation
-Oxr | Calcul au prix de revient
-Oxv | Calcul au prix de vente
-Oil | Ignore la multiplication du prix de l'article par la longueur et largeur
-Opn | Pas de contrôle sur l'existence du couple produit / client dans la nomenclature

Valeur alpha2

(paramétrage des colonnes d'éditions)

Par défaut ABCDEF

A | Code étiquette (ETI) d'un caractère de 1 à 9
B | Année d'exercice sur 2 caractères
C | Code client (Par défaut #SOC)
D | Code article
E | Date d'exigibilité du produit fini
F | Quantité de produit fini
G | Désignation article (issue du fichier article)
H | Stock minimum en unité d'utilisation (UU)
I | Stock maximum en unité d'utilisation (UU)
J | Stock disponible en unité d'utilisation (UU)
K | Stock physique en unité d'utilisation (UU)
L | Stock réserve en unité d'utilisation (UU)
M | Stock en commande en unité d'utilisation (UU)
N | Stock minimum en unité d'achat (UA)
O | Stock maximum en unité d'achat (UA)
P | Stock disponible en unité d'achat (UA)
Q | Stock physique en unité d'achat (UA)
R | Stock réserve en unité d'achat (UA)
S | Stock en commande en unité d'achat (UA)
T | Code formule de conversion (FOR) UU --> UA
U | Code unité d'achat (UNI)
V | Code unité d'utilisation (UNI)
W | Hauteur
X | Format (longueur x largeur)
Y | g/m2 (grammage ou poids)


Edition du plan d'achat

Edition du plan d'achat e_pla

Options

-Ofa | En plus des composants achetés, on édite aussi les composants fabriqués
 | (5ème zone paramétrée de la fiche article)

Valeur alpha2

(paramétrage des colonnes d'éditions)

Par défaut ABFDGECHI

A | Code étiquette (ETI) d'un caractère de 1 à 9
B | Année d'exercice sur 2 caractères
C | Code client (par défaut #SOC)
D | Code article
E | Date d'exigibilité du produit fini
F | Code matière
G | Date d'exigibilité de la matière
H | Quantité de matière
I | Valeur de la matière
J | Désignation du composant
K | Hauteur du composant
L | Format (longueur x largeur) du composant
M | g/m2 (grammage ou poids) du composant
N | Quantité de matière dans l'unité d'achat
O | Code formule de conversion (FOR) UU --> UA
P | Code unité d'achat (UNI)
Q | Code unité d'utilisation (UNI)
R | Prix achat
S | Prix achat dans l'unité d'utilisation
T | Valeur TTC
U | Code T.V.A. (TVA)

Valeur alpha3

Gestion des colonnes de tri pour l'édition

1 | CODE MATIERE
2 | CODE ARTICLE
3 | DATE D'eXIGIBILITÉ DE LA MATIERE
4 | DATE D'eXIGIBILITÉ DE L'aRTICLE
5 | CODE CLIENT)

Caractères 1 à 5 | Ordre du tri des colonnes (par défaut 13245) Valeur autorisée 1, 2, 3, 4, 5, N, 0, 5, 10 Exemple 2N1N3 Ordre du tri Caractère 1 CODE MATIERE 2 Caractère 2 CODE ARTICLE N Caractère 3 DATE D'eXIGIBILITÉ DE LA MATIERE 1 Caractère 4 DATE D'eXIGIBILITÉ DE L'aRTICLE N Caractère 5 CODE CLIENT 3 Cela signifie que l'on éditera par Caractère 3 DATE D'eXIGIBILITÉ DE LA MATIERE 1 Caractère 1 CODE MATIERE 2 Caractère 5 CODE CLIENT 3
Caractères 11 à 15 | Edition des totaux ? (O/N) (par défaut ONNNN) 10 15 20 Exemple ONNNN Ligne totale 11: 1 CODE MATIERE O 12: 2 CODE ARTICLE N 13: 3 DATE D'eXIGIBILITÉ DE LA MATIERE N 14: 4 DATE D'eXIGIBILITÉ DE L'aRTICLE N 15: 5 CODE CLIENT N Cela signifie que l'on éditera une ligne totale pour 11: 1 CODE MATIERE O
Caractères 21 à 25 | Saut de page à la rupture tri ? (O/N) (par défaut NNNNN) 20 25 30 Exemple NNNNN Saut de page 21: 1 CODE MATIERE N 22: 2 CODE ARTICLE N 23: 3 DATE D'eXIGIBILITÉ DE LA MATIERE N 24: 4 DATE D'eXIGIBILITÉ DE L'aRTICLE N 25: 5 CODE CLIENT N

Cela signifie qu'il n'y a pas de saut de page lié au rupture de tri.


Edition du plan directeur

Edition du plan directeur e_pld

Valeur alpha2

Caractères 1 à 20 | Paramétrage colonnes d'éditions tableau Matière. Par défaut AGCDFJ
Caractères 21 à 40 | Paramétrage colonnes d'éditions tableau Opérations. Par défaut BHCEF
Caractères 41 à 60 | Paramétrage colonnes d'éditions tableau Sous-traitance. Par défaut BHCFJ

A | Code matière
B | Code section


Besoins matières : calcul des besoins nets

Besoins matières : calcul des besoins nets cbn

Visualisation des besoins article et des besoins dossier

Edition des besoins article

Options

-Of2

Ouverture automatique de la seconde fenêtre de sélection article


Outil d'alimentation de la table cdf2_ventil

Outil d'alimentation de la table cdf2_ventil outil_cdf2_ventil

Cet outil a été créé dans le cadre de la gestion des besoins matières détaillés par dossier. Voir #CF-ATL A1[44]

Voir la table cdf2_ventil

Options

-B

Mode batch

Notes

_SUP_REQ_CDF1 | 21,60 Supplément de requête sur la table des entêtes de commandes fournisseurs (table cdf1)
_SUP_REQ_CDF2 | 21,60 Supplément de requête sur la table des lignes de commandes fournisseurs (table cdf2)


Affectation des factures de frais d'approche

Affectation des factures de frais d'approche G_fac_frais_appr

Les frais d'approche sont des frais de douane imposés aux articles importés (Frais de transit, frais de débarquement, frais de transport).

La facture fournisseur est saisie normalement.

La facture de frais d'approche est saisie comme une facture fournisseur avec différentes lignes d'articles génériques.

Celle-ci est rattachée à la facture réelle du fournisseur.

La facture de frais d'approche est répartie sur la facture réelle du fournisseur au prorata des montants HT de chaque ligne.

Les frais d'approche sont inclus dans le prix ou dans le montant de frais du mouvement de stock.

Les frais d'approche sont pris en compte dans le prix de revient de la fiche article.

Options

Oip | Montant de frais d'approche intégré au prix du mouvement de stock (s0_prix) Par défaut, le montant de frais d'approche est mis dans le montant de frais du mouvement de stock (s0_frais)
Omf | Marge fixe Par défaut, le pourcentage de marge est recalculé (Le prix de vente est fixe)
Osi | Simulation - Pas de mise à jour de fichier
Osr | Pas de mise à jour du stock résultant

Notes

_RECALCUL_PAMP

PAMP suite à la modification des prix dans les mouvements de stock <VF>

Lors de la facturation des frais d’approche, le prix des mouvements de stock de réception de la matière est modifié pour intégrer ces frais.

Or, le recalcul des prix des mouvements de consommation faits avant la facturation de ces frais n’est pas effectué, ce qui entraîne une erreur lors du calcul du PAMP de la fiche matière concernée.

Pour permettre ce recalcul simplement, on ajoute dans le programme la possibilité d’exécuter le programme crinv (qui modifie les prix de chaque mouvement de transfert ou de sortie en fonction du PAMP en cours de recalcul).

21,26 Type et code du paramètre de lancement du programme de création automatique de mouvement d'inventaire (crinv).

_SUP_REQ_FACFOU0

21,60 Complément de sélection sur la table des entêtes de factures de frais d'approche

Paramètres associés

#CF TRA

A2[1,5] Traçabilité de stk0 (rappel)

A3[11,15] Traçabilité de mat (rappel)

Voir aussi

G_facf | Option Ofa
G_v_jda | Option Ofa Nouvelles zones dans facfou0 : ff0_frais_appr Facture de frais d'approche (O/N) ff0_frais_appr_fac Numéro facture fournisseur rattachée à la facture de frais d'approche ff0_frais_appr_aff Facture de frais d'approche affectée (O/N) ff0_fac_rapprochee Facture fournisseur rapprochée (O/N)


Intégration des factures d'achat SAP vers VoluPack

Intégration des factures d'achat SAP vers VoluPack import_fac_ach_sap

Options

Ofp | Prise en compte du top fin de mois (voir paramètre TOP FIN)
Omf | Marge fixe dans le calcul du prix de vente de la fiche article (ne fonctionne qu'avec l'option Omp)
Omp | Mise à jour du prix d'achat dans la fiche article
Opm | Prise en compte des montants de frais et de perte dans le calcul du prix de revient de la fiche article (ne fonctionne qu'avec l'option Omp)
Osi | Simulation : Pas de mise à jour des tables

Valeur alpha 2

A2[1,3] | Type de mouvement d'entrée en stock si l'article n'est pas contrôlé (ENT par défaut)
A2[4,6] | Type de mouvement d'entrée en stock si l'article est contrôlé (ENT par défaut)

Notes

FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_IMPORT | 21,60 Nom du fichier à importer
FIC_LOCK | 21,60 Nom du fichier de verrouillage général
FIC_LOCK_EXTERNE | 21,60 Nom du fichier de verrouillage externe
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume
FIC_TRACE | 21,60 Nom du fichier trace

Paramètres nécessaires

TOP FIN | Top fin de mois
UNI | Note CORRES_UNA_SAP
TSC .LF | Ligne de commande SAP


Transfert des bons de réception vers SAP

Transfert des bons de réception vers SAP tr_sap_brc

Les BRC doivent obligatoirement être dans les tables de bons de réception.

Il faut donc que l'option Ofr dans le programme de saisie des BRC soit activée.

Les BRC à transférer sont repérés dans les tables de traçabilité tant en création qu'en modification.

Il est donc impératif de paramétrer la traçabilité sur les tables de bons de réception (voir paramétrage ci-dessous).

Options

Osi

Simulation du transfert – Génération du fichier mais pas de mise à jour des BRC transférés.

Notes

FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_EXPORT | 21,60 Nom du fichier d'export
FIC_TRACE | 21,60 Nom du fichier trace
FIC_LOCK | 21,60 Nom du fichier de verrouillage général
FIC_LOCK_EXTERNE | 21,60 Nom du fichier de verrouillage externe
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume

Paramètres nécessaires

#CF TRA | Note TRACABILITE_CHAMP
UNI | Note CORRES_UNA_SAP
TSC .LF | Ligne de commande SAP
TSC MP? | Code matière SAP


v_edi_brc Génération des Bons de réception à partir d'une visu des messages EDI Réception

Options triées

A l'exception de l'option en caractères gras, ces options sont communes avec la saisie manuelle des bons de réception (G_brc).

Oab

Ne pas afficher l'écran de rapprochement des bobines lors d'un traitement complet par la touche F17

La touche F17 est soumise à permission (V_EDI_BRC_F17).

Oaf

Annulation forcée des sorties réserves

Oan

Edition des étiquettes pour les articles négoces (mp_param[5] = A et mp_param[44] = N)

Oar

Annulation des sorties réserves affectées et création d'une sortie normales uniquement si la sortie réserve existe.

Occ

Mise à jour de la commande client

Cette option est prioritaire sur l'option Oep.

L'option Opa est désactivée si la commande client est retrouvée.

La commande client est retrouvée grâce à sa référence et au complément de sélection _SUP_REQ_REC_CDE_CLI.

La référence de la commande client doit commencer par le numéro de commande d'achat.

Oce

Demande de confirmation du lancement de l'édition des BRC

Ocq

Affichage d'un message d'avertissement si la quantité totale réceptionnée du papier est inférieure à la quantité totale réceptionnée des bobines

Ocr

Création d'une sortie réserve à la place d'une sortie normale

Oct

Affichage spécifique cartonniers (actuellement longueur et largeur de la ligne de commande)

Ocx

Confirmation de l'édition des Ordres d'exécution

Od2

Suppression du contrôle du nombre de palettes dans un emplacement

Ne tient plus compte de l'option payante BAS 22.

Oea

Création et impression des étiquettes d'achat

Oeb

Lancement de l'édition des BRC

Oec

Message de confirmation avant l'édition des étiquettes d'achat

Oen

Création d'une étiquette neutre

Oep

Gestion des entrées de composants d'un ensemble

L'option Opa est positionnée automatiquement.

Voir les notes

_SUP_SQL_EC_NOM0

_SUP_SQL_EC_STK0

EC_LIEU_STOCKAGE

EC_TMV_ENTREE

Oev

Edition des étiquettes pour les articles gérés en vrac (mp_param[40] = N)

L'option –O est automatiquement positionnée.

Oga

Lancement de la visualisation sans écran, avec enchaînement du rapprochement bobine, la génération du BRU et la génération du BRC pour chaque ligne sélectionnée

La touche F17 permet de rapprocher les bobines d'une ligne de commande fournisseur, de générer le BRU et le BRC.

Cette touche est soumise à permission sur touche V_EDI_BRC_F17

Cette option permet de lancer la visualisation en mode batch en enchaînant le traitement de la touche F17.

Oi1

Choix de l'imprimante étiquette demandé une seule fois

Oie

Initialisation des lieux de rangement 1 et 2 du mouvement d'entrée en stock avec les lieux du site de la commande.

Tableau de bord du multisite

Ola

Valorisation du stock avec les dimensions de la commande et non celles de l'article

Olb

On met le numéro de BRU dans le lot

Olc

Affichage du libellé de l'article dans la commande et non pas du libellé de l'article dans le fichier article

Olf

Active l'affectation des mouvements sur la ligne de commande

Olz

Stock la laize de la ligne de commande dans le lieu de rangement 2 du mouvement de stock

Oma

Si le détail palette est activé, l'affectation des entrées est la même que l'entrée prévisionnelle.

Opa

Réception à la palette. Si le nombre de palettes est connu et que l'article est géré à la palette.

Opb

Mise à jour du prix des entrées des bobines avec le prix du bon de réception

Opc

Gestion des papiers client

Ora

Initialisation des lieux de rangement 1 et 2 du mouvement d'entrée en stock avec les lieux de l'article.

Orb

Rapprochement entre les bobines intégrées par un fichier dans la table edi_bobine et les bobines intégrées par le fichier EDI des réceptions fournisseurs

Cette fonction est lancée par la touche de fonction F14.

Ors

Tient compte des remises de la ligne de commande lors de calcul du pris de mouvement d'entrée en stock.

Oru

Gestion du BRU. Obligatoire pour générer le bon de réception avec rapprochement du BRU. Cette option est automatique lorsque l'option Orb est positionnée.

Osr

Pas de mise à jour du stock résultant

Ove

Edition VoluEdit pour les étiquettes vrac

Valeur alpha 2

31 | Autorisation de modifier le bon de réception une fois qu'il est généré (O/N, N par défaut)
32 | Demande la confirmation pour générer le bon de réception (Fonction F11 et F12 (O/N, N par défaut)
33 | Demande la confirmation d'accéder à la modification des bons de réception après génération O on accède systématiquement C on demande confirmation N on n'accède pas (par défaut)
34 | Confirmation du rapprochement des bobines (O/N, N par défaut)
35 | Demande la confirmation d'éditer le bon de réception (O/N, N par défaut) O on accède systématiquement C on demande confirmation N on ne lance pas (par défaut)
36 | Demande la confirmation pour générer le bon de réception usine (BRU, Fonction F15) (O/N, N par défaut)
37 | Lors de la validation du rapprochement des bobines, demander la confirmation (O/N, N par défaut)
38 | Lors de la validation du rapprochement des bobines, afficher le message de confirmation du rapprochement avec le nombre de bobines (O/N, N par défaut)

Notes

ACCES_BRU | Type et code de paramètre de lancement des BRU (valable pour la génération et la visualisation)
COMPTEUR_BRC | 21,22 Numéro de compteur pour la génération des bons de réception.
EC_LIEU_STOCKAGE | 21,23 Lieu de rangement 1 (avec option Oep) 24,25 Lieu de rangement 2 (avec option Oep)
EC_TMV_ENTREE | 21,23 Type de mouvement d'entrée (avec option Oep)
ETIQACHAT_IMP | 21,23 Code paramètre imprimante pour l'édition des étiquettes (voir type paramètre #LP) 24 Choix de l'imprimante des étiquettes ou imprimante auto ? O Automatique N Non Automatique. Demande le choix parmi les 4 imprimantes du #LP paramétré.
FIC_TRACE | 21,60 Nom du fichier trace
POIDS_CAMION_COMPLET | 21,26 Tonnage camion complet Cette information est recherchée en priorité sur les TSC SEB et SE1.
POUR_MAXI_LIVRAISON | 21,26 Pourcentage maximum de livraison Cette information est recherchée en priorité sur les TSC SEB et SE1.
POUR_MINI_POUR_SOLDE | 21,26 Pourcentage de tonnage minimum réceptionné pour solde en camion incomplet Cette information est recherchée en priorité sur les TSC SEB et SE1.
RUN_EDIT_OEX | 21,26 Type et code du paramètre pour l'édition des ordres d'exécution
_SUP_ORDER_BY_BOBINE | 21,26 Complément de tri sur la table edi_rec_cond pour l'affichage du détail des bobines
_SUP_REQ_REC_CDE_CLI | 21,60 Complément de requête pour la recherche de la commande client (avec option Occ)
_SUP_SQL_EC_NOM0 | 21,60 Complément de requête sur la nomenclature pour la recherche des composants de l'ensemble (avec option Oep)
_SUP_SQL_EC_STK0 | 21,60 Complément de requête sur la table des stocks pour la recherche des mouvements de stock à annuler (avec option Oep)
TONNAGE_MINI_COMPLET | 21,26 Tonnage minimum en réception pour solde camion complet Cette information est recherchée en priorité sur les TSC SEB et SE1.
TYPE_NOTE_CDE_CLI | 21,23 Type de note pour l'enregistrement sur la ligne de commande client du numéro de BL Le numéro de BL est égal à la référence du BL fournisseur.

Ordres de tri disponibles

01 | Numéro avis expédition
02 | Code Fournisseur
03 | Date Bon de réception
04 | Statut
05 | Réf. commande fournisseur
06 | Code produit
07 | Commande fournisseur
08 | Ligne Commande
09 | Réf.BL Fournisseur
10 | Bon généré
11 | Ligne de bon généré
12 | Laize de la bobine

Liste des noms de zones autorisées

edi_rec | Toutes les zones de la table + les libellés
cdf1 | Toutes les zones de la table + les libellés
cdf2 | Toutes les zones de la table + les libellés

Package Matières/Articles/Produits - Les noms de zones peuvent être tels quels ou précédés de x_ où x peut prendre les valeurs de 1 à 5.

Package Tiers - Les noms de zones peuvent être tels quels ou contenir aff_

Package Entête de commandes clients - Les noms de zones peuvent être tels quels ou contenir aff_

Package Lignes de commandes clients - Les noms de zones peuvent être tels quels ou contenir aff_

Noms de zone contenant aff_

Pour les commandes d'achat affectées à une commande client, on peut accéder aux zones de cde1, cde2 et cli de la manière suivante :

Exemple pour cli : cl_nom -> cl_aff_nom

Exemple pour cde1 : ec_num -> ec_aff_num

Exemple pour cde2 : lc_num -> lc_aff_num

using - Voir #VI

ref_produit reffou_produit | Référence produit pour le client Référence produit pour le fournisseur chez le client
lib_le_libelle libfou_le_libelle | Libellé 1 pour le client Libellé 1 pour le fournisseur chez le client
lib_le_libelle2 libfou_le_libelle2 | Libellé 2 pour le client Libellé 2 pour le fournisseur chez le client


Intégration EDI des bons de réception

Intégration EDI des bons de réception G_integrer_edi_brc

Ce programme permet d'importer un fichier au format AVIEXP contenant des bons de réceptions dans 2 tables edi_rec et edi_rec_cond.

Options

Oar | Permet l'arrêt du lancement du programme.
Oic | Ignorer le conditionnement (ne pas prendre en compte les lignes LIGCOND)
Onp | Norme Papinet Une même commande-ligne peut être présente plusieurs fois dans le même fichier; dans ce cas, il faut prendre en compte toutes les bobines et cumuler le poids. (Actuellement sans option, lorsque l’on traite la ligne pour la 2ième fois, on annule et remplace.)
Otf | Permet le lancement du programme en tâche de fond.
Oup | Permet de stopper le traitement après un seul passage.

Valeur alpha 2

1,4 | Délai d'attente entre 2 passages en minutes (= 1 si option –Oun)
10 | L'heure est elle obligatoire ? (O/N, O par défaut) Correspond à la zone 5 de l'enregistrement ENTETE
11 | Quelle zone du fichier EDI utiliser pour rechercher le code fournisseur ? 1 Zone 11 de l'ENTETE : No d'identification de l'expéditeur 2 Zone 12 de l'ENTETE : No d'identification du destinataire 3 Zone 16 de l'ENTETE : No de fournisseur chez le client
12 | Comment retrouver le fournisseur VP ? 1 Par le champ code client (cl_code) de la fiche client 2 Par le champ code client chez le fournisseur (cl_codef) de la fiche client 3 Par la note de type EDI sur le fournisseur
19 | Recherche de la commande fournisseur avec la zone 6 de la ligne de type LIGART 1 Par la référence de la commande (champ ef_ref de la table cdf1) 2 Par le numéro de la commande (champ ef_num de la table cdf1)
20 | Quelle zone du fichier EDI utiliser pour rechercher l'article 1 Zone 5 de LIGART : N° Article chez le fournisseur 2 Zone 13 de LIGART : Référence article VP
21 | Comment retrouver le code article VP ? 1 Par le champ code article (mp_code) de la fiche article 2 par le champ référence (le_libpar1) de la table libellés étrangers 3 Par le champ GENCOD (mp_gencod) de la fiche article
22 | Recherche de la ligne de commande 1 Par le numéro de commande et le code article 2 Par la zone 14 de la ligne de type LIGART
40 | Quelle zone utilisée pour initialiser le N° d'étiquette VP si l'article est géré à la palette ? N Aucune zone n'est utilisé 1 Zone 9 de LIGCOND : N° etiquette transport 2 Zone 10 de LIGCOND : N° etiquette UC 3 Zone 11 de LIGCOND : N° etiquette lot
41 | Zone 6 de la ligne de type LIGCOND (no bobine fournisseur) O Oui (uniquement si le papier est géré à la bobine) (mp_param[46] = B) N Non

Notes

Toutes ces notes peuvent être écrites sur plusieurs lignes, lorsqu'une ligne ne suffit pas.

FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_ARRET | 21,60 Nom du fichier arrêt (voir option Oar)
FIC_EDI | 21,60 Nom du fichier EDI à intégrer
FIC_LOCK | 21,60 Nom du fichier de verrouillage général
FIC_LOCK_EDI | 21,60 Nom du fichier de verrouillage EDI
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage volume
FIC_TRACE | 21,60 Nom du fichier trace

Paramètres nécessaires

NTS EDI | Code fournisseur EDI chez le fournisseur
#CF TRA | Note TRACABILITE_TABLE : ajout des tables edi_rec et edi_rec_cond Note TRACABILITE_CHAMP : tous les champs des tables edi_rec et edi_rec_cond
TSC BSD | Bobine Sens Déroulement


Gestion des demandes d'achat

Gestion des demandes d'achat dem_achat

Option payante ACH / 2

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action : saisie Caractères 3 et suivants : Numéro de demande d'achat Exemple : -N[dae_num]
-NDE | Action : création Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis Exemple : -NDE[l2_devis|-|l2_sdevis+<<&]
-ND1 | Action : création/bloc haut Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis /Numéro d'entité du devis Exemple : -ND1[fi_devis|-|fi_sdevis+<<&|/|fi_entite+<<&]
-ND2 | Action : création/bloc bas Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis /Numéro d'entité du devis Exemple : -ND2[fi_devis|-|fi_sdevis+<<&|/|fi_entite+<<&]
-ND3 | Action : création à partir d'une formule matière Caractères 3 et suivants : Numéro de devis-Numéro de sous-devis /Numéro d'entité du devis/Numéro de phase Exemple : -ND3[fm_devis|-|fm_sdevis+<<&|/|fm_entite+<<&|/|fm_numphase+<<&]
-ND4 | Action : Numéro de devis-Numéro de sous-devis /Numéro d'entité du devis/Numéro de phase Caractères 3 et suivants : Numéro de demande d'achat Exemple : -ND4[fs_devis|-|fs_sdevis+<<&|/|fs_entite+<<&|/|fs_numphase+<<&]

Valeurs numériques

1

Numéro de compteur de demande d'achat

Options

Ocm | Gestion d'un compteur manuel Permet de gérer un compteur sans tenir compte de l'année et du mois Incompatible avec l'option Ony (numérotation annuelle)
Ony | Numérotation annuelle
Osq | Saisie de la quantité de la ligne produit dans plusieurs unités Ouverture d'une fenêtre permettant la saisie de la quantité dans 3 unités différentes : Unité d'utilisation Unité d'achat : Quantité dans l'unité d'achat = quantité dans l'unité d'utilisation * coef_conv(1) Unité paramétrée 3 : Quantité dans l'unité 3 = quantité dans l'unité d'utilisation * coef_conv(3) Cette ouverture est automatique en création. Elle doit être activée par <F8> en modification Paramétrage complémentaire : voir aide en ligne de type de paramètre FOR Suppression de cette saisie pour une formule donnée Arrondi de l'unité d'utilisation Définition de l'unité paramétrée 3
Oxm | Ouverture automatique de la fenêtre d'envoi des fax / mails lors de la validation de l'entête. En l'absence de cette option, vous êtes en mode manuel et la fenêtre est accessible par F22 dans l'écran de saisie de l'entête.

Valeur alpha 2

A2[1,3] | Type de notes de demande d'achat
A2[4,6] | Code état de l'entête de la demande d'achat par défaut (EDA)
A2[7,9] | Type de demande d'achat par défaut (TDA)
A2[10,12] | Code demandeur par défaut (DEM)
A2[13,15] | Code service par défaut (SER)
A2[16,18] | Code acheteur par défaut (ACH)
A2[19,21] | Code signature par défaut (SIG)
A2[22,24] | Code état de validation d'une ligne fournisseur (EDF)
A2[25,30] | Code client livré par défaut
A2[31,33] | Code adresse du client livré par défaut
A2[34] | Interdire l'accès au champ Unité d'achat du tableau des fournisseurs (O/N, N par défaut)

Valeur alpha 3

A3[1,6] | Type et code du paramètre de lancement de l'édition VoluEdit de la demande d'achat
A3[7,12] | Type et code du paramètre de lancement de la génération de commande d'achat

Notes

EMETTEUR_FAX_EMAIL | 21,23 Type de paramètre de l'expéditeur du fax/mail (FAB, REP, ...) 24, 26 Code émetteur de l'expéditeur
OBJET_DOCUMENT | 21,23 Type de document (DEA) 25,60 Objet du document pour le fax/email
TITRE_DOCUMENT | 21,23 Type de document (DEA) 25,60 Titre du document pour la fenêtre de gestion du fax/email. Celui-ci sera suivi de la mention N° et de la clé du document.
TITRE_SAI_NOTES | 21, 60 Titre de la fenêtre de saisie des notes

Paramètres nécessaires

EDA | Etat de l'entête de la demande d'achat - (W/T)
EDF | Etat des lignes fournisseur de la demande d'achat (W/E/R/V) Si au moins une ligne fournisseur a son état à V, on propose automatiquement la génération d'une demande en commande à la validation de la demande (voir ci-dessous le paramétrage de gen_cdef).
EDL | Etat des lignes produit de la demande d'achat (W/E/T)
MDA A1[1,3] | Motif de l'état de la demande d'achat : Code état (EDA) rattaché au motif
TDA A1[1,3] | Type de demande d'achat
DEM | Demandeur - Libellé uniquement, pas de paramétrage
SER | Service - Libellé uniquement, pas de paramétrage
QT A1[41] | Qualité Tiers - Qualité du fournisseur bloquant l'envoi d'une demande d'achat (O/N, N par défaut)

Autres paramétrages

gen_cdef | Option -Ony Numérotation annuelle Option -Ocd Recopie des notes depuis dem_achat_lig Option -Oca Activation de la gestion du cadencement Option -Oqg Contrôle si qualité générique A2[1,10] FULL : pré-génération + génération A3[41,46] Type de note SOURCE et DEST A4[31,55] Type de mode de génération Type de commande fournisseur par défaut Type de mouvement de stock en entrée Type du paramètre de l'édition Code du paramètre de l'édition Type du mouvement de stock en sortie Note commençant par TABLE_ORIGINE_DEM_ACHAT Note commençant par _SUP_REQ_DEM_ACHAT
devis_standard | Note commençant par RUN_PROG_DEM_ACHAT pour générer une demande d'achat à partir du devis via la touche F32.
Notes | Notes TYPE_ENVOI_DOCUMENT sur les correspondants destinataires sur #SOC(type de document = DEA)

Voir aussi

Voluedit_dem_achat | Edition VoluEdit des demandes d'achat
envoi_fax_email | Envoi de fax et d'emails
Documentation papier | VoluFaxMail.pdf

Nouvelles tables

dem_achat_cad | Demande achat - cadencements de livraison
dem_achat_ent | Entête demande d'achat
dem_achat_fou | Détail demande d'achat fournisseurs rattachés
dem_achat_lig | Lignes demande d'achat


Saisie des commandes fournisseurs

Saisie des commandes fournisseurs cdef

Valeurs numériques Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes

Paramètres associés

#CF CDF | Configuration des commandes fournisseurs
TYF | Types de commandes fournisseurs
USE | Note commençant par SECTEUR_ACHAT_AUT Note commençant par SECTEUR_ACHAT_PDF (cette note peut être mise à jour par le nouveau code secteur choisi après appel de Choix secteur.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande d'achat

Exemple : -N[lf_num]

Valeurs numériques

1 | Numéro du compteur (nul par défaut). Il faut créer des compteurs par défaut si on utilise les numéros de compteur Exemples Numéro de compteur = 1 pour la saisie des commandes de type FAD cpt.cp_soc = XXX cpt.cp_typ = A cpt.cp_num = 1 cpt.cp_aamm = 9999 cpt.cp_cpt = 99990000 Les commandes de type FAD sont numérotées à partir du numéro 1 de chaque mois Numéro de compteur = 2 pour la saisie des commandes de type AVO cpt.cp_soc = XXX cpt.cp_typ = A cpt.cp_num = 2 cpt.cp_aamm = 9999 cpt.cp_cpt = 99994999 Les commandes de type AVO sont numérotées à partir du numéro 5000
2 | Nombre de jours à ajouter à la date du jour pour obtenir la date de livraison. Par défaut, on prend la valeur 1. Cette valeur est utile si l'option -Od1 a été activée.

Options triées

-C | Paramétrage standard des types de note à saisir Exemple : -C3ACH, pour saisir des notes de type ACH
-Nx | x étant le numéro de commande (sur 8 caractères) En saisie d'entête de commande, le numéro de commande sera initialisé avec le numéro de commande à modifier
O01 | Aide à la saisie de l'affectation de type 1 (lire : zéro un) - Plus d'info
O02 | Aide à la saisie de l'affectation de type 2 (lire : zéro deux) - Plus d'info
O03 | Aide à la saisie de l'affectation de type 3 (lire : zéro trois) - Plus d'info
O04 | Aide à la saisie de l'affectation de type 4 (lire : zéro quatre) - Plus d'info
O05 | Aide à la saisie de l'affectation de type 5 (lire : zéro cinq) - Plus d'info
O18 | Sur le F18, on demande le code article à rechercher
Oaa | Les zones affectation et centre de coût sont initialisées avec les informations de la fiche article et non plus avec les informations de la ligne précédente
Oac | Affectation de la ligne de commande par rapport à une commande client et non pas par rapport à un dossier de fabrication
Oad | Permet de proposer par défaut le même lieu de stockage et de réception dans le cadencement.
Oae | Affichage des informations sur le type d'emballage du fournisseur
Oar | Saisie des information relatives à l'AR
Oas | En création d'adresse secondaire, par défaut on propose des blancs
Oat | Attribution automatique du code acheteur avec le paramétrage sur l'utilisateur Le but est de rechercher le code acheteur en cascade. En premier, on va aller lire le paramétrage USE A3[47,49]. S'il n'existe pas, on va chercher le début du nom user en USE A1[1,3]. Si ce dernier n'existe pas non plus, on va chercher le code du user.
Obp | Réception prévisionnelle des bobines Voir la fiche d'installation
Oc3 | Pour le contrôle du conditionnement, utiliser l'unité de conditionnement mp_cond
Oca | Saisie des cadencements de réception Option interdite si la gestion des besoins matières détaillés par dossier est activée (#CF-ATL A1[44] = O) Option possible si #CF-ATL A1[44] = I TYF A3[45] est prioritaire sur cette option.
Ocd | F11 contrôle date (sur date commande uniquement)
Ocn | Recopie automatique des notes article (d'un type donné paramétré en alpha3[1,3]), vers les notes de ligne de commande fournisseur (d'un type donné paramétré en alpha3[4,6]).
Ocp | Recopie de commande Cette option existe déjà pour la recopie de lignes.
Ocs | Si la commande ou la ligne de commande est soldée, un message d'avertissement s'affichera en bas de l'écran. Fonctionne avec -Oac
Oct | Saisie des infos techniques dans une fenêtre (largeur, longueur, poids, zone paramétrable) Les libellés de ces infos sont paramétrables dans les notes sur le TYF commençant par LIBELLE_TECHNIQUE_n. Attention, l'option Oml empêche ce fonctionnement.
Od1 | Le délai sur la ligne de commande est égal à la date du jour + 1
Oda | On vérifie si une commande a déjà été affectée avec le même dossier
Odl | Recopie du délai de la ligne précédente
Odn | Autorise la saisie de date à null, permet de ne pas imprimer la date dans le report
Oea | Alimentation zones OF et centre de coût sur les mouvements d'entrée de stock
Oeb | Edition des étiquettes de bobine. Nécessite l'option Obp Voir la fiche d'installation
Oec | Message de confirmation avant l'édition des étiquettes de bobine. Nécessite l'option Obp Voir la fiche d'installation
Oed | Edition automatique de la commande d'achat
Oee | Ne pas enchaîner les écrans DONNEES TECHNIQUES, AFFECTATION, DELAIS et QUANTITE si on est sorti d'un des écrans par la touche Echap
Oef | Echéance et mode de règlement sont initialisés à partir de l'adresse d'envoi de la commande Lors de la saisie d'une commande d'achat, l'échéance et le mode de règlement de la commande sont ceux de la fiche principale du fournisseur, quelle que soit l'adresse de facturation spécifiée. Cette option permet d'initialiser cette échéance et ce mode de règlement à partir des données de l'adresse d'envoi de la commande.
Oel | Enchaînement automatique entête lignes
Oen | Edition d'une étiquette neutre. Nécessite l'option Obp Voir la fiche d'installation
Ofm | Ouverture fenêtre pour MAJ du mouvement de stock dans le cas d'un changement d'état du mouvement. Fonctionne uniquement avec Omm
Ofp | Génération automatique d'une ligne de port pour les articles de port dans les achats extérieurs ==> fab5
Ofs | Génération automatique d'une ligne de sous-traitance pour les articles de sous-traitance dans les achats extérieurs ==> fab5
Oga | Gestion du poids en grammes / m²
Ogi | Saisie d'une affectation spéciale pour GIE Papier MR
Ogn | Ouverture d'une fenêtre pour la recopie d'une ligne de commande client (lien par la zone affectation)
Oi1 | Choix de l'imprimante étiquette demandé qu'une fois. Nécessite l'option Obp Voir la fiche d'installation
Oia | Initialisation de l'adresse de livraison par défaut selon le code SITE Voir SIT A1[28,30] Tableau de bord du multisite
Oic | SPECIFIQUE -
Oie | Initialisations de zones à partir du paramétrage du site de production (cdef/gen_cdef) Tableau de bord du multisite
Oif | Initialisation de l'adresse de facturation selon le site Voir SIT A3[42,44] Tableau de bord du multisite
Oim | Affichage type imprimeur. Affiche Format en lieu et place de Longueur et Largeur.
Ola | On utilise les longueur et largeur de la ligne de commande pour le calcul du coefficient de conversion
Oll | (Oll comme Option Libellé Ligne) Afficher le libellé de la ligne de commande même si celle-ci est soldée. La même option existe sur le programme de visualisation des commandes fournisseurs.
Ols | Chargement du libellé produit de la ligne de commande avec le libellé spécifique (article - fournisseur - pays - langue)
Olz | Stockage de la laize de la ligne de commande dans le lieu de rangement de niveau 2 du mouvement de stock
Omg | Interdit l'accès à la modification des données techniques des articles non génériques (utile uniquement si option Oml non activée)
Oml | On interdit la modification des zones longueur, largeur et poids lors de la saisie de commande TYF A3[3] a priorité sur cette option.
Omm | Pas d'option -Omm :Pas de mise à jour du stock si état du mouvement différent Option -Omm seule :Mise à jour du stock dans tous les cas même si état du mouvement différent Options -Omm et -Ofm Ouverture d'une fenêtre pour demander si le stock doit être mis à jour si état du mouvement différent
Omu | Gestion multi devises
Ona | Recopie des notes par défaut par type de commande d'achat Nécessite le paramètre de type TYF avec un code correspondant au code de type de commande (Exemple CAR) Sur ce paramètre, créer des notes #F1, #F2, #F3.
Ond | Récupération en création de commande des notes d'entête par défaut (#F1, #F2, #F3)
Onf | En importation de commande client, on récupère dans le F7 toutes les commandes clients et non pas seulement les commandes non facturables
Onr | Saisie de commandes de négoce mais avec possibilité de saisir des lignes de commandes non rattachées à une ligne de commande client
Onv | Supprime la vérification faite sur la zone affectation de la ligne
Ony | Numérotation annuelle pour le compteur Créer une note de type NUMERO_SECTEUR_CDEF.
Ope | Suppression du message d'édition à la validation de la commande (non compatible avec l'option Oed ( édition automatique)
Opv | Gestion d'un prix de vente sur la ligne de commande
Opz | Possibilité de saisir un prix à 0 même pour les articles valorisés
Oqa | Prise en compte de la quantité dans l'unité d'achat pour la recherche du tarif
Or1 | Recréation des reliquats d'entrée en commande en désolde de ligne commande
Or2 | Recréation des reliquats de sortie réserve en désolde de ligne commande
Ora | Par défaut, la référence est égale au numéro de commande
Ord | Permet de ne pas recopier l'affectation de la ligne précédente en saisie de commande
Ore | Le montant calculé de la ligne tient compte de la remise entête
Orf | Activation de la fenêtre de saisie des refoulages (voir TYF)
Org | Permet de retrouver le magasin en fonction de l'adresse de livraison. La recherche s'effectue sur le code adresse de livraison saisi dans l'entête de la commande d'achat. On recherche donc le code paramètre de type RG1 ayant le code adresse de livraison dans en A1[7,9].
Orl | Le montant calculé de la ligne tient compte de la remise ligne
Orm | Prise en compte du fichier remises
Ors | On tient compte des remises dans le calcul du prix du mouvement de stock
Osa | Saisie du dossier d'affectation dans une fenêtre TYF A3[1] positionné à O ou à N a priorité sur cette option.
Osc | Active les compteurs en mode secteur d'achat
Osd | Saisie du délai dans une fenêtre
Osl | Permet de modifier une ligne même si l'AR est saisi
Osp | Saisie du prix dans plusieurs unités (voir saisie des mouvements de stock, même paramètre) TYF A3[2] positionné à O ou à N a priorité sur cette option.
Osq | Saisie d'une quantité dans plusieurs unités possibles (voir saisie des mouvements de stock, même paramètre)
Osr | Pas de mise à jour du stock résultant lors de la mise à jour des stocks
Ot3 | Recherche de tarif en utilisant la date de livraison demandée au lieu de la date de commande Si la date de livraison demandée n'est pas renseignée, la recherche de tarif utilisera la date de commande. Cette option active automatiquement l'option Otr.
Otp | F11 total produit seulement
Otr | Prise en compte du fichier tarifs. Cette option est activé automatiquement si l'option Ot3 est activée.
Ova | Validation automatique des fax/emails à envoyer sans passer par la fenêtre de gestion des fax/emails
Ove | Edition VoluEdit des étiquettes de bobine. Nécessite l'option Obp Voir la fiche d'installation
Oxm | Ouverture automatique de l'écran de gestion de l'envoi des fax / mails à chaque création de commande
< Fin des options triées >

Valeur alpha 2

Caractères 1 à 6 | Code du fournisseur par défaut
Caractères 11 à 60 | Il est possible de contrôler le TYF saisi lors de la création de la commande, en y indiquant les TYF autorisés. Si cette zone est à blanc, pas de contrôle.

Valeur alpha 3

Caractères 1 à 3

Type de note article source

Caractères 4 à 6

Type de note ligne de commande destination

Si option -Ocn, il y a recopie automatique des notes de l'article vers les notes associées à la ligne de commande.

Caractères 7 à 11

Mot de passe annulation logique. volum si mot de passe non paramétré.

Caractères 12 à 14

TYF par défaut proposé lors de la création de la commande

Caractère 15

Demande du mot de passe d'annulation logique entête et ligne (F2) (O/N, N par défaut)

N Pas de demande du mot de passe

O Demande du mot de passe

Caractères 16 à 17

Contrôle si fournisseur commande différent fournisseur article

Caractère 16

Contrôle du code fournisseur de la commande

N Pas de contrôle (par défaut)

1 Contrôle code fournisseur commande avec code fournisseur article si code fournisseur article saisi

2 Contrôle code fournisseur commande avec code fournisseur article même si code fournisseur article non saisi

3 Contrôle code fournisseur commande avec code fournisseur libellé spécifique de l'article
Recherche si libellé spécifique avec code fournisseur commande ou avec code fournisseur à blanc

4 Contrôle code fournisseur commande avec code fournisseur libellé spécifique de l'article
Recherche si libellé spécifique avec code fournisseur commande uniquement

Caractère 17

Type de contrôle

N Pas de contrôle (par défaut)

W Message en bas de l'écran si différent

C Fenêtre de confirmation si différent

B Contrôle bloquant si différent

Caractères 18 à 23

Type et code du paramètre pour la recherche des tarifs (#CF TAR par défaut)

Le TYF A3[34,39] est prioritaire sur ce paramètre.

Caractère 24

Type de recherche du code article par F7

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Voir #CF CDF A1[32] = 5.

Q Recherche sur la qualité

T Recherche orientée Transformateurs

La note F7_SUR_CODE_ARTICLE du TYF est prioritaire sur ce paramètre.

Caractères 25 à 27

Code du paramètre par défaut (site de production)

Le type est recherché dans #CF CDF alpha1[1,3]

L'existence de ce paramétrage est vérifiée.

Tableau de bord du multisite

Caractère 28

Contrôle que la date d'accusé est supérieure à la date de la commande

N Pas de contrôle (valeur par défaut)

W Simple message d'information

B Contrôle bloquant

Caractère 29

Contrôle que la quantité d'accusé n'est pas supérieure à la quantité de la commande

N Pas de contrôle (valeur par défaut)

W Simple message d'information

B Contrôle bloquant

Caractère 30

Contrôle que le prix d'accusé n'est pas supérieur au prix de la commande

N Pas de contrôle (valeur par défaut)

W Simple message d'information

B Contrôle bloquant

Caractère 31

Méthode de mise à jour du besoin matière détaillé par dossier (F/P, F par défaut)

Voir #CF-ATL A1[44]

F Ouverture de la fenêtre (F14)

P Proratisation des quantités du détail

Caractère 32

Type de contrôle de conditionnement

Voir CND, valeur numérique 1

N pas de contrôle (valeur par défaut)

B contrôle bloquant + message

W Message informatif

C Message + confirmation

Valeur alpha 4

Caractères 1 à 6 | Type et code du paramètre pour l'édition (#ED ECF par défaut)
Caractères 7 à 11 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 12 à 14 | Type de paramètre composant le menu d'édition Fonctionnement identique au Ctrl Z Exemple avec EDA : Le programme va rechercher tous les paramètres de type EDA et les proposer dans un menu. Chacun de ces paramètres doit contenir en alpha1[1,6] un type et un code de paramètre de lancement. Pour chaque programme, le système passera en argument le N° de la commande d'achat en cours

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes du paramètre TYF sont prioritaires sur celles-ci.

Voir aussi la recherche de matières avec #CF RMP

Autres notes

AFFECT_COHERENCE_PRD

21 Le code produit de la commande client doit-il être identique au code produit de la commande fournisseur (O/N, O par défaut)

O Il est identique (par défaut)

N Il peut être différent

Le but est de pouvoir saisir un numéro de dossier dans la fenêtre de saisie d'affectation multiple sans contrôler le code produit car il peut être différent.

BORNES_DONNEE_TEC_

Contrôles des valeurs saisies par rapport à des bornes minimum/maximum

19 Numéro de donnée technique (1 à 4)

21,30 Valeur minimum (999999.999)

32,41 Valeur maximum (999999.999)

Ce fonctionnement est valable pour les programmes suivants

Saisie des commandes d'achat (ici

Saisie des inventaires (inventaire)

Saisie des devis multi-métiers (devis_standard)

Saisie des matières (mat)

Visualisation des besoins matières (v_cde_5)

Le paramétrage de contrôle sera recherché dans l'ordre suivant

1. Famille de la qualité matière

2. Type de commande d'achat (saisie des commandes d'achat uniquement)

3. Paramètre de lancement du programme (ici)

CBACON

Définition des codes blocages automatiques à contrôler en saisie de lignes de commande

7,9 Code blocage à utiliser pour activer le contrôle d'autorisation sur le montant global des lignes de commande.

Doit correspondre à un code blocage de type BLF avec A1[3,5] = 003.

Exemple

CBACONC01 pour le code blocage automatique de l'absence d'association d'une commande cliente avec la ligne de commande fournisseur.

#CC

Contrôler l'affichage et la saisie des champs

5,22 Nom du champ sur lequel le contrôle s'effectue.

23 Type de contrôle à effectuer :

N pas de contrôle (par défaut)

W le champ doit être saisi (non-bloquant)

B le champ doit être saisi (bloquant)

I le champ n'est pas accessible en saisie

M le champ est masqué

Cette note est recherchée en priorité dans le TYF. Si elle ne s'y trouve pas, elle sera recherchée ici.

La liste des champs contrôlables est visible dans le TYF.

CHANGE_LIBELLE_ACH

Pouvoir modifier le libellé du champ ef_ach

21,40 Texte du libellé à modifier dans la fenêtre de saisie cdef

CLI

4 à 6 Types de notes importables en négoce

CONFIG_RECEP_BOBINE

21,26 Type et code du paramètre de la configuration de la réception des bobines

#CFBOB par défaut

Voir la fiche d'installation

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_LFV

Lors d'une demande de transfert, prendre en compte la ventilation des lignes de commande d'achat

Voir le chapitre #CF DP2

DIRECT_PLANNING_SEL

21,60 Complément de sélection sur les tables cdf1 et cdf2 pour ne pas générer systématiquement une demande à chaque création, modification ou réception d'une commande d'achat.

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

EMETTEUR_FAX_EMAIL

Actuellement, l'émetteur des e-mails est le signataire.

Cette note permet de paramétrer l'émetteur comme étant l'acheteur

21,23 Type émetteur email

SIG Signataire (valeur par défaut)

ACH acheteur

ETIQBOBINE_IMP

21,23 Imprimante pour édition automatique des étiquettes de bobine

24 Demande de choix de l'imprimante des étiquettes ou imprimante automatique

N Demande (Valeur par défaut)

O Automatique

Voir la fiche d'installation

FIC_ANOMALIE

FIC_IMPORT

FIC_LOCK

FIC_LOCK_EXTERNE

FIC_LOCK_VS

FIC_TRACE

SPECIFIQUE

FORMULE_CONV_SURFACE

21,22 N° de formule de conversion surface (1 par défaut)

Cette note est recherchée en priorité dans le TYF.

FORMULE_CONV_TARIF

21,22 N° de formule de conversion tarif (1 par défaut)

Cette note est recherchée en priorité dans le TYF.

IMPORT_PARAM

SPECIFIQUE

LIBELLE_TECHNIQUE_n

où n peut prendre les valeurs 1 à 4

21,40 Libellé technique n

Cette note est recherchée en priorité dans le TYF.

LIB_SAISIE_LONG_LARG

21 Inversion des libellés de la saisie largeur/longueur (O/N, N par défaut)

Voir aussi la note SAISIE_LONG_LARG

La note du TYF est prioritaire sur celle-ci.

LP

3 Numéro de l'état (1, 2, 3)

4 à 6 Code paramètre du #LP

7 à 8 Nombre d'exemplaires

MAJ_PRIX_LIGNES_BRC

Mise à jour des prix sur les lignes de bons de réception non rapprochées

21 Mise à jour des prix des lignes de bons de réception non rapprochées correspondantes avec les prix des lignes de commande d'achat

O Mise à jour systématique

N Non (par défaut)

C Confirmation

22 Affichage de la liste des lignes des bons de réception mis à jour (O/N, O par défaut)

NUMERO_SECTEUR_CDEF

Nouveau compteur sur la commande d'achat
21 à 22 Caractères de type numérique insérés avec une numérotation de forme annuelle, construite sous la forme AASS9999, où SS représente ces deux caractères.

Ce fonctionnement est incompatible avec l'option de numérotation annuelle.

OBJET_DOCUMENT

21,23 Type de document (CDA)

25,60 Objet du document pour le fax/email

PASSWORD_PRIX_VENTE

21 à 25 Mot de passe pour la saisie du prix de vente à 0

RACINE_TSC_MP_SAP

SPECIFIQUE

SAISIE_LONG_LARG

21 Inversion de la saisie largeur/longueur (O/N, N par défaut)

Voir aussi la note LIB_SAISIE_LONG_LARG

La note du TYF est prioritaire sur celle-ci.

_SUP_REQ_BES_CDE5

21 à 60 Complément de requête pour la recherche du besoin dans la table cde5

_SUP_REQ_BES_STK0

21 à 60 Complément de requête pour la recherche du besoin dans la table stk0

_SUP_REQ_CLI_LIV

21 à 60 Complément de select pour la recherche du client à livrer

_SUP_REQ_FOU_CDE

21 à 60 Complément de select pour la recherche du fournisseur

_SUP_REQ_NOM0

21,60 Complément de requête sur la table nom0

Cette note est cumulative. Elle sert à l'affichage du libellé du code gamme dans les lignes de commande.

Le libellé du code gamme est maintenant affiché (ligne de commande, dans les informations de surface) s'il est présent dans le TSC 200.

Si le TSC 200 n'est pas présent sur le code article, alors ce supplément de requête permet de rechercher le TSC 200 d'un composant du code produit.

_SUP_SQL_CDE1

21 à 60 Supplément de requête sur cde1

TARIF_POUR_CTRL_MNT

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global

Utilisé dans le cadre du blocage des lignes de commandes fournisseur lorsque le montant global dépasse un plafond.

Par défaut, #CF #R1

Plus d'info ici : BLF A1[3,5] = 003

TARIF_CTRL_MNT_xxx

où xxx est le code blocage paramétré derrière le CBACON.

Si ce paramètre est renseigné, il sera pris en compte; sinon on prendra le paramétrage de la note TARIF_POUR_CTRL_MNT.

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global spécifiquement pour ce code blocage

Plus d'info ici : BLF A1[3,5] = 003

TITRE_DOCUMENT

21,23 Type de document (CDA)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TYF

4 à 6 Code du TYC à écarter dans l'importation des commandes clients

TYPE_COUTEAU

21 à 23 Type de couteau

TYPE_REFOULEUR

21 à 23 Type de refouleur


Génération automatique des commandes fournisseurs

Pour l'envoi de fax et / ou d'email lors de la génération automatique des commandes d'achats :

Les options Ova et Oxm doivent être positionnées.

La note commençant par Z doit être définie ainsi :

1234567890123456789012345

Zef_signature CSSS

ef_signature : Code signature de l'entête de la commande fournisseur

C : Constante

SSS représente le code signataire de la commande.

Ce code sera utilisé pour retrouver l'expéditeur du fax et/ou de l'email.

Il n'y a que 10 caractères pour saisir le nom de la table.

Vous devez donc ignorer le 11ème caractère du nom de la table,

ce qui donne respectivement :

dem_ach_en - dem_ach_li - dem_ach_fo

Génération automatique des commandes fournisseurs gen_cdef

La génération automatique (sans saisie) des commandes fournisseurs peut être réalisée en mode batch ou à l'aide d'un menu.

C'est lors du lancement du programme que le mode batch doit être activé ou non.

Elle se décompose en deux phases :

  • Alimentation de la table des pré-commandes (table gen_cdef)

  • Génération des commandes fournisseurs à partir des pré-commandes.

Pour la génération dune commande d'achat depuis une demande d'achat, un numéro de demande peut être passé en paramètre avec un -nDAxxxxxxxx

(où xxxxxxxx est le numéro de demande d'achat).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-nAF | Caractères 3 et suivants : affectation Exemple : -nAF[gf_affect]
-nDA | Caractères 3 et suivants : numéro de demande d'achat Exemple : -nDA[daf_num]
-nNC | Caractères 3 et suivants : numéro de commande client Exemple : -nNC[ec_num]

Options triées

Oaf | Même affectation pour toutes les lignes. Doit être conforme à la note FORCE_SEQUENCE de voluedit_oex_tc
Oca | Gestion des cadencements
Ocb | Copie automatique des notes des besoins matières dans la table cdf3
Occ | Recopie automatique des notes sur ligne de commande client (d'un type paramétré en A3[23,25]), vers les notes de ligne de commande fournisseur (d' un type paramétré en A3[26,28]).
Ocd | Recopie des notes depuis dem_achat_lig
Ocn | Recopie automatique des notes article (d'un type paramétré en A3[17,19]), vers les notes de ligne de commande fournisseur (d'un type paramétré en A3[20,22]).
Odf | Utiliser la devise fournisseur pour la génération des commandes
Oed | Demande d'édition de la commande
Ofl | Force l'initialisation des lieux de rangement du mouvement de stock généré avec les lieux de la fiche article, même si l'option Oie est positionnée (sinon, ces lieux sont initialisés avec ce qui est paramétré sur le site).
Oie | Initialisations de zones à partir du paramétrage du site de production (cdef/gen_cdef) Tableau de bord du multisite
Ols | Recherche du libellé fournisseur de l'article commandé
Omt | Mise en place d'un fichier trace pour les générations à partir de cde5 et/ou stk0 Le nom du fichier trace est gen_cdef.tra (en dur).
Ony | Numérotation annuelle
Opp | Prise en compte du nombre de poses plaque dans la sauvegarde des pointages Voir aussi le TSC PMI.
Oqa | Prise en compte de la quantité dans l'unité d'achat pour la recherche du tarif
Oqg | Contrôle si qualité générique
Orm | prise en compte du fichier remises
Orn | Lors de l'appel en automatique à la génération des commandes d'achat, récupérer le numéro de commande d'achat généré via le canal de communication (canal_comm). IMPORTANT : Cette option est destinée uniquement à être utilisée de façon automatique. Elle ne doit pas être mise manuellement dans le paramétrage.
Ors | Recopie des notes de stocks
Osm | Active les traitements du mode Batch en mode interactif (sans menu)
Osr | Pas de mise à jour du stock résultant lors de la mise à jour des stocks
Otr | Prise en compte du fichier tarifs
Ova | Validation automatique de la fenêtre de gestion des fax/emails
Oxm | Gestion des fax/emails lors de la création de la commande d'achat Voir détail dans les notes commençant par Z.

Fin des options triées

Valeur numérique 1

Compteur de la commande fournisseur générée

Valeur alpha 2

Caractères 1 à 10

Définition du choix de traitement réalisé en mode batch

FULL pré-génération (alimente la table gen_cdef) puis génération (valeur par défaut)

GDEF génération à partir de la table gen_cdef.

Caractère 11

Demande de confirmation de génération de la ligne de commande d'achat dans le cas où le besoin a déjà généré une ligne de commande d'achat (N/O/B/W/C, N par défaut)

N Pas de demande de confirmation sans message d'avertissement - On ne génère pas.

O Pas de demande de confirmation sans message d'avertissement - On génère.

B Pas de demande de confirmation avec message d'avertissement - On ne génère pas.

W Pas de demande de confirmation avec message d'avertissement - On génère.

C Demande de confirmation

On ne génère pas si la réponse est Non.

On génère si la réponse est Oui.

Caractères 12,17

Type et code du paramètre de configuration carton (#CF CAR par défaut)

Caractère 18

Inversion systématique du format dans le cas d'une génération de commande d'achat à partir des besoins matières (O/N, N par défaut)

Caractère 19

Initialisation par défaut de la section analytique

0 Pas d'affectation (par défaut)

1 Section analytique de la fiche article

2 Spécifique

3 Affectation selon le paramétrage du #CF TFF A4[15,16]

4 La section analytique est celle de l'entête de commande fournisseur. Si elle est vide, on prend celle de l'article.

5 Lecture en cascade

1 Section analytique de la fiche article (mode 1)

2 Section analytique saisie sur le couple famille/sous-famille

3 Section analytique saisie sur la famille

4 Section analytique selon le paramétrage du #CF TFF A4[15,16] (mode 3)

Il s'agit ici d'une initialisation par défaut. La section analytique peut ensuite être forcée via les notes commençant par Z.

Valeur alpha 3

Caractères 1 à 5 | Choix de la première table à partir de laquelle seront créées les pré-commandes - Voir A4[1,30] Les tables possibles (peu importe l'ordre) sont : cde5 Génération des besoins matières stk0 Génération à partir des stocks mat Génération à partir des matières dem_achat Génération à partir des demandes d'achat (entête - lignes - fournisseurs rattachés)
Caractères 6 à 10 | Choix de la deuxième table à partir de laquelle seront créées les pré-commandes - Voir A4[31,60] Les tables possibles (peu importe l'ordre) sont : cde5 Génération des besoins matières stk0 Génération à partir des stocks mat Génération à partir des matières dem_achat Génération à partir des demandes d'achat (entête - lignes - fournisseurs rattachés)
Caractères 11 à 16 | Type et code du paramètre pour la recherche des tarifs (option -Otr) (par défaut : #CF TAR)
Caractères 17 à 19 | SOURCE Type de notes articles à copier dans le type défini en A3[20,22 ] Nécessite l'option Ocn
Caractères 20 à 22 | DEST Type de notes de lignes de commandes (destinataire de la copie de notes dont le type est paramétré en A3[17,19]).
Caractères 23 à 25 | SOURCE Type de notes de lignes de cde client à copier dans le type défini en A3[26,28] Nécessite l'option Occ
Caractères 26 à 28 | DEST Type de notes de lignes de commandes fournisseurs (destinataire de la copie de notes dont le type est paramétré en A3[23,25])
Caractères 29 à 31 | SOURCE Type de notes de ligne des besoins matières à copier dans le type défini en A3[32,34] Nécessite l'option Ocb
Caractères 32 à 34 | DEST Type de notes de lignes de commandes fournisseurs (destinataire de la copie de notes dont le type est paramétré en A3[29,31])
Caractères 35 à 37 | SOURCE Type de note de stock à recopier dans le type défini en A3[38,40] Si aucun type renseigné, recopie de l'intégralité des notes de stocks.
Caractères 38 à 40 | DEST Type de note de ligne de commande d'achat (destinataire de la copie de notes dont le type est paramétré en A3[35,37])
Caractères 41 à 43 | SOURCE Type de note de demande d'achat à recopier dans le type défini en A3[44,46] Nécessite l'option Ocd
Caractères 44 à 46 | DEST Type de note de ligne de commande d'achat (destinataire de la copie de notes dont le type est paramétré en A3[41,43])

Valeur alpha 4

Caractères 1 à 30 | Paramétrage pour la première table utilisée (cde5 / stk0) :
Caractères 1 à 10 | Choix du mode de génération des commandes fournisseurs GRP/FOUR Groupement des commandes par fournisseur (valeur par défaut) GRP/REFE Groupement des commandes par fournisseur, nature de commande et référence GRP/AFF Groupement des commandes par fournisseur et affectation Seuls les 8 premiers caractères de l'affectation sont utilisés pour le groupement. Uniquement pour la table cde5.
Caractères 11 à 13 | Type de commande fournisseur (TYF) pour les commandes générées
Caractères 14 à 16 | Type de mouvement de stocks d'entrée généré lors de la génération des commandes fournisseurs. Le mouvement d'entrée en stock est généré si A1[3] du TYF = O ou C
Caractères 17 à 22 | Type et code du paramètre exécutant le programme d'édition de la commande fournisseur (utilisé avec l'option -Oed) Pas de valeur par défaut
Caractères 23 à 25 | Type du mouvement de stock de sortie généré Le mouvement de sortie du stock est généré si A1[4] du TYF = O ou C
Caractères 26 à 30 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 31 à 60 | Paramétrage pour la deuxième table utilisée (stk0 / mat / demandes d'achat) :
Caractères 31 à 40 | Choix du mode de génération des commandes fournisseurs GRP/FOUR Groupement des commandes par fournisseur (valeur par défaut) GRP/REFE Groupement des commandes par fournisseur, nature de commande et référence
Caractères 41 à 43 | Type de commande fournisseur (TYF) par défaut pour les commandes générées
Caractères 44 à 46 | Type de mouvement de stock d' entrée généré lors de la génération des commandes fournisseurs. Le mouvement d'entrée en stock est généré si A1[3] du TYF = O ou C
Caractères 47 à 52 | Type et code du paramètre exécutant le programme d'édition de la commande fournisseur (utilisé avec l'option -Oed)
Caractères 53 à 55 | Type du mouvement de stock de sortie généré Le mouvement de sortie du stock est généré si A1[4] du TYF = O ou C
Caractères 56 à 58 | Type de note sur la ligne de commande d'achat alimenté par la zone gen_cdef.gf_commentaire (dans le cas d'une gestion depuis la fiche matière)

Notes triées

CBACON

Définition des codes blocages automatiques à contrôler en saisie de lignes de commande

7,9 Code blocage à utiliser pour activer le contrôle d'autorisation sur le montant global des lignes de commande.

Doit correspondre à un code blocage de type BLF avec A1[3,5] = 003.

Plus d'info ici : BLF A1[3,5] = 003

_CRIT_XXXX_

_CRIT_CHAR_ _CRIT_DATE_ _CRIT_NUMD_ _CRIT_NUME_ _CRIT_VALE_

Ces notes sont décrites dans les programmes de visualisation.

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_LFV

Lors d'une demande de transfert, prendre en compte la ventilation des lignes de commande d'achat

Voir le chapitre #CF DP2

DIRECT_PLANNING_SEL

Filtre pour ne pas générer systématiquement une demande à chaque création, modification ou réception d'une commande d'achat.

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

EMETTEUR_FAX_EMAIL

21,26 Type et code de l'émetteur du fax / email

LANCE_MODIF_ACHAT

21,26 Type et code du paramètre de lancement de la saisie de commande d'achat

OBJET_DOCUMENT

21,23 Type de document (CDA)

25,60 Objet du document pour le fax/email

SA

3,60 Critère de sélection supplémentaire d'alimentation

Commencer par un espace

Exemple

SA and uc_fournisseur = JOEL

SG

3,60 Critère de sélection supplémentaire de génération

Commencer par un espace

Exemple

SG and gf_traite = C

_SUP_REQ_CDE1

21,60 Complément de requête sur cde1, pris en compte lors de la pré-génération.

Ne pas mettre le and initial.

_SUP_REQ_DEM_ACHAT

21, 60 Complément de requête sur tables dem_achat_lig et dem_achat_fou

_SUP_REQ_SITE

21,60 Code de la zone (colonne de la table stk0, cde1 ou gen_cdef)

Exemple : ec_c1. Avec cette zone, on construira un complément de requête qui prendra le site de l'utilisateur.

Peut être utilisé avec les notes SA / SG / _SUP_REQ_CDE1 / _SUP_REQ_DEM_ACHAT / _SUP_REQ_STK0

Exemple :

_SUP_REQ_SITE gf_efc1

_SUP_REQ_SITE s0_site_prod

_SUP_REQ_SITE ec_c1

Dans cet exemple, le premier _SUP_REQ_SITE sera ajouté au complément de requête sur la génération (note SG)

On obtiendra : and gf_efc1 = "xxx"

Le second _SUP_REQ_SITE sera ajouté au complément de requête sur la table stk0 (note _SUP_REQ_STK0)

On obtiendra : and s0_site_prod = "xxx"

Le dernier _SUP_REQ_SITE sera ajouté au complément de requête sur la table cde1 (note _SUP_REQ_CDE1)

On obtiendra : and ec_c1 = "xxx"

Tableau de bord du multisite

_SUP_REQ_STK0

21,60 Complément de requête sur stk0 pour la génération de la table gen_cdef.

TABLE_ORIGINE_DEM_ACHAT

Utilisé pour les demandes d'achat

31, 40 Type de mode de génération

41, 43 Type de commande fournisseur

44, 46 Type de mouvement de stock en entrée

47, 52 Type et code du paramètre de l'édition

53, 55 Type du mouvement de stock en sortie

Utilisé pour la génération de commande d'achat depuis le gen_cdef (de façon générale)

Ne pas confondre avec TDA A1[1,3]

TARIF_POUR_CTRL_MNT

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global

Utilisé dans le cadre du blocage des lignes de commandes fournisseur lorsque le montant global dépasse un plafond.

Par défaut, #CF #R1

Plus d'info ici : BLF A1[3,5] = 003

TITRE_DOCUMENT

21,23 Type de document (CDA)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TSC_CDE2_A_RECOPIER

21,23 Numéro du TSC à recopier de la commande client vers la commande fournisseur

TYPE_COUTEAU

21,23 Code couteau

TYPE_REFOULEUR

21,23 Code refouleur

Z

Affecter des valeurs aux champs d'entête et de ligne de commande fournisseur générés, à partir de valeurs d'autres tables

50 notes maximum - Précision pour l'envoi de fax

2,20 Nom du champ à affecter. Liste des champs disponibles :

Les champs de la table cdf1

Les champs de la table cdf2

21 [espace]

22 Caractère permettant d'affecter le champ de façon différente :

C Valeur constante.

La valeur constante doit être indiquée à partir du caractère 23.

Z Valeur provenant d'une zone

Le nom de la table est paramétré en 23,32

Le nom du champ est paramétré en 33,47

T Traitement

23,60 Valeur à affecter au champ défini en 2,20

23,32 Nom de la table. Tables utilisables :

cli

mat

cde1

cde2

cdf1

cdf2

dem_achat_ent

dem_achat_lig

dem_achat_fou

Remarque à propos des 3 tables dem_achat_xxx

33,47 Nom du champ dans la table

On affecte la valeur du champ de cette table au champ défini en 2,20.

Exemples

Zef_client_liv C#SOC

Zef_transport Zcli cl_incoterm


Edition des commandes fournisseurs

Edition des commandes fournisseurs edicf

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande d'achat

Exemple : -N[lf_num]

Options triées

-Nx | où x est le N° de commande sur 8 caractères obligatoirement
Oaf | Pas d'édition de l'état n°3 si l'affectation est à blanc
Ocp | Impression du total hors taxes en monnaie contrepartie
Ocu | SPECIFIQUE Edition des coordonnées de la société en entête
Oea | Edition des étiquettes d'achat
Oec | Message de confirmation avant l'édition des étiquettes d'achat
Oei | SPECIFIQUE Edition interne de la commande
Oen | SPECIFIQUE Edition d'une étiquette neutre (Sans quantité)
Ofe | Forçage de la génération des étiquettes achats pour produit lot / lot – lieu
Oil | Inversion laize/coupe
Oip | SPECIFIQUE Non édition du prix et de la référence
Ola | On utilise les longueur et largeur de la ligne d'achat pour le coef_conv
Oli | VOLUEDIT Mode d'édition listing. Incompatible avec –N
Olr | Si le lieu de réception est paramétré pour cela, le deuxième bon de commande ne s'édite pas.
Or2 | Edition d'un deuxième report
Or3 | Edition d'un troisième report
Osp | SPECIFIQUE Edition sans prix
Ota | Tri des lignes par numéro d'affectation
Otf | Tri des lignes par famille, sous-famille
Otp | Tri des lignes par produit
Oxm | Envoi automatique des fax/email Voir les notes VALID_FAX* dans les généralités.

Valeur alpha 2

Caractères 1 à 3 | SPECIFIQUE Type de notes paramétrées 1
Caractères 4 à 6 | SPECIFIQUE Type de notes paramétrées 2
Caractères 7 à 9 | SPECIFIQUE Type de notes paramétrées 3
Caractère 10 | Ouverture de la fenêtre de sélection de la ou des lignes à éditer (O/N, N par défaut). Ne fonctionne qu'en réédition. Ne fonctionne qu'avec l'édition des étiquettes d'achat (-Oea)

Valeur alpha 3

Titre de l'écran.

Par défaut : Edition des commandes fournisseurs (sans option Oli)

Par défaut : Liste des commandes fournisseurs (avec option Oli)

Notes

EDITION_NUM_ | SPECIFIQUE 13,14 Numéro de l'édition. Exemple 01 21,23 Code imprimante (#LP). Exemple ACH 25 Numéro de l'imprimante. Exemple 1 31,60 Titre de l'édition. Exemple Exemplaire fournisseur
ETIQACHAT_IMP | 21,23 Code paramètre de l'imprimante pour l'édition automatique des étiquettes d'achat
FORMULE_ENTETE | SPECIFIQUE 21,60 Notes de type formule de politesse à éditer en entête de page. Les lignes de notes peuvent être cumulées en utilisant les caractères ///
FORMULE_PIED | SPECIFIQUE 21,60 Notes de type formule de politesse à éditer en pied de page. Les lignes de notes peuvent être cumulées en utilisant les caractères /// Exemple Veuillez trouver ci-joint /// l'accusé de… donnera à l'impression Veuillez trouver ci-joint l'accusé de… Longueur page : 74 lignes (fixé par Appic, ne pas modifier !)
GENERER_EDI_ORDERS | 21, 26 Type et code du paramètre de lancement du programme generer_edi_cde (ex : #TR ORD) Permet de générer un fichier ORDERS depuis la chaîne de commande d'achat. La génération est déclenchée à l'édition de la commande d'achat, mais pas à la ré-édition. Permet aussi de générer d'autres fichiers. Le TSC ORD indique le fichier à générer.
LP | Paramétrage des #LP utilisés par les trois états. Le -X existe mais ne suffit pas. 3 Numéro de l'état (1, 2 ou 3) 4,6 Code du paramètre à utiliser. Par défaut : BCF 7,8 Nombre d'exemplaires à éditer. Par défaut : 1
N | SPECIFIQUE Emplacement des notes 2 1 Sur la ligne de commande ou 2 Sur l'article 3,60 Type de notes (codes sur 3 caractères, Exemple LIG#QA)
NA | Génération de lignes de notes dans l'entête 3,5 Type de note cible de l'entête de commande d'achat 6,60 Ligne de note à insérer dans l'entête de commande d'achat
NUM_CERTIF_FSC | 21,60 Numéro de certificat FSC
OBJET_FAX_EMAIL | SPECIFIQUE 21,60 Objet du fax ou de l'email par défaut. N'apparaîtra que si aucun objet n'a été mis par défaut dans l'édition concernée.
PC | SPECIFIQUE 5,60 Note de pied de page Il est possible de concaténer les lignes de notes en finissant la ligne par ///
SS | 3,60 Complément de requête sur la table des entêtes de commandes fournisseurs cdf1 Exemples SSand ef_num matches 97* SSand ef_tyc = FAD
TYPE_NOTE_CDF3_ENT | SPECIFIQUE 21,60 Type de note d'entête de commande fournisseur à éditer
TYPE_NOTE_CDF3_FAC | SPECIFIQUE 21,60 Types de notes de facturation sur entête de commande à éditer
TYPE_NOTE_CDF3_LIG | SPECIFIQUE 21,60 Types de notes sur ligne de commande à éditer
TYPE_NOTE_CDF3_LIV | SPECIFIQUE 21,60 Types de notes de livraison sur entête de commande à éditer (sous la forme : XXXYYYZZZ)
TYPE_NOTE_CLI3_FOU | SPECIFIQUE 21,60 Types de notes sur adresse principale du fournisseur à éditer
TYPE_NOTE_CLI3_SIT | SPECIFIQUE 21,60 Types de notes sur adresse de site de production du client à éditer Tableau de bord du multisite
TYPE_NOTE_CLI3_SOC | SPECIFIQUE 21,60 Types de notes sur adresse principale de la société du client à éditer
VALID_FAXMAIL_EDIT VALID_FAXMAIL_REEDIT VALID_FAXMAIL_VALID | Voir les notes dédiées au Fax/Mail


v_cdef Visualisation des commandes fournisseur

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro de commande d'achat Exemple : -N[ef_num]
-N_FOU | Caractères 3 et suivants : code fournisseur Exemple : -N_FOU[ef_fou]
-N_ART | Caractères 3 et suivants : Exemple : -N_ART[lf_prod] Le numéro est passé comme argument par le programme v_stk_lot_lieu (voir A4[12])
-N_LAI | Caractères 3 et suivants : Exemple : -N_LAI[lf_larg] Le numéro est passé comme argument par le programme v_stk_lot_lieu (voir A4[13])
-N_LIN | Argument : Numéro de lot industriel (appel depuis le programme de visualisation des lots industriels) Exemple : -N_LIN[lin_lot_indus]

Options

Ocb | Ouverture d'une fenêtre de sélection pour le filtrage des lignes de commande par valeur du statut et/ou code blocage
Oll | (Oll comme Option Libellé Ligne) Afficher le libellé de la ligne de commande même si celle-ci est soldée. La même option existe sur le programme de saisie des commandes fournisseurs.

Valeur alpha 2

Paramétrage des options

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 31 | Cadencement commandes (O/N)
Caractère 32 | Déduction remise (O/N)
Caractère 33 | Lignes annulées (O/N)
Caractère 34 | Edition des notes saisies (O/N)
Caractère 35 | Edition d'un libellé entre lignes (O/N)
Caractère 36 | Edition d'un entête société (O/N)
Caractère 37 | Utilisation longueur et largeur (O/N) de la commande d'achat pour le calcul du coefficient de conversion
Caractère 38 | Saisie des notes possible (O/N)
Caractère 39 | Restriction aux lignes de commande concernant des articles de sous-traitance ou de port (O/N)
Caractère 40 | Restriction aux lignes de commande concernant des entêtes de commande client soldées (O/N)
Caractère 41 | Restriction aux lignes de commande concernant des entêtes de commande client non soldées (O/N)
Caractère 42 | L'affectation des lignes d'achat correspond au sous-secteur - numéro de dossier
Caractère 43 | Gestion d'un prix de vente
Caractère 44 | Restriction aux lignes de commande concernant des articles suivis en stock.
Caractère 45 | Restriction aux lignes de commande concernant des articles non suivis en stock.
Caractère 46 | Restriction aux lignes de commande avec Quantité reçue > quantité facturée (issue de la saisie des factures fournisseurs)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES COMMANDES FOURNISSEURS

Valeur alpha 4

Paramétrage de l'autorisation d'utiliser les touches de fonction. Valeurs autorisées : O/N. Valeur par défaut : N

Caractère 5 | Touche F5 (O/N) rafraîchir la fenêtre de visualisation des commandes fournisseur
Caractère 6 | Touche F6 (O/N) Visualisation détail ligne cadencement
Caractère 8 | Touche F8 (O/N) Visualisation détail ligne commande
Caractère 9 | Autorisation d'accès à la touche de fonction F9
Caractère 11 | Autorisation d'accès à la touche de fonction F11 Voir la note PARAMETRE_SAISIE_CDF
Caractère 12 | Touche F12 (O/N Visualisation détail entête commande Voir la note PARAMETRE_SAISIE_BRC
Caractère 14 | Touche F14 (O/N, N par défaut) Solde de commande d'achat ou solde / désolde de ligne de commande d'achat Voir la note OPTIONS_CDF_RELIQUAT
Caractère 15 | Touche F15 (O/N, N par défaut) Saisie de l'accusé de réception de la commande d'achat.
Caractère 32 | Touche F32 pour l'accès à la visu des commandes clients (O/N)
Caractère 37 | Touche CONTROL-B. Permet de visualiser les stocks depuis la visu des commandes d'achat Voir aussi #CF ATL A1[24]
Caractère 38 | Touche CONTROL-C (O/N)
Caractère 40 | Touche CONTROL-F (O/N) Le format est paramétré dans la note USING_CTRL_F_ACH du #CF ATL.
Caractère 46 | Touche CONTROL-N (O/N)
Caractère 48 | Touche CONTROL-P (O/N) Calcul et affichage du pied de commande
Caractère 51 | Touche CONTROL-T (O/N)
Caractère 56 | Touche CONTROL-Z (O/N)

Notes

AUTORISE_TOUCHE_F49

Accès au code blocage

O autorise en visu uniquement

N accès interdit

M autorise en visu et modification

#CC

Masquer les nouvelles colonnes de l'écran des lignes de commande d'achat

5,22 Nom du champ sur lequel le contrôle s'effectue. Les champs sont les suivants

mp_uv Unité de vente (article)

stock_physique Stock physique

unite_achat Unité d'achat

unite_prix Unité de quantité d'achat

23 Type de contrôle à effectuer :

N Pas de contrôle (par défaut)

M Le champ est masqué.

_CSEL

Affichage de la colonne de sélection (colonne de droite)

Cette colonne permet de sélectionner des lignes pour lesquelles on veut par exemple enchaîner le déblocage et l'édition d'une liste de commandes d'achat.

L'action ACT016 permet d'enchaîner le déblocage et l'édition d'une liste de commandes d'achat à partir de la visualisation des commandes d'achat. Les codes blocages à débloquer par cette action sont paramétrables, ainsi que la possibilité d'attribuer un motif de déblocage à chaque code blocage.

Une commande initialement non bloquée sera ignorée par cette nouvelle action, et ne sera donc pas éditée.

Le permission MEN ACT016 est nécessaire.

Voir ci-dessous les notes DEBLOCAGE_AUTO_MDB et LCT_MULTI_CONFIG.

Voir la note CODES_BLOCAGE_ASS dans le paramètre MDB.

DEBLOCAGE_AUTO_MDB

Définition d'un code blocage à débloquer et du motif de déblocage associé, par l'action ACT016 via CTRL-K

21,23 Code blocage à débloquer (BLF)

25 Mode d'attribution du motif de déblocage pour le code blocage paramétré en [21,23]

O Attribution automatique. Une recherche automatique est effectuée pour retrouver le code blocage paramétré en [21,23] dans les notes CODES_BLOCAGE_ASS de tous les paramètres MDB existants.
Le motif attribué sera le 1er trouvé par la recherche.
Si aucun motif n'est trouvé, le code blocage sera simplement débloqué sans motif.

N Sans motif. Le code blocage sera simplement débloqué.

F Attribution forcée. Le motif de déblocage positionné pour le code blocage est défini en potion [27,29].
Si le code MDB saisi est vide ou n'existe pas, l'action ACT016 ne sera pas effectuée.

27,29 Motif de déblocage (MDB) à forcer. Utilisé uniquement si le caractère 25 = F.

LCT_MULTI_CONFIG

21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP

Si cette note est paramétrée, les 4 notes suivantes seront recherchées dans le #RP.

Dans le cas contraire, elles seront recherchées ici, dans le paramètre de lancement.

LCT_MULTI_TITRE_

LCT_MULTI_IMAGE_

LCT_MULTI_PARAM_

LCT_MULTI_COMPL_

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées)

Plus de détail dans le #RP

blocage

LIBC_BLOCAGE

LIBC_DEBLOCAGE

LIBL_BLOCAGE

LIBL_DEBLOCAGE

Libellés des codes blocage / déblocage

21,30 Libellé court blocage (par défaut : Bloqué)

21,30 Libellé court déblocage (par défaut : Débloqué)

21,45 Libellé long blocage (par défaut : Bloqué)

21,45 Libellé long déblocage (par défaut : Débloqué)

Ces libellés agissent sur les zones des codes blocage.

OPTIONS_CDF_RELIQUAT

21,60 Options utilisées lors du solde de la commande d'achat ou du solde / désolde de la ligne de commande d'achat - Voir A4[14]

Options disponibles :

ac Affectation de la ligne de commande par rapport à une commande client et non pas par rapport à un dossier de fabrication

bp Réception prévisionnelle des bobines

ca Saisie des cadencements de réception

dn Autorise la saisie de date à null, permet de ne pas imprimer la date dans le report

ea Alimentation zones OF et centre de coût sur les mouvements d'entrée de stock

gi Saisie d'une affectation spéciale pour GIE Papier MR

ie Initialisation des zones à partir du paramétrage du site de production

lz Stockage de la laize de la ligne de commande dans le lieu de rangement de niveau 2 du mouvement de stock

r1 Recréation des reliquats d'entrée en commande en désolde de ligne commande

r2 Recréation des reliquats de sortie réserve en désolde de ligne commande

rs On tient compte des remises dans le calcul du prix du mouvement de stock

sr Pas de mise à jour du stock résultant lors de la mise à jour des stocks

Pour plus d'info, consulter les mêmes options dans la saisie des commandes fournisseurs

Le paramétrage des options doit commencer en 21, de 2 en 2 et sans espace.

PARAMETRE_EDIT_CDEF

21,26 Type et code du paramètre de lancement de l'édition de la commande d'achat (touche F13)

PARAMETRE_SAISIE_BRC

21,26 Type et code du paramètre de lancement de la saisie des bons de réception

PARAMETRE_SAISIE_CDF

21,26 Type et code du paramètre de lancement de la saisie des commandes fournisseurs1.2

RUN_VISU_CDE

21,26 Type et code du paramètre de lancement de la visu de commandes client

Via la touche F32, on peut maintenant, depuis la visu des commandes fournisseurs, accéder à la visu des commandes clients (pour voir les infos de la commande d'affectation rattachée à la ligne de commande fournisseur -> lf_affect[1,8]).

_SUP_REQ_RECEPTION

21,60 Complément de requête sur les tables b_rec_ret_d et b_rec_ret_e pour la recherche des zones suivantes

somme_brd_quantite

dernier_bre_date_bon

dernier_bre_bon

Utile pour exploiter la zone somme_brd_quantite (Somme des quantités réceptionnées)

Ordres de tri disponibles

Voir les notes commençant par O

01 | c_fou (code fournisseur)
02 | c_ach (code acheteur)
03 | d_cde (date de commande)
04 | n_cde (numéro de commande)
05 | c_prod (code produit)
06 | c_fam (code famille)
07 | c_sfm (code sous-famille)
08 | c_datliv_p (date de livraison prévue)
09 | d_delfou (date de livraison prévue)
10 | d_arc (date de l'AR)

Liste des noms de zones autorisés

cdf1 - Entête commandes fournisseurs

cdf2 - Lignes commandes fournisseurs

cdf4 - Cadencement des livraisons fournisseurs

Libellés étrangers

Autres

cde2 - Lignes de commandes

Réception

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Facturation

Toutes les zones du package Tiers

Codes blocage

cdf1 - Entête commandes fournisseurs

ef_soc | Code société
ef_num | Numéro commande
ef_fou | Code fournisseur
nom_fou | Nom fournisseur
ef_ref | Référence commande
ef_tyc | Type commande
libc_tyc | Libellé court type commande
libl_tyc | Libellé long type commande
ef_c1 | Code zone paramétrable
libc_c1 | Libellé court zone paramétrable
libl_c1 | Libellé long zone paramétrable.
ef_datc | Date commande
ef_client_liv | Code du client final (à livrer)
nom_client_liv | Nom du client final pris au niveau de l'adresse secondaire
ef_adl | Code adresse de réception lié au client final
ville1_adl nom1_adl adr11_adl adr21_adl adr31_adl codp1_adl | Ville de l'adresse de réception prise sur l'adresse secondaire du client final Nom de l'adresse de réception 1ère ligne de l'adresse réception 2nde ligne de l'adresse réception 3ième ligne de l'adresse réception Code postal de l'adresse réception
ef_rgt | Lieu rangement
libc1_rgt | Libellé court lieu rangement
libl1_rgt | Libellé long lieu rangement
ef_adst | Code adresse sous-traitance
ville1_adst nom1_adst adr11_adst adr21_adst adr31_adst codp1_adst | Ville adresse sous-traitance Nom adresse sous-traitance 1ère ligne adresse sous-traitance 2nde ligne adresse sous-traitance 3ième ligne adresse sous-traitance Code postal adresse sous-traitance
ef_transport | Type transport
libc_transport | Libellé court type transport
libl_transport | Libellé long type transport
ef_adf | Code adresse facturation
ville1_adf nom1_adf adr11_adf adr21_adf adr31_adf codp1_adf | Ville adresse facturation Nom adresse facturation 1ère ligne adresse facturation 2nde ligne adresse facturation 3ième ligne adresse facturation Code postal adresse facturation
ef_mrg | Mode règlement
libc_mrg | Libellé court mode règlement
libl_mrg | Libellé long mode règlement
ef_ech | Code échéance
libc_ech | Libellé court code échéance
libl_ech | Libellé long code échéance
ef_rem | Remise globale en %
ef_ct | Code tarif
libc_ct | Libellé court code tarif
libl_ct | Libellé long code tarif
ef_cr | Code remise
libc_cr | Libellé court code remise
libl_cr | Libellé long code remise
ef_devise | Code devise
libc_devise | Libellé court code devise
libl_devise | Libellé long code devise
ef_cours | Taux devise
ef_exp | Exportation
ef_ach | Code acheteur
libc_ach | Libellé court code acheteur
libl_ach | Libellé long code acheteur
ef_sold | Commande soldée
ef_ar | Commande éditée
ef_fact | Facture éditée
ef_bl | Bons réception à éditer
ef_nofac | Numéro facture
ef_datfac | Date facture
ef_signature | Code signature
libc_signature | Libellé court code signature
libl_signature | Libellé long code signature
ef_corres | Correspondant
ef_titre | Titre du correspondant
libc_titre | Libellé court titre correspondant
libl_titre | Libellé long titre correspondant
ef_ada | Code adresse envoi commande
ville1_ada nom1_ada adr11_ada adr21_ada adr31_ada codp1_ada | Ville adresse envoi commande Nom adresse envoi commande 1ère ligne adresse envoi commande 2nde ligne adresse envoi commande 3ième ligne adresse envoi commande Code postal adresse envoi commande
ef_annu | Commande annulée

cdf2 - Lignes commandes fournisseurs

lf_num | Numéro commande
lf_lig | Numéro ligne commande
lf_cderat | Numéro commande rattachée
lf_lcderat | Numéro ligne commande rattachée
lf_prod | Code produit
lf_affect | OF d'affectation
lf_cdc | Centre de coût d'affectation
lib_lf_cdc | Libellé centre de coût d'affectation
lf_fam | Code famille
libc_fam | Libellé court code famille
libl_fam | Libellé long code famille
lf_sfm | Code sous-famille
libc_sfm | Libellé court code sous-famille
libl_sfm | Libellé long code sous-famille
lf_qtemar | Quantité du marché
lf_etatmar | Etat du marché (O si imprimé, blanc sinon)
lf_lib | Libellé produit
lf_long | Longueur
lf_larg | Largeur
lf_qtecde | Quantité commandée
lf_qteliv | Quantité réceptionnée
lf_qtefac | Quantité facturée
lf_solde | Ligne commande soldée
lf_prx | Prix
lf_prixvente | Prix de vente
lf_rem | Remise ligne en %
lf_forfait | Code forfait
lf_unacha | Unité achat
libc_unacha | Libellé court unité achat
libl_unacha | Libellé long unité achat
v1_unacha | Valeur 1 unité achat
lf_tva | Code TVA
libc_tva | Libellé court code TVA
libl_tva | Libellé long code TVA
lf_poids | Poids
lf_delfou | Date de livraison prévue
lf_delrep | Date de livraison réelle
lf_colis | Nombre colis
lf_adl | Code adresse réception
ville2_adl nom2_adl adr12_adl adr22_adl adr32_adl codp32_adl | Ville adresse réception Nom adresse réception 1ère ligne adresse réception 2nde ligne adresse réception 3ième ligne adresse réception Code postal adresse réception
lf_rgt | Lieu rangement
libc2_rgt | Libellé court lieu rangement
libl2_rgt | Libellé long lieu rangement
lf_adst | Code adresse sous-traitance
ville2_adst nom2_adst adr12_adst adr22_adst adr32_adst codp32_adst | Ville adresse sous-traitance Nom adresse sous-traitance 1ère ligne adresse sous-traitance 2nde ligne adresse sous-traitance 3ième ligne adresse sous-traitance Code postal adresse sous-traitance
lf_rstbl | Bons réception à éditer
lf_nummvt | Numéro mouvement de stock (pour l'entrée en commande)
lf_nummvts | Numéro mouvement de stock (pour la sortie réserve de l'affectation)
lf_sec_ana | Section analytique
lf_annu | Ligne de commande annulée
lf_arc | Code arc
lf_date_arc | Date de l'AR
lf_delai_demande | Délai demandé
lf_qte_init | Quantité initiale de la commande
lf_prix_init | Prix initial de la commande dans la devise société
lf_prix_init_dev | Prix initial de la commande dans la devise de la commande
lf_prix_init_euro | Prix initial de la commande dans la devise EURO
lf_cli nom_client_ligne | code client sur la ligne de commande nom client sur la ligne de commande

cdf4 - Cadencement des livraisons fournisseurs

ml_liglieu | Numéro de ligne de cadencement de livraison
ml_adl | Code adresse réception
ville3_adl nom3_adl adr13_adl adr23_adl adr33_adl codp3_adl | Ville adresse réception Nom adresse réception 1ère ligne adresse réception 2nde ligne adresse réception 3ième ligne adresse réception Code postal adresse réception
ml_rgt | Lieu rangement
libc3_rgt | Libellé court lieu rangement )
libl3_rgt | Libellé long lieu rangement )
ml_qte | Quantité
ml_nummvt | Numéro mouvement de stock (pour l'entrée en commande)
ml_nummvts | Numéro mouvement de stock (pour la sortie réserve de l'affectation)
ml_datliv_p | Date livraison prévue
ml_datliv_r | Date livraison réelle
ml_datappel | Date de l'appel
delai_en_jours | Nombre de jours séparant la date de livraison prévue de la date du jour (today)
ml_qteliv | Quantité réceptionnée
ml_solde | Ligne de cadencement de livraison soldée
ml_annul | Ligne de cadencement de livraison annulée

Libellés étrangers

ref_produit | référence produit pour le client de la matière
lib_le_libelle | libellé 1 étranger pour le client de la matière
lib_le_libelle2 | libellé 2 étranger pour le client de la matière
lib_le_fou_reference | référence produit pour le fournisseur de la commande
lib_le_fou_libelle1 | libellé 1 étranger pour le fournisseur de la commande
lib_le_fou_libelle2 | libellé 2 étranger pour le fournisseur de la commande
lib_le_fou_qua_reference | référence qualité du produit pour le fournisseur de la commande
lib_le_fou_qua_libelle1 | libellé 1 étranger qualité du produit pour le fournisseur de la commande
lib_le_fou_qua_libelle2 | libellé 2 étranger qualité du produit pour le fournisseur de la commande

Autres

using | Voir #VI
qte_restante | Si quantité commandée > quantité réceptionnée quantité restante = quantité commandée - quantité réceptionnée Sinon : quantité restante = 0
reste_a_livrer | Quantité commandée - Quantité réceptionnée
valeur | Prix * Quantité commandée * Formule conversion - Remises ligne et globale
valeur_recue | Prix * Quantité reçue * Formule conversion - Remises ligne et globale
ecart_montant | valeur - valeur_recue
valeur_vendue_c | Prix de vente * Quantité commandée * Formule conversion
valeur_vendue_r | Prix de vente * Quantité reçue * Formule conversion
ecart_montant_vendue | valeur_vendue_c - valeur_vendue_r
surf_tot_cdee | Quantité commandée * formule de conversion
surf_tot_recue | Quantité reçue * formule de conversion
solde_marche | Quantité du marché - quantité commandée
code_client | code du client de la commande d'affectation
nom_client | nom du client de la commande d'affectation
delai_ar | Délai répondu de la commande client d' affectation
ref_prod_fini | Référence (F24) du produit fini sur la commande client
lib_prod_fini | Libellé du produit fini sur la commande client
fam_prod_fini | Famille du produit fini sur la commande client
sfm_prod_fini | Sous-Famille produit fini sur la commande client
pays_fou_iso | Code ISO du pays du fournisseur
code_iso_devise | Code ISO de la devise du fournisseur
taux_dev_euro | Taux devise par rapport à l'euro
lf_annu_num | Flag d'annulation 1 ligne de commande annulée, 0 sinon
montant | Montant global (lf_qtecde*lf_prix)
montant_remise_deduite | Montant global remise déduite
date_time_std | Date + heure au format YYYY-MM-DD hh:mm:ss
incoterm | Code incoterm (ef_transport)
delta_gache | Delta de gâche entre la commande fournisseur et la commande client
taux_gache | Taux de gâche entre la commande fournisseur et la commande client
somme_brd_quantite | Somme des quantités réceptionnées Voir aussi _SUP_REQ_RECEPTION
somme_brd_valeur | somme (quantité réceptionnée * prix de la réception) / unité d'achat Voir aussi _SUP_REQ_RECEPTION
gen_brc_ok | Indique par un astérisque que la génération du bon de réception a été faite sur la ligne de visualisation Zone disponible en visualisation uniquement
pour_lf_certification | Pourcentage de la certification du code certification de la ligne de commande fournisseur

cde2 - Lignes de commandes

Toutes les zones de la table cde2

La totalisation est possible pour les zones suivantes (triées par ordre alphabétique) :

lc_qtecde

lc_qte_contrat

lc_qtelan

lc_qtefab

lc_qteliv

lc_qte_en_retour

lc_qteafa

lc_qtefac

lc_prx

lc_rem

lc_colis

lc_prxcli

lc_prx_au_plus

lc_prx_au_moins

lc_marge

lc_prx_revient

lc_prx_rvt_reel

lc_qteliv_reelle

lc_prx_euro

lc_prx_dev

lc_prxcli_euro

lc_prxcli_dev

lc_prx_plus_euro

lc_prx_plus_dev

lc_prx_moins_euro

lc_prx_moins_dev

lc_prx_rvt_euro

lc_prx_rvt_r_euro

lc_prx_rvt_dev

Réception

dernier_bre_bon | DERNIER numéro de bon de réception.
dernier_bre_date_bon | Date du DERNIER bon de réception. S'il n'y a pas de mise à jour du fichier des réceptions. La réception est stockée sur un mouvement de stock.
dernier_s0_brc | DERNIER numéro de bon de réception.
dernier_s0_brc_datm | Date du DERNIER bon de réception.

Facturation

Utilisation du programme strai.4ge

ATTENTION : ces zones ne sont accessibles que si la date de facture est renseignée.

dernier_fab5_datfac | Dernière date de facture
dernier_fab5_nofac | Dernier numéro de facture.
dernier_fab5_prix | Dernier prix (Montant / quantité).

Utilisation du contrôle facture

dernier_facfou_datfac | Dernière date de facture
dernier_facfou_nofac | Dernier numéro de facture
dernier_facfou_prix | Dernier prix (Montant / quantité)

Codes blocages

Voir les notes des libellés des codes blocage / déblocage

code_blocage | Code blocage de la ligne de commande
libc_blocage | Libellé court du code blocage (BLO) - Voir les notes de libellés des codes blocages
libl_blocage | Libellé long du code blocage (BLO) - Voir
code_statut_blocage | Code de statut/déblocage BLO Bloqué DEB Débloqué ___ Motif de déblocage
libc_statut_blocage | Libellé court du code de déblocage (MDB)
libl_statut_blocage | Libellé long du code de déblocage (MDB)
val_statut_blocage | Statut actuel du blocage 1 Bloqué 0 Débloqué Valeur négatives : Débloqué avec motif


Saisie des bons de réception et de retour

En création/modification de BR, on peut saisir des notes sur l'entête comme sur les lignes.

Avant, on pouvait saisir des notes sur les lignes mais ces notes étaient rattachées à la ligne de commande fournisseur de la ligne du BR.

Sur option, on choisit maintenant la cible des notes.
Soit on saisit des notes sur les lignes de commandes fournisseur, soit sur les lignes du BR.

Quelle que soit l'option, on peut saisir des notes sur l'entête du BR.

Les notes sont sauvegardées dans la tables notes avec le type R.

Clé entête : numéro de BR

Clé ligne : numéro de BR – ligne (using "##&")

Pour l'édition VoluEdit, il existe un nouveau package pour les notes d'entête et de lignes du BR.
On paramètre les VE_VAR avec la clé BRE et BRD. (paramétrage possible de notes simples ou groupées).

Saisie des bons de réception et de retour brc

Voir aussi : Génération des bons de réception à partir d'une visu des messages EDI Réception (v_edi_brc).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : Numéro de bon de réception
-N_C | Création à partir de la commande Caractères 3 et suivants : Numéro de commande d'achat-Numéro de ligne de commande d'achat Exemple : -N[lf_num|-|lf_lig+<<&]

Valeurs numériques

N1 | Pourcentage de dépassement autorisé sur les quantités reçues par rapport aux quantités restantes. Par défaut : 0
N2 | Numéro du compteur (Voir cdef)

Options triées

Oaf

Force l'annulation d'un mouvement de réserve lors de la saisie du bon de réception, même si la ligne de commande n'est pas rattachée à un dossier.

Oai

Aide à la saisie du détail des palettes en vrac

Le nombre de palettes et la quantité par palette sont remis à null sans message d'anomalie si le lieu de rangement est géré en vrac.

L'option Opa doit être paramétrée.

Oan

Edition des étiquettes d'achat pour les articles négoces seulement (mp_param[5] = A et mp_param[44] = N)

Cette option est autorisée si les 2 conditions suivantes sont réunies :

l'option Opa est paramétrée,

so_options[40] = N.

Oar

Annulation des sorties réserves affectées

La saisie des commandes d'achat permet une génération de mouvement de stock sorties réserves à la saisie de l'affectation de la commande d'achat.

Ce paramètre permet d'assurer la gestion de ces mouvements. Voir aussi l'option Our.

Option interdite si la gestion des besoins matières détaillés par dossier est activée.

Oas

Interdiction de réceptionner les articles non suivis en stock

Obm

Contrôle bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Oca

Saisie des commandes avec cadencement

Ocb

Contrôle de date bloquant

Occ

Mise à jour de la commande client

Cette option est prioritaire sur l'option Oep

L'option Opa est désactivée si la commande client est retrouvée.

La commande client est retrouvée grâce à sa référence e au complément de sélection _SUP_REQ_REC_CDE_CLI.

La référence de la commande client doit commencer par le numéro de commande d'achat.

Oce

N'affiche pas la fenêtre de confirmation de l'édition du bon (fonctionne avec l'option Oeb)

Ocf

Certification des bobines lors du rapprochement du BRU avec la commande d'achat

Ocl

Contrôle du code litige

Ocq

Affichage d'un message d'avertissement si la quantité totale réceptionnée du papier est inférieure à la quantité totale réceptionnée des bobines

Ocr

Création d'une réserve à la place d'une sortie normale

Option incompatible avec l'option Or2

Option interdite si la gestion des besoins matières détaillés par dossier est activée.

Oct

Affichage spécifique cartonniers (actuellement longueur et largeur de la ligne de commande)

Ocw

Contrôle de date warning

Od2

Suppression du contrôle du nombre de palettes dans un emplacement

Ne tient plus compte de l'option payante BAS 22.

Odp

Ouverture automatique de la fenêtre de saisie du détail palettes avant la saisie de la quantité de la ligne

La quantité de la ligne n'est pas modifiable.

C'est la quantité totale de la fenêtre de saisie qui initialise la quantité de la ligne.

Cette option est autorisée si les 3 conditions suivantes sont réunies :

l'option Opa est paramétrée,

so_options[40] = N,

l'option Osq n'est pas positionnée.

Odv

Détail vrac

Oea

Edition des étiquettes d'achat

est automatiquement activée si #CF BOB A2[45] = 2.

Cette option n'est plus incompatible avec l'option Opa pour les articles suivis à la palette en conteneur PA (mp_param[17] = 1 ou 2) et l'option société 40 = .

Oeb

Edition du bon de réception. Voir alpha2[24,29]

Oec

Message de confirmation avant l'édition des étiquettes d'achat

Cette option n'est plus incompatible avec l'option Opa pour les articles suivis à la palette en conteneur PA (mp_param[17] = 1 ou 2) et l'option société 40 = .

Oee

Edition étiquettes

Oen

Edition d'une étiquette neutre (Sans quantité)

Cette option n'est plus incompatible avec l'option Opa pour les articles suivis à la palette en conteneur PA (mp_param[17] = 1 ou 2) et l'option société 40 = .

Oep

Gestion des entrées de composants d'un ensemble.

L'option Opa est positionnée automatiquement.

Voir les notes

_SUP_SQL_EC_NOM0

_SUP_SQL_EC_STK0

EC_LIEU_STOCKAGE

EC_TMV_ENTREE

Oev

Edition des étiquettes d'achat pour les articles gérés en vrac

Ce sont des étiquettes neutres (Sans quantité).

Cette option est autorisée si les 2 conditions suivantes sont réunies :

l'option Opa est paramétrée,

so_options[40] = N.

Ofb

Mise à jour du numéro et de la ligne de commande fournisseur du 1er mouvement d'entrée des bobines du BRU

En réception manuelle des bobines, le numéro et la ligne de commande fournisseur des mouvements d'entrée des bobines ne sont pas renseignés.

Cette option met à jour le numéro et la ligne de commande fournisseur des mouvements d'entrée des bobines.

Le numéro et la ligne de commande fournisseur sont recherchés dans les lignes de commande fournisseur réceptionnées.

Le module prend la 1ère ligne de commande fournisseur du même papier et de la même laize que la bobine.

Ofp

TOP fin de période

Ofr

Mise à jour des fichiers de réception ou retour

Ogc

Gestion des réceptions à la palette avec la gestion des conteneurs

Cette option vient en complément de l'option 40 de la fiche société.

Option Opa nécessaire

Ogi

L'affectation correspond au sous-secteur + numéro de commande

Oi1

Demande unique du choix de l'imprimante d'édition des étiquettes

Oie

Initialisations de zones à partir du paramétrage du site de production (SIT A1[31,39])

Le lieu de réception est celui du site saisi du l'entête de la commande.

Voir aussi la note INIT_FAM_LIEUX.

Tableau de bord du multisite

Ola

On utilise les longueur et largeur de la ligne d'achat pour le coef_conv

Olb

Met à jour le lot papier avec le numéro de BRU

Olc

Affichage du libellé de l'article dans la commande et non pas du libellé de l'article dans le fichier article

Olf

Permet, lorsque l'affectation n'est pas renseignée, d'affecter les mouvements de stocks du bon de réception et leur centre de coût à la ligne de commande fournisseur

Oln

Lignes de notes sur les lignes du BR

Sans cette option, les notes saisies vont sur les lignes de commandes fournisseurs.

Plus de détails

Ne pas oublier de paramétrer les types de notes accessibles par –C

Exemple : -C2BR pour les NTS BR)

Ols

Affichage des lignes soldées

Olz

Stockage de la laize de la ligne de commande dans le lieu de rangement de niveau 2 du mouvement de stock

Oma

Si la saisie se fait par détail palette (Odp), l'affectation de l'entrée en stock sera la même que l'entrée prévisionnelle sinon l'affection sera par défaut du type No de commande + ligne + "PALETTE"

Omd

Modification du prix à la réception impossible

Omf

La marge de fiche article est fixe (Cette option est active uniquement avec l'option -Omp)

Oml

Saisie multilignes de commande fournisseur autorisée

Lors de la création d'un bon de réception de commande fournisseur, permettre de n'indiquer que le numéro de commande fournisseur (et non plus la ligne) même si l'option BAS/22 de gestion des emplacements est activée.

Omn

Possibilité de modifier ou créer les notes de la commande d'achat

Omp

Mise à jour du prix d'achat de la fiche article avec le prix saisi sur la ligne de réception

Omu

Saisie multi-devises au niveau de la ligne de réception ou de retour

Ony

Numérotation annuelle des bons de réception

Oof

Forçage de l'ouverture de la fenêtre de saisie du détail des palettes dans le cas où l'article est géré en vrac

L'option Opa doit être paramétrée.

Oos

Ouverture systématique de la fenêtre de saisie du lot et des lieux

Opa

Réception à la palette et accès au choix du n° de ligne de commande

Voir aussi A2[55]

Opb

Mise à jour du prix des bobines dans le fichier articles et les mouvements de stock

Opc

Gestion des papiers client. Réception de papier sans commande d'achat.

ATTENTION ! option spécifique

Opm

Prise en compte des champs Frais et Perte lors de la mise à jour du prix dans la fiche article.

Ces frais sont calculés en % et non en valeur.

Option -Omp obligatoire

Opp

Pas d'initialisation du poids de la réception - Voir mp_param[30]

Le poids est stocké dans la zone s0_libre de la table stk0

Opv

Gestion du prix de vente sur les mouvements de sortie

Opz

Possibilité de saisir un prix à 0 même pour les articles valorisés

Oqb

Supprime le contrôle de cohérence sur la quantité papier rapprochée

Oqc

Supprime la question Création d'un bon de réception ? (la réponse est toujours oui)

Oqr

Supprime le contrôle de cohérence sur la quantité reçue

(Ouverture d'une fenêtre de confirmation si quantité reçue supérieure à quantité commandée)

Cette option est intéressante lorsque l'on réceptionne toujours plus que ce que l'on a commandé

Or2

Recréation des reliquats de sortie réserve en désolde de ligne commande

Option incompatible avec l'option Ocr

Option interdite si la gestion des besoins matières détaillés par dossier est activée.

Ora

Lieu de rangement de la fenêtre de saisie du détail palettes initialisé avec celui de l'article

Si celui-ci n'est pas renseigné, il est initialisé avec celui du paramètre de lancement (A2[36,50]).

Voir aussi la note INIT_FAM_LIEUX.

Ore

Re-création des entrées prévisionnelles lors du désolde de la ligne de commande d'achats

Orh

Saisie d'un numéro de BRH (gestion des bobines). Le BRH est facultatif

Ors

On tient compte des remises dans le calcul du prix du mouvement de stock

Ort

Saisie des bons de retour de marchandises

Oru

Saisie d'un numéro de BRU (gestion des bobines). Le BRU est obligatoire

Osa

Affichage de O dans la zone solde de la ligne de commande fournisseur si quantité réceptionnée >= quantité commandée

Osc

Activation de la génération des mouvements de sortie des composants

Osf

Désactive la synchronisation de la sortie matière au délai de fabrication du lot.

Suite à une modification du mode d'alimentation de la date du mouvement de sortie généré lors de la réception des matières, mise en place d'une option permettant de retrouver le fonctionnement d'avant modification.

Osp

Saisie du prix pour plusieurs unités possibles

Voir description plus complète de ce paramètre sur le programme de saisie des stocks

Osq

Saisie d'une quantité dans plusieurs unités possibles

Voir description plus complète de ce paramètre sur le programme de saisie des stocks

Incompatible avec Odp

Osr

Pas de mise à jour du stock résultant

Osz

Demande de confirmation de la modification d'un prix de réception si stock physique à zéro

En cas de modification du prix et stock physique à zéro, le PAMP n' évolue pas

Otm

Alimentation de la zone libre avec le montant total saisi sur la ligne par la touche F17

Oua

Saisie de la quantité réelle en unité d'achat

Les options Ofr et Osq sont obligatoires.

Our

Remplace l'option Oar avec la contrainte suivante : la sortie réserve doit exister si on veut générer la sortie normale.

Cette option permet d'effectuer une sortie normale seulement pour les sorties affectées à un dossier.

2 nouvelles conditions sont ajoutées à cette sortie normale :

La première sur le TYF et la deuxième sur mp_param[44].

Option interdite si la gestion des besoins matières détaillés par dossier est activée.

Ove

Edition VoluEdit

Owm

Contrôle non bloquant sur la date du mouvement qui doit être comprise dans le mois en cours

Valeur alpha 2

Caractères 1 à 3

Type de mouvement de stock généré en entrée normale

Caractères 4 à 6

Type de mouvement de stock généré en entrée normale à contrôler

Caractères 7 à 9

Type de mouvement de stock généré en sortie normale

Ce type de mouvement permet de transformer la Sortie réserve créée par la commande d'achat par une Sortie normale.

Caractères 10 à 15

Type et code du paramètre du programme d'édition d'étiquettes (#ED ETA par défaut)

Caractères 16 à 18

Type de mouvement de stock généré en sortie réserve

Caractères 19 à 21

Code paramètre de l'édition des bons de papier

Caractère 22

Position par défaut de la confirmation Création bon. Par défaut, Non

Caractère 23

Position par défaut de la modification de bon. Par défaut, Non

Caractères 24 à 29

Type et code du paramètre de lancement de l'édition du bon (Valeur par défaut #ED BRC)

Caractères 30 à 32

Code paramètre TOP

Caractères 33 à 35

Type du mouvement d'entrée en commande généré lors du désolde de la ligne d'achat

Nécessite option -Ore. Valeur par défaut :EC

Caractères 36 à 38

Lieu de rangement de niveau 1 des réceptions de palette par défaut

Caractères 39 à 44

Lieu de rangement de niveau 2 des réceptions de palette par défaut

Caractères 45 à 50

Lieu de rangement de niveau 3 des réceptions de palette par défaut

Caractères 51 à 53

Code du paramètre du mot de passe

Permettre de paramétrer un mot de passe pour limiter l'accès à la modification d'un bon de réception ou d'un bon de retour.

Caractère 54

Numéro de formule de conversion à utiliser pour convertir la quantité de bobine en quantité de commande d'achat (1 à 4)

Caractère 55

Activation des TSC contextuels (O/N)

L'option Opa permet de saisir le nombre de produits par palette, ainsi que le nombre de palettes pour cette quantité.

En parallèle de cette option, en configurant un TSC contextuel (TSC REC) sur la zone lf_qterec, on peut désormais saisir le nombre TOTAL de palettes pour cette réception.

L'option 29 doit activée sur la société (so_options[29] = O).

Voir aussi le champ lf_qterec dans la note CONTEXTE_TSC du TSC.

Valeur alpha 3

Caractère 1 | Contrôle du lieu de rangement 3, article non géré à la palette. Le lieu 3 ne doit pas être saisi. N Pas de contrôle B Contrôle bloquant W Contrôle en avertissement
Caractère 2 | Contrôle du lieu de rangement 3, article géré à la palette. Le lieu 3 doit être saisi. N Pas de contrôle B Contrôle bloquant W Contrôle en avertissement
Caractère 3 | Contrôle d'obligation de saisie de la référence BL du fournisseur N Pas de contrôle W Message d'avertissement C Demande de confirmation B Contrôle bloquant
Caractère 4 | Contrôle de doublon de la référence BL du fournisseur N Pas de contrôle W Message d'avertissement C Demande de confirmation B Contrôle bloquant
Caractère 5 | Contrôle de stock physique de lot négatif Facultatif N Pas de contrôle (Valeur par défaut) W Avertissement C Demande de confirmation B Bloquant
Caractère 6 | Masquer la colonne ligne de cadencement (O/N, N par défaut)
Caractère 7 | Masquer la colonne famille (O/N, N par défaut)
Caractère 8 | Masquer la colonne sous-famille (O/N, N par défaut)

Notes triées

Attention, si le complément est sur plusieurs lignes, elles sont concaténées sans ajout de blanc entre chacune d'entre elles.

AIDE_SAISIE_OF

Méthode d'aide à la saisie des OF. Ce paramètre est prioritaire sur les autres.

BLOCAGE_MAJ_PRX_CDA

Permettre de bloquer la modification du prix des lignes de bons de réceptions non rapprochées.

Remarque : Le prix sera réactualisé sur la saisie des lignes de commandes d'achat en utilisant la ligne de note MAJ_PRIX_LIGNES_BRC de la saisie des commandes d'achat.

21 Blocage de la modification du prix

C Demande de confirmation

W Message non bloquant

B Message bloquant

N Pas de blocage (par défaut)

CONF_NB_EXEMPL_ETIQ

Permet d'éditer des étiquettes vrac depuis un bon de réception

21 Choix du nombre d'exemplaires d'étiquettes à éditer

22 Nombre d'exemplaires d'étiquettes par défaut

Voir aussi la note ETIQACHAT_IMP et les options Oev et Ove.

CRBR

5,60 Complément de select sur la table des entêtes de bons de réception et de retour (b_rec_ret_e)

Exemple

CRBR and bre_bon matches 99*

CREC

5,60 Complément de select sur la table des entêtes de commande (cdf1)

Exemples

CREC and ef_tyc = FAD

CREC and ef_xxxx .....

CRLC

5,60 Complément de select sur la table des lignes de commande (cdf2)

Exemples

CRLC and lf_qteliv != 0

CRLC and lf_xxxx .....

CRMS

5,60 Complément de select sur la table des mouvements de stock (stk0)

Exemples

CRMS and s0_qte != 0

CRMS and s0_xxxx .....

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_LFV

Lors d'une demande de transfert, prendre en compte la ventilation des lignes de commande d'achat

Voir le chapitre #CF DP2

DIRECT_PLANNING_SEL

21,60 Complément de sélection sur les tables cdf1 et cdf2 pour ne pas générer systématiquement une demande à chaque création, modification ou réception d'une commande d'achat.

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

EC_LIEU_STOCKAGE

21,23 Lieu de rangement 1 (avec option Oep)

24,25 Lieu de rangement 2 (avec option Oep)

EC_TMV_ENTREE

21,23 Type de mouvement d'entrée (avec option Oep)

ETIQACHAT_IMP

21,23 Code paramètre de l'imprimante pour l'édition automatique des étiquettes d'achat (ETP par défaut)

24 Imprimante automatique (O/N)

O Imprimante automatique (pas de choix) (voir aussi option Oi1)

N Imprimante non automatique (choix)

FORMAT_QUANTITE

21,60 Format numérique à appliquer aux zones de quantité

Voir aussi la note AFFICHE_UNITE_QTE dans le paramètre USE.

INIT_FAM_LIEUX

Initialisation des lieux de rangement en fonction de la famille de l'article

21,23 Code famille. Obligatoire

24 Mode d'initialisation des lieux de rangement. Obligatoire

1 Lieux de rangement de l'article (idem Ora)

2 Lieux de rangement du site de production (idem Oie) - Tableau de bord du multisite

Avant : Les lieux de rangement pouvaient être initialisés de 3 façons :

1 - Lieux de rangement du paramètre de lancement (pas d'option Oie ou Ora)

2 - Lieux de rangement du site de production (option Oie)

3 - Lieux de rangement de l'article (option Ora)

Maintenant, l'initialisation des lieux de rangement peut être faite en fonction de la famille de l'article.

Si la famille n'est pas paramétrée, les lieux de rangement seront initialisés comme auparavant.

Si le mode d'initialisation de la famille est 1, les lieux de rangement seront initialisés avec ceux de l'article (idem Ora).

Si le mode d'initialisation de la famille est 2, les lieux de rangement seront initialisés avec ceux du site de production (idem Oie).

NEW_CODE_VALIDITE

21,23 Code validité à mettre à jour sur l'article réceptionné

Si non renseigné, alors aucune action. Voir la note _SUP_REQ_MAJ_VALID

La note NEW_CODE_VALID_BRC du TYF est prioritaire sur celle-ci.

PARAM_LCT_LOT_INDUS

21,26 Type et code du paramètre de lancement de la saisie des lots industriels.

Cette note est obligatoire si la gestion des lots industriels est activée.

Elle permet l'accès à la saisie des lots industriels en création et/ou en modification.

RUN_EDIT_OEX

21, 26 Type et code du paramètre de lancement de l'édition de la fiche de fabrication

SC_LIEU_STOCKAGE

21,23 Lieu de stockage par défaut (RG1)

Ce lieu sert à :

• rechercher les mouvements d'entrée des composants

• alimenter le lieu de rangement des mouvements de sortie à générer

Le lieu est recherché en priorité sur le TSC du fournisseur (voir note SC_TSC_FOURNISSEUR)

SC_TMV_ENTREE

21,23 Type de mouvement de stock utilisé pour la recherche des mouvements d'entrée des composants liés à l'ensemble

SC_TMV_SORTIE

21,23 Type de mouvement de stock utilisé pour la génération des mouvements de sortie des composants liés à l'ensemble

SC_TSC_FOURNISSEUR

21,23 Code TSC sur le fournisseur servant à saisir le lieu de stockage

24 Zone TSC servant à la saisie du lieu de stockage

F Zone alpha 1 (ic_char3_1) (par défaut)

G Zone alpha de 30 caractères (ic_char30)

H Zone alpha 2 (ic_char3_2)

Voir aussi la note SC_LIEU_STOCKAGE

_SUP_REQ_REC_CDE_CLI

21,60 Complément de requête pour la recherche de la commande client (avec option Occ)

_SUP_REQ_MAJ_VALID

Complément de requête sur la fiche matière

L'article réceptionné ne sera mis à jour que s'il remplit cette condition.

But : pouvoir modifier automatiquement la validité d'un article réceptionné.

Voir la note NEW_CODE_VALIDITE.

La note _SUP_MAJ_VALID_BRC du TYF est prioritaire sur celle-ci.

Exemple

NEW_CODE_VALIDITE REE

_SUP_REQ_MAJ_VALID and mp_qualite = "INA"

_SUP_REQ_MAJ_VALID and mp_fam = "PAP"

_SUP_REQ_MAJ_VALID and mp_sfm = "T3"

_SUP_REQ_RECH_CDF

21,60 Complément de requête sur la table cdf1 pour la recherche des commandes d'achat

_SUP_REQ_SITE

Nouvelle zone dans la table b_rec_ret_e : bre_site

On renseigne par défaut cette zone avec le code site paramétré sur USE A3[10,12].

On peut par paramétrage rajouter un complément de sélection sur cette zone.

Ce complément s'ajoutera à celui déjà existant issu des notes CREC s'il porte sur une zone de la table des entêtes d'achat, ou sur les notes CRBR, s'il porte sur une zone de l'entête des bons de réception.

Tableau de bord du multisite

21,60 Nom de zone

ef_c1 : Nom de la zone correspondant au code site de l'entête de commande fournisseur.
L'ajout de cette ligne déclenche la recherche des commandes fournisseurs ayant un site de renseigné égal au site du code utilisateur.

bre_site : Ce critère sera utilisé pour la recherche de bon de réception

_SUP_SQL_EC_NOM0

21,60 Complément de requête sur la table nomenclature pour la recherche des composants de l'ensemble

(avec option Oep)

_SUP_SQL_EC_STK0

21,60 Complément de requête sur la table stocks pour la recherche des mouvements de stock à annuler

(avec option Oep)

_SUP_SQL_SC_NOM0

21,60 Complément de sélection sur la table nomenclature pour la recherche des composants liés à l'ensemble

_SUP_SQL_SC_STK0

Complément de sélection sur la table stocks pour la recherche des mouvements d'entrée des composants

TITRE_ECRAN_INT

21,60 Titre de l'écran en consultation

exemple : CONSULTATION DES BONS DE RETOUR

TITRE_ECRAN_SAI

21,60 Titre de l'écran en saisie

exemple : SAISIE DES BONS DE RETOUR

TITRE_C1_SAI_PAL

21,27 Titre de la colonne 1 de la saisie du détail palette (rgt3)

TITRE_C2_SAI_PAL

21,27 Titre de la colonne 2 de la saisie du détail palette (rgt3)

TITRE_QTE_SAI_PAL

21,42 Titre de la quantité de la saisie du détail palette (rgt3)

TITRE_SAI_PAL

21,60 Titre de la saisie du détail palette (rgt3)

TYPE_NOTE_BLO_RC

21,23 Type de note de revue de contrat

Si cette note est renseignée et si on solde la réception et si la quantité du cadencement est supérieure à la quantité réceptionnée totale, un code blocage automatique (039) sera positionné sur la revue de contrat.

TYPE_NOTE_CDE_CLI

21,23 Type de note pour l'enregistrement sur la ligne de commande client du numéro de BL

Le numéro de BL est égal à la référence du BL fournisseur.

TYPE_NOTE_LIG_ACHAT

21,23 Type de la note de ligne d'achat à afficher

TYPE_NOTE_PROD_AUTO

21,23 Type des notes saisies sur mat

Réception par palette avec la quantité par palette dans le lieu de rangement 3

La réception des commandes fournisseurs se fait toujours en global pour les articles non gérés par palette.

La réception des commandes fournisseurs se fait maintenant en détail pour les articles gérés par palette (Nombre de palettes et quantité par palette) avec possibilité d'éditer des étiquettes d'achat.

Paramétrage :

Voir les options -Opa, -Oea, -Oen, -Oec

Les options -Opa et -Ofr doivent être activées.

Les options -Oar, -Oaf et -Ocr ne doivent pas être activées.

alpha2[36,50]

Notes commençant par ETIQACHAT_IMP

so_options[40] = N

mp_param[40] = N pour les articles non gérés par palette.

mp_param[40] = O pour les articles gérés à la palette.

Une même réception peut contenir à la fois des articles non gérés par palette et gérés par palette.

Sur les lignes détail, lorsque l'article est géré par palette et la quantité reçue est modifiée et différente de 0, une fenêtre Saisie du détail palettes s'ouvre pour saisir celui-ci.

La touche F12 permet d'ouvrir cette fenêtre pour modifier le détail même si la quantité reçue n'a pas été modifiée, si l'article de la ligne détail est géré par palette.

En saisie d'une nouvelle réception, le tableau du détail palettes est pré-rempli.

Le nombre de palettes réceptionnées est obtenu en divisant la quantité reçue par le nombre de paquets par palette (TSC 220 de l'article).

Si la quantité reçue n'est pas un multiple du nombre de paquets par palette, une palette est ajoutée avec la quantité restante (Quantité reçue – Nombre de palettes X Nombre de paquets par palette) comme nombre de paquets par palette.

Le triplet lieu de rangement 1, lieu de rangement 2 et quantité par palette doit être unique pour une même ligne de commande ou ligne de cadencement de ligne de commande.


Edition des bons de réception

Edition des bons de réception ebrc

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bon de réception

Exemple : -N[bre_bon]

Options triées

-Oca | Edition des lignes de cadencement
-Oce | Affichage d'une fenêtre pour demander confirmation de l'édition des étiquettes
-Oen | SPECIFIQUE Pour éditer une étiquette neutre (quantité 0 sur la dernière étiquette)
-Oep | Pour traiter l'édition des étiquettes
-Ofr | Edition à partir des fichiers de réception ou retour de marchandises
-Ola | On utilise les longueur et largeur de la ligne d'achat pour le coef_conv
-Ort | Edition des bons de retour de marchandises (non géré)

Valeur alpha 2

Caractères 1 à 3 | SPECIFIQUE Type de notes 1 à éditer
Caractères 4 à 6 | SPECIFIQUE Type de notes 2 à éditer
Caractères 7 à 9 | SPECIFIQUE Type de notes 3 à éditer

Valeur alpha 3

Titre de l'écran. Par défaut : Edition des bons de réception

Valeur alpha 4

Caractère 1 | Edition du lot (O/N)
Caractère 2 | Edition du lieu de rangement 1 (O/N)
Caractère 3 | Edition du lieu de rangement 2 (O/N)
Caractère 4 | Edition du lieu de rangement 3 (O/N)
Caractère 5 | Edition des lignes soldées (O/N)

Notes

LP | Paramétrage de l'état. Le –X existe mais il ne suffit pas. 3 Numéro de l'état (1 « en dur » dans le code) 4,6 Code du paramètre à utiliser. Par défaut : BRC 7,8 Nombre d'exemplaires à éditer. Par défaut : 1
SS | 3,60 Complément de sélection sur la table stk0 à ajouter à la requête. Exemple SS and s0_etat = N
SB | 3,60 Complément de sélection sur les tables de réception / retour de marchandises Exemple SB and bre_devise = FRF La saisie des bons de réception de marchandises doit mettre à jour les fichiers de réception ou retour de marchandises si on utilise le paramètre –Ofr.
ETIQPROD_IMP | 21,23 Imprimante pour édition automatique des étiquettes de production


Contrôle des factures fournisseurs

Contrôle des factures fournisseurs facf

Saisie et contrôle des factures fournisseurs (via les bons de réception)

Cette saisie ne peut fonctionner que si l'option Ofr est indiqué lors de la saisie des bons de réception

(alimentation des tables b_rec_ret_d et b_rec_ret_e). L'ajout de l'option n'est pas rétroactif.

Valeur numérique 1

Numéro de compteur

Options triées

-B

Mode batch (disponible uniquement avec l'option Oir)

Oar

Aide au rapprochement des factures fournisseurs

Nécessite l'option payante ACH 05

Permet l'ouverture d'une fenêtre s'appuyant sur les données fournies par votre fournisseur pour aider l'utilisateur à rapprocher ces factures fournisseurs. Une fois les lignes de factures validées, l'application de contrôle est pré-remplie, il ne reste plus qu'à indiquer le montant de contrôle et de créer la facture.

Voir aussi :

- l'option Oir pour l'importation des fichiers du fournisseur

- TSC TJV Transfert journal de vente

- la note MAJ_FLAG_INFO_C dans la visualisation du journal des ventes

- les nouvelles zones lst_bl, date_liv et numero_bl dans la visualisation du journal des ventes

Obl

On liste les références de BL fournisseurs à inclure dans la facture

Occ

Contrôle exclusif des factures à partir des commandes

Permet de faire le contrôle des factures d'achats à partir des commandes et non pas des réceptions. Exemple pour les factures de transport qui ne sont pas réceptionnées.

Oei

On calcule avec l'escompte fournisseur mais on ne l'affiche pas dans les lignes

Ofa

Saisie des factures de frais d'approche

La sélection des bons de réception est automatiquement désactivée (A2[9] = N).

Voir l'affectation des factures de frais d'approche.

Ofc

Accès à la date comptable

Voir A2[30,33]

Ofe

Affichage de message d'avertissement lors de la détection de factures fournisseurs à l'état enregistrées mais non validées.

Ofm

Recherche du compte d'achat directement sur la famille (Idem Ofm transfert des achats)

Ogo

Gestion des opérations associées aux articles

Les codes opérations doivent être placés dans la zone ic_char30 du TSC FOP du code article.

Les correspondances article / opération sont paramétrées dans les notes commençant par LIEN_PROD_OPE.

Oir

Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures

Voir l'option Oar pour l'aide au rapprochement des factures fournisseurs.

Permet d'importer un fichier avec la liste des factures fournies par votre fournisseur.

Ce fichier permet de faire un lien entre ces BL et vos bons de réception.

A utiliser en mode batch (option -B) et avec les notes suivantes :

FIC_ANO_RAPPRO

FIC_LOCK

FIC_RAPPRO_FAC_FOU

SEPARATEUR_FIC_IMP

SUP_REQ_BRE_BRD

CODE_FOU_IMPORT_AR

La structure du fichier d'import est indiquée en bas de cette page.

Ola

Comme en saisie de ligne de commande fournisseur, on prend en compte les dimensions stockées sur la ligne de commande fournisseur pour la formule de conversion.

Oma

Active la possibilité de saisir plusieurs affectations sur une même ligne de facture

La même option existe dans la visu du journal des achats.

Ome

Mise à jour des entrées en stock. Fonctionne avec alpha3[15,20].

Omf

Marge fixe lors de la mise à jour du prix dans la fiche article

Option Omp obligatoire

Omn

Gestion de l'entrée prévisionnelle et des réserves associées liées à l'affectation de la sous-traitance

Omp

Mise à jour du prix d'achat dans la fiche article

Onp

Les lignes de bon de réception ne sont pas cochées Pointé en création de factures fournisseurs

Opm

Prise en compte des champs Frais et Perte lors de la mise à jour du prix dans la fiche article

Option -Omp obligatoire

Oq5

Calcul de la quantité de fab5 sans application du coefficient de conversion

Dans la saisie des factures d'achat, la quantité de fab5 est égale à la quantité facturée multipliée par le coefficient de conversion de l'article.

Dans la réception des commandes d'achat, la quantité de fab5 est égale à la quantité réceptionnée.

Le coefficient de conversion de l'article n'est pas pris en compte.

Si l'alimentation de fab5 est activée dans les 2 saisies, on se retrouve avec des quantités qui ne sont pas exprimées dans la même unité.

Cette option permet de ne pas appliquer le coefficient de conversion lors du calcul de la quantité de fab5 dans la saisie des factures d'achat.

Oqd

Affichage des quantités avec décimales

Ora

Rattachement des avoirs aux factures ou aux commandes d'achat

Cette option permet de faire cohabiter les options Obl et Occ.

Si saisie d'une facture d'achat, l'option Obl est activée si elle a été paramétrée et l'option Occ est désactivée.

Si saisie d'un avoir d'achat, l'option Occ est activée si elle a été paramétrée et l'option Obl est désactivée.

Orc

Réinitialisation du compteur en fonction de la date de facture

Orf

Calcul avec uniquement la remise issue de la fiche fournisseur

Osf

Saisie du montant des frais HT

Osh

Saisie du montant hors taxe

Osq

Saisie des quantités dans différentes unités de stockage

Le champ mp_fconv de l'article doit être renseigné.

Oss

Permet de saisir un site lorsque la facture est saisie sans bon de réception.

Tableau de bord du multisite

Ce site est utilisé dans le transfert des factures. Il est mis à jour dans la table facfou2 dans le champ code_tva sur l'enregistrement (ff2_enr) 1 qui est le HT.

Ost

Saisie de la TVA autorisée. Permet de modifier le montant de la TVA de la facture.

Otf

Top de Fin de mois autorisé. Dans TOP FIN, Renseigner les 2 valeurs numériques (année et mois)

Voir aussi A2[3]

Oua

Saisie de la quantité réelle en unité d'achat

L'option Osq doit être activée.

Valeur alpha 2

Caractère 1

Numérotation automatique (O/N, N par défaut)

Caractère 2

Numérotation annuelle (O/N, N par défaut)

Caractère 3

Gestion du top fin de période (O/N, N par défaut)

Caractère 4

Validation automatique de la facture après sélection des bons de réception si le montant de la facture est égal au montant à contrôler saisie (O/N, N par défaut)

Caractère 5

Type de recherche d'article (1, 2, 3, T, Q) (1 par défaut)

Caractère 6

Mise à jour de la table fab5 (sous-traitance gérée par programme strai) (O/N, N par défaut)

Caractère 7

Date par défaut (T/N, N par défaut)

Caractère 8

Ouverture de la fenêtre de saisie de la remise, escompte …(O/N, O par défaut)

Caractère 9

Ouverture de la fenêtre de sélection des bons (O/N, O par défaut)

Caractère 10

Contrôle de l'existence de la clé de répartition dans la table cle_rep (O/N, N par défaut)

Caractère 11

Contrôle de l'existence de du centre de coût dans la table cle_rep (O/N, N par défaut)

Caractère 12

Ouverture de la fenêtre de saisie des affectations comptables et analytiques

N Non (valeur par défaut)

1 OUI à la saisie du code article si la ligne de facture n'a pas de bon de réception

2 OUI à chaque ligne si la ligne de facture a un bon de réception

3 OUI pour les 2 cas

Caractère 13

Mode d'affectation de la section analytique si elle n'a pas été affectée à la saisie de la commande fournisseur ou si c'est une ligne de facture dans commande

0 Pas d'affectation de la section analytique (valeur par défaut)

1 Section analytique de a fiche 'article

2 Spécifique

3 Affectation selon le paramétrage du #CF TFF A4[15,16]

4 La section analytique est celle de l'entête de commande fournisseur.
Si elle est vide, on prend celle de l'article.

5 Lecture en cascade

1. Section analytique de la fiche article (mode 1)

2. Section analytique saisie sur le couple famille/sous-famille

3. Section analytique saisie sur la famille

4. Section analytique selon le paramétrage du #CF TFF A4[15,16]] (mode 3)

Un paramétrage identique existe aussi sur le #CF CDF.

Caractères 14 à 19

Type et code du paramètre de configuration des comptes d'achat. Par défaut : #CF TFF

Caractère 20

Mise à jour de la table fab5 pour tous les produits (O/N, O par défaut)

Uniquement les produits port et sous-traitance (mp_param[10] = O ou P).

Caractère 21

Recopie de l'affectation d'une nouvelle ligne à partir de la ligne précédente (O/N)

Caractère 22

Accès aux TSC en modification pour les factures déjà transférées (O/N, N par défaut)

Caractères 23,25

Code site utilisé pour le contrôle paramétré en caractère 26

Tableau de bord du multisite

Caractère 26

Contrôle si le code site de la commande d'achat est identique au code site du menu

Tableau de bord du multisite

Le code site du menu est obligatoire si le code contrôle est différent de N.

N Pas de contrôle

W Contrôle avec message d'avertissement

C Contrôle avec demande de confirmation

B Contrôle bloquant

S Sélection : On ne présente dans les commandes à facturer que celles rattachées au site à contrôler. Attention : dans ce cas uniquement, si le site à contrôler n'est pas paramétré, on prend celui de l'utilisateur – USE A3[10,12]

Caractères 27 à 29

Code du top de facturation (paramètre de type TOP)

Valeur par défaut : FIN

Caractère 30

Gestion du top fin de période de la date comptable (O/N, N par défaut)

Voir l'option Ofc

Caractères 31 à 33

Code du top de facturation de la date comptable (paramètre de type TOP)

Valeur par défaut : FIN

Voir l'option Ofc

Valeur alpha 3

Caractères 1 à 7 | Ecart autorisé en plus entre le montant saisi de la facture et le montant à contrôler
Caractères 8 à 14 | Ecart autorisé en moins entre le montant saisi de la facture et le montant à contrôler
Caractères 15 à 20 | Type et code du paramètre de lancement du programme de recalcul des mouvements de stocks en aval : crinv. Fonctionne avec l'option Ome Exemple de paramétrage de recalcul des mouvements de stocks (cas de prix moyens pondérés) : crinv.4ge -Omsmrcusasi
Caractères 21 à 23 | Code mot de passe pour annulation
Caractère 24 | Saisie obligatoire de la référence de facture fournisseur N Pas de contrôle W Message d'avertissement si référence non saisie B Message bloquant si référence non saisie C Demande de confirmation si référence non saisie
Caractère 25 | Contrôle de la présence de doublon (référence/code fournisseur) suite à la saisie de la référence de facture fournisseur N Pas de contrôle W Message d'avertissement si la référence existe déjà pour le fournisseur B Message bloquant si la référence existe déjà pour le fournisseur C Demande de confirmation si la référence existe déjà pour le fournisseur
Caractère 26 | Afficher la colonne Commande (O/N, N par défaut)
Caractère 27 | Afficher la colonne Réf BL fournisseur (O/N, N par défaut)
Caractère 28 | Afficher la colonne Facture/date BRC (O/N, N par défaut)

Notes

#CC | Contrôle des champs de l'entête 5 à 22 Nom du champ. Les champs suivants sont contrôlés : ff0_date_piece Date de la pièce ff0_reference Référence de la pièce ff0_mrg Mode de règlement ff0_ech Code échéance ff0_dev Code devise ff0_mode_tva Mode TVA 23 Type de contrôle N Pas de contrôle W Warning si champ non saisi B Champ obligatoire I Champ interdit en saisie 24 Génération d'une trace dans evt en cas de modification du champ 25 Saisie de la valeur zéro Gestion de la valeur zéro uniquement pour les valeurs numériques Si la valeur saisie est à zéro et qu'elle n'est pas significative, alors elle est remise à null pour être considérée comme non saisie. O Le zéro est significatif N Le zéro n'est pas significatif (considéré comme valeur nulle)
CODE_FOU_IMPORT_AR | 21,26 Code fournisseur imposé dans le cadre du rapprochement des factures Si cette note est présente, le code fournisseur du fichier d’import est ignoré et sera remplacé par celui-ci.
FIC_ANO_RAPPRO | Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures 21,60 Nom du fichier anomalie
FIC_LOCK | Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures 21,60 Nom du fichier de verrouillage d'import
FIC_RAPPRO_FAC_FOU | Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures 21,60 Nom du fichier d'import. L'éventuel astérisque contenu dans le nom du fichier permet d'intégrer dans le même traitement tous les fichiers ressemblant à ce nom.
LIEN_PROD_OPE | Correspondances article / opération. Option Ogo nécessaire 21,35 Code produit 41,50 Code opération
SEPARATEUR_FIC_IMP | Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures 21 Type de séparateur entre les champs. Séparateur par défaut : point-virgule
SUP_REQ_BRE_BRD | Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures 21,60 Complément de sélection des tables b_rec_ret_e et b_rec_ret_d
_SUP_REQ_FAB0 | 21,60 Complément de sélection pour la recherche de l'affectation
_SUP_REQ_FACFOU0 | 21,60 Complément de sélection sur la table des entêtes de factures fournisseurs Facultatif - Utilisé dans l'interrogation des factures fournisseurs Exemple _SUP_REQ_FACFOU0 and exists (select * from facfou1, cdf1 _SUP_REQ_FACFOU0 where ff1_soc = "SOC" _SUP_REQ_FACFOU0 and ff1_piece = ff0_piece _SUP_REQ_FACFOU0 and ef_soc = " SOC " _SUP_REQ_FACFOU0 and ef_num = ff1_cde _SUP_REQ_FACFOU0 and ef_c1 = "SIT")
TYF_GESTION_AVOIR | 21,23 Type d'avoir (exemple : AVO)

Importation d'un ou des fichiers du fournisseur pour le rapprochement des factures

Voir les options Oar et Oir.

Description du fichier importé

Nom du champ | Caractéristiques | Obligatoire
Code fournisseur | 6 caractères max | OUI
Numéro de commande interne au fournisseur | 20 caractères max | NON
Référence commande client interne au fournisseur | 20 caractères max | OUI si le type de pièce est un avoir
Code article | 15 caractères max | OUI
Référence BL fournisseur | 20 caractères max | NON
Liste des BL | Zone de texte | NON
Quantité livrée |  | OUI
Date de livraison | JJ/MM/AAAA | OUI
Numéro de facture fournisseur | 8 caractères max | OUI
Numéro de ligne de facture |  | OUI
Type pièce | A = avoir, F = facture | OUI
Date facture | JJ/MM/AAAA | OUI
Mode de règlement | 3 caractères max | NON (Si non renseignée : celui de la fiche fournisseur.)
Code échéance | 3 caractères max | NON (Si non renseignée : celle de la fiche fournisseur.)
Date échéance | JJ/MM/AAAA | NON (Si non renseignée : calculée automatiquement en fonction de la date de facture et du code échéance.)
Quantité facturée |  | OUI
Prix unitaire |  | OUI
Unité de prix | 3 caractères max | NON
Code devise | 3 caractères max | NON (Si non renseignée : celle de la fiche fournisseur.)
Taux de remise |  | NON
Taux d’escompte |  | NON
Prix unitaire remisé |  | NON
CA de la ligne de facture |  | OUI

Exemple de fichier :

973 ;021;973-00011 ;PF02010037-1 ;02102905; ;875.00 ;10/07/2002;02102170;1 ;F;29/07/2002;CH ;026;15/09/2002;875.00 ;0.00 ;MIL;EUR;0.0 ;2.0 ;1000.00000000;0.00 ;


Saisie des factures d'achat ou de sous-traitance

Saisie des factures d'achat ou de sous-traitance strai

Options [image] Configuration de l'édition

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande de sous-traitance

Exemple : -N[ec_num]

Options

-Nx | x étant le numéro de dossier à saisir. En saisie des achats extérieurs, le numéro de dossier sera initialisé avec le numéro de dossier à saisir.
-Oim | Imprimerie
-O01 | Aide à la saisie sur l'OF type 1 - Voir aussi Aide à la saisie des OF
-O02 | Aide à la saisie sur l'OF type 2 - Voir aussi Aide à la saisie des OF
-O03 | Aide à la saisie sur l'OF type 3 - Voir aussi Aide à la saisie des OF
-O04 | Aide à la saisie sur l'OF type 4 - Voir aussi Aide à la saisie des OF
-Otf | Edite un total par rupture. OUI en valeur par défaut
-Osf | Edite un saut de page par rupture. OUI en valeur par défaut
-Otg | Edite un total général
-Otq | Edite le total des quantités. La totalisation des quantités est paramétrable.
-Op1 | Autorisation de la saisie du port même si le dossier est clos. Avec demande de confirmation Dans le calcul du prix de revient, le port sera intégré et le dossier restera clos.
-Op2 | Autorisation de la saisie du port même si le dossier est clos. Sans demande de confirmation Dans le calcul du prix de revient, le port sera intégré et le dossier restera clos.
-Os1 | Autorisation de la saisie de la sous-traitance même si le dossier est clos. Avec demande de confirmation Dans le calcul du prix de revient, la sous-traitance sera intégrée et le dossier restera clos.
-Os2 | Autorisation de la saisie de la sous-traitance même si le dossier est clos. Sans demande de confirmation Dans le calcul du prix de revient, la sous-traitance sera intégrée et le dossier restera clos.
-On1 | Autorisation de la saisie sur article normal même si le dossier est clos. Avec demande de confirmation Dans le calcul du prix de revient, le montant sera intégré et le dossier restera clos.
-On2 | Autorisation de la saisie sur article normal même si le dossier est clos. Sans demande de confirmation Dans le calcul du prix de revient, le montant sera intégré et le dossier restera clos
-Of2 | Ouverture d'une deuxième fenêtre de complément de select sur le code du produit d'affectation.
-Oaf | Affection non accessible. L'accès à la zone affectation est interdit.
-Oia | Importation affectation. A la saisie d'une commande fournisseur, l' affectation de la ligne de commande fournisseur est importée dans la zone affectation.
-Oae | Affichage des écarts prévus / réalisés. Le prévu est puisé dans la commande fournisseur. Trois colonnes sont affichées à droite de la quantité et du montant saisi Le total réalisé Le prévu L'écart prévu / réalisé
-Oru | Remontée unique. Il ne peut exister qu'un seul mouvement de sous-traitance pour une commande fournisseur donnée. Il y a blocage après la saisie de ligne de commande fournisseur si le mouvement existe déjà.
-Ogn | Gestion négoce. Une commande d'achat est affectée à une commande client. Lors de la saisie du mouvement de sous-traitance, on remonte les informations "réalisés" sur la commande d'achat et la commande client. On dispose pour cela d'un tableau de suivi des écarts et marges.
-Obf | Si le code fournisseur est différent de celui de la commande fournisseur, il y a blocage. Sans cette option il y a un simple warning.
-Oce | Calcul la date d'échéance de la facture en automatique (échéance de la commande fournisseur)
-Ogs | Gestion des commandes de sous-traitance (maj de la commande d'achat)
-Oin | Forçage en manuel des factures à l'état intégré = O/N
-Ose | Solde de l'entête de commande d'achat si toutes les lignes sont soldées
-Oas | Saisie interdite des articles stockés (mp_suistk = O)
-Omd | En annulation, met à jour le dossier pour les factures intégrées et remet le dossier à calculer. Actuellement, ne fonctionne que pour les produits et non pour les opérations de sous traitance.
-Ocf | Suppression du contrôle : de la référence de la commande fournisseur du numéro de la commande fournisseur du numéro de ligne de la commande fournisseur
-Oro | Bascule du code article dans le code opération
-Oaz | Interdit de passer dans les zones code OP, code article, désignation et affectation
-Oss | Demande systématiquement si l'on veut solder la ligne de commande
-Orq | Recopie par défaut les quantités et le prix de la commande d'achat
-Ocs | Contrôle du solde de la ligne d'une commande fournisseur. La ligne ne doit pas être soldée
-Oso | La ligne doit être obligatoirement soldée pour permettre une saisie
-Oqr | Alimentation de la quantité avec la quantité réceptionnée (positionne automatiquement l'option -Orq)
-Ogi | Affectation pour le GIE papier
-Oca | Prise en compte du cadencement
-Omf | Mise à jour commande fournisseur si la date ou le numéro de facture sont saisis
-Oco | Numéro de commande fournisseur obligatoire
-Oai | Annulation de l'intégration pour modification du montant
-Ofp | TOP fin de période.
-Ode | N'édite pas le détail des lignes si une rupture est demandée. OUI en valeur par défaut
-Odr | Déduction des remises entête et ligne de la commande d'achat
-Ooa | Rend la saisie de l'opération obligatoire
-Oaa | Possibilité de saisir un code article dans le champ affectation Forme AP: + code article.
-Ocm | Saisie des taux HT de la facture
-Opf | Proratisation des frais
-Omp | Mise à jour du prix d'achat
-Ofi | Calcul du prix de vente avec marge fixe. A n'utiliser que si l'option est positionnée sur la fiche article
-Opm | Saisie des frais et pertes de la fiche article en valeur. A n'utiliser que si l'option est positionnée sur la fiche article
-Oab | Affiche la quantité et le montant prévu issus de la commande fournisseur Affiche aussi le pourcentage d'écart prévu / réalisé en quantité et en montant Option incompatible avec l'option -Oae
-Ome | Modification de l'entrée en stock et revalorisation des mouvements de stocks en aval. ATTENTION Seuls les produits valorisés au PAMP sont concernés.
-Ola | Utilise la longueur et la largeur de la ligne de commande d'achat pour le calcul du coefficient de conversion de l'article.
-Oiz | Permet d'initialiser la quantité réalisée à 0 par défaut
-O07 | (ça s'écrit : la lettre O, le chiffre zéro, le chiffre sept) Aide à la saisie d'of de type 00115006-1/99
-Oa2 | Annulation dans fab2 lors de l'annulation d'achats extérieurs (annulation dans fab5).
-Odn | Déploiement des colonnes du négoce aux autres commandes
-Omn | Gestion de l'entrée prévisionnelle et des réserves associées liées à l'affectation de la sous-traitance.
-Oqs | Saisie de la quantité en unité de stock C'est à dire que le prix d'achat de la fiche article sera calculé en tenant compte de la formule de conversion. Pu = (HT / Quantite) * (1 * coef_conv(1))

Configuration de l'édition

Créer un paramètre #CF XXX avec la configuration suivante :

Valeur alpha 1

Titre de l'état

Valeur alpha 2

Noms des colonnes

A | Code fournisseur
B | Nom du fournisseur
C | Numéro de mouvement
D | Code intégration
E | Date réception
F | Numéro de commande fournisseur
G | Numéro de ligne de commande
H | Date de la facture
I | Date d'échéance
J | Numéro de la facture
K | Numéro de ligne de la facture
L | Code opération
M | Code produit
N | Libellé de l'opération ou du produit
O | Affectation
P | Quantité (total si -Otq)
Q | Montant HT
R | Port
S | Note. La note s'éditera sur une 2ème ligne dans la zone libellé si cette colonne est paramétrée, sinon elle s'éditera seule dans une colonne.
T | Code article de l'OF affecté
U | Libellé article de l'oF affecté
V | Montant HT unitaire (Col.Q / Col.P) (total si -Otq)
W | Libellé article de l'oF affecté abrégé (20 premiers caractères).
X | Référence de la commande fournisseur

Les codes de colonnes ci-dessous suivis d'une étoile sont des codes utilisés dans la gestion négoce

a* | Commande client
b* | Ligne de commande client
c* | Libellé de la commande client
d* | Référence de la commande client
e* | Zone paramétrée de l'entête de commande client (cde1.ec_c1 paramétrée dans #CF CDE)
f* | Code client
g* | Libellé du client
h | Ligne de commande fournisseur soldée ? N non soldée - O soldée
i* | Etat de la ligne de commande client M Modifiable, A A facturer, F Facturée
j | Quantité achat prévue
k | Ecart quantité achat (réalisé - prévu)
l | Pourcentage d'écart sur la quantité d'achat
m* | Quantité vendue (quantité commande client)
n | Montant achat prévu
o | Ecart montant achat (réalisé - prévu)
p | Pourcentage d'écart montant achat
q* | Montant de vente prévu (montant de la commande client lc_prixcli)
r* | Montant de vente réalisé (lc_prx)
s* | Ecart montant vente (réalisé - prévu)
t* | Pourcentage d'écart montant vente
u* | Pourcentage de marge prévue (montant vente prévu - montant achat prévu) / montant achat prévu
v* | Pourcentage de marge réalisé (montant vente réalisé - montant achat réalisé) / montant achat réalisé
w* | Marge prévue (montant vente prévue - montant achat prévu)
x* | Marge réalisée (montant vente réalisé - montant achat réalisé)
** | Famille produit de la commande client
?* | Sous-famille de produit de la commande client
!* | Zone paramètre 1 de la ligne de commande client
+* | Représentant de la commande client
-* | Libellé de la ligne de commande client
y | Centre de coût
z | Libellé du centre de coût

Valeur alpha 3

Caractères 1 à 3 | Type du paramètre pour le lancement de la mise à jour des stocks en aval (crinv.4ge -Osi)
Caractères 4 à 6 | Code du paramètre pour le lancement de la mise à jour des stocks en aval (crinv.4ge -Osi)

Informations pour l'intégration du port saisi dans les achats extérieurs

Exemple Soit une saisie de 1000 F dans la zone montant et de 300 F dans la zone port.

Si le produit est paramétré En sous-traitance ou normal : mp_param[10] = O ou N

ou

En remontée en francs : mp_param[6] = F ou R

Alors : deux lignes seront créées dans fab3 : 1000 F sur le produit, 300 F sur le produit #PORT (qui doit être créé et paramétré en mp_param[10] = P, mp_param[6] = F ou R)

Si le produit est paramétré En port : mp_param[10]= P

ou

En remontée en francs : mp_param[6] = F ou R

Alors : une ligne sera créée dans fab3 :1300 F sur le produit.

Voir mp_param[6] et mp_param[10]

Edition Choix des ruptures et des tris en interactif

L'utilisateur peut modifier le titre de l'état

L'utilisateur fait sa sélection multicritères

L'utilisateur peut ensuite choisir sa rupture parmi les options proposées dans un menu

Aucune

Code fournisseur

Code opération

Code article
Affectation

Date réception

Date de facture

Date d'échéance

Numéro de la facture

Numéro de commande fournisseur

Centre de coût

S'il a choisi une rupture

On lui demande s'il faut éditer un total par rupture.
La valeur par défaut proposée dans la fenêtre de confirmation est OUI si l'option -Otf est positionnée, et NON sinon.

On lui demande ensuite s'il veut un saut de page par rupture.
La valeur par défaut proposée dans la fenêtre de confirmation est OUI si l'option -Osf est positionnée, et NON sinon.

Remarque

Si l'utilisateur ne veut ni total par rupture, ni saut de page par rupture, sa rupture fait simplement office de tri principal.

On lui propose ensuite un tri secondaire parmi les mêmes zones que précédemment.
L'utilisateur peut ainsi, entre les 10 ruptures et les 10 tris secondaires, procéder à de multiples combinaisons.

Remarque 1

Le tri secondaire ne sera pas proposé si la rupture choisie est Numéro de facture ou Numéro de commande fournisseur.

La rupture secondaire implicite est dans les deux cas le numéro de ligne (de facture ou de commande).

Remarque 2

Il est impossible de choisir un tri secondaire et un tri principal identique. Cela n'a pas de signification.

S'il n'a choisi aucune rupture

On lui propose un tri principal parmi les mêmes zones que précédemment. Cela permet de faire un tri classique sans rupture.


Edition des relances fournisseurs après réception prévue

Edition des relances fournisseurs après réception prévue rel_f

Options

Oxd | Cacher le cadre détail des visualisations Plus d'info dans l'aide du #VI
Oxs | Ne pas passer par l'écran de sélection Plus d'info dans l'aide du #VI

Listes des noms de zone autorisés

Toutes les zones du package Tiers

s0_fou | Code fournisseur | (fichier des stocks)
s0_prod | Code article | (fichier des stocks)
s0_datm | Date du mouvement | (fichier des stocks)
s0_cdefou | Numéro de commande fournisseur | (fichier des stocks)
s0_ligcde | Numéro ligne de commande | (fichier des stocks)
s0_num | Numéro du mouvement stock | (fichier des stocks)
s0_qte | Quantité mouvement | (fichier des stocks)
mp_des | Désignation de l'article | (fichier matière)
lf_prx | Prix commande fournisseur | (fichier cde fournisseur)
lf_qtecde | Quantité commande | (fichier cde fournisseur)
lf_qteliv | Quantité livrée | (fichier cde fournisseur)
qte_solde | Quantité soldée | (valeur calculée)
val_total_b | Valeur totale brute H.T. | (valeur calculée)
val_livre_b | Valeur livrée brute H.T. | (valeur calculée)
val_solde_b | Valeur soldée brute H.T. | (valeur calculée)
val_total_n | Valeur totale nette H.T. | (valeur calculée)
val_livre_n | Valeur livrée nette H.T. | (valeur calculée)
val_solde_n | Valeur soldée nette H.T. | (valeur calculée)
val_total_t | Valeur totale T.T.C | (valeur calculée)
val_livre_t | Valeur livrée T.T.C | (valeur calculée)
val_solde_t | Valeur soldée T.T.C | (valeur calculée)
t_rem_total | Total remise / Quantité totale | (valeur calculée)
t_rem_livre | Total remise / Quantité livrée | (valeur calculée)
t_rem_solde | Total remise / Quantité soldée | (valeur calculée)
tva_total | TVA de la valeur totale ht | (valeur calculée)
tva_livre | TVA de la valeur livrée ht | (valeur calculée)
tva_solde | TVA de la valeur soldée ht | (valeur calculée)
nbr_jrs_ret | Quantité soldée | (valeur calculée)


Transfert des factures fournisseurs en comptabilité

Transfert des factures fournisseurs en comptabilité tr_fac_fou

Ce programme utilise #CF TFF ou #CF XXX (XXX étant paramétré dans la note CONFIG_TRANSFERT).

Voir la fiche société pour déterminer le type de comptabilité.

Les comptabilités autorisées sont les suivantes :

1 | Comptabilité SAGE 1000 ou autres (générique, ordre des colonnes paramétrable)
G | SAGE 500
J | SAGE 100
V | Valc (VoluCompta)
Y | COBYS

Options triées

ATTENTION : pour la compta SAGE (type J), il faut obligatoirement mettre les options Otl et Ocf.

Sinon, l'interface ne transfère pas le détail des lignes de factures.

Ocf

Transfert des cumuls par compte par facture / avoir

Cumule les lignes identiques pour une même facture

Och

Pas de recalcul du HT ligne

Le HT pris en compte est celui de la table des lignes de factures calculé lors du contrôle de la facture.

Ocl

Contrôle que le code comptable fournisseur est bien codifié sur 8 caractères

Ocs

Changement de sens du HT sur le cumul par compte et non plus au ligne à ligne des factures

Exemple

Ligne 1 : Compte 60120000, montant : 100

Ligne 2 : Compte 60120000, montant –0.01

Sans l'option : 2 lignes dans le fichier de transfert :

Compte 60120000 avec 100 en Débit

Compte 60120000 avec 0.01 en Crédit

Avec l'option : une seule ligne dans le fichier de transfert :

Compte 60120000 avec 99.99 en Débit

Ode

Précise si c'est une TVA sur les débits ou les encaissements dans le libellé de l'écriture en plus du nom du fournisseur

Odf

Horodatage du fichier de transfert à la date et heure du transfert

Odh

Lorsqu'on initialise le fichier de transfert, celui-ci est sauvegardé avec le même nom et en ajoutant la date et l'heure du transfert. Ceci permet de conserver tous les fichiers de transfert.

Oee

Eclatement de l'escompte en 5 comptes

Oet

Gestion du mode exonération sur le paramètre TVA

Of0

Transfert des factures à 0

Ofc

Accès à la date comptable

Ofm

Débute la recherche du compte d'achat au niveau de la famille

Oif

Pas d'initialisation du fichier transfert - Activée uniquement en mode batch

Ol1

Libellé de la pièce avec nom abrégé du fournisseur et référence de la pièce.

Activée uniquement dans la comptabilité SAGE LIGNE 100.

Ola

Prise en compte des dimensions de la ligne de commande pour le calcul du coefficient de conversion

Old

Génération de la ligne en devise - Activée uniquement dans la comptabilité VOLUCOMPTA

Oml

Libellé de l'écriture = numéro de facture + nom du client

Ont

Conversion du fichier de transfert en format DOS

Ope

Eclatement du port non taxable en 5 comptes

Opu

Purge automatique du fichier de transfert - Activée uniquement dans la comptabilité VOLUCOMPTA

Ore

Eclatement de la remise en 5 comptes

Os1

Section = Zone paramétrable

Sous-famille de la ligne de commande par défaut

#CF TFF alpha4[15,16] = DQ

Os2

Renseigne la section pour les lignes TVA

Os3

Mois dans la section pour les lignes de TVA uniquement

Os4

Si la section analytique est imposée sur l'ordre d'achat, elle sera prise compte sinon elle sera recherchée selon le paramétrage dans le #CF TFF A4[15,16]

Uniquement pour Sage ligne 1000

Osc

Renseigne la section pour la ligne TTC (Fournisseur)

Ose

Déduit l'escompte du HT - Interdit avec compta SAGE LIGNE 500

Osf

Les frais ne sont pas ajoutés au HT

Osi

Simulation de transfert. Les factures ne sont pas marquées comme transférées.

Osm

Transfert des zones 14 à 18

Activée uniquement dans la comptabilité SAGE LIGNE 100

Osn

Renseigne la section pour les lignes remises, escompte et ports

Osr

Déduit les remises du HT - Interdit avec compta SAGE LIGNE 500

Ost

Saisie du montant total de la TVA de la facture

Celui-ci sera transféré en comptabilité et le compte de TVA sera associé au code TVA de la première ligne de la facture.

Ce montant est accessible par touche F17 et à la validation des lignes de factures avant la validation globale de la facture.

Pour info, le taux de TVA est initialisé à 99.99 dans la table facfou2 des pieds de facture.

Otb

Transfert des bons de réception non rapprochés en comptabilité

En début de mois, un fichier est généré sur le mois précédent de tous les bons de réception non rapprochés. Cela permet à la comptabilité de faire un prévisionnel des factures d'achat à venir.

Uniquement pour Sage ligne 1000

Voir la note SUP_REQ_B_REC_RET et le #CF TFB

Otf

Transférer dans un seul fichier les factures fournisseurs et les factures d'approche rattaché à la facture fournisseur. Les factures d'approches ont comme numéro de pièce celle de la facture fournisseur et comme numéro de facture le numéro de facture d'approche.

Fonctionne uniquement avec Sage 100 type 2.

Voir #CF TFF note SAGE_100_PARAM_GEN

Otl

Une ligne dans le fichier de transfert par ligne de facture

(Recherche du compte d'achat à chaque ligne de facture / avoir)

Cette option est automatiquement positionnée si compta SAGE LIGNE 500

Oua

Calcul du montant HT de la ligne avec la quantité réelle en unité d'achat

Valeur alpha 2

Caractères 1 à 2 | Longueur du libellé société édité en début de chaque ligne du fichier de transfert Activée uniquement dans la comptabilité SAGE LIGNE 100
Caractère 3 | Type de comptabilité du transfert - Facultatif Si renseigné, il remplacera le type de comptabilité de la fiche société. 1 SAGE LIGNE 1000 5 ANAEL E SETEC G SAGE LIGNE 500 J SAGE LIGNE 100 N COMPTAGE V VOLUCOMPTA Y COBYS

Notes

CONFIG_TRANSFERT | 21,23 Code du paramètre de configuration du transfert. Par défaut : TFF
CS | 3,60 Complément de select sur la table des entêtes de factures fournisseur (facfou0)
SUP_REQ_B_REC_RET | 21,60 Complément de sélection sur les tables b_rec_ret_e et b_rec_ret_d. Fonctionne uniquement avec l'option Otb. Voir aussi #CF TFB Pour Sage ligne 1000

Paramètres nécessaires

#CF TFF | toutes | Transfert des factures fournisseurs dans la comptabilité
DEV | alpha2[1,3] | Code devise pour le transfert en comptabilité
MAT | alpha2[12,15] | Section analytique pour transfert comptabilité Sage ligne 500
MRG | alpha1[1,3] | Code règlement correspondant en comptabilité pour le transfert des tiers en comptabilité
SIT | alpha3[21,23] | SAGE500 : Code site pour le transfert en comptabilité
 | alpha3[24] | SAGE500 : Code société pour le transfert en comptabilité
 | alpha3[25,30] | SAGE500 : Code journal d'achats pour le transfert en comptabilité
TOP | valeurs numériques 1 & 2 | Année et mois en cours
TVA | alpha1[18,25] | Code comptable pour le transfert en compta de la TVA des factures fournisseurs
 | alpha1[34] | TVA sur les débits ou les encaissements
 | alpha2[37] | Mode d'exonération de la ligne de facture ou d'avoir et de la ligne de frais d'expédition (N, O, S, I, E) Utilisé dans le transfert des factures / avoirs (tr_fcnn_vl et tr_fac_fou)
 | alpha2[38,40] | COBYS : Code TVA utilisé pour le transfert des factures d'achat en comptabilité
 | TVA_ACHAT_ECHEANCE | Si le fournisseur a un compte TVA à échéance, recherche le compte TVA sur les notes de code TVA. Si trouvé, ajout du mois d'échéance sur les 2 derniers caractères du compte.
 | COMPTE_TVA_ACH_ | Recherche du code TVA ou du compte TVA sur les notes du paramètre code TVA


Transfert des factures fournisseurs en comptabilité

Transfert des factures fournisseurs en comptabilité tr_facf_vl

Valeurs numériques

1 | Valeur à ajouter au numéro de compte pour obtenir le compte export
2 | Valeur à ajouter au numéro de compte pour obtenir le compte suspension de TVA

Options

-Ofm | Transfert par famille d'article sans examen du fichier produits pour la recherche du compte de vente d'achat
-Otl | Transfert par ligne de facture (recherche du compte de vente à chaque ligne de facture) Sinon, transfert global de la facture dans le compte de vente par défaut
-Ocf | Transfert des cumuls par compte par facture Sinon, une ligne d'écriture par ligne de facture
-Os2 | Mise à jour de la section dans les lignes TVA
-Osc | Mise à jour de la section dans les lignes TTC fournisseurs
-Osp | Mise à jour de la section dans les lignes port
-Omf | Utilisation du module fournisseur Le fichier de transfert n'est pas utilisé. Les tables du module fournisseur sont directement mises à jour.

Le transfert utilise #CF TFF

Le transfert utilise le paramètre TVA.

Si transfert ligne par ligne, la recherche du compte d'achat se fait dans l'ordre suivant :

Compte d'achat dans la fiche article

Compte d'achat de la famille d'article

Compte d'achat du code TVA associe à la ligne de commande ou au code produit (si pas de commande d'achat)

Compte d'achat par défaut

Remarques Dans le fichier société, il faut paramétrer le type de compta (M ou V), le numéro de journal des achats et le numéro de dossier comptable (soc)


Réception des commandes fournisseurs

Réception des commandes fournisseurs recep_cde_cab

L'objectif est de remplacer l'actuelle saisie des bons de réception.

  • Le cariste réceptionne des palettes d'achat.

  • La réception crée un mouvement d'entrée normale de la palette d'achat.

  • La ligne de commande est mise à jour, ainsi que le mouvement d'entrée en commande de celle-ci.

  • La fin provisoire ou définitive d'un bon de réception déclenche l'édition d'un bon de réception.

Options triées

Oar | Annulation du mouvement de réserve si la commande est affectée
Oas | Interdiction de réceptionner les articles non suivis en stock
Oie | Active la saisie d'informations sur les étiquettes
Olf | Les mouvements de stock sont affectés avec la ligne de commande client d'affectation
Omt | Alimentation d'un fichier trace Par défaut, pas d'alimentation d'un fichier trace
On3 | La quantité par palette est stockée dans le lieu 3 du mouvement de stock Cette option est automatiquement activée si l'option Os2 est activée.
Ony | Numérotation annuelle des bons de réception
Os2 | Scénario 2. Active automatiquement l'option On3 Ce nouveau scénario permet de réceptionner les produits de négoce en flashant les commandes d'achat et les quantités par palette. Les CAB sont édités sur le bon de livraison du fournisseur.
Osl | Pas de saisie du lieu de réception. Il sera initialisé par défaut. Voir A3[4,12]
Osr | Pas de mise à jour du stock résultant Par défaut, mise à jour du stock résultant
Ouc | Contrôle unicité commande fournisseur Pour interdire des numéros de commande fournisseur différents dans un même bon de réception.
Our | Annulation du mouvement de réserve si la commande est affectée uniquement si la réserve existe

Valeur numérique 1

Numéro de compteur des bons de réception. Type de compteur H. A blanc si pas de compteur

Valeur alpha 2

Caractères 1 à 60

Nom du fichier trace. Obligatoire. Exemple : /u/tmp/recep_cde_cab.TRA

Valeur alpha 3

Caractères 1 à 3 | Type de mouvement de stock d'entrée normale de palette d'achat.. Obligatoire. Exemple : EPA
Caractères 4 à 6 | Lieu de rangement 1 de réception. Obligatoire. Il doit être géré à la palette
Caractères 7 à 12 | Lieu de rangement 2 de réception
Caractères 13 à 18 | Lieu de rangement 3 de réception
Caractère 19 | Contrôle de la saisie de la référence du BL fournisseur N Pas de contrôle W Message en warning B Message Bloquant C Message de confirmation
Caractère 20 | Confirmation de la quantité saisie ou flashée (O/N, O par défaut)
Caractère 21 | Contrôle de doublon de la référence BL du fournisseur N Pas de contrôle W Message d'avertissement C Demande de confirmation B Contrôle bloquant

Notes triées

ETIQACHAT_IMP

21, 24 Code imprimante pour les étiquettes

POURCEN_QTE

Pourcentages à appliquer à la quantité commandée

21,29 Pourcentage mini

Ce pourcentage est diminuée par rapport à la quantité commandée et sert au solde automatique.

Si la quantité réceptionnée est inférieure à la quantité commandée – le pourcentage mini, alors la ligne de commande est soldée.

31,39 Pourcentage Maxi.

Ce pourcentage est ajouté à la quantité commandée et sert au contrôle et à l'affichage du message de la quantité réceptionnée par rapport à la quantité commandée.

Si la quantité réceptionnée est supérieure à la quantité commandée + le pourcentage maxi, alors un message d'erreur de quantité s'affiche.

RUN_EDIT_BR

21, 26 Type et code paramètre de l'édition des bons de réception. Facultatif. Exemple : #EDBRC

RUN_EDIT_OEX

21, 26 Type et code du paramètre de lancement de l'édition de la fiche de fabrication

SUP_REQ_B_REC_RET_E

21, 60 Supplément de requête sur la table des entêtes de réception des commandes fournisseur (b_rec_ret_e)

Obligatoire. Exemple : and bre_annu = "N"

SUP_REQ_CDF1

21, 60 Supplément de requête sur la table des entêtes de commande fournisseur (cdf1)

Obligatoire. Exemple : and ef_annu = "N"

Paramètres associés

USE A1[1,8] | Le login donne le code user (qui est dans le code du paramètre USE).
PRP A1[1,3] | Le code user donne le code préparateur.
TYF A2[13] | Permet d'effectuer ou non une sortie normale (O/N, N par défaut)
TYF A2[15,17] | Type de mouvement de sortie de stock

Scénario 2

Saisie du numéro de bon de réception

Entrée = création d'un nouveau bon

FIN : Fin de saisie

Saisie de la référence du BL du fournisseur

Contrôle paramétrable de la saisie : Non, Bloquant, Warning, avec Confirmation

Flashage du CAB : Commande + ligne de commande fournisseur

FPB : Fin Provisoire du bon

FDB : Fin Provisoire du bon

Flashage de la quantité sur la palette

Return ou flashage 9999999 : Fin de la saisie des quantités et retour

Mise à jour des stocks, du bon de réception et de la commande fournisseur

Si DFP ou FDB :

Possibilité d'éditer le Bon de réception

Possibilité d'éditer la fiche de fabrication de l'OF affecté aux lignes de commande réceptionnées

Retour


Transfert des achats vers JDE

Transfert des achats vers JDE tr_jd_achats

Principe

Exportation des réceptions des commandes d'achat de VoluPack vers la comptabilité JDE.

Le principe est de se baser sur la traçabilité des réceptions.

  • La création d'une ligne de réception transférera une ligne dans JDE.

  • La modification d'une ligne de réception transférera deux lignes dans JDE.(1 ligne avec les valeurs en négatif et une ligne avec les valeurs en positif).

  • L'annulation d'une ligne de réception transférera une ligne dans JDE. (1 ligne avec les valeurs en négatif).

L'unicité d'une commande JDE est un compteur de type W (table cpt_a).

Ce compteur est unique pour chaque transfert d'une ligne de réception.

Options

Ola | Utilisation des zones longueurs et largeurs dans le calcul de la conversion de la quantité
Ore | Prise en compte de la remise entête dans le calcul du montant.
Orl | Prise en compte de la remise ligne dans le calcul du montant.
Osi | Mode Simulation. La facture n'est pas marquée comme transférée.

Notes

_SUP_REQUETE | 21, 60 Complément de requête sur la table tracabilite_e
_INTERFACE_ACHAT_1 | 21, 60 Nom du fichier de transfert de l'entête des commandes
_INTERFACE_ACHAT_2 | 21, 60 Nom du fichier de transfert des lignes de commandes
_INTERFACE_ACHAT_3 | 21, 60 Nom du fichier de transfert de l'entête des réceptions
_INTERFACE_ACHAT_4 | 21, 60 Nom du fichier de transfert des lignes de réception
_CODE_SOCIETE_JDE | 21, 25 Code Société JDE. Il sera utilisé si la commande n'a pas de site. Tableau de bord du multisite
_CLE_GL | 21, 24 Code Clé G/L
_CENTRE_COUT_MAGASIN | 21, 32 Centre de coût Magasin
_NOM_UTILISATEUR | 21, 30 Nom de l'utilisateur
_TRANSACTION_CDE | 21, 28 Code de la transaction de la commande
_TRANSACTION_BRC | 21, 28 Code de la transaction de la réception
_TYPE_ORDRE | 21, 22 Type d'ordre
_COMPTE_COMPTA_SITE | 21, 28 Compte comptable du site. Il sera utilisé si la commande n'a pas de site. Tableau de bord du multisite
_ARTICLE_GENERIQUE | 21, 45 Code article générique
_STATUS_NEXT | 21, 23 Code du Status Next pour les lignes de commande 24,26 Code du Status Next pour les lignes BRC
_STATUS_LAST | 21, 23 Code du Status Last pour les lignes de commande 24,26 Code du Status Last pour les lignes BRC
_UNITE_POIDS | 21, 22 Code de l'unité de mesure du poids

Paramètres nécessaires

SIT | alpha1[46,50]
 | Notes commençant par _JDE_PARAM_ACHATS_
EXO | alpha1[3,4]
TVA | Notes commençant par _TAUX_TAXE_JDE_
FAM | alpha3[53,54]
SFM | Notes commençant par _JDE_PARAM_ACHATS_
POR | alpha1[18,23]


Génération des messages EDI de commandes d'achat (ORDERS)

Génération des messages EDI de commandes d'achat (ORDERS) generer_edi_cde

Ce programme génère un fichier EDI pouvant être de plusieurs types différents en fonction du TSC ORD:

- ORDERS (par défaut)

- ORDERS2

- SCAO

- GONDARDENNES

La génération est déclenchée :

  • à l'édition de la commande d'achat

  • à l'édition de l'AR

Il est appelé par :

  • edicf via le paramétrage de la note GENERER_EDI_ORDERS

  • acr via le paramétrage de la note GENERER_EDI_ORDERS

Evolution du 18/11/2011 - Nouveau format fournisseur de plaques GONDARDENNES

Les caractéristiques des différentes versions de fichiers EDI générés sont indiquées dans le tableau suivant.

Fichier | Version | Particularités
ETU_EDI_format fichiers EDI ORDERS | ORDERS V1 |
 | ORDERS V5 | Idem version 1 avec nouvelles zones : Zone paramétrée 3 (CDELIG 73) Code lieu de facturation (CDELIG 74) Lieu de facturation (CDELIG 75)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-NCDE | Caractères 3 et suivants : Numéro de commande client Exemple : -NCDE[ec_num]
-NCDF | Caractères 3 et suivants : Numéro de commande d'achat Exemple : -NCDF[ef_num]

Options

Oac

Dans le message ORDERS généré, le produit de la commande client associée remplace le libellé étranger de l'article (zone 10 de la ligne, caractères 91 à 130).

Oaf

La zone 9 du CDELIG pour la génération à partir d'une commande fournisseur est égale au code article de la ligne de commande

Code article fournisseur (VP) zone[76,90]

Odr

En ré-édition de la commande d'achat, demande de confirmation pour la retransmission du fichier ED

On se base sur une note sur l'entête de commande d'achat, de type EDI, qui contient la valeur "COMMANDE TELETRANSMISE"

Ofc

Uniquement pour la génération de l'ORDER à partir de la commande client

Le fournisseur est le client et non pas le sous-traitant.

Cela va permettre d'intégrer cet ORDERS dans une autre société VoluPack avec le même code client.

Off

Générer un fichier EDI par commande fournisseur

La présence de cette option passe outre le système d'historisation des fichiers EDI.

Ofl

Prendre en compte le format saisi dans la commande (si renseigné) plutôt que celui de la fiche article, celui-ci ayant pu être modifié entre-temps.

Sans cette option, la priorité sera donnée au format de la fiche article.

Cette option est valable à la fois pour les commandes clients et les commandes fournisseurs.

Ohd

Horodatage du nom du fichier

Le nom du fichier se présentera sous la forme suivante :

RacineFichier_codeTiers_date_heureminuteseconde

Ola

Sans cette option, la zone [45,47] du type de ligne CDELIG depuis une commande d'achat est initialisée avec le compteur de nombre de lignes traitées.

Avec cette option, la zone [45,47] du type de ligne CDELIG depuis une commande d'achat est initialisée avec le numéro de ligne de la commande d'achat.

Ole

Libellé étranger sur code produit

Par défaut , on recherche le libellé étranger de la qualité matière du produit commandé.

Cette option permet de faire la recherche du libellé étranger sur le code produit lui-même.

Ons

Le nom en sortie est celui paramétré dans les notes, on ne lui ajoute pas le code fournisseur

Ont

Active la conversion du fichier des messages EDI de commandes d'achat du format Unix au format Windows. Aucun impact si le fichier est déjà au format Windows.

Op3

Renseignement dans fichier ORDERS en vue de l'alimentation de la zone lc_p3

Voir aussi A3[15]

Opr

Pour les commandes de négoce, transfert du prix de revient (au lieu du prix unitaire) en position [147,156] du fichier ORDERS

Ore

Dans la zone 06, caractère 33 à 47, utiliser la zone ec_ref en lieu et place de ec_num, tiers

Dans la zone 07, caractère 48 à 87, compléter la zone ec_texte avec "REF :" ec_ref

Orm

En cas de modification de commande, pas de re-transfert du fichier

Valeur alpha 2

Caractères 1 à 4

Délai d'attente entre chaque boucle (en minutes)

Valeur par défaut : 1 minute

Le programme multiplie la valeur par 60 pour obtenir des secondes.

Valeur alpha 3

Caractères 1 à 3

Code TCO sur lequel la recherche du correspondant va être effectuée

Caractère 4

Inversion de la laize et de la coupe lors de la génération du fichier EDI ORDERS (O/N, N par défaut)

pour être en conformité avec la solution transformateur

Caractères 5 à 7

Paramétrage du code TSC, permettant le remplissage de la zone 073, en type CDF (on prend la valeur dans la zone ic_char30)

ATTENTION : l'option Op3 est prioritaire pour le remplissage de cette zone.

Caractères 8 à 10

Code EDI mis à jour lors du transfert (statut envoyé à JDE)

Caractère 11

Infos supplémentaires dans les fichiers de trace (ajout site, numéro et ligne de commande) (O/N) - Tableau de bord du multisite

Caractère 12

Spécifique au format fournisseur de plaques GONDARDENNES

Alimentation de la zone C0QUA1 :

1 en fonction de la famille ou sous-famille de la matière et du paramétrage #CF ATL A2[17] (valeur par défaut)

2 en fonction de la sous-famille de la matière

3 Libellé spécifique de la qualité matière si l'article commandé appartient à une famille carton
sinon, libellé spécifique de l'article commandé

Caractère 13

Spécifique au format fournisseur de plaques GONDARDENNES

Alimentation de la zone C0QUA2 :

1 avec le libellé étranger de la qualité matière (valeur par défaut)

2 avec les 4 premiers caractères de la zone mp_at1 du produit acheté

3 avec le code produit acheté suivi de la machine (spécifique)

Caractère 14

Mode d'alimentation de la zone commentaire

C ou [vide] La zone commentaire est alimentée avec 3 lignes de notes paramétrables (valeur par défaut).

L La zone commentaire est alimentée avec en premier la référence fournisseur de la qualité matière, suivie de 2 lignes de notes.

Caractère 15

Mode de renseignement de la zone 073 (caractères 600 à 619) en présence de l'option Op3

0 ef_ref (par défaut)

1 ic_char3_1 du TSC QUA (position 600 à 602) + lf_affect (position 603 à 619)

Notes triées

FIC_ANOMALIE

21, 60 Nom fichier anomalie

FIC_HIS_ORDERS

Nom du fichier ORDERS historisé

Remarques : .

• un suffixe est automatiquement attribué pour chaque fournisseur)

• l'option Ohd (horodatage) est appliquée également à ce nom de fichier.

• Si ce nom de fichier n'est pas paramétré, on prend par défaut le nom du fichier ORDERS (Note commençant par FIC_ORDERS) auquel on ajoute l'extension .HIS

• Dans tous les cas, l'extension .HIS est ajoutée automatiquement.

FIC_LOCK

21, 60 Nom du fichier lock Plus d'infos

FIC_LOCK_ORDERS

21, 60 Nom du fichier lock ORDERS ou SCAO Plus d'infos

FIC_LOCK_VS

21, 60 Nom fichier lock Volume Plus d'infos

FIC_ORDERS

21, 60 Nom du fichier ORDERS ou SCAO généré par fournisseur (un suffixe est automatiquement attribué pour chaque fournisseur)

FIC_TRACE

21, 60 Nom fichier trace

NOM_DU_SHELL

21, 60 Shell à lancer

PARAM_RECH_TARIF

21, 26 Type et code du paramètre de recherche de tarif (#CF TAR par défaut)

REP_FIC_01_20

21,60 Répertoire pour stocker les copies de sauvegardes .01, .02, …20

_SUP_REQ_CDF2

21,60 Complément de requête sur la table cdf2

TSC_ATELIER_LIVRE

Prise en compte des ateliers saisis sur les lignes

21,23 Code du TSC de la ligne de commande d'achat contenant le code de l'atelier

25,45 Nom de la zone du TSC contenant le code de l'atelier (ic_char3_1, ic_char30 ou ic_char3_2)

Lors de la saisie des commandes d'achats, un TSC permet aux utilisateurs de préciser l'atelier pour lequel la marchandise est destinée.

Afin de transférer cette donnée au fournisseur, on va rechercher le code atelier sur la ligne d'achat et le code de l'adresse associée (code client + code adresse) dans le paramètre associé.

Voir aussi ATE A1[2,10]

TYPE_CDE3_ORDERS

21,23 Type de notes de cde3 à récupérer sur les lignes de commande client

TYPE_CDF3_ORDERS

21, 23 Type de notes à récupérer sur commande fournisseur

TYPE_MAT3_ORDERS

21,23 Type de note à récupérer dans les notes des articles (table mat3)

Par défaut, la zone 024 du message CDELIG des commandes d'achat est initialisé avec la 1ère ligne de note de la ligne de commande d'achat.

Le type de note des lignes de commande d'achat est paramétré dans la note TYPE_CDF3_ORDERS (voir ci-dessus).

Si une note commençant par TYPE_MAT3_ORDERS est paramétrée, le texte est initialisé avec la 1ère ligne de note de l'article de l'affectation de la ligne de commande d'achat.

Le type de note des articles est paramétré dans la note TYPE_MAT3_ORDERS.

Si la ligne de commande d'achat n'a pas d'affectation ou si l'OF n'est pas trouvé, le texte est initialisé avec la 1ère ligne de note de la ligne de commande d'achat.

Paramètres

ACH | Téléphone et fax
CIC C20 | Libellé long : Code produit fini
CIC N01 à N20 | Cote de refoulage de 1 à 20
CIC P41 à P60 | Type de refoulage de 1 à 20
CIC P01 | Libellé long : Refoulage produit fini
CIC PST A1[1,3] = STR | Libellé long : sous-traitance
CP | Notes commençant par CORRESP_EDI : Code correspondance pour génération / intégration fichier EDI de type ORDERS ou autres
EDI | Statut de la commande par rapport à l'EDI
FAM A3[56] | Cette famille permet-elle la gestion de l'EDI ? (O/N, O par défaut)
Table cli | La zone cl_codef du fournisseur doit être renseignée. C'est avec cette zone que l'on renseigne le numéro de client (1ère zone du fichier généré).
TSC STR | TSC STR du produit de la ligne de commande : Zone G (char30) = Code fournisseur
TSC ORD | Zone F (char3_1) = O (Génération d'un fichier pour le fournisseur associé) Zone G (char_30) Type de fichier généré
TYC A4[59] = O | Génération d'un fichier ORDERS pour ce type de commande client
TYF A1[32] | Génération d'un fichier ORDERS ou autres pour ce type de commande fournisseur (O/N)
UNI | Notes commençant par CORRESP_EDI : Code correspondance pour génération / intégration fichier EDI de type ORDERS ou autres


Intégration des messages de la première palette

Intégration des messages de la première palette int_fpdata

Ce programme est opérationnel à partir de la V. 4.1.30.2.

Cette nouvelle interface permet d'intégrer les messages de la première palette du système PCTOPP.

Options

Ocd

Conserver les fichiers de données (ne supprime pas le fichier généré par PCTOPP)

Notes

FICHIER_FP_DATA | 21,60 Nom du fichier source à intégrer Note cumulative
FICHIER_LOCK_VS | 21,60 Nom du fichier de verrouillage posé par VoluPack lors de la lecture Note cumulative
FICHIER_LOCK_PCTOPP | 21,60 Nom du fichier de verrouillage posé par PCTOPP lors de l'écriture Note cumulative
FICHIER_UNICITE_EXE | 21,60 Nom du fichier interdisant plusieurs intégrations Note cumulative
FICHIER_TRACE | 21,60 Nom du fichier de l'historique des opérations Note cumulative
FICHIER_ERREUR | 21,60 Nom du fichier contenant les erreurs de transfert Note cumulative
ATTENTE_LIB_PCTOPP | 21,24 Durée de l'attente, en secondes, entre chaque test de la présence du verrouillage PCTOPP (10 par défaut)
ATTENTE_LIB_VSW | 21,24 Durée de l'attente, en secondes, avant la suppression du verrouillage VoluPack (0 par défaut)

Paramètres nécessaires

TSC .PA

Première palette


Interface Direct Planning

Interface Direct Planning directplanning

Ce programme est utilisable à partir de la V.4.0.170.2

Voir aussi #CF DP2

Valeur alpha 2

A2[1,3]

Code paramètre de la configuration de transfert Direct Planning (Par défaut : DP2)

Si vous mettez DPX, par exemple, alors le paramètre de configuration sera recherché sur #CF DPX.

Notes

_SUP_REQ_DPL_TRF_DEM | 21,60 Complément de requête sur la table dpl_trf_demande
_SUP_REQ_FAB1 | 21,60 Complément de requête sur la table fab1 Exemple Ne mettre que les commandes FB2 dans le planning : _SUP_REQ_FAB1 and exists _SUP_REQ_FAB1 (select * from cde1 _SUP_REQ_FAB1 where ec_soc = f1_soc _SUP_REQ_FAB1 and ec_num = f1_cde _SUP_REQ_FAB1 and ec_tyc = 'FB2')

Notes communes à tous les lanceurs utilisant la fonction f_directplanning_ajout_demande_transfert figurant dans f_directplanning.4GL

Outre le programme directplanning, les programmes suivants utilisent cette fonction :

clot_fbi | Clôture des FBI
dos_fab | Clôture de dossier
dp0 | Saisie des temps par dossier ou ordre de fabrication
edon | Edition du devis onduleur
gdf | Génération de dossiers nomenclature et gammes
gdf_don | Génération des dossiers de fabrication en automatique
gdf_ond | Génération de dossiers ondulé
gdf_ondu2 | Boucle de génération des dossiers de fabrication
int_rtm | Intégration des temps saisis par code barres
l_gdf | Génération de dossiers pour les industries graphiques
qclod | Clôture rapide
sbs | Saisie des temps par code barres. L'option Om1 (Mise a jour des phases terminées) doit être activée.
sjs | Saisie des temps journaliers par salarié

DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_SAE | 21,60 Complément de sélection sur la table action_evt Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activation du transfert Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2


Intégration de fichiers Preactor

Intégration de fichiers Preactor integration_preactor

Options

-B

Lancement en mode batch

Odc

Double calcul du sous-devis lors de la réactualisation (obligatoire si gestion des gâches cumulatives)

Odr

Désactiver le recalcul des devis modifiés

Oef

Gestion des effectifs lors de la réactualisation

Ofr

Activer la gestion des sous-devis de fabrication réels

Voir la note SCE_CAD_NON_VALIDE

Orc

Mise à jour des dates de la revue de contrat à partir des données intégrées

Ord

Recalcul la date répondue au client (lc_delrep) même si l'AR a déjà été édité

Ors

Références seules (une seule ligne par opération, pas de ligne d'entête

Orz

Remise à zéro de la quantité

• Sans l'option : Lors du calcul d'une opération, la quantité est remise à zéro si le temps total est à zéro (par défaut).

• Avec l'option : Lors du calcul d'une opération, la quantité n'est pas remise à zéro si le temps total est à zéro.

Remarque : cette option n'est prise en compte que pour les formules d'opération pour lesquelles les gâches cumulatives sont désactivées (ul_param[24] = O ou pas de gestion des gâches cumulatives).

Osr

Pas de mise à jour du stock résultant lors de l'annulation et/ou de la création de mouvements de stocks

Otd

Trace détaillée

Valeur alpha 2

A2[1,3] | Type de mouvement de stock (TMV) pour les entrées d'historique des outillages
A2[4,6] | Type de mouvement de stock (TMV) pour les sorties d'historique des outillages

Notes triées

ACT_CAD_NON_VALIDE

Actions paramétrables à réaliser sur les cadencements de fabrication non validés

Permet de réaliser un certain nombre d'actions paramétrables lors de l'intégration du fichier retour de production Preactor, pour les cadencements de fabrication non validés.

La gestion des sous-devis de fabrication réels doit être activé (option Ofr).

21,23 Code phase sur laquelle va s'appliquer l'action.

ATTENTION

• Si le code phase n'est pas renseigné, l'action s'applique à toutes les phases.

• Si le code phase est renseigné mais que la phase n'existe pas dans le sous-devis courant, aucune action ne sera réalisée.

24,26 Code action à réaliser

001 Remise à zéro d'une formule

002 Réinitialisation des prix matières

003 Prise en compte des quantités matières pour la partie variable

27,60 Paramétrage de l'action, variable selon le code action (voir le tableau en bas de cette page).

CODE_BLOCAGE_DEVIS

21,23 Code blocage de la génération Preactor (valeur obligatoire, pas de valeur par défaut)

CODE_TMV_CONSO_PREV

21,23 Code TMV des mouvements de stock de consommation prévisionnels créés lors de la génération des OF

(afin de recréer ces mouvements dans le cas d'une modification de date)

CONFIG_DEG_DER_DEVIS

21,23 Code paramètre de configuration générale du devis multi-métiers (exemple DEG)

24,26 Code paramètre de configuration du récapitulatif du devis multi-métiers (exemple DER)

FIC_ANOMALIE

21,60 Chemin complet pour le fichier des anomalies

FIC_PREACTOR_TACHES

21,60 Chemin complet pour le fichier des tâches

FIC_TRACE

21,60 complet pour le fichier de trace

MAJ_MAC_PHASE_

15,17 Code phase

21 Mise à jour de la machine pour cette phase (O/N, O par défaut)

SCE_CAD_NON_VALIDE

21,23 Code scénario de calcul à mettre en place sur le sous-devis de fabrication réel lié au cadencement de fabrication non validé en cours d'intégration.

L'option Ofr est requise.

_SUP_REQ_CAD_FAB_RES

Complément de recherche sur la table des stocks (stk0) des mouvements prévisionnels de réserve à annuler lors du solde d'un cadencement de livraison

_SUP_SQL_CDE8_APP

21,60 Complément de sélection pour la recherche des cadencements de livraison de type APP (Appel) et/ou LIV (Livraison)

_SUP_SQL_CDE8_SAP

21,60 Complément de sélection pour la recherche des cadencements de livraison de type SAP (Sur appel)

N.B. : Utilisé uniquement si la recherche de cadencement de livraison de type APP/LIV n'a retourné aucun résultat.

_SUP_SQL_STK0

21,60 Complément de sélection pour la recherche des mouvements de stocks de consommations prévisionnelles crées par la génération des OF

TACHE_NON_COMMENCEE

21,60 Mot-clé définissant que l'état de l'opération dans le fichier Preactor n'est pas commencée (l'OF sera à régénérer seulement si toutes ces lignes sont à cette valeur)

Par défaut : Non commenc

Remarque : la recherche se fait avec prise en compte de la longueur du mot-clé paramétré (si le mot-clé paramétré a une longueur de 8 caractères, on vérifiera les 8 premiers caractères de l'état de l'opération dans le fichier Preactor).

Cela permet d'éviter de prendre en compte les accents qui peuvent avoir des codes différents côtés VoluPack (ex : Non Commencée) et Preactor (ex : Non Commenc?e)

TACHE_TERMINEE

Mot-clé définissant que l'état de l'opération dans le fichier Preactor est terminée

Par défaut :Termin

Si toutes les lignes du cadencement sont terminées, le flag ccf_transfere de l'entête passe à 3.

Codes actions paramétrables à réaliser sur les cadencements de fabrication non validés

Voir la note ACT_CAD_NON_VALIDE

001 Remise à zéro des totaux d'une formule matière, opération ou sous-traitance

Car.27 = M : Remise à zéro d'une formule matière (obligatoire)

Les zones remises à zéro sont : fm_tot_qte, fm_total, fm_quantite

Car.28,30 Code formule matière pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.31,45 Code matière pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.27 = O : Remise à zéro d'une formule opération (obligatoire)

Les zones remises à zéro sont : fo_tot_qte, fo_tot_tps, fo_total, fo_tpsstd, fo_quantite, fo_cadence

Car.28,30 Code section pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.31,33 Code opération pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.34,36 Code sous-opération pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.37,39 Code formule opération pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.27 = S : Remise à zéro d'une formule sous-traitance (obligatoire)

Les zones remises à zéro sont : fs_total_f, fs_total_v, fs_total, fs_quantite, fs_pr_f, fs_pr_v, fs_pv_f, fs_pv_v

Car.28 30 Code formule sous-traitance pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.31 36 Code fournisseur pour laquelle la remise à zéro doit être effectuée (optionnel)

Car.37 51 Code matière pour laquelle la remise à zéro doit être effectuée (optionnel)

002 Réinitialisation des prix de revient d'une formule matière ou sous-traitance

Car.27 = M : Réinitialisation du prix de revient d'une formule matière (obligatoire)

Si la matière est suivie en stock, le prix de revient est réinitialisé par ordre de priorité avec :

1 Le prix d'achat moyen pondéré de la matière (mp_pamp)

2 Le tarif (si le code de recherche de tarif est renseigné, voir car. 46 à 48)

3 Le prix d'achat (mp_pa) (par défaut)

Si la matière n'est pas suivie en stock, le prix de revient est réinitialisé avec :

1. Le tarif (si le code de recherche de tarif est renseigné, voir car. 46 à 48)

2. Le prix d'achat (mp_pa) (par défaut)

Car.28,30 Code formule matière pour laquelle la réinitialisation du prix doit être effectuée (optionnel)

Car.31,45 Code matière pour laquelle la réinitialisation du prix doit être effectuée (optionnel)

Car.46,48 Code de recherche du tarif utilisé pour réinitialiser le prix de revient. Doit correspondre à un paramètre de type #CF.

Car.27 = S : Réinitialisation du prix de revient fixe/variable d'une formule sous-traitance (obligatoire)

Le prix de revient est réinitialisé par ordre de priorité avec :

1 Le tarif (si le code de recherche de tarif est renseigné, voir car. 53 à 55)

2 Le prix d'achat de la matière (mp_pa) (par défaut)

Car.28,30 Code formule sous-traitance pour laquelle la réinitialisation du prix doit être effectuée (optionnel)

Car.31,36 Code fournisseur pour laquelle la réinitialisation du prix doit être effectuée (optionnel)

Car.37,51 Code matière pour laquelle la réinitialisation du prix doit être effectuée (optionnel)

Car.52 Type de valorisation pour la matière sous-traitée (optionnel, L par défaut)

V Valeur : Réinitialisation du prix de revient variable

A Ajout : Réinitialisation du prix de revient variable

% Pourcentage : Réinitialisation du prix de revient variable

C Coefficient : Réinitialisation du prix de revient variable

L Libre : Réinitialisation du prix de revient variable (par défaut)

F Forfait : Réinitialisation du prix de revient fixe

Car.53,55 Code de recherche du tarif utilisé pour réinitialiser le prix de revient. Doit correspondre à un paramètre de type #CF.

003 Prise en compte des quantités matières pour la partie variable

Récupération de la somme des quantités matières des phases paramétrées (voir ci-dessous) et réinitialisation de la quantité des opérations de la phase sur laquelle l'action doit être réalisée (voir ci-dessus)

Les quantités mises à jour sont les zones fo_quantite et fo_tot_qte. La zone fo_g_v est réinitialisée à zéro.

Car.27,59 Liste des codes phases à prendre en compte pour le cumul des quantités matières. 11 codes phases de 3 caractères


Génération de fichiers Preactor

Génération de fichiers Preactor genere_preactor

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants :

Numéro de commande/Numéro de ligne de commande-Numéro de séquence de commande-Numéro de cadencement de fabrication

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+&&&]

-N[nc_num|-|nc_lig+&&&|/|nc_seq+&&&]

-N[nc_num|-|nc_lig+&&&|/|nc_seq+&&&|/|ccf_lig_cad+&&&]

Options

-B | Lancement en mode batch (pour un appel depuis un autre programme)
Ofr | Activer la gestion des sous-devis de fabrication réels
Ors | Références seules (une ligne par opération, pas de ligne d'entête)

Valeur alpha 2

A2[1]

Lecture des TSC sur le premier produit d'amalgame (et non sur le code affiche) (O/N, N par défaut)

Voir USE A3[58]

On cache les zones si le produit concerné est de type amalgame (mp_param[12]=O).

Dans l'interface de génération du fichier Préactor, on utilisera, sur paramétrage, le premier produit d'amalgame de l'affiche pour lire les TSC (ordinairement lues avec le code affiche).

Notes triées

CONFIG_DEG_DER_DEVIS

21,23 Code paramètre de configuration générale du devis multi-métiers (exemple DEG). Valeur obligatoire, pas de valeur par défaut

24,26 Code paramètre de configuration du récapitulatif du devis multi-métiers (exemple DER). Valeur obligatoire, pas de valeur par défaut

FIC_ANOMALIE

21,60 Chemin complet pour le fichier des anomalies

FIC_COPIE_LIENS

21,60 Nom du fichier des liens (le fichier généré est identique à celui nommé FIC_PREACTOR_LIENS)

FIC_COPIE_REGPT

21,60 Nom du fichier des tâches (le fichier généré est identique à celui nommé FIC_PREACTOR_REGPT)

FIC_COPIE_TACHES

21,60 Nom du fichier des tâches (le fichier généré est identique à celui nommé FIC_PREACTOR_TACHES)

FIC_OSYS_LOCK

21,60 Chemin complet pour le fichier de lock OSYS

FIC_OSYS_TACHES

21,60 Chemin complet pour le fichier de destination des tâches OSYS

FIC_PREACTOR_LIENS

21,60 Chemin complet pour le fichier des liens

FIC_PREACTOR_LOCK

21,60 Chemin complet pour le fichier de lock Preactor

FIC_PREACTOR_REGPT

21,60 Chemin complet pour le fichier de regroupement

FIC_PREACTOR_TACHES

21,60 Chemin complet pour le fichier des tâches

FIC_TRACE

21,60 Chemin complet pour le fichier de trace

FIC_VSW_LOCK

21,60 Chemin complet pour le fichier de lock VoluPack

OUTIL_LCO_FOR_ACT

Recherche du code outil dans la LCO FOR

21,40 Nom de la zone à tester pour activer la recherche de l'outil sur la LCO FOR

41,60 Valeur à tester pour activer la recherche de l'outil sur la LCO FOR

OUTIL_LCO_FOR_DES

Recherche du code outil dans la LCO FOR

21,40 Nom de la zone à tester pour désactiver la recherche de l'outil sur la LCO FOR

41,60 Valeur à tester pour désactiver la recherche de l'outil sur la LCO FOR

ATTENTION : Si aucune règle n'est paramétré, l'outil est recherché sur l'entité sans s'occuper de la LCO FOR SAUF pour les cadencements de type COL pour lesquels l'outil est pris dans la LCO FOR (d'où la possibilité de désactiver la recherche dans la LCO).

PS : Les noms de zones autorisées pour faire les tests actuellement sont :

L2_TYPE_PROD

FI_TYP_ENT

CCF_TYPE_CAD

Exemple

OUTIL_LCO_FOR_ACT L2_TYPE_PROD STR

Permet de spécifier que pour toutes les phases des devis de type STR, le code outil envoyé à Preactor sera pris dans la LCO FOR.

_SUP_REQ_CDE_CAD_FAB

21,60 Complément de sélection sur la table des cadencements de fabrication pour limiter le nombre d'OF à générer

Autres paramètres

TCF | A2[16,18] Code de la première phase opération à prendre en compte A2[19,21] Code de la dernière phase opération à prendre en compte A2[28] Type pris en compte dans l'édition Preactor pour la partie impression (O/N, O par défaut) A2[29] Type pris en compte dans l'édition Preactor pour la partie façonnage (O/N, O par défaut) A2[30,32] Code LCO du nombre prévisionnel de cadencements A2[33] Zone LCO du nombre prévisionnel de cadencements 1 Zone numérique 1 2 Zone numérique 2
PHA | Note TSC_TEMPS_ATTENTE


Génération des cadencements de fabrication

Génération des cadencements de fabrication G_genere_cad_fab

Voir la fiche d'installation sur les cadencements de fabrication.

BUT : Permettre de générer les cadencements de fabrication

Génération des fichiers Preactor

Génération des étiquettes Gap

Génération des ordres de fabrication

Edition des ordres de fabrication

La génération des ordres de fabrication liés à un cadencement de fabrication doit se faire obligatoirement par ce nouveau programme.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants :

Numéro de commande/Numéro de ligne de commande-Numéro de séquence de commande-Numéro de cadencement de fabrication

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+&&&]

-N[nc_num|-|nc_lig+&&&|/|nc_seq+&&&]

-N[nc_num|-|nc_lig+&&&|/|nc_seq+&&&|/|ccf_lig_cad+&&&]

Options

-R | Régénération d'un cadencement de fabrication
Oen | Création d'étiquette neutre (Gap)
Ofr | Activer la gestion des sous-devis de fabrication réels

Valeur alpha 2

1 | Valeur par défaut pour la génération des fichiers Preactor O Génération autorisée et lancée par défaut N Génération autorisée mais non lancée par défaut I Génération interdite
2 | Valeur par défaut pour la génération des étiquettes Gap O Génération autorisée et lancée par défaut N Génération autorisée mais non lancée par défaut I Génération interdite
3 | Valeur par défaut pour la génération des ordres de fabrication O Génération autorisée et lancée par défaut N Génération autorisée mais non lancée par défaut I Génération interdite
4 | Valeur par défaut pour l'édition des ordres de fabrication O Edition autorisée et lancée par défaut N Edition autorisée mais non lancée par défaut I Edition interdite

Valeur alpha 3

1,6

Type et code du paramètre de lancement de la génération des ordres de fabrication pour les lignes de commande (Ex : 07100001-1)

Pas de valeur par défaut, saisie obligatoire.

Important : Dans le cas où l'ordre de fabrication n'est pas encore généré, c'est ce paramétrage de lancement qui sera utilisé. Dans le cas contraire, c'est le paramétrage de lancement renseigné dans les caractères 19 à 24 qui sera utilisé.

7,12

Type et code du paramètre de lancement de l'édition des ordres de fabrication

13,18

Type et code du paramètre de lancement de la génération des ordres de fabrication pour les lignes de cadencements de fabrication (Ex : 07100001-101)

19,24

Type et code du paramètre de lancement de la régénération des ordres de fabrication pour les lignes de commande (Ex : 07100001-1)

Valeur par défaut : Paramètre de lancement de la génération des ordres de fabrication, paramétré en A3[1,6].

Important : Dans le cas où l'ordre de fabrication est déjà généré, c'est ce paramétrage de lancement qui sera utilisé.

Dans le cas contraire, c'est le paramétrage de lancement paramétré en A3[1,6]qui sera utilisé.

Notes

FIC_PREACTOR_TACHES | 21,60 Chemin de destination du fichier des tâches Preactor
FIC_PREACTOR_LIENS | 21,60 Chemin de destination du fichier des liens Preactor
FIC_PREACTOR_REGPT | 21,60 Chemin de destination du fichier de regroupement Preactor
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
_SUP_REQ_CDE_CAD_FAB | 21,60 Complément de sélection sur la table des cadencements de fabrication pour limiter le nombre d'OF à générer

Paramètres nécessaires

#CF DEG A4[38] | Enregistrement automatique des machines possibles dans le devis multi-métiers afin de permettre de les utiliser lors de la génération du fichier des tâches Preactor
TCF | Type de cadencement de fabrication
QAL A1[8] | Type d'appel de livraison
cde | Note PAR_LCT_GEN_CAD_FAB pour indiquer le type et le code du paramètre de lancement de la génération des cadencements de fabrication.


Calcul des actions de service

Calcul des actions de service pr_as_don

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : ordre de fabrication

Exemple : -N[f0_of]

Options

Oat | Génération d'une action de service de type transport dans le devis 97
Oex | Mode expert (pour les contrôles possibilité)
Ofv | Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.
Oin | Inversion laize/coupe
Opl | Mode plastique

Valeur alpha 2

A2[1,3] | Environnement de valorisation
A2[7,8] | Code calcul du devis
A2[9,15] | Paramétrage selon le code calcul du devis
A2[24,31] | Permet de récupérer la demande client par défaut pour les services cartonniers
A2[33] | Permet de récupérer l'offre de vente par défaut pour les services cartonniers
A2[34,36] | Site de production - Tableau de bord du multisite

Valeur alpha 3

A3[34,36]

Code environnement de prix de cession pour le prix de revient réel

Notes triées

CONFIG_PRIX_CESSION | 21,26 Type et code du paramètre de la configuration de tarif à appliquer lors de l'insertion du prix de cession en environnement PRR
_SUP_REQ_COMPOSANTS | 21,60 Complément de sélection sur la table fab0 permettant d'exclure les composants à ne pas prendre en compte dans le calcul du prix de cession en environnement PRR
_SUP_REQ_EXCLUE_PHA | 21,60 Complément de sélection sur la table fab1 permettant d'exclure les phases à ne pas prendre en compte dans le calcul du prix de cession en environnement PRR

Paramètres associés

CAS | Caractéristiques des actions de service
#CF TA1 | A2[2,4] Code tarif par défaut A2[12,14] Code catégorie par défaut A3[28,30] Code unité final du prix de cession
REP | A4[18,22] Taux de commission pris en compte dans le devis


Intégration TGV DATA

Intégration TGV DATA integration_tgvdata

Interface permettant d'intégrer le fichier TGV DATA fourni par PC TOPP dans la table charge_ilot.

OPTION PAYANTE PRO 8

Valeur alpha 2

A2[1,3]

Code site - Tableau de bord du multisite

Notes

FICHIER_LOCK_PCTOPP | 21, 60 Emplacement du fichier verrou PC TOPP
FICHIER_LOCK_VSW | 21, 60 Emplacement du fichier verrou indiquant que le programme est déjà lancé
FICHIER_TRACE | 21, 60 Emplacement du fichier de trace
FICHIER_ERREUR | 21, 60 Emplacement du fichier d'erreurs
FICHIER_PLANNING | 21, 60 Emplacement du fichier PC TOPP à intégrer
MACHINE_ | Correspondance machines 9, 14 Code machine TGVDATA 21, 26 Code machine VoluPack

Paramètres nécessaires

ILO A1[2,4]

Code du site auquel appartient l'îlot - Tableau de bord du multisite


Transfert du stock d'une matière vers PC-Topp

Transfert du stock d'une matière vers PC-Topp tr_pctopp_psdata

Cliquez ici pour accéder au site internet de PC-TOPP avec la description des fichiers.

Options

dr | Si la laize est supérieure à 4 caractères, on prend les 4 caractères de droite.
ga | Si la laize est supérieure à 4 caractères, on prend les 4 caractères de gauche.
pa | Remplacer le code produit transféré par son code AFNOR correspondant
r3 | La laize se trouve sur le lieu de rangement 3

Notes

COMPLEMENT MAT | 21,60 Complément de requête sur la table des articles
COMPLEMENT RGT | 21,60 Complément de requête sur la table des lieux de rangement
FIC_ANOMALIE | 21,60 Nom du fichier anomalies
FIC_LOCK | 21,60 Nom du fichier de verrouillage
FIC_PCTOPP | 21,60 Nom du fichier PCTOPP
FIC_TRACE | 21,60 Nom du fichier trace


Génération de dossiers imprimerie feuille / rotatives

Génération de dossiers imprimerie feuille / rotatives l_gdf

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de dossier-numéro de ligne de dossier

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+<<&]

Options ne commençant pas par -O, non triées

-A | Récupération du devis non spécifique Numéro du devis ou Numéro du sous-devis Exemple : TEXTILE-1
-B | Lancement de la génération en mode BATCH
-Kr | Génération automatique de mouvements de stocks : Génère une réservation dans le stock
-Kp | Génération automatique de mouvements de stocks : Génère un mouvement de sortie

Options commençant par -O, triées

-Oa

Arrondi de la quantité en fonction de l'unité.

(Actuellement seulement un arrondi à la quantité supérieure est possible. Voir alpha1[6] paramètre UNI)

-OA

Non génération des dossiers pour les articles asynchrones

-Ob

Génération des dossiers de production RELIURE

-OB

Blocage automatique si l'état du besoin matière est différent de A. <<< A VERIFIER >>>

-Oc

Permet de convertir les matières unités devis en unités d'utilisation (n'est valide qu'avec l'option reliure).

-OC

Permet de générer l'ordre de fabrication global (XXXXXXXX-1) lors de la génération des cadencements de fabrication.

Cette option ne doit être mise en place que pour la génération manuelle des OF.

Dans le cas d'une génération à partir du programme de génération des cadencements de fabrication, cette option NE DOIT PAS être mise en place.

-Od

Génération d'après devis spécifique

-OD

-Oe

Génération des mouvements de sortie réserve sur la nomenclature (n'est valide qu'avec l'option reliure)

Nécessite la note TYPE_SR_NOMENCLATURE

-OE

Désactiver les remontées de matières automatiques

-Of

Permet de ne pas proratiser la quantité nécessaire chez les clients dont les unités devisés et vendues sont différentes.

-OF

Mise en place de la gestion des frais

-Og

En régénération, conserve tout le réalisé.

Les temps et quantités en remontées automatiques (réalisé = prévu) sont supprimés.

Toute phase ayant des temps réalisés est conservée.

Tout produit ayant des quantités réalisées est conservé.

Voir complément de sélection de mouvements à supprimer (note SQL_SUPPRESS_MVT).

-OG

Génération de la matière principale à partir des lignes de besoins matières

-Oh

Génération hybride (mélange devis PRO / devis de calcul de prix)

-OH

Prise en compte de la marge de l'écran du détail des matières du devis

Par défaut, la marge saisie dans l'écran du détail des matières du devis est déduite lors du calcul du montant prévu des matières.

Cette option permet de prendre en compte la marge lors du calcul.

-Oi

Conserve les temps déjà saisis (fab2) quelle que soit l'opération

-OI

Génération d'un fichier PTCTOPP pour les transformateurs

Voir les notes FIC_PCTOPP, FIC_PCTOPP_LOCK et PCTOPP_COMMENTAIRE.

-Oj

Génération du textile

-Ok

Demande confirmation des générations de mvt de stk (pour chaque dossier généré)

-Ol

(petit l) Pas de génération si quantité lancée = 0

-OL

Enregistrement de la laize matière dans le lieu de rangement 2 des mouvements de stock générés

-Om

Mise à jour des mouvements de réservation avec les mouvements de sortie normale. Utiliser avec -Or

-OM

Activation du contrôle d'existence de l'article pour l'alimentation de fab0

-On

Calcul du coefficient de nomenclature

Si l'option est positionnée, le coefficient de nomenclature est calculé selon la formule suivante :

p_fm.fm_quantite / p_fi.fi_qteent

Si l'option n'est pas positionnée, le coefficient de nomenclature est initialisé à 1

-ON

Blocage de la génération en fonction de l'état du besoin négoce

-Oo

Spécial rotativiste : On génère des Kg pour le papier

-OO

Option pour le transfert vers Ortems (voir les notes commençant par FIC_ORTEMS)

-Op

Génération d'après devis PRO

-OP

Activation du regroupement des opérations pour l'alimentation de fab1

Permet de regrouper des opérations (même code opération, même machine) pour l'alimentation des gammes du dossier de fabrication.

-Oq

Génère automatiquement l'opération QTE ENT STO

-OQ

Lors de la régénération des cadencements de fabrication, ne pas proratiser la quantité lancée de fab0 (et des mouvements de stock associés) par la quantité lancée du cadencement. Prendre directement la quantité de la table fle_mat.

-Or

Régénération. Impose l'option-Os

-OR

Active le regroupement par dossier

Voir la note ENTx_COUL

-Os

Séparation gâche fixe et gâche variable dans fab0

-OS

Solde phase en remontée automatique des temps (o0_param[1] = E)

-Ot

Spécial rotativiste : On génère des Kg pour le papier, mais uniquement pour les devis roto

(pour les devis feuilles comme avant).

-OT

Génération du transport à partir de l'entité 99 => Nécessaire pour le devis_tc

-Ou

Permettre le choix de l'environnement de recherche de taux horaire lors de la génération de dossier

Utilisé conjointement avec A2[23,25]

-Ov

Valorisation des matières aux dimensions de la plaque du devis

-OV

Application du coef_conv sur les quantités rapatriées de cde5 (uniquement avec -OG).

-Ow

Pas de mise à jour du stock résultant lors de la mise à jour des stocks

-Ox

On ne multiplie pas par 100 mais par 10 pour la numérotation des phases.

-OX

Gestion des options

-Oy

On ne confirme la régénération de commande qu'au niveau de l'entête de commande.

-OY

Prise en compte du poids de papier roto à partir de fle_mat (valeur 1) et non pas fle_imp

-Oz

Date du mouvement généré = date de fabrication prévue indiquée sur la ligne de commande au lieu de la date du jour.

Incompatible avec -OZ

-OZ

Date des mouvement de stocks = date de début de fabrication prévisionnelle

Incompatible avec -Oz

-O0

[lire :option zéro]

Génère les lignes valorisées à zéro (matière, opération, sous-traitance)

-O1

Dans le cas d'une FBI, on ne génère fab0 que pour le produit de la ligne de commande

-O2

Idem que l'option -O1 si l' article de la ligne est simple.

Fonctionnement normal si l'article de la ligne est un ensemble.

-O3

Active la demande de confirmation pour la proratisation lors de la génération des dossiers de fabrication.

-O4

NON UTILISE

-O5

En régénération avec conservation du réalisé, conserver l'OF s'il a de la sous-traitance affectée

-O6

NON UTILISE

-O7

NON UTILISE

-O8

Génère le numéro de phase opération

-O9

Génère d'après le sous-devis 99 (sous-devis de fabrication)

Valeur alpha 2

Caractères 1, 3

Mouvement de sortie

Caractères 4, 6

Mouvement de réserve

Caractère 7

Calcul du transport prévu

N Non (par défaut)

E En total sur chaque entité

D En détail sur chaque entité

T En total à partir de l'écran récapitulatif du devis (table fle_2) et pour le prix de vente

Attention : C'est la zone l2_p_pv (prix de vente du port) qui est prise en compte)

ATTENTION : Ce paramètre est lu par cpr.

Caractères 8, 22

Code produit du transport (exemple #PORT) (si caractère 7 différent de N)

Attention : il doit être paramétré en article Port (mp_param[10] = P)

Ce produit transport est aussi utilisé dans l'intégration du port de la sous-traitance dans le calcul du prix de revient (cpr)

Caractères 23, 25

Environnement de recherche de taux horaire. Obligatoire avec l'option Ou

Caractères 26, 28

Code action automatique à créer après la génération d'un dossier de fabrication (Type de paramètre ASO)

Permet de créer en automatique des actions de suivi d'outillage après la génération des dossiers de fabrication pour les solutions imprimeurs/transformateurs.

IMPORTANT

Choix au menu de générer avec ou sans devis spécifique.

Si le choix est sans le devis spécifique, le N° de devis sera PRO et le N° de sous-devis sera égal à 1.

Notes triées

CONFIG_DEG_DER_DEVIS

21.23 Code paramètre de configuration générale du devis multi-métiers (par défaut : DEG)

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activer le transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

EFF_CCOUT_A_EXCLURE

Centre de coût à exclure du calcul de l'effectif nécessaire

Une ligne par centre de coût à exclure.

Ce paramétrage permet d'exclure un centre de coût pour toutes les opérations du devis calculé.

La même dote existe au niveau des formules : les 2 notes sont complémentaires.

ENTx_COUL

où x = numéro de l'entité

21,50 STD_RANDOM : affecte une couleur aléatoire2

Permet de regrouper les tâches d'un même dossier (numéro d'OF) (concaténation des phases communes de plusieurs entités).

Pour la visualisation dans le planning, une couleur est affectée automatiquement pour l'ensemble du dossier

Il faut activer l'option -OR

FIC_LOCK_EXECUTION

Nom du fichier lock empêchant les exécutions simultanées

FIC_ORTEMS_AMALG

21, 60 Nom du fichier Ortems concernant les produits sur un amalgame

FIC_ORTEMS_CDE

21, 60 Nom du fichier Ortems concernant les amalgames sur une commande

FIC_ORTEMS_LOCK

21, 60 Nom du fichier de lock utilisé pour le transfert vers Ortems

FIC_ORTEMS_NOMENCL

21, 60 Nom du fichier Ortems concernant la nomenclature

FIC_ORTEMS_TACHE

21, 60 Nom du fichier Ortems concernant les tâches

FIC_PCTOPP

21,60 Nom du fichier PCTOPP en sortie

Voir l'option -OI

FIC_PCTOPP_LOCK

21,60 Nom du fichier de verrou PCTOPP

Voir l'option -OI

FORMULE_CONV_UNITE

Paramétrage de la formule de conversion

21,23 Unité de départ pour la conversion

24,26 Unité de destination

27,29 Code phase de la formule utilisée pour la conversion

30,32 Code formule

33,33 Type de formule

M Matière

O Opération

S Sous-traitance

MAJ_TSC_DOSS_ACTUEL

21,23 Code TSC utilisé pour sauvegarder le numéro de dossier de fab en cours

La zone ic_char30 du TSC indiqué doit contenir le dernier numéro de dossier (nouveau).

25 Article à mettre à jour

L Article de la ligne de commande

Autre : Article de l'entête de l'OF

Dans le cas où le produit de la tête de l'OF n'est pas celui de la ligne de commande client, ce paramètre permet de spécifier que le produit où sera mis à jour ce TSC est celui de la ligne de commande client et non celui de la première ligne de l'OF.

MAJ_TSC_DOSS_ANCIEN

21,23 Code TSC utilisé pour sauvegarder l'ancien numéro de dossier de fab

La zone ic_char30 du TSC indiqué doit contenir l'avant dernier numéro de dossier (ancien).

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table cde3. Obligatoire. Exemple : TEX

24,32 Phase d'impression du TEXTILE. Obligatoire. Exemple : IMFIMFROU

33,33 Code de la saisie de la machine d'impression du TEXTILE

N Pas de saisie

O Saisie obligatoire

34,39 Type et code du paramètre de la configuration de la recherche des prix

unitaires machines du TEXTILE. Obligatoire. Exemple : #CFMAC

40,42 Code tarif des prix unitaires machines du TEXTILE. Obligatoire. Exemple : #MA

43,45 Code environnement de valorisation du TEXTILE. Obligatoire. Exemple : MAC

46,48 Type de mouvement des sorties réserves du TEXTILE. Obligatoire. Exemple : SR

49,51 TSC du nombre de couleurs du TEXTILE. Obligatoire. Exemple NCO

52,54 Type de mouvement des entrées prévisionnelles du TEXTILE. Obligatoire. EX : EP

PARAMETRE_CONFIG_DPL

21,26 Type et code du paramètre de configuration de Direct Planning

Exemple (valeur par défaut) #CF DPL

PCTOPP_COMMENTAIRE

Génération d'un fichier PCTOPP

Voir l'option -OI

21,24 Code destination PCTOPP

CORS Planning onduleuse

CORT Terminal onduleuse

RCL Impression onduleuse

CNVS Planning de transformation (toutes les machines de transformation de la gamme)

CNVT Terminal de transformation (toutes les machines de la gamme)

RCVM Impression transformation (toutes les machines de la gamme)

SALE Ventes

SHIP Expédition

26,60 Paramétrage de lecture des informations pour alimenter le commentaire

TSC_XXX_YYY_G où

XXX Origine du TSC

CAS01 Cascade mode 1

1 Séquence ligne de commande de rattachement

2 Ligne de commande de rattachement

3 Produit fini

4 Ensemble

5 Client + adresse de livraison de la ligne de commande de rattachement

6 Client de la commande de rattachement

CAS02 Cascade mode 2

1 Triplet

2 Produit fini

3 Ensemble

YYY Code TSC

G Zone alphanumérique de 30 caractères

NTS Voir syntaxe d'appel des NTS dans les visualisations.

Exemple de paramétrage des commentaires

PCTOPP_COMMENTAIRE CORS NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE CORT NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE RCL NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE CNVS NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE CNVT NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE RCVM NTS_CDEE/FAC/ALL*60*

PCTOPP_COMMENTAIRE SALE NTS_CDEE/EXP/ALL*60*

PCTOPP_COMMENTAIRE SHIP NTS_CDEE/EXP/ALL*60*

PCTOPP_COMMENTAIRE PALL NTS_CDEE/PAL/ALL*60*

SQL_SEL_MVT_SORTIE

21,60 Complément de select

SQL_SUPPRESS_MVT

21,60 Complément de sélection des mouvements à supprimer - Voir poption Og

Exemple

SQL_SUPPRESS_MVT and s0_etat != "N"

_SUP_REQ_FAB0

21, 60 Complément de requête sur fab0

_SUP_REQ_NEG_STK0

21, 60 Supplément de requête sur stk0 valable pour la restriction du contrôle de l'état des besoins négoce.

TSC_NB_AMALG

Paramétrage des TSC pour nombre de feuilles amalgame

2 lignes de notes sont possibles, soit 20 codes TSC au total

Pas de paramétrage par défaut

21, 23 Code du TSC 1

25, 27 Code du TSC 2

29, 31 Code du TSC 3

33, 35 Code du TSC 4

37, 39 Code du TSC 5

41, 43 Code du TSC 6

45, 47 Code du TSC 7

49, 51 Code du TSC 8

53, 55 Code du TSC 9

57, 59 Code du TSC 10

Exemple

TSC_NB_AMALG NB1 NB2 NB3 NB4 NB5

TSC_NB_POSE_AMALG

Paramétrage des TSC pour nombre de poses amalgame

2 lignes de notes sont possibles, soit 20 codes TSC au total

Pas de paramétrage par défaut

21, 23 Code du TSC 1

25, 27 Code du TSC 2

29, 31 Code du TSC 3

33, 35 Code du TSC 4

37, 39 Code du TSC 5

41, 43 Code du TSC 6

45, 47 Code du TSC 7

49, 51 Code du TSC 8

53, 55 Code du TSC 9

57, 59 Code du TSC 10

Exemple

TSC_NB_POSE_AMALG AM1 AM2 AM3 AM4 AM5

TYPE_SR_NOMENCLATURE

21, 23 Code du type de mouvement (TMV) pour les sorties réserves de la nomenclature.
Ce TMV doit être une sortie.


Génération de dossiers industries mécaniques

Génération de dossiers industries mécaniques gdf

Options Valeur alpha 2 Valeur alpha 3 Notes

Valeurs numériques

1

Potentiel général par défaut pour le jalonnement (options Ojj et Ooo)

Le temps d'attente (en jours) est un temps toujours avant la préparation et la réalisation.

Ce temps tient compte de la notion de jours et heures ouvrables si le caractère 7 de la zone paramètre saisie dans la table des postes de l'opération en cours est à O, sinon ce temps ne tient pas compte de cette notion.

Le temps d'attente est exprimé en jours, et la conversion en heures est simple (1 jours = 24 heures)

Exemple 0.2 jours = 24h x 0.2j = 4.8 heures

Valeur par défaut : 8

2

L I B R E

Options triées

-Kx

Teste si utilisation des générations de mouvement de stock. Selon la valeur de x :

r Réservations de stock

p Sortie de stock

-Nx

x étant le numéro d'OF à générer

O22

OF de format 90010001-01

O33

OF de format 90010001-001

Oaa

Génération des dossiers à générer ou à régénérer

Oaq

Arrondi de la quantité à réserver (Olo)

Obb

Génération des besoins matières brutes sans jalonnement. (voir Off et Ogg)

Obj

Génération des besoins matières brutes avec jalonnement. (voir Off et Ogg)

Calcul et mise à jour des dates de début et de fin prévues dans le dossier de fabrication.

(par défaut calendrier potentiel par section / machine / poste)

Occ

Mise à jour zone dossier généré si pas de contrôle

ou si contrôle et données techniques existantes

ou si contrôle et confirmation

Ocd

Calcul de la date de fin prévue différent

Odd

Génération à partir d'un devis / sous-devis s'il en existe un, saisie sur la ligne de commande. (F8)

Odp

Génération à partir du devis PRO

Odu

Mise à jour de la date de dernière utilisation dans la forme utilisée lors de la génération d'un dossier,

et de la date de dernière sortie des articles

Oec

Crée une entrée en commande de matières si option Oqq

Oed

Edition des dossiers à la suite de la génération

Oee

Ne tient pas compte de DT1 et DT2 dans le calcul des besoins brut et net.

DT1 = Longueur

DT2 = Largeur

Oep

Crée une entrée prévisionnelle de matières si option Oqq

Off

En liaison avec Obb ou Obj permet de fournir un besoin brut globalement

Sinon par défaut gestion au niveau de l'OF

Ofx

Si un article est rencontré plusieurs fois dans une nomenclature, les composantes fixes des différents coûts ne sont comptabilisées qu'une seule fois en tout.

Oga

Pas de génération de la gamme

Ogg

Génère les besoins matières bruts et nets au niveau de l'OF (avec Obj le besoin sera jalonné)

Ohh

Calendrier potentiel par section / machine pour Ojj

Oip

Interface Direct Planning

Oii

Calendrier potentiel par Section pour Ojj

Oil

(*) Ignore la longueur et la largeur dans les calculs. Par défaut, pour déterminer la quantité de mouvement de stock et le prix de l'article, on multiplie par la longueur et la largeur !

Ojj

Calcul et mise à jour des dates de début et de fin prévues dans le dossier de fabrication (jalonnement)

(par défaut calendrier potentiel par section / machine / poste)

Ojp

Calcul et mise à jour des dates de début et de fin prévues dans le dossier de fabrication avec chargement du calendrier par jour. (jalonnement) (L' emploi de gp_ch n'est plus nécessaire)

Ojr

Jalonne avec le temps restant (Temps prévu - temps réalisé)

Okk

Confirmation de la génération des mouvements de stock

Oll

On tient compte de la largeur des lames

Olo

Gestion des réserves matières en lots - lieux

Olr

Ouvre une fenêtre pour saisir le lieu de rangement lors d'un mouvement de stock

Omc

Gestion des matières de compléments (F9) : (OPTION) (Uniquement si option Oqq activée)

Omd

Mise à jour de la date d'entête de commande en régénération dans le cas d'une FBI non rattachée.

Omm

Choix par menu

Génération à partir d'un devis spécifique

Génération à partir des données techniques

Omo

Mise à jour du responsable de lancement avec le code de l'opérateur qui effectue le lancement

Onn

Pas de génération de dossier de fabrication

Ooo

Ne tient pas compte du calendrier par défaut des jours ouvrables (#JO/#JO/#JO) dans les calculs dates prévues pour Ojj

Oos

Pas de majoration de la quantité réservée de matière si l'opération de sciage n'est pas dans la gamme

Opp

Prix d'achat moyen pondéré

Oq0

Permet la génération de dossier avec quantité = 0

Oqq

Gestion stocks réserve (OPTION).

Si la quantité disponible est suffisante pour couvrir la quantité lancée, on effectue un mouvement de réserve de la quantité lancée et on ne génère pas les niveaux inférieurs.

Sinon, on ouvre une fenêtre et on propose en fonction du disponible la quantité à lancer minimum (quantité à lancer - quantité disponible) et on demande une quantité à lancer supérieure ou égale au minimum proposé.

Lorsque cette quantité à lancer est saisie, on effectue une entrée prévisionnelle de la quantité lancée, et on réserve uniquement la quantité nécessaire pour la commande, puis on continue à générer les niveaux inférieurs, avec la quantité lancée.

Or1

Crée un mouvement de réserve au niveau 1 si option Oqq

Gestion stocks réserve

Ora

Gestion rapide de la génération, régénération

Orr

Régénération d'un dossier de fabrication

Attention, si cette option est positionnée, certains paramètres seront lus sur l_gdf et non pas ici.

Plus de détail en pas de cette page, dans la section Paramètres nécessaires.

Oss

Affichage écran de sélection

Osv

Génération des dossiers en suivant

Otd

Taux décomposable. Le taux horaire utilisé pour la valorisation des gammes peut, s'il est paramétré comme tel sur l'opération, être la somme de trois taux :

Le taux horaire de l'opération

Le taux horaire de la machine associée à l'opération

Le taux horaire du salarié société #SOC

Sans cette option, le taux horaire retenu pour valoriser les gammes est uniquement celui de l'opération.

Ott

Arrondi par excès de la quantité (Pas de décimale)

Ouu

Génération par utilisateur seulement

Ovv

On ne génère que la 1ere ligne de commande et on supprime dans fab0 les autres lignes.

La première ligne est toujours générée avec le client #SOC et le produit PRODUCTION (Spécifique)

Oww

Pas de mise à jour du stock résultant

Oxa

Calcul au prix d'achat

Oxb

Calcul au prix selon le type de valorisation

Oxr

Calcul au prix de revient

Oxv

Calcul au prix de vente

Oxx

Demande de confirmation d'effacement des saisies de temps

Oyy

gestion de la gâche variable au niveau du calcul du coût des opérations de la gamme et gestion du comptage en entrée ou en sortie.

Ozz

Copie des notes de la nomenclature et gamme associée

Valeur alpha 2

Caractères 1 à 3 | Type de mouvement de sortie (par défaut : SOR)
Caractères 4 à 6 | Type de mouvement de réserve (par défaut : SOR)
Caractères 7 à 9 | Type de mouvement entrée prévisionnelle (par défaut : ENT)
Caractères 10 à 12 | Type de mouvement entrée en commande (par défaut : ENT)
Caractères 13 à 15 | Code paramètre pour le lancement du jalonnement à la suite de la génération (par défaut : SOR)
Caractères 16 à 18 | Code paramètre pour la réactualisation du devis avec la quantité lancée avant la génération (par défaut : SOR)

Valeur alpha 3

Caractères 1 à 56

Transfert de type de note devis (note_ldev), de type de note commande (cde3) vers type de note en fabrication (note_of)

On peut définir jusqu'à 8 blocs de 7 caractères. Les blocs sont côte à côte, sans séparateur.

La structure d'un bloc est la suivante :

Caractère 1 : Origine des notes à transférer

D Notes issues du devis

C Notes issues de la commande

Caractères 2 à 4 : Type de note du devis à transférer

Caractères 5 à 7 : Type de note de la ligne de commande où sont transférées les notes

ATTENTION !!! Ce transfert de notes paramétrable ne fonctionne que pour les générations à partir des devis.

Exemple

D021 C022NOR

Dans cet exemple, nous avons 2 blocs de 7 caractères :

les notes de type 021 du devis généré (D) seront recopiées dans les notes de type [blanc] du dossier de fabrication de destination.

Les notes de type 022 de la commande générée (C) seront recopiées dans les notes de type NOR du dossier de fabrication de destination.

Notes

COMPTEUR_FBI | 21 à 22 Type de compteur numérique obligatoire
DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
S | 2, 60 Complément de sélection sur fab2

Paramètres nécessaires

#FB RGD ou #FB GDF | On va lire certains paramètres de lancement de l'un de ces 2 programmes. Si l'option Orr est positionnée, on va lire sur #FB RGD Sinon, on va lire sur #FB GDF Dans les 2 cas, il s'agit du présent programme. Les paramètres suivants sont lus : Valeur numérique 1 Potentiel général par défaut pour le jalonnement Valeur numérique 2 (inutilisée) A2[1,3] TMV de sortie A2[4,6] TMV réserve A2[7,9] TMV entrée prévisionnelle A3[10,12] TMV entrée en commande
#CF ATL A3[17] | Méthode de prise en compte des plages horaires


Génération des dossiers de fabrication en automatique

Génération des dossiers de fabrication en automatique gdf_ondu

Options

Obg | Blocage génération Cette option bloque la génération mais n'empêche pas le transfert vers PC-TOPP
Ode | debug écran non
Odf | debug fichier oui
Odp | Permet la régénération après la déclaration de production
Oep | Crée une entrée prévisionnelle sur le produit lancé
Oex | Mode expert (pour les contrôles possibilité)
Opo | Papier pré-imprimé obligatoire si référence de pré-impression
Org | Régénération
Osi | Spécifique
Osp | Crée une sortie prévisionnelle sur les composants de niveau (n+1)
Ote | Test devis
Otp | Transfert PC-Topp

Valeur alpha 2

A2[1,3] | Code environnement de valorisation (coût complet / prix de cession)
A2[4,6] | Type de mouvement de sortie prévisionnelle
A2[7,9] | Type de mouvement d'entrée prévisionnelle
A2[10,12] | Famille qualité carton (inutilisé)
A2[13,15] | Sous-famille qualité carton (inutilisé)
A2[16,18] | Code environnement de valorisation (coût incomplet / prix PUMP)
A2[19] | Caractère @ pour le transfert PC TOPP partiel. Voir les notes commençant par FIC
A2[20] | Type de transfert. Seules valeurs possibles : P Transfert partiel C Transfert complet
A2[21] | Où récupère-t-on le code gamme standard ? Commandes TRANSFORME Si A2[21] = L : sur la ligne de commande (TSC 200, zone ic_char3_1) Sinon : sur le PF (TSC 200, zone ic_char3_1) Autres types de commande : le caractère A2[21] n'entre pas en ligne de compte. Commandes ODM : code gamme Ordre de Marche (récupéré en A4[1,3] Commandes CARTONNIER sur la ligne de commande (TSC 200, zone ic_char3_1); si non renseigné, code gamme = FB2 "en dur"
A2[22] | Régénération des OF 1 Régénération des OF dont la date de fabrication est supérieure ou égale à la date indiquée dans le paramètre TOP GRD, A1[1,10]. 2 Régénération OF suite à modification de commande Autres valeurs : Génération batch des OF

Valeur alpha 3

A3[1,30] | Nom du fichier lock pour PC-TOPP
A3[31,60] | Nom du fichier PC-TOPP

Valeur alpha 4

A4[1,3] | Code gamme pour Ordre de Marche
A4[4,6] | Type note erreur (par défaut : GAM)

Notes

MAJ_FLAG_INFO_C CF_MAJ_FLAG_INFO_C VAL_MAJ_FLAG_INFO_C | Voir page dédiée
FIC_ANOMALIE | 21 à 60 Nom du fichier anomalie
FIC_ARRET | 21 à 60 Nom du fichier arrêt
FIC_LOCK | 21 à 60 Nom du fichier lock Plus d'infos
FIC_LOCK_PCTOPP | 21 à 60 Nom du fichier lock PCTOPP Plus d'infos
FIC_LOCK_VS | 21 à 60 Nom du fichier lock VS Plus d'infos
FIC_PCTOPP | 21 à 60 Nom du fichier PCTOPP
FIC_TRACE | 21 à 60 Nom du fichier trace
PCTOPP_COMMENTAIRE | Possibilité d'éditer des commentaires (ligne de type C) dans le fichier PCTOPP 21 à 24 Code destination PCTOPP CORS Planning onduleuse CORT Terminal onduleuse RCL Impression onduleuse CNVS Planning de transformation (toutes les machines de transformation de la gamme) CNVT Terminal de transformation (toutes les machines de la gamme) RCVM Impression transformation (toutes les machines de la gamme) SALE Ventes SHIP Expédition 22 à 60 Paramétrage de lecture de l'information complémentaire (TSC) alimentant le commentaire TSC_XXX_YYY_G où XXX Origine du TSC CAS01 Cascade mode 1 1 Séquence ligne de commande de rattachement 2 Ligne de commande de rattachement 3 Produit fini 4 Ensemble 5 Client + adresse de livraison de la ligne de commande de rattachement 6 Client de la commande de rattachement CAS02 Cascade mode 2 1 Triplet 2 Produit fini 3 Ensemble YYY Code TSC G Zone alphanumérique de 30 caractères
_SUP_SQL_FAB0 | 21,60, Complément de sélection des ordres de fabrications à générer/régénérer (table fab0)

Paramètres utilisés

.EP zone num.1 | Nombre d'étiquettes
.ET | Type d'étiquette
.OO | Options onduleuse
.PP | Protection palette
.SP | Schéma de palettisation
.TP | Type de palette
.TR | Type de refouleur
FAM A3[31,33] | Code pour transfert PC TOPP
PC A1[4,9] | Profil carton
REA | Commandes CARTONNIER le mode est Cartonnier (on ne regarde pas le mode d'approvisionnement). Commandes autres que CARTONNIER Si REA A2[1] = S, alors le mode est Synchrone, sinon Asynchrone.
ROP | Numéro de rotation des piles

TSC utilisés

TSC 012 |
TSC 020 |
TSC 030 |
TSC 035 |
TSC 045 | Caractéristiques architecture
TSC 070 | Fiche technique
TSC 072 |
TSC 090 à 097 | Options onduleuse
TSC 110 |
TSC 200 | Gamme de fabrication
TSC 203 | Qualité carton
TSC 210 | Spécifications de colisage
TSC 218 | Dimensions de la palette
TSC 220 | Spécifications de palettisation
TSC 225 | Encombrement de palettisation
TSC 230 | Spécifications de cerclage
TSC 310 | Composition carton
TSC 332 |
TSC 510 | Ouverture, poussée et nombre de poses
TSC 51C | Récupération du code rotation avant ou après (voir paramètre type ROP - Rotation des piles)
TSC 600 | Caractéristiques machines
TSC GC1 |
TSC GD2 |
TSC I00 | Fiche impression
TSC I01 à I09 | Couleurs d'impression
TSC I23 |
TSC IC1, IC2, IC3 |
TSC N10 |
TSC N12 |
TSC NAB |
TSC P10, P11 | Spécifications étiquettes palettes
TSC P20 |
TSC PPC |
TSC Y01 |


Génération des dossiers de fabrication en automatique

Génération des dossiers de fabrication en automatique gdf_don

Cliquez ici pour accéder au site internet de PC-TOPP avec la description des fichiers.

Penser à #CF ATL A3[32] pour le système de planification.

Fichier généré

Le 18/12/2008 :

Ajout des zones 079, 080, 081 et 082 et décalage des zones suivantes.

Mise à jour des zones 015, 068, 080 (voir le TSC OND), 083.29 et 083.30

Zone 083.29 : Référence demande client (Référence client du devis (Zone kp_de_lvotrefdem de la table kp_demcli))

Zone 083.30 : Libellé spécifique 2 du PF (Libellé spécifique 2 du produit fini)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de dossier - numéro de ligne de dossier

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+<<&]

Valeurs numériques

1

Nombre de jours à retrancher de la date du jour pour la recherche des mouvements d'entrée d'outillage pour retrouver la date de disponibilité

Voir la note _SUP_REQ_STK0_OUT.

Options triées

-N

Génère ou régénère le numéro d'OF passé en argument

Oam

SPECIFIQUE. Permet de passer le nombre de machines de transformation passées à PCTOPP de 6 à 16

Oat

Génération d'une action de service de type transport dans le devis 98

Ocd

Calcul des déchets basé sur les TSC

Ocg

Gestion des consommables

Odp

Régénération de dossier après déclaration de production.

Cette option ne doit être positionnée qu'en régénération

Les options -Oep et -Osp (génération de mouvements prévisionnels) doivent être désactivées.

Note de DC : la cohabitation avec Osp ne pose aucun problème; à priori, idem avec Oep.

Si la régénération fait suite à de la production, le système remet à jour le prix des mouvements de stocks.

Odt

SPECIFIQUE. OTDATA date au plus tôt

La date de fin de fabrication est remplacée par le calcul suivant :

Nouvelle date = date de fin de fabrication + nombre de jours définis par la tolérance délai de la ligne de commande

Remarque : Le nombre de jours peut être négatif.

Voir le nombre de jours à ajouter ou à retirer à la date de fin de fabrication dans le paramètre QAL.

Si option absente, on prend le délai de fabrication saisi sur la ligne de commande.

Oee

Force l'édition du dossier de production en ré-génération même si l'option Odp est positionnée

Oeg

En régénération d'OF, la gamme sera envoyée vers PCTOPP même si la gamme n'a pas changé.

En régénération des dossiers de fabrication, si la gamme est inchangée, elle est remplacée par le caractère de transfert partiel (paramétrable en A2[19]).

En ajoutant cette option, la gamme sera toujours envoyée vers PCTOPP en régénération.

Oep

Crée une entrée prévisionnelle sur le produit lancé. Voir alpha2[7,9]

Oes

Envoi d'un fichier de statistiques de production

Voir les notes FIC_STATS_PROD et suivantes.

Oex

Mode expert (pour les contrôles de possibilité machine)

Ofd

Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût

Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.

Off

Activation du calcul de la date de fin de fabrication au plus tôt

Oga

Sélection automatique du code gamme2

Ogp

Gestion des plaques dans le devis

Oic

Affichage d'informations complémentaires avant message d'anomalie

Permet d'afficher avant chaque message d'anomalie les informations suivantes :

Code article + Désignation

Code client + Raison sociale

Agent commercial + Libellé long du paramètre REP

Suivi d'affaire + Libellé long du paramètre FAB

Oin

Inversion laize et coupe

Ole

Libellé encre donné par les TSC 134 à 139
Doit être géré dans la partie spécifique (K et E)

One

Régénération des OF non annulés avec AR non édité suite code blocage

Cette option ne doit être positionnée qu'en régénération (Option Org)

La racine du code TSC de stockage des codes blocages de la revue de contrat doit être renseignée (#CF CDE A3[37,38]). Voir aussi BLO A4[22]

Onv

Non valorisation de la composition même si celle-ci est valorisable, si la gamme saisie ne possède pas de machine de type onduleuse ou extrudeuse.

Ony

Gestion de la sous-traitance entre sites - Tableau de bord du multisite

Active la numérotation annuelle pour le compteur de FB2

Ooo

Transfert de l'onduleuse vers OMP :

Par défaut, l'onduleuse transmise à OMP est celle de la gamme.

Cette option permet de choisir un ordre de priorité du choix de l'onduleuse à transmettre.

– Si la compo n'a qu'une seule onduleuse autorisée, alors c'est celle-ci qui sera transmise (gestion des onduleuses interdites depuis la compo).

– Si la compo possède plusieurs onduleuses autorisées, alors on prendra celle qui est derrière le profil de la compo.

– A défaut des deux premières conditions, on prendra celle de la gamme comme actuellement.

Oop

Permet de lancer la régénération de dossier afin d'alimenter la zone lc_prx_revient avec la méthode du multiniveau.

Option Orm requise.

Ne pas oublier de mettre les mêmes compléments de sélection que pour le calcul du prix de revient (Orm) dans la génération classique des dossiers.

Voir les notes

_SUP_REQ_FAB0_CP_TET

_SUP_REQ_FAB0_CP_FIL

_SUP_REQ_FAB0_CRP

Opa

Génération d'un fichier plat à destination du Palettiseur

Voir plus bas la structure de ce fichier.

Les notes FIC_PALET, FIC_LOCK_PALET et FIC_TRACE_PALET sont obligatoires.

Opl

Paramétrage Plastique

Opo

Obligation d'avoir une référence de papier sous la référence de pré-impression pour permettre la génération.

Opr

Réservation des papiers

Cette option est automatiquement activée en multi-niveaux.

Voir mp_param[21] si on ne veut pas de réservation.

Oq0

Régénération des OF non annulés avec une quantité lancée à 0

Cette option ne doit être positionnée qu'en régénération (Option Org).

Oqt

Calcul de la quantité technique (zone 013 OTDATA) sans application de la gâche

Ore

Regroupement des éditions des OF à la fin du traitement

Org

Régénération

Orm

Nouvelle méthode d'alimentation de la zone lc_prx_revient en tenant compte du multi-niveaux

Voir les notes

_SUP_REQ_FAB0_CP_TET

_SUP_REQ_FAB0_CP_FIL

_SUP_REQ_FAB0_CRP

Orp

Réalisé prévu

Pour les articles consommés, montant réalisé = montant prévu (car pas de remontée dans les prix de revient)

Ors

Régénération des statistiques de production

Orv

Pas de contrôle sur qualité interdisant la génération d'OF

Osp

Crée une sortie prévisionnelle sur les composants de niveau (n+1). Voir alpha2[4,6]

Osr

Active la non prise en compte des rives mini dans les calculs du devis

Ost

Gestion de la sous-traitance entre sites - Tableau de bord du multisite

Active la sous-traitance des plaques

Otp

Transfert PC-Topp

Ots

Transfert SEEMI

Ovo

Génération fichier pour VoluOrdo / Direct Planning

Ovq

Pas de vérification si la quantité de la FBI dépasse la quantité demandée

Valeur alpha 2

Caractères 1 à 3 | Code environnement pour le calcul des taux horaires (Coût complet / Prix de cession)
Caractères 4 à 6 | Type de mouvement de sortie prévisionnelle. Voir option -Osp
Caractères 7 à 9 | Type de mouvement d'entrée prévisionnelle. Voir option -Oep
Caractères 10 à 15 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 16 à 18 | Code environnement pour le calcul du prix de cession - (Coût incomplet / Prix PUMP)
Caractère 19 | Caractère à utiliser pour un transfert partiel vers PC-Topp
Caractère 20 | Gestion du transfert partiel [blanc] Transfert complet en batch Transfert complet pour les cartonniers Demande de confirmation. Transfert partiel pour le transformé P Transfert partiel forcé C Transfert complet forcé Remarque Pour les cartonniers, il s'agit toujours d'un transfert complet
Caractère 21 | Gestion du code gamme [blanc] TSC 200 du PF pour le transformé TSC 200 ligne de commande pour le cartonnier L TSC 200 de la ligne de commande pour tous les types de produit.
Caractère 22 | Gestion régénération [blanc] Régénération suite à sélection multicritères 1 Régénération des OF dont la date de fabrication est supérieure ou = TOP RGD alpha1[1,10] 2 Régénération suite à modification de commande (f0_gener = 2)
Caractère 23 | Code usine pour PC-TOPP [à vérifier]
Caractères 24 à 31 | Numéro de devis pour le calcul des actions de service
Caractère 32 à 33 | Numéro d'offre pour le calcul des actions de service [à vérifier]
Caractères 34 à 36 | Site de production - Tableau de bord du multisite Permet de restreindre la génération de dossier aux OF de ce site
Caractères 37 à 51 | Code article pour la génération automatique de la correction de valeur
Caractères 52 à 57 | Type et code du paramètre pour le paramétrage du conditionnement cartonnier (par défaut #FBGDF)
Caractères 58 à 60 | Code produit PC-TOPP

Valeur alpha 3

Caractères 1 à 30

Caractères 31 à 60

Nom du fichier de verrou PCTOPP

Nom du fichier PC-TOPP

Si ces 2 X 30 caractères sont insuffisants, vous pouvez opter pour un paramétrage sur les notes FIC_PCTOPP_n et FIC_LOCK_PCTOPP_n qui offrent 2 X 40 caractères et qui en outre offrent la notion d'environnement de production.

Valeur alpha 4

Caractère 1

Caractère 2

Contrôler si le code site de la gamme est compatible avec le site de production de la FBI

N aucun contrôle

W message d'avertissement

B contrôle bloquant (la FBI n'est pas générée)

C demande de confirmation (pour poursuivre la génération)

Tableau de bord du multisite

Caractères 1 à 3

Code gamme pour génération ODM [à vérifier]

Caractères 4 à 6

Code action automatique à créer après la génération d'un dossier de fabrication (Type de paramètre ASO)

Permet de créer en automatique des actions de suivi d'outillage après la génération des dossiers de fabrication.

Caractère 7

Paramétrage du contrôle de la validité des outillages (Formes et clichés)

N Pas de contrôle

W Message d'avertissement avec génération de l'OF

C Demande de confirmation de génération de l'OF

B Message d'anomalie sans génération de l'OF

Caractère 8

Localisation des Mylars – méthode de construction de l'information

0 données de rangement de la fiche produit du Mylar (lieux 1 et 2).
Les Mylars sont transférés (Valeur par défaut).

1 les Mylars ne sont plus transférés en tant que tels, mais alimentent la zone location du cliché.

Caractères 9 à 11

Code environnement pour calcul du prix de cession pour l'alimentation de la zone coût prévu réactualisée

Notes triées

Parfois, l'intérêt du regroupement de certaines notes l'emporte sur le tri.

AS_TRANSPORT

21,23 Action de service de transport

CODE_CONFIG_OMP

21,23 Code du #CF : configuration pour OMP (par exemple : #CF OMP)

CODE_MACHINE_RV_GAM

21,26 Code machine

En régénération des dossiers de fabrication, si la gamme est inchangée, elle est remplacée par le caractère de transfert dit partiel (paramétrable en A2[19]).

Maintenant, via le paramétrage, il est possible pour certaines machines via leurs codes VoluPack, de renvoyer leurs gammes dans tous les cas.

Cette note permet de saisir une liste.

Dans tous les cas la gamme sera renvoyée si le code machine est présent dans cette liste paramétrée.

CODE_SYSTEME_PLANIF

21 Code du système de planification :

Permet de choisir le message affiché à la fin de la génération des OF.

1 PC-Topp (par défaut)

2 OM-Partners

3 AIS

4 Direct Planning

Dans le cas où rien n'est paramétré, on récupère le code sur #CF ATL, alpha3[32].

Voir aussi la note NOM_SYSTEME_PLANIF (ci-dessous)

COMPTEUR_TYC_FB2

Gestion de la sous-traitance entre sites - Tableau de bord du multisite

21,23 Numéro de compteur (null par défaut)

CONFIG_PRIX_CESSION

21,26 Type et code du paramètre de configuration de recherche du tarif

ECARTS_PLATEAU

Permettre de transférer à PCTOPP (OTDATA) les informations plateau :

• Largeur de la charge de palette (zone 123, 4 caractères)

• Longueur de la charge de palette (zone 124, 4 caractères)

• Largeur du plateau (zone 125, 4 caractères)

• Longueur du plateau (zone 126, 4 caractères)

Voir aussi les notes FORMAT_PLATEAU et PARAMETRAGE_PLATEAU

21,24 Ecart minimum du plateau par rapport à la charge (en mm)

26,29 Ecart maximum du plateau par rapport à la charge (en mm)

Valeurs par défaut (si cette note n'existe pas) :

Ecart minimum : 79 mm

Le plateau peut être jusqu'à 79 mm plus petit que la charge.

Ecart maximum : 20 mm

Le plateau peut être jusqu'à 20 mm plus grand que la charge.

FIC_PCTOPP_n

FIC_LOCK_PCTOPP_n

21,60 Nom du fichier PCTOPP en sortie

21,60 Nom du fichier de verrou PCTOPP

n représente le numéro d'environnement (réel, test, …)

0 (zéro) est la valeur par défaut pour l'environnement réel

Ces 2 notes offrent une plus grande longueur du nom de fichier que la zone alpha 3.

En outre, elles incluent la notion d'environnement de production (réel, test, …)

FIC_HISTO_PCTOPP_n

21,60 Nom du fichier d'historisation PCTOPP

où n peut prendre les valeurs (voir ci-dessus)

Le nom du fichier historisé peut-être horodaté.

Il faut dans ce cas utiliser la même codification que pour l'horodatage des fichiers par les visualisations.

%D2% Date du jour au format aammjj

%D4% Date du jour au format aaaammjj

%HM% Heure courante au format hhmm

%HS% Heure courante au format hhmmss

FORMAT_PLATEAU

Formats possibles des plateaux

21,24 Longueur du plateau

26,29 Largeur du plateau

ENVIR_PRIX_CESSION

21,23 Environnement de prix de cession

FIC_IMG

FIC_LOCK_IMG

21,60 Nom du fichier d'import de l'interface IMAGE

21,60 Nom du fichier lock

FICK_LOCK_AIS

FIC_LOCK_OMP

FICK_TRACE_AIS

FIC_TRACE_OMP

Transferts AIS (Winbox) et OM-Partners

21,60 Nom du fichier de verrouillage AIS

21,60 Nom du fichier de verrouillage OMP

21,60 Nom du fichier trace AIS

21,60 Nom du fichier trace OMP

FIC_STATS_PROD

FIC_LOCK_STATS_PROD

FIC_TRACE_STATS_PROD

Fichier de transfert de VoluPack vers PCTOPP

L'option Oes est obligatoire.

21,60 Nom du fichier statistiques de production

21,60 Nom du fichier de lock

21,60 Nom du fichier trace

FIC_OMP

FIC_TRACE_OMP

Pour la génération d'un fichier order au format XML

21,60 Nom du fichier OMP

21,60 Nom du fichier trace

FIC_PALET

FIC_LOCK_PALET

FIC_TRACE_PALET

Génération d'un fichier plat à destination du palettiseur

L'option Opa est obligatoire ainsi que les 3 notes suivantes :

21,60 Nom du fichier des données

21,60 Nom du fichier de verrouillage

21,60 Nom du fichier trace

IMPRESSION_AUTO_GENE

Impression automatique à la génération

21,26 Type et code du paramètre de lancement de l'édition

IMPRESSION_AUTO_REGE

Impression automatique à la régénération

21,26 Type et code du paramètre de lancement de l'édition

METHODE_MESSAGE_ANO

21 Numéro de la méthode

1 par défaut (construction standard)

2 nouvelle construction

MODE_DP_REGENERATION

21 Mode de (ré)-génération

G Génération normale

R Régénération (par défaut)

NB_SECONDES_ATTENTE

21,23 Temps d'attente entre 2 tentatives de blocage

NB_TENTATIVES

21,23 Nombre de tentatives de blocage

NOM_SYSTEME_PLANIF

21,30 Nom du système de planification

PCTOPP (par défaut)

OMP

AIS

IMAGE Voir description

Vérifiez aussi la note CODE_SYSTEME_PLANIF (ci-dessus)

Paramétrer les notes REPERTOIRE_FIC_XXX, FIC_XXXet FIC_LOCK_XXX

OPE_PALETTISATION

Code opération de palettisation

Si ce code est rempli, la palettisation ne sera pas prise en compte pour le calcul du prix de cession.

OTDATA_TYPE_PALETTE

Gestion Zones Palettisation pour transfert PCTOPP (OTDATA)

SPECIFIQUE

PARAMETRE_CONFIG_DPL

21,26 Type et code du paramètre de configuration de Direct Planning

Exemple (valeur par défaut) #CF DPL

PARAMETRAGE_PLATEAU

Type et code du paramètre où se situent les paramétrages des informations plateau à récupérer (pas de valeur par défaut)

Remarques

• Il peut s'agir d'un autre paramètre de lancement de génération d'OF ou d'un paramétrage de configuration.
Cela permet d'éviter de paramétrer autant de fois les informations plateau utilisées dans le transfert OTDATA qu'il y a de paramètres de lancement de génération d'OF : on paramètre ces 2 notes une fois pour toutes dans l'un des paramètres de lancement, et on indique ensuite où il se trouve.

• Ce paramétrage est prioritaire par rapport aux notes saisies sur le paramètre de lancement (notes ECARTS_PLATEAU et FORMAT_PLATEAU).

RACINE_TSC_MYLARS

NOTE ANNULEE

Les Mylars sont sur des TSC standard M10, M20, … M90.

Il faut indiquer au niveau des opérations (table i_postes) si on est sur une opération d'impression (ss_param[15] = I)

21,22 Racine du TSC permettant de retrouver les MYLARS. Par défaut : M

Les Mylars peuvent être transférés vers OMP.

Ils sont stockés dans des TSCs sur le code cliché.

Ces TSC peuvent se coder comme suit .M1, .M2, …

Il faut lors du transfert, spécifier la racine du TSC (M par défaut)

RECH_CONF_TAR_FB2

21,26 Type et code du paramètre définissant les méthodes de recherche des tarifs pour la FB2 générée (par défaut : #CFTAR)

REPERTOIRE_FIC_AIS

REPERTOIRE_FIC_OMP

21,60 Nom du répertoire où doivent être stockés les fichiers des transferts AIS (Winbox) et OM-Partners

REPERTOIRE_FIC_IMG

21,60 Nom du répertoire où doivent être stockés les fichiers d'import de l'interface IMAGE

_SUP_REQ_COMPOSANTS

21,23 Complément de sélection sur les composants à prendre en compte pour le calcul des coûts matières

Ce complément est utilisé avec une table temporaire dont voici les colonnes utilisables :

code_gamme Code gamme

mp_code Code article

mp_param Paramétrage article

mp_dt3 Donnée technique 3

mp_dt4 Donnée technique 4

prix_cession Prix de cession

Exemple and mp_code[1,3] not in ("ZDA","ZCO")

SUP_REQ_GDF

Complément de sélection sur fab0 (doit commencer par un and)

_SUP_REQ_FAB0_CP_TET

21,60 Complément de requête sur fab0 sur la recherche de la somme des coûts prévus ne concernant que l'OF de tête

Voir l'option Orm

_SUP_REQ_FAB0_CP_FIL

21,60 Complément de requête sur fab0 sur la recherche de la somme des coûts prévus pour l'OF de tête et les OF fils

Voir l'option Orm

_SUP_REQ_FAB0_CRP

21,60 Complément de requête sur fab0 sur la recherche de la somme f0_crp et f0_cpp prévus pour l'OF de tête les OF fils

Voir l'option Orm

_SUP_REQ_PREMIER_R

21,60 Complément de recherche du premier R du PF transféré (OTDATA)

Tables accessibles directement : nom0 et mat

Exemple

and mp_sdevis=99

_SUP_REQ_RECHLL_ARE

21,60 Complément de sélection de recherche par lieux pour les mouvements de stocks à retraiter

IMPORTANT : Par défaut, la recherche n'est pas limitée, la limitation au lieu de rangement 2 doit être paramétrée via ce complément de sélection.

Exemple

and s0_rgt2 matches "ARE*"

_SUP_REQ_STK0_OUTI

21,60 Supplément de requête sur la table stk0 pour la recherche des mouvements d'entrée d'outillage pour retrouver la date de disponibilité

Voir la valeur numérique 1

_SUP_REQ_SUPPR_FAB2

21,60 Complément de sélection de la suppression des temps (fab2) en régénération des ordres de fabrication

TMV_CONSO_ACCESSOIRE

21,23 Type de mouvement de stock de sortie des accessoires

Lors de la régénération de l'OF, tenir compte des sorties accessoires, suite à production sur l'OF, dans le calcul de la quantité des sorties réserves des accessoires qui vont être régénérées.

TYPE_NOTE_CLI_LIVRE

21,23 Notes sur le client livré pour le Ccorders_Cuscomments

Transfert OMP - Génération d'un fichier order au format XML

TYPE_NOTE_RC

21, 23 Type de note saisie dans l'écran de revue de contrat de la commande de rattachement

Génération d'un fichier plat à destination du Palettiseur - Structure du fichier

N° | Libellé | Position | ZONE OTDATA
01 | Code transaction | 001-001 | 001 | 0001-0001
02 | Numéro de commande (FBI) | 002-011 | 002 | 0002-0011
03 | Ligne de commande (Ligne de FBI) | 012-015 | 003 | 0012-0015
04 | Code article | 016-025 | 004 | 0016-0025
05 | Date de livraison | 026-033 | 005 | 0026-0033
06 | Nom du client | 034-057 | 007 | 0035-0058
07 | Code client | 058-063 | 043 | 0516-0521
08 | Quantité commandée | 064-069 | 012 | 0082-0087
09 | Code extrudeuse | 070-075 | 021 | 0219-0224
10 | Référence article client | 076-135 | 030 | 0385-0444
11 | Référence commande client | 136-167 | 053.2 | 0644-0675
12 | Dimensions intérieures | 168-185 | 032 | 0455-0472
13 | Hauteur de palette | 186-188 | 033 | 0473-0475
14 | Type de palette + Mode de gestion palette | 189-194 | 034 | 0476-0481
15 | Format de palette | 195-203 | 035 | 0482-0490
16 | Type d'étiquette | 204-204 | 039 | 0506-0506
17 | Nombre d'étiquettes par palette | 205-205 | 040 | 0507-0507
18 | Quantité par palette | 206-210 | 041 | 0508-0512
19 | Nombre de palettes par UC | 211-211 | 047 | 0602-0602
20 | Nombre de piles par UC | 212-212 | 048 | 0603-0603
21 | Dimensions hors tout : Largeur | 213-216 | 049 | 0604-0607
22 | Dimensions hors tout : Longueur | 217-220 | 050 | 0608-0611
23 | Schéma de palettisation | 221-226 | 051 | 0612-0617
24 | Numéro accusé de réception | 227-234 | 053.4 | 0677-0683
25 | Fraction | 235-239 | 053.5 | 0684-0688
26 | Libellé composition | 240-266 | 053.9 + 053.10 | 0696-0722
28 | Libellé substitution intérieure | 267-296 | 053.12 | 0756-0785
29 | Numéro de Plan de Palettisation | 297-308 | 080.25 | 1587-1598
30 | Nombre de palettes de la commande | 309-314 | 012 / 041 |
31 | Type de cerclage | 315-315 | TSC 239 | ic_char3_1
32 | Mode de cerclage | 316-316 | TSC 239 | ic_char3_2
33 | Tension de cerclage | 317-317 | TSC 239 | ic_char30
34 | Dépose de coiffe | 318-318 | TSC 241 | ic_char3_1
35 | Type de banderolage | 319-319 | TSC 241 | ic_char3_2
36 | Tension du film | 320-320 | TSC 241 | ic_char30

Description du fichier Image

Voir aussi le TSC EIM.

Ligne de type C (information de la commande commerciale)

Flag | C
Code client | ec_cli
Raison sociale | cl_nom de ec_cli
N° de commande | ec_num (numéro de commande commerciale)
Date de la commande | ec_datc (date de la commande commerciale)
Code qualité de la commande | mp_qualite_matiere de la présentation
Grammage | mp_poids de la présentation
Tonnage total de la commande | acp_en_quantite (poids total de l'artifice de commande)
Désignation de la qualité | mp_des de la qualité matière de la présentation
Machine | acp_en_cs1 (code statistique 1 de l'artifice de commande)
Solder (O/N) | ec_sold de la commande commerciale
Référence de la commande | ec_ref de la commande commerciale
Pays du client | cl_pays du client de la commande commerciale

Ligne du type D (ligne de découpe)

Flag | D
Code client | ec_cli
Raison sociale | cl_nom de ec_cli
N° de commande | ec_num (numéro de commande commerciale)
N° ligne de découpe | acp_lg_ligne (numéro ligne de découpe : artifice de commande)
Coefficient de la ligne de découpe | acp_lg_coef (coefficient de la ligne de découpe de l'artifice de commande)
Longueur | acp_lg_longueur (artifice de commande)
Laize/Largeur | acp_lg_largeur (artifice de commande)
Tonnage de la découpe | acp_lg_quantite (artifice de la commande)
Tonnage de la ligne de découpe | acp_lg_qte_lig (artifice de la commande)
FBI | FBI rattaché à la ligne de découpe


Lancement de dossiers

Lancement de dossiers edf

Par défaut, on édite les bons de travaux, les fiches suiveuses, les sorties magasin, les fiches de fabrication.

Il est possible de changer ce fonctionnement en précisant des options.

Options

-Kn

Permet de sortir en normal les matières lors du lancement si il n'y a pas eu de réserve lors de la génération.

Permet d'entrer en normal les produits finis et leurs semi-finis de niveau n-1 ou les produits semi-finis de niveau 1.

-Kp

Permet de déduire le stock réserve du stock physique

-Kr

Permet de réserver les matières lors du lancement s'il n'y a pas eu de réserve lors de la génération (la réservation peut se faire automatiquement par l'option -Kr de gdf).
La réédition peut se faire en ajoutant l'option –r.

-Oa

Art graphique : le devis est recherché dans la table ec_dtg

-Ob

Supprime l'édition des bons de travaux

-OB

Supprime les temps alloués sur le bon de travail

-Oc

Pour chaque dossier à éditer (fiche de fabrication), permet de modifier la liste des fiches à éditer

-OC

Affichage d'un avertissement lors de l'édition d'un OF clos (message non bloquant)
Il est possible de regrouper plusieurs options après le O. Exemple -Osb
Par défaut, on ne traite pas le stock

-Od

Feuille : le devis est recherché dans la table fle_2

-Oe

Choix imprimante pour chaque état

#LP FFA pour l'édition des fiches de fabrication

#LP BDT pour l'édition des bons de travaux

#LP FIS pour l'édition des fiches suiveuses

#LP SMG pour l'édition des sorties magasin

#LP COM pour l'édition de l'état complémentaire

#LP EDF si paramètre –Oe non positionné

-Of

Supprime l'édition des fiches suiveuses

-OF

Supprime les temps alloués sur les fiches suiveuses

-Oi

Supprime l'édition des fiches de fabrication

-OM

Transfert des données vers VOL'eTIQUETTE par mode NFS (uniquement si l'option -OV est positionnée)

-Op

Dans l'édition du récapitulatif , prend en comptes tous les OF à tous les niveaux)

-Oq

Supprime la question Installez le papier

-Or

Supprime l'édition du récapitulatif devis (dit Etat complémentaire)

-OR

Date de réserve initialisée directement avec la date d’entrée prévisionnelle de l’article

-Os

Supprime l'édition des sorties magasin

-OS

Pas de sortie réserve si l'article de niveau supérieur est acheté

-OV

Edition des étiquettes par Vol'Etiquette

-O0

Pas d'édition des fiches suiveuses pour les articles avec une quantité à lancer à zéro

-O2

Edition sur une ibm4232 (à gérer dans le report)

-O8

Edition des dossiers par rapport au sous-devis 99 (valable uniquement pour feuille)

-O9

Supprime l'édition de l'entité 99 (Arts graphiques)

Valeur alpha 2

Caractère 10

Saisie de l'ordre de tri des sorties magasin
1 Tri par OF (tri par défaut)
2 tri par date, OF

Edition des fiches de fabrication

Le paramètre FFA donne le paramétrage complet des fiches de fabrication.

Exemple FFA IMP Fiche IMPression
FFA LAB Fiche LABoratoire


Intégration des données de NOVAXIOM

Intégration des données de NOVAXIOM integrer_novaxiom

Intégrer des données transmises par NOVAXIOM vers VoluPack (via un fichier d'événements).

Insertion dans la table fab2 , pour chaque ligne du fichier, et mise à jour de la table fab1 lorsque l'opérateur est un responsable.

Valeur alpha 3

Caractères 1 à 3

Code de difficulté par défaut d'une opération non devisée

Notes

FICHIER_EVT_NOVAX | 21 à 60 Nom du fichier source
FICHIER_UNICITE_EXE | 21 à 60 Nom du fichier d'unicité (interdit l'intégration simultanée)
FICHIER_LOCK_VS | 21 à 60 Nom du fichier de lock posé par VoluPack
FICHIER_LOCK_NOVAX | 21 à 60 Nom du fichier de lock posé par Novaxiom
FICHIER_TRACE | 21 à 60 Nom du fichier trace
FICHIER_ERREUR | 21 à 60 Nom du fichier d'erreur
TRACE_DETAILLE | Active le détail de la traçabilité
HISTORISATION | Active l'historisation des fichiers traces et erreurs


Intégration du suivi de production TBDATA

Intégration du suivi de production TBDATA int_tbdata

Cliquez ici pour accéder au site internet de PC-TOPP avec la description des fichiers.

Options

Opl

On travaille en environnement plastique données Extrudeuse

Si cette option est activée et que la longueur de coupe majorée est supérieure à 9999, les quantités à planifier, planifiée et produite sont divisées par 100.

La longueur de coupe majorée est stockée dans la valeur numérique 2 du TSC 51C de la ligne de commande.

Ote

OPTION ANNULEE

Traiter tous les événement du fichier TBDATA (pas de regroupement sur le dernier enregistrement du couple OF/ Machine)

Explication : Intégration des commandes scindées (cumul des quantités produites).

Actuellement, par souci de rapidité, on ne conserve que le dernier enregistrement du couple OF/ Machine du fichier à intégrer.

Pour pouvoir utiliser cette notion de scindage (caractère a dans la zone 3 de PCTOPP), il faut traiter tous les événements de l'OF.

Notes triées

ATTENTE_LIB_PCTOPP

21 à 24 Durée de l'attente, en secondes, entre chaque test de la présence du verrouillage PCTOPP

(10 par défaut)

ATTENTE_LIB_VSW

21 à 24 Durée de l'attente, en secondes, avant la suppression du verrouillage VOLUPACK (0 par défaut)

ECART_MAX_HEURES_CDE

21 à 25 Écart maxi entre l'heure prévue d'entrée en magasin et l'heure prévue précédemment.

Si l'heure prévue d'entrée en magasin est différente de l'heure prévue précédemment, alors on doit mettre le lc_transfert_trans à 2 s'il vaut 1.

On ne fait le changement de flag que si la différence est supérieure ou égale à (ecart_max) heures.

FICHIER_ERREUR

FIC_ERREUR_N

21 à 60 Nom du fichier contenant les erreurs de transfert

Le but est d'avoir des fichiers différents en fonction de l'environnement.

Exemple : On est en environnement réel et on a un fichier TBDATA à produire, on passe en test alors on ne veut pas envoyer le fichier TBDATA en production et écraser les autres fichiers (trace, histo,..)

Remarque : si les notes ci-dessous ne sont pas en place, on prendra les notes par défaut qui ne gèrent pas l'environnement.

Attention : les notes FICHIER_ (sans environnement) et FIC_ (avec environnement) ne peuvent pas cohabiter.

FICHIER_HISTO

FIC_HISTO_N

21,60 Nom du fichier d'historisation de TBDATA

Le nom du fichier peut être horodaté. Dans ce cas, on utilise la même codification que pour l'horodatage des fichiers par les visualisations :

%D2% Date du jour au format aammjj

%D4% Date du jour au format aaaammjj

%HM% Heure courante au format hhmm

%HS% Heure courante au format hhmmss

idem, N étant l'environnement de VoluPack

FICHIER_LOCK_PCTOPP

FIC_LOCK_PCTOPP_N

21 à 60 Nom du fichier de verrouillage posé par PCTOPP lors de l'écriture

idem, N étant l'environnement de VoluPack

FICHIER_LOCK_VS

FIC_LOCK_VS_N

21 à 60 Nom du fichier de verrouillage posé par VOLUPACK lors de la lecture

idem, N étant l'environnement de VoluPack

FICHIER_TB_DATA

FIC_TB_DATA_N

21 à 60 Nom du fichier source à intégrer

idem, N étant l'environnement de VoluPack

FICHIER_TRACE

FIC_TRACE_N

21 à 60 Nom du fichier de l'historique des opérations

idem, N étant l'environnement de VoluPack

FICHIER_UNICITE_EXE

FIC_UNICITE_EXE_N

21 à 60 Nom du fichier interdisant plusieurs intégrations

idem, N étant l'environnement de VoluPack

HISTORISATION

Activation de l'historisation des fichiers trace et erreur

La seule présence de cette note produit son effet. Pas de paramétrage au caractère 21.

LIMITE_TYPE_AU_SITE

Limiter certains types de machines à certains sites - Tableau de bord du multisite

20 Un espace impératif

21 à 23 Type de machine devant être limité au site ci-dessous

Mettre un astérisque en position 21 pour toutes les machines

25 à 27 Code du site dans auquel il faut limiter le type de machine ci dessus

Possibilité de créer une ligne de note par site.

Exemple

LIMITE_TYPE_AU_SITE OND LIM

Pour limiter les ONDuleuses au site de LIMoges.

MACHINE_PARAMETREE

21 à 26 Machines paramétrées (10 maxi)

MAC_PCTOPP_IGNOREE

21 à 26 Code de la machine PCTOPP à ignorer dans les traitements. 25 machines maxi

Recherche de la correspondance machine PCTOPP / VOLUPACK sur le TSC 601 si la recherche sur le TSC 600 n'a pas abouti.

Prise en compte des déclarations de production par saisie codes barres

MAJ_DATE_PLANIF_TRAN

21 Mise à jour des dates de mises à disposition à chaque intégration des données de PCTOPP pour les machines de transformation (O/N, N par défaut)

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

TRACE_DETAILLE

Mode d'enregistrement dans le fichier trace comportant le détail de chaque enregistrement créé

La seule présence de cette note produit son effet. Pas de paramétrage au caractère 21.


Intégration du suivi de production OMP

Intégration du suivi de production OMP interface_fab_1_etat

Ce programme est opérationnel à partir de la V.4.0.186.2

Cliquez ici pour accéder au site internet de PC-TOPP avec la description des fichiers.

Notes triées

ATTENTE_LIB_OMP

21 à 24 Durée de l'attente, en secondes, entre chaque test de la présence du verrouillage OMP

(10 par défaut)

ATTENTE_LIB_VSW

21 à 24 Durée de l'attente, en secondes, avant la suppression du verrouillage VOLUPACK (0 par défaut)

ECART_MAX_HEURES_CDE

21 à 25 Écart maxi entre l'heure prévue d'entrée en magasin et l'heure prévue précédemment.

Si l'heure prévue d'entrée en magasin est différente de l'heure prévue précédemment, alors on doit mettre le lc_transfert_trans à 2 s'il vaut 1.

On ne fait le changement de flag que si la différence est supérieure ou égale à (ecart_max) heures.

FICHIER_ERREUR

21 à 60 Nom du fichier contenant les erreurs de transfert

FICHIER_LOCK_OMP

21 à 60 Nom du fichier de verrouillage posé par OMP lors de l'écriture

FICHIER_LOCK_VS

21 à 60 Nom du fichier de verrouillage posé par VOLUPACK lors de la lecture

FICHIER_TB_DATA

21 à 60 Nom du fichier source à intégrer

FICHIER_TRACE

21 à 60 Nom du fichier de l'historique des opérations

FICHIER_UNICITE_EXE

21 à 60 Nom du fichier interdisant plusieurs intégrations

HISTORISATION

Activation de l'historisation des fichiers trace et erreur

La seule présence de cette note produit son effet.

Pas de paramétrage au caractère 21.

REP_HISTORISATION

21 à 60 Répertoire d’historisation

LIMITE_TYPE_AU_SITE

Limiter certains types de machines à certains sites

20 Un espace impératif

21 à 23 Type de machine devant être limité au site ci-dessous

Mettre un astérisque en position 21 pour toutes les machines

25 à 27 Code du site dans auquel il faut limiter le type de machine ci dessus

Tableau de bord du multisite

Possibilité de créer une ligne de note par site.

Exemple

LIMITE_TYPE_AU_SITE OND LIM

Pour limiter les ONDuleuses au site de LIMoges.

MACHINE_PARAMETREE

21 à 26 Machines paramétrées (10 maxi)

MAC_OMP_IGNOREE

21 à 26 Code de la machine OMP à ignorer dans les traitements. 25 machines maxi

Recherche de la correspondance machine OMP / VOLUPACK sur le TSC 601 si la recherche sur le TSC 600 n'a pas abouti.

Prise en compte des déclarations de production par saisie codes barres

TRACE_DETAILLE

Mode d'enregistrement dans le fichier trace comportant le détail de chaque enregistrement créé

La seule présence de cette note produit son effet. Pas de paramétrage au caractère 21.


Interface MIDATA

Interface MIDATA fab_ond_integre

Cliquez ici pour accéder au site Internet de PCTOPP avec la description des fichiers.

Certaines zones de ces fichiers ne sont pas traitées par VoluPack.

Valeurs numériques

1 | Nombre de minutes à retirer à la plus petite heure de début du poste et à ajouter à la plus grande heure de fin du poste pour obtenir l'intervalle de validité des enregistrements 1, 3 et 4
2 | Nombre de jours d'écart pour distinguer 2 mariages Valeurs par défaut : 10

Options triées

O10

Ne prendre en compte que les 10 premiers caractères du code composition PCTOPP

Le 11ième n'est en fait qu'un indicateur de présence de colle RH.

Oas

Prise en compte des temps d'arrêts en secondes

Zone 12, caractères 228 à 231

Oca

Prise en compte des codes arrêts long de PCTOPP

Concaténation des zones 12 et 13 du descriptif des transferts MIDATA

Occ

Correspondance conception VP-PCTOPP

Inscription dans l'info_c 332, char30 de la conception

Ocm

On remplace le numéro de mariage PC_TOPP par une correspondance VoluPack pour éviter la gestion d'inter-mariage

Oco

On utilise la cadence objectif plastique p_ss.ss_txp

Ocp

Contrôle de la validité de plage de l'enregistrement poste

Ode

Permet de ne pas intégrer les déchets onduleuse lorsque l'on intègre les données onduleuse (option Odo).

Odm

Pour les machines de type jonction, division des zones suivantes par le nombre de morceaux

y1_nb_pf_plaq_ond

y1_nb_pf_plaq_ent

y1_qte_pf_ent

y1_qte_pf_sor

y1_qte_pf_gache

y1_qte_pf_sor_pre

Le type de jonction est paramétré dans des notes commençant par TYPE_JON_NB_MORCEAUX

Odo

Intégration de données spécifiques à l'onduleuse

Zones 34.1 à 34.7

Zones 34.8 à 34.14

Zones 34.15 à 34.214.15 à 3

Zones 34.22 à 34.28

Zones 34.29 à 34.34

Zones 34.35 à 34.37

Voir les 2 notes commençant par TYPE_DECHET ainsi que la note PREFIXE_PAPIER

Ofm

Initialiser la date de faction d'un mariage par la zone 2 du fichier PC-TOPP

(sinon la date de début de faction est la date de début du mariage).

Ogm

Utilisation de 20 gâches en lieu et place de la gâche totale

Zone N° 22 -> Nombre de PF (emballage) gâchés sur cette machine

Position 105 à 110 dans fichier PC_TOPP

Ome

On remplace le code matricule par le code employé

Opa

Gestion des papiers pré-imprimés

Récupérer le code papier VoluPack correspondant au code papier pré-imprimé PCTOPP.

Si la recherche actuelle du code papier échoue, effectuer la recherche sur code AFNOR.

Opi

Ne pas intégrer les données des papiers (ni prévues ni réelles)

Opl

On travaille en environnement plastique données Extrudeuse

Si cette option est activée et que la longueur de coupe majorée est supérieure à 9999, la quantité de plaques est divisée par 100 et la longueur de coupe est remplacée par la longueur de coupe majorée.

La longueur de coupe majorée est stockée dans la valeur numérique 2 du TSC 51C de la ligne de commande.

Opp

Contrôle de la présence poste dans fab_midat2

Ops

Annulation des postes supprimés dans PC-TOPP

Osp

(sp = sans préfixe) Permet de ne pas préfixer le code papier par XPAP lors de la récupération des informations du MIDATA.

Cette option ne peut pas cohabiter avec la note PREFIXE_PAPIER

Otp

La table temp_midata_global est présente physiquement

Fin des options triées

Valeur alpha 2

Caractères 1 à 60

Nom du fichier à importer

Valeur alpha3

Caractère 1 | Intégration enregistrement type 0 et 1 pour mise à jour de la table fab_midata1 (table commande) ou fab_tra_of_fac (O/N, O par défaut)
Caractère 2 | Intégration enregistrement type 2 pour mise à jour de la table fab_midata2 (table faction) (O/N, O par défaut)
Caractère 3 | Intégration enregistrement type 3 pour mise à jour de la table fab_midata3 (table de pointage du personnel) (O/N, O par défaut)
Caractère 4 | Intégration enregistrement type 4 pour mise à jour de la table fab_midata4 (table arrêts) ou fab_ond_arret ou fab_tra_arret (O/N, O par défaut)
Caractère 5 | Intégration enregistrement type 5 pour mise à jour de la table fab_midata5 ou fab_ond_arret ou fab_tra_arret (O/N, O par défaut)
Caractère 6 | Intégration enregistrement type 6 pour mise à jour de la table fab_midata6 ou fab_ond_mar (O/N, O par défaut)
Caractère 7 | Intégration enregistrement type 7 pour mise à jour de la table fab_midata7 ou fab_ond_mar (O/N, O par défaut)
Caractère 8 | Intégration enregistrement type 8 pour mise à jour de la table fab_midata8 ou fab_ond_rebut (O/N, O par défaut)
Caractère 9 | Non traité
Caractères 10 à 11 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 12 | Ancienne méthode (O/N, N par défaut) Peut aussi prendre la valeur de 2, ce qui est pris pour un O.
Caractères 13 à 15 | Code du site de production pour une gestion des codes arrêts par site. Voir les notes commençant par CODE_ARRET dans le paramètre TTR Tableau de bord du multisite
Caractères 16 à 18 | Paramétrage du code phase passage (PAS, ROU) PAS par défaut
Caractère 19 | Limiter la recherche de la correspondance des machines PCTOPP/VSW au site de production paramétré (O/N, N par défaut) - Tableau de bord du multisite

Valeur alpha 4

Caractère 1 | Contrôle sur l'existence de l'OF dans VoluPack (O/N, O par défaut)
Caractères 2 à 4 | Correspondance entre le code déchet blanc de PC_TOPP et un code déchet VOLUPACK Obligatoire si alpha3[1] = O
Caractères 5 à 7 | Code de la pause Casse-croûte - voir remarque en bas de ce document Le code doit exister en tant que paramètre de type TTR si alpha3[5] = O
Caractères 8 à 10 | Groupe de la pause Casse-croûte - voir remarque en bas de ce document S'il est renseigné, le code doit exister en tant que paramètre de type FAR si alpha3[5] = O
Caractères 11 à 13 | Code micro-arrêt - voir remarque en bas de ce document Le code doit exister en tant que paramètre de type TTR si alpha3[4] = O
Caractères 14 à 16 | Groupe micro-arrêt - voir remarque en bas de ce document S'il est renseigné, le code doit exister en tant que paramètre de type FAR si alpha3[4] = O
Caractère 17 | Contrôle de l'existence du code employé N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 18 | Contrôle de l'existence du code qualité planifiée N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 19 | Contrôle du grammage planifié à zéro N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 20 | Contrôle du métrage planifié à zéro N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 21 | Contrôle de la rogne planifié à zéro N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 22 | Contrôle de la durée prévue de la faction à zéro N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 23 | Contrôle du grammage réalisé du mariage à zéro N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 24 | Contrôle existence du code papier N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 25 | Contrôle existence du code arrêt N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 26 | Contrôle durée arrêt non vide N pas de contrôle, B Bloquant (par défaut), W Warning non bloquant
Caractère 27 | O Activation de la prise en compte des machines fictives N Fonctionnement normal (par défaut) Lorsqu'un code machine PC-TOPP a plusieurs correspondances dans le fichier machine volume (TSC 600/601) on prend en priorité la machine appartenant à la gamme du PF, sinon on prend la machine dont la priorité est la plus forte. Plus la valeur saisie est petite, plus la priorité est élevée. Par défaut, la priorité est placé à 9999 si elle n'est pas renseignée. Les codes machine PC-TOPP et VSW sont différents. La conversion est faite par les TSC 600 et 601 : TSC-600 ic-char30 doit contenir le code machine PC-TOPP (machine OND) TSC-601 ic-char30 doit contenir le code machine PC-TOPP (machine PLQ)
Caractère 28 | Contrôle sur le métrage réalisé de la faction (O/N, O par défaut)
Caractère 29 | Contrôle de la valeur du nombre de plaques en sortie machine (O/N, O par défaut) (zone mi1_qte_sort_real)

Notes triées

FIC_EXPORT_CL_DATA | 21 à 60 Nom du fichier d'export CL-DATA
MACH_A_EXCLURE_PR | 21 à 60 Code machine à exclure de l'intégration des temps réels de fabrication
NB_MOIS_CTRL_DATE | Permet de contrôler la date de poste 21, 22 Nombre de mois (à soustraire du mois courant pour obtenir la date limite) S'il existe une date de poste antérieure à la date limite calculée, alors on sort du programme sans traiter le fichier. La date limite est déterminée à partir de la date courante moins le nombre de mois paramétré.
NUM_OF_A_EXCLURE_PR | 21,26 Numéro d'OF à exclure de l'intégration des temps réels de fabrication
OF_SPECIAUX | 21,30 OF spéciaux : ces OF sont récupérés tels quels sans aucune vérification. Utilisé par exemple pour des échantillons.
PARAMETRAGE_PLAGE | 21 Code plage MIDATA. Obligatoire, Libre 22 Code plage VOLUME. Obligatoire 1 / 2 / 3 / 4 si #CF ATL alpha3[17] est différent de O J / M / A / N si #CF ATL alpha3[17] = O Seuls les codes plages MIDATA différents des codes plages VOLUME doivent être paramétrés. Le type dutilisation de la plage horaire est défini dans le #CF ATL alpha3[17] : Exemples si #CF ATL alpha3[17] est différent de O PARAMETRAGE_PLAGE J1 PARAMETRAGE_PLAGE M2 PARAMETRAGE_PLAGE A3 PARAMETRAGE_PLAGE N4 PARAMETRAGE_PLAGE S4 si #CF ATL alpha3[17] = O PARAMETRAGE_PLAGE JJ ==> Inutile PARAMETRAGE_PLAGE MM ==> Inutile PARAMETRAGE_PLAGE AA ==> Inutile PARAMETRAGE_PLAGE NN ==> Inutile PARAMETRAGE_PLAGE SN
POSTE_APRES_MIDI | Plage horaire du poste APRES MIDI (A) 21,24 Début de la plage (le programme divise par 100) 30,33 Fin de la plage (le programme divise par 100)
POSTE_JOUR | Plage horaire du poste JOUR (J) 21,24 Début de la plage (le programme divise par 100) 30,33 Fin de la plage (le programme divise par 100)
POSTE_MATIN | Plage horaire du poste MATIN (M) 21,24 Début de la plage (le programme divise par 100) 30,33 Fin de la plage (le programme divise par 100)
POSTE_NUIT | Plage horaire du poste NUIT (N) 21,24 Début de la plage (le programme divise par 100) 30,33 Fin de la plage (le programme divise par 100)
PREFIXE_PAPIER | 21,25 Préfixe du papier. 5 maximum. Fonctionne en désactivant l'option -Osp
QUALITE_COMPO_REELLE | 21,23 Qualité autorisée pour la recherche de la composition réelle 10 maximum
_SUP_REQ_PAP_AFNOR | 21,60 Supplément de requête sur la table mat pour la recherche des codes papiers par le code AFNOR
TYPE_DECHET_MAR | 21 à 23 Type des déchets pour le mariage (6 maximum) Contrôle existence dans paramètre TMT Voir option -Odo
TYPE_DECHET_OF | 21 à 23 Type des déchets pour l'OF (7 maximum) Valable aussi bien pour le premier que le deuxième OF Contrôle existence dans paramètre TMT Voir option -Odo
TYPE_JON_NB_MORCEAUX | 21, 23 Codification du type de jonction pour la division par le nombre de morceaux On peut créer 20 notes. Option Odm nécessaire.

Fin des notes triées

Remarques

Codes et groupes arrêts et casse-croûte

Il faut saisir les codes arrêts et casse-croûtes (alpha4[11,13] et alpha4[5, 7]) dans le paramètre TTR en alpha4[4,15].

Dans le cas dune société multisite, avec des codes arrêts pouvant différer suivant les sites, il faut paramétrer le code arrêt spécifique dans les notes commençant par CODE_ARRET_XXX dans le paramètre TTR.

Exemples

CODE_ARRET_ST1 ARR121

CODE_ARRET_ST2 PAN130

Il faut saisir les groupes micro arrêts et casse croûtes (alpha4[14,16] et alpha4[8,10]) dans le paramètre FAR.

Le code de la famille d'arrêt (FAR) est paramétré dans le TTR en alpha4[1,3].

Il faut saisir la conversion du code arrêt PC-TOPP dans le paramètre TTR en alpha4[4,15].

Il faut saisir les codes employés (correspondance code équipe) dans la table emp.

Intégration PR Transfo

Mettre en place le paramétrage #CF CAR afin davoir les suppléments de requête sur les différents types darticles.

Exemples

CLIENTNOMENCLATURE #SOC

SUPREQREFARC and mp_code[1,1] = "N"

SUPREQREFIMP and mp_code[1,1] = "I"

SUPREQREFPRE and mp_code[1,1] = "Y"

SUPREQPF and mp_code[1,1] = "P"

SUPREQPAL and mp_code[1,4] = "XPAL"


Export Direct Planning

Import des données de Direct Planning export_dpl

Ce programme permet d'importer les données provenant de Direct Planning V1.

Il est obsolète. Utilisez plutôt la version compatible Direct Planning 2.

Options

Oar | Demande d'arrêt du programme (si celui-ci tourne en continu).
Ocd | Conserver les fichiers de données (ne supprime pas les fichiers d'export de Direct Planning).
Of0 | Ne pas prendre en compte fab0 pour la recherche du composant. Le rechercher sur la ligne de commande
Oun | Le programme ne fait qu'une seule boucle de traitement.

Valeur alpha 2

Caractères 1 à 4

Délai d'attente entre chaque boucle de traitement (en minutes)

Caractère 5

Numéro d'entité pour l'OF dans la structure Direct Planning (de 1 à 5)

Caractère 6

Numéro de ressource indiquant la machine dans la structure Direct Planning (de 1 à 5)

Caractère 7

Méthode de calcul de la quantité planifiée sur le prévu :

1 La quantité planifiée représente celle à planifier, que l'on aura divisé par le nombre de tâches identiques.

2 La quantité planifiée est calculée en fonction celle à planifier et des durées de tâches, temps prévu de réglage et passage.

3 Récupération d'une zone libre de Direct Planning

Caractère 8

Zone libre de Direct Planning représentant cette quantité planifiée (de 1 à 5).

Notes

DELAI_TACHE_DEBUT | 21 23 Les tâches dont la date de début est antérieure à la date du jour moins le nombre de jours indiqué sur cette note ne sont pas traitées Exemple DELAI_TACHE_DEBUT 365 On exclut les tâches dont la date de début date d'un an et plus.
DELAI_TACHE_FIN | 21 23 Les tâches dont la date de fin est antérieure à la date du jour moins le nombre de jours indiqué sur cette note ne sont pas traitées
FIC_LCK_EXP_GEN | 21 60 Nom du fichier de verrouillage général La présence de ce fichier empêche le lancement du programme en simultané.
FIC_LCK_EXP_VSW | 21 60 Nom du fichier de verrouillage VSW (VoluPack) Empêche Direct Planning de travailler en parallèle sur ce fichier.
FIC_LCK_EXP_DPL | 21 60 Nom du fichier de verrouillage Direct Planning Empêche VSW (VoluPack) de travailler en parallèle sur ce fichier.
FIC_NOM_EXP_TASK | 21 60 Nom du fichier des tâches exportées de Direct Planning vers VoluPack
FIC_NOM_EXP_LINK | 21 60 Nom du fichier des liens exportés de Direct Planning vers VoluPack
FIC_NOM_EXP_ARR | 21 60 Nom du fichier d'arrêt pour interrompre la scrutation
FIC_REP_EXP | 21 60 Nom du répertoire contenant les fichiers


Saisie des lots industriels

Saisie des lots industriels lot_industriel

Ce programme est opérationnel à partir de la V.4.0.157.2.

Permet la création/modification des lots industriels internes ou fournisseurs.

Remarques

• L'option de gestion des lots industriels doit être activée (PRO 13)

• Un lot industriel interne se caractérise par un site de production, le code fournisseur société #SOC et un code article de type produit fini (P) ou semi-fini (S). L'option Olf ne doit pas être mise en place (par défaut, on saisira donc un lot industriel interne).

• Un lot industriel fournisseur se caractérise par un site de production, un code fournisseur et un code article de type matière (M).
L'option Olf doit être mise en place.

• Par défaut, le site de production est initialisé par le code usine rattaché à l'utilisateur courant.

Tableau de bord du multisite

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_SIT | Caractères 3 et suivants : site de production Exemple : -N_SIT[s0_site_prod]
-N_FOU | Caractères 3 et suivants : code fournisseur Exemple : -N_FOU[mp_fou]
-N_ART | Caractères 3 et suivants : code article Exemple : -N_ART[s0_prod]
-N_LOT | Caractères 3 et suivants : numéro de lot Exemple : -N_LOT[s0_lot]

Options

Oco | Consultation seule (seul le menu Interrogation sera accessible si cette option est mise en place.
Olf | Saisie des lots industriels fournisseurs

Notes

_SUP_SQL_CONTROLEUR

21,60 Complément de sélection pour la recherche des contrôleurs (utilisateurs, type de paramètre USE)

Paramètres nécessaires

USE A1[9,11]

Code usine associé à l'utilisateur (correspond à un type de paramètre SIT) - Tableau de bord du multisite

Ce site de production est obligatoire et sera utilisé pour créer et/ou rechercher les lots industriels

SLI

Statut du lot industriel

SSL A1[1,3]

Sous-statut du lot industriel

SSF

Stade du produit semi-fini

Programmes impactés

Génération des dossiers

Permettre la création automatique des produits semi-finis à la génération des dossiers, à partir d'un code statut de semi-fini accessible sur la saisie des formules.

Pas de paramétrage à mettre en oeuvre.

L'option de gestion des lots industriels doit être activée (PRO 13).

Principe de fonctionnement

• Le produit semi-fini est créé si le code statut de semi-fini est renseigné sur la formule (ul_ssf).

• Le code produit semi-fini est construit de la façon suivante :

o Si la ligne de formule (matière, opération ou sous-traitance) est une ligne globale :
Code produit de l'entité concaténé avec le code statut du semi-fini (par défaut)

o Sinon, si la ligne de formule (matière, opération ou sous-traitance) est une ligne rattachée à une ligne de référence multiple : Code produit de la ligne de référence multiple concaténé avec le code statut du semi-fini

Saisie des bons de réception

Permet la saisie du lot industriel rattaché à l'article en cours.

Remarques

• L'option de gestion des lots industriels doit être activée (PRO 13).

• La saisie du lot industriel est accessible et obligatoire si l'article en cours de réception est géré au lot industriel (mp_param 48 = O)

Paramétrage

1) Note PARAM_LCT_LOT_INDUS : 21,26 Type et code du paramètre de lancement de la saisie des lots industriels.

Ce paramétrage est obligatoire si la gestion des lots industriels est activée.

Il permet l'accès à la saisie des lots industriels en création / modification.

2) USE A1[9,11] Code usine associé à l'utilisateur (correspond à un paramètre de type SIT)

Ce site de production, obligatoire, est utilisé pour créer / rechercher les lots industriels.

Saisie des mouvements de stocks

Permet la saisie les informations de gestion des lots industriels.

Principe de fonctionnement

• L'option de gestion des lots industriels doit être activée (PRO 13).

• L'accès à la saisie du lot industriel saisi sur le mouvement de stock est possible par l'action Détail (F8).

• Les nouvelles zones accessibles de stk0 sont :

o Site de production (s0_site_prod)

o Numéro de lot industriel (s0_lot_indus)

o Statut du produit semi-fini (s0_ssf)

o Date/Heure de début (s0_date_deb)

o Date/Heure de fin (s0_date_fin)

Paramétrage

1) Note PARAM_LCT_LOT_INDUS : 21,26 :Type et code du paramètre de lancement de la saisie des lots industriels.

Ce paramétrage est obligatoire si la gestion des lots industriels est activée.

Il permet l'accès à la saisie des lots industriels en modification (F8).

2) USE A1[9,11] Code usine associé à l'utilisateur (correspond à un paramètre de type SIT)

Ce site de production, obligatoire, est utilisé pour rechercher les lots industriels.

Visualisation des

mouvements de stocks

profils de stock

Permet de visualiser les informations de gestion des lots industriels.

Nouvelles zones accessibles (nouvelles zones de la table stk0)

s0_lot_indus Numéro de lot industriel

s0_date_deb Date de début

s0_heure_deb Heure de début

s0_date_fin Date de fin

s0_heure_fin Heure de fin

s0_ssf Code statut du produit semi-fini

libc_s0_ssf Libellé court

libl_s0_ssf Libellé long

s0_site_prod Code site de production

libc_s0_site_prod Libellé court

libl_s0_site_prod Libellé long

L'heure est considérée comme une zone numérique, le point indiqué dans le format sera automatiquement remplacé par h (heure).

Exemple : Si le format est &&.&&, la valeur 05.41 sera remplacée par 05h41 dans la visualisation.


Déclaration de production

Pour accéder au nouvel écran de saisie, il est nécessaire d'activer l'option Omp.

Déclaration de production en création de palettes

Lors de la déclaration de production en création, une fois que la première palette est saisie, l'utilisateur peut dupliquer le contenu de celle-ci sur toutes les autres via la touche de fonction F3.

La duplication fonctionne uniquement sur les palettes non initialisées par une quantité.

Souvent, lors de la déclaration de production, toutes les palettes sont identiques sauf la dernière.

L'utilisateur peut modifier si nécessaire la dernière palette une fois lancée l'action Recopie première palette.

Déclaration de production en modification de palettes

Rappel :

Pour pouvoir modifier la déclaration de production, l'utilisateur doit saisir -1 dans la zone Nombre de palettes à créer.

Il accède à l'écran de modification de la déclaration de production de la FBI en cours.

Il peut modifier la déclaration de production de toutes les palettes produites pour cette FBI, si celles-ci n'ont qu'un seul mouvement de stock du type paramétré en A2[1,3] du paramètre de lancement.

Lorsque l'utilisateur est en modification, il peut annuler une palette via la touche de fonction F2.

S'il confirme son choix d'annuler la palette, alors la quantité de celle-ci passe à 0.

Lors de la validation, elle sera annulée.

Saisie spécifique des entrées en production des palettes pour le plastique.

Le flashage du CAB remplit automatiquement les champs de la saisie manuelle.

Création d'un conteneur spécifique par colis contenant le numéro de la palette et le numéro de colis.

Lors du flashage du CAB, les valeurs se positionnent automatiquement dans les champs.

Structure du code-barres :

1,8 Numéro de commande

9,11 Numéro de ligne de commande

12,14 Numéro de la palette

15,17 Nombre de colis

18,21 Quantité par colis

Il y a un conteneur généré par colis. Le 1er colis est le 001 et le dernier 008.

Structure du conteneur généré :

1,2 PF

3,10 Numéro de la commande

12,14 Numéro de ligne de commande

16,18 Numéro de palette

20,22 Numéro de colis

Affichage des entrées prévisionnelles rattachées à la ligne de commande de fabrication ou à la séquence de la ligne de commande de fabrication.

Seules les entrées prévisionnelles dont le type de mouvement est présent dans les TMV paramétrés dans ces notes sont affichées.

Pour chaque entrée prévisionnelle, une quantité fabriquée peut être saisie.

La somme des quantités fabriquées saisies doit être égale à la quantité fabriquée déclarée.

Chaque entrée prévisionnelle dont une quantité fabriquée est saisie déclenchera l'annulation de celle-ci et la création d'un reliquat si la quantité fabriquée saisie est inférieure à la quantité de l'entrée prévisionnelle.

La quantité fabriquée de la ligne de commande ou de la séquence de la ligne de commande sera mise à jour avec la quantité fabriquée déclarée.

Déclaration de production qte_prod

Fonctionnalités

Déclaration de production par code à barres

Déclaration de production en saisie manuelle

Déclaration de montage

Choix du modèle d'étiquette

Le modèle d'étiquette est indiqué en MDO A1[1,8].

Le code du paramètre MDO est recherché en priorité dans l'ordre suivant :

1 - TSC _ET de la ligne de commande

2 - TSC 250 du PF

3 - MDO du client

4 - MDO ETS en dur

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro de commande - numéro de ligne de commande ATTENTION : incompatible avec l'option Opd Exemple : -N[lc_num|lc_lig+&&&]
-N_RGT | Caractères 3 et suivants : Lieu de rangement 1 | Lieu de rangement 2 Exemple : -N_RGT[s0_rgt1|s0_rgt2]

Valeurs numériques

1

Niveau de clôture du dossier (15 par défaut)

Option particulière

-H

Option à positionner au niveau du menu (men.4gl).

Gestion par lecteur radio

Il faut désactiver les options Ocs, Ofd et Osm et activer les options Omt et Ova.

Options triées

O1f

N'avoir qu'un seul flot d'étiquettes (actuellement, il y a un flot par ligne de saisie de qte_prod)

O22

Dans le cas d'une saisie par code à barre (l'option Osm n'est pas activée), alors on utilise un code à barres de 22 caractères qui inclus la séquence. Sinon c'est un code à barre de 19 caractères.

O24

Gestion des codes à barres sur 24 caractères

Sans cette option, les codes sont gérés par défaut sur 19 caractères.

Avec cette option, on va regarder la note LONG_CARAC_OPTION_24

Si la note est absente, le code à barres est censé faire 24 caractères.

Si la note est présente, la longueur du code à barres est celle qui est paramétrée dans la note.

Oac

Par défaut, le lot des mouvements de stock de sortie de plaque de carton est initialisé avec le lot de fabrication.

Cette option permet de l'initialiser avec le lot d'achat.

Oad

Gestion des décimales dans le picking en déclaration de montage

Oae

Annulation des mouvements de stocks liés au conteneur lors d'une modification de l'entrée en production

Pour les articles gérés à la palette identifiée, cette option permet de modifier une entrée en stock en production même si elle a été mouvementée mais pas expédiée.

Si la modification est confirmée, tous les mouvements de stocks seront annulés et l'entrée en production sera recréée.

Oal

En déclaration de production CAB, accéder à la saisie de l'emplacement

Ne fonctionne pas avec la gestion CAB menu -H

Oar

Annulation des réserves au solde de la fabrication.

Option supprimée, remplacée par mp_param[38]

Oas

Droit aux synchrones et aux asynchrones

Si cette option et l'option One non spécifiées, droit aux asynchrones uniquement

Oat

Affichage Tolérance quantité de la FBI

Oca

Gestion du cartonnage

Ocd

Dans le traitement de tâche de fond (option Otf), permet, si elle est renseignée, de forcer la date du mouvement d'entrée avec la date cb_datim_acq_cab de la table cab_production.

Voir le paragraphe Alimentation depuis la table cab_production dans volupalette.

Oce

Message de confirmation avant l'édition des étiquettes

Ocf

Désactivation de la gestion du solde des cadencements de fabrication

Ocn

Permettre lors d'une saisie négative, de réintégrer aussi les consommations des composants (sortie négative)

Ocp

Contrôle de l'existence du numéro de palette dans la table etiqprod

Ocs

Contrôle de saisie (code à barres)

Sur la palette ayant une quantité à zéro ( supposée être la dernière palette ) on pose une question à l'utilisateur, en lui affichant la quantité totale produite.

Il est supposé avoir en main la fiche de la dernière palette sur laquelle est indiquée manuellement la quantité de cette palette, mais également la quantité totale produite.

Il compare alors cette quantité totale produite à l'écran à celle sur figurant sur sa fiche et indique en réponse (O/N) s'il y a égalité ou différence.

S'il y a différence, on alimente un fichier trace d'anomalie, qui sera édité et analysé par un autre service.

Odc

Blocage de la saisie si le dossier est clos au niveau 15

Odf

Date du mouvement d'entrée prévisionnelle égale au délai de fabrication (à la place du délai répondu)

Les options Otr et Orp doivent être activées.

Odp

Désactivation de la saisie automatique du picking des palettes par lieu de niveau 2

Cette saisie de picking ne s'ouvre que si le lieu de niveau 2 correspond à l'état palette VENDABLE.

Ods

Demande systématique de solde à la fin de la saisie

Valable uniquement en mode code à barres.

Pour le mode normal, il faut utiliser l'option Osf.

Oe4

Initialisation de la séquence de commande dans les étiquettes générées

Oec

Entrée en production des cadencement de fabrication de type ligne E (entité ou affiche)

Incompatible avec les options Olc, Omo et Omi

Voir la fiche d'installation

Oen

On imprime une étiquette neutre

Oep

Les étiquettes palettes sont créées et imprimées.

Oes

Les étiquettes palettes créées ne sont pas imprimées.

Cette option nécessite l'option Oep, dont elle restreint la portée.

Oev

Pouvoir générer des étiquettes vrac

Of2

Contrôle de production par codes barres.

Demande d'arrêt du programme en cas de lancement en tâche de fond

Ofd

On demande si l'on veut forcer la date de saisie (par défaut c'est la date du jour)

Ofp

Contrôle de la date par rapport à celle inscrite dans le paramètre TOP de FIN

Ofs

Forçage du contrôle d'insuffisance stock de composant pour le montage

Lors de la déclaration de montage, on contrôle que le stock des composant est suffisant pour réaliser le montage. Parfois, pour les palettes notamment, le stock peut être insuffisant, mais on veux monter quand même, car la consommation réelle est moindre que celle théorique calculée. Dans ce cas, on veut pouvoir forcer ce blocage.

Oft

Entrée en production par codes barres.

Demande d'arrêt du programme en cas de lancement en tâche de fond.

Ogd

Pour les transformateurs (option Oca), contrôle que le dossier de fabrication est bien généré.

Oie

Ignorer la gestion de l'état du lieu 2

Voir aussi la note GESTION_ETAT_LIEU_2 dans volupalette

Oim

Interdire de modifier une palette déjà badgée

Cette option ne doit pas être activée si l'option en tâche de fond n'est pas activée (Otf).

Oin

Interdire la saisie de quantité négative

Ola

Lieux de rangement par défaut associés au produit de la FBI courante

Olc

Entrée en production des cadencement de fabrication de type ligne L

Incompatible avec les options Oec, Omo et Omi

Voir la fiche d'installation

Olk

Pas de verrou sur les FB2

En saisie de BL les commandes FB2 sont verrouillées. Puisque c'est l'entête de commande qui est verrouillée et qu'une commande FB2 peut contenir 20 lignes de commandes.

La première ligne est en livraison alors que la dernière est encore en saisie code barres.

Cette dernière ligne ne peut donc pas être déclarée car le BL verrouille la commande

Ce paramètre permet de résoudre ce problème.

Ome

Mise à jour des entrées prévisionnelles

Voir note commençant par LISTE_TMV_ENT_PRE

Omf

Prise en compte du nombre de morceaux du FEFCO dans le calcul de la quantité de plaques à consommer

Omi

Déclaration de mitraillage

Omo

On traite cette saisie comme un montage (saisie sur ensemble, gestion des gâches (et non plus comme une déclaration de production))

Omp

Saisie manuelle par palette identifiée (nouvel écran)

Nouvelle saisie des entrées en production par palette

Explications

Option sur l'article pour saisir par colis et le poids de la palette

L'article doit être géré en gestion de stock Lots/lieux/Conditionnement

(gestion des conteneurs avec palette identifiée)

Ces options concernent aussi le programme de correction des stocks manuels (maj_stk).

Paramétrage annexe :

#CF CAB A1[14]

mp_param[46]

TSC SPP

Omt

On alimente un fichier trace avec les principales informations effectuées dans la saisie CAB.

Omv

Forçage du déstockage des composants pour le montage sur des magasins gérés en vrac

Les options Omo et Osg doivent être positionnées.

Voir aussi la note _SUP_REQ_MAGASIN

But : Faire des déclarations de montage en automatique à partir de la table cab_production.

La palette que l'on monte ne peut pas être badgée plusieurs fois.

On ne peut pas faire de montage automatique si on trouve du stock sur plusieurs magasins.

On3

On met à jour le lieu de niveau 3 avec la quantité de PF par palette

One

Droit aux synchrones + négoce

Si Oas et One non spécifiés, droit aux asynchrones uniquement

Oop

Annulation des sorties réserves affectées à l'OF père

Le supplément de requête _SUP_REQ_ANN_SR_OF_P est obligatoire.

Op1

Option papeterie

Op2

Sortie des plaques consommées éclatées par lieux de niveau 2

Si cette option est activée, les plaques consommées sont sorties par lieux de niveau 2.

Si la quantité consommée est supérieure ou égale à la quantité totale du lot, la quantité totale du lot est sortie par lieux de niveau 2.

Si la quantité consommée est inférieure à la quantité totale du lot et que le lot a une seule ligne de lieu de niveau 2, la quantité de plaques est sortie du lieu de niveau 2.

Si la quantité consommée est inférieure à la quantité totale du lot et que le lot a plusieurs lignes de lieu de niveau 2, un écran de picking est ouvert afin de saisir les consommations des lieux de niveau 2 à concurrence de la quantité de plaques.

L'abandon de la saisie du picking n'est pas autorisé.

Opd

Cette option n'est opérationnelle que si l'option société [41] est active ou si #CF ATL A1[36] = O.

Lors de la saisie des OF :

Si le produit est monté, on accède à la déclaration de montage.

Sinon on accède à la déclaration manuelle.

Attention : incompatible avec le Ctrl J

Ope

Sortie des plaques sans attendre le solde de la production

Il est nécessaire de désactiver l'option Oqp, qui permet la sortie des plaques au solde de production.

Rappel : les nombres de poses sens laize et coupe sont inscrits dans les CIC N47 et N48.

Opf

Palette filmée

Oph

Prise en compte de la quantité lancée de l'OF et des zones hp_z2 et hp_z4 de l'historique (table hist_pr) pour calculer le prix du mouvement de stock

Opl

Gestion spécifique de l'entrée en production pour le plastique

L'option Osm est obligatoire. mp_param[17] = 2 obligatoirement

+ d'infos

Opm

Permet d'entrer en stock l'ensemble monté même si la FBI saisie est rattachée à elle-même

Opp

Les entrées normales sont valorisées au prix des entrées prévisionnelles.

Si l'entrée prévisionnelle n'est pas trouvée ou à zéro, on prend le coût total de l'OF ramené aux 100 PF

Oq0

Remet systématiquement la quantité badgée à 0 pour obliger la saisie

Uniquement pour les articles cartonniers

Oqp

Permet de saisir la quantité de plaques consommées lors du solde en production

Orb

VoluPalette

Lors du rebadgeage d'une étiquette, on remet à jour le stock sans annuler le mouvement de stock précédent.

On ne génère plus une anomalie de type 5.

L'option Ose est activée automatiquement.

Orc

Remplir la table canal_comm

Ore

Recherche du code ensemble dans les nomenclatures

Orl

Répétition des lieux de niveau 1 et 2 de la ligne précédente

Contrôle du code état (Vendable, Non vendable, A retraiter, A détruire, &) du stock à la déclaration des quantités fabriquées.

Voir notes commençant par TAB_CTRL_LIG_SOLDEE si la ligne de commande commerciale est soldée et par TAB_CTRL_LIG_NSOLDEE si la ligne de commande commerciale n'est pas soldée.

Si l'option -Orl est activée, les lieux de niveau 1 et 2 seront initialisés avec ceux de la ligne précédente.

Orp

Recréation de l'entrée prévisionnelle de fabrication

L'option Otr doit être activée.

Osc

Avec cette option, les sorties composants ne sont pas faites.

Sans l'option, les sorties composants sont faites.

Ose

Remettre à jour les stocks lors du rebadgeage d'une étiquette

Osf

Demande systématique de mise en solde de fabrication (après chaque saisie)

Osg

Aide à la saisie de picking

Avec cette option, on propose directement les quantités à sortir en fonction du nombre d'ensembles.

Osi

Simulation : pas de création de mouvement de stock et pas de modification de la quantité fabriquée sur la ligne de commande

Osm

On utilise le module de saisie manuelle, sinon c'est le module de saisie par code à barres.

Osp

On solde automatiquement la fabrication si la quantité fabriquée est égale ou supérieure à un certain pourcentage de la quantité lancée.

Ot2

Contrôle de production par codes barres

Lancement du programme en tâche de fond

Boucle de traitement sur la table des événements palette.

(incompatible avec les option Osm et Otf

Otf

Entrée en production par codes barres

Lancement du programme en tâche de fond (P3)

Boucle de traitement sur la table des événements palette.

(incompatible avec l'option Osm, saisie manuelle)

Option Ose nécessaire

Otm

Gestion P2P3

Gestion transfert de magasin pour les commandes commerciales

Incompatible avec la déclaration de montage

But : Faire des transferts de magasin en automatique pour des ensembles à partir de la table cab_production.

La palette que l'on monte ne peut pas être badgée plusieurs fois (sauf si elle n'est pas numérotée).

On ne peut pas faire de montage automatique et du transfert en même temps.

Pour faire du transfert, il faut avoir du stock sur un magasin autre que le magasin de transfert.

Voir aussi

A4[17,22]

Note _SUP_REQ_MAGASIN

volupalette A2[1]

Otr

On transforme les entrées prévisionnelles en entrées normales.

Ou2

Contrôle de production par codes barres. Le programme ne fait qu'un seul passage.

Oun

Entrée en production par codes barres. Le programme ne fait qu'un seul passage.

Ouv

Utilisation de l'unité de vente pour calculer le prix du mouvement de stock

Les options Otr et Orp doivent être activées.

Ova

Validation automatique des messages écran.

Cette fonction est utile lorsque l'utilisateur ne voit pas l'écran, par exemple s'il utilise un lecteur code barres hertzien.

Ovq

On ne demande pas la saisie de la quantité par le code à barre, on accepte celle inscrite dans ce code dans le cas d'un ensemble monté.

Valeur alpha 2

Caractères 1 à 3

Type de mouvement pour les entrées en stock

Caractère 4

Paramétrage de la valeur du lot

1 Commande de fabrication + numéro de ligne

2 Commande commerciale + numéro de ligne

Caractères 5 à 7

Lieu de rangement de niveau 1

Caractères 8 à 13

Lieu de rangement de niveau 2

Caractères 14 à 19

Lieu de rangement de niveau 3

Caractère 20

Contrôle de la quantité saisie en remontée manuelle

Le contrôle est fait par rapport à la valeur numérique 1 du TSC 220 de l'article.

B Contrôle bloquant (valeur par défaut)

W Message d'avertissement avec validation

C Fenêtre de confirmation

N Pas de contrôle

Caractères 21 à 23

Type de mouvement de stock pour sortie normale

Caractères 24 à 26

Type de mouvement de stock pour entrée historique outillage

Caractères 27 à 29

Type de mouvement de stock pour sortie historique outillage

Caractères 30 à 34

% de dépassement de fabrication par rapport au commandé (99.99)

Si la quantité fabriquée dépasse la quantité commandée de ce pourcentage, alors le programme demande de confirmer la saisie.

Pour un fonctionnement plus évolué avec mot de passe, voir la note PCT_TOL_QTE_ENT_STK dans le paramètre TOL.

Caractères 35 à 39

Pourcentage de fabrication nécessaire par rapport au lancé pour pouvoir solder (99.99)

Si la quantité fabriquée ne représente pas ce pourcentage de la quantité lancée, alors le programme demande de confirmer la saisie lors du solde de fabrication.

Pour un fonctionnement plus évolué avec mot de passe, voir la note PCT_TOL_QTE_ENT_STK dans le paramètre TOL.

Caractères 40 à 42

Type de mouvement de stock pour entrée en montage

Caractères 43 à 45

Type de mouvement de stock pour sortie en montage

Caractère 46

Mise en place du contrôle sur quantité pour tous les TYC (O/N).

Nécessite alpha2[20] ci-dessus.

Caractères 47 à 49

Type de mouvement de stock pour une sortie normale de plaque

Caractères 50 à 52

Type de mouvement de stock en entrée pour mitraillage

Caractères 53 à 55

Type de mouvement de stock en sortie pour mitraillage

Caractères 56 à 58

Type du mouvement de stock en entrée de réception plaque

Si sortie de plaque au solde de la fabrication (option Oqp), on propose de sortir la quantité réceptionnée au titre de cette fabrication.

Cette nouvelle recherche fonctionne avec le paramétrage du type de mouvement de stock ayant servi à la réception de la plaque.

Valeur alpha 3

Caractères 1 à 6 | Type et code du paramètre de lancement de la consultation des stocks
Caractères 7 à 9 | Nombre de secondes d'attente avant une nouvelle tentative de verrouillage de l'article
Caractères 10 à 12 | Nombre de tentatives de verrouillage de l'article avant annulation de la saisie (1 par défaut)
Caractères 13 à 15 | Lieu 1 de déstockage (pour le montage des PF) Egalement : lieu où l'on prend les plaques à mitrailler
Caractères 16 à 21 | Lieu 2 de déstockage (pour le montage des PF)
Caractères 22 à 27 | Lieu 3 de déstockage (pour le montage des PF)
Caractères 28 à 31 | Délai d'attente en secondes Ce délai correspond à l'attente entre deux boucles de traitement. Par défaut, ce délai est de une seconde. Valable pour l'entrée en production et pour le contrôle de production par codes barres
Caractères 32 à 35 | Délai en minutes pour le contrôle d'un verrouillage long Délai au-delà duquel un article non traité (suite à des verrouillages système) sera marqué comme ayant subit un long lock Valable pour l'entrée en production par codes barres uniquement
Caractères 36 à 39 | Temps d'attente entre deux boucles sur la table cab_production. Temps exprimé en secondes (pour le traitement de contrôle P2).
Caractères 40 à 42 | Type du mouvement de stock d'entrée sur le lot de la FBI (doit être une entrée normale)
Caractères 43 à 45 | Type du mouvement de stock de sortie sur le lot d'origine (doit être une sortie normale)
Caractère 46 | Contrôle du solde de la ligne de la commande commerciale N Pas de contrôle W Warning si la ligne de la commande commerciale est soldée C Demande de confirmation si la ligne de la commande commerciale est soldée B Bloquant si la ligne de la commande commerciale est soldée
Caractère 47 | Contrôle du numéro d'OF saisi par rapport au complément de requête _SUP_REQ_CTRL_SITE Le message est personnalisable dans la note MESSAGE_CTRL_SITE N (par défaut) Non, pas de contrôle W avertissement B bloquant Ce paramètre permet de contrôler le numéro d'OF. Exemple 1 : complément de requête sur cde1.ec_c1 = "XXX" pour contrôler le site de production. Exemple 2 : and ec_num > "07080000" pour contrôler que le numéro d'OF saisi est au moins supérieur à 0708 Tableau de bord du multisite
Caractères 48 à 50 | Code action automatique à créer après le solde de la fabrication (Type de paramètre ASO) Permet de créer en automatique des actions de suivi d'outillage au solde de la fabrication.
Caractère 51 | Contrôle du solde de la ligne de cadencement de fabrication d'une affiche N Pas de contrôle C demande de confirmation du désolde W message en warning B contrôle bloquant
Caractère 52 | Méthode d'initialisation du tableau de picking (F12) 1 Picking automatique sans éclatement de palette (Valeur par défaut) 2 Picking automatique avec éclatement de palette L'option Osg doit être positionnée 3 Picking automatique sans éclatement de palette Le tri se fait sur la date des lots (le plus ancien en priorité).
Caractères 53 à 55 | Type du mouvement de stock des sorties pour éclatement de palette Obligatoire si option Osg et A3[52] = 2. Le type de mouvement de stock doit être une sortie normale.
Caractères 56 à 58 | Type du mouvement de stock des entrées pour éclatement de palette Obligatoire si option Osg et A3[52] = 2. Le type de mouvement de stock doit être une entrée normale.
Caractère 59 | Mode de contrôle du désolde si l'OF est clos N pas de contrôle (valeur par défaut) B contrôle bloquant W contrôle informatif C demande de confirmation

Valeur alpha 4

Caractères 1 à 6

Pourcentage nécessaire de quantité fabriquée par rapport à la quantité lancée pour la demande du solde de fabrication (999.99)

Ce pourcentage est recherché en priorité sur TOL A1[16,21].

Caractères 7 à 9 | Nombre de jours pour la borne inférieure | Vérifier que la date de mouvement saisie pour les entrées est comprise dans une plage paramétrée (+/- n jours par rapport à la date du jour). Si les bornes ne sont pas saisies, il n'y a pas de contrôle.
Caractères 10 à 12 | Nombre de jours pour la borne supérieure
Caractère 13 | Type de contrôle N pas de contrôle (par défaut) B contrôle bloquant W contrôle warning C demande de confirmation

Caractères 14 à 16 | Type de la note qui alimentera la table des notes sur stock (stk0_notes) Voir le paragraphe Alimentation depuis la table cab_production dans volupalette.
Caractères 17 à 19 | Type de mouvement en entrée pour le transfert
Caractères 20 à 22 | Type de mouvement en sortie pour le transfert
Caractères 23 à 25 | Type de mouvement de sortie pour une annulation de l'entrée de la bobine

Notes triées

CODE_NTS_TRACE

21,23 Code note qui permettra d'alimenter une note formatée avec le fichier trace paramétré dans la note FIC_TRACE_P2P3_n

Sera visible dans la visualisation de la traçabilité des programmes (table numéro 28).

CODE_TSC_COM_CNI

21,23 Code TSC sur lequel sera inscrit le commentaire provenant de la table cab_production.

Ce TSC porte sur l'identifiant conteneur de la table conteneur_info.

DIRECT_PLANNING_CFG

21,23 Code du paramètre de configuration du transfert DirectPlanning. Par défaut : DP2.

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

ECART_POURC_QTE_PPAL

21 à 25 Pourcentage d'écart sur la quantité par palette (99.99)

ETIQPROD_IMP

21 à 23 Code imprimante (#LP) pour sortie étiquettes production

24 Imprimante automatique

O Imprimante automatique (pas de choix) Valeur par défaut
Si l'édition des étiquettes est une édition VoluEdit, la valeur O est obligatoire.
En effet, VoluEdit ne permet pas de choisir une imprimante dynamiquement (via l'ouverture de la fenêtre Windows de choix d'imprimante) sauf lorsque l'on est en mode aperçu ce qui n'est pas le cas pour les éditions d'étiquettes issues de la déclaration de production.
On peut néanmoins choisir l'imprimante via la note VE_SOR

N Imprimante non automatique (choix) uniquement pour les éditions standards (ce choix n'est pas actif pour les éditions VoluEdit).

FIC_ARRET

21 à 60 Nom du fichier d'arrêt.

La présence de ce fichier stoppera le déroulement du programme à la fin de sa boucle.

Nom par défaut : qte_prod_arret_demande

Valable pour l'entrée en production par codes barres

FIC_ARRET_P2

21 à 60 Nom du fichier d'arrêt.

La présence de ce fichier stoppera le déroulement du programme à la fin de sa boucle.

Nom par défaut : qte_prod_arret_demande_p2

Valable pour le contrôle de production par codes barres

FIC_LOCK

21 à 60 Nom du fichier de verrouillage Volume Software.

La présence de ce fichier empêche de lancer deux fois le programme.

Nom par défaut : qte_prod_tache_de_fond

Valable pour l'entrée en production par codes barres

FIC_LOCK_P2

21 à 60 Nom du fichier de verrouillage Volume Software.

La présence de ce fichier empêche de lancer deux fois le programme.

Nom par défaut : qte_prod_tache_de_fond_p2

Valable pour le contrôle de production par codes barres

FIC_TRACE_P2P3_n

n est le code environnement de l'application.

21,60 Nom du fichier trace.

Le nom du fichier peut être horodaté grâce aux mots-clés suivants :

%D2% Date du jour au format aammjj

%D4% Date du jour au format aaaammjj

%HM% Heure courante au format hhmm

%HS% Heure courante au format hhmmss

Voir aussi la note CODE_NTS_TRACE.

LIB_QTE_PRODUITE

21 à 47 Libellé de la quantité produite

LIB_ZONE_LIBRE_1

LIB_ZONE_LIBRE_2

LIB_ZONE_LIBRE_3

21,45 Libellé de la zone. (obligatoire sans H ; inutile si H)

Voir les notes ZONE_LIBRE_1, ZONE_LIBRE_2, ZONE_LIBRE_3

LISTE_TMV_ENT_PRE

21,23 Type de mouvement de stock d'entrée prévisionnelle. Utilisé par l'option Ome

Explications

LONG_CARAC_OPTION_24

21,22 Longueur du code à barres. Par défaut : 24

Option O24 obligatoire

MAG_VRAC_MULTI_NIV

Attention : La présence de cette note conditionne l'utilisation de la déclaration automatique de production pour le multi-niveaux.

Si elle est renseignée, les informations ci-après sont obligatoires et seront utilisées pour tous les niveaux inférieurs de la nomenclature multi-niveaux.

Voir aussi

Option Opd

TSC 280

21,23 Magasin (gestion en vrac obligatoire)

24,26 Aire de rangement

MESSAGE_CTRL_SITE

21,60 Message personnalisé pour le contrôle en A3[47] - Tableau de bord du multisite

MVT_CCF_LOG_E_E

Mettre à jour les quantités fabriquées dans la table cde_cad_fab pour certains types de cadencements de fabrication

21,60 Liste des types autorisés pour un transfert type E vers E

La saisie se fait 3 caractères par 3 caractères.

Exemple : GLOIMPAFF

Pour l'entrée en stock d'affiche de type GLO, on veut mettre aussi à jour la quantité fabriquée pour le type IMP et pour les produits les type GLO.

Voir la fiche d'installation

MVT_CCF_LOG_E_L

Mettre à jour les quantités fabriquées dans la table cde_cad_fab pour certains types de cadencements de fabrication

21,60 Liste des types autorisés pour un transfert type E vers L

La saisie se fait 3 caractères par 3 caractères.

Exemple : AFF

Voir la fiche d'installation

MVT_CCF_LOG_L_E

Mettre à jour les quantités fabriquées dans la table cde_cad_fab pour certains types de cadencements de fabrication

21,60 Liste des types autorisés pour un transfert type L vers E

La saisie se fait 3 caractères par 3 caractères.

Exemple : GLOIMP

Voir la fiche d'installation

MVT_CCF_LOG_L_L

Mettre à jour les quantités fabriquées dans la table cde_cad_fab pour certains types de cadencements de fabrication

21,60 Liste des types autorisés pour un transfert type L vers L

La saisie se fait 3 caractères par 3 caractères.

Exemple : GLOI

Voir la fiche d'installation

OPTION_ETIQPROD_IMP

Pour l'édition VoluEdit des étiquettes de production

21,24 Paramétrage sur 2 caractères

li mode listing

ti titre multi-lignes

PARAM_SAISIE_DEVIS

21,26 Type et code du paramètre de lancement de la saisie des devis multi-métiers

Permet, lors de la déclaration de production, de visualiser l'écran de conditionnement du devis multi-métiers (en consultation seule). L'appel à cette fonction se fera par la touche F22 (Shift+F10).

Remarque : L'écran de conditionnement du devis multi-métiers étant compatible avec celui du devis transformateur carton (TC), il est également possible de visualiser cet écran pour un devis créé via le devis TC, mais en utilisant la saisie du devis multi-métiers.

Voir l'option Oac dans la saisie des devis multi-métiers

PHASE_F_S_REQ_FAB1

21,60 Complément de sélection sur fab1 pour la recherche des tâches à terminer

Note cumulative

Lors de la déclaration de production, quand l'utilisateur solde la fabrication (soit par une demande de confirmation, soit en automatique selon le paramétrage), une demande sera faite à l'interface de Direct Planning pour générer un ordre d'avancement à 100% pour toutes les tâches liées à l'OF.

Dans Direct Planning, les tâches seront considérées comme terminées.

QTE_MAXI_PAR_PALETTE

21 à 25 Quantité maximum par palette

_SUP_REQ_ANN_SR_OF_P

21,60 Supplément de requête sur la table stk0 pour l'annulation des sorties réserves affectées à l'OF père. Obligatoire avec l'option Oop.

Exemple

and s0_typ = SR

En solde de fabrication, les sorties réserves attachées à l'OF père (Ex 11040001-1) ne sont pas annulées.

L'option -Oop permet de les annuler.

Un supplément de requête doit être paramétré (note _SUP_REQ_ANN_SR_OF_P sur le paramètre de lancement).

Le mp_param[38] de l'article ne doit pas être à I sinon les sorties réserves ne seront pas annulées.

_SUP_REQ_CAD_FAB_E

21,60 Supplément de requête pour la recherche de cadencements de fabrication de type E

Voir la fiche d'installation

_SUP_REQ_CAD_FAB_L

21,60 Supplément de requête pour la recherche de cadencements de fabrication de type L

Voir la fiche d'installation

_SUP_REQ_CAB_PROD

21 à 60 Supplément de requête sur la table cab_production

Valable pour l'entrée en production par codes barres

_SUP_REQ_CAB_PROD_P2

21 à 60 Supplément de requête sur la table cab_production

Valable pour le contrôle de production par codes barres

_SUP_REQ_CAD_FAB_RES

21,60 Complément de recherche (sur stk0) des mouvements prévisionnels de réserve à annuler lors du solde du cadencement de fabrication

_SUP_REQ_CTRL_SITE

21,60 Complément de requête qui permet de contrôler si l'OF saisi est conforme.

Voir A3[47] pour le type de contrôle - Tableau de bord du multisite

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note est prioritaire sur celle du paramètre USE.

_SUP_REQ_MAGASIN

21,60 Complément de requête sur les magasins utilisés pour la recherche de stocks pour les composants à déstocker

Si ce complément est saisi, on ne prend plus en compte le magasin de déstockage paramétré en A3[13,15].

SUPREQPFSN

21 à 60 Complément de critère de sélection pour la recherche des PF générant des sorties normales lors du solde de la fabrication. Si un supplément de requête a été paramétré, le type de mouvement de stock de sortie normale est obligatoire

_SUP_REQ_PLAQ_CDE5

21,60 Complément de requête sur la table cde5 afin d'exclure certaines plaques

_SUP_REQ_PLAQ_STK0

21,60 Complément de requête pour recherche de plaque en stock, sans le lot

_SUP_REQ_RECH_LIEU2

21,60 Complément de requête sur la table lieu_rgt_e

Ce complément de requête est utilisé par la recherche F7 sur le lieu de niveau 2 dans de la saisie du nombre de palettes par lieu de niveau 2 (voir option Odp)

TAB_CTRL_LIG_NSOLDEE

Etat de stock interdit pour une ligne de commande non soldée

Exemple : VEN interdira tous les états de stock commençant par VEN.

TAB_CTRL_LIG_SOLDEE

Etat de stock interdit pour une ligne de commande soldée

Exemple : VEN interdira tous les états de stock commençant par VEN.

TYPE_MACHINE

21,23 Type de la machine

TYPE_NOTE_BLO_RC

21,23 Type de note de revue de contrat

Un code blocage automatique (039) sera positionné sur la revue de contrat si :

- cette note est renseignée,

- on solde la fabrication,

- la quantité du cadencement est supérieure à la quantité fabriquée totale.

VE_SOR

8,60 Nom de l'imprimante

Voir la note ETIQPROD_IMP

ZONE_LIBRE_1

ZONE_LIBRE_2

ZONE_LIBRE_3

Affichage du contenu d'un TSC, d'une NOTE ou d'une zone de table

Lors de la déclaration de production, certaines données s'affichent en standard.

Selon le métier, d'autres informations peuvent être utile pour l'utilisateur.

Il est possible de paramétrer trois zones pour afficher des données contenues dans des TSC. Ces trois zones sont uniquement en consultation. Si une des zones est paramétrée alors le champ s'affichera.

Les libellés paramétrables de ces 3 zones sont définis dans les notes LIB_ZONE_LIBRE_n.

21,35 Syntaxe pour les TSC (Syntaxe 1) :

TSC_TypeTable_Origine_CodeTSC_CodeZone

37,39 Type de paramètre. Pour afficher le libellé long du par02 si le contenu du TSC fait référence à un code paramètre. (facultative)

41,60 Using. Permet de formater un numérique. (facultative)

21,35 Syntaxe pour les notes (la même que pour les visus) :

NTS_SSS/TTT/NNN*L*

Exemple

NTS_MAT/SPE/ALL*24*

21,35 Syntaxe pour les zones de table : [nomdelacolonne]

52,60 Using. Permet de formater un numérique. (facultative)

Tables accessibles : cde1, cde2, mat et cli

Paramètres associés

TMV A3[33] | Mise à jour de la quantité fabriquée (O/N)
USE | Note _SUP_REQ_LIEU_RGT_E : contrôle des lieux autorisés en saisie


Saisie journalière par salarié

Oom seul : pas beaucoup d'intérêt. Eventuellement en mécanique. Ajout du / avant le code phase.

92040040-1/103851 > 92040040-1/1/03851

Reprise de l'OF ligne n-1 03851 > 92040040-1/1/03851, 3851 > 92040040-1/1/03851

Oom avec O01 Une seule ligne de commande, une seule entité de fabrication (ajout du -1/1)

Cas numéro 1, Première ligne du tableau. Le numéro d'OF saisi doit avoir au moins une longueur de 10 caractères aammnppppp où aa = Année, mm = Mois, n = N° d'ordre de l'OF dans l'année et le mois, ppppp = N° de phase matière

Ce numéro est alors transformé en aamm000n-1/1/ppppp

Exemple 9204004003851 > 92040040-1/1/03851, 92044003851 > 92040040-1/1/03851

Cas numéro 2, Les autres lignes.

On saisit ppppp (Phase matière). Le code phase est complété à gauche par des zéros.

Le numéro est remplacé par (OF ligne (n-1))/ppppp

Exemple n-1 92040040-1/1. n 03851 > 92040040-1/1/03851, n 3851 > 92040040-1/1/03851

On saisit aammnppppp. Le code est remplacé par aamm000n-1/1/ppppp

Exemple 92044003851 > 92040040-1/1/03851 Oom -O01

Of Saisi 05831, OF retourné (numéro ligne n-1)/05831

Of Saisi 92052505831, OF retourné 92050025-1/1/05831

Saisie journalière par salarié sjs

Options Valeurs numériques Valeurs alpha Notes

Opérations de contrôle et de maintenance

Accès à la GED

Options triées

O01

Aide en saisie du numéro d'OF type 1.

Mise en automatique des zéros manquants. Ajout automatique du -1/1

Exemple OF saisi 90105 : 90100005-1/1

Voir aussi Aide à la saisie des OF

O02

Aide en saisie du numéro d'OF type 2. Ajout des zéros manquants

Dans ce cas, ne pas utiliser le paramètre NAC

Voir aussi Aide à la saisie des OF

O03

Aide en saisie du numéro d'OF type 3. Mise en automatique des zéros manquants. Ajout du -1

O04

Aide en saisie du numéro d'OF type 4. Mise en automatique des zéros manquants.

Ajout du - et du /.

Suppose que le numéro de ligne et le numéro de premier niveau soient inférieurs à 10

Voir aussi Aide à la saisie des OF

O06

Aide de type 6 sur OF (saisie de la référence commande + numéro de ligne)

Voir aussi Aide à la saisie des OF

Oao

Aide en saisie du code phase par la saisie d'un code opération (Uniquement en mécanique)

Oap

Aide en saisie du code phase (Voir paramètre #AP) A installer de préférence en imprimerie.

Oat

Affichage du libellé de la commande au lieu du libellé du produit

Obi

Bip à chaque message d'erreur

Ocb

Contrôle bloquant par rapport à la cadence ou au temps standard (+/- 10%).

Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi

Voir valeurs numériques 1 et 2 du paramètre de lancement

En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie.

En mécanique, la priorité du contrôle est donnée au temps de réalisation

Occ

Demande de changement du centre de coût si celui du salarié est différent de celui de l'opération.

Ocd

Contrôle bloquant : la date saisie ne doit pas être supérieure à la date du jour

Ocf

Saisie du coefficient

Och

Avec contrôle du chevauchement d'heure en saisie des temps

Oci

Mise en fonction du contrôle de compatibilité ou d'incompatibilité du TTR saisi

Ocm

Saisie en heures centièmes

Oco

Mode consultation exclusive

Ocp

Copie la phase d'une ligne sur l'autre

Ocr

Création rapide de phase (Reliure principalement)

Quand l'utilisateur entre un numéro de phase inconnu, on cherche un enregistrement dans par02 avec type paramètre = COP et valeur numérique 1 égale au code phase inconnu.

Si on trouve un enregistrement, on aura au niveau de la zone alpha1 le code clé de l'opération à intégrer dans le dossier.

Si on ne trouve pas d'enregistrement dans par02, on passe alors par la création normale de phase

Ocs

Demande de confirmation du temps réalisé

Oct

Possibilité au menu d'incrémenter le mois de contrôle

Ocw

Contrôle non bloquant par rapport à la cadence ou au temps standard (+/- 10%).

Attention, le contrôle se fait après la zone rebut

Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi

Voir valeurs numériques 1 et 2 du paramètre de lancement

En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie.

En mécanique, la priorité du contrôle est donnée au temps de réalisation

Oda

Recherche de l'opération élémentaire avec les dépendances de l'opération prévue dans le cas de la modification de machine (avec Oma Omm)

Ode

Affichage du numéro de devis de la ligne de commande en saisie

Odp

Active la génération du fichier d'interface Direct Planning en mode gestion d'avancement de tâche

Oga

Demande de (ré)génération de l'OF à la première saisie de temps sur l'OF

Aucun temps et aucune saisie matière ne doivent être saisies pour que la régénération soit demandée.

Ogd

Voir #CF EVT.

Ohd

Saisie des temps par début - fin

Ohm

Saisie en heure minutes. A installer de préférence si saisie en heure de début et heure de fin

Oim

Arts graphiques

Om2

Saisie automatique du code machine à chaque opération. Pour un dossier issu d'un devis pro on n'ouvrira la fenêtre que si la machine n'est pas renseignée. (sinon par CONTROL_G)

Oma

Saisie automatique du code machine à chaque opération (sinon par CONTROL_G)

Omm

Demande de confirmation lors de la modification du code machine sur une phase

Utilisable uniquement en imprimerie. Il s'agit d'un paramétrage très puissant facilitant énormément la saisie des temps en imprimerie puisqu' il n'y a plus à se soucier des codes phases lors de la saisie

3 cas se présentent :

- Il s'agit d'une faute de frappe

- Il s'agit d'une modification systématique du code machine sur cette phase

- Il s'agit en fait d'une nouvelle phase. 2 cas se présentent alors :

+ 1L'opération correspondant à la phase saisie a déjà été saisie sur cette nouvelle machine : le code phase existe donc déjà.

+ L'opération correspondant à la phase saisie n'a jamais été saisie pour cette opération : il y a création automatique de la phase.

Omp

Permet de bloquer la modification automatique de la phase, en cas de modification de la machine

Omr

Interdiction de saisir des temps sur une machine de référence

Oms

Modification systématique de la machine de la phase si la machine d'origine est une machine de référence dans le cas d'un changement de machine

Ono

Considère comme une anomalie le fait que la recherche d'une opération élémentaire aboutisse à plusieurs occurrences.

Onp

Création systématique d'une nouvelle phase en cas de modification de machine

Oo1

Aide en saisie d'OF, de type matière (M).

On saisit le code article plutôt que la phase matière et on renvoie le numéro d'OF correspondant.

Oo2

Aide en saisie d'OF, de type matière (M).

On saisit le numéro d'OF + code article et on renvoie le numéro d' OF correspondant.

On peut également saisir le code article seul, on utilise alors la racine de l'OF précédent.

Ooc

Décodage du numéro d 'OF après saisie

Oom

Aide en saisie d'OF, de type matière (M).

On doit combiner cette option avec les O01, O02, O03 ou O04.

Le numéro de phase matière a une longueur égale à 5.

Attention, certaines combinaisons sont incompatibles. A voir en fonction de la demande du client.

Fonctionnement Avec -Oom -O01 : Plus difficile à expliquer qu'à mettre en oeuvre !

Paramétrage classique

Oop

PERIMEE - Saisie du code opérateur

Opb

Si saisie des plages (-Opl) , contrôle bloquant entre les heures de début et de fin saisies et les heures de début et de fin paramétrées pour la faction concernée.

Opc

Pas de copie du numéro d'OF

Opf

Pas de contrôle de l'heure de fin

Cette option permet de saisir des temps totaux et des temps avec heure de début et heure de fin.

Opl

Possibilité de saisir la plage horaire 1 2 3 ou 4

Opm

Pas de gestion des matières consommées. Amélioration des temps de réponse

Opw

Si saisie des plages (Opl), contrôle avec warning entre les heures de début et de fin saisies et les heures de début et de fin paramétrées pour la faction concernée.

Oq2

Deuxième mode de saisie pour l'option Oqe. On saisit la quantité en entrée et cela alimente en automatique la quantité en sortie avec mise à zéro de la gâche.

Oqe

Saisie des quantités en entrée. Imprimerie seule [à vérifier]. Voir dp0

Ora

Saisie des aides par recopie (Voir valeur alpha 2 pour TTR affecté aux aides) et Ota

Ore

Permet de ne pas saisir le code responsable

Orp

En ajout de phase, le calcul de la nouvelle phase tient compte de la racine de la phase saisie et le numéro de phase ajoutée est 1

Si l'option n'est pas présente, le numéro de phase créé est le numéro maxi par rapport à l'OF et l'ajout est de 10.

Exemple

Saisie de phase 3002 avec machine 1300 prévue. La racine de la phase est 30.

Changement de machine 1800 avec ajout de nouvelle phase.

La nouvelle phase sera comprise entre 3003 et 3099.

Ors

Saisie des supplémentaires par recopie

Osa

Demande de confirmation pour validation et clôture automatique de la ligne de saisie

Osq

Saisie d'une quantité obligatoire

Ota

En recopie d'aide (Ora), on prend le TTR du conducteur et non le TTR paramétré.

Otn

Autorise la saisie d'une heure de fin inférieure à l'heure de début (pour les horaires de nuit)

Oto

Obligation de saisir un TTR, et proposition d'un TTR par défaut en fonction du type de l'opération

P TTR par défaut pour une opération de calage

R TTR par défaut pour une opération de roulage

Ots

On prend le TTR du conducteur lors de la recopie pour des suppléants.

Ott

Saisie d'un temps total après l'heure de début qui permet de calculer automatiquement l'heure de fin

Ouc

Modification possible du calendrier employé par la touche F13

Ovc

Vérification par double saisie du code client après la saisie du numéro d'OF.

Fin des options triées

Paramètre NAC utilisé pour faciliter la saisie d'un OF (OF d'aléas par exemple). Incompatible avec l'option O02.

Valeurs numériques 1 et 2

Fourchette pour contrôle de cadence

Exemple

valeur 1 = 10, valeur 2 = 20, cadence standard = 10000

On pourra saisir en saisie de temps entre 9000 et 12000 sans déclencher le contrôle (voir -Ocb -Ocw)

Valeur alpha 2

Caractères 1 à 3 | TTR pour recopie des aides. Toutes les lignes recopiées se verront attribuer ce TTR Ce TTR doit exister et tout son paramétrage doit être correctement effectué
Caractères 4 à 6 | Top d'interdiction de modification ou de saisie d'une ligne de temps postérieure au TOP (on saisit le code paramètre). Il faudra également créer un enregistrement TOP XXX avec : en valeur 1, le mois en cours, en valeur 2, l'année en cours.
Caractères 7 à 11 | Mot de passe pour l'incrémentation du mois de contrôle
Caractères 12 à 14 | Code du paramètre de lancement de la génération de dossiers. Par défaut : GDF
Caractères 15 à 17 | Code du paramètre de lancement de la régénération de dossiers. Par défaut : RGD
Caractères 18 à 20 | TTR pour les supplémentaires. Voir aussi les caractères 1 à 3.

Valeur alpha 4

Caractères 1 à 3

Code difficulté

Notes

CLE_CONFORMITE | Voir Opérations de contrôle et de maintenance
DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
EC_TYC_BUREAU_ETUDE | 21,59 Possibilité de paramétrer jusqu'à 13 TYC de commande permettant l'ouverture en automatique de la saisie d'un code client et d'un numéro de document qui seront affectés à l'OF en cours de saisie
FORMAT_COL_REBUT | 21,26 Format d’affichage de la colonne rebut (6 caractères maximum)
ORDER | Complément de tri pour la recherche des lignes de saisie de temps 6 à 60 Nom des champs sur lesquels on veut trier (table fab2), séparés par des virgules Exemple ORDER f2_hd, f2_of
PARAMETRE_CONFIG_DPL | 21,26 Type et code du paramètre de configuration de Direct Planning Exemple (valeur par défaut) #CF DPL
S_CTL | Voir Opérations de contrôle et de maintenance
SEMP | 6,20 Complément de sélection sur la table des employés
TSC_CONFORMITE | Voir Opérations de contrôle et de maintenance
USING_COL_QUANTITE | 21,28 Format d'affichage de la colonne quantité Actuellement, dans la saisie journalière par salarié, la colonne quantité a forcément 3 chiffres après la virgule, ce qui peut être interprété comme un séparateur de milliers au lieu d'un séparateur décimal. Cette note permet donc de paramétrer le format d’affichage de cette colonne.


Saisie des temps par dossier ou ordre de fabrication

Saisie des temps par dossier ou ordre de fabrication dp0

Options Valeurs numériques Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Paramètres associés

Opérations de contrôle et de maintenance

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de dossier - Numéro de ligne de dossier

Exemple : -N[lc_num|-|lc_lig+&&&&]

Options triées

-Nx | x étant le numéro de dossier à saisir En saisie de temps par dossier, le numéro de dossier sera initialisé avec le numéro de dossier à saisir
O03 | Aide de type 3 sur OF - Voir aussi Aide à la saisie des OF
O06 | Aide de type 6 sur OF - Voir aussi Aide à la saisie des OF
O99 | Prise en compte de l'entité 99 dans la remontée automatique de la quantité dans le niveau supérieur
Oac | Positionnement de l'OF à l'état à recalculer
Oat | Affichage du libellé de la commande au lieu du libellé du produit
Ocb | Contrôle bloquant par rapport à la cadence ou au temps standard (+/- 10%) Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi. Voir valeurs numériques 1 et 2 En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie. En mécanique, la priorité du contrôle est donnée au temps de réalisation.
Ocd | Supprime la mise à jour de cde2.lc_qtefab (quantité fabriquée sur la ligne de commande)
Ocf | En création d'une opération de roulage après saisie du code de l'opération, une fenêtre s'ouvre en automatique. Elle demande la saisie du coefficient ou nombre de poses et propose la valeur 1 par défaut.
Och | Avec contrôle du chevauchement d'heure en saisie des temps
Oci | Mise en fonction du contrôle de compatibilité ou d'incompatibilité du TTR saisi
Ocl | Cache la colonne Libellé de l'écran de détail des opérations
Ocm | Saisie et affichage des temps en heures - centièmes (défaut)
Ocp | Prise en compte pour le taux horaire des taux opération, machine et salarié. (Combinaisons possibles. Le paramétrage se fait dans o0_param[3,5].
Oct | Possibilité au menu d'incrémenter le mois de contrôle
Ocw | Contrôle non bloquant par rapport à la cadence ou au temps standard (+/- 10%) Attention, le contrôle se fait après la zone rebut Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi Voir valeurs numériques 1 et 2 En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie. En mécanique, la priorité du contrôle est donnée au temps de réalisation.
Odm | OPTION SUPPRIMEE Non détail des matières
Odo | OPTION SUPPRIMEE Non détail des opérations
Odp | Active la génération du fichier d'interface Direct Planning en mode gestion d'avancement de tâche Uniquement pour Direct Planning version 1 Non utilisable avec Direct Planning version 2
Odt | OPTION SUPPRIMEE Non détail des temps
Of0 | La quantité réalisée est saisissable et modifiable dans la saisie de production (uniquement en mécanique). Voir alpha2[12]
Of1 | Mise à jour en manuel des quantités fabriquées au niveau 1
Ofc | Saisie possible du code fonction dans la saisie des temps (fab2)
Ohd | Possibilité de saisir heure de début (0 sinon)
Ohm | Saisie et affichage des temps en heures - minutes
Oim | Imprimerie
Oit | On inverse l'affichage des temps dans le détail des temps d'une phase
Old | Imprimerie uniquement. sur une ligne représentant une entité, cette option permet d'afficher le libellé de l'entité (situé dans le devis imprimerie) plutôt que la désignation du produit.
Oll | Saisie largeur, longueur, hauteur, poids et données techniques 1 et 2 en imprimerie
Omc | Le coût matière du niveau est égal au cumul des montants des consommations (F6)
Omr | Interdiction de saisir des temps sur une machine de référence
Omt | Permet de modifier le montant sur l'écran détail matière consommée (accès par le F6 sur l'enregistrement matière de fab0).
Ono | Considère comme une anomalie le fait que la recherche d'une opération élémentaire aboutisse à plusieurs occurrences.
Oo2 | Saisie du code opérateur en saisie des remontées matières
Oop | Possibilité de saisir le code opérateur
Op2 | Prix de revient plastique Visualisation des notes du détail du calcul du prix de revient prévisionnel réactualisé de la composition (Action Prix rvt prév. ou touche CONTROL-P). Le détail du calcul est stocké dans la table note_of avec comme type de note #pr. La même option existe dans pr_midata.
Opb | Si saisie des plages (Opl) , contrôle bloquant entre les heures de début et de fin saisies et les heures de début et de fin paramétrées pour la faction concernée (cf aide sur paramètre FAC)
Opf | Pas de contrôle de l'heure de fin Cette option permet de saisir des temps totaux et des temps avec heure de début et heure de fin.
Opl | Autorise la saisie des plages horaires
Opm | Calcul à partir du prix d'achat moyen pondéré
Opv | Calcul à partir du prix dans l'unité de vente
Opw | Si saisie des plages (Opl) , contrôle avec warning entre les heures de début et de fin saisies et les heures de début et de fin paramétrées pour la faction concernée (cf aide sur paramètre FAC)
Oq2 |
Oqe | Saisie des quantités en entrée. Imprimerie seulement (à vérifier). Lors de la saisie de la quantité, ouverture d'une fenêtre permettant la saisie de Quantité entrée Gâche Quantité sortie avec Qsortie = (Qentrée - Gache) * Nb. de poses Les quantité stockées sont Qsortie saisie Gâche saisie * Nombre de poses Permet de saisir la quantité d'éléments ENTRES dans la machine, la gâche exprimée sur des éléments ENTRES dans la machine et d'en déduire les informations qui seront stockées.
Oqm | supprime le contrôle sur la quantité réalisée saisie en saisie des temps
Ore | Réactualisation du dossier Cette réactualisation est utile uniquement si on a un petit écart entre le produit et le réalisé. Si l'écart est trop grand, changement de cadence, la réactualisation ne voudrait rien dire !!!
Osa | Sauvegarde automatique du code opérateur et de la date saisie et remplissage de ces deux zones lors d'une création de ligne
Osf | OPTION SUPPRIMEE Supprime l'ouverture automatique des fenêtres lors de la saisie
Osm | Somme de toutes les opérations (roulage) où il y a des quantités de saisies.
Ost | Ouverture automatique de la fenêtre de saisie des temps après la zone Code difficulté
Otb | Valorisation des TTR à blanc
Otf | Même fonctionnalité que l'option Ous mais sans la restriction de la famille
Otn | Autorise la saisie d'une heure de fin inférieure à l'heure de début (pour les horaires de nuit). Utilisé pour les chevauchements sur minuit Exemple Saisie 22h00 à 3h00. Dans les fichiers, on a 22h00 à 27h00. Transparent pour l'utilisateur
Oto | Obligation de saisir un TTR, et proposition d'un TTR par défaut en fonction du type de l'opération (P/R) P TTR par défaut pour une opération de calage R TTR par défaut pour une opération de roulage
Ott | Saisie d'un temps total après l'heure de début qui permet de calculer automatiquement l'heure de fin.
Oup | Utilisation des prix de cession (voir paramétrage valeur alpha 3)
Ous | Nouvelle fenêtre de saisie des matières consommées dans la saisie de production par dossier (F6) Cette nouvelle fonctionnalité permet de saisir les quantités de matières consommées par unité de stockage. Elle est limitée à un paramètre sur une famille. Nécessite alpha4[1,10] et FAM alpha4[40,40]
Ouu | Saisie des consommations en quantité UU (F6)
Ovp | On n'utilise pas les zones longueur et largeur pour le calcul du coût
Oxa | Calcul au prix d'achat
Oxb | Calcul au prix selon le type de valorisation
Oxr | Calcul au prix de revient
Oxv | Calcul au prix de vente
Oz1 | Paramètre Remboursable ou non VSW Tours. (zone 1 dans la saisie des remontées matières)

Fin des options triées

Valeurs numériques 1 et 2

Fourchette pour contrôle de cadence

Exemple

valeur 1 = 10, valeur 2 = 20, cadence standard = 10000

On pourra saisir en saisie de temps entre 9000 et 12000 sans déclencher le contrôle (voir Ocb Ocw)

Valeur alpha 2

Caractères 1 à 3 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 4 à 6 | Top d'interdiction de modification ou de saisie d'une ligne de temps postérieure au TOP (on saisit le code paramètre). Il faudra créer également un enregistrement TOP XXX avec en valeur 1, le mois en cours en valeur 2, l'année en cours
Caractères 7 à 11 | Mot de passe pour l'incrémentation du mois de contrôle
Caractère 12 | Saisie de la quantité réalisée autorisée A pour les articles achetés F pour les articles fabriqués [Autre] pour les articles achetés et fabriqués (défaut) L'option Of0 doit être activée.
Caractère 13 | Autorisation de saisir des éléments de plus de 2 niveaux en mode imprimerie (O/N, N par défaut)

Valeur alpha3

Caractères 1 à 3 | Code environnement pour le calcul du réalisé Prix de cession matières Taux horaire des opérations
Caractère 4 | Dans le calcul du prix de cession , que fait-on si aucun prix trouvé ? 1 Renvoie nul et anomalie (ouverture fenêtre) 2 Renvoie zéro et conserve le prix calculé dans lec_mat_p (valeur par défaut)
Caractère 5 | Dans le calcul du prix de cession, que fait-on si plusieurs prix trouvés ? 1 Renvoie nul et affiche une fenêtre d'anomalie (valeur par défaut) 2 Renvoie le premier trouvé 3 Ouverture d'une fenêtre et choix du prix
Caractères 6 à 8 | Code environnement pour le calcul des coûts prévu dans le cas d'une création de phase. Si phase existante et modification du temps prévu, alors le coût prévu est recalculé par une règle de 3 sur le coût initial prévu et le temps initial prévu. (taux moyen pouvant inclure un effectif standard ou un delta d'effectif ...)
Caractères 9 à 11 | Code environnement
Caractères 12 à 17 | Type et code du paramètre de lancement de l'édition des prix de revient

Valeur alpha 4

Caractères 1 à 6 | Type du paramètre de la configuration de tarif utilisé (par défaut #CF TAR)
Caractères 7 à 9 | Code tarif utilisé (par défaut PR)
Caractère 10 | Curseur positionné sur la date dans la nouvelle fenêtre de saisie Par défaut, le curseur est positionné sur le premier champ, le code fournisseur

Notes

PARAMETRE_CONFIG_DPL

21,26 Type et code du paramètre de configuration de Direct Planning

Exemple (valeur par défaut) #CF DPL

Paramètres associés

TTR | Notes commençant par C
TMT | Valeurs numériques 1 et 2 - alpha1[1]
#CF ATL | alpha3[17]
TOP | Valeurs numériques 1 et 2
FAM | alpha4[40]
#AP | Valeur numérique 1
FAC | alpha1[9]
FOR | Formules de calcul


Saisie journalière par bon de travail

Saisie journalière par bon de travail sjo

Valeurs numériques 1 et 2

Fourchette pour contrôle de cadence

Exemple

valeur 1 = 10, valeur 2 = 20, cadence standard = 10000

On pourra saisir en saisie de temps entre 9000 et 12000 sans déclencher le contrôle (voir -Ocb -Ocw)

Options triées

-G | Utilisation du type de gamme
O01 | Aide de type 1 sur saisie OF - Voir aussi Aide à la saisie des OF
O02 | Aide de type 2 sur saisie OF - Voir aussi Aide à la saisie des OF
O03 | Aide de type 3 sur saisie OF - Voir aussi Aide à la saisie des OF
O04 | Aide de type 4 sur saisie OF - Voir aussi Aide à la saisie des OF
Oap | Aide sur saisie du code phase
Ocb | Contrôle bloquant par rapport à la cadence ou au temps standard (+/- 10%). Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi. Voir les 2 valeurs numériques. En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie. En mécanique, la priorité du contrôle est donnée au temps de réalisation.
Och | Contrôle chevauchement heure
Oci | Mise en fonction du contrôle de compatibilité ou d'incompatibilité du TTR saisi.
Ocm | Saisie en heures - centièmes
Oct | Possibilité au menu d'incrémenter le mois de contrôle
Ocw | Contrôle non bloquant par rapport à la cadence ou au temps standard (+/- 10%). Attention, le contrôle se fait après la zone rebut. Attention, le contrôle est effectué si TTR alpha1[28] = O ou si pas de TTR saisi. Voir les 2 valeurs numériques. En imprimerie, c'est l'opération élémentaire qui indique s'il s' agit d'une opération en temps ou en cadence selon la zone saisie. En mécanique, la priorité du contrôle est donnée au temps de réalisation.
Ohd | Saisie des temps par début - fin
Ohm | Saisie en heure - minutes
Oim | Arts graphiques
Oma | Demande de changement de machine automatique
Ono | Considère comme une anomalie le fait que la recherche d'une opération élémentaire aboutisse à plusieurs occurrences.
Oop | Saisie du code opérateur
Opb | Le contrôle de la plage est bloquant
Opf | Pas de contrôle de l'heure de fin. Cette option permet de saisir des temps totaux et des temps avec heure de début et heure de fin.
Opl | Saisie de la plage horaire
Opw | Le contrôle de la plage est en warning (pas bloquant)
Oqe | Saisie des quantités en entrée. Imprimerie seule [à vérifier]. Voir dp0
Otn | Autorise la saisie d'une heure de fin inférieure à l'heure de début (pour les horaires de nuit). Utilisé pour les chevauchements sur minuit. Exemple Saisie 22h00 à 3h00 ---> Dans les fichiers 22h00 à 27h00. Transparent pour l'utilisateur
Oto | Obligation de saisir un TTR, et proposition d'un TTR par défaut en fonction du type de l'opération (P/R)
Ott | Saisie d'un temps total après l'heure de début qui permet de calculer automatiquement l'heure de fin

Fin des options triées

#P TTR par défaut pour une opération de calage

#R TTR par défaut pour une opération de roulage

Valeur alpha 2

Caractères 1 à 3 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 4 à 6 | Top d'interdiction de modification ou de saisie d'une ligne de temps postérieure au TOP (on saisit le code paramètre) Il faudra créer également un enregistrement TOP XXX avec en valeur 1 : le mois en cours en valeur 2 : l'année en cours
Caractères 7 à 11 | Mot de passe pour l'incrémentation du mois de contrôle

Paramètres associés

GAM | Seule la présence du code paramètre est testée lors de la saisie
TTR | valeurs numériques 1 & 2 alpha1[17] alpha1[23] alpha1[31]


Saisie journalière par compagnon

Saisie journalière par compagnon stpai

Options

-Ohm | Saisie en heure - minutes
-Otn | Heures de nuit (possibilité de saisir un temps de fin < au temps de début)

Remarque Les temps sont toujours saisis en heure - début , heure - fin

Valeur alpha 2

Caractère 1

Type de salarié A Aide (par défaut)
S Supplémentaire

Remarque Seuls les TTR ayant N dans le caractère 29 de la valeur alpha 1 sont acceptés en saisie


Génération du planning prévisionnel des compagnons

Génération du planning prévisionnel des compagnons gen_tai

Valeur numérique 1

Nombre de jours à ajouter pour le calcul de la date de début de la période.

Exemple La période commence à j + x

j Date du traitement

x Nombre de jours

Attention x ne peut être à zéro

Valeur numérique 2

Durée de la période à traiter (en nombre de jours)

Exemple La date de fin de période est égal à la date de début de période plus le délai

Remarque

Pour le calendrier, voir les paramètres

  • CAL

  • MOI

  • SEM

  • JOU

Pour la faction, voir le paramètre FAC


Intégration des temps des compagnons

Intégration des temps des compagnons ITA int_tai

Voir documentation complète dans rco_pm.doc

Valeur numérique 1

Delta négligeable pour le rapprochement entre les heures de début et de fin du conducteur et de l'aide (en minutes)

Exemple 6.00 minutes

Valeur numérique 2

Delta négligeable pour le contrôle de la continuité des temps des conducteurs (en minutes)

Exemple 6.00 minutes

Options

-Ohm

Edition des anomalies. Le format des temps est en heures minutes (par défaut il est en heure centièmes)

Valeur alpha 2

Caractères 1 à 9 | Opération associée par défaut lors de la création des lignes compagnons saisis sans machine mais avec un TTR. 1 à 3 code section 4 à 6 code opération 7 à 9 code opération
Caractères 10 à 12 | Code difficulté associé
Caractères 13 à 18 | Code machine associé
Caractère 19 | Type de salarié A Aide (par défaut) S Supplémentaire
Caractère 20 | affichage de la fenêtre d'avertissement X affichage avec demande de confirmation O pas d'affichage, mais confirmation (équivalent réponse oui) N pas d'affichage de la fenêtre d'avertissement, mais sans confirmation (équivalent réponse non)

Remarque La lecture de l'opération se fait avec un code difficulté et un code machine (l'inexistence de cette opération est bloquante).


Saisie des quantités fabriquées

Saisie des quantités fabriquées bqf

Options

-Oph | Prise en compte de la quantité lancée de l'OF et des zones hp_z2 et hp_z4 de l'historique pour calculer le prix du mouvement de stock. (Traitement spécifique R)
-Opm | Pas de mise à jour des stocks de la nomenclature (Sorties réserve et normales)
-Opp | Pas d'initialisation du poids de la réception. Voir mp_param[30] Le poids est stocké dans la zone s0_libre de la table stk0.
-Oql | On prend la quantité lancée comme quantité à fabriquer au lieu de la quantité commandée
-Osa | Affichage de O dans la zone solde de la ligne de commande client si quantité fabriquée >= quantité commandée
-Osr | Pas de mise à jour du stock résultant
-Otl | Affichage de toutes les lignes
-Oxx | Pas de mise à jour du poids unitaire de la fiche article. Voir mp_param[30] Le poids est stocké dans la zone s0_libre de la table stk0
-Ofp | TOP fin de période.
-Obq | Déclenche l'ouverture d'une fenêtre de confirmation via un mot de passe dans le cas où le dépassement est supérieur au pourcentage défini dans la zone numérique 2. Le mot de passe est à définir dans le paramètre (PWD-BQF)
-Ocp | Contrôle sur le poids. Si le poids saisi est en dehors de l'intervalle de tolérance de alpha 2[18,23], le système ouvre une fenêtre de confirmation.
-Obp | Demande la confirmation avec mot de passe si le poids saisi est en dehors de l'intervalle paramétré (alpha 2[18,23]). Le mot de passe est à définir dans le paramètre (PWD-BQF). Nécessite l'option -Ocp.
-Ovl | Vérification de la cohérence du lot suivant le paramétrage indiqué sur le TMV, TYC et #CF-STK
-Oil | Si le numéro est non renseigné, on l'initialise avec la commande courante ou le numéro de commande + ligne (en fonction du paramétrage du TYC alpha1[38].
-Osq | Saisie des quantités en multi - unités Nécessite la note INVERSION_UU_ET_UA sur paramètre de type FOR (FORmules) Cette option est nécessaire si, dans la déclaration de production, on veut pouvoir choisir l'ordre de saisie des unités, entre l'unité d'utilisation et l'unité d'achat. Auparavant, la saisie des quantités en multi - unités se faisait par défaut sur l'unité d'utilisation, il est maintenant possible de saisir par défaut sur l'unité d'achat (par inversion des deux zones).
-Occ | Suppression de la fenêtre de validation Edition du bon dans le programme de saisie des quantités fabriquées
-Oqr | Mise à jour de la quantité réalisée dans la table fab0 (f0_qter) avec la valeur de la quantité fabriquée totale de la ligne de commande (lc_qtefab).
-Oif | Interdiction de saisir une date de production supérieure à la date de jour (Interdit Futur)

Valeur numérique 1

Pourcentage de dépassement autorisé sur les quantités fabriquées par rapport aux quantités restantes

Valeur numérique 2

2ème pourcentage de dépassement toléré de la quantité produite par rapport à la ligne de commande. Ce pourcentage doit être supérieur au précédent.

Valeur alpha 2

Caractères 1 à 3 | Type de mouvement de stock généré en entrée normale
Caractères 4 à 6 | Type de mouvement de stock généré en sortie normale
Caractères 7 à 12 | Code client par défaut
Caractères 13 à 17 | Heure de début de faction. La date proposée par défaut correspond à la veille quand la saisie s'effectue entre minuit et cette heure de début. Format HH.MM
Caractères 18 à 20 | Pourcentage de poids en MOINS toléré par rapport au poids brut de la fiche article Exemple -10, - 5, -5 (le signe - est toujours en position 18)
Caractères 21 à 23 | Pourcentage de poids en PLUS toléré par rapport au poids brut de la fiche article Exemple +10, + 5, +5 (le signe + est toujours en position 21)

Valeur alpha 3

Paramétrage des types de commande à prendre en compte

Notes

E | Complément de select sur la table entête de commande cde1 Exemples E and ec_cli = #SOC E and ec_xxxx Attention, si le complément est sur plusieurs lignes, elles sont concaténées sans ajout de blanc entre chacune d'entre elles
L | Complément de select sur la table ligne de commande cde2 Exemples L and lc_qtelan != 0 L and lc_xxxx Pour améliorer les temps de réponse en modification, il est possible de créer un index sur la table stk0, en s'appuyant sur les champs s0_brc et s0_soc.


Saisie des étiquettes de production

Saisie des étiquettes de production sai_etiqprod

Paramétrage relatif au codes SSCC et codes EAN128 : voir les notes spécifiques et explications dans le programme d'édition des étiquettes de colisage de commande.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 à 10 : cde ou cde-lig ou cde-lig/seq ou cde-lig/seq/cad

cde = Numéro de commande (8 caractères)

lig = Ligne de commande (3 caractères)

seq = Numéro de séquence (3 caractères)

cad = Ligne de cadencement (3 caractères)

Options

Oca | Gestion cartonnage
Oea | Etiquettes achat (n° de commande et ligne sont issus du fichier commande fournisseur)
Oli | Activation du mode liste
One | Active le calcul du nombre d'étiquette en sortie du deuxième écran
Ore | Recherche du code ensemble dans les nomenclatures
Ose | Initialiser l'adresse de la société émettrice avec le site de production de l'utilisateur Cette option prend le pas sur la note ADR_SOC_EMETTRICE Tableau de bord du multisite
Oti | Gestion titre multiligne (inutile pour le moment)
Ove | Edition VoluEdit Pensez au paramétrage standard de VoluEdit, notamment aux notes commençant par VE.

Notes

ADR_SOC_EMETTRICE | 21 à 23 Code adresse par défaut. Voir la note SOC_EMETTRICE Cette note est ignorée si l'option Ose est activée.
CODE_CLI_DEB_ANNEE | SPECIFIQUE
CODE_EAN128_SANS_PAR | 21 Codification avec ou sans parenthèses (O/N, N par défaut) O pas de parenthèses N on met des parenthèses
CODE_ETIQUETTE | 21 à 23 Code étiquette par défaut (paramètre de type MDO
CREATION_CODE_EAN128 | 21 à 23 Code de création : 002 Nouveau code de codification EAN128 Le paramétrage du code de codification 002 permet de codifier une chaîne de 51 caractères comme suit : Car. 1 : + (signe plus) Car. 2 à 3 : 2 premiers caractères du code société Car. 4 à 11 : Identifiant unique de l'étiquette Car. 12 à 29 : le_libpar1 (info du F24 du code produit) Car. 30 à 39 : Référence du lot client (lc_p3) Car. 40 à 51 : quantité par palette Cette chaîne est contenue dans le champ etp_cab_1
ETIQUETTE_NEUTRE | 21 La dernière fiche palette imprimée ne contient pas de quantité, elle est généralement renseignée à la main (palette de fin) (O/N)
MODE_CODE_SSCC | SPECIFIQUE
SOC_EMETTRICE | 21 à 26 Société émettrice par défaut. Voir la note ADR_SOC_EMETTRICE
TSC_EDITION_PF | 21,23 Code TSC d'édition du code PF Exemple du TSC PF : ZCCode edit. PF :N Z<<<< Code edit. PF #CCode edit. PF
TYPE_ETIQUETTE | 21 à 21 Type étiquette par défaut (P/C…)

Paramètres associés

CIC

Dans la fenêtre F8, les quantités de produit sont remontées en automatique selon les paramètres suivants :

CIC C24 = Code du produit de palettisation

CIC NA3 = Nombre de produits par paquet

CIC NA4 = Nombre de produits par caisse

CIC NA5 = Nombre de produits par palette


Saisie des rapports onduleuse

Saisie des rapports onduleuse fab_ond_saisie

Accès à la GED

Options

-Oex | Saisie extrudeuse
-Orp | Recherche des matières sur le produit fini (nécessite l'option –Oex)

Valeur numérique 1

Nombre de jours (par défaut, 200)

La date de début de la faction ne peut pas être inférieure à la date du jour – cette valeur.

Valeur numérique 2

Durée supplémentaire en minutes

Dans le contrôle de la durée des postes, il est possible de paramétrer une durée en minutes supplémentaires afin d'éviter les durées possibles de 8h01.

Valeur alpha 2

Caractère 1 | La création des numéros de mariage provient-elle d'un numéro séquentiel automatique ?
Caractère 2 | La durée planifiée de la faction est-elle saisissable ?
Caractère 3 | La durée planifiée est-elle alimentée par la durée réalisée ? Pour pouvoir être alimentée, la durée planifiée ne doit pas être saisissable.
Caractère 4 | La laize unitaire des OF est-elle saisissable ?
Caractère 5 | La laize des OF est-elle saisissable ?
Caractère 6 | La laize des OF doit-elle être calculée à partir du nombre de poses et de la laize unitaire ? Pour pouvoir être calculée, la laize des OF ne doit pas être saisissable.
Caractère 7 | La quantité saisie au niveau des OF correspond à 1 un nombre de coupes 2 un nombre de plaques (Valeur par défaut)
Caractère 8 | La coupe unitaire OF est-il saisissable ?
Caractère 9 | Le métrage OF est-il saisissable ?
Caractère 10 | Le métrage OF doit-il être calculé à partir du nombre coupes / nombre de plaques et la coupe unitaire ? Pour pouvoir être calculé, le métrage des OF ne doit pas être saisissable.
Caractère 11 | Le grammage planifié du mariage est-il saisissable ?
Caractère 12 | Le grammage planifié du mariage est-il alimenté par le grammage réalisé ? Pour pouvoir être alimenté, le grammage planifié ne doit pas être saisissable.
Caractère 13 | L'épaisseur planifiée du mariage est-elle saisissable ?
Caractère 14 | L'épaisseur planifiée du mariage est-elle alimentée par l'épaisseur mesurée ?
Caractère 15 | Le rogne planifiée du mariage est-il saisissable ?
Caractère 16 | La rogne planifiée du mariage est-elle alimentée par la rogne réalisée ? Pour pouvoir être alimentée, la rogne planifiée ne doit pas être saisissable.
Caractère 17 | Le métrage planifié du mariage est-il saisissable ?
Caractère 18 | Le métrage planifié du mariage est-il alimenté par la métrage réalisé ? Pour pouvoir être alimenté, le métrage planifié ne doit pas être saisissable.
Caractère 19 | Le grammage réalisé est-il saisissable ?
Caractère 20 | Le grammage réalisé est-il alimenté par défaut par la composition technique ?
Caractère 21 | La rogne réalisée du mariage est-elle saisissable ?
Caractère 22 | La rogne réalisée du mariage est-elle calculée à partir des laize des OF ? Pour pouvoir être calculée, la rogne du mariage ne doit pas être saisissable.
Caractère 23 | Le métrage réalisé du mariage est-il saisissable ?
Caractère 24 | Le métrage réalisé du mariage est-il calculé à partir des métrages des OF ? Pour pouvoir être calculé, le mariage réalisé ne doit pas être saisissable.
Caractère 25 | La composition technique est-elle saisissable ?
Caractère 26 | La composition technique est-elle alimentée par défaut par les OF ?
Caractère 27 | Le profil cannelure est-il saisissable ?
Caractère 28 | Le profil cannelure est-il alimenté par défaut par la composition technique ?
Caractère 29 | Les laizes papiers planifiés sont elles alimentées par défaut par la laize du mariage ?
Caractère 30 | Les laizes papiers réalisées sont elles alimentées par défaut par les planifiées ?
Caractères 31 à 35 | Pourcentage maximum admis entre le poids réel et le poids planifié (uniquement pour extrudeuse)

Valeur alpha 3

Caractères 1 à 3

Identifiant papiers

Valeur alpha 4

Caractères 1 à 4 | Plage 1 (journée) : Heure de début de faction
Caractères 5 à 8 | Plage 1 (journée) : Heure de fin de faction
Caractères 9 à 12 | Plage 2 (matinée) : Heure de début de faction
Caractères 13 à 16 | Plage 2 (matinée) : Heure de fin de faction
Caractères 17à 20 | Plage 3 (après-midi) : Heure de début de faction
Caractères 21 à 24 | Plage 3 (après-midi) : Heure de fin de faction
Caractères 25 à 28 | Plage 4 (nuit) : Heure de début de faction
Caractères 29 à 32 | Plage 4 (nuit) : Heure de fin de faction

Notes

AMALGAMER_8OF | 21 Permet d'amalgamer jusqu'à 8 OF (O/N, N par défaut) Avant, il était possible d'amalgamer jusqu'à 3 OF au maximum par mariage. Dans la visu des mariages, on accède aux variables suivantes : x1_of_N x1_nb_poses_of_N x1_lz_of_N x1_qte_plaq_of_N x1_coupe_of_N où N peut prendre les valeurs 1 à 8 pour les OF 1 à 8.
LD | 3 à 7 Laize disponible (30 maxi.)
_SUP_REQ_NOM0 | 21 à 60 Complément de requête sur la nomenclature (table nom0) pour la recherche des matières.
_SUP_REQ_MAT | 21 à 60 Complément de requête sur l'article (table mat) pour la recherche des matières.


Saisie des temps atelier par code barres

Code salarié aide ou supplémentaire

Au message Code salarié ?, saisie du code salarié.

Le code salarié doit exister, ne doit pas être annulé et doit avoir un code fonction autorisé (A2[16]).

Si c'est le cas, le module demandera un code action début ou fin d'activité.

Si ce n'est pas le cas, le module redemandera un code salarié après avoir affiché un message d'anomalie.

Début ou fin d'activité

Au message Action ?, saisie de l'action de début d'activité (DBTAC par défaut) ou de fin d'activité (FINAC par défaut).

Si c'est une action de début d'activité, le module contrôlera qu'aucune activité est en cours.

Si c'est le cas, le module demandera le type de saisie.

Si ce n'est pas le cas, le module redemandera un code action après avoir affiché un message d'anomalie.

Si c'est une action de fin d'activité, le module contrôlera qu'une activité est en cours.

Si c'est le cas, le module terminera l'activité, puis redemandera un code salarié.

Si ce n'est pas le cas, le module redemandera un code action après avoir affiché un message d'anomalie.

Type de saisie

Au message Machine / TTR ?, saisie de l'action de saisie de machine (MAC par défaut) ou de saisie de TTR (TTR par défaut).

Si c'est une action de saisie de machine, le module demandera un code machine.

Si c'est une action de saisie de TTR, le module demandera un code TTR.

Si c'est une autre action, le module redemandera un type de saisie après avoir affiché un message d'anomalie.

Saisie de la machine

Au message Machine ?, saisie du code machine.

La machine doit exister et ne doit pas être annulée.

Si c'est le cas, le module débutera l'activité, puis redemandera un code salarié.

Si ce n'est pas le cas, le module redemandera un code machine après avoir affiché un message d'anomalie.

Saisie du TTR

Au message TTR ?, saisie du code TTR.

Le TTR doit exister et doit être autorisé (TTR A1[29] = N).

Si c'est le cas, le module débutera l'activité, puis redemandera un code salarié.

Si ce n'est pas le cas, le module redemandera un code TTR après avoir affiché un message d'anomalie.

Remarques

La saisie multi-OF n'est pas autorisée (option Oti activée automatiquement).

La fin d'activité provisoire pour tous les événements en cours (FINPT par défaut) et la reprise de tous les événements suspendus (RETPT par défaut) ne sont pas autorisées.

Les touches suivantes ne sont pas autorisées :

F6 Saisie multi-OF

F13 Reprise de tous les événements suspendus

F17 Fin d'activité provisoire pour tous les événements en cours

F18 Visualisation de l'état d'avancement

F19 Edition du devis

F21 Lancement de la saisie des temps

CONTROL-N Saisie des notes

Rattachement des compagnons

Après la saisie du code salarié responsable des compagnons, l'opérateur saisira les compagnons rattachés au responsable.

Au message Action / OF ?, saisie de l'action de saisie des compagnons pour début d'activité (COMP par défaut).

Au message Action / Compagnon ?, saisie du compagnon rattaché ou de l'action de fin de saisie des compagnons (FINSC par défaut) lorsque tous les compagnons rattachés sont saisis.

Rattachement d'un nouveau compagnon

Si un nouveau compagnon est rattaché au responsable lorsqu'une activité est en cours, celui-ci sera saisi de la même façon que ci-dessus.

Par contre, si l'écart de temps entre l'heure de début de l'activité en cours et l'heure du rattachement du nouveau compagnon est inférieur au delta paramétré sur le paramètre de lancement, l'heure de début du nouveau compagnon sera l'heure de début de l'activité en cours, sinon ce sera l'heure du rattachement du nouveau compagnon.

Détachement d'un compagnon

Au message Action / OF ?, saisie de l'action de saisie des compagnons pour fin définitive d'activité (FINDC par défaut).

Au message Action / Compagnon ?, saisie du compagnon détaché ou de l'action de fin de saisie des compagnons (FINSC par défaut) lorsque tous les compagnons détachés sont saisis.

Remarques

La saisie multi-OF n'est pas autorisée (Option Oti activée automatiquement).

La fin d'activité provisoire pour tous les événements en cours (FINPT par défaut) et la reprise de tous les événements suspendus (RETPT par défaut) ne sont pas autorisées.

Les touches suivantes ne sont pas autorisées :

F6 Saisie multi-OF

F13 Reprise de tous les événements suspendus

F17 Fin d'activité provisoire pour tous les événements en cours

Saisie des temps atelier par codes-barres sbs

Voir aussi : Opérations de contrôle et de maintenance

Valeurs numériques

1 | Pourcentage de production
2 | Temps d'attente Le temps d'attente général par défaut est de 2 secondes. Le temps d'attente dans la saisie des temps par défaut est de 1 seconde. Remplace le paramètre ATT M23 qui n'est plus utilisé.

Options triées

O03

Aide No 3 à la saisie de l'OF - Voir aussi Aide à la saisie des OF

Oaa

Si le TTR saisi est un arrêt (alpha1[7] du TTR), cet événement sera considéré comme un aléa.

Oac

Permet d'afficher les compagnons rattachés au salarié

Les 4 premiers compagnons dans l'ordre alphabétique sont affichés.

L''option Ogc est obligatoire.

Oan

Affichage des notes des références de l'OF après la saisie de la phase

Oap

Affichage du message d'activité précédent sur 2 lignes

Oar

Autorise la saisie des compagnons (Voir option Ogc) pour les aides conducteurs

Forçage de la fonction des conducteurs ou responsables à R même si l'action est menée par un aide

Forçage de la fonction des compagnons à A même si c'est un responsable

Ocd

Pas de clôture définitive lors de la clôture automatique d'un événement

Ocp

Clôture provisoire des opérations drapeaux

Odp

Saisie de quantités sur les opérations drapeaux

Ofa

Ne propose pas la clôture automatique de la phase en cours, il faut explicitement déclarer sa fin

Oga

Gestion des aides. Option payante PRO 10

Cette gestion active automatiquement les options Oof et Oti.

Cette option est incompatible avec les options Ogc et Otp.

Cliquez ici pour afficher / masquer plus d'informations sur la gestion des aides.

Voir aussi :

A2[16]

Notes S_DAC / S_FAC / S_MAC / S_TTR

TTR A1[29] = N

Ogc

Gestion des groupes de compagnons. Option payante PRO 09

Cette gestion active automatiquement les options Oof et Oti.

Cette option est incompatible avec l'option Oga et Otp.

Cliquez ici pour afficher / masquer plus d'informations sur la gestion des compagnons.

Voir aussi les notes suivantes : DELTA_TEMPS_DBT / S_COM / S_FDC / S_FSC

Ogd

Gestion des dépassements

Cette option permet de gérer les dépassements de temps et de matières.

Cela se traduit par l'ouverture en automatique de la saisie d'une note et/ou de TSC selon le paramétrage.

Cette fenêtre s'ouvre

si la quantité saisie est supérieure à la quantité prévue + la tolérance,

ou si le temps de production saisi est supérieur au temps prévu + la tolérance.

Voir les notes du paramètre de lancement

CLE_CONFORMITE

FEN_AUTO_NTS_QTE_D

FEN_AUTO_NTS_TPS_D

POUR_DEP_QTE

POUR_DEP_TPS

TSC_CONFORMITE

Voir les notes sur le TTR

POUR_DEP_QTE

POUR_DEP_TPS

Voir la note CONTEXTE_TSC sur le TSC avec les 2 variables suivantes :

SBS_DEP_TPS (lors du dépassement du temps prévu)

SBS_DEP_QTE (lors du dépassement de la quantité lancée)

NTS avec nn_type = 6

Visus

v_evt : Source de la note : NOTSBS – Type clé (origine) : 6

v_fab2 : Source de la note : NOTFAB2 – Type clé (origine) : 6

Ohm

Affichage en heures minutes

Oim

Imprimerie

Om1

Pouvoir mettre la phase comme terminée dans FAB1, et l'envoyer vers le planning, sans attendre l'intégration des événements

Omp

Proposer la machine de la saisie précédente si c'est le même OF (Cde-Ligne/Entité)

Ooc

Proposer l'OF en cours du salarié

Oof

Affichage de l'OF en cours à la saisie du code salarié

Oom

Saisie de numéro d'OF (spécifique)

Oon

Gestion des opérations non prévues au devis. Voir A2[13,15]

Nouvelles fonctionnalités

Mettre en place une autorisation pour la saisie des opérations non prévue au devis

Possibilité d'ouvrir la saisie de TSC

Possibilité d'ouvrir la saisie de note

Voir les notes du paramètre de lancement

CLE_CONFORMITE

FEN_AUTO_NTS_ONP

SBS_ACCES_ONP_NON

SBS_ACCES_ONP_OUI

SBS_ACCES_ONP_PWD

TSC_CONFORMITE

Voir la note CONTEXTE_TSC sur le TSC avec la variable suivante :

SBS_OPE_NON_PREVUE

NTS avec nn_type = 6

Visus

v_evt : Source de la note : NOTSBS – Type clé (origine) : 6

v_fab2 : Source de la note : NOTFAB2 – Type clé (origine) : 6

Voir aussi l'option Opd ci-dessous

Oop

Si cette option est activée, le programme demandera toujours le type de travail après la saisie du code machine.

Si cette option n'est pas activée, le programme ne demandera le type de travail après la saisie du code machine que si o0_param[20] = O.

Opd

Pas de demande de confirmation lorsque l'opération n'a pas été devisée

L'option Oon doit être paramétrée.

Opm

Valorisation des déchets au PAMP (avec -Osc)

Opr

Affichage des OF provisoires à la saisie du code salarié si pas d'OF en cours

L'option Oof (Affichage de l'OF en cours) est activée automatiquement.

L'action de reprise de l'OF est générée automatiquement

Cette option ne fonctionne que dans le cadre d'un seul OF ouvert à la fois.

Ops

Second passage sur un OF avec phases identiques

Opv

Valorisation des déchets au prix de vente de l'article en unité de vente (avec -Osc)

Oq0

Lors de la clôture provisoire d'un événement , la quantité produite est égal à zéro

(par défaut elle est égale à la quantité prévue sur le dossier)

Oq1

Pour une opération de calage, la quantité produite sera à 1.

Oqd

Visualisation de la quantité déjà produite et de la quantité à produire

Oqo

On affiche la quantité prévue de l'opération en lieu et place de la quantité prévue de la ligne de commande.

Oqp

Pas de saisie des quantités produites

Oqr

Saisie des quantités en mode de saisie rapide des TTR. Nécessite l' option -Oaa

Ore

Saisie d'une retouche possible

Oro

Redémarrage automatique de l'opération après arrêt dû à un aléa

Osc

Activation de la fenêtre de saisie des consommation carton pour les triplets paramétrés

Osp

Proposer salarié de la saisie précédente

Oti

Touche F6 désactivée

Touche F6 (Saisie des multi-OF) est désactivée.

Otm

Lors de la fin normale d'un événement, la recherche des événements se fait sur tous les types de TTR. (Sans l'option, seuls les TTR à blanc sont sélectionnés).

Oto

Affichage du TTR par défaut de l'opération au message Type de travail ?

Otp

Saisie des temps de présence

Option incompatible avec la gestion des groupes de compagnons (Ogc) ou la gestion des aides (Oga)

Ott

Affichage du temps total réalisé

Ovf

Vérification dans les événements que l'opération est terminée

Oxa

Valorisation des déchets selon le prix d'achat de la fiche article (avec -Osc)

Oxb

Valorisation des déchets selon le mode de valorisation de l'article (avec -Osc) (mode de valorisation par défaut)

Oxr

Valorisation des déchets selon le prix de revient de la fiche article (avec -Osc)

Oxv

Valorisation des déchets selon le prix de vente de la fiche article (avec -Osc)

Valeur alpha 2

Caractère 1 | Contrôle la présence du responsable (N/R) N par défaut
Caractère 2 | Autorisation de correction (R/T/I) R par défaut
Caractères 3 à 5 | Non utilisés ? A VERIFIER
Caractère 6 | Recherche de la fonction dans la fiche employé (E/N) E par défaut
Caractère 7 | Fonction induction / saisie ou figée (S/R) S par défaut
Caractère 8 | Aléa Fonction conservée ou déterminée (C/D) C par défaut
Caractère 9 | Renvoi de la fonction (F/N) F par défaut
Caractères 10 à 12 | Code paramètre de la saisie des temps salarié
Caractères 13 à 15 | Code difficulté par défaut (pour créer la nouvelle opération dans les événements) Obligatoire avec l'option Oon. Il faut d'utiliser un code difficulté spécifique pour les opérations non devisées. Ne pas oublier de créer des opérations avec ce code difficulté
Caractère 16 | Type de salarié autorisé. Facultatif A Aide (par défaut) S Supplémentaire
Caractère 17 | Préfixe de saisie des TTR dans la zone de saisie de la phase ou de l'opération Facultatif. A à Z autorisés .Exemple : T Voir la note CREATION_AUTO_PHASES
Caractère 18 | Permettre de remplacer la désignation du produit P Affichage de la désignation du Produit (mat.mp_des) (par défaut) E Affichage de la référence d'Entête de commande (cde1.ec_texte) L Affichage de la désignation de la Ligne de commande (cde2.lc_lib)
Caractère 19 | Mode de création automatique des phases (1 ou 2, 1 par défaut) 1 Le numéro de phase est recherché sur le TTR 2 Le numéro de phase est recherché dans les notes CREATION_AUTO_PHASES
Caractères 20 à 25 | Machine par défaut - Facultatif Si celle-ci est paramétrée, la saisie de la machine ne sera pas demandée et la machine sera initialisée avec la machine par défaut.
Caractère 26 | Afficher un second code produit et son libellé N ou vide : non affiché (par défaut) D : afficher le code et le libellé du produit de la première référence multiple de l'entité du devis.

Valeur alpha 3

Caractères 1 à 2

Numéro de scénario (1 par défaut)

Notes triées

CLE_CONFORMITE

21,26 Nom de la machine fictive ayant des TSC

Si cette clé n'est pas renseignée, l'application prendra par défaut la machine 000000 (rappel).

Utilisée dans :

- les opérations de contrôle et de maintenance

- la gestion des dépassements de temps et de matières (option Ogd)

- la gestion des opérations non prévues au devis (option Oon)

Suite à des contraintes techniques, il est nécessaire d'associer les TSC à une machine fictive.

Ces TSC sont de type 5 (correspondant à des TSC de la table fab2).

La clé qui les définit est sous la forme suivante :

1,19 Numéro de l'OF

20,22 Type de gamme

23,28 Numéro de phase

29,32 Numéro de ligne

CREATION_AUTO_PHASES

Création automatique de phases

Voir aussi A2[17].

21,25 Numéro de phase - Obligatoire. 1 à 32500

26,34 Code opération - Obligatoire

Section sur 3 caractères

Opération sur 3 caractères

Sous-opération sur 3 caractères

35,40 Code machine - Facultatif

41,43 Code difficulté - Facultatif

44,46 Code TTR

Facultatif si le mode de création automatique des phases (A2[19]) est à 1 ou blanc

Obligatoire si le mode de création automatique des phases A2[19]) est à 2

DELTA_TEMPS_DBT

21,25 Delta de temps en minutes entre l'heure de début de l'activité en cours et l'heure du rattachement du nouveau compagnon

Si l'écart de temps est inférieur au delta, l'heure de début du nouveau compagnon sera celle du début de l'activité en cours, sinon ce sera l'heure du rattachement du nouveau compagnon.

Utilisé avec l'option Ogc

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

ETIQPROD_IMP

21,23 Imprimante pour édition automatique des étiquettes

Créer un MDO par défaut du même code que l'imprimante indiquée ici.

24 Demande de choix de l'imprimante des étiquettes ou imprimante auto ?

O automatique

N demande

Voir aussi TTR A2[44]

FEN_AUTO_NTS_ONP

21,23 Type de note à ouvrir (ouverture de la saisie des notes en automatique) si un opérateur saisit une opération non prévue dans le devis.

Utilisée dans la gestion des opérations non prévues au devis (option Oon)

FEN_AUTO_NTS_QTE_D

21,23 Type de note à ouvrir (ouverture de la saisie des notes en automatique) si un opérateur a dépassé la quantité lancée prévue (tolérance comprise).

Gestion des dépassements obligatoire (option Ogd)

FEN_AUTO_NTS_TPS_D

21,23 Type de note à ouvrir (ouverture de la saisie des notes en automatique) si un opérateur a dépassé le temps prévu (tolérance comprise).

Gestion des dépassements obligatoire (option Ogd)

OF_CLE

OF clés - La clé d'OF doit être unique

21,30 Clé d'OF - Obligatoire

32,51 Numéro d'OF - Obligatoire

53 Mode d'OF - Obligatoire

1 L'année et le mois sont ajoutés devant le numéro d'OF

2 Le numéro d'OF est pris tel quel

ORDER

7 à 11 complément d'order by pour l'affichage du tableau

PAR_LCT_EDIT_DEVIS

21,26 Type et code du paramètre de lancement de l'édition des devis

Ce paramétrage est obligatoire pour accéder à la touche F19.

PAR_LCT_ETAT_AVANCE

21,26 Type et code du paramètre de lancement de la visualisation de l'état d'avancement par défaut

Ce paramétrage est obligatoire pour accéder à la touche F18.

Le paramétrage de lancement de la visualisation d'état d'avancement utilisera de préférence l'option –Oss (exécution directe sans ouverture d'écran de sélection)

La même note existe dans le paramètre QEM où elle est prioritaire.

PAR_LCT_VISU_EVT

21,26 Type et code du paramètre de la visualisation des événements (F22)

PAR_LIB_RETOUCHE

21 à 60 Libellé du message

Par défaut : RETOUCHE (RET) ?

PHASE_FIN_DPL_OPERAT

21,26 Lors de la déclaration d'une fin de phase, mettre à jour l'opérateur ayant réalisé cette action sur le dossier (via le TSC DPL)

TOUTES : à chaque fin de phase , on met à jour ce TSC

AUCUNE : pas de mise à jour

nnnnnn : la mise à jour ne se fait que pour la phase nnnnnn

PLAGE_HORAIRE

Plages horaires

La plage horaire doit être unique et ne doit pas chevaucher une autre plage horaire.

21 Plage horaire - Obligatoire

Si #CF ATL A3[17] = N ou [espace]

1 Jour

2 Matin

3 Après-midi

4 Nuit

Si #CF ATL A3[17] = O

J Jour

M Matin

A Après-midi

N Nuit

23,26 Heure de début en heures/centièmes - Obligatoire

0000 à 2400

28,31 Heure de fin en heures/centièmes - Obligatoire

Supérieure à l'heure de début

0000 à 2400

POUR_DEP_QTE

21,23 Pourcentage de tolérance pour le dépassement de la quantité lancée.

Nécessaire avec la note FEN_AUTO_NTS_QTE_D ou le TSC contextuel.

Si 999, alors pas de contrôle.

Cette note existe aussi dans le TTR où elle est prioritaire.

POUR_DEP_TPS

21,23 Pourcentage de tolérance pour le dépassement du temps prévu.

Nécessaire avec la note FEN_AUTO_NTS_TPS_D ou le TSC contextuel.

Si 999, alors pas de contrôle

Cette note existe aussi dans le TTR où elle est prioritaire.

SBS_ACCES_ONP_OUI

25,30 Autorisation à saisir une opération non prévue au devis.

Code employé (em_code) ou GLOBAL.

Utilisée dans la gestion des opérations non prévues au devis (option Oon)

SBS_ACCES_ONP_NON

25,30 N'autorise pas la saisie d'une opération non prévue au devis.

Code employé (em_code) ou GLOBAL.

Utilisée dans la gestion des opérations non prévues au devis (option Oon)

SBS_ACCES_ONP_PWD

Autorisation à saisir une opération non prévue au devis sur mot de passe

21,23 Code paramètre sur le type paramètre PWD

25,30 Code employé (em_code) ou GLOBAL

Utilisée dans la gestion des opérations non prévues au devis (option Oon)

S_ACT

Demande d'activité en cours

7 à 11 Nouveau code (par défaut ACT)

S_AID

7 à 11 Code aide (exemple AIDE)

S_ALEA

Si un aléa (une panne par exemple) survient, l'utilisateur est obligé de mettre un TTR pour le définir. Ce TTR ne reflète pas forcément la réalité.

La nouvelle action ALEAS (par défaut), permet à l'opérateur de déclencher un début d'aléa sans déterminer la cause.

Celle-ci sera déterminée lorsque l'utilisateur saisira une reprise de roulage ou calage ou une fin.

Remarque : lors de l'intégration des temps, si l'OF contient une ligne d'événement avec un aléa non déterminé, l'OF complet ne sera pas intégré.

7,11 Paramétrage du début d'un aléa non déterminé (par défaut ALEAS)

Voir aussi la note _SUP_REQ_CODE_ALEAS

S_ANU

Paramétrage de l'annulation

7 à 11 Nouveau code (par défaut ANUL)

S_COM

7 à 11 Saisie des compagnons pour début d'activité

Facultatif - COMP par défaut

Utilisé avec l'option Ogc

S_CON

Paramétrage de la saisie consommation carton

7 à 11 Nouveau code (par défaut CONS)

S_CTL

Voir Opérations de contrôle et de maintenance

S_DAC

7 à 11 Saisie du début d'activité de l'aide ou du supplémentaire

Facultatif - DBTAC par défaut

Utilisé avec l'option Oga

S_FAC

7 à 11 Saisie de la fin d'activité de l'aide ou du supplémentaire

Facultatif - FINAC par défaut

Utilisé avec l'option Oga

S_FDC

7 à 11 Saisie des compagnons pour fin définitive d'activité

Facultatif - FINDC par défaut

Utilisé avec l'option Ogc

S_FID

Paramétrage de la fin définitive

7 à 11 Nouveau code (par défaut FIND)

S_FIN

Paramétrage de la fin non définitive

7 à 11 Nouveau code (par défaut FINN)

S_FIP

Paramétrage de la fin d'activité provisoire

7 à 11 Nouveau code (par défaut FINP)

S_FPT

Paramétrage de la fin d'activité provisoire pour tous les événements en cours

7 à 11 Nouveau code (par défaut FINPT)

S_FSC

7,11 Fin de saisie des compagnons (Début d'activité ou fin définitive d'activité)

Facultatif - FINSC par défaut

Utilisé avec l'option Ogc

S_MAC

7 à 11 Saisie de la machine

Facultatif - MAC par défaut

Utilisé avec l'option Oga

S_MAT

7 à 11 Code mat (exemple MAT)

S_MMAC

7 à 11 Modification de la machine utilisée si aucun temps n'a été saisi

Facultatif – MMAC par défaut

Lors de la saisie d'un OF + son numéro de phase, par défaut la machine utilisée correspond à celle qui est déclaré sur la phase.

Via l'action (MMAC par défaut), l'utilisateur peut modifier la machine si et seulement si aucun temps n'a été saisi.

S_REP

Paramétrage de la reprise provisoire

7 à 11 Nouveau code (par défaut RETP)

S_RPT

Reprise tous travaux suspendus

7 à 11 Nouveau code (par défaut RETPT)

S_SUP

saisie fonction supplémentaire

7 à 11 Nouveau code (par défaut SUP)

S_TTR

7 à 11 Saisie du TTR

Facultatif - TTR par défaut

Utilisé avec l'option Oga

_SUP_REQ_CODE_ALEAS

21,60 Complément de sélection sur la table par02 pour la présentation de la liste des aléas.

Fonctionne avec l'action ALEAS, voir la note S_ALEA.

Exemple

and p2_code like "5%"

TIT_FEN_AFF_NTS_CDE3

21,35 Titre de la colonne des références

Obligatoire

Exemple : Commande

36,60 Titre de la colonne des types des notes

Obligatoire

Exemple : Note sur cde3

TIT_FEN_AFF_NTS_CLI3

21,35 Titre de la colonne des références

Obligatoire

Exemple : Client

36,60 Titre de la colonne des types des notes

Obligatoire

Exemple : Note sur cli3

TIT_FEN_AFF_NTS_REF

21,35 Titre de la colonne des références

Obligatoire

Exemple : Référence

36,60 Titre de la colonne des types des notes

Obligatoire

Exemple : Type de consigne

TSC_CONFORMITE

21 Activation de l'affichage de la fenêtre (O/N)

22 Initialise la fenêtre d'affichage par les TSC par défaut (O/N) (Rappel)

Utilisée dans :

- les opérations de contrôle et de maintenance

- la gestion des dépassements de temps et de matières (option Ogd)

- la gestion des opérations non prévues au devis (option Oon)

VERIF_CADENCE

Vérification de la cadence ou du temps standard

21 Type de la vérification de la cadence ou du temps standard (W/B) - Obligatoire

W Contrôle avec fenêtre de confirmation

B Contrôle bloquant

23,28 Fourchette mini - Obligatoire

30,35 Fourchette maxi - Obligatoire

Exemple

Fourchette mini 10

Fourchette maxi 20

Cadence standard 10000

On pourra saisir entre 9000 et 12000 sans déclencher le contrôle.

Remarques

Attention à l'utilisation des reprises. On risque de se retrouver avec :

- Soit le TTR par défaut de l'opération standard

- Soit un TTR à blanc

Pour changer le code machine, en début de flashage du temps, taper le signe - (moins) devant le code phase.

Exemple : -4001

Le système ouvre la saisie du code machine qui sera utilisée pour cette phase.

Attention : l'opération élémentaire concernée doit exister pour cette machine.


v_evt Visualisation des événements d'atelier

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Argument : code salarié Exemple : -N[em_code]
-N_OF | Argument : N° d'OF sous la forme suivante : - Caractères 1 à 8 = numéro de l'offre - Caractère 9 = tiret - Caractères 10 à 12 = ligne de l'offre (using ‘&&&') Par exemple : appel à partir de la visualisation des commandes clients

Options

Otn

Gestion des temps de nuit

Si l'heure de début est inférieure à l'heure de début de la journée (#CF ATL A1[8,11]), la date de début de saisie est mise à la date de la veille et les heures de début et de fin sont majorées de 24 heures.

Valeur alpha 2

Caractère 31 | Imprimerie (O/N, N par défaut : mécanique)
Caractère 32 | temps en minutes (O/N, N par défaut : en heures centièmes)
Caractère 33 | Edition des temps prévus / réalisés phase uniquement sur la première ligne
Caractère 34 | Interdire la modification des événements intégrés O Interdiction de modifier les événements intégrés N Autorise la modification des événements intégrés [Valeur par défaut]
Caractère 35 | Temps de présence (N/O, N par défaut) N Sélection des événements autres que de type P. O Sélection des événements de type P.

Valeur alpha 4

Caractère 1

Touche F1 : Créer un événement (O/N)

La nouvelle autorisation (touche F1 : standard des visus de VoluPack) permet de créer un événement par duplication de l'événement en cours de sélection dans la visualisation. Pour dupliquer cet événement, il faut indiquer un type de travail (TTR), l'heure de début, l'heure de fin et la quantité. Cette fonctionnalité est utilisée dans le cas où le salarié a oublié de badger sur une opération de type de travail (TTR) ; exemple : une réunion, un arrêt déjeuner, etc.

Attention : Cette nouvelle action fonctionne uniquement si l'événement n'est pas intégrer dans fab2.

Caractère 4

Touche F4 (O/M/N) : Accès aux notes standards

O Accès en consultation uniquement

M Accès en modification

N Pas d’accès à la fonction

Caractère 8

Touche F8 - Rafraîchissement de la visualisation (O/N)

Caractère 20

Touche F20 : Accès aux informations complémentaires

O Accès en consultation uniquement

M Accès en modification

N Pas d’accès à la fonction

Caractère 46

Touche CONTROL-N - Saisie de la note de l'événement (O/N)

Caractères 56 à 60

Mot de passe sur les touches F1, F2 et F6 (Création, Suppression et Modification d'événement)

Notes

S | Complément de sélection sur la table des employés
_SUP_REQ_QTE_TTR_ | On peut paramétrer 9 zones de quantités avec un complément de sélection sur la table evt (par exemple les quantités de calages, les quantités de roulage et les quantités de lavage…) 18 N° du complément de sélection 21,60 Complément de sélection sur la table evt
TPS_AVANT_RAFRAICHIR | 21,25 Temps d'inactivité avant rafraîchissement 0 pas de rafraîchissement Valeur minimum : 10 secondes

Ordres de tri disponibles

1 | code_sal | Code salarié
2 | dat | Date de saisie
3 | n_hd | Heure début
4 | no_of | Numéro OF
5 | n_ph | Phase
6 | n_mac | Machine

Listes des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Nom de zone | Définition de la zone | Origine de la zone
using | Voir #VI |
ev_soc | Code de la société | table evt
ev_type | Type enregistrement T Temps saisis Q Correction des quantités sur OF | table evt
ev_capteur | Numéro du terminal | table evt
libc_capteur | Libellé du terminal par. TRM | table paramètre
ev_oper | Numéro du salarié | table evt
em_nom | Nom du salarié | table emp
em_prenom | Prénom du salarié | table emp
em_fonction | Fonction du salarié | table emp
em_plage | Faction du salarié | table emp
em_machine | Machine du salarié | table emp
em_qual libc_em_qual libl_em_qual | Code Qualification employé Libellé court Libellé long | table emp
lib_machine_emp | Libellé machine salarié | table mac0
ev_date | Date de début de saisie | table evt
ev_date_fin | Date de fin de saisie | table evt
ev_of | Numéro d'OF | table evt
ev_phase | Numéro de phase | table evt
ev_lig | Numéro de ligne | table evt
ev_hd | Heure de début | table evt
ev_hf | heure de fin | table evt
temps_total | = ev_hf - ev_hd, sinon 0 |
ev_ttr | Code du TTR | table evt
libc_ttr | Libellé court du TTR | table paramètre
libl_ttr | Libellé long du TTR | table paramètre
ev_operation | Code de l'opération | table evt
lib_operation | Libellé de l'opération | table ope0
ev_machine | code machine | table evt
lib_machine | libellé machine | table mac0
ev_qte | Quantité | table evt
ev_qte_rebut | Quantité rebutée | table evt
ev_code_matiere | Code du produit | table evt
ev_annul | Code annulé | table evt
ev_cloture | Code clôture N Non clôturé - Etat initial lorsque l'événement est en cours D Clôture définitive - La phase sera clôturée à l'intégration P Clôture provisoire - La phase ne sera pas clôturée à l'intégration I Clôturé non intégrable - Événement gardé pour une reprise A Clôture batch par cron | table evt
ev_libre | Zone libre Exemple Extérieur/Atelier | table evt
ev_traj_aller | Heure de trajet aller | table evt
ev_traj_retour | Heure de trajet retour | table evt
ev_repas | Heure de repas | table evt
ev_fonction | Fonction employé | table evt
lib_fonction | Libellé fonction |
ev_type_oper | Type d'opération | table evt
lib_type_oper | Libellé Type d'opération |
ev_type_ttr | Type de TTR | table evt
lib_type_ttr | Libellé du Type de TTR |
ev_note |  | table evt
ev_groupe | Code salarié du responsable du groupe | table evt
ev_etat | Code état de l'événement Blanc (Valeur par défaut) V = Validée A = Annulée Les codes V et A sont issus de l'intégration OSYS | table evt
le_libpar1 | Référence article du client |
le_libelle | Libellé spécifique 1 |
le_libelle2 | Libellé spécifique 2 |
nom_groupe | Nom du responsable du groupe | table emp
prenom_groupe | Prénom du responsable du groupe | table emp
fonction_groupe | Fonction du responsable du groupe | table emp
ev_plage lib_ev_plage | Plage horaire Libellé de la plage horaire Si #CF ATL A3[17] = N ou blanc 1 Journée - 2 Matin - 3 Après-midi - 4 Nuit Si #CF ATL A3[17] = O J Journée - M Matin - A Après-midi - N Nuit | table evt
ev_qte_roulee | Montre la quantité de l'événement si roulage, vide sinon (cumulable) |
ev_cadence | Divise la quantité roulée par le temps total (non cumulable) |
f0_cli | Code du client | table fab0
cl_nom | Nom du client Inconnu si n'existe pas | table cli
cl_nom_abrege | Nom abrégé du client | table cli
ec_ref | Référence de la commande | table cde1
ec_texte | Libellé de la commande | table cde1
f0_prod | Code du produit | table fab0
lib_f0_prod | Libellé du produit (mp_des | table mat
lc_lib | Désignation de la ligne de commande | table cde2
lc_qtecde |  | table cde2
temps_prevu | Temps restant prévu | calculé
f1_tp | Temps prévu | table fab1
f1_tpp | Temps préparation prévu | table fab1
f1_trp | Temps réalisation prévu | table fab1
f1_qtel | Quantité lancée de la phase | table fab1
f1_qter |  | table fab1
f1_tpr | Temps préparation réel | table fab1
f1_trr | Temps réalisation réel | table fab1
f1_tr | Temps réel | table fab1
f0_delp |  | table fab0
f1_cp | Coût prévu | table fab1
f1_cr | Coût réel | table fab1
f1_rebut | Quantité rebutée | table fab1
f1_qter | Quantité fabriquée | table fab1
f1_deld | Date | table fab1
f1_dde | Date | table fab1
f1_delr | Date | table fab1
f1_mach | Machine réelle | table fab1
lib_f1_mach | Libellé machine réelle | table mac0
tv_date | Date de début de saisie Si l'heure de début est inférieure à l'heure de début de la journée, la date de début de saisie est mise à la date de la veille. |
tv_hd | Heure de début Si l'heure de début est inférieure à l'heure de début de la journée, l'heure de début est majorée de 24 heures. Zone cumulable |
tv_hf | Heure de fin Si l'heure de début est inférieure à l'heure de début de la journée, l'heure de fin est majorée de 24 heures. Zone cumulable |
temps_total_hc | Durée en heures centièmes (Heure de fin - Heure de début) 0 si pas d'heure de fin |


Intégration des événements atelier

Intégration des événements atelier int_rtm

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-Ni

Intégration des temps atelier via canal_comm (code du paramètre de lancement du module à l'origine de l'action Ctrl K)

Ne pas utiliser pour le paramétrage, ce paramétrage est mis en place dans le cadre de l'action ACT021 (voir #RP).

Valeur numérique 1

Délai minimal d'activité (en minutes) pour détection des anomalies à l'intégration en GPAO. (-1 si pas de délai)

Options triées

Oaq

Dans les générations de mouvements de stock des options Oge et Ogs, les quantités sont arrondies de manière supérieure. On évite ainsi les quantités décimales.

Oat

Programme à exécuter sur un ordinateur atelier

Ob1

Traitement Batch Exportation GPAO

Ob2

Traitement Batch Importation EVT

Ob3

Traitement Batch Exportation EVT (atelier)

Ob4

Traitement Batch Importation GPAO (atelier)

Ob5

Traitement Batch Importation d'une sélection GPAO (atelier)

Ob6

Traitement Batch Epuration des événements annulés

Ob7

Traitement Batch Ajustement des événements via le calendrier employé.

Ob8

Traitement Batch Clôture automatique de tous les événements en cours

(ev_cloture est positionné à A)

Ob9

Traitement Batch Clôture provisoire des événements en cours. Mise à jour de la fiche employé.

ObA

Traitement Batch Déclôture provisoire des événements

ObB

Traitement Batch Clôture provisoire des événements avec proratisation du temps

ObC

Intégration des temps en batch

Ocs

Génération des sorties de stock sur les composants de l'article associé à l'OF pour les opérations à comptage ENTREE.

Génération des entrées en stock sur le composé d'après la quantité sortie sur un composant

Oct

Compactage des tables lors de l'importation des données GPAO (ce compactage a lieu sur le site atelier)

Of0

Mise à jour de l'entête du dossier (mis à calculer) dès qu'un événement est intégré

Oga

Génération de mouvements de stock en entrée normale pour chacun des éléments d'un amalgame. Il y a aussi génération d'un mouvement d'entrée normale sur l'article amalgame.

Ce mouvement annule la sortie normale initiale réalisée sur cet article amalgame.

Nécessite l'option Oge

Oge

Génération d'un mouvement de stock en entrée normale correspondant à la somme des quantités produites saisies sur pour chaque OF. Le type du mouvement de stock est défini en Alpha 2.

Exemple

OF Article Quantité produite saisie

94010001-1 SEMESTRIEL 120

94010001-1 SEMESTRIEL 200

94010001-1/1 FEUILLE 150

94010001-1/1 FEUILLE 100

Création des mouvements suivants :

Article Quantité Affectation

SEMESTRIEL 320 94010001-1

FEUILLE 250 94010001-1/1

Voir les options dépendantes de Oge

Ogs

Génération d'un mouvement de stock en sortie normale pour chacun des composants de l'article dans le dossier.

La quantité à sortir de stock pour chacun des composants est calculée à partir de la quantité du compose, du coefficient de nomenclature, de la gâche fixe et de la gâche variable du composant (puisée dans la nomenclature).

Le type du mouvement de stock est défini en Alpha 2.

Remarque L'option Ogs ne peut être utilisée qu'en complément de l'option Oge

Oim

Imprimerie

Omc

Mode contrôle

Oos

Gestion des opérations à ne pas mettre à jour en stock

Fonctionne avec les notes de type OPERATION_SANS_STK

Oqc

Pas de mouvements de stocks générés pour les opérations de calage

Otc

Si le groupe (champ ev_groupe de la table evt) de l'événement à intégrer est renseigné et différent du code opérateur, le TTR du compagnon est remplacé par le TTR paramétré en A2[36,38].

Otn

Gestion des temps de nuit

Voir aussi #CF ATL A1[8,11]

Si l'heure de début est inférieure à l'heure de début de la journée (#CF ATL - A1[8,11]), la date de début de saisie est mise à la date de la veille et les heures de début et de fin sont majorées de 24 heures

Options intervenant dans la valorisation d'un mouvement de stock

Uniquement si option Oge

Odj

Mise en anomalie si un événement ne se fait pas dans la journée

Opm

Valorisation au PAMP

Opv

Valorisation au prix de vente dans l'unité de vente

Osr

Mise à jour du stock résultant à chaque création de mouvement de stock

Otd

Lecture du TTR dans ope0 avant l'intégration de l'événement

Otr

Ajout du TTR dans la recherche de l'opération élémentaire

Oxa

Calcul au prix d'achat

Oxb

Calcul au prix selon le type de valorisation

Oxr

calcul au prix de revient

Oxv

calcul au prix de vente

Valeur alpha 2

Caractères 1 à 3 | Numéro de module d'intégration 500 Événement d'atelier
Caractères 4 à 6 | Type de mouvement de stock en entrée normale Utilisé par l'option Oge
Caractères 7 à 9 | Type de mouvement de stock en sortie normale Utilisé par l'option Ogs
Caractères 10 à 12 | Type de mouvement de stock en entrée prévisionnelle Utilisé par l'option Oge
Caractères 13 à 15 | Type de mouvement de stock en sortie réserve Utilisé par l'option Ogs
Caractères 16 à 23 | Première sélection définissant les éléments à transférer dans l'exportation des données GPAO Par défaut, année en cours - 1*. Exemple 93*
Caractères 24 à 31 | Seconde sélection définissant les éléments à transférer dans l'exportation des données GPAO Par défaut année en cours*. Exemple 94* Remarque importante Pour que les valeurs par défaut ne soient plus prises en compte les deux sélections doivent être définies.
Caractère 32 | Intégration des quantités produites et des quantités rebutées (O/N)
Caractères 33 à 35 | Code difficulté des opérations non devisées
Caractères 36 à 38 | TTR pour les compagnons. Voir option Otc
Caractères 39 à 41 | Type de note de la note de l'événement à intégrer dans la table des notes des OF Dans stat_fab2 : A2[1,60] doit contenir la colonne v (1ère ligne de note des lignes de temps) A3[51] = O (Editer la 1ère ligne de note des lignes de temps) A3[52,54] = Type de note de la 1ère ligne de note des lignes de temps - Facultatif
Caractères 42 à 44 | Type de mouvement de stock pour les entrées d'affiche en automatique
Caractères 45 à 47 | Type de mouvement de stock pour les sorties (consommations) d'affiche en automatique

Notes

Compléments de sélection

B6

4,60 Complément de sélection (voir les options Ob6, Ob7 et Ob8)

B7

B8

Autres notes

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activer le transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

LIEUX_1_2_3

Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de

saisie manuelle (stk0)

intégration des temps et matières (ici)

visualisation des mouvements de stocks (v_stk0)

La recherche se fait :

1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F ….)

2 sur la sous-famille de l'article

3 sur la famille de l'article

4 sur le type de mouvement de stock

5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3)

13 Type d'article : P, S, M, F … Correspond au champ mp_mp de la table mat (si blanc : recherche globale)

21,23 Lieu de rangement 1 (magasin)

25,27 Lieu de rangement 2 (Emplacement)

29,31 Lieu de rangement 3 (Emplacement)

NUM_PHASES_ENTREES

21,59 Liste des numéros de phases déclenchant la création en automatique d'un mouvement de stock d'entrée d'affiche

13 numéros de 3 caractères par ligne

Exemple (impression offset) : 30 35 60

NUM_PHASES_SORTIES

21,59 Liste des numéros de phases déclenchant la création en automatique d'un mouvement de stock de sortie d'affiche

13 numéros de 3 caractères par ligne

Exemple (découpe) : 100105

PHASE_FIN_DPL_OPERAT

21,26 Lors de la déclaration d'une fin de phase, mettre à jour l'opérateur ayant réalisé cette action sur le dossier (via le TSC DPL)

TOUTES : à chaque fin de phase , on met à jour ce TSC

AUCUNE : pas de mise à jour

nnnnnn : la mise à jour ne se fait que pour la phase nnnnnn

_SUP_REQ_EPU_EMP

21,60 Supplément de requête sur les salariés (table emp) en épuration des événements

_SUP_REQ_EPU_EVT

21,60 Supplément de requête sur les événements (table evt) en épuration des événements

_SUP_REQ_INT_EMP

21,60 Supplément de requête sur les salariés (table emp) en intégration des temps

_SUP_REQ_INT_EVT

21,60 Supplément de requête sur les événements (table evt) en intégration des temps

Générer automatiquement des temps de pause pour éviter aux employés de pointer (éviter ainsi le bouchon à la pointeuse).

TEMPS_PAUSE_HEURE_1 | 21 à 24 Heure de début de la pause numéro 1 25 à 28 Heure de fin de la pause numéro 1
TEMPS_PAUSE_OF_1 | 21 à 52 OF de la pause numéro 1
TEMPS_PAUSE_PHASE_1 | 21 à 25 Phase de la pause numéro 1
TEMPS_PAUSE_TTR_1 | 21 à 23 Type de travail de la pause numéro 1
TEMPS_PAUSE_HEURE_2 | 21 à 24 Heure de début de la pause numéro 2 25 à 28 Heure de fin de la pause numéro 2
TEMPS_PAUSE_OF_2 | 21 à 52 OF de la pause numéro 2
TEMPS_PAUSE_PHASE_2 | 21 à 25 Phase de la pause numéro 2
TEMPS_PAUSE_TTR_2 | 21 à 23 Type de travail de la pause numéro 2
OPERATION_SANS_STK | Empêcher la mise à jour des stocks Ces notes fonctionnent conjointement avec l'option Oos. 21 à 30 Code opération qui ne fait pas l'objet d'une mise à jour des stocks

Remarques

Transferts réseau Exécution du shell rtm_ftp_gpao

Site central è Tables GPAO è Site atelier

Les 11 tables suivantes sont transférées, sous forme de fichiers unl :

fab0 mat ope0 cde1 cli par02 fab1 pos mac0 cde2 emp

Transferts réseau Exécution du shell rtm_ftp_evt

Site atelier è Tables GPAO è Site central

Les nouveaux événements ateliers sont transférés sous evt.unl


Etude de rentabilité

Etude de rentabilité etude_rentabilite

Ce programme permet d'éditer l'étude de rentabilité.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[ec_num]

Options

-B | Mode batch
-N | Numéro de commande
Ocl | Edition des dossiers clôturés. Sinon, le code clôture est saisi N Dossiers non clôturés O Dossiers clôturés [espace] Dossiers non clôturés et clôturés
Oes | Calcul du montant facturé avec déduction de l'escompte de la facture
Ore | Calcul du montant facturé avec déduction des remises ligne et entête de la facture
Osd | Pas d'édition des lignes détail OF
Otc | Totalisation client Option utilisée si Tri Client - OF

Valeur alpha 2

1

Type de tri. Obligatoire en mode batch

1 Tri OF

2 Tri Client - OF

Notes

COL

4,60 Colonnes paramétrables de l'édition de l'étude de rentabilité - Pas de paramétrage par défaut

Paramétrage de la colonne sous la forme Titre zone*Nom zone*Longueur zone*Using zone*

Voir tableau ci-dessous

SUP_REQ_CDE2

21,60 Supplément de requête sur la table des lignes de commande (cde2)

Note cumulative

Exemple

and lc_prod not like "FRAIS%"

SUP_REQ_FAB0

21,60 Supplément de requête sur la table des dossiers de fabrication (fab0) - Obligatoire en mode batch

TYPES_ARTICLE_MAT

Types d'article (mp_param[10]) à cumuler dans les colonnes coûts prévu et réel des matières - N, P, A et F par défaut

Exemple

TYPES_ARTICLE_MAT N

Dans les colonnes coûts prévu et réel des matières, on cumule le coût des articles de type N.

TYPES_ARTICLE_ST

Types d'article (mp_param[10]) à cumuler dans les colonnes coûts prévu et réel de la sous-traitance - O par défaut

Exemple

TYPES_ARTICLE_ST OP

Dans les colonnes coûts prévu et réel de la sous-traitance, on cumule le coût des articles de type O et P.

Colonnes paramétrables de l'édition de l'étude de rentabilité

Voir la note commençant par COL

Les colonnes sont triées par ordre alphabétique.

cout_direct | Coût direct = Coût réel des matières + Coût réel des opérations + Coût réel de la sous-traitance
des_f0_prod | Désignation article (Fiche article)
f0_cde | Numéro commande
f0_cli | Code client
f0_lig | Ligne de commande
f0_of | Numéro ordre de fabrication
f0_prod | Code article
lc_dev | Numéro devis
lc_lib | Désignation article (Ligne commande)
lc_sdev | Numéro sous-devis
marge_brute | Marge brute = Montant facturé de l'ordre de fabrication - Coût direct
marge_brute_vs | Marge brute stock inclus = Montant facturé stock inclus de l'ordre de fabrication - Coût direct
matiere_devisee | Coût prévu des matières
matiere_realisee | Coût réel des matières
montant_facture | Montant facturé de l'ordre de fabrication
montant_facture_vs | Montant facturé stock inclus de l'ordre de fabrication = Montant facturé de l'ordre de fabrication + Valeur du stock
nom_f0_cli | Nom client
pourcentage_ca | % CA = (Montant facturé de l'ordre de fabrication * 100) / Montant facturé des ordres de fabrication sélectionnés
sous_traitance_devisee | Coût prévu de la sous-traitance
sous_traitance_realisee | Coût réel de la sous-traitance
taux_marge_brute | Taux marge brute = (Marge brute * 100) / Montant facturé de l'ordre de fabrication
taux_marge_brute_vs | Taux marge brute stock inclus = (Marge brute stock inclus * 100) / Montant facturé stock inclus de l'ordre de fabrication
using | Constante dans une colonne
valeur_ajoutee_devisee | Coût prévu des opérations
valeur_ajoutee_realisee | Coût réel des opérations
valeur_stock | Valeur du stock = Montant fabriqué de l'ordre de fabrication - Montant facturé de l'ordre de fabrication

Exemples

COLREFERENCE*lc_lib*40*

COLDOSSIER*f0_of*12*

COLDEVIS*lc_dev*8*

COLS-D*lc_sdev*3*##&*

COLMAT DEVIS*matiere_devisee*10*---------&*

COLVA DEVIS*valeur_ajoutee_devisee*10*---------&*

COLST DEVIS*sous_traitance_devisee*10*---------&*

COLMAT REALISE*matiere_realisee*11*----------&*

COLVA REALISE*valeur_ajoutee_realisee*10*---------&*

COLST REALISE*sous_traitance_realisee*10*---------&*

COLCT DIRECT*cout_direct*10*---------&*

COLFACT/CDE*montant_facture*10*---------&*

COLMARGE BRUTE*marge_brute*11*----------&*

COLTAUX*taux_marge_brute*9*-----&.&&*

COL% C.A.*pourcentage_ca*7*---&.&&*


Edition de l'étude de la gâche

Edition de l'étude de la gâche etude_gache

Ce module permet d'éditer 3 documents

Etude globale de la gâche

Etude de rentabilité de la gâche

Etude de la gâche

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[ec_num]

Options triées

-B | Mode Batch
-N | Numéro de commande
Ocl | Edition des dossiers clôturés. Sinon, le code clôture est saisi N Dossiers non clôturés O Dossiers clôturés [blanc] Dossiers non clôturés et clôturés
Ocm | Edition des temps en centièmes d'heures
Odp | Le devisé est égal au prévu. Sinon, le devisé provient du devis rattaché au dossier.
Oft | Toutes les phases sont considérées comme terminées
Ohm | Edition des temps en heures-minutes
Oqs | Edition de la quantité entrée en stock du support papier en unité de vente Option utilisée si édition de l'étude globale de la gâche
Otc | Totalisation client. Option utilisée si Tri Client - OF et édition de l'étude de rentabilité de la gâche ou de l'étude de la gâche

Valeur alpha 2

A2[1] | Type d'état de la gâche. Obligatoire en mode batch 1 Etude globale de la gâche 2 Etude de rentabilité de la gâche 3 Etude de la gâche 4 Génération fichier. Obligatoire en mode batch. Exemple : 1
A2[2] | Type de tri. Obligatoire en mode batch 1 Tri OF 2 Tri Client - OF
A2[3,5] | Type du mouvement de stock des entrées normales de papier. Obligatoire Le type du mouvement de stock doit être une entrée normale Exemple : E
A2[6,8] | Code opération de la phase impression. Obligatoire. Exemple : IOF
A2[9,11] | Code opération de la phase découpe. Obligatoire. Exemple : DEC
A2[12] | Type de gâche. Utilisé dans l'édition de l'étude de la gâche. Obligatoire en mode batch et si édition de l'étude de la gâche D Devisée / Réalisée P Prévue / Réalisée
A2[13,15] | Code famille des supports du dossier de fabrication. Obligatoire EX : CAR
A2[16,18] | Code sous-famille des supports du dossier de fabrication. Facultatif EX : FC
A2[19] | Type de lignes à éditer D Devisée et Réalisée P Prévue et Réalisée T Devisée, Prévue et Réalisée Utilisé dans l'édition de l'étude globale et de l'étude de rentabilité Obligatoire en mode batch et si édition de l'étude globale ou de l'étude de rentabilité
A2[20,22] | Code unité des feuilles Obligatoire Exemple : FL
A2[23,25] | Code unité des étuis Obligatoire Exemple : UN
A2[26,28] | Code unité des mètres linéaires Obligatoire Exemple : M

Valeur alpha 3

A3[1,9] | Code opération de réalisation ou de roulage de la phase impression. Obligatoire. EX : IO IOFROU
A3[10,18] | Code opération de réalisation ou de roulage de la phase découpe. Obligatoire. EX : DC DECROU
A3[19,27] | Code opération de réalisation ou de roulage de la phase façonnage. Obligatoire. EX : CO COLROU

Valeur alpha 4

A4[1,3] | Code formule verso du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO2
A4[4,6] | Code formule recto 1er passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO1
A4[7,9] | Code formule recto 2ème passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO3
A4[10,12] | Code TTR verso du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO2
A4[13,15] | Code TTR recto 1er passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO1
A4[16,18] | Code TTR recto 2ème passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO3

Notes

NOM_FICHIER_GENERE | 21,60 Nom du fichier généré Obligatoire si type d'état = 4 EX : etude_gache
SEPARATEUR_ZONES | Séparateur des zones du fichier généré Facultatif. Un blanc par défaut. null si pas de séparateur. Exemple : | ou null
SUP_REQ_CSLL | Supplément de requête sur la table des mouvements de stock pour le calcul du stock du lot Exemple and s0_rgt1 != "SCR"
SUP_REQ_FAB0 | Supplément de requête sur la table des dossiers de fabrication (fab0). Obligatoire en mode batch Exemple : and f0_of matches "05*"
ZFG | 4,60 Nom des zones du fichier généré Les 3 champs suivants doivent être suivis par un astérisque : Nom de la zone - Voir les tableaux en bas de cette page. Longueur de la zone Format de la zone Obligatoire si type d'état = 4

Paramètres nécessaires

PHA

A2[22] Phase à éditer dans l'édition de la gâche (O/N, N par défaut)

A2[23,25] Code sous-opération de réalisation ou de roulage de la phase. EX : ROU

A2[52] Phase rattachée

A2[53,55] Code section de l'opération de rattachement

A2[56,58] Code opération de l'opération de rattachement

Noms des zones autorisées pour la note commençant par ZFG

code_client | Code client du dossier
etuis_fabriques | Nombre d'étuis fabriqués
feuilles_decoupees | Nombre de feuilles découpées
feuilles_imprimees | Nombre de feuilles imprimées
feuilles_sorties | Nombre de feuilles sorties
nom_client | Nom client du dossier
nombre_poses | Nombre de poses
numero_devis | Numéro devis
numero_dossier | Numéro dossier
pa_1000_feuilles | Prix d'achat pour 1000 feuilles sorties (Coût feuilles sorties / Nombre feuilles sorties) * 1000
phase_dec_terminee | Phase de découpe terminée (N/O) La phase de découpe est considérée comme terminée si la phase de découpe de toutes les entités est terminée.
phase_fab_terminee | Phase de fabrication terminée (N/O) Cette zone correspond au reste à fabriquer (lc_rstfab) de la ligne de commande.
phase_imp_terminee | Phase d'impression terminée (N/O) La phase d'impression est considérée comme terminée si la phase d'impression de toutes les entités est terminée.
using | Constante

Noms des zones autorisées pour la note commençant par ZFG- uniquement pour Excel

Pour le transfert Excel, le type d’état doit être différent de 4 (A2[1]).

cout | Coût feuille
cout_flle_s | Coût feuilles sorties
cout_gache | Coût gâche
cout_gache_reelle | Coût de la gâche réelle
ecart_gache_reeltheo | Écart gâche réelle/théorique
flle_collage | Nombre de feuilles au collage
gache_collage | Gâche collage
gache_decoupe | Gâche découpe
gache_offset | Gâche offset
gache_theo | Gâche théorique
gache_tot | Gâche totale
nb_calages | Nombre d'entités (ou de calages)
nb_etuis_cde | Nombre d'étuis commandés
nb_etuis_liv | Nombre d'étuis livrés
nb_etuis_stk | Nombre d'étuis en stock
nb_flles_tot_dev | Nombre total de feuilles devisées
surcout_gache | Surcoût de la gâche


Gestion des prélèvements

Gestion des prélèvements prelevement

Voir aussi les TSC PRC et PRP

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : niveau de contrôle

Exemple : -N[p2_code]

Caractères 3 et suivants : numéro de commande-numéro de ligne de commande

Exemple : -N[lc_num|-|lc_lig+<<&]

Valeur alpha 2

A2[1,6]

Type et code du paramètre de lancement du programme à lancer

Exemples

SAIQTB Saisie des quantités de base

SAISUP Saisie des Suppléments

SAIEST Saisie des quantités sur Estampille

SAINCP Saisie des quantités supplémentaires par niveau de contrôle

EDICAR Edition

Valeur alpha 3

A3[1]

Type de recherche pour la fiche matière (1, 2, 3, Q, T) (Vu dans prelev_2_c)

Notes

_SUP_REQ_CLI | 21,60 Supplément de requête sur la table cli
_SUP_REQ_MAT | 21,60 Supplément de requête sur la table mat

Paramètres nécessaires

#CF PRL | Configuration des prélèvements
TSC PRL | Prélèvement à faire ou à ne pas faire
#CF CAR | Notes commençant par SUPREQREFARC
TYC | Notes commençant par DT1 (DT11, DT12, DT13). Si aucune note trouvée, on va chercher sur #CF CDE (voir ci-dessous)
#CF CDE | A1[4,6] - A1[7,9] - A1[10,12] Type du paramètre associé au champ lc_p1, lc_p2, lc_p3 de la ligne de commande
.TL | Type de ligne de commande (TSC stocké sur CIC C20)
#CF ATL | A3[18] Le délai de contrôle pour les prélèvements est exprimé en heures ou en jours. Ce délai est saisi sur l'écran de gestion des prélèvements (F31 sur fiche client ou fiche produit). Il est notamment utilisé lors du calcul de la date de fin de fabrication.


Statistiques production / opérations à ruptures paramétrables

Statistiques production / opérations à ruptures paramétrables stat_fab1

Voir stat_fab2 pour le paramétrage qui est identique, sauf qu'il n'y a pas de type TTR.

Voir aussi Opérations élémentaires et dépendances

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro d'ordre de fabrication

Exemple : -N[f0_of]

Colonnes paramétrables

Un astérisque désigne une colonne pouvant être choisie comme rupture.

Un signe plus désigne une colonne dont le usinget le titre peuvent être redéfinis.

A | * | OF
B | * | Phase
C | * | Code machine prévue
D |  | Libellé machine prévue
E |  | Coefficient
F | + | Quantité lancée
G | + | Quantité réalisée
H | + | Gache prévue
I | + | Rebut
J | + | Temps de préparation prévu
K | + | Temps de réalisation prévu
L | + | Temps de total prévu
M | + | Temps de préparation réalisé
N | + | Temps de réalisation réalisé
O | + | Temps de total réalisé
P | * | Phase terminée ? (O/N)
Q | * | Date début prévue opération
R | * | Date fin prévue opération
S | * | Date début réelle opération
T | * | Date fin réelle opération
U | * | Numéro de commande
V | * | Numéro de ligne de commande
W | * | Code client
X |  | Nom client
Y | * | Code article
Z |  | Désignation article
a | * | Code opération
b |  | Libellé opération
c | * | Code machine
d |  | Libellé machine
e | * | Section
f | * | Libellé court section
g | * | Libellé long section
h |  | Référence commande
i |  | Libellé de la commande
j | * | Zone paramètre entête commande
k | * | Libellé court zone paramètre
l | * | Libellé long zone paramètre
m | * | Code famille
n | * | Libellé court famille
o | * | Libellé long famille
p | * | Code sous-famille
q | * | Libellé court sous-famille
r | * | Libellé long sous-famille
s | * | Code difficulté (imprimerie)
t | * | Libellé court difficulté
u | * | Libellé long difficulté
v |  | Observation (zone libre)
w |  | Colonne vide de largeur paramétrable
x | + | Coût prévu
y | + | Coût réel


Statistiques temps de production à ruptures paramétrables

Statistiques temps de production à ruptures paramétrables stat_fab2

Généralités - Valeur alpha 2 - Valeur alpha 3 - Valeur alpha 4 - Notes

Voir aussi TTR A1[12]

Généralités

Le mode batch est possible pour ce programme.

Toutes les options (à l'exception des -O??) ci-dessous sont modifiables par l'utilisateur en interactif par l'accès à un menu paramétrage.

Ce menu n'apparaît pas si l'option -Osp (sans paramétrage) est utilisée.

Valeurs numériques

1 | Largeur de la colonne vide paramétrable en nombre de caractères
2 | Delta d'indentation des entêtes des ruptures en nombre de caractères

Options triées

Occ

Cadence réelle du calage des TTR = Temps / Quantité

Oce

Mode centièmes d'heures

Ocp

On n'affiche pas les cadences sur les opérations de préparation (de réglage).

Concerne les colonnes 0, à et ç

Dans ce programme, il est possible de paramétrer 3 colonnes pour éditer les cadences de production. Dans le cas des opérations de réglage (ou le temps est généralement fixe et où il n'y a pas réellement de cadence), cette valeur est recalculée en fonction du temps passé et de la quantité nécessaire au réglage.

Cette option créée permet de ne pas afficher des données dans les colonnes de cadence sur ces opérations de réglage afin de ne pas perturber les utilisateurs.

Ohm

Mode heures / minutes (heures / centièmes par défaut)

Oim

Mode imprimerie (mécanique par défaut)

Onp

La quantité réalisée est divisée par le nombre de poses

Osp

Sans le menu de paramétrage

Otc

Pas de prise en compte du nombre de calages dans les lignes de totalisation de la colonne O

Valeur alpha 2 : Colonnes paramétrables

Colonnes paramétrables. En paramétrage interactif ces zones peuvent être sélectionnées par une recherche par F7.

  • Pour les zones marqués F, on pourra reparamétrer dans les notes le F ormat de la colonne.

  • Pour les zones marqués T, on pourra reparamétrer dans les notes le T itre de la colonne.

  • Pour les zones marquées L, on pourra reparamétrer la L argeur de la colonne (uniquement les colonnes alphanumériques).

  • Les zones marquées C pourront faire l'objet d'un cumul.

  • Les zones marquées R pourront être choisies comme type de Rupture (voir alpha 3).

A | TLR | OF - Numéro d'OF lié à la phase (fab1.f1_of = fab2.f2_of)
B | LR | Phase - fab1.f1_of = fab2.f2_of
C | TLR | Code opérateur - fab2.f2_oper
D | TL | Nom opérateur - Issu du fichier des employés
E | TL | Prénom opérateur - Issu du fichier des employés
F | R | Date d'imputation du temps de production (ce n'est pas forcément la date de saisie) - fab2.f2_date Cette date dépend du paramétrage de la "journée". Par exemple, si la journée de travail est comprise entre 5h00 du matin et 4h59, alors - une production réalisée le 23 janvier 2007 à 23h00 est imputée à la journée du 23 - une production réalisée le 24 janvier 2007 à 2h00 du matin est imputée à la journée du 23, et non du 24.
G | TLR | Numéro de semaine calculé en fonction de la date d'imputation.
H | TLR | Numéro de mois calculé en fonction de la date d'imputation
I | R | Heure de début de production. Cette heure peut être exprimée en heures/minutes ou heures/centième, en fonction de l'option Ohm.
J | R | Heure de fin de production. Cette heure peut être exprimée en heures/minutes ou heures/centième, en fonction de l'option Ohm.
K | FTC | Temps réel = Heure de début - heure de fin. Exprimée en heures/minutes ou heures/centièmes, en fonction de l'option Ohm.
L | TLR | Code TTR - fab2.f2_typtrav
M | TLR | Libellé court TTR - Libellé court du paramètre TTR
N | TLR | Libellé long TTR - Libellé long du paramètre TTR
O | FTC | Quantité saisie - fab2.f2_qte. Voir les règles de calcul
P | FTC | Rebut
Q | TLR | Fonction employé (R/A/S)
R | TLR | Centre de coût
S | TL | Libellé centre de coût
T | TLR | Plage d'activité
U | TLR | Numéro de commande
V | TR | Numéro de ligne de commande
W | TLR | Code client
X | L | Nom client
Y | TLR | Code article
Z | TL | Désignation article
a | TLR | Code opération
b | TL | Libellé opération
c | TLR | Code machine
d | TL | Libellé machine
e | LR | Code section
f | TLR | Libellé court section
g | TLR | Libellé long section
h | TL | Référence commande
i | TL | Libellé de la commande
j | TLR | Zone paramétrable entête commande
k | TLR | Libellé court zone paramétrable
l | TLR | Libellé long zone paramétrable
m | TLR | Code famille
n | TLR | Libellé court famille
o | TLR | Libellé long famille
p | TLR | Code sous-famille
q | TLR | Libellé court sous-famille
r | TLR | Libellé long sous-famille
s | TLR | Code difficulté (imprimerie uniquement)
t | TLR | Libellé court difficulté (imprimerie uniquement)
u | TLR | Libellé long difficulté (imprimerie uniquement)
v | TL | Observation (zone libre) 1ère ligne de note des lignes de temps
w | L | Colonne vide de largeur paramétrable en valeur numérique 1 Utile pour des statistiques où on n'imprime pas les lignes détail La colonne w est placée en première position de façon à décaler les informations utiles vers la droite
x | FTC | Temps unitaire standard (issu du fichier opération) Pour un calage, il s'agit du temps standard de calage, issu du fichier des opérations. Pour un roulage, il s'agit du temps unitaire de réalisation. Soit 1/cadence. C'est le temps nécessaire pour réaliser un tour machine
y | FTC | Temps unitaire réel. Temps réalisé / quantité réalisée (Colonne K / Colonne O)
z | FTC | Temps standard. Quantité réalisée / cadence standard ou Quantité réalisée * Temps standard. C'est le temps que l'on aurait dû passer pour réaliser la quantité réelle en appliquant la cadence ou le temps standard.
0 | FTC | Quantité horaire moyenne réelle (cadence réelle). Quantité réalisée / Temps réalisé Voir l'option Ocp
1 | FTC | Temps réel au mille. Idem 0 mais multiplié par 1000
2 | FTC | Temps standard au mille. Idem z mais pour 1000
3 | FTC | Pourcentage d'écart entre le temps réel et le temps standard
4 | R | Jour (lundi, mardi, etc.)
5 | FTC | Temps du TTR 1
6 | FTC | Temps du TTR 2
7 | FTC | Temps du TTR 3
8 | FTC | Temps du TTR 4
9 | FTC | Temps du TTR 5
+ | FTC | Quantité du TTR 1
- | FTC | Quantité du TTR 2
< | FTC | Quantité du TTR 3
/ | FTC | Quantité du TTR 4
= | FTC | Quantité du TTR 5
> | FTC | Coût du TTR 1
! | FTC | Coût du TTR 2
( | FTC | Coût du TTR 3
) | FTC | Coût du TTR 4
. | FTC | Coût du TTR 5
? | FTC | Gâche du TTR 1
[ | FTC | Gâche du TTR 2
] | FTC | Gâche du TTR 3
& | FTC | Gâche du TTR 4
é | FTC | Gâche du TTR 5

{

LR

Mode d'utilisation (Imprimerie uniquement)

}

LR

Libellé court Mode d'utilisation (Imprimerie uniquement)

;

LR

Libellé long Mode d'utilisation (Imprimerie uniquement)

$

FTC

Quantité horaire moyenne standard (cadence standard)

Cadence standard (soit la cadence standard, soit le temps standard exprimé sous forme de cadence)

%

FTC

Temps prévu (prorata quantité)

Recalcul du temps prévu, issu de la cadence prévue ou du temps prévu, au prorata de la quantité réalisée.

Le prévu est différent du standard dans la mesure où le standard a pu être modifiée ponctuellement pour un dossier.

_

FTC

Temps prévu (prorata temps)

Recalcul du temps prévu, au prorata du temps total réellement passé.

Exemple :

Prévu 4h00. Temps passé total : 5h00.

Temps de la ligne en cours de traitement : 2h00

Temps prévu pour cette ligne : 2*5/4 = 2h30

à

FTC

Cadence standard du devis

Modification de la méthode de calcul

La ligne de totalisation est égale à la somme des quantités réelles (Colonne O) divisée par la somme des temps prévus.

Le temps prévu est égal à la quantité réelle (Colonne O) divisée par la cadence standard du devis (Colonne à).

Voir l'option Ocp

ç

FTC

Pourcentage d'écart entre la cadence réelle et la cadence standard du devis

Modification de la méthode de calcul

La ligne de totalisation est égale au pourcentage d'écart entre la cadence réelle (Colonne 0 Zéro) et la cadence standard du devis (Colonne à).

Voir l'option Ocp

@

FTC

Colonne calculée

è

Temps moyen de calage

Le temps moyen de calage -ci est égal au temps réel de calage divisé par le nombre de calages.

La ligne de totalisation est égale à la somme des temps réels de calage divisée par la somme du nombre de calages.

:

Pourcentage d'écart entre le temps moyen de calage et le temps standard de calage

Le temps standard de calage est égal au temps de calage du devis multiplié par 100.

La ligne de totalisation est égale au pourcentage d'écart entre le temps moyen de calage et le temps standard de calage.

Le temps standard de calage est égal à la somme des temps prévus de calage divisée par la somme du nombre de calages, puis multiplié par 100.

Le temps prévu de calage est égal au nombre de calages divisé par le temps standard de calage.

Le temps standard de calage est égal au temps de calage du devis multiplié par 100.

Valeur alpha 3

Caractères 1 à 35 | Fonctions de tri / rupture Ces fonctions sont reprises en détail ci-après. Voir Paramétrage des fonctions sous ce tableau.
Caractères 36 à 50 | Réservés à des extensions futures
Caractère 51 | Edition de la 1ère ligne de note des lignes de temps (N/O, N par défaut)
Caractères 52 à 54 | Types de notes
Caractère 55 | Edition d'un total général (O/N, N par défaut)
Caractère 56 | Edition des lignes de détail (O/N, N par défaut)
Caractère 57 | Edition épurée (case à cocher)

alpha3[1,35] - Paramétrage des fonctions

Pour chacun des 5 niveaux, le paramétrage est le suivant :

  • Définition des niveaux
    Dans les caractères 1 à 5, vous définissez de 1 à 5 niveaux de tri avec ou sans rupture.

  • Définition des colonnes
    Dans les caractères 6 à 10, vous définissez les colonnes (voir alpha 2) devant faire l'objet de tris / ruptures pour chaque niveau correspondant.
    Laissez à blanc si le caractère 1 à 5 correspondant est à     I (inactif).

  • Total après chaque rupture
    Dans les caractères 11 à 15, vous indiquez si vous voulez un total après chaque rupture.
    Les lignes de totaux sont encadrées par deux lignes de tirets.
    Toutefois, si l'on n'imprime pas les lignes détails (alpha3[56] = N), la ligne de total correspondant à la sous-rupture de niveau le plus bas (numéro de niveau maximum) est imprimée SANS ces deux lignes de tirets. C'est à dire qu'elle se comporte comme une ligne détail.
    Laissez à blanc si le caractère 1 à 5 correspondant n'est pas     R (pas de rupture).

  • Saut de page après chaque rupture
    Dans les caractères 16 à 20, vous indiquez si vous voulez un saut de page après chaque rupture.
    Utilisé principalement pour les ruptures de haut niveau
    Laissez à blanc si le caractère 1 à 5 correspondant n'est pas     R (pas de rupture).

  • Saut de ligne avant chaque rupture
    Dans les caractères 21 à 25, vous indiquez si vous voulez un saut de ligne avant chaque rupture.
    Laissez à blanc si le caractère 1 à 5 correspondant n'est pas     R (pas de rupture).

  • Entête de rupture
    Dans les caractères 26 à 30, vous indiquez si vous voulez une entête de rupture.
    Laissez à blanc si le caractère 1 à 5 correspondant n'est pas     R (pas de rupture).

  • Tri
    Dans les caractères 31 à 35, vous indiquez le type de tri souhaité pour chacun des 5 niveaux.
    Laissez à blanc si le caractère 1 à 5 correspondant est à     I (inactif).

Fonction | Niveau 1 | Niveau 2 | Niveau 3 | Niveau 4 | Niveau 5
R = tri avec rupture, T = tri sans rupture, I = inactif (par défaut) | alpha3[1] | alpha3[2] | alpha3[3] | alpha3[4] | alpha3[5]
Zone sur laquelle effectuer le tri / rupture | alpha3[6] | alpha3[7] | alpha3[8] | alpha3[9] | alpha3[10]
Edition d'un total après chaque rupture (O/N, N par défaut) | alpha3[11] | alpha3[12] | alpha3[13] | alpha3[14] | alpha3[15]
Saut de page après chaque rupture (O/N, N par défaut) | alpha3[16] | alpha3[17] | alpha3[18] | alpha3[19] | alpha3[20]
Saut de ligne avant chaque rupture (O/N, N par défaut) | alpha3[21] | alpha3[22] | alpha3[23] | alpha3[24] | alpha3[25]
Entête de rupture : O = Oui, N = Non, S = Soulignée (par défaut) | alpha3[26] | alpha3[27] | alpha3[28] | alpha3[29] | alpha3[30]
Tri : C = croissant (par défaut), D = décroissant | alpha3[31] | alpha3[32] | alpha3[33] | alpha3[34] | alpha3[35]

Exemple

1 2 3

12345678901234567890123456789012345

RRRTIeaCF OOO ONN NOO OOO CCCD

Code section (colonne e) : tri avec rupture en ordre croissant, total à chaque rupture, saut de page après chaque rupture, entête de rupture

Code opération (colonne a) : tri avec rupture en ordre croissant, total à chaque rupture, saut de ligne avant chaque rupture, entête de rupture

Code opérateur (colonne C) : tri avec rupture en ordre croissant, total à chaque rupture, saut de ligne avant chaque rupture, entête de rupture

Date de saisie (colonne F) : tri sans rupture en ordre décroissant

Le niveau 5 est inutilisé dans cet exemple.

Valeur alpha 4

Caractères 1 à 60

Titre de l'état

Note triées

CALCUL

9 Numéro de formule

10,60 Formule en notation polonaise inverse

a = colonne K : Temps total en heures

b = colonne O : Quantité

c = colonne P : Rebut

d = colonne x : Temps unitaire standard en heures

e = colonne y : Temps unitaire réel en heure

f = colonne z : Temps standard en heures

g = colonne 0 : Quantité horaire moyenne réelle

h = colonne 1 : Temps réel au mille en heures

i = colonne 2 : Temps standard au mille en heures

j = colonne 3 : Ecart temps réel / temps standard en heures

k = colonne 5 : Temps type TTR 1 en heures

l = colonne 6 : Temps type TTR 2 en heures

m = colonne 7 : Temps type TTR 3 en heures

n = colonne 8 : Temps type TTR 4 en heures

o = colonne 9 : Temps type TTR 5 en heures

p = colonne plus : Quantité type TTR 1

q = colonne moins : Quantité type TTR 2

r = colonne inférieur : Quantité type TTR 3

s = colonne divise : Quantité type TTR 4

t = colonne égal : Quantité type TTR 5

u = colonne supérieur : Coût type TTR 1

v = colonne exclamation : Coût type TTR 2

w = colonne par_ouvrante : Coût type TTR 3

x = colonne par_fermante : Coût type TTR 4

y = colonne point : Coût type TTR 5

z = colonne dollar : Quantité horaire moyenne standard

A = colonne interrogation: Gâche type TTR 1

B = colonne crochet_ouvr : Gâche type TTR 2

C = Colonne crochet_ferm : Gâche type TTR 3

D = Colonne & : Gâche type TTR 4

E = Colonne ‚ : Gâche type TTR 5

Exemples de formule

ab/ : Vous divisez le temps total par la quantité

ab/c* : Vous divisez le temps total par la quantité et vous le multipliez ensuite par la quantité rebutée.

CUMUL_

Par défaut, si cette note n'est pas stipulée, toutes les colonnes sont cumulées.

On paramètre donc cette note quand il y a des colonnes que l'on ne veut pas cumuler.

7 Caractère de définition de la colonne

Les colonnes autorisées sont marquées C dans la liste des colonnes en alpha 2.

8 Numéro de la colonne calculée quand le caractère 7 = @

Les valeurs possibles sont 1 à 9. La valeur 10 est représentée par le 0.

9,14 Niveaux de rupture (O/N)

On a 6 caractères car on dispose de 5 ruptures paramétrables et d'une totalisation générale.

On peut donc ainsi préciser pour quelle rupture la colonne est cumulable.

ENVIRONNEMENT

15,17 Code environnement

FICHIER_

Transfert dans un fichier

9,11 Numéro de la colonne de début de zone

12,14 Numéro de la colonne de fin de zone

15 Type de la ligne

C Constante

V Variable

Si type de la ligne = C :

16,60 Constante (blancs compris)

Si type de la ligne = V :

16 Code de la colonne à éditer défini plus haut

16,18 Dans le cas d'une colonne calculée :

@NN où NN correspond au numéro de la colonne calculée

LARGE_

7 Colonne

Les colonnes autorisées sont marquées L dans la liste des colonnes en alpha 2.

9,11 Largeur de la colonne

S

2,60 Complément de sélection sur fab2

TITRE_

7 Colonne

Les colonnes autorisées sont marquées T dans la liste des colonnes en alpha 2.

8 Longueur. Uniquement si caractère 7 = @

Les valeurs possibles sont 1 à 9. La valeur 10 est représentée par le 0.

9,38 Définition du titre

TYPE_TTR

Colonnes TTR à règle de remplissage paramétrables

9 Numéro du TTR (valeurs possibles : 1 à 5)

11,12 Numéro de caractère sur le TTR (valeurs possibles : 1 à 60)

14 Nombre de valeurs de ce caractère (valeurs possibles : 1 à 5)

16,20 Liste des valeurs de ce caractère

22 On impute à ce TTR les lignes de temps sans TTR (les lignes dont le TTR est à blanc) (O/N)

24 Cumul des temps des responsables (O/N)

25 Cumul des temps des supplémentaires (O/N)

26 Cumul des temps des aides (O/N)

27 Cumul des temps des mobiles (O/N)

29 Cumul des quantités des responsables (O/N)

30 Cumul des quantités des supplémentaires (O/N)

31 Cumul des quantités des aides (O/N)

32 Cumul des quantités des mobiles (O/N)

34 Cumul des coûts des responsables (O/N)

35 Cumul des coûts des supplémentaires (O/N)

36 Cumul des coûts des aides (O/N)

37 Cumul des coûts des mobiles (O/N)

39,50 Libellé de ce type de TTR

51 Cumul des gâches des responsables (O/N)

52 Cumul des gâches des supplémentaires (O/N)

53 Cumul des gâches des aides (O/N)

54 Cumul des gâches des mobiles (O/N)

USING

7 Colonne

Les colonnes autorisées sont marquées F dans la liste des colonnes en alpha 2.

8 Longueur. Uniquement si caractère 7 = @

Les valeurs possibles sont 1 à 9. La valeur 10 est représentée par le 0.

9,38 Définition du format (using)

Fin des notes triées


v_fab1 Visualisation des phases de fabrication

Cette visualisation permet de contrôler par phase et par machine les quantités fabriquées d'affiches et de produits finis ainsi que toutes les consommations matières.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : ordre de fabrication

Exemple : -N[f0_of]

Options

Occ | Saisie d'un critère de sélection
Odp | Mise à jour de l'interface Direct Planning
Of1 | Ajout de la table fab_1_etat - Ajout des critères de tri 7 et 8
Onp | Diviser les cadences par le nombre de poses
Oop | Sélection des opérations dont l'opération précédente est terminée
Opq | Proratisation des quantités avec le cadencement de fabrication Ne sert que dans la recherche du papier prévu dans le devis (table fle_mat). Même option que dans le programme de visu des mouvements de stocks
Oss | Exécution de la visualisation sans ouverture d'écran de sélection
Ovf | Vision d'ensemble de la fabrication Cette option permet d'initialiser les colonnes nécessaires à la visu.

Valeur alpha 2

Caractère 5 | Affichage des zones de temps en heure minutes (O/N)
Caractères 15 à 17 | Longueur de la ligne éditable Sert uniquement dans l'édition Par défaut : 350 Permet d'éditer une même ligne sur plusieurs lignes.

Valeur alpha 4

Caractère 13

Accès à la visualisation des stocks du dossier en cours (O/N, N par défaut)

Notes

CODE_ETAT_PLANNING | 21,23 Code d'état de planning par défaut pour la recherche des temps Correspond à un code paramètre de type EPP
DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
PARAM_ACCES_DP0 | 21,26 Type et code du paramètre de lancement du programme Saisie des temps par dossier ou ordre de fabrication (G_dp0)
PARAM_ACC_VISU_STK | 21,26 Type et code du paramètre de lancement de la visualisation des stocks du dossier en cours
PHASE_FIN_DPL_OPERAT | 21,26 Lors de la déclaration d'une fin de phase, mettre à jour l'opérateur ayant réalisé cette action sur le dossier (via le TSC DPL) TOUTES : à chaque fin de phase , on met à jour ce TSC AUCUNE : pas de mise à jour nnnnnn : la mise à jour ne se fait que pour la phase nnnnnn
_SUP_REQ_CONSO_AFF | 21,60 Complément de requête sur la table stk0 pour le calcul de la quantité consommée Voir la zone aff_qte_conso_reelle Exemple _SUP_REQ_CONSO_AFF and s0_anu = 'N' _SUP_REQ_CONSO_AFF and s0_typ in ('CAR','RSA')
_SUP_REQ_TEMP | Complément de sélection sur la table temporaire de la visu Voir les champs de cette table en bas. La première clause doit commencer par where temp_visu. Les noms de zones de la table temporaire doivent être préfixés avec where. Exemple _SUP_REQ_TEMP where temp_visu.qte_conso_prevue > 0

Paramètres associés

PHA (Phases)

Note _CORRES_PHASE_MAT

Modes de calcul des lignes de totalisation

M Moyenne (Total / Nb de valeurs)

O Totalisation

T Total de zones temporelles

C Permet, pour une zone calculée, d'effectuer le calcul à partir de zones cumulées
Intéressant pour tous les calculs non linéaires.
Ainsi on calculera, par exemple, le pourcentage du total de la colonne X par rapport à la colonne Y.
En effet, les opérations de somme ou moyenne de valeurs n'ont aucun sens pour les pourcentages.

Ordres de tri disponibles

Avec l'option Of1 | Sans l'option Of1 | Tri
1 | 1 | Numéro phase
2 | 2 | Opération
3 | 3 | Section
4 | 4 | Machine
5 | 5 | Termine
6 | 6 | Laize onduleuse
7 |  | Date planifiée
8 |  | Heure planifiée
9 | 7 | Numéro d'OF
15 | 13 | Tri sur la date de mise à jour

Listes de noms de zones autorisés

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Toutes les zones du package Tiers

Toutes les zones de la table fab0

Toutes les zones de la table fab1

Toutes les zones de la table fab_1_etat.

Table des opérations

o0_lib | Libellé de l'opération
o0_ope | Code opération
o0_sec | Code section
o0_sop | Code sous-opération

Table des entêtes de commandes

ec_ar | AR à éditer
ec_c1 | zone paramétrée de l'entête
ec_cli |
ec_cli_final nom_ec_cli_final ec_cli_final_adr | Client final Nom Adresse
ec_datc | Date de la commande
ec_date_client | Date du client
ec_ref ec_ref_2 | Référence de la commande client 2ème Référence de la commande client
ec_suiv | Suivi de la commande
ec_texte | Libellé de la commande
ec_transp | Code transporteur

Table des lignes de commandes

lc_cderat | Commande de rattachement
lc_delcli | Délai client
lc_delfab | Délai de fabrication
lc_delrep | Délai répondu
lc_lcderat | Ligne de commande de rattachement
lc_lib | Libellé sur la ligne de commande
lc_qtecde | Quantité commandée de la ligne de commande
lc_qtefab | Quantité fabriquée de la ligne de commande
lc_qtelan | Quantité lancée de la ligne de commande
lc_rstfab | reste à fabriquer de la commande

Table temporaire (valeurs calculées) - Autres zones

aff_phase | Code de l'affiche de l'OF. Correspond au produit associé à l'enregistrement de l'entité. Exemple : 10120001-101/1
aff_qte_conso_reelle | Quantité consommée réelle
aff_qte_fab_prevue | Quantité prévue fabriquée. Cette quantité est recherchée dans les cadencements de fabrication
aff_qte_fab_reelle | Quantité prévue fabriquée. Cette quantité est recherchée dans les cadencements de fabrication
aff_qte_conso_prevue | Quantité prévue de consommation
aff_date_conso_reelle | Date réelle de consommation
cad_p | Cadence prev.=f1_Quantité l/f1_tp
cad_r | Cadence real.=f1_Quantité r/f1_tr
code_op_prec | Code de l'opération précédente
code_op_suiv | Code de l'opération suivante
der_ope_ter | Code de la dernière opération terminée
des_compo_tech | Libellé Code composition technique de l'article
des_matiere_prevue | Désignation de la matière prévue
des_qualite_matiere | Libellé Code composition l'article
des_sfm_compo | Libellé sous-famille composition technique
fam_compo | Famille composition technique
fam_mat |
fam_phase | Code famille de la matière du champ mat_phase
fin_op_prec | Fin de l'opération précédente D si elle est commencée N si rien de fait F si elle est terminée
laize |
laize_coupe |
laize_reelle | Laize réelle consommée. Ce champ est issu de la table fab3.
largeur_prevue | Largeur la matière prévue. Elel est issue du devis (table fle_mat)
libc_f0_uni_prod |
libc_f1_etat_plan |
mach_ope_suiv |
mat_phase | Code de la matière associée à la phase machine Correspond au champ f0_prod de la table fab0. Le f0_prod correspond à l'OF 10120001-101/1/01501
matiere_prevue | Code matière prévue. elle est issue du devis (table fle_mat)
mlineaire |
nb_op_restantes | Nombre d'opérations restant à effectuer après l'opération éditée
nb_palettes |
outils |
pf_phase | Code du PF de l'OF en cours. Ces PF sont recherchés dans les cadencements de fabrication. Il y aura autant de lignes dans la visu que de codes PF.
pf_qte_fab_prevue | Quantité prévue fabriquée. Cette quantité est recherchée dans les cadencements de fabrication.
pf_qte_fab_reelle | Quantité réelle fabriquée. Cette quantité est recherchée dans les cadencements de fabrication.
phase_mat | Phase de la matière associée à la phase machine. Correspond au champ f0_of de la table fab0. Si le champ f0_of est 10120001-101/1/01501, le code phase_mat sera égal à 01501
pointages |
pres_notes | Présence de notes (O) pour l'OF et la phase
qte_conso_prevue | Quantité prévue consommée de la matière. Attention : pour cette quantité le cumul est fait sur la 1ère entité.
qte_conso_reelle | Quantité réelle consommée de la matière. Cumul de fab3 si calcul par laize.
sfm_compo | Sous-famille composition technique
solde | Temps prévu - Temps réalisé
tps_affectable | Temps affectable au dossier (somme des temps présents dans fab2 dont le type de travail est paramétré comme imputable au dossier) Cette colonne peut être utilisée dans les formules de calcul
tps_non_affectable | Temps non affectable au dossier (somme des temps présents dans fab2 dont le type de travail est paramétré comme non imputable au dossier) Cette colonne peut être utilisée dans les formules de calcul.
temps_prev_restant | Si quantité lancée et quantité réalisée différentes de zéro : Temps = Temps prévu préparation + temps prévu réalisé X Qé réalisée / Qté lancée Sinon Temps = Temps prévu total
vol_prev | Nombre de volumes prévu spécifique reliure = p_f0.f0_qtel On va chercher le nombre de volumes prévu au lancement
vol_rel | Nombre de volumes réalisé spécifique reliure En reliure, les phases sont figées. On va lire la fiche de fabrication pour réajuster les quantités. Exemple pour la phase 2152 pliure Hors texte 6 p. Si, dans la fiche de fabrication, on constate qu'il y a 2 hors textes de 6 pages, les quantités réalisées seront divisées par 2 pour obtenir le nombre de volumes prévu.
using | Voir #VI


Analyse par centres de coût et machines

Analyse par centres de coût et machines sp_mac1

Valeurs numériques

1 | Borne de début de la plage horaire
2 | Borne de fin de la plage horaire

Options

Opl | Rupture sur la plage horaire
Oor | Tri dans l'ordre des valeurs issue du fichier paramètre TMC <code type machine de la machine en cours> (Par défaut tri par code type machine de la machine en cours)

Valeur alpha 2

Caractères 1 à 30

Paramétrage des colonnes d'édition. Valeur par défaut : ABCDEFGHIJKLMNOPQRST

Col | Libellé | Pour info : zone | Pour info : mode de calcul
A | Code machine | ff_machine |
B | Temps travaillé | ff_tps_trav |
C | Nombre de calages | ff_nb_cal |
D | Temps de calage | ff_tps_cal |
E | Temps pour opérations spécifiques | ff_tps_ope | Le libellé est en A2[31,39]
F | Temps de roulage | ff_tps_rou |
G | Nombre de passages | ff_nb_pass |
H | Moyenne sur roulage | ff_m_rou | ff_nb_pass / ff_tps_rou
I | Moyenne sur calage + roulage | ff_m_calrou | ff_nb_pass / (ff_tps_rou + ff_tps_cal)
J | Moyenne sur temps travaillé | ff_m_tpstra | ff_nb_pass / ff_tps_trav
K | Temps prévu | ff_tps_prevu |
L | Pourcentage d'occupation machine | ff_occup |
M | Total des arrêts | ff_tot_arret |
N | Pourcentage d'arrêt | ff_pc_arret | (ff_tot_arret / ff_tps_trav) * 100
O | Total et Pourcentage d'arrêt de type 1 | ff_tot1_arret ff_pc1_arret | (ff_tot1_arret / ff_tps_trav) * 100
P | Total et Pourcentage d'arrêt de type 2 | ff_tot2_arret ff_pc2_arret | (ff_tot2_arret / ff_tps_trav) * 100
Q | Total et Pourcentage d'arrêt de type 3 | ff_tot3_arret ff_pc3_arret | (ff_tot3_arret / ff_tps_trav) * 100
R | Fabrication moyenne (calage) | ff_fm_cal | ff_tps_cal / ff_nb_cal
S | Fabrication moyenne (roulage) | ff_fm_rou | ff_tps_rou / ff_nb_cal
T | Fabrication moyenne (passage) | ff_fm_pass | ff_nb_pass / ff_nb_cal
U | Taux horaire moyen calage | ff_tho_cal | ff_val_cal / ff_tps_cal
V | Montant calage | ff_val_cal |
W | Taux horaire moyen roulage | ff_tho_rou | ff_val_rou / ff_tps_rou
X | Montant roulage | ff_val_rou |
Y | Montant total (calage + roulage) | ff_val_tot | ff_val_cal + ff_val_rou

Caractères 31 à 39

Libellé de l'opération spécifique (si A2[1,30] contient le code E entre autres).

Par défaut : " BAT/BAD "

Valeur alpha 3

Caractères 1 à 3

Code environnement pour le calcul de la valorisation

Notes

_SUP_FAB2

Complément de sélection sur les temps saisis (Accès aux tables fab1 et fab2)

Utilisé par exemple pour exclure des statistiques les enregistrements correspondant aux opérations de contrôle.

Paramètres nécessaires

#CF ATL A3[17] | Méthode de prise en compte des plages horaires
TTR | TTR A1[1] Réservé à Volume Software. Doit en général être à blanc TTR A1[2 ]Temps affectable au dossier TTR A1[3] Calage à comptabiliser (O/N) TTR A1[7] Temps d'arrêt à comptabiliser (O/N) TTR A1[8] Temps travaillé à comptabiliser (O/N) TTR A1[9] Temps de calage à comptabiliser (O/N) TTR A1[10] Temps de roulage à comptabiliser (O/N) TTR A1[11] Temps d'arrêt à comptabiliser (O/N) TTR A1[13] Temps d'arrêt 1 à comptabiliser (O/N) TTR A1[14] Temps d'arrêt 2 à comptabiliser (O/N) TTR A1[15] Temps d'arrêt 3 à comptabiliser (O/N)
LIB ARR | LIB A1[1,15] Libellé type arrêt 1 LIB A1[16,30] Libellé type arrêt 2 LIB A1[31,45] Libellé type arrêt 3
#CF MA1 | Valeurs par défaut (voir ci-dessus les paramètres identiques dans TTR) A1[2 ]Temps affectable au dossier A1[3] Calage à comptabiliser (O/N) A1[7] Temps d'arrêt à comptabiliser (O/N) A1[8] Temps travaillé à comptabiliser (O/N) A1[9] Temps de calage à comptabiliser (O/N) A1[10] Temps de roulage à comptabiliser (O/N)


Analyse des arrêts machine

Analyse des arrêts machine arret

Cet état permet une analyse des arrêts par machine (physique ou fictive).

Toute l'analyse est basée sur la saisie journalière des temps; elle est principalement issue de l'utilisation des TTR.

Les arrêts machines sont classés dans 3 grandes familles paramétrables :

Exemples de paramétrage

Famille 1 : Pannes

Famille 2 : Attentes

Famille 3 : Entretien

Les libellés des 3 types d'arrêts machines sont paramétrés dans LIB ARR.

Paramétrage des TTR

A1[7]doit être à O s'il s'agit d'un TTR devant figurer dans cet état.

A1[11] doit être à O

A1[13] doit être à O s'il s'agit d'un arrêt de la famille 1 (Pannes dans notre exemple)

A1[14] doit être à O s'il s'agit d'un arrêt de la famille 2 (Attentes dans notre exemple)

A1[15] doit être à O s'il s'agit d'un arrêt de la famille 3 (Entretien dans notre exemple)

Remarque : ces flags peuvent être modifiés sans impact sur le prix de revient.

La création d'un index sur le fichier fab1 cle (f1_soc,f1_mach) améliore considérablement les temps de réponse de cette édition.

Valeur alpha3

Caractères 1 à 3

Code environnement pour le calcul de la valorisation


Récapitulatif des temps salarié par jour

Récapitulatif des temps salarié par jour sp_tps_sal

Paramétrage interactif

On demande à l'utilisateur s'il veut le récapitulatif par TTR.

Si OUI On lui demande s'il veut uniquement le récapitulatif.

Options

-Ocm | Edition des temps en centièmes
-Ohm | Edition des temps en heures minutes
-Os1 | Supprime le saut de page par salarié
-Ore | SUPPRIME Edite un récapitulatif par TTR : à ne plus utiliser (choix dans le programme)

Valeur alpha2

Titre de l'état

Notes

SUP_FAB2

21,60 Complément de sélection sur fab2


Analyse des temps non affectables

Analyse des temps non affectables list_ttr

Options

-Ott | N'affiche que le récapitulatif des TTR (le paramétrage des colonnes ne modifie pas le récapitulatif)
-Ors | Edition du récapitulatif par section
-Ohm | Edition en heures minutes
-Ome | Mécanique

Valeur alpha 2

Caractères 1 à 30 | Paramétrage des colonnes de l'édition : par défaut ABCDE A Code machine B Code TTR C Libellé du TTR D Temps E Observation F Numéro d'OF G Opération H Coût horaire de l'opération I Valeur J Cadence K Temps moyen L Quantité saisie M Quantité rebutée ou gâchée
Caractères 31 à 45 | Libellé famille 1 TTR : voir TTR alpha1[20]
Caractères 46 à 60 | Libellé famille 2 TTR : voir TTR alpha1[20]

Valeur alpha 3

Caractères 1 à 3

Code environnement pour le calcul de la valorisation


Récapitulatif des TTR par salarié et par section

Récapitulatif des TTR par salarié et par section rec_ttr

Options

-Occ | Tri par centre de coût plutôt que par section (par défaut le tri se fait par section / salarié)
-Ore | Récapitulatif par TTR
-Osa | Récapitulatif par salarié / section
-Ohm | Edition des temps en heures / minutes


Edition et historisation des temps par section

Edition et historisation des temps par section l_t_s

Sans paramètre : édite sans historiser les temps passés (réalisés) affectables au dossier (si TTR alpha[2] = D, ou si pas de TTR)

Options

-Opr | Edite les temps prévus, ainsi que l'écart temps
-Ohp | Historise ce qui est édité (sauf les lignes d'écarts et de totalisations)

Valeur numérique 1

Valeur de début de la section (par défaut 1)

Valeur numérique 2

Valeur de fin de la section (par défaut 15)

Remarque

On affecte une valeur ou numéro à un code section donne , en saisissant le numéro de colonne de la section dans la valeur numérique 2 du paramètre SEC.

On ne peut historiser au maximum que les sections valorisées de 1 à 75.

ATTENTION S'adresse à l'imprimerie comme à la mécanique. Cependant la section en imprimerie est représentée par le premier code du triplet SEC OPE SOP de l'opération.


Décompte des éléments variables de paie

Décompte des éléments variables de paie dpaie

Options Valeurs numériques Valeur alpha 2 Notes Paramétrage des règles

Options triées

Odt | Détail TTR en bout d'état
Ofi | Edition dans un fichier
Opg | Pas de détail TTR général (actif si option Odt)
Oph | Pas de détail TTR hebdomadaire (actif si option Odt)
Opj | Pas de détail TTR journalier (actif si option Odt)
Opm | Pas de détail TTR mensuel (actif si option Odt)
Ops | Pas de détail TTR salarié (actif si option Odt)
Orc | Initialisation repos compensateur Permet d'initialiser le cumul heures supplémentaires Mettre dans le code matricule de chaque employé Caractères 1 à 4 Jour - Mois début calcul Caractères 5 à 8 Cumul Heures en heures - centièmes Exemple Calcul à partir du 31/01/1994 avec 19H50 pour du 01/01/1994 au 30/01/1994 Caractères 1 à 4 3101 Caractères 5 à 8 1950
Orp | Recherche du nombre de jours dans la semaine courante dans le calcul des heures annualisées
Ose | Avec semaine 0
Oze | Les résultats à zéro apparaissent sous la forme 0 (sinon ils apparaissent sous la forme de [blanc])

Valeurs numériques

1 | Nombre de colonnes de TTR en bout d'état (option Odt) (1 par défaut)
2 | Type de libellé du TTR en bout d'état (option Odt) 1 Code TTR (valeur par défaut) 2 Libellé court du TTR 3 Libellé long du TTR 4 Trois premiers caractères du libellé court du TTR 5 Trois premiers caractères du libellé long du TTR

Valeur alpha 2

Caractères 1 à 3 | Code du TTR par défaut pris en compte lorsqu'il n'y a pas de TTR saisi sur la ligne.
Caractères 4 à 60 | Paramétrage des colonnes A Code employé B Nom de l'employé C Date sous la forme Lu 04/05 D Compteur 1 (= Temps dû) E Compteur 2 F Compteur 3 G Compteur 4 H Compteur 5 I Compteur 6 J Compteur 7 K Compteur 8 L Compteur 9 M Compteur 10 N Compteur 11 O Compteur 12 P Compteur 13 Q Compteur 14 R Compteur 15 S T U V W X Y Z Matricule paie de l'employé a Calcul interprété numéro 1 b Calcul interprété numéro 2 c Calcul interprété numéro 3 d Calcul interprété numéro 4 e Calcul interprété numéro 5 f Calcul interprété numéro 6 g Calcul interprété numéro 7 h Calcul interprété numéro 8 i Calcul interprété numéro 9 j Calcul interprété numéro 10 k Calcul compilé numéro 1 l Calcul compilé numéro 2 m Calcul compilé numéro 3 n Calcul compilé numéro 4 o Calcul compilé numéro 5 p Calcul compilé numéro 6 q Calcul compilé numéro 7 r Calcul compilé numéro 8 s Calcul compilé numéro 9 t Calcul compilé numéro 10

Remarque

Calcul temps dû des jours fériés. Les jours fériés sont traités comme le dimanche.

Mettre 24 et non 0 dans le temps du calendrier de l'employé. Le programme mettra 0 dans le temps dû et dans le code jour.

Notes triées

ARRONDI_COMPTEUR_

Possibilité d'arrondir les minutes des compteurs journaliers 2 à 15 (E à R) Voir A2[4,60]

L'arrondi du compteur journalier 1 (D) qui correspond au temps dû n'est pas autorisé.

Dans ces notes, on définit des tranches en minutes. 100 notes maxi.

Pour chaque tranche, on précise une valeur arrondie en minutes.

18,19 Numéro de compteur journalier. Obligatoire. Valeurs autorisées : 2 à 15

21 Signe du début de la tranche. Obligatoire. Valeurs autorisées : = et >

= correspond à >=

22,23 Début de la tranche en minutes. Obligatoire. Valeurs autorisées : 0 à 60

Le début de la tranche doit être inférieur ou égal à la fin de la tranche.

24 Signe de la fin de la tranche. Obligatoire. Valeurs autorisées : = et <

= correspond à <=

25,26 Fin de la tranche en minutes. Obligatoire. Valeurs autorisées : 0 à 60

La fin de la tranche doit être supérieure ou égale au début de la tranche.

27,28 Valeur arrondie en minutes. Obligatoire. Valeurs autorisées : 0 à 60

Exemples

ARRONDI_COMPTEUR_02 =00=0800

ARRONDI_COMPTEUR_02 >08<2315

ARRONDI_COMPTEUR_02 =23<3830

ARRONDI_COMPTEUR_02 =38<5345

ARRONDI_COMPTEUR_02 =53<6060

CC

Paramétrage de chaque colonne

3 Code colonne

4 à 13 Libellé colonne

CG

Paramétrage des règles générales

Caractères 3 à 52 Règle générale

Caractère 53

O Valeur éditée

N Valeur non éditée

I Pas d'impression de la ligne

Caractère 54

N Le résultat peut être négatif ou positif

Exemples

-2 ---> -2

2 ---> 2

O Le résultat doit être positif

Exemples

-2 ---> 0

2 ---> 2

R Raz du cumul précédent avant cumul

CH

Paramétrage des règles hebdomadaires

Caractères 3 à 52 Règle hebdomadaire

Caractère 53

O Valeur éditée

N Valeur non éditée

I Pas d'impression de la ligne

Caractère 54

N Le résultat peut être négatif ou positif

Exemples

-2 ---> -2

2 ---> 2

O Le résultat doit être positif

Exemples

-2 ---> 0

2 ---> 2

R Raz du cumul précédent avant cumul

CJ

Paramétrage des règles journalières

Caractères 3 à 52 Règle journalière

Caractère 53

O Valeur éditée

N Valeur non éditée

I Pas d'impression de la ligne

Caractère 54

N Le résultat peut être négatif ou positif

Exemples

-2 ---> -2

2 ---> 2

O Le résultat doit être positif

Exemples

-2 ---> 0

2 ---> 2

R Raz du cumul précédent avant cumul

CM

Paramétrage des règles mensuelles

Caractères 3 à 52 Règle mensuelle

Caractère 53

O Valeur éditée

N Valeur non éditée

I Pas d'impression de la ligne

Caractère 54

N Le résultat peut être négatif ou positif

Exemples

-2 ---> -2

2 ---> 2

O Le résultat doit être positif

Exemples

-2 ---> 0

2 ---> 2

R Raz du cumul précédent avant cumul

CS

Paramétrage des règles salariés

Caractères 3 à 52 Règle salarié

Caractère 53

O Valeur éditée

N Valeur non éditée

I Pas d'impression de la ligne

Caractère 54

N Le résultat peut être négatif ou positif

Exemples

-2 ---> -2

2 ---> 2

O Le résultat doit être positif

Exemples

-2 ---> 0

2 ---> 2

R Raz du cumul précédent avant cumul

DT

Paramétrage des cumuls d'heures par tranches horaires

Caractères 3 à 6 Heure début de la tranche

Caractères 7 à 10 Heure fin de la tranche

Caractère 11 Type d'employé

E Equipe

I Individuel

[blanc] Totalité

Caractère 12 Code plage

1 Journée

2 Matin

3 Après-midi

4 Nuit

[blanc] Totalité

Caractères 13 à 14 Numéro de compteur

02 E

03 F

15 R

Caractère 15 Type d'heures à cumuler. TTR alpha1[8]

O Heures travaillées

N Heures non travaillées

[blanc]Totalité

Remarque Si HD > HF, rajouter 2400 sur HF

Exemple HD 2100 et HF 0500 ==> HD 2100 et HF 2900

FICHIER_

Ces lignes seront prises en compte si l'option Ofi est active.

Caractères 9 à 11 Colonne de début

Caractères 12 à 14 Colonne de fin

Caractères 15 Type de la ligne

C Caractères 16 à 60 : constante

B Blancs de la colonne début à la colonne fin

V Caractère 16 = 1 Code employé

Caractère 16 = 2 Libellé de la colonne

Caractère 16 = 3 Valeur de la colonne

Caractères 17 à 26 using dans le cas où car.15=V et car.16 = 3

HA

Paramétrage des heures annualisées (Attention, il ne doit y en avoir qu'un !)

10 valeurs autorisées pour les numéros de calcul interprétés ci-dessous :

01 a

02 b

03 c

04 d

05 e

06 f

07 g

08 h

09 i

10 j

Caractères 3 à 4 Numéro calcul interprété heures annualisées

Caractères 5 à 6 Numéro calcul interprété temps du

Caractères 7 à 8 Numéro calcul interprété temps présence

Caractères 9 à 10 Numéro calcul interprété temps brisure

PC

Paramétrage des compteurs à prendre en compte

Attention, il ne doit y avoir qu'une seule ligne.

Pour prendre en compte tous les compteurs, ne rien mettre.

Seuls les compteurs dont les lignes CC sont saisies sont calculés et donc utilisables.

3 Compteur 2 (E)

4 Compteur 3 (F)

5 Compteur 4 (G)

6 Compteur 5 (H)

7 Compteur 6 (I)

8 Compteur 7 (J)

9 Compteur 8 (K)

10 Compteur 9 (L)

11 Compteur 10 (M)

12 Compteur 11 (N)

13 Compteur 12 (O)

14 Compteur 13 (P)

15 Compteur 14 (Q)

16 Compteur 15 (R)

PT

Paramétrage des TTR à prendre en compte. (Attention, 45 TTR maximum !)

Pour prendre en compte tous les TTR, ne rien mettre.

Caractères 3 à 5 : 1er TTR

Caractères 6 à 8 : 2ème TTR

Caractères 9 à 11 : 3ème TTR

Caractères 12 à 14 : 4ème TTR

Caractères 15 à 17 : 5ème TTR

Caractères 18 à 20 : 6ème TTR

Caractères 21 à 23 : 7ème TTR

Caractères 24 à 26 : 8ème TTR

Caractères 27 à 29 : 9ème TTR

Caractères 30 à 32 : 10ème TTR

Caractères 33 à 35 : 11ème TTR

Caractères 36 à 38 : 12ème TTR

Caractères 39 à 41 : 13ème TTR

Caractères 42 à 44 : 14ème TTR

Caractères 45 à 47 : 15ème TTR

RC

Paramétrage du repos compensateur (Attention, il ne doit y en avoir qu'un !)

Le temps dû peut être fixe quelque soit le calendrier ou variable suivant le calendrier.

Si temps dû fixe, mettre un nombre d'heures sous la forme HHMM.

Si temps dû variable, mettre DU au lieu d'un nombre d'heures.

Si périodicité de calcul journalière (caractère 31 = J)

Caractères 3 à 6 Temps dû du lundi (HHMM ou DU)

Exemple 0700 ou 0750 ou 0800 ou DU

Caractères 7 à 10 Temps dû du mardi (HHMM ou DU)

Caractères 11 à 14 Temps dû du mercredi (HHMM ou DU)

Caractères 15 à 18 Temps dû du jeudi (HHMM ou DU)

Caractères 19 à 22 Temps dû du vendredi (HHMM ou DU)

Caractères 23 à 26 Temps dû du samedi (HHMM ou DU)

Caractères 27 à 30 Temps dû du dimanche (HHMM ou DU)

Si périodicité de calcul hebdomadaire (caractère 31 = H)

Caractères 3 à 6 Temps dû de la semaine (HHMM ou DU)

Exemple 3900 ou 4000 ou DU

Caractères 7 à 10 Non utilisé

Caractères 11 à 14 Non utilisé

Caractères 15 à 18 Non utilisé

Caractères 19 à 22 Non utilisé

Caractères 23 à 26 Non utilisé

Caractères 27 à 30 Non utilisé

Si périodicité de calcul mensuelle (caractère 31 = M)

Caractères 3 à 6 Temps dû du mois (HHMM ou DU)

Exemple 9900 ou 8900 ou DU

Caractères 7 à 10 Temps dû du mois (HHMM ou DU)

Exemple 7000 ou 8000 ou DU

Caractères 11 à 14 Temps dû du mois (HHMM ou DU)

Caractères 15 à 18 Temps dû du mois (HHMM ou DU)

Caractères 19 à 22 Temps dû du mois (HHMM ou DU)

Caractères 23 à 26 Temps dû du mois (HHMM ou DU)

Caractères 27 à 30 Temps dû du mois (HHMM ou DU)

Remarque

Pour obtenir le temps dû du mois si temps d fixe, on fait la somme des 7 temps dus

Exemple : Si temps dû fixe de 169H00, on peut mettre :

9900 dans le 1er temps dû

7000 dans le 2ème temps dû

0000 dans les 5 autres temps dus

<ou>

8900 dans le 1er temps dû

8000 dans le 2ème temps dû

0000 dans les 5 autres temps dus

Caractère 31 Périodicité de calcul (J-H-M)

J Journalière

H Hebdomadaire

M Mensuelle

Caractères 32 à 33 Numéro calcul interprété (01 à 10)

01 a

02 b

03 c

04 d

05 e

06 f

07 g

08 h

09 i

10 j

SS

3,60 Complément de sélection sur la table des temps (fab2)

Exemple

SSand f2_oper matches 1*

SSand f2_typtrav = #R

T

Titre de l'état (Attention, il ne doit y en avoir qu'un !)

Par défaut : ELEMENTS VARIABLES DE PAIE

Paramétrage des règles

Les 15 premiers compteurs (de D à R) sont toujours gérés en cumul.

Les 10 compteurs (a, b, c, d, e, f, g, h, i et j) sont gérés par des règles interprétées.

Les 10 compteurs (k, l, m, n, o, p, q, r, s et t) sont gérés par des règles interprétées également.

Les variables utilisées pour écrire le texte des règles interprétées portent le nom des colonnes.

Les règles suivantes ne sont pas gérées :

JA, JB, JC, JD

HA, HB, HC, HD

MA, MB, MC, MD

SA, SB, SC, SD

GA, GB, GC, GD

Variables supplémentaires

@ | Code jour traité 0 Dimanche 1 Lundi 2 Mardi 3 Mercredi 4 Jeudi 5 Vendredi 6 Samedi
& | Code plage traitée Attention, le code plage est valable pour la journée complète. Cette variable est utilisable uniquement si le salarié ne change pas de plage horaire dans sa journée. 1 Journée 2 Matin 3 Après-midi 4 Nuit
§ | Type employé traité 1 Equipe 2 Individu

Les constantes ne doivent pas contenir de décimales. Il est toujours possible de transformer un décimal par une division plus ou moins savante !!!!

Fonctions utilisables

+ Addition

- Soustraction

* Multiplication

/ Division

> Max

< Min

= Egal

) a b ) 1 si a > b 0 sinon

( a b ( 1 si a < b 0 sinon

? Si alors sinon

?45:46# Si pile != 0 alors résultat = 45, sinon résultat = 46

Chaîne entre ? et [:] = Formule pour le alors

[:] et # Formule pour le sinon

! Idem ? pour les IF imbriqués

Le [:] est remplacé par le [.]

Le # est remplacé par le [;]

$ Descend d'un niveau dans la pile

% Conserve la première décimale

Exemple Temps du / 2 D2/

Ordre de calcul des compteurs

DEFGHIJKLMNOPQRabcdefghijklmnopqrst

Les variables des règles J font référence aux cumuls sur la journée de chacun des compteurs.

Les variables des règles H font référence aux cumuls sur la semaine de chacun des compteurs J après application des règles J.

Les variables des règles M font référence aux cumuls sur le mois de chacun des compteurs H après application des règles H.

Les variables des règles S font référence aux cumuls sur le salarié de chacun des compteurs M après application des règles M.

Les variables des règles G font référence aux cumuls sur le général de chacun des compteurs S après application des règles S.


Suivi encours pliure (spécifique reliure)

Suivi encours pliure (spécifique reliure) pliure

Valeur numérique 1

Indique le nombre de jours avant la date du jour qui seront visualisés par défaut

Valeur numérique 2

Indique le nombre de jours avant la date du jour qui seront édités par défaut

Notes

EM | Opération d'emboîtage Exemple EM008EMBROU EM008EMBMAI
PL | Opération de pliure Exemple PL002P08ROU PL002P12ROU
PE | Opération de pliure extérieure Exemple PL002PLIEXT


Saisie des contrôles laboratoire

des_article_long (concaténation mp_des et mp_des2)

ec_devise, libc_ec_devise, libl_ec_devise

ec_ref_cderat

ec_sold

lc_bareme, libc_lc_bareme, libl_lc_bareme

lc_delcli

lc_delrep

lc_gen_dos_fab

lc_haut

lc_larg

lc_lieu_rgt1, libc_lc_lieu_rgt1, libl_lc_lieu_rgt1

lc_long

lc_p3

lc_prx

lc_prx_au_moins

lc_prx_au_plus

lc_prx_moins_dev

lc_prx_moins_euro

lc_prx_plus_dev

lc_prx_plus_euro

lc_qtecde

lc_qualif_appel, libc_lc_qualif_appel, libl_lc_qualif_appel, libs_lc_qualif_appel

lc_rstfab

lc_solde

lc_tva, libc_lc_tva, libl_lc_tva

lc_unvent, libc_lc_unvent, libl_lc_unvent

lc_unvent_au, libc_lc_unvent_au, libl_lc_unvent_au

lieu_destockage

mp_cond, libc_mp_cond, libl_mp_cond

mp_sbes

mp_scdef

mp_sdisp

mp_sphy

mp_sres

qte_fab_fbi

qte_raf_cda

qte_ral_cda

qte_tot_cda

quantite_initiale_sap

ref_client

sphy_sit Stock physique d'un lieu rattaché au site (dont le code site est lu sur la zone ec_c1)

zc1_lc_tva

zc1_lc_unvent

Saisie des contrôles laboratoire labo

Accès à la GED

Voir le paramètre de configuration laboratoire : #CF LAB

Types de notes : Certains types de notes sont figés pour le contrôle laboratoire :

Le type de note NCO est utilisé pour l'édition des avis de non-conformité (raisons de la non-conformité).

Le type de note AUT correspond aux notes en automatiques.

Ces deux types de notes ne doivent pas être modifiés.

Options

Oau | Lancement avec le type de contrôle AUT
Oet | Lancement avec le type de contrôle ETU pour étude
Oma | Lancement avec le type de contrôle MAN
Oof | Lancement avec le type de contrôle OF pour Ordre de Fabrication

Valeur alpha 2

A2[1,60]

Chemin complet et nom du fichier à créer lors de la génération d'un fichier texte à partir des données du contrôle laboratoire.

Valeur alpha 3

A3[1,3]

Code blocage automatique laboratoire (exemple LAB)

Notes

CODES_BLOCAGE_LABO | 21,59 Liste des codes blocage laboratoire (BLO) à prendre en compte pour la vérification de l'existence d’un contrôle laboratoire sur l'OF 13 codes de 3 caractères par ligne.
LIGPAR_RC | 10,60 Possibilité de définir des champs visualisables en bas de l'écran de revue de contrat avec l'option Ovl Paramétrage de la ligne d'affichage sous la forme suivante LLL*CCC*TTT*UUU*SL* LLL Libellé affichable à l'écran CCC Liste des champs visualisables : Cliquez ici pour afficher / masquer la Liste des champs visualisables (triée par ordre alpha) Les TSC, avec la même syntaxe d'appel que pour les visus. Exemple d'affichage de TSC : LIGPAR_RC Info Livraison*TSC_LC_LI_60F_G*30** TTT Taille de la zone UUU using SL Saut de ligne (O/N, N par défaut) Cette note est disponible dans tout programme appelant la revue de contrat : cde, labo, v_cdem
MSG_NONCONFORME_ | Affichage d'un message explicite lors de la détection d'une non-conformité 17,19 Code du test pour lequel afficher un message def Valeur par défaut (dans le cas où le code de test n'est pas paramétré Les codes sont détaillés dans le #CF LAB. 21 Type d'affichage du message N Pas de message (par défaut) W Message non bloquant B Message bloquant C Demande de confirmation 22 Valeur par défaut en cas de demande de confirmation O Oui N Non (par défaut) Cette note est prioritaire sur celle du #CF LAB.


Edition des prix de revient à partir de l'historique

Edition des prix de revient à partir de l'historique edi_pr

SPECIFIQUE

Valeurs numériques

N1

Type de tri

1

2

Options

Ocs | On ne prend pas en compte les coûts supplémentaire réels
Oec | Eclatement de la ligne commission
Oem | Eclatement de la ligne matière - Voir A4[1,3]
Oes | Edition du détail de sous-traitance
Omn | Eclatement du multi-niveaux dans l'éclatement de la ligne matière
Op2 | Utilisation du PRP2, stocké dans hist_pr de type 2 zone hp_z15 initialisé depuis la valeur de fab0.f0_cp_react
Opl | Plastique
Ose | Saisie des bornes de pourcentage pour la sélection EBIT
Osf | Edition de la sous-traitance façonnage
Otf | Tri sur famille technique de hist_pr avec hp_type = F

Valeur alpha 2

A2[1,10] | Date de début de l'analyse
A2[11,20] | Date de fin de l'analyse

Valeur alpha 3

A3[1] | Edition du détail (O/N, O par défaut)
A3[2] | Tri sur direction des ventes (O/N, N par défaut)
A3[3] | Tri sur direction des régions (O/N, N par défaut)
A3[4] | Tri sur représentant (O/N, N par défaut)
A3[5] | Tri sur client (O/N, N par défaut)
A3[6] | Tri sur article (O/N, N par défaut)
A3[7] | Tri sur commande (O/N, N par défaut)
A3[8] | Tri sur lignes de commande (O/N, N par défaut)
A3[9] | Tri sur OF (O/N, N par défaut)
A3[10] | Tri sur composition commerciale (O/N, N par défaut)
A3[11] | Tri sur famille technique (O/N, N par défaut)
A3[12] | Tri sur famille commerciale (O/N, N par défaut)

Valeur alpha 4

A4[1,3]

Type de rupture

FAM sur famille

SFM sur sous-famille (par défaut)

Notes

MSG_MULTI_NIVEAUX | 21,60 Ligne de message pour le multi-niveaux
SUP_REQ_CDE2 | 21,60 Supplément de requête sur cde2
SUP_REQ_CLI | 21,60 Supplément de requête sur cli
SUP_REQ_HIST_PR | 21,60 Supplément de requête sur hist_pr

Paramètres nécessaires

FAM A4[14,23] | Types d'article autorisés pour cette famille
REP A4[26,28} | Code structure force de vente


Epuration de la table cab_production

Epuration de la table cab_production epu_cab_production

Notes

_SUP_REQ_EPUR_CB | 21,60 Complément de requête sur la table cab_production - Obligatoire
FIC_TRACE | 21,60 Nom (et emplacement) du fichier trace - Obligatoire


Edition des encours de production

Edition des encours de production en_cours

Détail des calculs (voir note NOM_FICHIER_TRACE) :

Encours partiel = Coût support + Coût encres + Coût vernis + Coût plaques + Coût clichés + Coût Cyrels + Coût caisses + Coût palettes + Coût opérations

Coût fixe = Prix vente matière + Prix vente opération + Prix vente sous-traitance

Coût variable = Prix vente matière + Prix vente opération + Prix vente sous-traitance + Prix vente port

Prix devisé = Coût fixe + ((Coût variable X Quantité commandée) / Quantité devisée)

Abattement forfaitaire = valeur num2 du paramètre de lancement Coeff rectificatif = Montant commandé / Prix devisé

Encours net = (Encours partiel X Coeff rectificatif) - ((Montant livré + Montant en stock) X (1 - (Abattement forfaitaire / 100)))

Valeur carton = Coût support - ( Coût support X ((Quantité en stock + Quantité livrée) / Quantité commandée))

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande

Exemple : -N[lc_num]

Valeurs numériques

N1 | Pourcentage de tolérance de dépassement entre les quantités produites des postes découpe et impression
N2 | Pourcentage d'abattement forfaitaire de l'en-cours net

Options

-B | Mode batch
Ocl | Edition des dossiers clôturés Sinon, le code clôture est saisi : N Dossiers non clôturés O Dossiers clôturés blanc Dossiers non clôturés et clôturés
Osd | Pas d'édition des lignes détail OF
Otc | Totalisation client. Option utilisée si Tri Client / OF
Otr | Trace des calculs

Valeur alpha 2

A2[1,8] | Date de calcul de l'en-cours (Sous la forme JJMMAAAA) Obligatoire en mode batch Si l'en-cours doit toujours être édité à la date du jour, saisir today.
A2[9] | Type de tri. Obligatoire en mode batch 1 Tri OF 2 Tri Client / OF
A2[10,12] | Type du mouvement de stock des entrées normales de fabrication des PF. Obligatoire Le type du mouvement de stock doit être une entrée normale.
A2[13,15] | Code famille des supports du dossier de fabrication. Obligatoire EX : CAR
A2[16,18] | 16 18 Code sous-famille des supports du dossier de fabrication. Facultatif EX : FC

Valeur alpha 3

A3[1,9] | Code opération de réalisation ou de roulage de la phase impression. Obligatoire. EX : IO IOFROU
A3[10,18] | Code opération de réalisation ou de roulage de la phase découpe. Obligatoire. EX : DC DECROU
A3[19,27] | Code opération de réalisation ou de roulage de la phase façonnage. Obligatoire. EX : CO COLROU
A3[28,36] | Code opération de préparation ou de calage de la phase impression. Obligatoire. EX : IO IOFCAL
A3[37,39] | Code formule verso du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO2
A3[40,42] | Code formule recto 1er passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO1
A3[43,45] | Code formule recto 2ème passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO3
A3[46,48] | Code TTR verso du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO2
A3[49,51] | Code TTR recto 1er passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO1
A3[52,54] | Code TTR recto 2ème passage du code opération de réalisation ou de roulage de la phase impression Obligatoire. Exemple RO3

Valeur alpha 4

A4[1,3] | Code famille des encres du dossier de fabrication. Obligatoir. EX : ENC
A4[4,6] | Code famille des vernis du dossier de fabrication. Obligatoire. EX : VER
A4[7,9] | Code famille des plaques du dossier de fabrication. Obligatoire. EX : PLA
A410,12[] | Code famille des clichés du dossier de fabrication. Obligatoire. EX : CLI
A4[13,15] | Code famille des cyrels du dossier de fabrication. Obligatoire. EX : CYR
A4[16,18] | Code famille des caisses du dossier de fabrication. Obligatoire. EX : CAI
A4[19,21] | Code famille des palettes du dossier de fabrication. Obligatoire. EX : PAL
A4[31,33] | Code famille des frais de plaques de la commande. Obligatoire. EX : FRA
A4[34,36] | Code famille des frais de clichés de la commande. Obligatoire. EX : FRA
A4[37,39] | Code famille des frais de cyrels de la commande. Obligatoire. EX : FRA

Notes

SUP_REQ_FAB0 | 21, 60 Supplément de requête sur la table des dossiers de fabrication (fab0) Obligatoire en mode batch. EX : and f0_of matches "05*"
NOM_FICHIER_TRACE | 21, 60 Nom du fichier trace. Obligatoire. EX : /u/atlas/trace_en_cours


Calcul du prix de revient

_REMONTEE_MAT_AUTO XEMBALLAGE 2and f0_prod like 'ZPA%'

_REMONTEE_MAT_AUTO ZVE 3and f2_typtrav like 'A%'

La matière XEMBALLAGE sera remontée en automatique par la méthode 2 en tenant compte de la consommation des matières commençant par ZPA.

Les matières dont la racine est ZVE seront remontées en automatique par la méthode 3 en tenant compte des consommations des matières commençant par ZPA.

Dans la méthode 3, la phase concernée est déterminé en fonction de l'OF de la matière.

Si 10010005-101/1/03002, alors les phases concernées seront celles 30001 à 3009.

La phase doit être terminée et les opérations de ces phases doivent être du Roulage.

Pour les matières non tenues en stock, elles seront valorisées au prix d'achat de la fiche article.

Calcul du prix de revient cpr

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de commande

Exemple : -N[ec_num]

Valeurs numériques

1 | Valeur à déduire pour la valorisation de temps masqué (TTR à blanc) Lié à l'option Otb
2 | L I B R E

Options triées

Nx

x étant le numéro de commande à calculer

O1m

(chiffre 1 puis lettre m comme dans mouvement)

Intégration des mouvements de stock au prix du 1er mouvement de stock du lot du produit

L'option Oin doit être activée.

Oas

Suppression dans fab3 des articles Actions de service (mp_param [10] = A)

Obr

Intègre les mouvements de stock (cf paramétrage TMV) dans fab2 (remplace le traitement de sjs)

Réservé au FB1 (SPECIFIQUE)

Occ

Confirmation du calcul pour chaque commande

Ocd

Pas de mise à jour de la quantité fabriquée dans la ligne de commande

Ocf

Contrôle de la réception facture (à mettre aussi sur en_co)

Si l'option est positionnée, les lignes de sous-traitance (fab5) pour lesquelles la facture n'a pas été reçue sont prise en compte dans le prix de revient mais pas dans le calcul des encours.

Ocp

Sans cette option, les temps saisis sont valorisés avec le taux horaire de l'opération.

Avec cette option les temps saisis sont valorisés avec un taux horaire qui est une somme conditionnelle de 3 taux horaires différents

Taux = Taux opération (si o0_param[3] = O)

+ Taux machine (si o0_param [4] = O)

+ Taux salarié (si o0_param [5] = O)

Ocq

Conversion de la quantité des stocks en unité d'achat.

Odf

Intégration dans fab5 à la date de la facture si elle est renseignée

Odp

Alimentation des dates de début et de fin de production de fab0 depuis les stocks ou fab3 pour les phases purement matières

Oen

Ecarte les dossiers non générés

Of3

(en minuscules) Utilisation de la formule de conversion 3 pour convertir les quantités de stock

UNIQUEMENT lorsque la remontée des temps se fait par quantité.

OF3

(en majuscules) Utilisation de la formule de conversion 3 pour convertir les quantités de stock

UNIQUEMENT lorsque la remontée des temps se fait en montants.

Ofp

Dans l'intégration des mouvements de stock en francs, on rajoute le pourcentage de frais et le pourcentage de perte de l'article au montant calculé (s0_qte * s0_prix * coef_conv(1))

Ogd

Voir #CF EVT.

Oif

Intégration automatique des mouvements d'achats extérieurs

Fonctionnement différent si achat extérieur sur opération ou sur un article

Fonctionnement différent pour la mécanique et l'imprimerie

Oim

Imprimerie (mécanique par défaut)

Oin

Intégration automatique des mouvements de stock en fonction de leur affectation

Fonctionnement différent pour la mécanique et l'imprimerie

Voir mp_param[31]

Oir

Non intégration de la sous-traitance affectée à la racine de l'OF

Ola

On utilise la longueur et la largeur de la ligne de commande fournisseur lors de l'intégration des matières consommées pour le calcul du coefficient de conversion.

Olm

Récupération de la laize matière dans le lieu de rangement 2 des mouvements de stock à intégrer

Oma

Dans l'intégration des mouvements de stock en francs, on rajoute le pourcentage de marge de l'article au montant calculé (s0_qte * s0_prix * coef_conv(1))

Omq

Pas de mise a jour de la quantité dans fab2 lors d'une intégration des achats extérieurs

Oon

Lors de l'intégration des mouvements de stock, permet de prendre en compte qu'il n'y a qu'un niveau de nomenclature, bien que les onduleurs soient en Oim (art graphique).

Oos

Lors de la remontée des opérations de sous-traitance dans fab1, on initialise le code produit de la table fab1 avec celui de l'opération précédente au lieu de prendre l'article de la ligne de commande.

Opc

Proratisation des coûts matières remontés automatiquement

Opm

Utilisation du PAMP pour les calculs

Opt

Proratiser le temps de réalisation prévu (table fab1) avec le coefficient suivant :

Quantité réalisée / Quantité de l'opération

Voir aussi option Op2

Opv

Utilisation du prix de vente en unité de vente (pas de conversion)

Op2

Proratisation des temps prévus des opérations par rapport à la quantité fabriquée de la ligne de commande

Voir aussi option Opt.

Oqm

Si pas de quantité dans fab2 ni dans fab3, on conserve la quantité et le coût calculé par dp0 (pour la mécanique).

Ore

Demande de réactualisation du dossier

Orm

Le réalisé matière est égal au prévu matière. Voir la note _REMONTEE_MAT_AUTO

Oro

Le réalisé opération est égal au prévu opération.

Osm

Somme de toutes les opérations (roulage) pour lesquelles des quantités ont été saisies.

Oso

On termine l'opération si la remontée de la sous-traitance vient d'une ligne de commande d'achat soldée.

Ost

En intégration des achats extérieurs, on n'intègre que les opérations et articles de sous-traitance, c'est à dire :

les opérations où o0_param [6] = O

les articles où mp_param[10] = O ou P

Otb

Valorisation des temps masqués (TTR à blanc) (voir valeur numérique 1)

Otm

Recherche du tarif dans tar0 pour le calcul du montant matière de fab3. Voir la note PARAMETRE_DP0

Oup

Utilisation des prix de cession (voir alpha3)

Ouu

Cumule les quantités consommées en Unité d'Utilisation

Les quantités consommées dans un dossier peuvent être exprimées dans 2 unités différentes, l'unité d'utilisation (qui est celle suivie en stock) et en unité d'achat.

Pour la remontée des quantités consommées dans le dossier, on créé une option qui permet de cumuler les quantités en unité de stockage au lieu des quantités en unité d'achat.

Ovp

On n'utilise pas les zones longueur et largeur pour le calcul du coût

Oxa

Calcul au prix d'achat

Oxb

Calcul au prix selon le type de valorisation

Oxr

Calcul au prix de revient

Oxv

Calcul au prix de vente

Valeur alpha 3

Caractères 1 à 3 | Code environnement pour la recherche des taux horaire
Caractère 4 | Dans le calcul du prix de cession, que fait-on si aucun prix trouvé ? 1 Renvoie nul et anomalie (ouverture fenêtre) 2 Renvoie zéro et prend le prix de l'article (celui lu dans la fonction lec_mat_p) (par défaut)
Caractère 5 | Dans le calcul du prix de cession , que fait-on si plusieurs prix trouvés ? 1 Renvoie nul et anomalie (ouverture fenêtre) (par défaut) 2 Renvoie le premier prix trouvé 3 Ouverture d'une fenêtre et choix du prix
Caractère 6 | Mise à jour de la table temporaire selon état de la clé 0 On met à jour la table quelque soit l'état de la clé. 1 On met à jour la table si l'état de la clé est true. 2 On met à jour la table si l'état de la clé est false.
Caractères 7 à 9 | Code environnement pour le prix de cession. Voir aussi les caractères 12 à 14 Si non renseigné, alors est égal au code environnement pour la recherche des taux horaires (A3[1,3]).
Caractère 10 | Intégration des lignes de sous-traitance (table fab5) dont le montant est à zéro N Non (par défaut) O Oui
Caractère 11 | On prend en compte les familles de nomenclature dans le calcul
Caractères 12 à 14 | Code environnement en configuration multi-niveau pour le prix de cession Si aucun prix de cession n'est trouvé avec cet environnement, on recherche avec le code environnement paramétré sur les caractères 7 à 9. Note Cette recherche de prix de cession ne se fait que pour les articles de type produit fini. Voir #CF/CAR note SUPREQPF

Notes triées

FORMULE_CONV_UNITE

Paramétrage de la formule de conversion

21,23 Unité de départ pour la conversion

24,26 Unité de destination

27,29 Code phase de la formule utilisée pour la conversion

30,32 Code formule

33,33 Type de formule

M Matière

O Opération

S Sous-traitance

PAR_LCT_CALCUL_AS

21,26 Type et code du paramètre de lancement du calcul des actions de service dans le prix de revient

PARAMETRE_DP0

21,23 Type paramètre du programme de saisie des temps

25,27 Code paramètre du programme de saisie des temps

Cette note permet de rechercher la configuration de recherche de tarifs définie sur le paramètre de lancement du programme de saisie de production (dp0).

Cela permet ainsi d'assurer la cohérence entre les deux programmes.

Cette recherche n'est active que si l'option -Otm est présente.

Les valeurs lues sur le paramètre de lancement de dp0 sont les suivantes :

A4[1,6] Paramètre de la configuration de tarif utilisé (par défaut #CF TAR)

A4[7,9] Code tarif utilisé (par défaut, PR)

_REMONTEE_MAT_AUTO

Remontée des matières en automatique

Est conditionné par l'option Orm et l'option mp_param[6].

21,35 Racine du code matière dont la remontée matières sera automatique

36 Méthode de calcul

1. Le réalisé d'une matière est égal au prévu de cette matière.

2. Le réalisé d'une matière est égal au réalisé de la consommation d'une autre matière.
Exemple : La matière XEMBALLAGE dépend de la consommation des palettes.
S'il y a 5 palettes consommées il y aura 5 XEMBALLAGE consommées.

3. Le réalisé d'une matière est égal au prorata de la consommation prévue par rapport à la consommation réalisée des phases associées à cette matière.
Exemple : Vernis. Le réalisé est égal au prorata de la consommation des phases d'impression.
Vernis : prévu 10Kg. Impression : Prévu = 10000, Réalisé = 12000
Réalisé du vernis : 10 * (12000/10000) = 12 Kg

37,60 Complément de sélection.

Méthode 1 : sur la table fab0

Méthode 2 : les tables fab1 et fab2

Remarque : le détail des remontées matières est historisé dans la table fab3.

Les dates de réalisation dépendent des dates de consommations du calcul (selon la méthode).

Exemple de paramétrage

_SUP_REQ_FAB0

21,60 Complément de sélection des ordres de fabrication à calculer (fab0)

_SUP_REQ_FAB0_RCP

Lors du calcul du prix de revient, permettre de limiter l'alimentation du récapitulatif des coûts des matières à partir de l'ordre de fabrication (fab0).

Remarques

• Le récapitulatif des coûts s'alimente automatiquement à partir du moment où l'option payante correspondante (PRO 04) est active.

• Les origines du récapitulatif des coûts utilisés lors du calcul du prix de revient sont :

REV Prix de revient (environnement prévisionnel)

RER Prix de revient (environnement réel)

• Le paramétrage courant concerne uniquement l'alimentation de la catégorie MAT (matières).
L'alimentation de la catégorie GAM (gamme) ne nécessite pas de paramétrage particulier.

• L'alimentation de la catégorie FAS (frais d'actions de service) sera faite via le programme de calcul des actions de service onduleurs (pr_as_don) et ne nécessite pas de paramétrage particulier.

21,60 Complément de sélection sur les lignes des matières consommées pour l'ordre de fabrication (fab0) à prendre en compte pour alimenter le récapitulatif des coûts

Exemple

and f0_prod not like ‘VAL%'

_SUP_REQ_STK0_CSLL_D

21, 60 Supplément de requête sur la table des mouvements de stock pour la valorisation au prix d'achat moyen pondéré du lot

(mp_param[31] de la fiche article à D)

Le supplément de requête est utilisé dans la fonction de calcul du stock lot – lieu (Fonction f_calcul_stock_lot_lieu)

Facultatif

Exemple :_SUP_REQ_STK0_CSLL_D and s0_typ in ("RE","EF")

_SUP_REQ_STK0_CSLL_E

21,60 Supplément de requête sur la table des mouvements de stock pour la valorisation au prix de revient du lot

(mp_param[31] de la fiche article à E)

Le supplément de requête est utilisé dans la fonction de calcul du stock lot – lieu (Fonction f_calcul_stock_lot_lieu)

Facultatif

Exemple :_SUP_REQ_STK0_CSLL_E and s0_typ in ("RE","EF")

_SUP_REQ_STK0_CSLL_F

Supplément de requête sur la table des mouvements de stock pour la valorisation au prix de vente du lot

(mp_param[31] de la fiche article à F).

Le supplément de requête est utilisé dans la fonction de calcul du stock lot – lieu (Fonction f_calcul_stock_lot_lieu)

Facultatif

Exemple :_SUP_REQ_STK0_CSLL_F and s0_typ in ("RE","EF")

_SUP_REQ_STK0_1ERMVT

Supplément de requête sur la table des mouvements de stock pour récupérer le prix du 1er mouvement de stock du lot du produit

Les options Oin et O1m doivent être activées.

Facultatif

Exemple

_SUP_REQ_STK0_1ERMVT and s0_typ in ("ENT")

ZONE_FLE_MAT_COEF

21 Numéro de la zone (fm_v) de la table fle_mat contenant le coefficient de la matière

Facultatif. Seules les valeurs 1 et 2 sont autorisées

Paramètres associés

#FB GDF | Intégration du port de la sous-traitance saisie dans strai.4ge. Si options Oim (imprimerie) et Ost (intégration sous-traitance), on va lire l_gdf A2[7]. Si l_gdf A2[7] est différent de N, on va regarder le code produit transport dans l_gdf A2[8,22]. Le code produit transport doit exister, et son mp_param[10] doit être P. ATTENTION : #FB GDF doit être paramétré avec l_gdf et non pas gdf - Vérifié le 20/07/2006
TVA A2[53,55] | Code environnement pour valorisation des matières dans la génération de dossier


Calcul du prix de revient Transformateur et Onduleur

Calcul du prix de revient Transformateur et Onduleur pr_midata

Options

Oda | Intégration du détail des arrêts Pour garder la cohérence du traitement, cette option permet aussi de gérer les événements par date et code faction, ainsi que l'intégration des conducteurs. Voir A2[16,18]
Ode | Prise en compte des déchets réels dans le calcul Nécessite –Omc
 | Réservé Volume Software
Olo | Liste, dans le fichier précisé dans la note NOM_FICHIER_LISTE_OF, les OF qui ont une machine réelle différente de celle prévue
Omc | Prise en compte des matières consommées réellement
Op2 | Prix de revient plastique Génération des notes du détail du calcul du prix de revient prévisionnel réactualisé de la composition Le détail du calcul est stocké dans la table note_of avec comme type de note #pr. La même option existe dans dp0.
Osd | Saisie d'une date afin de restreindre le traitement à cette date ATTENTION : ne fonctionne qu'avec l'option Oda.

Valeur alpha 2

Caractères 1 à 3 | Type paramètre pour arrêt imputable
Caractères 4 à 6 | Code paramètre pour arrêt imputable
Caractères 7 à 9 | Type de paramètre pour arrêt non imputable
Caractères 10 à 12 | Code de paramètre pour arrêt non imputable
Caractères 13 à 15 | Code phase passage (PAS, ROU, …). PAS par défaut
Caractères 16 à 18 | Type de travail correspondant à une suite de réglage Obligatoire avec l'option –Oda Exemple : SP

Valeur alpha 3

Caractères 1 à 5 | Phase de gamme minimum (correspond généralement à celle du passage onduleuse) (Valeur par défaut : 20)
Caractères 6 à 10 | Phase minimum de création
Caractères 11 à 13 | Code environnement pour calcul du prix de cession (seulement avec option –0mc)
Caractère 14 | Que fait-on si aucun prix trouvé ? 1 retourne une erreur 2 retourne zéro (valeur par défaut)
Caractère 15 | Que fait-on si plusieurs prix trouvés ? 1 retourne une erreur (valeur par défaut) 2 retourne le premier prix trouvé 3 fenêtre de choix entre les prix possibles
Caractères 16 à 18 | Code environnement pour calcul du prix de cession pour l'alimentation de la zone coût prévu réactualisée Nécessite l'option Omc.

Notes triées

CODE_MICRO_ARRET

21,23 Code micro arrêt

INITIALE_OPE_MAC

Prise en compte de l'initiale du code opération par rapport à la machine

21,26 Code machine définissant l'initiale du code opération
ou
Code de la machine physique donnée par PCTOPP

30 Initiale à mettre dans le premier caractère du code opération lors de la recherche des opérations élémentaires.

40,45 Code de la machine de référence servant à effectuer la recherche des opérations élémentaire [par défaut, sera le code de la machine physique]

MACHINE_A_EXCLURE

21,60 Codes des machines à exclure, en plus des machines de base OND, PAC et EXT

NOM_FICHIER_LISTE_OF

21,60 Nom du fichier de liste des OF

Par défaut, le nom du fichier est liste_of_mach_non_prev.dat sous le répertoire client.

Voir option Olo

OPERATION_A_PRENDRE

21,60 Codes des opérations à prendre en compte, en plus de l'opération de base PAS

SUP_REQ_FAB_OND_OF

21,60 Supplément de requête sur la table fab_ond_of

SUP_REQ_FAB_TRA_FAC

21,60 Complément de sélection sur la table fab_tra_of_fac

SUP_REQ_FAB_TRA_OF

21,60 Supplément de requête sur la table fab_tra_of

SUP_REQ_FAB1

21,60 Complément de requête sur la réinitialisation des lignes de fab1 dont le type de machine de la machine de la ligne n'est pas de type OND ni EXT.

Exemple

and f1_mach not in (STRAI)

and f1_mach in

(select m0_machine from mac0

where m0_soc = "XXX"

and m0_typmac not in ("STR"))

XXX correspond au code société.

SUP_REQ_FAB2

21,60 Complément de sélection sur la table fab2

SUP_REQ_TRA_ARR

21,60 Complément de sélection sur la table fab_tra_arret


Edition et historisation du prix de revient

Edition et historisation du prix de revient epr0

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[lc_num]

Options triées

-r

Réédition

Nx

x étant le numéro de commande à éditer ou à rééditer

Oae

Ajoute automatiquement une étoile (*) à la fin du numéro d'OF saisi.

Obt

Interdit l'impression du tableau du bilan technique (si géré en spécifique)

Oc0

Edition des cadences sans décimales

Oc2

N'édite pas les niveaux < 2 dans le détail produit dans tous les cas de devis (SPECIFIQUE)

Ocl

Edition des dossiers avec niveau de clôture > 1

Ocm

Edition du détail salarié en heures centièmes

Oco

N'édite pas les niveaux < 2 dans le détail produit si devis suivant ou amalgame (SPECIFIQUE)

Odc

Edition des dossiers complets

Ods

Edition de la partie Détail seule

Oed

Edition des dépendances (opération imprimerie). (SPECIFIQUE)

Oes

Edition du détail des temps par salarié.

A gérer en spécifique dans le report (le report standard epr0 n'en tient pas compte).

Oet

Edition de tous les dossiers.

On édite les dossiers dont le prix de revient n'a pas été édité et ceux dont le prix de revient a déjà été édité.

Of5

Edition du détail sous-traitance (table fab5)

Ofr

Edition par référence de commande

Avec cette option, l'édition se fera en détail pour chaque cadencement des OF rattachés à la commande commerciale sélectionnée.

Sans cette option, l'édition se fera en global c'est-à-dire avec un cumul des cadencements et OF rattachés à la commande commerciale sélectionnée.

Ogc

Edition par cadencement de fabrication (Avant c'était géré par un complément de sélection)

Avec cette option, l'édition se fera en détail pour chaque cadencement de fabrication.

Sans cette option, l'édition se fera en global c'est-à-dire avec un cumul de tous les cadencements par OF.

Ogt

Edition par train

Sélection d'un numéro de train.

Avec cette option, l'édition se fera en détail pour chaque cadencement des OF appartenant au train sélectionné.

Sans cette option, l'édition se fera en global c'est-à-dire avec un cumul des cadencements et OF appartenant au train sélectionné.

Ohi

Historisation mensuelle

Ohm

Edition du détail salarié en heures minutes. Possible également pour le tableau détail opération.

Oim

Imprimerie (mécanique par défaut)

Oit

Interdit l'impression du tableau des incidents techniques (si géré en spécifique)

Ola

On n'édite pas les lignes annulées

Old

Imprimerie uniquement. Dans le tableau produit / entité, permet d'afficher le libellé de l'entité (situé dans le devis imprimerie) plutôt que la désignation du produit.

Omn

Eclatement du multi-niveaux dans l'édition et l'historisation des prix de revient

Le prix de revient des articles multi-niveaux est intégré aux matières.

Cette option permet d'éclater le prix de revient des articles multi-niveaux en matière, en façonnage variable et fixe et en actions de service.

Onp

La quantité réalisée est divisée par le nombre de poses.

Op3

Edition des PU avec 3 décimales

Opl

Plastique

Option utilisée pour calculer la quantité fabriquée

Si la quantité fabriquée est supérieure de 5% à la quantité lancée, la quantité fabriquée sera égale à la quantité lancée.

Opm

PAMP pour calcul (au lieu de prix d'achat)

Opv

Prix dans l'unité de vente pour le calcul

Oqe

Réactualisation du prévu en fonction de la quantité fabriquée ou emboîtée

Par défaut, la réactualisation se fait en fonction de la quantité fabriquée.

Oqf

Quantité fabriquée recalculée et mise à jour de la zone lc_qtefab dans cde2

Voir la note _SUP_REQ_MAJ_QTEFAB

Oqr

Mise à jour de la quantité réalisée du 1er niveau avec la quantité fabriquée de la ligne de commande - Voir l'option Oqf ci-dessus

Ora

Réactualisation du prévu en fonction de la quantité emboîtée

Ore

Edition du récapitulatif seul ; à mettre en œuvre dans chaque report spécifique du client

Orf

Récapitulation du PR par famille / sous – famille (SPECIFIQUE)

Org

Edition du récapitulatif global

Orp

Calcul de tous les écarts de la façon suivante : écart = réalisé – prévu.

Sans l'option : écart = prévu – réalisé.

Oso

Edition du sous-total des lignes d'opération qui ont le même libellé

Oss

Edition du sous-total des lignes d'opération qui ont le même libellé sans éditer le détail

Ost

Edition du détail sous-traitance (matières). Option Devis

Oxa

Calcul au prix d'achat

Oxb

Calcul au prix selon le type de valorisation

Oxr

Calcul au prix de revient

Oxv

Calcul au prix de vente

Oz0

Permet d'afficher dans le tableau du détail produit / matières les valeur à 0 (au lieu de les laisser à blanc)

Valeur alpha 2

Caractères 1 à 3 | Code environnement
Caractères 4 à 6 | Code du paramètre de configuration de l'édition du prix de revient (PRV par défaut). Le type est systématiquement #CF.
Caractère 7 | Menu automatique 0 On demande à l’utilisateur ce qu’il souhaite [valeur par défaut]. 1 On accède directement à la saisie des critères de recherche. 2 On accède directement à la saisie de la liste des commandes à éditer.

Notes triées

AAMM_POUR_ENTITE_DEV

21,30 Pourcentage du mois pour le calcul des frais généraux

Spécifique

CALCUL_AUTO_DOSSIER

21,26 Type et code du paramètre de lancement du programme d'intégration des prix de revient

CODE_QUALIF_PR_NEG

21,23 Code qualificatif en cas de prix de revient négatif (par défaut : AEN) (SPECIFIQUE)

CODE_QUALIF_PR_POS

21,23 Code qualificatif en cas de prix de revient positif (par défaut : AEP) (SPECIFIQUE)

CONVERSION_REALISE

21 conversion des quantités réalisées (O/N, N par défaut)

Voir Conversion d'unité pour les quantités réalisées

COUT_FIXE_ENTITE_DEV

21,30 Coût fixe par entité du devis - (SPECIFIQUE)

Exemple : 200 ou 200.00 ou 200.5 ou 200.50

FORMULE_CONV_PPI

Spécifique

_ORDER_BY_FAB0

Complément de tri sur la table fab0

Par défaut, le tri est le suivant : order by f0_cde, f0_lig, f0_tri

Standard à tous les prix de revient

PARAM_INDICATEURS

Spécifique

21,26 Type et code du paramètre de lancement du programme où se situe le paramétrage des indicateurs (Paramétrage de lancement du devis multi-métiers, par exemple)

Remarque :

Si aucun type et code de paramètre n'est paramétré, ou si celui-ci n'existe pas, on va rechercher le paramétrage des indicateurs sur le paramètre de lancement de l'édition.

Se reporter à l'aide en ligne de paramétrage des indicateurs du récapitulatif des coûts :

voluedit_fle_cli : note PARAM_INDICATEURS

devis_standard : notes

_FOR_INDIC_

_TIT_INDIC*

_VAR_INDIC_

POUR_FIXE_ENTITE_DEV

21,30 Pourcentage par défaut pour le calcul des FG (si le mode n°2 est paramétré) - Spécifique

PRIX_FIXE_PALETTE_LV

21,30 Prix fixe par palette livrée - (SPECIFIQUE)

Exemple : 100 ou 100.00 ou 100.5 ou 100.50

RUPTURE_DET_TRA

21,60 Rupture par TTR (nouvelle méthode) (SPECIFIQUE)

Si non paramétré : rupture par code machine (ancienne méthode)

SOUS_TOTAL_DET_STR

21,60 Affichage des sous totaux par type de matière (TMT) pour le détail de sous-traitance. SPECIFIQUE

SOUS_TOTAL_DET_TRA

21,60 Affichage des sous-totaux par type de travail (TTR) pour le détail des travaux

SPECIFIQUE

STOCKER_ELEMENT_PRU

Spécifique

Stocker les éléments de calcul du PRU (Indicateurs) dans la table d'historisation des prix de revient

21 Type d'enregistrement d'historisation pour les indicateurs a à o

La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

22 Type d'enregistrement d'historisation pour les indicateurs p à D

La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

23 Type d'enregistrement d'historisation pour les indicateurs E à S

La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

24 Type d'enregistrement d'historisation pour les indicateurs T à Z

La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

_SUP_REQ_FAB0

21,60 Complément de sélection sur fab0

_SUP_REQ_FAB1

21, 60 Supplément de requête sur fab1

_SUP_REQ_FAB2

21,60 Supplément de requête sur fab2 (SPECIFIQUE)

_SUP_REQ_FAB3

21,60 Supplément de requête sur fab3 (SPECIFIQUE)

_SUP_REQ_MAJ_QTEFAB

21,60 Complément de requête sur la table stk0 pour le calcul de la quantité fabriquée

Voir l'option Oqf

_SUP_REQ_STK_QT_REAL

Spécifique

TAUX_STRUCTURE_

16,19 Année de fabrication (Ex : 2000) (SPECIFIQUE)

21,26 Taux horaire

TAUX_TRANSPORT_

16,19 Année de fabrication (Ex : 2000)

21,26 Taux horaire

TX_HORAIRE_PT_MORT

Permet de déterminer quel taux horaire prendre en compte pour une période donnée.

Lorsque la date de clôture de la fiche est comprise dans une des périodes paramétrées, le taux horaire correspondant est appliqué dans l'historisation.

Si la date de clôture n'est pas renseignée c'est la date du jour qui est prise en compte.

21, 30 Date de début de période

32, 41 Date de fin de période

51, 60 Taux horaire point mort

TYPE_CALCUL_FRAIS

21 Mode de calcul des frais généraux - Spécifique

1 selon le mode classique (par défaut)

2 selon pourcentage

VALEUR_ECART_PR_NEG

21,60 Valeur d'écart en cas de prix de revient négatif

VALEUR_ECART_PR_POS

21,60 Valeur d'écart en cas de prix de revient positif

Optimisation

Note : Quand on recherche les factures rattachées au dossier, l'édition peut être longue.

Pour diminuer les temps de traitement, il faut rajouter un index sur la table des lignes de commandes (cde2).

==> lc_soc, lc_cderat, lc_lcderat

Edition et historisation du prix de revient CNJ

Après l'édition du détail matières / produits, du détail opérations, du détail travail (option Oes) et des 2 détails sous-traitance (options Ost et Of5), le module éditera un récapitulatif de la facturation, un récapitulatif des matières et un récapitulatif des machines.

L'historisation crée 2 enregistrements dans la table hist_pr (F et G).

Enregistrement de type F

Zone paramétrable 1 hp_z1 Quantité facturée

Zone paramétrable 2 hp_z2 Montant facturé

Zone paramétrable 3 hp_z3 Coût prévu des matières premières - Familles CAR-OND-PVC-CAG-ONG-PVG

Zone paramétrable 4 hp_z4 Coût réel des matières premières - Familles CAR-OND-PVC-CAG-ONG-PVG

Zone paramétrable 5 hp_z5 Coût prévu de la sous-traitance - Famille STR

Zone paramétrable 6 hp_z6 Coût réel de la sous-traitance - Famille STR

Zone paramétrable 7 hp_z7 Coût prévu des accessoires - Familles différentes de CAR-OND-PVC-CAG-ONG-PVG-STR
Famille FRA et sous-familles différentes de POR-FIN-CAP-GEN-STO

Zone paramétrable 8 hp_z8 Coût réel des accessoires - Familles différentes de CAR-OND-PVC-CAG-ONG-PVG-STR
Famille FRA et sous-familles différentes de POR-FIN-CAP-GEN-STO

Zone paramétrable 9 hp_z9 Coût prévu du transport - Famille FRA et sous-famille POR

Zone paramétrable 10 hp_z10 Coût réel du transport - Famille FRA et sous-famille POR

Zone paramétrable 11 hp_z11 Coût prévu des frais - Famille FRA et sous-familles FIN-CAP-GEN-STO

Zone paramétrable 12 hp_z12 Coût réel des frais - Famille FRA et sous-familles FIN-CAP-GEN-STO

Zone paramétrable 13 hp_z13 Coût variable prévu des machines

Zone paramétrable 14 hp_z14 Coût variable réel des machines

Zone paramétrable 15 hp_z15 0

Enregistrement de type G

Zone paramétrable 1 hp_z1 Coût fixe prévu des machines

Zone paramétrable 2 hp_z2 Coût fixe réel des machines

Zone paramétrable 3 hp_z3 0

Zone paramétrable 4 hp_z4 0

Zone paramétrable 5 hp_z5 0

Zone paramétrable 6 hp_z6 0

Zone paramétrable 7 hp_z7 0

Zone paramétrable 8 hp_z8 0

Zone paramétrable 9 hp_z9 0

Zone paramétrable 10 hp_z10 0

Zone paramétrable 11 hp_z11 0

Zone paramétrable 12 hp_z12 0

Zone paramétrable 13 hp_z13 0

Zone paramétrable 14 hp_z14 0

Zone paramétrable 15 hp_z15 0


Visualisation de l'historique

Visualisation de l'historique pr_hi

Valeur alpha 2

Caractère 1 | Type d'enregistrement de premier niveau. F par défaut (Zone hp_type dans la table hist_pr)
Caractère 2 | Type d'enregistrement de deuxième niveau. G par défaut (Zone hp_type dans la table hist_pr)
Caractères 3 à 5 | Code édition du prix de revient. Pas de valeur par défaut Utilisé pour appeler le programme d'édition (type = #ED, en dur dans le code) à l'appui sur la touche F6. Le programme est appelé avec un -N suivi du [N° de commande]-[N° de ligne de commande].

Paramètres nécessaires

SEC | Codes sections (libellé court et valeur numérique 2)
ZHx | Zones historiques (où x = alpha2[1])

Les libellés des 15 zones paramétrées (hp_z1 à hp_z15) du fichier historique du prix de revient (table hist_pr) sont définis dans le libellé court du fichier paramètre (type ZHx et code Z1 à Z15)

Exemple Le libellé de la zone hp_z5 , de type d'enregistrement F, sera défini comme paramètre ZHF Z5.

Exemple Le libellé de la zonehp_z5 , de type d'enregistrement L, sera défini comme paramètre ZHL Z5


Edition de l'historique du prix de revient

Edition de l'historique du prix de revient hipr

Paramètre associé : #CF HIS ou tout autre paramètre de configuration identique au type du paramètre de lancement.

Exemple : Si le paramètre de lancement de hipr est #ED HIS, alors le paramètre associé devra être #CF HIS.

Options

Orm

Restriction de l'édition à une machine présente dans FAB1

Opz

Permet la mise à jour des prix de revient.

Permet en outre l'utilisation du paramétrage des zones de l'historique des prix de revient

Voir les notes commençant par _Z_ dans #CF HIS

Osf

SPECIFIQUE - Sélection par le numéro de facture

Voir #CF HIS, alpha1[1,60] et notes commençant par VALEUR_DEF_ZP_

Osj

Permet de ne pas faire la jointure entre la table de l'historique et la table des lignes de commande.

En fait, cette option permet de revenir au fonctionnement précédent (qui a été modifié suite à une VoluFiche) car certains client n'historisent pas le numéro de la ligne de commande ce qui rend cette fameuse jointure impossible [note de SL].

Valeur alpha 2

Caractère 1

Type de l'historique à éditer (toujours F) (valeur par défaut)

Types historique pour le standard

B Historique produit de la commande (mdl ??)

F Historique produit de la commande (zones 1 à 15)

G Historique produit de la commande (zones 16 à 30)L : Historique prix de vente

M Récapitulatif des coûts au niveau de la commande, environnement CEV (devis onduleur)

N Récapitulatif des coûts au niveau de la commande, environnement CER (devis onduleur)

T Historique associé à la facture

X Récapitulatif des coûts au niveau de la facture, environnement CEV (devis onduleur)

Y Récapitulatif des coûts au niveau de la facture, environnement CER (devis onduleur)

Créer des paramètres pour les zones paramétrées

Type ZHF

Code Znn où nn = N° de la zone paramétrée

avec les caractéristiques suivantes :

Libellé court Libellé de la zone paramétrée

Valeur numérique 1 Numéro de zone du dividende (1 à 15)

Valeur numérique 2 Numéro de zone du diviseur (1 à 15)

Les valeurs 1 et 2 ne doivent pas être remplies si la zone paramétrée est la somme de ces valeurs.

Exemple : hp_z15 = hp_z3 + hp_z4 : le paramètre ZHF Z15 ne doit pas avoir de valeurs numériques 1 & 2.

Les valeurs 1 et 2 doivent être remplies si la zone est le pourcentage entre de ces 2 valeurs.

Zone paramétrée = (Somme zone paramétrée valeur 1 / Somme zone paramétrée valeur 2) * 100.

Exemple : hp_z14 = hp_z2 / hp_z1 / 100 : le paramètre ZHF Z14 doit avoir 2 en valeur numérique 1 et 1 en valeur numérique 2.

Ceci est valable sur les lignes de totalisation (Total commande, total client et total général)


Clôture des dossiers de fabrication

Clôture des dossiers de fabrication dos_fab

Options triées

Oas | Annulation des mouvements de stocks à la clôture du dossier Entrée prévisionnelle Sortie réserve
Oat | Affichage du libellé de la commande au lieu du libellé du produit
Obi | Sélection uniquement des commandes de type FBI
Occ | Contrôle si après clôture au niveau 2, le prix de revient a été édité. Si oui, permet la clôture niveau 3 Sinon, la refuse.
Ocf | Gestion des cadencements de fabrication activée
Odb | Si dossier non clôturé, alors la date est automatiquement remise à nulle
Odp | Active l'interface Direct Planning
Of7 | L'interrogation du niveau de clôture par F7 disponible (par défaut non disponible)
Ofe | Contrôle si le dossier est facture entièrement avant de le clôturer. Si non, demande si on désire le clôturer
Ofp | Contrôle si le dossier est facture partiellement avant de le clôturer. Si non, demande si on désire le clôturer
Oli | Clôture au niveau de la ligne de commande, cela veut dire que l'historique du prix de revient est géré au niveau de la ligne de commande, et non comme par défaut au niveau de la commande (Exemple C géré au niveau de la commande globale)
On1 | Le niveau 1 est proposé (par défaut non proposé)
OnA | Le niveau 10 est proposé (par défaut non proposé)
Osd | Solde ou désolde la ligne de commande L'option Oli (Clôture au niveau de la ligne de commande) doit être présente.

Valeurs numériques

1 | Valeur du N de niveau de clôture (0 par défaut) règle 1: valeur1 < valeur2 règle 2: valeur1 <= alpha2[1,2] Exemple Si le client déclôture toujours au niveau 1, il faut indiquer 1
2 | Valeur du O de niveau de clôture (5 par défaut) règle 1: valeur2 > valeur1 règle 2: valeur2 > alpha2[1,2] Exemple Si le client clôture toujours au niveau 15, il faut indiquer 15

Valeur alpha 2

Caractères 1 à 2 | Niveau maximum du non clôturé (1 par défaut) règle 1 alpha2[1,2] >= valeur1 règle 2 alpha2[1,2] < valeur2
Caractère 3 | Solde la ligne de commande (N/O/C) N Pas de solde de la ligne de commande (Valeur par défaut) O Pas de demande de confirmation pour solder la ligne de commande C Demande de confirmation pour solder la ligne de commande
Caractère 4 | Désolde la ligne de commande (N/O/C) N Pas de désolde de la ligne de commande (Valeur par défaut) O Pas de demande de confirmation pour désolder la ligne de commande C Demande de confirmation pour désolder la ligne de commande
Caractère 5 | Sélection du menu 0 Choix de la sélection 1 Sélection standard 2 Sélection par liste

Exemple de paramétrage (conseillé)

Valeur numérique 1 01

Valeur numérique 2 15

Valeur alpha 1 dos_fab -Odbli

Valeur alpha 2 Caractère 1 0
Caractère 2 1

Notes

DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
TYPES_A_CLOTURER | 21 à 60 Listes des enregistrements de hist_pr à mettre à jour. Nombre maxi d'enregistrements : 40 Un caractère représente un type d'enregistrement. Exemple : 123456 à enreg. 1, 2, 3, 4, 5 et 6


Clôture des FBI

Clôture des FBI clot_fbi

Ce programme sert à clôturer de façon automatique les FBI dans le but de pouvoir calculer les prix de revient.

Options

-B | Lancement en mode Batch
Odc | Date clôture : on garde la valeur initiale de la zone f0_date
Odf | Mise à jour de la date de hist_pr (hp_date) avec la date de fab0 (f0_date) si celle-ci est renseignée sinon avec la date du jour
Odp | Active l'interface Direct Planning
Ofp | Historiser avec la famille du produit

Valeurs numériques

1 | Niveau de clôture (15 par défaut en mode batch)
2 | Nombre de jours à soustraire à la date du jour (2 par défaut en mode batch)

Notes

DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2
SUP_REQ_FAB0 | 21,60 Complément de requête sur fab0 pour la recherche des OF à traiter
SUP_REQ_STK0 | 21,60 Complément de requête sur stk0 pour la recherche de la date de dernière entrée en magasin.
TYPES_A_CLOTURER | 21,60 Types d'historique de prix de revient à clôturer 40 types possibles, sur 1 caractère chacun.


Clôture rapide des dossiers de fabrication

Clôture rapide des dossiers de fabrication qclod

Valeur numérique 1

Valeur du N de niveau de clôture (0 par défaut)

règle 1 valeur1 < valeur2

règle 2 valeur1 <= alpha2[1,2]

Exemple Si le client déclôture toujours au niveau 1, il faut indiquer 1

Valeur numérique 2

Valeur du O de niveau de clôture (5 par défaut)

règle 1 valeur2 > valeur1

règle 2 valeur2 > alpha2[1,2]

Exemple Si le client clôture toujours au niveau 15, il faut indiquer 15

Options triées

Oas | Annulation des mouvements de stocks Entrée prévisionnelle Sortie réserve
Obi | Interdiction de clôture des FBI à la clôture du dossier
Occ | Contrôle si après clôture au niveau 2, le prix de revient a été édité, si oui permet la clôture niveau 3, sinon la refuse.
Odb | Si dossier non clôture alors la date est automatiquement remise à nulle
Odp | Active l'interface Direct Planning
Of7 | Ne propose que les choix dossier clôture NON ou OUI En sélection de dossier NON Dossier <= le niveau maximum du non clôturé OUI Dossier > le niveau maximum du non clôturé En affectation de niveau de clôture NON Dossier Valeur 1 (Fichier paramètre) OUI Dossier Valeur 2 (Fichier paramètre)
Ofe | Contrôle si le dossier est facturé entièrement avant de le clôturer. Si non, pas de clôture
Ofp | Contrôle si le dossier est facture partiellement avant de le clôturer. Si non, pas de clôture
Oli | Clôture au niveau de la ligne de commande, cela veut dire que l'historique du prix de revient est géré au niveau de la ligne de commande, et non comme par défaut au niveau de la commande. (Exemple C géré au niveau de la commande globale)
Osl | Sans temps d'attente entre les messages

Valeur alpha2

Caractères 1 à 2

Définit le niveau maximum du non clôturé (1 par défaut)

règle 1 alpha2[1,2] >= valeur1

règle 2 alpha2[1,2] < valeur2

Notes

DIRECT_PLANNING_CFG | 21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2) Voir le chapitre #CF DP2
DIRECT_PLANNING_TRF | 21 Activer le transfert vers Direct Planning (O/N, N par défaut) Voir le chapitre #CF DP2

Exemple de paramétrage (conseillé)

Valeur 1 | 1
Valeur 2 | 15
Valeur alpha 1 | qclod.4ge -Odblif7
Valeur alpha 2 | Caractère 1 0 Caractère 2 1


Gestion des encours de production

Gestion des encours de production encours

Ce programme permet de modifier les encours de production des OF générés non clos et d'en déduire le prix de revient.

Il présente, sur un premier écran, la liste paramétrable des OF en cours de production, puis, par appui sur la touche F6, le détail des encours par phases du devis initial pour l'OF actif.

Sur ce second écran, il est possible d'effectuer les opérations suivantes :

  • Saisie du pourcentage de réalisation de la phase, toutes formules confondues.

  • Par appui sur la touche F7 ou, automatiquement, saisie des quantités produites et des temps de production pour cette phase à une date donnée ou, total.

Le tableau principal et le tableau du détail de l'OF (touche F6) peuvent être transférés vers Excel.

Le transfert vers Excel est soumis à l'option payante WIN-04.

Options

Ocm | Active la gestion des marges Permet de prendre en compte les marges (sous-traitance, matières premières, frais de mise en route et production) dans le calcul du réalisé.
Osv | Active la recherche des encours sans variante

Valeur alpha 2

1,3

Type de notes (par défaut : TEC) pour la table note_ldev

Notes triées

AVO_REDUISANT_QLIV

21,59 Liste des TYC d’avoir qui décrémenteront la quantité livrée de l’OF par leur quantité commandée (sur 3 caractères chacun)

OUVERTURE_AUTO_COEF

21 Ouverture automatique de la saisie des quantités et temps de production de la phase (F7 sur le second écran) (O/N, N par défaut)

PARAM_COL_

Paramétrage de la colonne

11,12 Numéro de la colonne

21 Présence de la colonne dans l'export vers Excel

N colonne non exportée

A colonne présente dans le tableau principal et dans le détail de l'OF (fonctionne uniquement avec les colonnes détails).
(se reporter au tableau des colonnes pour connaître leur valeur par défaut)

Exemple : la colonne 25 est présente dans l'export du détail mais on souhaite l'avoir aussi lors de l'export du tableau principal.

PARAM_COL_25 A

PARAM_EXCEL

Paramétrage de l'export vers Excel

21 Export du tableau principal avec le détail de l'OF.

O avec le détail de l'OF

N sans le détail de l'OF (Par défaut)

22 Export directement vers Excel

O export directement

N la fenêtre avec la liste des encours s'ouvre (Par défaut)

SAISIE_DATE_ENCOURS

21 Saisie de la date d'affectation de l ‘encours journalier de la phase (F7 sur second écran)

O Oui, initialisée à la date du jour (par défaut)

N Non, forcé à la date du jour

SELECTION_FAB0

21 à 60 Complément de sélection des OF à présenter (porte uniquement sur fab0)

Exemple : and f0_of matches "0007*"

TITRE_COL_

Titre de la colonne

11,12 Numéro de la colonne

21,60 Titre de la colonne.

Note cumulative

TRI_LISTE_OF

21 à 60 Ordre de tri de la liste des OF (sur fab0 sans order by)

Exemple : f0_of desc, f0_date

Paramètres nécessaires

UNI

Valeur numérique 1 : unité de vente

Si paramètre non trouvé : unité de vente = 1

Si paramètre trouvé :

Si nul : unité de vente = 1

Si égal = 0 : unité de vente = quantité

Tableau des colonnes

N° colonne | Titre (par défaut) | Présentes dans le tableau principal
1 | Numéro de commande
2 | Ligne de commande
3 | Quantité commandée
4 | Quantité livrée
5 | Reliquat
6 | Code client
7 | Nom client
8 | Code représentant
9 | Référence commande
10 | Encours réel
11 | Qté cdée
12 | P. vente (cdé)
13 | P. revient (cdé)
14 | Qté livrée
15 | P. vente (liv)
16 | P. revient (liv)
17 | Quantité facturée
18 | P. vente (facturé)
19 | P. revient (facturé)
20 | Reste facturer
21 | Marge Sup.
22 | Détail encours OF
23 | Entité | Détail de l'OF
24 | Num phase
25 | Phase
26 | Réalisé
27 | Encours réalisé
28 | Coûts matières
29 | Coûts fixes opération
30 | Coût variable opération


Liste des encours

Vocabulaire :

Etape : Ensemble de phases appliquées pendant la production regroupées en fonction de leur méthode de valorisation et de leur fonctionnalité

Phase : Ensemble des opérations et des matières regroupées en fonction de leur fonctionnalité (on retrouve la notion de phase du devis)

Attention : Un numéro de phase utilisé dans les dossiers de production correspond à une opération ou à une matière ; ce numéro se calcule en fonction du numéro de phase du devis et du numéro de la formule opération ou matière dans la phase du devis.

On désire valoriser l'encours en spécifiant 3 types d'étapes :

1. La fabrication du produit semi-fini (aussi appelé affiche)

2. La fabrication du produit fini

3. Le stockage du produit fini

Les règles de valorisation de l'encours sont les suivantes :

Au niveau des étapes

Pour chaque étape, on calcule le coût matière et le coût opération ainsi que la quantité produite.

a. Si, à la date de calcul de l'encours, on produit des affiches, la valorisation obtenue est la somme des coûts matières et des coûts opération.

b. Si, à la date de calcul de l'encours, on fabrique les produits finis, la valorisation obtenue correspond à la valorisation de l'étape précédente proratisée à la quantité produite dans l'étape en cours, à laquelle s'ajoute les coûts matières et opérations de l'étape en cours (la proratisation de l'étape précédente permettant de gérer les gâches ou la réaffectation des affiches à d'autres OF)

c. Si, à la date de calcul de l'encours, on en est au stockage des produits finis, l'encours ne se calcule plus par rapport à la quantité stockée, mais par rapport à la quantité restante (la quantité stockée faisant alors partie de la valorisation des stocks et non plus de l'encours). La valorisation s'obtient donc en proratisant les valeurs des étapes précédentes par rapport à la quantité restante calculée par différence entre la quantité produite à l'étape précédente à laquelle se soustrait la quantité mise en stock (on tenant compte du nombre de poses). A cette valeur, on ajoute les coûts matières et opérations de l'étape en cours.

Au niveau des phases

Pour que les coûts matière et les coûts opérations soient valorisés, il a été demandé que la phase correspondante (au sens de phase du devis) soit terminée à la date de calcul, mais il existe des exceptions à cette règle (consommation papier qui sont prises en compte à leur date de consommation même si la phase en question n'est pas terminée à cette date).

Pour pouvoir mettre tout cela en place, il a donc était ajouté au programme la possibilité de paramétrer des étapes et les conditions de prise en compte d'un coût matière (et/ou opération) par rapport à la fin de la phase associée.

Liste des encours en_co

La liste des encours de production ne traite que les commandes donnant lieu à fabrication, c'est à dire les commandes dont le type (TYC) commence par FB.

Les commandes ou lignes de commandes annulées sont exclues du traitement.

Les encours dont la date de mouvement est inférieure à la date d'ouverture de commande sont ignorés !

Validation des encours par étape

Valeurs numériques

1 | Pourcentage de frais sur transport à prendre en compte dans les frais sur vente si ligne livrable
2 | Nombre de jours à déduire de la date de calcul des encours La date de calcul des encours est initialisée à la date du jour. Facultatif - Utilisé en mode batch, voir option -B

Options triées

-B

Mode Batch

Incompatible avec l'option Oem

Voir aussi A3[26] et valeur numérique 2

Oac

Spécifie que l'amalgame est cumulé sur la ligne d'entête (à positionner si les montants facturés sont doublés)

Oal

Si trace en cours, on édite les lignes où il n'y a aucun calcul.

Ocf

Contrôle de la réception facture (à mettre aussi sur cpr)

Si l'option est positionnée, les lignes de sous-traitance (fab5) pour lesquelles la facture n'a pas été reçue sont prises en compte dans le prix de revient mais pas dans le calcul des encours.

Ocl

Rupture au niveau du client

Ocp

Calcul de l'encours à partir des coûts prévus dans fab1

Odc

Prise en compte de la date clôture

Exemples :

Dossier clôturé le 01/12/93 : l'encours au 15/12/93 ne doit pas tenir compte du dossier.

Dossier clôturé le 20/12/93. l'encours au 15/12/93 doit tenir compte de ce dossier.

Odl

N'édite que le total commande.

Oeb

La quantité emballée sera prise dans la table emb.

Oem

Restriction des dossiers par rapport à la date d'emboîtage

Interdit en mode batch, voir option -B

Oen

Pouvoir afficher les zones u,v et w en négatif

Of3

Pas d'utilisation de fab3 pour le calcul du coût matière.

Ofb

Prise en compte des cadencements de fabrication

Off

Ajoute les frais fixes de production (voir paramètre SEC) aux amortissements.

Oha

Rupture au niveau de la commande.

Ol0

Pas de prise en compte des quantités lancées à zéro.

Ola

Prise en comptes de toutes les lignes de commande

(Un OF doit être présent sur la ligne 1)

Incompatible avec l'option Ost

Ole

Le montant de l'en cours de production est limité au montant restant à facturer.

Ome

Mécanique (imprimerie par défaut).

On1

Si encours < 0 alors on édite la ligne avec un encours à 0, mais on ajoute la valeur négative de l'encours au total encours.

Cette option concerne l'encours (Colonne U) ou l’encours direct (Colonne v).

Voir note COL_SI_ENC_NEGATIF

On2

Si encours < 0 alors on n'édite pas la ligne et on ne l'ajoute pas au total encours.

On3

Si encours < 0 alors on édite la ligne avec un encours négatif, mais on ne l'ajoute pas dans le total encours.

On4

Si encours < 0 alors on édite la ligne avec un encours à 0, mais on ne l'ajoute pas dans le total encours.

Opf

Pas de prise en compte des quantités livrées et facturées des produits fantômes.

Opl

Saut de page au niveau du client.

Opm

Utilisation du PAMP pour les calculs au lieu du PU.

Opp

Proratiser les coûts matière et opération au pourcentage d'encours

Cette option applique le pourcentage d'encours aux coûts matière et opération.

De plus, elle modifie le calcul des coûts matières, ceux-ci étant dans ce cas la somme des coûts prévus (fab0.f0_cp) pour l'ordre de fabrication en cours.

Un complément de sélection est paramétrable : voir la note commençant par _SUP_REQ_FAB0_COMPO.

Opv

Utilisation du prix de vente en unité de vente.

Oql

La quantité lancée est positionnée à 0 si à la date du calcul de l'encours la fabrication n'était pas commencée.

( i.e. si il n'y a pas de mouvement de stock de sortie normale antérieur à cette date ).

Orf

Les frais sur vente ne sont pas retirés.

Osc

Utilisation des segments de consommation (calcul de l'encours d'une matière dite en remontée automatique en fonction de la quantité réalisée sur une opération paramétrée sur la famille de l'article consommé).

Osf

On va tenir compte du paramétrage sur la sous-famille des produits (alpha1[13 et 14]) pour savoir si les lignes de facture de ces produits doivent intervenir au niveau des quantités et montants facturés. (colonnes c et T).

Ost

Prend en compte de tous les dossiers (clos ou non) ayant du stock à la date de calcul de l'encours.

Permet accès au module de valorisation fiscale des stocks.

Incompatible avec l'option Ola

Otd

Active un mode trace détaillée permettant d’obtenir un rapport beaucoup plus complet à la fin de la valorisation

Voir aussi l'option Otr pour une trace plus simple

Otq

Edition des totaux quantités.

Otr

Permet de conserver une trace des éléments pris en compte pour le calcul des encours.

Cette trace est visualisée à la fin de l'édition et est imprimable par la touche F8.

Voir aussi l'option Otd pour une trace plus détaillée

Ovd

Valorisation de la commande à partir du prix remis du devis associé à celle-ci quand le prix de la ligne de commande n'est pas renseigné (cas des FB1)

Ovl

Valorisation au prix de vente de la ligne de commande client au lieu du PAMP des mouvements de stock

Dans le cas des appairages, le prix unitaire de vente de la ligne de commande ne s'applique pas au produit suivi en stock.

On réalise une proratisation en fonction des ratios des prix de revient de l'ensemble et du PF.

Ovp

Produits appairés valorisés au prorata des poids. L'option Ovl doit être activée

Ovs

Produits appairés valorisés au prorata des surfaces. L'option Ovl doit être activée

Oxa

Calcul au prix d'achat

Oxb

Calcul au prix selon le type de valorisation

Oxr

Calcul au prix de revient

Oxv

Calcul au prix de vente

Valeur alpha 2

Paramétrage des colonnes de l'édition

Par défaut : ABCDLMPQTU (marquées en gras dans le tableau ci-dessous)

A

Numéro de commande

B

Numéro ligne de commande

C

Code Client de la commande

D

Nom du Client

E

Code Produit de la ligne de commande

F

Désignation Produit

G

Code Famille

H

Libellé court Famille

I

Code Sous-famille

J

Libellé court Sous-famille

K

Quantité Commandée

L

Quantité Lancée

M

Quantité Fabriquée au niveau de la commande (C'est une quantité totale, elle ne tient pas compte de la date d'en-cours)

N

Quantité Livrée Commande (même remarque que M)

O

Quantité Facturée Commande (même remarque que M)

P

Coût Matière à la date de calcul de l'en-cours.

Q

Coût Opération à la date de calcul de l'en-cours.

R

Coût Sous-traitance à la date de calcul de l'en-cours.

S

Montant Production = Matière + Opération + S-Traitance

T

Montant Facturé

U

En-cours = Montant Production - Montant Facturé

V

Date de l'ouverture de commande

W

Délai Client

X

Délai Répondu

Y

Référence de la commande

Z

Libellé de la commande

a

En-cours de production

Si ligne de commande non soldée (d'un point de vue livraison)

Règle de 3 entre la quantité totale commandée et la quantité restant à facturer estimée par différence entre la quantité commandée et la quantité déjà facturée

En-cours de production = Montant Production X (Quantité Commandée- Quantité Facturée) / Quantité Commandée

a = S x (K - c) / K

Si ligne de commande soldée

Règle de 3 entre la quantité totale LIVREE et la quantité restant à facturer estimée par différence entre la quantité livrée et la quantité déjà facturée

En-cours de production = Montant Production X (Quantité Livrée - Quantité Facturée) / Quantité Livrée

a = S x (b - c) / b

b

Quantité Livrée à la date de calcul de l'encours

c

Quantité Facturée à la date de calcul de l'encours

d

Numéro de devis

e

Quantité emboîtée

f

Quantité emballée

g

Reste (quantité emballée - quantité livrée)

h

Quantité facturable (saisie sur le BL)

i

Reste a facturer (facturable - facturée)

j

Encours Net de production

Cet en-cours est calculé en excluant les quantités déjà intégrées en stock.

Ces quantités en stock sont valorisées par le programme Valorisation des produits finis.

La colonne l représente la quantité déjà intégrée en stock à la date de l'en-cours pour cette commande.

On retient tous les mouvements de fabrication.

Restriction pour les FB2 : Ne pas avoir le même produit sur plusieurs lignes de la même commande (commande ouverte).

Cette restriction vient de l'absence de numéro de ligne au niveau des mouvements de stocks.

Encours net = Montant Production X (Quantité Lancée - Somme (Mouvements Entrée Normale de PF) / Quantité Lancée

a = S * % (% représente la proportion de l'en cours = (Quantité Lancée - Mouvements) / Quantité Lancée

k

Encours Net de production:

Encours net = Montant Production X (Quantité Lancée - Quantité fabriquée) / Quantité Lancée

formule k = S*((L-M)/L)

L = p_lc.lc_qtelan

M = p_lc.lc_qtefab (cf commentaires sur M)

l

Entrée en stock issue de la fabrication

On tient compte de la date d'en-cours, c'est une somme algébrique (Entrée -Sortie) pour tous les mouvements (TMV) pris en compte.

m

Valeur de la commande (indépendante de la date de calcul)

Ligne de commande = Valeur de la ligne de commande

Cumul commande = Somme des valeurs des lignes de commande composant la commande

n

Valeur de la commande hors frais sur vente

Idem m - frais sur vente

Voir valeur numérique 2 dans FAM

o

Valeur main d'œuvre au taux des amortissements.

(Temps des responsables uniquement)

(Paramétrage de l'environnement de valorisation des amortissements sur le paramètre de lancement.)

p

Valeur main d'œuvre au taux complet - taux des amortissements (Q - o)

Valeur "sèche" du montant main d'œuvre.

q

Montant facturé hors frais sur vente et frais de transport

Voir valeur numérique 2 dans FAM

r

Valeur stock du lot

s

Valeur stock du lot hors frais sur vente

Voir valeur numérique 2 dans FAM

t

Valeur stock comptable

s x (1 - o / S) = Valeur stock au prix de revient - part des amortissements

u

Valeur stock comptable corrigée

t * coef. paramétré sur paramètre de lancement

Le coef. est en général donné par la comptabilité et tient compte des bénéfices de la société, etc ...

v

Encours direct

L'encours direct est égal au prix de revient diminué du montant des vente et stock.

v = P + Q + R - q - s

w

Encours comptable

L'encours comptable est égal à l'encours direct diminué de la valeur des amortissements techniques des produits fabriqués.

w = v - (max(n, (s + q)) - (s + q)) / max(n, (s +q))

PR complet limité à la valeur en PR de la commande

- Valeur facturée (en PR)

- Valeur stock (en PR)

- Amortissements et frais fixes de production correspondant à la part des produits devant encore être fabriqués (c'est à dire les produits ni livrés, ni en stock)

Remarque : la valeur de la commande peut être ajustée par un pourcentage correspondant au dépassement autorisé par le client. (passe acceptée)

x

Coût matière spécifique (Ex. Papier)

Voir FAM, alpha3[33]

y

Coût matière non spécifique

Coût matière total - coût matière spécifique

z

Montant facturable

si ligne commande soldée : montant reste à facturer = quantité livrée * prix

si ligne commande non soldée : montant reste à facturer = quantité commandée * prix

1

Montant reste à facturer

T - z (Montant facturé - montant a facturer)

2

Dossier clos ou encours

Clos ---> Dossier clos

En C ---> Dossier en cours

3

à facturer

4

Pourcentage d'abattement fixe

Voir la note POURC_ABAT_FIXE

5

Encours calculé (encours – abattement fixe)

6

RESERVE

7

RESERVE

8

RESERVE

9

RESERVE

0

RESERVE

è

RESERVE

&

RESERVE

é

RESERVE

#

RESERVE

*

RESERVE

à

RESERVE

<

RESERVE

>

RESERVE

Valeur alpha 3

Caractères 1 à 3 | Code environnement pour la valorisation des temps par centre de coût (cet environnement correspond à l'environnement Coût complet)
Caractères 4 à 6 | Code environnement pour la valorisation des temps par centre de coût (cet environnement correspond à l'environnement Amortissements + frais fixes de production)Seuls les temps des responsables sont pris en compte dans ce calcul
Caractères 7 à 11 | Pourcentage pour correction stock comptable (colonne u) (u = t * correction / 100)
Caractères 12 à 16 | Passe acceptée (colonne w) Valeur commande corrigée = valeur commande * (1 + passe)
Caractère 17 | Prise en compte de la remise entête lors de la valorisation au prix de vente de la ligne de commande L'option Ovl doit être activée.
Caractère 18 | Prise en compte de la remise ligne lors de la valorisation au prix de vente de la ligne de commande L'option Ovl doit être activée.
Caractères 19 à 24 | RESERVES
Caractère 25 | Masque le message Opération XXX a disparu (O/N, N par défaut)
Caractère 26 | Type de tri 1 Tri par commande, ligne de commande 2 Tri par client, commande, ligne de commande Obligatoire en mode batch, voir option -B

Notes triées

CODE_PHASE_CCOLLAGE

RESERVE

CODE_PHASE_DECOUPE

RESERVE

COL_PAS_EDI_SI_ENC_0

21 Pas d'édition de la ligne si l'encours est à 0

Nom de la colonne (U et v)

Colonne U Encours

Colonne v Encours direct

Facultatif - Pas de valeur par défaut

COL_SI_ENC_NEGATIF

21 Edition et cumul de l'encours de la ligne si l'encours est négatif

Nom de la colonne (U et v, U par défaut)

Colonne U Encours

Colonne v Encours direct

Facultatif - Voir options On1, On2, On3 et On4

EXCEPT_TEST_TERMINE

Voir plus bas, à la suite de la note TEST_PHASE_TERMINEE

POURC_ABAT_FIXE

Pourcentage d'abattement fixe (colonne 4)

POURCENT_ABATTEMENT

21,26 Pourcentage d'abattement à appliquer sur la quantité lancée pour l'exclusion automatique d'ordre de fabrication

POURC_DEPASS_QTE

RESERVE

POURC_DEPASS_TMP

RESERVE

PRORATISATION_ETAPE

Valorisation des encours par étape

21,30 Numéro de la phase débutant l'étape

31 Méthode de calcul de l'encours à cette étape :

0 Etape Affiche : On cumule les différents coûts

1 Etape Produits finis : On proratise les coûts des étapes précédentes par rapport à la quantité produite puis on ajoute les coûts de l'étape en cours

2 Etape Stockage : On proratise les coûts des étapes précédentes par rapport à la quantité restante puis on ajoute les coûts de l'étape en cours

33,42 Code de l'étape

50 Méthode de calcul de la quantité produite

S Quantité entrée en stock pour le produit

[Blanc] : Quantité remontée dans le dossier de production

_SUP_REQ_CDE1_CDE2

21,60 Complément de requête sur les tables cde1 et cde2

_SUP_REQ_FAB0

21,60 Complément de sélection sur la table fab0 pour la recherche des coûts matière

_SUP_REQ_FAB0_COMPO

21,60 Complément de sélection sur la table fab0 pour la recherche des coûts matière avec proratisation au pourcentage d'encours

Exemple : and f0_prod matches "Q-*"

_SUP_REQ_FAB1

Supplément de requête pour la table fab1

_SUP_REQ_FAB2

21,60 Complément de sélection sur la table fab2 pour la recherche des coûts opération

Exemple : and f2_cdc = "C-1"

_SUP_REQ_FAB0_PHA

RESERVE

_SUP_REQ_FAB2_QTE

RESERVE

_SUP_REQ_FAB2_TPS

RESERVE

_SUP_REQ_STK0

21,60 Complément de sélection sur la table stk0 pour la recherche de la valeur d'entrée en stock issue de la fabrication (hors commandes de type FB1 et FB2)

Exemple : and s0_typ = "FR" and s0_es = "E"

_SUP_REQ_STK_PROD

Complément de requête sur la table stk0 pour le calcul des quantités produites dans le cas d'une méthode de type S

TEST_PHASE_TERMINEE

21,25 Définition de la portée d'une phase.

Cette ligne permet de spécifier que les temps et les matières affectés à une phase ne sont pris en compte que si la phase est terminée à la date de calcul.

La notion de portée d'une phase permet de déterminer informatiquement parlant ce que l'on appelle une phase.

Explications

Quand on saisit un temps ou une consommation matière, on l'affecte à un numéro de phase dans le dossier.

Généralement, cela correspond à une ligne d'opération ou de matière dans le devis (exemple : la phase 3002 pour une opération correspond à la 2nde ligne d'opération de la phase 30 de la gamme du devis).

Donc, si on ne souhaite prendre en compte la valeur que si la phase 30 de la gamme du devis est terminée, il faut que le programme aille rechercher la dernière opération de la phase 30 pour déterminer sa date de fin.

Conclusion, les phases du dossier étant numérotées 3001, 3002, 3003,...; la définition de la portée de la phase est donc de 100 (du numéro 3000 à 3100).

Si on ne veut tester que la fin de l'opération concernée, la définition de la portée est de 1 (c'est la valeur par défaut).

Si on ne veut pas tester cette date de fin, on ne met pas la note.

Les exceptions pourront être déclarées dans la note EXCEPT_TEST_TERMINE

Pas définissant une phase. Exemple avec un pas de 1000 :

1ère phase : numéros de 1 à 999

2nde phase : numéros de 1000 à 1999

3ième phase : numéros de 2000 à 2999

etc….

EXCEPT_TEST_TERMINE

21,29 Triplet des opérations auxquelles ne s'applique pas la note TEST_PHASE_TERMINEE

31,60 Complément de requête applicable sur les tables fab3, fab0 et mat pour restreindre le calcul du coût de consommation dans fab3 pour ce triplet.

Attention, on prend quand même en compte la date de consommation de fab3 par rapport à la date de calcul.

Explications

Le Papier Pour Impression (PPI) est consommé à la date de saisie, mais la phase associée n'a pas d'opération.

Elle n'a donc pas de date de fin, et quand bien même, le papier est consommé même si la phase n'est pas finie.

Par conséquent, on paramètre le triplet de l'opération liée comme étant une exception et on limite les consommations calculées aux familles PPI et PPO (Papier Pour Ondulé qui se traite de la même manière) par la note suivante :

EXCEPT_TEST_TERMINE MSTMSTMSV and mp_fam in ('PPI','PPO')

NB : Il est possible de saisir plusieurs lignes de ce type sur le même triplet pour paramétrer un complément de sélection plus complexe. Exemple :

EXCEPT_TEST_TERMINE MSTMSTMSC and (mp_fam = 'PPI'

EXCEPT_TEST_TERMINE MSTMSTMSC or mp_fam = 'PPO')

TITRE_c

où c représente le code de la colonne (voir les codes en alpha2)

Paramétrage des titres des colonnes. Attention : les titres des colonnes sont limités en longueur.

11, 40 Titre de la colonne

TYPES_ARTICLE_MAT

Types d'article (mp_param[10]) à cumuler dans la colonne P (Coût Matière) N, P, A et F par défaut

TYPES_ARTICLE_ST

Types d'article (mp_param[10]) à cumuler dans la colonne R (Coût Sous-Traitance) O par défaut.2

Autres paramètres

PHA A2[59]

RESERVE

Opérations

Paramètre TTR alpha1[19]

Sous-traitance ope0.o0_st = O

Matières

Paramètre TMT A1[5]

Sous-traitance mp_param[10] = O

Optimisation

Si vous recherchez les factures rattachées au dossier, l'édition peut être longue.

Pour diminuer les temps de traitement, il faut rajouter un index sur la table des lignes de commandes (cde2) ==> lc_soc, lc_cderat, lc_lcderat


Boucle de génération des dossiers de fabrication

Boucle de génération des dossiers de fabrication gdf_ondu2

Cliquez ici pour accéder au site internet de PC-TOPP avec la description des fichiers.

Voir aussi l'autre programme de génération de dossiers (gdf_ondu).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de dossier - numéro de ligne de dossier

Exemples :

-N[ec_num]

-N[lc_num|-|lc_lig+<<&]

Valeurs numériques

1

Nombre de boucles à faire avant l'arrêt automatique du programme

(le programme boucle tant qu'il ne voit pas le fichier de demande d'arrêt)

Options triées

Oar

Arrêt du programme en tâche de fond

Obg

Blocage génération

Cette option bloque la génération mais n'empêche pas le transfert vers PC-TOPP

Oci

On envoie les refoulages à PC-TOPP même en cannelure inversée

Ode

Debug écran

Odf

Debug fichier

Odp

Permet la régénération après la déclaration de production

Oep

Crée une entrée prévisionnelle sur le produit lancé

Oex

Mode expert (pour les contrôles possibilité)

Oft

On force le transfert PC_TOPP

Oge

Active la gestion des excédents

Ope

Palettisation des ensembles montés

Opo

Papier pré-imprimé obligatoire si référence de pré-impression

Oqp

Transférer à PCTOPP la quantité lancée la quantité la plus proche correspondante à un nombre de palette comptée

La quantité par palette est sur le TSC 220, zone ic_num1

La quantité utilisée est la quantité lancée initiale à laquelle on applique l'éventuelle tolérance de quantité.

Orb

Active le mode recalcul batch des devis => n'affiche plus les messages de recalcul

Org

Régénération

Osi

Particularités SI

Oso

Particularités SO

Osp

Crée une sortie prévisionnelle sur les composants de niveau (n+1)

Ote

Test devis

Otf

Le programme tourne en tâche de fond

Otp

Transfert PC-Topp

Ott

Transfert transitoire (pour les anciennes commandes)

Valeur alpha 2

Caractères 1 à 3 | Code environnement de valorisation (coût complet / prix de cession)
Caractères 4 à 6 | Type de mouvement de sortie prévisionnelle
Caractères 7 à 9 | Type de mouvement d'entrée prévisionnelle
Caractères 10 à 12 | Famille qualité carton (inutilisé)
Caractères 13 à 15 | Sous-famille qualité carton (inutilisé)
Caractères 16 à 18 | Code environnement de valorisation (coût incomplet / prix PUMP)
Caractère 19 | Caractère @ pour le transfert PC TOPP partiel. Voir les notes commençant par FIC
Caractère 20 | Type de transfert P Transfert partiel C Transfert complet [blanc] Demande de confirmation pour transfert partiel. Dans la négative, transfert complet (par défaut).
Caractère 21 | Code gamme standard (uniquement si type de commande = transformé) L sur la ligne de commande sinon sur le PF
Caractère 22 | Régénération des OF 1 Régénération des OF dont la date de fabrication est supérieure ou égale à la date indiquée dans le paramètre TOP GRD, alpha1[1,10]. 2 Régénération OF suite à modification de commande Autres valeurs : Génération batch des OF
Caractères 23 à 26 | Temps d'attente, exprimé en secondes. Valeur par défaut : 600
Caractère 27 à 32 | Code de la machine de transformation à enregistrer lorsque la quantité lancée est nulle (STK par défaut)

Valeur alpha 4

Caractères 1 à 3 | Code gamme pour ordres de marche
Caractères 4 à 6 | Code erreur ? GAM par défaut

Notes

ALIM_ZONE_zzz_t

Paramétrage de l'alimentation de la zone zzz avec le type de commande t - SPECIFIQUE

où t peut prendre les valeurs suivantes, en fonction du type de commande :

C commande cartonnier (FB2)

S mode de réapprovisionnement de l'article synchrone

A autres

21,26 Code du client

30 Méthode à appliquer

1 Alimentation par la référence de la ligne de commande (lc_p3) ou, à défaut, par la référence de la commande commerciale (ec_ref de la commande de rattachement) [Valeur par défaut pour les types de commande C]

2 Alimentation par la référence de la commande commerciale (ec_ref de la commande de rattachement)
[Valeur par défaut pour les types de commande A et S]

3 Alimentation par la concaténation de la référence de la commande commerciale (ec_ref de la commande de rattachement), suivi de la référence de la ligne de commande (lc_p3) [les 2 zones seront séparées par un trait d'union].

Actuellement, ce paramétrage n'est actif que pour la zone 52.2 (numéro de la commande dans les données spécifiques).

Exemple pour le client C04620

ALIM_ZONE_52.2_C C046203

CF_MAJ_FLAG_INFO_C

Voir page dédiée

FIC_ANOMALIE

21 à 60 Nom du fichier anomalie

FIC_ARRET

21 à 60 Nom du fichier arrêt

FIC_LOCK

21 à 60 Nom du fichier lock Plus d'infos

FIC_LOCK_PCTOPP

21 à 60 Nom du fichier lock PCTOPP Plus d'infos

FIC_LOCK_VS

21 à 60 Nom du fichier lock VS Plus d'infos

FIC_PCTOPP

21 à 60 Nom du fichier PCTOPP

FIC_TRACE

21 à 60 Nom du fichier trace

MAJ_FLAG_INFO_C

Voir page dédiée

PCTOPP_COMMENTAIRE

Possibilité d'éditer des commentaires (ligne de type C) dans le fichier PCTOPP

21 à 24 Code destination PCTOPP

CORS Planning onduleuse

CORT Terminal onduleuse

RCL Impression onduleuse

CNVS Planning de transformation (toutes les machines de transformation de la gamme)

CNVT Terminal de transformation (toutes les machines de la gamme)

RCVM Impression transformation (toutes les machines de la gamme)

SALE Ventes

SHIP Expédition

22 à 60 Paramétrage de lecture de l'information complémentaire (TSC) alimentant le commentaire

TSC_XXX_YYY_G où

XXX Origine du TSC

CAS01 Cascade mode 1

1 Séquence ligne de commande de rattachement

2 Ligne de commande de rattachement

3 Produit fini

4 Ensemble

5 Client + adresse de livraison de la ligne de commande de rattachement

6 Client de la commande de rattachement

CAS02 Cascade mode 2

1 Triplet

2 Produit fini

3 Ensemble

YYY Code TSC

G Zone alphanumérique de 30 caractères

_SUP_SQL_FAB0

21,60, Complément de sélection des ordres de fabrications à générer/régénérer (table fab0)


Edition des prix de revient des ensembles

Edition des prix de revient des ensembles prix_revient_ensemble

Valeurs numériques

1

Nombre de décimales de la colonne quantité. Ce nombre doit être compris entre 0 et 3.

Valeur alpha 2

1 | Type de l'historique de la table des historiques des prix de revient (hist_pr) de la zone quantité réalisée. Obligatoire. Exemple : F
2,3 | Numéro de la zone numérique de la table des historiques des prix de revient (hist_pr) de la zone quantité réalisée. Obligatoire Ce numéro doit être compris entre 1 et 15 Exemple : 05
4 | Type de l'historique de la table des historiques des prix de revient (hist_pr) de la zone coût réalisé. Obligatoire. Exemple : F
5,6 | Numéro de la zone numérique de la table des historiques des prix de revient (hist_pr) de la zone coût réalisé. Obligatoire Le numéro doit être compris entre 1 et 15 Exemple : 02

Notes

SUP_REQ_NOM0 | 21,60 Supplément de requête sur la table des nomenclatures (nom0). Exemple : and n0_cli = "#SOC"
SUP_REQ_HIST_PR | 21,60 Supplément de requête sur la table des historiques de prix de revient (hist_pr) Exemple : and hp_client = "#SOC"


Saisie des entrées / sorties de véhicules

Saisie des entrées / sorties de véhicules suivi_vehicules

Ce programme est opérationnel à partir de la V. 4.1.13.2

Il permet de saisir les entrées/sorties des camions de l’usine.

A l’entrée de l’usine, le camion est pesé et donne le motif de transport (la raison pour laquelle il vient : déchargement de papier, bobine ou chargement de produit fini)

Lors de sa sortie, il est de nouveau pesé et selon le motif donné, un numéro de bon de réception ou numéro de groupage BL sera demandé (selon paramétrage).

Si le camion vient pour décharger son chargement puis en charger un, il devra faire trois passages au point de contrôle.

A l’entrée, il est pesé, le motif est renseigné et l’utilisateur indiquera que le camion reviendra pour une pesé intermédiaire.

Une fois le camion déchargé, il ira au point de contrôle pour une pesée.

Puis il ira charger sa cargaison. Une fois celle-ci faite, avant de quitter l’usine, le camion sera de nouveau pesé.

Options

Ocs

Mode consultation

Valeur alpha 2

A2[1]

Initialisation du filtre avec la date du jour

Noms de zones autorisés

suiv_vehicule | Voir le package
groupage_bl | Voir le package
b_rec_ret_e | Voir le package
b_rec_ret_d | Voir le package

Voir aussi

v_suivi_vehicules | Visualisation des entrées / sorties de camions
MOV | Nouveau type de paramètre : Motif de transport
v_groupage_bl v_jda v_brc | Disponibilité de la nouvelle table suiv_vehicule


Transfert des préparations - Liste des palettes

Cette nouvelle fonctionnalité permet de tronquer le code palette lors du transfert de la liste des palettes.

Utile dans le cas d'un changement de longueur du code palette.

Exemple

Vous avez géré jusqu'à présent un code palette sur six caractères

Maintenant vous souhaitez un code palette sur huit caractères.

Lors de vos transferts, tous vos codes palettes seront sur huit caractères.

Or l'application qui va utiliser le fichier texte créé risque de ne pas retrouver les codes palettes qui étaient avant sur six caractères.

Cette fonctionnalité permet de tronquer tous les codes palettes inférieurs à telle valeur.

Transfert des préparations - Liste des palettes trans_pal_exped

Ce programme est opérationnel à partir de la V. 4.0.203.2

But : Pouvoir générer un fichier par BL, contenant les informations sur les palettes expédiées.

On utilise la mécanique standard de flag/déflag.

La mécanique se base sur la gestion d'un TSC.

A chaque modification de BL (gestion du BL en mode dégradé avec picking du numéro de palette), ce TSC sera positionné comme étant à transférer.

(cette mécanique sera aussi à mettre en œuvre dans le module de préparation des expéditions en mode CAB – G_prep_cde_cab)

A chaque transfert, il sera mis à jour comme étant transféré.

Le fichier en sortie, (un fichier par BL), sera nommé avec un préfixe, le numéro de BL (avec la ligne) et un horodatage.

Il sera construit ainsi :

1ière ligne : numéro de bon de livraison_ ligne de bon de livraison

2ième ligne : NEW/UPDATE/DELETE/FINISH

3ième ligne : le nombre de palettes prévues

4ième ligne : la liste des palettes séparées par des : (XXXX si aucune palette prise)

5ième ligne : le numéro de commande

6ième ligne : le produit livré

L'action DELETE implique de prendre en compte les BL annulés lors du traitement du transfert.

L'action FINISH implique de mettre en place la gestion du flag de transfert lors de l'édition définitive du BL.

Mise en place d'une copie du fichier généré dans un répertoire dédié.

Mise en place du paramétrage de l'extension du fichier (.txt, …)

Dans la construction des palettes, celles-ci peuvent ne pas encore avoir été saisies dans le BL, il faut donc aller les rechercher dans les tables conteneur_info et conteneur_produit (les prélèvements en premier, et dans l’ordre de création) à concurrence du nombre de palettes prévues.

Paramétrage préliminaire

blv

Note MAJ_FLAG_INFO_C

prep_cde_cab (à faire)

Valeur alpha 2

A2[1,3]

Code du TSC gérant le transfert

Notes

ATTENTE_LIB_SERVICE | 21,60 Temps en secondes d'attente de libération du verrou du programme externe
ATTENTE_LIB_VSW | 21,60 Temps d'attente pour libérer le verrou du programme Volume
EXT_FIC | 21,60 Extension du fichier (txt, ...)
FICHIER_ERREUR | 21,60 Nom du fichier erreur
FICHIER_LOCK_SERVICE | 21,60 Nom du fichier de lock du programme externe
FICHIER_LOCK_VS | 21,60 Nom du fichier de lock Volume Software
FICHIER_TRACE | 21,60 Nom du fichier trace
FICHIER_UNICITE_EXE | 21,60 Nom du fichier qui garantit l'exécution d'un seul programme à la fois
HORODATAGE | 21,60 Format de l'horodatage (cf gestion dans les visus) Le nom du fichier peut être horodaté grâce aux mots-clés suivants : %D2% Date du jour au format aammjj %D4% Date du jour au format aaaammjj %HM% Heure courante au format hhmm %HS% Heure courante au format hhmmss
PREFIX_FIC | 21,60 Préfixe du fichier en sortie
REP_COP | 21,60 Répertoire de copie pour la version OSYS
REP_FIC | 21,60 Répertoire de stockage du fichier généré
_SUP_REQ_BLV1 | 21,60 Supplément de requête sur l'entête de BL
_SUP_REQ_BLV2 | 21,60 Supplément de requête sur la ligne de BL
_SUP_REQ_CONTENEUR | 21,60 Supplément de requête sur les tables conteneur_info et conteneur_produit
_SUP_REQ_PAL_EXP3 | 21,60 Supplément de requête sur pal_expedition_3
TRONQUE_INF_CP | Tronquer le numéro de palette à envoyer 21,28 Numéro de palette Si le code palette est strictement inférieur à cette valeur, alors le code palette sera tronqué. 30,31 Longueur du numéro de palette 33,34 Début de la zone à conserver (min : 1) 36,37 Fin de la zone à conserver (max : longueur du numéro de palette défini en car.30,31) Cliquez pour plus d'info
TRONQUE_SUP_CP | Tronquer le numéro de palette à envoyer 21,28 Numéro de palette Si le code palette est supérieur ou égal à cette valeur, alors le code palette sera tronqué. 30,31 Longueur du numéro de palette 33,34 Début de la zone à conserver (min : 1) 36,37 Fin de la zone à conserver (max : longueur du numéro de palette défini en car.30,31) Voir remarque ci-dessus pour l'utilité de ces 2 notes.

Création du TSC gérant le transfert

En alpha4 : Nom du TSC, utilisé dans la recherche des BL à transférer, stocké en zone ic_char30 du TSC.

La création du TSC (de type livraison L) en modification de BL, mettra à jour

- La zone A : avec la date de création du TSC

- La zone C : avec l'heure de création du TSC

- La zone F : avec la valeur pour demander le transfert

Le module de transfert des préparations mettra à jour ce TSC

- La zone F : avec la valeur indiquant que le transfert a été effectué

- La zone B : avec la date de transfert

- La zone D : avec l'heure de transfert

Paramétrage de la saisie dégradée des BL (gestion du picking de chaque palette)

Commande standard de flag du TSC

TSC TPE de type L (livraison)

Mise à jour de la zone F avec la valeur O.

La clé du TSC est construite avec le numéro et la ligne du BL.

Edition définitive du BL

Commande standard de flag du TSC

TSC TPE de type L (livraison)

Mise à jour de la zone F avec la valeur O.

La clé du TSC est construite avec le numéro et la ligne du BL.

Il sera mis à jour lors de l'édition définitive du BL.

Module de transfert


Interface de mise à jour des affrètements

Interface de mise à jour des affrètements interface_maj_affret

Ce programme est opérationnel à partir de la V. 4.0.192.2

Les champs gb_autorise_ajout, gb_autorise_modif et gb_autorise_annul ont été ajoutés à la table groupage_bl.

Ils peuvent prendre comme valeur N ou O, O étant la valeur par défaut.

Le module permet de mettre à jour ces 3 champs à partir d'un fichier.

Le fichier des affrètements à mettre à jour doit contenir au moins les champs gb_no_groupage, gb_ligne_groupage, autorise_entete et autorise_ligne.

Les seules valeurs autorisées des champs autorise_entete et autorise_ligne sont 0 et 2.

Si les champs autorise_entete et autorise_ligne sont à 0, la ligne du groupage aura O dans les champs gb_autorise_ajout, gb_autorise_modif et gb_autorise_annul.

Si le champ autorise_entete est à 0 et le champ autorise_ligne est à 2, la ligne du groupage aura O dans le champ gb_autorise_ajout et N dans les champs gb_autorise_modif et gb_autorise_annul.

Si le champ autorise_entete est à 2, toutes les lignes du groupage auront N dans les champs gb_autorise_ajout, gb_autorise_modif et gb_autorise_annul.

Le champ autorise_ligne ne sera pas utilisé.

Tableau récapitulatif

autorise_entete | autorise_ligne | gb_autorise_ajout | gb_autorise_modif | gb_autorise_annul
0 | 0 | O (Oui) | O (Oui) | O (Oui)
0 | 2 | O (Oui) | N (Non) | N (Non)
2 |  | N (Non) | N (Non) | N (Non)

Options

Oar | Arrêt du programme en tâche de fond
Osi | Simulation - Les lignes de groupage ne sont pas mises à jour.
Oup | Arrêt du programme en tâche de fond après un seul passage.

Valeur alpha 2

A2[1,4]

Délai d'attente en minutes - Facultatif - 1 minute par défaut

Notes

CHAMP_FICHIER CTRL_CHAFIC_UNICITE | 21,38 Nom du champ - Obligatoire Tous les champs de la table groupage_bl et les champs autorise_entete et autorise_ligne 41,43 Position de début du champ - Obligatoire 45,47 Longueur du champ - Obligatoire Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique. Fonctionne avec la note CHAMP_FICHIER) O chaque nom de champ doit être unique (par défaut) N pas de contrôle
FIC_ANOMALIE | 21,60 Nom du fichier des anomalies - Obligatoire
FIC_ARRET | 21,60 Nom du fichier d'arrêt - Obligatoire
FIC_INTERFACE | 21,60 Nom du fichier des affrètements à mettre à jour - Obligatoire
FIC_INTERFACE_REP | 21,60 Répertoire du fichier des affrètements à mettre à jour - Facultatif
FIC_INTERFACE_REP_H | 21,60 Répertoire historique du fichier des affrètements à mettre à jour - Facultatif
FIC_LOCK | 21,60 Nom du fichier du lock général posé par le programme - Obligatoire
FIC_LOCK_EXT | 21,60 Nom du fichier du lock posé par un programme externe - Obligatoire
FIC_LOCK_VS | 21,60 Nom du fichier du lock posé par le programme qui peut être utilisé par un programme externe - Obligatoire
FIC_TRACE | 21,60 Nom du fichier de trace - Obligatoire

Les contrôles d'autorisation d'ajout, de modification et d'annulation sont gérés dans les modules de préparation des affrètements (G_prep_affret) et d'expédition des affrètements (G_exped_affretements).

Exemple de paramétrage

FIC_INTERFACE maj_affret_int*

FIC_INTERFACE_REP affret/

FIC_INTERFACE_REP_H affret/histo/

FIC_LOCK affret/maj_affret_lck

FIC_LOCK_EXT affret/maj_affret_lck_ext

FIC_LOCK_VS affret/maj_affret_lck_vs

FIC_ARRET affret/maj_affret_arr

FIC_ANOMALIE affret/maj_affret_ano

FIC_TRACE affret/maj_affret_tra

CHAMP_FICHIER gb_no_groupage 1 8

CHAMP_FICHIER gb_ligne_groupage 9 3

CHAMP_FICHIER autorise_entete 12 1

CHAMP_FICHIER autorise_ligne 13 1

1 2 3 4

123456789012345678901234567890123456789012345


Bordereaux transporteurs

Bordereaux transporteurs bortrans

Options

Ony

Numérotation annuelle des bordereaux

Valeurs numériques

1

Exploitation de plusieurs compteurs

Valeur alpha 2

Caractère 1 | Mode de validation chauffeur. Obligatoire P Préalable N Non S Seule
Caractère 2 | Mode de validation comptable. Obligatoire P Préalable N Non S Seule

A2[1,2] Tableau des compatibilités |  | Chauffeur
 |  | P | S | N
Comptable | P | OK | NON | NON
 | S | NON | NON | OK
 | N | NON | OK | OK

Valeur alpha 3

Caractères 1 à 60

Titre de l'écran

Notes

COMP_SQL_BLV | 21,60 Complément de requête SQL sur les entêtes de BL.
PROGRAMME_EDI_BLV | 21,26 Type et code du paramètre de lancement de l'édition des BL. Par défaut : #ED BLV
PROGRAMME_EDITION | 21,26 Type et code du paramètre de lancement de l'édition des bordereaux de transport. Par défaut : #ED BOT
TYB_ACCEPTE | 21,60 Type de bordereau accepté. On peut indiquer jusqu'à 10 notes maximum.
TYB_DEFAUT | 21,60 Type de bordereau par défaut
TYPE_NOTE_ENTETE | 21,60 Types de notes d'entête (par défaut : BOT)
TYPE_NOTE_LIGNE | Types de notes de lignes. Doivent être regroupées (si 1 et 3 sont identiques mais que 2 est différent, message d'erreur : les 2 identiques doivent être en 1 et 2 ou 2 et 3). 21 index (de 1 à 3) 22 [espace] 23,40 table (valeurs par défaut, en fonction de l'index : 1 - CLI3 , 2 - BLV3 , 3 - BLV3) 41,43 type (valeurs par défaut, en fonction de l'index : 1 - LIV, 2 - LIV, 3 - BOT)


Génération du fichier des déclarations d'échanges de biens

Génération du fichier des déclarations d'échanges de biens deb

Valeurs numériques

1

Numéro de transmission du fichier DEB

Valeur alpha 2

A2[1,3] | Code site - Tableau de bord du multisite
A2[4,5] | Code usine
A2[6,7] | Code dépôt
A2[8,9] | Racine du numéro de BL
A2[10] | Regroupement des lignes de DEB par numéro de pièce et nomenclature douanière (O/N, N par défaut)
A2[11] | Forçage des zones 21 & 22 en FRS après bascule en EURO (O/N, N par défaut)
A2[12] | Contrôle du numéro intracom des factures N pas de contrôle (fonctionnement actuel) 1 l'anomalie est consignée et la ligne ne sera pas générée. 2 l'anomalie est consignée et la ligne sera générée.

Notes

CSB1 | 5,60 Complément de select sur blv1 (obligatoire en mode batch)
CSB2 | 5,60 Complément de select sur blv2 (obligatoire en mode batch)
CSF | 4,60 Complément de select sur fac0 (obligatoire en mode batch)
FAMILLES_OUTILLAGES | 21, 59 Liste des codes familles de type frais 13 codes familles par ligne, sous la forme : AAABBBCCC…MMM
FICH_DEB | 9,60 Nom du fichier DEB à générer
PARAM_TARIF_FBI | 21,26 Type et code du paramètre de recherche des tarifs (par exemple, #CFTAR) - Pas de valeur par défaut 27,29 Code du tarif recherché (ex : DEB)

Paramètres nécessaires

DEV A1[1,2] | Code ISO de la devise (seuls les caractères 1 et 2 sont utilisés).
FAM A2[13,25] | Nomenclature douanière par défaut
PAY A1[7,9] | Code pays normalisé pour la déclaration d'échange de biens entre états membres (CE)
PAY A1[14] | Pays faisant l'objet d'une déclaration d'échange de biens entre états membres (CE)
PAY A1[22,35] | Numéro de TVA du pays
POR A1[4,6] | Code INCOTERM normalisé pour la déclaration d'échange de biens entre états membres (CE)
RG1 A1[12] | Type de lieu de rangement ou de magasin (1 - 2 - 3 - 4 - 5)
RG1 A1[13] | Type de lieu de rangement (Interne - Externe)
RG1 A1[14,19] | Code du tiers
RG1 A1[20,22] | Code de l'adresse du tiers
TAR DEB | Tarif de vente d'un FBI de transfert
TRS A1[2] | Code normalisé (CE) pour envoi DEB
TVA A3[41,43] | Code pays TVA
TVA A3[44,57] | Numéro d'immatriculation TVA
TYC A3[14] | Prise en compte dans les statistiques du poids et de la surface en commande
#CF DKP | Notes commençant par NOMENCLATUREDEB
#CF EUR A1[26,28] | Devise société avant passage à l'EURO


Saisie des véhicules

Saisie des véhicules vehicules

Option payante. Clé d'activation de type LIV numéro 6

Gestion des véhicules de location

Nouveau module permettant la saisie des véhicules (nouvelle table vehicules).

On peut créer, modifier, éditer des véhicules. Chaque véhicule est rattaché à un transporteur.

Un état de disponibilité est saisi pour une période donnée.

Lors de la valorisation d'un affrètement, on peut rechercher les tarifs des véhicules de location disponibles via un bouton d'action situé dans la fenêtre de choix des tarifs.

Deux nouvelles zones de la table groupage_bl sont alors renseignées : le kilométrage prévu (gb_km_prev) et le véhicule prévu (gb_vehicule_prev).

Dans le module de préfacturation, le coût du transport est revalorisé.

On cumule alors les distances parcourues pour le véhicule sélectionné sur le mois du transport (table veh_distance).

Une valorisation particulière est effectuée via le module interface_prefac dans le cas d'un transport avec un véhicule de location et un mode de transport de location (mode paramétré dans le #CF LOG).

Cette valorisation se base sur la distance déjà parcourue du véhicule sélectionné sur le mois du transport.

Si le kilométrage d'un affrètement couvre deux plages kilométriques de tarif, alors le calcul du coût tient compte de ces plages kilométriques.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code véhicule

Exemple : -N[gb_vehicule]

Valeur alpha 2

1 | Contrôle si le transporteur possède au moins un type de véhicule N Non / W Warning / C Confirmation / B Bloquant
2,4 | Type de véhicule par défaut (type TVE)
5,7 | Mode de transport par défaut (type TRS)
8,10 | Etat véhicule par défaut (type ETV)
11,16 | Transporteur par défaut

Notes

Notes se terminant par LISTE_VEH :

Création automatique d'un fichier de liste des véhicules à la validation de la saisie et/ou via un menu (option Liste du menu principal de l'application).

Le fichier liste contient les informations suivantes, séparées par le caractère pipe :

• Code véhicule (vehicules.veh_vehicule)

• Désignation du véhicule (vehicules.veh_des)

• Code transporteur (vehicules.veh_transp)

FICHIER_LISTE_VEH

Création automatique d'un fichier de liste des véhicules (voir explications en début du paragraphe )

21,60 Chemin d'accès et nom du fichier de liste des véhicules

Remarques :

• Ce paramétrage active la création automatique du fichier liste et l'apparition du menu Liste.

• Le nom du fichier sera complété automatiquement par un horodatage sous la forme _yyyymmdd_hhmms, situé à la fin du nom ou avant l'extension.

Exemples

Sur la base d'une construction de la liste le 02/07/2010 à 11h 39m et 12s.

• Si le nom du fichier paramétré est liste_veh.txt, le fichier créé aura pour nom liste_veh_20100702_113912.txt

• Si le nom du fichier paramétré est liste_veh, le fichier créé aura pour nom liste_veh_20100702_113912

_SUP_SQL_LISTE_VEH

Création automatique d'un fichier de liste des véhicules (voir explications en début du paragraphe Notes)

21,60 Complément de sélection des véhicules à prendre en compte pour la construction du fichier liste

Paramètres nécessaires

#CF LOG A1[27,29] | ZZZ Mode de transport correspondant à la location (code de type TRS)
TRS ZZZ A1[22] | Valorisation de ce mode de transport avec distance incluant le retour au point de départ (O/N, N par défaut)
ETV A1[1] | Disponibilité du véhicule (O/N, N par défaut


Interface transport VoluPack JDE

Interface transport VoluPack JDE tr_jde_groupage

Cette interface permet de transférer les groupages vers JDE.

Elle peut être lancée en mode batch. Elle s'exécute à l'infini en tâche de fond. Un autre batch est nécessaire pour la stopper.

Etude : \\VOLUNT\TIERS\Clients\Emin Leydier\Technique\Etudes\ETU_PM_Analyse détaillée Interface transport V9.doc

Options

Oar | Demande de l'arrêt du traitement en batch
Osi | Mode Simulation (les lignes de commandes ne sont pas marquées comme transférées)
Oup | Exécution d'une seule boucle en traitement Batch

Valeur alpha 2

1,4

Durée d'attente entre 2 cycles en traitement Batch

Notes

FICHIER_JDE | 21 60 Nom du fichier de transfert
FICHIER_ERREUR | 21 60 Nom du fichier des erreurs
FICHIER_TRACE | 21 60 Nom du fichier trace
FICHIER_LOCK_JDE | 21 60 Nom du fichier lock posé par JDE
FICHIER_LOCK_VS | 21 60 Nom du fichier lock posé par VoluPack
FICHIER_ARRET | 21 60 Nom du fichier arrêt créé lors de la demande d'arrêt (option Oar)
FICHIER_LOCK | 21 60 Nom du fichier lock qui permet l'unicité du lancement du programme
SUP_REQ_GROUPAGE | 21 60 Supplément de requête sur la table groupage_bl. Exemple : and gb_adl = "001"
LARGEUR_CAMION | 21 60 Largeur du camion en millimètres
SUP_REQ_STK0_PAL | Complément de sélection pour la recherche des palettes réellement produites Exemple : and s0_typ = "FR" and s0_es = "E"

Paramètres nécessaires

TRS A1[8,10] | Correspondance JDE
RG1 A1[14,19] | Tiers livré
RG1 A1[20,22] | Code adresse secondaire du tiers livré
RG1 A2[1,12] | Lieu prélèvement JDE
SIT A1[46,50] | Code société JDE
TLI A1[1,3] | Correspondance JDE (code tournée)
#CF LOG A1[11,13] | Type de note des notes comportant l'ancien numéro de chargement


Préparation de commande par code à barres

Préparation de commande par code à barres prep_cde_cab

Valeurs numériques

1 | Numéro de compteur des bons de livraison
2 | Numéro de compteur des bons de préparation

Options triées

O22

CAB transformateur sur 22 caractères

Obd

Les bons de livraison sont générés en définitif

Oc2

Conserve l'emplacement d'origine de la palette de picking lors de l'entrée sur le lieu intermédiaire. (champ s0_rgt2)

La même option existe dans la saisie des BL.

Ocf

Création d'une ligne de groupage par flashage de la palette à expédier

Odc

La date des mouvements de stock est égale à la date du chargement.

Autrement dit, l'heure de faction du chargement est prise en compte (voir note HEURE_DEBUT_FACTION)

Odl

La date des mouvements de stocks est égale à la date du bon de livraison.

Autrement dit, l'heure de faction de livraison est prise en compte (voir note HEURE_DEBUT_FACTION)

Ofp

Pas d'édition de la fiche palette (camion) - Voir TSC EFP

Oft

Suppression de la demande de confirmation du transfert ou de la livraison et forçage du transfert des FBI. Le lieu intermédiaire des FBI est obligatoire.

Ogd

Mise à jour de l'état d'affrètement en définitif (gb_etat_affret = 6) même si toutes les lignes de groupage ne sont pas expédiées.

Par défaut, seules les lignes de groupage dont le BL est édité en définitif sont flaguées en définitif (gb_etat_affret = 6)

Ogy

Numérotation annuelle des bons de préparation

Ol0

Génération des BL avec des lignes de livraison à 0 pour les lignes de groupage non préparées

Omt

On alimente un fichier trace avec les principales informations effectuées

On3

Mise à jour du lieu de rangement de niveau 3 avec la quantité de la palette

Par défaut, pas de mise à jour du lieu de rangement de niveau 3 avec la quantité de la palette

Ony

Compteur bon de livraison annuel

Ops

Le code préparateur est mis dans le champ b1_sitp de l'entête du bon de livraison

Ors

Les réaffectations de stock au solde/désolde des lignes de commandes sont autorisées (surplus - excédents)

Voir les notes

REAFFECT_ETAT

REAFFECT_VEN_NVE

REAFFECT_NVE_VEN

_SQL_REAFFECT_VEN

_SQL_REAFFECT_NVE

Os2

Scénario onduleur

La palette d'expédition correspond à un camion

Dans le scénario par défaut, la palette d'expédition correspond à une palette

Os3

Activation du scénario 3 pour saisir une nouvelle ligne de groupage sur la base du scénario onduleur

Osl

Solde manuel des lignes de commande, de séquence et de cadencement du bon de préparation en fin définitive du bon de préparation

Osr

Pas de mise à jour du stock résultant

Ote

Paramètres communs pour la gestion par codes à barres

Valeur alpha 2

Caractères 1 à n

Nom du fichier trace

Valeur alpha 3

Caractères 1 à 3

Type de mouvement de stock de sortie normale de palette de picking

Caractères 4 à 6

Type de mouvement de stock d'entrée normale de palette d'expédition

Caractères 7 à 9

Lieu de rangement 1 d'expédition

Caractères 10 à 15

Lieu de rangement 2 d'expédition

Caractères 16 à 21

Lieu de rangement 3 d'expédition

Caractère 22

Mode de calcul de la quantité à préparer

1 La quantité à préparer est la quantité de la palette de picking

2 La quantité à préparer est la quantité restant à préparer si celle-ci est inférieure à la quantité de la palette de picking.

La quantité à préparer est la quantité de la palette de picking si celle-ci est inférieure ou égale à la quantité restant à préparer

Caractères 23 à 25

Type d'action à mener après la saisie de la ligne de préparation

FPP Fin provisoire de palette

FDP Fin définitive de palette (valeur par défaut)

999 pour ajouter une ligne de groupage non prévue

Ce paramétrage n'est pas utilisé en scénarios 2 et 3.

Caractères 26 à 28

Lieu intermédiaire 1 pour gestion palette complète et type action FPP

Caractères 29 à 34

Lieu intermédiaire 2 pour gestion palette complète et type action FPP

Caractères 35 à 40

Lieu intermédiaire 3 pour gestion palette complète et type action FPP

Caractères 41 à 43

Type de mouvement en entrée de stock pour gestion palette complète et type action FPP

Caractères 44 à 46

Type de mouvement en sortie de stock pour gestion palette complète et type action FPP

Caractère 47

Mode de contrôle du lot de la commande

N Pas de contrôle même si le lot de la commande est différent du lot du picking (par défaut)

W Message d'avertissement si le lot de la commande est différent du lot du picking

C Demande de confirmation si le lot de la commande est différent du lot du picking

B Blocage si le lot de la commande est différent du lot du picking

Caractère 48

Mode de contrôle de la quantité livrée totale de la ligne de commande

N Pas de contrôle même si la quantité livrée totale de la ligne de commande est supérieure à la quantité livrée maxi autorisée (par défaut)

W Message d'avertissement si la quantité livrée totale de la ligne de commande est supérieure à la quantité livrée maxi autorisée

C Demande de confirmation si la quantité livrée totale de la ligne de commande est supérieure à la quantité livrée maxi autorisée

B Blocage si la quantité livrée totale de la ligne de commande est supérieure à la quantité livrée maxi autorisée

Caractères 49 à 51

Code TSC du mode de contrôle de la quantité par palette

Le contrôle porte sur la zone ic_char3_1.

Par défaut, les caractères 49 à 51 sont à blanc.

Le mode de contrôle de la quantité par palette peut être dans un TSC rattaché :

- soit à la ligne de commande

- soit à la commande

- soit à l'article de la ligne de commande

- soit au client de la commande

Le contrôle porte sur la zone ic_char3_1

Mode de contrôle de la quantité par palette

N Pas de contrôle même si la quantité par palette est différente de la quantité du picking

W Message d'avertissement si la quantité par palette est différente de la quantité du picking

C Demande de confirmation si la quantité par palette est différente de la quantité du picking

B Blocage si la quantité par palette est différente de la quantité du picking

Caractère 52

Mode de contrôle du nombre de palettes du bon de préparation

N Pas de contrôle même si le nombre de palettes du bon de préparation est différent du nombre de palettes prévues (par défaut)

W Message d'avertissement si le nombre de palettes du bon de préparation est différent du nombre de palettes prévues

C Demande de confirmation si le nombre de palettes du bon de préparation est différent du nombre de palettes prévues

B Blocage si le nombre de palettes du bon de préparation est différent du nombre de palettes prévues

Caractère 53

Visa du cariste en validation définitive de l'affrètement

N Pas de visa du cariste (Valeur par défaut)

1 Visa du cariste avec O par défaut

2 Visa du cariste avec N par défaut

Voir aussi les notes Ln_MES_VISA_CARISTE et le TSC VCA

Caractère 54

Mode de contrôle du lot chargé si commande asynchrone

N Pas de contrôle même si le lot chargé n'est pas le plus ancien

W Message d'avertissement si le lot chargé n'est pas le plus ancien

C Demande de confirmation si le lot chargé n'est pas le plus ancien

B Blocage si le lot chargé n'est pas le plus ancien

Caractère 55

Saisie des expéditions CAB Avec terminal embarqué

Que doit-on afficher dans la recherche du lot le plus ancien ?

1 le lot

2 la FBI

Caractère 56

Saisie des expéditions CAB Avec terminal embarqué

Autorisation de création d'une nouvelle ligne de groupage

N Pas d'autorisation

O Autorisation avec confirmation

Caractère 57

Contrôle du nombre de palettes chargées et prévues par lot uniquement avec terminal embarqué

N Pas de contrôle (par défaut)

W Warning

C Avec Confirmation

B Bloquant

Avec les choix B et C , la localisation du stock est lancée sur le 1er lot du tableau.

Caractère 58

Contrôle s'il reste du stock sur les lots synchrones chargés par le cariste avec terminal embarqué.

N Pas de contrôle (par défaut)

W Warning

C Avec Confirmation

B Bloquant

Un tableau affiche par lot le nombre de palettes et la quantité par palette restant en stock.

Caractère 59

Ajout d'une ligne de groupage

Contrôle du solde de la commande (entête, ligne, séquence, linge de cadencement de livraison)

N Pas de contrôle

W Contrôle non bloquant

C Demande de confirmation

B Contrôle Bloquant (valeur par défaut)

NB : Cette action est utilisée dans la saisie en Terminal Piéton et Embarqué

Valeur alpha 4

Caractères 1 à 3 | Type de mouvement de stock de sortie normale de réintégration d'une palette d'expédition Facultatif - Le type de mouvement de stock doit être une sortie normale. EX : SPE
Caractères 4 à 6 | Type de mouvement de stock d'entrée normale de réintégration d'une palette de picking Obligatoire si type de mouvement de stock de sortie normale de réintégration d'une palette d'expédition renseigné. Le type de mouvement de stock doit être une entrée normale EX : EPP
Caractères 7 à 9 | Lieu de rangement 1 de réintégration d'une palette de picking Obligatoire si type de mouvement de stock de sortie normale de réintégration d'une palette d'expédition renseigné. EX : LUM
Caractères 10 à 15 | Lieu de rangement 2 de réintégration d'une palette de picking Facultatif - L'emplacement (Lieux de rangement 1 et 2) doit exister dans la table lieu_rgt_e. EX : VEN001

Notes triées

GB_TRANS_DEFAUT

Code transporteur par défaut utilisé pour la création d'un groupage

Il est prioritaire sur celui saisi sur la commande.

GB_TYPE_VEH_DEFAUT

21,23 Code paramètre du type de véhicule (paramètre TVE). Facultatif

Ce paramétrage ne sera utilisé que si aucun type de véhicule n'est renseigné sur le groupage initial

HEURE_DEBUT_FACTION

Prise en compte de l'heure de faction pour la date du BL et la date de chargement

Voir les options Odc et Odl.

21,25 Heure de début de faction de livraison (ex : 06.00)

26,30 Heure de début de faction de chargement (ex : 06.00)

_IMAGE_LG_EN_CO

21,60 Nom de l'image du flag de la ligne de groupage en cours

Par défaut : fleche_verte

L1_MES_VISA_CARISTE

21,59 1ère ligne du message du visa du cariste

Voir le TSC VCA et A3[53]

Si la dimension de l'écran du terminal est de 8 lignes sur 20 colonnes, la ligne du message ne doit pas dépasser 19 caractères.

Si la dimension de l'écran du terminal est de 16 lignes sur 40 colonnes, la ligne du message ne doit pas dépasser 39 caractères.

L2_MES_VISA_CARISTE

21,59 2ème ligne du message du visa du cariste

Voir le TSC VCA et A3[53]

Si la dimension de l'écran du terminal est de 8 lignes sur 20 colonnes, la ligne du message ne doit pas dépasser 19 caractères.

Si la dimension de l'écran du terminal est de 16 lignes sur 40 colonnes, la ligne du message ne doit pas dépasser 39 caractères.

L3_MES_VISA_CARISTE

21,59 3ème ligne du message du visa du cariste

Voir le TSC VCA et A3[53]

Si la dimension de l'écran du terminal est de 8 lignes sur 20 colonnes, la ligne du message ne doit pas dépasser 19 caractères.

Si la dimension de l'écran du terminal est de 16 lignes sur 40 colonnes, la ligne du message ne doit pas dépasser 39 caractères.

L4_MES_VISA_CARISTE

21,59 4ème ligne du message du visa du cariste

Voir le TSC VCA et A3[53]

Si la dimension de l'écran du terminal est de 8 lignes sur 20 colonnes, la ligne du message ne doit pas dépasser 19 caractères.

Si la dimension de l'écran du terminal est de 16 lignes sur 40 colonnes, la ligne du message ne doit pas dépasser 39 caractères.

L5_MES_VISA_CARISTE

21,57 5ème ligne du message du visa du cariste

Voir le TSC VCA et A3[53]

Si la dimension de l'écran du terminal est de 8 lignes sur 20 colonnes, la ligne du message ne doit pas dépasser 17 caractères.

Si la dimension de l'écran du terminal est de 16 lignes sur 40 colonnes, la ligne du message ne doit pas dépasser 37 caractères.

MAJ_FLAG_INFO_C

21,60 Paramétrage du TSC à mettre à jour

Transfert des expéditions - Envoi des informations sur les palettes expédiées

_PARAM_TRANSFERT_PAL

21,26 Type et code du paramètre de lancement pour le transfert d'emplacement d'une palette

Exemple : #FBTEH

Lors d'un non chargement d'une palette supplémentaire (la quantité expédiée est supérieure à la quantité prévue) , il est possible sur paramétrage et avec confirmation de la transférer directement dans un autre emplacement. ça fonctionne en Terminal Piéton et en Terminal Embarqué.

_PAR_LOCALISATION

21 à 26 Type et code du paramètre de lancement de la localisation

REAFFECT_ETAT

Code état des mouvements générés (N ou 2, N par défaut)

Voir option Ors

REAFFECT_NVE_VEN

Réaffectation de stock NVE > VEN

21,23 Type de mouvement de sortie au désolde

24,26 Type de mouvement d'entrée au désolde

27,29 Lieu de rangement 1 au désolde

30,35 Lieu de rangement 2 au désolde

Voir option Ors

REAFFECT_VEN_NVE

Réaffectation de stock NEN > NVE

21,23 Type de mouvement de sortie au solde

24,26 Type de mouvement d'entrée au solde

27,29 Lieu de rangement 1 au solde

30,35 Lieu de rangement 2 au solde

Voir option Ors

_SQL_QTE_CHARGE_LOT

21,60 Supplément de requête sur la table pal_expédition_3 pour la recherche de la quantité chargée du lot

NB : Index à créer sur la table pal_expédition_3 sur le champ numéro du lot (pe3_lot_pick, pe3_soc)

_SQL_REAFFECT_NVE

1,60 Complément de requête pour les excédents (surplus) à réaffecter2

Voir option Ors

_SQL_REAFFECT_VEN

1,60 Complément de requête pour les excédents (surplus) à réaffecter

Voir option Ors

RUN_EDIT_BL

21 à 26 Type et code du paramètre de lancement de l'édition des BL

_STYLE_CAB

Paramètres communs pour la gestion par codes à barres

_SUP_REQ_CONT_INFO

21,60 Supplément de requête sur la table des conteneurs informations (conteneur_info)

Utilisé pour la recherche du lot le plus ancien

_SUP_REQ_CONT_PROD

21,60 Supplément de requête sur la table des conteneurs produits (conteneur_produit)

Utilisé pour la recherche du lot le plus ancien

SUP_REQ_GROUPAGE_BL

21 à 60 Supplément de requête sur la table des bons de préparation (Table groupage_bl)

Obligatoire

Exemple : and gb_no_groupage[3] = "1"

_TYPE_NOTE_LIVRAISON

Type de note

Ces notes servent à la recherche des notes de livraison sur le client.

TYPE_PAL_COMPLETE

21,35 Type de palette. Doit exister dans la fiche article.

VALIDE_ETAT_PAL_EXP

21 Autorisation pour les palettes sans état (O/N)

22 Autorisation pour les palettes d'état 1 (VEN) (O/N)

23 Autorisation pour les palettes d'état 2 (NVE) (O/N)

24 Autorisation pour les palettes d'état 3 (ARE) (O/N)

25 Autorisation pour les palettes d'état 4 (ADE) (O/N)

Paramètres associés

#CF BLV | Notes commençant par MVT_TYPE_LIV_
#CF ATL A3[33] | Utilisation des préfixes pour l'état des palettes
so_options[35] | Gestion de la consignation, de la mise à disposition, de la sous-traitance et de la cession à filiale


Saisie des bons de livraison

F13 et calcul du risque

La logique du F13 est de suspendre provisoirement la facturation d'un BL mais en aucun cas de décréter que c'est un "cadeau client".

A ce titre, un BL suspendu par F13 ne décrémente effectivement pas le risque client.

Rappel : si la commande n'est pas soldée, le risque est globalement égal à la valeur commandée - la valeur facturée.

Si la commande est soldée, le risque est la valeur livrée non facturée.

Donc, les BL provisoirement déclarés non facturables sortent du risque lorsque la commande est soldée, ce qui semble logique.

b1_datl

b1_date_chargem

b1_ref

b1_adrf

b1_devise

b1_sitp

b1_tport

b1_pht

b1_tvap

b1_trsp

b1_no_groupage

b1_transitaire

b1_ordre_chargt)

b1_adrf Adresse de facturation

b1_adrl Adresse de livraison

b1_cembal Coût emballage

b1_col Nombre de colis

b1_com Commentaires

b1_date_chargem Date de chargement

b1_datl Date de livraison

b1_devise Code devise

b1_embal Emballage

b1_heure_depart Heure départ

b1_lieu_rgt1 Lieu de rangement

b1_montant Montant

b1_no_groupage No groupage

b1_ordre_chargt Ordre de chargement

b1_pht Port HT

b1_poids Poids

b1_poids_brut_tr Poids brut transporté

b1_ref Référence du BL

b1_sitp Site de production

b1_tadr Type d'adresse

b1_tport Type de port

b1_trans Transporteur

b1_transitaire Transitaire

b1_trsp Type de transport

b1_tvae Code TVA emballage

b1_tvap Code TVA Port

b1_type_vehicule Type de véhicule

b1_vehicule Véhicule

Si la prise en compte de la phase de mitraillage sur le lieu intermédiaire est activée (RG1 A2[23]=O), la quantité des mouvements de stock dentrée sur ce lieu intermédiaire est multipliée par le nombre de poses du produit livré (zone ic_num1 du TSC KC du produit livré).

Saisie des bons de livraison blv

Valeurs numériques 1 & 2 - Options - Valeur alpha 2 - Valeur alpha 3 - Valeur alpha 4

Notes du paramètre de lancement - Détail du colisage - Détail emballage - Paramètres associés

Suivi des palettes consignées - Gestion des retours de produit

Suivi des stocks des produits finis en transit des bons de livraison et de transfert

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 à 10 : N° de BL

Exemple : -N[b2_blv]

-n

-nES

-nLS

-nAE

-nAL

Appel depuis la gestion des expéditions des affrètements

Caractères 03 à 04 : Type du traitement

ES Accès à l'écran de l'entête d'un BL seulement

LS Accès à l'écran des lignes d'un BL seulement

AE Annulation d'un BL en automatique

AL Annulation d'une ligne d'un BL en automatique

Caractères 05 à 12 : Numéro du BL Il ne doit pas être annulé.

Caractères 13 à 13 : - (Moins) Uniquement si le type du traitement est AL.

Caractères 14 à 16 : Ligne du BL Uniquement si le type du traitement est AL Elle ne doit pas être annulée.

Exemples

Accès à l'écran de l'entête du BL 030800001 : -nES030800001

Accès à l'écran des lignes du BL 030800001 : -nLS030800001

Annulation du BL 030800001 : -nAE030800001

Annulation de la ligne 2 du BL 030800001 : -nAL030800001-2

-nCBl

Création d'un BL depuis une liste de lignes de commandes

Petit n, grand C, grand B, petit l (l comme ligne)

Syntaxe :

-nCBlxxxxxxxx-xxx

Exemples

-nCBl12070001-001,12070002-002,12070010-001

-nCBl12070012-001/10 (avec le numéro de séquence), 12070013-001

Exemple de paramétrage

Dans la visu des commandes clients (v_cdem)

_CSEL

LCT_MULTI_CONFIG #RPBLV

Dans le #RP BLV, avec la touche Ctrl K (voir #RP)

LCT_MULTI_TITRE_01 Création de BL

LCT_MULTI_IMAGE_01 g_table

LCT_MULTI_PARAM_01 ACT010[lc_num|-|lc_lig]

LCT_MULTI_COMPL_01 010

Dans le paramètre KSC 010

CREER_BL #SABLV

Voir les notes CODE_TRANSP_DEFAUT et NUM_GROUPAGE_DEFAUT.

Voir les notes LCT_MULTI_PARAM_ avec l'action ACT010 et LCT_MULTI_REACT_ pour le déclenchement de cette action depuis la visu de commande.

Voir la note CREER_BL dans le paramètre de type KSC.

-nCBc

Création d'un BL depuis canal_comm

Petit n, grand C, grand B, petit c (c comme canal_comm)

(Code du paramètre de lancement du module originaire de l'action ctrl+k).

Syntaxe :

-nCBcxxx

Exemple

-nCBcSCH

-nNC

Appel depuis la visu des commandes (voir l'option Oli dans v_cdem)

Syntaxe :

-nNCCOMMANDE-LIG/SEQ/CAD:PID-SIT

où

-nNC Mot clé

COMMANDE Numéro de commande (8 caractères)

LIG Ligne de commande (3 caractères)

SEQ Séquence de la ligne de commande (3 caractères) - Si non utilisé, mettre 000

CAD Ligne de cadencement de livraison de la ligne de commande ou de la séquence de la ligne de commande (3 caractères - Format &&&) - Si non utilisé, mettre 000

PID Clé de la table sce0 du critère sur les dépôts (10 caractères) - Si non utilisé, mettre xxxxxxxxxx

SIT Code site sur 3 caractères (ec_c1 par exemple)

Valeurs numériques

1 | Numéro du compteur utilisé pour la numérotation des BL. Par défaut, le numéro du compteur est à nul.
2 | Pourcentage de tolérance entre la quantité livrée et la quantité commandée. Fonctionne avec l'option -Olc

Options triées

Oa1

Les codes adresses de livraison et de facturation à blanc ne sont pas pris en compte lors de la génération des bons de livraison

Oab

Adresse de facturation à blanc au lieu de l'adresse de facturation du client

Oac

On ne considère pas les colis comme un sous-ensemble d'une palette, on cumule donc palettes + colis sur la ligne de BL.

Oad

Autorisation de modifier la date de chargement en saisie du picking

Les options Odp et-Odc doivent être activées.

Oaf

Activation de la touche de bascule de la ligne de BL à l'état non facturable ou facturable sur un BL définitif (F13)

La ligne du bon de livraison peut être basculée par la touche F13 :

- à l'état non facturable si celle-ci est facturable

- à l'état facturable si celle-ci a été basculée à l'état non facturable au préalable

La bascule est possible si le bon de livraison est édité en définitif et non facturé totalement ou partiellement.

Voir aussi facn option Obf

Cliquez ici pour afficher / masquer des précisions sur l'état non facturable.

Oal

Désactive le contrôle de la validité de l'adresse de facturation saisie sur l'entête du BL si l'adresse de facturation est laissée à blanc et si so_options[37] positionne la recherche de l'adresse de facturation sur la ligne de commande.

Oam

Gestion des articles appairés montés - Voir aussi l'option Osn.

a) Fonctionne obligatoirement avec l'option Osa (gestion des appairages)

b) Si l'option Osa n'a pas été mise :

On livre toujours le produit fini pour les articles non appairés (mp_param[22] = N)

Les articles appairés montés ou non montés ne sont pas autorisés (mp_param[22] = M ou O)

c) Si l'option Osa a été mise et l'option Oam n'a pas été mise :

On livre toujours le semi-fini pour les articles appairés montés ou non montés (mp_param[22] = M ou O)

Les articles non appairés ne sont pas autorisés (mp_param[22] = N)

d) Si les options Osa et Oam ont été mises :

On livre le produit fini pour les articles appairés montés (mp_param[22] = M)

On livre le semi-fini pour les articles appairés non montés (mp_param[22] = O)

Les articles non appairés ne sont pas autorisés (mp_param[22] = N)

Oan

Autoriser la saisie d'une ligne de livraison même si l'accusé de réception n'est pas édité

Oap

Affiche le prix

Oas

En création d'adresse secondaire, par (F9), on met des blancs (par défaut on propose l'adresse principale du client.)

Oat

Alimentation automatique de l'adresse temporaire sur un magasin de sous-traitance

Dans le cas où le lieu de rangement est un magasin de sous-traitance, on crée automatiquement l'adresse temporaire du BL (touche F6) avec l'adresse définie sur le magasin.

Ob1

Saisie des bons de transfert. so_options[42] doit être = O.

incompatible avec les options Odp et Obh.

Attention : si vous activez cette option, vous ne pourrez pas utiliser la gestion des retours de produits.

Obc

Pas de contrôle de l'entête du BL avec l'entête de la commande si l'une des 2 zones n'est pas remplie

Obe

Saisie d'un numéro de groupage ou de bordereau d'expédition

Obf

Pas de contrôle entre l'entête du BL et l'entête de commande si l'un des codes adresse de facturation est à blanc

incompatible avec l'option Obc.

Obg

Interdit la saisie d'un BL sur une ligne de commande dont la quantité commandée est à zéro

Obh

Gestion des bons de livraison générés par codes à barres

so_options[40] doit être égal à O.

incompatible avec l'option -Odp (Détail palettes).

Les options suivantes sont obligatoires:

Osa (Saisie des appairages)

Odc (Génération des mouvements de stock avec la date de chargement)

Ogb (Gestion des groupages)

Omg (Mise à jour des groupages)

Mettre à jour le paramètre #CF BLV.

Obl

Pas de contrôle entre l'entête du BL et l'entête de commande si l'un des codes adresse de livraison est à blanc

incompatible avec l'option Obc.

Obm

Pas de contrôle entre l'entête du BL et l'entête de commande si l'un des codes de mode de transport est à blanc

incompatible avec l'option Obc.

Obp

Pas de contrôle entre l'entête du BL et l'entête de commande si l'un des codes de type de port est à blanc

incompatible avec l'option Obc.

Obt

Pas de contrôle entre l'entête du BL et l'entête de commande si l'un des codes transporteur est à blanc

incompatible avec l'option Obc.

Oc0 (zéro)

Les lignes créées sont avec b2_qteliv = 0, b2_qte = 0. A employer avec l'option Ocd.

Oc1

Désactivation de la mise à jour du nombre de colis de l'entête du BL avec le total des colis des lignes du BL lorsque l'option Oco (indispensable dans ce cas) est activée.

Oc2

Conserve l'emplacement d'origine de la palette de picking lors de l'entrée sur le lieu intermédiaire. (champ s0_rgt2)

La même option existe dans la préparation des commandes par codes barres.

Oc4

Contrôle la cohérence entre le lieu de rangement 1 de cde4 et celui de la ligne de picking

Oc9

Prise en compte des groupages sans commandes

Oca

Calcule le détail du colisage en ne calculant que le poids caisse (nb_caisse * poids)

Ocb

Contrôle de l'entête du BL avec l'entête de la commande avec ouverture d'une fenêtre impossible à contourner.

Occ

Contrôle si toutes les lignes des commandes figurent dans le BL

Ocd

Saisie du numéro d'une commande pour tout le BL et rappel de toutes les zones possibles

Création des lignes automatiques par F12 dans l'entête.

Option incompatible avec la gestion de la mise à disposition et consignation.

Oce

Cette option reprend l'option Ocd, mais sans créer les lignes. Elle complète uniquement l'entête de BL

Ocl

Accès aux bons de livraison en consultation uniquement

Ocm

Demande de confirmation de mise à jour du code devise du BL avec celui de la commande pour la 1ère ligne de livraison.

Oco

Cumule le poids et le nombre de colis des lignes de BL et écrase les valeurs saisies en entête

Ocp

Calcul du poids lors de la saisie du colisage (F7)

Ocr

Contrôle du stock physique avant la création d'une sortie réserve selon le paramétrage du TYC A1[12,14].

Dans le cas de l'option, même fonctionnement que pour une sortie normale.

Ocs

Possibilité d'exclure les commandes soldées lors des recherches

Oct

En annulation d'une ligne d'un BL, si le picking a généré des mouvements de transfert, ces derniers ne seront pas annulés.

Ocu

Edition des coordonnées de la société en entête

Ocv

Vérification de la date de livraison en fonction du calendrier rattaché au point de livraison

Si cette option est positionnée, on vérifie que la date de livraison est valide en allant vérifier le calendrier rattaché au lieu de livraison ou intermédiaire, le second étant prioritaire sur le premier.

Ocy

Les commandes sont en numérotation annuelle

Odb

Mise à jour automatique de la date des mouvements de stock prévisionnels si modification de la date de livraison ou de la date de chargement du BL

Option Odl ou Odc obligatoire.

Odc

La date de chargement saisie sur l'entête du BL est mise dans la date des mouvements de stock au lieu de la date de création du BL.

A l'activation du paramètre, la date de chargement devient obligatoire. Elle n'est pas modifiable si l'option Odp ou Obh est activée.

L'option Oad permet de lever cette interdiction (Option Odp uniquement).

La date de chargement peut être également contrôlée en création par rapport à une date de fin de période (voir option Ofp).

Odl

La date de livraison saisie sur l'entête du BL est mise dans la date des mouvements de stock au lieu de la date de création du BL.

Odp

F7 détail palettes (picking). Remplace le F7 détail colisage et le F7 détail emballage.

Voir la note commençant par CR, les notes commençant par EMPL_ et la note USING_NFBI_PICKLOT.

Ods

Demande à l'utilisateur s'il désire solder la ligne de commande courante

Oea

Enchaînement automatique entête - lignes

Oeb

On envoie le numéro du dernier BL au programme d'édition

Oec

Mise à jour du lieu de rangement dans les mouvements de stock

Incompatible avec les options Omc, Osa, Oof

Oee

Enchaînement des éditions (permettre l'édition définitive après l'édition provisoire)

Oef

Si le lieu intermédiaire est renseigné sur l'entête de BL, l'envoi du fax/mail ne se fait pas.

Oem

Saisie des emballages valorisés. Avec cette option, le poids, sur la ligne de BL, n'est pas initialisé avec : quantité livrée * poids de la ligne de commande

Of1

Interdiction de livrer la première ligne d'une FB1

Ofa

Ouverture automatique de la fenêtre du picking si la quantité livrée est à zéro

De plus, le nombre de colis ou de palettes de la ligne du BL est alimenté par le nombre de palettes du picking à la validation de celui-ci.

Ofb

Dans la fenêtre de saisie du détail du colisage, la première zone libellé est automatiquement remplie avec le numéro de FBI associée, et la quantité déjà fabriquée sur cette FBI. Exemple FBI 97026001-1 : 10000 Fab

Ofc

Contrôle de l'entête du BL avec l'entête de la commande avec ouverture d'une fenêtre pour demander une confirmation s'il existe des différences. Les zones contrôlées sont :

Adresse de livraison

Adresse de facturation

Type de port

Mode de transport

Code transporteur

A utiliser de préférence avec Obc.

Sans ce paramètre, le message apparaît simplement en bas de l'écran.

Combiné avec Ocb, ce contrôle devient bloquant.

Ofo

Forçage du conditionnement à la palette même si les produits sont gérés en vrac

Ofp

TOP fin de période.

Oft

Envoi du Fax-Email sur le correspondant du transporteur de l'entête du BL

Oga

Ouverture automatique d'une sélection de groupage est autorisée (dépend de l'option Omg)

Ogb

La gestion par groupage est possible (exemple SYLOGI).

Active les 4 tests définis en A3[12 à 15]

Ogd

Gestion des dépôts - GENERO uniquement

Ogi

Lorsqu'un BL est rattaché à un numéro de groupage présent dans la table groupage_bl, il est interdit de le créer, le modifier ou l'annuler dans la saisie des BL.

Cette option permet d'éviter la mise à jour d'un BL qui a été créé par le module de gestion des expéditions des affrètements

Ohq

Homogénéisation des quantités livrées

Cette option met à jour toutes les lignes de BL à partir de la deuxième ligne, les quantités livrées et facturées des lignes de BL dont la commande et la quantité commandée est identique à la première ligne de BL. Cette mise à jour se fait lorsque la saisie de la première ligne est complète.

Oia

Pas de mise à jour du champ lc_transfert_trans : flag de transfert des commandes dans SYLOGI et JDE

Oic

Initialisation des données suivantes en saisie du détail colisage, avec la valeur 1

Nombre de palettes

Nombre de colis par palettes

Nombre d'exemplaires par colis

Oid

Initialise la date de livraison du BL généré avec le délai demandé de la première ligne de commande livrée (uniquement en génération)

Lors de la saisie simplifiée des commandes, il est possible de saisir le délai demandé par le client.

Quel que soit le délai saisi, si le BL est généré automatiquement à la suite de la commande, la date de livraison du BL est obligatoirement la date du jour de saisie.

Cette option permet que la date de livraison du BL soit le délai demandé par le client (on prend celui de la première ligne de commande livrée).

Oif

Interdiction de saisir la quantité à facturer

Positionne cette quantité égale à la quantité à commander lors de la première livraison

Positionne cette quantité égale à zéro lors des livraisons suivantes

Est utilisé lors d'une facturation forfaitaire

Oih

Interdit la saisie dans la zone heure de départ de l'en-tête du BL

Oil

Initialisation de la ligne de BL générée à partir du numéro de commande de l'entête du BL

(poids et ligne soldée)

Oip

Interdiction du picking sur le même magasin que le lieu intermédiaire du BL

Voir aussi les notes _SUP_REQ_INTERD_PICK.

Ola

Ouverture en fin de saisie de ligne des livraisons déjà effectuées sur les composants de l'ensemble appairé

Olb

Initialisation de l'adresse de livraison à blanc si saisie du numéro de commande dans l'entête du BL

Permet la récupération de l'adresse de la ligne si option Ome.

Olc

On ouvre une fenêtre de confirmation si la quantité livrée est supérieure à la quantité commandée

Ne fonctionne pas si la quantité facturée est différente de la quantité livrée !

Fonctionne avec la valeur numérique 2.

Old

Lien avec les entités du devis pour le calcul du poids lors ce que l'on est dans le F7 colisage (utilisation de la surface et du grammage dans fle_imp)

Olf

Mise à jour de la quantité livrée facturable de la ligne de commande dans le F13 de la saisie des lignes de BL

Option Oaf obligatoire.

Explication :

La touche F13 permet de basculer une ligne de BL à l'état non facturable ou facturable sur un BL définitif.

Si cette option n'est pas activée, seule la quantité à facturer de la ligne de commande sera mise à jour dans le F13 de la saisie des lignes de BL.

Si cette option est activée, la quantité à facturer et la quantité livrée facturable de la ligne de commande seront mises à jour dans le F13 de la saisie des lignes de BL.

Olm

Type de numéro d'OF

Olp

On limite le picking à la seule commande

Ols

Les lignes de commande ne sont jamais soldées en automatique, l'utilisateur doit intervenir manuellement en saisissant O dans la zone solde.

Voir aussi QAL A1[9]

Olv

Autorise le lieu intermédiaire à vide si le client n'est pas facturable.

Cette option permet de saisir un BL sur un client non facturable (cl_param[13]) sans être obligé de saisir un lieu intermédiaire.

Cette option n'est valide que si on gère les magasins de mise à disposition et de mise en consignation (so_options[35]).

Pourquoi cette option ?

En fait, puisque le client est non facturable, lorsque l'on a mis en place la mise en consignation, on a considéré qu'il fallait que le BL soit lui-même non facturable, donc on a rendu le lieu intermédiaire obligatoire.

Cette zone n'est en aucun cas obligatoire pour le bon fonctionnement du système, c'était juste pour des notions conceptuelles.

Oma

Ouverture automatique de la fenêtre de saisie de la quantité facturée

Omc

Si mouvement de réserve généré sur la ligne de commande, mise à jour de cette réserve si SN à la saisie du BL.

Incompatible avec l'option Oec

Omd

Interdit de saisir des lignes ayant des lieux de destockage différents

Ome

Les zones suivantes, de l'entête du BL, sont initialisées avec les informations de la commande saisie sur la première ligne du BL et non avec celles du client

Adresse livraison

Adresse facturation

Type de port

Mode de transport

Code transporteur

L'adresse de livraison vient de la ligne de commande (et non de l'entête de commande) si so_options[19] = O.

Omf

Modification de la quantité facturée dans l'écran des appairages à l'aide de la touche F9 (fonctionne uniquement avec l'option Osa).

Omg

En modification de l'entête de BL, on met à jour le groupage si on gère le groupage_bl (option Ogb)

Omi

Modification de la ligne du BL interdite (ligne alimentée par la fenêtre colisage)

Oml

Possibilité de saisir des mètres linéaires dans la fenêtre de colisage

Omm

Mise à jour du magasin du mouvement de livraison prévisionnel

Omp

Dans la fenêtre de picking, la saisie de la mise sur palette se fait au F10 de validation de la fenêtre de picking et non plus après chaque ligne de picking avec une quantité.

La touche F7 pour saisir la mise sur palette n'est plus autorisée.

Omr

Suppression de la fenêtre de confirmation de modification du lieu intermédiaire

Omt

Annulation des mouvements de transfert du picking si la quantité saisie du picking est inférieure à la quantité initiale du picking

Cette option est nécessaire pour A4[9].

Onc

Affichage automatique des notes saisies sur le couple client / adresse entre l'écran d'entête et l'écran des lignes (en mode consultation). Le type de notes affichées est obligatoirement paramétré en A2[43,45].

Onf

Solder les lignes non facturables

Ono

Saisie d'un BL sur la ligne de commande et non sur la ligne de nomenclature pour les commandes avec des articles appairés.

Cette option est annulée par l'option Osa (appairages).

Onr

Pas de réaffectation de lot

Cette option est nécessaire au fonctionnement de l'option Oop dans l'édition des BL

Ony

Numérotation annuelle des BL

Oof

Saisie par numéro d'OF - incompatible avec l'option Oec

Oot

Mise à jour du magasin de départ de l'ordre de transport avec le lieu de destination du BL dans le cas d'un bon de transfert et si le lieu de destination du BL est différent du lieu de destination de la ligne de commande ou de la séquence de la ligne de commande livrée

Les bons de transfert sont des BL des types suivants : (b2_type_livraison)

8 Transfert sous-traitant

10 Retour sous-traitant

14 Entrée sous-traitant

Le lieu de destination du BL correspond au champ b1_lieu_rgt1 de la table blv1.

Le lieu de destination de la ligne de commande ou de la séquence de la ligne de commande livrée correspond au champ lc_lieu_rgt1 de la table cde2.

La logistique doit être activée (#CF LOG A1[1] = O).

Op1

Poids du colisage arrondi au plus proche avec 1 décimale

Op2

Prise en compte du poids des palettes dans le calcul du poids transporté - GENERO uniquement

Voir notes POIDS_UNI_PAL_DEFAUT et _SUP_REQ_PAL

Op3

Bon de livraison en mode papeterie

Opa

Au retour de la saisie du détail du colisage, la zone Col/Pal sur la ligne de BL est alimentée avec le nombre de palettes (et non pas avec le nombre de colis).

incompatible avec l'option Oac.

Opc

Pas de contrôle de l'entête du BL avec l'entête de la commande

Opd

Picking avec décimales

Ope

Picking sans contrôle sur le magasin de départ

Opi

Poids inutilisé (O/N, N par défaut)

Le poids calculé en saisie de BL depuis la quantité de la commande peut, dans certains cas, dépasser la capacité du champ (champ déclaré en decimal(10,2)).

Cette option permet de ne pas tenir compte du poids lors de la saisie d'un BL.

Deux possibilités lors du dépassement :

1) En fonctionnement normal, on retourne sur la zone quantité.

2) Avec cette option, on force le poids à zéro.

Opm

Modification du nombre de palettes de la ligne du bon de livraison malgré l'interdiction de modifier celle-ci (paramètre -Omi) (uniquement si le BL n'est pas édité en définitif.

Opn

Transformation des entrées prévisionnelles en entrées normales

Les entrées prévisionnelles sont générées à la saisie de la commande pour les articles non appairés ou appairés montés ou à l'édition de l'accusé de réception pour les articles appairés non montés.

La transformation est faite si le lieu intermédiaire de l'entête du bon de livraison est identique à celui de la revue de contrat.

Opo

Calcul du port en automatique d'après le poids total sur l'entête du BL à la validation des lignes.

Si POR alpha[1] = O et p2_code = b1_tport)

Si le code du transporteur n'est pas renseigné, la recherche de tarif propose le / les transporteur(s) potentiel(s) trouvé(s).

Si 1 seul trouvé on affecte automatiquement sinon on ouvre une fenêtre.

Complément de sélection de la recherche possible dans #CF BLV)

Opp

Active le mode picking palette dégradé (option Ogb obligatoire)

Ops

Picking Sécurisé

Le programme ne propose au picking que les stocks effectivement entrés à la date de livraison, en prenant en compte toutes les sorties saisies dans la base de données.

Opt

Poids unitaire net de l'article issu d'un TSC (CIC N54) de l'article au lieu de la zone mp_poids de l'article ou de la zone lc_poids de la ligne de commande

Opw

Supprime l'affichage des Warning de contrôle sur

quantité livrée différente de quantité commandée

quantité facturée différente de quantité livrée

nombre d'exemplaires différent de quantité livrée

Attention : cette option ne désactive pas l'option Olc

Opz

L'expédition des palettes incomplètes est autorisée

Sans cette option, lors de la modification des BL CAB , il est interdit d'expédier une palette incomplète.

Oq0

Interdit la saisie de la quantité livrée à la valeur zéro

Oqf

Quantité restant à livrer = quantité fabriquée - quantité livrée

Si quantité fabriquée = 0, quantité restant à livrer restant à livrer = quantité commandée - quantité livrée

Oql

Saisie de la quantité livrée

Oqt

Saisie du nombre de caisses total au lieu du nombre de caisses par palette

et du nombre d'exemplaires total au lieu du nombre d'exemplaires par caisse

dans la fenêtre du détail du colisage

Ora

Accès à la saisie du lieu intermédiaire de l'entête du BL

Lles gestions MAD, option société 35, et du bon de transfert, Ob1, ne doivent pas être actives.

Le type des lignes de livraison n'est pas impacté par cette option et reste en livraison client.

Or1

Si on n'a pas saisi de lieu intermédiaire sur la ligne de commande (Fenêtre revue de contrat), la livraison est considérée comme une vente normale afin de déclencher la mise à jour des sorties réserves.

Cette option est autorisée si so_options[35] = O.

Or2

La mise à jour des sorties réserves ne dépend pas du type de livraison, mais du fait que le lieu de la sortie réserve est identique au lieu de la sortie normale.

Cette option met également à jour le magasin de déstockage prévisionnel (stk0.s0_rgt1) lors de la saisie d'un bordereau de transfert de stock.

Cette option ne fonctionne que dans le cas où un lieu intermédiaire est indiqué sur l'entête du BL.

Cette option est autorisée si so_options[35] = O.

Incompatible avec option Or3

Or3

Si le picking effectué pour la livraison d'un magasin de consignation/dépôt vers le client final, porte sur la même magasin que celui prévu sur la ligne de commande au niveau de la livraison prévisionnelle, alors on mettra à jour la quantité de la livraison prévisionnelle.

Voir aussi QAL A2[32]

Incompatible avec option Or2

Org

En annulation de BL généré par code à barres, le groupage du BL peut être réactivé au lieu d'être annulé si tous les BL générés par ce groupage ont pu être annulés.

Orl

Ouverture automatique de la recherche sur les lignes de commandes après la saisie d'un numéro de commande

Uniquement sur la première ligne

Oro

Lors de la génération d'un bon de transfert, solde de son ordre de transport et régénération d'un ordre de transfert pour la livraison client.

Incompatible avec l'option Oot. La régénération dépend d'un paramétrage sur le lieu de transfert.

Ors

Réaffectation des excédents (surplus) de production. (Utilisé avec l'option -Odp)

Voir les notes REAFFECT_NVE_VEN et REAFFECT_VEN_NVE

ATTENTION : il est IMPERATIF de mettre un COMPLEMENT de SELECTION !

Voir les notes SQL_REAFFECT_NVE_VEN et SQL_REAFFECT_VEN_NVE

Attention, on ne gère pas les excédents sur les asynchrones chez les onduleurs.

Ort

Activation de la recopie des TSC saisis sur le bon de livraison par défaut (bl n°00000000)

Orv

Réactualisation du prix de revient de la ligne de commande en utilisant la moyenne des prix d'achat des lots utilisés pour livrer la ligne de commande client.

Option Odp obligatoire (picking).

La livraison ne doit pas faire référence à une ligne de nomenclature (cde4).

mp_param[5] doit être égal à A (produit acheté).

Os2

Scénario onduleur (Palette expédition = Camion)

Le nombre de palettes correspond au nombre de palettes de picking

Dans le scénario par défaut (Palette expédition = Palette), le nombre de palettes correspond au nombre de palettes d'expédition

Osa

Saisie des appairages - Incompatible avec l'option Oec

Annule l'option Ono, force alpha2[34] à N.

Obligatoire si so_options[33] = O

Indispensable pour permettre A4[8]

Osc

Autorise la saisie de la même commande (n° de commande – n° ligne de commande – n° de séquence) plusieurs fois dans le BL.

Par défaut, on ne peut pas saisir plusieurs fois la même commande.

Nous entendons par la même commande le triplet suivant : n° de commande – n° de ligne de commande et le n° de séquence.

Cette option permet de lever cette interdiction.

Osd

Désactive la limitation de la recherche des stocks à la date du jour, ou du BL, dans le picking des livraisons.

Cela permet de voir tous les stocks existants et ce quelque soit leur date.

Osf

Saisie de la quantité fabriquée associée à la ligne de commande et possibilité de solder la fabrication

L'ouverture de la fenêtre de saisie est automatique

Osg

Aide à la saisie globale du picking palette.

Active la pré-sélection automatique des palettes de picking.

Osl

Affichage stock lot et lot - lieu

Osn

SPECIFIQUE N Mise à jour stock.(Création d'un mouvement de stock sur le produit le plus haut de la nomenclature liée à la ligne de commande)

Remarques

a) Fonctionne aussi avec l'option Oam (gestion des articles appairés montés)

b) Si l'option Osa n'a pas été mise :

On livre toujours le produit fini pour les articles non appairés (mp_param[22] = N)

Les articles appairés montés ou non montés ne sont pas autorisés (mp_param[22] = M ou O)

c) Si l'option Osa a été mise et l'option Oam n'a pas été mise :

On livre toujours le semi-fini pour les articles appairés montés ou non (mp_param[22] = M ou O)

Les articles non appairés ne sont pas autorisés (mp_param[22] = N)

d) Si les options Osa et Oam ont été mises :

On livre le produit fini pour les articles appairés montés (mp_param[22] = M)

On livre le semi-fini pour les articles appairés non (mp_param[22] = O)

Les articles non appairés ne sont pas autorisés (mp_param[22] = N)

Osr

Pas de mise à jour du stock résultant lors de la mise à jour des stocks

Ost

Suivi des stocks des produits finis en transit

Les produits finis sont sortis du lieu de picking et entrés sur le lieu de transit à la validation du picking des bons de transfert et de livraison.

Ot2

Passage à 2 de la zone lc_transfert_trans de la ligne de commande lorsque la ligne de commande ou la ligne de séquence commande est seulement modifiée.

Passage à 3 de la zone lc_transfert_trans de la ligne de commande lorsque l'état solde / désolde de la ligne de commande ou de la ligne de séquence commande change même si elle est modifiée.

Option non paramétrée :

Passage à 3 de la zone lc_transfert_trans de la ligne de commande lorsque l'état solde / désolde de la ligne de commande ou de la ligne de séquence commande change.

Ote

Saisie simplifiée des livraisons de type TEXTILE

Otl

En création de ligne de livraison, dupliquer les TSC de la ligne par défaut

Ne fonctionne que si la note FALF20 à pour valeur O.

Otm

Saisie du type mouvement de stock

Otp

Dans la saisie du détail du picking palette, le tableau est trié de la manière suivante :

palettes sélectionnées

palette de prélèvement

dernière palette créée

autres palettes dans l'ordre de saisie (FIFO)

Otr

Passer directement de la zone lieu intermédiaire à la zone transporteur (pour faciliter la saisie de l'entête du BL)

Cette option évite à l'utilisateur de paramétrer les notes #CC pour les 13 champs présents entre ces deux zones.

En dehors de cette option, tout champ qui a la valeur I (interdiction) dans la note #CC est grisé, donc non saisissable.

Oul

Saisie uniquement de la quantité livrée

Ouv

Utilisation de l'unité de vente pour calculer le prix de vente issu du fichier mat/prod et le prix du mouvement de stock

Ova

Validation automatique des fax/emails à envoyer sans passer par la fenêtre de gestion des fax/emails

Ow0 (zéro)

Avertissement si quantité livrée à 0

Oxm

Ouverture automatique de l'écran de gestion de l'envoi des fax / mails à chaque création de bon de livraison (à la validation par la touche F10).

Valeur alpha 2

Caractères 1 à 5

Mot de passe annulation logique.

Caractère 6

Demande mot de passe annulation logique entête et ligne par F2

N (par défaut) Pas de demande du mot de passe sur F2.

Le mot de passe n'est valable que pour l'annulation massive accessible par le menu.

O Demande du mot de passe.

Caractères 7 à 8

Début de plage autorisée pour la date du BL (x jours en moins par rapport à la date du jour)

(Actif en création de BL uniquement)

A2[35] doit être = O et A2[36] doit être = F ou B

Caractères 9 à 10

Fin de plage autorisée pour la date du BL (x jours en plus par rapport à la date du jour)

(Actif en création de BL uniquement)

A2[35] doit être = O et A2[36] doit être = F ou B

Caractère 11

Ouverture automatique de la fenêtre colisage (O/N, N par défaut)

Caractère 12

Saisie obligatoire du nombre de palettes dans la fenêtre colisage (O/N, N par défaut)

O Lance l'outil de correction de stock

N En cas d'absence de stock, on autorise la saisie d'une quantité à zéro sur la ligne de BL

Caractère 13

Saisie obligatoire du nombre de caisses dans la fenêtre colisage (O/N, N par défaut)

Caractère 14

Saisie obligatoire du nombre d'exemplaires par caisse dans la fenêtre colisage (O/N, N par défaut)

Caractère 15

Saisie obligatoire du poids dans la fenêtre colisage (O/N, N par défaut)

Caractère 16

Calcul du poids en FIFO dans la fenêtre colisage (Spécifique R) (O/N, N par défaut)

Caractère 17

La quantité livrée est initialisée avec le nombre d'exemplaires du colisage (O/N, N par défaut)

Caractère 18

Ouverture automatique de la fenêtre de stockage (O/N, N par défaut)

Permet de saisir le lieu de départ du stock - Incompatible avec le picking (option Odp)

Caractères 19 à 24

Type et code du paramètre de lancement de l'édition des BL

Permet d'éditer le BL avec une demande ou pas de confirmation (A2[31]) après le F10 des lignes.

Caractères 25 à 30

Type et code du paramètre de lancement de la réédition de BL

Permet de rééditer le BL avec une demande ou pas de confirmation (A2[32]) après le F10 des lignes

Caractère 31

Demande de confirmation pour édition BL (O/N, O par défaut)

Caractère 32

Demande de confirmation pour réédition BL (O/N, O par défaut)

Caractère 33

Mode d'accès aux frais d'expédition

O Consultation uniquement

N Consultation et modification (par défaut)

Caractère 34

Définition de la forme de saisie des lignes de BL

O Saisie avec des décimales sur les quantités (par défaut)

N Saisie sans décimales sur les quantités (valeur forcée si option Osa)

Caractère 35

Contrôle de la date de livraison en création / modification du BL

O Contrôle activé

N Pas de contrôle (valeur par défaut)

Caractère 36

Type de contrôle de la date (alpha2[5])

F Simple avertissement avec fenêtre de confirmation (valeur par défaut)

B Contrôle bloquant

Caractères 37 à 39

Visualisation du calendrier client / adresse de livraison (F11)

Nombre de jours en moins pour la recherche du calendrier par rapport à la date du BL

Caractères 40 à 42

Visualisation du calendrier client / adresse de livraison (F11)

Nombre de jours en plus pour la recherche du calendrier par rapport à la date du BL

Caractères 43 à 45

Type des notes du couple client-adresse de livraison (option Onc)

Caractère 46

Contrôle des livraisons partielles. Lorsque le champ Livraison partielle de la fiche client est à N, il est possible d'interdire les bons de livraison partiels.

N Pas de contrôle (valeur par défaut)

W Message d'avertissement avec validation

C Fenêtre de confirmation

B Contrôle bloquant

Caractères 47 à 52

Type et code du paramètre de lancement pour l'édition du BL définitif

Caractères 53 à 58

Type et code du paramètre de lancement pour la réédition du BL définitif

Caractère 59

Interdire la saisie d'une ligne de BL en cas d'absence de stock (O/N, N par défaut)

Ne pas proposer la correction manuelle de stock

Caractère 60

Ouverture automatique de la fenêtre du détail du colisage après la saisie du détail du picking en création de ligne (N/O, N par défaut)

Activation de l'action Détail colisage picking (Touche F14) permettant de modifier le détail du colisage.

L'option Odp doit être activée.

Le nombre de colis/palettes affiché sur la ligne du bon de livraison est issu du détail du colisage.

Le nombre de palettes du détail du picking est stocké dans la 1ère ligne de note de type #np de la ligne du bon de livraison.

Valeur alpha 3

Caractères 1 à 5

Heure de début de faction. La date proposée par défaut correspond à la veille quand la saisie s'effectue entre minuit et cette heure de début. Format HH.MM

Caractères 6 à 11

Type et code du paramètre de lancement du module d'édition du groupage ou du bordereau d'expédition.

Caractère 12

Contrôle que le client de l'entête du BL correspond au client prévu sur l'affrètement (N/W/B)

Nécessite l'option Ogb

Caractère 13

Contrôle que la date du BL correspond à la date prévue de l'affrètement (N/W/B)

Nécessite l'option Ogb

Caractère 14

Contrôle que la ligne de commande saisie sur le BL est bien dans le groupage (N/W/B)

Nécessite l'option Ogb

Caractère 15

Contrôle que le nombre de palettes saisi sur l'écran du picking correspond au nombre de palettes prévues dans l'affrètement (O/N)

Nécessite l'option Ogb

Caractère 16

Type de recherche F7 commande (activé dans le module blv_psta uniquement)

1 Recherche de commandes avec retour du numéro de la commande avec saisie d'un critère de sélection. Valeur par défaut

2 Recherche de commandes avec retour du numéro de la commande, du numéro de la ligne de commande et du numéro de la séquence de la ligne de commande avec saisie d'un critère de sélection

3 Recherche de commandes avec retour du numéro de la commande, du numéro de la ligne de commande et du numéro de la séquence de la ligne de commande sans saisie d'un critère de sélection

Caractère 17

Type de chargement du nombre de palettes à charger de la fenêtre de picking en création de lignes

N Le nombre de palettes reste à 0

O Le nombre de palettes provient de SYLOGI. Valeur par défaut

Caractère 18

La touche F20 sur la ligne de BL permet de saisir

E des infos complémentaires sur l'entête de commande

L des infos complémentaires sur la ligne de commande

B des infos complémentaires sur la ligne de BL

(Nécessite les notes commençant par FAEF20 et FALF20).

Caractère 19

Code contrôle du lieu intermédiaire

Possibilité de vérifier, à partir de la deuxième ligne du BL, si le lieu intermédiaire de la commande correspond bien à celui de l'entête du BL. A noter que le contrôle du lieu sur la première ligne BL propose la modification du lieu intermédiaire sur l'entête du BL (ce contrôle n'a pas été modifié).

so_options[35] doit être à O.

N pas de contrôle (par défaut)

W warning

C Choix

B Bloquant

Caractère 20

Contrôle de la plage sur date de chargement (W/B/N, N par défaut)

Caractères 21, 22

Plage de date de chargement : début

Caractères 23, 24

Plage de date de chargement : fin

Caractères 25 à 27

Code du site par défaut. Le type de paramètre provient de #CF BLV alpha1[1].

Tableau de bord du multisite

Caractère 40

Paramétrage du contrôle de saisie du site de production (W/B/N, N par défaut)

Tableau de bord du multisite

Caractères 41 à 43

Lieu de rangement 1 des palettes d'expédition

Si non renseigné, alors on prend par défaut le lieu de stockage.

Caractères 44 à 49

Lieu de rangement 2 des palettes d'expédition

Si non renseigné, alors on prend par défaut le lieu de stockage.

Caractères 50 à 55

Lieu de rangement 3 des palettes d'expédition

Valeur alpha 4

Caractère 1

Contrôle de l'unicité de l'adresse de livraison (entête BL / commande)

N Pas de contrôle [Valeur par défaut]

C Demande de confirmation si adresse de livraison différente (valeur nulle incluse au test)

c Demande de confirmation si adresse de livraison différente (valeur nulle non significative)

W Affichage d'un message en bas de fenêtre si adresse de livraison différente (valeur nulle incluse au test)

w Affichage d'un message en bas de fenêtre si adresse de livraison différente (valeur nulle non significative)

B Message bloquant si adresse de livraison différente (valeur nulle incluse au test)

b Message bloquant si adresse de livraison différente (valeur nulle non significative)

Caractère 2

Contrôle de l'unicité de l'adresse de facturation (entête BL / commande)

N Pas de contrôle [Valeur par défaut]

C Demande de confirmation si adresse de facturation différente (valeur nulle incluse au test)

c Demande de confirmation si adresse de facturation différente (valeur nulle non significative)

W Affichage d'un message en bas de fenêtre si adresse de facturation différente (valeur nulle incluse au test)

w Affichage d'un message en bas de fenêtre si adresse de facturation différente (valeur nulle non significative)

B Message bloquant si adresse de facturation différente (valeur nulle incluse au test)

b Message bloquant si adresse de facturation différente (valeur nulle non significative)

Caractère 3

Contrôle de l'unicité du type de port (entête BL / commande)

N Pas de contrôle [Valeur par défaut]

C Demande de confirmation si mode de port différent (Valeur nulle incluse au test)

c Demande de confirmation si mode de port différent (Valeur nulle non significative)

W Message en bas de fenêtre si mode de port différent (Valeur nulle incluse au test)

w Message en bas de fenêtre si mode de port différent (Valeur nulle non significative)

B Message bloquant si mode de port différent (Valeur nulle incluse au test)

b Message bloquant si mode de port différent (Valeur nulle non significative)

Caractère 4

Contrôle de l'unicité du mode de transport (entête BL / commande)

N Pas de contrôle [Valeur par défaut]

C Demande de confirmation si mode de transport différent (Valeur nulle incluse au test)

c Demande de confirmation si mode de transport différent (Valeur nulle non significative)

W Message en bas de fenêtre si mode de transport différent (Valeur nulle incluse au test)

w Message en bas de fenêtre si mode de transport différent (Valeur nulle non significative)

B Message bloquant si mode de transport différent (Valeur nulle incluse au test)

b Message bloquant si mode de transport différent (Valeur nulle non significative)

Caractère 5

Contrôle de l'unicité du code transporteur (entête BL / commande)

N Pas de contrôle [Valeur par défaut]

C Demande de confirmation si code transporteur différent (Valeur nulle incluse au test)

c Demande de confirmation si code transporteur différent (Valeur nulle non significative)

W Message en bas de fenêtre si code transporteur différent (Valeur nulle incluse au test)

w Message en bas de fenêtre si code transporteur différent (Valeur nulle non significative)

B Message bloquant si code transporteur différent (Valeur nulle incluse au test)

b Message bloquant si code transporteur différent (Valeur nulle non significative)

Caractère 6

Exclusion de la première ligne du BL des 5 contrôles d'unicité ci-dessus

N Pas d'exclusion , la première ligne est testée (Valeur par défaut).

O Exclusion, la première ligne ne subit aucun des tests d'unicité.

Caractère 7

SUPPRIME

Caractère 8

Demande de confirmation si l'appairage du BL n'est pas équilibré

N Pas de contrôle (Valeur par défaut)

W Affichage d'un message d'avertissement sans demande de confirmation

C Affichage d'un message d'avertissement avec demande de confirmation

B Affichage d'un message d'anomalie bloquant

L'option Osa doit être activée.

En sortie de l'écran des lignes du BL (Touche DEL ou F10), le programme peut contrôler si l'appairage est équilibré.

Si le contrôle est activé et que l'appairage n'est pas équilibré, le programme affiche un message d'avertissement avec ou sans demande de confirmation ou un message d'anomalie bloquant.

Dans le cas de l'affichage du message d'anomalie bloquant, l'opérateur ne peut pas sortir de l'écran des lignes tant qu'il n'a pas équilibré l'appairage.

Le contrôle est fait même si l'opérateur veut sortir par la touche DEL.

Dans un premier temps, le programme vérifie que les quantités livrées respectent l'appairage.

La quantité livrée de la première ligne de BL de la ligne de commande sert de référence.

Dans un deuxième temps, le programme vérifie que tous les composants de l'ensemble sont livrés sur le BL.

Caractère 9

Message d'avertissement d'annulation des mouvements de transfert du picking si la quantité saisie du picking est inférieure à la quantité initiale du picking

N Message d'avertissement sans demande de confirmation

O Message d'avertissement avec demande de confirmation (Valeur par défaut)

L'option Omt doit être activée.

Caractère 10

Suivi des stocks des produits finis en transit des bons de transfert et/ou de livraison

1 Des bons de transfert (valeur par défaut)

2 Des bons de livraison

3 Des bons de transfert et de livraison

L'option Ost doit être activée.

Caractère 11

Contrôle si le stock final du lot est négatif lorsque celui-ci est diminué de la quantité du picking (N/W/C/B, N par défaut)

N Pas de contrôle

W Contrôle avec message d'avertissement

C Contrôle avec demande de confirmation

B Contrôle bloquant

L'option Odp doit être activée (F7 détail palettes ou picking).

Caractère 12

Modification du contrôle fait sur la comparaison entre le nombre de palettes à saisir et le nombre de palettes sélectionnées dans la saisie du détail du picking palette

4 possibilités :

B bloquant (par défaut)

C confirmation

W warning

N pas de contrôle

Caractères 13 à 15

Code du TOP du BL. Valeur par défaut : FIN

Notes triées

AFF_NOTE_QTE

Affichage automatique de notes avant saisie quantité

Ces notes ne fonctionnent que si l'article n'est pas cartonnier, c'est à dire mp_param[29] != 1 ou 4

L'article commandé doit avoir une nomenclature, les notes étant lues dessus.

Soit celui identifié par la séquence saisie soit en recherchant dans nom0.

Une fois le PF trouvé, la note REQ_COMPO_NOTE_QTE permet de retrouver un article de sa nomenclature, dans nom0, normalement la composition, (cette note est obligatoire).

Une fois la composition trouvée, on va lire le TSC paramétré en 21,23 pour retrouver le type de note à afficher.

Puis on va lire les notes du paramètre NTS que l'on vient de récupérer pour afficher un message de confirmation.

21,23 TSC

24 Code zone du TSC

25,27 Type de note à afficher

41,60 Complément de requête pour la recherche de composition

#CC

Contrôle de saisie des champs

5,22 Nom du champ. Cliquez ici pour afficher / masquer la liste des champs

23 Type de contrôle (N/W/B/I) (I = Interdit)

24 Le champ provoque-t-il une trace dans la table des événements d'atelier ? (O/N)

25 La valeur zéro est elle considérée comme significative ? (O/N)

26 La zone doit-elle être numérique ? (O/N, N par défaut)

CLI_ADRSEC_XXXXXXXX

Couples client - adresse secondaire autorisés ou interdits

où XXXXXXXX peut prendre les valeurs suivantes :

AUTORISE : pour autoriser les couples client - adresse secondaire

INTERDIT : pour interdire les couples client - adresse secondaire

21,26 Code client

28,30 Code adresse secondaire (* pour tous les codes adresse secondaires

Le contrôle du couple client - adresse secondaire est activé s'il y a au moins une ligne de paramétrage.

Il est conseillé de n'utiliser qu'un seul des 2 mots-clés pour un paramètre de lancement :

Si seul le mot clé CLI_ADRSEC_INTERDIT est utilisé, seuls les couples paramétrés seront interdits, tous les autres seront autorisés.

Si seul le mot clé CLI_ADRSEC_AUTORISE est utilisé, seuls les couples paramétrés seront autorisés, tous les autres seront interdits.

Dans le cas où l'on a un couple paramétré à la fois dans la liste des clients interdits et dans la liste des clients autorisés, c'est l'interdiction qui est prioritaire.

Si on remplace le code adresse secondaire par * alors tous les codes adresses secondaires du client sont concernés.

CODE_TRANSP_DEFAUT

21,26 Code transporteur.

Le BL créé depuis une liste de commande (-nCB) sera initialisé par défaut avec ce code transporteur.

CONTROLE_LIEU_RGT1

21 Saisie de la PLV - Contrôle de cohérence entre le lieu intermédiaire du BL et le lieu du produit de niveau supérieur - GENERO uniquement

N Pas de contrôle (Par défaut)

W Contrôle non bloquant

C Demande de confirmation

B Contrôle bloquant

Pour les livraisons aux sous-traitants, permet d'effectuer un contrôle de cohérence entre le lieu intermédiaire saisi sur l'entête du BL et le magasin de production de la ligne de nomenclature de commande du niveau supérieur. #CF ATL A1[36] est nécessaire.

COPIE_NOTES_CDE_BLV

Permet, lors de la création d'une nouvelle ligne de BL, de recopier les notes de la ligne de commande associée (table cde3) vers les notes de la ligne de BL (table blv3)

21,23 Type de note source de la ligne de commande (cde3)

24,26 Type de note destination de la ligne de bon de livraison (blv3)

COPIE_NOTES_CLI_BLV

Recopie les notes du client (adresse principale) sur les notes de l'en-tête du BL

21, 23 Type de note client source

24, 26 Type de note BL destinataire

CORRECTION_STOCKS

21,26 Paramètre de lancement du programme de correction des stocks palette.

(Type + Code) Par défaut : #SACOS

Doit pointer vers un programme du type maj_stk

31,36 Paramètre de lancement du programme de correction des stocks en vrac.

(Type + Code) Par défaut : #SACOR

Doit pointer vers un programme du type corr_stk

CR

3,60 Complément de requête pour la recherche des lots/lieux dans le détail colisage palettes

Utilisé dans le F7 détail palettes (option Odp) pour la récupération des lots / lieux de l'article livré.

CTRL_DT_LIV_CHARGMT

21,60 Paramétrage du contrôle de cohérence entre la date de livraison et celle de chargement.

N Pas de contrôle (par défaut)

B Bloquant

W Affichage d'un warning

C Demande de confirmation

23 Nombre de jours minimum après la date de chargement

date_livraison >= date_chargement + nb_jours

DECLARE_PRODUCTION

21,26 Type et code du paramètre d'accès à la déclaration de production

Ce paramétrage conditionne l'accès à la déclaration de production par la touche F18.

EMETTEUR_FAX_EMAIL

21,26 Type et code de l'émetteur du fax / email

Si le type est FAB et que le code n'est pas renseigné, alors on prendra comme code la zone Suivi d'affaire du client livré

EMPL_NFBI_PICKLOT

Aide à la saisie du picking dans les stocks

21,22 Début de l'emplacement du numéro FBI dans le code palette/bobine.

24,25 Fin de l'emplacement du numéro FBI dans le code palette/bobine.

Cette note permet d'activer l'aide au picking dans les stocks selon le numéro de FBI (touche F6 dans le picking)

L'option Odp est obligatoire.

Exemple

Code palette/bobine : 130800010100

Pour cet exemple, le numéro FBI est toujours situé sur les 8 premiers caractères du code palette/bobine.

La note sera paramétrée :

EMPL_NFBI_PICKLOT 01 08

EMPL_NPAL_PICKLOT

Aide à la saisie du picking dans les stocks

21,22 Début de l'emplacement du numéro de la palette/bobine dans le code palette/bobine.

24,25 Fin de l'emplacement du numéro de la palette/bobine dans le code palette/bobine.

Cette note permet d'activer l'aide au picking dans les stocks (touche F6 dans le picking).

L'option Odp est obligatoire.

Exemple

Code palette/bobine : 130800010100

Pour cet exemple, le numéro de la palette/bobine est toujours situé sur les 4 derniers caractères du code palette/bobine.

La note sera paramétrée :

EMPL_NPAL_PICKLOT 09 12

ETATS_CADENCEMENTS

21,23 Code état de création des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : CRE

24,26 Code état de modification des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : MOD

27,29 Code état de livraison non soldée des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : LNS

30,32 Code état de validation des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : VAL

Si cette note n'existe pas, elle est recherchée dans le #CF ATL.

FAEF20

7 Saisie automatique des TSC dans la saisie des BL (O/N). Voir alpha3[18]

FALF20

7 Saisie automatique des TSC sur ligne de BL (O/N). Voir alpha3[18]

FENETRE_AUTO_CLIENT

Permettre d'ouvrir des notes d'un certain type après la saisie du client du BL ou à l'ouverture de ce dernier

Remarque : Seules les notes saisies sur l'adresse principale du client sont prises en compte.

21,23 Type de notes saisies sur la fiche client à afficher

24 Ouverture de la saisie des notes en modification (O/N, O par défaut)

LIEU2_A_EXCLURE_DSOL

21,23 Code du lieu à exclure du lieu2 du mouvement de stock de référence.

La chaîne de caractère ainsi résultante sera concaténée au lieu2 paramétré dans la note REAFFECT_NVE_VEN.

LIEU2_A_EXCLURE_REAF

21,23 Code du lieu à exclure du lieu2 du mouvement de stock de référence.

La chaîne de caractères ainsi résultante sera concaténée au lieu2 paramétré dans la note REAFFECT_VEN_NVE.

LIS_CTRL_TSC

21,23 TSC à contrôler

Voir aussi TYP_CTRL_TSC

M_CTRL_QTE_PAR_PAL

Permet d'activer le contrôle de la quantité par palette lors du picking en saisie de bon de livraison.

Cette note contient le code du TSC qui contient le type de contrôle à faire sur la quantité par palette.

Le TSC peut être mis sur la ligne de commande, sur l'entête de commande, sur l'article de la ligne de commande ou le client de la commande.

Lors du picking, si la quantité par palette réelle est différente de la quantité par palette théorique alors un message s'affichera selon le type de contrôle choisi. Par défaut, il n'y a aucun contrôle.

21,23 Code TSC du mode de contrôle de la quantité par palette

Le contrôle porte sur la zone ic_char3_1.

Par défaut, les caractères 49 à 51 sont à blanc.

Le mode de contrôle de la quantité par palette peut être dans un TSC rattaché :

- soit à la ligne de commande

- soit à la commande

- soit à l'article de la ligne de commande

- soit au client de la commande

Le contrôle porte sur la zone ic_char3_1

Mode de contrôle de la quantité par palette

N Pas de contrôle même si la quantité par palette est différente de la quantité du picking (valeur par défaut)

W Message d'avertissement si la quantité par palette est différente de la quantité du picking

C Demande de confirmation si la quantité par palette est différente de la quantité du picking

B Blocage si la quantité par palette est différente de la quantité du picking

MAG_DEF_BON_TRSFT

21,23 Lieu intermédiaire par défaut des bons de transfert. Facultatif

MAJ_FLAG_INFO_C

21,60 Paramétrage du TSC à mettre à jour

Transfert des expéditions - Envoi des informations sur les palettes expédiées

MES_CTRL_TSC

21,60 Message à afficher lors de la présence du TSC

Fonctionne conjointement avec les notes LIS_CTRL_TSC et TYP_CTRL_TSC

_NGP_BL_DEGRADE

Création nouveau groupage en mode dégradé

21,23 Numéro du compteur des groupages (espace ou 1 à 999)

Exemple 001

24 Type de numérotation des groupages

N Mensuel (par défaut)

O Annuel

N_GROUPAGE_A_EXCLURE

21,28 Numéros de groupage à exclure du contrôle (11 maxi)

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table blv3. Obligatoire. Exemple : TEX

24,26 Type de mouvement des sorties normales du TEXTILE. Obligatoire. Ex : SL

27,29 Type de mouvement des sorties réserves du TEXTILE. Obligatoire. Ex : SR

30,32 Type de mouvement des entrées normales du TEXTILE. Obligatoire. Ex : EL

33,35 Type de mouvement des entrées prévisionnelles du TEXTILE. Obligatoire. Ex : EP

36,38 Lieu de rangement par défaut des lignes du TEXTILE (Type RG1) si pas de lieu intermédiaire sur l'entête du BL. Facultatif. Exemple : TXI

NUM_AFFRET_AUTORISE

21, 28 Numéro d'affrètement autorisé (19 maxi)

Ceci permet de paramétrer une liste restrictive de numéros d'affrètements que l'opérateur pourra utiliser, car on ne doit pas pouvoir saisir un numéro d'affrètement qui a été généré via GENERO.

Cela renforce l'action de l'option Ogi.

NUM_CERTIF_FSC

21,60 Numéro de certificat FSC

NUM_GROUPAGE_DEFAUT

Numéro de groupage

Le BL créé depuis une liste de commande (-nCB) sera initialisé par défaut avec ce numéro de groupage.

OBJET_DOCUMENT

21,23 Type de document (BLV)

25,60 Objet du document pour le fax/email

ORDER_CDE2_BLV_AUTO

21,60 Complément de tri des lignes de commandes lors de la création des lignes de BL en automatique (Ocd)

PAL_CONSIG_ADRESSE

21,23 Code adresse secondaire par défaut de destination du retour d'une palette consignée

Voir le suivi des palettes consignées

PAL_CONSIG_CLIENT

21,26 Code client destinataire par défaut du retour d'une palette consignée - Par défaut : #SOC

Voir le suivi des palettes consignées

PAL_CONSIG_DEV_TAR0

21 Si le prix du tarif est à zéro, on recherche le prix sur le devis associé (O/N, N par défaut)

Voir le suivi des palettes consignées

PAL_CONSIG_LI_QUA

21,23 Code du paramètre de qualification du cadencement de livraison qui sera généré

Dans la gestion des retours de palettes consignées, en saisie de BL, le système génère automatiquement une ligne de commande avec sa ligne de cadencement de livraison.

Par défaut, le qualificatif du cadencement de livraison n'est pas renseigné, ce qui peut poser des problèmes si on retourne sur la ligne générée en saisie de commande.

PAL_CONSIG_RECH_TAR

21,26 Type et code paramètre de recherche du tarif d'une palette consignée

Par défaut : le prix est récupéré sur la fiche article de la palette (mat.mp_pv)

Voir le suivi des palettes consignées

PAL_CONSIG_RGT_1

21,23 Lieu de rangement 1 de destination par défaut du retour d'une palette consignée

Voir le suivi des palettes consignées

PAL_CONSIG_RGT_2

21,26 Lieu de rangement 2 de destination par défaut du retour d'une palette consignée

Voir le suivi des palettes consignées

PAL_CONSIG_RGT_3

21,26 Lieu de rangement 3 de destination par défaut du retour d'une palette consignée

Voir le suivi des palettes consignées

PARAM_CONSULT

21,26 Type et code du paramètre de lancement du programme de qualité carton en mode consultation (#SA QUA par défaut).

Cette note est accessible dans tous les programmes exploitant la fonction f_visu_nomenclature : cde, blv, v_cdem, v_jbl

POIDS_UNI_PAL_DEFAUT

21,30 Poids unitaire d'une palette par défaut. Obligatoire

Exemple : POIDS_UNI_PAL_DEFAUT0.600

Voir option Op2

POURC_QTEFAB_QTELIV

Suppression des ordres de transport concernant les CDA

21,26 Pourcentage sur quantité fabriquée pour comparaison avec la quantité livrée réelle.

Suppression des OT concernant les CDA selon la règle suivante au moment de la question du solde de la ligne (en saisie de ligne de BL) :

Qté livrée réelle >= Qté Cdée et Qté livrée réelle = +- x% de la qté fab

C'est le paramétrage de ce pourcentage qui déclenche ce nouveau fonctionnement.

Avec ce paramétrage, on passe outre le contrôle sur le solde de toutes les CD1 rattachées.

Rappel : Dans la logistique, la saisie des BL est lancée automatiquement depuis le module des expéditions.

REAFFECT_NVE_VEN

Réaffectation des excédents (surplus) de production (Option Ors)

21,23 Type du mouvement de sortie de réaffectation (Par défaut SN)

24,26 Type de mouvement d'entrée de réaffectation (Par défaut EN)

27,29 Lieu de niveau 1 pour le mouvement d'entrée (Par défaut USI)

30,35 Lieu de niveau 2 pour le mouvement d'entrée (Par défaut VEN)

Voir aussi la note LIEU2_A_EXCLURE_DSOL

REAFFECT_VEN_NVE

Réaffectation des excédents (surplus) de production (Option Ors)

21,23 Type de mouvement de sortie de réaffectation (Par défaut SN)

24,26 Type de mouvement d'entrée de réaffectation (Par défaut EN)

27,29 Lieu de niveau 1 pour le mouvement d'entrée (Par défaut USI)

30,35 Lieu de niveau 2 pour le mouvement d'entrée (Par défaut NVE)

Voir aussi la note LIEU2_A_EXCLURE_REAF

REGROUP_STOCK_ART

Voir dans les généralités

REQ_COMPO_NOTE_QTE

21,60 Supplément de requête pour la lecture du composant utilisé pour l'affichage automatique de notes avant saisie quantité (note AFF_NOTE_QTE)

RP_AFFICHER_BLV

Gestion des retours de produits

Affichage et saisie des zones de BL correspondant au produit retourné (O/N, O par défaut)

• Numéro de BL

• Numéro de ligne de BL

RP_AFFICHER_CDE

Gestion des retours de produits

Affichage et saisie des zones de commande correspondant au produit retourné (O/N, O par défaut)

• Numéro de commande

• Ligne de commande

• Séquence de commande

RP_LIEU_RANGEMENT

Gestion des retours de produits

21,23 Magasin par défaut (lieu de rangement 1) de destination du produit retourné

Pas de valeur par défaut

24,29 Emplacement par défaut (lieu de rangement 2 : entête - détail) de destination du produit retourné

Pas de valeur par défaut

RP_RECH_TAR

Gestion des retours de produits

21,26 Type et code du paramètre de recherche du tarif d'un produit retourné

Par défaut : Le prix est récupéré sur la fiche article (mp_pv)

RP_SUP_SQL_F7_BLV

Gestion des retours de produits

21,60 Complément de sélection pour la recherche du numéro de BL d'origine du retour

RP_SUP_SQL_F7_CDE

Gestion des retours de produits

21,60 Complément de sélection pour la recherche du numéro de commande d'origine du retour

RP_SUP_SQL_F7_PROD

Gestion des retours de produits

Complément de sélection pour la recherche du code produit retourné

RP_TYPE_RECDMP

Gestion des retours de produits

21 Type de recherche d'article pour la saisie du code produit retourné

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Q Recherche sur la qualité

T Recherche orientée Transformateurs

SQL_REAFFECT_NVE

_SQL_REAFFECT_NVE_VEN

21,60 Complément de sélection pour la recherche des excédents (surplus) de production à réaffecter (Ors)

Les 2 syntaxes sont autorisées mais il est recommandé d'utiliser la syntaxe courte qui est identique à celle de la saisie de commande client.

SQL_REAFFECT_VEN

SQL_REAFFECT_VEN_NVE

21,60 Complément de sélection pour la recherche des excédents (surplus) de production à réaffecter (Ors)

Les 2 syntaxes sont autorisées mais il est recommandé d'utiliser la syntaxe courte qui est identique à celle de la saisie de commande client.

_SUP_REQ_BLV1

21,60 Supplément de requête sur la table blv1

Utilisé en modification, interrogation et annulation pour vérifier si le BL peut être modifié, interrogé ou annulé.

Exemple

and blv1.b1_blv matches "060*"

_SUP_REQ_CDE8

21,60 Supplément de requête sur la table cde8

Exemple and li_lig_cad > 1

_SUP_REQ_GROUPAGE_BL

21,60 Supplément de requête sur la table groupage_bl

_SUP_REQ_INTERD_PICK

Supplément de requête sur lieux interdits de picking

Contrôle du lieu de destockage dans picking BL

L'option Oip doit être positionnée.

21,60 Complément de requête uniquement sur table lieu_rgt_e (sur champs lre_rgt1 et / ou lre_rgt2)

Exemples : _SUP_REQ_INTERD_PICK and lre_rgt1 = SFV

_SUP_REQ_INTERD_PICK and lre_rgt2 matches *ROU

interdit de livrer depuis SFV tout ce qui est en zone ROU

Les champs (lieux de rangements) correspondants à la sélection seront interdits.

Il existe 4 notes gérant les limitations de picking :

1) _SUP_REQ_INTERD_PICK

2) _SUP_REQ_I_CLI_PICK liée au client à livrer

3) _SUP_REQ_I_RG1_PICK liée au lieu intermédiaire (b1_lieu_rgt1)

4) _SUP_REQ_INTER_PICK3 supplément de requête si le client ou le lieu intermédiaire ne sont pas rattachés au _SUP_REQ_I_CLI_PICK ou au _SUP_REQ_I_RG1_PICK

Le fonctionnement est le suivant :

Le supplément de requête 1 sera toujours appliqué (_SUP_REQ_INTERD_PICK).

Si le lieu intermédiaire correspond à un supplément de requête (_SUP_REQ_I_RG1_PICK), alors le fonctionnement sera : 1 + 3.

Sinon, si le client et le code adresse correspondent à un supplément de requête (_SUP_REQ_I_CLI_PICK) on aura 1 + 2.

Enfin, si aucune des conditions ci-dessus ne sont réunies, alors le fonctionnement sera 1 + 4.

_SUP_REQ_I_CLI_PICK

Supplément de requête lié au client à livrer

L'option Oip doit être positionnée.

21,26 Code client

27,29 Code adresse secondaire

30,60 Supplément de requête uniquement sur table lieu_rgt_e

_SUP_REQ_I_RG1_PICK

Supplément de requête sur le lieu intermédiaire (b1_lieu_rgt1)

L'option Oip doit être positionnée.

21,23 Lieu de rangement de niveau 1

25,60 Supplément de requête uniquement sur table lieu_rgt_e

_SUP_REQ_INTER_PICK3

21,60 Supplément de requête uniquement sur table lieu_rgt_e

L'option Oip doit être positionnée.

_SUP_REQ_LIEU_RGT1

21,60 Complément de requête

Permet d'exclure des code de type RG1 dans l'interrogation (F7) sur la zone des lieux intermédiaires. Idem dans exped_affretements

Ce complément de requête peut être restreint par utilisateur : dans ce cas, il peut être complété par une autre note, du même nom, sur le paramètre USE.

_SUP_REQ_PAL

21,60 Supplément de requête pour la recherche de l'article palette sur la table nom0. Obligatoire - GENERO uniquement

Exemple

_SUP_REQ_PAL and nom0.n0_pcsant [1,4] = "XPAL"

Voir option Op2

_SUP_REQ_PICK_DEGRA

21,60 Complément de requête sur la table stk0 pour la recherche des palettes dans l'écran du picking

Cela permet par exemple d'exclure des lieux de rangement.

Exemple

_SUP_REQ_PICK_DEGRA and s0_rgt1 not in ("COD")

_SUP_REQ_SITE_PICK

Compléter la recherche actuelle des lieux de picking, en tenant compte des sites de production de l'utilisateur.

Tableau de bord du multisite

La seule présence de la note vérifiera que le site de production associé au lieu de rangement est (s'il est renseigné) identique à celui de l'utilisateur.

TITRE_DOCUMENT

21,23 Type de document (BLV)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

TYC_LOT_INT_PICK_

Contrôle du lot du picking

18,20 TYC de la commande livrée - Obligatoire

21,23 TYC (Commande client) ou TYF (Commande fournisseur) de la commande du lot interdit. Obligatoire
Le TYC doit être identique au TYC de la commande livrée si le picking est autorisé que sur les lots de la ligne de commande livrée (cas des FB2).

25,25 Code contrôle du lot du picking - Facultatif

N Pas de contrôle (Valeur par défaut)

W Avertissement

C Demande de confirmation

B Bloquant

TYP_CTRL_TSC

21 Type de contrôle si présence d'un TSC

N pas de contrôle (valeur par défaut)

B Contrôle bloquant

W Contrôle avec avertissement

C Contrôle avec demande de confirmation

Le message est paramétré dans la note MES_CTRL_TSC

TYPE_NOTES_LIG_BL

21,23 Type de note de la ligne de commande à afficher lors de la saisie des lignes de BL

USING_NFBI_PICKLOT

21,44 Using du numéro d'OF extérieur

A utiliser dans le cas où le code palette/bobine contient le numéro d'OF extérieur au lieu du numéro de FBI de VoluPack. Le numéro d'OF extérieur est un numérique.

Voir l'option Odp.

Paramètres associés

#CF ATL | Adresses provenant du dossier de fabrication
#CF BLV | Gestion de la configuration du BL
#CF TRA | Traçabilité
#CF CDE |

Infos sur les zones nc_qteliv

Sur un BL, il y a 2 zones quantités : b2_qte et b2_qteliv

b2_qte représente la quantité facturable sur le BL

b2_qteliv représente la quantité réellement livrée du BL

Il faut savoir aussi qu'un BL possède un état de validation pour la facturation, on parle alors de BL définitif (par opposition au BL provisoire).

Lorsqu'on saisit un BL sur une ligne de nomenclature de commande, on fait :

nc_qteliv = nc_qteliv + b2_qte (cela représente la quantité livrée facturable sur la ligne de nomenclature).

nc_qteliv_non_val = nc_qteliv_non_val + b2_qte (cela représente la quantité livrée facturable non validée en facturation).

nc_qteliv_reelle = nc_qteliv_reelle + b2_qteliv (cela représente la quantité réellement livrée sur la ligne de nomenclature).

Lorsqu'on valide le BL (édition en définitif), on fait :

nc_qteliv_non_val = nc_qteliv_non_val - b2_qte

nc_qteliv_val = nc_qteliv_val + b2_qte

=> La quantité livrée facturable du BL passe de la zone non validée à la zone validée...

Lorsqu'on facture le BL (attention, puisque l'on travaille sur des lignes de nomenclature, on n'est pas obligé de facturer l'intégralité de ta quantité livrée facturable), on fait :

nc_qteliv_val = nc_qteliv_val - fl_qte

En conclusion :

nc_qteliv Quantité livrée facturable

nc_qteliv_reelle Quantité réellement livrée

nc_qteliv_non_val Quantité livrée facturable non encore validée

nc_qteliv_val Quantité livrée facturable validée mais non encore facturée

Saisie du détail du colisage

Il s'agit d'une saisie améliorée de notes.

Mode d'emploi : Faire F7 sur la zone poids ou nombre de colis ou nombre d'exemplaires / colis.

Une fenêtre est alors ouverte dans laquelle on peut saisir en tableau :

  • Un libellé

  • Un nombre de palettes

  • Un nombre de colis (caisses)

  • Un nombre d'exemplaires par colis

  • Un poids

Au F10, le nombre total de colis est calculé, le poids total est calculé et le nombre total d'exemplaires par colis est calculé.

Les lignes saisies sont mémorisées dans les notes liées à la ligne de BL (Note de type #dc en minuscules !!!)

Saisie du détail emballage

(qd -Oem remplace la saisie colisage) Il s'agit d'une saisie améliorée de notes.

Mode d'emploi : Faire F7 sur la zone poids ou nombre de colis ou nombre d'exemplaires / colis.

Une fenêtre est alors ouverte dans laquelle on peut saisir en tableau :

  • Un code emballage (type paramètre EMB)

  • Un nombre de palettes

  • Un nombre de colis

  • Un nombre d'exemplaires par colis

  • Un poids

  • Un coût de l'emballage

Ce coût est calculé à partir du coût unitaire de l'emballage saisi en A1[16,25] sur le code paramètre

Exemple coût unitaire * nombre palettes * nombre colis par palettes

Le nombre de palettes n'intervient donc que comme un coefficient multiplicateur du coût de l'emballage et n'est pas valorisé au même titre que les colis.

Ce coût est remonté dans l'entête, provisoirement dans la zone b1_montant en attendant mieux

Pour que le poids total et le nombre d'exemplaires remontent aussi sur l'entête, ne pas oublier -Oco

Au F10, le nombre total de colis est calculé, le poids total est calculé et le nombre total d'exemplaires par colis est calculé.

Les lignes saisies sont mémorisées dans les notes liées à la ligne de BL (Note de type #dc en minuscules !!!)

Suivi des stocks des produits finis en transit des bons de livraison et de transfert

Suivi des stocks des produits finis en transit des | bons de livraison | bons de transfert
Le lieu de transit est indiqué en RG1 A2[19,21] sur... | ... le lieu de picking | ... le lieu intermédiaire
Saisie : Paramétrer A4[10]. à la validation du picking, les produits finis sont sortis du lieu de picking et entrés sur le lieu de transit (option Ost). |  |
Edition définitive : Paramétrer A3[28]. Les produits finis sont sortis du lieu de transit (option Ost) ... |  | ... et entrés sur le lieu intermédiaire. Prise en compte de la phase de mitraillage ?
Sur le lieu de transit, l'indicateur de lieu de transit RG1 A2[22] = O. |  |
Les types de mouvement de stock de transfert sur un lieu de transit sont paramétrables dans les notes MVT_TYPE_LIV_ du #CF BLV, caractères 33 à 38. |  |

Suivi des palettes consignées

Permet de gérer le suivi des palettes consignées dans la saisie des BL.

La permission TOU/BLV2_CTRL_R (interdite par défaut) est requise pour créer une ligne de retour de palette consignée.

Cette gestion utilise la saisie simplifiée des commandes (accessible depuis la visualisation des articles, par exemple).

Paramétrage

blv | notes commençant par PAL_CONSIG PAL_CONSIG_ADRESSE PAL_CONSIG_CLIENT PAL_CONSIG_DEV_TAR0 PAL_CONSIG_RECH_TAR PAL_CONSIG_RGT_1 PAL_CONSIG_RGT_2 PAL_CONSIG_RGT_3
TMV | A3[6] = T
#CF BLV | Notes TMV_ENT_PAL_CONSIG et TMV_SOR_PAL_CONSIG
#CF CDE | Note TSC_PAL_CONSIGNEE
SFM | Note PALETTE_CONSIGNEE

Gestion des retours de produits

Dans la saisie des BL, on peur gérer les retours de produits (création d'une ligne de BL avec une quantité négative, associée à la création d'une ligne de commande avec la même quantité).

Remarques

• Nouvelle action disponible dans la saisie des lignes des bons de livraison soumise aux contraintes suivantes :

o Control-Shift-R : Retour de produit

o Option payante LIV 8 : Gestion des retours de produits

o Permission TOU BLV2_CTRL_MJ_R : touche CTRL-MAJ-R sur ligne BL

• Cette fonctionnalité est incompatible avec la saisie des bons de transfert (option Ob1 sur la saisie des bons de livraison)

• La gestion des ensembles (nomenclature de commande cde4) n'est pas gérée pour le moment. Il est possible de saisir le retour d'un produit faisant partie d'une nomenclature, mais celui-ci sera enregistré au niveau de la ligne de commande (cde2).

Paramétrage

Paramètre de lancement (ici) : toutes les notes commençant par RP

#CF BLV : note TMV_ENT_RETOUR_PDT_


Edition des bons de livraison

Exemples de paramétrages des éditions / rééditions

Concerne uniquement les paramètres suivants : -P -r -Obn -Obp -Ort

Les autres paramètres devront être ajoutés à ces combinaisons

Edition provisoire des BL | -P
Réédition des tous les BL édités provisoirement ou définitivement | -r –Ort
Edition définitive des BL édités provisoirement | -Obn
Edition définitive des tous les BL édités ou non provisoirement | Pas de paramétrage
Réédition seulement des BL édités définitivement | -r
Réédition seulement des BL édités provisoirement | -r –P
Edition définitive des BL jamais édités provisoirement | -Obp

Une édition commerciale simplifiée peut être obtenue en créant des notes de type EDC sur une entité de sous-devis

Type et code : NTS EDC

Libellé long : Notes commerciales

Edition des bons de livraison blv_ed1
Edition des BL GALIA blv_galia_ed1

Options - Valeurs alpha - Paramètres associés - Types d'édition - Notes

Suivi des stocks des produits finis en transit des bons de livraison et de transfert : voir le paragraphe dédié dans la saisie des BL.

Choix du modèle d'étiquette

Le modèle d'étiquette est indiqué en MDO A1[1,8].

Le code du paramètre MDO est recherché en priorité dans l'ordre suivant :

1 - TSC _ET de la ligne de commande

2 - TSC 250 du PF

3 - TSC P10 DU PF

4 - MDO du client

5 - MDO ETS en dur

Types d'édition

-r | Pour la réédition des BL provisoires et/ou définitifs
-P | Pour l'édition provisoire des BL ou la réédition des BL provisoires
-e | Edition complète sans passer par l'écran de sélection des BL en provisoire ou en définitif
-N | Doit être suivi du numéro de BL à éditer
-X | 3,5 Code quai 6,8 Code imprimante
-W | 3,5 Code quai 6,8 Numéro d'imprimante
-B | Mode batch

Cliquez ici pour afficher / masquer des exemples de paramétrage

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : N° de BL

Exemple : -N[b1_blv]

Options triées

Oab

Cette option permet de lancer l'édition de BL annulés.

Pour les BL annulés, la mention ANNULE apparaît derrière le numéro de BL lors de l'édition.

Oad

Affiche le numéro du dernier BL saisi, uniquement dans le cas d'une édition partielle

Oas

Affichage aire de stockage

Obn

Pas de sélection des BL non édités. Permet, pour un paramétrage d'édition de BL définitive, d'interdire l'édition définitive de BL non édités provisoirement

Obp

Pas de sélection des BL édités provisoirement (sélection des BL jamais édités)

Obs

Actif uniquement si Ocd. S'il n'y a aucun critère de sélection, permet d'éditer les BL concernant les commandes soldées et dont le mois de livraison est dans le mois en cours

Obv

Edition de bons de livraison valorisés

On génère une facture de simulation pour le bon de livraison édité quelque soit l'état de celui-ci (Provisoire ou Définitif) Voir alpha3[10,15]

Oca

Cartonnage

Ocb

Recopie du BL vers une autre société lors de l'édition définitive

Lors de l'édition définitive du BL, il est possible de recopier le contenu du BL vers une autre société (le numéro de BL sera automatiquement incrémenté sur la société destinatrice).

Paramétrer la note RECOPIE_BL et le TSC 60E.

Attention :

– La recopie fonctionne uniquement si les sociétés sont sur la même base de données.

– Les deux sociétés doivent avoir les mêmes codes clients et articles.

Ocd

Sélection des BL par les commandes. Bien sûr aucun intérêt si le client ne saisit pas une commande par BL. En réédition, on passe automatiquement par la sélection par numéro de BL

Ocg

Code barre groupage en fin d'édition de BL - SPECIFIQUE

Ocp

OPTION PERIMEE

Ocu

Edition des coordonnées de la société

Ocv

Choix de la valorisation d'un BL à l'édition

Odb

Mise à jour de la date de livraison du BL avec la date de l'édition.

Odc

La date du mouvement de stock sera la date de chargement et non la date du jour.

Odi

Edition définitive interdite sur un client AVIEXP

Voir la note AFF_MSG_PROV_AVIEXP.

Odl

La date du mouvement de stock généré est la date du bon de livraison et non la date du jour

Ce paramètre existe aussi sur blv.4ge

Odo

Rend obligatoire le critère date

Oec

Affiche le récapitulatif des critères de sélections sur écran

Oeg

Contrôle la cohérence des étiquettes Galia

Oen

Edition d'une étiquette neutre

Oep

Exécution d'un programme pour chaque BL édité.

Le programme à lancer doit être paramétré :

- soit en alpha2[30,35] pour enchaînement standard,

- soit dans la note PGM_RUN_PROG_CLI pour un enchaînement spécifique à chaque client livré.

Attention !

Ce programme est lancé systématiquement si l'on ne positionne pas l'option Oes.

Si l'option Oes est positionnée, on vérifie :

1) que le client est AVIEXP (TSC TRS sur l'adresse de livraison, zone ic_char3_1 = O, S ou A)

2) si le client AVIEXP est différent de A, qu'il existe un message de type CALDEL

Oes

Edition spécifique GALIA

Conditionne l'envoi du programme lié à l'option Oep.

Oet

Edition des étiquettes spécifiques GALIA

Ofd

Edition ou réédition de factures de douane

Ofe

Forçage de la mise à jour du champ gb_etat_affret à l'édition du BL définitif

Rappel : si tous les BL du groupage sont en définitif, alors le champ gb_etat_affret est mis à jour à 6 (état définitif)

Ce mode de fonctionnement existe déjà si la logistique est activée (voir #CF LOG)

Ofp

Force le prix du mouvement de la sortie normale au PAMP recalculé du produit.

Ne fonctionne qu'avec les options –Orp et –Orb.

Ogd

Mise à jour de l'état d'affrètement en définitif (gb_etat_affret = 6) même si toutes les lignes de groupage ne sont pas expédiées.

Par défaut, seules les lignes de groupage dont le BL est édité en définitif sont flaguées en définitif (gb_etat_affret = 6)

Ogi

Lorsqu'un BL est rattaché à un numéro de groupage présent dans la table groupage_bl, il est interdit de l'éditer dans le programme standard d'édition des BL (blv_ed1).

Cette option permet d'éviter l'édition d'un BL qui a été créé par le module de gestion des expéditions des affrètements

Ohb

Mise à jour de l'heure de départ du BL avec l'heure de l'édition.

Oii

Interface des entrées en stock dans ITEM

A chaque édition d'un BL, écriture dans un fichier ASCII qui sera envoyé au système du transporteur.

Un filtre Information à transférer est mis en place au niveau du lieu de rangement 1 de l'entête de BL édité.

Voir la note FIC_ITEM_LOCK

Voir aussi les notes commençant par FIC_ITEM_ et la note TYPE_INTERFACE_ITEM dans RG1.

Oiq

Paramétrage des imprimantes par quai de groupage et non plus par USE

Cette option utilise le même paramétrage que le choix des imprimantes par code USE, notes de type -X, ce qui les rend incompatibles.

Oit

Informations transporteur

Pour édition APPIC :

Ligne 51 caractère 106 : Nom du transporteur

Ligne 52 caractère 106 : adresse 1 du transporteur

Ligne 53 caractère 106 : adresse 2 du transporteur

Ligne 54 caractère 106 : code postal du transporteur

Ligne 54 caractère 114 : ville du transporteur

Ligne 54 caractère 139 : libellé long du pays du transporteur

Ol0

(ligne zéro) Pas d'édition des lignes où la quantité est 0

Ols

On ne tient pas compte si la ligne est soldée pour créer l'entrée prévisionnelle sur reliquat
En édition définitive des BL (fonctionne uniquement avec l'option -Opn)

Omc

Edition ou réédition des documents de mise en consignation

Omd

Pouvoir forcer la date et l'heure d'arrivée sur le bon de livraison

Modification de la date et heure d'arrivée

Ome

Mise à jour de la table des événements (insertion d'un enregistrement pour chaque BL édité en définitif)

Omn

Edition par VOL'ETIQUETTE en mode NFS

Omu

Interdit la sélection multicritère

Ono

Voir paramètre -Ono dans la saisie des BL. Transformation des sorties réserves générées par l'édition de l'AR en sorties normales pour les lignes de nomenclature (cde4)

Ooa

Désactive l'édition de la ligne des accessoires

Ooc

Désactive l'édition de la ligne des couleurs

Oof

Désactive l'édition de la ligne FEFCO

Ool

Edition du libellé de la composition

Oop

Liste des OF pickés

Jusqu'à 4 OF différents peuvent être affichés.

Attention : l'option Onr en saisie de BL doit être activée. Elle empêche la réaffectation de lot.

Pour chacun des OF, on affiche la date de fin de fabrication qui lui correspond (recherche dans la table stk0 avec la commande rattachée).

Opa

Gestion des facturations palettes

(voir ci-dessous le tableau de correspondance des CIC à paramétrer)

Opb

Quand un numéro de BL est passé (par -NXXXXXXXX), on considère que l' on doit éditer tous les BL ayant un numéro supérieur à celui passé.

Opn

Transformation des entrées prévisionnelles en entrées normales avec gestion du reliquat

Paramétrage : Type du mouvement de stock d'entrée normale en édition de BL

alpha2[25,27] du TYC de la commande ou #CF BLV alpha1[32,34] si non renseigné.

Opp

Passage des mouvements de stock d'entrée prévisionnelle des BL à normal :

En édition provisoire des BL, en réédition provisoire des BL, en édition définitive des BL.

Opq

Passage des mouvements de stock d'entrée prévisionnelle des BL à normal en édition définitive des BL.

Opr

Palettes regroupées

Permet de regrouper les lignes de colisage en fonction de la quantité par palette (correspondant à la zone s0_rgt3).

Opz

Interdire l'édition du bon de livraison si le poids d'une ligne est à zéro

Orb

Suppression de la sortie réserve générée par la saisie du BL et création de la sortie normale avec comme type de mouvement celui de la sortie réserve en édition définitive des BL

Si sortie normale déjà créée à la même date, on ne recrée pas le mouvement de sortie normale.

Orn

Déduction de la sortie normale générée par l'édition du BL de la sortie réserve générée par la commande en édition définitive des BL (Gestion du reliquat de réserve sur la commande).

Orp

Suppression de la sortie réserve générée par la saisie du BL et création de la sortie normale avec comme type de mouvement celui de la sortie réserve en édition-réédition provisoire des BL et en édition définitive des BL

Si sortie normale déjà créée à la même date, on ne recrée pas le mouvement de sortie normale

Orq

Réintégration de la quantité non livrée de l'appel de livraison si la ligne de cadencement de livraison est soldée et si le bon est édité en définitif

Ort

La réédition devient unique, que les BL aient été édités provisoirement ou définitivement

A utiliser avec -r (mais pas avec -P)

Osc

Edition des étiquettes galia sans confirmation

Osr

Pas de mise à jour du stock résultant lors de la mise à jour des stocks

Ost

Suivi des stocks des produits finis en transit

Les produits finis sont sortis du lieu de transit et entrés sur le lieu intermédiaire en édition définitive des bons de transfert.

Les produits finis sont sortis du lieu de transit en édition définitive des bons de livraison.

Ote

Edition des notes de type TEXTILE de la table blv3

Otp

Totalisation picking édition VoluEdit

Ots

La ligne de séparation entre les BL n'est pas éditée lors de l'édition

Ott

Lorsqu'on transforme la sortie réserve créée par la saisie du BL en sortie normale, le type de mouvement de stock de la sortie réserve est remplacé par celui de la sortie normale de l'édition du BL.

Ova

Recherche le modèle d'étiquette sur la fiche article

Ovb

Valorisation des BL - à faire dans chaque report spécifique

Ovc

Valorisation des bons de livraison si cl_valbl = O (valorisation BL du client livré)

A faire dans chaque report spécifique.

Les options suivantes ne doivent pas être activées :

Ofd (facture de douane)

Omc (document de mise en consignation)

-P (édition provisoire)

Les modèles APPIC doivent être modifiés.

Ove

Edition par VOL'ETIQUETTE

Ovp

Vérification du prix de vente par rapport au tarif

Lors de l'édition définitive des bons de livraison, on peut bloquer la validation en facturation du BL si le prix de vente ne correspond pas au tarif trouvé pour le produit courant.

Voir les notes commençant par PAR_CONF_TARIF_TYC.

Ovq

Contrôle lors de l'édition du BL définitif la quantité livrée par rapport à celle commandée

Une tolérance peut être paramétrée dans #CF BLV valeur numérique 3.

Jusqu'à présent, lorsqu'un utilisateur crée un BL, il est averti par un message non bloquant que la quantité livrée est supérieure à celle commandée.

Ainsi, il peut éditer un BL provisoire puis un définitif.

Via cette option, on peut interdire l'édition du BL définitif si la quantité livrée est supérieure à la quantité commandée.

Une tolérance en pourcentage de la quantité commandée peut être appliquée.

Cette option est soumise à la permission MEN BLV_V_QST

Ovs

Exécution du programme de visualisation des mouvements de stock pour chaque BL édité

Le programme à lancer doit être paramétré en A2[36,41].

Oxm

Envoi automatique des fax / email

Voir les notes VALID_FAXMAIL_EDIT et VALID_FAXMAIL_REEDIT

Fin des options triées

Tableau de correspondance des CIC à paramétrer. Voir option –Opa ci-dessus.

C08 | code article palette 1 | P66 | Produit appairé sur la même palette
C09 | code article contre palette 1 | P67 | Produit appairé sur la même contre-palette
C12 | code article palette 2 | P68 | Produit appairé sur la même palette
C13 | code article contre palette 2 | P69 | Produit appairé sur la même contre-palette
C14 | code article palette 3 | P70 | Produit appairé sur la même palette
C15 | code article contre palette 3 | P71 | Produit appairé sur la même contre-palette
C16 | code article palette 4 | P72 | Produit appairé sur la même palette
C17 | code article contre palette 4 | P73 | Produit appairé sur la même contre-palette
C18 | code article palette 5 | P74 | Produit appairé sur la même palette
C19 | code article contre palette 5 | P75 | Produit appairé sur la même contre-palette

Valeur alpha 2

Caractère 1 | Visualisation d'un état de l'édition des BL 0 Visualisation de tous les BL (par défaut) 1 Visualisation des BL édités 2 Visualisation des BL en anomalie 3 Aucun BL
Caractères 2 à 7 | Type et code du paramètre de lancement du module d'édition des factures de douane
Caractères 8 à 13 | Type du paramètre de lancement du module de réédition des factures de douane
Caractères 14 à 19 | Type et code du paramètre de lancement du module d'édition des documents de mise en consignation
Caractères 20 à 25 | Type et code du paramètre de lancement du module de réédition des documents de mise en consignation
Caractères 26 à 29 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 30 à 35 | Type et code du paramètre de lancement du programme à exécuter pour chaque BL L'option Oep doit être positionnée. Pour un enchaînement spécifique à chaque client livré, remplacez ce paramétrage par la note PGM_RUN_PROG_CLI.
Caractères 36 à 41 | Type et code du paramètre de lancement du programme de visualisation des mouvements de stock à exécuter pour chaque BL édité L'option Ovs doit être positionnée.

Valeur alpha 3

Caractères 1 à 3

Temps d'attente pour le programme Vol'Etiquette, nécessaire car il s'agit d'un programme pouvant utiliser un transfert FTP de fichier.

Caractères 4 à 9

Type et code du paramètre de recherche des tarifs pour les palettes / contre-palettes

(par défaut #CF TAR)

Caractères 10 à 15

Type et code du paramètre de lancement de l'édition des BL valorisés (si option -Obv positionnée).

Un BL valorisé est en fait une édition de la facture de simulation correspondante.

Caractères 16 à 18

Code tarif de recherche du prix de la ligne de palette / contre-palette qui va être générée.

Si non renseigné, on recherche avec le code tarif de l'entête de commande.

Caractères 19 à 21

Nouveau code tournée à appliquer après validation d'un BL

Pas de valeur par défaut, si non renseigné, pas de mise à jour du code tournée.

Caractères 22 à 24

Code TSC à lire sur le produit livré pour récupérer le code emballage (qui sera lu à son tour)

Créer le code TSC XXX avec la zone ic_char_30 = code emballage

Explication

Lors de l'édition définitive d'un BL, on recherche le code palette (en vue de la sortie automatique des palettes consignées).

Cette recherche se fait selon le cascading suivant :

- TSC 231 sur ligne de BL

- TSC 231 sur ligne de commande

- TSC 231 sur produit livré

- TSC 231 du TSC du produit livré (nouveau niveau )

- nomenclature.

On recherche un emballage pris sur le TSC paramétrable du produit livré, puis on recherche le code palette pris sur le TSC 231 du code emballage préalablement trouvé.

Caractères 25 à 27

Code qualificatif sur appel du cadencement de livraison - Obligatoire

Exemple : SAP

Caractère 28

Suivi des stocks des produits finis en transit des bons de transfert et/ou de livraison

1 Des bons de transfert (valeur par défaut)

2 Des bons de livraison

3 Des bons de transfert et de livraison

L'option -Ost doit être activée.

Caractère 29

SPECIFIQUE

Cumuler le poids de plusieurs composants de nomenclature dans le poids total brutselon le complément de requête SUP_REQ_CONSO (O/N, N par défaut)

Notes triées

AFF_MSG_PROV_AVIEXP

21,60 Message à afficher lors de l'édition provisoire d'un BL AVIEXP

500 caractères maximum, le passage à la ligne peut-être paramétré par le code /n)

Exemple :

Attention : Client de type AVIEXP /n

Obligation de remettre au chauffeur un bon de livraison Galia

Voir option Odi et code E pour la zone alpha 1 du TSC TRS.

CONF_VOLUEDIT_ETIQ

21,26 Type et code du paramètre de lancement de l'édition des étiquettes

FIC_ITEM_LOCK

21,60 Nom du fichier lock utilisé pour transfert ITEM

FORMULE_ENTETE

SPECIFIQUE

21 à 60 Notes paramétrables sur entête d'édition - Formules de politesse

(Caractères /// pour continuer sur la ligne suivante)

FORMULE_PIED

SPECIFIQUE

21,60 Notes paramétrables sur pied d'édition - Formules de politesse

(Caractères /// pour continuer sur la ligne suivante)

IMPRIMANTE_ETIQ_PAL

21,23 Code #LP de l'imprimante utilisée pour l'impression des étiquettes GALIA

(la première imprimante sera utilisée).

INFOS_CONTREPALETTE

Lors de la création automatique de mouvement de sortie des palettes, doubler la quantité si présence d'une contre-palettisation.

Il y a présence de contre-palettisation si le code paramètre contre-palette défini par paramétrage est présent dans le TSC correspondant sur le produit livré.

21, 23 Code TSC où sont stockées les informations de contre-palettisation

Par défaut : P50

24 Zone TSC où est stockée le code paramètre de contre-palettisation

F Première zone de 3 car. (ic_char3_1)

G Zone de 30 car. (ic_char30) (par défaut)

H Deuxième zone de 3 car. (ic_char3_2)

26, 28 Code paramètre de type de coiffe correspondant à la contre-palette

Ce code est associé au type de paramètre .TC

Par défaut : CPA

LIGNE_OF_A_EDITER

SPECIFIQUE

21,26 Code client. Mettre un astérisque pour désigner tous les clients.

27,29 Point de livraison (laisser à blanc pour le client principal)

(mettre un astérisque pour tous les points de livraison

30,32 Code langue

33,57 Libellé spécifique à éditer à la place du N° d'OF

Plusieurs lignes peuvent être paramétrées.

Exemples

LIGNE_OF_A_EDITER XYZ 001

La ligne contenant l'OF et la date de fin de fabrication n'apparaîtra dans l'édition du BL, que si la livraison est destinée au client XYZ et au lieu de livraison 001.

LIGNE_OF_A_EDITER XYZ 002AN WORK NUMBER

(libellé anglais + point de livraison 002)

LIGNE_OF_A_EDITER XYE * ES NUMERO DE FABRICACION

(libellé espagnol et tous les points de livraison)

N

SPECIFIQUE

2 Paramétrage des notes à éditer

1 Note entête BL

2 Note article

3 Note ligne de commande

4 Note ligne de BL

5 Note client adresse principale

6 Note client adresse de livraison

3,59 Types de notes (19 X 3 caractères)

NOTE_SUR_UV

21, 40 Nom de la note paramétrée sur le code unité de vente pour retrouver les unités de quantité et de poids correspondantes du client

SPECIFIQUE GALIA

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table blv3. Obligatoire. Exemple : TEX

PAR_CONF_TARIF_TYC

Vérification du prix de vente avant la validation définitive des BL

21,23 Type de commande

25,30 Type et code du paramètre de configuration des tarifs à associer au TYC.

Par défaut #CF TAR

PGM_RUN_PROG_CLI

Permet d'avoir un enchaînement spécifique à un client livré.

L'option Oep doit être positionnée.

Pour un enchaînement standard, remplacez cette note par alpha2[30,35].

21,26 Code client

27,29 Adresse livraison (ou * pour toutes les adresses secondaires)

30,35 Type et code du programme lancé (enchaînement)

RECOPIE_BL

Recopie du BL vers une autre société lors de l'édition définitive

21,23 Code société destinataire

26,29 Numéro de compteur (par défaut : null)

32 Numérotation annuelle des BL

L'option Ocb doit être positionnée, et le TSC 60E doit être paramétré.

S

2,60 Complément de requête sur blv1

_SUP_ORDER_BY_ENT

21,60 Complément d'order by (tri) sur entête de bon de livraison

Ex : b1_cli, b1_trans

_SUP_ORDER_BY_LIG

21,60 Complément d'order by (tri) sur ligne de bon de livraison et/ou ligne de commande

Ex : lc_prod, b2_lig

_SUPREQACC

SPECIFIQUE

21,60 Supplément de requête sur la table mat

_SUP_REQ_CDE4_MONTE

21,60 Complément de sélection des lignes de nomenclature à éditer dans le cas de livraison d'ensemble monté

SUP_REQ_CONSO

SPECIFIQUE

21,60 Complément de requête sur mat et nom0 pour les composants de nomenclature dont on veut cumuler le poids dans le Poids total brut.

Complémentaire avec la note SUP_REQ_CONSO du #CF BLV.

Voir aussi A3[29]

_SUP_REQ_ED_ETIQU

21,60 Complément de requête (sur la table etiqprod) à appliquer dans le décompte

A utiliser avec la note _TYP_REQ_ED_ETIQU

SUP_REQ_PAL

Spécifique

21,60 Complément de requête sur mat ou nom0 pour la recherche du poids de palettisation

Ce complément de requête existe aussi sur le #CF BLV. Il n'y a pas de priorité, les 2 compléments peuvent être utilisés et se compléter mutuellement.

Voir aussi A3[29]

_SUP_SQL_STK0_PICK

Complément de sélection sur la table des stocks (stk0) pour la recherche des mouvements de picking de palettes.

La requête de base vérifie déjà les zones suivantes :

s0_soc = 'sss'

s0_affect = 'BL No. nnnnnnnn Ligne : lll'

s0_es = 'S'

s0_anu = 'N'

Lors de l'édition définitive d'un BL, permettre de stocker les pickings de palettes effectués sur les lignes de commandes livrées.

Remarques :

• Ce fonctionnement nécessite l'option payante LIV/9.

• Lors d'une réédition définitive, le stockage n'est effectué que si aucune ligne de picking n'a été enregistrée pour la ligne de BL courante.

• Cette table sera exploitable via un programme de visualisation dédié, le calcul du prix de revient et le batch de réactualisation du récapitulatif des coûts.

TI

SPECIFIQUE

3,60 Texte d'introduction du BL

100 notes maximum peuvent être saisies.

TYPE_NOTE_BLV_LIG

SPECIFIQUE

21,60 Types de notes sur ligne de bon de livraison

TYPE_NOTE_BLV3

SPECIFIQUE

21,60 Types de notes sur entête de bon de livraison à éditer

TYPE_NOTE_BLV3_LIG

SPECIFIQUE

21,60 Types de notes sur ligne de bon de livraison à éditer

TYPE_NOTE_CDE3

SPECIFIQUE

21,60 Types de notes sur entête de commande à éditer

TYPE_NOTE_CDE3_LIG

SPECIFIQUE

21,60 Types de notes sur ligne de commande à éditer

TYPE_NOTE_CDE_LIG

SPECIFIQUE

21,60 Types de notes sur ligne de commande.

TYPE_NOTE_CLI3_ADL

SPECIFIQUE

21,60 Types de notes sur adresse de livraison du client à éditer

TYPE_NOTE_CLI3_SIT

SPECIFIQUETableau de bord du multisite

21,60 Types de notes sur adresse secondaire ou principale sur site de production à éditer

TYPE_NOTE_DEVIS

SPECIFIQUE

21,60 Types de notes sur devis

TYPE_NOTE_E_BLV_ENT

SPECIFIQUE

21,60 Types de notes sur entête de bon de livraison

A éditer dans la partie entête du corps

TYPE_NOTE_E_CDE_ENT

SPECIFIQUE

21,60 Types de notes sur entête de commande

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI

SPECIFIQUE

21,60 Types de notes sur adresse principale du client

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI_ADF

SPECIFIQUE

21,60 Types de notes sur adresse de facturation du client

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI_ADL

SPECIFIQUE

21,60 Types de notes sur adresse de livraison du client

A éditer dans la partie entête du corps

TYPE_NOTE_MAT

SPECIFIQUE

21,60 Types de notes sur article

TYPE_NOTE_MAT3

SPECIFIQUE

21,60 Types de notes sur article à éditer

TYPE_NOTE_P_BLV_ENT

SPECIFIQUE

21,60 Types de notes sur entête de bon de livraison

A éditer dans la partie pied du corps

TYPE_NOTE_P_CDE_ENT

SPECIFIQUE

21,60 Types de notes sur entête de commande

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI

SPECIFIQUE

21,60 Types de notes sur adresse principale du client

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADF

SPECIFIQUE

21,60 Types de notes sur adresse de facturation du client

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADL

SPECIFIQUE

21,60 Types de notes sur adresse de livraison du client

A éditer dans la partie pied du corps

TYPE_POIDS_EDITE_BL

Spécifique

21 Type de poids édité de l'entête du BL

1 Poids total (Valeur par défaut)

2 Poids total brut transporté

_TYP_REQ_ED_ETIQU

21 Type de décompte réalisé

0 On compte le nombre d'étiquettes éditées (etp_date_edition is not null), et on propose l'édition des étiquettes si on n'en trouve aucune.

1 On compte le nombre d'étiquettes non éditées (etp_date_edition is null), et on propose l'édition des étiquettes si on en trouve au moins une.

A utiliser avec la note _SUP_REQ_ED_ETIQU

VALID_FAXMAIL_EDIT

VALID_FAXMAIL_REEDIT

VALID_FAXMAIL_VALID

Voir les notes dédiées au Fax/Mail.

Paramètres associés

#ED BL1 | Les notes servent à saisir un message général qui sera édité sur les BL (2 premières lignes)
TSC BLD | Non édition des lignes de détail palette pour les bons de livraison de type FB2, sur certains clients.
TSC TRS | Temps de transport
UNI | Note dont le nom est paramétré dans les notes commençant par NOTE_SUR_UV


Edition du journal des livraisons

Edition du journal des livraisons jbl

NON VISIBLE DANS VOLUAIDE

Options triées

-Oam | L'adresse du magasin, si elles existe, se substitue à l'adresse de livraison.
-Ocs | Calcul de la surface même si les TSC ne sont pas renseignés
-Odf | Edition du détail des frais
-Oed | Edition de toutes les lignes de BL
-Ofr | Edition d'un tableau des frais
-Ol0 | Pas d'édition des lignes à 0
-Omd | Calcul des montants dans la devise de l'entête de commande
-Osa | Avec gestion des appairages
-Osd | Edition des quantités sans décimales.
-Osl | Saut d'une ligne après chaque BL.
-Osn | Si -Osu : la surface par défaut est la surface brute. Ce paramétrage permet d'utiliser la surface nette.
-Ost | Supprime la ligne de totalisation par rupture
-Osu | Surface issue de TSC sur le PF
-Otf | Edition du total des frais d'expédition par catégorie de frais
-Ov1 | Pas de valorisation des BL
-Ov2 | Pas de valorisation des BL de consignation
-Ov3 | Valorisation uniquement des BL de consignation

Valeur numérique 1

Ordre de tri. Par défaut : 1

1 Tri par client avec total client

2 Tri par jour avec total jour

3 Tri par client et numéro de commande

4 Tri par numéro de bon de livraison

5 Tri par famille, sous-famille

6 Tri par représentant, client et numéro de commande

7 Tri par magasin de stockage

Valeur alpha 2

Paramétrage des colonnes de l'édition (AEFGLMPU par défaut)

A | Code Client
B | Nom du Client
C | Sans appairages (option –Osa absente) : N° de cde et N° de ligne de cde. Avec appairages (option –Osa présente) : N° de Commande, N° de ligne de cde et séquence de la ligne de cde
D | Quantité Commandée
E | Référence Commande
F | Numéro de BL et numéro Ligne de BL
G | Date
H | Code Transporteur
I | Nom du Transporteur
J | Poids Total
K | Nombre total de Colis (entête de BL)
L | Code Produit
M | Quantité à facturer saisie sur la ligne de BL (Hors appairage)
N | Poids de la ligne de BL
O | Nb de colis de la ligne BL
P | Numéro de Facture
Q | Montant total du BL (avec totalisation)
R | Zone Commentaire du BL
S | Code Postal de l'adresse de livraison
T | Ville de l'adresse de livraison
U | Zone de 34 caractères blancs.
V | Quantité livrée
W | Prix unitaire
X | Unité de vente
Y | Libellé produit
Z | Valeur (avec totalisation) (Valeur = P.U. x Quantité livrée / Unité de vente)
a | Référence du BL
b | Cumul quantité livrée
c | Titre de l'ouvrage (ec_texte)
d | Type mouvement de stock
e | Libellé court du type mouvement de stock
f | Libellé long du type mouvement de stock
g | Port hors taxe (entête BL)
h | Edition de notes. En alpha4[1,3], on indiquera le type de note. alpha4[4] indique s'il faut aller chercher les notes sur les commandes ou sur les BL.
i | Prix client de la commande
j | Valeur avec prix client (avec totalisation) (Valeur = Prix client x Quantité livrée / Unité de vente)
k | Longueur ligne de commande
l | Largeur ligne de commande
m | Hauteur ligne de commande
n | Famille de la ligne de commande
o | Sous-famille de la ligne de commande
p | Libellé court de la famille
q | Libellé court de la sous-famille
r | Prix unitaire net. Il s'agit du prix unitaire avec déduction des remises et de l'escompte.
s | Valeur nette (avec totalisation) Il s'agit de la colonne Z avec déduction des remises et de l'escompte.
t | Quantité restant à livrer. C'est la quantité commandée a laquelle on soustrait la somme des quantités déjà livrées sur cette ligne de commande.
u | Surface livrée
v | Colonne vide (utile pour une édition avec uniquement les cumuls)
w | Code mode de transport
x | Libellé court du mode de transport
y | Libellé long du mode de transport
z | Date de livraison souhaitée de la ligne de commande
0 | Date de livraison proposée de la ligne de commande
1 | Numéro de groupage
2 | Date de chargement
3 | Quantité réellement facturée
4 | Quantité restante à facturer (colonne M - colonne 3)
5 | Code Tolérance de livraison de la ligne de commande
6 | Libelle court du code tolérance de livraison
7 | Prix de vente du plus de la ligne de commande
8 | Prix de vente du moins de la ligne de commande
9 | Unité de vente du plus ou du moins
* | Libellé de la ligne de commande
+ | Ligne de commande soldée (O/N)
- | Quantité en plus ou mois calculée comme suit : Si la ligne de commande est soldée uniquement : Quantité = Quantité commandée - somme des quantités livrées
. | Variation entre la quantité commandée et la quantité livrée en %
? | Type de port de la commande
> | Code tournée
< | Libelle court du code tournée
: | Code centre dominant de la ligne de commande
; | Libellé court du centre dominant
( | Somme des frais d'expédition
) | Code représentant de la fiche client
[ | Code du transitaire
] | Nom du transitaire
@ | Code du magasin (entête de BL)
& | Type de livraison
_ | Adresse 1 de livraison
% | Adresse 2 de livraison
$ | Libellé court du magasin de stockage
# | Libellé long du magasin de stockage
{ | Poids restant à facturer
} | Montant restant à facturer
! | Code devise
= | Code type de véhicule
/ | Libellé court type de véhicule
, | Libellé long type de véhicule (c'est une virgule)
' | Code représentant de la commande (c'est une apostrophe)

Valeur alpha 3

Titre de l'état

Valeur alpha 4

Caractères 1 à 3 | Type de note (voir colonne h en alpha2)
Caractère 4 | Provenance des notes (voir colonne h en alpha2) B Bon de livraison (par défaut) C Commande
Caractères 5 à 60 | Liste des colonnes pour l'édition des frais d'expédition. ABCDEFG par défaut. A Code Frais B Libellé C Montant Hors Marge D % Marge E Montant margé F Code et taux de TVA G Numéro de facture

Note : Pour la ligne totaux des frais, voir le paramètre #CF FEX pour le paramétrage de l'intitulé (alpha 1, 2, 3)

Notes sur le paramètre de lancement

S

Complément de sélection

(la liste des tables accessibles dépend du paramétrage)


Edition des bordereaux d'expédition

Edition des bordereaux d'expédition ebexp

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bordereau d'expédition

Exemple : -N[b1_no_groupage]

Options

-Obt

Activation de l'édition des bordereaux transporteurs
Permet l'édition de bordereaux par transporteur à la place de bordereaux d'expéditions par numéro de groupage.
Ces bordereaux transporteurs contiennent tous les BL à livrer pour un transporteur donné.

Notes

S

2 à 60 Complément de sélection des BL


v_jbl Visualisation du journal des bons de livraison

Indicateurs de rentabilité

Options

-C

Type de notes sur bon de livraison et commande à éditer (Paramétrage standard des types de notes).

N.B. : Il n'est pas nécessaire de répéter les types de notes s'ils sont identiques entre notes sur bon de livraison et notes sur commandes

Oaf

Activation de la touche de bascule de la ligne de BL à l'état non facturable ou facturable sur un BL définitif (F13)

La ligne du bon de livraison peut être basculée par la touche F13 :

- à l'état non facturable si celle-ci est facturable

- à l'état facturable si celle-ci a été basculée à l'état non facturable au préalable

La bascule est possible si le bon de livraison est édité en définitif et non facturé totalement ou partiellement.

Pensez à autoriser la touche F13 dans alpha4[13].

Sujet à permission : action TOU, LIG_BL_FACT

Obr

Permet de basculer en visu des bons de retours

Oet

Edition des types de notes ainsi que leurs libellés associés à chaque rupture de type

Oh1

Rechercher systématiquement l'historique de prix de revient sur la première ligne de commande

Permet l'accès aux zones de l'historique du prix de revient (hist_pr).

IMPORTANT : Le type d'enregistrement de l'historique de prix de revient est obligatoire, il doit être précisé avant le nom de la colonne à visualiser (A-hp_cde, X-hp_z1, etc.)

Oir

Inhibition du rafraîchissement

Suite à une édition, lorsque l'on revient sur l'écran de visu, un rafraîchissement est programmé automatiquement.

On peut maintenant inhiber ce rafraîchissement par cette option.

Olf

Mise à jour de la quantité livrée facturable dans le F13 de la visualisation des lignes de BL

L'option Oaf doit être activée.

Explication :

La touche F13 permet de basculer une ligne de BL à l'état non facturable ou facturable sur un BL définitif.

Si cette option n'est pas activée, seule la quantité à facturer de la ligne de commande sera mise à jour dans le F13 de la visualisation des lignes de BL.

Si cette option est activée, la quantité à facturer et la quantité livrée facturable de la ligne de commande seront mises à jour dans le F13 de la visualisation des lignes de BL.

Omt

Sur la période donnée on recherche les BL, avec colonne Bon de retour et aussi les BR validés à cette période.

Opb

Période de sélection de BL et BR

Lorsque l'on fait une sélection sur une période donnée, le système retourne tous les BL et les BR correspondant à cette période. Cette option permet de sélectionner les BR correspondant à la période demandée (BR rattachés à des BL hors période). A2[32] = O

Ori

Permet de répéter les informations communes entre 2 lignes consécutives.

Sans cette option, lorsqu'une de ces données se répète d'une ligne sur la suivante, la colonne est laissée vide pour faciliter la visualisation des changements.

Otm

En visualisation, s'il l'on n'a qu'une ligne de totalisation, ne pas afficher les totalisations après les ruptures si elles ne portent que sur une seule ligne.

Oxd

Cacher le cadre détails

Oxs

Ne pas passer par l'écran de sélection

Valeur alpha 2

Caractère 1 | Second écran de sélection (critères de sélection portant sur mat) (O/N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractère 14 | Edition en mode condensé (O/N, O par défaut)
Caractère 31 | O 1 ligne par ligne de BL N 1 ligne par BL
Caractère 32 | Lien avec les tables bon_retour_cli_1 et bon_retour_cli_2 (O/N, N par défaut)
Caractère 33 | Lien avec la table groupage_bl (O/N, N par défaut) - GENERO
Caractère 34 | L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E
Caractères 35 à 37 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
Caractères 38 à 41 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 42 | Type de visualisation
Caractère 43 | Edition d'un libellé Observations entre les lignes (O/N, N par défaut)
Caractère 44 | Edition des notes d'entête de bon de livraison (O/N, N par défaut)
Caractère 45 | Edition des notes de lignes de bon de livraison (O/N, N par défaut)
Caractère 46 | Edition des notes d'entête de commandes (O/N, N par défaut)
Caractère 47 | Edition des notes de lignes de commandes (O/N, N par défaut)
Caractère 48 | Type de recherche du code article par F7 1 Recherche Normale (désignation, famille, etc ...) (par défaut) 2 Recherche sur les données techniques 3 Recherche spécifique papier Q Recherche par composition carton (qualité) T Recherche Transformateur

Valeur alpha 3

Titre de la visualisation

VISUALISATION DU JOURNAL DES LIVRAISONS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 13 | Autorisation de la touche de fonction F13 pour bascule de la ligne de BL à l'état non facturable ou facturable sur un BL définitif. Voir option -Oaf
Caractère 16 | Edition des BL en provisoire Active les notes PARAM_LCT_EDIT_BLP PARAM_LCT_REEDIT_BLP
Caractère 17 | Edition des BL en définitif Active les notes PARAM_LCT_EDIT_BLD PARAM_LCT_REEDIT_BLD
Caractère 20 | Accès aux informations complémentaires de l'entête du BL N ou [espace] Pas d'accès O Accès en visualisation M Accès en modification Entête de bon de livraison TSC_B1_NU_XXX_Y XXX correspond au code du TSC Y correspond au code de la zone du TSC (A à H)
Caractère 21 | Accès aux informations complémentaires de la ligne du BL N ou [espace] Pas d'accès O Accès en visualisation M Accès en modification Ligne de bon de livraison TSC_B2_NU_XXX_Y XXX correspond au code du TSC Y correspond au code de la zone du TSC (A à H)
Caractère 38 | Touche CONTROL-C autorisée (O/N) Calculatrice
Caractère 51 | Touche CONTROL-T autorisée (O/N) Visualisation des touches
Caractère 56 | Touche CONTROL-Z autorisée (O/N) Lancement de programmes

Notes triées

CLIENT_NOMENCLATURE

21 à 26 Référence client (#SOC par défaut)

EDITION_SANS_VALEUR

21 Edition du journal des livraisons même si aucun enregistrement n'est trouvé (O/N)

Si cette note n'est pas trouvée ici, elle sera recherchée sur #CF/ATL.

FIN_FIC_1_T_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

LARGEUR_CAMION

21 à 24 Largeur du camion en mm.

Au niveau de chaque ligne de BL, il est possible de paramétrer une colonne indiquant le nombre de mètres linéaires plancher représentés par la livraison.

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

LIBELLE_SIT_PROD

Texte du libellé Site production

Par défaut : libellé long du par01 du type de paramètre SIT

Tableau de bord du multisite

LIEU2_A_EXCLURE_DSOL

21 à 23 Code du lieu à exclure du lieu2 du mouvement de stock de référence.

La chaîne de caractère ainsi résultante sera concaténée au lieu 2 paramétré dans la note REAFFECT_NVE_VEN.

Nécessite l'option Ors dans la saisie des BL.

LIEU2_A_EXCLURE_REAF

21 à 23 Code du lieu à exclure du lieu2 du mouvement de stock de référence.

La chaîne de caractère ainsi résultante sera concaténée au lieu 2 paramétré dans la note REAFFECT_VEN_NVE.

Nécessite l'option Ors dans la saisie des BL.

MAJ_FLAG_INFO_C

Voir page dédiée

PARAM_CONSULT

21,26 Type et code du paramètre de lancement du programme de qualité carton en mode consultation (#SA QUA par défaut).

Cette note est accessible dans tous les programmes exploitant la fonction f_visu_nomenclature : cde, blv, v_cdem, v_jbl

PARAM_LCT_EDIT_BLD

21,26 Type et code du paramètre de lancement de l'édition des BL définitifs

A4[16 et 17] doivent être à O pour autoriser cette action.

PARAM_LCT_EDIT_BLP

21,26 Type et code du paramètre de lancement de l'édition des BL provisoires

A4[16 et 17] doivent être à O pour autoriser cette action.

PARAM_LCT_REEDIT_BLD

21,26 Type et code du paramètre de lancement de la réédition des BL définitifs

A4[16 et 17] doivent être à O pour autoriser cette action.

PARAM_LCT_REEDIT_BLP

21,26 Type et code du paramètre de lancement de la réédition des BL provisoire

A4[16 et 17] doivent être à O pour autoriser cette action.

QUALITE_CARTON

21 Référence qualité (Q par défaut)

REAFFECT_ETAT

21 Code état des mouvements générés (N ou 2, N par défaut)

Nécessite l'option Ors dans la saisie des BL.

REAFFECT_NVE_VEN

Paramétrage des mouvements générés au DESOLDE

21 à 23 Type du mouvement de sortie (SN par défaut)

24 à 26 Type du mouvement d'entrée (EN par défaut)

27 à 29 Lieu de rangement 1 en entrée (USI par défaut)

30 à 35 Lieu de rangement 2 en entrée (NVE par défaut)

Nécessite l'option Ors dans la saisie des BL.

REAFFECT_VEN_NVE

Paramétrage des mouvements générés au SOLDE

21 à 23 Type du mouvement de sortie (SN par défaut)

24 à 26 Type du mouvement d'entrée (EN par défaut)

27 à 29 Lieu de rangement 1 en entrée (USI par défaut)

30 à 35 Lieu de rangement 2 en entrée (NVE par défaut)

Nécessite l'option Ors dans la saisie des BL.

SEP_VISU_TYPE_F_CHAR

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

_SQL_REAFFECT_NVE

21 à xx Complément de recherche des surplus de production sur stk0 pour la ré-affectation au dé-solde de la ligne de commande.

Exemple : and s0_rgt1 = "LUM" and s0_rgt2 = "NVE"

Nécessite l'option Ors dans la saisie des BL.

_SQL_REAFFECT_VEN

21 à xx Complément de recherche des surplus de production sur stk0 pour la ré-affectation au solde de la ligne de commande.

Exemple : and s0_rgt1 = "LUM" and s0_rgt2 = "VEN"

Nécessite l'option Ors dans la saisie des BL.

TEXT_LIBRE_1_V_T_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

TITRE_VISU_TYPE_F

Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

Indicateurs de rentabilité

Tri 27

Option Oh1

A2[3] = O

A2[42] = S

Zones de l'historique du prix de revient

Notes de paramétrage pour le tableau de bord des indicateurs de rentabilité

S and ec_tyc = ec_tyc | Prise en compte de la table des lignes de commandes (cde2)
_VAR_a mtt_livre2_dev | Définition des variables de calcul
_VAR_b N-hp_z4
_VAR_c N-hp_z5
_VAR_d N-hp_z6
_VAR_e N-hp_z7
_VAR_f N-hp_z8
_VAR_g surf_nette_ligne
_VAR_h b2_qteliv
_VAR_j poids_net_ligne
_CALC_01 bc+ | Définition des formules de calcul
_CALC_02 bc+d+
_CALC_03 abc+-
_CALC_04 abc+-d-e-f-
_CALC_05 abc+-d-e-f-1000*g/
O27 1**N*N*** | Tri sur l'origine du client (cli.cl_orig)
O01 2**U*N*** | Tri sur le code client (cli.cl_code), en mode de cumul U (regroupement des lignes de commandes par code client, avec affichage des valeurs dans les colonnes de la visualisation)
E Region*libc_cl_orig *9**N*N* | Définition des colonnes à visualiser/éditer
E CLI*cl_code*6**N*N*
E Raison sociale*cl_nom*30**N*N*
E Agent*libl_cl_repr*20**N*N*
E MT HT* mtt_livre2_dev*12*--------&.&&*O*N*
E POIDS* poids_net_ligne*12*--------&.&&*O*N*
E SURFACE* surf_nette_ligne*12*--------&.&&*O*N*
E Matiere*CALC_01*12*--------&&&&*O*N*
E Conversion*N-hp_z6*12*--------&&&&*O*N*
E C.Direct*CALC_02*12*--------&&&&*O*N*
E C.Distrub*N-hp_z7*12*--------&&&&*O*N*
E C.Palettes*N-hp_z8*12*--------&&&&*O*N*
E DeltaP MAT*CALC_03*12*--------&&&&*O*N*
E Contribution*CALC_04*12*--------&&&&*O*N*
D N Commande:*lc_num*8** | Définition des colonnes de détail pour la visualisation
D -*lc_lig*3*<<&*
D N BL: *b2_blv*8**
D -*b2_lig*3*<<&*
D Ref cde Clt:*ec_ref*15**
D Date Cde:*ec_datc*10*dd/mm/yyyy*
F Origine*libl_cl_orig*12*** | Définition des colonnes à éditer dans un fichier
F Agn*cl_repr*3****
F NomAgn*libl_cl_repr*15***
F CLI*b1_cli*5*****
F Raison*cl_nom*30***
F MT HT*mtt_livre2_dev*12*--------&.&&*O**
F MT TTC*mtt_livre2_dev*12*--------&.&&*O**
F QTE*b2_qteliv*10*------&.&&*O**
F POIDS*poids_net_ligne*10*------&.&&*O**
F SURFACE*surf_nette_ligne*10*------&.&&*O*
F Matiere*CALC_01*12*--------&.&&*O*
F Conversion*N-hp_z6*12*--------&.&&*O*
F C.Direct*CALC_02*12*--------&.&&*O*
F C.Distrub*N-hp_z7*12*--------&.&&*O*N*
F C.Palettes*N-hp_z8*12*--------&.&&*O*N*
F DeltaP MAT*CALC_03*12*--------&.&&*O*
F Contribution*CALC_04*12*--------&.&&*O*
F Cont/1000m² *CALC_05*12*--------&.&&*O*
F Date*ec_datc*8*dd/mm/yy***
F N° BL*b2_blv*8***
F Lig*b2_lig*4*###&*N*N*
F N° CDE*ec_num*8***
F Lig*lc_lig*4*###&*N*N*
F Référence*lc_prod*10***
F Désignation*lc_lib*40**
F Long*mp_lon*6*-----&*O**
F Larg*mp_lar*6*-----&*O**
F Haut*mp_hau*6*-----&*O**
F Code Famille*mp_fam*3***
F Famille*libl_mp_fam*30***
F Code ss Fam.*mp_sfm*3***
F ss Famille*libl_mp_sfm*30***
F Code CS1*mp_cs1*3***
F Lib.CS1*libl_mp_cs1*30***
F Code Secteur*mp_cs2*3***
F Secteur*libl_mp_cs2*30***
F Code ss Sect*mp_cs3*3***
F ss Secteur*libl_mp_cs3*30***
F Code CS4*mp_cs4*3***
F Code IP*libc_mp_cs4*10***
F Lib.CS4*libl_mp_cs4*30***
F Suiv*cl_suiv*3***
F NomSuiv*libl_cl_suiv*30***
F Type*ec_tyc*3***

Ordres de tri

Voir les notes commençant par O

1 | code_cli | code client
2 | date_blv | date du BL
3 | num_blv | numéro du BL
4 | num_cde | numéro de commande
5 | code_fam | famille
6 | code_sfm | sous-famille
7 | code_art | code article
8 | code_rep | code représentant
9 | code_mag | code magasin
10 | code_tad | type d'adresse
11 | code_rgt | lieu rgt1
12 | code_dch | date de chargement
13 | code_spr | site de production
14 | code_tpt | type de port
15 | code_mtp | mode de transport
16 | code_ngr | numéro de groupage
17 | code_tra | transitaire
18 | code_ctp | code transporteur
19 | code_tve | type de véhicule
20 | code_veh | véhicule
21 | code_cop | code postal de livraison
22 | code_vil | ville de livraison
23 | code_pay | pays de livraison
24 | num_annee_mois | mois année
25 | num_annee_sem | semaine année
26 | num_annee | année
27 | cl_orig | origine du client
28 | b2_type_livraison | Type de livraison

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Les noms de zones en italiques peuvent être cumulés.

Entête bon de livraison

Ligne bon de livraison

Entête du bon de retour

Ligne du bon de retour

Entête commande

Ligne commande

Nomenclature ligne de commande

Parties communes à cde et cde4

Fiche tiers

Package adresses secondaires

Matières

Libellés étrangers - libellés spécifiques

Cadencement de livraison prévisionnels : toutes les zones

Autres zones

Adresse de livraison du lieu intermédiaire de l'entête du bon de livraison

Groupages BL

Cadencements de livraison

Historique du prix de revient

Entête bon de livraison

b1_soc | Code société
b1_blv | Numéro de bon de livraison
b1_cli | Code client
nom_b1_cli | Nom client
b1_ref | Référence du bon de livraison
b1_sitp | Code zone paramétrable
libc_b1_sitp | Libellé court code zone paramétrable
libl_b1_sitp | Libellé long code zone paramétrable
b1_tport | Type de port
libc_b1_tport | Libellé court type de port
libl_b1_tport | Libellé long type de port
b1_pht | Port taxable en devise société
b1_pht_euro | Port taxable en EURO
b1_pht_dev | Port taxable en devise
b1_tvap | Code TVA port taxable
libc_b1_tvap | Libellé court code TVA port taxable
libl_b1_tvap | Libellé long code TVA port taxable
zc1_b1_tvap | Valeur 1 code TVA port taxable
b1_trsp | Mode de transport
libc_b1_trsp | Libellé court mode de transport
libl_b1_trsp | Libellé long mode de transport
b1_trans | Code transporteur
nom_b1_trans | Nom transporteur
b1_tadr | Type d'adresse de livraison
b1_adrl | Code adresse livraison
nom_b1_adrl | Nom client de livraison
adr1_b1_adrl | Adresse 1 de livraison
adr2_b1_adrl | Adresse 2 de livraison
codp_b1_adrl | Code postal de livraison
telph1_b1_adrl | Téléphone 1 de livraison
telph2_b1_adrl | Téléphone 2 de livraison
telcop_b1_adrl | Télécopie de livraison
telex_b1_adrl | Télex de livraison
pays_b1_adrl | Code pays de livraison
libc_pays_b1_adrl | Libellé court pays de livraison
libl_pays_b1_adrl | Libellé long pays de livraison
vil_b1_adrl | Ville adresse livraison
b1_datl | Date bon de livraison
b1_adrf | Code adresse facturation
codp_b1_adrf | Code postal adresse de facturation
vil_b1_adrf | Ville adresse facturation
b1_col | Nombre de colis total
b1_poids | Poids total
b1_montant | Coût en devise société
b1_montant_euro | Coût en EURO
b1_montant_dev | Coût en devise
b1_com | Observation
b1_edit libc_b1_edit | Bon de livraison édité (O/P/N) Libellé de l'indicateur O Définitif P Provisoire N Non édité (par défaut, si b1_edit n'est pas renseigné)
b1_embal | Type d'emballage
b1_cembal | Coût emballage en devise société
b1_cembal_euro | Coût emballage en EURO
b1_cembal_dev | Coût emballage en devise
b1_tvae | Code TVA emballage
libc_b1_tvae | Libellé court code TVA emballage
libl_b1_tvae | Libellé long code TVA emballage
zc1_b1_tvae | Valeur 1 code TVA emballage
b1_type_vehicule | Type de véhicule
libc_b1_type_vehicule | Libellé court type de véhicule
libl_b1_type_vehicule | Libellé long type de véhicule
b1_vehicule | Véhicule (Immatriculation)
b1_heure_depart | Heure de départ
b1_no_groupage | Numéro groupage
b1_date_chargem | Date de chargement
b1_lieu_rgt1 | Magasin destination
libc_b1_lieu_rgt1 | Libellé court magasin destination
libl_b1_lieu_rgt1 | Libellé long magasin destination
b1_ordre_chargt | Ordre de chargement
b1_devise | Code devise
libc_b1_devise | Libellé court code devise
libl_b1_devise | Libellé long code devise
b1_annu | Bon de livraison annulé
b1_transitaire | Code transitaire
nom_b1_transitaire | Nom transitaire
b1_annee_mois | Année et mois de livraison (AAAAMM)
b1_annee_sem | Année et semaine de livraison (AAAASS)
b1_annee | Année de livraison (AAAA)
b1_poids_brut_tr | Poids but transporté
b1_vehicule code_b1_vehicule libc_b1_vehicule | Libellé long du véhicule Véhicule Libellé court du véhicule
b1_tx_commission | Taux de commission de l'adresse de livraison de l'entête de bon de livraison

Ligne bon de livraison

b2_soc | Code société
b2_blv | Numéro de bon de livraison
b2_lig | Numéro de ligne de bon de livraison
b2_cde | Numéro de commande
b2_ligcde | Numéro de ligne de commande
b2_ligseq | Numéro de séquence de la ligne de commande
b2_qte | Quantité livrée facturable
b2_qteliv | Quantité livrée
b2_poids | Poids
b2_nbcolis | Nombre de colis
b2_excolis | Nombre d'exemplaires
b2_nummvt | Numéro de mouvement de stock
b2_fact | Ligne de bon de livraison facturée (O/N)
b2_solde | Ligne de commande soldée (O/N)
b2_type_livraison lib_b2_type_livraison | Type de livraison Libellé du type de livraison
b2_annu | Ligne de bon de livraison annulée
b2_ml_plancher | Mètre linéaire plancher sur le livret
b2_qteliv_non_facturee | Quantité livrée non facturée de la ligne du bon de livraison
b2_ligcad | Numéro de ligne de cadencement de livraison

Entête du bon de retour

br1_soc | Code société
br1_numero | Numéro du bon de retour
br1_client | Code client
nom_br1_client | Nom client
br1_type | Type du bon de retour (Paramètre TBR)
libc_br1_type | Libellé court du type du bon de retour
libl_br1_type | Libellé long du type du bon de retour
br1_adr_recup_liv | Code adresse où l'on récupère la livraison en retour
nom_br1_adr_recup_liv | Nom adresse
adr1_br1_adr_recup_liv | Adresse 1 de l'adresse
adr2_br1_adr_recup_liv | Adresse 2 de l'adresse
codp_br1_adr_recup_li" | Code postal de l'adresse
ville_br1_adr_recup_liv | Ville de l'adresse
pays_br1_adr_recup_liv | Pays de l'adresse (Paramètre PAY)
libc_pays_br1_adr_recup_liv | Libellé court du pays de l'adresse
libl_pays_br1_adr_recup_liv | Libellé long du pays de l'adresse
br1_statut | Statut du bon de retour
br1_reprise_edit | Demande de reprise éditée (O/N)
br1_bon_edit | Bon de retour édité (O/N)
br1_site_prod | Site de production (Paramètre SIT)
libc_br1_site_prod | Libellé court du site de production
libl_br1_site_prod | Libellé long du site de production
br1_numero_bl | Numéro du bon de livraison associé
br1_date_creation | Date de création du bon de retour
br1_date_valid | Date de validation du bon de retour
br1_transporteur | Code transporteur
nom_br1_transporteur | Nom transporteur
br1_annule | Bon de retour annulé

Ligne du bon de retour

br2_soc | Code société
br2_numero | Numéro du bon de retour
br2_ligne | Ligne du bon de retour
br2_num_cde | Numéro de commande
br2_lig_cde | Ligne de commande
br2_seq_cde | Numéro de séquence de la ligne de commande
br2_cad_cde | Numéro de ligne de cadencement de livraison
br2_motif_retour | Motif du retour (Paramètre MOR)
libc_br2_motif_retour | Libellé court du motif du retour
libl_br2_motif_retour | Libellé long du motif du retour
br2_rgt1 | Lieu de rangement 1 (Paramètre RG1)
libc_br2_rgt1 | Libellé court du lieu de rangement 1
libl_br2_rgt1 | Libellé long du lieu de rangement 1
br2_rgt2 | Lieu de rangement 2
br2_nb_palette | Nombre de palettes (cumulable)
br2_qte_palette | Quantité par palette
br2_qte_totale | Quantité totale (cumulable)
br2_avoir_a_gen | Avoir à générer (O/N)
br2_avoir_genere | Avoir généré (O/N)
br2_num_avoir | Numéro d'avoir généré
br2_lig_avoir | Numéro de ligne de l'avoir généré
br2_num_mvt_stk | Numéro du mouvement de stock
br2_annule | Ligne de bon de retour annulée
br2_num_fac_assoc | Numéro de facture associée à la ligne de commande
br2_lig_fac_assoc | Numéro de ligne de la facture associée à la ligne de commande

Entête commande

Informations des commandes de type contrat

Package de l'entête de la commande contrat associée à la ligne de commande actuelle

ajouter les préfixes ctr_ec_, des_ctr_ec_, libc_ctr_ec_, libl_ctr_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

Package de l'entête de la commande contrat associée à la ligne de commande de rattachement actuelle

ajouter les préfixes ctr_rat_ec_, des_ctr_rat_ec_, libc_ctr_rat_ec_, libl_ctr_rat_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

Package de l'entête de la commande contrat associée à la ligne de commande de marché actuelle

ajouter les préfixes ctr_marche_ec_, des_ctr_marche_ec_, libc_ctr_marche_ec_, libl_ctr_marche_ec_

suivi du nom d'un champ de la table cde1 (sans le préfixe ec_)

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
codp_ec_ade | Code postal adresse de réception
ville_ec_ada | Ville adresse réception
ec_adf | Code adresse facturation
codp_ec_adf | Code postal adresse de facturation
ville_ec_adf | Ville adresse facturation
ec_adl | Code adresse livraison
codp_ec_adl | Code postal adresse de livraison
ville_ec_adl | Ville adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_acc_euro | Acompte en EURO
ec_acc_dev | Acompte en devise
ec_pnt | Port non taxable en devise société
ec_pnt_euro | Port non taxable en EURO
ec_pnt_dev | Port non taxable en devise
ec_pht | Port taxable en devise société
ec_pht_euro | Port taxable en EURO
ec_pht_dev | Port taxable en devise
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accuse de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facture
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande
ec_tx_commission | Taux de commission de l'adresse de livraison de l'entête de commande

Ligne commande

Informations des commandes de type contrat

Package de la ligne de la commande contrat associée à la ligne de commande actuelle

ajouter les préfixes ctr_lc_, des_ctr_lc_, libc_ctr_lc_, libl_ctr_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

Package de la ligne de la commande contrat associée à la ligne de commande de rattachement actuelle

ajouter les préfixes ctr_rat_lc_, des_ctr_rat_lc_, libc_ctr_rat_lc_, libl_ctr_rat_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

Package de la ligne de la commande contrat associée à la ligne de commande de marché actuelle

ajouter les préfixes ctr_marche_lc_, des_ctr_marche_lc_, libc_ctr_marche_lc_, libl_ctr_marche_lc_

suivi du nom d'un champ de la table cde2 (sans le préfixe lc_)

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Numéro ligne commande
lc_prod | Code article
lib_lc_prod | Désignation article (Fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (Ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteliv_reelle | Quantité réellement livrée
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_prx_euro | Prix unitaire vente en EURO
lc_prx_dev | Prix unitaire vente en devise
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code TVA
libc_lc_tva | Libellé court code TVA
libl_lc_tva | Libellé long code TVA
zc1_lc_tva | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_deldep | Date de départ au plus tard
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (non utilisée)
lc_colis | Nombre colis
lc_prxcli | Prix client en devise société
lc_prxcli_euro | Prix client en EURO
lc_prxcli_dev | Prix client en devise
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
codp_lc_adl | Code postal adresse de livraison
ville_lc_adl | Ville adresse livraison
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_plus_euro | Prix unitaire vente au plus en EURO
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_prx_moins_euro | Prix unitaire vente au moins en EURO
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_prx_rvt_euro | Prix unitaire revient en EURO
lc_prx_rvt_dev | Prix unitaire revient en devise
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_prx_rvt_r_euro | Prix unitaire revient réel en EURO
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1. Fenêtre Revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_annu | Ligne commande annulée
lc_ml_plancher | Mètres linéaires plancher
lc_cs1 | Code statistique 1
lc_cs2 | Code statistique 2
lc_cs3 | Code statistique 3
lc_cs4 | Code statistique 4
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long
lc_tx_commission | Taux de commission de l'adresse de livraison de la ligne de commande
lc_num_contrat | Numéro de contrat
lc_lig_contrat | Ligne de contrat

Nomenclature ligne de commande

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Numéro ligne commande
nc_seq | Numéro de séquence
nc_prod | Code article
lib_nc_prod | Désignation article (fiche article)
nc_coef_nom | Coefficient de nomenclature
nc_qtecde | Quantité commandée
nc_qteliv | Quantité livrée
nc_qteliv_non_val | Quantité livrée non validée
nc_qteliv_val | Quantité livrée validée
nc_rgt1 | Code lieu de rangement 1
libl_nc_rgt1 | Libellé long code lieu de rangement 1
libc_nc_rgt1 | Libellé court code lieu de rangement 1
nc_rgt2 | Code lieu de rangement 2
nc_rgt3 | Code lieu de rangement 3
nc_qtefab | Quantité fabriquée
nc_rstfab | Solder la fabrication (O/N)
nc_nummvt | Numéro de mouvement en stock
nc_nummvt2 | Numéro d'entrée prévisionnelle
nc_numfbi | Numéro de Self Billing Invoice
nc_solde | Ligne soldée
nc_reap | Mode de réapprovisionnement

Parties communes à cde et cde4

bl_prod | Code article
lib_bl_prod | Désignation article (Fiche article)
bl_qtecde | Quantité commandée
bl_qteliv | Quantité livrée
bl_solde | Ligne soldée

Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

codp_cl_adra ville_cl_adra | Code postal adresse de réception Ville adresse réception
codp_cl_adrb ville_cl_adrb | Code postal adresse de livraison Ville adresse livraison
codp_cl_adrd ville_cl_adrd | Code postal adresse offres de prix Ville adresse offres de prix
codp_cl_adrf ville_cl_adrf | Code postal adresse de facturation Ville adresse facturation

Libellés étrangers libellés spécifiques

le_langue | Code langue
le_libpar1 | Code article spécifique
le_libelle | Libellé article spécifique
le_libelle2 | Libellé complémentaire article spécifique

Autres zones

Les colonnes dont le nom commence par br_ (ainsi que la colonne br2_qte_totale) sont accessibles même si A2[32] n'est pas à O.

Dans ce cas, la sémantique des colonnes reste la même mais correspond au cumul de tous les bons de retour passés sur la ligne du BL.

br_mtt_livre_dev | Bon de retour : Montant livré dans la devise
br_mtt_livre_eur | Bon de retour : Montant livré en euros
br_mtt_livre1 | Bon de retour : Montant livré
br_mtt_livre1_dev | Bon de retour : Montant livré dans la devise
br_mtt_livre1_eur | Bon de retour : Montant livré en euros
br_mtt_livre2 | Bon de retour : Montant livré proratisé
br_mtt_livre2_dev | Bon de retour : Montant livré proratisé dans la devise
br_mtt_livre2_eur | Bon de retour : Montant livré proratisé en euros
br_mtt_livre_marge_pr | Bon de retour : Montant livré marge prévisionnelle
br_mtt_livre_marge_pr_dev | Bon de retour : Montant livré marge prévisionnelle dans la devise
br_mtt_livre_marge_pr_eur | Bon de retour : Montant livré marge prévisionnelle en euros
br_mtt_livre_marge_prr | Bon de retour : Montant livré marge réelle
br_mtt_livre_marge_prr_dev | Bon de retour : Montant livré marge réelle dans la devise
br_mtt_livre_marge_prr_eur | Bon de retour : Montant livré marge réelle en euros
br_mtt_livre_pr | Bon de retour : Montant livré prix de revient prévisionnel
br_mtt_livre_pr_dev | Bon de retour : Montant livré prix de revient prévisionnel dans la devise
br_mtt_livre_pr_eur | Bon de retour : Montant livré prix de revient prévisionnel en euros
br_mtt_livre_prr | Bon de retour : Montant livré prix de revient réel
br_mtt_livre_prr_dev | Bon de retour : Montant livré prix de revient réel dans la devise
br_mtt_livre_prr_eur | Bon de retour : Montant livré prix de revient réel en euros
br_poids_brut_ligne | Bon de retour : Poids brut de la ligne
br_poids_net_ligne | Bon de retour : Poids net de la ligne
br_surf_brute_ligne | Bon de retour : Surface brute de la ligne
br_surf_nette_ligne | Bon de retour : Surface nette de la ligne
gb_volume_lig | Volume de la ligne de groupage
gb_volume_tot | Volume total du groupage
mtt_livre | Bon de livraison : Montant livré
mtt_livre_dev | Bon de livraison : Montant livré dans la devise
mtt_livre_eur | Bon de livraison : Montant livré en euro
mtt_livre1 | Bon de livraison : Montant livré par élément
mtt_livre1_dev | Bon de livraison : Montant livré par élément dans la devise
mtt_livre1_eur | Bon de livraison : Montant livré par élément en euro
mtt_livre2 | Bon de livraison : Montant livré proratisé
mtt_livre2_dev | Bon de livraison : Montant livré proratisé en devise
mtt_livre2_eur | Bon de livraison : Montant livré proratisé en euros
mtt_livre_marge_pr | Bon de livraison : Montant livré marge prévisionnelle
mtt_livre_marge_pr_dev | Bon de livraison : Montant livré marge prévisionnelle en devise
mtt_livre_marge_pr_eur | Bon de livraison : Montant livré marge prévisionnelle en euros
mtt_livre_marge_prr | Bon de livraison : Montant livré marge réelle
mtt_livre_marge_prr_dev | Bon de livraison : Montant livré marge réelle en devise
mtt_livre_marge_prr_eur | Bon de livraison : Montant livré marge réelle en euro
mtt_livre_pr | Bon de livraison : Montant livré prix de revient prévisionnel
mtt_livre_pr_dev | Bon de livraison : Montant livré prix de revient prévisionnel en devise
mtt_livre_pr_eur | Bon de livraison : Montant livré prix de revient prévisionnel en euros
mtt_livre_prr | Bon de livraison : Montant livré prix de revient réel
mtt_livre_prr_dev | Bon de livraison : Montant livré prix de revient réel en devise
mtt_livre_prr_eur | Bon de livraison : Montant livré prix de revient réel en euros
poids_brut_ligne | Bon de livraison : Poids brut de la ligne
poids_brut_total | Bon de livraison : Poids brut
poids_net_ligne | Bon de livraison : Poids net de la ligne
poids_net_total | Bon de livraison : Poids net
surf_brute_ligne | Bon de livraison : Surface brute de la ligne
surf_brute_totale | Bon de livraison : Surface brute
surf_nette_ligne | Bon de livraison : Surface nette de la ligne
surf_nette_totale | Bon de livraison : Surface nette
Facture | Numéro de la dernière facture de la ligne de BL (12 caractères)
using | Voir #VI
tmv_b2_nummvt libl_tmv_b2_nummvt libc_tmv_b2_nummvt | Code, libellés long et court du type de mouvement associé à la ligne de BL (dans b2_nummvt)
mtt_facturable | Montant facturable dans la devise société de la ligne du BL Cette valeur est nulle si la ligne du BL n'est pas facturable, et elle est calculée par rapport à la quantité facturable du BL – zone b2_qte – et non la quantité livrée du BL – zone b2_qteliv)
mtt_facturable_dev | Montant facturable dans la devise du client de la ligne du BL
mtt_facturable_eur | Montant facturable en Euro de la ligne du BL

Adresse de livraison du lieu intermédiaire de l'entête du bon de livraison

livraison_cl_code | Code tiers
livraison_cl_adrb | Code adresse livraison
livraison_cl_nom | Nom tiers
livraison_cl_adr1 | Ligne 1 adresse rue
livraison_cl_adr2 | Ligne 2 adresse rue
livraison_cl_adr3 | Ligne 3 adresse rue
livraison_cl_codp | Code postal
livraison_cl_vil | Adresse ville
livraison_cl_pays | Code pays
livraison_libc_cl_pays | Libellé court du code pays
livraison_libl_cl_pays | Libellé long du code pays
livraison_cl_telph1 | Numéro téléphone 1
livraison_cl_telph2 | Numéro téléphone 2
livraison_cl_telcop | Numéro télécopie
livraison_cl_telex | Numéro télex

Groupages BL - GENERO

Toutes les zones de la table + les zones suivantes :

nom_gb_code_client | Nom du client
nom_gb_trans | Nom du transporteur
nom_gb_adl | Nom de l'adresse de livraison
codp_gb_adl | Code postal de l'adresse de livraison
vil_gb_adl | Ville de l'adresse de livraison
pays_gb_adl | Pays de l'adresse de livraison
libc_pays_gb_adl libl_pays_gb_adl | Libellés court et long du pays de l'adresse de livraison
libc_gb_tport libl_gb_tport | Libellés court et long du type de port
libc_gb_trsp libl_gb_trsp | Libellés court et long du mode de transport
libc_gb_preparateur libl_gb_preparateur | Libellés court et long du code préparateur
lib_gb_statut | Libellé du statut
libc_gb_code_tarif libl_gb_code_tarif | Libellés court et long du code tarif
libc_gb_type_vehicule libl_gb_type_vehicule | Libellés court et long du type de véhicule
lib_gb_etat_affret | Libellé de l'état de l'affrètement
libc_gb_quai libl_gb_quai | Libellés court et long du quai affecté
libc_gb_cariste libl_gb_cariste | Libellés court et long du cariste
libc_gb_mag_depart libl_gb_mag_depart | Libellés court et long du magasin de départ
libc_gb_lieu_rgt1 libl_gb_lieu_rgt1 | Libellés court et long du lieu intermédiaire
libc_gb_devise_cout libl_gb_devise_cout | Libellés court et long de la devise du coût
lib_gb_zone_tarifaire | Libellé de la zone tarifaire livrée
libc_gb_unite_fact_cout libl_gb_unite_fact_cout | Libellés court et long de l'unité de coût facturable
libc_gb_site_prod libl_gb_site_prod | Libellés court et long du site de production
libc_gb_env_tarif libl_gb_env_tarif | Libellés court et long de l'environnement tarif

Les zones suivantes sont cumulables et utilisables dans les formules de calcul paramétrables :

gb_cout_charg_prev | Coût du chargement prévu
gb_poids_prev | Poids prévu
gb_qte_prev | Quantité prévue
gb_nb_pal_prev | Nombre de palettes prévues
gb_qte_reelle | Quantité réelle
gb_metr_lineaire | Métrage linéaire
gb_metr_reel | Métrage réel
gb_cout_reel | Coût réel
gb_qte_fact_cout | Quantité de coût facturable
gb_metr_lin_lot | Métrage linéaire du lot expédition
gb_cout_lo | Coût lot expédition
gb_km_prev | Kilométrage prévu
gb_frais_suppl | Frais supplémentaire

Cadencements de livraison

li_adr | Code adresse
li_adr1 | Adresse 1
li_adr2 | Adresse 2
li_adr_fac | Code adresse de facturation
li_annu | Ligne annulée (O/N)
li_civ_corres libc_li_civ_corres libl_li_civ_corres | Civilité du correspondant Libellé court Libellé long
li_conf char | Appel confirmation
li_cpos | Code postal
li_date_appel | Date de l'appel client
li_date_dem | Date demandée par le client
li_date_depart | Date de départ
li_date_solde | Date du solde
li_datliv | Date de livraison
li_lig | Numéro de ligne
li_lig_cad | Cadencement de livraison
li_mode_saisie | Mode de saisie des cadencements de livraison (A : ancien / N : nouveau)
li_montant | Montant de la ligne de cadencement de livraison
li_nom | Nom
li_nom_corres | Nom du correspondant
li_num | Numéro de commande
li_num_mvt | Numéro de mouvement de stock
li_num_mvt3 | Numéro de mouvement de stock entrée prévisionnelle sur lieu intermédiaire (contrat)
li_pays | Pays
li_poids | Poids
li_qte_liv_fact | Quantité livrée facturable
li_qte_liv_reel | Quantité livrée réelle
li_qteliv | Quantité commandée
li_qua libc_li_qua libl_li_qua | Qualificatif de l'appel Libellé court Libellé long
li_ref_cli | Référence de l'appel client
li_rgt libc_li_rgt libl_li_rgt | Lieu de rangement Libellé court Libellé long
li_seq | Numéro de séquence
li_solde | Solde de livraison (O/N)
li_surface | Surface de la ligne de cadencement de livraison
li_tco_corres libc_li_tco_corres libl_li_tco_corres | Titre du correspondant Libellé court Libellé long
li_tolerance_liv | Tolérance de livraison
li_transp | Code transporteur
li_tx_commission | Taux de commission de l'adresse de livraison de la ligne de cadencement de livraison de la ligne de bon de livraison (n'est pas un champ de la table cde8).
li_type |
li_type_liv | Type de livraison
li_valid_adv | Code validation administration des ventes
li_valid_log | Code validation logistique
li_valid_prod | Code validation production
li_ville | Ville

Historique du prix de revient

Toutes les zones de la table hist_pr, précédées du type d'enregistrement de l'historique de prix de revient, ainsi que les zones suivantes :

(Les zones hp_z1 à hp_z15 (zones historiques numériques) sont accessibles dans les données calculées et sont cumulables.)

lib_hp_produit Désignation article (fiche article)

nom_hp_a1 Nom tiers

nom_hp_client Nom client

les zones suivantes peuvent être précédées de libc_ pour avoir le libellé court ou libl_ pour avoir le libellé long :

hp_a1 zone historique alphanumérique 1

hp_c1 zone paramétrable

hp_cs1 du code statistique 1

hp_cs2 du code statistique 2

hp_cs3 du code statistique 3

hp_cs4 du code statistique 4

hp_dep code département

hp_fam code famille

hp_repr code représentant

hp_sfm code sous-famille

Exemples

F-hp_z1 Zone historique numérique 1 du type d'enregistrement historisé F

A-lib_hp_produit Désignation article du type d'enregistrement historisé A

X-libl_hp_fam Libellé long de la famille du type d'enregistrement historisé X


Etiquettes de colisage de commande

Etiquettes de colisage de commande etiq

Valeurs numériques

1 | Nombre d'étiquettes minimum par commande à éditer
2 | Nombre de lignes entre chaque étiquette (valeur minimum par défaut 1)

Le nombre d'étiquettes est égal au nombre de colis saisis dans le détail de la ligne de commande.

Mais si ce nombre est inférieur au nombre saisi en valeur numérique 1, la valeur est prioritaire.

Options

Opl | Ecran 2 : Saisie de 98 numéros de commande différents
Ocd | Impression en condensé
Oec | Prise en compte des cadencements de fabrications de type E (entité) <VF> Incompatible avec l'option Olc.
Olc | Prise en compte des cadencements de fabrications de type L (ligne) <VF> Incompatible avec l'option Oec.
Ops | N'édite pas les informations de la société. (Par défaut, on les édite)
Ove | Activation du mode génération enregistrement dans etiqprod pour édition VoluEdit
Oli | Mode listing
Oti | Gestion des titres multilignes
Oee | Enchaînement automatique édition VoluEdit

Valeur alpha 2

Caractères de 1 à 3

Marge de gauche (par défaut 1)

Valeur alpha 3

Caractères 1 à 3 | Code imprimante étiquettes caisses- Spécifique Par défaut : CLI
Caractères 4 à 6 | Code imprimante étiquettes palettes- Spécifique Par défaut : PAL
Caractère 7 | Code contrôle du solde de la ligne de commande ou de la séquence de la ligne de commande N ou Blanc Pas de contrôle W Warning B Bloquant

Notes

CODE_EAN128_SANS_PAR | 21 Permet de codifier la séquence avec ou sans parenthèses O sans parenthèse N avec parenthèses (par défaut)
CODE_SSCC_SANS_PAR | 21 Générer le code SSCC dans la zone etp_cab_2 sans parenthèses (O/N, N par défaut) Option payante PRO-7
CREATION_CODE_EAN128 | 21,23 Code de codification sur 3 caractères Exemple : 001 : Séquence EAN128 (400)(241)(37)
CREATION_CODE_SSCC | 21 Générer le code SSCC dans la zone etp_cab_2 (O/N, N par défaut) Option payante PRO-7
ORIGINE_ETIQUETTE | Code origine étiquette alimente le champ etp_origine_etiq (utile pour recherche rapide dans edi_etiprod)
ETIQPROD_IMP | Code imprimante pour édition VoluEdit de type #LP (code ETP par défaut) Etiquettes palette
ETIQPROD_IMP_C | Code imprimante pour édition VoluEdit de type #LP (code ETP par défaut) Etiquettes caisse
F_RCF_CADENCEMENT | 21 Recherche du cadencement de fabrication avec le numéro de ligne de commande (O/N, O par défaut) 22 Renvoie le code article au lieu de la ligne de cadencement (O/N, N par défaut)
_SUP_REQ_RECH_CDE1 | 21,60 Complément de sélection sur la table des entêtes de commande (cde1) pour la recherche par F7 (Numéro commande)
_SUP_REQ_RECH_CDE2 | Complément de sélection sur la table des lignes de commande (cde2) pour la recherche par F7 (Numéro de ligne)

Code SSCC

Serial Shipping Container Code

Récapitulatif du contenu du code SSCC

Caractère 1 | Caractère d'extension, à ce jour 0
Caractère 2 | 1er caractère du code pays (3 pour la France)
Caractères 3 à 7 ou 3 à 10 | Code CNUF (Code National Unifié Fabricant)
Caractères 8 à 17 ou 11 à 17 | Numéro séquentiel (compteur alpha X)
Caractère 18 | Clé de contrôle

La clé de contrôle est calculé comme suit :

1 somme des colonnes paires en partant de la droite

2 on multiplie le résultat par 3

3 somme des colonnes impaires en partant de la droite

4 on additionne le résultat de 2 et 3

5 On soustrait le résultat de l'étape 4 du multiple de 10 supérieur

Exemple : 03453120000000128 donne une clé de 9

1 : 11

2 : 33

3 : 18

4 : 51

5 : 9 (60 - 51)


Etiquettes de palettisation et de caisses

Etiquettes de palettisation et de caisses etiq_pal

#ED ETP | Etiquettes de palettisation
#ED ETC | Etiquettes caisses

Edition d'étiquettes grand format. Cette édition nécessite en principe une imprimante spéciale.

L'édition est traitée à ce jour en standard. Jusqu'à quand ???

(Dépendra des imprimantes utilisées mais aussi du dessin de l'étiquette)

Options

-Osp | Edition via le spool
-Oca | Edition des étiquettes caisses

Valeur alpha 2

Nom du device imprimante (ex. /dev/lp1)


Etiquettes de colisage

Etiquettes de colisage etiql

Options, valeur alpha et notes

[néant]

Sélection possible de 98 bons de livraisons

Le nombre d'étiquettes éditées par bl est déterminé par le nombre de colis saisi en entête du bl

Sur ces étiquettes s'éditent :

  • Numéro de colis

  • Adresse de livraison (saisi en entête du bl)

  • Nombre de colis

  • Poids total (saisi en entête du bl)


Edition des recommandés

Edition des recommandés edi_recom

Valeur alpha 2

Colonnes 1 à 60

Paramétrage état (FL1O par défaut) Touche F6
Origine recommandée
F = Facture, B = Bon livraison, C = Client
Type recommandé
L = Lettre, C = Colis
Taux recommandation
1=R1, 2=R2, 3=R3, 4=ETR
Avis de réception
O=Oui, N=Non

Valeur alpha 3

Titre état (EDITION RECOMMANDE par défaut)


v_tra Visualisation des coûts de transport

Options

-Otg | La composition est toujours groupable
-Ojg | La composition n'est jamais groupable

Valeur alpha 2

Options spécifiques par défaut

Caractère 14 | Edition en mode condensé (O/N, N par défaut)
Caractères 31 à 33 | Code environnement de valorisation
Caractères 34 à 41 | Numéro de demande pour la gestion de l' action de service TRANSPORTER Attention : cette offre ne doit être utilisée que pour ce traitement
Caractère 42 | [-]
Caractère 43 | Numéro d'offre pour la gestion de l' action de service TRANSPORTER
Caractères 44 à 46 | Code de l'action de service TRANSPORTER

Ordres de tris disponibles

1 | tra | CODE TRANSPORTEUR
2 | dat | DATE
3 | v | TYPE DE VEHICULE
4 | veh | IMMATRICULATION
5 | imm | HEURE DE DEPART

Listes des nom de zones autorisés

Zones lues dans une table temporaire mise à jour à partir des BL ou BT

bl_ou_bt | L si BL, T si BT
numer | Numéro de BL ou BT
c_transporteur | Code du transporteur
date_transport | Date du transport
c_type_vehicule | Code type de véhicule
vehicule | Véhicule
heure_depart | Heure de départ du véhicule
poids | Poids transporté
surface | Surface transportée
nb_palettes | Nombre de palettes
c_client_depart | Code client de départ
c_adresse_depart | Code adresse de départ
c_nom_depart | Nom du client de départ
c_adr1_depart | Adresse 1 du client de départ
c_adr2_depart | Adresse 2 du client de départ
c_pays_depart | Code pays de départ
c_postal_depart | Code postal de départ
c_vil_depart | Ville du client de départ
c_client_arrivee | Code client d'arrivée
c_adresse_arrivee | Code adresse d'arrivée
c_nom_arrivee | Nom du client d'arrivée
c_adr1_arrivee | Adresse 1 du client d'arrivée
c_adr2_arrivee | Adresse 2 du client d'arrivée
c_pays_arrivee | Code pays d'arrivée
c_postal_arrivee | Code postal d'arrivée
c_vil_arrivee | Ville du client d'arrivée
kilometrage | Kilométrage
valo | Valorisation standard (spécifique client)
c_geo | Code secteur géographique

Autres zones éditables

nom_c_transporteur | Nom du transporteur
libc_c_type_vehicule | Libellé court du type de véhicule
libl_c_type_vehicule | Libellé long du type de véhicule
libc_c_pays_depart | Libellé court du pays de départ
libl_c_pays_depart | Libellé long du pays de départ
libc_c_pays_arrivee | Libellé court du pays d'arrivée
libl_c_pays_arrivee | Libellé long du pays d'arrivée
nom_c_client_depart | Nom du client de départ
nom_c_client_arrivee | Nom du client d'arrivée
libc_c_geo | Libellé court du secteur géographique
libl_c_geo | Libellé long du secteur géographique


Gestion des bons de retour clients

TBR A1[1] = O (Demande de reprise)

TBR A1[2] = O (Génération automatique d'avoir)

TBR A1[3] = W (Saisie du BL de référence )

TBR A1[4] = W (Contrôle de l' adresse de récupération par rapport à l'adresse de livraison du BL de référence

Gestion des bons de retour clients bon_de_retour

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bon de retour

Exemple : -N[br1_numero]

Valeurs numériques

1

Compteur pour la génération de numéro de bon de retour

Options

Odl

Permet de désolder la ligne de commande sans désolder la ligne de cadencement lorsque la ligne du bon de retour porte sur une ligne de cadencement

Une confirmation de désolde de la ligne de commande est demandée à l’utilisateur si celle-ci est soldée.

Ods

Permet de désolder

la ligne

et/ou la ligne de nomenclature

et/ou la ligne de cadencement

d'une commande lors de la saisie d'une ligne de bon de retour.

Une confirmation est demandée à l'utilisateur si la ligne (ou séquence ou cadencement) en cours de saisie est soldée.

Nécessite la permission MEN – BR_CDE_LIG_D (Désolde ligne)

Odv

Accès à la saisie de la date de validation du bon de retour et utilisation de cette date pour alimenter la date des mouvements de stocks générés

Oea

Enchaînement automatique de l'édition après la validation du bon de retour

Ony

Numérotation annuelle lors de la création automatique de bons de retour.

Ouc

Gérer le détail de palettisation pour les articles gérés en lot-lieux-conditionnement (mp_param[17] = 2)

L'option 40 de la fiche société doit être activée.

Ova

Valider automatiquement le bon de retour saisi à la validation des lignes sans avoir à retourner dessus pour faire le F11

Valeur alpha 2

Caractères 1 à 6 | Type et code du paramètre de lancement de la génération automatique d'avoirs ou de la gestion des bons de retour / génération d'avoirs Voir TBR - L'article NE doit PAS être appairé. Cliquez ici pour voir le paramétrage du TBR BRE
Caractères 7 à 12 | Type et code du paramètre de lancement de lancement de l'édition des bons de retour clients
Caractères 13 à 15 | Code site de production Le type est paramétré sur le paramètre #CF BLV A1[1,3] Si rien de saisi, le type a pour valeur SIT. Tableau de bord du multisite
Caractère 16 | Type de solde pour la recherche des cadencements de livraison N cadencement non soldé (par défaut) O cadencement soldé X cadencement non soldé et soldé

Valeur alpha 3

Caractères 1 à 5

Mot de passe pour l'accès au menu Annulation

Notes

RECUP_NUM_FACTURE | 21 Récupération du numéro de facture associée à la ligne de commande saisie. N Pas de récupération du numéro de facture. W Numéro de facture optionnel dans le cas où plusieurs factures sont trouvées (si une seule facture, on l'utilise). (option par défaut) B Numéro de facture obligatoire (si une seule facture, on l'utilise) D Si plusieurs factures trouvées, on prend la dernière en date (pas d'ouverture de fenêtre). Note : Pour W et B, une fenêtre de choix s'ouvrira si plusieurs factures sont trouvées.
_SUP_ORDER_BON_RET | 21,60 Complément de tri SQL pour la recherche de bon de retour (menu Interrogation)
_SUP_REQ_BON_RET | 21,60 Complément de requête SQL pour la recherche de bon de retour (menu Interrogation)
_SUP_REQ_LIEU_RGT1 | 21,60 Liste des lieux autorisés Cette note peut être complétée par un paramétrage plus fin sur le code utilisateur.
_SUP_REQ_SITE | 21,60 Complément de requête sur le site de production Tableau de bord du multisite Exemple _SUP_REQ_SITE br1_site_prod

Paramètres nécessaires

MOR | Motif de retour de la ligne
TBR | Type de bon de retour


Gestion des bons de retour clients

Gestion des bons de retour clients bon_de_retour_avo

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères et suivants :Numéro de bon de retour

Exemple : -N[br1_numero]

Options

Oes

Ecran supplémentaire de sélection pour les bons de retour n'ayant pas généré d'avoir, à l'identique de celle qui se base sur les bons de retour ayant généré des avoirs

Omc

Génération des avoirs sur bon de retour d'une référence multi-composants

Par défaut, le module génère un avoir par ligne de bon de retour.

Cette option est automatiquement activée si la note GROUP_PAR_COMMANDE est à O (Oui).

Si la ligne de bon de retour concerne un composant d'une référence multi-composants, l'avoir sera généré même si les autres composants ne sont pas retournés ou sont retournés mais absents dans la sélection.

Si cette option est paramétrée, l'avoir sera généré si les autres composants de la référence sont retournés et présents dans la sélection.

Si la génération des avoirs concerne une ligne de bon de retour d'une référence comportant plusieurs composants, le module vérifiera que tous les composants de la nomenclature sont présents dans la sélection.

Si ce n'est pas le cas, l'avoir ne sera pas généré.

Si c'est le cas, l'avoir sera généré avec la plus grande quantité commune des composants de la nomenclature comme quantité commandée.

Un écran de visualisation des avoirs non générés sera affiché en fin de traitement.

Celui-ci affichera la liste des composants de la nomenclature manquants des lignes de bon de retour dont l'avoir n'a pas été généré.

Ony

Numérotation annuelle lors de la création automatique d'avoirs

Valeur alpha 2

1,6

Type et code du paramètre de lancement de la saisie de commande de type avoir

7,9

Type de notes à recopier lors de la génération de l'avoir (entête et ligne)

10,15

Type et code du paramètre de lancement du programme de réactualisation des indicateurs de rentabilité

Permet de générer les indicateurs de rentabilité sur la ligne d'avoir généré via le programme de réactualisation (rcp_batch_don).

Notes

COMPTEUR_TYC_

14,16 Type de commande à générer

21,22 Numéro de compteur pour la création du numéro de commande de type avoir

GROUP_PAR_COMMANDE

21 Activer le regroupement par commande (O/N, N par défaut)

Les avoirs peuvent déjà être regroupés par appairage (option Omc).

Cette note permet de générer un seul avoir par commande.

Si elle est à O (Oui), alors l'option Omc est automatiquement activée.

RECUP_NUM_FACTURE

21 Récupération du numéro de facture associée à la ligne de commande saisie, si aucune facture n'a été saisie lors de la création de la ligne de bon de retour.

N Pas de récupération du numéro de facture

W Numéro de facture optionnel dans le cas où plusieurs factures sont trouvées (si une seule facture, on l'utilise) (par défaut)

B Numéro de facture obligatoire (si une seule facture, on l'utilise)

D Si plusieurs factures trouvées, on prend la dernière en date (pas d'ouverture de fenêtre)

Note : Dans les cas W et B, une fenêtre de choix s'ouvrira si plusieurs factures sont trouvées.

_SUP_ORDER_BON_RET

21,60 Complément de tri pour la recherche de bons de retour

_SUP_REQ_BON_RET

21,60 Complément de requête pour la recherche de bons de retour

_SUP_REQ_SITE

21,60 Complément de requête le site de production - Tableau de bord du multisite

Exemple

_SUP_REQ_SITE br1_site_prod

Le type de commande à générer est paramétré sur le motif du bon de retour.

Tables concernées

bon_retour_cli_1 | Bons de retour client (entête)
bon_retour_cli_2 | Bons de retour client (lignes)


Edition des bons de retour clients

Edition des bons de retour clients bon_de_retour_edi

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bon de retour

Exemple : -N[br1_numero]

Valeur alpha 2

Caractère 1 | Edition de la zone Numéro de commande/ligne (O ou blanc/N)
Caractère 2 | Edition de la zone Libellé paramétrable (lc_p3) (O ou blanc/N)
Caractère 3 | Edition de la zone Libellé de ligne de commande (lc_lib) (O ou blanc/N)

Paramètres nécessaires

TBR

Notes commençant par #CC


Aide à la saisie des groupages

Aide à la saisie des groupages aide_saisie_groupages

Aide à la saisie des groupages des lignes de commande ou des lignes de nomenclature de ligne de commande.

Valeurs numériques

1

Numéro de compteur des groupages

Options triées

ag | Affichage automatique du groupage après la génération de celui-ci
al | Réactualisation des lots (Uniquement les informations sur le stock article)
mf | Mise à jour du flag de transfert des lignes de commande
ny | Numérotation annuelle des groupages

Valeur alpha 2

Caractères 1 à 4

Largeur du camion. Exemple : 4800. Utilisée pour calculer le mètre linéaire

Caractère 5

Flag de contrôle annulation de groupage si celui-ci a été édité

N Pas de contrôle

W Message d'avertissement

C Demande de confirmation

B Contrôle bloquant

Caractère 6

Mode de fonctionnement du module

1 Intégration, modification des lots et génération des groupages

Un seul poste peut être activé. Autorisé si le mode de fonctionnement des postes activés est différent de 1, 3 (a) et 4.

2 Consultation des lots et des groupages

Autant de postes que souhaités peuvent être activés.

Autorisé quelque soit le mode de fonctionnement des postes activés.

3 Intégration et modification des lots

Un seul poste de ce mode de fonctionnement (b) peut être activé.

Autorisé si le mode de fonctionnement des postes activés est différent de 1 et 3 (b).

4 Génération des groupages

Un seul poste avec ce mode de fonctionnement peut être activé.

Autorisé si le mode de fonctionnement des postes activés est différent de 1 et 4

NB

(a) Le contrôle est fait uniquement sur le mode de fonctionnement 3

(b) Le contrôle et le blocage est fait sur le mode de fonctionnement 3 et le type/code du paramètre de lancement.

Caractère 7

Flag d'affichage des lots groupés avec un code transporteur

N Pas d'affichage

O Affichage

Caractère 8

Flag solde des lots groupés et livrés avec une commande 99999999

N Pas de solde

O Solde

Ce flag est pris en compte dans la réactualisation des lots :

- soit après l'intégration et avant l'affichage de l'écran du détail des lots si l'option Oal est présente

- soit à l'activation de la touche F6 dans l'écran du détail des lots

Caractères 9 à 11

Code TSC du code sous-traitant de la dernière machine. Par défaut : STR

Utilisé si les colonnes code_sous_traitant et/ou nom_sous_traitant sont paramétrées.

Voir les lignes paramétrables de l'écran de détail du lot en bas de ce chapitre.

Notes

#CC | Contrôle des champs - Permet de rendre obligatoire ou non les champs transporteur et code tarif dans l'écran de détail des groupages. 5,22 Nom du champ (gb_trans et gb_code_tarif) 23 Type de contrôle (pas de contrôle / Warning / Bloquant / Interdit en saisie) 24 Traçage 25 Modifie 26 Zéro significatif 27 Zone numérique Les zones en italiques sont communes aux notes commençant par #CC mais ne sont pas utilisées ici.
LIEUX_DESTOCK_EXCLUS | 21,23 Lieu de destockage exclus - Cette note ne peut pas cohabiter avec les INCLUS
LIEUX_DESTOCK_INCLUS | 21,23 Lieu de destockage inclus - Cette note ne peut pas cohabiter avec les EXCLUS
LPL LPD | Paramétrage des lignes de l'écran des lots - 100 lignes maxi Paramétrage des lignes de l'écran du détail du lot - 100 lignes maxi Pour le détail des zones disponibles, voir les tableaux ci-dessous. Si A2[6] est différent de 3, le paramétrage des lieux de stockage est facultatif. Si A2[6] est égal à 3, le paramétrage des lieux de stockage est obligatoire. 4 Numéro de ligne paramétrable de l'écran des lots ou du détail des lots (1 à 4) 5 à 60 Paramétrage sous forme de 4 zones toutes suivies d'un astérisque : Titre zone*Nom zone*Longueur zone*Using zone* Exemples LPL1Mét lin théo :*gp_metr_lin_theo*7*---&.&&* LPD1Lg pal :*gpd_long_pal*4*---&*
NB_JOURS_AVT_DEPART | 21,23 Nombre de jours avant le départ (pour déterminer la date de présentation) Par défaut : 0. Doit être compris entre 0 et 365.
RUN_AFF_DET_ART_LOT | 21,26 Type et code du paramètre de lancement pour l'affichage du détail du stock de l'article de la ligne du lot (maj_stk). Exemple : #SACOS
RUN_EDIT_ORDRE_CHGT | 21,26 Type et code du paramètre de lancement pour l'édition des ordres de chargement. (voluedit_bon_prep) Exemple : #VEODC
SUP_REQ_CDE1 | 21,60 Supplément de requête sur les entêtes de commande (cde1)
SUP_REQ_CDE2 | 21,60 Supplément de requête sur les lignes de commande (cde2)
SUP_REQ_CDE4 | 21,60 Supplément de requête sur les lignes de nomenclature (cde4)
SUP_REQ_G_STD_D | 21,60 Supplément de requête sur les gammes standard (g_std_d)
SUP_REQ_STK0 | 21,60 Supplément de requête sur les mouvements de stock (stk0)
SUP_REQ_GROUPAGE | 21,60 Supplément de requête sur les groupages (groupage_prepa) EX : and groupage_prepa.gp_deldep < "01012000"
SUP_REQ_ORDER_BY | 21,60 Complément de tri order by Zones utilisables : temp_lot.code_dept temp_lot.vil temp_lot.nom_client temp_lot.cli temp_lot.adl temp_lot.lieu_destock Tri par défaut : temp_lot.deldep temp_lot.code_dept temp_lot.vil temp_lot.nom_client temp_lot.cli temp_lot.adl temp_lot.lieu_destock temp_lot.ind_eclatement L'indice d'éclatement (temp_lot.ind_eclatement) ne doit pas être paramétré. Il est renseigné automatiquement en fin du tri paramétré.

Paramètres nécessaires

RG1 A1[35,37] | Code de regroupement du lieu de rangement- Doit exister en tant que lieu de rangement
DEP A1[13,15] | Code de regroupement du département

Lignes paramétrables de l'écran des lots (table groupage_prepa)

Pour les notes commençant par LPL

gp_soc | Code société
gp_deldep | Date de départ
gp_cli | Code client
nom_gp_cli | Nom client de l'adresse principale
adr1_gp_cli | Adresse rue 1 de l'adresse principale
adr2_gp_cli | Adresse rue 2 de l'adresse principale
codp_gp_cli | Code postal de l'adresse principale
vil_gp_cli | Ville de l'adresse principale
pays_gp_cli | Code pays de l'adresse principale
libc_pays_gp_cli | Libellé court du code pays de l'adresse principale
libl_pays_gp_cli | Libellé long du code pays de l'adresse principale
gp_adl | Adresse de livraison
nom_gp_adl | Nom client de l'adresse de livraison
adr1_gp_adl | Adresse rue 1 de l'adresse de livraison
adr2_gp_adl | Adresse rue 2 de l'adresse de livraison
codp_gp_adl | Code postal de l'adresse de livraison
vil_gp_adl | Ville de l'adresse de livraison
pays_gp_adl | Code pays de l'adresse de livraison
libc_pays_gp_adl | Libellé court du code pays de l'adresse de livraison
libl_pays_gp_adl | Libellé long du code pays de l'adresse de livraison
gp_pays | Code pays du client livré
libc_gp_pays | Libellé court du code pays du client livré
libl_gp_pays | Libellé long du code pays du client livré
gp_code_dept | Code département du client livré
gp_vil | Ville du client livré
gp_ind_eclatement | Indice d'éclatement
gp_lieu_destock | Lieu de déstockage
libc_gp_lieu_destock | Libellé court du lieu de déstockage
libl_gp_lieu_destock | Libellé long du lieu de déstockage
gp_distance_km | Distance en kilomètres
gp_metr_lin_theo | Métrage linéaire théorique
gp_metr_lin_esti | Métrage linéaire estimé
gp_type_vehicule | Type de véhicule
libc_gp_type_vehicule | Libellé court du type de véhicule
libl_gp_type_vehicule | Libellé long du type de véhicule
gp_trsp | Code transporteur
nom_gp_trsp | Nom transporteur
gp_metrage_valid | Métrage validé
gp_statut_modif | Statut des modifications
gp_no_groupage | Numéro de groupage
gp_ind_pret | Indicateur "Prêt"
gp_edit_fiche_t | Edition fiche "T"
gp_lieu_destock_r | Lieu de déstockage réel
libc_gp_lieu_destock_r | Libellé court du lieu de déstockage réel
libl_gp_lieu_destock_r | Libellé long du lieu de déstockage réel
TSC_CL_C2_XXX_Y | TSC du client livré où XXX = Code du TSC et Y = Code zone du TSC Exemple TSC_CL_C2_215_D : Zone num 2 du TSC 215 du client livré
using | Constante dans une colonne

Lignes paramétrables de l'écran de détail du lot (table groupage_prepa_d)

Pour les notes commençant par LPD

gpd_soc | Code société
gpd_num_cde | Numéro de commande
gpd_lig_cde | Ligne de commande
gpd_seq_cde | Ligne de séquence de la ligne de commande
gpd_cli | Code client
nom_gpd_cli | Nom client de l'adresse principale
adr1_gpd_cli | Adresse rue 1 de l'adresse principale
adr2_gpd_cli | Adresse rue 2 de l'adresse principale
codp_gpd_cli | Code postal de l'adresse principale
vil_gpd_cli | Ville de l'adresse principale
pays_gpd_cli | Code pays de l'adresse principale
libc_pays_gpd_cli | Libellé court du code pays de l'adresse principale
libl_pays_gpd_cli | Libellé long du code pays de l'adresse principale
gpd_adl | Adresse de livraison
nom_gpd_adl | Nom client de l'adresse de livraison
adr1_gpd_adl | Adresse rue 1 de l'adresse de livraison
adr2_gpd_adl | Adresse rue 2 de l'adresse de livraison
codp_gpd_adl | Code postal de l'adresse de livraison
vil_gpd_adl | Ville de l'adresse de livraison
pays_gpd_adl | Code pays de l'adresse de livraison
libc_pays_gpd_adl | Libellé court du code pays de l'adresse de livraison
libl_pays_gpd_adl | Libellé long du code pays de l'adresse de livraison
gpd_deldep | Date de départ
gpd_delrep | Date de livraison
gpd_pays | Code pays du client livré
libc_gpd_pays | Libellé court du code pays du client livré
libl_gpd_pays | Libellé long du code pays du client livré
gpd_code_dept | Code département du client livré
gpd_vil | Ville du client livré
gpd_ind_eclatement | Indice d'éclatement
gpd_long_pal | Longueur palette
gpd_larg_pal | Largeur palette
gpd_haut_pal | Hauteur palette
gpd_qte_palette | Quantité par palette
gpd_qteliv | Quantité à livrer
gpd_qte_stock | Quantité en stock
gpd_metr_lin_theo | Métrage linéaire théorique en stock
gpd_nb_pal_stock | Nombre de palettes en stock
gpd_metr_lin_cde | Métrage linéaire théorique de la commande
gpd_nb_pal_cde | Nombre de palettes théoriques de la commande
gpd_nb_pal_affret | Nombre de palettes affrétées
gpd_statut_modif | Statut des modifications
gpd_der_mach_gam | Dernière machine de la gamme
libc_gpd_der_mach_gam | Libellé court de la dernière machine de la gamme
libl_gpd_der_mach_gam | Libellé long de la dernière machine de la gamme
gpd_lieu_inter | Lieu intermédiaire
libc_gpd_lieu_inter | Libellé court du lieu intermédiaire
libl_gpd_lieu_inter | Libellé long du lieu intermédiaire
gpd_lieu_destock | Lieu de déstockage
libc_gpd_lieu_destock | Libellé court du lieu de déstockage
libl_gpd_lieu_destock | Libellé long du lieu de déstockage
gpd_heur_liv_tot | Heure de livraison au plus tôt
gpd_heur_liv_tard | Heure de livraison au plus tard
gpd_tol_liv | Tolérance de livraison
libc_gpd_tol_liv | Libellé court de la tolérance de livraison
libl_gpd_tol_liv | Libellé long de la tolérance de livraison
gpd_tol_qte | Tolérance sur quantité
libc_gpd_tol_qte | Libellé court de la tolérance sur quantité
libl_gpd_tol_qte | Libellé long de la tolérance sur quantité
gpd_date_entp_mag | Date entrée prévue en magasin
gpd_heur_entp_mag | Heure entrée prévue en magasin
gpd_lieu_destock_r | Lieu de déstockage réel
libc_gpd_lieu_destock_r | Libellé court du lieu de déstockage réel
libl_gpd_lieu_destock_r | Libellé long du lieu de déstockage réel
code_article | Code article de la ligne de commande ou de la ligne de séquence de la ligne de commande
libelle_article | Libellé article de la ligne de commande ou de la ligne de séquence de la ligne de commande
numero_fbi | Numéro de la FBI de la ligne de séquence de la ligne de commande
poids_pf_a_livrer | Poids total du PF à livrer
ec_c1 | Code zone paramétrable de la commande
libc_ec_c1 | Libellé court du code zone paramétrable de la commande
libl_ec_c1 | Libellé long du code zone paramétrable de la commande
code_sous_traitant |
nom_sous_traitant |
NOTE_XXX_YYY | Note de la ligne de commande où XXX = Type de note et YYY = Numéro de ligne de note Exemple NOTE_LIV_002 : 2ème ligne de note de type LIV de la ligne de commande
using | Constante dans une colonne


Zones tarifaires et affrètements

Zones tarifaires et affrètements zones_tarif_affret

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Options

-Oaf

Saisie des zones affrètements

Par défaut, saisie des zones tarifaires

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique - Facultatif
Caractère 6 | Flag d'édition des lignes annulées - Obligatoire N Non O Oui C Fenêtre de choix

Notes

SUP_REQ_ZONES_TARAFF

21,60 Supplément de requête sur la table des zones tarifaires et affrètements

Pour l'édition des zones tarif

Paramètres associés

PAY | alpha1[16,18] - alpha1[36] alpha1[38]
#CF CLI | alpha4[1,10) - alpha4[11,13]


Grilles de pourcentage

Grilles de pourcentage grilles_pour

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Options

Opc | Le contrôle de continuité des plages des tarifs des transporteurs est désactivé.
OpC Attention au C majuscule | Contrôle toujours la continuité des plages sans forcer le point de départ à 0.

Valeur alpha 2

Caractères 1 à 5

Mot de passe pour l'annulation physique (facultatif)

Notes

SUP_REQ_GRILLES_POUR

21,60 Supplément de requête sur la table des grilles de pourcentage

Pour l'édition des grilles de pourcentage


Tarifs transporteurs

Tarifs transporteurs tarifs_transporteur

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code de tarif transporteur

Exemple : -N[tte_code_tarif]

Valeurs numériques

1 |
2 | Nombre de jours de délai pour le contrôle de la date de début de validité

Options

Ocs | Consultation des tarifs des transporteurs
Ona | Numérotation automatique des codes tarifs des transporteurs Type de compteur U
Opc | Le contrôle de continuité des plages des tarifs des transporteurs est désactivé. Par contre, le contrôle de chevauchement est toujours fait.
OpC Attention au C majuscule | Contrôle toujours la continuité des plages sans forcer le point de départ à 0.

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour l'annulation physique. Facultatif
Caractère 6 | Longueur du code tarif Obligatoire si option –Ona La longueur du code tarif doit être comprise entre 1 et 6.
Caractères 7 à 9 | Type de port par défaut (Type de paramètre POR). Obligatoire
Caractères 10 à 11 | Racine des TSC des types de véhicule. Obligatoire Egalement paramétrable dans #CF LOG A1[6,7]
Caractère 12 | Contrôle si le transporteur possède au moins un type de véhicule- Obligatoire N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant

Notes

SUP_REQ_TARIF_TRANSP

21, 60 Supplément de requête sur les tables entête et ligne des tarifs des transporteurs

Paramètres associés

TFA | Types de frais
#CF TRA | Traçabilité


Simulation de transport

Simulation de transport simul_transport

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Permet d'évaluer un transporteur.

La fenêtre d'évaluation est accessible depuis la simulation de transport.

Une fois les tarifs affichés, on peut accéder à cette fenêtre par la touche F6.

Valorisation du coût du transport.

Cette valorisation se fait par transporteur.

Les différents modes de calcul sont les suivants :

au plus cher

On calcule le coût de transport de chacun des points de déchargement pris individuellement. On retient le plus cher.

au plus loin

On calcule la distance individuelle vers chacun des points de déchargement; on retient le coût du plus éloigné.

au jalonnement

L'unité de coût du tarif doit être au km. Le coût est calculé sur la base de la distance totale en passant par l' ensemble des points de destination (du point de départ au 1er point de déchargement, puis du premier au second, ... jusqu'au dernier).

au lot (groupement de livraisons pour le même point de destination)

Le coût du transport est basé sur la somme des valorisations de chaque lot selon la distance entre le point de départ et le point d'arrivée du lot sans tenir compte du jalonnement entre les points de déchargement.

A noter : selon le mode de transport, on peut interdire la valorisation d'un transport.

Options

Ovi

Vérification de la saisie du code commune INSEE

Valeur alpha 2

1,3

Code environnement de tarif (de type ETT)

Notes

Pas de notes

Paramètres utilisés

TSC MCT | Clé = code transporteur ic_num1 = Mode de valorisation du transport pour le transporteur : 1 au plus cher 2 au plus loin 3 au jalonnement 4 au lot
UNI | alpha1[9] peut prendre les valeurs suivantes : P au poids M au mètre linéaire K au kilomètre G générique
#CF WSL | Configuration way server
TRS | alpha1[11] Valorisation du mode de transport alpha1[19,21] Code magasin de départ par défaut (de type RG1) pour tarif location


Export des tarifs transporteurs

Export des tarifs transporteurs tarif_transp_export

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Options

Ofp

Format personnalisé pour le mode batch

Valeur alpha 2

Caractères 1 à 60

Répertoire de stockage des fichiers d'export générés

Valeur alpha 3

Caractères 1 à 20 | Nom du fichier d'export (ou unload) de la table tarif_transp_ent
Caractères 21 à 40 | Nom du fichier d'export (ou unload) de la table tarif_transp_lig
Caractères 41 à 60 | Nom du fichier d'export (ou unload) de la table tarif_transp_pla

Valeur alpha 4

Caractères 1 à 20 | Nom du fichier d'export (ou unload) de la table tarif_transp_acc
Caractères 21 à 40 | Nom du fichier d'export (ou unload) de la table grilles_pour

Notes

CARACTERE_DELIMITEUR | 21 Caractère délimiteur utilisé dans les fichiers d'export
EXP_GRILLES_POUR | 21,60 Nom de la zone de la table grilles_pour * (optionnel) using (optionnel)
EXP_TARIF_TRANSP_ACC | 21,60 Nom de la zone de la table tarif_transp_acc * (optionnel) using (optionnel)
EXP_TARIF_TRANSP_ENT | 21,60 Nom de la zone de la table tarif_transp_ent * (optionnel) using (optionnel)
EXP_TARIF_TRANSP_LIG | 21,60 Nom de la zone de la table tarif_transp_lig * (optionnel) using (optionnel)
EXP_TARIF_TRANSP_PLA | 21,60 Nom de la zone de la table tarif_transp_pla * (optionnel) using (optionnel)
_NOM_FICHIER_TRACES | 21, 60 Nom du fichier trace

Exemples pour les notes commençant par EXP_

EXP_TARIF_TRANSP_ENTtte_soc

EXP_TARIF_TRANSP_ENTtte_code_tarif

EXP_TARIF_TRANSP_ENTtte_designation

EXP_TARIF_TRANSP_ENTtte_transp

EXP_TARIF_TRANSP_ENTtte_devise

EXP_TARIF_TRANSP_ENTtte_tarif_std

EXP_TARIF_TRANSP_ENTtte_code_tarif_std

EXP_TARIF_TRANSP_ENTtte_tport

EXP_TARIF_TRANSP_ENTtte_trsp

EXP_TARIF_TRANSP_ENTtte_frais_access

EXP_TARIF_TRANSP_ENTtte_env_tarif

EXP_TARIF_TRANSP_LIGttd_soc

EXP_TARIF_TRANSP_LIGttd_code_tarif

EXP_TARIF_TRANSP_LIGttd_ligne*<<<&

EXP_TARIF_TRANSP_LIGttd_date_deb_val*DD/MM/YYYY

EXP_TARIF_TRANSP_LIGttd_date_fin_val*DD/MM/YYYY

EXP_TARIF_TRANSP_LIGttd_mag_depart

EXP_TARIF_TRANSP_LIGttd_code_zone

EXP_TARIF_TRANSP_LIGttd_deb_tranche_km*<<<<<<&

EXP_TARIF_TRANSP_LIGttd_fin_tranche_km*<<<<<<&

EXP_TARIF_TRANSP_LIGttd_type_vehicule

EXP_TARIF_TRANSP_LIGttd_type_tarif

EXP_TARIF_TRANSP_LIGttd_cout*<<<<<<<&.&&

EXP_TARIF_TRANSP_LIGttd_code_uni_cout

EXP_TARIF_TRANSP_LIGttd_code_grille

EXP_TARIF_TRANSP_LIGttd_date_dern_util*DD/MM/YYYY

EXP_TARIF_TRANSP_PLAttp_soc

EXP_TARIF_TRANSP_PLAttp_code_tarif

EXP_TARIF_TRANSP_PLAttp_ligne*<<<&

EXP_TARIF_TRANSP_PLAttp_ligne_plage*<<<&

EXP_TARIF_TRANSP_PLAttp_limite_inf*<<<<<&.&&

EXP_TARIF_TRANSP_PLAttp_limite_sup*<<<<<&.&&

EXP_TARIF_TRANSP_PLAttp_code_uni_qte

EXP_TARIF_TRANSP_PLAttp_cout*<<<<<&.&&

EXP_TARIF_TRANSP_PLAttp_code_uni_cout

EXP_TARIF_TRANSP_ACCtta_soc

EXP_TARIF_TRANSP_ACCtta_code_tarif

EXP_TARIF_TRANSP_ACCtta_ligne_acc*<<<&

EXP_TARIF_TRANSP_ACCtta_type_frais_acc

EXP_TARIF_TRANSP_ACCtta_type_vehicule

EXP_TARIF_TRANSP_ACCtta_nb_points_chg*<<<&

EXP_TARIF_TRANSP_ACCtta_nb_points_dech*<<<&

EXP_TARIF_TRANSP_ACCtta_cout*<<<<<&.&&

EXP_TARIF_TRANSP_ACCtta_code_uni_cout

EXP_TARIF_TRANSP_ACCtta_date_deb_val*DD/MM/YYYY

EXP_TARIF_TRANSP_ACCtta_date_fin_val*DD/MM/YYYY

EXP_GRILLES_POUR gpt_soc

EXP_GRILLES_POUR gpt_code_grille

EXP_GRILLES_POUR gpt_designation

EXP_GRILLES_POUR gpt_date_creation*DD/MM/YYYY

EXP_GRILLES_POUR gpt_ligne*<<<&

EXP_GRILLES_POUR gpt_limite_inf*<<<<<&.&&

EXP_GRILLES_POUR gpt_limite_sup*<<<<<&.&&

EXP_GRILLES_POUR gpt_code_uni_qte

EXP_GRILLES_POUR gpt_pourcentage*<&&.&&


Import des tarifs transporteurs

Import des tarifs transporteurs tarif_transp_import

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

à partir des fichiers à importer, on alimente les tables suivantes :

grilles_pour (Grilles de pourcentage)

tarif_transp_acc (Tarifs transporteur frais accessoire)

tarif_transp_ent (Tarifs transporteur)

tarif_transp_lig (Tarifs transporteur ligne)

tarif_transp_pla (Tarifs transporteur plage de tarif)

Valeur alpha2

Caractères 1 à 60

Répertoire de stockage des fichiers d'import générés

Valeur alpha3

Caractères 1 à 20 | Nom du fichier utilisé pour l'importation de la table tarif_transp_ent
Caractères 21 à 40 | Nom du fichier utilisé pour l'importation de la table tarif_transp_lig
Caractères 41 à 60 | Nom du fichier utilisé pour l'importation de la table tarif_transp_pla

Valeur alpha4

Caractères 1 à 20 | Nom du fichier utilisé pour l'importation de la table tarif_transp_acc
Caractères 21 à 40 | Nom du fichier utilisé pour l'importation de la table grilles_pour

Notes

_NOM_FICHIER_TRACES | 21, 60 Nom du fichier trace
_NOM_FICHIER_ERR | 21, 60 Nom du fichier erreur
CARACTERE_DELIMITEUR | 21 Caractère délimiteur utilisé dans les fichiers d'import


Interface préfacturation

Interface de préfacturation interface_prefac

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Valeurs numériques

1

Compteur des fichiers de transfert des entêtes et des lignes

Options

-B | Mode batch
Orr | Recalcul du tarif du transporteur lors de la régénération
Osf | Pas de génération des fichiers d'interface On ne génère que la commande d'achat. Voir aussi la note GENERE_CDE_ACH_TRSP.
Otp | Permet de désactiver le test de présence du TSC étape

Valeur alpha 2

Caractères 1 à 2 | Classe de commande. Obligatoire. Exemples : D2 ou D6 ou D3
Caractères 3 à 5 | Type de produit. Obligatoire. Exemples : ON ou PA
Caractères 6 à 10 | Racine du compteur du fichier de transfert des entêtes. Obligatoire
Caractères 11 à 15 | Racine du compteur du fichier de transfert des lignes. Obligatoire
Caractères 16 à 18 | Code environnement des tarifs des transporteurs (Paramètre ETT) Obligatoire si la gestion des environnements des tarifs des transporteurs est activée Exemple : 001

Notes triées

GENERE_CDE_ACH_TRSP

Lors de la revalorisation du transport d'un affrètement (ou groupage) depuis le module de pré-facturation, on génère une commande d'achat de transport.

Lors d'une régénération du groupage, l'ancienne commande d'achat est annulée logiquement, et une nouvelle est crée.

21,25 Numéro de compteur des commandes fournisseur

26,28 TYF par défaut pour la commande générée

29,44 Code produit générique par défaut pour la commande générée

PRD_CODIF permet de paramétrer un code article variable au format suivant :

- Racine fixe sur n caractères (Note RACINE_PRD_CODIF)

- V ou L pour Vente ou Location (issu du TSC TVL (ic_char3_1) sur le transporteur)

- Métrage réel du groupage sur 2 caractères numériques.

- Type de camion sur 2 caractères ( TVE A1[19,20]).

Exemple : Z-TV06SR

Z-T : Racine

V : Vente

06 : Métrage linéaire

SR : Type de camion

45,47 Type de notes

48,50 Code Acheteur par défaut (sinon on prend celui de la fiche fournisseur)

51,53 Code Signataire par défaut (sinon vide)

54 Numérotation annuelle de la commande fournisseur (O/N, N par défaut) <VF>

NOM_FICHIER_ENTETES

Nom du fichier de transfert des entêtes. Obligatoire.

Exemple : /u/tmp/prefac_entetes

NOM_FICHIER_LIGNES

Nom du fichier de transfert des lignes. Obligatoire.

Exemples : /u/tmp/prefac_lignes

NOM_FICHIER_TRACE

21,60 Nom du fichier de trace des affrètements traités. Obligatoire

PARAMETRAGE_TAXE

21, 23 Pays de départ (*** pour tous les pays). Obligatoire.

24, 26 Pays de destination. Obligatoire.

INT Pour tous les pays intracom.

EXP Pour tous les pays hors CEE

27, 29 Nationalité du transporteur (*** pour toutes les nationalités). Obligatoire.

30, 32 Code taxe. Obligatoire.

33, 34 Type taxe. Obligatoire.

35, 36 Régime taxe. Obligatoire.

37, 38 Mode taxe. Obligatoire.

Exemples :

DE DE DE 431DED S

CH CH CH 429CHD S

BE BE BE 168BED S

LU LU LU 137LUD S

ES ES ES 139ESD S

FR FR FR 441FRE S

FR INTFR 441FRE S

***INT***442IPD S

***EXP***133EXD S

PARAMETRAGE_TYPE_LIV

21,23 Paramétrage du type de livraison. Obligatoire.

001 Livraison client en vente directe

002 Entrée mise à disposition client

003 Sortie mise à disposition client

004 Entrée mise à disposition usine

005 Sortie mise à disposition usine

006 Entrée consignation client

007 Sortie consignation client

008 Transfert sous-traitant

009 Sortie sous-traitant

010 Retour sous-traitant

011 Livraison filiale

012 Entrée mise à disposition client

013 Entrée consignation client

014 Entrée sous-traitant

015 Bon de transfert

016 Entrée mise à disposition client

017 Entrée mise à disposition usine

101 Fabrication sous-traitant

24, 29 Type de transport. Obligatoire.

30, 31 Type de mouvement. Obligatoire.

32, 37 Type de transport export. Obligatoire

Exemples :

001TT1FRA01TT1EXP

002TT2FRA02TT2EXP

003TT3FRA03TT3EXP

PARAMETRAGE_TYPE_PRD

21, 23 Sous-famille de la composition technique. Obligatoire.

24, 26 Type de produit. Obligatoire.

Exemple : V AK

RACINE_PRD_CODIF

21,30 Racine fixe utilisée dans la construction paramétrable du code article

Utilisée si l'on saisit PRD_CODIF comme code article dans la note GENERE_CDE_ACH_TRSP.

SUP_REQ_CORRES

21,60 Complément de requête pour la recherche du correspondant (table corres)

SUP_REQ_GROUPAGE_BL

Supplément de requête (Table groupage_bl)

Exemple : and gb_no_groupage matches "03*"

TSC_TAXE_GASOIL

21,23 Code TSC de la taxe GASOIL qui est ajoutée au coût réel du transport <VF>

Paramètres nécessaires

PAY | alpha1[40]
#CF LOG | alpha1[1] alpha1[3,5] Code TSC pour l'ordre des étapes d'un trajet
TRS | alpha1[11] Valorisation du mode de transport alpha1[19,21] Code magasin de départ par défaut (de type RG1) pour tarif location

Fichiers générés

Fichier des entêtes

01 | Code ORIAC transporteur | 001 à 017
02 | Classe de commande | 018 à 019
03 | Numéro d'affrètement | 020 à 029
04 | Mode de transport | 030 à 032
05 | Type de véhicule | 033 à 035
06 | Numéro camion | 036 à 047
07 | Tarif forcé | 048 à 048
08 | Devise | 049 à 051
09 | Affrètement modifié | 052 à 052
10 | Créateur de l'affrètement | 053 à 062
11 | Date de création de l'affrètement | 063 à 070
12 | Nombre de clients livrés | 071 à 073
13 | Type de taxe | 074 à 075
14 | Mode de taxe | 076 à 077
15 | Régime de taxe | 078 à 079

Fichier des lignes

01 | Numéro d'affrètement | 001 à 010
02 | Numéro de bon de livraison | 011 à 018
03 | Date du bon de livraison | 019 à 026
04 | Type de transport | 027 à 032
05 | Lieu de chargement | 033 à 035
06 | Code de taxe | 036 à 038
07 | Type de mouvement | 039 à 040
08 | Code tiers livré | 041 à 049
09 | Pays livré | 050 à 052
10 | Département livré | 053 à 055
11 | Ville | 056 à 080
12 | Zone tarifaire livrée | 081 à 086
13 | Distance Kms entre site et client | 087 à 095
14 | Unité facturable | 096 à 098
15 | Quantité facturable | 099 à 112
16 | Montant facturable | 113 à 121
17 | Montant HT barème proposé | 122 à 130
18 | Métrage linéaire prévu | 131 à 138
19 | Métrage linéaire réel | 139 à 146
20 | Poids brut BL | 147 à 157
21 | Nombre lots chargés | 158 à 161
22 | Type de produit | 162 à 164
23 | Compteur des bons de livraison | 165 à 167


Gestion des expéditions des affrètements

Gestion des expéditions des affrètements exped_affretements

Ce programme s'inscrit dans le cadre de la logistique.

Accès à la GED

>>> Voir la fiche d'installation complète sur la logistique.

Fonctionnalités | Valeurs numériques | Options
Valeur alpha 2 | Notes | Paramètres nécessaires

Permissions nécessaires

MOD EXPED_LIG_ADL Contrôle d'autorisation de modification de l'adresse de livraison de la ligne de groupage

MOD EXPED_LIG_DEP Contrôle d'autorisation de modification du lieu de déstockage de la ligne de groupage

MOD EXPED_LIG_INT Contrôle d'autorisation de modification du lieu intermédiaire de la ligne de groupage

TOU EXPED_LIG_F2 Contrôle d'autorisation d'annulation de la ligne de groupage (Touche F2)

TOU EXPED_F6 Suppression d'un affrètement qui contient au moins sur une de ses lignes un BL validé en définitif (touche F6 sur l'entête de groupage)

Fonctionnalités

Remplacement de la saisie actuelle des bons de livraison pris individuellement par une saisie groupée à partir des informations d'un affrètement.

L'affrètement ayant été saisi préalablement, tous les bons de livraison correspondants sont générés automatiquement.

Les écrans de saisie des lignes des bons de livraison se succèdent pour permettre à l'utilisateur de saisir les pickings correspondants.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro d'affrètement Exemple : -N[gb_no_groupage]
-ni | Caractères 4 et suivants : numéro d'affrètement Exemple : -ni[gb_no_groupage] En visu de commande client, la touche F26 (Etat de la production) affiche le numéro de l'étape en plus du numéro de l'affrètement. Depuis cet écran, un Ctrl J affiche l'itinéraire.

Valeurs numériques

1 | Numéro de compteur des bons de livraison. A blanc si pas de compteur. Type de compteur B
2 | Numéro de compteur des affrètements (ou des groupages)A blanc si pas de compteur. Type de compteur 0 (Zéro)

Options triées

-N

Numéro de l'affrètement (8 caractères)

Oaa

Aide à la saisie du numéro d'affrètement

Oan

Autoriser la génération de la ligne de livraison même si l'accusé de réception de la commande n'est pas édité

Dans la saisie des lignes de BL, la ligne de BL ne peut pas être saisie si l'AR de la commande n'est pas édité.

Lors de la génération des lignes de BL via le module exped_affretements, la ligne de BL pouvait être générée même si l'AR de la commande n'était pas édité.

Maintenant, la génération n'est plus autorisée si l'AR n'est pas édité.

L'option Oan permet de supprimer ce contrôle comme dans le module blv.

Oav

Le contrôle du véhicule est fait à la validation définitive de l'affrètement au lieu de la génération des bons de livraison

Oby

Numérotation annuelle des bons de livraison

Oco

La saisie du code cariste est obligatoire

Ocs

Consultation des affrètements

Ocv

Contrôle l'existence du véhicule

Odo

Saisie de la date de livraison d'étape obligatoire dans l'écran de saisie d'itinéraire

Oef

Envoi Fax/Mail filtré : On n'envoie pas les BL de transfert

Ofe

Flag édité : initialisation selon ligne existante

Ogp

Gestion du préparateur

Ogy

Numérotation annuelle des affrètements

Oia

Ouverture de la fenêtre itinéraire automatiquement après l'édition provisoire du BL

Onc

Affichage automatique, après la création de l'entête du bon de livraison, des notes saisies sur le couple client-adresse de livraison et pour un type de note paramétré en alpha2[5,7]

Ooa

Génération des BL par ordre des lignes d'affrètement

Oof

Ouverture de la fenêtre de saisie des lignes de BL même si des BL ont déjà été générés

Explication :

La touche F6 permet de générer les lignes de BL des lignes du tableau des lignes d'affrètement.

La touche F11 permet de générer la ligne de BL de la ligne courante du tableau des lignes d'affrètement.

Si des lignes de BL ont été déjà générées, l'écran de saisie des lignes de BL ne s'ouvrira pas.

Si cette option est activée, l'écran de saisie des lignes de BL s'ouvrira même si des lignes de BL ont été déjà générées.

Oor

Gestion des ordres de transport reliquats

Si cette option est activée et que la ligne de commande ou de nomenclature n'est pas soldée et que la quantité livrée est supérieure ou égale à la quantité à livrer de l'ordre de transport, on vérifie qu'il n'existe pas d'ordre de transport complémentaire sur le lot du produit livré et qu'il reste du stock sur le lot du produit livré.

Si ce n'est pas le cas, l'ordre de transport est soldé.

Si c'est le cas, on pose alors la question : "Il reste encore du stock pour cette commande. Voulez-vous créer un ordre de transport reliquat ?".

Si OUI, un mouvement de livraison prévisionnelle sur le lot est créé avec comme quantité la quantité en stock du lot et comme date la date du jour.

L'ordre de transport n'est pas soldé.

Si NON, l'ordre de transport est soldé.

Op2

Prise en compte du poids des palettes dans le calcul du poids transporté

Voir notes POIDS_UNI_PAL_DEFAUT et _SUP_REQ_PAL

Osr

Pas de mise à jour du stock résultant

Ova

Ouverture en automatique de la fenêtre de choix du véhicule

En création d'affrètement et sur option, une fenêtre de choix du véhicule s'ouvre automatiquement en sortie de champ mode de transport. Les véhicules proposés tiennent compte du transporteur et du mode de transport saisis.

Ovi

Validation définitive du BL interdite

Oxm

Fax-email

Valeur alpha 2

Caractère 1 | Contrôle si le bon de livraison a été édité en provisoire avant de l' éditer en définitif. Obligatoire N Edition définitive autorisée d'un bon de livraison non édité en provisoire O Edition définitive non autorisée d'un bon de livraison non édité en provisoire
Caractère 2 | Contrôle si le magasin de départ est identique à celui de la ligne de commande ou de la séquence de la ligne de commande. Obligatoire N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 3 | Contrôle si le lieu intermédiaire est identique à celui de la revue de contrat de la ligne de commande. Obligatoire N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 4 | Contrôle si le mode de transport de l'affrètement est identique à celui de la commande N Pas de contrôle W Contrôle non bloquant C Contrôle avec demande de confirmation B Contrôle bloquant
Caractères 5,7 | Type de notes du couple client-adresse de livraison. Obligatoire si option -Onc
Caractère 8 | Demande d'édition du bordereau d'expédition après la validation définitive de l'affrètement (O/N)
Caractère 9 | Demande de sortie de l'affrètement en cours après l'édition provisoire des bons de livraison (O/N)
Caractère 10 | Demande de confirmation de passage de l'affrètement de l'état définitif à l'état provisoire. Obligatoir N Pas de demande de confirmation W Message d'avertissement sans demande de confirmation C Demande de confirmation B Passage de l'affrètement de l'état définitif à l'état provisoire non autorisé
Caractères 11 à 13 | Code du mot de passe de confirmation de passage de l'affrètement de l'état définitif à l'état provisoire. Facultatif
Caractère 14 | Edition de l'ordre d'achat de transport. Obligatoire N Pas d'édition O Edition A Edition en annulation seulement
Caractère 15 | Contrôle de l'identifiant véhicule N Pas de contrôle (valeur par défaut) C Contrôle avec demande de confirmation de la conduite à tenir B Contrôle bloquant W Contrôle avec message d'avertissement
Caractère 16 | Rupture sur l'adresse de facturation lors de la génération des BL (O/N, N par défaut)
Caractère 17 | Rupture sur le type de port lors de la génération des BL (O/N, N par défaut)
Caractères 18 à 20 | Code environnement des tarifs des transporteurs (Paramètre ETT) Obligatoire si la gestion des environnements des tarifs des transporteurs est activée Exemple : 001
Caractères 21 à 26 | Code transporteur par défaut - Facultatif
Caractère 27 | Edition des ordres d'achat de transport en validation définitive des affrètements O/N, N par défaut
Caractère 28 | Valeur par défaut du flag gb_groupage_edite lors de la création de la première ligne d'un groupage (O/N, N par défaut)
Caractères 29 et 30 | Nombre de jours en moins pour le contrôle de la date de départ par rapport à la date du jour
Caractères 31 et 32 | Nombre de jours en plus pour le contrôle de la date de départ par rapport à la date du jour
Caractère 33 | Type de contrôle2 W Warning B Bloquant C Avec confirmation (valeur par défaut)
Caractère 34 | Initialisation de la date et heure de fin de chargement N Pas d'initialisation de la date et heure de fin de chargement 1 Initialisation de la date et heure de fin de chargement avec la date et heure de début de chargement
Caractère 35 | Initialisation de la date et heure de départ usine N Pas d'initialisation de la date et heure de départ usine 1 Initialisation de la date et heure de fin de départ usine avec la date et heure de début de chargement
Caractère 36 | Initialisation de l'heure de départ de l'entête du BL N Pas d'initialisation de l'heure de départ de l'entête du BL 1 Initialisation de l'heure de l'entête du BL avec l'heure de départ usine
Caractères 37 à 39 | Code du TSC de la ligne de groupage dont la zone ic_char30 alimentera la zone commentaire (b1_com) de l'entête de BL (table blv1) lors de la création du BL Facultatif. Exemple : COM Si aucun code TSC a été paramétré, la zone commentaire restera à blanc. ATTENTION, la zone ic_char30 est toujours saisie en majuscules.
Caractère 40 | On ne demande qu'une seule fois l'imprimante – Cette option conditionne ce qui suit (O/N, N par défaut)
Caractère 41 | L'imprimante pour l'édition définitive du BL est la même que celle pour le provisoire (O/N, N par défaut)
Caractère 42 | Le choix de l'imprimante pour édition BL provisoire est valide pour toute la session, sinon il est redemandé à la première édition après changement du groupage. (O/N, N par défaut)
Caractère 43 | Le choix de l'imprimante pour édition du BL définitif est valide pour toute la session, sinon il est redemandé à la première édition après changement du groupage. (O/N, N par défaut)
Caractère 44 | L'imprimante pour l'édition du bordereau est la même que celle pour le BL définitif (O/N, N par défaut)
Caractère 45 | Génération automatique des mails pour les BL (O/N, N par défaut) N La grille de gestion des mails s'ouvrira automatiquement. Initialement : Voir la gestion d'envoi de mails via des scripts.

Notes triées

Les notes pour l'intégration des données de chargement et création de BL en automatique sont dans un tableau séparé, plus bas.

Les notes pour la génération de commande depuis une ligne d'expédition sont dans un tableau séparé, plus bas.

EMETTEUR_FAX_EMAIL

Emetteur fax / mail Option payante EFE-7

21,23 Type émetteur (par ex. REP)

24,26 Code émetteur

GESTION_NOM_DOC_MAIL

Cette note est utilisable dans les programmes d'édition AR, BL, Facture, Ordre d'Achat de Transport

21 Mise à jour de la table envoi_fax_email avec le nom du document édité (O/N, N par défaut)

Complément du paramétrage sur #CF EFM

Voir la gestion d'envoi de mails via des scripts.

LIEUX_RGT1_VALIDES

21,60 Paramétrage des lieux de rangement valides. Facultatif

Maximum 52 lieux, soit 4 lignes de 13 blocs de 3 caractères

Si non renseigné, tous les lieux de rangement sont autorisés.

Si renseigné, seuls les lieux de rangement paramétrés sont autorisés

Exemple LIEUX_RGT1_VALIDES USIKAY

LPE

Lignes paramétrables de l'écran des expéditions des affrètements

4 Numéro de ligne paramétrable de l'écran des expéditions des affrètements (1 à 2)

5, 60 Paramétrage de la ligne sous la forme Titre zone*Nom zone*Longueur zone*usingzone*

La liste des noms de zones disponibles figure ci-dessous.

Exemple : LPE1Mét lin théo :*gp_metr_lin_theo*7*---&.&&*

OBJET_DOCUMENT

21,23 Type de document (OAT)

25,60 Objet du document pour le fax/email

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

PARAM_V_GROUPAGE_BL

21,26 Type et code du paramètre de lancement de la visu des groupages

POIDS_UNI_PAL_DEFAUT

21,30 Poids unitaire d'une palette par défaut. Obligatoire

Exemple : POIDS_UNI_PAL_DEFAUT0.600

Voir option Op2

RUN_AFF_DET_ART_AFF

21,26 Type et code du paramètre de lancement de l'affichage du détail du stock de l'article de la ligne de l'affrètement

Exemple : #SACOS

RUN_EDIT_BL_DEF

RUN_REEDIT_BL_DEF

21,26 Type et code du paramètre de lancement de l'édition / réédition des BL définitifs

RUN_EDIT_BL_DEF_AUTO

21,26 Type et code du paramètre de lancement de l'édition définitive du BL

Si le BL généré par l'automatisme est un BL à l'export (cde1.ec_exp de la première ligne de BL), l'édition de celui-ci devra être réalisée en définitif. Cette édition définitive lancera l'édition de la facture de douane associée (existe déjà).

RUN_EDIT_BL_PRO

RUN_REEDIT_BL_PRO

21,26 Type et code du paramètre de lancement de l'édition / réédition des BL provisoires

RUN_EDIT_BL_PRP_DEF

RUN_REEDIT_BL_PRP_DEF

21,26 Type et code du paramètre de lancement de l'édition / réédition définitive des BL pour propriétaire

Voir le TSC _PR

RUN_EDIT_BL_PRP_PRO

RUN_REEDIT_BL_PRP_PRO

21,26 Type et code du paramètre de lancement de l'édition / réédition provisoire des BL pour propriétaire

Voir le TSC _PR

RUN_EDIT_BORD_EXPED

21,26 Type de paramètre de lancement de l'édition des bordereaux d'expédition

Exemple : #EDBDE

RUN_EDIT_OAT_VAL_DEF

21,26 Type et code du paramètre de lancement de l'édition des ordres d'achat de transport en validation définitive des affrètement

Obligatoire si édition des ordres d'achat de transport en validation définitive des affrètements (A2[27])= O.

Exemple : #EDOVD

RUN_EDIT_ORDRE_ACHAT

21,26 Type et code du paramètre de lancement de l'édition des ordres d'achat de transport

RUN_EDIT_ORDRE_CHGT

21,26 Type de paramètre de lancement de l'édition des ordres de chargement

Exemple : #EDODC

RUN_SAISIE_BL

21,26 Type de paramètre de lancement de la saisie des bons de livraison

Exemple : #SABLV

SUP_REQ_GROUPAGE_BL

21, 60 Supplément de requête sur la table groupage des bons de livraison (table groupage_bl)

_SUP_REQ_LIEU_RGT1

21,60 Complément de requête

Permet d'exclure des code de type RG1 dans l'interrogation (F7) sur la zone des lieux intermédiaires.

Idem dans la saisie des bons de livraison

_SUP_REQ_PAL

21,60 Supplément de requête pour la recherche de l'article palette sur la table nom0. Obligatoire

Exemple

_SUP_REQ_PAL and nom0.n0_pcsant [1,4] = "XPAL"

Voir option Op2

TITRE_DOCUMENT

21,23 Type de document (OAT)

25,60 Titre du document pour la fenêtre de gestion du fax/email.

Celui-ci sera suivi de la mention N° et de la clé du document.

TOLERANCE_QTE_A_LIV

21 27 Pourcentage de tolérance (Format 9999.99). Facultatif

Exemple TOLERANCE_QTE_A_LIV 0005.00

Dans le cas où la ligne de commande ou la séquence de la ligne de commande n'est pas soldée, on contrôle si la quantité livrée de la ligne d'affrètement est supérieure ou égale à la quantité à livrer de cette même ligne minorée du pourcentage de tolérance.

Si OUI, l'ordre de transport de la ligne d'affrètement passe à l'état soldé.

Si NON, l'ordre de transport de la ligne d'affrètement passe à l'état non soldé.

La ligne de commande ou la séquence de la ligne de commande reste non soldée.

TYPE_NOTE_A_CREER

Paramétrage pour la recopie des notes du groupage

Permet de choisir si la recopie se fait

- vers les notes de l'entête du BL

- vers les notes des lignes de BL

Ce nouveau paramétrage remplace l'ancien (notes TYPE_NOTE_ORIG et TYPE_NOTE_DEST qui ne doivent plus être utilisées).

21,23 Type de notes qui seront prises sur le groupage

26,28 Type de notes générées sur le BL

31 Entête ou Ligne

E Entête du BL

L (ou vide) Ligne du BL (par défaut)

Exemple

TYPE_NOTE_A_CREER AFF B+F

Les notes sur la groupage de type AFF seront recopiées sur la ligne de BL dans des notes de type B+F.

Note cumulative

TYPE_NOTE_DEST

PARAMETRE PERIME

21,23 Type de notes générées sur la ligne de BL

Exemple : B+F

Les notes sur le groupage de type AFF seront recopiées sur la ligne de BL dans des notes de type B+F.

Lors de la génération des BL, insérer des notes provenant du groupage.

Les notes seront prises en priorité sur la ligne de groupage, puis sur l'entête de groupage si rien de trouvé sur la ligne.

TYPE_NOTE_ORIG

PARAMETRE PERIME

21,23 Type de notes qui seront prises sur le groupage

Exemple : AFF

Notes pour l'intégration des données de chargement et création de BL en automatique

Permet d'intégrer un fichier de chargement automatisé dans les affrètements, de générer automatiquement les bons de livraisons et de les éditer

Cette notes ne sont pas triées en ordre alphabétique, mais plutôt en ordre chronologique.

DATE_LIVRAISON | Colonne Date de livraison intégrée dans la table blv1, zone b1_datl. Le format de cette date dans le fichier est YYYYMMDD. 21,23 Indice de début de la colonne Date de livraison 24,26 Indice de fin de la colonne Date de livraison
MODE_AUTONOME | 21 Gestion du mode autonome pour l'intégration du fichier d'interface (O/N)
FICHIER_INTEGRATION | 21,60 Nom du fichier à intégrer
FICHIER_LOCK_VS | 21,60 Nom du fichier de lock posé par Volume
FICHIER_LOCK_SERVICE | 21,60 Nom du fichier de lock service
FICHIER_UNICITE_EXE | 21,60 Nom du fichier pour contrôle unicité
FICHIER_TRACE | 21,60 Nom du fichier de trace
FICHIER_ERREUR | 21,60 Nom du fichier d'erreur
ATTENTE_LIB_SERVICE | 21,24 Temps d'attente de libération du service
ATTENTE_LIB_VSW | 21,24 Temps d'attente de libération du fichier de lock
TYPE_MVT_SN_BL | 21,23 Type de mouvement de sortie générés lors de la création des BL
CODE_QUAI_DEFAUT | 21,23 Code quai par défaut (pour envoi édition)
NUMERO_AFF | 21,23 Indice de début de la colonne numéro d'affrètement 24,26 Indice de fin
LIGNE_AFF | 21,23 Indice de début de la colonne numéro de ligne d'affrètement 24,26 Indice de fin
VEHICULE | 21,23 Indice de début de la colonne véhicule 24,26 Indice de fin
NUM_CDE_COMM | 21,23 Indice de début de la colonne numéro de commande commerciale 24,26 Indice de fin
LIG_CDE_COMM | 21,23 Indice de début de la colonne numéro de ligne de commande commerciale 24,26 Indice de fin
SEQ_CDE_COMM | 21,23 Indice de début de la colonne numéro de séquence de commande commerciale 24,26 Indice de fin
NOMBRE_PALETTE | 21,23 Indice de début de la colonne nombre de palettes 24,26 Indice de fin
QUANTITE_PAR_PALETTE | 21,23 Indice de début de la colonne quantité par palette 24,26 Indice de fin
CODE_QUAI | 21,23 Indice de début de la colonne code quai 24,26 Indice de fin
SOLDE_CDE_LIVREE | 21,23 Indice de début de la colonne solde de la commande 24,26 Indice de fin
-W | 3,5 Code du quai (QAI) 6,8 Code imprimante rattachée au quai
-X | 3,5 Code du quai (QAI) 6 Indice de l'imprimante rattachée au quai

Notes pour la génération de commande depuis une ligne d'expédition

La génération de la commande commerciale sur une ligne d'expédition (touche F23) se fait via la saisie des commandes simplifiée, qui utilise le mécanisme de l'EDI (remarque : la visualisation des messages s'affiche temporairement).

Ces notes sont prioritaires sur celles du #CF SSC.

Option payante LIV 7 et autorisation sur la touche F23 : BLV2_GEN_CDE

SSC_CTRL_CLI_PROD | 21 Contrôle que le code client ou le code produit est passé en argument (O/N, O par défaut Pour les expéditions, il ne faut pas contrôler, le client ou le produit ne sont pas connus, ils seront saisis
SSC_SAISIE_REF_CDE | 21 Doit-on saisir la référence client ? (O/N, N par défaut) Si Non, la référence sera initialisée par le compteur défini dans la note SSC_COMPTEUR_EDC_REF
SSC_SAISIE_LIEU_INTER | 21 Doit-on saisir le lieu intermédiaire ? (O/N, N par défaut) Ce lieu alimentera la zone cde2.lc_lieu_rgt1
SSC_SAISIE_LIEU_DESTOC | 21 Doit-on saisir le lieu de déstockage ? (O/N, N par défaut) Ce lieu alimentera les zones cde4.nc_rgt1, cde4.nc_rgt2 et cde4.nc_rgt3
SSC_LIEU_INTER | 21,23 Lieu intermédiaire par défaut dans le cas de la saisie.
SSC_LIEU_DESTOCK | 21,35 Lieux de déstockage par défaut 23 lieu 1 24,29: lieu 2 30,35: lieu 3 Si la saisie n'a pas lieu, ces données seront prises sur la fiche produit.

Paramètres nécessaires

#CF TRA | alpha1[1,6] pour la traçabilité des champs alpha3[46,50] pour la traçabilité sur la table des groupages des bons de livraison (groupage_bl) Notes commençant par TRACABILITE_CHAMP
#CF LOG | Toutes les valeurs alpha1[1,18] sauf le 2
TRS | alpha1[12]

Liste des zones disponibles pour les lignes paramétrables de l'écran des expéditions des affrètements

GROUPAGE BL

ENTETE COMMANDE

LIGNE COMMANDE

NOMENCLATURE DE LIGNE DE COMMANDE

PARTIES COMMUNES A CDE2 ET CDE4

ENTETE BON DE LIVRAISON

LIGNE BON DE LIVRAISON

FICHE TIERS

FICHE ARTICLE

AUTRES

Table GROUPAGE BL

gb_soc | Code société
gb_no_groupage | Numéro groupage
gb_cde | Numéro commande
gb_ligcde | Ligne de commande
gb_ligseq | Ligne de séquence
gb_code_client | Code client
nom_gb_code_client | Nom client
gb_trans | Code transporteur
nom_gb_trans | Nom transporteur
gb_date_pres_dem | Date de présentation demandée
gb_heure_pres_dem | Heure de présentation demandée
gb_cout_charg_prev | Coût du chargement prévu
gb_poids_prev | Poids prévu
gb_qte_prev | Quantité prévue
gb_nb_pal_prev | Nombre de palettes prévues
gb_solde_prev | Solde total ou partiel
gb_groupage_edite | Groupage édité (O/N)
gb_annul | Code annulation
gb_adl | Code adresse livraison
nom_gb_adl | Nom adresse livraison
codp_gb_adl | Code postal adresse livraison
vil_gb_adl | Ville adresse livraison
pays_gb_adl | Pays adresse livraison
libc_pays_gb_adl | Libellé court pays adresse livraison
libl_pays_gb_adl | Libellé long pays adresse livraison
code_tiers_livre | Code tiers du client livré
adr_tiers_livre | Adresse du tiers du client livré
nom_tiers_livre | Nom du tiers du client livré
codp_tiers_livre | Code postal du tiers du client livré
ville_tiers_livre | Ville du tiers du client livré
pays_tiers_livre | Pays du tiers du client livré
libc_pays_tiers_livre | Libellé court du pays du tiers du client livré
libl_pays_tiers_livre | Libellé long du pays du tiers du client livré
gb_tport | Type de port
libc_gb_tport | Libellé court type de port
libl_gb_tport | Libellé long type de port
gb_trsp | Mode de transport
libc_gb_trsp | Libellé court mode de transport
libl_gb_trsp | Libellé long mode de transport
gb_preparateur | Code préparateur
libc_gb_preparateur | Libellé court code préparateur
libl_gb_preparateur | Libellé long code préparateur
gb_ligne_groupage | Ligne de groupage
gb_qte_reelle | Quantité réelle
gb_statut | Code statut
lib_gb_statut | Libellé code statut
gb_metr_lineaire | Métrage linéaire
gb_code_tarif | Code tarif
libc_gb_code_tarif | Libellé court code tarif
libl_gb_code_tarif | Libellé long code tarif
gb_type_vehicule | Type de véhicule
libc_gb_type_vehicule | Libellé court type de véhicule
libl_gb_type_vehicule | Libellé long type de véhicule
gb_etat_affret | Etat de l'affrètement
lib_gb_etat_affret | Libellé état de l'affrètement
gb_date_pres_reel | Date de présentation
gb_heure_pres_reel | Heure de présentation
gb_vehicule | Véhicule (Immatriculation, ...)
gb_date_dbt_chgt | Date de début de chargement
gb_heure_dbt_chgt | Heure de début de chargement
gb_date_fin_chgt | Date de fin de chargement
gb_heure_fin_chgt | Heure de fin de chargement
gb_quai | Quai affecté
libc_gb_quai | Libellé court quai affecté
libl_gb_quai | Libellé long quai affecté
gb_cariste | Cariste
libc_gb_cariste | Libellé court cariste
libl_gb_cariste | Libellé long cariste
gb_date_dep_usine | Date de départ de l'usine
gb_heure_dep_usine | Heure de départ de l'usine
gb_metr_reel | Métrage réel
gb_mag_depart | Magasin de départ
libc_gb_mag_depart | Libellé court magasin de départ
libl_gb_mag_depart | Libellé long magasin de départ
gb_lieu_rgt1 | Lieu intermédiaire
libc_gb_lieu_rgt1 | Libellé court lieu intermédiaire
libl_gb_lieu_rgt1 | Libellé long lieu intermédiaire
gb_blv | Numéro de bon de livraison
gb_ligblv | Ligne du bon de livraison
gb_cout_reel | Coût réel
gb_forcage_cout | Forçage du coût (O=Oui - N=Non)
gb_reponse_trans | Réponse du transporteur
gb_date_dem_trsft | Date de demande de transfert
gb_heure_dem_trsft | Heure de demande de transfert
gb_date_rep_trans | Date de réponse du transporteur
gb_heure_rep_trans | Heure de réponse du transporteur
gb_date_crea_aff | Date de création de l'affrètement
gb_heure_crea_aff | Heure de création de l'affrètement
gb_date_valid_def | Date de validation définitive
gb_devise_cout | Devise du coût
libc_gb_devise_cout | Libellé court devise du coût
libl_gb_devise_cout | Libellé long devise du coût
gb_zone_tarifaire | Zone tarifaire livrée
lib_gb_zone_tarifaire | Désignation zone tarifaire livrée
gb_unite_fact_cout | Unité de coût facturable
libc_gb_unite_fact_cout | Libellé court unité de coût facturable
libl_gb_unite_fact_cout | Libellé long unité de coût facturable
gb_qte_fact_cout | Quantité de coût facturable
gb_transfert_1 | Flag 1er transfert (O=Oui - N=Non)
gb_transfert_2 | Flag 2ème transfert (O=Oui - N=Non)

Zones ENTETE COMMANDE

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
nom_ec_ada | Nom adresse réception
copd_ec_ade | Code postal adresse réception
vil_ec_ada | Ville adresse réception
pays_ec_ada | Pays adresse réception
libc_pays_ec_ada | Libellé court pays adresse réception
libl_pays_ec_ada | Libellé long pays adresse réception
ec_adf | Code adresse facturation
nom_ec_adf | Nom adresse facturation
copd_ec_adf | Code postal adresse facturation
vil_ec_adf | Ville adresse facturation
pays_ec_adf | Pays adresse facturation
libc_pays_ec_adf | Libellé court pays adresse facturation
libl_pays_ec_adf | Libellé long pays adresse facturation
ec_adl | Code adresse livraison
nom_ec_adl | Nom adresse livraison
copd_ec_adl | Code postal adresse livraison
vil_ec_adl | Ville adresse livraison
pays_ec_adl | Pays adresse livraison
libc_pays_ec_adl | Libellé court pays adresse livraison
libl_pays_ec_adl | Libellé long pays adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_acc_euro | Acompte en EURO
ec_acc_dev | Acompte en devise
ec_pnt | Port non taxable en devise société
ec_pnt_euro | Port non taxable en EURO
ec_pnt_dev | Port non taxable en devise
ec_pht | Port taxable en devise société
ec_pht_euro | Port taxable en EURO
ec_pht_dev | Port taxable en devise
ec_tvap | Code tva port taxable
libc_ec_tvap | Libellé court code tva port taxable
libl_ec_tvap | Libellé long code tva port taxable
zc1_ec_tvap | Valeur 1 code tva port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accusé de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BLs à éditer
ec_portf | Port facturé
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande
ec_web_statut | Code statut pour les commandes web
ec_date_deb_val | Date de début de validité
ec_date_fin_val | Date de fin de validité

Zones LIGNE COMMANDE

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Ligne de commande
lc_prod | Code article
lib_lc_prod | Désignation article (Fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (Ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteliv_reelle | Quantité réellement livrée
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_prx_euro | Prix unitaire vente en EURO
lc_prx_dev | Prix unitaire vente en devise
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé code zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code tva
libc_lc_tva | Libellé court code tva
libl_lc_tva | Libellé long code tva
zc1_lc_tva | Valeur 1 code tva
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_deldep | Date de départ
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (Non utilisée)
lc_colis | Nombre colis
lc_prxcli | Prix client en devise société
lc_prxcli_euro | Prix client en EURO
lc_prxcli_dev | Prix Client en devise
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BLs à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
nom_lc_adl | Nom adresse livraison
copd_lc_adl | Code postal adresse livraison
vil_lc_adl | Ville adresse livraison
pays_lc_adl | Pays adresse livraison
libc_pays_lc_adl | Libellé court pays adresse livraison
libl_pays_lc_adl | Libellé long pays adresse livraison
lc_adf | Code adresse facturation
nom_lc_adf | Nom adresse facturation
copd_lc_adf | Code postal adresse facturation
vil_lc_adf | Ville adresse facturation
pays_lc_adf | Pays adresse facturation
libc_pays_lc_adf | Libellé court pays adresse facturation
libl_pays_lc_adf | Libellé long pays adresse facturation
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_plus_euro | Prix unitaire vente au plus en EURO
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_prx_moins_euro | Prix unitaire vente au moins en EURO
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_prx_rvt_euro | Prix unitaire revient en EURO
lc_prx_rvt_dev | Prix unitaire revient en devise
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_prx_rvt_r_euro | Prix unitaire revient réel en EURO
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1 è Fenêtre Revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_date_gener | Date de génération
lc_date_regener | Date de régénération
lc_prixnet | Prix net
lc_sbi | Code Facture SBI (Self Billing Invoice)
lc_heure_cli_tot | Heure de livraison souhaitée au plus tôt
lc_heure_cli_tard | Heure de livraison souhaitée au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_fab_tot | Heure de fin de fabrication au plus tôt
lc_heure_fab_tard | Heure de fin de fabrication au plus tard
lc_heure_dep_tot | Heure de départ au plus tôt
lc_heure_dep_tard | Heure de départ au plus tard
lc_transfert_trans | Code transfert SYLOGI
lc_gen_bl_auto | Génération automatique des BLs
lc_variante | Numéro de variante retenue lors du transfert du devis
lc_nummvt3 | Numéro de mouvement entrée prévisionnelle sur lieu intermédiaire
lc_volupilot_ok | Flag indiquant si la commande à été traitée par VoluPilot
lc_mpl_prx_ini | Prix initial en devise société
lc_mpl_prx_ini_eur | Prix initial en EURO
lc_mpl_prx_ini_dev | Prix initial en devise
lc_mpl_qte_ini | Quantité commandée initiale
lc_qte_en_retour | Quantité retournée par le bon de retour
lc_annu | Ligne commande annulée
lc_entite | Entité du devis
lc_cs1 | Code statistique 1
libc_lc_cs1 | Libellé court code statistique 1
libl_lc_cs1 | Libellé long code statistique 1
lc_cs2 | Code statistique 2
libc_lc_cs2 | Libellé court code statistique 2
libl_lc_cs2 | Libellé long code statistique 2
lc_cs3 | Code statistique 3
libc_lc_cs3 | Libellé court code statistique 3
libl_lc_cs3 | Libellé long code statistique 3
lc_cs4 | Code statistique 4
libc_lc_cs4 | Libellé court code statistique 4
libl_lc_cs4 | Libellé long code statistique 4
lc_qte_contrat | Quantité du contrat
lc_var_prod | Code variante de production
lc_ligne_a_epurer | Ligne à épurer (O/N)

Zones NOMENCLATURE DE LIGNE DE COMMANDE

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Ligne de commande
nc_seq | Ligne de séquence
nc_prod | Code article
lib_nc_prod | Désignation article (Fiche article)
nc_coef_nom | Coefficient de nomenclature
nc_qtecde | Quantité commandée
nc_qteliv | Quantité livrée
nc_qteliv_non_val | Quantité livrée non validée
nc_qteliv_val | Quantité livrée validée
nc_qteliv_reelle | Quantité réellement livrée
nc_rgt1 | Code lieu de rangement 1
libc_nc_rgt1 | Libellé court code lieu de rangement 1
libl_nc_rgt1 | Libellé long code lieu de rangement 1
nc_rgt2 | Code lieu de rangement 2
nc_rgt3 | Code lieu de rangement 3
nc_qtefab | Quantité fabriquée
nc_rstfab | Solder la fabrication (O/N)
nc_nummvt | Numéro de mouvement en stock
nc_nummvt2 | Numéro d'entrée prévisionnelle
nc_numfbi | Numéro de la FBI
nc_ligfbi | Numéro de ligne de la FBI
nc_solde | Ligne soldée
nc_reap | Mode de réapprovisionnement
libc_nc_reap | Libellé court mode de réapprovisionnement
libl_nc_reap | Libellé long mode de réapprovisionnement
nc_nummvt3 | Numéro de mouvement entrée prévisionnelle sur lieu intermédiaire
nc_qte_contrat | Quantité du contrat

Zones PARTIES COMMUNES A CDE2 ET CDE4

bl_prod | Code article
lib_bl_prod | Désignation article (Fiche article)
bl_qtecde | Quantité commandée
bl_qteliv | Quantité livrée
bl_qteliv_reelle | Quantité réellement livrée
bl_solde | Ligne soldée

Zones ENTETE BON DE LIVRAISON

b1_soc | Code société
b1_blv | Numéro bon de livraison
b1_cli | Code client
nom_b1_cli | Nom client
b1_ref | Référence bon de livraison
b1_sitp | Zone paramétrable 1 (Par exemple SIT pour site de production)
libc_b1_sitp | Libellé court zone paramétrable 1
libl_b1_sitp | Libellé long zone paramétrable 1
b1_tport | Type de port
libc_b1_tport | Libellé court type de port
libl_b1_tport | Libellé long type de port
b1_pht | Port taxable en devise société
b1_pht_euro | Port taxable en EURO
b1_pht_dev | Port taxable en devise
b1_tvap | Code tva port taxable
libc_b1_tvap | Libellé court code tva port taxable
libl_b1_tvap | Libellé long code tva port taxable
zc1_b1_tvap | Valeur 1 code tva port taxable
b1_trsp | Mode de transport
libc_b1_trsp | Libellé court mode de transport
libl_b1_trsp | Libellé long mode de transport
b1_trans | Code transporteur
nom_b1_trans | Nom transporteur
b1_tadr | Type adresse
b1_adrl | Code adresse livraison
nom_b1_adrl | Nom adresse livraison
codp_b1_adrl | Code postal adresse livraison
vil_b1_adrl | Ville adresse livraison
pays_b1_adrl | Pays adresse livraison
libc_pays_b1_adrl | Libellé court pays adresse livraison
libl_pays_b1_adrl | Libellé long pays adresse livraison
b1_datl | Date de livraison
b1_adrf | Code adresse facturation
nom_b1_adrf | Nom adresse facturation
codp_b1_adrf | Code postal adresse facturation
vil_b1_adrf | Ville adresse facturation
pays_b1_adrf | Pays adresse facturation
libc_pays_b1_adrf | Libellé court pays adresse facturation
libl_pays_b1_adrf | Libellé long pays adresse facturation
b1_col | Nombre de colis
b1_poids | Poids total
b1_montant | Coût réel du transport en devise société
b1_montant_euro | Coût réel du transport en EURO
b1_montant_dev | Coût réel du transport en devise
b1_com | Zone commentaire
b1_edit | Edité (O/N)
b1_embal | Type emballage
b1_cembal | Coût emballage en devise société
b1_cembal_euro | Coût emballage en EURO
b1_cembal_dev | Coût emballage en devise
b1_tvae | Code tva emballage
libc_b1_tvae | Libellé court code tva emballage
libl_b1_tvae | Libellé long code tva emballage
zc1_b1_tvae | Valeur 1 code tva emballage
b1_type_vehicule | Type de véhicule
libc_b1_type_vehicule | Libellé court type de véhicule
libl_b1_type_vehicule | Libellé long type de véhicule
b1_vehicule | Véhicule (Immatriculation)
b1_heure_depart | Heure de départ du véhicule
b1_no_groupage | Numéro de groupage
b1_date_chargem | Date de chargement
b1_lieu_rgt1 | Lieu de rangement de niveau 1
libc_b1_lieu_rgt1 | Libellé court lieu de rangement de niveau 1
libl_b1_lieu_rgt1 | Libellé long lieu de rangement de niveau 1
b1_ordre_chargt | Numéro d'ordre de chargement
b1_devise | Code devise
libc_b1_devise | Libellé court code devise
libl_b1_devise | Libellé long code devise
b1_transfert_trans | Transfert bon de livraison vers SYLOGI
b1_poids_brut_tr | Poids total brut transporté
b1_annu | Bon de livraison annulé
b1_transitaire | Code transitaire
nom_b1_transitaire | Nom transitaire
b1_blv_cab | Bon de livraison généré par code à barres

Zones LIGNE BON DE LIVRAISON

b2_soc | Code société
b2_blv | Numéro bon de livraison
b2_lig | Ligne de bon de livraison
b2_cde | Numéro commande
b2_ligcde | Ligne de commande
b2_ligseq | Ligne de séquence
b2_qte | Quantité livrée facturable
b2_qteliv | Quantité livrée
b2_poids | Poids livré
b2_nbcolis | Nombre de colis ou de palette de la ligne
b2_excolis | Nombre d'exemplaires ou de colis
b2_nummvt | Numéro de mouvement de stock engendré
b2_fact | Ligne facturée (O/N)
b2_solde | Ligne de BL soldant la ligne de commande
b2_type_livraison | Type de livraison
b2_maj_deb | MAJ déclaration d'échange de biens
b2_annu | Ligne bon de livraison annulée
b2_ligcad | Ligne de cadencement de livraison
b2_ligne_a_epurer | Ligne à épurer (O/N)

Zones FICHE TIERS

cl_soc | Code société
cl_code | Code tiers
cl_cpf | Type tiers
cl_cpt | Code comptable
cl_qual | Code forme juridique
libc_cl_qual | Libellé court code forme juridique
libl_cl_qual | Libellé long code forme juridique
cl_nom | Nom tiers
cl_adr1 | Ligne 1 adresse rue
cl_adr2 | Ligne 2 adresse rue
cl_codp | Code postal
cl_vil | Adresse ville
cl_validite_adr | Code validité adresse
libc_cl_validite_adr | Libellé court code validité adresse
libl_cl_validite_adr | Libellé long code validité adresse
cl_telph1 | Numéro téléphone 1
cl_telph2 | Numéro téléphone 2
cl_telcop | Numéro fax
cl_telex | Numéro télex
cl_corres | Nom correspondant
cl_code_domb1 | Code domiciliation bancaire 1
cl_domb1 | Domiciliation bancaire 1
cl_domb2 | Zone paramétrable
cl_rib | R.I.B.
cl_pays | Code pays
libc_cl_pays | Libellé court code pays
libl_cl_pays | Libellé long code pays
cl_langue | Code langue
libc_cl_langue | Libellé court code langue
libl_cl_langue | Libellé long code langue
cl_dev | Code devise
libc_cl_dev | Libellé court code devise
libl_cl_dev | Libellé long code devise
cl_geo | Code géographique
libc_cl_geo | Libellé court code géographique
libl_cl_geo | Libellé long code géographique
cl_cat | Code catégorie client
libc_cl_cat | Libellé court code catégorie client
libl_cl_cat | Libellé long code catégorie client
cl_act | Code secteur activité
libc_cl_act | Libellé court code secteur activité
libl_cl_act | Libellé long code secteur activité
cl_orig | Code origine
libc_cl_orig | Libellé court code origine
libl_cl_orig | Libellé long code origine
cl_mrg | Mode règlement
libc_cl_mrg | Libellé court mode règlement
libl_cl_mrg | Libellé long mode règlement
cl_ech | Code échéance
libc_cl_ech | Libellé court code échéance
libl_cl_ech | Libellé long code échéance
cl_zpar | Zone paramétrée 1
cl_reml | Taux remise ligne commande (en %)
cl_remg | Taux remise globale commande (en %)
cl_esc | Taux escompte commande (en %)
cl_codef | Code client chez le fournisseur
nom_cl_codef | Nom client chez le fournisseur
cl_minf | Minimum commande
cl_repr | Code représentant
libc_cl_repr | Libellé court code représentant
libl_cl_repr | Libellé long code représentant
cl_ape | Code APE
cl_siret | Numéro identification TVA et SIRET
cl_rel | Edition relevés de factures
cl_nbfac | Nombre d'exemplaires de facture
cl_regbl | Code regroupement commandes et BLs
cl_valbl | Valorisation BLs
cl_livp | Livraison partielle
cl_facp | Facturation partielle
cl_edit | Edition traites
cl_trac | Gestion traites acceptées
cl_exp | Code exportation
cl_seuila | Montant seuil acompte
cl_prca | Taux acompte
cl_cred | Montant crédit accordé
cl_tar | Code tarif
libc_cl_tar | Libellé court code tarif
libl_cl_tar | Libellé long code tarif
cl_rem | Code remise
libc_cl_rem | Libellé court code remise
libl_cl_rem | Libellé long code remise
cl_tour | Code tournée
libc_cl_tour | Libellé court code tournée
libl_cl_tour | Libellé long code tournée
cl_perf | Code périodicité facturation
libc_cl_perf | Libellé court code périodicité facturation
libl_cl_perf | Libellé long code périodicité facturation
cl_perr | Code périodicité relevés de factures
libc_cl_perr | Libellé court code périodicité relevés de factures
libl_cl_perr | Libellé long code périodicité relevés de factures
cl_adrd | Code adresse offres de prix
nom_cl_adrd | Nom adresse offres de prix
copd_cl_adrd | Code postal adresse offres de prix
vil_cl_adrd | Ville adresse offres de prix
pays_cl_adrd | Pays adresse offres de prix
libc_pays_cl_adrd | Libellé court pays adresse offres de prix
libl_pays_cl_adrd | Libellé long pays adresse offres de prix
cl_adra | Code adresse réception
nom_cl_adra | Nom adresse réception
copd_cl_adra | Code postal adresse réception
vil_cl_adra | Ville adresse réception
pays_cl_adra | Pays adresse réception
libc_pays_cl_adra | Libellé court pays adresse réception
libl_pays_cl_adra | Libellé long pays adresse réception
cl_adrb | Code adresse livraison
nom_cl_adrb | Nom adresse livraison
copd_cl_adrb | Code postal adresse livraison
vil_cl_adrb | Ville adresse livraison
pays_cl_adrb | Pays adresse livraison
libc_pays_cl_adrb | Libellé court pays adresse livraison
libl_pays_cl_adrb | Libellé long pays adresse livraison
cl_adrf | Code adresse facturation
nom_cl_adrf | Nom adresse facturation
copd_cl_adrf | Code postal adresse facturation
vil_cl_adrf | Ville adresse facturation
pays_cl_adrf | Pays adresse facturation
libc_pays_cl_adrf | Libellé court pays adresse facturation
libl_pays_cl_adrf | Libellé long pays adresse facturation
cl_qualite | Code qualité
libc_cl_qualite | Libellé court code qualité
libl_cl_qualite | Libellé long code qualité
cl_documents | Documents à joindre
cl_param | Zone données diverses
cl_incoterm | Type de port
libc_cl_incoterm | Libellé court type de port
libl_cl_incoterm | Libellé long type de port
cl_marge | Marge client
cl_insee | Code insee
cl_cligr | Code client groupe
nom_cl_cligr | Nom client groupe
cl_clifact | Code client facturation
nom_cl_clifact | Nom client facturation
cl_zparnum | Zone paramétrable
cl_zpar2 | Zone paramétrée 2
cl_zpar3 | Zone paramétrée 3
cl_dateannu | Date annulation
cl_titre | Code titre correspondant
libc_cl_titre | Libellé court code titre correspondant
libl_cl_titre | Libellé long code titre correspondant
cl_agrement | Code agrément
libc_cl_agrement | Libellé court code agrément
libl_cl_agrement | Libellé long code agrément
cl_transp | Code transporteur
nom_cl_transp | Nom transporteur
cl_trsp | Mode de transport
libc_cl_trsp | Libellé court mode de transport
libl_cl_trsp | Libellé long mode de transport
cl_suiv | Code suivi affaire
libc_cl_suiv | Libellé court code suivi affaire
libl_cl_suiv | Libellé long code suivi affaire
cl_domb | Domiciliation bancaire 2
cl_delai_consigne | Délai de maximum de consigne
cl_mailing | Code mailing
libc_cl_mailing | Libellé court code mailing
libl_cl_mailing | Libellé long code mailing
cl_groupe_risque | Code client risque groupe
nom_cl_groupe_risque | Nom client risque groupe
cl_ach_aff | Numéro acheteur affacturage
cl_tolerance_liv | Code tolérance de livraison
libc_cl_tolerance_liv | Libellé court code tolérance de livraison
libl_cl_tolerance_liv | Libellé long code tolérance de livraison
cl_qualif_appel | Code qualificatif appel de livraison
libc_cl_qualif_appel | Libellé court code qualificatif appel de livraison
libl_cl_qualif_appel | Libellé long code qualificatif appel de livraison
cl_email | Email
cl_pla_franco_port | Montant plafond franco de port
cl_zpar_adresse | Zone paramétrée adresse
cl_port_dest | Ville port destination
cl_tournee_liv | Code tournée livraison
libc_cl_tournee_liv | Libellé court code tournée livraison
libl_cl_tournee_liv | Libellé long code tournée livraison
cl_site_web | Site web
cl_annul | Tiers annulé
cl_dat_cr | Date enregistrement tiers
cl_nom_abrege | Nom client abrégé
cl_corres_civilite | Code civilité du correspondant
libc_cl_corres_civilite | Libellé court code civilité du correspondant
libl_cl_corres_civilite | Libellé long code civilité du correspondant
cl_latitude | Latitude
cl_longitude | Longitude
cl_transitaire | Code transitaire
nom_cl_transitaire | Nom transitaire

Zones FICHE ARTICLE

mp_soc | Code société
mp_code | Code article
mp_mp | Type article
mp_afnor | Code normalisé
lib_mp_afnor_art | Désignation article
lib_mp_afnor_ecma | Désignation ecma
mp_des | Désignation article
mp_param | Zone données diverses
mp_fam | Code famille
libc_mp_fam | Libellé court code famille
libl_mp_fam | Libellé long code famille
mp_sfm | Code sous-famille
libc_mp_sfm | Libellé court code sous-famille
libl_mp_sfm | Libellé long code sous-famille
mp_libre | Zone libre
libc_mp_libre | Libellé court zone libre
libl_mp_libre | Libellé long zone libre
mp_rgt1 | Code lieu rangement 1
libc_mp_rgt1 | Libellé court code lieu rangement 1
libl_mp_rgt1 | Libellé long code lieu rangement 1
mp_rgt2 | Code lieu rangement 2
mp_rgt3 | Code lieu rangement 3
mp_dt1 | Donnée technique numérique 1
mp_dt2 | Donnée technique numérique 2
mp_dt3 | Donnée technique numérique 3
mp_dt4 | Donnée technique numérique 4
mp_dt5 | Donnée technique numérique 5
mp_dt6 | Donnée technique numérique 6
mp_dt7 | Donnée technique numérique 7
mp_dt8 | Donnée technique numérique 8
mp_at1 | Donnée technique alphanumérique 1
mp_at2 | Donnée technique alphanumérique 2
mp_hau | Hauteur
mp_lon | Longueur
mp_lar | Largeur
mp_cond | Code conditionnement
libc_mp_cond | Libellé court code conditionnement
libl_mp_cond | Libellé long code conditionnement
mp_coul | Code couleur
libc_mp_coul | Libellé court code couleur
libl_mp_coul | Libellé long code couleur
mp_poids | Poids
mp_ua | Code unité achat
libc_mp_ua | Libellé court code unité achat
libl_mp_ua | Libellé long code unité achat
zc1_mp_ua | Valeur 1 code unité achat
mp_uv | Code unité vente
libc_mp_uv | Libellé court code unité vente
libl_mp_uv | Libellé long code unité vente
zc1_mp_uv | Valeur 1 code unité vente
mp_uvente | Code unité vente 2
libc_mp_uvente | Libellé court code unité vente 2
libl_mp_uvente | Libellé long code unité vente 2
zc1_mp_uvente | Valeur 1 code unité vente 2
mp_fconv | Code formule conversion
libc_mp_fconv | Libellé court code formule conversion
libl_mp_fconv | Libellé long code formule conversion
mp_fconv2 | Code formule conversion 2
libc_mp_fconv2 | Libellé court code formule conversion 2
libl_mp_fconv2 | Libellé long code formule conversion 2
mp_remp | Code article remplacement
lib_mp_remp | Désignation article remplacement
mp_pamp | Valeur stock
mp_pa | Prix achat
mp_cfrais | Taux frais
mp_cperte | Taux perte
mp_pr | Prix revient
mp_marg | Taux marge
mp_pv | Prix vente
mp_pv2 | Prix vente dans unité utilisation
mp_tva | Code tva
libc_mp_tva | Libellé court code tva
libl_mp_tva | Libellé long code tva
zc1_mp_tva | Valeur 1 code tva
mp_cpta | Compte achat
mp_cptv | Compte vente
mp_ana | Code analytique
mp_suistk | Suivi en stock
mp_tval | Type valorisation
mp_dermvt | Date dernier mouvement stock
mp_derinv | Date dernier inventaire stock
mp_derent | Date dernière entrée stock
mp_dersor | Date dernière sortie stock
mp_smini | Stock mini
mp_smaxi | Stock maxi
mp_sdisp | Stock disponible
mp_sphy | Stock physique
mp_sres | Stock réserve
mp_sbes | Stock besoins
mp_scdef | Stock en commande ou en fabrication
mp_ssim | Stock simulation
mp_minfou | Minimum commande fournisseur ou fabrication
mp_abc | Classement ABC
mp_contrôle | Code contrôle qualité
mp_reap | Code réapprovisionnement
libc_mp_reap | Libellé court code réapprovisionnement
libl_mp_reap | Libellé long code réapprovisionnement
mp_foucli | Code fournisseur
nom_mp_foucli | Nom fournisseur
mp_cli | Code client
nom_mp_cli | Nom client
mp_qteeco | Quantité économique commande ou fabrication
mp_delmoy | Délai moyen d'approvisionnement
mp_ndm | Numéro dernier mouvement stock
mp_qualite | Code qualité
libc_mp_qualite | Libellé court code qualité
libl_mp_qualite | Libellé long code qualité
mp_z1 | Zone paramétrée 1
mp_z2 | Zone paramétrée 2
mp_z3 | Zone paramétrée 3
mp_z4 | Zone paramétrée 4
mp_z5 | Zone paramétrée 5
mp_alerte | Stock alerte
mp_gestionnaire | Code gestionnaire
libc_mp_gestionnaire | Libellé court code gestionnaire
libl_mp_gestionnaire | Libellé long code gestionnaire
mp_pr_fixe | Prix fixe
mp_coefdiv_ffix | Coefficient diviseur frais fixe
mp_affect | Numéro affectation
mp_cdc | Code centre de coût
lib_mp_cdc | Libellé centre de coût
mp_devis | Numéro devis
mp_sdevis | Numéro sous-devis
mp_entite | Entité du devis
mp_qualite_matiere | Code qualité matière
lib_mp_qualite_matiere | Libellé qualité matière
mp_gencod | Code gencod
mp_itf14 | Code ITF14
mp_anu | Article annulé
mp_date | Date enregistrement article
mp_etat_bes | Etat des besoins matières
mp_qtemini_cdeclt | Quantité minimum pour commande client
mp_site_prod | Site de production
libc_mp_site_prod | Libellé court site de production
libl_mp_site_prod | Libellé long site de production
mp_cs1 | Code statistique 1
libc_mp_cs1 | Libellé court code statistique 1
libl_mp_cs1 | Libellé long code statistique 1
mp_cs2 | Code statistique 2
libc_mp_cs2 | Libellé court code statistique 2
libl_mp_cs2 | Libellé long code statistique 2
mp_cs3 | Code statistique 3
libc_mp_cs3 | Libellé court code statistique 3
libl_mp_cs3 | Libellé long code statistique 3
mp_cs4 | Code statistique 4
libc_mp_cs4 | Libellé court code statistique 4
libl_mp_cs4 | Libellé long code statistique 4

AUTRES

using

Constante dans une colonne


Interface SDDATA

Interface SDDATA interface_sddata

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Valeurs numériques

N1

Nombre de caractères de la ligne de commande (1 à 4) : 4 par défaut

Options

O1a | La commande CD1 est transférée avec les informations de la commande CDA si elle n'a pas de FBI Si cette option n'est pas activée, la commande CD1 n'est pas transférée car, par défaut, elle n'a pas de FBI.
Otf | Traitement en tâche de fond, sans grille de sélection
Oar | Option qui permet de stopper le traitement
Oup | Option qui permet de stopper le traitement après un seul passage

Valeur alpha 2

Caractères 1 à 4

Délai d'attente (en minutes) entre chaque boucle de traitement

Notes

FIC_SDDATA | 21,60 Nom du fichier de transfert
FIC_LOCK | 21,60 Nom du fichier de verrouillage général Plus d'infos
FIC_LOCK_SDDATA | 21,60 Nom du fichier de verrouillage SDATA Plus d'infos
FIC_LOCK_VS | 21,60 Nom du fichier de verrouillage Volume Plus d'infos
FIC_ARRET | 21,60 Nom du fichier d'arrêt (option –Oar)
FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_TRACE | 21,60 Nom du fichier de trace
_SUP_REQ_GROUPAGE_BL | 21,60 Complément de recherche pour la recherche sur les groupages


Edition de l'ordre d'achat de transport

Edition de l'ordre d'achat de transport edition_ordre_achat_transport

Ce programme s'inscrit dans le cadre de la logistique.

Il existe également une version VoluEdit.

>>> Voir la fiche d'installation complète sur la logistique.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N1C | Action : préparation / création Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1C[gb_no_groupage]
-N2C | Action : expédition / création Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2C[gb_no_groupage]
-N1M | Action : préparation / modification Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1M[gb_no_groupage]
-N2M | Action : expédition / modification Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2M[gb_no_groupage]
-N1A | Action : préparation / annulation Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1A[gb_no_groupage]
-N2A | Action : / expédition / annulation Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2A[gb_no_groupage]

Options

-N

Numéro de l'affrètement (8 caractères)

-XY

où X = Code module

1 Module de préparation des affrètements

2 Module d'expédition des affrètements

et Y = Type d'événement

C Création

M Modification

A Annulation

Exemples :

-1C | Edition de l'ordre d'achat de transport d'un affrètement créé dans le module de préparation des affrètements
-1M | Edition de l'ordre d'achat de transport d'un affrètement modifié dans le module de préparation des affrètements
-1A | Edition de l'ordre d'achat de transport d'un affrètement annulé dans le module de préparation des affrètements
-2C | Edition de l'ordre d'achat de transport d'un affrètement créé dans le module d'expédition des affrètements
-2M | Edition de l'ordre d'achat de transport d'un affrètement modifié dans le module d'expédition des affrètements
-2A | Edition de l'ordre d'achat de transport d'un affrètement annulé dans le module d'expédition des affrètements

Oco

Correspondant non obligatoire

Ofm

Ne repositionne pas l'enregistrement de Fax/Mail à renvoyer automatiquement en réédition de l'ordre d'achat transport.

Remarque : cela n'empêche pas la validation automatique par les notes VALID_FAX….

Valeur alpha 2

A2[1,3]

Code site de production - Tableau de bord du multisite

Notes

SUP_REQ_GROUPAGE_BL | 21, 60 Supplément de requête sur la table groupage des bons de livraison (Table groupage_bl)
NOTE_XXX_YYYYYYYYYY | 21, 60 Note éditée en entête ou en pied de page de l'ordre d'achat de transport XXX = Code ISO de la langue YYYYYYYYYY = Type de note Module de préparation des affrètements : ENTETE_1_1 : 1ère note d'entête de page ENTETE_1_2 : 2ème note d'entête de page PIED_1_1 : 1ère note de pied de page PIED_1_2 : 2ème note de pied de page Module d'expédition des affrètements ENTETE_2_1 : 1ère note d'entête de page ENTETE_2_2 : 2ème note d'entête de page PIED_2_1 : 1ère note de pied de page PIED_2_2 :2ème note de pied de page

Paramètres nécessaires

PRP | alpha1[6,11]
#CF LOG | Valeur alpha1[1], Valeur alpha1[3,5], Valeur alpha1[8,10], Valeur alpha1[14,16]
#CF WSL | Configuration Way Server


Préparation des affrètements

Préparation des affrètements prep_affret

Voir en bas de page l'explication des pictogrammes.

>>> Voir la fiche d'installation complète sur la logistique.

Valeurs numériques | Options | Valeur alpha 2
Valeurs alpha 3 & 4 | Notes | Paramètres nécessaires
Remarques diverses | Explication des pictogrammes | Transfert vers Excel

Valeurs numériques

1 | Numéro de compteur des groupages
2 | Non utilisée

Options triées

O1m

Affichage de la 1ère machine de l'OF suivant (OF supérieur) si article Multi-Niveau

Oaa

Aide à la saisie du numéro d'affrètement

Oac

Initialisation de la date de disponibilité avec la date prévue de l'OF de l'article chapeau si article Multi-Niveau

L'OF de l'article chapeau correspond à l'OF de la 1ère FBI (FBI créée par la CD2)

Oan

Afficher la colonne notes.

Dans certains tableaux, cette nouvelle colonne s'affiche et, le cas échéant, contient le pictogramme Attention révélant la présence de notes de type EXP ou LXP.

Oap

Annulation des prévisions de stock (Entrées prévisionnelles)

Oaq

Affiche la colonne quantité du stock physique du produit fini.

Nota : cette colonne apparaît uniquement dans les onglets Ordres de transport et Ordres transport à affréter.

Oar

Annulation des reliquats de stock (Sorties réserves)

Obf

Basculement automatique des ordres de transport de l'onglet en attente vers l'onglet à affréter

Obm

Mise à jour de la date de mise à disposition si la quantité en stock est supérieure à la quantité mini livrable

Oca

Lors de la sélection d'un ordre de transport à affréter pour le mettre dans le filtre de travail, prendre aussi les ordres de transports en attente pour les produits appairés qui portent sur la même commande.

Ocs

Consultation

Odb

Recherche de la date et de l'heure de disponibilité sur la date et l'heure de début prévues ou de production

Odc

Affichage spécifique pour informations lors du chargement des ordres de transport

Les informations s'affichent dans la fenêtre noire ou dans un fichier si vous lancez le programme avec une redirection comme 1>test

Odd

Si la phase PC-Topp M est absente, la date de disponibilité est initialisée avec la date de production de la dernière machine des autres phases PC-Topp de la table fab_1_etat

Ofm

En fonctionnement normal, quand on passe un OT dans le filtre de travail, on recalcule son flag (retard/stock insuffisant/trop de stock). On valide implicitement le flag Commande modifiée.

Avec cette option, un OT avec un flag Commande modifiée que l'on passe dans le filtre gardera son flag Commande modifiée.

Ofr

Permet de sélection dans le filtre de travail les ordres de transport de type reliquats (en plus de ceux à affréter

Ojs

Dans l'onglet Suivi des affrètements, dans le tableau Liste des affrètements, ajout d'une colonne avec un indicateur de l'état du stock.

Fonctionne uniquement avec les affrètements dont l'état est inférieur à 2.

Indicateur du stock :

[Jauge rouge] Le stock est insuffisant.

[Jauge verte] Le stock est suffisant.

Oma

Mise à jour automatique des dates de disponibilité

Auparavant, lors du changement d'onglet, les dates de disponibilité était mises à jour dans l'onglet actif.

A partir du 14/11/2011, en plus de ces anciennes actions, lorsque l'utilisateur édite l'ordre de chargement, cela met à jour les dates de disponibilité dans les trois onglets : Ordres de transport, Ordres de transport en attente et Ordres de transport à affréter.

Ona

Numérotation annuelle (compteur groupage_bl)

Oor

Onglet de regroupement

Orf

Permet la fusion d'un reliquat avec un ordre de chargement existant ayant les mêmes caractéristiques.

Mise en situation

Nous avons un ordre de chargement (OT) contenant 50 palettes.

Nous le scindons en deux parties : une de 33 palettes et l'autre de 17 palettes.

L'affrètement se fait avec l'ordre de chargement de 33 palettes.

Au moment de la livraison, l'affréteur peut mettre 32 palettes dans le camion. Il y a donc un reliquat d'une palette.

Sans l'option –Orf :

Sur le reliquat, l'action Basculer (via la touche F12) permet de mettre ce reliquat dans Ordres transport à affréter.

Cela crée un nouvel ordre de chargement. Au final nous avons deux ordres de chargement.

Avec l'option –Orf :

Sur le reliquat, l'action Basculer (via la touche F12) permet de mettre ce reliquat dans Ordres transport à affréter.

Si un ou des ordres de chargement ayant les mêmes caractéristiques que le reliquat existent, alors l'utilisateur aura le choix :

- soit de fusionner le reliquat avec un OT existant

- soit de créer un ordre de chargement (comme maintenant).

S'il y a plusieurs ordres de chargement, alors une fenêtre s'ouvre et l'utilisateur pourra choisir avec quel OT il souhaitera fusionner son reliquat.

Ors

Réaffectations autorisées de stock au solde des lignes de commandes

Ort

Historisation des motifs de refus transporteur

Voir les TSC RT0 à RT9.

Osa

On recherche le stock des produits synchrones de la même façon que pour les produits asynchrones

Ose

Ne pas modifier l'état de l'affrètement si celui-ci est à l'état 2 ou 3 depuis l'onglet Gestion affrètements

Ceci vaut pour les affrètements existants. En création, l'option n'est pas prise en compte.

Voir la note _CSEL

Osi

Supprimée. Remplacée par #CF LOG A2[2]

Osl

Sélection automatique des lots

Osm

Sélection manuelle : pas de mise à jour automatique de l'état des lignes d'expéditions

Osr

Pas de mise à jour du stock résultant

Ost

Le stock n'est pas limité au magasin de départ.

Oto

Optimisation du chargement et du tri des ordres de transport

La note ORDER_BY_OTR doit être paramétrée.

Cette option permet d'optimiser le chargement des ordres de transport en les triant dès la sélection et non pas après le chargement dans les tables temporaires.

Ots

Dans l'onglet Suivi des affrètements, active le tri des colonnes du tableau Liste des affrètements (Attention, les données redondantes sont affichées).

Oxm

Gestion du fax mail

Valeur alpha 2

1

Affichage date rendu au plus tôt dans colonne de détail

N affichage date rendu (par défaut)

O affichage date rendu au plus tôt

2

Affichage date départ au plus tôt dans colonne de détail

N affichage date départ (par défaut)

O affichage date départ au plus tôt

3,5

Type de véhicule par défaut

6,11

Type et code du paramètre de lancement du programme retour

21,23

Type de note concernant le forçage de prix d'un affrètement (ex : PRX)

Ce nouveau type de note est à déclarer (NTS PRX)

Si aucun type n'est précisé dans ce paramètre, alors il n'y aura pas de saisie de note

24,26

Magasin de départ par défaut de l'onglet Sélection (Paramètre RG1) - Facultatif

27

Date de mise à disposition

N La date de mise à disposition remontée par le TBDATA est toujours la date de production.

O La date de mise à disposition remontée par le TBDATA est la date de production si elle est renseignée, sinon c'est la date prévisionnelle.

Attention : voir aussi l'option Odd et le complément de requête _SUP_REQ_FAB_1_ETAT.

28

Affichage de la référence de la commande dans le bloc détail (O/N, N par défaut)

Dans le bloc détail commande, on remplace le numéro de la commande par sa référence si elle est renseignée (zone ec_ref).

Si la référence est identique au numéro, on prend le complément de référence sur la ligne de commande (zone lc_p3).

29

Afficher la colonne Heure (O/N, N par défaut)

Les utilisateurs qui affichent la colonne Heure dans l'application de préparation des affrètements, perdent leur configuration d'affichage à chaque nouveau patch de VoluPack/VoluPrim.

Pour remédier à ce problème, l'affichage de cette colonne est maintenant géré via paramétrage.

30

Champ à afficher comme libellé du transporteur

A le nom abrégé (cli.cl_nom_abrege) est affiché s'il est renseigné, sinon on affiche la raison sociale (cli.cl_nom) (par défaut).

R la raison sociale est affichée systématiquement.

Valeur alpha 3

1,6 | Code transporteur avec lequel on veut travailler. Cette zone est facultative. Si elle n'est pas renseignée, la valorisation d'un affrètement sera faite avec tous les transporteurs adéquats.
7 | Blocage du code transporteur (O/N, N par défaut) Si oui, le code transporteur est obligatoire en alpha3[1,6].
8 | Champ quai obligatoire (O/N, N par défaut)
9 | Initialisation de la date de présentation de l'affrètement avec la veille de la date de livraison du 1er OT (O/N, N par défaut)

Valeur alpha 4

1 | Profil utilisateur N pas de profil particulier (par défaut) P Préparateur. L'accès à l'onglet Gestion des affrètements est interdit A Affréteur. L'accès à l'onglet Reliquat est interdit.
2 | Edition automatique de l'ordre de chargement (O/N, N par défaut)
44 | Touche CONTROL-K (O/N) Action à réaliser sur une sélection multiple Voir la note _CSEL

Notes triées - Le tri ignore le caractère _ (soulignement)

ACCES_V_GB_SUIVI

21,26 Type et code du paramètre pour accéder à la visualisation du groupage BL (v_groupage_bl).

Nota : si la note est présente, dans l'onglet Suivi des affrètements, l'action Visualisation du groupage – touche F8 – est active.

AFF_COL_ZONE_LIBRE

21 Affichage de la colonne Zone libre (O/N, N par défaut)

BLOC_DET_LOT

Préparations des affrètements avec la gestion des lots d'expéditions

13,60 *Libellé*Origine*Zone*TSC*Using*

Libellé affiché devant la zone

Origine - 4 possibilités :

cli2 pour une zone de la table cli2

cli_distance pour une zone de la table cli_distance

TSC_CLI pour TSC sur client (et adresse de livraison)

TSC_LOT pour TSC sur lot d'expédition

Zone - 3 possibilités :

Nom d'une colonne de la table cli2

Nom d'une colonne de la table cli_distance

Code zone de la table info_c

TSC - Plusieurs possibilités :

[ne rien mettre si Origine = cli2 ou cli_distance]

TSC du client livré (si Origine = TSC_CLI)

TSC du lot d'expédition (si Origine = TSC_LOT)

TSC_CAS01 Cascade 1

TSC du point de livraison (client ou lieu de rangement intermédiaire si ce dernier est renseigné) (BLOC_DET_LOT*TSC_CLLIV*G*60F**)

Using : facultatif

Voir #CF LOG A2[1] : Gestion par lots d'expéditions (O/N, N par défaut)

Exemples

BLOC_DET_LOT*Adr 1:*cli2*c2_adr1***

BLOC_DET_LOT*Adr 2:*cli2*c2_adr2***

BLOC_DET_LOT*dist :*cli_distance*cdk_distance***

BLOC_DET_LOT*TestTP3*TSC_CLI*C*TP3*&&&&&&*

BLOC_DET_LOT*TestTP3*TSC_CLI*D*TP3*&&&&&&*

BLOC_DET_LOT*TestTP4*TSC_CLI*E*TP3**

BLOC_DET_LOT*TestAF1*TSC_LOT*F*AF1**

BLOC_DET_LOT*TestAF1*TSC_LOT*G*AF1**

BLOC_DET_OTR_CLI

Paramétrer des zones affichées dans le bloc détail infos clients des ordres de transport

17 à 60 *Libellé*Origine*Zone*Numéro de TSC client livré*Using (optionnel)*

Libellé : Libellé affiché devant la zone

Origine : 3 possibilités :

cli2 pour zone table cli2

TSC_CLI pour TSC sur client (et adresse de livraison)

TSC_CLI_LIB_XXX Libellé du code de type XXX lu dans le TSC (où XXX représente un type de paramètre)

Zone : 2 possibilités selon Origine :

Nom d'une colonne de la table cli2

Code zone de la table info_c

Exemples

BLOC_DET_OTR_CLI*RV*TSC_CLI*G*60B*

BLOC_DET_OTR_CLI*divers*TSC_CLI*G*60W*

BLOC_DET_OTR_CLI*Rec*TSC_CLI*G*61A*

BLOC_DET_OTR_CLI*Blo*TSC_CLI_LIB_BLO*F*RC1*

CODE_ETAT_MAT_BLO

21,50 Liste des codes état produit (mp_qualite) bloquants (à concaténer 3 par 3 -> 10 maxi)

COHERENCE_TRANSP_TVE

Contrôle de cohérence entre le transporteur et le type de véhicule

N pas de contrôle

W Warning

C Confirmation

B Bloquant

Lors de la modification du transporteur ou du type de véhicule d'un affrètement, on vérifie, selon paramétrage, la cohérence entre les deux.

Pour rappel, chaque transporteur a dans ses TSC, la liste des types de véhicules qu'il utilise.

COL_CLIENT

21 Affiche la colonne client dans l'onglet suivi des affrètements (O/N, N par défaut).
La rupture des lignes se fait sur le client, l'adresse de livraison et la ville.

22 Affiche la colonne nom client dans l'onglet suivi des affrètements (O/N, N par défaut).
Cette fonctionnalité fonctionne uniquement si car.21 = O.

COL_METRAGE_LIN

21 Affiche la colonne métrage linéaire dans l'onglet suivi des affrètements (O/N, N par défaut)

_CSEL

Affichage de la colonne de sélection (comme dans les visus)

Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement.

Elle est présente uniquement dans l'onglet Suivi des affrètements.

Pour sélectionner une ligne dans le but de faire un Ctrl K, appuyez sur la barre d'espace.

Pour passer de l'onglet Suivi des affrètements à l'onglet Gestion des affrètements, faites un double-clic sur la ligne concernée.

Le double-clic dans l'onglet Suivi des affrètements est indépendant du paramétrage général du double-clic expliqué dans le document Action à exécuter lors d'un double-clic dans un tableau.

La note CSEL est indispensable pour ce changement d'onglet.

Paramétrage

Option Ose pour ne pas modifier l'état de l'affrètement si celui-ci est à l'état 2 ou 3.

A4[44] = O pour autoriser la touche Ctrl K

Action ACT014 du Ctrl K (#RP) pour modifier l'état de l'affrètement de 1 à 2

Note _CSEL pour afficher la colonne de sélection

Permissions

ACT014 pour autoriser l'action ACT014 du Ctrl K

PREPAFFRET_ET2 pour modifier un affrètement dont l'état est à 2 ou à 3

EMETTEUR_FAX_EMAIL

21, 26 Type et code de l'émetteur fax mail

MODIF_AFF_EXPEDIE

21 Autorisation de modification (O/N, N par défaut)

NTS_TARIF_MINIMUM

21,23 Code de la note de type NTS pour commenter le choix du transporteur

Cette note vient en complément de la note TSC_TARIF_MINIMUM.

_OPTION_LIB_MACHINE

21,23 Type des machines de sous-traitance

_ORDER_BY_LOT

21,60 Complément pour le tri des lots d'expéditions (sur table lot_expedition)

Ex : lex_grp_dep, lex_date_dep

_ORDER_BY_OTR

21,60 Complément de tri sur la table ordre_transport

Voir aussi l'option Oto.

PARAM_CONSULT_STOCK

21,26 Type et code du paramètre de lancement de consultation des stocks

PARAM_CONSULT_TRACE

21,26 Type et code du paramètre de la visualisation des événements sur les OT

Voir la note _CRIT_DATT_ dans la visu de la traçabilité.

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

La même note existe sur le #CF ATL où elle est prioritaire.

PARAM_EDIT_C_A_C

21,26 Type et code du paramètre de lancement de l'édition du document de confirmation d'affrètement client

PARAM_EDIT_O_A_T

21,26 Type et code du paramètre de lancement de l'édition ordre d'achat de transport

27 V si édition VoluEdit

PARAM_EDIT_ORDRE_CHT

21,26 Type et code du paramètre de lancement de l'édition ordre de chargement

PARAM_EXPED_AFFRET

21,26 Type du paramètre de lancement de la consultation des expédition des affrètements

PARAM_FICHE_CLIENT

Accès à la fiche client ou adresse secondaire sur un OT

21,26 Type et code du paramètre de lancement pour l'accès à la fiche client

27 Accès en consultation à la fiche adresse secondaire (O/N, N par défaut)

PARAM_V_GROUPAGE_BL

21,26 Type et code du paramètre de lancement de la visu des groupages

QTE_STK_COUL_INF

21,60 Définit la couleur de la colonne Qté en stock si la valeur est inférieure à la tolérance.

Par défaut : aucune couleur de définie

Possibilité d'indiquer un nom générique (voir tableau) ou n'importe quelle valeur générique.

Voir la liste des couleurs prédéfinies au bas de cette page.

QTE_STK_COUL_SUP

21,60 Définit la couleur de la colonne Qté en stock si la valeur est supérieure à la tolérance.

Par défaut : orange

Possibilité d'indiquer un nom générique (voir tableau) ou n'importe quelle valeur générique.

Voir la liste des couleurs prédéfinies au bas de cette page.

QTE_STK_COUL_TOL

21,60 Définit la couleur de la colonne Qté en stock si la valeur est comprise dans l'intervalle ou égale aux tolérances.

Par défaut : green (vert)

Possibilité d'indiquer un nom générique (voir tableau) ou n'importe quelle valeur générique.

Voir la liste des couleurs prédéfinies au bas de cette page.

RECUP_INFO_PALETTES

21 Permet d'afficher le nombre de palettes dans le bloc de détail du stock (O/N, N par défaut)

_SUP_REQ_FAB_1_ETAT

21,60 Complément de requête sur la table fab_1_etat

Exemple

and f1e_machine = "A0000"

_SUP_REQ_GROUPAGE_BL

21,60 Complément de requête sur table groupage_bl

_SUP_REQ_LIEU_CDA

21,60 Complément de requête pour la recherche de magasin dans le cas de l'ajout d'une CDA au filtre de travail

Si ce complément n'est pas trouvé ici, il est recherché sur le #CF LOG.

Explication : Aujourd'hui, dans le filtre de travail, on peut ajouter des commandes non prévues.

Pour ajouter une CDA, il faut qu'elle possède un lieu intermédiaire (saisie en revue de contrat).

On peut lever cette contrainte, mais il faudra attribuer un magasin de destination à cette CDA.

La liste des magasins se fait avec un complément de requête.

Si ce complément n'est pas saisi, le fonctionnement actuel restera.

Si le complément de requête ne propose qu'un seul magasin, alors celui-ci sera pris en compte sans affichage de la grille de résultat.

_SUP_REQ_ORDRE_TRANS

21,60 Complément de requête sur table ordre_transport

_SUP_REQ_RECH_LL

21,60 Complément de requête pour la recherche des stocks (sur table stk0)

TITRE_TRANS_EXCEL

21,60 Titre général de la visualisation. Pas de valeur par défaut

Voir le paragraphe Transfert du suivi des affrètements vers Excel

TRANSFERT_EXCEL

21 Permet le transfert du tableau Suivi des affrètements vers Excel (O/N, N par défaut)

Voir le paragraphe Transfert du suivi des affrètements vers Excel

TSC_TARIF_MINIMUM

Sauvegarder dans un TSC le tarif le plus bas calculé lors de la valorisation du transport

Dans le cas où l'utilisateur ne choisit pas le transporteur le moins cher, on peut forcer l'utilisateur à saisir une note d'explication du choix.

21,23 Code TSC utilisé pour le tarif le moins cher

24,26 Code TSC utilisé pour le deuxième tarif le moins cher (dans le cas d'un coût identique)

Dans ces TSC :

La zone ic_num1 donne le coût minimum.

La zone ic_char30 donne le code transport le moins cher.

_TYPE_NOTES_CDE

21,23 Type de notes commande

_TYPE_NOTES_CLI

21,23 Type de notes client

Tolérance

Les explications qui suivent valent pour les notes suivantes :

QTE_STK_COUL_INF

QTE_STK_COUL_SUP

QTE_STK_COUL_TOL

Tolérance client

Dans la fiche client et dans l'adresse de livraison, il existe la possibilité de déclarer une tolérance (TOL) de quantité.

Tolérance pour la ligne de commande

La tolérance client sera automatiquement reportée sur la tolérance de la ligne de commande de vente. Il sera possible de la modifier.

Dans le cas où il n'existe pas de tolérance client, la sélection de la tolérance sur la ligne de la commande s'effectue par la méthode suivante :

Si le client a un TSC X09 avec ic_char3-1= O, alors la tolérance est 0%.

Sinon, on prend la quantité fixe pour majoration de la quantité lancée sur le TSC lié au CIC N72 de l'article s'il existe.

Sinon, on prend la quantité fixe pour majoration de la quantité lancée sur le TSC lié au CIC N72 du client s'il existe.

Sinon, on prend le pourcentage de majoration de la quantité lancée sur le TSC lié au CIC N72 de l'article s'il existe.

Sinon, on prend le pourcentage de majoration de la quantité lancée sur le TSC lié au CIC N72 du client s'il existe.

Sinon, on lit le #CF SFA pour prendre en compte les tolérances : #CF SFA A2[19] à #CF SFA A2[23].

Paramètres nécessaires

#CF CDE | alpha3[37,38] Racine des TSC pour les codes blocage
#CF LOG | alpha1[3,5] Code TSC pour l'ordre des étapes d'un trajet alpha1[8,10] Type de notes affrètement alpha1[11,13] Type de notes annulation affrètement alpha1[19,21] Type de notes historisation de la valorisation d'un affrètement alpha2[1] Gestion par lots d'expédition
#CF LSP | Configuration localisation stock palette
#CF WSL | alpha4[2] Forçage de la valorisation des transport au plus loin (O/N, N par défaut)
BLO | alpha2[11] Blocage envoi commande pour l'affrètement (O/N, N par défaut)
CIC | CIC PTV Type de véhicule CIC C22 Palette à reprendre CIC NHD Heure de début de livraison CIC NHF Heure de fin de livraison
RTA | alpha1[1] Réponse positive du transporteur (O/N, O par défaut)
TRS | alpha1[11] Valorisation du transport (O/N, O par défaut) alpha1[13,18] Code transporteur imposé pour les modes de transport sans valorisation
TFA | Notes CONTROLE_APPLI_xxx

Autoriser les modifications de notes sur lignes de commande

On peut autoriser l'ouverture de la saisie des notes de lignes de commande (cde3) en modification.

Par défaut, l'ouverture de la fenêtre ne se fait qu'en mode consultation.

Seules les notes sur les lignes de commandes peuvent être modifiables.

(clic droit dans le tableau lignes affrètement de l'onglet gestion affrètement et sélection notes cde LXP)

En modification, le curseur se positionne automatiquement sur une nouvelle ligne.

Gestion des permissions : TOU MODIF_CDE3_LXP

TSC par défaut sur code article GROUPAGE_DEF

L'article GROUPAGE_DEF contient tous les TSC à recopier sur le groupage dans le cas où la note INFO_C_DEFAUT est paramétrée sur le paramètre de lancement de prep_affret avec le code A en position 21.

Explication des pictogrammes

L'indicateur utilisé dans la préparation des affrètements regroupe 3 états différents :

Le stock

Le stock est insuffisant.

Le stock dépasse le besoin (uniquement pour les ordres de transport à affréter).

Alerte du retard sur date de départ

La date de départ est égale à la date du jour.

La date de départ est dépassée. Retard

Les flags des deux premiers états sont cumulables.

On peut avoir, par exemple un ordre de transport avec un stock insuffisant et dont la date de départ doit se faire dans la journée, ce qui donne :

Modification de la commande

La commande a été modifiée depuis la création de l'ordre de transport

Les flags des deux premiers états sont cumulables.

On peut avoir par exemple un ordre de transport avec un stock insuffisant et dont la date de départ doit se faire dans la journée.

Les flags en vert sont uniquement pour les ordres de transport à affréter.

Le flag de modification est affiché pour avertir l'utilisateur qu'une modification de la commande a été faite après la création de l'ordre de transport.

Une fois cette information lue, l'utilisateur est amené à "valider" la modification.

Le flag de modification s'efface alors. Selon les cas, il peut être remplacé par le flag des stocks et/ou du délai.

Liste des couleurs prédéfinies

Ces couleurs concernent les notes suivantes :

QTE_STOCK_COUL_INF

QTE_STOCK_COUL_SUP

QTE_STOCK_COUL_TOL

Transfert du suivi des affrètements vers Excel

Depuis l'onglet suivi des affrètements, on peut transférer le tableau vers Excel.

Cela se paramètre comme une visu (voir l'aide générale au paramétrage des modules de visualisation #VI).

En plus des colonnes du tableau cité ci-dessus, il est possible d'envoyer des informations supplémentaires liées au client, au transporteur ou du groupage.

Pour utiliser l'export vers Excel, il faut activer l'option payante WIN 5 pour le programme de préparation des affrètements.

Les notes TITRE_TRANS_EXCEL et TRANSFERT_EXCEL doivent être paramétrées.

Les notes COL_METRAGE_LIN et COL_CLIENT ont été ajoutées à cette occasion.

Paramétrage du transfert vers Excel :

Pour les colonnes à transférer vers Excel, se reporter à la documentation générale au paramétrage des modules de visualisation #VI.

Liste des noms de zones autorisés

Pour les informations du client à livrer :

Utilisation du package tiers (Clients – Fournisseurs – Prospects).

Attention : les noms des zones sont accessibles en préfixant les zones cl_ par c_

Exemple : c_cl_code.

Pour les informations du transporteur :

Utilisation du package tiers (Clients – Fournisseurs – Prospects).

Attention : les noms des zones sont accessibles en préfixant les zones cl_ par t_

Exemple : t_cl_code.

Pour les informations de l'affrètement (groupage) :

Utilisation du package Groupages de BL.

Autres zones

Ces zones correspondent au tableau affiché dans l'onglet suivi des affrètements.

nexp_aff_num Numéro d'affrètement (groupage)

nexp_aff_lig Nombre de ligne contenu dans l'affrètement

nexp_date Date de présentation prévue

nexp_heure_prev Heure de présentation prévue

nexp_date_dep Date de départ

nexp_transp_nom Nom du transporteur

nexp_tve Type de véhicule

nexp_trsp Mode de transport

nexp_pays Code pays

nexp_vil Ville de destination

nexp_nb_cli Nombre de client différent

nexp_createur Code de la personne qui a préparé l'affrètement

nexp_etat État de l'affrètement

nexp_metre_lin Métrage linéaire

nexp_code_client Code client

nexp_nom_cli Nom du client


Edition des affrètements pour infos client

Edition des affrètements pour infos client edi_affret_cli

Confirmation d'Affrètement Client (CAC en abrégé)

Certains clients peuvent vouloir un document de confirmation d'affrètement.

On paramètre ce besoin sur le TSC CAC (zone ic_char3_1).

L'édition, si elle est demandée (au moins un client à E ou C), est faite avant l'édition de l'ordre d'achat de transport.

Dans certains cas, on bloque la validation de l'affrètement tant que le client n'a pas répondu.

L'affrètement reste donc à l'état 0 avec un statut W (attente).

On peut consulter les affrètements en attente de réponse client dans l'onglet suivi des affrètements en cochant la case Attente acceptation.

Dans l'écran itinéraire, on voit le détail des étapes de déchargement.

On peut saisir des infos sur le conducteur et l'immatriculation du véhicule.

On peut aussi saisir des notes qui apparaîtront dans l'édition du CAC. Ces notes sont rattachées à l'étape sur laquelle elles sont saisies.

Une action permet de saisir la réponse client (action active uniquement sur les lignes C (envoi avec confirmation).

Le type et le code du paramètre de lancement de ce programme sont paramétrés dans la note PARAM_EDIT_C_A_C du programme prep_affret.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro d'affrètement

Exemple : -N[gb_no_groupage]

Valeur alpha 2

A2[1,4]

Code site. Obligatoire - Tableau de bord du multisite

Notes

NOTE_ | Notes paramétrables entête et pied de l'ordre d'achat de transport 6,8 Code ISO de la langue 10,19 Position de la note Module de préparation des affrètements : ENTETE_1_1 : 1ère note d'entête de page ENTETE_1_2 : 2ème note d'entête de page PIED_1_1 : 1ère note de pied de page PIED_1_2 : 2ème note de pied de page Module d'expédition des affrètements ENTETE_2_1 : 1ère note d'entête de page ENTETE_2_2 : 2ème note d'entête de page PIED_2_1 : 1ère note de pied de page PIED_2_2 :2ème note de pied de page 21,60 Note éditée en entête ou en pied de page
SUP_REQ_GROUPAGE_BL | 21,60 Supplément de requête sur la table groupage des bons de livraison
TYPE_NOTES_EDIT_DOC | 21,23 Type de notes d'édition

Paramètres associés

#CF LOG | A1[1] Logistique activée (O/N, N par défaut) A1[3,5] Code TSC de l'ordre des étapes A1[34,36] Code TSC utilisé pour l'enregistrement des plages horaires d'arrivée chez le client A1[46,48] Code TSC des confirmations d'affrètement client A2[6,8] Code TSC pour édition CAC à paramétrer sur les clients A2[9,11] Code notes (de type NTS) pour édition CAC
TSC CAC | Edition CAC à paramétrer sur les clients
TSC CV1 / CV2 / CV3 | Conducteur du véhicule
#CF WSL | A4[2] Forçage de la valorisation des transports au plus loin


Saisie des répartitions analytiques SAP Type 3

Saisie des répartitions analytiques SAP Type 3 repana_ado

PAS DE PARAMÉTRAGE


Edition paramétrable des traites

Edition paramétrable des traites ed_traites

Voir aussi l'édition par VoluEdit.

Ce nouveau programme permet une édition complètement paramétrable des traites, afin de pouvoir passer d'une imprimante matricielle à une imprimante laser sans refaire complètement le programme d'édition.

Cette nouvelle version du programme d'édition des traites n'est autre qu'un généralisation aux autres types d'imprimantes du précédent programme qui était limité aux imprimantes matricielles.

Valeurs numériques

1 | marge gauche 1
2 | emplacement du RIB, 1ère partie = code pays

Options triées

Oa2 | Active l'édition de la mention affacturage
Oa4 | Edition des années sur 4 caractères
Oaa | Active l'édition de l'adresse d'affacturage (note P_COL_AFFAC)
Oad | Désactive l'édition de l'adresse de la société émettrice
Oaf | Active l'édition de l'adresse de facturation
Occ | Désactive l'édition du code comptable client (note P_COL_COMPTE)
Od2 | Désactive l'édition de la domiciliation bancaire 2 du client (note P_COL_DOMBAN)
Oda | Désactive l'édition du détail de l'adresse (note P_COL_RAIS)
Oes | Active l'édition du numéro de SIREN (note P_COL_SIRET
Ofc | Edition des traites relatives aux factures
Ofj | Active l'édition de la forme juridique (zone numérique 2 + P_DELTA_RIB[33,35])
Olt | Edition de la liste des traites
Omf | Gestion des échéances multiples sur facture (pour les factures à plusieurs échéances, on édite une traite par échéance)
Omr | Gestion des échéances multiples sur relevé (pour les relevés à plusieurs échéances, on édite une traite par échéance)
Onp | Edition du numéro de pièce dans la référence tiré (P_COL_COMPTE)
Onr | Désactive l'édition du RIB (note zone numérique 2 + P_DELTA_RIB
Opd | Désactive l'édition de la date (note P_COL_DATREL)
Opl | Active l'édition du numéro de facture ou du relevé (note P_COL_NUMREL)
Ort | Désactive l'édition de la référence tiré (note P_COL_COMPTE)
Osp | Désactive l'édition du pied de la traite (note P_COL_CPTPIED)

Valeur alpha 2

1,3 | Code adresse de la société émettrice
4,4 | Edition du code représentant (O/N) [Valeur par défaut : N]
5,6 | Longueur d'une page en nombre de lignes (une page peut contenir plusieurs traites) [Valeur par défaut : 24]
7,8 | Longueur d'une traite en nombre de lignes (doit être supérieur à 14) [Valeur par défaut : 24]

Notes triées

LIBTRACNON

12,32 Libellé à éditer si la traite n'est pas sur acceptation

LIBTRACOUI

12,32 Libellé à éditer sur traite sur acceptation

MARGE_HAUTE

21,22 Nombre de lignes définissant la marge haute d'une traite [Valeur par défaut : 0]

MARGE_PHYSIQUE

21,22 = Nombre de lignes (Marge physique haute de l'imprimante) - s'applique à partir de la seconde traite de la page.

P_COL_ADRCLI

21,23 Emplacement d'édition de l'adresse de facturation [Valeur par défaut : Marge gauche 1 + 30]

P_COL_AFFAC

21,23 Emplacement d'édition de l'adresse d'affacturage [Valeur par défaut : Marge gauche 1 + 39]

P_COL_CODEISO

21,23 Emplacement d'édition du code ISO de la devise de la traite [Valeur par défaut : Marge gauche 1 + 69]

P_COL_COMPTE

21,23 Emplacement d'édition du numéro de compte client [Valeur par défaut : Marge gauche 1 + 39]

P_COL_CPTPIED

21,23 Emplacement d'édition du compte en pied de la traite [Valeur par défaut : Marge gauche 1 + 30]

P_COL_DATECH

21,23 Emplacement d'édition de la date d'échéance [Valeur par défaut : Marge gauche 1 + 26]

P_COL_DATREL

21,23 Emplacement d'édition de la date de la traite [Valeur par défaut : Marge gauche 1 + 15]

P_COL_DOMBAN

21,23 Emplacement d'édition de la domiciliation bancaire [Valeur par défaut : Marge gauche 1 + 57]

P_COL_LCR

21,23 Emplacement d'édition de la mention LCR [Valeur par défaut : Marge gauche 1 + 76]

P_COL_LIBTRAC

21,23 Emplacement d'édition du libellé des traites sur acceptation [Valeur par défaut : Marge gauche 1 + 47]

P_COL_NAPDEV

21,23 Emplacement d'édition du montant à payer [Valeur par défaut : Marge gauche 1 + 64]

P_COL_NUMREL

21,23 Emplacement d'édition du numéro de la pièce [Valeur par défaut : Marge gauche 1 + 39]

P_COL_RAIS

21,23 Emplacement d'édition de la raison sociale [Valeur par défaut : Marge gauche 1 + 3]

P_COL_SIRET

21,23 Emplacement d'édition du numéro de SIRET [Valeur par défaut : Marge gauche 1 + 20]

P_DELTA_RIB

21,23 Delta à appliquer avant la 2ème partie du RIB (Code clé) [Valeur par défaut : 6]

25,27 Delta à appliquer avant la 3ème partie du RIB (Code SIREN) [Valeur par défaut : 12]

29,31 Delta à appliquer avant la 4ème partie du RIB (Code établissement) [Valeur par défaut : 24]

33,35 Delta à appliquer avant la 5ème partie du RIB (Forme juridique) [Valeur par défaut : 30]

37,39 Delta à appliquer avant la 6ème partie du RIB (Domiciliation bancaire) [Valeur par défaut : 55]

PRESENCE_DEMI_MARGE

21 + ou - (Gestion d'une demi ligne de marge physique)

SEPARATION_CORPS

21,22 Nombre de lignes séparant l'entête du corps d'une traite [Valeur par défaut : 3]

Fin des notes triées


Calcul et édition des factures

Précédemment, l'option Ofb ne pouvait pas être paramétrée si la gestion des appairages (so_options[15]) était activée.

Maintenant, cette interdiction a été levée.

Si l'article de la ligne de commande est

un article non appairé (N),

ou un ensemble appairé non monté mono-produit (P),

ou un ensemble appairé non monté avec facturation sur l'article de référence (R),

ou un ensemble appairé monté (M),

ou un ensemble appairé monté à l’extérieur (E),

la ligne de commande sera facturée à la date du BL.

Si l'article de la ligne de commande est un ensemble appairé non monté multi-produit (O), la ligne de commande sera facturée à la date de facturation saisie.

Calcul et édition des factures facn

Options | Valeur numérique 1 | Valeur alpha 2
Notes | Type d'enregistrement | User
Périodicité facturation | Gestion du mois en cours | Gestion du plus et du moins
Gestion des frais d'expédition | Gestion de la suspension de TVA | Stockage des acomptes et des avances
Paramètres associés | Non-édition lignes de commande | Génération Fichier de Transaction Facture
Suspension de la TVA commande |  |

Attention : il est OBLIGATOIRE de créer les CIC C07 et P65.

Pour renseigner sur quel TSC se trouve le code tiers (CIC C07) et l'adresse secondaire de l'adresse d'envoi (CIC P65).

TSC à saisir ensuite sur la fiche du tiers facturé.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Action : Facturation Caractères 3 et suivants : Numéro de commande Exemple : -N[ec_num]
-n | Action : Réédition Caractères 3 et suivants : Numéro de facture Exemple : -n[fe_fac]
-P | Action : Facturation Caractères 3 et suivants : Numéro de pré-facture Exemple : -P[fe_fac]
-b | Action : Valorisation Caractères 3 et suivants : Numéro de BL Exemple : -b[b1_blv]

Options triées

Options autres que -O

-Wm

Edition de plusieurs copies sur des imprimantes différentes

Voir les notes de type EDITION_NUM

Options -O triées

Oaa

Stockage des acomptes et des avances déjà versés

Oaf

SPECIFIQUE Gestion de l'affacturage

Voir aussi #CF SFA A2[42]

Oal

SPECIFIQUE Prise en compte du champ ec_pro dans la sélection des factures

Pour le client XXX, le champ ec_pro est utilisé pour l'édition spécifique des BCI.

Oam

Gestion des appairages

Sans cette option, les ensembles appairés non montés mono-PF (mp_param[22] = P) sont facturés comme les ensembles appairés non montés multi-PF.

Le numéro et la ligne du BL ne sont pas renseignés dans la table fac1 (ou pfac1 si simulation).

Alimentation de la table fac6 (ou pfac6 si simulation).

Avec cette option, les ensembles appairés non montés mono-PF (mp_param[22] = P) sont facturés comme les produits non appairés.

Le numéro et la ligne du BL sont renseignés dans la table fac1 (ou pfac1 si simulation).

Pas d'alimentation de la table fac6 (ou pfac6 si simulation)

Obf

Contrôle si la ligne du BL est facturable (Colonne b2_afacturer de la table blv2)

La ligne du bon de livraison peut être basculée suivant l'option Oaf de blv.

- à l'état non facturable si celle-ci est facturable

- à l'état facturable si celle-ci a été basculée à l'état non facturable au préalable

dans la saisie des bons de livraison et la visualisation des bons de livraison par la touche F13.

La bascule est possible si le bon de livraison est édité en définitif et non facturé totalement ou partiellement.

Obp

Autorisation du basculement de la prise en compte de la périodicité de facturation

Obv

Calcul et édition d'un bon de livraison valorisé

On génère une facture de simulation pour le bon de livraison édité quelque soit l'état de celui-ci (Provisoire ou Définitif)

DOIT ETRE ACCOMPAGNEE DES OPTIONS Osi et Olr et -bx

Oc0

Pas de facturation pour une ligne dont le prix est à zéro

Spécifique A et B : cette option doit être désactivée pour pouvoir faire apparaître les lignes dont le prix est à zéro dans la facturation. Voir FAM, alpha3[39]

Cette option n'est pas prise en compte si la note FAM_SFM_PRIX_A_0 est paramétrée.

Oc1

Contrôle la quantité à facturer de la ligne de commande pour ne pas facturer les lignes ayant une quantité à facturer négative

Oc2

Permet de ne pas prendre en compte les quantités à 0

Oca

SPECIFIQUE Edition en mode cartonnage.

Occ

Clôture dossier au niveau de la commande

Numéro de dossier : numéro de commande de rattachement + numéro de ligne de commande de rattachement

ATTENTION, les mouvements de stock créés par la génération du dossier ne sont pas annulés.

Ocd

Contrôle si la devise du BL est identique aux devises des commandes livrées de celui-ci.

Ocl

Clôture dossier au niveau de la ligne de commande

Numéro de dossier : numéro de commande de rattachement + numéro de ligne de commande de rattachement

ATTENTION, les mouvements de stock créés par la génération du dossier ne sont pas annulés.

Oco

Code comptable obligatoire (dans le cas contraire, la ligne n'est pas facturée)

Ocp

SPECIFIQUE VOLUEDIT Autorise l'affichage de la contre-valeur en Euros

Ocr

Si type de commande = FAD ou AVO, on contrôle si la ligne de commande est facturable en fonction de cl_param[5]

Par défaut, les commandes de type FAD et AVO sont facturées systématiquement.

Ocs

Accès en calcul seul

Oct

Envoi de copies à un ou plusieurs tiers (nécessite les paires de CIC C04 à C06 et P62 à P64)

Les Cxx sont les codes clients, les Pxx les codes adresses secondaires

Ocu

SPECIFIQUE Edition des coordonnées de la société

Oda

Pas de facturation des lignes de commande d'ensembles appairés si un des bons de livraison édités en définitif a une date de livraison supérieure à la date de facturation

Voir aussi l'option ODA dans l'édition VoluEdit.

Odb

Non facturation des bons de livraison dont la date de livraison est supérieure à la date de facturation

Voir aussi l'option ODB dans l'édition VoluEdit.

Odf

Cette option permet d'initialiser la date de facturation avec celle qui aura été saisie au préalable ou avec la date du jour selon le paramétrage.

Fonctionne uniquement avec l'option Ofb.

Odl

SPECIFIQUE Détail de livraison sur la ligne de facture

Odt

Dissociation des TVA d'une facture par le code en plus du taux

Aujourd'hui, via 2 codes de TVA différents, on dissocie la TVA sur débit de la TVA sur encaissement.

Ces 2 TVA ont des codes différents mais le même taux.

On souhaite pouvoir les facturer ensemble, tout en les dissociant à l'édition.

Oe4

Prise en compte de l'escompte dans la mise à jour de mat4

Oea

Enchaînement automatique du calcul et de l'édition

Oei

Epuration sans condition des tables de simulation de facture (pfac*)

Cette option n'épure ni les factures de cession, ni les proforma.

Oel

Génération d'un événement dans evt_trans à chaque édition de ligne de facture

Oem

Récupérer le code échéance et le code mode de règlement sur le client et non plus sur la commande

Oen

Édition des notes de BL type B+F et FAC avec la ligne de facture, en dessous de celles de type ABF.

Attention : cette option est incompatible avec l'option Orr.

Si l'option Ora est présente :

- si le regroupement est actif, les notes seront éditées au niveau de l'entête.

- si le regroupement est inactif, les notes seront éditées au niveau de la ligne.

Oes

Accès en édition seule

Oet

Envoi de facture à un tiers. (nécessite la paire de CIC C07 - P65)

Of2

La gestion de la date de facture dans le cas de la facturation comptoir devient identique à la gestion de la date dans la facturation courante.

Ofa

Contrôle si commande facturable (lc_afacturer)

Ofb

Facturation à la date du BL

Si 2 BL pour un même client ont des dates de BL différentes, le client recevra une facture par BL datée à la date de celui-ci.

Si ces mêmes BL ont la date de BL identique, le client recevra une seule facture datée à la date des BL.

Si des frais doivent être facturés (pas de BL), ceux-ci seront facturés à la date de facturation saisie.

Si la date de facturation est identique à la date d'un des BL , ceux-ci seront sur la même facture.

Remarques :

L'option Osb (Self Billing Invoice) ne doit pas être activée.

L'option Ofc (Facturation comptoir) ne doit pas être activée.

à propos de la gestion des appairages

Ofc

Facturation comptoir INCOMPATIBLE AVEC OPTION -Osb

Ofd

Contrôle date facture > date réception facture fournisseur

Ofn

Suppression du test des factures nulles dans le transfert en comptabilité au changement de mois de facturation

Ofo

SPECIFIQUE

Forcer la réédition d'un original de facture (sans la mention "DUPLICATA") en cas d'incident technique

Ofp

Gestion de la facturation partielle INCOMPATIBLE AVEC OPTION -Osb

Ofr

Force la gestion proratisée pour les unités de forfait (UNI.num1 = 0)

Cette option est prioritaire sur le paramètre UNI A1[23]. Plus de détails dans ce paramètre.

Ofu

Non facturation des lignes de commande facturables uniquement dont la date répondue au client ou la date demandée par le client ou la date de la commande est supérieure à la date de facturation

Ogf

Gestion des frais d'expédition saisis, soit au niveau de l'entête de la commande, soit au niveau des lignes des bons de livraison

Oin

Active la génération de fichiers de type INVOICE ou autres (PCARD ou INFACTO ou OB10), contenant des informations sur les factures. Voir plus bas les notes particulières à cette gestion.

Si #CF EDI A1[2] = N et TSC INV (du couple client-adresse secondaire) char3_1 = O ou A ou T , la génération du fichier INVOICE sera autorisée pour ce couple client-adresse secondaire.

Si #CF EDI A1[2] = O et #CF EDI note TSC_INV car.21 = O ou A ou T, la génération du fichier INVOICE sera autorisée pour tous les couples clients-adresses secondaires.

Il est possible de paramétrer le transfert des factures sans BL selon le client facturé avec le TSC IN0, qui a priorité sur #CF EDI A1[5].

Oir

Tri sur les représentants et édition automatique des factures sur l' imprimante rattachée au représentant.

Ol2

On prend les informations sur l'article facturé pour calculer le poids et la surface.

Ola

Liste des factures calculées et non calculées

Olc

On prend les informations sur la ligne de commande pour calculer le poids et la surface.

Olr

Permet à différents utilisateurs de facturer en même temps (lr : lock restreint)

Le paramètre de lancement doit disposer d'un numéro de compteur non nul (valeur numérique 1)

Chaque processus de facturation doit travailler avec son propre compteur de facturation.

Le paramètre de lancement doit disposer de notes de complément de sélection.

Chaque processus de facturation doit utiliser un complément de sélection lui interdisant l'accès aux commandes des autres processus de facturation.

Voir la note LR pour la sélection des commandes à facturer.

Voir la note _SUP_REQ_FAC pour la sélection des factures à éditer/rééditer.

On ne peut permettre un parallélisme entre 2 processus de facturation que si on est certain que ces 2 programmes travaillent sur des commandes parfaitement distinctes (ceci afin d'assurer la cohérence des regroupements de commandes ou de BL par facture)

La zone cl_regbl peut contenir les valeurs suivantes :

1 ou N SANS regroupement de commande, SANS regroupement de BL (aucun regroupement)

2 AVEC regroupement de commande, SANS regroupement de BL (une facture par commande)

3 ou O SANS regroupement de commande, AVEC regroupement de BL (une facture par BL)

4 AVEC regroupement de commande, AVEC regroupement de BL (une facture globale)

5 Référence de regroupement de facture de l'entête de commande

6 Référence de regroupement de contrat de l'entête de commande

La mise en oeuvre de ce paramètre doit être faite avec une extrême prudence et ne doit en aucun cas se faire sans une vérification préalable de l'environnement de facturation.

Ols

Clôture dossier au niveau de la ligne de commande si ligne de commande soldée

L'option Ocl doit être paramétrée.

Si la ligne de commande appartient à un amalgame, toutes les lignes de l'amalgame doivent être soldées.

Om4

Alimentation de la table mat4 (statistiques article)

Omd

Mise à jour du code édition du dossier de fabrication

Omg

Gestion du mille+ selon le TSC MPG à créer avec le paramétrage suivant :

InfoC / Zone F (ic_char3_1) Facturation de cette ligne en tenant compte des valeurs au mille +

Incompatible avec l'option Oba de l'édition VoluEdit

Oml

Prendre le mode exonération sur l'adresse de livraison.

Le compte client sera aussi recherché sur l'adresse de livraison.

Oms

ANNULE LE 14/01/2003 - VF_WA_0189 Active la gestion des compteurs multisite

Omt

Mise à jour de la zone ec_tour de la table cde1 avec la valeur présente dans alpha2[10,12] lorsque la commande est soldée et facturée.

Ona

Numérotation annuelle des factures

Onf

Active l'affichage des notes en pied de facture

Ooa

SPECIFIQUE Edition des accessoires

Ooc | SPECIFIQUE Désactive l'édition de la ligne des couleurs
Oof | SPECIFIQUE Désactive l'édition de la ligne FEFCO
Ool | SPECIFIQUE Désactive l'édition de la ligne libellé composition

Ooo

SPECIFIQUE Edition des options onduleuse / extrudeuse

Op2

Prend le prix tarif après application de la formule de calcul (p2 n'est actif que si pt est présent)

Op3

Prends le poids sur le BL et non plus dans les TSC ou dans la ligne de commande

ATTENTION La surface sera nulle. Cette option inhibe l'option -Olc

Opb

Pas de cumul des ports (commande ou BL)

Opc

Permet d'avoir plusieurs commandes différentes sur une même facture proforma

Opf

Gestion du franco de port

Opm

Gestion du plus et du moins

Incompatible avec l'option Oba de l'édition VoluEdit

Opn

Empêche les prochaines factures négatives

Si on a rencontré quelques erreurs au niveau de la validation des BL, il peut arriver que la quantité à facturer calculée soit supérieure à celle stockée sur la ligne de commande.

Dans ce cas, la quantité à facturer de la ligne de commande passe en négatif après la première facturation, ce qui aura pour effet de donner une facture négative lors du prochain calcul.

Pour empêcher cela, on ajoute une option dans le programme de calcul des factures pour remettre à 0 les quantités à facturer qui sont négatives suite au calcul de facturation.

Opo

Facture proforma : entraîne automatiquement l'option -Osi

Incompatible avec l'option Ofa

Opr

Interdit la réédition dans le cas ou le prix unitaire de la ligne de facture est différent de celui de la commande

Opt

Permet de prendre le prix tarif lors du calcul de la facture (sur fichier produit uniquement).

Or4

Prise en compte des remises dans la mise à jour de mat4

Ora

Regroupement des lignes de facture de la même référence (article) ayant les mêmes prix unitaire et unité de vente selon le client facturé

L'option Orr permet de faire le regroupement des lignes de factures de la même référence (article), mais cela s'applique à toutes les factures éditées ou réédités.

Cette nouvelle option permet de faire la même chose que l'option Orr mais en plus elle procède au regroupement des lignes de facture selon le client facturé.

Si l'option Ora est activée, il ne faut pas mettre l'option Orr.

De plus, l'ordre de tri est imposé à l'image de celui fait par l'option Orr.

C'est-à-dire il est fait selon le numéro de facture, le code produit, le prix de vente et l'unité de vente.

ATTENTION : Cette option ne peut pas être utilisée avec les éditions VoluEdit car les catalogues, lors de leurs générations sont différents.

Pour reproduire le même fonctionnement sous VoluEdit, il faut créer un catalogue sans l'option Orr.

Puis dans un second temps, créer le deuxième catalogue avec l'option Orr.

Les catalogues sont nommés différemment : facture et facture regroupement.

Ensuite, il faut créer deux lanceurs :

un lanceur avec l'option Orr et un complément de requête qui ne prendra que les enregistrements où TSC RCL ic_char3_1 = O.

un lanceur sans l'option Orr et un complément de requête qui ne prendra que les enregistrements où TSC RCL ic_char3_1 est différent de O.

La clé de ce TSC correspond au client facturé, c'est-à-dire code client + code adresse de facturation.

Orb

Si regroupement sur la référence regroupement facture de l'entête de commande

(Code regroupement

Commandes / BL du 2ème écran de la fiche client à 5), on ne regroupe pas les commandes dont la référence regroupement facture n'a pas été saisie.

On a mis # dans les références non saisies afin de pouvoir les trier et les regrouper.

Orc

Rupture de facturation sur la ligne de cadencement de livraison

Ore

Mode de règlement et code échéance de la commande

Mode de règlement, code échéance et mode d'application de la TVA de la commande

Orr

Regroupement des lignes de facture de la même référence (article) ayant les mêmes prix unitaire et unité de vente

Incompatible avec l'option Ora.

Ors

Accès en réédition seulement

Cette option peut être positionnée dans le paramètre de lancement du programme d'édition de factures clients par fax/mail.

Le type et le code de ce paramètre de lancement sont définis dans la note EDI du programme envoi_fax_email.

Os1

Ajout de la ligne de commande dans l'écran de sélection

Les options Osb et Ofc ne doivent pas être activées.

Os2

Ajout du numéro et de la ligne de BL dans l'écran de sélection

La gestion des appairages (so_options[15]) ne doit pas être activée.

Les options Osb, Ofc, Oam, Obv et Oce ne doivent pas être activées.

Osa

Séparation des bons de livraisons appairés lorsque le schéma de facturation du client est sans regroupement BL

Permet de séparer les BL appairés, lorsque le client facturé est dans l'un des schémas de facturation suivants (cli.cl_regbl) :

• N – Sans regroupement BL

• 1 – Sans Regroup. Cde Sans Regroup. BL

• 2 – Avec Regroup. Cde Sans Regroup. BL

Osb

Facturation SBI (Self Billing Invoice).

Calcul des factures SBI indépendamment du calcul standard

INCOMPATIBLE AVEC OPTIONS Ofc et Ofp et -Nx

Osc

Utilisation des scénarios

Osi

Facturation de simulation. Cette option est considérée comme active si l'option Opo est positionnée.

Oso

NE PLUS UTILISER SPECIFIQUE CLIENT

Osr

Tri et rupture sur le signe du taux de remise de la ligne de commande

Incompatible avec l'option Ote

Les taux de remise des lignes d'une commande sont à 0 et négatifs ou à 0 et positifs, mais jamais à 0, négatifs et positifs (Voir option Our dans la saisie des commandes clients).

Si le client a un regroupement de commandes, le programme fera une facture pour les commandes ayant au moins une des lignes avec un taux de remise négatif et une autre pour les commandes ayant au moins une des lignes avec un taux de remise positif.

Les lignes de commande ayant un taux de remise à 0 seront facturées avec les lignes de la même commande ayant un taux de remise différent de 0.

Les commandes dont le taux de remise de toutes les lignes est à 0, seront facturées avec les commandes ayant au moins une des lignes avec un taux de remise positif.

Ost

SPECIFIQUE Mise à jour des statistiques en temps réel.

Ot1 (1/5)

Tri et rupture sur le type de port de l'entête des commandes une seule option parmi les cinq !

Ot2

Tri et rupture sur le type de port du bon de livraison (b1_tport)

Ota

Tri et rupture par adresse de livraison pour tous les clients

Si l'option n'est pas mise, cela dépend de cl_param[20] = O.

Otc (2/5)

SPECIFIQUE Tri et rupture par catégorie de produit (lc_p1) une seule option parmi les cinq !

Otd

Désactive la saisie de la date de facturation. Date de facturation : date du jour dans ce cas

Ote

Tri et rupture par taux d'escompte (ec_esc)

Incompatible avec l'option Osr

Otf

Autorise l'accès au menu Top fin de mois. Il y a possibilité de fonctionner avec la gestion du mois en cours, en interdisant l'accès à ce menu à certains utilisateurs.

Voir Alpha 2
Voir Gestion du mois en cours avec Top de fin de mois

Oti

Interdit la sélection de toutes les commandes lors du calcul des factures

Otp (3/5)

Tri paramétré sur site de production (zone ec_c1) de l'entête de commande

Tableau de bord du multisite

une seule option parmi les cinq !

Otr (4/5)

Tri et rupture par code représentant (lc_repr) une seule option parmi les cinq !

Ott (5/5)

Tri et rupture par code de TVA (lc_tva) une seule option parmi les cinq !

Ovd

Ne facture que les commandes dont la date est inférieure ou égale à la date de facturation

Ovt

Vérification du code identifiant TVA

ATTENTION : VAS A1[5] = O ou N mais surtout pas à blanc !

Oxm

Gestion automatique de l'envoi par fax/email

Voir les notes VALID_FAX* dans les généralités.

Voir aussi la note TYPE_ENVOI_DOCUMENT

Valeur numérique 1

Numéro du compteur déterminant le numéro de la facture (ou de la simulation de facture).

Cette valeur fonctionne aussi bien en numérotation mensuelle qu'en numérotation annuelle.

Valeur alpha 2

Caractères 1 à 3

Code paramètre associé au type paramètre TOP, dans lequel le mois en cours est défini.

Caractères 4 à 8

Mot de passe demandé au Top de fin de mois.

Caractère 9

Visualisation d'un état du calcul des factures

0 Toutes les commandes et les BL

1 Uniquement les commandes et les BL facturés

2 Uniquement les commandes et les BL non facturés

Caractères 10 à 12

Valeur qui sera affectée à la zone ec_tour de l'entête de commande (code tournée) si l'option -Omt est positionnée.

Caractères 13 à 15

Code TSC client de la recherche du prix de vente dans les tarifs

Exemple : PVT

Caractères 16 à 17

Racine du TSC de stockage des numéros d'autorisation et des montants déduits de la suspension de TVA des factures

Elle est facultative. Si elle est renseignée, elle est toujours en majuscules et de longueur 2.

Caractères 18 à 20

Code TSC client de l'autorisation de calcul des factures en cas de numéro d'identification TVA incorrect

Exemple ACF

L'option Ovt contrôle le numéro d'identification TVA du client.

Si celui-ci n'est pas correct, un message d'anomalie est affiché et aucune commande de ce client ne sera calculée.

Si pour certains clients le calcul des factures doit être effectué même en cas d'anomalie, le code TSC client de l'autorisation de calcul des factures en cas de numéro d'identification TVA incorrect doit être renseigné ici.

Le TSC est saisi sur le client et le caractère O (Oui) doit être mis dans la 1ère zone alpha de 3 caractères.

Les zones de la table info_c renseignées sont les suivantes

ic_type = F

ic_cle = Code client

ic_ts = Code TSC (A2[18,20] du paramètre de lancement)

ic_char3_1 Code autorisation de calcul des factures en cas de numéro d'identification TVA

incorrect O/N, N par défaut)

Remarque : cela concerne le client principal, cette gestion n'est pas active sur les adresses secondaires.

Caractères 21 à 25

Extension du fichier EDI généré

Cette extension est prioritaire à celle qui est paramétrée sur #CF EDI A1[9,13].

Exemple : txt ou dat

Notes triées

Il existe aussi des notes particulières à l'EDI INVOICE / PCARD / OB10 - voir tableau séparé plus bas.

Remarques importantes

Les 2 premières lignes de notes sont réservées pour le message qui sera imprimé sur la facture.

Les compléments de sélection ne sont pas pris en compte si on utilise les scénarios.

ACTION_AUTO_AVOIR

Code action automatique d'avoir sur facturation d'outillage (Type de paramètre ASO)

ACTION_AUTO_FACTURE

Code action automatique de facturation d'outillage (Type de paramètre ASO)

AFF_NOTES_CLI_FAC

21 à 23 Code type de notes (exemple CLI)

CLIENT_REGLEMENT

21,26 Code tiers du règlement

28,30 Code adresse secondaire règlement

CODE_EDIT_ART_CDE4

SPECIFIQUE

CR

3,60 Complément de sélection paramétrable pour le calcul

Exemple

CR and ec_tyc in ("FAD","AVO")

<ou>

CR and (ec_tyc = "FAD" or ec_tyc = "AVO)

CR_INVOIC

Dématérialisation des factures

10,60 Complément de sélection sur la table cde1 pour exclure certaines factures du traitement INVOIC

Lors du calcul de la facture et de la génération du message INVOIC, on positionne la facture comme étant éditée en fonction d'un nouveau flag sur le client facturé (TSC INV).

Par complément de sélection sur l'entête de commande, on pourra exclure une facture du traitement INVOIC.

Voir aussi TSC INV, zone ic_char3_2 (On passe la facture comme étant éditée lors de la génération du message INVOICE).

EDIT_AVEC_COPIE_CC

REEDIT_AVEC_COPIE_CC

21 (Ré)édition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des factures par canal_comm

EDITION_NUM_NN

(où NN = N° de la copie sur 2 chiffres) 20 notes maxi

Permet de lancer plusieurs copies d'une édition, sur des imprimantes différentes

2 possibilités :

- Dans le menu du choix de l'imprimante, l'utilisateur choisit l'option multi - imprimantes

- On ajoute sur le paramètre de lancement l'option -Wm.

Dans ce cas, le menu de choix de l'imprimante n'est pas proposé à l'utilisateur.

21 à 23 Code paramètre de l'imprimante

25 Numéro de l'imprimante (1-4)

31 à 50 Nom de l'exemplaire

EDIT_RIB_MODE_EXO

21,60 Liste des codes d'exonération pour lesquels le RIB et l'IBAN doivent être édités

EMETTEUR_FAX_EMAIL

21 à 26 Type et code du paramètre de l'émetteur fax/email

Ce paramétrage permet de retrouver le correspondant sur la fiche du client émetteur (#SOC).

FAM_SFM_PRIX_A_0

21,26 Couples de famille-sous-famille et familles des outillages facturables avec un prix à 0 malgré l'option Oc0

21,23 Code famille - Obligatoire

24,26 Code sous-famille - Facultatif

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

FORMAT_EDITION

21,23 Format de l'édition de la facture APPIC

PAY Paysage (Valeur par défaut)

POR Portrait

Facultatif.

FORMULE_ENTETE

SPECIFIQUE

21 à 60 Notes de type formule de politesse à éditer en haut de page.

Les lignes de notes peuvent être cumulées en utilisant les caractères ///

Exemple

Veuillez trouver ci-joint ///

l'accusé de

donnera à l'impression : Veuillez trouver ci-joint l'accusé de

FORMULE_PIED

SPECIFIQUE

21 à 60 Notes de type formule de politesse à éditer en pied de page.

Les lignes de notes peuvent être cumulées en utilisant les caractères ///

Exemple

Veuillez trouver ci-joint ///

l'accusé de

donnera à l'impression : Veuillez trouver ci-joint l'accusé de

_HIS_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_LIB_FAC_EURO

SPECIFIQUE

21 à 60 Libellé de la facture si la facture est en Euro

LR

4,60 Complément de sélection paramétrable, à utiliser conjointement avec l'option -Olr

Exemple

LR and p_fac1.fl_fac[5] ="3"

N

SPECIFIQUE

2 Type de notes

1 Notes sur client société (#SOC)

2 Notes sur entête de commande

3 Notes sur ligne de commande

4 Notes sur article

5 Notes sur client (adresse d'accusé de réception)

6 Notes sur client (adresse de livraison)

7 Notes sur entête de BL

8 Notes sur ligne de BL

3 à 60 Types de notes (codés sur 3 caractères, Exemple LIG#QA)

NOTE_FACTOR_1

NOTE_FACTOR_2

NOTE_FACTOR_3

21,60 1ère ligne éditée en pied de facture (3 notes possibles)

21,60 2ème ligne éditée en pied de facture (3 notes possibles)

21,60 3ème ligne éditée en pied de facture (3 notes possibles)

SPECIFIQUE -

Edition d'une mention de paiement au factor

La mention de paiement au factor est éditée sur 3 lignes de 120 caractères chacune en pied de facture.

Celle-ci est éditée si cl_param[10] = O ou F et si le document édité est une facture (Pas d'édition pour les avoirs).

NOTES_AFFACTURAGE_

Edition des notes d'affacturage sur la dernière page - SPECIFIQUE19 20 Numéro de note d'affacturage

19,20 1 ou 01 à 10

21,60 Note d'affacturage

10 notes d'affacturage peuvent être éditées.

La longueur de la note est de 90 caractères.

Pour obtenir une note de 90 caractères, 3 notes d'affacturage commençant par le même mot clé (ex : NOTES_AFFACTURAGE_1) doivent être paramétrées.

La 1ère note aura une longueur de 40 caractères, la 2ème note de 40 caractères et la 3ème note de 10 caractères.

Les 3 notes seront concaténées pour en faire une seule de 90 caractères.

Exemples

NOTES_AFFACTURAGE_1 Pour être libératoire, votre règlement

NOTES_AFFACTURAGE_1 doit être effectué directement à l'ord

NOTES_AFFACTURAGE_1 re de

NOTES_AFFACTURAGE_2 GE FACTOFRANCE Tour FACTO - 18 rue Hoch

NOTES_AFFACTURAGE_2 e - Cedex 88 - 92988 LA DEFENSE CEDEX

NOTES_AFFACTURAGE_3 TEL : 01.46.35.70.00 - GE FACTOFRANCE R

NOTES_AFFACTURAGE_3 IB : 13580 00001 00550108090 56 -

NOTES_AFFACTURAGE_4 qui le reçoit par subrogation et devra

NOTES_AFFACTURAGE_4 être avisée de toute réclamation à cet

NOTES_AFFACTURAGE_4 te créance

NOTES_RIB

21,60 Note à imprimer pour les clients affacturage

_ORDER_BY_FAC

21,60 order by supplémentaire pour éditer ou rééditer les factures

Celui-ci est UNIQUEMENT sur les champs de la table fac0 (Facturation réelle) ou pfac0 (Simulation de facturation).

Il est inséré juste avant le premier champ de l'order by.

Exemples

Facturation réelle

_ORDER_BY_FAC fac0.fe_cli, fac0.fe_adf,

_ORDER_BY_FAC fac0.fe_cpt

Simulation de facturation

_ORDER_BY_FAC pfac0.fe_cli, pfac0.fe_adf,

_ORDER_BY_FAC       pfac0.fe_cpt

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

PAS_DE_LIGNE_BL

SPECIFIQUE

21 Pas d'édition de la ligne Bon de livraison (O/N)

PAS_DE_LIGNE_DOUBLE

SPECIFIQUE

21 Permet de n'éditer qu'une seule fois les lignes de notes pour une même commande et une même ligne (si celles-ci se suivent dans l'édition) sur une même facture (O/N)

REEDIT_AVEC_COPIE_CC

EDIT_AVEC_COPIE_CC

21 (Ré)édition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des factures par canal_comm

REF_PEUGEOT

21 à 28 Racine

SUP_CDE1_INDIC

21,60 Critère de sélection sur cde1 pour les commandes assujetties aux indicateurs de rentabilité

SUP_CDE2_INDIC

21,60 Critère de sélection sur cde2 pour les commandes assujetties aux indicateurs de rentabilité

_SUP_REQ_CCO_FAC

21,23 Complément de requête portant sur la table fac0, pour inclure/exclure certaines factures de l'alimentation de la table canal_comm

Lors de l'édition des factures en mode alimentation de la table canal_comm, toutes les factures éditées sont inscrites dans la table. Il faut pouvoir inclure/exclure certaines factures (par exemple celles qui ne sont pas sujettes à un envoi de mail).

_SUP_REQ_FAC

21 à 60 Supplément de requête sur les tables fac1 et pfac1 pour l'dition

Exemple

and fl_fac in (select fe_fac from fac0 where fe_soc = "XXX" and fe_fac = fl_fac and fe_date < "01012001")

TEXTE_VIR_BANQUE

Références bancaires à éditer sur la facture lorsque le mode de règlement est VIR.

7 notes maximum

21 à 60 Zone de texte concernant les modalités de virement

Voir aussi : TSC BQE

Exemples

par virement bancaire

sur le compte ouvert au CEPME

CODE BANQUE : 18359 CODE GUICHET : 00043

N° COMPTE : 00003188651 CLE : 41

_TIT_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TYPE_MSG_LOCK_FIC

21 Type de message d'avertissement du lock des fichiers

E Message sur la dernière ligne de l'écran accompagné d'un bip sonore (Valeur par défaut)

C Message affiché dans une fenêtre au milieu de l'écran nécessitant l'intervention de l'utilisateur

TYPE_NOTE_BLV3

SPECIFIQUE

21 à 60 Types de notes sur entête de bon de livraison à éditer

TYPE_NOTE_BLV3_LIG

SPECIFIQUE

21 à 60 Types de notes sur ligne de bon de livraison à éditer

TYPE_NOTE_BLV_LIG

SPECIFIQUE

21 à 60 Types de notes sur ligne de bon de livraison

TYPE_NOTE_CDE3

SPECIFIQUE

21 à 60 Types de notes sur entête de commande à éditer (sous la forme : XXXYYYZZZ)

TYPE_NOTE_CDE3_LIG

SPECIFIQUE

21 à 60 Types de notes sur ligne de commande à éditer

TYPE_NOTE_CDE_LIG

SPECIFIQUE

21 à 60 Types de notes sur ligne de commande

TYPE_NOTE_CLI3_ADF

SPECIFIQUE

21 à 60 Types de notes sur adresse de facturation du client à éditer

TYPE_NOTE_CLI3_SIT

SPECIFIQUE

21 à 60 Types de notes sur adresse secondaire ou principale sur site de production à éditer - Tableau de bord du multisite

TYPE_NOTE_DEVIS

SPECIFIQUE

21 à 60 Types de notes sur entité de devis à éditer

TYPE_NOTE_E_BLV_ENT

SPECIFIQUE

21 à 60 Types de notes sur entête de bon de livraison.

A éditer dans la partie entête du corps

TYPE_NOTE_E_CDE_ENT

SPECIFIQUE

21 à 60 Types de notes sur entête de commande

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI

SPECIFIQUE

21 à 60 Types de notes sur adresse principale du client

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI_ADF

SPECIFIQUE

21 à 60 Types de notes sur adresse de facturation du client

A éditer dans la partie entête du corps

TYPE_NOTE_E_CLI_ADL

SPECIFIQUE

21 à 60 Types de notes sur adresse de livraison du client

A éditer dans la partie entête du corps

TYPE_NOTE_LIGNE_BL

21,23 Type de note de la ligne du BL - Facultatif - ALV par défaut

TYPE_NOTE_MAT

SPECIFIQUE

21 à 60 Types de notes sur article

TYPE_NOTE_MAT3

SPECIFIQUE

21 à 60 Types de notes sur article à éditer

TYPE_NOTE_P_BLV_ENT

SPECIFIQUE

21 à 60 Types de notes sur entête de bon de livraison

A éditer dans la partie pied du corps

TYPE_NOTE_P_CDE_ENT

SPECIFIQUE

21 à 60 Types de notes sur entête de commande

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI

SPECIFIQUE

21 à 60 Types de notes sur adresse principale du client

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADF

SPECIFIQUE

21 à 60 Types de notes sur adresse de facturation du client

A éditer dans la partie pied du corps

TYPE_NOTE_P_CLI_ADL

SPECIFIQUE

21 à 60 Types de notes sur adresse de livraison du client

A éditer dans la partie pied du corps

VALID_FAXMAIL_EDIT

VALID_FAXMAIL_REEDIT

VALID_FAXMAIL_VALID

Voir les notes dédiées au Fax/Mail

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

Génération Fichier de Transaction Facture

Génération d'un fichier de transaction s'appuyant sur le fonctionnement de l'EDI INVOICE

Permet la génération de fichiers contenant des informations sur les factures.

Ce programme génère des messages EDI de type INVOICE, PCARD, INFACTO et OB10.

En fonction de #CF EDI A1[6,8], il y a deux structures de fichiers (non requis pour OB10).

La structure du fichier généré est ici : ETU_EDI_format fichiers EDI INVOIC

Pour les fichiers de type OB10, il sera créé 1 fichier par facture. La chaîne saisie dans la note FIC_OB10 sera donc suivie du numéro de facture et de la date d’envoi.

Notes particulières à la génération de fichiers INVOICE et autres

Toutes ces notes requièrent l'option Oin.

Voir aussi #CF EDI, et notamment #CF EDI A1[6,8] et les notes TVA_, NTS_ et TSC_INV

Voir aussi TSC INV.

FIC_INVOICE

FIC_PCARD

FIC_INFACTO

FIC_OB10

<ou bien>

FIC_INVOICE_N

FIC_PCARD_N

FIC_INFACTO_N

FIC_OB10_N

21,60 Chemin + Racine du nom du fichier d'interface à générer

Par défaut, l'interface est de type INVOICE.

Lorsque l'interface est d'un type autre que INVOICE (PCARD ou INFACTO ou OB10), le nom du type d'interface est indiqué :

soit dans la zone G (char30) du TSC INV.
La zone F (char 3_1) de ce même TSC contient le code A (Autre).

soit dans #CF EDI note TSC_INV car.23 à 52.
Le caractère 21 de cette même note contient le code A (Autre).

Le _N spécifie le numéro d'environnement.

Vous ne pouvez pas faire cohabiter des notes avec et des notes sans numéro d'environnement.

FIC_LOCK_INVOICE

21 à 60 Chemin + Nom fichier de lock par une application externe Plus d'infos

FIC_LOCK

21 à 60 Chemin + Nom du fichier de lock général Plus d'infos

FIC_LOCK_VS

21 à 60 Chemin + Nom du fichier de lock posé lors du traitement Plus d'infos

FIC_ANOMALIE

21 à 60 Chemin + Nom du fichier d'anomalie

PAYS_RIB_BANQUE_SOC

Informations sur la banque de la société

Uniquement pour la génération d'un fichier INFACTO

21,23 Code ISO du pays de la banque de la société

25,50 RIB de la banque de la société

25-29 Code banque

30-30 [espace]

31-35 Code agence

36-36 [espace]

37-47 Numéro de compte banque

48-48 [espace]

49-50 Clé du numéro de compte banque

Exemple

PAYS_RIB_BANQUE_SOC FR 18359 00043 00003188651 99

Remarques importantes

Pour chaque couple client-adresse secondaire, la zone ic_char3_1 du TSC INV doit être égale à O pour autoriser la génération de fichier INVOICE.

Si la zone ic_char3_1 contient A (Autre), alors la zone char30 contient une clé (nom de l'interface).

Le fichier correspondant à cette clé est généré. Cette clé est INVOICE par défaut.

La zone ic_char3_1 peut prendre les valeurs O, N, A : Il ne faut donc pas paramétrer de contrôle de type O/N sur cette zone de TSC (cf paramétrage TSC).

Contrairement à la génération du fichier INVOICE, les TYC FAD et AVO sont autorisés pour la génération d'autres fichiers.

Le catalogue VoluEdit (Entête facture - Fiche facture) dispose d'une information dédiée : le Top Télétransmission (Vrai/Faux).

Si la facture a généré un fichier de type INVOICE, une note de type EDI rattachée à la facture a été créée.

C'est la présence de cette note qui positionne le Top Télétransmission à Vrai.

Le Top Télétransmission est toujours à Faux pour les factures de simulation.

Consignes de paramétrage pour l'interface PCARD uniquement

Dans le cas de génération d'un fichier de type PCARD, l'utilisateur doit générer une facture par commande.

L'option société 12 doit être activée pour la gestion des TSC sur la commande

Informations obligatoires devant être saisies par l'utilisateur

Sur le client (adresse de facturation) : (F20) infos complémentaires (TSC)

  • TF1 (ic_char30) : N° de carte CPC transmise par le client sur le bon de commande

  • TF2 (ic_char30) : Date d'expiration de la carte sous la forme MMAA

  • TF3 (ic_char30) : Nom du titulaire de la carte CPC

Sur le client (adresse de facturation) : La première ligne de note de type EDI

  • Le code Identifiant OGONE du client (sur #SOC pour le fournisseur)

Sur l'entête de commande : (F20) infos complémentaires (TSC)

  • TF4 (ic_char30) : Centre de coût client communiqué sur le bon de commande

Sur la ligne de commande : (F20) infos complémentaire (TSC)

  • TF5 (ic_char30) : N° de Ref produit renseigné sur la fiche de liaison Renault

  • TF6 (ic_char30) : N° de dossier CEI renseigné sur la fiche de liaison Renault

  • TF7 (ic_char30) : N° de fiche / Modèle indiqués sur la fiche de liaison

Type d'enregistrement des pieds de facture

Table fac2 : champ fp_enr

Type de montant pied de facture

0 Total remise ligne

1 Total brute taxable (non remisé)

2 Escompte d'entête de commande

3 Port taxable (entête de cde et/ou bl)

4 Total HT (1-0-C-2+3+L+M)

5 Total TVA 1 (regroupement 1er taux TVA)

6 Total TVA 2 (regroupement 2ème taux TVA)

7 Total TVA 3 (regroupement 3ème taux TVA)

8 Total TVA 4 (sur frais d'emballage)

9 Total TVA 5 (sur frais de port)

A Total TVA (5+6+7+8+9)

B TOTAL TTC

C Remise d'entête de commande

D Port non taxable

E Total taxe parafiscale 1

F Total taxe parafiscale 2

G Total taxe parafiscale 3

H Total taxe parafiscale 4

I Total taxe parafiscale 5

J Total taxe parafiscale (E+F+G+H+I)

K Montant acompte entête de commande

L Montant frais emballage sur BL

M Montant frais expédition sur lignes commande

N Droit de timbre (spécifique)

User (table fac2 : champ fp_user)

Si fp_enr = A, alors fp_user contient le code export qui peut prendre les valeurs suivantes :

  • N Normal

  • O Export

  • I Intracommunautaire

  • S Suspension de TVA

  • E Exonéré

Si fp_enr différent de A, alors fp_user contient le code TVA

Numérotation des factures et avoirs

Numérotation mensuelle | Créer un enregistrement dans la table de gestion des compteurs et indiquer : Le code société Le type de compteur (F, facture ou avoir ; S, facture ou avoir de simulation) La numérotation L'année et le mois (Exemple 9999) La valeur de départ du compteur (Exemple 991200001)
Numérotation annuelle | Option -Ona Créer un enregistrement dans la table de gestion des compteurs alphanumériques et indiquer : Le code société Le type de compteur (F, facture ou avoir ; S; facture ou avoir de simulation) La racine La valeur de départ du compteur

Périodicité facturation

Type paramètre

PER

Gestion du mois en cours avec Top de fin de mois

Paramétrage nécessaire

Positionner l'option -Otf (uniquement pour l'utilisateur habilité à effectuer la clôture de fin de mois).

Positionner alpha2[1,3] et [4,8]

Paramétrer l'année et le mois en cours dans le paramètre TOP

Principe de fonctionnement

1) Date par défaut

Lors de la Sélection de facture, l'utilisateur doit saisir la date de facturation. La valeur par défaut proposée est la date du jour, si la date du jour est dans le mois en cours.

La valeur par défaut proposée est le dernier jour du mois en cours, si la date du jour est supérieure au mois en cours.

Exemple En début décembre, si le top de fin de mois de novembre n'a pas été fait, la date proposée par défaut est le 31/11/93. Cela permet de continuer à émettre des factures sur Novembre sans changer systématiquement la date proposée.

2) Contrôle bloquant

Lors du top de fin de mois, le mois en cours est clôturé. Par la suite, il ne sera plus possible d'émettre de facture sur ce mois clos !

Remarque La seule solution, pour ce faire, est la modification manuelle du paramètre TOP FIN (ou autre code).

3) Top de fin de mois

Lors du top de fin de mois divers contrôles non bloquants sont réalisés :

  • Confirmation de clôture du mois

  • Contrôle si toutes les lignes de factures ont été éditées

  • Contrôle si toutes les traites ont été éditées

  • Contrôle si tous les relevés ont été édités

  • Contrôle si toutes les factures ont été transférées en comptabilité

  • Confirmation par saisie du mot de passe

Gestion du plus et du moins

La facturation du plus et du moins est possible :

  • Si c'est une ligne de commande avec un bon de livraison

  • Si c'est le dernier bon de livraison de la ligne de commande

  • Si la ligne de commande est soldée

  • Si la quantité commandée est différente de la quantité livrée à facturer

  • Si le prix au plus est renseigné dans le cas où la différence entre les quantités commandée et livrée à facturer est positive

  • Si le prix au moins est renseigné dans le cas où la différence entre les quantités commandée et livrée à facturer est négative

La quantité commandée est facturée au prix normal.

  • Si la différence est positive, celle-ci est facturée au prix au plus.

  • Si la différence est négative, celle-ci est facturée au prix au moins.

Exemple 1

Quantité commandée | 5000
Quantité livrée à facturer | 5100
Prix normal | 1000F le mille
Prix au moins | 900F le mille
Prix au plus | 1100F le mille
La facture sera donc |
5000 à 1000F le mille | 5000F
100 à 1100F le mille | 110F
Total de la facture | 5110F

Exemple 2

Quantité commandée | 5000
Quantité livrée à facturer | 4800
Prix normal | 1000F le mille
Prix au moins | 900F le mille
Prix au plus | 1100F le mille
La facture sera donc |
5000 à 1000F le mille | 5000F
200 à 900F le mille | 180F
Total de la facture | 4820F

Gestion des frais d'expédition

La facturation des frais d'expédition est possible :

  • Si le type du port de la commande ou du bon de livraison est renseigné

  • Si le caractère 2 de la zone alpha 1 du paramètre type de port est O ou [blanc]

Gestion de la suspension de TVA

Pour activer cette fonctionnalité, positionnez le caractère 31 de la fiche société à O

Les montants d'autorisation de suspension de TVA doivent être saisis sur la fiche client par la touche F22.

Lors du calcul de la facture, si la facture n'est pas en suspension de TVA, elle est calculée normalement. Si elle est en suspension de TVA, le système vérifie que le montant d'autorisation n'est pas dépassé.

Si le montant d'autorisation est franchi, la facture n'est pas calculée.

Si le montant d'autorisation n'est pas franchi, le montant total HT facturé est mis à jour avec le montant HT de la facture.

Stockage des acomptes et des avances

Les acomptes et les avances sont saisis dans les commandes

L'article saisi doit être un article non livrable et non facturable.

Le caractère 36 de ses données diverses doit être positionné à O.

Le montant TTC de l'acompte ou de l'avance est saisi dans la zone prix

Après chaque calcul de facture, la table fac7 (Facturation réelle) ou pfac7 (Facture de simulation) est alimentée avec les lignes des commandes facturées.

Paramètres associés

SPECIFIQUE

Une édition commerciale simplifiée peut être obtenue en créant des notes de type EDC sur une entité de sous-devis.

Type et code | NTS EDC
Libellé long | Notes commerciales

Cette fonction est accessible depuis les programmes blv_ed1, acr, facn et dco_c

Non-édition de lignes de commande dans l'édition de factures

SPECIFIQUE - Permet aussi le regroupement des lignes de factures sur une seule ligne reliées sur paramétrage d'un TSC.

Créer un TSC EDI comme suit :

Libellé long | Editable (O/N)
Notes | Caractère 1: Z Caractères 2 à 60: Paramétrage standard des TSC: zone ic_char3_1 (O/N)

Suspension de TVA commande

Pour activer la suspension de TVA, so_options[31] = O.

La gestion de la suspension de TVA au niveau de la commande ne nécessite aucun paramétrage.

Dans le calcul de la facturation, le calcul de la suspension de TVA est activé si la commande est en suspension de TVA (Mode exonération de la commande à S).

  • Si la commande a son propre montant d'autorisation, elle est facturée tant que le montant n'est pas dépassé.
    Dès que son montant d'autorisation est dépassé, la commande n'est plus facturée.
    Pour que la commande soit à nouveau facturée, son montant d'autorisation doit être modifié.

  • Si la commande n'a pas son propre montant d'autorisation mais le client a un montant d'autorisation, elle est facturée tant que ce dernier n'est pas dépassé.
    Dès que le montant d'autorisation du client est dépassé, la commande n'est plus facturée.
    Pour que la commande soit à nouveau facturée, le montant d'autorisation du client doit être modifié ou son propre montant d'autorisation doit être créé.

  • Si la commande n'a pas son propre montant d'autorisation et le client n'a pas de montant d'autorisation, elle n'est pas facturée.

  • Si la commande est livrée et le bon de livraison a du port et de l'emballage, le contrôle de dépassement est fait sur le montant d'autorisation du client car ceux-ci ne peuvent pas être imputés à une commande (un bon de livraison peut livrer plusieurs commandes).

  • Si une commande a son propre montant d'autorisation et le client n'a pas de montant d'autorisation et si la commande est livrée et le bon de livraison a du port et de l'emballage, la commande n'est pas facturée tant qu'un montant d'autorisation du client supérieur au port plus l'emballage du bon de livraison n'est pas saisi.


Validation manuelle des livraisons pour facturation

Validation manuelle des livraisons pour facturation aid_fac

Paramètre de configuration

#CF FAC

ATTENTION : Ce module est incompatible avec la notion d'articles appairés. Il ne valide que les BL sur ligne de commande, la notion de séquence n'y existe pas.

Options

-Odl | La date du mouvement de stock généré est la date du bon de livraison et non la date du jour. Ce paramètre existe aussi sur blv.
-Ome | Mise à jour de l'entête de commande pour permettre la facturation d' une ligne facturable uniquement
-Opr | Mise à jour prix et unité de vente fichier produits (F6)
-Orf | Sélection de la totalité (par défaut, on sélectionne le reste à facturer)
-Orn | Déduction de la sortie normale générée par l'édition du BL de la sortie réserve générée par la commande en édition définitive des BL. Gestion du reliquat de réserve sur la commande.
-Orb | Suppression de la sortie réserve générée par la saisie du BL et création de la sortie normale avec comme type de mouvement celui de la sortie réserve en édition définitive des BL Si sortie normale déjà créée à la même date, on ne recrée pas le mouvement de sortie normale
-Osr | Pas de mise à jour du stock résultant lors de la mise à jour des stocks
-Ouv | Utilisation de l'unité de vente pour calculer le prix de vente issu du fichier mat/prod et le prix du mouvement de stock
-Osd | Ecrans de saisie sans décimales pour les champs Quantité
-Omq | Possibilité de modifier la quantité à facturer si ligne avec BL même si celui-ci a été édité en définitif
-Opm | Validation du Plus ou Moins (ouverture de l'écran de validation du Plus ou Moins par F14)
-Omt | Mise à jour (par la touche F15) de la zone paramétrée ec_tour de l'entête de commande)
-Oip | Interdit la saisie des zones relatives au port
-Om0 | Affichage d'un message d'avertissement Attention ! Prix de la ligne à zéro ! lorsque le prix de la ligne est à zéro.
-Ovf | Validation des articles uniquement facturable par le F8 TYC alpha1[31] = F

Valeur alpha 2

Caractères 1 à 3 | Libellé extra court de la zone paramétrée ec_tour de l'entête de commande, affiché sur l'écran de validation.
Caractères 4 à 6 | Valeur mise dans la zone paramétrée ec_tour de l'entête de commande si paramètre -Omt et touche F15 activée.
Caractère 7 | Type d'écran F7 détail de prix 1 Saisie sans marge stockée dans la table cde3 2 Saisie avec marge stockée dans la table cde3 3 Saisie avec marge et quantité sans décimales stockée dans la table cde7 4 Saisie avec marge et quantité avec décimales stockée dans la table cde7 5 Saisie sans marge et quantité sans décimales stockée dans la table cde7 6 Saisie sans marge et quantité avec décimales stockée dans la table cde7 7 Ecran de saisie F7 détail prix standard avec marge, prix de revient et quantités avec décimales, totalisation dans l'unité de la ligne de commande. Stocké dans cde7
Caractère 8 | Valeur par défaut du message de confirmation de la mise à jour des fichiers O La confirmation propose Oui N La confirmation propose Non (valeur par défaut)

Notes

S

3,60 Complément de sélection sur la table cde1

Ce complément de sélection peut être dynamique si l'on utilise les notes _CRIT_

Dans ce cas, une fenêtre de saisie s'ouvre pour que l'utilisateur saisisse la valeur souhaitée.

Mode de recherche des commandes

Dans le bandeau d'entête de la validation, 3 champs (Client, Dev, Cde) sont saisissables et non obligatoires.

1 des 3 champs doit toujours être saisi.

Si le champ Dev est renseigné, seules les commandes dans cette devise sont visualisées.

Si le champ Dev n'est pas renseigné ainsi que le champ Cde, seules les commandes dans la devise société sont visualisées.

Si le champ Dev n'est pas renseigné et que le champ Cde contient un numéro de commande, seule cette commande est visualisée quelque soit sa devise.

Si le champ Dev n'est pas renseigné et que le champ Cde ne contient pas un numéro de commande, seules les commandes dans la devise société sont visualisées.

Reste à facturer

La touche CONTROL-P qui permettait de le calculer et de le visualiser a été remplacée par CONTROL-Y comme dans la saisie et la visualisation des commandes clients.

Touches F1 et F2

Avant, pour les désactiver, on les remplaçait par les touches CONTROL-Y et CONTROL-U.

Maintenant, on les remplace par les touches F35 et F36.


v_fac Visualisation des factures

Visualisation des factures v_fac

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de facture

Exemple : -N[fe_fac]

Options triées

Oe4 | Ne tient pas compte de l'escompte pour le calcul du CA en commande
Ofr | Force la gestion proratisée pour les unités de forfait (UNI.num1 = 0) Cette option est prioritaire sur le paramètre UNI A1[23]. Plus de détails dans ce paramètre.
Oga | Génération de commande de type AVO - FAD (touche F17)
Ona | Numérotation annuelle
Or4 | Ne tient pas compte des remises pour le calcul du CA en commande
Osi | Visualisation des factures de simulation
Ota | Rupture sur l'adresse de livraison pour tous les clients Si l'option n'est pas mise, cela dépend de cl_param[20] = O. Cette option est utilisée dans la génération des commandes de type AVO - FAD (Option -Oga - Touche F17)

Valeur alpha 2

A2[1,3] | Code du mot de passe pour la génération de cde de type AVO - FAD
A2[4,6] | Type de notes à recopier (table cde3)
A2[7,12] | Type et code du paramètre de lancement du calcul de la facture

Notes

ACCES_CDE_TYC_ | 15,17 TYC de commande (ex : AVO, FAD...) 21,26 Type et code du paramètre de lancement de la visu de commande (exemple #SAAVO)
ARTICLE_EMBALLAGE | 21,35 Code article de l'emballage - Facultatif Exemple : EMBALLAGE
ARTICLE_PORT_NON_TAX | 21,35 Code article du port non taxable - Facultatif Exemple : PORT_NTX 36,38 Code TVA du port non taxable - Obligatoire si caractères 21 à 35 renseignés Le taux du code TVA doit être à 0. Exemple : 2
ARTICLE_PORT_TAX | 21,35 Code article du port taxable - Facultatif Exemple : PORT_TAX
COMPTEUR_TYC_ | 14,16 TYC de commande (ex :AVO, FAD...) 21,22 Compteur
FORCAGE_DATE_ECH_CON | 21 Forçage des dates d’échéance en mode consultation (O/N, N par défaut)
ORDER_BY_FACTURE | 21,60 Colonnes de tri pour la sélection des factures, séparées par une virgule Tables accessibles : Mode simulation (option Osi) : table pfac0 Mode normal : table fac0 Exemples Tri par client : ORDER_BY_FACTURE fe_cli Tri par client puis date : ORDER_BY_FACTURE fe_cli, fe_date L'instruction order by est ajoutée automatiquement par le programme, il ne faut donc pas la mettre sur ces notes.
S | 3,60 Complément de sélection sur la table fac0 (pour le programme G_v_fac.42r) Ce complément de sélection peut être dynamique si l'on utilise les notes _CRIT_ Dans ce cas, une fenêtre de saisie s'ouvre pour que l'utilisateur saisisse la valeur souhaitée.


Edition des relevés de factures

Edition des relevés de factures rel0

Options triées

Oa2 | Edition en mode affacturage
Oaf | Rupture sur le mode de règlement ou la date d'échéance ou l'adresse de facturation
Obp | Autorisation du basculement de la prise en compte de la périodicité de relevé
Ocp | Autorise l'affichage de la contre-valeur en Euros
Oea | L'échéance des avoirs est égale à la date de la pièce. (Par défaut elle est égale à la dernière échéance calculée de la dernière facture).
Oer | La date d'échéance du relevé est la date d'édition du relevé Si cette option est absente, calcul de la date prévisionnelle du relevé en fonction de la périodicité du client et calcul de la date d'échéance par rapport à cette date prévisionnelle.
Ofd | Saisie d'une fourchette de dates de sélection des factures
Oif | Initialisation du tableau des factures L'option Osf est activée automatiquement.
Ona | Numérotation annuelle (Voir valeur numérique 2)
Ore | Rupture sur le mode de règlement ou la date d'échéance (1 relevé par mode de règlement et date d'échéance)
Osf | Sélection de numéros de facture pour un client donné

Valeurs numériques

1 | Dans les éditions ou l'on édite des traites en pied de relevé, on indique ici un ajustement qui permet de faire varier horizontalement la position de la traite. Par défaut, la valeur d'ajustement est égale à 2.
2 | Numéro de compteur (nécessite l'option -Ona) Créer un compteur de type R :Numérotation, 1 ; Année/Mois, 0000 Exemple 00100001

Notes sur le paramètre de lancement

CR

3 à 60 Complément de requête sur la table fac2

Exemple

CR fp_fac matches 001*

Paramètre lié

Périodicité relevé


Edition des traites

Edition des traites tra0

Ce programme est remplacé par ed_traites.

Valeur numérique 1

Première colonne d'édition des traites sur relevés (2 par défaut)

Valeur numérique 2

Première colonne d'édition des traites sur factures (5 par défaut)

Options

-Oad | Supprime l'édition de l'adresse de la société
-Oaf | Edition de l'adresse de facturation du client si traites sur relevés du client si traites sur factures ancienne version de la facture si traites sur factures nouvelle version
-Occ | Désactive l'édition du code comptable client
-Od2 | Supprime l'édition de la zone cl_domb2 du fichier client
-Ofc | Edition des traites à partir des factures
-Olt | Edition de la liste des traites
-Onr | Supprime l'édition du RIB
-Opd | Supprime l'édition de la date de création de la traite
-Opl | Edition du numéro de facture ou de relevé
-Ofj | Edition de la forme juridique (au dessus du nom du client)
-Oa2 | Edition en mode affacturage
-Ort | Edition dans ref tiré
-Omf | Gestion des échéances multiples pour les factures
-Omr | Gestion des échéances multiples pour les relevés
-Oa4 | Edition des dates au format dd/mm/yyyy (au lieu de dd/mm/yy)
-Onp | Edition du numéro de pièce dans le référence tiré. Soit le numéro de facture, soit le numéro de relevé
-Oes | Edition du N° de SIREN client sur la traite

Valeur alpha2

Caractères 1 à 3 | Code de l'adresse secondaire traite (Exemple TRA) (Celle-ci est valable pour toutes les traites)
Caractère 4 | Edition du code représentant à cote du numéro de facture si celui-ci est édité. (à paramétrer uniquement pour les traites sur facture) (O/N N par défaut)
Caractères 5 à 6 | Longueur de la page pour les traites (24 par défaut) (Pourquoi pas donné par le #LP ?)
Caractères 7 à 8 | Longueur d'une traite en nombre de lignes

Remarque

Si la zone alpha2[1,3] du mode de règlement est égale à LCR, LCR est imprimé sur la traite


v_jdv Visualisation du journal des ventes

Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Tris Noms de zones autorisés

Options

Ocs | Si le calcul de surface avec TSC donne zéro, calculer la surface en utilisant les poids
Ofr | Force la gestion proratisée pour les unités de forfait (UNI.num1 = 0) Cette option est prioritaire sur le paramètre UNI A1[23]. Plus de détails dans ce paramètre.
Oh1 | Rechercher systématiquement l'historique de prix de revient sur la première ligne de commande
Opn | Force le calcul du poids net ligne et du poids net total (ne tient pas compte du paramètre so_options[27]).
Opz | Pas d'édition des .00 lorsque la valeur de la colonne est nulle
Osi | Voir les factures de simulation
Osu | Calcul des surfaces en utilisant les poids
Otp | Détail de TVA intracommunautaire/exportation par pays

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch (E/F) E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractère 14 | Edition en mode condensé (O/N, O par défaut)
Caractère 31 | Représentation d'une ligne N Une ligne par facture/avoir (par défaut) O Une ligne par ligne de facture/avoir
Caractère 32 | Edition récapitulatif en devise société (O/N)
Caractère 33 | Edition récapitulatif en EURO (O/N)
Caractère 34 | Edition récapitulatif en devise (O/N)
Caractères 35 à 37 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
Caractères 38 à 40 | Type paramètre catégorie vente. La valeur du type paramètre catégorie vente est entièrement libre (Exemple CVT). Voir documentation sur le type paramètre EXO.
Caractère 41 | Sélection multicritère complémentaire sur Agent entête et Agent ligne et Catégorie vente et code pays facturé (spécifique)
Caractère 42 | Gestion de l'agent de l'entête à blanc O Agent entête = Agent ligne si Agent entête à blanc N Agent entête = blanc si Agent entête à blanc (par défaut)
Caractère 43 | Gestion de l'agent de la ligne à blanc O Agent ligne = Agent entête si Agent ligne à blanc N Agent ligne = blanc si Agent ligne à blanc (par défaut)
Caractère 44 | Détail par catégorie de vente O/N (N par défaut)
Caractère 45 | Tri par composition commerciale (N/O) N Le tri par composition commerciale est positionné à true (par défaut) O Le tri par composition commerciale est positionné à false
Caractère 46 | Type de l'historique du prix de revient (hp_type de la table hist_pr) F par défaut Utilisé pour le calcul du prix du papier des dossiers de fabrication des factures (Colonne prix_papier)
Caractères 47 à 48 | Numéro de la zone de l'historique du prix de revient (hp_zxx de la table hist_pr) 1 à 15, 2 par défaut Utilisé pour le calcul du prix du papier des dossiers de fabrication des factures (colonne prix_papier)
Caractère 49 | Ajout du total débit et crédit dans le récapitulatif

Valeur alpha 3

Titre de la visualisation

VISUALISATION DU JOURNAL DES VENTES

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 11 | Touche F11 (O/N) Visualisation du récapitulatif en devise société
Caractère 12 | Touche F12 (O/N) Visualisation du récapitulatif en EURO
Caractère 13 | Touche F13 (O/N) Visualisation du récapitulatif en devise
Caractère 38 | Touche CONTROL-C (O/N) Calculatrice
Caractère 51 | Touche CONTROL-T (O/N) Visualisation des touches
Caractère 56 | Touche CONTROL-Z (O/N) Lancement de programmes

Notes

C_JOURNAL_LETTRAGE | 21,60 Codes journaux utilisés pour la recherche dans la table histo Jusqu'à 20 codes peuvent être précisés, sans séparateur, chaque code faisant 2 caractères. 1 seule ligne de notes autorisée Cette note existe aussi dans int_cpt
CLIPPED_LIGNE_EF | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
CODE_ENR_AVOIR | 21,60 Code d'enregistrement pour les avoirs
CODE_ENR_FACTURE | 21,60 Code d'enregistrement pour les factures
CODE_VENDEUR | 21,60 Code vendeur
FIN_FIC_1_T_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
MAJ_FLAG_INFO_C | Voir page dédiée Cette note permet de ne pas exporter de nouveau les mêmes lignes, lors de la prochaine exportation du journal des ventes.
SEP_VISU_TYPE_F_CHAR | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
TEXT_LIBRE_1_V_T_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier. Zones supplémentaires utilisables dans cette visu : – date – heure au format hh :mm – cpt1 compteur. Celui-ci s'incrément depuis la zone numérique 1 du paramètre de lancement. – espace*α où α est un nombre entier (exemple : %espace*10% créera 10 espaces) – nb_avoir_tot nombre total d'avoirs – nb_facture_tot nombre total de factures – mtt_avoir montant total des avoirs – mtt_facture montant total des factures
TITRE_VISU_TYPE_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

Ordres de tri disponibles

1 | code_cli | Code Client
2 | date_fac | Date Facturation
3 | type_fac | Type Facture/Avoir
4 | num_fac | Numéro Facture/avoir
5 | mode_exo | Mode Exonération TVA
6 | mois_fac | Mois Facturation
7 | code_cpt | Code Comptable Client
8 | num_cde | Numéro Commande
9 | num_blv | Numéro Bon Livraison
10 | code_fam | Code Famille
11 | code_sfm | Code Sous-Famille
12 | code_art | Code Article
13 | ctg_cli | Code Catégorie client
14 | ctg_vte | Code Catégorie vente
15 | nat_mvt | Nature Mouvement
16 | code_dev | Code Devise
17 | code_age | Code Agent entête commande
18 | code_agl | Code Agent ligne commande
19 | code_pays | Code Pays facturé
20 | n_sfm_comcar | Sous-Famille Composition Technique
21 | nom_client | Nom Client
22 | date_ech | Date échéance
23 | n_fam_comcar | Famille Composition Technique
24 | n_fam_quacar | Famille Composition Commerciale
25 | n_sfm_quacar | Sous-Famille Composition Commerciale
26 | n_sect_geo | Secteur géographique
27 | n_activ_cli | Activité client
28 | n_code_reg | Code regroupement représentant
29 | n_date_regl | Date de règlement
30 | c_cs1 | Code statistique 1
31 | c_cs2 | Code statistique 2
32 | c_cs3 | Code statistique 3
33 | c_cs4 | Code statistique 4
34 |  | Catégorie du client final (cli.cl_cat de cde1.ec_cli_final)
35 | c_cli_final | Client final
36 |  | Origine du client facturé (cli.cl_origine)
37 | agent_client | Code agent du client facturé (cli.cl_repr)
38 |  | Numéro de ligne de facture / Avoir
39 |  | Code du 1er composant de l'article facturé

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Entête facture

Ligne facture

Pied de facture

Entête commande

Ligne commande

Entête bon de livraison

Ligne bon de livraison

Tiers

Toutes les zones de la fiche client final sont accessibles en préfixant les zones cl_ par f_

Par exemple, le nom du client final sera f_cl_nom.

Adresses secondaires

Client final

Toutes les zones de la fiche adresse secondaire du client final sont accessibles en préfixant les zones c2_ par f_

Par exemple, le code postal du client final sera f_c2_codp.

Adresse de facturation

Toutes les zones de la fiche adresse de facturation (fe_adf) sont accessibles en préfixant les zones c2_ par adf_

Exemple : adf_c2_adr1 : 1ère ligne de l'adresse de facturation

Adresse de livraison

Toutes les zones de la fiche adresse de livraison (fe_adl) sont accessibles en préfixant les zones c2_ par adl_

Exemple : adl_libl_c2_ech : Libellé long de l'échéance de l'adresse de livraison

Package Matières/Articles/Produits

- Les noms de zones peuvent être tels quels,

- Les noms de zones peuvent être précédés de x_ où x peut prendre les valeurs de 1 à 5 (voir les Particularités dans le package).

- On peut remplacer la chaîne mp_ par la chaîne comp1_mp_ pour avoir les données du 1er composant (code article commençant par P) de l'article facturé si celui-ci est un ensemble, sinon de l'article facturé lui-même.
Exemple
V Composant*comp1_mp_code*15**
Les TSC spécifiques à cet article (1er composant de l'article facturé, sinon l'article facturé lui-même) peuvent être appelés en utilisant l'origine de clé LC_AP.

ainsi que la zone suivante : coef_conv

Package Cadencements de livraison prévisionnels

Ligne facture en devise société

Ligne facture en EURO

Ligne facture en devise

Pied de facture en devise société

Pied de facture en EURO

Pied de facture en devise

Zones particulières au droit de timbre

Entête du devis

Historique du prix de revient

Autres zones

Entête facture

fe_soc | Code société
fe_fac | Numéro facture/avoir
fe_cli | Code client
nom_fe_cli | Nom client
fe_date | Date de facturation
fe_adl | Code adresse de livraison
ville_fe_adl | Ville adresse de livraison
nom_fe_adl | Nom du client adresse de livraison
fe_adf | Code adresse de facturation
ville_fe_adf | Ville adresse de facturation
nom_fe_adf | Nom du client adresse de facturation
fe_mrg | Mode règlement
libc_fe_mrg | Libellé court mode règlement
libl_fe_mrg | Libellé long mode règlement
fe_ech | Code échéance
libc_fe_ech | Libellé court code échéance
libl_fe_ech | Libellé long code échéance
fe_cpt | Code comptable
fe_siret | Numéro identification TVA et SIRET
fe_fadavo | Numéro facture/avoir de rattachement
fe_maj_vp | Code mise à jour Volupilot
fe_ident_cpta_aux | Numéro identification comptabilité auxiliaire
fe_dev | Code devise
libc_fe_dev | Libellé court code devise
libl_fe_dev | Libellé long code devise
fe_cours_dev | Cours de la devise de la facture/avoir
pays_fe_adf | Code pays de facturation
libc_pays_fe_adf | Libellé court du pays de facturation
libl_pays_fe_adf | Libellé long du pays de facturation
fe_tx_commission | Taux de commission de l'adresse de livraison de l'entête de facture

Lignes de facture

1) Toutes les zones du package

2) Les zones suivantes :

zc1_fl_unvent | Valeur 1 code unité de vente
zc1_fl_ctva | Valeur 1 code TVA
zc1_fl_unvent_au | Valeur 1 code unité de vente du plus ou du moins
libc_fl_unvent_au libl_fl_unvent_au | Libellé court du code unité de vente du plus ou du moins Libellé long du code unité de vente du plus ou du moins

Pied de facture

fp_soc | Code société
fp_fac | Numéro facture/avoir
fp_enr | Numéro enregistrement
fp_date | Date de facturation
fp_af | Type facture/avoir (F Facture – A Avoir)
fp_taux | Taux en devise société
fp_base | Base en devise société
fp_base_euro | Base en EURO
fp_base_dev | Base en devise
fp_mont | Montant en devise société
fp_mont_euro | Montant en EURO
fp_mont_dev | Montant en devise
fp_transf | Code transfert en comptabilité
fp_traeff | Code transfert dans les effets
fp_datech | Date d'échéance. Ne pas utiliser. Voir date_echeance_1
fp_user | User

Entête commande

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
ville_ec_ada | Ville adresse réception
ec_adf | Code adresse facturation
ville_ec_adf | Ville adresse facturation
ec_adl | Code adresse livraison
ville_ec_adl | Ville adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_acc_euro | Acompte en EURO
ec_acc_dev | Acompte en devise
ec_pnt | Port non taxable en devise société
ec_pnt_euro | Port non taxable en EURO
ec_pnt_dev | Port non taxable en devise
ec_pht | Port taxable en devise société
ec_pht_euro | Port taxable en EURO
ec_pht_dev | Port taxable en devise
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accuse de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facture
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande
ec_cli_final nom_ec_cli_final ville_ec_cli_final_adr | Code du client final de la commande Nom du client final de la commande Ville correspondante à l'adresse du client final de la commande (principale ou secondaire)
ec_tx_commission | Taux de commission de l'adresse de livraison de l'entête de commande

Ligne commande

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Numéro ligne commande
lc_prod | Code article
lib_lc_prod | Désignation article (Fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (Ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandee
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteliv_reelle | Quantité réellement livrée
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_prx_euro | Prix unitaire vente en EURO
lc_prx_dev | Prix unitaire vente en devise
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code TVA
libc_lc_tva | Libellé court code TVA
libl_lc_tva | Libellé long code TVA
zc1_lc_tva | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_deldep | Date de départ au plus tard
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (non utilisée)
lc_colis | Nombre colis
lc_prxcli | Prix client en devise société
lc_prxcli_euro | Prix client en EURO
lc_prxcli_dev | Prix client en devise
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
ville_lc_adl | Ville adresse livraison
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_plus_euro | Prix unitaire vente au plus en EURO
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_prx_moins_euro | Prix unitaire vente au moins en EURO
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_prx_rvt_euro | Prix unitaire revient en EURO
lc_prx_rvt_dev | Prix unitaire revient en devise
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_prx_rvt_r_euro | Prix unitaire revient réel en EURO
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1. Fenêtre Revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_annu | Ligne commande annulée
lc_cs1, libc_lc_cs1, libl_lc_cs1 | Code statistique 1 Libellés court et long
lc_cs2 libc_lc_cs2, libl_lc_cs2 | Code statistique 2 Libellés court et long
lc_cs3 libc_lc_cs3, libl_lc_cs3 | Code statistique 3 Libellés court et long
lc_cs4 libc_lc_cs4, libl_lc_cs4 | Code statistique 4 Libellés court et long
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long
lc_tx_commission | Taux de commission de l'adresse de livraison de la ligne de commande

Entête bon de livraison

b1_soc | Code société
b1_blv | Numéro de bon de livraison
b1_cli | Code client
nom_b1_cli | Nom client
b1_ref | Référence du bon de livraison
b1_sitp | Code zone paramétrable
libc_b1_sitp | Libellé court code zone paramétrable
libl_b1_sitp | Libellé long code zone paramétrable
b1_tport | Type de port
libc_b1_tport | Libellé court type de port
libl_b1_tport | Libellé long type de port
b1_pht | Port taxable en devise société
b1_pht_euro | Port taxable en EURO
b1_pht_dev | Port taxable en devise
b1_tvap | Code TVA port taxable
libc_b1_tvap | Libellé court code TVA port taxable
libl_b1_tvap | Libellé long code TVA port taxable
zc1_b1_tvap | Valeur 1 code TVA port taxable
b1_trsp | Mode de transport
libc_b1_trsp | Libellé court mode de transport
libl_b1_trsp | Libellé long mode de transport
b1_trans | Code transporteur
nom_b1_trans | Nom transporteur
b1_tadr | Type d'adresse de livraison
b1_adrl | Code adresse livraison
ville_b1_adrl | Ville adresse livraison
b1_datl | Date bon de livraison
b1_adrf | Code adresse facturation
ville_b1_adrf | Ville adresse facturation
b1_col | Nombre de colis total
b1_poids | Poids total
b1_montant | Coût en devise société
b1_montant_euro | Coût en EURO
b1_montant_dev | Coût en devise
b1_com | Observation
b1_edit | Bon de livraison édité
b1_embal | Type d'emballage
b1_cembal | Coût emballage en devise société
b1_cembal_euro | Coût emballage en EURO
b1_cembal_dev | Coût emballage en devise
b1_tvae | Code TVA emballage
libc_b1_tvae | Libellé court code TVA emballage
libl_b1_tvae | Libellé long code TVA emballage
zc1_b1_tvae | Valeur 1 code TVA emballage
b1_type_vehicule | Type de véhicule
libc_b1_type_vehicule | Libellé court type de véhicule
libl_b1_type_vehicule | Libellé long type de véhicule
b1_vehicule | Véhicule (Immatriculation)
b1_heure_depart | Heure de départ
b1_no_groupage | Numéro groupage
b1_date_chargem | Date de chargement
b1_lieu_rgt1 | Magasin destination
libc_b1_lieu_rgt1 | Libellé court magasin destination
libl_b1_lieu_rgt1 | Libellé long magasin destination
b1_ordre_chargt | Ordre de chargement
b1_devise | Code devise
libc_b1_devise | Libellé court code devise
libl_b1_devise | Libellé long code devise
b1_annu | Bon de livraison annule
b1_transitaire | Code transitaire
nom_b1_transitaire | Nom transitaire
b1_tx_commission | Taux de commission de l'adresse de livraison de l'entête de bon de livraison

Ligne bon de livraison

b2_soc | Code société
b2_blv | Numéro de bon de livraison
b2_lig | Numéro de ligne de bon de livraison
b2_cde | Numéro de commande
b2_ligcde | Numéro de ligne de commande
b2_ligseq | Numéro de séquence de la ligne de commande
b2_qte | Quantité livrée facturable (cumulable)
b2_qteliv | Quantité livrée
b2_poids | Poids
b2_nbcolis | Nombre de colis
b2_excolis | Nombre d'exemplaires
b2_nummvt | Numéro de mouvement de stock
b2_fact | Ligne de bon de livraison facturée (O/N)
b2_solde | Ligne de commande soldée (O/N)
b2_type_livraison | Type de livraison
b2_annu | Ligne de bon de livraison annulée

Ligne facture en devise société

mtt_ligne_brut_ht mtt_ligne_livrable mtt_ligne_frais | Montant brut HT de la ligne mtt_ligne_livrable = mtt_ligne_brut_ht si mp_param[2] = N mtt_ligne_frais = = mtt_ligne_brut_ht si mp_param[2] = O
mtt_ligne_brut_ht_au | Montant brut HT du + ou du - de la ligne
mtt_ligne_brut_ht_tt | Montant brut HT total de la ligne
mtt_ligne_remise | Montant remise de la ligne
mtt_ligne_remise_au | Montant remise du + ou du - de la ligne
mtt_ligne_remise_tt | Montant remise total de la ligne
mtt_ligne_escompte | Montant escompte de la ligne
mtt_ligne_escompte_au | Montant escompte du + ou du - de la ligne
mtt_ligne_escompte_tt | Montant escompte total de la ligne
mtt_ligne_net_ht | Montant net HT de la ligne
mtt_ligne_net_ht_au | Montant net HT du + ou du - de la ligne
mtt_ligne_net_ht_tt | Montant net HT total de la ligne
mtt_ligne_tva | Montant TVA de la ligne
mtt_ligne_tva_au | Montant TVA du + ou du - de la ligne
mtt_ligne_tva_tt | Montant TVA total de la ligne
mtt_ligne_ttc | Montant TTC de la ligne
mtt_ligne_ttc_au | Montant TTC du + ou du - de la ligne
mtt_ligne_ttc_tt | Montant TTC total de la ligne

Ligne facture en EURO

mtt_ligne_brut_ht_euro | Montant brut HT de la ligne
mtt_ligne_brut_ht_au_euro | Montant brut HT du + ou du - de la ligne
mtt_ligne_brut_ht_tt_euro | Montant brut HT total de la ligne
mtt_ligne_remise_euro | Montant remise de la ligne
mtt_ligne_remise_au_euro | Montant remise du + ou du - de la ligne
mtt_ligne_remise_tt_euro | Montant remise total de la ligne
mtt_ligne_escompte_euro | Montant escompte de la ligne
mtt_ligne_escompte_au_euro | Montant escompte du + ou du - de la ligne
mtt_ligne_escompte_tt_euro | Montant escompte total de la ligne
mtt_ligne_net_ht_euro | Montant net HT de la ligne
mtt_ligne_net_ht_au_euro | Montant net HT du + ou du - de la ligne
mtt_ligne_net_ht_tt_euro | Montant net HT total de la ligne
mtt_ligne_tva_euro | Montant TVA de la ligne
mtt_ligne_tva_au_euro | Montant TVA du + ou du - de la ligne
mtt_ligne_tva_tt_euro | Montant TVA total de la ligne
mtt_ligne_ttc_euro | Montant TTC de la ligne
mtt_ligne_ttc_au_euro | Montant TTC du + ou du - de la ligne
mtt_ligne_ttc_tt_euro | Montant TTC total de la ligne

Ligne facture en devise

mtt_ligne_brut_ht_devise | Montant brut HT de la ligne
mtt_ligne_brut_ht_au_devise | Montant brut HT du + ou du - de la ligne
mtt_ligne_brut_ht_tt_devise | Montant brut HT total de la ligne
mtt_ligne_remise_devise | Montant remise de la ligne
mtt_ligne_remise_au_devise | Montant remise du + ou du - de la ligne
mtt_ligne_remise_tt_devise | Montant remise total de la ligne
mtt_ligne_escompte_devise | Montant escompte de la ligne
mtt_ligne_escompte_au_devise | Montant escompte du + ou du - de la ligne
mtt_ligne_escompte_tt_devise | Montant escompte total de la ligne
mtt_ligne_net_ht_devise | Montant net HT de la ligne
mtt_ligne_net_ht_au_devise | Montant net HT du + ou du - de la ligne
mtt_ligne_net_ht_tt_devise | Montant net HT total de la ligne
mtt_ligne_tva_devise | Montant TVA de la ligne
mtt_ligne_tva_au_devise | Montant TVA du + ou du - de la ligne
mtt_ligne_tva_tt_devise | Montant TVA total de la ligne
mtt_ligne_ttc_devise | Montant TTC de la ligne
mtt_ligne_ttc_au_devise | Montant TTC du + ou du - de la ligne
mtt_ligne_ttc_tt_devise | Montant TTC total de la ligne

Pied de facture en devise société

mtt_brut_ht | Montant brut HT
mtt_remise_ligne | Montant remise ligne
mtt_remise_entete | Montant remise entête
mtt_remise_totale | Montant remise totale
mtt_escompte | Montant escompte
mtt_port_taxable | Montant port taxable
mtt_port_non_taxable | Montant port non taxable
mtt_port_total | Montant port total
mtt_emballage | Montant emballage
mtt_net_ht_taxable | Montant net HT taxable
mtt_net_ht_total | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1 | Montant TVA 1
base_tva_1 | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2 | Montant TVA 2
base_tva_2 | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3 | Montant TVA 3
base_tva_3 | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4 | Montant TVA 4
base_tva_4 | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5 | Montant TVA 5
base_tva_5 | Base TVA 5
mtt_tva | Montant TVA
taux_par_1 | Taux Taxe Parafiscale 1
mtt_par_1 | Montant Taxe Parafiscale 1
base_par_1 | Base Taxe Parafiscale 1
taux_par_2 | Taux Taxe Parafiscale 2
mtt_par_2 | Montant Taxe Parafiscale 2
base_par_2 | Base Taxe Parafiscale 2
taux_par_3 | Taux Taxe Parafiscale 3
mtt_par_3 | Montant Taxe Parafiscale 3
base_par_3 | Base Taxe Parafiscale 3
taux_par_4 | Taux Taxe Parafiscale 4
mtt_par_4 | Montant Taxe Parafiscale 4
base_par_4 | Base Taxe Parafiscale 4
taux_par_5 | Taux Taxe Parafiscale 5
mtt_par_5 | Montant Taxe Parafiscale 5
base_par_5 | Base Taxe Parafiscale 5
mtt_taxe_parafiscale | Montant Taxe Parafiscale
mtt_frais_expedition | Montant frais expédition
mtt_acompte | Montant acompte
mtt_ttc | Montant TTC

Pied de facture en EURO

mtt_brut_ht_euro | Montant brut HT
mtt_remise_ligne_euro | Montant remise ligne
mtt_remise_entete_euro | Montant remise entête
mtt_remise_totale_euro | Montant remise totale
mtt_escompte_euro | Montant escompte
mtt_port_taxable_euro | Montant port taxable
mtt_port_non_taxable_euro | Montant port non taxable
mtt_port_total_euro | Montant port total
mtt_emballage_euro | Montant emballage
mtt_net_ht_taxable_euro | Montant net HT taxable
mtt_net_ht_total_euro | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1_euro | Montant TVA 1
base_tva_1_euro | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2_euro | Montant TVA 2
base_tva_2_euro | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3_euro | Montant TVA 3
base_tva_3_euro | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4_euro | Montant TVA 4
base_tva_4_euro | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5_euro | Montant TVA 5
base_tva_5_euro | Base TVA 5
mtt_tva_euro | Montant TVA
taux_par_1 | Taux Taxe Parafiscale 1
mtt_par_1_euro | Montant Taxe Parafiscale 1
base_par_1_euro | Base Taxe Parafiscale 1
taux_par_2 | Taux Taxe Parafiscale 2
mtt_par_2_euro | Montant Taxe Parafiscale 2
base_par_2_euro | Base Taxe Parafiscale 2
taux_par_3 | Taux Taxe Parafiscale 3
mtt_par_3_euro | Montant Taxe Parafiscale 3
base_par_3_euro | Base Taxe Parafiscale 3
taux_par_4 | Taux Taxe Parafiscale 4
mtt_par_4_euro | Montant Taxe Parafiscale 4
base_par_4_euro | Base Taxe Parafiscale 4
taux_par_5 | Taux Taxe Parafiscale 5
mtt_par_5_euro | Montant Taxe Parafiscale 5
base_par_5_euro | Base Taxe Parafiscale 5
mtt_taxe_parafiscale_euro | Montant Taxe Parafiscale
mtt_frais_expedition_euro | Montant frais expedition
mtt_acompte_euro | Montant acompte
mtt_ttc_euro | Montant TTC

Pied de facture en devise

mtt_brut_ht_devise | Montant brut HT
mtt_remise_ligne_devise | Montant remise ligne
mtt_remise_entete_devise | Montant remise entête
mtt_remise_totale_devise | Montant remise totale
mtt_escompte_devise | Montant escompte
mtt_port_taxable_devise | Montant port taxable
mtt_port_non_taxable_devise | Montant port non taxable
mtt_port_total_devise | Montant port total
mtt_emballage_devise | Montant emballage
mtt_net_ht_taxable_devise | Montant net HT taxable
mtt_net_ht_total_devise | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1_devise | Montant TVA 1
base_tva_1_devise | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2_devise | Montant TVA 2
base_tva_2_devise | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3_devise | Montant TVA 3
base_tva_3_devise | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4_devise | Montant TVA 4
base_tva_4_devise | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5_devise | Montant TVA 5
base_tva_5_devise | Base TVA 5
mtt_tva_devise | Montant TVA
taux_par_1 | Taux Taxe Parafiscale 1
mtt_par_1_devise | Montant Taxe Parafiscale 1
base_par_1_devise | Base Taxe Parafiscale 1
taux_par_2 | Taux Taxe Parafiscale 2
mtt_par_2_devise | Montant Taxe Parafiscale 2
base_par_2_devise | Base Taxe Parafiscale 2
taux_par_3 | Taux Taxe Parafiscale 3
mtt_par_3_devise | Montant Taxe Parafiscale 3
base_par_3_devise | Base Taxe Parafiscale 3
taux_par_4 | Taux Taxe Parafiscale 4
mtt_par_4_devise | Montant Taxe Parafiscale 4
base_par_4_devise | Base Taxe Parafiscale 4
taux_par_5 | Taux Taxe Parafiscale 5
mtt_par_5_devise | Montant Taxe Parafiscale 5
base_par_5_devise | Base Taxe Parafiscale 5
mtt_taxe_parafiscale_devise | Montant Taxe Parafiscale
mtt_frais_expedition_devise | Montant frais expedition
mtt_acompte_devise | Montant acompte
mtt_ttc_devise | Montant TTC

Zones particulières au droit de timbre

mtt_droit_timbre | Montant droit de timbre en devise société
mtt_droit_timbre_euro | Montant droit de timbre en EURO
mtt_droit_timbre_devise | Montant droit de timbre en devise

Entête du devis

Toutes les zones de la table fle_2 + les zones suivantes :

D'une manière générale, toutes les zones numériques et dates font partie du dictionnaire et sont cumulables.

des_l2_code_prod | Désignation du produit
nom_l2_client | Nom du client
nom_l2_transporteur | Nom du transporteur
z1_l2_etat | Zone numérique 1 de l'état du devis
z1_l2_type_prix | Zone numérique 1 de remise de prix

ainsi que les libellés court et long des zones ci-contre -> Le libellé court est préfixé lbc_, tandis que le libellé long est préfixé libl_. Exemple Le libellé court de la zone l2_bareme est libc_l2_bareme, le libellé long est libl_l2_bareme | l2_bareme | Barème
 | l2_civilite | Civilité du correspondant
 | l2_devise | Devise
 | l2_deviseur | Deviseur
 | l2_env_matiere | Environnement matière
 | l2_env_operation | Environnement opération
 | l2_etat | Etat du devis
 | l2_fabricant | Fabricant
 | l2_motif | Motif
 | l2_representant | Représentant
 | l2_sce_calcul | Scénario de calcul
 | l2_signature | Signataire
 | l2_site | Site
 | l2_suiv | Suivi
 | l2_tit_corres | Titre de correspondant
 | l2_type_dev | Type de devis
 | l2_type_finition | Finition
 | l2_type_port | Type de port
 | l2_type_prix | Remise de prix
 | l2_type_prod | Type de processus

Remarque : Le numéro de devis/sous-devis est récupéré dans l'ordre suivant :

• Zone texte de l'entête de commande Suivant notre devis N°…

• Zone issue de de l'entête de commande

• Recherche du dernier devis portant sur l'entête de commande en cours

• Récupération du numéro de devis/sous-devis associé à la ligne de commande en cours

Exemple de paramétrage pour construire une colonne calculée d'édition du prix de vente standard affiché dans l'écran de récapitulatif de prix du devis multi-métiers

Le prix de vente standard est calculé comme suit :

(Prix de vente devisé + Montant de la commission) * Prix pour / Quantité devisée

_VAR_a l2_px_pv

_VAR_b l2_c_pv

_VAR_c l2_pour

_VAR_d l2_qtedev

_CALC_01 ab+c*d/

Voir les notes commençant par _VAR_ dans le paramètre #VI.

Historique du prix de revient

Table hist_pr

Pour accéder aux zones d'historique de prix de revient, faire précéder le nom de la zone par le type d'enregistrement et d'un tiret (exemple : F-, X-)

Exemples

F-hp_z1 : Zone historique numérique 1 du type d'enregistrement historisé F (niveau ligne de commande)

X-hp_z2 : Zone historique numérique 2 du type d'enregistrement historisé X (niveau ligne de facture)

Les types d'enregistrement T, X et Y sont enregistrés au niveau de la ligne de facture + ligne de commande, tous les autres types le sont au niveau de la ligne de commande.

hp_a1 lib_hp_a1 nom_hp_a1 libc_hp_a1 libl_hp_a1 | Zone historique alphanumérique 1 Désignation Nom Libellé court Libellé long
hp_annule | Code annulation
hp_c1 libc_hp_c1 libl_hp_c1 | Code zone paramétrable Libellé court Libellé long
hp_cde | Numéro dossier
hp_cl2 | Code adresse de livraison
hp_client nom_hp_client | Code client Nom client
hp_cs1 libc_hp_cs1 libl_hp_cs1 | Code statistique 1 Libellé court Libellé long
hp_cs2 libc_hp_cs2 libl_hp_cs2 | Code statistique 2 Libellé court Libellé long
hp_cs3 libc_hp_cs3 libl_hp_cs3 | Code statistique 3 Libellé court Libellé long
hp_cs4 libc_hp_cs4 libl_hp_cs4 | Code statistique 4 Libellé court Libellé long
hp_d1 | Zone historique date 1
hp_date | Date clôture dossier
hp_datecde | Date dossier
hp_dep libc_hp_dep libl_hp_dep | Code département Libellé court Libellé long code département
hp_fam libc_hp_fam libl_hp_fam | Code famille Libellé court Libellé long
hp_lcde | Numéro ligne dossier
hp_libelle | Libellé libre
hp_lig_fac | Numéro ligne facture
hp_num_fac | Numéro facture
hp_produit lib_hp_produit | Code article Désignation article (Fiche article)
hp_ref | Référence dossier
hp_repr libc_hp_repr libl_hp_repr | Code représentant Libellé court Libellé long
hp_seq | Numéro de séquence du dossier
hp_sfm libc_hp_sfm libl_hp_sfm | Code sous-famille Libellé court Libellé long
hp_soc | Code société
hp_type | Type historique
hp_var_prod | Code variante de production
hp_z1 hp_z2 hp_z3 hp_z4 hp_z5 hp_z6 hp_z7 hp_z8 hp_z9 hp_z10 hp_z11 hp_z12 hp_z13 hp_z14 hp_z15 | Zones historiques numériques 1 à 15 - Accessibles dans le dictionnaire des données

Autres zones

mp_fam_comcar | Famille de la composition technique (Code)
libc_mp_fam_comcar | Famille de la composition technique (Libellé court)
libl_mp_fam_comcar | Famille de la composition technique (Libellé long)
mp_sfm_comcar | Sous-famille de la composition technique (Code)
libc_mp_sfm_comcar | Sous-famille de la composition technique (Libellé court)
libl_mp_sfm_comcar | Sous-famille de la composition technique (Libellé long)
mp_fam_quacar | Famille de la composition commerciale (Code)
libc_mp_fam_quacar | Famille de la composition commerciale (Libellé court)
libl_mp_fam_quacar | Famille de la composition commerciale (Libellé long)
mp_sfm_quacar | Sous-famille de la composition commerciale (Code)
libc_mp_sfm_quacar | Sous-famille de la composition commerciale (Libellé court)
libl_mp_sfm_quacar | Sous-famille de la composition commerciale (Libellé long)
surf_uni_brute | Surface unitaire brute
surf_m2_brute | Surface m2 brute
surf_uni_nette | Surface unitaire nette
surf_m2_nette | Surface m2 nette
poids_net_ligne | Poids net de la ligne facture/avoir
poids_net_total | Poids net de la facture/avoir
date_echeance_1 | Date échéance 1
date_echeance_2 | Date échéance 2 si échéances multiples
date_echeance_3 | Date échéance 3 si échéances multiples
date_echeance_4 | Date échéance 4 si échéances multiples
mode_exoneration | Mode exonération. Type paramètre EXO.
libc_mode_exoneration | Libellé court mode exonération
libl_mode_exoneration | Libellé long mode exonération
mois_facturation | Mois de facturation
categorie_vente | Catégorie de vente. Type paramètre paramétré en alpha2[38,40] du paramètre de lancement. Voir documentation sur le type paramètre EXO.
libc_categorie_vente | Libellé court catégorie de vente
libl_categorie_vente | Libellé long catégorie de vente
nature_mouvement | Nature du mouvement. Caractères 16 à 19 de la valeur alpha 4 du TYC
pourcen_prime_fidelite | Pourcentage de prime de fidélité (RFA) Recherche dans les tarifs sur tiers et type de tarif RFA
pourcen_prime_activite | Pourcentage de prime d'activité (PA ) Recherche dans les tarifs sur articles et type de tarif PA.
le_signe | 1 si facture –1 si avoir
prix_papier | Prix du papier des dossiers de fabrication de la facture ATTENTION : n'est ni affiché ni édité si A2[31] = O (1 ligne par ligne de facture/avoir)
using | Voir #VI
lst_bl | Liste des BL de fac6. Présenté sous la forme suivante : BL xxxxxx DATE jj/mm/aaaa QTE xxxx PROD aaaaaaaaaaaa
date_liv | Date de livraison Dans le cas d'un ensemble, on prend la date de livraison du premier BL sinon dans le cas d'un article normal on prend la date du BL.
numero_bl | Numéro de BL Dans le cas d'un ensemble, s'il n'y a qu'un BL dans fac6, on prend le numéro de BL. Sinon ce champ renverra une valeur vide.
code_enr | Code d'enregistrement (les notes CODE_ENR_AVOIR et CODE_ENR_FACTURE obligatoire)
date_jour | Date du jour
code_vendeur | Code vendeur (note CODE_VENDEUR obligatoire)
siren_cli_f | Numéro de SIREN du client facturé
nic_cli_f | Numéro NIC du client facturé
signe_piece | Signe de la pièce Si c'est un avoir, le signe sera - (moins) Si c'est une facture, le signe sera + (plus)
mrg_factocic | Moyenne de paiement FACTOCIC + date échéance
type_piece_factocic | Type de pièce : Si c'est un avoir, le type sera AVO. Si c'est une facture, le type sera FAC.
mode_paiement | Mode de paiement EUROFACTOR Si c'est une facture payée par traite, la valeur sera T, sinon la valeur sera A.
poids_uni_net poids_uni_brut poids_brut_ligne | Poids unitaire net en kg (calculé à partir du TSC 202) Poids unitaire brut en kg (calculé à partir du TSC 201) Poids brut de la ligne en kg (calculé à partir du TSC 201)


Outil de mise à jour du numéro et de la ligne du BL de la table fac1

Outil de mise à jour du numéro et de la ligne du BL de la table fac1 outil_maj_no_bl_lig_bl_fac1

Cet outil remet à jour le numéro et la ligne du bon de livraison de la table fac1 des factures clients créées par l'importation des factures clients Prophée.

Options

Osi

Simulation du traitement - La table des lignes de factures (fac1) n'est pas mise à jour.

Valeur alpha 2

1,3 | Type des notes de stockage des données des factures clients Prophée - Obligatoire Doit être identique à importation_prophee_fac_cli, A2[4,6] Exemple STO
4 | Racine des TSC d'importation des bons de livraison clients Prophée- Obligatoire Doit être identique à importation_prophee_fac_cli, A2[12] Exemple +

Notes

SUP_REQ_FAC1

Supplément de requête sur la table fac1 - Obligatoire

Exemple

and fl_fac matches "03*"


Importation des règlements dans VoluPack

Importation des règlements dans VoluPack G_importe_reglements

Remonter les règlements des factures dans VoluPack, à partir d'un fichier paramétrable de type .csv, construit en fonction du logiciel comptable.

Actuellement, cela n'est géré que pour une interface SAGE 100.

Option payante CDE 12

Les 2 nouvelles zones de l'entête de facture, à savoir fe_pourc_reglement et fe_date_reglement (tables fac0 et pfac0) sont disponible dans le package standard des visus, notamment pour le journal des ventes ainsi que pour l'affichage du détail BL.Facture.

Une nouvelle zone fer_mtt_reglement représentant le montant TTC déjà réglé est également disponible pour ces mêmes modules.

Une fonctionnalité permettant de consulter le détail des règlements est accessible depuis le journal des ventes et la visualisation des factures (Touche F15 détail règlement).

Sur le module v_fac, cette touche est liée à la permission TOU VFAC_F15.

Valeur alpha 2

A2[1] | Numéro de format du fichier d'import 1 SAGE 100 – Grand livre des tiers 2 Qualiac S Standard VSW (par défaut)
A2[2] | Délimiteur dans le fichier importé de type csv (point-virgule, pipe, ... Par défaut : point-virgule)

Notes

CODE_SOC_QUALIAC | 21,23 Code société à traiter Dans l'interface type QUALIAC, le fichier contient des données provenant de différentes sociétés.
HISTO_DIR | 21,60 Nom du répertoire dans lequel les fichiers traités seront déplacés après traitement. Lors de ce déplacement on leur ajoutera une extension horodatée au format : .YYYYMMDD-HHMMSS.ok pour un import sans erreur .YYYYMMDD-HHMMSS.err pour un import avec erreur Dans ce répertoire, on créera systématiquement un fichier de rapport doté du même nom mais ayant une extension .log à la place de .ok ou .err. Exemple Directory historique : /u/atlas/echange_compta/histo/ Dans ce répertoire, on trouvera après traitement réussi, deux fichiers : reglement.csv.20090706-121153.ok
IMPORT_FILE_MASK | Masque décrivant le masque des fichiers d'import à lire. Exemple : /u/atlas/echange_compta/reglement*.csv Tous les fichiers correspondants à ce masque (reglement*.csv) seront lus dans l'ordre alpha des noms de fichiers. Le masque peut très bien ne spécifier qu'un seul nom de fichier. Exemple : /u/atlas/echange_compta/reglement.csv


Facturation Efficial

Facturation Efficial efficial_phase_1

SPECIFIQUE

Génération à partir de la table des entêtes de facture (fac0) d'un fichier contenant des enregistrements de type

- T100 : Entreprise client

- T130 : Réseau entreprise client

- T200 : Etablissement client

- T210 : Réseau établissement client

- T290 : Réalisés (DEB, F.A, FAL et FIN)

Pour le descriptif du fichier, consulter les documents

O:\Clients\Dore Emballage\Technique\Etudes\Efficial\EffiCial_Interface Phase 1 V7_Etude VSW.doc

O:\Clients\Maine Emballages\Technique\Etudes\EffiCial_Interface Phase 1 V6.doc

Voir aussi : dans la visu des commandes clients, zones permettant de récupérer les codes clients utilisés par Efficial.

Valeurs numériques

1

Coefficient correcteur

Utilisé pour calculer la surface de la ligne de facture à partir du devis (A2[9] = 3)

Options

Occ | Code client commun au groupe au lieu du code client si renseigné
Ocs | Calcul de la valeur "Spread" (Zone T290-REA-MT-SPREAD) et de la valeur "Contribution benefit" (Zone T290-REA-MT-CONTRIB) Voir TSC EFF
Oee | Eclatement de l'escompte en plusieurs comptes (Taxable, export, suspension de TVA, intracommunautaire et exonération de TVA)
Oep | Eclatement du port non taxable en plusieurs comptes (Export, suspension de TVA, intracommunautaire et exonération de TVA) L'option Ogp doit être activée.
Oer | Eclatement de la remise en plusieurs comptes (taxable, export, suspension de TVA, intracommunautaire et exonération).
Ofm | Le compte de vente n'est pas recherché sur l'article facturé.
Ogp | Gestion des ports taxable et non taxable
Ola | Utilisation des longueur et largeur de la ligne de commande pour le calcul du coefficient de conversion L'option Ocs doit être activée. Utilisé dans le calcul du coût d'achat des matières saisies.
Ore | Prise en compte de la remise entête pour le calcul du montant de la ligne de commande d'achat L'option Ocs doit être activée. Utilisé dans le calcul du coût d'achat des matières saisies.
Orl | Prise en compte de la remise ligne pour le calcul du montant de la ligne de commande d'achat L'option Ocs doit être activée. Utilisé dans le calcul du coût d'achat des matières saisies.
Osi | Simulation. Pas de mise à jour du champ fe_transfert_ext de la table des entêtes de facture (table fac0)
Otc | Transcodification des comptes comptables Voir A2[11,16]

Valeur alpha 2

A2[1]

Code site. Obligatoire - Tableau de bord du multisite

A2[2,4]

Code paramètre de la configuration du transfert des factures. Facultatif. TRF par défaut

A2[5,7]

Code TSC du code désignation de l'article facturé. Obligatoire.

Le code désignation de l'article facturé est saisi dans le 1er champ de 3 caractères (champ ic_char3_1 de la table info_c).

Le code désignation de l'article facturé est saisi sur l'article ou sur le FEFCO.

A2[8]

Mode d'alimentation du code client

Méthode1 (par défaut)

Pour l'adresse principale, caractères 2 à 5 du code client suivi de 00.

Pour les adresses secondaires, caractères 2 à 5 du code client suivi des caractères 2 à 3 du code adresse

Méthode2

Pour l'adresse principale, caractères 1 à 5 du code client suivi de 0.

Pour les adresses secondaires, caractères 1 à 5 du code client suivi du caractère de recodification (1 à 9, A à Z et a à z) du code adresse

Celui-ci est sauvegardé dans la zone ic_char3_1 du TSC A1C du code adresse du client

Le dernier caractère de recodification des codes adresses du client est sauvegardé dans la zone ic_char3_1 du TSC A1C du client

A2[9]

Mode d'alimentation des poids / surface

1 à partir de la nomenclature (valeur par défaut)

2 à partir des données de la facture

3 à partir des données de la facture pour le poids et du devis pour la surface (voir valeur numérique 1)

A2[10]

Mode d'alimentation du prix de revient

1 à partir de sta_com (valeur par défaut)

2 valeur 0

A2[11,16]

Type et code du paramètre de transcodification des comptes comptables

Obligatoire si option Otc

Notes

CODE_EXP_EFFICIAL_N | 21 Code taxe taxable. Exemple : 1
CODE_EXP_EFFICIAL_O | 21 Code taxe export Exemple : 3
CODE_EXP_EFFICIAL_S | 21 Code taxe suspension de TVA Exemple : 0
CODE_EXP_EFFICIAL_I | 21 Code taxe intracommunautaire Exemple : 9
CODE_EXP_EFFICIAL_E | 21 Code taxe exonération Exemple : 4
FAM_POUR_COUT_PROD | 21,23 Code famille (Type paramètre FAM) Pourcentage à retirer du montant SPREAD pour obtenir le coût de production L'option Ocs doit être activée. Utilisé dans le calcul du coût de production.
FIC_RACINE_EFFICIAL | 21,60 Racine du nom du fichier Efficial Phase 1. Obligatoire A la racine du nom du fichier Efficial Phase 1, on ajoute la date et l'heure ainsi que l'extension .txt.
FIC_ANOM_EFFICIAL | 21,60 Nom du fichier des anomalies Efficial Phase 1. Facultatif. Si renseigné, l'extension .ano est ajoutée au nom du fichier des anomalies. Si non renseigné, le nom du fichier des anomalies prend le même nom que le fichier Efficial Phase 1 avec .ano comme extension.
FIC_TRACE_EFFICIAL | 21,60 Nom du fichier des traces Efficial Phase 1. Facultatif. Si renseigné, l'extension .tra est ajoutée au nom du fichier des traces. Si non renseigné, le nom du fichier des traces prend le même nom que le fichier Efficial Phase 1 avec .tra comme extension.
SUP_REQ_CDF2 | 21,60 Supplément de requête des lignes de commande d'achat à prendre en compte Facultatif - L'option Ocs doit être activée. Utilisé dans le calcul du coût d'achat des matières saisies.
SUP_REQ_COMPO_BOIS | 21,60 Code composition correspondant à la palette Sera exclus du calcul poids surface Exemple : Q-BOIS
SUP_REQ_COMPO_MONT | 21,60 Code composition correspondant au montage On redescendra d'un niveau de nomenclature pour le calcul poids surface Exemple : Q-MONTAGE
SUP_REQ_FAB0_CAM | 21,60 Supplément de requête des lignes de production du dossier de fabrication (fab0) à prendre en compte Facultatif - L'option Ocs doit être activée. Utilisé dans le calcul du coût d'achat des matières saisies Exemple and (f0_prod not matches "P*" and f0_prod not matches "X*")
SUP_REQ_FAB0_CT | 21,60 Supplément de requête des lignes de production du dossier de fabrication (fab0) à prendre en compte Facultatif - L'option Ocs doit être activée. Utilisé dans le calcul du coût de transport Exemple and f0_prod = "XTRANSPORT"
SUP_REQ_FAB1 | 21,60 Supplément de requête des lignes d'opération du dossier de fabrication à prendre en compte Facultatif - L'option Ocs doit être activée. Utilisé dans le calcul du coût de production
SUP_REQ_FAC0 | 21,60 Supplément de requête des factures (fac0) à transférer. Facultatif
SUP_REQ_FAC0_DER_FAC | 21,60 Supplément de requête pour rechercher la dernière facture transférée (fac0). Facultatif
SUP_REQ_FBI_ASYNC | 21,60 Supplément de requête des entêtes et des lignes de commande (cde1 et cde2) à prendre en compte Facultatif - L'option Ocs doit être activée. Utilisé dans le cas des fabrications asynchrones pour rechercher la FBI
SUP_REQ_FLE_IMP | 21,60 Supplément de requête des entités du devis (table fle_imp) à prendre en compte dans le calcul de la surface à partir du devis - Facultatif Utilisé pour calculer la surface de la ligne de facture à partir du devis (A2[9] = 3) Exemple : and fi_typ_ent = "STD"
SUP_REQ_MAT_PRD_NEG | 21,60 Supplément de requête pour déterminer si l'article facturé est un produit négoce (mat). Facultatif
TYC_CDE_PDS_SURF | 21,23 Type de commande ne mettant pas à jour le poids et la surface (Type paramètre TYC) Une note par type de commande

Paramètres nécessaires

DEV

Note CODE_DEV_EFFICIAL Code devise de transaction

ECH

Note CODE_ECH_EFFICIAL Numéro de condition de règlement

FAB

A4[1,2] Code assistante commerciale

FAM

Note CODE_FAM_EFFICIAL Code désignation avant assemblage

MRG

Note CODE_MRG_EFFICIAL Code moyen de règlement

PAY

Note CODE_PAY_EFFICIAL Code pays selon norme ISO3166

POR

A1[4,6] Code INCOTERM

Note CODE_POR_EFFICIAL Code port

REP

A3[1,4] Code agent commercial

SFM

Note CODE_SFM_EFFICIAL Code désignation de l'article facturé si l'article est un produit de type négoce

TRS

Note CODE_TRS_EFFICIAL Code moyen de transport

UNI

Note CODE_UNI_EFFICIAL Code unité de vente

#CF BLV

Note S : Complément de select paramétrable pour la recherche des tarifs transporteurs

Facultatif - L'option Ocs doit être activée.

Utilisé dans le calcul du coût de transport

#CF TRF

TRF ou toute autre valeur indiquée en A2[2,4]

Valeur numérique 1 : Valeur à ajouter au numéro de compte pour obtenir le compte export (hors CEE)

Valeur numérique 2 : Valeur à ajouter au numéro de compte pour obtenir le compte suspension de TVA

A1[1,8] Numéro de compte de vente par défaut. Obligatoire

A1[9,16] Numéro de compte de port taxable. Obligatoire si option Ogp

A1[25,32] Numéro de compte de remise. Obligatoire

A1[33,40] Numéro de compte d'escompte. Obligatoire

A1[41,48] Numéro de compte de port non taxable ou de port non taxable export (option Oep). Obligatoire si option Ogp

A3[1,8] Valeur à ajouter au numéro de compte pour obtenir le compte intracommunautaire

A3[25,32] Numéro de compte de port intracommunautaire. Obligatoire si options Ogp et Oep.

A3[33,40] Numéro de compte de port suspension de TVA. Obligatoire si options Ogp et Oep.

A4[17,24] Valeur à ajouter au numéro de compte pour obtenir le compte exonération

A4[25,32] Numéro de compte de port exonération de TVA. Obligatoire si options Ogp et Oep.

XXX YYY

où XXX = A2[11,13] et YYY = A2[14,16]

Exemple de type et de code pour ce paramètre : #TR TCC (Transcodification des Comptes Comptables)

Notes sur ce paramètre :

Caractères 01 à 08 : Compte général VoluPack - Exemple 70100000

Caractère 09 : Type de client (Caractère 6 de la zone de données diverses de la fiche client) - Facultatif

Caractères 11 à 20 : Compte général SAP - Exemple 70110000


Transfert des factures clients en comptabilité

Transfert des factures clients en comptabilité tr_fcnn_vl

Options Notes du paramètre de lancement Paramètres associés

Ce programme utilise #CF TRF ou #CF XXX (XXX étant paramétré dans la note CONFIG_TRANSFERT).

Voir aussi les codes statistiques.

Voir la fiche société pour déterminer le type de comptabilité.

Voir les différents formats de fichier :

  • COBYS

  • COTRE

  • LD Compta

  • SAGE 500

  • Sage 100

  • AGRESSO

  • Sage 1000 ou générique

Valeurs numériques

N1 | Code forçage du poids passé à la fonction de calcul du poids unitaire et de la surface unitaire ans le cas d'un article cartonnier, le code forçage n'est pas utilisé. Le poids unitaire est celui de la ligne de commande et la surface unitaire est calculée avec la longueur et la largeur de la ligne de commande. Dans le cas d'un article non cartonnier, le code forçage est utilisé. Les surfaces unitaires brute et nette sont prises dans les info_c. Surface unitaire brute : CIC N55 Surface unitaire nette : CIC N57 0 Mode normal Les poids unitaires brut et net sont pris dans les info_c. Poids unitaire brut : CIC N54 Poids unitaire net : CIC N56 1 On force la récupération du poids depuis la ligne de commande (lc_poids) (valeur par défaut) 2 On force la récupération du poids depuis la fiche article (mp_poids)

Options triées

ATTENTION : pour la compta SAGE 100 (type J), il faut obligatoirement mettre les options Otl et Ocf.

Sinon, l'interface ne transfère pas le détail des lignes de factures.

Oaa | COTRE - AGRESSO - Gestion des acomptes et avances
Oaf | Transfert des factures cédées Fonctionne uniquement avec les comptabilités 1 et J (type 1 et 2). Option payante BAS-32 Voir le TSC #AF, zone ic_char3_2, ainsi que les notes dédiées dans le #CF TRF.
Ocd | COTRE - Ajout du centre dominant de la ligne de commande de la 1ère ligne de la facture Remplacement du code représentant client par le code représentant de la ligne de commande de la 1ère ligne de la facture
Ocf | Centralisation par facture Transfert des cumuls par compte par facture/avoir. Sinon, une ligne d'écriture par ligne de facture Entraîne automatiquement l'option Oct.
Ocl | Désactivation du contrôle de la longueur du code client
Ode | Précise si la TVA est une TVA sur les débits ou une TVA sur les encaissements dans le libellé de l'écriture en plus du nom du client.
Odf | Horodatage du fichier de transfert à la date et heure du transfert
Odh | Lorsqu'on initialise le fichier de transfert, celui-ci est sauvegardé avec le même nom en rajoutant la date et l'heure du transfert. Ceci permet de conserver tous les fichiers de transfert.
Oee | VOLUCOMPTA - VALC - Eclate l'escompte en : Escompte export Escompte intracommunautaire Escompte en suspension de TVA
Oen | Transferts des encaissements
Oer | Permet de prendre la date d'échéance sur le relevé (s'il en existe un)
Oes | Ouverture d'un écran de sélection (Client et date de facturation) à la place de l'écran de saisie de l'année et du mois de transfert
Oet | Prend le mode d'exonération paramétré sur la TVA (alpha 2[37])
Of0 | Transfert des factures à 0
Ofc | VoluCompta / VALC - Facturation comptoir.
Ofl | SAGE 100 - Ajout du numéro de facture dans le libellé de chaque écriture
Ofm | Transfert par famille d'article sans examen du fichier produits pour la recherche du compte de vente
Ofr | Force la gestion proratisée pour les unités de forfait (UNI.num1 = 0) Cette option est prioritaire sur le paramètre UNI A1[23]. Plus de détails dans ce paramètre.
Oi2 | Permet de ne pas avoir les messages de confirmation au lancement du programme Attention, dans ce cas, il n'y a pas de sauvegarde de l'ancien fichier de transfert !
Oia | Initialisation automatique du fichier de transfert
Oif | Pas d'initialisation du fichier de transfert (en mode batch)
Old | VoluCompta / VALC - Permet la génération de lignes en devises.
Olk | Positionnement d'un fichier lock obligatoire Voir la note FICH_LOCK
Olt | SAGE 100 - Précise le libellé de l'entête de la commande (ec_texte) dans l'écriture du compte client uniquement
Omd | COTRE - Montants en devise de la facture et apparition du code devise en fin de ligne On transfère les factures en montant devise.
Oml | Libellé de l'écriture = numéro de facture + nom du client
Ont | Conversion du fichier de transfert des clients de Unix en DOS
Ope | VoluCompta / VALC - Eclate le port non taxable en Port export Port intra-communautaire Port en suspension de TVA
Opu | VoluCompta / VALC - Purge automatique du fichier de transfert
Ore | VoluCompta / VALC - Eclate la remise en Remise export Remise intra-communautaire Remise en suspension de TVA
Os1 | Section Zone paramétrée : #CF TRF A4[15,16] Sous-famille de la ligne de commande par défaut
Os2 | TOUTES COMPTAS SAUF AGRESSO ET JDE - Met la dernière section analytique sélectionnée de chaque facture sur les lignes TVA et taxe parafiscale de cette même facture. Os2 a priorité sur Os3.
Os3 | TOUTES COMPTAS SAUF AGRESSO ET JDE - On affecte la valeur du mois de la facture dans la section, uniquement pour les lignes de TVA et taxe parafiscale.
Osc | Met la dernière section analytique sélectionnée de chaque facture sur la ligne TTC (client) de cette même facture.
Ose | Supprime la ligne d'escompte Pas de transfert du montant de l'escompte. Si un % d'escompte est saisi, il sera déduit des HT de la facture.
Osi | Mode simulation. Les factures ne sont pas marquées comme transférées.
Osm | SAGE 100 - Ajout des zones 14 à 18 (devises)
Osn | Met la dernière section analytique sélectionnée de chaque facture sur les lignes remise, escompte et port de cette même facture.
Osr | Supprime la ligne de remise Pas de transfert du montant de la remise Si un % de remise est saisi, il sera déduit des HT de la facture.
Ost | Sauvegarde de l'affectation comptable par ligne de facture dans des TSC Cela permet de les afficher dans une visualisation par exemple (v_jdv). Voir les TSC SHT et SVT.
Ot2 | SAARI ANCIENNE VERSION (code I) - Mise à jour de l'enregistrement dans fac2 de type A
Otf | Transfère la totalité des factures à transférer sans saisie de la période
Otl | Transfert par ligne de facture/avoir (recherche du compte de vente à chaque ligne de facture/avoir) Sinon, transfert global de la facture dans le compte de vente par défaut

Valeur alpha 2

Caractères 1 & 2

SAGE 100 - Nombre maximum de caractères pour la raison sociale du fichier société (30 maxi)

Notes du paramètre de lancement

CS

3 à 60 Complément de select sur fac2.

Exemple

CS and fp_fac matches “001*”

A utiliser avec précaution, car le complément ne peut être fait que sur la table fac2 et l'enregistrement 4.

CONFIG_TRANSFERT

21, 23 Code du paramètre de configuration du transfert (par défaut #CF TRF)

DERNIERE_EXECUTION

Contrôle du temps passé entre 2 transferts

21,25 Nombre d'heures minimal entre 2 transferts (si 0, il n'y a pas de contrôle, mais le message de confirmation indiquera la date de dernier transfert)

26 Type de contrôle (B : bloquant ; C ou blanc : Confirmation)

31,40 Date du dernier transfert (automatiquement renseignée – Ne pas saisir)

42,46 Heure du dernier transfert (automatiquement renseignée – Ne pas saisir)

Le transfert des factures en comptabilité s'accompagne d'une contrainte forte :

On ne peut transférer une facture qu'une seule fois dans la comptabilité.

Cette contrainte oblige les utilisateurs à respecter une procédure assez stricte d'importation du fichier généré par Volume aussitôt après sa création au risque de ne pas avoir toutes les factures dans la comptabilité.

Pour empêcher qu'un transfert vienne écraser les données du transfert précédent car l'utilisateur, interrompu dans sa procédure, exécute 2 fois de suite le transfert, on met en place un paramétrage permettant de spécifier en heures le délai minimal qui doit être respecté entre 2 transferts.

FICH_LOCK

21,60 Chemin et non du fichier lock (Voir option Olk)

FICH_TRAN

Paramétrage du fichier de transfert

11 à 60 Chemin complet et nom du fichier transfert. Exemple /u/atlas/atlas.dbs/tr_facval

Le chemin est paramétrable dans 3 endroits différents ! La priorité est la suivante :

1) Notes commençant par FICH_TRAN du paramètre de lancement de tr_fcnn_vl (c'est ici)

2) Notes commençant par FICH_TRAN du #CF_TRF

3) #CF TRF A2[1,52]. (à éviter car limité à 52 caractères, alors que les notes peuvent être cumulées pour permettre des chemins d'accès longs)

FIN_DE_MOIS

21 Top fin de mois (O/N, N par défaut) - Compta PN uniquement

PARAM_COMPTE_CS1_

21,31 Type de notes pour la recherche du paramétrage particulier pour Interface des ventes avec la comptabilité FININFOR

Valeur par défaut : COMPTE_CS1_

Paramètres utilisés

#CF ATL

alpha3[29,30]

Longueur du compte client, si option Ocl (par défaut : 8)

#CF FAC

alpha1[22,24]

Délai en jours pour l'escompte sur règlement

alpha1[25,26]

Taux d'escompte légal mensuel (si non trouvé sur TSC ESR)

Notes COLLECTIF_CLIENT_

Compta REEL : N° de compte collectif client, selon le régime de TVA.

#CF FEX

Valeur alpha 4

Comptes de frais d'expédition

COTRE et AGRESSO principalement (mais non exclusivement)

#CF TRF

toutes

Paramétrage principal

CAT

Valeur numérique 2

Delta à appliquer au compte de vente ou d'achat en fonction de la catégorie du tiers dans le transfert en comptabilité

CPR

Notes commençant par le code TVA

Correspondance entre code TVA et code article pour les frais d'expédition.

Ce paramètre est lié à #CF FEX.

DEV

alpha2[1,3]

COBYS & VOLUCOMPTA - VALC - Code devise pour le transfert en comptabilité

alpha2[4,5]

SAGE100 interface 2 - Numéro de devise pour le transfert en comptabilité.

ECH

Valeurs numériques 1 et 2

Nombre de jours de crédit pour l'échéance (si taux non trouvé sur TSC ESR)

EXO

alpha1[3,4]

Correspondance mode d'exonération pour JDE

FAM

alpha3[51,52]

Correspondance Unité de mesure de la quantité (JDE)

Notes SAGE100...

SAGE100 (Angleterre) - Notes pour le transfert vers la comptabilité

Notes ANA_SAGE_100

SAGE100 interface 2 - Paramétrage de la ventilation analytique

FEX

Notes TVAV

Paramétrage des comptes de vente des frais d'expédition par code TVA et catégorie de client

MAT

alpha2[16,19]

Section analytique pour transfert comptabilité SAGE ligne 500

MRG

alpha1[1,3]

Code règlement correspondant en comptabilité pour le transfert des tiers en comptabilité

PER

alpha1[1]

Si option Oer - Code calcul périodicité (Semaine, Mois, Période)

valeur numérique 1

Si option Oer - Jour du mois (utilisé uniquement si périodicité mensuelle).

SFM

SIT

alpha1[46,50]

Code société JDE

alpha3[1,8]

REEL - Rubrique analytique pour comptabilité

alpha3[15,20]

SAGE500 : Code journal des ventes pour le transfert en comptabilité

alpha3[21,23]

SAGE500 : Code site pour le transfert en comptabilité

alpha3[24]

SAGE500 : Code société pour le transfert en comptabilité

alpha3[31,38]

Numéro d'ID du compte pour JDE

TOP

valeurs numériques 1 & 2

Année et mois en cours

TSC ESR

valeur numérique 1

Escompte paramétré sur le client (type de clé F)

Si le taux d'escompte n'est pas trouvé sur le TSC ESR, un taux d'escompte légal mensuel est paramétré globalement sur #CF FAC.

Ce taux d'escompte est paramétré en #CF FAC A1[25,26]

Le délai en jours est paramétré en #CF FAC A1[22,24].

La durée est calculée à partir de l'échéance de l'entête de commande (on prend les valeurs numériques 1 et 2 sur ECH).

TVA

valeur numérique 1

Pourcentage de TVA

alpha1[1,8]

Code comptable pour le transfert en compta de la TVA des factures clients.

Voir aussi ci-dessous TVA alpha2[41,48] quand le compte de TVA est différent s'il s'agit d'un avoir.

alpha1[9,16]

alpha1[35,42]

alpha1[43,50]

alpha2[9,16]

alpha2[28,35]

Code comptable pour le transfert en compta

de la taxe parafiscale des factures clients

idem en suspension de TVA

idem en intracommunautaire

idem en export

idem en exonération

alpha1[34]

TVA sur les débits ou les encaissements

alpha2[37]

Mode d'exonération de la ligne de facture ou d'avoir et de la ligne de frais d'expédition (N, O, S, I, E)

alpha2[38,40]

COBYS : Code TVA utilisé pour le transfert des factures d'achat en comptabilité

alpha2[41,48]

SAGE100 interface 2 : Compte comptable de TVA pour les avoirs.

Le compte de TVA est différent s'il s'agit d'un avoir (en Belgique).

alpha2[49,52]

Code zone de TVA pour JDE

Note COMPTE_TVA_

REEL : code TVA et mode d'application de la TVA.

Note _TAUX_TAXE_JDE_

Taux de taxe pour JDE

UNI

valeur numérique 1

Unité de vente


Transfert clients vers VoluCompta

Transfert des tiers dans VoluCompta tr_cli_vln

Options Remarques Valeur alpha 2 Valeur alpha 3

Options triées

-Oaf | Transfert des adresses de facturation
-Opt | Pas de transfert du numéro de téléphone afin de ne pas écraser le numéro de téléphone saisi en comptabilité
-Otc | Pas de transfert des clients
-Otf | Pas de transfert des fournisseurs
-Otm | Modification des tiers autorisée. Sinon création des nouveaux uniquement
-Otp | Pas de transfert des prospects
-Oul | Création d'un fichier d'extraction des tiers (unload d'une table temporaire à l'image de la table tiers de la comptabilité VoluCompta)

Remarques

On ne peut pas transférer les tiers et les adresses de facturation en même temps. Il faut prévoir 2 options au menu.

Vérifier que les modes de règlement (MRG) ont été bien paramétrés (Valeur alpha mode de règlement correspondant dans VoluCompta des positions 1 à 3).

Valeur alpha 2

Caractères 1 à 20 | Si base SE indiquer le chemin complet et le nom de la base de données VoluCompta sans l'extension dbs Exemple /u1/valc/demo Si base ONLINE : indiquer seulement le nom complet de la base de données sans l'extension dbs Exemple demo Remarque ATTENTION à la priorité de la directory et de la base de VoluCompta (mettre 777)
Caractères 31 à 40 | Nom du fichier d'extraction des tiers

Valeur alpha 3

Caractères 1 à 2 | Section analytique des clients (NN par défaut) Mettre SN
Caractères 3 à 4 | Section analytique des fournisseurs (NN par défaut)
Caractères 5 à 6 | Section analytique des prospects (NN par défaut)
Caractère 7 | Zone statistique 1 Code zone de la table cli - voir les zones possibles
Caractère 8 | Zone statistique 1 Position début de la zone
Caractère 9 | Zone statistique 1 Position fin de la zone
Caractère 10 | Zone statistique 2 Code zone de la table cli - voir les zones possibles
Caractère 11 | Zone statistique 2 Position début de la zone
Caractère 12 | Zone statistique 2 Position fin de la zone
Caractère 13 | Zone statistique 3 Code zone de la table cli - - voir les zones possibles
Caractère 14 | Zone statistique 3 Position début de la zone
Caractère 15 | Zone statistique 3 Position fin de la zone
Caractères 16 à 18 | Type du paramètre pour la recherche des programmes à proposer dans le menu paramétré des transferts ou à lancer en automatique. Exemple MET

Notes

_SUP_REQ_SUR_CLI

21 à 60 Supplément de requête sur la table cli


Transfert des tiers dans Sage ligne 100

Transfert des tiers dans Sage ligne 100 tr_cli_sage

Options triées

Oaf

Transfert des adresses de facturation. Incompatible avec -Oet

Oet

Uniquement les tiers créés ou modifiés. Incompatible avec -Oaf

(Sélection dans la table evt_trans mise à jour en création / modification des tiers en liaison avec les champs contrôlables)

Ogd

Gestion des devises

Si cette option est activée, le code devise de la fiche client dans VoluPack sera mis à jour dans la fiche tiers de la comptabilité.

Attention ! Cela a des conséquences sur les règlements dans la comptabilité.

Voir paramétrage des devises

Oia

Lors du transfert des clients vers Sage, nous envoyons la raison sociale du client, ainsi que son nom abrégé (ces 2 champs sont saisis dans la fiche client).

Il peut arriver que le nom abrégé n'ait rien à voir avec la raison sociale du client.

Cette option permet d'envoyer, dans le nom abrégé transmis à Sage, les 17 premiers caractères de la raison sociale

Ont

Conversion du fichier de transfert en DOS

Ori

Contrôle de cohérence de la clé RIB

Orq

Code représentant VoluPack dans champ qualité SAGE

Otc

Pas de transfert des clients

Otf

Pas de transfert des fournisseurs

Otp

Pas de transfert des prospects

Valeur alpha 2

Nom du fichier de sortie (Exemple : /tmp/tiers_sage.txt)

Notes

CODE_DEVISE | 21,23 Code devise VoluPack 25,26 Numéro de devise correspondant dans Sage Exemple Euro = 1 Dollar US = 2 etc
COMPTE_COLLECTIF | 21,23 Préfixe des numéros de comptes 25,37 Compte collectif correspondant 39 Longueur du préfixe du numéro de compte (3 par défaut) (0 : Pas de préfixe) 42 Type de tiers (C Client, F Fournisseur, P Prospect) [espace] : Pas de contrôle (valeur par défaut) Le premier collectif saisi par préfixe sera le collectif principal dans la comptabilité Sage. Exemples : COMPTE_COLLECTIF 41100000 0 -> Collectif principal COMPTE_COLLECTIF 41200000 0 COMPTE_COLLECTIF 401 40100000 3 COMPTE_COLLECTIF 10 41100000 2 COMPTE_COLLECTIF 40 40100000 2 F COMPTE_COLLECTIF 10 41100000 2 C
CS | 4,60 Complément de requête Ne fonctionne pas avec l'option -Oaf Exemple CS and cl_qualite = "OKO"
LONGUEUR_COMPTE | 21,23 Longueur des comptes (0 : pas de contrôle, 17 maxi) Exemple LONGUEUR_COMPTE 8
MODE_DE_REGLEMENT | 50 modes de règlement maximum 21,23 Code mode de règlement Volume 25,26 Code mode de règlement Sage Exemple MODE_DE_REGLEMENT CHQ 1 50 codes de mode de règlement maximum
_SUP_REQ_CLI2 | 21,60 Complément de select sur cli2 Exemple and c2_validite_adr = "COM"
VERSION | 21,23 Numéro de version (5 par défaut) Le code version 13 correspond à la version 15 et plus de SAGE


Transfert paramétrable des tiers vers la comptabilité

Transfert paramétrable des tiers vers la comptabilité tr_cli_cpt

Voir la fiche société pour déterminer le type de comptabilité.

Voir les différents formats de fichier :

  • COBYS

  • COTRE

  • LD Compta

  • SAGE 500

Options

Oet | Transfert des tiers dont une modification (création, modification ou suppression) a été détectée. Pour la trace des modifications sur la fiche tiers, voir la page Contrôle des champs dans la fiche tiers. Pour information, cette trace est stockée dans la table evt_trans. En l'absence de cette option, l'intégralité du fichier tiers est traité par la passerelle.
Oas | Transfert des adresses secondaires (table cli2) Les champs paramétrés et non renseignés dans l'adresse secondaire sont initialisés avec les valeurs du client principal.
Ova | Prise en compte du code validité adresse (type F)
Oea | En batch, le fichier est sauvegardé et épuré
Ods | On ne met pas le dernier séparateur
-B | Mode batch

Valeur alpha 2

Caractères 1 à 60

Nom du fichier de sortie

Notes

COL_ASS_CRE_xx | Transfert paramétrable des tiers vers la comptabilité 21,30 Avec xx un nombre compris entre 01 et 99. Numéro d'agrément associé à l'indice xx des colonnes liées à l'assurance-crédit. Nécessaire pour les colonnes qui commencent par ass_credit_xx_
F | 3,60 [Nom du champ]*[Taille]*[Using]* Le using n'est pas utilisé pour les champs de type chaîne. Dans le nom du champ, on peut aussi mettre comte_cp pour avoir le comté et le code postal. Voir ci-après la liste des champs paramétrables
GUILLEMET | 21 Présence de guillemets (O/N, N par défaut)
LONGUEUR_COMPTE | 21,22 Longueur du compte. Attention ! Pas de contrôle !
SEPARATEUR | 21 Séparateur de champ. Exemple : |
SUPREQCLI | 21,60 Supplément de requête sur les tiers. Exemple : and cl_cpf = "C"

Liste des champs paramétrables (notes commençant par F)

1) Tous les champs de table cli

2) Champs de la table trace (evt_trans)

et_date_creation | Date de la dernière mise à jour
et_type_action | Type de mise à jour C Création M Modification S Suppression

3) Champs spéciaux

ablanc

Champ à blanc

ass_credit_XX_YYYYYYYY

ass_credit_XX_montant

ass_credit_XX_cod_cotation

ass_credit_XX_libl_cotation

ass_credit_XX_libc_cotation

Transfert paramétrable des tiers vers la comptabilité

Avec XX un nombre compris entre 01 et 99 lié à la note COL_ASS_CRE_xx

Montant du crédit accordé

Code cotation risque (type CRI)

Libellé long de la cotation risque (type paramètre CRI)

Libellé court de la cotation risque (type paramètre CRI)

cl_dev

code_iso_cl_dev

Code ISO de la devise

cl_ech

libc_cl_ech

libl_cl_ech

fin_mois_cl_ech

jour_cl_ech

ech_compta_cl_ech

nombre_jours_cl_ech

Libellé court de l'échéance

Libellé long

Code fin de mois de l'échéance

Jour de l'échéance

Code échéance correspondant en comptabilité

Nombre de jours de l'échéance

cl_langue

code_iso_cl_langue

Code ISO de la langue

cl_mrg

mrg_compta_cl_mrg

Mode de règlement correspondant en comptabilité

cl_param_NN

NN représente le numéro d'indice de la zone cl_param (1 à 50)

cl_pays

libc_cl_pays

libl_cl_pays

code_iso_cl_pays

Libellé court du pays

Libellé long du pays

Code ISO du pays

cl_repr

libc_cl_repr

libl_cl_repr

telephone_cl_repr

Libellé court du représentant

Libellé long du représentant

Numéro de téléphone du code représentant

code_repr_anael

Code représentant correspondant en comptabilité ANAEL

comte_cp

comte_cp_pays

Comté + code postal (zones séparées par des espaces)

Comté + code postal + libellé court du pays (zones séparées par des espaces)

corres_type_NNN_nom_champ

NNN Représente le type de correspondant (champ co_tco)

nom_du_champ

co_type

co_civilite

co_nom

co_prenom

co_telph

co_telcop

co_email

nature_cpt_aux

Nature des comptes auxiliaires

CLT pour client

FRS pour fournisseur

numero_adresse_tiers

Chrono numéro d'adresse du tiers

rib_code_banque

rib_code_guichet

rib_numero_compte

rib_cle

Code banque du code RIB (caractères 1 à 5)

Code guichet du code RIB (caractères 6 à 10)

Numéro de compte du code RIB (caractères 11 à 21)

Clé du code RIB (caractères 22 et 23)

sicre

simaj

Siècle de création

0 si 1900

1 si 2000

Siècle de modification

0 si 1900

1 si 2000

siret_code_pays

siret_code_cle

siret_code_siren

siret_code_etablissement

Code pays du code identification TVA (caractères 1 et 2)

Code clé du code identification TVA (caractères 3 et 4)

Code SIREN du code identification TVA (caractères 5 à 13)

Code établissement du code identification TVA (caractères 14 à 18)

siret_par_pays

Pour le transfert des clients vers TOTEM, permet de tenir compte de la longueur du code paramétrée dans le pays du client (PAY A1[20,21])

Dans le cas d'un client FR, le pays étant paramétré avec la longueur de l'identifiant TVA sur 11 caractères, on transfère l'identifiant avec le code pays sur 13 caractères puis 1 blanc.

Dans le cas d'un client NL, le pays étant paramétré avec la longueur de l'identifiant TVA sur 12 caractères, on transfère l'identifiant avec le code pays sur 14 caractères.

taux_escompte

Taux d'escompte stocké dans la valeur numérique 1 du TSC ESR

today

Date du jour

TSC_CL_CL_XXX_Y

Infos complémentaires de l'adresse principale ou des adresses secondaires du tiers

où XXX = code du TSC (Ex: NAB, 202,...)

et Y = code de la zone

Le TSC de l'adresse principale est de la forme TSC_CL_CL_NAB_G

Le TSC des adresses secondaires est de la forme TSC_CL_C2_NAB_G

On remplace CL par C2 si on est en transfert d'adresses secondaires.

valeur_constante

Valeur constante saisie dans using

Champs spéciaux pour interface TOTEM

nom_correspondant | Nom du correspondant si titre correspondant = CPT, à blanc sinon
compte_general_associe | Compte collectif client : 411200 si catégorie client = GRR 181200 si catégorie client = VAL 411100 dans les autres cas
en_cours_autorise | En cours autorisé à la date du jour

Exemple de paramétrage

cl_param

#________Options supprimees.

# et : Uniquement les tiers crees ou modifies.

#___________________________________________________________

# Longueur du compte

LONGUEUR_COMPTE 00

# Complement de selection

SUPREQCLI and cl_cpf = "C"

SUPREQCLI and cl_code not matches "00000C"

SUPREQCLI and cl_code != "#SOC"

#SUPREQCLI and cl_code = '00685'

# Pas de guillement.

GUILLEMET N

# Separateur

SEPARATEUR |

# Definition du fichier interface

F cl_cpf*1**

F cl_code*6**

F valeur_constante*5*SIEGE**

F valeur_constante*5*SIEGE**

F cl_nom*30**

F cl_adr1*25**

F cl_adr2*25**

F cl_adr3*25**

F cl_codp*5**

F cl_vil*30**

F cl_pays*3***

F valeur_constante*8*CEDEX 01**

F cl_telph1*20**

F cl_telcop*20**

F cl_email*60***

F cl_exp*1**

F corres_typ_COM_co_tco*3***

F corres_typ_COM_co_civilite*3**

F corres_typ_COM_co_prenom*30***

F corres_typ_COM_co_nom*30***

F corres_typ_COM_co_telph*20***

F corres_typ_COM_co_telcop*20***

F corres_typ_COM_co_email*60***

F cl_mrg*3**

F libc_cl_ech*10***

F cl_siret*18**

F cl_param_10*1***


Interface de comptabilité

En position 91 à 98 du fichier d'import de SAP encours clients, il y a une date d'expiration du plafond des encours du client.

Si la date du jour est avant ou dans l'intervalle date expiration + délai de grâce, alors on n'applique pas de code blocage d'expiration.

Par contre, si la date du jour est supérieure à la date d'expiration + délai de grâce, alors un code blocage s'appliquera selon le paramétrage.

ATTENTION : le code blocage pour impayé reste prioritaire.

Interface de comptabilité int_cpt

Options Valeur alpha 2 Notes Descriptif du fichier importé

Ce module peut être exécuté en mode Batch.

Il récupère les infos comptables pour les reverser dans la table risque_detail.

Valeurs numériques

N1

Nombre de jours à ajouter à la date du jour pour obtenir la date d'échéance

Uniquement pour le type de fichier A

Options

Oac

Assurance crédit : suppression de toutes les autorisations (Permanentes, Temporaires, Supplémentaires) et intégration de nouvelles permissions selon le fichier intégré

Occ

Recherche du code client à partir de son code comptable (uniquement si type de fichier = 1)

Oft

Force le tri de lecture du fichier de données par numéro de ligne

Uniquement dans le cadre d'une base Oracle sous Windows

Ord

Génération de la table risque_detail

Orr

Les tables histo, echean et risque_detail ne sont pas réinitialisées.

Cela permet de lancer plusieurs fois l'intégration avec des fichiers d'import émanant de plusieurs comptabilités sans les réinitialiser pour le même client.

Osf

Suppression des enregistrements FNT de la table risque_detail des factures transférées en comptabilité

Lors de la génération de la table risque_detail , les enregistrements de type FAC sont supprimés et régénérés à partir du fichier d'intégration.

Si cette option est activée, les enregistrements de type FNT sont supprimés si la facture rattachée à l'enregistrement est transférée en comptabilité.

L'option Ord doit être activée pour que cette nouvelle fonctionnalité soit activée.

Si le module d'intégration est lancé par le module risque détail,cette option ne doit pas être activée.

Le module risque détail supprime tous les enregistrements de type FNT et recrée ceux des factures non transférées en comptabilité.

Valeur alpha2

Caractère 1 | Type de fichier en entrée Voir plus bas les différents types et leur descriptif.
Caractères 2 à 4 | Code société du fichier à intégrer Si non renseigné, il est rempli avec le code société courant.
Caractère 5 | Uniquement pour la comptabilité Sage Ligne 100 O Le numéro de pièce est dans la référence pièce du fichier à importer SAGE N Le numéro de pièce est dans le numéro d'écriture du fichier à importer SAGE (valeur par défaut)
Caractères 6 à 11 | Type et code du paramètre de lancement pour lancement multiple
Caractère 12 | Méthode de codification du code client (obligatoire) Uniquement si A2[1] = 0 1 "0" + Caractères 1 à 4 de la ligne du fichier 2 Caractères 1 à 5 de la ligne du fichier
Caractère 13 | Option de fichier SAP Uniquement si A2[1] = 0 1 par défaut 2 fichier d'intégration des plafonds clients

Valeur alpha3

Caractères 1 à 3 | Code qualité à mettre à jour sur le tiers en cas d'impayé Pour conserver l'ancien code qualité, on utilise le TSC IMP sur le tiers concerné. Permet de modifier la qualité d'un tiers si celui-ci présente des impayés lors de l'intégration d'un fichier de comptabilité de type FININFOR.
Caractères 4,6 | 4,6 Code qualité à mettre à jour sur le tiers en cas de date expirée du plafond. Plus d'info
Caractères 7,9 | 7,9 Nombre de jours en plus de la date d'expiration. (Délai de grâce.) Voir info dans les caractères 4,6.
Caractères 10,12 | Supprimé le 30/03/2012 Remplacé par : Si le tiers passe d'expiré à non expiré, son ancien code qualité sera rétabli.

Notes sur le paramètre

C_JOURNAL_LETTRAGE

Périmé

NE PLUS UTILISER

COL_

Uniquement pour SAGE ligne 500

Pour chacune des 15 lignes de notes suivantes, le paramétrage se découpe ainsi :

05 à 20 Nom de la colonne

  1. NUMERO_COMPTE

  2. SENS_PIECE

  3. MONTANT_PIECE_1 (partie entière du montant dans la devise société)

  4. MONTANT_PIECE_2 (partie décimale du montant dans la devise société)

  5. LIBELLE_PIECE

  6. DATE_PIECE_JJ

  7. DATE_PIECE_MM

  8. DATE_PIECE_AA

  9. NUMERO_PIECE

  10. DATE_ECHEANCE_JJ

  11. DATE_ECHEANCE_MM

  12. DATE_ECHEANCE_AA

  13. TYPE_PIECE

  14. MONTANT_DEVISE_1 (partie entière du montant dans la devise de la pièce)

  15. MONTANT_DEVISE_2 (partie décimale du montant dans la devise de la pièce)

21 à 23 Position de début de la colonne dans le fichier

25 à 27 Position de fin de la colonne dans le fichier

F_CR_ANOMALIES

F_CR_ANOMALIES_N

15,60 Nom et chemin du fichier compte-rendu des anomalies OBLIGATOIRE EN MODE BATCH.

Voir remarque ci-dessous sur le _N.

F_INTEGRATION

F_INTEGRATION_N

15,60 Nom et chemin du fichier d'intégration. OBLIGATOIRE

Voir remarque ci-dessous sur le _N.

à propos du _N

Pour ces 3 notes, le _N est facultatif est représente la valeur de l'environnement dans lequel le fichier doit être utilisé (réel, test, …).

A noter qu'il ne peut y avoir que des notes du mode standard, ou des notes du nouveau mode avec gestion de l'environnement.

Les 2 types de notes ne peuvent pas cohabiter dans un même paramètre de lancement.

F_HISTO

F_HISTO_N

Permet d'historiser et d'horodater le fichier d'encours client à intégrer.

Cette opération est effectuée en fin de traitement du fichier.

15,60 Nom du fichier d'historisation de l'encours client.

Le nom du fichier peut être horodaté.

Dans ce cas, il faut utiliser la même codification que pour l'horodatage des fichiers par les visualisations :

%D2% Date du jour au format aammjj

%D4% Date du jour au format aaaammjj

%HM% Heure courante au format hhmm

%HS% Heure courante au format hhmmss

Voir remarque ci-dessus sur le _N.

MAJ_TSC

Alimentation automatique de TSC

Syntaxe : MAJ_TSC*nom_zone_origine*code_TSC*nom_zone_info_c*

Exemples

MAJ_TSC*mp_fam*TES*ic_char3_1*

MAj_TSC*mp_sfm*TES*ic_char3_2

QUAL_SANS_EXPIR_PLF

Liste des qualités de client (paramètres QT) pour lesquelles on ne tiendra pas compte de la date d'expiration du plafond d'un client.

Cela signifie que le traitement s'opère comme i la date de validité du plafond n'avait pas expiré et que la qualité du client n'est pas positionnée à PLF (Plafond expiré – qualité paramétré en A3[4,6] du paramètre de lancement).

Cette liste doit être saisie comme une suite de codes qualité sur 3 caractères, séparés par un espace. Ils doivent donc être saisis en positions 21 à 23, 25 à 27, 29 à 31, 33 à 35, etc jusque 57 à 59.

Descriptif du fichier importé

Le type de fichier est indiqué en alpha2[1].

Sauf exception mentionnée, les fichiers à importer sont de type linéaire sans séparateur de champs.

Types de fichier existants à ce jour :

0 Fichier des écritures comptables issu de l'interface SAP Encours Clients - Voir descriptif du fichier

1 Ancien type de fichier

2 Type de fichier avec risque détail

3 Sage Ligne 100 (voir particularités ci-dessous)

4 Identique au type 2 avec N° de pièce à 12 caractères et non 10

5 Sage Ligne 500

6 Comptabilité CCMX (champs séparés par des points-virgules) (voir particularités ci-dessous)

7 Fininfor (champs séparés par des points-virgules)

8 Totem

9 Ecritures lettrées de SAGE 100 avec séparateur; (point-virgule)

A Fichier des soldes comptables issu de l'interface ANAEL Encours Clients

Voir valeur numérique 1

Particularités propres à Sage Ligne 100 (type 3)

  • La première ligne du fichier ne contient que le code société.

  • Le code client est recherché dans la table cli avec le compte client comme critère de recherche.

  • Les dates de pièce et d'échéance sont sur 6 caractères et sans séparateur :
    si l'année est supérieure à 79, on ajoute 19 devant, sinon on ajoute 20.
    Dans tous les cas, le séparateur / est ajouté.

  • Le N° de pièce est récupéré dans les caractères [039,050] si alpha2[5] = O
    et si les caractères [039,051] contiennent une valeur.

Particularités propres à CCMX (type 6)

  • Les enregistrements envoyés par CCMX sont les écritures non lettrées par client.

  • Si le montant débit est renseigné , la pièce est considérée comme une facture.
    type = type de pièce = FAC; sens = D

  • Si le montant crédit est renseigné , la pièce est considérée comme un avoir.
    type = type de pièce = AVO; sens = C

  • Les dates sont au format JJ/MM/AA

  • Les montants sont au format ########&.&&

  • Bien que l'interface gère une zone débit et une zone crédit, une seule des 2 zones doit contenir un montant sinon seul le débit est pris en compte.

Champ 1 : date de la pièce

Champ 2 : n° de compte (15 caractères maxi)

Champ 3 : n° de pièce (8 caractères)

Champ 4 : date échéance

Champ 5 : Montant débit (12 caractères)

Champ 6 : Montant débit (12 caractères)

Champ 7 : libellé (60 caractères)

Particularités propres aux écritures lettrées de SAGE 100 (type 9)

Tous les champs sont séparés par un ; (point virgule).

Le format exporté par SAGE est un fichier Excel (.xls) sauvegardé au format .csv avec séparateur ;

Comme ce format ne met pas de séparateur après le dernier champ, il faut lancer la commande suivante pour effectuer cette opération :

sed "s/$/;/g" fichier_orig > fichier_dest

Le fichier destination doit toujours être différent du fichier origine.

Champ 1 : Compte tiers

Champ 2 : Date d'écriture (jjmmaa)

Champ 3 : Code journal sur 2 caractères maxi

Champ 4 : Numéro d'écriture

Champ 5 : Référence de la pièce (n'est utile que si A2[5] = O)

Champ 6 : Inutilisé

Champ 7 : Inutilisé

Champ 8 : Libellé de la pièce

Champ 9 :Libellé du règlement (inutilisé)

Champ 10 : Date d'échéance (jjmmaa)

Champ 11 : Code lettrage (sur 2 caractères maxi)

Champ 12 : Montant Débit

Champ 13 : Montant crédit

Champ 14 : Inutilisé

Zone

Type 1

Type 2

Type 3

Type 4

Type 5

Type 6

Type 7

Type 8

Type 9

société

societe

[001,003]

societe

[001,003]

societe

societe

societe

[001,003]

type

FAC

FAC

FAC

FAC

FAC

FAC/AVO

FAC

FAC

code client

[011,016]

[004,009]

cl_code

[004,009]

Code du client recherché à partir du compte

Code du client recherché à partir du compte

Code client du fichier

Code du client recherché à partir du compte

date pièce

[001,010]

[020,029|

[004,009]

[022,031|

[082,087]

[001,008]

date du jour

[024,033]

compte client

[011,018]

Code comptable du client si existe

[026,038]

Code comptable du client si existe

[007,012]

cli.cl_cpt

[004,013]

type de pièce

[019,021]

[076,078]

[010,011]

[078,080]

[216,218]

FAC/AVO

FAC/AVO

[080,082]

numéro de pièce

[022,031]

[010,019]

[106,112]
ou
[039,050]

[010,021]

[089,098]

[026,033]

[vide]

[014,023]

sens de la pièce

[032]

[060]

[084]

[062]

[023]

D/C

D/C

[064]

montant de la pièce

[033,047]

[040,059]

[085,104]

[042,061]

[024,041]

[044,055]

ou

[057,068]

montant facture du fichier/100

[044,063]

montant en Euro

0

0

0

0

0

calculé

0

montant en devise

0

0

0

0

[226,243]

calculé

0

date d'échéance

[048,057]

[030,039]

[078,083]

[032,041]

[0191,0196]

[035,042]

date du jour

[034,043]

traite acceptée

[058]

[109]

N

[111]

N

N

N

[113]

Site de production

[059,061]

N

N

N

N

[vide]

[vide]

[blanc]

libellé de la pièce

[blanc]

[079,108]

[052,076]

[081,110]

[042,046]

[070,128]

[vide]

[083,112]

mode de règlement

[blanc]

[073,075]

[077]

[075,077]

[vide]

[blanc]

[vide]

[077,079]

nombre de rappels

0

[061,062]

0

[063,064]

0

[blanc]

0

[065,066]

date du dernier rappel

[blanc]

[063,072]

[blanc]

[065,074]

[vide]

[blanc]

[vide]

[067,076]

anomalie

N

N

N

N

N

N

N

N

Particularités propres aux soldes comptables issu de l'interface ANAEL Encours Clients (type A)

Le format du fichier à intégrer est le suivant :

Caractères 001-008 Code client comptable (cl_cpt)

Caractères 009-023 Solde comptable en centimes d'Euro


Mise à jour du fichier des effets

Mise à jour du fichier des effets tr_effet

Options

-Omf | Pas de MAJ à partir des factures
-Omr | Pas de MAJ à partir des relevés

Vérifier le paramétrage des modes de règlement (MRG).

Valeur alpha 1

Caractère 5 | Code MAJ table des effets (O ou N)
Caractères 6 à 8 | Type acceptation de l'effet (A, NA, AFA ou blanc)


Fichier DOS des effets

Fichier DOS des effets tr_dosef

Paramètre associé : #CF PEF

(à vérifier : le code du paramètre de configuration doit être identique à celui du paramètre de lancement.

Valeur alpha 2

Paramétrage des zones du fichier DOS

A | Référence société
B | Type d'effet
C | Type d'acceptation
D | Date de création
E | Date d'échéance
F | Montant de l'effet
G | Code comptable client
H | Raison sociale client
I | Domiciliation bancaire client
J | Code banque client
K | Code guichet client
L | Numéro de compte client
M | Clé RIB client
N | Numéro de pièce de l'effet
O | Référence tire de l'effet
P | Numéro RCS de la société (so_rcs)


Transfert des tiers dans la comptabilité CCMX

Transfert des tiers dans la comptabilité CCMX tr_cli_ccmx

Cliquez ici pour voir le format du fichier de transfert.

Options triées

Oaf | Transfert des adresses de facturation - Incompatible avec l'option Ota
Ocb | Ajout du champ bénéficiaire à la fin du fichier (= 20 premiers caractères de la raison sociale)
Oea | Epuration automatique en mode Batch
Oet | Prise en compte de la table evt_trans (table mise à jour en création ou modification de tiers selon paramétrage)
Ont | Conversion du fichier de transfert en DOS
Ota | Lorsque le code adresse de facturation est renseigné sur le client et que le code comptable de l'adresse de facturation n'est pas renseigné : permet de transférer les infos de l'adresse secondaire de facturation en lieu et place des infos de l'adresse principale. Incompatible avec l'option Oaf
Otc | Pas de transfert des clients
Otf | Pas de transfert des fournisseurs
Otp | Pas de transfert des prospects
Ova | Prise en compte de la validité d'adresse

Valeur alpha 2

Caractères 1 à 60

Chemin et nom du fichier de transfert

Exemple : /u/atlas/transfert/tiers.txt

Notes

_SUP_REQ_TIERS | 21,60 Complément de select sur les tiers (table cli) Exemple : and cl_cpf = "C" Exemple : and cl_code not in ("#SOC","000000","00000C")
_SUP_REQ_CLI2 | 21,60 Complément de select sur les tiers (table cli2) Exemple : and c2_adr matches "F*"
LONGUEUR_COMPTE | 21,22 Longueur des comptes autorisée. 0 : Pas de contrôle
SEPARATEUR | 21 Séparateur de champ Exemple : |
COMPTE_COLLECTIF | 21, 23 Préfixe 25, 37 Compte collectif 39 Longueur de la racine. 0 : Pas de préfixe 42 Type de Tiers : C : Client, F : Fournisseur, P : Prospect, [espace] : pas de contrôle (valeur par défaut)


Transfert des tiers vers la comptabilité JDE

Transfert des tiers vers la comptabilité JDE tr_cli_jde

Options

-Oea

Epuration automatique en mode batch

Valeur alpha 2

Caractères 1 à 60

Chemin et nom du fichier de transfert des données communes

EX : /u/atlas/transfert/tiers_dc.txt

Valeur alpha 3

Caractères 1 à 60

Chemin et nom du fichier de transfert des données société

EX : /u/atlas/transfert/tiers_ds.txt

Valeur alpha4

Caractères 1 à 60

Chemin et nom du fichier de transfert des avis de modifications fournisseurs

EX : /u/atlas/transfert/tiers_dm.txt

Notes

_CODE_SOCIETE_JDE | 21,60 Code société JDE du site - Tableau de bord du multisite
_CODE_SITE_DUPLIQUE | 21,23 Code site à dupliquer - Tableau de bord du multisite 24,28 Code Société JDE correspondante
_TRANCHE_INF_1000 | 21,24 Code tranche pour les numéros de compte comptable inférieurs à 1000 26,28 Code tranche pour les numéros de compte comptable groupe inférieurs à 1000 pour les clients 30,33 Code tranche pour les numéros de compte comptable inférieurs à 1000 pour les fournisseurs 35,37 Code tranche pour les numéros de compte comptable groupe inférieurs à 1000 pour les fournisseurs
_TRANCHE_SUP_1000 | 21,24 Code tranche pour les numéros de compte comptable supérieurs à 1000 26,28 Code tranche pour les numéros de compte comptable groupe supérieurs à 1000 pour les clients 30,33 Code tranche pour les numéros de compte comptable supérieurs à 1000 pour les fournisseurs 35,37 Code tranche pour les numéros de compte comptable groupe supérieurs à 1000 pour les fournisseurs
_CENTRE_DE_COUT | 21,32 Centre de coût

Paramètres nécessaires

DEN | Dénomination - Forme juridique
PAY | alpha1[16,18]
TLI | alpha1[1,3]
TOU | alpha1[1,3]
EXO | alpha1[3,4]
 | alpha1[5,14]
POR | alpha1[4,6]
ACT | alpha1[4,6]
TSC DAS | 1,2 ZF 3,17 Code DAS2 18 N 24 Z 42,56 Code DAS2


Statistiques

Statistiques stat2

Il faut d'abord lancer une mise à jour de stat0 pour que les quantités et le chiffre d'affaires s'affichent dans l'édition.

Suivant les options du menu utilisées, et pour réduire les temps d'édition, il faut créer les index suivants :

Menu Client | Edition par client, famille, sous-famille Ajout index XX_ix_stat0_1 sur la table stat0 st_soc, st_cli, st_fam, st_sfm
Menu Ventes | Edition par famille, sous-famille, article Ajout index XX_ix_stat0_2 sur la table ststat0at0 st_soc, st_fam, st_sfm, st_prod
Menu Représentant | Edition par représentant, famille, sous-famille (Edition des familles de produit par représentant : alpha2[5] = N) Ajout index XX_ix_stat0_3 sur la table stat0 st_soc, st_rep, st_fam, st_sfm
Menu Représentant | Edition par représentant, client, famille (Edition des clients par représentant : alpha2[5] = O) Ajout index XX_ix_stat0_4 sur la table stat0 st_soc, st_rep, st_cli, st_fam
Menu Zone param | Edition par zone paramétrée, client, famille Ajout index XX_ix_stat0_5 sur la table stat0 st_soc, st_par, st_cli, st_fam

Options triées

-B | Mode batch : permet de lancer automatiquement la mise à jour des statistiques
-Oar | Edite les adresses rue du client
-Oav | Edite le code postal et l'adresse ville du client
-Obl | Prend en compte les lignes £££ (FAM) et BON (SFM)
-Oet | Crée un enregistrement cumul mensuel et annuel
-Of2 | Ouverture automatique de la deuxième fenêtre de sélection de critères de recherche sur la fiche article. Sélection complémentaire sur tous les champs de la fiche article (touche F8).
-Ofe | Statistiques facturation escompte non déduite
-Ofr | Statistiques facturation remise non déduite
-Oht | Calcul des commissions sur le total HT facture
-Ol0 | Met à jour dans le fichier commissions les montants à zéro
-Omc | Sélection du mois en cours Par défaut, c'est le mois précédent qui est sélectionné Associé à l'option -B, permet de sélectionner le mois en cours. IMPORTANT : si un cron est mis en place, il faut lancer 2 traitements : l'un avec cette option pour traiter le mois en cours, l'autre sans cette option pour traiter le mois précédent. Si on ne traite que le mois en cours, les factures émises en début de mois sur une date fin du mois précédent ne seront pas prises en compte.
-Omd | Affiche les montants sans décimales
-Onv | Statistiques sur articles non vendus
-Op1 | Rien
-Op2 | Supprime l'édition du niveau 2
-Op3 | Supprime l'édition du niveau 3
-Opc | Affiche les pourcentages (ne peut fonctionner que si les mises à jour ont été faites avec -Oet) NE FONCTIONNE PLUS
-Opl | Edite le libellé centrale au lieu du libellé catégorie client
-Oqd | Affiche les quantités sans décimales
-Orp | Permet de réduire les espaces pour afficher les colonnes des marges
-Os1 | Saut de page au niveau 1
-Os2 | Saut de page au niveau 2
-Os3 | Rien
-Osc | Mise à jour du fichier des commissions (stat1)
-Ose | Calcul des commissions sur le détail ht avant escompte
-Osr | Calcul des commissions sur le détail ht avant remise
-Opr | Montant commissionné PV - Prix client (p_lc.lc_prx - p_lc.lc_prxcli)
-Obm | Montant commissionné PV. Taux de commission = selon % marge (PV -PR)/PR on en déduit le % commission en tarif type #RE, Catégorie REP

Fin des options triées

Valeur alpha 2

1 à 9 | Paramétrage (NNAONOONN par défaut)
Caractère 1 | Edition des marges (O/N)
Caractère 2 | Edition des articles non vendus (O/N) O Toutes les lignes mouvementées depuis le début de l'année avec seulement le cumul période pour les lignes mouvementées sur la période sélectionnée N Uniquement les lignes mouvementées sur la période sélectionnée
Caractère 3 | Cumuls sur année ou exercice A Année E Exercice
Caractère 4 | Edition des cumuls année ou exercice (O/N) O Edite les cumuls du mois début année ou exercice au mois fin année ou exercice N Edite les cumuls du mois début année ou exercice au mois fin saisi
Caractère 5 | Edition des clients par représentant (O/N) O Edite les clients par représentant N Edite les familles de produit par représentant
Caractère 6 | Edition niveau 2 (O/N)
Caractère 7 | Edition niveau 3 (O/N)
Caractère 8 | Saut page niveau 1 (O/N)
Caractère 9 | Saut page niveau 2 (O/N)

Notes

COLONNE_LIBRE_X

1 <X< 5

X correspond au N° du champ st_libre_x de la table stat0

21,38 Titre de la colonne (par ex. surface)

Permet d'ajouter les colonnes libres pour l'édition des statistiques

(permet de visualiser les cumuls par période et par année sur les champs st_libre_1 à st_libre_5)

Paramètres associés

#CF FAC configuration du calcul des factures

Autres

La mise à jour manuelle va examiner l'ensemble des éléments de facture non encore transférés en statistiques.

Requête à mettre en œuvre pour permettre le "re-transfert" :

update fac1 set fl_maj "N"

where fl_soc "..."

and fl_fac matches "8912*"

Attention : A utiliser avec précaution (penser aux enregistrements de cumul de stat0 et stat1)


Statistiques facturation (dégressif cumulé par client)

Statistiques facturation (dégressif cumulé par client) stat_dc

Reliure uniquement

Options

-Ofm

Les notions de prises en compte se situent au niveau de la famille et non plus au niveau de la sous-famille
(par défaut, sous-famille).

Détermination des produits à prendre en compte au niveau des statistiques.

Au niveau du paramétrage de chaque sous-famille

alpha[13] | permet d'indiquer que le CA des produits appartenant à la sous famille doit être pris en compte dans les statistiques O Pour indiquer que l'on prend en compte la sous-famille N ou [blanc] pour indiquer de ne pas la prendre en compte
alpha[14] | permet d'indiquer que la quantité des produits appartenant à la sous famille doit être pris en compte dans les statistiques O Pour indiquer que l'on prend en compte la sous-famille N ou [blanc] Pour indiquer de ne pas la prendre en compte

Au niveau de chaque entête de commande

Le code saisi dans la zone paramètre permet d'indiquer un code sous-famille sous lequel seront regroupées (pour l'édition des statistiques) toutes les lignes de factures liées à cette commande.

Paramétrer la saisie du code sous-famille dans l'entête de commande. #CF CDE, alpha1[1,3] = SFM

Paramétrer le transfert de ce code dans le fichier stat0 (fichier historique des statistiques). #SA FAC, alpha[6] = A

Etat statistiques de ventes dégressif cumulé

En ligne

Pour chaque groupe de client (zone code groupe client sur le deuxième écran de la fiche client) on trouvera :

  • La raison sociale du groupe client

  • Le rang du groupe client pour le CA cumulé

  • Le rang du groupe client pour le CA cumulé et groupe de produit par rapport à l'ensemble des clients

  • Le CA du mois calculé à partir de toutes les lignes de factures concernant des produits dont la sous-famille doit être prise en compte au niveau des statistiques CA (voir paragraphe codification sous-famille)

    • % CA mois | pourcentage de la colonne précédente par rapport au total CA mois de la catégorie (dans le récapitulatif)
CA cumul N | cumul de la colonne CA du mois depuis janvier jusqu'au mois courant.
% CA cumul N | pourcentage de la colonne précédente par rapport au total cumul N de la catégorie (dans le récapitulatif)
CA cumul N-1 | idem CA cumul N mais pour l'année N-1
% CA cumul N-1 | pourcentage de la colonne précédente par rapport au total cumul N-1 de la catégorie (dans le récapitulatif)
 | % de variation entre cumul N et le cumul N-1
volume mois | idem CA du mois mais pour les quantités
% volume du mois | idem % CA du mois mais pour les quantités
volume cumul N | idem CA cumul N mais pour les quantités
% volume cumul N | idem CA cumul N mais pour les quantités
volume cumul N-1 | idem CA cumul N-1 mais pour les quantités
% volume cumul N-1 | idem % CA cumul N-1 mais pour les quantités
 | % de variation entre volume cumul N et volume cumul N-1

    On trouvera un sous total par groupe client

    On pourra avoir un sous-total par représentant si on répond oui à la question détail représentant lors de l'exécution du programme (après l'écran de sélection).

    On pourra avoir un état dégressif mensuel en répondant oui à la question dégressif mensuel (Le rang des catégories et des groupes client se calcule avec le CA du mois).

    Remarque Quand un groupe client ne possède qu'une seule ligne, on imprime uniquement la ligne sous-total client. Au niveau de cette ligne, on rappelle le nom du groupe ainsi que le nom de la catégorie concerné par l'unique ligne de ce groupe client. (Le rang est celui du groupe client).

    On trouvera un récapitulatif à la fin de l'état avec :

    Un total pour chaque catégorie (les catégories mises dans l'ordre décroissant du CA du mois)

    Un total général

    Conseils

    Il est conseillé de créer une sous famille # afin de faire ressortir les commandes où la zone paramètre n'a pas été renseignée.

    Il est conseillé de créer un représentant # afin de faire ressortir les clients non suivis par un représentant.

    Il est conseillé de créer un client $ afin de faire ressortir les lignes de factures pour lesquels le client n'existe plus.


Statistiques facturation (statistiques filiales

Statistiques facturation statistiques filiales stat_fil

Options

-Ofm | Les notions de prise en compte se situent au niveau de la famille et non plus au niveau de la sous-famille (par défaut, sous-famille).
-Or2 | On va regrouper les lignes de stat0 sur le code famille (incompatible -Or3)
-Or3 | On va regrouper les lignes de stat0 sur le code sous-famille (incompatible –Or2) Or2 et Or3 absentes : regroupement sur la zone paramètre de l'entête de commande (Cf explications plus bas)
-Oec | Permet d'éditer les centimes.
-Oss | On tri les groupes par code origine zone sur la fiche client (cl_orig), et les clients sur la zone paramétrée de la fiche client (cl_zpar).
-Odt | Permet d'obtenir le détail des lignes quand un client ne possède qu' une ligne en édition, ou quand un groupe ne possède qu'une ligne en édition. (Explication Dans le fonctionnement normal quand un client ne possède qu'une ligne de détail, on n'édite pas la ligne de détail, on édite seulement la ligne de total. Idem pour les groupes. Ceci permet d'avoir un état plus clair mais on perd de l'information L'option dt permet d'éditer toutes les lignes

Valeur alpha 2

Paramétrage des colonnes à éditer

Paramétrage par défaut | ABCDEFGHIJKLMNOPQ
Séparateurs | OOONONONOONONONOO

A | La raison sociale du client
B | La catégorie de regroupement
C | Le rang du client pour le CA cumule et groupe de produit par rapport à l'ensemble des clients
D | le CA du mois calcule à partir de toutes les lignes de factures concernant des produits dont la sous-famille doit être prise en compte au niveau des statistiques CA (Cf paragraphe codification sous-famille)
E | % CA Mois Pourcentage de la colonne précédente par rapport au total CA Mois de la catégorie (dans le récapitulatif)
F | CA cumul N Cumul de la colonne CA du mois depuis janvier jusqu'au mois courant
G | % CA CUMUL N Pourcentage de la colonne précédente par rapport au total CUMUL N de la catégorie (dans le récapitulatif)
H | CA CUMUL N-1 Idem CA cumule N mais pour l'année N-1
I | % CA CUMUL N-1 Pourcentage de la colonne précédente par rapport au total CUMUL N-1 de la catégorie (dans le récapitulatif)
J | % de variation entre CUMUL N et le CUMUL N-1
K | Vol mois Idem CA du mois mais pour les quantités
L | % volume du mois idem % CA du mois mais pour les quantités
M | VOL cumul N Idem CA cumul N mais pour les quantités
N | % Vol Cumul N Idem CA cumul N mais pour les quantités
O | VOL cumul N-1 Idem CA cumul N-1 mais pour les quantités
P | % Vol Cumul N-1 Idem % CA cumul N-1 mais pour les quantités
Q | % de variation entre VOL cumul N et VOL cumul N-1
R | prix moyen par volume (mensuel) D/K
S | prix moyen par volume (pour l'année N) F/M
T | prix moyen par volume (pour l'année N-1) H/O
U | libellé court du code origine sur la fiche client (cl_orig)
V | libellé court du code Zone paramétrée sur la fiche client (cl_zpar)
W | Colonne vide
X | Code origine sur la fiche client (cl_orig)
Y | Code de la zone paramétrée sur la fiche client

REMARQUES

La colonne A (raison sociale du client) déborde volontairement sur les lignes de sous-totaux.

Pourquoi ? afin de mettre TOTAL GROUPE +raison sociale. Il est donc conseillé de paramétrer la colonne à part une colonne non utilisé dans les sous-totaux.

Valeur alpha 3

Paramétrage des séparateurs de colonne. En vis à vis avec le paramétrage sur la zone alpha2, on indique si on désire un séparateur après l'édition de la colonne.

O ou [blanc] | Séparateur
N | Pas de séparateur

(Ceci permet d'avoir des états statistiques plus lisibles)

Valeur alpha 4

TITRE DE L'eTAT (modifiable juste avant le lancement de l'édition)

Détermination des produits à prendre en compte au niveau des statistiques

Paramètres associés

Au niveau du paramétrage de chaque sous-famille (si l'option -Ofm n'a pas été choisie) :

alpha1[13] indique que le CA des produits appartenant à la sous famille doit être pris en compte dans les statistiques.

alpha1[14] indique que les quantités appartenant à la sous famille doivent être prises en compte dans les statistiques.

Au niveau du paramétrage de chaque famille (si option -Ofm a été choisie)

alpha4[12] permet d'indiquer que le CA des produits appartenant à la sous famille doit être pris en compte dans les statistiques.

alpha4[13] permet d'indiquer que les quantités appartenant à la sous famille doit être pris en compte dans les statistiques.

Au niveau de chaque entête de commande (si les options -Or2 et -Or3 n'ont pas été choisies) :

Le code saisi dans la zone paramètre permet d'indiquer un code sous-famille sous lequel seront regroupées (pour l'édition des

statistiques) toutes les lignes de factures liées à cette commande.

Il faut paramétrer la saisie du code sous-famille dans l'entête de commande. Dans le paramètre #CF CDE mettre SFM en alpha1[1,3]

Il faut paramétrer le transfert de ce code dans le fichier stat0 (fichier historique des statistiques). Dans le paramètre #SA FAC mettre A en alpha1[6].

REMARQUES

On trouvera un sous-total par client.

On trouvera un sous-total par groupe client (zone code groupe client sur le deuxième écran de la fiche client)

Quand un client ne possède qu'une seule ligne, on imprime uniquement la ligne sous-total client.

Au niveau de cette ligne, on rappelle le nom du client ainsi que le nom de la catégorie concernée par l'unique ligne de ce client (le rang est celui du client).

On trouvera un récapitulatif à la fin de l'état avec :

  • Un total pour chaque catégorie (les catégories mises dans décroissant du CA du mois)

  • Un total général

Conseils

  • Il est conseillé de créer une sous famille # afin de faire ressortir au niveau de l'édition les commandes où la zone paramètre n'a pas été renseignée.

  • Il est conseillé de créer une famille # afin de faire ressortir au niveau de l'édition les produits n'ayant pas de famille.

  • Il est conseillé de créer une sous-famille # afin de faire ressortir au niveau de l'édition les produits n'ayant pas de sous-famille.

  • Il est conseillé de créer un client $ afin de faire ressortir au niveau de l'édition les lignes de factures pour lesquels le client n'existe plus.


Statistiques spécial reliure

Statistiques spécial reliure stat_rel

Options

-Ofm | Les notions de prises en compte se situent au niveau de la famille et non plus au niveau de la sous-famille (par défaut, sous-famille).
-Oss | On tri les groupes par code origine zone sur la fiche client (cl_orig), et les clients sur la zone paramétrée de la fiche client (cl_zpar).
-Odt | Permet d'obtenir le détail des lignes quand un client ne possède qu' une ligne en édition, ou quand un groupe ne possède qu'une ligne en édition. (Explication Dans le fonctionnement normal quand un client ne possède qu'une ligne de détail on n'édite pas la ligne de détail , on édite seulement la ligne de total, idem pour les groupes. Ceci permet d'avoir un état plus clair. Mais on perd de l'information. L'option dt permet d'éditer toutes les lignes.
-Oec | On éditera les centimes. par défaut on arrondi au franc près
-Olc | Imprime uniquement les lignes clients (pas de ligne groupe)
-Olg | Imprime uniquement les lignes groupe (pas de ligne client)
-Oq0 | N'édite pas les lignes dont les quantités sont à 0

Valeur alpha 2

Paramétrage des colonnes à éditer.

A | La raison sociale du client
C | Le rang du client pour le CA cumule et groupe de produit par rapport à l'ensemble des clients
D | le CA du mois calculé à partir de toutes les lignes de factures. Concernant des produits dont la sous-famille doit être prise en compte au niveau des statistiques CA (Cf paragraphe codification sous-famille)
E | % CA Mois Pourcentage de la colonne précédente par rapport au total CA mois de la catégorie (dans le récapitulatif)
F | CA cumul N Cumul de la colonne CA du mois depuis janvier jusqu'au mois courant.
G | % CA CUMUL N Pourcentage de la colonne précédente par rapport au total CUMUL N de la catégorie (dans le récapitulatif)
H | CA CUMUL N-1 Idem CA cumule N mais pour l'année N-1
I | % CA CUMUL N-1 Pourcentage de la colonne précédente par rapport au total CUMUL N-1 de la catégorie (dans le récapitulatif)
J | % de variation entre CUMUL N et le CUMUL N-1
K | Vol mois Idem CA du mois mais pour les quantités
L | % volume du mois Idem % CA du mois mais pour les quantités
M | VOL cumul N Idem CA cumul N mais pour les quantités
N | % Vol Cumul N Idem CA cumul N mais pour les quantités
O | VOL cumul N-1 Idem CA cumul N-1 mais pour les quantités
P | % Vol Cumul N-1 Idem % CA cumul N-1 mais pour les quantités
Q | % de variation entre VOL cumul N et VOL cumul N-1
R | Prix moyen par volume (mensuel) D/K
S | Prix moyen par volume (pour l'année N) F/M
T | Prix moyen par volume (pour l'année N-1) H/O
U | Libellé court du code origine sur la fiche client (cl_orig)
V | Libellé court du code Zone paramétrée sur la fiche client (cl_zpar)
W | Colonne vide
X | Code origine sur la fiche client (cl_orig)
Y | Code de la zone paramétrée sur la fiche client
a | Volumes détails production du mois
b | Volumes détails production cumul N
c | Volumes détails production cumul N-1

REMARQUES

La colonne A (raison sociale du client) déborde volontairement sur les lignes de sous-totaux.

Pourquoi ? afin de mettre TOTAL GROUPE + raison sociale. Il est donc conseillé de faire suivre la colonne A par une colonne non utilisé dans les sous-totaux.(la colonne W par Exemple )

Valeur alpha 3

Paramétrage des séparateurs de colonne

En vis à vis avec le paramétrage sur la zone alpha2, on indique si on désire un séparateur après l'édition de la colonne :

O ou blanc | Séparateur
N | Pas de séparateur

(ceci permet d'avoir des états statistiques plus lisibles)

Valeur alpha 4

TITRE DE L'eTAT (modifiable juste avant le lancement de l'édition)

Détermination des produits à prendre en compte au niveau des statistiques

Paramètres associés

Au niveau du paramétrage de chaque sous-famille (si l'option -Ofm n'a pas été choisie) :

alpha1[13] indique que le CA des produits appartenant à la sous famille doit être pris en compte dans les statistiques.

alpha1[14] indique que les quantités appartenant à la sous famille doivent être prises en compte dans les statistiques.

Au niveau du paramétrage de chaque famille (si option -Ofm a été choisie)

alpha4[12] permet d'indiquer que le CA des produits appartenant à la sous famille doit être pris en compte dans les statistiques.

alpha4[13] permet d'indiquer que les quantités appartenant à la sous famille doit être pris en compte dans les statistiques.

REMARQUES

On trouvera une ligne par client.

On trouvera un sous-total par groupe client (zone code groupe client sur le deuxième écran de la fiche client.

Quand un groupe ne possède qu'une seule ligne, on imprime uniquement la ligne sous-total groupe.

On trouvera un total général à la fin de l'état

Il est conseillé de créer un client $ afin de faire ressortir au niveau de l'édition les lignes de factures pour lesquels le client n'existe plus.


Commissions

Commissions représentants statec

Paramétrage préliminaire

  • La notion de regroupement de représentant est définie dans la fiche représentant.

  • Vérifier la présence de -Osc sur stat2 afin que lors de la Mise à jour le fichier commission soit bien alimenté

  • #CF FAC alpha1[7,8].

En fonction de ce paramétrage, 4 éditions différentes peuvent être réalisées

Etat 1 | Les caractères 7 et 8 ne sont pas renseignés Tri et rupture par année / mois Regroupement représentant Représentant
Etat 2 | Le caractère 7 est renseigné et 8 non renseigné Tri et rupture par année / mois Regroupement représentant Représentant Paramétrage du caractère 7 (s1_p1)
Etat 3 | Le caractère 8 est renseigné et 7 non renseigné Tri et rupture par année / mois Regroupement représentant Représentant Paramétrage du caractère 8 (cs1_clmp)
Etat 4 | Les caractères 7 et 8 sont renseignés Tri et rupture par année / mois Regroupement représentant Représentant Paramétrage du caractère 8 (s1_clmp) Paramétrage du caractère 7 (s1_p1)

Options

-Ol0 | Edite les montants des commissions à zéro
-Od1 | Supprime le détail des factures
-Od2 | Supprime le total des factures
-Od3 | Supprime le total du paramètre dans l'état 2 & 4
-Od4 | Supprime le total client ou article dans l'état 3 & 4
-Os1 | Supprime le saut de page après chaque groupe
-Os2 | Supprime le saut de page après chaque représentant
-Otg | Supprime le total général
-Oar | Edite les adresses rue du client
-Oav | Edite le code postal et l adresse ville du client

Options spécifiques à P

-Ol0 | Edite les montants des commissions à zéro
-Orp | Supprime le total général du représentant
-Otg | Supprime le total général

Paramètres associés

Mise à jour de la table des commissions : #CF FAC alpha1[7] et #CF FAC alpha1[8].


MAJ et édition des commissions

MAJ et édition des commissions sta_com

Options

O2r | Utilise le champ ec_suiv pour contenir un code représentant supplémentaire
Otp | Taux de commission proportionnel dans le cas où la remise est à l'intérieur de la fourchette de la gamme de produit

Valeur alpha 2

Colonnes 1 à 30 | Paramétrage état (OOO par défaut) Edition des lignes à 0 (O/N) Montants avec décimales (O/N) Edition montants commissions (O/N)
Colonnes 31 à 33 | Code paramètre franco de port (FRA par défaut)
Colonnes 34 à 37 | Taux remise franco de port (3% par défaut)
Colonnes 38 à 41 | Taux 1 (1.8% par défaut)
Colonnes 42 à 45 | Taux 2 (1.25% par défaut)
Colonnes 46 à 49 | Taux 3 (1.5% par défaut)
Colonnes 50 à 57 | Plafond (230000 par défaut)

Valeur alpha 3

Titre état (ETAT DES COMMISSIONS par défaut)

Valeur alpha 4

Paramétrage des colonnes d'édition (ABCDEFGHIJK par défaut)

A | Numéro de facture/avoir
B | Code client
C | Nom du client
D | C.A. H.T.
E | Port et divers (ristournes)
F | C.A. H.T. net
G | Coefficient (secteurs commerciaux)
H | C.A. soumis à la commission
I | C.A. soumis au 1er taux
J | C.A. soumis au 2ème taux
K | C.A. soumis au 3ème taux
L | C.A. soumis au 4ème taux

Paramètres associés

Mise à jour de la table des commissions : #CF FAC alpha1[7] et #CF FAC alpha1[8].

Bornes inférieure et supérieure pour taux de commission : MAT valeurs numériques 1 & 2

Uniquement pour les secteurs commerciaux : REP alpha1


Saisie des prévisionnels TTR

Saisie des prévisionnels c_ttr

VOL_8010 | #SA CPT | bud_cpt.4g | Table des comptes de charges
VOL_8020 | #SA CLA | cpt_ch | Table des classes de charges
VOL_8030 | #SA CLF | cle_rep | Table des clés de répartitions
VOL_0282 | #SA COU | ccout | Table des centres de coût

#BA, ICH Intégration des charges d'après clefs

Imprimantes

bud_cpt | #LP CPT
cpt_ch | #LP CLA
cle_rep | #LP CLE
ccout | #LP COU

Le type de section ou centre de coût (TYS) est figé dans ccout.4ge

Il n'accepte que 2 valeurs

PRI | Centres principaux
AUX | Centres auxiliaires

Valeur alpha 2

Paramétrage type de cumul et type paramètre du type

Caractère 1 | Type de cumul (par défaut T)
Caractère 4 | Type paramètre du type de cumul (par défaut TTR)


Intégration des temps de production dans la table des centres de coût et dans la table des TTR

Intégration des temps de production dans la table des centres de coût et dans la table des TTR g_ctt


Intégration des temps de production dans la table des centres de coût, des classes de TTR et des TTR

Intégration des temps de production dans la table des centres de coût, des classes de TTR et des TTR g_c_ttr

Options

-Osc | Ne génère pas les classes de TTR
-Ost | Ne génère pas les TTR

Valeur alpha2

Paramétrage type de cumul et type paramètre du type

Caractère 1 | Type de cumul pour TTR (par défaut T)
Caractère 2 | Type de cumul pour Classe de TTR (par défaut C)


Table des frais

Table des frais frais


Répartition primaire et secondaire

Répartition primaire et secondaire repart

Options

-Oco

Interdit la répartition primaire, n'autorise que la répartition secondaire.
(Important chez C car c'est le programme tr_sec_val.4ge qui effectue la répartition primaire des charges réelles, la répartition primaire des charges avec repart.4ge effacerait la répartition primaire avec tr_sec_val.4ge)


Répartition primaire et secondaire( 2)

Répartition primaire et secondaire (2) repart2

Options

-Oco | Pas de répartition primaire
-Onr | Niveau centre de coût auxiliaire = Z+c0_rang au lieu de Z + niveau
-Opp | Pas de répartition primaire des charges prévues
-Opr | Pas de répartition primaire des charges réelles
-Osp | Pas de répartition secondaire des charges prévues
-Osr | Pas de répartition secondaire des charges réelles

Valeur alpha 2

Configuration pour le calcul de l'assiette sur les heures (types de clé = H ou S)

Les heures prévues et réalisées sont stockées dans la table c_ttr

Caractère 1 | Type TTR (T, TTR - C, Classe de TTR) C par défaut
Caractères 2 à 4 | Code TTR (Exemple DIR, IND, etc.) DIR par défaut
Caractères 5 à 7 | Code TTR absence (Exemple ABS) ABS par défaut


Edition de l'analyse de l'écart des frais par centre de coût

Edition de l'analyse de l'écart des frais par centre de coût ctr_bud2

Imprimante #LP CBU

Options

-Oco | Lignes d'analyses supplémentaires (pour C) (Heures devisées corrigées x Ct standard) (Ecart) (% de Couverture) (Production)
-Orn | Rupture sur les n 1er caractères de la nature de frais (Voir valeur 1) (Uniquement pour les frais directs)
-Osd | Les lignes détail de la 1ère partie de l'état (les frais directs) ne sont pas éditées

Valeur 1

Longueur sous-total nature de frais (1 à 8)

Si paramètre -Orn


Intégration des comptes et libellés

Intégration des comptes et libellés tr_cpt_val

Valeur alpha 2

Caractères 1 à 20 | Chemin complet et nom de la base de la comptabilité VoluCompta.
 | Possibilité de paramétrer plusieurs bases comptables (10 maxi).

Notes

DC | 3 à 22 Chemin complet et nom de la base de la VoluCompta
CC | Possibilité de paramétrer un complément de critère de sélection sur la table cptgen de VoluCompta 3 à 60 Complément de critère de sélection Exemple CCand cptgen.ccode between 6 and 7zzzzzzz

Ne pas oublier de mettre en 777, le log.file, les tables sys* et cptgen de la database VoluCompta pour permettre la lecture de ces fichiers.


Répartition primaire par transfert de charges prévues issues de VoluCompta

Répartition primaire par transfert de charges prévues issues de VoluCompta tr_bud_val

Remarque Ce programme met à jour la table (nature de) frais !

Valeur alpha

La charge prévue issue de la comptabilité provient du budget

Voir tr_cpt_val, alpha2[1, 20]

Notes

DC

3 à 22 Chemin complet et nom de la base VoluCompta

Ne pas oublier de mettre en 777, le log.file, les tables sys* et budget de la database VoluCompta pour permettre la lecture de ces fichiers.


Répartition primaire par transfert de charges réelles issues de VoluCompta.

Répartition primaire par transfert de charges réelles issues de VoluCompta tr_ana_val

Remarque Ce programme met à jour la table frais !

Options

Par défaut, la charge issue de la comptabilité (pour les comptes paramétrés ainsi) provient de l'analytique (table anahisto dans VoluCompta)

-Ose

La charge issue de la comptabilité (pour les comptes paramétrés ainsi) provient de la compta générale par section (table balcpt dans VoluCompta)
Remarque : Cette option remplace le programme tr_sec_val.4ge

Il faut paramétrer en tr_cpt_val alpha2[1,20], le chemin complet et le nom de la base de la comptabilité VoluCompta.

Possibilité de paramétrer plusieurs bases comptables (10 maxi).

Notes

DC

3 à 22 Chemin complet et nom de la base de la VoluCompta

Ne pas oublier de mettre en 777, le log.file, les tables sys*, balcpt et anahisto de la database VoluCompta pour permettre la lecture de ces fichiers.


v_reclamation Visualisation des réclamations

Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Tris Liste des noms de zones autorisés

Pour les types d'actions, voir le paramètre TAC.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de réclamation ou ne non-conformité interne

Exemple : -N[rce_num_rec]

Options

Orf

Réclamations fournisseurs

Valeur alpha 2

Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère10 | Lancement en Batch (E/F) E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractères 11 à 16 | Type et code du paramètre de lancement du programme de saisie des NCI (exemple #SANCI)
Caractères 17 à 22 | Type et code du paramètre de lancement du programme de saisie des réclamations (exemple #SARCL)
Caractères 35 à 37 | Longueur de la ligne éditable Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.

Valeur alpha 3

Titre de la visualisation

Par défaut : VISUALISATION DES RECLAMATIONS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère8 | Touche F8 | (O/N) | Détail ligne de commande
Caractère 12 | Touche F12 | (O/N) | Détail entête de commande
Caractère 14 | Touche F14 | (O/N) | Edition réclamation
Caractère 19 | Touche F19 | (O/N) | Détail de l'article
Caractère 21 | Touche F21 | (O/N) | Accès à la saisie des NCI ou réclamations clients
Caractère 37 | Touche CONTROL-B | (O/N) | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]
Caractère 38 | Touche CONTROL-C | (O/N) | Calculatrice
Caractère 51 | Touche CONTROL-T | (O/N) | Visualisation des touches
Caractère 56 | Touche CONTROL-Z | (O/N) | Lancement de programmes

Notes

RUN_EDIT_RECLAM | 21,26 Type et code du paramètre de lancement de l'édition des réclamations Exemple : #VERCL
_SUP_REQ_STK0_PF_EF | Complément de sélection sur la table stk0 Ce complément de sélection permet de ne voir que le stock à retraiter.
autres notes | Voir les notes communes à tous les programmes de visualisation (#VI)

Types de clés disponibles

Type de clé | Commentaires | Table | Clé
RECL | Réclamation client | reclamation | C-rce_num_rec
RECI | Non-conformité interne | reclamation | I-rce_num_rec
RECF | Réclamation fournisseurs | reclamation | F-rce_num_rec
RCAC | Réclamation client action corrective | reclam_action_cor | C-rac_num_rec-rac_num_action
RFAC | Réclamation fournisseurs action corrective | reclam_action_cor | F-rac_num_rec-rac_num_action
RIAC | Non-conformité interne action corrective | reclam_action_cor | I-rac_num_rec-rac_num_action

Types de notes disponibles

Type de note | Commentaires | Table
ACC | Actions correctives | reclam_action_cor
CAV | Description de l’avoir | reclamation
DES | Description de la réclamation | reclamation
DET | Détails réclamation | reclamation
IVE | Information sur les vérifications effectuées | reclamation
OBG | Observation générale de la réclamation | reclamation
RCA | Recherche de causes | reclamation
TRT | Traitement de la réclamation | reclamation

Ordres de tris disponibles

1 | tri_rce_type | Type de réclamation
2 | tri_rce_num_rec | Numéro de réclamation
3 | tri_rce_redacteur | Code rédacteur
4 | tri_rce_date_saisie | Date de saisie
5 | tri_rce_date_recept | Date de réception
6 | tri_rce_departement | Code département
7 | tri_rce_secteur | Code secteur
8 | tri_rce_statut | Statut
9 | tri_rce_num_of | Numéro d'OF
10 | tri_rce_code_client | Code client
11 | tri_rcd_ordre | Numéro d'ordre
12 | tri_rcd_num_cde | Numéro de commande
13 | tri_rcd_prod | Code produit
14 | tri_rde_code_defaut | Code défaut
15 | tri_rod_code_origine | Code origine
16 | tri_rtt_code_trait | Code traitement
17 | tri_rac_num_action | Numéro d'action

Liste des noms de zone autorisés

Notes sur la réclamation

Table RECLAMATION - Entête de la réclamation

Table RECLAMATION_DET - Détail de la réclamation

Table RECLAM_DEFAUT - Défauts constatés

Table RECLAM_ORI_DEFAUT - Origine des défauts

Table RECLAM_RESPONSAB - Responsables

Table RECLAM_TRAITEMENT - Traitements à réaliser

Table RECLAM_ACTION_COR - Actions correctives à mener

Table CDE1 - Entête de commande

Table CDE2 - Ligne de la commande

Table CDE4 - Nomenclature de la commande

Table CLI - Fiche tiers

Autres zones

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Bons de Retour Clients - Entête

Bons de Retour Clients - Lignes

Commandes Fournisseurs - Entête

Commandes Fournisseurs - Lignes

Bons de Réception et de Retour - Entête

Bons de Réception et de Retour - Lignes

Notes sur la réclamation

notes_calc_avoir | description du calcul de l avoir
notes_desc_reclam | description de la réclamation
notes_detail_reclam | détails réclamation
notes_traitement_reclam | traitement réclamation
notes_observations_reclam | observations générales réclamation
notes_infos_verif_reclam | informations sur les vérifications effectuées

Table RECLAMATION - Entête de la réclamation

rce_soc | Code société
rce_type | Type de document (Interne, Client, Fournisseur)
rce_num_rec | Numéro de document pour le type
rce_redacteur | Code rédacteur
rce_statut | Statut du document
rce_date_saisie | Date de saisie du document
rce_date_recept | Date de réception du document
rce_modele | Modèle (ADM Administratif, CDE Commande, FAC Facture)
rce_sup_corres | Support de correspondance
rce_corres_cli | Correspondant client
rce_retour_echant | Retour échantillon (O/N)
rce_qte_ret_echan | Quantité échantillon retournée
rce_date_ret_echan | Date de retour échantillon
rce_retour_mar | Retour marchandise (O/N)
rce_qte_ret_mar | Quantité de marchandise retournée
rce_date_ret_mar | Date retour marchandise
rce_pb_prix | Problème de prix (O/N)
rce_avoir_dem | Avoir demandé (O/N)
rce_mont_avo_dem | Montant avoir demandé
rce_estim_avo | Avoir estimé (O/N)
rce_num_of | Numéro d'oF
rce_secteur | Code secteur
libc_rce_secteur | Libellé court secteur
libl_rce_secteur | Libellé long secteur
rce_departement | Code département
libc_rce_departement | Libellé court département
libl_rce_departement | Libellé long département
rce_personne_pres | Nom des personnes présentes
rce_date_prev_tt | Date prévue de traitement
rce_tt_conforme | Traitement conforme (O/N)
rce_date_conforme | Date de gestion conformité
rce_visa | Code visa conformité
libc_rce_visa | Libellé court visa conformité
libl_rce_visa | Libellé long visa conformité
rce_edite | Document édité (O/N)
rce_cout_total | Cout total de la réclamation
rce_annu | Document annulé (O/N)
rce_date_trait | Date de traitement
rce_avoir_dec | Avoir décidé (O/N)
rce_mont_avo_dec | Montant avoir décidé
rce_estim_avo_dec | Estimation avoir décidé (O/N)
rce_frais_trsp | Frais de transport
rce_att_dos_qual | Attente de dossier contrôle qualité
rce_rep_ecrite | Réponse écrite (O/N)
rce_date_rep | Date de réponse
rce_code_client | Code client
rce_devise_avo | Devise de l'avoir
rce_datp_rech_caus | Date prévue de recherche de cause
rce_derogation | Code dérogation
libc_rce_derogation | Libellé court dérogation
libl_rce_derogation | Libellé long dérogation
rce_qte_litige | Quantité litigieuse
rce_qte_produite | Quantité produite
rce_date_cloture | Date de clôture

Table RECLAMATION_DET - Détail de la réclamation

Attention : au moins une zone de cette table doit être présente pour que les zones des tables cde1 et cde2 soient accessibles.

rcd_soc | Code société
rcd_type | Type réclamation (Interne, Client, Fournisseur)
rcd_num_rec | Numéro de document
rcd_ordre | Numéro d'ordre
rcd_num_cde | Numéro de commande
rcd_lig_cde | Ligne de commande
rcd_seq_cde | Séquence de commande
rcd_prod | Code produit
des_rcd_prod | Désignation du produit
rcd_quantite | Quantité de commande

Table RECLAM_DEFAUT - Défauts constatés

rde_soc | Code société
rde_type | Type document (Interne, Client, Fournisseur)
rde_num_rec | Numéro de document
rde_code_defaut | Code défaut
libc_rde_code_defaut | Libellé court défaut
libl_rde_code_defaut | Libellé long défaut
rde_commentaire | Commentaire

Table RECLAM_ORI_DEFAUT - Origine des défauts

rod_soc | Code société
rod_type | Type document (Interne, Client, Fournisseur)
rod_num_rec | Numéro de document
rod_code_defaut | Code défaut
libc_rod_code_defaut | Libellé court défaut
libl_rod_code_defaut | Libellé long défaut
rod_code_origine | Code origine
libc_rod_code_origine | Libellé court origine
libl_rod_code_origine | Libellé long origine
rod_secteur | Code secteur
libc_rod_secteur | Libellé court secteur
libl_rod_secteur | Libellé long secteur
rod_departement | Code département
libc_rod_departement | Libellé court département
libl_rod_departement | Libellé long département
rod_commentaire | Commentaire

Table RECLAM_RESPONSAB - Responsables

rrc_soc | Code société
rrc_type | Type document (Interne, Client, Fournisseur)
rrc_num_rec | Numéro de document
rrc_type_resp | Type de responsable
rrc_responsable | Code responsable
libc_rrc_responsable | Libellé court responsable
libl_rrc_responsable | Libellé long responsable
rrc_date_envoi | Date envoi du document

Table RECLAM_TRAITEMENT - Traitements à réaliser

rtt_soc | Code société
rtt_type | Type de document (Interne, Client, Fournisseur)
rtt_num_rec | Numéro de document
rtt_code_trait | Code traitement
libc_rtt_code_trait | Libellé court traitement
libl_rtt_code_trait | Libellé long traitement
rtt_date_trait | Date de traitement
rtt_qte | Quantité traitement
rtt_temps | Temps
rtt_cout_uni | Coût unitaire
rtt_cout_tot | Coût total
rtt_etap_fab | Etape de fabrication
libc_rtt_etap_fab | Libellé court étape de fabrication
libl_rtt_etap_fab | Libellé long étape de fabrication
rtt_commentaire | Commentaire
rtt_temps rtt_temps_ventil_1 rtt_temps_ventil_2 rtt_temps_ventil_3 rtt_temps_ventil_4 rtt_temps_ventil_5 | Temps de traitement. Zone cumulable Contiendra le temps du traitement (rtt_temps) si TRC A4[1] = O. Contiendra le temps du traitement (rtt_temps) si TRC A4[2] = O. Contiendra le temps du traitement (rtt_temps) si TRC A4[3] = O. Contiendra le temps du traitement (rtt_temps) si TRC A4[4] = O. Contiendra le temps du traitement (rtt_temps) si TRC A4[5] = O.
rtt_qte_rebut | Quantité rebutée
rtt_cout_uni_rebut | Coût unitaire du rebut
rtt_uni_rebut | Unité du rebut
libc_rtt_uni_rebut | Libellé court de l’unité du rebut
libl_rtt_uni_rebut | Libellé long de l’unité du rebut
zc1_rtt_uni_rebut | Zone numérique 1 de l’unité du rebut (coefficient de conversion)

Table RECLAM_ACTION_COR - Actions correctives à mener

rac_soc | Société
rac_type | Type de réclamation (Interne, Client, Fournisseur)
rac_num_rec | Numéro de réclamation
rac_num_action | Numéro action corrective
rac_code_service | Code service
libc_rac_code_service | Libellé court service
libl_rac_code_service | Libellé long service
rac_code_resp | Code responsable
libc_rac_responsable | Libellé court responsable
libl_rac_responsable | Libellé long responsable
rac_date_prev | Date prévue
rac_date_real | Date de réalisation
rac_ac_efficace | Action corrective efficace (O/N)
rac_date_verif | Date vérification efficacité
rac_visa | Visa de conformité
libc_rac_visa | Libellé court visa de conformité
libl_rac_visa | Libellé long visa de conformité
rac_rep_ecrite | Réponse écrite faite (O/N)
rac_date_rep | Date de réponse
rac_verif_a_faire | Vérification à faire (O/N)
notes_desc_action_cor | Description de l'action corrective

Table CDE1 - Entête de commande

Attention : au moins une zone de la table reclamation_det doit être présente pour que les zones de cette table soient accessibles.

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
copd_ec_ade | Code postal adresse réception
ville_ec_ada | Ville adresse réception
pays_ec_ada | Pays adresse réception
libc_pays_ec_ada | Libellé court pays adresse réception
libl_pays_ec_ada | Libellé long pays adresse réception
ec_adf | Code adresse facturation
copd_ec_adf | Code postal adresse facturation
ville_ec_adf | Ville adresse facturation
pays_ec_adf | Pays adresse facturation
libc_pays_ec_adf | Libellé court pays adresse facturation
libl_pays_ec_adf | Libellé long pays adresse facturation
ec_adl | Code adresse livraison
copd_ec_adl | Code postal adresse livraison
ville_ec_adl | Ville adresse livraison
pays_ec_adl | Pays adresse livraison
libc_pays_ec_adl | Libellé court pays adresse livraison
libl_pays_ec_adl | Libellé long pays adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_acc_euro | Acompte en EURO
ec_acc_dev | Acompte en devise
ec_pnt | Port non taxable en devise société
ec_pnt_euro | Port non taxable en EURO
ec_pnt_dev | Port non taxable en devise
ec_pht | Port taxable en devise société
ec_pht_euro | Port taxable en EURO
ec_pht_dev | Port taxable en devise
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accusé de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facturé
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande

Table CDE2 - Ligne de la commande

Attention : au moins une zone de la table reclamation_det doit être présente pour que les zones de cette table soient accessibles.

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Ligne de commande
lc_prod | Code article
lib_lc_prod | Désignation article (Fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (Ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteliv_reelle | Quantité réellement livrée
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_prx_euro | Prix unitaire vente en EURO
lc_prx_dev | Prix unitaire vente en devise
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé code zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code TVA
libc_lc_tva | Libellé court code TVA
libl_lc_tva | Libellé long code TVA
zc1_lc_tva | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_deldep | Date de départ
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (Non utilisée)
lc_heure_cli_tot | Heure de livraison souhaitée au plus tôt
lc_heure_cli_tard | Heure de livraison souhaitée au plus tard
lc_heure_dep_tot | Heure de départ au plus tôt
lc_heure_dep_tard | Heure de départ au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_fab_tot | Heure de fin de fabrication au plus tôt
lc_heure_fab_tard | Heure de fin de fabrication au plus tard
lc_colis | Nombre de colis
lc_prxcli | Prix client en devise société
lc_prxcli_euro | Prix client en EURO
lc_prxcli_dev | Prix Client en devise
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
copd_lc_adl | Code postal adresse livraison
ville_lc_adl | Ville adresse livraison
pays_lc_adl | Pays adresse livraison
libc_pays_lc_adl | Libellé court pays adresse livraison
libl_pays_lc_adl | Libellé long pays adresse livraison
lc_adf | Code adresse facturation
copd_lc_adf | Code postal adresse facturation
ville_lc_adf | Ville adresse facturation
pays_lc_adf | Pays adresse facturation
libc_pays_lc_adf | Libellé court pays adresse facturation
libl_pays_lc_adf | Libellé long pays adresse facturation
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_plus_euro | Prix unitaire vente au plus en EURO
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_prx_moins_euro | Prix unitaire vente au moins en EURO
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_prx_rvt_euro | Prix unitaire revient en EURO
lc_prx_rvt_dev | Prix unitaire revient en devise
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_prx_rvt_r_euro | Prix unitaire revient réel en EURO
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1 ==> Fenêtre Revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_annu | Ligne commande annulée
lc_ml_plancher | Mètre linéaire plancher
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Table CDE4 - Nomenclature de la commande

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Ligne de commande
nc_seq | Ligne de séquence
nc_prod | Code article
lib_nc_prod | Désignation article (Fiche article)
nc_coef_nom | Coefficient de nomenclature
nc_qtecde | Quantité commandée
nc_qteliv | Quantité livrée
nc_qteliv_non_val | Quantité livrée non validée
nc_qteliv_val | Quantité livrée validée
nc_rgt1 | Code lieu de rangement 1
libl_nc_rgt1 | Libellé long code lieu de rangement 1
libc_nc_rgt1 | Libellé court code lieu de rangement 1
nc_rgt2 | Code lieu de rangement 2
nc_rgt3 | Code lieu de rangement 3
nc_qtefab | Quantité fabriquée
nc_rstfab | Solder la fabrication (O/N)
nc_nummvt | Numéro de mouvement en stock
nc_nummvt2 | Numéro d'entrée prévisionnelle
nc_numfbi | Numéro de la FBI
nc_ligfbi | Numéro de ligne de la FBI
nc_solde | Ligne soldée
nc_reap | Mode de réapprovisionnement

Table CLI - Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

copd_cl_adra ville_cl_adra pays_cl_adra libc_pays_cl_adra libl_pays_cl_adra | Code postal adresse réception Ville adresse réception Pays adresse réception Libellé court pays adresse réception Libellé long pays adresse réception
copd_cl_adrb ville_cl_adrb pays_cl_adrb libc_pays_cl_adrb libl_pays_cl_adrb | Code postal adresse livraison Ville adresse livraison Pays adresse livraison Libellé court pays adresse livraison Libellé long pays adresse livraison
copd_cl_adrd ville_cl_adrd pays_cl_adrd libc_pays_cl_adrd libl_pays_cl_adrd | Code postal adresse offres de prix Ville adresse offres de prix Pays adresse offres de prix Libellé court pays adresse offres de prix Libellé long pays adresse offres de prix
copd_cl_adrf ville_cl_adrf pays_cl_adrf libc_pays_cl_adrf libl_pays_cl_adrf | Code postal adresse facturation Ville adresse facturation Pays adresse facturation Libellé court pays adresse facturation Libellé long pays adresse facturation

Table MAT - Fiche article

mp_soc | Code société
mp_code | Code article
mp_mp | Type article
mp_afnor | Code normalisé
lib_mp_afnor_art | Désignation article
lib_mp_afnor_ecma | Désignation ECMA
mp_des | Désignation article
mp_param | Zone données diverses
mp_fam | Code famille
libc_mp_fam | Libellé court code famille
libl_mp_fam | Libellé long code famille
mp_sfm | Code sous-famille
libc_mp_sfm | Libellé court code sous-famille
libl_mp_sfm | Libellé long code sous-famille
mp_libre | Zone libre
libc_mp_libre | Libellé court zone libre
libl_mp_libre | Libellé long zone libre
mp_rgt1 | Code lieu rangement 1
libc_mp_rgt1 | Libellé court code lieu rangement 1
libl_mp_rgt1 | Libellé long code lieu rangement 1
mp_rgt2 | Code lieu rangement 2
mp_rgt3 | Code lieu rangement 3
mp_dt1 | Donnée technique numérique 1
mp_dt2 | Donnée technique numérique 2
mp_dt3 | Donnée technique numérique 3
mp_dt4 | Donnée technique numérique 4
mp_dt5 | Donnée technique numérique 5
mp_dt6 | Donnée technique numérique 6
mp_dt7 | Donnée technique numérique 7
mp_dt8 | Donnée technique numérique 8
mp_at1 | Donnée technique alphanumérique 1
mp_at2 | Donnée technique alphanumérique 2
mp_hau | Hauteur
mp_lon | Longueur
mp_lar | Largeur
mp_cond | Code conditionnement
libc_mp_cond | Libellé court code conditionnement
libl_mp_cond | Libellé long code conditionnement
mp_coul | Code couleur
libc_mp_coul | Libellé court code couleur
libl_mp_coul | Libellé long code couleur
mp_poids | Poids
mp_ua | Code unité achat
libc_mp_ua | Libellé court code unité achat
libl_mp_ua | Libellé long code unité achat
zc1_mp_ua | Valeur 1 code unité achat
mp_uv | Code unité vente
libc_mp_uv | Libellé court code unité vente
libl_mp_uv | Libellé long code unité vente
zc1_mp_uv | Valeur 1 code unité vente
mp_uvente | Code unité vente 2
libc_mp_uvente | Libellé court code unité vente 2
libl_mp_uvente | Libellé long code unité vente 2
zc1_mp_uvente | Valeur 1 code unité vente 2
mp_fconv | Code formule conversion
libc_mp_fconv | Libellé court code formule conversion
libl_mp_fconv | Libellé long code formule conversion
mp_fconv2 | Code formule conversion 2
libc_mp_fconv2 | Libellé court code formule conversion 2
libl_mp_fconv2 | Libellé long code formule conversion 2
mp_remp | Code article remplacement
lib_mp_remp | Désignation article remplacement
mp_pamp | Valeur stock
mp_pa | Prix achat
mp_cfrais | Taux frais
mp_cperte | Taux perte
mp_pr | Prix revient
mp_marg | Taux marge
mp_pv | Prix vente
mp_pv2 | Prix vente dans unité utilisation
mp_tva | Code TVA
libc_mp_tva | Libellé court code TVA
libl_mp_tva | Libellé long code TVA
zc1_mp_tva | Valeur 1 code TVA
mp_cpta | Compte achat
mp_cptv | Compte vente
mp_ana | Code analytique
mp_suistk | Suivi en stock
mp_tval | Type valorisation
mp_dermvt | Date dernier mouvement
stock |
mp_derinv | Date dernier inventaire stock
mp_derent | Date dernière entrée stock
mp_dersor | Date dernière sortie stock
mp_smini | Stock mini
mp_smaxi | Stock maxi
mp_sdisp | Stock disponible
mp_sphy | Stock physique
mp_sres | Stock réserve
mp_sbes | Stock besoins
mp_scdef | Stock en commande ou en fabrication
mp_ssim | Stock simulation
mp_minfou | Minimum commande fournisseur ou fabrication
mp_abc | Classement ABC
mp_controle | Code controle qualité
mp_reap | Code réapprovisionnement
libc_mp_reap | Libellé court code réapprovisionnement
libl_mp_reap | Libellé long code réapprovisionnement
mp_foucli | Code fournisseur
nom_mp_foucli | Nom fournisseur
mp_cli | Code client
nom_mp_cli | Nom client
mp_qteeco | Quantité économique commande ou fabrication
mp_delmoy | Délai moyen d'approvisionnement
mp_ndm | Numéro dernier mouvement stock
mp_qualite | Code qualité
libc_mp_qualite | Libellé court code qualité
libl_mp_qualite | Libellé long code qualité
mp_z1 | Zone paramétrée 1
mp_z2 | Zone paramétrée 2
mp_z3 | Zone paramétrée 3
mp_z4 | Zone paramétrée 4
mp_z5 | Zone paramétrée 5
mp_alerte | Stock alerte
mp_gestionnaire | Code gestionnaire
libc_mp_gestionnaire | Libellé court code gestionnaire
libl_mp_gestionnaire | Libellé long code gestionnaire
mp_pr_fixe | Prix fixe
mp_coefdiv_ffix | Coefficient diviseur frais fixe
mp_affect | Numéro affectation
mp_cdc | Code centre de coût
lib_mp_cdc | Libellé centre de coût
mp_devis | Numéro devis
mp_sdevis | Numéro sous-devis
mp_gencod | Code gencod
mp_itf14 | Code ITF14
mp_anu | Article annulé
mp_date | Date enregistrement article

Autres zones

using | Voir #VI
num_avoir | Numéro d'avoir Il s'agit du numéro d'avoir issu de la gestion des retours (bon_de_retour) ou du numéro du premier avoir fait sur la commande liée à la réclamation.
date_avoir | Date de l'avoir Il s'agit du numéro d'avoir issu de la gestion des retours (bon_de_retour) ou du numéro du premier avoir fait sur la commande liée à la réclamation.
stk_pf | Stock du PF de la commande associée à la réclamation2
stk_encours | Stock encours de fabrication de la commande associée à la réclamation


Epuration de la traçabilité

Epuration de la traçabilité epu_traca

Le paramétrage se situe dans #CF TRA : note commençant par NBJOURS_RETENTION_


Saisie des non-conformités internes

Saisie des non-conformités internes nci_saisie

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de non-conformité interne

Exemple : -N[rce_num_rec]

Options

-Ona | Numérotation annuelle
-Oxm | Ecran de saisie fax/email
-Ova | Validation automatique de la fenêtre de gestion de fax/email

Valeur alpha 2

Caractères 1 à 6

Type et code du paramètre de lancement de l'édition (reclam_edition)

Notes pour la gestion des sites

Des notes similaires existent pour la saisie des réclamations.

Tableau de bord du multisite

GESTION_SITE | 21 Gestion du site à partir de la commande (C) ou d'un paramètre (P)
SITE_DEFAUT | 21,23 Valeur du site par défaut, paramètre SIT. En gestion de site P, ce sera ce site qui sera utilisé dans la saisie. S'il n'est pas renseigné, on prendra celui de l'utilisateur.
CONTROL_SITE | Contrôle su site N pas de contrôle B contrôle bloquant W contrôle non bloquant C contrôle demandant une confirmation Le contrôle dépend du mode de gestion du site (C ou P). 1) S'il provient du paramétrage (P), l'OF devra appartenir à ce site. 2) S'il provient de la commande (C), il n'y aura pas de contrôle.

Notes

Voir aussi les notes dédiées à la gestion des sites (ci-dessus).

TITRE_DOCUMENT | 21 à 23 Type de document (NCI) 25 à 60 Titre du document pour la fenêtre de gestion du fax/email. Celui-ci sera suivi de la mention N° et de la clé du document. Exemple : NON-CONFORMITE
OBJET_DOCUMENT | 21 à 23 Type de document (NCI) 25 à 60 Objet du document pour le fax/email Exemple : Veuillez recevoir ci-joint votre réclamation client
EMETTEUR_FAX_EMAIL | 21 à 26 Type et code de paramètre de l'expéditeur du fax/email
TYC_OF_AUTORISE | 21 à 23 TYC rattaché autorisé. 10 notes maximum

Paramètres nécessaires

Voir reclam_cli_saisie pour une liste exhaustive des paramètres associés.

Notes TYPE_ENVOI_DOCUMENT sur les correspondants destinataires sur #SOC

(type de document = NCI)


Saisie des réclamations clients ou fournisseurs

Saisie des réclamations clients ou fournisseurs reclam_cli_saisie

Gestion des statuts

Si la gestion des statuts est faite en automatique, les états sont les suivants :

1 Non traitées (état affecté lors de la création de la réclamation)

2 Traitement en cours (état affecté lors de la saisie d'une date de traitement)

3 En attente de dossier (état affecté lors de la saisie d'une date de traitement et dossier en attente)

4 Close (état affecté s'il n'y a pas de dossier en attente, si toutes les actions correctives ont une date de vérification, un visa et une note de type ACC)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de réclamation client

Exemple : -N[rce_num_rec]

Valeurs numériques

1

Numéro du compteur à utiliser pour la numérotation automatique de la réclamation client

Options triées

Oms | Permet la saisie manuelle du statut
Ona | Numérotation annuelle
Oqr | Gestion des nouvelles zones concernant la quantité rebutée au niveau des traitements
Orf | Réclamation fournisseur
Ova | Validation automatique de la fenêtre de gestion de fax/email
Oxm | Ecran de saisie fax/email

Valeur alpha 2

Caractères 1 à 3 | Code support de correspondance par défaut
Caractère 4 | Type de fenêtre de recherche F7 sur produit 1 Recherche normale (valeur par défaut) 2 Recherche sur les données techniques 3 Recherche papier Q Recherche qualité carton T Recherche transformateur
Caractères 5 à 10 | Type et code du paramètre de lancement de l'édition
Caractère 11 | Accès à la saisie des défauts (touche F6) (O/N, N par défaut) O L'accès se fait à partir de l'écran principal. N L'accès se fait à partir de l'écran de traitement (F11 depuis l'écran principal)
Caractère 12 | Saisie de la date prévue des actions correctives obligatoire (O/N, O par défaut)
Caractère 13 | Saisie d'un retour de marchandise obligatoire pour pouvoir saisir des traitements à réaliser (F11 à partir de l'écran principal puis maj+F1 à partir de l'écran de traitement des réclamations) (O/N, O par défaut).
Caractère 14 | Contrôle de la quantité en litige N Pas de contrôle (Valeur par défaut) W Contrôle avec message d'avertissement C Contrôle avec demande de confirmation B Contrôle bloquant
Caractère 15 | Type de contrôle si présence de stock PF et stock encours sur la commande (N/W/C/B, N par défaut) Possibilité de contrôler le stock PF et stock encours d'une commande lors de la saisie des réclamations.
Caractère 16 | Edition de la réclamation à la validation de la saisie N Pas d'édition [valeur par défaut] C Edition automatique à la création uniquement M Edition automatique à la modification uniquement T Edition automatique dans tous les cas U Pose la question à l'utilisateur

Notes pour la gestion des sites

Des notes similaires existent pour la saisie des non-conformités internes.

Tableau de bord du multisite

GESTION_SITE | 21 Gestion du site à partir de la commande (C) ou d'un paramètre (P)
SITE_DEFAUT | 21,23 Valeur du site par défaut, paramètre SIT. En gestion de site P, ce sera ce site qui sera utilisé dans la saisie. S'il n'est pas renseigné, on prendra celui de l'utilisateur.
CONTROL_SITE | Contrôle su site N pas de contrôle B contrôle bloquant W contrôle non bloquant C contrôle demandant une confirmation Le contrôle dépend du mode de gestion du site (C ou P). 1) S'il provient du paramétrage (P), les commandes devront appartenir à ce site. 2) S'il provient de la commande (C), toutes les commandes devront avoir le même site que celui de la première commande saisie.

Notes triées

Voir aussi les notes dédiées à la gestion des sites (ci-dessus).

ACCES_VISU_CDE | 21,26 Type et code du paramètre d'accès à la visualisation des commandes clients
ACCES_VISU_CDF | 21,26 Type et code du paramètre d'accès à la visualisation des commandes fournisseurs
EMETTEUR_FAX_EMAIL | 21,26 Type et code du paramètre de l'expéditeur du fax/email. Par exemple, REPXXX
OBJET_DOCUMENT | 21,23 Type de document (RCL) 25,60 Objet du document pour le fax/email Exemple : Veuillez recevoir ci-joint votre réclamation client
TITRE_DOCUMENT | 21,23 Type de document (RCL) 25,60 Titre du document pour la fenêtre de gestion du fax/email. Celui-ci sera suivi de la mention N° et de la clé du document. Exemple : NON-CONFORMITE

Paramètres associés - programmes connexes

#SOC | Notes TYPE_ENVOI_DOCUMENT sur les correspondants destinataires (type de document = RCL)
cde A4[32] | Contrôle de la présence d'une réclamation client pour le produit (ou l'un de ses composants) saisi sur la ligne de commande
cde | Note _SUP_REQ_RECLAM - Complément de requête sur les réclamations clients
DCO | Défaut constaté
DRC | Département de la réclamation
DRG | Dérogations
ODQ | Origine des défauts constatés
RRC | Responsable de la réclamation
SEN | Service de l'action corrective
SRC | Secteur de la réclamation
SUC | Support de correspondance
TQE | Etape de fabrication
TRC | Traitement de la réclamation
TSC | Type de clé N. Par exemple, pour ajouter une zone de saisie pour l'archivage des éditions des réclamations.
USE A1[1,8] | Code opérateur (seul le rédacteur de la réclamation a le droit de la modifier)
USE A2[35] | Droit de saisir les traitements sur la réclamation (O/N, N par défaut)
VRC | Visa de conformité de la réclamation
Traçabilité | La table des réclamations porte le N°6. Paramétrage en A2[26,30]
Table des notes | nn_type = (N = non-conformité interne / C = réclamation client) nn_cle = N° de la réclamation nn_type_note peut prendre les valeurs suivantes : ACC Actions correctives à mener CAV Descriptif calcul avoir DES Descriptif réclamation DET Descriptif réclamation sur l'écran traitement IVE Vérification effectuées OBG Observations générales RCA Recherche des causes TRT Traitement réclamation
Tables concernées | reclamation Réclamations clients et Non-conformités internes reclamation_det Détails reclam_action_cor Actions correctives reclam_defaut Défauts constatés reclam_ori_defaut Origines des défauts reclam_responsab Responsables reclam_traitement Traitements
v_reclamation | Visualisation des réclamations et des NCI A2[11,16] Type et code du paramètre de lancement du programme de saisie des NCI (par ex.#SANCI) A2[17,22] Type et code du paramètre de lancement du programme de saisie des réclamations (par ex. #SARCL)
reclam_edition | Edition des réclamations (VoluEdit)
nci_saisie | Saisie des NCI (non-conformités internes)
lance_edition | Enchaînement automatique d'éditions. Note commençant par NCE


Gestion du fichier des prospects

Gestion du fichier des prospects prospect

Options Valeur alpha 2 Valeur alpha 3 Notes Paramètres associés Table visite

Options

jxx | Numéro du jour dans la semaine du premier jour de la semaine Exemple j03: le mercredi au lieu du lundi est considéré comme le premier jour de la semaine Utilisé dans pro_chx_sem.4gl (détourne num_sem et date_sem)
Oas | Tri en ordre croissant pour les actions
Oc3 | Enregistrement des notes des prospects dans cli3 au lieu de note_act.
Ocd | Contrôle de la mise à jour des actions sur la date de l'événement plutôt que sur la date d'action
Ocl | Le type de tiers Client (C) est interdit. Cette option annule et remplace l'ancienne où le type P était configuré dans le client par défaut 000000.
Oco | Consultation du prospect sans modification possible
Ode | Tri en ordre décroissant pour les actions
Oen | Edition en mode non condensé
Of2 | Ouvertures de la fenêtre 2 pour sélection de critères en interrogation et édition
Ofo | Le type de tiers fournisseur (F) est interdit.
Ona | Numérotation automatique des codes prospects
Ooq | Demande si on désire en ordre décroissant ou croissant pour le tri des actions
Opr | Le type de tiers prospect (P) est interdit.
Ote | Edition avec le titre pour les étiquettes
Otp | Top facturation automatique (inhibe la saisie du champ date facturation dans pro_cde.4gl)
Ozp | Lecture de cl_zpar et affectation à ec_c1 pour commande commerciale

Valeur alpha 2

Paramétrage de l'édition prospect et action

Caractères 1 à 25 | Edition des prospects
Caractères 26 à 45 | Edition de la fiche action
Caractères 46 à 60 | Types de notes autorisées à l'édition

Edition des prospects

A | Code prospect
B | Nom du prospect
C | Adresse 1
D | Adresse 2
E | Code postal
F | Ville
G | Code suivi par
H | Libellé suivi par
I | Téléphone
J | Télécopie
K | Télex
L | Code secteur activité
M | Libellé secteur activité
N | Nom du 1er correspondant
O | Code fonction du 1er correspondant
P | Libellé fonction
Q | Téléphone 1er correspondant
R | Nom du 2ème correspondant
S | Code fonction du 2ème correspondant
T | Libellé fonction
U | Téléphone 2ème correspondant
V | Code forme juridique
W | Libellé forme juridique
X | Code A.P.E
Y | Nombre de salarié
Z | C.A
a | C.A potentiel dans notre secteur d'activité
b | Code paramètre 1
c | Libellé paramètre 1
d | Code paramètre 2
e | Libellé paramètre 2
f | Zone de paramétrage
g | Zone date 1 libellé paramétrable
h | Zone date 2 libellé paramétrable
i | Zone numérique 1 libellé paramétrable
j | Zone numérique 2 libellé paramétrable
k | Zone alpha 1 libellé paramétrable
l | Zone alpha 2 libellé paramétrable
m | Code origine
n | Libellé origine
o | Type (prospect, client , suivi)
p | Code secteur géographique
q | libellé secteur géographique
r | Code catégorie
s | Libellé catégorie
t | Code pays
u | Date de création du prospect
v | Libellé court du pays
w | Zone paramétrée
x | Libellé court de la zone paramétrée
y | Code qualité tiers
z | Libellé court de la qualité tiers
1 | Code du suivi d'affaires
2 | Libellé court du suivi d'affaire

Edition de la fiche action

A | Code prospect
B | Nom du prospect
C | Date de l'action
D | Code mené par
E | Libellé mené par
F | Code événement
G | Libellé événement
H | Code de réalisation
I | Date de réalisation
J | Délai
K | Ecart de réalisation
L | Nom de fichier
M | Code origine
N | Libellé origine
O | Adresse ligne 1
P | Adresse ligne 2
Q | Code postal
R | Ville
S | Numéro de téléphone du prospect
T | Type (prospect, client , suivi)
U | Code secteur géographique
V | Libellé secteur géographique
W | Numéro
X | Code secteur activité
Y | Libellé secteur activité
Z | Code catégorie
a | Libellé catégorie

Types de notes autorisées à l'édition

Pour les types de notes autorisées, voir le paramètres NTS

Valeur alpha 3

Edition de la fiche de visite

Caractères 1 à 25

Edition de la fiche visite

A | Code prospect
B | Raison sociale
C | Date de la visite (real :négociation)
D | But de la visite
E | Qui décide
F | Fonction
G | Libellé fonction
H | Date de décision
I | C.A estime
J | Etape (accroche, négociation, conclusion, etc.)
K | Libellé étape
L | Note sur l'étape
M | Observations
O | Adresse ligne 1
P | Adresse ligne 2
Q | Code postal
R | Ville
S | Numéro de téléphone du prospect
T | Type (prospect, client , suivi)
U | Code secteur géographique
V | Libellé secteur géographique
W | Numéro
X | Code secteur activité
Y | Libellé secteur activité
Z | Code catégorie
a | Libellé catégorie
b | Numéro de Télécopie du prospect
c | Date de l'action (date act approche)
d | Code mené par
e | Libellé mené par
f | Code événement
g | Libellé événement
h | Code de réalisation
j | Délai
k | Ecart de réalisation
l | Nom de fichier

Notes

_SUP_ORDER_BY_ACT

21, 60 Complément de tri sur les tables clients (cli), actions (action), visites (visite, si accessible)

Paramètres associés

#CF ATL | A1[2] Type de fenêtre en interrogation
#CF CLI | Libellé du champ z_param
#CF PRS | Deuxième écran de la fiche prospect
ACT | Secteur d'activité
CAT | Catégorie
DEN | Paramètre dénomination forme juridique
DPC | Détail du prix de la commande
ETP | Paramètre étape de visite (accroche, conclusion, etc)
EVT | Type d'événement :A1[1] ouvre ou non la fiche de visite.
GEO | Secteur géographique
LIB | Paramétrage des libellés LIB PR1 Libellé de la 1ère zone paramétrable de la fenêtre 2 .On prend le libellé court LIB PR2 Libellé de la 2ème zone paramétrable de la fenêtre 2 .On prend le libellé court LIB PR4 Libellé de la zone date 1 de la fenêtre 2 .On prend le libellé long LIB PR5 Libellé de la zone date 2 de la fenêtre 2 .On prend le libellé long LIB PR6 Libellé de la zone numérique 1 de la fenêtre 2 .On prend le libellé long LIB PR7 Libellé de la zone numérique 2 de la fenêtre 2 .On prend le libellé long LIB PR8 Libellé de la zone alpha 1 de la fenêtre 2 .On prend le libellé long LIB PR9 Libellé de la zone alpha 2 de la fenêtre 2 .On prend le libellé long
MRA | Mode Réalisation Action
ORG | Paramètre origine
PHS | Libellé des dates dans le suivi des dates
SUI | Paramètre suivi par
TCO | Paramètre fonction du correspondant
UNI | Unité d'œuvre


Gestion du planning des actions

Gestion du planning des actions planing

Options

-Oen | Edition en mode non condensé
-Ott | Edition du cumul de charge (+ des délais)
-Oar | Edition des actions réalisées et non plus des actions à réaliser

Valeur alpha 2

Paramétrage de l'édition planning

Caractères 1 à 25

Edition du planning

Edition du planning

A | Raison sociale
B | Date de réalisation
C | Code action menée par
D | Libellé mené par
E | Code évènement
F | Libellé évènement
G | Délai de réalisation
H | Adresse du client 1
I | Adresse du client 2
J | Code postal
K | Ville
L | Téléphone
M | Code secteur géographique
N | Libellé secteur géographique
O | Code secteur d'activité
P | Libellé secteur d'activité
Q | A réalisé ou R réalisé
R | Date de fin
S | Fichier
T | Code client
U | Colonne vide sans titre de 5 caractères de large
V | Code représentant
W | Libellé court du représentant
X | Numéro de télécopie
Y | Nom du correspondant
Z | Titre du correspondant
a | Libellé court du titre du correspondant
b | Téléphone 2
c | Code origine du prospect
d | Libellé court du code origine du prospect
e | Type du tiers édité
f | Code catégorie du prospect
g | Libellé court du code catégorie du prospect
h | Code du pays
i | Date de création du prospect
j | Libellé court du pays
k | Zone paramétrée
l | Libellé court de la zone paramétrée
m | Code qualité tiers
n | Libellé court de la qualité tiers
o | Code du suivi d'affaire
p | Libellé court du suivi d'affaire

Types de notes autorisées à l'édition

Pour les types de notes autorisées, voir le paramètres NTS

#CF PRS

On va chercher le début de la ligne de notes comme dans les prospects

Valeur alpha

Paramétrage des zones paramétrables

Caractères 1 à 3 | Paramètre 1ère zone paramétrable de la fenêtre 2 de la fiche prospect
Caractères 4 à 6 | Paramètre 2ème zone paramétrable de la fenêtre 2 de la fiche prospect
Caractères 7 à 8 | Colonne de début d'édition des notes

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour annulation physique à blanc si pas de mot de passe
Caractères 6 à 60 | Chemin d'accès à uniplex

Zone note

Paramétrage de la zone de paramétrage de la fenêtre 2 de la fiche prospect

Caractères 1 à 2 | Numéro de ligne du tableau de la zone de paramétrage
Caractères 3 à 27 | Libellé de la ligne du tableau
Caractère 28 | Code paramètres
Caractères 29 à 53 | Libellé du code paramètre

Valeur alpha 3

Caractère 1

Saisie obligatoire de la charge machine et ventilation financière

Valeur alpha 4

Caractères 1 à 3

Type de machine (simplifie la recherche F7)


Edition du carnet de commandes

Edition du carnet de commandes pro_etat1

Le carnet de commande commercial est alimenté par Volugold. L'avancement des commandes est réalisé dans la table suiv_cde. Les commandes peuvent être

  • en cours

  • livrées

  • Facturées

Options

-Oen | Edition en mode non condensé
-Otf | Pas d'édition du total par fabricant
-jxx | Numéro du jour dans la semaine du premier jour de la semaine (Exemple j03: mercredi au lieu de lundi est considéré comme le premier jour de la semaine) Utilisé dans pro_chx_sem.4gl (détourne num_sem et date_sem) afin de modifier la semaine calendaire

Valeur alpha 2

Paramétrage de l'édition commande en cours

Caractères 1 à 25 | Colonage édition des commandes en cours
Caractère 26 | Ed ventilation prix associée

Colonage état commande en cours

A | Code client/prospect
B | Raison sociale
C | Code action menée par
D | Libellé mené par
E | Numéro de commande
F | Libellé commande
G | Date commande
H | Adresse du client
I | Adresse du client
J | Code postal
K | Ville
L | Téléphone
M | Montant de toutes les commandes en cours
N | Quantité commande
O | Montant commandes en cours - entrées de la semaine
P | Montant des commandes entrées dans la semaine
Q | Date de livraison prévue
T | Commentaire associe à la commande
U | code fabricant (SUI)
V | Nom du fabricant
b | Raison sociale (court : 15 caractères)

Valeur alpha 3

Paramétrage de l'édition commandes livrées

Caractères 1 à 25 | Colonage édition des commandes livrées
Caractère 26 | Edition ventilation prix (MO, imp, etc.)

Colonage état commandes livrées

A | Code client/prospect
B | Raison sociale
C | Code action menée par
D | Libellé mené par
E | Numéro de commande
F | Libellé commande
G | Date commande
H | Adresse du client
I | Adresse du client
J | Code postal
K | Ville
L | Téléphone
M | Montant de toutes les commandes livrées
N | Quantité commande
O | Montant = (commandes livrées - livrées dans la semaine )
P | Montant des commandes livrées dans la semaine
Q | Date de livraison prévue
R | Date de livraison réalisé
T | Commentaire associe à la commande
U | code fabricant (SUI)
V | Nom du fabricant

Valeur alpha 4

Paramétrage de l'édition commandes facturées

Caractères 1 à 25 | Colonage édition des commandes facturées
Caractère 26 | Edition ventilation prix (MO, imp, etc.)

Colonage état commandes facturées

A | Code client/prospect
B | Raison sociale
C | Code action menée par
D | Libellé mené par
E | Numéro de commande
F | Libellé commande
G | Date commande
H | Adresse du client
I | Adresse du client
J | Code postal
K | Ville
L | Téléphone
M | Montant de toutes les commandes facturées
N | Quantité commande
O | Montant = (commandes facturées - facturées dans la semaine)
P | Montant des commandes facturées la semaine
Q | Date de livraison prévue
R | Date de livraison réalisé
S | Date de facturation
T | Commentaire associe à la commande
U | Code fabricant (SUI)
V | Nom du fabricant


Edition du cumul hebdomadaire par commercial

Edition du cumul hebdomadaire par commercial pro_etat2

Les commandes commerciales sont alimentées par Volugold.

L'historisation des commandes est réalisée dans la table histo_cde.

Les éditions sont les suivantes :

  • Edition des entrées hebdo par commercial (depuis le début de l'année)

  • Edition entrées de la semaine courante

Options

-Oen | Edition en mode non condense
-jxx | Numéro du jour dans la semaine du premier jour de la semaine (Exemple j03: mercredi au lieu de lundi est considéré comme le premier jour de la semaine) Utilisé dans pro_chx_sem.4gl (détourne num_sem et date_sem) afin de modifier la semaine calendaire

Valeur alpha 2

Paramétrage édition cumul entrées représentant

Caractères 1 à 25

Colonage édition des entrées cumulées

Valeur alpha 3

Paramétrage de édition entrées semaine

Caractères 1 à 25

Colonage édition entrées semaine

Colonage édition (alpha2 & alpha3)

A | Code action menée par
B | Libellé mené par
C | An/Sem (format AASS)
c | An/Sem (format SS)
D | C.A. en commande
E | C.A. prévisionnel (objectifs)
F | Nombre de commande
G | C.A. livré
H | C.A. facturé
I | Commission
J | % commission
K | Total C.A. commande
L | Total C.A. prévisionnel
M | Nombre total de commandes
N | Total C.A livre
O | Total C.A. facture
P | Total commission
Q | Moyen C.A. commande
R | Moyen C.A. prévu
S | Moyen nb commande
T | Moyen C.A. livre
U | Moyen C.A. facture
V | Moyen commission


Edition du cumul hebdomadaire par société - groupe

Edition du cumul hebdomadaire par société - groupe pro_etat3

Les commandes commerciales sont alimentées par Volugold.

L'historisation des commandes est réalisée dans la table histo_cde.

Les éditions sont les suivantes :

  • Edition des entrées hebdo par société(depuis début année)

  • Edition entrées de la semaine courante par société

  • Edition des entrées hebdo pour groupe(depuis deb année)

Options

-Oen | Edition en mode non condense
-jxx | Numéro du jour dans la semaine du premier jour de la semaine (Exemple j03 : mercredi au lieu de lundi est considéré comme le premier jour de la semaine) Utilisé dans pro_chx_sem.4gl (détourne num_sem et date_sem) afin de modifier la semaine calendaire

Valeur alpha 2

Paramétrage de l'édition cumul hebdo société

Caractères 1 à 25

Colonage édition des entrées cumulées

Valeur alpha 3

Paramétrage l'édition entrées semaine société

Caractères 1 à 25

Colonage édition des entrées cumulées

Valeur alpha 4

Paramétrage l'édition cumul groupe société

Caractères de 1 à 25

Colonage édition des entrées cumulées

Colonage édition (alpha2 & alpha3 & alpha4)

A | Code action menée par
B | Libellé mené par
C | An/Sem (format AASS)
c | An/Sem (format SS)
D | C.A. en commande
E | C.A. prévisionnel (objectifs)
F | Nombre de commande
G | C.A. livré
H | C.A. facturé
I | Commission
J | % commission
K | Total C.A. commande
L | Total C.A. prévisionnel
M | Nombre total de commandes
N | Total C.A livre
O | Total C.A. facture
P | Total commission
Q | Moyen C.A. commande
R | Moyen C.A. prévu
S | Moyen nb commande
T | Moyen C.A. livre
U | Moyen C.A. facture
V | Moyen commission
W | CA à facturer (N/O)

Spécifique édition pour le groupe

i | An/Se
j | Se
d | C.A. commande remplace D, E, F, G, H
e | C.A. prévisionnel
f | Nombre commande
g | C.A. livre
h | C.A. facture
j | CA à facturer (N/O)


Saisie du CA prévisionnel commercial par société

Saisie du CA prévisionnel commercial par société pro_prev

Options

-Omo

Permet de modifier les C.A. commande, C.A livraison, C.A facturation ainsi que le nombre de commandes


Edition du planning suivi commande

Edition du planning suivi commande pro_etat4

Valeur numerique1

Type du code de rattachement

1 = Type commande

Options

-Oen

Edition en mode normal (mode condense par défaut)

Libellé long

Libellé de l'écran de sélection

Valeur alpha 2

Paramétrage colonage 1er état

Caractères 1 à 3 | Type étape 1 (code paramètre PHS)
Caractères 4 à 6 | Type étape 2 (code paramètre PHS)
Caractères 7 à 9 | Type étape 3 (code paramètre PHS)

On a le droit d'éditer 3 étapes au maximum par état.

Le type étape 1 sera assigné au chiffre 1, le type étape 2 sera assigné au chiffre 2.

Ce paramétrage est utilisé pour la fonction DATE_sai().

Caractères 15 à 50

Colonage de l'état (cf détails paramètres)
Nota AB2T1
Indique colonne 1 = A
Indique colonne 2 = B
Indique colonne 3 = 2 (étape 2 : liste de date)
Indique colonne 4 = T
Indique colonne 5 = 1

Valeur alpha 3

Paramétrage colonage 1er état

Caractères 1 à 3 | Type étape 1 (code paramètre PHS)
Caractères 4 à 6 | Type étape 2 (code paramètre PHS)
Caractères 7 à 9 | Type étape 3 (code paramètre PHS)

On a le droit d'éditer 3 étapes au maximum par état

Le type étape 1 sera assigné au chiffre 1, le type étape 2 sera assigné au chiffre 2.

Ce paramétrage est utilisé pour la fonction DATE_sai()

Caractères 15 à 50

Colonage de l'état (cf détails paramètres)
Nota AB2T1
Indique colonne 1 = A
Indique colonne 2 = B
Indique colonne 3 = 2 (étape 2 :liste de date)
Indique colonne 4 = T
Indique colonne 5 = 1

Valeur alpha 4

Caractères 1 à 30 | Libellé du menu choix report1 et titre du report
Caractères 16 à 31 | Libellé du menu choix report2 et titre du report2

Colonage etat1(alpha2[15,50] et etat2(alpha3[15,50]

A | Code client/prospect
B | Raison sociale
C | Code action menée par
D | Libellé mené par
E | Numéro de commande
F | Libellé commande
G | Date commande
H | Adresse du client
I | Adresse du client
J | Code postal
K | Ville
L | Téléphone
M | Montant commandes
N | Quantité commande
Q | Date de livraison prévue
R | Date de livraison réalisé
S | Date de facturation
T | Commentaire associe à la commande
U | Code fabricant (SUI)
V | Nom du fabricant
1 | Etape 1 (alpha2 1-3) (alpha3 1-3)
2 | Etape 2 (alpha2 4-6) (alpha3 4-6)
3 | Etape 3 (alpha2 7-9) (alpha3 7-9)


Top facturation automatique

Top facturation automatique pro_top

Batch de Top facturation qui regarde pour les commandes commerciales SUIV_CDE si les quantités à facturer = 0 pour chaque ligne de la commande alors la commande est facturée

Options

-jxx

Numéro du jour dans la semaine du premier jour de la semaine (Exemple j03 : mercredi au lieu de lundi est considéré comme le premier jour de la semaine)
Utilisé dans pro_chx_sem.4gl (détourne num_sem et date_sem) afin de modifier la semaine calendaire


Edition des charges machines hebdomadaire

Edition des charges machines hebdomadaire pro_etat5

Edition de la charge machine hebdomadaire

La charge par machine est enregistrée dans la table SUIV_MAC alimentée par la fonction sai_tab_suiv_mac()

Options

-Oen

Edition en mode normal (condensé par défaut)

Valeur alpha 2

Caractères 1 à 60

Titre par défaut de l'état

Valeur alpha 3

Paramétrage de l'édition

Caractères 1 à 25

Colonage édition de la charge

Valeur alpha 4

Il faut donner la liste des sociétés à éditer (par défaut c'est la société courante)

Caractères 1 à 3 | Code société 1
Caractères 4 à 6 | Code société 2

Colonage édition plan de charge machine

A | Code société (société qui a planifié la charge)
B | Libellé société
C | Semaine (format aass)
D | Code machine
E | Désignation machine
F | Code client
G | Nom client (raison sociale)
H | Code représentant
I | Nom du représentant
J | Charge machine
K | No commande
L | Libellé de la commande
M | Date de livraison prévue
N | Date de commande
O | Commentaires
P | Commentaires court (30 caractères)


Lancement autonome d'éditions VoluEdit

Lancement autonome d'éditions VoluEdit edition_canal_comm

Ce programme est opérationnel à partir de la V. 4.0.186.2

Il est possible d'éditer des documents en déposant un enregistrement dans la table canal_comm pour que ce document soit édité plus tard (en général par cron avec sauvegarde d'un pdf).

Auparavant, il fallait un lanceur par type d'édition (BL, facture…)

Ce nouveau programme permet d'éditer directement tous les enregistrements d'édition présent dans la table canal_comm, quel que-soit leur type.

Valeurs numériques

1 | Temps d'attente en seconde entre 2 boucles de traitement
2 | non utilisée

Options

Oar | Arrêt
Oup | Un seul passage

Notes

FIC_ANOMALIE

21,60 Nom (avec emplacement) du fichier d'anomalie

FIC_TRACE

21,60 Nom (avec emplacement) du fichier trace

FIC_NB_HISTO

21,23 Nombre de fichiers historisés

LCT_EDT_

9,11 Type d'édition

Liste des types d'éditions possibles : BLV, CDF, DEV, FAC, OEX, ACR

12 Caractère souligné (undescore _)

13,15 Site de production Tableau de bord du multisite

Le site de production peut être omis si le paramètre est le même, tous sites confondus, ou si on ne gère pas le multisite.

Voir le chapitre dédié aux éditions par canal_comm dans le #VE.

16 Caractère souligné (undescore _)

17,18 Indice de lancement (01, 02 …) si on veut lancer plusieurs éditions pour le même message

21,23 Type et code du paramètre de lancement de l'édition

ACR Edition des AR de commande et PRX

BLV Edition des BL

CDF Edition des commandes fournisseurs

DEA Edition des demandes d'achat

DEV Edition des devis

FAC Edition des factures

FAS Edition des factures de simulation

OAT Edition des ordres de transport

OEX Edition des ordres de fabrication

TRA Edition des traites

Pour les devis, on fait 1 édition avec le paramètre #VEDEV, tous sites confondus.

Pour les BL, on fait 1 édition avec le paramètre #VEBL1 pour le site 1 et VEBL2 pour le site 2.

Pour les factures, on fait 2 éditions avec les paramètres #VEFA1 et VEFA2, tous sites confondus.

Pour les AR :

on fait 2 éditions avec les paramètres VEAR1 et VEAC1 pour le site 1.

on fait 1 édition avec le paramètre VEACR pour le site 2.

Important : dans les paramètres d'édition #VExxx appelés, aucun caractère ne doit être présent en position A1[50].

_SUP_REQ_CCO

21,60 Supplément de requête sur la table canal_comm


Contrôle des données de VoluPack

Contrôle des données de VoluPack controle_vsw

Permet de contrôler et éventuellement de corriger certaines données dans les tables VoluPack.

Ce programme permet de :

• Vérifier la cohérence des valeurs de compteurs alphanumériques avec les derniers articles créés (la valeur correspondante à la racine du compteur doit être égale à la valeur du compteur du dernier article utilisant cette même racine)

• Corriger les valeurs de compteurs alphanumériques d'articles (mise à jour de la valeur du compteur par la valeur du compteur du dernier article utilisant la même racine)

Exemples

Racine | Compteur actuel | Dernier élément créé pour ce compteur | Type d'anomalie | Option nécessaire | Compteur corrigé
EC32574- | 21 | EC32574-0000015 | 21 > 15 |  | 15
PS32451- | 9 | PS32451-0000007 | 9 > 7 |  | 7
AF14250- | 37 | AF14250-0000039 | 37 < 39 | Ocs | 39

Evolutions du 01/03/2012

Fonctionnalités

Dans l'outil de contrôle des donnés VoluPack, permettre de corriger les compteurs alphanumérique inexistants (type A Article uniquement).

Paramétrage

• Longueur de racine d'article

• Complément de sélection des articles à prendre en compte

• Longueur de folioteur

Fonctionnement

1. On parcourt les articles concernés par le complément

2. On récupère la racine (nn premiers caractères du code article, selon la longueur de la racine)

3. On vérifie dans la table des compteurs alphanumériques (cpt_a) si la racine existe

4. On vérifie que la partie correspondante au folioteur du code article est bien une valeur numérique

a. Position de début du folioteur : Longueur de racine + 1

b. Position de fin du folioteur : Longueur de racine + Longueur de folioteur

5. Si le compteur n'existe pas, on affiche une ligne d'anomalie, sélectionnée par défaut

6. Le lancement de la correction insère un nouveau compteur alphanumérique avec comme valeur le dernier élément trouvé.

Exemples

Soit le paramétrage suivant :

• Longueur de racine : 6

• Complément de sélection : and mp_code[1] = « P » and mp_code[6] = « - »

• Longueur de folioteur : 4

Article | Racine | Dernier élément | Type d'anomalie | Compteur corrigé
P0105-0009 | P0105- | P0105-0009 | Compteur inexistant | 9
P0237-0002 | P0237- | P0237-0002 |  | 2
PHOTO-POLY | PHOTO- | PHOTO-POLY |  | POLY n'est pas une valeur numérique. Cet article n'est pas pris en compte.

Options

Osi | Mode simulation (aucune modification dans les tables VoluPack)
Ocs | Prise en compte des valeurs de compteurs supérieures à la valeur des compteurs des derniers éléments créés

Valeur alpha 2

A2[1,2] | Longueur de la racine sur les codes articles Ce paramétrage active la vérification et la correction des compteurs inexistants. La longueur de folioteur et le complément de sélection correspondant deviennent alors obligatoires.
A3[3,4] | Longueur de folioteur sur les codes articles Ce paramétrage est lié à la vérification et la correction des compteurs inexistants : les codes articles dont la partie correspondant au folioteur n'est pas numérique ne sont pas pris en compte. Récupération de la partie correspondante au folioteur : Position de début du folioteur : Longueur de racine + 1 Position de fin du folioteur : Longueur de racine + Longueur de folioteur

Notes

FICHIER_TRACE_CPTA | 21,60 Chemin d'accès au fichier de trace de la correction des compteurs alphanumériques
_SUP_REQ_CPTA_A | 21,60 Complément de sélection des compteurs alphanumériques d'articles (type A)
_SUP_REQ_CPTA_MAT | 21,60 Complément de sélection des articles à prendre en compte pour la vérification de l'existence des compteurs alphanumériques


Requeteur

Requêteur requeteur

Le requêteur VoluPack est un outil permettant d'effectuer des requêtes SQL.

Il permet de travailler aussi bien sur une base Informix ou Oracle et être exécuté en environnement 350 ou Genero.

Arguments de ligne de commande :

-f : exécution de requêtes SQL contenues dans un fichier.

Paramètre : nom du fichier contenant des requêtes SQL à exécuter

exemple

run requeteur –freq_1

Exécute la requête SQL située dans le fichier req_1.sql

-c : lance l'outil de correction des serials

exemple

run requeteur –c


Déprotection des tables

Déprotection des tables deprot_tab

Options

Oes

Ecran de sélection des enregistrements des locks

On peut maintenant afficher une fenêtre de saisie de critère pour la sélection des enregistrements de la table je_lock.

Une nouvelle fonction a aussi été rajoutée. Elle permet de sélectionner (ou dé-sélectionner) tous les enregistrement d'un seul clic (touche F13).

Valeur alpha 2

Caractère 1

Désactivation de la recherche dans canal_comm (O/N, N par défaut)

Notes

COMPLEMENT_SELECT

21,60 Complément de sélection de la liste des locks

Exemple

and jl_table != "FGLRUN"

Il est fortement conseillé de prévoir un paramètre de lancement du programme de gestion des locks sans ce complément afin de pouvoir, par ce dernier, accéder à la liste de toutes les protections.


Gestion des permissions

Gestion des permissions permis

Voir le paramètre ACP et les codes actions.


Messages d'alerte de traçabilité

Messages d'alerte de traçabilité alerte_tracabilite

Option PAYANTE : BAS 20

Nouveau champ dans la table tracabilite_e : te_alerte

Permet d'envoyer des alertes à différents destinataires sur plusieurs supports (mail, fax, fichier…) en fonction des événements de traçabilité (ATR).

Pour chaque zone, les valeurs AVANT et APRES modification apparaissent dans l'alerte.

Possibilité d'envoi de mail via des logiciels d'envoi d'email par ligne de commande (construction d'un .bat nécessaire).

Exécution ici d'un exécutable du domaine publique nommé blat.exe

Création d'un index recommandé chez les utilisateurs : index duplicate sur te_alerte

Création d'un index obligatoire chez les utilisateurs : index duplicate sur te_alerte, te_soc

(surtout dans le cas où une des sociétés ne gère pas les alertes).

Pour le démarrage de ce module, il est impératif d'exécuter la requête suivante :

update tracabilite_e set te_alerte = "I"

pour ignorer l'intégralité des messages déjà enregistrés.

Options

Oar | Demande d'arrêt du traitement (quand le programme a été lancé précédemment avec l'option Obo) Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR
Obo | Lancement du traitement en boucle Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR
Ofm | Utilisation de l'alerte traçabilité pour la table envoi_fax_email Plus d'info en bas de cette page.

Valeur alpha 2

Caractères 1 à 60

Chemin du répertoire de stockage des fichiers d'alerte

Un fichier est créé à chaque message généré. Charge à l'utilisateur du nettoyage de ces derniers.

Exemple : ./tmp/fichiers_atr

Valeur alpha 3

Caractères 1 à 60

Nom de l'expéditeur pour réception d'e-mails (doit appartenir à la table de VoluFaxMail)

Utile uniquement si utilisation de la solution VoluFaxMail sinon l'expéditeur apparaît comme inconnu à la réception du mail.

Notes

ACTIONS_AUTORISEES

21, 59 Liste des actions autorisées (13 codes actions de 3 caractères par ligne)

Mettre un N en caractère 321 pour spécifier qu'aucune action n'est autorisée.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

FIC_ANOMALIE

21,60 Chemin d'accès au fichier des anomalies

Note obligatoire si l'option Obo est activée, facultative dans les autres cas.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

FIC_ARRET

21,60 Chemin d'accès au fichier de demande d'arrêt

Note obligatoire si l'option Obo est activée, ignorée dans les autres cas.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

FIC_LOCK

21,60 Chemin d'accès au fichier de lock

Note obligatoire si l'option Obo est activée, ignorée dans les autres cas.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

FIC_TRACE

21,60 Chemin d'accès au fichier de trace

Note obligatoire si l'option Obo est activée, facultative dans les autres cas.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

INTERVAL_TEMPS_MIN

21,25 Délai, en minutes, indiquant les messages qui doivent être en alerte - Plus d'info en bas de cette page.

Si la différence entre la date d'autorisation pour un mail non envoyé et la date à l'instant t est supérieure à ce délai, alors on enverra une alerte

Délai par défaut : 60 minutes

_SUP_REQ_TYPE_ATR

21,60 Complément de sélection sur le type ATR - Plus d'info en bas de cette page.

Permet de ne prendre que les types gérant l'alerte traçabilité sur la table envoi_fax_email

TPS_ATTENTE_BOUCLE

21,24 Temps d'attente entre chaque boucle du traitement

Note facultative utilisée lorsque le programme est lancé avec l'option Obo.

Utilisée dans la gestion des actions à effectuer lors d'une alerte traçabilité. Voir ATR

Paramètres associés

ATR | Code événement.
USE | ou tout autre type de paramètre indiqué dans les notes commençant par ENVOI_DEST du paramètre ATR Notes commençant par ATR

Installation

L:\Installation\Utilitaires\blat\.exe

L:\Installation\Utilitaires\blat\blat.bat

Fichier blat.bat

echo off

cls

rem ------------- DEBUT DE LA SECTION A PERSONNALISER

rem SERVEUR_UNIX nom du serveur Unix pour connection FTP

rem DIR_WIN répertoire Windows ou se trouve l'utilitaire d'envoi de Mail

rem LOGIN_UNIX nom du login pour transfert FTP

rem PASSW_UNIX mot de passe pour transfert FTP

rem SERVER_SMTP serveur smtp

rem LOGIN Login smtp

rem %1 répertoire body Unix

rem %2 fichier body Unix

rem %3 destinataire

rem %4 emetteur

rem %5 sujet/objet

rem %6 piece jointe

set SERVER_UNIX=scodev2

set DIR_WIN=L:\Installation\Utilitaires\blat

set LOGIN_UNIX=atlas

set PASSW_UNIX=xxxxxx

set SERVER_SMTP=smtp.wanadoo.fr

set LOGIN=volupack@volusoft.com

rem ------------- FIN DE LA SECTION A PERSONNALISER

rem 1--- Positionnement sous windows

%DIR_WIN%

rem 2--- Generation script transfert ---------------

set FIC_FTP=%2%.ftp

set FIC_UNIX=%1%/

set FIC_UNIX=%FIC_UNIX%%2%

echo user %LOGIN_UNIX% %PASSW_UNIX% >%FIC_FTP%

echo ascii >>%FIC_FTP%

echo get %FIC_UNIX% >>%FIC_FTP%

echo bye >>%FIC_FTP%

rem 3--- Execution script transfert-----------------

ftp -n -s:.\%FIC_FTP% %SERVER_UNIX%

rem 4--- Ppéraparation envoi mail ------------------

set EXECUTABLE=%DIR_WIN%/blat.exe

set MAIL_VSW=%EXECUTABLE% %2 -to %3 -i %4 -server %SERVER_SMTP% -f %LOGIN% -subject %5 -attach %6

rem 5--- Envoi mail -----------

%MAIL_VSW%

rem 6 --- Suppression des fichiers temporaires -----

del %FIC_FTP%

del %2%

Analyse des fax et mails

Nouvelle fonction permettant de recevoir en automatique une information indiquant que des mails valides et autorisés sont toujours en attente d'envoi.

Paramétrage

ATR A1[3]

ATR note SUP_REQ_ATR

USE notes commençant par ATR

doc en cours


Epuration et compactage de la base de données

Epuration et compactage de la base de données epu_dos

ATTENTION

NE LANCEZ CE PROGRAMME QUE SOUS LA SUPERVISION DE VOLUME SOFTWARE !

EFFECTUEZ UNE SAUVEGARDE AU PREALABLE

AUCUN POSTE NE DOIT ETRE CONNECTE

Options triées

Ocl | Méthode de compactage par alter index to cluster
Oda | Epuration des Commandes d'achat à partir de la date de la commande et non plus à partir du Numéro de Commande
Odb | Epuration des BL à partir de la date du BL et non plus à partir du numéro de BL
Odc | Epuration des commandes clients à partir de la date de la commande et non plus à partir du numéro
Odf | Epuration des dossiers de fabrication à partir de la date de création du dossier (f0_delp : date prévue de fabrication) et non plus à partir du numéro de dossier
Oea | Epuration des fichiers de fabrication
Oeb | Epuration des BL
Oec | Epuration des commandes clients
Oef | Epuration des factures
Oem | Epuration des réceptions matières (reliure)
Oeo | Epuration des commandes fournisseurs
Oer | Epuration des relevés
Oes | Epuration des factures de simulation
Oet | Epuration des statistiques

Valeur alpha 2

Paramétrage des contrôles :

O Contrôle (par défaut)

N Pas de contrôle

Caractère 1 | Contrôle à effectuer
Caractère 2 | Accusé de réception non édité (COMMANDE)
Caractère 3 | Ordre exécution non édité (COMMANDE)
Caractère 4 | Reste BL à éditer (COMMANDE)
Caractère 5 | Reste factures à éditer (COMMANDE)
Caractère 6 | Commande non soldée (COMMANDE)
Caractère 7 | Dossier non clôturé (COMMANDE)
Caractère 8 | BL non édité en définitif (BON LIVRAISON)
Caractère 9 | BL non facturé (BON LIVRAISON)
Caractère 10 | Facture non éditée (FACTURE)
Caractère 11 | Relevé non édité (FACTURE)
Caractère 12 | Traite non éditée (FACTURE)
Caractère 13 | Transfert compta non effectué (FACTURE)
Caractère 14 | Transfert effets non effectué (FACTURE)
Caractère 15 | Dossier non clôturé (FACTURE)
Caractère 16 | Relevé non édité (RELEVE)
Caractère 17 | Traite/relevé non édité (RELEVE)
Caractère 18 | Transfert effets non effectué (RELEVE)
Caractère 19 | Dossier non généré (FABRICATION)
Caractère 20 | Dossier non édité (FABRICATION)
Caractère 21 | Dossier non historisé (FABRICATION)
Caractère 22 | Dossier non clôture (FABRICATION)
Caractère 23 | Liste des lignes épurées (STATISTIQUES)
Caractère 24 | Commande non soldée (FACTURE)
Caractère 25 | Commande non soldée (FABRICATION)
Caractère 26 | Commande non soldée (BON LIVRAISON)
Caractère 27 | Dossier non clôturé (BON LIVRAISON)
Caractère 28 | Contrôle de dossier avec conteneur en stock
Caractère 29 | Contrôle de l'existence d'un conteneur en stock sur les commandes de type fabrication (FBI/FB2)


imprimantes

Imprimantes Imprimantes

Voir aide en ligne sur le paramètre #LP

defaut/user/imprimante

defaut/groupe/imprimante

defaut/tty/imprimante

Les 3 imprimantes suivantes ne sont pas utilisées A REVOIR

#LP DOS | Edition complète des dossiers de fabrication
#LP BDT | Edition des bons de travaux
#LP FIS | Edition des fiches suiveuses

L'imprimante #LP DEF est utilisée par la fonction chx_perif lorsque celle ci ne trouve pas la définition de l'imprimante demandée.

Définition de l'imprimante proposée en fonction d'un ordre de sélection

Il est possible de choisir l'ordre de sélection des imprimantes. Cet ordre est défini par le paramètre #CF IMP, valeur alpha 1.

Les imprimantes y sont repérées par des lettres

P | Imprimante du programme
U | Imprimante utilisateur (définie dans ./defaut/user/imprimante)
X | Imprimante passée en paramètre au programme (-X)

L'ordre d'apparition des lettres définit l'ordre de sélection des imprimantes. Le paramétrage par défaut est PUX. Si aucune des 3 imprimantes n'est trouvée, on prend l'imprimante par défaut (#LP DEF).


Statistiques diverses

Statistiques diverses DIV stat

Visualisation de statistiques sur le nombre de devis, de commandes, de BL, etc.


Recalcul statistiques facturation

Recalcul statistiques facturation tools_stat

Options

-Obl | Prend en compte les lignes £££ (FAM) et BON (SFM)
-Oet | Cree un enregistrement cumul mensuel et annuel
-Ofe | Statistiques facturation escompte non déduite
-Ofr | Statistiques facturation remise non déduite
-Oht | Calcul des commissions sur le total HT facture
-Ol0 | Met à jour dans le fichier commissions les montants à zéro
-Oni | Multiplication de la quantité facturée par la donnée technique 8 (pour convertir les tonnes) et prix dans la donnée technique 1 du fichier matière
-Onv | Statistiques sur articles non vendus
-Osc | Mise à jour le fichier des commissions (stat1)
-Ose | Calcul des commissions sur le détail ht avant escompte
-Osr | Calcul des commissions sur le détail ht avant remise


Enchaîneur automatique d'éditions

Enchaîneur automatique d'éditions lance_edition

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro de document (devis, réclamation, etc.) Exemples : -N[l2_devis] -N[ec_num]
-n | Caractères 3 et suivants : numéro de document - numéro de ligne de document (devis, réclamation, etc.) Exemples : -n[l2_devis|-|l2_sdevis+<<&] -n[lc_num|-|lc_lig+<<&]

Options

-N

Pour les éditions de type FAB

Syntaxe : -N<numéro document>* (ne pas oublier l'astérisque final)

Valeur alpha 2

Caractères 1 & 2

Délai d'attente (en secondes) entre 2 impressions

Notes

DESACTIVE_AUTONEXT

La présence de cette ligne permet de désactiver la validation automatique de la saisie de la clé du document lors que les 8 caractères qui la composent sont saisis (cela oblige alors à faire F10 pour valider la saisie).

MONO_DOCUMENT

21 N désactive l'obligation de saisir le numéro de ligne du document

TTTNNN

TTT = Type d'édition

BLV Bons de livraison (sert aussi pour lancer l'édition des AR de commande client)

CDF Commande d'achat

DEV Devis

FAB Fiche de fabrication

NCE Réclamations

NNN = Numéro d'édition (facultatif)

21,26 Type et code du paramètre de lancement de l'édition

Exemples

TTTNNN78901234567890123456

DEV #VEOF1

DEV #VEOF2

DEV #VEOF3

Ce paramétrage permet d'enchaîner 3 éditions différentes ayant un devis commun saisi lors du lancement du programme.

Les éditions se font successivement dans l'ordre des lignes de notes (ici : édition OF1 puis OF2 puis OF3)


Epuration Volupack

Suppression de n labo_resultat

Suppression de n labo_papier

Suppression de n labo_entete

Suppression de n notes de labo

Suppression de n fab_midata1

Suppression de n fab_midata2

Suppression de n fab_midata3

Suppression de n fab_midata4

Suppression de n cor_mariage

Suppression de n fab_ond_of_mar

Suppression de n fab_ond_of

Suppression de n fab_ond_arret

Suppression de n fab_ond_rebut

Suppression de n fab_ond_mar

Suppression de n fab_tra_of

Suppression de n fab_tra_of_fac

Suppression de n fab_tra_arret

Suppression de n pal_expedition_1

Suppression de n pal_expedition_2

Suppression de n pal_expedition_3

Suppression de n fab_1_etat

Suppression de n fab6

Suppression de n fab5

Suppression de n fab4

Suppression de n fab3

Suppression de n fab2

Suppression de n fab1

Suppression de n fab0

Suppression de n edi_cde

Suppression de n frais_exp

Suppression de n info_c

Suppression de n cde8

Suppression de n cde7

Suppression de n cde6

Suppression de n cde5

Suppression de n cde4

Suppression de n cde3

Suppression de n notes de commande

Suppression de n cde2

Suppression de n cde1

Suppression de n fac6

Suppression de n groupage_bl_prepa

Suppression de n groupage_bl_pal_l

Suppression de n groupage_bl_pal_e

Suppression de n preparation affr^tement d'tail

Suppression de n preparation affr^tement

Suppression de n groupage BL

Suppression de n notes de lignes de BL

Suppression de n notes de BL

Suppression de n lignes de BL

Suppression de n BL

Suppression de n lignes de SBI

Suppression de n SBI

Suppression de n lignes de facture

Suppression de n notes de facture

Suppression de n fac7

Suppression de n fac2

Suppression de n factures

Suppression de n pfac0

Suppression de n pfac1

Suppression de n pfac2

Suppression de n pfac6

Suppression de n pfac7

Suppression de n notes de tiers

Suppression de n cli6

Suppression de n cli5

Suppression de n cli4

Suppression de n cli3

Suppression de n cli2

Suppression de n cli

Epuration Volupack epuration_volupack

Cette fonction d'épuration est soumise à la gestion des permissions (action MEN, argument EPU_VP)

Epuration de VoluPack selon un choix de menu :

  • Factures

  • Commandes

  • Clients

  • Articles (reste à réaliser)

Existe en mode simulation.

Fonctionne en mode batch.

Il existe un outil qui permet pour toutes les CD1, de mettre à jour la commande de rattachement de la ligne par celle de la CDA.

Prérequis :

Effectuer une sauvegarde de la base avant de lancer ce traitement

En cas de plantage, lancer l'instruction suivante :

update blv2 set b2_ligne_a_epurer = "N"

where b2_soc = societe

and b2_ligne_a_epurer = "X" or b2_ligne_a_epurer = "I";

update cde2 set lc_ligne_a_epurer = "N"

where lc_soc = societe

and lc_ligne_a_epurer = "X" or lc_ligne_a_epurer = "I";

Options

-Osi

Mode simulation

Valeur alpha 2

Caractère 1

Valeur du traitement d'épuration à effectuer en mode batch

1 Facture - Voir un extrait du fichier trace

2 Commande

3 Article

4 Client - Voir un extrait du fichier trace

Notes

FIC_EVENEMENT_FAC | 21,60 Nom du fichier au seront inscrits les événements liés à la demande de suppression de facture
FIC_EVENEMENT_CDE | 21,60 Nom du fichier au seront inscrits les événements liés à la demande de suppression de commande
FIC_EVENEMENT_MAT | 21,60 Nom du fichier au seront inscrits les événements liés à la demande de suppression de produit
FIC_EVENEMENT_CLI | 21,60 Nom du fichier au seront inscrits les événements liés à la demande de suppression de client
_SUP_REQ_FAC0 | 21,60 Complément de requête sur FAC0 lors de la demande de suppression de facture
_ORD_REQ_FAC0 | 21,60 Ordre de tri sur FAC0 lors de la demande de suppression de facture
_SUP_REQ_CDE | 21,60 Complément de requête sur CDE1 lors de la demande de suppression de commande
_ORD_REQ_CDE | 21,60 Ordre de tri sur CDE1 lors de la demande de suppression de commande
_SUP_REQ_MAT | 21,60 Complément de requête sur MAT lors de la demande de suppression de produit
_ORD_REQ_MAT | 21,60 Ordre de tri sur MAT lors de la demande de suppression de produit
_SUP_REQ_CLI | 21,60 Complément de requête sur CLI lors de la demande de suppression de client
_ORD_REQ_CLI | 21,60 Ordre de tri sur CLI lors de la demande de suppression de client


Solder une fabrication et épurer les mvts de stock prévisionnels

Solder une fabrication et épurer les mouvements de stock prévisionnels outil_73_solde_fab

Cet outil permet de solder des fabrications non soldées, antérieures à une date paramétrée, quand la quantité fabriquée dépasse un certain pourcentage de la quantité lancée.

Le mode vérification permet d'effectuer la sélection sans mise à jour.

Les informations sont stockées dans le fichier outil_73_solde_fab.out.

Une trace est générée dans le fichier outil_73_solde_fab.out, même si l'on est en mode vérification.

Auparavant, l'ancienne trace est sauvegardée sous le nom de outil_73_solde_fab.bak.

Options

-Ove

Mode vérification de la sélection - aucun traitement n'est effectué.

Valeur alpha 2

Caractères 1 à 3 | Type de mouvement entrée pour les entrées outillage
Caractères 4 à 6 | Type de mouvement sortie pour les sorties outillage
Caractères 7 à 16 | Date de sélection
Caractères 17 à 22 | Pourcentage de fabrication réalisée par rapport au lancé Mettre une valeur entière. Le programme divise cette valeur par 100.
Caractères 23 à 26 | Délai à retrancher de la date du jour Si la date de sélection(alpha2[7,16]) n'est pas saisie, alors on prendra en compte tous les événements de commande dont la date de création est antérieure à la date du jour moins ce délai. Ce délai est ignoré si la date de contrôle est renseignée.
Caractères 27 à 29 | Code action automatique à créer au solde de la fabrication (Type de paramètre ASO) Permet de créer une action automatique de suivi d'outillage au solde de la fabrication (outil 73).

Valeur alpha 3

Caractères 1 à x

Répertoire dans lequel seront créés les fichiers outil_73_solde_fab.out et outil_73_solde_fab.bak

Notes

_SUP_REQ_CDE1 | 21, 60 Complément de requête sur cde1
_SUP_REQ_CDE2 | 21, 60 Complément de requête sur cde2


Mise en oeuvre des menus

Mise en œuvre des menus

Gestion du code page des fichiers de menu

Il est maintenant possible de créer un répertoire société-groupe dans le répertoire menu.

Donc, aujourd'hui, quand on recherche un fichier menu pour un utilisateur, on recherche dans les répertoires suivants, par ordre de priorité :

menu/<user>

menu/<societe>-<groupe>

menu/<groupe>

menu/<societe>

menu/<societe>_atlas

menu/atlas

Ce fonctionnement est disponible à partir de la version 4.0.168.1.

Mise en oeuvre des contrôles d'accès

Il est possible de contrôler les droits d'accès aux MODUVOLUMES

Ces contrôles d'accès sont définissables pour chaque MODUVOLUME, pour :

  • un utilisateur donné : (user)

  • un groupe d'utilisateurs : (groupe)

  • tous les utilisateurs : (GLOBAL)

Les contrôles sont de nature suivante :

  • Autorisation d'accès : (ACCES_OUI)

  • Autorisation d'accès sur mot de passe : (ACCES_PWD)

  • Interdiction d'accès : (ACCES_NON)

La mise en œuvre de ces contrôles d'accès est réalisée dans les notes du paramètre de lancement d'un MODUVOLUME.

On utilisera des notes commençant par ACCES_. Ces notes commençant par ACCES_ doivent impérativement figurer en tête des notes du paramètre de lancement.

Le contrôle d'accès parcourt ces notes du haut vers le bas.

Il s'arrête dès qu'il rencontre une ligne commençant pas ACCES_ dont les caractères 20 à 27 définissent soit :

Son login

Son groupe au sens VSW (Cf defaut/user/groupe)

Le mot clé GLOBAL (en majuscule)

Pour une cohérence vis-à-vis de la norme, les caractères seront de 21 à 28 (la codification actuelle continuera de fonctionner).

On définira donc les paramétrages utilisateur en premier, puis les paramétrages groupe, puis le paramétrage global à tous les utilisateurs.

Si aucun paramétrage de contrôle d'accès n'est réalisé, l'accès au module est autorisé.

Notes

ACCES_OUI | Paramétrage d'une autorisation d'accès 20,27 login ou groupe ou GLOBAL
ACCES_PWD | Paramétrage d'une autorisation d'accès sur mot de passe 11,13 code paramètre sur le type paramètre PWD 20,27 login ou groupe ou GLOBAL
ACCES_NON | Paramétrage d'une interdiction d'accès 20,27 login ou groupe ou GLOBAL
ACCES_MSG_xxx | Lorsque l’accès à un programme n’est pas autorisé, on a le message suivant : "Vous n'êtes pas habilité à exécuter ce programme." (ce contrôle est fait avec les notes ACCES_xxx) Dans ce cas, on peut ajouter un message paramétré supplémentaire : "Vous n'êtes pas habilité à exécuter ce programme." "A faire en phase 2" 21,60 Message à faire apparaître xxx est le code langue de l’utilisateur. dans le cas du Français, on peut le laisser à blanc. ATTENTION : cette note doit être saisie avant celles des accès. Exemple ACCES_MSG A faire en phase 2 ACCES_MSG_en To do in step 2 ACCES_NON

Pour définir un mot de passe, on créera un paramètre de type PWD. En valeur A1[1,5] on définira le mot de passe.

Exemple

Utilisateurs

Dans cet exemple nous avons 6 utilisateurs appartenant aux groupes suivants

Login | Groupe
Robert | facture
Alain | facture
Pascal | facture
Denis | gescom
Sonia | gescom
Céline | gescom

Paramétrage

ACCES_OUI | Robert
ACCES_NON | facture
ACCES_NON | Denis
ACCES_PWD 001 | gescom
ACCES_NON | GLOBAL

Signification

L'utilisateur Robert a accès au module.

Le groupe facture n'a pas accès au module, sauf Robert pour lequel on a réalisé une spécification préalable. Alain et Pascal ne pourront donc pas accéder au module.

L'utilisateur Denis n'a pas accès au module.

Le groupe gescom a accès au module sur mot de passe. Ceci concerne donc Sonia et Céline.

Les autres utilisateurs n'accèdent pas au module.

Gestion du code page des fichiers de menu

Gestion du jeu des caractères des fichiers des menus afin d'obtenir un affichage correct dans le menu VoluPack/VoluPrim, qui travaille en code page CP858, quelque soit le système qui les héberge.

Cela nécessite une conversion des fichiers des menus afin de tous les avoir dans le même jeu, celui du système.

Cette option ne modifie en rien les fichiers des menus, la conversion se fait au sein du programme et dans les fichiers 4sm construits par le menu lors de l'enregistrement de ce dernier.

Exemple : Windows est en code page CP1252 et Linux est en code page ISO-8859-15, en Europe.

Variable d'environnement VSW_MENU_CODEPAGE

Les valeurs autorisées sont :

CP858 pour un système AIX

CP1252 pour Windows

ISO-8859-15 pour un SCO ou un Linux

La valeur par défaut est CP858, cette valeur n'entraîne aucune conversion puisque c'est celle du jeu de caractères des programmes.

Une mauvaise valeur provoquera l'affichage d'un message d'avertissement mais ne sera pas bloquante.

Suite à la mise en place de cette variable, il est nécessaire de rafraîchir le menu ou d'effacer les fichiers 4sm.

Pour les serveurs Windows, cette variable est aà ajouter aux scripts qui lancent le menu pour les utilisateurs.

Pour les serveurs Unix, cette variable est à ajouter au $CLIENT.shl.


Gestion des compteurs numériques

Gestion des compteurs numériques cptgest

Améliorations apportées dans la V.4.1.23

Auparavant, lorsqu'un compteur dépassait sa valeur maximale, on obtenait un identifiant à étoiles. Par exemple 13AC****.

Un nouveau type de compteur a donc été créé pour avoir une incrémentation alphanumérique sur le 1er caractère variable.

Par exemple, là où l'on s'arrêtait à 13AC9999, on peut désormais passer à 13ACA000.

Le compteur peut s'incrémenter ensuite jusqu'à 13ACA999 puis 13ACB000, et ainsi de suite jusqu'à 13ACZ999.

Décomposition du champ Année-mois (cp_aamm)

- Caractères 1 à 2 : saisir 13 pour le mode annuel.

- Caractère 3 : saisir r pour indiquer que l'on souhaite avoir une racine fixe avant le compteur alphanumérique.

- Caractère 4 : indique la longueur de la racine fixe. Celle-ci doit être comprise entre 1 et 4.

A noter que l'on ne peut avoir qu'un seul compteur annuel avec racine fixe par Société / Type / Numéro / Année.

Par exemple, si vous créez un compteur avec Année-Mois = 13r2, vous ne pouvez pas créer un autre compteur avec Année-Mois = 13r4.

Dans la table cpt, la zone cp_typ (Type de compteur) peut prendre les valeurs suivantes :

Types de compteurs

A | Numéro de commande fournisseur
B | Numéro de BL
C | Numéro de commande client
D | Numéro de devis
E | Numéro d'étude
F | Numéro de facture client
G | Numéro de facture fournisseur
H | Numéro de bon de réception
I | Numéro de fiche de fabrication (Reliure)
J | Numéro de bon de remontée des quantités fabriquées
K | Numéro de bon de réception usine
L | Numéro de bon de commande
M | Numéro de maintenance
N | Numéro automatique client (aamm=9999 cpt=9999NNNN)
O | Numéro d'ordre sur la commande
P | Numéro pour codification automatique des clients par département
Q | Numéro de compteur gestion du SFAC
R | Numéro de relevé de facture
S | Numéro de facture de simulation
T | Numéro de bordereau de transfert de stock
U | Numérotation d'autorisation de suspension de TVA
V | Numéro d'identifiant étiquettes de production
W | Numéro de bordereau de transfert
X | Numéro automatique de produit
Y | Numéro de bon de retour client
Z | Numéro de compteur pour transfert vers SYLOGI
0 | Numéro de groupage BL et bon de préparation
1 | Numéro de réclamation client
2 | Numéro de non-conformité interne (NCI)
3 | Numéro d'offre de prix
4 | Numéro d'affaire
5 | Numéro de demande d'achat
6 | Numéro de facture de cession
7 | [inutilisé]
8 | Numéro de réclamation fournisseur
a | Numéro de fichier fax/mail
d | Numéro de flux (action et événement)
e | Enveloppes de paramètres
i | Numéro de message INVRPT
s | Numéro de SBI de simulation
w | Numéro de message WIPRPT


Gestion des compteurs alphanumériques

Gestion des compteurs alphanumériques cptagest

Types de compteurs

A | Code article
B | Numéro de bordereau d'inventaire
C | Code client
D | Code comptable client
E | Code comptable fournisseur
F | Réservé
G | Numéro de facture
H | Numéro de lot de la ligne de commande
I | Numéro de bordereau inventaire CAB
J | Numéro de palette d'expédition
K | Référence commande (EDI)
L | Réservé
M | [inutilisé]
N | [inutilisé]
O | [inutilisé]
P | Réservé prévisions
Q | [inutilisé]
R | [inutilisé]
S | Numéro de facture de simulation
T | Clé tarifaire opération
U | Numéro de tarif transporteur
V | Réservé VoluPlan
W | Interface achats JDE
X | Code SSCC


Gestion des envois de fax/email en automatique

Gestion des envois de fax/email en automatique gestion_fax_email

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_

Caractères 3 et suivants : [type du document]-[clé du document]

Caractères 3 à 5 : type du document

Caractères 7 à 27 : clé du document

Valeur alpha 2

A2[1] | E Initialisation dans les critères de sélection du nom de l'expéditeur par celui de l'utilisateur (USE) Voir ci-dessous la gestion d'envoi de mails via des scripts.
A2[2] | Contrôle de la présence d'une pièce jointe dans la table lors de la mise à jour de l'autorisation d'envoi ou de la modification du statut (valeur à renvoyer) (O/N, N par défaut) Voir ci-dessous la gestion d'envoi de mails via des scripts.
A2[3] | Initialisation de la zone envoi autorisé dans l'écran de sélection des fax/emails O Envoi autorisé N Envoi non autorisé [vide] pas de sélection (on prend tout)
A2[4] | Initialisation de la zone Statut de l'envoi dans l'écran de sélection des fax/emails 0 Non envoyé 1 Envoyé 2 A réenvoyer

Notes

_SUP_REQ_EFE | 21,60 Complément de requête sur la table envoi_fax_email
_SUP_ORDER_BY_EFE | 21,60 Complément de tri sur la table envoi_fax_email

Envoi de mails via des scripts

Cette fonctionnalité est accessible à partir de la V. 4.1.13.2

1) Nouvelles zones dans la table envoi_fax_email

efe_piece_jointe Nom de la pièce jointe

efe_corps_mail Corps du mail

2) Programme gestion_fax_email (ici) : A2[1] et A2[2]

3) Programme envoi_fax_email : option Oes et note EDI_typ_mod_sit

4) Programme exped_affretements : A2[45] et note GESTION_NOM_DOC_MAIL

5) Programmes d'édition des AR, des BL, des factures et des ordres d'achat de transport : note GESTION_NOM_DOC_MAIL

6) #CF EFM

7) WIN A1[7-8] et note ARGUMENTS_SCRIPT

8) RG1 A1[14,19], A1[20,22] et A1[38]


Correspondance logiciel

Correspondance logiciel correspondance

Ce programme permet de saisir des correspondances de codes entre VoluPack et des logiciels externes.

Il est utilisé pour réaliser des correspondances de codes avec les logiciels suivants :

· Direct Planning

· Artios CAD

Ce programme permet de saisir les correspondances entre :

• Un code qualité carton VoluPack et un code qualité carton Artios CAD

• Un code FEFCO / ECMA VoluPack et un code standard Artios CAD

• Un code machine VoluPack et un code machine Direct Planning

Valeur alpha 2

1,3

Type de correspondance entre logiciels (Type de paramètre TCL)

4,6

Code site par défaut (Type de paramètre SIT, pour un type de correspondance saisissable par site uniquement)

Remarque : Si le type de correspondance doit être saisi par site et que celui-ci n'est pas précisé par défaut, il devra être renseigné avant l'accès à la saisie des correspondances.

Tableau de bord du multisite

Voir aussi le paramètre de type TCL.


Test VMC

Test VMC vmc_test

Permet de tester l'interface entre VoluPack et Volume Media Center.

Pour le moment, ce programme permet de ne tester que l'interface Artios CAD (visualisation d'un standard côté, non côté, d'une étude…)

Valeur alpha 2

A2[1,15] | Code standard FEFCO / ECMA Volume par défaut (ce code doit avoir une correspondance Artios – voir le paramétrage des correspondances)
A2[16,18] | Code site de production par défaut pour l'interface ArtiosCAD Tableau de bord du multisite Pas de valeur par défaut, ce code est récupéré en priorité sur le paramétrage de l'utilisateur courant Voir aussi USE A3[10,12] et #CF VMC A1[3] Permet de passer à l'interface ArtiosCAD (via Volume Media Center) un code site de production. L'ordre de priorité de la récupération du code site de production est le suivant : • Utilisateur courant • Paramètre de lancement Nécessite la version 1.2.1 de VMC, avec gestion de la compatibilité 1.1.6. Le même paramétrage existe pour le programme de saisie / édition des codes FEFCO et ECMA (A2[6,8])

Valeur alpha 3

1,15

Nom de fichier étude par défaut


Intégration des fichiers AQUIVUS

Intégration des fichiers AQUIVUS G_integration_aquivus

Valeur alpha 2

1,60

Emplacement du répertoire des fichiers à traiter

Exemple

/u/client/aquivus

Notes

_SUP_SQL_CCOUT0 | 21,60 Complément de sélection de recherche du centre de coût associé au coefficient d'opérateur (table ccout0)
_SUP_SQL_CCOUT1 | 21,60 Complément de sélection de recherche du centre de coût associé au coefficient d'opérateur (table ccout1)
VALEUR_DEFAUT_OF | 21,52 Numéro d'OF par défaut (si celui-ci n'est pas renseigné dans le fichier)
VALEUR_DEFAUT_PHASE | 21,25 Numéro de phase par défaut (si celle-ci n'est pas renseignée dans le fichier)

Paramètres nécessaires

TTR A3[16,19]

Code TTR AQUIVUS


Alimentation des tables listes et cubes de ReflexClient

Alimentation des tables cubes et listes de ReflexClient reflexclient_cube

Ce programme est complètement conçu comme un programme batch devant être lancé périodiquement par cron.

A ce titre, il a une sortie écran uniquement sur la console.

Clés d'activation nécessaires

CRM-01 pour l'interface ReflexClient Cubes et Listes

CRM-02 pour les devis

CRM-03 pour les commandes

CRM-04 pour les factures

CRM-05 pour les commandes d'achat (commandes fournisseurs)

CRM-06 pour l'historique des prix de revient

CRM-07 pour la facture détaillée (sta_com facture)

CRM-08 pour le cube de production

Ce programme génère un rapport détaillé dans le répertoire reflexclient.log créé automatiquement.

Ce répertoire contient un fichier de log horodaté pour chaque lancement.

Options triées

-B

Mode Batch

-Nxxx

Limitation du traitement à un complément de sélection sur le numéro de devis, de commande client, de facture ou de commande d'achat.

Cette option est uniquement employée dans le cadre d'un retraitement de maintenance (#SA RFM).

Exemples

-Orcic -N09*: Recalcule le cube commande pour toutes les commandes commençant par 09.

-Orfif -N0812* Recalcule le cube facture pour toutes les factures commençant par 0812.

Oia

Intégration des commandes d'achat

Oic

Intégration des commandes clients

Oid

Intégration des devis

Oif

Intégration des factures

Oi1

Intégration des factures détaillées- 4.0.152.1

Oip

Intégration de l'historique des prix de revient

Cette option nécessite l'option d'intégration des commandes clients Oic).

Le cube Prix de revient utilise la table du cube Commandes clients.

Les mesures Prix de revient sont en effet toutes associées à une commande.

Oit

Intégration des temps de production

Ora

Remise à zéro de la table cube commande d'achat (table crmk_commande_ach)

Orc

Remise à zéro de la table cube commande (table crmk_commande)

Ord

Remise à zéro de la table cube devis (table crmk_devis)

Orf

Remise à zéro de la table cube facture (table crmk_facture)

Or1

Remise à zéro de le table cube facture détaillée (table crmk_sta_com_fac)- 4.0.152.1

Ort

Remise à zéro de la table cube production (table crmk_production)

Orx

Remise à zéro complète de toutes les tables cubes et libellés associés (avec suppression de l'antériorité) (tables crmk_*)

Ce fonctionnement est utile dans le cas des nouveaux clients qui souhaitent faire une reprise de leurs anciennes données.

Ces anciennes données devront impérativement avoir la zone date_maj_record à la date du 01/01/1900.

Lors d'un recalcul complet des cubes, l'option Orz ne supprime pas les données dont la zone date_maj_record = 01/01/1900.

Lors d'un recalcul complet des cubes, l'option Orx supprime aussi les données dont la zone date_maj_record = 01/01/1900.

Orz

Remise à zéro complète de toutes les tables cubes et libellés associés (sans suppression de l'antériorité) (tables crmk_*)

Valeur alpha 2

Flags relatifs au contenu des tables

Pour un fonctionnement standard, toute la zone alpha 2 peut être laissée à blanc.

A2[1,2]

ID Environnement nécessaire à ReflexClient (par défaut : 01)

A2[3]

Doit-on intégrer les commandes commerciales ? (O/N, O par défaut)

Les commandes commerciales sont celles donnant lieu à facturation.

Type de commande de rattachement : CD1, CD2, CD3, FAD, AVO, FB2, FB3, FB1 pour les lignes 2 et plus.

A2[4]

Doit-on intégrer les commandes de production ? (O/N, O par défaut)

Les commandes de production sont celles donnant lieu à un lancement en production.

Type de commande de rattachement : FBI, FB2, FB3, FB1 uniquement pour la ligne 1.

A2[5]

Doit-on intégrer les autres commandes ? (O/N, O par défaut)

Il s'agit des commandes qui ne sont ni commerciales, ni de production.

Type de commande de rattachement : PRX, CDA, CDI, CDP, CTR, FBA, FBM, FBP, SIM et tous les types non cités.)

A2[6]

Les commissions des commerciaux sont-elles calculées sous Volume et stockées dans stat1 ? (O/N, N par défaut)

En précisant que les commissions ne sont pas calculées sous Volume, on évite la recherche et optimise ainsi les temps de traitement.

A2[7]

Forcer la recherche des familles et sous-familles dans la fiche article plutôt que dans la ligne de commande client ? (O/N, O par défaut)

Par ce paramètre, on peut rechercher famille et sous-famille dans la fiche article plutôt que dans la ligne de commande client.

Ce forçage est à O par défaut, car à l'usage il est souvent plus pertinent de prendre cette information dans la fiche article.

Impact sur les cubes Commande et Facture.

Voir la note A2C7_EXCEPTION_TYC

A2[8]

Forcer la recherche des codes statistiques CS1 à CS4 dans la fiche article plutôt que dans la ligne de commande client ? (O/N, O par défaut)

Par ce paramètre, on peut rechercher les codes statistiques dans la fiche article plutôt que dans la ligne de commande.

Ce forçage est à O par défaut, car à l'usage il est souvent plus pertinent de prendre cette information dans la fiche article.

Impact sur les cubes Commande, Facture et Facture détaillée.

Voir la note A2C8_EXCEPTION_TYC

A2[9]

Forcer la recherche des familles et sous-familles dans la fiche article plutôt que dans la ligne d'achat ? (O/N, O par défaut)

Par ce paramètre, on peut recherche famille et sous-famille dans la fiche article plutôt que dans la ligne de commande d'achat.

Ce forçage est à O par défaut, car à l'usage il est souvent plus pertinent de prendre cette information dans la fiche article.

Impact sur le cube Achat.

Voir la note par A2C9_EXCEPTION_TYF

A2[10]

Type d'environnement Volume concernant les opérations et gammes (D/M, D par défaut)

D Environnement Arts graphiques. Les opérations sont décrites par le triplet SEC-OPE-SOP et utilisent des dépendances.

M Environnement Mécanique. Les opérations ne disposent pas de dépendance.

Dans ce mode, la configuration des dépendances (notes PRO_DEP* sur #CF RFX) n'est pas active.

Valeur alpha 3

Flags relatifs aux traitements complémentaires ou d'optimisation

A3[1]

Faut-il procéder à une vérification systématique des libellés des tables annexes ? (O/N, O par défaut)

ReflexClient cube stocke dans les tables annexes les libellés des axes (exemple crmk_famille, crmk_produit, crmk_categorie,etc).

Or, ces libellés peuvent avoir été modifiés sous VoluPack. Ce traitement permet d'actualiser ces libellés.

A3[2]

Faut-il procéder au recalcul des cubes concernant un client ayant été modifiés ? (O/N, O par défaut)

Si #CF RFX – A1[1] = O, on assure une traçabilité des clients pour lesquels un axe utilisé dans le cube a été modifié.

Exemple : changement de secteur géographique ou de code NAF.

Ce recalcul permet de propager cette valeur modifiée dans tous les cubes concernant ce client.

A3[3]

Faut-il procéder au recalcul des cubes concernant un article ayant été modifié ? (O/N, O par défaut)

Si #CF RFX – A1[1] = O, on assure une traçabilité des article pour lesquels un axe utilisé dans le cube a été modifié.

Exemple : changement de famille, de code statistique, etc.

Ce recalcul permet de propager cette valeur modifiée dans tous les cubes concernant cet article.

Notes

N'oubliez pas que les filtrages peuvent aussi être réalisés par des compléments de sélection d'import définis dans ReflexClient.

On peut ainsi traiter plus de choses dans Volume et ensuite n'en importer qu'une sélection dans le cube.

Par exemple, on peut choisir de ne calculer que les années utiles ici via les compléments de sélection indiqués ci-dessus,

ou alors tout calculer ici et n'importer dans le cube que les données à partir d'une année spécifiée.

A2C7_EXCEPTION_TYC | 21,23 TYC de commande client dont la recherche des familles/sous-familles doit être faite dans la ligne de commande client plutôt que dans la fiche article malgré le forçage de la recherche dans la fiche article (A2[7] = O)
A2C8_EXCEPTION_TYC | 21,23 TYC de commande client dont la recherche des codes statistiques doit être faite dans la ligne de commande client plutôt que dans la fiche article malgré le forçage de la recherche dans la fiche article (A2[8] = O)
A2C9_EXCEPTION_TYF | 21,23 TYF de commande d'achat dont la recherche des familles/sous-familles doit être faite dans la ligne de commande d'achat plutôt que dans la fiche article malgré le forçage de la recherche dans la fiche article (A2[9] = O)
_SUP_REQ_CDE1 | 21,60 Complément de sélection sur cde1 pour le cube commande Exemple : Uniquement les commande depuis une date donnée _SUP_REQ_CDE1 and ec_datc >= "01/01/2005"
_SUP_REQ_CDE2 | 21,60 Complément de sélection sur cde2 pour le cube commande
_SUP_REQ_CDE2_FAC | 21,60 Complément de sélection sur cde2pour le cube facture
_SUP_REQ_CDF1 | 21,60 Complément de sélection sur cdf1 pour le cube achat Exemple : Uniquement les commandes d'achat depuis une date donnée _SUP_REQ_CDF1 and ef_datc >= "01/01/2005"
_SUP_REQ_CDF2 | 21,60 Complément de sélection sur cdf2 pour le cube achat
_SUP_REQ_FAC0 | 21,60 Complément de sélection sur fac0 pour le cube facture Exemple : Uniquement les factures depuis une date donnée. _SUP_REQ_FAC0 and fe_date >= "01/01/2005"
_SUP_REQ_FLE2 | 21,60 Complément de sélection sur fle_2 pour le cube devis Exemple : Uniquement les devis depuis une date donnée. _SUP_REQ_FLE2 and l2_date_dev >= "01/01/2005"
_SUP_REQ_SCF | 21,60 Complément de sélection sur sta_com pour le cube facture détaillée- 4.0.152.1 Exemple _SUP_REQ_SCF and sta_date_fac >= "01/01/2005"

Paramètres nécessaire

#CF CDE A1[1,3] | Type de paramètre associé à la zone paramétrable de l'entête de commande
#CF RFX | Gestion des cubes

Paramètres de lancement à créer

#SA RFJ : ReflexClient Journalier

Alpha1 = G_reflexclient_cube.4ge -Oicifia

Alpha2 = 01OOO

Notes

_SUP_REQ_FLE2 and l2_date_dev >= "01/01/2009"

_SUP_REQ_FAC0 and fe_date >= "01/01/2009"

_SUP_REQ_CDE1 and ec_datc >= "01/01/2009"

_SUP_REQ_CDF1 and ef_datc >= "01/01/2009"

Le complément de select sur fle_2 est juste mis pour mémoire si jamais on souhaite ajouter l'option Oid pour intégrer les devis.

#SA RFC : ReflexClient Recalcul

Programme à lancer quand des informations ont changé dans la fiche client ou article ou lorsqu'on a procédé à des modifications via SQL dans les lignes de commandes par exemple.

Ce paramètre est toujours créé par recopie du paramètre #SA RFJ auquel on ajoute l'option Orz (remise à zéro).

Exemple de paramétrage d'un lancement journalier incrémental #SA RFC

Valeur alpha 1 : G_reflexclient_cube.4ge -Oidicifiaip

Valeur alpha 2 : 01OOO

Exemple de paramétrage d'une intégration complète du cube #SA RFR

Valeur alpha 1 : G_reflexclient_cube.4ge -Orzidicifiaip

Valeur alpha 2 : 01OOO

Par rapport à l'exemple précédent, on a ajouté l'option Orz qui provoque une remise à zéro complète du cube avant d'intégrer les devis, les commandes et les factures.

ATTENTION : Une remise à zéro peut prendre plusieurs dizaines de minutes, voire plusieurs heures suivant la volumétrie de votre base.

Principes techniques de fonctionnement

Génération du cube Devis

Le programme parcourt les enregistrements de fle_2 pour lesquels l2_maj_reflex est à null ou 0 en se limitant au complément de select SUP_REQ_FLE2.

Il génère des enregistrements dans crmk_devis.

L'option-Ord remet à zéro le contenu de la table crmk_devis et remet à 0 les tous les flags de fle_2.

Génération du cube Commandes clients

Le programme parcourt les enregistrements de cde2 pour lesquels lc_maj_reflex est à null ou 0 en se limitant au complément de select SUP_REQ_CDE1 et SUP_REQ_CDE2.

Il génère des enregistrements dans crmk_commande.

L'option Orc remet à zéro le contenu de la table crmk_commande et remet à 0 les tous les flags de cde2.

Génération du cube Factures

Le programme parcourt les enregistrements de fac0 pour lesquels fe_maj_reflex est à null ou 0 en se limitant au complément de select SUP_REQ_FAC0.

Il génère des enregistrements dans crmk_facture.

L'option Orf remet à zéro le contenu de la table crmk_facture et remet à 0 les tous les flags de fac0.

Génération du cube Achat

Le programme parcourt les enregistrements de cdf2 pour lesquels lf_maj_reflex est à null ou 0 en se limitant au complément de select _SUP_REQ_CDF1 et _SUP_REQ_CDF2.

Il génère des enregistrements dans crmk_commande_ach.

L'option Ora remet à zéro le contenu de la table crmk_commande_ach et remet à 0 les tous les flags de cdf2.

Génération des tables filles

Il existe plusieurs tables filles identifiables par le radical crmk_.

Exemples : crmk_societe, crmk_produit, crmk_famille, crmk_sous_famille, etc...

Lors des générations, ces tables sont remplies uniquement avec les enregistrements rencontrés dans les tables crmk_devis, crmk_commande, crmk_facture et crmk_commande_ach.

L'option Orz permet de remettre a zéros les tables crmk_devis, crmk_commande, crmk_facture et crmk_commande_ach...

Poids et surfaces

Les calculs de poids et surfaces sont réalisés via la fonction standard dédiée. Celle-ci envoie un message lorsque les 4 CIC ne sont pas créés.


Batch d'épuration de la table d'envoi fax/email

Batch d'épuration de la table d'envoi fax/email epu_fax_email

Ce programme permet d'épurer la table des envois fax/emails avec nombre de jours de rétention par type de document.

Notes

JOURS_RETENTION_

17,19 Type de document d'envoi fax/email

ACR Accusés de réception

ATR Alerte traçabilité

AVC Avenants de commande

BLV Bons de livraison

CDA Commandes d'achats

DEA Demandes d'achat

DEF (Type par défaut) : Le nombre de jours de rétention paramétré pour ce type particulier sera pris en compte pour la suppression des enregistrements dont le type n'est pas paramétré.

DEV Devis

FAC Facture

OAT Ordres d'achats de transport

21,24 Nombre de jours de rétention pour le document. Par défaut : 365 jours

Exemples

JOURS_RETENTION_ACR 450

JOURS_RETENTION_BLV 400

JOURS_RETENTION_DEF 300

Dans l'exemple ci-dessus :

  • Tous les enregistrements d'envois fax/email de type ACR datant de plus de 450 jours à partir de la date d'épuration seront supprimés.

  • Tous les enregistrements d'envois fax/email de type BLV datant de plus de 400 jours à partir de la date d'épuration seront supprimés.

  • Tous les enregistrements d'envois fax/email de type autre que ACR et BLV datant de plus de 300 jours à partir de la date d'épuration seront supprimés.


Gestion des habilitations

Gestion des habilitations habilit

Pas de paramétrage.

Utilise le paramètre #TC.

Utilise la table habilit.


Synchronisation ReflexClient

Synchronisation ReflexClient demon_crm

Options

Oci

Contrôle d'intégrité

Valeur alpha 2

1 | Autorise la traçabilité sur cli en création (O/N, N par défaut)
2 | Autorise la traçabilité sur cli en modification (O/N, N par défaut)
3 | Autorise la traçabilité sur cli en suppression (O/N, N par défaut)
4 | Autorise la traçabilité sur cli2 en création (O/N, N par défaut)
5 | Autorise la traçabilité sur cli2 en modification (O/N, N par défaut)
6 | Autorise la traçabilité sur cli2 en suppression (O/N, N par défaut)
7 | Autorise la traçabilité sur corres en création (O/N, N par défaut)
8 | Autorise la traçabilité sur corres en modification (O/N, N par défaut)
9 | Autorise la traçabilité sur corres en suppression (O/N, N par défaut)

Paramètres nécessaires

#CF CRM


Lancement d'un programme GENERO depuis la version 3.50 et réciproquement

Lancement d'un programme GENERO depuis la v. 3.50 et réciproquement lancement_pgm_genero

Valeur alpha 2

1,60

Chemin et nom du script de lancement des programmes GENERO

Exemple : /home/genero/lancement_genero

Si le mot GENEROapparaît dans ce chemin, le programme cherchera à lancer automatiquement le client GENEROsur le poste utilisateur (cf param. USE)

Valeur alpha 3

1,30

Adresse IP ou nom du serveur genero

Valeur alpha 4

1,6

Type et code du paramètre à lancer (facultatif)

Paramètres nécessaires

USE

Note commençant par CHEMIN_GDC

Note commençant par TYPE_CONNECTION

Pour les serveurs Windows, nécessite le positionnement de la variable VSWOS à windowsnt.


Envoi de fax et d'emails

Envoi de fax et d'emails envoi_fax_email

Option payante EFE 6

Nouveau fonctionnement avec le module FileRequest AVM

Options

Oad

Autoriser les envois vers n'importe quel numéro / email à partir du site de développement Volume Software

Oar

Arrêt du programme en tâche de fond

Oes

Le fax/mail est lancé par l'intermédiaire d'un script enregistré dans un paramètre de type WIN

Il s'inscrit dans les notes du module G_envoi_fax_email, comme le lancement actuel. (note commençant par EDI_typ_mod_site.

Exemple

EDI_ACR_MEL WINSAR

Si aucun paramétrage inscrit en fonction du type de document, possibilité d'inscrire ce paramétrage sur #CF EFM A1[37,42].

Voir la gestion d'envoi de mails via des scripts.

Oga

Génération des actions VoluGold

Opj

Vérification au préalable de la présence de la pièce jointe (le nom est celui du document qui serait construit par l'édition VoluEdit).

En cas d'absence, on lance l'édition classique afin de générer le document.

Cette option est utilisée dans le cadre du Nouveau fonctionnement avec le module FileRequest AVM

Oup

Arrêt du programme en tâche de fond après un seul passage

Valeur alpha2

1 à 4

Délai d'attente en minutes

Notes

CLE_DOCUMENT_xxx PREFIX_DOCUMENT_xxx CLE_OBJET_xxx PREFIX_OBJET_xxx | Notes permettant de : - nommer les pièces jointes - construire l'objet du mail Voir la page dédiée.
EDI_typ_mod_sit | Paramétrage des types de document et des modes d'envoi par site où typ peut prendre les valeurs suivantes : ACR Edition d'accusé de réception CDA Edition de commande d'achat DEV Edition de devis BLV Edition de bon de livraison MLG Edition de mailing par VoluEdit DEA Edition de demande d'achat par VoluEdit OAT Edition des ordres d'achat de transport FAC Factures clients et mod peut prendre les valeurs suivantes : FAX Envoi par fax MEL Envoi par e-mail et sit correspond au site de production (à blanc si pas de gestion du site de production) Tableau de bord du multisite 21,26 Type et code du paramètre de lancement du programme d'édition Voir la gestion d'envoi de mails via des scripts.
FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
FIC_NB_HISTO | 21,23 Nombre de fichiers traces et erreurs à historiser. Valeur par défaut 20
FIC_TRACE | 21,60 Nom du fichier trace
_SUP_ | 21 à 60 Supplément de requête sur la table envoi_fax_email


Intégration de fichier ADELI

Intégration de fichier ADELI adeli

Nouvelle table : adeli

Options

Orz

Remise à zéro de la table avant intégration de fichier complet

Cette option ne doit pas être positionnée pour un fichier de mise à jour

Valeur alpha 2

1,60

Chemin et nom du fichier ADELI à intégrer

Paramètres nécessaires

SPR | Libellé de la situation professionnelle
SPQ | Libellé de la spécialité qualifiée par l'ordre des médecins
SPC | Libellé de la nature de la spécialisation
CAC | Libellé du motif de cessation d'activité


Géocodage client

Géocodage client geocodage_cli

Ce programme s'inscrit dans le cadre de la logistique.

>>> Voir la fiche d'installation complète sur la logistique.

Options

-Oap | Mise à jour uniquement de l'adresse principale (table cli) Les adresses secondaires présentent dans la table cli2 ne sont pas mises à jour.
-B | Mode batch En mode batch, si plusieurs résultats sont retournés par Way Server pour une adresse, alors, le système ignore les réponses. Il n'y a alors pas de mise à jour. Dans le cas contraire, une fenêtre s'ouvre automatiquement pour proposer les différents choix. La validation d'un choix entraîne une mise à jour dans la table correspondante.

Valeur alpha 2

Caractère 1 | Ré-actualisation des coordonnées (O/N, N par défaut) Si O, on redemande les coordonnées d'une adresse même si les zones latitude et longitude sont déjà renseignées.
Caractère 2 | Calcul de la distance entre le client et le magasin principal Le code du magasin principal est paramétré dans le #CF WSL en alpha3[5,7]. Mise à jour de la table cli_distance : O Oui (si pas déjà calculé) N Non (par défaut) R Réactualisation des données de la table

Notes

_SUP_REQ_GEOCODAGE | 21 60 Complément de requête sur table cli Exemple and cl_annul = "N"
_SUP_REQ_GEOCODAGE2 | 21 60 Complément de requête sur table cli2 Exemple and c2_annul = "N"

Paramètres associés

#CF WSL | Configuration WAY SERVER
cli | Option -Ogc pour le géocodage du client Note _SUP_REQ_GEOCODAGE (et _SUP_REQ_GEOCODAGE2): Ce supplément de requête peut servir à éviter de géocoder des adresses inutilement.


Statistiques commerciales

Permettre d'intégrer les enregistrements d'historique de prix de revient (au niveau de la ligne de commande et/ou de la ligne de facture) dans les statistiques commerciales (sta_com_d)

Remarques :

La mise à jour des indicateurs de rentabilité (recap_couts) au niveau de la facture remet celle-ci comme étant à prendre en compte dans le programme des statistiques (G_stat_com.42r)

L'option d'alimentation de la table sta_com_d par paramétrage est utilisée, celle-ci nécessite la mise en place d'une option (voir ci-dessous) et est sujet à option payante (BAS/12)

ATTENTION : Pour l'alimentation statistique des factures, si l'enregistrement d'historique est récupéré au niveau de la commande, aucune proratisation n'est effectuée (dans le cas où l'indicateur récupéré est liée à la quantité commandée, il ne sera pas proratisé à la quantité facturée).

Statistiques commerciales stat_com

Valeurs alpha Notes Zones mises à jour

Options triées

Oac

Prise en compte de l'AS commission pour les chefs de secteurs externes (idem maj_stat_com)

Voir note COEFF_COUT_FACONNAGE

Oas

Le transport n'est pas recalculé lorsqu'une action de service de type transport existe déjà.

Oca

Prix de revient prévisionnel et réel = CA facturé

Incompatible avec l'option Opr

Oc4

Génération de la nomenclature (table cde4) à partir de la table nom0 lors de l'intégration des factures et des avoirs dans les statistiques commerciales lorsque le produit de la ligne de commande est un ensemble appairé et que la nomenclature n'a pas été générée.

Ocd

Génération des statistiques à partir des commandes

Ce paramétrage est obsolète : on affecte la nouvelle zone de paramétrage.

Le fait de positionner cette option force alpha2[1] à la valeur C

Ocr

Mise à jour du prix de revient réel avec le coût réel du dossier de fabrication si celui-ci est clos dans la génération des statistiques sur factures

Si cette option n'est pas activée, le prix de revient réel est toujours à 0.

Si cette option est activée et que le dossier de fabrication n'est pas clos, le prix de revient réel est à 0.

Si cette option est activée et que le dossier de fabrication est clos, le prix de revient réel est mis à jour avec le coût réel de celui-ci.

Ocs

Option d'ouverture d'une fenêtre de sélection des commandes

Oct

Recalcul du coût de transport

L'option Oas doit être activée.

Odr

Alimenter la table sta_com_d avec les données réelles (f0_cr, f0_crr), en lieu et place des données prévisionnelles.

Ofc

Le prix de revient est prix sur la ligne de commande quand la FBI est close.

Oip

A la création de sta_com, on renseigne la valeur du PRR avec celle du PRP.

On gère un flag dans sta_com_d : std_char03_14

0 PRR non disponible

1 PRR disponible pour dossier non clos

C PRR disponible sur dossier clos

Oiq

Environnement plastique

Olb

Non édition des lignes de debuggage

Omf

Mise à jour des familles et des sous-familles

Omn

SPECIFIQUE - Ne pas prendre ne compte le calcul du multi-niveaux

Omr

Mise à jour des représentants venant de la fiche client

Oms

Mise à jour des codes statistiques avec ceux de la ligne de commande

Onc

Mise à jour des codes secteur d'activité et représentant avec code_nc si la valeur trouvée est nulle.

Ope

Purge des enregistrement de type ensemble puisqu'ils sont inutiles

Incompatible avec A2[1] = L.

Opl

Poids net à partir du BL

Opm

On crée les lignes PF dans sta_com uniquement pour le PF de poids le plus grand d'un ensemble.

Utilisé en statistiques de type E (voir alpha2[1])

Opr

Prix de revient = CA si nul

Incompatible avec l'option Oca

Oqn

Quantités négatives pour un avoir

Orc

Le représentant doit être pris sur la fiche client ou sur les adresses secondaires

Ord

Calcul du prix de revient réel avec le prix de revient prévu réactualisé

On recalcule ce prix après avoir alimenté le détail.

Ore

Prise en compte de l'escompte dans le calcul de la ristourne

Avant, pour les factures, l'escompte était ajouté "en dur" à la ristourne (ristourne = ristourne + escompte).

Pour les autres documents, l'escompte n'était pas additionné à la ristourne (ristourne = ristourne).

Maintenant, la ristourne reste la ristourne. Cette option, permet d'y ajouter l'escompte et ce, pour tous les documents.

Orp

On force les représentants avec ceux des adresses principales de la fiche client

Ort

Recherche des prix de revient prévisionnel et réel dans les tarifs

Ose

Suppression des enregistrements evt_trans à l'issue d'un traitement accompli avec succès

Osp

sta_com_d est alimentée par paramétrage (option payante BAS 12)

Osr

Alimentation des codes statistiques CS1 à CS4 avec ceux du produit de la ligne de commande

Incompatible avec l'option Oms

Oth

Trace historique

Otr

Trace

Valeur alpha 2

Caractère 1

Type des statistiques générées

F Intégration des factures dans les statistiques commerciales (par défaut)

Génère des enregistrements de type F dans sta_com et sta_com_d

E Intégration des factures dans les statistiques commerciales (evt_trans)

Génère des enregistrements de type E dans sta_com et sta_com_d

C Intégration des commandes dans les statistiques commerciales

Génère des enregistrements de type C dans sta_com

L Intégration des bons de livraison dans les statistiques commerciales

Génère des enregistrements de type L dans sta_com et sta_com_d

Incompatible avec option Ope.

Valeur alpha 3

Pour info : les lignes PF représentent des livraisons appairées, les lignes ENS représentent des livraisons sur ensemble monté.

Caractères 1 à 3 | Code Non communiqué (obligatoire)
Caractères 4 à 15 | Nom du fichier trace (obligatoire) Le répertoire est dans la note REP_FIC_TRACE
Caractères 16 à 18 | Code action de service pour le calcul du transport
Caractère 19 | Méthode de calcul du transport 2 Nouvelle méthode de calcul du transport par la fonction de valorisation des transport
Caractère 20 | CAR Affectation de FAM/SFM facturé
Caractère 21 | CAR Affectation de FAM/SFM fabriqué
Caractère 22 | FRA Affectation de FAM/SFM facturé
Caractère 23 | FRA Affectation de FAM/SFM fabriqué
Caractère 24 | PF Affectation de FAM/SFM facturé
Caractère 25 | PF Affectation de FAM/SFM fabriqué
Caractère 26 | ENS Affectation de FAM/SFM facturé
Caractère 27 | ENS Affectation de FAM/SFM fabriqué
Caractères 28 à 30 | Code du type de véhicule utilisé pour la valorisation du transport
Caractère 31 | Méthode de calcul du CA de la table sta_com des livraisons clients 0 b2_montant (Valeur par défaut) 1 Montant livré au prix remis 2 Montant livré au prix proratisé selon le poids de l'élément dans l'ensemble
Caractères 32 à 34 | Code environnement de la recherche du prix de revient prévisionnel dans les tarifs Exemple : PR
Caractères 35 à 37 | Code environnement de la recherche du prix de revient réel dans les tarifs Exemple : PRR

Notes triées

ATTENTION ! Particularités de certaines notes, qui ne respectent pas les habitudes...

  • Certaines notes (les compléments de requête) sont en minuscules !

  • La note ArchitectureN est en minuscules sauf le premier et le dernier caractères.

  • La plupart des notes ont un paramétrage qui ne commence pas en caractère 21.

  • La note % TOLERANCE PAMP contient des espaces et non pas des underscores.

% TOLERANCE PAMP

18,20 Tolérance d'écart du prix de revient prévisionnel par rapport au PAMP unitaire

ArchitectureN

15,17 Famille pour les ensembles en architecture N (ensembles achetés)

18,20 Sous-famille pour les ensembles en architecture N (ensembles achetés)

COEFF_COUT_FACONNAGE

21,25 Coefficient multiplicateur à appliquer au coût de façonnage (idem maj_stat_com)

Voir option Oac

PR_EGAL_CA

12,14 Famille pour laquelle on force PR = CA

15,17 Sous-famille pour laquelle on force PR = CA

PR_EGAL_ZERO

14,16 Famille pour laquelle on force PR = 0

17,19 Sous-famille pour laquelle on force PR = 0

REP_FIC_TRACE

21,60 Répertoire du fichier de trace, obligatoirement terminé par un slash

Facultatif - Si le répertoire n'est pas renseigné, le fichier est créé comme précédemment dans le répertoire de l'application.

Pour info : le nom du fichier se trouve en A3[4,15].

Utile à cause des serveurs TSE, car le fichier trace est actuellement soit sur TSE1, soit sur TSE2.

Exemple D:/VOLUPACK/CELTA2/test_nv/

sup_req_blv1

13, 60 Complément de requête sur les entêtes de bon de livraison

EX :sup_req_blv1 and b1_blv matches "9809*"

sup_req_blv2

13 60 Complément de requête sur les lignes de bon de livraison

EX :sup_req_blv2 and b2_blv matches "9810*"

sup_req_cde1

13,60 Complément de requête sur l'entête de commande

sup_req_cde2

13,60 Complément de requête sur les lignes de commande

sup_req_com_car

16,60 Complément de requête OBLIGATOIRE sur les compositions techniques

sup_req_evt

12,60 Complément de requête sur evt_trans

_SUP_REQ_FAB0_AS

SPECIFIQUE

21,60 Complément de sélection sur fab0 pour les actions de service

Ce complément ne sert que pour l'OF de tête dans le cadre du multiniveau du département plastique.

Voir la note _SUP_REQ_FAB0_MN_AS

_SUP_REQ_FAB0_CM

SPECIFIQUE

21,60 Complément de sélection sur fab0 pour le calcul du coût matière de l'article chapeau pour la zone 3 (Coûts matières)

Exemple

and (f0_prod matches "Q*" or f0_prod matches "Z*")

_SUP_REQ_FAB0_FV_CM

SPECIFIQUE

21,60 Complément de sélection sur fab0 pour le calcul du coût matière de l'article chapeau pour la zone 4 (Frais variables)

Exemple

and f0_prod matches "P*"

_SUP_REQ_FAB0_MN_AS

21,60 Complément de sélection sur fab0 pour les actions de service pour les OF fils

Ce complément ne sert que dans le cadre du multiniveau du département plastique.

_SUP_REQ_FAB0_MN_CM

SPECIFIQUE

21,60 Complément de sélection sur fab0 pour le calcul des coûts matières des articles de niveaux inférieurs (hors article chapeau)

Exemple

and f0_prod matches "Q*"

_SUP_REQ_F0_FV_MN_CM

21,60 Complément de sélection sur fab0 pour le calcul des coûts matières frais variables des articles de niveaux inférieurs (hors article chapeau) (pour le département plastique)

Exemple

and f0_prod matches "Q*"

sup_req_fac0

13,60 Complément de requête sur l'entête de facture

sup_req_fbi

12,60 Complément de requête sur la recherche de FBI pour le calcul du prix de revient

sup_req_maj_fam

16,60 Complément de requête sur la mise à jour des familles

sup_req_maj_rep

16,60 Complément de requête sur la mise à jour des représentants

sup_req_qua_car

16,60 Complément de requête OBLIGATOIRE sur les compositions commerciales

Z11_03_EGAL_CA_

Possibilité de forcer les zones std_dec11_03_01 à std_dec11_03_30 de la table sta_com_d avec le CA

16,17 Numéro de la zone de la table sta_com_d (01 à 30) - Obligatoire

21,23 Famille pour laquelle on force la zone avec le CA - Obligatoire

24,26 Sous-famille pour laquelle on force la zone avec le CA - Facultatif

Z11_03_EGAL_ZERO_

Possibilité de forcer les zones std_dec11_03_01 à std_dec11_03_30 de la table sta_com_d à zéro

16,17 Numéro de la zone de la table sta_com_d (01 à 30) - Obligatoire

21,23 Famille pour laquelle on force la zone avec le CA - Obligatoire

24,26 Sous-famille pour laquelle on force la zone à zéro - Facultatif

_Z_STDx_ccc_nn

Voir ci-dessous pour la construction de cette note

Construction de la note _Z_STDx_ccc_nn

x = méthode de calcul du prix de revient (voir tableau plus bas)

1 Articles achetés (mp_param[5] = A)

2 Prix de revient prévisionnel et réel = CA

Familles/Sous-familles paramétrées dans les notes du paramètre de lancement et pour lesquelles PR= CA - Voir notes PR_EGAL_CA

3 Familles/Sous-familles paramétrées dans les notes du paramètre de lancement et pour lesquelles PR = 0 - Voir notes PR_EGAL_ZERO

4 Produit cartonnier/Composant d'un ensemble

5 Factures directes (FAD) ou Avoir (AVO)
Si la facture directe ou l'avoir n'est rattaché à aucune facture, recherche de la dernière FBI associée au produit fabriquée.
Si une FBI est trouvée, utilisation de la méthode 4 (Produit cartonnier/Composant d'un ensemble). Pas de paramétrage.

9 On ne tient pas compte de la méthode de calcul au niveau du lancement, un seul paramétrage suffit.
Cela évite les différents paramétrages suivant les modes de calcul.

D Autres cas (par défaut)

Type de données | ccc = code du champ pour la table sta_com_d | nn = N° du champ de la table sta_com_d
integer | INT | 01 à 05
smallint | SML | 01 à 05
decimal(11,3) | DEC1103 | 01 à 30
char(3) | CHR03 | 01 à 15
etc... | (voir tableau en bas) |

21, 60 Code du champ à récupérer :

- Champs de la table cli (exemple cl_code)

- Champs de la table mat (exemple mp_code)

y compris des_mp_qualite_mat : Désignation de la qualité matière (produit : mat dans f_zone)

ainsi que des_mg_qualite_mat : Désignation de la qualité matière (matière générique : mat_gen dans f_zone)

- Champs de la table hist_pr, sous la forme OT-hp_x, où

O Origine de l'enregistrement

C Ligne de commande

F Ligne de facture

(Attention : pas de valeur par défaut)

T Type de l'enregistrement (hist_pr.hp_type)

(Attention : pas de valeur par défaut)

hp_x Champ de la table hist_pr à récupérer

Exemples

FX-hp_z1 Zone numérique 1 de l'enregistrement de type X de l'historique au niveau de la ligne de facture

CM-hp_z12 Zone numérique 12 de l'enregistrement de type M de l'historique au niveau de la ligne de commande

FY-hp_z3 Zone numérique 3 de l'enregistrement de type Y de l'historique au niveau de la ligne de facture

etc.

Explications

- TSC : syntaxe d'appel des TSC (syntaxe 1)

Exemple :TSC_CL_CL_.01_G récupère la zone ic_char30 du TSC .01 sur le client

- Indicateurs de présence spécifiques :

SPE_PRES_COMP_I | Composante impression sur le PF | (résultat = O/N)
SPE_PRES_COMP_Y | Composante pré-impression sur le PF | (résultat = O/N)
SPE_PRES_COMP_D | Forme de découpe sur la composante conception | (résultat = O/N)
SPE_PRES_COMP_P | Palette sur le PF | (résultat = O/N)
SPE_PRES_COMP_A | Accessoires | (résultat = O/N)
SPE_PRES_COMP_K | Consommables | (résultat = O/N)

Modèle de paramétrage | zone de sta_com_d | Valeur numéro de zone
_Z_STDD_INT_01 | std_integer_01 | (nn : 01 à 05)
_Z_STD1_SML_02 | std_smallint_02 | (nn : 01 à 05)
_Z_STD2_DEC1103_13 | std_decimal11_03_13 | (nn : 01 à 30)
_Z_STD3_CHR03_03 | std_char03_03 | (nn : 01 à 15)
_Z_STD4_CHR10_01 | std_char10_01 | (nn : 01 à 05)
_Z_STD5_CHR15_10 | std_char15_10 | (nn : 01 à 10)
_Z_STDD_CHR30_09 | std_char30_09 | (nn : 01 à 15)
_Z_STD1_CHR40_04 | std_char40_04 | (nn : 01 à 05)
_Z_STD2_DAT_02 | std_date_02 | (nn : 01 à 05)

Exemples de paramétrage

123456789012345678901234567890

_Z_STD4_CHR10_01 cl_code

_Z_STD1_CHR15_01 mp_code

_Z_STD2_CHR15_02 mp_code

_Z_STD3_CHR15_03 mp_code

_Z_STD4_CHR15_04 mp_code

_Z_STD5_CHR15_05 mp_code

_Z_STDD_CHR15_06 mp_code

_Z_STDD_DEC1103_02 mp_lon

_Z_STDD_DEC1103_03 mp_lar

_Z_STDD_DEC1103_04 mp_hau

_Z_STDD_DEC1103_05 mp_poids

_Z_STD4_CHR03_01 SPE_PRES_COMP_I

_Z_STD4_CHR03_02 SPE_PRES_COMP_Y

_Z_STD4_CHR03_03 SPE_PRES_COMP_D

_Z_STD4_CHR03_04 SPE_PRES_COMP_P

_Z_STDD_CHR30_08 TSC_CL_CL_.01_G

_Z_STD4_DEC1103_01 FX-hp_z1 (1)

_Z_STD4_DEC1103_02 FX-hp_z2 (2)

_Z_STD4_DEC1103_01 FY-hp_z1 (3)

_Z_STD4_DEC1103_02 FY-hp_z2 (4)

Renvois des 4 derniers exemples :

(1) Pour la méthode de calcul du prix de revient n°4 uniquement
Alimentation de la première zone décimale (std_decimal11_03_01) avec la valeur 1 (hp_z1) de l'historique de type X au niveau de la ligne de facture

(2) Pour la méthode de calcul du prix de revient n°4 uniquement
Alimentation de la deuxième zone décimale (std_decimal11_03_02) avec la valeur 2 (hp_z2) de l'historique de type X au niveau de la ligne de facture

(3) Pour la méthode de calcul du prix de revient n°4 uniquement
Alimentation de la première zone décimale (std_decimal11_03_01) avec la valeur 1 (hp_z1) de l'historique de type Y au niveau de la ligne de facture

(4) Pour la méthode de calcul du prix de revient n°4 uniquement
Alimentation de la deuxième zone décimale (std_decimal11_03_02) avec la valeur 2 (hp_z2) de l'historique de type Y au niveau de la ligne de facture

Liste des zones de sta_com mises à jour pour les BL, par ordre alphabétique

sta_adc | Code adresse d'envoi de commande de l'entête de commande livrée
sta_adf | Code adresse de facturation de l'entête du BL
sta_adl | Code adresse du tiers livré (via RG1 dans le cas d'un transfert)
sta_ca_dev | Alimenté selon A3[31]
sta_ca_euro | 0Alimenté selon A3[31]
sta_ca_fr | 0Alimenté selon A3[31]
sta_cannelure |
sta_cde | Numéro de commande commerciale livrée
sta_client | Code du tiers livré (via RG1 dans le cas d'un transfert)
sta_coef_nom | Coefficient de nomenclature entre l'ensemble et le PF livré.
sta_compo_com | Code composition commerciale du produit livré
sta_compo_tech | Code composition technique du produit livré
sta_cs1 | Code statistique 1 du PF
sta_cs2 | Code statistique 2 du PF
sta_cs3 | Code statistique 3 du PF
sta_cs4 | Code statistique 4 du PF
sta_date_fac | Date de livraison de l'entête du BL
sta_ec_c1 | Zone paramétrable de l'entête de commande (site de commande pour une CD2, site de production si transfert d'une FBI).
sta_fac | Numéro de BL/BT
sta_fam_com | Famille composition commerciale du produit livré
sta_fam_tech | Famille composition technique du produit livré
sta_famfab | famille du produit fabriqué
sta_famfac | famille du produit facturé
sta_lcde | Numéro de ligne commande commerciale livrée
sta_lfac | Numéro de ligne du BL/BT
sta_lrep | Code représentant de la ligne de commande livrée
sta_lsite | Site de rattachement commercial du représentant de la ligne de commande (lié à la structure de la force de vente)
sta_num | 0
sta_poids_brut | Poids brute livré
sta_poids_net | Poids net livré
sta_pr_prev | 0
sta_pr_reel | 0
sta_prodfab | Code du produit livré (entre autres pour les ensembles montés, cette zone est bien égale au code ensemble puisque c'est l'ensemble qui est livré)
sta_prodfac | Code produit facturé
sta_prodfac_cli | Référence client du produit facturé
sta_qte | Quantité livrée
sta_qte_ens | 0
sta_rep | Code représentant du client, de l'entête de commande ou de la ligne de commande selon paramétrage.
sta_ristourne | 0
sta_sfm_com | Sous-Famille composition commerciale du produit livré
sta_sfm_tech | Sous-Famille composition technique du produit livré
sta_sfmfab | Sous-famille du produit fabriqué
sta_sfmfac | Sous-famille du produit facturé
sta_site | Site de rattachement commercial du représentant de l'entête de commande (lié à la structure de la force de vente)
sta_soc | Code société émettrice du BL/BT
sta_source | L
sta_suiv | Code assistante commerciale de la commande livrée
sta_surf_brut | Surface brute livrée
sta_surf_net | Surface nette livrée
sta_type | CAR si commande cartonnier (plaque) ENS si ensemble monté FRA si ligne de frais (ni un ensemble, ni un article cartonnier) PF si produit fini classique


Nomenclature douanière

Nomenclature douanière deb_n

Options

-Ocs

Mode consultation


#VE Aide générale au paramétrage des éditions VoluEdit

En plus du code (du Profil Cannelure, dans notre exemple -TSC_MP_PC_C1-), on récupère aussi :

libl_TSC_MP_PC_C1 (libellé long du profil cannelure)

libc_TSC_MP_PC_C1 (libellé court du profil cannelure)

num1_TSC_MP_PC_C1 (valeur numérique 1 du profil cannelure)

num2_TSC_MP_PC_C1 (valeur numérique 2 du profil cannelure)

alph_TSC_MP_PC_C1 (valeur alpha 1 du profil cannelure)

com_TSC_MP_PC_C1 (valeur alpha 2 du profil cannelure)

alph3_TSC_MP_PC_C1 (valeur alpha 3 du profil cannelure)

alph4_TSC_MP_PC_C1 (valeur alpha 4 du profil cannelure)

A titre d'exemple, dans VoluEdit :

La zone mp_code sera disponible sous le code mpMP_CT1_code.

La zone mp_fam sera disponible sous le code mpMP_CT1_fam.

etc.

Mais ce n'est pas tout ! Vous aurez également accès à toutes les zones de chaque paramètre.

Par exemple, pour la famille (mp_fam), vous aurez accès aux zones :

libl_mpMP_CT1_fam (libellé long de la famille)

libc_mpMP_CT1_fam (libellé court de la famille)

num1_mpMP_CT1_fam (valeur numérique 1 de la famille)

num2_mpMP_CT1_fam (valeur numérique 2 de la famille)

alph_mpMP_CT1_fam (valeur alpha 1 de la famille)

com_mpMP_CT1_fam (valeur alpha 2 de la famille)

alph3_mpMP_CT1_fam (valeur alpha 3 de la famille)

alph4_mpMP_CT1_fam (valeur alpha 4 de la famille)

Attention la sous-famille (sfm) ne respecte pas cette syntaxe :

Par exemple, le libellé long est codé mpMP_CT1_libl_sfm et non pas libl_mpMP_CT1_fam.

La structure est la suivante :

TSC Mot-clé déclarant un TSC

MP Code source de la clé (article principal - voir l'aide en ligne de chaque programme VoluEdit)

AFF Le TSC AFF est le TSC de l'affiche.

T01 Indique le premier TSC pour cette source.
Les identifiants suivants devront être codés T02, T03, etc.

A indique le type de clé du TSC qui suit (A = Article)

ITR Le TSC ITR indique les informations techniques au recto.

H représente le code zone du TSC (char 3_2).
Le TSC ITR zone H indique le type de vernis.

3 est le format à appliquer (3 caractères).

La structure est la suivante :

TSC Mot-clé déclarant un TSC

MP Code source de la clé (article principal - voir l'aide en ligne de chaque programme VoluEdit)

AFF Le TSC FC est le TSC de l'affiche.

T01 Indique le premier TSC pour cette source.
Les identifiants suivants devront être codés T02, T03, etc.

A indique le type de clé du TSC qui suit (A = Article)

ITR Le TSC ITR indique les informations techniques au recto.

H représente le code zone du TSC (char 3_2).
Le TSC ITR zone H indique le type de vernis.

LL indique que l'on récupère le libellé long du paramètre lu (dans la zone H).

Développé initialement pour G_voluedit_blv

Si l'on paramètre des notes sur le client principal, et des notes sur le client livré (par exemple), et que l'adresse de livraison n'est pas renseignée, alors le client livré est aussi le client principal, et l'on risque d'avoir des notes en double à l'édition.

Exemple

Il y a une note de type FAB sur le client principal : XXXXXXXXXXXXXXXXXXXXXXXXX

Il y a une note de type LIV sur le client secondaire 001 : YYYYYYYYYYYYYYYYYYYY

Si l'adresse de livraison est 001, on affichera les notes groupées suivantes dans le même cadre :

XXXXXXXXXXXXXXXXXXXXXXXXXXXX

YYYYYYYYYYYYYYYYYYYYYYYYYYYY

Si l'adresse de livraison est " ", on affichera les notes groupées suivantes dans le même cadre :

XXXXXXXXXXXXXXXXXXXXXXXXXXXX

Si le N n'est pas mis :

Si l'adresse de livraison est 001, on affichera les notes groupées suivante dans le même cadre :

XXXXXXXXXXXXXXXXXXXXXXXXXXXX

YYYYYYYYYYYYYYYYYYYYYYYYYYYY

Si l'adresse de livraison est ' ', on affichera les notes groupées suivante dans le même cadre :

XXXXXXXXXXXXXXXXXXXXXXXXXXXX

XXXXXXXXXXXXXXXXXXXXXXXXXXXX

#VE Aide générale au paramétrage des éditions VoluEdit

Voir aussi #CF EVE

Nouvelle fonction d'édition par canal_comm

Afin de bénéficier de cette aide, tous les paramètres de lancement des programmes d'édition VoluEdit doivent être de type #VE.

Attention ! si USE A3[57] est différent de O (Oui), on ne peut plus transférer le catalogue.

Valeur alpha 3

Titre de la fenêtre de sélection

Notes

EDITER_RAPPORT | Sur certaines éditions, l'option Obe permet de ne pas éditer le rapport récapitulatif en fin de traitement. Cette note permet de généraliser ce fonctionnement à toutes les éditions. 21 Editer un rapport (O/N, O par défaut)
CLE_DOCUMENT_xxx PREFIX_DOCUMENT_xxx CLE_OBJET_xxx PREFIX_OBJET_xxx | Notes permettant de : - nommer les pièces jointes - construire l'objet du mail Voir la page dédiée.
GRW_CONFIG | Active les éditions avec Genero Report Writer 21,23 Code paramètre de type GRW (configuration des éditions) 24,26 Code paramètre de type GRV (configuration des variables additionnelles dans le catalogue)
VE_CAT | Paramétrage centralisé de catalogue
VE_DOC | Document VoluEdit sélectionnable
VE_IMP | Choix de la sortie impression
VE_NCA | Caractères 8 à 60 : Nom du catalogue à utiliser pour l'édition
VE_SIT_SOR_ | Paramétrage de l'imprimante par site - Tableau de bord du multisite
VE_SOR | Choix de l'imprimante On peut déclarer cette note sans indiquer d'imprimante (édition "dans le vide") Dans ce cas, il n'y a aucune édition, mais les éventuels traitements sont tout de même effectués (mise à jour de flag, etc.).
VE_VAR | Variables à ajouter au catalogue
VE_WEB | 21 Edition VoluEdit utilisée pour le mode WEB (O/N, N par défaut) Force la sortie en mode DIRECTE, active le mode batch et impose le nom du fichier PDF. Voir #CF WEB

Notes commençant par VE_VAR : Variables à ajouter au catalogue.

Attention : Ces notes seront IGNOREES s'il existe une note de type VE_CAT.

Il existe 4 notes commençant par VE_VAR :

1 - Notes VE_VAR avec les TSC

2 - Notes VE_VAR avec les notes

3 - Notes VE_VAR avec les notes groupées

4 - Notes VE_VAR avec les LCO

Notes VE_VAR avec les TSC

Le résultat proviendra d'une information complémentaire (stockée dans un TSC).

Note : seules les 2 syntaxes suivantes sont possibles.

Les autres syntaxes (décrites dans d'autres pages) NE sont PAS utilisables.

2 syntaxes possibles :

1) VE_VAR Libellé*TSC_SS_CCC_ZZZ*Format*Niveau*

Libellé Libellé de la zone du TSC

TSC Mot clé indiquant qu'il s'agit d'un TSC

SS Source de la clé. Les codes sources des clés sont détaillés pour chaque édition VoluEdit dans leurs pages respectives.

CCC Code du TSC

ZZZ Code zone du TSC en respectant la syntaxe suivante :

D1, D2 pour les zones dates

N1, N2, N3 pour les zones numériques (exemple 2 dans le tableau plus bas)

C1, C2 pour les zones alphanumériques de 3 caractères (exemple 3 dans le tableau plus bas)

L1, L2 Si C1 et C2 contiennent un code paramètre, alors on a accès à tout le paramétrage (libellé, valeurs numériques et alpha) (exemple 4 dans le tableau plus bas)

C30 pour la zone alphanumérique de 30 caractères (idem exemple 3)

L30 Si C30 contient un code paramètre, alors on a accès à tout le paramétrage (libellé, valeurs numériques et alpha) (idem exemple 4)

MAT Permet de récupérer toutes les zones de la fiche article dont le code est stocké sur un TSC.

Par exemple, sur VoluEdit, le lieu de rangement de l'article stocké sur le TSC CT1 sera accessible par le champ mpMP_CT1_rgt1
(exemples 5 et 8 dans le tableau plus bas)

CLP Client principal

CL1 Client adresse 1

CL2 Client adresse 2

Txx Permet de ramener un TSC défini dans la zone Format dont la clé est la zone ic_char30 du TSC défini par SS et CCC (exemple 6 dans le tableau plus bas)

xx est un identifiant unique (par exemple T01, T02, T03….) pour chaque source identique mais de type de trame de saisie (ic_ts) différent.

Dans ce cas, le format est de type T_CCC_Z_F avec :

T Type de TSC (ic_type)

CCC Code TSC (ic_ts)

Z Code zone TSC

F Le format

Pour les zones caractères (ic_char3_1, ic_char3_2 et ic_char30), le paramétrage des TSC permet de spécifier si elles pointent sur une table
(voir les caractères 19/20 de la note commençant par Z).

Si la zone du TSC pointe sur la table par02, on peut récupérer les libellés et les valeurs numériques

On remplace alors le format par l'un des codes suivants : (exemple 7 dans le tableau plus bas)

LC Libellé court (p2_libc)

LL Libellé long (p2_libl)

N1 Zone numérique 1 (p2_zc1)

N2 Zone numérique 2 (p2_zc2)

N3 Zone numérique 2 (p2_zc3)

N4 Zone numérique 2 (p2_zc4)

Si la zone du TSC pointe sur la table mat, on peut maintenant récupérer le libellé, les dimensions et le poids

On remplace alors le format par l'un des codes suivants :

LL Libellé (mp_des)

N1 Longueur (mp_lon)

N2 Largeur (mp_lar)

N3 Hauteur (mp_hau)

N4 Poids (mp_poids)

C1S pour la zone alphanumérique de 30 caractères limitée au 1er slash trouvé

Exemple : NOIR /UV 150 PW renvoie NOIR

LE pour les libellés étrangers d'un code produit (ou FEFCO) issu de la lecture de la zone alphanumérique de 30 caractères d'un TSC.

Si aucun enregistrement de la table lib_etr n'est trouvé, on lit la table libelle_langue.
On récupère la valeur de la zone ll_lib_principal dans le_libpar1,
et la valeur de la zone ll_lib_complement dans le_libelle2.

Format Pour les zones dates et numériques : Format de la zone. Pour les zones alphanumériques : largeur de la zone.

Niveau Niveau multi-produit pour le devis onduleur.

Exemples

N° | Syntaxe | Explication
1 |  |
2 | VE_VAR Affiche: Laize *TSC_MP_41P_N1* | On récupère la zone numérique 1 du TSC 41P (code source MP - article principal)
3 | VE_VAR Profil cannelure *TSC_MP_PC_C1* | On récupère la zone alpha 1 du TSC PC
4 | VE_VAR Profil cannelure *TSC_MP_PC_L1* | Idem que ci-dessus mais en plus on récupère tout le paramétrage (+ d'info)
5 | VE_VAR Papier cannelure 1 *TSC_MP_CT1_C30*15 VE_VAR Papier cannelure 1 *TSC_MP_CT1_MAT* | On récupère (sur 15 car.) la zone alpha de 30 car. du TSC CT1 et on l'utilise comme clé pour récupérer toutes les zones de la table mat (+ d'info)
6 | VE_VAR TSC AFF Vernis recto*TSC_MP_AFF_T01*A_ITR_H_3** | On récupère le TSC ITR à partir du TSC AFF (+ d'info)
7 | VE_VAR TSC AFF Vernis recto*TSC_MP_AFF_T01*A_ITR_H_LL** | On récupère le libellé long du paramètre lu dans la zone H du TSC ITR à partir du TSC AFF (+ d'info)
8 | Cliquez pour afficher / masquer un exemple "visuel"

2) VE_VAR Libellé*TSC_CAS0n_CCC_Txx*Format*

Dans la pratique, n'est utilisé que dans voluedit_oex.

Libellé Libellé de la zone du TSC

TSC Mot clé indiquant qu'il s'agit d'un TSC

CAS0n TSC avec cascade

CAS01

Séquence de ligne de commande de rattachement

Ligne de commande de rattachement

Produit

Ensemble

Client + adresse livraison

Client

CAS02

Triplet article / gamme / phase

Article

Ensemble

CAS03

Ligne de commande de rattachement

Produit (MP/ENT)

Produit

Client + adresse de livraison

Client

CCC Code du TSC

Txx Permet de ramener un TSC défini dans la zone Format dont la clé est la zone ic_char30 du TSC défini par CAS02 et CCC

xx est un identifiant unique (par exemple T01, T02, T03….) pour chaque source identique mais de type de trame de saisie (ic_ts) différent.

Voir exemples plus bas.

Dans ce cas, le format est de type T_CCC_Z_F avec :

T Type de TSC (ic_type)

CCC Code TSC (ic_ts)

Z Code zone TSC

F Le format (idem Format du paramétrage classique)

Exemples

VE_VAR FORME 1T*TSC_CAS02_DF1_C30*

VE_VAR FORME 1T*TSC_CAS02_DF1_MAT*

VE_VAR FORME 2T*TSC_CAS02_DF2_C30*

VE_VAR FORME 2T*TSC_CAS02_DF2_MAT*

VE_VAR ENCRE 1T*TSC_CAS02_I01_L1*

VE_VAR ENCRE 2T*TSC_CAS02_I02_L1*

VE_VAR ENCRE 3T*TSC_CAS02_I03_L1*

VE_VAR CLICHE 1T*TSC_CAS02_IC1_C30*

VE_VAR CLICHE 1T*TSC_CAS02_IC1_MAT*

VE_VAR NB. MORC. 1T*TSC_CAS02_IC1_T01*A_OU1_D_###*

VE_VAR DATE DISP 1T*TSC_CAS02_IC1_T02*A_ICD_A_dd/mm/yyyy*

VE_VAR CLICHE 2T*TSC_CAS02_IC2_C30*

VE_VAR CLICHE 2T*TSC_CAS02_IC2_MAT*

VE_VAR CLICHE 3T*TSC_CAS02_IC3_C30*

VE_VAR CLICHE 3T*TSC_CAS02_IC3_MAT*

VE_VAR NB. MORC. 3T*TSC_CAS02_IC3_T03*A_OU1_D_###*

VE_VAR DATE DISP 3T*TSC_CAS02_IC3_T04*A_ICD_A_dd/mm/yyyy*

VE_VAR DIVERS MAC 2T*TSC_CAS02_GC2_C30*

VE_VAR DIVERS MAC 3T*TSC_CAS02_GC3_C30*

VE_VAR Ond/Divers 1T*TSC_T/OND_GO1_C30*

VE_VAR Ond/Divers 2T*TSC_T/OND_GO2_C30*

Notes VE_VAR avec les notes

Le résultat proviendra d'une série de lignes de notes.

VE_VAR Libellé*NOTES_SS_TN1_TN2_TN3*NbLig*Niveau*Adresse*

NOTES Mot clé indiquant qu'il s'agit d'une note

SS Source de la clé. Les codes sources des clés sont détaillés pour chaque édition VoluEdit

TN1 à TN3 Il est possible d'indiquer jusqu'à 3 types de notes

Si la note n'est pas typée, mettre ###

NbLig Nombre de lignes

Attention : la présence d'un unique champ suffit à imprimer plusieurs lignes de notes.

Prévoyez donc un espace suffisant pour contenir le nombre de notes maximum attendu.

Niveau Niveau multi-produit pour le devis onduleur.

Adresse On prend en compte l'adresse, même si le code adresse secondaire n'est pas renseigné (O/N)

Exemples

VE_VAR Une note de type LIV sur client*NOTES_CL_LIV*1*

VE_VAR Trois notes CDE, BLV, FAC*NOTES_CL_CDE_BLV_FAC*3*

VE_VAR notes_nom*NOTES_MP/NOM_ART*1*

Pour provoquer un saut de ligne lors de l'édition, commencez la ligne par //.

Pour paramétrer des notes libres de type NTS saisies dans par02note, la source de la clé doit être ##.

On indique les types de notes (il s'agit des codes paramètres correspondant au type de paramètre NTS)

Exemple

VE_VAR Notes Libres*NOTES_##_FAC_BLV*

Dans cet exemple, on va chercher les notes sur les paramètres NTS FAC et NTS BLV.

Ces notes se trouvent dans le catalogue dans le groupe de l'entête pour les éditions du type entête-lignes :

voluedit_acr

voluedit_blv

voluedit_facn

voluedit_fle_cli

voluedit_oex

voluedit_oex_tc

Elles se trouvent à la racine du catalogue pour les éditions du type fiches :

voluedit_fiche_produit

voluedit_fiche_tiers

Notes VE_VAR avec les notes groupées

Le résultat proviendra d'une série de lignes de notes groupées.

VE_VAR Libellé*NOTGR_SS_TN1_TN2_TN3*NbLig*Niveau*PEC*

NOTGR Mot clé indiquant qu'il s'agit de notes groupées.

SS Source de la clé. Les codes sources des clés sont détaillés pour chaque édition VoluEdit.

TN1 à TN3 Il est possible d'indiquer jusqu'à 3 types de notes.

NbLig Nombre de lignes.

Niveau Niveau multi-produit pour le devis onduleur.

PEC Prise en compte de la note si l'adresse secondaire n'est pas renseignée (O/N, O par défaut) - Plus d'info

Les lignes de notes paramétrées avec NOTGR_ génèrent une seule variable dans un même contexte, mais cette variable est générée dans un groupe multilignes indépendant.

Le nom de cette variable résulte de la concaténation des différents paramétrages qui la concernent.

Exemple

VE_VAR Note Livraison*NOTGR_CL_LIV*

VE_VAR - Note Palettisation*NOTGR_CL_PAL*

Ces 2 paramètres génèreront une seule variable dans le groupe multi-lignes Notes groupées contextuel à l'édition des informations du client.

Cette variable aura pour nom Note Livraison - Note Palettisation.

Ce groupe multi-lignes, nommé Notes Groupées, contient, en plus de la variable concernant le texte de la note, une variable contenant le type de note.

Pour provoquer un saut de ligne lors de l'édition, commencez la ligne par //.

Pour paramétrer des notes libres de type NTS saisies dans par02note, la source de la clé doit être ##.

On indique les types de notes (il s'agit des codes paramètres correspondant au type de paramètre NTS)

Exemple

VE_VAR Notes Libres BLV*NOTGR_##_BLV*

Dans cet exemple, on va chercher les notes sur le paramètre NTS BLV.

Ces notes se trouvent dans le catalogue dans le groupe de l'entête pour les éditions du type entête-lignes :

voluedit_acr

voluedit_blv

voluedit_facn

voluedit_fle_cli

voluedit_oex

voluedit_oex_tc

Elles se trouvent à la racine du catalogue pour les éditions du type fiches :

voluedit_fiche_produit

voluedit_fiche_tiers

Notes VE_VAR avec les LCO

Le résultat proviendra d'une information complémentaire.

VE_VAR Libellé*LCO_SS_CCC_Z*Format*

LCO Mot clé indiquant qu'il s'agit d'une ligne complémentaire.

SS Source de la clé :

L2 Entête du devis

FI Entité du devis

LI Entité de la ligne de commande

Les codes sources des clés sont détaillés pour chaque édition VoluEdit.

CCC Code de la LCO

Z Code zone de la LCO :

M,N Matière, Machine

O,S Opération, Section seule

1,2, 3, 4 Zones numériques 1 à 4

A,B, G, H Zones alphanumériques 1 à 4

D,F Difficulté, Fournisseur

Format Format de la zone

Exemple

VE_VAR Donnée technique*LCO_D_T16_1*0*

En plus du code produit ramené, on peut maintenant récupérer n'importe quelle zone de sa fiche mat.

Exemple

VE_VAR Fiche conditionnement*LCO_FI_EM1_M_mp_qualite***

On rajoute au paramétrage existant :

mp_qualite : nom de la zone recherchée de la table mat

Exemple avec un numérique

VE_VAR Fiche conditionnement*LCO_FI_EM1_M_mp_lon_N***

On peut préciser le format si c'est un numérique.

N : format numérique (optionnel)

Notes commençant par VE_CAT : Paramétrage centralisé de catalogue

Cette note évite d'avoir à dupliquer les notes VE_VAR s'il existe plusieurs paramètres de lancement pour un même programme d'édition.

La note VE_CAT a priorité sur les notes VE_VAR, qui sont donc ignorées.

Caractères 8 à 10 Type du paramètre sur lequel il faut rechercher les notes de type VE_VAR

Caractères 11 à 13 Code du paramètre sur lequel il faut rechercher les notes de type VE_VAR

Exemple

VE_CAT #VEACR

Notes commençant par VE_DOC : Documents VoluEdit sélectionnables

Vous pouvez limiter les modèles apparaissant dans la liste de choix au moment de l'édition (voir § 5), en créant des notes commençant par VE_DOC.

Caractères 8 à 60 : Nom d'un fichier situé dans le répertoire dédié aux modèles VoluEdit (paramétrage dans VoluEdit).

Ces notes sont cumulables.

Si plus de 2 modèles sont paramétrés, ceux-ci seront proposés à l'utilisateur dans une liste de sélection.

Si aucun modèle n'est paramétré, tous les modèles présents dans le répertoire dédié aux modèles VoluEdit seront présentés dans la liste de sélection.

Vous pouvez restreindre la liste de modèles à l'aide d'un ou plusieurs filtres :

Un affichage plus rapide de la liste peut être obtenu en ne paramétrant que des noms de modèles complets.

Exemples

VE_DOC AR* Sélectionne tous les modèles commençant par AR

VE_DOC *AR Sélectionne tous les modèles se terminant par AR

VE_DOC *AR* Sélectionne tous les modèles dont le nom contient l'expression AR

VE_DOC Mon édition

VE_DOC fac*

Notes commençant par VE_IMP : Choix de la sortie impression

Vous pouvez limiter le choix de la sortie édition (voir § 5) en créant des notes commençant par VE_IMP.

Caractères 8 à 60 choix de la sortie édition

PREVISU Affichage du document dans la fenêtre de prévisualisation. Le document peut encore être modifié et sauvegardé avant d'être imprimé.

ATTENTION ! Ce mode n'est plus maintenu.

Pour conserver l'édition en tant que fichier, il est toutefois possible de l'orienter vers un logiciel gérant une imprimante virtuelle.

Cette imprimante convertit l'édition VoluEdit au format .pdf.

Ces logiciels de conversion sont généralement des outils gratuits téléchargeables sur Internet (pdfcreator, cute pdf writer..)

APERCU Affichage du document dans la fenêtre d'aperçu avant impression. Le document ne peut plus être modifié ni sauvegardé.

DIRECTE Impression directe sur l'imprimante par défaut.

Ces notes sont cumulables. Sans paramétrage, les 3 options sont proposées à l'utilisateur lors de l'édition.

Exemples

VE_IMP APERCU

VE_IMP DIRECTE

Notes commençant par VE_SOR : Choix de l'imprimante

Vous pouvez imposer une imprimante particulière en créant des notes commençant par VE_SOR.

Caractères 8 à 60 Nom d'une imprimante configurée sous Windows.

Il est possible de ne spécifier qu'une partie du nom de l'imprimante.

Exemples

VE_SOR Imprimante_Laser_Compta

VE_SOR Imprimante_Laser*

VE_SOR *Laser*

VE_SOR *Compta

Il est préférable de déclarer une imprimante réseau afin que tous les postes puissent avoir accès à cette imprimante.

ATTENTION : si vous imprimez sur une imprimante qui n'est pas l'imprimante par défaut configurée dans Windows, vous DEVEZ IMPERATIVEMENT déclarer cette imprimante dans la note commençant par VE_SOR.

Notes commençant par VE_SIT_SOR : Choix de l'imprimante par site

Tableau de bord du multisite

Actuellement on peut paramétrer l'imprimante à utiliser sur la note commençant par VE_SOR.

On peut maintenant affiner ce paramétrage en indiquant quelle imprimante on peut utiliser sur le site de production associé à l'utilisateur.

La note VE_SOR doit être présente.

S'il n'y a pas d'imprimante paramétrée pour le site du user, on prend celle paramétrée dans la note VE_SOR.

Disponible à partir de la V. 4.0.167.2

Caractères 12 à 14 : Code site de production

Caractères 16 à 60 : Code imprimante à utiliser pour ce site de production

Exemples

VE_SOR Konica

VE_SIT_SOR_ABC PDFCreator

VE_SIT_SOR_DEF HP LaserJet 6P 3ème

Si l'utilisateur fait partie du site ABC, on imprimera sur l'imprimante PDFCReator.

Si l'utilisateur fait partie du site DEF, on imprimera sur l'imprimante HP LaserJet 6P 3ème.

S'il ne fait partie d'aucun de ces deux sites, on imprimera sur l'imprimante Konica.

Rappel

La gestion par site doit être activée (#CF SIT A1[1] = O).

Le site est indiqué sur l'utilisateur (USE A3[10,12]).

Edition par canal_comm

Lors de l'édition ou de la réédition standard des

Devis (voluedit_fle_cli),

Commandes d'achat (voluedit_edicf),

Bons de livraison (voluedit_blv),

Factures (voluedit_facn),

on peut provoquer une édition VoluEdit par canal_comm, invisible pour l'utilisateur.

Cela permet d'enregistrer un document au format pdf en plus de l'édition.

Le lanceur de l'édition standard aura le paramétrage suivant :

Option Ogc | Permet de bénéficier de cette fonctionnalité sans édition visible.
EDIT_AVEC_COPIE_CC | 21 Création d'un enregistrement dans canal_comm lors de l'édition (O/N)
REEDIT_AVEC_COPIE_CC | 21 Création d'un enregistrement dans canal_comm lors de la réédition (O/N)

Un cron permettra de déclencher la création de PDF. Paramétrage du cron :

Option Oup | Un seul passage
Option Oar | Arrêt de la scrutation (si l'option Oar n'est pas positionnée)
Note MODE_AUTONOME | 21 Mode autonome (O/N) Mettre O
Note FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie
Note FIC_TRACE | 21,60 Nom du fichier trace
Note FIC_LOCK_EXECUTION | 21,60 Nom fichier lock
Note PARAM_ED_xxx_AUTO | 21,26 Type et code du paramètre de lancement de l'édition VoluEdit PDF du document (par exemple #VEBLX) où xxx peut prendre les mêmes valeurs que celles de la note CLE_DOCUMENT_xxx ci-dessous.

Le lanceur de l'édition VoluEdit PDF (par exemple #VEBLX) aura le paramétrage suivant :

VE_SOR | 8,60 PDFCreator
VE_IMP | 8,60 DIRECTE
CLE_DOCUMENT_xxx | 21,60 Paramétrage pour nommer la pièce jointe (en haut de ce chapitre)

NOUVEAU : un programme permet d'éditer directement tous les enregistrements d'édition présent dans la table canal_comm, quelque soit leur type.


#CF EVE Configuration VoluEdit

Voir le paramétrage des éditions VoluEdit : #VE pour les paramètres généraux

Valeurs numériques

NUM 1 | Nombre de variables catalogue avant de faire une pause (par défaut : 50)
NUM 2 | Temporisation en secondes Temporisation entre chaque édition VoluEdit, afin de permettre à la première de fermer la socket avant que la deuxième ne l'ouvre.

Valeur alpha 1

Caractère 1 | Mode de transmission de données D liaison DDE (par défaut) S socket TCP-IP Si vous choisissez le mode TCP/IP : Vous devez ajouter les 2 lignes suivantes dans le fichier defaut/par_util : num_port_voluedit 11100 num_port_volusentinel 11101 Il s'agit de valeurs par défaut, qui doivent correspondre au paramétrage Windows. Dans VoluEdit : Menu Outils, Options, onglet Général : Si nécessaire, cochez la case Modification du numéro de port pour indiquer une nouvelle valeur.
Caractère 2 | Version VoluEdit >= 1.6.9 (O/N, N par défaut)

Valeur alpha 2

Caractère 1 | Les fichiers sont classés dans un sous-dossier société pour chaque catégorie (catalogues / documents / éditions) (O/N, N par défaut) O Les fichiers VoluEdit sont enregistrés dans autant de sous-dossiers différents que de sociétés pour chaque type de fichier. Nécessaire uniquement si vous gérez plusieurs sociétés et si vous souhaitez créer des éditions différentes pour chaque société. N Il n'y a pas de sous-répertoire par société.
Caractère 2 | Réservé Volume Software
Caractère 3 | Réservé à Volume Software -
Caractère 4 | Fermeture automatique de VoluEdit lors de la fermeture du GDC en TSE (O/N) Nécessite VoluEdit version 1.7.3
Caractère 5 | Temporisation pour l'ouverture de VoluEdit, en secondes. de 2 à 9 (valeur par défaut 2)


voluedit_acr Edition des accusés de réception de commande

Pensez à consulter les autres paramètres dans le programme d'édition standard.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_DEC

Uniquement pour la papeterie

Caractères 7 et suivants : numéro de commande papeterie et numéro de ligne de découpe en utilisant le format XXXXXXXX-YYY

où XXXXXXXX = numéro de commande papeterie sur 8 caractères et YYY = numéro de ligne de découpe

Options propres à l'édition VoluEdit

O9e

L'édition de l'AR portera uniquement sur la présentation (table cde9_e)

Il sera possible de faire l'édition même si aucune ligne de commande n'a été générée.

Ne fonctionne que si l'option Op1 est active.

Pour la papeterie

Oba

Gestion des barèmes

L'option payante CDE-8 (Saisie des barèmes) doit être activée.

L'option société 39 (Gestion des prix au mille +) doit être positionnée.

Occ

Sélection des lignes de cadencements de livraison à éditer

Odp

Edition bon de découpe

Cette option active automatiquement l'option Op1 même si elle n'est pas paramétrée.

Oev

Avec cette option, l'édition d'un AR peut entraîner le lancement de la visu de commande, avec le numéro de commande et le code de la forme de découpe en paramètres.

Si on passe le code de la forme de découpe, alors on ne passe plus le numéro de commande (pour pouvoir justement visualiser toutes les commandes ayant ce code de découpe).

Voir A3[28,34]

Ofe

Forcer l'édition d'une commande, même si elle est déjà éditée.

Ogc

Alimentation de canal_comm

Permettre d'éditer les AR VoluEdit en utilisant uniquement canal_comm, comme pour les BL et factures.

Utilisé entre-autre pour les éditions en WEB

Ol1

Edition de la ligne 1 des commandes de type FB1

Ome

Active la gestion du multi-lignes des entités

Oml

Edition en mode listing (Liste des commandes)

Onp

Activation des notes paramétrables

Voir les notes commençant par V- dans les TSC

Op1

Accusé de réception de papeterie - Voir l'option Op1 dans la saisie de commande client.

Voir les zones du package pied de commande

Ord

Lors de l'édition/réédition, les lignes de découpe sont regroupées.

Utilisé aussi pour la papeterie

Otc

Edition d'une commande liée à un devis transformateur carton (devis_tc)

Pour le devis transformateur carton (devis_tc), les LCO ne sont pas accessibles sur l'entête de devis. De même, les clés d'enregistrement étant différentes entre le devis transformateur carton et le devis multi-métiers, une option a été ajoutée afin de gérer correctement le devis transformateur.

Le code d'accès pour le paramétrage des variables (notes de type VE_VAR) est L2 (Entête du devis)

Ote

Edition des notes de type TEXTILE de la table cde3

Oti

Gestion des titres des groupes multilignes

Pensez aux caractères 1 à N de la valeur alpha 4.

Ove

OBLIGATOIRE Activation de l'édition par VoluEdit

Valeur alpha3

Caractères 28 à 33 | Type et code du paramètre de lancement de la visu de commande client. Voir option Oev Dans le programme de visualisation de commandes clients, paramétrez les notes suivantes : 1) Dans le complément de sélection commençant par S, ajoutez la chaîne _CODE_FORME_PARAM (au même titre que la chaîne CRIT_CHAR_n) : cette chaîne sera remplacée par le code de la forme passé en paramètre. 2) Paramétrez la note REFERENCES_OUTIL avec un O en caractère 21 et rien en caractère 22.
Caractère 34 | Passage du code de la forme de découpe (O/N) Voir option Oev
Caractère 35 | Restreindre ce code forme au client de la commande en cours

Valeur alpha 4

Caractère 1 | Activation du titre du groupe Ligne de commande au niveau de la ligne de commande (cde2) (O/N, N par défaut)
Caractère 2 | Activation du titre du groupe Nomenclature au niveau de la ligne de commande (cde2 )(O/N, N par défaut)
Caractère 3 | Activation du titre du groupe Cadencement de livraison au niveau de la ligne de commande (cde2) (O/N, N par défaut)
Caractère 4 | Activation du titre du groupe TEXTILE (O/N, N par défaut)
Caractère 5 | Activation du titre du groupe Cadencement de livraison au niveau de la nomenclature de commande (cde4)
Caractère 6 | Activation de la gestion du titre du groupe multi-lignes des entités du devis si option Oti positionnée (O/N, N par défaut)
Caractère 7 | Activation du titre du groupe Détail de prix (O/N, N par défaut)
Caractère 8 | Activation du titre du groupe Libellé du détail de prix (O/N, N par défaut)
Caractère 9 | Activation du titre du groupe Schéma de calcul du détail de prix (O/N, N par défaut)
Caractère 10 | Activation du titre du groupe Descriptif du schéma de calcul du détail de prix (O/N, N par défaut)

Notes propres à l'édition VoluEdit

EDIT_AVEC_COPIE_CC

REEDIT_AVEC_COPIE_CC

21 Ajout d'un enregistrement dans la table canal_comm lors de l'édition / la réédition d'un AR

EDITION_ARC_MODE

21 Mode d'édition

0- Configuration par défaut

1- Avec des cumuls de quantités pour le même produit.

Pour gérer les commandes PRX (offre de prix)

Voir la note SUP_REQ_POUR_PRX

Le but est de pouvoir cumuler plusieurs prix et quantités pour un même produit, sans répéter pour autant la fiche de ce même produit.

Cette option servira surtout pour les éditions qui utilisent la saisie de commande comme offre de prix.

ETATS_CADENCEMENTS

21,32 Réservé

33,35 Code état d'édition des cadencements de livraison (Paramètre ECA)

Remarques

1. La mise n'est effectuée que si le code état est paramétré.

2. Si le paramétrage n'existe pas sur le paramètre de lancement, on recherche ce dernier sur la configuration générale Atlas (#CFATL)

FAXMAIL_AVENANT

21 Gestion de l'envoi des avenants dans Fax/Mail

O On gère les avenants dans Fax/Mail en autorisant les nouveaux envois.

N On ne gère pas les avenants dans Fax/Mail (dans ce cas, on ne renverra que des AR traditionnels).

[Espace] Fonctionnement actuel (on envoie l'avenant par Fax/Mail mais les nouveaux envois sont à gérer directement dans le programme de gestion des Fax/Mails)

Cette note doit impérativement être saisie avant les notes de gestion de la validation automatique (note commençant par VALID_FAXMAIL)

MAJ_FLAG_INFO_C

Voir page dédiée

Exemple

1 2 3

1234567890123456789012345678901234567890

MAJ_FLAG_INFO_C FEPOCO [ec_num]

21 F = mise en place du flag

22,24 EPO = Code du TSC à mettre à jour

25 C = Type de clé TSC (C = commande)

26,28 O = Valeur du champ de flag

29,60 [ec_num] = Clé du TSC (numéro de commande)

Option Osm pour éditer le type de document désiré sans mettre à jour le champ ec_ar (statut de l'édition de l'AR)

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table cde3. Obligatoire. Exemple : TEX

ORDRE_GROUPE_LIGCDE

21 à 22 Code du groupe multi-lignes (de 01 à 02)

23 à 24 Numéro d'ordre du groupe multi-lignes (de 01 à 02)

Règles de paramétrage :

  1. Un code de groupe multi-lignes ne peut être paramétré qu'une seule fois.

  2. Un numéro d'ordre de groupe multi-lignes ne peut être paramétré qu'une seule fois.

  3. Si on ne paramètre pas les ordres de tous les groupes, on utilise les ordres par défaut pour les groupes restants.

  4. S'il existe un intervalle dans les numéros d' ordre, cet intervalle est comblé par les prochains ordres paramétrés. Ensuite, c'est la règle numéro 3 qui s'applique.

Ordre d'apparition des groupes par défaut :

01 Nomenclature de la commande

02 Cadencements de livraison de la commande

Exemple de paramétrage :

ORDRE_GROUPE_LIGCDE 0201

ORDRE_GROUPE_LIGCDE 0102

Le groupe Cadencement de livraison (02) sera édité en 1ère position.

Le groupe Nomenclature (01) sera édité en 2ème position.

PARAM_REF_CLIENT

Nouvelle zone de référence d'entête commande cliente plus grande <VF>

Dans la saisie des commandes clients et/ou lors du transfert d'un devis en commande, via paramétrage, il est possible de saisir une deuxième référence client (ec_ref_2) sans contrainte de clé unique jusqu'à 30 caractères.

La première référence peut être masquée pour ne laisser que la deuxième référence visible dans les écrans.

Cette nouvelle zone est accessible dans les éditions VoluEdit et dans les visualisations.

ATTENTION : Ne mettre les caractères 21 ET 22 à N (simultanément) quen transfert de devis en commande ou en consultation !!!

21 Afficher ou Masquer la référence client 2 (ec_ref_2) (champs plus grand)

O Afficher

Dans ce cas, la référence client (ec_ref) est systématiquement renseignée avec le numéro de commande (ec_num).

N Masquer (par défaut)

22 Afficher ou Masquer la référence client (ec_ref)

O Afficher (valeur par défaut si la note n'est pas créée, ou qu'elle est créée avec les car. 21 & 22 vides)

N Masquer (valeur par défaut si la note est créée, ou qu'elle est créée avec le car. 21= O)

23, 24 Type d'aide sur saisie référence (facultatif)

01 Référence = Numéro de commande

02 Référence = Client – Nombre de commandes

03 Référence = Client – Millésime de la commande – Nombre de commandes

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF ATL.

RESTRIC_STOCK_NUM_

Possibilité d'ajouter 5 zones de stock du PF (et 5 zones de stock de l'ensemble) dans le package de la fiche matière. Ces 5 zones sont rattachées à un complément de sélection paramétrable.

Attention, l'ajout de ces nouvelles zones ne se fait que s'il existe un paramètre de restriction sur le lanceur.

Dans l'exemple ci-dessous, on a paramétré deux restrictions sur le paramètre de lancement.

On aura donc 2 X 2 nouvelles zones de stocks (pour chaque restriction, on a le stock PF et le stock ensemble).

Attention !!! Le paramétrage se fait sur le lanceur du programme, et pas sur le paramètre du catalogue s'il existe.

Paramétrage

19,20 Numéro de la restriction

21,60 Restriction (sur la table stk0) pour la recherche de stock

Exemple

RESTRIC_STOCK_NUM_01 and s0_rgt1 in ('USI','MHU')

RESTRIC_STOCK_NUM_01 and s0_rgt1 is not null

RESTRIC_STOCK_NUM_02 and (s0_rgt1 in ('D92','D94','DPS',

RESTRIC_STOCK_NUM_02 'LTL','CTX', '', ' ')

RESTRIC_STOCK_NUM_02 or s0_rgt1 is null)

Dans le catalogue VoluEdit, nous avons 4 nouvelles zones sous Ligne de commande > Article ligne de commande :

Stock physique 01 de l'ensemble

Stock physique 01 du PF

Stock physique 02 de l'ensemble

Stock physique 02 du PF

_SUP_REQ_CDE4

21,60 Complément de sélection sur la table de la nomenclature des lignes de commande (cde4)

Utilisé notamment dans la gestion de la PLV

_SUP_REQ_FLE_IMP

Complément de requête sur la table fle_imp pour le groupe multi-lignes des entités

_SUP_REQ_INFOC_NOTE

Complément de requête sur info_c pour filtrer les TSC

SUP_REQ_POUR_PRX

21,60 Complément de requête pour exclure des produits, où la quantité ne sera pas cumulée

Fonctionne de pair avec la note EDITION_ARC_MODE

Exemple

SUP_REQ_POUR_PRX and lc_fam = 'FRA'

_SUP_REQ_TABLE_CDE8

21,60 Complément de sélection sur la table cde8 (cadencements de livraison)

TEMPO_VOLUEDIT

Délai d'attente en secondes

A partir de l'édition des AR (qui peut être faite via VoluEdit), on peut enchaîner l'édition des fiches de fabrication (qui peut aussi être une édition VoluEdit).

Dans le cas d'une configuration VoluEdit par socket, l'enchaînement de plusieurs éditions peut provoquer une erreur VoluEdit car le programme n'a pas le temps de ré-initialiser la socket employée.

Pour éviter cette erreur, cette temporisation paramétrable entre les éditions.

Paramètre optionnel

MDO, alpha1[13,20] : Nom du modèle de document pour VoluEdit

Champs détail du TEXTILE ajoutés au catalogue

Matière première | mp_textile | Car. 05-19 de cde3.kc_com
Désignation matière première | des_mp_textile |
Quantité matière première | qte_mp_textile | Car. 01-04 de cde3.kc_com
Tous les champs de la fiche matière première | kcmp_XXX | Table mat

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
CL | Code client | Entête de commande
CL/ACR | Adresse de l'AR | Entête de commande
CL/FAC | Adresse de facturation | Entête de commande
CL/FIN | Client final de la commande (adresse principale ou secondaire) |
CL/LIV | Adresse de livraison | Entête de commande
CL/SOC | Note sur #SOC | Entête
EC | Commande | Entête de commande
EC2 | Code ECMA (TSC seulement) |
FI | Entité (Notes seulement) |
LC | Ligne de commande | Ligne de commande
LC/LI | Cadencement de livraison au niveau de la ligne de commande (cde2) | Ligne de commande
LI/CLF | Notes saisies sur l'adresse de facturation de la ligne de cadencement de livraison |
LI/CLL | Notes saisies sur l'adresse de livraison de la ligne de cadencement de livraison |
MP | Code article principal | Ligne de commande
MP/ARC | Code article de l'architecture (composition) | Ligne de nomenclature
MP/COM | Code article de la composition | Ligne de nomenclature
MP/DEC | Code article de la découpe | Ligne de nomenclature
MP/ENS | Code article de l'ensemble | Ligne de nomenclature
MP/ENT | Code article de l'entité |
MP/IMP | Code article de l'impression | Ligne de nomenclature
MP/NOM | Code article de la nomenclature | Ligne de nomenclature
MP/PAL | Code article de la palette | Ligne de nomenclature
MP/PRE | Code article de la pré-impression | Ligne de nomenclature
MP/QUA | Code article de a qualité | Ligne de nomenclature
NC/LI | Cadencement de livraison au niveau de la ligne de nomenclature de commande (cde4) | Ligne de commande

Description du package Pied de commande

Voir l'option Op1 (papeterie)

Numéro de commande

Mode de règlement

Échéance

Exportation (O/N)

Montant brut HT

Remise

Escompte

Montant net HT

Taxe parafiscale

Montant total de la TVA

Montant port + TVA

Montant frais expédition + TVA

Montant TTC

Prix de revient


Ce package donne accès aux notes du tiers associé au lieu intermédiaire.

Dans certains cas, le lieu intermédiaire renseigné dans l'entête du BL fait référence à un fournisseur ou un client.

Il est maintenant possible d'accéder à ces notes.

Il faut dans ce cas que le nom du lieu intermédiaire (RG1) corresponde à un code tiers (soit un code tiers sur trois caractères).

voluedit_blv Edition des bons de livraison

Voir aussi le paramétrage du programme d'édition standard.

Options propres à l'édition VoluEdit

Oar

Arrêt de la scrutation (quand pas de passage unique)

Voir l'édition des BL par canal_comm

Ocf

Génération d'une commande d'achat en automatique lors de l'édition définitive du bon de livraison selon le lieu de rangement 1 (RG1) et le code statistique (CS1).

Voir aussi

Note CONFIG_TARIF_ACHAT

Note GENERATION_CDEF

CS1, caractères 11 à 17

RG1, note GEN_CDEF_FAM

SFM, note CODE_ART_ACH

Odp

Active le détail du colisage en statique (détail palette)

Odv

Edition du détail picking pour les produits gérés en vrac

Ofi

Accès au groupe multi lignes des entités liées au devis de la ligne de commande

Ogc

Gestion canal_comm

Permet d'ajouter un enregistrement dans canal_comm sans faire d'édition VoluEdit.

Voir l'édition des BL par canal_comm

Oge

Génération des étiquettes Galia

Cela positionne automatique l'option –Odp (détail palette)

La zone ic_char3_1 du TSC TRS doit être = E

Oip

Autorise la recherche d'infos colisage sur les notes de type #mp de blv3

Op0

Nombre de palettes mis à 0 si non renseignée dans le détail de colisage

Op3

Mode papeterie

Ajoute un package dans le catalogue des éditions des BL pour afficher la liste du colisage en mode papeterie.

Opc

Poids recalculé en utilisant le poids net de l'article (CIC-N54)

Dans l'édition VoluEdit des BL, si on souhaite éditer les poids nets (CIC N54 multipliés par la quantité livrée de la ligne), on peut le faire via une zone calculée, mais dans ce cas, on ne récupère pas le poids total sur l'entête du BL.

Cette option a pour but de recalculer les zones b1_poids et b2_poids des BL en fonction du poids net de l'article stocké dans le CIC-N54.

Opg

Lors de l'édition définitive du BL, si le nombre de palettes expédiées est différent du nombre de palettes prévues du groupage, le BL ne sera pas édité. Cette option est liée au A4[12] en saisie des BL qui permet de saisir et d'enregistrer le nombre de palettes prévues dans le groupage.

Orf

Lors du détail du colisage en édition/réédition, au lieu d'éditer une ligne par palette, l'édition fera le cumul des quantités par numéro de lot ayant la même quantité par palette.

Autrement dit : rupture par rapport au numéro de lot et/ou à la quantité par palette

Orq

Réintégration de la quantité non livrée de l'appel de livraison si la ligne de cadencement de livraison est soldée et si le BL est édité en définitif

Ote

Edition des notes de type TEXTILE de la table blv3

Oti

Gestion des titres des groupes multilignes

Pensez aux caractères 1 à N de la valeur alpha 4.

Otp

Totalisation du détail de picking par ligne de BL (Utilisation de la zone top_totalisation)

Oup

Un seul passage

Voir l'édition des BL par canal_comm

Ovd

Activation de l'édition par VoluEdit - OBLIGATOIRE

Valeur alpha 2

Caractère 1 | Type de messages à conserver pour la confirmation de fin d'édition [espace] On conserve tous les messages. 1 On ne conserve que les messages normaux. 2 On ne conserve que les messages d'erreur. 3 On ne conserve aucun message et le programme se termine sans action de l'utilisateur.
Caractère 7 | Activation du titre pour le groupe multilignes des entités du devis
Caractère 8 | Activation du titre pour le groupe multilignes de la nomenclature de la ligne de commande pour les ensembles montés.

Valeur alpha 3

Caractères 25 à 27

Code qualificatif Sur Appel du cadencement de livraison (paramètre QAL) - Obligatoire

EX : SAP

Valeur alpha 4

Caractère 1 | Activation du titre pour le groupe Ligne de BL (O/N, N par défaut)
Caractère 2 | Activation du titre pour le groupe Ligne colisage (O/N, N par défaut)
Caractère 3 | Activation du titre pour le groupe Ligne de picking (O/N, N par défaut)
Caractère 4 | Activation du titre pour le groupe TEXTILE (O/N, N par défaut)
Caractère 5 | Activation du titre pour le groupe multiligne récapitulatif par type de palette (O/N, N par défaut)
Caractère 6 | Activation du titre pour le groupe multiligne récapitulatif par type de protection palette (O/N, N par défaut)
Caractère 7 | Activation du titre pour le groupe multilignes des entités du devis
Caractère 8 | Activation du titre pour le groupe multilignes de la nomenclature des lignes de commande pour les ensembles montés
Caractère 9 | Activation du titre pour le groupe multilignes des lignes des palettes d'expédition
Caractère 10 | Activation du titre pour le groupe multilignes des lignes de picking des palettes d'expédition

Notes

CONFIG_TARIF_ACHAT | 21,26 Type et code de paramètre pour la recherche de tarif Voir l'option Ocf
EDIT_AVEC_COPIE_CC | 21 Edition normale avec envoi d'une copie vers canal_comm (O/N) - Voir l'édition des BL par canal_comm
FIC_ANOMALIE | 21,60 Nom du fichier d'anomalie - Voir l'édition des BL par canal_comm
FIC_LOCK_EXECUTION | 21,60 Nom du fichier lock - Voir l'édition des BL par canal_comm
FIC_TRACE | 21,60 Nom du fichier trace - Voir l'édition des BL par canal_cmom
GENERATION_CDEF | 21,26 Type et code du paramètre de lancement de la génération de commande d'achat Voir l'option Ocf
LCT_PRG_APRES_BL | 21,60 Type et code paramètre du programme à lancer après chaque BL Exécution d'un programme paramétré recevant en argument Nx où x = N° de BL. Ce module est exécuté pour chaque BL dont on éditera un accusé de réception.
MODE_AUTONOME | 21 Mode autonome (O/N) - Voir l'édition des BL par canal_comm
NOTE_TEXTILE | 21,23 Type de note du TEXTILE de la table blv3. Obligatoire. Exemple : TEX
PARAM_ED_BLV_AUTO | 21,26 Type et code du paramètre de lancement de l'édition VoluEdit des BL - Voir l'édition des BL par canal_comm
REEDIT_AVEC_COPIE_CC | 21 Réédition normale avec envoi d'une copie vers canal_comm (O/N) - Voir l'édition des BL par canal_comm
SUP_ORDER_BY_STK0 | 21,60 Ordre de tri sur la table stk0 Exemple _SUP_ORDER_BY_STK0 s0_lot, s0_rgt2
_SUP_REQ_FLE_IMP | 21,60 Complément de requête sur la table fle_imp
_SUP_REQ_SITE | Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur Tableau de bord du multisite 21,39 Nom de la colonne sur laquelle on fera le contrôle du site. Exemple : l2_site, ec_c1, b1_sitp, … Le site de production est inscrit sur le paramètre USE, en A3[10,12].
TEMPO_VOLUEDIT_ETIQ | Temporisation en secondes (5 par défaut) Cette temporisation permet d'éviter un plantage en TCP/IP, en DDE cela laisse plus de temps au poste pour traiter les données.
TYPE_TSC_PAP_BOBM | Mode papeterie Dans la liste du colisage papeterie (Op3), pouvoir récupérer l'information de la bobine mère. Permet d'initialiser la zone Bobine mère du catalogue Bon de livraison du Détail colisage papeterie. 21,23 Code du TSC contenant la bobine mère Types de table : CNI - CNP Type de clé : 7

Codes sources des clés TSC et Notes

Code

Libellé

Disponibilité

B1

Bon de livraison

Entête du BL

B2

Ligne de BL

Ligne de BL

CL

Code client

Entête du BL

CL/FAC

Adresse de facturation

Entête du BL

CL/FIN

Client final de la commande (adresse principale ou secondaire)

CL/LIV

Adresse de livraison

Entête du BL

CL/SOC

Note sur #SOC

Entête

EC

Entête de commande

Ligne de BL

LC

Ligne de commande

Ligne de BL

LC/LI

Notes sur cadencements de livraison

Ligne de BL

LI/CLF

Notes saisies sur l'adresse de facturation de la ligne de cadencement de livraison

LI/CLL

Notes saisies sur l'adresse de livraison de la ligne de cadencement de livraison

LII

Tiers associé au lieu intermédiaire - Info

Entête du BL

MP

Code article de la ligne de commande

Ligne de BL

MP/ARC

Code article de la l'architecture --> code article de l'architecture du PF livré

Pour info : le MP/ARC vise l'architecture du MP/NOM qui peut être le code produit de ligne de commande si on livre directement celui-ci.

Ligne de BL

MP/AR2

Permet de paramétrer une ligne de note pour obtenir les informations d'un TSC de type MP/ARC déjà paramétré pour un autre groupe VoluEdit

(TSC uniquement)

Exemples:

VE_VAR Laize Produit*TSC_MP/ARC_070_N1*0.00*

VE_VAR Laize Produit*TSC_MP/AR2_070_N1*0.00*

On obtient la même information mais dans deux groupes distincts.

Le premier groupe alimente la variable gl_ve_article_arc avec la clé tandis que le deuxième alimente la nouvelle variable gl_ve_article_ar2.

Ainsi, l'unicité du nom de variable VoluEdit est respectée.

En effet, le nom de la variable correspond à TSC_MP/ARC_070_N1 pour la 1ere ligne et TSC_MP/AR2_070_N1 pour la seconde.

MP/COM

Code article de la composition

MP/DEC

Code article de la découpe

MP/ENS

Code article de l'ensemble

MP/IMP

Code article de l'impression

MP/NOM

Code article du PF livré (nomenclature de commande)

NC/LI

Cadencement de livraison au niveau de la ligne de nomenclature de commande (cde4)

Accès aux notes de cadencement

Exemples

VE_VAR note cad interne *NOTES_NC/LI_PR2**

VE_VAR note cad client *NOTES_NC/LI_DER2**

MP/PAL

Code article de la palette

MP/PRE

Code article de la pré-impression

MP/QUA

Code article de la qualité

Paramètre optionnel

MDO, alpha1[13,20] : Nom du modèle de document pour VoluEdit

Champs détail du TEXTILE ajoutés au catalogue

Matière première | mp_textile | Car. 05-19 de blv3.kb_com
Désignation matière première | des_mp_textile |
Quantité matière première | qte_mp_textile | Car. 01-04 de blv3.kb_com
Tous les champs de la fiche matière première | kbmp_XXX | Table mat


voluedit_bon_prep Edition des bons de préparation

Pas d'équivalent en édition standard

Utiliser plutôt le programme d'édition des ordres de chargement (voluedit_ordre_chargement).

Valeur numérique 1

Nombre maximum de lots par page.

Options triées

-N<bon> | Edition du bon N° <bon>
Ols | Les informations de la ligne de groupage BL (table groupage_bl) ne se situent plus sous la ligne de commande, mais sous la séquence de la ligne de commande.
Ore | Permet de répéter l'entête de commande
Orl | Répéter les infos de la ligne de commande (groupe multi-ligne) sur toutes les pages à chaque rupture de séquence. Ne fonctionne que si l'option -Ove est activée.
Oti | Active la gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Ove | OBLIGATOIRE Activation de l' édition par VoluEdit

Valeur alpha 4

Caractère 1 | Activation titre groupe Entête commande (O/N, N par défaut)
Caractère 2 | Activation titre groupe Ligne commande (O/N, N par défaut)
Caractère 3 | Activation titre groupe Séquence (O/N, N par défaut)
Caractère 4 | Activation titre groupe Stock (O/N, N par défaut)
Caractère 5 | Activation titre groupe Nomenclature (O/N, N par défaut)

Notes

_SUP_REQ_GBL | 21,60 Complément de requête sur la table des groupages (groupage_bl)
_SUP_REQ_NOM0 | 21,60 Complément de requête sur la table des composants (nom0)
_SUP_REQ_STK0 | 21,60 Complément de requête sur la table des mouvements de stocks (stk0)
_SUP_ORDER_GBL | 21,60 Complément de tri sur la table des groupages (groupage_bl)
_SUP_ORDER_CDE2 | 21,60 Complément de tri sur la table des lignes de commande (cde2)
_SUP_ORDER_BY | 21,60 Complément de tri
TITRE_PROG | 21,60 Titre de l'écran. Par défaut : Sélection des ordres de chargement
TITRE_MENU | 21,50 Titre du menu. Par défaut : Ordres de chargement

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
CL | Code client | Entête de commande Nœud du groupage
CL/ACR | Adresse de l'AR | Entête de commande
CL/FAC | Adresse de facturation | Entête de commande
CL/LIL | Adresse de livraison de la ligne de commande | Ligne de commande
CL/LIV | Adresse de livraison | Entête de commande
EC | Commande | Entête de commande
LC | Ligne de commande | Ligne de commande
MP | Code article | Ligne de commande Séquence de commande
MP/ARC | Code de l'architecture (conception) |
MP/NOM | Code article d'un élément de nomenclature | Séquence de commande
NC | Séquence nomenclature de commande | Séquence de commande
NC/GBP | Type du TSC rattaché aux lignes de groupage Tous les champs de la nouvelle table groupage_bl_prepa ont été ajoutés au catalogue du bon de préparation. On peut aussi éditer les TSC rattachés aux lignes de groupage. |
NC/GP | Séquence nomenclature de commande – Groupage Voir ci-dessous Construction de la clé TSC (TSC uniquement) | Séquence de commande

Construction de la clé TSC sur les groupages BL

EXEMPLE : 20020328C12345ADLRG101

Date de départ "yyyymmdd"__|______|| || || |||

Code client________________________|____|| || |||

Adresse de livraison_____________________|_|| |||

Lieu de destockage__________________________|_|||

Indice d'éclatement "&&"_______________________||

Informations du tiers livré

Ajout des champs du tiers livré au catalogue

Le tiers livré n'est pas forcément celui de la ligne de groupage.

Pour déterminer le code du tiers livré et son code adresse de livraison, on procède de la façon suivante.

Par défaut, le code du tiers livré et son code adresse de livraison sont ceux de la ligne de groupage.

  • Si le lieu de rangement est renseigné et qu‘un code tiers lui est associé (RG1 A1[14,22]), on remplace le code du tiers livré et son code adresse de livraison par ceux du lieu de rangement de la ligne de groupage.

  • Si le code transitaire est renseigné (le code transitaire n'a pas de code adresse de livraison), on remplace le code du tiers livré et son code adresse de livraison par le code transitaire de l'adresse principale (pas de code adresse de livraison) ou l'adresse de livraison (un code adresse de livraison) du tiers livré.

code_tiers_livre | Code du tiers livré
adr_tiers_livre | Code adresse du tiers livré
nom_tiers_livre | Nom du tiers livré
codp_tiers_livre | Code postal du tiers livré
ville_tiers_livre | Ville du tiers livré
pays_tiers_livre | Pays du tiers livré


voluedit_ebrc Edition des bons de réception fournisseurs

Voir aussi le paramétrage du programme d'édition standard.

Options propres à l'édition VoluEdit

Oel | Activation mode liste en alternant un groupe entête et un groupe ligne de bon de réception
Oli | Activation du mode liste
Ove | OBLIGATOIRE Activation de l' édition par VoluEdit

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
BRE | Entête du bon de réception |
BRD | Ligne du bon de réception |
CL | Code client | Entête de commande
CL/ACR | Adresse de l'AR | Entête de commande
CL/FAC | Adresse de facturation | Entête de commande
CL/LIV | Adresse de livraison | Entête de commande
EF | Commande d'achat | Entête de commande
LF | Ligne de commande d'achat | Ligne de commande
MP | Code article principal | Ligne de commande

Notes

_SUP_REQ_SITE | Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur Tableau de bord du multisite 21,39 Nom de la colonne sur laquelle on fera le contrôle du site. Exemple : l2_site, ec_c1, b1_sitp, … Le site de production est inscrit sur le paramètre USE, en A3[10,12].
TEMPO_VOLUEDIT_ETIQ | 21,23 Temporisation entre deux éditions d'étiquettes VoluEdit, en secondes. Par défaut : 5 secondes


voluedit_bon_retour Edition VoluEdit des bons de retour

Voir aussi le paramétrage du programme d'édition standard.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Numéro de bon de retour

Exemple : -N[br1_numero]

Options triées

Oel | Mode liste qui présente les informations de l'entête pour chaque ligne de bon de retour
Oli | Mode liste des bons de retour (si option non positionnée on a un bon par page)
Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.

Valeur alpha 4

A41[1] | Activation de la gestion du titre du groupe multi-lignes des entêtes de bon de retour (O/N, N par défaut) Attention : Dans ce cas, un des modes liste doit être activé (-Oli/-Oel) + -Oti
A4[2] | Activation de la gestion du titre du groupe multilignes des lignes de bon de retour (O/N, N par défaut)
A4[3] | Activation de la gestion du titre du groupe multilignes des actions correctives (O/N, N par défaut)
A4[4] | Activation de la gestion du titre du groupe multilignes des traitements (O/N, N par défaut)
A4[5] | Activation de la gestion du titre du groupe multilignes des défauts constatés (O/N, N par défaut)
A4[6] | Activation de la gestion du titre du groupe multilignes des origines des défauts (O/N, N par défaut)
A4[7] | Activation de la gestion du titre du groupe multilignes des notes descriptives (O/N, N par défaut)
A4[8] | Activation de la gestion du titre du groupe multilignes des notes calcul avoir (O/N, N par défaut)
A4[9] | Activation de la gestion du titre du groupe multilignes des notes observations générales (O/N, N par défaut)
A4[10] | Activation de la gestion du titre du groupe multilignes des notes vérifications effectuées (O/N, N par défaut)
A4[11] | Activation de la gestion du titre du groupe multilignes des notes actions correctives (O/N, N par défaut)
A4[12] | Activation de la gestion du titre du groupe multilignes des notes traitement (O/N, N par défaut)
A4[13] | Activation de la gestion du titre du groupe multilignes des notes descriptives écran traitement (O/N, N par défaut)
A4[14] | Activation de la gestion du titre du groupe multilignes des notes recherche des causes (O/N, N par défaut)

Codes sources des clés Notes et Notes groupées

BR

Notes sur l'entête du bon de retour

Ce code source est valable :

1) pour des notes (NOTES)

2) pour des notes groupées (NOTGR)

Exemples

VE_VAR notes entete *NOTES_BR*NOTES_BR_BRC*

VE_VAR notes entete *NOTGR_BR_BRC*

Notes

_SUP_REQ_SITE

Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur

Tableau de bord du multisite

21,39 Nom de la colonne sur laquelle on fera le contrôle du site.

Exemple : l2_site, ec_c1, b1_sitp, …

Le site de production est inscrit sur le paramètre USE, en A3[10,12].


voluedit_edicf Edition des commandes fournisseurs

Voir aussi le paramétrage du programme d'édition standard.

Options propres à l'édition VoluEdit

Oar | Arrêt de la scrutation (quand pas de passage unique) Voir l'édition des commandes d'achat par canal_comm
Obp | Réception prévisionnelle des bobines Option Ove obligatoire Voir la fiche d'installation
Ogc | Gestion canal_comm Permet d'ajouter un enregistrement dans canal_comm sans faire d'édition VoluEdit. Voir l'édition des commandes d'achat par canal_com
Ola | Applique les dimensions de la ligne de commande dans la formule de conversion à la place des dimensions de la fiche article.
Oli | Mode d'édition listing. Incompatible avec –N
Opl | Ajoute un groupe Produit + infos complémentaires dans le catalogue
Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Oup | Un seul passage Voir l'édition des commandes d'achat par canal_comm
Ove | OBLIGATOIRE Activation de l' édition par VoluEdit

Valeur alpha 4

Caractère 1 | Activation titre groupe Ligne commande (O/N, N par défaut)
Caractère 2 | Activation titre groupe Cadencement (O/N, N par défaut)
Caractère 3 | Activation titre groupe Bobine ligne de commande (O/N, N par défaut) Voir la fiche d'installation
Caractère 4 | Activation titre Groupe Détail besoin matière (O/N, N par défaut) Voir #CF-ATL A1[44]

Notes

CONFIG_RECEP_BOBINE

Type et code du paramètre de configuration de la réception des bobines - Facultatif

#CFBOB par défaut

Voir la fiche d'installation

EDIT_AVEC_COPIE_CC

21 Edition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des commandes d'achat par canal_comm

FIC_ANOMALIE

21 Nom du fichier d'anomalie

Voir l'édition des commandes d'achat par canal_comm

FIC_LOCK_EXECUTION

21 Nom du fichier lock

Voir l'édition des commandes d'achat par canal_comm

FIC_TRACE

21 Nom du fichier trace

Voir l'édition des commandes d'achat par canal_comm

MODE_AUTONOME

21 Mode autonome (O/N)

Voir l'édition des commandes d'achat par canal_comm

NA

Génération de lignes de notes dans l'entête de commande d'achat

Ces notes sont générées une seule fois lors de l'édition ou de la réédition.

3,5 Type de note (par exemple : ANR)

Ce type de notes doit être créé pour que la prise en compte de la notion Annule et remplace soit active.

Elle sera positionnée au niveau des entêtes de commandes d'achat.

Ce type de notes était déjà utilisé pour l'édition des ACR. Son utilisation est donc étendue aux commandes d'achat.

6,60 Libellé

NEXT_PARAM_FAXEMAIL

21,26 Type et code du paramètre de lancement à exécuter pour envoyer la commande par Fax/Mail si cette occurrence n'a pas pu le faire (pour cause d'incompatibilité avec les compléments de sélection)

Explication

Actuellement, si les éditions envoyées par Fax/Mail nécessitent plusieurs modèles VoluEdit différents, il faut gérer plusieurs paramètres de lancement du programme envoi_fax_email avec des compléments de sélection assez compliqués.

Pour simplifier cela, on a ajouté la possibilité dans le programme d'édition des commandes d'achats VoluEdit la possibilité de demander l'édition Fax/Mail à un autre paramètre de lancement si le complément de sélection paramétré ne permet pas l'édition par cette occurrence.

PARAM_ED_CDF_AUTO

21,26 Type et code du paramètre de lancement de l'édition VoluEdit des commandes d'achats

Voir l'édition des commandes d'achat par canal_comm

REEDIT_AVEC_COPIE_CC

21 Réédition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des commandes d'achat par canal_comm

_SUP_REQ_SITE

Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur

Tableau de bord du multisite

21,39 Nom de la colonne sur laquelle on fera le contrôle du site.

Exemple : l2_site, ec_c1, b1_sitp, …

Le site de production est inscrit sur le paramètre USE, en A3[10,12].

_SUP_REQ_TABLE_CDE8

21,60 Complément de sélection sur la table cde8 (cadencements de livraison)

_SUP_REQ_TABLE_CDF4

21,60 Complément de requête sur la table cdf4

Permet par exemple de n'afficher les données que du premier cadencement de livraison de chaque ligne.

TEXTE_PARAM_

Possibilité de saisir des textes dans les notes du paramètre de lancement, disponibles ensuite dans le catalogue régénéré.

13,14 Indice du texte paramétrable

21,60 Texte paramétrable à éditer.

Les différentes lignes de texte paramétrable de même indice sont concaténées et séparées par un espace.

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
CL | Code client | Entête de commande
CL/ACR | Adresse de l'aR | Entête de commande
CL/FAC | Adresse de facturation | Entête de commande
CL/LIV | Adresse de livraison | Entête de commande
CL/SOC | Client société | Entête de commande
EF | Commande d'achat | Entête de commande
LF | Ligne de commande d'achat | Ligne de commande
MP | Code article | Ligne de commande


voluedit_dem_achat Edition des demandes d'achat

Option payante EVE 16 (autorise l'utilisation de l'édition VoluEdit de demande d'achat)

Pas d'équivalent en édition standard

Voir le programme de gestion des demandes d'achat.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de demande d'achat - code fournisseur

Exemples :

-N[dae_num]

-N[dae_num|-|cl_code]

Options

Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Oxm | Envoi automatique des fax/email

Notes

_SUP_REQ_DEM_ACHAT | 21, 60 Supplément de requête sur dem_achat_fou et dem_achat_lig

Codes sources des clés Notes

Code | Libellé
DAE | Entêtes des demandes d'achat
DAL | Lignes des commandes d'achat
DA/ENT | Entête. Variable globale correspondante : gl_ve_cle_dae_num
DA/LIG | Entête. Variable globale correspondante : gl_ve_cle_dal_num Ligne. Variable globale correspondante : gl_ve_cle_dal_lig
DA/FOU | Code fournisseur. Variable globale correspondante : gl_ve_cle_dem_achat_fou


voluedit_devis_ondu Edition du devis onduleur

Aucun rapport avec le paramétrage du programme d'édition standard.

Aucune option particulière pour l'édition via VoluEdit.

Valeur numérique 1

Niveau maximum de nomenclature. Par défaut : 1. Si supérieur à 9, plafonné à 9.

Options triées

Dyyy

Numéro d'envoi de destinataire (où yyy représente le numéro d'envoi de destinataire)

Nxxx

Numéro de devis - offre (où xxx représente le couple numéro de devis – numéro d'offre)

Oaz

Non édition des lignes de coûts d'action de service à 0 (zéro)

Ocd

Calcul des déchets basé sur les TSC

Ocl

Edition de la liste des devis par client

Tous les devis d'un même client seront regroupés sur la même page.

Nécessite l'option Oli pour l'édition par liste.

Odp

Edition d'offre de prix pour devis papeterie

Oec

Sélection du critère de sélection complet

Off

Edition des offres de vente 99 uniquement (devis en fabrication)

Ofv

Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût

Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.

Old

Saisie par numéro de devis/numéro d'offre de vente

Oli

Mode édition listing

Ops

Edition du premier sous-devis uniquement pour un devis

Ora

Edition de la liste des devis par adresse

Tous les devis livrés à la même adresse seront regroupés sur la même page.

Nécessite l'option Oli pour l'édition par liste

Ord

Rupture par numéro de devis

Osd

Edition de toutes les offres de vente d'un devis

Oti

Gestion des titres de groupe multilignes

Ovq

Edition d'un devis avec des variantes de quantités

Permet d'éditer un devis par rapport aux produits puis aux offres.

Les offres de ventes du devis à éditer doivent absolument être des variantes de quantités.

Ce mode d'édition nécessite l'utilisation du récapitulatif des coûts (indicateurs).

Si le devis contient plusieurs produits, alors un récapitulatif des coûts sera ajouté à la fin de l'édition.

Cette option n'est pas compatible avec les options Ocl, Odp, Off, Old, Oli, Ops, Ora, Osd, Oti, Oxm.

Attention : Utilisable seulement avec Genero Report Writer.

Oxm

Gestion du fax email automatique

Valeur alpha 2

Caractères 1 à 3 | Environnement pour les opérations (Ex : STD)
Caractères 4 à 6 | Environnement pour les matières (Ex : STD)

Notes triées

_FOR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

_ORDER_BY_DEVIS

21,60 Complément de tri sur la table des offres de vente (kp_offre)

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Le paramétrage de configuration est prioritaire à celui du paramètre de lancement.

_SUP_REQ_COLLE

21,60 Complément de sélection pour la recherche de l'article colle

(Ex : and mp_code matches "ZBQ*")

_SUP_REQ_DEVIS

21,60 Complément de sélection sur la table des offres de vente (kp_offre)

_SUP_REQ_KP_SEQACT

21,60 Complément de requête sur la table kp_seqact

_SUP_REQ_NOTES_TRI

21,60 Complément de sélection pour la recherche des notes sur le triplet de la gamme sans prendre en compte les phases

Exemple

On ne recherche que les notes de type LAB :

_SUP_REQ_NOTES_TRI and nn_type_note = "LAB"

_SUP_REQ_PAPIERS

21,60 Complément de sélection pour la recherche des articles papiers (Ex : and mp_code matches "XA*")

_SUP_REQ_S_CO

21,60 Supplément de requête sur la table kp_s_co

Doit commencer par " and …"

_TIT_INDIC*

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

TITRE_GRP_MULTI_LIG

21,50 Code du groupe multi-lignes pour lequel le titre doit être géré.

Edition d'une ligne avec valeurs à nul, pas de gestion de titre par défaut.

Les codes sont dans l'ordre alphabétique.

ACCESSOIRE

ACTION_SERVICE

CARACTERISTIQUE_ACTION_SERVICE

COMPOSANT

COUT_ACTION_SERVICE_OFFRE

COUT_PRODUIT_OFFRE

COUT_PRODUIT_PRODUIT

DEVIS

EFFECTIF_FABRICATION

EFFECTIF_HORS_FABRICATION

ENCRE

ETAT_DEVIS

FRAIS_ETABLISSEMENT

OFFRE

OPERATION_FABRICATION

OPERATION_HORS_FABRICATION

PAPIER

PRODUIT

RECAPITULATIF_COUTS_F_V pour les frais variables

RECAPITULATIF_COUTS_F_F pour les frais fixes

RECAPITULATIF_COUTS_F_A pour les frais autres

RECAPITULATIF_COUTS_IND pour les indicateurs

RECAPITULATIF_DEVISE

RECAPITULATIF_MARGE_OFFRE

RECAPITULATIF_MARGE_PRODUIT

REMISE_PRIX (pour la table kp_recap_tot)

VERNIS

51 Niveau de nomenclature du produit (de 1 à 9), uniquement compatible avec les groupes multilignes suivants : PRODUIT – ACCESSOIRE – ENCRE – PAPIER – VERNIS

Exemple pour la nomenclature multi-niveaux suivante :

Ensemble E1

Produit PF1

Produit PF2

Produit multi-niveau PF21

Produit multi-niveau PF211

Produit multi-niveau PF22

Les deux produits multi-niveaux PF21 ont un niveau de nomenclature de 1, et le produit multi-niveaux PF211 a un niveau de 2.

_VAR_INDIC_

Cette note sera recherchée en priorité sur le paramètre de configuration indiqué par la note PARAM_INDICATEURS.

Voir le paramètre #CF REC pour plus d'info.

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
CL | Code client |
CL/LIV | Adresse de livraison |
L1 | Notes saisies sur l'entête du devis | notes uniquement, pas TSC
MP | Code article principal |
MP/ACC | Code article de l'accessoire |
MP/ARC | Code article de l'architecture (conception) |
MP/COI | Code article de la coiffe |
MP/COL | Code article de la colle |
MP/COM | Code article de la composition |
MP/DCH | Code article du déchet |
MP/ENC | Code article de l'encre |
MP/ENS | Code article de l'ensemble |
MP/IMP | Code article de l'impression |
MP/PAL | Code article de la palette |
MP/PAP | Code article du papier |
MP/PRE | Code article de la pré-impression |
MP/QUA | Code article de la qualité |
MP/VER | Code article du vernis |
T/[OFB] | Triplet des opérations de fabrication Exemple TSC_T/OFB_910_MAT |
T/[OFH] | Triplet des opérations hors fabrication (Actions de service) Exemple TSC_T/OFH_910_MAT |


edi_etiqprod Edition des étiquettes de production

Paramétrage relatif au codes SSCC et codes EAN128 : voir les notes spécifiques et explications dans le programme d'édition des étiquettes de colisage de commande.

Alimentation de la table canal_comm et édition des étiquettes de production à partir de la table canal_comm avec un programme Windows

3 phases :

1 - Alimentation de la table canal_comm

Les options Orc et -H doivent être activées.

A2[1] du paramètre de lancement doit être à 1.

Le mode autonome (note MODE_AUTONOME_ETI) ne doit pas être activé.

2 - Edition des étiquettes à partir de la table canal_comm avec un programme Windows

L'option Opw doit être activée.

L'option Oup peut être activée.

Le mode autonome (note MODE_AUTONOME_ETI) doit être activé.

Les noms des fichiers d'anomalie et de trace doivent être renseignés (voir les notes).

Le répertoire et le nom du programme Windows à lancer doivent être renseignés (voir les notes).

3 - Arrêt du démon si pas d'option -Oup

L'option Oar doit être activée.

Le mode autonome (note MODE_AUTONOME_ETI) doit être activé.

Les noms des fichiers d'anomalie et de trace doivent être renseignés (voir les notes).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 à 10 : cde ou cde-lig

cde = Numéro de commande (8 caractères)

lig = Ligne de commande (3 caractères)

Valeurs numériques

N1 | Délai d'attente en secondes entre chaque réveil de ce programme en mode autonome (0 seconde par défaut)
N2 | non utilisée

Options

-H | Edition des étiquettes de production par code à barres Par défaut, un écran de sélection est affiché.
O22 | Gestion du code à barres sur 22 caractères (Intégration de la séquence) L'option -H doit être activée. Par défaut, le code à barres est sur 19 caractères.
Oar | En mode autonome, arrêt du démon
Oca | Critère de sélection sur la commande et la ligne de commande d'achat On utilise la zone affectation des lignes de commande d'achat sélectionnées. La zone affectation contient le numéro et la ligne de la commande commerciale.
Odc | Demande de confirmation pour édition des étiquettes avant le BL Première question : "Voulez-vous éditer les étiquettes avant le bon de livraison ?" Si oui : édition de la sélection faite par l'utilisateur Si non : deuxième question : "Le chargement a-t-il été effectué ?" Si oui : saisie du numéro de BL et édition des étiquettes correspondant à ce BL Si non : édition de la sélection faite par l'utilisateur
Oea | Etiquette d'achat
oIC | Affiche le package du client affecté à la commande d'achat Nécessite l'option Oea
One | Active l'option de forçage à respecter le nombre d'exemplaires d'étiquettes indiqué sur le TSC 250 du PF
Opf | Permet de rajouter un flag palette filmée pour l'envoi du programme etiquette.exe
Opw | Edition des étiquettes de production avec un programme Windows L'option-H doit être activée. L'option Ove ne doit pas être activée.
Orc | Alimentation de la table canal_comm L'option Ove ne doit pas être activée.
Oli | Activation du mode liste
Oti | Gestion titre multiligne (inutile pour le moment)
Oup | En mode autonome, un seul passage
Ove | Activation de l'édition par VoluEdit

Valeur alpha 2

Caractère 1

Mode d'alimentation de la table canal_comm (ARG_ED_ETIQPROD) obligatoire si Orc

1 CAB sur 19 caractères, 4 blancs et modèle de l'étiquette

ou CAB sur 22 caractères si O22, 1 blanc et modèle de l'étiquette

Ordre de recherche du modèle d'étiquette :

1 - Recherche du modèle d'étiquette sur le TSC _ET (info_c-ic_char3_1) de la ligne de commande.

2 - Si modèle d'étiquette non trouvé, recherche du modèle d'étiquette sur le TSC 250 (info_c-ic_char3_1) de l'article de la ligne de commande.

3 - Si modèle d'étiquette non trouvé, modèle d'étiquette de l'adresse de livraison ou de l'adresse principale du client (cli6-c6_modele_etiq).

4 - Si modèle d'étiquette non trouvé, modèle d'étiquette initialisé à ETS.

Caractère 2

Autorisation de suppression des étiquettes de production (O/N, N par défaut)

Dans la grille des étiquettes, il est possible de supprimer les étiquettes définitivement de la table etiqprod.

La suppression d'une étiquette se fera via la touche F2.

Elle ne sera plus visible à l'affichage.

Elle sera supprimée définitivement à la validation et après confirmation de cette action.

Notes

ETIQPROD_IMP

21,23 Code de l'imprimante. Exemple : ETP

24 Edition automatique (O ou N : demande (par défaut))

FIC_ANOMALIE_ETI

21,60 Nom du fichier d'anomalie

Obligatoire en mode autonome (note MODE_AUTONOME_ETI)

Exemple :Anomalie_etiquette

FIC_TRACE_ETI

21,60 Nom du fichier de trace

Obligatoire en mode autonome

Exemple :trace_etiquette

_ID_DEMON_ETI

21,22 Identifiant du démon de la tâche de fond

MODE_AUTONOME_ETI

21 Edition des étiquettes de production en mode autonome (démon) (O/N)

Les étiquettes de production à éditer en mode autonome sont recherchées dans la table canal_comm.

L'option Orc ne doit pas être activée.

NOM_PROG_WINDOWS_ETI

21,60 Nom du programme Windows à lancer

Obligatoire si option Opw

Exemple :WINWORD.EXE

REP_PROG_WINDOWS_ETI

21,60 Répertoire du programme Windows à lancer

Le répertoire peut être paramétré sur plusieurs lignes.

Chaque ligne doit commencer en caractère 21.

Exemple

C:/Program Files Microsoft Office

/Office

_SUP_ORDER_BY_ETP

21,60 Critère de tri paramétrable sur la table etiqprod

_SUP_REQ_ETIQPROD

21,60 Complément de sélection sur etiqprod et / ou cde2

TSC_EDIT_ETIQ_CLI

Choisir par client la possibilité d'éditer ou non les étiquettes

21,23 Code du TSC sur le client qui indique si on édite les étiquettes (la zone utilisée est ic_char3_1 en O/N)

L'absence du TSC, ou toute autre valeur que N dans la zone ic_char3_1, impliquent l'édition des étiquettes.

24 Respect de la hiérarchie client/adr puis client pour la recherche du TSC (O/N, O par défaut)

Cette note est utilisable dans le paramètre de lancement de tout programme permettant l’édition des étiquettes.

TSC_EDITION_PF

21,23 Code TSC d'édition du code PF

Exemple du TSC PF :

ZCCode edit. PF :N Z<<<< Code edit. PF

#CCode edit. PF

Paramétrage nécessaire pour les éditions automatiques dans qte_prod et oexp

#LP ETP Imprimante pour les étiquettes palettes

alpha1[1,20] | Nom du modèle VoluEdit, sans extension
alpha1[21,25] | VEDIT

Codes sources des clés TSC et NOTES

Code | Libellé
CL | Code client
EC | Entête de commande client
LC | Ligne de commande client
EF | Entête de commande fournisseur
LF | Ligne de commande fournisseur
MP | Code article principal
MP/PAL | Code article de la palette
NC | Séquence nomenclature de commande


voluedit_facn Edition des factures

Voir aussi le paramétrage du programme d'édition standard.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-Nf

Caractères 4 et suivants : Toutes les commandes à facturer

Ne pas utiliser pour le paramétrage d'une visu, ce paramétrage est mis en place dans le cadre de l'action ACT020 (voir #RP).

Options propres à l'édition VoluEdit

Oar | Arrêt - Voir l'édition des factures par canal_comm
Oba | Gestion des barèmes L'option payante CDE-8 (Saisie des barèmes) doit être activée. L'option société 39 (Gestion des prix au mille +) doit être positionnée. Les options Opm et Omg sont interdites (ces options sont dans le programme standard facn)
Oce | Facturation de cession Option Oei interdite.
Ocp | Autorise l'affichage de la contre-valeur en Euros
ODA | Pas de facturation des lignes de commande d'ensembles appairés si un des bons de livraison édités en définitif à une date de chargement supérieure à la date de facturation. Voir aussi l'option Oda dans le programme d'édition standard.
ODB | Non facturation des bons de livraison dont la date de chargement est supérieure à la date de facturation Voir aussi l'option Odb dans le programme d'édition standard.
Ofl | Permet de facturer le dernier jour du mois toutes les livraisons non facturées sans prendre en compte la périodicité (PER) et la gestion de la facturation partielle du client.
Og6 | Ne ramener qu'un enregistrement numéro de BL par fac6 On n'aura donc aucune information sur la ligne (poids, …), uniquement le numéro de BL et la date de livraison
Ogc | Gestion canal_comm Permet d'ajouter un enregistrement dans canal_comm sans faire d'édition VoluEdit. Voir l'édition des factures par canal_comm
One | Stockage du numéro d'autorisation et du montant HT facturé de l'exonération de TVA La racine du TSC de stockage des numéros d'autorisation et des montants déduits de la suspension de TVA des factures doit être paramétrée (facn A2[16,17]).
Orf | Facture corrective au taux de change de la facture de rattachement
Orn | Si regroupement sur la référence de contrat de l'entête de commande (Regroupement cdes/BL de l'onglet Facturation de la fiche client à réf contrat entête cde), on ne regroupe pas les commandes dont la référence de contrat n'a pas été saisie
Orr | Regroupement des lignes de facture de la même référence (article) ayant les mêmes prix unitaire et unité de vente Cette option n'est plus limitée à VoluEdit, elle est maintenant disponible dans facn.
Ot3 | Tri des taux de TVA dans l'ordre croissant du pied de facture
Otm | Gestion des titres des groupes multilignes Attention : c'est bien l'option Otm, et non pas Oti contrairement aux programmes d'édition VoluEdit. C'est la seule exception. Pensez aux caractères 1 à N de la valeur alpha 4.
Otx | Edition des notes de type TEXTILE de la table blv3
Oup | Un seul passage - Voir l'édition des factures par canal_comm
Ove | OBLIGATOIRE Activation de l'édition par VoluEdit

Valeur alpha 4

Caractère 1 | Activation titre groupe Ligne de facture (O/N, N par défaut)
Caractère 2 | Activation titre groupe Détail de BL facturé (O/N, N par défaut)
Caractère 3 | Activation titre groupe Ligne colisage (O/N, N par défaut)
Caractère 4 | Activation titre Groupe ligne picking (O/N, N par défaut)
Caractère 5 | Activation du titre du groupe TEXTILE (O/N, N par défaut)
Caractère 6 | Activation du titre du groupe Ligne référence (O/N, N par défaut)
Caractère 7 | Activation du titre du groupe Ligne facture du groupe Ligne référence (O/N, N par défaut)
Caractère 8 | Activation du titre du groupe Client Livré (O/N, N par défaut)
Caractère 9 | Activation du titre du groupe Détail nomenclature facturée (O/N, N par défaut)
Caractère 10 | Activation du titre du groupe Détail de prix (O/N, N par défaut)
Caractère 11 | Activation du titre du groupe Libellé du détail de prix (O/N, N par défaut)
Caractère 12 | Activation du titre du groupe Schéma de calcul du détail de prix (O/N, N par défaut)
Caractère 13 | Activation du titre du groupe Descriptif du schéma de calcul du détail de prix (O/N, N par défaut)

Notes

FIC_LOCK_EXECUTION

21,60 Chemin + Nom du fichier de lock - Voir l'édition des factures par canal_comm

FIC_TRACE

21,60 Chemin + Nom du fichier de trace - Voir l'édition des factures par canal_comm

FORCAGE_DATE_ECH_CON

21 Forçage des dates d'échéance en mode consultation (O/N, N par défaut)

MODE_AUTONOME

21 Mode autonome (O/N) - Voir l'édition des factures par canal_comm

NOTE_TEXTILE

21,23 Type de note du TEXTILE de la table blv3. Obligatoire. Exemple : TEX

PARAM_ED_FAC_AUTO

21,26 Type et code du paramètre de lancement de l'édition VoluEdit de facture - Voir l'édition des factures par canal_comm

SAISIR_EDITER_NOTES

21,23 Type de notes

Cette note permet de saisir des notes du type paramétré pour chaque facture éditée ou rééditée manuellement.

En présence de cette note, une fenêtre de saisie de notes de ce type s'ouvre alors automatiquement pour chaque facture éditée ou rééditée manuellement par ce programme.

NB. : Ne pas oublier de paramétrer la note VE_VAR correspondante pour pouvoir l'éditer.

_SUP_CORRECTION_BL

21,60 Complément de sélection sur les lignes de BL indiquées facturées que l'on souhaite vérifier dans les tables de la facturation.

Exemple

_SUP_CORRECTION_BL and b2_blv matches "09*"

Limite la vérification des lignes de BL notées facturées aux BL de 2009.

_SUP_REQ_EPU_PFAC0

21,60 Complément de sélection sur la table p_fac0

L'option Oei doit être positionnée.

Codes sources des clés TSC et Notes

Code

Libellé

Disponibilité

B1

Entête de BL

Ligne de facture

B2

Ligne de BL

Ligne de facture

CL

Code client

Entête de facture

CL/FAC

Adresse de facturation

Entête de facture

CL/LIV

Adresse de livraison

Entête de facture

CL/SOC

Note sur #SOC

Entête

EC

Entête de commande

Ligne de facture

FA

Entête de facture

Il faut passer par la visualisation des factures pour saisir ces notes.

LC

Ligne de commande

Ligne de facture

LC/LI

Notes sur cadencements de livraison

LI/CLF

Notes saisies sur l'adresse de facturation de la ligne de cadencement de livraison

LI/CLL

Notes saisies sur l'adresse de livraison de la ligne de cadencement de livraison

MP

Code article de la ligne de commande

Ligne de facture

MP/ARC

Code article de la l'architecture du PF livré

Pour info : le MP/ARC vise l'architecture du MP/NOM qui peut être le code produit de ligne de commande si on livre directement celui-ci.

MP/AR2

Permet de paramétrer une ligne de note pour obtenir les informations d'un TSC de type MP/ARC déjà paramétré pour un autre groupe VoluEdit

(TSC uniquement)

Exemples:

VE_VAR Laize Produit*TSC_MP/ARC_070_N1*0.00*

VE_VAR Laize Produit*TSC_MP/AR2_070_N1*0.00*

On obtient la même information mais dans deux groupes distincts.

Le premier groupe alimente la variable gl_ve_article_arc avec la clé tandis que le deuxième alimente la nouvelle variable gl_ve_article_ar2.

Ainsi, l'unicité du nom de variable VoluEdit est respectée.

En effet, le nom de la variable correspond à TSC_MP/ARC_070_N1pour la 1ere ligne et TSC_MP/AR2_070_N1 pour la seconde.

MP/COM

Code article de la composition

MP/DEC

Code article de la découpe

MP/ENS

Code article de l'ensemble

MP/IMP

Code article de l'impression

MP/NOM

Code article du PF livré (nomenclature de commande)

MP/PAL

Code article de la palette

MP/PRE

Code article de la pré-impression

MP/QUA

Code article de la qualité

MP/REF

Code article de la ligne de référence (option Orr nécessaire)

Exemples :

VE_VAR Type palette*TSC_MP/REF_220_C1*3*

VE_VAR Mode de gestion*TSC_MP/REF_220_C30*3*

VE_VAR Schéma de palet.*TSC_MP/REF_220_C2*3*

Ligne de référence de facture

NC/LI

Cadencement de livraison au niveau de la ligne de nomenclature de commande (cde4)

Paramètre optionnel

MDO, alpha1[13,20] : Nom du modèle de document pour VoluEdit

Champs détail du TEXTILE ajoutés au catalogue

Matière première | mp_textile | Car. 05-19 de blv3.kb_com
Désignation matière première | des_mp_textile |
Quantité matière première | qte_mp_textile | Car. 01-04 de blv3.kb_com
Tous les champs de la fiche matière première | kbmp_XXX | Table mat


voluedit_conteneur Edition des fiches conteneurs

Pas d'équivalent en édition standard

Options

Oar | Arrêt de la tâche de fond lanceur d'édition
Oti | Active la gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Oun | Mode autonome sur un seul passage
Ove | OBLIGATOIRE Activation de l'édition par VoluEdit

Valeur alpha 2

Caractères 1 à 4

Délai d'attente (en minute) entre 2 scrutations de la tâche de fond.

Valeur alpha 4

Caractère 1 | Activation titre Groupe produits (O/N, N par défaut)
Caractère 2 | Activation titre Groupe lot des produites (O/N, N par défaut)

Notes

FIC_ANOMALIE | 21 à 60 Nom du fichier des erreurs
FIC_TRACE | 21 à 60 Nom du fichier des traces
MODE_AUTONOME | 21 à 23 Mode autonome OUI ou NON
_SUP_REQ_CNP | 21 à 60 Supplément de requête à la table conteneur_produit
_SUP_ORDER_CNP | 21 à 60 Supplément d'order by à la requête sur la table conteneur_produit


voluedit_fiche_pal Edition des fiches palettes

Pas d'équivalent en édition standard

Type et code du paramètre

#VEPAA Lancement de la tâche de fond des fiches palettes

#VEPAB Arrêt de la tâche de fond des fiches palettes

Options triées

Oar | Arrêt de la tâche de fond lanceur d'édition
Oc2 | Le client est initialisé dans la table pal_expedition_2 et non dans la table pal_expedition_1.
Oti | Active la gestion des titres multilignes
Oun | Mode autonome sur un seul passage
Ove | OBLIGATOIRE Activation de l' édition par VoluEdit

Valeur alpha 2

Caractères 1 à 4

Délai d'attente (en minutes) entre 2 scrutations de la tâche de fond

Valeur alpha 4

Caractère 1 | Activation titre Groupe ligne de palette (O/N, N par défaut)
Caractère 2 | Activation titre Groupe ligne de picking (O/N, N par défaut)

Notes triées

FIC_ANOMALIE | 21,60 Nom du fichier des erreurs
FIC_TRACE | 21,60 Nom du fichier des traces
ID_DEMON | 21,22 Identifiant de la tâche de fond (exemple : 01) Doit être paramétré sur PRP, alpha1[4,5]
MODE_AUTONOME | 21,23 Mode autonome : OUI ou NON
_SUP_ORDER_PE1 | 21,60 Complément de tri à la requête sur la table pal_expedition_1
_SUP_ORDER_PE2 | 21,60 Complément de tri à la requête sur la table pal_expedition_2
_SUP_ORDER_PE3 | 21,60 Supplément de tri à la requête sur la table pal_expedition_3
_SUP_REQ_PE1 | 21,60 Complément de sélection sur la table pal_expedition_1
_SUP_REQ_PE2 | 21,60 Complément de sélection sur la table pal_expedition_2
_SUP_REQ_PE3 | 21,60 Complément de sélection sur la table pal_expedition_3

Codes sources des clés TSC et Notes

MP/PAL

Code article de la palette

Paramètre optionnel

MDO, alpha1[13,20] : Nom du modèle de document pour VoluEdit

Champs détail du TEXTILE ajoutés au catalogue

Matière première | mp_textile | Car. 05-19 de blv3.kb_com
Désignation matière première | des_mp_textile |
Quantité matière première | qte_mp_textile | Car. 01-04 de blv3.kb_com
Tous les champs de la fiche matière première | kbmp_XXX | Table mat

Paramètre nécessaire

PRP A1[4,5] : Identifiant de la tâche de fond pour l'édition de la fiche palette lors de la saisie des préparations de commande par lecteur CAB.


voluedit_fiche_produit Edition des fiches produits

Pas d'équivalent en édition standard

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code produit

Exemple : -N[lc_prod]

Options

Oen | Edition nomenclature Avec cette option, on peut éditer automatiquement les composants à partir du code composé.
Oli | Activation du mode liste
Onr | Des notes groupées ont été créées pour les références d'impression, de découpe et de palettisation (Ces références étant issues de la lecture d'un TSC sur la fiche produit). Cette option permet de bien différencier ces notes dans des blocs qui leur sont propres. Effectivement, on pouvait déjà afficher des notes groupées sur la référence d'impression par exemple, mais ces notes étaient "noyées" dans toutes les autres notes de l'article.
Oti | Active la gestion des titres multilignes

Valeur alpha 2

Caractère 1

Visualisation d'un état de l'édition des articles

0 Tous les articles (par défaut)

1 Uniquement les articles édités

2 Uniquement les articles en anomalie

3 Aucun article

Valeur alpha 4

Caractère 1 | Activation titre groupe Produit (O/N, N par défaut)
Caractère 2 | Activation titre groupe Nomenclature ligne (O/N, N par défaut)
Caractère 3 | Activation titre groupe Fournisseurs de l'article (O/N, N par défaut)
Caractère 4 | Activation titre Groupe Statistiques de l'article (O/N, N par défaut)
Caractère 5 | Gestion titre groupe multilignes tarifs (O/N) N par défaut (+ option –Oti)
Caractère 6 | Gestion titre groupe multilignes dernières factures (O/N) N par défaut (+ option –Oti)
Caractère 7 | Gestion des titres multilignes libellés étrangers (O/N, N par défaut) - Option Oti obligatoire
Caractère 8 | Gestion des titres multilignes tarifs libellés étrangers (O/N, N par défaut) - Option Oti obligatoire
Caractère 9 | Gestion du titre du groupe multilignes Machines (spécifique)

Notes

NB_DERN_FACTURES | Nombre maximum de factures à visualiser
_ORDER_BY_LIB_ETR | 21, 60 Ordre de tri sur lib_etr (ex : le_client, le_prod)
_ORDER_BY_TAR0_LIB | 21, 60 Ordre de tri sur la table tar0
_SUP_ORDER_BY_MAT | 21, 60 Complément de tri sur la table mat
_SUP_REQ_LIB_ETR | 21, 60 Complément de select sur la table lib_etr
_SUP_REQ_TAR0_LIB | 21, 60 Complément de sélection sur la table tar0
_SUP_REQ_MAT | 21, 60 Complément de requête sur la table mat
_SUP_REQ_GSTD | 21, 60 Complément de requête sur g_std_d pour le parcours des machines Exemple _SUP_REQ_GSTD and gd_sop = ‘PAS'
_SUP_REQ_NOM0 | 21,60 Complément de sélection sur la table nom0

Codes sources des clés TSC et NOTES

Code | Libellé
CAS02 | Notes avec cascade - Triplet article/gamme/phase - Article - Ensemble
CL | Code client
MP | Code article principal
MP/ARC | Code article de l'architecture
MP/COM | Code article de la composition
MP/DEC | Code article de la découpe
MP/IMP | Code article de l'impression
MP/PAL | Code article de la palette
MP/QUA | Code article de la qualité

Notes sur le paramètre #CF CAR

CLIENTNOMENCLATURE | Code client pour recherche des articles liés
SUPREQREFARC | Supplément de requête pour la sélection des codes articles architectures
SUPREQREFIMP | Supplément de requête pour la sélection des codes articles impression
SUPREQPAL | Supplément de requête pour la sélection des codes articles palette
SUPREQQUACAR | Supplément de requête pour la sélection des codes articles qualité carton
SUPREQCOMCAR | Supplément de requête pour la sélection des codes articles composition carton


voluedit_fiche_tiers Edition des fiches tiers

Permettre de passer à l'édition VoluEdit de la fiche tiers les arguments suivants :

• Code adresse secondaire (cli2.c2_adr)

• Numéro identifiant (ID) du correspondant (corres.co_id_contact_vsw)

Exemple de paramétrage d'édition directe VoluEdit de la fiche tiers depuis la saisie de la fiche client via le lancement des programmes paramétrable (Control-J)

On considère ici que le Control-J est activé depuis la ligne de saisie d'un correspondant, sur l'adresse principale ou secondaire.

Remarques :

• Si le code adresse secondaire est passé en paramètre, l'édition des correspondants sera limitée à cette seule adresse (corres.co_code_adresse).

• Si plusieurs arguments doivent être passés à l'édition via le lancement de programmes paramétrable (Control-J), ceux devront être correctement séparés.

Note | Caractères 21 à 60 | Explication
LCT_PROG_PARAM_001 | #VECLI-N_COR[co_id_contact_vsw] | Lancement du programme d'édition VoluEdit de la fiche tiers, de paramètre #VE CLI, avec comme premier argument le numéro identifiant (ID) du correspondant.
LCT_PROG_PARAM_001 | -N[co_code] | Passage du code tiers comme deuxième argument. ATTENTION : Le caractère 27 doit être à blanc, afin de bien séparer les deux arguments –N_COR et –N
LCT_PROG_PARAM_001 | -N_ADR[co_code_adresse] | Passage du code adresse secondaire comme troisième argument. ATTENTION : Le caractère 27 doit être à blanc, afin de bien séparer les deux arguments –N et –N_ADR
LCT_PROG_TITRE_001 | Edition de l'étiquette DYMO | Titre à afficher dans la fenêtre du Control-J (ou sur le bouton d'action)
LCT_PROG_IMAGE_001 | g_edit | Chemin/Nom de l'image à afficher dans la fenêtre du Control-J (ou sur le bouton d'action)

voluedit_fiche_tiers Edition des fiches tiers

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : Code client ou Code fournisseur ou Code prospect Exemples : -N[co_code] -N[ec_cli] -N[s0_fou]
-N_ADR | Caractères 3 et suivants : code adresse secondaire Exemple : -N_ADR[co_code_adresse]
-N_COR | Caractères 3 et suivants : ID du contact (correspondant) Exemple : -N_COR[co_id_contact_vsw]
-N_DVE | Caractères 3 et suivants : modèle VoluEdit Exemple : -N_DVE[fiche_tiers.dve]
-N_MLG | Caractères 3 et suivants : clé du mailing Exemple : -N_MLG[CLE_DOCUMENT_MLG]

Cliquez ici pour afficher / masquer une fenêtre d'exemples de passage d'arguments

Options triées

-Ocl | Edition des clients
-Ocp | Ecran de sélection supplémentaire sur la table prospect
-Oea | Ecran de sélection sur prospect / action / visite
-Ofo | Edition des fournisseurs
-Oli | Mode d'édition Liste des tiers (catalogue différent de celui de la fiche tiers)
-Opr | Edition des prospects
-Oti | Activation de la gestion des titres sur les groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.

Les options –Ocl, –Ofo et –Opr sont cumulables. N'en positionner aucune revient à positionner les 3.

Valeur alpha 4

Caractère 1 | Activation titre groupe Correspondants (O/N, N par défaut)
Caractère 2 | Activation titre groupe Articles (O/N, N par défaut)
Caractère 3 | Activation titre groupe Articles étrangers (O/N, N par défaut)
Caractère 4 | Activation titre groupe Encours (O/N, N par défaut)
Caractère 5 | Activation titre groupe Suspension de TVA (O/N, N par défaut)
Caractère 6 | Activation titre groupe Adresses secondaires (O/N, N par défaut)
Caractère 7 | Activation titre groupe Tarifs (O/N, N par défaut)
Caractère 8 | Activation titre groupe Statistiques du tiers (O/N, N par défaut)
Caractère 9 | Activation titre groupe Crédit client (O/N, N par défaut)

Notes triées

Suppléments de tri : écrire les colonnes séparées par des virgules.

Les suppléments de requête doivent commencer par and.

_ORDER_BY_ACTION | 21, 60 Supplément de tri sur les actions
_ORDER_BY_CLIENT | 21, 60 Supplément de tri des clients (tables cli et prospect)
_ORDER_BY_CORRES_1 | 21, 60 Supplément de tri pour le correspondant principal (1er choix)
_ORDER_BY_CORRES_2 | 21, 60 Supplément de tri pour le correspondant principal (2ème choix)
_ORDER_BY_LIS_CORRES | 21, 60 Supplément de tri pour la liste des correspondants
_ORDER_BY_RISQ_CLI | 21, 60 Supplément de tri pour la table historisation assurance crédit (cli5)
_ORDER_BY_STAT_CLI | 21, 60 Supplément de tri pour la table des statistiques tiers (cli4)
_ORDER_BY_TARIF | 21, 60 Supplément de tri pour la table des tarifs (tar0)
_SUP_REQ_ACTION | 21, 60 Supplément de requête pour la sélection sur la table action.
_SUP_REQ_ADR_SEC | 21, 60 Supplément de requête à la table des adresses secondaires (cli2)
_SUP_REQ_ARTICLE | 21, 60 Supplément de requête pour la sélection sur la table mat (articles habituellement commandés)
_SUP_REQ_CLIENT | 21, 60 Supplément de requête pour la sélection des clients.
_SUP_REQ_CORRES_1 | 21, 60 Supplément de requête pour la sélection du correspondant principal (1er choix)
_SUP_REQ_CORRES_2 | 21, 60 Supplément de requête pour la sélection du correspondant principal
_SUP_REQ_LIB_ETR | 21, 60 Complément de sélection sur la table lib_etr
_SUP_REQ_LIS_CORRES | 21, 60 Supplément de requête pour la sélection de la liste des correspondants.
_SUP_REQ_PROSPECT | 21, 60 Supplément de requête pour la sélection sur la table prospect.
_SUP_REQ_RISQ_CLI | 21, 60 Supplément de requête à la table historisation assurance crédit (cli5)
_SUP_REQ_TARIF | 21, 60 Supplément de requête à la table des tarifs (cli4)
_SUP_REQ_VISITE | 21, 60 Supplément de requête pour la sélection sur la table visite.

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
AC | Action sur prospect | Action
CL | Code client |
CL/SEC | Adresse secondaire du tiers |


voluedit_fle_cli Edition des offres de prix

Aucun rapport avec le programme d'édition standard.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de devis-numéro de sous-devis

Exemples :

-N[l2_devis]

-N[l2_devis|l2_sdevis+&&&]

Options triées

-N | Edition du devis via lancement de programme (Control-J) (Voir #RP) - N Numéro de devis Numéro de sous-devis Attention : Il n'y a pas de tiret entre le numéro de devis et le numéro de sous-devis. Exemples de paramétrage du #RP (action : édition) -N[l2_devis] -N[l2_devis|l2_sdevis+<<&]
Oar | Arrêt de la scrutation (quand pas de passage unique) Voir l'édition des devis par canal_comm
Obe | Désactive le rapport d'édition sans utiliser le mode batch -B
Ocl | Edition par client de la liste de devis. Ne fonctionne que si l'option Oli (édition en liste) est activée.
Odu | L'utilisateur ne peut sélectionner qu'un seul devis pour édition (nécessite -Old).
Oea | Edition triée par affaire
Oec | Edition client (par défaut) La date d'édition du devis est mise à jour (fle_2.l2_date_edi) La date d'édition de la remise de prix est mise à jour (fle_2.l2_date_rem) Voir les notes VE_DOC_DET, VE_DOC_DET, VE_DOC_DET dans TPR
Oed | Edition technique détaillée La date d'édition du devis n'est pas mise à jour (fle_2.l2_date_edi) La date d'édition de la remise de prix est mise à jour (fle_2.l2_date_rem) Voir les notes VE_DOC_DET, VE_DOC_DET, VE_DOC_DET dans TPR
Oef | Entités de façonnage séparées
Oeo | Edition des dossiers de fabrication Voir la note VE_DOC_DOS dans le TPR.
Oer | Permettre de lancer l'édition VoluEdit du devis feuille/carton avec un seul menu Edite/Réédite en lieu et place des deux boutons standard Edite et Réédite.
Oes | Edition technique simplifiée La date d'édition du devis n'est pas mise à jour (fle_2.l2_date_edi) La date d'édition de la remise de prix est mise à jour (fle_2.l2_date_rem) Voir les notes VE_DOC_DET, VE_DOC_DET, VE_DOC_DET dans TPR
Off | On édite seulement les sous-devis 99.
Ogc | Gestion canal_comm Permet d'ajouter un enregistrement dans canal_comm sans faire d'édition VoluEdit. Voir l'édition des devis par canal_comm
Ogr | Edite le groupe des références de l'entité avant le groupe entité
Old | L'utilisateur saisit un ou plusieurs devis dans une grille. Si l'option n'est pas positionnée, on propose à l'utilisateur un choix multicritères.
Oli | Mode d'édition en listing. Permet d'éditer les sous-devis en multilignes au niveau de l'entête. Sinon, on édite normalement en mode document, avec un saut de page à chaque nouveau sous-devis. Le catalogue listing est différent du catalogue document.
Ope | Pas d'édition des entités.
Opg | Pas d'édition des gammes.
Ops | On édite le premier sous-devis de chaque devis.
Ore | Active le regroupement des entités Si cette option est activée, la première référence de chaque travail différent sera éditée.
Orp | Rupture première entité (saut de page)
Ort | Permet d'éditer les lignes de transports par entité dans une liste
Osd | Tous les sous-devis du devis en cours sont édités. Cette option n'est prise en compte que si ce programme est appelé à partir du programme de saisie du devis.
Osr | Edition des devis en mode liste sans rupture (sur le client)
Osv | Applique la sélection saisie au groupe des variantes éditées But : permettre d'appliquer les critères de sélection saisis à l'édition des variantes afin de n'éditer que celles voulues.
Otd | Transport sur le devis. Forcer la recherche de celui-ci avec le numéro d'entité 99
Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Oup | Un seul passage Voir l'édition des devis par canal_comm
Ox1 | Regroupement des matières par entité Attention option Ore obligatoire
Ox2 | Regroupement de la sous-traitance par entité Attention option Ore obligatoire
Oxm | Envoi fax mail en automatique

Valeur alpha 2

Caractères 1 à 3 | Type de paramètre de la zone paramétrée du devis (l2_zpar1)
Caractères 4 à 6 | Code du paramètre de configuration du récapitulatif devis (#CF DER)
Caractère 7 | Détail des marges proposées (O/N, N par défaut) O Détail marges proposées pour 10, 20, 30, 40 et 50% de marge N Détail marges proposées pour 10, 30 et 50% de marge

Valeur alpha 4

Caractère 1 | Activation du titre pour le groupe devis (O/N, N par défaut)
Caractère 2 | Activation du titre pour le groupe entité (O/N, N par défaut)
Caractère 3 | Activation du titre pour le groupe variante (O/N, N par défaut)
Caractère 4 | Activation du titre pour le groupe option feuille (O/N, N par défaut)
Caractère 5 | Activation du titre pour le groupe gamme (O/N, N par défaut)
Caractère 6 | Activation du titre pour le groupe matière (O/N, N par défaut)
Caractère 7 | Activation du titre pour le groupe matière entité (O/N, N par défaut)
Caractère 8 | Activation du titre pour le groupe opération (O/N, N par défaut)
Caractère 9 | Activation du titre pour le groupe opération entité (O/N, N par défaut)
Caractère 10 | Activation du titre pour le groupe transport (O/N, N par défaut)
Caractère 11 | Activation du titre pour le groupe amalgame (O/N, N par défaut)
Caractère 12 | Activation du titre pour le groupe décomposition (O/N, N par défaut)
Caractère 13 | Activation du titre pour le groupe multi-bande (O/N, N par défaut)
Caractère 14 | Activation du titre pour le groupe sous-traitance (O/N, N par défaut)
Caractère 15 | Activation du titre pour le groupe sous-traitance entité (O/N, N par défaut)
Caractère 16 | Activation du titre pour le groupe marge (O/N, N par défaut)
Caractère 17 | Activation du titre pour le groupe variante feuille (O/N, N par défaut)
Caractère 18 | Activation du titre pour le groupe date_suivi (O/N, N par défaut)
Caractère 19 | Activation du titre pour le groupe marge devis (O/N, N par défaut)
Caractère 20 | Activation du titre pour le groupe Liste des références (O/N)
Caractère 21 | Activation du titre pour le groupe conditionnement
Caractère 22 | Activation du titre pour le groupe références de l'entité
Caractère 23 | Activation du titre pour le groupe Récapitulatif transport (O/N)
Caractère 24 | Activation du titre pour le groupe marges proposées (O/N, N par défaut)
Caractère 25 | Activation du titre pour le groupe multi-lignes Récapitulatif des coûts Frais (O/N, N par défaut)
Caractère 26 | Activation du titre pour le groupe multi-lignes Récapitulatif des coûts Indicateurs (O/N, N par défaut)
Caractère 27 | Activation du titre pour le groupe Totalisation gamme (O/N, N par défaut)
Caractère 28 | Activation du titre pour le groupe multi-lignes Nomenclature du devis (O/N, N par défaut)
Caractère 29 | Activation du titre pour le groupe multi-lignes Vernis hors-ligne entité (O/N, N par défaut) Voir les notes GROUPE_INDIV et _SUP_REQ_FLE_COMBI
Caractère 30 | Activation du titre pour le groupe multi-lignes Vernis sous-traitance entité (O/N, N par défaut)
Caractère 31 | Titre multi-lignes bloc papier
Caractère 32 | Titre multi-lignes bloc entité de façonnage
Caractère 33 | Titre multi-lignes bloc décomposition façonnage
Caractère 34 | Titre multi-lignes bloc conditionnement façonnage
Caractère 35 | Titre multi-lignes bloc roulage entité
Caractère 36 | Titre multi-lignes bloc transport façonnage
Caractère 37 | Titre multi-lignes bloc frais de premier établissement
Caractère 38 | Titre multi-ligne pour le bloc : Décomposition des prix d'une ligne de nomenclature (scénario) Plus d'info
Caractère 39 | Titre multi-ligne pour le bloc : Décomposition des prix d'une ligne de nomenclature (détail) Plus d'info
Caractère 40 | Titre multi-ligne pour le bloc : Décomposition des prix d'une ligne de référence multiple (scénario) Plus d'info
Caractère 41 | Titre multi-ligne pour le bloc : Décomposition des prix d'une ligne de référence multiple (détail) Plus d'info
Caractère 42 | Titre multi-ligne pour le bloc : Lignes multiples d'impression (O/N, N par défaut)

Notes

CODE_LCO_EDIT_ENT

21,23 Code LCO à lire pour récupérer la zone fc_a1

On peut éditer certaines entités selon un code LCO.

Sur ce code LCO (exemple EDE), on indique dans la zone fc_a1 si l'entité est à éditer oui ou non.

Par défaut, on édite l'entité.

CONFIG_DEG_DER_DEVIS

21,23 Code paramètre de configuration générale du devis multi-métiers (exemple DEG)

24,26 Code paramètre de configuration du récapitulatif du devis multi-métiers (exemple DER)

EDIT_AVEC_COPIE_CC

21 Edition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des devis par canal_comm

FIC_ANOMALIE

21,60 Nom du fichier d'anomalie

Voir l'édition des devis par canal_comm

FIC_LOCK_EXECUTION

21,60 Nom du fichier trace

Voir l'édition des devis par canal_comm

FIC_TRACE

21,60 Nom du fichier lock

Voir l'édition des devis par canal_comm

GROUPE_INDIV

21 à 60 Groupe indivisible dans cette édition.

Dans la mesure du possible, ce groupe sera imprimé sur une seule page, le saut de page éventuel se fera avant ce groupe, et non pas entre 2 lignes de ce groupe. Valeurs possibles :

AMALGAMME

CONDITIONNEMENT

DECOMPOSITION

DEVIS

ENTITE

GAMME

LIG_IMP : Lignes multiples d'impression (voir A4[42])

MARGE

MATIERE

MULTI_BANDE

OPERATION

SOUS_TRAITANCE

VARIANTE

VERNIS_HL

VERNIS_ST

MODE_AUTONOME

21 Mode autonome (O/N)

Voir l'édition des devis par canal_comm

MODE_RUPTURE_ENTITE

Mode de fonctionnement des ruptures

L'option Orp est obligatoire.

0 saut de page à chaque entité.

1 saut de page après la première entité (par défaut).

NTS_AVANT_EDITION

21,23 Type de notes à saisir avant l'édition d'une offre de prix

Permet, avant l'édition VoluEdit d'une offre de pri, d'ouvrir la saisie des notes d'un type paramétré.

Principe de fonctionnement :

• Avant l'édition de la première offre de prix : Ouverture de la saisie des notes du type paramétré (NTS) sur l'entête du sous-devis. Celles-ci deviennent ensuite les notes de références.

• Avant l'édition des offres de prix suivantes : Ouverture de la saisie des notes du type paramétré (NTS) sur l'entête du sous-devis. Si aucune note n'est saisie sur le sous-devis, on reprend les notes de références (celles de la première offre de prix éditée).

_ORDER_BY_DEVIS

21,60 Ordre de tri de la table des devis (table fle_2)

ORDRE_GROUPE

21,22 Code du groupe multi-lignes (de 01 à 03)

23,24 Numéro d'ordre du groupe multi-lignes (de 01 à 03).

Listes des groupes multi-lignes :

01 – Récapitulatif des transports du devis

02 – Frais de premier établissement

03 – Variante

Nota : Même fonctionnement que dans l'édition des réclamations.

Exemple de changement d'ordre

ORDRE_GROUPE 0301

ORDRE_GROUPE 0202

ORDRE_GROUPE 0103

Les données du groupe Variante s'afficheront en premier,

ensuite celles des Frais de premier établissement,

enfin le Récapitulatif des transports du devis.

PARAM_ED_DEV_AUTO

21,26 Type et code du paramètre de lancement de l'édition VoluEdit des devis

Voir l'édition des devis par canal_comm

PARAM_INDICATEURS

21,26 Type et code du paramètre de lancement du programme où se situe le paramétrage des indicateurs (paramétrage de lancement du devis multi-métiers, par exemple)

Remarque : Si aucun type et code de paramètre n'est paramétré, ou si celui-ci n'existe pas, on va rechercher le paramétrage des indicateurs sur le paramètre de lancement de l'édition.

Se reporter à l'aide en ligne de paramétrage des indicateurs du récapitulatif des coûts (devis multi-métiers)

REEDIT_AVEC_COPIE_CC

21 Réédition normale avec envoi d'une copie vers canal_comm (O/N)

Voir l'édition des devis par canal_comm

SUP_ORDER_VAR

21,60 Complément de tri pour les variantes du devis

Par défaut, le tri est le suivant : order by l2_sdevis

Exemple : order by l2_qte_lancee ASC

Nota : Cette note annule et remplace le tri par défaut et elle est cumulative.

_SUP_REQ_AMALGAMME

21,60 Complément de requête pour les amalgames (table fle_amalg)

_SUP_REQ_DEVIS

21,60 Supplément de requête pour la sélection des devis (table fle_2)

_SUP_REQ_DECPX_N_S

21,60 Complément de sélection sur la table de décomposition des prix (fle_frais) d'une ligne de nomenclature (scénario) Plus d'info

_SUP_REQ_DECPX_N_D

21,60 Complément de sélection sur la table de décomposition des prix (fle_frais) d'une ligne de nomenclature (détail) Plus d'info

_SUP_REQ_DECPX_R_S

21,60 Complément de sélection sur la table de décomposition des prix (fle_frais) d'une ligne de référence multiple (scénario) Plus d'info

_SUP_REQ_DECPX_R_D

21,60 Complément de sélection sur la table de décomposition des prix (fle_frais) d'une ligne de référence multiple (détail) Plus d'info

_SUP_REQ_EMBALLAGE

21,60 Complément de requête pour le conditionnement (table fle_emb)

_SUP_REQ_FLE_COMBI

21,60 Supplément de requête sur le vernis hors-ligne de l'entité (table fle_combi)

_SUP_REQ_FLE_COMBI2

21,60 Supplément de requête sur le vernis sous-traitance de l'entité (table fle_combi)

_SUP_REQ_FLE_COMBI3

21,60 Complément de sélection sur les lignes multiples d'impression (table fle_combi) (voir A4[42])

_SUP_REQ_FLE_FRAIS

21,60 Supplément de requête sur la table fle_frais

_SUP_REQ_FLE_GAM

21,60 Supplément de requête sur les gammes (table fle_gam)

_SUP_REQ_FLE_IMP

21,60 Complément de requête sur la table fle_imp

_SUP_REQ_FLE_MAT

21,60 Supplément de requête sur les matières (table fle_mat)

_SUP_REQ_FLE_NOM

21,60 Complément de sélection des lignes de nomenclature (fle_nom)

_SUP_REQ_FLE_OPE

21,60 Supplément de requête sur les opérations (table fle_ope)

_SUP_REQ_FLE_OPT

21,60 Supplément de requête sur les options (table fle_opt)

_SUP_REQ_FLE_STR

21,60 Supplément de requête sur la sous-traitance (table fle_str)

_SUP_REQ_FLE_VAR

21,60 Supplément de requête sur les variantes (table fle_var)

_SUP_REQ_MARGE

21,60 Complément de requête pour les marges (table fle_mar)

_SUP_REQ_MARGE_DEV

21,60 Complément de requête pour les marges du devis (table fle_mar)

_SUP_REQ_MULTI-BANDE

21,60 Complément de requête pour les multi-bandes (table fle_ba)

_SUP_REQ_NOTES_TEC

21,60 Supplément de requête à la table note_ldev (Notes TEC sur le devis)

_SUP_REQ_PAPIER

21,60 Complément de sélection sur la table fle_imp pour la sélection des papiers

_SUP_REQ_REF_MUL

21,60 Complément de sélection des lignes de références multiples associées à l'entête du devis (fle_dec)

_SUP_REQ_REF_MUL_E

21,60 Complément de sélection des lignes de références multiples associées à l'entité du devis (fle_dec)

_SUP_REQ_SITE

Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur

Tableau de bord du multisite

21,39 Nom de la colonne sur laquelle on fera le contrôle du site.

Exemple : l2_site, ec_c1, b1_sitp, …

Le site de production est inscrit sur le paramètre USE, en A3[10,12].

UNIT_CONV_CADENCE

21,23 Code du paramètre de l'unité (Type paramètre UNI)

Permet de convertir la cadence de l'opération vers l'unité paramétrée.

VE_NB_FEUILLES

21,23 Nombre de feuilles dans la page VoluEdit

Voir aussi la note GROUPE_INDIV qui permet une gestion correcte des sauts de page.

Codes sources des clés TSC et Notes

Code | Libellé | Disponibilité
CL | Code client | Sous-devis
CL/DEV | Adresse du devis | Sous-devis
CL/LIV | Adresse de livraison | Sous-devis
FI | Devis, Sous-devis, Entité | Entité
FI/LIM | Lignes d'impression multiple |
FI/REF | Liste des références | Entité
FI/RF1 | Liste des références (décomposition) | Entité
GA | Gamme | Gamme
GA/LIM | Ligne d'impression multiple dans la gamme devis La note NUM_PASS_LIEE doit être paramétrée sur chaque phase. |
L1 | Devis pour les TSC pour les notes | Sous-devis
L2 | Sous-devis | Variante
L2/PDP | Notes d'entête éditées en pied de page |
L2/VAR | Variante du sous-devis (Notes uniquement) |
LI | TSC sur l'entête du devis (TSC uniquement) |
MP | Code article principal | Sous-devis
MP/ENT | Code article de l'entité | Entité
MP/PAL | Palettisation de la référence de l'entête | Entête du devis
MP/QUA | Code qualité/papier | Entité
MP/REF | Code article multi-références |
REF | Liste des références | Entête du devis
RF1 | Liste des références (décomposition) | Entête du devis

Codes sources des clés LCO

Code | Libellé | Disponibilité
FI/MAT | Notes sur les formules matières |
FI/OPE | Notes sur les formules opérations |
FI/STR | Notes sur les formules sous-traitance |
FI | Devis, Sous-devis, Entité | Entité
L2 | Sous-devis | Sous-devis


voluedit_ordre_achat_transport Edition des ordres d'achat de transport

Voir aussi le paramétrage du programme d'édition standard.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N1C | Action: préparation - création de l'ordre d'achat de transport Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1C[gb_no_groupage]
-N2C | Action: expédition- création de l'ordre d'achat de transport Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2C[gb_no_groupage]
-N1M | Action: préparation - édition de la modification de l'ordre d'achat de transport si changement d'étapes Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1M[gb_no_groupage]
-N2M | Action: expédition- édition de la modification de l'ordre d'achat de transport si changement d'étapes Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2M[gb_no_groupage]
-N1A | Action: préparation - édition de l'annulation de l'ordre d'achat de transport Caractères 3 et suivants : Numéro d'affrètement Exemple : -N1A[gb_no_groupage]
-N2A | Action: expédition- édition de l'annulation de l'ordre d'achat de transport Caractères 3 et suivants : Numéro d'affrètement Exemple : -N2A[gb_no_groupage]

Options

Oce | Permet de déplacer les TSC de la fiche principale client du groupe des lignes de groupage dans le groupe des étapes
Oea | Active la visu des étapes d'arrivée uniquement
Ofm | Ne repositionne pas l'enregistrement de Fax/Mail à renvoyer automatiquement en réédition de l'ordre d'achat transport. Remarque : cela n'empêche pas la validation automatique par les notes VALID_FAX….
Ooa | Edition des affrètements complètement annulés Voir A2[7]
Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.
Ove | Edition VoluEdit (gestion pour modules externes)

Valeur alpha 2

A2[1,3]

Code site de production - Tableau de bord du multisite

A2[4,6]

Code du magasin de départ

A2[7]

Edition des lignes de groupage annulées (O/N, N par défaut)

Voir l'option Ooa.

Permet d'éditer toutes les lignes, mêmes annulées, d'un OAT qui n'est pas complètement annulé.

NB. : Cette évolution ne s'applique pas aux étapes, leurs données étant supprimées physiquement lors de l'annulation des lignes de groupage.

Il faut donc avoir un cadre multi-lignes sur les lignes de groupage BL dans le modèle VoluEdit pour avoir une édition des lignes annulées.

Dans le catalogue VoluEdit des OAT, une nouvelle variable est disponible au niveau de l'entête des groupages BL.

Cette variable (OAT complètement annulé) n'est renseignée qu'en présence de l'option Ooa et indique si un affrètement est complètement annulé (1) ou non (0).

Valeur alpha 4

1 | Titre du groupe multilignes ligne de groupage (si option Oti) (O/N, N par défaut)
2 | Titre du groupe multilignes étape (si option–Oti) (O/N, N par défaut)

Notes

SUP_REQ_CORRES_TRSP | 21,60 Complément de requête sur corres pour désigner le correspondant du transporteur
SUP_REQ_GROUPAG_BL | 21,60 Supplément de requête sur la table des groupages de BL (Table groupage_bl)
SUP_REQ_NB_DESIGNAT | 21,60 Complément de requête sur les tables cde1 et cde2 pour la recherche du nombre de désignations. Exemple and lc_annu = "N" and lc_solde = "N"
SUP_REQ_PAL_NOM0 | 21,60 Complément de requête sur la table nom0 pour la recherche du code palette2

Codes sources des clés TSC et Notes

Code | Libellé
CL | Code client
CL/LIV | Accès au TSC sur le tiers de l'étape (adresse de livraison si utilisée)
GBL | Groupage bon de livraison
NC/GBP | Ligne de groupage
GB/ETA | Permet de rattacher des TSC inscrits sur les lignes de groupages au bloc des étapes. Exemple : le payant pour sur le TSC AF1 zone numérique1 VE_VAR Payant pour*TSC_GB/ETA_AF1_N1*

Paramètres nécessaires

#CF LOG | Configuration logistique
#CF WSL | Configuration Way Server


voluedit_ordre_chargement Edition des ordres de chargement

Ce programme permet l'édition d'ordres de chargement dans le cadre de la logistique.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de groupage

Exemple : -N[gb_no_groupage]

Valeurs numériques

1

Nombre de lignes maximal à visualiser

Permet de limiter à un nombre de ligne maxi la liste des lignes de stock de l'article

Options

N | Numéro de groupage (à passer en argument pour un lancement depuis un autre programme)
Oea | Active la visu des étapes d'arrivée uniquement
Oer | Le menu de l'édition de l'ordre de chargement propose par défaut un choix pour l'édition, et un pour la réédition. Avec cette, ces deux choix sont fusionnés en un seul.
Ole | Prise en compte des lots d'expédition
Ooc | Affichage dans l'ordre de chargement du camion
Oti | Gestion des titres des groupes multilignes Pensez aux caractères 1 à N de la valeur alpha 4.

Valeurs alpha 4

1

Titre du groupe multilignes ligne de groupage (O/N, N par défaut)

2

Titre du groupe multilignes lot expédition (O/N, N par défaut)

3

Titre du groupe multilignes des stocks (O/N, N par défaut)

4

Titre du groupe multilignes Nomenclature (O/N, N par défaut)

5

Mode de rupture

O Rupture sur le n° de groupage, le code client, l'adresse de livraison, et la date de livraison

L Rupture sur le n° de groupage, le code client, et l'adresse de livraison

N Rupture sur le n° de groupage (par défaut)

6

Mode de recherche des stocks lots/lieux à lister sur l'ordre de chargement

1 Recherche limitée au n° de lot de la ligne de groupage s'il s'agit d'un article cartonnier (par défaut).

2 Recherche limitée au n° de lot de la ligne de groupage s'il s'agit d'un article synchrone ou si la commande de la ligne de groupage est de type FB2.

Notes triées

_SUP_ORDER_GBL | 21,60 Ordre de tri des groupages sur groupage_bl
_SUP_ORDER_LGBL | 21,60 Ordre de tri des lignes du groupage, sur groupage_bl Ne fonctionne pas si l'option Ooc est active.
_SUP_REQ_GBL | 21,60 Complément de select sur groupage_bl
SUP_REQ_NB_DESIGNAT | 21,23 Code du TYC associé au complément de requête ci-dessous 25,60 Complément de requête sur les tables cde1 et cde2 pour la recherche du nombre de désignations Le but est de disposer d'une variable indiquant le nombre de désignations d'une CDA. Dans VoluEdit, cette variable a été ajoutée dans le nœud Commande du groupe multi-ligne Ligne de groupage. Le nom de la variable est Nombre de désignations. Exemple and lc_annu = "N" and lc_solde = "N" and ec_tyc = "CD1"
_SUP_REQ_NOM0 | 21,60 Complément de requête sur le groupe multilignes nomenclature (ex. " and n0_pcse = …")
_SUP_REQ_STK0 | 21,60 Complément de requête sur stk0 pour le groupe multilignes des Stock
TITRE_MENU | 21,60 Titre du menu
TITRE_PROG | 21,60 Titre du programme à afficher dans l'écran de sélection

Codes sources des clés TSC et Notes

GBL | Entête groupage
NC/GBP | Ligne de groupage
CL | Client ligne de groupage
CL/LE | Client lot d'expédition
CL/LIV | Client livré de la ligne de groupage
LC | Ligne de commande de la ligne de groupage
LC_LI | Cadencement des lignes de commande
NC | Séquence de la ligne de commande
NC/LI | Cadencement des séquences de lignes de commande
LE | Lot d'expédition
MP | Produit de la séquence
MP/ENS | Code article de la découpe
CAS01 | Cascade 1


Edition des réclamations clients

Edition des réclamations clients reclam_edition

Il s'agit d'une édition VoluEdit.

Pas d'équivalent en édition standard

Pour les types d'actions, voir le paramètre TAC.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : type de réclamation client-numéro de réclamation client

Exemple : -N[rce_type|rce_num_rec]

Options

Oli | Edition en mode liste
Orf | Réclamations fournisseurs Nom du catalogue : Réclamation Fournisseur NCI
Oti | Gestion des titres des groupes multilignes
Ove | OBLIGATOIRE Activation de l' édition par VoluEdit
Oxm | Envoi automatique des fax / e-mails Voir les notes VALID_FAX* dans les généralités.

Valeur alpha 4

Caractère 1 | Gestion du titre du groupe Notes descriptives
Caractère 2 | Gestion du titre du groupe Notes calcul avoir
Caractère 3 | Gestion du titre du groupe Notes observations générales
Caractère 4 | Gestion du titre du groupe Notes vérifications effectuées
Caractère 5 | Gestion du titre du groupe Notes traitement
Caractère 6 | Gestion du titre du groupe Notes descriptives écran traitement
Caractère 7 | Gestion du titre du groupe commande
Caractère 8 | Gestion du titre du groupe actions correctives
Caractère 9 | Gestion du titre du groupe Notes actions correctives
Caractère 10 | Gestion du titre du groupe Notes recherche des causes
Caractère 11 | Gestion du titre du groupe Traitement
Caractère 12 | Gestion du titre du groupe Défaut
Caractère 13 | Gestion du titre du groupe Origine défaut

Notes

_SUP_REQ_RECLAM

21,60 Complément de requête sur la table reclamation

NB_MAX_LIG_NOTES_

Permet de limiter le nombre de notes multi-lignes dans un modèle statique

18,20 Type de notes

CAV

DES

TRT

IVE

ACC

OBG

DET

RCA

21,23 Nombre de lignes

ORDRE_GROUPE

21,22 Code du groupe multi-lignes (de 01 à 12)

23,24 Numéro d'ordre du groupe multi-lignes ( de 01 à 12)

L'ordre d'apparition des groupes par défaut est le suivant :

01 - Liste des commandes de la réclamation (table reclamation_det)

02 - Notes descriptives (notes DES)

03 - Notes observations générales (notes OBG)

04 - Traitement (table reclam_traitement)

05 - Descriptif réclamation sur écran traitement (notes DET)

06 - Groupe autonome : groupe autonome (pour la dérogation)

07 - Notes traitement (notes TRT)

08 - Notes sur la recherche des causes (notes RCA)

09 - Actions correctives (table reclam_action_cor)

10 - Constat : défaut (table reclam_defaut)

11 - Notes sur les vérifications effectuées (notes IVE)

12 - Notes descriptives calcul avoir (notes CAV)

Règles de paramétrage :

1. Un code de groupe multi-lignes ne peut être paramétré qu'une seule fois.

2. Un numéro d'ordre de groupe multi-lignes ne peut être paramétré qu'une seule fois.

3. Si on ne paramètre pas les ordres de tous les groupes, on utilise les ordres par défaut pour les groupes restants.

4. S'il existe un intervalle dans les numéros d'ordre, cet intervalle est comblé par les prochains ordres paramétrés. Ensuite, c'est la règle numéro 3 qui s'applique.

Exemple :

ORDRE_GROUPE 0801

ORDRE_GROUPE 0202

ORDRE_GROUPE 0303

ORDRE_GROUPE 0704

ORDRE_GROUPE 1105

ORDRE_GROUPE 0506

ORDRE_GROUPE 0407

ORDRE_GROUPE 0609

  • Les groupes 08, 02, 03, 07, 11, 05, 04 sont paramétrés dans l'ordre de 1 à 7.

  • Le groupe 06 est paramétré en 9ème position. Comme aucun ordre n'est paramétré en 8ème position, on remonte le groupe 06 en 8ème position.

  • Les groupes 01, 09, 10, 12 ne sont pas paramétrés. Ils seront utilisés de la 9ème à la 12ème place dans l'ordre par défaut.

Dans cet exemple, on aura donc l'ordre suivant :

  1. 08 - Recherche des causes : notes sur la recherche des causes

  2. 02 - Définition de la NCI : notes descriptives

  3. 03 - Notes Observation générales

  4. 07 - Traitement de la NCI : notes traitement

  5. 11 - Infos sur les vérifications : notes sur les vérifications effectuées

  6. 05 - Descriptif réclamation sur écran traitement

  7. 04 - Traitement de la NCI : traitement

  8. 06 - Groupe autonome : groupe autonome (pour la dérogation)

  9. 01 - Liste des commandes de la réclamation

  10. 09 - Actions correctives : actions correctives

  11. 10 - Constat : défaut

  12. 12 - Infos sur les vérifications : notes sur les vérifications effectuées

_SUP_REQ_RECLAM_DET

21,60 Complément de sélection sur la table reclamation_det

Exemple

_SUP_REQ_RECLAM_DET and rcd_ordre = 1

VALID_FAXMAIL_EDIT

VALID_FAXMAIL_REEDIT

VALID_FAXMAIL_VALID

Voir les notes dédiées au Fax/Mail

Codes sources des clés TSC

REC | Numéro de réclamation Exemple : VE_VAR Archivage*TSC_REC_ARC_C30*20*
RCE | TSC sur les réclamations


voluedit_releve Edition des relevés de factures

Voir aussi les paramétrage de l'édition "standard" des relevés de facture.

Options triées

-Oa2 | Edition de la mention Affacturage
-Oaf | Rupture sur le mode de règlement ou la date d'échéance du client + adresse de facturation
-Obp | Autorisation du basculement de la prise en compte de la périodicité de relevé
-Ocp | Edition des documents avec contrepartie
-Oea | La date d'échéance des avoirs est égale à la date de la pièce Par défaut, elle est égale à la dernière échéance calculée de la dernière facture.
-Oer | Calcul de la date d'échéance du relevé par rapport à la date d'édition du relevé
-Ona | Numérotation annuelle
-Ore | Rupture sur le mode de règlement ou la date d'échéance du client. Si rupture, autre relevé
-Osf | Sélection N° de factures
-Ove | OBLIGATOIRE Activation de l' édition par VoluEdit


voluedit_traites Edition des traites de factures par VoluEdit

Tout le paramétrage du programme d'édition standard est valable ici.

Options

Ogc | Alimentation de canal_comm uniquement Permet l'édition des traites en utilisant le système canal_comm. Utilisé en autre pour le mode WEB
Omt | Activation de l'édition de plusieurs traites par pages et du catalogue associé
Ors | Accès en réédition seulement
Ove | Edition via VoluEdit

Notes

_SUP_REQ_TRAITES | Complément de requête pour les factures (fac1, fac2)
_SUP_REQ_RELEVES | Complément de requête pour les relevés (rel0)


#VI Aide générale au paramétrage des modules de visualisation

consult_stock (uniquement l'option Oxs)

estk_s

rel_f

v_action_evt

v_action_mat

v_bonprep

v_brc

v_cde_5

v_cde_marche

v_cdef

v_cdem

v_cdemul

v_cli

v_dem_achat

v_don

v_eat

v_edi_brc

v_edi_cde

v_edi_cde_delfor

v_emp

v_evt

v_fab0

v_fab1

v_fab2

v_fab5

v_fle

v_groupage_bl

v_i_postes

v_jbl

v_jda

v_jdv

v_machine

v_mar

v_mat

v_mat4

v_odv

v_palchep

v_par02

v_prostk

v_reclamation

v_rem0

v_sbi

v_stk0

v_stk_lot_lieu

v_tar0

v_tra

v_tracabilite

v_triplet

v_cde

v_ecma

v_edi_stk_bob

v_fab3

v_i_postes

v_ond

v_par01

v_tarifs_transp

V FAM*mp_fam*3**N*N*

V SFM*mp_sfm*3**N*N*

V Code article*mp_code*15**N*N*

V Disponible*mp_sdisp*11*#######.###*N*N*

V Physique *mp_sphy*11*#######.###*N*N*

E Code article*mp_code*15**N*N*

E Désignation *mp_des*40**N*N*

E Disponible*mp_sdisp*11*#######.###*N*N*

E Physique *mp_sphy*11*#######.###*N*N*

E Date*mp_date*8*dd/mm/yy*N*N*

V Nom Abrege*TSC_CL_CL_NAB_G*12**N*N*

V Calcul*CALC_15*11*#######.###*N*N*

D Tarif :*TAR0_#CFTAR*6*--- --&*

Paramétrage | Résultat | Commentaires
4 " | | "champ1"|"champ2"|"champ3" | Les champs sont encadrés par des guillemets, et le séparateur est le pipe.
4 null null | champ1champ2champ3 | Les champs sont collés les uns aux autres. Ni encadrement, ni séparateur. A utiliser si les champs exportés sont de longueur fixe.
4 null ; | champ1;champ2;champ3 | Les champs ne sont pas encadrés, et le séparateur est le point-birgule.
4 / null | /champ1//champ2//champ3/ | Les champs sont encadrés par des slashes, et il n'y a pas de séparateur.

Complément de sélection paramétré sur la visualisation des besoins (G_v_cde_5), permettant de rechercher les commandes dont l'acheteur est celui renseigné sur l'utilisateur courant.

Code acheteur associé à l'utilisateur courant :

Paramètre USE/DEF, A3[47,49] = "IGO"

Complément de sélection :

S and exists

S (select ic_cle from info_c

S where ic_cle = uc_num || "-" || uc_lig

S and ic_ts matches "666"

S and ic_type = "C"

S and ic_char3_1 _CRIT_VALE_1

S and ic_soc = "VL")

Recherche de valeur automatique :

_CRIT_VALE_1 A O par02_user*p2_alph3*47*49*

A : On recherche une zone alphanumérique (p2_alph3)

O : La valeur recherchée doit exister (si le code acheteur n'est pas renseigné sur l'utilisateur, la visualisation ne sera pas accessible)

par02_user : On recherche une zone de la table par02 de l'utilisateur VoluPack courant

p2_alph3 : On recherche la zone paramétrable 3 de la table par02_user

47 49 : On ne prend en compte que les caractères 47 à 49 de la zone paramétrable 3 de la table par02_user

Résultat :

Le critère de sélection

S and ic_char3_1 _CRIT_VALE_1

devient

S and ic_char3_1 = "IGO"

#VI Aide générale au paramétrage des modules de visualisation

Options Valeurs alpha 1, 2, 3, 4 Notes Page dédiée aux exports vers Excel

Notes propres à la colorisation

Options

Les 2 options Oxd et Oxs sont disponibles dans la quasi-totalité des programmes de visualisation.

Listes des programmes disposant de ces options

Liste des programmes ne disposant pas de ces options

Otm

Suppression de la ligne de totalisation multilignes.

On n'affiche pas la ligne de totalisation si elle ne porte que sur une seule ligne de la visualisation, et si l'on n'a qu'un seul critère de rupture sur la visualisation.

S'il existe plusieurs critères/niveaux de rupture pour un écran de visualisation, alors toutes les lignes de totalisation sont affichées malgré cette option.

Cas particuliers :

Cette option ne fonctionne pas pour les programmes suivants :

v_eat (Visualisation de l'état d'avancement des travaux) - Pas de cumul

v_edi_cde_delfor (Visualisation des messages EDI de commandes) - Pas de cumul

v_libetr (Visualisation des libellés étrangers) - Pas de cumul

v_tarifs_transp (Visualisation des tarifs transporteurs) - Pas de rupture

v_triplet (Visualisation des triplets) - pas de rupture

Pour le programme v_fab2 (Visualisation du réalisé production) :

Cette option ne fonctionne que si l'on ne gère pas le détail de fab2

(v_fab2 A2[36] différent de O).

Oxd

Cacher le cadre détail des visualisations

La dimension du cadre Détail ne sera plus limitée à 76 caractères.

Il pourra s'étendre selon la largeur de la grille de visualisation.

La largeur maximale est paramétrable par la note LONGUEUR_MAX_DETAIL

Dans le cadre détail, les sauts de ligne sont gérés automatiquement lorsque l'on arrive en bout de ligne.

Il est également possible de forcer un saut de ligne en créant la note D /n.

Il reste possible d'afficher les détails en utilisant laction associée dans le menu Actions ou en cliquant sur le bouton correspondant.

Oxs

Ne pas passer par l'écran de sélection

Le paramétrage déjà existant (A2[8] ci-dessous) est toujours utilisable et est pris en compte si l'option n'est pas active.

Valeur alpha 1

#VI A1[1,60]

Nom du module de visualisation

Valeur alpha 2

Les caractères compris dans la plage 1-30 sont réservés à des options standard.

Les caractères compris dans la plage 31-60 sont réservés à des options spécifiques.

#VI A2[1] | Second écran de sélection (O/N, N par défaut) (Disponible suivant les cas)
#VI A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut) A partir de la V. 4.1.26.2, ce paramètre est susceptible d'être modifié par la case Ne plus ouvrir la fenêtre de tri que vous pouvez cocher au lancement de la visualisation. La permission ACC PARAM_TRI_VISU est nécessaire. Voir aussi les notes commençant par O pour les critères de tri.
#VI A2[3] | Edition sans les lignes de détails si rupture et cumul (O/N, N par défaut)
#VI A2[5] | En mode édition, on veut afficher aussi les critères saisies par les compléments de requête standard de la visualisation (note S) (O/N)
#VI A2[8] | Lancement de la visualisation sans écran de sélection (O/N, N par défaut)
#VI A2[9] | Edition d'un état destiné aux clients (O/N, N par défaut) Actif uniquement dans la visualisation des articles et des stocks
#VI A2[10] | Mode de visualisation E Edition (lancement du programme en batch) F création d'un Fichier (lancement du programme en batch) V Mode écran - Non dispo sur toutes les visus - se renseigner X Mode Excel - Non dispo sur toutes les visus - se renseigner

Valeur alpha 3

#VI A3[1,60]

Titre général de la visualisation

Valeur alpha 4

#VI A4[1,60] Voir aussi la note AUTORISE_TOUCHE_F | Touches de fonction autorisées - Voir le tableau N Touche de fonction non autorisée. N est la valeur par défaut sauf dans certains cas, notamment : 38 Control-C (Calculatrice) 51 Control-T (Aide sur les touches de fonction) 56 Control-Z (Lancement de programmes) O Touche de fonction autorisée et accès en consultation. M Touche de fonction autorisée et accès en modification. Valable uniquement si la touche de fonction concerne une saisie.
#VI A4[43] | Touche CONTROL-J (O/N) Appel de programmes
#VI A4[44] | Touche CONTROL-K (O/N) Action à réaliser sur une sélection multiple

Notes

Les notes commençant par une seule lettre apparaissent en premier lieu, suivies des autres notes.

Certaines zones sur le client final sont accessibles à la plupart des programmes de visualisation.

Cliquez ici pour en savoir plus.

Paramétrage | Résultat | Commentaires
4 " | | "champ1"|"champ2"|"champ3" | Les champs sont encadrés par des guillemets, et le séparateur est le pipe.
4 null null | champ1champ2champ3 | Les champs sont collés les uns aux autres. Ni encadrement, ni séparateur. A utiliser si les champs exportés sont de longueur fixe.
4 null ; | champ1;champ2;champ3 | Les champs ne sont pas encadrés, et le séparateur est le point-birgule.
4 / null | /champ1//champ2//champ3 | Les champs sont encadrés par des slashes, et il n'y a pas de séparateur.

ATTENTION : Les colonnes de totalisation doivent être placées juste après la première colonne V.

D /n

Saut de ligne dans le cadre détails

C

Commentaires à éditer

Ces notes seront éditées en entête de document.

D

E

F

V

Ces notes indiquent les variables à utiliser (Détail, Edition, Fichier, Visu).

Les champs sont séparés par un astérisque et le dernier champ doit se terminer obligatoirement par un astérisque.

Il faut laisser un caractère vide en position 2.

A partir du caractère 3, il y a 9 champs ordonnés de la manière suivante :

1) Le titre de la colonne

2) Le nom de colonne

Plusieurs possibilités :

- - Le nom de la colonne commence par TSC_ : voir la syntaxe d'appel des TSC

Le nom du champ est indiqué en clair (chaque visu dispose de sa propre liste des noms de zones autorisés)

- Le nom de colonne commence par NTS_ : voir la syntaxe d'appel des NTS

Ce paramétrage permet de définir des colonnes contenant des lignes de notes paramétrables.

Les champs 4 à 9 ne sont pas utilisés.

- Le nom de la colonne commence par CALC_

Le résultat proviendra d'une formule de calcul dont le numéro suit. Exemple : CALC_08

- Le nom de la colonne commence par VCI_

Le résultat proviendra de la variable de calcul intermédiaire x (résultat de la formule définie sur la note _VCI_).

- Le nom de la colonne commence par TAR0_

Permet de définir des colonnes paramétrables résultant d'une recherche paramétrable de barème.

Les champs 4 à 9 ne sont pas utilisés.

Syntaxe : TAR0_XXXYYY où XXXYYY représentent le type et le code du paramètre de recherche des tarifs.

3) La longueur de la colonne

4) using utilisé (essentiellement pour les zones numériques et les dates)

5) Zone à cumuler :

N Pas de totalisation

O Totalisation

M Calcul de la moyenne (total / nombre de valeurs)

T Total de zones temporelles (Intéressant si on veut les temps en heures minutes)

C Permet, pour une zone calculée, d'effectuer le calcul à partir de zones cumulées.

Intéressant pour tous les calculs non linéaires.

Ainsi on calculera, par exemple, le pourcentage du total de la colonne X par rapport à la colonne Y.

En effet les opérations de somme ou moyenne de valeurs n'ont aucun sens pour les pourcentages.

6) On édite la colonne uniquement sur les lignes de totalisation (O ou N)

7) Non utilisé

8) Code langue du titre de la colonne. Ne fonctionne que si #CF ATL alpha1[18] = O.

Ce code langue ne vaut que pour le titre de la colonne, il n'affecte pas le contenu.

9) Numéro de condition de colorisation

Ce champ n'est disponible que pour les visualisations (notes commençant par V).

Il n'est PAS DISPONIBLE pour les notes commençant par D, E et F.

Voir les notes propres à la colorisation, dans un tableau séparé.

Ü Quelques exemples

I (lettre i majuscule)

2,3 Indentation des totaux. Valeurs possibles :

DV

IV

DE

IE

4,60

N

2,60 Nom du fichier par défaut lors de l'export dans un fichier

O

Définition de l'ordre de tri

2,3 : Critère de tri (dépend du programme)

4,60 : Modalités du tri, découpées en 6 champs comme suit :

1) Numéro d'ordre pour le critère de tri, ou N si ce critère ne doit pas être trié

2) Libellé de la zone de tri affiché dans le tableau de sélection

Par défaut, c'est le libellé standard (en fonction du programme) qui est affiché.

3) Edition d'une ligne de totalisation (O/N)

4) Saut de page à chaque rupture (O/N)

5) Libellé affiché dans la visualisation.

Par défaut, c'est le libellé standard (en fonction du programme) qui est affiché.

6) Critère de tri supplémentaire, optionnel

Chacun des 6 champs doit se terminer par un astérisque.

Pour plus de lisibilité des notes, les modalités de tri peuvent être indiquées à partir du caractère 5 au lieu du caractère 4.

Exemple 1

Dans la visualisation des commandes clients, le numéro de dossier est le critère de tri N° 26.

Si on veut en faire l'ordre de tri principal, on écrira la ligne de note suivante :

O26 01*Dossier*O*N*Dossier**

En outre, cette note stipule que le libellé affiché dans le tableau de sélection et dans la visualisation est Dossier, et que l'on veut une ligne de totalisation, mais pas de saut de page à chaque changement de dossier.

Le numéro de ligne de dossier est le critère de tri N° 29. Pour en faire l'ordre de tri secondaire, on ajoutera la note suivante :

O27 02*Ligne*N*N*Ligne**

Exemple 2

O01 01*Client*O*N** asc, lc_qtecde desc*

Le code client est le critère de tri N° 1, c'est l'ordre de tri principal, le libellé affiché dans le tableau de sélection est Client, on veut une ligne totalisation pour chaque client mais pas de saut de page à chaque changement de client, le libellé affiché dans la visualisation est le libellé standard (en l'occurrence, Code client), et on a précisé un critère de tri supplémentaire :

asc est le mot clé indiquant que le tri -du code client- sera croissant (il est indiqué ici mais c'est inutile car le tri est croissant par défaut);

lc_qtecde desc indique que pour chaque client, on triera par ordre décroissant de quantité commandée.

A partir de la V. 4.1.26.2, les notes de tri que vous créez ici sont susceptibles d'être modifiées par une case que vous pouvez cocher lorsque la fenêtre de définition du tri apparaît (au lancement de la visu) : si vous modifiez les critères de tri dans cette fenêtre, et que vous cochez la case Mettre à jour le paramétrage par défaut, alors les notes existantes commençant par O sont remplacées par celles qui sont issues des réglages que vous avez effectués dans cette fenêtre.

La permission ACC PARAM_TRI_VISU est nécessaire.

Voir aussi A2[2] pour l'affichage ou non de la fenêtre de tri.

P

Formule de politesse paramétrable dans le cas d'un état client

R

3,42 Répertoire par défaut lors de l'export vers un fichier

1. Permet de saisir ou de paramétrer par défaut un répertoire de destination des fichiers.

2. Permet d'ajouter par mots-clés un horodatage au nom d'un fichier généré par les visualisations (mode fichier ou mode édition vers un fichier).

Remarque : Par extension, ce fonctionnement est valable pour toutes les éditions vers un fichier présentes dans VoluPack (via la fonction de choix d'un périphérique, mode f).

Le nom du fichier peut être horodaté grâce aux mots-clés suivants :

%D2% Date du jour au format aammjj

%D4% Date du jour au format aaaammjj

%HM% Heure courante au format hhmm

%HS% Heure courante au format hhmmss

Exemple (nous sommes le 02/07/2010 et il est 17h 25m 15s)

Nom de fichier paramétré : liste_client_%D4%_%HS%.txt

Nom de fichier généré : liste_client_20100702_172515.txt

ATTENTION : Les mots-clés d'horodatage ne peuvent pas être utilisés au niveau du nom du répertoire, à moins que ce répertoire existe déjà sur le système.

Cette note est prioritaire sur la note REPERTOIRE_FICHIERS dans le #CF ATL.

S

Critère de sélection supplémentaire

ATTENTION

Dans le cadre de la recherche d'articles par visualisation, ce critère peut être ignoré en fonction de #CF RMP A1[41]

Il est OBLIGATOIRE de mettre le nom de la table avant le nom de la colonne.

Pour v_cdem, il existe des nouvelles zones accessibles dans les critères. Cliquez ici pour les voir dans v_cdem.

Voir aussi les notes _CRIT.

Exemples

S and mat.mp_anu != "O"

S and mat.mp_mp matches "[M,F,X]"

V

Voir les notes D, E, F, V (attention : 3 syntaxes)

1, 2, 3, 4

Ces notes sont utilisées pour paramétrer le séparateur de champ et l'encadrement du champ.

Note commençant par 1 : paramétrage du séparateur de champ pour la Visualisation (notes commençant par V)

Note commençant par 2 : paramétrage du séparateur de champ pour de Détail (notes commençant par D)

Note commençant par 3 : paramétrage du séparateur de champ pour l'Edition (notes commençant par E)

Note commençant par 4 : paramétrage du séparateur de champ pour l'export dans un Fichier (notes commençant par F)

Caractère 3 : caractère encadrant le champ. Indiquez null dans les caractères 3 à 6 pour aucun caractère.

Caractère 8 : séparateur de champ. Indiquez null dans les caractères 3 à 6 pour aucun caractère.

Cette note sera avantageuse pour l'export dans un fichier.

Pour éviter l'effet de surprise, on évitera les valeurs par défaut...

Cliquez ici pour afficher / masquer des exemples.

AUTORISE_TOUCHE_F

Voir aussi la valeur alpha 4

Touches de fonction autorisées - Voir le tableau

18,20 Numéro de touche

21 Paramétrage des touches de fonction

N Touche de fonction non autorisée.

N est la valeur par défaut sauf dans certains cas, notamment :

38 Control-C (Calculatrice)

51 Control-T (Aide sur les touches de fonction)

56 Control-Z (Lancement de programmes)

O Touche de fonction autorisée et accès en consultation.

M Touche de fonction autorisée et accès en modification.

Valable uniquement si la touche de fonction concerne une saisie.

AUTORISE_TOUCHE_F37

21 Accès à la touche F37 (O/N, N par défaut)

Le contrôle d'accès à la touche F37, anciennement paramétré en A4[57], a été déporté dans cette note.

ATTENTION : Cette modification est susceptible d'impacter les programmes suivants s'ils gèrent la touche F37 :

estk | v_cli | v_fle | v_mat_4 | v_stk_lot_lieu
rel_f | v_don | v_groupage_bl | v_palchep | v_tar0
v_bon_prep | v_edi_cde | v_jbl | v_par02 | v_tdv
v_cde_5 | v_emp | v_jda | v_prostk | v_tra
v_cde_marche | v_evt | v_jdv | v_reclamation | v_triplet
v_cdef | v_fab0 | v_libetr | v_rem0 |
v_cdem | v_fab1 | v_mar | v_sbi |
v_cdemul | v_fab2 | v_mat | v_stk0 |

AUTORISE_TOUCHE_F254

21 Autorisation de la touche transfert vers Excel ( O/N)

Cette touche se nomme F254.

Cette fonctionnalité est soumise à une option payante WIN 3

Il est nécessaire d'installer le Volume Media Center. Le #CF VMC doit exister, même sans paramétrage.

_CALC_

Ces notes définissent des formules de calcul utilisées dans les visualisations.

Elles s'utilisent conjointement avec les notes _VAR_

Il faut saisir ces notes sur les premières lignes afin d'optimiser le temps de recherche.

7,8 N° de formule

9,10 Nombre de décimales (entre 0 et 15, à blanc si on ne veut pas d 'arrondi)

11,60 Formule en notation polonaise inversée (la notation normale fonctionne aussi, à vérifier).

Exemple

_CALC_08 bc-a*

_CRIT_CHAR_

_CRIT_DATE_

_CRIT_NUMD_

_CRIT_NUME_

_CRIT_VALE_

Ces notes existent également sur le programme gen_cdef.

Voir aussi les notes commençant par S.

Exemple

S and lc_tva _CRIT_CHAR_1

S and lc_delrep _CRIT_DATE_1

S and lc_lig _CRIT_NUME_2

1 2 3 4 5 6

123456789012345678901234567890123456789012345678901234567890

_CRIT_CHAR_1 PTVAO Code TVA à rechercher

_CRIT_DATE_1 C Critère sur délai répondu

_CRIT_NUME_2 U O Recherche limitée aux lignes

Lors du lancement du programme, durant la phase d'initialisation, 3 fenêtres vont donc s'ouvrir pour demander à l'utilisateur :

1) Le code TVA à rechercher
Sur cette fenêtre, vous avez la possibilité de faire F7, vous devez saisir une valeur et il y a un contrôle d'existence du code paramètre saisi.

2) Le critère à appliquer sur le délai répondu
Sur cette fenêtre, vous pouvez saisir aussi bien une date unique (exemple : 20/11/2003), qu'un critère évolué (exemple : >20/11/2003 ou 20/11/2003 :30/11/2003).

3) Le numéro de ligne de commande
Sur cette fenêtre, vous êtes obligé de saisir une valeur mais cette dernière ne sera pas contrôlée (rien ne vous empêchera de mettre 5 par exemple) mais seulement une valeur précise, vous n'aurez pas la possibilité de paramétrer >3

Remarque : Si l'opérateur est précisé dans le critère paramétré S, la saisie de la valeur devient obligatoire (équivalent au caractère 19 = O).

Le titre de la visualisation peut intégrer ce critère.

Exemple de titre

Reste à livrer au _CRIT_DATE_1

_CRIT_CHAR_

12 Identifiant de la variable caractère

13,14 Code formule pour l'interrogation en saisie de critère avec le type C (caractère 15 = C)

Ces codes formules sont les mêmes que ceux utilisés dans la saisie des TSC. Rappel :

01 Paramètre

02 Article (recherche produit)

03 ECMA / FEFCO

04 Gammes standard

05 Machines

06 Article (recherche données techniques)

07 Article (recherche papier)

08 Sous-famille

09 Tiers

10 Adresse secondaire

15 Type de saisie

C Saisie complexe [Valeur par défaut]

P Saisie d'un paramètre

U Saisie d'une chaîne précise

D Valeur par défaut (dans ce cas, on saisit la valeur par défaut dans les caractères 21 à 60)

16, 18 Si caractère 15 = P : Type du paramètre à saisir [Si non renseigné, pas de contrôle ni de F7]

Si caractère 15 = U : Longueur maximale de la chaîne à saisir [Par défaut, pas de contrôle]

Si car.13,14 = 01 : Type de paramètre

19 Saisie obligatoire

N Si la valeur n'est pas saisie, le critère sera is not null pour une saisie complexe (caractère 15 = C) ou is null pour tous les autres types de saisie (par défaut).

V Si la valeur n'est pas saisie, le critère sera is not null.

O La valeur est obligatoire.

21,60 Question posée à l'utilisateur dans la fenêtre

ou valeur par défaut si car.15 = D

_CRIT_DATE_

12 Identifiant de la variable date

15 Type de saisie

C Saisie complexe [Valeur par défaut]

U Saisie d'une date précise

D Valeur par défaut (dans ce cas, on saisit la valeur par défaut dans les caractères 21 à 60)

16,18 Uniquement si caractère 15 = U

Nombre de jours d'écart autorisé par rapport à la date du jours (par défaut, pas de contrôle)

19 Saisie obligatoire

N Si la valeur n'est pas saisie, le critère sera is not null pour une saisie complexe (caractère 15 = C) ou is null pour tous les autres types de saisie (par défaut).

V Si la valeur n'est pas saisie, le critère sera is not null.

O La valeur est obligatoire.

21,60 Question posée à l'utilisateur dans la fenêtre

ou valeur par défaut si car.15 = D

_CRIT_NUMD_

12 Identifiant de la variable numérique décimale

15 Type de saisie

C Saisie complexe [Valeur par défaut]

U Saisie d'une valeur unique

D Valeur par défaut (dans ce cas, on saisit la valeur par défaut dans les caractères 21 à 60)

16,18 Non utilisés

19 Saisie obligatoire

N Si la valeur n'est pas saisie, le critère sera is not null pour une saisie complexe (caractère 15 = C) ou is null pour tous les autres types de saisie (par défaut).

V Si la valeur n'est pas saisie, le critère sera is not null.

O La valeur est obligatoire.

21,60 Question posée à l'utilisateur dans la fenêtre

ou valeur par défaut si car.15 = D

_CRIT_NUME_

12 Identifiant de la variable numérique entière

15 Type de saisie

C Saisie complexe [Valeur par défaut]

U Saisie d'une valeur unique

D Valeur par défaut (dans ce cas, on saisit la valeur par défaut dans les caractères 21 à 60)

16,18 Non utilisés

19 Saisie obligatoire

N Si la valeur n'est pas saisie, le critère sera is not null pour une saisie complexe (caractère 15 = C) ou is null pour tous les autres types de saisie (par défaut).

V Si la valeur n'est pas saisie, le critère sera is not null.

O La valeur est obligatoire.

21,60 Question posée à l'utilisateur dans la fenêtre

ou valeur par défaut si car.15 = D

_CRIT_VALE_

Il est possible de remplacer les variables ci-dessus par une recherche automatique

12 Identifiant de la variable "valeur"

15 Type de la zone recherchée

A Zone alphanumérique (par défaut)

N Zone numérique

D Zone date

16,18 Réservé

19 La zone recherchée doit-elle exister ?

N Si la zone trouvée n’existe pas ou n’est pas remplie, le critère sera is null (par défaut).

V Si la zone trouvée n’existe pas ou n’est pas remplie, le critère sera is not null.

O Si la zone trouvée n’existe pas ou n’est pas remplie, l’initialisation du programme en cours est annulée.

21,60 Paramétrage de recherche de la zone, colonnes séparées par des astérisques

Table source*Zone source*Caractère début*Caractère fin*

Tables sources disponibles :

par02_user : Enregistrement du paramétrage de l'utilisateur VoluPack courant

Zones sources disponibles :

Table par02_user

p2_code : Code utilisateur

p2_zc1 : Zone numérique 1

p2_zc2 : Zone numérique 2

p2_alph : Zone paramétrable 1

p2_com : Zone paramétrable 2

p2_alph3 : Zone paramétrable 3

p2_alph4 : Zone paramétrable 4

Caractère début : Position du caractère de début de chaîne (ne peut être utilisé que sur les zones sources de type alphanumérique)

Caractère fin : Position du caractère de fin de chaîne (ne peut être utilisé que sur les zones sources de type alphanumérique)

Cliquez ici pour afficher / masquer un exemple

_CSEL

Affichage de la colonne de sélection. Voir aussi le #RP

Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement.

Si la note _CSEL est présente dans le paramétrage, alors seules les lignes sélectionnées seront transférées vers le tableur.

_EXCEL_XXXXXXXXXX

Voir les notes propres aux exports Excel

FORMAT_DEC_VISSTKDI

Pouvoir paramétrer le format des zones de stock (disponible, en commande, &) dans la visualisation des stocks disponibles par semaine et par jour.

21,60 Format des zones de stock en affichage

Exemple

### ##&

Ce paramètre se positionne sur chaque lanceur susceptible d'utiliser ces fonctions de visualisation de stock (f_visstkdi et f_visdisjo)

Remarque : cette note peut s'inscrire sur le paramètre #CF STK.

_FTSC_

Accès à toutes les infos de la fiche matière d'un produit lu depuis un TSC.

On peut aujourd'hui ramener jusqu'à 5 fiches matières différentes

7 Numéro de la fiche à charger

8 _ (caractère souligné "underscore")

9 et suivants : Idem paramétrage standard de lecture d'un TSC dans les visus

La zone lue doit impérativement être G (correspondant au ic_char30) puisque l'on veut récupérer un code produit.

Exemples

_FTSC_1_MP_AA_300_G

_FTSC_2_MP_AA_CC1_G

_FTSC_3_MP_AA_CT1_G

Pour accéder aux zones de la fiche matière chargée, il suffira de préfixer la zone mp_ par le numéro de fiche à charger.

Exemples

D MP1Code*1_mp_code*15*

D Fam*1_mp_fam*3*

D Sfm*1_mp_sfm*3*

D Long*1_mp_long*6*###&*

D MP2Code*2_mp_code*15*

D Fam*2_mp_fam*3*

D Sfm*2_mp_sfm*3*

D Long*2_mp_long*6*###&*

LONGUEUR_MAX_DETAIL

21,60 Longueur maximal du cadre Détail. La valeur par défaut est 200. Voir option Oxd

NTS

Voir notes V, D, E, F syntaxe 2

_SUP_REQ_SITE

Pouvoir restreindre la recherche en fonction du site associé à l'utilisateur

Tableau de bord du multisite

21,39 Nom de la colonne sur laquelle on fera le contrôle du site

Exemples

l2_site, ec_c1, b1_sitp, &

La recherche sera restreinte au site de production s'il est renseigné en USE A3[10,12], en construisant un complément de requête qui s'ajoutera à la sélection effectuée.

Exemple

Sur le USE, le site de production est 001

Paramétrage sur G_v_fle

_SUP_REQ_SITE l2_site

On obtiendra le complément de recherche suivant :

" and l2_site = '001'"

TSC_CA

Cascading pour les TSC dans les visualisations

La syntaxe est donnée dans la page intitulée Syntaxe d'appel dans les visualisations.

UTILISATION_LANG_CLI

Libellé étranger des codes paramètres

21 Utilisation de la langue du client (O/N, N par défaut)

Si oui, on recherche le libellé dans la table des libellés étrangers du code paramètre.

22 Code de la zone à prendre en compte pour la langue

Par défaut c'est la langue du client principal.

Dans la visualisation du devis onduleur et dans la visualisation des commandes clients, on a un enregistrement particulier pour le client livré; dans ce cas-là, on peut paramétrer le fait que l'on veut le libellé sur le client livré.

On mettra : p_cl_livraison.cl_langue

Auparavant, le libellé du code échéance pouvait être traduit dans les notes commençant par L, sur le paramètre ECH.

Ce principe est conservé dans la visualisation du devis onduleur.

La référence étrangère du code ensemble dans le devis onduleur est accessible dans la visualisation du devis via la colonne lib_etr_mp_ref_ens.

_VAR_

Ces notes définissent les variables utilisées dans les notes _CALC_

Il faut saisir ces notes sur les premières lignes afin d'optimiser le temps de recherche.

Caractère 6 : lettre utilisée dans la formule de la note _CALC_

Caractères 7,10 non utilisés (à blanc)

Caractères 11,60 Nom du champ à utiliser dans la formule (voir spécificité pour v_fle)

Exemple

_CALC_08 bc-a*

_VAR_a qtecde

_VAR_b prixvente

_VAR_c TSC_EC_NU_REM_C

La formule de calcul N° 8 peut donc s'écrire de la façon suivante, selon la notation "standard" :

(prixvente - TSC_EC_NU_REM_C) X qtecde

ATTENTION : certains programmes de visualisation ont leurs propres notes _VAR_, qui présentent des différences "locales".

_VCI_

Paramétrage de variables de calcul intermédiaire dans les visualisations

Ce paramétrage permet de :

" gérer correctement les cumuls des formules proratisées

" simplifier l'écriture des formules

6 Code variable (cette lettre sera utilisable comme variable dans les formules des notes commençant par _CALC_, ou dans une autre note commençant par _VCI_)

11,60 Formule de calcul en notation polonaise inversée

ou bien

Code formule de calcul sous la forme CALC_xx (où xx représente le numéro de formule de calcul).

La note commençant par _CALC_ doit exister.

Attention : la formule de calcul ne doit pas utiliser le code variable de la formule elle-même (la lettre définie en caractère 6).

Dans les notes commençant par V, D, E, F, un nouveau code colonne fait son apparition :

VCI_x : Affichage de la valeur de la variable de calcul intermédiaire x (résultat de la formule définie sur la note commençant par _VCI_x)

Mise en situation

Description des colonnes de visualisation :

Soit COL_1 une colonne de visualisation :

" liée à une formule calculée VAR_a / VAR_b

" dont le mode de cumul souhaité est O

Soit COL_2 une colonne de visualisation :

" liée à une variable simple VAR_c

" dont le mode de cumul souhaité est O

Soit COL_3 une colonne de visualisation :

" liée à une formule calculée VAR_a / VAR_b * VAR_c

" dont le mode de cumul souhaité est C

Paramétrage actuel pour l'exemple ci-dessus :

Variables de calcul

_VAR_a hp_z1

_VAR_b hp_z2

_VAR_c hp_z3

Formules de calcul

CALC_01 ab/

CALC_02 ab/c*

Colonnes de visualisation

V Colonne COL_1*CALC_01*12*########&.&&*O*

V Colonne COL_2*hp_z3*12*########&.&&*O*

V Colonne COL_3*CALC_02*12*########&.&&*C*

Principe de fonctionnement actuel des lignes de totalisation :

CUMUL(COL_1) = CUMUL(VAR_a / VAR_b)

CUMUL(COL_2) = CUMUL(VAR_c)

CUMUL(COL_3) = CUMUL(VAR_a) / CUMUL(VAR_b) * CUMUL(VAR_c)

Les colonnes de cumul sont systématiquement recalculées à partir des variables cumulées

Ainsi, le mode de cumul O défini pour la colonne COL_1 n'est pas utilisé pour la colonne COL_3

Principe de fonctionnement souhaité :

CUMUL(COL_1) = CUMUL(VAR_a / VAR_b)

CUMUL(COL_2) = CUMUL(VAR_c)

CUMUL(COL_3) = CUMUL(COL_1) * CUMUL(COL_2)

Soit :

CUMUL(COL_3) = CUMUL(VAR_a / VAR_b) * CUMUL(COL_2)

On veut repartir des résultats des cumuls des colonnes de visualisation COL_1 et COL_2 pour calculer la colonne COL_3, et ne pas repartir des variables cumulées.

Exemples

_VAR_a lc_qtecde --# Quantité ligne de commande

_VCI_b bc/ --# Prix de vente

_CALC_01 bc/ --# Prix de vente

Exemple de paramétrage pour l'exemple ci-dessus :

Variables de calcul

_VAR_a hp_z1

_VAR_b hp_z2

_VAR_c hp_z3

Variable intermédiaire de calcul

_VCI_D ab/

Formule de calcul

CALC_01 Dc*

Colonnes de visualisation

V Colonne COL_1*VCI_D*12*########&.&&*O*

V Colonne COL_2*hp_z3*12*########&.&&*O*

V Colonne COL_3*CALC_01*12*########&.&&*C*

Notes propres à la colorisation

Point commun de toutes notes : les caractères 6 à 8 indiquent le numéro de condition de colorisation.

Ce numéro doit correspondre à un numéro de condition saisi dans le champ 9 d'une ligne de note commençant par V.

Voir la fiche d'installation

_VCB_

6,8 Numéro de condition de colorisation.

Doit correspondre à un numéro de condition saisi dans le champ 9 d'une ligne de note commençant par V

Une seule ligne de note par numéro de condition

10,60 Nom du champ à utiliser comme valeur de base de comparaison.

On utilise comme valeur de base la valeur correspondant au champ paramétré, et non plus la valeur de la colonne conditionnée.

Remarques :

" Le nom du champ utilisé doit se trouver dans une ligne de note commençant par V ou D.

" Si toutefois vous désirez utiliser dans une condition un champ que vous ne voulez pas afficher dans la visualisation, vous pouvez paramétrer une ligne commençant par V avec une longueur à 0 (champ n°3)

IMPORTANT : Cette note est optionnelle.

Par défaut, la valeur de base est celle de la colonne en cours de colorisation (celle sur laquelle est paramétrée la condition).

_CEL_

_LIG_

_LTO_

_LTG_

Colorisation d'une cellule

Colorisation d'une ligne entière

Colorisation d'une ligne de totalisation intermédiaire

Colorisation d'une ligne de totalisation générale

Le paramétrage est quasiment identique sur chacune de ces 4 notes.

Les différences concernent :

- les lignes de totalisation intermédiaire (repérage sur fond vert dans ce paragraphe)

- la ligne de totalisation générale (repérage sur fond bleu dans ce paragraphe)

6,8 Numéro de condition de colorisation.

Doit correspondre à un numéro de condition saisi dans le champ 9 d'une ligne de note commençant par V

Plusieurs lignes de notes possibles pour un même numéro de condition (une ligne par condition à vérifier)

Si Numéro = 000, la colorisation de la ligne de totalisation n'est pas conditionnée à la valeur d'un champ.

Ce paramétrage permet de coloriser par défaut :

- les lignes de totalisation intermédiaire.

- la ligne de totalisation générale

10 Type de condition

V Valeur du dictionnaire

On compare la valeur de base à une autre valeur disponible dans la visualisation (nom de champ).

C Constante

On compare la valeur de base à la valeur constante paramétrée.

La constante peut aussi être paramétrée des façons suivantes :

TODAY

TODAY[Opérande][Nombre de jours]

TODAY[Opérande]CAL_[Nombre de jours]

TODAY[Opérande]CAL_[Code calendrier]_[Nombre de jours]

où

[Opérande] : + ou -

[Nombre de jours] : Nombre de jours à ajouter/supprimer à la date du jour

CAL_[Code calendrier] : Code calendrier Client/Employé. Par défaut : #SOC.

Exemples

TODAY-5 : Date du jour 5 jour

TODAY+CAL_2 : Date du jour + 2 jours ouvrés (calendrier société #SOC)

TODAY-CAL_CL052_15 : Date du jour 15 jours ouvrés (calendrier du client CL052)

Exemple de ligne de note

_CEL_001 C> TODAY+CAL_5 : Jaune4 reverse : Colorise le fond de la cellule en jaune si la date affichée est supérieure à la date du jour + 5 jours ouvrés (utilisation du calendrier société #SOC).

T On compare la couleur appliquée

- sur chaque ligne de détail concernée par la ligne de totalisation en cours

- sur chaque ligne de détail

On s'arrête dès que la condition est vérifiée.

B Blanc

On compare la valeur de base à la valeur nulle.

D Défaut

Pas de comparaison de valeur. Il s'agit ici de paramétrer la colorisation par défaut à appliquer si aucune condition n'est vérifiée.

Pour les notes LTO et LTG : Si la condition est associée à la première colonne de visualisation, la valeur de base sera le titre de la ligne de totalisation
Exemple : "> TOTAL Numéro commande 12060001"

11,60 Paramétrage de condition de colorisation.

Si caractère 10 = V : [Opérande][ ][Nom du champ][ ][:][ ][Code couleur]

Si caractère 10 = C : [Opérande][ ][Constante][ ][:][ ][Code couleur]

Si caractère 10 = T : [Opérande][ ][Code couleur][ ][:][ ][Code couleur]

Si caractère 10 = B : [:][ ][Code couleur]

Si caractère 10 = D :[:][ ][Code couleur]

où :

[:] : Le caractère deux points

[ ] : Le caractère espace

[Opérande] : Code opérande (voir annexe A ci-dessous)

[Nom du champ] : Nom du champ

[Constante] : Valeur de la constante

[Code couleur] : Couleur à appliquer (voir annexe B dans la fiche d'installation)

Un exemple

On souhaite coloriser la ligne 1 des commandes dans v_cdem.

Mais toutes les lignes de cadencement sont colorisées, il y a trop de vert.

On souhaite donc coloriser la ligne 1 des commandes uniquement pour la ligne 1 de cadencement (combinatoire).

Quand une condition est vérifiée, on s'arrête là (aucune autre condition n'est évaluée).

Dans l'exemple ci-dessous :

La ligne de commande est supérieure à 1, on met le texte en noir. On s'arrête.

La ligne de commande est inférieure ou égale à 1, on passe à la condition 2.

Paramétrage :

ANNEXE A : Liste des codes opérandes disponibles

Comparaison de zones alphanumériques

= La condition est vérifiée si la valeur de base est égale à la valeur paramétrée.

< La condition est vérifiée si la valeur de base est strictement inférieure à la valeur paramétrée.

> La condition est vérifiée si la valeur de base est strictement supérieure à la valeur paramétrée.

<= La condition est vérifiée si la valeur de base est inférieure ou égale à la valeur paramétrée.

>= La condition est vérifiée si la valeur de base est supérieure ou égale à la valeur paramétrée.

!= La condition est vérifiée si la valeur de base est différente de la valeur paramétrée.

&= La condition est vérifiée si la valeur de base contient la valeur paramétrée.

[= La condition est vérifiée si la valeur de base commence par la valeur paramétrée.

Comparaison de zones numériques

= La condition est vérifiée si la valeur de base est égale à la valeur paramétrée.

< La condition est vérifiée si la valeur de base est strictement inférieure à la valeur paramétrée.

> La condition est vérifiée si la valeur de base est strictement supérieure à la valeur paramétrée.

<= La condition est vérifiée si la valeur de base est inférieure ou égale à la valeur paramétrée.

>= La condition est vérifiée si la valeur de base est supérieure ou égale à la valeur paramétrée.

!= La condition est vérifiée si la valeur de base est différente de la valeur paramétrée.

Comparaison de zones de dates

= La condition est vérifiée si la valeur de base est égale à la valeur paramétrée.

< La condition est vérifiée si la valeur de base est strictement inférieure à la valeur paramétrée.

> La condition est vérifiée si la valeur de base est strictement supérieure à la valeur paramétrée.

<= La condition est vérifiée si la valeur de base est inférieure ou égale à la valeur paramétrée.

>= La condition est vérifiée si la valeur de base est supérieure ou égale à la valeur paramétrée.

!= La condition est vérifiée si la valeur de base est différente de la valeur paramétrée.

Noms de zone communs à toutes les visus

using

Ici, le mot-clé using indique que l'on veut mettre une constante.

Il n'a rien à voir avec le using utilisé pour le format d'affichage.

Syntaxe : V nomDeLaColonne*using*longueurColonne*constante*

Exemple

V X*using*1*X*

Dans cet exemple, le premier X indique le nom de la colonne (le nom qui apparaît dans l'entête de la colonne).

Le deuxième X est la constante (ici, un X que l'on place entre la longueur et la largeur).

Cette possibilité de mettre une constante existe dans (presque) toutes les visus sauf :

v_cde / v_eat / v_edi_cde_delfor / v_fab0 / v_fab3 / v_fac / v_tdv / v_tra

Tableau des touches de fonction

Les autorisations sur les touches de fonction se paramètrent dans la valeur Alpha 4 ou dans les notes AUTORISE_TOUCHE_F.

Les valeurs possibles sont les suivantes :

N Touche de fonction non autorisée

O Touche de fonction autorisée et accès en consultation

M Touche de fonction autorisée et accès en modification

Selon les visualisations, ces valeurs peuvent varier. Par exemple, la valeur M n'est valable que si la touche de fonction concerne une saisie.

Touche | Paramétrage | Fonction
F1 | A4[1] | Insertion (O/N, N par défaut)
F2 | A4[2] | Suppression (O/N, N par défaut)
F3 | A4[3] | Selon la visu
F4 | A4[4] | Selon la visu
F5 | A4[5] | Selon la visu
F6 | A4[6] | Selon la visu
F7 | A4[7] | Selon la visu
F8 | A4[8] | Selon la visu
F9 | A4[9] | Selon la visu
F10 | A4[10] | Selon la visu
F11 | A4[11] | Selon la visu
F12 | A4[12] | Selon la visu
F13 | A4[13] | Selon la visu
F14 | A4[14] | Selon la visu
F15 | A4[15] | Selon la visu
F16 | A4[16] | Selon la visu
F17 | A4[17] | Selon la visu
F18 | A4[18] | Selon la visu
F19 | A4[19] | Selon la visu
F20 | A4[20] | Selon la visu
F21 | A4[21] | Selon la visu
F22 | A4[22] | Selon la visu
F23 | A4[23] | Selon la visu
F24 | A4[24] | Selon la visu
F25 | A4[25] | Selon la visu
F26 | A4[26] | Selon la visu
F27 | A4[27] | Selon la visu
F28 | A4[28] | Selon la visu
F29 | A4[29] | Selon la visu
F30 | A4[30] | Selon la visu
F31 | A4[31] | Selon la visu
F32 | A4[32] | Selon la visu
F33 | A4[33] | Selon la visu
F34 | A4[34] | Selon la visu
F35 | A4[35] | Selon la visu
F36 | A4[36] | Selon la visu
F37 | AUTORISE_TOUCHE_F37 | Selon la visu
F38 | A4[58] | Selon la visu
F39 | A4[59] | Selon la visu
F40 | A4[60] | Selon la visu
F41 | AUTORISE_TOUCHE_F41 | Selon la visu
F42 | AUTORISE_TOUCHE_F42 | Selon la visu
F43 | AUTORISE_TOUCHE_F43 | Selon la visu
F44 | AUTORISE_TOUCHE_F44 | Selon la visu
F45 | AUTORISE_TOUCHE_F45 | Selon la visu
F46 | AUTORISE_TOUCHE_F46 | Selon la visu
F47 | AUTORISE_TOUCHE_F47 | Selon la visu
F48 | AUTORISE_TOUCHE_F48 | Selon la visu
F49 | AUTORISE_TOUCHE_F49 | Selon la visu
F50 | AUTORISE_TOUCHE_F50 | Selon la visu
F51 | AUTORISE_TOUCHE_F51 | Selon la visu
F52 | AUTORISE_TOUCHE_F52 | Selon la visu
F53 | AUTORISE_TOUCHE_F53 | Selon la visu
F54 | AUTORISE_TOUCHE_F54 | Selon la visu
F55 | AUTORISE_TOUCHE_F55 | Selon la visu
F56 | AUTORISE_TOUCHE_F56 | Selon la visu
F57 | AUTORISE_TOUCHE_F57 | Selon la visu
F58 | AUTORISE_TOUCHE_F58 | Selon la visu
F59 | AUTORISE_TOUCHE_F59 | CONTROL-A - Selon la visu
F60 | AUTORISE_TOUCHE_F60 | Accès à la fenêtre de fax/email
F253 | AUTORISE_TOUCHE_F253 | Selon la visu
F254 | AUTORISE_TOUCHE_F254 | Selon la visu
CONTROL-B | A4[37] | Selon la visu
CONTROL-C | A4[38] | Calculatrice (O/N, O par défaut)
CONTROL-E | A4[39] | Selon la visu
CONTROL-F | A4[40] | Selon la visu
CONTROL-G | A4[41] | Selon la visu
CONTROL-I | A4[42] | Selon la visu
CONTROL-J | A4[43] | Lancement paramétrable de programmes
CONTROL-K | A4[44] | Selon la visu
CONTROL-M | A4[45] | Selon la visu
CONTROL-N | A4[46] | Selon la visu
CONTROL-O | A4[47] | Selon la visu
CONTROL-P | A4[48] | Selon la visu
CONTROL-Q | A4[49] | Selon la visu
CONTROL-S | A4[50] | Selon la visu
CONTROL-T | A4[51] | Aide sur les touches de fonctions (O/N, O par défaut)
CONTROL-U | A4[52] | Selon la visu
CONTROL-V | A4[53] | Selon la visu
CONTROL-W | A4[54] | Selon la visu
CONTROL-Y | A4[55] | Selon la visu
CONTROL-Z | A4[56] | Lancement de programmes (O/N, O par défaut)


Exports vers Excel

Sous GENERO, tous les programmes de visualisation permettent un export vers Excel, ainsi que le programme de valorisation des stocks.

Vous pouvez aussi consulter le guide d'installation et d'utilisation : ExportExcel_fr.pdf sur le CD de mise à jour.

Vous devez créer le paramètre de configuration #CF VMC :

• Libellé long : Configuration VMC

• Libellé court : Config VMC

• Pas de paramétrage particulier

Pour pouvoir transférer les couleurs vers Excel il est nécessaire d'avoir au minimum la version 2.0 de VMC.

Cela implique la présence de la note _EXCEL_VMC_VERSION 2.0, soit au niveau du lanceur, soit dans le #CF/ATL.

Gestion des options

Activez l'option payante WIN 3 pour les programmes de visualisation.

Activez l'option payante WIN 4 pour le programme de valorisation des stocks (valst)

Ceci permet l'export Excel pour tous les utilisateurs et tous les programmes concernés.

Vous pouvez restreindre cette fonctionnalité à des (groupes d')utilisateurs via la gestion des permissions (TOU EXCEL).

Par défaut, l'export vers Excel est systématiquement autorisé.

Cependant, vous pouvez l'interdire dans certains programmes.

Pour ce faire, dans le paramètre de lancement du programme de visualisation concerné, créez la note AUTORISE_TOUCHE_F254 avec un N en caractère 21.

Par défaut, les lignes de totalisation sont envoyées à Excel.

Vous pouvez ne pas les envoyer, ou bien faire en sorte que la question soit posée à chaque fois.

Pour ce faire, dans le paramètre de lancement du programme de visualisation concerné, créez la note suivante _EXCEL_ENVOI_TOTAL avec, en caractère 21, l'un des 3 codes suivants :

• O Envoi des lignes de totalisation

• N Pas d'envoi des lignes de totalisation

• Q La question est posée lors de l'export

Remarques valables pour les programmes de visualisation :

• Si vous demandez d'abord une visualisation écran, puis, à partir de là, un export Excel, l'export se fera selon le mode V (notes commençant par V).
Si vous changez l'ordre de tri et / ou des colonnes dans VoluPack / VoluPrim, ce changement ne sera pas répercuté dans l'export Excel.

• Si vous demandez directement un export Excel, l'export se fera selon le mode E (notes commençant par E).

• Si un mode n'est pas paramétré, le programme recherche d'abord le mode V, puis le mode E, puis le mode F.
Ceci est vrai aussi bien pour les éditions standards que pour les exports Excel.

Remarque valable pour le programme de valorisation des stocks :

• Vous pouvez paramétrer un –Ww (double-v majuscule suivi de double-v minuscule) dans le paramètre de lancement afin de permettre l'export direct vers Excel.
Dans le cas contraire, la fenêtre classique de choix de périphérique s'affichera, proposant, entre autres, l'export Excel.

Notes du paramètre de lancement de la visualisation (#VI]

_EXCEL_DATE_EXPORT

21 Ajout de la date et de l'heure de l'export Excel entre le titre du document et les critères de la requête (O/N, N par défaut)

Ces in formations sont situées en entête du tableau exporté.

Cette note est prioritaire sur celle du #CF ATL.

_EXCEL_ENVOI_TOTAL

Envoi d'une totalisation vers Excel

Envoi vers Excel des lignes de totalisations (O/N/Q, O par défaut)

O Envoi des lignes de totalisation

N Pas d'envoi des lignes de totalisation

Q On pose la question de l'envoi

Nécessite la version 1.2.3 de VMC

_EXCEL_FORMAT

21,24 Format de fichier

XLSX (à partir de Microsoft Excel 2007) (par défaut.)

Cette note est prioritaire sur celle du #CF ATL

_EXCEL_MACRO_QUIT

Lors d'un envoi vers Excel avec une macro, permet de quitter Excel en fin de traitement (O/N, N par défaut)

Nécessite la version 1.2.3 de VMC

_EXCEL_NOM_FIC

21,60 Nom du fichier Excel

Exemple : liste_cde_client.xlsx

Cette note n'a pas d'équivalent dans le #CF ATL.

_EXCEL_NOM_MACRO

21,60 Nom de la macro Excel à exécuter

Elle doit être inscrite dans un fichier .xlam

Nécessite la version 1.2.3 de VMC. Voir le guide de l'administrateur de Volume Media Center pour de plus amples informations.

Note : Pour enchaîner plusieurs programmes, il faut utiliser la note ENVOI_PROG_AFTER sur la première visualisation.

_EXCEL_QUIT

21 A la fin de la création d'un fichier Excel, permet de quitter Excel en fin de traitement (O/N, N par défaut)

Cette note n'a pas d'équivalent dans le #CF ATL.

_EXCEL_REPERTOIRE

21,60 Nom du répertoire où sera déposé le fichier Excel généré (facultatif)

Par défaut, le répertoire est renseigné dans VMC.

Exemple : d:\doc\

Cette note est prioritaire sur celle du #CF ATL.

_EXCEL_VMC_VERSION

21,23 Numéro de version de VMC

1.8 ou vide (par défaut)

2.0

Cette note est prioritaire sur celle du #CF ATL.

Pour pouvoir transférer les couleurs vers Excel il est nécessaire d'avoir au minimum la version 2.0 de VMC.

Cela implique la présence de la note _EXCEL_VMC_VERSION 2.0, soit au niveau du lanceur, soit dans le #CF/ATL.

Ces nouvelles fonctionnalités nécessitent la version 2.0 de VMC.

Il n'est plus nécessaire d'avoir Microsoft Excel ou OpenOffice installé pour générer un fichier Excel.

Selon le paramétrage, un fichier de type XLSX (à partir de la version Microsoft Excel 2007) est créé et déposé dans le répertoire de votre choix.


v_action_evt Visualisation des actions - événements

Ce programme est disponible à partir de la V. 4.0.170.2

Il a été créé pour la gestion des actions événements (voir #CF EVT).

Évolutions

La version 4.0.182.2 apporte les améliorations suivantes :

• trier par clé d'enregistrement (action_evt.ace_cle)

• trier par numéro de ligne (action_evt.ace_ligne)

• lancer une action multiple permettant de modifier l'état, la priorité et/ou la date d'échéance d'une action - événement

• réactualiser la visualisation manuellement ou automatiquement après une modification

• afficher un libellé paramétrable pour le type d'action (action_evt.ace_type)

• épurer tous les enregistrements annulés logiquement présents dans la sélection

La gestion des actions - événements nécessite l'option payante BAS/31 (Gestion des actions événements, anciennement Traçabilité sur actions événements).

Options

Orv

On passe le N° d'OF en argument, sous la forme suivante :

- Caractères 1 à 8 = numéro de l'offre

- Caractère 9 = tiret

- Caractères 10 à 12 = ligne de l'offre (using ‘&&&')

Valeur alpha 4

A4[5] | F5 : Réactualisation manuelle de la visualisation activée (O/N, N par défaut)
A4[14] | F14 : Epuration des enregistrements annulés logiquement activée (O/N, N par défaut) Cette action peut être limitée via la permission TOU/VACTIONEVT_F14
A4[43] | Control-J : Lancement paramétrable de programmes activé (O/N, N par défaut)
A4[44] | Control-K : Lancement paramétrable multiple de programmes/actions activé (O/N, N par défaut) Cette action nécessite la présence de la note _CSEL (voir ci-dessous)
A4[47] | Control-O : Accès à la visualisation de la traçabilité activée (O/N, N par défaut)
A4[54] | Control-W : Ouverture du fichier associé à l'action activée (O/N, N par défaut)

Paramètres nécessaires

#CF EVT | Configuration des actions et des événements
#RP | Notes commençant par LCT_MULTI_ pour lancer une action multiple permettant de modifier l'état, la priorité et/ou la date d'échéance d'une action événement

Notes

_CSEL

Affichage de la colonne de sélection (colonne de droite)

Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement. Voir #RP

DIRECT_PLANNING_CFG

21,23 Code paramètre de configuration de l'interface Direct Planning (par défaut : DP2)

Voir le chapitre #CF DP2

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Voir le chapitre #CF DP2

DIRECT_PLANNING_TRF

21 Activation du transfert vers Direct Planning (O/N, N par défaut)

Voir le chapitre #CF DP2

GRW_CONFIG

Active les éditions avec Genero Report Writer

21,23 Code paramètre de type GRW (configuration des éditions)

24,26 Code paramètre de type GRV (configuration des variables additionnelles dans le catalogue)

GRW_MAX_LIGNES

Configuration pour bloquer le nombre de lignes à l'édition

21 Par type de sortie

N Toutes les sorties (par défaut)

I Sortie sur imprimante directe

22 Pour le type de blocage

N Pas de blocage

C Sur confirmation (avec messages de confirmation paramétrable, voir ci-dessous la note GRW_LIGNES_MSG_)

B Blocage

23,26 Nombres de lignes autorisées

Exemple

GRW_MAX_LIGNES IB100

Bloque à 100 lignes pour les sorties sur imprimante directe

GRW_LIGNES_MSG_X

Configuration des messages pour le blocage avec confirmation

X peut prendre les valeurs 1 à 4

Messages par défaut :

Ligne 1 : Attention

Ligne 2 : Voulez-vous réellement éditer plus de n lignes ?

Ligne 3 :

Ligne 4 :

21,60 Texte de la ligne de message

Exemple

GRW_LIGNES_MSG_1 Attention

GRW_LIGNES_MSG_2 Plus de 100 lignes

GRW_LIGNES_MSG_3 ???

GRW_LIGNES_MSG_4

GRW_LIGNES_SPECIF

Masquage de lignes lors de l'édition par GRW

21 Masquer les lignes de totalisation (O/N, Non par défaut)

22 Masquer les lignes de séparation (O/N, Non par défaut)

23 Masquer les lignes non remplies (O/N, Non par défaut)

LCT_MULTI_CONFIG

21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

NOTES_ACTION_EVT

Liste des codes NTS accessibles en saisie de notes pour les actions (paramétrage équivalent au –C)

Exemple 3CLI2QA

_SUP_REQ_ACT_EVT

21,60 Complément de sélection sur la table action_evt

Ce complément a la particularité de pouvoir recevoir une valeur d'une zone de table de la visualisation.

Les noms des champs sont encadrés par des crochets [ ]

Le using est précédé du +.

Exemple : nous souhaitons lors de l'action Saisie des actions affiche uniquement le numéro de flux sélectionné.

Le complément de sélection sera construit de la manière suivante :

_SUP_REQ_ACT_EVT and ace_nom_flux = "[ace_nom_flux]"

(les guillemets sont obligatoires dans ce cas car c'est une zone alphanumérique).

_SUP_REQ_PAR02_EVT

21,60 Complément de requête sur la table par02 pour restreindre les actions événements (type EVT)

TIC_ACTION_EVT

Liste des codes TIC accessibles pour les actions (paramétrage équivalent au –D)

Noms de zones autorisés : Les packages suivants :

Actions - événements

Affaires

Affaires avec le numéro de flux

Le flux est stocké dans la zone ace_nom_flux de la table action_evt.

Faire précéder la zone de flu_.

Exemple

flu_af_num_affaire

Commandes Clients - Entête

Commandes Clients - Lignes

Correspondants

Devis, Sous-Devis

Entités du Devis

Matières

Tiers

et les zones suivantes :

using - Voir #VI

Critères de tri disponibles

01 Origine de l'action

02 Code état

03 Code étape

04 Code action

05 Client

06 Produit

07 Date d'échéance

08 Menée par

09 Clé de l'enregistrement

10 Numéro de ligne


v_action_mat Visualisation des actions outillage

G_v_action_mat Visualisation des actions outillage

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro d'action outillage

Exemple : -N[acm_num]

Valeur alpha 4

Ceci est un début de liste - Liste incomplète

A4[37]

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Tables accessibles

Toutes les zones du package Tiers

action_mat

cde1

cde2

mat

cdf1

cdf2

mac0

et les zones suivantes :

using - Voir #VI


v_brc Visualisation des bons de réception / retour

Visualisation des bons de réception / retour v_brc

Ce programme est accessible à partir de la V.4.0.163.2

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_LIN

Argument : Numéro de lot industriel (appel depuis le programme de visualisation des lots industriels)

Exemple : -N_LIN[lin_lot_indus]

Options

v_brc Orv

Rafraîchissement automatique de la visualisation (après modification d'un bon de réception, par exemple)

Valeur alpha 2

v_brc A2 [2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
v_brc A2 [3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)
v_brc A2 [11] | Edition des lignes d'articles non suivi en stock (O/N, N par défaut)

Valeur alpha 3

v_brc A3 [1,60]

Titre de la visu

Valeur alpha 4

v_brc A4 [8] | Autorisation d'accès à la saisie des bons de réception (touche F8) O Accès en modification à la saisie des bons de réception N Pas d'accès à la saisie des bons de réception (par défaut)
v_brc A4 [20] | Autorisation d'accès à la saisie des informations complémentaires (TSC) (Touche : F20/Shift-F8) O Accès en consultation M Accès en modification N Pas d'accès Remarque Un menu permet de sélectionner l'origine des informations complémentaires : Entête ou ligne de bon de réception.
v_brc A4 [21] | Autorisation d'accès au raccourci n°1 du lancement paramétrable des programmes (Touche : F21/Shift-F9) (O/N)
v_brc A4 [22] | Autorisation d'accès au raccourci n°2 du lancement paramétrable des programmes (Touche : F22/Shift-F10) (O/N)
v_brc A4 [25] | Autorisation d'accès au rafraîchissement de la visualisation (touches Ctrl+Maj+F1) (O/N, N par défaut)
v_brc A4 [43] | Autorisation d'accès au lancement paramétrable des programmes (Touche : Control-J) (O/N)

Notes

V E D F | 3,60 Paramétrage standard des visus - Voir #VI - Voir ci-dessous la liste des zones disponibles.
O | 3,60 Tris disponibles 01 bre_bon Numéro de bon de réception 02 brd_lig Ligne de bon de réception 03 bre_type_bon Type de bon de réception (réception/retour) 04 bre_date_bon Date du bon de réception 05 bre_four Code fournisseur 06 bre_preparateur Code préparateur 07 brd_cde Numéro de commande fournisseur 08 brd_ligcde Ligne de commande fournisseur 09 brd_ligcad Cadencement de commande fournisseur 10 ef_tyc Type de commande fournisseur 11 ef_ach Code acheteur de la commande fournisseur 12 s0_lot Numéro de lot de l'entrée normale de la ligne de bon de réception
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
PARAM_SAISIE_BRC | 21,26 Type de code du paramètre de lancement de la saisie des bons de réception
_SUP_REQ_B_REC_RET_D | 21,60 Complément de sélection sur la table de détail des bons de réception (b_rec_ret_d)
_SUP_REQ_B_REC_RET_E | 21,60 Complément de sélection sur la table d'entête des bons de réception (b_rec_ret_e)
_SUP_REQ_CDF | 21,60 Complément de sélection sur la table d'entête des commandes fournisseurs (cdf1)
_SUP_REQ_CDF2 | 21,60 Complément de sélection sur la table des lignes des commandes fournisseurs (cdf2)
_SUP_REQ_CDF4 | 21,60 Complément de sélection sur la table des cadencements de livraison des commandes fournisseurs (cdf4)
_SUP_REQ_FACFOU0 | 21,60 Complément de sélection sur la table des factures fournisseurs (facfou0)
_SUP_REQ_MAT | 21,60 Complément de sélection sur la table des articles (mat, article du détail des bons de réception)
_SUP_REQ_STK0 | 21,60 Complément de sélection sur la table des stocks (stk0, mouvement d'entrée normale du détail des bons de réception)

Noms de zones autorisés

Toutes les zones des packages suivants :

Bons de Réception et de Retour - Entête

Bons de Réception et de Retour - Lignes

Cadencements de Livraison Fournisseurs

Commandes Fournisseurs - Entête

Commandes Fournisseurs - Lignes

Factures Fournisseurs - Entête

Matières

Mouvements de Stock

Package suiv_vehicule

Package cli pour le fournisseur à l'origine de la livraison.

Package cde2 (lignes de commande client)

Toutes les zones numériques sont cumulables et disponibles dans le dictionnaire de données.

Autres zones

pour_brd_certification Pourcentage de la certification du code certification de la ligne du bon de réception/retour de marchandises

poids_tot_certif Poids total des bobines certifié du bon de réception

lf_solde_num = lf_solde mais en numérique (utile pour des formules de calcul)


v_cde_5 Visualisation des besoins matières

Options

Oad | Affichage de la totalité des informations dans les lignes similaires de l'édition
Oaf | L'affectation commence toujours par commande-ligne. Si présence d'une séquence, alors l' affectation devient : commande-ligne/séquence Sinon, elle devient commande-ligne/1
Oca | Recopie dès le chargement de l'écran des notes sur le besoin Il est nécessaire d'avoir mis en place l'option Ocm ou Ocd
Ocd | Recopie des notes depuis le devis (clé devis-sous/devis) sur les besoins matières Même paramétrage que pour la recopie des notes depuis mat3. incompatible avec l'option Ocm. Le type de note indiqué dans LIST_TYPE_NOTE_A_REC peut être aussi paramétré avec le même type de note mais sur la famille et/ou sous-famille de la qualité carton. Voir aussi #CF SMC A1[33]
Ocf | Lancement automatique de la génération des commandes fournisseurs Créer des notes CHOIX_TYPE_NOTES et ACCES_GENCDEF
Ocm | Recopie automatique des notes saisies sur la matière dans celle des besoins matières
Ocp | Contrôle plaque On vérifie si les données techniques de cette plaque sont bien conformes à la demande.
Odc | Demande de confirmation pour appliquer le nouveau prix après un changement du fournisseur, délai ou quantité
Odj | Dans la modification de l'état du besoin, le délai doit être supérieur à la date du jour - GENERO uniquement
Opt | Dans la modification de l'état des besoins (touche F11 sur la visualisation des besoins), ne plus utiliser la recherche de tarif
Oqn | Quantité prise sur stock égale à la quantité nécessaire
Orf | Rafraîchir la visualisation (relance avec la même sélection) après le traitement par F11

Valeur alpha 2

Les caractères 1 à 30 sont réservés à des options standards

Les caractères 31 à 60 sont réservés à des options spécifiques

Caractère 1 | Second écran de sélection (O/N) ? (N par défaut) (Disponible suivant les cas)
Caractère 2 | Ouverture fenêtre de tri (O/N) ? (N par défaut)
Caractère 3 | Edition sans les lignes de détails si rupture et cumul (O/N, N par défaut)
Caractère 4 | Edition des notes saisies sur l'article (O/N)
Caractère 9 | Edition d'un état destiné aux clients (O/N) (N par défaut) (actif uniquement dans la visualisation des articles et des stocks)
Caractère 10 | Lancement du programme en Batch (E/F) E Edition F Fichier (actif uniquement sur la visualisation des commandes et des stocks)
Caractères 31 à 33 | Type paramètre imprimante (Exemple #LP)
Caractères 34 à 36 | Code paramètre imprimante (Exemple BES)
Caractère 37 | Code contrôle de la zone prix N pas de contrôle W Warning B Bloquant (par défaut) C Confirmation
Caractère 38 | Type de contrôle de cohérence entre matière refoulée et présence de pointages N Pas de contrôle [valeur par défaut] W Fenêtre de warning C Demande de confirmation B Contrôle bloquant
Caractères 39 et 40 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 41 à 43 | Type de notes des lignes produits (Exemple ACH) Voir la note LIST_TYPE_NOTE_A_REC
Caractères 44 à 46 | Type de notes des besoins matières (Exemple ACH) Voir aussi #CF SMC A1[34,36]
Caractères 47 à 52 | Type et code du paramètre de lancement pour la configuration de la visualisation des tarifs par la touche F8 (pour visualiser les tarifs de la qualité du carton utilisé - uc_qualite_carton de la table cde5) Exemple : #CFTQA
Caractère 53 | Génération de la commande d'achat dès la validation par F11 (N par défaut) N pas de génération (elle sera faite au F10) W demande de confirmation de la génération (ne sera pas faire au F10) O lancement de la génération (ne sera pas faite au F10) L'option Ocf est nécessaire.
Caractère 54 | Méthode de mise à jour du besoin matière détaillé par dossier (F/P, F par défaut) Voir #CF-ATL A1[44] F Ouverture de la fenêtre (F14) P Proratisation des quantités du détail
Caractère 55 | Lancement automatique de la génération de commandes d'achat sans question de validation (O/N, N par défaut)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES BESOINS MATIERES

Valeur alpha 4

Paramétrage de l'accès aux touches de fonction

Sauf mention contraire spécifiée pour les touches de fonction, chaque caractère représente une touche de fonction (par exemple le caractère 6 représente la touche F6).

Pour chaque touche de fonction, les valeurs suivantes sont proposées :

N | Touche de fonction non autorisée (par défaut)
O | Touche de fonction autorisée pour accès en consultation
M | Touche de fonction autorisée pour accès en modification

Caractère 6 | F6 (O/N/M)
Caractère 8 | F8 Visualisation des tarifs (O/N) - Permission : TOU - V_CDE5_F8
Caractère 9 | F9 Saisie des matières consommées pour les cartonniers (O/N/M)
Caractère 11 | F11 Modification de l'état du besoin (N/O)
Caractère 12 | F12 (N/O/M)
Caractère 14 | F14 (O/N)
Caractère 15 | F15
Caractère 16 | F16
Caractère 17 | F17
Caractère 18 | F18
Caractère 19 | F19
Caractère 20 | F20 Accès aux informations complémentaires sur article PF (O/N/M)
Caractère 21 | F21 Accès aux informations complémentaires de l'ensemble (O/N)
Caractère 22 | F22 Accès aux informations complémentaires sur article plaque (O/N/M)
Caractère 24 | (O/N/M)
Caractère 37 | CTRL-B (O/N)
Caractère 38 | CTRL-C (O/N)
Caractère 39 | CTRL-E (O/N)
Caractère 46 | CTRL-N Accès aux notes (O/N/M)
Caractère 48 | CTRL-P Accès au stock (O/N)
Caractère 51 | CTRL-T (O/N)
Caractère 52 | CTRL-U (O/N)
Caractère 56 | CTRL-Z (O/N)

Notes

ACCES_BES_AUTORISE

Avec la nouvelle gestion (depuis le devis standard), pouvoir quand même accéder à l'ancienne grille de saisie des besoins (via le F9)

21 O/N

ACCES_GENCDEF

21,26 Type et code lancement de gen_cdef (exemple #SAGCF)

BORNES_DONNEE_TEC_

Contrôles des valeurs saisies par rapport à des bornes minimum/maximum

19 Numéro de donnée technique (1 à 4)

21,30 Valeur minimum (999999.999)

32,41 Valeur maximum (999999.999)

Ce fonctionnement est valable pour les programmes suivants

Saisie des commandes d'achat (cdef)

Saisie des inventaires (inventaire)

Saisie des devis multi-métiers (devis_standard)

Saisie des matières (mat)

Visualisation des besoins matières (ici)

Le paramétrage de contrôle sera recherché dans l'ordre suivant

1. Famille de la qualité matière

2. Type de commande d'achat (saisie des commandes d'achat uniquement)

3. Paramètre de lancement du programme (ici)

CHOIX_TYPE_NOTES

21,23 Type de notes (exemple ACH)

CODE_BESOIN_SMC

21,23 Code paramètre de configuration des sorties matières consommées

Le type de paramètre est figé à #CF.

Paramétrage optionnel, par défaut : SMC

DONNEE_TECH_1_OBLIG

DONNEE_TECH_2_OBLIG

DONNEE_TECH_3_OBLIG

DONNEE_TECH_4_OBLIG

Vérification des données techniques. Dans les 4 cas, les valeurs possibles sont : O/N, N par défaut

Lors du passage en commande du besoin, la donnée technique 1 est obligatoire (uc_coupe_brute)

Lors du passage en commande du besoin, la donnée technique 2 est obligatoire (uc_laize_brute)

Lors du passage en commande du besoin, la donnée technique 3 est obligatoire (uc_hauteur)

Lors du passage en commande du besoin, la donnée technique 4 est obligatoire (uc_poids)

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

LIBELLE_TECHNIQUE_n

où n peut prendre les valeurs 1 à 4

21,40 Libellé technique n

Cette note est recherchée en priorité dans le TYF.

LIST_TYPE_NOTE_A_REC

21,23 Type de note de mat3 que l'on veut recopier

Actuellement, on peut paramétrer le type de note source en A2[41,43].

On peut maintenant recopier les notes de types différents, et ne plus se limiter à un seul type.

Si cette liste est paramétrée, elle prend le pas sur le paramétrage initial.

Conserver l'option Ocm.

Ce paramétrage existe aussi sur la famille, la sous-famille et la configuration de la saisie des matières consommées.

METHODE_RECH_PLAQUE

21 Méthode de recherche des plaques

I format impression (par défaut)

P format plaque

D format découpe

F format feuille

Q Format plaque avec cumul avec les poses impression

MODE_CALCUL_RECH_MAT

21 Mode de calcul de recherche des matières

N normal (valeur par défaut)

B bobine

PARAM_TARIF_PLAQUE

21,26 Type et code du paramètre de configuration de la recherche des tarifs sur la plaque à commander

Jusqu'à présent, la recherche des tarifs réalisée dans le traitement des besoins matière ne pouvait se faire que sur la qualité matière du besoin.

Maintenant, on peut faire une première recherche sur le code plaque commandé (si déjà existant) puis sur le code produit de la ligne de commande, puis finalement sur la qualité matière.

PARAM_TARIF_PRODUIT

21,26 Type et code du paramètre de configuration de la recherche des tarifs sur le produit commandé à l'origine du besoin

Voir la remarque ci-dessus, sur la note PARAM_TARIF_PLAQUE.

RELIQUAT_CONFIR_SYST

21 Confirmation systématique du reliquat (O/N, N par défaut)

On ne pose plus la question du reliquat, la confirmation est systématique.

_SUP_REQ_GEN_M_UTIL

21,60 Complément de requête sur la table mat, pour indiquer que le code matière doit être régénéré si la condition est respectée.

UNITE_SURFACE_FEFCO

21,23 Unité de calcul de la surface du FEFCO (Code dimension SUR)

M2 : surface unitaire calculée en mètre carré

MM2 : surface unitaire calculée en millimètre carré (valeur par défaut)

Utilisé pour la mise à jour du poids de la ligne de commande par la saisie des besoins (#CF SMC A2[3] et A2[5])

USING_QUANTITE

21, 30 Using à utiliser pour l'affichage du décimal

Exemple : &&&.&&

XCLI1

21,60 Complément de requête pour la recherche des tiers

Fonctionne comme la note SCLI1 (voir les généralités), mais la fenêtre de sélection sera ignorée.

ZON_TECH2_EN_PREMIER

21 Saisir la longueur (donnée technique 2) en premier lors de la touche F32 (modification du besoin) (O/N)

22 Uniquement si caractère 21 = O :

Inversion laize/coupe en recherche de matière en stock (F11 puis Sur stock) (O/N, O par défaut)

N Il n'y a pas d'inversion laize/coupe en recherche de matière en stock.

23 Uniquement si caractère 21 = O :

Inversion laize/coupe en passage en commande lors du traitement du besoin (O/N, N par défaut)

Ordres de tris disponibles

Voir les notes commençant par O

01 | num_cde (numéro de commande)
02 | code_cli (code client)
03 | état (état du besoin matière )
04 | profil (profil carton)
05 | qualité (qualité carton)
06 | plaque (code matière consommée)
07 | fournisseur (fournisseur de la matière à commander)
08 | refoule (matière refoulée)
09 | date_dispo (date de disponibilité matière souhaitée)
10 | delai_rep (délai de réponse client)
11 | laize_brute (laize brute)
12 | priorite (niveau de priorité)
13 | lig_cde (numéro de ligne)
14 | sequence_cde (numéro de séquence dans cde4)
15 | date_creation (date de création du besoin)
16 | code_fam (code famille)
17 | code_sfam (code sous-famille)
18 | Date de commande des matières premières au plus tard (uc_date_plus_tard)

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Table cde_5

Package Entêtes de commandes (cde1)

Package Lignes de commandes (cde2)

Tiers

Table cdf2

Package Matières/Articles/Produits

l Les noms de zones peuvent être précédés de x_ où x peut prendre les valeurs de 1 à 5.

l Pour l'article fabriqué de la ligne de besoins matières, les noms de zones se terminent par _cde5.

Exemples : mp_code_cde5, mp_des_cde5, libl_mp_fam_cde5

l Pour la qualité carton de la ligne de besoins matières, les noms de zones se terminent par _uc_qual_car.

Exemples : mp_code_uc_qual_car, mp_des_uc_qual_car, libl_mp_fam_uc_qual_car

l Pour la matière consommée de la ligne de besoins matières, les noms de zones se terminent par _uc_mat_util.

Exemples : mp_code_uc_mat_util, mp_des_uc_mat_util, libl_mp_fam_uc_mat_util

Divers

Gestion spécifique des TSC

Table cde_5

uc_soc | Code société
uc_num | Numéro de commande
uc_lig | Numéro de ligne
uc_lig_mat | Numéro de ligne consommation matière
uc_seq_ensemble | Numéro de séquence commande dans CDE4
uc_article_fab | Code article fabriqué
mp_des_cde5 | Désignation de l'article fabriqué (cde5)
uc_etat | Etat du besoin matière (A, T, C, S, etc.)
uc_qualite_carton | Qualité carton
uc_profil_carton | Profil carton
uc_mat_util | Code matière consommée
uc_qte_util | Quantité de matière utilisée
uc_nb_pos_laize | Nombre de pose laize en découpe
uc_nb_pos_coupe | Nombre de pose coupe en découpe
uc_rogne_laize_dec | Rogne de laize en découpe
uc_rogne_coupe_dec | Rogne de coupe en découpe
uc_laize_dec | Laize du format de découpe
uc_coupe_dec | Coupe du format de découpe
uc_surf_dec | Surface découpe unitaire
uc_laize_uni | Laize unitaire
uc_coupe_uni | Coupe unitaire
uc_surf_uni | Surface unitaire
uc_pos_laize_imp | Nombre de poses laize en impression
uc_pos_coupe_imp | Nombre de poses coupe en impression
uc_rogne_laize_imp | Rogne de laize en impression
uc_rogne_coupe_imp | Rogne de coupe en impression
uc_laize_imp | Laize du format impression
uc_coupe_imp | Coupe du format impression
uc_surf_imp | Surface impression unitaire
uc_pos_laize_nette | Nombre de poses laize sur la feuille
uc_pos_coupe_nette | Nombre de poses coupe sur la feuille
uc_rogne_laize_net | Rogne de laize feuille
uc_rogne_coupe_net | Rogne de coupe feuille
uc_laize_nette | Laize du format feuille
uc_coupe_nette | Coupe du format feuille
uc_surf_nette | Surface unitaire feuille
uc_surf_nette_tot | Surface feuille totale
uc_laize_brute | Laize brute
uc_coupe_brute | Coupe brute
uc_surf_brute | Surface brute unitaire
uc_surf_brute_tot | Surface brute totale consommée
uc_surf_brute_cde | Surface brute totale commandée
uc_num_stk | Numéro de mouvement de stock associé à la consommation
uc_fournisseur | Fournisseur de la matière à commander
uc_qte_cde | Quantité de matière à commander
uc_prix_ua | Prix d'achat
uc_ua | Unité d'achat
uc_date_dispo | Date de disponibilité souhaitée matière
uc_refoule | Matière refoulée (O/N)
uc_ds1 | Dimensions spécifiques 1
uc_ds2 | Dimensions spécifiques 2
uc_ds3 | Dimensions spécifiques 3
uc_ds4 | Dimensions spécifiques 4
uc_ds5 | Dimensions spécifiques 5
uc_ds6 | Dimensions spécifiques 6
uc_ds7 | Dimensions spécifiques 7
uc_ds8 | Dimensions spécifiques 8
uc_ds9 | Dimensions spécifiques 9
uc_ds10 | Dimensions spécifiques 10
uc_ds11 | Dimensions spécifiques 11
uc_ds12 | Dimensions spécifiques 11
uc_date_creation | Date de création du besoin
uc_annul | Annulation (O/N)
uc_date_plus_tard | Date de commande des matières premières au plus tard
retard | Pas de retard si date système <= date de commande des MP au plus tard è Colonne à blanc Retard si date système > date de commande des MP au plus tard è Colonne remplie avec un X
uc_ada ville_uc_ada | Code adresse d'envoi Ville de l'adresse d'envoi (libellé)
uc_adf ville_uc_adf | Code adresse de facturation Ville de l'adresse de facturation (libellé)

Table client

Toutes les zones du package Tiers ainsi que

fou_nom

Nom du fournisseur

Table cdf2

lf_num | Numéro commande achat (commande + ligne)
lf_delrep | Délai réponse commande achat
lf_qtecde | Quantité commandée
lf_qteliv | Quantité livrée
lf_arc | Code ARC
lf_date_arc | Date de l'aRC
lf_delai_demande | Délai demandé
lf qte_init | Quantité initiale de la commande
lf_prix_init | Prix initial de la commande dans la devise société
lf_prix_init_dev | Prix initial de la commande dans la devise de la commande
lf_prix_init_euro | Prix initial de la commande dans la devise EURO

Divers

using | Voir #VI
Saisie | Zone vide
lib_qualite | Libellé étranger de la qualité carton (le_libpar1)
lib_qualite_matiere | Libellé étranger de la qualité matière du produit pour le client (le_libpar1)
pointage_laize_calcule | Pointages recalculés au moment de la visualisation en fonction du FECO, du profil carton et des dimensions de l'article du besoin.
pointage_coupe_calcule | Pointage coupe de l'article de CDE5
pointage_laize_tsc_prod | Pointages mémorisés dans les CIC N01 à N20 de l'article à l'origine du besoin matière (uc_article_fab dans cde5
pointage_coupe_tsc_prod | Pointage coupe de l'article de CDE5 (CIC N80 à N99)
kma_nb_morceaux | Nombre de morceaux du FEFCO
nbre_pf_a_fabriquer | Nombre de produits finis à fabriquer
qte_util_ua | Conversion de la zone qte_util en unité d'achat, en utilisant : longueur = laize brute largeur = coupe_brute code coefficient de conversion indiqué sur la qualité
lib_spe_qualite | Libellé spécifique 1 de la qualité carton pour le fournisseur
lib_spe2_qualite | Libellé spécifique 2 de la qualité carton pour le fournisseur

Gestion spécifique des TSC

Affichage des valeurs des TSC sur article plaque / généré

Si le nom de la colonne commence par TSC_GEN_, le résultat proviendra d'une information complémentaire sur l'article généré. (Sans la chaîne GEN_, il s'agira d'informations sur le produit fini)

La syntaxe est la suivante :

TSC_GEN_MP_AA_080_C

où

TSC | Nom de colonne paramétrable TSC sur article généré
MP | Clé et code du type de clé
80 | Code du TSC (Exemple 080, 081, etc.)
C | Code zone de la table info_c

Voir le paramétrage standard des TSC pour plus d'informations.


v_cde_marche Visualisation des commandes de marché

Options Tri Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de commande

Exemple : -N[f0_cde]

Options

Oab

Le calcul de la quantité lancée non fabriquée pour les articles simples achetés est fait en s'appuyant sur les commandes FBI portant sur l'article et non sur les commandes d'achat.

On peut utiliser cette visu pour lister les produits dont le stock est insuffisant (état des relances).

Dans tous les cas, s'il y a risque de rupture de stock, on génère une commande de type FBI afin de faire un réapprovisionnement.

Si l'article est fabriqué, la FBI sera fabriquée; sinon, une commande d'achat sera générée via le traitement des besoins de la commande générée pour l'article acheté.

Le problème est le suivant : si on attend que le besoin de la commande FBI soit traité pour retirer la ligne produit de l'état des relances, il y a un fort risque qu'un utilisateur régénère une nouvelle commande pour ce même produit.

Si, pour tous les articles suivis dans l'état des relances, il y a obligatoirement une commande FBI générée avant chaque commande d'achat (nécessaire pour les affectations des commandes d'achat et le calcul des prix de revient), on peut mettre en place cette option qui va calculer la quantité lancée non fabriquée en fonction de ces FBI et non plus en fonction des commandes d'achat qui seront générées plus tard.

Olp

Quantité lancée non fabriquée recherchée sur le produit

Opz

Pas d'édition des .00 lorsque la valeur de la colonne est nulle

Oql

Pas d'édition des lignes où la quantité à lancer est égale à zéro.

Ori

Dans l'état des relances, si un même article se présente plusieurs fois consécutives, les stocks ne sont pas recalculés. Cette option permet de répéter les informations de stocks sur 2 lignes consécutives d'un même article.

Orv

Recalcul visu (on rafraîchit l'écran en sortie du F21 et/ou du F34)

Valeur alpha 2

Paramétrage des options

Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch (E/F) E Édition F Fichier (Nom du fichier à paramétrer dans les notes)

Valeur alpha 3

Caractères 1 à 60

Titre de la visualisation

VISUALISATION DU JOURNAL DES ACHATS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 21 | Droit d'accès au F21 (O/N, N par défaut)
Caractère 34 | Droit d'accès au F34 (O/N, N par défaut)
Caractère 38 | Touche CONTROL-C (O/N) - Calculatrice
Caractère 48 | Touche CONTROL-P (O/N) - Visualisation des stocks sur produit
Caractère 51 | Touche CONTROL-T (O/N) - Visualisation des touches
Caractère 56 | Touche CONTROL-Z (O/N) - Lancement de programmes

Notes triées

EDAR (édition) RDAR (réédition) | 5 7 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite 8 : (2 points) 9,14 Type et code du lanceur de l'édition d'AR
RUNCDE | Si gestion par site (caractère 24 = :) 21,23 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite 24 : (2 points) 25,30 Type et code du paramètre de lancement de la saisie de commande Si pas de gestion par site (caractère 24 = :) 21,26 Type et code du paramètre de lancement de la saisie de commande
RUN_VISU_TYPE_RATT | 21,23 Code TYC 24,26 Code site (correspond à la zone au ec_c1) - Tableau de bord du multisite 27 : (2 points) 28,33 Type et code du lanceur de la visu de commande rattachée au TYC
SSC_CODE_SITE | 21,23 Code site à prendre en compte par la génération de commande, si celui-ci n'est pas renseigné par le programme appelant. Met à jour la zone edi_cde.edc_c1 Tableau de bord du multisite Cette note est prioritaire sur celle du #CF SSC. Génér.cde
SSC_DELAI_OBLIGATOIRE | Le délai est-il obligatoire (O/N, N par défaut) Cette note est prioritaire sur celle du #CF SSC.
SSC_LCO_DEVIS_PRIO | 21,23 Code de la LCO définissant la priorité du sous-devis (LCO GDF par défaut) Dans la recherche du prix de la ligne de commande par la variante de devis, il est désormais possible de forcer la variante utilisée par un LCO sur l'entité du devis. Le prix de la ligne de commande sera celui de la variante forcée. LCO A1[16] de la variante prioritaire doit être égal à O (Oui). Cette note est prioritaire sur celle du #CF SSC. Génér.cde
SSC_PRX_DEV_TARIF_0 | 21 Récupération du prix sur le devis associé au produit si la recherche de tarif ne retourne pas de valeur (O/N, N par défaut) Cette note est prioritaire sur celle du #CF SSC. Génér.cde
_SUP_REQ_CDE_ACH | Complément de requête pour la recherche de commandes d'achat rattachée à la commande de marché Exemple and ef_tyc = "PLA"
_SUP_REQ_CDE_FAB | Complément de requête pour la recherche de commandes FBI rattachée à la commande de marché Exemple and ec_tyc = "FBI"
_SUP_REQ_FLE_MAT | Complément de requête pour la recherche de produits dans la nomenclature du devis Exemple and fm_matiere not matches "XENC"
_SUP_REQ_STK0 | Complément de requête pour la recherche du stock physique Exemple and s0_rgt1 = "USI"

Ordres de tris disponibles

Voir les notes commençant par O

01 | n_code_cli (Code client)
02 | n_code_mat (Code article)
03 | n_mat_cdm (Code article de la ligne de commande)
04 | n_seq_nom (Séquence de nomenclature)
05 | n_num_prov (Provenance (Ligne nomenclature devis)
06 | n_date_rep (Date de clôture de contrat)
07 | n_num_cdm (Numéro de commande)
08 | n_lig_cdm (Ligne de commande)

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Entête de commande

Ligne de commande

Fiche tiers

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Autres zones

Entête de commande

ec_soc | Code société de l'entête de commande
ec_num | Numéro de commande
ec_cli | Code client
ec_ref | Référence de la commande client
ec_cderat | Code dossier de rattachement
ec_tyc | Type de la commande (TYC)
libc_ec_tyc | Type de la commande (TYC) Libellé court
libl_ec_tyc | Type de la commande (TYC) Libellé long
ec_c1 | Zone paramétrable (voir #CF CDE)
libc_ec_c1 | Zone paramétrable (voir #CF CDE) Libellé court
libl_ec_c1 | Zone paramétrable (voir #CF CDE) Libellé long
ec_datc | Date de commande client (ou date d'enregistrement)
ec_ada | Code adresse accuse de réception
ville_ec_ada | Ville adresse accuse de réception
nom_ec_ada | Nom adresse accuse de réception
ec_adf | Code adresse de facturation
ville_ec_adf | Ville adresse de facturation
nom_ec_adf | Nom adresse de facturation
ec_adl | Code adresse de livraison
ville_ec_adl | Ville adresse de livraison
nom_ec_adl | Nom adresse de livraison
ec_mrg | Code mode de règlement (MRG)
libc_ec_mrg | Code mode de règlement (MRG) Libellé court
libl_ec_mrg | Code mode de règlement (MRG) Libellé long
ec_ech | Code échéance (ECH)
libc_ec_ech | Code échéance (ECH) Libellé court
libl_ec_ech | Code échéance (ECH) Libellé long
ec_rem | Remise (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte
ec_pnt | Montant du port non taxable en HT
ec_pht | Montant du port taxable en HT
ec_tvap | Code TVA sur le port (TVA)
libc_ec_tvap | Code TVA sur le port (TVA) Libellé court
libl_ec_tvap | Code TVA sur le port (TVA) Libellé long
ec_tport | Type de port (POR)
libc_ec_tport | Type de port (POR) Libellé court
libl_ec_tport | Type de port (POR) Libellé long
ec_trsp | Mode de transport (TRS)
libc_ec_trsp | Mode de transport (TRS) Libellé court
libl_ec_trsp | Mode de transport (TRS) Libellé long
ec_transp | Code transporteur (fichier client)
nom_ec_transp | Nom transporteur (fichier client)
ec_tour | Code tournée (TOU)
libc_ec_tour | Code tournée (TOU) Libellé court
libl_ec_tour | Code tournée (TOU) Libellé long
ec_ct | Code tarif
libc_ec_ct | Code tarif Libellé court
libl_ec_ct | Code tarif Libellé long
ec_cr | Code remise
libc_ec_cr | Code remise Libellé court
libl_ec_cr | Code remise Libellé long
ec_exp | Exportation (O/N)
ec_suiv | Affaire suivi par (FAB)
libc_ec_suiv | Affaire suivi par (FAB) Libellé court
libl_ec_suiv | Affaire suivi par (FAB) Libellé long
ec_rep | Code représentant (REP)
libc_ec_rep | Code représentant (REP) Libellé court
libl_ec_rep | Code représentant (REP) Libellé long
ec_trep | Taux de commission du représentant
ec_fab | En fabrication (O/N)
ec_sold | Commande soldée (O/N)
ec_pro | Proforma (O/N)
ec_prx | Demande de prix (O/N)
ec_conf | Fiche de conformité (O/N)
ec_ar | Accusés de réception à éditer (O/N)
ec_oe | Ordre d'exécution à éditer (O/N)
ec_fact | Reste des factures à éditer (O/N)
ec_bl | Reste des BL à éditer (O/N)
ec_portf | Le port est facture (O/N)
ec_ord | Numéro d'ordre
ec_texte | Commentaire libre
ec_rstafa | Reste à facturer (O/N)
ec_poids | Poids total
ec_date_client | Date client
ec_afacturer | Commande à facturer (O/N)
ec_corres | Correspondant chez le client attache à la commande
ec_titre | Titre du correspondant attache à la commande
libc_ec_titre | Titre du correspondant attache à la commande Libellé court
libl_ec_titre | Titre du correspondant attache à la commande Libellé long
ec_fadavo | Numéro facture/avoir
ec_issue_de | Commande issue de
ec_type_liaison | Code type de liaison (LIE)
libc_ec_type_liaison | Code type de liaison (LIE) Libellé court
libl_ec_type_liaison | Code type de liaison (LIE) Libellé long
ec_ref_liaison | Référence de liaison
ec_ref_reg_fact | Référence de regroupement de facturation
ec_acc_euro | Acompte en Euros
ec_acc_dev | Acompte en devise
ec_pnt_euro | Montant du port non taxable en HT et en Euros
ec_pnt_dev | Montant du port non taxable en HT et en devise
ec_pht_euro | Montant du port taxable en HT et en Euros
ec_pht_dev | Montant du port taxable en HT et en devise
ec_devise | Code devise
libc_ec_devise | Code devise Libellé court
libl_ec_devise | Code devise Libellé long
ec_annu | Annulé (O/N)
ec_date | Date d'enregistrement
ec_web_statut | Code statut pour les commandes WEB
libc_ec_web_statut | Code statut pour les commandes WEB Libellé court
libl_ec_web_statut | Code statut pour les commandes WEB Libellé long
zc1_ec_tvap |

Ligne de commande

lc_soc | Code société de la ligne de facture
lc_num | Numéro de commande
lc_lig | Numéro de ligne
lc_prod | Code produit
lc_fam | Code famille (FAM)
libc_lc_fam | Code famille (FAM) Libellé court
libl_lc_fam | Code famille (FAM) Libellé long
lc_sfm | Code sous-famille (SFM)
libc_lc_sfm | Code sous-famille (SFM) Libellé court
libl_lc_sfm | Code sous-famille (SFM) Libellé long
lc_lib | Libellé du produit
lc_repr | Code représentant (REP)
libc_lc_repr | Code représentant (REP) Libellé court
libl_lc_repr | Code représentant (REP) Libellé long
lc_com | Taux de commissions
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro du devis
lc_sdev | Numéro du sous-devis
lc_cderat | Numéro de commande de rattachement
lc_lcderat | Numéro de ligne de commande de rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_qte_en_retour | Quantité de retour client
lc_solde | Solde
lc_prx | Prix
lc_rem | Remise
lc_p1 | Zone paramètre 1
libc_lc_p1 | Zone paramètre 1 Libellé court
libl_lc_p1 | Zone paramètre 1 Libellé long
lc_p2 | Zone paramètre 2
libc_lc_p2 | Zone paramètre 2 Libellé court
libl_lc_p2 | Zone paramètre 2 Libellé long
lc_p3 | Zone paramètre 3
lib_lc_p3 | Zone paramètre 3
lc_unvent | Unité de vente
libc_lc_unvent | Unité de vente Libellé court
libl_lc_unvent | Unité de vente Libellé long
lc_tva | Code TVA (TVA)
libc_lc_tva | Code TVA (TVA) Libellé court
libl_lc_tva | Code TVA (TVA) Libellé long
lc_poids | Poids unitaire
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée et accusée (calculée ou manuelle)
lc_delfab | Date de fin de fabrication (calculée ou manuelle)
lc_delrea | NON UTILISEE
lc_colis | Nb de colis
lc_prxcli | Prix client
lc_rstfac | Reste des factures à éditer (O/N)
lc_rstbl | Reste des BL à éditer (O/N)
lc_nummvt | Numéro de mouvement de stock engendré
lc_priorite | Niveau de priorité de la commande
libc_lc_priorite | Niveau de priorité de la commande Libellé court
libl_lc_priorite | Niveau de priorité de la commande Libellé long
lc_rstafa | Reste à facturer (O/N)
lc_rstfab | Reste à fabriquer (O/N)
lc_adl | Code adresse livraison
ville_lc_adl | Ville adresse de livraison
nom_lc_adl | Nom adresse de livraison
lc_adf | Code adresse de facturation
ville_lc_adf | Ville adresse de facturation
nom_lc_adf | Nom adresse de facturation
lc_haut | Hauteur
lc_afacturer | Ligne de commande à facturer (O/N)
lc_nummvt2 | Numéro de mouvement de stock quantité lancée
lc_par_tyc | Code paramètre rattaché au type de commande
libc_lc_par_tyc | Code paramètre rattaché au type de commande Libellé court
libl_lc_par_tyc | Code paramètre rattaché au type de commande Libellé long
lc_lot | Numéro de lot
lc_qualif_appel | Qualificatif appel de livraison
libc_lc_qualif_appel | Qualificatif appel de livraison Libellé court
libl_lc_qualif_appel | Qualificatif appel de livraison Libellé long
lc_facrat | Numéro de facture de rattachement
lc_lfacrat | Numéro ligne de facture de rattachement
lc_unvent_au | Unité de vente au plus ou au moins
libc_lc_unvent_au | Unité de vente au plus ou au moins Libellé court
libl_lc_unvent_au | Unité de vente au plus ou au moins Libellé long
lc_prx_au_plus | Prix au plus
lc_prx_au_moins | Prix au moins
lc_marge | Pourcentage de marge
lc_prx_revient | Prix de revient
lc_tolerance_liv | Code tolérance de livraison (TOL)
libc_lc_tolerance_liv | Code tolérance de livraison (TOL) Libellé court
libl_lc_tolerance_liv | Code tolérance de livraison (TOL) Libellé long
lc_prx_rvt_reel | Prix de revient réel
lc_date_solde | Date du solde de la ligne de commande
lc_qteliv_reelle | Quantité réellement livrée
lc_prx_euro | Prix en Euros
lc_prx_dev | Prix en devise
lc_prxcli_euro | Prix client en Euros
lc_prxcli_dev | Prix client en devise
lc_prx_plus_euro | Prix au plus en Euros
lc_prx_plus_dev | Prix au plus en devise
lc_prx_moins_euro | Prix au moins en Euros
lc_prx_moins_dev | Prix au moins en devise
lc_prx_rvt_euro | Prix de revient en Euros
lc_prx_rvt_r_euro | Prix de revient réel en Euros
lc_lieu_rgt1 | Numéro de lieu de rangement niveau 1
lc_deldep | Date de départ
lc_prx_rvt_dev | Prix de revient en devise
lc_date_gener | Date de génération
lc_date_regener | Date de régénération
lc_prixnet | Prix net
lc_sbi | Code facture SBI (Self Billing Invoice)
lc_heure_cli_tot | Heure client proposée au plus tôt
lc_heure_cli_tard | Heure client proposée au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_fab_tot | Heure de fin fabrication au plus tôt
lc_heure_fab_tard | Heure de fin fabrication au plus tard
lc_heure_dep_tot | Heure de départ proposée au plus tôt
lc_heure_dep_tard | Heure de départ proposée au plus tard
lc_transfert_trans | Code transfert SYLOGI
lc_gen_bl_auto | Génération automatique des BL
lc_variante | Numéro de variante retenue lors du transfert du devis
lc_nummvt3 | Numéro de mouvement entrée prévisionnelle sur lieu intermédiaire
lc_volupilot_ok | Flag indiquant si la commande à été traitée par Volupilot
lc_mpl_prx_ini | Prix initial
lc_mpl_prx_ini_eur | Prix initial en Euros
lc_mpl_prx_ini_dev | Prix initial en Devise
lc_mpl_qte_ini | Quantité commandée initiale
lc_qte_en_retour | Quantité retournée par le bon de retour
lc_annu | Annulé (O/N)
zc1_lc_unvent |
zc1_lc_unvent_au |
zc1_lc_tva |
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

Autres zones

qte_reste_à_livrer | Quantité restant à livrer
qte_lancee_non_fab | Quantité lancée/achetée non fabriquée/reçue
stock_physique | Stock physique
qte_a_lancer | Quantité à lancer/à acheter
qte_commandee | Quantité commandée
qte_livree | Quantité livrée
le_signe | Signe
using | Voir #VI


v_dem_achat Visualisation des demandes d'achat

Ce programme est opérationnel à partir de la V. 4.0.182.2

Options

Orv

Rafraîchissement automatique de la visualisation si nécessaire

(Après l'affichage de la demande d'achat ou le lancement de programmes de la ligne courante)

Valeur alpha 2

A2[1] | Second écran de sélection (O/N, N par défaut)
A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)
A2[10] | Lancement du programme en Batch E Edition F Fichier
A2[38] | Lien avec les lignes fournisseurs des lignes des demandes d'achat (O/N, O par défaut)

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[5] | Touche F5 - Rafraîchissement de la visualisation (O/N, N par défaut)
A4[8] | Touche F8 - Lancement de l'affichage de la demande d'achat (O/N, N par défaut)
A4[43] | Touche CONTROL-J - Lancement de programmes de la ligne courante (O/N, N par défaut)
A4[44] | Touche CONTROL-K - Lancement de programmes des lignes sélectionnées (O/N, N par défaut)

Notes

_CSEL | Affichage de la colonne de sélection (colonne de droite) Cette colonne permet de sélectionner des lignes sur lesquelles on veut appliquer un traitement. Voir #RP
LCT_MULTI_CONFIG | 21,26 Type de code du paramètre de configuration des actions/programmes pour la sélection multiple. Voir #RP Exemple pour générer une commande d'achat à partir des lignes sélectionnées Dans les notes du #VI DMA (paramètre de lancement v_dem_achat), ajouter cette note : LCT_MULTI_CONFIG #RPDA1 Dans les notes du #RP DA1, ajouter ces notes : LCT_MULTI_TITRE_01 Lancement des programmes LCT_MULTI_TITRE_02 Génération des commandes d'achat LCT_MULTI_PARAM_02 #SAGDA-nDA[dae_num]
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
RUN_AFF_DEM_ACHAT | 21,26 Type et code paramètre du lancement de l'affichage de la demande d'achat
_SUP_REQ_DEM_ACH_ENT | 21,60 Complément de sélection sur la table dem_achat_ent
_SUP_REQ_DEM_ACH_LIG | 21,60 Complément de sélection sur la table dem_achat_lig
_SUP_REQ_DEM_ACH_FOU | 21,60 Complément de sélection sur la table dem_achat_fou Le lien avec les lignes fournisseurs des lignes des demandes d'achat doit être activé (A2[38] = O).

Critères de tri

01 | dae_num | Numéro de demande d'achat
02 | dae_date_dem | Date de demande d'achat
03 | dae_demandeur | Demandeur
04 | dae_service | Service
05 | dae_site | Site
06 | dae_delrep | Délai de réponse souhaité
07 | dal_lig | Ligne de demande d'achat
08 | dal_prod | Produit
09 | daf_fou | Fournisseur Le lien avec les lignes fournisseurs des lignes des demandes d'achat doit être activé (A2[38] = O).
10 | daf_date_envoi | Date d'envoi Le lien avec les lignes fournisseurs des lignes des demandes d'achat doit être activé (A2[38] = O).

Liste des zones disponibles

using | Voir #VI
Entête de la demande d'achat | Toutes les zones du Package Demande Achat Entête
Ligne de la demande d'achat | Toutes les zones du Package Demande Achat Ligne
Ligne fournisseur de la ligne de la demande d'achat | Toutes les zones du Package Demande Achat Fournisseur
Produit de la ligne de la demande d'achat (dal_prod) | Toutes les zones du Package Articles - Matières - Produits
Adresse principale du client de la ligne de la demande d'achat (dal_liv_cli) | Toutes les zones du Package Tiers Les zones sont préfixées de dal_
Adresse secondaire du client de la ligne de la demande d'achat (dal_liv_adr) | Toutes les zones du Package Adresses secondaires Les zones sont préfixées de dal_
Adresse principale du fournisseur de la ligne fournisseur de la ligne de la demande d'achat (daf_fou) | Toutes les zones du Package Tiers Les zones sont préfixées de daf_
Adresse secondaire du fournisseur de la ligne fournisseur de la ligne de la demande d'achat (daf_adr) | Toutes les zones du Package Package Adresses secondaires Les zones sont préfixées de daf_

Zones cumulables et utilisables dans les formules de calcul

Zone | Libellé | Table
daf_prix_prop | Prix proposé (non cumulable) | dem_achat_fou
daf_qtecde | Quantité passée en commande | dem_achat_fou
daf_qtefou | Quantité fournisseur | dem_achat_fou
dal_hau | Hauteur | dem_achat_lig
dal_lar | Largeur | dem_achat_lig
dal_lon | Longueur | dem_achat_lig
dal_nb_liv_prev | Nombre de livraisons prévues | dem_achat_lig
dal_nb_mois_prev | Nombre de mois | dem_achat_lig
dal_poids | Poids | dem_achat_lig
dal_prix_max | Prix maxi (non cumulable) | dem_achat_lig
dal_qtedem | Quantité demandée | dem_achat_lig


v_don Visualisation du devis onduleur

Valeurs alpha Tri Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de devis

Exemple : -N[kp_de_ndemcli]

Options

Ofv | Dans le calcul du devis onduleur : cette option permet de modifier la méthode de répartition entre coûts fixes et variables selon le type de frais rattaché au centre de coût Sans cette option, la répartition se fait selon le type d'opération : préparation/réalisation.
Ogr | Gestion des remises de prix. Permet d'accéder aux remises de prix L'autorisation d'accès à la fonction F13 (Saisie des remises de prix) se fait via A4[13].
Orp | Accès à l'écran de remise de prix L'autorisation d'accès à la fonction F13 (Saisie des remises de prix) se fait via A4[13].

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch (E/F) E Édition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractère 13 | Possibilité d'accéder directement au sous menu E d'édition F d'édition dans un fichier
Caractères 15 à 17 | Longueur de la ligne éditable Sert uniquement dans l'édition. Par défaut 350 Permet d'éditer une même ligne sur plusieurs lignes
Caractère 30 | Édition d'un entête société (O/N)
Caractère 31 | Détail offre (O/N)
Caractère 32 | Détail PF (O/N) ATTENTION Détail PF et Pas de détail Offre sont incompatibles.
Caractères 33 à 35 | Type du paramètre pour lecture configuration devis
Caractères 36 à 38 | Code du paramètre pour lecture configuration devis
Caractère 39 | Détail composition carton (édition uniquement)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES COMMANDES CLIENTS

Valeur alpha 4

Paramétrage des touches de fonction

A4[13] | Autorisation d'accès à la fonction F13 (Shift-F1) : Accès à l'écran de saisie des remises de prix Nécessaire aux options Ogr et Orp O Accès en consultation M Accès en modification N Accès interdit (par défaut)
A4[37] | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]

Notes

_FOR_INDIC_ _TIT_INDIC_ _VAR_INDIC_ | Edition des indicateurs de récapitulatif des coûts 21,60 Paramétrage des formules de calcul des indicateurs 21,60 Paramétrage des indicateurs 21,60 Paramétrage des variables de calcul des indicateurs Ces 3 notes existent aussi sur le #CF REC où elles sont prioritaires. Le #CF REC peut être remplacé par tout autre paramètre dont le nom est indiqué dans la note PARAM_INDICATEURS (ci-dessous). Les variables suivantes sont accessibles dans les notes commençant par V, E, D, F : IND_Champ_Numéro pour les indicateurs prévisionnels <ou> INR_Champ_Numéro pour les indicateurs réels où Champ LIB Libellé de l'indicateur COU Coût de l'indicateur C_U Coût unitaire de l'indicateur Numéro Numéro de l'indicateur (1 à 100, celui-ci est défini selon l'ordre des notes TIT_INDIC_) Exemples de noms de colonne IND_COU_001 : Edition du coût de l'indicateur n°1 IND_C_U_010 : Edition du coût unitaire de l'indicateur n°10
PARAM_INDICATEURS | 21,26 Type et code du paramètre de configuration du récapitulatif des coûts Fait référence aux notes _VAR_INDIC_, _FOR_INDIC_ et _TIT_INDIC*, qui peuvent être paramétrées ici ou sur le #CF REC où elles sont prioritaires.
_SUP_REQ_AFFAIRE | 21,60 Complément de sélection sur la table affaire utilisé dans la recherche des devis à visualiser
_SUP_REQ_D_ART_CONSO | 21,60 Complément de requête pour le détail des articles consommés Ce complément se fait pour la table nom0.
_SUP_REQ_DETAIL_COMP | 21,60 Complément de requête pour le détail de la composition Ce complément se fait pour la table nom0.
_SUP_REQ_KP_ETAT | 21,60 Complément de requête sur kp_etat
_SUP_REQ_KP_RECAP_TO | 21,60 Complément de requête sur la table kp_recap_tot Exemple : and kp_to_ndemcli = "07120011"
_SUP_REQ_NOM0 | 21,60 Complément de sélection sur la table nom0 utilisé pour trouver le premier produit fini dans la nomenclature de l'offre courante lorsque le détail PF est désactivé (A2[32] = N).
_SUP_REQ_TAUX_ENCRE | 21,60 Critère de recherche sur la table nom0 pour spécifier les éléments de l'article d'impression à prendre en compte dans le calcul de la zone taux_encrage.

Liste des champs pour le tri

Voir les notes commençant par O

1 | c_demcli | Numéro devis
2 | d_demcli | Date devis
3 | c_cli | Code client
4 | c_rep | Code représentant
5 | c_refembcli | Ref.Emballage client
6 | c_offven | Numéro offre
7 | c_refembkp | Ref.Emballage interne
8 | c_fam | Code famille Réf.emb.Int
9 | c_sfm | Code S/Famille Réf.emb.Int
10 | c_qte | Quantité Réf.emb.Int
11 | c_refpf | Réf.Produit fini
12 | c_fam_pf | Code famille PF
13 | c_sfm_pf | Code S/Famille PF
14 | c_sfm_compo | Code S/Famille compo
15 | c_num_aff | Numéro d'affaire
16 | c_lig_aff | Numéro de ligne d'affaire
17 | c_des_aff | Désignation d'affaire

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Table Devis

Libellés liés à la table devis

Table Offre

Table nom0 (Produit fini)

Fiche tiers

Package adresses secondaires

Fiche tiers livraison

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

En outre, toutes les zones peuvent être préfixées de :

mp_pf_ (article référence du produit fini)

mp_ref_ens_ (article référence interne de l'emballage)

mp_qua_car_ Composition commerciale (qualité carton)

mp_com_car_ Composition technique

Ce préfixage ne fait pas partie du package, il est "en dur" ici, ainsi que les zones suivantes :

mp_ref_ens_surface_brute / mp_pf_surface_brute : Surface brute de l'ensemble / du produit fini

mp_ref_ens_surface_nette / mp_pf_surface_nette : Surface nette de l'ensemble / du produit fini

mp_ref_ens_poids_brut / mp_pf_poids_brut : Poids brut de l'ensemble / du produit fini

mp_ref_ens_poids_net / mp_pf_poids_net : Poids net de l'ensemble / du produit fini

Champs calculés (écran 080)

Autres

Récapitulatif des Coûts

Informations de l'adresse de livraison

Données des caractéristiques des actions de service

Table Devis

kp_de_soc | Code société
kp_de_ndemcli | Numéro du devis
kp_de_ldemcli | Libellé du devis
kp_de_lvotrefdem | Référence client
kp_de_ddemcli | Date du devis
kp_de_ccliliv | Code client
kp_de_cclipdo | Code adresse de livraison
kp_de_ctypcorcli | Code du correspondant
kp_de_lnomcorcli | Nom du correspondant
kp_de_ntelcorcli | Téléphone du correspondant
kp_de_crep | Code représentant
kp_de_kcom | Taux de commission du représentant
kp_de_kprifid | % prime de fidélité
kp_de_nrefembcli | Référence d'emballage du client
kp_de_lrefembcli | Libellé référence d'emballage du client
kp_de_qrefembdem | Quantité demandée 1
kp_de_qrefembdem2 | Quantité demandée 2
kp_de_qrefembdem3 | Quantité demandée 3
kp_de_qrefembdem4 | Quantité demandée 4
kp_de_qrefembdem5 | Quantité demandée 5
kp_de_qrefembdem6 | Quantité demandée 6
kp_de_crempri | Code unité de remise de prix
kp_de_cdev | Code devise
kp_de_crepcli | Code réponse du client
kp_de_cmotdeccli | Motif de la réponse
kp_de_drepcli | Date de la réponse
kp_de_noffven | Numéro d'offre choisie
kp_de_noffvenhis |
kp_de_mprivenneg | Prix négocié
kp_de_kparmaroff | % part de marché
kp_de_site libc_kp_de_site libl_kp_de_site | Site de production créateur du devis Libellé court Libellé long
kp_de_env_ope libc_kp_de_env_ope libl_kp_de_env_ope | Code environnement de calcul des opérations du devis (Spécifique Libellé court Libellé long
kp_de_env_mat libc_kp_de_env_mat libl_kp_de_env_mat | Code environnement de calcul des matières du devis (Spécifique) Libellé court Libellé long
tel_kp_de_crep | Téléphone du représentant

Libellés liés à la table devis

libc_kp_de_crep | Libellé court du représentant
libl_kp_de_crep | Libellé long du représentant
libc_kp_de_crempri | Libellé court de l'unité de remise de prix
libl_kp_de_crempri | Libellé long de l'unité de remise de prix
libc_kp_de_cdev | Libellé court de la devise
libl_kp_de_cdev | Libellé long de la devise

Table Offre

kp_of_noffven | Numéro d'offre
kp_of_ddebvaloff | Date début de validité de l'offre
kp_of_dfinvaloff | Date fin de validité de l'offre
kp_of_cser | Code service
kp_of_nrefembkp | Référence d'emballage interne
kp_of_qrefemboff | Quantité demandée
libc_kp_of_cser | Libellé court du service
libl_kp_of_cser | Libellé long du service
kp_of_qtealiv | Quantité de livraison

Table nom0 (Produit fini)

n0_seq | Numéro de séquence
n0_pcsant | Référence du produit fini
n0_epai | Epaisseur
n0_larg | Largeur
n0_long | Longueur
n0_qte | Coefficient de nomenclature
n0_gf | Gâche fixe
n0_gv | Gâche variable
n0_prix | Prix
n0_rep | Repère
n0_tr | Type
n0_marq | Marque

Fiche tiers

Toutes les zones du package Tiers et les zones suivantes :

tel_cl_suiv | Téléphone du suivi d'affaire
ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

Fiche tiers livraison

livraison_cl_code | Code tiers
livraison_cl_nom | Nom tiers
livraison_cl_adr1 | Ligne 1 adresse rue
livraison_cl_adr2 | Ligne 2 adresse rue
livraison_cl_codp | Code postal
livraison_cl_vil | Adresse ville
livraison_cl_telph1 | Numéro téléphone 1
livraison_cl_telph2 | Numéro téléphone 2
livraison_cl_telcop | Numéro fax
livraison_cl_telex | Numéro télex
livraison_cl_pays | Code pays
livraison_libc_cl_pays | Libellé court code pays
livraison_libl_cl_pays | Libellé long code pays
livraison_cl_adrb | Code adresse livraison

Champs calculés (écran 080)

Tous ces champs sont cumulables.

cout_as_fixe | Coût total fixe des actions de service
cout_as_var | Coût total variable des actions de service
cout_as_100 | Coût total au 100 des actions de service
cout_mo_fixe_str | Coût main d'œuvre fixe sous-traitance (PF)
cout_mo_variable_str | Coût main d'œuvre variable sous-traitance (PF)
cout_mat_fixe_str | Coût matière fixe sous-traitance (PF)
cout_mat_variable_str | Coût matière variable sous-traitance (PF)
cout_str_fixe | Coût sous-traitance fixe (PF)
cout_str_variable | Coût sous-traitance variable (PF)
cout_mo_fixe | Coût main d'œuvre fixe (PF)
cout_mat_fixe | Coût matière fixe (PF)
cout_fixe | Coût fixe (PF)
cout_mo_variable | Coût main d'œuvre variable (PF)
cout_mat_variable | Coût matière variable (PF)
cout_variable | Coût variable (PF)
cout_mo | Coût main d'œuvre (PF)
cout_mat | Coût matière (PF)
cout_str | Coût sous-traitance (PF)
cout | Coût total (PF)
cout_100_variable | Coût variable au 100 (PF)
cout_100_fixe | Coût fixe (PF)
cout_100_mo | Coût main d'œuvre au 100 (PF)
cout_100_mat | Coût matière au 100 (PF)
cout_100_str | Coût sous-traitance au 100 (PF)
cout_100 | Coût total au 100 (PF)
charge_fixe_article | Charge fixe article (PF)
charge_fixe_as | Charge fixe actions de service
charge_variable_as | Charge variable des actions de service
charge_fixe_totale | Charge fixe totale
Prix_total_fixe | Prix total fixe
Prix_total_variable | Prix total variable
Prix_total_100 | Prix total au 100
using | Voir #VI

Autres

AS_XXX_code_as | Code action de service XXX
AS_XXX_libc_as | Libellé court du code action de service XXX
AS_XXX_libl_as | Libellé long du code action de service XXX
AS_XXX_coût_fixe | Coût fixe du code action de service XXX
AS_XXX_coût_variable | Coût fixe du code action de service XXX
AS_XXX_coût_100 | Coût au 100 du code action de service XXX
cout_mp_qua_car_env_dev | Coût de la composition dans l'environnement de calcul du devis (Spécifique)
cout_mp_qua_car_env_reel | Coût de la composition dans l'environnement réel correspondant à l'environnement de calcul du devis (Spécifique)
taux_de_change | Taux de change pour la devise du devis
date_taux_de_change | Date du taux de change (par défaut : date du jour)
IND_Champ_Numéro | Voir les notes concernant le récapitulatif des coûts.
taux_encrage | Taux d'encrage
d_compo_code_papierX | Code papier (X compris entre 1 et 9)
d_compo_prixX | Prix au mille (cumule) (X compris entre 1 et 9)
d_compo_desX | Désignation du code papier (X compris entre 1 et 9)
d_art_conso_code_matY | Code matière (X compris entre 1 et 5)
d_art_conso_desY | Désignation du code matière (X compris entre 1 et 5)
d_art_conso_prixY | Prix (cumule) (X compris entre 1 et 5)
d_art_conso_coefY | Coefficient (X compris entre 1 et 5)
taux_encrage | Taux d'encrage en fonction des éléments présents dans la nomenclature de l'article d'impression. Voir la note _SUP_REQ_TAUX_ENCRE pour exclure les vernis.
MP_QC | Article composition commerciale (qualité carton)
MP_CC | Article composition technique

Informations de l'adresse de livraison

Les zones suivantes de la table cli, triées par ordre alphabétique, peuvent être préfixées de livraison_ pour récupérer les informations de l'adresse de livraison.

Exemples

livraison_cl_bic

livraison_libc_cl_bic

livraison_libl_cl_bic

cl_code_bic | Code BIC |
cl_code_domb1 | Code domiciliation bancaire |
cl_corres | Nom du correspondant principal |
cl_cpt | Code comptable |
cl_dev | Code devise | libc_cl_dev, libl_cl_dev
cl_domb1 | Domiciliation bancaire 1 |
cl_domb2 | Domiciliation bancaire 2 |
cl_ech | Code échéance | libc_cl_ech, libl_cl_ech
cl_exp | Exportation (O/N) |
cl_geo | Code secteur géographique | libc_cl_geo, libl_cl_geo
cl_iban | Code IBAN |
cl_incoterm | Code conditions de port | libc_cl_incoterm, libl_cl_incoterm
cl_langue | Code langue | libc_cl_langue, libl_cl_langue
cl_mrg | Code mode de règlement | libc_cl_mrg, libl_cl_mrg
cl_qual | Code forme juridique | libc_cl_qual, libl_cl_qual
cl_repr | Code représentant | libc_cl_repr, libl_cl_repr
cl_rib | Relevé d'identité bancaire |
cl_siret | Numéro d'identification TVA / SIRET |
cl_titre | Code titre du correspondant | libc_cl_titre, libl_cl_titre
cl_transp | Code transporteur attaché au client | nom_cl_transp
cl_trsp | Code type de transport | libc_cl_trsp, libl_cl_trsp
cl_validite_adr | Code validité d'adresse | libc_cl_validite_adr, libl_cl_validite_adr
cl_zparnum | Zone paramétrable numérique |

Données des caractéristiques des actions de service

XXX correspond au code de l'action de service.

YYY correspond au code de la caractéristique de l'action de service.

Par défaut : Si le nom de champ n'est pas précisé (CAS_XXX_YYY), c'est la valeur numérique qui est utilisée.

CAS_XXX_YYY --> CAS_XXX_YYY_valnum_cas

CAS_XXX_YYY_code_as | Code de l'action de service
CAS_XXX_YYY_libc_as | Libellé court de l'action de service
CAS_XXX_YYY_libl_as | Libellé long de l'action de service
CAS_XXX_YYY_code_cas | Code caractéristique d'action de service
CAS_XXX_YYY_libc_cas | Libellé court de la caractéristique d'action de service
CAS_XXX_YYY_libl_cas | Libellé long de la caractéristique d'action de service
CAS_XXX_YYY_valnum_cas | Valeur numérique de la caractéristique d'action de service
CAS_XXX_YYY_valalp_cas | Valeur alphanumérique de la caractéristique d'action de service


v_eat Visualisation de l'état d'avancement des travaux

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro d'ordre de fabrication

Exemple : -N[f0_of]

Options

Odm | Délai d'approvisionnement des articles non fabriqués
Ofp | Au lieu d'un critère de recherche par différence de date, on donne la date de fin prévue
Oga | Affichage des articles sans gamme
Ohd | Possibilité de saisir heure de début (0 sinon) - idem dp0
Ohm | Temps édités en heures / minutes
Oim | Gérer l'état d'avancement pour un imprimeur
Oit | On inverse l'affichage des temps dans le détail des temps d'une phase - idem dp0
Opo | Sur l'état de l'OF, on ramène la première opération non terminée en tenant compte de l'écart sélectionné
Otn | Autorise la saisie d'une heure de fin inférieure à l'heure de début (pour les horaires de nuit). Utilisé pour les chevauchements sur minuit - idem dp0


v_ecma Visualisation des codes ECMA/FEFCO

Ce paramètre est opérationnel à partir de la V.4.0.186.2

Il permet de visualiser les codes saisis par le biais du programme de saisie des codes ECMA / FEFCO.

Les données accessibles sont :

o ECMA (ecma)

o Libellés des couples FEFCO dessus/dessous (ecma2)

o Gammes standards applicables à un couple FEFCO dessus/dessous (g_ecma)

o Formule de définition des pointages par FEFCO (for_po)

o Majoration par profil carton associé à chaque ligne de pointage (maj_po)

o Libellés étrangers des couples FEFCO dessus/dessous (libelle_langue)

o Informations complémentaires TSC (info_c)

Les actions possibles sur une ligne de visualisation sont :

o Accès à la saisie des codes ECMA/FEFCO (touche de fonction F8, cette action peut être limitée via la permission TOU/VECMA_F8)

o Accès à l'onglet Gammes applicables (et uniquement celui-ci) de la saisie des codes ECMA/FEFCO (touche de fonction F9, cette action peut être limitée via la permission TOU/VECMA_F9)

o Accès à l'onglet Pointages (et uniquement celui-ci) de la saisie des codes ECMA/FEFCO (touche de fonction F11, cette action peut être limitée via la permission TOU/VECMA_F11)

o Accès à la saisie des informations complémentaires (TSC, touches de fonction Shift F8)

o Accès paramétrable à un programme externe n°1 (voir aide en ligne, type de paramètre #RP, touches de fonction Shift F9)

o Accès paramétrable à un programme externe n°2 (voir aide en ligne, type de paramètre #RP, touches de fonction Shift F10)

o Rafraîchissement de la visualisation (touches de fonction Control Shift F1)

o Génération d'un fichier Excel à partir du résultat de la visualisation

o Lancement de programme paramétrable (voir aide en ligne #RP, touches de fonction Control J)

o Accès à la saisie des notes (touches de fonction Control-N)

En utilisant le paramétrage du #RP, un programme peut appeler le programme de visualisation.

Exemples

-N[kma_code]

-N[el_ecma_dessus|-|el_ecma_dessous]

Options

Orv | Rafraîchissement automatique de la visualisation après le lancement d'une action (Appel à la saisie des informations ECMA/FEFCO , par exemple)
Oxd | Cache la partie Détails de l'écran de visualisation
Oxs | Accès à l'écran de visualisation sans écran de sélection

Valeur alpha 2

A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)

Valeur alpha 3

A3[1,60]

Titre de la visualisation

Valeur alpha 4

A4[8] | Touche de fonction F8 : Accès à la saisie des codes ECMA/FEFCO O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[9] | Touche de fonction F9 : Accès à l'onglet « Gammes applicables » (et uniquement celui-ci) de la saisie des codes ECMA/FEFCO O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[11] | Touche de fonction F11 : Accès à l'onglet « Pointages » (et uniquement celui-ci) de la saisie des codes ECMA/FEFCO O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A420] | Touche de fonction Shift+F8 : Accès à la saisie des informations complémentaires (TSC) O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[21] | Touche de fonction Shift+F9 : Accès au premier programme externe paramétrable (O/N, N par défaut)
A4[22] | Touche de fonction Shift+F10 : Accès au deuxième programme externe paramétrable (O/N, N par défaut)
A4[25] | Touche de fonction Control+Shift+F1 : Accès au rafraîchissement de la visualisation (O/N, N par défaut)
A4[43] | Touche de fonction Control+J : Accès au lancement des programmes paramétrable (O/N, N par défaut)
A4[46] | Touche de fonction Control+N : Accès à la saisie des notes O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)

Notes

_SUP_REQ_ECMA | 21,60 Complément de sélection sur la table des codes ECMA/FEFCO (ecma)
_SUP_REQ_ECMA2 | 21,60 Complément de sélection sur la table des libellés FEFCO dessus/dessous (ecma2)
_SUP_REQ_G_ECMA | 21,60 Complément de sélection sur la table des gammes applicables (g_ecma)
_SUP_REQ_FOR_PO | 21,60 Complément de sélection sur la table des formules de définition des pointages (for_po)
_SUP_REQ_MAJ_PO | 21,60 Complément de sélection sur la table des majorations par profil carton (maj_po)
_SUP_REQ_LIB_LNG | 21,60 Complément de sélection sur la table des libellés étrangers FEFCO dessus/dessous (libelle_langue)
PARAM_SAISIE_ECMA | 21,26 Type et code du paramètre de lancement de la saisie des codes ECMA/FEFCO

Ordres de tris disponibles

01 | Code ECMA (ecma)
02 | Code ECMA dessus (ecma2)
03 | Code ECMA dessous (ecma2)
04 | Numéro de séquence
05 | Désignation
06 | Code normalisé
07 | Type d'ECMA
08 | Nombre de morceaux
09 | Numéro d'ordre
10 | Actif
11 | Classe
12 | Sous-classe

Noms de zone autorisés

using - Voir #VI


v_edi_cde Visualisation des messages EDI de commande et génération de commande

Valeur alpha 2 Valeurs alpha 3 & 4 Notes Tri Zones : edi_cde Autres zones

Ce programme permet de visualiser les messages CALDEL et ORDERS.

Pour visualiser les messages DELFOR et DELINS, voir le programme v_edi_cde_delfor.

Le paramétrage marqué Génér.cde concerne la génération de commande à partir de la visu des articles et des profils de stock (Plus d'info : voir #CF SSC).

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : clé EDI Exemple : -N[edc_num_message]
-NE | Caractères 3 et suivants : Clé EDI Code client Type de message Type de commande Exemple : -N[edc_num_message|edc_cli|edc_type_message|edc_tyc]

Options triées

Obl | Lors de la génération de commande, on crée automatiquement le BL associé. (option payante CDE-02)
Occ | Lors de la création de la commande EDI, ne pas rechercher les commandes précédentes sur le même article afin de créer entièrement une nouvelle commande.
Ocn | Active la recopie des notes de l'article Voir la note NTS_ART_A_RECOPIER
Odl | Lors de la génération de commande, on initialise la date de génération par la date de livraison. (option payante CDE-02)
Ofm | Active l'intégration de fax-email
Oga | Génération automatique de commande via EDI
Ogb | Génération des commandes en mode batch Voir la note FICHIER_TRACE_GB Si la visualisation des commandes EDI est appelée avec cette option de la saisie simplifiée de commande, les paramétrages d'accès à la commande (note ACCES_CDE_TYC_XXX) de lancement de l'AR (note ACCES_AR_TYC_XXX) de lancement de BL (notes ACCES_EDI_BL, ACCES_EDI_DEF_BL, ACCES_REEDI_BL) fonctionnent de façon standard (et non en batch).
Oge | Génération étiquette Permet d'alimenter la table etiqprod pendant la génération de commande en vue de l'édition des étiquettes GALIA (déclenchée lors de l'édition des BL).
Ona | Active la prise en compte de la numérotation annuelle des compteurs dans la gestion des statistiques (table cli4)
Ord | Pas de rupture sur le point de destination

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 4 | Mécanique - Imprimerie (O/N) N Mécanique O Imprimerie
Caractères 7 à 9 | Type de mouvement normal pour une sortie de BL
Caractère 10 | Lancement en Batch (E/F) E Édition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractère 11 | Type d'écran de saisie F7 détail prix (1 à 6) 1 Écran de saisie F7 détail prix standard Stocke dans cde3 2 Écran de saisie F7 détail prix avec marge Stocke dans cde3 3 Écran de saisie F7 détail prix avec marge, prix de revient et quantités saisies sans décimales Stocke dans cde7 4 Écran de saisie F7 détail prix avec marge, prix de revient et quantités saisies avec décimales Stocke dans cde7 5 Écran de saisie F7 détail prix standards avec quantités saisies sans décimales Stocke dans cde7 6 Écran de saisie F7 détail prix standards avec quantités saisies avec décimales Stocke dans cde7
Caractère 12 | Édition des notes saisies (O/N) sur le client adresse livraison de la ligne de commande
Caractère 13 | Possibilité d'accéder directement au sous-menu E d'édition F d'édition dans un fichier
Caractère 14 | Édition en mode condensé (sauf entête)
Caractères 15 à 17 | Longueur de la ligne éditable. Sert uniquement dans l'édition Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes
Caractère 22 | Édition de la liste des accessoires (O/N) (édition uniquement) Remarque Paramétrer le complément de sélection des accessoires.
Caractère 23 | A utiliser lors d'édition des PRX Exclure les lignes de commande PRX dont la commande de transfert est facturée (O/N, N par défaut)
Caractères 24 à 27 | Largeur du camion - à utiliser pour les palettes
Caractère 28 | Sélection de la ligne de (O/N) commande même si celle-ci n'a pas de nomenclature dans le cas d'une visualisation avec le détail de la nomenclature
Caractère 29 |
Caractère 30 | Édition de la liste des stocks (O/N) par lieux
Caractère 31 | Accès modification commande générée (touche F21) (O/N/Q) Q demande de confirmation
Caractère 32 | Confirmation de génération de commande (touches F11, F12, F13) (O/N, N par défaut)
Caractère 33 | Accès à la saisie des commandes après la génération sans demande - Génér.cde O Accès systématique à la saisie des commandes N Accès à la saisie des commandes avec demande de confirmation I Pas d'accès à la saisie des commandes
Caractère 34 | Accès aux commandes après génération par F13 (O/N, N par défaut)
Caractère 35 | Accès à l'édition des AR après la génération sans demande Génér.cde O Accès systématique à l'édition des AR N Accès à l'édition des AR avec demande de confirmation I Pas d'accès à l'édition des AR
Caractère 36 | Demande de confirmation de génération de BL (O/N, N par défaut) SPECIFIQUE (option payante CDE-02)
Caractère 37 | Demande de confirmation de l'édition provisoire du BL (O/N, N par défaut) SPECIFIQUE (option payante CDE-02)
Caractère 38 | Demande de confirmation de l'édition définitive du BL (O/N, N par défaut) SPECIFIQUE (option payante CDE-02)
Caractère 39 | Recherche des articles par le libellé étranger (F12) O Recherche par libellé étranger N ou [blanc] recherche par gencod A Recherche sur le libellé étranger avec la zone edc_prod_cli
Caractère 40 | Activation de la génération des CD1 hors plage paramétrées sur le TYC CDA (O/N, N par défaut)
Caractère 41 | Gestion de la charge en aveugle (mode batch) (O/N, N par défaut)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES MESSAGES EDI ORDERS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 6 | Touche F6 (O/N) - Rafraîchissement de l'écran de saisie suite aux modifications
Caractère 8 | Touche F8 (O/N) - Zoom sur le message EDI
Caractère 9 | Touche F9 (O/N) - Modification du prix
Caractère 11 | Touche F11 (O/N) - Génération de la ligne de commande correspondant au message EDI
Caractère 12 | Touche F12 (O/N) - Génération de la commande complète correspondant au message EDI
Caractère 13 | Touche F13 (O/N) - Génération de toutes les commandes relatives aux messages EDI affichés
Caractère 14 | Touche F14 (O/N) - Génération d'une ligne de BL - SPECIFIQUE (option payante CDE-02)
Caractère 15 | Touche F15 (O/N) - Génération d'un BL - SPECIFIQUE (option payante CDE-02)
Caractère 16 | Touche F16 (O/N) - Génération de tous les BL - SPECIFIQUE (option payante CDE-02)
Caractère 17 | Touche F17 (O/N) - Fusion des lignes CALDEL
Caractère 18 | Interdire pour un message EDI de type ORDERS, la possibilité de l'intégrer dans la gestion commerciale, par l'activation d'un statut spécifique I. Cette activation se fait par la touche F18, et est soumis à la gestion des permissions. Permission de type touche TOU, Code V_EDI_CDE_STATUT
Caractère 19 | Autorise la fonction F19 : Eclatement de la ligne CALDEL (O/ N, N par défaut)
Caractère 21 | Touche F21 (O/N) - Modification d'une commande générée à partir du message EDI
Caractère 22 | Touche F22 (O/N) - Modification le TYC
Caractère 23 | Touche F23 (O/N) - Génération des notes EMB et des étiquettes
Caractère 24 | Touche F24 (O/N) - Mise à jour des dates pour fusion EDI Les dates seront mises à jour par rapport aux dates saisies par l'utilisateur. Tous les messages qui ont une date supérieure à celle du champ date de début seront remplacés par la date de fusion. Nécessite la permission MEN DATE_MAJ Voir aussi la note _SUP_REQ_MAJ_DATE
Caractère 25 | Autorisation de la touche F25 (O/N) Voir la note SAISIE_COMMENTAIRE.

Notes triées

Rappel : les notes marquées Génér.cde concernent la génération de commande à partir de la visu des articles et des profils de stock (Plus d'info : voir #CF SSC).

ACCES_AR_TYC_

14,16 Type de commande : FB2/CD2/CD1 Génér.cde

17,19 Code site - Tableau de bord du multisite

21,26 Type du paramètre de lancement de l'édition des accusés de réception pour le TYC paramétré en 14,16 et éventuellement pour le site paramétré en 17,19

ACCES_CDE_TYC_

15,17 Type de commande : FB2/CD2/CD1 Génér.cde

18,20 Code site - Tableau de bord du multisite

21,26 Type du paramètre de lancement de la saisie des commandes pour le TYC paramétré en 15,17 et éventuellement pour le site paramétré en 17,19

Certains paramètres sont récupérés sur le paramètre de lancement lié à cette note.

ACCES_CREER_BL

21,26 Type et code paramètre de lancement de la saisie des BL à utiliser pour créer et modifier le BL à partir de la commande générée

Permet, lors de la génération de commande via la visualisation de l'EDI (Saisie simplifiée des commandes), de créer le BL dans la foulée.

Celui-ci est créé via la saisie des BL en mode création (-nCBl[numéro de commande]).

ACCES_EDI_BL

21,26 Type et code du paramètre d'édition provisoire du BL (Exemple #ED BPC)Génér.cde

(option payante CDE-02)

ACCES_EDI_DEF_BL

21,26 Type et code du paramètre d'édition définitive du BL (Exemple #ED BDV)Génér.cde

(option payante CDE-02)

ACCES_REEDI_BL

21,26 Type et code du paramètre de réédition provisoire du BL (Exemple #RD BLV) Génér.cde

(option payante CDE-02)

C_FAM_ART_DES_SIT

21,23 Code famille du produit

Cette note facultative fonctionne avec l'option da dans la note OPTION_CDE_TYC_ (ci-dessous)

Exemple

C_FAM_ART_DES_SIT XYZ

Pour la famille XYZ, le lieu de destockage sera en priorité celui du paramètre SIT.

Tableau de bord du multisite

COMPTEUR_EDC_REF

Lors de l'intégration de messages EDI PEUGEOT (type CALDEL), toutes les références commande client (EDC_REF) sont identiques, ce qui pose un gros problème d'intégration, car cette information sert de clé au traitement (intégration et génération de commande).

Dans ce cas, cette référence sera désormais dans la zone libellé commande client, et la zone actuelle référence client ne sera pas transmise.

Elle sera alimentée automatiquement lors de l'intégration par un compteur alphanumérique.

21, 29 Code racine du compteur alphanumérique (type K)

30 Longueur du folioteur

Exemple :

21 à 29 = PEUG

30 = 5

Cela donnera un code : PEUG00001

COMPTEUR_TYC_

14,16 Type de commande : FB2/CD2/CD1 (FBI aussi ? à vérifier)

17,19 Code site - Tableau de bord du multisite

21,22 Numéro de compteur

COMPTEUR_TYC_BLV

21,22 Numéro de compteur

CTRL_FUSION_CALDEL

21 Contrôle de la présence de lignes CALDEL à fusionner avant la génération des commandes

N pas de contrôle (par défaut)

W contrôle non bloquant

B contrôle bloquant

CTRL_PRIX_0_TYC_

Contrôle du prix à zéro

17,19 Type de commande (Paramètre TYC)

21,21 Type de contrôle si le prix de la ligne de commande à générer est à 0 -.Facultatif

N Pas de contrôle

W Contrôle non bloquant

C Contrôle avec demande de confirmation

B Contrôle bloquant (par défaut)

FICHIER_TRACE_GB

21,60 Nom (et chemin) du fichier trace de la génération automatique des commandes

Génér.cde Voir option Ogb

NTS_ART_A_RECOPIER

Recopie de note de l'article commandé sur la ligne de commande générée

Voir l'option Ocn

21,23 Type de notes à copier de l'article

24,26 Type de note à créer sur la commande

OPTION_BL

OPTION_BL_TYC ?

(option payante CDE-02)

21 à 60 Options pour la génération de bon de livraison :

ny Numérotation annuelle des BL : seul cas possible, les autres sont inhibés.

OPTION_CDE_TYC_

Options à prendre en compte dans la saisie de commande Génér.cde

16,18 Type de commande : FB2/CD2/CD1

21,60 Options de lancement de cde en fonction du TYC :

ae Code édition AR de la commande mis à éditer O si modification de la quantité commandée
ou si modification du délai répondu
ou si modification de l'adresse de livraison
ou si modification de la laize ou de la coupe pour les articles cartonniers
ou si modification des informations complémentaires

af Actualisation des FBI générées en édition d'accusé de réception

au Edition automatique des AR après modification de commande

c2 Contrôle de cohérence entre le code représentant de l'entête et celui de la ligne.
Un des 2 codes doit être saisi.

cr Contrôle de cohérence entre code représentant de l'entête et celui de la ligne
Un des 2 codes doit être saisi.
Si les 2 sont saisis, ils doivent être différents.

da En configuration multi-site, l'application prend par défaut le lieu de déstockage dans le paramètre SIT.
Avec cette option, on inverse les priorités, c'est-à-dire que le lieu de déstockage de l'article est pris en priorité sur la fiche article.
La note C_FAM_ART_DES_SIT permet d'exclure des codes familles que l'on préfère mettre en priorité sur le lieu du paramètre SIT - Tableau de bord du multisite

dl Prise en compte du délai laboratoire dans le calcul de la date de fin de fabrication (correspond à la note DELAI_LABO_FIN_FAB sur le paramètre de lancement de la saisie de commande)

dr Ecrit le détail de la remise dans notes ### REM

lt Construit le libellé de la ligne de commande en fonction de TYC alpha1[44].
Si cette option n'est pas activée, l'ordre des dimensions sera toujours Largeur Longueur

mm Pas de mise à jour des mouvements de stock

ny Numérotation annuelle des numéros de commande

pu Visu total ligne

r1 Le code représentant de l'entête de commande est initialisé avec celui du code adresse de réception

r2 Le code représentant de la ligne de commande est initialisé avec celui du code adresse de livraison

ra Contrôle des délais de réapprovisionnement des accessoires (correspond à la note VERIF_DELAI_REAP_ACC sur le paramètre de lancement de la saisie de commande)

rm Prise en compte du fichier remise

sr Pas de mise à jour du stock résultant

t3 Prise en compte du fichier tarif en utilisant la date de livraison au lieu de la date de cde

tc Tarif cartonnier

tr Prise en compte du fichier tarif

uv On utilise l'unité de vente pour calculer le prix de vente issu du fichier mat / prod et le prix du mouvement de stock

vn Contrôle de la validité des composants (PF) du produit vendu

PARAM_INDICATEURS

21,26 Type et code paramètre de configuration du récapitulatif des coûts

Lors de la génération de commande, le prix de revient unitaire est calculé depuis le récapitulatif des coûts du devis..

PARAM_REMPLIR_ZONE

21,26 Type et code du paramètre de configuration pour remplir les zones de la ligne de commande client

Voir la note commençant par Z dans le #CF TDC.

QUALIFICATIF_APPEL

21,23 Qualification pour la création du cadencement (paramètre de type QAL)

QUALITES_EXCLUES

21,23 Code qualité à exclure de la recherche de code produit à partir des libellés étrangers

Permet d'exclure les articles dans la recherche par libellés étrangers (F12 dans le détail de la ligne EDI) dont le code qualité est paramétré.

S

3,60 Complément de requête sur la table edi_cde

SAISIE_COMMENTAIRE

Modifier les libellés de la table edi_cde. Voir A4[25]

21 Modification de la zone edc_com1 (O/N, O par défaut)

22 Modification de la zone edc_com2 (O/N, O par défaut)

23 Modification de la zone edc_com3 (O/N, O par défaut)

24 Modification de la zone edc_lig_com (O/N, O par défaut)

_SUP_REQ_LIB_xxxxxx

_SUP_REQ_LIB_CALDEL

_SUP_REQ_LIB_DELFOR

_SUP_REQ_LIB_DELINS

_SUP_REQ_LIB_INVRPT

_SUP_REQ_LIB_ORDERS

21, 60 Complément de sélection pour la recherche de référence sur transfert EDI via les libellés étrangers

Le mot clé %PRODUIT% peut être utilisé : il sera remplacé à l'exécution de la requête par le code produit utilisé au moment du transfert.

Exemple : and le_libelle2 = %PRODUIT%

A partir du moment où un complément de sélection est paramétré, la zone de recherche n'est plus précisée (and [zone de lib_etr] = [produit utilisé dans l'interface EDI]).

Dans ce cas, il est nécessaire de l'ajouter manuellement au complément de sélection grâce au mot clé %PRODUIT% (and [zone] = %PRODUIT%).

_SUP_REQ_MAJ_DATE

21,60 Supplément de requête pour la recherche des dates à mettre à jour

Voir A4[24]

Exemple

_SUP_REQ_MAJ_DATE and edc_cli = 'PE0024'

_SUP_REQ_MAJ_DATE and edc_adl like '07%'

_SUP_REQ_STK0_NIV2

21 à 60 Supplément de requête sur stk0 pour exclure certains lieux de rangement lors de la recherche du stock pour la livraison

Ex : and s0_rgt2 not in ("NVE", "ARE")

(option payante CDE-02)

_SUP_REQ_STK_TYC_xxx

21, 60 Complément de requête sur stk0

_SUP_REQ_TYC_MODIF

21,60 Complément de sélection sur la table par02 pour la recherche du TYC

La touche F22 permet de modifier le TYC d'une commande (la commande ne doit pas être générée).

Ce complément de sélection permet de restreindre le choix des TYC proposés.

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage

TSC_POUR_ENREG_MVT

21,23 Code du TSC qui enregistre le type du mouvement sur la ligne du BL- Obligatoire

TYP_CTRL_STK_TYC_xxx

21 Type de contrôle du stock (N, B, C, W)

W Warning

N non (valeur par défaut)

B Bloquant (ne génère pas la ligne de commande)

C demande de confirmation

TYP_LOT_LIEU_TYC_xxx

21 Type de recherche du stock physique

0 Par lot

1 Par lieux

2 Par lots-lieux (valeur par défaut)

3 Par lieux-lots

TYPE_MVT_

10,14 Type du mouvement transféré

21,23 Code du mouvement dans VoluPack

Option Obl obligatoire

TYPE_NTS_EDC_COM

21,23 Type de notes dans lequel on va recopier les valeurs edc_com1, edc_com2 et edc_com3

VOLUWEB_DUREE_BOUCLE

21,22 Temps d'attente VoluWeb

VOLUWEB_NBRE_BOUCLE

21,22 Nombre de boucles d'attente VoluWeb

Les notes SPECIFIQUES (option payante CDE-02) nécessitent le paramétrage suivant :

TYC CDE alpha1[34] = N (on ne génère pas de FBI)

RG1 XXX alpha1[14,19] = code du client (où XXX = Code magasin plate forme extérieure)

La correspondance du client externe avec le client VoluPack se fera par une note de type EDI sur le code client VoluPack paramétrée ainsi :

Caractères 1 à 19 : Code client externe

Caractères 20 à 22 : Code magasin plate forme extérieure

Paramètres nécessaires

TYC CDE, alpha1[34] Génération de FBI

TYC CDA, alpha4[1,3] et alpha4[4,9] TYC généré par une CDA

RG1, alpha1[14,19] Code du client

mp_param[29] En fonction de la valeur lue :

Si valeur 1, accès à #CF ATL alpha2[19,21]

Si valeur 2, accès à #CF ATL alpha2[27,29]

UNI, valeur numérique 1

REP, valeur numérique 1

REA alpha2[1]

#CF CAR notes SUPREQPAL

#CF CDE alpha3[37,38]

#CF CDE note DELAI_REP_EN_JOURS

#CF CHA note commençant par POURC_OCCUP_JOUR

BLO

BLO alpha3[1], alpha3[2] et alpha3[3]

BLO alpha1[3,5] code blocage

BLO alpha3[31,34] si code blocage 002 : pourcentage en moins

BLO alpha3[35,38] si code blocage 002 : pourcentage en plus

BLO notes commençant par CBACON pour les codes blocage automatiques

Certains paramètres de lancement de la saisie de commandes sont exploités ici

Voir la note ACCES_CDE_TYC

cde alpha4[18,20] Site de production par défaut

cde alpha4[30] Contrôle de la surface mini à commander

cde notes CBACON, CBAFBI

cde notes PARAM_RECH_TARIF et PARAM_RECH_REMISE

cde notes TSC_CCL_A_RECOPIER

cde notes TSC_CLI_A_RECOPIER

cde notes TSC_MAT_A_RECOPIER

Ordres de tris disponibles

Voir les notes commençant par O

01 | num_msg (tri sur numéro de message)
02 | code_cli (tri sur code client)
03 | date_cde (tri sur date de commande)
04 | tyc_cde (tri sur type de commande)
05 | statut (tri sur statut)
06 | cde_gen (tri sur numéro de commande générée)
07 | cde_ref (tri sur numéro de commande client)
08 | cde_lig (tri sur numéro de ligne)
09 | cde_rat (tri sur numéro commande référence du contrat)
10 | usi_des (tri sur usine destinataire)
11 | sit_pro (tri sur site de production)
12 | date_liv (tri sur date de livraison)
13 | site_liv (tri sur adresse de livraison)
14 | code_prod (tri sur code produit)
15 | cl_suiv (tri sur code suivi d'affaire)

Liste des noms de zones autorisés

edi_cde

Toutes zones de la table

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

client

Package Tiers

ainsi que les zones suivantes :

cl_vil_livr | Ville de l'adresse de livraison
cl_param16 | Zone 16 des données diverses

autres

using | Voir #VI
nb_palette | Nombre de palettes sur un message de type CALDEL

Commandes clients

ec_xxx | Tous les champs de la table cde1 (entête de commande) (utilisables dans les formules de calcul)
lc_xxx | Tous les champs de la table cde2 (ligne de commande) (utilisables dans les formules de calcul)


v_edi_cde_delfor Visualisation des messages EDI de commande et génération de commande

SPECIFIQUE. Les noms de zones à visualiser sont figés.

Ce programme permet de visualiser les messages DELFOR et DELINS.

Pour visualiser les messages CALDEL et ORDERS, voir le programme v_edi_cde.

Pour optimiser les temps de réponse, créer un index sur la table edi_cde :

index ix_edi_cde_[cli] colonnes : edc_cli, edc_delcli, edc_type_message

Options

Ogc

Cette option permet de générer des commandes selon un TYC paramétré dans la note TYC_CREER_CDE.

Les messages EDI doivent avoir un statut du type z.

Attention : toutes les commandes du TYC paramétré seront annulées logiquement avant la création des commandes, sauf si c'est un TYC standard.

Pour éviter la multiplication des numéros de commande, il est possible, via la note NB_LIG_MAX_CDE, de paramétrer le nombre de ligne maximum contenu dans une commande créée.

Si certains messages EDI n'ont pas créé de ligne de commande suite à une erreur (par exemple le code produit n'existe pas), le statut de cette ligne deviendra e et sera répertorié dans les logs d'anomalie.

Les commandes sont créées selon les ruptures suivantes :

1. Selon la zone ec_c1

2. Selon le code client VP

3. Selon le nombre de ligne maximum autorisé par commande

Valeur alpha 2

Caractère 1 | Accès suppression ligne par F2 (O/N, N par défaut)
Caractère 2 | Autorisation génération de commande (touche F12) (O/N, N par défaut)
Caractère 3 | Demande de confirmation de la génération de commande (O/N, N par défaut)
Caractère 4 | Accès aux commandes après génération par F12 en automatique (O/N, N par défaut)
Caractère 5 | Demande d'accès données LIGFLX par F9 (O/N)
Caractère 6 | Confirmation du lancement de l'accusé de réception (O/N, N par défaut) SPECIFIQUE
Caractères 7 à 9 | Type de mouvement normale pour une sortie de BL (LR par défaut)
Caractère 31 | Accès modification commande générée (touche F21) (O/N/Q) Q demande de confirmation
Caractère 32 | Confirmation de génération de commande (touches F11, F12, F13) (O/N, N par défaut)
Caractère 33 | Accès à la commande après génération sans demande (O/N, N par défaut)
Caractère 34 | Accès aux commandes après génération par F13 (O/N, N par défaut)
Caractère 35 | Accès à l'édition de l'AR après génération sans demande (O/N, N par défaut)
Caractère 36 | Confirmation de génération de BL (touches F14, F15, F16) (O/N, N par défaut)
Caractère 37 | Demande d'édition automatique du BL (O/N, N par défaut)
Caractère 38 | Contrôle d'édition définitive du BL (O/N, N par défaut)
Caractère 39 | Récupération du code article VoluPack (touche F12) O Recherche sur le libellé étranger avec la zone edc_ref_art_cli A Recherche sur le libellé étranger avec la zone edc_prod_cli autres Recherche sur mp_gencod avec la zone edc_ref_art_cli
Caractère 40 | Activation de la génération des CD1 hors plage paramétré sur le TYC CDA

Valeur alpha 3

Titre de la visualisation

Par défaut : Visualisation des messages DELFOR

Valeur alpha 4

Caractères 1 à 6

Type et code du paramètre de lancement de v_cdem

Notes

ACCES_AR_TYC_xxx

21,26 Type et code du paramètre de lancement de l'édition de l'AR

ACCES_CDE_TYC_xxx

21,26 Type et code du paramètre de lancement de la commande de type xxx.

ACCES_TYC_CDI

21,26 Type et code du paramètre pour modification de commande de type CDI

COMPTEUR_TYC_xxx

21,22 Compteur à reprendre pour la génération de commande de type xxx.

EDITION_AR_FBI

21,26 Type et code du paramètre de lancement de l'édition des AR de FBI

NB_LIG_MAX_CDE

21,23 Nombre de lignes maximum contenu dans une commande, avant la création d'une nouvelle commande

Voir l'option Ogc

Le nombre est compris entre 1 et 400 lignes.

OPTION_CDE_TYC_xxx

21,60 Options de lancement pour saisie des commandes xxx:

ae | Code édition AR de la commande mis à éditer O si modification de la quantité commandée ou si modification du délai répondu ou si modification de l'adresse de livraison ou si modification de la laize ou de la coupe pour les articles cartonniers ou si modification des informations complémentaires
af | Actualisation des FBI générées en édition d'accusé de réception
c2 | Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne Un des 2 codes doit être saisi.
cr | Contrôle de cohérence entre le code représentant de l'entête et le code représentant de la ligne Un des 2 codes doit être saisi. Si les 2 sont saisis, ils doivent être différents
dl | Prise en compte du délai laboratoire dans le calcul de la date de fin de fabrication
dr | Contrôle des délais de réapprovisionnement des accessoires
ny | Numérotation annuelle des numéros de commande
r1 | Le code représentant de l'entête de commande est initialisé avec celui du code adresse de réception
r2 | Le code représentant de la ligne de commande est initialisé avec celui du code adresse de livraison
sr | Pas de mise à jour du stock résultant

SUP_REQ_EDI_CDE

21,60 Supplément de requête sur la table edi_cde

SUP_REQ_STK0_EXT

21,60 Supplément de requête sur la table stk0 pour le magasin externe

SUP_REQ_STK0_USI

21,60 Supplément de requête sur la table stk0 pour le magasin usine

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage

TYC_CREER_CDE

21,23 Type de commande client utilisé lors de la création en automatique des commandes

Voir l'option Ogc


v_edi_stk_bob Visualisation de la table EDI des sorties des bobines

001 Bobine inexistante

002 Bobine annulée

003 Bobine non suivie en stock

004 Bobine consommée entièrement

005 Papier de la bobine non renseigné

006 Papier inexistant

007 Papier annulé

008 Papier non suivi en stock

009 Papier consommé entièrement

010 Poids bobine restant > Poids bobine physique

011 Métrage bobine restant > Métrage bobine physique

012 Poids sortie > Stock physique papier

013 Longueur sortie > Stock physique papier

v_edi_stk_bob Visualisation de la table EDI des sorties des bobines

Ce programme est opérationnel à partir de la V. 4.0.170.2.

Voir le programme d'intégration des sorties de bobines.

Options

Orv

Rafraîchissement automatique de la visualisation si nécessaire (après la modification du statut)

Valeur alpha 2

A2[1] | Second écran de sélection (O/N, N par défaut)
A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)
A2[10] | Lancement du programme en Batch E Edition F Fichier

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[8] | Touche F8 - Modification du statut (O/N, N par défaut) Le statut a 4 valeurs possibles A A traiter - Le statut peut être mis à S. E Erreur - Le statut peut être mis à A. Liste des codes erreurs T Traité - La modification du statut n’est pas autorisée. S Supprimé - Le statut peut être mis à A.
A4[25] | Touche F25 - Rafraîchissement de la visualisation (O/N, N par défaut)
A4[47] | Touche CONTROL-O - Visualisation de la traçabilité (O/N, N par défaut)
A4[48] | Touche CONTROL-P - Visualisation des mouvements de stock (O/N, N par défaut)

Notes

AUTORISE_TOUCHE_F254 | 21 Autorisation de la touche transfert vers Excel (O/N, N par défaut)
_SUP_REQ_EDI_STK_BOB | 21,60 Complément de sélection sur la table edi_stk_bobine

Ordres de tri disponibles

01 | eds_bobine_int Numéro de bobine interne
02 | eds_bobine_four Numéro de bobine fournisseur
03 | eds_date_heure_sor[1,8] Date de sortie
04 | eds_date_heure_sor[9,14] Heure de sortie
05 | eds_num_prog Numéro de programme
06 | eds_code_lanceur Code lanceur
07 | eds_statut Code statut
08 | eds_code_erreur Code erreur

Liste des zones disponibles

Matières

Mouvements de Stock

using - Voir #VI

edi_stk_bobine Toutes les zones de la table + les zones suivantes

des_bobine_int Désignation du numéro de bobine interne

eds_date_sor Date de sortie

eds_heure_sor Heure de sortie

lib_eds_code_erreur Libellé du code erreur

lib_eds_statut Libellé du statut

libc_eds_code_lanceur, libl_eds_code_lanceur Libellés court et long du code lanceur


v_fab0 Visualisation des dossiers de fabrication

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : ordre de fabrication

Exemple : -N[f0_of]

Options

Oem

Si un des 4 cumuls (Entrées de la totalité et du jour et sorties de la totalité et du jour) des mouvements de stock du composant du dossier est différent de 0, les mouvements de stock de l'ensemble ne sont pas cumulés même si celui-ci est monté.

Ogs

Test si l'OF a été traité dans fab_1_etat avant la date d'en cours au lieu de fab_ond

Old

N'édite pas les lignes de détail de l' OF (celles comprenant un / dans le numéro de l'OF).

Opt

Pas de prise en compte des rapports de production transfo

L'option Or2 doit être activée.

Or2

Règle 2 de calcul du stock d'en-cours

S'il n'existe pas de rapport de production onduleuse/extrudeuse et transfo, l'en-cours est à 0.

S'il existe uniquement un rapport de production transfo, l'en-cours est égal à la quantité lancée de l'OF moins les entrées magasins.

S'il existe un rapport de production onduleuse/extrudeuse, l'en-cours est égal à la quantité réalisée de l'OF en sortie de l'onduleuse/extrudeuse moins les entrées magasins.

Valeur alpha 2

Paramétrage des options

Caractère 1 | Second écran de sélection
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 31 | Saisie de la date de l'encours

Valeur alpha 3

Titre de la visualisation

Valeur alpha 4

Paramétrage des touches de fonction

A4[5] | Touche F5 (O/N, N par défaut) Rafraîchir l'écran de visualisation
A4[6] | La touche F6 permet de marquer le dossier de fabrication comme généré (f0_gener = 1) Cette touche peut être conditionnée par une permission (TOU V_FAB0_F6).
A4[37] | Touche Ctrl-B pour accès à la visualisation des stocks Voir aussi #CF ATL A1[24]

Notes

PARAM_EDI_FIC_FAB | 21 26 Type et code du paramètre de lancement de l'édition de la fiche de fabrication Facultatif - #EDFFA par défaut
PARAM_GEN_DOS | 21 26 Type et code du paramètre de lancement de la génération du dossier Facultatif - #FBGDF par défaut
PARAM_LAN_DOS | 21 26 Type et code du paramètre de lancement du lancement du dossier Facultatif - #FBDOS par défaut
PARAM_REG_DOS | 21 26 Type et code du paramètre de lancement de la régénération du dossier Facultatif - #FBRGD par défaut

Ordres de tris disponibles

1 | nof | Numéro d'ordre de fabrication
2 | cli | Code Client
3 | sec | Code
4 | dat | DATE COMMANDE
5 | prd | Code produit
6 | ope | OPERATEUR
7 | rat | Commande de rattachement
8 | dep | DATE DEPART COMMANDE
9 | fab | Date fin fab cde

Listes des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Table fab0

Table fab_ond_of

Toutes les zones du package Tiers

Entête de commande

Ligne de commande

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Zones calculées

Table fab0

f0_soc | Code de la société
f0_of | Numéro d'OF
f0_tri | Numéro de tri
f0_cde | Numéro de commande
f0_lig | Numéro de ligne de commande
f0_cli | Numéro de client
f0_prod | Code de l'article
f0_rep | Numéro de repaire
f0_marq | Marque
f0_larg | Largeur
f0_long | Longueur
f0_qtel | Quantité lancée
f0_qter | Quantité réalisée
f0_gp | Quantité gâche prévue
f0_gr | Quantité gâche réalisée
f0_delp | Date délai prévu
f0_delr | Date délai réel
f0_cmn | Coût matière du niveau
f0_cpn | Coût préparation de ce niveau
f0_crn | Coût réalisation de ce niveau
f0_cmp | Coût matière prévu variable
f0_cmr | Coût matière réalisé
f0_cpp | Coût préparation prévu = Coût fixe total
f0_cpr | Coût préparation réel
f0_crp | Coût réalisation prévu (MO) Variable
f0_crr | Coût réalisation réel
f0_cp | Coût prévu
f0_cr | Coût réel
f0_sim | Simulation (O/N)
f0_gener | Dossier généré (0, False, 1, True)
f0_lance | Dossier lancé (0, False, 1, True)
f0_edite | Dossier édité (0, False, 1, True)
f0_clos | Dossier clôturé (0, 1, 5, 10 ou 15)
f0_acalc | Dossier à calculer (0, False, 1, True)
f0_typga | Type de gamme
f0_phase | Dernière opération exécutée (numéro de phase)
f0_datde | Date effective de début de fabrication
f0_nummvt | Numéro de mouvement de stock engendré
f0_datfc | Date de début prévue de fabrication
f0_hdp | Heure de début prévue de l'oF
f0_hdf | Heure de fin prévue de l'oF
f0_coef_nom | Coefficient de nomenclature
f0_prix_uni | Coût unitaire
f0_gp_f | Gâche prévue fixe
f0_gr_f | Gâche réalisée fixe
f0_capteur | Numéro du capteur en entrée
f0_capteur_s | Numéro du capteur en sortie
f0_anu | Annulé (O/N)
f0_date | Date de clôture du dossier
f0_user | Opérateur
libc_f0_gener | Libellé du flag de génération
libc_f0_lance | Libellé du flag de lancement
libc_f0_edite | Libellé du flag d'édition
libc_f0_clos | Libellé du flag de clôture
libc_f0_acalc | Libellé du flag de calcul
libc_f0_anu | Libellé du flag d'annulation
f0_uni_prod libc_f0_uni_prod libl_f0_uni_prod | Unité de production Libellé court Libellé long
f0_long | Longueur
f0_larg | Largeur
f0_hau | Hauteur
f0_poids | Poids
f0_dt1 | Donnée technique 1
f0_dt2 | Donnée technique 2
f0_qtel_up | Quantité lancée en unité de production (cumulable)
f0_qter_up | Quantité réalisée en unité de production (cumulable)

Ordres de fabrication onduleuse et extrudeuse

x3_qte_plaq_real | Quantité de plaques réalisées
x3_surf_real | Surface réalisée
x3_poids_real | Poids réalisé

Entête de commande

ec_datc | Date de la commande
ec_c1 | Paramètre de l'entête de la commande
libc_ec_c1 | Libellé court de ec_c1
libl_ec_c1 | Libellé long de ec_c1
ec_ar | AR à éditer
ec_texte | Commentaire libre
ec_ref ec_ref_2 | Référence de la commande client 2ème Référence de la commande client
libc_ec_oe libl_ec_oe | Ordre d'exécution édité Libellé court : Oui / Non Libellé long : Edité / Non édité
ec_issue_de | Commande issue de

Ligne de commande

lc_cderat | Commande de rattachement
lc_lcderat | Ligne de la commande de rattachement
lc_deldep | Date départ (ligne de commande)
lc_delfab | Date de fin de fabrication (ligne de commande)
lc_date_gener | Date de génération
lc_date_regener | Date de régénération
lc_poids | Poids unitaire
lc_lib | Libellé du produit
lc_rat_prod | Code produit de la ligne de commande de rattachement
lc_rat_lib | Libellé de la ligne de commande de rattachement
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Zones calculées

cumul_entrées | Cumuls des quantités entrées pour l'OF
cumul_sorties | Cumuls des quantités sorties pour l'OF
quantite_en_cours | Quantité lancée - Cumuls des quantités entrées
poids_en_cours | Poids de la quantité en cours
surface_en_cours | Surface de la quantité en cours
montant_en_cours | Montant de l'en cours (coût prévu / quantité lancée) * quantité en cours
poids_lance | Poids de la quantité lancée
surface_lancee | Surface de la quantité lancée
reste_a_realiser | Quantité lancée - quantité réalisée 0 si quantité lancée < quantité réalisée
triplet_ope | Code Sec-Ope-Sop de la dernière opération exécutée (libellé en clair de f0_phase)
machine | Code machine de la dernière opération exécutée
lib_machine | Libellé machine de la dernière opération exécutée
quantite_ond_ext | Quantité de PF réalisés en sortie de l'onduleuse/extrudeuse


v_fab2 Visualisation du réalisé production

Champs | fab2 unitaire | å fab2 par phase | Totaux uniquement | libellé | TTR A1[2] | TTR A1[4] | TTR A1[7] | TTR A1[9] | TTR A1[10] | TTR A1[11] | Exemple / commentaire
f2_total | x |  |  | tous les temps saisis en production |  |  |  |  |  |  |
f2_total_ph |  | x |  |  |  |  |  |  |  |  |
tps_exclu | x |  |  | Tps exclu |  | = E |  |  |  |  | nettoyage fin de semaine par exemple
tps_exclu_ph |  | x |  | " |  |  |  |  |  |  |
tps_ouverture | x |  |  | temps total - temps exclu |  |  |  |  |  |  |
tps_ouverture_ph |  | x |  | " |  |  |  |  |  |  |
tps_arret | x |  |  | Arrêt non exclu affectable ou non au dossier |  | <> E | = O |  |  | = O | Tous sauf nettoyage fin de semaine par exemple
tps_arret_ph |  | x |  | " |  |  |  |  |  |  |
tps_arret_aff | x |  |  | Arrêt non exclu affectable au dossier | = D | <> E | = O |  |  | = O | Attente outillage par exemple
tps_arret_aff_ph |  | x |  | " |  |  |  |  |  |  |
tps_arret_naff | x |  |  | Arrêt non exclu non affectable au dossier | <> D | <> E | = O |  |  | = O | Panne mécanique par exemple
tps_arret_naff_ph |  | x |  | " |  |  |  |  |  |  |
tps_arret_tot | x |  |  | Arrêt y compris arrêt exclu |  |  | = O |  |  |  |
tps_arret_tot_ph |  | x |  | " |  |  |  |  |  |  |
tps_reglage | x |  |  | Tps de réglage |  | <> E | <> O | = O |  |  |
tps_reglage_ph |  | x |  | " |  |  |  |  |  |  |
tps_roulage | x |  |  | Tps de roulage |  | <> E | <> O |  | = O |  |
tps_roulage_ph |  | x |  | " |  |  |  |  |  |  |
tpsp_reglage | x |  |  | Tps prévu de réglage (issu de l'opération élémentaire de rattachement) |  |  |  |  |  |  |
tpsp_reglage_ph |  | x |  | " |  |  |  |  |  |  |
tpsp_roulage | x |  |  | Tps prévu de roulage (issu de l'opération élémentaire de rattachement) |  |  |  |  |  |  | calcul sous la forme {qté produite / cadence de l'opé. élémentaire}
tpsp_roulage_ph |  | x |  | " |  |  |  |  |  |  |
tps_marche | x |  |  | Tps de marche = Tps de réglage + tps de roulage |  |  |  |  |  |  |
tps_marche_ph |  | x |  | " |  |  |  |  |  |  |
tps_mar_arr | x |  |  | = tps de marche + les arrêts affectables au dossier |  |  |  |  |  |  |
tps_mar_arr_ph |  | x |  | " |  |  |  |  |  |  |
tps_reg_arr | x |  |  | = tps de réglage + les arrêts affectables au dossier lors du réglage |  |  |  |  |  |  |
tps_reg_arr_ph |  | x |  | " |  |  |  |  |  |  |
tps_roul_arr | x |  |  | = tps de roulage + les arrêts affectables au dossier lors du roulage |  |  |  |  |  |  |
tps_roul_arr_ph |  | x |  | " |  |  |  |  |  |  |

Champs | fab2 unitaire | å fab2 par phase | Totaux uniquement | libellé | TTR A1[2] | TTR A1[4] | TTR A1[7] | TTR A1[9] | TTR A1[10] | TTR A1[11] | Exemple / commentaire
qte_roulage | x |  |  | Quantité produite bonne en unité de sortie machine |  |  |  |  |  |  | nombre d'emballages par exemple
qte_roulage_ph |  | x |  | " |  |  |  |  |  |  |
qte_roulage_po | x |  |  | Quantité produite bonne en unité d'entrée machine |  |  |  |  |  |  | Par exemple : nombre de plaques au margeur ayant donné des emballages "bons". Mais ce peut êre aussi des mètres linéaires si c'est l'unité de passage
qte_roulage_po_ph |  | x |  | " |  |  |  |  |  |  |
f2_rebut | x |  |  | Quantité de gâche en unité de sortie machine |  |  |  |  |  |  | Nombre d'emballages perdus au roulage par exemple, si phase de roulage
f2_rebut_ph |  | x |  | " |  |  |  |  |  |  |
f2_reb_po | x |  |  | Quantité de gâche en unité d'entré machine |  |  |  |  |  |  | Par exemple : nombre de plaques de réglage par exemple si sur une phase de réglage
f2_reb_po_ph |  | x |  | " |  |  |  |  |  |  |
gacp_prevu | x |  |  | Quantité de gâche prévue en unité de sortie machine (issue de l'opération élémentaire de rattachement) |  |  |  |  |  |  | calcul sous la forme {si réglage : {gâche fixe de l'opé élémentaire} si roulage : {qte_roulage * % gâche variable de l'opé élémentaire}
gacp_prevu_ph |  | x |  |  |  |  |  |  |  |  |
gacp_prevu_po | x |  |  | Quantité de gâche prévue en unité d'entrée machine (issue de l'opération élémentaire de rattachement) |  |  |  |  |  |  |
gacp_prevu_po_ph |  | x |  |  |  |  |  |  |  |  |
gl_laize | x | x |  | Largeur en entrée machine |  |  |  |  |  |  | Stocké sur le TSC 510 de la phase, si non trouvé, long x larg sur le sous-OF avec pour matière la qualité
gl_coupe | x | x |  | Longueur en entrée machine |  |  |  |  |  |  | Stocké sur le TSC 510 de la phase, si non trouvé, long x larg sur le sous-OF avec pour matière la qualité
pousse | x | x |  | idem gl_coupe |  |  |  |  |  |  |
ouverture | x | x |  | idem gl_laize |  |  |  |  |  |  |
surf_roulage | x |  |  | surface de support bonne lors d'une phase de roulage |  |  |  |  |  |  | Qte_roulage_po * ouverture * pousse
surf_roulage_ph |  | x |  | " |  |  |  |  |  |  | "
surf_gache | x |  |  | surface de support gâchée en réglage ou roulage |  |  |  |  |  |  | f2_reb_po * ouverture * pousse
surf_gache_ph |  | x |  | " |  |  |  |  |  |  | "
surf_total | x |  |  | Surface en roulage + surface de gache |  |  |  |  |  |  |
surf_total_ph |  | x |  | " |  |  |  |  |  |  |
poids_roulage | x |  |  | surface roulage * poids de 1 m² de support |  |  |  |  |  |  | poids de 1m² de support trouvé dans mp_poids de l'article "Q.." correspondant
poids_roulage_ph |  | x |  |  |  |  |  |  |  |  |
poids_gache | x |  |  | surface de support gâchée en réglage ou roulage * 1 m² de support |  |  |  |  |  |  | poids de 1m² de support trouvé dans mp_poids de l'article "Q.." correspondant
poids_gache_ph |  | x |  |  |  |  |  |  |  |  |
poids_total | x |  |  | Poids en roulage + poids de la gâche |  |  |  |  |  |  |
poids_total_ph |  | x |  |  |  |  |  |  |  |  |
nb_of | x |  |  | nombre d'OF différents comptabilisés (cf commentaire) |  |  |  |  |  |  | lors du traitement, compteur avec +1 à chaque changement d'OF. L'ordre de tri est donc essentiel pour la signification de la donnée. Exemple : tri par OF puis machine donnera un résultat différent de tri par date/heure puis OF puis machine)
nb_of_ph |  | x |  |  |  |  |  |  |  |  |
nb_reglage | x |  |  | nombre de réglages |  | <> E | <> O | = O |  |  | si TTR A1[3] = "O" alors la quantité de réglage comptabilisé est de 1, si "N" qte de réglage = quantité saisie, si blanc qte de réglage = 0
nb_reglage_ph |  | x |  |  |  |  |  |  |  |  |

Champs | fab2 unitaire | å fab2 par phase | Totaux uniquement | libellé | TTR A1[2] | TTR A1[4] | TTR A1[7] | TTR A1[9] | TTR A1[10] | TTR A1[11] | Exemple / commentaire
cad_pl_to | x |  |  | cadence en unité d'entrée machine sur temps d'ouverture |  |  |  |  |  |  | qte_roulage_po / tps_ouverture. L'unité dépend de l'unité de roulage
cad_pl_to_ph |  | x |  |  |  |  |  |  |  |  |
cad_pl_tm | x |  |  | cadence en unité d'entrée machine sur temps de marche |  |  |  |  |  |  | qte_roulage_po / tps_marche
cad_pl_tm_ph |  | x |  |  |  |  |  |  |  |  |
cad_pl_tra | x |  |  | cadence en unité d'entrée machine sur temps de marche + les arrêts affectables |  |  |  |  |  |  | qte_roulage_po / tps_mar_arr
cad_pl_tra_ph |  | x |  |  |  |  |  |  |  |  |
cad_pl_tr | x |  |  | cadence en unité d'entrée machine sur temps de roulage |  |  |  |  |  |  | qte_roulage_po / tps_roulage
cad_pl_tr_ph |  | x |  |  |  |  |  |  |  |  |
cad_m2_to | x |  |  | cadence en m² sur temps d'ouverture |  |  |  |  |  |  | surf_roulage / tps_ouverture
cad_m2_to_ph |  | x |  |  |  |  |  |  |  |  |
cad_m2_tm | x |  |  | cadence en m² sur temps de marche |  |  |  |  |  |  | surf_roulage / tps_marche
cad_m2_tm_ph |  | x |  |  |  |  |  |  |  |  |
cad_m2_tra | x |  |  | cadence en m² sur temps de marche + les arrêts affectables |  |  |  |  |  |  | surf_roulage / tps_mar_arr
cad_m2_tra_ph |  | x |  |  |  |  |  |  |  |  |
cad_m2_tr | x |  |  | cadence en m² sur temps de roulage |  |  |  |  |  |  | surf_roulage / tps_roulage
cad_m2_tr_ph |  | x |  |  |  |  |  |  |  |  |
cad_ml_to_mn | x |  |  | cadence en unité par minute sur temps d'ouverture |  |  |  |  |  |  | cad_pl_to / 60 : utile par exemple pour une onduleuse…
cad_ml_to_mn_ph |  | x |  |  |  |  |  |  |  |  |
cad_ml_tm_mn | x |  |  | cadence en unité par minute sur temps de marche |  |  |  |  |  |  | cad_pl_tm / 60 : utile par exemple pour une onduleuse…
cad_ml_tm_mn_ph |  | x |  |  |  |  |  |  |  |  |
cadp_plaque | x | x |  | cadence prévue sur l'opération élémentaire de rattachement |  |  |  |  |  |  | si roulage
cadp_m2 | x | x |  | cadence prévue en m² |  |  |  |  |  |  | (surf_roulage / qte_roulage_po) * cadp_plaque
gac_pourc | x |  |  | % de gâche |  |  |  |  |  |  | f2_rebut / ( qte_roulage + f2_rebut)
gac_pourc_ph |  | x |  |  |  |  |  |  |  |  |
ect_gache | x |  |  | % écart entre gâche prévue et réelle |  |  |  |  |  |  | positif : mali, négatif = boni
ect_gache_ph |  | x |  |  |  |  |  |  |  |  |
ect_reglage | x |  |  | % écart entre temps réglage réel et temps de réglage prévu |  |  |  |  |  |  | positif : mali, négatif = boni
ect_reglage_ph |  | x |  |  |  |  |  |  |  |  |
ect_reg_arr | x |  |  | % écart entre temps réglage + arrêt affectable réel et temps de réglage prévu |  |  |  |  |  |  | positif : mali, négatif = boni
ect_reg_arr_ph |  | x |  |  |  |  |  |  |  |  |
ect_roulage | x |  |  | % écart entre temps roulage réel et temps de roulage prévu |  |  |  |  |  |  | positif : mali, négatif = boni
ect_roulage_ph |  | x |  |  |  |  |  |  |  |  |
ect_roul_arr | x |  |  | % écart entre temps roulage + arrêt affectable réel et temps de roulage prévu |  |  |  |  |  |  | positif : mali, négatif = boni
ect_roul_arr_ph |  | x |  |  |  |  |  |  |  |  |
gramme_moy | x |  |  | grammage moyen |  |  |  |  |  |  | poids_roulage / surf_roulage
gramme_moy_ph |  | x |  |  |  |  |  |  |  |  |
taux_arret | x |  |  | % d'arrêt |  |  |  |  |  |  | tps_arret / tps_ouverture
taux_arret_ph |  | x |  |  |  |  |  |  |  |  |
taux_eng | x |  |  | taux d'engagement |  |  |  |  |  |  | tps_marche / tps_ouverture
taux_eng_ph |  | x |  |  |  |  |  |  |  |  |
serie_moy_pl |  |  | x | série moyenne par OF en unité d'entrée machine |  |  |  |  |  |  | (qte_roulage_po + f2_rebut_po) / nb_of
serie_moy_pl_reg |  |  | x | série moyenne par réglage en unité d'entrée machine |  |  |  |  |  |  | (qte_roulage_po + f2_rebut_po) / nb_reglage
serie_moy_m2 |  |  | x | série moyenne par OF en m² |  |  |  |  |  |  | surf_total / nb_of
serie_moy_m2_reg |  |  | x | série moyenne par réglage en m² |  |  |  |  |  |  | surf_total / nb_reglage
reg_moy |  |  | x | temps de réglage moyen |  |  |  |  |  |  | tps_reglage / nb_reglage
regp_moy |  |  | x | temps de réglage moyen prévu |  |  |  |  |  |  | tpsp_reglage / nb_reglage
surf_moy_pl |  |  | x | surface moyenne en unité d'entrée machine |  |  |  |  |  |  | surf_total / (qte_roulage_po + f2_reb_po)

Champs | fab2 unitaire | å fab2 par phase | Totaux uniquement | libellé | TTR A1[2] | TTR A1[4] | TTR A1[7] | TTR A1[9] | TTR A1[10] | TTR A1[11] | Exemple / commentaire
f2_of |  |  |  | n° d'OF |  |  |  |  |  |  |
f2_phase |  |  |  | code de la phase |  |  |  |  |  |  |
f2_lig |  |  |  | No de ligne de saisie |  |  |  |  |  |  |
f2_cdc |  |  |  | centre de coût |  |  |  |  |  |  |
f2_code_client |  |  |  | code client |  |  |  |  |  |  |
f2_plage |  |  |  | plage (matin, etc…) |  |  |  |  |  |  |
f2_date |  |  |  | date de la saisie |  |  |  |  |  |  |
f2_hd |  |  |  | heure de début |  |  |  |  |  |  |
f2_hf |  |  |  | heure de fin |  |  |  |  |  |  |
f2_fonct |  |  |  | fonction ("R", "S", "A") |  |  |  |  |  |  |
f2_oper |  |  |  | code opérateur |  |  |  |  |  |  |
f2_no_document |  |  |  | n° de document |  |  |  |  |  |  |
f2_typga |  |  |  | type de gamme |  |  |  |  |  |  |
f2_typtrav |  |  |  | type de travail (TTR) |  |  |  |  |  |  |
f1_cde |  |  |  | n° d'entête de commande |  |  |  |  |  |  |
f1_cli |  |  |  | code client |  |  |  |  |  |  |
f1_coef |  |  |  | qte fabriquée à chaque tour de machine |  |  |  |  |  |  |
f1_ddc |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_dde |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_deld |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_delr |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_gp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_hdp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_hfp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_lig |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_mach |  |  |  | code machine de réalisation |  |  |  |  |  |  |
f1_machp |  |  |  | Code machine prévu |  |  |  |  |  |  |
f1_oper |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_prod |  |  |  | Code produit fabriqué |  |  |  |  |  |  |
f1_sect |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_term |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_tp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_tpp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_tpr |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_tr |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_trp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_trr |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_cp |  |  |  | voir description fab1 |  |  |  |  |  |  |
f1_cr |  |  |  | voir description fab1 |  |  |  |  |  |  |
gl_qualite |  |  |  | code qualité du support de l'OF concerné |  |  |  |  |  |  | si plusieurs supports, alors le premier trouvé
libc_f2_typtrav |  |  |  | libellé court du TTR |  |  |  |  |  |  |
libl_f2_typtrav |  |  |  | libellé long du TTR |  |  |  |  |  |  |
m0_coder |  |  |  | code machine de rattachement de la machine utilisée |  |  |  |  |  |  |
m0_desig |  |  |  | désignation de la machine utilisée |  |  |  |  |  |  |
m0_typmac |  |  |  | type de la machine utilisée |  |  |  |  |  |  |
nom_f1_cli |  |  |  | raison sociale attachée au client stocké dans f1_cli |  |  |  |  |  |  |
ss_sec |  |  |  | section de l'opération sur lequel est faite une saisie |  |  |  |  |  |  |
ss_ope |  |  |  | sous-section de l'opération sur lequel est faite une saisie |  |  |  |  |  |  |
ss_sop |  |  |  | sous-opération de l'opération sur lequel est faite une saisie |  |  |  |  |  |  |
taux_hor |  |  |  | taux horaire |  |  |  |  |  |  |

Champs | fab2 unitaire | å fab2 par phase | Totaux uniquement | libellé | TTR A1[2] | TTR A1[4] | TTR A1[7] | TTR A1[9] | TTR A1[10] | TTR A1[11] | Exemple / commentaire
lc_larg | x | x |  | laize brute utilisée pour le groupage |  |  |  |  |  |  |
laize_net | x |  |  | laize nette utilisée pour le groupage |  |  |  |  |  |  | laize brute - rogne. Rq : cette laize peut être restreinte uniquement aux OF portant sur la famille "PLA" (A2[38] = 'O'), voire uniquement aux plaques cartonniers (sous famille "CAR" avec A2[39] = 'O')
laize_net_ph |  | x |  |  |  |  |  |  |  |  |
surf_net | x |  |  | surface nette roulée |  |  |  |  |  |  | qte_roulage * laize nette
surf_net_ph |  | x |  |  |  |  |  |  |  |  |
poids_net | x |  |  | poids net roulé |  |  |  |  |  |  | surf_net * poids de 1m² de carton
poids_net_ph |  | x |  |  |  |  |  |  |  |  |
laize_moy | x | x |  | laize moyenne |  |  |  |  |  |  | surf_roulage / qte_roulage
rogne_mm | x |  |  | rogne en mm |  |  |  |  |  |  | laize brute - laize nette
rogne_mm_ph |  | x |  |  |  |  |  |  |  |  |
rogne_% | x |  |  | % de rogne |  |  |  |  |  |  | rogne en mm / laize brute
rogne_%_ph |  | x |  |  |  |  |  |  |  |  |
rogne_m2 | x |  |  | rogne en m² |  |  |  |  |  |  | rogne en mm * qte_roulage
rogne_m2_ph |  | x |  |  |  |  |  |  |  |  |
rogne_ton | x |  |  | rogne en tonne |  |  |  |  |  |  | rogne_m² * gramme_moy
rogne_ton_ph |  | x |  |  |  |  |  |  |  |  |
nb_basc | x |  |  | nombre de basculements d'arbre de réglage |  |  |  |  |  |  | Compteur + 1 à chaque changement de FBA. A but d'optimisation : nécessite A2[40] = 'O'
nb_basc_ph |  | x |  |  |  |  |  |  |  |  |
nb_chgt_laize | x |  |  | nombre de changements de laize |  |  |  |  |  |  | Compteur + 1 à chaque changement de laize sur les FBA. A but d'optimisation : nécessite A2[40] = 'O'
nb_chgt_laize_ph |  | x |  |  |  |  |  |  |  |  |
nb_chgt_qc | x |  |  | nombre de changements de qualité |  |  |  |  |  |  | Compteur + 1 à chaque changement de qualité sur les FBA. A but d'optimisation : nécessite A2[40] = 'O'
nb_chgt_qc_ph |  | x |  |  |  |  |  |  |  |  |
serie_moy_m2_ond |  |  | x | série onduleuse moyenne en m² |  |  |  |  |  |  | surface brute / nombre de basculements. A but d'optimisation : nécessite A2[40] = 'O'

v_fab2 Visualisation du réalisé production

Description générale

Cette fonctionnalité VoluPack a pour but de fournir des éléments de statistiques de production issus du suivi d'activité en temps complété des éléments de gâche disponibles sur l'opération.

Globalement l'objectif est :

d'analyser suivant plusieurs axes les temps de production réels

de les comparer avec les temps prévus

A noter que cette statistique de production ne propose pas de valorisation en euro des écarts constatés.

Généralité de fonctionnement

Cette fonctionnalité est basée sur le principe des visus paramétrables Volume Software. Elle permet donc :

une Visualisation, Edition et extraction fichier

une sélection multicritères des axes d'analyse

un tri paramétrable avec gestion des sous-totaux et des sauts de page

un paramétrage des données ou mesures à faire apparaître

Les axes d'analyse disponibles sont pour l'essentiel :

le numéro d'OF ou le produit (le quoi)

la période d'analyse (le quand)

la faction ou l'opérateur ou l'équipe (le qui)

des agrégats du global au détail tels que : la machine, le type de travail, la gamme, l'opération standard, l'opération élémentaire

Ces axes d'analyse sont repris en critères de tri / saut de page.

Cliquez ici pour afficher / masquer une copie d'écran.

Liste des champs paramétrables

Champs toujours accessibles

Données de type temps

Données de type quantité

Données calculées

Autres données

Champs accessibles uniquement en visu de type onduleuse ( A2[34] = O). Ne fonctionne que si gestion des commandes FBA (fabrication d'amalgame)

Voir aussi la liste des noms de zones autorisés plus bas.

Valeur alpha 2

1

Second écran de sélection (O/N, N par défaut)

2

Choix de l'ordre de tri (O/N, N par défaut)

3

Pas d'édition des lignes détail (O/N, N par défaut)

O Pas d'édition

N Edition

4

Imprimerie ou Mécanique

O Imprimerie

N Mécanique (par défaut)

14

Edition condensé de la visualisation O/N (O par défaut)

31

Edition des lignes annulées (O/N, N par défaut

32

Edition d'un libellé entre chaque ligne (O/N, N par défaut)

33

Edition d'un entête société sur chaque page de l'édition (O/N, N par défaut)

34

Type de visualisation

T Transformé (par défaut)

O Onduleuse

35

Unité utilisée pour la visualisation

O en minutes

N en centièmes (par défaut)

36

Mode de fonctionnement :

O On veut le détail de fab2 . Tous les champs sont utilisables.

N Pas de détail de fab2 .

Dans ce cas, il conviendra de n'utiliser que les noms des champs suffixés par _ph

Explication : le résultat des statistiques est de 2 natures en fonction du paramétrage.

En effet, on trouve dans la table fab2 une ou plusieurs lignes pour la même phase réalisée (pour une même phase, il peut y avoir n arrêts, n changements d'opérateur, etc…).

La table fab2 enregistre donc chaque événement.

Dans un objectif statistique de production, ces événements élémentaires sont potentiellement sans intérêt.

Dans ce but, la visu permet de ne présenter qu'une somme des enregistrements fab2 par phase.

37

Option édition (O/N, O par défaut)

38

Restriction plaque

O Pas restriction plaque

N Restriction plaque (par défaut)

39

Restriction plaque cartonnier

O Pas restriction plaque cartonnier - ceci force le caractère 38 à O.

N Restriction plaque cartonnier (par défaut)

40

Calcul des changements laize, qualité, etc...

O Non

N Oui (par défaut)

41,43

Code environnement (utilisé pour le calcul du taux horaire)

44

On ne multiplie pas par 100 mais par 10 pour la numérotation des phases (O/N, N par défaut)

Valeur alpha 3

1,60

Titre de la visualisation

Valeur alpha 4

A4[37]

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Notes

_SUP_REQ_QTE_TTR_

On peut paramétrer 9 zones de quantités avec un complément de sélection sur la table fab2

(par exemple les quantités de calages, les quantités de roulage et les quantités de lavage…)

18 N° du complément de sélection (de 1 à 9)

21,60 Complément de sélection sur la table fab2

Zones disponibles

QTE_TTR_1 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_1

QTE_TTR_2 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_2

QTE_TTR_3 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_3

QTE_TTR_4 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_4

QTE_TTR_5 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_5

QTE_TTR_6 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_6

QTE_TTR_7 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_7

QTE_TTR_8 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_8

QTE_TTR_9 : Calcule la quantité produite (zone f2_qte) selon le complément de sélection _SUP_REQ_QTE_TTR_9

_SUP_REQ_TPS_TTR_

On peut paramétrer 9 zones de temps avec un complément de sélection sur la table fab2

(par exemple les quantités de calages, les quantités de roulage et les quantités de lavage…)

18 N° du complément de sélection (de 1 à 9)

21,60 Complément de sélection sur la table fab2

Zones disponibles

TPS_TTR_1 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_1

TPS_TTR_2 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_2

TPS_TTR_3 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_3

TPS_TTR_4 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_4

TPS_TTR_5 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_5

TPS_TTR_6 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_6

TPS_TTR_7 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_7

TPS_TTR_8 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_8

TPS_TTR_9 : Calcule le temps passé (zone f2_total) selon le complément de sélection _SUP_REQ_TPS_TTR_9

TPS_AVANT_RAFRAICHIR

21,25 Temps d'inactivité avant rafraîchissement

0 pas de rafraîchissement

Valeur minimum : 10 secondes

TSC_F1_MP_

Lire le contenu des TSC du code article de fab1 (produit fabriqué)

11,12 Origine du TSC

14,16 Code du TSC

17 Zone du TSC

Exemple

Lecture d'un TSC avec comme clé la zone f1_prod : (origine du TSC = AE, code du TSC = 200)

V TSC*TSC_F1_MP_AE_201_C*8*<<<<&.&&&*N*

Ordres de tri disponibles

Voir les notes commençant par O

01 | Date opération
02 | Code faction
03 | Code opérateur
04 | Code équipe
05 | Machine fictive
06 | Code article
07 | Famille d'arrêt
08 | Code gamme / profil
09 | Valeur laize
10 | Numéro de commande
11 | Machine de référence
12 | Machine physique
13 | Code section / opération
14 | Code opération standard
15 | Code opération élémentaire
16 | Type de travail
17 | Numéro d'OF
18 | Heure de début d'opération
19 | Code client (fab2/f2_code_client)
20 | Numéro de document (fab2/f2_no_document)
21 | Numéro de phase (fab2/f2_phase) Racine du numéro de phase : valeur entière de la division f2_phase/100 (ou f2_phase/10 selon A2[44])

Liste des noms de zones autorisés

Tous les noms de zones sont triés.

CUM = Zones cumulables

FDC = Zones utilisables dans les formules de calcul

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

using - Voir #VI

Table cde2

Zones | CUM | FDC
lc_larg |  |

Table fab1

Zones | CUM | FDC |
f1_cde |  |  |
f1_cli nom_f1_cli |  |  | Client du dossier Nom du client du dossier
f1_coef |  |  |
f1_cp |  |  |
f1_cr |  |  |
f1_date_etat_plan |  |  |
f1_ddc |  |  |
f1_dde |  |  |
f1_deld |  |  |
f1_delr |  |  |
f1_effectif |  |  |
f1_etat_plan libc_f1_etat_plan libl_f1_etat_plan |  |  |
f1_gp |  |  |
f1_hdp |  |  |
f1_hfp |  |  |
f1_lig |  |  |
f1_mach |  |  |
f1_machp |  |  |
f1_oper nom_f1_oper |  |  | Opération Libellé de l'opération
f1_prod des_f1_prod |  |  | Désignation de l'article produit
f1_qtel |  |  |
f1_qter |  |  |
f1_rebut |  |  |
f1_sect |  |  |
f1_term |  |  |
f1_tp |  |  |
f1_tpp |  |  |
f1_tpr |  |  |
f1_tr |  |  |
f1_trp |  |  |
f1_trr |  |  |

Table fab2

Zones | CUM | FDC |
f2_cdc |  |  |
f2_code_client |  |  |
f2_date |  | X ? |
f2_fonct |  |  |
f2_hd |  |  |
f2_hf |  |  |
f2_lig |  |  |
f2_no_document |  |  |
f2_of |  |  |
f2_oper |  |  |
f2_phase |  |  |
f2_plage |  |  |
f2_qte |  |  |
f2_reb_po |  |  |
f2_reb_po_ph |  |  |
f2_rebut |  |  |
f2_rebut_ph |  |  |
f2_soc |  |  |
f2_total |  |  |
f2_total_ph |  |  |
f2_typga |  |  |
f2_typtrav libc_f2_typtrav libl_f2_typtrav |  |  | Type de travail Libellé court Libellé long

Table mac0

Zones | CUM | FDC
m0_coder |  |
m0_desig |  |
m0_typmac |  |

Autres zones

Zones | CUM | FDC |
cad_m2_tm | X |  |
cad_m2_tm_ph | X |  |
cad_m2_to | X |  |
cad_m2_to_ph | X |  |
cad_m2_tr | X |  |
cad_m2_tr_ph | X |  |
cad_m2_tra | X |  |
cad_m2_tra_ph | X |  |
cad_ml_tm_mn | X |  |
cad_ml_tm_mn_ph | X |  |
cad_ml_to_mn | X |  |
cad_ml_to_mn_ph | X |  |
cad_pl_tm | X |  |
cad_pl_tm_ph | X |  |
cad_pl_to | X |  |
cad_pl_to_ph | X |  |
cad_pl_tr | X |  |
cad_pl_tr_ph | X |  |
cad_pl_tra | X |  |
cad_pl_tra_ph | X |  |
cadp_m2 | X |  |
cadp_plaque | X |  |
ect_gache | X |  |
ect_gache_ph | X |  |
ect_reg_arr | X |  |
ect_reg_arr_ph | X |  |
ect_reglage | X |  |
ect_reglage_ph | X |  |
ect_roul_arr | X |  |
ect_roul_arr_ph | X |  |
ect_roulage | X |  |
ect_roulage_ph | X |  |
em_fonction |  |  | Nom de l'employé
em_machine |  |  |
em_nom |  |  | Nom de l'employé
em_plage |  |  |
em_prenom |  |  | Prénom de l'employé
gac_pourc | X |  |
gac_pourc_ph | X |  |
gacp_prevu |  |  |
gacp_prevu_ph |  |  |
gacp_prevu_po |  |  |
gacp_prevu_po_ph |  |  |
gl_coupe |  |  |
gl_laize |  |  |
gl_qualite |  |  |
gramme_moy | X |  |
gramme_moy_ph | X |  |
laize_moy | X |  |
laize_net |  |  |
laize_net_ph |  |  |
lib_machine_emp |  |  |
nb_basc |  |  |
nb_basc_ph |  |  |
nb_chgt_laize |  |  |
nb_chgt_laize_ph |  |  |
nb_chgt_qc |  |  |
nb_chgt_qc_ph |  |  |
nb_of |  |  |
nb_of_ph |  |  |
nb_poses_meca |  |  |
nb_reglage |  |  |
nb_reglage_ph |  |  |
o0_lib |  |  |
ouverture |  |  |
poids_gache |  |  |
poids_gache_ph |  |  |
poids_net |  |  |
poids_net_ph |  |  |
poids_roulage |  |  |
poids_roulage_ph |  |  |
poids_total |  |  |
poids_total_ph |  |  |
pousse |  |  |
qte_roulage |  |  |
qte_roulage_ph |  |  |
qte_roulage_po |  |  |
qte_roulage_po_ph |  |  |
reg_moy | X |  |
regp_moy | X |  |
rogne_% | X |  |
rogne_%_ph | X |  |
rogne_m2 |  |  |
rogne_m2_ph |  |  |
rogne_mm | X |  |
rogne_mm_ph | X |  |
rogne_ton |  |  |
rogne_ton_ph |  |  |
serie_moy_m2 | X |  |
serie_moy_m2_ond | X |  |
serie_moy_m2_reg | X |  |
serie_moy_pl | X |  |
serie_moy_pl_reg | X |  |
ss_ope |  |  |
ss_sec |  |  |
ss_sop |  |  |
surf_gache |  |  |
surf_gache_ph |  |  |
surf_moy_pl | X |  |
surf_net |  |  |
surf_net_ph |  |  |
surf_roulage |  |  |
surf_roulage_ph |  |  |
surf_total |  |  |
surf_total_ph |  |  |
taux_arret | X |  |
taux_arret_ph | X |  |
taux_eng | X |  |
taux_eng_ph | X |  |
taux_hor |  |  | Taux horaire
tps_arret |  |  |
tps_arret_aff |  |  |
tps_arret_aff_ph |  |  |
tps_arret_naff |  |  |
tps_arret_naff_ph |  |  |
tps_arret_ph |  |  |
tps_arret_tot |  |  |
tps_arret_tot_ph |  |  |
tps_exclu |  |  |
tps_exclu_ph |  |  |
tps_mar_arr |  |  |
tps_mar_arr_ph |  |  |
tps_marche |  |  |
tps_marche_ph |  |  |
tps_ouverture |  |  |
tps_ouverture_ph |  |  |
tps_reg_arr |  |  |
tps_reg_arr_ph |  |  |
tps_reglage |  |  |
tps_reglage_ph |  |  |
tps_roul_arr |  |  |
tps_roul_arr_ph |  |  |
tps_roulage |  |  |
tps_roulage_ph |  |  |
tpsp_reglage |  |  |
tpsp_reglage_ph |  |  |
tpsp_roulage | X |  |
tpsp_roulage_ph | X |  |


v_fab3 Visualisation de la table fab3

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : ordre de fabrication Exemple : -N[f0_of]
-N_P | Caractères 3 et suivants : code produit Exemple : -N[f0_prod]

Options

Old

Pas d'édition du détail de l'OF

Ordres de tri disponibles

1 | Numéro d'OF
2 | Ligne d'OF
3 | Opérateur
4 | Client
5 | Date
6 | Type
7 | Produit
8 | Commande/Ligne
9 | Date commande

Liste des noms de zone autorisés

Toutes les zones du package Tiers

Toutes les zones du package Articles / Matières / Produits

Tous les champs des tables suivantes :

fab3

fab0

cde1

cde2


v_fab5 Visualisation des achats extérieurs (factures de sous-traitance)

Valeur alpha 4

A4[37]

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Ordres de tri disponibles

Voir les notes commençant par O

01 | Code fournisseur
02 | Code produit
03 | Date de réception
04 | Affectation

Listes des zones disponibles

Les zones sont triées en ordre alphabétique.

La colonne lib signifie que les libellés court et long sont disponibles.

Par exemple : fi_fam (code famille) : libc_fi_fam (libellé court de la famille) et libl_fi_fam (libellé long de la famille).

La colonne cum indique que la zone peut être cumulée (non indiqué pour l'instant).

La colonne for indique que la zone est utilisable dans une formule de calcul (non indiqué pour l'instant).

1) Champs de la table fab5

Zone | Libellé | lib | cum | for
 | Tous les champs de la table fab5 |  |  |
prix_unitaire | f5_mtht/f5_qte |  |  |
ref_produit | Libellé étranger |  |  |

2) Toutes les zones du package Tiers (f5_fou)

ainsi que la zone code_iso_pays

3) Champs de la table cdf1

Zone | Libellé | lib | cum | for
ef_mrg |  | X |  |
ef_transport incoterm | code incoterm | X |  |
code_iso_devise | code ISO de la devise (ef_devise) |  |  |

4) Champs de la table cdf2

Zone | Libellé | lib | cum | for
lf_lib |  |  |  |
taux_dev_euro | ratio prix devise/prix euro |  |  |

5) Champs de la table mat (f5_prod)

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

6) Autres champs

Zone | Libellé | lib | cum | for
using | Voir #VI |  |  |
date_time_std | Date + heure au format"YYYY-MM-DD hh:mm:ss |  |  |
lf_lib_laize | Si famille du produit = PAP, alors la laize est concaténée au libellé |  |  |


v_formules Visualisation des formules

Visualisation des formules v_formules

Ce programme est opérationnel à partir de la V. 4.1.31.2

Il permet de visualiser les données de la table formules.

Il reprend l’écran de sélection du programme de saisie des formules et l’écran de visualisation standard, sur lequel plusieurs actions sont disponibles :

- Accès au programme de Saisie des formules (touche F8)

- Accès à la saisie des dépendances (touche F9)

- Accès à la saisie des notes des formules : table formules2 (CTRL+N)

- Accès à la traçabilité (CTRL+O)

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Argument : Nppp-fff-qq

avec :

ppp Phase (ul_phase)

fff Formule (ul_formule)

qqq Type (ul_quoi)

Options

Orv | Recalcul automatique de l’écran de visualisation si nécessaire. En l’absence de cette option, un simple rafraichissement de la ligne en cours est effectué
Oxd | Masquer les détails par défaut
Oxs | Pas d'écran de sélection

Notes

SAISIE_FORMULES

21,26 Type et code du paramètre de lancement du programme de saisie des formules.

Noms de zones autorisés

Les zones du package Formules

Critères de tri disponibles

01 - Code phase

02 - Code formule

03 - Matière ou Opération

04 - Type du paramètre 1

05 - Type du paramètre 2

06 - Pourcentage de montant (critère de totalisation)

07 - Pourcentage de frais (critère de totalisation)

08 - Type de la machine requise pour le calcul de la formule

09 - Code ligne complémentaire

10 - Code phase à utiliser pour les calculs

11 - Code formule à utiliser pour les calculs

12 - Configuration du tarif d'achat

13 - Configuration du tarif de vente

14 - Code difficulté paramétrable – Subdivisé en 2 car. et 7 car.

15 - Code édition

16 - Code article par défaut

17 - Code section par défaut

18 - Code opération par défaut

19 - Code sous-opération par défaut

20 - Nature des frais (NDF)

21 - Complément montant en %

22 - Complément frais en %

23 - Code regroupement des opérations à la fabrication (fab1)

24 - Code section de l’opération de référence pour le regroupement

25 - Code opération de l’opération de référence pour le regroupement

26 - Code Sous-opération de l’opération de référence pour le regroupement

27 - L’opération est-elle porteuse d’une quantité et d’une gâche ?

28 - Exclusion phase opération du transfert Direct Planning (O/N)

29 - Code des regroupements des opérations dans Direct Planning

30 - Mode de rupture pour les opérations ayant le même code regroupement

31 - L’opération est-elle porteuse d’une quantité et d’une gâche ? (DP)

32 - Unité de production

33 - Stade du produit semi-fini pour le lot industriel (SSF)

34 - Nature montant (NDR)

35 - Numéro d'ordre

36 - Code actif (O/N)

37 - Classe

38 - Sous-classe

Exemple de paramétrage

Option Oxd

A4[8] = M (accès en modification)

A4[43] = O (Ctrl J)

A4[46] = M (Ctrl N)

# Colonnes

V Phase*ul_phase*5*

V Formule*ul_formule*5*

V Type*ul_quoi*3******1*

V Désignation*ul_desig*30*

V Produit def.*ul_defprod*15*

V Section*ul_sec*5*

V Opération*ul_ope*5*

V Sous-ope*ul_sop*5*

V FD:Pha*ul_phase_ut*5*

V FD:for*ul_formule_ut*5*

# colorisation

_LIG_001 C= M : violet1

_LIG_001 C= O : bleusombre1

_LIG_001 C= S : orange1

# ctrl+J

LCT_PROG_IMAGE_01 date.png

LCT_PROG_TITRE_01 Voir les Opérations

LCT_PROG_PARAM_01 #VIOPE-NT[ul_sec|-|ul_ope|-|ul_sop]


v_gammes_standard Visualisation des gammes standard

Ce programme est opérationnel à partir de la V. 4.1.16.

Des compléments de sélections peuvent être paramétrés sur les tables suivantes :

• Entête de gamme standard (g_std_e)

• Détail de gamme standard (g_std_d)

Toutes les données des tables suivantes sont accessibles :

• Entête de gamme standard (g_std_e)

• Détail de gamme standard (g_std_d)

• Notes de gamme standard (g_std_n)

• Notes de phase de gamme (notes)

• Machine associée à la phase de gamme (mac0)

• Informations complémentaires des gammes standard et des phases de gamme.

Sur une ligne de visualisation, les actions suivantes sont possibles :

• Saisie/Consultation des notes de gamme (table g_std_n) – CTRL-N

• Saisie/Consultation des notes de phase (table notes) – F9

• Saisie/Consultation de la gamme standard – F8

• Rafraîchissement de la visualisation – F5

• Afficher/Masquer les détails

• Transfert Excel

Remarques :

• Si le paramétrage de la visualisation ne contient que des champs de l'entête de gamme et qu'il n'y a pas de critère de sélection sur les détails de gamme standard, alors chaque ligne affichera les données d'une gamme standard. Sinon, chaque ligne affichera les données d'un couple gamme standard/phase.

• Gestion des cumuls/totalisations

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-NM

Passage d’un code machine en critère de sélection pour la visu des gammes

Exemple

-NM[m0_machine]

Options

Orv | Rafraîchissement automatique de la visualisation si nécessaire (après la saisie de l'opération)
Oxd | Affichage sans détails
Oxs | Gestion sans écran de sélection

Valeur alpha 2

A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[5] | Autorisation d'accès au rafraîchissement de la visualisation (O/N, N par défaut)
A4[8] | Autorisation d'accès à la saisie des gammes standard (O/N/M, N par défaut)
A4[9] | Autorisation d'accès à la saisie des notes de phase de gamme (O/N/M, N par défaut)
A4[46] | Autorisation d'accès à la saisie des notes de gamme standard (O/N/M, N par défaut)

Notes

SAISIE_G_STD | 21,26 Type et code du paramètre de lancement du programme de saisie des gammes standard
_SUP_REQ_G_STD_E | 21,60 Complément de sélection sur la table des entêtes de gamme standard (g_std_e)
_SUP_REQ_G_STD_D | 21,60 Complément de sélection sur la table des détails de gamme standard (g_std_d)

Critères de tri disponibles

01 | Gamme
02 | Phase
03 | Machine
04 | Site
05 | Désignation gamme
06 | Jonction
07 | Découpe
08 | Colisage
09 | Nombre mini de couleurs
10 | Nombre maxi de couleurs

Zones disponibles

Tous les champs numériques sont disponibles pour les colonnes de calcul.

Entête de gamme standard | package
Détail de gamme standard | package
Notes de gamme standard | g_std_n
Notes de phase de gamme | notes
Machine associée à la phase de gamme | package
Informations complémentaires des gammes standard et des phases de gamme | TSC

Nouveau type de notes disponible pour les colonnes de la visualisation pour afficher les entêtes de gamme standard (table g_std_n) : GAM

Voir NTS - Syntaxe d'appel dans les visus

Pour rappel :

X Titre de la colonne*NTS_SSS/TTT/NNN/*L*

où

X = Type de visu (V, D, E, F)

NTS = Mot-clé annonçant une colonne de notes

SSS = Source de la note : mettre GAM

TTT = Type de la note. Ce type doit être vide (mettre 1 espace).

NNN = Nombre de lignes. On peut ainsi indiquer :

ALL pour éditer toutes les lignes

PRE pour éditer un astérisque indiquant la présence d'au moins une note

Exemple

V Notes de gamme*NTS_GAM/ /ALL*30*

Il est également possible d'afficher les notes des phases (table notes) de gammes en utilisant le paramétrage déjà existant.

Exemple

V Notes de phase*NTS_NOTG/CCV/ALL*30*


v_groupage_bl Visualisation des groupages

Valeurs alpha Notes Tris Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N | Caractères 3 et suivants : numéro de commande Exemple : -N[ec_num]
-NGB | Caractères 3 et suivants : numéro de groupage Exemple : -NGB[gb_no_groupage]
-NLC | Caractères 3 et suivants : numéro de commande, ligne de commande Exemple : -NLC[lc_num]-[lc_lig]

Options

Ono | Argument (-N) obligatoire Avec cette option, si le -N n'est pas passé en paramètre, on sort immédiatement du programme.
Osa | On recherche le stock des produits synchrones de la même façon que pour les produits asynchrones. Cette option correspond à celle de la préparation des affrètements. Ce paramétrage est lié à l'affichage de la jauge de stock.
Ost | Le stock n'est pas limité au magasin de départ. Cette option correspond à celle de la préparation des affrètements. Ce paramétrage est lié à l'affichage de la jauge de stock.

Valeur alpha 2

Caractère 2

Choix de l'ordre du tri (O/N)

Caractère 3

Pas d'édition des lignes détail (O/N)

Caractère 6

Pas de création de fichier si pas d'enregistrement trouvé (O/N, N par défaut)

Caractère 10

Lancement en Batch (E/F)

E Edition

F Fichier (Nom du fichier à paramétrer dans les notes)

Caractère 33

Visualisation des lignes de groupage annulées (O/N, N par défaut)

Caractères 35 à 37

Longueur de la ligne éditable. Sert uniquement dans l'édition.

Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.

Caractère 42

Contrôle des affrètements (O/N, N par défaut)

Caractères 43 à 44

Delta d'heures

Sert uniquement si caractère 42 est à O

Par défaut 0 (zéro)

Caractère 45

Edition de la liste des stocks par lieux (Lieu de rangement de niveau 1) (O/N)

2 modes d'édition :

1) Colonnes code_lieu (Code du lieu) et stock_lieu (Stock du lieu) non paramétrées :

Edition d'un tableau à 2 colonnes (Code du lieu et stock du lieu) après l'édition de la ligne détail

2) Colonnes code_lieu (Code du lieu) et stock_lieu (Stock du lieu) paramétrées :

Edition des colonnes code_lieu et stock_lieu intégrées dans la ligne détail

Il y a autant de lignes détail que de lieux avec du stock.

Seules les colonnes code_lieu et stock_lieu sont éditées dans les lignes détail suivantes.

Caractère 46

Edition des notes de l'entête de l'affrètement (O/N, N par défaut)

Caractère 47

Edition des notes de la ligne de l'affrètement (O/N, N par défaut)

Caractère 48

Edition des tarifs inférieurs à celui sélectionné (O/N)

Voir la note commençant par _SUP_REQ_TAR_SUP_MIN

On peut, par un complément de sélect, sélectionner uniquement les affrètements pour lesquels le prix validé est strictement supérieur au prix le plus bas de la liste des tarifs trouvés (pour l'affrètement).

A l'édition, on peut visualiser chaque tarif trouvé dont le prix est strictement inférieur au prix validé.

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES GROUPAGES

Valeur alpha 4

Caractère 8

Touche F8 (O/N) - Détail ligne de commande

Caractère 11

Touche F11 (O/N) - Détail des palettes d'expédition

Caractère 12

Touche F12 (O/N) - Détail entête de commande

Caractère 13

Touche F13 (O/N) - Gestion des expéditions de l'affrètement (ou du groupage)

Caractère 14

Touche F14 (O/N) - Edition ordre de chargement

Caractère 15

Autoriser l'accès direct au détail d'une ligne de palette

Pour voir le détail d'une ligne d'une palette, il faut faire F11 puis F8 puis F8.

La touche F15 fait cet enchaînement directement en se basant sur le numéro et la ligne de groupage.

On considère que dans certains cas, il ne peut y avoir qu'une palette et qu'une ligne.

Ajout de la colonne Palette de prélèvement de la table conteneur_info.

Cette colonne n'est visible que si l'option de gestion de prélèvement est activée : #CF CAB A1[6] = O

Caractère 19

Touche F19 (O/N) - Détail de l'article

Caractère 21

Touche F21 (O/N) Frais supplémentaires sur affrètements

Caractère 37

Touche Ctrl-B pour accès à la visualisation des stocks

Voir aussi #CF ATL A1[24]

Caractère 38

Touche CONTROL-C (O/N) - Calculatrice

Caractère 40

Touche CONTROL-F (O/N) - Visualisation des BL et des factures

Caractère 46

Touche CONTROL-N (O/N)

Visualisation des notes de l'affrètement

Caractère 51

Touche CONTROL-T (O/N) - Visualisation des touches

Caractère 56

Touche CONTROL-Z (O/N) - Lancement de programmes

Notes

CF_MAJ_FLAG_INFO_C | Voir page dédiée
LCT_PROG_CONFIG LCT_PROG_PARAM_ LCT_PROG_TITRE_ LCT_PROG_IMAGE_ | 21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx) La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées). Plus de détail dans le #RP
MAJ_FLAG_INFO_C | Voir page dédiée
RUN_EDIT_ORDRE_CHGT | 21,26 Type et code du paramètre de lancement de l'édition des ordres de chargement
RUN_GES_EXPED_AFFRET | 21,26 Type et code de paramètre de lancement de la gestion des expéditions des affrètements Exemple : #SA AFF
_SUP_REQ_LIEUX | 21,60 Supplément de requête pour la recherche des stocks par lieux sur la table stk0
_SUP_REQ_RECH_LL | 21,60 Complément de requête pour la recherche des stocks (sur table stk0) Ce paramétrage est lié à l'affichage de la jauge de stock.
_SUP_REQ_TAR_SUP_MIN | 21,60 Complément de select permettant de sélectionner uniquement les affrètement dont le prix validé est strictement supérieur au prix le plus bas. Voir A2[48] Exemple SUP_REQ_TAR_SUP_MIN and nn_soc = gb_soc SUP_REQ_TAR_SUP_MIN and nn_type = "J" SUP_REQ_TAR_SUP_MIN and nn_cle = gb_no_groupage SUP_REQ_TAR_SUP_MIN and nn_type_note = "HIS" SUP_REQ_TAR_SUP_MIN and nn_ligne = 5 SUP_REQ_TAR_SUP_MIN and trim(nn_com[13,60]) SUP_REQ_TAR_SUP_MIN < gb_cout_charg_prev
TSC_CL_CL_XXX_Y | TSC du client du groupage (table groupage_bl, champ gb_code_client) Caractères 1 à 10 : TSC_CL_CL_ Caractères 11 à 13 : XXX = Code du TSC Caractère 14 _ Caractère 15 : Y = Code de la zone du TSC Exemple TSC_CL_CL_60W_G
TSC_CL_C2_XXX_Y | TSC du couple client/adresse secondaire du groupage (table groupage_bl, champs gb_code_client + gb_adl) Caractères 1 à 10 : TSC_CL_C2_ Caractères 11 à 13 : XXX = Code du TSC Caractère 14 _ Caractère 15 : Y = Code de la zone du TSC Exemple TSC_CL_C2_60W_G
TSC_CL_LI_XXX_Y | TSC du point de livraison (client ou lieu de rangement intermédiaire si ce dernier est renseigné) Caractères 1 à 10 : TSC_CL_LI_ Caractères 11 à 13 : XXX = Code du TSC Caractère 14 _ Caractère 15 : Y = Code de la zone du TSC

Ordres de tris disponibles

Voir les notes commençant par O

1 | num_grp | Numéro de groupage
2 | lig_grp | Ligne du groupage
3 | num_cde | Numéro de commande
4 | lig_cde | Ligne de commande
5 | seq_cde | Séquence de commande
6 | code_cli | Code client
7 | code_trans | Code transporteur
8 | date_pres | Date de première présentation
9 | code_prep | Code préparateur
10 | code_stat | Code statut
11 | code_magd | Code magasin de départ - Logistique
12 | code_lieui | Code lieu intermédiaire - Logistique
13 | code_quai | Code quai affecté - Logistique
14 | code_car | Code cariste - Logistique
15 | code_etat | Code état - Logistique
16 | heure_pres | Heure de première présentation
17 | code_suiv | Code suivi affaire de la commande
18 |  | Date de départ de l'usine

Variables ajoutées au dictionnaire

gb_cout_charg_prev | Coût du chargement prévu
gb_poids_prev | Poids prévu
gb_qte_prev | Quantité prévue
gb_nb_pal_prev | Nombre de palettes prévues
gb_qte_reelle | Quantité réelle
gb_metr_lineaire | Métrage linéaire
gb_metr_reel | Métrage réel
gb_cout_reel | Coût réel
gb_qte_fact_cout | Quantité de coût facturable
gb_volume_tot | Volume total du groupage
gb_volume_lig | Volume de la ligne de groupage

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Groupage bl

groupage_prepa

groupage_prepa_d

groupage_bl_prepa

Entête de commande

Ligne de commande

Nomenclature de la ligne de commande

Parties communes à cde et cde4

Fiche tiers

Tiers livré

Autres zones

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Adresses secondaires

Bons de Livraison - Entête

Bons de Livraison - Lignes

Toutes les zones de la table ordre_transport

Package suiv_vehicule

groupage_bl

Toutes les zones de la table + les zones suivantes :

nom_gb_code_client | Nom client
nom_gb_trans | Nom transporteur
codp_gb_adl | Code postal adresse livraison
nom_gb_adl | Nom adresse livraison
vil_gb_adl | Ville adresse livraison
pays_gb_adl | Pays adresse livraison
libc_pays_gb_adl | Libellé court pays adresse livraison
libl_pays_gb_adl | Libellé long pays adresse livraison
libc_gb_tport | Libellé court type de port
libl_gb_tport | Libellé long type de port
libc_gb_trsp | Libellé court mode de transport
libl_gb_trsp | Libellé long mode de transport
libc_gb_preparateur | Libellé court code préparateur
libl_gb_preparateur | Libellé long code préparateur
lib_gb_statut | Libellé code statut
nom_gb_adl | Nom adresse livraison
lib_gb_etat_affret | Libellé état de l'affrètement
libc_gb_quai libl_gb_quai | Libellé court quai affecté Libellé long quai affecté
libc_gb_cariste libl_gb_cariste | Libellé court cariste Libellé long cariste
libc_gb_mag_depart libl_gb_mag_depart | Libellé court magasin de départ Libellé long magasin de départ
libc_gb_lieu_rgt1 libl_gb_lieu_rgt1 | Libellé court lieu intermédiaire Libellé long lieu intermédiaire
libc_gb_devise_cout libl_gb_devise_cout | Libellé court devise du coût Libellé long devise du coût
lib_gb_zone_tarifaire | Désignation zone tarifaire livrée
libc_gb_unite_fact_cout libl_gb_unite_fact_cout | Libellé court unité de coût facturable Libellé long unité de coût facturable
libl_site_prod libc_site_prod | Libellé court du site de production Libellé long du site de production
gb_nom_ville | Concaténation du nom du client, suivi de // puis de la ville de livraison

groupage_prepa

Toutes les zones de la table + les zones suivantes :

gp_nom_cli | Nom client de l'adresse principale
gp_nom_adl | Nom client de l'adresse de livraison
gp_adr1_adl | Adresse rue 1 de l'adresse de livraison
gp_adr2_adl | Adresse rue 2 de l'adresse de livraison
gp_codp_adl | Code postal de l'adresse de livraison
gp_vil_adl | Ville de l'adresse de livraison
gp_pays_adl | Code pays de l'adresse de livraison
gp_libc_pays_adl | Libellé court du code pays de l'adresse de livraison
gp_libl_pays_adl | Libellé long du code pays de l'adresse de livraison
gp_libc_pays | Libellé court du code pays du client livré
gp_libl_pays | Libellé long du code pays du client livré
gp_libc_lieu_destock | Libellé court du lieu de déstockage
gp_libl_lieu_destock | Libellé long du lieu de déstockage
gp_libc_type_vehicule | Libellé court du type de véhicule
gp_libl_type_vehicule | Libellé long du type de véhicule
gp_nom_trsp | Nom transporteur
gp_libc_lieu_destock_r | Libellé court du lieu de déstockage réel
gp_libl_lieu_destock_r | Libellé long du lieu de déstockage réel

groupage_prepa_d

Toutes les zones de la table + les zones suivantes :

gpd_nom_adl | Nom client de l'adresse de livraison
gpd_adr1_adl | Adresse rue 1 de l'adresse de livraison
gpd_adr2_adl | Adresse rue 2 de l'adresse de livraison
gpd_codp_adl | Code postal de l'adresse de livraison
gpd_vil_adl | Ville de l'adresse de livraison
gpd_pays_adl | Code pays de l'adresse de livraison
gpd_libc_pays_adl | Libellé court du code pays de l'adresse de livraison
gpd_libl_pays_adl | Libellé long du code pays de l'adresse de livraison
gpd_libc_pays | Libellé court du code pays du client livré
gpd_libl_pays | Libellé long du code pays du client livré
gpd_lib_der_mach_gam | Libellé de la dernière machine de la gamme Cette zone remplace les zones gpd_libc_der_mach_gam et gpd_libl_der_mach_gam
gpd_libc_lieu_inter | Libellé court du lieu intermédiaire
gpd_libl_lieu_inter | Libellé long du lieu intermédiaire
gpd_libc_lieu_destock | Libellé court du lieu de déstockage
gpd_libl_lieu_destock | Libellé long du lieu de déstockage
gpd_libc_tol_liv | Libellé court de la tolérance de livraison
gpd_libl_tol_liv | Libellé long de la tolérance de livraison
gpd_libc_tol_qte | Libellé court de la tolérance sur quantité
gpd_libl_tol_qte | Libellé long de la tolérance sur quantité
gpd_libc_lieu_destock_r | Libellé court du lieu de déstockage réel
gpd_libl_lieu_destock_r | Libellé long du lieu de déstockage réel
gpd_code_article | Code article de la ligne de commande ou de la ligne de séquence de la ligne de commande
gpd_libelle_article | Libellé article de la ligne de commande ou de la ligne de séquence de la ligne de commande
gpd_numero_fbi | Numéro de la FBI de la ligne de séquence de la ligne de commande
gpd_poids_pf_a_livrer | Poids total du PF à livrer

groupage_bl_prepa

Toutes les zones de la table + les zones suivantes :

libc_gbp_pays | Libellé court code pays
libl_gbp_pays | Libellé long code pays
lib_gbp_der_mach_gam | Libellé dernière machine de la gamme
libc_gbp_lieu_inter | Libellé court lieu intermédiaire
libl_gbp_lieu_inter | Libellé long lieu intermédiaire
libc_gbp_lieu_destock | Libellé court lieu de déstockage
libl_gbp_lieu_destock | Libellé long lieu de déstockage
libc_gbp_tol_liv | Libellé court tolérance de livraison
libl_gbp_tol_liv | Libellé long tolérance de livraison
libc_gbp_tol_qte | Libellé court tolérance sur quantité
libl_gbp_tol_qte | Libellé long tolérance sur quantité
libc_gbp_lieu_destock_r | Libellé court lieu de déstockage réel
libl_gbp_lieu_destock_r | Libellé long lieu de déstockage réel

Entête de commande

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
copd_ec_ade | Code postal adresse réception
ville_ec_ada | Ville adresse réception
pays_ec_ada | Pays adresse réception
libc_pays_ec_ada | Libellé court pays adresse réception
libl_pays_ec_ada | Libellé long pays adresse réception
ec_adf | Code adresse facturation
copd_ec_adf | Code postal adresse facturation
ville_ec_adf | Ville adresse facturation
pays_ec_adf | Pays adresse facturation
libc_pays_ec_adf | Libellé court pays adresse facturation
libl_pays_ec_adf | Libellé long pays adresse facturation
ec_adl | Code adresse livraison
copd_ec_adl | Code postal adresse livraison
ville_ec_adl | Ville adresse livraison
pays_ec_adl | Pays adresse livraison
libc_pays_ec_adl | Libellé court pays adresse livraison
libl_pays_ec_adl | Libellé long pays adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_acc_euro | Acompte en EUROS
ec_acc_dev | Acompte en devise
ec_pnt | Port non taxable en devise société
ec_pnt_euro | Port non taxable en EUROS
ec_pnt_dev | Port non taxable en devise
ec_pht | Port taxable en devise société
ec_pht_euro | Port taxable en EUROS
ec_pht_dev | Port taxable en devise
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accusé de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facturé
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture - avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande

Ligne de commande

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Ligne de commande
lc_prod | Code article
lib_lc_prod | Désignation article (fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteliv_reelle | Quantité réellement livrée
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_prx_euro | Prix unitaire vente en EUROS
lc_prx_dev | Prix unitaire vente en devise
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé code zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_TVA | Code TVA
libc_lc_TVA | Libellé court code TVA
libl_lc_TVA | Libellé long code TVA
zc1_lc_TVA | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_deldep | Date de départ
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (Non utilisée)
lc_heure_cli_tot | Heure de livraison souhaitée au plus tôt
lc_heure_cli_tard | Heure de livraison souhaitée au plus tard
lc_heure_dep_tot | Heure de départ au plus tôt
lc_heure_dep_tard | Heure de départ au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_fab_tot | Heure de fin de fabrication au plus tôt
lc_heure_fab_tard | Heure de fin de fabrication au plus tard
lc_colis | Nombre colis
lc_prxcli | Prix client en devise société
lc_prxcli_euro | Prix client en EUROS
lc_prxcli_dev | Prix Client en devise
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
copd_lc_adl | Code postal adresse livraison
ville_lc_adl | Ville adresse livraison
pays_lc_adl | Pays adresse livraison
libc_pays_lc_adl | Libellé court pays adresse livraison
libl_pays_lc_adl | Libellé long pays adresse livraison
lc_adf | Code adresse facturation
copd_lc_adf | Code postal adresse facturation
ville_lc_adf | Ville adresse facturation
pays_lc_adf | Pays adresse facturation
libc_pays_lc_adf | Libellé court pays adresse facturation
libl_pays_lc_adf | Libellé long pays adresse facturation
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_plus_euro | Prix unitaire vente au plus en EUROS
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_prx_moins_euro | Prix unitaire vente au moins en EUROS
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_prx_rvt_euro | Prix unitaire revient en EUROS
lc_prx_rvt_dev | Prix unitaire revient en devise
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_prx_rvt_r_euro | Prix unitaire revient réel en EUROS
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1. Fenêtre revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_annu | Ligne commande annulée
lc_ml_plancher | Mètre linéaire plancher
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Nomenclature de la ligne de commande

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Ligne de commande
nc_seq | Ligne de séquence
nc_prod | Code article
lib_nc_prod | Désignation article (fiche article)
nc_coef_nom | Coefficient de nomenclature
nc_qtecde | Quantité commandée
nc_qteliv | Quantité livrée
nc_qteliv_non_val | Quantité livrée non validée
nc_qteliv_val | Quantité livrée validée
nc_rgt1 | Code lieu de rangement 1
libl_nc_rgt1 | Libellé long code lieu de rangement 1
libc_nc_rgt1 | Libellé court code lieu de rangement 1
nc_rgt2 | Code lieu de rangement 2
nc_rgt3 | Code lieu de rangement 3
nc_qtefab | Quantité fabriquée
nc_rstfab | Solder la fabrication (O/N)
nc_nummvt | Numéro de mouvement en stock
nc_nummvt2 | Numéro d'entrée prévisionnelle
nc_numfbi | Numéro de la FBI
nc_ligfbi | Numéro de ligne de la FBI
nc_solde | Ligne soldée
nc_reap | Mode de réapprovisionnement

Parties communes à cde et cde4

bl_prod | Code article
lib_bl_prod | Désignation article (fiche article)
bl_qtecde | Quantité commandée
bl_qteliv | Quantité livrée
bl_solde | Ligne soldée

Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

copd_cl_adra ville_cl_adra pays_cl_adra libc_pays_cl_adra libl_pays_cl_adra | Code postal adresse réception Ville adresse réception Pays adresse réception Libellé court pays adresse réception Libellé long pays adresse réception
copd_cl_adrb ville_cl_adrb pays_cl_adrb libc_pays_cl_adrb libl_pays_cl_adrb | Code postal adresse livraison Ville adresse livraison Pays adresse livraison Libellé court pays adresse livraison Libellé long pays adresse livraison
copd_cl_adrd ville_cl_adrd pays_cl_adrd libc_pays_cl_adrd libl_pays_cl_adrd | Code postal adresse offres de prix Ville adresse offres de prix Pays adresse offres de prix Libellé court pays adresse offres de prix Libellé long pays adresse offres de prix
copd_cl_adrf ville_cl_adrf pays_cl_adrf libc_pays_cl_adrf libl_pays_cl_adrf | Code postal adresse facturation Ville adresse facturation Pays adresse facturation Libellé court pays adresse facturation Libellé long pays adresse facturation

Tiers livré

Le tiers livré n'est pas forcément celui de la ligne de groupage.

Pour déterminer le code du tiers livré et son code adresse de livraison, on procède de la façon suivante :

Par défaut, le code du tiers livré et son code adresse de livraison sont ceux de la ligne de groupage.

  • Si le lieu de rangement est renseigné et qu‘un code tiers lui est associé (RG1 A1[14,22]), on remplace le code du tiers livré et son code adresse de livraison par ceux du lieu de rangement de la ligne de groupage.

  • Si le code transitaire est renseigné (le code transitaire n'a pas de code adresse de livraison), on remplace le code du tiers livré et son code adresse de livraison par le code transitaire de l'adresse principale (pas de code adresse de livraison) ou l'adresse de livraison (un code adresse de livraison) du tiers livré .

code_tiers_livre | Code du tiers livré
adr_tiers_livre | Code adresse du tiers livré
nom_tiers_livre | Nom du tiers livré
codp_tiers_livre | Code postal du tiers livré
ville_tiers_livre | Ville du tiers livré
pays_tiers_livre | Pays du tiers livré
libc_pays_tiers_livre | Libellé court du pays du tiers livré
libl_pays_tiers_livre | Libellé long du pays du tiers livré

Fiche article

mp_soc | Code société
mp_code | Code article
mp_mp | Type article
mp_afnor | Code normalisé
lib_mp_afnor_art | Désignation article
lib_mp_afnor_ecma | Désignation ecma
mp_des | Désignation article
mp_param | Zone données diverses
mp_fam | Code famille
libc_mp_fam | Libellé court code famille
libl_mp_fam | Libellé long code famille
mp_sfm | Code sous-famille
libc_mp_sfm | Libellé court code sous-famille
libl_mp_sfm | Libellé long code sous-famille
mp_libre | Zone libre
libc_mp_libre | Libellé court zone libre
libl_mp_libre | Libellé long zone libre
mp_rgt1 | Code lieu rangement 1
libc_mp_rgt1 | Libellé court code lieu rangement 1
libl_mp_rgt1 | Libellé long code lieu rangement 1
mp_rgt2 | Code lieu rangement 2
mp_rgt3 | Code lieu rangement 3
mp_dt1 | Donnée technique numérique 1
mp_dt2 | Donnée technique numérique 2
mp_dt3 | Donnée technique numérique 3
mp_dt4 | Donnée technique numérique 4
mp_dt5 | Donnée technique numérique 5
mp_dt6 | Donnée technique numérique 6
mp_dt7 | Donnée technique numérique 7
mp_dt8 | Donnée technique numérique 8
mp_at1 | Donnée technique alphanumérique 1
mp_at2 | Donnée technique alphanumérique 2
mp_hau | Hauteur
mp_lon | Longueur
mp_lar | Largeur
mp_cond | Code conditionnement
libc_mp_cond | Libellé court code conditionnement
libl_mp_cond | Libellé long code conditionnement
mp_coul | Code couleur
libc_mp_coul | Libellé court code couleur
libl_mp_coul | Libellé long code couleur
mp_poids | Poids
mp_ua | Code unité achat
libc_mp_ua | Libellé court code unité achat
libl_mp_ua | Libellé long code unité achat
zc1_mp_ua | Valeur 1 code unité achat
mp_uv | Code unité vente
libc_mp_uv | Libellé court code unité vente
libl_mp_uv | Libellé long code unité vente
zc1_mp_uv | Valeur 1 code unité vente
mp_uvente | Code unité vente 2
libc_mp_uvente | Libellé court code unité vente 2
libl_mp_uvente | Libellé long code unité vente 2
zc1_mp_uvente | Valeur 1 code unité vente 2
mp_fconv | Code formule conversion
libc_mp_fconv | Libellé court code formule conversion
libl_mp_fconv | Libellé long code formule conversion
mp_fconv2 | Code formule conversion 2
libc_mp_fconv2 | Libellé court code formule conversion 2
libl_mp_fconv2 | Libellé long code formule conversion 2
mp_remp | Code article remplacement
lib_mp_remp | Désignation article remplacement
mp_pamp | Valeur stock
mp_pa | Prix achat
mp_cfrais | Taux frais
mp_cperte | Taux perte
mp_pr | Prix revient
mp_marg | Taux marge
mp_pv | Prix vente
mp_pv2 | Prix vente dans unité utilisation
mp_TVA | Code TVA
libc_mp_TVA | Libellé court code TVA
libl_mp_TVA | Libellé long code TVA
zc1_mp_TVA | Valeur 1 code TVA
mp_cpta | Compte achat
mp_cptv | Compte vente
mp_ana | Code analytique
mp_suistk | Suivi en stock
mp_tval | Type valorisation
mp_dermvt | Date dernier mouvement stock
mp_derinv | Date dernier inventaire stock
mp_derent | Date dernière entrée stock
mp_dersor | Date dernière sortie stock
mp_smini | Stock mini
mp_smaxi | Stock maxi
mp_sdisp | Stock disponible
mp_sphy | Stock physique
mp_sres | Stock réserve
mp_sbes | Stock besoins
mp_scdef | Stock en commande ou en fabrication
mp_ssim | Stock simulation
mp_minfou | Minimum commande fournisseur ou fabrication
mp_abc | Classement ABC
mp_controle | Code contrôle qualité
mp_reap | Code réapprovisionnement
libc_mp_reap | Libellé court code réapprovisionnement
libl_mp_reap | Libellé long code réapprovisionnement
mp_foucli | Code fournisseur
nom_mp_foucli | Nom fournisseur
mp_cli | Code client
nom_mp_cli | Nom client
mp_qteeco | Quantité économique commande ou fabrication
mp_delmoy | Délai moyen d'approvisionnement
mp_ndm | Numéro dernier mouvement stock
mp_qualite | Code qualité
libc_mp_qualite | Libellé court code qualité
libl_mp_qualite | Libellé long code qualité
mp_z1 | Zone paramétrée 1
mp_z2 | Zone paramétrée 2
mp_z3 | Zone paramétrée 3
mp_z4 | Zone paramétrée 4
mp_z5 | Zone paramétrée 5
mp_alerte | Stock alerte
mp_gestionnaire | Code gestionnaire
libc_mp_gestionnaire | Libellé court code gestionnaire
libl_mp_gestionnaire | Libellé long code gestionnaire
mp_pr_fixe | Prix fixe
mp_coefdiv_ffix | Coefficient diviseur frais fixe
mp_affect | Numéro affectation
mp_cdc | Code centre de coût
lib_mp_cdc | Libellé centre de coût
mp_devis | Numéro devis
mp_sdevis | Numéro sous-devis
mp_gencod | Code gencod
mp_itf14 | Code ITF14
mp_anu | Article annulé
mp_date | Date enregistrement article

Autres zones

ligne_sequence_fbi

Ligne de séquence qui a générée la FBI

date_entree_magasin

Date entrée en magasin

heure_entree_magasin

Heure entrée en magasin

using

Voir #VI

b2_nbcolis

Quantité réelle de palettes expédiées

kilometrage

Distance utilisée lors de la valorisation du groupage (interface_prefac)

no_facture_transp

Numéro de facture du transporteur

mt_facture_transp

Montant HT de la facture du transporteur dans la devise société

mt_facture_transp_eur

Montant HT de la facture du transporteur dans la devise Euro

mt_facture_transp_dev

Montant HT de la facture du transporteur dans la devise de saisie de la facture

numero_lot

Numéro du lot du tableau des stocks par lieux ou lieux/lot

jauge_stock

Code état de stock

Cette zone est liée à l'affichage de la jauge de stock.

Ce code état permet d'afficher la cellule ou la ligne en couleur grâce au paramétrage de colorisation des visualisations.

Code état | Picto | Signification
N |  | Le stock est inférieur à la quantité à livrer.
O |  | Le stock est strictement supérieur à la quantité à livrer.
L | aucun | Le stock est égal à la quantité à livrer.

Ce flag est cumulable avec celui du délai.

jauge_delai

Code état de délai

Cette zone est liée à l'affichage de la jauge de stock.

Ce code état permet d'afficher la cellule ou la ligne en couleur grâce au paramétrage de colorisation des visualisations.

Code état | Picto |
L |  | La date de départ est égale à la date du jour.
N |  | La date de départ est inférieure à la date du jour. Retard
O | aucun | La date de départ est strictement supérieure à la date du jour.

Ce flag est cumulable avec celui du stock.

code_lieu

Code du lieu du tableau des stocks par lieux

En édition, visualisation et export Excel et si A2[45] = O et si la colonne stock_lieu est paramétrée.

Les 20 premières colonnes ne doivent pas être toutes vides lors du transfert vers Excel car sinon la ligne ne sera pas transmise.

code_lieu2

Code du lieu de rangement de niveau 2 du tableau des stocks par lieux

En édition, visualisation et export Excel et si A2[45] = O et si la colonne stock_lieu est paramétrée.

Les 20 premières colonnes ne doivent pas être toutes vides lors du transfert vers Excel car sinon la ligne ne sera pas transmise.

stock_lieu

Stock du lieu du tableau des stocks par lieux

En édition, visualisation et export Excel et si A2[45] = O et si la colonne stock_lieu est paramétrée.

Les 20 premières colonnes ne doivent pas être toutes vides lors du transfert vers Excel car sinon la ligne ne sera pas transmise.


v_i_postes Visualisation des opérations élémentaires

Toutes les données des tables suivantes sont accessibles (voir aussi les compléments de sélection sur ces tables, dans les notes)

• Opération élémentaire (i_postes)

• Libellés d'opération élémentaire (i_lposte)

• Machine associée à l'opération (mac0)

• Centre de coût associé à l'opération (ccout0)

• Clé tarifaire (article) associée à l'opération (mat)

Sur une ligne de visualisation, les actions suivantes sont possibles :

• Visualisation des tarifs associés à la clé tarifaire (v_tar0)

• Saisie de l'opération élémentaire sélectionnée (l_postes)

• Rafraîchissement de la visualisation

Remarque

Dans le cas où la recherche sélectionnée par l'utilisateur ne ramène les opérations que d'un seul triplet (section/opération/sous-opération), les titres des colonnes de dépendances (zone alphanumériques 1 à 4, bornes inférieures/supérieures de 1 à 4) sont remplacés par les libellés renseignées dans la table correspondante (i_lposte).

L'accès à la saisie des opérations élémentaires en modification est soumis à la permission TOU VIPOSTES_F8.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-NS | Caractères 3 et suivants : numéro de série de l'opération Exemple : -NS[ss_num]
-NT | Caractères 3 et suivants : code triplet (section, opération, sous-opération) Exemples : -NT[fo_sec|fo_ope|fo_sop] -NT[ul_sec|-|ul_ope|-|ul_sop]
-NM | Caractères 3 et suivants : code machine Exemple : -NM[m0_machine]

Options

Orv

Rafraîchissement automatique de la visualisation si nécessaire (après la saisie de l'opération)

Valeur alpha 2

A2[2]

Ouverture de la fenêtre de tri (O/N, N par défaut)

A2[3]

Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)

A2[31]

Attribution automatique des titres des zones de dépendances si une seule opération standard sélection (O/N, O par défaut)

Actuellement, si une seule opération standard est sélectionnée dans la visualisation des opérations élémentaires, le titre des colonnes de dépendance paramétrées est automatiquement mis à jour selon le libellé paramétré pour cette dépendance dans l'opération standard.

Problème : si on utilise cette zone dans le détail avec la zone de titre paramétrée juste devant, on a un doublon qui provoque un décalage en fonction de la sélection. Pour éviter cela, on paramètre donc cet automatisme.

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[6] | Autorisation d'accès à la visualisation des tarifs (O/N, N par défaut)
A4[8] | Autorisation d'accès à la saisie des opérations élémentaires O Accès à la saisie des opérations élémentaires en consultation uniquement M Accès à la saisie des opérations élémentaires en modification (action pouvant être limitée par la permission VIPOSTES_F8) N Pas d'accès à la saisie des opérations élémentaires (par défaut)
A4[9] | Autorisation d'accès à la saisie des deltas d'effectifs de l'opération sélectionnée O Accès à la saisie des deltas d'effectifs en consultation uniquement M Accès à la saisie des deltas d'effectifs en modification (Action pouvant être limitée par la permission POSTE_EFF) N Pas d'accès à la saisie des deltas d'effectifs (par défaut)
A4[25] | Autorisation d'accès au rafraîchissement de la visualisation (O/N, N par défaut)

Notes

PARAM_SAISIE_OPE | 21,26 Type et code du paramètre de lancement de la saisie des opérations élémentaires (l_postes)
PARAM_VISU_TARIF | 21,26 Type et code du paramètre de lancement de la visualisation des tarifs (v_tar0) Le lien est le code article (clé tarifaire) associé à l'opération élémentaire (i_postes.ss_cletarifaire).
_SUP_REQ_CCOUT0 | 21,60 Complément de sélection sur la table des centres de coût (ccout0) Le lien est le code de centre de coût associé à l'opération élémentaire (i_postes.ss_secana).
_SUP_REQ_I_LPOSTE | 21,60 Complément de sélection sur la table des libellés d'opérations élémentaires (i_lposte)
_SUP_REQ_I_POSTES | 21,60 Complément de sélection sur la table des opérations élémentaires (i_postes)
_SUP_REQ_MAC0 | 21,60 Complément de sélection sur la table des machines (mac0) Le lien est le code machine associé à l'opération élémentaire (i_postes.ss_mac).
_SUP_REQ_MAT | 21,60 Complément de sélection sur la table des articles associés aux opérations (mat) Le lien est le code article (clé tarifaire) associé à l'opération élémentaire (i_postes.ss_cletarifaire).

Ordres de tri disponibles

01 | ss_num | Serial de l'opération (par défaut)
02 | ss_sec | Code section
03 | ss_ope | Code opération
04 | ss_sop | Code sous-opération
05 | ss_triplet | Triplet (Sec-Ope-Sop)
06 | ss_dif | Code difficulté
07 | ss_mac | Code machine
08 | ss_z1 | Zone alphanumérique 1
09 | ss_z2 | Zone alphanumérique 2
10 | ss_z3 | Zone alphanumérique 3
11 | ss_z4 | Zone alphanumérique 4
12 | ss_i1 | Borne inférieure de la plage 1
13 | ss_i2 | Borne inférieure de la plage 2
14 | ss_i3 | Borne inférieure de la plage 3
15 | ss_i4 | Borne inférieure de la plage 4
16 | ss_secana | Section analytique/Centre de coût
17 | ss_ttr | Type de travail
18 | ss_cletarifaire | Clé tarifaire (article)

Liste des zones disponibles

Opérations

Opérations (Libellés)

Machines

Centres de Coût

Matières

Autres zones

using | Voir #VI
pres_effectifs | Affichage d'un astérisque (*) lorsque l'opération élémentaire a au moins un delta d'effectif saisi.
nb_effectifs | Nombre de delta d'effectif pour l'opération élémentaire
somme_effectifs | Somme des effectifs (total du nombre d'individus) pour l'opération élémentaire


v_jda Visualisation du journal des achats

Options Valeurs alpha Tri Noms de zones autorisés

ATTENTION

L'option -Ofr doit être présente sur le programme de saisie des bons de réceptions (ebrc) afin que les tables b_rec_ret_e et b_rec_ret_d soient mises à jour.

Options

Ofa

Ajout des colonnes de la table facfou0 liées à la saisie des factures de frais d'approche dans le critère de sélection

ff0_frais_appr

ff0_frais_appr_fac

ff0_frais_appr_aff

ff0_fac_rapprochee

Voir l'affectation des factures de frais d'approche.

Ola

Prise en compte des dimensions de la ligne de commande d'achat pour les conversions

Lorsque l'on calcule les montants dans le journal des achats, on doit faire des conversions pour tenir compte des différentes unités.

Pour certaines de ces conversions, il est nécessaire d'utiliser les dimensions.

Le but de ce développement est d'utiliser les dimensions spécifiées sur la commande d'achat plutôt que celles de la fiche produit.

Oma

Active la possibilité de saisir plusieurs affectations sur une même ligne de facture

Nécessite l'accès à la touche F18

La même option existe dans le contrôle des factures fournisseurs.

Voir aussi A4[18]

Opn

Force le calcul du poids net ligne et du poids net total (ne tient pas compte du paramètre société[27] )

Opz

Pas d'édition des lignes à 0 (zéro).²

Osh

Montant hors taxe saisi dans le contrôle des factures d'achat

Valeur alpha 2

Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch (E/F) E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractère 31 | 1 ligne par facture/avoir (O/N) ou 1 ligne par ligne de facture/avoir N 1 ligne par facture/avoir O 1 ligne par ligne de facture/avoir
Caractère 32 | Édition récapitulatif en devise société (O/N)
Caractère 33 | Édition récapitulatif en EUROS (O/N)
Caractère 34 | Édition récapitulatif en devise (O/N)
Caractères 35 à 37 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
38 à 48 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 49 | Ajout du total débit et crédit dans le récapitulatif

Valeur alpha 3

Caractères 1 à 60

Titre de la visualisation

VISUALISATION DU JOURNAL DES ACHATS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 11 | Touche F11 (O/N) Visualisation du récapitulatif en devise société
Caractère 12 | Touche F12 (O/N) Visualisation du récapitulatif en EURO
Caractère 13 | Touche F13 (O/N) Visualisation du récapitulatif en devise
Caractère 18 | Accès à la saisie des affectations pour une même ligne de facture (nécessite l'option –Oma) O Consultation seule M Modification N Non
Caractère 38 | Touche CONTROL-C (O/N) Calculatrice
Caractère 51 | Touche CONTROL-T (O/N) Visualisation des touches
Caractère 56 | Touche CONTROL-Z (O/N) Lancement de programmes

Notes

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

Ordres de tris disponibles

Voir les notes commençant par O

01 | code_fou | code fournisseur
02 | date_fac | date de facture
03 | type_fac | type de pièce Facture/Avoir
04 | num_fac | numéro de facture
05 | mode_exo | mode exonération
06 | mois_fac | mois de facturation
07 | code_cpt | code comptable
08 | num_cde | numéro de commande
09 | num_bon | numéro de bon de réception
10 | code_fam | code famille
11 | code_sfm | code sous-famille
12 | code_art | code article
13 | ctg_cli | code catégorie client
14 | code_dev | code devise
15 | code_ach | code acheteur
16 | sec_ana | Numéro de compte de section analytique (facfou1.ff1_sec_ana)
17 | cpt_ach | Numéro de compte d’achat (facfou1.ff1_compte_achat)

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Factures Fournisseurs - Entête

Factures Fournisseurs - Lignes

Pied de facture

Entête de commande

Ligne de commande

Entête du bon de réception

Ligne du bon de réception

Fiche tiers

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Ligne de facture en devise société

Ligne de facture en Euros

Ligne de facture en devise

Pied de facture en devise société

Pied de facture en Euros

Pied de facture en devise

Dossiers de fabrication - Nomenclatures

Autres zones

Package suiv_vehicule

Pied de facture

Toutes les zones de la table

Entête de commande

ef_soc | Code société
ef_num | Numéro commande
ef_fou | Code fournisseur
nom_ef_fou | Nom fournisseur
ef_ref | Référence commande
ef_tyc | Type commande
libc_ef_tyc | Libellé court type commande
libl_ef_tyc | Libellé long type commande
ef_c1 | Code zone paramétrable
libc_ef_c1 | Libellé court code zone paramétrable
libl_ef_c1 | Libellé long code zone paramétrable
ef_datc | Date commande
ef_adl codp_ef_adl | Code adresse de livraison Code postal de l'adresse de livraison
ville_ef_adl | Ville adresse de réception
ef_rgt | Lieu de rangement
libc_ef_rgt | Libellé court du lieu de rangement
libl_ef_rgt | Libellé long du lieu de rangement
ef_adst | Lieu de sous-traitance chez le fournisseur
ville_ef_adst | Ville de sous-traitance chez le fournisseur
ef_transport | Type de port
libc_ef_transport | Libellé court type de port
libl_ef_transport | Libellé long type de port
ef_adf | Code adresse facturation
ville_ef_adf | Ville adresse facturation
ef_mrg | Mode règlement
libc_ef_mrg | Libellé court mode règlement
libl_ef_mrg | Libellé long mode règlement
ef_ech | Code échéance
libc_ef_ech | Libellé court code échéance
libl_ef_ech | Libellé long code échéance
ef_rem | Remise globale (en %)
ef_ct | Code tarif
libc_ef_ct | Libellé court code tarif
libl_ef_ct | Libellé long code tarif
ef_cr | Code remise
libc_ef_cr | Libellé court code remise
libl_ef_cr | Libellé long code remise
ef_devise | Code devise
libc_ef_devise | Libellé court code devise
libl_ef_devise | Libellé long code devise
ef_cours | Cours de la devise
ef_exp | Code exportation
ef_ach | code acheteur
libc_ef_ach | libellé court du code acheteur
libl_ef_ach | libellé long du code acheteur
ef_sold | Commande soldée
ef_ar | Accuse de réception à éditer
ef_fact | Reste des factures à éditer
ef_bl | Reste des bons à éditer
ef_nofac | Numéro de facture
ef_datfac | Date de facture
ef_signature | Code signataire de la commande
libc_ef_signataire | Libellé court du code signataire
libl_ef_signataire | Libellé long du code signataire
ef_ada | Code adresse d'envoi de la commande
ville_ef_ada | Ville adresse d'envoi de la commande
ef_client_liv | Code du client livré
nom_ef_client_liv | Nom du client livré
ef_annu | Commande annulée

Ligne de commande

lf_soc | Code société
lf_num | Numéro commande
lf_lig | Numéro ligne commande
lf_cderat | Numéro commande rattachée
lf_lcderat | Numéro ligne commande rattachée
lf_prod | Code article
lib_lf_prod | Désignation article (fiche article)
lf_affect | OF d'affectation
lf_fam | Code famille
libc_lf_fam | Libellé court code famille
libl_lf_fam | Libellé long code famille
lf_sfm | Code sous-famille
libc_lf_sfm | Libellé court code sous-famille
libl_lf_sfm | Libellé long code sous-famille
lf_lib | Désignation de la ligne de commande
lf_long | Longueur
lf_larg | Largeur
lf_qtecde | Quantité commandée
lf_qteliv | Quantité livrée à facturer
lf_qtefac | Quantité facturée
lf_solde | Ligne commande soldée
lf_prx | Prix_unitaire_d'achat
lf_rem | Remise ligne (en %)
lf_forfait | Forfait O/N
lf_unvent | Code unité d'achat
libc_lf_unacha | Libellé court code unité d'achat
libl_lf_unacha | Libellé long code unité d'achat
zc1_lf_unacha | Valeur 1 code unité d'achat
lf_tva | Code TVA
libc_lf_tva | Libellé court code TVA
libl_lf_tva | Libellé long code TVA
zc1_lf_tva | Valeur 1 code TVA
lf_poids | Poids ligne commande
lf_delfou | Délai du fournisseur
lf_delrep | Délai répondu
lf_colis | Nombre colis
lf_adl codp_lf_adl | Code adresse livraison (sur ef_client_liv) Code postal de l'adresse de livraison
ville_lf_adl | Ville adresse livraison (sur ef_client_liv)
lf_rgt | Lieu de rangement
libc_lf_rgt | libellé court du lieu de rangement
libl_lf_rgt | libellé long du lieu de rangement
lf_adst | Code adresse de sous-traitance (fournisseur)
ville_lf_adst | Ville de sous-traitance (fournisseur)
lf_rstbl | Reste des bons à éditer
lf_nummvt | Numéro de mouvement de stock en entrée
lf_nummvts | Numéro de mouvement de stock en sortie
lf_prixliv | Prix unitaire d'achat réalisé
lf_cdc | Numéro du centre de coût
lf_qtemar | Quantité de marche
lf_etatmar | Etat du marché
lf_prixvente | Prix unitaire de vente
lf_sec_ana | Code section analytique
lf_prx_euro | Prix unitaire d'achat en EUROS
lf_prx_dev | Prix unitaire d'achat en devise
lf_prixliv_euro | Prix unitaire d'achat réalisé en EUROS
lf_prixliv_dev | Prix unitaire d'achat réalisé en devise
lf_prixvente_euro | Prix unitaire de vente en EUROS
lf_prixvente_dev | Prix unitaire de vente en devise

Entête du bon de réception

bre_soc | Code société
bre_bon | Numéro de bon de réception
bre_type_bon | Type de bon (C, réception, T, retour)
bre_date_bon | Date du bon
bre_four | Code fournisseur
nom_bre_four | Nom du fournisseur
bre_devise | Code de la devise
libc_bre_devise | Libellé court de la devise
libl_bre_devise | Libellé long de la devise
bre_annu | Bon annulé O/N

Ligne du bon de réception

brd_soc | Code société
brd_bon | Numéro du bon de réception
brd_lig | Numéro de ligne
brd_cde | Numéro de commande d'achat
brd_ligcde | Numéro de ligne de la commande d'achat
brd_ligcad | Numéro de ligne de cadencement de la ligne de commande
brd_article | Code article
des_brd_article | Désignation de l'article
brd_quantite | Quantité réceptionnée
brd_prix | Valeur de la réception/retour
brd_nummvt | numéro du mouvement de stock d'entrée normale
brd_nummvts | numéro du mouvement de stock de sortie normale
brd_prix_euro | Valeur de la réception/retour en EUROS
brd_prix_dev | Valeur de la réception/retour en devise
brd_solde | Ligne soldée O/N
brd_litige | Code litige O/N
brd_ref_bl_four | Référence du BL fournisseur
brd_rappro | Ligne de réception rapprochée
brd_annu | Ligne annulée O/N

Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

Ligne de facture en devise société

mtt_ligne_brut_ht | Montant brut HT de la ligne
mtt_ligne_remise | Montant remise de la ligne
mtt_ligne_escompte | Montant escompte de la ligne
mtt_ligne_net_ht | Montant net HT de la ligne
mtt_ligne_tva | Montant TVA de la ligne
mtt_ligne_ttc | Montant TTC de la ligne

Ligne de facture en Euros

mtt_ligne_brut_ht_euro | Montant brut HT de la ligne
mtt_ligne_remise_euro | Montant remise de la ligne
mtt_ligne_escompte_euro | Montant escompte de la ligne
mtt_ligne_net_ht_euro | Montant net HT de la ligne
mtt_ligne_tva_euro | Montant TVA de la ligne
mtt_ligne_ttc_euro | Montant TTC de la ligne

Ligne de facture en devise

mtt_ligne_brut_ht_devise | Montant brut HT de la ligne
mtt_ligne_remise_devise | Montant remise de la ligne
mtt_ligne_escompte_devise | Montant escompte de la ligne
mtt_ligne_net_ht_devise | Montant net HT de la ligne
mtt_ligne_tva_devise | Montant TVA de la ligne
mtt_ligne_ttc_devise | Montant TTC de la ligne

Pied de facture en devise société

mtt_brut_ht | Montant brut HT
mtt_remise_ligne | Montant remise ligne
mtt_remise_entete | Montant remise entête
mtt_remise_totale | Montant remise totale
mtt_escompte | Montant escompte
mtt_port_taxable | Montant port taxable
mtt_port_non_taxable | Montant port non taxable
mtt_port_total | Montant port total
mtt_net_ht_taxable | Montant net HT taxable
mtt_net_ht_total | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1 | Montant TVA 1
base_tva_1 | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2 | Montant TVA 2
base_tva_2 | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3 | Montant TVA 3
base_tva_3 | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4 | Montant TVA 4
base_tva_4 | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5 | Montant TVA 5
base_tva_5 | Base TVA 5
mtt_tva | Montant TVA
mtt_ttc | Montant TTC

Pied de facture en Euros

mtt_brut_ht_euro | Montant brut HT
mtt_remise_ligne_euro | Montant remise ligne
mtt_remise_entête_euro | Montant remise entête
mtt_remise_totale_euro | Montant remise totale
mtt_escompte_euro | Montant escompte
mtt_port_taxable_euro | Montant port taxable
mtt_port_non_taxable_euro | Montant port non taxable
mtt_port_total_euro | Montant port total
mtt_net_ht_taxable_euro | Montant net HT taxable
mtt_net_ht_total_euro | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1_euro | Montant TVA 1
base_tva_1_euro | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2_euro | Montant TVA 2
base_tva_2_euro | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3_euro | Montant TVA 3
base_tva_3_euro | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4_euro | Montant TVA 4
base_tva_4_euro | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5_euro | Montant TVA 5
base_tva_5_euro | Base TVA 5
mtt_tva_euro | Montant TVA
mtt_ttc_euro | Montant TTC

Pied de facture en devise

mtt_brut_ht_devise | Montant brut HT
mtt_remise_ligne_devise | Montant remise ligne
mtt_remise_entete_devise | Montant remise entête
mtt_remise_totale_devise | Montant remise totale
mtt_escompte_devise | Montant escompte
mtt_port_taxable_devise | Montant port taxable
mtt_port_non_taxable_devise | Montant port non taxable
mtt_port_total_devise | Montant port total
mtt_net_ht_taxable_devise | Montant net HT taxable
mtt_net_ht_total_devise | Montant net HT total
taux_tva_1 | Taux TVA 1
mtt_tva_1_devise | Montant TVA 1
base_tva_1_devise | Base TVA 1
taux_tva_2 | Taux TVA 2
mtt_tva_2_devise | Montant TVA 2
base_tva_2_devise | Base TVA 2
taux_tva_3 | Taux TVA 3
mtt_tva_3_devise | Montant TVA 3
base_tva_3_devise | Base TVA 3
taux_tva_4 | Taux TVA 4
mtt_tva_4_devise | Montant TVA 4
base_tva_4_devise | Base TVA 4
taux_tva_5 | Taux TVA 5
mtt_tva_5_devise | Montant TVA 5
base_tva_5_devise | Base TVA 5
mtt_tva_devise | Montant TVA
mtt_ttc_devise | Montant TTC

Dossiers de fabrication - Nomenclatures

Zone ajoutées le 07/05/2013

f0_cde | Commande
f0_cli | Code client
f0_of | Numéro d'OF
f0_prod des_f0_prod | Code article Désignation de l'article
f0_qtel | Quantité lancée
f0_qter | Quantité réalisée
f0_soc | Société

Autres zones

using | Voir #VI
poids_net_ligne | Poids net de la ligne facture/avoir
poids_net_total | Poids net de la facture/avoir
date_echeance_1 | Date échéance 1
date_echeance_2 | Date échéance 2 si échéances multiples
date_echeance_3 | Date échéance 3 si échéances multiples
date_echeance_4 | Date échéance 4 si échéances multiples
mode_exoneration | Mode exonération. Type paramètre EXO.
libc_mode_exoneration | Libellé court mode exonération
libl_mode_exoneration | Libellé long mode exonération
mois_facturation | Mois de facturation
coef_conv | Coefficient de conversion (fonction coef_conv) Tient compte de l'option Ola. Non disponible en visu, disponible uniquement dans les formules de calcul.
longueur | Si option Ola, longueur de la commande d'achat Sinon, longueur de la fiche produit. Non disponible en visu, disponible uniquement dans les formules de calcul.
largeur | Si option Ola, largeur de la commande d'achat Sinon, largeur de la fiche produit. Non disponible en visu, disponible uniquement dans les formules de calcul.
pour_lf_certification | Pourcentage de la certification du code certification de la ligne de commande fournisseur
pour_brd_certification | Pourcentage de la certification du code certification de la ligne du bon de réception/retour de marchandises


v_lieu_rgt Visualisation des lieux de rangement

Cette visu est opérationnelle à partir de la V. 4.1.7.2

Options

-N | Code article affecté au lieu. (-Nxxxxxx avec xxxx = code article)
Ogo | Gestion de l'outillage

Notes

CLIPPED_LIGNE_EF | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
CONTROLE_LIEUX_RGT | 21 Contrôle des lieux de rangement lors de la saisie (O/N, O par défaut)
CTRL_DOUBLON_RGT | 21 Contrôle si un lieu RG1 est déjà affecté à un code papier quelque soit RG2 et/ou RG3 dans le cas d'une utilisation en mono-référence.
CTRL_PRESENCE_STK | Contrôle lors de la désaffectation si du stock est présent dans le lieu. N Pas de contrôle C Demande de confirmation W Affichage d'un message
SEP_VISU_TYPE_F_CHAR | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
SUP_REQ_RECH_STK | 21, 60 Complément de sélection sur stk0 lors de la recherche de stock au moment de la désaffectation. Note cumulative
TEXT_LIBRE_1_V_T_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier. Zones disponibles supplémentaires : – date – heure au format hh :mm – cpt1 compteur. Celui-ci s'incrément depuis la zone numérique 1 du paramètre de lancement. – espace*α où α est un nombre entier (exemple : %espace*10% créera 10 espaces) Exemple : Extraction du %date% à %heure%
TITRE_VISU_TYPE_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

Noms de zones disponibles

lieu_rgt_e | Package Lieux de rangement (Entête)
lieu_rgt_d | Package Lieux de rangement (Lignes)
mat | Package Articles - Matières - Produits


v_lot_industriel Visualisation des lots industriels

Ce programme est opérationnel à partie de la V. 4.1.26.2

Il permet de visualiser les lots industriels : tables lot_industriel, cli, et mat.

Les actions suivantes sont accessibles :

- Visualisation des mouvements de stock associés à ce lot.

- Accès aux informations du lot pour notamment valider ou invalider ce dernier.

- Accès aux bons de réception (dans le cas d'un lot sur achat)

- Accès à la commande qui a initié ce lot (lancement d'une visualisation)

Commande d'achat ou commande commerciale suivant le type de lot.

- Accès à l'article.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_ART

Code article

Options

Olf | Visualisation des lots industriels fournisseurs Sans option, Visualisation des lots industriels liés aux commandes commerciales
Orv | Rafraîchissement automatique de l'écran de visualisation après l'exécution d'une action pouvant modifier les données affichées : Accès au lot industriel (F8) et Accès à l'article (F9).
Oxd | Cacher le cadre Détail.
Oxs | Ne pas passer par l'écran de sélection.

Valeur alpha 4

A4[5] | Autorisation de rafraîchir l'écran de visualisation (O/N, N par défaut)
A4[8] | Accès au détail d'un lot industriel à partir de l'écran de visualisation (O/M/N, N par défaut) O Accès en consultation M Accès en modification N Pas d'accès
A4[9] | Accès au détail d'un article à partir de l'écran de visualisation (O/M/N, N par défaut) O Accès en consultation M Accès en modification N Pas d'accès
A4[13] | Autorisation d'accès à la visualisation des bons de réception qui ont initié le lot industriel (O/N, N par défaut)
A4[14] | Autorisation d'accès à la visualisation des commandes d'achat s'il y l'option Olf, sinon à la visualisation des commandes client, qui ont initié le lot industriel (O/N, N par défaut)
A4[15] | Autorisation d'accès à la visualisation des mouvements de stocks liés au lot industriel (O/N, N par défaut)
A4[16] | Autorisation d'accès à la fonction de visualisation des matières restantes en stock pour un lot donné (O/N, N par défaut)
A4[17] | Autorisation d'accès à la fonction de visualisation des produits en fabrication pour un lot donné (O/N, N par défaut)

Notes

SAISIE_ARTICLE | 21,26 Type et code du paramètre de lancement de la saisie des articles
SAISIE_LOT_INDUS | 21,26 Type et code du paramètre de lancement de la saisie des lots industriels
_SUP_REQ_LOT_INDUS | 21,60 Complément de sélection pour la visualisation des lots industriels (tables lot_industriel, cli, ou mat)
_SUP_SQL_CONTROLEUR | 21,60 Complément de sélection pour la recherche des contrôleurs (en interrogation sur la zone, table par02)
VISU_BRC_PARAM | 21,26 Type et code du paramètre de lancement de la visualisation des bons de réception
VISU_CDE_PARAM | 21,26 Type et code du paramètre de lancement de la visualisation des commandes client
VISU_CDF_PARAM | 21,26 Type et code du paramètre de lancement de la visualisation des commandes d'achat
VISU_PROD_EN_FAB | 21,26 Type et code du paramètre de lancement de la visualisation des commandes client pour la visualisation des produits en fabrication pour un lot donné
VISU_STK0_PARAM | 21,26 Type et code du paramètre de lancement de la visualisation des mouvements de stock

Zones utilisables

Lot industriel | Toutes les zones du package Lot Industriel
Article | Toutes les zones du package Articles - Matières - Produits
Tiers | Toutes les zones du package Tiers

Critères de tri disponibles

Par défaut, le tri se fait sur les zones 01 à 05.

01 | Type d'enregistrement
02 | Site de production
03 | Fournisseur
04 | Article
05 | Numéro de lot industriel
06 | Référence fournisseur
07 | Date de début de validité
08 | Date de fin de validité
09 | Statut du lot industriel
10 | Sous-statut du lot industriel
11 | Litige
12 | Date de création
13 | Date de clôture
14 | Date de contrôle
15 | Code contrôleur
16 | Enregistrement annulé logiquement

Possibilité d'appeler les visualisations suivantes, en leur passant le numéro de lot industriel en argument

v_brc | Visualisation des bons de réception
v_cdem | Visualisation des commandes client
v_cdef | Visualisation des commandes d'achat
v_stk0 | Visualisation des mouvements de stock


v_machine Visualisation des machines

Visualisation des machines v_machine

Ce programme est utilisable à partir de la V. 4.0.186.2

Orv

Rafraîchissement automatique de la visualisation si nécessaire

(Après les touches F8, F11, F12, F20, F21, F22, F23, F24, F25 et CONTROL-J)

Valeur alpha 2

A2[1] | Second écran de sélection (O/N, N par défaut)
A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)
A2[10] | Lancement du programme en Batch E Edition F Fichier
A2[38] | Lien avec les effectifs standards (table ef_std) (O/N, N par défaut)
A2[39,41] | Code étiquette de la table des taux mensuels des centres de coût (Paramètre ETI - table ccout1) Facultatif - STD par défaut
A2[42,44] | Code utilisation de la table des taux mensuels des centres de coût (Paramètre ETI - table ccout1) Facultatif - STD par défaut

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[5] | Touche F5 - Rafraîchissement de la visualisation (O/N, N par défaut)
A4[8] | Touche F8 - Lancement de la saisie de la machine (O/N, N par défaut)
A4[11] | Touche F11 - Visualisation des effectifs standards de la machine (O/N, N par défaut)
A4[12] | Touche F12 - Visualisation des opérations élémentaires de la machine (O/N, N par défaut)
A4[20] | Touche F20 (Shift-F8) - Visualisation des informations complémentaires de la machine (O/N, N par défaut)
A4[21] | Touche F21 (Shift-F9) - Lancement de programme - Raccourci n°1 (O/N, N par défaut)
A4[22] | Touche F22 (Shift-F10) - Lancement de programme - Raccourci n°2 (O/N, N par défaut)
A4[23] | Touche F23 (Shift-F11) - Lancement de programme - Raccourci n°3 (O/N, N par défaut)
A4[24] | Touche F24 (Shift-F12) - Lancement de programme - Raccourci n°4 (O/N, N par défaut)
A4[25] | Touche F25 (Control-Shift-F1) - Lancement de programme - Raccourci n°5 (O/N, N par défaut)
A4[43] | Touche CONTROL-J - Lancement de programme de la ligne courante (O/N, N par défaut)

Notes

LCT_PROG_CONFIG | Voir aide générale au paramétrage des modules de visualisation Voir aide du paramètre #RP
RUN_SAISIE_MACHINE | 21,26 Type et code paramètre du lancement de la saisie de la machine
RUN_VISU_OPE_ELE_MAC | 21,26 Type et code paramètre du lancement de la visualisation des opérations élémentaires de la machine
_SUP_REQ_EF_STD | 21,60 Complément de sélection sur la table ef_std Note utilisée si A2[38] = O.
_SUP_REQ_MAC0 | 21,60 Complément de sélection sur la table mac0

Ordres de tri disponibles

01 | m0_machine | Code machine
02 | m0_typmac | Type de machine
03 | m0_sit_prod | Site de production
04 | m0_atelier | Atelier
05 | m0_actif | Code actif
06 | m0_ordre | Numéro d'ordre
07 | ccout | Centre de coût

Liste des zones disponibles

ZC = Zones cumulables et utilisables dans les formules de calcul.

mac0 | ZC | Machines | Toutes les zones du Package
ef_std | ZC | Effectifs standards | Toutes les zones du Package
ccout0 |  | Centres de coût | Toutes les zones du Package
ccout1 | ZC | Taux mensuels des centres de coût | Toutes les zones du Package
Autres zones | ZC | pres_eff_std nb_lignes_eff_std type_ligne using | Présence d'au moins une ligne dans la table des effectifs standards Nombre de lignes dans la table des effectifs standards Type de ligne (M = Ligne machine - E = Ligne effectif standard) Voir #VI


v_mar Visualisation des mariages

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de mariage

Exemple : -N[x1_num_mariage]

Options

Oc2 | Utilisation du coefficient paramétré sur la zone numérique 2 du paramètre de type CAN lors du calcul du grammage du papier.
O5c | Ajout de 5 critères de sélection Client de l'OF Famille de l'article de l'OF Article de l'OF Composition planifiée du mariage Composition fabriquée de l'OF

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch (E/F) E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractères 15 à 17 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
Caractères 30 | Option regroupement par papier (O/N, O par défaut)
Caractère 31 | Option plastique (O/N, N par défaut)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES MARIAGES

Valeur alpha 4

Paramétrage des touches de fonction

Ordres de tris disponibles

1 | code_ond | Code Onduleuse
2 | code_mar | Numéro Mariage
3 | datim_deb_mar | Date, heure début mariage
4 | code_fac | Code Faction
5 | code_equ | Code équipe
6 | datim_deb_fac | Date, heure début faction
7 | code_pap | Code Papier
8 | code_laize | Laize

Liste des noms de zones autorisées

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Mariages (table fab_ond_mar)

Package Tiers

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Fiche article composition commerciale carton

Fiche article composition technique carton

Colonnes spéciales

Mariages (table fab_ond_mar)

x1_soc | Code société
x1_code_onduleuse lib_x1_code_onduleuse | Code onduleuse Libellé de l'onduleuse
x1_num_mariage | Numéro de mariage
x1_num_inter_mar | Numéro inter mariage
x1_datim_deb_mar date_deb_mar heure_deb_mar | Date et heure début mariage Date de début de mariage Heure de début de mariage
x1_datim_fin_mar date_fin_mar heure_fin_mar | Date et heure fin mariage Date de fin de mariage Heure de fin de mariage
x1_code_faction lib_x1_code_faction | Code faction Libellé du code faction
x1_code_equipe nom_x1_code_equipe | Code équipe Nom de l'équipe
x1_duree_plan_mar | Durée prévue du mariage
x1_duree_mar | Durée réelle du mariage
x1_datim_deb_fac date_deb_fac heure_deb_fac | Date et heure de début de faction Date de début de faction Heure de début de faction
x1_datim_fin_fac date_fin_fac heure_fin_fac | Date et heure de fin de faction Date de fin de faction Heure de fin de faction
x1_duree_plan_fac | Durée prévue de faction
x1_duree_fac | Durée réelle de faction
x1_profil_cannel libc_x1_profil_cannel libl_x1_profil_cannel | Code du profil cannelé Libellé court du profil cannelé Libellé long du profil cannelé
x1_qual_monte | Composition commerciale montée
x1_pap_N_planif des_x1_pap_N_planif | Papier planifié N (N compris entre 1 et 9) Désignation du papier planifié N
x1_pap_N_monte des_x1_pap_N_monte | Papier monté N (N compris entre 1 et 9) Désignation du papier monté N
x1_lz_N_planif | Laize planifiée N (N compris entre 1 et 9)
x1_lz_N_monte | Laize montée N (N compris entre 1 et 9)
x1_lz_mar | Laize du mariage
x1_gram_monte | Grammage monté
x1_gram_planif | Grammage planifié
x1_gram_real | Grammage réel
x1_rogne_monte | Rogne montée
x1_rogne_planif | Rogne planifiée
x1_rogne_real | Rogne réelle
x1_metr_monte_fac | Métrage montée faction
x1_metr_planif_fac | Métrage planifié faction
x1_metr_real_fac | Métrage réel faction
x1_metr_monte_mar | Métrage montée mariage
x1_metr_planif_mar | Métrage planifié mariage
x1_metr_real_mar | Métrage réel mariage
x1_justif_modif | Justification de la modification
x1_epais_mes | Epaisseur
x1_of_N | Numéro de l'OF N, où N peut prendre les valeurs 1 à 8
x1_nb_poses_of_N | Nombre de poses de l'OF N, où N peut prendre les valeurs 1 à 8
x1_lz_of_N | Laize de l'OF N, où N peut prendre les valeurs 1 à 8
x1_qte_plaq_of_N | Nombre de plaques de l'OF N, où N peut prendre les valeurs 1 à 8
x1_coupe_of_N | Nombre de coupes de l'OF N, où N peut prendre les valeurs 1 à 8

Fiche tiers

Les zones du Package Tiers peuvent êtres préfixées de :

of1_ pour l'OF 1

of2_ pour l'OF 2

of3_ pour l'OF 3

of4_ pour l'OF 4

of5_ pour l'OF 5

of6_ pour l'OF 6

of7_ pour l'OF 7

of8_ pour l'OF 8

Ce préfixage est nécessaire pour les OF 2 à 8.

Pour préserver la compatibilité avec l'existant, il est facultatif pour l'OF 1.

Exemples

 | OF 1 | OF 2 | OF 3
Code tarif | of1_cl_tar cl_tar | of2_cl_tar | of3_cl_tar
Libellé court | of1_libc_cl_tar libc_cl_tar | of2_libc_cl_tar | of3_libc_cl_tar
Libellé long | of1_libl_cl_tar libl_cl_tar | of2_libl_cl_tar | of3_libl_cl_tar

Exception : Pour l'OF 1, on dispose également des zones suivantes :

nom_cl_codef | Nom client chez le fournisseur
nom_cl_clifact | Nom client facturation
nom_cl_transp | Nom transporteur
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrf | Ville adresse facturation

Fiche article

Les zones du Package Matière peuvent êtres préfixées de :

of1_ pour l'OF 1

of2_ pour l'OF 2

of3_ pour l'OF 3

of4_ pour l'OF 4

of5_ pour l'OF 5

of6_ pour l'OF 6

of7_ pour l'OF 7

of8_ pour l'OF 8

Ce préfixage est nécessaire pour les OF 2 à 8.

Pour préserver la compatibilité avec l'existant, il est facultatif pour l'OF 1.

Exemples

 | OF 1 | OF 2 | OF 3
Code famille | of1_mp_fam mp_fam | of2_mp_fam | of3_mp_fam
Libellé court | of1_libc_mp_fam libc_mp_fam | of2_libc_mp_fam | of3_libc_mp_fam
Libellé long | of1_libl_mp_fam libl_mp_fam | of3_libl_mp_fam | of3_libl_mp_fam

Autres zones

des_x1_qual_planif | Désignation de la composition planifiée
of1_qual_fab | Composition fabriquée de l'OF 1
of1_des_qual_fab | Désignation de la composition fabriquée de l'OF 1
of2_qual_fab | Composition fabriquée de l'OF 2
of2_des_qual_fab | Désignation de la composition fabriquée de l'OF 2
of3_qual_fab | Composition fabriquée de l'OF 3
of3_des_qual_fab | Désignation de la composition fabriquée de l'OF 3

Exception : Pour l'OF 1, on dispose également des zones suivantes :

zc1_mp_ua | Valeur 1 code unité achat
zc1_mp_uv | Valeur 1 code unité vente
zc1_mp_uvente | Valeur 1 code unité vente 2
zc1_mp_tva | Valeur 1 code TVA

Fiche article composition commerciale carton

et

Fiche article composition technique carton

Les zones suivantes de la table mat peuvent être préfixées de :

mp_qua_car_ pour la composition commerciale

mp_com_car_ pour la composition technique

mp_code | Code article
mp_des | Désignation
mp_fam libc_[préfixe]mp_fam libl_[préfixe]mp_fam | Code famille Libellé court de la famille Libellé long de la famille
mp_sfm libc_[préfixe]mp_sfm libl_[préfixe]mp_sfm | Code sous-famille Libellé court de la sous-famille Libellé long de la sous-famille
mp_lon | Longueur
mp_lar | Largeur
mp_hau | Epaisseur
mp_poids | Poids (en g/m2)

Colonnes spéciales

tv_papier | Code papier (matière) si tri par papier
tv_grammage | Grammage de l'article (si tri) (tient compte des coefficients d'ondulation)
tv_laize | Laize du tri
tv_poids_reel | Consommation granulé par "papier" Uniquement valable dans un environnement plastique

Autres

rebut_type rebut_type_XXX | [blanc] Type de rebut (XXX)
libc_rebut_type libc_rebut_type_XXX | "Tous types" Libellé court du type de rebut XXX
libl_rebut_type libl_rebut_type_XXX | "Tous types de rebuts" Libellé long du type de rebut XXX
rebut_qte rebut_qte_type_XXX | Somme des quantités de plaques au rebut pour la ligne de mariage courante (x4_qte_plaq_rebut) idem pour le type de rebut XXX
rebut_poids rebut_poids_type_XXX | Somme des poids de déchets pour la ligne de mariage courante (x4_poids_dechet) idem pour le type de rebut XXX

où XXX représente un type de rebut (doit correspondre à un code paramètre de type TMT).


v_odv Visualisation du devis onduleur

Options Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Tris Noms de zones autorisés

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : numéro de devis - numéro de sous-devis

Exemples :

-N[od_of_ndemcli]

-N[od_of_ndemcli|-|od_of_noffven+<<&]

Options

-B | Lancement de la visualisation en mode batch (Edition/Fichier)
Oct | Autorise l'accès à la zone de saisie du futur tarif
Onc | Accès à la concurrence par offre de vente
Opz | Pas d'édition des lignes à 0
Ora | Réactualisation automatique
Ore | Recalcul batch du devis avant son édition
Ori | Répétition des informations dans le cas du multi-lignes (Exemple : 2 lignes d'historiques de prix de vente pour une même ligne de devis/sous-devis)
Ovt | Force la date de fin de validité des tarifs créés au 31/12/2100 Existe aussi dans devis_ondu

Valeur alpha 2

Caractère 30

Affichage des données concernant les commandes rattachées en édition (O/N)

Attention : Il est nécessaire d'avoir paramétré des colonnes relatives aux tables des commandes clients pour que ce paramétrage soit effectif

Valeur alpha 3

Titre de la visualisation : VISUALISATION DES DEVIS ONDULEURS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 9 | Touche F9 (O/N) (Informations sur la concurrence)
Caractère 11 | Touche F11 (O/N) (Consultation des prix remis)
Caractère 13 | Touche F13 (O/N) (Consultation des prix de vente)
Caractère 14 | Touche F14 (O/N) (Edition du devis/sous-devis)
Caractère 20 | Autorisation d'accès à la touche de fonction F20 (Devis) (O/N, N par défaut)
Caractère 21 | Touche F21 (O/N) (Modification du sous-devis)
Caractère 38 | Touche CONTROL-C (O/N) (Calculatrice)
Caractère 51 | Touche CONTROL-T (O/N) (Visualisation des touches)
Caractère 56 | Touche CONTROL-Z (O/N) (Lancement de programmes)

Notes

PARAM_ACCES_V_CDEM

21,26 Type et code du paramètre de lancement de la visu des commandes clients

27,29 Code du TYC de rattachement des commandes à visualiser (optionnel)

PARAM_EDITION_DEVIS

21,26 Type et code du paramètre de l'édition de devis (pour pouvoir éditer un devis (par la touche F14)

PARAM_SAISIE_DEVIS

21,26 Type et code du paramètre de lancement de l'accès à la saisie des devis onduleurs

REP_CLI_MULTI_PV

Pour pouvoir saisir les prix de vente (par la touche F13)

21,22 Q1/Q2

_SUP_REQ_CLI

21,60 Supplément de requête sur la table des clients

Exemple

and cl_nom matches "CLI*"

_SUP_REQ_DEMCLI

21,60 Complément de requête sur la table od_demcli

Exemple

and od_de_ddemcli > "01/01/2011"

_SUP_REQ_HIS_DEMCON

21,60 Complément de requête sur la table od_hist_demcon

Exemple

and od_hp_qte <= 5000

_SUP_REQ_HIS_PRIX

21,60 Complément de requête sur la table od_hist_prix

Exemple

and od_hp_prix_ven > 0

_SUP_REQ_MAT

21,60 Complément de requête sur la table des articles

Exemple

and mp_sdisp > 0

_SUP_REQ_OFFRE

21,60 Complément de requête sur la table od_offre

Exemple

and od_of_noffven != 99

_SUP_REQ_TARIF_VEN_1

_SUP_REQ_TARIF_VEN_2

21,60 Complément de requête pour la recherche du tarif de vente (zones tr_1* / tr_2*) sur le client/code produit en lieu et place de la recherche par le serial 1 / 2)

La recherche des tarifs (zones tr_1* / tr_2*) se fait à partir d'un serial stocké sur l'offre.

On peut maintenant rechercher ces tarifs pour le client/code produit, et un complément de requête sans tenir compte de ces serials.

Ordres de tris disponibles

Voir les notes commençant par O

01 |  | Code client
02 |  | Code représentant
03 |  | Code ensemble
04 |  | Devis
05 |  | Sous-devis
06 |  | Réponse devis
07 |  | Date de début de validité
08 |  | Date de fin de validité
09 | le_libpar1 | Référence article du client
10 | le_libelle2 | Complément libellé spécifique
11 | le_libelle | Libellé spécifique

Liste des noms de zone autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Table od_recap_tot (récap. des coûts du devis onduleur): toutes les zones

Devis

Offre de vente

Fiche tiers

Package Matières/Articles/Produits

Les noms de zones peuvent être précédés de x_ où x peut prendre les valeurs de 1 à 5.

Les noms de zones peuvent être précédés de mp_pal pour avoir les informations sur la fiche article palette du devis.

Historique des prix

Historique concurrence

Divers

Zones commençant par tr_

Toutes les zones, triées par ordre alphabétique, à la date du 13/11/2008

DEVIS

od_de_soc | Code société du devis
od_de_ndemcli | Numéro de devis
od_de_ldemcli | Libellé du devis
od_de_lvotrefdem | Référence client
od_de_ctypcorcli | Titre du correspondant
libc_od_de_ctypcorcli | Titre du correspondant (Libellé court)
libl_od_de_ctypcorcli | Titre du correspondant (Libellé long)
od_de_lnomcorcli | Nom du correspondant
od_de_ntelcorcli | Numéro de téléphone du correspondant
od_de_nrefembcli | Code article client
od_de_lrefembcli | Libellé article client
od_de_ddemcli | Date du devis
od_de_ccliliv | Code client livré
od_de_qrefembdem | Quantité demandée
od_de_cclipdo | Adresse de livraison
ville_od_de_cclipdo | Ville adresse de livraison
nom_od_de_cclipdo | Nom adresse de livraison
od_de_crepcli | Réponse client
od_de_cmotdeccli | Motif de décision du client
libc_od_de_cmotdeccli | Motif de décision du client (Libellé court)
libl_od_de_cmotdeccli | Motif de décision du client (Libellé long)
od_de_drepcli | Date de réponse du client
od_de_noffven | Numéro de sous-devis retenu
od_de_noffvenhis | Numéro de sous-devis historisé
od_de_mprivenneg | Prix de vente négocié
od_de_kparmaroff | Pourcentage de part de marché
od_de_cod_rem_prx | Code de remise de prix
libc_od_de_cod_rem_prx | Code de remise de prix (Libellé court)
libl_od_de_cod_rem_prx | Code de remise de prix (Libellé long)

OFFRE DE VENTE

od_of_soc | Code société du devis
od_of_ndemcli | Numéro de devis
od_of_noffven | Numéro de sous-devis
od_of_ddebvaloff | Date de début de validité
od_of_dfinvaloff | Date de fin de validité
od_of_cser | Code service
od_of_nrefembodv | Code ensemble
od_of_qrefemboff | Quantité demandée
od_of_date_cli_fut | Date du changement de tarif
od_of_prix_cli_fut | Nouveau tarif à appliquer
od_of_serial_tar_1 | Serial du tarif 1
od_of_serial_tar_2 | Serial du tarif 2

FICHE TIERS

Toutes les zones du package Tiers

ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

FICHE ARTICLE (PREMIER PRODUIT FINI DE LA NOMENCLATURE)

mp_pf_soc | Code société
mp_pf_code | Code article
mp_pf_mp | Type article
mp_pf_afnor | Code normalisé
lib_mp_pf_afnor_art | Désignation article
lib_mp_pf_afnor_ecma | Désignation ECMA
mp_pf_des | Désignation article
mp_pf_param | Zone données diverses
mp_pf_fam | Code famille
libc_mp_pf_fam | Libellé court code famille
libl_mp_pf_fam | Libellé long code famille
mp_pf_sfm | Code sous-famille
libc_mp_pf_sfm | Libellé court code sous-famille
libl_mp_pf_sfm | Libellé long code sous-famille
mp_pf_libre | Zone libre
libc_mp_pf_libre | Libellé court zone libre
libl_mp_pf_libre | Libellé long zone libre
mp_pf_rgt1 | Code lieu rangement 1
libc_mp_pf_rgt1 | Libellé court code lieu rangement 1
libl_mp_pf_rgt1 | Libellé long code lieu rangement 1
mp_pf_rgt2 | Code lieu rangement 2
mp_pf_rgt3 | Code lieu rangement 3
mp_pf_dt1 | Donnée technique numérique 1
mp_pf_dt2 | Donnée technique numérique 2
mp_pf_dt3 | Donnée technique numérique 3
mp_pf_dt4 | Donnée technique numérique 4
mp_pf_dt5 | Donnée technique numérique 5
mp_pf_dt6 | Donnée technique numérique 6
mp_pf_dt7 | Donnée technique numérique 7
mp_pf_dt8 | Donnée technique numérique 8
mp_pf_at1 | Donnée technique alphanumérique 1
mp_pf_at2 | Donnée technique alphanumérique 2
mp_pf_hau | Hauteur
mp_pf_lon | Longueur
mp_pf_lar | Largeur
mp_pf_cond | Code conditionnement
libc_mp_pf_cond | Libellé court code conditionnement
libl_mp_pf_cond | Libellé long code conditionnement
mp_pf_coul | Code couleur
libc_mp_pf_coul | Libellé court code couleur
libl_mp_pf_coul | Libellé long code couleur
mp_pf_poids | Poids
mp_pf_ua | Code unité achat
libc_mp_pf_ua | Libellé court code unité achat
libl_mp_pf_ua | Libellé long code unité achat
zc1_mp_pf_ua | Valeur 1 code unité achat
mp_pf_uv | Code unité vente
libc_mp_pf_uv | Libellé court code unité vente
libl_mp_pf_uv | Libellé long code unité vente
zc1_mp_pf_uv | Valeur 1 code unité vente
mp_pf_uvente | Code unité vente 2
libc_mp_pf_uvente | Libellé court code unité vente 2
libl_mp_pf_uvente | Libellé long code unité vente 2
zc1_mp_pf_uvente | Valeur 1 code unité vente 2
mp_pf_fconv | Code formule conversion
libc_mp_pf_fconv | Libellé court code formule conversion
libl_mp_pf_fconv | Libellé long code formule conversion
mp_pf_fconv2 | Code formule conversion 2
libc_mp_pf_fconv2 | Libellé court code formule conversion 2
libl_mp_pf_fconv2 | Libellé long code formule conversion 2
mp_pf_remp | Code article remplacement
lib_mp_pf_remp | Désignation article remplacement
mp_pf_pamp | Valeur stock
mp_pf_pa | Prix achat
mp_pf_cfrais | Taux frais
mp_pf_cperte | Taux perte
mp_pf_pr | Prix revient
mp_pf_marg | Taux marge
mp_pf_pv | Prix vente
mp_pf_pv2 | Prix vente dans unité utilisation
mp_pf_tva | Code TVA
libc_mp_pf_tva | Libellé court code TVA
libl_mp_pf_tva | Libellé long code TVA
zc1_mp_pf_tva | Valeur 1 code TVA
mp_pf_cpta | Compte d'achat
mp_pf_cptv | Compte de vente
mp_pf_ana | Code analytique
mp_pf_suistk | Suivi en stock
mp_pf_tval | Type valorisation
mp_pf_dermvt | Date dernier mouvement stock
mp_pf_derinv | Date dernier inventaire stock
mp_pf_derent | Date dernière entrée stock
mp_pf_dersor | Date dernière sortie stock
mp_pf_smini | Stock mini
mp_pf_smaxi | Stock maxi
mp_pf_sdisp | Stock disponible
mp_pf_sphy | Stock physique
mp_pf_sres | Stock réserve
mp_pf_sbes | Stock besoins
mp_pf_scdef | Stock en commande ou en fabrication
mp_pf_ssim | Stock simulation
mp_pf_minfou | Minimum commande fournisseur ou fabrication
mp_pf_abc | Classement ABC
mp_pf_controle | Code contrôle qualité
mp_pf_reap | Code réapprovisionnement
libc_mp_pf_reap | Libellé court code réapprovisionnement
libl_mp_pf_reap | Libellé long code réapprovisionnement
mp_pf_foucli | Code fournisseur
nom_mp_pf_foucli | Nom fournisseur
mp_pf_cli | Code client
nom_mp_pf_cli | Nom client
mp_pf_qteeco | Quantité économique commande ou fabrication
mp_pf_delmoy | Délai moyen d'approvisionnement
mp_pf_ndm | Numéro dernier mouvement stock
mp_pf_qualite | Code qualité
libc_mp_pf_qualite | Libellé court code qualité
libl_mp_pf_qualite | Libellé long code qualité
mp_pf_z1 | Zone paramétrée 1
mp_pf_z2 | Zone paramétrée 2
mp_pf_z3 | Zone paramétrée 3
mp_pf_z4 | Zone paramétrée 4
mp_pf_z5 | Zone paramétrée 5
mp_pf_alerte | Stock alerte
mp_pf_gestionnaire | Code gestionnaire
libc_mp_pf_gestionnaire | Libellé court code gestionnaire
libl_mp_pf_gestionnaire | Libellé long code gestionnaire
mp_pf_pr_fixe | Prix fixe
mp_pf_coefdiv_ffix | Coefficient diviseur frais fixe
mp_pf_affect | Numéro affectation
mp_pf_cdc | Code centre de coût
lib_mp_pf_cdc | Libellé centre de coût
mp_pf_devis | Numéro devis
mp_pf_sdevis | Numéro sous-devis
mp_pf_gencod | Code GENCOD
mp_pf_itf14 | Code ITF14
mp_pf_anu | Article annulé
mp_pf_date | Date enregistrement article

HISTORIQUE DES PRIX

od_hp_soc | Code société
od_hp_prod | Code produit
od_hp_cli | Code client
od_hp_date_cre | Date de création
od_hp_num_enr | Numéro d'enregistrement
od_hp_qte | Quantité de l'offre
od_hp_prix_revient | Prix de revient
od_hp_prix_remis | Prix remis
od_hp_prix_ven | Prix de vente
od_hp_poids_uni | Poids unitaire
od_hp_surf_uni | Surface unitaire

HISTORIQUE CONCURRENCE

od_hc_soc | Code société
od_hc_prod | Code produit
od_hc_cli | Code client
od_hc_datim_cre | Date de création
od_hc_num_enr | Numéro d'enregistrement
od_hc_ccon | Code concurrent
libc_od_hc_ccon | Code concurrent (Libellé court)
libl_od_hc_ccon | Code concurrent (Libellé long)
od_hc_qte | Quantité
od_hc_mprivencon | Prix de la concurrence
od_hc_kparmarcon | Part de marché de la concurrence
using | Voir #VI

Divers

prix_vente_ou_remis | Prix de vente si renseigné ou prix remis par défaut
chute_laize | Chute de la laize en m2 de la quantité devisée

Zones tr_ (triées)

tr_1_anu | Tarif annulé O/N
tr_1_bascule_euro | Bascule Euro O/N
tr_1_binf | Borne inférieure
tr_1_bsup | Borne supérieure
tr_1_cat | Catégorie
tr_1_cle | Serial 1
tr_1_cli | Client
tr_1_datd | Date de début
tr_1_datf | Date de fin
tr_1_devise | Devise
tr_1_devise_av_euro | Devise avant Euro
tr_1_fam | Famille
tr_1_mat | Article
tr_1_note_1 | Note 1
tr_1_note_2 | Note 2
tr_1_prixnet | Prix net O/N
tr_1_sfm | Sous-famille
tr_1_soc | Code société du tarif
tr_1_tar | Type de tarif
tr_1_unite | Unité
tr_1_va | VA O/N
tr_1_val | Valeur 1
tr_1_val2 | Valeur 2
tr_1_val_av_euro | Valeur avant Euro
tr_2_anu | Tarif annulé O/N
tr_2_bascule_euro | Bascule Euro O/N
tr_2_binf | Borne inférieure
tr_2_bsup | Borne supérieure
tr_2_cat | Catégorie
tr_2_cle | Serial 2
tr_2_cli | Client
tr_2_datd | Date de début
tr_2_datf | Date de fin
tr_2_devise | Devise
tr_2_devise_av_euro | Devise avant Euro
tr_2_fam | Famille
tr_2_mat | Article
tr_2_note_2 | Note 1
tr_2_note_2 | Note 2
tr_2_prixnet | Prix net O/N
tr_2_sfm | Sous-famille
tr_2_soc | Code société du tarif
tr_2_tar | Type de tarif
tr_2_unite | Unité
tr_2_va | VA O/N
tr_2_val | Valeur 1
tr_2_val2 | Valeur 2
tr_2_val_av_euro | Valeur avant Euro

Toutes les zones, triées par ordre alphabétique, à la date du 13/11/2008

cl_ach_aff Code acheteur pour affacturage

cl_act Code secteur d'activité

cl_adr1 Ligne d'adresse 1

cl_adr2 Ligne d'adresse 2

cl_adra Adresse d'envoi des AR

cl_adrb Adresse d'envoi des BL

cl_adrd Adresse d'envoi des offres de prix

cl_adrf Adresse d'envoi des factures

cl_agrement Code agrément

cl_annul Fiche annulée O/N

cl_ape Code APE

cl_cat Code catégorie du client

cl_clifact Code du client facturé

cl_cligr Code du groupe du client

cl_code code tiers

cl_code_domb1 Code domiciliation bancaire

cl_codef Votre code (client si fournisseur / fournisseur si client)

cl_codp Code postal

cl_corres Correspondant principal

cl_cpf Type de tiers

cl_cpt Compte tiers

cl_cred Crédit d'accord

cl_dat_cr Date de création de la fiche

cl_dateannu Date d'annulation de la fiche tiers

cl_delai_consigne Délai maxi de consignation

cl_dev Code devise client

cl_documents Documents à joindre

cl_domb Suite de la domiciliation bancaire

cl_domb1 Domiciliation bancaire 1

cl_domb2 Zone paramétrable

cl_ech Code échéance

cl_edit Edition des traites O/N

cl_email Adresse E-mail

cl_esc Taux d'escompte

cl_exp Exportation O/N

cl_facp Facturation partielle autorisée O/N

cl_geo Code secteur géographique

cl_groupe_risque Code client utilisé dans le calcul du risque groupe

cl_iban RIB

cl_incoterm Conditions de port habituelle du client

cl_insee Code INSEE de la commune

cl_langue Langue utilisée

cl_livp Livraisons partielles autorisées O/N

cl_mailing Type de mailing

cl_marge Taux de marge du client

cl_minf Minimum de commande

cl_mrg Code mode de règlement

cl_nbfac Nombre de copies de facture à éditer

cl_nom Nom du tiers

cl_nom_abrege Nom abrégé du tiers

cl_orig Code origine

cl_param Zone de données diverses

cl_pays Code pays

cl_perf Code périodicité de facturation

cl_perr Code périodicité des relevés de factures

cl_pla_franco_port Montant plafond franco de port

cl_port_dest Ville port destination

cl_prca Taux de l'acompte

cl_qual Code forme juridique

cl_qualif_appel Qualificatif de l'appel de livraison

cl_qualite Code qualité tiers

cl_regbl Regroupement de BL O/N

cl_rel Edition de relevé de facture O/N

cl_rem Code remise

cl_remg Taux de remise globale des commandes

cl_reml Taux de remise par ligne de commande

cl_repr Code représentant

cl_rib RIB

cl_seuila Montant du seuil d'acompte

cl_siret SIRET

cl_soc Code société de la fiche tiers

cl_suiv Code suivi d'affaire

cl_tar Code tarif

cl_telcop FAX

cl_telex Telex

cl_telph1 Téléphone 1

cl_telph2 Téléphone 2

cl_titre Code titre du correspondant

cl_tolerance_liv Tolérance de livraison

cl_tour Code tournée

cl_trac Gestion des traites acceptées O/N

cl_transp Code transporteur du client

cl_trsp Code du type de transport

cl_valbl Valorisation des BL O/N

cl_validite_adr Code validité de l'adresse

cl_vil Ville

cl_zpar Zone paramétrable

cl_zpar2 Zone paramétrable 2

cl_zpar3 Zone paramétrable 3

cl_zpar_adresse Zone paramétrable adresse

cl_zparnum Zone paramétrable

le_client Client

le_langue Langue

le_libelle Libellé 1

le_libelle2 Libellé 2

le_libpar1 Libellé article

le_prod Article

le_signe Signe

le_soc Code société du libellé

lib_mp_afnor_art Libellé AFNOR si code normalisé renseigné

lib_mp_afnor_ecma Libellé normalisé ECMA si code ECMA renseigné

lib_mp_cdc Libellé du centre de coût

lib_mp_qualite_matiere Désignation de la qualité matière

lib_mp_remp Désignation de remplacement

libc_cl_act libellé court du secteur d'activité

libc_cl_agrement Libellé court de l'agrément

libc_cl_cat Libellé court de la catégorie du client

libc_cl_dev Libellé court du code devise

libc_cl_ech Libellé court de l'échéance

libc_cl_geo Libellé court du secteur géographique

libc_cl_incoterm Libellé court des conditions de port

libc_cl_langue Libellé court de la langue utilisée

libc_cl_mailing Libellé court du type de mailing

libc_cl_mrg Libellé court du mode de règlement

libc_cl_orig Libellé court de l'origine

libc_cl_pays Libellé court du code pays

libc_cl_perf Libellé court de la périodicité de facturation

libc_cl_perr Libellé court de la périodicité des relevés

libc_cl_qual Libellé court de la forme juridique

libc_cl_qualif_appel Libellé court du qualificatif d'appel de livraison

libc_cl_qualite Libellé court de la qualité tiers

libc_cl_rem Libellé court du code remise

libc_cl_repr Libellé court du représentant

libc_cl_suiv Libellé court du suivi d'affaire

libc_cl_tar Libellé court du code tarif

libc_cl_titre Libellé court du titre du correspondant

libc_cl_tolerance_liv Libellé court de la tolérance de livraison

libc_cl_tour Libellé court du code tournée

libc_cl_trsp Libellé court du type de transport

libc_cl_validite_adr Libellé court du code validité de l'adresse

libc_le_langue Langue (Libellé court)

libc_mp_cond Libellé court du conditionnement

libc_mp_coul Libellé court du code couleur

libc_mp_fam Libellé court de la famille

libc_mp_fconv Libellé court de la formule de conversion

libc_mp_fconv2 Libellé court de la formule de conversion 2

libc_mp_gestionnaire Libellé court du gestionnaire

libc_mp_libre Libellé court de la zone produit

libc_mp_qualite Libellé court du qualificatif de l'article

libc_mp_reap Libellé court du mode de réapprovisionnement

libc_mp_rgt1 Libellé court du lieu de rangement de niveau 1

libc_mp_sfm Libellé court de la sous-famille

libc_mp_tva Libellé court de la TVA

libc_mp_ua Libellé court de l'unité d'achat

libc_mp_uv Libellé court de l'unité de vente

libc_mp_uvente (libellé court) Spécifique

libc_od_de_cmotdeccli Motif de décision du client (Libellé court)

libc_od_de_cod_rem_prx Code de remise de prix (Libellé court)

libc_od_de_ctypcorcli Titre du correspondant (Libellé court)

libc_od_hc_ccon Code concurrent (Libellé court)

libc_tr_1_cat Catégorie (Libellé court)

libc_tr_1_devise Devise (Libellé court)

libc_tr_1_devise_av_euro Devise avant Euro (Libellé court)

libc_tr_1_fam Famille (Libellé court)

libc_tr_1_sfm Sous-famille (Libellé court)

libc_tr_1_tar Type de tarif (Libellé court)

libc_tr_1_unite Unité (Libellé court)

libc_tr_2_cat Catégorie (Libellé court)

libc_tr_2_devise Devise (Libellé court)

libc_tr_2_devise_av_euro Devise avant Euro (Libellé court)

libc_tr_2_fam Famille (Libellé court)

libc_tr_2_sfm Sous-famille (Libellé court)

libc_tr_2_tar Type de tarif (Libellé court)

libc_tr_2_unite Unité (Libellé court)

libl_cl_act libellé long du secteur d'activité

libl_cl_agrement Libellé long de l'agrément

libl_cl_cat Libellé long de la catégorie du client

libl_cl_dev Libellé long du code devise

libl_cl_ech Libellé long de l'échéance

libl_cl_geo Libellé long du secteur géographique

libl_cl_incoterm Libellé long des conditions de port

libl_cl_langue Libellé long de la langue utilisée

libl_cl_mailing Libellé long du type de mailing

libl_cl_mrg Libellé long du mode de règlement

libl_cl_orig Libellé long de l'origine

libl_cl_pays Libellé long du code pays

libl_cl_perf Libellé long de la périodicité de facturation

libl_cl_perr Libellé long de la périodicité des relevés

libl_cl_qual Libellé long de la forme juridique

libl_cl_qualif_appel Libellé long du qualificatif d'appel de livraison

libl_cl_qualite Libellé long de la qualité tiers

libl_cl_rem Libellé long du code remise

libl_cl_repr Libellé long du représentant

libl_cl_suiv Libellé long du suivi d'affaire

libl_cl_tar Libellé long du code tarif

libl_cl_titre Libellé long du titre du correspondant

libl_cl_tolerance_liv Libellé long de la tolérance de livraison

libl_cl_tour Libellé long du code tournée

libl_cl_trsp Libellé long du type de transport

libl_cl_validite_adr Libellé long du code validité de l'adresse

libl_le_langue Langue (Libellé long)

libl_mp_cond Libellé long du conditionnement

libl_mp_coul Libellé long du code couleur

libl_mp_fam Libellé long de la famille

libl_mp_fconv Libellé long de la formule de conversion

libl_mp_fconv2 Libellé long de la formule de conversion 2

libl_mp_gestionnaire Libellé long du gestionnaire

libl_mp_libre Libellé long de la zone produit

libl_mp_qualite Libellé long du qualificatif de l'article

libl_mp_reap Libellé long du mode de réapprovisionnement

libl_mp_rgt1 Libellé long du lieu de rangement de niveau 1

libl_mp_sfm Libellé long de la sous-famille

libl_mp_tva Libellé long de la TVA

libl_mp_ua Libellé long de l'unité d'achat

libl_mp_uv Libellé long de l'unité de vente

libl_mp_uvente (libellé long) Spécifique

libl_od_de_cmotdeccli Motif de décision du client (Libellé long)

libl_od_de_cod_rem_prx Code de remise de prix (Libellé long)

libl_od_de_ctypcorcli Titre du correspondant (Libellé long)

libl_od_hc_ccon Code concurrent (Libellé long)

libl_tr_1_cat Catégorie (Libellé long)

libl_tr_1_devise Devise (Libellé long)

libl_tr_1_devise_av_euro Devise avant Euro (Libellé long)

libl_tr_1_fam Famille (Libellé long)

libl_tr_1_sfm Sous-famille (Libellé long)

libl_tr_1_tar Type de tarif (Libellé long)

libl_tr_1_unite Unité (Libellé long)

libl_tr_2_cat Catégorie (Libellé long)

libl_tr_2_devise Devise (Libellé long)

libl_tr_2_devise_av_euro Devise avant Euro (Libellé long)

libl_tr_2_fam Famille (Libellé long)

libl_tr_2_sfm Sous-famille (Libellé long)

libl_tr_2_tar Type de tarif (Libellé long)

libl_tr_2_unite Unité (Libellé long)

mp_abc Classement A/B/C

mp_affect OF d'affectation par défaut

mp_afnor Code normalisé AFNOR

mp_alerte Seuil d'alerte

mp_ana Code analytique

mp_anu Article annulé O/N

mp_at1 Donnée technique alpha 1

mp_at2 Donnée technique alpha 2

mp_cdc Centre de coût d'affectation

mp_cfrais taux de frais

mp_cli Code du client principale

mp_code Code article

mp_coefdiv_ffix Coefficient diviseur des frais fixes

mp_cond Code conditionnement

mp_controle Code contrôle de qualité

mp_coul Code couleur

mp_cperte Taux de perte

mp_cpta Compte d'achat

mp_cptv Compte de vente

mp_date Date de création

mp_delmoy Délai moyen de réapprovisionnement ou de fabrication

mp_derent Date de la dernière entrée en stock

mp_derinv Date du dernier inventaire

mp_dermvt Date du dernier mouvement

mp_dersor Date de la dernière sortie du stock

mp_des Désignation de l'article

mp_des2 Désignation de l'article

mp_devis Devis d'origine

mp_dt1 Donnée technique numérique 1

mp_dt2 Donnée technique numérique 2

mp_dt3 Donnée technique numérique 3

mp_dt4 Donnée technique numérique 4

mp_dt5 Donnée technique numérique 5

mp_dt6 Donnée technique numérique 6

mp_dt7 Donnée technique numérique 7

mp_dt8 Donnée technique numérique 8

mp_fam Famille

mp_fconv Formule de conversion

mp_fconv2 Formule de conversion 2

mp_foucli Code fournisseur principale

mp_gencod Code à barres

mp_gestionnaire Code gestionnaire

mp_hau Hauteur

mp_itf14 ITF14

mp_lar Largeur

mp_libre Zone libre

mp_lon Longueur

mp_marg Taux de marge

mp_minfou Minimum commande fournisseur ou fabrication

mp_mp Type de l'article

mp_ndm Numéro du dernier mouvement de stock

mp_pa Prix d'achat

mp_pamp Valeur du stock en prix d'achat moyen pondéré

mp_param Données diverses de l'article

mp_param_22 Données diverses de l'article

mp_poids Poids

mp_pr Prix de revient

mp_pr_fixe Prix de revient fixe

mp_pv Prix de vente

mp_pv2 Prix de vente dans l'unité d'utilisation

mp_qteeco Quantité économique de commande

mp_qualite Qualificatif de l'article

mp_qualite_matiere Code qualité matière

mp_reap Mode de réapprovisionnement

mp_remp Code produit de remplacement

mp_rgt1 Lieux de rangement de niveau 1

mp_rgt2 Lieu de rangement de niveau 2

mp_rgt3 Lieu de rangement de niveau 3

mp_sbes Besoins

mp_scdef Stock en commande fournisseur et fabrication

mp_sdevis sous-devis d'origine

mp_sdisp Stock disponible

mp_sfm Sous-famille

mp_smaxi Stock maxi

mp_smini Stock mini

mp_soc Code société de la fiche article

mp_sphy Stock physique

mp_sres Stock réserve

mp_ssim Stock issu d'une simulation

mp_suistk Suivi en stock O/N

mp_tva Taux de TVA

mp_tval Type de valorisation

mp_ua Unité d'achat

mp_uv Unité de vente

mp_uvente (unité de vente) Spécifique

mp_z1 zone libre 1

mp_z2 zone libre 2

mp_z3 zone libre 3

mp_z4 zone libre 4

mp_z5 zone libre 5

nom_cl_clifact Nom du client facturé

nom_cl_cligr Nom du groupe du client

nom_cl_codef nom du client/fournisseur

nom_cl_groupe_risque Nom du client utilisé dans le calcul du risque groupe

nom_cl_transp nom du transporteur du client

nom_mp_cli Nom du client principale

nom_mp_foucli Nom du fournisseur principale

nom_od_de_cclipdo Nom adresse de livraison

od_de_ccliliv Code client livré

od_de_cclipdo Adresse de livraison

od_de_cmotdeccli Motif de décision du client

od_de_cod_rem_prx Code de remise de prix

od_de_crepcli Réponse client

od_de_ctypcorcli Titre du correspondant

od_de_ddemcli Date du devis

od_de_drepcli Date de réponse du client

od_de_kparmaroff Pourcentage de part de marché

od_de_ldemcli Libellé du devis

od_de_lnomcorcli Nom du correspondant

od_de_lrefembcli Libellé article client

od_de_lvotrefdem Référence client

od_de_mprivenneg Prix de vente négocié

od_de_ndemcli Numéro de devis

od_de_noffven Numéro de sous-devis retenu

od_de_noffvenhis Numéro de sous-devis historisé

od_de_nrefembcli Code article client

od_de_ntelcorcli Numéro de téléphone du correspondant

od_de_qrefembdem Quantité demandée

od_de_soc Code société du devis

od_hc_ccon Code concurrent

od_hc_cli Code client

od_hc_datim_cre Date de création

od_hc_kparmarcon Part de marché de la concurrence

od_hc_mprivencon Prix de la concurrence

od_hc_num_enr Numéro d'enregistrement

od_hc_prod Code produit

od_hc_qte Quantité

od_hc_soc Code société

od_hp_cli Code client

od_hp_date_cre Date de création

od_hp_num_enr Numéro d'enregistrement

od_hp_poids_uni Poids unitaire

od_hp_prix_remis Prix remis

od_hp_prix_revient Prix de revient

od_hp_prix_ven Prix de vente

od_hp_prod Code produit

od_hp_qte Quantité de l'offre

od_hp_soc Code société

od_hp_surf_uni Surface unitaire

od_of_cser Code service

od_of_date_cli_fut Date du changement de tarif

od_of_ddebvaloff Date de début de validité

od_of_dfinvaloff Date de fin de validité

od_of_ndemcli Numéro de devis

od_of_noffven Numéro de sous-devis

od_of_nrefembodv Code ensemble

od_of_prix_cli_fut Nouveau tarif à appliquer

od_of_qrefemboff Quantité demandée

od_of_serial_tar_1 Serial du tarif 1

od_of_serial_tar_2 Serial du tarif 2

od_of_soc Code société du devis

od_to_cs_100 Coûts supplémentaire au 100

od_to_marge_com Marge commerciale

od_to_marge_prev Marge prévisionnelle

od_to_marge_pv Marge sur le PV

od_to_ndemcli Numéro de devis

od_to_noffven Numéro de sous-devis

od_to_pf_100 Prix PF au 100

od_to_prix_dev Prix devisé

od_to_prix_dev_kg Prix devisé au kg

od_to_prix_dev_m2 Prix devisé au m2

od_to_prix_rem_cli Prix remis client

od_to_prix_remis Prix remis

od_to_prix_revient Prix de revient

od_to_prix_ven Prix de vente

od_to_prix_ven_cli Prix de vente client

od_to_prix_ven_kg Prix de vente au kg

od_to_prix_ven_m2 Prix de vente au m2

od_to_soc Code société du devis

prix_vente_ou_remis Prix remis ou prix de vente

tr_1_anu Tarif annulé O/N

tr_1_bascule_euro Bascule Euro O/N

tr_1_binf Borne inférieure

tr_1_bsup Borne supérieure

tr_1_cat Catégorie

tr_1_cle Serial 1

tr_1_cli Client

tr_1_datd Date de début

tr_1_datf Date de fin

tr_1_devise Devise

tr_1_devise_av_euro Devise avant Euro

tr_1_fam Famille

tr_1_mat Article

tr_1_note_1 Note 1

tr_1_note_2 Note 2

tr_1_prixnet Prix net O/N

tr_1_sfm Sous-famille

tr_1_soc Code société du tarif

tr_1_tar Type de tarif

tr_1_unite Unité

tr_1_va VA O/N

tr_1_val Valeur 1

tr_1_val2 Valeur 2

tr_1_val_av_euro Valeur avant Euro

tr_2_anu Tarif annulé O/N

tr_2_bascule_euro Bascule Euro O/N

tr_2_binf Borne inférieure

tr_2_bsup Borne supérieure

tr_2_cat Catégorie

tr_2_cle Serial 2

tr_2_cli Client

tr_2_datd Date de début

tr_2_datf Date de fin

tr_2_devise Devise

tr_2_devise_av_euro Devise avant Euro

tr_2_fam Famille

tr_2_mat Article

tr_2_note_2 Note 1

tr_2_note_2 Note 2

tr_2_prixnet Prix net O/N

tr_2_sfm Sous-famille

tr_2_soc Code société du tarif

tr_2_tar Type de tarif

tr_2_unite Unité

tr_2_va VA O/N

tr_2_val Valeur 1

tr_2_val2 Valeur 2

tr_2_val_av_euro Valeur avant Euro

ville_cl_adra Ville d'envoi des AR

ville_cl_adrb Ville d'envoi des BL

ville_cl_adrd Ville d'envoi des offres de prix

ville_cl_adrf Ville d'envoi des factures

ville_od_de_cclipdo Ville adresse de livraison

zc1_mp_tva Valeur du taux de TVA

zc1_mp_ua Valeur de l'unité d'achat

zc1_mp_uv Valeur de l'unité de vente

zc1_mp_uvente (valeur) Spécifique


v_palchep Visualisation des palettes CHEP

Valeurs alpha Notes Tris Noms de zones autorisés

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 10 | Lancement en Batch E Edition F Fichier (Nom du fichier à paramétrer dans les notes)
Caractères 31 à 33 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
Caractères 34 à 36 | TSC spécifications palette Exemple 290

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES PALETTES CHEP

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 38 | Touche CONTROL-C (O/N) - Calculatrice
Caractère 51 | Touche CONTROL-T (O/N) - Visualisation des touches
Caractère 56 | Touche CONTROL-Z (O/N) - Lancement de programmes

Notes

_SUP_REQ_FAB0_PAL

21,60 Complément de critère de sélection pour la recherche des palettes à partir de la table fab0 pour les expéditions d'articles composition (commandes FB2).

Tous les champs de la table fab0 sont accessibles.

supreqtabletemp

ou

SUPREQTABLETEMP

21,60 Complément facultatif de critère de sélection sur la table temporaire.

Champs accessibles de la table temporaire :

temp_visu.type_pal | Type palette
temp_visu.mode_gest_pal | Mode gestion palette
temp_visu.code_client_liv | Client livré
temp_visu.code_adresse_liv | Code adresse client livré
temp_visu.code_postal_liv | Code postal client livré
temp_visu.nom_ville_liv | Ville client livré
temp_visu.code_pays_liv | Code pays client livré
temp_visu.num_blv | N° BL
temp_visu.num_lig_blv | N° de ligne de BL
temp_visu.date_blv | Date livraison
temp_visu.num_bex | N° bordereau d'expédition
temp_visu.code_client_cde | Client commande
temp_visu.code_adresse_cde | Code adresse client commande
temp_visu.code_postal_cde | Code postal client commande
temp_visu.nom_ville_cde | Ville client commande
temp_visu.code_pays_cde | Code pays client commande
temp_visu.num_cde | N°de de commande
temp_visu.num_lig_cde | N° de ligne de commande
temp_visu.num_seq_lig_cde | N° de séquence de ligne de commande
temp_visu.date_cde | Date commande
temp_visu.code_art | Code produit fini
temp_visu.code_pal | Code palette
temp_visu.format_pal | Format palette (EX : 1200 X 2400)

Exemples

supreqtabletemp and temp_visu.type_pal = "BOI"

supreqtabletemp and temp_visu.mode_gest_pal = "PE"

supreqpal

ou

SUPREQPAL

21 à 60 Complément obligatoire de critère de sélection pour la recherche des palettes.

Tous les champs de la table nom0 sont accessibles.

Exemple

supreqpal and nom0.n0_pcsant matches "ZDA*"

Ordres de tris disponibles

1 | t_pal | Type Palette
2 | m_ges | Mode Gestion Palette
3 | c_cliliv | Code Client Livraison
4 | c_adrliv | Code Adresse Livraison
5 | c_posliv | Code Postal Livraison
6 | n_villiv | Nom Ville Livraison
7 | c_payliv | Code Pays Livraison
8 | n_blv | N° Bon Livraison
9 | d_blv | Date Bon Livraison
10 | n_bex | N° Bordereau Expédition
11 | c_clicde | Code Client Commande
12 | c_adrcde | Code Adresse Commande
13 | c_poscde | Code Postal Commande
14 | n_vilcde | Nom Ville Commande
15 | c_paycde | Code Pays Commande
16 | n_cde | N° Commande
17 | d_cde | Date Commande
18 | c_art | Code Produit Fini
19 | c_pal | Code Palette
20 | d_format | Format Palette

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Entête bon de livraison

Ligne bon de livraison

Entête commande

Ligne commande

Nomenclature ligne de commande

Fiche tiers adresse principale

Fiche tiers adresse de livraison

Fiche tiers adresse de commande

Fiche article produit fini

Fiche article palette

Autres zones

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Entête bon de livraison

b1_soc | Code société
b1_blv | Numéro de bon de livraison
b1_cli | Code client
nom_b1_cli | Nom client
b1_ref | Référence du bon de livraison
b1_sitp | Code zone paramétrable
libc_b1_sitp | Libellé court code zone paramétrable
libl_b1_sitp | Libellé long code zone paramétrable
b1_tport | Type de port
libc_b1_tport | Libellé court type de port
libl_b1_tport | Libellé long type de port
b1_pht | Port taxable en devise société
b1_tvap | Code TVA port taxable
libc_b1_tvap | Libellé court code TVA port taxable
libl_b1_tvap | Libellé long code TVA port taxable
zc1_b1_tvap | Valeur 1 code TVA port taxable
b1_trsp | Mode de transport
libc_b1_trsp | Libellé court mode de transport
libl_b1_trsp | Libellé long mode de transport
b1_trans | Code transporteur
nom_b1_trans | Nom transporteur
b1_tadr | Type d'adresse de livraison
b1_adrl | Code adresse livraison
ville_b1_adrl | Ville adresse livraison
b1_datl | Date bon de livraison
b1_adrf | Code adresse facturation
ville_b1_adrf | Ville adresse facturation
b1_col | Nombre de colis total
b1_poids | Poids total
b1_montant | Coût en devise société
b1_com | Observation
b1_edit | Bon de livraison édité
b1_embal | Type d'emballage
b1_cembal | Coût emballage en devise société
b1_tvae | Code TVA emballage
libc_b1_tvae | Libellé court code TVA emballage
libl_b1_tvae | Libellé long code TVA emballage
zc1_b1_tvae | Valeur 1 code TVA emballage
b1_type_vehicule | Type de véhicule
libc_b1_type_vehicule | Libellé court type de véhicule
libl_b1_type_vehicule | Libellé long type de véhicule
b1_vehicule | Véhicule (immatriculation)
b1_heure_depart | Heure de départ
b1_no_groupage | Numéro groupage
b1_date_chargem | Date de chargement
b1_pht_euro | Port taxable en EUROS
b1_pht_dev | Port taxable en devise
b1_montant_euro | Coût en EUROS
b1_montant_dev | Coût en devise
b1_cembal_euro | Coût emballage en EUROS
b1_cembal_dev | Coût emballage en devise
b1_lieu_rgt1 | Magasin destination
libc_b1_lieu_rgt1 | Libellé court magasin destination
libl_b1_lieu_rgt1 | Libellé long magasin destination
b1_ordre_chargt | Ordre de chargement
b1_annu | Bon de livraison annule
b1_transitaire | Code transitaire
nom_b1_transitaire | Nom transitaire

Ligne bon de livraison

b2_soc | Code société
b2_blv | Numéro de bon de livraison
b2_lig | Numéro de ligne de bon de livraison
b2_cde | Numéro de commande
b2_ligcde | Numéro de ligne de commande
b2_ligseq | Numéro de séquence de la ligne de commande
b2_qte | Quantité livrée facturable
b2_qteliv | Quantité livrée
b2_poids | Poids
b2_nbcolis | Nombre de colis/palettes
b2_excolis | Nombre d'exemplaires
b2_nummvt | Numéro de mouvement de stock
b2_fact | Ligne de bon de livraison facturée (O/N)
b2_solde | Ligne de commande soldée (O/N)
b2_type_livraison | Type de livraison
b2_annu | Ligne de bon de livraison annulée

Entête commande

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court code zone paramétrable
libl_ec_c1 | Libellé long code zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
ville_ec_ada | Ville adresse réception
ec_adf | Code adresse facturation
ville_ec_adf | Ville adresse facturation
ec_adl | Code adresse livraison
ville_ec_adl | Ville adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte en devise société
ec_pnt | Port non taxable en devise société
ec_pht | Port taxable en devise société
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accuse de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facture
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture - avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_acc_euro | Acompte en EUROS
ec_acc_dev | Acompte en devise
ec_pnt_euro | Port non taxable en EUROS
ec_pnt_dev | Port non taxable en devise
ec_pht_euro | Port taxable en EUROS
ec_pht_dev | Port taxable en devise
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande

Ligne commande

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Numéro ligne commande
lc_prod | Code article
lib_lc_prod | Désignation article (fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
lc_lib | Désignation article (ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée à facturer
lc_qteafa | Quantité à facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente en devise société
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court code zone paramétrable 1
libl_lc_p1 | Libellé long code zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court code zone paramétrable 2
libl_lc_p2 | Libellé long code zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code TVA
libc_lc_tva | Libellé court code TVA
libl_lc_tva | Libellé long code TVA
zc1_lc_tva | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delrep | Date de livraison proposée
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (non utilisée)
lc_colis | Nombre colis
lc_prxcli | Prix client en devise société
lc_rstfac | Reste des factures a éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorite | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
ville_lc_adl | Ville adresse livraison
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus en devise société
lc_prx_au_moins | Prix unitaire vente au moins en devise société
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient en devise société
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel en devise société
lc_date_solde | Date de solde de la ligne de commande
lc_qteliv_reelle | Quantité réellement livrée
lc_prx_euro | Prix unitaire vente en EUROS
lc_prx_dev | Prix unitaire vente en devise
lc_prxcli_euro | Prix client en EUROS
lc_prxcli_dev | Prix client en devise
lc_prx_plus_euro | Prix unitaire vente au plus en EUROS
lc_prx_plus_dev | Prix unitaire vente au plus en devise
lc_prx_moins_euro | Prix unitaire vente au moins en EUROS
lc_prx_moins_dev | Prix unitaire vente au moins en devise
lc_prx_rvt_euro | Prix unitaire revient en EUROS
lc_prx_rvt_r_euro | Prix unitaire revient réel en EUROS
lc_lieu_rgt1 | Code lieu de rangement 1
 | Fenêtre revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_deldep | Date de départ au plus tard
lc_annu | Ligne commande annulée
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Nomenclature ligne de commande

nc_soc | Code société
nc_num | Numéro commande
nc_lig | Numéro ligne commande
nc_seq | Numéro séquence
nc_prod | Code article
lib_nc_prod | Désignation article (fiche article)
nc_coef_nom | Coefficient nomenclature
nc_qtecde | Quantité commandée nomenclature
nc_qteliv | Quantité livrée nomenclature
nc_qteliv_non_val | Quantité livrée non validée nomenclature
nc_qteliv_val | Quantité livrée validée nomenclature
nc_rgt1 | Code lieu rangement 1
libc_nc_rgt1 | Libellé court code lieu rangement 1
libl_nc_rgt1 | Libellé long code lieu rangement 1
nc_rgt2 | Code lieu rangement 2
nc_rgt3 | Code lieu rangement 3
nc_nummvt | Numéro mouvement de stock
nc_solde | Ligne nomenclature soldée

Fiche tiers adresse principale

Toutes les zones du package Tiers ainsi que les zones suivantes :

ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

Fiche tiers adresse de livraison

livraison_code_client | Code tiers
livraison_code_adresse | Code adresse livraison
livraison_nom | Nom tiers
livraison_adresse_1 | Ligne 1 adresse rue
livraison_adresse_2 | Ligne 2 adresse rue
livraison_code_postal | Code postal
livraison_ville | Adresse ville
livraison_pays | Code pays
livraison_libc_pays | Libellé court code pays
livraison_libl_pays | Libellé long code pays
livraison_telephone_1 | Numéro téléphone 1
livraison_telephone_2 | Numéro téléphone 2
livraison_telecopie | Numéro fax
livraison_telex | Numéro télex

Fiche tiers adresse de commande

commande_code_client | Code tiers
commande_code_adresse | Code adresse commande
commande_nom | Nom tiers
commande_adresse_1 | Ligne 1 adresse rue
commande_adresse_2 | Ligne 2 adresse rue
commande_code_postal | Code postal
commande_ville | Adresse ville
commande_pays | Code pays
commande_libc_pays | Libellé court code pays
commande_libl_pays | Libellé long code pays
commande_telephone_1 | Numéro téléphone 1
commande_telephone_2 | Numéro téléphone 2
commande_telecopie | Numéro fax
commande_telex | Numéro télex

Fiche article produit fini

pf_mp_soc | Code société
pf_mp_code | Code article
pf_mp_mp | Type article
pf_mp_afnor | Code normalise
pf_lib_mp_afnor_art | Désignation article
pf_lib_mp_afnor_ecma | Désignation ECMA
pf_mp_des | Désignation article
pf_mp_param | Zone données diverses
pf_mp_fam | Code famille
pf_libc_mp_fam | Libellé court code famille
pf_libl_mp_fam | Libellé long code famille
pf_mp_sfm | Code sous-famille
pf_libc_mp_sfm | Libellé court code sous-famille
pf_libl_mp_sfm | Libellé long code sous-famille
pf_mp_libre | Zone libre
pf_libc_mp_libre | Libellé court zone libre
pf_libl_mp_libre | Libellé long zone libre
pf_mp_rgt1 | Code lieu rangement 1
pf_libc_mp_rgt1 | Libellé court code lieu rangement 1
pf_libl_mp_rgt1 | Libellé long code lieu rangement 1
pf_mp_rgt2 | Code lieu rangement 2
pf_mp_rgt3 | Code lieu rangement 3
pf_mp_dt1 | Donnée technique numérique 1
pf_mp_dt2 | Donnée technique numérique 2
pf_mp_dt3 | Donnée technique numérique 3
pf_mp_dt4 | Donnée technique numérique 4
pf_mp_dt5 | Donnée technique numérique 5
pf_mp_dt6 | Donnée technique numérique 6
pf_mp_dt7 | Donnée technique numérique 7
pf_mp_dt8 | Donnée technique numérique 8
pf_mp_at1 | Donnée technique alphanumérique 1
pf_mp_at2 | Donnée technique alphanumérique 2
pf_mp_hau | Hauteur
pf_mp_lon | Longueur
pf_mp_lar | Largeur
pf_mp_cond | Code conditionnement
pf_libc_mp_cond | Libellé court code conditionnement
pf_libl_mp_cond | Libellé long code conditionnement
pf_mp_coul | Code couleur
pf_libc_mp_coul | Libellé court code couleur
pf_libl_mp_coul | Libellé long code couleur
pf_mp_poids | Poids
pf_mp_ua | Code unité achat
pf_libc_mp_ua | Libellé court code unité achat
pf_libl_mp_ua | Libellé long code unité achat
pf_zc1_mp_ua | Valeur 1 code unité achat
pf_mp_uv | Code unité vente
pf_libc_mp_uv | Libellé court code unité vente
pf_libl_mp_uv | Libellé long code unité vente
pf_zc1_mp_uv | Valeur 1 code unité vente
pf_mp_uvente | Code unité vente 2
pf_libc_mp_uvente | Libellé court code unité vente 2
pf_libl_mp_uvente | Libellé long code unité vente 2
pf_zc1_mp_uvente | Valeur 1 code unité vente 2
pf_mp_fconv | Code formule conversion
pf_libc_mp_fconv | Libellé court code formule conversion
pf_libl_mp_fconv | Libellé long code formule conversion
pf_mp_fconv2 | Code formule conversion 2
pf_libc_mp_fconv2 | Libellé court code formule conversion 2
pf_libl_mp_fconv2 | Libellé long code formule conversion 2
pf_mp_remp | Code article remplacement
pf_lib_mp_remp | Désignation article remplacement
pf_mp_pamp | Valeur stock
pf_mp_pa | Prix achat
pf_mp_cfrais | Taux frais
pf_mp_cperte | Taux perte
pf_mp_pr | Prix revient
pf_mp_marg | Taux marge
pf_mp_pv | Prix vente
pf_mp_pv2 | Prix vente dans unité utilisation
pf_mp_tva | Code TVA
pf_libc_mp_tva | Libellé court code TVA
pf_libl_mp_tva | Libellé long code TVA
pf_zc1_mp_tva | Valeur 1 code TVA
pf_mp_cpta | Compte achat
pf_mp_cptv | Compte vente
pf_mp_ana | Code analytique
pf_mp_suistk | Suivi en stock
pf_mp_tval | Type valorisation
pf_mp_dermvt | Date dernier mouvement stock
pf_mp_derinv | Date dernier inventaire stock
pf_mp_smini | Stock mini
pf_mp_smaxi | Stock maxi
pf_mp_sdisp | Stock disponible
pf_mp_sphy | Stock physique
pf_mp_sres | Stock réserve
pf_mp_sbes | Stock besoins
pf_mp_scdef | Stock en commande ou en fabrication
pf_mp_ssim | Stock simulation
pf_mp_minfou | Minimum commande fournisseur ou fabrication
pf_mp_abc | Classement ABC
pf_mp_controle | Code contrôle qualité
pf_mp_reap | Code réapprovisionnement
pf_libc_mp_reap | Libellé court code réapprovisionnement
pf_libl_mp_reap | Libellé long code réapprovisionnement
pf_mp_foucli | Code fournisseur
pf_nom_mp_foucli | Nom fournisseur
pf_mp_cli | Code client
pf_nom_mp_cli | Nom client
pf_mp_qteeco | Quantité économique commande ou fabrication
pf_mp_delmoy | Délai moyen d'approvisionnement
pf_mp_ndm | Numéro dernier mouvement stock
pf_mp_qualite | Code qualité
pf_libc_mp_qualite | Libellé court code qualité
pf_libl_mp_qualite | Libellé long code qualité
pf_mp_z1 | Zone paramétrée 1
pf_mp_z2 | Zone paramétrée 2
pf_mp_z3 | Zone paramétrée 3
pf_mp_z4 | Zone paramétrée 4
pf_mp_z5 | Zone paramétrée 5
pf_mp_alerte | Stock alerte
pf_mp_gestionnaire | Code gestionnaire
pf_libc_mp_gestionnaire | Libellé court code gestionnaire
pf_libl_mp_gestionnaire | Libellé long code gestionnaire
pf_mp_pr_fixe | Prix fixe
pf_mp_coefdiv_ffix | Coefficient diviseur frais fixe
pf_mp_affect | Numéro affectation
pf_mp_cdc | Code centre de coût
pf_lib_mp_cdc | Libellé centre de coût
pf_mp_derent | Date dernière entrée stock
pf_mp_dersor | Date dernière sortie stock
pf_mp_devis | Numéro devis
pf_mp_sdevis | Numéro sous-devis
pf_mp_gencod | Code GENCOD
pf_mp_itf14 | Code ITF14
pf_mp_anu | Article annulé
pf_mp_date | Date enregistrement article
pf_mp_qualite_matiere pf_lib_mp_qualite_matiere | Qualité matière Désignation de la qualité matière

Fiche article palette

pal_mp_soc | Code société
pal_mp_code | Code article
pal_mp_mp | Type article
pal_mp_afnor | Code normalisé
pal_lib_mp_afnor_art | Désignation article
pal_lib_mp_afnor_ecma | Désignation ECMA
pal_mp_des | Désignation article
pal_mp_param | Zone données diverses
pal_mp_fam | Code famille
pal_libc_mp_fam | Libellé court code famille
pal_libl_mp_fam | Libellé long code famille
pal_mp_sfm | Code sous-famille
pal_libc_mp_sfm | Libellé court code sous-famille
pal_libl_mp_sfm | Libellé long code sous-famille
pal_mp_libre | Zone libre
pal_libc_mp_libre | Libellé court zone libre
pal_libl_mp_libre | Libellé long zone libre
pal_mp_rgt1 | Code lieu rangement 1
pal_libc_mp_rgt1 | Libellé court code lieu rangement 1
pal_libl_mp_rgt1 | Libellé long code lieu rangement 1
pal_mp_rgt2 | Code lieu rangement 2
pal_mp_rgt3 | Code lieu rangement 3
pal_mp_dt1 | Donnée technique numérique 1
pal_mp_dt2 | Donnée technique numérique 2
pal_mp_dt3 | Donnée technique numérique 3
pal_mp_dt4 | Donnée technique numérique 4
pal_mp_dt5 | Donnée technique numérique 5
pal_mp_dt6 | Donnée technique numérique 6
pal_mp_dt7 | Donnée technique numérique 7
pal_mp_dt8 | Donnée technique numérique 8
pal_mp_at1 | Donnée technique alphanumérique 1
pal_mp_at2 | Donnée technique alphanumérique 2
pal_mp_hau | Hauteur
pal_mp_lon | Longueur
pal_mp_lar | Largeur
pal_mp_cond | Code conditionnement
pal_libc_mp_cond | Libellé court code conditionnement
pal_libl_mp_cond | Libellé long code conditionnement
pal_mp_coul | Code couleur
pal_libc_mp_coul | Libellé court code couleur
pal_libl_mp_coul | Libellé long code couleur
pal_mp_poids | Poids
pal_mp_ua | Code unité achat
pal_libc_mp_ua | Libellé court code unité achat
pal_libl_mp_ua | Libellé long code unité achat
pal_zc1_mp_ua | Valeur 1 code unité achat
pal_mp_uv | Code unité vente
pal_libc_mp_uv | Libellé court code unité vente
pal_libl_mp_uv | Libellé long code unité vente
pal_zc1_mp_uv | Valeur 1 code unité vente
pal_mp_uvente | Code unité vente 2
pal_libc_mp_uvente | Libellé court code unité vente 2
pal_libl_mp_uvente | Libellé long code unité vente 2
pal_zc1_mp_uvente | Valeur 1 code unité vente 2
pal_mp_fconv | Code formule conversion
pal_libc_mp_fconv | Libellé court code formule conversion
pal_libl_mp_fconv | Libellé long code formule conversion
pal_mp_fconv2 | Code formule conversion 2
pal_libc_mp_fconv2 | Libellé court code formule conversion 2
pal_libl_mp_fconv2 | Libellé long code formule conversion 2
pal_mp_remp | Code article remplacement
pal_lib_mp_remp | Désignation article remplacement
pal_mp_pamp | Valeur stock
pal_mp_pa | Prix achat
pal_mp_cfrais | Taux frais
pal_mp_cperte | Taux perte
pal_mp_pr | Prix revient
pal_mp_marg | Taux marge
pal_mp_pv | Prix vente
pal_mp_pv2 | Prix vente dans unité utilisation
pal_mp_tva | Code TVA
pal_libc_mp_tva | Libellé court code TVA
pal_libl_mp_tva | Libellé long code TVA
pal_zc1_mp_tva | Valeur 1 code TVA
pal_mp_cpta | Compte achat
pal_mp_cptv | Compte vente
pal_mp_ana | Code analytique
pal_mp_suistk | Suivi en stock
pal_mp_tval | Type valorisation
pal_mp_dermvt | Date dernier mouvement stock
pal_mp_derinv | Date dernier inventaire stock
pal_mp_smini | Stock mini
pal_mp_smaxi | Stock maxi
pal_mp_sdisp | Stock disponible
pal_mp_sphy | Stock physique
pal_mp_sres | Stock réserve
pal_mp_sbes | Stock besoins
pal_mp_scdef | Stock en commande ou en fabrication
pal_mp_ssim | Stock simulation
pal_mp_minfou | Minimum commande fournisseur ou fabrication
pal_mp_abc | Classement ABC
pal_mp_controle | Code contrôle qualité
pal_mp_reap | Code réapprovisionnement
pal_libc_mp_reap | Libellé court code réapprovisionnement
pal_libl_mp_reap | Libellé long code réapprovisionnement
pal_mp_foucli | Code fournisseur
pal_nom_mp_foucli | Nom fournisseur
pal_mp_cli | Code client
pal_nom_mp_cli | Nom client
pal_mp_qteeco | Quantité économique commande ou fabrication
pal_mp_delmoy | Délai moyen d'approvisionnement
pal_mp_ndm | Numéro dernier mouvement stock
pal_mp_qualite | Code qualité
pal_libc_mp_qualite | Libellé court code qualité
pal_libl_mp_qualite | Libellé long code qualité
pal_mp_z1 | Zone paramétrée 1
pal_mp_z2 | Zone paramétrée 2
pal_mp_z3 | Zone paramétrée 3
pal_mp_z4 | Zone paramétrée 4
pal_mp_z5 | Zone paramétrée 5
pal_mp_alerte | Stock alerte
pal_mp_gestionnaire | Code gestionnaire
pal_libc_mp_gestionnaire | Libellé court code gestionnaire
pal_libl_mp_gestionnaire | Libellé long code gestionnaire
pal_mp_pr_fixe | Prix fixe
pal_mp_coefdiv_ffix | Coefficient diviseur frais fixe
pal_mp_affect | Numéro affectation
pal_mp_cdc | Code centre de coût
pal_lib_mp_cdc | Libellé centre de coût
pal_mp_derent | Date dernière entrée stock
pal_mp_dersor | Date dernière sortie stock
pal_mp_devis | Numéro devis
pal_mp_sdevis | Numéro sous-devis
pal_mp_gencod | Code GENCOD
pal_mp_itf14 | Code ITF14
pal_mp_anu | Article annulé
pal_mp_date | Date enregistrement article

Autres zones

type_palette | Type palette Type paramètre TP.
libc_type_palette | Libellé court mode exonération
libl_type_palette | Libellé long mode exonération
mode_gestion | Mode gestion palette Type paramètre MG
libc_mode_gestion | Libellé court mode gestion palette
libl_mode_gestion | Libellé long mode gestion palette
format_palette | Format palette 1200 X 2400
using | Voir #VI


v_par01 Visualisation des types de paramètres

Cette visu est opérationnelle à partir de la V. 4.0.188.2

Elle peut être appelée depuis un autre programme par la touche Ctrl J (voir #RP).

Données accessibles :

Type de paramètre (par01)

Notes (notes)

Actions possibles sur une ligne de visualisation :

Accès à la saisie des notes de saisie simplifiée (touche de fonction F6)

Accès à la saisie des types de paramètre (touche de fonction F8, cette action peut être limitée via la permission TOU/VPAR01_F8)

Accès à la saisie des libellés étrangers (touche de fonction F12)

Accès paramétrable à un programme externe n°1 (voir #RP, touche de fonction Shift+F9)

Accès paramétrable à un programme externe n°2 (voir #RP, touche de fonction Shift+F10)

Rafraîchissement de la visualisation (touche de fonction Control+Shift+F1)

Génération d'un fichier Excel à partir du résultat de la visualisation

Lancement de programme paramétrable (voir #RP, touche de fonction Control-J)

Accès à la saisie des notes (touche de fonction Control-N)

Accès à la saisie des notes de vérification/suppression (touche de fonction Control-P)

Options

Orv

Rafraîchissement automatique de la visualisation après le lancement d'une action

(Appel à la saisie des types de paramètre, par exemple)

Valeur alpha 2

A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détail si rupture et cumul (O/N, N par défaut)

Valeur alpha 3

A3[1,60]

Titre de la visualisation

Valeur alpha 4

A4[6] | Touche de fonction F6 : Accès à la saisie simplifiée (notes de type P02) O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[8] | Touche de fonction F8 : Accès à la saisie des types de paramètre O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[11] | Touche de fonction F12 : Accès à la saisie des libellés étrangers O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[21] | Touche de fonction Shift+F9 : Accès au premier programme externe paramétrable (O/N, N par défaut)
A4[22] | Touche de fonction Shift+F10 : Accès au deuxième programme externe paramétrable (O/N, N par défaut)
A4[25] | Touche de fonction Control+Shift+F1 : Accès au rafraîchissement de la visualisation (O/N, N par défaut)
A4[43] | Touche de fonction Control+J : Accès au lancement des programmes paramétrable (O/N, N par défaut)
A4[46] | Touche de fonction Control+N : Accès à la saisie des notes O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)
A4[48] | Touche de fonction Control+P : Accès à la saisie des notes de vérification/suppression (notes de type SUP) O Accès en consultation uniquement M Accès en modification N Pas d'accès (par défaut)

Notes

PARAM_SAISIE_PAR01 | 21,26 Type et code du paramètre de lancement de la saisie des types de paramètres
_SUP_REQ_NOTES | 21,60 Complément de sélection sur la table des notes sur types de paramètres
_SUP_REQ_PAR01 | 21,60 Complément de sélection sur la table des types de paramètres

Notes commençant par O : Ordres de tris disponibles

Tri par défaut : 01, 02, 03, 04, 05

01 | Type paramètre (par01)
02 | Libellé paramètre (par01)
03 | Catégorie paramètre (par01)
04 | Type de note (notes)
05 | Numéro de ligne de note (notes)

Zones accessibles

using - Voir #VI


v_picking_palette Visualisation des pickings palette

Ce programme est opérationnel à partir de la V. 4.1.46.2

Permet de visualiser les pickings de palettes et les tables associées (bon de livraison, commande, produit, etc.)

Remarques :

• Cette visualisation peut être appelée via des arguments (voir ci-dessous)

• Pour le moment, seule l'origine BLV (bon de livraison) est gérée :

o Le remplissage de la table des pickings de palettes se fait lors de l'édition définitive des BL (ou lors de la réédition si aucun picking de palette n'a encore été enregistré sur le BL)

o Le remplissage de cette table est lié à l'option payante LIV/9.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N_BLV | Bon de livraison -N_BLV[b1_blv] Ligne de bon de livraison -N_BLV[b2_blv|-|b2_lig+&&&]
-N_CDE | Numéro de commande livrée -N_CDE[ec_num] Numéro de ligne de commande livrée -N_CDE[lc_num|-|lc_lig+&&&] Numéro de séquence de commande livrée -N_CDE[nc_num|-|nc_lig+&&&|-|nc_seq+&&&]
-N_LOT | Numéro de commande de picking -N_LOT[ec_num] Numéro de ligne de commande de picking -N_LOT[lc_num|-|lc_lig+&&&]
-N_OF | Numéro de commande de fabrication -N_OF[ec_num] Numéro de ligne de commande de fabrication -N_OF[lc_num|-|lc_lig+&&&]

ATTENTION : Le formatage des numéros de lignes (+&&&) est obligatoire pour l'appel via argument.

Options

Orv | Réactualisation de la visualisation autorisée
Otm | Suppression de la ligne de totalisation multi-lignes
Oxd | Cacher le cadre Détail
Oxs | Ne pas passer par l'écran de sélection

Valeur alpha 2

A2[2] | Ouverture de la fenêtre de tri (O/N, N par défaut)
A2[3] | Edition sans les lignes de détails si rupture et cumul (O/N, N par défaut)
A2[5] | En mode édition, afficher aussi les critères saisies par les compléments de requête standard de la visualisation (note commençant par S) (O/N, N par défaut)
A2[8] | Lancement de la visualisation sans écran de sélection (O/N, N par défaut)
A2[10] | Mode de visualisation par défaut E Edition F Fichier V Visualisation X Excel

Valeur alpha 3

A3[1,60]

Titre général de la visualisation

Valeur alpha 4

A4[25]

Activation de la combinaison de touche F25 (Control-Shift-F1)

Réactualisation de la visualisation

Notes

S | Complément de sélection général - Tables utilisables : picking_palette Picking des palettes blv1 Bon de livraison blv2 Ligne de bon de livraison cde1 Commande livrée cde2 Ligne de commande livrée ATTENTION : les zones liées aux commandes doivent obligatoirement être préfixées avec le nom de la table correspondante. Exemples and cde1.ec_tyc = 'CD2' and cde2.lc_prod like 'P%'
_SUP_SQL_CDE1_LOT | Complément de sélection sur la table des commandes utilisées pour le picking (lot) (cde1) ATTENTION : les zones doivent obligatoirement être préfixées avec l'alias cde1_lot. Exemple and cde1_lot.ec_tyc = 'CD2'
_SUP_SQL_CDE2_LOT | Complément de sélection sur la table des lignes de commandes utilisées pour le picking (lot) (cde2) ATTENTION : les zones doivent obligatoirement être préfixées avec l'alias cde2_lot. Exemple and cde2_lot.lc_prod like 'R%'
_SUP_SQL_CDE1_OF | Complément de sélection sur la table des commandes de fabrication (OF) (cde1) ATTENTION : les zones doivent obligatoirement être préfixées avec l'alias cde1_of. Exemple and cde1_of.ec_tyc in ('FBI', 'FB2')
_SUP_SQL_CDE2_OF | Complément de sélection sur la table des lignes de commandes de fabrication (OF) (cde2) ATTENTION : les zones doivent obligatoirement être préfixées avec l'alias cde2_of. Exemple and cde2_of.lc_prod like 'P%'
_SUP_SQL_F7_CDE1 | Complément de sélection sur la table des commandes (cde1) pour la recherche du numéro de commande dans l'écran de sélection (F7)
_SUP_SQL_F7_CDE1_LOT | Complément de sélection sur la table des commandes (cde1) pour la recherche du numéro de commande utilisée pour le picking (lot) dans l'écran de sélection (F7)
_SUP_SQL_F7_CDE1_OF | Complément de sélection sur la table des commandes (cde1) pour la recherche du numéro de commande de fabrication (OF) dans l'écran de sélection (F7)

Ordres de tri disponibles (notes commençant par O)

1 | Origine (BLV)
2 | Numéro d'origine (Numéro de BL)
3 | Ligne d'origine (Ligne de BL)
4 | Ligne de picking
5 | Numéro de commande pickée (Lot)
6 | Ligne de commande pickée (Lot)
7 | Numéro de commande de fabrication (OF)
8 | Ligne de commande de fabrication (OF)
9 | Lieu de rangement 1
10 | Lieu de rangement 2
11 | Lieu de rangement 3
12 | Code article livré

Noms de zones autorisés

Toutes les zones des packages suivants :

Les zones numériques sont cumulables et/ou utilisables dans des formules de calcul.

Package | Préfixe | Description
picking_palette | pp_ | Picking de palette
blv1 | b1_ | Entête du bon de livraison associé au picking
blv2 | b2_ | Ligne du bon de livraison associé au picking
cde1 | ec_ | Entête de la commande associée à la ligne du BL
cde2 | lc_ | Ligne de la commande associée à la ligne du BL
cde4 | nc_ | Séquence de la commande associée à la ligne du BL
mat | mp_ | Article associé à la ligne ou séquence de la commande
cde1 (lot) | lot_ec_ | Entête de la commande pickée (lot) associée au picking
 | des_lot_ec_ | Description d'une zone
 | libc_lot_ec_ | Libellé court d'un paramètre
 | libl_lot_ec_ | Libellé long d'un paramètre
cde2 (lot) | lot_lc_ | Ligne de la commande pickée (lot) associée au picking
 | des_lot_lc_ | Description d'une zone
 | libc_lot_lc_ | Libellé court d'un paramètre
 | libl_lot_lc_ | Libellé long d'un paramètre
cde1 (OF) | of_ec_ | Entête de la commande de fabrication (OF) associée au picking
 | des_of_ec_ | Description d'une zone
 | libc_of_ec_ | Libellé court d'un paramètre
 | libl_of_ec_ | Libellé long d'un paramètre
cde2 (OF) | of_lc_ | Ligne de la commande de fabrication (OF) associée au picking
 | des_of_lc_ | Description d'une zone
 | libc_of_lc_ | Libellé court d'un paramètre
 | libl_of_lc_ | Libellé long d'un paramètre

Voir aussi

Edition des BL | note _SUP_SQL_STK0_PICK
Batch de réactualisation des coûts | Valeur numérique 1 = 5 : Cumul des coûts des ordres de fabrication ayant participé à la livraison


v_sbi Visualisation des factures SBI

Valeurs alpha [image] Tri [image] Noms de zones autorisés

Valeur alpha 2

Caractère 1 | Second écran de sélection (N)
Caractère 2 | Choix de l'ordre du tri (O/N)
Caractère 3 | Pas d'édition des lignes détail (O/N)
Caractère 13 | Possibilité d'accéder directement au sous-menu E d'édition F d'édition dans un fichier
Caractères 15 à 17 | Longueur de la ligne éditable. Sert uniquement dans l'édition. Par défaut 350. Permet d'éditer une même ligne sur plusieurs lignes.
Caractère 30 | Édition d'un entête société (O/N)

Valeur alpha 3

Titre de la visualisation

VISUALISATION DES FACTURES SBI

Ordres de tris disponibles

Voir les notes commençant par O

1 | Code client
2 | Numéro de facture SBI
3 | Numéro de BL
4 | Numéro de ligne de BL

Liste des noms de zones autorisés

Les noms de zones soulignés peuvent être utilisés dans les formules de calcul paramétrables.

Entête de facture SBI

Ligne de facture SBI

Fiche tiers

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Entête commande

Ligne commande

Champs calculés

Entête du BL

using - Voir #VI

Entête de facture SBI

sb_soc | Code société
sb_code_client | Code client
sb_no_facture | Numéro facture SBI
sb_date_facture | Date de la facture
sb_en_attente | Facture en attente
sb_devise | Devise de la facture
sb_montant_ht | Montant hors taxes
sb_montant_tva | Montant de la TVA
sb_montant_ttc | Montant TTC
sb_ecart_ht | Ecart hors taxes
sb_annule | Facture annulée
sv_simulation | Simulation (O/N)

Ligne de facture SBI

lb_soc | Code société
lb_blv | Numéro de BL
lb_lbl | Numéro de ligne de BL
lb_qte_livre | Quantité livrée
lb_qte_a_facturer | Quantité à facturer
lb_prix_uni | Prix unitaire
lb_prix_uni_mod | Prix unitaire
lb_conforme | Ligne conforme
lb_annule | Ligne annulée

Fiche tiers

Toutes les zones du package Tiers ainsi que les zones suivantes :

ville_cl_adra | Ville adresse réception
ville_cl_adrb | Ville adresse livraison
ville_cl_adrd | Ville adresse offres de prix
ville_cl_adrf | Ville adresse facturation

Entête commande

ec_soc | Code société
ec_num | Numéro commande
ec_cli | Code client
nom_ec_cli | Nom client
ec_ref | Référence commande
ec_cderat | Numéro dossier rattachement
ec_tyc | Type commande
libc_ec_tyc | Libellé court type commande
libl_ec_tyc | Libellé long type commande
ec_c1 | Code zone paramétrable
libc_ec_c1 | Libellé court zone paramétrable
libl_ec_c1 | Libellé long zone paramétrable
ec_datc | Date commande
ec_ada | Code adresse réception
ville_ec_ada | Ville adresse réception
ec_adf | Code adresse facturation
ville_ec_adf | Ville adresse facturation
ec_adl | Code adresse livraison
ville_ec_adl | Ville adresse livraison
ec_mrg | Mode règlement
libc_ec_mrg | Libellé court mode règlement
libl_ec_mrg | Libellé long mode règlement
ec_ech | Code échéance
libc_ec_ech | Libellé court code échéance
libl_ec_ech | Libellé long code échéance
ec_rem | Remise globale (en %)
ec_esc | Escompte (en %)
ec_acc | Acompte dans la devise de la société
ec_acc_euro | Acompte dans la devise EUROS
ec_acc_dev | Acompte dans la devise de la commande
ec_pnt | Port non taxable dans la devise de la société
ec_pnt_euro | Port non taxable dans la devise EUROS
ec_pnt_dev | Port non taxable dans la devise de la commande
ec_pht | Port taxable dans la devise de la société
ec_pht_euro | Port taxable dans la devise EUROS
ec_pht_dev | Port taxable dans la devise de la commande
ec_tvap | Code TVA port taxable
libc_ec_tvap | Libellé court code TVA port taxable
libl_ec_tvap | Libellé long code TVA port taxable
zc1_ec_tvap | Valeur 1 code TVA port taxable
ec_tport | Type de port
libc_ec_tport | Libellé court type de port
libl_ec_tport | Libellé long type de port
ec_trsp | Mode de transport
libc_ec_trsp | Libellé court mode de transport
libl_ec_trsp | Libellé long mode de transport
ec_transp | Code transporteur
nom_ec_transp | Nom transporteur
ec_tour | Code tournée
libc_ec_tour | Libellé court code tournée
libl_ec_tour | Libellé long code tournée
ec_ct | Code tarif
libc_ec_ct | Libellé court code tarif
libl_ec_ct | Libellé long code tarif
ec_cr | Code remise
libc_ec_cr | Libellé court code remise
libl_ec_cr | Libellé long code remise
ec_exp | Code exportation
ec_suiv | Code suivi affaire
libc_ec_suiv | Libellé court code suivi affaire
libl_ec_suiv | Libellé long code suivi affaire
ec_rep | Code représentant
libc_ec_rep | Libellé court code représentant
libl_ec_rep | Libellé long code représentant
ec_trep | Taux commission représentant
ec_fab | En fabrication
ec_sold | Commande soldée
ec_pro | Proforma
ec_prx | Demande de prix
ec_conf | Fiche de conformité
ec_ar | Accuse de réception à éditer
ec_oe | Ordre d'exécution à éditer
ec_fact | Reste des factures à éditer
ec_bl | Reste des BL à éditer
ec_portf | Port facture
ec_ord | Numéro ordre
ec_texte | Libellé commande
ec_rstafa | Reste à facturer
ec_poids | Poids total commande
ec_date_client | Date client commande
ec_afacturer | Commande à facturer
ec_corres | Nom correspondant
ec_titre | Titre correspondant
libc_ec_titre | Libellé court titre correspondant
libl_ec_titre | Libellé long titre correspondant
ec_fadavo | Facture - avoir
ec_issue_de | Origine commande
ec_type_liaison | Type liaison
libc_ec_type_liaison | Libellé court type liaison
libl_ec_type_liaison | Libellé long type liaison
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_devise | Code devise
libc_ec_devise | Libellé court code devise
libl_ec_devise | Libellé long code devise
ec_annu | Commande annulée
ec_date | Date enregistrement commande

Ligne commande

lc_soc | Code société
lc_num | Numéro commande
lc_lig | Numéro ligne commande
lc_prod | Code article
lib_lc_prod | Désignation article (fiche article)
lc_fam | Code famille
libc_lc_fam | Libellé court code famille
libl_lc_fam | Libellé long code famille
lc_sfm | Code sous-famille
libc_lc_sfm | Libellé court code sous-famille
libl_lc_sfm | Libellé long code sous-famille
type_sfm_lc_sfm | Type de sous famille de la sous famille de la ligne de commande
lc_lib | Désignation article (ligne commande)
lc_repr | Code représentant
libc_lc_repr | Libellé court code représentant
libl_lc_repr | Libellé long code représentant
lc_com | Taux commission représentant
lc_long | Longueur
lc_larg | Largeur
lc_dev | Numéro devis
lc_sdev | Numéro sous-devis
lc_cderat | Numéro dossier rattachement
lc_lcderat | Numéro ligne dossier rattachement
lc_qtecde | Quantité commandée
lc_qtelan | Quantité lancée
lc_qtefab | Quantité fabriquée
lc_qteliv | Quantité livrée facturable
lc_qteliv_2 | Quantité réellement livrée (non utilisée)
lc_qteafa | Quantité a facturer
lc_qtefac | Quantité facturée
lc_solde | Ligne commande soldée
lc_prx | Prix unitaire vente dans la devise de la société
lc_prx_euro | Prix unitaire vente dans la devise EUROS
lc_prx_dev | Prix unitaire vente dans la devise de la commande
lc_rem | Remise ligne (en %)
lc_p1 | Code zone paramétrable 1
libc_lc_p1 | Libellé court zone paramétrable 1
libl_lc_p1 | Libellé long zone paramétrable 1
lc_p2 | Code zone paramétrable 2
libc_lc_p2 | Libellé court zone paramétrable 2
libl_lc_p2 | Libellé long zone paramétrable 2
lc_p3 | Code zone paramétrable 3
lib_lc_p3 | Libellé zone paramétrable 3
lc_unvent | Code unité vente
libc_lc_unvent | Libellé court code unité vente
libl_lc_unvent | Libellé long code unité vente
zc1_lc_unvent | Valeur 1 code unité vente
lc_tva | Code TVA
libc_lc_tva | Libellé court code TVA
libl_lc_tva | Libellé long code TVA
zc1_lc_tva | Valeur 1 code TVA
lc_poids | Poids ligne commande
lc_delcli | Date de livraison souhaitée
lc_delcli_aass | Semaine de livraison souhaitée (format 9724)
lc_delrep | Date de livraison proposée
lc_delrep_aass | Semaine de livraison proposée (format 9724)
lc_deldep | Date de départ au plus tard
lc_deldep_aass | Semaine de départ au plus tard (format 9724)
lc_deldep_au_plus_tot | Date de départ au plus tôt Ajout de la valeur 1 du paramètre <QAL><lc_qualif_appel> à la date de départ au plus tard (lc_deldep)
lc_delfab | Date de fin de fabrication
lc_delfab_aass | Semaine de fin de fabrication (format 9724)
lc_delrea | Date de réalisation (non utilisée)
lc_delrea_aass | Semaine de réalisation (format 9724)
lc_colis | Nombre colis
lc_prxcli | Prix client dans la devise de la société
lc_date_gener | Date de génération (pour les commandes générables)
lc_date_regener | Date de régénération (pour les commandes générables)
lc_prxcli_euro | Prix client dans la devise EUROS
lc_prxcli_dev | Prix client dans la devise de la commande
lc_rstfac | Reste des factures à éditer
lc_rstbl | Reste des BL à éditer
lc_nummvt | Numéro mouvement de stock 1
lc_priorité | Niveau priorité ligne commande
libc_lc_priorite | Libellé court niveau priorité ligne commande
libl_lc_priorite | Libellé long niveau priorité ligne commande
lc_rstafa | Reste à facturer
lc_rstfab | Reste à fabriquer
lc_adl | Code adresse livraison
ville_lc_adl | Ville adresse livraison
lc_haut | Hauteur
lc_afacturer | Ligne commande à facturer
lc_nummvt2 | Numéro mouvement de stock 2
lc_par_tyc | Code paramètre type de commande
libc_lc_par_tyc | Libellé court code paramètre type de commande
libl_lc_par_tyc | Libellé long code paramètre type de commande
lc_lot | Numéro de lot de la ligne de commande
lc_qualif_appel | Qualification de l'appel de livraison
libc_lc_qualif_appel | Libellé court qualification de l'appel de livraison
libl_lc_qualif_appel | Libellé long qualification de l'appel de livraison
lc_facrat | Numéro facture rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_unvent_au | Code unité vente au
libc_lc_unvent_au | Libellé court code unité vente au
libl_lc_unvent_au | Libellé long code unité vente au
zc1_lc_unvent_au | Valeur 1 code unité vente au
lc_prx_au_plus | Prix unitaire vente au plus dans la devise de la société
lc_prx_plus_euro | Prix unitaire vente au plus dans la devise EUROS
lc_prx_plus_dev | Prix unitaire vente au plus dans la devise de la commande
lc_prx_au_moins | Prix unitaire vente au moins dans la devise de la société
lc_prx_moins_euro | Prix unitaire vente au moins dans la devise EUROS
lc_prx_moins_dev | Prix unitaire vente au moins dans la devise de la commande
lc_marge | Pourcentage marge
lc_prx_revient | Prix unitaire revient dans la devise de la société
lc_prx_rvt_euro | Prix unitaire revient dans la devise EUROS
lc_prx_rvt_dev | Prix unitaire revient dans la devise de la commande
lc_tolerance_liv | Code tolérance livraison
libc_lc_tolerance_liv | Libellé court code tolérance livraison
libl_lc_tolerance_liv | Libellé long code tolérance livraison
lc_prx_rvt_reel | Prix unitaire revient réel dans la devise de la société
lc_prx_rvt_r_euro | Prix unitaire revient réel dans la devise EUROS
lc_date_solde | Date de solde de la ligne de commande
lc_lieu_rgt1 | Code lieu de rangement 1 Fenêtre revue de contrat
libc_lc_lieu_rgt1 | Libellé court code lieu de rangement 1
libl_lc_lieu_rgt1 | Libellé long code lieu de rangement 1
lc_annu | Ligne commande annulée
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Champs calculés

ht_ligne | Montant HT calculé de la ligne de facture
tva_ligne | Montant TVA calculé de la ligne de facture

Entête du BL

b1_ref

Référence du bon de livraison


v_suivi_vehicules Suivi des entrées / sorties de camions

Ce programme est opérationnel à partir de la V. 4.1.13.2

Programme de saisie des entrées / sorties : suivi_vehicules

Notes

CLIPPED_LIGNE_EF | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
SEP_VISU_TYPE_F_CHAR | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
TEXT_LIBRE_1_V_T_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.
TITRE_VISU_TYPE_F | Cette note fait partie d'un ensemble de notes pour l'export dans un fichier.

Noms de zones autorisés

suiv_vehicule | Voir le package
groupage_bl | Voir le package
b_rec_ret_e | Voir le package
b_rec_ret_d | Voir le package


v_tarifs_transp Visualisation des tarifs transporteurs

Visualisation des tarifs transporteurs, avec ou sans transfert Excel.

Permet de visualiser tous les tarifs selon des critères de saisie.

Les 13 premières colonnes sont figées. Les autres dépendront de l'unité de recherche demandée.

La visualisation oblige à préciser l'unité de recherche. Une seule unité est autorisée par visu.

Le transfert direct sous Excel permet de sélectionner toutes les unités de recherches paramétrées.

Un fichier Excel est créé par unité de recherche.

Si l'utilisateur ne veut voir qu'un seul fichier Excel (correspondant à une seule unité de recherche), il suffit de passer par la visualisation, puis de cliquer sur le bouton Excel.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code transporteur

Exemple : -N[ec_transp]

Options

Osk

Saisie kilométrique sur ligne de tarif

Avant, un tarif ayant des bornes kilométriques de saisie était considéré comme un tarif "au kilomètre".

Avec la nouvelle option, on désactive ce principe.

Si, sur la ligne de tarif, l'unité est le forfait et que sur l'éventuelle grille de pourcentage rattachée, l'unité est différente du kilomètre, alors, on considère l'unité de la ligne de tarif comme différente du km (ou égale à l'unité de la grille de pourcentage rattachée).

Exemple : Ligne1 du tarif A, de 1 à 100KM, Forfaitaire avec grille G.

Si l'unité de la grille G est le ML, alors la ligne 1 du tarif A sera au ML.

Valeur alpha 2

A2[2]

Choix de l'ordre de tri (O/N, N par défaut)

Notes

RUN_TARIFS_TRANSP | 21,26 Type et code du paramètre de lancement de la saisie des tarifs transporteurs
_SUP_REQ_TTD | 21,60 Complément de requête sur la table tarif_transp_lig
_SUP_REQ_TTE | 21,60 Complément de requête sur la table tarif_transp_ent

Paramètres nécessaires

UNI A1[9] | Rappel G unité générique (ou au forfait) K unité au kilomètre
UNI A1[20] | Rappel : Camion complet (O/N)
UNI A1[22] | Unité de recherche pour la visualisation (ex : ML, KM ou PAL) (O/N)
UNI | Notes TIT_V_TARIFS_TRANSP et INFO_V_TARIFS_TRANSP

Zones accessibles

using - Voir #VI


v_tracabilite Visualisation de la traçabilité

mp_ref_kp_ Article pour la référence d'ensemble

mp_ref_arc Référence d'architecture

mp_ref_imp Référence d'impression

mp_ref_pre Référence de pré-impression

mp_pap_pre Référence de papier pré-impression

mp_pf Produit fini

mp_qua_car Référence qualité carton

mp_com_car Référence composition carton

mp_pal Référence article palette

mp_coiffe Article coiffe

Dans les notes du paramètre de lancement du devis onduleur:

LCT_PROG_PARAM_01 #VITPR+CRIT_CHAR_[%|mp_ref_kp_code+S2

LCT_PROG_PARAM_01 |%]

Dans les notes du paramètre de lancement de la visualisation de la traçabilité (#VI TRP) :

-Oxdxs

# On ne prend que les événements de modification

S and te_evenement = 2

# On ne prend que les événements de traça. liés aux articles

# (Table mat et info_c)

S and te_num_table in (4, 14)

# Pour le test, on demande àl'utilisateur de saisir

# le code de l'ensemble entouré par des "*"

# Cette partie sera à automatiser via développement

# complémentaire

S and te_cle_alpha _CRIT_CHAR_1

_CRIT_CHAR_1 C OCode Ensembles sans le R (*CODE_ENS*)

V Clé*te_cle_alpha*15**N*N*

V Utilisateur*nom_te_login*20**N*N*

V Date*date_te_date_heure*10*dd/mm/yyyy*N*N*

V Heure*heure_te_date_heure*5*#&.&&*N*N*

V Champ*td_nom_champ*20**N*N*

V Clair*nom_td_nom_champ*60**N*N*

V Avant*td_valeur_avant*40**N*N*

V Après*td_valeur_apres*40**N*N*

Visualisation de la traçabilité v_tracabilite

Ce module permet de visualiser les tables de traçabilité (tables tracabilite_e et tracabilite_d).

La configuration de la traçabilité se fait dans #CF TRA.

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : code article

Exemple : -N[mp_code+C15]

P lus de détail

Options

Oxd | Cacher le cadre détail des visualisations Plus d'info dans l'aide du #VI
Oxs | Ne pas passer par l'écran de sélection Plus d'info dans l'aide du #VI

Valeur alpha 2

A2[1] | Second écran de sélection (O/N, N par défaut)
A2[2] | Choix de l'ordre du tri (O/N, N par défaut)
A2[3] | Pas d'édition des lignes détail (O/N, N par défaut)
A2[8] | Lancement de la visualisation sans écran de sélection (O/N, N par défaut)
A2[10] | Mode de visualisation E Edition F Fichier V Mode écran X Mode Excel
A2[11,13] | Longueur de la ligne éditable Sert uniquement dans l'édition Permet d'éditer une même ligne sur plusieurs lignes Par défaut 1000
A2[31,33] | Type paramètre de la zone Catégorie Tiers (tr_cat) de la table tar0 CAT par défaut Mettre adr pour un code adresse de tiers au lieu d'un code paramètre. Utilisé pour la visualisation de la table tar0 (te_num_table = 38)
A2[34,39] | Type et code paramètre de la configuration de la saisie des tarifs en tableau paramétrable. A blanc par défaut. Ceux-ci sont utilisés pour récupérer le type paramètre de la zone Rubrique Paramétrable (tr_char) de la table tar0 (A3[45,47]) Utilisé pour la visualisation de la table tar0 (te_num_table = 38)

Valeur alpha 3

A3[1,30]

Titre de la visualisation

T R A C A B I L I T E

Valeur alpha 4

A4[5] | Touche F5 (O/N) Rafraîchissement de la visualisation Voir la note TPS_AVANT_RAFRAICHIR
A4[8] | Touche F8 (O/N) Affichage du détail de la traçabilité
A4[38] | Touche CONTROL-C (O/N) Calculatrice
A4[46] | Accès aux notes sur la traçabilité O Accès en consultation uniquement M Accès en modification N Accès interdit (par défaut) Les notes sont au format texte et sont enregistrées dans la table notes_formatees Le type de clé est t. La clé est le numéro de série d'entête de traçabilité (tracabilite_e.te_serial)
A4[51] | Touche CONTROL-T (O/N) Visualisation des touches
A4[56] | Touche CONTROL-Z (O/N) Lancement de programmes

Notes

_CRIT_DATT_

Événements sur les OT depuis le dernier rechargement du tableau des affrètements

12 Identifiant de la variable datetime

15 Type de saisie

C Saisie évoluée (valeur par défaut)

U Saisie d'un datetime précis

19 Saisie obligatoire

N Si valeur non renseignée, le critère sera is null (valeur par défaut)

O Obligation de saisir une date

21,60 Question posée à l'utilisateur dans la fenêtre

Voir la note PARAM_CONSULT_TRACE dans prep_affret.

LCT_PROG_CONFIG

LCT_PROG_PARAM_

LCT_PROG_TITRE_

LCT_PROG_IMAGE_

21,26 Type et code du paramètre de configuration de lancement de programmes (#RPxxx)

La note LCT_PROG_CONFIG est prioritaire (les autres lignes commençant par LCT_ sont alors ignorées).

Plus de détail dans le #RP

Le paramètre +CRIT_CHAR_[nomduchamp] permet d'avoir toutes les données qui ressemblent au contenu du champ de la table concernée en y concaténant un ‘%' (voir exemple ci-dessous, cela équivaut à traduire par un like 'contenudunomduchamp%').

Exemple

LCT_PROG_PARAM_02 #VITPR+CRIT_CHAR_[mp_code]|%

La ligne ci-dessus sera traduite par :

like '(contenu mp_code)%'

Pour rappel, dans les noms des champs, si l'on met un + cela correspond à l'appel d'un using.

Ce dernier a été complété par les deux modes suivants :

1) Le caractère +Cx (où x est un nombre) indique que le champ réservera au minimum x caractères dans la clé.

Exemple

LCT_PROG_PARAM_02 #VITPR -N[mp_code+C15]

Si le contenu de mp_code = 'ART4569', la clé sera 'ART4569 '

2) Le caractère +Sx-y (où x et y sont des nombres) équivaut à un substring, c'est-à-dire, on conserve la zone de caractères que l'on souhaite utiliser.

x : début de chaîne (obligatoire)

y : fin de chaîne (n'est pas obligatoire, par défaut sa valeur est sans limite)

Exemples

Dans les exemples ci-dessous, on considèrera « ART12345678 » est le contenu de mp_code. La chaîne fait 11 caractères et elle commence de 1 à 11.

1er exemple

LCT_PROG_PARAM_02 #VITPR-N[mp_code+S4]

La clé sera '12345678'

2ème exemple

LCT_PROG_PARAM_02 #VITPR-N[mp_code+S4-8]

La clé sera '12345'

3ème exemple

LCT_PROG_PARAM_02 #VITPR-N[mp_code+S1-8]

La clé sera 'ART12345'

Paramétrage d'un paramètre sur plusieurs lignes :

Selon la complexité de la clé avec l'utilisation d'un ou des using, le paramètre de la clé peut ne pas tenir sur une seule ligne. Voici un exemple pour paramétrer sur plusieurs lignes :

1 2 3 4 5 6

123456789012345678901234567890123456789012345678901234567890

LCT_PROG_PARAM_01 #VITPR+CRIT_CHAR_[%|mp_ref_kp_code+S2

LCT_PROG_PARAM_01 |%]

Nota : la suite de la chaîne du paramétrage doit débuter en 27. La dernière ligne devra comporter le crochet fermant (]).

Les champs accessibles sont les suivants.

Exemple de paramétrage en partant du devis onduleur

TPS_AVANT_RAFRAICHIR

21,25 Temps d'inactivité avant rafraîchissement

0 pas de rafraîchissement

Valeur minimum : 10 secondes

Voir A4[5]

Ordres de tri disponibles

01 | tab_tra | Tri sur numéro de la table
02 | alp_tra | Tri sur clé alphanumérique
03 | num_tra | Tri sur clé numérique
04 | eve_tra | Tri sur code événement
05 | d_h_tra | Tri sur date et heure
06 | log_tra | Tri sur login
07 | chp_tra | Tri sur nom du champ

Liste des zones disponibles

Les zones sont triées par ordre alphabétique.

Package Matières/Articles/Produits : les noms de zones sont précédés de x_ où x peut prendre les valeurs de 1 à 5.

Package Tiers

Matières

Tarifs

Récapitulatif des Coûts

On peut tracer les appels de programmes par le biais de la touche CONTROL-U dans par02.

Cette traçabilité porte sur la table 28 (appel des programmes). Il s'agit d'une table fictive.

Dans le détail de traçabilité, la zone valeur_avant contient la date et l'heure de lancement, la zone valeur_après contient la date et l'heure de fin de traitement.

La zone temps_traitement contient le temps de traitement exprimé en heures :minutes :secondes

Cette zone peut-être totalisée.

Traçabilité entête (traçabilite_e)

te_alerte | Code alerte (A/T/I)
te_cle_alpha | Clé alphanumérique de l'événement
te_cle_num | Clé numérique de l'événement
te_code_par_lct | Code de paramètre de lancement
date_te_date_heure | Date de l'événement
heure_te_date_heure | Heure de l'événement
te_evenement libelle_te_evenement | Code de l'événement (1 à 5) Libellé de l'événement
te_login nom_te_login | Login de l'événement Nom du login de l'événement
te_num_table nom_te_num_table | Numéro de la table (01 à 38) Nom de la table
te_serial | Numéro de serial
te_soc | Code société
te_transfere | Code transfert (O/N)
te_type_par_lct | Type de paramètre de lancement

Traçabilité détail (traçabilite_d)

td_nom_champ nom_td_nom_champ | Nom du champ Nom du champ en clair
td_serial | Numéro de serial
td_valeur_apres | Valeur du champ après
td_valeur_avant | Valeur du champ avant

Entêtes des commandes clients (cde1)

ec_acc | Acompte dans la devise de la société
ec_acc_dev | Acompte dans la devise de la commande
ec_acc_euro | Acompte dans la devise EURO
ec_ada nom_ec_ada codp_ec_ada ville_ec_ada pays_ec_ada libc_pays_ec_ada libl_pays_ec_ada | Code adresse de réception Nom Code postal Ville Pays Libellé court pays Libellé long pays
ec_adf nom_ec_adf codp_ec_adf ville_ec_adf pays_ec_adf libc_pays_ec_adf libl_pays_ec_adf | Code adresse de facturation Nom Code postal Ville Pays Libellé court pays Libellé long pays
ec_adl nom_ec_adl codp_ec_adl ville_ec_adl pays_ec_adl libc_pays_ec_adl libl_pays_ec_adl | Code adresse de livraison Nom Code postal Ville Pays Libellé court pays Libellé long pays
ec_afacturer | Commande à facturer
ec_annu | Commande annulée
ec_ar | Accusé de réception à éditer
ec_bl | Reste des BL à éditer
ec_c1 libc_ec_c1 libl_ec_c1 | Code zone paramétrable Libellé court Libellé long
ec_cderat | Numéro dossier rattachement
ec_cli nom_ec_cli | Code client Nom client
ec_conf | Fiche de conformité
ec_corres | Nom correspondant
ec_cr libc_ec_cr libl_ec_cr | Code remise Libellé court Libellé long
ec_ct libc_ec_ct libl_ec_ct | Code tarif Libellé court Libellé long
ec_datc | Date commande
ec_date | Date enregistrement commande
ec_date_client | Date client commande
ec_date_deb_val | Date de début de validité du contrat
ec_date_fin_val | Date de fin de validité du contrat
ec_devise libc_ec_devise libl_ec_devise | Code devise Libellé court Libellé long
ec_ech libc_ec_ech libl_ec_ech | Code échéance Libellé court Libellé long
ec_esc | Escompte (en %)
ec_exp | Code exportation
ec_fab | En fabrication
ec_fabricant libc_ec_fabricant libl_ec_fabricant | Code fabricant Libellé court Libellé long
ec_fact | Reste des factures à éditer
ec_fadavo | Facture-avoir
ec_issue_de | Origine commande
ec_mrg libc_ec_mrg libl_ec_mrg | Mode règlement Libellé court Libellé long
ec_num | Numéro commande
ec_oe | Ordre d'exécution à éditer
ec_ord | Numéro ordre
ec_pht | Port taxable dans la devise de la société
ec_pht_dev | Port taxable dans la devise de la commande
ec_pht_euro | Port taxable dans la devise EURO
ec_pnt | Port non taxable dans la devise de la société
ec_pnt_dev | Port non taxable dans la devise de la commande
ec_pnt_euro | Port non taxable dans la devise EURO
ec_poids | Poids total commande
ec_portf | Port facturé
ec_pro | Pro forma
ec_prx | Demande de prix
ec_ref | Référence commande
ec_ref_liaison | Référence liaison
ec_ref_reg_fact | Référence regroupement de facturation
ec_rem | Remise globale (en %)
ec_rep libc_ec_rep libl_ec_rep | Code représentant Libellé court Libellé long
ec_rstafa | Reste à facturer
ec_soc | Code société
ec_sold | Commande soldée
ec_suiv libc_ec_suiv libl_ec_suiv | Code suivi affaire Libellé court Libellé long
ec_texte | Libellé commande
ec_titre libc_ec_titre libl_ec_titre | Titre correspondant Libellé court Libellé long
ec_tour libc_ec_tour libl_ec_tour | Code tournée Libellé court Libellé long
ec_tport libc_ec_tport libl_ec_tport | Type de port Libellé court Libellé long
ec_transp nom_ec_transp | Code transporteur Nom transporteur
ec_trep | Taux commission représentant
ec_trsp libc_ec_trsp libl_ec_trsp | Mode de transport Libellé court Libellé long
ec_tvap libc_ec_tvap libl_ec_tvap zc1_ec_tvap | Code TVA port taxable Libellé court Libellé long Valeur 1
ec_tyc libc_ec_tyc libl_ec_tyc | Type commande Libellé court Libellé long
ec_type_liaison libc_ec_type_liaison libl_ec_type_liaison | Type liaison Libellé court Libellé long
ec_web_statut libc_ec_web_statut libl_ec_web_statut | Code statut pour les commandes WEB Libellé court Libellé long code

Lignes des commandes clients (cde2)

lc_adf nom_lc_adf codp_lc_adf ville_lc_adf pays_lc_adf libc_pays_lc_adf libl_pays_lc_adf | Code adresse de facturation Nom Code postal Ville Pays Libellé court pays Libellé long pays
lc_adl nom_lc_adl codp_lc_adl ville_lc_adl pays_lc_adl libc_pays_lc_adl libl_pays_lc_adl | Code adresse de livraison Nom Code postal Ville Pays Libellé court pays Libellé long pays
lc_afacturer | Ligne commande à facturer
lc_amalgame | Ligne d'amalgame (A/L/N)
lc_annu | Ligne commande annulée
lc_cderat | Numéro dossier rattachement
lc_colis | Nombre colis
lc_com | Taux commission représentant
lc_cs1 libc_lc_cs1 libl_lc_cs1 | Code statistique 1 Libellé court Libellé long
lc_cs2 libc_lc_cs2 libl_lc_cs2 | Code statistique 2 Libellé court Libellé long
lc_cs3 libc_lc_cs3 libl_lc_cs3 | Code statistique 3 Libellé court Libellé long
lc_cs4 libc_lc_cs4 libl_lc_cs4 | Code statistique 4 Libellé court Libellé long
lc_date_gener | Date de génération
lc_date_regener | Date de régénération
lc_date_solde | Date de solde de la ligne de commande
lc_delcli | Date de livraison souhaitée
lc_deldep | Date de départ
lc_delfab | Date de fin de fabrication
lc_delrea | Date de réalisation (Non utilisée)
lc_delrep | Date de livraison proposée
lc_dev | Numéro devis
lc_entite | Numéro entité
lc_facrat | Numéro facture rattachement
lc_fam libc_lc_fam libl_lc_fam | Code famille Libellé court Libellé long
lc_gen_bl_auto | Génération automatique des BL
lc_haut | Hauteur
lc_heure_cli_tard | Heure de livraison souhaitée au plus tard
lc_heure_cli_tot | Heure de livraison souhaitée au plus tôt
lc_heure_dep_tard | Heure de départ proposée au plus tard
lc_heure_dep_tot | Heure de départ proposée au plus tôt
lc_heure_fab_tard | Heure de fin de fabrication au plus tard
lc_heure_fab_tot | Heure de fin de fabrication au plus tôt
lc_heure_rep_tard | Heure de livraison proposée au plus tard
lc_heure_rep_tot | Heure de livraison proposée au plus tôt
lc_larg | Largeur
lc_lcderat | Numéro ligne dossier rattachement
lc_lfacrat | Numéro ligne facture rattachement
lc_lib | Désignation article (Ligne commande)
lc_lieu_rgt1 libc_lc_lieu_rgt1 libl_lc_lieu_rgt1 | Code lieu de rangement 1 Libellé court Libellé long
lc_lig | Numéro ligne commande
lc_lig_affaire | Ligne d'affaire
lc_lig_amalgame | Numéro de la ligne parente d'amalgame
lc_lig_contrat | Ligne de contrat
lc_ligne_a_epurer | Ligne à épurer
lc_long | Longueur
lc_lot | Numéro lot de la ligne de commande
lc_maj_dpl | Flag de transfert vers Direc tPlanning
lc_maj_reflex | Flag de transfert vers ReflexClient
lc_marge | Pourcentage marge
lc_mpl_prx_ini | Prix initial dans la devise de la société
lc_mpl_prx_ini_dev | Prix initial dans la devise de la commande
lc_mpl_prx_ini_eur | Prix initial dans la devise EURO
lc_mpl_qte_ini | Quantité commandée initiale
lc_num | Numéro commande
lc_num_affaire | Numéro d'affaire
lc_num_contrat | Numéro de contrat
lc_nummvt | Numéro mouvement de stock 1
lc_nummvt2 | Numéro mouvement de stock 2
lc_nummvt3 | Numéro mouvement de stock 3
lc_p1 libc_lc_p1 libl_lc_p1 | Code zone paramétrable 1 Libellé court Libellé long
lc_p2 libc_lc_p2 libl_lc_p2 | Code zone paramétrable 2 Libellé court Libellé long
lc_p3 lib_lc_p3 | Code zone paramétrable 3 Libellé zone
lc_par_tyc libc_lc_par_tyc libl_lc_par_tyc | Code paramètre type de commande Libellé court Libellé long
lc_poids | Poids ligne commande
lc_priorite libc_lc_priorite libl_lc_priorite | Niveau priorité ligne commande Libellé court Libellé long
lc_prixnet | Prix net
lc_prod lib_lc_prod | Code article Désignation article (fiche article)
lc_prx | Prix unitaire vente dans la devise de la société
lc_prx_au_moins | Prix unitaire vente au moins dans la devise de la société
lc_prx_au_plus | Prix unitaire vente au plus dans la devise de la société
lc_prx_dev | Prix unitaire vente dans la devise de la commande
lc_prx_euro | Prix unitaire vente dans la devise EURO
lc_prx_moins_dev | Prix unitaire vente au moins dans la devise de la commande
lc_prx_moins_euro | Prix unitaire vente au moins dans la devise EURO
lc_prx_plus_dev | Prix unitaire vente au plus dans la devise de la commande
lc_prx_plus_euro | Prix unitaire vente au plus dans la devise EURO
lc_prx_revient | Prix unitaire revient dans la devise de la société
lc_prx_rvt_dev | Prix unitaire revient dans la devise de la commande
lc_prx_rvt_euro | Prix unitaire revient dans la devise EURO
lc_prx_rvt_r_euro | Prix unitaire revient réel dans la devise EURO
lc_prx_rvt_reel | Prix unitaire revient réel dans la devise de la société
lc_prxcli | Prix client dans la devise de la société
lc_prxcli_dev | Prix client dans la devise de la commande
lc_prxcli_euro | Prix client dans la devise EURO
lc_qte_contrat | Quantité commandée actuelle du contrat
lc_qte_en_retour | Quantité retournée par le bon de retour
lc_qteafa | Quantité à facturer
lc_qtecde | Quantité commandée
lc_qtefab | Quantité fabriquée
lc_qtefac | Quantité facturée
lc_qtelan | Quantité lancée
lc_qteliv | Quantité livrée facturable
lc_qteliv_reelle | Quantité réellement livrée
lc_qualif_appel libc_lc_qualif_appel libl_lc_qualif_appel | Qualification de l'appel de livraison Libellé court Libellé long
lc_ref_prod_cli | Référence produit du client
lc_rem | Remise ligne (en %)
lc_repr libc_lc_repr libl_lc_repr | Code représentant Libellé court Libellé long
lc_rstafa | Reste à facturer
lc_rstbl | Reste des BL à éditer
lc_rstfab | Reste à fabriquer
lc_rstfac | Reste des factures à éditer
lc_sbi | Code Facture SBI (Self Billing Invoice)
lc_sdev | Numéro sous-devis
lc_sfm libc_lc_sfm libl_lc_sfm | Code sous-famille Libellé court Libellé long
lc_soc | Code société
lc_solde | Ligne commande soldée
lc_surface | Surface commandée
lc_tolerance_liv libc_lc_tolerance_liv libl_lc_tolerance_liv | Code tolérance livraison Libellé court Libellé long
lc_transfert_trans | Code transfert SYLOGI
lc_tva libc_lc_tva libl_lc_tva zc1_lc_tva | Code TVA Libellé court Libellé long Valeur 1
lc_unvent libc_lc_unvent libl_lc_unvent zc1_lc_unvent | Code unité vente Libellé court Libellé long Valeur 1
lc_unvent_au libc_lc_unvent_au libl_lc_unvent_au zc1_lc_unvent_au | Code unité vente au Libellé court Libellé long Valeur 1
lc_var_prod | Code variante de production
lc_variante | Numéro variante retenue lors du transfert du devis
lc_volupilot_ok | Flag indiquant si la commande a été traitée par VoluPilot
lc_motif_mod_date libc_lc_motif_mod_date libl_lc_motif_mod_date | Code motif de modification de date de la revue de contrat Libellé court Libellé long

Autres zones

using | Voir #VI
libc_prog libl_prog | Libellés court et long du paramètre de lancement
libl_tsc | Libellé long du TSC
libc_tsc | Libellé court du TSC


v_triplet Visualisation des triplets

Arguments d'appel

Ce programme peut être appelé à partir d'un autre programme, notamment dans le cadre de la touche Ctrl J (Voir #RP).

Le programme appelant peut alors passer les paramètres suivants :

-N

Caractères 3 et suivants : Code triplet (Section Opération Sous-opération)

Exemple : -N[fo_sec|fo_ope|fo_sop]

Valeur alpha 2

Caractère 1

Second écran de sélection (N)

Caractère 2

Choix de l'ordre du tri (O/N)

Caractère 3

Pas d'édition des lignes détail (O/N)

Caractère 31

Type de recherche code article par F7

1 Recherche normale (désignation, famille, etc.)

2 Recherche sur les données techniques

3 Recherche spécifique papier

Caractère 32

Mode d'affichage des gammes

O Toutes les gammes utilisées sont affichées : chaque couple Produit fini/Gamme utilisable pour ce produit fait l'objet d'une ligne de visualisation.

N Seule la gamme active est affichée : seul le couple Produit fini/Gamme active pour le produit fini fait l'objet d'une ligne de visualisation (par défaut).

Valeur alpha 3

Caractère 1 à 60

Titre de la visualisation. Exemple : VISUALISATION DES TRIPLETS

Valeur alpha 4

Paramétrage des touches de fonction

Caractère 38 | Touche CONTROL-C (O/N)
Caractère 51 | Touche CONTROL-T (O/N)
Caractère 56 | Touche CONTROL-Z (O/N)

Notes

S

3,60 Critère de sélection supplémentaire

Voir aide sur #VI pour plus de détails.

Le critère de sélection peut porter sur les tables suivantes :

mat

Pour l'outillage : Remplacer mat. par mat_o. dans le préfixe des noms de zone

Pour le produit fini : Remplacer mat. par mat_p. dans le préfixe des noms de zone

info_c

Pour l'outillage : Remplacer info_c. par info_c_o. dans le préfixe des noms de zone

Pour le produit fini : Remplacer info_c. par info_c_p. dans le préfixe des noms de zone

Exemples

and mat_o.mp_rgt2 = "XXX" (lieu de rangement 2 de l'outillage égal à XXX)

and mat_p.mp_qualite != "DEV" (code validité du produit fini différent de DEV)

Ordres de tris disponibles

1 | c_out | Code Outillage
2 | c_prd | Code Produit Fini
3 | c_gam | Code Gamme
4 | n_pha | Numéro Phase
5 | c_mac | Code Machine

Liste des noms de zones autorisés

Package Matières/Articles/Produits

Affichage des champs de la fiche article de l'outillage : Préfixer le nom du champ par outil_

Affichage des champs de la fiche article du produit fini : Préfixer le nom du champ par pf_

Affichage des informations complémentaires de l'outillage : Utiliser la syntaxe :

TSC_TypeTable_Origine_CodeTSC_CodeZone

Avec :

TypeTable : MP (mat)

Origine : OU (outil)

CodeTSC : Code du TSC

CodeZone : Code de la zone

Affichage des informations complémentaires du produit fini : Utiliser la syntaxe :

TSC_TypeTable_Origine_CodeTSC_CodeZone

Avec :

TypeTable : MP (mat)

Origine : PF (produit fini)

CodeTSC : Code du TSC

CodeZone : Code de la zone

Exemples

outil_mp_rgt1 (magasin de l'outillage)

outil_libl_mp_rgt1 (libellé long du magasin de l'outillage)

TSC_MP_OU_O01_C (nombre de passes maxi de l'outillage)

pf_mp_qualite_matiere (composition du produit fini)

pf_lib_mp_qualite_matiere (libellé de la composition du produit fini)

TSC_MP_PF_071_G (numéro d'étude du produit fini)

Table des informations complémentaires

ic_soc | Code société
ic_type | Type de clé (toujours égal à T)
ic_cle | Clé
ic_ts | Type de trame de saisie
ic_date1 | 1er champ date
ic_date2 | 2ème champ date
ic_num1 | 1er champ numérique
ic_num2 | 2ème champ numérique
ic_num3 | 3ème champ numérique
ic_char3_1 | 1er champ alphanumérique
ic_char30 | 2ème champ alphanumérique
ic_char3_2 | 3ème champ alphanumérique

Table détail des gammes standards

gd_soc | Code société
gd_code_gamme | Code gamme
des_gd_code_gamme | Désignation de la gamme
gd_phase | Numéro de phase
gd_sec | Code section
gd_ope | Code opération
gd_sop | Code sous-opération
gd_dif | Code difficulté
libc_gd_dif | Libellé court code difficulté
libl_gd_dif | Libellé long code difficulté
gd_mac | Code machine
des_gd_mac | Désignation de la machine

Autres noms de zone, triés par ordre alphabétique

des_outillage | Désignation de l'outillage
des_produit_fini | Désignation du produit fini
lib_operation | Libellé de l'opération
operation | Code opération (section, opération, sous-opération)
outillage | Code outillage
outi_libc_mp_qualite | Libellé court de la validité
outi_mp_derent | Date de dernière entrée en stock de l'outillage
outi_mp_dermvt | Date du dernier mouvement de stock de l'outillage
outi_mp_dersor | Date de dernière sortie du stock de l' outillage
outi_mp_qualite | Code validité
produit_fini | Code produit fini
using | Voir #VI

Zones de la table PF

mp_code | Code du produit fini (idem produit_fini)
mp_des | Désignation du produit fini (idem des_produit_fini)
mp_gencod | Code gencod
mp_itf14 | Code ITF14
mp_derent | Date de dernière entrée en stock du produit fini
mp_dersor | Date de dernière sortie du stock du produit fini
mp_qualite | Code qualité du produit fini
libc_mp_qualite | Libellé court du code mp_qualite
libl_mp_qualite | Libellé long du code mp_qualite

Table des libellés étrangers

le_libpar1 | Référence article du client
le_libelle | Libellé spécifique
le_libelle2 | Complément au libellé spécifique

Zones de la table client attachée au PF et Zones de la fiche client attachée au produit fini

Toutes les zones du package Tiers


Using

Using (Format d'affichage)

Le mot-clé using utilisé notamment dans les programmes de visualisation permet de spécifier le format d'affichage des données.

La chaîne de formatage doit être entre guillemets.

Lorsque vous spécifiez un format d'affichage trop petit, le nombre ne peut pas s'afficher. Une série d'astérisques est affichée pour signaler le dépassement.

La chaîne de formatage peut comprendre les codes suivants :

*

astérisque

Les zéros non significatifs sont remplacés par des astérisques (inutilisable dans les visus)

&

et commercial

Affiche les zéros non significatifs

#

dièse

N'affiche pas les zéros non significatifs

espace

Affiche l'espace (généralement utilisé comme séparateur de milliers)

.

point

Affiche le séparateur décimal (point ou virgule selon votre configuration)

-

moins

Affiche le signe moins si le nombre est négatif.

Si vous mettez plusieurs signes moins sur une ligne, le signe sera cadré à droite juste avant le nombre.

+

plus

Affiche le signe plus si le nombre est supérieur ou égal à zéro. Affiche le signe moins si le nombre est négatif.

Si vous mettez plusieurs signes plus sur une ligne, le signe sera cadré à droite juste avant le nombre.

<

inférieur

Les nombres sont cadrés à gauche

dd

Jour du mois sous forme de 2 chiffres (01 à 31)

ddd

Jour de la semaine sous forme d'une abréviation à 3 lettres (en Anglais)

mm

Mois sous forme de 2 chiffres (01 à 12)

mmm

Mois sous forme d'une abréviation à 3 lettres (en Anglais)

yy

Année sous forme de 2 chiffres (00 à 99)

yyyy

Année sous forme de 4 chiffres (0000 à 9999)

Exemples d'affichage de dates

La date affichée est le 28 juillet 2005.

ddmmyy | 280705
mmddyy | 072805
yymmdd | 050728
dd/mm/yyyy | 28/07/2005
dd-mm-yy | 28-07-05
ddd dd mmm yyyy | Thu 28 Jul 2005

Exemples d'affichage de nombres

Format/Nombre | 12345,67 | 1234,56 | 123,45 | -123,45 | 1.00 | 0
*****.** | 12345,67 | *1234,56 | **123,45 | **123,45 | ****1,00 | *****,**
&&&&&.&& | 12345,67 | 01234,56 | 00123,45 | 00123,45 | 00001,00 | 00000,00
#####.## | 12345,67 | 1234,56 | 123,45 | 123,45 | 1,00 |
## ###.## | 12 345,67 | 1 234,56 | 123,45 | 123,45 | 1,00 |
-- ---.## | dépassement | 1 234,56 | 123,45 | - 123,45 | 1,00 | 0,00
++ +++.## | dépassement | +1 234,56 | + 123,45 | - 123,45 | +1,00 | +0,00
<<<<<.<< | 12345,67 | 1234,56 | 123,45 | 123,45 | 1,00 | 0,00


#XX Tous paramètres de configuration

Lors de l'appel à l'aide Windows par F5, il permet de substituer un paramètre standard à un paramètre utilisateur.

Notes

EQUIVALENCE_AIDE

21,26 Type et code du paramètre à afficher dans l'aide Windows.

Exemple si cette note est déclarée dans #CF TCA :

EQUIVALENCE_AIDE    #CFTAR

Lorsque l'utilisateur est dans le paramètre #CF TCA et qu'il demande de l'aide, l'aide affichée sera celle de #CF TAR

Lorsque cette note n'est pas précisée, l'appel à l'aide Windows se fait sur le paramètre en cours.


#CF 4JS Configuration 4 J's

Valeur alpha 1

Caractère 1 inactif sous GENERO | Affichage des messages dans O des fenêtres 4GL classiques N des fenêtres Windows (par défaut)
Caractère 2 inactif sous GENERO | Affichage des confirmations dans O des fenêtres 4GL classiques N des fenêtres Windows (par défaut)
Caractère 3 inactif sous GENERO | Touches d'options non actives invisibles O touches invisibles, pas de libellé N touches visibles, libellé Non disponibles (défaut) (conditionnée par l'option gui.empty.button.visible = false du fglprofile)
Caractère 4 inactif sous GENERO | Autorisation d'affichage des libellés des boutons sur 20 caractères (O/N, N par défaut, sur 8 caractères)
Caractère 5 | Utilisation de l'alternance des couleurs pour les colonnes des visus O Alternance des colonnes entre les différentes colonnes (par défaut) N toutes les colonnes ont la même couleur de fond Pour Genero : actif uniquement en visualisation
Caractère 6 | Affichage avec une police en mode GRAS N affichage police normale (par défaut) O affichage en mode GRAS (police sans-serif, taille 10pt, fond bold Pour Genero : actif uniquement en visualisation
Caractère 7 | Ligne de totalisation N pas de ligne de totalisation 0 ligne de totalisation = ligne blanche 1 ligne de totalisation = ____________________ (valeur par défaut) 2 ligne de totalisation = ==================== Pour Genero : actif uniquement en visualisation
Caractère 8 | Ligne de séparation des ruptures N pas de ligne de séparation 0 ligne de séparation = ligne blanche 1 ligne de séparation = ____________________ 2 ligne de séparation = ==================== (par défaut) Pour Genero : actif uniquement en visualisation

Notes pour les styles

A partir de la V.4.1.0.2 (GENERO 2.30), les notes suivantes sont périmées.

Pour accéder à l'aide à la saisie des paramètres de style :

  1. Allez dans la saisie des paramètres (par02)

  2. Type STY (ce type a été créé par Volume Software, il est donc dans votre base si vous avez fait la mise à jour).

  3. Code DEF (vous créez maintenant ce code DEFaut pour créer un modèle de style qui sera systématiquement appliqué pour tous les utilisateurs).

  4. Faites F8 pour accéder à la fenêtre d'aide à la saisie des notes de paramétrage

FENETRE_MAXIMISEE

21 Ouverture écran en mode plein écran (O/N, N par défaut)

Il est nécessaire de réinitialiser le Client GDC la première fois. Nécessite un GDC 1.33.1n

La même note existe sur le USE où elle est prioritaire.

STYLE_COULEUR_FOND

21,60 Couleur de fond. La même note existe sur le USE où elle est prioritaire.

STYLE_COULEUR_TEXTE

21,60 Couleur de texte. La même note existe sur le USE où elle est prioritaire.

STYLE_COUL_LG_ACTIVE

21,60 Couleur de la ligne active dans les tableaux. La même note existe sur le USE où elle est prioritaire.

La liste des couleurs prédéfinies et la règle de priorité sont les mêmes que pour la note STYLE_COULEUR_FOND

STYLE_FONT

21,60 Nom de la police d'affichage.

La même note existe sur le USE où elle est prioritaire.

Peuvent être utilisées toutes les polices du système qui héberge le GDC, en respectant minuscules et majuscules.

Ex : Arial, Calibri, Times New Roman…

STYLE_FONTSIZE

21,60 xxpt : Taille de la police demandée

La taille est exprimée en points sur 2 caractères. Exemples : 09pt, 10pt

Cette note est recherchée en priorité dans le paramètre USE.

Exemple

STYLE_FONTSIZE 10pt

STYLE_FONTSTYLE

21,60 Style de la police d'affichage.

Les valeurs possibles sont les suivantes : light, normal, bold, demi-bold et black.

La même note existe sur le USE où elle est prioritaire.

Voir aussi #VI, notes commençant par 1,2,3,4


#CF 521 Tableau du détail des coûts

#CF 521 Tableau du détail des coûts dans l'édition de la partie commerciale du devis arts graphiques.

Spécifiquemr.pgm/MR_fle_r_r.4gl

Notes

TI

TF

Paramétrage du tableau Impression (TI) ou du tableau Façonnage (TF)

3 Formule s'appliquant au recto R ou au verso V

4 Formule opération O ou matière M

5,7 Code phase

8,10 Code formule

11 Calage en plus


#CF AAS Analyse d'activité

Spécifique.

Valeur numérique 1

Numéro de la ligne (1 à 13) pour mettre à jour les TNA budgétés et réalisés des centres de coût

0 (par défaut) Pas de mise à jour

Valeur numérique 2

Numéro de la ligne (1 à 13) pour mettre à jour les TA budgétés et réalisés des centres de coût

0 par défaut Pas de mise à jour

Valeur alpha 1

Pour lecture

Caractères 1 à 3 | Classe ttr ligne no 2
Caractères 4 à 6 | Classe ttr ligne no 3
Caractères 7 à 9 | Classe ttr ligne no 4
Caractères 10 à 12 | Classe ttr ligne no 6
Caractères 13 à 15 | Classe ttr ligne no 8
Caractères 16 à 18 | Classe ttr ligne no 10
Caractères 19 à 21 | Classe ttr ligne no 12

Pour écriture (MAJ des classes de ttr lignes 5,7,9,11,13)

Caractères 25 à 27 | Classe ttr ligne no 5 ( 1 - (2+3+4))
Caractères 28 à 30 | Classe ttr ligne no 7 ( 5 - 6)
Caractères 31 à 33 | Classe ttr ligne no 9 ( 7 + 8)
Caractères 34 à 36 | Classe ttr ligne no 11 ( 9 - 10)
Caractères 37 à 39 | Classe ttr ligne no 13 (11 - 12)

Valeur alpha 2

Titre de l'édition (par défaut = ANALYSE D'ACTIVITE)


#CF AFF Gestion des affaires

Ce paramètre est utilisé par le devis standard et le devis onduleur.

Valeurs numériques

Num 1 | Numéro de compteur des affaires
Num 2 |

Valeur alpha 1

Caractère 1 | Activation de la numérotation automatique (O/N) La numérotation automatique fonctionne sur le schéma suivant : AAMMXXXX AA Année MM Mois XXXX Compteur
Caractère 2 | Création en automatique du scénario sélectionné lors de la saisie de l’affaire (O/N, N par défaut)
Caractère 3 | Ouverture de la fenêtre des actions événements en automatique après la création du scénario (O/N, N par défaut) Nécessite A1[2] = O.

Valeur alpha 2

Caractères 1 à 3 | Type des notes à saisir directement dans la fenêtre de saisie des affaires (par défaut : AFF)
Caractères 4 à 60 | Type de notes complémentaires lors de la saisie de notes par CONTROL-N. Les types de notes sont saisis tous les 3 caractères : 4 à 6, 7 à 9, etc.

Valeur alpha 3

Caractères 1 à 3

Type de paramètre utilisé pour le code suivi d’affaires (Par défaut : SUI)

Notes

TITRE_ECRAN_SAISIE | Titre de l'écran de saisie des affaires
TITRE_ECRAN_NOTES | Titre de l'écran de saisie des notes sur affaires
_SUP_SQL_RECH_AFF | Complément de sélection pour la recherche d'affaires


#CF APP Paramétrage des éditions APPIC

Paramétrage des éditions utilisant APPIC et la gestion des bacs imprimantes.

Valeur alpha 1

Caractère 1 | Méthode d'obtention du nombre d'exemplaires total O Le nombre d'exemplaires est obtenu par sommation des nombres d'exemplaires associés au client et à #SOC (cli6) N Le nombre d'exemplaires est uniquement issu des nombres d'exemplaires saisis sur le client (cli6)
Caractère 2 | Mode de gestion du nombre d'exemplaires de la facture O La gestion du nombre d'exemplaires dans la facture est réalisée via APPIC. Ce paramétrage permet la gestion du nombre d'exemplaires par bac imprimante N La gestion du nombre d'exemplaires dans la facture est réalisée par VSW
Caractère 3 | Méthode d'obtention du nombre d'exemplaires société O Recherche du nombre d'exemplaires société à partir du code client et du code adresse saisis dans la zone alpha1 du paramètre SIT (site de production renseigné en entête de document) - Tableau de bord du multisite N Recherche du nombre d'exemplaires société à partir de #SOC
Caractère 4 | Paramétrage du modèle de document M Le paramétrage présent sur le MDO est prioritaire sur le #LP. Sinon, le paramétrage des bacs du #LP est prioritaire sur celui du MDO.

Paramètres associés

#LP | Notes commençant par APPIC_DEF_BACn
MDO | Notes commençant par APPIC_NB_PAGES_BAC1

Notes sur le paramètre de lancement des programmes faisant des éditions APPIC

ATTENTION : ces notes ne sont pas sur le #CF APP mais bien sur le paramètre de lancement

NB_COPIES | Caractères 21 à 22 : Nombre de copies désiré
NB_COPIES_SIT_XXX | ou XXX représente le code du site - Tableau de bord du multisite Caractères 21 à 22 : Nombre de copies désiré


#CF ART Interface Artios

Le numéro de port du client de l'interface peut être paramétré via la variable d'environnement NUM_PORT_ARTIOS (est prioritaire sur le paramétrage précédent).

ATTENTION : cette gestion n'est pas compatible avec GENERO : elle n'a donc rien à voir avec VMC et VAS.

Valeurs numériques

1

Numéro de port pour communication avec l'interface (doit être >= 11200) et identique à celui configuré sur le programme Windows interface_ARTIOS.exe

Notes

CORRESP_COMPO_CIALE | 21,40 Code Artios de la qualité carton 41,60 Code VoluPack correspondant
CHAMP_UTIL | 21 Type Artios E Pose M Etude 22,30 Code identifiant ARTIOS 31,60 Zone VoluPack à renseigner Nom du champ de l'enregistrement à renseigner, préfixé du nom de l'enregistrement (p_035. ou p_048.) Exemples : p_035.cjonemb (code jonction) p_048.rlonpal (longueur de la palette) Voir les listes ci-dessous

Note commençant par CHAMP_UTIL : liste des zones VoluPack à renseigner, à préfixer avec p_035.

La liste est triée en ordre alphabétique.

accessoires | Accessoire
bpattache | Points d'attache
bposfordec | Nombre de poses
bposrem | Poses en remorque
carcfefrcosou | Code FEFCO dessous
carcfefrcosur | Code FEFCO dessus
ccomdec | Code complexité découpe
ccomregout | Code complexité réglage outil
cfampf | Famille PF
cgamstd | Code gamme standard
cjonemb | Code jonction
cpatintext | Code patte INT/EXT
cpospatjon | Code position patte
cquacar | Qualité carton
csfmpf | Sous-famille PF
dern_zone | Dernière zone
estampilles | Estampilles
jonction | Jonction
lcomdec | Libellé court complexité découpe
lcomregout | Libellé
lembpromec | Libellé court emballage mécanisé
lgamstd | Libellé gamme standard
ljonemb | Libellé jonction
longfilet | Longueur filet par pose
longscie | Longueur à scier par plaque
lpospatjon | Libellé position patte
lquacar | Libellé qualité carton
lrefpf | Désignation du PF
netuemb | No étude emballage
nfictec | No fiche technique
nplan | No plan
nrefarc | Référence architecture
nrefpf | Référence du PF
options_ond | Options onduleuse
rcoubrupla | Coupe brute plaque
rcounetarc | Coupe unitaire nette (architecture)
rhauint | Hauteur
rlaibrupla | Laize brute plaque
rlainetarc | Laize unitaire nette (architecture)
rlarint | Largeur
rlarpatjon | Patte de jonction
rlonint | Longueur
rpoidsnetarc | Poids unitaire net (architecture)
rpropatbas | Prolongée dessous
rpropathau | Prolongée dessus
rsurfnetarc | Surface unitaire nette (architecture)
vcaninv | Cannelure inversée
vembpromec | Emballage mécanisé
voutcomp | Outils spéciaux

Note commençant par CHAMP_UTIL : liste des zones VoluPack à renseigner, à préfixer avec p_048.

La liste est triée en ordre alphabétique.

bartcol | Nombre d'articles par colis
bartcon | Nombre d'articles conditionnés
bpaluticon | Nombre de palettes utilisées / conditionnement
cmodgespal | Code mode de gestion de palette
coefcoi |
cschpal | Code schéma de palettisation
cspecer | Code cerclage
cspecol | Code spécification de colisage
ctypcoi | Type de coiffe
ctypetipal | Code type d'étiquette sur palette
ctyppal | Code type de palette
ft_pf | Format PF
gerbage | Gerbage
lplanpal | Plan de palettisation
lrefpf | Désignation du PF
lschpal | Libellé schéma de palettisation
lspecer | Libellé schéma de palettisation
lspecol | Libellé spécification de colisage
ltypetipal | Libellé type d'étiquette sur palette
nbetipal | Nombre d'étiquettes par palette
nrefpf |
position_charge |
pression_lat |
pression_ver |
rhauencpal | Hauteur encombrement palette
rlarcoi | Largeur coiffe
rlarencpal | Largeur encombrement palette
rlarpal | Largeur palette
rloncoi | Longueur coiffe
rlonencpal | Longueur encombrement palette
rlonpal | Longueur palette
surface_pf |


#CF ATL Configuration générale Atlas

Gestion des options

L'option payante ACH-4 doit être activée.

Edition Voluedit des ordres d'exécution

Ajout du package de la table cde5_ventil.

A4[28] = O pour l'activation des titres du groupe Détail besoin matière.

Visualisation des besoins matières

Ouverture de la fenêtre du détail des besoins matières de la ligne de commande après modification de la quantité du besoin si A2[54] = F (méthode de mise à jour du détail des besoins matières).

Proratisation du détail des besoins matières de la ligne de commande après modification de la quantité du besoin si A2[54] = P (méthode de mise à jour du détail des besoins matières)..

Modification du détail des besoins matières de la ligne de commande (touche F14).

Génération automatique des commandes fournisseurs

Dans la 1ère phase, alimentation de la table gen_cdef_ventil.

Dans la 2ème phase, alimentation de la table cdf2_ventil.

Saisie des commandes fournisseurs

L'option Oca (Cadencements de réception) doit être désactivée.

Ouverture de la fenêtre du détail des besoins matières de la ligne de commande après modification de la quantité commandée si A3[31] = F (méthode de mise à jour du détail des besoins matières).

Proratisation du détail des besoins matières de la ligne de commande après modification de la quantité commandée si A3[31] = P (méthode de mise à jour du détail des besoins matières).

Modification du détail des besoins matières de la ligne de commande (touche F14).

Edition Voluedit des commandes fournisseurs

Ajout du package de la table cdf2_ventil.

A4[4] = O pour l'activation des titres du groupe Détail besoin matière.

Saisie des bons de réception et de retour

Consultation du détail des besoins matières de la ligne de commande (Touche F14).

Indication si le détail a plusieurs ventilations.

Plusieurs options doivent être désactivées :

Oar Annulation des sorties réserves affectées

Ocr Création d'une réserve à la place d'une sortie normale

Or2 Recréation des reliquats de sortie réserve en désolde de ligne commande

Our Remplace Oar avec la contrainte suivante :
la sortie réserve doit exister si on veut générer la sortie normale.

Saisie des mouvements de stock

et

Visualisation des mouvements de stock

Mise à jour du détail des besoins matières lors de la transformation de la sortie réserve générée par le besoin en sortie normale.

Mise à jour de la quantité consommée du besoin.

Si reliquat et après confirmation, génération d'un mouvement de reliquat de sortie de réserve.

Epuration des dossiers

et

Epuration totale

Epuration des tables cde5_ventil et cdf2_ventil.

Outil d'alimentation de la table cdf2_ventil

Outil d'alimentation de la table cdf2_ventil lorsque la ligne de commande n'a pas d'enregistrement dans la table cdf2_ventil : nouveau programme

Quantité fabriquée < Quantité commandée

Quantité fabriquée > Quantité commandée mini

La ligne est soldée si le stock du lot est à 0.

Quantité fabriquée <= Quantité commandée mini

Si le pré-solde de la ligne est à N, la ligne n'est pas soldée.

Si le pré-solde de la ligne est à O, la ligne est soldée si le stock du lot est à 0.

Quantité fabriquée >= Quantité commandée

Quantité fabriquée >= Quantité commandée maxi

Si l'alerte de la ligne est à N, l'alerte est mise à B et la ligne n'est pas soldée.

Si l'alerte de la ligne est à B (Bloquée), l'alerte reste à B (Bloquée) et la ligne n'est pas soldée.

Si l'alerte de la ligne est à D (Débloquée), la ligne est soldée si la quantité livrée de la ligne est égale ou supérieure à la quantité commandée maxi de la ligne.

Quantité fabriquée < Quantité commandée maxi

La ligne est soldée si le stock du lot est à 0.

TYPES DE COMPTEURS - Source : f_numsuiv2.4gl

A Numéro de commande fournisseur

B Numéro de BL

C Numéro de commande client

D Numéro de devis

E Numéro d'étude

F Numéro de facture client

G Numéro de facture fournisseur

H Numéro de bon de réception

I Numéro de fiche de fabrication

J Numéro de bon de remontée des quantités fabriquées

K Numéro de bon de réception usine ou de pré-facture

L Numéro de bon de commande

M Numéro de maintenance

N Numéro automatique client (aamm=9999 cpt=9999NNNN)

O Numéro d'ordre sur la commande

P Numéro pour codification automatique des clients par département

Q Compteur gestion du SFAC

R Numéro de relevé de facture

S Numéro de facture client de simulation (pfac0, pfac1, pfac2)

et Numéro de pré-facture (fac3 , fac4)

T Numéro de bordereau de transfert de stock

U Numérotation des autorisations de suspension de TVA

V Identifiant des étiquettes de production (etiqprod)

W Numéro de bordereau de transport

X Numéro automatique de produit

Y Bon de retour client

Z Numéro de ligne du fichier texte de transfert vers SYLOGI

0 Numéro de groupage BL et de bon de préparation

1 Numéro de compteur pour les réclamations client

2 Numéro de compteur pour les non-conformités internes

3 Numéro de compteur pour les offres de prix

4 Numéro de compteur pour les affaires

5 Numéro de compteur pour les demandes d'achats

O Avec regroupement BL

N Sans regroupement BL

1 Sans regroupement commande, Sans regroupement BL

2 Avec regroupement commande, Sans regroupement BL

3 Sans regroupement commande, Avec regroupement BL

4 Avec regroupement commande, Avec regroupement BL

5 Réf. regroupement facture, entête de commande

6 Réf. regroupement commande, entête de commande

#CF ATL Configuration générale Atlas

Valeurs numériques

#CF ATL N1

Nombre maximum d'adresses secondaires pouvant être retournées par le F7 de recherche des codes d'adresses.

Si le nombre d'adresses secondaires pour le tiers courant est supérieur à cette valeur paramétrée, une fenêtre de saisie complémentaire d'informations est automatiquement ouverte afin de restreindre la recherche (par exemple, en indiquant un pays, une ville, etc.)

Valeur par défaut : 150

Valeur maximale : 150

#CF ATL N2

non utilisée

Valeur alpha 1

#CF ATL A1[1]

N Calculatrice VOLUME (créer le paramètre WIN CLC - voir les exemples dans le paramètre WIN)

B Pour utilisation de bc (calculatrice)

W Pour utilisation de la calculatrice Windows.

La calculatrice est obtenue par CTRL-C sur tous les écrans Volume.

Dans certaines configurations, le CTRL-C est désactivé et l'utilisation de la calculatrice n'est pas possible

#CF ATL A1[2]

Recherche des clients en étendant les critères aux adresses secondaires

[espace] On recherche les clients sans extension des critères aux adresses secondaires et sans afficher le détail des adresses retrouvées. Voir la note COULEUR_ETAT_QAL dans le paramètre QT.

A On recherche les clients sans extension des critères aux adresses secondaires mais avec affichage du détail des adresses retrouvées.

B On recherche les clients avec extension des critères aux adresses secondaires mais sans afficher le détail des adresses retrouvées. Voir la note COULEUR_ETAT_QAL dans le paramètre QT.

C On recherche les clients avec extension des critères aux adresses secondaires et avec affichage du détail des adresses retrouvées.

#CF ATL A1[3,5]

SPECIFIQUE Code société stock

#CF ATL A1[6]

SPECIFIQUE Millésime en cours (réservé)

#CF ATL A1[7]

Statistiques clients

C Statistiques clients sur l'année civile (par défaut)

E Statistiques clients sur l'année d'exercice

2 Les deux types de totaux sont présents

#CF ATL A1[8,11]

Heure de début de la journée (par défaut 0000) elle est utilisée pour la gestion des heures de nuit.

Exemple 0500

NB : l'heure est à saisir en centièmes d'heure

#CF ATL A1[12,14]

Modèle étiquette par défaut pour VOL'ETIQ

#CF ATL A1[15]

Fonctionnement sous Windows NT

O Fonctionnement aux normes DOS

N Fonctionnement aux normes UNIX (valeur par défaut)

#CF ATL A1[16]

Gestion du mode trace du verrouillage d' enregistrement

O On trace tous les verrouillages dans un fichier (FIC_TRACE_LOCK)

N Pas de trace, valeur par défaut

#CF ATL A1[17]

Gestion des noms longs client

Touche F7 sur le nom du client (adresse principale et/ou secondaire)

O On autorise la saisie d'un nom long

N On interdit la saisie d'un nom long

Cette zone supplémentaire est rangée dans la table cli3 (notes sur fiche client) avec comme code paramètre note NTS NLC (en dur dans le programme).

Cette zone n'est pas interrogeable.

#CF ATL A1[18]

Langue

O Prise en compte du paramétrage du code langue pour les libellés multi langues. Si fr, le système prend également en compte les lignes avec le code langue à blanc.

N Le système prend en compte les lignes sans code user et celles avec fr.

Dans le cadre d'une nouvelle installation, pour les visus, il est conseillé de positionner de suite le code langue.

#CF ATL A1[19]

BL facturables

O Les BL sont non facturables

N Les BL sont facturables (par défaut)

#CF ATL A1[20]

Activation de l'aide Windows (O/N, N par défaut)

Le nom complet (avec le répertoire) est indiqué dans la note commençant par :

FICHIER_AIDE_WIN pour l'aide de Volume Software,

FICHIER_AIDE_CLI pour l'aide personnalisée du client.

#CF ATL A1[21]

Mode d'affichage du prix de la facture dans le Control-F

N Prix unitaire HT dans l'unité (défaut)

O TTC de la ligne de facture

U Prix à l'unité de la ligne de facture

#CF ATL A1[22]

Mode de gestion des achats de papier

1 Au poids (Par défaut)

2 Au mètre linéaire

#CF ATL A1[23]

Numéro du jour de la semaine qui détermine le mois d'imputation

(0=Dimanche, 1=Lundi, 2=Mardi, 3=Mercredi, 4=Jeudi, 5=Vendredi, 6=Samedi)

Exemple : si on indique 3 (mercredi) ,cela veut dire que le mois doit se terminer par un mercredi : autrement dit, si le dernier jour du mois est un mardi, alors le mois se termine le mercredi du mois suivant.

<ou>

T Imputation au numéro de trimestre (rare)

N Imputation normale (par défaut)

#CF ATL A1[24]

Visualisation simplifiée des stocks en lieu et place de la visualisation des lots et/ou lieux (O/N, N par défaut)

#CF ATL A1[25,30]

Code calendrier de vérification de la date au plus tard suite au calcul (voir A2[36,41]

La date calculée doit exister dans ce calendrier en tant que date possible.

Utilisé en saisie de commande client (cde).

Par défaut : #SOC

Voir revue de contrat

#CF ATL A1[31,32]

Nombre de bips à émettre pour un message d'erreur (3 par défaut)

#CF ATL A1[33,34]

Nombre de bips à émettre pour un message autre (2 par défaut)

#CF ATL A1[35]

Où stocke-t-on la laize des bobines ? Inversion de format (fi_lar_papier et fi_lon_papier)

O La laize des bobines est saisie dans la zone mp_lon (anciens rotativistes).

N La laize des bobines est saisie dans la zone mp_lar (par défaut).

Ce paramètre est actif dans le devis standard et dans la recherche optimisée des papiers (si le paramètre #CFSMC A1[23] est actif dans ce dernier cas).

#CF ATL A1[36]

Activation de la gestion de la PLV dans la chaîne commerciale (O/N, N par défaut)

Permet de gérer la PLV dans la chaîne commerciale, du transfert de devis en commande jusqu'à la facturation.

#CF ATL A1[37,38]

Code langue pour affichage des messages inexistants dans la langue de l'utilisateur (en, fr, pl, sp, fr par défaut)

Exemple :

Langue de l'utilisateur : pl (Polonais)

Langue paramétrée en A1[37,38] : en (Anglais)

Si le message en Polonais n'est pas trouvé, c'est le message en Anglais qui sera affiché.

Par défaut, ce serait le message en Français qui s'afficherait.

#CF ATL A1[39]

Utilisation de la nouvelle interface de Direct Planning

1 ou [espace] Ancien transfert utilisant la configuration #CF DPL (par défaut)

2 Nouveau mode utilisant la configuration #CF DP2.

#CF ATL A1[40,42]

Nombre de jours à déduire de la date courante pour la recherche du taux de change de la devise

0 (Zéro) par défaut.

#CF ATL A1[43]

Initialisation de la fin du libellé d'une ligne de commande carton à blanc (O/N, N par défaut)

Voir mp_param[29] = 4)

#CF ATL A1[44]

Gestion des besoins matières détaillés par dossier

O gestion activée

N gestion non activée (par défaut)

I information (création des besoins dans cde5 et cde5_ventil sans les mouvements de stock)

Cliquez ici pour afficher / masquer plus de détails.

#CF ATL A1[45]

Regroupement facturation lignes produit et frais (O/N, N par défaut)

Ce paramètre n'est pris en compte que si la zone 22 des données diverses de la fiche client = G.

#CF ATL A1[46]

Gestion des remontées en unité de production (O/N, N par défaut)

Tables modifiées :

formules ajout de la zone ul_uni_prod Unité de production

fab3 ajout de la zone f3_qte_up Quantité en unité de production

fab0 ajout des zones (accessibles dans l'édition des ordres d'exécution pour les onduleurs)

f0_amalgame Ligne d'amalgame (A/N)

f0_regroupement Code de regroupement

f0_uni_prod Unité de production

f0_hau Hauteur

f0_poids Poids

f0_dt1 Donnée technique 1

f0_dt2 Donnée technique 2

f0_qtel_up Quantité lancée en unité de production

f0_qter_up Quantité réalisée en unité de production

Voir aussi :

ul_param(34 et 35)

FOR notes SAISIE_MULTI_UNITE - FORMULE_3 - FORMULE_3_UP

# CF PRV A1[1,50] - Colonnes z ( ) { } < >

#CF ATL A1[47]

Traçabilité des offres autres que l'offre commerciale 99 (O/N, O par défaut)

L'offre 99 est toujours tracée.

#CF ATL A1[48,50]

Code TSC du code palette

Facultatif - Utilisé dans le calcul du métrage linéaire de plancher

Valeur alpha 2

#CF ATL A2[1]

Numéro automatique des clients avec folioteur (O Oui, N Non)

#CF ATL A2[2,3]

Longueur de la racine, par défaut 01

Si 00, pas de racine; dans ce cas, dans la saisie des compteurs, il faut mettre ### dans le champ racine pour que le compteur commence sans racine.

Voir les notes commençant par RACINE pour définir les racines autorisées.

Si la longueur de la racine est à 99, elle est considérée comme de longueur variable.

#CF ATL A2[4,5]

Longueur du folioteur, par défaut 05

#CF ATL A2[6]

Numéro automatique des fournisseurs avec folioteur (O Oui, N Non)

#CF ATL A2[7,8]

Longueur de la racine, par défaut 01

Voir les notes commençant par RACINE pour définir les racines autorisées.

Si la longueur de la racine est à 99, elle est considérée comme de longueur variable.

#CF ATL A2[9,10]

Longueur du folioteur, par défaut 05

#CF ATL A2[11]

Numéro automatique des prospects avec folioteur (O Oui, N Non)

#CF ATL A2[12,13]

Longueur de la racine, par défaut 01

Voir les notes commençant par RACINE pour définir les racines autorisées.

Si la longueur de la racine est à 99, elle est considérée comme de longueur variable.

#CF ATL A2[14,15]

Longueur du folioteur, par défaut 05

#CF ATL A2[16]

R Le client utilise le devis reliure

D Le client utilise un autre devis

#CF ATL A2[17]

La qualité carton est accessible sur l'article au niveau de

1 la famille

2 la sous-famille

#CF ATL A2[18]

A VERIFIER

Dans le CTRL-F sur la commande

En plus de la visualisation des BL et des factures d'une ligne de commande, on aura les commandes d'achat affectées.

O Visu. des BL, factures et commandes d'achat

N Visu. des BL et des factures

1 Visu. des BL et des factures et recherche des commandes rattachées (nécessité de créer un index sur lc_cderat)

2 Visu. des BL, des factures, recherche des commandes rattachées (nécessité de créer un index sur lc_cderat) et recherche des factures rattachées (nécessité de créer un index sur lc_facrat)

X Accès au nouvel écran de visualisation des BL et factures

Voir plus bas les notes ACCES_ACHAT, ACCES_BL, ACCES_BR et ACCES_FACTURE

#CF ATL A2[19,21]

Pour les articles cartonniers dans la solution onduleur

Génération automatique du libellé de la ligne de commande client dans le cas d'un article de type 1.
Code du TSC donnant la qualité carton.

#CF ATL A2[22,26]

Mot de passe pour la transformation d'un prospect en client.

#CF ATL A2[27,29]

Pour les articles cartonniers dans la solution onduleur

Génération automatique du libellé de la ligne de commande client dans le cas d'un article de type 2.
Code du TSC donnant la qualité carton.

#CF ATL A2[30]

Méthode d'arrondi de la 3ème décimale lorsque celle-ci a la valeur 5 (I ou S)

I arrondi à la valeur inférieure (Valeur par défaut)

0.124 : 0.12

0.125 : 0.12

0.126 : 0.13

S arrondi à la valeur supérieure

0.124 : 0.12

0.125 : 0.13

0.126 : 0.13

Cette méthode est appliquée à partir d' une date paramétrée en alpha2[49,56]

Elle est utilisée dans les modules suivants :

Saisie des commandes clients (calcul du pied de facture)

Visualisation des commandes clients (calcul du pied de facture)

Validation de factures (calcul du pied de facture)

Calcul et édition des factures

Visualisation des factures

Transfert des factures en comptabilité

#CF ATL A2[31]

La suppression d'un client laisse une trace dans le fichier evt.

#CF ATL A2[32]

La suppression d'un fournisseur laisse une trace dans le fichier evt.

#CF ATL A2[33]

La suppression d'un prospect laisse une trace dans le fichier evt.

#CF ATL A2[34]

Mise à jour de la table traçabilité (O/N, N par défaut)

#CF ATL A2[35]

Mode d'initialisation du mode d'exonération, du type de port, du mode de transport et du code transporteur de l'entête de commande (O/N, N par défaut)

N Le mode d'exonération, le type de port, le mode de transport et le code transporteur sont initialisés avec ceux de l'adresse principale du client

O Le mode d'exonération, le type de port, le mode de transport et le code transporteur sont initialisés avec ceux de l'adresse de livraison du client (conforme à la loi)

NB : Ceux-ci sont remis à jour à chaque modification du code adresse de livraison de l'entête de commande. La modification du code adresse de livraison de la ligne de commande ne les remet pas à jour.

#CF ATL A2[36,41]

Code calendrier à utiliser pour calculer la date de départ au plus tard dans la saisie des commandes clients (alpha3[27] du TYC de la commande clients).

Si non rempli, le code calendrier est égal au code transporteur saisi sur la commande clients.

Exemple : #SOC

Voir revue de contrat

#CF ATL A2[42]

Recherche du code machine * lors de la recherche des opérations élémentaires

O On utilise le code machine * (valeur par défaut)

N On n'utilise pas le code machine *

#CF ATL A2[43]

Application d'un ordre de tri lors de la recherche des opérations élémentaires

O On applique un ordre de tri (valeur par défaut)

N On n'applique pas d'ordre de tri

#CF ATL A2[44]

Contrôle du mode d'application de TVA en fonction du pays de livraison (fiche client et commande)

(O/N, N par défaut)

#CF ATL A2[45]

Contrôle champ identifiant comptable sur adresses secondaires

N Pas de saisie (par défaut)

1 Saisie non contrôlée

2 Saisie contrôlée avec rapatriement des infos de la fiche client en création uniquement

#CF ATL A2[46]

Recherche du code difficulté * lors de la recherche des opérations élémentaires

O On utilise le code difficulté *

N On n'utilise pas le code difficulté * (valeur par défaut)

#CF ATL A2[47]

Cadrage du code client dans le code comptable

G gauche et seul

D Radical + code client (par défaut)

#CF ATL A2[48]

Numérotation automatique des codes adresses secondaires (O/N, N par défaut)

#CF ATL A2[49,56]

Date de prise en compte de la méthode d'arrondi de la 3ème décimale lorsque celle-ci est à 5 et que alpha2[30] = S.

Si aucune date n'est renseignée, l'arrondi sera appliqué systématiquement si la méthode S est paramétré.

Format JJMMAAAA

#CF ATL A2[57,59]

Code TVA en activité (utilisé dans le devis onduleur devis_ondu)

#CF ATL A2[60]

Lors de la recopie des libellés étrangers, les grammages et les formats seront également recopiés (O/N)

Valeur alpha3

#CF ATL A3[1]

Numérotation automatique du code comptable CLIENT (O/N)

#CF ATL A3[2,5]

Radical du code comptable par défaut (exemple 411)

#CF ATL A3[6]

Numérotation automatique du code comptable FOURNISSEUR (O/N)

#CF ATL A3[7,10]

Radical du code comptable par défaut (exemple 401)

#CF ATL A3[11]

Affectation du code comptable lors du passage d'un Prospect en Client (cli.4ge)

Le code comptable affecté sera alors généré selon le mode de fonctionnement de celui du client.

Exemple :

Si client avec code comptable en auto alors code en auto (radical du client par défaut).

Si client avec code comptable en manuel, alors code en manuel (radical du client)

#CF ATL A3[12]

Type de devis - Voir aussi TEN A1[41]

B Bobine

C Devis onduleur (odv)

I Imprimerie

K Devis onduleur standard (don)

M Mécanique

O Devis onduleur (devis_rco)

R Reliure (non utilisé - vérifier cette info)

T Continu

Utilisé si l'option Old est positionnée dans la saisie des commandes clients (lien entre devis et commande)

#CF ATL A3[13]

Visualisation par ctrl B des stocks à zéro sur les lieux de niveau 2

N ou [espace] Visualisation des stocks à 0

O Les stocks à zéro sur les lieux de niveau 2 ne sont pas visualisés.

#CF ATL A3[14,16]

TSC commentaire utilisé dans la recherche des machines

#CF ATL A3[17]

Méthode de prise en compte des plages horaires

N ou [espace] Ancienne méthode, gestion avec

code 1 (journée)

code 2 (matin)

code 3 (après-midi)

code 4 (nuit)

O Nouvelle méthode, gestion avec

code J (journée)

code M (matin)

code A (après-midi)

code N (nuit)

#CF ATL A3[18]

Méthode de prise en compte délais de sécurité

J ou [espace] Le délai est en Jour(s)

H Le délai est en Heure(s)

#CF ATL A3[19]

Activation de l'obligation de saisie des codes INSEE pour les adresses principales et secondaires de type livraison du pays de la société.

O La saisie est obligatoire

N La saisie n'est pas obligatoire (par défaut)

#CF ATL A3[20]

Type de message d'erreur lorsque l'outil n'existe pas dans la gestion des outils par mouvements de stocks automatiques.

1 Message dans une boîte de dialogue (intervention de l'utilisateur) (par défaut)

2 Message sur fond rouge en bas de l'écran (pas d'intervention de l'utilisateur)

3 Message dans le compte-rendu d'édition (s'il existe et selon son paramétrage)

N Pas de message d'erreur

#CF ATL A3[21,24]

Calcul des mètres linéaires de plancher

Valeur à ajouter au calcul optimum pour obtenir la valeur finale. La valeur est exprimée en mm.

Par défaut 50 mm

#CF ATL A3[25,28]

Calcul des mètres linéaires de plancher

Valeur de l'arrondi

Par défaut 100 mm

Exemple Si le calcul exact aboutit à 12563 mm de plancher

La valeur retournée est 12563 + 50 = 12613, arrondi au 100 supérieur 12700 soit 12,7 ML

On utilise ici les valeurs par défaut.

#CF ATL A3[29,30]

Longueur du compte tiers ( maxi 17). Valeur par défaut : 8

#CF ATL A3[31]

Rendre le code validité adresse obligatoire sur la saisie des adresses secondaires

Valeur par défaut N

#CF ATL A3[32]

Code du système de planification :

Permet de choisir le message affiché à la fin de la génération des OF.

1 PC-Topp (par défaut)

2 OM-Partners

3 AIS

4 VoluOrdo / Direct Planning

5 Image

Ce paramètre est pris par défaut s'il n'est pas renseigné dans la note commençant par CODE_SYSTEME_PLANIF dans gdf_don.

#CF ATL A3[33]

Utilisation des préfixes pour l'état des palettes (O/N) (Gestion des excédents)

#CF ATL A3[34]

L Longueur de l'état de palette (L peut prendre les valeurs de 1 à 5)

Dans la table stk0, la zone s0_rgt2 (Lieu de rangement de niveau 2) fait 6 caractères.

On y stockera :

le code état des palettes dans les caractères 1 à L

l'aire de stockage dans les caractères L+1 à 6

Exemple :

Valeur recommandée pour L : 3

Donc, dans s0_rgt2, on stockera :

le code état des palettes dans les caractères 1 à 3,

l'aire de stockage dans les caractères 4 à 6.

Voir les notes commençant par CODES_ETATS_PALETTE_

#CF ATL A3[35,37]

Lieu de rangement niveau 1 par défaut de la société

#CF ATL A3[38,43]

Lieu de rangement niveau 2 par défaut de la société

#CF ATL A3[44,49]

Lieu de rangement niveau 3 par défaut de la société

#CF ATL A3[50]

Calcul du prix de revient réel avec le delta d'effectif saisi dans le devis onduleur (O/N, N par défaut)

#CF ATL A3[51,56]

Code calendrier à utiliser pour vérifier la date rendue client dans la saisie des commandes

Si non rempli, pas de contrôle de niveau 3

Exemple : #SOC

#CF ATL A3[57]

Affichage du type de livraison (O/N, N par défaut)

Possibilité d'afficher le type de livraison sous la forme d'une lettre devant le numéro du bon de livraison dans le CTRL-F. Voir aussi le tableau des types de livraison.

Si l'affichage est activé, la lettre (D/A/*) (indiquant que la commande a des commandes rattachées) n'est plus affichée.

Chaque type de livraison est représenté par une lettre.

1 Livraison client en vente directe Blanc

2 Entrée mise à disposition client M

3 Sortie mise à disposition client m

4 Entrée mise à disposition usine M

5 Sortie mise à disposition usine m

6 Entrée consignation client C

7 Sortie consignation client c

8 Transfert sous-traitant V

9 Sortie sous-traitant W

10 Retour sous-traitant w

11 Livraison filiale F

12 Entrée mise à disposition client M

13 Entrée consignation client C

14 Entrée sous traitant X

15 Bon de transfert T

16 Entrée mise à disposition client M

17 Entrée mise à disposition usine M

101 Fabrication sous-traitant Y

Note : le retour est identifié par lettre R.

#CF ATL A3[58]

Pour le calcul de l'échéance du carnet de commande, prendre la plus grande date entre le délai répondu (lc_delrep) et la date du jour (O/N, N par défaut)

Utilisé par G_risque_detail

#CF ATL A3[59]

Pouvoir saisir le code comptable de la fiche tiers en minuscule (O/N, N par défaut)

#CF ATL A3[60]

Méthode de solde utilisée dans la saisie des bons de livraison lors de la livraison dune ligne de cadencement de livraison (1/2, 1 par défaut)

1 La ligne de commande ou de nomenclature est soldée lorsque tous les cadencements de livraison sont soldés et que le reste à livrer de la ligne SAP est à 0.

2 La ligne de commande ou de nomenclature est soldée selon cette méthode.

Voir les notes AUTORISE_TOUCHE_F54 et AUTORISE_TOUCHE_F55 dans la visu des commandes clients

Remarques

Le changement de valeur de l'alerte et du pré-solde de la ligne de commande ou de nomenclature est fait par la visualisation des commandes clients (Touches F54 et F55.

La tolérance de livraison prise en compte est celle de la ligne de commande.

Valeur alpha 4

#CF ATL A4[1,15]

Libellé zone s0_libre (table stk0)

#CF ATL A4[16,23]

Libellé du code (FEFCO, ECMA, code SAC...) sur écran du devis

#CF ATL A4[24,41]

Libellé du code tourné.

Ce libellé apparaît sur la fiche tiers, sur l'entête de commande, fenêtre de sélection de facture

#CF ATL A4[42]

Utilisation de la feuille de calcul (O/N).

Accès par F7 sur certaines zones numériques (devis TC, LCO et TSC)

#CF ATL A4[43,44]

#CF ATL A4[43]

#CF ATL A4[44]

Permettent l'utilisation de la table stk_lot_lieu, à la place de la table stk0, en recherche des lots/lieux.

Les principaux programmes concernés sont les suivants :

· Correction de stock (maj_stk)

· Visualisation des commandes (v_cdem, tableau lieux en édition)

· Saisie des commandes clients (cde, transfert du stock de non vendable à vendable)

· Visualisation des stocks (v_stk0)

· Saisie des BL (blv, picking)

Cette fonctionnalité a pour but d'améliorer les temps des traitements sur les stocks.

Ces modifications ne sont vraiment efficaces que si la table stk_lot_lieu est rafraîchie régulièrement (programme maj_stk_lot_lieu)

ATTENTION : cette option peut donner de faux résultats.

(O/N, N par défaut) Utilisation de la table stk_lot_lieu pour les articles dont mp_param[19] = N

(O/N, N par défaut) Utilisation de la table stk_lot_lieu pour les articles dont mp_param[19] = T

Le caractère 44 n'est pris en compte que si le caractère 33 = O.

#CF ATL A4[45,46]

Temps d'attente en secondes lors d'accès concurrents aux données (bases on-line uniquement).

#CF ATL A4[47]

Libellés en déclaration manuelle de production

1 Palette (par défaut)

2 Colis

#CF ATL A4[48]

Gestion du stock résultant (O/N, O par défaut)

Si N, le stock résultant est toujours à zéro.

#CF ATL A4[49,51]

Type de paramètre Origine pour la saisie et le calcul du transport

RG1 : Lieu de rangement

SIT Site de production - Tableau de bord du multisite

#CF ATL A4[52]

Caractère de début du code client à recopier lors de la création du code comptable

Ne pas confondre avec #CF ATL A4[59] qui fait la même chose pour les fournisseurs. Voir cli option Orc.

#CF ATL A4[53]

Caractère de fin du code client à recopier lors de la création du code comptable

Ne pas confondre avec #CF ATL A4[60] qui fait la même chose pour les fournisseurs. Voir cli option Orc

#CF ATL A4[54]

Gestion des décimales dans l'écran des pointages (devis onduleur non concerné)

D gestion des décimales

C gestion des décimales pour les dimensions calculées uniquement

[blanc] gestion en valeurs entières (valeur par défaut)

Ce paramètre est nécessaire à VoluOptimix.

Voir aussi le document Word VoluOptimix-Installation.

#CF ATL A4[55]

Récupération automatique du tarif transporteur le plus bas trouvé (O/N, N par défaut)

#CF ATL A4[56]

Calcul des déchets dans le devis onduleur

O Le calcul se fait sur le poids brut (TSC 201)

N Le calcul se fait sur le poids net (TSC 202) (valeur par défaut)

#CF ATL A4[57]

Nouvelle gestion des besoins matière à partir de donnée du devis standard multi-métier (O/N, N par défaut)

Pour utiliser les données techniques de ce devis : #CF SMC A2[18] = O

#CF ATL A4[58]

Nouvelle gestion des taux de commission des représentants (O/N, N par défaut)

Voir aussi les permissions en ACCès et en MODification : CL_TX_COMM et C2_TX_COMM

N Le taux de commission est initialisé avec la valeur numérique 1 du paramètre REP

O Le taux de commission est initialisé avec celui de l'adresse si celui-ci est renseigné (différent de null).
Sinon, le taux de commission est initialisé avec celui du client si celui-ci est renseigné (différent de null).
Sinon, le taux de commission est initialisé avec la valeur numérique 1 du paramètre REP.

S Le taux de commission est initialisé avec la valeur numérique 1 du paramètre REP et aucun message de changement de taux de commission n'apparaît si l'on change le code représentant d'une commande.

#CF ATL A4[59]

Caractère de début du code fournisseur à recopier lors de la création du code comptable

Ne pas confondre avec #CF ATL A4[52] qui fait la même chose pour les clients. Voir cli option Orc

#CF ATL A4[60]

Caractère de fin du code fournisseur à recopier lors de la création du code comptable.

Ne pas confondre avec #CF ATL A4[53] qui fait la même chose pour les clients. Voir cli option Orc

Notes triées

ACCES_ACHAT

21,26 Type et code paramètre pour l'accès aux achats

Cet accès est lié à une permission (CBF_ACC_ACH pour le type TOU) - Voir aussi le #CF CBF

A2[18] doit âtre à X.

ACCES_BL

21,26 Type et code paramètre pour l'accès aux bons de livraison

Cet accès est lié à une permission (CBF_ACC_BL pour le type TOU) - Voir aussi le #CF CBF

A2[18] doit âtre à X.

ACCES_BR

21,26 Type et code paramètre pour l'accès aux bons de retour

Cet accès est lié à une permission (CBF_ACC_BR pour le type TOU) - Voir aussi le #CF CBF

A2[18] doit âtre à X.

ACCES_FACTURE

21,26 Type et code paramètre pour l'accès aux factures

Cet accès est lié à une permission (CBF_ACC_FAC pour le type TOU) - Voir aussi le #CF CBF

A2[18] doit âtre à X.

ACCES_REEDI_BL

21 à 26 Type et code du paramètre de réédition provisoire du BL. Exemple #RDBLV

utilisé dans cde et v_cdem

ACCES_REEDI_FAC

21 à 26 Type et code du paramètre de réédition provisoire de la facture. Exemple #RDFAC

utilisé dans cde et v_cdem

ANNUL_SFM_TEST_CDE

ANNUL_SFM_TEST_CDF

ANNUL_SFM_TEST_MAT

ANNUL_SFM_TEST_NOM1

21 Doit-on tester la présence du couple Famille/Sous-famille lors de l'annulation logique de la sous-famille ? (O/N)

dans les lignes de commande client

dans les lignes de commande fournisseur

dans les matières

dans les nomenclatures

ATTENTION : Si la ligne de note n'est pas saisie, le contrôle sera fait.

Si la ligne de note est saisie mais avec une valeur différente de O (ou sans valeur), le contrôle ne sera pas fait.

ANN_P_SFM_TEST_CDE

ANN_P_SFM_TEST_CDF

ANN_P_SFM_TEST_MAT

ANN_P_SFM_TEST_NOM1

21 Doit-on tester la présence du couple Famille/Sous-famille lors de l'annulation physique de la sous-famille ? (O/N)

dans les lignes de commande client

dans les lignes de commande fournisseur

dans les matières

dans les nomenclatures

ATTENTION : Si la ligne de note n'est pas saisie, le contrôle sera fait.

Si la ligne de note est saisie mais avec une valeur différente de O (ou sans valeur), le contrôle ne sera pas fait.

AUTORISE_CONTROL_J

21 Autorisation de la touche CONTROL-J (lancements de programmes) (O/N, N par défaut)

Cette note est recherchée en priorité sur paramètre USE.

BUDGET_#SOC_SAISI

21 Le budget prévisionnel du client #SOC est-il saisi ?

O il est saisi, on ne le recalcule pas.

N il n'est pas saisi, on le recalcule en cumulant ceux des autres tiers. [Valeur par défaut]

CHEVAUCHEMENT_CPT_

Test de chevauchement de compteurs avec actions associées

Permet de déterminer lorsqu'un compteur arrive à sa limite et commence à empiéter sur les valeurs d'un autre compteur.

19 Type du compteur à tester (cliquez ici pour afficher / masquer la liste)

21 Action à exécuter si chevauchement

R Réinitialisation du compteur en le faisant repartir de sa valeur initiale (pour le cas des factures de simulation si elles sont épurées à chaque calcul)

[autre] Message d'erreur avec sortie immédiate du programme (le message signale qu'il y a chevauchement et qu'il faut prévenir le responsable informatique.)

CHX_SOC_PROG_OUVERT

Accès à l'écran de sélection des sociétés lorsqu'un programme est ouvert

O Accès toujours autorisé

C Accès autorisé sur confirmation

N Accès interdit

Par défaut : Ce paramétrage est récupéré en priorité sur le USE.

CLE_CONFORMITE

Voir Opérations de contrôle et de maintenance

CLE_DOCUMENT_xxx

Cette note est recherchée en priorité dans le paramètre de lancement du programme concerné.

Voir aussi la note PREFIX_DOCUMENT_xxx

CODES_ETATS_PALETTE_

Ces notes exigent que L soit défini en alpha3[34].

9 états maxi, les 4 premiers sont figés par leur rang et par leur signification

21+0L à 20+1L Code état VENDABLE (exemple VEN)

21+1L à 20+2L Code état NON VENDABLE (exemple NVE)

21+2L à 20+3L Code état A RETRAITER (exemple ARE)

21+3L à 20+4L Code état A DETRUIRE (exemple ADE)

21+4L à 20+5L Code état à définir par l'utilisateur

21+5L à 20+6L Code état à définir par l'utilisateur

21+6L à 20+7L Code état à définir par l'utilisateur

21+7L à 20+8L Code état à définir par l'utilisateur

21+8L à 20+9L Code état à définir par l'utilisateur

DESIG_2_MAJUSCULES

Casse de saisie pour la désignation 2 des articles

O Saisie en majuscules

N Saisie en minuscules (par défaut)

EDITION_SANS_VALEUR

Edition de la visualisation même si aucun enregistrement n'est trouvé (O/N, N par défaut)

Pour le moment, ce paramétrage n'est valable que pour l'édition du journal des livraisons.

Cette note est recherchée ne priorité dans le paramètre de lancement de l'édition du journal des livraisons.

ESTAMP_NIV_INF

21 En saisie des estampilles, pouvoir utiliser un niveau qui soit inférieur à celui indiqué par la composition (O/N, N par défaut)

La liste des niveaux possibles apparaîtra dans l'ordre alphabétique.

ETATS_CADENCEMENTS

21,23 Code état de création des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : CRE

24,26 Code état de modification des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : MOD

27,29 Code état de livraison non soldée des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : LNS

30,32 Code état de validation des cadencements de livraison

Paramètre ECA - Facultatif - Exemple : VAL

33,35 Code état d'édition des cadencements de livraison

Paramètre ECA

Remarque : La mise n'est effectuée que si le code état est paramétré.

Cette note est prise en compte si elle n'est pas trouvée dans les paramètres de lancements de cde, v_cdem, blv et voluedit_acr

_EXCEL_DATE_EXPORT

21 Ajout de la date et de l'heure de l'export Excel entre le titre du document et les critères de la requête (O/N, N par défaut)

Ce paramétrage vaut pour tous les programmes de visualisation.

La note sur le paramètre de lancement (#VI) est prioritaire.

_EXCEL_FORMAT

21,24 Format de fichier

XLSX (à partir de Microsoft Excel 2007) (par défaut)

La note sur le paramètre de lancement (#VI) est prioritaire.

_EXCEL_REPERTOIRE

21,60 Nom du répertoire où sera déposé le fichier Excel généré (facultatif)

Par défaut, le répertoire est renseigné dans VMC.

Exemple : d:\doc

La note sur le paramètre de lancement (#VI) est prioritaire.

_EXCEL_VMC_VERSION

21,23 Numéro de version de VMC

1.8 ou vide (par défaut)

2.0

La note sur le paramètre de lancement (#VI) est prioritaire.

FICHIER_AIDE_CLI

21,60 Chemin d'accès et nom du fichier d'aide Windows du client

La syntaxe est au format Unix : le / sert à délimiter les répertoires.

Exemple : D:/Aide en ligne/Cartonix.chm

Si le chemin d'accès est très long, il peut être défini sur plusieurs lignes.

Attention, les espaces de fin de chaînes seront supprimés.

Activé par alpha1[20]

FICHIER_AIDE_WIN

21,60 Chemin d'accès et nom du fichier d'aide Windows de VSW

La syntaxe est au format Unix : le / sert à délimiter les répertoires.

Exemple : D:/Aide en ligne/VoluHelp.chm

Si le chemin d'accès est très long, il peut être défini sur plusieurs lignes.

Attention, les espaces de fin de chaînes seront supprimés.

Activé par alpha1[20]

FICHIER_STYLE_PERSO

NOTE SUPPRIMEE

GESTION_COEFF_MARGE

Dans le récapitulatif du prix du devis multi-métiers, remplacer le pourcentage de marge par une gestion de coefficient de marge. (O/N, N par défaut)

GESTION_TRAIN_CADFAB

Gestion des trains de cadencements de fabrication (O/N, N par défaut)

INFO_SITE_XXX

Gestion de la sous-traitance entre sites - Tableau de bord du multisite

où XXX = site

21,26 Code client rattaché au SITE XXX

27,32 Code fournisseur rattaché au SITE XXX

LCT_PROG_ANOMALIES

Dans la fenêtre de sélection des lancements de programmes (Control-J), affichage des lignes avec argument en anomalie ou non trouvé

T Avec affichage des lignes avec argument en anomalie ou non trouvé (par défaut)

N Avec affichage des lignes avec argument non trouvé uniquement

A Avec affichage des lignes avec argument en anomalie uniquement

X Sans affichage des lignes avec argument en anomalie ou non trouvé

Ce paramètre existe aussi au niveau du USE où il est prioritaire.

LCT_MULTI_ANOMALIES

Dans la fenêtre de sélection des lancements multi-sélections (Control-K), affichage des lignes avec argument en anomalie ou non trouvé

T Avec affichage des lignes avec argument en anomalie ou non trouvé (par défaut)

N Avec affichage des lignes avec argument non trouvé uniquement

A Avec affichage des lignes avec argument en anomalie uniquement

X Sans affichage des lignes avec argument en anomalie ou non trouvé

Ce paramètre existe aussi au niveau du USE où il est prioritaire.

LIEN_CLASSE_SCLASSE

21,23 Code du paramètre de type #LI, qui gère le lien entre les paramètres de classe et de sous-classe

Voir la fiche d'installation des nouvelles zones de la table par02

MAINTENANCE

Permet de paramétrer le message qui apparaît dans la fenêtre de gestion de la maintenance.

(Dans le cas par exemple où la maintenance directe est assurée en interne et non par Volume Software).

On ne prend en compte que les 2 premières lignes.

MAJ_AUTOMATIQUE_MAT

21 Recopie automatique des informations dans G_mat (O/N, N par défaut)

Les poids et surface issus des TSC sont recopiés dans les données techniques.

MAJ_STK_RESUL_MVT_PR

21 Mise à jour du stock résultant sur les mouvements prévisionnels (O/N, O par défaut)

MAJ_STK_SI_MODIF_PV

Modification des stocks si le prix de vente de la fiche produit a été modifié (O/N O par défaut)

Lorsqu'une commande est modifiée, les mouvements de stocks associés peuvent être mis à jour&

C'est le cas si le prix du mouvement ne correspond pas au prix de vente de la fiche produit.

Mais, ces nouveaux mouvements de stocks viennent perturber la logistique; on ajoute donc un paramètre pour ne pas générer de nouveaux stocks s'l n'y a que le prix de vente qui a été modifié.

MASQUE_REGRP_CDE_BL

21,60 Modes de regroupement commande/BL à masquer dans la fiche client

Chaque caractère saisi correspond au code du mode de regroupement qui sera masqué dans l'onglet Facturation de la fiche Client. Mémo

Exemple

MASQUE_REGRP_CDE_BL ON3

Dans cet exemple, on masquera les modes O, N et 3 (voir mémo ci-dessus)

Cette note est recherchée en priorité sur le programme de saisie des tiers ou de tout programme utilisant l'écran G_cli.

MENU_LANGUE_DEFAUT

Code langue par défaut à utiliser pour les libellés des menus (et uniquement ceux-ci)

Par défaut : fr

IMPORTANT : Le code langue par défaut pour les autres libellés affichés dans VoluPack (actions, messages, etc.) reste le code langue secondaire (A1[37,38]).

La note déclarée sur le USE est prioritaire à celle-ci.

MENU_NOTES_ENVIRON

Permettre de saisir et d'afficher les notes société du menu général par environnement.

N La saisie (si autorisée) et l'affichage des notes se feront globalement pour cet utilisateur (par défaut).

O La saisie (si autorisée) et l'affichage des notes se feront par rapport à l'environnement courant pour cet utilisateur.

S La saisie (si autorisée) des notes se fera par sélection de l'environnement.
L'affichage des notes se fera par rapport à l'environnement courant pour cet utilisateur.

Cette note existe aussi sur le USE, où elle est prioritaire.

Remarques

• Les notes affichées sur le menu sont uniquement celles saisies sur l'environnement courant

• Le paramétrage d'autorisation de saisie des notes est indépendant du paramétrage décrit sur cette fiche (note MENU_NOTES_SOCIETE du USE)

• L'environnement global (société) correspond au fonctionnement actuel (les notes saisies sont affichées pour tous les utilisateurs indépendamment de l'environnement)

• Rappel : L'environnement par défaut est l'environnement réel (n°0)

MENU_XXXXXXXXXX

Ces notes sont destinées au nouveau menu général.

Elles sont recherchées en priorité sur paramètre USE.

METHODE_CALC_ML

21 Méthode de calcul lors de la phase du chargement des palettes dans le camion

0 (ou vide) L'algorithme charge le camion tant que le nombre de palettes chargées dans le camion est strictement inférieur au nombre de palettes à charger. (par défaut)

1 L'algorithme charge le camion tant que le nombre de palettes chargées dans le camion est inférieur ou égal au nombre de palettes à charger.

METHODE_CALCUL_ESC

21 Méthode de calcul de l'escompte

1 Par défaut)

Base TVA = HT - ESC

TTC = HT ESC + TVA

2 2ème Méthode

Base TVA = HT - ESC

TTC = HT + TVA

Utilisé par tr_fcnn_vl et facn

MIGRATION_4JS

IMPORTANT : NE PLUS UTILISER CETTE NOTE !!!

MAJ_STK_RESUL_MVT_PR

21 Mise à jour du stock résultant des mouvements prévisionnels (O/N, O par défaut)

Si N, le stock résultant des mouvements prévisionnels sera à 0.

Cette fonctionnalité est active dans tous les modules créant des mouvements de stock.

MENU_SELECTION_USER

Voir description dans le paramètre USE.

MENU_SUP_SQL_USER

Voir description dans le paramètre USE.

MODE_CERTIFICATION

21 Certification forestière

C (ou vide) présence sur la fiche client (par défaut)

A présence sur la fiche article

M selon vente / achat
pour les ventes, la certification est prise sur la fiche article.
pour les achats, la certification est prise sur le fournisseur ou sur le couple fournisseur/code article (voir TSC FSC).

D présence sur la fiche client et sur la fiche article.
Pour les ventes, la certification sera prise en premier sur la fiche article. S'il n'y a rien, alors sur celle du client.
Si aucun des deux n'a de certification, alors l'article n'est pas certifié.

Nota : L'article pourra être initialisé par la certification présente sur le fiche client si celui-ci est rattaché à un client.

Voir le paramètre CRT

MODE_PAPETERIE

Mode papeterie (O/N, N par défaut)

Voir l'option Op1 dans la saisie de commande client.

MOT_PASSE_SUPP_MAINT

21,23 Mot de passe supplémentaire. Doit exister en tant que paramètre de type PWD.

Mot de passe supplémentaire pour l'accès au module de maintenance (touche CTRL-E).

OPTIMISE_LEC_FORMULE

21 Optimisation de la lecture des formules (O/N, O par défaut)

O Au premier lancement on lit les formules que l'on charge dans un tableau - Ensuite on travaille sur ce tableau.

N On lit les formules à chaque fois.

ORDER_RECH_ADR

21,60 Complément de tri sur la table cli2, pour la recherche d'adresses secondaires

Doit commencer par order by

Exemple

order by c2_adr asc

PARAM_DECLAR_PROD

21,26 Type et code du paramètre de lancement de la déclaration de production

Ce paramètre a priorité sur les paramètres de lancement des programmes suivants :

v_cdem

int_tbdata

exped_affretements

prep_affret

cde

v_stk0

PARAM_INDICE_ART_X

où X correspond à la première lettre du code article

21 à 22 Indice de début

24 à 25 Indice de fin

Exemple :

PARAM_INDICE_ART_E 10 12

Pour l'article E10000040002000, le compteur vaut 002 (caractères 10 à 12).

Lors de l'appel de la fonction, le stock de l'article E10000040001000 (dont l'indice est le précédent) sera affiché.

PARAM_REF_CLIENT

Nouvelle zone de référence d'entête commande cliente plus grande <VF>

Dans la saisie des commandes clients et/ou lors du transfert d'un devis en commande, via paramétrage, il est possible de saisir une deuxième référence client (ec_ref_2) sans contrainte de clé unique jusqu'à 30 caractères.

La première référence peut être masquée pour ne laisser que la deuxième référence visible dans les écrans.

Cette nouvelle zone est accessible dans les éditions VoluEdit et dans les visualisations.

ATTENTION : Ne mettre les caractères 21 ET 22 à N (simultanément) qu'en transfert de devis en commande ou en consultation !!!

21 Afficher ou Masquer la référence client 2 (ec_ref_2) (champs plus grand)

O Afficher

Dans ce cas, la référence client (ec_ref) est systématiquement renseignée avec le numéro de commande (ec_num).

N Masquer (par défaut)

22 Afficher ou Masquer la référence client (ec_ref)

O Afficher (valeur par défaut si la note n'est pas créée, ou qu'elle est créée avec les car. 21 & 22 vides)

N Masquer (valeur par défaut si la note est créée, ou qu'elle est créée avec le car. 21= O)

23, 24 Type d'aide sur saisie référence (facultatif)

01 Référence = Numéro de commande

02 Référence = Client Nombre de commandes

03 Référence = Client Millésime de la commande Nombre de commandes

Cette note est recherchée en priorité sur le paramètre de lancement des programmes suivants :

Saisie des commandes clients

Visualisation des commandes clients

Edition VoluEdit des AR

PARTIE_ENTIERE_QTE

21 Recherche du prix de cession avec la partie entière (sans arrondi) de la quantité (Blanc/N/O, N par défaut)

Dans le cadre du devis onduleur, possibilité de rechercher le prix de cession avec la partie entière (sans arrondi) de la quantité.

Le paramétrage peut être activé pour des environnements donnés (paramètre ETI) ou pour tous les environnements (paramètre #CF ATL).

Le paramétrage sur ETI est prioritaire au paramétrage sur #CF ATL.

Si la note sur le paramètre ETI est absente, la fonction recherchera la note sur le paramètre #CF ATL.

Si la note sur le paramètre ETI est présente, la fonction ne recherchera pas la note sur le paramètre #CF ATL quelle que soit la valeur paramétrée (Blanc, N ou O) sur le paramètre ETI.

PREFIX_DOCUMENT_xxx

Cette note est recherchée en priorité dans le paramètre de lancement du programme concerné.

Voir aussi la note CLE_DOCUMENT_xxx

PRIORITE A GENERO ACTIVEE

Active le lancement des programmes Genero correspondants, s'ils existent, pour l'utilisateur

Cette note est lue ici si elle n'est pas trouvée sur le paramètre USE.

RACINE_CLI

RACINE_FOU

RACINE_PRO

Définition des racines autorisées pour la numérotation automatique

12 à 60 Liste des racines possibles séparées par un espace

Exemple : RACINE_FOU F G H :

La numérotation fournisseur commencera par F, G, ou H.

Le F sera la racine par défaut car il apparaît en première position.

Voir alpha2[1,15] pour le paramétrage de la numérotation automatique et de la longueur de la racine.

Ces notes sont lues en priorité dans le paramètre de lancement du programme cli.

A défaut, elles sont lues ici.

La note RACINE_PRO est lue en priorité dans le paramètre de lancement du programme devis_standard.

A défaut, elle est lue ici.

REP_AIDE_LIGNE

21,60 Répertoire où se situe laide en ligne

Voir la page dédiée

REPERTOIRE_FICHIERS

Paramétrer par défaut un répertoire de destination des fichiers

21,60 Répertoire par défaut lors de lexport vers un fichier.

Ce paramétrage est actif pour toutes les visualisations.

La ligne de note R sur le paramètre de lancement de la visu est prioritaire.

SIMULATION_AN_SRES

21 Simuler la recherche de l'ancien stock résultant par un calcul sur stock (O/N)

Voir aussi l'option Off dans la saisie des mouvements de stock.

Lorsque le logiciel contrôle si la validation d'un nouveau mouvement de stock va provoquer un stock négatif, il s'appuie sur la fonction qui récupère l'ancien stock résultant à date.

Cette fonction suppose que le stock résultant de chaque mouvement de stock physique soit à jour, ce qui est paramétrable (A4[48]).

Pour les clients qui ne mettent pas à jour le stock résultant sur chacun des mouvements de stock, il est maintenant possible de recalculer ce stock résultant par un calcul sur les stocks.

SITES_XXX_YYY

Gestion de la sous-traitance entre sites - Tableau de bord du multisite

où XXX = site demandeur, YYY = site de fabrication

21 Génération de la FBI (O/N, N par défaut)

22 Commande facturable : le caractère 22 remplit les zones ec_afacturer et lc_afacturer de la FB2 générée (O/N, N par défaut)

23,25 Nombre de jours de délai entre les sites XXX et YYY

SUF_AIDE_LIGNE

21,25 Suffixe du nom du document dans le cas où celui-ci est construit.

Voir la page dédiée

Exemples

.docx, .pdf, ...

_SUP_ORDER_SOCIETE

21,60 Complément d'ordre de tri par défaut pour le choix des sociétés sur le menu VoluPack

Exemple _SUP_ORDER_SOCIETE order by so_code (ne pas oublier de rajouter le order by).

La même note existe sur le paramètre USE où elle est prioritaire.

_SUP_REQ_F7_ECH

21,60 Complément de requête pour interdire ou non les saisies libres des dates d'échéance

Exemple pour autoriser

_SUP_REQ_F7_ECH and 1=1

Exemple pour interdire

_SUP_REQ_F7_ECH and (p2_alph[41] is null

_SUP_REQ_F7_ECH or p2_alph[41] != "O")

_SUP_REQ_FAB_1_ETAT

21,60 Supplément de requête sur la table fab_1_etat lors de la vérification de la planification éventuelle d'une commande.

_SUP_REQ_GB_VISUF1E

21,60 Complément de sélection sur la table groupage_bl

_SUP_REQ_NOM0_VISNOM

21,60 Complément de requête sur la table mat. <VF>

Ce complément de requête intervient dans la visualisation de nomenclature.

Le même complément de requête existe sur le paramètre de lancement de la saisie des articles où il est prioritaire.

_SUP_SQL_SOCIETE

21,60 Complément de sélection par défaut pour le choix des sociétés sur le menu VoluPack

La même note existe sur le paramètre USE où elle est prioritaire.

TBDATA_AVEC_PARTIEL

21 Gestion du partiel dans la visualisation du TB-DATA (O/N, O par défaut)

ATTENTION, Ce paramétrage a été supprimé.

TITRE_MENU

21,60 Titre de la fenêtre des menus Genero, par défaut : Volupack menu

TRSP_REDUCTION_MLP

Calcul du métrage linéaire plancher

21 Activation de la gestion de la réduction du métrage linéaire plancher (O/N, N par défaut)

22,26 Largeur de palette Europe. Par défaut : 800 mm

Lors du calcul du métrage linéaire plancher (devis onduleurs, devis multi-métiers, préparation des affrètements, etc.), permet de réduire ce dernier en fonction du dernier rang chargé.

Principe de fonctionnement :

1. Une fois le calcul du métrage linéaire plancher optimum, on regarde si le dernier rang chargé est complet ou non.

2. S'il n'est pas complet, alors on réduit le métrage linéaire de la façon suivante :

MLP = MLP optimum - Longueur dernier rang + Longueur dernier rang X (Largeur dernier rang / Largeur camion).

Remarque : Cette règle n'est appliquée que si la place disponible sur le dernier rang est strictement supérieure à la largeur d'une palette Europe (800 mm par défaut, voir paramétrage ci-dessous)

Cette note est prise en priorité sur le paramètre de lancement de devis_standard, don, prep_affret, ...

TSC_CONFORMITE

Voir Opérations de contrôle et de maintenance

TSC_TRANS_NON_PART

21 à 23 Code TSC de transfert non partiel.

Lors du passage de la validité des produits de X à FAB, ce TSC sera créé sur chaque ligne de commande de fabrication.

TYPE_RECH_F7_CLI

Utilisable dans tout programme utilisant la recherche des tiers

Cette note est recherchée en priorité :

1) dans le paramètre de lancement (figurent dans le chapitre Généralités)

2) dans le #CF CLI

3) dans le #CF ATL (c'est ici)

Elle permet de spécifier le type et le code du programme de visualisation des tiers que l'on souhaite utiliser pour visualiser le résultat de la recherche des tiers par la fonction F7 dans tous les programmes.

21,26 Type et code du paramètre du programme de visualisation des tiers à utiliser pour visualiser le résultat de la recherche de tiers par la touche F7.

USING_CTRL_F

21 à 30 using à appliquer dans les quantités affichées dans le Ctrl F des commandes clients

USING_CTRL_F_ACH

21 à 30 using à appliquer aux quantités affichées dans le Ctrl F des commandes fournisseurs (#####&.&&& par défaut)

Exemple : ## ### ##&

VALIDITE_ENSEMBLE

21 à 23 Si les produits ont des validités différentes lors de la sauvegarde, la validité de l'ensemble sera initialisée avec ce code paramétré (sinon la validité de l'ensemble est égale à la validité des produits).

VSW_CONV_TABULATION

21 Nombre d'espaces à mettre lors de la conversation des tabulations en espaces. Par défaut : 8

Remarques

  1. La racine du code comptable est contenue dans la fiche par défaut du client, du prospect ou du fournisseur.

  2. Si code comptable sur le prospect par défaut initialisation du code à la création de la fiche

  3. Dans le fichier société, il faut paramétrer le type de compta pour que le code comptable de la fiche tiers soit alimenté en automatique


#CF BLV Bons de livraison

Valeurs numériques

3

Tolérance appliquée lors du contrôle de la quantité livrée exprimée en pourcentage

Utilisé par blv_ed1 option Ovq

Valeur alpha 1

Caractères 1 à 3

Type de paramètre de la zone site de production sur l'entête de bon de livraison (b1_sitp)

Tableau de bord du multisite

Caractères 4 à 12

Caractères 13 à 15

Type de mouvement de stock de sortie normale en saisie de BL

Caractères 16 à 18

Type de mouvement de stock en sortie normale (édition BL)

Caractères 19 à 21

Type de mouvement de stock en sortie réserve (saisie BL)

Caractère 22

Type de l'état des mouvements de transfert (2 ou N) (F7 détail palettes)

Caractères 23 à 25

Type du mouvement de sortie de transfert (en saisie de BL)

Caractères 26 à 28

Type du mouvement d'entrée de transfert (en saisie de BL)

Caractères 29 à 31

Type de mouvement de stock d'entrée normale en saisie de BL

Caractères 32 à 34

Type du mouvement de stock d'entrée normale en édition de BL.

Caractères 35 à 37

Type de mouvement de sortie de palette de picking. Exemple SPP

Caractères 38 à 40

Type de mouvement d'entrée de palette d'expédition. Exemple EPE

Par défaut (uniquement pour l'édition des BL) : EN

Caractères 41 à 43

Type de mouvement de sortie de palette d'expédition. Exemple SPE

Par défaut (uniquement pour l'édition des BL) : SN

Caractères 44 à 46

Type de mouvement d'entrée de palette d'expédition sur le lieu intermédiaire. EX : ELI

Caractère 47

Méthode de valorisation utilisée pour la ligne de bon de livraison

1 Première méthode de calcul de la valorisation

Si la livraison concerne un ensemble

Valeur BL = Quantité livrée X Prix de la ligne de commande / Unité de vente

Si la livraison concerne un composant

Valeur BL = Quantité livrée X Prix de la ligne de commande / 1000 X coefficient

où Coefficient = Somme des prix de revient prévisionnels des composants X Coefficient de nomenclature / Prix de revient prévisionnel du composant livré X Coefficient de nomenclature

N.B. : Le prix de revient prévisionnel doit être stocké aux 1000 sur la fiche article.

Caractère 48

Méthode de calcul pour la surface livrée

1 : Première méthode de calcul (Surface brute)

Pour une commande cartonnier :

Surface = Longueur X Largeur X Quantité livrée

Si le format de la ligne de commande n'est pas renseigné, on va chercher le format du produit livré : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

Pour une commande non cartonnier :

Surface = Surface unitaire brute X Quantité livrée

La surface unitaire brute est prise sur le TSC 201 Zone numérique 2 sur le produit livré : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

2 : Deuxième méthode de calcul (Surface nette)

Pour une commande cartonnier : Idem méthode 1, voir ci-dessus

Pour une commande non cartonnier :

Surface = Surface unitaire nette X Quantité livrée

La surface unitaire nette est prise sur le TSC 202 Zone numérique 2 sur le produit livré : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

Permet de calculer et d'enregistrer dans un champ de la table blv2 la surface (b2_surface) de la ligne de livraison.

Cette nouvelle zone est accessible dans les éditions VoluEdit et les visualisations permettant d'éditer les lignes de livraison.

Valeur alpha 2

Caractères 1 à 3 | Type de mouvement de stock pour la réintégration d'une palette commandée
Caractères 4 à 30 | Texte du libellé Site production Par défaut : libellé long du par01 du type de paramètre SIT Tableau de bord du multisite
Caractères 31 à 33 | Lieu de rangement 1 pour le mouvement d'entrée de palette d'expédition
Caractères 34 à 39 | Lieu de rangement 2 pour le mouvement d'entrée de palette d'expédition

Notes

MVT_TYPE_LIV_

Types de mouvement associés au type de livraison

14,16 Type de livraison, pouvant prendre les valeurs indiquées dans la fiche d'installation Mise à disposition et Consignation.

21,23 Type de mouvement sortie normale

24,26 Type de mouvement sortie réserve

27,29 Type de mouvement entrée normale

30,32 Type de mouvement d'entrée prévisionnelle

33,35 Type de mouvement de sortie normale d'un lieu de picking ou d'un lieu intermédiaire pour un transfert sur un lieu de transit
Si non renseigné,on utilise le type de mouvement de sortie normale (21,23).

36,38 Type de mouvement d'entrée normale sur un lieu de transit
Si non renseigné, on utilise le type de mouvement d'entrée normale (27,29).

NOTES_CONFORMITE

21 à 60 Notes de conformité

Remarques : Les notes de conformité peuvent être concaténées en utilisant ///

Par exemple :

Ligne 1 : Nous déclarons que la fourniture ///

Ligne 2 : citée est conforme.

On obtiendra à l'impression :

Nous déclarons que la fourniture citée est conforme.

Ces notes nécessitent la création du TSC .DC (char3_2) :

Libellé : Edition des notes

Valeur : O On édite des notes de conformité à la place du certificat de conformité

N On édite le certificat de conformité (par défaut)

S

2,60 Complément de select paramétrable pour la recherche des tarifs transporteur.

Exemple :

S and to_trans != "PROST"

SUP_REQ_CONSO

SPECIFIQUE

21,60 Complément de requête sur mat et nom0 pour les composants de nomenclature dont on veut cumuler le poids dans le Poids total brut.

Complémentaire avec la note SUP_REQ_CONSO du blv_ed1.

SUP_REQ_PAL

21,60 Complément de requête sur mat et nom0 pour la recherche du poids de palettisation

Ce complément de requête existe aussi sur le programme d'édition des BL (blv_ed1).

Il n'y a pas de priorité, les 2 compléments peuvent être utilisés et se compléter mutuellement.

TMV_ENT_PAL_CONSIG

21,23 Type de mouvement d'entrée en stock d'une palette consignée

Doit correspondre à un paramètre de type TMV avecA3[6] = T.

IMPORTANT : La présence de dette note conditionne la gestion du retour des palettes consignées dans la saisie des BL. Voir le suivi des palettes consignées

TMV_ENT_RETOUR_PDT

21,23 Type de mouvement d'entrée en stock d'un produit retourné

IMPORTANT : Ce paramétrage est obligatoire pour la gestion des retours de produits.

TMV_SOR_PAL_CONSIG

21,23 Type de mouvement de sortie de stock d'une palette consignée

Doit correspondre à un paramètre de type TMV avecA3[6] = T.

IMPORTANT : La présence de dette note conditionne la gestion du retour des palettes consignées dans la saisie des BL. Voir le suivi des palettes consignées


#CF BOB Configuration de la réception des bobines et des palettes

#CF BOB et #CF PAL Configuration de la réception des bobines et des palettes

Le type et le code ne sont pas figés : ils sont paramétrés dans la note CONFIG_RECEP_BOBINE des programmes suivants :

G_cdef

G_voluedit_edicf

G_recep_bob_cab

G_s_e_bob_cab

Voir la fiche d'installation pour les bobines Voir la fiche d'installation pour les palettes

Ce paramètre a été initialement créé pour les bobines.

Il a été ensuite adapté pour les palettes.

Les paramètres spécifiques aux bobines sont surlignés en gris,

tandis que les paramètres spécifiques aux palettes sont surlignés en vert.

Valeurs numériques

1

Type de réception autorisé - Facultatif

1 Réception des bobines (Valeur par défaut)

2 Réception des palettes

9 Réception des bobines et des palettes

Valeur alpha 1

#CF BOB A1[1,4] | Racine des articles bobines - Obligatoire La somme des longueurs de la racine et du folioteur des articles bobines ne doit pas être supérieure à 5 Exemple : B
#CF BOB A1[5] | Longueur du folioteur des articles bobines - Obligatoire La somme des longueurs de la racine et du folioteur des articles bobines ne doit pas être supérieure à 5 Exemple : 4
#CF BOB A1[6,20] | Article bobine par défaut - Obligatoire Exemple : 000000000000BOB
#CF BOB A1[21] | Type du mode de gestion du stock de la bobine (mp_param[17]) - Obligatoire 1 Mode de gestion du stock de l'article bobine par défaut 2 Mode de gestion du stock de l'article papier
#CF BOB A1[22] | Mode de gestion des lieux de rangement - Obligatoire 1 Lieux de rangement de l'article bobine par défaut 2 Lieux de rangement du paramètre de lancement
#CF BOB A1[23,25] | Lieu de rangement 1 de la bobine par défaut - Obligatoire si lieux de rangement du paramètre de lancement Exemple : USI
#CF BOB A1[26,31] | Lieu de rangement 2 de la bobine par défaut - Facultatif
#CF BOB A1[32,37] | Lieu de rangement 3 de la bobine par défaut - Facultatif
#CF BOB A1[38] | Type de libellé de la bobine - Obligatoire 1 Libellé du papier 2 Libellé spécifique fournisseur du papier
#CF BOB A1[39] | Mode d'alimentation de la table EDI - Facultatif N Pas d'alimentation (Valeur par défaut) O Alimentation

Valeur alpha 2

#CF BOB A2[1,3]

TSC article de la densité des bobines - Obligatoire

Exemple : BOB

#CF BOB A2[4]

Zone du TSC article de la densité des bobines - Obligatoire

1 ic_num1

2 ic_num2

3 ic_num3

Si les TSC article de la densité et du diamètre des bobines sont identiques, les zones des TSC doivent être différentes.

EX : 1

#CF BOB A2[5,11]

Densité des bobines par défaut - Obligatoire

Exemple : 0000760

#CF BOB A2[12,14]

TSC article du diamètre des bobines - Obligatoire

Exemple : BOB

#CF BOB A2[15]

Zone du TSC article du diamètre des bobines - Obligatoire

1 ic_num1

2 ic_num2

3 ic_num3

Si les TSC article de la densité et du diamètre des bobines sont identiques, les zones des TSC doivent être différentes.

#CF BOB A2[16,19]

Diamètre des bobines par défaut - Obligatoire

Exemple : 1500

#CF BOB A2[20,23]

Diamètre du mandrin - Obligatoire

EX : 0100

#CF BOB A2[24,26]

TSC bobine de stockage du numéro de mouvement de stock des bobines - Obligatoire

Ce TSC doit être différent des autres TSC paramétrés en A2 (surlignés en jaune pâle).

Exemple : MVT

Paramétrage de ce TSC :

Zone ic_num1 : Numéro du mouvement d'entrée en commande des bobines

Exemple : ZCMvt Entrée Cde N Z#####&

Zone ic_num2 : Numéro du mouvement d'entrée normale des bobines

Exemple : ZDMvt Entrée Nor.N Z#####&

#CF BOB A2[27,29]

pour les BOBINES

TSC fournisseur de création des bobines et d'édition des étiquettes de bobine - Obligatoire

Ce TSC doit être différent des TSC paramétrés en valeur alpha 2.

Exemple : B-E

Paramétrage de ce TSC :

Zone ic_char3_1 : Type de paramètre de création des bobines et d'édition des étiquettes de bobine

Exemple : ZFBob. - Etiq. N01BETN

Dans cet exemple, on fait référence au paramètre de type BET.

Créez ce type de paramètre avec le code de votre choix et le paramétrage suivant :

Libellé long Bobines + Etiquettes

Libellé abrégé Bob + Etiq

Valeur numérique 1 : Création des bobines et d'édition des étiquettes de bobine

1 Création des bobines (par défaut)

2 Création des bobines et édition des étiquettes de bobine

3 Pas de création des bobines ni d'édition des étiquettes de bobine

Zone ic_char3_2 : Type de paramètre de scénario de saisie des CAB des bobines

Exemple : ZHCAB. - Bob. N01C-BN

Dans cet exemple, on fait référence au paramètre de type C-B.

Créez ce type de paramètre avec le code de votre choix (par exemple 201) et le paramétrage suivant :

Libellé long Scénario 201

Libellé abrégé Scén. 201

Valeur numérique 1 : Nombre de CAB à flasher

Note CABTIT 7,8 Numéro du CAB (1 à 10)

9,60 Nom zone*Titre zone*Réinitialisation zone*

Nom zone

titre (seule valeur autorisée)

Titre zone

Titre du CAB

Réinitialisation zone

(O/N, O par défaut)

Note CABDEC 7,8 Numéro du CAB (1 à 10)

9,60 Nom zone*Début zone*Fin zone*

Nom zone

code_bobine Code bobine

code_bobine_four Code bobine fournisseur

largeur_bobine Largeur bobine

longueur_bobine Longueur bobine

poids_bobine Poids bobine

code_papier Code papier

laize_papier Laize papier

grammage_papier Grammage papier

numero_commande Numéro de commande

ligne_commande Ligne de commande

Début zone

Position de début de la zone

Fin zone

Position de fin de la zone

Note

Le code bobine fournisseur est stocké dans la zone le_libpar1 de la table lib_etr de l'article bobine.

Le code papier du CAB est par défaut un code papier fournisseur.

On recherche si celui-ci est présent dans la table lib_etr pour le fournisseur réceptionné.

Le code papier fournisseur est stocké dans la zone le_libelle2 de la table lib_etr.

Si aucun papier trouvé, le code papier du CAB est le code papier VoluPack.

Si un papier a été trouvé, le code produit stocké dans la zone le_prod de la table lib_etr est le code papier VoluPack.

Exemples

CABTIT1 titre*CAB Bobine*

CABDEC1 code_bobine*1*15*

CABDEC1 largeur_bobine*16*21*

CABDEC1 longueur_bobine*22*27*

CABDEC1 poids_bobine*28*33*

CABTIT2 titre*CAB Papier*

CABDEC2 code_papier*1*15*

CABDEC2 laize_papier*16*21*

CABDEC2 grammage_papier*22*27*

CABTIT3 titre*CAB Commande*N*

CABDEC3 numero_commande*1*8*

CABDEC3 ligne_commande*9*12*

#CF BOB A2[27,29]

pour les PALETTES

TSC fournisseur de scénario de saisie des CAB des palettes - Obligatoire

Exemple : SCP

Paramétrage de ce TSC :

Zone ic_char30 : Type de paramètre de scénario de saisie des CAB des palettes

Exemple : CAB. - Pal. N01C-PN

Dans cet exemple, on fait référence au paramètre de type C-P.

Créez ce type de paramètre avec le code de votre choix (par exemple 201) et le paramétrage suivant :

Libellé long Scénario 201

Libellé abrégé Scén. 201

Valeur numérique 1 : Nombre de CAB à flasher

Note CABTIT 7,8 Numéro du CAB (1 à 10)

9,60 Nom zone*Titre zone*Réinitialisation zone*

Nom zone

titre (seule valeur autorisée)

Titre zone

Titre du CAB

Réinitialisation zone

(O/N, O par défaut)

Note CABDEC 7,8 Numéro du CAB (1 à 10)

9,60 Nom zone*Début zone*Fin zone*

Nom zone

code_cab_etiq_four CAB étiquette

quantite_papier Quantité papier

poids_papier Poids papier

coupe_papier Coupe papier

code_papier Code papier

laize_papier Laize papier

grammage_papier Grammage papier

numero_commande Numéro de commande

ligne_commande Ligne de commande

Début zone

Position de début de la zone

Fin zone

Position de fin de la zone

Notes

Le code papier du CAB est par défaut un code papier fournisseur.

On recherche si celui-ci est présent dans la table lib_etr pour le fournisseur réceptionné.

Le code papier fournisseur est stocké dans la zone le_libelle2 de la table lib_etr.

Si aucun papier trouvé, le code papier du CAB est le code papier VoluPack.

Si un papier a été trouvé, le code produit stocké dans la zone le_prod de la table lib_etr est est le code papier VoluPack.

Le poids papier du CAB est divisé par 1000.

Le code CAB de l'étiquette fournisseur est stocké dans la zone etp_cab_3 de la table etiqprod lors de la création de l'étiquette.

C'est ce code CAB qui est utilisé pour vérifier si la palette n'a pas été déjà réceptionnée.

Exemples

# 1) Commande Fournisseur

CABTIT1 titre*Commande Fourn.*N*

CABDEC1 numero_commande*1*8*

# 2) Code barre scanné

CABTIT2 titre*CAB en haut*

CABDEC2 code_papier*1*5*

CABDEC2 grammage_papier*3*5*

CABDEC2 quantite_papier*6*9*

CABDEC2 poids_papier*10*15*

CABDEC2 laize_papier*16*19*

CABDEC2 coupe_papier*20*23*

# 3) CAB étiquette fournisseur

CABTIT3 titre*CAB étiquette four.*

CABDEC3 code_cab_etiq_four*1*10*

#CF BOB A2[30,32]

Lieu de rangement 1 de la palette par défaut - Obligatoire - Exemple : USP

#CF BOB A2[33,38]

Lieu de rangement 2 de la palette par défaut - Facultatif

#CF BOB A2[39,44]

Lieu de rangement 3 de la palette par défaut - Facultatif

#CF BOB A2[45]

Structure du conteneur

1 Structure du conteneur standard (PANNNNNNNLLL-CCC-PPPP) (par défaut)

2 Le Conteneur = CAB saisi ou scanné
L'option Oea sera automatiquement positionnée dans la saisie des bons de réception. Elle permet d’éditer les étiquettes achats.
Dans ce cas, les étiquettes achats seront uniquement créées dans la table etiqprod, la palette étant retrouvée par le champ etp_cab_3.

#CF BOB A2[46,49]

Racine du code palette (exemple P)

Uniquement si #CF BOB A2[45] = 2

#CF BOB A2[50,51]

Longueur du folio du code palette (exemple 5)

Uniquement si #CF BOB A2[45] = 2

Avec une racine P et une longueur de 5, les codes palettes auront une structure : P00001 à P99999.


#CF CAB Codes barres

Utilisé entre autres dans

la déclaration de production par codes-barres (qte_prod)

la saisie des inventaires par codes-barres (saisie_inventaire_cab)

les corrections de stocks (maj_stk)

la préparation des commandes d'achat par codes-barres (prep_cde_cab)

la saisie des mouvements manuels de palette (mvt_manuel_cab)

le transfert d'emplacement de palette (tran_empl_cab)

le changement d'état d'une palette (change_etat_pal_cab)

la régularisation de la quantité informatique en stock (regularisation_stock_cab)

la saisie des bons de livraison (blv)

Voir aussi le paramètre de saisie CAB.

Valeurs numériques

#CF CAB N1 | N'est plus utilisé. Voir la note LG_EMPLACEMENT_1_2
#CF CAB N2 | Longueur du code à barres
#CF CAB N3 | Début de la zone du numéro de palette ou de bobine Ce paramétrage existe aussi dans le programme de saisie de correction de stock.
#CF CAB N4 | Fin de la zone du numéro de palette ou de bobine

Dans l'option papeterie, le CAB est construit avec le numéro de l'OF du système planificateur (8 caractères) et d'un numéro de bobine (4 caractères).

Valeur alpha 1

#CF CAB A1[1]

Saisie d'un numéro d'étiquette à la place d'un code barres (O/N, N par défaut)

O Le numéro du conteneur est le numéro de CAB qui est sur l'étiquette de la palette.

La valeur est forcée à O si so_options[40] et so_options[44] sont tous les 2 à O.

N Le numéro du conteneur est standard au CAB de PCTOPP.

#CF CAB A1[2]

L I B R E - L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E

#CF CAB A1[3]

Gestion de la quantité par caisse et du nombre de caisses par palette

N Non (Valeur par défaut)

O Oui (palette homogène en quantité par caisse)

D Détail (palette hétérogène en quantité par caisse)

Note : en détail, la table conteneur_prod_det est alimentée.

#CF CAB A1[4]

La touche ESC est-elle utilisable pour sortir des programmes CAB si l'on se trouve sur le 1er champ de saisie ? (O/N, N par défaut)

#CF CAB A1[5]

Scan ou saisie de l'emplacement en 3 temps (Magasin + Emplacement 1 + Emplacement 2)

La saisie du magasin est facultative. Le magasin d'origine étant affiché par défaut.

#CF CAB A1[6]

Gestion de la palette de prélèvement activée (O/N, N par défaut)

Si N : PAS de gestion de la palette de prélèvement, les champs liés à ce paramètre sont masqués.

Voir v_groupage_bl A4[15]

#CF CAB A1[7]

Gestion des stocks à la palette identifiée - Gestion des ensembles montés

N Le conteneur est sur la commande commerciale pour un ensemble monté (mp_param[22] = M)

O Le conteneur est sur la FBI su 1er élément de l'ensemble pour un ensemble monté (mp_param[22] = M)

#CF CAB A1[8]

Mode d'initialisation du numéro de lot

1 Numéro de lot =

numéro de commande [tiret] numéro de ligne au format &&&

2 Numéro de lot =

numéro de commande de rattachement [tiret] ligne de commande de rattachement au format &&&

#CF CAB A1[9,10]

Nombre maximum de lignes dans la fenêtre de saisie du détail Caisse (3 par défaut)

#CF CAB A1[11,12]

Nombre maximum de caisses en prélèvement (1 par défaut)

#CF CAB A1[13]

Initialiser le code à barres avec le numéro de FBI + un compteur sur 4 chiffres (O/N, N par défaut)

Vérifie si le début du code à barres saisi manuellement correspond au numéro FBI.

Permet de vérifier si l'étiquette existe déjà; si oui, alors l'utilisateur sera informé du dernier numéro d'étiquette.

#CF CAB A1[14]

Saisie des emplacements (magasin et emplacement) (O/N, N par défaut)

Valeur alpha 2

#CF CAB A2[1,10]

Remplacement du mot Caisse par un mot paramétré ici.

Ceci est valable pour les programmes suivants :

blv Saisie BL dégradé

change_etat_pal_cab Changement état cab

mvt_manuel_cab Sortie destruction

qte_prod Déclaration prod CAB

regularisation_stock_cab Régul stock CAB

Transfert emplacement

Exemple : Colis

Notes

LG_EMPLACEMENT_1_2 | 21 Longueur de l'emplacement 1 22 Longueur de l'emplacement 2 23 Redimensionnement de l'emplacement 1 (O/N, N par défaut) O Dans le programme de transfert d'emplacement, si on redimensionne l'emplacement 1 et que la longueur est inférieure à 3, on ne pourra plus saisir automatiquement le magasin dans cette zone.
_USING_CONTENEUR | 21,35 Paramétrage du using pour le conteneur Ce paramétrage n'est utilisé que si le numéro de conteneur est identique au CAB Voir #CF CAB A1[1] ci-dessus. Utilisé aussi pour la papeterie


#CF CAR Carton

Valeur alpha 1

Caractères 1 à 3 | Code UNITE de tarif cartonnier
Caractère 4 | Correspondance de la laize avec la largeur de la fiche article N La laize correspond à la longueur O La laize correspond à la largeur (par défaut) Actuellement utilisable dans - Devis transformateur (devis_tc) - Saisie des matières consommées associées à une ligne de commande (f_saitcde5) - La génération de commande fournisseur (gen_cdef) - La génération des articles plaques (f_genart*) - Création code papier et stock (cre_papier_stock) D'autres modules utilisent systématiquement la largeur de la fiche article en tant que laize : - Fenêtre de saisie des refoulages en saisie des commandes fournisseur (cdef) - Saisie des consommations carton en saisie des temps code barres (sbs)
Caractère 5 | Méthode de recherche du composant palette N Par la nomenclature

Notes triées

CLIENTNOMENCLATURE

Définition du client nomenclature (ex : #SOC)

PREFIX_CAI

21,30 Préfixe du code caisse VoluPack

PREFIX_PAL

21,30 Préfixe du code palette VoluPack

PREFIXE_PAPIER

21,60 Préfixe papier pour la recherche qualité carton

SUPREQACC

21,60 Supplément de requête pour la recherche des accessoires

SUPREQCOMCAR

21,60 Supplément de requête pour la recherche de la composition carton

SUPREQCOUIMP

21,60 Supplément de requête sur la table nom0

SUPREQFORDEC

21,60 Supplément de requête sur la table

SUPREQPAL

21,60 Supplément de requête pour la recherche des palettes

SUPREQPF

21,60 Supplément de requête sur mat pour la recherche de la référence PF

SUPREQQUACAR

21,60 Supplément de requête pour la recherche de la qualité carton

SUPREQREFARC

21,60 Supplément de requête pour la recherche du code conception

SUPREQREFDEC

21,60 Supplément de requête pour la recherche du code découpe

SUPREQREFIMP

21,60 Supplément de requête pour la recherche de la référence d'impression

SUPREQREFODV

21,60 Supplément de requête pour la recherche de l'ensemble

SUPREQREFPRE

21,60 Supplément de requête pour la recherche de la référence de pré-impression

SURFACE_MINI

21,36 Surface minimum à commander

37 Contrôle de la surface minimum à commander en fonction de la surface brute minimale des composants de l'article composition (O/N, N par défaut)

Si O : vous devez indiquer un type de notes en car.38,40.

Si N : le contrôle est effectué sur la surface saisie en caractères 21,36.

38,40 Type de notes à saisir en cas de forçage du contrôle de la surface minimum à commander (seulement si le caractère 37 = O).

Voir la saisie de commande client, A4[30]


#CF CBF Commandes BL Factures

LIGPARCACommande : *lf_num*8*

LIGPARCA - *lf_lig*3*<<&*

LIGPARCAProduit : *lf_prod*15*

LIGPARCATYF : *ef_tyc*3*

LIGPARCA - : *libl_ef_tyc*25*

LIGPARCAMode reglt : *ef_mrg*3*

LIGPARCA - : *libl_ef_mrg*25*

LIGPARCA date création : *ef_datc*10*dd/mm/yyyy*

LIGPARCAAcheteur : *ef_ach*3*

LIGPARCA - : *libl_ef_ach*25*

LIGPARCCTYC*ec_tyc*3*

LIGPARCCDélai de fabrication : *lc_delfab*10*dd/mm/yyyy*

LIGPARCCReprésentant : *lc_repr*3*

LIGPARCCPoids : *lc_poids*10*### ###.&&*

LIGPARCCCode stat 1 : *lc_cs1*3*

LIGPARCCLongueur : *lc_long*10*### ###.&&*

LIGPARCCLargeur : *lc_larg*10*### ###.&&*

LIGPARCCRemise : *lc_rem*10*### ###.&&*

LIGPARCCSurface : *lc_surface*10*### ###.&&*

LIGPARCCDevis : *lc_dev*8*

LIGPARCCSdevis : *lc_sdev*3*<<&*

LIGPARCCLibellé : *lc_lib*40*

LIGPARCCQuantité fabriquée : *lc_qtefab*10*### ###.&&*

LIGPARCCFamille : *lc_fam*3*

LIGPARCCS/famille : *lc_sfm*3*

LIGPARCCPrix commande : *lc_prx*10*### ###.&&*

LIGPARCCUnité de vente : *lc_unvent*3*

LIGPARCC-*libl_lc_unvent*25*

LIGPARCRTYC*ec_tyc*3*

LIGPARCRCommande : *lc_num*8*

LIGPARCRLigne : *lc_lig*3*##&*

LIGPARCRUnité de vente : *lc_unvent*3*

LIGPARCRDélai de fabrication : *lc_delfab*10*dd/mm/yyyy*

LIGPARCRReprésentant : *lc_repr*3*

LIGPARCRPoids : *lc_poids*10*### ###.&&*

LIGPARCRLongueur : *lc_long*10*### ###.&&*

LIGPARCRLargeur : *lc_larg*10*### ###.&&*

LIGPARCRRemise : *lc_rem*10*### ###.&&*

LIGPARCRLibellé : *lc_lib*40*

LIGPARCRQuantité fabriquée : *lc_qtefab*10*### ###.&&*

LIGPARCrTYC*ec_tyc*3*

LIGPARCrCommande : *lc_num*8*

LIGPARCrLigne : *lc_lig*3*##&*

LIGPARCrUnité de vente : *lc_unvent*3*

LIGPARCrDélai de fabrication : *lc_delfab*10*dd/mm/yyyy*

LIGPARCrReprésentant : *lc_repr*3*

LIGPARCrPoids : *lc_poids*10*### ###.&&*

LIGPARCrRemise : *lc_rem*10*### ###.&&*

LIGPARCrLibellé : *lc_lib*40*

LIGPARCrQuantité fabriquée : *lc_qtefab*10*### ###.&&*

LIGPARCrFamille : *lc_fam*3*

LIGPARCrS/famille : *lc_sfm*3*

LIGPARCBClient : *b1_cli*6*

LIGPARCBTransporteur : *b1_trans*6*

LIGPARCBRéférence : *b1_ref*15*

LIGPARCBVéhicule : *b1_vehicule*12*

LIGPARCBType Port : *b1_tport*3*

LIGPARCBLibellé type Port : *libc_b1_tport*10*

LIGPARCBPoids ligne : *b2_poids*10*### ###.&&*

LIGPARCBNombre colis : *b2_nbcolis*5*####&*

LIGPARCBSurface ligne : *b2_surface*10*### ###.&&*

LIGPARCbClient : *br1_client*6*

LIGPARCbType : *br1_type*3*

LIGPARCb- *libl_br1_type*25*

LIGPARCbBon livraison : *br1_numero_bl*8*

LIGPARCbTransporteur : *br1_transporteur*6*

LIGPARCbType Véhicule : *br1_type_vehicule*3*

LIGPARCb- *libl_br1_type_vehicule*25*

LIGPARCbMotif : *br2_motif_retour*3*

LIGPARCb- *libl_br2_motif_retour*25*

LIGPARCbQuantité : *br2_qte_totale*10*### ###.&&*

LIGPARCF Devise :*fe_dev*3*

LIGPARCF - *libl_fe_dev*25*

LIGPARCF Unité : *fl_unvent*3*

LIGPARCF - *libl_fl_unvent*25*

LIGPARCF Compte : *fe_cpt*17*

LIGPARCF Remise : *fl_rem*5*&&.&&*

LIGPARCF Traite : *fl_trait*1*

LIGPARCF Poids ligne : *fl_poids*10*### ###.&&*

#CF CBF Commandes BL Factures

Visualisation des BL et des factures d'une commande

Sur ce nouvel écran (accessible par Ctrl F), on visualise d'un seul coup d'œil :

  • La présence de commande d’achat

  • La présence de commande de rattachement

  • La commande commerciale

  • La présence de commande rattachée

  • Le bon de livraison ou de retour ou de transfert

  • La facture

Affichage d’information de la commande d'achat dans un bloc détail dédié

Accès possible à la commande d'achat

Affichage d'information de la commande de rattachement dans un bloc détail dédié

Lancement possible de la visualisation des BL/factures pour cette commande

Affichage d'information de la commande commerciale dans un bloc détail dédié

Affichage d'information de la commande rattachée dans un bloc détail dédié

Lancement possible de la visualisation des BL/factures pour cette commande

Affichage d'information du bon de livraison ou de transfert ou de retour dans un bloc détail

Accès possible au bon de livraison ou de retour dédié

Affichage d'information de la facture dans un bloc détail dédié

Accès possible à la facture

Les détails des différents blocs sont paramétrables sur les paramètres de lancement ou bien dans un paramètre réservé (#CF CBF).

Ce nouvel écran est accessible par un paramétrage sur le #CF ATL.

Notes sur le paramètre de lancement ou sur le #CF CBF

Les notes suivantes sont recherchées en priorité sur le paramètre de lancement, puis sur le #CF CBF.

Tous les programmes ayant accès à la visu des BL et factures d'une commande sont concernés, notamment :

aid_fac

blv

cde

v_mat

devis_standard

v_fle

v_prostk

v_fac

v_edi_cde

v_edi_cde_delfor

tr_l_cde

cocde

gestion_outils_sui

prep_affret_nexp

v_cdem

v_edi_cde

v_fac

v_groupage_bl

v_jbl

v_jdv

v_fac

Paramétrage de la ligne d'affichage (dans le Control-F) sous la forme suivante : LLL*CCC*TTT*UUU*

LLL Libellé affichable à l'écran

CCC Liste des champs visualisables (dépend du bloc choisi)

TTT Taille de la zone

UUU Using de la zone

Exemple pour le bloc commande commerciale

LIGPARCCReprésentant : *lc_repr*3*

Astuce

Si le titre est limité au caractère - (signe moins), cela indique un caractère de concaténation.

Exemple

LIGPARCCUnité de vente : *lc_unvent*3*

LIGPARCC -*libl_lc_unvent*25*

L'unité de vente et le libellé seront concaténés. Résultat :

Unité de vente : CEN-aux cent pièces

Cliquez ici pour afficher / masquer des exemples de paramétrage

LIGPARCA | 9,60 Paramétrage des zones de détail des achats - 12 zones possibles Sont accessibles toutes les zones des tables cdf1 et cdf2 Voir les infos au-dessus de ce tableau.
LIGPARCB | 9,60 Paramétrage des zones de détail des bons de livraison - 12 zones possibles Sont accessibles toutes les zones des tables blv1 et blv2 Voir les infos au-dessus de ce tableau.
LIGPARCb | 9,60 Paramétrage des zones de détail des bons de retour - 12 zones possibles Sont accessibles toutes les zones des tables bon_retour_cli_1 et bon_retour_cli_2 Voir les infos au-dessus de ce tableau.
LIGPARCC | 9,60 Paramétrage des zones de détail des commandes commerciales - 18 zones possibles Sont accessibles toutes les zones des tables cde1 et cde2 Voir les infos au-dessus de ce tableau.
LIGPARCF | 9,60 Paramétrage des zones de détail des factures - 12 zones possibles Sont accessibles toutes les zones des tables fac0 et fac1 Voir les infos au-dessus de ce tableau.
LIGPARCR | 9,60 Paramétrage des zones de détail des commandes de rattachements - 12 zones possibles Sont accessibles toutes les zones des tables cde1 et cde2 Voir les infos au-dessus de ce tableau.
LIGPARCr | 9,60 Paramétrage des zones de détail des commandes rattachées - 12 zones possibles Sont accessibles toutes les zones des tables cde1 et cde2 Voir les infos au-dessus de ce tableau.

Notes sur le #CF CBF

AFFICHAGE_GB_ACH | 21 Affichage du bloc détail des achats (O/N, O par défaut)
AFFICHAGE_GB_BL | 21 Affichage du bloc détail des bons de livraisons (O/N, O par défaut)
AFFICHAGE_GB_CDR | 21 Affichage du bloc détail des commandes de rattachement (O/N, O par défaut)
AFFICHAGE_GB_CDr | 21 Affichage du bloc détail des commandes rattachées (O/N, O par défaut)
AFFICHAGE_GB_FAC | 21 Affichage du bloc détail des factures (O/N, O par défaut)

Autres paramètres

#CF ATL | A2[18] = X : Accès au nouvel écran de visualisation des BL et factures Notes ACCES_ACHAT ACCES_FACTURE ACCES_BL ACCES_BR
Permissions | TOU CBF_ACC_ACH CBF_ACC_BL CBF_ACC_BR CBF_ACC_FAC


#CF CBN Calcul des besoins nets

Valeur alpha 1

Caractères 1 à 10

Date du début de période du dernier calcul des besoins lancé.


#CF CDE Commandes clients

Valeur numérique 1

Numéro de compteur des commandes créées dans VoluGold par un événement

Valeur alpha 1

#CF CDE A1[1,3]

Type du paramètre ec_c1 (entête de commande)

#CF CDE A1[4,6]

Type du paramètre associé au champ lc_p1 de la ligne de commande

ATTENTION Le type paramètre STK est réservé

La saisie des caractères 4 à 6 entraîne l' ouverture de la fenêtre donnée technique 1 sur les lignes de commande et le libellé saisi est affiché.

#CF CDE A1[7,9]

Type du paramètre associé au champ lc_p2 de la ligne de commande

La saisie des caractères 7 à 9 entraîne l' ouverture de la fenêtre donnée technique 1 sur les lignes de commande et le libellé saisi est affiché.

#CF CDE A1[10,12]

Type du paramètre associé au champ lc_p3 de la ligne de commande

Contrôle sur quel fichier (dans la revue de contrat)

AUT Référence client

CAR Qualité carton

CLI Client

DAT Date d'avenant

LIV Livraison

MAT matière

REF Référence de commande client

XXX Zone sans contrôle

.TL (TSC)

La valeur que vous indiquez ici sera remplacée par la valeur spécifiée dans les caractères 26 à 28 de la note DT1 du TYC, quand le caractère 4 de cette note = 3 (champ lc_p3).

#CF CDE A1[13]

Ouverture ou non de la fenêtre prix pour les codes suivants du paramètre ec_c1

O Oui

Autres Non

#CF CDE A1[14,16]

#CF CDE A1[17,19]

#CF CDE A1[20,22]

Code 1 du paramètre ec_c1 (entête)

Code 2 du paramètre ec_c1 (entête)

Code 3 du paramètre ec_c1 (entête)

L'un de ces 3 codes peut être saisi dans l'entête de commande (ec_c1) ce qui permet d'ouvrir la fenêtre de saisie d'une des zones paramétrées dans les lignes de commande (lc_p1, lc_p2 et lc_p3).

#CF CDE A1[23,25]

Type de mouvement de stock en sortie normale

#CF CDE A1[26,28]

Type de mouvement de stock en sortie réserve

#CF CDE A1[29,31]

Type de mouvement de stock en entrée prévisionnelle

#CF CDE A1[32]

Possibilité de saisir la catégorie du produit dans la fenêtre activée par la touche F23 sur la ligne de commande. (Paramètre MAT)

Catégorie du produit prise dans mp_libre de la table MAT et mise dans lc_p1 de la table cde2

O Oui

Autres Non

ATTENTION Ne pas l'utiliser si valeurs 4 à 12

#CF CDE A1[33]

Type d'enregistrement de la table hist_pr (hp_type C, F ...)

#CF CDE A1[34,35]

No de la zone prix de revient de la table hist_pr (hp_zn 01 à 15)

#CF CDE A1[36,38]

Type de mouvement de stock en entrée normale

#CF CDE A1[39]

Type de recherche F7 sur produit

1 Recherche normale et par défaut (desg,fam,...)

2 Recherche données techniques

3 Recherche spécifique papier

Q Recherche qualité

T Recherche Transformateur

#CF CDE A1[40,47]

Contrôle de saisie des champs paramétrables

N Saisie facultative

W Warning

B Saisie obligatoire

#CF CDE A1[40]

Champs paramétrable 1 (lc_p1)

#CF CDE A1[41]

Champs paramétrable 2 (lc_p2)

#CF CDE A1[42]

Champs paramétrable 3 (lc_p3)

#CF CDE A1[43]

Champs longueur

#CF CDE A1[44]

Champs largeur

#CF CDE A1[45]

Champs hauteur

#CF CDE A1[46]

Champs poids

#CF CDE A1[47]

Champs prix client

#CF CDE A1[48]

Type de complément de recherche F7 sur produit

1 Complément de recherche sur le client de la table des libellés spécifiques (lib_etr.le_client) avec le client de l'entête de la commande

2 Complément de recherche sur le client de la table des articles (mat.mp_cli) avec le client de l'entête de la commande. Le F7 présente uniquement les articles du client.

3 Le F7 présente uniquement les articles du client ET les articles qui ne sont pas associés à un client.

4 Aucun complément (recherche standard des articles)

5 Le F7 présente uniquement les articles du contrat lié à la commande en cours

6 Le F7 présente uniquement les articles dont les codes génériques sont les articles du contrat lié à la commande en cours.

L'ordre de priorité est le suivant :

1) Saisie des commandes clients, option Ofc

2) LIE A1[6]

3) #CF CDE A1[48] (ici)

#CF CDE A1[49]

Contrôle de saisie d'un prix a zéro

N Pas de contrôle

W Warning

C Fenêtre de confirmation

B Saisie obligatoire

#CF CDE A1[50]

Contrôle client article avec client commande si client article saisi

N Pas de contrôle

W Warning si clients différents

C Fenêtre de confirmation si clients différents

B Anomalie bloquante si clients différents

Valeur alpha 2

#CF CDE A2[1,20] | Champs Longueur La saisie des caractères 1 à 20 entraîne l'ouverture de la fenêtre donnée technique 2 sur les lignes de commande et le libellé saisi est affiché.
#CF CDE A2[21,40] | Champs Largeur La saisie des caractères 21 à 40 entraîne l'ouverture de la fenêtre donnée technique 2 sur les lignes de commande et le libellé saisi est affiché.
#CF CDE A2[41,60] | Champs Prix client La saisie des caractères 41 à60 entraîne l'ouverture de la fenêtre donnée technique 2 sur les lignes de commande et le libellé saisi est affiche

Valeur alpha 3

#CF CDE A3[1,20]

Champ Hauteur

La saisie des caractères 1 à 20 entraîne l'ouverture de la fenêtre donnée technique 2 sur les lignes de commande et le libellé saisi est affiché.

#CF CDE A3[21,29]

Champs Poids/Grammage

La saisie des caractères 21 a 29 entraîne l'ouverture de la fenêtre donnée technique 2 sur les lignes de commande et le libellé saisi est affiche

#CF CDE A3[30]

Contrôle s'il existe des lignes de commande avec des codes TVA différents

N Pas de contrôle

W Warning si code TVA différent

C Fenêtre de confirmation si code TVA différent

B Anomalie bloquante si code TVA différent

#CF CDE A3[31]

Contrôle sur le numéro de devis / sous-devis

N ou [blanc] Aucun contrôle n'est effectué

1 Contrôle de l'existence du devis. Modification autorisée si la ligne de commande n'est pas générée.

2 Modification autorisée si la ligne de commande est générée mais aucune remontée n'est effectuée.

NB ne pas utiliser pour le devis reliure.

#CF CDE A3[32,33]

Contrôle sur la saisie de la famille, sous-famille

N ou blanc Aucun contrôle n'est effectué

W Warning

B Bloquant

#CF CDE A3[34,35]

Nombre de jours pour le contrôle de la date de fin de validité de l' offre de vente.

Contrôle Date fin de validité de l'offre Date du jour Nombre de jours.

#CF CDE A3[36]

Alimentation automatique de la zone lot de la ligne de commande

N Pas d'alimentation automatique

1 Numérotation automatique du lot par compteur

2 Numérotation automatique du lot identique au lot du stock

#CF CDE A3[37,38]

Racine du code TSC de stockage des codes blocages de la revue de contrat (exemple RC)

#CF CDE A3[39]

Saisie du champs Issue de (Origine de la commande) sur l'entête de commande (O/N, N par défaut)

#CF CDE A3[40,42]

Type de mouvement de stock en entrée prévisionnelle sur lieu intermédiaire

(si celui du TYC n'existe pas)

#CF CDE A3[43]

Date des mouvements de stocks de la FBI générée

0 (zéro) ou [espace] Délai répondu de la ligne de la FBI

1 Délai de fin de fabrication de la ligne de la FBI.

#CF CDE A3[44,46]

Type de mouvement de stock en sortie besoin

#CF CDE A3[47,49]

Type de mouvement de stock en entrée pour saisie BL prévisionnelle sur lieu intermédiaire

#CF CDE A3[50]

Code statistique CS1 obligatoire en saisie d'une ligne de commande (O/N, N par défaut)

La note CTRL_CODE_CS_1 sur le TYC a priorité sur ce paramétrage

#CF CDE A3[51]

Code statistique CS2 obligatoire en saisie d'une ligne de commande (O/N, N par défaut)

La note CTRL_CODE_CS_2 sur le TYC a priorité sur ce paramétrage

#CF CDE A3[52]

Code statistique CS3 obligatoire en saisie d'une ligne de commande (O/N, N par défaut)

La note CTRL_CODE_CS_3 sur le TYC a priorité sur ce paramétrage

#CF CDE A3[53]

Code statistique CS4 obligatoire en saisie d'une ligne de commande (O/N, N par défaut)

La note CTRL_CODE_CS_4 sur le TYC a priorité sur ce paramétrage

#CF CDE A3[54]

Méthode de calcul pour la surface commandée

1 Première méthode de calcul (Surface brute)

Pour une commande cartonnier :

Surface = Longueur X Largeur X Quantité commandée

Si le format de la ligne de commande n'est pas renseigné, on va chercher le format du produit commandé (cde2.lc_prod)

Pour une commande non cartonnier :

Surface = Surface unitaire brute X Quantité commandée

La surface unitaire brute est prise sur le TSC 201 Zone numérique 2 sur le produit commandé (cde2.lc_prod)

2 Deuxième méthode de calcul (Surface nette)

Pour une commande cartonnier : Idem méthode 1, voir ci-dessus

Pour une commande non cartonnier :

Surface = Surface unitaire nette X Quantité commandée

La surface unitaire nette est prise sur le TSC 202 Zone numérique 2 sur le produit commandée (cde2.lc_prod)

Permet de calculer et d'enregistrer dans un champ de la table cde2 la surface (lc_surface) de la ligne de commande.

Cette nouvelle zone est accessible dans les éditions VoluEdit et les visualisations permettant d'éditer les lignes de commande.

#CF CDE A3[55]

Méthode de calcul pour la surface d'appel de livraison

1 Première méthode de calcul (Surface brute)

Pour une commande cartonnier :

Surface = Longueur X Largeur X Quantité d'appel

Si le format de la ligne de commande n'est pas renseigné, on va chercher le format du produit d'appel : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

Pour une commande non cartonnier :

Surface = Surface unitaire brute X Quantité d'appel

La surface unitaire brute est prise sur le TSC 201 Zone numérique 2 sur le produit d'appel : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

2 Deuxième méthode de calcul (Surface nette)

Pour une commande cartonnier : Idem méthode 1, voir ci-dessus

Pour une commande non cartonnier :

Surface = Surface unitaire nette X Quantité d'appel

La surface unitaire brute est prise sur le TSC 202 Zone numérique 2 sur le produit d'appel : ligne de commande (cde2.lc_prod) ou nomenclature si elle existe (cde4.nc_prod)

Permet de calculer et d'enregistrer dans un champ de la table cde8 la surface (li_surface) de la ligne d'appel de livraison.

Cette nouvelle zone est accessible dans les éditions VoluEdit et les visualisations permettant d'éditer les appels de livraisons.

#CF CDE A3[56]

Méthode de calcul pour le montant d'appel de livraison

1 Première méthode de calcul (la seule au 05/08/2005)

Si la livraison concerne un ensemble :

Montant = Quantité d'appel X Prix de la ligne de commande / Unité de vente

Si la livraison concerne un composant :

Montant = Quantité d'appel X Prix de la ligne de commande / 1000 X coefficient

où Coefficient = Somme des prix de revient prévisionnels des composants X Coefficient de nomenclature / Prix de revient prévisionnel du composant livré X Coefficient de nomenclature

Le prix de revient prévisionnel doit être stocké aux 1000 sur la fiche article.

Permet de calculer et d'enregistrer dans un champ de la table cde8 le montant (li_montant) de la ligne d'appel de livraison.

Cette nouvelle zone est accessible dans les éditions VoluEdit et les visualisations permettant d'éditer les appels de livraisons.

#CF CDE A3[57]

Mode de rattachement des contrats

1 Entête de commande (Valeur par défaut)

2 Ligne de commande

#CF CDE A3[58]

Gestion de la quantité restant à livrer réelle (O/N)

On peut prendre en compte, sur une ligne de type SAP, les quantités réellement livrées des lignes sur appel de livraison.

Si A3[58] = O :

1) En sortie d'écran de cadencement de livraison, la somme des quantités cadencées est désynchronisée de la quantité commandée si on répond non au message de correction.
Exemple : en cartonnage, pouvoir livrer le surplus de fabrication non commandé par le client.

2) En sortie de déclaration de production pour un article fabriqué ou en sortie de la saisie des bons de réception pour un article de négoce, si la quantité est supérieure à celle commandée, la quantité de la ligne sur-appel de livraison du cadencement de fabrication est mise à jour.
Voir aussi code blocage 039.

#CF CDE A3[59]

Activer la gestion des gâches cumulatives lors de la création des FBI multi-niveaux (O/N, N par défaut)

Lors de la création des FBI multi-niveaux, permettre de prendre en compte les gâches calculées dans le devis onduleur et de les appliquer aux quantités commandée et lancée.

#CF CDE A3[60]

Accès aux codes blocage dans la revue de contrat (O/N, O par défaut)

Si on met N, cela masque le tableau des codes blocage.

Cette évolution affecte le programme de saisie des commandes ainsi que les programmes accédant en consultation à la revue de contrat :

- G_cde

- G_v_cdem

- G_labo

Valeur alpha 4

#CF CDE A4[1]

Affichage de la date du prochain cadencement sur l'écran de recherche des lignes de commande (O/N, N par défaut)

Notes

COMPLEMENT_CODE

Type de complément de recherche F7 sur produit

Le F7 présente uniquement les articles avec le même code client final que la commande (O/N, N par défaut).

Voir aussi la note CODE_CLIENT_FINAL dans le #CF TDC.

DELAI_REP_EN_JOURS

Contrôle sur quantité disponible et délai de réponse. Code blocage automatique 010 sur commande

21,60 Nombre de jours ouvrés pour le calcul de la date de livraison proposée

_DIM_CDE2

Taille des colonnes du tableau de saisie des lignes de commandes

11,30 Code de la zone (lc_lig, lc_prod, lc_lib, lc_qtecde, lc_prx, lc_rem)

31,33 Nombre de caractères affichés pour la colonne

JOURS_APRES_DATE_LIV

21,23 Définit la borne supérieure de la plage de dates sur laquelle on va chercher les commandes à livrer.

24,32 Code calendrier. Si le code calendrier est renseigné, alors le calcul de la borne supérieure de la plage de dates ne prendra en compte que les jours ouvrés. Sinon, on prend en compte tous les jours sans exception.

Cette note est recherchée en priorité sur le paramètre de lancement de la saisie de commandes clients.

JOURS_AVANT_DATE_LIV

21,23 Définit la borne inférieure de la plage de dates sur laquelle on va chercher les commandes à livrer.

24,32 Code calendrier. Si le code calendrier est renseigné, alors le calcul de la borne inférieure de la plage de dates ne prendra en compte que les jours ouvrés. Sinon, on prend en compte tous les jours sans exception.

Cette note est recherchée en priorité sur le paramètre de lancement de la saisie de commandes clients.

LCO_NB_CAD_FAB_PREV

21,23 Code LCO sur première entité de devis où sera saisi le nombre de cadencements de fabrication prévu

Valeur 1 : Nombre de cadencements de fabrication d'impression prévus

Valeur 2 : Nombre de cadencements de fabrication de façonnage prévus

PC_QTE_INF_PRIX

Gestion automatique du prix de vente devisé

21,60 Pourcentage de dépassement inférieur autorisé pour la quantité commandée par rapport à la quantité de la variante

PC_QTE_INF_VARIANTE

Gestion automatique de la variante de la ligne de commande

21,60 Pourcentage de dépassement inférieur autorisé pour la quantité lancée par rapport à la quantité de la variante

PC_QTE_SUP_PRIX

21,60 Pourcentage de dépassement supérieur autorisé pour la quantité commandée par rapport à la quantité de la variante

PC_QTE_SUP_VARIANTE

21,60 Pourcentage de dépassement supérieur autorisé pour la quantité lancée par rapport à la quantité de la variante

REAFFECT_ETAT

21 Code état des mouvements générés (N ou 2, N par défaut)

REAFFECT_NVE_VEN

21,60 Paramétrage des mouvements générés au DESOLDE

21,23 Type du mouvement de sortie (SN par défaut)

24,26 Type du mouvement d'entrée (EN par défaut)

27,29 Lieu de rangement 1 en entrée (USI par défaut)

30,35 Lieu de rangement 2 en entrée (VEN par défaut)

REAFFECT_VEN_NVE

21,60 Paramétrage des mouvements générés au SOLDE

21,23 Type du mouvement de sortie (SN par défaut)

24,26 Type du mouvement d'entrée (EN par défaut)

27,29 Lieu de rangement 1 en entrée (USI par défaut)

30,35 Lieu de rangement 2 en entrée (NVE par défaut)

_SQL_REAFFECT_NVE

21,60 Supplément sql pour recherche des mouvements au DESOLDE de commande

_SQL_REAFFECT_VEN

21,60 Supplément sql pour recherche des mouvements au SOLDE de commande

_SUP_CDE_A_LIVRER

Complément de requête sur la table cde2 pour la recherche de commandes à livrer dans le même département sur une plage de date donnée

Cette note est recherchée en priorité sur le paramètre de lancement de la saisie de commandes clients.

SUP_REQ_LIG_CONTRAT

21,60 Supplément de requête de recherche des lignes de contrat

Exemple

SUP_REQ_LIG_CONTRAT and (lc_qte_contrat is null

SUP_REQ_LIG_CONTRAT or (lc_qte_contrat is not null

SUP_REQ_LIG_CONTRAT and lc_qtecde > lc_qte_contrat))

_SUP_REQ_TSC_COPLIG

21,60 Complément de sélection des informations complémentaires à prendre en compte lors de la recopie d'une ligne de commande

La même note, dans le paramètre de lancement de la saisie de commande, est prioritaire sur celle-ci.

_SUP_REQ_TSC_PDT_ADL

21,60 Complément de sélection pour la recherche des informations complémentaires (TSC) contenant les couples client/adresse secondaire de livraison.

Ces informations complémentaires seront saisies sur les produit

Exemple

and ic_ts[1,2] = "AL"

Ce complément de sélection est recherché en priorité sur le paramètre de lancement de la saisie des commandes.

Les TSC concernés doivent être paramétrés ainsi :

Zone F (ic_char3_1) : Saisie de l'adresse secondaire

Zone G (ic_char30) : Saisie du code client

_SUP_SQL_PRODUIT_QS

21,60 Complément de sélection des produits à qualifier/surveiller (table mat)

Exemple

and mp_code matches "P*"

and mp_reap != "A"

TOL_QTE_RACINE_TSC

21, 22 Racine des TSC de stockage des code familles et tolérances.

Cette note active la gestion des tolérances multiples en saisie de commande.

Si la racine fait 1 caractère, on dispose des TSC 01 à 99.

Si la racine fait 2caractères, on dispose des TSC 1 à 9.

Exemples :

Racine T : TSC T01 à T99

Racine TQ : TSC TQ1 à TQ9

Ces TSC sont sur le client.

TSC_NB_CAD_FAB_PREV

21,23 Code TSC sur ligne de commande où sera recopié le nombre de cadencements de fabrication prévus renseigné sur le devis transféré en commande

Valeur 1 : Nombre de cadencements de fabrication d'impression prévus

Valeur 2 : Nombre de cadencements de fabrication de façonnage prévus

TSC_NB_CAD_FAB_REEL

21,23 Code TSC sur ligne de commande où sera renseigné automatiquement le nombre de cadencements de fabrication créés réellement

Valeur 1 : Nombre de cadencements de fabrication d'impression prévus

Valeur 2 : Nombre de cadencements de fabrication de façonnage prévus

TSC_PAL_CONSIGNEE

21,23 Code TSC sur produit fini utilisé pour la saisie du code palette consignée

Voir le suivi des palettes consignées

Le code palette sera saisi dans la zone alphanumérique de 30 caractères et doit être un article existant.

La présence de ce paramétrage conditionne la gestion du retour des palettes consignées dans la saisie des commandes simplifiées et dans la visualisation des factures.

TYPE_NOTES_BESOINS

21,23 Type de note à créer lors de l'annulation automatique ou de la création d'une ligne de reliquat dans les besoins

Si ce type de note n'est pas renseigné, aucune note ne sera créée.

Génération automatique d'informations

Permet la génération automatique d'informations (notamment des TSC), par copie d'éléments existants ou la création de nouveaux éléments.

L'entité source à partir de laquelle seront copiés les éléments peut être de nature différente de l'entité cible.

La génération automatique d'informations est paramétrée dans les notes de par02. Le type et le code paramètre de par02 dépend de l'événement en question. Pour la génération de commande à partir du devis, le paramétrage se fait sur #CF/CDE.

aaa_bbb_ccc_ddd_eee

21 à 60 fff*g*hhh*i*j

aaa Code événement. Valeur possible : CDE

bbb Valeurs possibles : CRE (Création) ou REP (Reprise)

ccc Source de la clé. Valeur possible : ENT (entête fiche de fabrication)

ddd Cible de la clé.

Valeurs possibles : ENT (entête commande) ou LI2 (ligne 2 de la commande)

eee Information à générer. Valeurs possibles : TSC ou PAR (paramètre issu d'une table)

Configuration de la valeur : fff*g*hhh*i*j

Si eee = TSC

fff Code TSC Source

g Zone du TSC Source (A-H). Facultatif.

Si non indiqué : le TSC entier est généré.

Ne doit pas être précisé avec l'option création (voir zone bbb du mot clé).

hhh Code TSC Cible

i Zone du TSC Cible (A-H). Doit être renseignée si la zone g est renseignée.

j Régénérer l'information si elle existe déjà (O/N)

Si eee = PAR

fff Code Colonne Source. Valeurs possibles pour la table ENT :

FAB code fabricant

REP code représentant

g Zone inutilisée

hhh Code TSC Cible

i Zone du TSC Cible. Seule valeur possible : G

j Régénérer l'information si elle existe déjà (O/N)


#CF CDF Commandes fournisseurs

Valeur alpha 1

Le paramétrage est identique à celui de #CF CDE mais n'est pas forcément utilisé.

#CF CDF A1[1,3]

Type du paramètre ef_c1 (Entête)

Le libellé affiché est saisi dans la zone libellé du type de paramètre.

#CF CDF A1[4,6]

Non utilisé au 01/12/2003. Réservé au Type du paramètre lf_p1

#CF CDF A1[7,9]

Non utilisé au 01/12/2003. Réservé au Type du paramètre lf_p2

#CF CDF A1[10,12]

Contrôle sur quel fichier

CLI client

MAT matière

LIV Lieu de livraison

[autres valeurs] Zone libre

#CF CDF A1[13]

Ouverture ou non de la fenêtre prix pour les codes suivants du paramètre ef_c1

O Oui

[autres] Non

#CF CDF A1[14,16)

Code 1 du paramètre ef_c1 (Entête)

#CF CDF A1[17,19]

Code 2 du paramètre ef_c1 (Entête)

#CF CDF A1[20,22]

Code 3 du paramètre ef_c1 (Entête)

#CF CDF A1[23,25]

Type mouvement de stock entrée normale

#CF CDF A1[26,28)

Type mouvement de stock entrée en commande

#CF CDF A1[29,31]

Type de mouvement d'entrée en commande par défaut des bobines - Facultatif

ENT par défaut

EX : BEC

Voir la fiche d'installation

#CF CDF A1[32]

Type de complément de recherche F7 sur produit

1 Complément de recherche sur le fournisseur de la table des libellés spécifiques (lib_etr.le_client) avec le fournisseur de l'entête de la commande

2 Complément de recherche sur le fournisseur de la table des articles (mat.mp_foucli) avec le fournisseur de l'entête de la commande. Le F7 présente uniquement les articles du fournisseur.

3 Le F7 présente les articles du fournisseur ET les articles qui ne sont pas associés à un fournisseur.

4 Aucun complément (recherche standard des articles)

5 Recherche des produits par le code fournisseur de la fiche article, des libellés étrangers ou ceux qui ne sont pas affectés

Valeur alpha 3

#CF CDF A3[37,38]

Racine du code TSC de stockage des codes blocages (exemple RF)

#CF CDF A3[40]

Mode d'affectation de la section analytique si elle n'a pas été affectée à la saisie de la commande fournisseur ou si c'est une ligne de facture dans commande

0 Pas d'affectation de la section analytique (valeur par défaut)

1 Section analytique de a fiche 'article

2 Spécifique

3 Affectation selon le paramétrage du #CF TFF A4[15,16]

4 La section analytique est celle de l'entête de commande fournisseur.
Si elle est vide, on prend celle de l'article.

5 Lecture en cascade

1. Section analytique de la fiche article (mode 1)

2. Section analytique saisie sur le couple famille/sous-famille

3. Section analytique saisie sur la famille

4. Section analytique selon le paramétrage du #CF TFF A4[15,16]] (mode 3)

Un paramétrage identique existe au niveau du paramètre de lancement de facn.

#CF CDF A3[41,49]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

#CF CDF A3[50]

Code statistique CS1 obligatoire en saisie d'une ligne de commande d'achat (O/N, N par défaut)

La note CTRL_CODE_CS_1 du TYF a priorité sur ce paramètre.

Rappel : FAM A4[52] = Code statistique CS1 saisissable (O/N, O par défaut)

#CF CDF A3[51]

Code statistique CS2 obligatoire en saisie d'une ligne de commande d'achat (O/N, N par défaut)

La note CTRL_CODE_CS_2 du TYF a priorité sur ce paramètre.

Rappel : FAM A4[53] = Code statistique CS2 saisissable (O/N, O par défaut)

#CF CDF A3[52]

Code statistique CS3 obligatoire en saisie d'une ligne de commande d'achat (O/N, N par défaut)

La note CTRL_CODE_CS_3 du TYF a priorité sur ce paramètre.

Rappel : FAM A4[54] = Code statistique CS3 saisissable (O/N, O par défaut)

#CF CDF A3[53]

Code statistique CS4 obligatoire en saisie d'une ligne de commande d'achat (O/N, N par défaut)

La note CTRL_CODE_CS_4 du TYF a priorité sur ce paramètre.

Rappel : FAM A4[55] = Code statistique CS4 saisissable (O/N, O par défaut)

Valeur alpha 4

#CF CDF A4[1,26]

Possibilité de changer le libellé Site de production

Indiquez ici un libellé à votre convenance.

Si non renseigné, le libellé Site de production apparaîtra dans l'écran de saisie des commandes fournisseurs.

Notes

CHAMP_MODIF_CDF1 | 21 à 40 Champ de la table cdf1 qui, s'il est modifié, va déclencher une mise à jour de la date de modification (ef_datim_modif).
CHAMP_MODIF_CDF2 | 21à 40Champ de la table cdf2 qui, s'il est modifié, va déclencher une mise à jour de la date de modification (lf_datim_modif).


#CF CEE Configuration Europe (TVA intracommunautaire)

Notes

Caractères 1 à 60

Note à éditer en entête d'édition (bloc TVA Intracommunautaire)


#CF CHA Charge logistique

Valeur alpha 1

Caractère 1 | Réponse au délai standard (O/N, N par défaut)
Caractère 2 | Forcer le calcul de la charge en délai annoncé (O/N, N par défaut)

Notes

POURC_OCCUP_JOUR

Permet de paramétrer le pourcentage de charge cumulée par jour

21 à 22 Jour de la semaine (LU, MA, ME, JE, VE, SA, DI)

25 à 29 Pourcentage de charge minimum

30 à 34 Pourcentage de charge maximum

Exemples

POURC_OCCUP_JOUR LU 0 20

POURC_OCCUP_JOUR MA 20 40

POURC_OCCUP_JOUR ME 40 60

POURC_OCCUP_JOUR JE 60 80

POURC_OCCUP_JOUR VE 80 100

Voir aussi le paramètre .SE qui permet de paramétrer les semaines particulières.


#CF CRF Analyse du carnet de commande

Le code du paramètre de configuration doit correspondre à celui du paramètre de lancement de cde_rep.

Valeur alpha 1

Caractères 1 à 3 | Code département produit 1
Caractères 4 à 14 | Libellé département produit 1
Caractères 15 à 17 | Code département produit 2
Caractères 18 à 28 | Libellé département produit 2

Valeur alpha 2

Paramétrage des colonnes d'édition

cod | Code client
nom | Nom client
cdp | Code postal
vil | Ville
cde | Numéro commande
ref | Référence commande
tyc | Type commande
tgl | Total général
___ | Codes familles existant
___ | Codes département produits déterminés en zone alpha

Un département produit est un regroupement de famille.

Dans FAM, alpha2[1,3] détermine le code département produit auquel se rattache le code famille.


#CF CLI Clients - #CF FOU Fournisseurs - #CF PRO Prospects

#CF CLI Clients
#CF FOU Fournisseurs
#CF PRO Prospects

Valeur alpha 1

Caractères 1 à 15 | Libellé de la zone libre cl_domb2 dans la table cli
Caractères 16 à 30 | Libellé de la zone libre 1 (cl_zpar dans la table cli). Tableau de bord du multisite
Caractères 31 à 33 | Type du paramètre de la zone libre 1 (cl_zpar dans la table cli)
Caractère 34 | Contrôle de l'unicité de l'identifiant TVA (du SIRET) Permet de vérifier l'unicité de l'identifiant TVA dans la base. N Aucun contrôle W Avertissement B Bloquant Voir aussi la note CTRL_UNICITE_SIREN
Caractère 35 | Type d'événement généré lors du passage d'un prospect en client. M Modification (défaut) C Création
Caractère 36 | Gestion des représentants externes (agences). Voir A3[16,18] O Oui N Non (par défaut)
Caractère 37 | Position des représentants internes sur la fiche client. Voir A3[16,18] 0 Position normale (par défaut) 1 Zone paramétrée 1 2 Zone paramétrée 2 3 Zone paramétrée 3
Caractère 38 | Position des représentants externes (agences) sur la fiche client. Voir A3[16,18] 0 Position normale 1 Zone paramétrée 1 (par défaut) 2 Zone paramétrée 2 3 Zone paramétrée 3
Caractère 39 | Contrôle des permissions uniquement en modification (O/N, N par défaut)
Caractère 40 | Ouverture automatique de la saisie des informations complémentaires à la validation d'une adresse secondaire O ou C Ouverture à la création d'une nouvelle adresse secondaire T Ouverture systématique N Pas d'ouverture automatique (par défaut)
Caractère 41 | Ouverture automatique de la saisie des informations complémentaires à la validation de l'adresse principale (saisie des informations générales du tiers) O ou C Ouverture à la création d'un nouveau tiers T Ouverture systématique N Pas d'ouverture automatique (par défaut)
Caractère 42 | Contrôle de l'unicité du code SIREN sur les adresses secondaires (table cli2) (O/N, N par défaut) Voir la note CTRL_UNICITE_SIREN
Caractère 43 | Afficher sur l'écran de modélisations des clients, les exemplaires société (O/N, N par défaut)
Caractère 44 | Dans le programme de saisie des tiers (G_cli) et dans la saisie des adresses secondaires, contrôle si le code comptable saisi est un code tiers existant et valide, ou celui en cours de création. N Pas de contrôle (par défaut) B Contrôle bloquant C Message de confirmation W Warning (simple avertissement) Le contrôle peut être affiné avec la note _SUP_REQ_CODE_COMPTA.
Caractère 45 | Lorsque l'on crée une adresse de facturation, si le client principal n'a pas d'adresse de facturation par défaut (cl_adrf vide), on lui attribue automatiquement la 1ère adresse de facturation qui lui est rattachée dans l'ordre alphabétique.

Valeur alpha 2

Caractères 1 à 60

Paramétrage des colonnes d'édition abrégée

A Code client

B Nom du client

C Adresse 1

D Adresse 2

E Code postal

F Ville

G Téléphone 1

H Téléphone 2 (si –Oco : numéro des correspondants)

I Télécopie

J Télex

K Nom du correspondant

L Domiciliation bancaire 1

M RIB

N Code pays

O Libellé du pays

P Code devise

Q Libellé devise

R Code secteur géographique

S Libellé secteur géographique

T Code catégorie client

U Libellé catégorie client

V Code secteur activité

W Libellé secteur activité

X Code origine

Y Libellé origine

Z Code mode de règlement

a Libellé mode de règlement

b Code échéance

c Libellé échéance

d Taux de remise par ligne

e Taux de remise globale

f Taux d'escompte

g Code représentant

h Nom du représentant

i Code tarif

j Libellé tarif

k Code remise

l Libellé de la remise

m Code tournée

n Libellé tournée

o Date de création

p Domiciliation bancaire 2

q Zone paramètre zpar

r Libellé zone paramètre zpar

s Code Langue

t Libellé du code langue

u Code qualité

v Libellé du code qualité

w Code APE

x Code SIRET

y Titre du correspondant

z Libellé du titre du correspondant

1 Code de la zone zpar2

2 Libellé du code de la zone zpar2

3 Code de la zone zpar3

4 Libellé du code de la zone zpar3

5 Code des conditions de port

6 Libellé des conditions de port

7 Client groupe

8 Code comptable

9 Code C/P/F (Client / Prospect / Fournisseur)

0 Zone Données diverses

% Zone paramétrée numérique

+ Code agrément

- Libellé agrément

$ Code transporteur

# Code suivi d'affaire

À Libellé court du suivi d'affaire

| Code type de transport

Á Libellé court type de transport

! Montant plafond franco de port

, Code de la zone paramétrée adresse (zpar_adresse)

; Libellé du code de la zone paramétrée adresse

: Ville port destination

ç Adresse e-mail

Valeur alpha 3

Caractères 1 à 15 | Libellé de la zone libre 2 (cl_zpar2 dans la table cli)
Caractères 16 à 18 | Type du paramètre de la zone libre 2 (cl_zpar2 dans la table cli) Utilisé pour la gestion des représentants
Caractères 19 à 33 | Libellé de la zone libre 3 (cl_zpar3 dans la table cli)
Caractères 34 à 36 | Type du paramètre de la zone libre 3 (cl_zpar3 dans la table cli)
Caractères 37 à 51 | Libellé de la zone libre numérique (cl_zparnum dans la table cli)

Valeur alpha 4

Caractères 1 à 10 | Libellé de la zone libre adresse (cl_zpar_adresse dans la table cli)
Caractères 11 à 13 | Type du paramètre de la zone libre adresse (cl_zpar_adresse dans la table cli)
Caractère 14 | Cacher la modélisation du devis sur le client principal
Caractère 15 | Cacher la modélisation de l'AR sur le client principal
Caractère 16 | Cacher la modélisation du BL sur le client principal
Caractère 17 | Cacher la modélisation des étiquettes sur le client principal
Caractère 18 | Cacher la modélisation de la facture sur le client principal
Caractère 19 | Cacher la modélisation du relevé sur le client principal
Caractère 20 | Cacher la modélisation du devis sur le client secondaire
Caractère 21 | Cacher la modélisation de l'AR sur le client secondaire
Caractère 22 | Cacher la modélisation du BL sur le client secondaire
Caractère 23 | Cacher la modélisation des étiquettes sur le secondaire
Caractère 24 | Cacher la modélisation de la facture sur le secondaire
Caractère 25 | Cacher la modélisation du relevé sur le client secondaire

Notes

CLPARAM_INTERDIT_

Interdire certaines valeurs aux différentes zones du champ cl_param dans le programme de saisie des tiers

Ce paramétrage ne s'applique pas aux caractères dont la valeur ne peut-être que O ou N (case à cocher).

18,19 Indice du caractère sur lequel les valeurs listées sont interdites.

21,60 Liste des valeurs interdites pour le caractère spécifié du champ cl_param.

Exemples

CLPARAM_INTERDIT_10 F

CLPARAM_INTERDIT_05 LR

Pour le caractère 10 du cl_param (Gestion de l'affacturage), on interdit la valeur F.

Pour le caractère 5 du cl_param (Mode de facturation des articles), on interdit les valeurs L et R.

CTRL_UNICITE_SIREN

Vérification de l'unicité du code SIREN en fonction du type de tiers et du code pays

21 Type de contrôle

N Aucun contrôle

W Avertissement

C Demande de confirmation

B Bloquant

22 Type de tiers

C Clients

F Fournisseurs

P Prospects

* Tous les types de tiers

23,24 Code pays (mettre un astérisque pour tous les pays)

Voir aussi A1[34] et A1[42].

DROIT_ACCES_CL_PARAM

Accès paramétrables des zones du cl_param

21,22 Numéro du cl_param (de 1 à 21)

23 Visibilité de la zone

O Zone visible et accessible (par défaut)

N Zone cachée

C Zone visible mais non accessible (consultation)

On peut contrôler l'accès à chaque zone du cl_param.

Par défaut, toutes les zones sont visibles et accessibles.

Le paramétrage est recherché en priorité sur le user (USE XXX où xxx est le code utilisateur).

Si au moins une ligne de paramétrage concernant l'accès aux zones du cl_param est trouvée, alors les permissions sont prises sur l'utilisateur.

Si aucun paramétrage n'est trouvé sur l'utilisateur, on va lire le paramétrage sur la configuration de la fiche tiers (#CF CLI ou autre).

Si vous paramétrez des notes à la fois sur le USE et sur le #CF CLI, seules celles du USE seront prises en compte.

_EVAL_TRANSP_BAREME

21,22 Barème

_EVAL_TRANSP_CRITERE

Paramétrage de la grille d'évaluation des transporteurs

21, 60 Paramétrage du critère d'évaluation

Structure de la note (les 5 astérisques sont obligatoires) :

_EVAL_TRANSP_CRITERE*Code du TSC*Zone du TSC*Libellé du critère*Coefficient du critère*

Exemple

_EVAL_TRANSP_CRITERE*XXX*C*Mon critère N° 1*7*

_EVAL_TRANSP_CRITERE*XXX*D*Mon critère N° 2*6*

_EVAL_TRANSP_CRITERE*XXX*E*Mon critère N° 3*4*

Le TSC XXX sert à stocker 3 critères d'évaluation, dont vous fixez le coefficient (ici, respectivement 7, 6 et 4).

Ces 3 critères apparaîtront dans la grille dévaluation, avec leur libellé et leur coefficient.

Pour chacun de ces critères, l'utilisateur pourra saisir une valeur :

La valeur du critère 1 sera saisie dans la zone numérique 1 (code C - ic_num1)

La valeur du critère 2 sera saisie dans la zone numérique 2 (code D - ic_num2)

La valeur du critère 3 sera saisie dans la zone numérique 3 (code E - ic_num3)

HAB_SUP_REQ_CDE1

21 à 60 Supplément de requête sur la table cde1

HAB_SUP_REQ_CDE2

21 à 60 Supplément de requête sur la table cde2

HAB_SUP_REQ_CDF1

21 à 60 Supplément de requête à la table cdf1 dans la recherche des articles habituellement achetés.

HAB_SUP_REQ_CDF2

21 à 60 Supplément de requête à la table cdf2 dans la recherche des articles habituellement achetés.

HAB_SUP_REQ_MAT

21 à 60 Supplément de requête à la table mat dans la recherche des articles habituellement achetés.

_SUP_ORDER_BY_CLI

Voir généralités

_SUP_REQ_CODE_COMPTA

21,60 Complément de sélection portant sur la table cli pour le contrôle du code comptable

Voir A1[44] et pour la recherche des codes comptables.

(fonction F7 sur les champs cl_cpt de l'écran G_cli et c2_cpt de l'écran G_cli3)

_SUP_SQL_LIBETR_MAT

21,60 Complément de sélection sur la table des articles

La même note existe dans le paramètre de lancement de la saisie des tiers où elle est prioritaire.

Exemple

and mp_qualite not in ("DEV", "INA")

TSC_ADRESSE_FRAIS

Lors d'une saisie de commande ou d'un transfert de devis en commande, permet de spécifier une adresse de facturation par défaut spécifique pour les frais à l'aide d'un TSC au niveau de la fiche client.

Cette adresse de facturation des frais est renseignée par défaut au niveau de la ligne de commande dans le programme de saisie des commandes ou lors d'un transfert de devis en commande si les conditions suivantes sont remplies :

- La note TSC_ADRESSE_FRAIS est correctement paramétrée.

- Le client de la commande dispose d'une adresse de facturation des frais.

- L'article de la ligne de commande a son mp_param[10] (Type d'article en valorisation) à F (Frais de premier établissement).

21,23 Code TSC de l'adresse de facturation par défaut des frais.

24 Zone de la table info_c dans laquelle est stockée l'adresse de facturation par défaut des frais :

F ic_char3_1

G ic_char30

H ic_char3_2

TYPE_RECH_F7_ADR

21,26 Type et code du paramètre de lancement de la visualisation de clients à utiliser pour visualiser le résultat de la recherche d'adresses secondaires par la touche F7

TYPE_RECH_F7_CLI

Utilisable dans tout programme utilisant la recherche des tiers

Cette note est recherchée en priorité :

1) dans le paramètre de lancement (figurent dans le chapitre Généralités)

2) dans le #CF CLI (c'est ici)

3) dans le #CF ATL

Elle permet de spécifier le type et le code du programme de visualisation des tiers que l'on souhaite utiliser pour visualiser le résultat de la recherche des tiers par la fonction F7 dans tous les programmes.

21,26 Type et code du paramètre du programme de visualisation des tiers à utiliser pour visualiser le résultat de la recherche de tiers par la touche F7.


#CF CRM Interface ReflexClient

Gestion de l'interface avec ReflexClient.

Le paramétrage (hormis les notes) peut se faire de manière interactive par le biais du programme administration_crm.4ge (Onglet Configuration)

Valeur alpha 1

A1[1] | Activation de l'interface avec ReflexClient (O/N, N par défaut)
A1[2] | Synchronisation des établissements/adresses secondaires (O/N, N par défaut)
A1[3] | Synchronisation des contacts/correspondants O/N, (N par défaut)
A1[4] | Synchronisation des clients (O/N, N par défaut)
A1[5] | Synchronisation des prospects (O/N, N par défaut)
A1[6] | Synchronisation des fournisseurs (O/N, N par défaut)

Valeur alpha 2

A2[1,5] | Racine codification automatique du client
A2[6] | Longueur du folioteur pour codification code client
A2[7,11] | Racine du prospect
A2[12] | Longueur du folioteur pour codification code prospect
A2[13,17] | Racine du fournisseur
A2[18] | Longueur du folioteur pour codification code fournisseur

Notes

DESYNCHRONISATION

Nom de la zone de table cli, cli2, corres à désynchroniser

La modification/création de l'équivalent de cette zone dans la CRM n'impactera pas la zone paramétrée.

De même, la modification de cette zone dans VoluPack n'impactera pas son équivalent dans la CRM.

Attention : les zones servant de clé à la table ne doivent pas faire l'objet de la désynchronisation.

exemples : cl_code, c2_code, c2_adr, co_nom ….


#CF CTC Transferts Cartec

Valeur alpha 1

Caractère 1

Historisation des fichiers traces et anomalie (O/N, N par défaut)

Notes

FIC_CARTEC | 21 à 36 Nom du fichier de transfert
FIC_LOCK_CARTEC | 21 à 36 Nom du fichier de verrouillage posé par CARTEC Plus d'infos
FIC_LOCK_VS | 21 à 36 Nom du fichier de verrouillage posé par Volume Software Plus d'infos
FIC_TRACE_CARTEC | 21 à 36 Nom du fichier de trace des événements
FIC_ANOMALIE_CARTEC | 21 à 36 Nom du fichier d'anomalie
DECOUPAGE_TSC_60 | 21 à 36 Découpage du TSC de la zone 60 (code estampille) Valeur par défaut : 2ESTic_char3_1 Exemple : 2ESTic_char3_1 2 pour générique (Type A puis C) EST : code TSC ic_char_31_1 : zone à récupérer
DECOUPAGE_TSC_71 | 21 à 36 Découpage du TSC de la zone 71 (Nombre de couleur) Valeur par défaut : 2IMPic_num2
DECOUPAGE_TSC_72 | 21 à 36 Découpage du TSC de la zone 72 (Code couleur 1) Valeur par défaut : 2CO1ic_char3_1
DECOUPAGE_TSC_73 | 21 à 36 Découpage du TSC de la zone 73 (Code couleur 2) Valeur par défaut : 2CO2ic_char3_1
DECOUPAGE_TSC_74 | 21 à 36 Découpage du TSC de la zone 74 (Code couleur 3) Valeur par défaut : 2CO3ic_char3_1
DECOUPAGE_TSC_78 | 21 à 36 Découpage du TSC de la zone 78 (Code cliché 1) Valeur par défaut : 2CL1ic_char30
DECOUPAGE_TSC_79 | 21 à 36 Découpage du TSC de la zone 79 (Code cliché 2) Valeur par défaut : 2CL2ic_char30
DECOUPAGE_TSC_80 | 21 à 36 Découpage du TSC de la zone 80 (Code cliché 3) Valeur par défaut : 2CL3ic_char30
DECOUPAGE_TSC_81 | 21 à 36 Découpage du TSC de la zone 81 (Code cliché 4) Valeur par défaut : 2CL4ic_char30
DECOUPAGE_TSC_82 | 21 à 36 Découpage du TSC de la zone 82 (Code cliché 5) Valeur par défaut : 2CL5ic_char30
DECOUPAGE_TSC_83 | 21 à 36 Découpage du TSC de la zone 83 (Code cliché 6) Valeur par défaut : 2CL6ic_char30
DECOUPAGE_TSC_85 | 21 à 36 Découpage du TSC de la zone 85 (Forme découpe 1) Valeur par défaut : 2DC1ic_char30
DECOUPAGE_TSC_86 | 21 à 36 Découpage du TSC de la zone 86 (Forme découpe 2) Valeur par défaut : 2DC2ic_char30
DECOUPAGE_TSC_87 | 21 à 36 Découpage du TSC de la zone 87 (Forme découpe 3) Valeur par défaut : 2DC3ic_char30
DECOUPAGE_TSC_88 | 21 à 36 Découpage du TSC de la zone 88 (Epaisseur des encoches) Valeur par défaut :
DECOUPAGE_TSC_89 | 21 à 36 Découpage du TSC de la zone 89 (Longueur des lames) Valeur par défaut :
DECOUPAGE_TSC_90 | 21 à 36 Découpage du TSC de la zone 90 (Nombre de feuilles par paquet) Valeur par défaut : 2CNDic_num2
DECOUPAGE_TSC_91 | 21 à 36 Découpage du TSC de la zone 91 (Code jonction) Valeur par défaut : 2E2050ic_char3_1
DECOUPAGE_TSC_92 | 21 à 36 Découpage du TSC de la zone 92 (Nombre de liens par paquet) Valeur par défaut :
DECOUPAGE_TSC_93 | 21 à 36 Découpage du TSC de la zone 93 (Nombre de feuillards) Valeur par défaut : 2230ic_char3_1
DECOUPAGE_TSC_94 | 21 à 36 Découpage du TSC de la zone 94 (Type de palette) Valeur par défaut : 2CNDic_char3_1
DECOUPAGE_TSC_96 | 21 à 36 Découpage du TSC de la zone 96 (Schéma de palettisation) Valeur par défaut : 2CNDic_char3_1
DECOUPAGE_TSC_97 | 21 à 36 Découpage du TSC de la zone 97 (Quantité par palette) Valeur par défaut : 2CNDic_num1
DECOUPAGE_TSC_98 | 21 à 36 Découpage du TSC de la zone 98 (Présence film) Valeur par défaut :
TYPE_PARAM_91 | 21 à 23 Type paramètre zone 91 (Libellé jonction) Valeur par défaut : .JE
TYPE_PARAM_95 | 21 à 23 Type paramètre zone 95 (Libellé palette) Valeur par défaut :
TYPE_PARAM_LIB_COUL | 21 à 23 Type paramètre libellé couleur (pour zone 75,76 et 77) Valeur par défaut : COU


#CF CTR Contrats

Voir aussi #CF CDE A3[57] (mode de rattachement des contrats).

Notes

Certains compléments de sélection existent sur la nomenclature et sur la ligne de commande.

Si le compléments de sélection sur nomenclature n'est pas renseigné, alors on prend son équivalent sur la ligne de commande associée (s'il existe).

Exemple, basé sur le premier complément de sélection du tableau :

Si _SUP_REQ_NOM_CDE1 n'est pas renseigné, alors on prendra le complément de requête_SUP_REQ_CDE1.

_SUP_REQ_NOM_CDE1

_SUP_REQ_CDE1

21,60 Complément sur la table cde1 correspondant aux entêtes de commandes associées au contrat

pour la maj des lignes de nomenclature de contrat par le cumul des quantités des commandes associées

pour la maj des lignes de contrat par le cumul des quantités des commandes associées

_SUP_REQ_NOM_CDE2

_SUP_REQ_CDE2

21,60 Complément sur la table cde2 correspondant aux lignes de commandes associées au contrat

pour la maj des lignes de nomenclature de contrat par le cumul des quantités des commandes associées

pour la maj des lignes de contrat par le cumul des quantités des commandes associées

_SUP_REQ_NOM_CDE4

21,60 Complément sur la table cde4 correspondant aux lignes de nomenclature associées au contrat

pour la maj des lignes de nomenclature de contrat par le cumul des quantités des commandes associées

_SUP_REQ_NOM_PAR02

_SUP_REQ_PAR02

21,60 Complément sur la table par02 correspondant au type de liaison

(LIE A1[5] = O avec code paramètre = type de liaison de la commande associée au contrat)

pour la maj des lignes de nomenclature de contrat par le cumul des quantités des commandes associées

pour la maj des lignes de contrat par le cumul des quantités des commandes associées

_SUP_REQ_QTEAFA

21,60 Complément de sélection pour cumuler les quantités à facturer

de la ligne de commande (cde2)

_SUP_REQ_NOM_QTECON

_SUP_REQ_QTECON

21,60 Complément de sélection pour cumuler les quantités du contrat

de la ligne de nomenclature (cde4)

de la ligne de commande (cde2)

_SUP_REQ_NOM_QTEFAB

_SUP_REQ_QTEFAB

21,60 Complément de sélection pour cumuler les quantités fabriquées

de la ligne de nomenclature (cde4)

de la ligne de commande (cde2)

_SUP_REQ_QTEFAC

21,60 Complément de sélection pour cumuler les quantités facturées

de la ligne de commande (cde2)

_SUP_REQ_QTELAN

21,60 Complément de sélection pour cumuler les quantités lancées

de la ligne de commande (cde2)

_SUP_REQ_NOM_QTELIV

_SUP_REQ_QTELIV

21,60 Complément de sélection pour cumuler les quantités livrées

de la ligne de nomenclature (cde4)

de la ligne de commande (cde2)

_SUP_REQ_NOM_QTELNV

21,60 Complément de sélection pour cumuler les quantités livrées non validées

de la ligne de nomenclature (cde4)

_SUP_REQ_NOM_QTELVA

21,60 Complément de sélection pour cumuler les quantités livrées validées

de la ligne de nomenclature (cde4)

_SUP_REQ_NOM_QTELVR

_SUP_REQ_QTELVR

21,60 Complément de sélection pour cumuler les quantités livrées réelles

de la ligne de nomenclature (cde4)

de la ligne de commande (cde2)


#CF DAO Configuration de la gestion des appels d'offres

Ce paramètre est utilisable à partir de la V.4.1.46.2

Il est appelé par la note AO_CONFIGURATION du devis onduleur.

Notes triées

Toutes ces notes peuvent êtres mises ici ou sur le paramétrage de lancement du devis onduleur.

Dans ce dernier cas, la note AO_CONFIGURATION ne doit pas être paramétrée dans le devis onduleur.

AO_CHAMP_FICHIER

21,38 Nom du champ de destination dans VoluPack (voir liste ci-dessous)

41,43 Cas 1 (sans séparateur de champ) : Position de début de champ

Cas 2 (avec séparateur de champ) : Position séquentielle du champ

45,47 Cas 1 (sans séparateur de champ) : Position de fin de champ

Cas 2 (avec séparateur de champ) : Non applicable

AO_CHAMP_SEPARATEUR

21 Caractère de séparation des champs dans une ligne du fichier d'import

Par défaut : point-virgule

IMPORTANT :

• En présence de notes commençant par AO_CHAMP_FICHIER, si aucun séparateur de champs n'est défini, alors les champs sont paramétrés sur des positions fixes.

• Si vous spécifiez un séparateur de champs, il doit y avoir un séparateur de champ après le dernier champ pour que celui-ci soit pris en compte.

AO_CHAMP_VALEUR

21,38 Nom du champ de destination dans VoluPack (voir liste ci-dessous)

41,60 Valeur par défaut

AO_FICHIER_ERREUR

AO_FICHIER_ERREUR_N

Syntaxe pour environnement réel ou par défaut

Syntaxe pour environnement de test (où N est compris entre 1 et 3)

21,60 Chemin d'accès et nom du fichier des anomalies (liste des lignes en erreurs)

AO_FICHIER_IMPORT

AO_FICHIER_IMPORT_N

Syntaxe pour environnement réel ou par défaut

Syntaxe pour environnement de test (où N est compris entre 1 et 3)

21,60 Chemin d'accès et nom du fichier à importer

AO_FICHIER_TRACE

AO_FICHIER_TRACE_N

Syntaxe pour environnement réel ou par défaut

Syntaxe pour environnement de test (où N est compris entre 1 et 3)

21,60 Chemin d'accès et nom du fichier de trace

AO_PARAM_LCT_V_DON

21,26 Type et code du paramètre de lancement de la visualisation des devis onduleurs intégrés

CTRL_CHAFIC_UNICITE

21 Contrôle de l'unicité des champs (le nom du champ doit être unique).

Paramétrage lié aux notes commençant par AO_CHAMP_FICHIER

O Chaque nom de champ doit être unique (par défaut)

N Pas de contrôle d'unicité

Liste des champs de destination dans VoluPack

Les zones obligatoires peuvent être initialisées par défaut en utilisant les notes commençant par AO_CHAMP_VALEUR ou par le devis/article par défaut.

 |  | Saisissable dans |  |
Nom du champ | Description | Devis simplifié (Architecture automatique) | Devis concepteur (Architecture étudiée) | Obligatoire (selon type de saisie)
Demande client (005)
DEM_CODE_CLIENT | Code tiers | O | O | O
DEM_CODE_ADRESSE | Code adresse de livraison | O | O |
DEM_REF_PRODUIT | Référence du produit |  | O | O
DEM_QTE_OFFRE_1 | Quantité d'offre n°1 | O | O | O
DEM_QTE_OFFRE_2 | Quantité d'offre n°2 | O | O |
DEM_QTE_OFFRE_3 | Quantité d'offre n°3 | O | O |
DEM_QTE_OFFRE_4 | Quantité d'offre n°4 | O | O |
DEM_QTE_OFFRE_5 | Quantité d'offre n°5 | O | O |
DEM_QTE_OFFRE_6 | Quantité d'offre n°6 | O | O |
DEM_LIBELLE | Libellé du devis | O | O | O
DEM_TYPE_PORT | Type de port (POR) | O |  |
DEM_TYPE_CORRES | Titre du de correspondant (TCO) | O |  |
DEM_NOM_CORRES | Nom du correspondant | O |  |
DEM_TEL_CORRES | Téléphone du correspondant | O |  |
DEM_REPRESENTANT | Code représentant (REP) | O |  | O
DEM_REMISE_PRIX | Code de remise de prix (QRP) | O |  | O
DEM_CAM_REMPLI | Camion complet (O/N) | O |  |
Offre de prix (020) (Article référence R)
OFF_CODE_CS1 | Code statistique 1 (CS1) |  |  |
OFF_CODE_CS2 | Code statistique 2 (CS2) |  |  |
OFF_CODE_CS3 | Code statistique 3 (CS3) |  |  |
OFF_CODE_CS4 | Code statistique 4 (CS4) |  |  |
Architecture automatique/étudiée (030/035) (Article architecture A)
ARC_LON_INT | Longueur intérieure | O | O | O
ARC_LAR_INT | Largeur intérieure | O | O | O
ARC_HAU_INT | Hauteur intérieure | O | O | O
ARC_COMPOSITION | Code composition | O | O | O
ARC_FEFCO_DESSUS | Code FEFCO dessus | O |  | O
ARC_FEFCO_DESSOUS | Code FEFCO dessous | O |  | O
ARC_CODE_QUALITE | Code qualité | O | O | O
ARC_COMPLEXITE_DEC | Code complexité de découpe | O | O | O
ARC_JONCTION | Présence de jonction (O/N) | O | O | O
ARC_TYPE_JONCTION | Type de jonction | O | O | O
ARC_PATTE_INT_EXT | Patte intérieure/extérieure | O | O | O
ARC_PROLON_DESSUS | Code prolongement dessus | O | O | O
ARC_PROLON_DESSOUS | Code prolongement dessous | O | O | O
ARC_ETUDE | Numéro d'étude |  | O | O
ARC_FAM_PF | Code famille du PF |  | O | O
ARC_SFM_PF | Code sous-famille du PF |  | O | O
ARC_LAIZE_BRUTE | Laize brute |  | O | O
ARC_COUPE_BRUTE | Coupe brute |  | O | O
ARC_LAIZE_NETTE | Laize nette |  | O | O
ARC_COUPE_NETTE | Coupe nette |  | O | O
ARC_NB_POSES | Nombre de poses |  | O | O
ARC_METRAGE_FILET | Métrage filet unitaire |  | O | O
ARC_POSE_REMORQUE | Nombre de poses en remorque |  | O | O
Impression (045) (Article impression I)
IMP_NB_COULEURS | Nombre de couleurs | O | O |
Détail des couleurs (047)
IMP_SURFACE_N | avec N compris entre 1 et 9 Surface d'impression de la couleur N | O | O |
Conditionnement (si imposé) (048)
CDT_LAR_PF | Largeur assemblée du PF |  | O |
CDT_LON_PF | Longueur assemblée du PF |  | O |
CDT_HAU_PF | Hauteur assemblée du PF |  | O |
CDT_NB_PRODUITS | Nombre de produits |  | O |
CDT_LON_PAL | Longueur de la palette |  | O |
CDT_LAR_PAL | Largeur de la palette |  | O |
CDT_LON_ENC | Longueur d'encombrement |  | O |
CDT_LAR_ENC | Largeur d'encombrement |  | O |
CDT_HAU_ENC | Hauteur d'encombrement |  | O |
Gamme de fabrication (050)
GAM_CODE_GAMME | Code gamme |  | O | O
GAM_CODE_GAMME_LIB | Libellé de la gamme Ce champ spécifique permet de retrouver le code gamme à partir d'un libellé |  |  |
GAM_MACHINE_N | avec N compris entre 1 et 9 Code machine N Utilisé pour mettre en place un format (ouverture/poussée) sur la gamme. Le code machine doit correspondre à une machine présente dans la gamme. |  |  |
GAM_OUVERTURE_N | avec N compris entre 1 et 9 Ouverture pour la machine N |  |  |
GAM_POUSSEE_N | avec N compris entre 1 et 9 Poussée pour la machine N |  |  |


#CF DEG Configuration générale des devis

Le résultat du calcul de la valeur 1 de la formule (V1) sera le coefficient de conversion des unités pour la quantité de l'opération

Le résultat du calcul de la valeur 2 de la formule (V2) sera le coefficient de conversion des unités pour la quantité de gâche variable de l'opération (par défaut, c'est le coefficient de la valeur V1 qui sera pris en compte)

Exemple :

Formule de conversion : Tours à Feuilles
V1 | 1/Nombre de passages au recto | 1/2 = 0.5
V2 | Pas de conversion (1 tour = 1 feuille de gâche) | 1

Formule de conversion : Feuilles à Tours
V1 | Nombre de passages au recto | 2
V2 | Pas de conversion (1 feuille de gâche = 1 tour) | 1

1. Première opération calculée

Quantité H.G. | % G.V | G.F | Quantité T.G.C. | Quantité G.V. | Unité
21750 | - | 10 | 21760 | - | Feuilles
Passage en tours (avec double passage)
21750 * 2 | - | 10 * 2 | - | - | Feuille à Tours
=
43500 | - | 20 | 43520 | - | Tours

2. A. Deuxième opération calculée (sans gestion du multi-passages)

Quantité H.G. | % G.V | G.F | Quantité T.G.C. | Quantité G.V. | Unité
43520 | 3.00 | - | 44866 | 1346 | Tours
Passage en feuilles
43520 * 0.5 | - | - | - | 1346 * 0.5 | Tours à Feuille
=
21760 | - | - | 22433 | 673 | Feuille

2. B. Deuxième opération calculée (avec gestion du multi-passages)

Quantité H.G. | % G.V | G.F | Quantité T.G.C. | Quantité G.V. | Unité
43520 | 3.00 | - | 44866 | 1346 | Tours
Passage en feuilles (avec double passage)
43520 * 0.5 | - | - | - | 1346 * 1 | Tours à Feuille
=
21760 | - | - | 23106 | 1346 | Feuille

On remarque dans le deuxième exemple (2.B.) que l'application du coefficient spécifique à la gâche variable permet de définir qu'un tour est égal à une feuille de gâche.

Dans le premier exemple (2.A.), on applique le même coefficient de conversion à la quantité hors gâche et à la quantité de gâche variable, on définit donc qu'un tour est égal à ½ feuille de gâche, ce qui est incorrect.

#CF DEG Configuration générale des devis

Valeurs numériques 1 & 2 Valeur alpha 1 Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes

Valeurs numériques

#CF DEG N1 | Coefficient pondérateur pour le calcul de la gâche fixe au deuxième passage
#CF DEG N2 | Coefficient pondérateur pour le calcul de la gâche fixe au troisième passage et plus

Valeur alpha 1

#CF DEG A1[1]

Configuration du F11 (calcul du devis).

F11 sur premier / dernier écran

A1[1] = N : Recalcul de la variante (ou sous-devis) complète.

Toutes les entités sont recalculées complètement.

A1[1] = O La question suivante est posée :

Doit-on recalculer l'ensemble du devis (toutes variantes confondues) ou uniquement la variante courante ?

Les marges sont recalculées.

F11 sur écran entité

A1[1] = N : Recalcul de l'entité complète (et seulement de l'entité courante).

A1[1] = O : La question suivante est posée

Doit-on recalculer toutes les entités ou uniquement l'entité courante ?

Devis standard : Les marges sont recalculées.

Autres devis : Les marges ne sont pas recalculées (1).

F11 sur écran des phases

A1[1] = N : Recalcul de la phase courante seule.

A1[1] = O : La question suivante est posée :

Doit-on recalculer toutes les phases ou uniquement la phase courante ?

Devis standard : Les marges sont recalculées.

Autres devis : Les marges ne sont pas recalculées (1).

F11 sur écrans détail matière / opération / sous-traitance

La question suivante est posée : Recalcul d'une ligne ou de toutes les lignes ?

(sauf pour le détail sous-traitance)

Les marges ne sont pas recalculées.

les seules sources d'information concernent

(1) Les marges sont réattribuées mais ne sont pas recalculées.

#CF DEG A1[2]

Recopie de la sous-traitance

O La sous-traitance est recopiée lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N La sous-traitance n'est recopiée ni en copie ni en génération.

C La sous-traitance est recopiée en copie de devis uniquement. ***

G La sous-traitance est recopiée en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[3]

Recopie du transport

O Le transport est recopié lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N Le transport n'est recopié ni en copie ni en génération.

C Le transport est recopiée en copie de devis uniquement. ***

G Le transport est recopié en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[4]

Mise à zéro de zone en génération

O La génération remet à zéro les zones techniques liées à chaque entité.

Ce qui oblige le deviseur à les ressaisir et donc à ne pas les oublier. ***

Attention aux répercussions sur alpha4[30] et [31]

N La génération agit comme une recopie parfaite et ne remet rien à zéro.

#CF DEG A1[5]

Existence des produits et contrôle des validités

Pour le devis multi-métiers, voir l'option Ovq.

O Les codes produits doivent être référencés (non bloquant)
Les validités des produits sont contrôlées
(bloquant/non bloquant selon paramétrage de la validité)

B Les codes produits doivent être référencés (bloquant)
Les validités des produits sont contrôlées
(bloquant/non bloquant selon paramétrage de la validité)

N Les codes produits ne doivent pas forcément être référencés (non bloquant, par défaut)
Les validités des produits ne sont pas contrôlées.

#CF DEG A1[6]

Mise à la valeur nulle des valeurs numériques en génération de devis pour :

• Les formules matières (fm_v1 à fm_v10)

• Les formules opérations (fo_v1 à fo_v10)

• Les lignes complémentaires LCO (fc_v1 à fc_v4)

O Les valeurs 1 à 10 des formules matières et opérations sont recopiées.
Les valeurs 1 à 4 des LCO sont recopiées.

N Les valeurs 1 à 10 des formules matières et opérations ne sont pas recopiées.
Les valeurs 1 à 4 des LCO ne sont pas recopiées.

0 Les valeurs 1 à 10 des formules matières et opérations sont recopiées.
Les valeurs 1 à 4 des LCO ne sont pas recopiées.

1 Les valeurs 1 à 10 des formules matières et opérations ne sont pas recopiées.
Les valeurs 1 à 4 des LCO sont recopiées.

#CF DEG A1[7]

Mise à blanc des valeurs alphanumériques en génération de devis pour :

• Les formules matières (fm_a1)

• Les formules opérations (fo_a1 et fo_a2)

• Les lignes complémentaires LCO (fc_a1 à fc_a4)

O Les valeurs 1 des formules matières sont recopiées.
Les valeurs 1 et 2 des formules opérations sont recopiées.
Les valeurs 1 à 4 des LCO sont recopiées.

N Les valeurs 1 des formules matières ne sont pas recopiées.
Les valeurs 1 et 2 des formules opérations ne sont pas recopiées.
Les valeurs 1 à 4 des LCO ne sont pas recopiées.

0 Les valeurs 1 des formules matières sont recopiées.
Les valeurs 1 et 2 des formules opérations sont recopiées.
Les valeurs 1 à 4 des LCO ne sont pas recopiées.

1 Les valeurs 1 des formules matières ne sont pas recopiées.
Les valeurs 1 et 2 des formules opérations ne sont pas recopiées.
Les valeurs 1 à 4 des LCO sont recopiées.

#CF DEG A1[8]

Type de recherche du code papier (ou carton)

1 Recherche classique

2 Recherche avec données techniques

3 Recherche spécifique (papier ou carton)

Q Qualité matière

#CF DEG A1[9]

Recopie des notes

O Les notes sont recopiées lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N Les notes ne sont recopiées ni en copie ni en génération.

C Les notes sont recopiées en copie de devis uniquement. ***

G Les notes sont recopiées en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[10]

Difficulté sur gâche de finition

O On prend en compte une difficulté sur la gâche de finition. Celle-ci doit être saisie sur le tableau complémentaire dans la ligne de code #GF (zone code de difficulté)

N On ne prend pas en compte une difficulté sur la gâche de finition. ***

#CF DEG A1[11]

Conditionnement papier

O On prend en compte le conditionnement papier lors du calcul de celui-ci.

N On ne prend pas en compte le conditionnement papier lors du calcul de celui-ci.

#CF DEG A1[12]

Configuration du F2 sur écran des phases.

O Le F2 sur une phase a un effet immédiat et irréversible.

N Le F2 annule logiquement la phase. La phase n'est annulée physiquement qu'à la validation de l'écran des phases. Cette configuration permet de réintégrer une phase annulée par erreur.

(Pour réintégrer une phase annulée logiquement, refaire F2 sur la phase). ***

#CF DEG A1[13]

Plage de quantité pour opération de roulage en tournée basculable.

N La quantité prise en compte pour la recherche de l'opération de roulage est égale à la quantité roulée
Exemple : 10 000 tours en bascule :
Opération recto : quantité = 10 000. Opération verso : quantité = 10 000

O La quantité prise en compte pour la recherche de l'opération de roulage est égale à la quantité roulée multipliée par 2.
Exemple : 10 000 tours en bascule :
Opération recto : quantité = 20 000. Opération verso : quantité = 20 000
Attention : Cette quantité sera prise en compte pour toutes les tournées.

#CF DEG A1[14]

Confirmation des tournées basculables

O Sur l'écran de définition technique de l'entité, vous devez confirmer la bascule.
Si elle est effectivement confirmée, vous passez à l'écran suivant.
Sinon, vous restez sur l'écran technique pour modification d'une erreur éventuelle.

N Sur l'écran de définition technique de l'entité, pas de demande de confirmation de la bascule.

M Sur l'écran de définition technique de l'entité, vous devez confirmer la bascule. ***
Si elle est effectivement confirmée, vous passez à l'écran suivant.
Sinon la zone est mise à jour et vous passez à l'écran suivant sans possibilité directe de modification.

#CF DEG A1[15]

Le poids devise doit-il être calculé sur la base du format de la feuille ou sur la base du format ouvert de l'ouvrage.

F Format de la feuille + Gâches

O Format fini.

#CF DEG A1[16]

Création d'une autre entité ? (O/N/I)

O Une fenêtre propose de créer une autre entité, avec le bouton Oui par défaut.

N Une fenêtre propose de créer une autre entité, avec le bouton Non par défaut.

I La fenêtre de proposition de création d'une autre entité ne s'affiche pas.

Ce paramètre existe aussi sur le TPR A2[22] où il est prioritaire.

#CF DEG A1[17]

Contrôle technique par rapport à la machine

O On fait un contrôle non bloquant ***

B On fait un contrôle bloquant

N On ne fait pas de contrôle

#CF DEG A1[18]

Nombre de devis dans les statistiques client

O On compte +1 pour chaque sous-devis dans la fiche client. (valeur par défaut)
Chaque variante du devis de base est comptée

N On compte +1 pour chaque devis uniquement ***

#CF DEG A1[19]

Utilisation du tarif pour le papier

N Non

1 Type 1

Code tarif (Roto ou Feuille)

Code article

Mode d'approvisionnement (TAP)

Tonnage

Date

#CF DEG A1[20]

Calcul du devis en heure minute (Utilisable en mécanique uniquement)

O Oui

N calcul en heures centièmes

#CF DEG A1[21]

Recherche de devis par données techniques (Utilisable en mécanique uniquement)

O Oui

N Non (recherche standard)

#CF DEG A1[22]

Nouvelle gestion de la bascule (A utiliser dans toutes les nouvelles installations)

Utilisable uniquement en imprimerie. Obligatoire en roto. Ne pas mettre en carton

On gère le nombre de poses dans la décomposition de la feuille imprimée.

Dans le cas d'une bascule, on impute tout au recto.

O On gère la bascule et le nombre de poses

N On ne gère pas le nombre de poses

#CF DEG A1[23]

Recopie du tableau de marge

O Le tableau de marge est recopié lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N Le tableau de marge n'est recopié ni en copie ni en génération.

C Le tableau de marge est recopié en copie de devis uniquement. ***

G Le tableau de marge est recopié en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[24]

Calcul du calage 1, calage suivant et 1000 de roulage

O On effectue le calcul. Cette option est souvent nécessaire si vous éditez le tableau de marge.

N On n'effectue pas le calcul

#CF DEG A1[25]

Demande de confirmation de modification pour un devis transféré en commande.

O On demande confirmation de modification du devis s'il est déjà transféré en commande.

N On ne demande aucune confirmation

#CF DEG A1[26]

Fenêtre de confirmation pour "génération automatique"

O L'option Oui est proposée en première option

N L'option Non est proposée en première option

X Toujours Oui

Y Toujours Non

#CF DEG A1[27]

Configuration en multi-bandes

O La gestion multi-bandes est active

N La gestion multi-bandes est inactive

#CF DEG A1[28]

Doit-on conserver le code paramètre sur l'écran entité lors de la génération ?

O On conserve

N On efface

#CF DEG A1[29]

Avertissement si prix bloqué, cadence bloquée ou prix valorisé avec papier externe

O On avertit lors de la saisie du numéro de sous-devis de la présence :

• d'un prix papier bloqué

• d'un prix papier valorisé avec papier externe

• de cadence/temps/gâche/prix opération bloqué

• de gâche/prix matière bloqué

• de gâche/prix sous-traitance bloqué

• de prix transport bloqué

N Aucun message d'avertissement

#CF DEG A1[30]

Possibilité d'inhiber certains messages d'avertissements. Messages actuellement pris en compte :

contrôle du format : message indiquant que le papier sera passé dans le mauvais sens.

#CF DEG A1[31]

Une fenêtre d'avertissement s'ouvre si, dans le calcul d'une entité, une opération n'a pas pu être trouvée. On indique la phase, l'opération et la formule.

#CF DEG A1[32]

Recopie des informations complémentaires

O Les informations complémentaires sont copiées lors de la copie d'un devis ou de la génération d'un nouveau devis.

N les informations complémentaires ne sont recopiées ni en copie ni en génération.

C Les informations complémentaires sont recopiées en copie de devis uniquement.

G les informations complémentaires sont recopiées en génération de devis uniquement.

Le renouvellement est une copie.

#CF DEG A1[33]

Recopie du conditionnement

O Le conditionnement est recopié lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N Le conditionnement n'est recopié ni en copie ni en génération.

C Le conditionnement est recopié en copie de devis uniquement. ***

G Le conditionnement est recopie en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[34]

Accès à la zone type de finition sur le premier écran du devis imprimerie.

O La zone est présente et on peut y accéder.

N La zone n'est pas affichée et on ne peut pas y accéder

#CF DEG A1[35]

Accès aux écrans de gestion de l'imposition

O Possibilité d'accéder aux écrans de gestion de l'imposition sur l'écran de l'entité du devis imprimerie (F19,F21,F24)
Obligatoire pour le devis optimisé (afin d'initialiser correctement la dimension engagée utilisée dans le calcul du pliage)

N Impossible d'accéder aux écrans de gestion de l'imposition.

#CF DEG A1[36]

Devis de référence par défaut lors de la recopie

O Le devis proposé lors de la recopie est le devis de référence.

N Le devis proposé lors de la recopie est le sous devis 1 correspondant (si le numéro de sous-devis à créer est > 1).
Exemple : création du devis 95010001 sous-devis 2 :
Recopie : le devis proposé est 95010001 sous-devis 1

#CF DEG A1[37]

Ouverture automatique de la fenêtre du CTRL-N après la génération automatique des notes (F19)

O La fenêtre de saisie des notes s'ouvre automatiquement.

N ou [espace] : La fenêtre de saisie des notes ne s'ouvre pas.

#CF DEG A1[38]

Ouverture automatique de la fenêtre de saisie des lignes complémentaires sur l'entité 99 après avoir saisi le format fini.

O La fenêtre de saisie s'ouvre automatiquement dès que l'on entre sur l'entité 99

N La fenêtre de saisie ne s'ouvre pas.

#CF DEG A1[39]

Recopie du tableau de suivi des dates

O Le tableau de dates est recopié lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N Le tableau de dates n'est recopié ni en copie ni en génération.

C Le tableau de dates est recopié en copie de devis uniquement. ***

G Le tableau de dates est recopié en génération de devis uniquement.

Le renouvellement est une recopie.

#CF DEG A1[40]

Saisie groupée des notes dans le tableau des phases

O La saisie des notes se fera dans un tableau regroupant toutes les phases activées de la gamme.

N La saisie des notes se fera phase par phase.

#CF DEG A1[41]

La formule de calcul utilisée pour le calcul du poids dans le devis est dans la valeur alpha 4 du coefficient de conversion au lieu d'être dans la valeur alpha 1 (cas où la matière n'est pas suivie en stock en kg).

O Le coefficient est en alpha4

N Le coefficient est en alpha1 (par défaut)

#CF DEG A1[42]

La formule de calcul utilisée pour le calcul du tarif (conversion kg --> UA de la matière) est en valeur alpha 3 du coefficient de conversion.

O Le coefficient est en alpha3

N Le coefficient est en alpha1 (par défaut)

#CF DEG A1[43]

Lors de la recopie d'un devis, si le type de produit du source et destination est différent, on va chercher l'entité 99 sur le devis de référence défini derrière le paramètre type de produit du devis destination.

Cette articulation permet de gérer assez simplement des versions de façonnage (BC en BS en PQ).

O On va chercher l'entité 99 sur le devis de référence si type de produit différent.

N On recopie l'entité 99 du devis source vers le devis destination.

#CF DEG A1[44]

Mode de gestion du transporteur

O Mode automatique (transporteur ramené du calcul mais recalcul complet à chaque fois)

S Mode semi-automatique (transporteur ramené du calcul mais pas remis à jour à chaque fois)

N Mode manuel [valeur par défaut] (transporteur non ramené du calcul)

Actuellement, il existe 2 modes de gestion des transporteurs dans les devis transformateurs (devis_tc et devis_standard).

Il y a un mode automatique qui recalcule le transport sans tenir compte du transporteur saisi dans le transport, et un mode manuel qui ne tient pas compte du transporteur relatif au tarif choisi lors du calcul.

Le nouveau mode semi-automatique permet de tenir compte du transporteur saisi dans le calcul du transport (permet d'éviter de valider plusieurs fois la fenêtre proposant les différents tarifs trouvés) ET de récupérer le transporteur du tarif choisi (permet de faire un premier calcul avec tous les transporteurs et de faire un premier choix).

#CF DEG A1[45]

Gâche de finition

O La gâche de finition sera saisie manuellement dans les données complémentaires (code ligne #GF, zone numérique 1 --> Gâche fixe, zone numérique 2 --> Gâche variable)

P La recherche gâche de finition sera paramétrable. Utilisation de la formule ### #GF

L La gâche de finition sera saisie manuellement dans des données complémentaires paramétrables sur le paramètre de type TPR

I La lecture des gâches de finition passe par la formule IMF GF (gâche fixe) et IMF GV (gâche variable).
Dans le devis multi-métiers, on recherche par défaut les gâches de finition fixes et variables via les formules de calcul figées IMF GF et IMF GV.
Les dépendances sont libres. Le code section, opération et sous-opération de la formule représente le triplet sur lequel s'effectue la recherche.

S La recherche de la gâche de finition se fait sur l'opération IMF-IMF-GF.
La dépendance prise en compte est la surface totale.

T La recherche de la gâche de finition se fait sur l'opération IMF-IMF-GF.
La dépendance prise en compte est le nombre de tours.

N La recherche de la gâche de finition se fait sur l'opération IMF-IMF-GF (par défaut).
La dépendance prise en compte dépend du type de devis (F/T/C/I/O/B)

F Nombre de tours

T Nombre de tours

C Nombre de tours

I Nombre de tours

O Surface totale

B Surface totale

#CF DEG A1[46]

Génération automatique de la phase EMF (O/N, N par défaut)

#CF DEG A1[47]

Génération automatique de la phase EMC O/N, N par défaut)

#CF DEG A1[48]

Génération automatique de la phase EMP (O/N, N par défaut)

#CF DEG A1[49]

Utilisation du tableau données complémentaires. 1 ligne par zone.

O Utilisation du nouveau tableau

N Utilisation de l'ancien tableau

#CF DEG A1[50]

On affichera une ligne total dans l'écran récapitulatif des sous-devis.

Valeur alpha 2

#CF DEG A2[1,3]

Code paramètre pour le lancement du programme Windows (F26)

Exemples : PVI pour Picvisu - PPA pour Pic param

#CF DEG A2[4]

E code ECMA (PIC VISU)

F fichier (PIC PARAM)

#CF DEG A2[5,54]

Chemin d'accès disque NFS. Exemple : /windows/picador

#CF DEG A2[55]

Copie des amalgames de chaque entité lors de la génération et de la recopie d'un devis.

(Amalgames actifs seulement dans le devis carton plat)

O Copie des amalgames (génération et recopie)

N Pas de recopie des amalgames.

#CF DEG A2[56]

Existence des codes produits sur amalgames

O Les codes produits saisis sur l'amalgame (devis carton) sont contrôlés (existence vérifiée).
Le contrôle est non bloquant.

B Les codes produits saisis sur l'amalgame (devis carton) sont contrôlés (existence vérifiée).
Le contrôle est bloquant.

N Les codes produits saisis sur l'amalgame (devis carton) ne sont pas contrôlés.

#CF DEG A2[57]

Présentation du dernier numéro de devis (O/N, N par défaut

O Si l'utilisateur ne renseigne pas le numéro de devis, le système lui affiche le dernier numéro de devis

N Si l'utilisateur ne renseigne pas le numéro de devis, le système passe en création de devis

Uniquement pour la saisie des devis multi-métiers :

Présentation du dernier numéro de sous-devis existant après la saisie d'un numéro de devis (O/N, N par défaut)

Remarques :

• Si l'utilisateur n'est pas autorisé à créer les autres sous-devis que le premier, c'est le premier numéro de sous-devis qui sera présenté (voir paramétrage ci-dessous).

• Si la présentation du dernier numéro de sous-devis est activée, la création d'un nouveau sous-devis se fait en effaçant le numéro présenté.
Le système proposera alors un nouveau numéro de sous-devis.

Voir aussi :

USE A2[9] Autorisation de créer le premier sous-devis (O/N, N par défaut)

USE A2[10) Autorisation de créer les autres sous-devis (O/N, N par défaut)

#CF DEG A2[58]

Affectation automatique de la désignation du devis si le produit est un produit fini

O Le champ l2_desdev est initialisé par mp_des.

Le champ l2_desdev2 est initialisé par mp_at2.

D Le champ l2_desdev est initialisé par mp_des.

Le champ l2_desdev2 est initialisé par mp_des2.

N Pas d'affectation automatique (par défaut)

L Le champ l2_desdev est initialisé par mp_des.

Le champ l2_desdev2 est initialisé par le_libpar1 du produit final.

#CF DEG A2[59]

Affectation du type de finition à la création du sous-devis 99

R Rang de tirage : affectation des 3 premiers caractères de la zone de rangement 2 du produit.

N Pas d'affectation à la création

#CF DEG A2[60]

Sélection de l'impression de la contrepartie.

O impression

Par défaut : pas d'impression.

Valeur alpha 3

#CF DEG A3[1]

Dans le devis carton (devis_dco) et le devis sérigraphie (devis_ser), au niveau de chaque ligne sur le premier écran :

1 Tableau complémentaire rattaché au sous-devis

2 Tableau complémentaire rattaché à l'entité

3 Ouverture d'une fenêtre pour effectuer un choix manuel entre sous-devis et entité.

#CF DEG A3[2]

Mode de fonctionnement du tableau multi-bandes

O Chargement des informations articles

N Pas de chargement

#CF DEG A3[3]

Ouverture automatique de l'écran des lignes complémentaires après validation de l'écran des entités (devis feuille)

O Ouverture automatique

N Pas d'ouverture

#CF DEG A3[4]

Recalcul du tableau des emballages

O Recalcul du tableau.
Pour que le tableau soit réactualisé, il est nécessaire d'avoir la phase EMF (mise sous paquet), EMC (mise sous caisse) ou EMP (mise sur palette).
Le tableau est réactualisé, de la même manière que si l'on venait ressaisir les codes paquets, caisse et palette.

N Pas de recalcul

#CF DEG A3[5]

Toute modification du prix papier positionne la rubrique Papier bloqué à O

O Cette fonction est active

N ou [espace] Cette fonction n'est pas active.

#CF DEG A3[6]

Permet d'utiliser un numéro de phase fixe pour chaque code phase.

(Quand on fait F1 sur le tableau des phases, on attribue un numéro de phase fixe).

Le numéro de phase est paramétré sur le paramètre de la phase (alpha3[52,54)

O Insertion des phases avec numéro fixe

N ou [espace] Option non active

#CF DEG A3[7]

Ouverture automatique de l'écran transport (CONTROL-B) après validation de l'écran des entités (devis feuille) et uniquement pour l'entité 99.

O Ouverture automatique

N Pas d'ouverture

T ouverture automatique pour toutes les entités

#CF DEG A3[8]

Arrêt automatique du processus de calcul dès la première erreur de calcul sur une phase.

Remarque : la phase est toujours complètement calculée

O Arrêt automatique

N Pas d'arrêt (par défaut)

#CF DEG A3[9]

Recalcul du récapitulatif devis à chaque calcul d'entité.

O On recalcule tout le récapitulatif à chaque calcul d'une entité (par défaut)

Gain de sécurité

N Le recalcul complet n'est fait qu'au recalcul du sous-devis. Gain de performance

#CF DEG A3[10]

Unité de stockage de l'information surface sur devis_dco :

M en mètres carrés

C ou [espace] en centimètres carrés

#CF DEG A3[11]

Positionnement de l'option par défaut dans la confirmation de recopie des sous-devis

O ou [espace] : Oui par défaut

N Non par défaut

#CF DEG A3[12]

La date de décision est égale à blanc par défaut

N ou [espace] elle est égale à la date du jour

O elle est égale à blanc

#CF DEG A3[13]

Récupération du format de l'entité précédente

N ou [espace] : pas de récupération

O récupération

#CF DEG A3[14]

Gestion de la bascule manuellement

N ou [espace] : gestion classique

O gestion manuelle

#CF DEG A3[15]

Ouverture automatique de la saisie des marges lors du passage sur le dernier écran

N ou [espace] : pas d'ouverture automatique

O ouverture automatique

#CF DEG A3[16,18]

Type paramètre de la zone paramétrable du premier écran de saisie

#CF DEG A3[19]

Contrôle unicité produit - Fonctionne avec les caractères 20 à 22.

O contrôle unicité

N ou [espace] pas de contrôle

#CF DEG A3[20,22]

Type de devis. Lors de la saisie du code produit sur le premier écran du devis imprimerie, si le type de devis est égal à celui qui est paramétré ici, alors on vérifie qu'il n'existe pas d'autre devis du même type ayant le même produit.

#CF DEG A3[23]

Gestion d'un groupement des bandes

N ou [espace] Pas de regroupement

O Regroupement

#CF DEG A3[24]

Génération automatique des bandes à la validation de la décomposition de la forme imprimante

N ou [espace] Pas de génération

O Génération

#CF DEG A3[25]

Mise à jour automatique des bandes après modification d'un élément de l'entité

N ou [espace] Pas de mise à jour

O Mise à jour

#CF DEG A3[26]

Ouverture d'un écran de sélection multicritères sur le F7 des machines d'impression

N ou [espace] Pas d'ouverture

O ouverture

#CF DEG A3[27,29]

Code de l'environnement de travail utilisé dans la valorisation globale du devis par centres de coûts.

Voir les notes sur les gammes

#CF DEG A3[30]

Désactivation de la réattribution des marges

#CF DEG A3[31]

Inversion des rôles entre l'écran récapitulatif et le tableau des marges

#CF DEG A3[32]

Gestion cameron.

#CF DEG A3[33]

Enchaînement de la génération des notes après validation du tableau des marges

#CF DEG A3[34]

Génération du devis avec le devis du produit

#CF DEG A3[35]

Gestion des amalgames.

#CF DEG A3[36]

Mode d'accès à la commission du représentant

R ou [espace] Commission donnée par le code représentant

C Commission donnée par le client via le fichier des barèmes avec :

Code tarif = #CR

Code client du devis

Date de création du devis

Quantité devisée

Si cette commission n'est pas trouvée, on conserve la commission donnée par la fiche représentant.

#CF DEG A3[37]

Saisie de dossier de fabrication (O/N, N par défaut)

O On est en saisie du dossier de fabrication

Dans ce cas, on veillera à indiquer un #CF DEG distinct de celui du devis, dans le paramètre de lancement du devis multi-métiers en A2[1,3].

N On est en saisie de devis (par défaut)

#CF DEG A3[38]

Ce caractère permet de garder les marges même en cas de recalcul du sous-devis.

#CF DEG A3[39]

Ce caractère permet de remettre à zéro les marges dans le cas de création de dossier de fabrication

#CF DEG A3[40]

Ce caractère permet d'imposer un nombre de tournées entier en saisie d'entités.

#CF DEG A3[41]

Gestion globale du pliage sur l'entité 99

#CF DEG A3[42]

Toute entité dont le numéro est supérieur à 90 sera considérée comme une entité de façonnage.

#CF DEG A3[43]

Regroupement des papiers sur le CONTROL-P.

On effectue des regroupements sur le code papier, le format et le code stock .

#CF DEG A3[44]

Utilisation des modules d'optimisation.

#CF DEG A3[45]

Les sous-devis copiés sont crées avec le type sous-devis NOR

#CF DEG A3[46]

Application de la règle du payant pour le calcul du transport

#CF DEG A3[47]

En fiche de fabrication, après avoir tapé le numéro de la fiche, si la fiche n'existe pas, on crée la fiche par recopie du devis correspondant au produit de la première ligne de commande (dont le numéro est à celui de la fiche de fabrication)

#CF DEG A3[48]

Contrôle surface de la décomposition de la feuille avec le format de tirage.

#CF DEG A3[49]

Lors du changement du chiffre de tirage du devis, on ne met pas à jour l'emballage et le conditionnement.

#CF DEG A3[50]

Permet de demander si l'on doit relancer le calcul du devis avant de quitter le devis par F6.

#CF DEG A3[51]

Au moment de la validation du produit sur le premier écran du devis, permet de mettre à jour la zone devis, sous-devis de l'article avec le devis courant.

Attention si l'option alpha3[19] est active, on mettra à jour l'article uniquement si le type du devis courant est identique au type défini en alpha3[20,22].

#CF DEG A3[52]

Nouvelle saisie des livraisons et du conditionnement :

N ou [espace] ancienne saisie

1 ou O nouvelle saisie version 1

2 nouvelle saisie version 2

#CF DEG A3[53]

Calcul automatique des livraisons à la sortie saisie s'il y eu une modification (valable uniquement dans la nouvelle saisie).

N ou [espace] pas de calcul

O calcul

#CF DEG A3[54]

Gestion du nombre de paquets en nombre d'exemplaires ou en Kg.

O Gestion en nombre d'exemplaires

N ou [espace] Gestion au Kg.

#CF DEG A3[55]

Prise en compte du nombre de tournées dans le poids des entités multi-bandes.

O Le nombre de tournées est pris en compte.

N ou [espace] : Le nombre de tournées n'est pas pris en compte.

#CF DEG A3[56]

A l'exécution du calcul d'un devis, lorsque l'on rencontre une formule automatique et que l'on ne trouve pas d'opération élémentaire :

N ou [espace] : on ne fait rien

1 on affiche les sources possibles d'erreurs (notes saisies sur la formule)

2 on recherche la dépendance responsable de l'erreur et on affiche un message personnalisé.

#CF DEG A3[57]

Contrôle de validation des notes par défaut après saisie dans note_dev.

N ou [espace] : Pas de contrôle

O contrôle

#CF DEG A3[58]

Lors de la recopie de devis, on conserve le représentant et la commission du devis copie et non ceux du client pour lequel on copie le devis.

N ou [espace] : Représentant et commission du client

O Représentant et commission du devis copie.

#CF DEG A3[59]

Pas de mise à jour du transport si changement client.

N ou [espace] : le transport est mis à jour

O le transport n'est pas mis à jour

#CF DEG A3[60]

Possibilité de mettre à jour le format fini des entités avec le format fini saisi sur l'entête du devis

N Pas de mise à jour (par défaut)

W Demande de confirmation

O Mise à jour systématique avec affichage d'un message d'avertissement

F Mise à jour systématique sans affichage d'un message d'avertissement

Dans le cas des FEUillets et des DEPliants (TPR A1[21,23]), la pagination saisie sur l'entête mettra à jour la pagination des entités. Voir TPR A4[36]

Valeur alpha 4

#CF DEG A4[1]

Numéro du compteur pour la numérotation des devis. Par défaut le numéro de compteur est nul.

#CF DEG A4[2]

Numérotation automatique des devis

O Numérotation automatique activée (par défaut)

N Numérotation automatique désactivée

Remarque : Sur le premier écran du devis, la touche F24 permet de basculer du mode numérotation automatique au mode numérotation manuelle et inversement.

#CF DEG A4[3 à 5]

Type de la commande qui peut être générée avec la fiche de fabrication (si rien : FB2)

#CF DEG A4[6]

Accès à la fonction de transfert des devis vers PROSPER (Oui/Non)
ATTENTION : cet accès ne peut être paramétré que pour les fiches de fabrication (-Off)

#CF DEG A4[7]

Réservé (transfert devis depuis PROSPER)

#CF DEG A4[8]

Mise à jour du code tarif en fonction du client

#CF DEG A4[9]

Activation de l'utilisation des LCO contextuelles dans le devis (O/N)

Ouverture automatique sur les zones paramétrées dans les notes des LCO

#CF DEG A4[10]

Mode de gestion du devis

O Devis avec gestion des options (phases au 1000, récap au 1000, recherche avec variantes)

N Gestion normale du devis

#CF DEG A4[11]

Activation d'un message d'avertissement si le code produit du sous devis est un produit simple alors qu'il y a plusieurs entités dans le sous devis.

#CF DEG A4[12]

Saisie des tableaux de placements / coupes pour les massicots.

O Oui

N Non (par défaut)

#CF DEG A4[13]

Mise à jour du coût du transport si prix forcé suite à la modification de la quantité du sous-devis (ou création d'une nouvelle variante de quantité)

1 Remise à blanc systématique du prix (par défaut ou si le prix n'est pas forcé)

2 Le prix forcé n'est pas modifié

3 Proratisation du prix forcé

4 Suppression du forçage du prix (le prix n'est pas modifié)

Dans les cas 1, 2 et 3, un message avertit l'utilisateur de la présence d'un prix de transport forcé.

#CF DEG A4[14]

Recopie de la feuille de calcul

O La feuille de calcul est recopiée lors de la recopie d'un devis ou de la génération d'un nouveau devis.

N La feuille de calcul n'est recopiée ni en copie ni en génération.

C La feuille de calcul est recopiée en copie de devis uniquement.

G La feuille de calcul est recopiée en génération de devis uniquement.

#CF DEG A4[15]

Mise à jour de l'article sous-traité en recopie de devis (O/N, N par défaut)

#CF DEG A4[16]

Les dimensions de l'article sont en mm.

O oui

N non (par défaut, donc elles sont en cm)

Cette information a priorité sur TEN A1[1].

#CF DEG A4[17]

Recopie des schémas

O Les schémas sont copiés lors de la copie d'un devis ou de la génération d'un nouveau devis.

N Les schémas ne sont recopiés ni en copie ni en génération.

C Les schémas sont recopiés en copie de devis uniquement.

G les schémas sont recopiés en génération de devis uniquement.

Le renouvellement est une copie.

#CF DEG A4[18]

Autorise la suppression du conditionnement si l'ensemble devisé est monté.

O On autorise la suppression du conditionnement

N La suppression n'est possible que si l'ensemble n'est pas généré ou qu'il n'est pas intégré dans une nomenclature (fonctionnement par défaut)

#CF DEG A4[19]

Mode de gestion de la zone PF par charge

O La zone PF par charge contient le nombre réel de PF sur la palette (Valeur par défaut)

N La zone PF par charge contient le nombre de PF pouvant être conditionnés sur la palette

#CF DEG A4[20]

Mode de fonctionnement du conditionnement (Nombre de paquets, caisses et palettes)

1 Les données du conditionnement sont lues et enregistrés sur la première ligne de la table fle_emb

2 Les données du conditionnement sont lues et enregistrés sur des lignes complémentaires (LCO) :

LCO EMF : Nombre de paquets

LCO EMC : Nombre de caisses

LCO EMP : Nombre de palettes

#CF DEG A4[21]

Accès au nouvel écran des phases (O/N)

#CF DEG A4[22]

Prise en compte de la date de début de validité pour la recherche du taux dans les centres de coûts

(O/N)

#CF DEG A4[23]

Vérification de l'appartenance d'un produit à un client dans l'écran des références multiples du devis standard

B Bloquant

C Demande de confirmation

W Avertissement

N Aucune vérification

#CF DEG A4[24]

Hors Gâche ou Hors Gâche Impression

N Hors Gâche (Valeur par défaut)

O Hors Gâche Impression

#CF DEG A4[25]

Recopie ou non du multi-papier (O/N, O par défaut)

Permet de recopier ou non le multi-papier dans la recopie d'entité

(LCO PA0 à PA9 et PAP et formules matières PA0 à PA9 de la phase PAS)

#CF DEG A4[26]

Récupération du code fournisseur et mise à jour de la zone correspondante dans l'entité (fle_imp.fi_fournisseur) lors de la recherche de tarif papier/qualité (O/N, N par défaut)

#CF DEG A4[27]

Recopie du numéro d'affaire / ligne lors de la recopie d'un devis / sous-devis

(O/N, N par défaut)

#CF DEG A4[28]

Désactiver le facteur multiplicateur paramétré en caractères 5 et 6 des codes calculs

O Oui, je veux désactiver le facteur multiplicateur

N Non, je ne veux pas désactiver le facteur multiplicateur (par défaut)

IMPORTANT : voir les réserves dans le chapitre consacré au facteur multiplicateur.

#CF DEG A4[29]

Accès à la commission du représentant dans le devis multi-métiers (zone masquée)

O Pas d'accès et zone masquée

N Accès autorisé et zone visible (par défaut)

#CF DEG A4[30]

Valeur par défaut en création de devis de la zone jonction (O/N, N par défaut)

Utilisée dans le devis_tc

L'initialisation de cette zone est faite au préalable sur le devis de référence.

Si elle n'est pas renseignée sur le devis de référence, alors l'initialisation se fait ici.

SI elle est renseignée sur le devis de référence et alpha1[4] = O, alors l'initialisation se fait ici.

#CF DEG A4[31]

Valeur par défaut en création de devis de la zone colisage (O/N, N par défaut)

Utilisée dans le devis_tc

L'initialisation de cette zone est faite au préalable sur le devis de référence.

Si elle n'est pas renseignée sur le devis de référence, alors l'initialisation se fait ici.

SI elle est renseignée sur le devis de référence et alpha1[4] = O, alors l'initialisation se fait ici.

#CF DEG A4[32]

Recopie des informations clients (Code et adresse secondaire) lors de la recopie de devis

O Le client et son adresse sont récupérés sur le devis à copier.

N: Le client et son adresse ne sont récupérés sur le devis à copier que si aucun code client n'a été renseigné avant la copie.

#CF DEG A4[33]

Utilisation des gâches cumulatives (O/N, N par défaut)

Voir aussi les notes sur les formules

#CF DEG A4[34]

Interdiction de suppression d'un devis, d'une entité ou d'une ligne de nomenclature lorsque le devis a été transféré en commande (O/N, N par défaut)

#CF DEG A4[35]

Mode de recopie des références multiples lors de la recopie d'entité

O On recopie les références multiples dans tous les cas. (par défaut)

N On ne recopie jamais les références multiples.

C On recopie les références multiples sur demande de confirmation.

Ce paramétrage n'est utilisé que pour la recopie directe d'entité.

Lors de la recopie d'un sous-devis complet, les références multiples sont recopiées dans tous les cas.

#CF DEG A4[36]

Pour le devis standard

Niveau du contrôle sur la cohérence entre la pagination issue des plis saisis et de la pagination totale de l'entité.

B (bloquant

W (warning)

N (non bloquant) par défaut

#CF DEG A4[37]

Unité de mesure de la quantité traitée dans le pliage

Voir aussi O/PLI/51 : Dépendance numérique 4 au nombre d'exemplaires

O La quantité traitée dans le pliage est en nombre d'exemplaires.

N La quantité traitée dans le pliage est en mètres linéaires (par défaut)

idem caractère 39 de la note OPT_OPE_PLIAGE_ROU sur le TEN.

#CF DEG A4[38]

Enregistrement automatique des machines possibles dans le devis multi-métiers afin de permettre de les utiliser lors de la génération du fichier des tâches Preactor

#CF DEG A4[39]

Traitement du vernis hors ligne sur l'écran ETIFEU

O Indication sur l'écran de la présence du vernis hors-ligne et indication dans un écran complémentaire du détail du vernis (type, pourcentage et machine pour le recto et le verso)

N (par défaut) Indication du type de vernis hors ligne utilisé.

#CF DEG A4[40,41]

Racine TSC pour l'enregistrement des codes blocages sur devis

Par défaut : BD

#CF DEG A4[42]

Réactualisation des dates de validité lors du recalcul

O Réactualisation systématique

C Réactualisation sur demande de confirmation

N Pas de réactualisation

Permet de réactualiser les dates de validité lors du recalcul du sous-devis en cours selon les règles suivantes :

• Date de début de validité = date du jour

• Date de fin de validité = [selon le paramétrage du code barème (TAR)]

#CF DEG A4[43]

Prise en compte des vernis totaux (coefficient de vernissage égal à 100%) pour la comptabilisation du nombre de plaques (O/N, N par défaut)

Utilisé dans les formules suivantes :

Formules figées matières concernées par ce paramétrage :

mpla3

mpla4

mpla52

mpla53

Formules figées opérations concernées par ce paramétrage :

oimf16

oimf17

oimf18

oimf19

oimf30

oimf52

oimf53

#CF DEG A4[44]

Contrôler la compatibilité vernis/machine (avertissement non bloquant) (O/N, N par défaut)

#CF DEG A4[45]

Mise à jour des informations du correspondant à partir du devis (O/N, N par défaut)

cde1.ec_titre = fle_2.l2_tit_corres (Titre du correspondant)

cde1.ec_corres = fle_2.l2_corres (Nom du correspondant)

#CF DEG A4[46]

Mise à jour des informations du suivi d'affaire à partir du devis (O/N, N par défaut)

devis.4ge : cde1.ec_suiv = fle_2.l2_deviseur (Deviseur)

devis_standard.42r : cde1.ec_suiv = fle_2.l2_suiv (Suivi d'affaire)

#CF DEG A4[47]

Mise à jour de la référence de la commande à partir du devis

1 cde1.ec_texte = fle_2.l2_desdev1 (1ière ligne de désignation)

2 cde1.ec_texte = fle_2.l2_desdev2 (2ème ligne de désignation)

N Pas de mise à jour (par défaut)

Ce paramétrage est prioritaire par rapport à l'option Oml (sur devis ou devis_standard)

CF DEG A4[48]

Mise à jour de la désignation de la ligne de commande à partir du devis

1 cde2.lc_lib = fle_2.l2_desdev1 (1ière ligne de désignation)

2 cde2. lc_lib = fle_2.l2_desdev2 (2ème ligne de désignation)

N Pas de mise à jour (par défaut)

Remarque : Ce paramétrage est prioritaire par rapport à l'option Oml (sur devis ou devis_standard)

#CF DEG A4[49]

Activation du devis optimisé.( O/N, O par défaut). Le paramètre #CF OPT doit exister

#CF DEG A4[50]

Interdiction de recopie d'un sous-devis sans entité 1

O La recopie d'un sous-devis sans entité 1 est possible. Dans ce cas, les numéros d'entités sont décalés lors de la recopie (les entités 2, 3, 4 deviennent les entités 1, 2 et 3) (Par défaut)

C La recopie d'un sous-devis sans entité 1 n'est possible que sur confirmation de la part de l'utilisateur. Dans le cas où la recopie est autorisée par l'utilisateur, les numéros d'entités sont décalés lors de la recopie (les entités 2, 3, 4 deviennent les entités 1, 2 et 3)

N La recopie d'un sous-devis sans entité 1 est strictement interdite.

#CF DEG A4[51]

Recherche automatique de la plieuse selon le code pli/site de production de l'entité (si saisi) (O/N, N par défaut)

Tableau de bord du multisite

#CF DEG A4[52]

Réinitialisation des forçages des prix existants sur les formules matières (valeur remise à N)

O Réinitialisation systématique des forçages

C Réinitialisation des forçages sur confirmation
(la confirmation est demandée à la première formule rencontrée pour laquelle le prix matière est forcé).

N Pas de réinitialisation, la valeur du forçage est recopiée telle quelle.

#CF DEG A4[53]

Réinitialisation des forçages des prix existants sur les formules opérations (valeur remise à N)

O Réinitialisation systématique des forçages

C Réinitialisation des forçages sur confirmation
(la confirmation est demandée à la première formule rencontrée pour laquelle le prix opération est forcé).

N Pas de réinitialisation, la valeur du forçage est recopiée telle quelle.

#CF DEG A4[54]

Réinitialisation des forçages des prix existants sur les formules sous-traitance (valeur remise à N)

O Réinitialisation systématique des forçages

C Réinitialisation des forçages sur confirmation
(la confirmation est demandée à la première formule rencontrée pour laquelle le prix sous-traitance est forcé).

N Pas de réinitialisation, la valeur du forçage est recopiée telle quelle.

#CF DEG A4[55]

Activation de l'utilisation des TSC contextuelles dans le devis (O/N, N par défaut)

Ouverture automatique sur les zones paramétrées dans les notes des TSC

En savoir plus sur l'ouverture contextuelle des informations complémentaires (TSC)

Notes triées

1

Paramétrage des formules entrant dans le calcul du premier calage.

Le calcul est effectué en prix de revient.

Attention : On ne doit indiquer ici que les formules qui différencient le premier calage des suivants. Le système ajoutera automatiquement le prix du calage suivant.

Exemple : Trace, montage, mise au format, ...

Si on indique une formule correspondant à des frais variables, on ne prend que le coût lié à la gâche fixe.

2 Type de formule

O pour une formule opération

M pour une formule matière

S pour une formule sous-traitance

3 à 5 Code phase

6 à 8 Code formule

CCAI

Complément de requête sur table mat pour la recherche des caisses

Exemple : CCAI and mp_code matches "CAI*"

Les 3 notes CCAI, CPAL, CPAQ doivent être paramétrées.

Exemple si non utilisé : CCAI and 1=1

CDEVTYP

8,10 Type de note sur deviseur (par défaut : #)

CONFIG_PAR_CHAR_1

Recherche sur la zone paramétrable alphanumérique 1

Paramétrer aussi les notes LIB_ZONE_PAR_CHAR_1 et _SUP_SQL_PAR_CHAR_1

21 Source de la donnée à saisir dans la zone paramétrée alphanumérique 1

A Code article

L Libre (par défaut)

22 En fonction de la source :

Si la source est un article (A) :

Type de recherche article

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche papier

5 Recherche des produits sur fournisseur

Q Recherche qualité carton

T Recherche transformateur

Si la source est libre (par défaut) : La recherche sur le champ est désactivée.

23 Saisie de la zone obligatoire (O/N, N par défaut)

CONTRAINTES_CLI_DEF

21 Active la recherche des contraintes client par défaut sur l'adresse principale du client (O/N)

COPIE_DEV_REINIT_SCE

21 Réinitialisation du scénario du calcul lors de la recopie d'un sous-devis

(hors génération, dans ce cas, on prend le scénario de calcul du sous-devis par défaut) O/N, N par défaut)

22,24 Code scénario de calcul par défaut (doit correspondre à un type de paramètre SCE). Laisser à blanc pour effacer le scénario de calcul.

CPAL

Utilisées entre autres dans l'optimisation du conditionnement

Complément de requête sur table mat pour la recherche des palettes

Exemple : CPAL and mp_code matches "PAL*"

Les 3 notes CCAI, CPAL, CPAQ doivent être paramétrées

Exemple si non utilisé : CPAL and 1=1

CPAQ

Complément de requête sur table mat pour la recherche des paquets

Exemple : CPAQ and mp_code matches "PAQ*"

Les 3 notes CCAI, CPAL, CPAQ doivent être paramétrées

Exemple si non utilisé : CPAQ and 1=1

FORMULE_CONV_UNITE

Formule de conversion

21,23 Unité de départ

24,26 Unité d'arrivée

27,29 Code phase

30,32 Code formule

33,33 Type de formule (M,O,S)

Plus d'explications sur cette note

Calcul des gâches cumulatives- Gestion du multi-passages : Voir aussi le code calcul MP

Voir aussi les notes sur les formules

LIB1

Libellé affiché devant la première ligne de désignation du devis.

Par défaut : Désignation du devis

Attention, limité à 20 caractères

Seule la première note est prise en compte.

LIB2

Libellé affiché devant la seconde ligne de désignation du devis

Pas de valeur par défaut

Attention, limité à 20 caractères

Seule la première note est prise en compte.

LIB_AFFAIRE

21,60 Libellé de la zone Affaire (fle_2.l2_num_affaire)

Permet de paramétrer ce libellé dans l'entête du devis multi-métiers.

Par défaut : Affaire

LIBF

Libellé affiché devant la ligne de type de finition du devis

Par défaut : FINITION Type

Attention, limité à 15 caractères

Seule la première note est prise en compte.

LIB_REF_CLIENT

21,60 Libellé de la zone Référence client (fle_2.l2_refcli)

Permet de paramétrer ce libellé dans l'entête du devis multi-métiers.

Par défaut : Référence

LIB_SITE_PRODUCTION

21,60 Libellé pour la zone Site de production (l2_site) sur l'entête du devis

Tableau de bord du multisite

Par défaut : Site de production

LIB_ZONE_PAR_CHAR_1

Recherche sur la zone paramétrable alphanumérique 1

Paramétrer aussi les notes CONFIG_PAR_CHAR_1 et _SUP_SQL_PAR_CHAR_1

21,60 Libellé de la zone paramétrée alphanumérique 1

Important : La saisie de ce libellé conditionne la présence du champ de recherche sur les écrans de recherche du devis (standard et visualisation).

LIEN_MACHINE_PLI

21, 23 Code de lien par défaut (type #LI) entre les tables machine (mac0) et pli (par02).

La note CODE_LIEN_TABLES du paramètre TMC est prioritaire.

MAJ_LCO_PAR_DEFAUT

21,23 Code LCO pour laquelle les valeurs par défaut doivent être remises en place

(nécessite le paramétrage d'une note de type #X sur la LCO).

MAJQTE

Lors du changement de la quantité devisée, les opérations paramétrées derrière ces notes voient leur quantité mise à jour automatiquement et proportionnellement.

Exemple 1 : Qté devise = 10000 : Qté opération = 1000

Exemple 2 : L'utilisateur change la quantité devise = 20000.

La quantité de l'opération passe à 1000*20000/10000=2000

7 Type de formule

O Opération

M matière

S sous traitance

8 à 10 Code phase

11 à 13 Code formule

_NOM_SANS_ACCES_ENT

21 Interdire l'accès aux entités à partir des onglets de la nomenclature (O/N)

O Les boutons d'accès aux entités ne s'afficheront pas dans les onglets de la saisie de la nomenclature

N Les boutons d'accès aux entités s'afficheront dans les onglets de la saisie de la nomenclature [Valeur par défaut]

_ORDER_BY_CHX_GAMME

21,60 Complément d'order by sur les tables g_ecma et g_std_e

Exemple

_ORDER_BY_CHX_GAMME ge_code_gamme desc

OUVERTURE_LCO_CALCUL

21 à 23 Code de la phase à recalculer

PWD

Lors du calcul d'une entité, si le programme détecte une erreur et que l'arrêt du calcul est paramétré (A3[8] = O), un mot de passe est demandé pour continuer

R

Le calcul est effectué en prix de revient.

Paramétrage des formules entrant dans le calcul du 1000 de roulage.

(Coût du roulage / Nombre de tours hors gâche machine)

On exclut les gâches fixes.

2 Type de formule

O pour une formule opération

M pour une formule matière

S pour une formule sous-traitance

3 à 5 Code phase

6 à 8 Code formule

S

Paramétrage des formules entrant dans le calcul du calage suivant.

On totalise tous les coûts puis le total est divisé par le nombre de tournées.

Les frais indiqués dans le paragraphe précédent ne doivent pas figurer ici.

Le calcul est effectué en prix de revient.

Si on indique une formule correspondant à des frais variables, on ne prend que le coût lié à la gâche fixe.

2 Type de formule

O pour une formule opération

M pour une formule matière

S pour une formule sous-traitance

3 à 5 Code phase

6 à 8 Code formule

SENT

Complément de requête pour la recherche des devis en copie d'entités

20 à 60 Critère de sélection (Exemple : SENT l2_type_dev = STD)

On peut saisir autant de lignes que l'on veut.

SFAC

Complément de requête pour la recherche des devis en copie d'entité 99

20 à 60 Critère de sélection (Exemple : SFAC l2_type_dev = STD)

On peut saisir autant de lignes que l'on veut.

_SUP_SQL_PAR_CHAR_1

Recherche sur la zone paramétrable alphanumérique 1

Paramétrer aussi les notes LIB_ZONE_PAR_CHAR_1 et CONFIG_PAR_CHAR_1

21,60 Complément de sélection pour la recherche de la donnée à saisir dans la zone paramétrée alphanumérique 1.

Important : Le mot-clé %CLIENT% sera remplacé automatiquement à l'exécution par le client du sous-devis courant.

Si la source est un article (A) :

Complément de sélection sur la table des articles (mat).

Exemple : and mp_cli = "%CLIENT%"

Si la source est libre (par défaut) : La recherche sur le champ est désactivée.

TOUCHE_CONTEXTE_

TOUCHE_CONTEXTE_REF

TOUCHE_CONTEXTE_IMP

TOUCHE_CONTEXTE_LCO

TOUCHE_CONTEXTE_TSC

Permettre de paramétrer les touches qui activeront les ouvertures contextuelles des écrans de saisie des références multiples (entête/entité) et lignes d'impression multiple.

17,19 Code écran contextuel

REF Saisie des références multiples (entête/entité)

IMP Saisie des lignes d'impression multiple

LCO Saisie des lignes complémentaires

TSC Saisie des infos complémentaires

21,40 Combinaison de touches déclenchant l'ouverture contextuelle des écrans

tab Tabulation vers le champ suivant

return Retour/Entrée vers le champ suivant

shift-tab Tabulation vers le champ précédent

accept Validation de l'écran

41,60 Nom du champ pour lequel la combinaison de touches est active.

REF Saisie des références multiples sur l'entête du sous-devis

Activation par TPR A4[16]

Ecran ENTETE : Ouverture avant le champ l2_bareme Nombre de références de l'entête du sous-devis

REF Saisie des références multiples sur l'entité boîte pliante d'un sous-devis

Activation par TEN A4[15]

Écrans FEUDEP : Ouverture après le champ fi_nb_references Nombre de références de l'entité d'un sous-devis

BOIPLI

ETIBOB

ETIFEU

TRFCAR

SAILCO

IMP Saisie des lignes d'impressions multiples sur l'entité d'un sous-devis

Activation par TEN A2[60]

Ecran BOIPLI : Ouverture avant les champs fi_co_recto Nombre de couleurs au recto

fi_equerre Présence de massicot

Ecran ETIBOB : Ouverture avant les champs fi_co_recto Nombre de couleurs au recto

fi_dorure : Présence de dorure

Ecran TRFCAR: Ouverture avant le champ fi_co_recto Nombre de couleurs

LCO Saisie des lignes complémentaires

Les champs disponibles sont les mêmes que ceux de la note CONTEXTE_LCO du paramètre LCO.

Cette note n'est pas prise en compte dans le cas d'une ouverture contextuelle de LCO à la validation d'un écran.

TSC Saisie des informations complémentaires

Les champs disponibles sont les mêmes que ceux de la note CONTEXTE_TSC du paramètre TSC.

Remarques

• Ce paramétrage est optionnel : si aucun nom de champ n'est indiqué, la combinaison de touches paramétrée active l'ouverture contextuelle de l'écran quel que soit le champ.

• Pour une optimisation du fonctionnement, placer les touches valables pour tous les champs en premier.

• Si aucun paramétrage n'est indiqué, l'ouverture contextuelle des écrans fonctionne comme précédemment (un clic de la souris sur un champ activera toutes les ouvertures contextuelles des champs rencontrées jusqu'à celui-ci).

TPS_ATT_SECHAGE_BASC

21,26 Temps de séchage avant bascule

Voir le code calcul PG, caractère 1 = 1 ainsi que OIMF70

Voir aussi la note OPT_OPE_TPS_SECHAGE sur le paramètre TEN

TSC

Paramétrage des TSC contenant les valeurs par défaut des zones de l'entité liées aux machines

4 à 23 Nom de la zone :

fi_co_recto Nombre de couleurs recto

fi_enc_r Pourcentage d'encrage recto

fi_pr_recto Nombre de couleurs primaires recto

fi_ve_recto Pourcentage de vernis recto

fi_cgt_r Nombre de changements de version recto

fi_cgt_r_r Nombre de repiquages recto

fi_co_verso Nombre de couleurs verso

fi_enc_v Pourcentage d'encrage verso

fi_pr_verso Nombre de couleurs primaires verso

fi_ve_verso Pourcentage de vernis verso

fi_cgt_v Nombre de changements de version verso

fi_cgt_v_r Nombre de repiquages verso

24 à 26 Code TSC

27 Code de la zone

Exemple

TSCfi_co_recto         610C

Quand on utilise les références multiples sur le devis multi-métiers, le prix est calculé automatiquement au prorata de la surface des différent éléments.

Pour cela , les codes ECMA / Contour doivent disposer de SUR comme dimension calculée.


#CF DER Récapitulatif devis

Valeurs numériques

#CF DER N1 | Marge sur port
#CF DER N2 | Marge supplémentaire à appliquer

Valeur alpha 1

#CF DER A1[1,8] | Libellé ligne paramétrée 1 du récapitulatif. (type imprimerie)
#CF DER A1[9,16] | Libellé ligne paramétrée 2 du récapitulatif. (type imprimerie)
#CF DER A1[17,24] | Libellé dont
#CF DER A1[25,32] | Libellé et

Valeur alpha 2

#CF DER A2[1]

Doit-on enlever le port sur le montant commissionné ? (O/N)

#CF DER A2[2]

Mode de calcul de la commission

N Normal Devise 200F Com. 5% : Commission = 200 + 5% = 10F

O Devise = 200 Com. = 5% : Commission 200*(100/(100-5) -1) = 10.52 210.52-5%=200

#CF DER A2[3]

Mode de calcul de la marge supplémentaire (idem 2)

#CF DER A2[4]

Base pour marge sup. sur PR ou PV (N PR, O PV)

#CF DER A2[5]

Doit-on exclure le port dans la base marge supplémentaire

O On exclut le port

N On inclut le port

#CF DER A2[6]

Le port entre-t-il dans le calcul du 1000+

O Oui (le port est considéré comme variable)

N Non (le port est fixe)

#CF DER A2[7]

Détermination de la marge commerciale par le biais de dépendances

N Pas de détermination automatique

S Détermination automatique en fonction de plusieurs critères

C Détermination automatique en fonction de la surface et du client (devis dco uniquement)

1 Détermination automatique en fonction de la surface et de la catégorie client

2 Détermination automatique en fonction de la surface et du client

3 Détermination automatique en fonction de la quantité, de la catégorie client et du type de devis

IMPORTANT : Les valeurs S et C sont dépendantes du type de devis (TEN A1[41]) :

#CF DER A2[7] = S et TEN A1[41] = B équivaut à #CF DER A2[7] = 1

#CF DER A2[7] = S et TEN A1[41] = [autre] équivaut à #CF DER A2[7] = 3

#CF DER A2[7] = C et TEN A1[41] = B équivaut à #CF DER A2[7] = 2

#CF DER A2[7] = C et TEN A1[41] = [autre] équivaut à #CF DER A2[7] = 3

#CF DER A2[8]

Unité d'utilisation pour le calcul du transport dans le devis et dans la logistique (voir aussi UNI A1[9]

A à la surface au sol

B au volume de la palette

C au nombre de palettes

D au nombre total de palettes du devis

F Recherche du poids sur une phase formule
La phase est paramétrée en #CFDER A3[2,4]

G Recherche du poids sur une phase formule. Pas de proratisation
La phase est paramétrée en #CFDER A3[2,4]
Générique (obligatoire pour unité forfaitaire) [19/11/2013 note de DVA : à vérifier]

K au kilomètre

M au mètre linéaire plancher
La largeur camion est paramétrée en #CFDER A2[27,30] uniquement si optimisation de la palettisation.

N au mètre linéaire plancher (entité courante uniquement) - Largeur du camion en #CFDER A2[27,30]

P au poids (par défaut)

V au volume

X Pas de calcul du transport

La largeur de camion est utilisée par la fonction f_ml_plancher pour l'optimisation de chargement du camion.

Possibilité d'utiliser le métrage linéaire de plancher calculé à partir des éléments du conditionnement dans la quantité utilisé par le programme de tarification des transporteurs (tro.4ge).

La valeur calculée correspond au métrage linéaire de plancher exprimé en millimètres (option retenue pour ne pas perdre de décimales, la zone ft_poids étant un integer).

On utilise donc des tarifs de transport au métrage linéaire de plancher exprimé lui aussi en millimètres.

On paramètre l'unité de prix de transport UTR MLP (mètre linéaire de plancher) en indiquant 1000 dans la valeur numérique 1 (diviseur standard utilisé par le calcul du transport).

#CF DER A2[9]

Calcul du prix contrôle - voir A3[9,16]

K Prix au kilo (par défaut) (on prend le poids total brut)

V Valeur ajoutée au m2

S Prix au m2

N Prix au kilo (on prends le poids total net)

F A partir d'une formule paramétrée en alpha 3-

M % Formule paramétrée en alpha 3 / Prix remis

A Quantité/100 * le cent remis - coût matière - coût sous-traitance

B Marge constatée ((montant remis / PR total) - 1) * 100

C Valeur ajoutée : prix remis - PR matière - PR sous-traitance - PV port / prix remis * 100

(pourcentage)

D (Quantité/1000 * le mille remis)- coût matière- coût sous-traitance

E Marge constatée ((montant remis / PR total) - 1) * 1000

#CF DER A2[10]

Gestion du tableau de marge (O/N)

#CF DER A2[11]

Autorisation de modification du prix remis (O/N)

#CF DER A2[12]

Autorisation de modification du 1000+ calculé (O/N)

#CF DER A2[13]

Le % de commission du représentant est intégré au % de marge commerciale (O/N)

#CF DER A2[14,16]

Arrondi à réaliser sur le prix de vente lors du calcul du tableau de marge

0 Pas d'arrondi (par défaut)

1 Arrondi à l'euro le plus proche

–1 Arrondi à l'euro supérieur

10 Arrondi aux 10 euros les plus proches

–10 Arrondi aux 10 euros supérieurs

#CF DER A2[17]

Autorisation de modification du pourcentage entre prix remis et prix devisé (O/N)

#CF DER A2[18]

Réactualisation du prix remis

O Le prix remis n'est pas calculé. Il faut le saisir. Il ne sera pas modifié par un calcul du devis

M La marge globale n'est pas calculée. Il faut soit saisir la marge, soit le prix remis. La marge globale ne sera pas modifiée par un calcul du devis (à la fin du calcul, on réapplique la marge saisie auparavant au prix de revient ou au prix de vente standard).
Voir A2[53] et le calcul des marges à partir du prix de vente standard.

N Le prix remis est calculé (par défaut)

#CF DER A2[19]

Ne pas utiliser la marge port par défaut définie sur la valeur 1

O ou blanc Utiliser la marge par défaut

N Ne pas utiliser la marge par défaut

#CF DER A2[20]

Tenir compte des appairages pour calculer le prix remis

O Utilisation des appairages

N ou blanc Pas d'utilisation des appairages

#CF DER A2[21]

Accès aux notes lors de la recherche de devis (actif seulement sur le devis dco / tc pour l'instant)

1 Notes sur l'entête

3 Notes sur l'entité

F ou blanc Fenêtre d'interrogation

#CF DER A2[22]

Accès aux LCO lors de la recherche de devis (actif seulement sur le devis dco / tc pour l'instant)

C Accès en consultation uniquement

M ou blanc Accès en modification

#CF DER A2[23]

Accès au champ PR matière ligne paramétrée 1 (l2_m_1_pr) (O/N, N par défaut)

#CF DER A2[24]

(En mode gestion des options uniquement #CF DEG alpha4[10]).

Le port doit il être calculé depuis la marge supplémentaire ?

O La marge supplémentaire est d'abord calculée puis le port est obtenu par pourcentage de cette marge. (TSC POR.ic_num1 sur sous devis)

N Le port est calculé avant la marge supplémentaire puis y est intégré ou pas (par défaut)

#CF DER A2[25]

Autorisation de modification du 1000+ remis (O/N, O par défaut)

#CF DER A2[26]

Le 1000+ remis n'est calculé qu'une seule fois. Il faut le saisir.

Il ne sera pas modifié par un recalcul du devis

O Prix calculé 1 seule fois

N Prix toujours recalculé (défaut)

#CF DER A2[27,30]

Largeur du camion pour le calcul du métrage linéaire plancher (A2[8] = M ou N))

Valeur par défaut : 2.40

#CF DER A2[31]

Autorisation de modification du montant de commande O/N (O par défaut)

#CF DER A2[32]

Mode de calcul du transport

1 Par défaut

2 Prise en compte de l'unité référentielle dans la table tro

#CF DER A2[33]

Initialisation de l'origine pour le calcul du transport

1 Le site de l'entête du devis (par défaut)

2 Une LCO paramétrable (voir caractères suivants)

3 Initialisation avec le code site renseigné sur l'entité s'il est saisi, sinon avec le code site renseigné sur l'entête. Tableau de bord du multisite <VF>

4 Même chose que 3;
en outre, l'origine ne sera pas utilisée dans la recherche des tarifs transport.

#CF DER A2[34,36]

Type de LCO pour l'origine

Exemple : SIT

#CF DER A2[37]

Champ à prendre en compte dans la LCO (table fle_com)

1 champ fc_a1

2 champ fc_a2

3 Zone alphanumérique 3 (fc_a3)

4 Zone alphanumérique 4 (fc_a4)

#CF DER A2[38]

Accès au prix remis via le tableau des marges

O Permet l'accès au prix remis via le tableau des marges [Valeur par défaut]

N Interdit l'accès au prix remis via le tableau des marges

#CF DER A2[39]

Si les prix négociés du devis (prix à la quantité, frais de clichés, frais d'outillages, prix en multi-références) ne sont pas saisis, ceux-ci sont initialisés automatiquement par les prix remis (O/N, N par défaut)

O Initialisation du prix négocié si celui-ci n'est pas saisi

F Initialisation systématique du prix négocié

N Aucune initialisation (par défaut)

#CF DER A2[40]

Exclusion du port client (O/N, N par défaut)

Retire le port du détail des marges, pour le gérer en phase inclue au prix.

#CF DER A2[41]

Prise en compte des frais dans le récap (O/N, N par défaut)

Permet d'intégrer les frais dans le calcul du récap du devis.

Les valeurs impactées sont le montant de la marge commerciale, le montant de la commande et le prix au mille calculé.

#CF DER A2[42]

Pas d'accès à l'écran de récapitulatif (O/N, N par défaut)

#CF DER A2[43]

La marge sur le prix de vente des références multiples est reprise automatiquement à partir de celle saisie sur le sous-devis. (O/N, N par défaut)

#CF DER A2[44]

Mode de recherche du tarif transporteur

1 recherche en utilisant le code postal du point de livraison

2 recherche en ne tenant pas compte des codes postaux de la grille

3 recherche avec le code postal du point de livraison puis le code postal non renseigné
Mode à utiliser dans le cas de transporteur ayant des grilles pour les départements de leur région et une grille nationale.
Exemple : TNT Paris qui a une grille pour chaque département de la région parisienne(75, 77, 92, 93, 94, 95) et une grille nationale (saisie sans code postal)

#CF DER A2[45]

Recalcul du sous-devis courant avant l'ouverture de l'écran de récapitulatif des marges (F21)

T Recalcul systématique

C Recalcul sur demande de confirmation

N Pas de recalcul (par défaut)

#CF DER A2[46,49]

Hauteur du camion pour le calcul du métrage linéaire plancher

Valeur par défaut : 2.50

#CF DER A2[50]

Réinitialisation des prix remis/négociés et/ou des frais lors de la copie d'un devis

Permet de réinitialiser indépendamment les prix remis/négociés et les frais lors de la recopie d'un sous-devis

O Réinitialisation des prix remis/négociés et des frais

P Réinitialisation des prix remis/négociés uniquement

F Réinitialisation des frais uniquement

N Aucune réinitialisation (par défaut)

#CF DER A2[51]

Prendre en compte le type d'article (Fixe/Variable) lors de la génération de la sous-traitance du tableau des marges

O Si l'article est déclaré comme Fixe, les valeurs de la sous-traitance fixe ainsi que les valeurs variables sont cumulées dans la partie fixe du groupe de marge (dont partie fixe). La partie variable du groupe de marge n'est alors pas alimentée.
Si l'article est déclaré comme Variable (par défaut), les valeurs de la sous-traitance fixe vont dans la partie fixe et les valeurs variables dans la partie variable du groupe de marge (équivalent au fonctionnement par défaut)

N Pas de prise en compte du type d'article (par défaut)

#CF DER A2[52]

Prix de mille+ saisissable dans l'écran du détail des prix

C Saisie du mille+ calculé (par défaut)

R Saisie du mille+ remis

#CF DER A2[53]

Calcul des marges sur prix de vente remis/négocié à partir du prix de vente standard

O Le calcul des marges se fait à partir du prix de vente standard

N Le calcul des marges se fait à partir du prix de revient (par défaut)

Remarque : Ce fonctionnement est valable pour les écrans suivants :

• Récapitulatif du prix du sous-devis

• Récapitulatif des prix par référence

• Application des marges pour les frais de premier établissement (NDF)

#CF DER A2[54]

Gestion de la décomposition des prix (O/N, N par défaut) Plus d'info

#CF DER A2[55]

Vérification de la saisie des prix remis : Plus d'info

• Contrôle de la somme des prix remis des références par rapport au prix remis du devis

• Contrôle de la somme des prix décomposés par rapport au prix remis d'une référence

B La somme des prix remis de niveau inférieur doit être égale au prix remis de niveau supérieur (bloquant)

W La somme des prix remis de niveau inférieur doit être égale au prix remis de niveau supérieur (non bloquant)

C La somme des prix remis de niveau inférieur doit être égale au prix remis de niveau supérieur (demande de confirmation)

N Pas de contrôle des prix remis (par défaut)

#CF DER A2[56]

Contrôle du nombre de voyages pour une livraison client

B Contrôle bloquant (par défaut)
Le nombre de voyages doit être égal à 1.

W Contrôle non bloquant
Affichage d'un message d'avertissement si le nombre de voyages est différent de 1.

C Demande de confirmation
Demande de confirmation si le nombre de voyages est différent de 1.

O Pas de contrôle
Le nombre de voyages peut être différent de 1.

Valeur alpha 3

#CF DER A3[1,8]

Voir le détail ci-dessous

Lié au calcul du transport, alpha2[8]

Voir aussi

TPR note FOR_POIDS_TRANSPORT

UNI note FOR_POIDS_TRANSPORT

UNI A1[11,18]

#CF DER A3[1]

Méthode de recherche pour le calcul du poids du transport

T Recherche sur formule en utilisant le code calcul RT
(Recherche données matières pour la formule de transport paramétrable, par défaut)

M Recherche sur formule en utilisant le code calcul RM
(Recherche données matières pour la formule de transport paramétrable)

#CF DER A3[2,4]

Code phase, correspond aux caractères 1 à 3 du code calcul RM/RT)

#CF DER A3[5,7]

Code formule, correspond aux caractères 4 à 6 du code calcul RM/RT)

#CF DER A3[8]

Rubrique, correspond au caractère 7 du code calcul RM/RT)

#CF DER A3[9,16]

Lié au calcul du prix contrôle, A2[9]

Car 9 Recherche sur formule matière ou opération

Si M, utilisez l'aide RM sur fl_caldep

Si O, utilisez l'aide RV sur fl_caldep

Seul le type M est géré.

Car 10,12 Code phase

Car 13,15 Code formule

Car 16 Rubrique à rechercher

#CF DER A3[17]

Génération du transport uniquement sur la première entité (O/N, N par défaut)

#CF DER A3[18]

Autorisation de modification de l'adresse de livraison de l'écran de saisie des livraisons

O Le code adresse ainsi que l'adresse de livraison peuvent être modifiés manuellement.
Dans le cas d'un type de transport client (C), le code client peut également être modifié.

N Le code adresse peut être modifié.
L'adresse de livraison ne peut pas être modifiée manuellement.
Dans le cas d'un type de transport client (C), le code client ne peut pas être modifié.

Valeurs par défaut :

Pour le devis multi-métiers : N par défaut

Pour les autres devis : O par défaut

#CF DER A3[19]

Permettre de stocker dans les notes du paramètre GMA/999 la liste des formules non affectées à un groupe de marge spécifique (O/N, N par défaut)

#CF DER A3[20]

Activation du mode debug pour le calcul des gâches cumulatives (O/N, N par défaut)

Valeur alpha 4

#CF DER A4[1,4] | Coefficient pour les colonnes indicatives des coûts matière, fabrication, sous-traitance, frais, port et de la valeur ajoutée (devis TC uniquement)
#CF DER A4[6,14] | Libellé associé au coefficient (devis TC uniquement)

Notes

Si les libellés dont et et sont saisis, il est possible de paramétrer dans les notes comment seront calculées les zones dont et et de la façon suivante :

La zone dont correspond au type 1.

La zone et correspond au type 2.

Le paramétrage des deux types est lié à la formule de calcul.

Caractère 1 | Z
Caractère 2 | O pour une formule opération M pour une formule matière S pour une formule sous-traitance
Caractères 3 à 5 | Code phase
Caractères 6 à 8 | Code formule
Caractères 9 à 11 | Pourcentage à comptabiliser dans le type 1
Caractères 12 à 13 | Pourcentage à comptabiliser dans le type 2

Exemple

ZOMON1 050040

50 % du montant calculé par la formule : O MON 1 seront affectés au type 1

40 % du montant calculé par la formule : O MON 1 seront affectés au type 2

Vous pouvez saisir 20 lignes au maximum

CODE_NDR_TRANSPORT

Code nature de regroupement pour les frais de transport (correspond à un type de paramètre NDR). Par défaut : #RV - Plus d'info

Remarque : Il peut s'agir d'une nature de regroupement déjà utilisée dans une formule.

Dans ce cas, les frais de transport seront cumulés aux prix déjà existants pour cette nature de regroupement.

Important : Ce paramétrage concerne le fonctionnement standard.

COEFF_PRIX_AU_MOINS

Pourcentage pris en compte pour calculer le prix au moins à partir du prix au plus (2 décimales)

Le prix au moins est calculé lors du transfert de devis en commande.

FORMULE_RECH_MARGES

Formule de recherche des marges

21,23 Code phase de recherche des marges

24,26 Code formule de recherche des marges

27 Type de la formule de recherche des marges

M Matière

O Opération

S Sous-traitance

28 Reporter les marges sur les prix par références multiples (O/N, O par défaut)

Dans la saisie des devis multi-métiers :

• Initialiser les marges sur prix remis et/ou prix négocié avec les zones d'une opération (i_postes) récupérée grâce au calcul d'une formule paramétrable.

• Contrôler les marges sur prix remis et/ou négocié par rapport aux valeurs minimum/maximum récupérées sur cette même opération (via un code blocage).

Correspondance des valeurs saisissables sur l'opération (i_postes) :

Zone opération | Désignation de base | Désignation pour la gestion des marges des prix remis et/ou négocié
Marges sur le prix remis
ss_g_fix | Gâche fixe | Marge sur prix remis standard
ss_g_var | Gâche variable | Marge sur prix remis minimum
ss_g_cadence | Cadence | Marge sur prix remis maximum
Marges sur le prix négocié
ss_g_march | Marge sur coût horaire | Marge sur prix négocié standard
ss_g_txps | Taux horaire des personnes supplémentaires | Marge sur prix négocié minimum
ss_g_marps | Marge sur taux des personnes supplémentaires | Marge sur prix négocié maximum

Voir aussi :

Devis multi-métiers, note CODE_BLOCAGE_AUTO, nouveau champ d'action du code blocage PRIX_NEGOCIE.

BLD A1[3,5] = 006 (Nouveau code blocage de devis pour le contrôle des marges sur prix remis et prix négociés).

LIB_PC_COUV_FR_FIXE

21,60 Libellé de titre de la zone de visualisation du pourcentage de couverture des charges fixes

Pas de valeur par défaut : Ce paramétrage conditionne l'affichage de la zone.

Dans l'écran de saisie des marges (récapitulatif du devis), permet de visualiser le pourcentage de couverture des charges fixes.

Le pourcentage de couverture des charges fixes est calculé comme suit :

% Couv. FF = ((Montant de commande – Prix de revient) / Prix de revient des opérations) * 100

LIB_PRIX_VENTE

21,60 Libellé de la colonne de prix de vente standard (Par défaut : P.V. standard)

LIB_PRIX_REMIS

21,60 Libellé de la colonne de prix remis (Par défaut : Prix de vente remis)

LIB_PRIX_NEGOCIE

21,60 Libellé de la colonne de prix négocié (Par défaut : Prix négocié)

NOTE_RECAP_TAB_MAT

21 à 60 Ligne de titre pour le tableau récapitulatif (partie matières) de l'édition interne du devis

NOTE_RECAP_TAB_OPE

21 à 60 Ligne de titre pour le tableau récapitulatif (partie opérations) de l'édition interne du devis

NOTE_RECAP_TAB_STR

21 à 60 Ligne de titre pour le tableau récapitulatif (partie sous-traitance) de l'édition interne du devis

TITRE_LIGNE_FRAIS_1

21,25 Dans l'écran des variantes de quantité/qualité, titre pour la ligne 1 de frais (NDF)

TITRE_LIGNE_FRAIS_2

21,25 Dans l'écran des variantes de quantité/qualité, titre pour la ligne 2 de frais (NDF)

TITRE_LIGNE_FRAIS_3

21,25 Dans l'écran des variantes de quantité/qualité, titre pour la ligne 3 de frais (NDF)

TITRE_LIGNE_FRAIS_4

21,25 Dans l'écran des variantes de quantité/qualité, titre pour la ligne 4 de frais (NDF)

TITRE_LIGNE_FRAIS_5

21,25 Dans l'écran des variantes de quantité/qualité, titre pour la ligne 5 de frais (NDF)


#CF DEV Configuration du devis car

Paramètre spécifique utilisé par dco_c

Notes

FORMULE_ENTETE | 21 à 60 Formule de politesse à insérer dans l'entête de l'édition
FORMULE_PIED | 21 à 60 Formule de politesse à insérer dans le pied de page de l'édition (avant les signatures)
FORMULE_CONDITIONS | 21 à 60 Formule de politesse à insérer dans le pied de page de l'édition (après les signatures)

Remarque

Les lignes peuvent être concaténées entre elles par le symbole ///. Le point à insérer une ligne blanche.

Exemple

1ère ligne | Nous avons le plaisir de vous ///
2ème ligne | confirmer ci-après…

donnera à l'impression : nous avons le plaisir de vous confirmer ci-après…

Remarque valable pour les notes de type FORMULE_PIED uniquement

Le titre du correspondant peut être inséré dans la note avec le code %CORRES%. Ce code sera alors remplacé à l'impression par le titre du correspondant.


#CF DKP Devis onduleur

La chute de rive est un déchet technique sur la coupe de la plaque qui permet:

- de palier l’imprécision de la coupeuse transversale de l'onduleuse dans une plage dimensionnelle critique (petites longueurs de coupe)

- de réaliser une impression bord à bord malgré l’écrasement (conséquence plutôt de l'onduleuse) du carton sur le bord. Après un premier passage d'impression (souvent en ligne), on retire cette chute.

L'ordre de grandeur de la chute est de 10mm.

Ce déchet technique n'est pas considéré dans la surface nette puisqu'elle n'est pas livrée.

Elle est bien entendu dans la surface brute (plaque onduleuse).

La recherche des rognes (dans les deux sens) dépend, dans le cas le plus complexe, du type de découpe, de la machine et de la cannelure.

Si le type de découpe précise l'utilisation d'une rogne, alors ce sont les informations du type de découpe qui seront utilisées en tant que rogne, quelles que soit la machine et la cannelure.

La valeur zéro est significative, ce qui signifie que si un type de découpe précise une rogne à zéro, on aura une rogne à zéro.

Sinon :

Si le couple (machine/cannelure) précise une rogne, alors on utilise les informations de ce couple (machine/cannelure).

La valeur zéro est également significative.

Sinon on utilise les informations de rogne saisies sur la machine.

#CF DKP Devis onduleur

Notes triées - Le caractère souligné _ (underscore ) n'est pas pris en compte dans le tri.

Le mot clé est indiqué dans les caractères 1 à 20. Le paramétrage est indiqué à partir du caractère 21.

Tous les compléments de requêtes sont sur 100 caractères maximum. On peut donc utiliser plusieurs lignes.

Les autres mots clés ne doivent apparaître qu'une fois. Le programme ne contrôle pas le paramétrage.

Si les compléments de requête concernent uniquement la zone mp_code, la recherche est beaucoup plus rapide.

Exemple : and mp_code matches "P*"

Attention : les articles par défaut doivent impérativement satisfaire aux conditions du complément de requête.

2_PASSAGES_MITRAIL

2 passages obligatoires sur mitrailleuse en gestion de plaques sur stocks dans le devis onduleur (O/N, N par défaut)

ACCES_QUANTITE_LIVR

Accès à la zone Livraison par sur l'écran de l'offre de vente (Ecran 020) (O/N, N par défaut)

ACTIVER_PAPETERIE

Activation du mode papeterie pour la saisie des devis onduleurs (O/N, N par défaut)

Voir l'option Odp dans le devis onduleur.

ACTSERFAB

Code action de service de fabrication

Exemple : ACTSERFAB FAB

ACTSERFIN

Premier caractère commun à toutes les actions de service de type Marge

Exemple : ACTSERFIN %

ACTSERPRE

Code action de service pour le stockage du coût et de la quantité de pré-impression

Exemple : ACTSERPRE PRE

AFF_NOTES_CLI_DEVIS

Il est possible de faire apparaître automatiquement une fenêtre de consultation des notes clients à la validation d'un entête de devis.

21,59 Liste des types de notes clients à afficher à la validation de la saisie de l'entête du devis.

13 types de 3 caractères par ligne.

Cette note existe aussi dans le paramètre de lancement du devis onduleur, où elle est prioritaire.

Elle nécessite l'option Onc dans le devis onduleur.

ARRONDIQFA

Arrondi de la quantité de fabrication

Exemple : ARRONDIQFA 1

AS_TYPE_COMMISSION

21,23 Code action de service de type commission (Exemple : %CO)

BASE_CALCUL_PRIX

Permet d'indiquer quel prix (prix de revient ou prix calculé) est utilisé pour calculer les prix remis et négocié

21 Base de calcul des prix remis et négocié de l'écran de remise de prix

1 Prix de revient (Par défaut)

2 Prix de revient + Marge standard

CALCULCOUTCLICHE

Mode de calcul du coût de cliché :

1 (Par défaut) sinull(f_lec_z_info_c("A",p_mp_pf.mp_code,"202","ic_num2"))

* pourcentage_encrage / 100

* gl_cout_moyen_cliche_imp

2 Prise en compte de la couleur dans le coût du cliché.

Au coût calculé par le mode 1, on applique la formule * ((nb_couleurs + 1) / 2)

CALCUL_G_FIX_OND

21 Mode calcul de la gâche fixe onduleuse

0 La gâche fixe onduleuse est celle de l'opération (Valeur par défaut).

1 La gâche fixe onduleuse est celle de l'opération divisée par le nombre de poses triplet et par la coupe brute.

2 La gâche fixe onduleuse est celle de l'opération divisée par la coupe brute.

CARACTSERFABNFA

Code caractéristique de l'action de service ACTSERFAB pour le stockage du nombre de fabrications

Exemple : CARACTSERFABNFA NFA

CARACTSERFABQFA

Code caractéristique de l'action de service ACTSERFAB pour le stockage de la quantité de fabrication

Exemple : CARACTSERFABQFA QFA

CARACTSERFINECH

Code caractéristique de l'action de service ACTSERFIN pour le stockage du code échéance attaché au client.

Exemple : CARACTSERFINECH ECH

CARACTSERFINPR

Premier caractère commun à toutes les caractéristiques de stockage de la base de calcul d'une action de service de type Marge.

Exemple : CARACTSERFINPR %

CARACTSERPRECOU

Code caractéristique de l'action de service ACTSERPRE pour le stockage du coût de pré-impression

Exemple : CARACTSERPRECOU COU

CARACTSERPREQTE

Code caractéristique de l'action de service ACTSERPRE pour le stockage de la quantité pré-imprimée

Exemple : CARACTSERPREQTE QTE

CLIENTNOMENCLATURE

Code client pour accès aux nomenclatures

Valeur par défaut : #SOC

Exemple : CLIENTNOMENCLATURE #SOC

COEFF_GEOMETRIE

Liste des éléments déterminant le coefficient de géométrie

Rapport L/C (min, max)

Surface en M² (min, max)

Hauteur (min, max)

21,26 Code de la machine

27,30 Rapport L/C min (ex : 01.2)

31,34 Rapport L/C max (ex : 03.4)

35,39 Surface min (ex : 03.04)

40,44 Surface max (ex : 07.00)

45,48 : Hauteur min (ex : 0010)

49,52 : Hauteur max (ex : 0030)

53,56 : Coef de géométrie (ex : 5.00)

ATTENTION : Pour les valeurs numériques, il est nécessaire de renseigner tous les caractères de la zone indiquée.

De plus, la virgule symbolisée par le caractère '.'ne doit pas changer de place.

CONDIT_INFO_COMP

21,23 Type du paramètre utilisé pour définir l'information complémentaire.

La gestion du détail de conditionnement fonctionne si le type de paramètre ainsi défini existe dans la table des types de paramètre (par01).

Le libellé affiché est celui du type de paramètre défini.

COUTMINICLICHEIMP

Coût mini à prendre en compte pour les clichés d'impression

COUTMOYENCLICHEIMP

Coût moyen de M² de cliché sur machine de transformation

FICTIFACHETE

Attention : Note déplacée vers le paramètre de lancement de don le 22/10/2004

FORMULE_COEFNOM_DEF

Paramétrage d'une formule par défaut

21,23 Numéro de formule par défaut pour le calcul du coefficient de nomenclature (.PP A2[9,11])

25,30 Paramétrage de la formule par défaut pour le calcul du coefficient de nomenclature (.PP A2[12,17])

Pour gérer les protections palettes en stock, il est désormais obligatoire de paramétrer sur les protections palettes (.PP) une formule de calcul du coefficient de nomenclature sans laquelle le devis retourne un message d'erreur signalant une erreur de paramétrage de la dite formule.

Pour éviter les problèmes lors de l'utilisation de nouveaux codes et de reprise de l'existant, on ajoute à ce développement la possibilité de paramétrer une formule par défaut dans les lignes de note de configuration des devis.

GESTION_VAR_TECHN

21 Activation de la gestion des variantes techniques (O/N)

Voir le contexte dans la gestion des variantes techniques de la solution onduleur, en bas de ce chapitre.

HISTORISEETSUPPRIME

Permet de ne pas supprimer les offres non retenues lors de l'enregistrement de la réponse du client

21,23 NON Ne supprime pas les offres.

LISTE_OO_POUR_RIVES

21,60 Complément de sélection sur le paramètre .OO (option onduleuse) pour récupérer les options onduleuses concernées par cette chute de rives. Voir aussi la note PINCES_SYSTEMATIQUES.

Plus d'info ici

LISTE_TSC_COMPO_REC

21,59 Liste des TSC à recopier de la composition vers l'architecture (13 codes TSC paramétrables par ligne, sous la forme AAABBBCCC, …, MMM)

MAJ_ENS_AVEC_1ER_PF

21 Mise à jour des données de l'ensemble avec les données du 1er PF de la nomenclature (N/O, N par défaut)

MDT_ACTIVATION

Activation de la nouvelle modélisation des données techniques

Voir les notes propres à cette nouvelle fonction.

METLINMINI

21,30 Métrage linéaire minimum (facultatif)

31 Type de message à afficher si le métrage linéaire minimum n'est pas respecté

N Pas de contrôle

W Message d'avertissement (la gamme est considérée comme applicable)

C Demande de confirmation pour forçage de la gamme

B Message bloquant (la gamme est considérée comme non applicable)

32,34 Code du mot de passe pour forçage de la gamme

Facultatif si caractère 31 = C

MULTI_NIV_FORCE_MP20

21 Forcer le mode de calcul de la quantité du PF en multi-niveaux (O/N, O par défaut)

Le mode de calcul des quantité pour le PF (mp_param[20]) est systématiquement forcé à C (Gâche sur quantité lancée) dans le cadre du multi-niveaux. Il est possible maintenant de désactiver ce forçage.

NOMENCLATUREDEB

Permet, lors de la création d'un code article, de récupérer le code nomenclature douanière associée au couple famille/sous-famille saisi. Voir la note CREER_NOM_DOUANIERE dans le programme de saisie des matières.

21,23 Type de produit (code sous-famille de la composition)

24,26 Code famille du produit fini

27,29 Code sous-famille du produit fini

30,42 Code nomenclature douanière par défaut du produit fini

PCT_LIM_COUT_COMPO

Permet de limiter le coût de la compo à un pourcentage maxi de la perte

21,23 Pourcentage (entier) maxi de la perte

Par ex : 20 (pour 20%)

PINCES_SYSTEMATIQUES

Prendre en compte systématiquement la prise de pinces (O/N, N par défaut)

Voir aussi

note LISTE_OO_POUR_RIVES

.CD A1[5,14]

note ROGNE sur le paramètre PC

Plus d'info ici

POIDS_SURF_COMPO_0

Prendre en compte le poids du PF du niveau supérieur si la composition de ce PF a un grammage > 0 (O/N, N par défaut)

RACHATDECHETS

Code article pour la valorisation des rachats de déchets

REINIT_GENCOD

21, Réinitialisation du GENCOD lors de la recopie de produit (O/N, N par défaut)

REP_IMG_SCHEMA_PAL

21,60 Répertoire des images des schémas de palettisation

Utilisé pour l'optimisation du conditionnement dans le devis onduleur.

Voir .SP A4[1,30]

_SUP_ORDER_BY_DEV

Complément de tri pour la recherche de devis

Cette note est recherchée en priorité sur le paramètre de lancement du devis onduleur.

Les champs accessibles en complément sont :

kp_de_ndemcli Numéro de devis

kp_de_ldemcli Libellé interne du devis

kp_de_ccliliv Code client livré

kp_de_nrefembcli Référence client

kp_de_lrefembcli Libellé client

kp_de_qrefembdem Quantité

mp_qualite Code validité d'article

Exemple : mp_qualite, kp_de_ccliliv

SUPREQACC

21,60 Complément de sélection pour la recherche des accessoires (table mat)

Exemple : and mp_code matches "ACC*"

Ne pas confondre avec la note _SUP_REQ_ACCESSOIRE dans la devis onduleur, qui concerne la recherches des accessoires dont le poids et la surface doivent être intégrés dans les poids et surfaces de l'ensemble.

SUPREQCOIFFE

21,60 Complément de sélection pour la recherche des coiffes (table mat)

Exemple : and mp_code matches "COI*"

SUPREQCOMCAR

21,60 Complément de sélection pour la recherche des compositions carton (table mat)

Exemple : and mp_code matches "COM*"

SUPREQCON

21,60 Complément de sélection pour la recherche des consommables (table mat)

Exemple : and mp_code matches "CON*"

SUPREQCONSOM

21,60 Complément de sélection pour la recherche des consommables génériques (table mat)

SUPREQCOUIMP

21,60 Complément de sélection pour la recherche des couleurs imprimées (table mat)

Exemple : and mp_code matches "COU*"

SUPREQNOTESCLIENT

21,60 Complément de sélection pour la recherche de notes sur le client (table cli3)

Si des notes existent, le mot NOTE est affiché en entête des écrans du devis

Exemple : and cc_type in ("OF", "GAM")

SUPREQPAL

21,60 Complément de sélection pour la recherche des palettes (table mat)

Exemple : and mp_code matches "PAL*"

SUPREQPAPPRE

21,60 Complément de sélection pour la recherche des référence papier de pré-impression (table mat)

Génération uniquement

Exemple : and mp_code matches "PAP*"

SUPREQPF

21,60 Complément de sélection pour la recherche du produit fini (table mat)

Cette note n'est pas prise en compte si la note _SUP_REQ_PF_ENS est positionnée dans le devis onduleur.

Exemple : and mp_code matches "PF*"

SUPREQQUACAR

21,60 Complément de sélection pour la recherche de qualité carton (table mat)

Exemple : and mp_code matches "CAR*"

SUPREQRAJOUTAS

21,60 Complément de sélection pour l'ajout d'une action de service dans l'option utilitaires (tables kp_demcli et kp_offre)

Exemple : and kp_of_noffven = 99

SUPREQREFARC

21,60 Complément de sélection pour la recherche de référence d'architecture (table mat)

Exemple : and mp_code matches "AARC*"

SUPREQREFIMP

21,60 Complément de sélection pour la recherche de référence d'impression (table mat)

Exemple : and mp_code matches "I*"

SUPREQREFKP

21,60 Complément de sélection pour la recherche de référence ENSEMBLE (table mat)

Exemple : and mp_code matches "REFEN*"

SUPREQREFPRE

21,60 Complément de sélection pour la recherche de référence de pré-impression (table mat)

Exemple : and mp_code matches "R*"

SUPREQRETRAITAS

21,60 Complément de sélection pour le retrait d'une action de service dans l'option utilitaires (tables kp_demcli et kp_offre)

Exemple : and kp_of_noffven = 99

SUPREQSCHEMAPAL

21,60 Complément de sélection sur par02 concernant le schéma de palettisation

Utilisé pour l'optimisation du conditionnement dans le devis onduleur.

SUPREQSUREMB

21,60 Complément de requête concernant le sur-emballage (table mat)

Exemple : and mp_code matches "ZDASUREMB*"

SUPREQTSCENCRE

21,60 Complément de sélection pour la recherche des encres dans les TSC du triplet (table info_c)

La présence de ce supplément de requête déclenche le contrôle de cohérence entre les encres saisies sur l'écran "ENCRE" 047 et celles saisies sur le triplet.

SUPREQVERNIS

21,60 Complément de sélection pour la recherche de vernis (table mat)

Exemple : and mp_code matches "ZBAV*"

Si le complément de requête des vernis est renseigné, alors la nouvelle zone type de vernis sur l'écran d'impression (don_045) est obligatoire.

SURFACE_ET_NB_POSES

Cette note était auparavant dans le paramètre de lancement de don.

Limiter le nombre de poses onduleuse pour une surface donnée

21, 30 Surface de référence

31, 32 Nombre de poses associé

SURFACEVALORISATION

21,30 Surface minimum de valorisation à prendre en compte pour le calcul du coût des plaques

Pas de limitation du coût des plaques si ce paramétrage n'est pas renseigné ou renseigné avec une surface à 0.

TAR0_INITIALISATION

Permet d'initialiser :

  • le code tarif

  • le code de la catégorie du tarif

  • le code de la zone char du tarif

  • la date de fin du tarif

  • le type de bornes

  • le type de la borne supérieure de la dernière tranche

  • le delta à ajouter à la borne inférieure pour obtenir la borne supérieure

21,23 Code du tarif. Facultatif. Exemple : V

24,26 Code de la catégorie du tarif. Facultatif

Exemple : ADL Adresse de livraison du devis

27,29 Code de la zone char du tarif. Facultatif

Exemple : EMT Code environnement matière du sous-devis

30 Date de fin du tarif

1 Date de fin de validité de l'offre (Par défaut)

2 31/12/2100

31 Type de bornes

1 Pas de tranche de quantités

Bornes inférieure et supérieure initialisées avec la quantité de l'offre (par défaut)

2 Tranche de quantités

Borne inférieure initialisée avec la quantité de l'offre

Borne supérieure initialisée avec la quantité de l'offre de la quantité supérieure – 1

32 Type de la borne supérieure de la dernière tranche

1 Borne supérieure initialisée à 999999999.999 (Par défaut)

2 Delta à ajouter à la borne inférieure pour obtenir la borne supérieure (Utilisé si 31 = 2)

33,45 Delta à ajouter à la borne inférieure pour obtenir la borne supérieure

Delta à cadrer à gauche avec 9 entiers et 3 décimales maximum

Utilisé si 31 = 2 et 32 = 2

EX : 100 ou 100.50 ou 3000 ou 3000.000

TOLERANCEARRONDI

Valeur de la tolérance de l'arrondi effectué sur les quantités roulées.

En dessous de la tolérance, on affiche la partie entière de la quantité roulée.

Au dessus de la tolérance, la partie entière plus 1.

Concerne uniquement les affichages de l'écran 050 et l'édition.

Exemple : tolérance = 0.001

Quantité = 3.02012452 à 4

Quantité = 3.00000256 à 3

TOLERANCEQFA

Tolérance de la quantité de fabrication

Exemple : TOLERANCEQFA 1000

TYPEADRESSE

Paramétrage du type d'adresse autorisée en saisie du devis

L Livraison

D Devis

TYPEREPRISEARTICLE

21 Type de reprise d'article

1 Reprise simple

2 Reprise complète

UNITE_PRE_IMP

21,60 Unité pour affichage sur l'écran de pré-impression

Exemple

UNITE_PRE_IMP M2

Gestion des variantes techniques dans le devis onduleur

1. Dans le devis, on peut pour chaque produit, saisir une variante technique.

On peut la renseigner dans l'écran du complément PF (F22 sur les lignes).

Lors de cette saisie, une fenêtre s'ouvre automatiquement pour lister les produits ayant la même variante technique que l'on vient de saisir.

On peut alors choisir quel sera le produit par défaut par site. Tableau de bord du multisite

L'info est enregistrée dans le TSC _VT du code produit.

Cette fonctionnalité est activée par la note GESTION_VAR_TECHN.

La touche F8 donne accès à la liste des PF qui ont la même variante technique.

2. Dans la génération des OF, on peut forcer la variante en en choisissant une dans la liste du tableau ci-dessus.

On récupère alors automatiquement la gamme associée.

On alimente alors le TSC _VP sur la ligne de FBI.

3. On peut modifier la variante de production d'une ligne de FBI par le programme de visualisation de commande.

On sélectionne les FBI substituables par complément de sélection et on active la colonne de sélection multiple (note commençant par _CSEL).

Paramétrer l'action 003 sur la note LCT_MULTI_PARAM qui permettra de changer la variante de production pour toutes les lignes sélectionnées et de mettre à jour le flag f0_gener = 2 correspondant.


#CF DMG Devis mécanique

Valeur alpha 1

Caractère 1 | Poids de la fiche article O Poids au cent N Poids à l'unité
Caractère 2 | On réactualise le devis à la recopie A Réactualisation automatique M On demande confirmation avant d'effectuer la réactualisation
Caractère 3 | Interdiction de la renumérotation des phases O On interdit la renumérotation N On autorise la renumérotation
Caractère 4 | Mise à zéro de zone en génération O La génération remet à zéro les zones techniques.
Caractères 5 à 7 | Code tarif pour les formules sur les opérations. Par défaut ce code tarif correspond au code saisi sur le premier écran du devis.
Caractère 8 | Type de recherche des articles 1 Recherche classique 2 Recherche avec données techniques
Caractère 9 | Recopie des notes O Les notes sont recopiées lors de la recopie d'un devis ou de la génération d'un nouveau devis N Les notes ne sont recopiées ni en copie ni en génération C Les notes sont recopiées en copie de devis uniquement G Les notes sont recopiées en génération de devis uniquement. Le renouvellement est une recopie
Caractère 10 | Réinitialisation des zones calculées lors de la réactualisation du devis O Oui N ou [espace] Non
Caractère 11 | Ouverture ou non des fenêtres de calcul durant la réactualisation du devis N Non O ou [espace] Oui
Caractère 12 | Sélection ou non des sous-devis de fabrication dans l'interrogation des devis N Exclusion des sous-devis de fabrication O ou [espace] Sélection des sous-devis de fabrication
Caractère 20 | Calcul du devis en heure minute O Oui N Calcul en heure centième
Caractère 21 | Recherche de devis par données techniques O Oui N Non (recherche standard)
Caractère 22 | Contrôle de saisie d'un fournisseur N Pas de contrôle W Message d'avertissement B Interdiction de saisir un devis pour un fournisseur
Caractère 23 | Temps minimum sur une opération (O/N) Paramétrage du temps minimum dans les notes sur #CF DMG Caractères 1 à 5 TMINI Caractères 6 à 16 ######.#### (temps minimum en heures centièmes)
Caractère 24 | On ne prend pas en compte les articles de type port au niveau du récapitulatif général N ou [espace] On prend en compte ces articles O On ne prend pas en compte ces articles
Caractère 25 | Réactualisation du devis après la validation du 2ème écran (identique au F11) (Non par défaut) N ou [espace] Pas de réactualisation O On demande la réactualisation
Caractère 26 | Lors de la réactualisation du devis (F11), calcul ou non du poids (Oui par défaut) O ou [espace Calcul du poids N Pas de calcul du poids


#CF DMR Calcul de récapitulatif du devis mécanique

Valeur alpha 2

Caractère 1 | Le port n'est pas inclus dans le montant commissionné (O/N)
Caractère 6 | Le port est-il variable ou fixe pour le calcul du 1000 + O Variable N Fixe


#CF DP2 Interface Direct Planning

Ce document est entièrement consacré à l'interface Direct Planning.

La gestion des marqueurs étant particulièrement importance, elle fait l'objet d'un chapitre à part entière (CHAPITRE 2).

Le CHAPITRE 1, lui, est consacré à tout le reste de l'interface.

CHAPITRE 1 - INTERFACE DIRECT PLANNING

1. Activer la nouvelle interface

2. Saisir les correspondances Machine

3. Activer la création des demandes de transfert DirectP lanning pour un programme donné.

3.1 Activer la création des demandes de transfert

3.2 Sur quels programmes ?

4. L'interface Direct Planning

5. Paramétrage de l'interface Direct Planning : #CF DP2

5.1 Généralités sur le paramétrage de #CF DP2

5.2 Emplacement des fichiers CSV de transfert

5.3 Configuration générale

5.4 Configuration du regroupement des entités

5.5 Configuration du regroupement des opérations

5.6 Configuration des liens entre les tâches et durée des liens

5.7 Configuration de la quantité et gâche prévue d'une tâche et calcul de l'état d'avancement

5.8 Configuration de zones standards

5.9 Configuration des entités Direct Planning

5.10 Configuration des tâches

5.11 Configuration des marqueurs

5.12 Configuration de l'import des éléments techniques

5.13 Codes champs

5.14 Configuration des codes champs variables liés au devis : CCV_DEV_GRP

5.15 Configuration des codes champs variables standards : CCV_STD

CHAPITRE 2 - LA GESTION DES MARQUEURS

Objectif

Génération des demandes

Configuration de l'interface pour la gestion des marqueurs (dans #CF DP2)

Principe

Configuration des recherches à réaliser

Principe de configuration des recherches

La recherche dans les achats

La recherche dans les actions / événements

Configuration des marqueurs

Exemple complet sur une recherche dans les achats

Modifications sur G_directplanning.42r

Modification de la base de données

Modification dans les traitements

Visualiser les marqueurs dans l'historique

Modification dans Direct Planning

Exemple de paramétrage

CHAPITRE 1 - INTERFACE DIRECT PLANNING

1. Activer la nouvelle interface

#CF ATL A1[39]

Valeur : 2 pour activer la nouvelle interface de Direct Planning

1 ou [blanc] : ancienne interface obsolète, ne pas utiliser

2. Saisir les correspondances Machine

Créer le paramètre TCL DPL

Alpha 1 = 0402N

Créer le paramètre #SA CMA

Libellé : Correspondances Machine

Alpha 1 = G_correspondance.4ge

Alpha 2 = DPL (ou tout autre code de type TCL créé ci-dessus)

Mettre #SA CMA au menu, par exemple dans les fichiers de base, au même niveau que la saisie des machines.

Ce programme permet de définir quelles machines seront ou non transférées dans DirectPlanning.

Il permet aussi de gérer une correspondance entre les codes machine Volume et les codes machine Direct Planning :

Règle 1 : Si une machine VS n'est associée à aucune machine DP, on enverra vers DP le code machine de VS.
Par défaut, on suppose donc que VS et DP ont les mêmes codifications.

Règle 2 : Si une machine VS est associée à un code # ou commençant par #, alors la machine VS est exclue du transfert vers DP.

3. Activer la création des demandes de transfert DirectPlanning pour un programme donné

3.1 Activer la création des demandes de transfert

Certains programmes Volume ont la capacité de générer des demandes de transfert vers DirectPlanning concernant un OF.

Les notes qui suivent sont sur le paramètre de lancement des programmes concernés (la liste est donnée plus bas).

Ces notes permettent d'activer une demande de transfert vers DirectPlanning.

Ces demandes générées par ces transfert seront insérées dans la table dpl_trf_demande.

DIRECT_PLANNING_TRF

21 Activer le transfert vers Direct Planning (O/N, N par défaut)

DIRECT_PLANNING_CFG

21,xx Plusieurs possibilités :

21,23 Code du paramètre de configuration de Direct Planning (par défaut : DP2)

Par défaut, les règles décrivant le transfert DirectPlanning sont recherchées sur le paramètre #CF DP2.

Vous pouvez ici spécifier un autre environnement (par exemple : DP3. Ce transfert sera alors piloté par #CF DP3)

MULTISITE

Ce mot-clé indique que le paramètre de configuration de l'interface se trouve sur le site de production associé à la demande en cours : il peut s'agir dune commande (OF) ou d'un sous-devis (réservation de capacité).

La gestion multisite doit être activée (#CF SIT A1[1] = O)

MULTISITE_ENTITE

Uniquement pour les devis Imprimerie et Multi-métiers.

Ce mot-clé indique qu'on utilise des plannings différents selon les sites de production des entités.

Ce qui veut dire que chaque site de production des entités de la demande en cours peut avoir son propre paramètre de configuration : il peut s'agir des entités associées à la commande (OF) ou des entités d'un sous-devis (réservation de capacité).

Si ce paramétrage est mis en place, une demande est générée pour chaque paramètre de configuration différent associé aux sites de production des entités. Lors du transfert vers DirectPlanning, les entités dont le site est associé à une autre configuration que celle en cours seront exclues.

Remarques concernant la génération des demandes :

- Si aucun site de production n'est renseigné au niveau des entités, une seule demande est générée pour le paramètre de configuration par défaut (voir ci-dessus)

- Si au moins une entité possède un site de production associé à une configuration spécifique ET si une autre entité ne possède pas de site de production ou de configuration spécifique associé, aucune demande n'est générée pour cette dernière.

Remarques concernant la création des taches d'entités à transférer à DirectPlanning :

- Si le site de production n'est pas renseigné sur l'entité en cours de traitement, l'entité n'est pas exclue.

- Si le site de production est renseigné sur l'entité en cours de traitement mais que celui-ci n'est pas associé à une configuration spécifique, l'entité n'est pas exclue.

- Si le site de production est renseigné sur l'entité en cours de traitement et que celui-ci est associé à une configuration différente de celle en cours (voir ci-dessous), l'entité est exclue.

La gestion multisite doit être activée (#CF SIT A1[1] O)

Tableau de bord du multisite

Aucune option de type -O n'est nécessaire.

Toutes les options -O concernant DirectPlanning concernent l'ancienne interface et sont donc obsolètes.

3.2 Sur quels programmes ?

Génération de dossiers

On positionnera les demandes de transfert sur les fiches paramètres de génération et de régénération.

Les demandes générées informeront DirectPlanning sur les nouveaux dossiers à intégrer (génération) ou les dossiers ayant évolué (régénération).

l_gdf

Génération de dossiers pour les industries graphiques

gdf

Génération de dossiers nomenclature et gammes

Clôture de dossiers

Les demandes générées feront évoluer l'état d'avancement des tâches des OF clôturés. Toutes les tâches seront déclarées terminées (état d'avancement 100%).

dos_fab

Clôture de dossier

clot_fbi

Clôture des FBI

qclod

Clôture rapide

Saisie atelier

Les demandes générées feront évoluer l'état d'avancement des tâches sur lesquelles des temps et quantités sont remontés.

La saisie des temps via sbs saura remonter uniquement les phases terminées en temps réel (sans attendre int_rtm).

Une tâche DirectPlanning est constituée de regroupement de différentes phases du dossier (fab1). Si la dernière de ces phases regroupées est clôturée (fab1.f1_term= O), alors la tâche DirectPlanning sera déclarée terminée (état d'avancement 100%).

L'intégration des temps saura remonter un état d'avancement tenant compte des quantités produites déclarées. Ainsi, sur une quantité prévue de 10000, si 5000 ont été déclarés produits, l'état d'avancement de la tâche passera à 50%.

sjs

Saisie des temps journalière par salarié

sbs

Saisie des temps par code à barres

Option Om1 nécessaire

int_rtm

Intégration des temps saisis par code à barres (sbs)

Déclaration de production

Lorsqu'on déclare la production soldée via qte_prod, on déclare de manière induite que toutes les tâches de cette commande sont également terminées (état d'avancement 100%).

qte_prod

Déclaration d'entrée en stock des produits finis

Visualisation des dossiers

Depuis ce programme, il est possible de clôturer une phase.

v_fab1

Visu des dossiers

Achats et marqueurs

Les programmes suivants génèrent des demandes d'actualisation en vue de mettre à jour les marqueurs liés aux achats.

cdef

Saisie de commande d'achat

brc

Bon de réception

gen_cdef

Génération des commandes d'achat

4. L'interface DirectPlanning

Créer le paramètre #SA DPL

Libellé : Interface DirectPlanning

Alpha 1 = G_directplanning.4ge

Alpha 2 = DP2 (pointe vers #CF DP2 pour la création d'un fichier d'export pour Direct Planning)

Note DIRECT_PLANNING_TRF O

Note DIRECT_PLANNING_CFG DP2 (pointe vers #CF DP2 pour la demande de transfert vers DirectPlanning)

Mettre #SA DPL au menu.

G_directplanning ne traite qu'un environnement à la fois.

Donc si on configure plusieurs environnements, il faudra plusieurs paramètres de lancement pour G_directplanning.

Il existe un mode batch (-B) qui permet l'intégration directe de toutes les demandes en attente.

La note DIRECT_PLANNING_TRF O est nécessaire pour autoriser les actions F11, F12 et F13 (créations de demandes de re-créations, actualisation et suppression) depuis l'interface DirectPlanning.

Une seule instance de G_directplanning est possible à un instant T.

5. Paramétrage de l'interface DirectPlanning : #CF DP2

5.1 Généralités sur le paramétrage de #CF DP2

Le paramètre de configuration #CF DP2 (par défaut) décrit l'interface vers DirectPlanning.

Le paramétrage est réalisé exclusivement dans les notes.

Les clés de paramétrage sont indiquées dans les colonnes 1 à 20, les valeurs de paramétrage dans les colonnes 21 à 60.

Tous les paramètres commençant par :

CFG_ sont des paramètres de configuration contenant toujours des valeurs du type 01, 02, etc.

V_ sont des valeurs.

5.2 Emplacement des fichiers CSV de transfert

Serveur Volume sous Windows

CFG_TRANSFERT_FIC | 21,22 Configuration du mode de transfert des fichiers vers Direct Planning. 01 : Fichiers CSV directement créés au bon endroit. Aucun transfert nécessaire.
V_FIC_SRC_DIR | 21,60 Répertoire Windows où sont créés les fichiers CSV. Si mon planning.dpl est situé sous E:\DirectPlanning\, alors le répertoire de dépose des fichiers CSV est nommé E:\DirectPlanning\planning.import\. C'est ce répertoire que l'on paramètre ici. Si le répertoire est trop long, il peut être défini sur plusieurs notes V_FIC_SRC_DIR

Pas de transfert FTP requis avec un serveur Volume sous Windows; on positionne les fichiers CSV directement au bon endroit.

Serveur Volume sous Unix

CFG_TRANSFERT_FIC | 21,22 Configuration du mode de transfert des fichiers vers Direct Planning. 02 : Fichiers CSV créés dans un répertoire (par exemple sous Unix) et devant être transféré automatiquement sous Windows via FTP
V_FIC_SRC_HOST | 21,xx Hôte Unix (ou adresse IP) ou sont créés les fichiers CSV (serait utilisé pour un transfert FTP)
V_FIC_SRC_DIR | 21,xx Répertoire Unix où sont créés les fichiers CSV
V_FIC_DES_HOST | 21,xx Hôte de destination (Windows)
V_FIC_DES_DIR | 21,xx Répertoire de destination où déposer les fichiers CSV

Note : les transferts FTP ne sont pour le moment pas automatisés.

Exemple : contenu de ftp_directplanning.txt

test

test

cd /u/atlas/directplanning/

lcd "E :\DirectPlanning\monplanning.import\"

mget import*.csv

mdelete import*.csv

quit

Il est important de se mettre dans les bons répertoires (serveur et pc) pour pouvoir lancer le mget.

On peut se permettre de tout supprimer puisque les fichiers sont sauvegardés dans le répertoire histo.

Contenu de transfert_direcplanning.bat :

C:\WINDOWS\system32\ftp.EXE -i -s:ftp_directplanning.txt xxx.xxx.xxx.xxx

Le -i permet la confirmation systématique pour chaque fichier à transférer.

xxx.xxx.xxx.xxx est l'adresse IP du serveur UNIX Volume.

Fichiers CSV générés

On ne paramètre pas le nom des fichiers CSV générés, ils sont de la forme : import_YYYYMMDD_HHMMSS.csv.

Ils sont créés dans le répertoire source paramétré via V_FIC_SRC_DIR.

Exemple : import_20080226_113556.csv

Répertoire d'historisation Volume

Il existe un répertoire de sauvegarde contenant une copie des fichiers CSV créés par G_directplanning.

En effet, ceux-ci seront renommés par DP à l'issue de l'import (voire effacés).

Ce répertoire s'appelle histo_volume et est créé automatiquement par le programme.

Il est situé sous le répertoire source V_FIC_SRC_DIR.

Journaux de log

Dans ce répertoire d'historisation V_FIC_SRC_DIR/histo_volume, on crée systématiquement un fichier de log portant le même nom que le fichier CSV mais doté d'une extension log.

Exemple : import_20080226_113556.log

Ce fichier contient en entête et un pied horodaté.

Il contient aussi les erreurs de configuration ou de traitement rencontrées.

Fichiers locks

On ne paramètre pas les noms des fichiers locks external_write.lck et directplanning_read.lck.

Ils seront gérés directement par G_directplanning dans le cas d'un CFG_TRANSFERT_FIC = 1.

La gestion par FTP dans le cas d'un CFG_TRANSFERT_FIC = 2 n'est pas réalisée à ce jour.

5.3 Configuration générale

CFG_TYPE_ENV

21,22 Configuration du type d'environnement

01 Environnement Imprimerie et multi-métiers

La gamme est issue de fab1 généré par l_gdf et initialement issue de fle_gam.

02 Environnement Onduleur

La gamme est issue de fab1 généré par gdf_don (ou gdf_ondu) et initialement issue de g_std_d.

03 Environnement Nomenclature et Gammes ou Mécanique

La gamme est issue de fab1 généré par gdf et initialement issue de gam0.

10 Environnement Gamme standard sans génération.

La gamme est issue de g_std_d. Le client n'utilise aucun module de génération de dossier.

11 Environnement Imprimerie et multi-métiers contenant uniquement des réservations de capacité

La gamme est issue directement du devis sélectionné (fle_gam).

CFG_DPL_VERSION

21,22 Configuration de la version de Direct Planning utilisée

01 Export au format Direct Planning 1.2.12. Par défaut.

02 Export au format Direct Planning 1.2.13 qui introduit la notion de création/modification des entités.

20 Export au format de la version 2.0

CFG_MIGRATION

21,nn Code d'environnement de migration vers Direct Planning 2.

A utiliser dans le cas d'une installation d'un Direct Planning 2 sur un serveur, alors que le client utilise déjà Direct Planning 1.

Il est possible de configurer ici le code #CF d'un paramétrage destiné à Direct Planning 2.

Ainsi toute demande formulée pour cet environnement (#CF DP2 par exemple) sera dupliquée automatiquement dans l'environnement de migration (#CF D22 par exemple).

Ainsi le client pourra travailler en parallèle sur les deux plannings.

Lorsque le nouveau planning sera validé, il faudra modifier les paramètres de lancements pour générer les futures demandes dans #CF D22 et non plus dans #CF DP2.

CFG_COMPARAISON

21,22 Configuration de la méthode de comparaison des changements intervenus dans une gamme lors de la demande de régénération d'OF, de la transformation de réservation de capacité en OF ou d'une demande d'état d'avancement d'un OF

01 Comparaison des changements par gammes. Par défaut.

02 Comparaison des changements tâche par tâche dans une gamme.

DEF_MP_TSC1

DEF_MP_TSC2

DEF_MP_TSC3

DEF_MP_TSC4

DEF_MP_TSC5

DEF_MP_TSC6

DEF_MP_TSC7

DEF_MP_TSC8

DEF_MP_TSC9

Configuration de lecture de fiche article dont le code est défini dans un TSC (zone char30).

Permet par exemple de lire les champs d'une fiche cliché.

Le code du cliché est indiqué dans un TSC de l'article de fabrication.

Permet d'utiliser par exemple, la zone : Z_mp_tsc_α_fam

21,22 Article

AF article de ligne de l'article fabriqué

AC article de ligne de commande

AR article de ligne de commande de rattachement

23 tiret (-) (signe moins)

24,26 code TSC

Configuration dédiée devis imprimerie et multi-métier

CFG_EXCLU_SITE_ENT

21,22 Mode d'exclusion des entités selon leur site de production

01 Les sites de production des entités ne sont pas pris en compte. Aucune exclusion d'entité. Par défaut

02 Les sites de production des entités sont pris en compte.
Les entités dont le site de production est associé à une configuration différente de celle en cours sont exclues.

Ce paramétrage est à déclarer si on utilise des plannings différents selon les sites de production des entités.

Il doit impérativement être associé à une note sur le paramètre de lancement des programmes générant les demandes :

DIRECT_PLANNING_CFG MULTISITE_ENTITE

Voir le Tableau de bord du multisite

V_DEV_MULT_PHA

21,nn Coefficient multiplicateur des numéros de phases dans la génération de dossier

Par défaut : 100

Valeurs possibles : uniquement 100 ou 10.

L'option Ox sur l_gdf permet en effet de multiplier le numéro de phase par 10 plutôt que par 100.

CFG_DEV_SDEVIS_99

21,22 Sous-devis

01 On lit toujours le sous-devis sur la ligne de commande. Par défaut.

02 On force toujours la lecture du sous devis 99, même si la ligne de commande précise un rattachement à un numéro de sous-devis autre (1,2,3, etc).

LEC_OPE0_SANS_SERIAL

21 Action corrective (O/N, N par défaut)

O Si la lecture de la table ope0 par le numéro d'opération de la table fab1 (serial) n'a pas ramené d'enregistrement, on tente une lecture avec la section, opération et sous-opération.
Ceci est fait pour palier le fait que les serials ont été reconstruits dans la table ope0 , d'où la perte du lien avec la table fab1.

Réservation de capacité

La réservation de capacité est un mode spécial.

Depuis le devis, on génère une réservation de capacité dans le planning en simulant une génération de dossier pour ce devis.

CFG_DEV_RESERVE_CFG | Code paramètre de configuration des réservations de capacité lié à la configuration actuelle (correspond à un type paramètre #CF).
CFG_DEV_SUP_SQL_RES | Complément de sélection pour la recherche des devis lors d'une demande de réservation de capacité Attention, si le numéro de devis est saisi manuellement, il doit répondre au critère paramétré.

Pour mettre en place ce mode il faut 2fiches de paramétrage associé à 2paramètres de lancement de Direct Planning :

#CF DPR

CFG_TYPE_ENV = 11

Génère les tâches associées aux réservations de capacités issues des devis.

Dans l'historique, on ne verra que les tâches générées depuis ces réservations.

#CF DP2

CFG_TYPE_ENV = 01

Génère les tâches associées aux véritables dossiers.

Dans l'historique, on verra les tâches générées mais également les réservations de capacités issues de la configuration #CF DPR.

Pour cela, il faut créer ici la note CFG_DEV_RESERVE_CFG DPR

Configuration de génération de la gamme du devis (réservations)

Les paramètres ci-dessous sont utilisés lors de la demande d'une réservation de capacité (Type d'environnement CFG_TYPE_ENV = 11).

Il s'agit d'une reprise de certaines options disponibles dans le programme de génération des ordres de fabrication (l_gdf).

CFG_GDF_PRORAT_QTES | Permet de ne pas proratiser la quantité nécessaire chez les clients dont les unités devisées et vendues sont différentes. Correspond à l'option Of sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_CONF_PRORAT | Active la demande de confirmation pour la proratisation lors de la génération de la gamme Correspond à l'option O3 sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_REG_PAR_FOR | Activation du regroupement des opérations pour l'alimentation des gammes Correspond à l'option OP sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_QTE_ENT_STO | Génère automatiquement l'opération QTE ENT STO Correspond à l'option Oq sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_LIGNE_ZERO | Génère les lignes valorisées à zéro (opérations) Correspond à l'option O0 sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_PHASE_MS_1 | Génère le numéro de phase d'opération en enlevant une unité (numéro de phase - 1) Correspond à l'option O8 sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_HYBRIDE | Génération hybride (mélange devis PRO / devis de calcul de prix) Correspond à l'option Oh sur la génération des ordres de fabrication (l_gdf).
CFG_GDF_SOLD_REM_TPS | Solde phase en remontée automatique des temps Correspond à l'option OS sur la génération des ordres de fabrication (l_gdf).

5.4 Configuration du regroupement des entités

Il est possible de regrouper en une gamme unique toutes les opérations d'entités appartenant à un même type d'entité.

CFG_REG_ENTDEV

21,22 Méthode de regroupement des entités du devis (entités au sens devis multi-métiers)

Ce paramètre ne s'applique que dans l'environnement 1.

01 Pas de regroupement des entités. Par défaut.

On ne regroupe pas les entités. Elles ont chacune leur gamme propre

02 Regroupement de toutes les entités d'un type donné.

On regroupe toutes les entités d'un type donné en une gamme unique.

C'est utile pour traiter des entités différentes qui sont finalement produites amalgamées.

Les types d'entités à regrouper sont listés dans les notes LST_REG_TEN. Voir ci-dessous.

Les entités associées à un type d'entité non listé conservent leur gamme propre par entité et ne sont pas regroupées.

Dans le cas d'un regroupement, c'est la première entité à regrouper rencontrée qui détermine le début de l'ID_ERP.

Exemple : pour l'OF 08010001-1, si je dois regrouper les entités 2 et 5, toutes deux sur le type d'entité BOI, alors l'ID ERP commencera par 08010001-1/2.

C'est l'entité 2 qui est porteuse du groupement.

Notes techniques : rdre de regroupement employé est le suivant :

order by num_entite_grp, num_phase_dev, cod_machine_dpl, num_phase_fab1, num_entite

On regroupe notamment par machine avant de regrouper par phase, car on peut tenter de regrouper deux entités ayant des phases parfaitement identiques mais ayant leurs phases d'impression sur deux machines différentes.

On évite ainsi les alternances de machines dans le regroupement.

LST_REG_TEN

Liste de types d'entités pour lesquels les entités verront leur opérations regroupées en une gamme unique.

Ce paramètre ne s'applique que dans l'environnement 1.

Ces paramètres ne doivent être lus que pour CFG_REG_ENTDEV = 02.

21,nn <Type entité> <Code regroupement>

Type entité> correspond au type d'entité du devis (TEN)

<Code regroupement> : seule la valeur * (astérisque) est acceptée pour le code regroupement.

Exemple 1

LST_REG_TEN BOI *

On regroupe en une gamme unique toutes les entités (les entités sont toujours de type BOI).

Exemple 2 : Transformateur PLV

Entité 1 : Type BOI

Entité 2 : Type THE

Entité 3 : Type IMP

Entité 4 : Type FAC

Entité 5 : Type BOI

Entité 6 : Type IMP

Entité 7 : Type THE

Paramétrage

LST_REG_TEN BOI *

LST_REG_TEN IMP *

Les entités 1 et 5 de type BOI sont regroupées sur l'entité 1 porteuse.

Les entités 3 et 6 de type IMP sont regroupées sur l'entité 3 porteuse.

L'entité 2 de type THE conserve sa gamme propre.

L'entité 4 de type FAC conserve sa gamme propre.

L'entité 7 de type THE conserve sa gamme propre.

5.5 Configuration du regroupement des opérations

Un dossier Volume contenant des phases opératoires détaillées (calage, roulage, lavage), on peut souhaiter vouloir les regrouper en une seule tâche à destination de Direct Planning.

CFG_REG_OPE

21,22 Méthode de regroupement des opérations

01 Regroupement standard par machine. Par défaut
On regroupe toutes les opérations d'une entité qui se suivent et dont la machine Direct Planning est identique.
La machine Direct Planning est la machine obtenue après correspondance.

02 Regroupement par machine et phase.
Méthode uniquement disponible en environnement 1.
On regroupe toutes les opérations d'une entité qui se suivent et dont la machine Direct Planning est identique et dont le code phase (PHA) est identique.

03 Regroupement par machine et code de regroupement.
Méthode uniquement disponible en environnement 1.
On regroupe toutes les opérations d'une entité qui se suivent et dont la machine Direct Planning est identique et dont le code de regroupement saisi sur la formule est identique.
Si le code regroupement n'est pas renseigné sur la formule, on utilise alors le code phase de manière à tomber sur le mode de regroupement 2.
Avec cette méthode, on peut regrouper des opérations sur des codes phases différents mais aussi éclater des opérations sur des codes phases identiques.

Exemple des différents regroupements d'opérations

Opération (Sec, Phase, Sous-op.) | Machine | Code regroupement sur formule | Regroupement 1 | Regroupement 2 | Regroupement 3
PRE IMP CAL | M1 | RECTO | Une tâche regroupant toutes les opérations de M1 | Une tâche phase IMP | Une tâche code regroupement RECTO
PRE IMP ROU | M1 | RECTO
PRE IMP LAV | M1 | RECTO
PRE IMP CA2 | M1 | VERSO |  |  | Une tâche code regroupement VERSO
PRE IMP RO2 | M1 | VERSO
PRE IMP LA2 | M1 | VERSO
PRE VER ROU |  | VERNIS |  | Une tâche phase VER | Une tâche code regroupement VERNIS

Cas du pliage

Les décompositions en type de cahiers (saisies dans fle_dec) génèrent automatiquement des couples CAL/ROU en pliage pour chacune des lignes de décomposition.

C'est le type de phase PLI (en dur) qui déclenche ce traitement dans le devis.

Dans DP, on va disposer d'une tâche pour chacun de ces couples et ne pas les regrouper.

Au niveau liens, ces tâches seront parallèles.

Pour cela, on utilisera une rupture en parallèle sur la formule associée au roulage du pliage.

On dispose d'un ensemble de codes spéciaux Décomposition de cahier DEV_DCAH_* qui permettent de personnaliser le libellé d'une tâche de pliage.

Le type de pli de cette décomposition DEV_DCAH_PLI_COD associé à un élément technique DirectPlanning permet notamment de gérer une coloration automatique des tâches en fonction du type de pli.

Cas du Collage

En saisie des références multiples (également dans fle_dec) on renseigne les quantités de produit, le code ECMA, le L B H de chacune des références.

Le programme devis est alors capable de dupliquer les phases collages (calage et roulage) pour chacune des lignes de références uniques (même quadruplet ECMA, L B H).

Dans le même esprit que précédemment pour le pliage, les tâches de collage s'exécuteront en parallèle.

5.6 Configuration des liens entre les tâches et durée des liens

Les liens internes à une entité : LIEN_INT

CFG_LIENS_INT

Méthode de gestion des liens internes : les liens entre les tâches d'une même gamme

00 Pas de création de liens entre les tâches d'une même gamme
Les tâches d'une même gamme ne sont pas liées entre elles.

01 Gestion standard des liens internes (mode par défaut)
On crée des liens en série entre les tâches qui se suivent au sein d'une même gamme.
Dans l'environnement 1, nous disposons d'une gamme propre à chaque entité du devis

02 Gestion configurable des liens internes
On va pouvoir via des notes LIEN_INT écrire des règles définissants la manière dont les liens entre les tâches doivent être créés.
Méthode uniquement disponible en environnement 1
Méthode uniquement disponible dans le cas d'un regroupement d'opération : CFG_REG_OPE = 2 (regroupement par phase) ou 3 (regroupement par code sur formule).

LIEN_INT

Syntaxe des liens internes à une entité :

TES:GRPSRC=>GRPDES DUREE

Avec les paramètres suivants :

TES : Le type d'entité source concerné.

G RPSRC : Code groupement source ou succession de codes groupement identifiant la tâche source du lien

On recherche pour source du lien, les tâches ayant un code groupement donné (le code groupement est soit le code phase du devis, soit saisi sur la fiche formule).

Il est possible de lister plusieurs codes groupement sources séparés par des virgules.

L'interpréteur recherchera une tâche dotée du premier code groupement.

S'il en trouve une, il aura trouvé une tâche source et n'explorera pas les autres codes groupement.

S'il n'en trouve pas, il tentera une recherche sur le second code groupement listé, et ainsi de suite.

Valeurs spéciales

#FIRST : La première tâche de l'entité

#LAST: La dernière tâche de l'entité

Exemples

IMP

IMP,REF

#LAST

REF,ASS,#LAST

GRPDES : Code groupement destination ou succession de codes groupement identifiant la tâche destination du lien.

Ayant trouvé un lien source, l'interpréteur va rechercher un lien de destination dans l'entité courante (pour un lien interne).

Il est possible de lister plusieurs codes groupements sources séparés par des virgule. La recherche s'arrêtera dès qu'une tâche possédant un des codes groupement destination est trouvée.

Valeurs spéciales

#NEXT: Le groupe groupement source est la prochaine tâche à suivre dans la gamme.
C'est la valeur par défaut si on ne donne aucune directive pour un groupement.

#FIRST : La première tâche de l'entité.

#LAST: La dernière tâche de l'entité.

#END: Il n'y a pas de groupement de destination
On indique qu'aucun lien ne doit être créé.

Exemples

IMP,REF,#NEXT

#LAST

ASS,MCO,#END

D UREE :Configuration de la durée du lien entre la source et la destination.

Ce paramètre est optionnel. Si la durée n'est pas spécifiée, elle vaut 0.

Plusieurs syntaxes :

%DUR=valeur : La durée du lien vaut valeur minutes.

%DURM=valeur : La durée du lien vaut valeur minutes.

%DURH=valeur : La durée du lien vaut valeur heures.

Avec valeur exprimée

Directement par une valeur numérique.

Exemple : %DURH=4

Par lecture du contenu d'une LCO sur l'entité source.

Exemple : %DURH=LCO_D_205_1 : ici la LCO contient des heures

Par lecture du contenu d'une LCO sur l'entité source associé à une valeur par défaut dans le cas où la LCO n'existe pas ou est non saisie (valeur null).

Exemple : %DURM=LCO_D_206_1,120 : ici la LCO contient des minutes et la valeur par défaut et 120 minutes.

Remarques

U ne règle de lien longue peut être rédigée sur plusieurs lignes : on poursuit à la ligne suivante MAIS en commençant en caractère 22 et non en 21 (le caractère 21 est laissé blanc pour signifier une suite).

Dans le cas de liens internes à une entité, si aucune règle n'a été trouvée pour une tâche, il sera automatiquement créé un lien entre cette tâche et celle qui la suit dans la gamme.

Exemples

Pour le type d'entité COU, le groupement IMP va vers le groupement PLI. On parle de groupement mais il peut s'agir indifféremment de code groupement ou de phase.

LIEN_INT COU:IMP=>PLI

Pour le type d'entité INT, le groupement RECTO va vers le groupement PLI : on introduit un délai de 60 min entre la fin de la première tâche et le début de la seconde.

LIEN_INT INT:RECTO=>PLI %DUR=60

Pour le type d'entité INT, le groupement IMP va vers la phase qui la suit, sans qu'on ai besoin de la spécifier.

LIEN_INT INT:IMP=>#NEXT

Si il n'y a pas de directive pour un groupement c'est la règle #NEXT qui s'applique implicitement (liens en série par défaut).

Pour le type d'entité INT, la phase PAO a deux liens sortant vers IM1 et IM2.

LIEN_INT INT:PAO=>IM1

LIEN_INT INT:PAO=>IM2

On peut donc avoir plusieurs règles de définition de liens sortant pour une même source.

On peut spécifier explicitement qu'il n'y a pas de lien a suivre derrière une tâche.

LIEN_INT FAC:REL=>#END

Pour une gamme, peuvent apparaître dans l'ordre

IM1 (impression premier passage),

IM2 (éventuellement second passage)

IM3 (éventuellement troisième passage)

On peut spécifier une durée (de séchage) de 3 heures entre la dernière des opérations d'impression et la tâche suivante.

LIEN_INT INT:IM3,IM2,IM1=>#NEXT %DURH=3

Pour une entité COU, un lien doit être créé du groupement OZA vers INF.

Si INF n'existe pas, vers COR, ou vers PLA ou vers EQU.

Enfin si EQU n'existe pas, on créera un lien vers la tâche suivant OZA dans la gamme.

La durée de lien (décrite sur la ligne de note suivante et commençant en caractère 22) est donnée en minutes par la LCO 300 sur l'entité COU.

Si cette LCO n'est pas renseignée, la valeur par défaut est de 180 minutes.

1 2

1234567890123456789012

LIEN_INT COU:OZA=>INF,COR,PLA,EQU,#NEXT

LIEN_INT %DURM=LCO_D_300_1,180

Pour une entité COU, un lien doit être créé du groupement OZA vers INF.

Si INF n'existe pas, vers COR.

Enfin si COR n'existe pas aucun lien interne ne sera créé au départ de OZA.

LIEN_INT COU:OZA=>INF,COR,#END

Les liens externes inter-entités : LIEN_EXT

CFG_LIENS_EXT

Méthode de gestion des liens externes : les liens entre les tâches de gamme différentes

00 ou 01 Aucune gestion des liens entre les tâches (par défaut)

02 Gestion configurable des liens externes.
On va pouvoir via des notes LIEN_EXT définir la manière dont les liens externes entre les tâches doivent être créés.
On peut ainsi relier entre elles différentes entités.
Méthode uniquement disponible en environnement 1.
Méthode uniquement disponible dans le cas d'un regroupement d'opération CFG_REG_OPE = 2 (regroupement par phase) ou 3 (regroupement par code sur formule).

03 Gestion automatique des liens externes via nomenclature descriptive PLV du devis.
C'est la nomenclature descriptive et les références saisies sur l'entête du devis et le rattachement de ces références aux différentes entités qui vont automatiquement décrire les liens à créer entre les tâches.
Méthode uniquement disponible en environnement 1
Pas de contrainte sur CFG_REG_OPE

LIEN_EXT

Syntaxe des liens internes à une entité :

TES:GRPSRC=>TED:GRPDES DUREE

Avec les paramètres suivants :

TES: Le type d'entité source concerné.

TED: Le type d'entité destination concerné.

GRPSRC : Code groupement source ou succession de codes groupement identifiant la tâche source du lien

Voir ci-dessus documentation LIEN_INT

GRPDES : Code groupement destination ou succession de codes groupement identifiant la tâche destination du lien.

Voir ci-dessus documentation LIEN_INT

DUREE :Configuration de la durée du lien entre la source et la destination.

Voir ci-dessus documentation LIEN_INT

Remarques

Une règle de lien longue peut être rédigée sur plusieurs lignes : on poursuit à la ligne suivante MAIS en commençant en caractère 22 et non en 21 (le caractère 22 est laissé blanc pour signifier une suite).

Dans le cas de liens externes, il n'y a aucune création implicite de lien.

La dernière tâche des entités de type INT est liée à la première tâche des entités de type FAC.

LIEN_EXT INT:#LAST=>FAC:#FIRST

A noter qu'il peut en effet y avoir plusieurs entités sources de type INT (c'est même fréquent) et également plusieurs entités destination de type FAC.

Si on a 3 entités de type INT et deux entités de type FAC, dans notre exemple on devra alors créer 6 liens.

La dernière tâche des entités de type COU (Couverture) est liée à la tâche de groupement MCO (Montage couverture) sur l'entité de façonnage.

Si le groupement MCO n'est pas trouvé, on créera malgré tout un lien vers la première tâche de l'entité FAC.

La durée de lien (décrite sur la ligne de note suivante et commençant en caractère 22) est donnée en heures par la LCO 205 sur l'entité COU (source).

Si cette LCO n'est pas renseignée, la valeur par défaut est de 3 heures.

LIEN_EXT COU:#LAST=>FAC:MCO,#FIRST

LIEN_EXT %DURH=LCO_D_205_1,3

La dernière tâche des entités de type COU (Couverture) est liée à la tâche de groupement MCO (Montage couverture) sur l'entité de façonnage, ou bien à la tâche de groupement ASS sur l'entité de façonnage.

Si le groupement ASS n'est pas trouvé, on ne créera aucun lien. La durée du lien est de 4 heures.

LIEN_EXT COU:#LAST=>FAC:MCO,ASS %DURH=4

Remarque sur la sous-traitance

La sous-traitance devra être gérée et configurée dans le devis comme les autres opérations.

Les opérations de sous-traitance devront apparaître en final dans fab1.

La durée par contre sera une durée très courte de type jalon.

En effet, dans Direct Planning, nous souhaitons récupérer une tâche courte sur une machine dédiée à la sous-traitance (qu'aura défini le devis).

La tâche aura une durée très courte pour qu'elle puisse jouer son rôle de jalon.

Par contre, les liens entrant et sortant de la sous-traitance pourront porter des durées attestant des temps de sous-traitance.

Ces temps comme décrits plus haut pourront être définis par une constante ou par une LCO calculée par le devis.

5.7 Configuration de la quantité et gâche prévue d'une tâche et calcul de l'état d'avancement

CFG_QTE_LANCEE

Configuration du cumul des quantités et gâches lors du regroupement des tâches.

01 La quantité est issue de la dernière opération regroupée variable.

Cette dernière opération est porteuse de la quantité.

Exemple 1

4001 - Calage

4002 - Roulage recto (Qte = 100.000)

4003 - Roulage verso (Qte = 100.000)

La quantité est issue de l'opération 4003

02 Détermination de la phase porteuse de la quantité via la table des formules.

Si plusieurs phases sont désignées, on cumule alors les quantités des phases désignées.

On utilisera la zone ul_dpl_regroup_qte de la table formules.

Une valeur blanc ou null correspond à N.

Exemple 2

4001 Réglage recto N

4002 Réglage verso N

4003 Calage recto N

4004 Calage verso N

4005 - Roulage recto (Qte = 100.000) N

4006 - Roulage version (Qte = 100.000) O

4007 Changement plaque recto N

4008 Changement plaque verso N

4009 Roulage vernis acrylique (Qte = x ) N

La quantité est issue de la phase 4006 car le flag dans la formule de 4006 est à O.

Les autres flags sont à blanc ou à N.

Exemple 3

Boite Pliante Qte 100.000 mais sur la phase de collage il y a 3 types de collages.

4001 Calage CFC

4002 - Roulage CFC (Qte = 20.000) O

4003 Calage CF2

4004 - Roulage CF2 (Qte = 30.000) O

4005 Calage CF3

4006 - Roulage CF3 (Qte = 50.000) O

Comme 3 phases sont indiquées porteuses de la quantité, on cumule les 3 quantités (20.000+30.000+50.000 pour obtenir donc 100.000 pour la tâche Direct Planning)

Quantité lancée et Gâche prévue

Lors d'un lancement, la génération de dossier tient compte des gâches cumulatives.

Ainsi, on augmente la quantité à entrer en machine en fonction de la gâche prévue.

Exemple

Gâche prévue de 3%

Qté en entrée : 20.600 à Qté en sortie à produire : 20.000

La table fab1 contient alors :

Quantité lancée : F1_qtel = 20.000

Gâche prévue : F1_gp = 600

Pour la table dpl_trf_tache, on stockera :

QTE_LANCEE : La quantité lancée Hors gâche

GACHE_PREVUE : La gâche prévue déterminée par la même principe que la quantité.

Etat d'avancement

Les opérations porteuses des quantités significatives seront utiles dans la détermination de l'état d'avancement.

Dans l'exemple 1 ci-dessus, seul la phase 4003 comptera dans l'état d'avancement.

Si la phase 4003 est clôturée (ou si l'OF est clos), la tâche Direct Planning sera à 100%.

Si elle n'est pas clôturée, la quantité réalisée de cette phase indiquera l'état d'avancement.

Exemple : qté réalisée de 50.000 : état d'avancement = 50%.

Idem pour l'exemple 2 avec la phase 4006.

Pour l'exemple 3, les phases 4002, 4004 et 4006 interviennent selon le même principe.

Exemple phase 4002 close et phase 4004 réalisée avec une quantité de 15.000. Etat d'avancement = (20.000 + 15.000) / 100.000 à 35%

5.8 Configuration de zones standards

Les zones standards ont plusieurs manières d'être renseignées.

CZO_DATE_DEB

Configuration de la zone Date de début lors de la création.

01 Les tâches sont positionnées par défaut à la date et heure du jour ou l'import est réalisé sous DirectPlanning. Mode par défaut.

Correspond à un envoi de NOW en date de début.

Dans ce mode, il existe désormais la gestion d'une exception.

Dans l'ensemble des tâches de cet OF, on recherche la plus contraignante (la plus grande) des dates de réception prévue (donc date de début au plus tôt) sur l'ensemble des marqueurs.

Si une date est trouvée, alors la tâche sera positionnée à cette date et non à la date du jour.

Ceci afin d'éviter qu'une fois la tâche importée dans DP, l'aide à la planification réalise un décalage vers la droite des tâches dotées de date de début au plus tôt, emmenant avec elles les tâches situées à leur droite.

Comme les dates de début au plus tôt issues de VoluPack n'ont pas d'heure, on pourra utiliser le paramètre ci-dessous pour configurer une heure :

V_HHMM_DATE_DEB HH:MM : Heure de début de la date de début. Valeur par défaut : 06:00

02 Les tâches sont positionnées dans la même journée que leur date de fin au plus tard et à une heure de début de journée paramétrée.

Cela permet de placer les tâches de manière assez proche de leur deadline dans le planning.

V_HHMM_DATE_DEB HH:MM : Heure de début de la date de début. Valeur par défaut : 06:00

V_HDED_DATE_DEB Nombre d'heures venant en déduction de la date et heure de début de tâche. Valeur par défaut : 000

03 Réservé

CZO_DDEB_PTOT

Configuration de la zone Date de début au plus tôt

01 Date de début au plus tôt non renseignée (mode par défaut)

CZO_DFIN_PTARD

Configuration de la zone Date de fin au plus tard

00 Date de fin au plus tard non renseignée.

01 Date de fin au plus tard renseignée sur la dernière tâche de la gamme.
Renseigné à partir de la date de fin au plus tard saisi sur la ligne de commande. Mode par défaut.
Attention, la tâche renseignée doit être la dernière de la gamme, c'est à dire la dernière tâche de la dernière entité de façonnage (pas simple).
Ce calcul ne pourra se faire qu'après la phase de regroupement des tâches et la phase de création des liens.
Toutes les tâches (il n'y en aura souvent qu'une) qui n'auront aucun lien sortant se verront affecter cette date de fin au plus tard.
Remarque : Ce paramétrage est incompatible avec les demandes de réservation de capacité (Type d'environnement 11).

02 Date de livraison du devis sélectionné lors d'une demande de réservation de capacité.

Paramètres influant sur cette zone

V_HHMM_DFIN_PTARD HH:MM : Heure et minute de fin de la date de fin au plus tard. Valeur par défaut : 17:00

V_HDED_DFIN_PTARD Nombre d'heures venant en déduction de la date et heure de fin au plus tard. Valeur par défaut : 000

CZO_DUREE

Configuration de la zone Durée

01 La durée standard d'une tâche telle que calculée par le module de génération et tenant compte des regroupements de phases opératoires. (mode par défaut)

Paramètre influant sur cette zone

V_POURC_MAJO_DUREE XX : Pourcentage de majoration de la durée de la tâche. Valeur par défaut : 00 = 0 %

Exemple 05 pour 5 %.

CZO_DUR_REG_PREV

Configuration de la zone Durée de réglage prévue (DirectPlanning 2.0 uniquement)

00 La durée de réglage prévue est laissée à blanc. C'est DirectPlanning qui calculera automatiquement cette durée en fonction de la machine, de l'opération et éventuellement des éléments techniques.

01 La durée de réglage prévue est déterminée par l'ERP (mode par défaut).

CZO_DUR_PAS_PREV

Configuration de la zone Durée de passage prévue (DirectPlanning 2.0 uniquement)

00 La durée de passage prévue est laissée à blanc. C'est DirectPlanning qui calculera automatiquement cette durée en fonction de la machine, de la quantité prévue, de l'opération et éventuellement des éléments techniques.

01 La durée de passage prévue est déterminée par l'ERP (mode par défaut).

CZO_DUR_REG_REAL

Configuration de la zone Durée de réglage réalisée (DirectPlanning 2.0 uniquement)

00 La durée de réglage réalisée est laissée à blanc. Cette saisie du réalisé sera effectuée dans Direct Planning.

01 La durée de réglage réalisée est déterminée par l'ERP. Si des temps de passage réalisés sont trouvés dans VoluPack, alors on alimentera également la zone Réglage terminé à O (mode par défaut).

CZO_DUR_PAS_REAL

Configuration de la zone Durée de passage réalisée (DirectPlanning 2.0 uniquement)

00 La durée de passage réalisée et la durée des arrêts sont laissées à blanc.
Cette saisie du réalisé sera effectuée dans Direct Planning.

01 La durée de passage réalisée est déterminée par l'ERP.
Si des temps d'arrêts sont trouvés dans VoluPack, alors on alimentera également la zone Durée des arrêts réalisés (mode par défaut).

CZO_QTE_PREV

Configuration de la zone Quantité prévue (DirectPlanning 2.0 uniquement)

00 La quantité prévue est laissée à blanc. Cette saisie sera réalisée dans Direct Planning ou bien on ne souhaite pas que cette notion de quantité (et les calculs automatiques des durées qui en découlent) intervienne dans Direct Planning.

01 La quantité prévue est issue de l'ERP.
Se reporter à la configuration CFG_QTE_LANCEE qui précise la manière dont cette quantité lancée est calculée (mode par défaut).

CZO_AVANCEMENT

Etat d'avancement de la tâche

Préambule sur le fonctionnement VoluPack :

En dehors de ce paramétrage, il faut savoir que dans une tâche 3 zones interviennent dans l'état d'avancement :

la quantité lancée

la quantité réalisée

le pourcentage d'état d'avancement en lui-même.

La quantité lancée est pilotée par le paramétrage CFG_QTE_LANCEE décrit plus haut.

La quantité réalisée est renseignée à partir du moment où les saisies des temps ont été intégrées, c'est-à-dire :

- Saisie journalière (sjs)

- Saisie code barre par salarié (sbs) et intégration des temps d'atelier (int_rtm).

Le problème est que l'intégration des temps atelier est souvent réalisée le lendemain.

Il existe donc sur sbs (avec option Om1) un fonctionnement qui fait que lorsqu'un salarié déclare une Fin définitive de phase, alors (si la phase est la dernière des phases regroupées pour former une tâche), l'interface est capable de signaler un état d'avancement 100%, sans pour autant disposer d'une quantité réalisée.

Si le module de déclaration des quantités produites (qte_prod) est utilisé, alors lorsqu'une commande de fabrication est soldée, alors toutes les tâches de cette commande sont déclarées terminées et l'état d'avancement dans VoluPack positionné à 100%.

Si la tâche n'est pas terminée, il est possible de calculer un état d'avancement en se basant sur le ratio entre la quantité réalisée issue de la saisie des temps (table fab2) et la quantité lancée (issu de fab1). Attention cette logique se complique avec les regroupements.

Configuration de la zone Etat d'avancement

La logique décrite ci-dessus intervient quoi qu'il arrive.

Vous pouvez ensuite choisir votre mode de communication avec Direct Planning.

00 Ni la zone état d'avancement, ni la zone quantité réalisée ne sont renseignées dans l'interface.
Cette saisie, si elle est utilisée, sera effectuée dans DP 2.

01 Transfert de l'état d'avancement uniquement. (Pour Direct Planning 1.2)
Dans ce mode, seul l'état d'avancement est transféré à Direct Planning. La zone quantité réalisée n'est pas renseignée.
C'est Direct planning à l'intégration qui calculera une quantité réalisée en accord avec l'état d'avancement qui lui a été passé.
Ce mode était le mode historique de Direct Planning 1.2 puisque dans cette version, seul l'état d'avancement existait (il n'existait pas de notion de quantité lancée ou réalisé). Il n'est pas conseillé avec Direct Planning 2.0

02 Transfert de la zone quantité réalisée ( Direct Planning 2.0 uniquement )
Si vous disposez de Direct Planning 2.0, paramétrez cette option pour transférer les quantités réalisées en plus de l'état d'avancement.
Note technique sur la construction du fichier CSV. Il existe plusieurs cas de figure :

" On transfère la quantité réalisée quand elle est saisie sur le dossier. L'état d'avancement est laissé à blanc et sera calculé par Direct Planning 2.0 en fonction du ratio entre la quantité réalisée et la quantité prévue.

" On transfère l'état d'avancement dans le cas où une clôture de phase, une clôture de dossier ou une déclaration de fin de production ont eu lieu sans qu'une quantité réalisée n'ait été saisie.

CZO_OPERATION

Configuration de la zone Opération (Direct Planning 2.0 uniquement)

00 La zone Opération est laissée à blanc dans l'interface.
Lors de la création d'une tâche, l'opération sera toujours non renseignée.
Le fichier CSV contiendra explicitement une zone vide.

01 L'opération est issue de la configuration de Direct Planning. (Mode par défaut.)
Lors de la création d'une tâche on utilisera l'opération par défaut spécifiée sur la machine.
Le fichier CSV contiendra la chaîne #DEF.

02 L'opération est issue de la fiche formule associée à la première tâche regroupée pour laquelle ce code opération est saisi.
Si l'opération issue de la fiche formule n'est pas renseignée, on prendra par défaut celle configurée dans Direct Planning.
Exemple : dans le cas simple du regroupement d'un réglage et d'un passage, c'est la fiche formule du passage qui contiendra le code Opération Direct Planning (mode par défaut).

V_POURC_DUREE_DPLAN

Pourcentage d'augmentation de la durée d'une tâche au-delà duquel on déclenche une déplanification.

Valeur par défaut : 050 : 50%

Si la ligne est absente ou si = -1, alors une augmentation de durée ne déplanifie jamais une tâche.

5.9 Configuration des entités Direct Planning

ENT1_COD ENT1_LIB ENT1_COULEUR ENT1_ZL1 ENT1_ZL[2 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Peut être décrit sur plusieurs lignes. Code couleur de l'entité ou STD_RANDOM. Par défaut : LightYellow Zone libre 1. Cette zone peut être constituée par plusieurs lignes de paramétrage. 10 lignes de notes possibles Zone libre 2 à 10 (Direct Planning 2 uniquement)
ENT2_COD ENT2_LIB ENT2_COULEUR ENT2_LIEE_ENT1 ENT2_ZL1 ENT2_ZL[2 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Code couleur de l'entité L'entité 2 est elle liée à l'entité 1 ? (O/N, N Par défaut) Zone Libre de l'entité Zone libre 2 à 10 (Direct Planning 2 uniquement)
ENT3_COD ENT3_LIB ENT3_COULEUR ENT3_LIEE_ENT1 ENT3_LIEE_ENT2 ENT3_ZL1 ENT3_ZL[2 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Code couleur de l'entité L'entité 3 est elle liée à l'entité 1 ? (O/N, N Par défaut) L'entité 3 est elle liée à l'entité 2 ? (O/N, N Par défaut) Zone Libre de l'entité Zone libre 2 à 10 (Direct Planning 2 uniquement)
ENT4_COD ENT4_LIB ENT4_COULEUR ENT4_LIEE_ENT1 ENT4_LIEE_ENT2 ENT4_LIEE_ENT3 ENT4_ZL1 ENT4_ZL[2 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Code couleur de l'entité L'entité 4 est elle liée à l'entité 1 ? (O/N, N Par défaut) L'entité 4 est elle liée à l'entité 2 ? (O/N, N Par défaut) L'entité 4 est elle liée à l'entité 3 ? (O/N, N Par défaut) Zone Libre de l'entité Zone libre 2 à 10 (Direct Planning 2 uniquement)
ENT5_COD ENT5_LIB ENT5_COULEUR ENT5_LIEE_ENT1 ENT5_LIEE_ENT2 ENT5_LIEE_ENT3 ENT5_LIEE_ENT4 ENT5_ZL1 ENT5_ZL[2 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Code couleur de l'entité L'entité 5 est-elle liée à l'entité 1 ? (O/N, N Par défaut) L'entité 5 est-elle liée à l'entité 2 ? (O/N, N Par défaut) L'entité 5 est-elle liée à l'entité 3 ? (O/N, N Par défaut) L'entité 5 est-elle liée à l'entité 4 ? (O/N, N Par défaut) Zone Libre de l'entité Zone libre 2 à 10 (Direct Planning 2 uniquement)
ENT 6 à ENT10 | Direct Planning 2.0 gère 10 entités.
ENT10_COD ENT10_LIB ENT10_COULEUR ENT10_LIEE_ENT1 ENT10_LIEE_ENT2 ENT10_LIEE_ENT3 ENT10_LIEE_ENT4 ENT10_LIEE_ENT5 ENT10_LIEE_ENT6 ENT10_LIEE_ENT7 ENT10_LIEE_ENT8 ENT10_LIEE_ENT9 ENT10_ZL[1 à 10] | Le code correspondant au code de l'entité Le code correspondant au libellé de l'entité Code couleur de l'entité L'entité 10 est-elle liée à l'entité 1 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 2 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 3 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 4 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 5 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 6 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 7 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 8 ? (O/N, N Par défaut) L'entité 10 est-elle liée à l'entité 9 ? (O/N, N Par défaut) Zone libre 1 à 10 (Direct Planning 2 uniquement)

5.10 Configuration des tâches

Toutes les zones ci-dessous peuvent être constituées par plusieurs lignes de paramétrage.

TAC_NOM

Le nom de la tâche

TAC_COD_RES_[2..5]

Le code des ressources 2 à 5

Cette configuration est obsolète pour Direct Planning 2.

TAC_COD_ET[1..5]

Eléments techniques de 1 à 5

TAC_COD_ET[6..20]

Eléments techniques de 6 à 20 (Direct Planning 2.0 uniquement).

TAC_ZL[1 à 5]

Zones libres de la tâche

TAC_ZL[6 à 10]

Zones libres (de 6 à 10) de la tâche. (Direct Planning 2.0 uniquement).

TAC_DUR_TRANSITION

Valeur du temps de transition imposé (en minutes). (Direct Planning 2.0 uniquement).

Depuis Direct Planning 2.0, le temps de transition entre deux tâches peut être imposé. On peut donc ici en imposer une valeur.

Ne pas configurer cette note si on ne souhaite pas imposer ce temps de transition.

Il sera alors déterminé automatiquement par Direct Planning 2.0 en fonction des éléments techniques.

La gestion des temps de transition est disponible dans Direct Planning dans l'offre Intégrale.

On pourra par exemple, utiliser un LCO ou un TSC pour déterminer cette valeur.

Une valeur null lue correspondra à une non-imposition de cette durée de transition (zone laissée à blanc dans l'interface).

TAC_ALERTE_MAN

Texte de l'alerte manuelle (Direct Planning 2.0 uniquement).

5.11 Configuration des marqueurs

La gestion des marqueurs fait désormais l'objet d'un chapitre à part entière en 2ème partie de ce document.

5.12 Configuration de l'import des éléments techniques

TEC[1...20]_COD | Code correspondant au code de l'élément technique
TEC[1...20]_LIB | Code correspondant au libellé de l'élément technique. Peut être décrit sur plusieurs lignes.
TEC[1...20]_COULEUR | Code couleur de l'élément technique ou STD_RANDOM. Par défaut : LightYellow

La présence d'une note TEC :

L'absence de la note TAC_COD_ET[n]. Avec n correspondant au TEC[n]_COD

L'import dans DP de l'élément technique TEC[n]_COD avec libellé et couleur paramétrés.

Exemple

TAC_COD_ET1 TSC_AF110_C

TEC2_COD Z_mp_qua_sfm

TEC2_LIB Z_libl_mp_qua_sfm

5.13 Codes champ

Les codes champs sont utilisés dans les configurations des entités, des tâches et des codes champs variables pour définir des libellés ou des codes.

Remarques

Partout où ces codes sont employés, on peut les concaténer en séparant avec un point virgule.

Les espaces à droite sont toujours supprimés du résultat d'un code. Un code d'un seul espace est cependant conservé.

Codes champs standards

STD_CLI_COD

STD_CLI_LIB

Code Client

Raison sociale du client

STD_CODE_POSTAL_PAYS

Code postal du client livré. Si le client livré se situe dans le même pays que la société il renverra uniquement le code postal.

Si le client livré est dans un autre pays, alors le code postal sera sous la forme suivante : PPPXXXX

Avec PPP = code pays ISO et XXXX = le code postal.

STD_CDE1_COD

STD_CDE1_LIB

Numéro de commande (ex : 08020001)

Libellé entête de commande (ec_texte)

STD_CDE2_COD

STD_CDE2_PROD_COD

STD_CDE2_PROD_LIB

STD_CDE2_LIB

STD_CDE2_QTE

STD_LIB_ETR_PROD_CDE

Numéro de commande et ligne de commande (ex : 08020001-2)

Code article de la ligne de commande

Libellé de l'article de la ligne de commande

Libellé de la ligne de commande (lc_lib)

Quantité commandée de produit fini. lc_qtecde de l'OF avec un using <<<<<<<<<<<&

Libellé étranger du code article de la ligne de commande

STD_OF_COD

STD_OF_QTE

STD_OF_PROD_COD

STD_OF_PROD_LIB

STD_LIB_ETR_PROD_OF

Numéro de l'OF associé à la gamme (ex : 08020001-2/4)

Quantité de l'OF (issue de fab0)

Code article de l'OF

Libellé de l'article de l'OF

Libellé étranger du code article de l'OF

STD_OF_RAC_COD

STD_OF_RAC_QTE

STD_OF_RAC_PROD_COD

STD_OF_RAC_PROD_LIB

Numéro de L'OF racine (ex : 08020001-2)

Quantité de l'of racine (issue de fab0)

Code article de l'OF racine

Libellé de l'article de l'OF racine

STD_REP_COD

STD_REP_LIB

STD_REP_TEL

Code Représentant de la ligne de commande (lc_repr) (ou ec_repr ou cl_repr si non renseigné)

Nom du représentant

Téléphone du représentant

On recherche d'abord le commercial dans la table corres sur #SOC (ligne associée au REP)

Si aucun résultat trouvé, on prend le téléphone dans REP A2[1,30].

STD_FAB_COD

STD_FAB_LIB

STD_FAB_TEL

Code du fabricant de l'entête de commande (ec_suiv) (ou celui du client si non renseigné)

Nom du fabricant

Téléphone du représentant

On recherche d'abord le fabricant dans la table corres sur #SOC (ligne associée au FAB)

Si aucun résultat trouvé on prend le téléphone dans FAB A2[1,30].

STD_CORRES_COD

STD_CORRES_LIB

STD_CORRES_TEL

Code du correspondant principal de l'entête de commande (ou de la fiche client si non renseigné).

Ce code est de la forme <code client>/<Nom du correspondant>

Nom du correspondant principal.

Téléphone du correspondant principal issu de la table des correspondants.

STD_QTE_LANCEE_GC

Quantité lancée de l'opération gâche comprise.

Cette quantité est calculée en utilisant la configuration CFG_QTE_LANCEE.

On utilise un using <<<<<<<<<<<& pour l'envoi dans le fichier Direct Planning.

STD_QTE_LANCEE_HG

Quantité lancée de l'opération Hors gâche.

Cette quantité est calculée en utilisant la configuration CFG_QTE_LANCEE.

On utilise un using <<<<<<<<<<<& pour l'envoi dans le fichier Direct Planning.

STD_GACHE_PREVUE

Gâche prévue

Cette quantité est calculée en utilisant la configuration CFG_QTE_LANCEE.

On utilise un using <<<<<<<<<<<& pour l'envoi dans le fichier Direct Planning.

STD_QTE_REALISEE

Quantité réalisée de l'opération.

On utilise un using <<<<<<<<<<<& pour l'envoi dans le fichier Direct Planning.

STD_DUR_REG

STD_DUR_PAS

STD_DUR_TOT

Durée planifiée du réglage (Format : 124 Min)

Durée planifiée du passage

Durée planifiée totale

STD_DUR_REG_REALISEE

STD_DUR_PAS_REALISEE

STD_DUR_TOT_REALISEE

Durée réalisée du réglage

Durée réalisée du passage

Durée réalisée totale

STD_RANDOM

Code couleur aléatoire

Code fonctionnant à partir de Direct Planning 1.2.13

Changement de méthode par rapport à l'ancien transfert DirectPlanning.

Le code STD_RANDOM génère dans le fichier CSV le mot clé RANDOM. Il n'a de sens qu'associé à un champ couleur.

C'est alors DirectPlanning uniquement à partir de la version 1.2.13- qui lors de l'import affectera une couleur aléatoirement.

Il s'agira d'une couleur pastel visuellement acceptable.

STD_REGROUP_COD

STD_NUM_TRANSFERT

STD_NUM_TACHE

STD_DATE_DEMANDE

Code de regroupement paramétré dans les formules (ou code phase quand non renseigné).

Numéro de transfert Volume. Il s'agit d'un numéro de transfert Volume issu de la table dpl_trf_tache. Exemple : [48717]

Numéro de tâche du transfert en cours Exemple : [48717-12]

Date de la demande de transfert. Exemple : [2008/03/28 17:25]

Codes d'accès à une zone d'une table

Z_xxxx

ou

Z_xxxx%yyyy

Accès à la zone xxxx de la base en imposant un format yyyy

Pour les numériques le format par défaut est <<<<<<<<<&

Pour les dates le using par défaut est dd/mm/yyyy

Tables accessibles

client (cl_)

client livré (cl_liv_)

Entête de commande (ec_)

Entête de commande de rattachement (ec_rat_)

Ligne de commande (lc_)

Ligne de commande de rattachement (lc_rat_)

Article de ligne de l'article fabriqué (mp_fab_ ou mp_) : c'est l'article de fab1

Article de ligne de commande (mp_cde_)

Article de ligne de commande de rattachement (mp_cdr_)

Article de ligne de la qualité (mp_qua_). Spécifique onduleur

Article de ligne de l'architecture (mp_arc_). Spécifique onduleur

Article de ligne de l'impression (mp_imp_). Spécifique onduleur

Article du mp_tsc(mp_tsc_n_)

avec n de 1 à 5 : Voir paramétrage DEF_MP_TSC plus haut.

Article de la qualité du papier (mp_paq_) (lecture de mat via le code article fi_c_papier).

Article du cliché (mp_cli_n_) avec n de 1 à 2. Solution onduleur : TSC C%0 sur couple article-gamme.

Article de la forme de découpe (mp_fdc_n_) avec n de 1 à 2. Solution onduleur : TSC 910/911/912/913 sur couple article-gamme.

Qualité matière du code article de l'OF (STD_OF_PROD_COD) (mp_qmof_)

Qualité matière du code article de la ligne de commande (STD_CDE2_PROD_COD) (mp_qcde_)

Gamme de fabrication fab1 (f1_)

Devis imprimerie (l2_)

Entités du devis (fi_)

L'OF gamme (f0_gam_ ou f0_ ) : fab0 de la gamme courante , ex : 08040001-1/4

L'OF racine (f0_rac_) : fab0 du plus haut niveau, ex : 08040001-1

Décomposition en cahier (de_dcah_)

Références multiples (de_refm_)

Accès aux libellés courts et longs :

Z_libc_ xxxx (exemple : Z_libc_cl_pays)

Z_libl_ xxxx (exemple : Z_libl_cl_pays)

Accès aux LCO / TSC / NTS

LCO_ | Accès à une LCO selon la syntaxe d'appel La syntaxe LCO_O_LLL_Z%[using) permet d'indiquer un using.
TSC_ | Accès à un TSC selon la syntaxe d'appel <ou> Dans toutes ces syntaxes qui suivent, Z représente le code zone du TSC. La syntaxe TSC_x_TSC_Z%[using) permet d'indiquer un using.
TSC_A_TSC_Z TSC_AFTSC_Z TSC_ACTSC_Z TSC_ARTSC_Z | TSC article TSC article de fabrication TSC article de la ligne de commande TSC article de la ligne de commande de rattachement
TSC_A1TSC_Z TSC_A2TSC_Z TSC_A3TSC_Z TSC_A4TSC_Z TSC_A5TSC_Z | TSC défini via la note DEF_MP_TSC1 TSC défini via la note DEF_MP_TSC2 TSC défini via la note DEF_MP_TSC3 TSC défini via la note DEF_MP_TSC4 TSC défini via la note DEF_MP_TSC5
TSC_C_TSC_Z | TSC de la ligne de commande
TSC_F_TSC_Z | TSC client
TSC_O_TSC_Z | TSC de la dernière ligne de fab1 regroupée Exemple : Si on a regroupé un calage et un roulage, la dernière ligne lue dans le regroupement sera le roulage. C'est donc à cette ligne qu'on aura accès.
TSC_D_TSC_Z | TSC Entité devis
NTS_ | Accès à la 1ère ligne de note avec la syntaxe NTS_xxxxxx_yyy où xxxxxx = Nom de la table CDEEC Table cde3 - Entête de commande commerciale CDEEF Table cde3- Entête de commande de fabrication CDELC Table cde3- Ligne de commande commerciale CDELF Table cde3- Ligne de commande de fabrication CLI Table cli3 - Client CLIL Table cli3- Client livré MATC Table mat3 - Article commercialisé MATF Table mat3- Article fabriqué NOTAC Table notes - Article commercialisé NOTAF Table notes- Article fabriqué NOTDEC Table notes- Entête de commande commerciale NOTDEF Table notes- Entête de commande de fabrication NOTDLC Table notes- Ligne de commande commerciale NOTDLF Table notes- Ligne de commande de fabrication NOTH Table notes- Client NOTHL Table notes- Client livré NOTM Table notes- Machine yyy = Type de note

Codes champs onduleur

OND_OPERATION_COD OND_OPERATION_LIB | Code de l'opération Libellé de l'opération
OND_SECTION_CODE OND_SECTION_LIB | Code de la section Libellé de la section
OND_CLICHE_1 OND_CLICHE_2 | Code du cliché 1 Code du cliché 2
OND_FORME_1 OND_FORME_2 | Numéro de la forme 1 Numéro de la forme 2
OND_COULEURS OND_COULEUR_n | Liste des codes couleurs + le nombre de couleur au total Avec n de 1 à 5 Code couleurs

Codes champs devis

DEV_DEVIS_01 DEV_DEVIS_02 DEV_DEVIS_03 | Numéro de devis au format : 08040001 Numéro de devis et sous devis au format : 08040001-1 Numéro de devis, sous-devis et entité au format : 08040001-1/3
DEV_PHA_COD DEV_PHA_LIB | Code de la phase (PHA) Libellé de la phase Attention dans le cas d'un regroupement d'opérations appartenant à des phases différentes (plutôt rare), ces codes renverront les informations concernant la dernière phase regroupée.
DEV_TEN_COD DEV_TEN_LIB | Code du type d'entité (TEN) Libellé du type d'entité
DEV_ENT_NUM DEV_ENT_LIB DEV_ENT_COLOR | Numéro de l'entité au format 1 Désignation de l'entité (fi_d_entite) Couleur automatique de l'entité. Les entités de 1 à 9 ont des couleurs particulières et Jaune au delà.
DEV_TPR_COD DEV_TPR_LIB | Code du type de produit (TPR) Libellé du type de produit
DEV_FORMAT_01 DEV_FORMAT_02 DEV_FORMAT_03 DEV_FORMAT_04 | Format de l'entité (fi_lar_fini x fi_lon_fini) Format de tirage (fi_lar_tir x f_lon_tir) Format papier (fi_lar_papier x fi_lon_papier) Format d'ouverture (fi_lar_ouv x fi_lon_ouv)
DEV_QTE_01 | Quantité de l'entité (formatée sans décimales)
DEV_QUAL_COD DEV_QUAL_LIB DEV_QUAL_LIB_01 DEV_QUAL_GRAM | Code papier (fi_c_papier) Désignation papier (fi_d_papier) Désignation du papier suivie de son grammage Grammage papier de la forme 120g
DEV_PQUA_COD DEV_PQUA_LIB | Code de la qualité papier/carton (lié au fi_c_papier) Libellé de la qualité papier/carton (lié au fi_c_papier)

Codes champs prédéfinis pour des noms de tâches

DEV_NOM_01 | Numéro de l'entité suivi du libellé de l'entité 3 Cahier 64 pages
DEV_NOM_02 | Numéro de l'entité suivi du libellé de l'entité et du format (ajouter une condition sur le format) 3 Cahier 64 pages : 18 x 32

Codes champs devis décomposition de cahier

Code utilisé spécifiquement pour les opérations de pliage.

Les codes proposés ici permettent d'affecter à un champ d'une tâche, un libellé décrivant le pliage qui lui est propre.

Il est judicieux de les employer dans CCV_DEV_GRP_xx où l'on testera le groupement PLI.

DEV_DCAH_PLI_COD DEV_DCAH_PLI_LIB | Code pliage correspondant automatiquement à la ligne de décomposition associée à la tâche. Ce code pliage pourra dans Direct Planning être utilisé sur un élément technique. Via coloration par élément technique on pourra ainsi bien visualiser les changements de pliage. Voire on pourra utiliser les ajouts automatique de temps de transition dans Direct Planning. Libellé du pli
DEV_DCAH_NB_FEU DEV_DCAH_NB_CAH DEV_DCAH_NB_PAG DEV_DCAH_NB_POS DEV_DCAH_NBT_PAG | Nombre de feuilles Nombre de cahiers Nombre de pages par cahier Nombre de poses Nombre total de pages (Nombre de feuilles X Nombre de cahiers X Nombre de pages par cahier)
DEV_DCAH_LIB_01 DEV_DCAH_LIB_02 | Libellé du pliage correspondant automatiquement à la ligne de décomposition associée à la tâche. Cah de 8 Pag en 1 Pos Cah de 8 Pag en 1 Pos : Pli : 12C

Voir Annexes pour le détail du fonctionnement de fle_dec.

Codes champs devis références multiples

Ces codes permettent pour une tâche donnée d'aller chercher une information sur la ligne de référence multiple associée. Utile notamment pour le Collage.

DEV_REFM_REF_NUM DEV_REFM_REF_COD DEV_REFM_REF_LIB DEV_REFM_QTE DEV_REFM_NB_POSES | Numéro de la référence Code de la référence Libellé de la référence Quantité de la référence Nombre de poses de la référence
DEV_REFM_ECMA_COD DEV_REFM_ECMA_LIB DEV_REFM_DIM_ABH DEV_REFM_DIM_A DEV_REFM_DIM_B DEV_REFM_DIM_H | Code ECMA Libellé de l'ECMA Dimensions intérieurs (au format A x B x H) Dimension intérieure A Dimension intérieure B Dimension intérieure H

Voir les annexes pour le détail du fonctionnement des références multiples.

Codes champs devis traitant des couleurs

Dans les codes suivants, on utilisera les abréviations suivantes :

rR : Nombre de couleurs recto

vV : Nombre de couleurs verso

cC : Nombre total de couleurs (nombre de couleurs recto + nombre de couleurs verso - nombre de couleurs communes.

VAR : Code du vernis acrylique recto

VAV : Code du vernis acrylique verso

Retiration

On définit une machine retiration si mac0.m0_zb = O.

Il s'agit à l'écran de la zone paramétrable 5 de la fiche machine.

Comme on est susceptible de regrouper plusieurs machines Volume en une seule machine DP, c'est la dernière machine regroupée qui détermine s'il s'agit ou non de retiration.

Dans les codes ci-dessous on emploiera les séparateurs suivants :

/ pour les impressions en retiration

+ pour les impressions classiques

DEV_COUL_TOT | Nombre de couleurs total cC
DEV_COUL_RV | Nombre de couleurs recto et verso rR rR+vV ou rR/vV (en retiration) Pas d'espaces autour du + ou du /
DEV_COUL_RV_VA | Nombre de couleurs et vernis acrylique recto et verso rR rR+vV ou rR/vV (en retiration) rR VAR rR VAR+vV VAV ou rR VAR/vV VAV (en retiration) Un espace entre rR et VAR si VAR est renseigné.
DEV_COUL_R | Nombre de couleurs recto rR
DEV_COUL_R_VA | Nombre de couleurs recto et vernis acrylique rR rR VAR
DEV_COUL_V | Nombre de couleurs verso vV
DEV_COUL_V_VA | Nombre de couleurs recto et vernis acrylique vV vV VAV
DEV_R_VA | Vernis acrylique recto précédé d'un blanc VAR
DEV_V_VA | Vernis acrylique verso précédé d'un blanc VAV
DEV_COUL_PANT_RV | Nombre de pantone recto et verso pR pR+qV ou pR/qV (en retiration) avec : Nombre de pantone recto : p = r (Nbre couleur primaire recto) Nombre de pantone verso : q = v (Nbre couleur primaire verso)

Codes champs standards en configuration gammes standards

STD_GAMME_COD STD_GAMME_LIB | Code de la gamme Libelle de la gamme
STD_LAIZE_ONDULEUSE | Laize onduleuse Si type de machine OND : TSC 070 N1 de la machine. Sinon : N/A Le type de machine (TMC) est obtenu en lisant la machine dans fab1 pour NUM_OF et NUM_PHASE_FIN.
STD_REF_ENSEMBLE | Libellé étranger de l'ensemble
STD_BESOIN_TOTAL | Besoin total pour cette ligne de commande (issu de la table cde5)

5.14 Configuration des codes champs variables liées au devis : CCV_DEV_GRP

Les codes champs variables permettent de renvoyer des libellés différents selon que l'on est sur une tâche liée à un code regroupement donné.

Les codes champs variables du devis dépendent donc du code groupement issu de la formule (ou de la phase si ce code groupement n'est pas rempli).

On peut en paramétrer 50 différents.

CCV_DEV_GRP_01

CCV_DEV_GRP_02

&

CCV_DEV_GRP_49

CCV_DEV_GRP_50

Configuration de codes champs variables du devis en fonction du groupement

Avec les CCV_DEV_GRP, vous pouvez définir des libellés variables dont les règles de construction dépendent du code groupement de la tâche.

XXXXXX :<paramétrage utilisant des codes champs>

où XXXXXX est le code groupement (ou le code phase) pour lequel on définit la zone

Si XXXXXX = #ELSE définit une condition de paramétrage, si jamais on n'a pas trouvé de paramétrage relatif au code groupement de la tâche.

Attention, chaque ligne de configuration pourra se décomposer sur plusieurs lignes.

La ligne de suite est située juste après la première ligne et cette fois ne commence pas par XXXXXX :.

Exemple de paramétrage

TAC_NOM

CCV_DEV_GRP_01

CCV_DEV_GRP_01

CCV_DEV_GRP_01

CCV_DEV_GRP_1

IMP:DEV_COUL_RV

PLI:DEV_DCAH_LIB_01

#ELSE : DEV_PHA_LIB

Le libellé de la tâche contiendra ce champ variable.

Si phase IMP, on renvoie le code champ qui donne le nombre de couleurs recto/verso.

Si phase PLI, on renvoie le code champ qui donne la décomposition du pliage.

Pour les autres phases, on renvoie simplement le libellé de la phase.

5.15 Configuration des codes champs variables standards : CCV_STD

Les codes champs variables standards sont une généralisation des codes champs variables devis.

Dans ce cas, au lieu de tester un code regroupement, on pourra tester n'importe quel code calcul.

On peut en paramétrer 50 différents.

CCV_STD_01

CCV_STD_02

&

CCV_STD_50

Configuration de codes champs variables standards en fonction du groupement.

Avec les CCV, vous pouvez définir des libellés variables dont les règles de construction dépendent du code groupement de la tâche.

#EVAL:<code calcul à évaluer>

<valeur 1>:<code calcul retourné si le code calcul évalué vaut valeur 1.

<valeur 2>:<code calcul retourné si le code calcul évalué vaut valeur 2.

<valeur 3>:<code calcul retourné si le code calcul évalué vaut valeur 3.

#EMPTY:<code calcul retourné si le code calcul évalué est blanc ou vide >

#ZERO:<code calcul retourné si le code calcul évalué est blanc ou vide ou vaut 0>

#ELSE:<code calcul retourné dans tous les autres cas>

Attention, chaque ligne de configuration pourra se décomposer sur plusieurs lignes.

La ligne de suite est située juste après la première ligne et cette fois ne commence pas par XXXXXX :.

Dans un code calcul retourné, le "deux-points" peut être utilisé mais il doit alors être encadré par deux point-virgules.

Exemple : #ELSE :Nb coul ;:; LCO_D_I11_1

Exemple de paramétrage

TAC_ZL1

CCV_STD_01

CCV_STD_01

CCV_STD_01

CCV_STD_01

CCV_STD_01

CCV_STD_01

#EVAL:LCO_D_I11_1

#ZERO:Sans impression recto

1:Une couleur recto

#ELSE:LCO_D_I11_1; coul.recto; ;

LCO_D_I11_A_LIBC;

La zone libre 1 contiendra ce champ variable.

On évalue le nombre de couleur recto.

Si zéro (ou non saisi)

Si une couleur

Si plus d'une couleur

Suite du libellé pour #ELSE

Un CCV_STD peut sans problème être utilisé dans un autre CCV_STD ou CCV_DEV_GRP.

CHAPITRE 2 - LA GESTION DES MARQUEURS

Objectif

L'objectif est de pouvoir associer les états de certains marqueurs Direct Planning à des éléments déclencheurs dans Volume.

Exemples

• Un marqueur Présence carton voit ses états se modifier en fonction des états :

Commande d'achat à passer

Commande d'achat existante

Commande d'achat réceptionnée

• Un marqueur est associé à une ligne de la table des action/événements, exemple

Bon à gaufrer à envoyer

Bon à gaufrer envoyé

Une difficulté réside dans le fait que suite à modification de Volume sur ces éléments déclencheurs (commande d'achat, action / événement), alors tous les OF concernés dans Direct Planning doivent se trouver modifiés automatiquement.

Génération des demandes

Le principe de l'interface Direct Planning repose sur le fait que des programmes déclencheurs génèrent des demandes (dans la table dpl_trf_demande) d'actualisation d'un OF dans Direct Planning.

Ce principe doit être conservé.

La difficulté est cependant de ne pas générer massivement un grand nombre de demandes qui ne concernent pas Direct Planning.

Par exemple, si on a uniquement un marqueur qui attend la réception d'une forme de découpe, alors il est inutile de générer des demandes pour tout achat qui ne concerne pas une forme de découpe.

Partie commune à toutes les demandes

Les notes suivantes doivent être définies dans le paramètre de lancement des programmes.

DIRECT_PLANNING_TRF

21 Activer le transfert vers Direct Planning (O/N, N par défaut)

Au niveau des achats

Les notes suivantes doivent être définies dans le paramètre de lancement des programmes gérant les achats.

DIRECT_PLANNING_SEL

21,60 Complément de sélection sur les tables cdf1 et cdf2

Pour ne pas générer systématiquement une demande à chaque création, modification ou réception d'une commande d'achat.

Plusieurs lignes possibles. La ligne suivante commence par un blanc, si c'est la suite d'une expression longue.

Exemple : and ef_tyc = "CAR"

DIRECT_PLANNING_LFV

21 Lors d'une demande de transfert à Direct Planning dans la gestion des achats, prendre en compte la ventilation des lignes de commande d'achat (cdf2_ventil).

O recherche dans la table des ventilations

N pas de recherche dans la table des ventilations (par défaut)

Les programmes pouvant recevoir les notes ci-dessus sont les suivants :

gen_cdef | Génération des commandes d'achat
cdef | Saisie des commandes d'achat
brc | Saisie des bons de réception

Pour les achats, on sera donc capable de générer des demandes d'actualisation sur les OF apparaissant en affectation (soit directe, soit sur la ligne de ventilation) d'une commande d'achat.

On pourra filtrer les commandes d'achats que l'on souhaite inspecter, de manière à ne pas générer trop de demandes.

Au niveau des actions / événements

Les notes suivantes doivent être définies dans le paramètre de lancement des programmes gérant les actions / événements.

DIRECT_PLANNING_SAE

21,60 Complément de sélection sur la table action_evt

Pour ne pas générer systématiquement une demande à chaque création ou modification d'une action événement.

Plusieurs lignes possibles. La ligne suivante commence par un blanc, si c'est la suite d'une expression longue.

Exemple : and ace_etape = "RMD" and ace_code = "450"

Les programmes pouvant recevoir les notes ci-dessus sont les suivants :

directplanning | Interface Direct Planning
cde | Saisie des commandes clients
cli | Saisie des tiers
devis_standard | Saisie des devis multi-métiers
mat | Saisie des articles
v_action_evt | Visualisation des actions - événements
v_cdem | Visualisation des commandes clients
v_cli | Visualisation des tiers
v_fle | Visualisation des devis

Configuration de l'interface pour la gestion des marqueurs

Principe

Le principe est de pouvoir configurer des recherches qui seront évaluées pour chaque nouvelle demande de création/modification d'OF.

Une recherche peut être une recherche dans les achats, dans la table des actions_evenement par exemple.

Chaque recherche est configurée via des arguments (mode de fonctionnement de la recherche, critères de sélection).

Ces recherches sont évaluées une seule fois (par OF) et stockent leur résultat dans un tableau interne.

Chaque donnée résultante de la recherche est disponible via des codes calcul.

Ces codes calcul sont utilisés ensuite pour définir le statut des marqueurs et enrichir les zones configurables des marqueurs.

Configuration des recherches à réaliser

Principe de configuration des recherches

Il est possible de configurer jusqu'à 99 recherches. Le nn identifie chaque recherche (de 01 à 99).

RECnn_FONCTION

Code de la fonction de recherche à déclencher.

Fonction disponible : ACHAT

RECnn_PARAMETRE

Paramètres de la fonction de recherche.

Un seul paramètre par ligne. Le nombre de lignes de paramètres possibles est propre à chaque fonction de recherche.

Si le paramètre est très long, on poursuit à la ligne suivante en prenant soin de laisser le caractère 21 à blanc.

Chaque recherche produit un ensemble de données comme résultat. Chacune de ces données sera accessible via un code champ.

Ce code champ pourra être utilisé comme tous les autres pour remplir les zones de l'interface.

Cependant, il sera surtout utilisé pour remplir les états et les zones configurables de marqueurs.

REC01_xxxxxxxx

Ce code champ fournit la valeur de la donnée xxxxxxxx obtenue dans le cadre de la recherche 01.

La recherche dans les achats

Cette fonction recherche dans les achats, une ligne de commande d'achat où l'OF apparaît dans l'affectation de la ligne de commande d'achat ou dans les lignes de ventilation.

RECnn_FONCTION | ACHAT
RECnn_PARAMETRE | SEL_CDF1 : Critère de sélection sur la table des entêtes de commande d'achat Exemple SEL_CDF1: ef_tyc = "PAP" SEL_CDF2 : Critère de sélection sur la table des lignes de commande d'achat Exemple SEL_CDF2: lf_prod like "XPAP%" or lf_fam = "PAP" REC_VENTILATION : 0/1, 1 par défaut Recherche dans la table des ventilations. Gain de temps dans la recherche si les ventilations ne sont jamais utilisées.

Codes champs résultat

RECnn_COD_FOURNISSEUR | Code fournisseur C'est le dernier code fournisseur trouvé qui sera importé.
RECxx_COD_PROD | Code produit de la ligne de la commande d'achat
RECnn_DATE_ACCUSEE | Date de réception accusée par le fournisseur C'est la dernière date de réception accusée par le fournisseur trouvée qui sera importée.
RECnn_DATE_CDE | Date de la commande d'achat C'est la dernière date de commande d'achat trouvé qui sera importée.
RECnn_DATE_RECEPTION | Date de réception réelle C'est la dernière date de réception réelle trouvée qui sera importée (brc).
RECnn_DATE_SOUHAITEE | Date de réception souhaitée C'est la dernière date de réception souhaitée trouvée qui sera importée.
RECnn_FORMAT | Liste des différents formats des différentes commandes d'achats affectées à l'OF.
RECnn_LIB_FOURNISSEUR | Libellé du fournisseur C'est le dernier libellé fournisseur trouvé qui sera importé.
RECnn_LST_NUM_CDE | Liste des numéros de commande d'achat rattaché à l'OF.
RECnn_NODATE | Aucune date ne sera envoyée à Direct Planning.
RECnn_NUM_CDE | Numéro de la commande d'achat. Retourne le dernier numéro de commande d'achat trouvé qui sera importé.
RECnn_QTE_CDE | Quantité commandée
RECnn_QTE_RECUE | Somme des quantités reçues pour cette commande.
RECnn_RECEPTIONNEE | La commande d'achat a-t-elle été réceptionnée ? (0/1)
RECnn_SOLDEE | La commande d'achat a été réceptionnée et soldée en réception. (0/1) C'est le dernier bon de réception trouvé qui sera importé.
RECnn_TROUVEE | Existe-t-il une commande d'achat correspondant à ces critères de recherche ? (0/1)

La recherche dans les actions - événements

Cette fonction recherche dans la table des actions - événements rattachés à la commande.

RECnn_FONCTION | ACTION_EVT
RECnn_PARAMETRE | REC_OBJET : On spécifie sur quel élément l'action a été saisie : CDE_ENTETE (entête de commande client – cde1) CDE_LIGNE (ligne de commande client – cde2) DEVIS_FLLES (Devis feuille – fle_2) DEVIS_ENTITE (Entité du devis – fle_imp) REC_ETAPE: On spécifie sur quelle étape on recherche (optionnel mais sera sûrement saisi) REC_ACTION : On spécifie sur quelle action on recherche (optionnel mais sera sûrement saisi) REC_ETAT : A,E,T,X Exemple : A, E : recherche des actions à réaliser SEL_ACE: Critère de sélection sur la table action_evt (autres que sur étape et action). (optionnel) Exemple : SEL_ACE: ace_gere_par ='XXX' REC_ORDER : Ordre de recherche des différents enregistrements de la table action_evt. Il peut en effet exister plusieurs enregistrements portant sur un même couple étape / action. On retiendra toujours le premier enregistrement trouvé dans cet ordre de lecture. Exemples ace_ligne asc (par défaut) ace_ligne desc ace_date_cloture desc, ace_ligne asc

Codes champs résultat

RECnn_TROUVE | Existe-t-il une action / un événement correspondant à ces critères de recherche ? (0/1)
RECnn_ETAT_COD | Renvoie l'état A A faire E En cours T Terminé X Abandonné
RECnn_ETAT_LIB | Renvoie le libellé de l'état A faire En cours Terminé Abandonné
RECnn_SOLDEE | 1 si état Terminé ou Abandonné 0 si état A faire ou En cours
RECnn_ETAPE_COD | Code de l'étape
RECnn_ETAPE_LIB | Libellé long de l'étape
RECnn_ACTION_COD | Code de l'action
RECnn_ACTION_LIB | Libellé long de l'action (événement)
RECnn_DATE_PREVUE | Date prévue
RECnn_DATE_ECHEANCE | Date d'échéance
RECnn_DATE_CLOTURE | Date de clôture
RECnn_NODATE | Aucune date ne sera envoyée à Direct Planning.
RECnn_USER_CRE_COD | Code utilisateur à l'origine de la création de l'événement
RECnn_USER_CRE_LIB | Libellé long de l'utilisateur à l'origine de la création de l'événement
RECnn_USER_GER_COD | Code utilisateur qui gère l'événement
RECnn_USER_GER_LIB | Libellé long de l'utilisateur qui gère l'événement
RECnn_USER_CLO_COD | Code utilisateur qui a clôturé l'événement
RECnn_USER_CLO_LIB | Libellé long de l'utilisateur qui a clôturé l'événement
RECnn_OBJET | Objet de l'événement
RECnn_INT_EXT | I / E
RECnn_PRIORITE | Niveau de priorité de l'événement
RECnn_QUALIF_COD | Code qualificatif de l'état
RECnn_QUALIF_LIB | Libellé long du qualificatif de l'état
RECnn_FICHIER | Pièce jointe à l'événement
RECnn_CONTACT_NOM | Le contact chez le client
RECnn_CONTACT_TEL | Le numéro de téléphone du contact chez le client
RECnn_CONTACT_EMAIL | L'adresse e-mail du contact chez le client

Exemple

• Une recherche 02 sur étape BAT et action RVC et état = Terminé : si trouvé alors marqueur dans l'état BAT OK.

• Une recherche 01 sur étape BAT : si enregistrement trouvé alors marqueur dans l'état Attente BAT

• sinon aucune action trouvée alors marqueur dans l'état Pas de BAT

On veut la dernière action à réaliser : prenant les actions dans l'ordre écran, on veut retenir la première qui soit dans l'état A faire ou En cours :

• Recherche 03 sur étape BAT avec état in (‘A', ‘E' ) : on retient la première et on renverra le libellé de l'action, le user affecté et l'échéance.

Configuration des marqueurs

MRQnn_ACTIF

Activation du transfert du marqueur (O/N, N par défaut)

Ce paramètre permet de ne pas transférer les marqueurs dans Direct Planning, même si la configuration listée ci-dessous est présente.

MRQnn_TACHE_CIBLE

Définition des tâches cibles pour ce marqueur.

Par ce paramétrage, on définit sur quelles tâches sera positionné ce marqueur.

Il est possible de créer plusieurs lignes MRQnn_TACHE_CIBLE.

Chacune de ces lignes pourra définir un jeu de tâches cibles différentes.

TES:GRPSRC avec les paramètres suivants :

TES : Le type d'entité source concerné.

Valeurs spéciales :

#ALL : On applique ce marqueur sur tous les types d'entités.

GRPSRC : Code groupement source ou succession de codes groupement identifiant la tâche cible à affecter.

Pour définir sur quelles tâches on va positionner ce marqueur, on recherche les tâches ayant un code groupement donné (le code groupement est soit le code phase du devis, soit saisi sur la fiche formule).

Il est possible de lister plusieurs codes groupement sources séparés par des virgules.

L'interpréteur recherchera une tâche dotée du premier code groupement.

S'il en trouve une, il aura trouvé la tâche sur laquelle il va positionner le marqueur.

S'il n'en trouve pas, il tentera une recherche sur le second code groupement listé, et ainsi de suite.

Valeurs spéciales :

#FIRST : La première tâche de l'entité.

#LAST: La dernière tâche de l'entité.

#ALL : sur toutes les tâches de l'entité.

Exemples

CCO, #FIRST : positionne le marqueur sur la tâche de contre-collage en priorité, ou sur la première tâche de la gamme si elle n'existe pas.

Valeur par défaut :

Si aucune règle n'est configurée, la règle par défaut qui s'applique est : #ALL:#FIRST

C'est à dire que le marqueur est positionné sur la première tâche de la gamme.

MRQnn_ETAT_5

MRQnn_ETAT_4

MRQnb_ETAT_3

MRQnb_ETAT_2

MRQnn_ETAT_1

MRQnn_ETAT_0

Activation d'un état pour le marqueur nn (0/1).

On positionne ici un code calcul qui doit renvoyer un booléen (0/1).

On évalue les règles dans l'ordre où elles sont saisies.

La premier ETAT qui a son code calcul à True (1) est considéré comme l'état actif.

Si l'état 0 est vrai alors le marqueur est désactivé.

Dans l'évaluation, les codes calcul (renvoyant un booléen) pourront être associés en expression AND ou OR.

Les codes calcul renvoyant un nombre pourront être associés aux opérateurs arithmétiques (+, -, * et /) mais aussi aux opérateurs de comparaison (>, <, <=, >=, = et ! (différent)).

Les parenthèses qui entourent une expression sont prioritaires.

La valeur spéciale #TRUE renvoie vrai.

Exemple suite à la configuration d'une recherche dans les achats :

• L'état 3 est positionné en priorité si la commande d'achat a été trouvée et réceptionnée.

• L'état 2 est positionné si l'état 3 n'a pas été positionné et si la commande d'achat existe.

• L'état 1 est positionné systématiquement si l'état 2 n'a pas été positionné.

MRQ01_ETAT_3 REC01_RECEPTIONNEE

MRQ01_ETAT_2 REC01_TROUVEE

MRQ01_ETAT_1 #TRUE

Exemple 2 : Si je veux conditionner l'état du marqueur 4 sur le fait que j'ai réceptionné le carton (recherche 01) ET les affiches (recherche 02) :

MRQ04_ETAT_3 REC01_RECEPTIONNEE AND REC02_RECEPTIONNEE

MRQ04_ETAT_2 REC01_TROUVEE AND REC02_RECEPTIONNEE

MRQ04_ETAT_1 #TRUE

MRQnn_DATE_REC_PREV

MRQnn_HHMM_REC_PREV

MRQnn_DATE_REC_REAL

MRQnn_HHMM_REC_REAL

Code calcul des dates de réception prévue et réalisée.

A ne configurer que pour des marqueurs de type Multi-état avec attente de réception d'élément.

Peut recevoir une date (jj/mm/yyyy) ou une datetime (jj/mm/yyyy hh:mm).

Comme dans la plupart des cas, la date extraite de Volume ne contiendra pas d'heure, vous pouvez utiliser les paramètres : MRQ01_HHMM_REC_PREV et MRQ01_HHMM_REC_REAL pour spécifier une heure associée aux dates de réception prévue et réalisée.

Pour ne pas envoyer de date de réception prévue, il faut mettre le code champs résultat REC01_NODATE comme paramètre pour la note MRQ01_DATE_REC_PREV.

Exemple

MRQ01_DATE_REC_PREV REC01_DATE_ACCUSEE

MRQ01_HHMM_REC_PREV 09:00

MRQ01_DATE_REC_REAL REC01_DATE_RECEPTION

MRQ01_HHMM_REC_REAL 09:00

Exemple complet sur une recherche dans les achats

J'ai dans Direct Planning un marqueur 1 qui a 3 états :

• Etat 1 : Carton à commander

• Etat 2 : Commande carton en attente de réception

• Etat 3 : Carton réceptionné

J'ai également configuré 4 zones configurables sur ce marqueur :

• Le numéro de commande d'achat

• La date de la commande

• La quantité commandée

• La quantité reçue

J'ai configuré :

REC01_FONCTION ACHAT

REC01_PARAMETRE SEL_CDF1: ef_tyc='MAT'

REC01_PARAMETRE SEL_CDF2: lf_fam='PAP'

REC01_PARAMETRE REC_VENTILATION: 1

MRQ01_ACTIF O

MRQ01_TACHE_CIBLE #ALL:#FIRST

MRQ01_ETAT_3 REC01_RECEPTIONNEE

MRQ01_ETAT_2 REC01_TROUVEE

MRQ01_ETAT_1 #TRUE

MRQ01_ZC1 REC01_NUM_CDE

MRQ01_ZC2 REC01_DATE_CDE

MRQ01_ZC3 REC01_QTE_CDE

MRQ01_ZC4 REC01_QTE_RECUE

MRQ01_DATE_REC_PREV REC01_DATE_ACCUSEE

MRQ01_HHMM_REC_PREV 09:00

MRQ01_DATE_REC_REAL REC01_DATE_RECEPTION

MRQ01_HHMM_REC_REAL 09:00

Modifications sur G_directplanning.42r

Modification de la base de données

Création de la table de stockage des marqueurs sur les tâches dpl_trf_tache_mrq

C'est une table fille de dpl_trf_tache créée de manière à éviter l'ajout de 150 colonnes dans cette table.

Clé unique : num_transfert, num_tache, num_marqueur

Modification dans les traitements

Visualiser les marqueurs dans l'historique

Modification dans Direct Planning

A priori, aucune modification n'est nécessaire, Direct Planning est prêt à recevoir des directives de création/modification sur les marqueurs.

Vérifier, dans Direct Planning, en recevant un marqueur avec une portée, que l'ensemble des tâches associées à cette portée est bien modifié.

Exemple de paramétrage

Paramétrage de la saisie des commandes fournisseurs

# Création d'une demande à DP

DIRECT_PLANNING_TRF O

DIRECT_PLANNING_CFG DP4

DIRECT_PLANNING_SEL and ef_tyc in ("CAR", "PDF")

Paramétrage de la saisie des bons de réception et de retour

# Création d'une demande à DP

DIRECT_PLANNING_TRF O

DIRECT_PLANNING_CFG DP4

DIRECT_PLANNING_SEL and ef_tyc in ("CAR", "PDF")

Paramétrage de l'interface Direct Planning

CFG_TRANSFERT_FIC 01

V_FIC_SRC_DIR d:\tmp\planningimport

CFG_TYPE_ENV 01

CFG_DPL_VERSION 20

CFG_DEV_RESERVE_CFG DPR

#_____ methode de comparaison par tâche

CFG_COMPARAISON 02

#_________Pas de regroupement des entités

CFG_REG_ENTDEV 01

LST_REG_TEN xxx *

CFG_REG_OPE 02

CFG_LIENS_INT 01

CFG_LIENS_EXT 03

CFG_QTE_LANCEE 01

CZO_DATE_DEB 01

CZO_DUREE 01

V_POURC_MAJO_DUREE 0

CZO_AVANCEMENT 01

CZO_DDEB_PTOT 01

CZO_DFIN_PTARD 01

V_HHMM_DFIN_PTARD 17:00

V_HDED_DFIN_PTARD 000

V_POURC_DUREE_DPLAN -1

# Entité 1 : le commercial

ENT1_COD STD_REP_COD

ENT1_LIB STD_REP_LIB

ENT1_ZL1 STD_REP_TEL

ENT1_COULEUR STD_RANDOM

# Entité 2 : le client

ENT2_COD STD_CLI_COD

ENT2_LIB STD_CLI_LIB

ENT2_ZL1 Z_cl_liv_telph1

ENT2_COULEUR STD_RANDOM

ENT2_LIEE_ENT1 O

# Entité 3 : l'OF

ENT3_COD STD_OF_COD

ENT3_LIB STD_CDE2_LIB

ENT3_ZL1 STD_CDE2_PROD_COD

ENT3_COULEUR DEV_ENT_COLOR

ENT3_LIEE_ENT1 O

ENT3_LIEE_ENT2 O

### CONFIGURATION DES TACHES ###

TAC_NOM STD_CDE2_COD;-;STD_CLI_LIB

TAC_ZL1 Date livraison : ;Z_lc_delrep

TAC_ZL2 QTE DOSSIER : ;Z_l2_qtedev

# Gestion des recherches

REC01_FONCTION ACHAT

REC01_PARAMETRE SEL_CDF1:ef_tyc="CAR"

REC01_PARAMETRE REC_VENTILATION:0

REC02_FONCTION ACHAT

REC02_PARAMETRE SEL_CDF1:ef_tyc="PDF"

REC02_PARAMETRE REC_VENTILATION:0

# Gestion des marqueurs

# Marqueur 1

MRQ01_ACTIF O

MRQ01_TACHE_CIBLE #ALL:#FIRST

MRQ01_ETAT_3 REC01_RECEPTIONNEE AND

MRQ01_ETAT_3 REC02_RECEPTIONNEE AND (

MRQ01_ETAT_3 REC01_QTE_RECUE > (REC01_QTE_CDE * 0.9))

MRQ01_ETAT_2 REC01_QTE_RECUE > (REC01_QTE_CDE * 0.7)

MRQ01_ETAT_1 #TRUE

MRQ01_ZC1 REC01_NUM_CDE

MRQ01_ZC2 REC01_DATE_CDE

MRQ01_ZC3 REC01_QTE_CDE

MRQ01_ZC4 REC01_QTE_RECUE

MRQ01_DATE_REC_PREV REC01_DATE_SOUHAITEE

MRQ01_DATE_REC_REAL REC01_DATE_RECEPTION

# Marqueur 2

MRQ02_ACTIF O

MRQ02_TACHE_CIBLE #ALL:#FIRST

MRQ02_ETAT_3 REC02_RECEPTIONNEE AND

MRQ02_ETAT_3 REC01_RECEPTIONNEE

MRQ02_ETAT_2 REC02_QTE_CDE > 0

MRQ02_ETAT_1 #TRUE

MRQ02_ZC1 REC02_NUM_CDE

MRQ02_ZC2 REC02_DATE_CDE

MRQ02_DATE_REC_PREV REC02_DATE_SOUHAITEE

MRQ02_DATE_REC_REAL REC02_DATE_RECEPTION


#CF DRE Devis reliure

Valeur alpha 1

Les formats suivant sont en millimètres :

Caractères 1 à 4 | Largeur mini pour un ouvrage à la française
Caractères 5 à 8 | Largeur maxi pour un ouvrage à la française
Caractères 9 à 12 | Hauteur mini pour un ouvrage à la française
Caractères 13 à 16 | Hauteur maxi pour un ouvrage à la française
Caractères 17 à 20 | Largeur mini pour un ouvrage à l'italienne
Caractères 21 à 24 | Largeur maxi pour un ouvrage à l'italienne
Caractères 25 à 28 | Hauteur mini pour un ouvrage à l'italienne
Caractères 29 à 32 | Hauteur maxi pour un ouvrage à l'italienne
Caractère 33 | F Le client possède un FAX redir. Après validation de la fiche de fabrication, on propose la génération et l'envoi d'une commande fournisseur par fax.

Valeur alpha 2

Caractère 1

si O Ouverture automatique de la fenêtre 1PO sur le premier écran du devis

Sinon La fenêtre n'est pas ouverte automatiquement

Caractère 2

si O Ouverture automatique de la fenêtre CSC sur le premier écran du devis

sinon La fenêtre n'est pas ouverte automatiquement

Caractère 3

si O Accès à la zone type de mise en caisse et nombre de cales sur le quatrième écran du devis

sinon On ne peut pas accéder aux zones type de mise en caisse et nombre de cales

Caractère 4

si O Nouveau mode de gestion des hors-texte

HT 2 pages nombre saisie sur la zone carton 2 pages du deuxième écran

HT 4 pages nombre saisie sur la zone carton 4 pages du deuxième écran

HT 6 pages nombre saisie sur la zone carton 6 pages du deuxième écran

Sinon on conserve l'ancien mode de gestion des hors-texte.

Caractère 5

si O Sur le deuxième écran le libellé Gardes blanches devient Gardes feuilles et le libellé Gardes couleurs devient Gardes en rouleaux

sinon on ne change pas le libellé

Caractère 6

si O Sur le quatrième écran, la touche F19 calcule automatiquement le montant du transport Montant = qté devisée * prix saisie dans la zone numérique 1 du paramètre #CF DRE. De plus le montant est recalculé quand on change la quantité de la tranche ou quand on indique O dans la zone transport.

Sinon La touche F19 n'est pas active et il n'y a pas de calcul automatique du transport

Caractère 7

si O Le code carton n'est plus calculé automatiquement
sinon Le code carton est calculé automatiquement (cf aide devis reliure)

Caractère 8

si O Nouveau mode de gestion de la dorure (possibilité de saisir la décomposition de la dorure, F16 sur le quatrième écran du devis)

Caractère 9

si O Active la touche F20 sur le premier écran du devis. Cette touche permet de transformer un client temporaire en client normal. Si F20, le code du client est attribué automatiquement (suivant le paramétrage défini sur #CF ATL) et la fiche temporaire est effacée.

Caractères 10 à 12

Type de la commande qui peut être générée avec la fiche de fabrication (si rien FB1)

Caractère 13

si O Pour les gardes en onglet on ajoute 16 mm à la largeur. Les trois premiers caractères de la valeur alpha 2 sur le paramètre TGB et TGC permet d'indiquer le type de garde (ONG onglet PLA à plat)

si ONG : Garde en onglet +16mm

Caractère 14

si O Quand on change le type garde couleur TGC, recherche automatique du code matière de la feuille. Un complément de requête peut être défini dans la zone alpha 3 et 4 du paramètre TGC.(la recherche s'effectuera parmi les matières). Ensuite on prends la feuille pour laquelle on à le minimum de chute. La recherche s'effectue aussi si le deviseur change le format du bloc.

Caractère 15

si O Pour les gardes couleurs, respect du sens travers pour calculer le nombre de poses.

Caractère 16

si O Autre mode de calcul pour l'encollage. Normalement largeur encol = épaisseur bloc + 30 mm, longueur encol = hauteur bloc + 20 mm. Si l'option 16 est active, largeur encol = épaisseur bloc + 40 mm, longueur encol = hauteur bloc - 20 mm

Caractère 17

si O Optimisation plus fine pour la découpe dans les matières de recouvrement en bobine. On prend en compte la possibilité d'un ré-enroulement. Sur l'écran il y deux zones pour le nombre de poses :

le nombre de poses sens travers

le nombre de poses sens longueur

L'opération 1152 possède une dépendance alpha pour la présence ou l'absence du ré-enroulement (dépendance alpha 2 : O/N)

Caractère 18

Sur le deuxième écran du devis, dans le cas où on ne traite pas un bloc, on recopie la valeur du nombre de gardes à plier sauf si on a choisi l'option 18 ;

dans ce cas, on recopie sauf si le type de couture CSC (premier écran) commence par S, on met à zéro le nombre de gardes à coller.

Pourquoi ? Car on considère que le collage sera inclus dans une autre opération. Ceci est très spécifique, c'est pourquoi on a mis une option.

Caractère 19

Cette option permet de faire apparaître une zone code formule de politesse sur le premier écran du devis.

Ce code permettra de paramétrer les entêtes et pieds de page de l'édition client.

Le type paramètre associé aux formules de politesse est FOP.

(Pour pouvoir saisir le texte associé à chaque formule de politesse, cf aide en ligne.)

Caractère 20

Nouvelle gestion du carton. Si le tonnage est inférieur à POIDS_CAR_CDE tonnes ou si le % de chute est > à CHUTE_CAR_CDE, le carton est découpé par le relieur, sinon il est acheté à un fournisseur carton.

Caractère 21

Gestion détaillée des conversions épaisseur grammage

Caractère 22

Permet d'activer l'écran de transposition.

Cette option permet de rendre actif l'écran de transposition.

L'écran peut être appelé par la touche F23. Cet écran apparaîtra de manière automatique après le dernier écran de la fiche de fabrication.

Caractère 23

Gestion des matières clients dans la fiche de fabrication.

Caractère 24

Calcul détaillé pour la consommation de colle. Si cette option est active, le calcul de consommation pour la colle est le suivant :

ENCOLLAGE DU DOS

Consommation au mètre carré sur le produit COLLE_DOS

Surface : épaisseur du bloc * hauteur du bloc

ENCOLLAGE DES PLATS

Consommation au mètre carré sur le produit COLLE_PLAT

Surface : (hauteur du bloc + 2 * épaisseur carton + 2 * 20 mm) * (2 * largeur bloc + largeur dos + 2 * 20 mm)

Caractère 25

Ouverture automatique des fenêtres type de garde.

Cette option permet de rendre actif la gestion possible des matières client. Ceci est valable pour les gardes et la matière de recouvrement. Pour les matières de recouvrement :

Avant il était possible de mettre C Client ou N Nous, désormais il sera possible de mettre R Matière client à réserver.

Pour les gardes on pouvait mettre O ou N (à fournir oui ou non), désormais on pourra mettre R (on ne fournit pas les gardes mais il faudra gérer celle du client : Mouvement réserve)

Caractère 26

Autorise la création de devis en recopie à partir d'une fiche de fabrication.

Caractère 27

Affiche le libellé du produit saisi sur le premier écran du devis (ou fiche).

Caractère 28

Propose la réactualisation automatique des quantités des lignes de transport (par une règle de trois) quand on change la quantité du devis.

Caractère 29

Permet lors de l'ouverture de la commande, dans le cas d'une FB1, de générer une deuxième ligne de commande.

Caractère 30

Permet d'ajouter en plus deux fois l'épaisseur du carton pour calculer la largeur du format de recouvrement.

Caractère 31

Permet de gérer un supplément pour calculer la longueur du tranchefile.

Si dos rond, on applique le coefficient !

Caractère 32

Après chaque F6. Demande si le devis doit être recalculé.

Caractère 33

si O Accès à la zone type de reliure sur le deuxième écran du devis.

Caractère 34

si O Accès à la zone chaîne d'emboîtage sur le quatrième écran du devis + sur l'édition interne du devis.

Caractère 35

si O Mise en place des opérations pour la réalisation d'agenda.

Caractère 36

si O Accès en modification à la zone code dos sur le troisième écran du devis.

Caractère 37

si O Pas d'ouverture de la fenêtre détail découpe en mode nouvelle version du carton.

Caractère 38

si O Les prix proposés et négociés sont égaux au total du devis s'ils ne sont pas renseignés.

Caractère 39

si O Prise en compte du nombre de pages carton sur le 2ème écran.

Caractère 40

si O Recalcul des volumes par caisse et par paquet si les codes d'emballage modifiés sont paramétrés.

Lorsque l'option 20 est mise en œuvre, il est obligatoire de définir des variables de paramétrage suivantes :

PLAGE_FILIERE borne1 borne2 valeur1

borne1 du caractère 15 à 19

borne2 du caractère 20 à 24

valeur1 du caractère 25 à 29

(Possibilité de mettre plusieurs lignes)

Les variables PLAGE_FILIERE vont permettre de définir des plages de filières sur lesquelles les chutes minimum à la coupe sont différentes.

Borne1 : Borne inférieure pour la filière (inclus dans la plage)

Borne2 : Borne supérieure pour la filière (exclus de la plage)

Valeur1 : Valeur de la chute minimum à la coupe

RECH_DOS lar_mini lar_maxi code_dos

lar_mini caractère 15 à 19 (inclus dans la plage)

lar_maxi caractère 20 à 24 (exclus de la plage)

code_dos caractère 25 à 39

(Possibilité de mettre plusieurs lignes)

Les lignes de ce type vont permettre de déterminer le code carte dos en fonction de la largeur du dos (ceci est utilisé dans le cas où le relieur découpe lui-même le carton). La définition de plage de largeur permettra de choisir le code associé.

FILIERE_FCAR filière ajust1 ajust2

Filière caractère 15 à 19 (inclus dans la plage supérieure)

ajust1_fcar caractère 20 à 24

ajust2_fcar caractère 25 à 29

1 seule ligne

Permet de définir un ajustement pour le calcul du format carton.

Si la filière du carton est inférieure ou égale à filière, on ajoute l'ajustement 1 à la hauteur du carton

sinon on ajoute l'ajustement 2 à la hauteur du carton.

COEF_SECU_CAR coef

1 seule ligne

Permet de définir une marge de sécurité pour la découpe du carton.

Ce coefficient s'appliquera sur l'épaisseur du bloc.

COEF_TRANCHEFILE coef

1 seule ligne

Permet de gérer un supplément pour le calcul de la longueur du tranchefile.

Si dos rond, on applique le coefficient !

EPA_MOY_RECOUV

1 seule ligne

Permet de définir la valeur moyenne de l'épaisseur de recouvrement utilisée dans la calcul du format du carton.

POIDS_CAR_CDE

1 seule ligne

Permet de définir le poids carton en KG au delà duquel (>=) il est préférable de commander le carton.

CHUTE_CAR_CDE

1 seule ligne

Permet de définir le pourcentage de chute au delà duquel (>=) il est préférable de commander le carton prédécoupé.

COMP_REQ_CAR

(possibilité de mettre plusieurs lignes)

Permet de définir un complément de requête pour la recherche du meilleur format carton dans les stocks (paramètre très particulier, contacter Volume pour définir la valeur à mettre)

Lorsque l'option 21 est mise en œuvre, il est obligatoire de définir des variables de paramétrage suivantes :

CONV_EPA mini maxi valeur

Possibilité de mettre plusieurs lignes.

Chaque ligne permettra de définir le grammage pour une plage d'épaisseur.

Caractères 15 à 19 : valeur mini de la plage

Caractères 20 à 24 : valeur maxi de la plage

Caractères 25 à 29 : grammage

Notes

O

Identificateur type de ligne opération

2 à 16 Code générique de l'opération

(Les zones suivantes ne sont pas gérées actuellement)

17 à 21 Numéro de phase

22 à 24 Code section

25 à 27 Code opération

28 à 30 Code sous-opération

31 à 36 Code machine

37 à 39 Code difficulté

40 à 49 Zone paramétrée


#CF DT0 Paramétrage gammes et nomenclatures

Ce paramétrage est utilisé par dt0.

Valeurs numériques

1 |
2 | Nombre de décalages maximum

Valeur alpha 1

Colonnes à éditer. Voir dt0.

Valeur alpha 3

Caractères 1 à 3 | Type de notes de gammes par défaut où seront recopiées les notes de l'opération (si option -Oob)
Caractères 4 et 5 | Type de recherche article sur le composé : A3[4] = 0 et A3[5] = [espace] : ancienne recherche spécifique à ce module
Caractère 4 | 1 Recherche avec référence client 2 Recherche sur les données techniques 3 Recherche spécifique papier
Caractère 5 | [espace] Sans signification N Sans fenêtre de sélection multicritères.
Caractères 6 et 7 | Type de recherche article sur les composants :
Caractère 6 | 1 Recherche avec référence client 2 Recherche sur les données techniques 3 Recherche spécifique papier
Caractère 7 | [espace] Sans signification N Sans fenêtre de sélection multicritères.


#CF EDS Edition du devis / de la fiche de fabrication

#CF EDS Edition simplifiée du devis
#CF EDD Edition détaillée du devis
#CF EFS Edition simplifiée de la fiche de fabrication
#CF EFD Edition détaillée de la fiche de fabrication

Valeur numérique 1

Longueur du libellé de la formule

Valeur alpha 1

Dans les valeurs qui suivent, mettre : | N si pas de tableau O si tableau S si tableau et saut de page après
Caractère 1 | Présence du tableau détail matière
Caractère 2 | Présence du tableau opération
Caractère 3 | Présence du tableau récapitulatif devis
Caractère 4 | Présence tableau des phases
Caractère 5 | Présence du tableau matières/opérations par phase
Caractère 6 | Tableau regroupement des phases par entité
Caractère 7 | Tableau regroupement des phases par devis
Caractère 8 | Tableau des livraisons
Caractère 9 | Tableau sous-traitance
Caractère 10 | Edition des lignes à zéro
Caractère 11 | Edition des lignes détail sur le tableau matière/opération
Caractère 12 | Edition des lignes détail sur le tableau matière
Caractère 13 | Edition des lignes détail sur le tableau opération
Caractère 14 | Edition du détail code ECMA
Caractère 15 | Suppression des lignes total sur tableau matières/opérations O Suppression des totaux N Non suppression
Caractère 16 | Edition des notes (paramétrage du/des types de notes dans les notes)
Caractère 17 | Edition du tableau de marge N Pas d'édition O Tableau en fin de devis S Tableau en fin de devis et saut après E Tableau par entité
Caractère 18 | Edition des entités (O,N ou S) Attention, si on n'édite pas les entités, les tableaux de regroupement ne sont pas éditables. O Edition des entités N Pas d'édition des entités S Edition sans saut de page avant chaque entité
Caractère 19 | Edition de l'adresse du client
Caractère 20 | Edition du format de la première entité au niveau du devis
Caractère 21 | Edition d'un mini récapitulatif (prix) après l'édition des notes techniques. Le récapitulatif est paramétré dans les notes commençant par MINIRECAP. En l'absence de ces notes, le récapitulatif est standard (ancien récapitulatif).
Caractère 22 | Edition d'un récapitulatif papier O Edition d'un récapitulatif papier N Pas d'édition d'un récapitulatif papier C Edition d'un récapitulatif papier simplifié (plus condensé)
Caractère 23 | Edition du tableau matière, matière/opération, opération, sous-traitance en prix hors marge
Caractère 24 | Edition du détail matière
Caractère 25 | Dans l'édition du tableau des marges, permet des sous-totalisations
Caractère 26 | Edition de la désignation O ou [espace] Edition standard N Pas d'édition
Caractère 27 | Edition de quantité du devis O ou [espace Edition standard N Pas d'édition
Caractère 28 | Edition de la quantité de l'entité O ou [espace] Edition standard 2 Edition en gras et large N Pas d'édition
Caractère 23 | Edition du code FEFCO ou ECMA O ou [espace] Edition standard N Pas d'édition
Caractère 30 | Edition ligne Dimensions intérieures O ou [espace] Edition standard 2 Edition L et l seuls
Caractère 31 | Edition lignes sérigraphie N ou [espace] Pas d'édition O Edition
Caractère 32 | Edition ligne - Référence - Type – Code O ou [espace] Edition N Pas d'édition
Caractère 33 | Edition du tableau des lignes complémentaires N ou [espace] Pas d'édition 1 Edition entête 2 Edition des entités seules O Edition complète Voir l'aide en ligne sur les LCO pour n'éditer que certaines lignes !
Caractère 34 | Faut-il éditer les lignes à zéro du tableau des lignes complémentaires ? Ne concerne pas les devis de référence O Edition N ou [espace] Pas d'édition
Caractère 35 | Edition du tableau des marges proposées 1 Edition du tableau 10-20-30-40-50 2 Edition du tableau 10-30-50 N ou [espace] Pas d'édition
Caractère 36 | Ignorer les colonnes quantités au niveau des formats (quantité Découpe - Impression - Feuille) N ou [espace] On édite O On ignore
Caractère 37 | Type d'édition de la ligne papier [espace] Standard Imprimerie S Suppression de cette ligne sur devis dco seulement 1 Edition du code et libellé uniquement du support
Caractère 38 | Edition des dimensions spécifiques du code FEFCO-SAC N ou [espace] Pas d'édition O Édition
Caractère 39 | Edition du développé unitaire/surface nette/brute O ou [espace] Edition N Pas d'édition
Caractère 40 | Edition avec suppression de saut de ligne N ou [espace] Pas de suppression O Suppression
Caractère 41 | Edition du tableau récapitulatif spécifique. Le paramétrage de ce tableau est sous #CFRCP N ou [espace] Pas tableau spécifique O Tableau spécifique
Caractère 42 | Edition du tableau des marges pour chaque entité O ou [espace] On édite le tableau des marges de chaque entité ainsi que le tableau global. N On édite seulement le tableau global
Caractère 43 | Edition des lignes de notes blanches O ou [espace] Edition des lignes blanches N Pas d'édition des lignes blanches
Caractère 44 | Edition de la ligne type pré-presse, typons, ozalids, BAT et zone paramétrée (entité) O ou [espace] Edition de la ligne N Pas d'édition de la ligne
Caractère 45 | Edition de la ligne format (entité) O ou [espace Edition de la ligne N Pas d'édition de la ligne
Caractère 46 | Edition entête avant chaque entité O ou [espace] Edition entête N Pas d'édition d'entête (sauf la première entité)
Caractère 47 | Edition du numéro de devis au début de chaque page O ou [espace] Edition N Pas d'édition
Caractère 48 | Edition contractée du tableau des livraisons N ou [espace Edition normale N Edition contractée
Caractère 49 | Edition spécifique du prix de revient, de la marge, du pourcentage du prix de revient par rapport au prix de vente, du prix de vente et de l' unité de vente après le récapitulatif. N ou [espace] Pas d'édition O Edition de la ligne Edition sur deux lignes
Caractère 50 | Spécifique Edition des notes du sous-devis 0

Valeur alpha 2

Caractères 1 à 20 | Paramétrage des colonnes du tableau matière/opération ATTENTION si la ligne est trop longue, cela provoque un plantage du programme A Code B Machine C Quantité D Quantité totale E Cadence/temps F Temps total G Coût unitaire H Prix de Vente Unitaire I Total J Total Fixe K Total Variable L Prix du 1000 de tours M Code formule N Libellé formule O 1000 suivant (par rapport à la quantité devisée saisie au niveau du devis) P Libellé de la matière ou de l'opération Q Numéro de phase R Gâche fixe S Gâche variable (%) T Quantité de gâche variable U Unité de la matière dans le tableau des matières / opération W Libellé valeur numérique 1 X Valeur numérique 1 Y Libellé valeur numérique 2 Z Valeur numérique 2 a Libellé machine b Frais détail opération
Caractères 21 à 40 | Paramétrage des colonnes du tableau matière ATTENTION si la ligne est trop longue, cela provoque un plantage du programme A Code matière B Quantité C Gâche fixe D Gâche variable E Total quantité F Prix de revient G Marge H Prix de vente I Total J Total fixe K Total variable L Code formule M Libellé formule N Libellé de la matière O Numéro de phase Q Unité de la matière dans le tableau des matières
Caractères 41 à 60 | Paramétrage des colonnes du tableau opération ATTENTION si la ligne est trop longue, cela provoque un plantage du programme A Opération B Machine C Code difficulté D Quantité E Gâche fixe F Gâche variable G Total quantité H Cadence/temps I Total temps J Prix de revient K Marge L Prix de vente M Total N Fixe O Variable P Code formule Q Libellé formule R Libellé l'opération S Numéro de phase T Longueur mini bande planning (voir valeur 1 du paramètre PHA) U Longueur maxi bande planning (voir valeur 2 du paramètre PHA) V Cadence/temps atelier (voir PHA) W Libellé valeur numérique 1 X Valeur numérique 1 Y Libellé valeur numérique 2 Z Valeur numérique 2 a Libellé machine b Frais détail opération c Unité de l'opération dans le tableau des opérations

Valeur alpha 3

Caractère 1 | Impression de la marge sur code produit
Caractère 2 | La marge globale du récapitulatif. est prise dans 1 l2_px_ma [Valeur par défaut] 2 l2_m_ma
Caractère 3 | Edition du prix contrôle (O/N)
Caractères 4 à 6 | Code de la devise de la contrepartie
Caractère 7 | Unité du prix du papier K ou [espace] Prix au kilo T Prix à la Tonne

Notes

R

Notes pour le regroupement de phases

2,4 Code de regroupement

5,24 Libellé du regroupement de phase

25,48 Par groupe de 3 caractères, les phases à regrouper (8 maximum).

N

Notes pour la définition du type de note à éditer

2,4 Type de note à éditer

Si aucun type n'est précisé, toutes les notes seront éditées.

Exemples :

NFAB Edition des notes de type FAB

N#li Edition des notes de type #li (Notes de livraison figées)

MINIRECAP

Ces notes permettent de remplacer le mini-récapitulatif par un récapitulatif paramétrable.

alpha1[21] doit être positionné à O.

Syntaxe de ces notes :

MINIRECAP*libellé*champ où Libellé représente un texte libre et Champ un des champs suivants :

1 | l2_px_pv | Prix total du devis
2 | l2_m_ma | Marge supplémentaire
3 | l2_p_pv | Montant total port
4 | l2_z1 | Prix contrôle
5 | l2_remis | Prix remis
6 | pv_au | Prix calculé ramené à l'unité
7 | pv_port_au | Montant port ramené à l'unité
8 | pv_au_hors_transport | (6) - (7)
9 | pv_remis_hors_transport | (5) - (7)
10 | lib_qrp | Libellé long de l'unité de remise de prix
11 | l2_remis_devise | Prix remis en devise

MINIRECAP*changement_de_ligne provoque un saut de ligne.

MINIRECAP*texte libre permet d'insérer un texte libre.

Ce paramétrage ne fonctionne pas comme les visus :

Les libellés et les champs sont concaténés les uns à la suite des autres sur la même ligne jusqu'à la note changement_de_ligne.

Exemples de paramétrage

MINIRECAP*changement_de_ligne

MINIRECAP* R E C A P I T U L A T I F

MINIRECAP* D E V I S

MINIRECAP*changement_de_ligne

MINIRECAP*changement_de_ligne

MINIRECAP*TOTAL DEVIS : *l2_px_pv

MINIRECAP*changement_de_ligne

MINIRECAP*Port total : *l2_p_pv

MINIRECAP* soit : *pv_port_au

MINIRECAP* *lib_qrp

MINIRECAP*changement_de_ligne

MINIRECAP*Marge : *l2_m_ma

MINIRECAP* %

MINIRECAP*changement_de_ligne

MINIRECAP*changement_de_ligne

MINIRECAP*Prix calculé : *pv_au

MINIRECAP* *lib_qrp

MINIRECAP* Prix remis : *l2_remis

MINIRECAP* *lib_qrp

MINIRECAP*changement_de_ligne

MINIRECAP*Hors transport : *pv_au_hors_transport

MINIRECAP* *lib_qrp

MINIRECAP* Hors transport : *pv_remis_hors_transport

MINIRECAP* *lib_qrp

MINIRECAP*changement_de_ligne

MINIRECAP*changement_de_ligne

MINIRECAP*P.R. Usine : *l2_z1

Résultat obtenu :

R E C A P I T U L A T I F D E V I S

TOTAL DEVIS : 10 494.21

Port total : 800.00 soit : 80.00 Le cent

Marge : 20.00 %

Prix calculé : 1 049.42 Le cent Prix remis : 760.00 Le cent

Hors transport : 969.42 Le cent Hors transport : 680.00 Le cent

P.R. Usine : 6 094.90


#CF EDI Configuration générale EDI INVOICE

Valeur alpha 1

#CF EDI A1[1]

Mode d'alimentation du libellé de la commande (zone 28)

1 ec_texte (valeur par défaut)

2 lc_p3 si renseigné, ou ec_ref_liaison si renseigné ou ec_texte

#CF EDI A1[2]

Génération du fichier INVOICE pour tous les clients (O/N, N par défaut)

Si oui, le type de génération du fichier INVOICE, le nom de l'interface et le flag de mise à jour des factures sont paramétrés sur la note TSC_INV.

#CF EDI A1[3]

Mode d'alimentation de la zone référence de commande (zone 27)

C : On prend la référence sur la commande de contrat si valide, sinon on conserve la référence de la commande facturée.

[espace] : On prend la référence de la commande facturée.

#CF EDI A1[4]

Remplacer le numéro de BL par les 8 premiers caractères de la référence BL (O/N, N par défaut)

#CF EDI A1[5]

Transfert des factures sans BL

O On transfère toutes les factures sans BL

A On transfère toutes les factures sans BL excepté les Avoirs

F On transfère toutes les factures sans BL excepté les Facturations Directes (FAD)

N On ne transfère aucune facture sans BL [Valeur par défaut]

Le TSC IN0 (char3_1) est prioritaire sur ce paramètre.

#CF EDI A1[6,8]

Numéro de version d'INVOICE (001 à 003, 001 par défaut) - Voir option Oin dans facn

La version 002 ajoute la notion de facture/avoir et le N° d'agrément

La version 003 ajoute le code EDI du service à facturer, issu du TSC CIV.

#CF EDI A1[9,13]

Extension du fichier EDI généré

L'extension paramétrée sur facn A2(21,25) est prioritaire.

Exemple : txt ou dat

#CF EDI A1[14]

Lors de la construction du nom du fichier en sortie, clipper le code client avant de lui accoler le code adresse

Ceci afin d'éviter des espaces dans le nom du fichier, si le code client n'est pas complet (6 caractères. (O/N, N par défaut)

#CF EDI A1[15]

Dans le cas des avoirs (TYC = AVO)

O La zone référence (zone 27) sera remplie par la référence (ec_ref) de la commande de rattachement.
La ligne de BL sera initialisée par le numéro et la ligne du BL rattaché à la facture de la commande de rattachement.

N Fonctionnement actuel : la zone référence est renseigné par la référence de la commande en cours (par défaut).

#CF EDI A1[16]

Envoi des informations EDI suivantes (O/N, O par défaut)

- la date de facture ou d'avoir rattaché dans l'enregistrement FACLIG

- la référence d'appel de livraison dans l'enregistrement LIGBLV

Ces informations supplémentaires modifient la structure du fichier EDI INVOIC V2.

Valeur alpha 2

#CF EDI A2[1,3]

Code unité de quantité si figé pour toutes les versions de fichier à générer

Permet d'harmoniser les différentes versions. Pour rappel :

Dans le transfert EDI Invoice des factures, pour les enregistrements de type FACLIG (ligne de facture), une zone contient le code de l'unité de la quantité…

Pour les versions de fichier à générer 001 et 003, ce code est figé à PCE.

Pour la version de fichier à générer 002, ce code est pris sur l'unité du prix de vente de la facture.

Notes

FILTRE_EDI_EC_REF

21,60 Syntaxe que doit respecter la référence client de la commande (ec_ref) pour afficher le libellé de la commande (ec_texte)

Si ec_ref commence par PEUG, alors le contenu de la zone V/Cde de l'édition sera le libellé de la commande.

Exemple : PEUG

MSG_FAC_TELETRANS

SPECIFIQUE

Mention qui doit figurer sur la facture lorsque celle ci est télétransmise

Par défaut : "FACTURE TELETRANSMISE"

NTS_

Types de notes - Voir option Oin dans facn

Pour la version 002 du fichier EDI Invoice

5 Type de ligne de la note - Obligatoire

E Note d'entête facture

L Note de ligne facture

P Note de pied de facture

7,11 Clé de la note - Obligatoire

Note d'entête facture

CLI Client principal

CLIL Client livré

CLIF Client facturé

NOTFE Entête facture

Note de ligne facture

CDEE Entête commande

CDEL Ligne commande

BLVE Entête bon de livraison

BLVL Ligne bon de livraison

NOTFL Ligne facture

#SOC Note sur la société

13,15 Type de note (paramètre NTS) - Obligatoire

17,19 Nombre de lignes de la note à éditer (1 à 999) - Doit être supérieur à zéro. ALL pour toutes les lignes

21,22 Longueur de la note (1 à 60) - Doit être supérieur à zéro

Exemples

NTS_E NOTFE FAC ALL 60

NTS_E CLIF FAC ALL 60

NTS_L CDEE FAC ALL 60

NTS_L CDEL FAC ALL 60

NTS_L BLVL LIV ALL 60

TSC_INV

Caractéristiques de génération du fichier INVOICE

21 Type de génération du fichier INVOICE

O Oui - Dans KP_facn_rp, imprime la mention Facture télétransmise.

N Non

A Autre (Génération d'un fichier de type autre que INVOICE)
Dans ce cas, les caractères 23 à 52 contiennent le nom de l'interface.

T Autorisation de générer un fichier INVOICE en prenant toutes les factures (y compris celles sans BL, les FAD, AVO, ...)

22 On passe la facture comme étant éditée lors de la génération du message INVOICE (O/N, N par défaut).

23,52 Nom de l'interface autre que INVOICE. 3 possibilités : PCARD, INFACTO, et OB10.

TVA_

Notion de TVA - Obligatoire - 5 lignes maximum pour la même notion de TVA - Voir option Oin dans facn

Pour la version 002 du fichier EDI Invoice

5 Mode de TVA

N Taxable

O Export

S Suspension

I Intracommunautaire

E Exonéré

6,60 Note de TVA

Exemples

TVA_NTVA sur débits

TVA_IFacturation établie en exonération de taxes

TVA_ISuivant CGI ART 262 TER I

TVA_OFacturation établie en exonération de taxes

TVA_OSuivant CGI ART 262 I-1

TVA_SFacturation établie en suspension de taxes

TVA_SSuivant CGI ART 275 Attestation n°

TVA_EFacturation établie en exonération de taxes

TVA_ESuivant CGI ART 262 2-b


#CF EFE Configuration de désactivation d'envoi de document via fax/mail pour un type donné

La gestion de document via fax/mail doit d'abord être validée par l'option payante EFE, puis gérée au niveau des programmes par l'option Oxm.

Valeur alpha 1

#CF EFE A1[1] | Le fax/email est activé pour le type de document Devis (O/N, N par défaut)
#CF EFE A1[2] | Le fax/email est activé pour le type de document Commande client (O/N, N par défaut)
#CF EFE A1[3] | Le fax/email est activé pour le type de document Commande d'achat (O/N, N par défaut)
#CF EFE A1[4] | Le fax/email est activé pour le type de document Bon de livraison (O/N, N par défaut)
#CF EFE A1[5] | Le fax/email est activé pour le type de document VoluMailing (O/N, N par défaut)
#CF EFE A1[6] | Le fax/email est activé pour le type de document Demande d'achat (O/N, N par défaut)
#CF EFE A1[7] | Le fax/email est activé pour le type de document Ordre d'achat de transport (O/N, N par défaut)
#CF EFE A1[8] | Le fax/email est activé pour le type de document Standard (O/N, N par défaut)
#CF EFE A1[9] | Le fax/email est activé pour le type de document Facture (O/N, N par défaut)


#CF EFM Gestion des envois fax/email par AVM (FileRequest)

Ce paramètre de configuration est opérationnel à partir de la V. 4.0.203.2

Il est utilisé par le programme d'envoi de fax et de mails.

Valeurs numériques

1 | Non utilisée
2 | Non utilisée

Valeur alpha 1

#CF EFM A1[1] | Gestion du module FileRequest (O/N, N par défaut)
#CF EFM A1[2,11] | Préfixe du fichier compagnon (fichier contenant les différents tags) Sera associé à un compteur dont cpt_typ = a, la création de ce compteur est automatique . Attention : ce préfixe doit correspondre au préfixe défini dans les paramètres d'interface avec AVM ( filerequest.ini). En standard : H
#CF EFM A1[12] | Les fichiers PDF sont contenus dans un répertoire. Gère-t-on les sous-répertoires par type de document ? (O/N, N par défaut) Si oui, sous le répertoire défini dans les notes, il devra y avoir des sous-répertoires ACR, BLV, …
#CF EFM A1[13] | Gestion du texte du mail dans la table (O/N, N par défaut) Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[14] | Ajout du nom du document au choix de l'imprimante (O/N, N par défaut) Ce nom sera passé en argument au script d'édition lié au paramètre de l'imprimante sélectionnée Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[15] | Mise à jour de la table envoi_fax_email avec le nom du document édité (O/N, N par défaut) Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[16] | Lors de la création de l'enregistrement du mail, si aucune information n'a été trouvée sur le correspondant, on prendra l'émail et le nom de l'expéditeur sur l'utilisateur connecté (paramètre USE) Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[17,36] | Note indiquant sur le USE où se trouve l'adresse email du destinataire (ceci est volontairement paramétré, car certains clients utilisent déjà une note sur le USE) Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[37,42] | Type et code du paramètre général d'envoi du script de gestion de mail (paramètre de type WIN) dans le cas où aucun paramètre de script n'est renseigné sur le module de gestion des envois fax/email Voir la gestion d'envoi de mails via des scripts.
#CF EFM A1[43] | Lors de la mise à jour de la table envoi_fax_email (A1[15]), on vérifie l'existence de l'enregistrement (O/N, N par défaut)
#CF EFM A1[44] | Génération d'un fichier body unique en ajoutant le PID dans le nom du fichier transmis à AVM (O/N, N par défaut)
#CF EFM A1[45] |
#CF EFM A1[46] | Utilisation du code langue dans le corps du mail ((O/N, N par défaut) Permet de saisir un corps de mail en fonction du code langue du correspondant. A cette occasion, les tables corres et envoi_fax_email on un nouveau champ Code langue. Les corps de mail seront donc saisis en fonction du type de document et du code langue. Il sera possible d'indiquer que l'on ne veut travailler qu'en français.
#CF EFM A1[47] | Affichage de l'écran de sélection sur la visualisation des fax/mail (O/N, N par défaut)

Valeur alpha 2

#CF EFM A2[1]

Prise en compte des adresses d'envoi des documents dans la recherche des destinataires des Fax/Mails (O/N, O par défaut)

Lors d'un envoi d'un document par Fax/Mail à un client, la recherche des différents destinataires du message se fait parmi les correspondants du client, en tenant compte de l'adresse d'envoi du document.

L'objectif de ce développement est de permettre d'envoyer ces documents aux autres correspondants sans tenir compte des adresses d'envoi.

Notes

CLE_NOM_BODY_xxx

Construction du nom du fichier body pour le type de document xxx.

xxx peut-être ACR, BLV, …

Exemple pour un AR

AR_|ec_soc|_|ec_cli|_|cl_langue|.txt

NOM_FIC_BODY_DEFAUT

Nom du fichier body par défaut.

Les noms des fichiers body peuvent être construits en fonction de la société, commande, …

Si le fichier construit n'existe pas, on utilisera le fichier par défaut.

PARAM_VISU_DOC

16,18 Type de document (ACR, BLV,...) Par défaut : GEN - Paramètre de type WIN

21,26 Paramétrage pour la visualisation de la pièce jointe dans la visualisation des mails à envoyer

Voir la gestion d'envoi de mails via des scripts.

Exemples

PARAM_VISU_DOC WINPDF

PARAM_VISU_DOC_ACR WINPDF

PARAM_VISU_DOC_BLV WINPDF

PARAM_VISU_GED_

16,18 Type de document (ACR, BLV,...) Par défaut : GEN - Paramètre de type WIN

Paramètre de type WIN

21,26 Paramétrage pour la visualisation de la pièce jointe par la GED

Exemple

PARAM_VISU_GED_ACR WINGE1

REP_DEPOSE_FR_AVM

21,60 Répertoire des fichiers compagnon, body et pièce jointe à chaque envoi de fax/email.

REP_FIC_BODY_AVM

21,60 Répertoire transmis à AVM pour la recherche des fichiers PDF

Si VoluPack est installé sur un serveur Linux, les répertoires utilisés dans les programmes du serveur ne peuvent plus être les mêmes que ceux transmis à AVM qui, lui, est installé sur un serveur Windows.

Ce paramétrage permet donc d distinguer le répertoire AVM du répertoire VoluPack.

REP_FIC_BODY_PDF

21,60 Permet d'enregistrer les fichiers body et PDF dans un autre répertoire ou sous répertoire que le fichier de dépose.

Utilisé à partir de la version 1.6.2.0 de FileRequest.

Permet de traiter le fichier compagnon, puis de le supprimer sans toucher au body ou PDF, ce qui posait problème lors de l'envoi d'un même mail à 2 destinataires.

REP_PRESENCE_BODY

21,60 Répertoire des fichiers body

REP_PRESENCE_PDF

21,60 Répertoire des fichiers pièces jointes de type PDF

Il peut y avoir un sous répertoire par type de document (voir A1[12] ci-dessus)

Voir la gestion d'envoi de mails via des scripts.

Principe

Le module standard de gestion des fax/email avec AVM construit les pièces jointes en format PDF, à partir de flux PCL de l'édition VoluEdit, transformé dans une étape intermédiaire en fichier .tiff, d'où une dégradation importante de la qualité du fichier PDF.

Le module FileRequest fonctionne différemment.

Il faut construire un fichier compagnon qui contient tous les tags (émetteur, pièce jointe, body, …) et le déposer dans un répertoire partagé en même temps que les fichiers body et pièces jointes.

Ce fichier compagnon est nommé avec un préfixe et un compteur (compteur a).

Le fichier body saisi par l'utilisateur est le contenu du mail.

Le fichier pièce jointe est l'édition VoluEdit au format PDF.

Le programme envoi_fax_email permet d'utiliser ce module, soit comme maintenant en lançant l'édition sur une imprimante de type PDF, soit en utilisant un fichier PDF déjà existant.
L'option Opj vérifie au préalable la présence de la pièce jointe (le nom est celui du document qui serait construit par l'édition VoluEdit.
En cas d'absence, on lance l'édition classique afin de générer le document.

Exemple AR

1) Saisie d'une commande client avec option –Oxm

Ouverture de la grille de saisie des destinataires/expéditeur  alimentation de la table envoi_fax_email

2) Edition AR (voluedit)

Avec option –Oxm

Recherche séquence d'envoi fax/email (rien de trouvé, car nécessite le passage de la clé en argument du lanceur (-N))

Suivant les notes VALID_xxxx,

- mise à jour automatique de la zone efe_flag_autorise

- ouverture d'un écran pour validation du flag sur les différentes lignes de fax/mail à envoyer pour ce document.

3) Gestion éventuelle des fax emails (gestion_fax_email), maj autorisation d'envoi, …

4) Edition des AR (fax/mail) Pas d'option -Oxm

Cette édition est lancée depuis le daemon envoi_fax_email (avec la clé ACR en argument)

Recherche séquence d'envoi fax/email (on trouve l'expéditeur, …)

L'imprimante par défaut est SpoolFax.

La table envoi_fax_email est mise à jour.

On gère le nom du document pièce jointe en sortie avec les notes

xxx : ACR, DEV, …

PREFIX_DOCUMENT_xxx

CLE_DOCUMENT_xxx

En édition VoluEdit, seule la CLE_DOCUMENT est utilisée.


#CF EMx Edition du devis mécanique

#CF EMS Edition simplifiée du devis mécanique
#CF EMD Edition détaillée du devis mécanique

Valeur alpha1

Caractères 1 à 30 | Paramétrage des colonnes nomenclatures (par défaut ABFJGH) A Niveau de nomenclature (1 à 7) B Séquence (phase / composant / libellé) C Epaisseur D Largeur E Longueur F Prix de revient unitaire devise G Quantité H Valeur total de la ligne de nomenclature I Date de création J Taux de marge devise K Prix d'achat fichier Article (Unité achat) L Code unité d'achat fichier Article (U/A) M Libellé court unité d'achat fichier Article N Taux de frais fichier Article O Taux de perte fichier Article P Prix de revient fichier Article (Unité achat) Q Taux de marge fichier Article R Prix de vente fichier Article (Unité achat) S Prix de vente fichier Article (Unité utilisation) T Code unité de vente (ou utilisation) (U/V) U Libellé court unité de vente fichier Article V Prix de vente unitaire devise
Caractères 31 à 60 | Paramétrage des colonnes gammes (par défaut ABCDEFGHI) A Type de gamme B Numéro de phase C Code opération D Libellé opération E Temps de préparation F Temps de réalisation G Coût forfaitaire H Coût total préparation I Coût total réalisation

Valeur alpha2

Caractère 1,1 | Edition des notes d'entête (D) O/N
Caractère 2,2 | Edition des notes de nomenclature O/N
Caractère 3,3 | Edition des notes de gamme O/N
Caractère 4,4 | Edition des notes de récapitulatif (CV) O/N


#CF EUR Euro

Valeur alpha 1

Caractères 1 à 8

Date de début de la période transitoire du passage à l'euro.

Par défaut, elle est égale au 01011999.

Caractères 9 à 16

Date du jour pour l'activation du contrôle du paramétrage des devises et de la devise de la fiche société.

Par défaut, elle est égale à la date du jour et donc, le contrôle ne sera pas activé avant la date de début de la période transitoire (par défaut 01011999).

En effet, le contrôle est activé si la date paramétrée est supérieure ou égale à la date de début de la période transitoire.

Pour l'activer avant, vous devez mettre la même date que la date de début de la période transitoire.

NE PLUS UTILISER

Caractères 17 à 24

Date de fin de la période transitoire du passage à l'euro.

Par défaut, elle est égale au 31122001.

Caractère 25

Conversion des montants devise en devise société et en EURO (O/N, O par défaut)
- du CTRL-P de la saisie des commandes clients et de la visualisation des commandes clients
- du pied des factures/avoirs (calcul des factures/avoirs)

- des relevés (édition des relevés)

- des écritures comptables (Transfert des factures/avoirs)
Facturation
Avant la date de passage à l'eURO (avant le 01/01/1999), tous les calculs sont faits en devise commande et en devise société. Les calculs sont également faits en EURO, mais uniquement à titre indicatif.
A partir de la date de passage à l'eURO (à partir du 01/01/1999), tous les calculs sont faits en devise commande, en devise société et en EURO. Si la conversion est activée, le pied de la facture calculée en devise commande est converti en devise société et en EURO et les champs montants devise société et EURO sont mis à jour avec les nouvelles valeurs.
Relevés de factures
Dans la table des relevés
- le champs montant devise contient le montant TTC déduit du montant de l'acompte en devise facture.
- le champs montant contient le montant TTC déduit du montant de l'acompte en devise société.
- le champs montant EURO contient le montant TTC déduit du montant de l' acompte en EURO.
Si la conversion est activée, le montant TTC déduit du montant de l'acompte en devise facture est converti en devise société et en EURO et les champs montants devise société et EURO sont mis à jour avec les nouvelles valeurs.
Transfert des factures
Si la conversion est activée, ce sont les montants de la facture calculée en devise facture et convertie en devise société qui sont comptabilisés.
En effet, il est interdit, par le droit européen, de calculer la même facture dans plusieurs devises (devise commande, devise société et EURO). Il faut calculer la facture dans la devise de la commande et la convertir ensuite en devise société et en EURO.
Si la conversion est activée, la facture est convertie en devise société et en EURO en prenant la facture calculée en devise facture comme base de calcul. La facture en devise société peut être déséquilibrée, ainsi que celle en EURO. Si un écart de conversion est constaté, celui-ci est comptabilisé dans un compte d'écart créditeur si l'écart est positif ou dans un compte d'écart débiteur si l'écart est négatif.
Les comptes d'écart sont paramétrés sur le paramètre.
#CFTRF_COMPTES_ECART_CONV

Caractères 26 à 28

Devise société avant passage à l'eURO. Exemple FRF

Caractères 29 à 36

Date de passage du logiciel de comptabilité VOLUCOMPTA à l'eURO. Exemple 01012001
ATTENTION, celle-ci doit être enlevée lorsque l'exercice comptable en FRANC est clôturé.

Notes

Caractères 1 à 12 | TABLE_MIGREE
Caractères 21 à 38 | Nom de la table migrée


Dans le cas où aucune action n'est saisie sur une clé donnée, on peut faire appel à un scénario.

Ce dernier permet de renseigner automatiquement une liste d'actions prédéfinies.

Code du lien des tables : S-E.

Sur le code paramètre du scénario, on va définir les étapes et actions via la touche CTRL- MAJ-F5.

Sur le code scénario, on va remplir l'ordre des chronologique des étapes que l'on veut créer.

Pour chaque étape, on aura une liste d'actions associées.

#CF EVT Configuration des actions et des événements

Ce paramètre est opérationnel à partir de la V. 4.0.170.2

Il est utilisé dans le cadre de la gestion des actions et des événements.

Il permet de gérer les OF du Bureau d'Etude.

Les actions peuvent être saisies depuis les programmes suivants (via la touche CTRL-A) :

Saisie des matières (mat)

Saisie des tiers (cli)

Saisie des commandes clients (cde)

Saisie des devis multi-métiers (devis_standard)

Visualisation des commandes (v_cdem)

Saisie des devis onduleurs (don) (voir paragraphe dédié en bas de cette page)

Valeur alpha 1

#CF EVT A1[1,3] | Type de notes à afficher en direct dans l'écran de saisie des actions-événements (par exemple : EVT) A partir de la V. 4.1.3.2, ce paramètre est toujours utilisable, mais il peut être remplacé par le -C qui permet de déclarer plusieurs types de notes. Le #CF EVT A1[1,3] et le paramètre - C peuvent cohabiter : dans ce cas, ils se complètent.
#CF EVT A1[4,6] | Code du lien liant un scénario à des étapes (et événements) (par exemple : S-E)
#CF EVT A1[7,9] | Code du lien liant une étape à des actions (par défaut : E-A)

Valeur alpha 2

#CF EVT A2[1] | Sélection du type de clé des actions à saisir depuis la visualisation des commandes L (par défaut) : saisie des actions sur la Ligne de commande E saisie des actions sur l'Entête de commande C Confirmation : on demande à l'utilisateur son choix
#CF EVT A2[2] | Afficher la colonne Utilisateur (O/N, N par défaut) Voir : Gestion des actions événements depuis le devis onduleur.
#CF EVT A2[3] | Afficher la colonne Affaire (O/N, N par défaut) Voir : Gestion des actions événements depuis le devis onduleur.
#CF EVT A2[4] | Activer le tri dynamique des colonnes (O/N, O par défaut) Voir : Gestion des actions événements depuis le devis onduleur.
#CF EVT A2[5] | Activer la gestion des permissions pour la modification/suppression des lignes du tableau selon l'utilisateur et/ou le groupe d'appartenance de l'utilisateur (O/N, N par défaut) Voir : Gestion des actions événements depuis le devis onduleur.
#CF EVT A2[6] | Activer la gestion des groupes utilisateurs (O/N, N par défaut) Voir : Gestion des actions événements depuis le devis onduleur.
#CF EVT A2[7] | Renseigner automatiquement l'intervenant (Menée par) lors du changement de l'état (O/N, N par défaut)
#CF EVT A2[8] | Renseigner la date de clôture et l'utilisateur qui clôture l'action lorsque l'état devient terminé (O/N, N par défaut)
#CF EVT A2[9] | Gestion du flux – création d'un numéro unique pour chaque scénario O Mise en place d'une numérotation de flux. Le scénario reçoit un numéro unique. N Aucune numérotation (par défaut) (ajout le 18/09/2012) S Mise en place d'une numérotation de flux avec création possible uniquement via les scénarios
#CF EVT A2[10] | Affichage du filtre O Affiche la zone de filtre N N'affiche pas la zone de filtre (par défaut) 1 Affiche la zone de filtre. A la validation de l'écran, retour dans le programme appelant
#CF EVT A2[11] | Saisie de la date d'échéance lors de l'ajout d'un scénario O Saisie obligatoire N Saisie facultative (Par défaut
#CF EVT A2[12] | Masquer la colonne Numéro flux (O/N, N par défaut))
#CF EVT A2[13] | Masquer la colonne Origine (O/N, N par défaut))
#CF EVT A2[14] | Masquer la colonne Libellé (O/N, N par défaut))
#CF EVT A2[15] | Masquer la colonne Qualité (O/N, N par défaut))
#CF EVT A2[16] | Masquer la colonne Menée par (O/N, N par défaut))
#CF EVT A2[17] | Afficher les informations du flux dans le détail (O/N, N par défaut))
#CF EVT A2[18] | Afficher les informations sur l'événement (O/N, N par défaut))
#CF EVT A2[19] | Afficher le groupe contact (O/N, O par défaut)
#CF EVT A2[20] | Afficher le groupe notes (O/N, O par défaut)
#CF EVT A2[21] | Afficher la colonne I/E (O/N, O par défaut)

Notes

AFF_EVENEMENT_

Visualisation/Modification des actions et des événements associés au type d'origine

Plus d'information en bas de cette page

Cette note est recherchée ici si elle n'est pas trouvée dans le paramètre de lancement du programme.

15,17 Type d'action et événement d'origine

EC Entête de commande

LC Ligne de commande

L2 Sous-devis

FI Entité de sous-devis

AF Affaire

CL Client

MP: Produit fini

21 Affichage des actions et événements de l'entête de commande associée au type d'origine (N/O/M, N par défaut)

22 Affichage des actions et événements de la ligne de commande associée au type d'origine (N/O/M, N par défaut)

23 Affichage des actions et événements du sous-devis associé au type d'origine (N/O/M, N par défaut)

24 Affichage des actions et événements de l'entité de sous-devis associée au type d'origine (N/O/M, N par défaut)

25 Affichage des actions et événements de l'affaire associée au type d'origine (N/O/M, N par défaut)

26 Affichage des actions et événements du client associé au type d'origine (N/O/M, N par défaut)

27 Affichage des actions et événements du produit associé au type d'origine (N/O/M, N par défaut)

LIB_TYPE_ACTION_

17,19 Type de l'action événement et libellés court/long par défaut

MP Libellés court et long : Produit

CL Libellés court et lon : Tiers

EC Libellé court : Cde/entête

Libellé long : Commande (entête)

LC Libellé court : Cde/ligne

Libellé long : Commande (ligne)

L2 Libellés court et long : Devis

FI Libellé court : Dev/entité

Libellé long : Devis (entité)

21,60 Libellé à afficher dans la visualisation des actions événements

Remarque : Si un libellé est paramétré pour un type d'action événement, il remplace à la fois le libellé court et le libellé long par défaut.

Autres paramètres

NOTES_ACTION_EVT | Saisie des matières (mat) Saisie des tiers (cli) Saisie des commandes clients (cde) Saisie des devis multi-métiers (devis_standard) Visualisation des commandes (v_cdem)
EVT | A1[5,14] Notes -C et -D
#CF TRA | Traçabilité de la table action_evt
Gestion des options | Option payante pour l'accès à la traçabilité de la table action_evt : BAS 31
v_action_evt | Visualisation des actions et des événements
cde A3[7,9] = CBE | TYC par défaut pour les commandes de type BE Il est nécessaire de créer un nouveau TYC pour ce type de commande. Par paramétrage via les notes #CC, on peut alors supprimer toutes les zones de la partie basse de l'entête de commande.

Visualisation/Modification des actions et des événements associés au type d'origine

Ce paragraphe concerne la note AFF_EVENEMENT_

• Ce fonctionnement est accessible à partir de la fonction de saisie des actions et événements, quel que soit le programme.
Le paramétrage de lancement concerne donc tous les programmes permettant d'accéder à la saisie des actions et événements.

• Les actions et les événements du type d'origine sont toujours affichés en premier.

• Les actions et les événements associés au type d'origine sont toujours affichés dans l'ordre suivant :

o Entête de commande (EC)

o Ligne de commande (LC)

o Devis/Sous-devis (L2)

o Entité de sous-devis (FI)

o Affaire (AF)

o Client (CL)

o Produit fini (MP)

• Les actions et les événements associés affichables dépendent du type d'origine de la saisie (voir tableau ci-dessous).

• La possibilité de modifier les actions et les événements associés au type d'origine est soumise à des permissions d'accès (une permission par type d'action et événement) :

o Entête de commande : ACC/ACT_EVT_EC

o Ligne de commande : ACC/ACT_EVT_LC

o Devis/Sous-devis : ACC/ACT_EVT_L2

o Entité de sous-devis : ACC/ACT_EVT_FI

o Affaire : ACC/ACT_EVT_AF

o Client : ACC/ACT_EVT_CL

o Produit fini : ACC/ACT_EVT_MP

• La saisie des informations du type d'origine n'est pas affectée par la permission associée.
Les permissions ne concernent en effet que la saisie des actions et événements associés au type d'origine, pas le type d'origine lui-même.

• Par défaut, seuls les actions et les événements du type d'origine de la saisie sont affichés.

• La modification de l'ordre des actions et événements ne concerne que le type d'origine (en mode modification d'ordre, les actions et événements associés ne sont plus affichés).

• Seuls les actions et événements du type d'origine peuvent être supprimés.

• Seul des actions et événements du type d'origine peuvent être créés (en fin de tableau ou par insertion).

• Le paramétrage est pris en priorité sur le paramètre de lancement du programme en cours.

Informations visualisables selon le type d'origine de la saisie

Origine de la saisie | Informations visualisables selon le type d'origine de la saisie
 | Entête Cde | Ligne Cde | Sous-devis | Entité | Affaire | Client | Produit fini
Entête de commande | - |  | O |  | O | O |
Ligne de commande | O | - | O |  | O | O | O
Sous-devis | O | O | - |  | O | O |
Entité | O | O | O | - | O | O | O
Affaire |  |  |  |  | - | O | O
Client |  |  |  |  |  | - |
Produit fini |  |  | O |  | O | O | -

Gestion des actions événements depuis le devis onduleur

Tout paramètre de lancement utilisant les actions événements :

CONFIG_EVT : car.21,23 : Code paramètre (#CF/xxx) qui contient le paramétrage pour les actions événements (c'est ici)

CONFIG_AFF : car.21,23 : Code paramètre (#CF/xxx) qui contient le paramétrage pour la saisie des affaires

don

Note NOTES_ACTION_EVT

#CF EVT

A2[2] et suivants

GRU

Notes EVT_AUTORISE_USE et ENVOI_DEST

ATR

Note ENVOI_DEST

EVT

A1[18,20] Code groupe de type GRU

A3[1,60] Objet ou commentaire de l'événement

ETP

A1[18,20] Code groupe de type GRU


#CF FAC Calcul des factures

ATTENTION ! Ce paramétrage est réservé à Volume Software.

Alimentation du fichier des commission des représentants (stat1) : stat2, option –Osc

Valeur alpha 1

Alimentation du fichier stat0.

Caractère 1 | Mise à jour stat0.st_prod (O/N/R), R produit de la ligne de rattachement
Caractère 2 | Mise à jour stat0.st_fam (O/N/R), R famille de la ligne de rattachement
Caractère 3 | Mise à jour stat0.st_sfm (O/N/R), R sous-famille de la ligne de rattachement
Caractère 4 | Mise à jour stat0.st_cli (O/N)
Caractère 5 | Mise à jour stat0.st_rep (O/N)
Caractère 6 | Mise à jour de la table des statistiques de facturation (stat0) La zone st_par est alimentée par : A p_ec.ec_c1 B p_b1.b1_sitp C p_cl.cl_geo D p_cl.cl_cat E p_cl.cl_act F p_cl.cl_orig G p_lc.lc_p1 H p_ec.ec_tyc (Type de la commande) N rien
Caractère 7 | Mise à jour table des statistiques des commissions (stat1) La zone s1_p1 est alimentée en fonction du paramétrage suivant : A p_ec.ec_c1 : #CF CDE alpha1[1,3] B p_b1.b1_sitp : #CF BLV alpha1[1,3] C p_cl.cl_geo : Secteur géographique D p_cl.cl_cat : Catégorie client E p_cl.cl_act : Secteur d'activité F p_cl.cl_orig : Origine G Traitement spécifique A (p_lc.lc_p1 et p_lc.lc_p2) H p_lc.lc_fam
Caractère 8 | Mise à jour table des commissions (stat1) La zone stat1.s1_clmp sera alimentée en fonction du paramétrage suivant : A code article C code client
Caractère 9 | Mise à jour stat0.st_par1 A p_cl.cl_codp[1,2] B p_mp.mp_cond C type d'imposition issu de la fiche de fabrication reliure
Caractère 10 | Mise à jour stat0.st_par2 A traitement spécifique A (p_lc.lc_p1 et p_lc.lc_p2) B p_lc.lc_p1 C type de couture issu de la fiche de fabrication reliure
Caractère 11 | Mise à jour stat0.st_libre_1 A Nombre de cahiers issu de la fiche de fabrication reliure. B Poids facturé (fl_poids) C Poids brut (défini sur le CIC N56 du produit) D Poids net (défini sur le CIC N54 du produit) E Surface brute (définie sur le CIC N57 du produit) F Surface nette (définie sur le CIC N55 du produit) G Nombre de couleurs (défini sur le TSC 110 ic_num1 du produit)
Caractère 12 | A Selon la quantité lancée sur la fiche de fabrication : si 1 < quantité <= 5000 : ajout de la quantité à stat0.t_libre2 si 5000 < quantité <= 15000 : ajout de la quantité à stat0.st_libre3 si 15000 < quantité <= 50000 : ajout de la quantité à stat0.st_libre4 si 50000 < quantité : ajout de la quantité à stat0.st_libre5
Caractère 13 | Mise à jour stat0.st_libre_2 C Poids brut (défini sur le CIC N56 du produit) D Poids net (défini sur le CIC N54 du produit) E Surface brute (définie sur le CIC N57 du produit) F Surface nette (définie sur le CIC N55 du produit) G Nombre de couleurs (défini sur le TSC 110 ic_num1 du produit)
Caractère 14 | Mise à jour stat0.st_libre_3 C Poids brut (défini sur le CIC N56 du produit) D Poids net (défini sur le CIC N54 du produit) E Surface brute (définie sur le CIC N57 du produit) F Surface nette (définie sur le CIC N55 du produit) G Nombre de couleurs (défini sur le TSC 110 ic_num1 du produit)
Caractère 15 | Mise à jour stat0.st_libre_4 C Poids brut (défini sur le CIC N56 du produit) D Poids net (défini sur le CIC N54 du produit) E Surface brute (définie sur le CIC N57 du produit) F Surface nette (définie sur le CIC N55 du produit) G Nombre de couleur (défini sur le TSC 110 ic_num1 du produit)
Caractère 16 | Mise à jour stat0.st_libre_5 C Poids brut (défini sur le CIC N56 du produit) D Poids net (défini sur le CIC N54 du produit) E Surface brute (définie sur le CIC N57 du produit) F Surface nette (définie sur le CIC N55 du produit) G Nombre de couleur (défini sur le TSC 110 ic_num1 du produit)
Caractère 17 | Création d'un article fictif #POR dont le montant sera la somme des ports taxables et/ou exonérés de la période choisie (O/N)
Caractère 18 |
Caractère 19 |
Caractère 20 | Ordre d'édition et réédition des factures 1 par facture et ligne de facture 2 par facture, commande, ligne de commande et ligne de facture 3 par facture, BL et ligne de BL 4 par facture, BL, numéro de commande, famille d'article commandé et produit commandé 5 par facture, produit, BL et ligne de BL 6 par facture, adresse de livraison, commande, ligne de commande et ligne de facture
Caractère 21 |
Caractères 22 à 24 | Délai en jours pour l'escompte sur règlement. Le taux étant paramétré sur le client (TSC). Exemple : 030
Caractères 25 à 26 | Taux d'escompte légal mensuel. Si le taux d'escompte sur règlement n'est pas paramétré sur le client (TSC), le taux d'escompte légal mensuel sert à le calculer. Exemple : 01.25
Caractère 27 | Mode de calcul de la TVA dans le module de facturation 1 Calcul de la TVA sur les montants HT cumulés par code TVA 2 Calcul de la TVA sur le montant HT de chaque ligne avec cumul du montant TVA par code TVA
Caractère 28 | Mode de regroupement à appliquer sur les FAD et les AVO C On applique le mode de regroupement Client (Valeur par défaut) L 1 ligne de commande sur 1 facture O 1 commande de n lignes sur 1 facture N n commandes sur 1 facture A utiliser si on désire regrouper les commandes d'avoir sur une seule facture. Par défaut, les commandes d'avoir ne sont pas regroupées dans une seule facture même si le type de regroupement paramétré sur le client est 4.
Caractère 29 | Prise en compte du calendrier lors du calcul de la date d'échéance (O/N, N par défaut)
Caractères 30 à 35 | Code calendrier spécifique à utiliser lors du calcul de la date d'échéance Par défaut : #SOC (Calendrier générique société)

Notes

CODE_JOURNAL | 21,60 Code journal Exclusivement numérique. Sert à calculer le code VCS.
CODE_VCS | 21,22 Numéro de version. Actuellement seule la version 1 existe. Remarque : cette note est obligatoire pour activer la génération du code VCS 24,26 Code TSC. (par défaut VCS). TSC qui stockera le code VCS dans la zone ic_char30 (G)
COLLECTIF_CLIENT_ | Comptabilité REEL (type R) 18 Régime TVA N Taxable O Export S Suspension I Intracommunautaire E Exonéré 19,28 N° de compte Utilisé notamment dans tr_fcnn_vl
DEDICACE | 21,40 Texte de la dédicace
DROIT_DE_TIMBRE | 21,30 Montant du droit de timbre Exemple : 0.200
TEXTE_MODE_SOU_ | Edition des mentions légales 2 lignes de 80 caractères sont éditées par mode de soumission. Chaque ligne éditée correspond à 2 lignes de notes de 40 caractères. 16,18 Code langue (exemple FRA) 19 _ (underscore) 20 Mode de soumission N Taxable O Export S Suspension I Intracommunautaire E Exonéré 21,60 Texte légal


#CF FEX Frais d'expédition

Les types de frais d'expédition sont gérés dans chaque paramètre de type FEX dans le caractère alpha1[1,1].

Les libellés correspondants à ces types de frais d'expédition sont paramétrables dans #CF FEX.

Valeur alpha 1

Caractères 1 à 25 | Libellé du type de frais d'expédition 1
Caractères 26 à 50 | Libellé du type de frais d'expédition 2

Valeur alpha 2

Caractères 1 à 25 | Libellé du type de frais d'expédition 3
Caractères 26 à 50 | Libellé du type de frais d'expédition 4

Valeur alpha 3

Caractères 1 à 25

Libellé du type de frais d'expédition 5

Valeur alpha 4

Caractères 1 à 8 | Compte comptable du type de frais d'expédition 1
Caractères 9 à 16 | Compte comptable du type de frais d'expédition 2
Caractères 17 à 24 | Compte comptable du type de frais d'expédition 3
Caractères 25 à 32 | Compte comptable du type de frais d'expédition 4
Caractères 33 à 40 | Compte comptable du type de frais d'expédition 5


#CF FLA Configuration du flash

Valeur alpha 2

Caractère 1 | Type de surface à récupérer (B Brute, N Nette)
Caractère 2 | Type de poids à récupérer (B Brute, N Nette)
Caractères 3 à 7 | Type de remontée pour la partie commerciale AVAL ou AMONT
Caractères 8 à 12 | Type de remontée pour la partie production AVAL ou AMONT
Caractères 13 à 17 | Type de remontée pour la partie expédition / facturation AVAL ou AMONT
Caractères 18 à 22 | Coefficient de production supplémentaire
Caractère 23 | Méthode calcul objectif journalier 1 Objectif mensuel / nombre jours ouvrés du mois 2 Objectif annuel / nombre jours ouvrés de l'année
Caractère 24 | Méthode d'identification des objectifs 1 Méthode directe (cf caractères 25 à 28) 2 Le CA est le premier objectif La DENsite est le deuxième objectif Le prix moyen au KiloGramme le troisième objectif La valeur ajoutée est le quatrième objectif L'objectif poids est calculé comme suit CA / PMKG L'objectif surface est calculé comme suit (CA / PMKG) / DEN
Caractère 25 | Objectif surface
Caractère 26 | Objectif poids
Caractère 27 | Objectif chiffre d'affaire
Caractère 28 | Objectif valeur ajoutée
Caractères 30 à 34 | Heure début journée commerciale (ex 05.00)
Caractères 35 à 39 | Heure début journée production
Caractères 40 à 44 | Heure début journée expédition/facturation
Caractère 45 | L'heure paramétrée est celle de D ou [espace] Début de la journée F Fin de la journée

Notes

DEF_IMPUT | Indique le flash associé au couple famille / sous-famille de produit Attention à l'ordre de saisie du couple famille / sous-famille 15 à 16 Numéro du flash (99 en l'absence de gestion du flash pour le risque client) 17 à 19 Critère (ex FAM) (FAM en l'absence de gestion du flash pour le risque client) 25 à 27 Code famille (* en l'absence de gestion du flash pour le risque client) 28 à 30 Code sous-famille (* en l'absence de gestion du flash pour le risque client)
DEFINITION_NUM | Indique la définition du flash 15 à 16 Numéro du flash 17 à 60 Libellé du flash
HIERARCHIE_NUM | Indique la hiérarchie des flashs 15 à 16 Numéro du flash fils 17 à 18 Numéro du flash père


mp_afnor / mp_at1 / mp_at2 / mp_cli / mp_cond / mp_coul / mp_cpta / mp_cs1 / mp_cs2 / mp_cs3 / mp_cs4 / mp_des / mp_des2 / mp_devis / mp_dt1 / mp_dt2 / mp_dt3 / mp_dt4 / mp_dt5 / mp_dt6 / mp_dt7 / mp_dt8 / mp_fam / mp_fconv / mp_foucli / mp_hau / mp_lar / mp_libre / mp_libre / mp_lon / mp_marg / mp_mp / mp_pa / mp_poids / mp_pr / mp_pv / mp_pv2 / mp_qualite / mp_qualite_matiere / mp_reap / mp_remp / mp_rgt1 / mp_rgt2 / mp_rgt3 / mp_sdevis / mp_sfm / mp_tva / mp_ua / mp_uv /

#CF GEA Génération automatique d'articles

Généralités Valeur alpha 1 Notes : clauses Notes : règles

ATTENTION : pour la gestion multi-formats, un nouveau paramètre a été ajouté dans les données diverses de la fiche article : mp_param[45]

Notes pour la saisie des libellés techniques paramétrables

Ces notes existent aussi sur le TYF (où elles sont alors prioritaires) pour la génération des produits depuis la commande d'achat.

LIBELLE_TECHNIQUE_1 | 21,40 Libellé de la zone 1. Exemple : Largeur (valeur par défaut) 41,60 Nom de la zone 1. Exemple : mp_lar (valeur par défaut) Cette note, si elle est paramétrée, a priorité sur celle de mat.
LIBELLE_TECHNIQUE_2 | 21,40 Libellé de la zone 2. Exemple : Longueur (valeur par défaut) 41,60 Nom de la zone 2. Exemple : mp_lon (valeur par défaut) Cette note, si elle est paramétrée, a priorité sur celle de mat.
LIBELLE_TECHNIQUE_3 | 21,40 Libellé de la zone 3. Exemple : Hauteur (valeur par défaut) 41,60 Nom de la zone 3. Exemple : mp_hau (valeur par défaut) Cette note n'existe pas dans mat.
LIBELLE_TECHNIQUE_4 | 21,40 Libellé de la zone 4. Exemple : Poids (valeur par défaut) 41,60 Nom de la zone 4. Exemple : mp_poids (valeur par défaut) Cette note n'existe pas dans mat.

D'abord quelques mots sur la fonction f_genart...

La fonction f_genart a pour but de créer des articles à partir de matières génériques.

L'exemple le plus courant concerne la gestion des besoins matières pour les cartonniers.

En fait, la problématique commence avec l'arrivée d'une commande d'une caisse.

Pour produire la caisse demandée, il nous faut une plaque en double cannelure ayant une certaine laize et une certaine coupe.

Dans notre application, les cartonniers utilisent dans leurs devis des matières dites génériques (dans notre exemple, une double cannelure) auxquelles ils appliquent les dimensions devisées. Quand la commande client arrive, il faut passer la commande au fournisseur.

Pour générer un code article que l'on pourra commander et re-commander à loisir, cette fonctionnalité s'appuie donc sur la matière générique utilisée et les dimensions spécifiées par

  • le devis

  • la commande client

  • les besoins matières (souvent générés par la commande client)

  • la commande fournisseur (qui, elle même, peut être générée par les besoins matière)

  • la saisie des articles

  • les inventaires

  • les demandes d'achat

  • la découpe et la refente de bobines

Par conséquent, le choix du niveau de génération de l'article dépend du niveau d'automatisme paramétré chez le client.

Ceci n'a rien à voir avec le paramétrage, mais cet éclaircissement est nécessaire afin de comprendre sa complexité.

Valeur alpha 1

Paramétrage des différents niveaux auxquels on peut générer l'article.

Pour chaque caractère, les réponses possibles sont O/N. N est la valeur par défaut.

#CF GEA A1[1] | La génération par le devis est autorisée - Notes commençant par GENER_DEV_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[2] | La génération par la commande client est autorisée - Notes commençant par GENER_CDE_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[3] | La génération par les besoins matière est autorisée - Notes commençant par GENER_TBE_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[4] | La génération par les commandes d'achat est autorisée - Notes commençant par GENER_CDF_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[5] | La génération par la saisie des matières est autorisée - Notes commençant par GENER_MAT_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[6] | La génération par le programme inventaire est autorisée - Notes commençant par GENER_INV (O/N/X) X = la génération est autorisée uniquement si le produit est générique. Génération d'article à partir de la saisie d'une qualité non suivie en stock et multi-format (mp_param[45] = O)
#CF GEA A1[7] | La génération par la saisie des demandes d'achats est autorisée - Notes commençant par GENER_DEA_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.
#CF GEA A1[8] | Activation génération depuis maj_stk - Notes commençant par GENER_STK_ (O/N/X) X = la génération est autorisée uniquement si le produit est générique.

Valeur alpha 2

#CF GEA A2[1]

Dans le cas d'une génération de PLAQUE (cf. MODEL)

Détermine la portée de réintégration du code plaque dans le devis générateur

D On réintègre le nouveau code plaque sur toutes les variantes du devis ayant la même qualité et les mêmes dimensions. Mettre systématiquement le code D.

[espace] On ne réintègre le nouveau code plaque que sur l'entité génératrice.

N Pas de réintégration du nouveau code plaque sur le devis

Notes

A chaque niveau de génération, on associe un code source (SRC) sur 3 caractères qui va permettre de paramétrer le mode de génération de l'article dans ce cas d'appel :

Si le programme appelant est | la valeur de SRC est
Devis transformateur - voir A1[1] | DEV
Saisie de commandes client - voir A1[2] | CDE
Besoins matières - voir A1[3] | TBE
Saisie de commandes fournisseur - voir A1[4] | CDF
Saisie des articles - voir A1[5] | MAT
Saisie des inventaires par bordereau - voir A1[6] | INV
Saisie des demandes d'achats - voir A1[7] | DEA
Refente de bobine, découpe de bobine - voir A1[8] | STK

Par convention :

Afin de pas répéter inutilement N fois chaque ligne de paramétrage, on utilisera désormais ce code SRC (comme source).

De plus, on appliquera la légende suivante :

Les caractères en gras représentent les codes en dur dans le paramétrage à ils devront apparaître tels quels dans vos lignes de notes.

Les caractères normaux représentent des codes libres dans le paramétrage à il n'existe aucune règle concernant ces codes.

Les caractères en italiques représentent des codes à valeurs limités; certains sont assujettis à une liste de valeurs possibles, d'autres serviront de clé pour lire des paramétrages dépendants.

Pour faciliter la compréhension, ce document de paramétrage suivra la logique du programme mais ne fera pas un listing des différentes zones ou lignes de notes possibles à effectuer (bien que ce document se veuille exhaustif quant aux possibilités de paramétrage).

Donc, puisque l'on a défini les différents niveaux de génération de l'article, il faut définir pour chaque niveau les règles à appliquer pour la génération.

Premier problème, ce n'est pas parce que l'on génère l'article à partir d'un niveau fixe, que les mêmes règles s'appliquent à tous les articles qui vont être générés.

Afin de résoudre ce problème, on permet au client de spécifier plusieurs ensembles de règles de génération à partir d'un même point de départ, en fonction de critères multiples.

Ces critères, ou conditions (CND) peuvent être de 9 natures différentes, chacune codée sur 3 caractères :

BOB

Génération type bobine

F40

Le critère est défini par FAM A4[40] de la matière générique

Ce critère permet de définir plus aisément des regroupements et facilite le paramétrage par rapport au 1er critère.

FAM

Le critère est défini par le code famille de la matière générique.

Le critère FOR est appelé en sous-niveau du critère FAM.

FEU

Génération type feuille

FOR

Format

K40

Le critère est défini par le type KMA A1[22] du produit.

Nota : ce critère se fait sur l'article fabriqué et non l'article générique (qualité carton utilisée)

Ce critère permet de définir plus aisément des regroupements et facilite le paramétrage par rapport au 1er critère.

PRE

Le critère est défini par le début du code de la matière générique.

SFM

Le critère est défini par le code famille et le code sous-famille de la matière générique

TMP

Type de matière ou produit (cf mat.mp.mp)

On définit que le code CLE représente l'identifiant qui permettra de définir les règles à appliquer pour générer l'article.

Pour déterminer ce code CLE, on paramètre donc les différentes clauses possibles via des lignes de note commençant par GENER_SRC_

Syntaxe :

Caractères 1 à 6 | GENER_
Caractères 7 à 9 | SRC (représente le niveau auquel est généré l'article, voir ci-dessus)
Caractère 10 | _ (underscore)
Caractères 11 à 12 | CLE (représente l'identifiant de l'ensemble des règles à appliquer)
Caractère 13 | (espace)
Caractères 14 à 16 | CND (représente la condition d'application des règles, voir ci-dessus)
Caractère 17 | (espace)
Caractères 18 à 59 | Argument à tester en fonction du code de condition d'application des règles Si CND = BOB : On peut passer un code famille comme argument, ou ne pas passer d'argument. Si CND = F40 : L'argument à passer est FAM alpha4[40] (donc 1 caractère). Si CND = FAM : L'argument à passer est un code famille. Si CND = FEU : On peut passer un code famille comme argument, ou ne pas passer d'argument. Si CND = FOR : Pas d'argument (test non existence de format). Si CND = K40 : L'argument à passer est KMA A1[22] (donc 1 caractère). Si CND = PRE : L'argument à passer est le début d'un code article (donc maximum 15 caractères). Si CND = SFM : L'argument à passer est un code sous-famille SI CND = TMP : L'argument à passer est Q pour Qualité, par exemple.
Caractère 60 | Affichage du message récapitulatif des articles créés en fin de traitement (O/N, O par défaut)

ATTENTION : un article est généré dès qu'une condition est vraie !

Autrement dit, si des générations multiples sont réalisées "à tort", il est vraisemblable que certaines conditions se recoupent.

Vérifiez vos conditions et éliminez celles qui interfèrent.

Exemples :

12345678901234567890 |
GENER_CDE_M1 FAM PAP | Lors de l'appel par la saisie de commande client, si la matière générique appartient à la famille PAP, alors on appliquera les règles identifiées par la clé M1.
GENER_TBE_M2 PRE QBCT | Lors de l'appel par la visualisation des besoins matières, si le code de la matière générique commence par les caractères QBCT, alors on appliquera les règles identifiées par la clé M2.
GENER_DEV_M3 F40 F | Lors de l'appel par la saisie des devis, si la famille de la matière générique est paramétrée avec un F en alpha4[40], alors on appliquera les règles identifiées par la clé M3.
GENER_CDF_M1 BOB | La génération d'article aura lieu si BOBINE à générer. L'article généré sera systématiquement non générique (mp_param[25] = N).
GENER_CDF_M2 FEU | La génération d'article aura lieu si FEUILLE à générer. L'article généré sera systématiquement non générique (mp_param[25] = N).
GENER_CDF_C4 FAM CAI FOR | Lors de l'appel par la saisie de commande fournisseur, si la matière appartient à la famille CAI et qu'elle n'a pas de format, alors on appliquera les règles identifiées par la clé C4.
GENER_CDF_C4 BOB CAR | Lors de l'appel par la saisie de commande fournisseur, en cas de génération de bobine, si la matière générique appartient à la famille CAR, alors on appliquera les règles identifiées par la clé C4.
GENER_TBE_M4 FAM CAI PRE QCT | Lors de l'appel par la visualisation des besoins, si la matière appartient à la famille CAI et que le code commence par QCT, alors on appliquera les règles identifiées par la clé M4.
GENER_MAT_C1_SFM PAP CCH | Lors de l'appel par la saisie des matières, si la matière appartient à la famille PAP et à la sous famille CCH , alors on appliquera les règles identifiées par la clé C1.

Complément de sélection sur la table mat lors de la recherche de l'existence d'un code produit correspondant aux critères saisis.

Par exemple, ce complément peut permettre d'exclure des codes matières dans la recherche de produit équivalent.

Caractères 1 à 6 | SUPCP_
Caractères 7 à 9 | SRC (représente le niveau auquel est généré l'article, voir ci-dessus)
Caractère 10 | _ (underscore)
Caractères 11 à 12 | CLE (représente l'identifiant de l'ensemble des règles à appliquer)
Caractères 14 à 60 | Complément de sélection sur la table mat

Exemple

SUPCP_CDF_C2 and mp_code like "GC1%"

è A ce stade, on sait comment identifier les règles que l'on va appliquer.

Voyons maintenant ces règles : il en existe 8 :

1 | CODIF_ | Codification de l'article
2 | MODEL_ | Modèle de génération
3 | LIBEL_ | Libellé du modèle de génération
4 | MPDEF_ | Article de référence
5 | REMPL_ | Règles de remplacement (ou d'initialisation)
6 | VERIF_ | Vérification d'article existant
7 | DESIG_ | Paramétrage du contenu du champ mp_des de l'article généré
8 | COPIE_NTS_ | Recopier les notes de l'entité vers l'article plaque

Respecter le format du compte d'astérisques dans les différentes constructions.

1 - Dans un premier temps, si on doit générer un article, voyons comment on va définir le code de l'article.

Pour cela, on dispose de lignes de notes commençant par CODIF_ qui vont nous permettre de définir la structure du code.

Syntaxe :

Caractères 1 à 6

CODIF_

Caractères 7 à 8

CLE (représente la clé d'identification des règles à prendre en compte)

Caractère 9

_ (underscore)

Caractère 10

Rang (position dans le code article généré)

Caractères 11 à 13

à blanc

Caractères 14 à 60

Elément de la structure du code à générer.

La définition d'un élément de la structure du code à générer se fait en 5 parties, le séparateur utilisé étant l'astérisque.

Syntaxe : Nom_variable*Position_début*Longueur*Format*Folio*

Nom_variable représente la variable que l'on va utiliser pour définir cet élément.

Les variables suivantes sont autorisées :

Tous les champs de la table mat associés à l'article en cours (celui de la ligne de commande dans le cas d'un appel par le programme des commandes client, par exemple) (On conserve la racine mp_)

Egalement des_mp_qualite_mat :

Désignation de la qualité matière (produit : mat dans f_zone)

Tous les champs de la table mat associés à la matière générique (racine mg_)

Egalement des_mg_qualite_mat :

Désignation de la qualité matière (matière générique : mat_gen dans f_zone)

Tous les champs de la table fle_imp (entité du devis)

Tous les champs de la table cde5 (besoins matière)

Tous les champs de la table cdf2 (ligne de la commande d'achat)

constante : la valeur contenue dans l'emplacement Format sera appliquée dans le code généré

tsc_cle_code_zone : On va rechercher le contenu d'un TSC défini par les zones :

clé = clé sur laquelle le TSC a été saisi

PF = TSC saisi sur l'article en cours

MG = TSC saisi sur la matière générique

code = code du TSC

zone = zone recherchée du TSC

folio :on génère, à partir des champs stipulés comme élément de la racine (cf. 5eme partie de la définition de l'élément), une valeur numérique dépendante d'un compteur Volume. 1 seul folio par code.

Position_début indique le premier caractère du contenu de Nom_variable à prendre en compte au sein du code qui sera généré.

Longueur détermine le nombre de caractères qui seront pris dans le contenu de Nom_variable pour être intégrés au code qui sera généré (99 pour une longueur variable, permet de supprimer les blancs)

Format permet de spécifier le format des valeurs numériques éventuellement définies par Nom_variable.

Folio permet d'intégrer la chaîne de caractères récupérée par les critères précédents dans la racine servant à définir un éventuel compteur.

Exemple :

Si nous voulons générer un code qui contienne :

Caractères 1 à 3 | le code famille de la matière générique
Caractères 4 à 9 | les caractères 4 à 9 du code produit de la ligne de commande (car on sait qu'ils contiennent le code client)
Caractères 10 à 12 | la zone ic_char3 du TSC 201 de l'article en cours
Caractères 13 à 15 | une valeur numérique dans le cas du duplicata, valeur qui ne doit pas tenir compte du TSC NAB.

il nous faut paramétrer les lignes suivantes :

CODIF_M1_1 mg_fam*1*3**O*

CODIF_M1_2 mp_code*4*6**O*

CODIF_M1_3 TSC_PF_201_F*1*3**N*

CODIF_M1_4 folio*1*3*&&&**N*

A ce degré de paramétrage, nous avons notre code produit.

2 - Maintenant, il est obligatoire de spécifier un modèle de génération.

Ceci se fait par les lignes de note commençant par MODEL_.

A l'heure actuelle, cette fonction n'intègre que 2 types de modèle de génération : PLAQUE ou MOUSSE.

  • Le modèle PLAQUE permet d'initialiser, sans avoir à les paramétrer, les dimensions de l'article qui sera généré à partir des dimensions les plus précises en fonction du niveau de génération (devis, commande client, besoin matière ou commande d'achat).
    De plus, ce modèle mettra automatiquement à jour les données modifiées par cette génération vis à vis du programme appelant (les codes matières utilisées au niveau des formules du devis pas exemple), ainsi que les TSC nécessaires à la bonne gestion des plaques dans Volume Software (ceci inclus aussi les pointages si l'article est refoulé).

  • Le modèle MOUSSE ne possède aucun automatisme.
    Il permet donc de générer les articles en suivant scrupuleusement le paramétrage spécifié.

Syntaxe :

Caractères 1 à 6 | MODEL_
Caractères 7 à 8 | CLE (représente la clé d'identification des règles à prendre en compte)
Caractères 9 à 13 | Toujours à blanc
Caractères 14 à 60 | Mode de génération [PLAQUE, MOUSSE]. Attention, pas de valeur par défaut.

3 - Libellé du modèle de génération

Ce type de modèle n'est pas très parlant et peut être perturbant lorsqu'il apparaît dans les messages relatifs à la génération.

Les notes commençant par LIBEL_ permettent d'associer un libellé qui servira d'identifiant au modèle de génération dans les messages.

Caractères 1 à 6 | LIBEL_
Caractères 7 à 8 | CLE (représente la clé d'identification des règles à prendre en compte)
Caractères 14 à 60 | Libellé

Donc, maintenant, nous avons un code article ainsi qu'une méthode de génération, que nous faut-il d'autre ?

4 - En général, à Volume Software, quand on crée un article, on s' appuie toujours sur une copie d'un article de référence nommé article défaut.

Ce mode de fonctionnement ne déroge pas à la règle et on peut définir le code de l'article par défaut de cette génération grâce aux lignes de notes commençant par MPDEF_

Syntaxe :

Caractères 1 à 6 | MPDEF_
Caractères 7 à 8 | CLE (représente la clé d'identification des règles à prendre en compte)
Caractères 9 à 13 | Toujours à blanc
Caractères 14 à 28 | Code de l'article par défaut à utiliser pour la génération

Tout est prêt pour générer l'article.

5 - Toutefois, l'utilisateur peut désirer initialiser automatiquement certaines zones de la fiche article qu'il va créer (ou bien même certains TSC) à partir des données dont il dispose à ce niveau.

Champs de la table article autorisés : Cliquez ici pour afficher / masquer la liste des champs triés par ordre alphabétique.

Pour cela, on met à sa disposition les lignes de notes commençant par REMPL.

Syntaxe :

Caractères 1 à 6

REMPL_

Caractères 7 à 9

SRC (Représente le niveau de génération de l'article [DEV, CDE, TBE, CDF])

Caractères 10

_ (underscore)

Caractères 11 à 12

CLE (représente la clé d'identification des règles à prendre en compte.)

Caractère 13

Toujours à blanc.

Caractères 14 à 60

Définition de la règle de remplacement de la zone : Zone_à_remplir*Zone_origine*Valeur*
où

Zone_à_remplir Un des champs de la fiche article qui sera créée ou un TSC. Voir le chapitre de la génération du code article pour la syntaxe de la zone TSC.

Zone_origine Champ dont on va copier la valeur
Tous les champs pouvant servir à générer le code article sont accessibles.
Voir aussi les zones sous ce tableau.

Valeur Valeur, dans le cas où la zone d'origine est constante.

Calcul du poids et de la surface

Permettre de calculer le poids et la surface d'une plaque et de récupérer ceux-ci afin de renseigner certains champs.

Calcul de la surface : (Laize de la plaque (mm) / 1000) x (Coupe de la plaque (mm) / 1000) : m²

Calcul du poids : (Laize de la plaque (mm) / 1000) x (Coupe de la plaque (mm) / 1000) x (Grammage de la qualité associée à la plaque (g/m²) / 1000) : kg

Important : Le calcul du poids et de la surface utilisant les dimensions de la plaque en cours de création, il faut absolument que celles-ci (laize/coupe) soient paramétrées auparavant.

Nouvelles valeurs possibles pour la zone d'origine :

poids_brut Poids brut

surface_brute Surface brute

poids_net Poids net (= poids_brut)

surface_nette Surface nette (= surface_brute)

grammage_qual Poids de l'article qualité matière

Exemples

REMPL_TBE_B1 mp_lon*uc_laize_brute*

Remplissage de la longueur du nouvel article avec la laize brute du besoin matière

REMPL_TBE_B1 mp_lar*uc_coupe_brute*

Remplissage de la largeur du nouvel article avec la coupe brute du besoin matière

REMPL_TBE_B1 TSC_PF_201_C*poids_brut**

Remplissage de la zone numérique 1 du TSC 201 sur le nouvel article avec le poids brut calculé

REMPL_TBE_B1 TSC_PF_201_D*surface_brute**

Remplissage de la zone numérique 2 du TSC 201 sur le nouvel article avec la surface brute calculée

Important : L'ordre doit être respecté, le remplissage des dimensions du nouvel article doit se trouver avant l'utilisation des variables calculées poids et surface.

6 - Maintenant que nous savons paramétrer la génération de notre article, que doit-on faire quand les caractéristiques de l'article à générer correspondent à un article existant ?

Pour déterminer le mode opératoire à suivre, nous utilisons une ligne de note commençant par VERIF

Pour l'instant il existe 3 types de comportements :

N | On crée systématiquement un nouvel article.
VA | On utilise systématiquement l'article existant.
VQ | On demande à l'utilisateur ce que l'on doit faire.

Pour déterminer si un article existant possède les mêmes caractéristiques que celles de l'article à générer, nous utiliserons un code déterminant l'algorithme de recherche des articles déjà créés.

Les algorithmes existants sont les suivants :

QF

Qualité et Format (Longueur et largeur)

QFF

Qualité, format (longueur et largeur) et famille

QM

Qualité matière

Un écran présente tous les articles ayant la même qualité matière et les mêmes dimensions.

L'utilisateur sélectionne alors l'article voulu.

QFP

Nouvel algorithme pour déterminer si un article existant possède les mêmes caractéristiques que celles de l'article à générer

QFP : Un écran présente tous les articles ayant la même qualité matière, les mêmes dimensions, le même fournisseur et le même poids / grammage

L'utilisateur sélectionne alors l'article voulu.

QFR

Présente les articles ayant la même Qualité, le même Format et les mêmes Refoulages.

Syntaxe :

Caractères 1 à 6 | VERIF_
Caractères 7 à 9 | SRC (représente le niveau de génération de l'article [DEV, CDE, TBE, CDF])
Caractère 10 | _ (underscore)
Caractères 11 à 12 | CLE (représente la clé d'identification des règles à prendre en compte)
Caractère 13 | Toujours à blanc
Caractères 14 à 60 | Définition du mode opératoire à suivre. La définition du mode opératoire à suivre se fait en 2 parties, le séparateur utilisé étant l'astérisque. Syntaxe : Type de comportement*Code algorithme de test*

Exemples :

VERIF_CDE_M1 VQ** | Attention, en l'absence d'algorithme, les 2 étoiles sont obligatoires.
VERIF_CDF_M1 VQ*QM* | Génération article après algorithme de test sur qualité matière et format.
VERIF_xxxxx* QFP* |

7 - Paramétrage du contenu du champ mp_des de l'article généré

Caractères 1 à 6

DESIG_ (identique à CODIF_ sans la gestion du folio)

Caractères 7 à 8

CLE (représente la clé d'identification des règles à prendre en compte)

Caractère 9

_ (underscore)

Caractère 10

Rang (position dans le code article généré)

Caractères 11 à 13

Toujours à blanc

Caractères 14 à 60

Elément de la structure du code à générer.

La définition d'un élément de la structure du code à générer se fait en 4 parties, le séparateur utilisé étant l'astérisque.

Syntaxe : Nom_variable*Position_début*Longueur*Format*

Nom_variable représente la variable que l'on va utiliser pour définir cet élément.

Les variables suivantes sont autorisées :

Tous les champs de la table mat associés à l'article en cours (celui de la ligne de commande dans le cas d'un appel par le programme des commandes client, par exemple) (On conserve la racine mp_)

Tous les champs de la table mat associés à la matière générique (racine mg_)

Tous les champs de la table fle_imp (entité du devis)

Tous les champs de la table cde5 (besoins matière)

Tous les champs de la table cdf2 (ligne de la commande d'achat)

constante : la valeur contenue dans l'emplacement Format sera appliquée dans le code généré

tsc_cle_code_zone : On va rechercher le contenu d'un TSC défini par les zones :

clé = clé sur laquelle le TSC a été saisi

PF = TSC saisi sur l'article en cours

MG = TSC saisi sur la matière générique

code = code du TSC

zone = zone recherchée du TSC

Position_début indique le premier caractère du contenu de Nom_variable à prendre en compte au sein du code qui sera généré.

Longueur détermine le nombre de caractères qui seront pris dans le contenu de Nom_variable pour être intégrés au code qui sera généré

Format permet de spécifier le format des valeurs numériques éventuellement définies par Nom_variable.

8 - Recopier les notes de l'entité vers l'article plaque.

ATTENTION : cette action est valable uniquement dans le devis multi-métiers.

Cette fonctionnalité est disponible lors de la génération des articles plaques via les actions :

• Control+Shift+F8 : Génération du papier

• Control+Shift+F6 : Génération des produits

Caractères 1 à 10 | COPIE_NTS_
Caractères 11 à 16 | Source des notes ENTITE : Notes saisies sur l'entité du devis multi-métiers (note_ldev)
Caractère 17 | _ (underscore)
Caractères 18 à 19 | CLE (représente l'identifiant de l'ensemble des règles à appliquer)
Caractère 20 | Toujours à blanc
Caractères 21 à 29 | Listes des types de notes (NTS) à recopier. 13 codes de 3 caractères par ligne


#CF GST Paramétrage de la gestion des stocks

Ce paramètre est utilisable à partir de la V. 4.1.45.2.

Il est appelé par la note CONFIG_GST_STK de v_stk0.

Notes

AFFECT_FORMAT_GIE | 21 Affectation des mouvements de stocks format GIE papier MR SSE-99999999 (O/N, N par défaut). Correspond à A2[8] de v_stk0.
AIDE_SAISIE_AFFECT | 21 Aide sur saisie de l'affectation. 0 Sans aide (par défaut) 1 Ajout en auto de 1/1 et des zéros manquants 2 Ajout des zéros manquants 3 Ajout en auto de -1 et des zéros manquants 4 Ajout en auto des zéros manquants, du -1 et du / avec le premier niveau de l'OF. Correspond aux l'options –Oo1, -Oo2, -Oo3 et –Oo4 de v_stk0.
CREATION_RELIQUAT | 21 Création des reliquats après demande de confirmation lors d'une transformation de S-R en S-N (O/N, N par défaut) Correspond à l'option –Ocr de v_stk0.
CTRL_AFFECT_SN | 21 Affectation obligatoire si sortie normale et numéro de commande client saisi (O/N, N par défaut). Correspond à l'option –Oao de v_stk0.
CTRL_EXISTENCE_OF | 21 Contrôle l'existence du numéro d'OF (O/N, N par défaut). ATTENTION : cette option est OBLIGATOIRE si on veut vérifier l'existence du dossier, contrôler qu'il est non clôturé, et positionner le dossier à calculer. Correspond à l'option –Oof de v_stk0.
INIT_NOTE_LIB_CDE | 21 Alimente automatiquement la zone note avec le libellé de la ligne de commande (affectation) (O/N, N par défaut). ATTENTION : nécessite la note CTRL_EXISTENCE_OF à O Correspond à l'option –Onc de v_stk0.
MODE_IMPRIMERIE | 21 Imprimerie - Edition du format et du grammage si famille = PAP ou CAR) (O/N, N par défaut). Correspond à l'option –Oim de v_stk0.
SAI_D_MVT_RELIQUAT | 21 Ouverture d'une fenêtre permettant la saisie d'une date pour les mouvements de reliquat (O/N, N par défaut)


#CF GPF Génération de produits finis

gere_a_la_palette Gestion à la palette

le_libelle Libellé client 1

le_libelle2 Libellé client 2

le_libpar1 Référence client

mp_alerte Stock d'alerte

mp_code Code produit fini modifié - 3.8.01.2

mp_controle Code contrôle

mp_cs1 Code statistique 1

mp_cs2 Code statistique 2

mp_cs3 Code statistique 3

mp_cs4 Code statistique 4

mp_delmoy Délai moyen

mp_des Désignation

mp_etat_bes Etat du besoin matière

mp_fam Famille

mp_foucli Fournisseur

mp_gencod Gencod

mp_gestionnaire Code gestionnaire

mp_minfou Minimum de commande client

mp_prod_generique Article générique - GENERO UNIQUEMENT - 4.0.20.2

mp_qualite Validité d'article

mp_reap Mode de réapprovisionnement

mp_rgt1 Lieu de rangement 1

mp_rgt2 Lieu de rangement 2

mp_rgt3 Lieu de rangement 3

mp_sfm Sous-famille

mp_smaxi Stock maximum

mp_smini Stock minimum

car_de_braille | Valeur alphanumérique correspondante à la présence de braille
car_de_dorure | Valeur alphanumérique correspondante à la présence de dorure
car_de_fenetrage | Valeur alphanumérique correspondante à la présence de fenêtrage
car_de_foulage | Valeur alphanumérique correspondante à la présence de foulage
car_de_gaufrage | Valeur alphanumérique correspondante à la présence de gaufrage
car_de_hologramme | Valeur alphanumérique correspondante à la présence d'hologramme
car_de_rainage | Valeur alphanumérique correspondante à la présence de rainage
car_de_transfert | Valeur alphanumérique correspondante à la présence de dorure
car_de_vignette | Valeur alphanumérique correspondante à la présence de vignette
code_plaque | Transfert du fi_c_papier uniquement si c'est une plaque
coupe_nette_plaque | Coupe nette plaque
des_mg_qualite_mat | Désignation de la qualité matière
des_mp_qualite_mat | Désignation de la qualité matière
fi_entite_lettre | prend la valeur A si fi_entite = 1, B si fi_entite = 2, etc...
laize_nette_plaque | Laize nette plaque
marge_px_negocie | Marge sur le prix négocié
marge_px_remis | Marge sur le prix remis
marge_px_vente | Marge sur le prix de vente
nb_composant | Nombre de composants
nb_morceaux_fefco | Nombre de morceaux du FEFCO
poids_uni_brut_gr | Poids unitaire brut du produit en grammes, utile pour le TSC 201
poids_uni_brut_kg | Poids unitaire brut du produit en kg, utile pour mp_poids
poids_uni_net_gr | Poids unitaire net du produit en grammes, utile pour le TSC 202
poids_uni_net_kg | Poids unitaire net du produit en kg, utile pour mp_poids
pointages | Transfert des pointages sur le PF. n'utilise pas la zone cible.
px_pr_unite_dev | Prix de revient dans l'unité du devis
p2_zc1_mp_fam | Zone numérique 1 de la famille du produit en cours de génération - 4.0.71.2
qualite_generique | Qualité générique
som_poids_uni_brut_gr | Poids unitaire brut du composé en grammes
som_poids_uni_brut_kg | Poids unitaire net du composé en kilos
som_poids_uni_net_gr | Poids unitaire net du composé en grammes
som_poids_uni_net_kg | Poids unitaire net du composé en kilos
som_surf_uni_brute_m2 | Surface unitaire brute du composé en m2
som_surf_uni_nette_m2 | Surface unitaire nette du composé en m2
surf_uni_brute_m2 | Surface unitaire brute du produit en m2, utile pour le TSC 201
surf_uni_nette_m2 | Surface unitaire nette du produit en m2, utile pour le TSC 202

Exemple d'utilisation de folio_nom

EA

- PS1

- PS2

PS3

Après génération (*folio_nom**4*&&&&**)

EAGENERE0001

- PSGENERE0001-01

- PSGENERE0001-02

PSGENERE0002

Exemple

Code produit décomposé de la façon suivante : CCCCC/FFFF/II où :

• CCCCC : Code client

• FFFF : Folioteur incrémenté par le devis

• II : Folioteur incrémenté par la fiche client

Dans la saisie du devis : pour le code client FED02, les codes produits générés seront :

FED02/0001/01

FED02/0002/01

FED02/0003/01

etc.

Dans la saisie de la fiche article : pour le code client FED02, les codes produits générés seront :

FED02/0001/02, FED02/0001/03, etc.

FED02/0002/02, FED02/0002/03, etc.

FED02/0003/02, FED02/0003/03, etc.

etc.

Ligne de note de paramétrage | Description | Nb.Car. | Ex.
CODIF_COMPOSANT*l2_client*1*5**O* | Code client | 5 | FED02
CODIF_COMPOSANT*valeur*1*1*/*O* | Caractère fixe : / | 1 | /
CODIF_COMPOSANT*folio**4*** | Folioteur incrémenté par la génération des produits du devis | 4 | 0001, 0002, etc.
CODIF_COMPOSANT*valeur*1*1*/*N* | Caractère fixe : / | 1 | /
CODIF_COMPOSANT*indice_client**2*** | Folioteur incrémenté par la saisie des articles | 2 | 01

Compteurs alphanumériques générés par l'exemple ci-dessus :

Type | Racine | Valeur | Description
A | FED02/ | 1 | Compteurs générés puis incrémentés par le devis
A | FED02/ | 2
etc.
A | FED02/0001/ | 1 | Compteurs générés par le devis puis incrémentés par la saisie des articles
A | FED02/0002/ | 1
etc.

Soit le paramétrage suivant :

CODIF_COMPOSE*l2_client*1*5**O*

CODIF_COMPOSE*valeur***/*N*

CODIF_COMPOSE*l2_refcli*3*5**N*

CODIF_COMPOSE*valeur***-*N*

CODIF_COMPOSE*folio**3**N*

Le code produit sera constitué des éléments suivants :

  1. Les 5 premiers caractères du code client,

  2. une barre de fraction,

  3. 5 caractères de la référence client du devis, à partir du 3ème caractère,

  4. un tiret,

  5. un folioteur de longueur fixe (3 caractères) dont la racine est constituée des 5 premiers caractères du code client.

Autre exemple de paramétrage :

CODIF_COMPOSE*TSC_SD_NBC_C***###&*N*

Cette ligne indique que la zone ic_num1 du TSC NBC sur le sous-devis entrera dans la codification du produit.

Pour initialiser la zone mp_param[40] du produit composé avec la valeur alpha 1 du LCO PAL saisi sur l'entité :

REMPLIR_ZONE_COMPOSE*mp_param*LCO_EN_PAL_A**40*

Pour initialiser la zone mp_param[29] du produit composant à la valeur 2 :

REMPLIR_ZONE_COMPOSANT*mp_param*valeur*2*29*

La référence client (le_libpar1) sera renseigné par défaut avec lae référence client du devis (l2_refcli)

REMPLIR_ZONE_COMPOSANT*le_libpar1*l2_refcli*

#CF GPF Génération de produits finis

La génération de produits finis à partir du devis pourra se faire depuis les devis standard et transformateur ainsi que le transfert du devis en commande.

REMARQUE IMPORTANTE

Si le code produit de l'entité de façonnage (PIQ) est le même que celui de l'entête de devis (PIQ, code composé du devis), le code composé ayant déjà été généré, on le récupère et on met à jour l'entité de façonnage avec ce dernier.

La solution consiste à mettre 2 codes produits différents sur l'entête et sur l'entité de façonnage (PIQURE sur l'entête et PIQ sur l'entité, par exemple).

Tout autre code que #CF GPF peut être utilisé. Le type et le code doivent être paramétrés dans les programmes suivants :

  • en alpha2[7,12] du devis standard

  • en alpha2[7,12] de devis_tc (devis transformateur)

  • en alpha3[19,24] de tr_l_devis (transfert du devis en commande)

  • TPR A4[24,29]

La génération de produits finis doit être activée par /

  • l' option -Ogp dans devis_tc

  • l' option -O5 dans tr_l_devis

Valeur alpha 2

#CF GPF A2[1]

Mise à jour fiche article

N Pas de mise à jour (par défaut)

1 Systématique et entière

2 Systématique mais on ne modifie pas les numéros de devis, sous-devis, entité

3 Mise à jour uniquement si le numéro de devis/sous-devis courant est égal au numéro de devis/sous-devis de la fiche

4 Mise à jour uniquement si le numéro de devis courant est égal au numéro de devis de la fiche

5 Systématique et mise à jour du numéro de devis, sous-devis et entité si aucun de ces champs ne sont renseignés sur la fiche

6 Systématique et mise à jour du numéro de devis, sous-devis et entité si l'un de ces champs n'est pas renseigné sur la fiche

7 Mise à jour uniquement si le numéro de devis courant est égal au numéro de devis de la fiche ou si ce dernier n'est pas renseigné (dans ce cas, il prend la valeur du numéro de devis courant)

#CF GPF A2[2]

Génération séquences de lignes de commande (cde4) correspondant aux entités du sous-devis en respectant les appairages - Voir ci-dessous A2[22]

N Pas de génération (par défaut)

O Génération sans confirmation

C Génération avec confirmation

Les valeurs O et C peuvent être contredites par le TPR en ce qui concerne la confirmation.

Le caractère 2 n'est pris en compte que si le caractère 3 = N.

Si le caractère 3 = O ou C, le caractère 2 est forcé à la valeur du caractère 3

#CF GPF A2[3]

Génération nomenclature (nom0) en respectant les appairages - Voir ci-dessous A2[22]

N Pas de génération (par défaut)

O Génération sans confirmation

C Génération avec confirmation

Les valeurs O et C peuvent être contredites par le TPR en ce qui concerne la confirmation.

Les valeurs O et C forcent le caractère 2 à la même valeur : en effet, puisque l'on génère une nomenclature, on devra aussi générer les séquences de lignes de commande.

#CF GPF A2[4]

Mise à jour des codes produits sur tous les sous-devis

O Mise à jour de tous les sous-devis (par défaut)

N Mise à jour du sous-devis en cours uniquement

#CF GPF A2[5]

Génération du composé

N Pas de génération (par défaut)

O Génération sans ouverture de fenêtre

F Génération avec ouverture d'une fenêtre présentant le code généré

#CF GPF A2[6]

Génération des composants

N Pas de génération (par défaut)

O Génération sans ouverture de fenêtre

F Génération avec ouverture d'une fenêtre présentant le code généré

Les valeurs O et F peut être contredites par le TPR.

#CF GPF A2[7]

Sur F30 dans le devis, vérification que le devis est calculé (O/N, N par défaut)

#CF GPF A2[8]

Transfert des TSC de palettisation

O Recopie des TSC de palettisation avec recopie du code palette dans la nomenclature du produit simple généré

N Aucune recopie (par défaut)

T Recopie des TSC de palettisation sans recopie du code palette dans la nomenclature du produit simple généré

#CF GPF A2[9]

Désignation des produits simples

E Entité

D Devis (par défaut)

#CF GPF A2[10]

mp_param[25] de l'article composé qui va être généré

[blanc] On conserve la donnée diverse de l'article de référence.

O L'article composé généré est générique.

N L'article composé généré n'est pas générique.

#CF GPF A2[11]

mp_param[25] des articles composants qui vont être générés

[blanc] On conserve la donnée diverse de l'article de référence.

O Les articles composants générés sont génériques.

N Les articles composants générés ne sont pas génériques.

#CF GPF A2[12]

Valeur figée du mp_param[25] généré pour les articles de type référence multiple (Article générique)

O Article toujours générique

N Article non générique

[Rien] Pas de valeur figée

#CF GPF A2[13]

Génération des références multiples

N Pas de génération (par défaut)

O Génération sans ouverture de fenêtre

F Génération avec ouverture d'une fenêtre présentant le code généré

#CF GPF A2[14]

Ouverture d'écran de saisie d'informations d'article en génération

N Ouverture d'un écran simplifié permettant de modifier uniquement le code produit à générer (par défaut)

O Ouverture d'un écran permettant de saisir des informations complémentaires ainsi que le code article à générer

#CF GPF A2[15]

Dans l'écran permettant de saisir des informations complémentaires ainsi que le code article à générer, initialiser la désignation client par la désignation du devis (nécessite que A2[14] = O)

(O/N, N = Aucune initialisation)

#CF GPF A2[16]

Génération des produits composants en multi-références

O Ne pas générer les produits composants en multi-références

N Génération des produits composants en multi-références (par défaut)

#CF GPF A2[17]

Recopie d'article vers une autre société (O/N, N par défaut)

Voir la note RECOPIE_ART_SOC

#CF GPF A2[18]

Valeur figée du mp_param[25] généré pour les articles de type nomenclature (article générique).

Pour gestion PLV

O Article toujours générique

N Article non générique

[espace] Pas de valeur figée

#CF GPF A2[19]

Génération des composants de nomenclature (fle_nom)

Pour gestion PLV

N Pas de génération (par défaut)

O Génération sans ouverture de fenêtre

F Génération avec ouverture d'une fenêtre présentant le code généré

#CF GPF A2[20]

Ouverture d'écran de saisie d'informations d'article en régénération batch

N Pas d'ouverture d'écran en régénération.
Pour les articles non générés, on prend en compte le paramétrage saisi pour la génération (A2[14])

O Ouverture d'un écran permettant de saisir des informations complémentaires ainsi que le code article à régénérer (A2[14] = O)

R Pas d'ouverture d'écran en régénération.
Régénération seule, les articles non encore générés ne sont pas traités.

#CF GPF A2[21]

Article suivi en stock (C/N/O/Q)

C On conserve le flag article suivi en stock de l'article copié (Valeur par défaut)

N Article non suivi en stock

O Article suivi en stock

Q On demande si l'article est suivi en stock

#CF GPF A2[22]

Vérification de la présence d'enregistrements dans la nomenclature multi-niveaux

O Prendre en compte les caractères 2 et 3 seulement s'il existe des enregistrements dans la nomenclature

N Prendre en compte les caractères 2 et 3 dans tous les cas (par défaut)

#CF GPF A2[23]

Génération du code produit de l'entité (affiche)

N Pas de génération (par défaut)

O Génération sans ouverture de fenêtre

F Génération avec ouverture d'une fenêtre présentant le code généré

#CF GPF A2[24]

Valeur figée du mp_param[25] généré pour les articles de type affiche (Article générique)

O Article toujours générique

N Article non générique

[Rien] Pas de valeur figée

#CF GPF A2[25]

Entité 1 par défaut lors de la génération des PF si la référence n'est pas associée à une entité (O/N, N par défaut)

#CF GPF A2[26]

Alimentation automatique du numéro de plan CAO

E On alimente le numéro de plan CAO avec le code produit généré de l'entité.

N Pas d'alimentation du numéro de plan CAO en automatique.

#CF GPF A2[27]

Lors de la génération des produits finis, dans le cas de la PLV, si le produit source est géré comme un ensemble monté (type M), on force le produit cible à être géré comme un ensemble monté extérieur (type E), sinon, il garde la gestion du produit cible

Activer le forçage ensemble monté extérieur (O/N, O par défaut)

#CF GPF A2[28]

Génération des produits sans quantité (O/N, O par défaut)

Permet de ne pas générer/régénérer les produits associés à une quantité à zéro.

Les couples produit/quantité sont les suivants :

• Produit d'entête de devis (l2_code_prod) et quantité du devis (l2_qtedev)

• Produit d'entité de devis (fi_prod_ent) et quantité d'entité (fi_qteent)

• Produit de ligne de nomenclature (fno_composant) et quantité de nomenclature (fno_quantite)

• Produit référence multiple (de_produit) et quantité de référence (de_quantite)

#CF GPF A2[29]

Accès à la saisie des informations complémentaires après la génération d'un article

G pour les nouveaux articles uniquement (génération)

R pour les articles mis à jour uniquement (régénération)

2 pour tous les articles (génération/régénération)

N pour aucun article (par défaut)

Permet d'accéder à la saisie des informations complémentaires (TSC) après chaque article venant d'être généré (en génération et/ou régénération).

#CF GPF A2[30]

Blocage de la génération des produits finis si le code produit codifié existe déjà

N Aucune vérification de l'existence du code produit codifié

W Vérification et affichage d'un message non bloquant (par défaut)

B Vérification et affichage d'un message bloquant. La génération est interrompue.

C Vérification et demande de confirmation si le code produit codifié existe déjà.
Si la confirmation n'est pas donnée par l'utilisateur, la génération est interrompue.

#CF GPF A2[31]

Ouverture de la saisie des notes après validation de la génération/régénération

G Génération uniquement

R Régénération uniquement

V Création de version uniquement

2 Génération/Régénération

3 Génération/Régénération/Création de version

N Non (par défaut)

Valeur alpha 3

#CF GPF A3[1]

Tenir compte du mp_param[22] du produit composé pour inhiber ou non la création des composants.

O On tient compte du mp_param[22] (par défaut)

i.e. Si le produit composé est un produit simple (mp_param[22] = N), on ne crée pas les composants.

N On ne tient pas compte du mp_param[22] pour l'inhibition des composants.

SOLUTION PROVISOIRE POUR GERER LES ENSEMBLES MONTES COMME DES PRODUITS SIMPLES.

#CF GPF A3[2]

Nouveau mode de fonctionnement dans la recopie des notes du devis vers l'article lors de la génération/régénération des produits finis :

Voir aussi #CF IPF note RECOPIE_NOTES

Suppression des notes sur l'article cible seulement s'il existe des notes à recopier du devis, puis recopie de ces notes.

N.B. : Le fonctionnement actuel (mode de recopie = O) supprime les notes sur l'article, même s'il n'existe aucune note à recopier du devis

Mode de recopie des notes du devis vers l'article

N On ajoute les notes du devis à la suite des notes existantes sur l'article (par défaut)

O On supprime les notes de l'article puis on recopie (les notes sont supprimées sur l'article même si aucune note n'est à recopier du devis)

R On recopie en supprimant les notes de l'article au besoin (les notes ne sont supprimées sur l'article que si au moins une note est à recopier du devis)

X Pas de recopie des notes

#CF GPF A3[3]

Limitation de la recopie des notes

2 ou [blanc] On recopie vers le composé ET les composants

0 On recopie les notes vers le composé

1 On recopie les notes vers les composants

#CF GPF A3[4]

Réinitialisation des données lors de la régénération

N ou [blanc] Seuls les champs paramétrés sont réinitialisés

O On réinitialise aussi le type de l'article généré ainsi que ses données diverses

#CF GPF A3[5]

Mise à jour uniquement pour la fiche de conditionnement (O/N, N par défaut)

#CF GPF A3[6]

Contrôle d'existence de la référence client pour d'autres produits du même client

N Pas de contrôle (par défaut)

W Contrôle avec message non bloquant

B Contrôle avec message bloquant

C Contrôle avec demande de confirmation

#CF GPF A3[7]

Ecrasement des libellés étrangers à la régénération des produits finis

O On écrase systématiquement les libellés étrangers par les valeurs provenant du paramétrage (par défaut).

N On garde systématiquement les libellés étrangers existants sur la fiche produit.

C Lorsque l'on détecte une modification de libellés étrangers, une demande de confirmation propose à l'utilisateur d'écraser les valeurs existantes par les valeurs issues du paramétrage.

Remarque : Si les libellés étrangers ne sont pas renseignés sur la fiche article existante, ils sont automatiquement alimentés par les valeurs issues du paramétrage.

Notes triées

#CC

Contrôle des champs - Utilisé par le devis_tc

5,22 Cliquez ici pour afficher / masquer la liste des champs disponibles, triés par ordre alphabétique.

23 Type de contrôle à faire si le champ n'est pas saisi

N Pas de contrôle (par défaut)

W Contrôle non bloquant

B Contrôle bloquant

I Saisie interdite

Exemples

#CC mp_cs1 I

La saisie du code statistique 1 est interdite, le curseur de saisie ne passera pas sur ce champ.

#CC mp_fam B

La saisie de la famille du produit est obligatoire, la validation de la génération sera impossible tant que ce champ ne sera pas renseigné.

CODE_MAJ_QA_VERSION

21,23 Code validité à mettre en place sur les produits obsolètes après génération d'une nouvelle version de produit

Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.

CODES_NTS_ARTICLE

21,59 Liste des types de notes à ouvrir après validation de la génération/régénération

13 codes NTS par ligne de note

CODE_TARIF

21,23 Code tarif par défaut

CODIF_

Paramétrage de la construction du code produit.

Ces notes sont prises en compte dans leur ordre d'apparition.

La syntaxe est la suivante :

CODIF_Mot clé*Donnée*Début*Longueur*Using*O/N*

Mot clé

AFFICHE Pour les affiches

COMPOSE Code article des composés (désigne le code article lié à fle_2 (l2_code_prod))

COMPOSANT Code article des composants (désigne le code article lié à fle_imp (fi_prod_ent))

REFERENCE Initialisation des références

COMPO_NOM Pour gestion PLV (pour tous les composants de la nomenclature)

Donnée

Vous pouvez choisir parmi les données suivantes :

1) Tout champ des tables fle_2, fle_imp, fle_dec, fle_nom et mat (y compris les champs mg_*)

ainsi que les champs suivants (cliquer ici pour les afficher / masquer)

2) Le mot valeur, qui permet d'indiquer une constante dans le Using.

3) Le mot folio, qui permet de spécifier un folioteur

4) Le mot folio_alpha_cli : folioteur alphanumérique saisi sur le TSC CHC sur le client du devis (fle2.l2_client)

5) Le mot folio_alpha_cligr : folioteur alphanumérique saisi sur le TSC CHC (zone alphanumérique 1 de 3 caractères) sur le client groupe (cli.cl_cligr) rattaché au client du devis (fle2.l2_client). Si aucun client groupe n'est renseigné, on cherche le TSC CHC sur le client du devis.

6) Le mot folio_compose : folio de l'ensemble comme racine du folio des composants

7) Le mot folio_nom : Ce paramétrage fonctionne comme le mot clé folio mais ne crée un nouveau folio que pour les produits de plus haut niveau dans la nomenclature.
Dans le cas des produits composants, le folio est repris de son composé.
Cliquez ici pour afficher / masquer un exemple avec folio_nom.

8) Un TSC ou une LCO, selon le format suivant :

Type_Portée_Code_Zone

Type : TSC ou LCO

Portée : ED pour les devis

SD pour les sous-devis

EN pour les entités (implicitement : entité N° 1)

RD pour les références multiples saisies sur l'entête du devis

RE pour les références multiples saisies sur l'entité du devis (implicitement : entité N°1)

I + numéro de passage sur 2 caractères

Exemples

I01 Ligne d'impression, passage n°1

I10 Ligne d'impression, passage n°10

Code : Code du TSC ou de la LCO

Zone : Code zone du TSC ou de la LCO

9) Le mot indice_client : Folioteur d'indice client forcé à 1 dans la génération des produits, incrémentable via la saisie des articles (génération d'un compteur alphanumérique)

10) Le mot today (élément de la date du jour - voir le using)
Exemple : CODIF_COMPOSE*today**2*yy*O*

Cliquez ici pour afficher / masquer des exemples de paramétrage de l'indice client.

NB : il existe un programme de contrôle des compteurs en cas d'anomalie.

Début

Position du premier caractère à prendre en compte dans Donnée

Longueur

Nombre de caractères à prendre en compte dans Donnée

using

Format d'affichage de Donnée (ou valeur constante)

Si la donnée = today :

dd Jour au format JJ (01, 02, etc.)

mm Mois au format MM (01, 02, etc.)

y Année au format A (9, 10, etc.)

yy Année au format AA (09, 10, etc.)

yyyy Année au format AAAA (2009, 2010, etc.)

O/N

Pour les colonnes folio, folio_nom et indice_client, indique si elles sont de longueur variable (O/N, N par défaut)

Pour les autres colonnes, indique si elle servent à la recherche du folio (O/N, N par défaut)

Cliquez ici pour afficher / masquer des exemples de notes commençant par CODIF_.

COPIE_NTS_

Recopier certaines notes (NTS) de l'article référence générique

Voir aussi la note COP_TSC_NTS_REGENERE.

11,20 Type de produit concerné par la recopie des notes

COMPOSE : Composé (fle_2)

AFFICHE : Affiche (fle_imp)

COMPOSANT : Composant (fle_imp)

REFERENCE : Référence multiple (fle_dec)

COMPO_NOM : Composant de nomenclature (fle_nom)

21,59 Listes des types de notes (NTS) à recopier : 13 codes de 3 caractères par ligne

COPIE_TSC_

Permettre de recopier certaines informations complémentaires (TSC) de l'article référence générique.

Voir aussi la note COP_TSC_NTS_REGENERE.

11,20 Type de produit concerné par la recopie des TSC

COMPOSE Composé (fle_2)

AFFICHE Affiche (fle_imp)

COMPOSANT Composant (fle_imp)

REFERENCE Référence multiple (fle_dec)

COMPO_NOM : Nomenclature (fle_nom)

21,59 Liste des TSC à recopier : 13 codes de 3 caractères par ligne

COP_NTSLI_

Recopie des notes saisies sur les lignes d'impression multiples vers le produit généré

Voir aussi la note COP_TSC_NTS_REGENERE.

11,20 Type de produit concerné par la recopie des notes

AFFICHE : Affiche (fle_imp)

COMPOSANT : Composant (fle_imp)

REFERENCE : Référence multiple (fle_dec)

COMPO_NOM : Composant de nomenclature (fle_nom)

21,60 Liste des couples Type de note source (NTS) et racine du type de note cible (NTS)

8 couples de 3 caractères + 2 caractères maximum

La racine du type de note cible est complétée avec le numéro de passage sur 1 ou 2 caractères selon la longueur de la racine.

Racine sur 1 caractère : Numéro de vernis sur 2 caractères

Exemple avec une racine N

N01, N02, …, N99, N00 (=N100)

Racine sur 2 caractères : Numéro de vernis sur 1 caractère

Exemple avec une racine OB

OB1, OB2, …, OB9, OB0 (=OB10)

IMPORTANT : Dans le cas de vernis multiples pour un même passage, seules les notes saisies au niveau du premier vernis sont prises en compte.

COP_NTSVH_

Recopie des notes saisies sur les vernis hors-lignes vers le produit généré

Voir aussi la note COP_TSC_NTS_REGENERE.

11,20 Type de produit concerné par la recopie des notes

AFFICHE : Affiche (fle_imp)

COMPOSANT : Composant (fle_imp)

REFERENCE : Référence multiple (fle_dec)

COMPO_NOM : Composant de nomenclature (fle_nom)

21,60 Liste des couples Type de note source (NTS) et racine du type de note cible (NTS)

8 couples de 3 caractères + 2 caractères maximum

La racine du type de note cible est complétée avec le numéro de vernis hors-ligne sur 1 ou 2 caractères selon la longueur de la racine.

Racine sur 1 caractère : Numéro de vernis sur 2 caractères

Exemple avec une racine N

N01, N02, …, N99, N00 (=N100)

Racine sur 2 caractères : Numéro de vernis sur 1 caractère

Exemple avec une racine OB

OB1, OB2, …, OB9, OB0 (=OB10)

COP_NTSVS_

Recopie des notes saisies sur les vernis sous-traités vers le produit généré

Voir aussi la note COP_TSC_NTS_REGENERE.

11,20 Type de produit concerné par la recopie des notes

AFFICHE : Affiche (fle_imp)

COMPOSANT : Composant (fle_imp)

REFERENCE : Référence multiple (fle_dec)

COMPO_NOM : Composant de nomenclature (fle_nom)

21,60 Liste des couples Type de note source (NTS) et racine du type de note cible (NTS)

8 couples de 3 caractères + 2 caractères maximum

La racine du type de note cible est complétée avec le numéro de vernis sous-traité sur 1 ou 2 caractères selon la longueur de la racine.

Racine sur 1 caractère : Numéro de vernis sur 2 caractères

Exemple avec une racine N

N01, N02, …, N99, N00 (=N100)

Racine sur 2 caractères : Numéro de vernis sur 1 caractère

Exemple avec une racine OB

OB1, OB2, …, OB9, OB0 (=OB10)

COP_TSC_NTS_REGENERE

Recopie des TSC et des notes en régénération de produits finis

Dans la saisie des devis multi-métiers, permet de recopier les informations complémentaires (TSC) et les notes même en régénération des produits finis.

Remarques

Sont concernées par ce fonctionnement :

o La recopie des informations complémentaires (TSC) (COPIE_TSC_*)

o La recopie des notes (COPIE_NTS_*)

o La recopie des notes des lignes d'impression multiples (COP_NTSLI_*)

o La recopie des notes des vernis hors-lignes (COP_NTSVH_*)

o La recopie des notes des vernis sous-traités (COP_NTSVS_*)

ATTENTION : La recopie écrase les informations actuellement saisies sur l'article à régénérer.

21 Recopie par défaut en régénération pour les éléments non paramétrés spécifiquement (voir ci-dessous)

O Recopie systématique

C Demande de confirmation

N Pas de recopie (par défaut)

22 Recopie des informations complémentaires (TSC) en régénération

O Recopie systématique

C Demande de confirmation

N Pas de recopie (par défaut)

Ce paramétrage est prioritaire à celui saisi en caractère 21

23 Recopie des notes en régénération

O Recopie systématique

C Demande de confirmation

N Pas de recopie (par défaut)

Ce paramétrage est prioritaire à celui saisi en caractère 21

24 Recopie des notes d'impression multiples et/ou vernis en régénération

O Recopie systématique

C Demande de confirmation

N Pas de recopie (par défaut)

Ce paramétrage est prioritaire à celui saisi en caractère 21

DEFAUT_TARIF

21 Prix de vente de la fiche article

O On conserve le prix de vente de la fiche article

N On initialise le prix de vente de la fiche article à null [Valeur par défaut]

Voir aussi la note METHOD_TARIF

DELTA_TARIF

21,25 Indique le delta (quantité) pour les plages de tarif de la méthode Q2

METHOD_TARIF

21,22 Méthode de génération de tarif

Q1 : génère un tarif par variante de quantité

Q2 : génère des plages de tarif

L'absence de ce paramétrage inhibe la génération des tarifs.

Voir aussi la note DEFAUT_TARIF

Le paramétrage REMPLIR_ZONE_COMPOSE*mp_pv…est impératif.

La zone mp_pv du PF est ensuite mise à vide lors de la génération des tarifs

PARAM_SAISIE_TARIF

21,26 Type et code du paramètre de configuration de saisie des tarifs (du type #CF/TA1)

Ce paramétrage permet de gérer l'initialisation des zones :

• Prix net (voir #CF TA1 A3[35])

• Site (voir #CF TA1 A3[57]) (Gestion multi-site uniquement, #CF SIT A1[1] = O) - T ableau de bord du multisite

PRIX_NEGOCIE_TARIF

21 Lors de la génération des tarifs, on prend comme valeur les prix négociés.

S'ils ne sont pas renseignés, on prend par défaut les prix remis.

RECOPIE_ART_SOC

21,26 Type et code du paramètre de la configuration de la recopie d'article vers une autre société

Exemple : #CFRAS

Voir A2[17]

RECOPIE_NOTES

Permet le transfert des notes de l'entité vers l'article généré lors de la génération des produits finis du devis.

14 à 16 Type de note source sur l'entité

17 à 19 Type de note cible sur l'article

ATTENTION : en régénération des PF, les notes sur l'article ne sont pas effacées.

REMPLIR_ZONE_

Paramétrage des zones à remplir dans la fiche produit.

La syntaxe est la suivante :

REMPLIR_ZONE_Mot clé*Zone cible*Zone source*Valeur*Caractère*Ordre

Mot-clé

AFFICHE Pour les affiches

COMPOSE Initialisation des composés

COMPOSANT Initialisation des composants

REFERENCE Initialisation des références

COMPO_NOM Pour gestion PLV

Zone cible

3 types de zones cibles sont possibles :

Type 1) La plupart des champs de la table mat

Type 2) Un TSC article, selon le format suivant :

TSC_Type_Code_Zone

Type : Type de clé - valeurs possibles :

MP Article (valeur par défaut)

MP/CLI Article/Client

MP/ADL Article/Client/Adresse de livraison

Code : Code du TSC

Zone : Code zone du TSC

Type 3) Pour renseigner automatiquement les libellés étrangers disponibles

dans la fenêtre de génération des produits finis (dans le devis_tc) :

le_libpar1 Référence client

le_libelle Libellé client 1

le_libelle2 Libellé client 2

Zone source

Vous pouvez choisir parmi les données suivantes :

1) Tout champ des tables fle_2, fle_imp, fle_dec, fle_nom et mat (y compris les champs mg_*)

ainsi que les champs suivants (voir en bas de cette page).

2) Le mot valeur, qui permet d'indiquer une constante dans la Valeur.

3) Un TSC ou une LCO, selon le format suivant :

Type_Portée_Code_Zone

Type : TSC ou LCO

Portée : ED pour les devis

SD pour les sous-devis

EN pour les entités (implicitement : entité N° 1)

RD pour les références multiples saisies sur l'entête du devis

RE pour les références multiples saisies sur l'entité du devis (implicitement : entité N°1)

I + numéro de passage sur 2 caractères

Exemples

I01 Ligne d'impression, passage n°1

I10 Ligne d'impression, passage n°10

Code : Code du TSC ou de la LCO

Zone : Code zone du TSC ou de la LCO

4) FOR_INDIC_ suivi d'un numéro de formule du tableau des indicateurs du récapitulatif des coûts (Caractères 12 à 13 des notes commençant par _FOR_INDIC du paramètre de lancement du devis standard)

Cette zone source n'est valide que pour les composés. La zone cible doit être mp_pr.

Exemple

REMPLIR_ZONE_COMPOSE*mp_pr*FOR_INDIC_18*

Valeur

Permet d'indiquer une constante si Zone source contient le mot valeur.

Non applicable aux zones cibles de type 3

Caractère

Si Zone cible contient mp_param, permet d'indiquer le caractère concerné.

Non applicable aux zones cibles de type 3

Ordre

Numéro d'ordre de recherche pour la valeur source

Tant qu'aucune valeur n'est trouvée, on boucle sur les numéros d'ordre trouvés pour la zone cible courante.

Exemples

REMPLIR_ZONE_REFERENCE*TSC_MP_FE2_G*TSC_RE_FE2_G***1*

REMPLIR_ZONE_REFERENCE*TSC_MP_FE2_G*LCO_EN_FE2_M***2*

Le but du paramétrage ci-dessus est de renseigner par lecture en cascade le TSC FE2 (zone de 30 caractères).

Si une valeur est trouvée sur le TSC FE2 situé sur la ligne de référence, on renseigne le TSC FE2 de l'article avec, sinon on le renseigne avec la valeur de la LCO FE2 située sur l'entité.

Cliquez ici pour afficher / masquer des exemples de notes commençant par REMPLIR_ZONE_.

_SUP_REQ_REF_CLI

21,60 Complément de recherche des références existantes portant sur les tables lib_etr et mat

Lors de la génération des produits par le devis, il est possible de paramétrer un contrôle d'existence de la référence client au sein des libellés étrangers.

Pour que l'on puisse décider si on doit tenir compte ou non des articles annulés logiquement, ce complément de requête sur la recherche des libellés existants.

_SUP_SQL_MAT_NOTES

21,60 Complément de sélection sur la table des articles (mat) pour l'ouverture de l'écran de saisie des notes après validation de la génération/régénération

Exemple : n'ouvrir l'écran que pour les articles dont la famille est PF :

and mp_fam = "PF"

Zones sources disponibles pour la note REMPLIR_ZONE_

code_plaque | Code plaque Transfert du code papier uniquement s'il est non générique (mp_param[25] = N)
coupe_nette_plaque | Coupe nette plaque
ens_de_ (zones commençant par) | Toutes les zones de la référence d'ensemble associé au produit en cours. Si aucune référence d'ensemble trouvée, on prend les informations de la première référence définie sur l'entité courante (équivalent du préfixe ref_de_)
fi_entite_lettre | = A si fi_entite = 1 = B si fi_entite = 2 etc.
fi_lar_tir_O fi_lar_tir_N fi_lar_tir_I | Largeur du format de tirage si le respect du sens papier est à O Largeur du format de tirage si le respect du sens papier est à N Largeur du format de tirage si le respect du sens papier est à I Voir remarque et exemples sous ce tableau.
fi_lar_tir_X10 fi_lar_tir_X10_O fi_lar_tir_X10_N fi_lar_tir_X10_I | Format de tirage sens travers X 10 Largeur du format de tirage multipliée par 10 si le respect du sens papier est à O Largeur du format de tirage multipliée par 10 si le respect du sens papier est à N Largeur du format de tirage multipliée par 10 si le respect du sens papier est à I Voir remarque et exemples sous ce tableau.
fi_lon_tir_O fi_lon_tir_N fi_lon_tir_I | Longueur du format de tirage si le respect du sens papier est à O Longueur du format de tirage si le respect du sens papier est à N Longueur du format de tirage si le respect du sens papier est à I Voir remarque et exemples sous ce tableau.
fi_lon_tir_X10 fi_lon_tir_X10_O fi_lon_tir_X10_N fi_lon_tir_X10_I | Format de tirage sens machine X 10 Longueur du format de tirage multipliée par 10 si le respect du sens papier est à O Longueur du format de tirage multipliée par 10 si le respect du sens papier est à N Longueur du format de tirage multipliée par 10 si le respect du sens papier est à I Voir remarque et exemples sous ce tableau.
fi_pli_principal | Code pli principal de l'entité
fi_pli_second_1 | Code pli secondaire 1 de l'entité
fi_pli_second_2 | Code pli secondaire 2 de l'entité
fi_pli_second_3 | Code pli secondaire 3 de l'entité
fi_pli_second_4 | Code pli secondaire 4 de l'entité
fi_pli_second_5 | Code pli secondaire 5 de l'entité
laize_nette_plaque | Laize nette plaque
marge_px_achat | Marge sur le prix d'achat
marge_px_negocie | Marge sur prix négocié
marge_px_remis | Marge sur prix remis
marge_px_vente | Marge sur prix de vente
nb_morceaux_fefco | Nombre de morceaux du FEFCO
poids_uni_brut_gr | Poids unitaire brut du produit en grammes (utile pour le TSC 201)
poids_uni_brut_kg | Poids unitaire brut du produit en kg (utile pour mp_poids)
poids_uni_net_gr | Poids unitaire net du produit en grammes (utile pour le TSC 202)
poids_uni_net_kg | Poids unitaire net du produit en kg (utile pour mp_poids)
pointages | Transfert des pointages sur le PF. Zone cible non utilisée.
pr_mat_mille | Coût matière au mille
pr_ope_mille | Coût opération au mille
pr_str_mille | Coût sous-traitance au mille
pr_trs_mille | Coût transport au mille
px_pr_unite_dev | Prix de revient dans l'unité du sous-devis
px_pv_unite_dev | Prix de vente dans l'unité du sous-devis
qualite_generique | Si le code papier est générique (mp_param[25] = O), alors il est renvoyé comme étant la qualité matière. Vérifiez aussi #CF SMC alpha1[12].
Les zones commençant par ref_de_ ref_marge_px_negocie ref_marge_px_remis ref_marge_px_vente ref_px_pr_unite_dev ref_px_pv_unite_dev | Toutes les zones de la première référence (fle_dec.*) définie sur l'entité en cours ainsi que les 5 zones suivantes : Marge sur prix négocié de la première référence Marge sur prix remis de la première référence Marge sur prix de vente de la première référence Prix de revient dans l'unité du devis de la première référence Prix de vente dans l'unité du devis de la première référence
som_poids_uni_brut_gr | Poids unitaire brut du composé en grammes
som_poids_uni_brut_kg | Poids unitaire brut du composé en kilos
som_poids_uni_net_gr | Poids unitaire net du composé en grammes
som_poids_uni_net_kg | Poids unitaire net du composé en kilos
som_surf_uni_brute_m2 | Surface unitaire brute du composé en m2
som_surf_uni_nette_m2 | Surface unitaire nette du composé en m2
surf_uni_brute_m2 | Surface unitaire brute du produit en m2 (utile pour le TSC 201)
surf_uni_nette_m2 | Surface unitaire nette du produit en m2 (utile pour le TSC 202)

A propos des zones fi_lar_tir_xxx et fi_lar_tir_xxx

Pour ces zones sources, la valeur est récupérée et mise en place dans la zone cible uniquement si la condition est vérifiée.

Exemples

REMPLIR_ZONE_ENTITE*TSC_MP_TIR_A*fi_lar_tir_O*

REMPLIR_ZONE_ENTITE*TSC_MP_TIR_B*fi_lon_tir_O*

REMPLIR_ZONE_ENTITE*TSC_MP_TIR_B*fi_lar_tir_N*

REMPLIR_ZONE_ENTITE*TSC_MP_TIR_A*fi_lon_tir_N*

Si le respect du sens papier est à O :

• La largeur du format de tirage va dans la première zone numérique de la TSC TIR.

• La longueur du format de tirage va dans la deuxième zone numérique de la TSC TIR.

Si le respect du sens papier est à N :

• La largeur du format de tirage va dans la deuxième zone numérique de la TSC TIR.

• La longueur du format de tirage va dans la première zone numérique de la TSC TIR.

Zones sources disponibles (suite) : Accès aux données des vernis et lignes d'impressions multiples

A partir de l'entité, on peut accéder aux données suivantes de la table fle_combi :

• Vernis hors-ligne (type d'enregistrement = 1), en remplaçant le préfixe fco_ par VHL_

• Vernis sous-traité (type d'enregistrement = 2), en remplaçant le préfixe fco_ par VST_

• Lignes d'impressions multiples (type d'enregistrement = 3), en remplaçant le préfixe fco_ par LIM_

Les zones de ce tableau sont triées par ordre alphabétique.

La zone... |  | ... est utilisable en la préfixant de :
bascule | Présence de bascule |  |  | LIM_
cgt_r_rv | Nombre de repiquages |  |  | LIM_
cgt_rv | Nombre de changement de plaques recto/verso |  |  | LIM_
cgt_teinte_rv | Nombre de changement de teintes recto/verso |  |  | LIM_
couleur_rv | Nombre de couleurs recto/verso |  |  | LIM_
devis | Numéro de devis | VHL_ | VST_ | LIM_
enc_rv | Pourcentage d'encre recto/verso |  |  | LIM_
entite | Numéro d'entité | VHL_ | VST_ | LIM_
fournisseur | Code du sous-traitant | VHL_ | VST_ |
mac_forcee_rv | Machine forcée recto/verso |  |  | LIM_
mac_imp | Machine d'impression recto/verso |  |  | LIM_
mac_ve_recto | Code machine de vernissage au recto | VHL_ | VST_ |
mac_ve_verso | Code machine de vernissage au verso | VHL_ | VST_ |
nb_cl_commune | Nombre de couleurs communes entre recto et verso |  |  | LIM_
nb_teintes_rv | Nombre de recherches de teintes recto/verso |  |  | LIM_
num_pass | Numéro de passage (99 pour les vernis VHL et VST) | VHL_ | VST_ | LIM_
num_vernis | Numéro de vernis (1 pour les vernis VHL et VST) | VHL_ | VST_ | LIM_ l
pr_rv | Nombre de couleurs primaires |  |  | LIM_
quadri_rv | Présence de quadrichromie recto/verso |  |  | LIM_
recto_verso | Ligne d'impression recto/verso/les deux |  |  | LIM_
sdevis | Numéro de sous-devis | VHL_ | VST_ | LIM_
type | Type d'enregistrement 1 pour les vernis hors-ligne (VHL) 2 pour les vernis sous-traités (VST) 3 pour les lignes d'impression multiples (LIM) | VHL_ | VST_ | LIM_
type_passage | Type de ligne/passage impression |  |  | LIM_
type_vernis_r | Code de vernis recto | VHL_ | VST_ | LIM_ l
type_vernis_v | Code de vernis verso | VHL_ | VST_ |
ve_recto | Coefficient de vernissage au recto | VHL_ | VST_ | LIM_ l
ve_verso | Coefficient de vernissage au verso | VHL_ | VST_ |

Pour les lignes d'impressions multiples (zones préfixées LIM_)

Le numéro de passage peut être précisé. Par défaut, il est égal à 1 (premier passage). Valable pour toutes les zones.

Le numéro de vernis peut être précisé. Par défaut, il est égal à 1 (première ligne de vernis). Valable pour les zones marquées l

Pour ce faire, il suffit d'ajouter à la suite du nom de champ source les numéros séparés par des slashes.

Exemples

LIM_ve_recto/2/3 : Coefficient de vernissage du troisième vernis du deuxième passage

LIM_ve_recto//3 : Coefficient de vernissage du troisième vernis du premier passage

(le numéro de passage n'est pas précisé, il est donc égal à 1).

LIM_nb_cl_commune/2 : Nombre de couleurs communes entre le recto et le verso pour le deuxième passage

(le numéro de vernis n'est pas précisé, il est donc égal à 1)

LIM_mac_imp : Code machine du premier passage

(le numéro de passage et le numéro de vernis ne sont pas précisés, ils sont donc égaux à 1)


#CF HIS Historique du prix de revient

Si le paramètre de lancement de hipr est #ED HIS, alors le paramètre associé devra être #CF HIS.

Autrement dit, le code du paramètre de configuration doit être identique au code du paramètre de lancement de l'édition.

Valeur alpha 1

Caractères 1 à 60

Codage des colonnes de l'état

Par défaut, 13 colonnes : ACDEHIPQRSTUV

A Numéro de commande

B Numéro de ligne de commande

C Date clôture

D Code client

E Nom du client

F Code département

G Code représentant

H Références

I Code produit

J Code famille

K Libellé court de la famille

L Libellé long de la famille

M Code sous-famille

N Libellé court de la sous-famille

O Libellé long de la sous-famille

P Zone paramétrée 1

Q Zone paramétrée 2

R Zone paramétrée 3

S Zone paramétrée 4

T Zone paramétrée 5

U Zone paramétrée 6

V Zone paramétrée 7

W Zone paramétrée 8

X Zone paramétrée 9

Y Zone paramétrée 10

Z Zone paramétrée 11

a Zone paramétrée 12

b Zone paramétrée 13

c Zone paramétrée 14

d Zone paramétrée 15

e Date commande

f Libellé produit

g Libellé commande

h Commande soldée ou ligne de commande soldée

i Nom abrégé du représentant

j Nom entier du représentant

k Zone paramétrée de l'entête de commande

l Zone paramétrée 16 (type d'historique G)

m Zone paramétrée 17 (type d'historique G)

n Zone paramétrée 18 (type d'historique G)

o Zone paramétrée 19 (type d'historique G)

p Zone paramétrée 20 (type d'historique G)

q Zone paramétrée 21 (type d'historique G)

r Zone paramétrée 22 (type d'historique G)

s Zone paramétrée 23 (type d'historique G)

t Zone paramétrée 24 (type d'historique G)

u Zone paramétrée 25 (type d'historique G)

v Zone paramétrée 26 (type d'historique G)

w Zone paramétrée 27 (type d'historique G)

x Zone paramétrée 28 (type d'historique G)

y Zone paramétrée 29 (type d'historique G)

z Zone paramétrée 30 (type d'historique G)

0 Zone calcul 1

1 Zone calcul 2

2 Zone calcul 3

3 Zone calcul 4

4 Zone calcul 5

5 Zone calcul 6

6 Zone calcul 7

7 Zone calcul 8

8 Zone calcul 9

9 Zone calcul 10

& Première ligne de note

_ Libellé produit

é Longueur produit

è Largeur produit

à Hauteur produit

( zone alphanumérique 1 de l'historisation (hp_a1)

) Date paramétrée de l'historisation (hp_d1)

[ Code adresse de livraison historisée (hp_cl2)

ç autorise l'affichage de la commande date de solde

(applicable aux autres codes paramètres)

] Code statistique 1 (mp_cs1)

# Code statistique 2 (mp_cs2)

{ Code statistique 3 (mp_cs3)

} Code statistique 4 (mp_cs4)

Valeur alpha 2

Titre de l'état

Par défaut : HISTORIQUE DES PRIX DE REVIENT

Valeur alpha 3

Paramétrage des tris, des ruptures et des sauts de page

Caractère 1 | Critère de tri 1 Par commande et ligne de commande (valeur par défaut) 2 Par client, commande et ligne de commande 3 Par représentant, client, commande et ligne 4 Par famille, sous-famille, client, commande et ligne 5 Par client, zone par. et commande 6 Par date de commande, commande et ligne de commande 7 Par produit, commande et ligne de cde 8 Tri libre. Voir la note TRI_LIBRE 9 Par zone alphanumérique 1, commande et ligne de commande
Caractère 2 | Edition d'une ligne de totalisation par commande O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 3 | Edition d'une ligne de totalisation par client O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 4 | Edition d'une ligne de totalisation par représentant O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 5 | Edition d'une ligne de totalisation par famille O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 6 | Edition d'une ligne de totalisation par sous-famille O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 7 | Edition d'une ligne de totalisation par zone paramétrée sur l'entête de commande O Détail + totalisation (par défaut) N Pas de détail D Détail seul
Caractère 8 | Edition d'une ligne de totalisation par produit O Détail + totalisation (par défaut) N Pas de détail D Détail seul Exemples 3OOONNNN Ligne de totalisation au changement de commande, client, ou représentant 3NNONNNN Ligne de totalisation au changement de représentant Remarque La zone que l'on veut voir totalisée doit être contenue dans l'ordre de tri choisi. Exemple : Si l'on veut éditer une ligne de totalisation par client, les tris possibles sont 2, 3 et 4.
Caractère 9 | Edition d'une ligne de totalisation par zone alphanumérique 1 O Détail + totalisation (par défaut) N Pas de détail D Détail seul
 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 21 | Type de la zone alphanumérique 1 1 Code machine
 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractère 30 | Edition d'un saut de page par commande (O/N, N par défaut)
Caractère 31 | Edition d'un saut de page par client (O/N, N par défaut)
Caractère 32 | Edition d'un saut de page par représentant (O/N, N par défaut)
Caractère 33 | Edition d'un saut de page par sous-famille (O/N, N par défaut)
Caractère 34 | Edition d'un saut de page par famille (O/N, N par défaut)
Caractère 35 | Edition d'un saut de page par zone paramétrée (O/N, N par défaut)
Caractère 36 | Edition d'un saut de page par produit (O/N, N par défaut)
Caractère 37 | Edition d'un saut de page par zone alphanumérique 1 (O/N, N par défaut)
 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 51 à 60 | Types d'historique. Valeurs possibles : G H I Valeur par défaut : G si utilisation d'une des zones paramétrées 16 à 30. Valeur par défaut : GH si type G et utilisation d'une des zones !?#>@$ç():[]%=< G si pas type G et utilisation d'une des zones !?#>@$ç():[]%=<

Valeur alpha 4

Caractères 1 à 60

Type de cumul à appliquer à la colonne située sur le même caractère en zone alpha 1.

C Cumul traditionnel [Valeur par défaut]

M Moyenne

O Cumul traditionnel (ancienne codification)

N Pas de cumul (ancienne codification)

B Pas de cumul

/ On divise la donnée historisée paramétrée en zc1 par celle paramétrée en zc2 sur le paramètre ZHF associé à la colonne

* On multiplie la donnée historisée paramétrée en zc1 par celle paramétrée en zc2 sur le paramètre ZHF associé à la colonne

% On calcule le pourcentage entre la donnée historisée paramétrée en zc1 par celle paramétrée en zc2 sur le paramètre ZHF associée à la colonne.

Attention : Si des opérandes sont paramétrées sur le paramètre ZHF associé à la colonne, le cumul traditionnel sera remplacé par un calcul de pourcentage.

Notes triée

C | 2 à 11 Titre de la colonne 11 à 60 Formule de calcul Exemple PQ+ = zone paramétrée 1 historique F + zone paramétrée 2 historique F.
PAR | Possibilité de paramétrer le nom, le using et la largeur des colonnes dans les notes 4 à 21 Type de colonne (A, B, C, etc.) 22 à 39 Nom de la colonne 40 à 57 using de la colonne (Exemple ### ### ##&) (facultatif) 58 à 59 Largeur de la colonne (facultatif)
S | 2 à 60 Complément de sélection Exemple and hp_cli !=
TRI_LIBRE | Permet d'afficher le détail des lignes triées par paramétrage Cette note est prise en compte si A3[1] = 8. 21,60 Chaîne de caractères devant suivre l'instruction order by Exemple : hp_z1, hp_z2 desc, hp_client Par défaut : (hp_cde, hp_lig)
VALEUR_DEF_ZP_ | Types d'historiques à afficher (paramétrage zones à zones) 15 Caractère symbolisant la colonne (voir paramétrage zone Alpha1) 21 Type d'historique 23 Z (pour Zone historisée) 24 à 25 Numéro de la zone historisée (de 1 à 15) Exemple Pour afficher la valeur de la zone historisée n°9 du type d'historique M dans la colonne zone paramétrée 21, il faudra paramétrer la ligne de note comme suit car 1 15 21 25 +-------------+-----+---+--... VALEUR_DEF_ZP_q M_Z9
_Z_PRIX_REV_UNI | Paramétrage des zones de l'historique des prix de revient 21 Type d'enregistrement des données F (zones 1 à 15) (par défaut) G (zones 16 à 30) 22 à 24 Code de la zone de la table hist_pr, représentant le prix de revient unitaire, qui sera utilisé pour calculer le prix de revient unitaire de la fiche article. Défaut : Z12
_Z_PRIX_REVIENT | 21 Type d'enregistrement des données F (zones 1 à 15) (par défaut) G (zones 16 à 30) 22 à 24 Code de la zone de la table hist_pr, représentant le prix de revient global, qui sera utilisé pour calculer le prix de revient unitaire de la fiche article. Défaut : Z11
_Z_QUANTITE_CDE | 21 Type d'enregistrement des données F (zones 1 à 15) (par défaut) G (zones 16 à 30) 22 à 24 Code de la zone de la table hist_pr, représentant la quantité commandée, qui sera utilisé pour calculer le prix de revient unitaire de la fiche article. Défaut : Z1


#CF IMP Priorité des imprimantes

Ce paramétrage permet de définir l'ordre de sélection des imprimantes dans VOLUME

P Imprimante programme (chx_perif)

U Imprimante user

X Imprimante paramètre (X sur paramètre de lancement)

Valeur alpha1

Caractères 1 à 3

Mettre les lettres des imprimantes dans l'ordre voulu pour la sélection. Paramétrage par défaut : PUX

P On recherche d'abord l'imprimante programme (définie en dur dans le code – Voir #LP)

U Si on ne la trouve pas, on recherche l'imprimante utilisateur (-x)

X Si on ne la trouve pas, on recherche l'imprimante du paramètre de lancement (-X)

En dernier recours, on recherche l'imprimante par défaut (#LP DEF)


#CF INV Inventaire

Valeur alpha 1

Caractère 1

Mode de gestion des inventaires par environnement activé (O/N)


#CF IPF Intégration de produit fini

NE PAS UTILISER AVEC LES PRODUITS GENERIQUES !

TRES IMPORTANT : Mettre à jour le TSC Type d'entité sur le code produit. Ce TSC (070, zone ic_char3_2) permet de créer l'entité.

L'appellation du paramètre est libre : #CF IPF peut être remplacé par toute autre type / code.

Ce paramètre est lu par le programme devis_standard.

Les type et code du paramètre de configuration d'intégration des produits finis sont récupérés dans l'ordre suivant :

1. TPR A4[50,55]

2. Devis standard, paramètre de lancement, A2[13,18]

3. par défaut, #CF IPF

Valeur alpha 1

Caractère 1

En modification, ouverture d'un écran de vérification d'intégration des données.

Cet écran affiche les données qui seront mises à jour ainsi que leurs valeurs associées et permet ainsi de sélectionner les champs à mettre à jour.

O Ouverture de l'écran (par défaut)

N Pas d'ouverture d'écran, les données sont mises à jour dans le devis automatiquement.

Caractère 2

Alimentation du devis par les informations du produit (non générique)

O Le pré-chargement des informations de base et la mise à jour via le paramétrage #CF IPF sont faits systématiquement.

N Le pré-chargement des informations de base est fait systématiquement. La mise à jour via le paramétrage #CF/IPF n'est jamais faite.

C Le pré-chargement des informations de base est fait systématiquement. La mise à jour via le paramétrage #CF/IPF est faite par demande de confirmation (par défaut)

P Le pré-chargement des informations de base n'est jamais fait. La mise à jour via le paramétrage #CF/IPF est faite systématiquement.

Q Le pré-chargement des informations de base et la mise à jour via le paramétrage #CF/IPF sont faits par demande de confirmation.

R Identique à C, mais mémorise la réponse dans le cas de la validation de la nomenclature pour ne répondre qu'une fois à la question.

L'activation/désactivation du pré-chargement est indépendant de l'option d'activation de l'intégration des données à partir de la fiche produit Opf.

Caractère 3

Lors de la saisie d'un PF d'une référence multiple, comment intégrer les données des PF

S les intégrer uniquement sur la saisie des références multiples au niveau de l'entête (sous-devis)

E les intégrer uniquement sur la saisie des références multiples au niveau des entités

2 les intégrer sur la saisie des références multiples au niveau de l'entête et des entités (par défaut)

Caractère 4

Méthode d'intégration des données des produits finis sur l'entête des devis

S Intégration uniquement à partir de l'écran d'entête des devis

2 Intégration quelle que soit l'origine : entête et/ou entité (par défaut)

Caractère 5

Méthode d'intégration des données des produits finis sur l'entité des devis

E Intégration uniquement à partir de l'écran d'entités des devis

2 Intégration quelle que soit l'origine : entête et/ou entité (par défaut)

Notes

RECOPIE_NOTES

Lors de l'intégration des produits finis, permettre de recopier les notes de l'article vers le devis

Voir aussi #CF GPF A3[2]

La recopie se fait selon la règle suivante :

• Intégration de l'article de l'entête du devis : Notes sur l'entête du devis

• Intégration d'un article d'entité du devis : Notes sur l'entité du devis

• Intégration d'un article référence du devis : Notes sur la référence du devis

21,23 Type de note source (article)

24,26 Type de note cible (devis/entité/référence)

27 Recopie des notes sur l'entête du devis lors de l'intégration du produit d'entête

N Pas de recopie des notes

C Recopie des notes uniquement s'il n'en existe pas déjà sur l'entête du devis (par défaut)

A Recopie des notes en mode Annule et remplace (les notes sur l'entête du devis sont supprimées s'il existe des notes à recopier de l'article)

28 Recopie des notes sur l'entité du devis lors de l'intégration d'un produit d'entité

N Pas de recopie des notes

C Recopie des notes uniquement s'il n'en existe pas déjà sur l'entité du devis (par défaut)

A Recopie des notes en mode Annule et remplace (les notes sur l'entité du devis sont supprimées s'il existe des notes à recopier de l'article)

29 Recopie des notes sur la ligne de référence du devis lors de l'intégration d'un produit référence

N Pas de recopie des notes

C Recopie des notes uniquement s'il n'en existe pas déjà sur la ligne de référence du devis (par défaut)

A Recopie des notes en mode Annule et remplace (les notes sur la ligne de référence du devis sont supprimées s'il existe des notes à recopier de l'article)

REMPLIR_ZONE_

14,20 Table cible - N'oubliez pas l'astérisque

ENTETE* Devis / Sous-devis

ENTITE* Entité

REFMUL Référence multiple

21, 60 Paramétrage sous la forme suivante : ZC*ZS*VAL*CAR*MAJ*ART*

ZC Zone cible : voir tableau plus bas

ZS Zone source : voir tableau plus bas

VAL Valeur fixe

CAR Caractère

MAJ Mise à jour par défaut (O/N)

ART Article à prendre en compte (nouveau paramètre)

Permet de définir le code article à prendre en compte pour la zone source.

Valeurs possibles :

PFD Article Devis/Entité (facultatif, par défaut)I

MP Article Impression

PAL Article Palettisation

DEC Article Découpe

PFE Produit fini de l'entité courante ou de la première entité trouvée sur le sous-devis courant

QMA Code qualité matière

Selon la table cible (ENTETE/ENTITE), c'est soit le produit du devis, soit le produit fini de l'entité qui est pris en compte.

Si on force la mise à jour du code produit de l'entité, la note correspondante doit se trouver en FIN de paramétrage :

Exemple

REMPLIR_ZONE_ENTITE*fi_prod_ent*l2_code_prod***

Exemples

REMPLIR_ZONE_ENTITE*fi_co_recto*TSC_XX_COR_C****IMP*

Le nombre de couleurs recto (fi_co_recto) doit être mis à jour avec le contenu de la zone numérique 1 (C) du TSC COR sur l'article d'impression.

L'article d'impression sera recherché par la zone de TSC (définie par le CIC C23) sur le produit fini saisi sur l'entité (fi_prod_ent)

REMPLIR_ZONE_ENTITE*fi_num_forme*mp_code****DEC*

Le code outil (fi_num_forme) doit être mis à jour avec le code article de découpe.

L'article de découpe sera recherché par la zone de TSC (définie par le CIC C01) sur le produit fini saisi sur l'entité (fi_prod_ent)

REMPLIR_ZONE_ENTITE*fi_d_entite*mp_des****

ou

REMPLIR_ZONE_ENTITE*fi_d_entite*mp_des****PFD*

La désignation de l'entité (fi_d_entite) doit être mise à jour avec la désignation du produit fini de l'entité (mp_des).

REMPLIR_ZONE_REFMUL*de_largeur*mp_lar****

REMPLIR_ZONE_REFMUL*de_longueur*mp_lon*****

REMPLIR_ZONE_REFMUL*de_cs1*mp_cs1***

REMPLIR_ZONE_REFMUL*de_cs2*mp_cs2****

REMPLIR_ZONE_REFMUL*de_designation*mp_des****

REMPLIR_ZONE_REFMUL*de_nb_teintes*TSC_XX_IVC_C****

Remarques importantes

Une fois une ligne de note paramétrée pour mettre à jour un code produit, les lignes suivantes seront mises à jour avec le nouveau code produit correspondant (voir exemple ci-dessous).

Les codes produits possibles sont uniquement les 3 définis ci-dessus (il est interdit d'utiliser le mot-clé mp_code)

REMPLIR_ZONE_ENTETE*l2_desdev1*mp_des****

Mise à jour de la désignation 1 du devis avec la désignation 1 du produit saisi sur l'entête de devis

REMPLIR_ZONE_ENTETE*l2_desdev2*mp_des2****

Mise à jour de la désignation 2 du devis avec la désignation 2 du produit saisi sur l'entête de devis

REMPLIR_ZONE_ENTITE*fi_prod_ent*l2_code_prod****

Mise à jour du produit de l'entité avec le produit saisi sur l'entête de devis

REMPLIR_ZONE_ENTITE*fi_d_entite*mp_des****

Mise à jour de la désignation de l'entité avec la désignation 1 du produit saisi sur l'entête de devis

REMPLIR_ZONE_ENTITE*fi_ecma*mp_afnor****

Mise à jour du code ECMA/FEFCO de l'entité avec le code ECMA/FEFCO du produit saisi sur l'entête de devis

Zone cible : zone à mettre à jour. Plusieurs possibilités :

table fle_2 pour l'entête : Voir plus bas les zones cibles utilisables dans la table fle_2

table fle_imp pour les entités : Voir plus bas les zones cibles utilisables dans la table fle_imp

table fle_com pour les LCO (sur entête et/ou entités)

Découpage du paramétrage des LCO cibles : LCO_XX_YYY_Z
LCO | Mot clé
XX | LCO rattachée au sous devis (SD) ou à l'entité (EN)
YYY | Code de la LCO
Z | Zone cible de la LCO. Valeurs possibles : M fc_matiere N fc_machine O fc_ope P fc_sop S fc_sec 1 fc_v1 2 fc_v2 A fc_a1 B fc_a2 D fc_dif F fc_fournisseur
Exemple : LCO_SD_JL1_1 zone fc_v1 du TSC JL1 rattaché au sous-devis (entête du sous-devis)

table fle_dec pour les références multiples : de_produit Code produit référence multiple

table info_c pour les TSC (sur entête ou entités)

Découpage du paramétrage des TSC cibles : TSC_XX_YYY_Z
TSC | Mot clé
XX | Origine du TSC SD Sous-devis EN Entité du devis RE Référence multiple (entête) RF Référence multiple (entité) Si les informations complémentaires des références multiples doivent être identiques au niveau de l'entête du devis et au niveau de l'entité, les deux origines (RE/RF) doivent être paramétrées.
YYY | Code du TSC
Z | Zone cible du TSC
Exemple : TSC_SD_201_D : zone numérique 2 du TSC 201 rattaché au sous-devis (entête du sous-devis)

Autres zones

car_de_braille Présence de braille associée à la valeur alphanumérique source

car_de_dorure Présence de dorure associée à la valeur alphanumérique source

car_de_fenetrage Présence de fenêtrage associée à la valeur alphanumérique source

car_de_foulage Présence de foulage associée à la valeur alphanumérique source

car_de_gaufrage Présence de gaufrage associée à la valeur alphanumérique source

car_de_hologramme Présence d'hologramme associée à la valeur alphanumérique source

car_de_rainage Présence de rainage associée à la valeur alphanumérique source

car_de_transfert Présence de transfert associée à la valeur alphanumérique source

car_de_vignette Présence de vignette associée à la valeur alphanumérique source

Zone source : zone à copier. Plusieurs possibilités :

1) table fle_2 pour l'entête : l2_code_prod Code produit de l'entête

2) table fle_imp pour les entités : fi_prod_ent Code produit de l'entité

3) table fle_dec pour les références multiples : de_produit Code produit référence multiple

4) table mat récupération de tous les champs possibles SAUF mp_code, avec les champs suivants :

des_mp_qualite_mat : Désignation de la qualité matière (produit : mat dans f_zone)

des_mg_qualite_mat : Désignation de la qualité matière (matière générique : mat_gen dans f_zone)

5) table info_c pour les TSC (toujours rattaché au produit fini) :

Paramétrage des TSC sources: TSC_XX_YYY_Z
TSC | Mot clé
XX | inutilisé ici
YYY | Code du TSC
Z | Zone à récupérer du TSC
Exemple : TSC_XX_201_D : zone numérique 2 du TSC 201 rattaché au produit fini

6) table lib_etr : Le code client pris en compte est celui du produit en cours d'intégration.

le_libelle Libellé spécifique 1

le_libelle2 Libellé spécifique 2

le_libpar1 Référence client

7) TSC sous la forme TSC_XX_YYY_Z avec :

XX Origine du TSC :

SD Sous-devis

EN Entité

RE Référence multiple (entête)

RF Référence multiple (entité)

MP Article (par défaut

Zones cibles utilisables dans la table fle_2

l2_code_prod | Code produit de l'entête
l2_dossier | Numéro de dossier
l2_etude | Code étude
l2_nb_references | Nombre de références
l2_num_cahier | Numéro de cahier des charges
l2_num_conception | Numéro de conception
l2_num_forme | Numéro de forme
l2_num_plan_cao | Numéro de plan CAO
l2_tol_maxi | Tolérance de quantité maximum
l2_tol_mini | Tolérance de quantité minimum
l2_transporteur | Code transporteur
l2_type_prod | Type de produit
l2_zchr1 | Zone paramétrable alphanumérique 1
l2_znum1 | Zone paramétrable numérique 1
l2_zpar2 | Zone paramétrable code 2

Zones cibles utilisables dans la table fle_imp

Dans l'ordre alphabétique des noms de zone.

fi_bascule

fi_blanc_barbe

fi_blanc_pied

fi_blanc_pli

fi_blanc_tete

fi_bord_max

fi_bord_min

fi_c_papier

fi_cgt_r

fi_cgt_r_r

fi_cgt_teinte_r

fi_cgt_teinte_v

fi_cgt_v

fi_cgt_v_r

fi_co_recto

fi_co_verso

fi_code_gamme

fi_collage

fi_couleur_pap

fi_coupe_dec

fi_coupe_plaq_net

fi_cs1

fi_cs2

fi_cs3

fi_cs4

fi_d_entite

fi_d_papier

fi_depassant

fi_dorure

fi_ecma

fi_enc_r

fi_enc_v

fi_fam

fi_fini_dblc

fi_fini_dblc_max

fi_fini_dblc_min

fi_fini_par1

fi_fini_par2

fi_foulage

fi_gaufrage

fi_grammage

fi_grattage

fi_hau_fini

fi_laize_dec

fi_laize_plaq_net

fi_lar_fini

fi_lar_ouv

fi_lar_papier

fi_lar_tir

fi_lon_fini

fi_lon_ouv

fi_lon_papier

fi_lon_tir

fi_mac_forcee_r

fi_mac_forcee_v

fi_mac_imp

fi_mac_imp2

fi_nb_cl_commune

fi_nb_cl_fle_r

fi_nb_cl_fle_v

fi_nb_cl_off_r

fi_nb_cl_off_v

fi_nb_cl_ser_r

fi_nb_cl_ser_v

fi_nb_cl_typ_r

fi_nb_cl_typ_v

fi_nb_decoupe

fi_nb_feu

fi_nb_poses

fi_nb_references

fi_nb_teintes_r

fi_nb_teintes_v

fi_nbp_haup_hauc

fi_nbp_haup_larc

fi_nbp_larp_hauc

fi_nbp_larp_larc

fi_num1

fi_num2

fi_num3

fi_num4

fi_num_forme

fi_num_plan_cao

fi_numerotage

fi_page_feu

fi_perfo

fi_pli_dblc

fi_pos_reperes

fi_pose_sm

fi_pose_st

fi_pr_recto

fi_pr_verso

fi_prod_ent Code produit de l'entité

fi_quadri_r

fi_quadri_v

fi_reperes

fi_resp_sens_pap

fi_sfm

fi_sit

fi_tot_page

fi_typ_ent

fi_type_dimension

fi_type_pellic

fi_type_pre_presse

fi_type_vernis_r

fi_type_vernis_v

fi_ve_recto

fi_ve_verso

fi_z1

fi_z10

fi_z11

fi_z12

fi_z2

fi_z3

fi_z4

fi_z5

fi_z6

fi_z7

fi_z8

fi_z9

fi_zpar

fi_zpar2

fi_zpar3


#CF ISO Format normalisé des numéros de téléphone

Ce paramètre est opérationnel à partir de la V. 4.1.10.2

Notes

_FORMAT_ISO_ | 13,14 Code pays ISO 21,60 Masque de saisie du numéro de téléphone. Exemple _FORMAT_ISO_FR &&&&&&&&& Le numéro de téléphone sera : +33247000000 _FORMAT_ISO_FR &&& &&& &&& Le numéro de téléphone sera : +33247 000 000
_LG_MINI_ISO_ | 14,15 Code pays ISO 21,22 Longueur minimum du numéro de téléphone
_LG_MAXI_ISO_ | 14,15 Code pays ISO 21,22 Longueur maximum du numéro de téléphone
NUM_NATIONALE_IND | 21,60 Indicatif du pays pour activer la numérotation nationale Exemple Le numéro à envoyer est au format +XXX(YY)ZZZZZZ Avec la note NUM_NATIONALE_IND XXX On enverra le numéro YYZZZZZZ Sans la note On enverra le numéro 00XXXZZZZZZ


#CF KMA Configuration ECMA / FEFCO

Ce paramètre de configuration est disponible à partir de la V. 4.1.43.2

Il est utilisé par pointages_ecma et par tous les programmes pouvant faire appel à la nouvelle saisie des pointages ECMA/FEFCO.

Notes

Le paramétrage saisi sur le paramètre de lancement du programme en cours est prioritaire sur celui saisi ici.

ARTICLE_SIMULATION

21,35 Code article utilisé pour la simulation

Ce code servira de support pour la simulation des pointages

RAPPEL : Un article par défaut ne doit pas être utilisé comme article de simulation.

ASSURE_MODIF_FEFCO

21 Lors d'un appel en consultation, permettre de passer en modification via une action dédiée (O/N, N par défaut)

FORCE_CALC_PROD_GEN

21 Forcer le recalcul systématique des pointages pour les articles génériques (O/N, O par défaut)

MAJ_SURFACE_POIDS

21 (O/N, N par défaut )Mise à jour des poids et surfaces brutes/nettes sur l'article (ou qualité carton) courant lors de la validation des pointages de :

• Poids brut (TSC 201/C)

• Poids net (TSC 202/C)

• Surface brute (TSC 201/D)

• Surface nette (TSC 202/D)

• Laize unitaire (CIC/N30)

• Coupe unitaire (CIC/N30)

Remarques :

• Ce paramétrage n'est valable que pour une saisie directe des pointages sur un article (ou qualité carton). Il est ignoré lors de l'utilisation de la saisie via un devis, par exemple.

• Si l'article courant est associé à un devis, une demande de confirmation est faite avant de mettre à jour.

PAS_DE_MSG_RECALCUL

21 Pas de demande de confirmation avant le recalcul des pointages suite à une modification manuelle (O/N, N par défaut )

Remarque : En mode simulation (-Osi), la demande de confirmation n'est jamais affichée.

_SUP_SQL_F7_ARTICLE

21,60 Complément de sélection sur la table mat pour la recherche de l'article

_SUP_SQL_F7_QUALITE

21,60 Complément de sélection sur la table mat pour la recherche de la qualité carton

TSC_MODIF_POINTAGES

21,23 Code TSC de stockage d'une modification manuelle effectuée sur les pointages (doit correspondre à un paramètre de type TSC)

TYPE_COUTEAU

21,23 Code paramètre de type de couteau par défaut (doit correspondre à un paramètre de type CP)

TYPE_REFOULEUR

21,23 Code paramètre de type de refouleur par défaut (doit correspondre à un paramètre de type CP)


#CF LAB Contrôle laboratoire

Valeur alpha 1

A1[1] | Contrôle laboratoire activé (O/N, N par défaut)
A1[2] | Blocage laboratoire activé (O/N, N par défaut)
A1[3] | Prise en compte du client dans le blocage laboratoire (O/N, N par défaut)
A1[4,6] | TSC blocage laboratoire client si le client est pris en compte (exemple BLC)

Notes triées

CLIENT_NOMENCLATURE | 21,60 Code client du client nomenclature (ex : #SOC)
CODE_CHAR_TSC_09 | 21,60 Code du char3_1 des TSC 09*, pour la génération du fichier d' extraction des données laboratoire (Zone n°13 : RH)
COMP_ORDER_BY_EDIT | 21,60 Complément de tri pour l'édition (tri sur labo_entete)
COMP_ORDER_BY_GEN | 21,60 Complément de tri pour la génération de fichier texte (tri sur labo_entete)
COMP_SELECT_EDIT | 21,60 Complément de sélection pour l'édition (tri sur labo_entete)
COMP_SELECT_ESTAMP | 21,60 Complément de sélection des estampilles (table info_c) pour le blocage laboratoire Exemple and ic_ts between 33A and 33N
COMP_SELECT_GEN | 21,60 Complément de sélection pour la génération de fichier texte (tri sur labo_entete)
LIBELLE_CRITEREn | (où n peut prendre les valeurs de 1 à 8) Libellés paramétrables de l'écran de complément de détail 21,60 Libellé du critère n pour l'écran complémentaire de détail
MSG_NONCONFORME_ | Affichage d'un message explicite lors de la détection d'une non-conformité La note du paramètre de lancement de la saisie des contrôles laboratoire est prioritaire sur celle-ci. 17,19 Code du test pour lequel afficher un message def Valeur par défaut (dans le cas où le code de test n'est pas paramétré Voir le tableau des tests en bas de cette page. 21 Type d'affichage du message N Pas de message (par défaut) W Message non bloquant B Message bloquant C Demande de confirmation 22 Valeur par défaut en cas de demande de confirmation O Oui N Non (par défaut) Cette note est prioritaire sur celle du #CF LAB.
NUM_DOC_CONFORME | 21,60 Numéro de document pour la déclaration de conformité
NUM_DOC_NONCONFORME | 21,60 Numéro de document pour l'avis de non-conformité
RESPONSABLE_LABO | 21,60 Nom/Prénom du responsable du laboratoire de contrôle
TOL_ | Tolérances minimum et maximum pour les contrôles de valeurs 5,7 Code du test. Voir le tableau des tests en bas de cette page. 21,23 Tolérance minimum (en %) 25,27 Tolérance maximum (en %)
TRAITEMENT | 21,60 Code du type de paramètre traitement (ex : TRT)
TYPE_MVT_ENTREE_MAG | 21,60 Type de mouvement d'entrée en magasin (ex : FR)

Codes des tests triés

20A | Epaisseur 20kPa avec impression
20S | Epaisseur 20kPa sans impression
4C+ | 4C + E
80A | Epaisseur 80kPa avec impression
80S | Epaisseur 80kPa sans impression
C11 | Cannelure 1 - Valeur 1
C12 | Cannelure 1 - Valeur 2
C21 | Cannelure 2 - Valeur 1
C22 | Cannelure 2 - Valeur 2
C31 | Cannelure 3 - Valeur 1
C32 | Cannelure 3 - Valeur 2
C41 | Cannelure 4 - Valeur 1
C42 | Cannelure 4 - Valeur 2
CAB | Code à barre
CAF | Résistance du collage AFNOR
CF9 | Résistance du collage FEFCO 9
COR | Cobb recto
COU | Poids des couvertures
COV | Cobb verso
ECH |
ECL | Eclatement
ECT | Edge Crush Test
ESD | Essai Denison
FC1 | Flat Crush Test l1
FC2 | Flat Crush Test l2
GRA | Grammage
HAU | Hauteur
KP |
LAR | Largeur
LON | Longueur
P |
PER | Perforation
RIG | Rigidité


#CF LOG Configuration logistique

>>> Voir la fiche d'installation complète sur la logistique.

Dans l'application de préparations des affrètements, lorsque l'utilisateur crée un affrètement, il peut avoir accès à une action pour optimiser le chargement via une application externe. Cette action permet de créer un fichier d'import.

Initialement orienté Maxload, ce fichier de wonfiguration s'utilise aussi avec Cargo Wiz depuis le 30/05/2012.

La distinction se fait dans le caractère A2[14]. Les notes contenant le terme CARGOWIZ sont dédiées à cette nouvelle utilisation.

Ce fichier est utilisé par les programmes suivants :

  • cde

  • v_cdem

  • acr

  • exped_affretements

  • prep_affret

Valeurs numériques

1 | Largeur du camion pour le calcul du métrage linéaire restant à livrer de la commande. du conditionnement avec critère d'optimisation sur métrage linéaire Exemple : 2400
2 | Pourcentage de tolérance sur le métrage maxi type de véhicule

Valeur alpha 1

Caractère 1

Logistique activée (O/N, N par défaut)

Caractère 2

Type d'annulation de l'ordre de transport

L Annulation logique

P Annulation physique (valeur par défaut)

Caractères 3 à 5

Code TSC pour l'ordre des étapes d'un trajet - Obligatoire

Caractères 6 à 7

Racine des TSC des types de véhicule autorisés pour chaque transporteur - Obligatoire

Egalement paramétrable dans tarifs_transporteurs A2[10,11]

Caractères 8 à 10

Type de notes des affrètements - Obligatoire

Caractères 11 à 13

Type de notes d'annulation des affrètements - Obligatoire

Type des notes comportant l'ancien numéro de chargement (tr_jde_groupage)

Caractères 14 à 16

Type de notes d'édition des ordres d'achat de transport - Obligatoire

Caractères 17 à 18

Racine du code TSC des frais accessoires facultatifs utilisé pour un affrètement donné - Obligatoire

Utilisé par TFA alpha1[2]

Caractères 19 à 21

Type de notes d'historisation de la valorisation. Obligatoire. Exemple HIS

Caractère 22

Code contrôle pour vérification qu'un affrètement ne dépasse pas la capacité maximum (métrage linéaire) du type de véhicule sélectionné

N pas de contrôle (par défaut)

W warning

C Confirmation

B bloquant

Caractères 23 à 25

Code type de véhicule par défaut pour interface MAXLOAD

Caractère 26

Contrôle de la présence de la commande dans un affrètement lors du solde de celle-ci (O/N, O par défaut

Caractères 27 à 29

ZZZ Mode de transport correspondant à la location (code de type TRS) - Utilisé dans vehicules

Caractère 30

Gestion des environnements des tarifs des transporteurs activée (O/N, N par défaut)

Caractères 31 à 33

Code environnement des tarifs des transporteurs par défaut (Paramètre ETT)

Obligatoire si la gestion des environnements des tarifs des transporteurs est activée.

Exemple : 001

Caractères 34 à 36

Code TSC utilisé pour l'enregistrement des plages horaires d'arrivée chez le client

Caractères 37 à 39

Historisation des tarifs proposés lors de la valorisation

Caractères 40 à 42

Code TSC distance kilométrique de l'affrètement (ou groupage)

Par défaut DKM

Caractères 43 et 44

Racine des codes TSC pour stocker les frais supplémentaires (FS par défaut)

On peut saisir des frais supplémentaires dans les programmes suivants :

Gestion des expéditions des affrètements ( G_exped_affretements) (touche F25)

Visualisation des groupages ( G_v_groupage_bl) (touche F21)

Ceux-ci sont stockés dans les TSC dont la racine est paramétrable ici.

La somme des frais supplémentaire saisis est sauvegardée dans la zone gb_frais_suppl de la table groupage_bl et cette somme est ajoutée au coût réel du groupage (zone gb_cout_reel).

Voir aussi TFA A1[1].

Caractère 45

Désactive le forçage à asynchrone des commandes sans quantité lancée (O/N, N par défaut)

Explication : Pour les commandes n'ayant pas de quantité lancée, on forçait le flag otr_reap à A, c'est-à-dire asynchrone.

On peut maintenant inhiber ce forçage pour garder la valeur initiale (synchrone/asynchrone pris sur cde4 ou mat).

Caractères 46 à 48

Code TSC des confirmations d'affrètement client - INFO A VERIFIER

Caractère 49

Cacher la zone Intégration dans la logistique dans l'écran de revue de contrat

Caractère 50

Type de contrôle à effectuer lors de la création manuelle d'un ordre de transport depuis les modules de préparation ou d'expédition des affrètements (N/C/B/W)

Aujourd'hui, le flag lc_logistique détermine si une commande doit générer ou non la création d'un ordre de transport.

Dans le cas d'une création manuelle, on se basait aussi sur ce flag, d'où l'impossibilité de créer un OT pour les commandes non prévues dans la logistique (ex : cas des CDI).

Maintenant, et depuis la préparation ou l'expédition des affrètements, on peut créer manuellement un OT provenant de n'importe quelle commande.

Valeur alpha 2

Caractère 1 | Gestion par lots d'expéditions (O/N, N par défaut)
Caractère 2 | Désactivation du calcul de distance (via Loxane) (O/N, N par défaut)
Caractère 3 | Gestion des reliquats d'affrètement en édition provisoire (O/N, N par défaut) - Utilisé par G_blv_ed1 Par défaut, les reliquats d'affrètement sont gérés en édition définitive.
Caractère 4 | Suppression de l'ouverture de la fenêtre de confirmation (O/N, N par défaut)
Caractère 5 | Ouverture systématique de la fenêtre des frais de déchargements supplémentaires dans le cas où l'on prend en compte ces frais
Caractère 6 à 8 | Code TSC pour édition CAC à paramétrer sur les clients Voir l'édition du document de confirmation d'affrètement client
Caractère 9 à 11 | Code notes (de type NTS) pour édition CAC Voir l'édition du document de confirmation d'affrètement client
Caractère 12 | En dé-solde de commande, lors de la création éventuelle des mouvements prévisionnels de livraison, pouvoir re-créer les ordres de transport. (O/N, N par défaut)
Caractère 13 | Nombre de jours à ajouter à la date du jour pour le calcul de la date de disponibilité de l'ordre de transport créé lors de la génération du bon de transfert.
Caractère 14 | Choix de l'interface – 1 (ou vide) : Maxload (par défaut) – 2 : Cargo Wiz

Notes

CARGOWIZ_ORIENT

21 Orientation du chargement :

1 non activée

2 le chargement peut être tourné horizontalement (par défaut)

4 le chargement peut être tourné n'importe comment mais il ne sera pas basculé vers le haut

6 le chargement peut être tourné n'importe comment

EXT_FIC_CARGOWIZ

21,23 Extension du fichier (facultative - par défaut : txt)

LOCK_EXTERNE_MAXLOAD

21,60 Indique l'emplacement d'un fichier lock externe (empêche la génération d'un fichier tant que ce dernier est en place)

Possibilité de concaténer le chemin sur plusieurs lignes

LOCK_EXT_CARGOWIZ

21,60 Fichier Lock externe

LOCK_INTERNE_MAXLOAD

21,60 Chemin + nom fichier lock interne (que pose VoluPack lorsqu'il génère un fichier)

Possibilité de concaténer le chemin sur plusieurs lignes

LOCK_INT_CARGOWIZ

21,60 Fichier Lock interne

NOM_FIC_CARGOWIZ

21,60 Nom du fichier

Le nom du fichier peut comporter des options pour son format :

-h : horodatage du fichier

-i : identifiant (exemple : identifiant du groupage)

Exemple : nomfichier –hi ou nomfichier -h

PARAM_ENTETE

Dans sa nouvelle version, MaxLoad a changé le format de l'entête de ce fichier.

Le but de ce développement est donc de le rendre paramétrable - 4.0.181.2

21,60 Zone à ajouter dans l'entête

Détail des zones pouvant être paramétrées dans la construction de l'entête :

Valeur constante : inscrire la valeur, sans la faire commencer par [

Valeur issue de la base de données : Paramétrer le nom de la zone entre [ ]

ATTENTION : Chaque zone ainsi paramétrée sera séparée de la zone précédente par le séparateur « ; »

[so_rais] Raison sociale issue de la fiche société

[so_rais%x,y] Caractères x à y de la raison sociale de la fiche société

[gb_type_vehicule] Code type de véhicule issu du groupage
(par défaut, paramétré en A1[23,25])

[gb_type_vehicule%p2_zc1:<<<&] Zone numérique 1 du paramètre TVE du type de véhicule
(affiché avec le format <<<&)

[gb_type_vehicule%p2_alph:x,y] Caractères x à y de la zone alpha 1 du paramètre TVE du type de véhicule

[CR] Permet de spécifier la fin d'une ligne, ce qui permet d'en paramétrer une nouvelle en dessous

A partir de gb_type_vehicule, toutes les zones usuelles de par02 sont accessibles.

Exemple de paramétrage pour reproduire la valeur par défaut

REP_FICHIERS_MAXLOAD

21,60 Emplacement où VoluPack génère les fichiers

Possibilité de concaténer le chemin sur plusieurs lignes

REP_FIC_CARGOWIZ

21,60 Répertoire qui contiendra les fichiers

SUP_REQ_G_STD_D

21,60 Supplément de requête sur la table des gammes standard (g_std_d) pour la recherche de la dernière machine de la gamme dans la fonction "Mise à jour de la table des ordres de transport" (f_majordretrsp)

_SUP_REQ_LIEU_CDA

21,60 Complément de requête pour la recherche de magasin dans le cas de l'ajout d'une CDA au filtre de travail

Ce complément est recherché en priorité sur le paramètre de lancement de prep_affret.

Explication : Aujourd'hui, dans le filtre de travail, on peut ajouter des commandes non prévues.

Pour ajouter une CDA, il faut qu'elle possède un lieu intermédiaire (saisie en revue de contrat).

On peut lever cette contrainte, mais il faudra attribuer un magasin de destination à cette CDA.

La liste des magasins se fait avec un complément de requête.

Si ce complément n'est pas saisi, le fonctionnement actuel restera.

Si le complément de requête ne propose qu'un seul magasin, alors celui-ci sera pris en compte sans affichage de la grille de résultat.

_TRANSPORTEURS_STD

21,60 Liste, formatée, des transporteurs à prendre en compte pour la recherche de tarifs standards

6 caractères, taille fixe, par code transporteur, les codes étant séparés par un espace.

Exemple

_TRANSPORTEURS_STD F3132 F0210 F0231 F3050 F9999

Si cette note n'est pas mise en place, la recherche reste la même qu'avant.


#CF LSP Configuration localisation stock palette

Dans la préparation des affrètements, on peut visualiser la localisation des stocks d'un affrètement sur un plan (via la touche F3).

Cette fonctionnalité sera accessible depuis d'autres programmes.

#CF LSP A1[1] #CF LSP A2[1,2 ] : Permet de modifier l'affichage des commentaires : On indique pour chaque emplacement trouvé le n° de commande, le nombre de palettes à charger (pris sur la commande) et le nombre de palettes présent sur l'emplacement.

Valeur alpha1

#CF LSP A1[1]

Couleur unique pour tous les emplacements trouvés (O/N)

Valeur alpha2

#CF LSP A2[1] | Type de saisie pour les emplacements 1 lieu 1 2 lieu1 et lieu2[1,3] 3 lieu1 et lieu2[4,6] 4 lieu2
#CF LSP A2[2] | 1 Nouvel affichage détaillé des commentaires

Notes

CODE_MAGASIN_STOCK | 21,23 Code magasin de stockage dans la table stk0 (s0_rgt1)
COULEUR_EMPLACEMENT | 21,60 Codes couleurs
NOM_PLAN_STOCKAGE | 21,60 Nom du plan de stockage. Valeurs possibles : plan_U2 (par défaut) plan_EL plan_SJ
_SUP_REQ_CDE2 | 21,60 Complément de sélection sur table cde2
_SUP_REQ_MAT | 21,60 Complément de sélection sur table mat
_SUP_REQ_OTR | 21,60 Complément de sélection sur table ordre_transport
_SUP_REQ_RECH_LL | 21,60 Complément de sélection sur table stk0
ZONE_EMPLACEMENT_ | 18,20 Zone numérique de 001 à 999 21,23 Code lieu rangement1 24,29 Code lieu rangement2 (sans code état)


#CF MAT Articles
#CF MAM Matières
#CF MAN Matières
#CF MAO Outillage
#CF MAP Produits
#CF MAQ Qualité matière

Valeur numérique 1

Type de format pour l'édition de la quantité (utilisé dans l'édition abrégée et statistiques)

0 | ------------&
1 | ----------&.&
2 | ---------&.&&
3 | --------&.&&&

Valeur alpha 2

Caractères 1 à 40

A Code matière/produit
B Désignation matière/produit
C Code famille
D libelle famille
E Code sous-famille
F libelle sous-famille
G Prix d'achat
H Prix de revient
I Prix de vente
J Code TVA
K Stock physique
L Valeur du stock (PAMP par défaut)
M Stock mini
N Stock maxi
O Stock disponible
P Code normalisé
Q Prix de vente dans l'unité d'utilisation
R Code fournisseur principal
S Délai moyen d'approvisionnement fournisseur
T Minimum commande fournisseur
U Quantité économique de commande
V Stock en commande fournisseur
W Stock réservé
X Code qualité
Y Stock issue d'une simulation
Z Classement A/B/C
a Hauteur
b Longueur
c Largeur
d Code conditionnement
e Code couleur
f Poids
g Code unité d'achat
h libellé unité d'achat
i Code unité de vente
j libellé unité de vente
k Code formule de conversion
l Code produit de remplacement
m Taux de frais
n Taux de perte
o Taux de marge
p Suivi en stock (O/N)
q Type de valorisation
r Date du dernier mouvement
s Code matière ou produit (M/P)
t Zone libre
u Première zone de rangement (RG1)
v Deuxième zone de rangement (RG2)
w Troisième zone de rangement (RG3)
x Valeur unitaire du stock
y Code client principal
z Stock physique dans l'unité d'achat
0 Quantité à commander
(Quantité à commander = Stock maximum - Disponible
Disponible = Stock physique + Stock en commande fournisseur - Stock en réserve)
1 Format (longueur x largeur) sans décimale
2 Grammage (g/m2) sans décimale
3 Donnée technique alpha 1
4 Date de la première entrée en stock
5 Date de la dernière sortie de stock
6 Nom du fournisseur principal
7 Nom du client principal
8 Notes matières
9 Donnée technique alpha 2
+ Donnée technique numérique 1
* Donnée technique numérique 2
/ Donnée technique numérique 3
% Donnée technique numérique 4
= Donnée technique numérique 5
$ Donnée technique numérique 6
? Donnée technique numérique 7
! Donnée technique numérique 8
- Seuil d'alerte
& Référence client
; Date du dernier inventaire
< Date de la dernière entrée
> Date de la dernière sortie
( Code qualité matière
) Désignation qualité matière

Caractères 41 à 60

Colonnes dont le total doit être édité (-Oltvs), et dont la colonne est paramétrée dans alpha2).

Exemple

La colonne L est paramétrée en alpha2 si on souhaite que le total de cette colonne apparaisse sur les lignes de total, (si paramètre -Oltvs), il faut saisir L en zone alpha, l'ordre importe peu, car c'est le colonage d'alpha2[1,40] qui définit l'ordre.

Remarque

Actuellement, seules les colonnes K ,L, z éditent un total.

Valeur alpha 3

Titre de l'édition du fichier articles.

Notes

DROIT_ACCES_MP_PARAM

Accès paramétrables des zones du mp_param

21,22 Numéro du mp_param (de 1 à 46)

23 Visibilité de la zone

O Zone visible et accessible (par défaut)

N Zone cachée

C Zone visible mais non accessible (consultation)

On peut contrôler l'accès à chaque zone du mp_param.

Par défaut, toutes les zones sont visibles et accessibles.

Le paramétrage est recherché en priorité sur le user (USE XXX où xxx est le code utilisateur).

Si au moins une ligne de paramétrage concernant l'accès aux zones du mp_param est trouvée, alors les permissions sont prises sur l'utilisateur.

Si aucun paramétrage n'est trouvé sur l'utilisateur, on va lire le paramétrage sur la configuration de la fiche matière (#CF MAT ou autre).

Si vous paramétrez des notes à la fois sur le USE et sur le #CF MAT, seules celles du USE seront prises en compte.


#CF XXX Configuration de la mise à jour pour le devis multi-métiers

Cette page regroupe tous les paramètres de configuration de mise à jour pour le devis multi-métiers : #CF MSD / #CF MED / #CF MEV / #CF MRD / #CF MEF.

#CF | Mise à jour des | Appelé par | Champs possibles
 |  |  | Tables | LCO | TSC | NTS | GAM
MSD | Sous-devis | TPR MAJ_SDEVIS_DEVIS | fle_2 | LCO_SD | TSC_SD | NTS_SD |
MED/MEV | Entités du devis Entités des variantes | TEN MAJ_ENTITES_DEVIS TEN MAJ_ENTITES_VARQTE | fle_imp | LCO_EN | TSC_EN | NTS_EN | GAM
MRD | Références du devis | TPR MAJ_REFMUL_DEVIS TPR MAJ_REFMUL_VARQTE | fle_dec |  | TSC_RE TSC_RF | NTS_RE NTS_RF |
MEF | Entités de fabrication Entités commerciales | TEN MAJ_ENTITES_FAB TEN MAJ_ENTITES_IDF TEN MAJ_ENTITES_IDC | fle_imp | LCO_EN | TSC_EN | NTS_EN | GAM

Remarque : Les codes de paramètres de configuration figurant dans le tableau ci-dessus (colonne de gauche) sont donnés à titre indicatif.
Rien ne vous empêche de créer vos propres codes et/ou de faire du regroupement.
Par exemple, vous créez un #CF MDV qui regroupe le paramétrage de configuration de mise à jour des sous-devis, des entités et des références du devis.

Valeur alpha 1 pour le devis (sous-devis, entités, références) - Lignes 1, 2 et 3 du tableau ci-dessus

#CF MSD A1[1]

#CF MED A1[1]

#CF MEV A1[1]

#CF MRD A1[1]

Recalcul du sous-devis après une mise à jour réussie

O Recalcul systématique

C Recalcul sur demande de confirmation

N Pas de recalcul

Valeur alpha 1 pour les entités de fabrication - Ligne 4 du tableau ci-dessus

#CF MEF A1[1,6] | Type et code du paramètre de configuration de la régénération des produits
#CF MEF A1[7,12] | Type et code paramètre de lancement de la régénération des cadencements de fabrication

Notes

MAJ_CHAMP

11,60 Définition du champ à mettre à jour sous la forme : [champ]*[libellé]*[création]*[valeur]*[mise à jour]*

[champ] : Code du champ à mettre à jour - voir le tableau ci-dessus pour les champs possibles :

1) Toutes les zones des tables possibles fle_2, fle_imp et fle_dec (voir tableau ci-dessus)

2) LCO : Paramétrage sous la forme : LCO_[type]_[code]_[zone] où

[type] : SD LCO sur sous-devis

EN LCO sur entité

[code] : Code de la LCO

[zone] : Zone de la LCO

Remarque : La LCO peut être créée si elle n'existe pas sur l'entité cible avec les valeurs de la LCO source.

3) TSC : Paramétrage sous la forme : TSC_[type]_[code]_[zone] où

[type] : SD TSC sur sous-devis

EN TSC sur entité

RE TSC sur ligne de référence multiple d'entête

RF TSC sur ligne de référence multiple d'entité

[code] : code du TSC

[zone] : zone du TSC

Remarque : Le TSC peut être créé s'il n'existe pas sur l'entité cible avec les valeurs du TSC source.

4) NTS : Paramétrage de la forme : NTS_[type]_[code] où

[type] : SD Note sur sous-devis

EN Note sur entité

RE Note sur ligne de référence multiple d'entête

RF Note sur ligne de référence multiple d'entité

[code] : Code de la note (NTS)

Remarque : Les lignes de notes peuvent être créées si elles n'existent pas sur la référence cible avec les lignes de notes saisies sur la référence source.

5) GAM : Gamme/Phase sur entité. Paramétrage de la forme : GAM_[code]_[zone] où

[code] : Code phase

[zone] : Toutes les zones des tables fle_gam (ga_*), fle_mat (fm_*), fle_ope (fo_*)_fle_str (fs_*)

Remarques :

• Le même code phase doit exister sur l'entité cible (le numéro de phase peut être différent).

• Le report d'une modification de phase peut entraîner une mise à jour multiple (si présence de plusieurs formules) sur l'entité cible.

• Cette mise à jour multiple est indiquée via la présence d'une icône dans la colonne Mul. de l'écran de validation de mise à jour.

[libellé] : Libellé à afficher dans l'écran de validation de mise à jour (optionnel)

[création] : Création de LCO/TSC/notes sur la cible avec les valeurs de la source si inexistant (O/N, N par défaut).

[valeur] : Valeur fixe

[mise à jour] : Valider par défaut la mise à jour de ce champ dans l'écran de validation (O/N, O par défaut).

Remarque : La ligne de paramétrage doit finir par un astérisque.

Exemple

Paramètre de saisie TPR

Note

MAJ_SDEVIS_DEVIS #CFMSD

Paramètre de configuration #CFMSD

A1[1] = N

Notes

MAJ_CHAMP l2_type_dev*Type devis*

MAJ_CHAMP LCO_SD_WI1_1*Calage coll poign*O*

MAJ_CHAMP LCO_SD_WI2_1*Prix au mille*O*

MAJ_CHAMP TSC_SD_#FR_F*Cde référence*O*

MAJ_CHAMP TSC_SD_SDP_F*Scénario prix*O*


#CF MRC Marges contributives

Valeur alpha1

Caractère 1 | Autorisation de création d'événement de type devis (O/N, O par défaut)
Caractère 2 | Autorisation de création d'événement de type commande (O/N, O par défaut)
Caractère 3 | Autorisation de création d'événement de type génération FBI (O/N, O par défaut)
Caractère 4 | Autorisation de création d'événement de type livraison (O/N, O par défaut)

Interdire la création d'événement pour un client : générer un TSC de type MRC, avec pour valeur N dans la zone ic_char3_1.

Notes

Caractères 1 à 20 | CODE_ENVIRONNEMENT
Caractères 21 à 23 | Code de l'environnement Si aucun code n'est défini, alors on prendra de base un seul environnement de code STD.


#CF NTS Configuration des notes

Ce paramètre est utilisé par stk0 et la saisie des notes groupées

Valeurs numériques

1

Longueur de note

Valeur alpha 1

#CF NTS A1[1]

Activation du nouveau mode de sélection des types de notes (par boutons) (O/N, O par défaut)


#CF ODV Devis onduleur

Notes standard

CERCLAGE_PAR_DEFAUT

30,32 Code cerclage par défaut

Notes spécifiques

NUM_AUTO_FICHE_IMP | 21 Numérotation automatique des fiches d'impression (N/Q/O, N par défaut)
RACINE_FIC_IMP | 21,25 Racine de la numérotation automatique
LONG_FOLIO_FIC_IMP | 21,25 Longueur folio racine pour la numérotation automatique

Notes spécifiques

CLIENTNOMENCLATURE

21,26 Code client pour les nomenclatures

Notes spécifiques

SUPREQREFODV | 21,60 Complément de requête pour la recherche de l'ensemble
SUPREQREFARC | 21,60 Complément de requête pour la recherche du code conception
SUPREQREFIMP | 21,60 Complément de requête pour la recherche de la référence d'impression
SUPREQREFPRE | 21,60 Complément de requête pour la recherche de la référence de pre-impression
SUPREQPF | 21,60 Complément de requête pour la recherche de la référence PF
SUPREQQUACAR | 21,60 Complément de requête pour la recherche de la qualité carton
SUPREQCOMCAR | 21,60 Complément de requête pour la recherche de la composition carton
SUPREQFORDEC | 21,60 Complément de requête pour la recherche de la forme de découpe
SUPREQACC | 21,60 Complément de requête pour la recherche des accessoires
SUPREQCAIREG | 21,60 Complément de requête pour la recherche des caisses de regroupement
SUPREQPAL | 21,60 Complément de requête pour la recherche des palettes
SUPREQCOUIMP | 21,60 Complément de requête pour la recherche des couleurs imprimées
SUPREQCOIFFE | 21,60 Complément de requête pour la recherche des coiffes
FAMCON | 21,23 Famille de consommables
ACTSERPRE | 21,60 Action de service de pre impression
RECALCUL_PRX_REMIS | 21 Recalcul du prix remis dans le recalcul batch du devis en lieu et place de la marge sur prix remis (O/N)
CARACTSERPRECOU | 21,60 Caractéristique action de service pour le coût de pré-impression
CARACTSERPREQTE | 21,60 Caractéristique action de service pour la quantité pré-imprimée
ACTSERFAB | 21,60 Action de service de fabrication
CARACTSERFABNFA | 21,60 Caractéristique action de service pour le nombre de fabrications
CARACTSERFABQFA | 21,60 Caractéristique action de service pour la quantité fabriquée
ARRONDIQFA | 21,60 Arrondi de la quantité de fabrication
TOLERANCEQFA | 21,60 Tolérance de la quantité de fabrication
ACTSERFIN | 21,60 Action de service finance
CARACTSERFINPR | 21,60 Caractéristique action de service pour le PR
CARACTSERFINECH | 21,60 Caractéristique action de service pour le code échéance
TOLERANCEARRONDI | 21,60 Tolérance arrondi sur les quantités roulées
OUVERTUREMAXCOMB | 21,60 Ouverture maximum sur les combinés
POUSSEEMINCOMB | 21,60 Poussée minimum sur les combinés
COUPE_BANDE_ENTRAI | 21,60 Coupe bande entraînement
RECOP_TSC_FAB_99 | 21,60 Recopie du TSC de fabrication à partir de l'offre 99
DATE_TARIF_VIGUEUR | 21,30 Date (format JJ/MM/AAAA)
SUIVI_COMMERCIAL | 21,60 Suivi commercial

+ les 3 notes NUM_AUTO_FICHE_IMP, RACINE_FIC_IMP, LONG_FOLIO_FIC_IMP (voir plus haut)


#CF OND Devis onduleur

Notes

SUPREQCON | 21, 60 Complément de requête pour la recherche des articles consommables.
FAM_SFM_EXCLU_REF | 21, 60 Couples de familles/sous-familles à exclure de la remise à niveau de la référence R. 6 couples paramétrables par ligne de note Exemple : CAIMISCAIMID (Famille CAI / Sous-famille MIS, Famille CAI / Sous-famille MID)


#CF OMP Transfert fichier Order OMP

#CF OMP ou tout autre #CF XXX référencé par la note CODE_CONFIG_OMP du gdf_don

Utilisé pour la génération d'un fichier order au format XML

Notes

NTS_CUSCOMMENTS | 21,23 Type de notes lues sur le client livré pour l'alimentation de la zone Cuscomments
NTS_CCORDER | 21,23 Type de notes lues sur le client livré pour l'alimentation de la zone Dlycomments
NTS_CCPRODUCT | 21,23 Type de notes lues sur le produit pour l'alimentation de la zone Comments du ccproduct
NTS_CCPROCESS | 21,23 Type de notes lues sur le produit pour l'alimentation de la zone Comments du ccprocess
NTS_CCOPERATION | 21,23 Type de notes lues sur le produit pour l'alimentation de la zone Palletizationcomments
NTS_CCOPERATION_T | 21,23 Type de notes lues sur le triplet pour l'alimentation de la zone Comments du ccoperation
TSC_CTRL_SPEC_CLI | 21,23 Code TSC utilisé sur le client pour indiquer si ce dernier doit faire l'objet d'un contrôle supplémentaire (alimentation de la zone Qualspecification)
OMP_TOL_QUANTITE_FAB | Gestion des pourcentages de quantités minimum, maximum et objectif à fabriquer Cette note existe aussi sur le paramètre de saisie TOL où elle est prioritaire. 21,29 Quantité de début 30,38 Quantité de fin 39,44 Pourcentage mini de fabrication (+/- x%) 45,50 Pourcentage maxi de fabrication (+/- x%) 51,56 Pourcentage objectif de fabrication (+/- x%)

Paramètres associés

gdf_don | Notes NOM_SYSTEME_PLANIF REPERTOIRE_FIC_OMP FIC_OMP FIC_TRACE_OMP TYPE_NOTE_CLI_LIVRE CODE_CONFIG_OMP
BLO A4[27,29] | Code OMP du blocage Ce code fait partie de la clé qui alimente la zone Stopcodeid. Si cette zone n'est pas renseignée, le code blocage n'est pas pris en compte dans l'intégration OMP
TOL A1[12,14] | Pourcentage objectif Ex : 5 si on se fixe comme objectif de produire 105% de la quantité prévue
.SC A2[16,18] | Code colisage OMP Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Bundlestrappinginfo.
.CE A1[1,3] | Code cerclage OMP Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Layerstrappinginfo.
.TP A1[6,8] | Type de palette OMP Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Labeltype.


#CF OPT Configuration de l'optimisation du devis

Ce paramètre est utilisé dans le cadre de l'optimisation du devis standard.

Valeurs numériques

1

Temps limite de traitement (en minutes)

Valeur alpha 1

#CF OPT A1[1,3]

Filtre pour le calcul des solutions verso (on calcule le verso pour les N premières solutions recto uniquement) (par défaut : 100)

#CF OPT A1[4,6]

Nombre maximum de solutions à afficher par entité (dans le fichier trace) et au final

#CF OPT A1[7,9]

Filtre pour la recherche de décompositions (par défaut : 3) La valeur maximale est de 5.

Exemple :

1 On prend le type de pli avec le nombre de pages maximum, puis on passe au niveau suivant.

2 On prend les 2 premiers types de pli, puis on passe au niveau suivant, etc.

#CF OPT A1[10]

Type de pli à prendre en compte

R il s'agit des plis en ligne, ce sont les plis roto

F il s'agit des plis pour une plieuse dédiée (que l'on peut imprimer sur une machine feuille ou roto en sortie à plat).

2 ce code permet de prendre les 2 types de pli.

#CF OPT A1[11]

Conservation de la machine recto pour la machine verso (les informations de vernis doivent être identiques)

N On effectue toujours une recherche de machine verso, quelque soient les informations d'impression (par défaut).

O La machine recto est toujours égale à la machine verso.

1 La machine recto est égale à la machine verso si l'écart du nombre de couleurs entre recto et verso est inférieur ou égal à 1.

2 La machine recto est égale à la machine verso si l'écart du nombre de couleurs entre recto et verso est inférieur ou égal à 2.

#CF OPT A1[12]

Application automatique de la meilleure solution

O La meilleure solution trouvée est automatiquement appliquée sans ouverture d'écran.

N Une fenêtre de sélection permet de sélectionner la solution à appliquer (par défaut).

#CF OPT A1[13,18]

Code machine de refente

ATTENTION : les codes définis dans les notes _REFENTE_CAL et _REFENTE_ROU ont priorité sur ce code.

#CF OPT A1[19]

basculable/non basculable

O ou blanc => basculable/non basculable sur sous-famille papier

N => basculable/non basculable sur famille papier

#CF OPT A1[20]

Eclatement

O l'éclatement sur plusieurs feuilles d'une même entité est autorisé (par défaut).

N l'éclatement sur plusieurs feuilles n'est pas autorisé.

#CF OPT A1[21]

Niveau de détail des messages trace dans l'optimisation

1 Affichage des solutions trouvées uniquement

2 Affichage des solutions trouvées et des messages simples

3 Affichage des solutions trouvées et de tous les messages

4 Affichage des solutions trouvées, de tous les messages et d'informations complémentaires pour aider à l'installation

5 Niveau 4 + détail complet sur l'optimisation du façonnage

#CF OPT A1[22]

Visibilité de l'écran de sélection des machines

O L'écran de sélection des machines est caché.

N Activation de l'écran de sélection des machines.

Voir aussi les notes REC_MACHINE_ sur le TEN (caractère 27)

#CF OPT A1[23]

Eclatement de la solution déterminée par l'optimisation en plusieurs entités si le code bascule est différent sur les feuilles de la décomposition (O/N, N par défaut)

#CF OPT A1[24,26]

Code paramètre de type TIM dans le cas d'une optimisation sur un seul cahier

#CF OPT A1[27,29]

Code paramètre de type TIM dans le cas d'une optimisation sur plusieurs cahiers

#CF OPT A1[30]

Tronçonnage autorisé (O/N, N par défaut)

#CF OPT A1[31]

Nombre de plis différents (en nombre de pages) que l'optimisation doit tester pour chacune des machines d'impression

(par défaut : pas de limite)

#CF OPT A1[32]

Alimentation automatique des notes de la nomenclature avec le détail des machines d'impression et de la décomposition à l'issue de l'optimisation (O/N N par défaut)

#CF OPT A1[33]

Impression autorisée sur des machines feuille (O/N, O par défaut)

#CF OPT A1[34]

Impression autorisée sur des rotatives (O/N, O par défaut)

#CF OPT A1[35]

Impression autorisée sur des machines superposées (O/N, O par défaut)

#CF OPT A1[36,37]

Nombre de solutions sélectionnées par entité pour la construction des solutions finales (par défaut : 5)

INUTILISE

#CF OPT A1[38,39]

Permet de sélectionner les solutions à afficher pour chacune des entités (dans le fichier trace) et au final en fonction de leur écart (en %) avec la meilleure solution

#CF OPT A1[40]

Le nombre de poses au pliage défini dans NB_POSES_PLIAGE n'est plus un maximum mais une valeur fixe.

Ce paramètre permet de figer le nombre de poses au pliage et donc au façonnage.

Il n'est pas modifiable par l'utilisateur dans la fenêtre de sélection du paramétrage.

Lorsqu'il est actif, un message le rappelle au lancement de chaque optimisation.

#CF OPT A1[41]

Mode de recherche des décompositions

O Activation des décompositions prioritaires (obligatoire pour le coming & going)

N (par défaut) Recherche des décompositions en combinant les paginations des impositions trouvées (par pagination décroissante).

#CF OPT A1[42,43]

Nombre de papiers à afficher pour chacune des solutions de l'optimisation d'un entité

Par défaut, le nombre de papiers est 1. Ce qui évite l'ouverture de l'écran de validation.

Permet de vérifier le résultat de l'optimisation papier dans le cas où la recherche se fait dans la base papier (note TSC_POIDS_MIN_CDE)

#CF OPT A1[44]

L'optimisation du papier tient compte :

O du coût d'achat de refente et d'équerrage.
En complément, il faut utiliser le paramètre A1[42,43].
Ce dernier permet de préciser le nombre de papiers qui participeront à l'optimisation.
Les papiers choisis sont ceux pour lesquelles la perte papier est la plus faible.
La valorisation s'effectue ensuite pour chacun de ces papiers. Le moins cher sera sélectionné.

N de la perte papier uniquement (par défaut)

#CF OPT A1[45]

Activation de la gestion du façonnage multi-passages pour le calcul du devis optimisé

Permettre de gérer la piqûre et les couvertures avec rabats dans le devis optimisé.

O Façonnage multi-passages activé, les machines de façonnage dont le nombre de postes est inférieur au nombre de cahiers sont prises en compte.

N Façonnage multi-passages désactivé, les machines de façonnage dont le nombre de postes est inférieur au nombre de cahiers sont exclues (par défaut).

Nombre de passages = Arrondi supérieur (Nombre de cahiers / Nombre de postes)

#CF OPT A1[46]

Prendre en compte les coûts de calage/roulage pour filtrer les décompositions (O/N, N par défaut)

#CF OPT A1[47]

Recherche de décomposition en coming & going

O Recherche des décompositions en coming & going + prioritaires standards

N Recherche uniquement des décompositions prioritaires standards (par défaut)

F Recherche uniquement des décompositions en coming & going (forçage)

Remarque : Si aucune décomposition n'est trouvée en coming & going lors d'une recherche forcée (F), le devis optimisé demande à l'utilisateur s'il veut rechercher les décompositions prioritaires standards.

#CF OPT A1[48]

Pour le devis optimisé imprimerie

Prise en compte des formats standards des papiers

O Recherche des formats sur la table mat_format

S Recherche des formats sur les notes de la sous-famille du papier

2 Recherche des formats sur la table mat_format,
puis sur les notes de la sous-famille du papier si aucun format sur la table mat_format

N Pas de prise en compte des formats standards des papiers (par défaut)

#CF OPT A1[49]

Affichage d'un message lors du passage en optimisation globale lorsqu'il existe plus d'une entité optimisable

Pour le devis Imprimerie

Si la gestion de la nomenclature est activée (TPR A4[11] différent de N)

N Pas de message

Le passage en optimisation globale est forcé.

W ou C Message d'avertissement

Le passage en optimisation globale est forcé.

Si la gestion de la nomenclature n'est pas activée (TPR A4[11] égal à N)

N Pas de message

Le passage en optimisation globale est forcé.

W Message d'avertissement

Le passage en optimisation globale est forcé.

C Demande de confirmation (par défaut)

Le passage en optimisation globale n'est pas forcé.

#CF OPT A1[50]

Affichage d’un message d’avertissement lorsqu'une entité a été définie comme non optimisable (O/N, O par défaut)

Notes

AJOUT_PLI

21 à 25 : Valeur à ajouter entre chaque exemplaire à plier (en mm) - PARAMETRE SUPPRIME

Le calcul de la longueur pliée doit tenir compte d'un écart entre chaque exemplaire plié.

Précédemment, cet écart était paramétré dans cette note et était donc commun à toutes les plieuses.

Son paramétrage se fait maintenant sur chacune des plieuses selon trois plages possibles et dépend de la dimension engagée.

Si aucune des plages ne convient, l'écart sera nul.

Cette modification a également été reportée dans la génération du pliage.

BORNE_COEF_GRAMMAGE

Bornes de grammage

21,28 Première borne de grammage (en g/m²)

29,36 Deuxième borne de grammage (en g/m²)

37,44 Troisième borne de grammage (en g/m²)

45,52 Quatrième borne de grammage (en g/m²)

53,60 Cinquième borne de grammage (en g/m²)

BORNE_COEF_QUANTITE

Bornes de quantité

21,28 Première borne de quantité (en nb de tours)

29,36 Deuxième borne de quantité (en nb de tours)

37,44 Troisième borne de quantité (en nb de tours)

45,52 Quatrième borne de quantité (en nb de tours)

53,60 Cinquième borne de quantité (en nb de tours)

CODES_DE_LCO_ENCRES

Code paramètre du LCO où sera saisi le code encre (zone M : code matière)

21,23 Code paramètre du LCO où sera saisi le code encre recto

24,26 Code paramètre du LCO où sera saisi le code encre verso - Par défaut : code LCO recto

ECART_POURC_EPA

21,22 Pourcentage d''écart limite entre l'épaisseur du dos saisie et l'épaisseur du dos calculée pour la saisie du devis multi-métiers
Par défaut : Si aucune valeur n'est saisie, il n'y aura aucun contrôle.

23,24 Pourcentage d'écart limite entre l'épaisseur du dos saisie et l'épaisseur du dos calculée pour la saisie des dossiers de fabrication (option Off sur le devis multi-métiers) - Par défaut : Si aucune valeur n'est saisie, il n'y aura aucun contrôle.

NB_POSES_PLIAGE

21 à 22 Nombre de poses maximum au pliage

Voir aussi A1[40] qui modifie le sens de ce paramétrage.

Par défaut : 2

Maximum : 10

PAGE_COMING_&_GOING

21?56 Liste des paginations compatibles avec la recherche de décompositions en coming & going (par 3 caractères)

Remarque : Ces paginations correspondent aux paginations saisies dans les décompositions prioritaires

Exemple : 032016008

REPERTOIRE_TRACE

21,60 Répertoire de destination du trace par solution

Permet de construire un trace par solution (50 premières solutions) à la fin du devis optimisé.

_SUP_SQL_MAT_FORMA

21,60 Complément de sélection des formats papier en stock à prendre en compte dans le devis optimisé imprimerie (table mat_format)

TSC_POIDS_MIN_CDE

21,23 Code TSC

31,39 Seuil par défaut en Kg pour la feuille

41,49 Seuil par défaut en Kg pour la roto

Cette information complémentaire permet de définir sur la qualité papier la valeur minimale de commande pour la feuille et la roto.

Sur la valeur numérique 1, définition de la valeur minimale pour la feuille en kg.

Sur la valeur numérique 2, définition de la valeur minimale pour la roto en kg.

Si aucune valeur n'est définie, le minimum de commande sera de 3000 kg.


#CF OTI On Time In Full

Ce paramètre est utilisable à partir de la V. 4.1.46.2

Voir aussi le programme outil_otif.

Valeur alpha 1

#CF OTI A1[1]

OTIF actif (on calcule l'OTIF quand une ligne de commande est soldée (O/N, N par défaut

Valeur alpha 2

#CF OTI A2[1,2] | Mode de récupération de la date de référence 1 Date de livraison proposée (lc_delrep) (PAR DEFAUT) 2 Date de livraison souhaitée (lc_delcli) 3 Date de livraison souhaitée ou date de livraison proposée si motif OK. Voir MMD A2[1].
#CF OTI A2[3,4] | Mode de récupération de la date de livraison 1 Date de livraison (b1_datl) (PAR DEFAUT) 2 Date de chargement (b1_date_chargem)
#CF OTI A2[5,6] | Mode de récupération du temps de transport 0 Temps par défaut à zéro (PAR DEFAUT) 1 Temps pris sur la zone cl_zparnum 2 Temps pris sur la zone cl_zparnum ou c2_zparnum si une adresse de livraison existe sur b1_adrl.


#CF OUT Configuration des outillages

Ce paramètre est utilisé par G_gestion_outils.

Valeur alpha 1

1,3 | Méthode de stockage des outils par rapport aux produits finis 001 Outils stockés sur les informations complémentaires sur triplet Article/Gamme/Phase de gamme 002 Outils stockés sur les informations complémentaires sur article (info_c) 003 Outils stockés sur la nomenclature de l'article (nom0) (valeur par défaut)
4,6 | Code de lien entre tables pour la saisie des emplacements rattachés à l'outil Ce code est lu dans la saisie simplifiée des outils et permet d'atteindre directement la saisie des liens entre les outils et les lieux de rangement lorsque l'on tape un O (Oui) dans la zone mp_multi_lieux.

Valeur alpha 2

1

Activation de la traçabilité sur la table des actions de suivi d'outillages (action_mat) (O/N, N par défaut)

Supprimé car redondant avec la note TRACABILITE_TABLE dans #CF TRA

Notes triées

CLIENT_NOMENCLATURE

Code client utilisé pour la nomenclature (Par défaut : #SOC)

LISTE_TSC_KIT_OUTIL

21,59 Codes d'informations complémentaires (TSC) à prendre en compte pour retrouver les outils liés à l'outillage principal en cours de saisie.

Jusqu'à 13 codes de 3 caractères

_SUP_REQ_INFO_C

Complément de sélection pour la recherche des produits finis rattachés à un outil (et inversement) dans les informations complémentaires

(Méthodes de stockage 001 et 002. Table info_c)

Exemple : and ic_ts in ("900","901")

Codes TSC fixés quelque soit le paramétrage

C10, C20, C30, C40, C50, C60, C70, C80, C90,M10, M20, M30, M40, M50, M60, M70, M80, M90, 910, 911, 912, 913, 920, 921, 922, 923, 924, 925, 926, 927, 928, 929

_SUP_REQ_OUTIL

Complément de sélection pour la recherche des outils rattachés à un produit fini dans la nomenclature

(Méthode de stockage 003. Table mat, champ mp_code)

Exemple : and mp_code matches "O*"

_SUP_REQ_PF

Complément de sélection pour la recherche des produits finis rattachés à un outil dans la nomenclature

(Méthode de stockage 003. Table mat, champ mp_code)

Exemple : and mp_code matches "P*"

TRONQUER_CODE_OUTIL

Troncature des codes outil

21,22 Caractère de début à prendre en compte pour la récupération du code outil. Par défaut : 1

23,24 Caractère de fin à prendre en compte pour la récupération du code outil. Par défaut : 15

25,27 Code famille à prendre en compte pour la récupération du code outil (obligatoire)

28,30 Code sous-famille à prendre en compte pour la récupération du code outil
(Paramétrage facultatif : si non saisi, on tronque le code par rapport à la famille)

Cette note est prioritaire sur celle de l'interface AV_DATA.

Principe de fonctionnement

Pour chaque outillage parcouru, on effectue les vérifications suivantes :

1. Si le couple code famille/code sous-famille de l'outil courant est trouvé dans la configuration des outillage, on prend le paramétrage correspondant pour tronquer le code.

(sinon)

2. Si le code famille de l'outil courant est trouvé dans la configuration des outillages (paramétrage global par famille, aucune sous-famille paramétrée), on prend le paramétrage correspondant pour tronquer le code.

(sinon)

3. Si le code famille de l'outil courant n'est pas trouvé dans la configuration des outillages, on prend le paramétrage global par défaut situé sur le paramètre de lancement de l'interface AV-DATA.


#CF PEF Paramétrage des effets DOS

Valeur alpha 1

Caractères 1 à 50

Chemin et nom fichier DOS (Exemple /u/atlas/atlas.dbs/tr_effet)

Valeur alpha 2

Caractères 1 à 30 | Commande formatage (Exemple dosformat /dev/fd096ds15)
Caractères 31 à 40 | Commande copy (Exemple doscp)
Caractères 41 à 60 | Unité et nom fichier disquette DOS (Exemple à:effet)


#CF PIC Configuration VoluPicador

ATTENTION : nécessite l'installation de la version 1.1 de VoluPicador.

2 cas de figure peuvent se présenter :

En 4 J'S 3.50

Par défaut, il est inutile, on travaille alors en mode DDE.

Si l'on veut travailler en mode socket, il est obligatoire.

En 4 J'S 4.x sous GENERO

Il est obligatoire, car GENERO ne peut fonctionner qu'en mode socket.

Valeurs numériques

1 | Temporisation lors de l'ouverture de VoluPicador (par défaut : 1 seconde) - Mode TCP/IP seulement
2 | Temporisation à l'établissement de la connexion (par défaut : 1 seconde) - Mode TCP/IP seulement

Valeur alpha 1

Caractère 1

Mode de connexion VoluPicador

S Socket TCP/IP (obligatoire sous GENERO)

D DDE (par défaut)


#CF POS Opérations élémentaires

Voir aussi Opérations élémentaires et dépendances

Valeur alpha 2

Caractères 1 à

Noms des colonnes éditables

A Code section

B Code opération

C Code sous-opération

D Libellé opération

E Type

F Difficulté

G Machine

H Dépendance alpha 1

I Dépendance alpha 2

J Dépendance alpha 3

K Dépendance alpha 4

L Plage 1

M Plage 2

N Plage 3

O Plage 4

P Gâche fixe

Q Gâche variable

R Unité quantité

S Cadence

T Temps

U Unité cadence

V Coût horaire

W Marge coût horaire

X Prix de vente coût horaire

Y Nombre personnes supplémentaires

Z Taux personne supplémentaire

1 Marge personne supplémentaire

2 Prix de vente personne supplémentaire

3 Type de frais <OPE>

4 Sect analytique

5 Correction pour calcul de temps

6 Prix au 1000

7 Zone paramètres

8 Code TTR (p_ss.ss_ttr)

9 Numéro de série (ou clé)

0 Code formule de calcul

a Code mode d'utilisation

b Gâche fixe/variable (% si variable)

c Cadence/temps (même colonne)

d Taux historisé du mois en cours

e Liste des taux de l'année en cours

f Code formule cadence

g Code formule temps


#CF PRL Prélèvements

Valeurs numériques

1 | Quantité à prélever par défaut
2 | non utilisée

Valeur alpha 2

Non utilisée

Valeur alpha 3

Caractère 1 | O Nouvelle méthode de prélèvement des échantillons pour contrôle lors de la fabrication. N Ancienne méthode (par défaut La nouvelle méthode a pour but de faciliter la mise en place du paramétrage des prélèvements. Le prélèvement produit est prioritaire par rapport à celui du client.
Caractère 2 | Ne pas prendre en compte les TSC N10 lors de la recherche de prélèvement (O/N, N par défaut)
Caractère 3 | Code hiérarchie de la recherche (1 par défaut) 1 Client -- Produit -- Cde commerciale -- FBI -- Forçage – Estampille 2 Cde commerciale -- FBI -- Produit -- Client -- Forçage -- Estampille

Valeur alpha 4

Caractères 1 à 60

Commentaire prélèvement quantité lancée ligne de commande - Uniquement pour impression

Notes

REF1 | 21,60 Service laboratoire - Uniquement pour impression
REF2 | 21,60 Service laboratoire - Uniquement pour impression
ACCES_QTE_PRELEV | 21,26 Type et code du paramètre de lancement du programme de gestion des prélèvements

Nouvelle méthode de prélèvement des échantillons pour contrôle lors de la fabrication

Saisie des clients

Gestion des quantités à prélever par la touche F31

Niveau de contrôle (1) | Gestion des quantités supplémentaires à prélever par plage de quantité (accès à la table prelev_qte_base par niveau)
Pas de niveau de contrôle (1) | Saisie d'une ligne de prélèvement pour le client (cette saisie représente un enregistrement de la table prelev_qte_supp)

(1) Cette information est stockée sur le TSC de type PRC (Prélèvement sur client) (ic_char3_2)

Saisie des articles

Gestion des quantités à prélever par la touche F31

Niveau de contrôle (2) | Gestion des quantités supplémentaires à prélever par plage de quantité (accès à la table prelev_qte_base par niveau)
Pas de niveau de contrôle (2) | Saisie d'une ligne de prélèvement pour le client et le produit (cette saisie représente un enregistrement de la table prelev_qte_supp)

(2) Cette information est stockée sur le TSC de type PRP (Prélèvement sur produit) (ic_char3_2)

Autres paramètres

Niveau de contrôle

Type de ligne de commande


#CF PRS 2ème écran de la fiche prospect

#CF PRS 2ème écran de la fiche prospect – VoluGold

Valeur alpha 1

(paramétrage des zones paramétrables)

Caractères 1 à 3 | Paramètre 1ère zone paramétrable de la fenêtre 2 de la fiche prospect
Caractères 4 à 6 | Paramètre 2ème zone paramétrable de la fenêtre 2 de la fiche prospect
Caractères 7 à 8 | Colonne de début d'édition des notes

Valeur alpha 2

Caractères 1 à 5 | Mot de passe pour annulation physique à blanc si pas de mot de passe
Caractères 6 à 60 | Chemin d'accès à uniplex

Valeur alpha 3

Caractère 1 | Saisie obligatoire de la charge machine et ventilation financière (W/B)
Caractère 2 | Saisie de la charge machine (O/N, O par défaut)
Caractère 3 | Saisie de la ventilation financière (O/N, O par défaut)
Caractère 4 | Saisie du planning (O/N, O par défaut)
Caractère 5 | Recopie automatique lors de la création d'un client/prospect (table cli), des données dans la table prospect (O/N)

Valeur alpha 4

Caractères 1 à 3 | Type de Machine (simplifie la recherche F7)
Caractères 4 à 6 | Type paramètre du programme d'édition des étiquettes après la création d'une commande
Caractères 7 à 9 | Code paramètre du programme d'édition des étiquettes après la création d'une commande
Caractères 10 à 12 | Type paramètre de création de PR (MR)
Caractères 13 à 15 | Code paramètre de création du PR (MR)

Notes

(paramétrage de la zone de paramétrage de la fenêtre 2 de la fiche prospect)

Caractères 1 à 2 | Numéro de ligne du tableau de la zone de paramétrage
Caractères 3 à 27 | Libellé de la ligne du tableau
Caractères 28 | Code paramètres
Caractères 29 à 53 | Libelle du code paramètre


#CF PRV Edition des prix de revient

Utilisé par epr0

Le code PRV peut être remplacé par un autre code indiqué dans epr0 A2[4,6].

Valeur numérique 1

Pourcentage de frais sur transport à prendre en compte lors de l'édition.

Valeur alpha 1

Caractères 1 à x

Nom des colonnes tableau matière

A OF

B Produit

C Désignation

D Largeur

E Longueur

F Quantité lancée

G Quantité réalisée

H Unité

I Ecart sur quantité

J Gâche variable prévue

K Gâche variable réalisée

L Ecart sur gâche variable

M Délai prévu

N Délai réalisé

O Coût matière niveau

P Coût de préparation niveau

Q Coût de réalisation niveau

R Coût matière prévu

S Coût matière réalisé

T Ecart coût matière

U Coût de préparation prévu

V Coût de préparation réalisé

W Ecart coût de préparation

X Coût de réalisation prévu

Y Coût de réalisation réalisé

Z Ecart coût de réalisation

1 Coût total prévu

2 Coût total réalisé

3 Ecart coût total

4 Type de gamme

5 Phase

6 Date de début

7 Numéro de mouvement

8 Prix unitaire prévu

9 Prix unitaire réalisé

0 Ecart prix unitaire

a Visualisation du niveau sous la forme

b Visualisation du numéro de commande ligne

c Gâche fixe prévue

d Gâche fixe réalisée

e Ecart sur gâche fixe

f Numéro lot du mouvement de stock

g Lieu du mouvement de stock

h Libellé lieu du mouvement de stock

i Prix prévu pour une unité de la quantité lancée

j Prix réalisé pour une unité de la quantité réalisée

k Ecart (prévu - réalisé) (i-j)

l Quantité totale prévue (avec gâche)

m Quantité totale réalisée (avec gâche)

n Ecart quantité (avec gâche)

o Prix de vente unitaire saisi dans la nomenclature

p Code produit ou entité + code produit

si niveau le plus haut, code produit, sinon numéro de l'entité + code produit

n'est utilisable qu'en imprimerie

mettre l'option pour Old

q Nombre de pages en totalité pour le niveau le plus haut, sinon par entité

n'est utilisable qu'en imprimerie

mettre l'option pour -Old

r Nombre de Couleurs Recto/Verso

n'est utilisable qu'en imprimerie

mettre l'option pour -Old

s Longueur de la plaque

t Largeur de la plaque

u Quantité de plaques

v Surface unitaire

w Surface totale

x % Quantité réalisée

y % Coût réalisé

z Unité de production

( Hauteur

) Poids

{ Donnée technique 1

} Donnée technique 2

< Quantité lancée en unité de production

> Quantité réalisée en unité de production

& Marge sur matière en tenant compte du coefficient de structure (voir les notes)

, Quantité commandée

; Quantité reçue

! Unité de vente

Valeur alpha 2

Caractères 1 à 39

Nom des colonnes tableau opération

A Numéro d'OF

B Type de gamme

C Phase

D Produit

E Libellé produit

F Opération

G Libellé opération

H Machine

I Section

J Quantité lancée

K Quantité réalisée

L Unité

M Ecart sur quantité

N Gâche prévue

O Gâche réalisée

P Ecart sur gâche

Q Date de début calculée

R Délai demande

S Date de début

T Délai réalisé

U Temps de préparation prévu

V Temps de préparation réalisé

W Ecart temps de préparation

X Temps de réalisation prévu

Y Temps de réalisation réalisé

Z Ecart temps de réalisation

0 Somme des temps des responsables, des supplémentaires, des aides et des mobiles pour l'opération

1 Total temps prévu

2 Total temps réalisé

3 Ecart temps

4 Coût prévu

5 Coût réalisé

6 Ecart coût

7 Cadence prévue

8 Cadence réalisée

Quantité réalisée / Temps réalisé

9 Ecart cadence

a Machine prévue

b Coût horaire (saisi sur l'opération (non historisé))

c Disponible uniquement en imprimerie

Temps standard

(Quantité réalisée / cadence standard ou Quantité réalisée * temps unitaire standard)

d Disponible uniquement en imprimerie

Coût standard = Temps standard * prix de revient

e Disponible uniquement en imprimerie

Ecart coût standard - Réalisé

f Disponible uniquement en imprimerie

Ecart temps standard - réalisé

g Cadence standard

soit la cadence du fichier opération

soit (1 / temps standard) du fichier opération si celui-ci est renseigné.

h Visualisation du numéro de commande ligne

i Libellé machine (réalisée)

j Prix prévu pour une unité de la quantité lancée

k Prix réalisé pour une unité de la quantité réalisée

l Ecart (j-k)

m Taux prévu (coût prévu / temps prévu)

n Taux réalisé (coût réalisé / temps réalisé)

p Libellé de la section

q Temps réalisé unitaire

r Temps des responsables

s Temps des supplémentaires

t Temps des mobiles

u Temps des aides

v Cadence roulage prévue

w Cadence roulage réalisée

Quantité réalisée / Temps Roulage Réalisé.

x Ecart cadence roulage (colonne v - w)

y Effectif prévu

z Effectif réalisé

% Coût main d'œuvre directe

+ Coût machine

? Marge sur opérations

@ Cadence prévue devis

- % Temps réalisé

= % Cadence réalisée

! % Coût réalisé

$ (dollar) Cadence prévue avec la quantité réalisée
Cadence prévue = Quantité réalisée + Gâche réalisée / Temps de roulage prévu
= p_f1.f1_qter + p_f1.f1_rebut / p_f1.f1_trp

Caractères 40 à 60

Nom des colonnes tableau détail salarié

A Code salarié

B Nom du salarié

C Date de saisie

D Numéro d'OF

E Type de gamme

F Phase

G Opération

H Libellé opération

I Heure de début

J Heure de fin

K Heure total

L TTR

M Libellé court TTR

N Quantité

O Montant

P Fonction

Q Centre de coût

R Code machine

S Libellé machine

T Libellé long TTR

U Cadence

V Quantité totale (quantité + gâche)

W Cadence sur quantité totale

Valeur alpha 3

Caractères 1 à 30 | Nom des colonnes tableau sous-traitance (table fab3) A Numéro d'OF B Produit C Quantité D Date E Notes F type TMT G Libellé long du type TMT H Montant I Numéro de bon de réception J Ligne de bon de réception
Caractères 31 à 60 | Nom des colonnes tableau sous-traitance (table fab5) A Numéro d'OF B Code du fournisseur C Date réception D Numéro de commande E Numéro de ligne de commande F Date facture G Date échéance H Numéro de facture I Numéro de ligne de facture J Code opération K Produit L Libellé du produit M Quantité N Montant HT O Port HT P Notes Q Centre de coût R Libellé du centre de coût S Numéro du bon de livraison fournisseur T Numéro de ligne du bon de livraison fournisseur U Numéro de certificat V Montant HT prévu W Nom du fournisseur X Montant PR (montant hors taxe + charge) Non disponible sur tous les PR Y Numéro de bon de réception Z Ligne de bon de réception

Valeur alpha 4

Caractères 1 à 30

Nom des colonnes tableau récapitulatif par FAM/SFM

A Code famille

B Libellé de la famille

C Code sous famille

D Libellé de la sous-famille

E Quantité remontée

F Quantité dans l'unité d'utilisation calculée avec le coefficient de conversion 2

(valeur alpha 2 du paramètre FOR)

G Prix de revient

H Prix de vente

I Marge en valeur

J Marge en %

Les colonnes H, I, J ne sont éditées que pour les totaux.

Notes

MAT ou OPE ou STR | Paramétrage du titre, du using et de la largeur de colonnes 4 à 21 Type de colonne (A, B, C, etc.) 22 à 39 Nom de la colonne 40 à 57 usingde la colonne (ex ### ### ##&) (facultatif) 58 à 59 Largeur de la colonne (facultatif)
TITREMAT, TITREOPE, TITRESTR | Paramétrage du titre au-dessus des tableaux Matière, main d'œuvre, sous-traitance 9 à 60 Titre du tableau Il est possible de mettre jusqu'à 6 lignes par titre.
CONVERSION_XXX_YYY | Conversion d'unités pour les quantités réalisées où XXX représente le code de l'unité à convertir et YYY le code de l'unité de conversion. 21 à 23 Code du paramètre FOR utilisé pour la conversion de XXX en YYY 24 Numéro de la formule à utiliser sur ce paramètre (1 à 99)


#CF RAS Recopie d'article vers une autre société

Ce paramètre est utilisé par le devis standard.

Le type et le code de ce paramètre (par convention, #CFRAS) sont définis dans les notes RECOPIE_ART_SOC du paramètre #CFGPF (ou de tout autre paramètre de configuration défini en A2[7,12] du devis standard).

Valeur alpha 1

1 | Mode de recopie C Conservation de l'article si déjà créé (Valeur par défaut) R Remplacement de l'article si déjà créé
2 | Suppression du préfixe du code article cible si déjà présent N Pas de suppression (Valeur par défaut) O Suppression
3 | Suppression du préfixe du code client cible si déjà présent N Pas de suppression (Valeur par défaut) O Suppression
4 | Article suivi en stock sur la société cible C On conserve le flag article suivi en stock de l'article copié (Valeur par défaut) N Article non suivi en stock O Article suivi en stock Q On demande si l'article est suivi en stock
5 | Conservation de la date de création de l'article copié N La date de création du nouvel article sera à la date du jour (Valeur par défaut) O On conserve la date de création de l'article copié
6 | Recopie des note N Pas de recopie (Valeur par défaut) O Recopie
7 | Recopie des libellés étrangers N Pas de recopie (Valeur par défaut O Recopie
8 | Recopie des informations complémentaires N Pas de recopie (Valeur par défaut) O Recopie
9 | Recopie des liens de nomenclature N Pas de recopie (Valeur par défaut) O Recopie

Notes

PREFIXE_CODE_SOURCE

21, 21 Préfixe du code article à recopier. Exemple T ou B

23, 25 Code de la société cible. Exemple TIP ou BEN

Exemples

PREFIXE_CODE_SOURCE T TIP

PREFIXE_CODE_SOURCE B BEN


#CF RCP Tableau récapitulatif devis

Utilisé uniquement dans fle_edi.

Si vous cherchez le paramétrage du tableau récapitulatif des coûts (devis onduleur ou devis multi-métiers), allez voir #CF REC.

Valeur alpha 1

Caractères 1 à 3 | Code phase de la phase cliché
Caractères 4 à 6 | Code phase de la phase forme
Caractères 7 à 9 | Code phase de la phase sérigraphie


#CF RCS Recopie de commande client vers une autre société

Ce paramètre est utilisé par le devis standard.

Le type et le code de ce paramètre (par convention, #CFRCS) sont définis dans les notes RECOPIE_CDE_CLI_SOC du paramètre #CFTDC (ou de tout autre paramètre de configuration défini dans la note PARAM_GENERER_CDE du devis standard).

Valeurs numériques

1

Numéro de compteur de la commande client cible

Valeur alpha 1

1,3 | TYC de la commande client cible. Obligatoire. Exemple CD2
4 | Numérotation annuelle de la commande client cible N Numérotation mensuelle (Valeur par défaut) O Numérotation annuelle
5 | Type de référence de la commande client cible 1 Numéro de commande (Valeur par défaut) 2 Client + Nombre de commandes 3 Client + Millésime + Nombre de commandes
6 | Suppression du préfixe du code client cible si déjà présent N Pas de suppression (Valeur par défaut) O Suppression
7 | Suppression du préfixe du code article cible si déjà présent N Pas de suppression (Valeur par défaut) O Suppression

Notes

PREFIXE_CODE_SOURCE

21,21 Préfixe de la commande client à recopier. Exemple T ou B

23,25 Code de la société cible. Exemple TIP ou BEN

Exemples

PREFIXE_CODE_SOURCE T TIP

PREFIXE_CODE_SOURCE B BEN


#CF RE1 Saisie des remises

Code RE1 ou tout autre code, mais pas #CF REM réservé à la recherche des remises

Le paramètre de lancement des programmes concernés doit indiquer le type et le code de paramètre de la configuration de la saisie des remises.

Exemples

Programme | Nom | Param. de lancement | Type | Code
Saisie des remises | rem0 | #SA REM | alpha3[22,24] = #CF | alpha3[25,27] = RE1
Saisie des tiers | cli | #SA CLI | alpha2[18,20] = #CF | alpha2[21,23] = RE2
Saisie des articles | mat | #SA MAT | alpha2[48,50] = #CF | alpha2[51,53] = RE3
Visualisation des tiers | v_cli | #VI CLI | alpha2[31,33] = #CF | alpha2[34,36] = RE2
Visualisation des articles | v_mat | #VI MAT | alpha2[21,23] = #CF | alpha2[24,26) = RE3

Attention

Cette configuration est utilisée :

  • dans la saisie des remises en tableau à partir de la fiche article ou client

  • dans la saisie en ligne : dans ce cas, seuls les paramètres soulignés ci-dessous sont utilisés.

Valeur alpha 1

remise.hlp (nom du fichier d'aide)

Attention : bien indiquer remise.hlp même si le nom du fichier d'aide est remise.

Valeur alpha 2

Caractère 1 | Saisie du code remise (O/N/I, O par défaut) 0 Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 2 à 4 | Code remise par défaut
Caractère 5 | Saisie obligatoire du code remise N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS
Caractère 8 | Saisie du code catégorie (O/N/I, O par défaut) O Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 9 à 11 | Type de paramètre de la catégorie
Caractères 12 à 14 | Code de la catégorie par défaut
Caractère 15 | Saisie obligatoire du code catégorie N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS
Caractère 18 | Saisie du code article (O/N/I, O par défaut) O Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 19 à 33 | Code article par défaut
Caractère 34 | Saisie obligatoire du code article N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS
Caractère 37 | Saisie du code tiers (O/N/I, O par défaut) O Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 38 à 43 | Code tiers par défaut
Caractère 44 | Type de tiers (C/F/L, L par défaut) C Client F Fournisseur L Libre
Caractère 45 | Saisie obligatoire du code tiers N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS
Caractère 46 | Faut-il prendre le tiers principal par défaut si la saisie des remises est appelée à partir de la saisie des articles ? (N/C/F, N par défaut) N Non C Client F Fournisseur
Caractère 48 | Saisie du code famille (O/N/I, O par défaut) O Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 49 à 51 | Code famille par défaut
Caractère 52 | Saisie obligatoire du code famille N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS
Caractère 55 | Saisie du code sous-famille (O/N/I, O par défaut) O Saisie avec contrôle N Pas de saisie I Saisie sans contrôle
Caractères 56 à 58 | Code sous-famille par défaut
Caractère 59 | Saisie obligatoire du code sous famille N Non (par défaut) O/B Bloquant C avec confirmation W Warning avec mot de passe indiqué dans la note CHAMPS_NON_SAISIS

NB : La saisie du code famille et du code sous-famille ne sera pas possible si un article est saisi car elles dépendent automatiquement de celui-ci.

Valeur alpha 3

Caractère 1 | Saisie des plages de quantités (O/N, O par défaut) O Saisie N Pas de saisie
Caractère 2 | Contrôle de chevauchement sur les plages de quantités (O/N, N par défaut) O Contrôle N Pas de contrôle
Caractère 5 | Saisie des plages de dates (O/N, O par défaut) O Saisie N Pas de saisie
Caractère 6 | Contrôle de chevauchement sur les plages de dates (O/N, N par défaut) O Contrôle N Pas de contrôle
Caractère 13 | Faut-il forcer le jour de début et de fin des plages de dates ? (O/N, N par défaut) O Forçage N Pas de forçage
Caractères 14 à 15 | Jour de la date de début
Caractères 16 à 17 | Jour de la date de fin Mettre 31 pour fin de mois

Valeur alpha 4

Caractères 1 à 5

Mot de passe

Notes

S | Complément de requête Exemple : S order by rm_rem, rm_cat, rm_datd, rm_datf
CHAMPS_NON_SAISIS | 21,25 Mot de passe pour répondre au warning en cas de non saisie de certaines zones. Voir alpha2[5], [15], [34], [45], [52], [59]

NB

Le code remise, le type et le code de catégorie, le code article, le code client, le code famille et le code sous-famille peuvent être passés en paramètre lors de l'appel de la fonction de saisie des remises. Dans ce cas ils sont prioritaires et ils deviennent figés et non modifiables.


#CF RFX Configuration générale des cubes

Ce paramètre est utilisé par le programme reflexclient_cube.

Lors de la modification de certaines zones dans la fiche client ou la fiche produit, alimenter une table de modification indiquant qu'il est nécessaire de recalculer les cubes pour les clients ou les produits modifiés.

Valeur alpha 1

#CF RFX A1[1]

Activation de la traçabilité des clients et articles modifiés ayant un impact sur le cube ? (O/N, N par défaut)

Si cet indicateur est à O, on réalisera une détection automatique des modifications de fiches clients ou articles sur des champs utilisés par les cubes.

La liste des clients ou articles modifiés est stockée dans la table crmk_fiche_modif.

Lors du traitement journalier du cube, on recalculera alors tous les éléments des cubes concernant ces clients ou articles.

#CF RFX A1[2]

Activer l'alimentation des zones mesures ERP pour le cube commande (O/N, N par défaut)

Si cet indicateur est à O, on utilisera les notes CDE_MES* pour remplir les zones mesure_erp_xxx de la table crmk_commande.

#CF RFX A1[3]

Activer la lecture de la configuration de la consolidation (O/N, N par défaut)

Si cet indicateur est à O, on utilisera les notes CNS_* pour définir des méthodes d'initialisation des codes consolidation pour les tables filles (société, famille, etc.)

Si cet indicateur est à N, tous les codes consolidations seront initialisés à blanc. C'est l'option à choisir si vous n'envisagez pas de consolidation inter-bases.

Valeur alpha 2

#CF RFX A2[1,2]

Numéro d'environnement ReflexClient associé à cette société.

Il sera utilisé pour alimenter la table crmk_fiche_modif.

A noter qu'on le retrouve aussi sur les paramètres de lancement des calculs des cubes.

Notes

TSC_FORME_DECOUPE | 21,23 Code TSC qui contient le code article de la forme de découpe (Par défaut : 300)
TSC_GAMME_PRODUIT | 21,23 Code TSC qui contient le code article de la gamme de produit (Par défaut : GAM)

CONSOLIDATION

Notes de configuration de la consolidation

CNS_table

21,22 Méthode d'initialisation de la zone cod_consolidation pour chacune des tables filles (liste ci-dessous)

BL Blanc. Le code consolidation reste à blanc.
A utiliser pour des tables qui n'ont rien en commun entre les bases consolidées.
Exemple : les commerciaux, les produits.

BE Blanc avec exception possible. Le code consolidation est à blanc avec possibilité de forcer un code d'exception pour la donnée concernée.
Voir le paragraphe Saisie des exceptions plus bas.
Exemple : les sociétés, si vous avez quelques clients communs entre les bases consolidées, vous pourrez ici préconfigurer des codes de consolidation identique (via le TSC RFX).

CO Le code de la donnée est utilisé comme code consolidation.
Exemple : les devises, les familles où même les sociétés si votre organisation interne a anticipé cette codification commune des clients entre différentes bases.

CE Le code de la donnée est utilisé comme code consolidation mais vous avez la possibilité de forcer un code d'exception pour la donnée concernée.
Voir le paragraphe Saisie des exceptions plus bas.
Exemple : les familles mais avec une exception possible propre à une base.

Saisie des exceptions (consolidation)

Les exceptions évoquées ci-dessus dans les codes BE et CE sont saisissables dans différents endroits selon la nature de la donnée :

--> Pour toutes les données de type paramètre (ou sous-famille), le code de consolidation d'exception est saisi dans la note RFX_CONSOLIDATION.

RFX_CONSOLIDATION

21,30 Code de consolidation d'exception (pour toutes les données de type paramètre (ou sous-famille))

--> Pour toutes les données ou les informations complémentaires (TSC), le code de consolidation d'exception est saisi dans le TSC RFX, zone ic_char30.

Ligne de note du TSC RFX :

TIC*

ZGCode consolidé N Z Conso :

Consolidation : Liste des tables configurables

Code de la table

Nom

Saisie de l'exception via

societe

groupe_erp

fournisseur

centre_cout

societe_adr

produit

produit_ach

qualite_mat

produit_fab

compo_com

compo_tech

commercial

suivi_affaire

unite_vente

mode_reglem

echeance

devise

type_commande

fabricant

deviseur

type_produit

etat_dev

motif_eta_dev

remise_prix

unite_plus

stat_1

stat_2

stat_3

stat_4

zone_param_c1

sect_geo

sect_activite

categorie

cl_zpar1

cl_zpar2

cl_zpar3

type_cde_ach

param_c1_ach

acheteur

signataire

unite_ach

unite_uti

site

statut_rep

sfdv

cannelure

famille

fam_ach

fam_qual

fam_fab

fam_com

fam_tech

sous_famille

sous_fam_ach

sous_fam_qual

sous_fam_fab

sous_fam_com

sous_fam_tech

Prospects et clients

Groupe Volume

Fournisseur

Centre de coût

Société et adresses secondaires

Produit commandé

Produit acheté

Qualité matière

Produit fabriqué

Composition commerciale

Composition technique

Commercial

Suivi d'affaire

Unité de vente

Mode de règlement

Echéance

Devise

Type de commande client

Fabricant

Deviseur

Type de produit (devis)

Etat du devis

Motif lié à l'état du devis

Remise de prix au

Unité du plus

Code statistique 1

Code statistique 2

Code statistique 3

Code statistique 4

Zone paramétrable entête de commande

Secteur géographique

Secteur d'activité

Catégorie

Zone configurable 1 de la fiche client

Zone configurable 2 de la fiche client

Zone configurable 3 de la fiche client

Type de commande d'achat

Zone param. entête de commande d'achat

Acheteur

Signataire (achat)

Unité d'achat

Unité d'utilisation

Site

Statut du commercial

Structure de force de vente

Cannelure

Famille

Famille d'achat

Famille de qualité matière

Famille de fabrication

Famille de composition commerciale

Famille de composition technique

Sous-Famille

Sous-Famille d'achat

Sous-Famille de qualité matière

Sous-Famille de fabrication

Sous-Famille de composition commerciale

Sous-Famille de composition technique

TSC RFX sur tiers

TSC RFX sur tiers

TSC RFX sur fournisseur

TSC RFX sur client et/ou adresse secondaire

TSC RFX sur article

TSC RFX sur article

TSC RFX sur article

TSC RFX sur article

TSC RFX sur article

TSC RFX sur article

Note sur paramètre REP

Note sur paramètre FAB

Note sur paramètre UNI

Note sur paramètre MRG

Note sur paramètre ECH

Note sur paramètre DEV

Note sur paramètre TYC

Note sur paramètre FAB

Note sur paramètre VED

Note sur paramètre TPR

Note sur paramètre ETD

Note sur paramètre MRD

Note sur paramètre QRP

Note sur paramètre UNI

Note sur paramètre CS1

Note sur paramètre CS2

Note sur paramètre CS3

Note sur paramètre CS4

Note sur paramètre configurable

Note sur paramètre GEO

Note sur paramètre ACT

Note sur paramètre CAT

Note sur paramètre configurable

Note sur paramètre configurable

Note sur paramètre configurable

Note sur paramètre TYF

Note sur paramètre configurable

Note sur paramètre ACH

Note sur paramètre SIG

Note sur paramètre UNI

Note sur paramètre UNI

Note sur paramètre SIT

Note sur paramètre SRE

Note sur paramètre SFV

Note sur paramètre PC

Note sur paramètre FAM

Note sur paramètre FAM

Note sur paramètre FAM

Note sur paramètre FAM

Note sur paramètre FAM

Note sur paramètre FAM

Note sur la sous-famille

Note sur la sous-famille

Note sur la sous-famille

Note sur la sous-famille

Note sur la sous-famille

Note sur la sous-famille

Pour ReflexClient, les sous-familles sont toujours hiérarchiques

INTEGRATION HISTORIQUE PRIX DE REVIENT

Notes de configuration de l'intégration historique prix de revient :

Chaque ligne du cube commande (table crmk_commande) contient 100 mesures ERP : mesure_erp_001 à mesure_erp_100.

Le but de cette configuration est de décrire les règles d'alimentation de chacune des ces zones.

CDE_MES_xxx | 21,60 Code calcul zone ou formule de calcul Affectation directe du contenu d'une zone mesure_erp_xxx avec xxx compris entre 001 et 100.
CDE_VAR_v | 21,60 Code calcul zone ou formule de calcul Affectation directe du contenu d'une variable temporaire v qui sera réutilisée dans une formule de calcul, avec v pouvant prendre les valeurs a à z et A à Y.
CDE_MES_xxx_VAR_v | 21,60 Code calcul zone ou formule de calcul Affectation directe du contenu d'une zone mesure_erp_xxx et mémorisation dans le même temps du résultat dans une variable v

Possibilité d'ajouter des commentaires

Dans la zone de 21 à 60, il est possible d'ajouter un commentaire précédé de --# (moins moins dièse).

Ce commentaire permet notamment de préciser le nom de la mesure erp affectée.

Exemple

CDE_MES_001 A-hp_z1 --# Cout prévu

Remarque sur l'évaluation

L'évaluation des affectations est toujours réalisée en parcourant les notes de haut en bas.

Ainsi, une fois une variable x affectée, elle peut être utilisée dans les lignes de notes qui suivent.

Sur le même principe, elle peut tout à fait être réaffectée après avoir été utilisée par une formule de calcul.

Formules de calcul

Les formules de calcul utilisent l'interpréteur standard de Volume.

Attention, dans ce cas, le symbole = (égal) doit être présent en colonne 20 de manière à préciser qu'une formule de calcul est décrite de 21 à 60.

Exemples de formules

ab/ | a / b
a#>0?exp1;exp2 | Evalue la variable a. Si positif, renvoie l'évaluation de l'expression exp1, sinon renvoie l'évaluation de l'expression exp2.

Codes calcul

X-hp_zn | Lecture de l'enregistrement historique prix de revient (hist_pr) de type X pour la zone numéro n. - Avec X variant de A à Z et de 0 à 9 - Avec n variant de 1 à 15. Dans le cas particulier où l'on rencontre plusieurs enregistrements dans hist_pr pour une même commande et même type, on choisit la plus récente (hp_date_enr le plus grand. Exemple : A-hp_z7
[XYZ]-hp_zn | Lecture de l'enregistrement historique prix de revient (hist_pr) de type X pour la zone numéro n. Si l''enregistrement n'est pas trouvé, on tente de lire le type Y. Si à nouveau pas trouvé, on tente de lire le type Z.

On peut accéder à quelques mesures du cube commande :

qte_commandee

qte_livree

qte_facturee

qte_retournee

qte_reste_a_liv

qte_reste_a_fac

qte_lancee

qte_fabriquee

qte_reste_a_fab

Quantité commandée

Quantité livrée

Quantité facturée

Quantité retournée

Quantité restant à livrer

Quantité restant à facturer

Quantité lancée

Quantité fabriquée

Quantité restant à fabriquer

mtt_cde_brut

mtt_cde_rist

mtt_cde_net

mtt_liv_brut

mtt_liv_rist

mtt_liv_net

mtt_fac_brut

mtt_fac_rist

mtt_fac_net

mtt_ret_brut

mtt_ret_rist

mtt_ret_net

mtt_rsta_liv_brut

mtt_rsta_liv_rist

mtt_rsta_liv_net

mtt_rsta_fac_brut

mtt_rsta_fac_rist

mtt_rsta_fac_net

Montant commandé brut

Montant ristourne sur le commandé

Montant commandé net

Montant livré brut

Montant ristourne sur le livré

Montant livré net

Montant facturé brut

Montant ristourne sur le facturé

Montant facturé net

Montant retourné brut

Montant ristourne sur le retourné

Montant retourné net

Montant restant à livrer brut

Montant ristourne sur le restant à livrer

Montant restant à livrer net

Montant restant à facturer brut

Montant ristourne sur le restant à facturer

Montant restant à facturer net

mtt_prx_revient

Montant du prix de revient (prévisionnel) tel que renseigné dans cde2.lc_prx_revient

poids_uni_brut

poids_uni_net

surface_uni_brute

surface_uni_nette

Poids unitaire brut

Poids unitaire net

Surface unitaire brute

Surface unitaire nette

mesure_erp_001

mesure_erp_002

…

mesure_erp_100

Chaque variable mesure_erp_xxx est alimentée dès que la ligne de note CDE_MES_xxx a été évaluée.

Exemples

CDE_MES_001 1-hp_z1 --# Qte lancée

CDE_MES_002 1-hp_z2 --# Qte fab

CDE_MES_003 qte_lancee

CDE_MES_010 2-hp_z1 --# Cout prévu total

CDE_MES_011 2-hp_z2 --# Cout prévu oper var

CDE_MES_012 4-hp_z1 --# Cout prévu oper fixe

CDE_MES_013 2-hp_z11 --# Commission prévue

CDE_MES_014 2-hp_z12 --# Prime fidelité prévue

CDE_MES_015 4-hp_z2 --# Frais ADM fixe

CDE_MES_016 6-hp_z1 --# Transport prévu

CDE_MES_017 6-hp_z3 --# Amortisst prévu

CDE_MES_020 3-hp_z1 --# Cout réalisé total

CDE_MES_021 3-hp_z2 --# Cout réalisé oper var

CDE_MES_022 5-hp_z1 --# Cout réalisé oper fixe

CDE_MES_023 3-hp_z11 --# Commission réalisé

CDE_MES_024 3-hp_z12 --# Prime fidelité réalisé

CDE_MES_025 5-hp_z2 --# Frais ADM fixe

CDE_MES_026 6-hp_z2 --# Transport réal

CDE_MES_027 6-hp_z4 --# Amortisst réal

{ Le paragraphe qui suit doit être re-vérifié }

Zones déclenchant la mise à jour de la table crmk_fiche_modif

cli : cl_pays - cl_codp - cl_geo - cl_act - cl_cat - cl_zpar - cl_ape - cl_cligr

cli2 : c2_pays - c2_codp - c2_geo

mat : mp_cs1 - mp_cs2 - mp_cs3 - mp_cs4 - mp_uv - mp_fam - mp_sfm - mp_long - mp_larg - mp_poids - mp_qualite_matiere - mp_fconv

INTEGRATION DU CUBE DE PRODUCTION

Le cube production permet entre autres de calculer le taux de rendement synthétique (TRS).

La clé d'activation CRM-08 (VoluPack/VoluPrim) et la version 2.8.2 de ReflexClient Cubes sont nécessaires.

Programme reflexclient_cube : positionner les options OIt et Ort, ainsi que A2[10].

Notes

Paramètres généraux du cube de production

PRO_FAC_HEU_DEB

21,25 Heure de début de faction au format HH:MM.

Par défaut : 05:00

Le cube de production gère une date de faction. Les saisies de temps commençant entre minuit et cette heure de début de faction seront affectées à la date de faction du jour précédent.

Décomposition des temps selon le TTR

Dans le cube de production, chaque ligne de saisie de temps est affectée à une catégorie :

• Production, décomposés (selon le type d'opération) en

o calage

o roulage

• Arrêts, décomposés en :

o Arrêts de production

 Arrêts de production propres

 Arrêts de productions induits

o Arrêts structurels

Outre le calage/roulage qui dépend de l'opération, cette affection dépend du TTR et est pilotée par le paramétrage suivant :

PRO_TTR_PNQ_ADD

21,23 Code du type paramètre TTR.

Affectation d'un TTR à une activité Production non qualifiée.

Il s'agit d'une activité de production, par opposition à un arrêt.

Non qualifié signifie qu'on ne souhaite pas conserver ce TTR dans le cube.

Exemples : #R, #P, CAL ou ROU qui n'apportent rien dans les analyses, étant donné que c'est l'opération qui indique déjà au cube s'il s'agit d'un calage ou d'un roulage.

Par défaut : si aucune indication n'est donnée pour un TTR, il sera affecté à cette catégorie.

(Plusieurs lignes possibles)

PRO_TTR_PQL_ADD

21,23 Code du type paramètre TTR

Affectation d'un TTR à une activité Production qualifiée.

Il s'agit d'une activité de production, par opposition à un arrêt.

Cette fois, on conserve le TTR; on souhaite en disposer en analyse dans les cubes.

Il faut avoir à l'esprit que pour une opération de roulage, les temps affectés à des TTR en production qualifiée ou non qualifiée, entrent dans le cumul des temps qui permettra de calculer la cadence réelle de la machine (en fonction des quantités produites déclarées.

Ainsi, un TTR Lavage devra être classé en arrêt structurel, car les temps de lavage ne doivent pas entrer dans les temps permettant de mesurer la cadence de la machine.

(Plusieurs lignes possibles)

PRO_TTR_APP_ADD

21,23 Code du type paramètre TTR.

Affectation d'un TTR à une activité arrêt de production propre.

L'arrêt de production propre trouve son origine dans le poste de travail en lui-même.

Exemples : pannes, changement d'outils, etc.

(Plusieurs lignes possibles)

PRO_TTR_API_ADD

21,23 Code du type paramètre TTR.

Affectation d'un TTR à une activité arrêt de production induit.

L'arrêt de production induit (ou subi) n'est pas dépendant du poste de travail en lui-même, mais trouve son origine en amont ou à l'extérieur de la machine.

Exemple : manque de matière, manque de personnel, défaut d'énergie, blocages amont, etc.

(Plusieurs lignes possibles)

PRO_TTR_ARS_ADD

21,23 Code du type paramètre TTR.

Affectation d'un TTR à une activité arrêt structurel.

Aussi appelé temps de désengagement du moyen de production ou arrêt planifié.

Il qualifie un temps où il n'était pas prévu de produire.

Exemple : nettoyage, maintenance préventive, essais, formation, pauses, réunions, sous-charge, etc.

(Plusieurs lignes possibles)

Impact de cette affectation des TTR :

Reportez-vous au document ReflexClient – Cube production et TRS pour en savoir plus.

Définition des axes de dépendances.

Le cube propose 30 axes de dépendances configurables.

Dans les paramètres ci-dessous, le numéro d'axe varie de 001 à 030.

Cas de dépendances numériques.

Exemple complet

PRO_DEP_001_LIB Grammage

PRO_DEP_001_ADD DC -DEC-ROU:DN1

PRO_DEP_001_ADD CO -COL-ROU:DN2

PRO_DEP_001_MAX 9999

PRO_DEP_001_USI ###&

PRO_DEP_001_LIB

21,60 Libellé de la dépendance et donc le libellé de l'axe qui sera importé dans ReflexClient.

Il apparaîtra comme tel à l'utilisateur du cube.

Exemple

PRO_DEP_001_LIB Grammage

PRO_DEP_001_ADD

21,60 Opération standard et numéro de dépendance.

On désigne ici chacune des opérations standards porteuses de cette dépendance.

Si par exemple, je créé une dépendance numérique Nombre de couleurs, je vais lister ici les opérations standards où cette notion apparaît.

Format : SEC-OPE-SOP:DN4

• SEC-OPE-SOP : l'opération standard (du caractère 1 à 11).
La section, opération ou sous-opération occupent toujours 3 caractères.
Les - séparateurs sont donc toujours en position 4 et 8.

• DN4 : DN signifie Dépendance Numérique et le 4 représente le numéro de dépendance au sein de l'opération standard. Il varie de 1 à 4.

Exemples

PRO_DEP_001_ADD DC -DEC-ROU:DN1

PRO_DEP_001_ADD CO -COL-ROU:DN2

(Plusieurs lignes possibles)

PRO_DEP_001_MAX

21,60 La valeur maximum significative pour la borne supérieure de cette dépendance numérique dans les opérations élémentaires.

L'objectif de l'axe dépendance Grammage est d'afficher un contenu de la forme :

[Non applicable)

Grammage - 0 à 349

Grammage - 350 à 449

Grammage - 450 et plus

Grammage - Dans tous les cas

Ainsi lorsque des opérations élémentaires disposant d'une borne maximale, supérieure ou égale à ce paramétrage, elle apparaîtra sous la forme 450 et plus et non pas 450 à 99999999.

Exemple

PRO_DEP_001_MAX 9999

PRO_DEP_001_USI

21,60 Le masque d'affichage (using) de la valeur numérique inférieure de la plage.

On utilisera de préférence des usings composés de dièses (#) plutôt que des symboles inférieur (<) de manière à ce que les plages apparaissent dans un ordre croissant.

Exemple

PRO_DEP_001_MAX ###&

Cas des dépendances alphanumériques

Exemple complet

PRO_DEP_012_LIB Type ECMA

PRO_DEP_012_ADD CO -COL-CAL:DA1

PRO_DEP_012_ADD CO -COL-ROU:DA1

PRO_DEP_012_DAL CS:Collage supérieur

PRO_DEP_012_DAL DAP:Découpe à plat

PRO_DEP_012_DAL FA:Fond auto

PRO_DEP_001_LIB

21,60 C'est le libellé de la dépendance et donc le libellé de l'axe qui sera importé dans ReflexClient.

Il apparaîtra comme tel à l'utilisateur du cube.

PRO_DEP_001_ADD

21,60 Opération standard et numéro de dépendance.

On désigne ici chacune des opérations standards porteuses de cette dépendance.

Format : SEC-OPE-SOP:DA4

• SEC-OPE-SOP : l'opération standard (du caractère 1 à 11).
La section, opération ou sous-opération occupent toujours 3 caractères.
Les - séparateurs sont donc toujours en position 4 et 8.

• DA4 : DN signifie Dépendance Alphanumérique et le 4 représente le numéro de dépendance au sein de l'opération standard. Il varie de 1 à 4.

Exemples

PRO_DEP_012_ADD CO -COL-CAL:DA1

PRO_DEP_012_ADD CO -COL-ROU:DA1

(Plusieurs lignes possibles)

PRO_DEP_001_DAL

21,60 Une expression permettant d'associer un libellé clair à un code rencontré dans les dépendances alphanumériques.

Les opérations élémentaires contiennent en dépendances alphanumériques des codes qui n'ont pas toujours un libellé associé dans Volume.

On peut donc ici décrire plusieurs expressions de la forme : CODE:Libellé

où :

• CODE est la valeur de la dépendance alpha.

• Libellé est le libellé qu'on lui associe

Exemple

PRO_DEP_012_DAL CS:Collage supérieur

PRO_DEP_012_DAL DAP:Découpe à plat

PRO_DEP_012_DAL FA:Fond auto

(Plusieurs lignes possibles)

Imposer le type d'opération (calage ou roulage) via le TTR

(Paramètres optionnels – ne devraient normalement pas être utilisés)

PRO_ROU_IMPOSE_DEF

21 Imposer le type d'opération via le TTR (O/N, N par défaut)

Si N : Pas d'imposition ; on est dans le fonctionnement classique;
c'est l'opération qui induit le type d'opération (calage ou roulage).

Si O : c'est le TTR qui induit le fait qu'on soit en calage ou roulage.
Par défaut, toutes les lignes de temps sont considérées en roulage et le paramétrage ci-dessous permet de décrire les lignes de temps de calage.

PRO_CAL_IMPOSE_TTR

21,60 Liste des TTR imposant le calage

N'a de sens que si le paramètre PRO_ROU_IMPOSE_DEF ci-dessus = O.

Permet de lister les TTR pour lesquels les lignes de saisie de temps seront des calages, et non des roulages, comme c'est le cas par défaut.

(Plusieurs lignes possibles)

Imposer la fonction Aide par le TTR

(Paramètres optionnels)

PRO_FON_AID_TTR

Liste des TTR imposant la fonction Aide, même si la ligne de temps a été saisie en tant que Responsable.

Pour tout TTR non spécifié, on conserve la fonction opérateur saisie.

(Plusieurs lignes possibles)


#CF REC Récapitulatif des coûts

• Par défaut, les indicateurs sont historisés comme suit :

o Le type d'enregistrement (hp_type) dépend du contexte de calcul :

 Commande/Prévisionnel : Type d'historique M

 Commande/Réel : Type d'historique N

 Facture/Prévisionnel : Type d'historique X

 Facture/Réel : Type d'historique Y

o Les zones hp_z1 à hp_z15 contiennent les 15 premiers indicateurs dans l'ordre du paramétrage.

• A partir du moment où une note de paramétrage d'historisation est créée (note commençant par _HIS_INDIC*), le fonctionnement par défaut n'est plus utilisé.
Si le type d'enregistrement (hp_type) n'est pas renseigné pour le réel, celui-ci n'est pas historisé.
De même, si aucun type n'est renseigné pour le contexte de facturation, les indicateurs ne seront pas historisés au niveau des factures.

• Chaque paramétrage d'historisation d'indicateur doit être associé au paramétrage de l'indicateur qui doit être historisé (voir exemple ci-dessous), de la façon suivante :

o Paramétrage de l'indicateur n°1 (« _TIT_INDIC* »)

o Paramétrage d'historisation de l'indicateur n°1 (« _HIS_INDIC* »)

o Paramétrage de l'indicateur n°2 (« _TIT_INDIC* »)

o Paramétrage d'historisation de l'indicateur n°2 (« _HIS_INDIC* »)

o etc.

• Lorsque le type d'historique est renseigné pour l'environnement :

o Si la zone d'historique pour l'environnement Commande/Réel n'est pas renseigné, on prend par défaut la zone d'historique de l'environnement Commande/Prévisionnel.

o Si la zone d'historique pour l'environnement Facture/Prévisionnel n'est pas renseigné, on prend par défaut la zone d'historique de l'environnement Commande/Prévisionnel.

o Si la zone d'historique pour l'environnement Facture/Réel n'est pas renseigné, on prend par défaut la zone d'historique de l'environnement Facture/Prévisionnel.

Exemple 1 : Paramétrage simulant le fonctionnement par défaut :

• Le type d'enregistrement (hp_type) dépend du contexte de calcul :

o Commande/Prévisionnel : Type d'historique M

o Commande/Réel : Type d'historique N

o Facture/Prévisionnel : Type d'historique X

o Facture/Réel : Type d'historique Y

• Les zones hp_z1 à hp_z15 contiennent les 15 premiers indicateurs dans l'ordre du paramétrage.

_TIT_INDIC*Coût matière*FOR_01*### ##&.&&* Paramétrage de l'indicateur n°1

_HIS_INDIC*M*hp_z1*N*hp_z1*X*hp_z1*Y*hp_z1* Paramétrage de l'historisation de l'indicateur n°1

_TIT_INDIC*… Paramétrage de l'indicateur n°2

_HIS_INDIC*M*hp_z2*N**X* *Y** Paramétrage de l'historisation de l'indicateur n°2

Remarque : Ici, les zones d'historique pour l'environnement Commande/Réel, Facture/Prévisionnel et Facture/Réel ne sont pas précisées.

On prend par défaut les zones de l'environnement Commande/Prévisionnel : hp_z2

_TIT_INDIC*… Paramétrage de l'indicateur n°15

_HIS_INDIC*M*hp_z15*N**X* *Y** Paramétrage de l'historisation de l'indicateur n°15

Exemple 2 : Paramétrage d'historisation de quelques indicateurs spécifiques

Contexte :

L'environnement réel n'est pas utilisé.

20 indicateurs sont paramétrés.

On ne souhaite pas historiser tous les indicateurs mais seulement :

• l'indicateur n°3 dans la zone historisée n°1 du type M (commande) et X (facture)

• l'indicateur n°5 dans la zone historisée n°2 du type M (commande) et X (facture)

• l'indicateur n°16 dans la zone historisée n°3 du type M (commande) et X (facture)

• l'indicateur n°20 dans la zone historisée n°1 du type A (commande) (pas d'historisation de cet indicateur au niveau de la facture)

_TIT_INDIC*Coût matière*FOR_01*### ##&.&&* Paramétrage de l'indicateur n°1

_TIT_INDIC*… Paramétrage de l'indicateur n°2

_TIT_INDIC*… Paramétrage de l'indicateur n°3

_HIS_INDIC*M*hp_z1***X* Paramétrage de l'historisation de l'indicateur n°3

_TIT_INDIC*… Paramétrage de l'indicateur n°4

_TIT_INDIC*… Paramétrage de l'indicateur n°5

_HIS_INDIC*M*hp_z2***X* Paramétrage de l'historisation de l'indicateur n°5

_TIT_INDIC*… Paramétrage de l'indicateur n°6

_TIT_INDIC*… Paramétrage de l'indicateur n°7

_TIT_INDIC*… Paramétrage de l'indicateur n°8

_TIT_INDIC*… Paramétrage de l'indicateur n°9

_TIT_INDIC*… Paramétrage de l'indicateur n°10

_TIT_INDIC*… Paramétrage de l'indicateur n°11

_TIT_INDIC*… Paramétrage de l'indicateur n°12

_TIT_INDIC*… Paramétrage de l'indicateur n°13

_TIT_INDIC*… Paramétrage de l'indicateur n°14

_TIT_INDIC*… Paramétrage de l'indicateur n°15

_TIT_INDIC*… Paramétrage de l'indicateur n°16

_HIS_INDIC*M*hp_z3***X* Paramétrage de l'historisation de l'indicateur n°16

_TIT_INDIC*… Paramétrage de l'indicateur n°17

_TIT_INDIC*… Paramétrage de l'indicateur n°18

_TIT_INDIC*… Paramétrage de l'indicateur n°19

_TIT_INDIC*… Paramétrage de l'indicateur n°20

_HIS_INDIC*A*hp_z1* Paramétrage de l'historisation de l'indicateur n°20

poids_uni_ensemble Poids unitaire de l'ensemble

prix_remis_offre Prix remis de l'offre

prix_negocie_retenu Prix de vente négocié de l'offre de vente retenue

prix_remis_retenu Prix de vente remis de l'offre de vente retenue

prix_offre_retenu Prix de vente de l'offre de vente retenue
(prix de vente négocié si la zone est renseignée, sinon prix remis)

qte_ensemble Quantité de l'ensemble

Pour les zones prix_xxx_retenu, il s'agit d'un prix total pour la quantité de l'offre de vente retenue (prix de vente négocié/remis dans l'unité de remise de prix multiplié par la quantité de l'offre de vente retenue).

cout_fixe_transport Coût fixe de transport

cout_transport Coût global de transport

cout_vari_transport Coût variable de transport

heure_machine_hc Heures de machines en heure/centièmes

heure_machine_hm Heures de machines en heure/minutes

poids_uni_brut_gr Poids unitaire brut (en g)

poids_uni_brut_kg Poids unitaire brut (en kg)

poids_uni_net_gr Poids unitaire net (en g)

poids_uni_net_kg Poids unitaire net (en kg)

prix_negocie Prix négocié dans l'unité de remise de prix

prix_negocie_devis Prix négocié de l'ensemble

prix_remis_devis Prix de l'ensemble

qte_devis Quantité de l'ensemble

surf_uni_brute_m2 Surface unitaire brute (en m2)

surf_uni_nette_m2 Surface unitaire nette (en m2)

total_pr Total des prix de revient de l'écran des marges
Il est possible de limiter le calcul du total via le complément de sélection _SUP_REQ_FLE_MAR_RCP.

SOMME_a_bbb_ccc Somme des coûts :

a type de coûts

V Variables

F Fixes

A Autres

X pas de critère

bbb catégorie

MAT Matière (calculé à partir du prix de vente)

MPR Matière (calculé à partir du prix de revient) (devis multi-métiers)

OPE Opération

STR Sous-traitance (calculé à partir du prix de vente)

SPR Sous-traitance (calculé à partir du prix de revient) (devis multi-métiers)

XXX Pas de critère

ccc niveau de regroupement

Paramètre NCC

XXX pas de critère

TSC selon la syntaxe générale d'appel des TSC

Permettre dans le calcul du récapitulatif des coûts (via la saisie des commandes ou le batch de réactualisation des coûts) de sélectionner automatiquement la méthode de réactualisation 2 (offre fictive) si le pourcentage d'écart entre la quantité commandée et la quantité devisée est supérieur à un montant paramétré (cette sélection ne s'applique que lorsque la méthode 1 est utilisée par défaut).

Méthode de calcul du pourcentage d'écart :

% Ecart = ((Quantité commandée – Quantité devisée) / Quantité commandée) X 100

Rappel :

la méthode de réactualisation (1 ou 2) est indiquée dans la valeur numérique 1 du paramètre de lancement du batch de réactualisation des coûts.

#CF REC Récapitulatif des coûts

Un certain nombre de programmes peuvent réactualiser le récapitulatif des coûts.

Pour ces programmes, le paramétrage de mise à jour des coûts peut se faire de 2 manières différentes :

  • dans leur propre paramètre de lancement

  • dans un paramètre de configuration (comme le #CF REC, par exemple) - Méthode recommandée

Option PRO 04 nécessaire

Pour que le paramétrage soit recherché dans un paramètre de configuration, la note PARAM_INDICATEURS doit être déclarée dans le paramètre de lancement. Cette note indique le paramètre de configuration où figurent les notes pour la réactualisation du récapitulatif des coûts.

Quand la note PARAM_INDICATEURS est configurée, toutes les autres notes de réactualisation du récapitulatif des coûts sont ignorées dans le paramètre de lancement.

Le paramètre de configuration généralement utilisé est le #CF REC. Toutes les notes concernées sont documentées ici.

Pour éviter les répétitions, elles ne sont pas documentées dans les paramètres de lancement; elles sont juste citées avec un lien vers le #CF REC.

Les programmes concernés sont les suivants :

  • saisie du devis onduleur

  • édition VoluEdit du devis onduleur

  • saisie du devis multi-métiers

  • saisie des commandes clients

  • visualisation des commandes clients

  • batch de réactualisation des coûts du devis onduleur

  • batch de réactualisation des coûts du devis multi-métiers

  • calcul et édition des factures

  • visualisation des articles

Option PRO 04 nécessaire

Notes pour le récapitulatif des coûts

_FOR_INDIC_

12,13 Numéro de formule

15,16 Précision de l'arrondi (nombre de décimales)

18,60 Formule en notation polonaise inversée

_HIS_INDIC*

Paramétrer l'historisation des indicateurs du récapitulatif des coût

(enregistrement dans la table de l'historique des prix de revient : hist_pr)

Les 8 champs suivants doivent être séparés par un astérisque :

1 Type d'enregistrement d'historique (hp_type) pour les indicateurs de coûts Commande/Prévisionnel

2 Zone d'enregistrement d'historique (hp_z1, hp_z2, …, hp_z15) pour les indicateurs de coûts Commande/Prévisionnel

3 Type d'enregistrement d'historique (hp_type) pour les indicateurs de coûts Commande/Réel

4 Zone d'enregistrement d'historique (hp_z1, hp_z2, …, hp_z15) pour les indicateurs de coûts Commande/Réel

5 Type d'enregistrement d'historique (hp_type) pour les indicateurs de coûts Commande/Prévisionnel

6 Zone d'enregistrement d'historique (hp_z1, hp_z2, …, hp_z15) pour les indicateurs de coûts Facture/Prévisionnel

7 Type d'enregistrement d'historique (hp_type) pour les indicateurs de coûts Commande/Prévisionnel

8 Zone d'enregistrement d'historique (hp_z1, hp_z2, …, hp_z15) pour les indicateurs de coûts Facture/Réel

ATTENTION :

Chaque note doit se situer sous la note de paramétrage de l'indicateur devant être historisé, commençant par _TIT_INDIC*

Remarques

Exemples

_TIT_INDIC*

12,60 Les 3 champs suivants doivent être suivis par un astérisque :

Titre ou libellé de l'indicateur

Code du champ. Voir paramétrage du code de champs d'une formule (_FOR_INDIC)

Format d'affichage de l'indicateur

_VAR_INDIC_

12 Code de la variable à utiliser dans les formules de calcul

14,60 Code champ correspondant.

Champs disponibles pour le devis onduleur

Champs disponibles pour le devis multi-métiers, la saisie et la visu de commande

Champs disponibles communs

Autres Notes

CODE_BLOCAGE_RCP

21,23 Code blocage d'absence d'indicateurs de rentabilité client sur la ligne de commande

24 Si le code blocage existe sur la ligne de commande et qu'il a été débloqué manuellement, faut-il le re-bloquer automatiquement en cas de problème lors de la réactualisation ?

O Re-blocage systématique (par défaut)

N Pas de re-blocage

C Demande de confirmation
Si le programme de réactualisation est exécuté en mode batch, cette valeur correspond à la valeur O.

DS_DOUBLE_CALCUL

UNIQUEMENT POUR DEVIS MULTI-METIERS

21 Activer le double calcul du devis multi-métiers lors de la réactualisation des coûts (O/N, N par défaut)

DS_GESTION_EFFECTIF

UNIQUEMENT POUR DEVIS MULTI-METIERS

21 Activer la gestion de l'effectif du devis multi-métiers lors de la réactualisation des coûts (O/N, N par défaut)

DS_RAZ_QUANTITES

21 Activer la remise à zéro des quantités des opérations si le temps total est à zéro (O/N, O par défaut)

LISTE_TYC_CALC_RCP

21,59 Liste des types de commandes (TYC) pour lesquels le calcul et la visualisation des indicateurs de rentabilité client sont activés

13 codes de 3 caractères par ligne

Par défaut : La liste est composée des TYC suivants : AVO, CD1, CD2, FAD, FBI et FB2.

Remarques :

• Le paramétrage concerne uniquement les TYC de rattachement (voir TYC A4[13,15]).

• La liste des TYC de rattachement par défaut n'est utilisée que si aucun TYC n'est paramétré.
à partir du moment où un ou plusieurs TYC sont paramétrés, seuls ces derniers sont pris en compte.

MAJ_LC_PRX_RVT_RCP

21,22 Numéro de formule du tableau des indicateurs du récapitulatif des coûts

(caractères 12 et 13 des notes commençant par _FOR_INDIC)

Remarque : fonctionne avec les messages EDI

METHODE_2_ECART_QTE

UNIQUEMENT POUR DEVIS ONDULEURS - Méthode selon écart de quantité (devisée/commandée)

La note saisie sur le paramètre de lancement de programme (cde ou rcp_batch_don) est prioritaire : le paramétrage peut donc être activé par défaut sur le paramètre de configuration #CF REC et désactivé sur un paramètre de lancement particulier.

21 Activation de la sélection automatique de la méthode 2 si l'écart entre la quantité commandée et la quantité devisée est trop important (O/N, N par défaut)

22,24 Pourcentage d'écart minimum à partir duquel la méthode de réactualisation n°2 sera utilisée automatiquement (0 à 100). Par défaut : 50

Exemples avec un % écart minimum = 50

Qté commandée = 5000, Qté devisée = 2000

% d'écart = 60% : La méthode n°2 sera appliquée automatiquement.

Qté commandée : 6000, Qté devisée : 4500

% d'écart = 25% : La méthode n°1 restera appliquée (si c'est la méthode par défaut).

Plus d'infos

PRORAT_PRX_RVT_RCP

21 Mode de proratisation du prix de revient

0 Aucune proratisation (par défaut)

1 Proratisation en fonction de la quantité commandée

2 Proratisation en fonction de la quantité lancée

3 Proratisation en fonction du prix de la ligne de commande (voir ci-dessus)

La formule de calcul du prix de revient est la suivante : PR = PR * (PV / PT) où

PR Prix de revient de la ligne de commande

PV Prix de vente de la ligne de commande

PT Somme des prix des lignes de la commande (hors lignes de frais ou transport)

Voir aussi la note MAJ_LC_PRX_RVT_RCP

Remarque : fonctionne avec les messages EDI

STOCKER_ELEMENT_PRU

Stocker les éléments de calcul du PRU (indicateurs) dans la table d'historisation des prix de revient

Remarque : fonctionne avec les messages EDI

21 Type d'enregistrement d'historisation pour les indicateurs a à o

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

22 Type d'enregistrement d'historisation pour les indicateurs p à D

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

23 Type d'enregistrement d'historisation pour les indicateurs E à S

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

24 Type d'enregistrement d'historisation pour les indicateurs T à Z

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

_SUP_REQ_FLE_MAR_RCP

21,60 Complément de sélection pour le calcul du total des prix de revient de l’écran des marges (table fle_mar)

Si cette note n'est pas trouvée ici, elle sera recherchée dans le paramètre de lancement du devis multi-métiers.

_SUP_REQ_FLE_OPE_RCP

UNIQUEMENT POUR DEVIS MULTI-METIERS

21,60 Complément de sélection sur la table du détail des opérations (fle_ope) pour le calcul des indicateurs des heures de machine

_SUP_REQ_FLE_TRA_RCP

UNIQUEMENT POUR DEVIS MULTI-METIERS

21,60 Complément de sélection sur la table des lignes de transport (fle_tra) pour le calcul des indicateurs des coûts de transport

_SUP_REQ_RCP_MAT_MN

UNIQUEMENT POUR DEVIS ONDULEURS - Complément de sélection des composants de niveaux inférieurs à prendre en compte pour le calcul du récapitulatif des coûts des devis multi-niveaux (table recap_couts)

Exemple

and rcp_matiere not matches "ZP*"

Exemples en bas de page (onduleur)

Remarques au niveau du devis onduleur

Dans le devis onduleur, on peut visualiser le récapitulatif des coûts sur plusieurs environnements : prévisionnel (DEV) et réel (DER).

La bascule d'un type d'environnement à un autre se fait par la touche F9 (bascule Prévisionnel / Réel)

L'accès aux différents types d'environnement est soumis à permission :

- Type d'environnement prévisionnel (DEV) : permission TOU DON_080_F8_DEV

- Type d'environnement réel (DER) : permission TOU DON_080_F8_DER

Remarques au niveau des commandes clients (création, visualisation)

Dans la saisie et la visualisation des commandes clients, on peut accéder au récapitulatif des coûts de la ligne de commande sur plusieurs environnements : prévisionnel (CEV/PRP) et réel (CER/PRR).

Lors de la réactualisation via l'offre fictive, on peut enregistrer les indicateurs de récapitulatif des coûts calculés sur la ligne de commande au niveau de l'historique du prix de revient (hist_pr).

Remarques

• Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients/Récapitulatif des coûts).

• L'accès à la visualisation du récapitulatif des coûts se fait via une touche de fonction sur la ligne de commande (Détail Coûts) :
F39 en saisie de commande, F51 en visualisation de commande

• Le récapitulatif des coûts est calculé lors de la création d'une ligne de commande pour les types CD2/CD1 et lors de la génération des OF pour les types FBI/FB2.

• Le récapitulatif des coûts peut être réactualisé via le recalcul d'une offre de vente fictive, faisant appel à la saisie des devis onduleurs.

• La bascule d'un type d'environnement à un autre se fait par la touche F9 (bascule Prévisionnel / Réel).

• L'accès aux différents types d'environnement est soumis à permission :

Pour les commandes de types CD2/CD1 :

Type d'environnement prévisionnel (CEV) : permission TOU CDE2_F39_CEV

Type d'environnement réel (CER) : permission TOU CDE2_F39_CER

Pour les commandes de types FBI/FB2 :

Type d'environnement prévisionnel (PRP) : permission TOU CDE2_F39_PRP

Type d'environnement réel (PRR) : permission TOU CDE2_F39_PRR

Réactualisation des indicateurs via l'offre fictive uniquement :

• Les indicateurs d'environnement CEV sont enregistrés dans le type M de l'historique de prix de revient (hist_pr)

• Les indicateurs d'environnement CER sont enregistrés dans le type N de l'historique de prix de revient (hist_pr)

Le TSC _RC permet au programme de réactualisation batch du récapitulatif des coûts de connaître les lignes de commandes ayant fait l'objet de modifications afin de les régénérer.

Il est créé et mis à jour automatiquement lors de la création/modification de la ligne de commande.

Remarques au niveau du calcul / édition de factures

Lors de l'édition de la facture, on peut enregistrer les indicateurs de récapitulatif des coûts calculés sur la ligne de commande au niveau de l'historique du prix de revient (hist_pr).

Remarques :

• Cette fonctionnalité est soumise à l'option payante CDE/13 (Commandes clients / Récapitulatif des coûts)

• Les valeurs des indicateurs sont recalculées au prorata de la quantité facturée (coefficient = quantité facturée / quantité commandée).

• Les indicateurs d'environnement CEV sont enregistrés dans le type X de l'historique de prix de revient (hist_pr)

• Les indicateurs d'environnement CER sont enregistrés dans le type Y de l'historique de prix de revient (hist_pr)

Exemple complet de paramétrage (environnement onduleur)

Paramètres de lancement

Programme | Type / Code | Module | Paramétrage
Saisie des devis onduleur | #SA DA1 | don | PARAM_INDICATEURS #CFRCP
Edition des offres de vente | #VE OFF | voluedit_devis_ondu | PARAM_INDICATEURS #CFRCP
Saisie des commandes CD2 | #SA CD2 | cde | PARAM_INDICATEURS #CFRCP PARAM_CALCUL_DEVIS #SADA1
Visualisation des commandes | #VI CD2 | v_cdem (spécifique) | AUTORISE_TOUCHE_F51 O PARAM_INDICATEURS #CFRCP PARAM_CALCUL_DEVIS #SADA1
Edition des factures | #ED FKC | voluedit_facn | PARAM_INDICATEURS #CFRCP
Batch de réactualisation du récapitulatif des coûts | #UT RCP | rcp_batch_don | PARAM_INDICATEURS #CFRCP PARAM_CALCUL_DEVIS #SADA1 A2[6] = O (Prise en compte du TSC _RC)

Notes du #CF RCP - Configuration des indicateurs du récapitulatif des coûts

# Variables

_VAR_INDIC_a SOMME_X_MAT_CMP

_VAR_INDIC_b SOMME_X_MAT_XXX

_VAR_INDIC_c SOMME_X_GAM_XXX

_VAR_INDIC_d SOMME_X_XXX_CDR

_VAR_INDIC_e SOMME_X_XXX_XXX

# Formules

_FOR_INDIC_01_04_ba-

_FOR_INDIC_02_04_cd+

_FOR_INDIC_03_04_ea-

_FOR_INDIC_04_04_eb-

_FOR_INDIC_05_04_eb-c-d-

# Indicateurs

_TIT_INDIC*Papier*SOMME_X_MAT_CMP* ### ### ##&.&&&&*

_TIT_INDIC*Aut MAT*FOR_01* ### ### ##&.&&&&*

_TIT_INDIC*Direct*SOMME_X_XXX_CDR* ### ### ##&.&&&&*

_TIT_INDIC*DPP*FOR_03* ### ### ##&.&&&&*

_TIT_INDIC*DPM*FOR_04* ### ### ##&.&&&&*

_TIT_INDIC*MC*FOR_05* ### ### ##&.&&&&*

_TIT_INDIC*CC*SOMME_X_GAM_XXX* ### ### ##&.&&&&*

Remarques

Les indicateurs ci-dessus seront enregistrés dans cet ordre dans la table des historiques de prix de revient (hist_pr), de hp_z1 à hp_z7.

L'indicateur CC est utilisé pour le tableau de bord (visualisation via la zone historisée hp_z7).

Exemple de paramétrage du tableau de bord - Paramètre de lancement de v_cdem

-Ohp

Gestion de plusieurs types d'enregistrements hist_pr sur la ligne de commande

A2[1] = N

Second écran de sélection

A2[2] = N

Choix de l'ordre de tri

A2[3] = N

Pas d'édition des lignes détail

A2[4] = O

Imprimerie

A2[49] = S

Type de visualisation Standard

A3[1,60]

TABLEAU DE BORD 1

Notes

#----------------------< Variables calculées / Formules >---

_VAR_a lc_qtecde

_VAR_b lc_prx_dev

_VAR_c M-hp_z2

_VAR_d M-hp_z7

_VAR_e surf_cde_202

_VAR_f poids_cde_202

_CALC_01 ab*

_CALC_02 cd+

_CALC_03 ab*1000*e/

_CALC_04 f1000/

#---------------------------< Colonnes de visualisation >---

V Région*libc_cl_orig*10**N*N*

V Agent*libl_ec_rep*20**N*N*

V Client*ec_cli*6**N*N*

V Nom*nom_ec_cli*30**N*N*

V MAD*CALC_01*12*# ### ##&.&&*O*N*

V Surface*surf_cde_202*7*### ##&*O*N*

V Tonne*CALC_04*7*### ##&*O*N*

V Matière*M-hp_z2*10*### ##&.&&*O*N*

V Conversion*M-hp_z7*10*### ##&.&&*O*N*

V Coût Direct*CALC_02*10*### ##&.&&*O*N*

V Delta P. Matière*M-hp_z5*10*### ##&.&&*O*N*

V Contribution*M-hp_z6*10*### ##&.&&*O*N*

V Coût / 1000 m2*CALC_03*12*# ### ##&.&&*O*N*

#----------------------------------< Colonnes de détail >---

D N°Commande : *ec_num*8**

D Réf Cde clt : *ec_ref*15**

D Date Commande : *ec_datc*10*dd/mm/yyyy*

#--------------------------------------< Ordres de tris >---

O201**N*N**

O422**N*N**

O013**N*N**

Remarques

Les zones historisées récupérées sont les indicateurs de type CEV (prix prévisionnels).

Pour obtenir les zones historisées de type CER (prix réels), il faut préfixer les colonnes hp_z* par N- (N-hp_z2, N-hp_z7, etc.).


#CF REM Recherche des remises

Voir aussi l'aide sur la saisie des remises.

Règle

Les plages de dates et les plages de quantités font systématiquement partie de la recherche de remise.

Zone alpha 1

Caractères 1 à 25 | Ordre de recherche des remises La recherche de remise sera effectuée pour tous les types de recherche paramétrés. Ce qui amène le système à trouver éventuellement plusieurs remises correspondant au cas traité. Code, Recherche effectuée 1 tiers, article 2 tiers, famille 3 tiers, famille, sous-famille 4 catégorie tiers, article 5 catégorie tiers, famille 6 catégorie tiers, famille, sous-famille 7 code remise, article 8 code remise, famille 9 code remise, famille, sous-famille A famille B tiers, sous-famille C famille, sous-famille D sous-famille E article F code remise, tiers, article G code remise, tiers, famille H code remise, tiers, famille, sous-famille
Caractère 26 | Valeur retenue M Maxi (valeur par défaut) m Mini T Cumul des remises D Dernier trouvé (dans l'ordre défini par les paramètres 1 à 25) P Premier trouvé (dans l'ordre défini par les paramètres 1 à 25) Y Moyenne [(maxi + mini) / 2]
Caractère 27 | Conservation détail calcul de la remise H Conservation [blanc] Non conservation
Caractère 28 | Recherche automatique (ouverture de la fenêtre de choix) O Recherche automatique activée (pas d'ouverture) N Pas de recherche automatique [valeur par défaut]
Caractère 29 | Prise en compte de la remise à taux égal à 0 O prise en compte du taux à zéro N pas de prise en compte du taux à zéro (valeur par défaut)
Caractère 30 | Type de calcul pour la remise globale sur les lignes F Regroupement par famille S Regroupement par famille, sous-famille
Caractère 31 | Pour les articles non soumis à remise globale (mp_param[41] = N), faut-il les prendre en compte pour le calcul de la quantité globale ? O On les prend en compte (valeur par défaut) N On ne les prend pas en compte
Caractère 32 | Pour les lignes saisies avec un prix NET, faut-il la prendre en compte pour le calcul de la quantité globale ? O On la prend en compte (valeur par défaut) N On ne les prend pas en compte

Valeur alpha 2

Zone identique à la zone alpha 1, mais utilisée uniquement pour les recherches de remises globales.

Valeur alpha 3

Zone définissant le mode de recherche de la remise en fonction des critères de recherche définis dans la zone alpha 1

Caractères 1 à 25

Pour chaque type de recherche paramétrée dans la zone alpha 1, il est possible de spécifier si les critères non choisis doivent avoir une valeur nulle ou une valeur quelconque.
Si le caractère 1 de la zone alpha 3 est à
O Les critères non pris en compte lors de la 1ère recherche doivent être nuls
N Les critères non pris en compte lors de la 1ère recherche peuvent avoir une valeur quelconque
(Valeur par défaut)

Valeur alpha 4

Zone parfaitement identique à la zone alpha 3 mais associée aux critères de recherche de la zone alpha 2 (remises globales)

Exemple

Caractères 1 à 3 | 17B
Caractère 26 | P
Caractère 27 | 1ère recherche effectuée sur le couple tiers - article 2ème recherche effectuée sur le couple code remise - article 3ème recherche effectuée sur le couple tiers - sous-famille La valeur retenue sera la 1ère valeur trouvée


#CF RMP Recherche des articles

Les programmes faisant appel à ce paramètre peuvent disposer de leur propre paramétrage d'accès à la visualisation.

Dans ce cas, le paramètre de lancement a priorité sur le paramétrage général (en alpha1[5, 12, 19, 26 et 33]).

Notes sur le paramètre de lancement des programmes faisant appel à #CF RMP

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

21,23 Type du paramètre de lancement de la visualisation v_mat (normalement #VI)

21,23 Code du paramètre de lancement de la visualisation v_mat

où X peut prendre les valeurs

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche spécifique papier

5 Recherche par fournisseur et libellé étranger

Q Recherche sur la qualité

T Recherche orientée Transformateurs

Valeur alpha 1

A1[1]

Ordre de tri dans le type de recherche par défaut

C Tri croissant par code article

c Tri décroissant par code article

D Tri croissant par désignation (par défaut)

d Tri décroissant par désignation

S Tri croissant par référence article du client

s Tri décroissant par référence article du client

N Tri croissant par code normalisé

n Tri décroissant par code normalisé

A1[2]

Ordre de tri dans le type de recherche sur les données techniques

C Tri croissant par code article

c Tri décroissant par code article

D Tri croissant par désignation

d Tri décroissant par désignation

N Tri croissant par code normalisé

n Tri décroissant par code normalisé

A1[3]

Ordre de tri dans le type de recherche spécifique papier

C Tri croissant par code article

c Tri décroissant par code article

D Tri croissant par désignation

d Tri décroissant par désignation

N Tri croissant par code normalisé

n Tri décroissant par code normalisé

A1[4]

Ordre de tri dans le type de recherche spécifique papier

D Tri croissant par description

d Tri décroissant par description

C Tri croissant par code article

c Tri décroissant par code article

A1[5]

Affichage de la recherche par F7 de type 1 par la visualisation des articles

Voir la note en haut de page.

A1[6,8]

Type de paramètre de la visualisation des articles pour la recherche de type 1Remarque : si le critère de recherche porte sur autre chose que mat (libellé étranger par exemple) l'affichage se fera en mode normal

A1[9,11]

Code de paramètre de la visualisation des articles pour la recherche de type 1

A1[12]

Affichage de la recherche par F7 de type 2 par la visualisation des articles

Voir la note en haut de page.

A1[13,18]

Type et code de paramètre de la visualisation des articles pour la recherche de type 2

A1[19]

Affichage de la recherche par F7 de type 3 par la visualisation des articles

Voir la note en haut de page.

A1[20,25]

Type et code de paramètre de la visualisation des articles pour la recherche de type 3

A1[26]

Affichage de la recherche par F7 de type Q par la visualisation des articles

Voir la note en haut de page.

Remarque : si le critère de recherche porte sur autre chose que mat (profile, code LNE par exemple), l'affichage se fera en mode normal.

A1[27,32]

Type et code de paramètre de la visualisation des articles pour la recherche de type Q

A1[33]

Affichage de la recherche par F7 de type T par la visualisation des articles

Voir la note en haut de page.

Remarque : si le critère de recherche porte sur autre chose que mat (libellé étranger par exemple), l'affichage se fera en mode normal.

A1[34,39]

Type et code de paramètre de la visualisation des articles pour la recherche de type T

A1[40]

Méthode de recherche de produit par site de production - Tableau de bord du multisite

N Aucune vérification par rapport au site de production (fonctionnement actuel, par défaut)

O Les articles retournés seront ceux dont le site de production de l'article est celui renseigné sur l'utilisateur

T Les articles retournés seront ceux dont le site de production de l'article est celui renseigné sur l'utilisateur ou ceux dont le site de production n'est pas renseigné

N.B. : Si aucun site de production n'est renseigné sur l'utilisateur, la méthode de recherche bascule automatiquement sur N (recherche par le fonctionnement actuel).

A1[41]

Il existe 2 compléments de sélection à prendre en compte dans le cadre de la recherche d'articles par visualisation :

- Le complément de sélection général de la visualisation (notes commençant par S)

- Le complément de sélection renseigné sur le paramètre de lancement du programme.
(notes commençant par SMAT)

En outre, il faut bien faire la distinction entre le paramétrage du programme appelant et celui du programme appelé :

Exemple

Le programme de saisie des articles (programme appelant) peut avoir des notes SMAT.

Le programme de visu des articles (programme appelé) peut aussi avoir des notes SMAT ainsi que des notes S.

Le caractère A1[41] permet d'indiquer, parmi ces 3 notes, laquelle doit être prise en compte :

1) la note SMAT du programme appelant

2) la note SMAT du programme appelé

3) la note S du programme appelé

Il peut prendre les valeurs suivantes (O/N, N par défaut)

O La note S est prise en compte.
La note SMAT du programme appelant n'est pas prise en compte, même si aucun complément n'est renseigné sur le programme appelé.

N La note S n'est pas prise en compte.
La note SMAT du programme appelant est prise en compte si elle n'est pas paramétrée sur le programme appelé.

Notes

INVERSE_FORMAT_MAT

Inverser le format (laize/largeur x coupe/longueur au lieu de longueur x largeur dans l'écran de sélection de la recherche spécifique papiers

19 Type de recherche d'article

3 Recherche spécifique papier

21 Inverser le format dans l'écran de sélection et dans celui du résultat de recherche

O Laize/largeur x Coupe/Longueur

N Longueur x Largeur (par défaut)

Ce paramétrage est recherché en priorité sur le paramètre de lancement du programme.

LS

Libellé supplémentaire (libellé d'un composant / d'une composition)

3 Première lettre du code produit où l'on veut rechercher un libellé supplémentaire

13 à 32 Titre du libellé supplémentaire exemple Compo Technique

33 à 60 Complément de requête pour aller chercher un composant

S

Critère de sélection complémentaire utilisable dans tous les types de recherche
Caractère 2 : indiquez le numéro du type de recherche concerné, (voir mat alpha3[5])

Attention : NE PAS mettre de and en début de ligne !

exemple S2mp_code matches A*

O

Ordre de tri utilisable seulement dans le type de recherche T

2 Numéro du type de recherche concerne uniquement T

exemple OT order by mp_lon, mp_code

Tris possibles :

mat.mp_afnor : code FEFCO

mat.mp_qualite_matiere : qualité carton

mat.mp_lon : longueur

mat.mp_lar : largeur

mat.mp_hau : hauteur

mat.mp_cli : client

mat.mp_code : code produit

mat.mp_des : description produit

mat.mp_fam : famille

mat.mp_sfm : sous famille

mat.mp_devis : devis

mat.mp_sdevis : sous devis

lib_etr.le_client : référence client

lib_etr.le_libpar1 : libellé référence client

E

Paramétrage de l'édition du résultat de la sélection - Exemple E2ACB

2 Numéro du type de recherche concernée

3 à 60 Colonnes à éditer. Le paramétrage est fonction du type de recherche actif :

Type de recherche 1 (par défaut):

A Code article

B Référence client de l'article

C Type d'article (P,M,...)

D Désignation

Type de recherche 2 (données techniques):

A Code article

B Type d'article (P,M,...)

C Désignation

Type de recherche 3 (papiers) :

A Code article

B Désignation

C Famille

D Sous-famille

E Client principal

F Longueur

G Largeur

H Poids

I Suivi en stock (O/N)

J Stock disponible

K Prix de revient

L Fournisseur principal

M Nom du client principal

N Code couleur

O Nom du fournisseur principal

P Stock disponible immédiat

Q Qualité matière

Type de recherche Q (qualité) :

A Code qualité

B Désignation

C Papier 1

D Papier 2

E Papier 3

F Papier 4

G Papier 5

H Papier 6

I Papier 7

J Papier 8

K Papier 9

L Profil

M Code LNE

N Catégorie

O Epaisseur

P Grammage

Q Négoce

R Trait. Surf. Auto.

S Estampillable

T Groupabilité

Type de recherche T (transformateurs) :

A code article

B Désignation

C Référence client

D Libellé référence client

E FEFCO

F Longueur

G Largeur

H Hauteur

I Qualité carton

J Libellé qualité

K Devis - sous / devis

L Client principal

M Nom du client principal


#CF SC1 Statistiques de facturation

#CF SC1 Statistiques de facturation : scénario 1 : Progression
#CF SC2 Statistiques de facturation : scénario 2 : Palmarès
#CF SC3 Statistiques de facturation : scénario 3 : Détail mensuel
#CF SC4

Les valeurs par défaut sont définies dans stat_cli.

Valeur alpha 1

Titre 1 (sans rupture)

Valeur alpha 2

Configuration 1 (sans rupture)

Voir ci-dessous la table des colonnes disponibles

Valeur alpha 3

Titre 2 (avec rupture)

Valeur alpha 4

Configuration 2 (avec rupture)

Voir ci-dessous la table des colonnes disponibles

Table des colonnes disponibles dans les valeurs alpha 2 et 4 :

Les colonnes marquées en bleu ne sont accessibles que si so_options[27] = O.

A | Nom du client
B | Code
C | CA année N
D | CA commercial (ou commandé si option –Ocd) de l'année N
E | CA année N-1
F | CA commercial (ou commandé si option –Ocd) de l'année N-1
G | CA année N-2
H | CA commercial (ou commandé si option –Ocd) de l'année N-2
I | Progression CA de N-1 à N
J | Progression du CA commercial (ou commandé si option –Ocd) de N-1 à N
K | Progression CA de N-2 à N
L | Progression du CA commercial (ou commandé si option –Ocd) de N-2 à N
M | Progression CA de N-2 à N-1
N | Progression du CA commercial (ou commandé si option –Ocd) de N-2 à N-1
O | % CA par rapport au cumul CA
P | % CA commercial (ou commandé si option –Ocd) par rapport au cumul du CA commercial
Q | CA cumulé
R | CA commercial (ou commandé si option –Ocd) cumulé
S | % CA cumulé par rapport au cumul CA
T | % CA commercial (ou commandé si option –Ocd) cumulé par rapport au cumul du CA commercial
U | CA commercial (ou commandé si option –Ocd) mensuel + cumul
V | % Poids net commandé cumulé par rapport au cumul poids net commandé
W | % Surface nette commandée cumulée par rapport au cumul surface nette commandée
X | Poids net commandé mensuel (12 mois) + cumul
Y | Surface nette commandée mensuelle (12 mois) + cumul
Z | n'existe pas
a | Libellé long de la rupture
b | Libellé court de la rupture
c | Code de la rupture
d | Rang dans le classement
e | CA en commande
f | CA prévisionnel
g | Prévision sur le mois
h | CA potentiel
i | Progression CA prévisionnel / CA de l'année
j | Nombre de commandes
k | Poids net commandé année N
l | Surface nette commandée année N
m | Poids net commandé année N-1
n | Surface nette commandée année N-1
o | Poids net commandé année N-2
p | Surface nette commandée année N-2
q | Progression poids net commandé de N-1 à N
r | Progression surface nette commandée de N-1 à N
s | Progression poids net commandé de N-2 à N
t | Progression surface nette commandée de N-2 à N
u | Progression poids net commandé de N-2 à N-1
v | Progression surface nette commandée de N-2 à N-1
w | % Poids net commandé par rapport au cumul poids net commandé
x | % Surface nette commandée par rapport au cumul surface nette commandée
y | Poids net en commande cumulé
z | Surface nette en commande cumulée
1 | Poids net prévisionnel
2 | Surface nette prévisionnelle
3 | Progression poids net prévisionnel / poids net commandé de l'année
4 | Progression surface nette prévisionnelle / surface nette commandée de l'année
5 | Poids net facturé année N
6 | Surface nette facturée année N
7 | Poids net facturé année N-1
8 | Surface nette facturée année N-1
9 | Poids net facturé année N-2
0 | Surface nette facturée année N-2
( | Progression poids net facturé de N-1 à N
) | Progression surface nette facturée de N-1 à N
[ | Progression poids net facturé de N-2 à N
] | Progression surface nette facturée de N-2 à N
< | Progression poids net facturé de N-2 à N-1
> | Progression surface nette facturée de N-2 à N-1
+ | % poids net facturé par rapport au cumul poids net facturé
- | % Surface nette facturée par rapport au cumul surface nette facturée
* | Poids net facturé cumulé
/ | Surface nette facturée cumulée
. | % Poids net facturé cumulé par rapport au cumul poids net facturé
, | % Surface nette facturée cumulée par rapport au cumul surface nette facturée
; | Poids net facturé mensuel (12 mois) + cumul
: | Surface nette facturée mensuelle (12 mois) + cumul
? | Nombre d'affaires (pour édition)
@ | Colonne cl_domb2
é | Ecart CA année N-1 par rapport au CA année N
è | Ecart CA commercial (ou commandé si option -Ocd) année N-1 par rapport au CA commercial (ou commandé si option Ocd) année N
ç | Ecart CA année N-2 par rapport au CA année N
à | Ecart CA commercial (ou commandé si option -Ocd) année N-2 par rapport au CA commercial (ou commandé si option Ocd) année N
ù | Ecart CA année N-2 par rapport au CA année N-1
& | Ecart CA commercial (ou commandé si option -Ocd) année N-2 par rapport au CA commercial (ou commandé si option Ocd) année N-1
{ | Ecart CA par rapport au cumul CA
} | Ecart CA commercial (ou commandé si option -Ocd) par rapport au cumul CA commercial (ou commandé si option Ocd)
% | Ecart CA cumulé par rapport au cumul CA
! | Ecart CA commercial (ou commandé si option -Ocd) cumulé par rapport au cumul CA commercial (ou commandé si option Ocd)
= | Ecart CA prévisionnel par rapport au CA
$ | CA de la période à N-1
# | CA commercial de la période à N-1 (ou commandé si Ocd)
£ | CA de la période à N-2
µ | CA commercial de la période à N-2 (ou commandé si Ocd)


#CF SCC Consommations carton

Valeur alpha 1

A1[1,3] | Type de mouvement de stock pour les sorties plaques
A1[4,6] | Type de mouvement de stock pour les entrées chutes
A1[7,9] | Type de mouvement de stock pour les sorties déchets

Valeur alpha 2

A2[1] | Affectation des sorties de plaques à l'OF (O/N, O par défaut)
A2[2] | Affectation des entrées de chutes à l'OF (O/N, O par défaut)
A2[3] | Affectation des sorties de déchets à l'OF (O/N, O par défaut)
A2[4] | Valeur contenue dans s0_libre des mouvements de déchet 1 Surface totale de déchet en m2 2 Poids total de déchet en kg 3 % de perte par rapport au format initial

Valeur alpha 3

A3[1,5] | Position de la longueur dans le code plaque par rapport au début ou à la fin du code 0104O Les 4 derniers caractères en partant de la fin du code 0104N Du caractère 1 au caractère 4 en partant du début
A3[6,10] | Position de la largeur dans le code plaque par rapport au début ou à la fin du code 0508O Les 4 caractères suivants la longueur en partant de la fin du code 0508N Du caractère 5 au caractère 8 en partant du début

Valeur alpha 4

A4[1,3] | Lieu (1) de stockage des déchets par défaut
A4[4,9] | Lieu (2) de stockage des déchets par défaut
A4[10,15] | Lieu (3) de stockage des déchets par défaut
A4[16,30] | Lot de stockage des déchets par défaut
A4[31,33] | Famille déchet. ### pour conserver la famille de la plaque
A4[34,36] | Sous-famille déchet. ### pour conserver la sous-famille de la plaque

Notes

QUALITE_CARTON

21,60 Nom de la zone sur la fiche article contenant le code qualité de la plaque

Les possibilités sont les suivantes :

mp_at1

mp_at2

mp_qualite_matiere

TSC_MA1 (ic_char30)

SQL_ARTICLE

21,60 Complément de sélection pour le F7 sur le code article

SSC_SAISIE_MULTIPLE

21 Permettre la saisie de plusieurs produits

O La saisie de plusieurs produits est toujours autorisée.

N La saisie de plusieurs produits est interdite (par défaut).

P La saisie de plusieurs produits n'est autorisée que si l'appel à la saisie simplifiée se fait sans code produit (par exemple : depuis la saisie des bons de livraison, l'appel se fait avec le code client uniquement).

IMPORTANT : Lorsque l'appel à la saisie simplifiée se fait depuis une sélection multiple de produits (Control-K dans une visualisation par exemple), la saisie est automatiquement multi-produits, mais est limitée si la valeur du paramétrage ci-dessus est différente de O (l'insertion d'une nouvelle ligne est interdite).

TRIPLET_OUVERTURE

Triplet devant déclencher l'ouverture de la fenêtre

Exemple CAIMITROU


#CF SEN VoluSentinel

Valeurs numériques

1

Nombre de secondes d'attente après le lancement automatique d'application et avant une deuxième tentative de connexion

2

Time out, doit être compris entre 10 et 300. Valeur par défaut : 10

Le délai d'expiration de VoluSentinel (menus, VoluEdit…) est fixé par défaut à 10 secondes.

Dans le cas où VoluEdit sous-traite un travail auprès d'un autre programme (par exemple une impression pdf), ce délai par défaut peut être dépassé.

L'objectif est de pouvoir saisir un délai plus important, connaissant la durée réclamée par la/ou les tâche(s) à accomplir.

Valeur alpha 3

Caractère 1 | Activation de la sirène dans qte_prod (O/N, N par défaut)
Caractère 2 | Activation d'un boîtier leds dans qte_prod (O/N, N par défaut)


#CF SFA Assurance crédit

Cette nouvelle fonctionnalité permet d'intégrer les lignes de commande FBI à la place des lignes de commande CD2 dans le calcul du risque clients.

La ligne de commande FBI est intégrée dans le risque clients si

- des lignes de commande CD2 sont rattachées à la ligne de commande FBI

- les articles des lignes de commande CD2 et FBI sont identiques

- les articles des lignes de commande CD2 sont des articles non appairés ou appairés montés

Si les conditions sont remplies, la ligne de commande FBI est intégrée avec la quantité lancée si la fabrication n'est pas soldée, sinon avec la quantité fabriquée valorisée au prix de la ligne de commande FBI.

Si les conditions ne sont pas remplies, la ligne de commande FBI n'est pas intégrée.

La ligne de commande CD2 n'est pas intégrée dans le risque clients si :

- l'article de la ligne de commande CD2 est un article non appairé ou appairé monté

- la commande de rattachement est une FBI

- les articles des lignes de commande CD2 et FBI sont identiques

Si les conditions sont remplies, la ligne de commande CD2 n'est pas intégrée.

Si les conditions ne sont pas remplies, la ligne de commande CD2 est intégrée avec la quantité commandée valorisée au prix de la ligne de commande CD2.

En modification de ligne de commande, l'enregistrement CDE de la ligne de commande CD2 ou FBI de la table risque_detail est mis à jour sans tenir compte de la quantité facturée.

En déclaration de production, l'enregistrement CDE de la ligne de commande FBI de la table risque_detail est mis à jour sans tenir compte de la quantité facturée.

En facturation, l'enregistrement CDE de la ligne de commande CD2 ou FBI de la table risque_detail est mis à jour en déduisant le montant de la ligne de facture.

Si le prix de la ligne de commande FBI est différent de celui de la ligne de commande CD2, le montant calculé sera différent de celui qui sera recalculé par le programme risque_detail.

#CF SFA Assurance crédit

Valeur numérique 1 Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Mise à jour de la qualité Tiers

Valeur numérique 1

Nombre de jours utilisés en alpha2[12] et alpha2[34]

Valeur alpha 2

#CF SFA A2[1]

Prise en compte des avoirs dans l'encours du carnet de commande (O/N, N par défaut)

#CF SFA A2[2]

Prise en compte de la remise dans l'encours du carnet de commande (O/N, N par défaut)

#CF SFA A2[3]

Prise en compte de l'escompte dans l'encours du carnet de commande (O/N, N par défaut)

#CF SFA A2[4]

Prise en compte des avoirs dans le calcul du risque (O/N, N par défaut)

#CF SFA A2[5]

Numérotation automatique des autorisations dans la fiche client (O/N)

#CF SFA A2[6]

Sélection préalable à la saisie des autorisations dans la fiche client (O/N)

#CF SFA A2[7]

Prise en compte de l'encours du carnet de commande VoluGold (O/N, N par défaut)

#CF SFA A2[8]

Prise en compte du portefeuille d'effets de VoluCompta (O/N, N par défaut).

Voir alpha2[14]

#CF SFA A2[9,11]

Délai pour le risque de retour des effets impayés.

Exemple : 015 : pendant une période de 15 jours, on considère que l'effet risque d'être impayé.

Au delà de ce délai, l'effet est considéré comme payé.

A remplir si #CF SFA A4[8 = O

#CF SFA A2[12]

Traitement des factures présentes dans ATLAS (O/N) O par défaut

O On ne traite que les factures non transférées en comptabilité

N On traite toutes les factures non échues. On traite aussi les factures échues depuis moins de N jours (voir valeur numérique 1).

En l'absence de VoluCompta ou d'une compta compatible int_cpt, mettre N.

#CF SFA A2[13]

Traitement du risque groupe (O/N, N par défaut)

N Calcul du risque client uniquement

O Calcul du risque client et du risque groupe

#CF SFA A2[14]

Nouveau module effets clients (VoluCompta) (O/N, N par défaut).

Voir alpha2[8]

#CF SFA A2[15]

Type de risque (C/G) Obligatoire si BATCH. Pas de valeur par défaut

C Risque client

G Risque groupe

#CF SFA A2[16]

Type d'édition (1/2/3) Obligatoire si BATCH. Pas de valeur par défaut

1 Semainier

2 Semaine courante

3 Clients en dépassement de crédit

#CF SFA A2[17]

Tables histo et echean d'atlas alimentées par le module int_cpt (O/N, N par défaut)

En présence de VoluCompta, mettre N.

#CF SFA A2[18]

Affichage du contenu des écrans trié par date d'échéance (O/N, N par défaut)

#CF SFA A2[19]

Recherche du pourcentage de tolérance sur le client (O/N, N par défaut)

#CF SFA A2[20]

Recherche du pourcentage de tolérance sur le client société #SOC (O/N, N par défaut)

#CF SFA A2[21,22]

Racine info_c tolérance saisie sur le client ou sur le client société #SOC

Obligatoire si #CF SFA A4[19 ou 20 à O

S'il s'agit de commande de plaques, le programme cherche tout d'abord la présence de TSC avec la racine [#CF SFA A4[21]P. Si non trouvé, il garde la racine entière.

#CF SFA A2[23]

Unité utilisée pour la tolérance

Q Quantité (par défaut)

P Poids

S Surface

#CF SFA A2[24]

Activation de la mise à jour automatique du troisième caractère du code de la qualité tiers en fonction du risque (O/N)

Voir plus bas les notes commençant QT.

#CF SFA A2[25,27]

Paramétrage des colonnes Montant et Dépassement

PTS ou [rien] Autorisations Permanente + Temporaire + Supplémentaire

PT- Autorisation Permanente + Temporaire

--S Autorisation Supplémentaire

#CF SFA A2[28]

Alimentation de la table risque_detail en commande à partir du flash (O/N, N par défaut)

#CF SFA A2[29]

Alimentation de la table risque_detail en facturation à partir du flash (O/N, N par défaut)

#CF SFA A2[30]

Mode de fonctionnement de la touche F18

O Affichage du risque à partir de la table risque_detail (rapide)

N Calcul et affichage du risque sans utiliser la table risque_detail(lent) (valeur par défaut)

#CF SFA A2[31]

Recalcul des factures non transférées en édition (O/N, N par défaut)

#CF SFA A2[32]

Mode de calcul de la date d'échéance prévisionnelle du carnet de commandes

N (valeur par défaut) La date d'échéance prévisionnelle est la date d' échéance réelle de la commande.

Le montant de la commande est mis de la semaine courante à la semaine de la date d'échéance de la commande

O La date d'échéance prévisionnelle est la date du jour.

Le montant de la commande est mis sur la semaine courante uniquement quelque soit la date d'échéance de la commande

I La date d'échéance prévisionnelle est la date d'échéance la plus grande des écritures de comptabilité réelles et différées et des factures non transférées en comptabilité.

Le montant de la commande est mis de la semaine courante à la semaine de la date d'échéance la plus grande.

#CF SFA A2[33]

Nouveau module effets clients avec validation des effets de VoluCompta (O/N, O par défaut)

N Certification sans validation des effets

O Certification avec validation des effets

Voir alpha2[8] et alpha2[14]

#CF SFA A2[34]

Traitement des factures transférées dont la date d'échéance (à + N jours) n'est pas atteinte (O/N, N par défaut))

N Les factures transférées ne sont pas prises en compte.

O Les factures transférées dont la date d'échéance (à + N jours) n'est pas atteinte sont prises en compte.

Remarques :

alpha2[12] est mis à O.

Les factures sont mises dans la colonne Historique Comptabilité

(Tableau "ETAT DU COMPTE CLIENT" ==> Touche F6)

#CF SFA A2[35]

Mode de calcul de la quantité du carnet de commandes (1/2/3, 1 par défaut)

Soit les zones suivantes :

Q Quantité carnet de commandes

QC Quantité commandée

QL Quantité livrée

QF Quantité facturée

TL Tolérance de livraison

1 La tolérance de livraison n'est pas utilisée pour déterminer la quantité du carnet de commandes.

Ligne de commande non soldée Q = QC - QF

Ligne de commande soldée et livrable Q = QL - QF

Ligne de commande soldée et non livrable Q = QC - QF

2 Si la ligne de commande est non soldée ou soldée et livrable, la tolérance de livraison est utilisée pour déterminer la quantité du carnet de commandes.

Ligne de commande non soldée Q = QC + QC * TL – QF

Ligne de commande soldée et livrable Si QC + QC * TL <= QL à Q = QC + QC * TL – QF

Si QC + QC * TL > QL à Q = QL – QF

Ligne de commande soldée et non livrable Q = QC – QF

3 Si la ligne de commande est non soldée ou soldée et livrable, la tolérance de livraison est utilisée pour déterminer la quantité du carnet de commandes.

Si la ligne de commande est soldée et livrable et que tous les BL de celle-ci sont facturés,

la quantité est de 0.

Sinon, elle est calculée comme le mode de calcul 2.

Ligne de commande non soldée Q = QC + QC * TL – QF

Ligne de commande soldée et livrable :

Si plus de BL à facturer à Q = 0

Si BL à facturer et si QC + QC * TL <= QL à Q = QC + QC * TL – QF

Si BL à facturer et si QC + QC * TL > QL à Q = QL – QF

Ligne de commande soldée et non livrable Q = QC – QF

#CF SFA A2[36]

Prise en compte dans le risque client des premières lignes des commandes FB1

O Les lignes sont intégrées dans le calcul du risque client

N Les lignes sont ignorées par le calcul du risque client [Valeur par défaut]

#CF SFA A2[37]

Niveau de détail d'affichage du carnet de commande

E Affichage d'1 ligne par commande

L Affichage d'1 ligne par ligne de commande [Valeur par défaut]

#CF SFA A2[38]

Application de la tolérance de livraison dans le calcul du carnet de commande (O/N, O par défaut)

#CF SFA A2[39]

Calcul de l'encours de la ligne de commande si le dossier de fabrication est clôturé (O/N, O par défaut)

A2[36] doit être à O.

#CF SFA A2[40]

Calcul du risque en s'appuyant sur les données de la table risque_detail alimentée par int_cpt (O/N, N par défaut)

#CF SFA A2[41]

Intégration des FBI dans le calcul du risque clients (O/N, N par défaut)

Cliquez ici pour afficher / masquer des explications supplémentaires.

#CF SFA A2[42]

Test de la zone lc_afacturer pour la prise en compte des commandes dans le risque client

ATTENTION : Valeur par défaut = O.

Voir l'option Oaf du dans facn, qui spécifie si on teste la zone lc_afacturer pour le calcul des factures.

#CF SFA A2[43]

Méthode de calcul de la quantité du carnet de commandes des lignes de commande livrables et soldées (1/2, 1 par défaut)

1 Q = QL - QF

2 Q = QS si QS != 0 sinon QL - QF

avec :

Q = Quantité du carnet de commandes

QL = Quantité livrée

QF = Quantité facturée

QS = Quantité en stock du lot de la ligne de commande

La prise en compte des FBI ne doit pas être activée (A2[41] = N ou [espace]).

Voir la note _SUP_REQ_QTE_EN_STK

#CF SFA A2[44]

Edition du détail du carnet de commandes (N/O, N par défaut)

#CF SFA A2[45]

Gestion des FBI de réapprovisionnement et des CD2 asynchrones dans le risque clients (O/N, N par défaut)

#CF SFA A2[46]

Prise en compte de la tolérance de livraison des FBI de réapprovisionnement (O/N, N par défaut)

#CF SFA A2[47,59]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

#CF SFA A2[60]

Utilisation de l'ancien module de calcul de l'assurance crédit (O/N, N par défaut)

Vu avec GR le 25/09/2002 : doit toujours être à N.

Valeur alpha 3

#CF SFA A3[1,40]

Chemin de la base de données comptable. Uniquement pour VoluCompta.

Valeur alpha 4

#CF SFA A4[1]

Prise en compte du calcul du port dans le carnet de commande (O/N, N par défaut)

#CF SFA A4[2]

Calcul du risque client sur les montants en HT (O/N, N par défaut)

#CF SFA A4[3]

Code client utilisé pour le calcul du risque client

F Le code client est le code comptable de l'adresse de facturation, sinon le code comptable du client, sinon le code du client lui-même.

N Le code client utilisé est celui du client lui-même (par défaut)

Ce code client est également utilisé pour le blocage de commande sur le contrôle du risque client (type de blocage 003)

Ce paramètre est valable également pour tout autre programme faisant appel à la fonction de calcul du risque client, et l'adresse de facturation de la ligne de commande est prise en compte si elle est disponible et renseignée.

Exemple

Sur la fiche client (cli), le calcul du risque se fera en priorité :

- Sur le code comptable de l'adresse de facturation par défaut du client
(zone cli2.c2_cpt sur la fiche d'adresse secondaire du cli.cl_adrf)

- Sur le code comptable du client (zone cli.cl_cpt de la fiche client)

- Sur le code client (zone cli.cl_code de la fiche client, fonctionnement standard)

Sur la saisie des lignes de commande (cde), le calcul du risque client se fera en priorité :

- Sur le code comptable de l'adresse de facturation de la ligne de commande
(zone cli2.c2_cpt de l'adresse secondaire cde1.ec_cli-cde2.lc_adf)

- Sur le code comptable de l'adresse de facturation par défaut du client de l'entête de commande
(zone cli2.c2_cpt sur la fiche d'adresse secondaire du cli.cl_adrf du client cde1.ec_cli)

- Sur le code comptable du client (zone cli.cl_cpt du client de l'entête de commande cde1.ec_cli)

- Sur le code client de l'entête de commande (cde1.ec_cli, fonctionnement standard)

Code origine du client

Code cl_orig

Libellé court libc_cl_orig

Libellé long libl_cl_orig

Code représentant du client

Code cl_repr

Libellé court libc_cl_repr

Libellé long libl_cl_repr

Code fabricant du client

Code cl_suiv

Libellé court libc_cl_suiv

Libellé long libl_cl_suiv

Code qualité du client

Code cl_qualite

Libellé court libc_cl_qualite

Libellé long libl_cl_qualite

Code échéance du client

Code cl_ech

Libellé court libc_cl_ech

Libellé long libl_cl_ech

Mode règlement du client

Code cl_mrg

Libellé court libc_cl_mrg

Libellé long libl_cl_mrg

Code SIREN du client

code_siren (cl_siret[5,13])

Date de la dernière commande

Code date_enr

Adresse principale du client

Nom

Code nom _cli

Adresse 1

Code adresse1_cli

Adresse 2

Code adresse2_cli

Adresse 3

Code adresse3_cli

Code postal

Code code_postal_cli

Ville

Code ville_cli

Pays

Code pays_cli

Notes

CR | 3 à 60 Complément de requête facultatif sur la fiche client Utilisé dans la fonction de calcul du risque de tous les clients. Exemples CRand cl_code matches "A*" CRand cl_cpf = "C"
LPE | Colonnes paramétrables de l'édition du risque client - Facultatif Paramétrage de la ligne sous la forme Titre zone*Nom zone*Longueur zone*Using zone* Cliquez ici pour afficher / masquer la liste des noms des zones disponibles. Exemples LPECode Origine*cl_orig*12** LPECode Agent*cl_repr*10** LPECode SA*cl_suiv*7** LPECode Qualité*cl_qualite*12**
MTT_AUTORISATION_DEF | 21,35 Montant d'autorisation par défaut Exemple : 100000 Voir (ci-dessous) la règle de gestion en fonction du montant de l'encours.
OT | Tri, rupture et totalisation (facultatif) 3 à 4 Numéro de la zone 01 Groupe 02 Client 03 Vendeur ou représentant 04 Suivi d'affaire 5 à 6 Numéro de tri 01 à 04 09 Pas de tri 7 Rupture si tri (O/N, N par défaut) 8 Totalisation si tri et rupture (O/N, N par défaut) Exemples OT0101OO Tri, rupture et totalisation par groupe OT0202OO Tri, rupture et totalisation par client OT0309NN Pas de tri, de rupture et de totalisation par vendeur OT0409NN Pas de tri, de rupture et de totalisation par suivi d'affaire
QT | Paramétrage des données concernant la mise à jour de la qualité tiers en fonction du résultat du calcul risque alpha2[24] doit être à O (Oui). 3 Code OK (par exemple : O) 4 Code WARNING (par exemple : W) 5 Code BLOQUANT (par exemple : B) 6 10 % d'écart accepté par rapport au montant autorisation Exemple QTOWB50 Ce qui pour un client X, ayant par défaut un code qualité BC, donnerait : S'il n'a aucun encours, le code qualité BCO Si son encours est inférieur à 50% du montant de l'autorisation, le code qualité BCW Si son encours dépasse les 50% du montant de l'autorisation, le code qualité BCB Les codes qualités tiers, type QT, BC, BCO, BCW et BCB doivent exister.
_SUP_REQ_QTE_EN_STK | 21,60 Complément de sélection du calcul de la quantité en stock du lot de la ligne de commande. Obligatoire Utilisé dans la fonction de calcul du stock lot/lieu/lot-lieu. Voir A2[43]
_SUP_REQ_QTE_STK_FBI | Complément de sélection du calcul de la quantité en stock du lot de la ligne de commande des FBI de réapprovisionnement - Facultatif
TD | Titre de l'état du détail du carnet de commandes Facultatif - Par défaut : DETAIL DU CARNET DE COMMANDES Exemple TDCarnet de commandes
TE | 3 à 60 Titre de l'état Exemple TEDEPASSEMENT DE CREDIT

Règle de gestion en fonction du montant de l'encours

Calcul du risque : l'option doit être paramétrée (#CF SFA A[24])

Voir aussi la note MTT_AUTORISATION_DEF.

1 - Le client n'a pas de code qualité tiers renseigné. Pas de mise à jour

2 - Le client a un code qualité tiers mais n'a aucun montant d'autorisation saisi dans la fenêtre adéquate.

Si le montant de l'encours est <= 0, mise à jour de la qualité tiers avec le code OK (voir les notes QT sur #CFSFA)

Sinon, mise à jour avec qualité Bloquant.

3 - Le client a un code qualité tiers mais le montant global autorisé est à zéro.

Si le montant de l'encours est <= 0, mise à jour de la qualité tiers avec le code OK (voir les notes QT sur #CFSFA)

Sinon, mise à jour avec qualité Bloquant.

4 - Le client a un code qualité tiers, a eu des montant d'autorisation à un instant T, mais qui ne sont plus valides à la date du traitement.

Si le montant de l'encours est <= 0, mise à jour de la qualité tiers, avec le code OK (voir les notes QT sur #CFSFA)

Sinon, mise à jour avec qualité Bloquant.

5 - le client à un code qualité et des montants d'autorisation saisi

Si le montant encours est <= 0, mise à jour qualité tiers, avec le code OK (voir les notes QT sur #CFSFA)

Sinon , si ce montant est < au montant du risque (minoré d'un pourcentage) (voir les notes QT sur #CFSFA), mise à jour de la qualité tiers avec le code Warning; sinon, c'est bloquant.

Dans la revue de contrat, tous ces cas (si aucun montant d'autorisation n'est saisi) provoqueront un code blocage financier.

Cette mise à jour ne se fait que si le type de risque est C (Client), il ne s'applique pas pour le type de risque G (Groupe).

1) Dans le calcul du risque (risque_detail), ce type (C ou G) est pris sur le paramètre #CF SFA A2[15].

2 Pour le calcul du risque à partir de la fiche client :

S'il n'y a pas de code risque groupe (cf onglet Données diverses), le type de risque est C, et l'algorithme de la mise à jour s'applique.

S'il y a un code risque groupe, alors une question est posée via des boutons : Client - Groupe - Quitte

L'algorithme de mise à jour ne s'applique que pour le type client.


#CF SIT Sites

Tableau de bord du multisite

Valeur alpha 1

#CF SIT A1[1]

Autorise la gestion par site de production (O/N, N par défaut)

#CF SIT A1[2]

Mode d'attribution des lieux de rangement par défaut du site de production, dans le cas où la table mat_site n'est pas alimentée par F25 sur la fiche article (O/N, N par défaut)

O Si pas de lieu de rangement pour le site de production de l'article, ce sont ceux du site de production qui sont pris par défaut.

N Si pas de lieu de rangement pour le site de production de l'article, ce sont ceux de l'article qui sont pris par défaut.

#CF SIT A1[3]

Activation de la gestion du risque client par site (O/N, N par défaut)

N Le risque client reste géré au niveau de la société.

O Le risque client est géré au niveau des sites d'agrément. Nécessite l'activation de la clé BAS-16

#CF SIT A1[4]

Activation de la valorisation de la composition par site (O/N, N par défaut)


#CF SMC Matières consommées

Valeurs numériques 1 & 2 [image] Valeur alpha 1 [image] Valeur alpha 2 [image] Notes

Vérifiez le paramètre de lancement de votre programme : la note CODE_BESOIN_SMC indique

le code du paramètre de configuration (par défaut : SMC) Le type, lui, est figé (#CF).

L'affichage des matières consommées dans le devis dépend des paramètre suivants :

- Le mode imprimerie #CF SMC A1[23]

- La laize inversée ou non #CF ATL A1[35]

- Le mode de calcul de pose bobine #CF SMC A1[21]

- Le critère #CF SMC A1[22]

- Le type de devis TEN A1[41]

o Si I et si machine roto saisie , alors forçage à B (bobine)

o Si machine feuille forçage à F

o Sinon imprimerie utilisation du paramètre TEN A4[12]

Valeur numériques

#CF SMC N1 | Tolérance laize (en mm) appliquée lors de la recherche des matières sur format.
#CF SMC N2 | Tolérance coupe (en mm) appliquée lors de la recherche des matières sur format.

Valeur alpha 1

#CF SMC A1[1]

Les matières consommées doivent-elles être gérées en stock ? (O/N)

#CF SMC A1[2]

Les matières consommées sont elles des matières génériques ? (O/N)

Voir mp_param[25].

#CF SMC A1[3,5]

Type de mouvement de stock pour les sorties réserves générées par la saisie des matières consommées.

#CF SMC A1[6,7]

6 Type de recherche sur la qualité.

Type 1 : recherche normale

Type 2 : recherche sur les données techniques

Type 3 : recherche papier

7 Ouverture de la fenêtre de sélection multicritères (O/N)

#CF SMC A1[8,9]

Type de recherche sur les matières. Voir ci-dessus.

#CF SMC A1[10,11]

Nombre maximum de matières optimales à afficher lors de la recherche par format

#CF SMC A1[12]

Recherche de la qualité matière

1 par la famille / sous-famille (par défaut)

2 par la qualité matière de la fiche article

3 par la famille
(uniquement si les majorations sont prises sur la famille et non sur la sous-famille)

4 par une recherche sur le début du code article

5 par une recherche sur le début du code qualité matière rattaché à l'article

#CF SMC A1[13,15]

Délai administratif pour le calcul de la date de réapprovisionnement, en nombre de jours.

#CF SMC A1[16]

Génération des besoins pour les articles achetés (O/N, O par défaut)

#CF SMC A1[17,19]

TSC du délai moyen d'approvisionnement des PF du fournisseur. Facultatif

EX : DMA

#CF SMC A1[20]

Code de la zone numérique du TSC du délai moyen d'approvisionnement des PF du fournisseur (1 à 3)

Obligatoire si le TSC du délai moyen d'approvisionnement des PF du fournisseur est renseigné

EX : 1

#CF SMC A1[21]

Calcul du nombre de poses bobines

1 Le nombre de poses calculé donne un nombre de poses format fini dans la laize papier) (par défaut).

2 Le nombre de poses calculée est un nombre de poses format de tirage (éventuellement plusieurs poses format fini dans un format de tirage) dans la laize papier.

3 Calculs adaptés aux étiquettes bobines

4 Le nombre de poses calculé donne un nombre de poses format de tirage dans la laize papier, on ne tient pas compte des débords et on prend en compte la largeur de la plaque en lieu et place de la largeur du papier commandé.

Voir également TEN A4[12].

#CF SMC A1[22]

Critère de sélection automatique

O Un critère de sélection automatique sur les familles feuilles et bobines est ajouté.
Le tri entre les familles est fait à partir de FAM A4[40].

N Aucune activité (par défaut)

#CF SMC A1[23]

Mode d'affichage

O Mode d'affichage imprimerie

Attention, engendre une inversion du format en liaison avec le #CF ATL A1[35] (fi_lar_papier et fi_lon_papier)

N Aucune activité (par défaut)

#CF SMC A1[24]

Regroupement des besoins (par fournisseur, dimension) (O/N, N par défaut)

#CF SMC A1[25]

Avertir si la date de disponibilité du besoin est inférieure à la date du jour

N Non , valeur par défaut

W Afficher un message en warning

#CF SMC A1[26]

Mise à blanc de la date de disponibilité du besoin matière si celle-ci est inférieure à la date du jour

O Oui (par défaut)

N Non

S Forçage systématique de la date à blanc (quelle que soit sa valeur initiale)

#CF SMC A1[27,29]

Type de note source sur l'entête de la gamme (saisie des gammes)

Exemple : ACH

Remarque : Type de note obligatoire pour l'activation de la recopie des notes saisies sur la gamme vers les notes sur le besoin matière

#CF SMC A1[30,32]

Type de note destination sur le besoin matière (visualisation des besoins matières)

Exemple : ACH

Remarque : Type de note obligatoire pour l'activation de la recopie des notes saisies sur la gamme vers les notes sur le besoin matière

#CF SMC A1[33]

Recopie des notes depuis le devis sur les besoins (O/N, N par défaut)

Equivalent à l'option Ocd sur la visualisation des besoins.

#CF SMC A1[34,36]

Type de notes des besoins matières (Exemple ACH)

Paramètre A2[44,46] sur la visualisation des besoins

#CF SMC A1[37,42]

Code calendrier transporteur par défaut pour les besoins

(prise en compte si aucun transporteur saisi sur la fiche fournisseur)

#CF SMC A1[43]

Si le délai demandé n'est pas respecté pour le fournisseur choisi, doit-on mettre à jour la date de disponibilité dans la table des besoins ? (O/N)

#CF SMC A1[44]

Forçage de l'état du besoin généré à A (génération à partir du devis standard) (O/N)

#CF ATL A4[57] doit être à O (oui).

#CF SMC A1[45]

Quantité à réserver dans les stocks

U Quantité utilisée (uc_qte_util) [valeur par défaut]

C Quantité commandée (uc_qte_cde)

Dans la gestion des besoins matière, il y a 2 quantités différentes : la quantité utilisée et la quantité commandée.

Dans certains cas, lors d'une modification manuelle du besoin, c'est la quantité commandée qui doit être mise en réserve en stock. Pour répondre à toutes les demandes, on paramètre donc l'origine de la quantité à réserver en stocks dans la gestion des besoins matières.

#CF SMC A1[46]

Lancement de la recherche de matière optimisée au retour de VoluOptimix

Le premier papier trouvé est automatiquement récupéré et mis à jour sur l'entité du devis.

La recherche de matière optimisée n'est pas effectuée si le format papier est bloqué.

Valeur alpha 2

#CF SMC A2[1]

Le contrôle entre la qualité carton saisie et la qualité carton associée à la matière doit-il être réalisé ?

(O/N)

#CF SMC A2[2]

Les refoulages figurent-ils dans les informations complémentaires de la fiche matière ? (O/N)

Voir type paramètre CIC pour les correspondances.

#CF SMC A2[3]

Le poids de l'article doit-il être calculé et mis à jour sur la ligne de commande ? (O/N)

On détermine une surface réelle de carton utilisée via une dimension calculée. Voir alpha 2[4].

Cette surface est multipliée par le grammage de la première matière utilisée (la matière principale)

Le poids ainsi obtenu est alors positionné sur la ligne de commande.

Cette méthode permet d'obtenir des poids corrects sur les bons de livraison.

#CF SMC A2[4]

Le poids calculé doit-il être mis à jour sur la fiche produit ? (O/N)

Ceci est utile lorsqu'un article qui a été fabriqué est vendu par la suite via une commande de type CD2.

#CF SMC A2[5]

Code identifiant la dimension calculée déterminant la surface réelle de carton utilisé.

Ce code doit être compris entre 1 et 9. On retrouve ce code sur la dimension calculée.

Voir DC alpha 1[1]. Dans le tableau de saisie des pointages, la dimension calculée devra être saisie.

La formule par défaut est : QR*. Cette formule donne la surface du développé unitaire.

#CF SMC A2[6,11]

Type et code du paramètre de la recherche des tarifs (exemple #CF TAR)

#CF SMC A2[12]

Forçage prix achat à 0 en cas de génération automatique besoin matière

#CF SMC A2[13]

Initialisation du champ refoulage de la table cde5 à :

O Oui

N Non (par défaut)

R Dépend de la valeur récupérée par le CIC P01 sur la qualité utilisée.

#CF SMC A2[14]

Recalcul matière

#CF SMC A2[15]

Force le recalcul des dimensions brutes de la matière (O/N, N par défaut)

#CF SMC A2[16]

Génération des mouvements de stocks (O/N, O par défaut)

#CF SMC A2[17]

Génération des besoins pour les produits asynchrones (O/N, N par défaut)

Il y a toujours la génération d'un besoin matière pour un produit asynchrone pour une commande de type FBI.

#CF SMC A2[18]

Gestion des besoins matières à partir de la variante de devis trouvée lors de la création de la ligne de commande (avec l'option -Orv sur commande) (O/N, N par défaut)

Pour la nouvelle gestion des besoins à partir de donnée du devis standard multi-métier (#CF ATL A4[57] = O).

Pour utiliser les données techniques de ce devis : #CF SMC A2[18] = O

#CF SMC A2[19]

Utilisation de l'unité de conversion dans la recherche du prix (O/N, N par défaut)

#CF SMC A2[20]

Forçage de l'utilisation du nombre de poses saisies dans l'entité du devis (O/N, N par défaut)

Exemple : Si l'on a défini un nombre de poses laize de 2, on n'affichera dans la recherche de matière optimale que les papiers permettant de faire tenir 2 poses laize.

#CF SMC A2[21]

Utiliser le coefficient de conversion présent sur la matière pour le calcul de la surface brute commandée (O/N, N par défaut)

#CF SMC A2[22]

Numéro de conversion à utiliser (1,2,3, …)

#CF SMC A2[23]

Ignorer les tolérances paramétrées dans les zones numériques lors du recalcul du nombre de poses du besoin s'il est pris sur stock (O/N – N par défaut)

Lors du traitement des besoins, si on choisit de prendre sur stock, il y a un recalcul du besoin pour choisir au mieux la plaque en stock.

Ce recalcul prend en compte les tolérances paramétrées sur les valeurs numériques 1 et 2 pour recalculer le nombre de poses par plaque.

On ne veut pas prendre en compte ces tolérances mais on ne peut pas les remettre à 0 car elles servent aussi à la recherche de la matière optimale.

On crée donc cette nouvelle option dans le #CF SMC.

#CF SMC A2[24]

Type de prix à utiliser dans la recherche des tarifs pour les besoins matière

F prix d'achat (valeur par défaut)

C prix de vente

R prix de revient

#CF SMC A2[25]

En mode bobine

Prise en compte du nombre de poses (O/N, O par défaut)

Si on ne prend pas en compte le nombre de poses, il n'y a pas d'impact sur la recherche; mais on prendra toutes les bobines trouvées en 1 pose, ce qui fera un pourcentage de perte plus élevé.

#CF SMC A2[26]

Alimentation de la matière utilisée avec la qualité carton si cette matière n'est pas saisie dans le CIC C01 de l'article commandé (O/N – N par défaut)

Dans certains cas, il n'y a pas de devis.

Les besoins matières sont donc générés en fonction des données techniques de l'article commandé.

Pour que le traitement complet du besoin avec génération du code plaque puis génération de la commande d'achat fonctionne correctement, la zone uc_mat_util doit impérativement être renseignée.

Si on va en saisie manuelle sur les besoins, et si cette zone n'est pas renseignée, elle s'initialise automatiquement avec le code qualité carton du besoin. Le même mécanisme a donc repris dès la génération du besoin.

Notes

#S

3,60 Complément de sélection sur la recherche des matières sur format

(F8 sur la zone matière consommée).

(recherché ici si non trouvé sur le paramètre de lancement de devis_tc)

Exemple #S mp_code[3,3] != "R"

AFFICHE_UNITE_UTILIS

21 Doit-on afficher l'unité d'utilisation de la qualité (O/N, N par défaut)

AFF_ZONE_ADA

21 Saisie de l'adresse d'envoi du fournisseur (besoin matière dans v_cde_5)

O Affiche la zone de saisie pour l'adresse d'envoi

N N'affiche pas la zone de saisie

AFF_ZONE_ADF

21 Saisie de l'adresse de facturation (besoin matière dans v_cde_5)

O Affiche la zone de saisie pour l'adresse de facturation

N N'affiche pas la zone de saisie

AVEC_MORCEAUX_FEFCO

21 Prise en compte du nombre de morceaux issu du FEFCO (O/N, N par défaut)

O La prise en compte du nombre de morceaux issu du FEFCO est faite lors de la génération des besoins matières (donc pas dans le devis).

N Le nombre de morceaux issu du FEFCO n'est pas pris en compte lors de la génération des besoins matières (doit donc être pris en compte dans les formules du devis).

CACHE_COUPE_ENTETE

21 Doit-on cacher la zone coupe située dans l'entête de l'écran des matières optimales (O/N, N par défaut)

CACHE_COUPE_LIGNE

21 Doit-on cacher la zone coupe située dans le tableau de l'écran des matières optimales (O/N, N par défaut)

CACHE_MODE

21 Doit-on cacher la zone mode inversé (Mode) située dans le tableau de l'écran des matières optimales (O/N, N par défaut)

CACHE_NB_POS_COUPE

21 Doit-on cacher la zone nombre de poses sens coupe située dans le tableau de l'écran des matières optimales (O/N, N par défaut)

CACHE_TOL

21 Doit-on cacher la zone utilisation tolérance () située dans le tableau de l'écran des matières optimales (O/N, N par défaut)

CODE_LCO_REFOULE

Gestion des besoins matières à partir de la variante de devis trouvée

21, 23 Code paramètre LCO correspondant à la saisie du code refoulé

25, 26 Zone LCO

#A Zone alphanumérique 1

#B Zone alphanumérique 2

#G Zone alphanumérique 3

#H Zone alphanumérique 4

La définition du réceptacle de saisie du profil carton (famille ou sous-famille de l'article ) est définie en alpha2[17] de #CFATL.

CONSERVE_TARIF_CALC

21 Conserver les tarifs calculés (O/N, N par défaut)

LIB_COUPE_BOB

21, 25 Libellé de la colonne Coupe lors de l'affichage d'un papier bobine

LIB_COUPE_DEF

21, 25 Libellé de la colonne Coupe

LIB_COUPE_FEU

21, 25 Libellé de la colonne Coupe lors de l'affichage d'un papier feuille

LIB_LAIZE_BOB

21, 25 Libellé de la colonne Laize lors de l'affichage d'un papier bobine

LIB_LAIZE_DEF

21, 25 Libellé de la colonne Laize

LIB_LAIZE_FEU

21, 25 Libellé de la colonne Laize lors de l'affichage d'un papier feuille

LIB_QUAL_RECH_MAT

21,60 Libellé à afficher pour la Qualité sur l’écran de recherche matière optimisée

LIST_TYPE_NOTE_A_REC

21,23 Type de note du devis que l'on veut recopier

(idem notes visualisation besoins)

MAS_ZONE_REFOULAGE

21 Masquer la case à cocher Matière à commander refoulée (O/N, N par défaut)

MODE_REAP_AUTORISE

21,60 Etats de besoin matière autorisés (NCRAS par défaut)

N Pas de commande

C A commander

R A regrouper

A A traiter

S Sur stock

REC_OPTI_COU_COL_xxx

21,40 Nom de la zone à contrôler pour la couleur en fonction de l'origine

xxx -> origine (DEV, BES)

Exemple pour BES : mp_coul (de la qualité carton)

Exemple pour DEV : fi_couleur_pap

REC_OPTI_GRA_COL_xxx

21,40 Nom de la zone à contrôler pour le grammage en fonction de l'origine

xxx -> origine (DEV, BES)

Exemple pour BES : uc_poids

Exemple pour DEV : fi_grammage

REC_OPTI_GRA_MAX

21,26 Tolérance grammage maxi

Exemple 100

Si le grammage est de 400, on pourra prendre des plaques dont le grammage est <= à 500

REC_OPTI_GRA_MIN

21,26 Tolérance grammage mini

Exemple 50

Si le grammage est de 400, on pourra prendre des plaques dont le grammage est >= à 350

SUP_REQ_RG1_SITE_USE

21 Complément de requête pour ne prendre que les lieux de rangement dont le site est celui du USE qui lance la recherche de plaque (O/N, N par défaut)

O Le complément de requête est automatiquement généré.

Tableau de bord du multisite

_SUP_REQ_STOCK

Pour les bobines

21,60 Complément de requête sur la table stk0 pour la recherche de stock physique dans le cas des bobines (la recherche se fait par un rechll).

_TYPE_RECH_LL

21,22 Type de recherche des stocks

Rappel : Type de recherche lot/lieu (Obligatoire)

0 Recherche des lots

1 Recherche des lieux

2 Recherche des lots-lieux

3 Recherche des lieux-lots

10 Recherche des lots sans optimisation

11 Recherche des lieux sans optimisation

12 Recherche des lots_lieux sans optimisation (par défaut)

13 Recherche des lieux-lots sans optimisation


#CF SSC Saisie simplifiée de commande

#CF SSC ou tout autre paramètre défini dans la note SSC_PARAM_CONFIG (v_mat et v_prostk)

Il est possible de générer une commande en saisissant un minimum d'information, à partir de :

la visualisation des produits (v_mat)

la visualisation des profils de stock (v_prostk)

Ce fonctionnement utilise la mécanique de la génération de commande EDI (Type de message : ORDERS)

Le type de commande est actuellement forcé à CD2.

Suivant le paramétrage, plusieurs enchaînements peuvent être réalisés :

Par défaut, on génère la commande EDI sans enchaînement particulier.

Sur paramétrage, la génération de commande EDI peut être suivie d'une visualisation directe du message EDI générée (visualisation des messages EDI).

Sur paramétrage (sur la visualisation des messages EDI), la commande commerciale CD2 peut être générée en automatique,

suivie ou non de l'accès à la saisie des commandes,

suivie ou non de l'édition des AR,

suivie ou non de la génération et de l'édition d'un BL.

Complément du 04/04/2011

1) Recherche de tarif : Si la recherche par le calcul de tarif ne retourne pas de valeur, alors rechercher le prix sur le devis associé au produit (ne concerne que la table fle_2, même principe qu'avec l'option Opz en saisie de commande commerciale)

2) Gérer le site dans cette génération, et dans la gestion des commandes de type EDI, les lancements de modification/visualisation des commandes et lancement d'AR, doivent être paramétrés en fonction du site.

Le paramétrage à mettre en oeuvre est repéré par la mention Génér.cde :

Dans v_mat : 4 notes commençant par SSC et 3 nouvelles zones

Dans v_prostk : 4 notes commençant par SSC et 3 nouvelles zones

Dans v_edi_cde : A2[33], A2[35] et 7 notes

Dans v_cdem et v_cde_marche : 3 notes

Dans exped_affretements : 6 notes

Notes

Toutes ces notes sont également paramétrables sur le paramètre de lancement de l'état des alertes. Elles y sont prioritaires.

SSC_CODE_SITE

21,23 Code site à prendre en compte par la génération de commande, si celui-ci n'est pas renseigné par le programme appelant.

Met à jour la zone edi_cde.edc_c1

Tableau de bord du multisite

La note déclarée sur v_cdem ou v_cde_marche est prioritaire à celle-ci.

SSC_COMPTEUR_EDC_REF

21,29 Code racine du compteur alphanumérique (type N)

30 Longueur du folioteur

La note déclarée sur v_mat ou v_prostk est prioritaire à celle-ci.

SSC_CTRL_CLI_PROD

21 Contrôle que le code client ou le code produit est passé en argument (O/N, O par défaut)

Pour les expéditions, il ne faut pas contrôler, le client ou le produit ne sont pas connus, ils seront saisis.

Option payante LIV 7 et autorisation sur la touche F23 : BLV2_GEN_CDE

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_DELAI_OBLIGATOIR

21 Le délai est-il obligatoire (O/N, N par défaut)

La note déclarée sur v_cdem ou v_cde_marche est prioritaire à celle-ci.

SSC_ECRAN_SAISIE

21 Ecran de saisie (O/N, O par défaut)

SSC_F10_VERIF_DELAI

21 Si le délai est accepté suite à la vérification par la touche F9, doit-on lancer immédiatement la génération de la commande (O/N, N par défaut)

O Si le délai est accepté suite à la vérification par la touche F9, on lance immédiatement la génération de la commande.

N Si le délai est accepté, on reste sur la saisie de la commande simplifiée, la validation se fera par la touche F10.

SSC_FORCAGE_TYP_REAP

21 Possibilité de forcer le mode de réapprovisionnement (O/N, N par défaut)

On forcera la valeur avec Synchrone, Asynchrone ou Rien.

Rien signifie que la gestion se fait comme actuellement, et qu'il n'y a pas de forçage.

SSC_INIT_ZONE_ADL

21 Initialisation de l'adresse de livraison de l'entête et de la ligne de commande avec la globale gl_code_adl initialisée dans le module d'intégration des données des propriétaires (O/N, N par défaut)

SSC_INIT_ZONE_DELCLI

21 Initialisation du délai client de la ligne de commande avec la globale gl_delai_client initialisée dans le module d'intégration des données des propriétaires (O/N, N par défaut)

SSC_INIT_ZONE_P3

21 Initialisation de la zone paramètre 3 de la ligne de commande avec la globale gl_code_p3 initialisée dans le module d'intégration des données des propriétaires (O/N, N par défaut)

SSC_LCO_DEVIS_PRIO

21,23 Code de la LCO définissant la priorité du sous-devis (LCO GDF par défaut)

Dans la recherche du prix de la ligne de commande par la variante de devis, il est désormais possible de forcer la variante utilisée par un LCO sur l'entité du devis. Le prix de la ligne de commande sera celui de la variante forcée.

LCO A1[16] de la variante prioritaire doit être égal à O (Oui).

La note déclarée sur v_cdem ou v_cde_marche est prioritaire à celle-ci.

SSC_LIEU_DESTOCK

21,35 Lieux de déstockage par défaut

23 lieu 1

24,29 lieu 2

30,35 lieu 3

Si la saisie n'a pas lieu, ces données seront prises sur la fiche produit.

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_LIEU_INTER

21,23 Lieu intermédiaire par défaut dans le cas de la saisie

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_LIG_REF_EXISTANT

21 Si la référence existe, peut-on la conserver et ajouter une ligne de commande à la commande déjà existante pour cette référence ? (O/N, N par défaut)

SSC_PARAM_COL

Paramétrage des colonnes de la saisie simplifiée de commande

21,50 Nom de la colonne à paramétrer. Colonnes disponibles :

lc_lib

lc_qtecde

lc_prx

lc_unvent

52 Colonne visible (O/N, N par défaut)

53 Valeur de la colonne modifiable (O/N, N par défaut)

SSC_PARAM_EDI_CDE

Saisie simplifié de commande en mode utilisateur

La note déclarée sur v_mat ou v_prostk est prioritaire à celle-ci.

21,26 Type et code du paramètre de lancement de la visualisation des commandes EDI

27 Ouverture de la visualisation EDI avec génération automatique de la commande

O A la validation de l'écran de saisie simplifiée de commande, on lance automatiquement la génération de la commande via la visualisation EDI. Les écrans et messages éventuels sont affichés à l'écran.

N A la validation de l'écran de saisie simplifiée de commande, on accède à la visualisation EDI. C'est à l'utilisateur de confirmer la génération de commande via la touche de fonction de génération (F12) (par défaut).

SSC_PARAM_RECH_TAR

21,26 Type et code du paramètre de configuration de recherche de tarif

La note déclarée sur v_mat ou v_prostk est prioritaire à celle-ci.

SSC_PRX_DEV_TARIF_0

21 Récupération du prix sur le devis associé au produit si la recherche de tarif ne retourne pas de valeur (O/N, N par défaut)

La note déclarée sur v_cdem ou v_cde_marche est prioritaire à celle-ci.

SSC_SAISIE_LIEU_DESTOC

21 Doit-on saisir le lieu de déstockage ? (O/N, N par défaut)

Ce lieu alimentera les zones cde4.nc_rgt1, cde4.nc_rgt2 et cde4.nc_rgt3

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_SAISIE_LIEU_INTER

21 Doit-on saisir le lieu intermédiaire ? (O/N, N par défaut)

Ce lieu alimentera la zone cde2.lc_lieu_rgt1

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_SAISIE_REF_CDE

21 Doit-on saisir la référence client ? (O/N, N par défaut)

Si Non, la référence sera initialisée par le compteur défini dans la note SSC_COMPTEUR_EDC_REF

La note déclarée sur exped_affretements est prioritaire à celle-ci.

SSC_TYP_TYC

21,23 Type de la commande générée

SSC_ZONE_INIT_QTE

21,38 Nom de la zone utilisée pour initialiser la quantité commandée de la ligne de commande

mp_qteeco

mp_qtemini_cdeclt

mp_smaxi

mp_smini

qte_transferee

_SUP_REQ_STK0_OUT_E

21,60 Complément de recherche sur la table stk0 lors de la recherche de mouvement de type Entrée pour la disponibilité des outillages

_SUP_REQ_STK0_OUT_S

21,60 Complément de recherche sur la table stk0 lors de la recherche de mouvement de type Sortie pour la disponibilité des outillages

TMV_ENT_OUTILLAGE

21,23 Type de mouvement d'entrée de l'outillage

TMV_SOR_OUTILLAGE

21,23 Type de mouvement de sortie de l'outillage


#CF STC Statistiques clients

Valeur alpha 2

Les colonnes A et B sont obligatoirement éditées, elles ne doivent donc pas figurer en alpha 2.

A | Numéro d'ordre
B | Code client
C | Nom du client
D | Année
E | Mois
F | CA facture
G | Cumul du CA
H | Nombre de devis
I | Nombre de commandes
J | Nombre de factures
K | % du CA total
L | CA prévisionnel
M | Rapport entre le CA facture et le CA prévisionnel
N | CA en commande
O | Poids net en commande (option)
P | Surface nette en commande (option)
Q | Poids net prévisionnel (option)
R | Surface nette prévisionnelle (option)
S | Poids net facturé (option)
T | Surface nette facturée (option)
U | Nombre d'affaires (pour édition)

Critères de sélection | Saisir 99 dans les mois pour éditer les cumuls annuels Pour éditer de 01/89 au 04/90 saisir 01/89 en date de début et 12/90 en date de fin
4 types de présentation | Client / Année / Mois avec un total par client et un total général Année / Mois / Client avec un total par année et un total général CA décroissant / Année / Mois / Client avec un total général Année / CA décroissant / Mois / Client avec un total par année et un total général


#CF STK Mouvements de stock

Valeurs numériques

1 | Nombre de décimales pour l'édition des quantités (0 à 3) (2 par défaut)
2 | Nombre de décimales pour les montants (0 à 2) (2 par défaut)

Valeur alpha 2

#CF STK A2[1,60]

Paramétrage des colonnes pour l'édition abrégée

Par défaut : CDJEFIKGHOPQRS (les colonnes concernées sont en bleu pour les repérer facilement).

A Code Matière / Produit

B Désignation Matière / Produit

C Numéro mouvement de stock

D Date mouvement de stock

E Type mouvement de stock

F Entrée / Sortie / Valeur (E,S,V)

G Client

H Numéro de commande

I Prix unitaire

J Frais - Port

K Ordre de fabrication (Affectation)

L Etat mouvement : Réserve / en Commande/ Normal / Prévisionnel (R,C,N,P)

M Quantité mouvement dans l'unité de vente

N non utilisé

O Stock résultant en unité de vente

P Numéro de lot

Q Première zone de rangement (RG1)

R Deuxième zone de rangement (RG2)

S Troisième zone de rangement (RG3)

T Code Famille

U libelle Famille

V Code Sous-Famille

W Libellé Sous-Famille

X Quantité mouvement dans l'unité d'achat

Y Code unité d'achat

Z libelle unité d'achat

a Code unité de vente

b libelle unité de vente

c Colonne des Entrées dans l'unité de vente

d Colonne des Sorties dans l'unité de vente

e Colonne des Entrées dans l'unité d'achat

f Colonne des Sorties dans l'unité d'achat

g Stock résultant en unité d'achat

h Valeur Stock

i Code Fournisseur principal (mat.mp_foucli)

j Nom du Fournisseur principal

k Valeur du mouvement

l Note (voir #CF NTS)

m Code Fournisseur en Entrée de stock (stk0.s0_fou)

n Numéro de Commande Fournisseur (stk0.s0_cdefou)

o Nom du Fournisseur en Entrée de stock

p Première ligne de note sur le mouvement (30 caractères)

q Première ligne de note sur le mouvement (60 caractères)

r Format (Longueur x largeur) sans décimales

s Grammage (g/m2) sans décimales

t Libelle court du lieu de rangement

u Centre de coût

v Libellé du centre de coût

Valeur alpha 3

#CF STK A3[1,3] | Type de mouvement de stock pour une régularisation d'entrée sur le stock physique
#CF STK A3[4,6] | Type de mouvement de stock pour une régularisation de sortie sur le stock physique
#CF STK A3[7,9] | Type de mouvement d'entrée pour la gestion des outils
#CF STK A3[10,12] | Type de mouvement de sortie pour la gestion des outils
#CF STK A3[13] | Code origine des informations pour le calcul du poids (0/1/2, 0 par défaut) - Facultatif 0 Mode normal 1 On force la récupération du poids sur la ligne de commande (lc_poids) 2 On force la récupération du poids dans la fiche article (mp_poids)
#CF STK A3[14] | Code état des mouvements de stock (N/O, N par défaut) - Facultatif N Code état à 2 si article géré par Lot-Lieu Code état à 4 si article géré par Lot-Lieu-Conditionnement O Code état à N
#CF STK A3[15,17] | Type de mouvement de stock de sortie du NON VENDABLE - Obligatoire Le type de mouvement doit être une sortie normale.
#CF STK A3[18,20] | Type de mouvement de stock d'entrée du A RETRAITER - Obligatoire Le type de mouvement doit être une entrée normale.

Valeur alpha 4

#CF STK A4[1] | Type de lot à contrôler C Le lot correspond à un entête de commande L Le lot correspond à une ligne de commande N Le lot n'est pas contrôlé
#CF STK A4[2] | Contrôle du produit vis à vis du lot N Pas de contrôle W Contrôle non bloquant
#CF STK A4[3] | Affichage de la colonne Date départ dans la visualisation simplifiée des stocks (O/N, N par défaut)
#CF STK A4[4] | Utilisation de la gestion des flag/deflag (O/N, N par défaut) Voir page dédiée
#CF STK A4[5] | Origine de la gestion des lots génériques N Pas de gestion des lots génériques [valeur par défaut] T Gestion des lots génériques sur les types de mouvements (paramètres TMV) Voir la note RADICAL_LOT_GENERIQ Dans le TMV, voir la note NUMERO_LOT_GENERIQ

Notes

FORMAT_DEC_VISSTKDI

Pouvoir paramétrer le format des zones de stock (disponible, en commande, …) dans la visualisation des stocks disponibles par semaine et par jour.

21,60 Format des zones de stock en affichage

Exemple

### ##&

Ce paramètre se positionne sur chaque lanceur susceptible d'utiliser ces fonctions de visualisation de stock (f_visstkdi et f_visdisjo)

Remarque : cette note s'inscrit sur le paramètre #VI mais peut aussi s'inscrire sur le paramètre #CF STK.

MAJ_STK_DEPUIS_VS

21,26 Type et code du paramètre de lancement de la correction des stocks lancée à partir de la visualisation simplifiée

La même note saisie sur le paramètre de lancement de la visu des stocks est prioritaire.

RADICAL_LOT_GENERIQ

Radical permettant d’identifier les lots génériques (2 caractères obligatoirement)

Voir #CF STK A4[5]

SUP_REQ_CONT_INFO

21,60 Supplément de requête de la table conteneur_info

SUP_REQ_CONT_PRODUIT

21,60 Supplément de requête de la table conteneur_produit

SUP_REQ_EXCEDENT

21,60 Supplément de requête pour la recherche des FBI

La requête porte sur les tables cde1, cde2 et cde4

SUP_REQ_RG1_SITE_USE

21 Limiter le traitement aux lieux de rangement du site de l'utilisateur (O/N, N par défaut)

Tableau de bord du multisite

Cette note existe aussi sur le paramètre de lancement des programmes suivants, où elle est prioritaire.

la visu des profils de stock

la visu des articles

_SUP_SQL_APPEL_CDE8

21,60 Complément de sélection pour la recherche des appels de livraison non soldés

Par défaut : and li_qua = "APP"

_SUP_SQL_TYC_CD1

21,60 Complément de sélection pour la recherche des commandes de type CD1 rattachées aux commandes de type CDA

Par défaut : and ec_tyc = "CD1"

VISU_STK_DEPUIS_VS

21,26 Type et code du paramètre de lancement de la visualisation des stocks lancée à partir de la visualisation simplifiée

La même note saisie sur le paramètre de lancement de la visu des stocks est prioritaire.


#CF STM Statistiques articles

Valeur alpha 2

A | Code matière/produit
B | Désignation matière/produit
C | Année
D | Mois
E | Quantité
F | CA au prix d'achat
G | CA au prix de revient
H | CA au prix de vente
I | Marge en valeur et % au prix d'achat
J | Marge en valeur et % au prix de revient


#CF STV Suspension de TVA

Valeur alpha 1

Caractère 1 | Numérotation automatique de l'autorisation de suspension (O/N, N par défaut)
Caractère 2 | Sélection préalable à la saisie (O/N) (O/N, N par défaut)


#CF TAC Transfert des comptes vers la compta Fabrical

#CF TAC Transfert des comptes vers la compta

Notes

Explications

Séparateur à la fin de chaque zone

Libellé de la zone : figé

Code(s) correspondant au libellé Il(s) est (sont) figé(s)

Ainsi pour chaque ligne, il faut saisir un libellé, puis [:], puis le code et enfin [:]

Description des lignes

cpte_contre_partie | Numéro de compte de contrepartie. Il correspond aux caractères 108 à 115 du fichier SETEC_ACO (longueur 8 caractères)
code_société | Il doit être égal a la valeur saisie dans la zone BD de la société. Il correspond aux caractères 2 à 5 du fichier SETEC_ACO (longueur 4 caractères)
code_division | Il correspond aux caractères 6 à 8 du fichier SETEC_ACO (longueur 3 caractères)
code_journal | Il correspond aux caractères 45 à 46 du fichier SETEC_ACO (longueur 2 caractères)
code_libellé | Il correspond aux caractères 55 du fichier SETEC_ACO (longueur 1 caractère)
code_cp | Code libellé du compte de contrepartie. Il correspond aux caractères 55 du fichier SETEC_ACO (longueur 1 caractère)
libellé_piece | Libellé pièce. Il correspond aux caractères 56 à 79 du fichier SETEC_ACO (longueur 24 caractères)
sens_écriture_débit | Sens de l'écriture cote débit. Il correspond aux caractères 116 à 117 du fichier SETEC_ACO (longueur 2 caractères)
sens_écriture_crédit | Sens de l'écriture cote crédit. Il correspond aux caractères 116 à 117 du fichier SETEC_ACO (longueur 2 caractères)


des_mp_qualite_mat : Désignation de la qualité matière (produit : mat dans f_zone)

des_mg_qualite_mat : Désignation de la qualité matière (matière générique : mat_gen dans f_zone)

Le champ tr_char de la table tar0 contient le code format de l'article (Paramètre FMT).

Les valeurs numériques 1 et 2 du code format contiennent la longueur et la largeur du format.

Tous les tarifs dont les valeurs numériques 1 et 2 du code format (tr_char) correspondent à la longueur et la largeur de la ligne de commande fournisseur sont sélectionnés.

#CF TAR Recherche des tarifs

Voir aussi l'aide sur la saisie des tarifs.

Règle

Les plages de dates, les plages de quantités et le code devise font systématiquement partie de la recherche de tarif.

Valeurs numériques

#CF TAR N1

Coefficient multiplicateur appliqué à la quantité avant la recherche des tarifs (ne peut pas être ni null, ni 0).

Ceci permet une éventuelle conversion de quantité avant la recherche.

Exemple : On recherche un tarif pour une quantité de 500.

Si, sur le paramètre #CF TAR, la zone numérique 1 contient 10, la recherche de tarif sera effectuée sur la quantité 5000.

#CF TAR N2

non utilisée

Valeur alpha 1

#CF TAR A1[1,25]

Ordre de recherche des tarifs

La recherche de tarif sera effectuée pour tous les types de recherche paramétrés.

Ce qui amène le système à trouver éventuellement plusieurs tarifs correspondants au cas traité.

Le caractère 26 indiquera quel tarif le système devra choisir.

Il n'y a en aucun cas cumul des valeurs trouvées.

1 tiers / article

2 tiers / famille

3 tiers / famille / sous-famille

4 catégorie tiers / article

5 catégorie tiers / famille

6 catégorie tiers / famille / sous-famille

7 code tarif / article

8 code tarif / famille

9 code tarif / famille / sous-famille

A code tarif / sous-famille

B article

C code tarif / article / tiers

D code tarif / tiers

E code tarif / tiers / famille / sous-famille

F code tarif / tiers / famille

G code tarif / tiers / article, famille et sous-famille

H code tarif / article / famille et sous-famille

I code tarif / catégorie tiers

J code tarif / catégorie tiers / article

K code tarif / catégorie tiers / article / famille / sous-famille

L Code tarif / catégorie tiers / famille /sous-famille

M Code tarif / catégorie tiers / famille

N Code tarif / catégorie tiers / sous-famille

O Tiers / Article / Famille / Sous-Famille

P Article / Famille / Sous-Famille

Q Article/Code tarif/Sans code tiers saisi

R Code tarif / tiers / catégorie tiers / article / famille / sous-famille

#CF TAR A1[26]

Valeur retenue

M Maxi

m Mini

D Dernier trouvé (dans l'ordre défini en #CF TAR A1[1,25])

P Premier trouvé (dans l'ordre défini en #CF TAR A1[1,25])

V Valeur par défaut mini (m)

Y (maxi + mini) / 2

#CF TAR A1[27]

Choix des tarifs en automatique

O Recherche automatique, donc aucune ouverture de fenêtre pour le choix de tarifs dans un mode de recherche, choix automatique du tarif en fonction du caractère 26.

D Ouverture de la fenêtre détaillée - voir #CF DEG A4[26]

N Ouverture de la fenêtre non détaillée sans blocage du prix (valeur par défaut)

#CF TAR A1[28]

Sélection rapide des tarifs

O Si on a trouvé un tarif dans le premier mode de recherche, on sort sans continuer.

P Si un tarif qui possède un prix net est trouvé, ce tarif est gardé et la recherche cesse.

N ou défaut Recherche sur tous les modes de sélection

#CF TAR A1[30,31]

Code calcul dépendance utilisé pour définir le code catégorie dans la recherche de tarif

(spécifique ME)

#CF TAR A1[32,38]

Paramétrage dépendance utilisé pour définir le code catégorie dans la recherche de tarif

(spécifique ME)

#CF TAR A1[39]

Définition de l'article sur lequel s'effectue la recherche de tarif

D Code article passé en paramètre (par défaut)

Q Code qualité matière de l'article passé en paramètre

C Code article passé en paramètre puis code qualité matière de l'article passé en paramètre si aucun tarif n'est trouvé sur ce dernier.

G Code article passé en paramètre puis code article générique de l'article passé en paramètre si aucun tarif n'est trouvé sur ce dernier puis code qualité matière de l'article passé en paramètre si aucun tarif n'est trouvé sur ce dernier.

#CF TAR A1[40]

Définition du tiers sur lequel s'effectue la recherche de tarif

D ou [blanc] Code tiers passé en paramètre

G Code groupe tiers du tiers passé en paramètre

g Code tiers passé en paramètre. Si aucun tarif trouvé, une deuxième recherche est effectuée sur le code groupe tiers du tiers passé en paramètre

#CF TAR A1[41]

Renvoie d'une valeur à 0 si aucun tarif trouvé

N Si aucun tarif trouvé, la valeur renvoyée est issue de la fiche article (par défaut)

O Si aucun tarif trouvé, la valeur renvoyée est 0

#CF TAR A1[42]

Définition de la famille sur laquelle s'effectue la recherche de tarif

O On recherche les tarifs avec le code famille de regroupement

N On recherche les tarifs avec le code famille du produit (par défaut)

#CF TAR A1[43]

Définition de la sous-famille sur laquelle s'effectue la recherche de tarif

O On recherche les tarifs avec le code sous-famille de regroupement

N On recherche les tarifs avec le code sous-famille du produit (par défaut)

#CF TAR A1[44]

Affichage d'un message si la recherche du tarif n'aboutit pas.

Voir les notes MESSAGE_TARIF_x

N Pas d'affichage de message (valeur par défaut)

O Affichage d'un message à chaque type de recherche qui n'aboutit pas

D Affichage d'un message sur le dernier type de recherche si aucun type de recherche n'aboutit.

#CF TAR A1[45,48]

La recherche des tarifs peut s'effectuer avec 4 paramètres :

  1. Type feuille/bobine (tar0.tr_feuille_bobine) - voir A1[45]

  2. Une valeur numérique - voir A1[46]
    (doit être comprise entre les bornes tar0.tr_num_binf et tar0.tr_num_bsup)

  3. Une valeur alphanumérique (tar0.tr_char) - voir A1[47]

  4. La valeur du site de production (tr_site) - voir A2[27]
    Tableau de bord du multisite

Cette recherche ramène maintenant en plus la partie fixe du tarif (tar0.tr_fixe) - voir A1[48]

L'alimentation des zones utilisées pour la recherche des tarifs se fait sur les notes commençant par _INFO_TR_.

On peut définir, pour chacune de ces 4 valeurs, des valeurs différentes en fonction de la famille et la sous-famille.

#CF TAR A1[45]

Recherche avec le type feuille/bobine passé en paramètre (tr_feuille_bobine)

Voir le paragraphe générique ci-dessus sur la recherche des tarifs.

#CF TAR A1[46]

Recherche avec la valeur numérique (tr_num_binf < x <tr_num_bsup)

Pour la gestion du TEXTILE, doit être à O (Oui)

La valeur numérique est alimentée avec le nombre de couleurs de la ligne de commande (Nombre de TSC C01 à C15).

Voir le paragraphe générique ci-dessus sur la recherche des tarifs.

#CF TAR A1[47]

Recherche avec la valeur alpha (tr_char)

Voir le paragraphe générique ci-dessus sur la recherche des tarifs.

#CF TAR A1[48]

Intégration de la partie fixe (O oui - N non - Q question posée)

Voir le paragraphe générique ci-dessus sur la recherche des tarifs.

Devis multi-métiers uniquement : Ce paramétrage est désactivé dans le cas de la génération des tarifs des produits de premier niveau de la nomenclature PLV (TPR A2[8] = O ou R)

Alimentation des prix négociés dans le devis multi-métiers (voir la note CONF_TAR_PX_NEGOCIE)

Le prix au plus négocié est alimenté avec la valeur du tarif.

Le prix négocié est alimenté avec la valeur du tarif + partie fixe ramenée à la quantité du devis.

Génération des tarifs dans le devis multi-métiers (voir la note CONF_TAR_PX_NEGOCIE)

La valeur du tarif est alimentée avec le prix au plus remis.

La partie fixe est alimentée par recalcul à partir du prix remis et du prix au plus.

#CF TAR A1[49]

Définition de l'adresse du tiers sur lequel s'effectue la recherche de tarif

C ou [blanc] Code adresse principale du tiers (le code adresse est à blanc).

A Code adresse secondaire du tiers.
Si aucun tarif trouvé, une deuxième recherche est effectuée sur le code groupe du tiers passé en paramètre si A1[40] = G.

a Code adresse secondaire du tiers.
Si aucun tarif trouvé, une deuxième recherche est effectuée sur le code adresse principale du tiers (le code adresse est à blanc).
Si aucun tarif trouvé, une troisième recherche peut être effectuée sur le code groupe du tiers passé en paramètre.

X Recherche sans critère sur l'adresse

#CF TAR A1[50]

Mise à jour du code papier de l'entité du devis avec le code papier du tarif sélectionné

Cette option ne fonctionne que si A1[27] = D (détail) ou O et si l'article de l'entité est générique.

En mode détail il faudra choisir la ligne.

Il est nécessaire de paramétrer la note FORMULE_RECH_TARIFsur le TEN.

Valeur alpha 2

#CF TAR A2[1,25]

Pour chaque type de recherche paramétrée en #CF TAR A1[1,25], il est possible de spécifier si les critères non choisis doivent avoir une valeur nulle ou une valeur quelconque.

Ici, le caractère correspondant peut prendre les valeurs suivantes :

O Les critères non pris en compte lors de la première recherche doivent être à nuls.

N Les critères non pris en compte lors de la première recherche peuvent avoir une valeur quelconque (par défaut).

#CF TAR A2[26]

Comportement à adopter lors d'une recherche de tarif avec code tiers s'il n'y a pas de code passé (cas d'une recherche de tarif matière sans code fournisseur) :

O On passe à la recherche suivante [Valeur par défaut]

N On retourne 0 (zéro) sans faire les recherches suivantes.

#CF TAR A2[27]

Recherche avec le site de production (tr_site) (O/N, N par défaut)

Tableau de bord du multisite

#CF TAR A2[28]

Recherche du tarif avec la notion de tiers final (extension de toutes les recherches avec le tiers)

Lors de la recherche du tarif pour les commandes client, il est maintenant possible via paramétrage de rechercher un tarif avec la notion de tiers final. Cette notion est une extension de la recherche de tarif.

O Recherche du couple tiers – tiers final
Si non trouvé, on recherche sur le tiers final.
Si non trouvé, on recherche sur le tiers.

C Recherche du couple tiers – tiers final
Si non trouvé, on recherche sur le tiers.
Si non trouvé, on recherche sur le tiers final.

A recherche avec le tiers final. Si le couple tiers – tiers final n'a pas de tarif, on recherche sur le tiers final puis sur le tiers enfin sur #SOC.

B recherche avec le tiers final. Si le couple tiers – tiers final n'a pas de tarif, recherche sur le tiers puis sur le tiers final enfin sur #SOC.

N ou vide : pas de recherche sur le tiers final (par défaut)

Pour le paramétrage au niveau de la saisie, voir la note _SAISIE_TIERS_FINAL.

#CF TAR A2[29]

Code du tarif

Afficher ou masquer les colonnes

O Oui, afficher (par défaut)

M Masquer

#CF TAR A2[30]

Code catégorie

#CF TAR A2[31]

Code de l'article

#CF TAR A2[32]

Code du tiers

#CF TAR A2[33]

Code adresse du tiers

#CF TAR A2[34]

Code famille

#CF TAR A2[35]

Code sous famille

#CF TAR A2[36]

Plage de quantité

#CF TAR A2[37]

Plage de date

#CF TAR A2[38]

Type de valorisation

#CF TAR A2[39]

Code devise

#CF TAR A2[40]

Code unité

#CF TAR A2[41]

Code Prix Net

#CF TAR A2[42]

Code Prix revient

#CF TAR A2[43]

Commentaire

#CF TAR A2[44]

Plage numérique

#CF TAR A2[45]

Partie fixe

#CF TAR A2[46]

Paramètre complémentaire

#CF TAR A2[47]

Type feuille bobine

#CF TAR A2[48]

Délai par jour

#CF TAR A2[49]

Site

#CF TAR A2[50]

Afficher paramétrage de l'affichage du prix au colis (O/N, N par défaut)

Valeur alpha 3

Les caractères 1 à 58 définissent le paramétrage de la création automatique de tarifs à partir du prix de la ligne de commande.

#CF TAR A3[1] | Mode de gestion du code tarif V Valeur du code tarif paramétré ci-dessous en alpha3[2,4] C Code tarif de l'entête de commande F Code tarif défini sur la famille de l'article : FAM alpha3[40,42]
#CF TAR A3[2,4] | Code tarif (caractère 1 = V).
#CF TAR A3[5,8] | En attente
#CF TAR A3[9] | Type de gestion de la famille P Code famille pris sur l'article de la ligne de commande B Code famille à blanc
#CF TAR A3[10,12] | En attente
#CF TAR A3[13] | Type de gestion de la sous-famille P Code sous-famille pris sur l'article de la ligne de commande B Code sous-famille à blanc
#CF TAR A3[14,16] | En attente
#CF TAR A3[17] | Type de gestion des plages de quantités 1 Plages de quantités prises sur les caractères 18 à 26 et 27 à 39 2 Plages de quantités prises sur la ligne de commande Quantité minimum = quantité maximum = quantité de la ligne de commande
#CF TAR A3[18,26] | Quantité minimum (caractère 17 = 1)
#CF TAR A3[27,39] | Quantité maximum (caractère 17 = 1)
#CF TAR A3[40] | Type de gestion de la date minimum P Date minimum prise sur les caractères 41 à 48 T Date minimum = date du jour
#CF TAR A3[41,48] | Date minimum (caractère 40 = P). Format JJMMAAAA
#CF TAR A3[49,56] | Date maximum. Format JJMMAAAA
#CF TAR A3[57] | Valeur du code prix net (O/N)
#CF TAR A3[58] | Valeur du type de tarif A Ajout au tarif de base V Valeur

Exemple

alpha1[1,3] = 17B

alpha1[26] = P

alpha2[1,3] = NOO

1ère recherche effectuée sur le couple tiers – article. Les autres valeurs sont quelconques.

2ème recherche effectuée sur le couple code tarif – article. Les autres valeurs sont nulles.

3ème recherche effectuée sur l'article. Les autres valeurs sont nulles.

La valeur retenue sera la 1ère valeur trouvée.

Notes triées

CODE_TAR_REAPPRO_

Code de recherche tarif papier selon le mode de réapprovisionnement de l'entité

18 Mode de réapprovisionnement

S Stock interne

C A commander

F Fabrication

B Fabristock

E Externe

21,23 Code de recherche de tarif (doit correspondre à un paramètre de type TAR)

But : Permettre de rechercher les tarifs selon le mode de réapprovisionnement du papier de l'entité (fle_imp.fi_pap_stk).

Principe de fonctionnement :

• Un paramétrage permet d'associer un code tarif (TAR) à un mode de réapprovisionnement.

• Si aucun code tarif n'est associé au mode de réapprovisionnement de l'entité courante ou que celui paramétré n'existe pas, on prend le code tarif de l'entête du devis (fle_2.l2_bareme).

• Ce fonctionnement est uniquement valable pour la recherche du tarif du papier de l'entité courante, et ce pour tout le devis multi-métiers (exemple : ce fonctionnement est valable pour les formules matières dont le code matière est égal au code papier de l'entité).

COL_DELAI_JOUR

21 Afficher la colonne Délai en nombre de jours (O/N, N par défaut)

CRITERE_COULEUR

Dans la saisie de commandes, les lignes peuvent être colorées en fonction du tarif.

21 Priorité de calcul du tarif

23 Code couleur correspondant

_INFO_TR_

_INFO_TR_NUM_

_INFO_TR_TFB_

_INFO_TR_VAR_

_INFO_TR_SIT_

Alimentation des zones utilisées pour la recherche des tarifs Voir A1[45,48]

10,13 Choix de la zone à renseigner :

NUM_ valeur numérique (champs tr_num_binf et tr_num_bsup) - voir exemples plus bas

TFB_ tarif feuille ou tarif bobine (champ tr_feuille_bobine) - voir exemples plus bas

VAR_ valeur alpha (champ tr_char) - voir exemples plus bas

SIT valeur du site - Tableau de bord du multisite

14,16 Code famille (ou * pour toutes les familles)

17,19 Code sous-famille (ou * pour toutes les sous-familles)

21,60 Alimentation des zones utilisées pour la recherche des tarifs. 4 possibilités :

1) TSC*Type*Code TSC*Zone du TSC*

Type = A (Article), C (Commande), D (Devis), ou F (Tiers)

Zone du TSC à indiquer tel que dans la table info_c

2) LCO*Type*Code LCO*Zone*

Type = D (Devis) : seul type reconnu, le D est donc une constante.

Zone LCO : v1, v2, v3, v4 : (zones numériques), a1, a2, a3, a4 (zones alpha)

3) Table*Nom zone*

Tables utilisables :

blv1

cde1

cdf2

fle_2

fle_imp

mat avec certains champs particuliers

par02 :

par02_TVA permet de récupérer toute zone (ou partie de zone) de la table par02 faisant référence à la TVA de la ligne de commande (paramètre de type TVA et de code stocké dans lc_tva).

par02_FMT : Recherche de tarif sur le format de l'article. Seule la zone p2_code est accessible.

4) valeur*constante figée*

(valeur est ici le mot-clé permettant d'alimenter la zone utilisée avec la constante figée)

Exemples

1 2 3 4

1234567890123456789012345678901234567890

_INFO_TR_TFB_* * LCO*D*FE2*a1*

_INFO_TR_TFB_GC1* mat*mp_libre*

_INFO_TR_TFB_GC1230 TSC*A*REC*ic_char3_1*

_INFO_TR_NUM_* * mat*mp_poids*

_INFO_TR_VAR_* * TSC*A*REC*ic_char3_2*

_INFO_TR_VAR_* * par02_FMT*p2_code*

Pour la gestion du TEXTILE, les valeurs doivent être les suivantes :

10,13 NUM_

14,16 * (toutes les familles)

17,19 * (toutes les sous-familles)

20,20 [blanc]

21,60 TSC*C*XXX*ic_num1* (le XXX doit rester tel quel - ne pas le remplacer par un code TSC)

MESSAGE_TARIF_x

où x est le caractère correspondant au type de recherche. Voir alpha1[44]

21,60 Message à afficher dans le cas où le type de recherche de tarif n'aboutit pas.

Vous devez mettre autant de lignes que de types de recherche de tarif contenus sur la configuration du tarif !

PARAM_CATEGORIE

Initialisation du champ tr_cat

Par défaut, le champ tr_cat est le champ cl_cat de la fiche client.

21,38 Nom de la table où récupérer l'information de catégorie de tarif. Tables possibles :

mat Fiche matière

fle_2 Fiche entête de devis multi-métiers

cdf1 Entête de commandes fournisseurs (pour vérifier sur le signataire de l'entête de commande d'achat (ef_signature) ou autre champs de la table)

USE : Ce mot-clé signifie que le champ tr_cat désigne le code utilisateur auquel sera appliqué le montant autorisé
Voir BLF A1[3,5] = 003

40,57 Nom de la zone où récupérer l'information de catégorie de tarif. Zones possibles :

Tous les champs de la table mat

Tous les champs de la table fle_2

Tous les champs de la table cdf1

RECHERCHE_TARIF

Initialisation du champ tr_tar

Par défaut, le code tarif (tr_tar) est initialisé avec le code tarif de l'entête de la commande client.

Il est possible d'initialiser ce champ en le recherchant dans la table tar0 avec comme critère le code client et le code CS1 à CS4 de la fiche matière ou de la ligne de commande.

21 F : on force le type de tarif.

22,24 Type de tarif à utiliser. Exemple : FCOM

21,38 Champ de recherche (exemple : mp_cs2)

La requête sera :

En dur :

"select tr_tar from tar0",

" where tr_soc = ",quote, societe, quote,

" and tr_anu = ", quote, "N", quote,

" and tr_datd <= ", quote, date_tarif, quote,

" and tr_datf >= ", quote, date_tarif, quote,

" and tr_binf <= ", qte," and tr_bsup >= ", qte,

" and (tr_mat is null or tr_mat = ", quote, " ", quote, ")"

+ selon paramétrage :

" and tr_cli = ", quote, tiers, quote,

" and tr_cat = ", quote, p_mp.mp_cs1, quote

S

2,60 Complément de requête sur la table tar0 avec utilisation de zones de tables préfixées par % et suffixées par un espace.

Exemple : %uc_qte_util

La zone %xxxx sera remplacée par sa valeur à l'exécution.

TR_VAL2_ALIMENTE

21,60 Quel champ tr_val2 doit-il alimenter dans cde2 ? (par défaut, aucun)

LC_PRXCLI alimente le champ lc_prxclitar

LC_PRX_REVIENT alimente lc_prx_revient


#CF TA1 Saisie des tarifs

Code TA1 ou tout autre code, mais pas #CF TAR réservé à la recherche des tarifs

Le paramètre de lancement des programmes concernés doit indiquer le type et le code de paramètre de la configuration de la saisie des tarifs.

Exemple

Programme | Nom | Param. de lancement | Type | Code
Saisie des articles | mat | #SA MAT | A3[26,28] = #CF | A3[29,31] = TA1

Valeur alpha 1

#CF TA1 A1[1,60]

tarif.hlp (nom du fichier d'aide)

Attention : bien indiquer tarif.hlp même si le nom du fichier d'aide est tarif.

Colonnes du tableau de saisie des tarifs

Dans les valeurs alpha 2 et 3, lorsque les choix O/N/I/M sont disponibles, ils ont la signification suivante :

O Oui

N Non

I Initialise le champ à vide pour obliger la saisie par l'interface quel que soit le code passé à la fonction de saisie simplifiée des tarifs

i Masquer la zone en l'initialisant avec la valeur nulle

M Masquer la colonne

Valeur alpha 2

#CF TA1 A2[1]

Saisie du code tarif (O/N/I/i/M, O par défaut) - Voir la signification ci-dessus)

#CF TA1 A2[2,4]

Code tarif par défaut

#CF TA1 A2[5]

Saisie obligatoire du code tarif (O/N, N par défaut)

#CF TA1 A2[6,7]

Inutilisés

#CF TA1 A2[8]

Saisie du code catégorie (O/N/I/i/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A2[9,11]

Type de paramètre de la zone Catégorie de tiers (tr_cat)

Mettre adr pour un code adresse de tiers au lieu d'un code paramètre

Celui-ci est utilisé si tar0 alpha3[1,3] n'est pas renseigné.

#CF TA1 A2[12,14]

Code catégorie par défaut

#CF TA1 A2[15]

Saisie obligatoire du code catégorie (O/N, N par défaut)

#CF TA1 A2[16,17]

Inutilisés

#CF TA1 A2[18]

Saisie du code article (O/N/I/i, O par défaut - Voir la signification ci-dessus)

Non masquable depuis la V. 4.1.41.2

#CF TA1 A2[19,33]

Code article par défaut

#CF TA1 A2[34]

Saisie obligatoire du code article (O/N, N par défaut)

#CF TA1 A2[35,36]

Inutilisés

#CF TA1 A2[37]

Saisi du code tiers (O/N/I/i/M, O par défaut - Voir la signification ci-dessus)

O La recherche se fait sur tous les clients (le code client est modifiable dans la saisie des tarifs).

N La recherche se fait sur le client paramétré sur #CF TA1 A2[38,43] ou sur le client principal de l'article (le code client n'est pas modifiable dans la saisie des tarifs).

C La recherche se fait sur le client de la commande (le code client est modifiable dans la saisie des tarifs).

B La recherche se fait sur le client de la commande et sur les tarifs sans code client (le code client est modifiable dans la saisie des tarifs).

#CF TA1 A2[38,43]

Code tiers par défaut

Si alpha2[37] = C ou B, alpha2[38] peut prendre l'une des 2 valeurs suivantes :

O Recherche avec tous les codes tarifs, même si le code tarif est renseigné sur l'entête de commande.

N La recherche s'effectue sur le code tarif de la commande.

Dans ce cas, alpha2[39,43] sont à blanc.

#CF TA1 A2[44]

Type de tiers : C Client, F Fournisseur, L Libre (par défaut)

#CF TA1 A2[45]

Saisie obligatoire du code tiers (O/N, N par défaut)

#CF TA1 A2[46]

Faut-il prendre le tiers principal par défaut si la saisie des tarifs est appelée à partir de la saisie des articles ?

N Non (par défaut)

C Client

F Fournisseur

#CF TA1 A2[47]

Inutilisé

#CF TA1 A2[48]

Saisie du code famille (O/N/I/i/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A2[49,51]

Code famille par défaut (sauf si car. 48 = I)

#CF TA1 A2[52]

Saisie obligatoire du code famille (O/N, N par défaut)

#CF TA1 A2[53,54]

Inutilisés

#CF TA1 A2[55]

Saisie du code sous-famille (O/N/I/i/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A2[56,58]

Code sous-famille par défaut (sauf si car. 55 = I)

#CF TA1 A2[59]

Saisie obligatoire du code sous-famille (O/N, N par défaut)

La saisie du code famille et du code sous-famille ne sera pas obligatoire si un article est saisi car elles dépendent automatiquement de celui-ci.

La suite de ce paramétrage est en alpha3[20].

Valeur alpha 3

#CF TA1 A3[1]

Saisie de la plage de quantités (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[2]

Contrôle sur la plage de quantités (O/N, N par défaut)

#CF TA1 A3[3,4]

Inutilisés

#CF TA1 A3[5)

Saisie de la plage de dates (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[6)

Contrôle sur la plage de dates (O/N, N par défaut)

#CF TA1 A3[7,8]

Inutilisés

#CF TA1 A3[9]

Saisie du type de valorisation (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[10]

Type de valorisation par défaut

V Valeur

A Ajout

C Coefficient

% Pourcentage

F Forfait - n'est pas utilisable dans la saisi en tableau

L Libre (par défaut) : dans ce cas, le caractère 9 est forcé à N.

#CF TA1 A3[11,12]

Inutilisés

#CF TA1 A3[13]

Faut-il forcer le jour de début et de fin des plages de dates (O/N, N par défaut)

#CF TA1 A3[14,15]

Uniquement si caractère 13 = O : Jour de la date de début (1 par défaut)

#CF TA1 A3[16,17]

Uniquement si caractère 13 = O : Jour de la date de fin. Mettre 31 pour fin de mois (31 par défaut)

#CF TA1 A3[18,19]

Inutilisés

#CF TA1 A3[20]

Saisie du code devise (O/N/I/M, O par défaut - Voir la signification ci-dessus)

ATTENTION : si so_options[34] = N, les caractères 20, 24 et 25 sont forcés à N, et le code devise par défaut est remis à blanc.

#CF TA1 A3[21,23]

Code devise par défaut

#CF TA1 A3[24]

Saisie obligatoire du code devise (O/N, N par défaut)

#CF TA1 A3[25]

Le code devise par défaut est celui du tiers saisi (O/N, N par défaut)

#CF TA1 A3[26]

Inutilisé

#CF TA1 A3[27]

Saisie du code unité (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[28,30]

Code unité final du prix de cession

#CF TA1 A3[31]

Saisie obligatoire du code unité (O/N, N par défaut)

#CF TA1 A3[32]

Le code unité par défaut est celui de l'article saisi

O On prend l'unité de vente

A On prend l'unité d'achat

N Pas d'unité par défaut (valeur par défaut)

#CF TA1 A3[33]

Affichage du prix au colis (O/N, N par défaut)

#CF TA1 A3[34]

Autorise le chargement des bornes et des dates par défaut (O/N, N par défaut).

#CF TA1 A3[35]

Saisie du prix net (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[36]

Code prix net par défaut

#CF TA1 A3[37]

Saisie du prix de revient (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[38]

Saisie du prix de revient obligatoire (O/N/Z, N par défaut)

Si Z, autorise la saisie d' un prix à 0.

#CF TA1 A3[39]

Saisie du commentaire (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[40]

Saisie du commentaire obligatoire (O/N, N par défaut)

#CF TA1 A3[41]

Saisie de la plage numérique (O/N/M , M par défaut)

#CF TA1 A3[42]

Contrôle de la plage numérique (O/N, N par défaut)

#CF TA1 A3[43]

Saisie du paramètre complémentaire (O/N/M , M par défaut)

#CF TA1 A3[44]

Contrôle du paramètre complémentaire (O/N, N par défaut)

#CF TA1 A3[45,47]

Type paramètre de la zone "Rubrique paramétrable" (tr_char).

Utilisé pour la visualisation de la table tar0 (te_num_table = 38

#CF TA1 A3[48]

Saisie de la partie fixe (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[49]

Contrôle de la partie fixe (O/N, N par défaut)

#CF TA1 A3[50]

Saisie du type feuille/bobine O/N/M , M par défaut - Voir la signification ci-dessus)

#CF TA1 A3[51]

Type feuille/bobine par défaut

#CF TA1 A3[52,54]

Code du paramètre complémentaire par défaut

#CF TA1 A3[55]

Saisie du code adresse tiers (O/N/I/M, O par défaut - Voir la signification ci-dessus)

#CF TA1 A3[56]

Saisie obligatoire du code adresse tiers (O/N, N par défaut)

#CF TA1 A3[57]

Saisie des tarifs en fonction du site de production

Tableau de bord du multisite

Le site de production par défaut est présent sur le code utilisateur (USE A3[10,12])

La gestion par site doit bien entendu être active (#CF SIT).

Remarque : Pour l'instant, cette possibilité est paramétrée en saisie simplifiée des tarifs.

La zone site (tr_site) est accessible en modification (O/N/I, O par défaut)

O La zone est accessible en modification, elle est initialisée par le site du USE

N La zone n'est pas accessible en modification, elle est initialisée par le site du USE.

I La zone doit être saisie, elle n'est pas initialisée.

Si on saisit un site, on a tous les tarifs du site saisi.
Si on ne saisit rien, on a tous les tarifs n'ayant pas de site.

B Site initialisé à blanc, modification impossible

M La zone est masquée

Si on ne gère pas le site (#CF SIT), on récupère tous les tarifs.

#CF TA1 A3[58]

La zone site (tr_site) est obligatoire (O/N, N par défaut)

Tableau de bord du multisite

#CF TA1 A3[59]

Activation de la saisie simplifiée des tarifs par plages de quantité (borne inférieure, borne supérieure et valeur du tarif) (O/N)

Voir une copie d'écran

O En création, ouverture de la fenêtre de saisie simplifiée des tarifs par plages de quantité en lieu et place du mode de saisie paramétré sur la saisie des articles en A3[6].

N Saisie de tarif selon mode de saisie paramétré sur la saisie des articles en A3[6].

Remarques

• Cette nouvelle saisie simplifiée des tarifs n'est accessible que dans le programme de saisie des articles (saisie normale et/ou simplifiée).

• Cette saisie n'est accessible qu'en création.
En modification, c'est la saisie par défaut qui est utilisée.

• Par défaut, la quantité minimum sur une nouvelle ligne est la quantité maximum de la ligne précédente + 1 (si cette dernière est saisie).

• Par défaut, la quantité maximum de la ligne précédente est la quantité minimum de la ligne en cours de création + 1

• Pour pouvoir accéder à cette nouvelle saisie, le code fournisseur chez le client (mat.mp_foucli) doit obligatoirement être saisi.

• Les valeurs par défaut sont initialisées via le paramétrage existant ici #CF/TA1).

Valeur alpha 4

Caractères 1,5]

Mot de passe

Notes

AFFICHE_LIBELLE

Affichage des libellés courts et long dans le nouvel écran de saisie des tarifs

21,60 nom_champ*C*L*TitreC*TitreL*

nom_champ = nom du champ de la table tar0 dont on souhaite afficher les libellés court et/ou long.
Au choix :

tr_binf

tr_bsup

tr_devise

tr_fam

tr_num_binf

tr_num_bsup

tr_sfm

tr_site

tr_tar

tr_unite

C = Affichage du libellé court ? O/N, N par défaut

L = Affichage du libellé long ? O/N, N par défaut

TitreC Titre de la colonne du libellé court

TitreL Titre de la colonne du libellé long

Si TitreC et/ou TitreL ne sont pas renseignés, un libellé par défaut sera affiché.

_BORNE_INF

Borne inférieure par défaut pour la quantité

21,33 numérique au format #########.### (9 dièses.3 dièses)

_BORNE_SUP

Borne supérieure par défaut pour la quantité

21,33 numérique au format #########.### (9 dièses.3 dièses)

_BORNE_NUM_INF

21,33 Borne numérique inférieure par défaut

_BORNE_NUM_SUP

21,33 Borne numérique supérieure par défaut

_CODES_CATEGORIES

21,23 Code catégorie pour lequel il faut créer un enregistrement de tarif (saisie simplifiée des tarifs par plages de quantités ou création automatique de tarif)

Cette note est utilisée entre autres par la note CREER_PARAMETRE_PP de la saisie simplifiée des articles, ou bien si A3[59] = O.

Une ligne de note par code catégorie : un enregistrement de tarif sera généré pour chaque code.

En général, la catégorie est un environnement pour les onduleurs. Par défaut, c'est une catégorie de tiers.

Le code doit correspond au type de paramètre défini en A2[9,11].

COL_DELAI_JOUR

21 Afficher la colonne Délai en nombre de jours (O/N, N par défaut)

COMPLEMT_TITRE_TAB

21,60 Complément au titre de la fenêtre de saisie des tarifs par tableau (1 seule ligne).

CTRL_LIB_ETR

21 Contrôle la présence d'un libellé étranger

N Pas de contrôle (par défaut)

B Bloquant

C Confirmation

W Warning

_DATE_DEBUT

21,30 Date de début par défaut au format JJ/MM/AAAA ou l'un des codes suivants :

JJ date du jour

DM début du mois prochain

FM fin du mois prochain

DA début de l'année prochaine

FA fin de l'année prochaine

_DATE_FIN

21,30 Date de fin par défaut. Même paramétrage que _DATE_DEBUT ci-dessus.

FORMAT_BORNES

21,60 Format numérique à appliquer aux zones tr_binf et tr_bsup (USING)

FORMAT_BORNES_NUM

21,60 Format numérique à appliquer aux zones tr_num_binf et tr_num_bsup (USING)

_SAISIE_TIERS_FINAL

21 Saisie du tiers final (O/N, N par défaut)

Voir aussi #CF TAR A2[28] pour la recherche de tarif prenant en compte le tiers final.

_VALEUR_FIXE

21,30 Valeur fixe par défaut

S

2, 60 Complément de requête sur la table tar0 avec utilisation de zones de tables préfixées par % et suffixées par un espace.

La zone %xxxx sera remplacée par sa valeur à l'exécution.

But : traitement du besoin matière (F8) : seuls les tarifs en vigueur sur la bonne quantité sont affichés

Exemple

S and tr_tar = 'A'

S and tr_anu = 'N'

S and tr_binf > (%uc_qte_util - (0.10*%uc_qte_util ))

S and tr_bsup > (%uc_qte_util + (0.20*%uc_qte_util ))

S and (tr_datd <= today

S and tr_datf >= today )

S order by tr_tar, tr_mat, tr_datd, tr_binf

Les valeurs suivantes peuvent être passées en paramètre lors de l'appel de la fonction de saisie des tarifs.

Dans ce cas, elles sont prioritaires, figées et non modifiables :

  • le code tarif

  • le type et le code de catégorie

  • le code article

  • le code client

  • le code famille

  • le code sous-famille

  • le type de valorisation

  • le code devise

  • le code unité


#CF TCD Copie des TSC

Paramétrage de la recopie des données contenues dans les TSC de la fiche client sur les TSC ou sur les LCO du devis.

Notes

RECOPIE_ZONE_TSC_CLI

Caractère 21 : * (astérisque)

Caractères 22 à 28 : TSC_CL_

Caractères 29 à 31 : Numéro de TSC de la fiche client

Caractère 33 : Zone de la table info_c à recopier

Caractère 34 : * (astérisque)

Caractères 35 à 37 : Destination : TSC ou LCO

Caractères 39 à 40 : DE (devis) ou EN (entité)

Caractères 42 à 44 : Numéro de la TSC ou LCO cible

Caractère 46 : Zone cible de la table info_c ou fle_com

Caractère 47 * (astérisque)


#CF TCL Transfert des clients calendriers vers la compta FABRICAL

#CF TCL Transfert des clients calendriers vers la compta

Notes

Séparateur : (2 points] à la fin de chaque zone.

Le libellé de la zone est figé.

Les codes correspondant au libellé sont figés.

Ainsi pour chaque ligne, il faut saisir un libellé (figé), puis [:], puis le code (figé) et enfin [:]

Ligne 1 | Libellé : code_societe Code : Il doit être égal à la valeur saisie dans la zone BD de la société. Il correspond aux caractères 1 à 4 du fichier SETEC_CLI_C (4 caractères).
Ligne 2 | Libellé : type_tiers Code : Code type tiers. Il correspond aux caractères 13 à 14 du fichier SETEC_CLI_C (2 caractères).
Ligne 3 | Libellé : pays_France Code : Code pays qui correspond à la France. Il correspond aux caractères 187 à 201 du fichier SETEC_CLI_C (15 caractères)
Ligne 4 | Libellé : pays_export Code : Code pays qui correspond à l'export. : Il correspond aux caractères 187 à 201 au fichier SETEC_CLI_C (15 caractères).
Ligne 5 | Libellé : cpte_centralisateur Code : Compte centralisateur. Il correspond aux caractères 202 à 209 du fichier SETEC_CLI_C (8 caractères)
Ligne 6 | Libellé : code_famille Code : Code famille. Il correspond aux caractères 210 à 211 du fichier SETEC_CLI_C_C (2 caractères)
Ligne 7 | Libellé : trait_devise Code : Traitement devise Fichier SETEC_CLI_C. Ce code correspond au caractère 212 (1 caractère)
Ligne 8 | Libellé : mode_reglement Code : Mode de règlement. Il correspond aux caractères 217 à 218 du fichier SETEC_CLI_C (2 caractères)
Ligne 9 | Libellé : nb_jours_reglement Code : Nombre de jours règlement. Il correspond aux caractères 219 à 221 du fichier SETEC_CLI_C (3 caractères)
Ligne 10 | Libellé : type_reglement Code : Type de règlement. Il correspond au caractère 222 du fichier SETEC_CLI_C (1 caractère)
Ligne 11 | Libellé : jour_reglement Code : Jour de règlement. Il correspond aux caractères 223 à 224 du fichier SETEC_CLI_C (2 caractères)
Ligne 12 | Libellé : releve Code : Relevé. Il correspond au caractère 225 du fichier SETEC_CLI_C (1 caractère)
Ligne 13 | Libellé : relance Code : Relance. Il correspond au caractère 226 du fichier SETEC_CLI_C (1 caractère)
Ligne 14 | Libellé : tva_exo Code : TVA exo. Il correspond au caractère 227 du fichier SETEC_CLI_C (1 caractère)
Ligne 15 | Libellé : tva_encaissement Code : TVA à encaissement. Il correspond au caractère 227 du fichier SETEC_CLI_C (1 caractère)
Ligne 16 | Libellé : trait_echeance Code : Traitement échéance. Il correspond au caractère 228 du fichier SETEC_CLI_C (1 caractère)
Ligne 17 | Libellé : fermeture Code : Fermeture. Il correspond au caractère 229 du fichier SETEC_CLI_C (1 caractère)
Ligne 18 | Libellé : trait_honoraires Code : Traitement des honoraires. Il correspond au caractère 244 du fichier SETEC_CLI_C (1 caractère)
Ligne 19 | Libellé : tiers_payant Code : Tiers payant. Il correspond aux caractères 245 à 252 du fichier SETEC_CLI_C (8 caractères)


#CF TDC Transfert du devis en commande

Le type et le code de ce paramètre sont définis dans la note PARAM_GENERER_CDE

- du paramètre TPR (en priorité)

- du devis standard

REMARQUE

Le type de transfert en commande (Global / Par référence) conditionne la génération des commandes.

Si global, alors le produit est pris sur le devis (L2_produit) et non sur la nomenclature ou les références.

Gestion des commandes de fabrication par référence

Transfert en commande de plusieurs devis

Valeurs numériques

#CF TDC N1 | Numéro du compteur (nul par défaut). Il faut créer des compteurs par défaut si on utilise les numéros de compteur. Le compteur numéro 9999 est réservé à une numérotation particulière. Le folioteur sur 4 après l'année et le mois n'est remis à zéro qu'en début d'année.
#CF TDC N2 | non utilisée

Valeur alpha 1

#CF TDC A1[1]

Initialisation du représentant

O Le représentant est toujours pris sur la fiche client

N Le représentant est pris sur le devis, puis sur le client s'il n'est pas saisi (par défaut).

#CF TDC A1[2]

Vérification du code client

O Afficher une demande de confirmation si le client du devis est différent de celui du produit

N Aucune vérification (par défaut)

#CF TDC A1[3]

Accès à la saisie du suivi des dates dans le transfert du devis en commande (F16)

O Accès à la saisie du suivi des dates

N Pas d'accès à la saisie du suivi des dates

R Accès à la saisie du suivi des dates avec recopie des dates saisies dans le devis (Touche F17 sur l'entête)

#CF TDC A1[4]

Mise à jour de la famille et sous-famille de la ligne de commande

O Traitement spécial pour les lignes facturables uniquement.

Prendre la famille et la sous-famille de la 2ème ligne de commande si FB1, ou de la 1ère ligne de commande si FB2

N Pas de traitement particulier (par défaut)

#CF TDC A1[5]

Génération automatique du dossier à la validation

O Génération automatique

N Pas de génération en automatique (par défaut)

I Edition interdite (pas d'accès à la zone d'édition "Géné.Dos")

#CF TDC A1[6]

Mise à jour du correspondant

O Mise à jour du correspondant de la commande avec celui saisi sur le devis

N Pas d'initialisation du correspondant (par défaut)

#CF TDC A1[7]

Réservé

#CF TDC A1[8]

Mise à jour à partir des dates de la revue de contrat saisies sur la première ligne de commande (O/N, N par défaut)

#CF TDC A1[9]

Création automatique de la fiche de fabrication à la validation

O Création

N Pas de création

F Récupération des informations technique du dernier devis de fabrication

Création d'un nouveau devis avec le même compteur que la commande générée.

Attention, pour éviter les doublons entre le devis source et le nouveau devis cible créé, il faut renseigner A2[38] du devis standard (exemple : D)

#CF TDC A1[10]

Mise à jour de la référence de commande

O Mise à jour par le numéro de la commande

N Pas de mise à jour (par défaut)

#CF TDC A1[11]

Affichage de l'adresse principale du client lors de la recherche de l'adresse secondaire (O/N, O par défaut)

#CF TDC A1[12]

Réactualisation du devis lors de la création automatique de la fiche de fabrication [voir #CF TDC A1[9] (O/N, N par défaut)

#CF TDC A1[13]

Edition automatique de l'accusé de réception

O Génération automatique

N Pas d'édition en automatique (par défaut)

I Edition interdite (pas d'accès à la zone d'édition "Edit.ACR")

#CF TDC A1[14]

Prise en compte de la remise client (O/N, N par défaut)

#CF TDC A1[15]

Prise en compte de l'escompte client (O/N, N par défaut)

#CF TDC A1[16]

Récupération de la devise sur la fiche client

O La devise est toujours prise sur la fiche client

N La devise est prise sur le devis (par défaut)

#CF TDC A1[17]

Génération automatique des besoins matières (O/N, N par défaut)

#CF TDC A1[18]

Transfert du tableau des marges (O/N, N par défaut)

#CF TDC A1[19]

Numérotation annuelle pour la création du numéro de commande (O/N, N par défaut)

#CF TDC A1[20]

Mise à jour des adresses secondaires d'accusé de réception et de livraison par celles saisies dans le devis

(O/N, N par défaut)

#CF TDC A1[21]

Mise à jour de l'adresse secondaire de facturation par celle saisie dans le devis (O/N, N par défaut)

#CF TDC A1[22]

Choix des sous-devis à transférer (O/N, N par défaut)

#CF TDC A1[23]

Type d'aide pour la saisie des références

1 Numéro de commande (valeur par défaut)

2 Client - Nombre de commandes

3 Client - Millésime de la commande - Nombre de commandes

#CF TDC A1[24]

Retransfert d'un devis vers une nouvelle commande - Ne pas confondre avec le A1[50] !

O Retransfert toujours autorisé

N Retransfert jamais autorisé

C Demande de confirmation (par défaut)

#CF TDC A1[25]

Accès à la saisie de commande en fin de transfert

O Ouverture systématique de la saisie de commande

N Jamais d'ouverture

C Demande de confirmation (par défaut)

Pour le devis standard, l'accès à la saisie de commande après un transfert de devis est conditionnée par USE A2[43].

#CF TDC A1[26]

Mode de remplissage de la zone de transport

1 Dates de ligne de commande mises à jour avec les dates saisies sur le devis. Le code transporteur et le type de port sont mis à jour avec les informations saisies sur le devis

2 Réservé

#CF TDC A1[27]

Mise à jour des cadencements de livraison : Code de validation d'administration des ventes

O Validation (par défaut)

N Aucune validation

#CF TDC A1[28]

Mise à jour des cadencements de livraison : Code de validation de la production

O Validation (par défaut)

N Aucune validation

#CF TDC A1[29]

Mise à jour des cadencements de livraison : Code de validation de la logistique

O Validation (par défaut)

N Aucune validation

#CF TDC A1[30]

Méthode de remplissage des prix de références multiples lors du transfert de devis en commande

O Réinitialisation des prix négociés (devis et références multiples) par le prix remis du devis

S Réinitialisation du prix remis des références multiples par le prix remis du devis, et du prix négocié des références multiples par le prix négocié du devis

M Si le prix remis de la référence multiple est à zéro : réinitialisation par le prix remis du devis.
Si le prix négocié de la référence multiple est à zéro : réinitialisation par le prix négocié du devis.

N Aucune réinitialisation des prix (par défaut)

#CF TDC A1[31]

Génération du cadencement avec le tableau du transport du devis (Control-B) (O/N, O par défaut)

#CF TDC A1[32,34]

Code de qualification du cadencement

#CF TDC A1[35]

Prise en compte des libellés spécifiques d'article

O Le libellé d'une nouvelle ligne de commande sera le libellé spécifique de l'article.

N Le libellé d'une nouvelle ligne de commande sera le libellé de l'article (par défaut).

#CF TDC A1[36]

Edition automatique du dossier à la validation

O Edition automatique

N Pas d'édition en automatique (par défaut)

I Edition interdite (pas d'accès à la zone d'édition "Edit.Dos")

#CF TDC A1[37]

Edition automatique du document de pré-commande

O Génération automatique

N Pas d'édition en automatique (par défaut)

I Edition interdite (pas d'accès à la zone d'édition "Edit.Pré")

#CF TDC A1[38]

Transfert des lignes de commande non valorisées2

O Les lignes non valorisées sont toujours transférées (par défaut)

N Les lignes non valorisées ne sont jamais transférées

C Les lignes non valorisées sont transférées sur demande de confirmation

#CF TDC A1[39]

Recopie de commande client vers une autre société

N Pas de recopie (Valeur par défaut)

O Recopie

Voir la note RECOPIE_CDE_CLI_SOC

#CF TDC A1[40]

Vérification et/ou génération des codes papiers génériques saisis sur les entités, dans le cas de la génération du dossier

N Aucun contrôle (par défaut)

C Dès qu'un code papier générique est trouvé sur une entité, une fenêtre de confirmation propose de le générer.

G Dès qu'un code papier générique est trouvé sur une entité, celui-ci est généré automatiquement.

B Dès qu'un code papier générique est trouvé sur une entité, un message d'erreur apparaît et la création de la commande est annulée.

Remarque : Ce paramétrage n'est valable que si le dossier est généré ou édité après la validation de la création de commande

#CF TDC A1[41]

Réinitialisation de la date de livraison du devis (et des dates de la ligne de commande)

N Pas de réinitialisation (par défaut)

O Réinitialisation de la date de livraison à la date du jour si celle-ci n'est pas renseignée

I Réinitialisation de la date de livraison à la date du jour si celle-ci est inférieure à la date du jour ou non renseignée

S Réinitialisation de la date de livraison à la date du jour si celle-ci n'est pas renseignée et saisie obligatoire de la date de livraison globale si celle-ci est inférieure ou égale à la date du jour

#CF TDC A1[42]

Générer les lignes de commande à partir de la nomenclature (O/N, N par défaut)

#CF TDC A1[43,45]

Type de devis de la fiche de fabrication

Si celui-ci n'est pas paramétré, c'est le type du devis en cours qui sera pris en compte.

#CF TDC A1[46]

Accès au champ de génération de cadencement de fabrication et valeur par défaut

Voir la fiche d'installation

O Le champ génération de cadencement de fabrication est accessible et coché par défaut.

N Le champ génération de cadencement de fabrication est accessible et décoché par défaut (valeur par défaut)

I Le champ génération de cadencement de fabrication n'est pas accessible (aucun enregistrement de cadencement de fabrication n'est créé).

Seule la valeur I permet de générer les mouvements de stock lors du transfert du devis en commande

#CF TDC A1[47,49]

Code tarif du devis de la fiche de fabrication

Si celui-ci n'est pas paramétré, c'est le code tarif du devis en cours qui sera pris en compte.

#CF TDC A1[50]

Retransfert d'un devis vers le même numéro de commande si celle-ci est annulée

O autorisé

N non autorisé (par défaut)

Ne pas confondre avec le A1[24] !

Valeur alpha 2

#CF TDC A2[1,60]

Types des notes à transférer du devis vers la commande (Entête de devis, Références multiples)

On définit sur 6 caractères le transfert de notes à effectuer.

Les 3 premiers caractères indiquent le type de note du devis à transférer, les trois caractères suivants indiquent le type de note de la commande (ou ligne) où sont transférées les notes.

S'il y a plusieurs types à transférer, on définit tous les 6 caractères les types de notes à transférer.

Valeur alpha 3

#CF TDC A3[1,6] | Type et code du paramètre de lancement de l'édition des accusés de réception
#CF TDC A3[7,9] | Type de commande par défaut
#CF TDC A3[10,12] | Etat du devis après son transfert en commande (Code paramètre ETD) Voir aussi #CF TDC A4[45,47]
#CF TDC A3[13,18] | Type et code du paramètre de lancement de la visualisation des stocks (Control-P)
#CF TDC A3[19,21] | Type de note de commande/ligne pour la saisie des notes (Control-N)
#CF TDC A3[22,23] | Racine du code TSC de revue de contrat (par défaut : RC)
#CF TDC A3[24,29] | Type et code du paramètre de lancement de la saisie des clients
#CF TDC A3[30,35] | Type et code du paramètre de lancement de la génération de dossier
#CF TDC A3[36,41] | Type et code du paramètre de lancement de la régénération de dossier
#CF TDC A3[42,47] | Type et code du paramètre de lancement de l'édition des dossiers
#CF TDC A3[48,53] | Type et code du paramètre de lancement de l'édition des pré-commandes
#CF TDC A3[54,56] | Concerne les cadencements de fabrication Voir la fiche d'installation Type de cadencement de fabrication par défaut pour les articles non montés pour la création des lignes lorsque la commande n'est pas cadencée en fabrication
#CF TDC A3[57,59] | Concerne les cadencements de fabrication Voir la fiche d'installation Type de cadencement de fabrication par défaut pour les articles montés pour la création des lignes lorsque la commande n'est pas cadencée en fabrication
#CF TDC A3[60] | Recalcul automatique avant le transfert de devis en commande T Toujours C Sur confirmation N Jamais Remarque : Le transfert en commande est annulé si des erreurs surviennent du calcul du ou des sous-devis à transférer.

Valeur alpha 4

#CF TDC A4[1]

Gestion des excédents de stocks (O/N, N par défaut)

#CF TDC A4[2]

Affichage d'une demande de confirmation permettant de détruire les excédents de stocks trouvés (O/N, N par défaut)

#CF TDC A4[3]

Lors de la réaffectation des stocks, il est possible de réaffecter le lot du mouvement de transfert en entrée du lieu à transférer

Nouveau lot : numéro commande, "-", ligne commande (O/N, N par défaut)

#CF TDC A4[4]

L'état des mouvements de transfert des réaffectations des stocks non vendables est mis à N au lieu de 2 (2 étant la valeur par défaut) (O/N, N par défaut)

#CF TDC A4[5,7]

Lieu de rangement 1 où l'on effectue la recherche de stock.

L'utilisation du caractère * permet d'élargir la recherche à un début de code lieu

Exemple : U* pour sélectionner tous les lieux de rangement commençant par U

#CF TDC A4[8,10]

Type de mouvement de transfert de stock en entrée pour les stocks à retraiter

#CF TDC A4[11,13]

Type de mouvement de transfert de stock en sortie pour les stocks à retraiter

#CF TDC A4[14,16]

Type de notes à générer pour les excédents à retraiter (voir les notes NOTES_EXCEDENT_ARE ci-dessous)

#CF TDC A4[17,19]

Type de mouvement de transfert de stock en entrée pour les stocks à détruire

#CF TDC A4[20,22]

Type de mouvement de transfert de stock en sortie pour les stocks à détruire

#CF TDC A4[23,25]

Type de notes à générer pour les excédents à détruire (voir les notes NOTES_EXCEDENT_ADE ci-dessous)

#CF TDC A4[26,31]

Type et code du paramètre de la configuration d'intégration des données des produits dans le devis de fabrication

#CF TDC A4[32]

Alimentation du taux de commission par celui saisie sur le devis (zone fle_2.l2_c_ma) et non sur le représentant (O/N, N par défaut)

#CF TDC A4[33,38]

Type et code du paramètre de la configuration d'intégration des données des produits dans les entités du devis de fabrication

#CF TDC A4[39]

Remplissage automatique de la zone libellé de commande (cde1.ec_texte) avec le texte Suivant notre devis XXXXXXXX-YYY

(où XXXXXXXX représente le numéro de devis en cours de transfert et YYY le numéro de sous-devis) (O/N, O par défaut)

#CF TDC A4[40]

Recalcul de la date de livraison proposée à partir de la date de départ lorsque celle-ci est modifiée (O/N, O par défaut)

#CF TDC A4[41]

Génération des besoins matières hors transfert du devis en commande

La nouvelle gestion des besoins doit être activée (#CF ATL A4[44] = O).

#CF TDC A4[42]

Mode d'initialisation de la tolérance de livraison en génération de commande

D Calcul par rapport à la tolérance saisie dans l'entête du devis [Valeur par défaut

C La tolérance de livraison est prise sur l'adresse principale du client

L La tolérance de livraison est prise sur l'adresse de livraison de la commande

#CF TDC A4[43]

Lancement de la génération et/ou régénération des produits avant le transfert en commande

G En génération uniquement.
La génération des produits est exécutée uniquement si tous les articles utilisés pour le transfert en commande sont génériques.

R En régénération uniquement.
La régénération des produits est exécutée uniquement si tous les articles utilisés pour le transfert en commande ont déjà fait l'objet d'une génération.

2 Lancement de la génération/régénération systématique.
Si tous les produits ont été générés, la régénération est exécutée, sinon on exécute la génération.

N Pas d'exécution de la génération/régénération des produits (par défaut).

#CF TDC A4[44]

Affichage des lignes de frais sans montant prix de vente à zéro) (O/N, O par défaut)

#CF TDC A4[45,47]

Etat du devis après la génération des besoins (Code paramètre ETD, normalement besoin généré)

Voir aussi #CF TDC A3[10,12]

#CF TDC A4[48]

Autoriser le transfert du devis des produits génériques en commande (O/N, N par défaut)

#CF TDC A4[49]

Mise à jour de la commande depuis le devis commercial (O/N, N par défaut)

Lors de la modification d'un devis déjà transféré en commande,ce nouveau paramétrage permet de mettre à jour la commande depuis le devis commercial au lieu du dossier de fabrication.

#CF TDC A4[50]

Affichage de l'écran de transfert en commande

Plus d'info : voir Transfert en commande de plusieurs devis

O L'écran est affiché, l'utilisateur doit le valider pour générer la commande (par défaut).

C L'écran n'est pas affiché, l'utilisateur doit valider un message de confirmation lui indiquant le numéro de commande qui va être généré.

N L'écran n'est pas affiché, la commande est directement générée.

#CF TDC A4[51]

Type de transfert de devis

C Transfert en commande (par défaut)

O Transfert en offre de prix

Permet de transférer les devis multi-métiers en offre de prix.

Remarque : Le fonctionnement du transfert reste inchangé, il ne s'agit ici que de changer les libellés du transfert en commande.

#CF TDC A4[52]

L I B R E

#CF TDC A4[53]

L I B R E

#CF TDC A4[54]

L I B R E

#CF TDC A4[55]

L I B R E

#CF TDC A4[56]

L I B R E

#CF TDC A4[57]

L I B R E

#CF TDC A4[58]

L I B R E

#CF TDC A4[59]

L I B R E

#CF TDC A4[60]

Nombre de décimales et séparateur à afficher pour les quantités (de 0 à 3) - 3 par défaut

Utilisé par le devis multi-métiers et la visualisation des devis.

0 pas de décimale (ex : 5444333222111)

1 1 décimale (ex : 44333222111,9)

2 2 décimales (ex : 4333222111,99)

3 3 décimales (par défaut) (ex : 333222111,999)

A 0 décimale avec séparateur (ex : 4 333 222 111)

B 1 décimale avec séparateur (ex : 333 222 111,9)

C 2 décimales avec séparateur (ex : 33 222 111,99)

D 3 décimales avec séparateur (ex : 3 222 111,999)

Notes triées

BLOCAGE_SDEVIS_FAB

21,23 Code blocage du sous-devis de fabrication à mettre en place si un produit est lié à une entité inexistante lors du transfert en commande.

Correspond à un paramètre de type BLD

Lors de la génération du sous-devis de fabrication au transfert du devis en commande, permet de bloquer le sous-devis de fabrication si un produit d'entité est lié à une entité de fabrication qui n'existe plus (produit lié à une entité ayant fait l'objet d'une suppression lors d'une demande de modification de commande, par exemple).

Dans ce cas, les données de fabrication de l'entité sont reprises du devis commercial (on met à jour le devis/sous-devis/entité du produit avec le numéro de devis/sous-devis/entité commercial en cours de transfert) et un code blocage est créé sur le sous-devis de fabrication.

CDE_PAR_REFERENCE

Gestion des commandes de fabrication par référence

21 Gestion des commandes de fabrication par référence activée (O/N, N par défaut)

22,24 Type de commande de fabrication

25,29 Numéro de compteur pour les commandes de fabrication (par défaut : le même que celui pour la commande commerciale)

30,32 Type de commande de frais

Remarques

" Si le type de commande frais n'est pas précisé, les lignes de frais seront toujours ajoutées à la fin de la première commande de fabrication.

" La création d'une commande de frais doit être précisée sur chaque client (TSC/#FR, voir ci-dessous).
Par défaut, les lignes de frais sont ajoutées à la fin de la première commande de fabrication.

33,37 Numéro de compteur pour les commandes de frais (par défaut : le même que celui pour la commande commerciale)

38 Réinitialisation du type et référence de liaison sur les commandes de fabrication et commandes de frais (O/N, N par défaut)

CODE_CLIENT_FINAL

Ajout et contrôle de saisie du champ ec_cli_final

Par défaut, lors du transfert du devis en commande, ce champ n'est pas affiché.

N Pas de contrôle

B Contrôle Bloquant

W Contrôle non bloquant

Voir aussi la note COMPLEMENT_CODE dans le #CF CDE.

CREER_LIGNES_CDE

Il est possible de rajouter des lignes supplémentaires en plus des références du devis.

21,23 Code NDF du frais

24,41 Nom de la zone de la table fle_2 utilisée pour alimenter le prix de vente de la ligne de commande (lc_prx)

42,59 Nom de la zone de la table fle_frais utilisée pour alimenter le prix de cession de la ligne de commande (lc_prx_cessi)

MAJ_LC_PRX_RVT_INDIC

21,22 Numéro de formule du tableau des indicateurs du récapitulatif des coûts (caractères 12 à 13 des notes commençant par _FOR_INDIC du paramètre de lancement du devis standard)

Exemple

MAJ_LC_PRX_RVT_INDIC18

MODE_EXO_ADR_LIV

21 Mode d'exonération de la commande à récupérer sur l'adresse de livraison (O/N, N par défaut)

NOTES_EXCEDENTS_ADE

Ligne de note à insérer lors du traitement de stock à détruire (Note sur ligne de commande)

NOTES_EXCEDENTS_ARE

21,60 Ligne de note à insérer lors du traitement de stock à retraiter (Note sur ligne de commande)

PARAM_LCT_VISU_BES

21,26 Type et code du paramètre de lancement de la visualisation des besoins matière

Dans la visualisation des besoins matière, voir la note XCLI1.

Cette note existe aussi dans la saisie des commandes clients.

Cette visualisation ne sera traitée que s'il existe des besoins matière pour cette commande. : voir la note _SUP_REQ_VISU_BES

PRORAT_PRX_RVT_INDIC

21 Mode de proratisation du prix de revient

0 Aucune proratisation (par défaut)

1 Proratisation en fonction de la quantité commandée

2 Proratisation en fonction de la quantité lancée

3 Proratisation en fonction du prix de la ligne de commande (voir ci-dessus)

La formule de calcul du prix de revient est : PR = PR * (PV / PT)

avec

PR Prix de revient de la ligne de commande

PV Prix de vente de la ligne de commande

PT Somme des prix des lignes de la commande (hors lignes de frais ou transport)

Voir aussi la note MAJ_LC_PRX_RVT_INDIC

RECOPIE_CDE_CLI_SOC

21,26 Type et code du paramètre de la configuration de la recopie de commande client vers une autre société

Exemple

RECOPIE_CDE_CLI_SOC #CFRCS

Voir A1[39]

RUN_SAISIE_CDE_

16,18 TYC de commande

21,26 Type et code du paramètre de lancement de la saisie de commande pour le TYC

27 Afficher l'écran d'entête de commande (O/N, O par défaut)

Plus d'info : voir Transfert en commande de plusieurs devis

STOCKER_ELEMENT_PRU

Stocker les éléments de calcul du PRU (indicateurs) dans la table d'historisation des prix de revient

21 Type d'enregistrement d'historisation pour les indicateurs a à o

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

22 Type d'enregistrement d'historisation pour les indicateurs p à D

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

23 Type d'enregistrement d'historisation pour les indicateurs E à S

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

24 Type d'enregistrement d'historisation pour les indicateurs T à Z

Remarque : La présence de ce type conditionne la création de l'enregistrement d'historisation correspondant.

_SUP_REQ_VISU_BES

21,60 Complément de requête pour la recherche d'existence de besoins matières.

Cette note existe aussi dans la saisie des commandes clients.

Exemple

_SUP_REQ_VISU_BES and uc_etat = 'A'

Voir la note PARAM_LCT_VISU_BES.

TCF_DEFAUT_TPR_ENS

Gestion des commandes de fabrication par référence

21,23 Type de processus devis

24,59 Liste des types de cadencements de fabrication à créer par défaut pour les ensembles et pour ce type de processus

12 codes de 3 caractères chacun.

TCF_DEFAUT_TPR_PS

Gestion des commandes de fabrication par référence

21,23 Type de processus devis

24,59 Liste des types de cadencements de fabrication à créer par défaut pour les produits simples et pour ce type de processus

12 codes de 3 caractères chacun.

TITRE_ENTETE_LIBELLE

Titre de la zone Libellé de commande (zone cde1.ec_texte) à afficher dans l'écran du transfert de devis en commande

Par défaut : Libellé commande

TITRE_SAI_NOTES_CDE

21,60 Titre de l'écran de saisie des notes dans le transfert de devis en commande

TYC_DEFAUT_L2_ZPAR2

Pour renseigner le type de commande (TYC) selon la zone paramétrée 2 saisie dans le devis

21,23 Code saisi dans la zone paramétrée 2

24,26 Type de commande associé à la valeur de la zone paramétrée n°2

27,31 Numéro de compteur associé au type de commande (TYC)

Par défaut : Le numéro de compteur par défaut est celui saisi dans la zone numérique 1.

Remarque : Ce numéro correspond à la zone numérique 1 du paramètre de lancement de la saisie des commandes associée à ce TYC

Voir la note TYP_ZONE_PAR_CODE_2 dans le TPR

TYPE_NOTES_EXCEDENT

21,23 Type de notes pour la gestion des stocks excédentaires

Si un devis a déjà été transféré en commande et que le stock produit a été partiellement livré et soldé, nous sommes en présence d'un stock excédentaire.

Si l'on transfère à nouveau ce devis en commande, un message apparaît pour demander à l'utilisateur s'il souhaite utiliser ce stock excédentaire.

Si l'utilisateur choisit d'utiliser ce stock excédentaire, ce paramètre permet de créer automatiquement une note sur le dossier de fabrication pour indiquer à l'utilisateur qu'il faut retraiter ce stock excédentaire.

Ce paramètre était initialement dans le paramètre de lancement du devis multi-métiers, en A3[10,14].

VISU_CDE_RATTACHEES

Gestion des commandes de fabrication par référence

21,26 Type et code du paramètre de visualisation des commandes rattachées

(visualisation des commandes de fabrication et commandes de frais)

Z

Affecter des valeurs aux champs de ligne de commande client générés à partir de valeurs d'autres tables.

2,20 Nom du champ à affecter, à prendre dans la table cde2.

21 [espace]

22 Caractère permettant d'affecter le champ de façon différente :

C Valeur constante. Doit être indiquée à partir du caractère 23

Z Valeur provenant d'une zone

Le nom de la table est paramétré en 23,32

Le nom du champ est paramétré en 33,47

23,60 Valeur à affecter au champ défini en 2,20

23,32 Nom de la table

33,47 Nom du champ dans la table

On affecte la valeur du champ de cette table au champ défini en 2,20.

Exemples

1 2 3 4

123456798012345679801234567980123456798012

Zlc_p1 CTES

Zlc_p2 Zfle_2 l2_bareme

La zone lc_p1 sera renseignée par une valeur fixe : TES.

La zone lc_p2 sera renseignée par la valeur contenue dans l2_bareme de fle_2.

Gestion des commandes de fabrication par référence

Permet, lors du transfert de devis en commande, de créer des commandes de fabrication par référence.

Remarques :

  • Une commande de fabrication est créée pour chaque couple ligne de commande commerciale/amalgame (entité/affiche)

  • Les frais peuvent faire l'objet d'une commande de frais indépendante ou ajoutés à la fin de la première commande de fabrication (par défaut)

  • Les commandes de fabrication sont créées après la validation de la saisie de la commande commerciale.
    Les cadencements de fabrication sont saisis sur cette dernière et reportés sur les commandes de fabrication.

  • Il est possible de lancer automatiquement une visualisation des commandes de fabrication et/ou commandes de frais après leur création.

  • La création par regroupement et la génération des cadencements de fabrication se fera sur les commandes de fabrication : les actions de regroupement et de génération seront désactivées sur la commande commerciale via un paramétrage sur son type de commande.

  • Il est possible de créer des cadencements de fabrication par défaut par type de processus devis.

  • Les modifications doivent être effectuées sur les commandes de fabrication.
    A partir du moment où des commande de fabrication par référence existent, la commande commerciale n'est plus modifiable.

Paramétrage à mettre en oeuvre

#CF TDC, notes (voir ci-dessus)

CDE_PAR_REFERENCE

TCF_DEFAUT_TPR_ENS

TCF_DEFAUT_TPR_PS

VISU_CDE_RATTACHEES

TSC #FR Commande de fabrication par référence sur les clients

TYC note CDE_PAR_REFERENCE Activation de la gestion des commandes de fabrication par référence

Voir aussi le paramétrage complémentaire dans v_cdem :

Notes AUTORISE_TOUCHE_F56 et RUN_VISU_CDE_RAT

Permet de visualiser les commandes rattachées à la commande en cours.

  • L'action se nomme Commandes rattachées (F56).

  • La sélection se fait à partir des zones de rattachement, soit au niveau de l'entête (cde1.ec_cderat), soit au niveau des lignes de commandes (cde2.lc_cderat, cde2.lc_lcderat)

  • La commande en cours ne fait pas partie de la sélection (dans le cas des commandes rattachées à elles-mêmes)

  • Attention à ne pas confondre avec l'action Commandes associées (F28), qui liste les commandes associées à un contrat
    (via la référence de liaison : cde1.ec_ref_liaison)

Notes AUTORISE_TOUCHE_F57, PAR_LCT_GEN_CAD_FAB, _SUP_REQ_ES_CAD_FAB et _SUP_REQ_SS_CAD_FAB

Permet d'accéder à la saisie des cadencements de fabrication (en modification ou en consultation seule) de la ligne de commande en cours.

  • L'action se nomme Cadencements de fabrication (F57).

Transfert en commande de plusieurs devis

Dans la visualisation des devis multi-métiers, permet de transférer plusieurs devis dans une seule commande.

Dans le transfert du devis en commande :

• Permet de cacher l'écran de transfert en commande (génération batch de la commande)

• Permet de cacher l'écran d'entête de commande (accès direct à la saisie des lignes de la commande)

Remarques :

• Ce fonctionnement utilise la sélection multiple standard (note _CSEL sur le paramètre de lancement)

• Les devis sélectionnés doivent avoir le même code client pour pouvoir être transférés dans une même commande.

Paramétrage

cde option Osl

#CF TDC A4[50]

#CF TDC note RUN_SAISIE_CDE_

QA A1[38]


#CF TFA Transfert des factures d'achat vers la compta FABRICAL

#CF TFA Transfert des factures d'achat vers la compta

Notes

Séparateur : (2 points] à la fin de chaque zone.

Le libellé de la zone est figé.

Les codes correspondant au libellé sont figés.

Ainsi pour chaque ligne, il faut saisir un libellé (figé), puis [:], puis le code (figé) et enfin [:]

Ligne 1 | Libellé : code_societe Code : Il doit être égal à la valeur saisie dans la zone BD de la société. Il correspond aux caractères 2 à 5 du fichier SETEC_FAL (4 caractères)
Ligne 2 | Libellé : code_division Code : Code division. Il correspond aux caractères 6 à 8 du fichier SETEC_FAL (3 caractères)
Ligne 3 | Libellé : date_echeance Code : Date échéance sous la forme jj/mm/aa. Elle correspond aux caractères 37 à 44 du fichier SETEC_FAL (8 caractères)
Ligne 4 | Libellé : code_journal Code : Code journal. Il correspond aux caractères 45 à 46 du fichier SETEC_FAL (2 caractères)
Ligne 5 | Libellé : code_facture Code : Code facture. Il correspond au caractère 55 du fichier SETEC_FAL (1 caractère)
Ligne 6 | Libellé : code_avoir Code : Code avoir. Il correspond au caractère 55 du fichier SETEC_FAL (1 caractère)
Ligne 7 | Libellé : lib_piece_facture Code : Libellé pièce facture. Il correspond aux caractères 56 à 79 du fichier SETEC_FAL (24 caractères)
Ligne 8 | Libellé : lib_piece_avoir Code : Libellé pièce avoir. Il correspond aux caractères 56 à 79 du fichier SETEC_FAL (24 caractères)
Ligne 9 | Libellé : lib_ligne_facture Code : Libellé ligne facture. Il correspond aux caractères 80 à 99 du fichier SETEC_FAL (20 caractères)
Ligne 10 | Libellé : lib_ligne_avoir Code : Libellé ligne avoir. Il correspond aux caractères 80 à 99 du fichier SETEC_FAL (20 caractères)
Ligne 11 | Libellé : sens_ecriture_debit Code : Sens de l'écriture égal au débit. Il correspond aux caractères 116 à 117 du fichier SETEC_FAL (2 caractères)
Ligne 12 | Libellé : sens_ecriture_credit Code : Sens de l'écriture égal au crédit. Il correspond aux caractères 116 à 117 du fichier SETEC_FAL (2 caractères)


#CF TFB Transfert des bons de réception

#CF TFB Transfert des bons de réception fournisseurs vers la comptabilité Sage 100

Ce paramètre est opérationnel à partir de la V. 4.1.41.3

Il est utilisé dans le cadre du transfert des factures et des bons de réception fournisseurs non rapprochés en comptabilité Sage ligne 1000

Notes

TYPE_LIB_PIECE

21 Type de libellé de la pièce

0 (ou vide) (par défaut) nom du fournisseur – référence de la facture fournisseur
ou si option Oml (dans tr_fac_fou) alors nom du fournisseur – numéro de facture Volume

1 code fournisseur – nom du fournisseur – numéro de facture

2 Numéro commande achat – code fournisseur – nom du fournisseur

Voir aussi

tr_fac_fou | Option Otb et note SUP_REQ_B_REC_RET
CS1 CS2 CS3 CS4 | Note COMPTE_BRC
SFM | Note COMPTE_BRC et A3[1,8]
TVA | Note COMPTE_BRC et A4[41,48]
FAM | Note COMPTE_BRC et Note TVA
TYF | Note COLLECTIF_BRC


#CF TFF Transfert des factures fournisseurs dans la comptabilité

Ces paramètres sont exploités dans les programmes tr_facf_vl, facf et principalement tr_fac_fou.

Valeur numérique 1

Valeur à ajouter au numéro de compte pour obtenir le compte d'achat export (hors C.E)

Valeur numérique 2

Valeur à ajouter au numéro de compte pour obtenir le compte d'achat suspension de taxe

Valeur alpha 1

Caractères 1 à 8 | Numéro de compte d'achat par défaut
Caractères 9 à 16 | Numéro de compte de port taxable par défaut
Caractères 17 à 24 | Numéro de compte de TVA par défaut
Caractères 25 à 32 | Numéro de compte de remise par défaut
Caractères 33 à 40 | Numéro de compte d'escompte par défaut
Caractères 41 à 48 | Numéro de compte de port non taxable par défaut

Valeur alpha 2

Caractères 1 à 52

Chemin et nom complets du fichier transfert

Valeur alpha 3

Caractères 1 à 8 | Valeur à ajouter au numéro de compte pour obtenir le compte d'achat intracommunautaire
Caractères 9 à 16 | Valeur à ajouter au numéro de compte pour obtenir le compte d'achat sur les encaissements Elle se cumule aux valeurs ajoutées pour l'export, la suspension, l' intracommunautaire ou l'exonération
Caractères 17 à 24 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 25 à 32 | Numéro de compte de port intracommunautaire - Uniquement si option Ope
Caractères 33 à 40 | Numéro de compte de port suspension de taxe - Uniquement si option Ope

Valeur alpha 4

Caractères 1 à 14 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
Caractères 15 et 16 | Codes table et zone section analytique Valeur par défaut : CT (sous-famille de la ligne de commande)
Caractères 17 à 24 | Valeur à ajouter au numéro de compte pour obtenir le compte d'achat exonération
Caractères 25 à 32 | Numéro de compte de port exonération - Uniquement si option Ope
Caractères 33 à 35 | Libellé abrégé de la facture – La valeur par défaut est FAF
Caractères 36 à 38 | Libellé abrégé de l'avoir
Caractères 39 et 40 | Code table et nature analytique (voir Fonction retournant une zone) Valeur par défaut : CT (sous-famille de la ligne de commande) Utilisé pour la génération d'un fichier de transfert des factures clients et/ou fournisseurs en comptabilité pour Sage ligne 1000. Voir les notes CODE_TYPE_PIECE MODE_FIC_SAGE_1000 TOL_BON_A_PAYER TYPE_LIB_PIECE ZONE_LIBRE_1

Notes triées

ANAEL_PARAM_GEN

Paramétrage du transfert vers la comptabilité ANAEL

21,25 Code société - Obligatoire - EX : 00096

26,27 Code établissement - Obligatoire - EX : CJ

28,28 Code enregistrement - Obligatoire - EX : 6

29,31 Code journal - Obligatoire - EX : ACI

32,34 Code écran de saisie - Obligatoire - EX : ACH

35,37 Code identifiant de saisie - Obligatoire - EX : VSW

38,43 Code section analytique - Obligatoire - EX : 6

AXE_ANALYTIQUE

21,29 Axe analytique

CFG_TYPE_NTS_LIB

21,23 Type de note qui peut contenir le libellé de la pièce.

Le libellé de la pièce peut être contenu dans une note de la ligne de facture.

Le nouveau paramétrage permet de rechercher la note contenant le libellé.

Si la note n'est pas renseignée, alors le libellé sera comme maintenant.

Remarque : le libellé est sur 25 caractères.

Attention : cette évolution fonctionne uniquement avec la comptabilité Sage ligne 100.

CHAMP_FICHIER

CTRL_CHAFIC_UNICITE

Mode fichier paramétrable

Utilisé pour le fichier d'interface Sage ligne 1000

La note MODE_FIC_SAGE_1000 doit être paramétrée à 2.

21,38 Nom de la colonne

41,43 Rang de la colonne dans une ligne du fichier

Exemple

CHAMP_FICHIER CODE_TIERS 015

Le code tiers sera en 15ème position dans chaque ligne du fichier.

Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique.

Fonctionne avec la note CHAMP_FICHIER)

O chaque nom de champ doit être unique (par défaut)

N pas de contrôle

CODE_JOURNAL_1000

21,30 Code journal

CODE_JOURNAL_VENICE

21,25 Journal compta Venice. Pour la compta Venice (code 6)

CODESJOURNAUX

Code journal par régime fiscal

18 à 20 Code journal régime fiscal TAXABLE

21 à 23 Code journal régime fiscal EXPORTATION

24 à 26 Code journal régime fiscal SUSPENSION

27 à 29 Code journal régime fiscal INTRACOMMUNAUTAIRE

30 à 32 Code journal régime fiscal EXONERE

Exemple CODESJOURNAUX TAXEXPSUSINTEXO

CODE_TYPE_PIECE

Code type de pièce

Utilisé pour le fichier d'interface Sage ligne 1000

21,23 Code type pièce pour les avoirs (par défaut : AVO)

25,27 Code type pièce pour les factures (par défaut : FAC)

COLLECTIF_FOURN.

Ne pas oublier le point final !

Numéro de compte collectif fournisseur

17,24 Compte général

25,32 Compte export (uniquement pour Sage ligne 1000)

33,40 Compte suspension (uniquement pour Sage ligne 1000)

41,48 Compte intracommunautaire (uniquement pour Sage ligne 1000)

49,56 Compte exonéré (uniquement pour Sage ligne 1000)

Ce paramétrage est recherché en priorité sur la note COLLECTIF_ACHAT du TYF.

Pour la compta ANAEL, le collectif sur le TSC CFO (Fiche fournisseur) est prioritaire.

COMPTES_ECART_CONV.

Ne pas oublier le point final !

21,28 Compte d'écart de conversion débiteur

29,36 Compte d'écart de conversion créditeur

Exemple COMPTES_ECART_CONV. 6780000077800000

Pour la gestion d'un compte d'écart entre le montant calculé et le montant contrôlé de la facture

COMPTES_ECART_CTRL.

Ne pas oublier le point final !

Compte d'écart entre le montant calculé et le montant contrôlé de la facture ou de l'avoir

21 à 28 Compte d'écart de contrôle débiteur

29 à 36 Compte d'écart de contrôle créditeur

Exemple COMPTES_ECART_CTRL. 6781000077810000

CPTE_REMISE_GRPE

Paramétrage compte remise groupe

21 à 28 Numéro de compte remise

Exemple CPTE_REMISE_GRPE 60900000

ECART_BON_A_PAYER

21,31 Montant du plafond à ne pas dépasser lors de la différence entre le montant de la facture et le montant de contrôle pour considérer comme bon à payer.

Nota : peut-être cumulé avec la note TOL_BON_A_PAYER.

INTRASTAT_CODE_AVOIR

21,60 Section Intrastat, code pour les avoirs (obligatoire pour la compta Venice)

INTRASTAT_CODE_FAC

21,60 Section Intrastat, code pour les factures (obligatoire pour la compta Venice)

L1

Paramétrage transfert pour Compta SAGE LIGNE 100

3 à 60 Lignes de texte qui seront mises en début du fichier de transfert

MODE_FIC_SAGE_1000

21 Mode du fichier de transfert

Utilisé pour le fichier d'interface Sage ligne 1000

1 (ou vide) : structure du fichier figé (par défaut)

2 mode paramétrable, c'est-à-dire l'utilisateur peut choisir l'ordre de l'apparition des champs
Voir la note CHAMP_FICHIER

NATURE_DOCUMENT

21,23 Nature du document (ZZZ par défaut)

SAGE_100_PARAM_GEN

Paramétrage général transfert compta SAGE 100

21 Type d'interface (1 ou 2). (Par défaut : 1)

22,24 Si type d'interface 2 : N° de version compta Sage 100

25 Si type d'interface 2 : Mise à jour des registres de taxes (O/N)

Si oui, voir les notes CODE_TVA_A et CODE_TVA_F sur le paramètre TVA.

26 Si type d'interface 2 : Mode de recherche du plan analytique

1 valeur ff1.sect_ana

2 note FAM : ANA_SAGE_100

SAGE_500_PARAM_GEN

Paramétrage transfert pour Compta SAGE LIGNE 500

21 à 22 Type code journal

01 Code journal de la fiche société ou suivant le mode d'exonération de la facture

02 Code journal du site de production (SIT alpha3[15,20])

Celui-ci est saisi sur l'entête de la commande

Tableau de bord du multisite

23 à 24 Type code analytique

01 Code analytique standard (3 caractères)

02 Code analytique spécifique (6 caractères) :

Code société (1 caractère), toujours à 1

Code site (1 caractère) :SIT alpha3[21] du paramètre de la commande de la ligne de facture - Tableau de bord du multisite

Code section (2 caractères), 05 si article fabriqué, 06 si article acheté

Code sous-section (2 caractères) :

MAT alpha2[12,13] de l'article de la ligne de facture

25 à 26 Type attribution compte remise

01 Pas d'ajout de delta sur le compte remise

02 Ajout d'un delta sur le compte remise selon si l'article est fabriqué ou acheté

Créer une note commençant par SAGE_500_REMISE_02.

27 à 28 Type format dates écriture et échéance

01 Dates sous la forme JJMMAAAA

02 Dates sous la forme AAAAMMJJ

29 à 31 Compatibilité

29 Déduction des remises lignes sur le HT (O/N, N par défaut)

30 Suppression de la remise globale sur le HT (O/N, N par défaut)

31 Suppression de l'escompte sur le HT (O/N, N par défaut)

32 à 33 L I B R E S

34 à 35 Section analytique de débit

36 à 37 Sous-section analytique de débit

38 à 39 Section analytique de crédit

40 à 41 Sous-section analytique de crédit

42 à 43 Section compte écart de contrôle (débit)

44 à 45 Sous-section compte écart de contrôle (débit)

46 à 47 Section compte écart de contrôle (crédit)

48 à 49 Sous-section compte écart de contrôle (crédit)

SAGE_500_REMISE_02

21 à 28 Valeur à ajouter au compte remise si l'article de la ligne de facture est un article fabriqué
29 à 36 Valeur à ajouter au compte remise si l'article de la ligne de facture est un article acheté
Exemple SAGE_500_REMISE_02 0000010000000700

SECT_ANALYTIQUE_ESC

21,32 Code section analytique pour l'escompte

SECT_PAR_DEFAUT

21,28 Valeur par défaut du code compta analytique.

Supprimé le 28/02/2012. Remplacé par le code douanier de la sous-famille ou famille de l'article.

SEPARATEUR

21 Séparateur de champ (obligatoire)

SETEC_DIVISION

Comptabilité SETEC - 21,23 Division

SETEC_SOCIETE

Comptabilité SETEC - 21,24 Société

SETEC_TYPE_ECRITURE

Comptabilité SETEC - 21 Type décriture

TOL_BON_A_PAYER

21,23 Tolérance de différence entre le montant de la facture et le montant de contrôle pour considérer comme bon à payer (en pourcentage).

Nota : peut-être cumulé avec la note ECART_BON_A_PAYER

Utilisé pour le fichier d'interface Sage ligne 1000

TOP_MOIS

Paramétrage top fin de mois

9 à 11 Code paramètre top fin de mois

Exemple TOP_MOISFAC

TSC_SECT_ANALYTIQUE

21,23 Code TSC pour la recherche de la section analytique

TVA_A_DATE_FACTURE

Ajout du mois de la date de la facture dans le compte de TVA

21 Ajout du mois de la facture dans le compte de TVA (O/N, N par défaut)

22,23 Position dans le compte où il faut ajouter le mois (de 1 à 7).

Exemple

Compte de TVA 44560000

Mois de la facture = 02

Position = 6

Résultat : 44560020

Attention : Si le paramétrage (en fonction du fournisseur) prévoit l'ajout du mois d'échéance dans le compte de TVA celui-ci est prioritaire.

TYPE_LIB_PIECE

Type de libellé de la pièce

Utilisé pour le fichier d'interface Sage ligne 1000

0 (ou vide) nom du fournisseur – référence de la facture fournisseur
ou si option Oml alors nom du fournisseur – numéro de facture Volume. (par défaut)

1 code fournisseur – nom du fournisseur – numéro de facture

ZONE_LIBRE_1

Pour paramétrer le contenu de la colonne zone_libre par la première ligne d'une note

Utilisé pour le fichier d'interface Sage ligne 1000

21,23 Code paramètre de type NTS

25,26 Source de la note

EF entête de commande fournisseur

LF ligne de commande fournisseur

VENICE_REF_SER

Référence de commande de Servibox (optionnel)

Supprimé le 28/02/2012. Remplacé par la référence de l'entête de commande

Compta Venice

ATTENTION ! Pensez à paramétrer les codes suivants :

TVA (Compte)

FAM (Compte)

SFM (Compte)

MRG (Mode de règlement)

Si transfert ligne par ligne, on recherche dans le fichier article le numéro du compte d'achat.

Si absent, on recherche dans le fichier paramètre le numéro correspondant à la sous-famille.

Si absent, on recherche dans le fichier paramètre le numéro correspondant à la famille.

Si absent, on recherche dans le fichier paramètre le numéro correspondant au code TVA.

Sinon on prend le compte d'achat par défaut.

Remarques

Dans le fichier société (soc.4ge), il faut paramétrer :

  • Le type de comptabilité

  • Le numéro du journal des achats

  • Le numéro du dossier comptable


#CF TRA Traçabilité

Options payantes pour l'accès à la traçabilité

ACH 03 Commandes d'achat

BAS 04 Informations complémentaires (F20)

BAS 06 Prélèvements

BAS 07 Clients

BAS 10 Matières

BAS 18 BL

BAS 23 Devis transformateur carton

BAS 24 Outillage

BAS 25 Tarifs

BAS 26 Codes ECMA / FEFCO

BAS 27 Machines

BAS 28 Gammes standard

BAS 29 Devis multi-métiers

CDE 03 Saisie de commande

Liste des programmes offrant un accès à la visualisation de la traçabilité

Actions d'outillage (suivi)

Actions d'outillage (visualisation)

Adresses secondaires (saisie)

Affrètements (préparation)

Articles (saisie)

BL (saisie)

Cadencements de fabrication (saisie)

Cadencements de livraison (saisie)

Codes ECMA / FEFCO (saisie)

Commandes clients (visualisation)

Commandes fournisseurs (saisie)

Devis multi-métiers (saisie)

Devis onduleurs (saisie)

Devis transformateurs carton ondulé (saisie)

Expéditions des affrètements (saisie)

Gammes standard (saisie)

Groupages (visualisation)

Journal des BL (visualisation)

Machines (saisie)

Mouvements de stock (visualisation)

Non-conformités internes (saisie)

Paramètres (saisie)

Prélèvements (gestion)

Remises de prix (gestion)

Réclamations clients (visualisation)

Réclamations clients (saisie)

TSC (informations complémentaires) (saisie)

Tarifs multicritères (saisie)

Tarifs transporteurs (gestion)

Tiers (saisie)

Permet de tracer les appels de programmes par le biais de la touche CONTROL-U dans par02.4ge

Il s'agit d'une table fictive

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

Voir la note TRACABILITE_CHAMP

Les champs que l'on peut tracer sont les suivants :

soc (société)

cle (contient le code blocage)

etat_blocage (BLO pour bloqué, DEB pour débloqué)

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

On construit une table temporaire fefco dont la structure est la suivante :

soc Code société

cle Clé du FEFCO : Devis-Sous_devis-Entité-TSC-n

TSC

Laize : 080 à 084 et 08A à 08E

Coupe : 085 à 089 et 08F à 08J

n

1 ic_num1 et ic_char3_1

2 ic_num2 et ic_char30

3 ic_num3 et ic_char3_2

dim_fefco Dimension du FEFCO

type_fefco Type de FEFCO (Paramètre CP)

Permettre de tracer les événements sur la table fle_dec dans la saisie des devis multi-métiers : références multiples et/ou décomposition des feuilles dans le devis multi-métiers.

Les enregistrements de fle_dec liés aux références multiples ont la valeur de_num_feuille égale à 0 (= zéro).

Les enregistrements de fle_dec liés aux décompositions des feuilles ont la valeur de_num_feuille supérieure à 0 (> zéro).

L'option payante BAS/29 (traçabilité sur le devis multi-métiers) doit être mise en place.

Les caractères 41 à 43 de la note TRACABILITE_TABLE sont inutilisés.

Le caractère 21 de la note TAB_FLAG_ est inutilisé.

Le caractère 22 de la note TAB_FLAG_ doit être à O pour avoir le détail de l'enregistrement délocké manuellement.

Les tables par02 et par02note sont systématiquement tracées en détail, même si aucun paramétrage ne l'indique.

Les tables par02 et par02note sont systématiquement tracées en détail, même si aucun paramétrage ne l'indique.

Les tables par02 et par02note sont systématiquement tracées en détail, même si aucun paramétrage ne l'indique.

Les tables par02 et par02note sont systématiquement tracées en détail, même si aucun paramétrage ne l'indique.

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

Voir la note TRACABILITE_CHAMP

Les champs que l'on peut tracer sont les suivants :

soc (société)

cle (contient le code blocage)

etat_blocage (BLO pour bloqué, DEB pour débloqué)

Permet de tracer les appels de programmes par le biais de la touche CONTROL-U dans par02.

Il s'agit d'une table fictive.

Dans le détail de traçabilité, la zone valeur_avant contient la date et l'heure de lancement, la zone valeur_après contient la date et l'heure de fin de traitement.

La zone temps_traitement contient le temps de traitement exprimé en heures :minutes :secondes

Cette zone peut-être totalisée.

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

Il ne s'agit pas d'une table de la base atlas mais juste d'une interface visant à obtenir un fonctionnement identique à la traçabilité des autres tables de la base.

On construit une table temporaire fefco dont la structure est la suivante :

soc Code société

cle Clé du FEFCO : Devis-Sous_devis-Entité-TSC-n

TSC

Laize : 080 à 084 et 08A à 08E

Coupe : 085 à 089 et 08F à 08J

n

1 ic_num1 et ic_char3_1

2 ic_num2 et ic_char30

3 ic_num3 et ic_char3_2

dim_fefco Dimension du FEFCO

type_fefco Type de FEFCO (Paramètre CP)

Les caractères 41 à 43 de la note TRACABILITE_TABLE sont inutilisés.

Le caractère 21 de la note TAB_FLAG_ est inutilisé.

Le caractère 22 de la note TAB_FLAG_ doit être à O pour avoir le détail de l'enregistrement délocké manuellement.

Permettre de tracer les événements sur la table fle_dec dans la saisie des devis multi-métiers : références multiples et/ou décomposition des feuilles dans le devis multi-métiers.

Les enregistrements de fle_dec liés aux références multiples ont la valeur de_num_feuille égale à 0 (= zéro).

Les enregistrements de fle_dec liés aux décompositions des feuilles ont la valeur de_num_feuille supérieure à 0 (> zéro).

L'option payante BAS/29 (traçabilité sur le devis multi-métiers) doit être mise en place.

#CF TRA Traçabilité

Certaines tables requièrent l'activation d'une option pour l'accès à la traçabilité. Cliquez ici pour afficher / masquer ces options.

On peut accéder à la visualisation de la traçabilité à partir de certains programmes. Cliquez ici pour en afficher / masquer la liste.

En gestion d'enveloppe Volume, la traçabilité est active pour toutes les tables, toutes les colonnes.

Sommaire de cette page

Liste des tables triée par nom de table

Liste des tables triée par numéro de table

Autres paramètres :

Valeur alpha 1

Valeurs alpha 2, 3 et 4 (une présentation différente de celle des listes, inutile pour la configuration)

Notes

Quelques explications

Les noms des tables traçables doivent être indiqués dans les valeurs alpha 2, 3 ou 4 ou dans les notes TRACABILITE_TABLE.

Le fait qu'une table soit référencée dans des valeurs alpha 2, 3 ou 4 ou dans la note TRACABILITE_TABLE n'est lié qu'à des raisons purement historiques :

En effet, lorsque toutes les valeurs alpha 2, 3 et 4 ont été prises, nous avons créé la note TRACABILITE_TABLE pour pouvoir continuer à ajouter de nouvelles tables au fur et à mesure de l'expression des besoins des clients.

Ainsi, pour chaque table, quelle que soit la méthode utilisée (valeur alpha ou note), nous disposons de 5 caractères pour paramétrer la traçabilité :

Le caractère 1 indique la traçabilité en création.

Le caractère 2 indique la traçabilité en modification.

Le caractère 3 indique la traçabilité en suppression logique.

Le caractère 4 indique la traçabilité en suppression physique.

Le caractère 5 est inutilisé pour l'instant.

Chacun de ces 5 caractères peut prendre l'une des valeurs suivantes :

N Pas de traçabilité

E Traçabilité entête

D Traçabilité entête et détail

Liste des tables triée par nom de table

Certaines tables font l'objet d'un renvoi : cliquez sur le renvoi pour voir les compléments d'information en dessous-du tableau.

Nom | Libellé | Numéro | Paramétrage
action_evt | Actions - Evénements | 78 | note TRACABILITE_TABLE
action_mat | Action de suivi d'outillage | 37 | note TRACABILITE_TABLE
appel_prog | Appels de programmes par CTRL-U dans par02 - Plus d'infos | 28 | aucune
b_rec_ret | Bons de réception et de retour de marchandises : table b_rec_ret_e pour les entêtes table b_rec_ret_d pour le détail des lignes | 03 | alpha2[11,15]
blv1 | Entêtes de BL - Option payante BAS 18 | 15 | alpha3[16,20]
blv2 | Lignes de BL - Option payante BAS 18 | 16 | alpha3[21,25]
ccout0 | Centres de coût | 94 | note TRACABILITE_TABLE
cde1 | Entêtes de commande client - Option payante CD 3 | 05 | alpha2[21,25]
cde2 | Lignes de commande client - Option payante CD 3 | 02 | alpha2[6,10]
cde3 | Notes sur les lignes de commande | 88 | note TRACABILITE_TABLE
cde4 | Nomenclature de ligne de commande - Option payante CD 3 | 22 | alpha3[51,55]
cde8 | Cadencements de livraison - Option payante CD 3 | 23 | alpha4[1,5]
cde9_e | Commandes de papeterie - Entêtes | 86 | note TRACABILITE_TABLE
cde9_l | Commandes de papeterie - Lignes | 87 | note TRACABILITE_TABLE
cde_cad_fab | Cadencements de fabrication | 58 | note TRACABILITE_TABLE
cde_qualif | Suivi des commandes de qualification | 63 | note TRACABILITE_TABLE
cdf1 | Table des entêtes de commande d'achat - Option payante ACH 3 | 42 | note TRACABILITE_TABLE
cdf2 | Table des lignes de commande d'achat - Option payante ACH 3 | 43 | note TRACABILITE_TABLE
cdf4 | Table des lignes de cadencement d'achat - Option payante ACH 3 | 44 | note TRACABILITE_TABLE
cli | Tiers - Option payante BAS 7 | 10 | alpha2[46,50]
cli2 | Adresses secondaires des tiers - Option payante BAS 7 | 11 | alpha2[51,55]
cli3 | Notes sur les tiers (1) (2) (4) - Option payante BAS 7 | 66 | note TRACABILITE_TABLE
cli5 | Historisation des assurances/crédits (1) (4) - Option payante BAS 7 | 67 | note TRACABILITE_TABLE
cli6 | Modèles de documents (1) (4) - Option payante BAS 7 | 68 | note TRACABILITE_TABLE
cli_distance | Distance kilométrique adresse client et magasin | 82 | note TRACABILITE_TABLE
code_blocage | Modifications des codes blocage dans la revue de contrat Plus d'infos | 25 | alpha4[11,15]
conteneur_info | Informations conteneurs | 39 | note TRACABILITE_TABLE
conteneur_prod_det | Détails des conteneurs | 85 | note TRACABILITE_TABLE
conteneur_produit | Description du contenu du conteneur | 40 | note TRACABILITE_TABLE
corres | Correspondants | 26 | alpha4[16,20]
crm | Traçabilité sur la CRM. Plus d'info | 29 | aucune
ecma | Codes ECMA/FEFCO - Option payante BAS 26 | 45 | note TRACABILITE_TABLE
ecma2 | Libellés des FEFCO dessus/dessous - Option payante BAS 26 | 46 | note TRACABILITE_TABLE
edi_bobine | EDI bobines | 55 | note TRACABILITE_TABLE
edi_rec | EDI réception | 56 | note TRACABILITE_TABLE
edi_rec_cond | EDI réception - détail conditionnement | 57 | note TRACABILITE_TABLE
edi_stk_bobine | Intégration EDI des bobines en stock | 77 | note TRACABILITE_TABLE
fab_1_etat | Etat de la fabrication | 64 | note TRACABILITE_TABLE
fefco | Détail FEFCO des devis Plus d'info - Option payante 26 | 36 | alpha4[56,60]
fle_2 | Entêtes des devis | 30 | alpha4[26,30]
fle_com | LCO des devis - Option payante BAS 23 | 32 | alpha4[36,40]
fle_dec | Références multiples - Décompositions des feuilles Plus d'info | 76 | note TRACABILITE_TABLE
fle_imp | Entités des devis - Option payante BAS 23 | 31 | alpha4[31,35]
fle_mat | Lignes de matière des devis | 34 | alpha4[46,50]
fle_ope | Lignes d'opération des devis - Option payante BAS 23 | 35 | alpha4[51,55]
fle_tra | Lignes de transport des devis | 33 | alpha4[41,45]
fo_c_cde1 | Entête de commande calendrier (table spécifique) |  | note TRACABILITE_TABLE
fo_c_cde2 | Lignes de commande calendrier (table spécifique) |  | note TRACABILITE_TABLE
for_po | Formules de calcul des pointages des FEFCO dessus/dessous Option payante BAS 26 ? à vérifier | 48 | note TRACABILITE_TABLE
formules | Formules de calcul - Particularités | 61 | note TRACABILITE_TABLE
formules2 | Notes sur les formules de calcul | 62 | note TRACABILITE_TABLE
g_ecma | Gammes applicables des FEFCO dessus/dessous | 47 | note TRACABILITE_TABLE
gestion_options | Clés des options | 93 | note TRACABILITE_TABLE
groupage_bl | Groupages des bons de livraison | 21 | alpha3[46,50]
g_std_d | Lignes de gamme standard - Option payante BAS 28 | 54 | note TRACABILITE_TABLE
g_std_e | Entêtes de gamme standard - Option payante BAS 28 | 53 | note TRACABILITE_TABLE
g_std_n | Notes sur entête de gamme standard | 92 | note TRACABILITE_TABLE
i_lposte | Libellés des opérations élémentaires | 90 | note TRACABILITE_TABLE
info_c | Trames de saisie complémentaire - Option payante BAS 4 | 04 | alpha2[16,20]
i_postes | Opérations élémentaires | 91 | note TRACABILITE_TABLE
je_lock | Table des locks d'enregistrements. Particularités | 59 | note TRACABILITE_TABLE
kp_recap_tot | Récapitulatif des coûts - Option payante PRO 4 | 41 | note TRACABILITE_TABLE
lib_etr | Libellés étrangers | 60 | note TRACABILITE_TABLE
lot_industriel | [en cours le 29/07/2010] | 65 | note TRACABILITE_TABLE
mac0 | Machines standards - Option payante BAS 27 | 50 | note TRACABILITE_TABLE
mac2 | Cadences/temps des machines standards - Option payante BAS 27 | 51 | note TRACABILITE_TABLE
mac4 | Taux horaires des machines standards - Option payante BAS 27 | 52 | note TRACABILITE_TABLE
maj_po | Majorations par profil carton pour le calcul des pointages des FEFCO dessus/dessous | 49 | note TRACABILITE_TABLE
mat | Matières - Option payante BAS 10 | 14 | alpha3[11,15]
mat2 | Fournisseurs secondaires des articles (1) (4) | 69 | note TRACABILITE_TABLE
mat3 | Notes sur les articles (1) (3) (4) | 70 | note TRACABILITE_TABLE
mat5 | Calendrier des mouvements (1) (4) | 71 | note TRACABILITE_TABLE
mat_format | Formats (1) (4) | 72 | note TRACABILITE_TABLE
mat_grammage | Grammages (1) (4) | 73 | note TRACABILITE_TABLE
mat_site | Lieux de rangement par site (1) (4) | 74 | note TRACABILITE_TABLE
mat_var_prod | Variantes de production (1) (4) | 75 | note TRACABILITE_TABLE
notes | Table des notes - Voir note TRACE_TYPE_CLE_NOTES | 79 | note TRACABILITE_TABLE
ope0 | Opérations communes | 89 | note TRACABILITE_TABLE
ordre_transport | Ordres de transport | 27 | alpha4[21,25]
par01 | Types de paramètres | 95 | note TRACABILITE_TABLE
par02 | Paramètres - Plus d'infos | 12 | alpha3[1,5]
par02note | Notes de paramètres - Plus d'infos | 13 | alpha3[6,10]
prelev_estampille | Prélèvements estampille - Option payante BAS 6 | 09 | alpha2[41,45]
prelev_qte_base | Prélèvements de base - Option payante BAS 6 | 07 | alpha2[31,35]
prelev_qte_supp | Prélèvements supplémentaires - Option payante BAS 6 | 08 | alpha2[36,40]
reclamation | Réclamations | 06 | alpha2[26,30]
sfm | Sous-familles | 24 | alpha4[6,10]
soc | Fiche société | 96 | note TRACABILITE_TABLE
stk0 | Stocks | 01 | alpha2[1,5]
tar0 | Tarifs - Option payante BAS 25 | 38 | note TRACABILITE_TABLE
tarif_transp_acc | Frais accessoires des tarifs transporteur | 18 | alpha3[31,35]
tarif_transp_ent | Entêtes des tarifs transporteur | 17 | alpha3[26,30]
tarif_transp_lig | Lignes des tarifs transporteur | 19 | alpha3[36,40]
tarif_transp_pla | Plages de tarif des lignes des tarifs transporteur | 20 | alpha3[41,45]
tro | Tarifs transporteurs | 80 | note TRACABILITE_TABLE

Liste des tables triée par numéro de table

Certaines tables font l'objet d'un renvoi : cliquez sur le renvoi pour voir les compléments d'information en dessous-du tableau.

Nom | Libellé | Numéro | Paramétrage
stk0 | Stocks | 01 | alpha2[1,5]
cde2 | Lignes de commande client | 02 | alpha2[6,10]
b_rec_ret | Bons de réception et de retour de marchandises : table b_rec_ret_e pour les entêtes table b_rec_ret_d pour le détail des lignes | 03 | alpha2[11,15]
info_c | Trames de saisie complémentaire | 04 | alpha2[16,20]
cde1 | Entêtes de commande client | 05 | alpha2[21,25]
reclamation | Réclamations | 06 | alpha2[26,30]
prelev_qte_base | Prélèvements de base | 07 | alpha2[31,35]
prelev_qte_supp | Prélèvements supplémentaires | 08 | alpha2[36,40]
prelev_estampille | Prélèvements estampille | 09 | alpha2[41,45]
cli | Tiers | 10 | alpha2[46,50]
cli2 | Adresses secondaires des tiers | 11 | alpha2[51,55]
par02 | Paramètres - Plus d'infos | 12 | alpha3[1,5]
par02note | Notes de paramètres - Plus d'infos | 13 | alpha3[6,10]
mat | Matières - Produits | 14 | alpha3[11,15]
blv1 | Entêtes de BL | 15 | alpha3[16,20]
blv2 | Lignes de BL | 16 | alpha3[21,25]
tarif_transp_ent | Entêtes des tarifs transporteur | 17 | alpha3[26,30]
tarif_transp_acc | Frais accessoires des tarifs transporteur | 18 | alpha3[31,35]
tarif_transp_lig | Lignes des tarifs transporteur | 19 | alpha3[36,40]
tarif_transp_pla | Plages de tarif des lignes des tarifs transporteur | 20 | alpha3[41,45]
groupage_bl | Groupages des bons de livraison | 21 | alpha3[46,50]
cde4 | Nomenclature de ligne de commande | 22 | alpha3[51,55]
cde8 | Cadencements de livraison | 23 | alpha4[1,5]
sfm | Sous-familles | 24 | alpha4[6,10]
code_blocage | Modifications des codes blocage dans la revue de contrat Plus d'infos | 25 | alpha4[11,15]
corres | Correspondants | 26 | alpha4[16,20]
ordre_transport | Ordres de transport | 27 | alpha4[21,25]
appel_prog | Appels de programmes par CTRL-U dans par02 Plus d'infos | 28 | aucune
crm | Traçabilité sur la CRM. Plus d'info | 29 | aucune
fle_2 | Entêtes des devis | 30 | alpha4[26,30]
fle_imp | Entités des devis | 31 | alpha4[31,35]
fle_com | LCO des devis | 32 | alpha4[36,40]
fle_tra | Lignes de transport des devis | 33 | alpha4[41,45]
fle_mat | Lignes de matière des devis | 34 | alpha4[46,50]
fle_ope | Lignes d'opération des devis | 35 | alpha4[51,55]
fefco | Détail FEFCO des devis Plus d'info | 36 | alpha4[56,60]
action_mat | Action de suivi d'outillage | 37 | note TRACABILITE_TABLE
tar0 | Tarifs | 38 | note TRACABILITE_TABLE
conteneur_info | Informations conteneurs | 39 | note TRACABILITE_TABLE
conteneur_produit | Description du contenu du conteneur | 40 | note TRACABILITE_TABLE
kp_recap_tot | Récapitulatif des coûts | 41 | note TRACABILITE_TABLE
cdf1 | Table des entêtes de commande d'achat | 42 | note TRACABILITE_TABLE
cdf2 | Table des lignes de commande d'achat | 43 | note TRACABILITE_TABLE
cdf4 | Table des lignes de cadencement d'achat | 44 | note TRACABILITE_TABLE
ecma | Codes ECMA/FEFCO | 45 | note TRACABILITE_TABLE
ecma2 | Libellés des FEFCO dessus/dessous | 46 | note TRACABILITE_TABLE
g_ecma | Gammes applicables des FEFCO dessus/dessous | 47 | note TRACABILITE_TABLE
for_po | Formules de calcul des pointages des FEFCO dessus/dessous | 48 | note TRACABILITE_TABLE
maj_po | Majorations par profil carton pour le calcul des pointages des FEFCO dessus/dessous | 49 | note TRACABILITE_TABLE
mac0 | Machines standards | 50 | note TRACABILITE_TABLE
mac2 | Cadences/temps des machines standards | 51 | note TRACABILITE_TABLE
mac4 | Taux horaires des machines standards | 52 | note TRACABILITE_TABLE
g_std_e | Entêtes de gamme standard | 53 | note TRACABILITE_TABLE
g_std_d | Lignes de gamme standard | 54 | note TRACABILITE_TABLE
edi_bobine | EDI bobines | 55 | note TRACABILITE_TABLE
edi_rec | EDI réception | 56 | note TRACABILITE_TABLE
edi_rec_cond | EDI réception - détail conditionnement | 57 | note TRACABILITE_TABLE
cde_cad_fab | Cadencements de fabrication | 58 | note TRACABILITE_TABLE
je_lock | Table des locks d'enregistrements. Particularités | 59 | note TRACABILITE_TABLE
lib_etr | Libellés étrangers | 60 | note TRACABILITE_TABLE
formules | Formules de calcul Particularités | 61 | note TRACABILITE_TABLE
formules2 | Notes sur les formules de calcul | 62 | note TRACABILITE_TABLE
cde_qualif | Suivi des commandes de qualification | 63 | note TRACABILITE_TABLE
fab_1_etat | Etat de la fabrication | 64 | note TRACABILITE_TABLE
lot_industriel | [en cours le 29/07/2010] | 65 | note TRACABILITE_TABLE
cli3 | Notes sur les tiers (1) (2) (4) | 66 | note TRACABILITE_TABLE
cli5 | Historisation des assurances/crédits (1) (4) | 67 | note TRACABILITE_TABLE
cli6 | Modèles de documents (1) (4) | 68 | note TRACABILITE_TABLE
mat2 | Fournisseurs secondaires des articles (1) (4) | 69 | note TRACABILITE_TABLE
mat3 | Notes sur les articles (1) (3) (4) | 70 | note TRACABILITE_TABLE
mat5 | Calendrier des mouvements (1) (4) | 71 | note TRACABILITE_TABLE
mat_format | Formats (1) (4) | 72 | note TRACABILITE_TABLE
mat_grammage | Grammages (1) (4) | 73 | note TRACABILITE_TABLE
mat_site | Lieux de rangement par site (1) (4) | 74 | note TRACABILITE_TABLE
mat_var_prod | Variantes de production (1) (4) | 75 | note TRACABILITE_TABLE
fle_dec | Références multiples - Décompositions des feuilles Plus d'info | 76 | note TRACABILITE_TABLE
edi_stk_bobine | Intégration EDI des bobines en stock | 77 | note TRACABILITE_TABLE
action_evt | Actions - Evénements | 78 | note TRACABILITE_TABLE
notes | Table des notes - Voir note TRACE_TYPE_CLE_NOTES | 79 | note TRACABILITE_TABLE
tro | Tarifs transporteurs | 80 | note TRACABILITE_TABLE
version | Version (mises à jour et patches) | 81 | note TRACABILITE_TABLE
cli_distance | Distance kilométrique adresse client et magasin | 82 | note TRACABILITE_TABLE
fo_c_cde1 | Entête de commande calendrier (table spécifique) | 83 | note TRACABILITE_TABLE
fo_c_cde2 | Lignes de commande calendrier (table spécifique) | 84 | note TRACABILITE_TABLE
conteneur_prod_det | Détails des conteneurs | 85 | note TRACABILITE_TABLE
cde9_e | Commandes de papeterie - Entêtes | 86 | note TRACABILITE_TABLE
cde9_l | Commandes de papeterie - Lignes | 87 | note TRACABILITE_TABLE
cde3 | Notes sur les lignes de commande | 88 | note TRACABILITE_TABLE
ope0 | Opérations communes | 89 | note TRACABILITE_TABLE
i_lposte | Libellé des opérations élémentaires | 90 | note TRACABILITE_TABLE
i_postes | Opérations élémentaires | 91 | note TRACABILITE_TABLE
g_std_n | Notes sur entête de gamme standard | 92 | note TRACABILITE_TABLE
gestion_options | Clés des options | 93 | note TRACABILITE_TABLE
ccout0 | Centres de coût | 94 | note TRACABILITE_TABLE
par01 | Types de paramètres | 95 | note TRACABILITE_TABLE
soc | Fiche société | 96 | note TRACABILITE_TABLE

Renvois sur certaines tables

(1) Seule la traçabilité d'entête est gérée pour les tables 66 à 75 (pas de détail disponible pour un enregistrement de traçabilité de type modification).

(2) La table cli3 est gérée en traçabilité via une clé simplifiée : code client/code adresse/type de note (le numéro de ligne de note n'est pas prise en compte).

(3) La table mat3 est gérée en traçabilité via une clé simplifiée : code article/type de note (le numéro de ligne de note n'est pas prise en compte).

(4) La traçabilité des tables 66 à 75 servira notamment pour la gestion d'actions à effectuer dans le programme des alertes sur traçabilité (alerte_tracabilite)

Valeur alpha 1

Caractère 1 | Traçabilité activée (O/N)
Caractères 2 à 4 | Type de note de traçabilité
Caractère 5 | Traçabilité des champs N On trace uniquement les champs modifiés O On trace tous les champs même ceux non modifiés Pour une gestion plus fine par table, voir les notes commençant par TAB_FLAG_. Doit être à N sauf avis contraire de Volume Software
Caractère 6 | Traçabilité des champs hors modification (pour création et annulation seulement) N On ne trace aucun champ (par défaut) O On trace tous les champs Pour une gestion plus fine par table, voir les notes commençant par TAB_FLAG_. Doit être à N sauf avis contraire de Volume Software

Valeurs alpha2 - 3 - 4

Consultez de préférence le tableau détaillé, trié par noms de tables (en haut de la page)

 | alpha2 | alpha3 | alpha4
1,5 | stk0 | par02 | cde8
6,10 | cde2 | par02_note | sfm
11,15 | b_rec_ret | mat | (code_blocage)
16,20 | info_c | blv1 | corres
21,25 | cde1 | blv2 | ordre_transport
26,30 | reclamation | tarif_transp_ent | fle_2
31,35 | prelev_qte_base | tarif_transp_acc | fle_imp
36,40 | prelev_qte_sup | tarif_transp_lig | fle_com
41,45 | prelev_estampille | tarif_transp_pla | fle_tra
46,50 | cli | groupage_bl | fle_mat
51,55 | cli2 | cde4 | fle_ope
56,60 |  |  | fefco

Les valeurs alpha 2, 3 et 4 étant toutes remplies, les autres tables sont répertoriées dans les notes commençant par TRACABILITE_TABLE.

Notes

NBJOURS_RETENTION_

Epuration des tables de traçabilité

19,20 Numéro de la table de traçabilité ou DF pour le nombre de jours de rétention par défaut.

21,24 Nombre de jours de rétention. Par défaut : 365

Exemples

NBJOURS_RETENTION_1 12

Tous les enregistrements de la table de traçabilité 1 (stk0) qui ont une date antérieure à aujourd'hui - 12 jours seront effacés.

NBJOURS_RETENTION_DF65

Toutes les tables dont le nombre de jours de rétention de données n'a pas été paramétré comme précédemment auront 65 jours de rétention.

TAB_FLAG_nn

où nn représente le N° de table (voir les listes)

21 Traçabilité des champs

N On trace uniquement les champs modifiés

O On trace tous les champs même ceux non modifiés

22 Traçabilité des champs hors modification (pour création et annulation seulement)

N On ne trace aucun champ (Par défaut)

O On trace les champs

TRACABILITE_CHAMP

21,40 Nom de la table. Voir les listes

41,60 Nom du champ. Mettre TOUS pour avoir tous les champs.

TRACABILITE_TABLE

Traçabilité des tables

21,40 Nom de la table à tracer. Voir les listes.

41 Activation de la traçabilité en création

N Pas de traçabilité

E Traçabilité entête

D Traçabilité entête et détail

42 Activation de la traçabilité en modification

N Pas de traçabilité

E Traçabilité entête

D Traçabilité entête et détail

43 Activation de la traçabilité en suppression logique

N Pas de traçabilité

E Traçabilité entête

D Traçabilité entête et détail

44 Activation de la traçabilité en suppression physique

N Pas de traçabilité

E Traçabilité entête

D Traçabilité entête et détail

45 inutilisé

TRACE_MTT_CL_QUALITE

21 Traçabilité des nouveaux champs si modification de la qualité client (O/N, N par défaut)

BLO A1[3,5] = 003 (Contrôle de l'encours client)

TRACE_MTT_LC_CODEBLO

21 Traçabilité des nouveaux champs si modification du code blocage risque (O/N, N par défaut)

BLO A1[3,5] = 003 (Contrôle de l'encours client)

TRACE_QTE_BLO_034

21 Traçabilité de la quantité commandée si modification de la quantité commandée de la ligne de commande ou annulation de la ligne de commande (O/N, N par défaut)

BLO A1[3,5] = 034 (Contrôle si une des FBI de la commande commerciale a été générée)

Voir le code blocage 034 pour plus d'info sur le paramétrage nécessaire.

TRACE_TYPE_CLE_NOTES

21,60 Types de clé de la table notes à tracer

Uniquement dans le cadre du devis standard, table des notes (table N° 79)

Chaque type de clé sur 1 caractère, soit 40 types de clé par ligne de note.

Par défaut, on trace tous les types de clé.

Si cette note est positionnée, seules les notes dont le type de clé est paramétré seront tracées.

Exemple

TRACE_TYPE_CLE_NOTESUD

Trace les notes dont le type de clé est U et D.

TRACE_TYPE_MVT_EXC

Paramétrage spécifique aux mouvements de stock

Par défaut, on trace tous les types de mouvements.

Si cette note est positionnée, seuls les mouvements dont le type n'est pas paramétré seront tracés.

21,60 Types de mouvement à ne pas tracer

Chaque type de mouvement sur 3 caractères, soit 13 types par ligne de note.

Ces notes ne peuvent pas cohabiter avec les notes TRACE_TYPE_MVT_STK ci-dessous.

Exemple

TRACE_TYPE_MVT_EXC CP LP DECECOEC

Trace les mouvements de stock de type autre que CP, LP, DEC, ECO, et EC.

TRACE_TYPE_MVT_STK

Paramétrage spécifique aux mouvements de stock

Par défaut, on trace tous les types de mouvements.

Si cette note est positionnée, seuls les mouvements dont le type est paramétré seront tracés.

21,60 Types de mouvement à tracer

Chaque type de mouvement sur 3 caractères, soit 13 types par ligne de note.

Ces notes ne peuvent pas cohabiter avec les notes TRACE_TYPE_MVT_EXC ci-dessus.

Exemple

TRACE_TYPE_MVT_STK CP LP DECECOEC

Trace les mouvements de stock de type CP, LP, DEC, ECO, et EC.


#CF TFP Transfert des factures fournisseurs dans la comptabilité MERCUR ou VALC

Valeur numérique 1

Valeur à ajouter au numéro de compte pour obtenir le compte export (hors C.E)

Valeur numérique 2

Valeur à ajouter au numéro de compte pour obtenir le compte suspension de TVA

Valeur alpha 1

Caractères 1 à 8 | Numéro de compte d'achat par défaut
Caractères 9 à 16 | Inutilisé
Caractères 17 à 24 | Numéro de compte de TVA par défaut (uniquement VALC)
Caractères 41 à 48 | Inutilisé

Valeur alpha 2

Caractères 1 à 60 | Comptabilité VALC - Chemin complet et nom du fichier transfert
Exemple | /u/atlas/atlas.dbs/tr_facval)

Valeur alpha 3

Caractères 1 à 8

Valeur à ajouter au numéro de compte pour obtenir le compte intracommunautaire

Valeur alpha 4

Caractère 15 | Code table section analytique (voir par.doc)
Caractère 16 | Code zone section analytique (voir par.doc)
Caractères 17 à 24 | Valeur à ajouter au numéro de compte pour obtenir le compte exonération

ATTENTION ! Pensez à paramétrer les codes suivants :

TVA (compte)

FAM (compte)

MRG (mode de règlement VALC)

Remarques

Dans le fichier société, il faut paramétrer le type de compta (M ou V), le numéro du journal des achats et le numéro du dossier comptable (programme soc.4ge).


#CF TRC Transfert des nouveaux clients vers la comptabilité FABRICAL

#CF TRC Transfert des nouveaux clients vers la comptabilité

Utilisé pour les almanachs et les calendriers

Notes

Explications

Séparateur : [2 points] à la fin de chaque zone.

Le libellé de la zone est figé.

Les codes correspondant aux libellés sont figés.

Ainsi pour chaque ligne, il faut saisir un libellé (figé), puis [:], puis le code (figé) et enfin [:]

Ligne 1 | Libellé : code_societe Code : Il doit être égal à la valeur saisie dans la zone BD de la société. Il correspond aux caractères 1 à 4 du fichier SETEC_CLI (4 caractères)
Ligne 2 | Libellé : type_tiers Code : Code type tiers. Il correspond aux caractères 13 à 14 du fichier SETEC_CLI (2 caractères)
Ligne 3 | Libellé : pays_france (uniquement Almanachs) Code : Code pays qui correspond à la France. Il correspond aux caractères 187 à 201 du fichier SETEC_CLI (15 caractères)
Ligne 4 | Libellé : pays_export (uniquement Almanachs) Code : Code pays qui correspond à l'export. Il correspond aux caractères 187 à 201 au fichier SETEC_CLI (15 caractères)
Ligne 5 | Libellé : cpte_centralisateur Code : Compte centralisateur. Il correspond aux caractères 202 à 209 du fichier SETEC_CLI (8 caractères)
Ligne 6 | Libellé : trait_devise Code : Traitement devise Il correspond au caractère 212 du fichier SETEC_CLI (1 caractère)
Ligne 7 | Libellé : mode_reglement (uniquement Almanachs) Code : Mode de règlement. Il correspond aux caractères 217 à 218 du fichier SETEC_CLI (2 caractères)
Ligne 8 | Libellé : nb_jours_reglement (uniquement Almanachs) Code : Nombre de jours règlement. Il correspond aux caractères 219 à 221 du fichier SETEC_CLI (3 caractères)
Ligne 9 | Libellé : type_reglement Code : Type de règlement. Il correspond au caractère 222 du fichier SETEC_CLI (1 caractère)
Ligne 10 | Libellé : jour_reglement (uniquement Almanachs) Code : Jour de règlement. Il correspond aux caractères 223 à 224 du fichier SETEC_CLI (2 caractères).
Ligne 11 | Libellé : releve Code : Relevé Il correspond au caractère 225 du fichier SETEC_CLI (1 caractère)
Ligne 12 | Libellé : :relance
Ligne 13 | Libellé : tva_exo (uniquement Almanachs) Code : TVA exo. Il correspond au caractère 227 du fichier SETEC_CLI (1 caractère)
Ligne 14 | Libellé : tva_encaissement (uniquement Almanachs) Code : TVA à encaissement. Il correspond au caractère 227 du fichier SETEC_CLI (1 caractère)
Ligne 15 | Libellé : trait_echeance Code : Traitement échéance. Il correspond au caractère 228 du fichier SETEC_CLI (1 caractère)
Ligne 16 | Libellé : fermeture Code : Fermeture. Il correspond au caractère 229 du fichier SETEC_CLI (1 caractère)
Ligne 17 | Libellé : trait_honoraires Code : Traitement des honoraires. Il correspond au caractère 244 du fichier SETEC_CLI (1 caractère)
Ligne 18 | Libellé : tiers_payant Code : Tiers payant. Il correspond aux caractères 245 à 252 du fichier SETEC_CLI (8 caractères)


#CF TRF Transfert des factures clients dans la comptabilité

Valeurs numériques 1 & 2 Valeur alpha 1 Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes Notes pour l'affacturage

Ce paramétrage est utilisé par tr_fcnn_vl.

Voir aussi l'ordre de recherche du compte de vente, et la possibilité de distinguer le compte de vente Facture du compte de vente Avoir.

Valeurs numériques

1 | Valeur à ajouter au numéro de compte pour obtenir le compte export (hors CEE)
2 | Valeur à ajouter au numéro de compte pour obtenir le compte suspension de TVA

Les autres valeurs à ajouter au numéro de compte se trouvent en alpha3[1,8] ainsi que alpha4[17,24].

Valeur alpha 1

Caractères 1 à 8 | N° de compte de vente par défaut
Caractères 9 à 16 | N° de compte de port taxable
Caractères 17 à 24 | N° de compte de TVA par défaut
Caractères 25 à 32 | N° de compte de remise (non utilisé si option Osr dans tr_fcnn_vl)
Caractères 33 à 40 | N° de compte d'escompte (non utilisé si option Ose dans tr_fcnn_vl)
Caractères 41 à 48 | N° de compte de port export
Caractères 49 et 50 | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
La suite des numéros de compte se trouve en A3[17,56]

Valeur alpha 2

Caractères 1 à 52 | Nom complet (avec chemin) du fichier de transfert Le chemin est paramétrable dans 3 endroits différents ! La priorité est la suivante : 1) Notes commençant par FICH_TRAN du paramètre de lancement de tr_fcnn_vl 2) Notes commençant par FICH_TRAN du #CF_TRF 3) #CF TRF A2[1,52] (c'est ici). (à éviter, car limité à 52 caractères, alors que les notes peuvent être cumulées pour permettre des chemins d'accès longs)
Caractères 53 à 60 | Compte par défaut pour la taxe parafiscale

Valeur alpha 3

Caractères 1 à 8 | Valeur à ajouter au numéro de compte pour obtenir le compte intracommunautaire
Caractères 9 à 16 | Valeur à ajouter au numéro de compte pour obtenir le compte HT sur les encaissements Attention, elle se cumule aux valeurs ajoutées pour l'export ou la suspension ou l'intracommunautaire ou l'exonération.
Caractères 17 à 24 | N° de compte emballage
Caractères 25 à 32 | N° de compte de port intracommunautaire Uniquement si option -Ope sur transfert en comptabilité.
Caractères 33 à 40 | N° de compte de port en suspension de TVA Uniquement si option -Ope sur transfert en comptabilité.
Caractères 41 à 48 | N° de compte d'emballage en suspension de TVA
Caractères 49 à 56 | N° de compte d'emballage intracommunautaire
La suite des numéros de compte se trouve en alpha4[7,14], alpha4[25,32] et alpha4[33,40].

Valeur alpha 4

Caractères 1 à 3 | Code produit rémunération intermédiaire
Caractères 4 à 6 | Code produit port franco
Caractères 7 à 14 | N° de compte d'emballage export
Caractères 15 et 16 | Codes table et zone section analytique Valeur par défaut : CT (sous-famille de la ligne de commande) Si le code est un TSC, renseigner le code dans la note TSC_SECT_ANALYTIQUE Exemple A4[15,16] = GG TSC_SECT_ANALYTIQUE C20 La section analytique du tiers est renseignée dans le TSC C20, zone G.
Caractères 17 à 24 | Valeur à ajouter au numéro de compte pour obtenir le compte exonération
Caractères 25 à 32 | N° de compte de port en exonération de TVA Uniquement si option -Ope sur transfert en comptabilité.
Caractères 33 à 40 | N° de compte d'emballage exonération
Caractères 41 à 48 | N° de compte de droit de timbre
Caractères 49 et 50 | Code table et nature analytique (voir Fonction retournant une zone) Valeur par défaut : CT (sous-famille de la ligne de commande) Utilisé pour la génération d'un fichier de transfert des factures clients et/ou fournisseurs en comptabilité pour Sage ligne 1000. Voir les notes AXE_ANALYTIQUE COD_SECT_ANAL_S1000 MODE_FIC_SAGE_1000 TYPE_LIB_PIECE ZONE_LIBRE_1

Notes pour l'affacturage

CPT_AFFACTURAGE_N | 21,38 Numéro de compte d'affacturage normal
CPT_AFFACTURAGE_O | 21,38 Numéro de compte d'affacturage d'export
CPT_AFFACTURAGE_I | 21,38 Numéro de compte d'affacturage d'intracommunautaire
CPT_AFFACTURAGE_S | 21,38 Numéro de compte d'affacturage de la suspension de TVA
CPT_AFFACTURAGE_E | 21,38 Numéro de compte d'affacturage exonéré
FICHIER_AFFACTURAGE | 21,60 Répertoire et nom du fichier pour l'affacturage. Note cumulative
JOURNAL_AFFACTURAGE | 21,23 Journal d'affacturage

Notes triées

Les notes pour l'affacturage sont dans un paragraphe séparé.

ANAEL_PARAM_GEN

Paramétrage pour la comptabilité ANAEL

21,25 Code société - Obligatoire - Exemple 00096

26,27 Code établissement - Obligatoire - Exemple CJ

28,28 Code enregistrement - Obligatoire - Exemple 6

29,31 Code journal - Obligatoire - Exemple VTF

32,34 Code écran de saisie - Obligatoire - Exemple VEN

35,37 Code identifiant de saisie - Obligatoire - Exemple VSW

38,43 Code section analytique - Obligatoire - Exemple 6

ANALYTIQUE_CCMX_SPEC

Recherche de la section analytique sur le champ lc_p1 de la ligne de commande - SPECIFIQUE

21,23 Type de paramètre associé au lc_p1 de la ligne de commande.

24 Type de champ du paramètre

1 Libellé court

ANALYTIQUE_ESC_CCMX

Permettre la gestion de la comptabilité analytique sur l'enregistrement escompte pour la comptabilité CCMX

21,28 Code section analytique de l'escompte

31,38 Code rubrique analytique de l'escompte

ANALYTIQUE_REM_CCMX

Permettre la gestion de la comptabilité analytique sur l'enregistrement remise pour la comptabilité CCMX

21,28 Code section analytique de la remise

31,38 Code rubrique analytique de la remise

AXE_ANALYTIQUE

21,29 Axe analytique

Utilisé pour le fichier d'interface Sage ligne 1000

CHAMP_FICHIER

Mode fichier paramétrable

Utilisé initialement pour le fichier d'interface Sage ligne 1000, obligatoire pour l'interface Ciel.

La note MODE_FIC_SAGE_1000 doit être paramétrée à 2. (même pour la comptabilité Ciel).

Voir aussi la note CTRL_CHAFIC_UNICITE pour le contrôle d'unicité des champs.

21,38 Nom de la colonne

41,43 Rang de la colonne dans une ligne du fichier

45,47 Longueur du champ (facultatif)

Exemple

CHAMP_FICHIER CODE_TIERS 015

Le code tiers sera en 15ème position dans chaque ligne du fichier.

CODE_VENTILATION

21 à 23 Code ventilation - Comptabilité PN

CODE_JOURNAL_1000

21,30 Code journal

CODE_JOURNAL_VENICE

Pour la compta Venice (code 6)

21,25 Journal compta Venice facture (optionnel)

27,29 Journal compta Venice avoir (optionnel)

CODESJOURNAUX

Ces codes se substituent à celui de la fiche société (qui doit être saisi malgré tout).

18 à 20 Code Journal régime fiscal TAXABLE

21 à 23 Code Journal régime fiscal EXPORTATION

24 à 26 Code Journal régime fiscal SUSPENSION

27 à 29 Code Journal régime fiscal INTRACOMMUNAUTAIRE

30 à 32 Code Journal régime fiscal EXONERE

COD_SECT_ANAL_S1000

21,60 Code de la section analytique

Utilisé pour le fichier d'interface Sage ligne 1000

COLLECT_AFFACTURAGE

21,28 Compte collectif pour l'affacturage

Le TSC CCA sur le fiche tiers est prioritaire.

Fonctionne uniquement avec Sage ligne 1000

COLLECTIF_CLIENT

Compte collectif client

17,24 Collectif National

25,32 Collectif Export

33,40 Collectif Suspension de taxe

41,48 Collectif Intracommunautaire

49,56 Collectif Exonération

Si les collectifs par type de taxe ne sont pas renseignés, le collectif national est pris par défaut.

Le collectif sur le TSC CCL (fiche client) est prioritaire.

COMPTE_REMISE

Numéro de compte remise. Par défaut : A1[25,32]

21,28 Compte général

29,36 Compte export

37,44 Compte suspension

45,52 Compte intracommunautaire

53,60 Compte exonéré

COMPTE_ESCOMPTE

Numéro de compte escompte. Par défaut : A1[33,40]

21,28 Compte général

29,36 Compte export

37,44 Compte suspension

45,52 Compte intracommunautaire

53,60 Compte exonéré

COMPTES_ECART_CONV.

(Ne pas oublier le point final !!!)

Pour les compta VOLUCOMPTA/VALC, EURINFO, TOTEM, SAGE 500, SAGE 100, LUMIERE

Gestion de l'euro et des devises. Uniquement si #CF EUR A1[25] = O (oui)

21,28 Compte d'écart de conversion débiteur

29,36 Compte d'écart de conversion créditeur

Exemple COMPTES_ECART_CONV. 6780000077800000

_COMPTE_VENTE_AVO

Paramétrage du compte de vente pour les avoirs.

Pour l'ordre de recherche du compte de vente pour les avoirs, voir cette page

CPTE_REMISE_GRPE

21 à 28 Numéro de compte remise groupe

Exemple CPTE_REMISE_GRPE 99999999

Si cette note n'existe pas, ou si le client n'est pas un client groupe, ou si le paramétrage n'est pas valide, le numéro de compte remise est celui par défaut.

CTRL_CHAFIC_UNICITE

21 Contrôle de l'unicité des champs (c'est-à-dire le nom du champ doit être unique).

O Chaque nom de champ doit être unique (par défaut)

N Pas de contrôle

Fonctionne avec la note CHAMP_FICHIER

Utilisé pour le fichier d'interface Sage ligne 1000 et Ciel

EURINFO_

EURINFO_NUM_USINE

EURINFO_CLI

EURINFO_CLE

Pour la compta EURINFO (type U). Plusieurs notes :

EURINFO_NUM_USINE (obligatoire)

21 à 60

EURINFO_CLI

13 à 18 cli

20 à 29 cpt_ven

31 à 40 cpt_tva

42 à 44 cpt_ana

46 à 48 code_taxe

EURINFO_CLE

13 à 18 cli

20 à 29 cpt_ven

31 à 40 cpt_tva

42 à 44 cpt_ana

46 à 48 code_taxe

FICH_TRAN

Paramétrage du fichier de transfert

10 Type de transfert

1 Transfert standard

2 Transfert comptabilité SAARI (HT-ANA).

Uniquement si option Ot2 sur tr_fcnn_vl.

11 à 60 Chemin complet et nom du fichier transfert.

Exemple /u/atlas/atlas.dbs/tr_facval

Le chemin est paramétrable dans 3 endroits différents ! La priorité est la suivante :

1) Notes commençant par FICH_TRAN du paramètre de lancement de tr_fcnn_vl

2) Notes commençant par FICH_TRAN du #CF_TRF (c'est ici)

3) #CF TRF A2[1,52] (à éviter car limité à 52 caractères, alors que les notes peuvent être cumulées pour permettre des chemins d'accès longs)

GUILLEMET

21 Les zones sont entre guillemets (O/N, N par défaut)

SAGE100, CCMX et sa variante H.

Voir aussi la note SEPARATEUR.

INTRASTAT_CODE_AVOIR

21,60 Section Intrastat, code pour les avoirs (obligatoire pour la compta Venice)

INTRASTAT_CODE_FAC

21,60 Section Intrastat, code pour les factures (obligatoire pour la compta Venice)

_JDE_PARAM_

21,25 Code société JDE. Il sera utilisé si la commande n'a pas de site. Tableau de bord du multisite

26,26 Notion de Groupe/Hors Groupe pour la tranche de Nos de compte inférieure à 1000

27,27 Notion de Groupe/Hors Groupe pour la tranche de Nos de compte supérieure à 1000

28,35 Numéro d'ID Compte

36,45 Numéro d'ID interface ou utilisateur

46,49 Classe pour la tranche de numéro de compte inférieure à 1000

50,53 Classe pour la tranche de numéro de compte supérieure à 1000

L1

3,60 Lignes de texte qui seront mises en début du fichier de transfert

Interdit avec SAGE 100 interface type 2

Pour SAGE 100 STANDARD : cette ligne de note est détournée de sa vocation initiale : elle doit contenir le numéro de dossier correspondant au nom du fichier MAE.

ELLE DOIT ALORS FIGURER EN PREMIERE POSITION DES LIGNES DE NOTES !!!

L2

CCMX uniquement

3,60 Lignes de texte qui seront mises en début du fichier de transfert

On peut cumuler plusieurs lignes

L3

CCMX uniquement

3,60 Lignes de texte qui seront mises en début du fichier de transfert

On peut cumuler plusieurs lignes

LD_COMPTA_PARAM_GEN

Paramétrage transfert LD Compta

21 à 26 Compte collectif client

Exemple : LD_COMPTA_PARAM_GEN 411000

MODE_FIC_SAGE_1000

21 Mode du fichier de transfert

Utilisé pour le fichier d'interface Sage ligne 1000

1 (ou vide) structure du fichier figé (par défaut)

2 mode paramétrable, c'est-à-dire l'utilisateur peut choisir l'ordre de l'apparition des champs.
Voir la note CHAMP_FICHIER

MONTANT_NEGATIF_AVO

21 Le montant sera négatif dans le fichier de transfert si c'est un avoir (O/N, N par défaut).

Nota : ne pas oublier de mettre un using du type : -<<<<<<&.&& si valeur à O.

NATURE_DOCUMENT

21,23 Nature du document (ZZZ par défaut)

NUMERO_SOCIETE_PN

21 N° de société - Compta PN uniquement

PARAM_SAGE_1000

Paramétrage du radical de compte de tiers et du type de nature (FAC/AVO)

21,23 Radical à ajouter au compte comptable client (exemples : C , 411 ..)

24 Type de Nature de Pièce

1 FAC pour Facture et AVO pour Avoir

2 FA pour Facture et AV pour Avoir

RAD_CPT_AI-COMPTA

Possibilité de paramétrer le radical des comptes HT et des autres comptes de la comptabilité AI-COMPTA

21,22 Radical des comptes HT - Facultatif

Si le radical est renseigné, celui-ci ne doit pas contenir de blanc

70 si non renseigné

23,24 Radical des autres comptes - Facultatif

Si le radical est renseigné, celui-ci ne doit pas contenir de blanc

43 si non renseigné

REEL:

REEL:NUMERO_SOCIETE:

REEL:ETABLISSEMENT :

REEL:SEC ANALYTIQUE:

Paramétrage transfert compta REEL (3 lignes de notes)

21 à 25 Numéro de la société

21 à x Code établissement (attention, il y a un espace avant les deux points !)

21 à x Section analytique

REMP_CL_VP_PAR_CCCL

21 Remplacer la zone Client VoluPack par le code comptable du client livré suivi du nom de sa ville (O/N, N par défaut)

Le but est d'avoir la possibilité de remplacer la zone Client VoluPack en position 674 du fichier FICH_TRAN1 paramétré en note de #CF TRF par le code comptable du client livré suivi du nom de sa ville.

SAGE_100_PARAM_GEN

Paramétrage général transfert compta SAGE 100 - OGLIBATOIRE !

21 Type d'interface (1 ou 2)

22 à 24 Si type d'interface 2 : N° de version compta Sage 100

25 Si type d'interface 2 : Mise à jour des registres de taxes (O/N)

Si oui, voir les notes CODE_TVA_A et CODE_TVA_F sur le paramètre TVA.

26 Si type d'interface 2 : Mode de recherche du plan analytique

1 valeur ff1.sect_ana

2 note FAM : ANA_SAGE_100

SAGE_500_EQUIV_

SAGE_500_EQUIV_TTC

SAGE_500_EQUIV_TVA

SAGE_500_EQUIV_HT

Gestion de l'axe 1 analytique via une table d'équivalence des comptes TTC, HT et TVA

Paramétrage général, caractères 23 & 24 doit être = 03.

Pour chacune des 3 équivalences (TTC, TVA et HT), il faut :

Renseigner les comptes (client, TVA ou vente) et les comptes équivalents

Laisser à blanc le compte (client, TVA ou vente) et renseigner le compte équivalent, qui sera alors le compte par défaut si le compte équivalent n'existe pas.

Exemple

SAGE_500_EQUIV_TTC 41100000

SAGE_500_EQUIV_TTC 10100702 41100001

SAGE_500_EQUIV_TTC D0611 41100002

SAGE_500_EQUIV_TTC D3011 41100003

Dans cet exemple, le compte 41100000 sera utilisé comme compte client équivalent par défaut si l'un des comptes 10100702, D0611 ou D3011 n' existe pas.

Caractères 1 à 20 SAGE_500_EQUIV_TTC

Caractères 21 à 28 Compte client

Caractères 31 à 38 Compte équivalent

Caractères 1 à 20 SAGE_500_EQUIV_TVA

Caractères 21 à 28 Compte TVA

Caractères 31 à 38 Compte équivalent

Caractères 1 à 20 SAGE_500_EQUIV_HT

Caractères 21 à 28 Compte vente

Caractères 31 à 38 Compte équivalent

SAGE_500_PARAM_GEN

Paramétrage général transfert compta SAGE 500

21 à 22 Type code journal

01 Code journal de la fiche société ou suivant le mode d'exonération de la facture

02 Code journal du site de production ( SIT alpha3[15,20]) - Tableau de bord du multisite

Celui-ci est saisi sur l'entête de la commande

23 à 24 Type code analytique

01 Code analytique Standard (3 caractères)

02 Code analytique Spécifique (6 caractères) :

Code Société (1 caractère, toujours à 1)

Code Site (1 caractère) - Tableau de bord du multisite

(SIT alpha3[21] du paramètre de la commande de la ligne de facture)

Code Section (2 caractères) (05 si article fabriqué, 06 si article acheté)

Code Sous-section (2 caractères)

(MAT alpha2[12,13] de l'article de la ligne de facture)

03 Gestion de l'axe 1 analytique via table d'équivalence des comptes TTC, HT et TVA

Voir les notes SAGE_500_EQUIV

25 à 26 Type attribution compte remise

01 Pas d'ajout de delta sur le compte remise

02 Ajout d'un delta sur le compte remise selon que l'article est fabriqué ou acheté

Créer une note commençant par SAGE_500_REMISE_02

27 à 28 Type format dates écriture et échéance

01 Dates sous la forme JJMMAAAA

02 Dates sous la forme AAAAMMJJ

29 à 31 Les 3 combinaisons suivantes sont possibles : ONN, NNN, OOO

Exemple : SAGE_500_PARAM_GEN 02020202NNN
29 Déduction des remises ligne sur le HT (O/N, N par défaut)

30 Suppression de la remise globale sur le HT (O/N, N par défaut)

31 Suppression de l' escompte sur le HT (O/N, N par défaut)

32 à 33 Type de centre analytique axe_3

01 axe 3 non renseigné (par défaut)

02 ajoute le code client groupe en caractères 185 à 200

03 ajoute le code client/fournisseur en caractères 185 à 200

34 à 35 Section compte écart de conversion (débit)

36 à 37 Sous-section compte écart de conversion (débit)

38 à 39 Section compte écart de conversion (crédit)

40 à 41 Sous-section compte écart de conversion (crédit)

42 Modèle d'interface

1 Modèle Standard

2 Modèle spécifique

3 Sage 500 Intégrale

SAGE_500_REMISE_02

Paramétrage des deltas à ajouter au compte de remise

21 à 28 Delta à ajouter au compte remise si l'article de la ligne de facture est un article fabriqué

29 à 36 Delta à ajouter au compte remise si l'article de la ligne de facture est un article acheté

Exemple SAGE_500_REMISE_02 0000010000000700

SAP_PARAM_GEN_COMPA

21,24 Champ BUKRS du type de record 1 Document Header Record

SAP_PARAM_GEN_DISTR

21,22 Champ WKORG du type de record 2 Document Item Record

SAP_PARAM_GEN_DIV

21,22 Champ SPART du type de record 2 Document Item Record

SAP_PARAM_GEN_PLANT

21,24 Champ WERKS du type de record 2 Document Item Record

SAP_PARAM_GEN_PROFI

21,31 Champ PRCTR du type de record 2 Document Item – GL Element Record

SAP_PARAM_GEN_SALES

21,24 Champ WSKTO du type de record 2 Document Item Record

SAP_PARAM_GEN_SAP3_1

21,32 Sert à alimenter la zone GROUP de l'enregistrement FILE_HEADER-BGR00 de l'interface SAP Type 3

SAP_PARAM_GEN_SAP3_2

21,23 Sert à alimenter la zone MANDT de l'enregistrement FILE_HEADER-BGR00 de l'interface SAP Type 3

SAP_PARAM_GEN_SAP3_3

21,32 Sert à alimenter la zone USNAM de l'enregistrement FILE_HEADER-BGR00 de l'interface SAP Type 3

SAP_PARAM_GEN_SAP3_4

21,24 Sert à alimenter la zone BUKRS de l'enregistrement DOCUMENT_HEADER-BBKPF de l'interface SAP Type 3

Sert à alimenter les zones RKE_BUKRS et VBUND de l'enregistrement DOCUMENT_ITEMS-BBSEG de l'interface SAP Type 3

SAP_PARAM_GEN_SAP3_5

21,24 Sert à alimenter les zones GSBER, WEKRS et RKE_WERKS de l'enr. DOCUMENT_ITEMS-BBSEG de l'interface SAP Type 3

SAP_PARAM_GEN_SAP3_NEWKO

25 Sert à alimenter la zone NEWCO de l'enregistrement DOCUMENT_ITEMS-BBSEG de l'interface SAP Type 3

Valeur 4 ou 6, 6 par défaut

6 sera alimenté avec =6. suivi du siret

4 sera alimenté avec =4. suivi du code client

SAP_PARAM_GEN_SITE

21,23 Code du site - Tableau de bord du multisite

SAP_PARAM_GEN_SYSID

21,31 Champ SYSID du type de record 0 Batch Header Record

SAP_PARAM_GEN_TYPE

21 Type d'interface

1 Mondi

2 CMCP

3 SAP Type 3

Voir aussi:

les 5 notes ci-dessus commençant par SAP_PARAM_GEN_SAP3

ECH A3[1,3] (Nombre de jours d'échéance)

MRG note CODE_MRG_SAP

Fiche société : Code compta = 4

SECT_PAR_DEFAUT

21,28 Valeur par défaut du code compta analytique.

Supprimé le 28/02/2012. Remplacé par le code douanier de la sous-famille ou famille de l'article.

SEPARATEUR

21 Caractère de séparation des zones. Par défaut, le séparateur est la virgule.

S sans séparateur

Pour CCMX, ce paramètre n'est pas pris en compte : c'est toujours le point-virgule.

Voir aussi la note GUILLEMET.

SETEC:

SETEC:NUMERO SOCIETE:

SETEC:CODE DIVISION:

Paramétrage transfert compta SETEC (2 lignes de notes)

22 à 25 Numéro de la société

21 à 23 Code division

TOP_MOIS

Paramétrage top fin de mois

9 à 11 Code paramètre top fin de mois

Exemple TOP_MOISFAC

TOTEM_

TOTEM_PARAMETRES_GEN

TOTEM_COMPTES_HT

TOTEM_COMPTES_REM

TOTEM_COMPTES_ESC

'

Paramétrage des comptes de vente

7 à 20 COMPTES_HT

21 à 23 Catégorie client (GRR, VAL ou * pour toutes catégories clients)

24 Régime TVA (N, O, S, I, E ou * pour tous régimes TVA)

N Taxable

O Export

S Suspension

I Intracommunautaire

E Exonéré

25 à 27 Code TVA (XXX ou * pour tous codes TVA)

28 à 30 Famille d'article (XXX ou * pour toutes familles d'articles)

31 à 33 Sous-famille d'article (XXX ou * pour toutes sous-familles d'articles)

34 à 43 Numéro de compte de vente (XXXXXXXXXX)

44 à 46 Code analytique 1 (G, D, J, S ou V)

47 à 49 Code analytique 2 (M2 ou NU)

50 à 52 Code analytique 3 (KG ou NU)

53 à 55 Code analytique 4 (ZZ, G, D, J, S ou V)

56 à 58 Code TSC du collectif client

La recherche du compte de vente se fait sur

La catégorie client (GRR, VAL et autres)

Le régime TVA (N, O, S, I et E)

Le code TVA de la ligne de facture

Le code famille de la ligne de commande facturée

Le code sous-famille de la ligne de commande facturée

Exemples

TOTEM_COMPTES_HT GRRN1 PAPBLA701001 G M2 KG ZZ SET

TOTEM_COMPTES_HT GRRN2 PAPCB 701002 G M2 KG G

TOTEM_COMPTES_HT GRRN* * * 701003 G M2 KG G

TOTEM_COMPTES_HT GRRO* * * 701004 G M2 KG G

TOTEM_COMPTES_HT GRRE* * * 701005 G M2 KG G

TOTEM_COMPTES_HT GRRS* * * 701006 G M2 KG G

TOTEM_COMPTES_HT GRRI* * * 701007 G M2 KG G

TOTEM_COMPTES_HT VALN1 PAPBLA702001 D M2 KG ZZ SET

TOTEM_COMPTES_HT VALN2 PAPCB 702002 D M2 KG D

TOTEM_COMPTES_HT VALN* * * 702003 D M2 KG D

TOTEM_COMPTES_HT VALO* * * 702004 D M2 KG D

TOTEM_COMPTES_HT VALE* * * 702005 D M2 KG D

TOTEM_COMPTES_HT VALS* * * 702006 D M2 KG D

TOTEM_COMPTES_HT VALI* * * 702007 D M2 KG D

TOTEM_COMPTES_HT * N1 PAPBLA703001 J M2 KG ZZ SET

TOTEM_COMPTES_HT * N2 PAPCB 703002 J M2 KG J

TOTEM_COMPTES_HT * N* * * 703003 J M2 KG J

TOTEM_COMPTES_HT * O* * * 703004 J M2 KG J

TOTEM_COMPTES_HT * E* * * 703005 J M2 KG J

TOTEM_COMPTES_HT * S* * * 703006 J M2 KG J

TOTEM_COMPTES_HT * I* * * 703007 J M2 KG J

Paramétrage des comptes de remise

7 à 20 COMPTES_REM

21 à 23 Catégorie client (GRR, VAL ou * pour toutes catégories clients)

24 Régime TVA (N, O, S, I, E ou * pour tous régimes TVA)

N Taxable

O Export

S Suspension

I Intracommunautaire

E Exonéré

25 à 27 Code TVA (XXX ou * pour tous codes TVA)

28 à 30 Type d'article (M, P, S, F, X, O, T, K ou * pour tous types d'articles)

M Matière

P Produit fini

S Semi fini

F Fourniture

X Article fantôme

O Outil

T Article de maintenance

K Kit

31 à 33 * sur toutes lignes de remise

34 à 43 Numéro de compte de remise (XXXXXXXXXX)

44 à 46 Code analytique 1 (G ou D)

47 à 49 Code analytique 2 (NU)

50 à 52 Code analytique 3 (NU)

53 à 55 Code analytique 4 (G ou D)

56 à 58 Non utilisé

La recherche du compte de remise se fait sur

La catégorie client (GRR, VAL et autres)

Le régime TVA (N, O, S, I et E)

Le code TVA de la ligne de facture

Le type d'article (M, P, S, F, X, O, T et K)

Exemples

TOTEM_COMPTES_REM * N* P * 709100 G NU NU G

TOTEM_COMPTES_REM * O* P * 709107 G NU NU G

TOTEM_COMPTES_REM * E* P * 709108 G NU NU G

TOTEM_COMPTES_REM * S* P * 709108 G NU NU G

TOTEM_COMPTES_REM * I* P * 709109 G NU NU G

TOTEM_COMPTES_REM * N* M * 709700 D NU NU D

TOTEM_COMPTES_REM * O* M * 709707 D NU NU D

TOTEM_COMPTES_REM * E* M * 709708 D NU NU D

TOTEM_COMPTES_REM * S* M * 709708 D NU NU D

TOTEM_COMPTES_REM * I* M * 709709 D NU NU D

TOTEM_COMPTES_REM * ** * * 709999 D NU NU D

Paramétrage des comptes d'escompte

7 à 20 COMPTES_ESC

21 à 23 Catégorie client (GRR, VAL ou * pour toutes catégories clients)

24 Régime TVA (N, O, S, I, E ou * pour tous régimes TVA)

N Taxable

O Export

S Suspension

I Intracommunautaire

E Exonéré

25 à 27 Code TVA (XXX ou * pour tous codes TVA)

28 à 30 Type d'article (M, P, S, F, X, O, T, K ou * pour tous types d'articles)

M Matière

P Produit fini

S Semi fini

F Fourniture

X Article fantôme

O Outil

T Article de maintenance

K Kit

31 à 33 * sur toutes lignes d'escompte

34 à 43 Numéro de compte d'escompte (XXXXXXXXXX)

44 à 46 Code analytique 1 (V)

47 à 49 Code analytique 2 (NU)

50 à 52 Code analytique 3 (NU)

53 à 55 Code analytique 4 (V)

56 à 58 Non utilisé

La recherche du compte d'escompte se fait sur

La catégorie client (GRR, VAL et autres)

Le régime TVA (N, O, S, I et E)

Le code TVA de la ligne de facture

Le type d'article (M, P, S, F, X, O, T et K)

Exemples

TOTEM_COMPTES_ESC * N* * * 665000 V NU NU V

TOTEM_COMPTES_ESC * O* * * 665007 V NU NU V

TOTEM_COMPTES_ESC * E* * * 665008 V NU NU V

TOTEM_COMPTES_ESC * S* * * 665008 V NU NU V

TOTEM_COMPTES_ESC * I* * * 665009 V NU NU V

La 1ère recherche se fait toujours sur le code.

Si celui-ci n'est pas trouvé, la 2ème recherche se fait sur l'astérisque.

TSC_COMPTE_COMPTABLE

21,23 Code du TSC

TSC_SECT_ANALYTIQUE

21,23 Code du TSC

Voir A4[15,16]

TYPE_LIB_PIECE

21 Type de libellé de la pièce

Utilisé pour le fichier d'interface Sage ligne 1000

0 (ou vide) nom du client ou si option Ofl alors nom du client – numéro de facture. (par défaut)

1 code client – nom du client – numéro de facture

USING_DATE

Using pour les dates (par défaut : dd/mm/yyyy)

Utilisé pour le fichier d'interface Sage ligne 1000 et Ciel

USING_NOMBRE

Using pour les nombres (par défaut : <<<<<<<<<<<&.&&)

Utilisé pour le fichier d'interface Sage ligne 1000 et Ciel

VAL_DEF_xx

21,60 où x est un nombre compris entre 01 et 99 : Valeur fixe dans le fichier de transfert

Utilisé pour le fichier d'interface Sage ligne 1000 et Ciel

VENICE_REF_SER

Référence de commande de Servibox (optionnel)

Le TSC VCS est prioritaire. Voir la note CODE_TSC_VCS

Utilisé pour la compta Venice (code 6)

ZONE_LIBRE_1

Permet de paramétrer le contenu de la colonne zone_libre par la première ligne d'une note.

Utilisé pour le fichier d'interface Sage ligne 1000

21,23 Code paramètre de type NTS.

25,26 Source de la note.

EC entête de commande

LC ligne de commande


#CF VAL Ecritures des comptes clients

A paramétrer uniquement si logiciel de comptabilité VALC

Valeur alpha 1

Caractères 1 à 50

Chemin et nom de la base de données comptable

Valeur alpha 2

Caractère 1 | Saisie d'un mot de passe (N/O) N Pas de saisie de mot de passe pour accéder à la visualisation O Saisie d'un mot de passe pour accéder à la visualisation
Caractères 2 à 6 | Mot de passe obligatoire si O en caractère 1
Caractère 7 | Ecran de sélection (N/O) N Pas d'écran de sélection O Ouverture d'un écran de sélection
Caractère 8 | Type d'écriture S Saisie du type d'écriture (lettrées et/ou non lettrées) T Toutes les écritures N Uniquement les écritures non lettrées L Uniquement les écritures lettrées
Caractère 9 | Type de tri C Croissant D Décroissant
Caractère 10 | Type de devise société S Saisie du type devise société (ancienne ou nouvelle devise société) A Ecritures dans l'ancienne devise société. Devise FRF par exemple.

Notes

S

Complément de select sur la table histo de la base de donnée de comptabilité
Exemples
S and histo.cjournal VE
S and histo.csection ADM
Attention, si le complément est sur plusieurs lignes, elles sont concaténées sans ajout de blanc entre chacune d'entre elles.


#CF VIS Paramétrage des visualisations

Notes

_NTS_XXX

où XXX = Votre propre nom de note, dont la longueur ne doit pas dépasser 15 caractères.

Caractères 21 à 60 : Paramétrage des types de notes à afficher en visualisation.

Plus d'information ici.


#CF VMC Configuration de Volume Media Center

Valeurs numériques

1

Numéro de port de communication avec le VMC (15000 par défaut)

Valeur alpha 1

#CF VMC A1[1]

Interface avec ArtiosCAD activée (O/N, N par défaut)

#CF VMC A1[2]

Fermer automatiquement VMC à la fermeture du Genero Desktop Client (manuellement ou avec l'option –X du GDC) (VMC 1.0.12)

Permet d'automatiser la fermeture du Volume Media Center lorsque le Genero Desktop Client se termine (l'option –X sur le gdc.exe permet ainsi de fermer le VMC à la fermeture de VoluPack). Ce fonctionnement est spécifique à l'utilisation de Volume Media Center sous un environnement TSE/Citrix.

#CF VMC A1[3]

Gestion de l'interface ArtiosCAD par site activée (O/N, N par défaut)

Tableau de bord du multisite

Notes

EPU_DONNEES_ARTIOS

Code TSC ou LCO de la zone à épurer au format utilisé dans les données paramétrables d'Artios

Lors de la modification d'une étude sous Artios, lorsque nous intégrons les données, il peut y avoir certaines données qui ont été enlevées dans les données paramétrables (TSC et/ou LCO).

Mais, comme on ne met à jour que les données reçues, certaines demeurent à tort dans le devis.

Pour corriger cela, cette ligne de notes indique la liste des données TSC et LCO à épurer lors d'une récupération des données Artios.


#CF WEB Configuration Web

Ce fichier de configuration est destiné à VoluPack en mode Web.

L'accès à VoluPack en mode WEB est soumis à l'activation de l'option WEB-1.

Le guide de l'administrateur se trouve ici :

M:\Documentation d'installation et d'évolution\20-Volupack WEB\INS_LR_Volupack Web - Guide d'administration.docx

Notes sur le #CF WEB

_WEB_BOUCLES_CANAL | 21,22 Nombre de tentatives de lecture des PDF pour les éditions VoluEdit. (Valeur par défaut 90 – entre chaque tentative il y a une temporisation non paramétrable de 2 secondes)
_WEB_BOUCLES_LP | 21,22 Nombre de tentatives de lecture du PDF pour les éditions classiques et APPIC. (Valeur par défaut 30 – entre chaque tentative il y a une temporisation non paramétrable de 2 secondes)
_WEB_REP_DEPOSE | 21,60 Répertoire de lecture des fichiers PDF générés par le système d'impression
_WEB_TEMPO_CANAL | 21,22 Temps nécessaire, en secondes, à la génération du premier PDF pour les éditions VoluEdit. Exécutée uniquement avant la première tentative de lecture des PDF. (Paramètre obligatoire – dépend du temps de scrutation du démon de gestion des demandes CANAL_COMM)

Notes sur le #LW (homologue du #LP

Le type de paramètre #LW, homologue du #LP, doit impérativement être créé, cela se fait en utilisant le programme G_par01.

Il est conseillé de créer au moins l'imprimante par défaut, paramètre #LW DEF, et de la paramétrer pour la génération des PDF.

_WEB_IMPRESSION_PDF

21 Groupe d'imprimantes générant des PDF (O/N, N par défaut)

Ce #LW génère des PDF pour le mode WEB, cela active les fonctions de transferts en fin d'édition.

Notes sur les paramètres de lancement

_WEB_JOURNALISATION | 21 Activation de la journalisation pour cette édition O/N. (N par défaut) Ne fonctionne que pour les impressions classiques en PDF et VoluEdit
_WEB_RACINE_DOC | 21,60 Racine des impressions. Permet de différencier les fichiers PDF. Elle sera précédée du code société et suivie d'une identification unique non paramétrable qui dépend du type d'édition. (Cf. chapitres spécifiques, paramétrage obligatoire) Seule la première ligne est prise en compte Principales valeurs conseillées : _ARC Edition des AR _BL Edition des BL _DEV Edition des devis _FAC Edition des factures _OF Edition des OF
VE_WEB | 21 Edition VoluEdit utilisée pour le mode WEB. Force la sortie en mode DIRECTE, active le mode batch et impose le nom du fichier PDF


#CF WSL Configuration WAY SERVER

Exemple :

[Speed7]

Name=Poids lourd

Motorway=110

DualCarriageWay=100

CatARoad=80

CatBRoad=60

SecondaryRoad=55

OtherRoad=50

ExpressWay=80

UrbanRoad=35

SlowUrbanRoad=20

WindingRoads=45

VeryWindingRoads=35

[Consum7]*

Name=Poids lourd

Motorway=35.0

Road=40.0

CityDriving=42.0

Petrol=1.00

PRK=0.00

PRH=0.00

TollClass=4

30=0.124000

31=0.124000

32=0.124000

34=0.124000

36=0.124000

39=0.130000

40=0.124000

41=0.124000

43=0.124000

44=0.124000

45=0.124000

46=0.124000

47=0.124000

48=0.124000

49=0.124000

351=0.000000

#CF WSL Configuration WAY SERVER

>>> Voir la fiche d'installation complète sur la logistique.

Ce paramétrage s'inscrit dans le cadre de la logistique.

Voir le programme geocodage_cli.

Valeur alpha 1

Caractères 1 à 50

Emplacement du répertoire partagé d'échange de fichiers entre VOLUPACK et WAY SERVER

Valeur alpha 2

Caractères 1 à 3 | Temps d'attente maximum (en secondes) pour la réponse de Way Server à une requête de localisation (ou géocodage).
Caractère 4 | Mise à jour dans les tables cli et cli2 des infos code postal et nom de ville récupérés du géocodage (Loxane) (O/N, N par défaut)
Caractères 11 à 40 | Nom du fichier trace pour le géocodage

Valeur alpha 3

Caractères 1 à 3 | Temps d'attente maximum (en secondes) pour la réponse de Way Server à une requête de calcul d'itinéraire
Caractère 4 | Type d'optimisation du calcul d'itinéraire D calcul en distance (par défaut) T calcul en temps P calcul en temps sans péage A calcul en temps sans autoroute
Caractères 5 à 7 | Code du magasin principal
Caractère 8 | Numéro du profil vitesse à prendre en compte (0 par défaut) - Voir la note NOM_PROFIL_VITESSE
Caractères 11 à 40 | Nom du fichier trace pour le calcul d'itinéraire

Valeur alpha 4

Caractère 1 | Mode de calcul standard d'itinéraire avec étape 1 au plus cher 2 au plus loin 3 au jalonnement (par défaut) 4 au lot
Caractère 2 | Forçage de la valorisation des transports au plus loin (O/N, N par défaut)

Notes

NOM_PROFIL_VITESSE

Lorsque l'on fait des calculs d'itinéraires directement dans le logiciel WayPro, l'utilisateur peut non seulement demander un calcul en fonction de la distance ou du temps, mais il peut aussi utiliser des profils de vitesse différents.

Les résultats montrent des différences de calcul qui peuvent être significatives.

Exemple de trajet : Chatenois – La Vancelle – Sarrebourg – Chatenois

En mode standard, Loxane retourne 193km (2H27)

En mode Poids lourd, Loxane retourne 205km (2H34)

Cette option d'optimisation est maintenant activable depuis VoluPack.

Voir A3[8]

19 Numéro du profil vitesse

21,60 Nom du profil vitesse

Dans le fichier ProfilTP.PRM (fourni par Loxane) présent dans le répertoire d'installation du WayServer (au même endroit que le fichier Way.ini), il faut ajouter à la main (s'il n'y est pas déjà) les données propres au profil vitesse utilisé.

Le bloc [Consum7] n'est pas obligatoire.

Le nom paramétré dans la note ci-dessus doit impérativement être le même que celui utilisé dans le fichier ProfilTP.PRM

Cliquez ici pour afficher / masquer un exemple.


#AF Affacturage

But :

  • définir une structure d'accueil des données relatives à l'affacturage

  • utiliser cette structure pour la mise en place dans la facturation Volume Software

Valeur alpha 1

Caractères 1 à 20

Numéro d'adhérent dans la société d'affacturage

Notes

[Pas de mot-clé]

1 à 60 Texte des mentions légales à imprimer sur la facture si gérés par le programme d'édition.

On peut inclure dans ce texte les codes suivants s'ils sont gérés par le programme d'édition :

%n% Pas de saut de ligne avant la note suivante

%dg% Début du mode gras

%fg% Fin du mode gras

%di% Début du mode italique

%fi% Fin du mode italique

%ds% Début du mode souligné

%fs% Fin du mode souligné

En outre, il est nécessaire de créer un TSC #AF avec les notes suivantes :

Notes sur TSC #AF

ZF | 3, 17 Libellé de saisie. Par exemple, Soc Affacturage 18 Saisie obligatoire. Par exemple, N 19,20 Code de contrôle de la zone. Mettre 01 21,23 Complément pour contrôle. Mettre #AF 24 Code affichage. Par exemple, 2 42,56 Libellé d'affichage. Par exemple, Soc Affacturage
#F | 3,47 Texte de la question (dans le nouveau mode de saisie). Par exemple, Société d'affacturage 57,58 Code langue. Par exemple, fr
ZA | 3, 17 Libellé de saisie. Par exemple, à partir du 18 Saisie obligatoire. Par exemple, N 25,39 usingd'affichage de la date. Mettre dd/mm/yyyy 42,56 Libellé d'affichage. Par exemple, à partir du
#A | 3,47 Texte de la question (dans le nouveau mode de saisie). Par exemple, Effective à partir du 57,58 Code langue. Par exemple, fr
ZG | 3, 17 Libellé de saisie. Par exemple, Lib n°adhérent 18 Saisie obligatoire. Par exemple, N 42,56 Libellé d'affichage. Par exemple, Lib n°adhérent
#G | 3,47 Texte de la question (dans le nouveau mode de saisie). Par exemple, Libellé imprimé avant code adhérent 57,58 Code langue. Par exemple, fr


#AP Saisie des phases

Ce paramètre permet de faciliter la saisie du code phase dans la saisie des temps de production.

Lors de la saisie du code phase, une fenêtre s'ouvre et permet la saisie d'un code paramètre (#AP).

Ce paramètre permet d'indiquer quelle est l'opération à rechercher dans l'ordre de fabrication.

La recherche de cette opération est alors lancée : si l'opération est trouvée, son numéro de phase est affiché.

Valeurs numériques

1 | Numéro de phase correspondant - Obligatoire si A2[4] = 2 ou 3. Prioritaire sur le paramétrage de la zone alpha 1
2 | Non utilisé

Valeur alpha 1

A1[1,10] | Premier code de l'opération à rechercher
A1[11,20] | Deuxième code de l'opération à rechercher
A1[21,30] | Troisième code de l'opération à rechercher
A1[31,40] | Quatrième code de l'opération à rechercher
A1[41,50] | Cinquième code de l'opération à rechercher

Valeur alpha 2

A2[1,3]

TTR par défaut - utilisé dans sjs

A2[4]

Mode de création de la phase

1 Recherche du numéro de phase (fonctionnement standard - valeur par défaut)

Si un numéro de phase a été paramétré en valeur numérique 1, on initialise le numéro de phase de l'opération avec celui-ci.

Si aucun numéro de phase n'a été paramétré, on recherche si un des codes opérations à rechercher en valeur alpha 1 est présent dans les opérations du dossier.

2 Création de la phase avec demande de confirmation

Si l'opération n'existe pas, la phase sera créée après confirmation.

Le numéro de phase est paramétré en valeur numérique 1.

Le code section, le code opération et le code sous-opération sont paramétrés en A1[1,9].

Le code difficulté est paramétré sur le paramètre de lancement de sjs en A4[1,3].

Le code machine est celui saisi après la saisie du code #AP.

3 Création de la phase sans demande de confirmation

Si l'opération n'existe pas, la phase sera créée sans demande de confirmation.

Le numéro de phase est paramétré en valeur numérique 1.

Le code section, le code opération et le code sous-opération sont paramétrés en A1[1,9].

Le code difficulté est paramétré sur le paramètre de lancement de sjs en A4[1,3].

Le code machine est celui saisi après la saisie du code #AP.

Remarque pour les modes 2 et 3 : le numéro de phase (valeur numérique 1) et le 1er code opération (A1[1,9]) doivent être renseignés. Dans le cas contraire, le mode création de phase est mis à 1 (fonctionnement standard).

Valeur alpha 3

A3[1,6] | Code machine par défaut
A3[7] | Permettre la saisie du code machine (O/N, O par défaut) Si le code machine par défaut n’est pas renseigné, la machine est toujours saisissable.


#CP Catégories de types de paramètres

Il s'agit des catégories regroupant les grands types de paramètre.

C'est la 3ème zone apparaissant à l'écran lorsque l'on crée un type de paramètre (PAR01).

Seul le libellé est utilisé.

Pas de paramétrage

Exemples de codes

CAR Carton

CLI Client

IMP Imprimerie

MEC Mécanique

SYS Système


#DE Paramétrage des devis

Ce type de paramètre est utilisé dans le calcul du devis arts graphiques.

Le premier caractère des codes paramétrés est figé.

F?? -> Utilisé pour rechercher les codes film pour la photogravure.

Valeur numérique 1

Borne inférieure surface

Valeur numérique 2

Borne supérieure surface

Valeur alpha 1

Caractères 1 à 15

Code du film à utiliser

Exemples

Code | Film | Surface | de | à
F01 | FILM01 |  | 0 | 432cm2
F02 | FILM02 |  | 432 | 1200cm2


#EM Emballages

#EM PAL

Volume des palettes

Valeur numérique 1 : Volume de la palette

Exemple : 1800 pour 1,8 M3

#EM C/P

Nombre de caisses par palette

Valeur numérique 1 : Nombre de caisses par palette

Le code de la caisse dépend du nombre de caisses

#EM CA*

Code de la caisse à prendre en compte

Valeur numérique 1 : Borne inférieure

Valeur numérique 2 : Borne supérieure

Valeur alpha 1 : Code caisse

Exemples

#EM CA1

Valeur numérique 1 : 0

Valeur numérique 2 : 200

Valeur alpha : C1

Entre 0 et 200 caisses, on prend la caisse C1.

#EM CA2

Valeur numérique 1 : 200.01

Valeur numérique 2 : 500

Valeur alpha : C2

Entre 200 et 500 caisses, on prend la caisse C2.


#F1 Formats finis standards

Valeur numérique 1

Largeur du format (en mm)

Valeur numérique 2

Longueur du format (en mm)


#F2 Diamètres standards du mandrin

Valeur numérique 1

Diamètre intérieur du mandrin (en mm)

Valeur numérique 2

Diamètre extérieur du mandrin (en mm)


#F3 Pourcentage de marge standard

Valeur numérique 1

Pourcentage de marge standard (utilisé par le devis standard)


#LI Liens entre tables

Dans les programmes mat et v_mat, l'option -Otl doit être activée.

Valeur alpha 1

Caractères 1 à 3

Code lien réciproque

Permet d'indiquer le lien réciproque, que vous devrez créer avec cette zone à blanc et en inversant les valeurs alpha 3 et 4.

Le lien réciproque sera automatiquement créé lorsque vous créerez le lien initial.

Exemple

Lien de outil vers lieu de rangement | Lien de lieu de rangement vers outil
#LI O/L | #LI L/O
A1[1,3] = L/O | [à blanc]
A3[1,18] = mat | A3[1,18] = lieu_rgt_e
A4[1,18] = lieu_rgt_e | A4[1,18] = mat

Caractère 4

O La saisie du détail du lien est possible.

Elle permet d'accéder à :

une zone de 60 caractères

deux zones paramètre de 3 caractères (voir le paramétrage des notes pour le type paramètre)

six zones numériques

N La saisie permet uniquement de saisir les liens entre la table mère et la table fille. (par défaut)

Caractère 5

Ce lien doit être recopié lors de la recopie des liens entre tables (O/N, O par défaut)

Valeur alpha 2

Caractères 1 à 60

Titre de la fenêtre de saisie des liens entre tables

Par défaut : SAISIE DES LIENS ENTRE TABLES

Valeur alpha 3

Caractères 1 à 18 | Nom de la table Atlas mère
Caractères 19 à 21 | Type de paramètre quand le nom de la table mère est par02.

Valeur alpha 4

Caractères 1 à 18 | Nom de la table Atlas fille
Caractères 19 à 21 | Type de paramètre quand le nom de la table fille est par02.

Notes

TITRE_SAI_CODE_PERE | 21, 36 Libellé du champ code père. Exemple : Code outil
TITRE_SAI_LIB_PERE | 21, 60 Libellé du champ désignation du code père. Exemple : Désignation outil
TITRE_SAI_CODE_FILS | 21, 36 Libellé de la colonne code fils. Exemple : Code machine
TITRE_SAI_LIB_FILS | 21, 60 Libellé de la colonne désignation du code fils. Exemple : Désignation machine
_SUP_REQ_RECH_PERE | 21, 60 Complément de requête pour la recherche des codes pères (exemple pour la recherche d'un article : and mp_mp = "O"
_SUP_REQ_RECH_FILS | 21, 60 Complément de requête pour la recherche des codes fils (exemple pour la recherche d'une machine : and m0_machine matches "COL*"
TYPE_PAR_ALPHA2 TYPE_PAR_ALPHA3 | 21, 23 Code paramètre du champ alpha 2 21, 23 Code paramètre du champ alpha 3
LIBELLE_ALPHA1 LIBELLE_ALPHA2 LIBELLE_ALPHA3 | 21, 30 Libellé de la zone alphanumérique 1 21, 30 Libellé de la zone paramètre 1 21, 30 Libellé de la zone paramètre 2
LIBELLE_NUM1 LIBELLE_NUM2 LIBELLE_NUM3 LIBELLE_NUM4 LIBELLE_NUM5 LIBELLE_NUM6 LIBELLE_NUM7 LIBELLE_NUM8 LIBELLE_NUM9 LIBELLE_NUM10 LIBELLE_NUM11 LIBELLE_NUM12 LIBELLE_NUM13 LIBELLE_NUM14 | 21, 30 Libellé de la zone numérique 1 21, 30 Libellé de la zone numérique 2 21, 30 Libellé de la zone numérique 3 21, 30 Libellé de la zone numérique 4 21, 30 Libellé de la zone numérique 5 21, 30 Libellé de la zone numérique 6 21, 30 Libellé de la zone numérique 7 21, 30 Libellé de la zone numérique 8 21, 30 Libellé de la zone numérique 9 21, 30 Libellé de la zone numérique 10 21, 30 Libellé de la zone numérique 11 21, 30 Libellé de la zone numérique 12 21, 30 Libellé de la zone numérique 13 21, 30 Libellé de la zone numérique 14


#LP Configuration des imprimantes

Voir aussi le paramètre #CF IMP

Valeurs numériques

1 | Longueur de la page en nombre de lignes. Pris par défaut si zone alpha 3 ou 4 non remplie
2 | Longueur de la page en nombre de lignes pour une éventuelle deuxième édition au sein d'un même programme (2 éditions en parallèle dans le même programme) Pris par défaut si zone alpha 3 ou 4 non remplie

Valeur alpha 1

Caractères 1 à 20 | Imprimante 1 : Commande d'impression (pour etiq : Nom de la maquette étiquette palette)
Caractères 21 à 25 | Imprimante 1 : Nom de l'imprimante (qui doit être paramétrée dans la table des imprimantes) (pour etiq : VEDIT)
Caractères 26 à 45 | Imprimante 2 : Commande d'impression
Caractères 46 à 50 | Imprimante 2 : Nom de l'imprimante (qui doit être paramétrée dans la table des imprimantes)

Exemple de commande d'impression : lp –dlp0

Exemple de nom d'imprimante : HP6

Valeur alpha 2

Caractères1 à 20 | Imprimante 3 : Commande d'impression
Caractères 21 à 25 | Imprimante 3 : Nom de l'imprimante (qui doit être paramétrée dans la table des imprimantes)
Caractères26 à 45 | Imprimante 4 : Commande d'impression
Caractères 46 à 50 | Imprimante 4 : Nom de l'imprimante (qui doit être paramétrée dans la table des imprimantes)
Caractère 51 | Ouverture fenêtre choix imprimante : N ou [espace] = Non, O = Oui Permet, lorsque le système accède à cette imprimante, d'ouvrir une fenêtre de choix parmi toutes les imprimantes disponibles dans l'entreprise.
Caractère 52 | Permet d'exclure certaines imprimantes du choix proposé si alpha2[51] = O ou si l'utilisateur choisit le bouton Autres imprimantes. O Imprimante exclue du choix N ou [espace] Imprimante inclue dans le choix
Caractère 53 | Imprimante associée à une ligne de commande O/N Voir les notes dédiées à ce type d'impression

Valeur alpha 3

Caractères 1 à 6 | Imprimante 1 : Longueur page
Caractères 7 à 12 | Imprimante 1 : Longueur page 2
Caractères 13 à 30 | Imprimante 1 : Chaîne d'initialisation
Caractères 31 à 36 | Imprimante 2 : Longueur page
Caractères 37 à 42 | Imprimante 2 : Longueur page 2
Caractères 43 à 60 | Imprimante 2 : Chaîne d'initialisation

Valeur alpha 4

Caractères 1 à 6 | Imprimante 3 : Longueur page
Caractères 7 à 12 | Imprimante 3 : Longueur page 2
Caractères 13 à 30 | Imprimante 3 : Chaîne d'initialisation
Caractères 31 à 36 | Imprimante 4 : Longueur page
Caractères 37 à 42 | Imprimante 4 : Longueur page 2
Caractères 43 à 60 | Imprimante 4 : Chaîne d'initialisation

Notes

L1

Libellé de l'imprimante 1 sur 20 caractères maxi

L2

Libellé de l'imprimante 2 sur 20 caractères maxi

L3

Libellé de l'imprimante 3 sur 20 caractères maxi

L4

Libellé de l'imprimante 4 sur 20 caractères maxi

APPIC_DEF_BACx_y_

avec :

x = 1 ou 2 selon que l'on paramètre le premier ou le deuxième bac

y représente le numéro d'imprimante

21 Numéro du bac APPIC

ATTENTION A CES 2 NOTES : ELLES SE RESSEMBLENT MAIS N'ONT PAS LA MEME SYNTAXE !

APPIC_code_BAC_n

où code représente le code du modèle de document et n est le numéro de l'imprimante choisie

21 Caractère identifiant le bac d'impression

0 bac courant

1 bac supérieur

2 mode manuel

3 bac supérieur en alimentation manuelle

4 bac inférieur

6 Magasin à enveloppes

L'utilisation d'APPIC permet de spécifier sur le paramètre de lancement des programmes d'édition les bacs utilisés sur l'imprimante de destination.

Le but de ce développement est de permettre le paramétrage du bac de l'imprimante de destination en fonction du modèle de document utilisé (paramètre MDO).

Ce développement est fait en standard mais suppose, pour fonctionner correctement que :

- L'édition doit utiliser APPIC,

- La fonction f_init_starpage est utilisée dans le report,

- Les fonds de pages de l'édition traitent la zone correspondante.

Exemples :

Soit le paramétrage suivant dans les notes du #LP

APPIC_BLN_BAC_1 3

APPIC_BLN_BAC_2 6

APPIC_BLN_BAC 2

APPIC_DEF_BAC1 1

Ceci signifie que lorsque l'on va utiliser l'imprimante 1 de ce #LP pour éditer un document dont le modèle est BLN, le bac sélectionné sera le numéro 3.

Si on édite ce même document sur l'imprimante 2, il sortira sur le bac 6.

Si on édite ce même document sur les imprimantes 3 et 4, alors ce sera le bac par défaut de ce modèle, soit le numéro 2.

Par contre, tous les autres documents APPIC sortiront sur le bac 1 quelle que soit l'imprimante choisie.

ATTENTION A CES 2 NOTES : ELLES SE RESSEMBLENT MAIS N'ONT PAS LA MEME SYNTAXE !

CODE_IMP_DEF_FD

21,23 Code imprimante pour l'édition des factures de douanes (code de type #LP)

24 Numéro de l'imprimante pour l'édition des factures de douanes (1,2,3,4,e, …)

Uniquement pour l'édition des BL

CODE_IMP_DEF_DMC

21,23 Code imprimante pour l'édition des documents de consignation (code de type #LP)

24 Numéro de l'imprimante pour l'édition des documents de consignation (1,2,3,4,e, …)

Uniquement pour l'édition des BL

COMPLEMENT_IMP_n

Sur la ligne de l'imprimante, se traduit par un CPn, où n peut varier de 0 à 9.

Chaîne qui prendra la place du complément dans la commande d'impression.

Code de l'imprimante, Code utilisateur, fond de page, etc.

Paramétrage de compléments sur le #LP pour les commandes d'impression, levant ainsi la limite du #LP qui est de 20 caractères.

Exemple : paramétrage d'un nom de fond de page APPIC avec le nom utilisateur sous Windows

ATTENTION :

• On ne peut avoir qu'une seule fois le même code CP par commande mais plusieurs codes CP peuvent être cumulés.

• la taille maximale de la commande d'impression, commande + compléments en clair + nombre de copies, ne peut excéder 50 caractères.

VE_DOC

8,60 Document(s) VoluEdit sélectionnable(s)

VE_IMP

8,60 Choix de la sortie impression

VE_NCA

8,60 Nom du catalogue à utiliser pour l'édition

VE_SOR

8,60 Nom de l'imprimante palette ou caisse (pour etiq)

Notes propres à l'impression via une ligne de commande (AVM Fax / Mail)

Ce mode d'impression nécessite que A2[53] = O (Oui).

x_CDE_ENVOI | 21,60 Commande d'envoi d'impression x représente le type d'envoi : F Envoi Fax par AVM M Envoi Mail par AVM L'adresse e-mail de l'émetteur est dans la note ATR_MAIL du paramètre USE. Exemples F_CDE_ENVOI lpcde -dspoolfax M_CDE_ENVOI lpcde -dspoolfax
REP_UNIX | 21 60 Répertoire partagé Unix ou sera généré le fichier d'édition à transférer Exemple REP_UNIX /u/emacs/tmp
SUP_FICHIER | 21 Suppression du fichier généré après traitement (O/N, N par défaut)

Cette fonction permet d'envoyer par Fax, Mail (AVM) n'importe quelle édition VoluPack (résultat d'une visualisation, …)

L'impression se fait dans un fichier, qui sera ensuite traité par Fax, Mail, …Le fichier généré s'appelle VSW_pid.

Pour les visualisations :

1) Choisir Edition dans le menu

2) Choisir edi/Cde dans le choix du périphérique (Edition par commande)

3) Le système propose alors toutes les imprimantes pour lesquelles A2[53] = O (Oui). Sélectionnez l'une d'entre elles.

4) L'écran de sélection des destinataires s'affiche.

En entête :

L'émetteur est initialisé par celui du paramètre USE.

L'objet provient du titre saisi dans la visualisation.

La Pièce jointe est inutilisée pour l'instant.

Remplir le tableau des destinataires : Nom et [N° de fax OU adresse e-mail)

5) Les instructions liées à l'imprimante sélectionnée sont alors exécutées (instruction paramétrées dans les notes x_CDE_ENVOI).)

Pour la partie technique :

Les éditions seront envoyées par pièces jointes au format tif.

On utilise l'imprimante virtuelle Spoolfax, que l'on définira sur le système Unix.

La taille du document pouvant varier en largeur, il a été nécessaire de faire des scripts pour paramétrer ce lancement d'édition, afin de ne pas tronquer celle-ci dans le fichier joint.

Ces scripts sont sous /usr/start et sont personnalisables (suppression du mode condensé, par exemple).

L'instruction d'édition n'est pas la commande classique Unix lp, mais par exemple un script lpcde, qui envoie d'abord des instructions PCL, avant de lancer la commande lp.

Exemple : lpcde –dspoolfax nom_fichier

Détail du cript lpcde

cat /usr/start/crlf_cde $2 | lp $1

Envoi d'abord du script crlf_cde, puis exécution de l'impression par la commande lp standard unix.

Détail du cript crlf_cde

^[&k2G^[&l1O^[(s26H

^[&k2G # conversion des line feed (LF) en retour chariot plus line feed (CR + LF)

^[&l1O # Impression en paysage

^[(s26H # densité de la police d'impression

Comme on le voit, le caractère d'échappement est ^[

Pour entrer de caractère au clavier, le plus simple est de passer par UltraEdit en mode hexadécimal.

Vous pouvez retrouver ces instructions PCL ici : http://h10025.www1.hp.com/ewfrf/wc/genericDocument?cc=fr&docname=bfd09160&lc=fr

Attribution d'une imprimante par tty

Les imprimantes attachées aux tty sont définies dans le fichier defaut/tty/imprimante sous la forme <code paramètre> <nom du groupe>

Il est préférable que l'imprimante paramétrée ne soit pas une des imprimantes "fixables" par les programmes VOLUME. Utilisez pour cela des codes numériques.

Exemples

003 /dev/tty1

001 /dev/tty2

Le tty 1 imprime sur #LP 003

Le tty 2 imprime sur #LP 003

Imprimantes "fixables" par VOLUME

La liste suivante n'est pas exhaustive. Elle donne quelques exemples de codes imprimantes paramétrés en durs dans les programmes.

Code Module

AAS | VOL_
ACR | Edition des accusés de réception
AEX | Edition des achats extérieurs
ALE | Etat des alertes
ANM | Articles non mouvementés
BAR | Edition de codes barres
BCF | Edition des bons de commandes fournisseurs
BDT | Edition des bons de travaux
BLV | Edition - réédition des bons de livraison
BOB | Edition des étiquettes de bobine
BRU | Edition des bons de réception usine
BTS | Edition des bordereaux de transfert de stock
CDF | Visu / Edition des commandes fournisseurs
CEP | Edition des cas d'emploi de composant
CLI | Edition fichier client
CNF | Edition des fiches de conformité
COM | Edition de l'état complémentaire
COU | Edition table des centres de coût
DEC | Edition devis client (Imprim)
DEI | Edition devis interne (Imprim)
DEV | Edition - réédition des devis
DOC | Edition doc en ligne
EDF | Edition des dossiers de fabrication
EFF | Transfert des effets
EFP | Edition de la fiche produit
EMP | Edition du fichier des employés
EPR | Edition des prix de revient
ETI | Edition des étiquettes de livraison
ETP | Edition des étiquettes de production
FAC | Edition - réédition des factures
FAF | Edition des factures fournisseurs
FAX | Edition des fax
FFA | Edition des fiches de fabrication
FIS | Edition des fiches suiveuses
FOR | Edition du fichier des formes
JBL | Edition du journal des livraisons
JDV | Edition du journal des ventes
KMA | Edition du fichier ECMA
LDV | Edition de la liste des devis
MAC | Edition du fichier des machines
MAT | Edition fichier matière
NEG | Edition du devis négoce
PAR | Edition du fichier des paramètres
PLF |
POS | Edition du fichier des opérations
PRL | Edition des contrôles cartons
PRX | Edition des propositions de prix
REL | Edition des relevés de facture
RLQ | Edition des reliquats de commandes
ROP | Récapitulatif des temps par semaine, commande et opération
RTM | Intégration remontées atelier
SMG | Edition des fiches de sortie magasin
ST1 | Statistiques paramétrables opérations
ST2 | Statistiques paramétrables saisie des temps
STA | Statistiques gestion commerciale
STK | Imprimante édition des stocks
STP | Statistiques de production
TAI | Génération planning prévisionnel des aides
TRA | Edition des traites
TRO | Edition des tarifs transporteurs
TRP | Edition du transfert du prix de revient

#LP ETP : Etiquettes de production

Libellé long | Imp. Etiquettes product.
Libellé abrégé | Imp. Etiq
Valeur numérique 1 | 100
Valeur numérique 2 | 100
Alpha1[1,20] | Séquence d'impression Appic sous la forme cat $1 | "shell de lancement pour Appic"
Alpha1[21,25] | Code de l'imprimante
Alpha3[1,3] | Longueur de la page : 100


#MA Matrice de saisie

Ce paramètre est utilisé par le programme matrice.

Le paramétrage a été entièrement refait le 11/04/2013 en V. 4.1.29.2

Valeur alpha 1

#MA A1[1,3]

Type de matrice associée au critère

DEC Décompositions prioritaires

Si le code du critère de matrice = DEC, le type de matrice par défaut est DEC.

Notes

LIB_COL_1_TAB_CRI | Libellé de la colonne de visualisation du code du critère Par défaut : Code Voir capture d'écran (B)
LIB_COL_2_TAB_CRI | Libellé de la colonne de visualisation de la désignation du critère Par défaut : Libellé du critère Voir capture d'écran (C)
LIB_COL_1_TAB_SEL | Libellé de la colonne de visualisation de la clé Par défaut : Clé Si le type de matrice est DEC : Pagination totale pour laquelle des décompositions prioritaires existent Par défaut : Pagination totale Voir capture d'écran (E)
LIB_COL_2_TAB_SEL | Libellé de la colonne de visualisation du nombre d'éléments présents sur la clé Par défaut : Nb Elém. Si le type de matrice est DEC : Nombre de décompositions prioritaires Par défaut : Nb Déc. Voir capture d'écran (F)
LIB_COLONNE_n | où n peut prendre les valeurs de 1 à 12 21,25 Libellé de la colonne n
LIB_COLONNE_13 | 21,25 Libellé de la colonne 13 (colonne de totalisation)
LIBELLE_CLE | 21,60 Libellé de la clé
LIB_GRP_TAB_CRI | Libellé du groupe de sélection des critères Par défaut : Liste des critères Voir capture d'écran (A)
LIB_GRP_TAB_MAT | Libellé du groupe de saisie de la matrice Par défaut : Matrice associée Si le type de matrice est DEC : Nombre de décompositions prioritaires Par défaut : Description des décompositions prioritaires Voir capture d'écran (G)
LIB_GRP_TAB_SEL | Libellé du groupe de sélection des clés Par défaut : Liste des clés Si le type de matrice est DEC : Par défaut : Liste des paginations Voir capture d'écran (D)
PAG_COLONNE_n | où n peut prendre les valeurs de 1 à 12 21,25 Pagination associée à la colonne n
TITRE_SAISIE | 21,60 Titre de la saisie


#RP Lancement de programmes

LCT_MULTI_TITRE_02 Modification actif/inactif

LCT_MULTI_IMAGE_02 g_modifier

LCT_MULTI_PARAM_02 ACT005-N[p2_type|p2_code]

LCT_MULTI_REACT_02 O

LCT_MULTI_TITRE_03 Annulation logique

LCT_MULTI_IMAGE_03 g_modifier

LCT_MULTI_PARAM_03 ACT006-N[p2_type|p2_code]

LCT_MULTI_REACT_03 O

LCT_MULTI_TITRE_02 Modification actif/inactif

LCT_MULTI_IMAGE_02 g_modifier

LCT_MULTI_PARAM_02 ACT005-N[p2_type|p2_code]

LCT_MULTI_REACT_02 O

Exemple de paramétrage

LCT_MULTI_TITRE_07 Facture des BL

LCT_MULTI_IMAGE_07 logos\grw_logo_32

LCT_MULTI_PARAM_07 ACT020[b2_cde]

LCT_MULTI_COMPL_07 JB1

#RP Lancement de programmes

Ce paramètre a 2 fonctions :

1) Lancement de programmes avec transmission d'arguments (voir ci-dessous) (notes LCT_PROG_xxx). Opérationnel à partir de la V. 4.0.157.2

2) Actions à réaliser sur une sélection multiple (voir plus bas dans ce document) (notes LCT_MULTI_xxx). Opérationnel à partir de la V. 4.0.173.2

1) Lancement de programmes avec transmission d'arguments - Ctrl J

Objet : dans certains programmes, pouvoir lancer des programmes VoluPack (ou Windows avec certaines restrictions),

avec la possibilité d'envoyer au programme cible un argument construit par paramètre (code client, code article, etc).

Dans le programme concerné, un appui sur la touche Ctrl J ouvre une fenêtre de sélection (sauf si une seule action est paramétrée).

Dans les programmes de visualisation, l'autorisation d'accès à la touche Ctrl J se fait en mettant O dans A4[43].

Pour afficher / masquer le paramétrage de cette fenêtre, cliquez ici.

Remarques

  • Si l'argument est correctement paramétré mais que la valeur n'est pas trouvée, le texte [Argument non trouvé] est affiché.

  • Si l'argument n'est pas correctement paramétré ou que la valeur de l'argument n'est pas accessible dans le dictionnaire de données, le texte [Argument en anomalie] est affiché.

  • Il est possible de paramétrer des lignes avec un titre mais sans action, afin d'afficher une ligne de séparation par exemple.

  • Des programmes Windows peuvent également être exécutés de la même façon (en utilisant le type de paramètre WIN).
    Attention toutefois : les programmes accessibles sont ceux de la machine où est exécuté VoluPack.
    Par conséquent, dans le cas d'une connexion en TSE, seuls les programmes du serveur sont accessibles.

  • Tous les programmes VoluPack sont accessibles, mais tous n'acceptent pas d'arguments en entrée.
    Les programmes concernés ont un paragraphe intitulé Arguments d'appel en tête de leur page respective.

  • Si aucun paramétrage n'existe sur le paramètre de lancement (configuration ou paramétrage direct), c'est le paramétrage de configuration par défaut qui sera utilisé : #RP_DF

  • Les codes paramètres associés au type #RP commençant par le caractère _ (souligné) sont réservés à Volume Software. (exemples : #RP_DF, #RP_CZ)

  • Si un seul programme à exécuter est paramétré, le programme est exécuté directement, la fenêtre de sélection n'apparaît pas.
    De plus, l'action associée au CTRL-J aura pour image et titre ceux de l'unique programme paramétré.

  • Un exemple concret ainsi que le paramétrage associé est disponible plus bas.

  • Il existe aussi une note LCT_PROG_ANOMALIES qui peut se paramétrer sur le #CF ATL ou sur le USE.

Paramétrage du Ctrl J

2 possibilités :

1/ Les notes suivantes sont dans le paramètre de lancement.

2/ Elles peuvent être "déportées" dans le #RP. Dans ce cas, il faut l'indiquer au paramètre de lancement par la note suivante :

LCT_PROG_CONFIG #RPBLV

Dans l'exemple ci-dessus, on indique au paramètre de lancement que le paramétrage de trouve dans le #RP BLV.

LCT_PROG_PARAM_

Syntaxe 1

(lancement de programme)

16,19 Numéro d'indice

21,26 Type et code du paramètre de lancement du programme à exécuter

Pour exécuter un programme Windows, le paramétrage WIN/[Code paramètre] doit exister.

27,60 Argument à passer au programme à exécuter. Les arguments suivants sont possibles :

1) Variables accessibles dans la visualisation en utilisant le même mot-clé entre crochets.

Exemple -N[fi_prod_ent] sera remplacé à l'exécution du programme par -N324766

2) TSC accessibles dans la visualisation (syntaxe d'appel de type 1)

Exemple -N[TSC_L2_DD_045_G] sera remplacé à l'exécution du programme par -NQGC1-300

3) Les données d'une LCO (syntaxe d'appel)

4) L'un des mots-clés suivants :

+CRIT_CHAR_

+CRIT_DATE_

+CRIT_NUME_

+CRIT_NUMD_

Une note commençant par _CRIT_ doit être paramétrée dans le programme appelé (de type visualisation).

Cliquez ici pour accéder à un exemple.

Possibilités de mise en forme

A) On peut concaténer des variables en utilisant le caractère | (pipe) entre chaque variable.
Pour les variables numériques, on peut préciser un using avec le caractère + (plus).
Exemple
-N[l2_devis|-|l2_sdevis+<<&] sera remplacé à l'exécution par
-NE0020628-1

B) On peut récupérer uniquement les caractères x à y d'une chaîne avec le code +S.
Exemple
[uc_article_fab+S3-12]
Ici, on récupère les caractères 3 à 15 de la zone uc_article_fab.

Remarques

" Il est possible de paramétrer sur plusieurs lignes (le numéro d'indice doit être identique).

Les type et code de paramètre ne sont obligatoires que sur la première ligne.

" Les variables accessibles peuvent provenir

du client (cli.cl_)

du produit (mat_mp)

du devis (fle_2.l2_)

de l'entité (fle_imp.fi_)

Cette liste n'est pas exhaustive et d'autres données peuvent être accessibles.

" Les arguments peuvent également être des options (-O), des types de notes à saisir (-C) ou autres. Voir les exemples ci-dessous

LCT_PROG_PARAM_

Syntaxe 2 (TSC)

Exemples

Pour accéder aux informations complémentaires (TSC) et aux notes (table notes uniquement) en utilisant un type de clé et une clé d'information paramétrable. Il est également possible de restreindre l'affichage des informations complémentaires à un type (TIC) particulier.

16,19 Numéro d'indice

21,23 Mot-clé TSC indiquant qu'on veut accéder à la saisie des informations complémentaires

24,26 Type d'information complémentaire. Doit correspondre à un paramètre de type TIC.

Si la zone est laissée à blanc, on prend en compte tous les TIC ou ceux définis sur le paramètre de lancement via l'argument -D (par défaut).

27 Type d'accès aux informations complémentaires

M Accès en modification

C Accès en consultation seule (par défaut)

28 Type de clé d'information complémentaire

Exemple : Y (TSC sur bon de réception)

29,60 Clé d'information complémentaire (la construction de cette clé varie selon le type de clé)

Exemple (TSC sur ligne de bon de réception)

[brd_bon|-|brd_lig+<<&]

LCT_PROG_PARAM_

Syntaxe 3 (NTS)

16,19 Numéro d'indice

21,23 Mot-clé NTS indiquant qu'on veut accéder à la saisie des notes (table Notes uniquement)

24,26 Type de note. Doit correspondre à un paramètre de type NTS.

Si la zone est laissée à blanc, on prend en compte tous les types de notes ou ceux définis sur le paramètre de lancement via l'argument -C (par défaut)

27 Type d'accès aux lignes de notes

M Accès en modification

C Accès en consultation seule (par défaut)

28 Type de clé de note

Exemple : M (Note sur machine)

29,60 Clé de note (la construction de cette clé varie selon le type de clé)

Exemple (Note sur machine)

[fi_mac_imp]

LCT_PROG_PARAM_

Syntaxe 4 (Lancement de script)

Exemple

16,19 Numéro d'indice

21,23 Pot-clé CMD annonçant qu'on veut lancer une commande

27,60 Commande à lancer

LCT_PROG_TITRE_

16,19 Numéro d'indice

21,60 Titre de l'action

Remarque : Il est possible de paramétrer le titre sur plusieurs lignes (le numéro d'indice doit être identique).

LCT_PROG_IMAGE_

16,19 Numéro d'indice

21,60 Chemin d'accès à l'image associée à l'action.

Par défaut, les images sont recherchées dans le répertoire par défaut défini dans la configuration 4J'S GDC.

Remarque

Il est possible de paramétrer le chemin d'accès à l'image sur plusieurs lignes (le numéro d'indice doit être identique)

LCT_PROG_REACT_

21 Réactualiser l'écran de visualisation (O/N/C, N par défaut)

N Pas de réactualisation (par défaut)

O Toujours réactualiser

C Demande de confirmation avant la réactualisation

L Réactualiser uniquement la ligne (fonctionne dans v_mat et v_emp)

LCT_PROG_COCHE_

à vérifier

16,19 Numéro d'indice

21 Le programme sera coché à l'ouverture de la fenêtre de lancement (O/N, N par défaut)

O Une case à cocher est rajoutée en fin de ligne de l'écran de lancement des programmes.

Si plusieurs lignes sont cochées, les programmes sont lancés les uns à la suite des autres.

Si aucun programme n'est coché, la touche "valider" lance l'exécution du programme correspondant à la ligne sélectionnée.

Les lignes présélectionnées sont paramétrables, par défaut elles ne sont pas sélectionnées.

Attention : en visualisation des éditions, seule la dernière édition reste visible, VoluEdit ne pouvant afficher plusieurs documents simultanément.

Une erreur peut survenir si la temporisation est trop courte entre 2 lancements de VoluEdit (voir la valeur numérique 2 dans #CF EVE).

Paramétrage du lancement de programme Windows

WIN A1[5]

L'option paramétrée dans la note OPTIONS_PROG doit être située avant le nom du document à l'exécution (O/N, N par défaut)

Exemple avec l'option paramétrée dans les notes /p

O programme.exe /p nom_du_document.ext

N programme.exe nom_du_document.ext /p

WIN A2[1,60]

Chemin d'accès au programme à exécuter. Ce chemin peut être complété via la note EXECUTABLE, voir ci-dessous.

Remarque : Le chemin d'accès au programme à exécuter n'est pas obligatoire. S'il n'est pas paramétré, VoluPack lancera automatiquement le programme par défaut associé à l'extension du document dans Windows.

WIN note EXECUTABLE

21,60 Complément au chemin d'accès à l'exécutable paramétré en WIN A2[1,60] : les 2 valeurs (zone alpha 2 et notes) seront concaténées.

Exemple 1

Pour afficher / masquer le paramétrage de cette fenêtre, cliquez ici.

Action | Argument dynamique | Programme VoluPack associé
Commandes de l'article | Article 324766 | Visualisation des commandes de l'article saisi dans l'entité du devis en cours de visualisation (G_v_cdem.42r)
Consultation de l'article | Article 324766 | Consultation de l'article saisi dans l'entité du devis en cours de visualisation (G_mat.42r)
Consultation du devis | Devis E0020628-1 | Consultation du devis en cours de visualisation (G_devis_standard.42r)

#VI DEV - Visualisation des devis

Note | Caractères 21 à 60 | Explication
LCT_PROG_CONFIG | #RPDEV | La configuration du lancement des programmes se trouve sur le paramètre #RPDEV

#RP DEV - Lancement des programmes en visualisation des devis

Note

Caractères 21 à 60

Explication

LCT_PROG_TITRE_01

PROGRAMMES VOLUPACK

Ligne de titre, sans action

LCT_PROG_TITRE_02

Commandes de l'article

Ligne de titre pour l'action

LCT_PROG_IMAGE_02

application_view_columns

Nom de l'image pour l'action

LCT_PROG_PARAM_02

#VICDE-N_ART[fi_prod_ent]

Exécution du paramètre de lancement #VI CDE, avec l'argument N_ART, concaténé avec le code produit de l'entité en cours de visualisation.

G_v_cdem.42r N_ART324766

LCT_PROG_TITRE_03

Consultation de l'article

Ligne de titre pour l'action

LCT_PROG_IMAGE_03

g_cree_modif

Nom de l'image pour l'action

LCT_PROG_PARAM_03

#COMAT-N[fi_prod_ent]

Exécution du paramètre de lancement #CO MAT, avec l'argument N, concaténé avec le code produit de l'entité en cours de visualisation.

G_mat.42r N324766

LCT_PROG_TITRE_04

Consultation du devis

Ligne de titre pour l'action

LCT_PROG_IMAGE_04

g_trace

Nom de l'image pour l'action

LCT_PROG_PARAM_04

#SADEV-N[l2_devis|-|l2_sdevis+<<&]

Exécution du paramètre de lancement #SA DEV, avec l'argument -N introduisant le numéro de devis/sous-devis en cours de visualisation

LCT_PROG_PARAM_04

-Oco

Dans cette ligne de note supplémentaire, on ajoute l'option Oco (consultation), ce qui donne :

G_devis_standard.42r NE0020628-1 Oco

Remarque

L'option Oco s'ajoute aux options déjà paramétrées sur le paramètre de lancement du devis #SA DEV.

Etant donné que les lignes de notes sont concaténées, il faut commencer le paramétrage en caractère 22 afin de respecter un espace entre les arguments.

Dans cet exemple, le paramétrage de l'option Oco sur la ligne de note commence en caractère 22, afin que l'espace entre l'argument N et l'option O soit pris en compte.

Exemple 2 (TSC)

Action | Argument dynamique | Fonction VoluPack associée
TSC Achats | Entête de bon de réception 10050002 | Accès en modification à la saisie des informations complémentaire de TIC ACH sur l'entête de bon de réception
TSC Fabrication | Ligne de bon de réception 10050002-1 | Accès en consultation à la saisie des informations complémentaire de TIC FAB sur la ligne de bon de réception
TSC sur entête | Entête de bon de réception 10050002 | Accès en modification à la saisie des informations complémentaire sur l'entête de bon de réception
TSC sur ligne | Ligne de bon de réception 10050002-1 | Accès en modification à la saisie des informations complémentaire sur la ligne de bon de réception

Notes du paramètre : #RPBRC - Lancement des programmes en visualisation des bons de réception

Note | Caractères 21 à 60 | Explication
LCT_PROG_TITRE_01 | TSC Achats | Ligne de titre pour l'action
LCT_PROG_IMAGE_01 | g_tsc | Nom de l'image pour l'action
LCT_PROG_PARAM_01 | TSCACHMY[bre_bon] | Accès à la saisie des informations complémentaires/en modification/de TIC ACH/de type de clé Y/sur l'entête de bon de réception en cours de visualisation
LCT_PROG_TITRE_02 | TSC Fabrication | Ligne de titre pour l'action
LCT_PROG_IMAGE_02 | g_tsc | Nom de l'image pour l'action
LCT_PROG_PARAM_02 | TSCFABCY[brd_bon|-|brd_lig+<<&] | Accès à la saisie des informations complémentaires/en modification/ de TIC FAB/de type de clé Y/sur la ligne de bon de réception en cours de visualisation
LCT_PROG_TITRE_03 | TSC sur entête | Ligne de titre pour l'action
LCT_PROG_IMAGE_03 | g_tsc | Nom de l'image pour l'action
LCT_PROG_PARAM_03 | TSC MY[bre_bon] | Accès à la saisie des informations complémentaires/en modification/de type de clé Y/sur l'entête de bon de réception en cours de visualisation
LCT_PROG_TITRE_04 | TSC sur ligne | Ligne de titre pour l'action
LCT_PROG_IMAGE_04 | g_tsc | Nom de l'image pour l'action
LCT_PROG_PARAM_04 | TSC MY[brd_bon|-|brd_lig+<<&] | Accès à la saisie des informations complémentaires/en modification/de type de clé Y/sur l'entête de bon de réception en cours de visualisation

Exemple 3 (envoi de mail)

LCT_PROG_TITRE_01 Messagerie

LCT_PROG_IMAGE_01 g_adresse

LCT_PROG_PARAM_01 WINEXTmailto:[cl_email]

Exemple 4 (Lancement de script)

Ouverture de sqlplus avant de la requête ma_requete.sql

1 2 3 4 5

12345678901234567890123456789012345678901234567890

LCT_PROG_TITRE_01 Requête SQL

LCT_PROG_IMAGE_01 g_trace

LCT_PROG_PARAM_01 CMD sql @ma_requete

Lancement du fichier de commandes ma_commande.cmd :

1 2 3 4 5

12345678901234567890123456789012345678901234567890

LCT_PROG_TITRE_02 Lancement Shell

LCT_PROG_IMAGE_02 g_trace

LCT_PROG_PARAM_02 CMD ma_commande.cmd

Autres exemples, en vrac

Exemple 1 - Visualisation des formes

La visualisation des formes (v_mat) permet, pour une forme affichée, de visualiser tous les produits utilisant cette forme (v_mat).

LCT_PROG_TITRE_01 Produits utilisant cette forme

LCT_PROG_PARAM_01 #VIPEP+CRIT_CHAR_[mp_code]

LCT_PROG_IMAGE_01 G_trace

Au lancement de la visualisation #VIPEP (Liste des PF pour une forme), la note _CRIT_CHAR_ de cette visualisation prendra automatiquement la valeur mp_code.

Le numéro de forme de découpe n'est plus demandé, il est passé en argument.

Les deux notes suivantes doivent être présentes sur #VIPEP :

S and mp_at1 _CRIT_CHAR_1

_CRIT_CHAR_1 Code forme

Exemple 2 - Visualisation des commandes avec cadencement

La visualisation des commandes avec cadencement (v_cdem) permet de visualiser les cadencements pour la date affichée.

LCT_PROG_TITRE_01 Cadencement à date

LCT_PROG_PARAM_01 #VI00J+CRIT_DATE_[li_datliv]

LCT_PROG_IMAGE_01 G_trace

Au lancement de la visualisation #VI00J (Cadencements à livrer), la note _CRIT_DATE_ de cette visualisation prendra automatiquement la valeur li_datliv.

La date de rendu n'est plus demandée, elle est passée en argument.

2) Actions à réaliser sur une sélection multiple - Ctrl K

Dans certaines visualisations, on peut afficher une colonne supplémentaire permettant de sélectionner des lignes.

On coche/décoche alors la ligne via la barre d'espace ou en double-cliquant dessus.

On peut aussi tout sélectionner ou désélectionner d'un seul coup.

En appuyant sur Ctrl K, on lance ensuite un traitement qui sera appliqué à l'ensemble des lignes sélectionnées.

Il existe aussi une note LCT_MULTI_ANOMALIES qui peut se paramétrer sur le #CF ATL ou sur le USE.

Tableau des actions possibles (nécessitant une permission)

Toutes ces actions (sauf les actions ACT002, ACT003 et ACT004) nécessitent la permission correspondante, de type MEN ACTnnn.

L'action est paramétrée dans les caractères 21 à 26 de la note LCT_MULTI_PARAM (voir ci-dessous).

Action

Programme

La touche Ctrl K permet de...

ACT001

visu des matières

modifier le code qualité de toutes les lignes sélectionnées.

Exemple complet avec copies d'écran ci-dessous

ACT002

visu des commandes clients

créer / modifier des trains de cadencements de fabrication

visualiser les commandes sans coût matière et réactualiser les indicateurs de rentabilité client

ACT003

visu des commandes clients

changer la variante de production pour toutes les lignes sélectionnées

ACT004

visu des actions - événements

modifier l'état, la priorité et/ou la date d'échéance des actions événements sélectionnées

Une information est mise à jour sur toutes les actions sélectionnées à partir du moment où une valeur est saisie (table action_evt).

Dans le cas contraire, la valeur initiale des enregistrements est conservée.

Remarques

La gestion des actions événements nécessite l'option payante BAS/31

L'épuration des enregistrements annulés logiquement peut être limitée via la permission TOU/VACTIONEVT_F14

ACT005

visu des paramètres

passer du code actif à inactif pour les paramètres actifs. Exemple

ACT006

visu des paramètres

annuler logiquement le paramètre inactif - Exemple

ACT007

visu des paramètres

passage du code inactif à actif pour les paramètres inactifs. Exemple

ACT008

visu des articles

supprimer logiquement des articles

ACT009

visu des tiers

supprimer logiquement des tiers

ACT010

visu des commandes clients

saisir un BL avec une liste de lignes de commande ayant la même adresse de livraison

La note LCT_MULTI_COMPL_ doit être paramétrée pour indiquer le type et le code paramètre de lancement de la saisie de BL (via la note CREER_BL du paramètre KSC

ACT011

visu des clients

mettre à jour les représentants

ACT012

visu des clients

mettre à jour les gestionnaires

ACT013

visu des devis multi-métiers

supprimer des devis

Nécessite l'autorisation de suppression des sous-devis pour l'utilisateur courant

Use A2[17] = Use A2[187] = O

Nécessite l'autorisation de suppression des sous-devis sur le type de devis (TDE)

TDE A1[6] = O

ACT014

Préparation des affrètements

Modifier l'état de l'affrètement de 1 à 2

Voir la note _CSEL dans la préparation des affrètements.

ACT015

visu des articles

Mise à jour en masse des fiches articles

Voir l'option Omm dans la visu des articles

ACT016

Visu des commandes d'achat

Enchaîner le déblocage et l'édition d'une liste de commandes d'achat

Dans v_cdef, voir les notes _CSEL, LCT_MULTI_xxxxx et DEBLOCAGE_AUTO_MDB

Voir la note CODES_BLOCAGE_ASS dans MDB.

ACT017

visu des commandes clients

Mise à jour de l'ordre de transport dans la visu des commandes clients

ACT018

visu des commandes clients

Mise à jour de la fiche matière avec le nouveau seuil d'alerte et la quantité de réapprovisionnement (mp_smini et mp_alerte)

Si la gestion se fait par lieu de rangement, mise à jour de la table stk_rg.

ACT019

toutes les visus ayant une sélection de produit

Saisie simplifiée de commande multi-produits

ACT020

Visu du journal des BL

Facturer plusieurs commandes en une seule action

Obligatoire, l'ajout du complément KSC, note CODE_ET_TYPE_APPLI

Le programme voluedit_facn sera appelé avec l'argument -Nf.

Exemple

ACT021

Visualisation des événements d'atelier

Intégrer dans fab2 uniquement les événements sélectionnés

Le programme int_rtm sera appelé avec l'argument -Ni.

Nécessite la note LCT_MULTI_COMPL pour indiquer le type et code paramètre pour l’intégration.

Tableau des actions possibles (ne nécessitant pas de permission)

Il s'agit ici d'actions dont la note LCT_MULTI_PARAM_ ne contient pas un code action sous la forme ACTnnn (dans les caractères 21 à 26), mais le type et le code du paramètre du programme à lancer (programme recevant un argument en entrée).

Programme | La touche Ctrl K permet de...
visualisation des devis | éditer le devis de toutes les lignes sélectionnées
visualisation des tarifs | éditer le devis de toutes les lignes sélectionnées
visu des demandes d'achat | générer des commandes d'achat

Paramétrage du Ctrl K

La note _CSEL doit être paramétrée dans tout programme de visualisation désirant exploiter cette fonction.

La seule présence de cette note, sans aucun paramétrage, permet d'afficher la colonne de sélection (dans la colonne de droite du tableau).

L'autorisation d'accès à la touche Ctrl K se fait en mettant O dans A4[44] du paramètre de lancement de la visu.

2 possibilités :

1/ Les notes suivantes sont dans le paramètre de lancement.

2/ Elles peuvent être "déportées" dans le #RP. Dans ce cas, il faut l'indiquer au paramètre de lancement par la note suivante :

LCT_MULTI_CONFIG #RPMA2

Dans l'exemple ci-dessus, on indique au paramètre de lancement que le paramétrage de trouve dans le #RP MA2.

note LCT_MULTI_TITRE_ | 17,18 Numéro de l'indice 21,60 Titre de l'action
note LCT_MULTI_IMAGE_ | 17,18 Numéro de l'indice 21,60 Image rattachée à afficher
note LCT_MULTI_PARAM_ | 17,18 Numéro de l'indice 21,26 Type et code du paramètre du programme à lancer (ou bien) ACTnnn, indiquant une ACTion standard définie par Volume Software, suivi de son code. Voir le tableau des actions possibles ci-dessus. 27,60 Argument à passer au programme à exécuter. Il est possible d'utiliser les variables accessibles dans la visualisation en utilisant le même mot-clé entre crochets. Exemple -N[mp_code] sera remplacé à l'exécution du programme par : -N301873
note LCT_MULTI_REACT | 17,18 Numéro de l'indice 21 Réactualisation de la visualisation après exécution du programme ou de l'action O Oui N Non (par défaut) C Confirmation
LCT_MULTI_COMPL_ | Visualisation des produits Complément sur la gestion du scénario 1 (modification de la zone mp_qualite) 17,18 Numéro de l'indice 21,26 Selon l'action ACT001 Numéro de paramétrage du scénario pour information complémentaire (paramètre de type KSC) ACT009 Message de confirmation avant de lancer l'annulation logique des tiers (O/N, N par défaut) ACT010 Type et Code du paramètre de lancement de la saisie de BL (via la note CREER_BL du paramètre KSC) ACT016 Type et Code du paramètre de lancement du programme d'édition à exécuter ACT021 Type et code paramètre de lancement du programme d'intégration des temps (int_rtm)

Exemple complet : Visualisation des matières - Paramètre de lancement

Exemple complet : Visualisation des matières - Paramétrage du #RP

Exemple complet : Visualisation des matières - Exécution

Remarque

  • Dans l'exemple ci-dessus, on a paramétré 3 actions :
    dans ce cas, le Ctrl K ouvre une fenêtre de sélection qui vous demande de choisir l'action que vous voulez réaliser.

  • Si vous ne paramétrez qu'une seule action, le Ctrl K lance immédiatement l'action, sans fenêtre de sélection, sans intervention de votre part.


#TC Types de contrôle

Utilisé par le programme habilit.

Pas de paramétrage particulier, seul le libellé est utilisé.


_Fonctions communes

Résultat de recherche F7 d'un code paramètre type MRG :

Fonctions communes

Les fonctions suivantes sont communes à tous les paramètres de saisie.

Notes commençant par AF7

Pouvoir afficher des libellés sur plusieurs lignes dans le tableau de recherche des paramètres.

Affecter plusieurs libellés à un même paramètre.

AF7

Sur un paramètre par02, cette note permet d'afficher une ou plusieurs lignes de libellés complémentaires dans la fenêtre de résultat F7 de recherche d'un code paramètre.

4, 23 Libellé

Cliquez ici pour afficher / masquer un exemple

Saisie simplifiée des paramètres (dans PAR02)

Notes commençant par COL_PAR_ (ou C_)

Les caractères 9 (ou 3) à 60 doivent contenir 7 champs, tous suivis par un astérisque :

1/ Langue du user (fr, en, sp…)

2/ Libellé de la zone

3/ Zone ou colonne de la table par02 (pour les valeurs alpha, préciser obligatoirement les bornes (par exemple, alpha1[1,1])
Identifiant de la ligne de note de paramétrage, sous la forme PN2_nnn, qui doit être paramétré en tant que note commençant par PN2_ (ci-dessous),
suivi des bornes concernant la saisie d'une valeur (par exemple, PN2_001[21,23])

4/ Format (using)

5/ Contrôle si zone non saisie

N pas de contrôle

W warning

M message

B bloquant

6/ Type de contrôle :

N contrôle numérique (pour les 2 zones numériques et pour des portions numériques des zones alphanumériques)

01 Contrôle bloquant de l'existence du paramètre cité en 7/ dans par02 (permet aussi une recherche du code par F7)

02 Contrôle bloquant de l'existence du paramètre cité en 7/ dans liens_tables (permet aussi une recherche du code par F7) - Plus d'info

7/ Type de paramètre permettant non seulement une recherche par F7, mais aussi un contrôle d'existence de la valeur saisie.

Notes commençant par PN2_

Caractères 5 à 60 : Paramétrage de l'identifiant d'une ligne de note de paramétrage, contenant 3 champs séparés par des astérisques

1) Identifiant de la ligne de note de paramétrage, suivi des bornes concernant le mot-clé de la ligne de note (par exemple, PN2_001[1,20])
Cet identifiant doit être utilisé dans le champ 3 d'une ligne de note commençant par COL_PAR_ ou C_ (ci-dessus).

2) Mot-clé de la ligne de note
Exemples :
CODE_QUALITE_DEVIS
_SUP_REQ_FLE_IMP
etc.

3) Création de la ligne de note même si aucune valeur n'est saisie (O/N, N par défaut)

Exemple pour la saisie simplifiée des familles :

Cliquez ici pour afficher / masquer une copie d'écran

Paramétrage :

  • Dans la saisie des types de paramètres (PAR01), vous entrez le code FAM.

  • Dans le champ Modifiable, vous entrez le code S.

  • Vous faites F6 pour atteindre la fenêtre du paramétrage de saisie simplifiée de PAR02.

  • Vous entrez les lignes de notes suivantes (sans les numéros, qui ne servent ici qu'à titre de renvoi) :

  1. COL_PAR_fr*pourcentage frais*p2_zc2*&&*

  2. COL_PAR_fr*sous-famille*p2_alph3[1,3]**B*SFM*

  3. COL_PAR_fr*Code cpt vente france*p2_alph[1,8]**W*

  4. COL_PAR_fr*Code cpt vente export*p2_alph[9,16]**B*

  5. COL_PAR_fr*Code num*p2_com[1,4]*####*M*N*

  1. Le pourcentage de frais est saisi en zone numérique 2 sur 2 chiffres. Aucun contrôle de saisie.

  2. La sous-famille est saisie en alpha3[1,3], sans format particulier, avec un message bloquant si la zone n'est pas saisie et une vérification de l'existence du paramètre SFM.

  3. Le compte vente France est saisi en alpha1[1,8], sans format particulier, avec un avertissement si la zone n'est pas saisie.

  4. Le compte vente export est saisi en alpha1[9,16], sans format particulier, avec un message bloquant si la zone n'est pas saisie.

  5. Le code num est saisi en alpha2[1,4] sur 4 chiffres, avec une demande de confirmation si la zone n'est pas saisie, et un contrôle numérique.

Attention : vérifiez que les utilisateurs concernés ont le droit de modifier !

La saisie simplifiée des paramètres s'appuie sur les libellés stockés dans la table notes.

La clé est constituée du type de paramètre et nn_type_note est fixe et égal à P02.

Utilisation

  • Dans la saisie des produits (mat), vous faites F7 sur le code famille.

  • Vous faites ensuite F1 pour créer ou F8 pour modifier une famille.

  • Vous êtes maintenant dans la fenêtre de saisie simplifié des familles.


1PO Code imposition

Les codes sont figés.

1 | A plat
2 | Roto en simple
3 | Roto en double à séparer
31 | Coming and going
4 | Bloc Cameron
5 | Bloc cousu
6 | Bloc avec couverture arrachée
7 | Fascicule
9 | Bloc Floch

L'ajout de nouveaux codes devra se faire conjointement avec le service développement de VOLUME.

Remarque

Le texte doit être considéré A plat si au moins un des cahiers est à plier.

Valeur alpha 1

1PO A1[1]

Utilisé pour le calcul de l'encours de pliure

P Avec pliure

R Roto

C Cameron

A Autre

1PO A1[10]

O Saisie des gardes possible dans le cas d'un paramètre 1PO correspondant à un bloc (codes 4, 5, 6, 8 et 9)

N Gestion actuelle. Dans le cas d'un code « imposition du texte (1PO) » correspondant à un bloc, il sera impossible de saisir les gardes

1PO A1[11]

O Saisie des détails hors-texte possible dans le cas d'un paramètre 1PO correspondant à un bloc (codes 4, 5, 6, 8 et 9)

N Gestion actuelle. Dans le cas d'un code « imposition du texte (1PO) » correspondant à un bloc, il sera impossible de saisir les détails hors-texte


ACH Acheteurs

Libellé long : Nom et fonction

C'est le libellé long qui sera affiché à l'écran.

Libellé court : NOM

Valeur alpha 1

ACH A1[1,50]

Fonction

Valeur alpha 2

ACH A2[1,30] | Numéro de téléphone
ACH A2[31,50] | Numéro de fax

Notes

_EMAIL

7,60 Email du représentant, accessible dans les catalogues suivants :

AR, BL, FACTURE, DEVIS, FAB, VED, ACH, REP et CDF


ACP Codes actions (permissions)

Attention : Aucune modification de ce paramétrage ne doit être effectuée sans consultation de Volume Software sous peine de dysfonctionnement grave.

Valeur alpha 1

ACP A1[1,24]

Message affiché dans les fenêtres

Saisie mot de passe

Autorisation refusée

Valeur alpha 2

ACP A2[1] | Permissions compatibles avec ce code action (1) O Permission accordée (par défaut) P Protection par mot de passe N Permission refusée
ACP A2[2] | Permissions compatibles avec ce code action (2) O Permission accordée P Protection par mot de passe (par défaut) N Permission refusée
ACP A2[3] | Permissions compatibles avec ce code action (3) O Permission accordée P Protection par mot de passe N Permission refusée (par défaut)

Notes

ARGUMENT

21 à 34 Valeur de l'argument

41 à 60 Message affiché dans les fenêtres

Saisie mot de passe

Autorisation refusée


ACT Secteurs d'activité

Valeur alpha 1

ACT A1[1] | O Edition des fiches de conformité si paramétré dans le TYC N Pas d'édition des fiches de conformité
ACT A1[2,3] | Filtre des données suivant code paramètre : Exemple :, CP autorise la visu du code pour les tiers clients et prospects F autorise la visu du code uniquement pour les tiers fournisseurs Par défaut, le code est visible pour tous les types de tiers
ACT A1[4,6] | Code activité Correspondance utilisée pour le transfert des tiers JDE La valeur est obligatoire mais non contrôlée

Notes

NOTE_PIED_FACTURE

21 à 60 Texte pour pied de facture.


ADM ???

ADM A1[1,6]

Utilisé comme valeur de retour dans les codes calcul RD et RV quand le caractère 7 = Z.


AFE Etape d'affaire

Utilisé dans le devis standard.

Pas de paramétrage.


AGR Codes agrément

Pas de paramétrage particulier


AID Aide en ligne

Ce paramètre est accessible à partir de la V.4.0.181.2

Voir la page dédiée

Valeur alpha 1

AID A1[1,5]

Suffixe du nom du document dans le cas où celui-ci est construit.

Exemples

.docx, .pdf, ...


AMS Autorisation mauvais sens

Paramètre utilisé pour déterminer le grammage maximum en mauvais sens dans le devis ATLAS-CARTON.


AS Actions de service

Valeur alpha 1

AS A1[1,3]

Code qualificatif de l'action de service

AS A1[4]

Indicateur de saisie obligatoire d'un produit fini (O/N, N par défaut)

AS A1[5]

Suppression par F2 autorisée dans le tableau de description des actions de service

O Autorisée

N Pas autorisée

AS A1[6]

Doublon autorisé pour un PF

O Autorisé

N Pas autorisé

Pour l'action de fabrication, le doublon n'est jamais autorisé.

AS A1[7]

Action de service à comptabiliser dans la VAD (O/N)

AS A1[8]

Action de service à réactualiser pour les commandes de type Transformé (O/N)

AS A1[9]

Action de service à réactualiser pour les commandes de type Cartonnier (O/N)

AS A1[10]

Action de service à comptabiliser dans le calcul de la base des actions de type commission, prime d'activité, etc. (deuxième phase de calcul) (O/N)

AS A1[11]

Action de service à comptabiliser dans le calcul de la base des actions de type marge (deuxième phase de calcul) (O/N)

AS A1[12]

Charge fixe (O/N)

AS A1[13]

Action de service transport (O/N)

AS A1[14,28]

Code article pour prise en compte dans le prix de revient

AS A1[29]

Périmé – Remplacé par CAS alpha1[8]

Réinitialisation de l'action de service lors de la recopie de devis

O L' action de service est réinitialisée [Valeur par défaut]

N L'action de service demeure sans être recalculée.

AS A1[30,35]

Codification (ZH2Z3 à ZH2Z15) de la zone d'historique dans laquelle sont stockés les coûts prévus réalisés de l'action de service.

AS A1[36]

Edition de l'action de service (O/N, O par défaut)

L'action de service est toujours prise en compte dans les calculs même si elle n'est pas éditée.

A1[37]

Action de service valorisée pour un prix départ (Type de port sur entête du devis : kp_demcli.kp_de_tport) (O/N, O par défaut)

Remarque : l'action de service est toujours valorisée pour un prix franco.

Ce paramètre est utilisé dans le cadre du devis onduleur simplifié. Voir G_don option Ods.

A1[38]

Proratiser le frais selon la nomenclature (O/N, N par défaut)

Exemple

Frais lié à une commande : pour un ensemble composé de n composants, il est nécessaire de répartir le frais de commande sur chaque composant.

A1[39]

Ne pas valoriser l'action de service si le couple code client–adresse de livraison est lié au site (SIT A1[1,6] et A1[7,9]) (O/N, N par défaut)

Ce nouveau paramétrage peut être utilisé dans le cas d'une production interne.

Dans ce cas, on ne valorise pas l'action de service Transport.

A1[40]

Valoriser l'action de service uniquement sur le premier composant de l'ensemble dans le cas d'un ensemble monté (O/N, N par défaut).

A1[41]

Valoriser l'action de service uniquement sur le premier composant de l'ensemble dans le cas d'un ensemble monté extérieur (O/N, N par défaut).

A1[42]

Valoriser l'action de service en fonction du type de sous-traitance

T (ou blanc) l'action de service est toujours valorisée (par défaut).

1 l'action de service est valorisée s'il y a une sous-traitance AVEC ou SANS retour de marchandise vers l'usine.

2 l'action de service est valorisée s'il y a une sous-traitance AVEC retour de marchandise vers l'usine.

3 l'action de service est valorisée s'il y a une sous-traitance SANS retour de marchandise vers l'usine.

4 l'action de service est valorisée s'il n'y a pas de sous-traitance ou s'il y a une sous-traitance AVEC retour de marchandise vers l'usine.

Nota : la présence de la sous-traitance se fait via la présence d'un TSC STR sur le triplet article/gamme/phase.

Valeur alpha 2

AS A2[1,9]

Code opération standard sous la forme XXXYYYZZZ

Si non renseignée, alors l'action est non valorisable.

AS A2[10,12]

Code de difficulté (NOR)

AS A2[13,18]

Code machine (XXXXXX)

AS A2[19,21]

Code formule pour réaliser la fonctionnalité

Une action de service XXX utilise en général une opération standard XAS XAS xxx.

C'est alors la formule de calcul paramétrée sur cette opération standard qui est utilisée (en général et par convention XAS XXX O).

Dans le cas où une action de service YYY utilise une opération standard autre que XAS XAS XXX, il faut pouvoir indiquer que c'est la formule XAS YYY O qui doit être utilisée.

Exemple : le transport entre l'usine et un sous-traitant utilise les mêmes matrices que le transport entre l'usine et le client mais avec des caractéristiques différentes.

Valeur alpha 3

AS A3[1]

Action de service à comptabiliser dans le calcul de la base des actions de type commission seule (troisième phase de calcul) (O/N)

AS A3[2]

Prise en compte de cette action de service pour le calcul du prix de cession du produit (O/N)

N = Exclusion du prix de cession

AS A3[3]

Calcul du coût prévu dans les dossiers par proratisation par rapport à la quantité lancée (O/N)

Par défaut (N), on proratise par rapport à la quantité commandée.

AS A3[4]

Autorisation de saisir une grille de tarif selon la quantité

O Saisie d'une grille de tarif autorisée

N Saisie d'une grille de tarif non autorisée.

Lors de la saisie du devis, dans l'écran des actions de service, l'utilisateur peut saisir une grille de tarif/unité selon la quantité.

Cette grille de saisie est accessible ou non selon AS A3[4].

Les valeurs saisies dans cette grille sont accessibles via des codes calculs.

Dans cette optique, 2 nouveaux codes calculs ont été créés au niveau des caractéristiques d'actions de service (CAS A2[7,8]) :

PX Prix selon la quantité

UN Valeur de l'unité selon la quantité

Notes

C

2 à 4 Code caractéristique (paramètre de type CAS)

On limitera le nombre de lignes à 20

Cette liste fournit la séquence d'apparition à l'écran


ASO Action de suivi d'outillage

Ce paramètre est utilisé par G_gestion_outils.

Valeur alpha 1

ASO A1[1]

Statut d'action

P Prévisionnelle

R Réelle (par défaut)

ASO A1[2]

Type d'action

M Manuelle (par défaut)

A Automatique

F Facturation (automatique)

ASO A1[3]

Mise à zéro du nombre de passes réalisées

N Pas de remise à zéro

C Demande de confirmation

O Remise à zéro systématique

ASO A1[4]

Mise à jour du nombre de passes réalisées et du taux d'utilisation

N Pas de mise à jour

O Mise à jour systématique

Remarques

Les informations de passes sont enregistrées sur le TSC O01.

Taux d'utilisation : Nombre de passes réalisées / Nombre de passes maximum

ASO A1[5,7]

Action à supprimer lors de l'enregistrement de l'action courante

Exemple : Suppression de l'action prévisionnelle à l'enregistrement de l'action réelle

Remarques

L'action à supprimer est recherchée en priorité avec le code action puis le numéro de commande de fabrication et/ou le numéro de commande d'achat.

Si aucun numéro de commande n'est renseigné au moment de la recherche, on prend l'action correspondante la plus ancienne.

Les mouvements de stocks associés à l'action à supprimer sont annulés. Voir A2[1, 3] et A2[10,12]

ASO A1[8]

Type d'action à effectuer lors de la création de l'action (manuelle ou automatique)

C Création d'un nouveau code outil par recopie du code outil courant

D Destruction du code outil courant (Annulation logique)

Remarque : La codification du nouveau code outil reprend le paramétrage standard de la saisie simplifiée (notes CODIF_ART sur la famille ou sur le paramètre de lancement).

ASO A1[9,11]

Code action automatique à générer sur le code outil nouvellement créé (uniquement si A1[8] = C).

Remarque : Aucun contrôle n'est effectué pour la création de cette action.

ASO A1[12]

Suppression physique de l'action à annuler (voir caractères 5 à 7)

O Les mouvements de stocks prévisionnels sont annulés et l'action est supprimée physiquement

N Les mouvements de stocks prévisionnels sont annulés mais l'action n'est pas supprimée physiquement (par défaut)

Valeur alpha 2

ASO A2[1,3] | Type de mouvement d'entrée à générer lors de l'enregistrement de l'action Ce type de mouvement est également pris en compte lors de l'annulation de l'action, le mouvement de stock d'entrée associé étant alors annulé.
ASO A2[4,6] | Code calcul de date de mouvement de stock d'entrée 001 Date de début de l'action 002 Date de fin de l'action 003 Date de l'action 004 Date de fin de fabrication prévue de la ligne de FBI rattachée à l'action 005 Date de fin de fabrication prévue de la ligne de FBI rattachée à l'action – Nombre de jours paramétré en A2[7,9]. 006 Date de solde de la ligne de FBI rattachée à l'action
ASO A2[7,9] | Si le code calcul de date est égal à 005 : Nombre de jours à retirer
ASO A2[10,12] | Type de mouvement de sortie à générer lors de l'enregistrement de l'action Ce type de mouvement est également pris en compte lors de l'annulation de l'action, le mouvement de stock de sortie associé étant alors annulé.
ASO A2[13,15] | Code calcul de date de mouvement de stock de sortie 001 Date de début de l'action 002 Date de fin de l'action 003 Date de l'action 004 Date de fin de fabrication prévue de la ligne de FBI rattachée à l'action 005 Date de fin de fabrication prévue de la ligne de FBI rattachée à l'action – Nombre de jours paramétré en A2[16,18]. 006 Date de solde de la ligne de FBI rattachée à l'action
ASO A2[16,18] | Si le code calcul de date est égal à 005 : Nombre de jours à retirer
ASO A2[19] | Type de mouvement de stock dans le cas d'un transfert inter-usine T Transfert de l'emplacement d'origine vers un emplacement externe R Réception de l'outil de l'emplacement externe vers l'emplacement d'origine N Mouvement de stock intra-usine (par défaut) Remarque : Le magasin externe doit être renseigné sur l'action de suivi d'outillage (zone acm_magasin de la table action_mat)

Valeur alpha 3

ASO A3[1,3]

Nouveau code validité d'article à mettre en place sur l'outil lors de l'enregistrement de l'action

ASO A3[4,6]

Nouveau code validité d'article à mettre en place sur les produits finis rattachés à l'outil lors de l'enregistrement de l'action

ASO A3[7]

Mise à jour de la date de début de validité de l'outil avec la date de fin de l'action (O/N, N par défaut)

Remarque : Si la nouvelle date de début de validité de l'outil est supérieure à la date de fin de validité renseignée, cette dernière est réinitialisée avec la date de début de validité.

ASO A3[8]

Mise à jour de la date de fin de validité de l'outil avec la date de fin de l'action (O/N, N par défaut)

Remarque : Si la nouvelle date de fin de validité de l'outil est inférieure à la date de début de validité renseignée, cette dernière est réinitialisée avec la date de fin de validité.

Notes triées

CALCUL_DATES_ACTION | 21,28 Nom du champ date à calculer lors de la création d'une action acm_date_action Date de l'action acm_date_debut Date de début d'action acm_date_fin Date de fin d'action 39,41 Code de calcul de date 001 Date du jour 002 Date de fin de fabrication de la FBI 003 Date de fin de fabrication de la FBI – Nombre de jours paramétré 004 Date de solde de la FBI 42,44 Pour le code calcul date 003 uniquement : Nombre de jours à déduire de la date de fin de fabrication
CONTROLE_DE_SAISIE | Paramétrage en colonnes, séparées par un astérisque Code*Type erreur*Paramètre 1*Paramètre 2* Code contrôle : Voir liste ci-dessous Type d'erreur N Pas de contrôle W Avertissement en cas d'erreur C Confirmation en cas d'erreur B Arrêt en cas d'erreur Paramètre 1 : Selon code, Voir liste ci-dessous Paramètre 2 : Selon code, Voir liste ci-dessous
INFO_A_SAISIR | Paramétrage en colonnes, séparées par un astérisque Libellé *Nom *Obligation de saisie Libellé du champ : Libellé du champ à saisir Nom du champ : Nom du champ à saisir (table action_mat) Obligation de saisie N Saisie facultative W Avertissement si zone non saisie C Confirmation si zone non saisie B Saisie obligatoire

Liste codes contrôles disponibles

Ces codes sont utilisés par la note CONTROLE_DE_SAISIE.

Code

Description

Périmètre (1)

Paramètres

001

Contrôle d'existence de mouvement de sortie prévisionnelle sur l'outillage

VAL

aucun

002

L'outil doit être en stock

ACT

aucun

003

L'outil ne doit pas être en stock

ACT

aucun

004

Contrôle de saisie d'informations sur l'outillage

ACT

1 Libellé du champ devant être saisi

2 Nom du champ devant être saisi :

Zone de la table mat

Information complémentaire sous la forme TSC_XXX_YY

XXX Code TSC

YY Colonne d'information

N1 Zone numérique 1

N2 Zone numérique 2

N3 Zone numérique 3

D1 Zone de date 1

D2 Zone de date 2

C1 Zone alphanumérique 1

C2 Zone alphanumérique 2

C30 Zone alphanumérique de 30 caractères

005

Contrôle des dates par rapport aux dates de validité d'outillage

VAL

aucun

006

Contrôle du code validité de l'outillage

ACT

1 Code validité

Si le paramètre Obligation de saisie est à N :

Liste des codes validités d'outil autorisés pour créer l'action

Si le paramètre Obligation de saisie est différent de N :

Liste des codes validités interdits (interdiction bloquante, en avertissement ou sur confirmation selon le paramétrage) pour créer l'action.

Remarque : Si le code validité de l'outil utilisé pour l'action n'est pas trouvé dans la liste des codes autorisés, un message d'erreur est affiché et l'action ne peut pas être créée.

007

Contrôle de la famille/sous-famille de l'outillage

ACT

1 Code famille

Si le paramètre Obligation de saisie est à N :

Liste des codes familles d'outil autorisés pour créer l'action

Si le paramètre Obligation de saisie est différent de N :

Liste des codes familles interdits (interdiction bloquante, en avertissement ou sur confirmation selon le paramétrage) pour créer l'action.

2 Code sous-famille

Si le paramètre Obligation de saisie est à N :

Liste des codes sous-familles d'outil autorisés pour créer l'action

Si le paramètre Obligation de saisie est différent de N :

Liste des codes sous-familles interdits (interdiction bloquante, en avertissement ou sur confirmation selon le paramétrage) pour créer l'action.

Remarques

Si le code famille de l'outil utilisé pour l'action n'est pas trouvé dans la liste des codes autorisés, un message d'erreur est affiché et l'action ne peut pas être créée.

Si le code sous-famille de l'outil utilisé pour l'action n'est pas trouvé dans la liste des codes autorisés, un message d'erreur est affiché et l'action ne peut pas être créée.

Si la sous-famille est paramétrée avec la famille qui lui est associée, c'est le libellé de la sous-famille hiérarchique (F6 sur paramètre FAM) qui sera affiché dans le message d'erreur.

Sinon, c'est le libellé du paramètre SFM.

(1) Périmètres d'application des contrôles

ACT Contrôle effectué à la modification du code action (avant la saisie des autres informations)

VAL Contrôle effectué à la validation de l'action (enregistrement)


ATE Ateliers

Valeur alpha 1

ATE A1[1] | Type d'atelier (utilisé dans l'édition des données de production)
ATE A1[2,7] | Prise en compte des ateliers saisis sur les lignes Code du client définissant l'adresse de l'atelier Voir la note TSC_ATELIER_LIVRE dans genere_edi_cde
ATE A1[8,10] | Prise en compte des ateliers saisis sur les lignes Code de l'adresse client définissant l'adresse de l'atelier Voir la note TSC_ATELIER_LIVRE dans genere_edi_cde


ATR Evénements d'alerte de traçabilité

Tous les champs de la table fab_1_etat

Ils'agit de l'enregistrement rattaché à l'état de fabrication ayant créé l'événement de traçabilité (nouvel enregistrement, seules certaines informations de l'ancien enregistrement sont disponibles, voir ci-dessous)

f1e_of_cde Numéro de commande de fabrication

f1e_of_lig Numéro de ligne de commande de fabrication

La modification de la date de planification lors de l'intégration TB-DATA crée l'événement de traçabilité qui va déclencher l'alerte. L'ancienne et la nouvelle date sont disponibles grâce aux codes suivants :

old_f1e_date_planif Ancienne date de planification

f1e_date_planif Nouvelle date de planification

La modification de l'heure de planification lors de l'intégration TB-DATA crée l'événement de traçabilité qui va déclencher l'alerte. L'ancienne et la nouvelle heure sont disponibles grâce aux codes suivants :

old_f1e_heure_planif Ancienne heure de planification

f1e_heure_planif Nouvelle heure de planification

La modification du code équipe lors de l'intégration TB-DATA crée l'événement de traçabilité qui va déclencher l'alerte. L'ancien et le nouveau code équipe sont disponibles grâce aux codes suivants :

old_f1e_equipe Ancien code équipe

f1e_equipe Nouveau code équipe

Permettre via une action sur alerte de traçabilité des tables entités (fle_imp) et lignes complémentaires (fle_com) de :

• Remettre à zéro une formule

• Réinitialiser les prix matières

• Prendre en compte les quantités matières pour la partie variable

Remarques :

• Ces actions de mise à jour de formules sont équivalentes à celles paramétrables lors de l'intégration Preactor (notes ACT_CAD_NON_VALIDE)

• Contrairement à l'intégration Preactor, ces actions ne sont pas exécutées dans le cadre d'une lecture de cadencement de fabrication.
Si ces actions doivent être exécutées dans le cadre d'un devis de fabrication lié à un cadencement non validé, le complément de sélection des actions à effectuer (notes _SUP_REQ_ATR) devra être construit en conséquence.

ATR Evénements d'alerte de traçabilité

Ce paramétrage est utilisé par le programme alerte_tracabilite.

Gestion des actions à effectuer

Envoi depuis la gestion alerte traçabilité, d'un fichier transformé en PDF, puis envoyé par Mail

Valeur alpha 1

ATR A1[1]

Activation de l'alerte (O/N, N par défaut)

ATR A1[2]

Afficher le détail des zones qui ont changé de valeur (O/N, O par défaut)

ATR A1[3]

Type d'événement réservé pour la gestion des alertes sur la table envoi_fax_email

La note SUP_REQ_ATR n'est pas obligatoire dans cette gestion, elle peut être activée, et porte alors sur des zones de la table envoi_fax_email (si l'on veut avoir des destinataires différents selon le type de document).

Voir, dans le programme alerte_tracabilite, le paragraphe décrivant la fonction permettant de recevoir automatiquement une information indiquant que des mails valides et autorisés sont toujours en attente d'envoi.

Valeur alpha 2

ATR A2[1,60]

Objet du message (pour envoi par mail)

Utile uniquement si utilisation de la solution VoluFaxMail.

Valeur alpha 3

ATR A3[1,60]

Répertoire et nom de la pièce jointe

Notes

ATR_ACTION_

Cette note est utilisée dans le cadre de la gestion des actions à effectuer, voir ci-dessous.

ATR_MSG

21, 60 Libellé par défaut d'entête du message.

Ce libellé sera pris par défaut si aucune note ATR_MSG_XXX n'a été créée sur le paramètre dont le type et le code sont indiqués dans la note ENVOI_DEST ci-dessous).

Le symbole $ permet de faire un saut de ligne.

On peut afficher certaines variables : les mots-clés (liste ci-dessous) doivent être entourés de %.

TE_CLE_ALPHA | Clé alpha de la table tracabilite_e
TE_CLE_NUM | Clé numérique
TE_CODE_USER TE_LIBC_USER TE_LIBL_USER | Code utilisateur Libellé court de l'utilisateur Libellé long de l'utilisateur
TE_EVENEMENT | Evénement (création, modification, annulation logique, annulation physique)
TE_DATE | Date de l'événement
TE_HEURE | Heure de l'événement
TE_LOGIN | Login utilisateur
TE_TYPE_PAR_LCT | Type du paramètre de lancement du programme ayant déclenché l'événement
TE_CODE_PAR_LCT | Code du paramètre de lancement du programme ayant déclenché l'événement
TE_SERIAL | N° de série de l'événement
TE_TABLE | Table de la base atlas concernée par l'événement
TE_TRANSFERE | Transféré (O/N)
TE_MODULE | Libellé du module à l'origine de l'événement
TODAY | Date du jour

Exemples

ATR_MSG La commande %TE_CLE_ALPHA%-%TE_CLE_NUM%

ATR_MSG a été modifiée par %TE_LOGIN% $le

ATR_MSG %TE_DATE% à %TE_HEURE%.

Autre possibilité : Texte du message avec les variables encadrées de %

On peut ajouter n'importe quelle valeur des tables :

ATTENTION : les noms sont en minuscules !

blv1 - blv2

cde1, cde2, cde4, cde8, cde_qualif

cli

fab_1_etat Plus d'info

fle_2

fle_imp

groupage_bl

info_c

lib_etr

ordre_transport

et aussi les 3 codes suivants :

CDE_LIEU_LIV_CLI : nom du client issu de lc_lieu_rgt1 (sinon issu de lc_adl)

CDE_LIEU_LIV_CODP : code postal du client issu de lc_lieu_rgt1 (sinon issu de lc_adl)

CDE_LIEU_LIV_VIL : ville du client issu de lc_lieu_rgt1 (sinon issu de lc_adl)

CDE_ADR_LIV_CLI : nom du client livré final (issu de lc_adl ou ec_cli)

CDE_ADR_LIV_CODP : code postal du client livré final (issu de lc_adl ou ec_cli)

CDE_ADR_LIV_VIL : ville du client livré final (issu de lc_adl ou ec_cli)

ATR_OBJET

21,60 Titre de l'objet pouvant contenir les mots clés déjà existant

ENVOI_DEST

Envoi de l''alerte de traçabilité vers un code utilisateur (le créateur ou celui qui gère l'action) ou vers un groupe d'utilisateurs

21,23 Type de paramètre

USE (type d'utilisateur)

FAB (fabricant - suivi d'affaire)

GRU (groupe d'utilisateurs)

24,26 Type de paramètre

<OU>

Code de recherche - Les codes suivants sont disponibles :

%a% (uniquement pour le type FAB)
Code spécifique de recherche de suivi d'affaire sur l'outillage
Recherche du suivi d'affaire sur le client rattaché à l'outillage.
Si aucun client n'est rattaché, on prend par défaut le suivi d'affaire du client société (#SOC).
Fonctionnement particulier à la gestion de l'outillage

%b% (uniquement pour le type FAB)
Code spécifique de recherche de l'intervenant associé à la commande rattachée, composant et machine de l'état de fabrication de l'OF (table n°64 : fab_1_etat)
Fonctionnement spécifique à la gestion des motifs de qualification/surveillance.
Permet de récupérer comme destinataire le code utilisateur intervenant de la gestion des motifs de qualification/surveillance.

%c% (uniquement avec le type USE)

Fonctionne uniquement avec les actions événements.

Recherche du code utilisateur créateur de la demande (ace_creer_par).

%d% (uniquement avec le type GRU)

Fonctionne uniquement avec les actions événements.

Recherche du code groupe utilisateur de l’action (ace_groupe).

%e% (uniquement avec le type USE)

Fonctionne uniquement avec les actions événements.

Recherche du code utilisateur qui gère l’action (ace_gerer_par).

Il est possible de paramétrer plusieurs destinataires, chacun faisant l'objet d'une ligne commençant par ENVOI_DEST

Exemples

ENVOI_DEST USESA

ENVOI_DEST USEPM

Le message sera adressé à 2 destinataires référencés dans le paramètre de type USE, ayant pour codes SA et PM.

Exemples avec codes de recherches

ENVOI_DEST USE%c%

ENVOI_DEST GRU%d%

_SUP_REQ_ATR

Cette note est utilisée dans le cadre de la gestion des actions à effectuer, voir ci-dessous.

Gestion des actions à effectuer

Permet d'effectuer des actions précises lors de la détection d'un mouvement de traçabilité sur une ou plusieurs table(s).

En date du 09/09/2010, 2 actions sont disponibles :

- Répercuter les informations saisies sur une société source vers une ou plusieurs société(s) cible(s), en création et/ou modification.

- Mettre à jour un ou plusieurs champs d'un sous-devis (table fle_2)

D'autres types d'actions pourront voir le jour ultérieurement.

Les tables gérées sont définies ici.

Remarques

  • Les informations des tables cli3, corres, mat3, tar0 et par02note sont recopiées en mode annule et remplace.
    Exemple : si on détecte un événement de traçabilité sur les notes de type XXX d'un article A, on supprime toutes les notes de type XXX sur l'article A sur la société cible puis on recopie les notes de type XXX de la société source vers la société cible, toujours pour l'article A.

  • Attention : Lors de la recopie d'un élément A (ex : tarif) associé à un autre élément B (ex : article, tiers, etc.), on considère que l'élément B existe sur la société cible.

  • Pour fonctionner correctement, la gestion de la traçabilité doit être activée pour toutes les tables concernées.

  • Lors de la création d'un tiers, d'un article et/ou d'un paramètre sur la société cible, toutes les tables liées sont recopiées
    (même si celles-ci ne font pas l'objet d'un événement de traçabilité).

Gestion des actions à effectuer - Paramétrage

#CF TRA | Nouvelles tables qui n'étaient pas tracées jusqu'à présent (tables 66 à 75)
alerte_tracabilite | Options Obo et Oar Notes FIC_LOCK, FIC_ARRET, FIC_TRACE, FIC_ANOMALIE, TPS_ATTENTE_BOUCLE, ACTIONS_AUTORISEES
ATR (cette page) | Notes _SUP_REQ_ATR et ATR_ACTION_ décrites ci-dessous :

_SUP_REQ_ATR

21,60 Complément de sélection pour la génération de l'événement.

La sélection indiquera au programme les événements de traçabilité à prendre en compte pour ce paramétrage.

Les tables disponibles sont :

Événements de traçabilité d'entête (tracabilite_e)

Événements de traçabilité de détail (tracabilite_d)

Important :

- Ce paramétrage est obligatoire.

- Les numéros des tables à prendre en compte doivent être indiqués via ce paramétrage.
La liste des tables tracées ainsi que leur numéro associé est disponible dans le paramètre #CF TRA.

- Les événements de traçabilité à prendre en compte pour l'action 002 doivent être liés à un sous-devis (exemples).

- Les événements de traçabilité à prendre en compte pour l'action 003 doivent être liés à une entité (table 31, fle_imp) ou une ligne complémentaire (table 32, fle_com)

Dans le complément de sélection, les mots-clés suivants sont disponibles :

TODAY

TODAY[Opérande][Nombre de jours]

TODAY[Opérande]CAL_[Nombre de jours]

TODAY[Opérande]CAL_[Code calendrier]_[Nombre de jours]

où

[Opérande] : + ou -

[Nombre de jours] : Nombre de jours à ajouter/supprimer à la date du jour

CAL_[Code calendrier] : Code calendrier Client/Employé. Par défaut : #SOC.

Exemples

TODAY-5 : Date du jour – 5 jour

TODAY+CAL_2 : Date du jour + 2 jours ouvrés (calendrier société #SOC)

TODAY-CAL_CL052_15 : Date du jour – 15 jours ouvrés (calendrier du client CL052)

Exemple de complément de sélection

and s0_datm <= (TODAY-CAL_3) : Date du mouvement de stock inférieure ou égale à la date du jour – 3 jours ouvrés.

ATR_ACTION_

Permettre d'effectuer des actions précises lors de la détection d'un mouvement de traçabilité sur une ou plusieurs tables.

12,14 Code action

001 Recopie d'informations vers d'autres sociétés

002 Mise à jour d'un champ d'un sous-devis (table fle_2)

003 Lancement d'actions paramétrables de mise à jour de formule
21,38 Nom du champ concerné à prendre dans les tables fle_2 ou fle_com
39,60 Laisser à vide. Le paramétrage doit être défini dans la note ACT_CAD_NON_VALIDE (ici, paramètre ATR) en utilisant la même syntaxe que celle du paramètre de lancement du programme integration_preactor.
Paramétrer aussi un complément de sélection via _SUP_REQ_ATR (ci-dessus)
Plus d'info

21,38 Nom du champ concerné. Voir ci-dessous les tables disponibles et le paramétrage associé.

La racine du nom permet de récupérer le nom de la table concernée.

Pour chaque table disponible, tous les champs sont utilisables.

Indiquez ici :

[racine de la table]* : Tous les champs de la table sont concernés (exemple : cl_* : tous les champs de la table cli)

<ou bien>

nom de champ : Seul le champ paramétré est concerné (exemple : cl_ech : seul ce champ est concerné).

Voir des exemples (plus bas)

39,60 Paramétrage de l'action à effectuer.

Ce paramétrage varie en fonction de la table concernée.

Voir ci-dessous les tables disponibles et le paramétrage associé.

Gestion des actions à effectuer - Tables disponibles et paramétrage associé pour les notes commençant par ATR_ACTION

Sauf indication contraire, les paramètres suivants sont communs à chaque table :

Caractère 39 | M Création ou modification selon l'existence sur la société cible C Création uniquement si enregistrement inexistant sur la société cible (par défaut) I Champ ne devant pas être mis à jour dans le cas d'une modification sur la société cible. Attention : uniquement si un champ est précisé dans les caractères 21 à 38. Si l'action concerne tous les champs, ce paramétrage est ignoré. Dans le cas d'une création sur la société cible, ce paramétrage est ignoré.
Caractères 40 à 42 | Code société cible (une ligne de note par société cible). Mettre un astérisque pour indiquer toutes les sociétés (autres que la société source).

IMPORTANT :

L'utilisation du paramétrage de type d'égalité doit respecter l'ordre suivant :

Les égalités, représentées par le signe égal (=), puis les exclusions, représentées par le point d'exclamation (!).

Dans le cas des exclusions, c'est la dernière ligne de paramétrage qui est prise en compte si la condition n'est pas vérifiée dans les égalités et qu'elle se vérifie pour toutes les exclusions, voir les exemples en fin de ce paragraphe.

Note ATR_ACTION_001 - Tables liées aux tiers

cli : Tiers, adresse principale (table N° 10)

21,38 | cl_* L'action concerne tous les champs. cl_xxx L'action ne concerne que le champ cl_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

cli2 : Tiers, adresses secondaires (table N° 11)

21,38 | c2_* L'action concerne tous les champs. c2_xxx L'action ne concerne que le champ c2_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

cli3 : Notes sur les tiers (table N° 66)

21,38

cc_* L'action concerne tous les champs.

39

Type de recopie vers la société cible

A Annule et remplace systématiquement les enregistrements correspondants à la clé code client/code adresse/type de note sur la société cible.

M idem A

C Recopie uniquement si aucune ligne de note n'existe pour la clé code client/code adresse/type de note sur la société cible
(par défaut).

40,42

Société cible

43

Type d'égalité pour la comparaison du type de note

= (signe égal) Recopie uniquement des notes du type paramétré ci-dessous (par défaut)

! (point d'exclamation) Recopie uniquement des notes de type différent de celui paramétré ci-dessous

44,46

Type de note à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de note)

cli5 : Historisation des assurances/crédits (table N° 67)

21,38 | c5_* L'action concerne tous les champs. c5_xxx L'action ne concerne que le champ c5_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

cli6 : Modèles de documents (table N° 68)

21,38 | c6_* L'action concerne tous les champs. c6_xxx L'action ne concerne que le champ c6_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

corres : Correspondants (table N° 26)

21,38

co_* L'action concerne tous les champs.

39

Type de recopie vers la société cible

A Annule et remplace systématiquement les enregistrements correspondants à la clé code client/type de correspondant/nom du correspondant sur la société cible.

M idem A

C Recopie uniquement si aucun correspondant n'existe pour la clé code client/type de correspondant/nom du correspondant sur la société cible (par défaut).

40,42

Société cible

Note ATR_ACTION_001 - Tables liées aux articles

mat : Articles (table N° 14)

21,38 | mp_* L'action concerne tous les champs. mp_xxx L'action ne concerne que le champ mp_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat2 : Fournisseurs secondaires des articles (table N° 69)

21,38 | mf_* L'action concerne tous les champs. mf_xxx L'action ne concerne que le champ mf_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat3 : Notes sur les articles (table N° 70)

21,38

mc_* L'action concerne tous les champs.

39

Type de recopie vers la société cible

A Annule et remplace systématiquement les enregistrements correspondants à la clé code article/ type de note sur la société cible.

M idem A

C Recopie uniquement si aucune ligne de note n'existe pour la clé code article/ type de note sur la société cible (par défaut).

40,42

Société cible

43

Type d'égalité pour la comparaison du type de note

= (signe égal) Recopie uniquement des notes du type paramétré ci-dessous (par défaut)

! (point d'exclamation) Recopie uniquement des notes de type différent de celui paramétré ci-dessous

44,46

Type de note à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de note)

mat5 : Calendrier des mouvements d'articles (table N° 71)

21,38 | m5_* L'action concerne tous les champs. m5_xxx L'action ne concerne que le champ m5_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat_format : Formats (table N° 72)

21,38 | mpf_* L'action concerne tous les champs. mpf_xxx L'action ne concerne que le champ mpf_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat_grammage : Grammages (table N° 73)

21,38 | mpg_* L'action concerne tous les champs. mpg_xxx L'action ne concerne que le champ mpg_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat_site : Lieux de rangement par site (table N° 74)

21,38 | ms_* L'action concerne tous les champs. ms_xxx L'action ne concerne que le champ ms_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

mat_var_prod : Variantes de production (table N° 75)

21,38 | mva_* L'action concerne tous les champs. mva_xxx L'action ne concerne que le champ mva_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

Note ATR_ACTION_001 - Tables liées aux tiers et aux articles

info_c : Informations complémentaires (TSC) (table N° 4)

21,38 | ic_* L'action concerne tous les champs. ic_xxx L'action ne concerne que le champ ic_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible
43 | Type d'égalité pour la comparaison du type de clé de TSC = (signe égal) Prise en compte uniquement des TSC du type de clé paramétré ci-dessous (par défaut) ! (point d'exclamation) Prise en compte uniquement des TSC de type de clé différent de celui paramétré ci-dessous.
44 | Type de clé de TSC à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de clé de TSC) A Article F Tiers
45 | Type d'égalité pour la comparaison du code de TSC = (signe égal) Prise en compte uniquement des TSC du code paramétré ci-dessous (par défaut) ! (point d'exclamation) Prise en compte uniquement des TSC de code différent de celui paramétré ci-dessous.
46 | Code de TSC à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par code TSC).

tar0 : Tarifs (table N° 38)

21,38

tr_* L'action concerne tous les champs.

39

Type de recopie vers la société cible

A Annule et remplace systématiquement les enregistrements correspondants à la clé code article/code client/code tarif/code famille/code sous-famille/code catégorie sur la société cible.

M idem A

C Recopie uniquement si aucun tarif n'existe pour la clé code article/code client/code tarif/code famille/code sous-famille/code catégorie sur la société cible (par défaut)

40,42

Société cible

lib_etr : Libellés étrangers (table N° 60)

21,38 | le_* L'action concerne tous les champs. le_xxx L'action ne concerne que le champ le_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible

Note ATR_ACTION_001 - Tables liées aux paramètres

par02 : Paramètres (table N° 12)

21,38 | p2_* L'action concerne tous les champs. p2_xxx L'action ne concerne que le champ p2_xxx.
39 | Type de recopie vers la société cible (M/C/I)
40,42 | Société cible
43 | Type d'égalité pour la comparaison du type de paramètre = (signe égal) Prise en compte uniquement des paramètres du type paramétré ci-dessous (par défaut) ! (point d'exclamation) Prise en compte uniquement des paramètres de type différent de celui paramétré ci-dessous.
44,46 | Type de paramètre à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de paramètre)
47 | Type d'égalité pour la comparaison du code de paramètre = (signe égal) Prise en compte uniquement des paramètres du code paramétré ci-dessous (par défaut) ! (point d'exclamation) Prise en compte uniquement des paramètres de code différent de celui paramétré ci-dessous.
48,50 | Code de paramètre à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de paramètre)

par02note : Notes sur les paramètres (table N° 13)

21,38

pn2_* L'action concerne tous les champs.

39

Type de recopie vers la société cible

A Annule et remplace systématiquement les enregistrements correspondants à la clé type paramètre/code paramètre sur la société cible.

M idem A

C Recopie uniquement si aucune ligne de note n'existe pour la clé type paramètre/code paramètre sur la société cible (par défaut)

40,42

Société cible

43

Type d'égalité pour la comparaison du type de paramètre

= (signe égal) Prise en compte uniquement des paramètres du type paramétré ci-dessous (par défaut).

! (point d'exclamation) Prise en compte uniquement des paramètres de type différent de celui paramétré ci-dessous.

44,46

Type de paramètre à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de paramètre)

47

Type d'égalité pour la comparaison du code de paramètre

= (signe égal) Prise en compte uniquement des paramètres du code paramétré ci-dessous (par défaut).

! (point d'exclamation) Prise en compte uniquement des paramètres de code différent de celui paramétré ci-dessous.

48,50

Code de paramètre à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par type de paramètre)

sfm : Sous-familles hiérarchiques (table N° 24)

21,38

sf_* L'action concerne tous les champs.

sf_xxx L'action ne concerne que le champ sf_xxx.

39

Type de recopie vers la société cible (M/C/I)

40,42

Société cible

43

Type d'égalité pour la comparaison du code famille

= (signe égal) Prise en compte uniquement des familles du code paramétré ci-dessous (par défaut).

! (point d'exclamation) Prise en compte uniquement des familles de code différent de celui paramétré ci-dessous.

44,46

Code famille à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par code famille)

47

Type d'égalité pour la comparaison du code sous-famille

= (signe égal) Prise en compte uniquement des sous-familles du code paramétré ci-dessous (par défaut).

! (point d'exclamation) Prise en compte uniquement des sous-familles de code différent de celui paramétré ci-dessous.

48,50

Code sous-famille à prendre en compte ou à exclure selon le paramétrage ci-dessus (une ligne par code sous-famille)

Note ATR_ACTION_002 - Table des sous-devis

fle_2 : Sous-devis (table N° 30)

21,38 | Nom du champ concerné. Celui-ci doit appartenir à la table des sous-devis (fle_2) Exemple l2_sce_calcul : L'action de mise à jour concerne le scénario de calcul du sous-devis.
39 | Type de la zone à mettre à jour - Obligatoire, pas de valeur par défaut A Alphanumérique N Numérique
40,60 | Valeur de mise à jour

Gestion des actions à effectuer - Exemples de paramétrage pour les notes commençant par _SUP_REQ_ATR

Tables liées aux tiers - Paramètre ATR 1CL - Recopie des informations tiers vers les autres sociétés

and ( ( te_num_table = 4 and te_cle_alpha matches "F-*" ) | Sélection des événements de traçabilité d'entête sur la table des informations complémentaires (TSC, info_c/4), pour les TSC concernant les tiers uniquement (type de clé de TSC = F)
or ( te_num_table = 10 and te_cle_alpha in (select cl_code from cli where cl_soc = te_soc and cl_code = te_cle_alpha and cl_cpf != "P") ) | Sélection des événements de traçabilité d'entête sur la table des tiers (cli/10), pour tous les tiers sauf les prospects (type de tiers = P)
or te_num_table in (11,26,66,67,68) ) | Sélection des événements de traçabilité d'entête sur les tables des adresses secondaires (cli2/11), des correspondants (corres/26), des notes sur tiers (cli3/66), des historisations assurances/crédits (cli5/67) et des modèles de documents (cli6/68)

Tables liées aux articles - Paramètre ATR 1AR - Recopie des informations articles vers les autres sociétés

and ( ( te_num_table = 4 and te_cle_alpha matches "A-*" ) | Sélection des événements de traçabilité d'entête sur la table des informations complémentaires (TSC, info_c/4), pour les TSC concernant les articles uniquement (type de clé de TSC = A)
or te_num_table in (14,69,70,71,72,73, 74,75) ) | Sélection des événements de traçabilité d'entête sur les tables des articles (mat/14), fournisseurs secondaires (mat2/69), notes sur articles (mat3/70), calendriers de mouvements (mat5/71), formats (mat_format/72), grammages (mat_grammage/73), lieux de rangement par site (mat_site/74), variantes de production (mat_var_prod/75).

Tables liées aux tiers et aux articles - Paramètre ATR 1DG - Recopie des tarifs et libellés vers les autres sociétés

and te_num_table in (38,60)

Sélection des événements de traçabilité d'entête sur les tables des

tarifs (tar0/38),

libellés étrangers (lib_etr/60).

Tables liées aux paramètres - Paramètre ATR 1PA - Recopie des paramètres vers les autres sociétés

and te_num_table in (12,13,24)

Sélection des événements de traçabilité d'entête sur les tables des

paramètres (par02/12),

notes sur les paramètres (par02note/13,

sous-familles hiérarchiques (sfm/24).

Gestion des actions à effectuer - Exemples de paramétrage pour les notes commençant par _ATR_ACTION_001

Tables liées aux tiers - Paramètre ATR 1CL - Recopie des informations tiers vers les autres sociétés

cl_* M*

cl_ech I003

Recopie des tiers (adresse principale) sur toutes les sociétés cibles (002 et 003 donc), en mode Création/modification

Le champ échéance (cl_ech) de l'adresse principale ne doit pas être mis à jour sur la société cible 003 (seulement dans le cas d'une modification, le tiers existant déjà sur la société 003)

c2_* M*

c2_ech I*

Recopie des adresses secondaires sur toutes les sociétés cibles, en mode Création/modification

Le champ échéance (c2_ech) des adresses secondaires ne doit pas être mis à jour sur les sociétés cibles (dans le cas d'une modification, les adresses secondaires existant déjà sur les sociétés cibles).

cc_* A* =FAB

cc_* C* =QT

cc_* C* !LIV

cc_* A* !FAC

Recopie des notes de type FAB en mode Annule et remplace sur toutes les sociétés cibles.

Recopie des notes de type QT en mode Création uniquement sur toutes les sociétés cibles (recopie uniquement s'il n'existe aucune ligne de note de type QT sur l'adresse secondaire de la société cible)

Recopie de toutes les notes sauf celles de type LIV en mode Création uniquement sur toutes les sociétés cibles

Recopie de toutes les notes sauf celles de type FAC en mode Annule et Remplace sur toutes les sociétés cibles

Remarque : Pour un type de note ne vérifiant pas les conditions d'égalité et vérifiant toutes les conditions d'exclusion, c'est la dernière ligne de paramétrage qui est prise en compte.

Par exemple, les notes de type FRA seront ici recopiées en mode Annule et remplace (FRA différent de LIV, et différent de FAC).

Exemples d'actions réalisées sur les sociétés cibles :

Les notes tiers de type FAB seront supprimées puis recopiées.

Les notes tiers de type QT seront recopiées seulement s'il n'en existe pas déjà.

Les notes tiers de type LIV ne seront pas recopiées.

Les notes tiers de type FAC ne seront pas recopiées.

Les notes tiers de type FRA seront supprimées puis recopiées.

c5_* M*

Recopie des historisations assurances/crédits sur toutes les sociétés cibles, en mode Création/modification

c6_* M*

Recopie des modèles de documents sur toutes les sociétés cibles, en mode Création/modification

co_* C*

Recopie des correspondants sur toutes les sociétés cibles, en mode Création uniquement

ic_* M* =F!VAB

ic_* M* =F!VAX

Recopie des informations complémentaires de type de clé F (tiers) et de code différent de VAB, sur toutes les sociétés cibles, en mode Création/modification

Recopie des informations complémentaires de type de clé F (tiers) et de code différent de VAX, sur toutes les sociétés cibles, en mode Création/modification

Exemples d'actions réalisées sur les sociétés cibles :

Les TSC tiers de code VAB ne seront ni créés ni modifiés.

Les TSC tiers de code VAX ne seront ni créés ni modifiés.

Les TSC de code PAL seront créés ou modifiés selon leur existence.

Tables liées aux articles - Paramètre ATR 1AR - Recopie des informations articles vers les autres sociétés

mp_* M* | Recopie des articles sur toutes les sociétés cibles, en mode Création/modification
mf_* M* | Recopie des fournisseurs secondaires sur toutes les sociétés cibles, en mode Création/modification
mc_* A002=AAA mc_* A003!AAA | Recopie des notes de type AAA en mode Annule et Remplace sur la société cible 002 Recopie de toutes les notes sauf celles de type AAA en mode Annule et Remplace sur la société cible 003 Exemples d'actions réalisées sur les sociétés cibles : Les notes articles de type AAA seront supprimées puis recopiées sur la société 002. Les notes articles de type AAA ne seront pas recopiées sur la société 003. Les notes articles de type BBB ne seront pas recopiées sur la société 002. Les notes articles de type BBB seront supprimées puis recopiées sur la société 003.
m5_* M* | Recopie des calendriers de mouvements sur toutes les sociétés cibles, en mode Création/modification
mpf_* M* | Recopie des formats sur toutes les sociétés cibles, en mode Création/modification
mpg_* M* | Recopie des grammages sur toutes les sociétés cibles, en mode Création/modification
ms_* M* | Recopie des lieux de rangement par site sur toutes les sociétés cibles, en mode Création/modification
mva_* M* | Recopie des variantes de production sur toutes les sociétés cibles, en mode Création/modification
ic_* M* =A | Recopie des informations complémentaires de type de clé A (articles) sur toutes les sociétés cibles, en mode Création/modification

Tables liées aux tiers et aux articles - Paramètre ATR 1DG - Recopie des tarifs et libellés vers les autres sociétés

tr_* A* | Recopie des tarifs sur toutes les sociétés cibles, en mode Annule et remplace
le_* M* | Recopie des libellés étrangers sur toutes les sociétés cibles, en mode Création/modification

Tables liées aux paramètres - Paramètre ATR 1PA - Recopie des paramètres vers les autres sociétés

p2_* M* =FAM=YYY

p2_* M* =FAM!ZZZ

p2_* M* !ATR

p2_* M* !#SA!ATR

Recopie des paramètres de type FAM et de code YYY sur toutes les sociétés cibles, en mode Création/modification

Recopie des paramètres de type FAM et de code différent de ZZZ sur toutes les sociétés cibles, en mode Création/modification

Recopie des paramètres de type différent de ATR sur toutes les sociétés cibles, en mode Création/modification

Recopie des paramètres de type différent de #SA et de code différent de ATR sur toutes les sociétés cibles, en mode Création/modification

Exemples d'actions réalisées sur les sociétés cibles :

Les paramètres de type FAM et de code YYY seront créés ou modifiés selon leur existence.

Les paramètres de type FAM et de code ZZZ ne seront ni créés ni modifiés

Les paramètres de type ATR ne seront ni créés ni modifiés.

Les paramètres de type #SA et de code ATR ne seront ni créés ni modifiés

Les paramètres de type FAM et de code ATR seront créés ou modifiés selon leur existence.

Les paramètres de type #UT et de code REQ seront créés ou modifiés selon leur existence.

pn2_* A* =FAM=YYY

pn2_* A* =FAM!ZZZ

pn2_* M* !ATR

pn2_* M* !#SA!ATR

Recopie des notes des paramètres de type FAM et de code YYY sur toutes les sociétés cibles, en mode Annule et remplace

Recopie des notes des paramètres de type FAM et de code différent de ZZZ sur toutes les sociétés cibles, en mode Annule et remplace

Recopie des notes des paramètres de type différent de ATR sur toutes les sociétés cibles, en mode Annule et remplace

Recopie des notes des paramètres de type différent de #SA et de code différent de ATR sur toutes les sociétés cibles, en mode Annule et remplace

Exemples d'actions réalisées sur les sociétés cibles :

Les notes des paramètres de type FAM et de code YYY seront créées ou modifiées selon leur existence

Les notes des paramètres de type FAM et de code ZZZ ne seront ni créées ni modifiées

Les notes des paramètres de type ATR ne seront ni créées ni modifiées

Les notes des paramètres de type #SA et de code ATR ne seront ni créées ni modifiées

Les notes des paramètres de type FAM et de code ATR seront créées ou modifiées selon leur existence

Les notes des paramètres de type #UT et de code REQ seront créées ou modifiées selon leur existence&

sf_* M* =YYY

sf_* M* =AFF=ABC

sf_* M* !AFF

sf_* M* !ZZZ

Recopie des sous-familles hiérarchiques de code sous-famille YYY sur toutes les sociétés cibles, en mode Création/Modification

Recopie des sous-familles hiérarchiques de code famille différent de AFF sur toutes les sociétés cibles, en mode Création/Modification

Recopie des sous-familles hiérarchiques de code famille différent de AFF et de code sous-famille différent de 001 sur toutes les sociétés cibles, en mode Création/Modification

Recopie des sous-familles hiérarchiques de code sous-famille différent de ZZZ sur toutes les sociétés cibles, en mode Création/Modification

Exemples d'actions réalisées sur les sociétés cibles :

Les sous-familles de code YYY seront créées ou modifiées selon leur existence.

Les sous-familles de code famille AFF et de code sous-famille ABC seront créées ou modifiées selon leur existence.

Les sous-familles de code famille AFF ne seront ni créées ni modifiées.

Les sous-familles de code sous-famille ZZZ ne seront ni créées ni modifiées.

Table des sous-devis - ATR 2SC- Mise à jour du scénario de calcul d'un sous-devis

and te_num_table = 31 and te_evenement = 2 and td_nom_champ = "fi_c_papier" | Sélection des événements de traçabilité en modification sur la table des entités, si la modification concerne le code qualité (fle_imp.fi_c_papier).
and te_num_table = 76 and te_evenement = 2 | Sélection des événements de traçabilité en modification sur la table des références multiples, pour tous les champs.

l2_sce_calcul ACNV | Mise à jour du scénario de calcul du sous-devis avec la valeur CNV Cette valeur doit correspondre à un paramètre de type SCE.
l2_prix_negocie N0 | Mise à jour du prix négocié du sous-devis avec la valeur 0 (zéro).

>>>>>>>>>>>>>>> Gestion des actions à effectuer - Fin du chapitre <<<<<<<<<<<<<<<

Envoi depuis la gestion alerte traçabilité, d'un fichier transformé en PDF, puis envoyé par mail.

Définition d'un type d'alerte

Paramétrage des actions à mener suite à l'alerte pour le user USE DEF - (notes sur le USE DEF)

Programme d'envoi des alertes

Description du atrpdf.bat

REM ------------------------------------------------

REM positionner le patch du logiciel générant le PDF

REM ------------------------------------------------

SET PATH=%PATH%;C:\Program Files\PDFCreator

REM ------------------------------------------------------------------

REM On recopie le fichier reçu en argument en .doc

REM pour ne pas avoir le titre du document dans le corps du document

REM Attention, on doit alors avoir Word d'installé

REM ------------------------------------------------------------------

COPY %1 %1.doc

REM -----------------------------------------------------------------

REM lancement du, logiciel de génération de PDF

REM /NOSTART : fermeture automatique du logiciel en fin de traitement

REM /PF : Traitera le fichier %1.doc

REM -----------------------------------------------------------------

PDFCreator.exe /NOSTART /PF"%1.doc"

REM -------------------------------------------------

REM positionner le patch du logiciel générant le Mail

REM -------------------------------------------------

SET PATH=%PATH%;C:\Program Files\SendMail

REM ------------------------------------------------------------------------------------

REM lancement du, logiciel de génération de mail

REM /u : destinataire %2 argument numéro 2 passé en paramètre

REM /t : objet du message %3 argument numéro 3 passé en paramètre

REM /m : nom du fichier dans le corps du message %1 argument numéro 1 passé en paramètre

REM si on met une pièce jointe ce body pourrait être un fichier général

REM /e : émetteur %4 argument numéro 4 passé en paramètre

REM /f : nom du fichier en pièce jointe %1 argument numéro 1 passé en paramètre

REM /l : Nom du répertoire ou sera positionné le log

REM ------------------------------------------------------------------------------------

REM ------------------------------------------------------------------------

REM on attend 5 secondes, sinon le PDF n'est pas construit

REM ------------------------------------------------------------------------

sleep 5

Sendmail.exe /u:%2 /t:%3 /m:%1 /e:%4 /f:%1.pdf /l:D:\VOLUPACK\DEMOAVV\sendmail.log

REM ---------------------------------

REM suppression des fichiers inutiles

REM ---------------------------------

del %1.txt

del %1

Logiciel de gestion de PDF : PDFCreator version 0.9.9 sous Windows 7

Fonctionne en ligne de commande ou par interface graphique.

Peut générer un PDF à partir de plusieurs documents différents.

Dans nom de fichier on peut aussi mettre : <REDMON_DOCNAME_FILE> à la place de <title>

Paramètres de ligne de commande de PDFCreator

PDFCreator vous permet de créer des documents via l'interface de ligne de commande.

Voici les différentes commandes acceptées par PDFCreator :

/CheckInstance

Si vous utilisez cette option, PDFCreator affiche une boîte de dialogue contenant des informations sur les instances en cours d'exécution (PDFCreator, PDFSpooler et Transtool).

Vous pouvez associer cette option avec l'option /NoStart.

Si vous voyez la propriété "Local", c'est qu'il existe une instance locale.

Regarder sur le bureau, la barre de tâches ou le gestionnaire de tâches pour localiser l'instance locale.

Si vous voyez seulement la propriété "Global", alors il existe au moins une instance dans une des sessions de vos serveurs.

Cette option est utile pour le débogage et pour les administrateurs afin de savoir si une instance de PDFCreator s'exécute sur un serveur.

Exemple

PDFCreator.exe /CheckInstance

/ClearCache

Supprime tous les fichiers temporaires de PDFCreator.

Cela est utile si PDFCreator ne peut démarrer à cause d'un fichier temporaire endommagé.

Exemple

pdfcreator.exe /ClearCache

/DeleteIF

Efface le fichier source après l'avoir converti.

Cette option doit être utilisée avec l'option /IF.

Exemple

pdfcreator.exe /IF"C:\description.ps" /OF"C:\description.pdf" /DeleteIF

/IF<input-filename> /OF<output-filename>

Convertit un fichier postscript ou bitmap (JPEG, BM) en un fichier PDF ou bitmap.

Le paramètre /OF doit être utilisé avec le paramètre /IF.

Pour définir le format de sortie, incluez l'extension de fichier correspondante dans le nom du fichier de sortie.

Il n'y a PAS d'espace entre les options et les noms de fichiers.

Le paramètre /OutputSubFormat définit le sous-format.

Habituellement "PDF/A-1b" et ""PDF/X" peuvent être utilisés pour le format PDF.

Exemples

pdfcreator.exe /IF"C:\description.ps" /OF"C:\description.pdf" /OutputSubFormat"PDF/A-1b"

pdfcreator.exe /IF"C:\description.ps" /OF"C:\description.tif"

pdfcreator.exe /IF"C:\image1.jpg" /OF"C:\image1.pdf"

pdfcreator.exe /IF"C:\image1.bmp" /OF"C:\image1.png"

/NoAbortIfRunning

Ouvre une nouvelle instance de PDFCreator sans vérifier si le programme est déjà en cours d'exécution.

Il est utile de combiner cette option avec l'option /NoProcessing.

Exemple

pdfcreator.exe /NoAbortIfRunning

/NoProcessing

Lorsque PDFCreator est lancé avec l'option /NoProcessing , l'ensemble des documents envoyés à PDFCreator ne sont pas convertis. Ils sont stockés dans la file d'attente jusqu'à ce que PDFCreator soit lancé sans l'option /NoProcessing.

Exemple

pdfcreator.exe /NoProcessing

/NoProcessingAtStartup

Lorsque vous utilisez cette option, PDFCreator ne convertira pas immédiatement les documents . Vous pouvez lancer manuellement la conversion en allant dans le menu Document et en sélectionnant Imprimer, ou en décochant la ligne Arrêt dans le menu Imprimante. L'option est utile si vous voulez collecter plusieurs fichiers d'abord, puis les fusionner entre eux en vue de créer un seul pdf.

Propriétés

0 - Off (Defaut)

1 - On

/NoStart

Lorsque vous utilisez l'option /PF, PDFCreator reste ouvert une fois sa tâche terminée. L'option /NoStart ferme automatiquement PDFCreator à la fin du traitement.

Exemple

pdfcreator.exe /NOSTART /PF"C:\help.doc"

/OpenOF

Ouvre le fichier converti à la fin du traitement. Cette option ne s'utilise qu'avec les options /IF et l'option /OF.

Exemple

pdfcreator.exe /IF"C:\description.ps" /OF"C:\description.pdf" /OpenOF

/OptionsFile<option-filename>

Précise les paramètres particuliers que doit utiliser PDFCreator.

Exemple

pdfcreator.exe /OptionsFile"C:\MyPDFCreator.ini"

Nota: Avec cette option (et un peu de travail) vous pouvez utiliser plus d'une imprimante par poste.

/PF<filename>

Imprime un fichier à l'aide du programme par défaut, déterminé par l'extension du fichier. En général, cette option est utile lorsqu'on utilise le mode Enregistrement automatique. Cette option ne peut pas être utilisée avec l'option /OF. Il n'y a PAS d'espace entre l'option et le nom de fichier.

Exemple

pdfcreator.exe /PF"C:\help.doc"

Vous pouvez également utiliser les caractères génériques pour créer des PDF à partir de tous les fichiers d'un dossier particulier.

Exemple

pdfcreator.exe /PF"C:\*.doc"

/ShowOnlyLogfile

Ouvre seulement le fichier journal de PDFCreator. Aucune autre fenêtre n'est ouverte.

Exemple

pdfcreator.exe /ShowOnlyLogfile

/ShowOnlyOptions

Ouvre seulement le panneau de configuration de PDFCreator. Aucune autre fenêtre n'est ouverte.

Exemple

pdfcreator.exe /ShowOnlyOptions

Logiciel de gestion de mail : Sendmail (freeware)

Fonctionne en ligne de commande ou par interface graphique.

Fenêtre pour envoyer des mails par interface graphique.

Nécessité de paramétrer les options

Listes des paramètres en ligne de commande

Cet outil est destiné à envoyer des mails de façon autonome, c'est à dire sans faire appel à un client de messagerie tel que Outlook.

Il peut aussi bien être utilisé en mode "fenêtré" qu'en mode "ligne de commande".

Syntaxe pour le mode ligne de commande

sendmail [/g|/u|/gd|/ud /t /m [/f] [/n] [/e] [/s] [/p] [/@] [/r] [/l]]

Paramètres :

/g:Groupe1, Groupe2 ... GroupeN

/u:Destinataire1, Destinataire2 ... DestinataireN

/gd (utilise la liste des groupes définie par défaut)

/ud (utilise la liste des destinataires définie par défaut)

/t:TitreMessage

/m:FichierCorpsMessage

/f:FichierJoint1, FichierJoint2 ... FichierJointN

/n:NbDestinatairesParMail

/e:Expéditeur

/p:PortSMTP

/s:ServeurSMTP

/@:SuffixeAdresseDestinataires

/r (reporting des erreurs par mail à l'émetteur)

/l (journalisation des actions et erreurs dans le fichier .log)

Exemples

sendmail /g:018 Bureau Carl /t:Pour info... /m:c:\temp\mess01.txt

sendmail /g:Admins /t:Pour info(suite)... /m:c:\temp\mess02.txt

sendmail /u:dp203462,ag205936 /t:Pour info (fin)... /m:c:\temp\mess03.txt

sendmail /ud /t:Pour info (fin)... /m:c:\temp\mess04.txt

Pour info, ce programme utilise le SMTPComponent freeware d'OstroSoft : http://www.ostrosoft.com

REMARQUE

Dans cet exemple, si on ne veut pas avoir de pièce jointe dans le mail, il n'est pas nécessaire de passer par la partie PDFCreator.


ATT Temps d'attente des messages

Valeurs numériques

ATT N1

Temps d'attente pour les messages d'erreur

Le temps d'attente pour la saisie des temps se trouve désormais dans la valeur numérique 2 du paramètre de lancement.


BAR Codes barèmes

Notes

DPC | Paramétrage des codes détails de prix 4,6 Code détail de prix - Obligatoire
FIL | Paramétrage des filtres 4,9 Code client - Facultatif 10,12 Code famille - Facultatif 13,15 Code sous-famille - Facultatif 16,30 Code article - Facultatif


BL Codes bons de livraison

Valeur alpha 1

BL A1[1] | Edition avec LOGO (O/N)
BL A1[2] | Edition avec prix (O/N)


BLD Codes blocage du devis

Mettre en place un code blocage sur les devis si le prix remis et/ou le prix négocié est à zéro.

Remarque : Les prix contrôlés sont ceux qui seront pris en compte lors du transfert en commande (zones cde2.lc_prx et cde2.lc_prx_cessi)

Principe de fonctionnement :

Prise en compte de la nomenclature : #CF TDC A1[42]

Méthode de remplissage des prix de références multiples lors du transfert de devis en commande : #CF TDC A1[30]

A) S'il y a présence et prise en compte de la nomenclature :

A1) Si le prix négocié est renseigné sur la ligne de nomenclature

Les prix contrôlés sont ceux de la ligne de nomenclature (fle_nom)

A2) Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

B) S'il n'y a pas présence ou non prise en compte de la nomenclature :

B1) Si présence de référence multiple

B11) Si le prix négocié n'est pas repris automatiquement

Les prix contrôlés sont ceux de la référence multiple (fle_dec)

B12) Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

B2 )Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

BLD Codes blocage du devis

But : Permettre de mettre en place des codes blocages automatiques et/ou manuels sur la saisie du devis multi-métiers.

Il est utilisé par la note CODE_BLOCAGE_AUTO dans G_devis_standard.

Valeur alpha 1

BLD A1[1]

Type de blocage

M Manuel

A Automatique

BLD A1[2]

Etat d'origine du blocage (si code blocage manuel)

0 Non bloqué

1 Bloqué

BLD A1[3,5]

Code contrôle pour les blocages automatiques

001 Contrôle du respect des marges.

On contrôle que le taux de marge actuel est bien supérieur ou égal au taux paramétré sur (dans cet ordre de priorité) :

1) TSC BDM valeur numérique 1

2) TEN A2[50,52]

002 Blocage automatique de contrôle de la qualité de vente (QV)

003 Contrôle à la fois le code blocage 001 et 002 (marge et vente)

004 Code blocage systématique

005 Contrôle de la validité des articles.

Le blocage est activé si au moins un article a une validité incompatible avec la saisie de devis (voir QA A1[34]).

Ce code est utilisé dans le cadre de la gestion des versions de produit.

006 Contrôle des marges sur prix remis et prix négociés par rapport aux valeurs minimum/maximum autorisées sur l'opération récupérée par la formule.

007 Contrôle des prix remis/négociés
Le contrôle est activé si les prix qui seront pris en compte lors du transfert en commande sont à zéro.
Plus d'info

Il peut s'agir des zones suivantes :

• fle_2.l2_remis : Prix remis sur l'entête du sous-devis

• fle_2.l2_prix_negocie : Prix négocié sur l'entête du sous-devis

• fle_dec.de_px_remis : Prix remis sur la référence multiple

• fle_dec.de_px_negocie : Prix négocié sur la référence multiple

• fle_nom.fno_px_remis : Prix remis sur la ligne de nomenclature

• fle_nom.fno_px_negocie : Prix négocié sur la ligne de nomenclature
Voir la note FORMULE_RECH_MARGES dans #CF DER.

BLD A1[6,8]

Code mot de passe pour le déblocage

BLD A1[9,11]

Statut du code blocage automatique à sa création

DEB Non bloqué

BLO Bloqué (par défaut)

BLD A1[12]

Autorisation de blocage/déblocage en visualisation de devis (O/N, N par défaut)

BLD A1[13]

Autorisation de blocage / déblocage en consultation de devis (O/N, N par défaut)

Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.

Mettre en place un code blocage sur les devis si le prix remis et/ou le prix négocié est à zéro.

Remarque : Les prix contrôlés sont ceux qui seront pris en compte lors du transfert en commande (zones cde2.lc_prx et cde2.lc_prx_cessi)

Principe de fonctionnement :

Prise en compte de la nomenclature : #CF TDC A1[42]

Méthode de remplissage des prix de références multiples lors du transfert de devis en commande : #CF TDC A1[30]

A) S'il y a présence et prise en compte de la nomenclature :

A1) Si le prix négocié est renseigné sur la ligne de nomenclature

Les prix contrôlés sont ceux de la ligne de nomenclature (fle_nom)

A2) Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

B) S'il n'y a pas présence ou non prise en compte de la nomenclature :

B1) Si présence de référence multiple

B11) Si le prix négocié n'est pas repris automatiquement

Les prix contrôlés sont ceux de la référence multiple (fle_dec)

B12) Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

B2 )Sinon

Les prix contrôlés sont ceux de l'entête de sous-devis (fle_2)

Valeur alpha 2

BLD A2[1] | Blocage de la génération des produits finis (O/N, N par défaut)
BLD A2[2] | Blocage du transfert de devis en commande (O/N, N par défaut)
BLD A2[3] | Blocage de l'édition VoluEdit de l'offre commerciale (O/N, N par défaut)
BLD A2[4] | Blocage de l'édition VoluEdit du devis technique (O/N, N par défaut)
BLD A2[5] | Blocage de la génération des fichiers Preactor (O/N, N par défaut)
BLD A2[6] | Blocage de la génération/régénération des ordres de fabrication (O/N, N par défaut)
BLD A2[7] | Blocage de la modification du devis (O/N, N par défaut) (si le devis est bloqué, celui-ci n'est accessible qu'en consultation uniquement). Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.
BLD A2[8] | Blocage de la sélection du devis pour recopie (O/N, N par défaut) (si le devis est bloqué, il ne pourra pas être sélectionné comme devis source à recopier dans la saisie des devis). Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.

Valeur alpha 3

BLD A3[1,2] | Code contrôle (MA pour marge, QV pour qualité de vente, …) - QV par défaut
BLD A3[3,5] | Code TSC client lié au code contrôle (MAC, QVC, …) QVC par défaut

Notes

TYPE_DE_BLOCAGE

21,23 Type de blocage

VER Blocage pour les versions de produit

Cette note est utilisée dans le cadre de la gestion des versions de produit

Autres paramètres

MDB | Motifs de déblocage
#CF DEG A4[40,41] | Racine TSC pour l'enregistrement des codes blocages sur devis. Par défaut : BD


BLF Codes blocages pour commandes fournisseurs

BLF Codes blocage pour commandes fournisseurs

Ce paramètre est utilisable à partir de la V.4.1.7.2

Il est utilisé par la note CBACON dans le programme de saisie des commandes fournisseurs.

En visu des commandes fournisseurs, la note AUTORISE_TOUCHE_F49 permet d'accéder au code blocage.

Valeur alpha 1

BLF A1[1]

Type de blocage (M/A)

M Manuel

A Automatique

BLF A1[2]

Etat d'origine du blocage (0/1) – à remplir si code blocage manuel

0 Non bloqué

1 Bloqué

BLF A1[3,5]

Code contrôle pour les blocages automatiques – à remplir si code blocage automatique

001 Contrôle si une commande fournisseur est associée à une commande cliente.

002 Contrôle si le prix de vente client est strictement inférieur au prix d'achat.

003 Contrôle si le montant global dépasse celui autorisé par le paramétrage.
Plus d'information sur le code 003 au bas de cette page.

004 Contrôle si l'utilisateur est connecté en tant que signataire (USE A3[17,19])

BLF A1[6,8]

Code mot de passe pour le déblocage (PWD/xxx)

BLF A1[9,11]

Statut du code blocage automatique à sa création : DEB ou BLO (BLO par défaut)

BLF A1[12,14]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - VERIFIER

BLF A1[15]

Déblocage de plusieurs lignes (O/N/C, N par défaut)

N Débloquer uniquement la ligne en cours (par défaut)

C Débloquer toutes les lignes de la commande en cours qui ont ce code blocage si l'utilisateur confirme.

O Débloquer toutes les lignes de la commande en cours qui ont ce code blocage sans demande de confirmation.

BLF A1[16]

Apparition du message de confirmation de blocage d'une ligne de commande

L après chaque ligne de commande (par défaut)

C à la validation de la commande

N pas de message de confirmation

BLF A1[17]

Code blocage global sur toutes les lignes de commande

G Si une ligne est bloquée par ce code blocage, manuellement ou automatiquement, alors toutes les autres lignes de la commande seront également bloquées par ce code blocage.
Inversement, si l’on débloque une ligne bloquée par ce code blocage, alors toutes les autres lignes de la commande sont débloquées pour ce code blocage.

N Blocage ligne par ligne.

Ceci est valable en gestion manuelle ou automatique des codes blocages.

BLF A1[15] est alors ignoré (ou forcé à O).

Valeur alpha 2

BLF A2[1] | Blocage de l'édition des commandes fournisseurs (O/N/B/W/C, N par défaut)
BLF A2[2] | Blocage du transfert EDI (O/N/B/W/C, N par défaut)

Valeur alpha 3

BLF A3[1]

Déblocage automatique sur modification du montant des lignes de commande

O Active le déblocage automatique des lignes concernées par le même type de contrôle que la ligne dont le montant a été modifié si le montant global ne dépasse pas le plafond autorisé.

N Désactive le déblocage automatique.
Le déblocage des lignes devra se faire manuellement (par défaut).

Valeur alpha 4

BLF A4[1]

C Affichage d'un message en cas de blocage VERIFIER

[Autre valeur] Pas d'affichage de message (par défaut)

Notes

CODES_BLOCAGE_ASS

21,59 Jusqu'à 10 codes blocage, séparés par des espaces :

21,23 Code blocage associé N° 1

25,27 Code blocage associé N° 2

29,31 Code blocage associé N° 3

33,35 Code blocage associé N° 4

37,39 Code blocage associé N° 5

41,43 Code blocage associé N° 6

45,47 Code blocage associé N° 7

49,51 Code blocage associé N° 8

53,55 Code blocage associé N° 9

57,59 Code blocage associé N° 10

Dès que l'on rencontre plus d'un espace, on arrête la lecture du paramétrage (les codes paramétrés après ne sont pas pris en compte).

Blocage d'une commande fournisseur selon le montant global

Lorsque BLF A1[3,5] = 003, on bloque les lignes de commandes fournisseur lorsque le montant global dépasse celui autorisé par le paramétrage.

Le blocage dépend de la famille ou famille/sous-famille de l'article acheté.

La recherche du montant se fait de la façon suivante :

1 Utilisateur/Famille/Sous-famille

2 Utilisateur/Famille

3 Famille/Sous-famille

4 Famille

Lorsque le montant d'une ligne est modifié, un contrôle automatique du montant des toutes les lignes concernées par le même type de contrôle est effectué, et si le montant cumulé de ces lignes ne dépasse pas le plafond paramétré, alors les blocages sur montant de ces lignes sont retirés automatiquement.

Le paramétrage de ces montants plafonds se fait par l'intermédiaire de la saisie des tarifs en utilisant :

- un type de tarif (#R1 par défaut)

- une configuration de recherche de tarifs (#CF #R1 par défaut) spécifiques.

De plus, lorsqu'au moins une ligne de commande est bloquée par tout type de blocage, un témoin visuel le signale au niveau de l'entête de commande.

La gestion des codes blocage automatique a été ajoutée au programme de génération de commande d’achat (G_gen_cdef).

Ajout de la possibilité d’avoir plusieurs codes blocage de montant (un sur le signataire et un sur la famille, par exemple).

Voir aussi :

Saisie des commandes fournisseurs (cdef) :

note TARIF_POUR_CTRL_MNT

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global (#CF #R1 par défaut)
Ce paramètre se configure comme un #CF TAR avec les contraintes suivantes :

#CF #R1 A1[1,25] Les possibilités sont les suivantes :

L Code tarif / Catégorie tiers / Famille / Sous-famille

M Code tarif / Catégorie tiers / Famille

9 Code tarif / Famille / Sous-famille

8 Code tarif / Famille

#CF #R1 A1[26] = P (Premier tarif trouvé dans l'ordre défini par les caractères A[1,25])

#CF #R1 A1[27] = O (Recherche automatique)

#CF #R1 A1[28] = O (La recherche s'arrête dès qu'on a trouvé un tarif valide.)

#CF #R1 A2[1,25] O/N en fonction des caractères déclarés dans #CF #R1 A1[1,25] :

Pour le caractère L = mettre N.

Pour les caractères M, 9 et 8 : mettre O.

Note PARAM_CATEGORIE : Car.21 à 23 = USE

note TARIF_CTRL_MNT_xxx

où xxx est le code blocage paramétré derrière le CBACON.
Si ce paramètre est renseigné, il sera pris en compte; sinon on prendra le paramétrage de la note TARIF_POUR_CTRL_MNT.

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global spécifiquement pour ce code blocage
Ce paramètre se configure comme un #CF TAR avec les mêmes contraintes que celles de la note TARIF_POUR_CTRL_MNT.

note CBACON

7,9 Code blocage à utiliser pour activer le contrôle d'autorisation sur le montant global des lignes de commande.
Doit correspondre au code blocage de type BLF défini ici.

Génération des commandes d'achat (gen_cdef) :

note TARIF_POUR_CTRL_MNT

21,26 Type et code du paramètre de la configuration de recherche de tarif à utiliser pour le contrôle sur le montant global (#CF #R1 par défaut)
Voir la même note dans le cdef ci-dessus.

note CBACON

7,9 Code blocage à utiliser pour activer le contrôle d'autorisation sur le montant global des lignes de commande.
Voir la même note dans le cdef ci-dessus.

BLF A1[15] ci-dessus

BLF A3[1] ci-dessus

Exemple de paramétrage lorsque BLF A1[3,5] = 003

 | 1 2 3 4 5 6 123456789012345678901234567890123456789012345678901234567890
cdef | TARIF_POUR_CTRL_MNT #CF#R1 CBACONMTG
#CF#R1 Alpha 1 Alpha 2 Alpha 3 Notes | LM98 POO Q NNN NOOO OO PARAM_CATEGORIE USE
BLFMTG Alpha 1 Alpha 2 Alpha 3 | A1003 BLOC C BB O


BLO Codes blocage

Il est recommandé de créer 2 Codes blocages 034 :

BLO MQC pour la Modification de la Quantité Commandée

BLO MQC A1[1] = A

BLO MQC A1[3,5] = 034

BLO MQC A1[9,11] = DEB

BLO MQC A3[1] = O

BLO MQC A3[59] = N

BLO ALC pour l'Annulation de la Ligne de Commande

BLO ALC A1[1] = A

BLO ALC A1[3,5] = 034

BLO ALC A1[9,11] = DEB

BLO ALC A3[1] = N

BLO ALC A3[59] = O

Saisie de commande client

note CBACONMQC pour la Modification de la Quantité Commandée

note CBACONALC pour l'Annulation de la Ligne de Commande

Configuration de la traçabilité

A4[11,15] = DDDDN

note TRACABILITE_CHAMP code_blocage TOUS

note TAB_FLAG_25 NN

note TRACE_QTE_BLO_034 O (nouvelle note dédiée au code 034)

TSC portant sur la ligne de commande

Le contrôle ne se fait que pour les produits commençant par R%

Pour ces produits commençant par R%, on vérifie la présence de la valeur A dans le TSC TOF.

BLO Codes blocage

Valeurs numériques

BLO N1

Coefficient multiplicateur à appliquer au tarif d'achat.

Attention : Ne fonctionne qu'avec le code blocage 013.

Valeur alpha 1

BLO A1[1]

Type de blocage (M/A)

M Manuel

A Automatique

BLO A1[2]

Etat d'origine du blocage (0/1) - à remplir si code blocage manuel

0 Non bloqué

1 Bloqué

BLO A1[3,5]

Code contrôle pour les blocages automatiques - à remplir si code blocage automatique

000 Contrôle à positionner dans le cas où les FBI associées à la ligne de commande ont été modifiées, rendant leur actualisation impossible (lié aux notes CBAFBI)

001 Contrôle si prix de vente à zéro

002 Contrôle de la plage de validité du prix de vente par rapport au prix de revient prévisionnel de la fiche article
PR(1-y%) <= PV <= PR(1+x%)
Le pourcentage y est paramétré en alpha3[31,34]
Le pourcentage x est paramétré en alpha3[35,38]

003 Contrôle de l'encours client. Voir le paramètre QT, alpha1[8,10]. Voir aussi #CF SFA A4[3]

004 Contrôle si capacité machine disponible insuffisante. Contrôle prévisionnel non géré à ce jour

005 Contrôle si le total des quantités commandées sur la CD1 est <= à la quantité commandée de la CDA

006 Contrôle si la date de livraison proposée de la CD1 est <= à la date de livraison proposée de la CDA

007 Contrôle si la surface totale du produit de la FB2 est >= à la surface totale minimum de la composition

008 Contrôle si le stock physique sur le lot (CDA) est suffisant pour honorer la ligne de CD1

009 Blocage laboratoire. Uniquement pour les commandes de type FBI et FB2

010 Contrôle si la quantité commandée est <= au stock disponible
Contrôle si la date de livraison proposée est >= à la date du jour plus un nombre de jours ouvrés paramétré. Uniquement sur les CD1 et/ou articles asynchrones

011 Contrôle si prix de vente négatif

012 Lors de la génération de FBI, pour les nomenclatures multi-niveaux, les mouvements de stocks prévisionnels ne sont pas mis à jour.
La FBI est bloquée, en attente de la validation de la date de fin de fabrication

013 Code blocage de vérification du prix de vente de l'article négoce. Voir alpha4[3,8] et [9,11]

014 Contrôle modification de la date de livraison demandée

015 Contrôle modification de la date de livraison proposée

016 Contrôle modification de la date de départ

017 Contrôle modification de la date de fin de fabrication

018 Contrôle écart prix de revient
lié aux notes REM_PRIX_DEVIS_ONDU

019 Contrôle présence tarif
lié aux notes REM_PRIX_DEVIS_ONDU

020 Contrôle différence entre tarif ou prix contrat et prix saisi
lié aux notes REM_PRIX_DEVIS_ONDU

021 Blocage quantité contrat
La quantité saisie sur la ligne de commande ne doit pas dépasser la quantité restante indiquée sur le contrat.

022 Blocage prix contrat
Le prix saisi sur la ligne de commande doit être le même que le prix indiqué dans le contrat.

023 Blocage date validité contrat
La date de livraison (date maximum prise sur les cadencements de livraison cde8) doit être compatible avec les dates de validités du contrat.

024 Code blocage sur qualité outil

025 Code blocage systématique

026 Code blocage automatique si le produit de la ligne de commande est un produit générique livrable (mp_param[25] = O et mp_param[2] = N)

027 Contrôle du prix à la tonne par rapport à la fourchette de prix paramétrée en A3[39,58]
Voir aussi la note TSC_PRIX_A_LA_TONNE en saisie de commande client.

028 Code blocage automatique en saisie de commande client, si la dernière commande de ce client date de plus de x jours (paramétré en A4[15,18])

029 Code blocage automatique si le mode de règlement de la commande est identique à celui paramétré en A4[19,21]

030 Code blocage en saisie de commande client, si la dernière commande du produit en cours date de plus de n jours, où n est paramétré en A4[23,25].

031 Code contrôle pour commandes urgentes. Voir A4[30,31] et A4[32,34]

032 Code validité de l'article (mp_qualite - Paramètre QA A1[30])
Pour les lignes de cadencement de livraison livrables, des autorisations de création, de modification et d'annulation peuvent être paramétrées.
Par défaut, tout est autorisé.
Les autorisations peuvent être paramétrées :
soit sur le code validité de l'article (QA A1[30,33])
soit sur le code blocage automatique 032 (BLO A4[34,36]).

033 Code blocage si la quantité commandée < quantité économique du produit

034 Code blocage activé si une des FBI de la commande commerciale a été générée et que la quantité commandée de la ligne de commande a été modifiée ou que la ligne de commande a été annulée. Plus d'info

035 Contrôle l'absence d'indicateurs de rentabilité client sur la ligne de commande
Ce code blocage automatique est mis en place si les indicateurs matière/gamme n'ont pas pu être calculés.
(offre de vente associée au produit non trouvée, calcul de l'offre de vente impossible)
Remarques :
Ce code blocage peut également être mis en place à la réactualisation des indicateurs de rentabilité via le batch de réactualisation du devis onduleur.
La zone alphanumérique de 30 caractères du TSC _RC est mise à jour avec l'état des indicateurs.

036 Code contrôle activé si le code TVA saisi sur la ligne de commande est associé à une catégorie de TVA interdite sur le client de la commande (liste des catégories de TVA saisie sur l'information complémentaire TSC/_CT)
Permet de mettre en place un code blocage automatique si le code TVA saisi sur la ligne de commande fait partie d'une catégorie interdite pour le client de la commande.

Principe de fonctionnement :

" Chaque code TVA sera associé à une catégorie de TVA en A2[59].
Exemple : C pour Consommation locale et A pour Admission temporaire

" Sur les fiches clients concernés, l'information complémentaire TSC _CT sera renseignée avec les catégories TVA interdites pour ce client (zones F, G et H : alphanumériques de 2 et 30 caractères)

" Lors du contrôle blocage, la catégorie associée au code TVA de la ligne de commande sera comparée à la liste des catégories de TVA interdites.

037 Bloque la commande si la tolérance de quantité de la ligne de commande client a une certaine valeur (les codes tolérance sont paramétrés sur la note TOL_SOUMISE_A_BLOCAG de la saisie de commande client)
Voir BLO A3[7]

038 Présence d'une valeur sur un TSC (sur article ou commande)
Voir A3[8] et les notes suivantes :
SUP_REQ_MAT_BLO_038
SUP_REQ_TSC_BLO_038
TYPE_CLE_TSC_038
Exemple

039 Code blocage livraison
Utilisé par la note TYPE_NOTE_BLO_RC des programmes suivants : qte_prod, brc et v_cdem
Voir aussi la note CONTROLE_QTE_A_CAD dans le TYC.
Voir aussi #CF CDE A3[58] (2ème partie)

040 Code contrôle pour le contrôle sur la limite de CA journalier à la validation de la revue de contrat
Vous annoncez à votre client une date de livraison. Or, à cette même date, un (trop) grand nombre de livraisons a été programmé, ce qui vous empêche de tenir vos délais.
Pour pallier ce problème, vous pouvez mettre un place ce code blocage qui empêche la validation de commandes quand un certain chiffre d'affaire a été atteint pour la date de livraison proposée.
Ce contrôle porte sur les commandes CD2.
Le chiffre d'affaire est paramétré dans la note CA_JOURNALIER_MAX
Voir aussi la note _SQL_CA_JOURN_MAX dans la saisie de commande client.

041 Contrôle que la date de fin de fabrication de la ligne de commande est bien antérieure à la date de fin de validité de l'outil. Dans le cas contraire, la ligne de commande est bloquée.

042 Blocage automatique en cas de modification à la baisse de la quantité d'une commande déjà planifiée ou semi-produite

043 Blocage automatique en cas de modification de la quantité d'une commande d'avoir sur bon de retour
Voir TYC A2[43]

044 Contrôle de la qualité client. Voir QT A1[7 à 10].

999 Code blocage automatique pour les commandes passées par Internet
Permet de vérifier si le produit de la ligne de commande a fait l'objet d'une commande datant de moins de N jours/mois (paramétrable).

BLO A1[6,8]

Code mot de passe pour le déblocage

BLO A1[9,11]

Statut du code blocage automatique à sa création : DEB ou BLO (BLO par défaut)

BLO A1[12]

Si ce code blocage est positionné, empêche-t-il la réouverture de la fenêtre de revue de contrat en fin de ligne de commande ? (O/N, N par défaut)
A partir du moment où un des codes blocages détectés a pour valeur N, la fenêtre de revue de contrat se rouvrira.

BLO A1[13]

Réservé VSW - A UTILIER AVEC PRECAUTION, ET UNIQUEMENT SOUS LA SUPERVISION DE VOLUME SOFTWARE

Autorisation de blocage / déblocage en visualisation de commande.

Attention ! les traitements associés au déblocage effectué au niveau de la ligne de commande, avec le programme de saisie de commande, ne sont pas reproduits en visualisation !

BLO A1[14]

Bloquant à l'état débloqué (DEB)

O Le code blocage sera bloquant lors de la validation de la ligne (par défaut)

N Le code blocage ne sera pas bloquant lors de la validation de la ligne

BLO A1[15]

Déblocage de plusieurs lignes (O/N/C, N par défaut)

N Débloquer uniquement la ligne en cours (fonctionnement actuel)

C Débloquer toutes les lignes de la commande en cours qui ont ce code blocage si l'utilisateur confirme.

O Débloquer toutes les lignes de la commande en cours qui ont ce code blocage sans demande de confirmation.

Valeur alpha 2

Niveaux de blocage

BLO A2[1]

Blocage ARC (O/N/B/W/C, N par défaut)

BLO A2[2]

Blocage production (O/N/B/W/C, N par défaut)

BLO A2[3]

Blocage saisie bons de livraison (O/N/B/W/C, N par défaut)

BLO A2[4]

Blocage calcul factures (O/N/B/W/C, N par défaut)

BLO A2[5]

Blocage réservation de capacité pour PC-Topp (zone 54) (O/N/B/W/C, N par défaut)

Ce caractère déclenche a priori un renvoi des OF à PC-TOPP.

BLO A2[6]

Blocage PCTOPP pour raison de planning (zone 73)

à blanc : pas de blocage (par défaut)

tout autre caractère : blocage pour raison de planification

Pour de plus amples détails sur les différentes valeurs, se reporter à l'aide de PCTOPP.

BLO A2[7]

Blocage PCTOPP pour raison commerciale (zone 74)

0 ou blanc pas de blocage (par défaut)

1 bloqué mais planification possible

2 bloqué et planification impossible

Pour de plus amples détails sur les différentes valeurs, se reporter à l'aide de PCTOPP.

BLO A2[8]

Blocage édition ordre d'exécution (O/N/B/W/C, N par défaut)

BLO A2[9]

Blocage édition ordre de chargement (O/N/B/W/C, N par défaut)

BLO A2[10]

Blocage Génération des mouvements prévisionnels de stock dans la saisie des commandes et l'édition de l'accusé de réception (O/N/B/W/C, N par défaut)

BLO A2[11]

Blocage d envoi des commandes en affrètement (O/N/B/W/C, N par défaut)

Voir le programme tr_jde_cde

BLO A2[12]

Avertissement de blocage de l'affrètement dans JDE (O/N/B/W/C, N par défaut)

La commande n'est pas rejetée (O/N, N par défaut) - Voir le programme tr_jde_cde

BLO A2[13]

Blocage de l'édition définitive du BL contenant la ligne de commande sur laquelle le code blocage est positionné (O/N/B/W/C, N par défaut)

Attention ,les traitements associés au déblocage effectué au niveau de la ligne de commande, avec le programme de saisie de commande, ne sont pas reproduits en visualisation ! DANGER !

BLO A2[14]

Blocage en saisie de picking (O/N/B/W/C, N par défaut)

Voir aussi la note LIEUX_SANS_CONTROLE ci-dessous

Valeur alpha 3

Options qui déclenchent l'activation du blocage automatique. A remplir si code blocage automatique

BLO A3[1] | Contrôle si modification de la quantité commandée (O/N)
BLO A3[2] | Contrôle si modification du prix de vente (O/N)
BLO A3[3] | Contrôle si modification de la date de fin de fabrication prévue (O/N)
BLO A3[4] | Contrôle si modification de la date de livraison proposée (O/N)
BLO A3[5] | Contrôle si modification de la longueur (O/N)
BLO A3[6] | Contrôle si modification de la largeur (O/N)
BLO A3[7] | Contrôle si modification de la tolérance de quantité (paramètre TOL) (O/N) Voir le code blocage 037.
BLO A3[8] | Déblocage automatique si la condition sur le TSC est respectée Voir le code blocage 038.
BLO A3[9,30] | L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S
BLO A3[31,34] | Pourcentage en moins (Exemple 0350) A remplir si code contrôle 002
BLO A3[35,38] | Pourcentage en plus (Exemple 0500) A remplir si code contrôle 002
BLO A3[39,48] | Borne inférieure de contrôle du prix à la tonne Voir BLO A1[3,5] = 027 Voir aussi la note TSC_PRIX_A_LA_TONNE en saisie de commande client.
BLO A3[49,58] | Borne supérieure de contrôle du prix à la tonne Voir BLO A1[3,5] = 027 Voir aussi la note TSC_PRIX_A_LA_TONNE en saisie de commande client.

Valeur alpha 4

BLO A4[1]

Si le contrôle s'avère positif, on ne valide pas la saisie de la ligne de commande

N NON On valide dans tous les cas

C CONFIRMATION On valide sur confirmation

O OUI On ne valide jamais

BLO A4[2]

Si le contrôle s'avère positif, on solde la ligne de CDA associée à la CD1 en cours

Ne fonctionne qu'avec les codes blocage 005 et 008

N NON On ne solde pas la ligne de CDA

C CONFIRMATION On solde sur confirmation

O OUI On solde sans confirmer

BLO A4[3,8]

Type et code de paramètre de recherche des tarifs pour le code blocage 013

BLO A4[9,11]

Code du tarif de référence. Uniquement pour le code blocage automatique 013.

BLO A4[12,14]

Correspondance JDE. N'est utilisée que si BLO A2[12] = O. Voir le programme tr_jde_cde

BLO A4[15,18]

Nombre jours possibles entre la date de création de la commande et la date de la dernière commande avant que le blocage 028 n'intervienne

Voir aussi la note _SUP_REQ_028_CDE1

BLO A4[19,21]

Mode de règlement - A remplir si code contrôle 029

Facultatif - PRO par défaut

BLO A4[22]

Régénération du dossier de fabrication (f0_gener à 2) (O/N, N par défaut) si les 3 conditions suivantes sont remplies : (voir aussi gdf_don option One et acr option One)

En saisie de commande client :

  • un code blocage édition AR sur la ligne de commande est débloqué,

  • l'AR n'a pas été édité,

  • l'OF a été généré.

En édition des AR de commande client :

  • un code blocage édition AR sur la ligne de commande est bloqué,

  • l'AR n'a pas été édité,

  • l'OF a été généré.

BLO A4[23,25]

Nombre de jours possibles entre la date de création de la commande et la date de la dernière commande avant que le blocage 030 n'intervienne.

Voir aussi les compléments de requête sur cde1 et cd2.

BLO A4[26]

Autorisation de mise à jour du prix de vente en cas de blocage (O/N, O par défaut)

BLO A4[27,29]

Code OMP du blocage

Ce code fait partie de la clé qui alimente la zone Stopcodeid

Si cette zone n'est pas renseignée, le code blocage n'est pas pris en compte dans l'intégration OMP.

Plus d'explication dans le #CF OMP

BLO A4[30,31]

Delta maxi en nombre de jours (entre le délai répondu et la date du jour)

Si non renseigné, le delta est égal à 2.

ir A4[32,33] pour les commandes asynchrones

Voir A1[3,5] = 031

BLO A4[32,33]

Delta maxi en nombre de jours (entre le délai répondu et la date du jour) pour les commandes asynchrones. Si non renseigné, le delta est égal à 2.

Voir A1[3,5] = 031

BLO A4[34]

Autorisation de création d'une ligne de cadencement de livraison (N/O, O par défaut)

BLO A4[35]

Autorisation de modification d'une ligne de cadencement de livraison (N/O, O par défaut)

BLO A4[36]

Autorisation d'annulation d'une ligne de cadencement de livraison (N/O, O par défaut)

Notes

CODES_DEBLOCAGE_ASS | Cette note n'existe plus et a été remplacée par sa contrepartie : Voir la note CODES_BLOCAGE_ASS dans le paramètre MDB.
LIEUX_SANS_CONTROLE | 21,60 Liste des magasins pour lesquels on ne fera pas de contrôle A saisir tous les 3 caractères (21-23, 24-26, 27-29&, 57-59) On peut désactiver un code blocage en fonction du lieu. Pour cela, on paramètre sur chaque code blocage la liste des magasin pour lesquels on ne fera pas de contrôle. Voir aussi BLO A2[14]
_SUP_REQ_028_CDE1 | 21,60 Complément de requête sur la table cde1 Code blocage 028, voir aussi A4[15,18]
_SUP_REQ_030_CDE1 | Complément de sélection sur la table des entêtes de commandes (cde1) pour la recherche des dernières commandes (code blocage automatique 030)
_SUP_REQ_030_CDE2 | Complément de sélection sur la table des lignes de commandes (cde2) pour la recherche des dernières commandes (code blocage automatique 030)
SUP_REQ_MAT_BLO_038 | Complément de requête sur la table mat sur le code produit de la ligne de commande, pour savoir s'il est soumis à un traitement de blocage Voir le code blocage 038.
SUP_REQ_TSC_BLO_038 | Complément de requête des info_c pour déterminer le blocage Le complément de requête porte sur des TSC du code produit, de l'entête de commande ou de la ligne de commande. Voir le code blocage 038.
TYPE_CLE_TSC_038 | Type de clé pour la recherche des info_c A article (valeur par défaut) CE entête de commande CL ligne de commande Voir le code blocage 038.


BQE Banque

Notes

TEXTE_VIR_BANQUE

21, 60 Notes bancaires (7 lignes maximum)

Voir aussi : TSC BQE.


BSD Bobine sens déroulement

Pas de paramétrage particulier.

Voir aussi le TSC BSD.


CAB Codes barres

Voir aussi #CF CAB.

Valeurs numériques

CAB N1 | Nombre de lignes de l'écran
CAB N2 | Nombre de colonnes de l'écran

Valeur alpha 1

CAB A1[1,20]

Code identification constructeur


CAD Formules de calcul cadences

Valeurs numériques

CAD N1

Définition de l'arrondi

Valeur alpha 2

CAD A2[1,60]

Formule de calcul

Les opérandes de cette formule sont définis sur la formule de calcul associée à l'opération standard.

(Saisie par F11 sur la fiche formule).

Les opérandes paramétrés vont de a à j

Remarque

Il existe 2 opérandes spéciaux :

X | La cadence issue de l'opération élémentaire
Y | Le temps issu de l'opération élémentaire


CAL Calendrier - Planning

Ce code est saisi sur la fiche de l'employé et permet de déterminer son temps dû pour une journée de travail donnée.

Si le code calendrier n'est pas saisi sur la fiche de l'employé ou si celui-ci n'existe pas, le temps dû saisi sur la fiche de l'employé est utilisé.

Le code calendrier saisi permet de déterminer, en fonction de la date scrutée, le code découpage horaire mensuel de l'employé, c'est à dire comment est organisé son mois de travail (Exemple une semaine de jour, une semaine de nuit, etc…).

Le découpage mensuel donne le code découpage hebdomadaire en fonction du numéro de semaine dans le mois.

Valeurs numériques

CAL N1

Temps dû par défaut si le découpage mois n'est pas saisi ou n'est pas trouvé.

Valeur alpha 1

CAL A1[1,3] | Code découpage mensuel janvier
CAL A1[4,6] | Code découpage mensuel février
CAL A1[7,9] | Code découpage mensuel mars
CAL A1[10,12] | Code découpage mensuel avril
CAL A1[13,15] | Code découpage mensuel mai
CAL A1[16,18] | Code découpage mensuel juin
CAL A1[19,21] | Code découpage mensuel juillet
CAL A1[22,24] | Code découpage mensuel août
CAL A1[25,27] | Code découpage mensuel septembre
CAL A1[28,30] | Code découpage mensuel octobre
CAL A1[31,33] | Code découpage mensuel novembre
CAL A1[34,36] | Code découpage mensuel décembre

Exemples – Les types (CAL, MOI, SEM, JOU) sont figés, mais pas les codes.

Code calendrier | CAL C03 (pour l'année 2003) On aura en alpha1 M01M01M01M01M01M01VACM01M01M01M01M01si tous les mois sont identiques sauf le mois de juillet pendant lequel le salarié prend ses congés. M01 correspond au découpage mensuel standard. VAC correspond à un découpage de vacances. On aura M01M02M03M04M05M06M07M08M09M10M11M12 si tous les mois sont différents.
Découpage mensuel | MOI M01 (pour le mois de janvier) Sachant qu'il peut y avoir jusqu'à 4 semaines entières et 2 semaines partielles dans un mois (soit en tout 6 semaines) : Si le salarié travaille de la même façon chaque semaine, on aura en alpha1 S01S01S01S01S01S01. Si toutes les semaines sont différentes, on aura S01S02S03S04S05S06. MOI VAC (pour le mois de juillet) : ne rien mettre en alpha1, et mettre 0 en valeur numérique 1.
Découpage hebdo | SEM S01 (pour la première semaine) On aura en alpha1 SEMSEMSEMSEMVENWE WE si les 4 premiers jours sont identiques. On aura en alpha1 LUNMARMERJEUVENWE WE si les 5 jours travaillés sont différents.
Découpage journalier | JOU SEM (Jour de semaine) (lundi, mardi, mercredi, jeudi) Valeur numérique 1 : 7.48 JOU VEN (vendredi) Valeur numérique 1 : 6.48 JOU WE (week-end) Valeur numérique 1 : 0

Exemple pour le jeudi 16/01/2003

Code calendrier | C03
CAL C03 | janvier : découpage mensuel M01
MOI M01 | semaine 3 de janvier : découpage hebdomadaire S03
SEM S03 | jeudi : découpage journalier SEM
JOU SEM | 7.48

Exemple pour le vendredi 17/01/2003

Code calendrier | C03
CAL C03 | janvier : découpage mensuel M01
MOI M01 | semaine 3 de janvier : découpage hebdomadaire S03
SEM S03 | vendredi : découpage journalier VEN
JOU VEN | 6.48

Exemple pour le samedi 18/01/2003

Code calendrier | C03
CAL C03 | janvier : découpage mensuel M01
MOI M01 | semaine 3 de janvier : découpage hebdomadaire S03
SEM S03 | samedi : découpage journalier WE
JOU WE | 0


CAN Types de cannelure

Valeurs numériques

CAN N1 | Coefficient 1 d'ondulation du cylindre cannelé
CAN N2 | Coefficient 2 d'ondulation du cylindre cannelé

Notes

CAN_ML_SIT_ | 12,14 Code site - Tableau de bord du multisite 21,25 Cannelure au mètre linéaire par site. Correspond à la cannelure au mètre linéaire paramétré dans la valeur numérique 3 Voir l'option Occ et la note CANNELURE_METRE_REF dans la gestion des compositions.
COEF_OND_SIT_ | Coefficient d'ondulation par site - Tableau de bord du multisite 14,16 Code site (Paramètre SIT) 21,30 Coefficient d'ondulation. Correspond au coefficient 1 d'ondulation paramétré dans la valeur numérique 1. Format 999.99999 Exemple : 1.23


CAP Capteurs atelier

Valeurs numériques

CAP N1

Diviseur

Exemple Le capteur envoie une information de comptage tous les 10000 impulsions
Diviseur 10000

Valeur alpha 1

CAP A1[1,6]

Code de la machine rattachée


CAS Caractéristiques actions de service

fCAS Caractéristiques actions de service

Paramétrages des codes calculs

Valeur alpha 1

CAS A1[1,3] | Code action de service de rattachement Permet le contrôle de saisie des caractéristiques. Impossibilité de saisir un code caractéristique non rattaché à l'action de service.
CAS A1[4] | Caractéristique modifiable ? O Oui N Non 9 Modifiable uniquement sur offre 99 1 Modifiable uniquement sur offre différente de 99 X Modifiable uniquement si présence d'une offre 99 Y Modifiable uniquement s'il n'y a pas d'offre 99
CAS A1[5] | Caractéristique à réactualiser pour les commandes de type Transformé (O/N)
CAS A1[6] | Caractéristique à réactualiser pour les commandes de type Cartonnier (O/N)
CAS A1[7] | Caractéristique à réactualiser lors du recalcul batch des devis (suivant le devis utilisé) (O/N)
CAS A1[8] | Réinitialisation de la caractéristique d'action de service lors de la recopie du devis (O/N, N par défaut) Ce paramètre annule et remplace le paramètre AS alpha1[29]. O La caractéristique sera réinitialisée après la recopie de devis. N La caractéristique ne sera pas réinitialisée.

Valeur alpha 2

CAS A2[1,3] | Type de saisie NUM Valeur numérique ALP Valeur alpha
CAS A2[4,6] | Type du paramètre à saisir (si nécessaire)
CAS A2[7,8] | Code calcul de la valeur de la caractéristique (voir le tableau ci-dessous)
CAS A2[9,15] | Paramétrage pour le code calcul Ce paramétrage peut comporter jusqu'à 7 caractères décrits dans le tableau ci-dessous.
CAS A2[16,29] | Valeur par défaut de la caractéristique (utilisée dans l'ajout d'une action de service dans les utilitaires du devis)

Code caractéristique figé dans VoluPack

LDP Lieu de déstockage du produit fini

Paramétrage des codes calculs

La liste est triée par ordre alphabétique.

Les codes calculs sont en A2[7,8] et les formules sont en A2[9,15].

A2[7,8]

A2[9,15]

BS

Ajout d'une somme au prix de revient pour un papier spécial

A2[9,11]

TSC Code TSC sur un des papiers composant la composition
Le but est de récupérer la valeur ic_char3_1 d'un TSC pour un papier, pour la rajouter au prix de revient.

CA

Résultat de calcul (NUM)

A2[9,15]

COUTMAT Coût total matière pour le PF

COUTOPE Coût total main d'oeuvre pour le PF

COUTTOT Coût total main d'oeuvre + matière pour le PF

CC

Indicateur camion complet - Réactualisable dans le suivi des coûts de transport - Pas de paramétrage (ALPHA)

CN

Calcul de la valeur d'une caractéristique action de service en fonction d'une valeur fixe paramétrée dans la caractéristique en valeur numérique 1 ou 2 (NUM)

A2[9]

1 On récupère la valeur numérique 1

2 On récupère la valeur numérique 2

CO

Commission - Pas de paramétrage (NUM)

CP

Code postal de livraison (ALPHANUM)

A2[9]

N Retourne le code postal numérique

A Retourne uniquement les premiers caractères alpha

DI

Distance en kilomètres entre l'usine et le client livré. Pas de paramétrage (NUM)

La distance saisie sur l'adresse de livraison (écran 005) ou sur l'adresse principale.

DK

Distance kilométrique entre un magasin et un client livré.

Utilisé pour l'intégration du calcul des tarifs transporteurs dans devis - Projet logistique

A2[9] Si la distance kilométrique est demandée, doit-on mettre à jour la table cli_distance ? (O/N, N par défaut)

EC

Code échéance client. Pas de paramétrage (ALPHA)

EM

Code environnement matière

FE

Livraison. Pas de paramétrage (ALPHA)

Renvoie E si le pays de livraison est différent du code pays de la fiche société.

Renvoie F dans le cas contraire

FP

Sous-famille du papier

A2[9,11] Code papier de la composition (voir les codes sous ce tableau)

HP

Hauteur palette. Pas de paramétrage (NUM)

Hauteur palette = TSC 225 du PF issu du conditionnement)

KQ

Caractères 1 à 3 : Racine du code d'information complémentaire (TSC) sur laquelle est saisi le coefficient de composition

MC

Calcul du coût de la colle (avec minoration possible)

A2[9] = O (seule valeur possible pour l'instant)

ML

Mètres linéaires de plancher du camion (NUM)

A2[9,12]

Largeur du camion (en millimètres)

A2[13]

D Pour la quantité demandée

L Pour la quantité de livraison

MM

Calcul de la marge sur coût matière

A2[9] = Type de localisation du papier

I Import

L Local

NF

Nombre de fabrications issu de l'écran gamme (pour le devis)

NP

Nombre de palettes ou d'unités de conditionnement utilisées pour un PF (NUM)

A2[9]

Y pour un nombre de palettes (par défaut)

Z pour un nombre d'unités de conditionnement

A2[10]

D Pour la quantité demandée

L Pour la quantité de livraison

Nombre de palettes = quantité demandée * coefficient de nomenclature Ref/PF * coefficient de nomenclature PF / Palette

Nombre d'unités de conditionnement = nombre de palettes / nombre de palettes par unité

OP

Origine du papier

A2[9,11] Code papier de la composition (voir les codes sous ce tableau)

PA

Code pays de livraison

A2[9]

blanc : Code pays de livraison du client final (par défaut)

S Recherche du sous-traitant éventuel en tant que destinataire au lieu du client final (recherche du premier TSC STR saisi sur le triplet article/gamme/phase).
Si aucun sous-traitant n'est trouvé, alors on prend sur le client final.

PD

Poids unitaire. Pas de paramétrage (NUM)

PF

Prime de fidélité. Pas de paramétrage (NUM)

PO

Pondération du coût de transport en fonction de la région livrée (ALPHA)

A2[9] Mode de recherche du coefficient de pondération

G Le coefficient est pris sur le secteur géographique du client livré (adresse secondaire ou principale)

D Le coefficient est pris sur le département pour les clients dont le code pays est identique au code pays de la fiche société et dans le secteur géographique pour les autres.

PP

Calcul du poids papier de la composition

A2[9] = Type de localisation du papier

I Import

L Local

Voir le TSC 211

PX

Prix selon la quantité

Ce prix est déterminé selon la grille de tarif/unité saisie dans le devis dans l'écran des actions de service. AS A3[4] = O

A2[9] Pas de paramétrage

QF

Quantité de fabrication issu de l'écran gamme (pour le devis)

QP

Quantité de produits de la commande. (NUM)

A2[9]

D Pour la quantité demandée

L Pour la quantité de livraison

Quantité de produits = quantité demandée * coefficient de nomenclature Ref/PF

RE

Renvoie en alphanumérique le mode de réapprovisionnement du produit fini - Voir REA A2[1]

SI

Site de production. Réactualisable dans le suivi des coûts de transport. Pas de paramétrage (ALPHA) - Tableau de bord du multisite

T1

Permet de rechercher un tarif sur le sous-traitant présent sur une phase de gamme.

A2[9] = Méthode à prendre ne compte

1 Recherche du sous-traitant sur la phase de gamme - Le produit à prendre en compte est celui de l'offre 99.

Seule méthode au 03/12/2013

A2[10,12] = Code du paramètre de recherche de tarif (le type est #CF)

T2

Recherche du coût de transport via le fichier tarif par rapport au sous-traitant (recherche du premier TSC STR saisi sur le triplet article/gamme/phase)

A2[9] = méthode de recherche

1 Coût entre le sous-traitant et l'usine

2 Coût entre le sous-traitant et le client final

A2[10,12] = Code paramètre de recherche de tarif (le type est #CF)

A2[13] Si la distance kilométrique est demandée, doit-on mettre à jour la table cli_distance ? (O/N, N par défaut)

TP

Type de produit (plastique) = sous-famille de la composition. Pas de paramétrage (ALPHA)

TS

TSC direct

A2[9] TSC de quel article. ATTENTION : certains de ces codes sont prévus mais pas encore opérationnels - A VERIFIER

A Référence d'architecture OPERATIONNEL

C Composition carton NON OPERATIONNEL

I Référence d'impression OPERATIONNEL

M Machine saisie sur la gamme NON OPERATIONNEL

P Référence de pré-impression NON OPERATIONNEL

Q Qualité carton OPERATIONNEL

T Triplet article/gamme/phase NON OPERATIONNEL

X Produit fini OPERATIONNEL

Y Palette NON OPERATIONNEL

Z Coiffe NON OPERATIONNEL

A2[10,12]

TSC

A2[13]

Code de la zone de stockage

A2[14]

U Résultat unitaire (par défaut)

Q Multiplication du résultat par la quantité commandée
Pour l'intégration du calcul des tarifs transporteurs dans devis - Logistique

M Multiplication du résultat par la quantité commandée et division par 1000
Pour l'intégration du calcul des tarifs transporteurs dans devis - Logistique

UN

Valeur de l'unité selon la quantité

Cette valeur est déterminée selon la grille de tarif/unité saisie dans le devis dans l'écran des actions de service. AS A3[4] = O

A2[9] Pas de paramétrage

VP

Calcul du montant du papier

A2[9,11] Code papier de la composition (voir les codes sous ce tableau)

A2[12,14] unité demandée

TON Prix à la tonne (par défaut)

CEN Prix aux 100Kg

UNI Prix à l'unité

ZA

Zone d'affrètement

A2[9]

blanc : Zone d'affrètement du client final (par défaut)

S Recherche du sous-traitant éventuel en tant que destinataire au lieu du client final (recherche du premier TSC STR saisi sur le triplet article/gamme/phase).
Si aucun sous-traitant n'est trouvé, alors on prend sur le client final.

Pour les codes FP, OP et VP : Les 9 codes des papiers (selon leur position) sont :

INT Intérieur

CA1 Cannelure1

ME1 Médian1

CA2 Cannelure2

ME2 Médian2

CA3 Cannelure3

ME3 Médian3

CA4 Cannelure4

EXT Extérieur


CAT Catégories de tiers

Valeurs numériques

CAT N1 | Valeur à ajouter au numéro de compte pour obtenir le compte d'achat
CAT N2 | Delta à appliquer au compte de vente ou d'achat en fonction de la catégorie du tiers dans le transfert en comptabilité

Valeur alpha 1

CAT A1[1] | Taxe parafiscale (O ou N)
CAT A1[2,3] | Filtre des données suivant code paramètre : Exemples : CP autorise la visu du code pour les tiers clients et prospects F autorise la visu du code uniquement pour les tiers fournisseurs Par défaut, le code est visible pour tous les types de tiers
CAT A1[4,18] | Code catégorie du tiers pour interface SIDE TRADE
CAT A1[19,21] | Type de finition associé - Doit correspondre à un paramètre de type TDF.

Valeur alpha 4

CAT A4[9] | Code regroupement C S P
CAT A4[10] | Rang dans le groupement (0 à 9)
CAT A4[11] | A imprimer (O ou N)
CAT A4[12] | Echéance obligatoire dans la table des échéances (spécifique) O Oui (commande interdite) (par défaut) N Non
CAT A4[13] | 2ème code regroupement C S P
CAT A4[14] | Rang dans le 2ème groupement (0 à 9)
CAT A4[15] | A imprimer (O ou N)


CAU Commentaires automatiques

Ce paramètre permet de constituer une bibliothèque de notes standards.

Les notes saisies sur ce paramètre seront automatiquement intégrables lors de la saisie de notes dans VOLUME.

Il est possible lorsque vous saisissez des notes de faire appel à un masque de saisie prédéfini dans les notes des paramètres de type CAU.

Par la touche F7 ou en tapant directement le code dans vos notes, les lignes du paramètre associé viendront s'ajouter automatiquement à vos notes en cours.

Voir aussi : paramètre NTS

Principe

Paramètre CAU 001 Libellé Présence cahier des charges

Lors de la saisie des notes sur un article (par exemple), il suffit de composer 001 dans la ligne de note pour que le système rapatrie automatiquement le texte.

Valeur alpha 4

A4[1,60]

Liste des types de note pouvant utiliser ces commentaires

Le code doit être précédé par le nombre de caractères le composant, comme pour l'argument -C).

Notes

[Note sans nom]]

1,60 Ligne de note automatique qui sera insérée lors de la saisie du code paramètre CAU/xxx dans la saisie des notes

Dans le cas d'un type de note avec saisie limitée, il est possible que les lignes automatiques ne puissent pas être insérées entièrement.

Exemple

Si le code 001 de commentaires automatiques ne peut être utilisé que par les types de note L, AR et FAC, la zone alpha 4 doit contenir 1L2AR3FAC.

ou encore 3FAC1L2AR ou toute autre combinaison entre les codes 1L, 2AR et 3FAC


CCL Correspondance entre un code paramètre et un code client

Utilisé en Répartition des Marges (MR)

Libellé long Contient le nom du client correspondant

Valeur alpha 1

CCL A1[1,6]

Le code client dont le code paramétré est l'abrégé


CDC Code de difficulté de calage

Ce paramètre est opérationnel à partir de la V.4.0.186.2

Il est utilisé par le programme de saisie des codes ECMA / FEFCO.

Pas de paramétrage, seuls les libellés sont utilisés.


CDR Code de difficulté de roulage

Ce paramètre est opérationnel à partir de la V.4.0.186.2

Il est utilisé par le programme de saisie des codes ECMA / FEFCO.

Pas de paramétrage, seuls les libellés sont utilisés.


CFC Formule de calcul pour la feuille de calcul

Libellé court Libellé qui sera affiché dans la feuille de calcul

Valeur alpha1

CFC A1[1,40]

Détail de la formule de calcul à utiliser

Exemple Longueur en m * , largeur en m

Valeur alpha2

CFC A2[1]

Edition de la feuille de calcul dans le récapitulatif du devis

O On édite après le récapitulatif

N ou blanc : On édite avec les variantes.


CIC Correspondance avec les informations complémentaires

Généralités Valeurs numériques Valeur alpha 1 CIC Dates CIC numériques CIC Paramètres CIC Chaînes de caractères

Généralités

Les codes CIC sont implicitement de différents types de données en fonction de la première lettre de leur code.

Exemple

Code CIC | Signification | Type de p_ic.*
D?? | Date | date
N?? | Numérique | décimal(11,3)
P?? | Paramètre | char(3)
C?? | Chaîne de caractères | char(30)

Ce code CIC est figé, mais l'utilisateur peut positionner cette zone dans le TSC de son choix.

Afin que le système prenne connaissance de ce choix, on paramètre au niveau du CIC, le TSC associé, ainsi que le numéro de champ dans les informations complémentaires.

Valeurs numériques

CIC N1 | Coefficient multiplicateur. La valeur lue dans la table info_c sera multipliée par ce coefficient.
CIC N2 | Coefficient diviseur. La valeur lue dans la table info_c sera divisée par ce coefficient.

Valeur alpha 1

CIC A1[1,3] | Code du TSC où est située la zone CIC.
CIC A1[4] | Numéro de la zone dans le record p_ic. *
Code CIC | Car 4 | Zone retournée | Code zone TSC
D?? | 1 | Date 1 | A
 | 2 | Date 2 | B
N?? | 1 | Numérique 1 | C
 | 2 | Numérique 2 | D
 | 3 | Numérique 3 | E
P?? | 1 | Char 3 (1) | F
 | 2 | Char 3 (2) | H
 | 3 | Paramètre dans chaîne | G
C?? | 1 | Chaîne de caractères | G

Liste des CIC définis

Dates

DV1 à DV5 | Codes CIC libres apparaissant dans les visualisations.
DP1 | Date de début de la période de référence - utilisé par gest_stk
DP2 | Date de fin de la période de référence - utilisé par gest_stk
DP3 | Date de début de la période de référence (par lieu de rangement) utilisé par gest_stk
DP4 | Date de fin de la période de référence (par lieu de rangement) utilisé par gest_stk

Numériques

N01 à xxx

Cotes de refoulage N° 1 à N° 20 (Laize Cartonniers)

Ces CIC sont associés à des TSC figés (TSC 08x pour les pointages refouleurs).

N01 TSC 080 zone numérique 1 - Pointage 01

N02 TSC 080 zone numérique 2 - Pointage 02

N03 TSC 080 zone numérique 3 - Pointage 03

N04 TSC 081 zone numérique 1 - Pointage 04

N05 TSC 081 zone numérique 2 - Pointage 05

N06 TSC 081 zone numérique 3 - Pointage 06

N07 TSC 082 zone numérique 1 - Pointage 07

N08 TSC 082 zone numérique 2 - Pointage 08

N09 TSC 082 zone numérique 3 - Pointage 09

N10 TSC 083 zone numérique 1 - Pointage 10

N11 TSC 083 zone numérique 2 - Pointage 11

N12 TSC 083 zone numérique 3 - Pointage 12

N13 TSC 084 zone numérique 1 - Pointage 13

N14 TSC 084 zone numérique 2 - Pointage 14

N15 TSC 084 zone numérique 3 - Pointage 15

N16 TSC 08A zone numérique 1 - Pointage 16

N17 TSC 08A zone numérique 2 - Pointage 17

N18 TSC 08A zone numérique 3 - Pointage 18

N19 TSC 08B zone numérique 1 - Pointage 19

N20 TSC 08B zone numérique 2 - Pointage 20

xxx TSC 08B zone numérique 3 - Pointage 21

xxx TSC 08C zone numérique 1 - Pointage 22

xxx TSC 08C zone numérique 2 - Pointage 23

xxx TSC 08C zone numérique 3 - Pointage 24

xxx TSC 08D zone numérique 1 - Pointage 25

xxx TSC 08D zone numérique 2 - Pointage 26

xxx TSC 08D zone numérique 3 - Pointage 27

xxx TSC 08E zone numérique 1 - Pointage 28

xxx TSC 08E zone numérique 2 - Pointage 29

xxx TSC 08E zone numérique 3 - Pointage 30

N30

Laize unitaire (Cartonniers)

N31

Coupe unitaire (Cartonniers)

N32

Surface unitaire (Cartonniers)

N33

Nombre de poses laize découpe (Cartonniers)

N34

Nombre de poses coupe découpe (Cartonniers)

N35

Rogne laize découpe (Cartonniers)

N36

Rogne coupe découpe (Cartonniers)

N37

Laize découpe (Cartonniers)

N38

Coupe découpe (Cartonniers)

N39

Surface découpe (Cartonniers)

N40

Nombre de poses laize impression (Cartonniers)

N41

Nombre de poses coupe impression (Cartonniers)

N42

Rogne laize impression (Cartonniers)

N43

Rogne coupe impression (Cartonniers)

N44

Laize impression (Cartonniers)

N45

Coupe impression (Cartonniers)

N46

Surface impression (Cartonniers)

N47

Nombre de poses laize feuille (Cartonniers)

N48

Nombre de poses coupe feuille (Cartonniers)

N49

Rogne laize feuille (Cartonniers)

N50

Rogne coupe feuille (Cartonniers)

N51

Laize feuille (Cartonniers)

N52

Coupe feuille (Cartonniers)

N53

Surface feuille (Cartonniers)

N54

Poids Unitaire Net Article (en grammes) (Pour cli4)

N55

Surface Unitaire Nette Article (Pour cli4)

N56

Poids Unitaire Brut Article (en grammes)

N57

Surface Unitaire Brute Article

N60

Dimension spécifique d sur article (Cartonniers)

N61

Dimension spécifique e sur article (Cartonniers)

N62

Dimension spécifique f sur article (Cartonniers)

N63

Dimension spécifique g sur article (Cartonniers)

N64

Dimension spécifique h sur article (Cartonniers)

N65

Dimension spécifique i sur article (Cartonniers)

N66

Dimension spécifique j sur article (Cartonniers)

N67

Dimension spécifique k sur article (Cartonniers)

N68

Dimension spécifique S sur article (Cartonniers)

N69

Dimension spécifique T sur article (Cartonniers)

N70

Dimension spécifique U sur article (Cartonniers)

N71

Dimension spécifique V sur article (Cartonniers)

N72

Quantité fixe pour majoration de la quantité lancée.

N73

Pourcentage de majoration de la quantité lancée.

N74

Temps moyen de transport saisi sur la fiche client ( ou adresse secondaire ) en nombre de jours.

N80 à xxx

Cotes de refoulage N° 1 à N° 20 (Coupe Cartonniers)

Ces CIC sont associés à des TSC figés (TSC 08x pour les pointages refouleurs).

N80 TSC 085 zone numérique 1 - Pointage 01

N81 TSC 085 zone numérique 2 - Pointage 02

N82 TSC 085 zone numérique 3 - Pointage 03

N83 TSC 086 zone numérique 1 - Pointage 04

N84 TSC 086 zone numérique 2 - Pointage 05

N85 TSC 086 zone numérique 3 - Pointage 06

N86 TSC 087 zone numérique 1 - Pointage 07

N87 TSC 087 zone numérique 2 - Pointage 08

N88 TSC 087 zone numérique 3 - Pointage 09

N89 TSC 088 zone numérique 1 - Pointage 10

N90 TSC 088 zone numérique 2 - Pointage 11

N91 TSC 088 zone numérique 3 - Pointage 12

N92 TSC 089 zone numérique 1 - Pointage 13

N93 TSC 089 zone numérique 2 - Pointage 14

N94 TSC 089 zone numérique 3 - Pointage 15

N95 TSC 08F zone numérique 1 - Pointage 16

N96 TSC 08F zone numérique 2 - Pointage 17

N97 TSC 08F zone numérique 3 - Pointage 18

N98 TSC 08G zone numérique 1 - Pointage 19

N99 TSC 08G zone numérique 2 - Pointage 20

xxx TSC 08G zone numérique 3 - Pointage 21

xxx TSC 08H zone numérique 1 - Pointage 22

xxx TSC 08H zone numérique 2 - Pointage 23

xxx TSC 08H zone numérique 3 - Pointage 24

xxx TSC 08I zone numérique 1 - Pointage 25

xxx TSC 08I zone numérique 2 - Pointage 26

xxx TSC 08I zone numérique 3 - Pointage 27

xxx TSC 08J zone numérique 1 - Pointage 28

xxx TSC 08J zone numérique 2 - Pointage 29

xxx TSC 08J zone numérique 3 - Pointage 30

NA1

Laize brute (cartonniers)

alpha1[1,3] Code TSC correspondant à la saisie de laize brute

alpha1[4] Code zone de TSC (Ex : 1 pour numérique 1)

NA2

Coupe brute (cartonniers)

alpha1[1,3] Code TSC correspondant à la saisie de coupe brute

alpha1[4] Code zone de TSC (Ex : 2 pour numérique 2)

NA3

Nombre de jours en saisie de commande client - Modifié le 12/04/2011 pour la V.4.0.188.2

Anciennement, ce CIC servait aussi au nombre de paquets par colis.

Maintenant, ce nombre de paquets par colis est dans le CIC NA6.

NA4

Nombre de produits par caisse

NA5

Nombre de produits par palette

NA6

Nombre de paquets par colis - Créé le 12/04/2011 pour la V.4.0.188.2

Anciennement, ce nombre de paquets par colis était dans le CIC NA3

NC1

Coefficient de couverture utilisé pour le calcul - utilisé par gest_stk

NC2

Délai moyen utilisé pour le calcul - utilisé par gest_stk

NC3

Ecart type - utilisé par gest_stk

NC4

Délais moyen utilisé pour le calcul (par lieu de rangement) utilisé par gest_stk

NC5

Ecart type (par lieu de rangement) utilisé par gest_stk

NHD

Heure de début de livraison (logistique)

NHF

Heure de fin de livraison (logistique)

NP1

Nombre de sorties sur la période - utilisé par gest_stk

NP2

Consommation moyenne sur la période - utilisé par gest_stk

NP3

Quantité maxi sortie sur la période - utilisé par gest_stk

NP4

Total des consommations sur la période - utilisé par gest_stk

NP5

Stock moyen sur la période (Moyenne arithmétique du stock journalier) - gest_stk

NP6

Taux de couverture sur la période - utilisé par gest_stk

NP7

Taux de rotation sur la période - utilisé par gest_stk

NP8

Consommation moyenne journalière pour la période - utilisé par gest_stk

NQ1

Seuil dalerte de la fiche article avant mise à jour (par lieu de rangement) utilisé par gest_stk

NQ2

Stock mini/sécu de la fiche article avant mise à jour (par lieu de rangement) utilisé par gest_stk

NQ3

Stock maxi de la fiche article avant mise à jour (par lieu de rangement) utilisé par gest_stk

NQ4

Stock mini calculé (par lieu de rangement) utilisé par gest_stk

NQ5

Stock de sécurité calculé (par lieu de rangement) utilisé par gest_stk

NQ6

Stock dalerte calculé (par lieu de rangement) utilisé par gest_stk

NQ7

Consommation moyenne par jour en réappro utilisé par gest_stken mode par lieu

NR1

Consommation moyenne par mois (par lieu de rangement) utilisé par gest_stk

NR2

Stock moyen sur la période (par lieu de rangement) utilisé par gest_stk

NR3

Taux de couverture sur la période (par lieu de rangement) utilisé par gest_st k

NR4

Taux de rotation sur la période (par lieu de rangement) utilisé par gest_stk

NR5

Consommation moyenne par jour (par lieu de rangement) utilisé par gest_stk

NR6

Quantité maxi sur la période (par lieu de rangement) utilisé par gest_stk

NR7

Quantité totale sur la période (par lieu de rangement) utilisé par gest_stk

NR8

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

NS1

Seuil d'alerte de la fiche article avant mise à jour - utilisé par gest_stk

NS2

Stock mini/sécu de la fiche article avant mise à jour - utilisé par gest_stk

NS3

Stock maxi de la fiche article avant mise à jour - utilisé par gest_stk

NS4

Stock mini calculé - utilisé par gest_stk

NS5

Stock de sécurité calculé - utilisé par gest_stk

NS6

Stock d'alerte calculé - utilisé par gest_stk

NS7

Quantité minimum de fabrication utilisé par gest_stk

NS8

Consommation moyenne mensuel utilisé par gest_stk

NS9

Consommation moyenne par jour en réappro utilisé par gest_stken mode global

NV1 à NV5

Codes CIC libres apparaissant dans les visualisations.

Paramètres

P01 | Matière refoulée ? (O/N) (Cartonniers)
P02 | Estampille ? (O/N) (Cartonniers)
P03 | Code du contrôle blocage 1 de la revue de contrat
P04 | Code du contrôle blocage 2 de la revue de contrat
P05 | Code du contrôle blocage 3 de la revue de contrat
P06 | Code du contrôle blocage 4 de la revue de contrat
P07 | Code du contrôle blocage 5 de la revue de contrat
P08 | Code du contrôle blocage 6 de la revue de contrat
P09 | Code du contrôle blocage 7 de la revue de contrat
P10 | Code du contrôle blocage 8 de la revue de contrat
P11 | Code du contrôle blocage 9 de la revue de contrat
P12 | Code du contrôle blocage 10 de la revue de contrat
P13 | Code du contrôle blocage 11 de la revue de contrat
P14 | Code du contrôle blocage 12 de la revue de contrat
P15 | Code du contrôle blocage 13 de la revue de contrat
P16 | Code du contrôle blocage 14 de la revue de contrat
P17 | Code du contrôle blocage 15 de la revue de contrat
P18 | Code du contrôle blocage 16 de la revue de contrat
P19 | Code du contrôle blocage 17 de la revue de contrat
P20 | Code du contrôle blocage 18 de la revue de contrat
P21 | Code du contrôle blocage 19 de la revue de contrat
P22 | Code du contrôle blocage 20 de la revue de contrat
P23 | Code du contrôle blocage 21 de la revue de contrat
P24 | Code du contrôle blocage 22 de la revue de contrat
P25 | Code du contrôle blocage 23 de la revue de contrat
P26 | Code du contrôle blocage 24 de la revue de contrat
P27 | Code du contrôle blocage 25 de la revue de contrat
P28 | Code du contrôle blocage 26 de la revue de contrat
P29 | Code du contrôle blocage 27 de la revue de contrat
P41 à P60 | Type de refoulage de 1 à 20 (Cartonniers)
P61 | Code du rainage
P62 à P64 | Code des adresses tiers pour l'envoi des copies de documents
P65 | Code de l'adresse du tiers pour l'envoi de documents
P66 | Produit appairé sur la même palette (voir CIC/C08)
P67 | Produit appairé sur la même contre palette (voir CIC/C09)
P68 | Produit appairé sur la même palette (voir CIC/C12)
P69 | Produit appairé sur la même contre - palette (voir CIC/C13)
P70 | Produit appairé sur la même palette (voir CIC/C14)
P71 | Produit appairé sur la même contre - palette (voir CIC/C15)
P72 | Produit appairé sur la même palette (voir CIC/C16)
P73 | Produit appairé sur la même contre - palette (voir CIC/C17)
P74 | Produit appairé sur la même palette (voir CIC/C18)
P75 | Produit appairé sur la même contre - palette (voir CIC/C19)
P76 | Lieu intermédiaire de stockage par défaut
P77 | Code acheteur
P78 | A1[1,3] = Code du TSC où est située la zone CIC. Exemple : PIA A1[4] = Numéro de la zone dans le record p_ic.* (1 à 3)
PV1 à PV5 | Codes CIC libres apparaissant dans les visualisations.
PST | Sous-traitance
PTV | Type de véhicule (logistique)

Chaînes de caractères

Attention à ne pas confondre le zéro et la lettre O majuscule dans l'appellation des CIC !

C01 | Matière principale (Cartonnier)
C02 | Matière secondaire (Cartonnier)
C03 | Contrôle racine N° SBI
C04 à C06 | Code tiers pour l'envoi des copies de documents
C07 | Code tiers pour l'envoi de documents
C08 | Code article palette pour facturation des palettes lors de l'édition de BL
C09 | Code article contre palette pour facturation des contre-palettes lors de l'édition de BL
C10 | Code fournisseur habituel
C11 | Qualité Carton
C12 | Code article palette pour facturation des palettes lors de l'édition de BL
C13 | Code article contre - palette pour facturation des contre - palettes lors de l'édition de BL
C14 | Code article palette pour facturation des palettes lors de l'édition de BL
C15 | Code article contre - palette pour facturation des contre - palettes lors de l'édition de BL
C16 | Code article palette pour facturation des palettes lors de l'édition de BL
C17 | Code article contre - palette pour facturation des contre - palettes lors de l'édition de BL
C18 | Code article palette pour facturation des palettes lors de l'édition de BL
C19 | Code article contre - palette pour facturation des contre - palettes lors de l'édition de BL
C20 | Code produit fini pour lequel le code article a été créé Utilisé dans la gestion des besoins matière Pour les prélèvements, voir le CIC C25
C21 | Code fournisseur supérieur à 8 caractères
C22 | Palette à reprendre (logistique)
C23 | TSC qui contient le produit d'impression pour les références multiples
C24 | TSC qui contient le code produit de palettisation pour les références multiples
C25 | N° d'étude qualité labo (utilisé dans la gestion des prélèvements Utilisé dans la gestion des prélèvements Pour les besoins matière, voir le CIC C20
CV1 à CV5 | Codes CIC libres apparaissant dans les visualisations.
CO1 à CO5 | ATTENTION : lire la lettre O et non pas le chiffre zéro. Outils associés aux PF. A1[4] = 1 pour indiquer la zone ic_char30 Correspondent aux TSC OU1 à OU5 pour les outils 1 à 5


CIV Civilité

Ce type de paramètre permet de compléter les noms des correspondants par un code civilité.

La saisie est facultatif.

Le libellé long du code civilité est ajouté devant les noms des expéditeurs et destinataires sur les entêtes des fax / e-mail.

Valeur alpha 1

CIV A1[1,3]

Code civilité pour interface SIDE TRADE


CLR Classes

Pas de paramétrage.

Voir la fiche d'installation des nouvelles zones de la table par02


CND Code conditionnement

Valeurs numériques

CND N1

Nombre d'unités par unité de conditionnement

Exemple

Il faudra saisir 500 dans la valeur 1 pour un conditionnement de 500 unités par unité de conditionnement.

Valeur alpha 1

CND A1[1] | Filtrage pour la recherche D Devis standard
CND A1[2] | Autorisation de saisie du sens d'enroulement (O/N)
CND A1[3,6] | Valeur par défaut pour la bobine (Diamètre, Nombre d'étiquettes, Longueur) - Voir alpha1[9]
CND A1[7] | Réservé.
CND A1[8] | Autorisation de saisie du métrage linéaire de la bobine (O/N)
CND A1[9] | Type de valeur de la zone alpha1[3,6] D Diamètre bobine N Nombre d'étiquettes par bobine L Longueur (mètres linéaires)
CND A1[10] | Mode d'emballage H Hors ligne (par défaut) L En ligne


COL Code colisage

Pas de paramétrage particulier


COM Comtés

Pas de paramétrage particulier.

Indiquer le code du comté et le nom complet dans le libellé long.

Exemple : COM GLO : GLOUCESTERSHIRE


COP Code paramètre

Le code choisi n'a aucune importance : On mettra autant de codes différents que de numéros de phases

Valeurs numériques

COP N1

Numéro de phase

Valeur alpha 1

COP A1[1,50]

code clé de l'opération à créer

Rappel

Ce type de paramètre est utilisé dans la saisie des temps (paramètre -Ocr). Quand l'utilisateur entre un numéro de phase inconnu, on créé l'opération dont le code clé se trouve dans la zone alpha1.


COR Code opération décorticage

Utilisé dans ATLAS-CARTON au niveau de l'opération décorticage.


COU Codes couleurs

Pas de paramétrage particulier


CP Codes pointages

Soient les refoulages suivants dans le devis :

Refouleur (REF) 177

Slitter (SL) 56

Refouleur (REF) 100

Slitter (SL) 100

Couteau (COU) 177

Ces refoulages seront tous passés au fournisseur.

Si le fournisseur ne sait pas faire de slittage, dans le paramètre CP SL, on exclue ces refoulages de la commande d'achat.

Les refoulages passés lors de la commande d'achat seront les suivants :

Refouleur 177

Refouleur 156

Couteau 277

CP Codes pointages

Valeur alpha 1

CP A1[1]

R Refouleur

C Couteau

CP A1[2]

O A contrôler

N Ignorer

CP A1[3]

O A transférer (défaut)

N Ignorer

Concerne la génération automatique d'articles

CP A1[4]

S Rainage supplémentaire

N Rainage normal

[spécifique, géré uniquement sur édition]

CP A1[5]

Type précis du refouleur

CP A1[6]

Type de trait - VoluOptimix - Voir ci-dessous

CP A1[7,8]

Couleur du trait - VoluOptimix - Voir ci-dessous

CP A1[9,11]

Code de remplacement du Code Pointage pour la génération des plaques si ce dernier est un couteau et que l'on n'est pas sur la dernière pose

Lors de la création d'un code plaque via la traitement des besoins, les pointages transférés à ce code plaque ne contiennent que les couteaux de la dernière pose.

Le but de ce paramétrage est de forcer le transfert des pointages ignorés en remplacement le type de pointage ‘couteaux'par un autre type paramétré (en effet, il ne devrait y avoir qu'un couteau en fin de plaque).

CP A1[12]

Doit-on exclure ce refoulage lors de la génération de commande fournisseur ?( O/N, N par défaut)

Lors de la génération de commande d'achat, ne pas passer tous les refoulages (certains n'étant pas gérés par le fournisseur).

Exemple

CP A1[13]

Doit-on transférer ce code pointage à OMP (O/N, O par défaut)

Cela permet d'exclure les pointages de type couteau.

CP A1[14]

Code pointage OMP

Lien entre le code pointage VoluPack et le code pointage OMP.

Il est important de le saisir si, dans la gamme de fabrication, on utilise en même temps différents types de refouleurs.

Il faut alors avoir un type de refouleur VoluPack par refouleur OMP.

Si, dans la gamme, ce sont toujours des types identiques, il suffit alors de renseigner le type OMP dans le paramètre de type .TR, A1[1].

Ce paramètre de type .TR est stocké sur le TSC 095 du produit architecture (saisi dans l'écran architecture).

Création d'un trait dans le programme ECMA

1. Paramétrage pour afficher un rectangle

dans la zone Code sens/dimension : nouveau code ‘R'comme rectangle

dans la zone Formule : codification point supérieur gauche sur 6 caractères, codification point inférieur droit sur 6 caractères.

pour la définition du type de trait et de la couleur paramétrage idem que le trait (type paramètre CP)

2. Paramétrage d'une condition pour afficher ou non un trait ou un rectangle

Sur la zone formule pour un code sens de type T (trait) ou R (rectangle)

Caractère 13 de la zone formule : nom de la variable de conditionnement (ex : a,b,c,d….)

Si la variable paramétrée est différente de 0 alors le trait/rectangle sera affiché (si absence de paramétrage)

Remplir les zones de la table des pointages for_ppo comme_suit :

up_sens_dimension (saisi dans la fenêtre de saisie des codes ECMA, dans la zone Code sens/dimension ) =

T Trait

R Rectangle

up_type_pointage = code de type CP (renseigne la couleur et le type de trait)

up_num_pointage = numéro du trait

up_formule[1,3] = code type pointage du point de départ du trait

up_formule[4,6] = numéro de pointage du point de départ du trait

up_formule[7,9] = code type pointage du point d'arrivée du trait

up_formule[10,12] = numéro de pointage du point d'arrivée du trait

Exemple

up_formule : COP001COP004

(trace un trait entre le point 1 et le point 4 de type COP)

Liste des types de traits (type T)

Code | Type de trait
0 | Plein
1 | Tirets
2 | Pointillés
3 | Tiret -1 Point
4 | Tiret - 2 Points

Liste des types de rectangles (type R)

Code | Type de trait
0 | hachures horizontales
1 | hachures verticales
2 | hachures diagonales (orientation inclinée vers la droite)
3 | hachures diagonales (orientation inclinée vers la gauche)
4 | hachures croisées verticales + horizontales (0+1)
5 | hachures croisées diagonales (2+3)
6 | rectangle plein

Liste de couleurs

Code | Couleur
0 | Noir
1 | Bleu
2 | Vert
3 | Cyan
4 | Rouge
5 | Magenta
6 | Jaune
7 | Blanc
8 | Gris foncé
9 | Gris clair
10 | Orange
11 | Crème
12 | Rose
13 | Marron
14 | Violet

Notes

CORRESP_EDI

21, 23 Code correspondance pour génération / intégration fichier EDI de type ORDERS ou autres

Les codes correspondances associés au type CP sont :

COU Couteau

REF Refouleur

C+R Couteau + Refouleur

Si le code de type CP à paramétrer est égal au code de correspondance ci-dessus, il n'est pas nécessaire de renseigner la ligne de note !


CPL Codes compléments

Voir aussi la saisie simplifiée d'articles, note commençant par COL_ART*

Valeur alpha 1

CPL A1[1] | Numéro d'indice du complément (1 à 9, pas de valeur par défaut) Chaque complément doit posséder un indice propre, le numéro d'indice influe sur l'ordre des boutons dans la saisie simplifiée.
CPL A1[2,3] | Numéro d'indice du complément pour la saisie dans les lignes complémentaires (LCO) 1 à 20, pas de valeur par défaut Chaque complément doit posséder un indice propre, le numéro d'indice influe sur l'ordre des boutons dans la saisie des lignes complémentaires (LCO).

Valeur alpha 2

CPL A2[1,60]

Chemin de l'image à mettre en place sur le bouton correspondant au code complément sur la saisie simplifiée.

Spécifique à la saisie des lignes complémentaires (LCO) :

Chemin de l'image de saisie non validée (ou par défaut) à mettre en place sur le bouton correspondant au code complément.

Valeur alpha 3

CPL A3[1,60]

Spécifique à la saisie des lignes complémentaires (LCO) :

Chemin de l'image de saisie validée à mettre en place sur le bouton correspondant au code complément.

Notes

SAISIE_VALIDEE_LCO

Spécifique à la saisie des lignes complémentaires (LCO) :

Paramétrage permettant de déterminer si la saisie des lignes complémentaires (LCO) du complément est validée ou non

Les caractères 21 à 24 permettent de récupérer la valeur saisie dans la zone de LCO de validation.

Les caractères 26 à 40 permettent de renseigner la valeur de validation.

21,23 Code LCO de validation

24 Zone LCO de validation

25 Code de comparaison d'égalité entre la valeur de la LCO de validation et la valeur paramétrée (la saisie des LCO du complément est considérée comme étant validée si la condition est vérifiée).

= La valeur saisie doit être égale à la valeur paramétrée

! La valeur saisie doit être différente de la valeur paramétrée

< La valeur saisie doit être inférieure à la valeur paramétrée

> La valeur saisie doit être supérieure à la valeur paramétrée

26,40 Valeur à comparer avec la valeur saisie dans la zone de la LCO de validation.

TYPES_NOTES_ARTICLE

21,59 Liste des types de notes (NTS) à visualiser pour ce complément

Ce paramétrage est prioritaire par rapport au –C du paramètre de lancement de la saisie des articles.

13 codes de 3 caractères par ligne

Saisie des lignes complémentaires (LCO) :

Images différentes sur les boutons complément selon une valeur de LCO

Permet de modifier dynamiquement l'image du bouton de complément (CPL) selon la valeur saisie d'une ligne complémentaire (LCO)

Un bouton complément est associé à une seule zone d'un seul code LCO.

Permettre de paramétrer le code complément (CPL) par défaut pour la saisie simplifiée des articles.

Le complément par défaut concerne les données générales (données qui ne sont pas associés à un code complément spécifique).

Créer le code CPL #DA.

En A2[1,60], indiquer le chemin de l'image du bouton des données par défaut.

Permettre de paramétrer le code complément (CPL) par défaut pour la saisie des informations complémentaires (TSC).

Le complément par défaut concerne les données générales (données qui ne sont pas associés à un code complément spécifique).

Créer le code CPL #DT.

En A2[1,60], indiquer le chemin de l'image du bouton des données par défaut.

Permettre de paramétrer le code complément (CPL) par défaut pour la saisie des données complémentaires (LCO).

Le complément par défaut concerne les données générales (données qui ne sont pas associés à un code complément spécifique).

Créer le code CPL #DL.

En A2[1,60], indiquer le chemin de l'image du bouton des données par défaut.


CPO Centres postaux

Valeurs numériques

CPO N1

Correspondance numérique du centre postal


CPR Correspondance codes produits & produit réel

CPR Correspondance code produit & produit réel

Ce paramètre permet d'assurer la correspondance entre un Code produit et un produit réel du fichier article.

Valeur alpha 1

CPR A1[1]

Imputation au chiffre d'affaire commercial (O/N)

O Par défaut

Ce paramètre permet de définir si le montant HT d'une ligne de facture saisie doit être imputé au chiffre d'affaire commercial.

Notes

Les notes permettent d'assurer la correspondance entre chaque code TVA et un code article.

C'est par cet article que l'on peut déterminer les comptes d'achat et de vente correspondants en comptabilité générale.

Il est donc ainsi possible pour un code produit donné, d'avoir des comptes d'imputation différents en fonction du code TVA.

Caractères 1 à 3 | Code TVA
Caractères 5 à 19 | Code article


CRI Cotation du risque

Aucun paramétrage


CRT Certification forestière

Ce paramètre est utilisable à partir de la V. 4.1.19.2

Il est utilisé dans les programmes suivants :

- devis onduleur

- saisie des produits

La certification peut être liée au client ou à la fiche article (Voir la note MODE_CERTIFICATION dans le #CF ATL et le TSC FSC.

– Si la certification est liée à l'article : lors de la création d'un article par défaut, celui-ci prend la certification de la fiche client.
Par contre, la saisie de commande et la saisie de BL prennent uniquement la certification qui est sur l'article.

– Dans le devis onduleur, si un des composants de l'ensemble est certifié, alors l'ensemble est certifié.

Valeurs numériques

1 | Pourcentage de la certification
2 | non utilisée

Certifications connues :

FSC = Forest Stewardship Council (Association pour la Protection de la Forêt) (WikipédiA)

PEFC = Program for the Endorsement of Forest Certification (Programme de Reconnaissance des Certifications Forestières) (WikipédiA)


CS Coûts supplémentaires

Valeur alpha 1

CS A1[1,3] | Type de coûts supplémentaires (TCS)
CS A1[4] | Ce coût est t-il associé à un PF (O/N, N par défaut)
CS A1[5] | Suppression autorisée lors de la saisie ? (O/N)
CS A1[6] | Doublon autorisé lors de la saisie ? (O/N)
CS A1[20,22] | Code d'imputation du coût STR Coût de structure COM Coût commercial CFI Coût financier TRA Coût de transport AUT Autre coût

Valeur alpha 2

CS A2[1,9] | Code opération standard sous la forme XXXYYYZZZ
CS A2[10,12] | Code de difficulté (NOR)
CS A2[13,18] | Code machine (XXXXXX)

Valeur alpha 3

CS A3[1] | Coût supplémentaire à valoriser pour une gamme hors négoce (ne commençant pas par ST) O par défaut
CS A3[2] | Coût supplémentaire à valoriser pour une gamme négoce (commençant par ST) O par défaut

Notes

C

Liste des éléments de calcul

2 à 4 Code élément de calcul ( Type ECC)

On limitera le nombre de lignes à 20

Cette liste fournit la séquence d'apparition à l'écran.


CSC Codes couture / sans couture

Les codes sont figés.

Tous les codes commençant par S sont considérés SANS COUTURE

C | Couture
SF | Sans couture Flexstabil
ST | Sans couture traditionnel

Valeur alpha 2

CSC A2[1,3] | Catégorie de couture Si MAN : opération manuelle
CSC A2[10] | Type assemblage couture en une opération
CSC A2[11] | Spécifique

Valeur alpha 3

CSC A3[1,6]

Code machine qui peut être utilisé par l'opération d'emboîtage

(Cf opération emboîtage sur l'aide devis Reliure)

Valeur alpha 4

CSC A4[1,60]

Libellé du devis client


CS1 CS2 CS3 CS4 Codes statistiques

L'obligation de saisie des codes statistiques se paramètre sur le TYC note CTRL_CODE_CS_

Valeur alpha 1

CSn A1[1] | Lien avec niveau inférieur (O/N, N par défaut) Non applicable à CS4
CSn A1[2,4] | Code statistique : Lien avec le code statistique de niveau supérieur Non applicable à CS1
CSn A1[5,7] | Code famille liée à ce code statistique Voir la note LIEN_AVEC_CODE_CS dans FAM.
CSn A1[8,10] | Code sous-famille liée à ce code statistique Voir la note LIEN_AVEC_CODE_CS dans FAM.
CSn A1[11] | Mode d'initialisation de la quantité d'achat Ceci fonctionne en génération automatique d'une commande d'achat lors de l'édition définitive d'un BL (Ocf). 1 Quantité livrée (par défaut) 2 Nombre de palette (par rapport à la quantité livrée)
CSn A1[12,17] | Type et code paramètre pour la recherche de tarif Ceci fonctionne en génération automatique d'une commande d'achat lors de l'édition définitive d'un BL (Ocf). Si non renseigné, on prend par défaut ceux du paramètre de lancement.

Si l'on fait F7 sur le deuxième code statistique (CS2), on lit le caractère alpha1[1] du premier code statistique pour savoir s'il existe un lien entre ces deux codes.

Si oui, on recherche tous les CS2 ayant le code CS1 paramétré en alpha1[2,4].

Valeur alpha 2

CSn A2[1,10]

Types d'articles autorisés pour ce code statistique

Utilisé dans le cadre de l'importation des matières – outils Prophée.

Notes

COMPTE_ACHAT | Paramétrage du compte d'achat 21,28 Compte de vente France 29,36 Compte de vente Export 37,44 Compte de vente Suspension de taxe 45,52 Compte de vente Intra-communautaire 53,60 Compte de vente Exonéré
COMPTE_BRC | Paramétrage du compte de vente pour les bons de réception Bons de réception : voir la page récapitulative dans le #CF TFB 21,28 Compte de vente France 29,36 Compte de vente Export 37,44 Compte de vente Suspension de taxe 45,52 Compte de vente Intra-communautaire 53,60 Compte de vente Exonéré
COMPTE_VENTE | Paramétrage du compte de vente 21,28 Compte de vente France 29,36 Compte de vente Export 37,44 Compte de vente Suspension de taxe 45,52 Compte de vente Intra-communautaire 53,60 Compte de vente Exonéré Pour l'ordre de recherche du compte de vente, voir cette page.
_COMPTE_VENTE_AVO | Paramétrage du compte de vente pour les avoirs. Pour l'ordre de recherche du compte de vente pour les avoirs, voir cette page.
_COMPTE_VENTE_GROUPE | Dans la fonction de recherche du compte de vente, ajout de la recherche si le client est Groupe. Ce paramétrage est effectif sur les paramètres CS1, CS2, CS3, CS4, SFM et FAM. 21,28 Compte de vente France 29,36 Compte de vente Export 37,44 Compte de Vente Suspension de Taxe 45,52 Compte de Vente Intracommunautaire 53,60 Compte de vente Exonéré
CS_LIE | 21,23 Code statistique : Lien avec le code statistique de niveau supérieur <VF> Avant, on ne pouvait lier un code statistique qu'avec un seul code statistique en renseignant ce code statistique père en A1[2,4]. Désormais, cette note permet de paramétrer plusieurs codes statistiques pères.
FAMSFM_LIEE | Un code statistique peut être lié à plusieurs familles ou familles/sous-familles. 21,23 Code famille liée à ce code statistique 24,26 Code sous-famille liée à ce code statistique Voir la note LIEN_AVEC_CODE_CS dans FAM.
LIBELLE_CS_ | Saisie des codes statistiques à partir de l'écran des informations complémentaires 12,14 Code Famille 15,17 Code Sous-famille Rappel : Autorisation des codes statistiques via le paramétrage de la famille du produit (FAM A4[52,55]) Attention, option payante BAS 15
METHODE_REMPL_POIDS | 21 Méthode pour remplir la zone lc_poids en saisie de commande 1 lc_poids = 1 S Saisie du poids total Vide méthode standard La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire. La recherche du paramétrage se fait dans l'ordre suivant : 1– Code statistique 1 (ici) 2– Famille – sous-famille 3– Famille Applicable uniquement à CS1 Utilisable entre autres dans la papeterie
SECTION_ANALYTIQUE | 21,32 Section analytique sur 12 caractères Exemple SECTION_ANALYTIQUE ANAVTEBUDV
UNITE_VENTE | Permet d'initialiser la zone lc_unvent (code UNI) en saisie de commande. La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire. La recherche du paramétrage se fait dans l'ordre suivant : 1– Code statistique 1 (ici) 2– Famille – sous-famille 3– Famille Applicable uniquement à CS1 Utilisable entre autres dans la papeterie
VALEUR_CODIF_ART | Voir la note CODIF_ART* dans la codification automatique des articles. <VF>

Libellés des codes statistiques

Les libellés des codes statistiques sont recherchés en cascade sur :

1. Famille/Sous-famille (mp_fam/mp_sfm)

2. Famille (mp_fam)

3. Type d'article (mp_mp)

4. Paramètre LIB/CSx (où x = 1 à 4) - Note LIBELLE_CS_

5. Type de paramètre CSx (où x = 1 à 4)


CTT Classes de TTR

Valeur alpha

CTT A1[1]

E Exclu (temps exclu de 1 - NOMBRE D'HEURES TOTALES dans ana_a

O ou Blanc Affectés


DAP Division APE

Pas de paramétrage, seul le libellé est utilisé.


DC Dimensions calculées

Les codes PER et SUR sont des codes utilisés en dur dans le devis standard.

PER Périmètre du code ECMA (code contour)

SUR Surface de l'élément

Valeur alpha 1

DC A1[1] | Ce caractère permet d'identifier une dimension calculée dans des traitements et éditions particulières, et ce malgré une codification libre du code paramètre.
DC A1[2] |


DCO Défauts constatés

Valeur alpha 2

DCO A2[1]

Type de code défaut

C Client

F Fournisseur

I Interne

S Standard (par défaut)


DCL Type de détail couleur

Dans les entités du devis multi-métiers, on peut saisir le détail des couleurs via un nouvel écran.

Cet écran est accessible via la touche de fonction Control-Maj-F4, sur les entités de type

FEUDEP Feuillet/Dépliant

ETIBOB Etiquette bobine

ETIFEU Etiquette feuille

BOIPLI Boîte pliante

SAILCO Saisie des lignes complémentaires

Les notes sont saisies via la saisie standard des notes, avec le type de note DCL.

Les lignes sont sauvegardées dans la base de données dans la table couleurs.

Valeur alpha 1

DCL A1[1,3] | Famille/Type de couleur Exemples ENC Encre VER Vernis DOR Dorure GAU Gaufrage
DCL A1[4,6] | Sous-famille/Sous-type de couleur correspondant au type ci-dessus
DCL A1[7,21] | Code matière par défaut
DCL A1[22] | Code H/L/S par défaut (Hors ligne/en Ligne/Sous-traitance, pas de valeur par défaut)

Valeur alpha 2

DCL A2[1] | Ouverture de l’écran de recherche des machines (O/N, N par défaut)
DCL A2[2] | Accès automatique au détail de l’écran après la saisie du numéro de groupe N Pas d’accès en automatique (par défaut) C Accès uniquement en création de ligne T Accès systématique

Notes

_SUP_REQ_FOURNISSEUR | 21,60 Complément de sélection pour la recherche des codes fournisseurs
_SUP_REQ_MACHINE | 21,60 Complément de sélection pour la recherche des codes machines
_SUP_REQ_MATIERE | 21,60 Complément de sélection pour la recherche des codes matières


DEC Codes découpe

Pas de paramétrage particulier


DEM Demandeur

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

DEM A1[1,3]

Code site du demandeur. Facultatif

Tableau de bord du multisite


DEN Dénomination - Forme juridique

Valeur alpha 1

DEN A1[1]

Forme juridique

Correspondance utilisée pour le transfert des tiers JDE.

La valeur est obligatoire mais non contrôlée.


DEP Départements

Les codes départements doivent être saisis sur 2 caractères

Valeur alpha 1

DEP A1[1,3]

Secteur géographique

Ce secteur géographique alimente automatiquement la zone Secteur géographique lors de la saisie du code postal dans la fiche client.

Uniquement si le code pays de la fiche client est égal au code pays de la fiche société

DEP A1[4,6]

Code port

DEP A1[7,9]

Coefficient de colisage

DEP A1[10,12]

Code poids

DEP A1[13,15]

Code de regroupement du département

Utilisé dans le module d'aide à la saisie des groupages

DEP A1[16,18]

Code région

DEP A1[19,21]

Code représentant

Ce code représentant alimente automatiquement la zone Secteur géographique lors de la saisie du code postal dans la fiche client

DEP A1[22,24]

Code pondération coût de transport

DEP A1[25]

Type de contrôle des livraisons dans un même département à une même date

Voir la note VISU_GROUPAGE_BL dans la saisie des commandes clients.

PAY A1[16,18] doit être FR (France).

O Contrôle standard (valeur par défaut)

N Pas de contrôle

L Restriction du contrôle au même lieu intermédiaire, sinon à la même adresse de livraison d'un même client.

X Contrôle restreint sur le même regroupement d'adresses de livraison.
En effet, si plusieurs adresses secondaires se trouvent physiquement proches, on peut désormais les indiquer comme étant regroupées sous une adresse de livraison commune dans le TSC RAL rattaché à la fiche client ou à l'adresse secondaire.
Le contrôle n'est effectué que si l'adresse de livraison, la date de livraison, ou le lieu intermédiaire ont été modifiés.


DEV Codes devises

Voir aussi le programme devise

Valeurs numériques

DEV N1 | Nombre de décimales
DEV N2 | Cours de la devise société pour 1 EURO A renseigner sur la devise EUR uniquement

Valeur alpha 1

DEV A1[1,6] | Code ISO de la devise (seuls les caractères 1 à 3 sont utilisés l'interface SIDE TRADE)
DEV A1[7] | Type de la devise (I ou O) Obligatoire I IN Devise faisant partie de l'union monétaire. O OUT Devise ne faisant pas partie de l'union monétaire Le cours de la devise pour 1 EURO au 01/01/1999 doit être présent dans le fichier des devises.
DEV A1[8,15] | Date de passage de la devise de OUT à IN Obligatoire si la devise est une devise IN La date de passage ne peut pas être antérieure au 01/01/1999
DEV A1[16,23] | Cours de la devise pour 1 EURO (6 chiffres significatifs) Obligatoire si la devise est une devise IN Le cours ne peut pas être égal à 0 Saisir le cours avec le point décimal (Exemple 6.47551 ou 138.334)
DEV A1[24] | Edition d'une traite sur relevé ou sur facture pour cette devise (N ou O) Facultatif Si le caractère est à N, la traite n'est pas éditée Si le caractère est à O, la traite est éditée Si le caractère a une autre valeur, la traite est éditée si la devise du relevé ou de la facture est identique à la devise de la société.
DEV A1[25,30] | Ecart autorisé pour le contrôle des factures SBI entre le HT de la facture SBI et le HT saisi (Exemple 0.03 (3 centimes))
DEV A1[31] | Valeurs autorisées pour la dernière décimale de la devise (1 ou 2) Si le caractère est à 1, toutes les valeurs sont autorisées Si le caractère est à 2, seules les valeurs 0 et 5 sont autorisées Par défaut, toutes les valeurs sont autorisées
DEV A1[32] | Nombre de décimales des montants Si celui-ci n'est pas renseigné, il est pris dans la valeur numérique 1. Si celle-ci n'est pas renseignée, il est égal à 2. Si le montant doit être retourné sans décimales, il faut saisir 0.

Valeur alpha 2

DEV A2[1,3] | Code devise pour le transfert en compta
DEV A2[4,5] | Numéro de devise pour le transfert en comptabilité SAGE 100 interface No 2 (format .txt) Le numéro de devise correspond à l'ordre de création des devises dans la comptabilité. Valeur par défaut : 1

REMARQUES IMPORTANTES POUR LA DEVISE DE L' EURO

Le code devise de l'EURO est EUR et est figé. Il doit exister. Il doit être paramétré comme ci-dessous :

Caractère 7 | Type de la devise I
Caractères 8 à 15 | Date de passage de la devise de OUT à IN 01/01/1999
Caractères 16 à 23 | Cours de la devise pour 1 EURO 1
Caractère 24 | Edition d'une traite sur relevé ou sur facture pour l'EURO N (pas d'édition de traite) O (édition d'une traite)

Notes

CODE_DEV_EFFICIAL | 21,23 Code devise de transaction - SPECIFIQUE
LIB_DEV_ | Fonction de transformation d'un nombre en lettres 9 à 11 Code ISO associé au code langue de l'adresse de facturation Ce code est recherché sur LAN A1[2,4]. 12 _ (underscore) 13 à 16 Code de libellé devise. Codes possibles : ENT code du libellé singulier de la devise ENTP code du libellé au pluriel de la devise ENTS code du libellé au pluriel conjugué de la devise (spécifique à la Pologne) CEN code du libellé au singulier du centième de devise CENP code du libellé au pluriel du centième de devise CENS code du libellé au pluriel conjugué du centième de devise (spécifique à la Pologne) MIL code du libellé au singulier du millième de devise MILP code du libellé au pluriel du millième de devise MILS code du libellé au pluriel conjugué du millième de devise (spécifique à la Pologne) 17 à 20 [blanc] 21 à 60 Libellé de la devise correspondant aux différents codes ci-dessus Exemples LIB_DEV_FRA_ENTP francs LIB_DEV_FRA_CEN centime
TRANSCO_SAP | 21,23 Transcodification du Code DEV chez SAP


DIF Code difficulté

Valeur alpha 1

DIF A1[1]

Sélection du code difficulté dans la recherche (O/N, O par défaut)


DOM Centre dominant

Valeur alpha 1

DOM A1[1]

Autorisé en ordonnancement (O/N, N par défaut)


DPC Détail prix commande

Valeurs numériques

DPC N1 | Prix de vente ou de revient par défaut
DPC N2 | Quantité par défaut

Valeur alpha 1

DPC A1[1,3] | Code unité de prix de vente
DPC A1[4,7] | Marge par défaut Exemples : 1000 pour 10,00%, 0500 pour 5,00%
DPC A1[8,10] | Code unité de quantité
DPC A1[11] | Ouverture fenêtre de saisie des barèmes dans la fenêtre de saisie du détail de prix N Non : Pas d'ouverture de la fenêtre de saisie des barèmes en création de lignes, Touche F8 d'ouverture de la fenêtre de saisie des barèmes non activée en création et en modification de lignes. O Oui: Ouverture automatique de la fenêtre de saisie des barèmes en création de lignes après la saisie du code détail de prix, Touche F8 d'ouverture de la fenêtre de saisie des barèmes activée en création et en modification de lignes

Notes triées

COR

Paramétrage des correspondances

4,6 Type de correspondance - Obligatoire

ETE Elément technique

SCC Schéma de calcul

7,9 Code correspondance - Obligatoire

10,18 Code calcul schéma de calcul

Interdit si Type correspondance ETE

Obligatoire si Type correspondance SCC

CL Code client de la commande

DI Dimension (voir le détail de ce code calcul)

EL Elément technique (voir le détail de ce code calcul)

QT Quantité (voir le détail de ce code calcul)

SC Quantité du schéma de calcul

TC TSC (voir le détail de ce code calcul)

19,36 Nom du champ à mettre à jour

Champ de l'entête du devis (table fle_2)

Champ des entités du devis (table fle_imp)

Champ des LCO de l'entête du devis et des entités (table fle_com)

Nom du champ sous la forme LCO_COD_Z

LCO Constante

COD Code de la ligne complémentaire (paramètre LCO)

Z Code la zone

Champ des TSC de l'entête du devis et des entités (table info_c)

Nom du champ sous la forme TSC_COD_Z

TSC Constante

COD Code de la trame de saisie complémentaire (paramètre TSC)

Z Code la zone

37,38 Numéro d'entité

Interdit si champ de la table fle_2

Obligatoire si champ de la table fle_imp

Facultatif si champ des tables fle_com et info_c

CRE

Paramétrage des créations des devis et des entités

4 Devis ou Entité - Obligatoire

D Devis

E Entité

5,12 Devis de référence - Obligatoire

13,14 Sous-devis de référence - Obligatoire

15,16 Entité de référence

Interdit si Devis (car.4 = D)

Obligatoire si Entité (car.4 = E)

17,18 Numéro ordre de l'entité à créer

Interdit si Devis (car.4 = D)

Obligatoire si Entité (car.4 = E)

19,27 Code calcul de désactivation - Facultatif

28 Signe du test

= Egal à la valeur de comparaison

! Différent de la valeur de comparaison

# Egal à null

Interdit si Code calcul de désactivation non renseigné

Obligatoire si Code calcul de désactivation renseigné

29,38 Valeur de comparaison

Interdite si Code calcul de désactivation non renseigné

Interdite si Code calcul de désactivation renseigné et Signe du test égal à #

ETE

Paramétrage des éléments techniques

A) Redécoupage pour paramétrage

4 à 6 Code de l'élément technique

7 P Paramétrage

8 Type de la zone de l'élément technique. Obligatoire

A Alphanumérique

N Numérique

9 Code saisie obligatoire de l'élément technique. Obligatoire

N Non

W Warning

B Bloquant

10 à 11 Type de contrôle de l'élément technique. Facultatif

[espace] Pas de contrôle

01 Code paramètre

02 Code article (Recherche produit)

03 Code ECMA / FEFCO

04 Code gamme standard

05 Code machine

06 Code article (Recherche données techniques)

07 Code article (Recherche papier)

08 Code sous-famille

09 Code tiers

12 à 14 Code complément contrôle de l'élément technique. Facultatif

15 à 29 using d'affichage de l'élément technique

Obligatoire sur une zone numérique

Facultatif sur une zone alphanumérique

30 à 31 Longueur de zone de l'élément technique. Obligatoire. 01 à 15 autorisée

32 à 41 Borne inférieure de l'élément technique. Facultatif

42 à 51 Borne supérieure de l'élément technique. Facultatif

B) Redécoupage pour le libellé

4 à 6 Code de l'élément technique

7 L Libellé

8 à 47 Libellé de l'élément technique. Obligatoire

48 à 57 Valeur par défaut de l'élément technique. Facultatif

58 Valeur figée (O/N, N par défaut) - Obligatoire

O La valeur est figée.

N La valeur est modifiable.

C) Complément de recherche d'articles ou de tiers

4 à 6 Code de l'élément technique. Obligatoire

7 S Sélection

8,60 Complément de recherche d'articles ou de tiers

Utilisé si le type de contrôle de l'élément technique est 02 ou 06 ou 07 ou 09

FIL

Paramétrage des filtres

4,9 Code client - Facultatif

10,12 Code famille - Facultatif

13,15 Code sous-famille - Facultatif

16,30 Code article - Facultatif

LIB

Paramétrage des libellés

4,60 Descriptif

100 lignes maxi

Utilisé dans les éditions VoluEdit

SCC

Paramétrage des schémas de calcul

A) Redécoupage pour paramétrage :

4 à 6 Code du schéma de calcul

7 P Paramétrage

8 à 10 Formule matière : Non renseigné

Formule opération : Code section du schéma de calcul - Obligatoire

11 à 13 Formule matière : Code phase du schéma de calcul - Obligatoire

Formule opération : Code opération du schéma de calcul - Obligatoire

14 à 16 Formule matière : Non renseigné

Formule opération : Code sous-opération du schéma de calcul - Obligatoire

17 à 19 Code formule du schéma de calcul. Obligatoire

20 à 22 Code unité du schéma de calcul. Facultatif

23 Code retour quantité du schéma de calcul (O/N, N par défaut). Obligatoire

Après validation de l'écran de saisie des barèmes (F10), c'est la quantité de ce schéma de calcul qui sera retournée sur la ligne détail de prix

24 prise en compte des gâches (O/N, N par défaut) - Obligatoire

25 prise en compte des temps de calage ou roulage - Obligatoire

N Non (par défaut)

R Temps de roulage

C Temps de calage

26 Mode de recherche du prix - Obligatoire

N Mode normal (par défaut)

T Recherche sur la clé tarifaire

C Recherche sur le centre de coût

27 Type formule du schéma de calcul (M/O, O par défaut) - Obligatoire

M Matière

O Opération

28 Affichage du message de cadence nulle (N/O, N par défaut) - Facultatif

N Pas d'affichage du message

O Affichage du message

B) Redécoupage pour le libellé :

4 à 6 Code du schéma de calcul

7 L Libellé

8 à 47 Libellé du schéma de calcul. Obligatoire

C) Redécoupage pour le descriptif

4 à 6 Code du schéma de calcul

7 D Descriptif

8 à 60 Descriptif

Seules les 3 premières lignes sont saisies

Utilisé dans les éditions VoluEdit


TSC DPL Envoi de l'opérateur vers Direct Planning

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1

ic_num2

ic_num3


DRC Département de la réclamation

Pas de paramétrage


DRG Dérogations

Pas de paramétrage particulier


DS Dimensions spécifiques

Valeurs numériques

DS N1

Valeur par défaut d'une dimension spécifique apparaissant automatiquement dans la zone formule lors de la saisie de cette dimension spécifique dans le tableau des pointages associé à la fiche FEFCO.

Valeur alpha 1

DS A1[1]

Ce caractère permet d'identifier une dimension spécifique parmi les possibilités suivantes, et ce malgré une codification libre du code paramètre
d Rabat
e Rabat dessus
f Rabat dessous
g Dimension du couvercle
h Dimension du recouvrant
i Dimension du renfort
j Dimension du rentrant
k Taille de la patte de jonctionnement

ATTENTION

Seules ces 8 premières valeurs sont actives au niveau du devis carton ondulé (devis_dco)

S Rabat écourté dessus

T Rabat écourté dessous

U Recouvrant dessus

V Recouvrant dessous


DT Type de signature

Pas de paramétrage. Seul le libellé est utilisé.


EAF Etat d'affaire

Utilisé dans le devis standard.

Pas de paramétrage.


EBM Etat des besoins matières

Valeur alpha 1

EBM A1[1]

Code de correspondance d'état de besoin matière

A A traiter

V Validé

I Ignoré

T Traité


ECA Etat cadencement

Valeur alpha 1

ECA A1[1] | Date obligatoire (O/N, N par défaut)
ECA A1[2] | Effacer la date (O/N, N par défaut)
ECA A1[3] | Motif obligatoire (O/N, N par défaut)

Notes

CODES_MOTIF_ETAT

21,23 Code motif associé à l'état. Les paramètres utilisés sont A1[1] et A1[2].

Saisie de l'état de cadencement de livraison - Sélection de l'état

On ajoute une liste déroulante optionnelle avec les états définis par les paramètres de type ECA.

Si les options de saisie de l'état (MODIF_ETATS_CADENC dans v_cdem) et du motif sont inactives, la fenêtre de choix ne s'ouvre pas et le fonctionnement par défaut reste inchangé.

L'état est obligatoire si l'option de saisie de l'état est activée.

Les états à afficher sont définis par la note LISTE_ETATS_CADENC dans v_cdem. Si cette note est absente ou vide, alors tous les états sont affichés.

Si une date est saisie, elle doit être supérieure ou égale à la date du jour.

Les motifs affichés dépendent de l'état sélectionné (CODES_MOTIF_ETAT ci-dessus).

Si aucun motif ne correspond (pas de paramétrage), alors tous les motifs sont affichés.

La saisie de date est obligatoire : ECA A1[1] ou MQA A1[1] = O

La date peut être effacée : ECA A1[2] ou MQA A1[2] = O

Le paramétrage de l'état est prioritaire sur celui du motif.


ECC Eléments de calcul

Valeur alpha 1

ECC A1[1,3] | Coût supplémentaire associé
ECC A1[4] | Elément de calcul modifiable ? (O/N)

Valeur alpha 2

ECC A2[1,3] | Nature de l'élément NUM Valeur numérique ALP Valeur alpha
ECC A2[4,6] | Type de paramètre si Nature ALP
ECC A2[7,8] | Code calcul pour initialisation automatique (voir ci-dessous)
ECC A2[9,15] | Paramétrage du code calcul Code TSC du centre de coût sur code machine


ECH Codes échéance

Echéances simples Echéances multiples Changement du jour de la facture pour le calcul

Valeurs numériques

ECH N1 | Echéance simple : Nombre de jours à rajouter sur la date de facturation
ECH N2 | Echéance simple : Jour de l'échéance

ATTENTION : Paramétrage des échéances fin de mois

  1. Fin de mois et ajout du nombre de jours en mois - jours. Le jour de l'échéance doit être à 32 et le top fin de mois à blanc.

  2. Fin de mois et ajout du nombre de jours en jours nets. Le jour de l'échéance doit être à 0 et le top fin de mois à F.

  3. Ajout du nombre de jours et fin de mois. Cette méthode est toujours en jours nets. Le jour de l'échéance doit être à 0 et le top fin de mois à f.

Valeur alpha 1

ECH A1[1,2] | Code échéance correspondant en comptabilité MERCUR à 2 caractères numériques
ECH A1[3] | Echéance simple : F pour échéance fin de mois avant ajout du nombre de jours f pour échéance fin de mois après ajout du nombre de jours [blanc] sans fin de mois
ECH A1[4] | Nombre d'échéances. 3 échéances maximum peuvent être paramétrées
ECH A1[5,10] | Echéance 1 :Pourcentage du montant
ECH A1[11,13] | Echéance 1 :Nombre de jours à rajouter sur la date de facturation
ECH A1[14,15] | Echéance 1 :Jour de l'échéance
ECH A1[16] | Echéance 1 : F pour échéance fin de mois avant ajout du nombre de jours f pour échéance fin de mois après ajout du nombre de jours [blanc] sans fin de mois
ECH A1[17,22] | Echéance 2 :Pourcentage du montant
ECH A1[23,25] | Echéance 2 :Nombre de jours à rajouter sur la date de facturation
ECH A1[26,27] | Echéance 2 :Jour de l'échéance
ECH A1[28] | Echéance 2 : F pour échéance fin de mois avant ajout du nombre de jours f pour échéance fin de mois après ajout du nombre de jours [blanc] sans fin de mois
ECH A1[29,34] | Echéance 3 :Pourcentage du montant
ECH A1[35,37] | Echéance 3 :Nombre de jours à rajouter sur la date de facturation
ECH A1[38,39] | Echéance 3 :Jour de l'échéance
ECH A1[40] | Echéance 3 : F pour échéance fin de mois avant ajout du nombre de jours f pour échéance fin de mois après ajout du nombre de jours [blanc] sans fin de mois
ECH A1[41] | Saisie libre de la date d'échéance (O/N, N par défaut)

Valeur alpha 2

ECH A2[1,2] | Jour du changement de mois de la facture
ECH A2[3,4] | Jour du mois suivant de la facture
ECH A2[5] | O indique que le code échéance correspond à une facture de type PROFORMA
ECH A2[6] | Calcul de la date d'échéance en jours nets (O/N, N par défaut) O Calcul en jours nets N Calcul en mois-jours

Valeur alpha 3

ECH A3[1,4] | Nombre de jours à financer (paramétrage spécifique)
ECH A3[5,7] | Code échéance pour transfert en compta

Valeur alpha 4

ECH A4[1,3] | Délai de paiement pour interface SIDE TRADE
ECH A4[4,5] | Fin de mois pour interface SIDE TRADE
ECH A4[6,7] | Réservé
ECH A4[8,10] | Code échéance de remplacement pour les prospects La liste des tiers concernés et la mise à jour de leur code échéance se font par des actions sur le type de paramètre ECH (F13 pour la liste, F14 pour la mise à jour).
ECH A4[11,13] | Code échéance de remplacement pour les clients La liste des tiers concernés et la mise à jour de leur code échéance se font par des actions sur le type de paramètre ECH (F13 pour la liste, F14 pour la mise à jour).
ECH A4[14,16] | Code échéance de remplacement pour les fournisseurs La liste des tiers concernés et la mise à jour de leur code échéance se font par des actions sur le type de paramètre ECH (F13 pour la liste, F14 pour la mise à jour).

Notes

L | 2 à 4 Code Langue 5 à 60 Libellé de l'échéance Voir aussi la note UTILISATION_LANG_CLI dans le #VI.
CODE_ECH_EFFICIAL | 21,24 Numéro de condition de règlement - SPECIFIQUE
ESCOMPTE | 21,22 Taux possible de l'escompte
FAX_MAIL_AR_SUR_ECH | 21 Gestion du fax/mail autorisée pour cette échéance en saisie de commande (O/N, O par défaut) Utilisé dans la saisie de commandes clients pour désactiver la gestion du fax/mail, même si l'option Oxm est positionnée. La même note existe aussi sur le TYC. Pas de hiérarchie.
JOUR_ECH_ | Code échéance avec plusieurs jours d'échéance 10 Numéro de l'échéance (1 à 3) 1 pour l'échéance simple ou la 1ère échéance multiple 2 pour la 2ème échéance multiple 3 pour la 3ème échéance multiple 21,40 Jours de l'échéance (10 maxi) Seules les valeurs 01 à 31 sont autorisées. Mettre 31 pour la fin de mois Les jours de l'échéance doivent être uniques et paramétrés dans l'ordre croissant. Exemple 05101520253031
TRANSCO_SAP | 21,23 Transcodification du Code ECH chez SAP

Exemples

1/3 ECHEANCES SIMPLES

Exemple 1

Echéance 15 jours

Valeur numérique 1 | 15
Valeur numérique 2 | 0
alpha1[3] | [blanc]

Exemple 2

Echéance 30 jours

Valeur numérique 1 | 30
Valeur numérique 2 | 0
alpha1[3] | [blanc]

Exemple 3

Echéance 15 jours le 10

Valeur numérique 1 | 15
Valeur numérique 2 | 10
alpha1[3] | [blanc]

Exemple 4

Echéance 30 jours le 10

Valeur numérique 1 | 30
Valeur numérique 2 | 10
alpha1[3] | [blanc]

Exemple 5

Echéance 15 jours le 10 fin de mois

Valeur numérique 1 | 15
Valeur numérique 2 | 10
alpha1[3] | F

Exemple 6

Echéance 30 jours le 10 fin de mois

Valeur numérique 1 | 30
Valeur numérique 2 | 10
alpha1[3] | F

Exemple 7

Echéance 15 jours fin de mois

Valeur numérique 1 | 15
Valeur numérique 2 | 32
alpha1[3] | [blanc]

Exemple 8

Echéance 30 jours fin de mois

Valeur numérique 1 | 30
Valeur numérique 2 | 32
alpha1[3] | [blanc]

2/3 ECHEANCES MULTIPLES

 |  | échéance 1 | échéance 2 | échéance 3
Pourcentage | format ###.## | 5 à 10 | 17 à 22 | 29 à 34
Nombre de jours | format ### | 11 à 13 | 23 à 25 | 35 à 37
Jour de l'échéance | format ## | 14 à 15 | 26 à 27 | 38 à 39
si fin de mois | F | 16 | 28 | 40

Exemple 1

2 échéances :

60% 15 jours le 10

40% 30 jours le 15

Caractère 4 | 2
Caractères 5 à 10 | 060.00
Caractères 11 à 13 | 015
Caractères 14 à 15 | 10
Caractère 16 | [blanc]
Caractères 17 à 22 | 040.00
Caractères 23 à 25 | 030
Caractères 26 à 27 | 15
Caractère 28 | [blanc]
Caractères 29 à 34 | [blanc]
Caractères 35 à 37 | [blanc]
Caractères 38 à 39 | [blanc]
Caractère 40 | [blanc]

Exemple 2

3 échéances :

50% 15 jours le 10 fin de mois

25% 30 jours le 15 fin de mois

25% 45 jours le 20 fin de mois

Caractère 4 | 3
Caractères 5 à 10 | 050.00
Caractères 11 à 13 | 015
Caractères 14 à 15 | 10
Caractère 16 | F
Caractères 17 à 22 | 025.00
Caractères 23 à 25 | 030
Caractères 26 à 27 | 15
Caractère 28 | F
Caractères 29 à 34 | 025.00
Caractères 35 à 37 | 045
Caractères 38 à 39 | 20
Caractère 40 | F

3/3 CHANGEMENT DU JOUR DE LA FACTURE POUR LE CALCUL

Exemple 1

Passage au 1er du mois suivant à partir du 26 de chaque mois

Caractères 1 à 2 | 26
Caractères 3 à 4 | 01
Si date facture = 15/01/95 | 15/01/95
Si date facture = 26/01/95 | 01/02/95
Si date facture= 28/01/95 | 01/02/95

Exemple 2

Passage au 10 du mois suivant à partir du 20 de chaque mois

Caractères 1 à 2 | 20
Caractères 3 à 4 | 10
Si date facture = 15/01/95 | 15/01/95
Si date facture = 20/01/95 | 10/02/95
Si date facture = 28/01/95 | 10/02/95


ECR Ecran suivant

Valeur alpha 1

ECR A1[1,10] | Nom de la variable écran à atteindre
ECR A1[11] | C écran commande D écran devis (en reliure) O écran carton ondulé X pour le devis onduleur, mette X si on ne veut pas avoir cet écran dans le CTRL-E (Navigation).
ECR A1[12] | F si écran fiche de fabrication (reliure)
ECR A1[13] | O écran accessible en consultation devis (par défaut) Les caractères 11 et 12 sont prioritaires
ECR A1[14] | O écran accessible en consultation fiche de fabrication (par défaut) Les caractères 11 et 12 sont prioritaires

Aide Devis reliure

Écran 1 | bru_1
Écran 2 | bru_2
Écran 3 | bru_3
Écran 4 | bru_4
Écran 5 | bru_5
Écran 6 | bru_6
Écran 7 | bru_7
Écran 8 | bru_8

Aide Fiche de fabrication reliure

Écran 1 | bru_1
Écran 2 | bru_2
Écran 3 | bru_3
Écran 4 | bru_4
Écran 5 | bru_5
Écran 6 | bru_6
Écran 7 | bru_7
Écran 8 | bru_71
Écran 9 | bru_72
Écran 10 | bru_73
Écran 11 | bru_8

Aide Offre de vente

ond_005 | Demande client
ond_020 | Offre
ond_030 | Architecture standard
ond_035 | Architecture B.E
ond_040 | Pointages et options onduleuses
ond_045 | Impression
ond_046 | Pré-impression
ond_047 | Détail des couleurs
ond_048 | Conditionnement
ond_049 | Accessoires
ond_050 | Gamme proposée
ond_060 | Actions de service
ond_070 | Détail action de service
ond_080 | Prix de revient


EDA Etat de l'entête de la demande d'achat

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

EDA A1[1]

Etat de l'entête de la demande d'achat

W attente

T traitée (toutes les lignes ont été passées en commande d'achat)

Dans la même famille :

EDF Etat des lignes fournisseur de la demande d'achat

EDL Etat des lignes de la demande d'achat


EDF Etat des lignes fournisseur de la demande d'achat

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

EDF A1[1]

Etat de la ligne fournisseur de la demande d'achat

W attente

E envoyé (la demande a été envoyée au fournisseur)

R rejeté (le fournisseur n'est pas retenu)

V validé (validation du fournisseur pour génération en commande d'achat)

Dans la même famille :

EDA Etat de l'entête de la demande d'achat

EDL Etat des lignes de la demande d'achat


EDI Statut de la commande par rapport à l'EDI

Ce paramètre est utilisé par G_generer_edi_cde.

Valeur alpha 1

EDI A1[1}

Planifié (donc commande non modifiable) (O/N, N par défaut)

Notes

GESTION_ZONE_LF_EDI

Gestion des zones de la table cdf2

21 Modifiable (O/N

22 Nécessite un retransfert si modifié (O/N)

24,60 Nom de la zone. Les zones autorisées sont les suivantes (par ordre alphabétique) :

lf_adl

lf_adst

lf_affect

lf_cdc

lf_colis

lf_delai_demande

lf_delfou

lf_etatmar

lf_fam

lf_forfait

lf_larg

lf_lib

lf_long

lf_poids

lf_prx

lf_qtecde

lf_qtemar

lf_rem

lf_rgt

lf_sec_ana

lf_sfm

lf_tva

Exemples

GESTION_ZONE_LF_EDI NN lf_long

GESTION_ZONE_LF_EDI NN lf_larg

GESTION_ZONE_LF_EDI OO lf_qtecde

GESTION_ZONE_LF_EDI OO lf_prx

Pour plus de souplesse, la laize et la coupe n'ont pas fait l'objet d'interdiction en dur dans le code.

L'exemple ci-dessus montre comment le gérer (2 premières lignes rendent impossible la modification des deux zones).


EDL Etat des lignes produit de la demande d'achat

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

EDL A1[1]

Etat de la ligne produit de la demande d'achat

W attente

E envoyé (la demande concernant la ligne a été envoyée au(x) fournisseur(s)

T traitée (toutes les lignes ont été passées en commande d'achat)

Dans la même famille :

EDA Etat de l'entête de la demande d'achat

EDF Etat des lignes fournisseur de la demande d'achat


EMB Types d'emballage

Valeurs numériques

EMB N1 | Nombre d'exemplaires par paquet
EMB N2 | Nombre d'exemplaires par caisse

Valeur alpha 1

EMB A1[1,15] | Code étui
EMB A1[16,25] | Valeur de cet emballage

Valeur alpha 2

EMB A2[1,15] | Code film à l'unité
EMB A2[16,30] | Code palette
EMB A2[31,45] | Code paquet
EMB A2[46,60] | Code caisse


EMP Type d'emplacement

Ce paramètre est par le programme lieu_rgt dans le cadre de la gestion des emplacements.

Pas de paramétrage. Seul le libellé est utilisé.


ENC Types d'encollage

Valeur alpha1

ENC A1[1,15]

Code encollage à utiliser. Le code saisi doit figurer dans le fichier des matières.


ENR Sens d'enroulement étiquette

Utilisé par le devis standard, entité étiquettes bobines.

Valeur alpha1

ENR A1[1]

Les étiquettes sont inversées (O/N, N par défaut).

Permet d’indiquer que les étiquettes sont inversées (le format de tirage est inversé par rapport au format fini). Voir schéma ci-dessous.


EPP Etat du planning de production

Ce paramètre est par la note CODE_ETAT_PLANNING dans v_fab1 (GENERO uniquement)

Codes à créer :

NCO Tâche non commencée

TER Tâche terminée

Pas de paramétrage particulier.


ETA Etat d'une offre de vente

Valeur alpha 1

ETA A1[1]

La demande est-elle modifiable (O/N, O par défaut)

On entend par demande le premier écran de l'offre de vente

Remarque

Une demande pouvant regrouper plusieurs offres, il faut que toutes les offres d'une demande soient modifiables pour que la demande soit modifiable.

Autrement dit, si l'une au moins des offres constituant une demande n'est pas modifiable, la demande n'est pas modifiable.


Dans le devis standard, il est possible de paramétrer les codes Etat du devis désirés.

Mais, par héritage des devis feuille et transformateur carton, certains codes états sont figés par les programmes.

Ce développement permet d’associer à chaque état figé par les programmes un code paramètre de type ETD permettant ainsi de voir les valeurs dans les listes de choix proposées en saisie de devis.

ETD Etat du devis

Pour limiter les codes ETD recherchés dans l'affectation par rapport à l'état du devis, le paramètre de lancement du programme concerné peut contenir la note suivante :

_SUP_SQL_RECCODEETD

21,60 Complément de requête sur la table par02 permettant de limiter les codes ETD recherchés dans l'affectation par rapport à l'état du devis

Doit commencer par and.

Valeur alpha 1

ETD A1[1] | Retransfert du devis en commande O Toujours N Jamais C sur confirmation de l'utilisateur (valeur par défaut)
ETD A1[2,4] | Code du type de liaison de l'entête de commande en génération par le devis
ETD A1[5] | Etat du devis figé par les programmes VoluPack associé à ce paramètre. Liste des états figés : A A calculer C Calculé D Devis en cours E Emis F dossier de Fabrication en cours G produits Générés P Passé en commande R Refusé T relance Téléphonique Explications
ETD A1[6] | Inutilisé
ETD A1[7] | Inutilisé
ETD A1[8] | Inutilisé
ETD A1[9] | Inutilisé
ETD A1[10] | Inutilisé
ETD A1[11] | Génération de dossier barème (O/N, N par défaut)
ETD A1[12] | Inutilisé
ETD A1[13] | Inutilisé
ETD A1[14] | Inutilisé
ETD A1[15] | Inutilisé
ETD A1[16] | Inutilisé
ETD A1[17] | Inutilisé
ETD A1[18] | Inutilisé
ETD A1[19] | Génération des besoins matières (O/N, N par défaut)


ETI Etiquettes budget

ETI Etiquettes budget (Environnement budget)

Permet d'identifier le budget mis en œuvre et la répartition des charges mensuelles en fonction du nombre de jours ouvrés.

Exemples

B01 Budget numéro 1

B02 Budget numéro 2

R02 Budget sélectionné

Valeurs numériques

ETI N1 | Coefficient de formule de calcul pour prix matières
ETI N2 | Coefficient de formule de calcul pour prix matières

Le tarif de l'environnement sera calculé de la matière suivante : tarif final = [valeur 1] * tarif + [valeur 2]

Valeur alpha 1

ETI A1[1,3] | Nombre de jours ouvrés de l'année
ETI A1[4,5] | Nombre de jours ouvrés de JANVIER (01)
ETI A1[6,7] | Nombre de jours ouvrés de FÉVRIER (02)
ETI A1[8,9] | Nombre de jours ouvrés de MARS (03)
ETI A1[10,11] | Nombre de jours ouvrés de AVRIL (04)
ETI A1[12,13] | Nombre de jours ouvrés de MAI (05)
ETI A1[14,15] | Nombre de jours ouvrés de JUIN (06)
ETI A1[16,17] | Nombre de jours ouvrés de JUILLET (07)
ETI A1[18,19] | Nombre de jours ouvrés de AOÛT (08)
ETI A1[20,21] | Nombre de jours ouvrés de SEPTEMBRE (09)
ETI A1[22,23] | Nombre de jours ouvrés de OCTOBRE (10)
ETI A1[24,25] | Nombre de jours ouvrés de NOVEMBRE (11)
ETI A1[26,27] | Nombre de jours ouvrés de DÉCEMBRE (12)

Exemple

En saisie d'un centre de coût, il suffit de saisir le mois de JANVIER (01), puis d'utiliser la touche F9 qui permet de répartir les charges sur les autres mois de la manière suivante :

Charge prévue du mois m

Charge prévue du mois de JANVIER *

Nombre de jours ouvrés du mois m /

Nombre de jours ouvrés du mois de JANVIER

Valeur alpha 2

ETI A2[1,3]

Environnement de substitution. Lors du calcul d'un coût de cession, si un tarif n'est pas trouvé dans l'environnement de recherche, une seconde recherche est effectuée dans cet environnement de substitution.

Exemple d'emploi : Devis carton ondulé ou module de gestion des qualités carton.

Une valorisation peut être réalisée dans un environnement donné, comme par exemple l'environnement SIM, dédié à la simulation. Hors tous les tarifs des matières ne sont pas nécessairement renseignés dans cet environnement, mais le sont sans doute dans un environnement DEV (Devis).

Aussi paramètre t-on DEV dans cette zone pour la fiche paramètre ETI SIM.

ETI A2[4,6]

Environnement de substitution. Lors de la recherche d'un taux horaire associé à un centre de coût, si un taux n'est pas trouvé dans l'environnement de recherche, une seconde recherche est effectuée dans cet environnement de substitution.

ETI A2[7,9]

Spécifique :

Admission Temporaire. ETI/AT A2[7,9] = AR.0 L'environnement AT est associé à l'environnement réel AR.

Consommation Locale. ETI/CL A2[7,9] = CR. L'environnement CL est associé à l'environnement réel CR.

ETI A2[10,12]

Environnement réel associé à l'environnement courant pour le calcul du récapitulatif des coûts (correspond à un paramètre de type ETI)

Notes

PARAM_TARIF_DE

En création de tarif lors de la saisie de réponse client dans le devis onduleur, alimenter la zone commentaire de la table tarif en fonction de la date d'application du tarif

16,25 Date d'application JJ/MM/YYYY

26,60 Commentaire

PARTIE_ENTIERE_QTE

21 Recherche du prix de cession avec la partie entière (sans arrondi) de la quantité (Blanc/N/O, N par défaut)

Dans le cadre du devis onduleur, possibilité de rechercher le prix de cession avec la partie entière (sans arrondi) de la quantité.

Le paramétrage peut être activé pour des environnements donnés (paramètre ETI) ou pour tous les environnements (paramètre #CF ATL).

Le paramétrage sur ETI est prioritaire au paramétrage sur #CF ATL.

Si la note sur le paramètre ETI est absente, la fonction recherchera la note sur le paramètre #CF ATL.

Si la note sur le paramètre ETI est présente, la fonction ne recherchera pas la note sur le paramètre #CF ATL quelle que soit la valeur paramétrée (Blanc, N ou O) sur le paramètre ETI.


ETP Etape de visite

Utilisé entre autres dans prospect.

Valeur alpha1

ETP A1[15,17]

Le code est un code de type USE.

Les personnes gérant un événement seront présélectionnées en fonction des paramétrages d'événements et d'étapes.

Si une personne est renseignée pour l'événement ainsi que pour l'étape, l'événement est prioritaire.

Le code de la personne n'est mis à jour que si un paramètre correspondant est trouvé.

Le même paramétrage existe dans EVT.

ETP A1[18,20]

Code groupe de type GRU

Le code groupe contient une liste d'utilisateurs (USE) ayant la permission de modifier/supprimer une ligne du tableau. Cela nécessite l'activation en A2[5] et A2[6] de #CF/EVT.

Voir : Gestion des actions événements depuis le devis onduleur.


ETT Environnement des tarifs des transporteurs

Ce paramètre est utilisé par

exped_affretements A2[18,20]

interface_prefac A2[16,18]

#CF LOG A1[31]

Seul le libellé est utilisé. Il n'y a pas de paramétrage.


ETV Etat du véhicule

Ce paramètre est utilisé par le programme vehicules.

Valeur alpha 1

ETV A1[1]

Disponibilité du véhicule (O/N, O par défaut)


EVI Environnement d'inventaire

Valeur alpha 1

EVI A1[1]

Type de commande de l'environnement

C Commande client (par défaut)

F Commande fournisseur

EVI A1[2,4]

Type de contrôle de saisie du lot

blanc : pas de contrôle (par défaut)

CDE : contrôle du lot sur les commandes client

CDF : contrôle du lot sur les commandes fournisseur

La saisie du lot peut être contrôlée, soit par rapport aux commandes client, soit par rapport aux commandes fournisseur. Il est nécessaire que le TYF et/ou le TYC en A3[31] = L.

EVI A1[5]

Type d'inventaire

A (ou vide) mode par défaut. Inventaire des matières sauf des bobines

B permet de faire l'inventaire des bobines

La saisie d'inventaire par bordereau permet de faire un état des lieux des stocks physique par rapport aux stocks théoriques (saisie informatique).

Soit il y a une différence en plus ou en moins, soit il y en a pas.

La saisie d'inventaire par bordereau fonctionne maintenant pour les bobines.

Le nouveau paramétrage au niveau de l'environnement (Type paramètre EVI), permet de faire l'inventaire des stocks bobines. De plus l'écran de saisie des bordereaux a évolué.

Remarque : Si par défaut la saisie d'inventaire est géré par lot et si les anciennes bobines ne l'étaient pas, alors dans le champ lot, l'utilisateur devra saisir #.

Nota : Si l'environnement est en mode bobine, les saisies se font en Kg (poids de la bobine).

EVI A1[6]

Gestion de stock à la palette (prioritaire sur l'option –Opa sur programme inventaire)

O Oui

N Non (par défaut)

<vide> Prise en compte de l'option –Opa sur programme inventaire.

Valeur alpha 2

EVI A2[1] | Lieu de rangement 1 par défaut proposé en saisie Si non renseigné, le lieu de rangement 1 proposé est celui de l'article.
EVI A2[2] | Lieu de rangement 2 par défaut proposé en saisie Si non renseigné, le lieu de rangement 2 proposé est celui de l'article
EVI A2[3] | Lieu de rangement 3 par défaut proposé en saisie Si non renseigné, le lieu de rangement 3 proposé est celui de l'article.

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes paramétrées sur EVI sont prioritaires sur celles du programme de saisie d'inventaire par bordereau.

Voir aussi EVI A1[6].

Autres notes

C | 3,60 Complément de sélection sur les tables conteneur_info et conteneur_produit
L | 2,60 Complément de requête obligatoire sur la table stk_lot_lieu (si option Otl) Exemple L and sl_rgt1 = 'USI'
M | 3,60 Complément de sélection sur la table mat - Obligatoire pour la phase GTE Exemple M and mp_fam = "PAP"
0 (chiffre zéro) | 3,60 Complément de sélection sur la table stk0 - Obligatoire pour la phase GTE Exemple 0 and s0_rgt1 = "USI"


EVT Evénement

Valeur alpha1

EVT A1[1]

Ouverture de la fiche visite (O/N)

EVT A1[2]

Ouverture de la saisie de commande (O/N)

EVT A1[3]

Lance la saisie du devis (O/N)

EVT A1[4]

Saisie obligatoire des affaires en création d'action

EVT A1[5]

Valeur par défaut de la zone Interne/Externe (I/E) (action_evt.ace_int_ext)

EVT A1[6]

Saisie obligatoire de la zone Menée par (O/N, N par défaut)

EVT A1[7]

Saisie obligatoire de la zone Qualificatif de l'état (O/N, N par défaut)

EVT A1[8,10]

Valeur par défaut de la zone Qualificatif de l'état (action_evt.ace_qual) type QAF

EVT A1[11]

Ouverture automatique de la saisie de note

EVT A1[12]

Ouverture automatique de la saisie des TSC

EVT A1[13]

Valeur par défaut de la zone Priorité (action_evt.ace_prio)

1 Faible

2 Normale

3 Elevée

EVT A1[14]

Valeur par défaut de la zone Etat (action_evt.ace_etat)

A A faire

E En cours

T Terminée

X Abandonnée

EVT A1[15,17]

Le code est un code de type USE.

Les personnes gérant un événement seront présélectionnées en fonction des paramétrages d'événements et d'étapes.

Si une personne est renseignée pour l'événement ainsi que pour l'étape, l'événement est prioritaire.

Le code de la personne n'est mis à jour que si un paramètre correspondant est trouvé.

Le même paramétrage existe dans ETP.

EVT A1[18,20]

Code groupe de type GRU

Le code groupe contient une liste d'utilisateurs (USE) ayant la permission de modifier/supprimer une ligne du tableau.

Cela nécessite l'activation en A2[5] et A2[6] de #CF/EVT.

Voir : Gestion des actions événements depuis le devis onduleur.

Valeur alpha 3

EVT A3[1,60]

Objet ou commentaire de l'événement

Voir : Gestion des actions événements depuis le devis onduleur.

Valeur alpha 4

EVT A4[1,3]

Lance un programme WINDOWS dont le nom est spécifié dans la zone document des actions.

*** A VERIFIER ***

Notes

-C | 3,60 Liste des codes NTS accessibles en saisie de notes pour les actions Exemple 3CLI2QA
-D | 6,60 Liste des TIC accessibles en saisie de TSC

Les paramètres inscrits sur fond jaune pâle ont été définis pour la gestion des actions, événements , dans le #CF EVT.


EXO Mode d'exonération

Valeur alpha 1

EXO A1[1] | Code catégorie de vente lorsque le pays du taux de TVA est identique au pays de la société. Le pays du taux de TVA est paramétré en alpha3[41,43] du code TVA.
EXO A1[2] | Code catégorie de vente lorsque le pays du taux de TVA est différent du pays de la société. Le pays du taux de TVA est paramétré en alpha3[41,43] du code TVA.
EXO A1[3,4] | Mode d'exonération Correspondance utilisée pour le transfert des tiers JDE. La valeur est obligatoire mais non contrôlée.
EXO A1[5,14] | Taux du mode d'exonération Correspondance utilisée pour le transfert des tiers JDE. La valeur est obligatoire mais non contrôlée.
EXO A1[15,19] | Sous-compte

Notes

TAUX_MODE_EXO_

15, 17 Code agrément du fournisseur

20, 29 Taux du mode d'exonération des fournisseur

Correspondance utilisée pour le transfert des tiers JDE.

La valeur est obligatoire mais non contrôlée.


F1E Code frais de 1er établissement

Valeur alpha 1

F1E A1[1] | Spécifique Les frais de premier établissement sont-ils générés automatiquement ? (O/N)
F1E A1[2,4] | Spécifique Code du TSC où se trouve stockée la valeur des frais de premier établissement correspondant.
F1E A1[5] | Spécifique Code de la zone du TSC C ic_num1 D ic_num2 E ic_num3 G ic_char_30
F1E A1[6] | Spécifique Code article du TSC X Produit fini


FAB Codes fabricants

FAB / SUI Fabricant / Suivi d'affaire

Il est nécessaire de recopier les codes FAB en codes SUI pour le devis standard (gestion des affaires).

Valeur alpha 1

FAB A1[1]

Filtre de recherche sur le type de fabricant (devis Multi-Métiers) :

F Fabricant

S Suivi d'affaire

[espace] Les deux

Valeur alpha 2

FAB A2[1,30] | Numéro de téléphone (+ poste etc.)
FAB A2[31,60] | Numéro de fax

Valeur alpha 3

FAB A3[1,40]

Adresse email du suivi d'affaire

Valeur alpha 4

FAB A4[1,15] | Code assistante commerciale Sur 15 caractères pour interface SIDE TRADE Sur 2 caractères pour interface EFFICIAL
FAB A4[16,18] | Site - Tableau de bord du multisite

Notes

ATR_xxxxxxxxx

Notes commençant par ATR, pour la gestion de l'outillage

Voir le paramétrage de ces 7 notes dans le paramètre de type USE.


FAC Codes faction

Les codes sont figés à

1 | Journée
2 | Matin
3 | Après-midi
4 | Nuit

Valeur alpha 1

Plage de temps autorisée (contrôle en saisie de temps si paramétré)

FAC A1[1,4] | Heure de début (en heures/minutes, exemple 0745)
FAC A1[5,8] | Heure de fin (en heures/minutes, exemple 2300)
FAC A1[9] | Plage de nuit O/N (N par défaut)

Valeur alpha 2

Plages automatiques de temps utilisées dans la génération automatique de l'activité prévisionnelle.

Elles sont définies par tranche de 15 caractères comme suit

FAC A2[1,4] | Plage 1 Heure de début (en heures/minutes, exemple 0745)
FAC A2[5,8] | Plage 1 Heure de fin (en heures/minutes, exemple 1830)
FAC A2[9,15] | Inutilisés
FAC A2[16,19] | Plage 2 Heure de début (en heures/minutes, exemple 0745)
FAC A2[20,23] | Plage 2 Heure de fin (en heures/minutes, exemple 1830)
FAC A2[24,30] | Inutilisés
FAC A2[31,34] | Plage 3 Heure de début (en heures/minutes, exemple 0745)
FAC A2[35,38] | Plage 3 Heure de fin (en heures/minutes, exemple 1830)
FAC A2[39,45] | Inutilisés
FAC A2[46,49] | Plage 4 Heure de début (en heures/minutes, exemple 0745)
FAC A2[50,53] | Plage 4 Heure de fin (en heures/minutes, exemple 1830)
FAC A2[54,60] | Inutilisés

Valeur alpha 3

Plages automatiques de temps utilisées dans la génération automatique de l'activité prévisionnelle.

Elles sont définies par tranche de 15 caractères comme suit

FAC A3[1,4] | Plage 5 Heure de début (en heures/minutes, exemple 0745)
FAC A3[5,8] | Plage 5 Heure de fin (en heures/minutes, exemple 1830)
FAC A3[9,15] | Inutilisés
FAC A3[16,19] | Plage 6 Heure de début (en heures/minutes, exemple 0745)
FAC A3[20,23] | Plage 6 Heure de fin (en heures/minutes, exemple 1830)
FAC A3[24,30] | Inutilisés
FAC A3[31,34] | Plage 7 Heure de début (en heures/minutes, exemple 0745)
FAC A3[35,38] | Plage 7 Heure de fin (en heures/minutes, exemple 1830)
FAC A3[39,45] | Inutilisés
FAC A3[46,49] | Plage 8 Heure de début (en heures/minutes, exemple 0745)
FAC A3[50,53] | Plage 8 Heure de fin (en heures/minutes, exemple 1830)
FAC A3[54,60] | Inutilisés


FAM familles

Valeurs numériques

FAM N1 | Numéro de zone historique pour le prix de revient (utilisation spécifique GRE). à une famille est associée la colonne historique. Numéro d'ordre d'apparition des familles dans le prix de revient (SPI).
FAM N2 | Pourcentage de frais sur vente pris en compte dans le calcul d'encours (en_co A2 contient n, q, ou s)

Valeur alpha 1

FAM A1[1,8] | Code comptable VENTE France pour transfert en comptabilité (classe 7)
FAM A1[9,16] | Code comptable VENTE export pour transfert en comptabilité (classe 7)
FAM A1[17] | Code formules de traitement et d'affichage pour l'état comparaison matières
FAM A1[18,25] | Code comptable VENTE suspension de TVA pour transfert en comptabilité (classe 7)
FAM A1[26,33] | Code comptable VENTE intracommunautaire pour transfert en comptabilité (classe 7)
FAM A1[34,41] | Code comptable VENTE exonérée pour transfert en comptabilité (classe 7)
FAM A1[42,44] | Nature de difficulté de la famille (pas de valeur par défaut) La nature de difficulté de la sous-famille est prioritaire sur cette valeur. Voir aussi VER A1[18,20]
FAM A1[45] | On ne tient pas compte de la consommation matière lors du contrôle d'annulation de la ligne de commande (O/N, N par défaut)
FAM A1[46,48] | Type de cadencement de fabrication de la famille. Voir TCF A2[30,33]
FAM A1[49] | Type de valorisation du stock physique du module de mise à jour de la table stk_lot_lieu A Prix d'achat de la fiche article L Prix de vente du lot (par défaut)

Valeur alpha 2

FAM A2[1,3] | Code département produit du code famille (analyse du carnet de commandes)
FAM A2[4,6] | Code formule de conversion Si cette zone est renseignée, alors on proposera cette formule de conversion par défaut pour les articles d'une même famille.
FAM A2[7,9] | Code groupement matière du code famille Ce code permet de faire des regroupements de famille pour sortir un état de comparaison matière. Exemple : Si vous désirez regrouper les familles acier et fer codifiées ACI et FER dans un groupe de famille codifiée 1, alors vous saisirez le code 1 dans la valeur alpha 2 caractère 7,9.
FAM A2[10,12] | Code formule de calcul pour devis mécanique
FAM A2[13,27] | Code douanier pour la famille Avec le découpage suivant (idem dans les notes SFM _CODE_DOUANIER) 13,25 code nomenclature douanière 26,27 code catégorie produit pour DEB
FAM A2[28,35] | Code comptable ACHAT France pour transfert en comptabilité (classe 6)
FAM A2[36,43] | Code comptable ACHAT export pour transfert en comptabilité (classe 6)
FAM A2[44,51] | Code comptable ACHAT suspension de TVA pour transfert en comptabilité (classe 6)
FAM A2[52,59] | Code comptable ACHAT intracommunautaire pour transfert en comptabilité (classe 6)
FAM A2[60] | Gestion à la surface pour la famille (O/N, N par défaut)

Valeur alpha 3

FAM A3[1] | Le poids s'applique au niveau : D département (par défaut) N national
FAM A3[2] | Le coefficient de colisage s'applique au niveau : D département (par défaut) N national
FAM A3[3] | La famille concerne : A les almanachs (par défaut) D les articles divers
FAM A3[4,7] | Indice de volume Indique le nombre d'almanachs contenus dans une case
FAM A3[8,9] | Numéro d'ordre dans la saisie des commandes (Exemple 01, 02, etc.)
FAM A3[10,13] | Section analytique d'achat
FAM A3[14,21] | Code comptable ACHAT exonéré pour transfert en comptabilité (classe 6)
FAM A3[22,30] | Code opération consommateur des matières de cette famille. Est utilisé dans le calcul d'encours pour les matières en remontée automatique afin de ne comptabiliser qu'une partie du coût matière en fonction de l'état d'avancement de l'opération consommatrice.
FAM A3[31,32] | Code sur 2 caractères pour le transfert vers PC-Topp (Zone OT-DATA 009 Offset VoluPack [71,73])
FAM A3[33] | Indicateur permettant de définir si cette famille de matière doit être classée dans une colonne spécifique dans le calcul d'encours (O/N) Exemple : La famille PAP (papier) est cumulée dans une colonne spécifique de l'encours.
FAM A3[34] | Indicateur permettant d'exclure cette famille pour le calcul du tonnage (zone qte_ua2) dans la visualisation des articles. Valeurs possibles O (valeur par défaut) Alimentation de la zone N pas d'alimentation de la zone
FAM A3[35,37] | Code de ventilation pour les familles
FAM A3[38] | O Ouvre la fenêtre de saisie des quantité dans la saisie des stocks N Saisie normale de la quantité dans la saisie des stocks (défaut)
FAM A3[39] | O La ligne de facture correspondante au produit de cette famille ne sera pas imprimée N La ligne de facture sera imprimée (défaut)
FAM A3[40,42] | Code tarif utilisé lors de la création automatique de tarifs sur ligne de commande Le paramétrage de la création de tarif sur la ligne de commande est en #CF TAR alpha3[1,58]. (option -Ota sur la saisie des commandes)
FAM A3[43] | Famille type de consommables génériques (O/N, N par défaut)
FAM A3[44] | Saisie obligatoire des dimensions sur l'écran des consommables (O/N, N par défaut)
FAM A3[45] | Saisie obligatoire de la quantité sur l'écran des consommables (O/N, N par défaut)
FAM A3[46] | Saisie obligatoire du pourcentage du poids sur l'écran des consommables (O/N, N par défaut)
FAM A3[47] | Poids du consommable à intégrer dans le poids du PF (O/N, N par défaut)
FAM A3[48] | Gestion à la bobine (O/N, N par défaut)
FAM A3[49] | La laize optimale est stockée dans le lieu de rangement 2 du mouvement de stock prévisionnel (O/N, N par défaut)
FAM A3[50] | Saisie de la hauteur pour les consommables appartenant à la famille (O/N, N par défaut) Si O, les caractères alpha3[44] et alpha[45] doivent eux aussi être à O.
FAM A3[51,52] | Correspondance Unité de mesure de la quantité (JDE)
FAM A3[53,54] | Correspondance Unité de mesure de la quantité (JDE)
FAM A3[55] | Type d'outil pour l'interface AVDATA S Cliché (par défaut) (anciennement C) T Forme (anciennement F)
FAM A3[56] | Cette famille permet-elle la gestion de l'EDI ? (O/N, O par défaut) Utilisé par G_generer_edi_cde
FAM A3[57] | Prise en compte du nombre de poses pour cette famille de produit d'entité Utilisé dans l_gdf O On prend en compte le nombre de poses d'entité. N On ne prend pas en compte le nombre de poses d'entité (par défaut).
FAM A3[58] | Ordre de fabrication à transférer vers le système de planification (O/N, O par défaut)
FAM A3[59] | Permettre l'intégration des produits finis génériques du devis multi-métiers pour cette famille (O/N, N par défaut) En résumé, un produit fini peut donc être intégré si : • il n'est pas générique • il a un code famille autorisant l'intégration

Valeur alpha 4

FAM A4[1,8] | Sur-famille
FAM A4[9,11] | Sur-famille pour la visu des statistiques clients
FAM A4[12] | Indique si la famille doit être prise en compte dans le cas des statistiques facturation (statistiques filiales) (O/N)
FAM A4[13] | Indique si la famille doit être prise en compte dans les quantités des statistiques facturation (statistiques filiales) (O/N)
FAM A4[14,23] | Types d'article autorisés pour cette famille M Matière P Produit fini S Semi-fini F Fourniture X Fantôme O Outils T Maintenance K Kit Q Qualité Ne rien mettre si tous les types sont autorisés.
FAM A4[24] | Saisie des commandes fournisseurs La donnée Largeur est-elle obligatoire ? (Laize pour la gestion des bobines)
FAM A4[25] | Edition des commandes fournisseurs Impression des données cahier des charges (O/N)
FAM A4[26] | Edition des commandes fournisseurs Impression des données spécificité technique (O/N)
FAM A4[27,29] | Code lot par défaut (saisie des commandes almanachs)
FAM A4[30,35] | Code section analytique pour transfert en comptabilité (pour compta VALC, ne prend en compte que les 3 premiers caractères)
FAM A4[36,38] | Nature de produit (utilisé dans devis)
FAM A4[39] | Famille hiérarchique N Non hiérarchique (par défaut) H Hiérarchique avec sous-famille
FAM A4[40] | Type famille papier (devis imprimerie) F Papier feuille R Papier roto / bobine K Papier cameron C Carton [blanc] Si pas papier ou carton
FAM A4[41,43] | Code famille de regroupement utilisable pour le flash journalier
FAM A4[44] | Type d'article (utilisé dans le transfert SYLOGI) C Carton ondulé P Carton plat A Plastique
FAM A4[45,47] | Code famille de regroupement des libellés
FAM A4[48,50] | Niveau de regroupement du coût (Type de paramètre NCC) Par défaut : DEF Utilisé pour le paramétrage du type de coût et du niveau de regroupement sur les familles/sous-famille du produit pour les coûts matières.
FAM A4[51] | Type de coût F Fixe V Variable A Autres (par défaut) Utilisé pour le paramétrage du type de coût et du niveau de regroupement sur les familles/sous-famille du produit pour les coûts matières.
FAM A4[52] | Code statistique 1 saisissable (O/N, N par défaut)
FAM A4[53] | Code statistique 2 saisissable (O/N, N par défaut)
FAM A4[54] | Code statistique 3 saisissable (O/N, N par défaut)
FAM A4[55] | Code statistique 4 saisissable (O/N, N par défaut)
FAM A4[56] | Mode de codification des matières / outils 1 Suppression des 5 derniers caractères 2 Codification automatique : notes commençant par CODIF_ART
FAM A4[57] | Famille de papier basculable (O/N, O par défaut)
FAM A4[58] | Type de papier utilisé pour la couverture cartonnée (TMC CVC) N Normal (par défaut) P Plein papier pelliculé T Toile
FAM A4[59] | Type négoce (O/N, N par défaut) Utilisé dans G_prep_affret Pour les articles de type négoce (qui n'ont pas de TBDATA), on récupère la date de fin de fabrication pour alimenter la date de disponibilité.
FAM A4[60] | Recherche de l'OF sur la famille de l'article consommé (O/N) N Pas de recherche de l'OF sur la famille de l'article consommé (Valeur par défaut) O Recherche de l'OF sur la famille de l'article consommé Utilisé dans G_v_stk0

Il y a plusieurs catégories de notes. Faites défiler l'écran pour les voir toutes.

ATTENTION : certaines notes ont été regroupées lorsqu'elles font partie d'une même entité logique : elles apparaissent dans des tableaux séparés.

Les autres notes figurent dans le tableau général des notes, après ces tableaux.

Notes pour l'optimisation du conditionnement dans le devis onduleur

FAM_RECH_COND

21,23 Code famille à utiliser pour rechercher les valeurs utilisées pour la détermination du conditionnement

Les valeurs utilisées pour la détermination du conditionnement peuvent être paramétrées sur la famille du semi-fini.

On peut aussi les déporter sur une autre famille par le biais de cette note.

DEPASSEMENTLARGEUR

DEPASSEMENTLONGUEUR

FORMATPALETTE

FORMATPALPLAQUE

HAUTEURMAXPALETTE

HAUTEURPALCARREE

HAUTEURPALETTE

HPALCARTONNIER

NBMAXPILES

NPALETTES

RETRAITLARGEURMAX

RETRAITLONGUEURMAX

Ces notes et leur hiérarchie de recherche sont décrites dans l'aide du don,

au paragraphe Optimisation du conditionnement dans le devis onduleur.

Notes triées

[sur 3 caractères]

4 à 60 Ligne de note à afficher

Est recherché sur SFM avant d'être recherché sur FAM.

Le mot-clé de cette note est paramétré dans cde sur la note TYPE_NOTE_ART_AFF.

Caractères 1 à 60

Notes sur la famille de l'article à imprimer au bas de la commande fournisseur.

Seules les deux premières lignes sont imprimées.

Fonctionne si l'option Ora (oex) est activée.

ALTAI_ANL_cccsss

Pour le transfert des factures de ventes vers la comptabilité ALTAI

Le code société doit être à 2. Voir aussi #CF TRF

ccc = Code catégorie du client

sss = Sous-famille

21,35 Code analytique. Si la sous-famille est à blanc, le code analytique s'applique à toutes les sous-familles non paramétrées pour cette catégorie.

ANA_SAGE_100

Paramétrage de la ventilation analytique COMPTABILITE SAGE 100 (interface N° 2)

21,23 Code sous-famille (si sous famille non renseignée, analytique sur la famille)

24,25 Numéro de plan analytique SAGE (1 à 10)

26,38 Code section analytique SAGE

ARRONDI_QTE_CDE

21 Méthode d'arrondi pour le calcul de la quantité commandée des articles nomenclaturés

S Arrondi à l'entier supérieur

P Arrondi au plus proche (par défaut)

BORNES_DONNEE_TEC_

Contrôles des valeurs saisies par rapport à des bornes minimum/maximum

19 Numéro de donnée technique (1 à 4)

21,30 Valeur minimum (999999.999)

32,41 Valeur maximum (999999.999)

Ce fonctionnement est valable pour les programmes suivants

Saisie des commandes d'achat (cdef)

Saisie des inventaires (inventaire)

Saisie des devis multi-métiers (devis_standard)

Saisie des matières (mat)

Visualisation des besoins matières (v_cde_5)

Le paramétrage de contrôle sera recherché dans l'ordre suivant

1. Famille de la qualité matière

2. Type de commande d'achat (saisie des commandes d'achat uniquement)

3. Paramètre de lancement du programme

#CC

Contrôle des champs dans la fiche article

CODE_FAM_EFFICIAL

21,23 Code désignation avant assemblage - SPECIFIQUE

CODE_QUALITE_DEVIS

21,23 Code qualité pour initialiser le code qualité des écrans d'architecture

La même note existe sur le paramètre TES (Type d'estampille).

Sur écran Architecture, renseigner automatiquement la zone Code qualité :

1° En fonction de la famille de l'ensemble saisi sur l'écran OFFRE :

- Le code qualité sera paramétré sur le paramètre FAM (contrôle d'existence à faire).

- L'automatisme ne devra être déclenché QUE si le code qualité n'est pas déjà renseigné.

2° en fonction du type d'estampille saisi sur l'écran architecture :

- Le code qualité sera paramétré sur le type d'estampille (contrôle d'existence à faire).

- L'automatisme ne devra être déclenché QUE si le code qualité n'est pas déjà renseigné

Le code qualité est obligatoire. Ne faire l'initialisation que si le code est à N Indifférent (que l'on soit en création ou modification d'architecture (étudiée ou automatique))

CODE_QUALITE_INTER

21,23 Code normalisé (format Gondardennes pour generer_edi_cde)

CODE_RGRP_BL_EXPED

21,23 Code regroupement BL

Cette note est recherchée en priorité :

sur la sous-famille hiérarchique rattachée à la famille (touche F6)

sur la famille elle-même

CODE_T023_EFFICIAL

21,29 Code équivalent T023 alimente la zone 6 du fichier 01

CODE_T025_EFFICIAL

21,24 Code équivalent T025 alimente la zone 23 du fichier 02

CODE_T134_EFFICIAL

21,24 Code équivalent T134 alimente la zone 3 du fichier 01 et du fichier 02

CODIF_ART*

Saisie simplifiée d'articles

CODIFICATION_ART_99

21,22 Code pour la codification de l'article de fabrication

Obligatoire si le devis onduleur utilise la méthode 7 (A2[26] = 7) pour la codification des articles.

_COEFF_MUL_PR_

21,26 Coefficient multiplicateur à appliquer sur le prix de cession dans le PR-MIDATA

Utilisé dans G_pr_midata

COL_ART*

Saisie simplifiée d'articles

COMPTE_ACHAT_SAGE

21,60 Compte d'achat. Facultatif

Utilisé par G_tr_stock_sage

COMPTE_BRC

Paramétrage du compte de vente pour les bons de réception

Bons de réception : voir la page récapitulative dans le #CF TFB

21,28 Compte de vente France

29,36 Compte de vente Export

37,44 Compte de vente Suspension de taxe

45,52 Compte de vente Intra-communautaire

53,60 Compte de vente Exonéré

COMPTE_CONSO_SAGE

21,60 Compte de consommation. Facultatif

Utilisé par G_tr_stock_sage

COMPTE_STOCK_SAGE

21,60 Compte de stockage. Facultatif

Utilisé par G_tr_stock_sage

_COMPTE_VENTE_AVO

Paramétrage du compte de vente pour les avoirs.

Pour l'ordre de recherche du compte de vente pour les avoirs, voir cette page

_COMPTE_VENTE_GROUPE

Dans la fonction de recherche du compte de vente, ajout de la recherche si le client est Groupe.

Ce paramétrage est effectif sur les paramètres CS1, CS2, CS3, CS4, SFM et FAM.

21,28 Compte de vente France

29,36 Compte de vente Export

37,44 Compte de Vente Suspension de Taxe

45,52 Compte de Vente Intracommunautaire

53,60 Compte de vente Exonéré

CORRES_IMPORT_MAT

Correspondance pour limportation des articles

Exemple pour la famille PAP : CORRES_IMPORT_MAT PAPI

CPT_ACHAT_GPE_

15,20 Code Groupe de fournisseur (champ cl_cligr de la fiche fournisseur)

21,28 Compte d'achat France

29,36 Compte d'achat Export

37,44 Compte d'achat Suspension de taxe

45,52 Compte d'achat Intracommunautaire

53,60 Compte d'achat exonéré

CPT_ESC_ACHAT

21,28 Numéro de compte d'escompte pour le transfert en comptabilité des lignes d'escompte des factures d'achat

Utilisé dans G_tr_fac_fou

Par défaut, le compte d'escompte est paramétré dans #CF TFF A1[33,40].

Maintenant, il peut être paramétré ici pour la famille de la ligne de commande de la 1ère ligne de la facture.

Si le compte d'escompte n'est pas paramétré sur la famille, c'est le compte d'escompte paramétré sur le paramètre de configuration qui est utilisé.

RAPPEL

Si l'option Ose est activée, l'escompte n'est pas comptabilisé séparément, mais déduit du montant HT.

Si l'option Oee est activée, un delta est ajouté au compte d'escompte.

Ce delta dépend du mode de taxation (Taxable, Export, Intracommunautaire, Suspension ou Exonération).

CTRL_CODE_CS_n

où n représente le code statistique (1 à 4)

21 Code statistique CSn obligatoire (O/N, N par défaut)

Plus d'explications dans la même note au niveau du TYC.

DN_INFO*

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Colonnes à afficher dans le tableau des informations d'article

Chacun des 4 champs doit être suivi d'un astérisque

1) Libellé de la rubrique

2) Zones possibles

mp_* : Toutes les zones de mat

TSC_[CodeTSC]_[ZoneTSC]

le_libpar1 : Référence client

le_libelle : Libellé spécifique 1

le_libelle2 : Libellé spécifique 2

3) Format (using)

4) Code langue à employer

Ce paramétrage est recherché dans l'ordre de priorité suivant :

Famille/Sous-famille

Famille

Paramètre de lancement

FAM

FAMF6

FAMF8

FAMF12

FAMF20

FAMF24

FAMF26

FAMF34

Ouverture automatique de fenêtres lors de la saisie de la fiche matière

4,6 Touche de fonction à simuler. Les touches suivantes sont possibles :

F6 - F8 - F12 - F20 - F24 - F26 - F34

7 Condition d'ouverture

O Ouverture automatique de la fenêtre dans tous les cas

C Ouverture automatique de la fenêtre en création seulement

Exemples

FAMF6 O : la fenêtre que l'on ouvre en faisant F6 s'ouvrira automatiquement dans tous les cas.

FAMF24C : la fenêtre que l'on ouvre en faisant F24 s'ouvrira en création uniquement.

FAM_ET_SFM_VAL

Ne pas valoriser certaines actions de service selon la famille/sous-famille commerciale

Paramètre utilisé dans :

- Devis onduleur (don)

- Génération des OF (gdf_don)

21,23 Code famille commerciale

24,26 Code sous-famille commerciale

L’action de service ne sera pas valorisée dans le calcul du devis et/ou en (ré) génération du dossier si la famille et sous-famille commerciale correspondent au paramétrage.

Exemples

Action non valorisée pour la famille et sous-famille suivante :

FAM_ET_SFM_VAL 714714

Action non valorisée pour la famille suivante :

FAM_ET_SFM_VAL 712

FORMAT_QUANTITE

21,60 Format numérique à appliquer aux zones de quantité :

- de la visualisation des stocks disponibles

- de la visualisation des stocks lots/lieux

GENERER_EDI_ORDERS

21,26 Type et code du paramètre de lancement du programme de génération des messages EDI de commandes d'achat (ORDERS)

Le but est de pouvoir mettre un autre paramètre de lancement pour la génération des messages EDI.

Par défaut, le paramètre est #TR ORD.

Si la note GENERER_EDI_ORDERS est paramétrée dans une famille et que la première ligne de la commande est cette famille, alors on prend en compte la note GENERER_EDI_ORDERS.

LIBELLE_SENS_FORMAT

Uniquement pour les produits de type M (Matières) et Q (Qualité carton)

21, 26 Libellé de la saisie de la colonne format sens travers. Par défaut : Trav.

27 Caractère de séparation. Par défaut : <blanc>

28, 33 Libellé de la saisie de la colonne format sens fibres. Par défaut : Fibres

LIEN_AVEC_CODE_CS

Lien avec les codes statistiques

21 Lien avec le code statistique CS1 (O/N, N par défaut)

22 Lien avec le code statistique CS2 (O/N, N par défaut)

23 Lien avec le code statistique CS3 (O/N, N par défaut)

24 Lien avec le code statistique CS4 (O/N, N par défaut)

Pensez à paramétrer la même note au niveau de la sous-famille.

LIEUX_1_2_3

Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de

saisie manuelle (stk0)

intégration des temps et matières (int_rtm)

visualisation des mouvements de stocks (v_stk0)

La recherche se fait :

1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F ….)

2 sur la sous-famille de l'article

3 sur la famille de l'article

4 sur le type de mouvement de stock

5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3)

21,23 Lieu de rangement 1 (magasin)

25,27 Lieu de rangement 2 (Emplacement)

29,31 Lieu de rangement 3 (Emplacement)

LIST_TYPE_NOTE_A_REC

21,23 Type de note de mat3 que l'on veut recopier

La même note existe aussi sur v_cde_5 et la sous-famille.

METHODE_REMPL_POIDS

21 Méthode pour remplir la zone lc_poids en saisie de commande

1 lc_poids = 1

S Saisie du poids total

Vide méthode standard

La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire.

La recherche du paramétrage se fait dans l'ordre suivant :

1– Code statistique 1

2– Famille – sous-famille

3– Famille (ici)

Utilisable entre autres dans la papeterie

MODIF_POIDS_BLV

21 L'utilisateur peut modifier le poids de la ligne du bon de livraison (O/N, N par défaut)

Utilisable entre autres dans la papeterie

OUTILLAGE_AVEC_KIT

21 Sous-famille liée à un kit d'outillage (O/N, N par défaut)

Permet de filtrer les outillages à prendre en compte.

Aucune duplication d'action ne sera faite à partir de cet outil si option non paramétrée.

22 Méthode de recherche des outils du kit

1 Recherche via le code racine

1. Le code outil courant est tronqué selon le paramétrage de configuration de l'outillage (note commençant par TRONQUER_CODE_OUTIL).

2. On recherche tous les outils de même famille/sous-famille ayant le même code racine.

3. On duplique l'action saisie sur les outils trouvés

2 Recherche via une liste de TSC

1. On lit la zone alphanumérique de 30 caractères des informations complémentaires (TSC) saisies sur l'outil courant selon le paramétrage de configuration de l'outillage (note commençant par LISTE_TSC_KIT_OUTIL).

2. Sur chaque outil rattaché à l'outillage courant, on duplique l'action saisie.

Remarque

La première méthode permet de dupliquer l'action saisie sur tous les outils ayant un même code racine, quelque soit le code outil saisi.

Par contre, la deuxième méthode ne permet de dupliquer une action que si celle-ci est saisie sur l'outillage principal (celui qui contient la liste des outils rattachés via les TSC).

PRIX_A_LA_TONNE

Contrôle du prix à la tonne

Voir la note TSC_PRIX_A_LA_TONNE dans la saisie des commandes clients

Voir BLO A1[3,5] = 027

21,30 Borne inférieure de contrôle du prix à la tonne

Borne sous la forme 9999999999 ou 999999.999

31,40 Borne supérieure de contrôle du prix à la tonne

Borne sous la forme 9999999999 ou 999999.999

41,50 Date de dérogation inférieure de contrôle du prix à la tonne

Date sous la forme JJ/MM/AAAA

51,60 Date de dérogation supérieure de contrôle du prix à la tonne

Date sous la forme JJ/MM/AAAA

PRODUIT_GEN_FBI_XXX

où XXX = code sous-famille

21,35 Code produit générique à utiliser lors de la génération de la FBI.

Nécessite option Opp dans acr

REGROUP_BESOIN_FAM

21, Regroupement possible pour cette famille (O/N, O par défaut)

SAGE100_ANL_cccsss

ccc = code catégorie du client

sss = sous-famille

21 à 35 Codes analytiques

Si la sous-famille est à blanc, le code analytique s'applique à toutes les sous-familles non paramétrées pour cette catégorie.

SAGE100_CCT_bbbsss

Notes pour le transfert vers la comptabilité SAGE100

bbb = 3 espaces

sss = sous-famille

21 à 23 Centres de coût

Si la sous-famille est à blanc, le centre de coût s'applique à toutes les sous-familles non paramétrées de cette famille.

SAISIE_PRX_FORME_CDE

Saisie du prix de la forme sur la ligne de commande (O/N, N par défaut)

Voir l'option Ofo en saisie de commande client.

La même note existe sur la sous-famille où elle est prioritaire.

SECTION_ANALYTIQUE

21,32 Section analytique sur 12 caractères - Supprimé le 28/02/2012

Voir #CF TRF note SECT_PAR_DEFAUT, elle aussi supprimée.

Voir #CF TFF note SECT_PAR_DEFAUT, elle aussi supprimée.

TVA

Paramétrage des comptes de vente, achat, avoir ou bon de réception par code TVA et catégorie de tiers pour le transfert en comptabilité

4 Achat, Vente, Avoir ou Bon de réception

A Achat

V Vente

C Avoir

B Bon de réception

Voir la page récapitulative dans le #CF TFB

5,7 Code TVA. Si non saisi, la recherche se fera sur la famille et le code catégorie.

8,10 Catégorie du tiers. Si non saisie, la recherche se fera sur la famille et le code catégorie.

11,18 Compte France

19,26 Compte Export

27,34 Compte Suspension de TVA

35,42 Compte Intracommunautaire

43,50 Compte Exonéré

TYPE_COUT_ET_NIVEAU

Paramétrage du type de coût et du niveau de regroupement sur les familles / sous-familles du produit pour les coûts matières.

2123 Code sous-famille de l'article

25 Type de coût

F Fixe

V Variable

A Autres (par défaut)

27,29 Niveau de regroupement du coût (Type de paramètre NCC) Par défaut : DEF)

UNITE_VENTE

Permet d'initialiser la zone lc_unvent (code UNI) en saisie de commande.

La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire.

La recherche du paramétrage se fait dans l'ordre suivant :

1– Code statistique 1

2– Famille – sous-famille

3– Famille (ici)

Utilisable entre autres dans la papeterie

V

Vérifications avant suppression d'un article

Lors d'une annulation logique ou physique d'un article, des vérifications sont effectuées à partir de ce paramétrage.

Voir le détail du paramétrage de cette note sur mat.

Ce paramètre est recherché en priorité dans cet ordre :

1) Paramètre de lancement du programme mat

2) Sous-famille

3) Famille

VALEUR_CODIF_ART

Voir la note CODIF_ART* dans la codification automatique des articles.


FAR Familles d'arrêts

Ce paramètre est utilisé dans fab_ond_integre (intégration MIDATA).

Pas de paramétrage particulier.


FEX Frais d'expédition

Valeur alpha 1

FEX A1[1] | Catégorie de frais d'expédition 1 à 5
FEX A1[2] | Marge automatique (O/N, N par défaut) O Marge de la ligne de commande (non modifiable) N Marge modifiable
FEX A1[3,10] | Code comptable associé pour le transfert des frais (fl05)
FEX A1[11,13] | Code TVA par défaut utilisé dans la saisie des frais
FEX A1[14] | Possibilité de saisir un prix de vente de ce frais à 0 (O/N)

Notes

TVA

TVAV

Paramétrage des comptes de vente des frais d'expédition par code TVA et catégorie de tiers

4 V Ventes

5 à 7 Code TVA. Si non saisi, la recherche se fera sur la famille et le code catégorie

8 à 10 Catégorie du client. Si non saisie, la recherche se fera sur la famille et le code TVA

11 à 18 Code comptable France pour transfert en comptabilité (classe 7)

19 à 26 Code comptable export pour transfert en comptabilité (classe 7)

27 à 34 Code comptable suspension de TVA pour transfert en comptabilité (classe 7)

35 à 42 Code comptable intracommunautaire pour transfert en comptabilité (classe 7)

43 à 50 Code comptable exonérée pour transfert en comptabilité (classe 7)


FFA Fiches de fabrication

Valeurs numériques

FFA N1 | Numéro d'ordre d'édition de la fiche de fabrication
FFA N2 | Édition de l'entité 99 (0 Non, 1 Oui) Édition des entités réelles (2 Non)

Exemples

0, on édite toutes les entités sauf la 99

1, on édite toutes les entités

2, on n'édite que l'entité 99

Valeur alpha 1

FFA A1[1,50]

Sous-titre de la fiche de fabrication

Valeur alpha 2

FFA A2[1,30] | Paramétrage édition tableau matière. Indiquer O (Oui) ou N (Non) pour chacune des colonnes.
FFA A2[31,60] | Paramétrage édition tableau opérations. Indiquer O (Oui) ou N (Non) pour chacune des colonnes.

FFA A2[1] | Numéro d'ordre de fabrication
FFA A2[2] | Code produit
FFA A2[3] | Désignation produit
FFA A2[4] | Quantité lancée
FFA A2[5] | Quantité réalisée
FFA A2[6] | Gâche prévue
FFA A2[7] | Gâche variable réalisée
FFA A2[8] | Délai prévu
FFA A2[9] | Délai réalisé
FFA A2[10] | Coût matière du niveau (mécanique)
FFA A2[11] | Coût de préparation prévu du niveau (mécanique)
FFA A2[12] | Coût de réalisation du niveau (mécanique)
FFA A2[13] | Coût matière prévu
FFA A2[14] | Coût matière réalisé
FFA A2[15] | Coût de préparation prévu (calage)
FFA A2[16] | Coût de préparation réalisé (roulage)
FFA A2[17] | Coût de réalisation prévu
FFA A2[18] | Coût de réalisation réalisé
FFA A2[19] | Coût total prévu
FFA A2[20] | Coût total réalisé
FFA A2[21] | Type de gamme de fabrication (mécanique)
FFA A2[22] | Numéro de phase de fabrication
FFA A2[23] | Date de début
FFA A2[24] | Numéro de mouvement de stock engendré
FFA A2[25] | Quantité prévue totale
FFA A2[26] | Quantité réalisée totale
FFA A2[27] | Gâche fixe réalisée
FFA A2[31] | Numéro d'ordre de fabrication
FFA A2[32] | Type de gamme de fabrication
FFA A2[33] | Numéro de phase
FFA A2[34] | Code opération
FFA A2[35] | Libellé opération
FFA A2[36] | Code machine
FFA A2[37] | Section
FFA A2[38] | Quantité lancée
FFA A2[39] | Quantité réalisée
FFA A2[40] | Gâche prévue
FFA A2[41] | Gâche réalisée
FFA A2[42] | Type (préparation ou réalisation)
FFA A2[43] | Date de début calculée
FFA A2[44] | Délai demandé
FFA A2[45] | Date de début
FFA A2[46] | Délai réalisé
FFA A2[47] | Temps de préparation prévu
FFA A2[48] | Temps de réalisation prévu
FFA A2[49] | Temps de préparation réalisé
FFA A2[50] | Temps de réalisation réalisé
FFA A2[51] | Temps total prévu
FFA A2[52] | Temps total réalisé
FFA A2[53] | Coût prévu
FFA A2[54] | Coût réalisé
FFA A2[55] | Code difficulté
FFA A2[56] | Quantité totale prévue
FFA A2[57] | Quantité totale réalisée

Notes

M | Concernent les familles matière à éditer Saisir (en majuscule) les familles à éditer
S | Concernent les sections opération à éditer Saisir (en majuscule) les sections à éditer
N | Concernent les types de notes à éditer sur la fiche Saisir (en majuscule) les types de notes à éditer (Notes saisies sur le devis)
C | Concernent les types de notes à éditer sur la fiche Saisir (en majuscule) les types de notes à éditer (Notes saisies sur la ligne de commande)


FIS Codes fiscaux

Valeur alpha 1

FIS A1[1] | Code export (O/N/S) (S Suspension de taxe)
FIS A1[2,4] | Type tarif NOR tarif en fonction du type de commande XXX tarif spécial (EXPORT....)
FIS A1[5] | Type de facture export

Exemple

Type 1 sauf AELE, Afrique, CE

Type 2 AELE

Type 3 Afrique

Type 4 CEE


FMT Codes formats

Ce paramètre est utilisé par importation_prophee_tarif_mp.

Libellé long

Longueur du format x Largeur du format

Longueur et largeur du format sous la forme <<<<<<<<<&.&&&

EX : 1200.000 x 250.000

Valeurs numériques

FMT N1 | Longueur du format sous la forme <<<<<<<<<&.&&&
FMT N2 | Largeur du format sous la forme <<<<<<<<<&.&&&

Valeur alpha1

FMT A1[1,15]

Code article associé au format


FOR Formules de calcul

Valeur alpha 1

FOR A1[1,50]

Formules de conversions

Valeur alpha 2

FOR A2[1,60]

Formules de conversions

Valeur alpha 3

FOR A3[1,60]

Formules de conversions

Valeur alpha 4

FOR A4[1,60]

Formules de conversions

[cf ci-dessous Interpréteur Atlas]

Paramétrage utilisé pour la saisie de quantité dans différentes unités

Notes triées

ARRONDI_

Gestion de l'arrondi

9,10 Portée de l'arrondi

PA L'arrondi porte sur le prix d'achat

UA L'arrondi porte sur l'unité d'achat

UU L'arrondi porte sur l'unité d'utilisation

12,22 Précision de l'arrondi. Mettre simplement 1 pour un arrondi sans décimales.

Exemples

ARRONDI_PA 0.01 : 2 chiffres après la virgule

ARRONDI_UA 0.001 : 3 chiffres après la virgule

ARRONDI_UU 0.0001 : 4 chiffres après la virgule

etc...

CC

Formule de conversion (Formules de calcul complémentaires)

3,4 Numéro de la formule (5 à 99)

5,60 Formule de calcul

FORMAT_UNITE_ACHAT

21,60 Format numérique à appliquer au champ valeur_unite_achat

des écrans G_s_qte_conv et G_s_qte_conv_ua

FORMAT_UNITE_UTIL

21,60 Format numérique à appliquer au champ valeur_unite_util

des écrans G_s_qte_conv et G_s_qte_conv_ua

FORMAT_UNITE_3

21,60 Format numérique à appliquer au champ valeur_unite_3

des écrans G_s_qte_conv et G_s_qte_conv_ua

FORMAT_UNITE_ACHAT_R

21,60 Format numérique à appliquer au champ valeur_unite_achat_r

des écrans G_s_qte_conv et G_s_qte_conv_ua

FORMULE_3

11 Accès à la quantité dans l'unité 3 (O/N)

12,14 Code paramètre de l'unité 3 (dans le paramètre de type UNI).

16,35 Libellé de la zone unité 3 - Voir #CF ATL A1[46]

La formule de conversion associée à la formule 3 est saisie en alpha 3.

FORMULE_3_UP

Unité 3

14 Accès à la zone unité 3 de production (O/N)

15,17 Code de l'unité 3 de production

18,37 Libellé de la zone unité 3 de production

Voir #CF ATL A1[46]

INVERSION_UU_ET_UA

21 Inversion des zones unité d'utilisation et unité d'achat (O/N, N par défaut)

QTE_REELLE_UA

15 Accès à la quantité réelle en UA (O/N, N par défaut)

16,18 Code de l'unité de la quantité réelle en UA

19,38 Libellé de la zone de la quantité réelle en UA

39 Numéro d'indice du coefficient de conversion pour calculer par défaut la quantité réelle en UA
(1/2/3/4, 1 par défaut)

La quantité réelle est stockée dans l'unité de stockage 2 (s0_qte_unite_2).

SAISIE_MULTI_PRIX

20 Ouverture de la fenêtre de saisie des quantités (O/N, O par défaut)

Cette fenêtre permet de saisir le prix pour différentes unités (pour 1 unité d'achat, d'utilisation ou autres cf FORMULE_3)

SAISIE_MULTI_UNITE

20 Ouverture de la fenêtre de saisie des quantités multi unités dans les achats (O/N, O par défaut)

21 Ouverture de la fenêtre de saisie des quantités multi unités dans la production (O/N, O par défaut)

Voir #CF ATL A1[46]

Interpréteur Atlas

L'interpréteur Atlas permet la conversion lors de l'utilisation du fichier matière du prix dans l'unité d'achat en prix dans l'unité de vente (encore appelé prix dans l'unité d'utilisation).

Cette fonction retourne un coefficient multiplicateur qui agit sur le prix d'achat pour donner le prix de vente.

Il fonctionne en notation post fixée (ou polonaise inverse), c'est à dire que les opérateurs utilisent les valeurs qui se trouvent au sommet d'une pile.

Opérateurs

/ | Divise l'avant-dernière valeur de la pile par la dernière. Enlève ces 2 valeurs et pose le résultat au sommet.
* | Multiplie l'avant dernière valeur de la pile par la dernière, enlève ces 2 valeurs et pose le résultat au sommet
+ | Additionne l'avant dernière valeur de la pile et la dernière, enlève ces 2 valeurs et pose le résultat au sommet
- | Soustrait la dernière valeur de la pile de l'avant dernière, enlève ces 2 valeurs et pose le résultat au sommet
[ | Valeur entière
] | Valeur supérieure
$ | Supprime la valeur au sommet de la pile.
% | Conserve uniquement la première décimale de la valeur au sommet de la pile.
A | Pose la valeur de la donnée technique 1 sur le sommet de la pile.
B | Pose la valeur de la donnée technique 2 sur le sommet de la pile.
C | Pose la valeur de la donnée technique 3 sur le sommet de la pile.
D | Pose la valeur de la donnée technique 4 sur le sommet de la pile.
à | Pose la valeur de la donnée technique 5 sur le sommet de la pile.
b | Pose la valeur de la donnée technique 6 sur le sommet de la pile.
c | Pose la valeur de la donnée technique 7 sur le sommet de la pile.
d | Pose la valeur de la donnée technique 8 sur le sommet de la pile.
H | Pose la hauteur sur le sommet de la pile.
L | Pose la longueur sur le sommet de la pile.
l | Pose la largeur sur le sommet de la pile.
E | Pose le poids (ou grammage) sur le sommet de la pile.
Z | Pose la valeur chiffrée 1 du paramètre FOR sur le sommet de la pile.
z | Pose la valeur chiffrée 2 du paramètre FOR sur le sommet de la pile.
> | Prends les 2 dernières valeurs de la pile, et dépose le maxi.
< | Prends les 2 dernières valeurs de la pile, et dépose le mini.
= | Pose 1 sur la pile si les deux dernières valeurs sont égales, sinon pose 0 (les 2 valeurs ne sont pas supprimées).
) | Pose 1 sur la pile si la dernière valeur est supérieure à l'avant dernière (les 2 valeurs ne sont pas supprimées).
( | Pose 1 sur la pile si la dernière valeur est inférieure à l'avant dernière (les 2 valeurs ne sont pas supprimées).
? | Teste le sommet de la pile. Si le sommet est <> 0, on exécute la formule jusqu'au [:] suivant
 | Si le sommet est = 0, on exécute du [:] suivant jusqu'au # suivant.

Constantes

Les constantes entières peuvent êtres saisies dans la formule de conversion. Pour utiliser des valeurs décimales, il faut utiliser les valeurs chiffrées et les déposer sur la pile par Z ou z.

Appel de l'interpréteur

Fonction coef_conv (no_formule)

Elle utilise la zone alpha 1 ou la zone alpha 2

Elle renvoie le coefficient par lequel il faut multiplier le prix dans l'unité d'achat pour avoir le prix dans l'unité de vente.

Exemple | let coef = coef_conv(1)
ou dans calcul | let prix_uni_vente = prix_uni_achat * coef_conv(1)
Valeur alpha 1 | * Formule standard
Valeur alpha 2 | * En standard : Non utilisée ou * Avec option : Utilisée en édition de prix de revient (récapitulatif famille/sous-famille)
Valeur alpha 3 | * En standard : Utilisée dans la saisie des quantités multi unités ou * Avec option : Utilisée dans le calcul des PR (-Of3) Conversion pour fab3
Valeur alpha 4 | * En standard : Utilisée dans le devis en cas d'utilisation de code papier reel


FP Fiches produit

Valeur alpha 2

FP A2[1,60]

Titre de l'état

Valeur alpha 3

FP A3[1]

Edition des fiches produit de la nomenclature (O/N, N par défaut)

Notes

S | Complément de select. Exemple S and mp_anu N
TSC | Code TSC à éditer Exemples TSC010 TSC020 Si vous souhaitez éditer TOUS les TSC saisis sur une fiche produit, indiquez TSC*
NOTE | Type de note à éditer Exemples NOTEPAP NOTECLI Si vous souhaitez éditer TOUTES les notes saisies sur une fiche produit, indiquez NOTE*


FPR Familles de produits

Paramétrage des familles de produit figées (utilisé dans le devis feuille).


GAM Gammes

Seul le libellé est utilisé.

Il n'y a pas de paramétrage.


GAP Groupe APE

Pas de paramétrage, seul le libellé est utilisé.


GCO Grammage colle

Utilisé dans ATLAS-CARTON.

Valeurs numériques

GCO N1

Grammage colle.


GEO Secteur géographique

Paramétrage libre.

Tenez compte des analyses futures propres à votre entreprise.

Le secteur géographique peut tout aussi bien contenir un code département (bien que celui-ci soit déjà connu en général via le code postal du client) qu'un code région (CEN pour Centre, ALS pour Alsace, etc.).

Il est possible d'effectuer une association automatique entre un département (paramètre DEP) et un secteur géographique.

Valeur alpha 1

GEO A1[1,3]

Code pondération coût de transport


GES Gestionnaires

Pas de paramétrage. Seuls les libellés sont utilisés.


GMA Groupes pour le tableau de marges

Remarques préliminaires

Le groupe 997 est réservé en tant que groupe d'accueil des frais de transport internes.

Le groupe 998 est réservé en tant que groupe d'accueil des frais de transport client.

Le groupe 999 est réservé en tant que groupe d'accueil de toutes les formules n'appartenant a aucun groupe.

Pour une opération, le % variable ou le % fixe se définissent dans la formule (%montant et %Frais).

Pour une matière, la part fixe ou variable dépend du mp_param[01] de l'article.

Observations

La saisie d'une marge sur un groupe de marge (forçage) réinitialise la marge de toutes les formules (matière/opération/sous-traitance) appartenant au groupe.

Il n'est plus possible d'appliquer une marge double.

Exemple :

Pour une formule matière : marge venant de la fiche matière à laquelle s'ajoute la marge du groupe.

Désormais, la marge de la fiche matière n'est prise en compte que si aucune marge n'a été forcée pour le groupe.

Il est désormais impossible d'appliquer une marge à un groupe lorsqu'une marge ou qu'un prix de vente a été forcé sur une formule matière appartenant à ce groupe.

De la même façon, la marge ou le prix de vente d'une formule (matière/opération/sous-traitance) ne pourra pas être modifié si une marge a été forcée sur le groupe de marge dont fait partie la formule.

Le recalcul (F11) ne prend pas en compte la réattribution des marges au niveau des phases et/ou formules (matière/opération/sous-traitance), il est donc désormais interdit de lancer celui-ci à ce niveau si la phase et/ou la formule à recalculer fait partie d'un groupe de marge dont la valeur a été forcée. Le recalcul devra s'effectuer obligatoirement au niveau de l'entité ou du sous-devis.

Important :

Dans un souci de mise à jour des devis, il peut être utile d'exécuter une réinitialisation des marges (F22 sur écran des marges) puis de re-saisir les valeurs de marges.

Valeurs numériques

GMA N1

Valeur de la marge par défaut

Valeur alpha 1

GMA A1[1,3] | Code de regroupement par défaut (RMA)
GMA A1[4] | Code édition par défaut
GMA A1[5] | A prendre en compte dans le tableau des enjeux (O/N) (tableau spécifique client)
GMA A1[6] | Code édition par défaut pour les lignes de totalisation du tableau des marges Si cette zone n'est pas renseignée, on prends par défaut la valeur définie sur le caractère 4
GMA A1[7,9] | Code regroupement pour pouvoir éditer des sous-totaux sur l'édition du tableau des marges
GMA A1[10,12] | Groupe de ventilation analytique (spécifique) (Libellés dans paramètre GVE)

Valeur alpha 2

GMA A2[1]

Prise en compte systématique de la marge du groupe de marge (O/N)

N par défaut si le paramétrage GMA n'existe pas.

O par défaut si le paramétrage GMA existe et que le caractère n'est pas renseigné.

Notes

DPC_ASSOCIE | 21,23 Code DPC associé au GMA (voir DPC, alpha1[8,10] : code obligatoire sinon DPC ignoré)
M | 2 Type de formule O pour une formule Opération M pour une formule Matière S pour une formule Sous-traitance 3,5 Code phase 6,8 Code formule 9 Elément principal du groupe de marge pour le tableau des enjeux (Oui/Non) 10 Elément à prendre en compte pour le temps devisé dans le tableau des enjeux (Oui/Non) 11 Elément à prendre en compte pour le calcul de la vitesse moyenne dans le tableau des enjeux (Oui/Non) 12 Elément à prendre en compte pour le calcul du taux moyen dans le tableau des enjeux (Oui/Non)


GRU Groupe utilisateur

Ce paramètre est utilisable à partir de la V.4.1.3.2

Cadre : Gestion des actions événements depuis le devis onduleur.

Notes

EVT_AUTORISE_USE | 21,23 Code utilisateur du type de paramètre USE. Une ligne de note par utilisateur faisant partie du groupe.
ENVOI_DEST | 21,26 Type et code de l'utilisateur Le type est traditionnellement USE, mais vous pouvez indiquer tout autre type à votre convenance.


GRV Configuration des variables additionnelles du catalogue

Ce paramètre est opérationnel à partir de la V.4.1.30.2

Il est référencé par la note GRW_CONFIG, qui doit être déclarée sur le paramètre de lancement de chaque édition VoluEdit que l'on souhaite mettre en mode Genero Report Writer.

Voir aussi le paramètre GRW pour la configuration des sorties.

Notes

DEF_CAB_xx_NOMTABLE | 21,60 Avec xx un nombre compris entre 01 et 99 Nom de la table que l’on souhaite avoir une variable pour un code à barres (correspond aux packages). Tables disponibles : cde1 entête de commande client cde2 ligne de commande client cdf1 entête de commande d’achat cdf2 ligne de commande d’achat mat fiche article etiqprod étiquette de production blv1 entête de bon de livraison blv2 ligne de bon de livraison groupage_bl groupage ordre_transport ordre de transport
DEF_CAB_xx_LIBELLE | 21,60 Avec xx un nombre compris entre 01 et 99 Libellé du code à barres (libellé de la zone dans le catalogue).
DEF_CAB_xx_CONTENU | 21,60 Avec xx un nombre compris entre 01 et 99 Le contenu du code à barres peut être construit avec les zones des tables. Pour inclure une zone d'une table dans le contenu, il faut l'entourer par des crochets [ et ]. Un using peut être appliqué en mettant un + entre le nom de la zone et le using. Zones supplémentaires disponibles : use Code du type paramètre USE Exemples sans using : [b1_blv] avec using : [b1_blv]-[b1_lig+<<&]
DEF_CAB_xx_TYPE | 21,60 Avec xx un nombre compris entre 01 et 99 Type de code à barres EAN128B (valeur par défaut)
VAR | Les notes VAR reprennent le rôle et la syntaxe des notes VE_VAR. Voir l'aide en ligne (#VE) pour plus d'information concernant le paramétrage d'une note VE_VAR. Exemple VAR Notes Libres*NOTES_##_FAC_BLV*

La syntaxe de VAR avec les notes dispose d'un paramètre supplémentaire, uniquement disponible dans GRW :

VAR Libellé*NOTES_SS_TN1_TN2_TN3*NbLig*Niveau*Adresse*NbCar*

NbCar = Nombre de caractères avant déclenchement d'un saut de ligne.

Par défaut, la rupture des notes se fait tous les 60 caractères (retour à la ligne).

Cette rupture peut être modifiée. Le chiffre doit être un multiple de 60.

Si la valeur est à 0, on considère qu'il n'y a aucune rupture.

Exemples

VAR Note client*CL_ACH***** | Retour à la ligne à chaque ligne de note (ou au bout des 60 caractères)
VAR Note client*CL_ACH****120* | Retour à la ligne après deux lignes de notes concaténées (ou au bout des 120 caractères)
VAR Note client*CL_ACH****0* | Aucun retour à la ligne ne sera fait.

Lors de la saisie d'une note, l'utilisateur peut forcer un retour à la ligne en mettant \n lors de sa saisie.

L'utilisation de notes groupées dans les éditions Genero Report Writer est obsolète.


GRW Configuration des éditions par Genero Report Writer

Ce paramètre est opérationnel à partir de la V.4.1.30.2

Il est référencé par la note GRW_CONFIG, qui doit être déclarée sur le paramètre de lancement de chaque édition VoluEdit que l'on souhaite mettre en mode Genero Report Writer.

Voir aussi le paramètre GRV pour la configuration des variables additionnelles.

Attention : tout le paramétrage de cette page est généré automatiquement par un programme d'aide à la saisie.

Consultez le document INS_NC_Genero report writer.doc

Tous les catalogues s'enrichissent d'une nouvelle variable par défaut (disponible uniquement avec GRW) : grw_type_sortie.

Cette variable permet de connaître le type de sortie sélectionnée par l'utilisateur pour l'édition de son document.

Cela permet de conditionner certaines parties du document selon le type de sortie (voir la note TYPE_SORTIE).

Valeur alpha 1

A1[1,50]

G_grw_driver.4ge

Notes de configuration générale

L'ordre des notes doit être respecté.

TYPE_DOCUMENT

21,60 Type de document (cde, fac, etc.)

CATALOGUE_XSD

21,60 Nom du catalogue

MODELE_4RP

21,60 Nom du modèle

REP_FONTS_ACTIVE

21 Active le répertoire des polices de caractères personnalisé pour GRW (O/N, N par défaut).

Par défaut, Genero Report Writer utilise les polices de caractères du système d'exploitation (Windows ou Linux).

Mais, lors de la génération d'un fichier PDF, on peut forcer Genero Runtime Engine (GRE) à incorporer les polices de caractères situées dans le répertoire fonts suivant : %fglldpath%\grw\fonts.

Nota : ce répertoire devra contenir les polices de caractères si la note est positionnée à O.

Notes de configuration des sorties (impression, fichier, aperçu, etc.)

L'ordre des notes doit être respecté.

Une configuration est égale à un type de sortie (PDF, RTF, Imprimante, etc.).

CFG_

5,6 Numéro de configuration (de 01 à 99).

Exemple : CFG_01

CONFIG_ACTIVE

21 Configuration de sortie active (O/N, N par défaut)

CONFIG_NOM

21,60 Nom de la configuration qui sera affichée dans l'écran de sélection du type de sortie.

Exemple : CONFIG_NOM Sortie PDF

TYPE_SORTIE

21,60 Type de sortie

APERCU L'édition s'affichera dans Genero Report Viewer (incorporé au GDC).

FRONTCALL Exécution d'une ligne de commande

HTML Création d'un fichier HTML (utilisable avec un navigateur web)

IMP L'édition se fera vers une imprimante

IMPLP L'édition se fera vers une imprimante en utilisant la commande lp (disponible uniquement sous un système de type unix).

JPG Création d'un fichier JPG

OORTF Création d'un fichier RTF (utilisable sous OpenOffice Writer)

PDF Création d'un fichier PDF

PNG Création d'un fichier PNG

RTF Création d'un fichier RTF (utilisable dans Microsoft Word par exemple)

SVG Création d'un fichier image vectoriel

SVGIMP L'édition se fera vers une imprimante connue par le GDC du poste client.

XLS Création d'un fichier XLS (utilisable dans Microsoft Excel et OpenOffice Calc)

XLSX Création d'un fichier XLSX (utilisable à partir de la version 2007 d'Excel)

RGRP_FICHIER

21,60 Regroupement de fichiers par :

FLUX Création d'un seul fichier qui regroupera toute la sélection.

DOC création d'un fichier par document. (Exemple : un fichier PDF par facture)

EXEMPLAIRE création d'un fichier par exemplaire.

Exemple

La CONFIG_01 contient deux exemplaires.

Un nommé ORI et l'autre DUP.

En finale, 2 fichiers seront créés : un par exemplaire.

MODE_IMPRESSION

21,60 Mode d'impression via le GDC (type de sortie : SVGIMP = impression vers les imprimantes connues par le GDC)

IMP_CHOIX_CLIENT : L'utilisateur pourra choisir l'imprimante via l'ouverture d'une boite de dialogue.

IMP_NOM_CLIENT : Impression via l'imprimante définie. (La note IMPRIMANTE_NOM est nécessaire).

IMP_DEFAUT_CLIENT : Impression via l'imprimante par défaut.

IMPRIMANTE_NOM

21,60 Nom de l'imprimante à utiliser pour les éditions sur papier.

Nota : seules les imprimantes configurées sur le serveur qui héberge Genero Runtime Engine seront disponibles.

BAC_ENTREE

21,60 Nom du bac d'entrée de l'imprimante

Par défaut : vide = c'est le driver ou l'imprimante qui choisis le bac d'entrée.

Nota : seules les media-name reconnues par Genero Runtime Engine seront disponibles.

RECTO_VERSO

21 Active le recto/verso en impression directe (si le driver de l'imprimante le permet) (O/N, N par défaut)

FLUX_REPERTOIRE

21,60 Nom du répertoire où seront déposés les fichiers lorsque le regroupement de fichier est mis à FLUX.

FLUX_FICHIER

21,60 Nom du fichier lorsque le regroupement de fichier est mis à FLUX.

DOC_REPERTOIRE

21,60 Nom du répertoire où seront déposés les fichiers lorsque le regroupement de fichier est mis à DOC.

DOC_FICHIER

21,60 Nom du fichier lorsque le regroupement de fichier est mis à DOC.

CFG_A_EXECUTER

21,60 Liste des configurations (types de sortie) qui seront exécutées à la suite de celle sélectionnée.

C'est-à-dire le système éditera dans un premier temps le ou les documents dans le type de sortie choisie.

Puis il éditera le ou les documents avec les types de sortie paramétrées dans la note CFG_A_EXECUTER à la suite.

Exemple d'utilisation : lorsqu'un utilisateur édite vers l'imprimante on souhaite qu'un fichier PDF soit crééen même temps.

EXEMPLAIRE_

12 13 Paramétrage des exemplaires

Numéro de l'exemplaire (de 01 à 99)

Exemple : EXEMPLAIRE_01

EXEMPLAIRE_CODE

21,60 Code de l'exemplaire

Ce code pourra être utilisé dans Genero Report Designer (GRD) pour conditionner l'affichage des pages root ou des mini page.

Exemple : EXEMPLAIRE_CODE ORI

NB_COPIES

21,60 Nombre de copies pour l'exemplaire.

Ce paramètre permet de définir le nombre de copies de l'exemplaire.

Ce paramètre peut être exprimé par une formule en faisant appel au paramétrage de la fiche client.

Zones disponibles

nb_copie_devis Nombre de copies du devis

nb_copie_ar Nombre de copies de l'accusé de réception

nb_copie_bl Nombre de copies du bon de livraison

nb_copie_etiq Nombre de copies de l'étiquette

nb_copie_facture Nombre de copies de la facture

nb_copie_releve Nombre de copies du relevé

nb_copie_gen_xx (avec xx un nombre de 01 à 99)

Nombre de copies selon une règle. Voir la documentation de chaque lanceur.

Exemple : pour le voluedit_oex (édition des ordres d'exécution, le nb_copie_gen_01 correspond au nombre de machines contenues dans la gamme (TSC 200).

Opérateurs arithmétiques disponibles

+ (addition)

- (soustraction)

* (multiplication)

Exemples

NB_COPIES 1

NB_COPIES nb_copie_facture - 1

NB_COPIES nb_copie_facture + 4

EX_REPERTOIRE

21,60 Nom du répertoire où seront déposés les fichiers lorsque le regroupement de fichier est mis à EXEMPLAIRE.

EX_FICHIER

21,60 Nom du fichier lorsque le regroupement de fichier est mis à EXEMPLAIRE.

Information concernant le nommage des fichiers et/ou des répertoires

Les noms du répertoire et/ou du fichier peuvent être construits avec les zones des tables.

Pour inclure une zone d'une table dans le nom, il faut l'entourer par des crochets [ et ].

Un using peut être appliqué en mettant un + entre le nom de la zone et le using.

Zones supplémentaires disponibles

societe Code société

exemplaire Code exemplaire GRW

use Code du type paramètre USE

today Date du jour (un using est obligatoire)

Exemples

sans using : BL_[b1_blv]

avec using : [b1_lig+<<&]

Exemple de configuration pour l'édition des factures

1) Paramétrage du #VE FAC (lanceur de voluedit_facn) :

GRW_CONFIG FAC

La note GRW_CONFIG indique qu'il faut rechercher le code paramètre FAC (de type GRW).

2) Paramètre GRW FAC :

# Config générale

TYPE_DOCUMENT fac

CATALOGUE_XSD VSW_facture

MODELE_4RP VSW_facture

# Config 1

CFG_01

CONFIG_ACTIVE O

CONFIG_NOM Aperçu

TYPE_SORTIE APERCU

RGRP_FICHIER FLUX

# Exemplaire 1 (de la config 1)

EXEMPLAIRE_01

EXEMPLAIRE_CODE VSW

NB_COPIES 1

# Config 2

CFG_02

CONFIG_ACTIVE O

CONFIG_NOM PDF Facture

TYPE_SORTIE PDF

RGRP_FICHIER DOC

DOC_REPERTOIRE D:\temp\grw\

DOC_FICHIER facture_[fe_fac]

# Exemplaire 1 (de la config 2)

EXEMPLAIRE_01

EXEMPLAIRE_CODE VSW

NB_COPIES 1

# Config 3

CFG_03

CONFIG_ACTIVE O

CONFIG_NOM Konica

TYPE_SORTIE IMP

RGRP_FICHIER FLUX

IMPRIMANTE_NOM KONICA MINOLTA C360SeriesPCL

CFG_A_EXECUTER 02

# Exemplaire 1 (de la config 3)

EXEMPLAIRE_01

EXEMPLAIRE_CODE VSW

NB_COPIES 1

# Config 4

CFG_04

CONFIG_ACTIVE O

CONFIG_NOM JPG

TYPE_SORTIE JPG

RGRP_FICHIER DOC

DOC_REPERTOIRE D:\temp\grw

DOC_FICHIER Facture_[fe_fac]

# Exemplaire 1 (de la config 4)

EXEMPLAIRE_01

EXEMPLAIRE_CODE VSW

NB_COPIES 1

# Config 5

CFG_05

CONFIG_ACTIVE O

CONFIG_NOM Sortie RTF

TYPE_SORTIE RTF

RGRP_FICHIER DOC

FLUX_REPERTOIRE D:\temp\grw

FLUX_FICHIER Facture_[fe_fac]

DOC_REPERTOIRE D:\temp\grw\

DOC_FICHIER Facture_[fe_fac]

# Exemplaire 1 (de la config 5)

EXEMPLAIRE_01

EXEMPLAIRE_CODE VSW

NB_COPIES 1


IDP Image disposition palette

Ce paramètre est opérationnel à partir de la V.4.0.214.2

Il est utilisé par le devis onduleur.

Notes

IMG

21,60 Nom du fichier (Image)

Le répertoire par défaut est celui de GDC avec les autres images.

Sinon, il est possible d'indiquer un chemin. (exemple : d:/u/img/00456.png) (ajouté le 09/02/2012)

En cas de nom long, plusieurs notes peuvent être utilisées.

Taille de l'image : 105x70

A cette occasion le TSC 23K, zone F (char3_1), change d'appellation :

En remorque (O/N) devient Disposition palette, pointant vers le code paramètre de type IDP.


IDV Identifiant véhicule

Ce paramètre est utilisé par exped_affretements A2[15]

Pas de paramétrage


ILO Ilots de charge

Valeurs numériques

1 | Taux de rectification des temps sur la machine. Exemple : 0,75 Permet d'appliquer un taux de rectification lié à l'îlot de charge aux temps de passage et de réglage lors du calcul de la charge machine.
2 | non utilisée

Valeur alpha 1

ILO A1[1] | Prise en compte de l'îlot dans le calcul des charges (O/N, N par défaut)
ILO A1[2,4] | Code du site auquel appartient l'îlot (integration_tgvdata) - Tableau de bord du multisite


JON Codes jonction

Pas de paramétrage particulier


JOU Code découpage journalier

Le code découpage journalier est issu du découpage hebdomadaire.

Valeurs numériques

JOU N1

Temps dû de la journée

Valeur alpha 2

JOU A2[1,4] | Plage 1 Heure de début (en heures/minutes, exemple 0745)
JOU A2[5,8] | Plage 1 Heure de début (en heures/minutes, exemple 0745)
JOU A2[9,11] | Plage 1 Code aléa (TTR, exemple Pause casse-croûte)
JOU A2[12] | Plage 1 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A2[13,15] | Plage 1 Inutilisés
JOU A2[16,19] | Plage 2 Heure de début (en heures/minutes, exemple 0745)
JOU A2[20,23] | Plage 2 Heure de fin (en heures/minutes, exemple 0745)
JOU A2[24,26] | Plage 2 Code aléa (TTR, exemple Pause casse-croûte)
JOU A2[27] | Plage 2Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A2[28,30] | Plage 2Inutilisés
JOU A2[31,34] | Plage 3 Heure de début (en heures/minutes, exemple 0745)
JOU A2[35,38] | Plage 3 Heure de fin (en heures/minutes, exemple 0745)
JOU A2[39,41] | Plage 3 Code aléa (TTR, exemple Pause casse-croûte)
JOU A2[42] | Plage 3 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A2[43,45] | Plage 3 Inutilisés
JOU A2[46,49] | Plage 4 Heure de début (en heures/minutes, exemple 0745)
JOU A2[50,53] | Plage 4 Heure de fin (en heures/minutes, exemple 0745)
JOU A2[54,56] | Plage 4 Code aléa (TTR, exemple Pause casse-croûte)
JOU A2[57] | Plage 4 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A2[58,60] | Plage 4 Inutilisés

Valeur alpha 3

JOU A3[1,4] | Plage 5 Heure de début (en heures/minutes, exemple 0745)
JOU A3[5,8] | Plage 5 Heure de début (en heures/minutes, exemple 0745)
JOU A3[9,11] | Plage 5 Code aléa (TTR, exemple Pause casse-croûte)
JOU A3[12] | Plage 5 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A3[13,15] | Plage 5 Inutilisés
JOU A3[16,19] | Plage 6 Heure de début (en heures/minutes, exemple 0745)
JOU A3[20,23] | Plage 6 Heure de fin (en heures/minutes, exemple 0745)
JOU A3[24,26] | Plage 6 Code aléa (TTR, exemple Pause casse-croûte)
JOU A3[27] | Plage 6Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A3[28,30] | Plage 6 Inutilisés
JOU A3[31,34] | Plage 7 Heure de début (en heures/minutes, exemple 0745)
JOU A3[35,38] | Plage 7 Heure de fin (en heures/minutes, exemple 0745)
JOU A3[39,41] | Plage 7 Code aléa (TTR, exemple Pause casse-croûte)
JOU A3[42] | Plage 7 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A3[43,45] | Plage 7 Inutilisés
JOU A3[46,49] | Plage 8 Heure de début (en heures/minutes, exemple 0745)
JOU A3[50,53] | Plage 8 Heure de fin (en heures/minutes, exemple 0745)
JOU A3[54,56] | Plage 8 Code aléa (TTR, exemple Pause casse-croûte)
JOU A3[57] | Plage 8 Type de plage (N Normal, E Entrée, S Sortie). La plage est créée dans fab2 uniquement si le type est N
JOU A3[58,60] | Plage 8 Inutilisés

Exemple

Soit les plages paramétrées

Zone alpha 2 : 08000000AL1N 09000910AL2N 00001200AL3S 13000000AL4E

Zone alpha 3 : 00001800AL5N

Soit l'événement

Salarié 1 : Of 92010001-1, phase 10

Heure début 0745 : heure fin 1815 aléa P

Les plages suivantes seront créées :

de 0745 à 0800 avec l'aléa AL1

de 0800 à 0900 avec l'aléa P

de 0900 à 0910 avec l'aléa AL2

de 0910 à 1200 avec l'aléa P

de 1300 à 1800 avec l'aléa P

de 1800 à 1815 avec l'aléa AL5

La plage de 1200 à 1300 ne sera pas créée.


KMA Codes ECMA - FEFCO

Type de boite utilisé dans VOLUPACK.

Ces grands types de boites sont des paramètres également utilisés dans la recherche des opérations (collage, etc.).

Boite à fond automatique, étui, etc.

ATTENTION : dans le devis standard (entité étiquette), le code contour est le code ECMA : dans ce cas, créez des codes à 3 caractères maximum et non pas 15.

Valeurs numériques

KMA N1

Utilisation dans la formule ### #AU

Valeur alpha 1

KMA A1[1] | O Dans le devis carton ondulé ou [blanc] On vérifiera la cohérence entre la largeur et la longueur ( devis_dco.4ge ) N Pas de contrôle
KMA A1[2,4] | Définit la famille du PF fabriqué (Spécifique)
KMA A1[5,7] | Définit la sous-famille du PF fabriqué (Spécifique)
KMA A1[8,10] | Type de collage (accessible dans la formule ### #AU)
KMA A1[11,13] | Zone libre (3 caractères). Spécifique. Accessible dans la formule ### #AU
KMA A1[14,16] | Définit la famille du PF négoce (Spécifique)
KMA A1[17, 19] | Définit la sous-famille du PF négoce (Spécifique)
KMA A1[20] | Devis carton ondulé (devis_odv.4ge) O Contrôle possibilité machine 14. Désigne les caisses américaines à rabats jointifs.
KMA A1[21] | Nombre de poses maximum Zéro ou (espace] : pas de contrôle
KMA A1[22] | Code de regroupement lors de la génération automatique d’article (#CF GEA pour CND = K40)


LAI Laize

Valeurs numériques

LAI N1

Valeur de la laize


LAN Code langue

Utilisé initialement pour PC-TOPP

Valeur alpha 1

LAN A1[1] | Code langue pour transfert PC-TOPP
LAN A1[2,4] | Code langue normalisé ISO
LAN A1[5,7] | Correspondance avec Interface Tiers JDE


LCO Lignes complémentaires

Voir les codes zones LCO

Syntaxe d'appel

Attention : Les codes LCO ne doivent pas utiliser les codes spéciaux tels que #, @, *, ?, ., /, ! etc.
Vous ne pouvez utiliser que les 10 chiffres.

La LCO #GF est réservée pour la saisie des gâches de finition.

Gâche fixe saisie dans la valeur numérique 1.

Gâche variable saisie dans la valeur numérique 2.

Pour que ce paramétrage soit actif, le caractère alpha1[45] sur le #CF DEG doit être à O.

Dans les formules, il faut bien sûr utiliser des codes calcul gâche comprise (QT 3 par exemple).

Valeurs numériques

LCO N1

Numéro d'ordre pour la création automatique en création de phase (mode contextuel uniquement)

Valeur alpha 1

LCO A1[1,3] | Type de paramètre associé à la 1ère zone alphanumérique de 3 caractères (fc_a1) * (astérisque) si pas de contrôle
LCO A1[4,6] | Type de paramètre associé à la 2ème zone alphanumérique de 3 caractères (fc_a2) * (astérisque) si pas de contrôle
LCO A1[7,9] | Type de la machine à saisir (* si pas de contrôle)
LCO A1[10] | Saisie du code opération (section, opération ou sous-section) (O/N)
LCO A1[11] | Saisie du code machine (O/N)
LCO A1[12] | Saisie du code de difficulté (O/N)
LCO A1[13] | Saisie du code matière (O/N/X) La valeur X permet de désactiver le contrôle existence de la matière UNIQUEMENT SUR LA NOUVELLE SAISIE !
LCO A1[14] | Saisie de la valeur numérique 1 (O/N)
LCO A1[15] | Saisie de la valeur numérique 2 (O/N)
LCO A1[16] | Saisie de la zone alpha 1 (O/N) La valeur saisie en alpha 1 doit être O ou N : O L'entité doit être éditée sur l'offre de prix client (par défaut) N L'entité ne doit pas être éditée sur l'offre de prix client
LCO A1[17] | Saisie de la zone alpha 2 (O/N)
LCO A1[18] | Saisie du code section seul et non du code opération complet (O/N)
LCO A1[19] | Zone opération. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[20] | Zone machine. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[21] | Code difficulté. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[22] | Code matière. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[23] | Valeur numérique 1. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[24] | Valeur numérique 2. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[25] | Valeur alpha 1. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[26] | Valeur alpha 2. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[27] | Code section. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[28] | Code fournisseur. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[29] | Saisie de la valeur numérique 3 (O/N, N par défaut)
LCO A1[30] | Saisie de la valeur numérique 4 (O/N, N par défaut)
LCO A1[31] | Saisie de la valeur alphanumérique 3 (O/N, N par défaut)
LCO A1[32,34] | Type de paramètre associé à la 3ième zone alphanumérique de 3 caractères (fc_a3) * : Pas de contrôle
LCO A1[35] | Saisie de la valeur alphanumérique 4 (O/N, N par défaut)
LCO A1[36,38] | Type de paramètre associé à la 4ième zone alphanumérique de 3 caractères (fc_a4) * : Pas de contrôle
LCO A1[39] | Saisie de la première ligne de note (O/N, N par défaut) Voir aussi LCO A1[46] ci-dessous Notes commençant par # avec le code E Note ORDRE_ELEMENT, car. 41-42
LCO A1[40] | Saisie code fournisseur (O/N)
LCO A1[41] | LCO copiée lors d'un éclatement d'amalgame (O/N, N par défaut) (touche F27 sur l'entité devis car)
LCO A1[42] | Valeur numérique 3. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[43] | Valeur numérique 4. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[44] | Valeur alpha 3. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[45] | Valeur alpha 4. O=Obligatoire, I=Interdit, N=Facultatif (par défaut)
LCO A1[46] | Contrôle de la saisie de la première ligne de note Voir LCO A1[39] O Saisie obligatoire I Saisie interdite N Saisie facultative (par défaut)

Valeur alpha 2

LCO A2[1,12]

Libellé pour la zone numérique 1

LCO A2[13,24]

Libellé pour la zone numérique 2

LCO A2[25,36]

Libellé pour la zone alphanumérique 1

LCO A2[37,48]

Libellé pour la zone alphanumérique 2

LCO A2[49]

O Dans la nouvelle saisie, la ligne n'est pas saisissable

Autre La ligne reste saisissable

LCO A2[50,52]

Code complément associé (doit correspondre à un paramètre de type CPL)

Permet, dans la saisie des lignes complémentaires (écran spécifique via la touche F13 ou écran d'entité de saisie LCO), de gérer des boutons de regroupement.

Remarques :

• Une LCO peut être associée à un seul bouton (20 boutons au maximum).

• Si le paramétrage du complément est incorrect (numéro d'indice inexistant ou hors limites), les données de la LCO seront affichées dans les données générales (premier bouton Données).

• Les compléments ne sont pas gérés dans le cadre des LCO contextuelles (les boutons n'apparaissent pas et les données affichées peuvent concerner des compléments différents).

Valeur alpha 3

LCO A3[1] | Permet de choisir le type de fenêtre de sélection qui s'ouvre lors d'un F7 sur une zone code matière 1 Fenêtre de sélection de type 1 2 Fenêtre de sélection de type 2 3 Fenêtre de sélection de type 3 N Pas d'ouverture de fenêtre de sélection (sélection de tous les codes articles)
LCO A3[2] | LCO utilisée pour la sauvegarde des totaux placements/coupes de la phase. Déclenche l'ouverture automatique de la saisie lors du passage sur la valeur numérique 1 (O/N, N par défaut)
LCO A3[3] | Conversion de la zone numérique fc_v1 de la table fle_com dans l'outil de bascule EURO (bascule_euro_fle_com) O/N
LCO A3[4] | Conversion de la zone numérique fc_v2 de la table fle_com dans l'outil de bascule EURO (bascule_euro_fle_com) O/N

Valeur alpha 4

LCO A4[1,12] | Libellé pour la zone numérique 3
LCO A4[13,24] | Libellé pour la zone numérique 4
LCO A4[25,36] | Libellé pour la zone alphanumérique 3
LCO A4[37,48] | Libellé pour la zone alphanumérique 4

Notes

D'autres actions sont réalisables depuis les notes sur la formule.

Notes commençant par un dièse

#

Question dans le nouveau mode de saisie

2 Code de la zone

3,57 Question

58,59 Code langue (en, pl, ...)

On ne peut pas modifier le libellé d'une question de code langue français lorsque la langue courante est étrangère.

Obligation de paramétrer une question avec le code de la langue étrangère.

#C

Possibilité de compléter le test d'activation / désactivation d'une phase en utilisant une autre LCO.

3,5 Code LCO à compléter

6,8 Phase à activer / désactiver

9,11 Activation/Désactivation à compléter (sur le 1er LCO testé) (ACT ou AC> ou AC< ou DES ou DE> ou DE<)

12 Code de la zone

13 Signe du test (=,<,>,!)

14,28 Valeur à tester

29,31 Code LCO venant compléter le test

Exemple

1er LCO (LC1) :

#YDDEBDES5 LC2

Phase DEBobinage DESactiveé si réponse Difficulté = 5 et si le test sur la LCO LC2 est validé.

2ème LCO (LC2) :

#CLC1DEBDESA=OUI

Test sur la LCO LC2 venant compléter le test sur LC1 : DESactivation si valeur alpha1 = OUI

#EDD

#EDS

Edition des lignes complémentaires sur édition technique du devis.

#EDD pour l'édition détaillée

#EDS pour l'édition simplifiée

Si ces notes n'existent pas, on édite toutes les rubriques.

Pour chaque paramètre, répondre O ou [espace] pour éditer, N pour ne pas éditer.

5 Code opération

6 Code machine

7 Code difficulté

8 Code matière

9 Valeur numérique 1

10 Valeur numérique 2

11 Valeur alpha 1

12 Valeur alpha 2

13 Code section

14 Code fournisseur

15 Edition de la zone numérique 3 (O/N, O par défaut)

16 Edition de la zone numérique 4 (O/N, O par défaut)

17 Edition de la zone alphanumérique 3 (O/N, O par défaut)

18 Edition de la zone alphanumérique 4 (O/N, O par défaut)

#Q

Mode question sur réponse

3 Code de la zone (Fonctionne uniquement avec les codes zones A et B)

5,56 Question LCO associée à la réponse

#X

Possibilité de définir une valeur par défaut si la zone est à blanc ou nulle

3 Type de la zone à mettre à jour

1 Zone numérique 1

2 Zone numérique 2

3 Zone numérique 3

4 Zone numérique 4

A Zone alphanumérique 1

B Zone alphanumérique 2

G Zone alphanumérique 3

H Zone alphanumérique 4

4,60 Valeur par défaut

#Y

Possibilité de définir des phases à activer suivant la réponse dans une des rubriques choisies.

3 Code de la zone

4,6 Code de la phase à activer ou désactiver

7,9 ACT Activer

AC> Activer si la valeur est supérieure

AC< Activer si la valeur est inférieure

AC! Activer si différent

DES Désactiver

DE> Désactiver si la valeur est supérieure

DE< Désactiver si la valeur est inférieure

DE! Désactiver si différent

10,22 Valeur (réponse) qui déclenche l' activation ou la désactivation.

Si vous désirez comparer avec la valeur nulle, vous devez saisir #.

25,27 Code LCO venant compléter le test (voir note #C)

Exemples

#YDDEBDES5 Phase DEBobinage DESactivée si réponse Difficulté 5

#YDDEBDES9 Phase DEBobinage DESactivée si réponse Difficulté 9

#YDDEBACT2 Phase DEBobinage activée si réponse difficulté 2

#Z

Complément de sélection lors de la consultation par F7 (uniquement sur la nouvelle saisie)

3 Code de la zone - zones possibles au 20/12/2007

F Code fournisseur

G Zone alphanumérique 3

H Zone alphanumérique 4

M Matière

N Machine

A Code paramètre 1 (valeur alpha 1)

B Code paramètre 2 (valeur alpha 2)

D Code difficulté

4,60 Complément de select introduit par and.

Autres notes

CODE_ACC_VISU_MAT_1

Voir plus bas TYPE_ACC_VISU_MAT_1 et CODE_ACC_VISU_MAT_1

CONTEXTE_LCO

Ouverture contextuelle des LCO

L'ouverture contextuelle des LCO est conditionnée par les paramètres suivants :

#CF DEG alpha4[9] = O

PHA alpha3[60] = O

21,40 Nom du champ où ouvrir la fenêtre de saisie contextuelle des LCO

Pour tous les écrans : fi_prod_ent (code produit de l'entité)

Pour l'écran de devis : l2_code_prod (code produit du devis)

Pour les entités (devis standard) : Voir plus bas la liste des zones possibles

Pour les phases (devis_tc - devis_car - devis_ser - devis - devis_standard) :

dans ce cas, le paramétrage au-delà du car.40 est ignoré.

fi_co_recto

fi_jonction

fi_colisage

...

phase_XXX où XXX représente le code de la phase (exemple : phase_DEC)

VALIDE_LIGIMP Ouverture à la validation de l'écran de saisie des lignes d'impressions multiples)

41 Non utilisé

42 Critère d'ouverture de la fenêtre :

(Non utilisé dans le cadre d'une ouverture à la validation d'un écran)

A Ouverture si la valeur champ <= la valeur paramétrée dans les caractères 45 à 60

B Ouverture si la valeur champ >= la valeur paramétrée dans les caractères 45 à 60

D Ouverture si la valeur du champ ¹ la valeur paramétrée dans les caractères 45 à 60

F Ouverture sur la frappe d'une touche dans le champ

M Ouverture en cas de modification du champ

S Ouverture systématique après le champ (par défaut)

V Ouverture si la valeur du champ = la valeur paramétrée dans les caractères 45 à 60

< Ouverture si la valeur du champ < la valeur paramétrée dans les caractères 45 à 60

> Ouverture si la valeur champ > la valeur paramétrée dans les caractères 45 à 60

2 Ouverture si les conditions M et V sont vérifiées

3 Ouverture si les conditions F et V sont vérifiées

4 Ouverture si les conditions M et D sont vérifiées

5 Ouverture si les conditions F et D sont vérifiées

6 Ouverture si les conditions M et < sont vérifiées

7 Ouverture si les conditions M et A sont vérifiées

8 Ouverture si les conditions M et > sont vérifiées

9 Ouverture si les conditions M et B sont vérifiées

43 Chargement complet de toutes les LCO (si le critère d'ouverture est vérifié) (O/N, N par défaut)

Permet d'ouvrir la saisie des LCO complète lors de l'ouverture contextuelle sur une zone.

Le chargement complet est activé à partir du moment où au moins une LCO contextuelle est paramétrée avec ce fonctionnement sur une zone de saisie (sinon, on ne charge que les LCO concernées par le contexte comme auparavant).

Le critère d'ouverture des LCO contextuelles reste valable même dans le cas d'une ouverture avec chargement complet.

44 Non utilisé

45,60 Valeur à comparer avec la valeur du champ pour les critères d’ouverture impliquant une comparaison avec la valeur du champ saisi

MAJ_AVEC_ZONE_LCO_

Mise à jour de champs à partir de valeurs de LCO

19 Code la zone LCO

21,38 Nom du champ à mettre à jour avec la valeur de la zone LCO

Tous les champs de l'entête du devis (fle_2.l2_*)

Tous les champs de l'entité du devis (fle_imp.fi_*)

Permet, lors de la validation de saisie de LCO dans le devis multi-métiers, de mettre à jour un ou plusieurs champ(s) de l'entête (fle_2) ou de l'entité (fle_imp) à partir des valeurs des LCO.

Remarques :

• Ce fonctionnement est valable pour la saisie standard des LCO (ancien/nouveau mode)

• La mise à jour des champs de l'entête/entité se fait à la validation de la saisie des LCO, uniquement pour les LCO en cours de saisie

ORDRE_ELEMENT

(avec un espace à la fin !) Ordre de saisie des éléments de la LCO

Si cette ligne n'est pas renseignée, on conserve l'ordre d'apparition habituel.

15,16 Ordre de saisie du code machine

17,18 Ordre de saisie du code difficulté

19,20 Ordre de saisie du code matière

21,22 Ordre de saisie de la valeur 1

23,24 Ordre de saisie de la valeur 2

25,26 Ordre de saisie de la zone alpha 1

27,28 Ordre de saisie de la zone alpha 2

29,30 Ordre de saisie de l'opération

31,32 Ordre de saisie du code fournisseur

33,34 Ordre de saisie de la zone numérique 3

35,36 Ordre de saisie de la zone numérique 4

37,38 Ordre de saisie de la zone alphanumérique 3

39,40 Ordre de saisie de la zone alphanumérique 4

41,42 Ordre de saisie de la première ligne de note (zone E)

Voir LCO A1[39]

ORDRE_OPERATION

Ordre des opérations

21,23 Code section

24,26 Code opération

27,29 Code sous-opération

30,32 N° formule dans la phase

33 O (lettre O majuscule)

34 Type opération

F Feuilles

A Amalgames

E Etuis

TYPE_NOTE_ASSOCIE

Associer des types de notes par code LCO

21,23 Type de notes (correspond à un type de paramètre NTS)

24,26 Code phase

27,29 Code formule

30 Type de formule

M Formule matière

O Formule opération

S Formule sous-traitance

Remarques

• Si le triplet phase/formule/type de formule existe dans le devis, les notes seront également accessibles dans la formule correspondante.

• Si le code formule et le type de formule ne sont pas renseignés, la note sera associée à la phase (les notes seront donc visibles au niveau de l'écran de saisie de la gamme)

TYPE_ACC_VISU_MAT_1

CODE_ACC_VISU_MAT_1

21,23 Type de paramètre de lancement de la visualisation des matières à utiliser en tant que recherche d'article

21,23 Code de paramètre de lancement de la visualisation des matières à utiliser en tant que recherche d'article

Les mêmes notes existent aussi au niveau du TSC.

Par défaut, on prend le paramètre de lancement paramétré sur le paramètre de lancement du programme en cours d'utilisation (par exemple, la saisie des devis dans le cas d'une recherche faite sur une LCO)

ATTENTION : voir aussi #CF RMP

VERIF_VAL_FORMULE

Lancer une vérification de valeurs par le paramétrage d'une formule de calcul après la saisie de la LCO.

Voir le paragraphe concerné dans le devis standard.

21 Code de la zone LCO

22,24 Code phase (de la formule de contrôle)

25,27 Code formule (de la formule de contrôle)

28 Type de contrôle

W Contrôle non bloquant

B Contrôle bloquant

N Pas de contrôle

Par défaut : on garde le fonctionnement actuel (Formule de contrôle, zone CAD/2, caractère 1).

ZONE_TRANSPORT_GEN

Dans le devis multi-métiers, il est possible actuellement de paramétrer sur des formules de sous-traitance une génération automatique d'une ligne de transport interne.

Ce paramétrage nécessite la mise en place d'une ligne LCO dédiée à cette génération.

Le but de ce développement est de permettre le paramétrage dans les lignes de notes de la LCO dédiée des valeurs qui sont figées sur la ligne de transport générée.

21,40 Code la zone figée parmi :

ft_transp

ft_nature

ft_adr

ft_nom

ft_adr1

ft_adr2

ft_cpos

ft_ville

ft_type

ft_origine

ft_pays

41,60 Valeur d'initialisation de la zone

Zones actives pour les LCO contextuelles (notes CONTEXTE_LCO)

Les zones sont triées par ordre alphabétique.

Des tableaux similaires existent aussi pour les types d'entités.

Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
code_adhesif | Code de l'adhésif |  |  | l |  |
code_dorsal | Code de support dorsal |  |  | l |  |
code_frontal | Code de support frontal |  |  | l |  |
de_pres_depassant | N° du pli ayant un dépassant (0 aucun) |  | l |  |  |
de_type_pli | Type de pli principal |  | l |  |  |
de_type_pli1 | Type de pli 1 |  | l |  |  |
de_type_pli2 | Type de pli 2 |  | l |  |  |
de_type_pli3 | Type de pli 3 |  | l |  |  |
de_type_pli4 | Type de pli 4 |  | l |  |  |
de_type_pli5 | Type de pli 5 |  | l |  |  |
fi_accessoires | Présence d'accessoires | l | l |  |  | l
fi_bat | Présence de bon à tirer | l | l | l | l |
fi_cgt_r | Nombre de changements de plaque au recto | l | l | l | l |
fi_cgt_v | Nombre de changements de plaque au verso | l | l | l | l |
fi_cgt_r_r | Nombre de repiquages au recto |  | l |  |  |
fi_cgt_v_r | Nombre de repiquages au verso |  | l |  |  |
fi_cgt_teinte_r | Nombre de changements de teinte au recto | l | l | l | l |
fi_cgt_teinte_v | Nombre de changements de teinte au verso | l | l | l | l |
fi_c_papier | Référence du support | l | l | l | l | l
fi_co_recto | Nombre de couleurs recto | l | l | l | l | l
fi_co_verso | Nombre de couleurs verso | l | l | l | l |
fi_collage | Présence de collage | l |  |  |  |
fi_conditionnement | Présence de conditionnement |  |  | l | l |
fi_contre_collage | Présence de contre-collage | l |  |  |  | l
fi_dorure | Présence de dorure | l | l | l | l |
fi_ecma | Code contour | l |  | l | l | l
fi_enc_r | Coefficient d'encrage recto | l | l | l | l |
fi_enc_v | Coefficient d'encrage verso | l | l | l | l |
fi_epreuve | Épreuve | l | l | l | l |
fi_equerre | Présence de massicot | l | l |  |  | l
Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
fi_fenetrage | Présence de fenêtrage | l |  |  |  |
fi_foulage | Présence de foulage |  | l | l | l |
fi_fournisseur | Code fournisseur du support |  | l |  | l |
fi_gaufrage | Présence de gaufrage | l | l | l | l |
fi_jonction | Présence de jonctionnement (n'est pas dans la table fle_imp) |  |  |  |  | l
fi_mac_forcee_r | Machine forcée au recto | l | l | l | l |
fi_mac_forcee_v | Machine forcée au verso | l | l | l | l |
fi_mac_imp | Machine d'impression au recto | l | l | l | l |
fi_mac_imp2 | Machine d'impression au verso | l | l | l | l |
fi_manuel | Présence d'opérations manuelles | l |  | l | l | l
fi_maquette | Maquette | l | l | l | l |
fi_mode_tirage | Mode de tirage | l |  |  |  |
fi_nb_decoupe | Présence de découpe | l | l | l | l |
fi_nb_poses | Nombre de poses | l |  |  |  |
fi_num_forme | Numéro de la forme de découpe | l |  | l | l | l
fi_num_plan_cao | Numéro d'étude | l |  | l | l | l
fi_numerotage | Présence de numérotage |  | l | l | l |
fi_pap_stk | Mode de réapprovisionnement | l |  |  |  |
fi_perfo | Présence de perforation |  | l | l | l |
fi_perso | Autres (personnalisation) | l | l | l | l | l
fi_photocompo | Photocomposition | l | l | l | l |
fi_photogravure | Photogravure | l | l | l | l |
fi_pliage_mach | Présence de pliage machine |  | l |  |  |
fi_pres_vernis_hl | Présence de vernis hors ligne | l | l |  | l |
fi_pres_vernis_st | Présence de vernis sous-traitance | l | l |  |  |
fi_pr_recto | Nombre de couleurs primaires au recto | l | l |  |  |
Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
fi_pr_verso | Nombre de couleurs primaires au verso | l | l |  |  |
fi_rainage | Présence de rainage |  | l |  |  |
fi_transfert | Présence de poudrage |  | l | l | l |
fi_type_jonction | Type de jonctionnement |  |  |  |  | l
fi_type_pellic | Type de pelliculage | l | l | l | l |
fi_type_pre_presse | Type de pré-presse | l | l | l | l |
fi_type_vernis_r | Type de vernis au recto | l | l | l | l |
fi_type_vernis_v | Type de vernis au verso | l | l | l | l |
fi_type_verso | Type d'impression verso |  |  | l |  |
fi_typons | Éléments fournis | l | l | l | l |
fi_ve_recto | Coefficient de vernissage au recto | l | l | l | l |
fi_ve_verso | Coefficient de vernissage au verso | l | l | l | l |
fi_vernis_hl | Type de vernis hors-ligne | l |  | l | l |
fi_zpar | Type d'imposition | l |  |  |  |
fi_zpar2 | Type de conditionnement |  |  | l |  |
fi_zpar3 | Sens d'enroulement |  |  | l |  |
lm_ex_par_paq | Nombre d'exemplaires par paquet | l | l |  | l |
lm_nb_cai | Nombre de caisses | l | l |  | l |
lm_nb_pal | Nombre de palettes | l | l |  | l |
lm_nb_paq | Nombre de paquets | l | l |  | l |
lm_poids_cai | Poids de la caisse (en Kg) | l | l |  | l |
lm_poids_pal | Poids de la palette (en Kg) | l | l |  | l |
nb_etiq_front | Nombre d'étiquettes de front |  |  | l |  |
phase_XXX |  |  |  |  |  |
presence_outil | Présence outil (0 : non saisi ou générique, 1 : saisi et non générique) |  |  | l |  |
Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR

Génération automatique du transport de sous-traitance

Permettre de générer automatiquement un enregistrement de transport de sous-traitance (port interne).

Le transport est généré selon le paramétrage de la dépendance 2 (Génér.Transport).

Cette nouvelle dépendance doit renvoyer un code LCO de génération de transport, dont les zones seront renseignées dans l'entité en cours (voir paramétrage ci-dessous).

Zone LCO | Type de donnée | Vérification | Description | Zone calculée de formule
A | Alpha (1) | Type de paramètre (NTR) | Nature du transport |
B | Alpha (2) | Type de paramètre (POR) | Type de port |
1 | Numérique (1) |  | Nombre de trajets (1) | Dimension 1 (fs_num_1) (2)
2 | Numérique (2) |  | Poids transporté | Dimension 2 (fs_num_2) (2)
 |  |  | Quantité livrée | Dimension 3 (fs_num_3) (2)
M | Alpha (matière) | Code matière (mat) | Code palette (1) |
F | Alpha (fournisseur) | Code client (cli) | Code transporteur |

(1) Ces zones sont obligatoires. Le transport ne sera pas généré (ou supprimé s'il existe déjà) si elles ne sont pas saisies.

Si le poids n'est pas saisi sur la LCO, il sera calculé automatiquement lors du calcul du transport, sinon il sera considéré comme étant forcé.

(2) Si les zones calculées sur la formule ramènent un résultat, ces valeurs sont prioritaires aux valeurs renseignées sur la LCO.


LCO Codes zones

Codes zones LCO

Ces zones sont enregistrées dans la table fle_com.

1 Valeur numérique 1 - fc_v1

2 Valeur numérique 2 - fc_v2

3 Valeur numérique 3 - fc_v3

4 Valeur numérique 4 - fc_v4

A Valeur alpha 1 - fc_a1

B Valeur alpha 2 - fc_a2

D Code difficulté - fc_dif

E Première ligne de note du premier type de note associé à la LCO

Voir LCO A1[39]

F Code fournisseur - fc_fournisseur

G Valeur alpha 3 - fc_a3

H Valeur alpha 4 - fc_a4

M Code matière - fc_matiere

N Code machine - fc_machine

O Code opération - fc_ope

P Code sous-opération - fc_sop

S Code section - fc_sec

T Triplet section/opération/sous-opération fc_sec + fc_ope + fc_sop


LCO Syntaxe d'appel

Initialement accessible en visu de devis feuille, de paramétrage est également accessible dans la fonction de lancement de programmes par la touche Ctrl J.

Syntaxe d'appel des LCO :

LCO_O_LLL_Z_LIB

LCO | Mot-clé indiquant une LCO
O | Origine de la LCO E Entête du sous-devis D Entité (par défaut) C Cascade (entité puis entête du sous-devis si la LCO n'existe pas sur l'entité)
LLL | Code de la LCO (ex : D16, T16, COM…)
Z | Code zone de la LCO
LIB | (optionnel) Méthode d'affichage. Il existe 4 méthodes d'affichage des LCO : LIB Libellé de la valeur de la LCO. Fonctionne avec M, N, O, F LIBC Libellé court du paramètre correspondant. Fonctionne avec Z = S, A, B, D, G ou H LIBL Libellé long du paramètre correspondant. Fonctionne avec Z = S, A, B, D, G ou H Autre Valeur saisie dans la LCO


LDE Ligne détail

Insertion simplifiées dans les notes (actif dans la saisie des notes du devis arts graphiques)

Valeur alpha1

LDE A1[1,8] | Numéro de devis à copier
LDE A1[9,10] | Numéro de sous-devis à copier

La copie concerne les notes de type TEC

Notes

(Récupérer par la touche F8 en saisie)

Saisie libre des notes à récupérer


LIB Paramétrage des libellés

Codes possibles

ARR | Libellés des types d'arrêts
DTn | (0 < n < 9) Libellés des données techniques numériques - Voir description plus bas
ATn | (0 < n < 3) Libellés des données techniques alphanumériques - Voir description plus bas
PRn | (0 < N < 10) VoluGold : Suivi des tiers
CSn | (0 < n < 5) Libellés des codes statistiques

Valeur alpha 1

LIB A1[1,50]

Si code = DTn ou ATn : Libellé paramètre fiche article

Si code = ARR

LIB A1[1,15] Libellé type arrêt 1 (exemple : Entretien)

LIB A1[16,30] Libellé type arrêt 2 (exemple : Gestion)

LIB A1[31,45] Libellé type arrêt 3 (exemple : Divers)

Valeur alpha 2

LIB A2[1,60]

Si code = DTn ou ATn : Compte pour transfert en compta

Valeur alpha 3

LIB A3[1] | Si code = DTn ou ATn : Contrôle de saisie des données techniques B Contrôle bloquant si la saisie n'est pas faite W Message d'avertissement non bloquant N Pas de contrôle (valeur par défaut
LIB A3[2] | Si code = DTn : Conversion des zones de données techniques numériques de la table mat dans l'outil de bascule EURO (bascule_euro_base) (O/N)

Notes

LIB_TYPE_FAM_ | 14,16 code famille de regroupement 21,51 Libellé des données techniques en fonction de la famille de regroupement Exemple : LIB_TYPE_FAM_PAP Seuil Laize Exacte (Famille PAPier) Uniquement pour les données techniques numériques (codes DT1 à DT8).
LIB_TYPE_MP_ | 13 type d'article utilisé (M, P, S, F, X, O, T, K, Q) 21,51 Libellé des données techniques en fonction du type d'article Uniquement pour les données techniques numériques (codes DT1 à DT8).
LIBELLE_CODE_STAT_ | 19 type d'article utilisé M Matière première P Produit fini S Produit semi-fini F Fourniture X Fantôme O Outil T Maintenance K Kit Q Qualité matière 21,60 Libellé du code statistique pour le type d'article paramétré.
LIBELLE_CS_ | Paramétrer le libellé des Codes statistiques 1 à 4 en fonction de la famille et de la sous famille 12,14 Code famille 15,17 Code sous-famille

Description des codes DTn et ATn

Code DT1

Libellé donnée technique 1 (exemple : consommation encre en g/m2)

NE PAS UTILISER EN PRESENCE DU DEVIS

Dans le devis feuille et ses dérivés, cette donnée technique est souvent utilisée en tant que consommation d'encre en g/m2.

Exemples

Code calcul EN (consommation encre et vernis)

Formules figées suivantes :

M CAR 4

M CAR 5

M CAR 6 La donnée technique 1 est ici utilisée en tant que distance entre 2 agrafes

M CAR 9 La donnée technique 1 est ici utilisée en tant que consommation moyenne de film par palette

M CAR 10

M IMF 1

M IMF 2

M IMF 3

M IMF 4

M IMF 6

M VER 3

Code DT2

Libellé donnée technique 2 (exemple : poids maxi caisse ou palette)

NE PAS UTILISER EN PRESENCE DU DEVIS

Nombre d'exemplaires maxi - Volume maxi

Dans le devis feuille et ses dérivés, cette donnée technique est souvent utilisée en tant que poids maxi d'un emballage.

Les différents emballages : Le paquet, la caisse, la palette.

Selon #CFDEG A3[54], dans le cas du paquet, la donnée technique 2 sera utilisée en tant que nombre maxi d'exemplaires par paquet.

Le code calcul CD permet aussi de calculer un nombre de palettes en utilisant cette donnée en tant que volume maxi d'une palette.

La donnée technique 2 est utilisée dans :

La gestion du conditionnement (F22 fle_emb)

Le calcul du coût de transport

Les codes calculs suivants :

CD (conditionnement)

DI (calcul et stockage du nombre de palettes)

Les formules figées suivantes :

M CAR 8

M EMC 1

M EMF 2

M EMM 1

M EMP 1

O EMC 1

O EMF 2

O EMP 1

Code DT3

Libellé donnée technique 3 (exemple : gâche fixe)

NE PAS UTILISER EN PRESENCE DU DEVIS

Dans le devis feuille et ses dérivés, cette donnée technique est partout utilisée en tant que gâche fixe.

Code DT4

Libellé donnée technique 4 (exemple : gâche variable)

NE PAS UTILISER EN PRESENCE DU DEVIS

Dans le devis feuille et ses dérivés, cette donnée technique est partout utilisée en tant que gâche variable.

Code DT5

Libellé donnée technique 5 (exemple : coût fixe sous-traitance)

NE PAS UTILISER EN PRESENCE DU DEVIS

Dans le devis feuille et ses dérivés, cette donnée technique est utilisée en tant que coût fixe pour les formules de sous-traitance.

Code DT6

Libellé donnée technique 6

Code DT7

Libellé donnée technique 7

Code DT8

Libellé donnée technique 8

Code AT1

Libellé donnée alphanumérique 1

Code AT2

Libellé donnée alphanumérique 2


LIE Type de liaison entête de commande client

Valeur alpha 1

LIE A1[1]

Type de contrôle à exercer

N Pas de contrôle

R Référence d'une commande du client de la commande

C Numéro d'une commande du client de la commande

L Numéro d'une ligne de commande du client de la commande (Non géré)

A Code d'un article du client de la commande

S Lieux de rangement (lié au type de la commande, alpha3[57,58])

P La référence liaison est paramétrable

E Code d'un article du client de la commande (client noté sur la fiche ou via le libellé étranger)

LIE A1[2,4]

Type de paramètre à saisir (dans le cas d'un type de contrôle <P>)

La référence liaison sera un code paramètre associé à ce type.

Par défaut, on prend comme type de paramètre le code saisi dans la zone Type de liaison.

LIE A1[5]

Type de liaison contrat, contrôle de la référence liaison (O/N)

Le numéro saisi doit être un numéro de contrat valide.

Si le contrôle de référence liaison n'est pas positionné, l'EDI Invoice considèrera que la référence de liaison saisie n'est pas une commande de contrat valide et alors conservera la prise de la référence sur la commande facturée.

LIE A1[6]

Type de complément de recherche F7 sur produit

1 Complément de recherche sur le client de la table des libellés spécifiques (lib_etr.le_client) avec le client de l'entête de la commande

2 Complément de recherche sur le client de la table des articles avec le client de l'entête de la commande. Le F7 présente uniquement les articles du client.

3 Le F7 présente uniquement les articles du client ET les articles qui ne sont pas associés à un client.

4 Aucun complément (recherche standard des articles)

5 Le F7 présente uniquement les articles du contrat lié à la commande en cours

6 Le F7 présente uniquement les articles dont les codes génériques sont les articles du contrat lié à la commande en cours.

L'ordre de priorité est le suivant :

1) Saisie des commandes clients, option Ofc

2) LIE A1[6] (ici)

3) #CF CDE A1[48]

Notes

FA GENERO uniquement | Lancement automatique des touches de fonction après la validation de la saisie du dernier champ de la ligne de commande 3 L Ligne 4,6 Touche de FonctionF31 Saisie des cadencements de livraison 7 Lancement en création (O/N, N par défaut) 8 Lancement en modification (O/N, N par défaut) Exemple FALF31
SUP_REQ_LIE | 21 à 60 Complément de requête pour la recherche de la référence de liaison Exemple : and mat.mp_mp = "X" Remarque : Les tables accessibles par le complément de requête paramétré dépendent du type de liaison, c'est pourquoi elles ne sont pas stipulées ici.


MAT Catégories de matières

Paramétrage libre. Il joue sur les tableaux récapitulatifs du devis.

Exemple Frais fixes et variables de premier établissement.

Valeurs numériques

MAT N1 | Borne inférieure pour le taux de commission
MAT N2 | Borne supérieure pour le taux de commission

Valeur alpha 1

MAT A1[1] | 0 Rien 1 Livré séparément 2 Livré sur-emballé
MAT A1[2] | 0 Rien 1 Composé de

Valeur alpha 2

MAT A2[1,3] | Sur-catégorie de produit
MAT A2[4,11] | Date limite de souscription pour la prise en compte des remises temporaires ad valorem (Spécifique client) Sous la forme JJMMAAAA
MAT A2[12,15] | Section analytique pour transfert comptabilité Sage ligne 500 Anciennement caractères 12 à 13 pour sous-section.
MAT A2[16,19] | Section analytique pour transfert comptabilité Sage ligne 500

Notes

PACK_STARTER_ALM

Réservé


MDA Motif de la demande d'achat

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

MDA A1[1,3]

Code état rattaché au motif


MDB Motifs de déblocage

Aide générale au paramétrage d'un motif de déblocage d'une commande dans la revue de contrat.

Libellé long

Description du motif de déblocage

Valeurs numériques

MDB N1 | Valeur de stockage du motif de déblocage dans la table info_c. Cette valeur doit être négative.
MDB N2 | Si on a débloqué un devis via un motif, permet d'empêcher le re-blocage en automatique 1 On refait le calcul du blocage automatique. 0 Le blocage a été désactivé, on ne refait pas de calcul.

Valeur alpha1

MDB A1[1,2]

Délai de conservation du déblocage, avant mise à jour par le re-calcul du devis

Exemple : 01 (le déblocage est conservé toute la journée)

Notes

CODES_BLOCAGE_ASS

Jusqu'à 10 codes blocage, séparés par des espaces

21,23 Code blocage associé N° 1

25,27 Code blocage associé N° 2

29,31 Code blocage associé N° 3

33,35 Code blocage associé N° 4

37,39 Code blocage associé N° 5

41,43 Code blocage associé N° 6

45,47 Code blocage associé N° 7

49,51 Code blocage associé N° 8

53,55 Code blocage associé N° 9

57,59 Code blocage associé N° 10

Les codes blocages peuvent être des types suivants :

BLO pour les commandes clients

BLD pour le devis multi-métiers

BLF pour les commandes d'achat

Dès que l'on rencontre plus d'un espace, on arrête la lecture du paramétrage (les codes paramétrés après ne sont pas pris en compte).


MDO Modèles de documents

Voir en bas de page les notes de type MDO sur cli3.

Valeur alpha 1

MDO A1[1,8] | Nom du modèle d'étiquette pour le fond de page APPIC
MDO A1[9] |
MDO A1[10] | Coefficient multiplicateur O Le nombre d'étiquettes calculé est multiplié par la quantité renseignée sur la fiche client N Le nombre d'étiquettes calculé n'est pas multiplié par la quantité renseignée sur la fiche client
MDO A1[11] | Mode de facturation. Spécifique 1 Standard 2 Avec le mille plus ou moins
MDO A1[12] | Edition du détail de prix dans la facture. Spécifique O Edition du détail. Nécessite que caractère 11 = 2 N Pas d'édition du détail (par défaut)
MDO A1[13,20] | Valeur de la variable modele_document transmise à VOLUEDIT Elle permet de conditionner certaines mises en forme.

Valeur alpha 2

Etiquettes production

MDO A2[1]

Type de note 1

Valeur 7 : Type de note 1 avec cascade notes sur ligne de commande/ notes sur produit

MDO A2[2]

Type de note 2

Valeur 7 : Type de note 2 avec cascade notes sur ligne de commande/ notes sur produit

MDO A2[3]

Type de note 3

Valeur 7 : Type de note 2 avec cascade notes sur ligne de commande/ notes sur produit

Avec type de note 1 : Note sur ligne de commande

Avec type de note 2 : Note sur ligne de BL

Avec type de note 3 : Note sur tiers

Avec type de note 4 : Note sur ensemble

Avec type de note 5 : Note sur produit fini

Avec type de note 6 : Note sur commande

MDO A2[4]

Etiquette neutre (O/N)

Par défaut : N

Si O alors pas de quantité sur dernière étiquette du flot

MDO A2[5]

Coupure automatique du nom de client pour une édition sur deux lignes

MDO A2[6,7]

Nombre de caractères maximum pour une ligne

Par défaut : 20 caractères

MDO A2[8]

Zone spécifique de destination de la première ligne de nom de client créé

1 Zone spécifique 1

2 Zone spécifique 2

3 Zone spécifique 3

4 Zone spécifique 4

5 Zone spécifique 5

6 Zone spécifique 6

7 Zone spécifique 7

8 Zone spécifique 8

9 Zone spécifique 9 (par défaut)

0 Zone spécifique 10

MDO A2[9]

Zone spécifique de destination de la deuxième ligne de nom de client créé

1 Zone spécifique 1

2 Zone spécifique 2

3 Zone spécifique 3

4 Zone spécifique 4

5 Zone spécifique 5

6 Zone spécifique 6

7 Zone spécifique 7

8 Zone spécifique 8

9 Zone spécifique 9

0 Zone spécifique 10 (par défaut)

MDO A2[10]

Suppression des données de la société émettrice sur l'étiquette neutre

Sur les étiquettes de production neutres, les données de la société destinataire n'apparaissent pas, par contre les données de la société émettrice sont présentes. Un développement a déjà été fait pour paramétrer cette édition sur un TSC de la fiche PF, mais cette édition ne dépend pas de l'article.

Le but de ce développement est de mettre en place un paramétrage plus général de l'édition des données de la société émettrice sur les étiquettes neutres.

O Ces données ne seront pas éditées

N Ces données seront éditées [Valeur par défaut]

Valeur alpha 3

MDO A3[1,8] | Nom de la page de garde d'un envoi par fax
MDO A3[9,16] | Nom de la page de garde d'un envoi par e-mail (non géré)
MDO A3[17,19] | Numéro de modèle de présentation de la facture
MDO A3[20,22] | Numéro d'ordre d'édition des lignes de facture

Notes

APPIC_NB_PAGES_BAC1

21, xx Nombre d'exemplaires sur le premier bac d'imprimante.

Par soustraction on obtient le nombre d'exemplaires sur le second bac.

Le nombre d'exemplaires et les codes du paramètre MDO sont renseignés dans cli6

Ecran de saisie de fiches clients,

F8 puis F23 pour adresse principale

F9 puis F23 pour adresses secondaires

APPIC_NUM_BAC

SUPPRIMEE

Remplacée par une note sur #LP

PAR_LCT_

Permettre de sélectionner un paramètre de lancement d'édition de BL par modèle de document client/adresse de livraison

9,20 Paramétrage sous la forme : [Edition/Réédition]_[Provisoire/Définitive]

[Edition/Réédition] =

EDIT : Edition de bon de livraison

REEDIT : Réédition de bon de livraison

[Provisoire/Définitive] =

PRO : Edition provisoire de bon de livraison

DEF : Edition définitive de bon de livraison

[vide] : Paramétrage de lancement par défaut

21,26 Type et code du paramètre de lancement de l'édition des BL

Exemples

1) PAR_LCT_EDIT_DEF #EDBLD

2) PAR_LCT_REEDIT_PRO #RDBLP

3) PAR_LCT_REEDIT #RDBLV

(1) Paramétrage de lancement de l'édition définitive de BL

(2) Paramétrage de lancement de la réédition provisoire de BL

(3) Paramétrage de lancement de la réédition de BL

Remarques :

Dans les exemples précédents, le paramétrage de lancement de la réédition définitive n'est pas paramétré, c'est donc le paramétrage de réédition par défaut (3) qui sera pris en compte

Si aucun paramètre de lancement n'est trouvé sur le modèle de document, c'est le paramétrage de lancement actuel qui est pris en compte.

Notes de type MDO sur cli3

Ces notes permettent de rechercher le logo adéquat (sur un modèle de document) pour les envoi par FAX.

Principe général : Pour tout type de document (FAC, BL, …excepté AR), on cherche un modèle de document (dans cli6) pour le destinataire (code client + code adresse destinataire). Si on ne trouve pas, on cherche sur l'expéditeur (#SOC + code adresse expéditeur).

Cas particulier : le type Accusé de réception (ACR) : on ne sait pas s'il s'agit d'une commande commerciale ou d'achat.

Afin de lever cette ambiguïté, on paramètre les codes des modèles sur les notes de type MDO avec pour clé #SOC + adresse expéditeur en fonction du type de tiers :

S'il s'agit d'un client, on ira chercher le code associé au paramètre PAGE_DE_GARDE_CDE tandis que si il s'agit d'un fournisseur on ira chercher le code du paramètre PAGE_DE_GARDE_ACHAT.

Si aucun paramétrage, on procède au fonctionnement décrit dans le principe général.

Notes de type MDO sur cli3 : clé #SOC, code adresse

PAGE_DE_GARDE_ACHAT | 21,23 Code Modèle de document (pour commande d'achat)
PAGE_DE_GARDE_CDE | 21,23 Code Modèle de document (pour commande client)


MMD Motif de modification de date

Ce paramètre est associé à la nouvelle zone lc_motif_mod_date ainsi que ses libellés court et long.

Cette zone est utilisée dans tous les programmes de visualisation permettant d'accéder aux informations de la ligne de commande :

v_bonprep / v_cde_5 / v_cde_marche / v_cdef / v_cdem / v_fab0 / v_fab1 / v_fab2 / v_groupage_bl

v_jbl / v_jdv / v_palchep / v_reclamation / v_sbi / v_stk0 / v_stk_lot_lieu / v_tracabilite

Valeur alpha 2

MMD A2[1]

Quelle date de livraison doit-on utiliser pour le calcul de l'OTIF ?

O On utilise la date de livraison proposée (lc_delrep).

N On utilise la date de livraison souhaitée (lc_delcli) (par défaut)

Attention : #CF OTI A2[1,2] doit être = 3.


MOI Code découpage mensuel

Le code découpage mensuel est issu du code calendrier.

Il permet de déterminer le code découpage hebdomadaire de l'employé en fonction de la date scrutée.

Remarque

Le premier jour du mois est toujours dans la semaine numéro 1 du mois.

Chaque lundi, le numéro de semaine augmente de 1.

Un mois est donc composé au maximum de 6 numéros de semaine (soit jusqu'à 4 semaines entières + 2 semaines partielles).

ATTENTION au chevauchement d'une semaine sur deux mois, pour les calendriers définissant un travail en équipe !

Valeurs numériques

MOI N1

Temps dû par défaut si le découpage hebdomadaire n'est pas saisi ou n'est pas trouvé.

Valeur alpha 1

MOI A1[1,3] | Code découpage semaine 1
MOI A1[4,6] | Code découpage semaine 2
MOI A1[7,9] | Code découpage semaine 3
MOI A1[10,12] | Code découpage semaine 4
MOI A1[13,15] | Code découpage semaine 5
MOI A1[16,18] | Code découpage semaine 6


MOR Motifs de retour

Valeur alpha 1

MOR A1[1,3] | Type d'avoir à générer. Paramètre de type TYC
MOR A1[4,6] | Type de mouvement de stock à générer. Paramètre de type TMV
MOR A1[7,9] | Code de valorisation du prix de mouvement de stock PMP Valorisation au PAMP de l'article commandé VAZ Valorisation à zéro

Notes

LIEUX_SITE_

12, 14 Code paramètre SIT du site de production - Tableau de bord du multisite

21, 23 Code paramètre RG1 du lieu de rangement 1

24, 29 Code du lieu de rangement 2


MOT Motif de décision

Utilisé entre autres dans epu_don


MOV Motif de transport

Ce paramètre est opérationnel à partir de la V. 4.1.13.2

Il est utilisé par le programme de saisie des entrées / sorties : suivi_vehicules

Valeur alpha 1

MOV A1[1,3]

Type de document attendu. (Par défaut : aucun)

GBL Groupage BL

BRC Bon de réception


MP1 Types de prix pour calcul devis mécanique

Valeurs numériques

MP1 N1

Choix du type de prix utilisé dans les calculs

1 Prix d'achat

2 Prix de revient

3 Prix de vente


MQA Motif de qualification d'appel

Ce paramètre est activé par l'option Omq de la visualisation de commandes clients.

Valeur alpha 1

MQA A1[1] | Date obligatoire pour ce motif (O/N, N par défaut)
MQA A1[2] | Effacer la date (O/N, N par défaut) Explications dans le paramètre ECA
MQA A1[3] | Contrôle de saisie d'une date antérieure à la date du jour (O/N, O par défaut)


MQS Motif de qualification/surveillance

Sujet : Suivi des commandes de qualification

Accès au suivi des commandes de qualification :

1) dans la saisie des lignes de commandes (Action Produits à qualifier/surveiller)

• L'action Produits à qualifier/surveiller n'est disponible dans le menu que si le type de paramètre Motif de qualification/surveillance existe (MQS).

• L'accès à la saisie des produits à qualifier/surveiller n'est possible que si un des produits composants du produit de la ligne de commande (ou le produit lui-même) est défini comme étant à qualifier ou à surveiller. La nomenclature multi-niveaux est prise en compte.

• L'ouverture de la saisie des produits à qualifier/surveiller est automatique à la création de la ligne de commande ou en modification si le code produit est modifié.

• La saisie des motifs de qualification/surveillance est obligatoire sur les produits à qualifier/surveiller. La validation de la ligne de commande sera impossible tant qu'au moins un des produits n'a pas de motif saisi.

2) dans la visualisation des lignes de commandes (Action Produits à qualifier/surveiller).

• L'action Produits à qualifier/surveiller n'est disponible dans le menu que si le type de paramètre Motif de qualification/surveillance existe (MQS).

• L'accès est possible selon le paramétrage en consultation ou en modification.

3) à partir des informations de l'état de fabrication (fab_1_etat) et du suivi des commandes de qualification (cde_qualif).

• La création automatique d'un enregistrement de traçabilité lors de l'intégration TB-DATA n'est disponible que si le type de paramètre Motif de qualification/surveillance existe (MQS).

• Lors de l'intégration TB-DATA, un enregistrement de traçabilité est automatiquement créé sur la table 64 (fab_1_etat) si la date/heure de planification ou le code équipe a changé.

• Une alerte de traçabilité peut alors être créé à partir de cet enregistrement.
L'accès aux informations suivantes est disponible (voir détail ci-dessous) :

o Etat de la fabrication (fab_1_etat)

o Numéro de commande de fabrication

o Numéro de ligne de commande de fabrication

o Entête de commande commerciale (cde1)

o Client de la commande commerciale (cli)

o Ligne de commande commerciale (cde2)

o Suivi des commandes de qualification (cde_qualif)

o Libellés étrangers pour le composant rattaché à l'état de fabrication (lib_etr)

Voir aussi

QA A1[29] | Etat de qualification/surveillance
#CF TRA | Traçabilité sur les tables cde_qualif et fab_1_etat
v_cdem | Note AUTORISE_TOUCHE_F53
ATR | Notes ATR_MSG et ATR_OBJET


MRA Mode Réalisation Action

Pas de paramétrage, seuls les libellés sont utilisés.

Ce paramètre est utilisé par le programme prospect.


MRD Motif de Refus du Devis

Valeur alpha 1

MRD A1[1,3]

Code état de rattachement (utilisé dans le devis_standard)


MRG Modes de règlement

Exemples

BAO Billet à ordre

CHE Chèque

ESP Espèces

Valeur alpha 1

MRG A1[1,3] | Code règlement correspondant en comptabilité pour le transfert des tiers en comptabilité MERCUR Sur 2 caractères numériques VALC Sur 3 caractères alphanumériques SETEC Sur 2 caractères alphanumériques EURINFO Sur 3 caractères COBYS Sur 2 caractères LD Compta Sur 2 caractères SAGE 100 Interface Standard (Format .pnm). Sur 1 caractère, qui doit correspondre à la 1ère lettre du code règlement dans SAGE. SAGE 100 Interface No 2 (Format .txt) Sur 2 car. num. Correspond à l'ordre de création des code règlements dans la comptabilité. JDE : mode de règlement JDE (sur 1 caractère)
MRG A1[4] | Ce mode de règlement est-il susceptible d'éditer une traite (O/N) ?
MRG A1[5] | Code maj table des effets (O/N)
MRG A1[6,8] | Type acceptation de l'effet (A, NA, AFA ou blanc)
MRG A1[9] | Code relevé (O/N)
MRG A1[10] | Code LCR (O/N)
MRG A1[11] | Code calcul des échéances (O/N)
MRG A1[12] | Génération d'un mouvement d'effet en transfert des factures calendriers (O/N)
MRG A1[13] | Code du type LCR pour la passerelle tiers ORIAC
MRG A1[14,17] | Code règlement pour le transfert des écritures dans la comptabilité ORIAC (Spécifique K)
MRG A1[18,20] | Code règlement pour le transfert des écritures dans la comptabilité ADONIX (Spécifique R)
MRG A1[21] | Ce mode de règlement est-il susceptible d'éditer un bon de livraison valorisé (O/N) ?
MRG A1[22,24] | Code moyen de règlement pour interface SIDE TRADE
MRG A1[25,26] | Correspondance pour l'interface achat Sage mode 2 avec l'option–Otf Cela doit correspondre au numéro dans l'ordre où sont créés les modes de règlement dans le la comptabilité Sage.

Valeur alpha 2

MRG A2[1,3] | LCR pour impression sur les traites
MRG A2[4,6] | Mode de règlement FACTOCIC

Valeur alpha 3

MRG A3[1]

(O/N)

Utilisé pour faire apparaître sur la facture un message propre au mode de règlement

Le message est figé dans le report de chaque client.

Notes

CODE_MRG_EFFICIAL | 21 Code moyen de règlement - SPECIFIQUE
CODE_MRG_SAP | 21,24 Correspondance du mode de règlement SAP Pour la comptabilité SAP Type 3 : - Seul le caractère 21 est utilisé. - Sert à alimenter la zone ZLSCH de l'enregistrement DOCUMENT_ITEMS-BBSEG de l'interface SAP Type 3 - Voir aussi #CF TRF note SAP_PARAM_GEN_TYPE Caractère 21 = 3
TRANSCO_SAP | 21,23 Transcodification du Code MRG chez SAP


MRT Motif de Refus Transporteur

Ce paramètre est utilisable à partir de la V. 4.1.43.2

Dans le programme de gestion des affrètements (prep_affret), avec l'option Ort, il est possible d'historiser jusqu'à 10 motifs de refus transporteurs par affrètement.

S'il l'on choisit un transporteur dont le tarif est plus élevé que d'autres proposés, alors on peut attribuer un motif de refus pour chaque transporteur dont le tarif est plus bas.

Ces motifs de refus transporteurs sont des codes paramètres de type MRT, et leur historique est stocké dans les TSC RT0 à RT9 de l'entête de groupage (clé = groupage_bl.gb_no_groupage).

Pas de paramétrage, seul le libellé est utilisé.


NAC Numéro automatique de commande

Valeur alpha 1

NAC A1[1,8]

Numéro de commande

Utilisé entre autres dans sjs (sauf si option O02).


NCC Niveau centre de coût

Utilisé dans le récapitulatif des coûts du devis onduleur (don) et du devis multi-métiers (devis_standard).

A renseigner sur le paramètre de la famille FAM A4[48,50].

Valeur alpha 1

NCC A1[1]

Type de frais pour le récapitulatif des coûts

F Fixe

V Variable

A Autre

Par défaut, on prend le type de frais saisi sur le centre de coût (Fixe/Variable uniquement).

Important : Ce paramétrage n'est actif que dans le récapitulatif des coûts, à des fins d'affichage des frais ou de calcul d'indicateurs.

Dans le calcul du devis, le fonctionnement reste inchangé (prise en compte du type de frais sur le centre de coût, Fixe/Variable uniquement).

NCC A1[2,4]

Niveau de centre de coût à prendre en compte lors de l'alimentation du récapitulatif des coûts pour les opérations de passage (doit correspondre à un paramètre de type NCC).

Par défaut : Niveau de centre de coût courant (paramètre courant)

Lors de l'alimentation du récapitulatif des coûts (devis, commande, ordre de fabrication, prix de revient), permettre d'associer au niveau de centre de coût de l'opération courante un niveau de centre de coût spécifique aux opérations de réglage.

Fonctionnement

• Lorsque l'opération courante est une opération de réglage (préparation), on prend comme niveau de centre de coût celui associé au niveau de centre de coût actuel (ope0.o0_niveau). Si celui-ci n'est pas renseigné, on prend le niveau de centre de coût actuel.

• Lorsque l'opération courante est une opération de passage (roulage), on prend comme niveau de centre de coût le niveau de centre de coût actuel (ope0.o0_niveau).

Notes

NAVIGATOR_NCC

Permet d'associer à chaque paramètre de niveau de centre de coût (NCC) un code pour Navigator.

Important : Cette transcodification ne sera pas traitée par VoluPack mais servira uniquement à générer le fichier texte vers Navigator.

21,30 Code de correspondance pour Navigator


NCP Niveau de contrôle

Pas de paramétrage


NDF Natures de frais

Valeurs numériques

1 | Marge sur prix remis
2 | Marge sur prix négocié

Valeur alpha 1

NDF A1[1,2]

Rang d'apparition des frais ( pour remplissage des champs frais dans la table fle_2)

Paramétrage des libellés des 2 lignes de ventilation : #CF DER, notes TITRE_LIGNE_FRAIS

Valeur alpha 2

NDF A2[1,15]

Code produit utilisé pour la génération de commande

(anciennement saisi sur les notes du #CFTDC commençant par CREER_LIGNES_CDE)

Pour les visus (v_fle et v_jdv), on ne duplique pas les lignes par sous-devis.

Le paramétrage de la zone l2_frais_1_negocie entraînera l'affichage de la zone flf_px_negocie du frais qui a le rang 1.

Ainsi, on peut paramétrer toutes les zones de fle_frais pour tous les frais. (ex : l2_frais_6_pr).

Dans la saisie du devis, on voit les 5 premiers frais de premier établissement dans l'écran des variantes.

S'il existe d'autres frais que ceux qui sont affichés, un petit symbole apparaît pour signaler à l'utilisateur qu'il en existe d’autres.

On accède au tableau complet via la touche F18.

Voir aussi voluedit_oex_tc, A4[27].


NDR Nature de regroupement

Ce paramètre est utilisé dans le cadre de la décomposition des prix des éléments (revient/vente standard).

Cette fonctionnalité fait partie du devis multi-métiers : elle est donc documentée dans ce chapitre : Plus d'info

Créer les natures de regroupement par défaut suivantes :

Type/Code | Libellé long | Lib. abrégé
NDR/#CF | Calage/Fixe | C/F
NDR/#RV | Roulage/Variable | R/V

Valeur alpha 1

NDR A1[1,2]

Rang d’apparition de la nature de regroupement dans l’écran de décomposition des prix

NDR A1[3]

Nature de regroupement spécifique à un scénario de regroupement : la nature de regroupement n’est pas utilisée dans les formules mais seulement pour regrouper à l’affichage et à l’édition des prix de natures différentes (O/N, N par défaut)

Voir le fonctionnement des scénarios de décomposition des prix ci-dessous (SDP)

NDR A1[4,6]

Code nature de regroupement associée pour la partie fixe d’une formule de sous-traitance (par défaut : #CF)

N.B. : La nature de regroupement spécifiée sur une formule de sous-traitance concernera toujours la partie variable

NDR A1[7]

Type du prix

F Fixe

V Variable (par défaut)

NDR A1[8,10]

Unité de calcul des prix de revient et prix de vente standard pour la nature de regroupement

Unité de saisie des prix de vente remis et prix négocié pour la nature de regroupement

(doit correspondre à un paramètre de type UNI). Par défaut : Unité du sous-devis

Valeur alpha 2

NDR A2[1,15]

Code produit utilisé pour la recherche de tarif (fonction de remplissage automatique du prix de vente remis via une recherche de tarif, accessible sur l’écran de décomposition des prix)

Valeur alpha 3

NDR A3[1,3]

Code de configuration de recherche de tarif (fonction de remplissage automatique du prix de vente remis via une recherche de tarif, accessible sur l’écran de décomposition des prix)

Par défaut : TAR


NHN Code Hiérarchique Prix Négocié

Voir aussi Code Hiérarchique Prix Remis (NHR).

Le code est indiqué par USE alpha2[47,49].

Notes

TTT_VVV

Paramétrer les différentes plages de marge autorisées pour le prix négocié

TTT = Type de la zone de la fiche client (don alpha2[43,45]). Obligatoire. Exemple CAT

VVV = Valeur de la zone de la fiche client. Facultatif. Exemple 001

21,27 Début de la plage sous la forme 9999.99. Obligatoire. Exemple 0001.00

31,37 Fin de la plage sous la forme 9999.99. Obligatoire. Exemple 0005.00

Exemples

CAT_ 0006.00 0010.00

CAT_001 0001.00 0005.00

La plage de marge 6.00 à 10.00 est autorisée pour tous les clients dont le code catégorie est différent de 001.

La plage de marge 1.00 à 5.00 est autorisée pour tous les clients dont le code catégorie est égal à 001.


NHR Code Hiérarchique Prix Remis

Voir aussi Code Hiérarchique Prix Négocié (NHN).

Le code est indiqué par USE alpha2[44,46].

Notes

TTT_VVV

Paramétrer les différentes plages de marge autorisées pour le prix remis

TTT = Type de la zone de la fiche client (don alpha2[43,45]). Obligatoire. Exemple CAT

VVV = Valeur de la zone de la fiche client. Facultatif. Exemple 001

21,27 Début de la plage sous la forme 9999.99. Obligatoire. Exemple 0001.00

31,37 Fin de la plage sous la forme 9999.99. Obligatoire. Exemple 0005.00

Exemples

CAT_ 0006.00 0010.00

CAT_001 0001.00 0005.00

La plage de marge 6.00 à 10.00 est autorisée pour tous les clients dont le code catégorie est différent de 001.

La plage de marge 1.00 à 5.00 est autorisée pour tous les clients dont le code catégorie est égal à 001.


NTR Nature de transport

Ne pas confondre avec le type de transport

Ce paramètre précise au niveau du transport la nature du transport (EXP express, RAP rapide, etc.)

Valeur alpha 1

NTR A1[1,3]

Première ligne concernant le type de transport - VERIFIER

Valeur alpha 2

NTR A2[1,10]

Deuxième ligne concernant le transport - VERIFIER

Valeur alpha 3

NTR A3[1,3]

Code MAT associé à la création automatique de produit


NTS Types de notes

Saisie simplifiée des notes

Voir en pas de page le tableau des valeurs possibles pour les types de tables et les clés.

Gestion des compléments avec boutons

Syntaxe d'appel dans les visus

Voir aussi les commentaires automatiques (paramètre de type CAU).

ATTENTION : Le type de note ### est interdit.

Dans le paramétrage des notes des éditions VoluEdit, on utilise ### pour exprimer des notes sans type (à blanc) sur les commandes fournisseurs (cdf3) : cela ne signifie pas qu'il s'agit de notes de type ###, mais de notes sans type.

Exemple

VE_VAR Note sans type*NOTES_###*3

Le type de note DE1 est réservé pour le devis (désignation complémentaire).

Le type de note DE2 est réservé pour le devis (Conditions générales de vente).

Le type de note OE1 est réservé pour l'ordre d'exécution (notes d'entête liées au paramètre de lancement du programme).

Le type de note OE2 est réservé pour l'ordre d'exécution (notes de ligne ou pied liées au paramètre de lancement du programme).

Valeurs numériques

NTS N1 | Longueur de la réglette qui sera affichée. Diminue la longueur de la réglette pour indiquer à l'utilisateur quelle longueur sera sauvegardée.
NTS N2 | Le fonctionnement de la valeur numérique 2 dépend du mode de fonctionnement. Saisie simplifiée des notes Ancien mode de sélection : Permet d'afficher les types de notes dans l'ordre désiré Nouveau mode de sélection : Numéro d'indice permettant d'afficher les boutons de sélection des types de notes dans l'ordre désiré dans l'écran de saisie des notes (20 boutons de sélection au maximum) Voir aussi NTS A1[10,11].

Valeur alpha 1

NTS A1[1]

(Utilisé uniquement dans la saisie et la visualisation des commandes client)

E Note d'entête de commande (Accessible en saisie sur l'entête et les lignes de commande)

Ces types de notes n'apparaissent pas sur la saisie des notes groupées

L Note de ligne (enregistre la note sur la ligne de commande courante)

(Par défaut on enregistre sur la ligne courante)

NTS A1[2]

G Il s'agit d'un type de notes groupées

autre Il ne s'agit pas d'un type de notes groupées (par défaut)

NTS A1[3]

Type de note de la ligne de commande à afficher dans la saisie des BL après la saisie de la ligne de commande (O/N, N par défaut)

NTS A1[4]

Affichage de ce type de note lié aux références de l'OF dans la fenêtre d'affichage des notes dans la saisie des temps par codes barres (T/P/N, N par défaut)

T Pour toutes les opérations standards

P Pour des opérations standards particulières (voir les notes OPE_STD_AFF_NTS_REF)

N Non

NTS A1[5]

Affichage de ce type de note lié aux commandes client dans la fenêtre d'affichage des notes dans la saisie des temps par codes barres (T/P/N, N par défaut)

T Pour toutes les opérations standards

P Pour des opérations standards particulières (voir les notes OPE_STD_AFF_NTS_REF)

N Non

NTS A1[6]

Affichage de ce type de note lié au client principal dans la fenêtre d'affichage des notes dans la saisie des temps par codes barres (T/P/N, N par défaut)

T Pour toutes les opérations standards

P Pour des opérations standards particulières (voir les notes OPE_STD_AFF_NTS_REF)

N Non

NTS A1[7,9]

Nombre de lignes saisissables au maximum dans la saisie standard des notes uniquement

Par défaut : 0 = Pas de limitation

NTS A1[10,11]

Gestion des compléments avec boutons

Nouveau mode de sélection uniquement : Numéro d'indice permettant d'afficher les boutons de sélection des types de notes dans l'ordre désiré dans l'écran de saisie des notes (20 boutons de sélection au maximum)

Par défaut : ce numéro d'indice est pris sur la valeur numérique 2

Saisie simplifiée des notes

NTS A1[12]

Méthode d'enregistrement des notes par défaut si aucune modification n'est effectuée

O Les notes par défaut sont systématiquement enregistrés (qu'elles soient modifiées ou non)

N Les notes par défaut non modifiées ne sont jamais enregistrées (elles doivent faire l'objet d'une modification pour être enregistrées)

C Demande de confirmation si les notes par défaut n'ont pas été modifiées (si elles ont fait l'objet d'une modification, elles seront enregistrées sans demande de confirmation) (par défaut)

Saisie simplifiée des notes

Valeur alpha 2

NTS A2[1,60]

Gestion des compléments avec boutons

21,60 Chemin de l'image à mettre en place sur le bouton correspondant au code type de notes (NTS) sur la saisie des notes.

Par défaut : l'image est celle habituellement utilisée pour l'action de saisie des notes

Aucune ligne de note présente pour ce type

Au moins une ligne de note présente pour ce type

Erreur de paramétrage sur les notes groupées (voir annexe 3)

Remarque : Si une image est paramétrée sur au moins un type de note (donc un bouton de sélection), les images de présence de notes s'afficheront à droite des boutons de sélection. Par exemple :

: Aucune ligne de note présente pour ce type

: Au moins une ligne de note présente pour ce type

Notes

Les notes sur les paramètres de type NTS sont des notes par défaut, recopiées lors du CONTROL-N

[Note sans nom]

1,60 Ligne de note par défaut qui sera recopiée lors de l'appel à la saisie des notes, si aucune note n'existe pour ce type

Remarques :

• Les notes GRP et OPE_STD_AFF_NTS_REF ne sont pas prises en compte comme lignes de notes par défaut.

• Les notes par défaut ne sont pas prises en compte dans la saisie des notes groupées.

GRP

4,60 Liste des types de notes à inclure dans la saisie groupée

19 codes de 3 caractères par ligne de note (doit correspondre à un type de paramètre NTS)

Exemple : GRPACTFACBLVCDE

OPE_STD_AFF_NTS_REF

Phase

21,23 Code section de la phase

24,26 Code opération de la phase

27,29 Code sous-opération de la phase

POPUP_NTS_ARTICLE

Déclencher l'affichage automatique de notes à certains endroits

Affichage automatique des notes de la fiche article (stockées dans la table mat3)

21,38 Type d'affichage automatique de la fenêtre de notes :

mat : à l'ouverture d'une fiche article en modification (programme mat).

lc_prod : après la saisie d'un nouveau code produit sur une ligne de commande (programme cde).

de_produit : après la saisie d'un nouveau code produit sur une ligne de nomenclature (programme devis_standard, fenêtre G_devis_standard_niv)

entete_ds : à l'ouverture d'un devis (devis_standard), on affiche les notes de l'article de la 1ère entité.

POPUP_NTS_TIERS

Déclencher l'affichage automatique de notes à certains endroits

Affichage automatique des notes de la fiche tiers (stockées dans la table cli3).

21,38 Type d'affichage automatique de la fenêtre de notes :

cli : à l'ouverture d'une fiche tiers en modification (programme cli)

Table des valeurs possibles pour les types de tables et les clés

Dans la table notes, les zones nn_type (type de table) et nn_cle (clé de la table) peuvent prendre les valeurs suivantes :

nn_type | Classe de l'information liée à la clé | nn_cle
A | Article | Code article
B | Bordereau de transport | Numéro de bordereau de transport
C | Notes sur le par01 | Notes sur le par01 Caractères 1 à 3 : Type de paramètre
D | Commande | Notes sur entête de commande Caractères 1 à 6 : Numéro de commande Notes sur la ligne de commande Caractères 1 à 8 : Numéro commande Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de la ligne de commande using "##&" Notes sur la nomenclature de commande Caractères 1 à 8 : Numéro commande Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de la ligne de commande using "##&" Caractère 13 : - (le signe moins) Caractères 14 à 16 : Numéro de séquence de la ligne de commande using "##&"
E | Devis | Notes sur le devis Caractères 1 à 8 : Numéro de devis Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de sous-devis Caractère 13 : - (le signe moins) Caractères 14 à 16 : Numéro d'entité
F | Facture | Notes sur entête de facture Caractères 1 à 8 : Numéro de facture Notes sur ligne de facture Caractères 1 à 8 : Numéro de facture Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de ligne de facture using "##&"
G | Notes sur le détail de la gamme standard | Détail gamme standard Caractères 1 à 3 : Code gamme Caractères 4 à 7 : Numéro de phase using "###&"
H | Tiers | Notes surs les tiers Caractères 1 à 6 : Code tiers
I | Sous-Famille | Notes sur les sous-familles Caractères 1 à 3 : Code famille Caractère 4 : - (le signe moins) Caractères 5 à 7 : Code sous-famille
J | Groupages - Affrètements | Notes sur les entêtes des groupages et affrètements Caractères 1 à 8 : Numéro de groupage Notes sur les lignes des groupages et affrètements Caractères 1 à 8 : Numéro de groupage Caractère 9 - (le signe moins) Caractères 10 à 12 : Numéro de ligne de groupage using "##&"
K | Affaires | Notes sur les affaires Caractère 1 à 8 : Numéro d'affaire Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro ligne d'affaire using "##&"
L | Contrôle Laboratoire | Contrôle laboratoire Caractères 1 à 3 : Type de contrôle Caractères 4 à 18 : Numéro de contrôle Caractères 11 à 16 : Numéro de ligne de contrôle using "<<&"
M | Machine | Code machine
N | Non conformité interne - Réclamation client | Numéro de réclamation client
O | Demande d'achat | Notes sur l'entête de la demande d'achat Caractères 1 à 8 : Numéro de la demande Notes sur les lignes de la demande d'achat Caractères 1 à 8 : Numéro de la demande Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de ligne de demande using "##&"
P | Permissions | Permissions Caractère 1 : Type identifiant Caractères 2 à 9 : Code identifiant Caractères 10 à 12 : Code action Caractères 13 à 32 : Argument action
Q | Action sur outillage | Action sur outillage (paramètre ASO) Caractères 1 à 11 : Numéro de série de la table action_mat using "##########&"
R | Bon de réception ou de retour de marchandises | Notes sur la ligne du bon de réception ou de retour de marchandises Caractères 1 à 8 : Numéro du bon de réception ou de retour Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de la ligne du bon de réception ou de retour using "##&" Caractère 13 : - (le signe moins) Car. 14 à 24 : Numéro de série issu de la table de traçabilité using "##########&"
S | Notes sur le correspondant (NCO) | Notes sur les correspondants Caractères 1 à 6 : Code tiers Caractères 7 à 9 : Code adresse secondaire Caractères 10 à 32 : Nom du correspondant (tronqué)
T | Triplet (article, code gamme, phase) | La codification de la clé est impérative. Ne jamais clipper les zones Caractères 1 à 15 : Code article Caractères 16 à 18 : Code gamme Caractères 19 à 22 : Numéro phase using "###&"
U | Suivi des dates | Caractères 1 à 24 : Code suivi de date (sd_code) Caractères 25 : > Caractères 26 à 28 : Type d'étape (001 à 004) Caractère 29 : /
V | Variantes des devis feuilles | Variantes des devis feuilles Caractères 1 à 8 : Numéro de devis Caractères 9 à 10 : Numéro de sous-devis using "&&" Caractères 11 à 12 : Numéro de variante using "&&"
W | Devis standard nomenclature | Notes sur devis standard nomenclature Caractères 1 à 8 : Numéro de devis Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de sous-devis Caractère 13 : - (le signe moins) Caractères 14 à 16 : Numéro de ligne de nomenclature
X | Devis standard références multiples | Notes sur devis standard références multiples Caractères 1 à 8 : Numéro de devis Caractère 9 : - (le signe moins) Caractères 10 à 12 : Numéro de sous-devis Caractère 13 : / (slash) Caractères 14 à 16 : Numéro d'entité (000 pour le moment) Caractère 17 : : (deux-points) Caractères 18 à 20 : Numéro de ligne
Y | Devis standard descriptif de roulage | Notes sur devis standard descriptif de roulage Caractères 1 à 8 : Numéro devis Caractère 9 : - (underscore) Caractères 10 à 12 : Numéro sous-devis Caractère 13 : / (slash) Caractères 14 à 16 : Numéro d'entité Caractère 17 : / (slash) Caractères 18 à 20 : Numéro de feuille Caractère 21 : : (deux-points) Caractère 22 à 24 : Numéro de ligne
Z | ECMA/FEFCO | Notes sur le code ECMA/FEFCO Caractères 1 à 15 : Code FEFCO/ECMA
@ | Détail couleur | Caractère 1 : Type d'enregistrement (D/A) Caractère 2 : - Caractères 3 à 28 : Clé d'enregistrement (Devis/Article) Caractère 29 : - Caractères 30 à 32 : Numéro de ligne d'enregistrement de détail couleur
& | Facture fournisseur | Caractères 1 à 8 : Numéro facture fournisseur Caractères 1 à 8 : Numéro facture fournisseur Caractère 9 : - Caractères 10 à 12 : Numéro ligne facture fournisseur using "##&"
$ | Actions (action_evt) |
£ | Motifs de qualification/surveillance |
0 | Notes temporaires |
1 | Spécifique | 1,8 Numéro de devis 9,10 Numéro de sous-devis 11,16 Numéro de client (ou site)
2 | Spécifique | 1,8 Numéro de dossier de fabrication
3 | Remise de prix | 1,8 Numéro de remise de prix
4 | Tarifs transporteurs | 1,9 Code tarif
5 | Ligne d'impression multiple | 1,8 Devis 9 Tiret 10,12 Sous-devis 13 Tiret 14,16 Entité 17 Tiret 18,20 003 21 Tiret 22,24 N° passage 25 Tiret 26,28 N° vernis
6 | Saisie des temps Voir les options Ogd et Oon dans la saisie des temps atelier | 01,19 Numéro de l'OF 20,22 Type de gamme 23,28 Numéro de phase 29,32 Numéro de ligne
m | Messages à l'attention des utilisateurs | 1,17 NOTES_MENU_GENERO
e | Corps du message de la gestion fax/email |

Gestion des compléments avec boutons

Permet, dans les différentes saisies des notes (Control-N), de gérer des boutons de regroupement par type de notes (NTS).

Remarques

• Les boutons affichés sont conditionnés selon le principe habituel des NTS : argument -C
(N.B. : les boutons remplacent la sélection du type de note qui apparaissait jusque-là avant la saisie des notes).

• La présence d'une note sur un type est indiquée :

o à droite du bouton si une image est paramétrée sur le type de note (Figure 1)

o sur le bouton directement si aucune image n'est paramétrée sur le type de note (Figure 2)

• A partir du moment où une image est paramétrée sur l'un des types de notes à afficher, la présence de notes sera indiquée à droite des boutons (Figure 2)

• Si le nombre de types de notes à afficher dépasse 20 boutons, un bouton supplémentaire apparaît et permet d'accéder aux types de notes non affichés (Figure 3).

Paramétrage : NTS A1[10,12] et NTS A2[1,60]


NTS Syntaxe d'appel dans les visus

Fonctionnalités

Ce paramétrage permet de définir des colonnes contenant des lignes de notes paramétrables.

En visualisation Ecran/Edition/Fichier, on affiche simplement la première ligne de note.

En visualisation EXCEL direct, on affiche le nombre de ligne sélectionnées.

On peut paramétrer

1) la ligne de notes que l'on veut visualiser

2) un cascading, où l'on veut voir la note X; si elle n'est pas trouvée, alors on veut voir la note Y

3) on peut faire apparaître plusieurs notes différentes dans la même colonne.

Disponibilité

Cette fonctionnalité est disponible dans les programmes de visu.

Syntaxe 1

On veut visualiser un seul type de notes à un endroit précis.

X Titre de la colonne*NTS_SSS/TTT/NNN*L*

où

X = Type de visu (V, D, E, F)

NTS = Mot-clé annonçant une colonne de notes

SSS = Source de la note (Voir en bas de page le tableau des types de clé disponibles

TTT = Type de la note

NNN = Nombre de lignes. On peut aussi indiquer :

ALL pour éditer toutes les lignes

PRE pour éditer un astérisque indiquant la présence d'au moins une note dans la sélection

L = Longueur

Comme pour les TSC, les clés sont lues dans la visu.

Nous avons ici un seul ensemble de notes; au sein de cet ensemble, le séparateur est le / (barre de fraction, alias slash).

Attention : dans la partie Paramétrage (NTS_SSS/TTT/NNN), on est limité à 33 caractères.

Exemple

Dans l'exemple qui suit, on veut visualiser toutes les lignes de notes de type FAC sur la ligne de facture :

E Note facture ligne*NTS_NOTFL/FAC/ALL*60*

Syntaxe 2

On veut visualiser toutes les lignes de notes de type FAC sur la ligne de facture (NOTFL/FAC/ALL)

Si elles n'existent pas, on veut voir les lignes de notes de type BL sur la ligne de BL (BLVL/BL/ALL)

E Note facture ligne*NTS_NOTFL/FAC/ALL_BLVL/BL/ALL*60*

<Ensemble 1><Ensemble 2 >

Notez que les 2 ensembles de notes sont séparés par le caractère _ (caractère souligné, alias underscore).

Au sein de chaque ensemble, le séparateur reste le /

Syntaxe 3

On veut visualiser toutes les lignes de notes de type FAC sur la ligne de facture et aussi celles des notes de type BL sur la ligne de BL.

Cette combinaison de plusieurs lignes de notes différentes est rendue possible par le mot-clé CUM, que l'on place en fin de paramétrage.

E Note facture ligne*NTS_NOTFL/FAC/ALL_BLVL/BL/ALL_CUM*60*

Vu la limitation du nombre de caractères (33), il est possible de déporter le paramétrage sur une autre note.

Dans ce cas, dans la partie Source, on indique un code qui permet de retrouver la (ou les) ligne(s) de notes, dont le paramétrage commence par le mot-clé _NTS_

Ces notes commençant par _NTS_xxx sont recherchées en priorité sur le paramètre de lancement.

Si elles n'y sont pas trouvées, on les recherche alors dans le paramétrage #CF VIS.

Ainsi, si l'on reprend les dernier exemple ci-dessus, on aura le paramétrage suivant :

E Note facture ligne*NTS_MA_NOTE1*60*

_NTS_MA_NOTE1 NOTFL/FAC/ALL_

_NTS_MA_NOTE1 BLVL/BL/ALL_CUM

Ici, on indique que le paramétrage se fait via une autre note (en l'occurrence, nommée MA_NOTE1).

Cette note MA_NOTE1 peut être divisée en plusieurs lignes.

Chaque ligne contient alors un ensemble de notes, ce qui présente plusieurs avantages :

- Plus de lisibilité.

- Le même paramétrage peut être partagé par plusieurs programmes de visualisation différents, ce qui évite d'avoir à le saisir plusieurs fois.

Notez que le caractère souligné est toujours présent, même si chaque ensemble de notes est sur une nouvelle ligne.

Source de la note - Types de clés disponibles

Type de clé | Commentaires | Table | Clé
BLVE | Entête de BL | blv3 | P_b1
BLVL | Ligne de BL | blv3 | P_b2
CLI | Client | cli3 | P_cl ou p_c2
CDEE | Entête de commande client | cde3 | P_ec
CDEL | Ligne de commande client | cde3 | P_lc
CDFE | Entête de commande fournisseur | cdf3 | P_ef
CDFL | Ligne de commande fournisseur | cdf3 | P_lf
CLIF | Client facturé | cli3 | P_c2f
CLIL | Client livré | cli3 | P_c2l
CLIP | Client principal | cli, cli2 | cl_code
GAM | Entête de gamme standard |  |
MAT | Fichier matière | mat3 | P_mp
NLDVD | Note sur le devis multi-métier | note_ldev | P_l2
NLDVE | Note sur le devis multi-métier (entité) | note_ldev | P_fi
Nota | Notes sur articles | notes | P_mp
NOTDB | Notes sur le besoin | cde5 | P_uc
NOTDC | Notes sur les cadencements de livraison | notes | p_li
Notde | Notes entête de commande client | notes | P_ec
NOTFAB2 |  |  |
Notdl | Notes sur ligne de commande client | notes | P_lc
Notds | Notes sur séquence de commande client | notes | P_nc
Notfe | Notes sur entête de facture | notes | P_fe
Notfl | Notes sur ligne de facture | notes | P_fl
Notg | Notes sur la gamme | notes | P_gd
Noth | Notes sur le tiers | notes | P_cl
Notje | Notes sur groupage (entête) | notes | P_gb
Notjl | Notes sur ligne de groupage | notes | P_gb
NOTK | Notes de l'affaire/flux | notes | af_num_affaire
NOTLIC2 | Notes sur l'adresse secondaire d'un cadencement de livraison (li_adr) | cli3 | ec_cli-li_adr
Notm | Notes sur machine | notes | P_m0
NOTS | Notes sur le correspondant | corres | P_co
NOTSBS |  |  |
NOT&E | Notes sur entête de facture fournisseur |  |
NOT&L | Notes sur ligne de facture fournisseur |  |
NOT$ (dollar) | Notes des actions–événements | notes | ace_serial
Stk | Notes sur stock | stk0_notes | P_s0


ODQ Origine des défauts constatés

Valeur alpha 1

ODQ A1[1,3]

Code secteur associé

Valeur alpha 2

ODQ A2[1]

Type de code origine

C Client

F Fournisseur

I Interne

S Standard (par défaut)


OPR Codes opérateurs

Pour la saisie des inventaires par bordereau

Valeur alpha 1

OPR A1[1,3] | Lieu de rangement 1 par défaut proposé en saisie Si non renseigné, le lieu de rangement 1 proposé est celui de l 'article
OPR A1[4,6] | Lieu de rangement 2 par défaut proposé en saisie Si non renseigné, le lieu de rangement 3 proposé est celui de l 'article
OPR A1[7,12] | Lieu de rangement 3 par défaut proposé en saisie Si non renseigné, le lieu de rangement 3 proposé est celui de l 'article


ORG Codes origine

Pas de paramétrage particulier


PAY Code pays

Voir en bas de page le formatage automatique des numéros de téléphone au format international.

Valeur alpha 1

PAY A1[1,3] | Code langue par défaut
PAY A1[4,6] | Code devise par défaut
PAY A1[7,9] | Code pays normalisé pour la déclaration d'échange de biens entre états membres (CE)
PAY A1[10,12] | Code pays permettant de constituer le code postal complet Exemple : NL-4562 Attention Le [-] dans cet exemple est significatif
PAY A1[13] | Numéro identification TVA obligatoire (O/N, N par défaut)
PAY A1[14] | Pays faisant l'objet d'une déclaration d'échange de biens entre états membres (CE)
PAY A1[15] | Mode d'application de TVA normal. Contrôlé lors de la saisie de la fiche client et des commandes. Exemples O (Export) Le pays de livraison doit être HORS France et HORS CE N (Taxable) Le pays de livraison doit être France I (Intracommunautaire) Le pays de livraison doit être CEE et HORS FRANCE S (Suspension) : Cas particulier de clients France en suspension : créer un code pays supplémentaire s'il y a un contrôle sur #CF ATL A2[44].
PAY A1[16,18] | Code ISO du pays (pour contrôle numéro de TVA) Ce code normalisé doit faire 2 caractères (même si 3 caractères ont été prévus). Le code FR est important pour la saisie du numéro de TVA intracommunautaire. Exemples : FR (France) - GB (Angleterre) Voir le site de l'ISO.
PAY A1[19] | Contrôle du N° de TVA: N Numérique A Alphanumérique
PAY A1[20,21] | Nombre de caractères derrière le code ISO (pour contrôle numéro de TVA) Contrôle non bloquant
PAY A1[22,35] | Numéro de TVA du pays (utilisée dans le DEB)
PAY A1[36] | Pour les pays utilisant l'équivalent du code INSEE pour les communes françaises O Pays ayant un code similaire Pays pris en compte dans la vérification du code commune INSEE. N Pays n'ayant pas un code similaire (par défaut) Pays ignoré lors de la vérification du code commune INSEE.
PAY A1[37] | Complément à zéro des informations lors de la saisie du RIB (Banque, Guichet , Compte ...) (O/N, O par défaut) Le NON implique le non contrôle de la clé RIB
PAY A1[38] | Longueur du code département dans le code postal (0 à 8) Exemple : 2 pour la France
PAY A1[39] | Contrôle de la clé du N° de SIREN contenu dans le numéro de TVA Intracommunautaire N Non (par défaut) W Warning B Bloquant C Avec Confirmation Voir aussi VAS A1[5]
PAY A1[40] | Pays faisant partie de la CEE (O/N)
PAY A1[41] | Affichage de la ligne d'information export dans l'édition des factures On ajoute une ligne d'information (par ligne de facture) selon le pays du tiers livré. La ligne est placé devant la ligne de note (7ème ligne du bloc ligne de facture). Les informations affichées sont : Le poids total, le nombre total de palettes, le délai de livraison et une note paramétrable en fonction du code pays. Voir la note NOTE_FACTURE_EXPORT
PAY A1[42] | Saisie du code établissement obligatoire dans le numéro d'identification TVA (O/N, O par défaut) Le même contrôle peut être paramétré au niveau du code validité d'adresse (VAS A1[18]).

Valeur alpha 2

PAY A2[1,3] | Code pays utilisé par LOXANE (Way Server) (cf. liste ci-dessous)
PAY A2[4,6] | Préfixe pays attribué par EAN international (3 chiffres Ce code commence par 3 pour la France.
PAY A2[7] | Inhiber le contrôle entre le code pays et le code CNUF pour générer le code SSCC (O/N) Ce paramètre est utilisé dans la saisie des étiquettes de production. Lors de la génération du code SSCC (Serial Shipping Container Code) un contrôle est fait par défaut entre le préfixe pays attribué par EAN international et le code CNUF (Code National Unifié Fournisseur). Dans certains pays, cela ne s'applique pas. Pour avoir un code SSCC pour ces pays, il faut inhiber ce contrôle.

Notes

CODE_PAY_EFFICIAL | 21,23 Code pays selon norme ISO 3166 - SPECIFIQUE
CODE_PAYS_SYLOGI | 21 à xx Code du pays pour SYLOGI
CORRES_IMPORT_TIERS | Correspondance pour l'importation des tiers
NOTE_FACTURE_EXPORT | 21,60 Commentaire à afficher dans l'édition Voir A1[41]
TRANSCO_SAP | 21,23 Transcodification du Code PAY chez SAP

Codes pays utilisés par Loxane (Way Server) (A2[1,3])

Pays | Code Way Server
Albanie Allemagne Andorre Arménie Autriche Azerbaïdjan Belgique Biélorussie Bosnie Herzégovine Bulgarie Chypre Croatie Danemark Espagne Estonie Finlande France Géorgie Gibraltar Grande-Bretagne Grèce Hongrie Iles Féroé Irlande Islande Italie Lettonie Liechtenstein Lituanie Luxembourg Macédoine Malte Moldavie Monaco Norvège Pays-Bas Pologne Portugal Roumanie Russie San Marin Slovaquie Slovénie Suède Suisse Bohème-Moravie Turquie Ukraine Vatican Yougoslavie | AL D AND ARM A ASE B BER BIH BG KPR HR DK E EW SF F GRU GI GB GR H FR IRL IS I LR FL LT L MK M MOL MC N NL PL P R ROS RSM SR SLO S CH CZ TR UKR V YU

Formatage automatique des numéros de téléphone au format international.

Si le numéro de téléphone est couleur rouge, cela veut dire qu'il ne respecte pas le format défini par défaut :

- soit la longueur n'est pas correcte (pas assez ou trop de chiffres)

- soit l'indicatif n'est pas correct.

La longueur et l'indicatif attendus sont indiqués dans le commentaire ou dans l'info bulle de chaque champ.

Ces valeurs peuvent être modifiées via paramétrage dans #CF ISO.

Code ISO | Pays | Indicatif | Masque | Longueur mini | Longueur maxi
AD | Andorre | 376 |  | 6 | 6
AE | Émirats Arabes Unis | 971 |  | 6 | 0
AF | Afghanistan | 93 |  | 6 | 0
AG | Antigua-et-Barbuda | 1 |  | 6 | 0
AI | Anguilla | 1 |  | 6 | 0
AL | Albanie | 355 |  | 6 | 0
AM | Arménie | 374 |  | 6 | 0
AN | Antilles Néerlandaises | 599 |  | 6 | 0
AO | Angola | 244 |  | 6 | 0
AQ | Antarctique |  |  | 6 | 0
AR | Argentine | 54 | ### ### #### | 10 | 10
AS | Samoa Américaines | 684 |  | 6 | 0
AT | Autriche | 43 | 0 | 9 | 11
AU | Australie | 61 | # #### #### | 9 | 9
AW | Aruba | 297 |  | 6 | 0
AZ | Azerbaïdjan | 994 |  | 6 | 0
BA | Bosnie-Herzégovine | 387 |  | 6 | 0
BB | Barbade | 1 |  | 6 | 0
BD | Bangladesh | 880 |  | 6 | 0
BE | Belgique | 32 | 0 | 9 | 10
BF | Burkina faso | 226 |  | 6 | 0
BG | Bulgarie | 359 | 0 | 9 | 11
BH | Bahreïn | 973 |  | 6 | 0
BI | Burundi | 257 |  | 6 | 0
BJ | Bénin | 229 |  | 6 | 0
BM | Bermudes | 1 |  | 6 | 0
BN | Brunéi Darussalam | 673 |  | 6 | 0
BO | Bolivie | 591 |  | 6 | 0
BR | Brésil | 55 |  | 10 | 10
BS | Bahamas | 1 |  | 6 | 0
BT | Bhoutan | 975 |  | 6 | 0
BV | Bouvet, île |  |  | 6 | 0
BW | Botswana | 267 |  | 6 | 0
BY | Bélarus | 375 |  | 6 | 0
BZ | Belize | 501 |  | 6 | 0
CA | Canada | 1 | ### ### #### | 10 | 10
CC | Cocos (Keeling), îles | 672 |  | 6 | 0
CD | Congo, République Démocratique du | 242 |  | 6 | 0
CF | Centrafricaine, République | 236 |  | 6 | 0
CG | Congo | 242 |  | 6 | 0
CH | Suisse | 41 | 0 | 10 | 10
CI | Côte d'Rvoire | 225 |  | 6 | 0
CK | Cook, Iles | 682 |  | 6 | 0
CL | Chili | 56 |  | 6 | 0
CM | Cameroun | 237 |  | 6 | 0
CN | Chine | 86 |  | 6 | 0
CO | Colombie | 57 |  | 6 | 0
CR | Costa Rica | 506 |  | 6 | 0
CU | Cuba | 53 |  | 6 | 0
CV | Cap-vert | 238 |  | 6 | 0
CX | Christmas, Ile | 672 |  | 6 | 0
CY | Chypre | 357 |  | 6 | 0
CZ | Tchèque, République | 420 |  | 9 | 9
DE | Allemagne | 49 | 0 | 9 | 12
DJ | Djibouti | 253 |  | 6 | 0
DK | Danemark | 45 |  | 8 | 8
DM | Dominique | 1 |  | 6 | 0
DO | Dominicaine, République | 809 |  | 6 | 0
DZ | Algérie | 213 | 0 | 10 | 10
EC | Équateur | 593 |  | 6 | 0
EE | Estonie | 372 |  | 6 | 0
EG | Égypte | 20 |  | 6 | 0
EH | Sahara Occidental |  |  | 6 | 0
ER | Érythrée | 291 |  | 6 | 0
ES | Espagne | 34 |  | 9 | 9
ET | Éthiopie | 251 |  | 6 | 0
FI | Finlande | 358 | 0 | 10 | 10
FJ | Fidji | 679 |  | 6 | 0
FK | Falkland, Iles (Malvinas) |  |  | 6 | 0
FM | Micronésie, Etats Fédérés de | 691 |  | 6 | 0
FO | Féroé, Iles | 298 |  | 6 | 0
FR | France | 33 | (0)# ## ## ## ## | 10 | 10
GA | Gabon | 241 |  | 6 | 0
GB | Royaume-Uni | 44 | 0 | 11 | 11
GD | Grenade | 1 |  | 6 | 0
GE | Géorgie | 995 |  | 6 | 0
GF | Guyane Française | 594 |  | 6 | 0
GH | Ghana | 233 |  | 6 | 0
GI | Gibraltar | 350 |  | 6 | 0
GL | Groenland | 299 |  | 6 | 0
GM | Gambie | 220 |  | 6 | 0
GN | Guinée | 224 |  | 6 | 0
GP | Guadeloupe | 33 | (0)# ## ## ## ## | 10 | 10
GQ | Guinée Equatoriale | 240 |  | 6 | 0
GR | Grèce | 30 |  | 10 | 10
GS | Géorgie du Sud et les Iles Sandwich du Sud |  |  | 6 | 0
GT | Guatemala | 502 |  | 7 | 0
GU | Guam | 1 |  | 6 | 0
GW | Guinée-Bissau | 245 |  | 6 | 0
GY | Guyana | 295 |  | 6 | 0
HK | Hong-kong | 852 |  | 8 | 0
HM | Heard, Ile et Mcdonald, Iles | 672 |  | 6 | 0
HN | Honduras | 504 |  | 6 | 0
HR | Croatie | 385 |  | 8 | 0
HT | Haïti | 509 |  | 6 | 0
HU | Hongrie | 36 |  | 8 | 0
ID | Indonésie | 62 |  | 7 | 0
IE | Irlande | 353 |  | 8 | 0
IL | Israël | 972 | 0 | 9 | 9
IN | Inde | 91 |  | 7 | 0
IO | Océan indien, Territoire Britannique de l' | 246 |  | 6 | 0
IQ | Iraq | 964 |  | 6 | 0
IR | Iran, République Islamique d' | 98 |  | 6 | 0
IS | Islande | 354 |  | 7 | 0
IT | Italie | 39 | 0 | 8 | 0
JM | Jamaïque | 1 |  | 6 | 0
JO | Jordanie | 962 |  | 6 | 0
JP | Japon | 81 |  | 9 | 0
KE | Kenya | 254 |  | 6 | 0
KG | Kirghizistan | 996 |  | 6 | 0
KH | Cambodge | 855 |  | 6 | 0
KI | Kiribati | 686 |  | 6 | 0
KM | Comores | 269 |  | 6 | 0
KN | Saint-Kitts-et-Nevis | 1 |  | 6 | 0
KP | Corée, République Populaire Démocratique de | 82 |  | 6 | 0
KR | Corée, République de | 850 |  | 6 | 0
KW | Koweït | 965 |  | 6 | 0
KY | Caïmanes, Iles | 1 |  | 6 | 0
KZ | Kazakhstan | 7 |  | 6 | 0
LA | Lao, République Démocratique Populaire | 856 |  | 6 | 0
LB | Liban | 961 |  | 7 | 0
LC | Sainte-Lucie | 1 |  | 6 | 0
LI | Liechtenstein | 41 |  | 6 | 0
LK | Sri lanka | 94 |  | 7 | 0
LR | Libéria | 231 |  | 6 | 0
LS | Lesotho | 266 |  | 6 | 0
LT | Lituanie | 370 |  | 6 | 0
LU | Luxembourg | 352 |  | 6 | 10
LV | Lettonie | 371 |  | 7 | 0
LY | Libyenne, Jamahiriya Arabe | 218 |  | 6 | 0
MA | Maroc | 212 | 0 | 10 | 10
MC | Monaco | 377 |  | 7 | 0
MD | Moldova, République de | 373 |  | 6 | 0
MG | Madagascar | 261 |  | 6 | 0
MH | Marshall, îles | 692 |  | 6 | 0
MK | Macédoine, l'ex-République Yougoslave de | 389 |  | 6 | 0
ML | Mali | 223 |  | 7 | 0
MM | Myanmar | 95 |  | 6 | 0
MN | Mongolie | 976 |  | 6 | 0
MO | Macao | 853 |  | 6 | 0
MP | Mariannes du Nord, Iles | 1 |  | 6 | 0
MQ | Martinique | 33 | (0)# ## ## ## ## | 10 | 10
MR | Mauritanie | 222 |  | 7 | 0
MS | Montserrat | 1 |  | 6 | 0
MT | Malte | 356 |  | 6 | 0
MU | Maurice | 230 |  | 6 | 0
MV | Maldives | 960 |  | 6 | 0
MW | Malawi | 265 |  | 6 | 0
MX | Mexique | 52 | ### ### #### | 10 | 10
MY | Malaisie | 60 |  | 7 | 0
MZ | Mozambique | 258 |  | 7 | 0
NA | Namibie | 264 |  | 6 | 0
NC | Nouvelle-Calédonie | 687 |  | 6 | 0
NE | Niger | 227 |  | 6 | 0
NF | Norfolk, île |  |  | 6 | 0
NG | Nigéria | 234 |  | 6 | 0
NI | Nicaragua | 505 |  | 6 | 0
NL | Pays-bas | 31 | 0 | 10 | 10
NO | Norvège | 47 |  | 7 | 0
NP | Népal | 977 |  | 6 | 0
NR | Nauru | 674 |  | 6 | 0
NU | Niué | 683 |  | 6 | 0
NZ | Nouvelle-Zélande | 64 |  | 6 | 0
OM | Oman | 968 |  | 6 | 0
PA | Panama | 507 |  | 6 | 0
PE | Pérou | 51 |  | 7 | 0
PF | Polynésie Française | 689 |  | 6 | 0
PG | Papouasie-Nouvelle-Guinée | 675 |  | 6 | 0
PH | Philippines | 63 |  | 6 | 0
PK | Pakistan | 92 |  | 7 | 0
PL | Pologne | 48 | 0 | 10 | 10
PM | Saint-Pierre-et-Miquelon | 508 |  | 6 | 0
PN | Pitcairn |  |  | 6 | 0
PR | Porto Rico | 1 |  | 6 | 0
PS | Palestinien Occupé, Territoire | 970 |  | 6 | 0
PT | Portugal | 351 |  | 9 | 9
PW | Palaos | 680 |  | 6 | 0
PY | Paraguay | 595 |  | 6 | 0
QA | Qatar | 974 |  | 6 | 0
RE | Réunion | 262 |  | 6 | 0
RO | Roumanie | 40 |  | 7 | 0
RU | Russie, Fédération de | 7 |  | 7 | 0
RW | Rwanda | 250 |  | 6 | 0
SA | Arabie Saoudite | 966 |  | 7 | 0
SB | Salomon, Iles | 677 |  | 6 | 0
SC | Seychelles | 248 |  | 6 | 0
SD | Soudan | 249 |  | 7 | 0
SE | Suède | 46 | 0 | 7 | 0
SG | Singapour | 65 |  | 7 | 0
SH | Sainte-Hélène | 290 |  | 6 | 0
SI | Slovénie | 386 |  | 7 | 0
SJ | Svalbard et Ile Jan Mayen |  |  | 6 | 0
SK | Slovaquie | 421 |  | 7 | 0
SL | Sierra Leone | 232 |  | 6 | 0
SM | Saint-Marin | 378 |  | 6 | 0
SN | Sénégal | 221 |  | 7 | 0
SO | Somalie | 252 |  | 6 | 0
SR | Suriname | 597 |  | 6 | 0
ST | Sao tomé-et-Principe | 239 |  | 6 | 0
SV | El salvador | 503 |  | 6 | 0
SY | Syrienne, République Arabe | 963 |  | 7 | 0
SZ | Swaziland | 268 |  | 6 | 0
TC | Turks et Caïques, îles | 1 |  | 6 | 0
TD | Tchad | 235 |  | 6 | 0
TF | Terres Australes Françaises |  |  | 6 | 0
TG | Togo | 228 |  | 7 | 0
TH | Thaïlande | 66 |  | 7 | 0
TJ | Tadjikistan | 7 |  | 6 | 0
TK | Tokelau | 690 |  | 6 | 0
TL | Timor Oriental | 670 |  | 6 | 0
TM | Turkménistan | 993 |  | 6 | 0
TN | Tunisie | 216 |  | 8 | 8
TO | Tonga | 676 |  | 6 | 0
TR | Turquie | 90 |  | 10 | 10
TT | Trinité-et-Tobago | 1 |  | 6 | 0
TV | Tuvalu | 688 |  | 6 | 0
TW | Taïwan, Province de Chine | 886 |  | 8 | 0
TZ | Tanzanie, République-Unie de | 255 |  | 7 | 0
UA | Ukraine | 380 |  | 7 | 0
UG | Ouganda | 256 |  | 7 | 0
UM | Îles Mineures Eloignées des Etats-Unis |  |  | 6 | 0
US | États-unis | 1 | ### ### #### | 10 | 10
UY | Uruguay | 598 |  | 7 | 0
UZ | Ouzbékistan | 998 |  | 6 | 0
VA | Saint-Siège (Etat de la Cité du Vatican) | 379 |  | 6 | 0
VC | Saint-Vincent-et-les Grenadines | 1 |  | 6 | 0
VE | Venezuela | 58 |  | 7 | 0
VG | Îles vierges Britanniques | 1 |  | 6 | 0
VI | Îles vierges des Etats-Unis | 1 |  | 6 | 0
VN | Viet Nam | 84 |  | 7 | 0
VU | Vanuatu | 678 |  | 6 | 0
WF | Wallis et Futuna | 681 |  | 6 | 0
WS | Samoa | 685 |  | 6 | 0
YE | Yémen | 967 |  | 6 | 0
YT | Mayotte | 262 |  | 6 | 0
YU | Yougoslavie | 381 |  | 7 | 0
ZA | Afrique du Sud | 27 |  | 7 | 0
ZM | Zambie | 260 |  | 7 | 0
ZW | Zimbabwe | 263 |  | 7 | 0


PC Profils carton

Valeurs numériques

PC N1 | Epaisseur de la caisse pliée définie en millimètres
PC N2 | Nombre de papiers constituant le profil

Valeur alpha 1

PC A1[1,3]

Structure du carton

PC A1[4,9]

Code machine ( ) ~

PC A1[10,12]

Nombre d'articles par colis par défaut (numérique)

PC A1[13,15]

Nombre minimum d'articles par colis (numérique)

PC A1[16,18]

Nombre maximum d'articles par colis (numérique)

PC A1[19]

Recherche de l'épaisseur du PF plié pour les devis non jonctionnés sur la qualité du devis (O/N, N par défaut)

ATTENTION : Spécifique au programme devis_ondu.

PC A1[20]

Type de la première cannelure (A, B, C, D)

A définir pour toutes les cannelures

PC A1[21]

Type de la seconde cannelure (A, B, C, D)

A définir pour les cannelures de type DD ou TC

PC A1[22]

Type de la troisième cannelure (A, B, C, D)

A définir pour les cannelures de type TC

PC A1[23,28]

Epaisseur du profil carton (numérique)

Définie en millimètres

PC A1[29,31]

Code gamme cartonnier par défaut (Ref Gamme)

Permet de définir la gamme utilisée pour les commandes cartonniers en fonction du profil carton

Utilisé pour les sites disposant de plusieurs onduleuses

PC A1[32]

Type de la quatrième cannelure (A, B, C, D)

A définir pour les cannelures de type QC

PC A1[33]

Initialisation du grammage de la colle à zéro (O/N, N par défaut)

PC A1[34,39]

Dimension de la majoration à utiliser si celle-ci n'est pas renseignée sur le couple FEFCO et profil carton (en mm)

Remarque : Cette dimension est prise en priorité sur la saisie des majorations du programme FEFCO : Saisie des FEFCO > Pointages (F11) > Profil carton (F8)

PC A1[40,42]

Code groupement matière du profil carton

Ce code permet de faire des regroupements de profil carton pour sortir un état de comparaison matière

Le profil carton est la famille ou la sous-famille selon #CF ATL A2[17].

Valeur alpha 2

PC A2[1,9]

Définit les lanceurs associés à chaque papier

On liste toujours les papiers de l'extérieur vers l'intérieur

Attention : après avoir modifié ce paramétrage, il faut lancer le recalcul batch des compositions.

Exemples

123 Pour un profil C

Le cannelé C est sur le lanceur 2

Le papier intérieur est sur le lanceur 3

145 Pour un profil B

Le cannelé B est sur le lanceur 4

Le papier intérieur est sur le lanceur 5

12345 Pour un profil CB

Le cannelé C est sur le lanceur 2

Le papier médian est sur le lanceur 3

Le cannelé B est sur le lanceur 4

Le papier intérieur est sur le lanceur 5

Ce paramétrage permettra au module de gestion des qualités carton de générer les TSC PA? associés à la composition. Dans notre exemple sur le profil B, le module créera des TSC PA1, PA4 et PA5 qui contiendront en ic_char30 le code de chacun des papiers.

Valeur alpha 3

PC A3[1,4] | Nombre de plaques par palette en sortie d'onduleuse (voir transfert PC-TOPP)
PC A3[5,8] | Nombre de plaques par palettes en sortie onduleuse Utilisé par voluedit_oex_tc

Valeur alpha 4

PC A4[1,3] | Correspondance code profil PCTOPP (pour le transfert PCTOPP MIDATA)
PC A4[4,8] | Borne inférieure de l'épaisseur normalisée
PC A4[9,13] | Borne supérieure de l'épaisseur normalisée

Notes

CADENCE_BASE | Cadence de base 15,17 Code indice LNE 20,26 Cadence onduleuse de base
FEFxxx-yyy | 4,6 Code FEFCO dessus 7 tiret (signe "moins") 8,10 Code FEFCO dessous 21, 23 Nombre d'articles par défaut
LAIZE_DI | Laizes disponibles 15, 17 Code groupabilité 20,23 Laize disponible 1 25,28 Laize disponible 2 30,33 Laize disponible 3 35,38 Laize disponible 4 40,43 Laize disponible 5 45,48 Laize disponible 6 50,53 Laize disponible 7 55,58 Laize disponible 8
LAIZE_DI_2 | Laizes disponibles (suite) 15,17 Code groupabilité 20,23 Laize disponible 9 25,28 Laize disponible 10 30,33 Laize disponible 11 35,38 Laize disponible 12 40,43 Laize disponible 13 45,48 Laize disponible 14 50,53 Laize disponible 15 55,58 Laize disponible 16
LAIZE_DI_MO | Laizes disponibles mono 15, 17 Code groupabilité 20,23 Laize disponible mono 1 25,28 Laize disponible mono 2 30,33 Laize disponible mono 3 35,38 Laize disponible mono 4 40,43 Laize disponible mono 5 45,48 Laize disponible mono 6 50,53 Laize disponible mono 7 55,58 Laize disponible mono 8
LAIZE_MOY | Laize moyenne 15,17 Code groupabilité 20,26 Laize moyenne
RIVE_MAXI_ONDULEUSE | 21,24 Valeur de la rive maxi (en mm)
RIVE_MINI_ONDULEUSE | 21,24 Taille minimum de la rive (mm). La taille est exprimée pour un côté. Ne pas oublier de multiplier par 2 pour les 2 côtés.
ROGNE | Prendre en compte systématiquement la prise de pinces Voir la note PINCES_SYSTEMATIQUES dans #CF DKP. 6,11 Code machine 12,16 Rogne sens travers 17,21 Rogne sens machine


PDE Paramétrage des dépendances

Voir aussi Opérations élémentaires et dépendances

Ces paramètres sont une aide au paramétrage des formules dans le devis feuille.

Un paramètre dépendance contient un code calcul et son paramétrage, que l'on peut récupérer par F7 lorsqu'on est dans la fenêtre de saisie des dépendances d'une formule.

Dans la saisie des formules, on peut sélectionner des paramétrages de code calcul via une nouvelle fenêtre.

On peut aussi afficher une documentation (et la modifier) pour chaque paramétrage sélectionnable.

Valeur alpha 1

PDE A1[1,2] | Code calcul
PDE A1[3,9] | Paramétrage du code calcul

Notes

AT | Paramétrage du titre 4,5 Code calcul 7,12 Paramétrage du code calcul 14,60 Description simple du code calcul C'est la description qui sera affichée dans le tableau de sélection (Fig. A)
AD | Paramétrage de la documentation 4,5 Code calcul 7,12 Paramétrage du code calcul 14,60 Documentation correspondante au paramétrage du code calcul Le texte peut être sur plusieurs lignes. C'est la documentation qui sera affichée dans l'onglet inférieur ou dans la fenêtre de documentation seule (Fig. B et C) Le texte peut être mis en forme avec les balises suivantes : <br> Passage à la ligne <u>[texte]</u> Souligner le texte <b>[texte]</b> Mettre en gras le texte <i>[texte]</i> Mettre en italique le texte <ul> <li>[texte1]</li> <li>[texte2]</li> </ul> Mettre texte1 et texte2 sous la forme d'une liste

ATTENTION

Les notes commençant par AT et AD doivent exister si le paramétrage doit être présent dans la fenêtre de sélection.

Les notes commençant par AT et AD doivent obligatoirement être saisies par couple et suivre l'ordre indiqué (AT puis AD).

Exemples

AT CNxxx1

AD CNxxx1

AT IE1

AD IE1

etc.

Exemples de paramétrage

Notes commençant par AD, caractères 14 à 60 | Résultat affiché à l'écran (Fig. B et C)
Ce paramétrage retourne la présence de | Ce paramétrage retourne la présence de bascule Paramétrage du retour via le caractère 2 • A : Retourne O/N • N : Retourne 1/0
<b>bascule</b>
<br><br>
<u>Paramétrage du retour via le caractère 2</u>
<ul>
<li>A : Retourne O/N</li>
<li>N : Retourne 1/0</li>
</ul>


PEL Types de pelliculage

Le type de pelliculage est stocké dans la zone fi_type_pellic.

Valeurs numériques

PEL N1 | Utilisée dans le code calcul IE, si caractère 1 = M.
PEL N2 | Utilisée dans le code calcul IE, si caractère 1 = O.

Valeur alpha1

PEL A1[1,15]

Code article de pelliculage


PER Code périodicité

Valeurs numériques

PER N1 | Jour - selon A1[1] si A1[1] = S : Jour de la semaine (1=lundi, 2=mardi, etc.) si A1[1] = M : Jour du mois 0 Plusieurs jours dans le mois (voir A2) 1 un seul jour : Le 1er de chaque mois 2 un seul jour : Le 2 de chaque mois 3 un seul jour : Le 3 de chaque mois, etc. 31 Le 31 de chaque mois ou fin de mois si A1[1] = P : Nombre de jours de la période 5 Tous les 5 jours ( 5-10-15-20-25-30) 7 Tous les 7 jours ( 7-14-21-28) 10 Tous les 10 jours (10-20-30) 14 Tous les 14 jours (14-28) 15 Tous les 15 jours (15-30), etc.
PER N2 | Ecart autorisé sur la date pour facturer ou éditer les relevés

Valeur alpha 1

PER A1[1]

Code calcul périodicité

S Semaine

M Mois par défaut)

P Période

PER A1[2]

Gestion de la période incomplète (O/N, N par défaut)

Exemple

Si N, nombre de jours de la période 7 et mois de 30 jours, le mois se décompose en 4 périodes qui sont

du 1 au 7

du 8 au 14

du 15 au 21

du 22 au 28

Si O, nombre de jours de la période 7 et mois de 30 jours, le mois se décompose en 5 périodes qui sont

du 1 au 7

du 8 au 14

du 15 au 21

du 22 au 28

Du 29 au 30

Valeur alpha 2

PER A2[1,40]

Jours du mois (20 x 2 caractères)

A remplir si code calcul périodicité M et si plusieurs jours dans le mois

Dans ce cas, Valeur 1 DOIT être égale à zéro

Exemple 102031 le 10, le 20 et le dernier jour du mois


PHA Phase

Les différentes phases :

  • EMC Emballage caisse

  • EMF Emballage film

  • EMP Emballage palette

Valeurs numériques

PHA N1

Coefficient multiplicateur du temps dans le tableau d'édition des opérations (colonne T) afin d'obtenir la longueur théorique de la bande planning

PHA N2

Pourcentage à ajouter à la longueur théorique de la bande planning pour obtenir la longueur maxi de la bande planning (tableau édition des opérations, colonne U).

Permet, combiné à la valeur 1, de déterminer une longueur mini et une longueur maxi de la bande planning

Valeur alpha 1

PHA A1[1,15]

Code matière par défaut (1)

PHA A1[16,18]

Code formule par défaut (1)

PHA A1[19]

Code famille phase

F Façonnage

E Emballage

PHA A1[20,21]

Ordre d'apparition dans certaines éditions (par exemple, dans le tableau des enjeux)

PHA A1[22]

Participe à l'éclatement de l'amalgame (O/N, N par défaut) (touche F27 sur entité devis car)

Utilisé aussi dans le devis standard. Voir la note INFOS_PHASE_REF_ sur TEN

PHA A1[23]

Flag de planification (O/N, N par défaut)

Ce paramétrage permet de renseigner la zone opération à planifier du fichier concernant la définition des tâches.

L'ordre des opérations n'est pas le même que celui du devis.

On indique donc sur chaque phase par le biais des LCO l'ordre dans le processus de fabrication.

Les LCO définissant l'ordre des opérations ont des notes de type ORDRE_OPERATION.

PHA A1[24]

Afficher une ligne de totalisation pour cette phase dans la saisie du tableau des phases

PHA A1[25,27]

Type de phase (utilisé dans l'optimisation des phases, touche F23)

Voir TEN, toutes les notes commençant par REC_MACHINE_XXXXXXX

ASS machine d'assemblage

BRA Braille

CAS Cassage

BSC Brochure sans couture (collé) - Voir Code calcul GN, caractère 1 = 2

COL Collage

COU Couture

DEC Découpe

DOR Dorure

EMB Emboîtage

FEN Fenêtrage

FOU Foulage

GAR Gardes (imprimées et blanches)

GAU Gaufrage

HOL Hologramme

IMP Impression

IMR Impression recto - déclenche également (touche F23) la mise à jour du code machine impression recto sur l'écran des entités (fi_mac_imp)

IMV Impression verso – déclenche également (touche F23) la mise à jour du code machine impression verso sur l'écran des entités

JAQ Jaquette

PIQ machine d'encartage / piqûre

RAI Rainage

TRF Transfert / Poudrage

VIG Vignette

Valeurs par défaut

Pour l’optimisation des phases : Pas de valeur par défaut

Pour le calcul des gâches cumulatives et la mise à jour des prix par référence : Code phase

PHA A1[28,30]

Code du type de note associé (zone fn_type de la table note_ldev)

PHA A1[31,45]

Code matière par défaut (2)

PHA A1[46,48]

Code formule par défaut (2)

PHA A1[49]

Paramétrage de l'ouverture de la fenêtre sous-traitance en automatique

N Pas d'ouverture automatique

O Ouverture automatique

PHA A1[50]

Paramétrage de l'ouverture d'une fenêtre permettant la saisie de la machine et du code de difficulté

N Pas d'ouverture automatique

O Ouverture automatique

Valeur alpha 2

PHA A2[1,3]

Section par défaut (1)

PHA A2[4,6]

Opération par défaut (1)

PHA A2[7,9]

Sous-opération par défaut (1)

PHA A2[10,15]

Machine par défaut (1)

PHA A2[16,18]

Code difficulté par défaut (1)

PHA A2[19,21]

Formule par défaut (1)

PHA A2[22]

Phase à éditer dans l'édition de la gâche (O/N, N défaut)

Voir exemples plus bas

PHA A2[23,25]

Code sous-opération de réalisation ou de roulage de la phase

Pour l'édition de la gâche - Voir exemples plus bas

PHA A2[26]

On ne tient pas compte du temps lors du contrôle d'annulation de la ligne de commande (O/N, N par défaut)

PHA A2[27]

Fonctionnement spécifique à la gestion des cadencements de fabrication avec sous-devis de fabrication réels

Exclusion de la phase du calcul selon l'appartenance à un type de cadencement (IMP/FAC)

O La phase est prise en compte seulement si elle fait partie des types de cadencements associés à la commande de fabrication (TCF A2[10,27]) (par défaut).

N La phase est toujours prise en compte, quel que soit son appartenance aux types de cadencements.

PHA A2[28]

La phase est-elle prise en compte dans le transfert vers Preactor ? (O/N, N par défaut)

PHA A2[29]

Afficher au minimum une ligne pour la phase quel que soit le paramétrage du mode d'affichage dans les formules.

O Si aucune ligne n'entre dans le critère d'affichage des formules (matière/opération/sous-traitance) de la phase, on affiche la première ligne de formule trouvée dans le tableau (par défaut)

N Si aucune ligne n'entre dans le critère d'affichage des formules (matière/opération/sous-traitance) de la phase, celle-ci n'est pas affichée dans le tableau.

Permet, dans le tableau de détail des phases (F18) d'afficher au moins une ligne d'une phase sans données, quel que soit le paramétrage du mode d'affichage des formules (ul_param[27]).

PHA A2[28,30]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

PHA A2[31,33]

Section par défaut (2)

PHA A2[34,36]

Opération par défaut (2)

PHA A2[37,39]

Sous-opération par défaut (2)

PHA A2[40,45]

Machine par défaut (2)

PHA A2[46,48]

Code difficulté par défaut (2)

PHA A2[49,51]

Formule par défaut (2)

PHA A2[52]

Phase rattachée (Temps et coûts) (O/N, N par défaut)

Pour l'édition de la gâche - Voir exemples plus bas

PHA A2[53,55]

Code section de l'opération de rattachement

Pour l'édition de la gâche - Voir exemples plus bas

PHA A2[56,58]

Code opération de l'opération de rattachement

Pour l'édition de la gâche - Voir exemples plus bas

PHA A2[59]

Phase prenant en compte le nombre de poses pour le calcul de l'encours

PHA A2[60]

Fixe ou variable si saisi en montant (F ou V)

Exemples pour l'édition de la gâche

Code PHA | PHA A2[22] | PHA A2[23,25] | PHA A2[52] | PHA A2[53,55] | PHA A2[56,58]
COL | O | ROU | N ou [blanc] | [blanc] | [blanc]
DEC | O | ROU | N ou [blanc] | [blanc] | [blanc]
IOF | O | ROU | N ou [blanc] | [blanc] | [blanc]
VAC | N ou [blanc] | [blanc] | O | IO | IOF

Valeur alpha 3

PHA A3[1,3]

Section par défaut (3)

PHA A3[4,6]

Opération par défaut (3)

PHA A3[7,9]

Sous-opération par défaut (3)

PHA A3[10,15]

Machine par défaut (3)

PHA A3[16,18]

Code difficulté par défaut (3)

PHA A3[19,21]

Formule par défaut (3)

PHA A3[22,30]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

PHA A3[31,33]

Section par défaut (4)

PHA A3[34,36]

Opération par défaut (4)

PHA A3[37,39]

Sous-opération par défaut (4)

PHA A3[40,45]

Machine par défaut (4)

PHA A3[46,48]

Code difficulté par défaut (4)

PHA A3[49,51]

Formule par défaut (4)

PHA A3[52,54]

Numéro de phase fixe pour ce code phase

#CF DEG A3[6] doit être = O (Oui).

PHA A3[55,57]

Code calcul de la phase. Il est par défaut égal au code de la phase. Il permet de rattacher une phase à une génération automatique standard.

Exemple

Pour l'emballage, les phases EMF, EMC, EMP sont calculables automatiquement. Vous pouvez créer une phase EM2 qui sera rattachée au calcul standard EMF

PHA A3[58]

O La gâche fixe sera divisée par le nombre de poses

(La gâche fixe sera exprimée en nombre de livres)

[blanc] La gâche fixe n'est pas divisée par le nombre de poses

(La gâche fixe sera exprime en nombre de feuilles)

PHA A3[59]

O Si la gâche n'a pas été forcée sur cette phase, on régénère la phase à partir des éléments présents sur ce paramètre (valable sur les phases qui ne sont pas générées automatiquement (pliage, conditionnement)

[blanc] Aucune régénération (choix par défaut)

PHA A3[60]

Activation de l'utilisation des LCO contextuelles sur la phase (O/N)

Ouverture automatique après le champ matière si la phase est active.

Valeur alpha 4

PHA A4[1,3]

Formule par défaut

PHA A4[4,9]

Fournisseur par défaut

PHA A4[10,24]

Code matière par défaut

C'est aussi le code matière généré lors de la génération du dossier, si le code matière n'est pas renseigné dans la saisie de la sous-traitance du devis (ctrl Y)

PHA A4[25,27]

Unité de prix par défaut

PHA A4[28]

Activation de la gestion du façonnage multi-passages pour cette phase

O Façonnage multi-passages activé, les opérations de façonnage seront dupliquées :
2 opérations (calage/roulage) par nombre de passages

N Façonnage multi-passages désactivé, les opérations ne sont pas dupliquées (par défaut)
Nécessaire pour TMC_controle_piqueuse = 001

PHA A4[29]

Activation de la gestion du pliage multi-poses

Uniquement pour la phase PLI. Voir aussi la note #O

O Pliage multi-poses activé, les opérations de pliage seront dupliquées

N Pliage multi-poses désactivé, les opérations ne sont pas dupliquées (par défaut)

Activation de la gestion du façonnage multi-poses

Pour les phases de façonnage. Voir aussi la note #O

O Façonnage multi-poses activé, les opérations de façonnage seront dupliquées

N Façonnage multi-poses désactivé, les opérations ne sont pas dupliquées (par défaut)

PHA A4[30,35]

Code machine de référence pour l'ajustement automatique des rognes

Remarque : si aucune machine n'est renseignée, c'est le fonctionnement actuel (contrôles dimensionnels via les notes CODES_CONTROLE_FACO saisis sur le type de machine TMC) qui est pris en compte.

PHA A4[36]

Dans l'optimisation par phase du devis multi-métiers, permet d'indiquer qu'une phase ne doit pas être optimisée.

Ce paramétrage n'est actif que si le devis multi-métiers est utilisé en optimisation multiple (imprimerie + par phase)

Prise en compte d'une phase lors de l'optimisation par phase (O/N, O par défaut)

O La phase est prise en compte lors de l'optimisation du devis par phase

N La phase est ignorée lors de l'optimisation du devis par phase

TEN A2[28] doit être égal à M.

PHA A4[37,51]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

PHA A4[52]

Sélection de cette phase dans édition spécifique (Gamme et Nomenclature)

PHA A4[53]

Sélection de cette phase dans édition spécifique (Nomenclature)

PHA A4[54]

Notes de fabrication éditées sur fiche suiveuse

O (ou espace) Edition

N pas d'édition

PHA A4[55]

Phase à prendre en compte sur l'édition de la fiche suiveuse (Spécifique R, B)

O Edition

N (ou espace) Pas d'édition

PHA A4[56]

Mode d'affichage de l'optimisation

M Choix manuel de la machine sur le tableau présenté

A Choix automatique Valeur la plus économique

PHA A4[57,59]

Pourcentage à appliquer à la cadence devisée pour obtenir la cadence atelier dans l'édition du tableau des opérations (colonne V)

Pour une opération calculée avec un temps standard, le pourcentage est appliqué en sens inverse.

Si le pourcentage indiqué est positif, on alloue moins de temps en atelier que ce qui a été devisé, sinon, on alloue plus de temps.

Exemple

10 % sur la cadence

Si cadence devis = 10000 : 11000

Si temps standard devis = 1,00h : 0,9 h

Exemple

-10 % sur la cadence

Si cadence devis = 10000 : 9000

Si temps standard devis = 1,00h : 1,1 h

PHA A4[60]

Spécifique Client

Exemple

La phase participe à l'édition du prix de revient : O/N

Nombre de bons de travaux à éditer (0, 1, 2, 3, etc.)

Notes triées

CODE_LCO_ASSOCIE

Code LCO associé permettant de récupérer la machine imposée pour la phase (champ 38).

Le code machine imposée sera saisi dans la ligne complémentaire de l'entité concernée (un code machine imposée par code phase).

CODE_MACHINE_STR

Envoi des informations à Preactor pour la sous-traitance :

• Machine associée à la phase

• Libellé du type de la machine associée à la phase

• Temps de calage

• Temps d'exécution

• Quantité sous-traitée

21,26 Code machine de sous-traitance. Pas de valeur par défaut

27 Inutilisé

28,30 Code du TSC sur la machine de sous-traitance sur laquelle récupérer :

• Le temps de calage. Zone numérique 1 (ic_num1) - Par défaut : 0

• Le temps d'exécution (roulage). Zone numérique 2 (ic_num2) - Par défaut : 1

31 Inutilisé

32,34 Code TPR associé à la sous-traitance totale (devis de sous-traitance). Par défaut : STR

_CORRES_PHASE_MAT

Correspondance Phase Matière

21,23 Racine du numéro de phase de fab1.

Exemple

Les phases OF (offset) sont générés avec un numéro de phase 3001, 3002, ...

La racine est donc 300.

25,27 Code la famille matière à rechercher dans pour consommations (table fab0).

Exemple

La famille PPI sera associée à la phase OF et la racine 300.

30 Recherche des consommations par laize (O/N, N par défaut)

Exemple

Les papiers seront recherchés par laize.

Voir v_fab1, options Opq et Ovf, note _SUP_REQ_TEMP

#D

Notes générées ou éditées automatiquement sur la proposition de prix au client (édition commerciale du devis).

#EDD

Définit si la phase est à éditer dans les différents tableaux des devis techniques de l'édition détaillée

5 N Phase non éditée dans tableau phases

6 N Phase non éditée dans tableau opérations

7 N Phase non éditée dans tableau matière/opérations

#EDS

Définit si la phase est à éditer dans les différents tableaux des devis techniques de l'édition simplifiée

5 N Phase non éditée dans tableau phases

6 N Phase non éditée dans tableau opérations

7 N Phase non éditée dans tableau matière/opérations

EXCLUE_DETAIL_PHASE

21 Exclure la phase dans la visualisation du détail des phases (Touche F18) (O/N)

#G

Machine participant à l'optimisation

Machine (6 caractères de 3 à 8)

Numéro de filtre (9 à 28 par 2 caractères)

Filtre 01 Contrôle par rapport au TPR

ATTENTION !

Après le calcul de l'optimisation, le système va, en fonction de A4[56] :

soit prendre en compte la meilleure valeur trouvée

soit afficher toutes les solutions

LCO_PLACEMENT_COUPE

Code de la LCO servant à sauvegarder les totaux des placements/coupes massicots pour cette phase (par défaut pas de sauvegarde)

#M

Matière par défaut

3,17 Code matière par défaut

18,20 Code formule par défaut

21 Type de ligne par défaut

G Globale

R Référence

A Automatique

F Forcée

22,27 Code fournisseur par défaut

NTS_PLACEMENT_COUPE

Code des notes servant à sauvegarder les valeurs des placements/coupes massicots pour cette phase (par défaut PLC)

1,18 NB_PLACEMENT_COUPE

21,23 Valeur de placement

41,43 Valeur de coupe

NUM_OPTION_DEFAUT

21 Numéro d'option par défaut pour la phase actuelle

#O

Opération par défaut

3,5 Section par défaut

6,8 Opération par défaut

9,11 Sous-opération par défaut

12,17 Machine par défaut

18,20 Code difficulté par défaut

21,23 Code formule

24 Type de ligne par défaut

G Globale

R Référence

A Automatique

F Forcée

Par défaut, la valeur sera prise sur la donnée diverse 23 de la formule.

25,26 Numéro de passage par défaut (1 par défaut)

27,28 Nombre de poses par défaut (1 par défaut)

NUM_PASS_LIEE

21,29 Numéro de passage lié avec le code phase

Cette note doit être paramétrée sur chaque phase pour utiliser le code source GA/LIM dans

- l'édition VoluEdit des ordres d'exécution pour les transformateurs

- l'édition du devis technique

PHASES_RATTACHEES

21,59 Listes des codes phases rattachés aux codes phases traités dans Preactor dont les dates prévisionnelles de consommation doivent être mises à jour.

13 codes phases de 3 caractères par ligne

Exemple

La phase COUPEUSE (CO) est rattachée à la phase CARTON POUR IMPRESSION (PPI)

La phase PPI est une phase matière de consommation papier, elle n'est donc pas envoyée à Preactor, il faut donc préciser via ce paramétrage que les dates prévisionnelles de consommation doivent être mises à jour lors de la récupération des informations Preactor de la phase CO.

QUANTITE_AVEC_GF

21 Inclusion des gâches de finition dans la quantité à plier (O/N)

#S

Sous-traitance par défaut

3,5 Code formule par défaut

6,11 Code fournisseur par défaut

12,26 Code matière par défaut

27,29 Unité de prix par défaut

30 Type de ligne par défaut

G Globale

R Référence

A Automatique

F Forcée

TSC_TEMPS_ATTENTE

Temps d'attente (génération de fichiers Preactor)

21,23 Code TSC de temps d'attente

24,24 Zone du TSC de temps d'attente

C Zone numérique 1 (par défaut)

D Zone numérique 2

E Zone numérique 3


PHS Etapes chronologiques

Ce type de paramètre permet de définir les libellés des étapes exploitées par date_sai (soc, code rattachement, type code rattachement).

Valeurs numériques

PHS N1

Ordre chronologique étape

Valeur alpha 2

PHS A2[1,12] | Libellé date1
PHS A2[13,24] | Libellé date2
PHS A2[25,36] | Libellé date3
PHS A2[37,48] | Libellé date4


PLI Type de pli

PLI Types de pli

Valeurs numériques

PLI N1 | Poids maximum / heure. Cette zone est à remplir si on désire une limitation des cadences en fonction du poids maximum / heure.
PLI N2 | Epaisseur maximum de cahier autorisé pour le pli

Valeur alpha 1

PLI A1[1]

Ouverture automatique du F13 dans le devis imprimerie en sortie de saisie de la décomposition de la feuille imprimée

O Ouverture

N Pas d'ouverture

PLI A1[2]

Permet de déterminer la dimension du cahier qui sera engagé dans la plieuse (1 pose au pliage)

L La dimension engagée est la largeur du cahier

H La dimension engagée est la hauteur du cahier

1 La dimension engagée est la largeur du produit fini plié

2 La dimension engagée est la hauteur du produit fini plié

N Pli non utilisable avec 1 pose au pliage

I Ignorer ce pli dans les contrôles de saisie

Pas de valeur par défaut

Pour rappel :

1 pose au pliage : PLI A1[2]

2 poses au pliage : PLI A4[29]

3 poses au pliage : PLI A4[49]

4 poses au pliage : PLI A4[50]

PLI A1[3,8]

Code plieuse par défaut

PLI A1[9,11]

Grammage maximum dans le sens inverse aux fibres

PLI A1[12,14]

Nombre de pages du pli

Ce nombre de pages doit être saisi avec la valeur alignée à gauche, sans 0.

Exemples

Caractère

Pagination 12 13 14

4 4

8 8

10 1 0

48 4 8

64 6 4

PLI A1[15]

Champ d'utilisation du code pli

D Le pli n'est utilisable que sur un devis.

F Le pli n'est utilisable que sur un dossier de fabrication.

2 Le pli est utilisable sur un devis ou sur un dossier de fabrication (par défaut).

PLI A1[16]

Type de pliage/façonnage pour ce pli (concerne les couvertures sur devis BSC/BCO)

P Ce pli sera pliée sur une plieuse (valeur par défaut). La couverture occupera un poste cahier sur la chaîne de piqûre.

M Ce pli sera plié par le margeur de couverture. La couverture n'occupera pas de poste cahier sur la chaîne de piqûre.

T Ce pli sera rainé avant d'être plié par une plieuse. La couverture occupera un poste cahier sur la chaîne de piqûre.

X Ce pli sera rainé et plié manuellement. La couverture occupera un poste cahier sur la chaîne de piqûre.

PLI A1[17]

L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E

PLI A1[18,20]

Grammage maxi toléré (pli parallèle au sens des fibres)

Pour tous les ouvrages sauf les BSC-BCO ( voir TPR A1[21,23])

En liaison avec PLI A1[50]

PLI A1[21]

Piqûre (O/N)

PLI A1[22]

Couture (O/N)

PLI A1[23]

Broché-Collé (O/N)

PLI A1[24,26]

Nombre de bandes

PLI A1[27]

Type de pli

F Feuille

R Roto

PLI A1[28]

Pli participant à l'optimisation (O/N, N par défaut)

PLI A1[29,31]

Grammage minimum

Pour tous les ouvrages sauf les BSC-BCO ( voir TPR A1[21,23])

En liaison avec PLI A1[50]

PLI A1[32]

Ce paramètre détermine si un pli est valide pour un format fini à la française, à l'italienne ou pour les deux

F format à la française

I format à l'italienne

2 les deux (par défaut)

PLI A1[33]

Type de pli

Voir aussi A2[1,15]

E Pli ECMA. Le format ouvert est calculé à partir des données d'un code ECMA
(voir méthode de construction du code ECMA dans le devis standard).

C Pli complexe. Le format ouvert est calculé à partir des plis paramétrés en alpha 2.

M Pli manuel. Le format ouvert est calculé selon les 5 plis renseignés dans l'entité.
Le calcul est le même que le pli complexe.
La seule différence est que les 5 plis sont modifiables.

A Pli asymétrique
Le format ouvert est saisi manuellement ainsi que le détail du pliage dans une fenêtre spéciale.

D Pli détail utile pour la saisie des plis asymétriques

Des plis par défaut peuvent être paramétrés de la même façon que le pli complexe.

PLI A1[34]

Ce paramètre est utilisé dans le cas d'un pli en ligne (A1[27] = R).

Il permet de définir quelle dimension doit être prise en compte pour le contrôle du format page.

H Hauteur du format fini

L Largeur du format fini (par défaut)

PLI A1[35,36]

Ce paramètre est actif si le pli est en ligne (A1[27] = R) et fonctionne conjointement avec A1[34].

Si A1[34] = H, cette zone contient le nombre de pages dans le sens laize.

Si A1[34] = L, cette zone contient le nombre de pages dans le sens développé.

PLI A1[37,39]

Difficulté du pli pour le calage

Cette zone correspond à la dépendance alpha 1 de la formule de calage plieuse O PLI 50.

PLI A1[40,42]

Difficulté du pli pour le roulage

Cette zone correspond à la dépendance alpha 1 de la formule de pliage O PLI 51.

PLI A1[43]

Nombre de plis économiques pour ce pli

PLI A1[44]

Nombre de plis accordéons pour ce pli

PLI A1[45]

Nombre de plis roulés pour ce pli

PLI A1[46]

Numéro du pli pour lequel il y a un dépassant (0 par défaut aucun dépassant)

PLI A1[47]

Pli de type rogné-collé (O/N, N par défaut)

PLI A1[48]

Pli avec cassage en ligne (O/N, N par défaut)

PLI A1[49]

Dimension sur lequel le cassage s'exerce

H Hauteur

L Largeur

Pas de valeur par défaut

PLI A1[50]

Type de pliage/façonnage pour ce pli (concerne les couvertures des ouvrages autres que BSC-BCO)

P Ce pli sera plié sur une plieuse (valeur par défaut).
La couverture occupera un poste cahier sur la chaîne de piqûre.

M Ce pli sera plié par le margeur de couverture.
La couverture n'occupera pas un poste cahier sur la chaîne de piqûre.

T Ce pli sera rainé avant d'être plié par une plieuse.
La couverture occupera un poste cahier sur la chaîne de piqûre.
(Pour le rainage cf. TEN Notes OPT_OPT_TYPO_CAL et OPT_OPE_TYOP_ROU)

X Ce pli sera rainé et plié manuellement.
La couverture occupera un poste cahier sur la chaîne de piqûre.
(Pour le pliage manuel cf. TEN Note OPT_OPE_PLI_MANUEL).

Valeur alpha 2

PLI A2[1,15]

5 codes plis de 3 caractères chacun

Dans le devis standard, le contenu de cette zone dépend de la valeur de la zone A1[33]

Elle conditionne le mode de calcul du format ouvert. Si A1[33] =

E Code contour permettant de calculer le format ouvert de la ligne de décomposition.

C La zone contient 5 codes plis maximum (de 3 en 3 car.) qu'il n'est pas possible de modifier.

M La zone contient 5 codes maximum (de 3 en 3 car.) qu'il est possible de modifier.
Le format ouvert est calculé en fonction du contenu des zones :
A3[1,60] pour la largeur
A4[1,60] pour la hauteur.

A La zone contient 4 codes plis de type détail (A1[33]=D) qui donne un enchaînement de départ pour la saisie manuelle du format ouvert.

D La zone contient les 6 types de pli maximum pour un groupe de pliage (de 1 en 1 car.).
Les deux valeurs possibles sont P (parallèle) et X (croisé).
Ce type de pli n'est autorisé que dans la saisie détaillée d'un pli asymétrique.

La solution imprimerie nécessite de saisir des codes ECMA identiques aux codes plis !

C'est une contrainte de la solution. Les codes ECMA sont donc sur 3 caractères.

PLI A2[16,20]

Largeur minimum

PLI A2[21,25]

Largeur maximum

PLI A2[26,30]

Longueur minimum

PLI A2[31,35]

Longueur maximum

PLI A2[36,38]

Code de pli pour la bande 1

PLI A2[39,41]

Code de pli pour la bande 2

PLI A2[42,44]

Code de pli pour la bande 3

PLI A2[45,47]

Code de pli pour la bande 4

PLI A2[48]

Pli autorisé pour les dépliants (O/N, O par défaut)

Voir aussi TEN A1[31,33]

PLI A2[49]

Pli dédié à la couverture

O Pli utilisable uniquement pour une entité de type couverture

N Pli non utilisable pour une entité de type couverture (par défaut)

Voir aussi TEN A1[31,33]

PLI A2[50]

Pli autorisé pour les feuillets (O/N, O par défaut)

Voir aussi TEN A1[31,33]

PLI A2[51]

Pli dédié à la jaquette

O Pli utilisable uniquement pour une entité de type jaquette

N Pli non utilisable pour une entité de type jaquette (par défaut)

Voir aussi TEN A1[31,33]

PLI A2[52]

Pli autorisé pour un encart rapporté (O/N, O par défaut)

Voir aussi TEN A1[31,33]

PLI A2[53]

Pli autorisé pour les couvertures pour cartonnés (O/N, O par défaut)

PLI A2[54,59]

R E S E R V E S - R E S E R V E S - R E S E R V E S - R E S E R V E S - R E S E R V E S - R E S E R V E S - R E S E R V E S

PLI A2[60]

Sens de la hauteur des poses

Permet de définir pour le pli le sens de la hauteur des poses (pour le calcul du respect du sens des fibres).

1 La hauteur de la pose est parallèle à la largeur du format ouvert

2 La hauteur de la pose est parallèle à la longueur du format ouvert

Pas de valeur par défaut (le renseignement de cette valeur est obligatoire pour le devis optimisé).

Valeur alpha 3 - Descriptif de pliage de la largeur

PLI A3[1,60] - Le descriptif est construit par blocs de 3 caractères.

Chaque bloc est défini de la façon suivante (voir explications complémentaires plus bas) :

PLI A3[1] PLI A3[2] | N Largeur du format fini A3[2] = D Ajustement négatif sur le premier volet du pli suivant A3[2] = E Ajustement négatif sur le premier volet du pli suivant + 0,5 mm A3[2] = F Ajustement négatif sur le dernier volet du pli suivant A3[2] = G Ajustement négatif sur le dernier volet du pli suivant + 0,5 mm A3[2] = / La valeur trouvée sera divisée par 2 (cas des plis fenêtres). I Largeur du format fini A3[2] = D Ajustement négatif sur le premier volet du pli suivant inversé A3[2] = E Ajustement négatif sur le premier volet du pli suivant inversé + 5 mm A3[2] = F Ajustement négatif sur le dernier volet du pli suivant inversé A3[2] = G Ajustement négatif sur le dernier volet du pli suivant inversé + 0,5 mm A3[2] = / La valeur trouvée sera divisée par 2 (cas des plis fenêtres). D Dépassant (dans ce cas, ne rien paramétrer en caractères 2 et 3).
PLI A3[3] | Valeur de l'ajustement

Valeur alpha4 - Descriptif de pliage de la hauteur

PLI A4[1,60] - Le descriptif est construit par blocs de 3 caractères.

Chaque bloc est défini de la façon suivante (voir explications complémentaires plus bas) :

PLI A4[1]

Hauteur du format fini

N Normal

I Inversé

PLI A4[2]

Ajustement négatif

D sur le premier volet du pli suivant (inversé si A4[1] = I)

E sur le premier volet du pli suivant (inversé si A4[1] = I) + 0,5 mm

F sur le dernier volet du pli suivant (inversé si A4[1] = I)

G sur le dernier volet du pli suivant (inversé si A4[1] = I) + 0,5 mm

/ La valeur trouvée sera divisée par 2 (cas des plis fenêtres).

PLI A4[3]

Valeur de l'ajustement

PLI A4[4,21]

6 blocs de 3 caractères identiques au bloc A4[1] - A4[2] - A4[3]

PLI A4[22,24]

Grammage minimum

Uniquement pour les TPR de type BSC/BCO (TPR A1[21,23] = BSC ou BCO)

PLI A4[25,27]

Grammage maximum toléré (pli parallèle au sens des fibres)

Uniquement pour les TPR de type BSC/BCO (TPR A1[21,23] = BSC ou BCO)

PLI A4[28]

Nombre de rabats sur le pli (0, par défaut/1/2/&)

Permet d'ouvrir l'écran de saisie de détail du FEFCO s'il existe un rabat sur le pli

(Saisie de la décomposition de la feuille, saisie de l'écran d'entité feuillet/dépliant).

PLI A4[29]

Permet de déterminer la dimension du cahier qui sera engagé dans la plieuse (2 poses au pliage)

L La dimension engagée est la largeur du cahier

H La dimension engagée est la hauteur du cahier

1 La dimension engagée est la largeur du produit fini plié

2 La dimension engagée est la hauteur du produit fini plié

N Pli non utilisable avec 2 poses au pliage

I Ignorer ce pli dans les contrôles de saisie

Pas de valeur par défaut

Pour rappel :

1 pose au pliage : PLI A1[2]

2 poses au pliage : PLI A4[29]

3 poses au pliage : PLI A4[49]

4 poses au pliage : PLI A4[50]

PLI A4[30]

N'est plus utilisé - Voir A4[29] L I B R E - L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E -L I B R E

PLI A4[31]

Présence d'un pli difficile pour le type de machine assembleuse/couseuse (ASS)

Remarque : Paramétrage lié au code calcul CH7

PLI A4[32]

Nature de pliage associée au code pli

O Présence de pliage (par défaut)

N Pas de présence de pliage (par défaut si le code pli est PLA)

L Présence de pliage en ligne (par défaut si le code pli est de type roto)

R Présence de refente seule

PLI A4[33,47]

Si A1[33] = E : Code contour permettant de calculer le format ouvert de l'entité.

Si ce code n'est pas renseigné, on prend par défaut celui saisi en A2[1,15].

Important : Ce paramétrage n'est pris en compte que pour le code pli saisi sur la première ligne de décomposition.

PLI A4[48]

Pli de type rogné (pour type de produit ROG, voir TPR A1[21,23]) (O/N, N par défaut)

PLI A4[49]

Permet de déterminer la dimension du cahier qui sera engagé dans la plieuse (3 poses au pliage)

L La dimension engagée est la largeur du cahier

H La dimension engagée est la hauteur du cahier

1 La dimension engagée est la largeur du produit fini plié

2 La dimension engagée est la hauteur du produit fini plié

N Pli non utilisable avec 3 poses au pliage

I Ignorer ce pli dans les contrôles de saisie

Pas de valeur par défaut

Pour rappel :

1 pose au pliage : PLI A1[2]

2 poses au pliage : PLI A4[29]

3 poses au pliage : PLI A4[49]

4 poses au pliage : PLI A4[50]

PLI A4[50]

Permet de déterminer la dimension du cahier qui sera engagé dans la plieuse (4 poses au pliage)

L La dimension engagée est la largeur du cahier

H La dimension engagée est la hauteur du cahier

1 La dimension engagée est la largeur du produit fini plié

2 La dimension engagée est la hauteur du produit fini plié

N Pli non utilisable avec 4 poses au pliage

I Ignorer ce pli dans les contrôles de saisie

Pas de valeur par défaut

Pour rappel :

1 pose au pliage : PLI A1[2]

2 poses au pliage : PLI A4[29]

3 poses au pliage : PLI A4[49]

4 poses au pliage : PLI A4[50]

PLI A4[51]

Nombre de poses au pliage par défaut pour le pli

1 1 pose au pliage (par défaut)

2 2 poses au pliage

3 3 poses au pliage

4 4 poses au pliage

PLI A4[52]

Multiple du nombre de cahiers pour le pli

(Le nombre de cahiers doit être un multiple de …)

Pas de valeur par défaut

PLI A4[53]

Multiple du nombre de poses d'impression pour le pli

(Le nombre de poses d'impression doit être un multiple de …)

Pas de valeur par défaut

PLI A4[54]

Multiple du nombre de poses d'impression pour le pli pour une bascule possible

(Pour pouvoir basculer, le nombre de poses d'impression doit être un multiple de …)

Pas de valeur par défaut

PLI A4[55]

Permet de déterminer la dimension du cahier qui sera multipliée par le nombre de poses au pliage (pli en 2, 3 ou 4 poses au pliage)

L La largeur du cahier sera multipliée par le nombre de poses au pliage

H La hauteur du cahier sera multipliée par le nombre de poses au pliage

Par défaut, on prend la dimension engagée dans la plieuse selon le nombre de poses au pliage (voir ci-dessus)

Explications complémentaires pour les valeurs alpha 3 et 4

Il ne faut pas préciser les blancs de pli, de barbe de tête ou de pied ou les double-coupes.

Ces valeurs seront automatiquement ajoutées par le programme en fonction des valeurs saisies dans le détail de l'imposition.

Valeur alpha 3 - Largeur. Pour chaque page imposée, le programme compte :

Lorsque 2 pages sont imposées côte à côte, il faut alterner les 2 codes pour qu'un blanc de pli soit en face d'un blanc de pli et qu'un blanc de barbe soit en face d'un blanc de barbe.

Le premier volet du pli suivant est un blanc de barbe ou de pli.

Valeur alpha 4 - Hauteur. Pour chaque page imposée, le programme compte :

Lorsque 2 pages sont imposées côte à côte, il faut alterner les 2 codes pour qu'un blanc de tête soit en face d'un blanc de tête et qu'un blanc de pied soit en face d'un blanc de pied.

Le premier volet du pli suivant est un blanc de tête ou de pied.

Notes

DOCUMENT_PLI

DOCUMENT_PLI

Permet d'ouvrir un document Windows associé au code pli saisi sur la ligne de décomposition de la feuille (touche Control-W).

21,60 Chemin d'accès au document Windows associé au pli

Il est possible d'utiliser les caractères réservés suivants pour remplir le nom de fichier à l'exécution

?01 Réservé

?02 Code client

?03 Devis_Sous devis_Entité

?04 Code pli

Cette note est recherchée dans l'ordre de priorité suivant :

1. sur le code pli (ici)

2. sur le type d'entité

3. sur le paramètre de lancement de la saisie des devis

EXCLURE_DEC_ENT_99

21 Exclure la décomposition associée au type d'entité de l'intégration des plis dans l'entité de façonnage 99 (O/N, N par défaut)

La note du TEN est prioritaires sur celle-ci.

Elle est utilisée par le devis imprimerie feuille et rotative.


POR Types de port

Valeur alpha 1

POR A1[1] | Calcul du port automatique à la validation des lignes de BL O Calcul du port N ou [espace] Pas de calcul du port
POR A1[2] | Type du port (facturable) O ou [espace] Port dû N Port payé (Exemple FRANCO)
POR A1[3] | Devis mécanique O Calcul du port dans le devis mécanique N ou [espace] Pas de calcul du port Devis Imprimerie (devis_standard/devis_car/devis_dco) O On force le calcul du port quelque soit le type de port. Ce paramétrage permet d'utiliser les INCOTERM FCA Franco transporteur (lieu convenu) FAS Franco le long du navire (lieu convenu) FOB Franco bord (Port embarquement) etc. N ou [espace] On tient compte du port uniquement si FRA (Franco)
POR A1[4,6] | Code INCOTERM normalisé pour la déclaration d'échange de biens entre états membres (CE). Correspondance utilisée pour le transfert des tiers JDE La valeur est obligatoire mais non contrôlée.
POR A1[7] | Ville port destination de la fiche tiers O Saisie obligatoire N ou [espace] Saisie non obligatoire
POR A1[8] | Calcul automatique du port à la validation des lignes de commandes O Calcul automatique N Pas de calcul automatique (défaut)
POR A1[9,11] | Type de port à affecter à la commande si, après le calcul automatique, la recherche par tranches a abouti à un montant
POR A1[12,14] | Type de port à affecter à la commande si, après le calcul automatique, la recherche par tranches n'a pas abouti à 0
POR A1[15,17] | Code TVA associé au port
POR A1[18,20] | Correspondance JDE pour achats et tiers Voir les programmes tr_jde_cde et tr_groupage
POR A1[21,23] | Correspondance JDE pour achats
POR A1[24] | Ne pas recalculer la date de livraison proposée après la saisie de la date de départ (O/N, N par défaut)
POR A1[25] | Interdit l'intégration à la logistique (O/N, N par défaut)
POR A1[26,28] | Code tarif (paramètre TAR) pour le calcul du tarif dans la gestion de l'EDI

Notes

CODE_POR_EFFICIAL

21 Code port


PPC Position charge / palette

Utilisé dans le devis onduleur (don).

Valeur alpha 1

A1[1]

Code orientation palette sur 1 caractère à envoyer au système PCTOPP

Caractère 1270 de la zone 082 du fichier OTDATA


PPL Pression latérale

Utilisé dans le devis onduleur (don).

Valeur alpha 1

A1[1,4]

Code taquage sur 4 caractères à envoyer au système PCTOPP

Caractères 1263 à 1266 de la zone 082 du fichier OTDATA


PPV Pression verticale

Utilisé dans le devis onduleur (don).

Valeur alpha 1

A1[1,4]

Code pression verticale sur 4 caractères à envoyer au système PCTOPP

Caractères 1273 à 1276 de la zone 082 du fichier OTDATA

Notes

OTDATA_PRESSION

Code pression pour OTDATA (0 à F) SPECIFIQUE


PRO Code proforma

Valeur alpha 1

PRO A1[1] | Mise à jour du stock (O/N)
PRO A1[2] | Code facture (O/N)
PRO A1[3] | Mise à jour du C.A (O/N)


PRP Préparateur

Le login (paramètre USE, alpha1[1,8]) donne le code user (Code paramètre du paramètre USE).

Le code user (paramètre PRP, alpha1[1,3]) donne le code préparateur (Code paramètre du paramètre PRP).

Valeur alpha 1

PRP A1[1,3] | Code utilisateur (USE)
PRP A1[4,5] | Code identifiant du démon d'édition des fiches palettes lors de la saisie des préparations de commande par lecteur code barre. Cet identifiant doit être paramétré aussi dans le lancement et l'arrêt du démon (voluedit_fiche_pal)
PRP A1[6,11] | Code tiers associé au préparateur


PWD Mot de passe

Valeur alpha 1

PWD A1[1,5]

Mot de passe


QA Qualité article

Un code validité article est un indicateur saisi sur un article. Par l'intermédiaire de cet indicateur, on a la possibilité de gérer un contrôle de saisie pour cet article dans différents modules de manière bloquante ou via un simple avertissement.

Ces modules sont

  • Saisie d'une commande

  • Saisie d'un bon de livraison

  • Edition d'un bon de livraison

  • Saisie d'une commande fournisseur

  • Modification d'un article

  • Génération du dossier de fabrication

  • Devis (spécifique K et B à ce jour)

Lors d'un avertissement ou d'un contrôle bloquant, il y a ouverture d'une fenêtre et affichage d'un message explicatif à l'attention de l'utilisateur.

Le message explicatif peut contenir deux parties :

  • Les notes commençant par N- saisies sur le paramètre <QA> <Code_validité_article>
    Ces notes sont propres à chaque code validité article.

  • Les notes de type #QA saisies sur le client. Ces notes peuvent fournir des explications complémentaires relatives à chaque article mis en cause.

Particularité de codification

Cas du devis carton ondulé

Les articles dont le code validité commence par D sont considérés comme des articles DEVis.

Les articles dont le code validité commence par F sont considérés comme des articles FABriqués.

Il s'agit d'une généralisation de la notion de validité DEV et FAB.

Valeur alpha 1

QA A1[1]

Possibilité de saisir des commandes clients pour l'article (voir notes TYC ci-après)

Possibilité de transférer l'article en commande

O Oui

W Non (non bloquant)

B Non (bloquant)

Cf Traitement des exceptions ci-dessous

QA A1[2]

Possibilité de saisir des bons de livraison pour l'article

O Oui

W Non (non bloquant)

B Non (bloquant)

QA A1[3]

Possibilité d'éditer des bons de livraison pour l'article

O Oui

W Non (non bloquant)

B Non (bloquant)

QA A1[4]

Possibilité de saisir des commandes fournisseurs pour l'article (voir notes TYF ci-après)

O Oui

W Non (non bloquant)

B Non (bloquant)

Cf Traitement des exceptions ci-dessous

QA A1[5]

Possibilité d'empêcher toute modification sur l'article

Possibilité d'empêcher l'utilisation de l'article en génération de produit du devis

Possibilité d'empêcher la régénération de l'article en devis

O Oui (article modifiable)

W Non (non bloquant)

B Non (bloquant)

QA A1[6]

Possibilité d'empêcher la génération du dossier de fabrication (devis ondulé uniquement (K))

O Oui (génération possible)

W Non (génération impossible, non bloquant)

B Non (génération impossible, bloquant)

QA A1[7]

Possibilité d'empêcher la valorisation d'un composant dans le devis (devis ondulé (K) et TC (B) uniquement)

O Oui (valorisation possible)

W Non (valorisation impossible, non bloquant)

B Non (valorisation impossible, bloquant)

QA A1[8]

Code blocage raison planning pour PC-Topp (zone 072).

Ce code est prioritaire par rapport aux codes blocage de la revue de contrat.

QA A1[9]

Possibilité d'empêcher la composition si une qualité papier est invalide

O Oui (composition possible)

W Non (composition impossible, non bloquant)

B Non (composition impossible, bloquant)

QA A1[10]

Code blocage raison commerciale pour PC-Topp (zone 073).

Ce code est prioritaire par rapport aux codes blocage de la revue de contrat.

QA A1[11]

Lancement d'édition de la fiche de spécification

N Pas d'édition de la fiche de spécification

F Edition avec fenêtre de confirmation

S Edition sans fenêtre de confirmation

QA A1[12]

Lancement d'édition de la fiche de fabrication

N Pas d'édition de la fiche de fabrication

F Edition avec fenêtre de confirmation

S Edition sans fenêtre de confirmation

QA A1[13]

Possibilité de contrôler la validité composant d'un PF pour création de l'offre 99 dans le devis

O Oui (valorisation possible)

W Non (valorisation impossible, non bloquant)

B Non (valorisation impossible, bloquant)

QA A1[14]

Génération automatique des besoins matières (O/N, O par défaut)

QA A1[15]

Possibilité d'empêcher la correction de stock pour l'article

O Oui (Correction possible)

W Non (Correction impossible - non bloquant)

B Non (Correction impossible - bloquant)

QA A1[16]

Avertissement de blocage de l'affrètement dans JDE

O La commande est envoyée à JDE comme étant "bloquée".
Le motif de blocage est donné par A1[17,19]

N La commande est envoyée à JDE sans blocage (par défaut)

Voir le programme tr_jde_cde

QA A1[17,19]

Motif de blocage si A1[16] = O

Voir le programme tr_jde_cde

QA A1[20]

Qualité de l'outil (O/N, N par défaut)

O Qualité valide (pour l'activation de phase, renvoie la valeur 1)
Action en cours de type réception

N Qualité non valide (pour l'activation de phase, renvoie la valeur 0)

QA A1[21,23]

Code blocage associé au type de blocage (ex : OUW pour un warning)

Ce code est facultatif. C'est par défaut le code blocage outil qui est utilisé.

QA A1[24]

Code blocage article pour préparation des affrètements

On peut bloquer un ordre de transport (interdiction de l'affréter) en fonction de la validité de l'article.

N Non (par défaut)

W Warning

C Confirmation

B Bloquant

QA A1[25]

Contrôler également la qualité matière associée à l'article (si renseignée)

(O/N, N par défaut)

Le contrôle de la qualité matière ne se fait que si l'article lui-même est valide, et peut entraîner de ce fait sa non validité (si qualité matière non valide).

QA A1[26]

Le passage d'une validité dans une offre 99 (F* hors FAB) à cette nouvelle validité entraîne-t-elle un repositionnement des OF à l'état à régénérer ? (O/N, N par défaut)

Remarque : Le repositionnement des OF à l'état à régénérer est forcé dans le cas du passage à la validité FAB.

QA A1[27]

Possibilité d'empêcher l'entrée en production pour l'article

Utilisé par G_qte_prod

O Oui (Entrée possible)

W Non (Entrée possible – message d'avertissement)

B Non (Entrée impossible - bloquant)

QA A1[28]

Possibilité d'empêcher la génération des produits finis dans le devis multi-métiers

B Bloquant (Génération des produits finis impossible)

N Non (Génération des produits finis possible)

QA A1[29]

Etat de qualification/surveillance

Q Produit à qualifier

S Produit à surveiller

N Pas de qualification/surveillance pour ce produit (par défaut)

QA A1[30]

Création du code blocage automatique 032 (BLO A1[3,5]) (N/O, N par défaut)

QA A1[31]

Autorisation de création d'une ligne de cadencement de livraison (N/O, O par défaut)

QA A1[32]

Autorisation de modification d'une ligne de cadencement de livraison (N/O, O par défaut)

QA A1[33]

Autorisation d'annulation d'une ligne de cadencement de livraison (N/O, O par défaut)

QA A1[34]

Possibilité d'empêcher l'utilisation de l'article dans un sous-devis

N Non (par défaut)

W Warning

B Bloquant

Remarques :

• Ce paramétrage ne concerne que la saisie des produits finis d'un sous-devis, au niveau :
- de l'entête (fle_2)
- de l'entité (fle_imp)
- de la nomenclature (fle_nom)
- des références multiples (fle_dec)

• Ce paramétrage est lié au code blocage automatique BLD 005 :

 Lorsqu'un produit est présent sur un sous-devis avec une validité bloquante (B), le code blocage peut être activé.

 ATTENTION : Si la validité est non bloquante (W), le code blocage ne sera pas activé mais à la saisie de l'article dans le sous-devis, un message apparaîtra.

Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.

QA A1[35]

Doit-on recodifier le composant lors de la recopie d'une offre ? (O/N, O par défaut)

QA A1[36]

Composition valide pour le transfert (programme tr_compo) (O/N, O par défaut)

QA A1[37]

Le code validité article est lié à un code article unique (O/N, N par défaut).

QA A1[38]

L'article est-il un produit temporaire ?

Ce paramétrage permet de désactiver l'interdiction de transférer en commande un produit générique.

Il est utilisé dans le cadre du Transfert en commande de plusieurs devis

O L'article est temporaire. S'il est générique, il peut être transféré en commande.

N L'article n'est pas temporaire.
S'il est générique, il ne peut pas être transféré en commande (par défaut)

Valeur alpha 2

QA A2[1,5]

Mot de passe permettant de passer outre le contrôle bloquant sur la fiche article

QA A2[6]

QA A2[7]

QA A2[8]

QA A2[9]

QA A2[10]

QA A2[11]

QA A2[12]

QA A2[13]

QA A2[14]

M Code validité autorisé pour le type d'article M (Matière)

P Code validité autorisé pour le type d'article P (Produit fini)

S Code validité autorisé pour le type d'article S (Produit semi-fini)

F Code validité autorisé pour le type d'article F (Fourniture)

X Code validité autorisé pour le type d'article X (Fantôme)

T Code validité autorisé pour le type d'article T (Maintenance)

O Code validité autorisé pour le type d'article O (Outil)

K Code validité autorisé pour le type d'article K (Kit)

Q Code validité autorisé pour le type d'article Q (Qualité)

Lors de la saisie du code validité d'un article, permet de filtrer ces derniers par rapport au type d'article.

IMPORTANT : Un code validité est utilisable sur tous les types d'articles si et seulement si aucun paramétrage n'est saisi dans les caractères 6 à 14, ou si tous les caractères sont saisis.

Remarques :

• Ce filtre est actif pour toutes les recherches et listes déroulantes de codes validités (saisie/modification détaillée des articles, saisie/modification simplifiée des articles, saisie/modification des compositions, saisie des TSC des composants, etc.)

• Lors de la saisie du code validité dans la saisie simplifiée des articles, le code saisi est contrôlé par rapport au type d'article en cours. Si le code validité n'est pas compatible avec le type d'article, ce code ne sera pas saisissable

• Un code validité article est par défaut autorisé pour tous les types d'articles si le paramétrage n'est pas renseigné. Si un code validité est associé à un ou plusieurs types d'article, ce code n'est plus autorisé pour les autres types d'articles.

Valeur alpha 3

QA A3[1, 6]

Code machine fictive à intégrer lors du transfert PC-TOPP

QA A3[7]

Envoi de la machine virtuelle configurée en A3[1,6] (O/N, N par défaut)

O On envoie toujours la machine virtuelle.

N On envoie une première fois la machine virtuelle, puis un flag est positionné pour ne plus la renvoyer.

Selon le paramétrage de la qualité d'un article (QA), on envoie les données d'une machine virtuelle vers PCTOPP. Le fonctionnement par défaut est l'envoi de ces données une seule fois.

Quand la commande a été générée une première fois, un TSC est créé automatiquement pour mettre en place un flag pour dire que cet article a déjà envoyé les données de la machine virtuelle vers PCTOPP, donc les prochaines fois les données de la machine virtuelle ne seront pas envoyées en régénération ou lors d'une nouvelle commande utilisant ce code article.

Maintenant, via paramétrage, on peut demander d'envoyer à chaque fois les données de la machine virtuelle. Si ce paramétrage est présent et si le TSC n'existe pas, alors il ne sera pas créé. De plus, si le TSC existe et si le paramétrage est actif, les données seront quand même envoyées.

Notes

MQS_RATTACHES

21,59 Liste des motifs de qualification/surveillance rattachés au code validité

13 codes de 3 caractères (chaque code doit correspondre à un type de paramètre MQS)

Permet de rattacher des motifs de qualification/surveillance (MQS) aux validités des articles (QA), afin de limiter la liste des motifs dans la saisie des commandes.

Remarque technique : Quand le curseur se trouve sur le motif de qualification/surveillance, la liste déroulante (combobox) est remplie automatiquement avec les motifs associés à la validité de l'article de la ligne en cours, et ce pour toutes les lignes de la colonne.

Certains motifs peuvent donc "disparaître" sur les autres lignes que celle en cours, ceci n'affecte que l'affichage et en rien le fonctionnement global.

En effet, la liste est reconstruite à la sortie du champ.

Traitement des exceptions

Utilisé uniquement pour les types de vérification Commandes clients (caractère 1) et Commandes fournisseurs (caractère 4).

Celles-ci sont saisies dans les notes du paramètre de la façon suivante :

TYC | Type de vérification Commandes clients (alpha1[1]) 4 à 6 Type de commande (CD2, FB1, FB2, etc.) 7 Code contrôle (O, W, B ou blanc)
TYF | Type de vérification Commandes fournisseurs (alpha1[4]) 4 à 6 Type de commande (FAD et AVO) 7 Code contrôle (O, W, B ou blanc)
N- | Déterminent la première partie du message explicatif apparaissant lors d'un contrôle bloquant ou d'un warning. 3 à 60 Message complémentaire Exemple N-Attention qualité incorrecte, plus de prise de commande N-pour cet article.


QAF Qualificatif d'affaire

Utilisé dans

le devis standard

la saisie des actions événements

Pas de paramétrage.


QAL Qualificatif d'appel de livraison

Alias : Tolérance sur délai

Valeurs numériques

QAL N1

Nombre de jours à ajouter ou à retirer à la date de fin de fabrication (SPECIFIQUE : saisie sur la ligne d'OF)

Permet de spécifier un nombre de jours entre les dates au plus tard saisies sur la ligne de commande et les dates au plus tôt.

Exemple

Date proposée au client : 28/04/1998 avec un code délai –2

(Le client permet une livraison en avance de 2 jours)

Date proposée au plus tard : 28/04/1998

Date proposée au plus tôt : 26/04/1998

Ce nombre de jours doit être signé.

Les jours non ouvrés ne sont pas comptabilisés dans le décompte.

Utilisation spécifique :

Nombre de jours à retirer de la date proposée au plus tard.

Valeur alpha 1

QAL A1[1]

Type de tolérance délai

S Tolérance à la semaine

La date proposée au plus tôt sera le premier jour ouvré de la semaine correspondant à la date proposée au plus tard.

La date de fin de fabrication au plus tôt sera le premier jour ouvré de la semaine correspondant à la date de fin de fabrication saisie sur l'OF.

I Impératif

La date proposée au plus tôt est égale à la date proposée au plus tard.

La date proposée au plus tôt est égale à la date de fin de fabrication saisie sur l'OF

Autre : Voir valeur numérique 1

Sert aussi de flag envoyé au système de planification (PC-TOPP, OMP, ….)

QAL A1[2]

Edition sur l'AR de la date proposée au client

QAL A1[3]

Qualificatif de type Appel de livraison

S Ligne initiale de l'appel de livraison (exemple: code SAP) - non livrable, mettre A1[4] = B

A Ligne appel de livraison (exemple: code APP) - livrable, mettre A1[4] = N

[blanc] Ligne normale

QAL A1[4]

Interdiction de livrer une ligne de commande sur appel

N Aucun contrôle

B Contrôle bloquant

W Contrôle non bloquant

QAL A1[5]

Correspondance JDE -Voir le programme tr_jde_cde

QAL A1[6]

Utilisation du calcul de la date proposée au plus tôt dans l'édition des AR (O/N, N, par défaut)

QAL A1[7]

Utilisation du calcul de la date de fin de fabrication au plus tôt dans la génération des OF (O/N,N par défaut)

QAL A1[8]

Type d'appel de livraison

F Appel ferme

P Appel prévisionnel

QAL A1[9]

Solde automatique de la ligne de cadencement de livraison en saisie des BL (O/N, N par défaut)

QAL A1[10,30]

Libellé qui représente la variable libs_quantite_initiale_sap (paramétrage -Ovl sur la ligne de commande).

QAL A1[31]

Autorisation de solder le cadencement de livraison (type SAP par exemple) lors d'un bon de transfert (BL avec lieu intermédiaire) même si la ligne de livraison est mise en solde automatique (O/N , O par défaut)

N : on ne soldera pas le cadencement de livraison, même si la ligne de livraison est marquée à solder.

QAL A1[32]

Interdire de changer le qualificatif (N/W/C/B, N par défaut)

N pas d'interdiction

W message de type Warning si le qualificatif est modifié

C demande de confirmation si le qualificatif est modifié

B interdiction de modifier le qualificatif

Valeur alpha 2

QAL A2[1,3]

Type de mouvement de stock de sortie réserve en saisie de commande client)

Voir aussi note MVT_TYPE_LIV_

QAL A2[4,6]

Type de mouvement de stock d'entrée prévisionnelle sur lieu intermédiaire en saisie de commande client) Voir aussi note MVT_TYPE_LIV_

QAL A2[7,9]

Type de mouvement de stock de sortie normale en saisie de bon de livraison

QAL A2[10,12]

Type de mouvement de stock d'entrée normale sur lieu intermédiaire en saisie de bon de livraison

QAL A2[13]

Gérer la sortie réserve en saisie de commande client (cf paramétrage du type de mouvement en A2[1,3] (O/N, O par défaut)

O On génère systématiquement la sortie réserve.

N On génère la sortie réserve si #CF ATL A1[36] = O.

X On ne génère rien quelle que soit la valeur de #CF ATL A1[36]

Pour ne pas créer de mouvement de stock selon le qualificatif de l'appel :

Une qualification SAP (sur appel) ne doit pas déclencher une sortie prévisionnelle.

Ce qualificatif fausse le stock disponible du produit. Paramétrage à mettre en oeuvre :

QAL SAP A2[13] = N

cde l'option Oqd doit être activée

cde A4[36] = 1

QAL A2[14]

Gérer l'entrée prévisionnelle sur lieu intermédiaire en saisie de commande client (cf paramétrage du type de mouvement en A2[4,6] (O/N, O par défaut)

QAL A2[15]

Contrôle de saisie du lieu de rangement de la ligne de cadencement de livraison

N Pas de contrôle (par défaut)

W Contrôle non bloquant, affichage d'un message d'avertissement

B Contrôle bloquant, la saisie du lieu de rangement est obligatoire

QAL A2[16,18]

Nouveau lieu de rangement pour un appel de livraison

2 usages, selon le qualificatif :

1) Pour le qualificatif de la ligne de cadencement de livraison d'origine générant l'appel de livraison :

[blanc] : à la création de l'appel de livraison, le lieu de rangement n'est pas modifié (par défaut).

ini : à la création de l'appel de livraison, le lieu de rangement est réinitialisé à blanc.

[Paramètre de type RG1] : à la création de l'appel de livraison, le lieu de rangement est réinitialisé avec ce nouveau code.

2) Pour le qualificatif de la ligne d'appel de livraison en cours de création :

[blanc] : A la création de 'appel de livraison ou à la modification du qualificatif de la ligne d'appel de livraison, le lieu de rangement n'est pas modifié (par défaut).

ini : A la création de l'appel de livraison ou à la modification du qualificatif de la ligne d'appel de livraison, le lieu de rangement est réinitialisé à blanc.

[Paramètre de type RG1] : A la création de l'appel de livraison ou à la modification du qualificatif de la ligne d'appel de livraison, le lieu de rangement est réinitialisé avec ce nouveau code.

QAL A2[19]

Lors de la création d'un appel de livraison depuis une ligne de cadencement de livraison soldée, désolder automatiquement la ligne de cadencement de livraison d'origine

O Désolde systématique à la création de l'appel de livraison

C Désolde sur demande de confirmation à la création de l'appel de livraison

N Pas de désolde automatique, la création de l'appel de livraison est interdite (par défaut)

QAL A2[20]

Prise en compte du qualificatif dans le calcul de la quantité cadencée de la ligne de commande (N/O, O par défaut)

QAL A2[21]

Forçage de la mise à jour des mouvements de stock de sortie réserve (N/O, N par défaut)

Si A2[21] de la ligne de cadencement de livraison (li_qua) = O, la mise à jour de la sortie réserve sera effectuée.

L'option Omc de la saisie des BL doit être paramétrée.

Si le lieu intermédiaire de l'entête du BL est un lieu de sous-traitance et que la gestion des cadencements de livraison est activée, la sortie réserve ne sera pas modifiée.

QAL A2[22,24]

Lieu de départ (lieu de rangement 1)

QAL A2[25,30]

Lieu de départ (lieu de rangement 2)

QAL A2[31]

Forçage du contrôle de la quantité livrée d'une ligne de cadencement de livraison par rapport à la quantité commandée de la ligne de commande (N/O, N par défaut)

Par défaut, le contrôle est fait par rapport à la quantité à livrer de la ligne de cadencement de livraison.

Ce contrôle est fait dans la saisie des BL.

Ce contrôle est prioritaire sur celui du TOL A1[15]

QAL A2[32]

Doit-on mettre à jour le lieu du mouvement de stock de livraison prévue avec le lieu saisi sur le cadencement de livraison (O/N, N par défaut)

Voir blv option Or3

Notes

CONTROLE_

Contrôle sur le cadencement de livraison

10,19 Champ d'application du contrôle à effectuer

ACT_APPLIV : Création d'un appel de livraison (Action Control-Maj-F2)

21,23 Code du contrôle à effectuer

Si caractère 10 à 19 = ACT_APPLIV :

001 Contrôle de la quantité facturée de la ligne de cadencement de livraison.
La création d'un appel de livraison pour cette ligne sera interdite tant qu'il reste une quantité à facturer.

24 Type de contrôle à effectuer

N Pas de contrôle (par défaut)

C Demande de confirmation

W Contrôle non bloquant (avertissement)

B Contrôle bloquant

MVT_TYPE_LIV_

Les types des mouvements prévisionnels de stock (Sortie Réserve et Entrée Prévisionnelle) des cadencements de livraison peuvent être paramétrés en QAL A2[1,3] et A2[4,6].

Maintenant, ils peuvent être aussi paramétrés cette note en fonction du type de livraison

Celui-ci est dépend du lieu intermédiaire saisi sur la ligne de cadencement de livraison

14, 16 Type de livraison

001 Livraison client en vente directe

002 Entrée mise à disposition client

004 Entrée mise à disposition usine

006 Entrée consignation client

008 Transfert sous-traitant

011 Livraison filiale

21, 23 Type de mouvement de stock de sortie réserve en saisie de commande client

24, 26 Type de mouvement de stock d'entrée prévisionnelle sur le lieu intermédiaire en saisie de commande client


QAI Quai

Ce paramètre est utilisable à partir de la V. 4.0.176.2.

Il est utilisé par le programme de gestion des expéditions des affrètements dans le cadre de l'intégration des données de chargement et création de BL en automatique.

Valeur alpha 1

QAI A1[1,3]

Code du lieu de rangement1 associé au quai

Notes

_SUP_REQ_PICK_ | 15,17 Code du magasin de destination (blanc est autorisé pour livraison au client final) 21,60 Complément de requête sur la table stk0 permettant de limiter les stocks accessibles aux BL générés sur le quai en question.
_SUP_REQ_STK0_NIV1 | 21,60 Complément de sélection sur le lieu de niveau 1 pour la recherche et le contrôle des stocks


QAS Qualificatif action de service

Pas de paramétrage


QEM Qualificatif employé

Ce paramètre est utilisé par sbs.

PAR_LCT_ETAT_AVANCE

21,26 Type et code du paramètre de lancement de la visualisation de l'état d'avancement par défaut

Ce paramétrage est obligatoire pour accéder à la touche F18.

Le paramétrage de lancement de la visualisation d'état d'avancement utilisera de préférence l'option –Oss (exécution directe sans ouverture d'écran de sélection)

Cette note est prioritaire sur la même note dans le paramètre de lancement de sbs.


QRP Quantité de remise de prix

Paramètre requis au niveau des devis

Valeurs numériques

QRP N1 | 1000 pour le prix au 1000 100 pour le prix au 100 etc... 1 pour le prix à l'unité 0 pour le prix global
QRP N2 | Permet de paramétrer l'arrondi utilisé pour le calcul du prix remis. Si la valeur est négative, l'arrondi se fait toujours à la valeur supérieure. Exemple 10 : On arrondit aux 10 francs supérieurs 100 : On arrondit aux 100 francs supérieurs Etc. Si cette valeur n'est pas saisie, il n'y a aucun arrondi

Valeur alpha 1

QRP A1[1] | Mode de transfert du devis en commande [blanc] : Transfert en global si aucune référence, sinon transfert des références (par défaut) R Transfert en global si aucune référence, sinon transfert des références G Transfert en global forcé, quelque soit le nombre de références Permet de transférer un devis en commande en forçant le mode remplissage des lignes de commande en global (pas d'utilisation des références multiples)
QRP A1[2] | L'utilisateur peut modifier l'unité par défaut (O/N, N par défaut) Voir la saisie de commande client papeterie, option Op1
QRP A1[3,4] | Unité par défaut pour la bobine (KG, M2 ou ML) (Par défaut : KG) Voir la saisie de commande client papeterie, option Op1
QRP A1[5,6] | Unité par défaut pour le papier (KG, M2 ou ML) (Par défaut : KG) Voir la saisie de commande client papeterie, option Op1

Valeur alpha 2

QRP A2[1,3] | Formule de conversion pour utilisation spécifique en édition de l'offre de prix
QRP A2[31,60] | Libellé de l'unité de conversion

Valeur alpha 3

QRP A3[1,30] | Libellé de l'unité (Exemple caisses, plaques, etc.)
QRP A3[31,60] | Quantité de la remise de prix (Exemple les 100 caisses, les 1000 plaques, etc.)


QT Qualité tiers

Valeurs alpha 1 et 2

Attention : les valeurs alpha1 et alpha 2 ont le même paramétrage.

La valeur alpha 1 gère le client lui-même.

La valeur alpha 2 gère le groupe de clients.

Si le code contrôle du client (Valeur alpha 1) est à O et si le client est rattaché à un groupe de client, le code contrôle du client est remplacé par le code contrôle du groupe du client (Valeur alpha 2).

Signification des codes pour les valeurs A1[1 à 5], A1[24], A1[42] et leurs équivalents en A2

La valeur par défaut est O dans tous les cas.

Code | Valeur alpha 1 (client) | Valeur alpha 2 (groupe)
O | Le code contrôle du client est remplacé par le code contrôle du groupe du client. | Pas de blocage
N | Pas de blocage | Pas de blocage
B | Contrôle bloquant | Contrôle bloquant
W | Message d'avertissement | Message d'avertissement

QT A1[1]

Possibilité de saisir des devis (Voir tableau ci-dessus)

QT A1[2]

Possibilité de saisir des commandes (Voir tableau ci-dessus)

QT A1[3]

Possibilité de saisir des bons de livraison (Voir tableau ci-dessus)

QT A1[4]

Possibilité de saisir des commandes fournisseurs (Voir tableau ci-dessus)

QT A1[5]

Initialisation du budget pour le compte tiers (Voir tableau ci-dessus)

QT A1[6]

Code blocage raison commerciale pour PC-Topp (zone 073).

Ce code est prioritaire par rapport aux codes blocage de la revue de contrat.

QT A1[7]

Contrôle du calcul du risque à la commande (N/W/B, B par défaut)

QT A1[8,10]

Code blocage utilisé, pouvant interdire certains fonctionnements.

Exemples

FIW pour un code blocage en warning (pas d'interdiction)

FIB pour un code blocage bloquant (gestion d'interdiction)

QT A1[11,12]

Filtre la liste des qualités tiers obtenue par F7 en ne proposant que les codes appropriés

Exemples :

CP filtre pour n'afficher que les codes QT propres aux clients et aux prospects

F filtre pour n'afficher que les codes QT propres aux fournisseurs

Par défaut, tous les codes sont affichés pour tous les types de tiers

QT A1[13]

Sur la saisie des matières, contrôle de cohérence du code fournisseur d'après son code qualité tiers (N/W/B/C, N par défaut)

QT A1[14,19]

Spécifique pour l'intégration des plafonds depuis la comptabilité ORIAC.

Coefficient multiplicateur (par ex. 1.25)

Permet d'appliquer un coefficient au montant de la limite de crédit.

QT A1[20]

Avertissement de blocage de l'affrètement dans JDE

La commande n'est pas rejetée. (O/N, N par défaut)

Voir le programme tr_jde_cde

QT A1[21,23]

Correspondance JDE. N'est utilisée que si alpha1[20] = O

Voir le programme tr_jde_cde

QT A1[24]

Possibilité de facturer pour les clients utilisant ce code qualité tiers (Voir tableau ci-dessus)

QT A1[25,39]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

QT A1[40]

Magasin à affréter ? (O/N, O par défaut)

Ce test n'est effectué que sur le magasin intermédiaire saisi sur la ligne de commande.

QT A1[41]

Qualité du fournisseur bloquant l'envoi d'une demande d'achat (O/N, N par défaut)

QT A1[42]

Possibilité de saisir ou de générer des groupages ou des affrètements pour le client (Voir tableau ci-dessus)

QT A1[43]

Désactiver le transporteur pour les affrètements

O le transporteur est désactivé

N le transporteur n'est pas désactivé (par défaut)

Certains transporteurs peuvent être désactivés dans la préparation des affrètements selon le paramétrage de leur qualité (depuis la fiche tiers).

Si le transporteur est désactivé, il ne sera plus proposé dans la recherche des tarifs ni dans la recherche depuis l'action F7.

La saisie manuelle du code fournisseur désactivé ne sera pas autorisée.

Valeur alpha 2

Identique à alpha 1. Voir remarque en haut de page.

Valeur alpha 3

QT A3[1,15]

Code qualité tiers pour interface SIDE TRADE

Notes

COULEUR_ETAT_QAL | Dans la recherche des clients (#CF ATL A1[2] = [espace] ou B), ajout des colonnes pays, libellé pays , code qualité et une zone état, représentant une couleur en fonction de la qualité. Les couleurs disponibles sont vert, orange et rouge Couleur à afficher Choix possibles : g_bouton_bleu g_bouton_vert g_bouton_orange g_bouton_rouge
N- | 3,60 Message à afficher lors d'un contrôle de type W (Warning - non bloquant) ou B (Bloquant). Ce message peut contenir plusieurs lignes. Il peut être complété par un autre message propre à chaque tiers , par le biais de notes de type #QT saisies sur le tiers mis en cause. Exemple N-Attention mauvais payeur N-Prévenir le service facturation pour accord N-sur toute nouvelle commande


QUA Code qualité papier

Valeurs numériques

QUA N1

Main du papier (pouvant être utilisée pour un calcul d'épaisseur)


REA Code réapprovisionnement

Permet de définir les règles de réapprovisionnement

ATTENTION

Le code paramètre de réapprovisionnement ne doit comporter qu'un caractère et doit être saisi uniquement sur le caractère 1 du code.

Valeurs numériques

REA N1 | La définition de cette valeur est définie par le code saisi en A1[1,3]
REA N2 | La définition de cette valeur est définie par le code saisi en A1[1,3]

Valeur alpha 1

REA A1[1,3] | Code indiquant à quoi servent les valeurs numériques 1 & 2 Exemple : 001. Valeur 1 = Périodicité en jours de la commande de réapprovisionnement Valeur 2 = Période en jours de recherche du besoin net
REA A1[4] | Table utilisée pour le calcul de la quantité Exemple : 5 indique que la table utilisée sera mat5
REA A1[5,7] | Code indiquant le mode de calcul du réapprovisionnement Exemple : 001 est le code pour le réapprovisionnement au stock mini

Valeur alpha 2

REA A2[1]

Mode de mise en fabrication d'un produit fini

S Produit synchrone

Création automatique d'une mise en fabrication dès la saisie de commande client

A Produit asynchrone

Création manuelle d'une mise en fabrication

Le produit a donné lieu à un devis

B Produit banalisé

Création manuelle d'une mise en fabrication

Le produit suit une gamme standard

REA A2[2]

Produit acquis depuis une commande fournisseur (négoce ) (O/N)

N Ce produit est géré comme un produit de négoce (Achat + Réception)

S Produit sous-traité

F C'est un produit fabriqué (valeur par défaut)

REA A2[3]

REA A2[4]

REA A2[5]

REA A2[6]

REA A2[7]

REA A2[8]

REA A2[9]

REA A2[10]

REA A2[11]

M Code réapprovisionnement autorisé pour le type d'article M (Matière)

P Code réapprovisionnement autorisé pour le type d'article P (Produit fini)

S Code réapprovisionnement autorisé pour le type d'article S (Produit semi-fini)

F Code réapprovisionnement autorisé pour le type d'article F (Fourniture)

X Code réapprovisionnement autorisé pour le type d'article X (Fantôme)

T Code réapprovisionnement autorisé pour le type d'article T (Maintenance)

O Code réapprovisionnement autorisé pour le type d'article O (Outil)

K Code réapprovisionnement autorisé pour le type d'article K (Kit)

Q Code réapprovisionnement autorisé pour le type d'article Q (Qualité)

Lors de la saisie du code réapprovisionnement d'un article, permettre de filtrer ces derniers par rapport au type d'article.

IMPORTANT : Un code réapprovisionnement est utilisable sur tous les types d'articles si et seulement si aucun paramétrage n'est saisi dans les caractères 3 à 11, ou si tous les caractères sont saisis.

Remarques :

• Ce filtre est actif pour toutes les recherches et listes déroulantes de codes réapprovisionnement (saisie/modification détaillée/simplifiée des articles, etc.)

• Lors de la saisie du code réapprovisionnement dans la saisie simplifiée des articles, le code saisi est contrôlé par rapport au type d'article en cours. Si le code réapprovisionnement n'est pas compatible avec le type d'article, ce code ne sera pas saisissable

• Un code réapprovisionnement article est par défaut autorisé pour tous les types d'articles si le paramétrage n'est pas renseigné. Si un code réapprovisionnement est associé à un ou plusieurs types d'article, ce code n'est plus autorisé pour les autres types d'articles.


REJ Rejets

Ce type de paramètre est référencé par la note TYPE_PARAM_REJET dans le programme G_integrer_bobine.

Autrement dit, vous pouvez utiliser n'importe quel type de paramètre et non pas uniquement REJ.

Pas de paramétrage particulier, seul le libellé doit être indiqué.

Ce paramètre est obligatoire pour le fonctionnement de G_integrer_bobine.


REM Code remise

Permet, selon le paramétrage de l'application, de sélectionner telle ou telle remise du fichier remise.

Valeurs numériques

1 | Taux de remise par défaut


REP Code représentant

Permet de définir les représentants associés à une société.

Valeurs numériques

REP N1 | Pourcentage de commission
REP N2 | Taux de charge sociale appliqué au représentant ou VRP. Les taux sont différents selon le type de commercial. On peut en tenir compte au niveau du devis pour inclure des charges différentes.

Valeur alpha 1

Uniquement pour les secteurs commerciaux

Décomposition du secteur commercial en code et taux (5 maxi)

REP A1[1,3]

Les 3 premiers caractères contiennent éventuellement un code de regroupement permettant des cumuls pour plusieurs codes représentants dans certains états statistiques.

Exemple

Monsieur Dupond est commissionné de la façon suivante :

5 % sur ses propres clients

3 % sur des affaires qui lui sont exceptionnellement imputées sur des clients hors secteur

Ceci se traduit généralement par 2 codes représentant :

DU1 5 % (clients sur secteur)

DU2 3 % (clients hors secteur)

Pourtant, il s'agit bien du même représentant.

On va donc attribuer à ces 2 codes représentant le même code de regroupement (Exemple DUP). Les états statistiques feront alors apparaître par exemple :

Représentant CA

DUP M. Dupond

Clients sur secteur 150 000

Clients hors secteur 220 000

Total 370 000

REP A1[4,6]

Code représentant 1

REP A1[7,10]

Taux représentant 1

REP A1[11,13]

Code représentant 2

REP A1[14,17]

Taux représentant 2

REP A1[18,20]

Code représentant 3

REP A1[21,24]

Taux représentant 3

REP A1[25,27]

Code représentant 4

REP A1[28,31]

Taux représentant 4

REP A1[32,34]

Code représentant 5

REP A1[35,38]

Taux représentant 5

Remarque La somme des taux doit être égale à 1

Valeur alpha 2

REP A2[1,30] | Numéro de téléphone (+ poste, etc.)
REP A2[31] | Edition du port sur l'offre de prix (O/N)
REP A2[32,39] | Zone libre de 8 caractères éditée sur offre de prix client (spécifique édition)
REP A2[40,60] | Numéro de télécopie du représentant (agent)

Valeur alpha 3

REP A3[1,15]

Code secteur commercial pour interface SIDE TRADE (15 caractères)

Code agent commercial pour interface EFFICIAL -(4 caractères) - SPECIFIQUE

Valeur alpha 4

REP A4[1,8] | Réservé Volume Software
REP A4[9,11] | Zone paramétrée entête de commande (par exemple : code représentant dans la saisie de commande)
REP A4[12,14] | Réseau commercial (spécifique)
REP A4[15,17] | Code secrétaire commerciale. Utilisation dans les éditions spécifiques uniquement
REP A4[18,22] | Taux de commission pris en compte dans le devis
REP A4[23,25] | Code statut du représentant (paramètre de type SRE) Exemple : Chef de secteur, Directeur des ventes, etc. CSE Chefs de secteurs externes (voir option Oac sur stat_com et maj_stat_com)
REP A4[26,28] | Code structure force de vente (paramètre de type SFV) Exemple : EST, OUEST
REP A4[29] | Le représentant est un représentant externe (agence) (O/N, N par défaut)
REP A4[30,35] | Code tiers du représentant externe (agence)
REP A4[36,38] | Code de l'imprimante rattachée au représentant (paramètre #LP XXX)
REP A4[39] | Numéro de l'imprimante rattachée au représentant
REP A4[40,42] | Centre dominant du représentant (Paramètre de type DOM)
REP A4[43,45] | Type d'envoi Fax/E-Mail des accusés de réception N Pas d'envoi FAX Envoi par fax MEL Envoi par e-mail F+M Envoi par fax/e-mail
REP A4[46,48] | Type d'envoi Fax/E-Mail des devis N Pas d'envoi FAX Envoi par fax MEL Envoi par e-mail F+M Envoi par fax/e-mail

Notes

_EMAIL | 7,60 Email du représentant, accessible dans les catalogues suivants : AR, BL, FACTURE, DEVIS, FAB, VED, ACH et REP
TRANSCO_ANAEL | 21,23 Code représentant correspondant en comptabilité ANAEL
TRANSCO_SAP | 21,23 Transcodification du Code REP chez SAP


RES Mode de réapprovisionnement des stocks

Valeur alpha 1

RES A1[1] | Code de correspondance de mode de réapprovisionnement C Commande d'achat négoce F Fabrication X Commande d'achat sous-traité (fabrication sous-traité) S Réapprovisionnement sur stock I Ignoré
RES A1[2] | Contrôle bloquant du code fournisseur (O/N, O par défaut)


RG1 Lieux de rangement 1

Valeur alpha 1

RG1 A1[1,6]

Code du transporteur utilisé dans la fonction de calcul du port par site de production - Tableau de bord du multisite

RG1 A1[7,9]

Code de l'adresse de réception associé dans la saisie des achats

RG1 A1[10]

Si O, le deuxième bon d'achat ne s'édite pas (O/N, N par défaut)

RG1 A1[11]

Si O, à la réception d'une commande d'achats, on génère une sortie plutôt qu'une réserve (O/N, N par défaut)

RG1 A1[12]

Type de lieu de rangement ou de magasin (1 par défaut)

1 Lieu de rangement ou magasin de production

2 Lieu de rangement ou magasin de mise à disposition

3 Lieu de rangement ou magasin de consignation

4 Lieu de rangement ou magasin de sous-traitance

5 Lieu de rangement ou magasin filiale

cf Gestion des mises à disposition, des consignations, des sous-traitances et des cessions à filiale.

RG1 A1[13]

Type de lieu de rangement

I Interne

E Externe

Utilisé dans la saisie des corrections de stock

RG1 A1[14,19]

Code du tiers du bordereau de transfert ou de retour associé au lieu de rangement

Code client de sous-traitance

Code du tiers du lieu de rangement ou du magasin de mise à disposition

Pour les lieux de rangement ou les magasins de mise à disposition usine, le code tiers ne doit pas être renseigné ou être égal à #SOC.

Pour les lieux de rangement ou les magasins de mise à disposition client, le code tiers doit être renseigné et être différent de #SOC.

RG1 A1[20,22]

Code de l'adresse du tiers du bordereau de transfert ou de retour associé au lieu de rangement

Code adresse secondaire lié au client de sous-traitance

Code de l'adresse de livraison du tiers du lieu de rangement ou du magasin de mise à disposition

RG1 A1[23,28]

Lieu de niveau 2 par défaut dans le cas où le bon de livraison correspond à une mise en stock dans un lieu externe.

Souvent, ce lieu de niveau 2 est égal à I (comme ignoré) puisque l'usine qui transfert le stock ne peut le préciser.

RG1 A1[29,31]

Code site d'appartenance (SIT) - Tableau de bord du multisite

RG1 A1[32]

Informations BL à éditer (O/N)

Exemple : Dans le cas d'un BL vers un sous-traitant les informations client ne doivent pas être éditées.

RG1 A1[33]

Mode de gestion du magasin

P Palette (valeur par défaut)

V Vrac

N Gestion à la palette non identifiée (sans conteneur)

RG1 A1[34]

O Les mouvements de stock de ce lieu de rangement ne sont pas pris en compte dans le profil de stock et l'état des alertes

N par défaut

RG1 A1[35,37]

Code de regroupement du lieu de rangement. Utilisé dans le module d' aide à la saisie des groupages.

Doit exister en tant que lieu de rangement

RG1 A1[38]

Envoi du BL à ce lieu de rangement (O/N, N par défaut)

(fax, mail, via le correspondant du tiers paramétré en alpha1[14,19])

RG1 A1[39]

Filtre Information à transférer au stockeur (O/N, N par défaut)

RG1 A1[40]

Magasin à affréter ? (O/N, O par défaut) Voir les programmes tr_jde_cde et tr_jde_groupage

Ce test n'est effectué que sur le magasin intermédiaire saisi sur la ligne de commande.

RG1 A1[41,43]

Code de regroupement du magasin de départ utilisé pour les tarifs transporteurs

RG1 A1[44]

Magasin générant une entrée de stock dans la saisie des bons de livraison (O/N, O par défaut)

Ce flag n'est utilisé que si le magasin saisi sur l'entête du bon de livraison est un lieu intermédiaire de sous-traitance (alpha1[12] = 4).)

RG1 A1[45]

Autorisation de livrer les composant d'un ensemble monté extérieur (O/N, N par défaut)

RG1 A1[46,48]

Code magasin de regroupement pour expédition (rupture BL)

RG1 A1[49]

Initialisation de l'emplacement d'entrée de la palette lors d'un transfert d'emplacement de palette (O/N, N par défaut)

RG1 A1[50]

Forcer le contrôle du lieu de rangement 3 pour tous les lieux rattachés à ce lieu de niveau 1

Ce paramétrage est prioritaire sur so_options[28]. Il est utilisé dans le cadre de l'outillage.

Valeur alpha 2

RG1 A2[1,12]

Correspondance JDE - Voir les programmes tr_jde_cde et tr_jde_groupage

RG1 A2[13,15]

Lieu de rangement 1 physique associé

Gestion des emplacements des produits finis

Ajout d'un complément de requête sur la recherche de lieu2

Le lieu 1 pouvant être un lieu logique (exemple MAD), faire le contrôle sur le lieu physique rattaché (exemple USI)

RG1 A2[16]

Sortie des composants

O Sortie des composants (par défaut)

N Pas de sortie des composants (par défaut)

RG1 A2[17]

Mode d'arrondi

I Arrondi inférieur

P Arrondi au plus proche

S Arrondi supérieur (par défaut)

RG1 A2[18]

Création d'un mouvement de stock de sortie de palette lors de l'édition ou la réédition provisoire d'un BL (O/N, N par défaut)

RG1 A2[19,21]

Lieu de transit du lieu intermédiaire

Suivi des stocks des produits finis en transit des bons de livraison et de transfert : voir le paragraphe dédié dans blv.

RG1 A2[22]

Lieu de transit (O/N, N par défaut)

Suivi des stocks des produits finis en transit des bons de livraison et de transfert : voir le paragraphe dédié dans blv.

RG1 A2[23]

Prise en compte de la phase de mitraillage (O/N, N par défaut)

RG1 A2[24]

Suppression lors de la livraison du mouvement de sortie prévisionnelle, lors d'une livraison sur un lieu de mise à disposition client (O/N, N par défaut)

ctuellement, si on fait une livraison sur un emplacement de mise à disposition client (type de livraison 3), il n'y a pas de suppression de la sortie réserve. Ce paramètre permet de la supprimer.

Il n'a pas de mise à jour des quantités livrées.

Remarque : ce n'est pas un bon de transfert avec un lieu intermédiaire.

RG1 A2[25,27]

Lieu 1 pour le montage

Voir les notes MOTIF_DECHET_n dans maj_stk

RG1 A2[28,33]

Lieu 2 pour le montage

Voir les notes MOTIF_DECHET_n dans maj_stk

RG1 A2[34,36]

Lieu 1 pour les déchets

Voir les notes MOTIF_DECHET_n dans maj_stk

RG1 A2[37,42]

Lieu 2 pour les déchets

Voir les notes MOTIF_DECHET_n dans maj_stk

RG1 A2[43]

Gestion du flag/deflag lors de l'édition du BL

Dans l'édition du BL, pouvoir utiliser la gestion du flag/deflag (mise à jour de TSC) dans le cas où il y a un lieu intermédiaire de saisie, et que ce lieu autorise la gestion du flag/deflag

RG1 A2[44]

Ce magasin donnera lieu lors de la génération du bon de transfert, à une création d'un ordre de transport pour la livraison vers le client (O/N, N pas défaut)

RG1 A2[45]

SPECIFIQUE Magasin à envoyer à PCTOPP (O/N, N par défaut)

RG1 A2[46]

Uniquement pour le devis onduleur (don)

Concerne l'écran de saisie de sous-traitance (écran 040 : sous-traitance de la phase).

blanc : Le magasin du produit est mis à jour par rapport à celui rattaché de la sous-traitance (par défaut)

N Le magasin du produit n'est pas mis à jour.

O Le magasin du produit est mis à jour.
Le magasin peut être imposé via le paramétrage en A2[47,49] et A2[50,55]

RG1 A2[47,49]

Uniquement pour le devis onduleur (don)

Concerne l'écran de saisie de sous-traitance (écran 040 : sous-traitance de la phase).

Lieu de rangement 1. Nécessite A2[46] = O. (paramétrage facultative car la valeur par défaut sera celle du magasin rattaché au sous-traitant).

RG1 A2[50,55]

Uniquement pour le devis onduleur (don)

Concerne l'écran de saisie de sous-traitance (écran 040 : sous-traitance de la phase).

Lieu de rangement 2. Nécessite A2[46] = O. (paramétrage facultative car la valeur par défaut sera celle du magasin rattaché au sous-traitant).

Valeur alpha 3

Il y a plusieurs catégories de notes. Faites défiler l'écran pour les voir toutes.

ATTENTION : certaines notes ont été regroupées lorsqu'elles font partie d'une même entité logique : elles apparaissent dans des tableaux séparés.

Les autres notes figurent dans le tableau général des notes, après ces tableaux.

Notes pour l'optimisation du conditionnement dans le devis onduleur

DEPASSEMENTLARGEUR

DEPASSEMENTLONGUEUR

FORMATPALETTE

FORMATPALPLAQUE

HAUTEURMAXPALETTE

HAUTEURPALCARREE

HAUTEURPALETTE

HPALCARTONNIER

NBMAXPILES

NPALETTES

RETRAITLARGEURMAX

RETRAITLONGUEURMAX

Ces notes et leur hiérarchie de recherche sont décrites dans l'aide du don,

au paragraphe Optimisation du conditionnement dans le devis onduleur.

Autres Notes

CLI_EMAIL_AUTORISE

CLI_EMAIL_INTERDIT

Ces 2 notes permettent d'établir une liste de couples client/adresse secondaire pour lesquels on autorise ou on interdit l'envoi de fax/email lors de la génération d'un BL.

CLI_EMAIL_AUTORISE : Autorisation d'envoi fax/email à un client ou à un couple client/adresse secondaire.

S'il existe au moins une ligne de note de ce type, alors l'envoi fax/email est interdit pour tous les couples client/adresse secondaire non listés.

CLI_EMAIL_INTERDIT : Interdiction d'envoi fax/email à un client ou à un couple client/adresse secondaire.

S'il existe au moins une ligne de note de ce type, alors l'envoi fax/email est autorisé pour tous les couples client/adresse secondaire non listés.

Si un couple client/adresse secondaire se trouve dans les 2 types de notes, c'est l'interdiction qui est prioritaire.

Si un couple client/adresse secondaire ne se trouve dans aucun des 2 types de notes et qu'il existe au moins une ligne de note de chaque type, alors l'envoi fax/email est autorisé par défaut.

21,26 Code client

28,30 Code adresse secondaire

Un astérisque en caractère 28 permet de faire porter la note sur l'adresse principale et toutes les adresses secondaires du client.

DELTA_DATE_LOG

21,25 Logistique : Ordre de transport : Delta pour le calcul de la date de livraison prévue et la date de départ

FIC_ITEM_ERREUR

21,60 Nom du fichier d'erreur utilisé pour transfert ITEM

FIC_ITEM_INTERFACE

21,60 Nom du fichier interface pour ITEM

FIC_ITEM_TRACE

21,60 Nom du fichier trace utilisé pour transfert ITEM

GEN_CDEF_FAM

21,23 Code famille autorisé à générer une commande d'achat en automatique lors de l'édition définitive d'un BL

Voir l'option Ocf dans l'édition VoluEdit des BL.

_SUP_REQ_LL_PREP_A

21,60 Complément de requête pour la recherche des stocks (table stk0 ou stk_lot_lieu)

TYPE_INTERFACE_ITEM

21,23 Type d'interface (en fonction des différents transporteurs)

TOP_STK_

9,17 Blocage de tous les lieux 2 du lieu 1 ou d'un lieu 2 du lieu 1

XXXXXXXXX Blocage de tous les lieux 2 du lieu 1

RG2XXXXXXBlocage du lieu 2 XXXXXX du lieu 1

18,27 Blocage à une date donnée (JJ/MM/AAAA). Facultatif

Si renseigné, seule la création ou la modification ou l'annulation des mouvements normaux postérieurs à cette date est autorisée.

Si non renseigné, aucune création ou modification ou annulation de mouvements normaux n'est autorisée.

LIEU_STOCK_HACHETTE

21, 26 Code du lieu de stockage

Exemples de codes

LIL Lille

LYO Lyon

AT1 Atelier 1


RMA Code de regroupement

Code regroupement dans le tableau de marges. Utilisé dans le devis multi-métiers

Le code de regroupement est utilisé dans le devis imprimerie afin de déterminer le libellé des regroupements lors de l'édition commerciale du tableau de marge. On édite uniquement les 15 premiers caractères du libellé long.

Valeur alpha 1

RMA A1[1] | Si le code RMA correspond à une sous-totalisation (#CF EDD alpha1[25]) O Edite le sous-total N N'édite pas le sous-total
RMA A1[2,4] | Code regroupement parent Permet de créer des sous-regroupements pour les phases éditées dans le tableau récapitulatif. Exemples RMA/2C : A1[2,4] = 2 RMA/2I : A1[2,4] = 2


ROP Rotation des piles

Ce paramètre est utilisable à partir de la V. 4.1.26.2

Il est utilisé par le programme de génération de dossier et par le TSC 51C.

Valeurs numériques

1 | Numéro de rotation 0 pas de rotation 1 rotation à 90° 2 rotation à 180° 3 rotation à 270°
2 | non utilisée


RRC Responsables des réclamations

Valeur alpha 1

RRC A1[1] | Le responsable est destinataire de la réclamation / de la NCI (O/N, N par défaut)
RRC A1[2] | Le responsable est responsable des traitements de la réclamation (O/N, N par défaut)
RRC A1[3] | Le responsable est responsable des causes de la réclamation (O/N, N par défaut)


RTA Réponse transporteur affrètement

Valeur alpha 1

RTA A1[1]

Réponse positive du transporteur (O/N, O par défaut)


RUN Code lancement de programmes

Les paramètres de ce type constituent l'ensemble des programmes qui pourront être lancés via CONTROL-Z.

Valeurs numériques

RUN N1

Ordre d'affichage inter-paramètres.

Via ce numéro, vous pouvez faire apparaître un code de lancement avant un autre dans le tableau du CONTROL-Z

Valeur alpha 1

RUN A1[1,3] | Type paramètre à lancer (exemple #SA)
RUN A1[4,6] | Code paramètre à lancer (exemple CLI)

Valeur alpha 2

RUN A2[1,60]

Permet d'afficher dans une colonne une image pour chaque programme à lancer (Control-Z)

Chemin d'accès de l'image à afficher dans la colonne


SCA Scénarios d'affaire

Utilisé dans le devis standard.

Pas de paramétrage.

ATTENTION : il existe un autre paramètre (spécifique) du même nom pour les sous-catégories de clients.

Valeur alpha 1

SCA A1[1] | Code scénario utilisable dans la saisie des affaires (O/N, O par défaut)
SCA A1[2] | Code scénario utilisable dans la saisie des actions sur événements (O/N, O par défaut)


SCA Code sous-catégories de clients

SPECIFIQUE

Valeur alpha 1

SCA A1[1,15]

Catégories autorisées (par 3 caractères)

ATTENTION : Il existe un autre paramètre du même nom pour les scénarios d'affaire.


SCE Scénarios de calcul du devis feuille

Valeur alpha 1

SCE A1[1] | Le prix de vente main-d'œuvre doit-il rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[2] | Le prix de vente matière doit-il rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[3] | Le prix de vente sous-traitance doit-il rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[4] | F11 bloque (O ou N)
SCE A1[5] | La marge sur main-d'œuvre doit-elle rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[6] | La marge sur matière doit-elle rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[7] | La marge sur sous-traitance doit-elle rester fixe (O ou N) lors du recalcul du devis ?
SCE A1[8] | Utilisation des modules d'optimisation (O ou N)
SCE A1[9] | Utilisation spécifique V Edition d'une variance par page Q Edition d'un tableau des quantités I Ignorer la variance
SCE A1[10] | Blocage des cadences des opérations du devis (O/N)
SCE A1[11] | Blocage des temps des opérations du devis (O/N)
SCE A1[12] | Blocage des coûts horaires des formules opérations (O/N, N par défaut)
SCE A1[13] | Blocage des prix de revient des formules matières (O/N, N par défaut)
SCE A1[14] | Blocage des prix de revient (fixe/variable) des formules sous-traitance (O/N, N par défaut)
SCE A1[15] | Blocage des activations/désactivations automatique de phases (O/N, N par défaut)


SCL Sous-classes

Pas de paramétrage.

Voir la fiche d'installation des nouvelles zones de la table par02


SDP Scénario de décomposition des prix

Ce paramètre est utilisable à partir de la V.4.0.182.2

Il est utilisé dans le cadre de la décomposition des prix des éléments (revient/vente standard).

Cette fonctionnalité fait partie du devis multi-métiers : elle est donc documentée dans ce chapitre : Plus d'info

Le code de ce paramètre représente le scénario de décomposition de prix saisi dans l'information complémentaire TSC SDP sur le client ou sur le sous-devis.

Notes

SCENARIO_NDR_

14,16 Code nature de regroupement père (NDR)

21,60 Codes nature de regroupement fils (NDR)

13 codes de 3 caractères par ligne

Exemples de scénarios

Car. 1 à 16 | Car. 21 à 60 | Description
SCENARIO_NDR_GEN | #CF#RV | Les natures de regroupement #CF (calage) et #RV (roulage) sont regroupées à l'affichage dans une même nature de regroupement GEN (général)
SCENARIO_NDR_PPI | PPI | La nature de regroupement PPI (papier) n'est pas regroupée mais fait l'objet d'une ligne à part entière dans l'affichage (par défaut). Remarque : cette ligne de paramétrage est optionnelle.


SEC Code section

Permet de définir les sections des opérations

Valeurs numériques

SEC N1 | Numéro de section (valeur entière obligatoirement unique) pour le tri.
SEC N2 | Numéro de section (valeur entière) utilisée dans l'édition de la liste des temps par section et l'historisation (la valeur n'est pas forcement unique).

Valeur alpha 1

SEC A1[1,6] | Pourcentage de frais administratifs
SEC A1[7,12] | Pourcentage de frais fixes de production


SEM Code découpage hebdomadaire

Le code découpage hebdomadaire est issu du code découpage mensuel .

Il permet de déterminer le code découpage journalier de chaque jour de la semaine.

Valeurs numériques

SEM N1

Temps du par défaut si le découpage jour n'est pas saisi ou n'est pas trouvé

Valeur alpha 1

SEM A1[1,3] | Code horaire lundi
SEM A1[4,6] | Code horaire mardi
SEM A1[7,9] | Code horaire mercredi
SEM A1[10,12] | Code horaire jeudi
SEM A1[13,15] | Code horaire vendredi
SEM A1[16,18] | Code horaire samedi
SEM A1[19,21] | Code horaire dimanche


SEN Service de l'action corrective

Pas de paramétrage particulier


SER Service

Ce paramètre est utilisé par dem_achat.

Pas de paramétrage.


SFM Sous-familles

Valeurs numériques

SFM N1

Selon la famille de l'article.

Exemples

Pour les papiers, on indiquera la main du papier.

Pour le calcul des déchets, on indiquera le coût matière au kg.

Gérer les seuils de réapprovisionnement en global : Délai moyen 1 de réapprovisionnement.

Utilisé dans le devis onduleur pour indiquer le prix de cession de rachat des déchets par sous-famille de la composition technique.

Ceci permet d'avoir un coût au Kg de déchets différent par composition.

Dans le cas de l'ondulé "classique", ce coût est donné par le prix de cession de l'article paramétré dans RACHATDECHETS (#CF DKP).

SFM N2

Gérer les seuils de réapprovisionnement en global : Délai moyen 2 de réapprovisionnement.

Valeur alpha 1

SFM A1[1,3] | Code groupe du code sous-famille
SFM A1[4,6] | Code formule de conversion Si cette zone est renseignée alors on proposera cette formule de conversion par défaut pour les articles d'une même sous-famille. S'il existe une formule de conversion différente au niveau de la famille, elle ne sera pas prise en compte car le niveau de sous-famille est prioritaire.
SFM A1[7,9] | Nature de difficulté de la sous-famille (pas de valeur par défaut) Cette valeur a priorité sur celle de la famille. Voir aussi VER A1[18,20]
SFM A1[10,12] | Code formule de calcul carton pour devis
SFM A1[13] | Indique si la sous-famille doit être prise en compte dans le cas des statistiques de facturation (dégressif cumulé client), O ou N
SFM A1[14] | Indique si la sous-famille doit être prise en compte dans les quantités des statistiques de facturation (dégressif cumulé client), O ou N
SFM A1[15] | Indique que la sous-famille détermine automatiquement une mise sous film (utilisation au niveau du devis carton ondulé) Voir la formule MCAR9 O Il y aura mise sous film N ou [blanc] Pas de mise sous film
SFM A1[16,23] | Code section analytique pour transfert en comptabilité (pour la compta VALC, ne prend en compte que les 3 premiers caractères)
SFM A1[24,26] | Spécifique, zone 09 du transfert OT-DATA PC-TOPP
SFM A1[27] | Sous-famille de papier basculable (O/N, O par défaut)
SFM A1[28,35] | Code rubrique analytique pour transfert en comptabilité
SFM A1[36,43] | Rubrique analytique ACHAT
SFM A1[44,46] | Code de regroupement sous-famille utilisable au niveau du flash journalier
SFM A1[47] | Paramétrage réservé Volume
SFM A1[48] | Prise en compte de cette sous-famille dans la recherche des remises (O/N, O par défaut)
SFM A1[49] | Type d'outil pour l'interface AVDATA S Cliché (par défaut) (anciennement C) T Forme (anciennement F)
SFM A1[50] | Gestion à la surface pour la sous-famille (O/N, N par défaut)

Valeur alpha 2

SFM A2[1,3] | Code unique de la sous-famille (spécifique client)
SFM A2[4,9] | Code CQI (spécifique client)
SFM A2[10,12] | Type de sous-famille (spécifique budget) (paramètre TSF)
SFM A2[13,20] | Code comptable VENTE France pour transfert en comptabilité (classe 7)
SFM A2[21,28] | Code comptable VENTE Export pour transfert en comptabilité (classe 7)
SFM A2[29,36] | Code comptable VENTE Suspension de TVA pour transfert en comptabilité (classe 7)
SFM A2[37,44] | Code comptable VENTE Intracommunautaire pour transfert en comptabilité (classe 7)
SFM A2[45,52] | Code comptable VENTE Exonéré pour transfert en comptabilité (classe 7)
SFM A2[53,60] | Code comptable ACHAT France (classe 6)

Valeur alpha 3

SFM A3[1,8]

Code comptable BONS DE RECEPTION France

Bons de réception : voir la page récapitulative dans le #CF TFB

Notes

[sur 3 caractères]

4 à 60 Ligne de note à afficher

Est recherché d'abord ici puis sur FAM.

Le mot-clé de cette note est paramétré dans cde sur la note TYPE_NOTE_ART_AFF.

ARRONDI_QTE_CDE

21 Méthode d'arrondi pour le calcul de la quantité commandée des articles nomenclaturés

S Arrondi à l'entier supérieur

P Arrondi au plus proche (par défaut)

#CC

Contrôle des champs pour la saisie simplifiée d'articles

CODE_ART_ACH

21,23 Code statistique 1 (code paramètre CS1)

25,39 Code article

Code article utilisé lors de la génération d'une commande d'achat en automatique lors de l'édition définitive d'un BL (–Ocf).

Ce code article est déterminé selon la valeur du code statistique 1.

Voir l'option Ocf dans l'édition VoluEdit des BL.

_CODE_DOUANIER

Code douanier pour la sous-famille. Idem dans FAM alpha2[13,27]

21,33 code nomenclature douanière

34,35 code catégorie produit pour DEBBL

CODE_QUALITE_INTER

21,23 Code normalisé (format Gondardennes pour generer_edi_cde)

CODE_SFM_EFFICIAL

21,23 Code désignation de l'article facturé si l'article est un produit de type négoce - SPECIFIQUE

_COEFF_MUL_PR_

21,26 Coefficient multiplicateur à appliquer sur le prix de cession dans le PR-MIDATA

Utilisé dans G_pr_midata

CODIF_ART*

Codification de l'article pour la création du code en automatique (saisie simplifiée d'articles)

COL_ART*

Colonnes à afficher dans le tableau de saisie simplifiée d'articles

COMPTE_ACHAT_SAGE

21,60 Compte d'achat. Facultatif

Utilisé par G_tr_stock_sage

COMPTE_BRC

Paramétrage du compte de vente pour les bons de réception

Bons de réception : voir la page récapitulative dans le #CF TFB

15,20 Code groupe fournisseur (champ cl_cligr de la fiche fournisseur)
Si on ne spécifie pas de code groupe fournisseur, les comptes d'achat s'appliqueront à tous les fournisseurs pour la famille et/ou la sous-famille correspondante.

21,28 Compte de vente France

29,36 Compte de vente Export

37,44 Compte de vente Suspension de taxe

45,52 Compte de vente Intra-communautaire

53,60 Compte de vente Exonéré

COMPTE_CONSO_SAGE

21,60 Compte de consommation. Facultatif

Utilisé par G_tr_stock_sage

COMPTE_STOCK_SAGE

21,60 Compte de stockage. Facultatif

Utilisé par G_tr_stock_sage

_COMPTE_VENTE_AVO

Paramétrage du compte de vente pour les avoirs.

Pour l'ordre de recherche du compte de vente pour les avoirs, voir cette page

_COMPTE_VENTE_GROUPE

Dans la fonction de recherche du compte de vente, ajout de la recherche si le client est Groupe.

Ce paramétrage est effectif sur les paramètres CS1, CS2, CS3, CS4, SFM et FAM.

21,28 Compte de vente France

29,36 Compte de vente Export

37,44 Compte de Vente Suspension de Taxe

45,52 Compte de Vente Intracommunautaire

53,60 Compte de vente Exonéré

CPT_ACHAT_GPE_

Saisie de comptes d'achat au niveau de la sous-famille

Au niveau des sous-familles, il n'était possible de saisir qu'un compte d'achat France.

Cette évolution permet de saisir à ce niveau tout type de compte d'achat (France, Export, Suspension, Intracommunautaire, Exonération).

15,20 Code groupe fournisseur (champ cl_cligr de la fiche fournisseur)

Si on ne spécifie pas de code groupe fournisseur, les comptes d'achat s'appliqueront à tous les fournisseurs pour la famille et/ou la sous-famille correspondante.

21,28 Compte d'achat France

Ce paramètre est ignoré si un compte d'achat est renseigné en A2[53,60] de la sous-famille.

29,36 Compte d'achat Export

37,44 Compte d'achat Suspension de taxe

45,52 Compte d'achat Intracommunautaire

53,60 Compte d'achat Exonéré

CTRL_CODE_CS_n

où n représente le code statistique (1 à 4)

21 Code statistique CSn obligatoire (O/N, N par défaut)

Plus d'explications dans la même note au niveau du TYC.

DELAI_FIXE_SIT_xxx

21 Délai fixe O/N

Le code xxx représente le code site de production.

Si rien n'est saisi, on prend le paramétrage par défaut sur la sous-famille (A1[47])

DN_INFO*

Construire une nomenclature de référence interne via un nouvel écran du devis onduleur

Colonnes à afficher dans le tableau des informations d'article

Chacun des 4 champs doit être suivi d'un astérisque

1) Libellé de la rubrique

2) Zones possibles

mp_* : Toutes les zones de mat

TSC_[CodeTSC]_[ZoneTSC]

le_libpar1 : Référence client

le_libelle : Libellé spécifique 1

le_libelle2 : Libellé spécifique 2

3) Format (using)

4) Code langue à employer

Ce paramétrage est recherché dans l'ordre de priorité suivant :

Famille/Sous-famille

Famille

Paramètre de lancement

_JDE_PARAM_ACHATS_

21,24 Centre de coût d'achat - JDE

25,30 Objet

31,33 Sous compte

_JDE_PARAM_VENTES_

Anciennement, ces notes s'appelaient _JDE_PARAM_ Leur nom a été complété

21,23 Centre de coût de vente

24,29 Objet

LIEN_AVEC_CODE_CS

Lien avec les codes statistiques

21 Lien avec le code statistique CS1 (O/N, N par défaut)

22 Lien avec le code statistique CS2 (O/N, N par défaut)

23 Lien avec le code statistique CS3 (O/N, N par défaut)

24 Lien avec le code statistique CS4 (O/N, N par défaut)

La même note existe au niveau de la famille.

LIEUX_1_2_3

Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de

saisie manuelle (stk0)

intégration des temps et matières (int_rtm)

visualisation des mouvements de stocks (v_stk0)

La recherche se fait :

1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F ….)

2 sur la sous-famille de l'article

3 sur la famille de l'article

4 sur le type de mouvement de stock

5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3)

21,23 Lieu de rangement 1 (magasin)

25,27 Lieu de rangement 2 (Emplacement)

29,31 Lieu de rangement 3 (Emplacement)

LIST_TYPE_NOTE_A_REC

21,23 Type de note de mat3 que l'on veut recopier

La même note existe aussi sur v_cde_5 et la famille.

PALETTE_CONSIGNEE

21 Palette consignée (O/N, N par défaut)

Voir le suivi des palettes consignées

PRIX_A_LA_TONNE

Contrôle du prix à la tonne

Voir la note TSC_PRIX_A_LA_TONNE dans la saisie des commandes clients

Voir BLO A1[3,5] = 027

21,30 Borne inférieure de contrôle du prix à la tonne

Borne sous la forme 9999999999 ou 999999.999

31,40 Borne supérieure de contrôle du prix à la tonne

Borne sous la forme 9999999999 ou 999999.999

41,50 Date de dérogation inférieure de contrôle du prix à la tonne

Date sous la forme JJ/MM/AAAA

51,60 Date de dérogation supérieure de contrôle du prix à la tonne

Date sous la forme JJ/MM/AAAA

SAISIE_PRX_FORME_CDE

Saisie du prix de la forme sur la ligne de commande (O/N, N par défaut)

Voir l'option Ofo en saisie de commande client.

Cette note est prioritaire sur celle de la famille.

V

Vérifications avant suppression d'un article2

Lors d'une annulation logique ou physique d'un article, des vérifications sont effectuées à partir de ce paramétrage.

Voir le détail du paramétrage de cette note sur mat.

Ce paramètre est recherché en priorité dans cet ordre :

1) Paramètre de lancement du programme mat

2) Sous-famille

3) Famille

TRF ou tout autre code référencé par la note CONFIG_TRANSFERT

Prise en compte du site pour l'attribution des comptes de ventes

Lors du transfert des factures clients en comptabilité, si VoluPack est configuré en multisite sur une société, les comptes de vente peuvent être différents par site.

Tableau de bord du multisite

5 Qualificatif de la ligne :

V pour vente (seul cas autorisé pour l'instant)

7 Valeur ou Ajout

V pour valeur

A pour ajout (Addition de la ligne de note avec le compte de vente correspondant en alpha 2)

13,20 Code comptable VENTE France pour transfert en comptabilité (classe 7)

21,28 Code comptable VENTE Export pour transfert en comptabilité (classe 7)

29,36 Code comptable VENTE Suspension de TVA pour transfert en comptabilité (classe 7)

37,44 Code comptable VENTE Intracommunautaire pour transfert en comptabilité (classe7)

45,52 Code comptable VENTE Exonéré pour transfert en comptabilité (classe 7)

Exemples

Dans les lignes suivantes, on indique les numéros de compte par Valeur pour 3 sites :

TF1-V-V 7011111 7011112 7011113 7011114 7011115

TF2-V-V 7081111 7081112 7081113 7081114 7081115

TF3-V-V 7091111 7091112 7091113 7091114 7091115

Dans les lignes suivantes, on indique les numéros de compte par Ajout :

TF1-V-A 11 12 13 14 15

TF2-V-A 21 22 23 24 25

TF3-V-A 31 32 33 34 35

Explications pour la note TF1 (correspondant au site 1)

On ajoute 11 au numéro de compte paramétré en A2[13,20].

On ajoute 12 au numéro de compte paramétré en A2[21,28].

On ajoute 13 au numéro de compte paramétré en A2[29,36].

On ajoute 14 au numéro de compte paramétré en A2[37,44].

On ajoute 15 au numéro de compte paramétré en A2[15.52].

Exemples

Si A2[13,20] = 7015000, alors le compte de vente France pour le site 1 = 7015011.

Si A2[45,52] = 7017000, alors le compte de vente Exonéré pour le site 3 = 7017035.

VALEUR_CODIF_ART

Voir la note CODIF_ART* dans la codification automatique des articles.


SFV Structure force de vente

Valeur alpha 1

SFV A1[1,3] | Code type de structure de force de vente (paramètre de type TSF) Exemple EST, OUEST, etc.
SFV A1[4,6] | Code site d'appartenance de la SFV Tableau de bord du multisite


SIG Code signature

Libellé long

Nom et fonction C'est le libellé long qui sera affiché à l'écran

Libellé court

NOM

Valeur alpha 1

SIG A1[1,30]

Fonction

Valeur alpha 2

SIG A2[1,30] | Numéro de téléphone (+ poste, etc.)
SIG A2[31,60] | Numéro de fax


SIT Site de production

Tableau de bord du multisite

Valeurs numériques

SIT N1

Numéro du compteur de commande client (STR)

Utilisé aussi pour une édition spécifique

Valeur alpha 1

SIT A1[1,6] | Code adresse principale du tiers rattaché au site
SIT A1[7,9] | Code adresse secondaire du tiers rattaché au site Peut être utilisé pour stocker des informations comme la raison sociale ou l'adresse d'un site
SIT A1[10,12] | Lieu de rangement niveau 1 par défaut du site de production
SIT A1[13,18] | Lieu de rangement niveau 2 par défaut du site de production
SIT A1[19,24] | Lieu de rangement niveau 3 par défaut du site de production
SIT A1[25,27] | Code adresse secondaire du tiers rattaché au site, utilisé comme adresse postale
SIT A1[28,30] | Code adresse secondaire du tiers rattaché au site, utilisé comme adresse de réception
SIT A1[31,33] | Lieu de rangement niveau 1 par défaut du site de production (lié à l'adresse de réception)
SIT A1[34,39] | Lieu de rangement niveau 2 par défaut du site de production (lié à l'adresse de réception)
SIT A1[40,45] | Lieu de rangement niveau 3 par défaut du site de production (lié à l'adresse de réception)
SIT A1[46,50] | Code société JDE

Valeur alpha 2

SIT A2[1,25]

Nom du correspondant technique du site de production

Valeur alpha 3

SIT A3[1,8] | Rubrique analytique pour comptabilité Pour compta REEL : correspond aussi à l'établissement
SIT A3[9,14] | Code fournisseur correspond à ce site (utilisé notamment dans la formule SFLA2)
SIT A3[15,20] | Code journal des ventes pour le transfert en comptabilité SAGE 500
SIT A3[21,23] | Code site pour le transfert en comptabilité SAGE 500 Attention : dans #CF TFF et #CF TRF, dans les notes commençant par SAGE_500_PARAM_GEN, si les caractères 23 à 24 = 02 (code analytique spécifique sur 6 caractères), on ne prend que le premier caractère du code site. Tableau de bord du multisite
SIT A3[24] | Code société pour le transfert en comptabilité SAGE 500
SIT A3[25,30] | Code journal d'achats pour le transfert en comptabilité SAGE 500
SIT A3[31,38] | Numéro d'ID Compte (utilisé pour JDE)
SIT A3[39,41] | Code du TSC de type d'offre sur ce site (TOF par défaut)
SIT A3[42,44] | Code adresse secondaire du tiers rattaché au site, utilisé comme adresse de facturation Voir l'option Oif dans la saisie des commandes fournisseurs.

Valeur alpha 4

SIT A4[1,3]

Code du site d'agrément rattaché au site de production

SIT A4[4]

Site de sous-traitance (O/N, N par défaut)

SIT A4[5,10]

Code fournisseur rattaché au site

SIT A4[11,16]

Code client rattaché au site

SIT A4[17,19]

Site de rattachement pour ce site de production - SPECIFIQUE

SIT A4[20,23]

Largeur du camion (en mm)

Exemple : 2400

SIT A4[24]

Gestion de la charge (O/N, O par défaut)

SIT A4[25,30]

Code machine de type massicot associé au site de production

SIT A4[31,36]

Code machine de type Aide associé au site de production

SIT A4[37,39]

TYC des commandes créées lors du transfert par la visu de commande

SIT A4[40,42]

Code échéance à utiliser sur la commande générée lors du transfert intersite

Voir la note NEW_TYC_TRANSCDESITE dans le TYC

SIT A4[43,45]

Code mode de règlement à utiliser sur la commande générée lors du transfert intersite

Voir la note NEW_TYC_TRANSCDESITE dans le TYC

SIT A4[46,48]

Code site de rattachement pour le calcul des prix de cession. Par défaut à blanc

Ce paramètre peut être utile dans le cas d'une société composée de plusieurs sites dont certains ont les mêmes tarifs. Cela évite de saisir plusieurs fois le tarif.

Le calcul des prix de cession des articles par site de production fonctionne uniquement :

- dans le devis onduleur et la (ré-)génération de dossier pour les onduleurs,

- si la gestion par site de production est activée (#CF SIT A1[1] = O).

Il fonctionne suivant la règle suivante :

- Recherche du prix de cession de l'article selon le site.

- Si aucun tarif n'est trouvé, alors recherche du prix dit multi-sites (en clair, un prix sans site).

Notes

AFAQ

21,40 N° de l'AFAQ (Association Française de l'Assurance Qualité)

Ce numéro est disponible dans les éditions VoluEdit (Accusé de réception, bon de livraison, édition des factures et édition des commandes fournisseurs)

ARTICLE_CDEF

21,35 Compo carton par défaut du site

Exemple : CDEF1

ARTICLE_PC_DEF

21,35 Produit cartonnier par défaut du site

Exemple : PC_DEF1

ARTICLE_QDEF

21,35 Qualité carton par défaut du site

Exemple : QDEF1

CODE_CNUF

21,30 Codification du CNUF

Ce code prendra le pas sur celui indiqué dans la fiche société (so_id_entreprise)

Plus d'info sur le code CNUF

COMPTEUR_

Gestion des compteurs multisite

Dans la gestion des compteurs, on gère des compteurs associés au paramètre de lancement.

A cette gestion, on greffe la gestion des compteurs liés au sites par le biais de cette note.

Il y aura une recherche des compteurs liés aux sites, en cas de gestion du multisite, pour éventuellement remplacer le compteur "standard" du paramètre de lancement.

Sur le site, tous les compteurs liés à ce site seront définis, ceux des commandes pourront être valable pour tous types de commande, valables pour un type précis de commande, …

10 Type de compteur

C commande

B Bon de livraison

…

11 Séparateur _

12,13 Numéro de compteur

14 Séparateur _

15,20 Type et code paramètre de lancement

Exemples

Pour les commandes, on prendra le compteur par défaut des commandes :

COMPTEUR_C

Pour les commandes lancées par le paramètre #SA CTR, on utilisera le compteur 01 des commandes :

COMPTEUR_C_01_#SACTR

Pour les bons de livraison, on prendra le compteur 02 des bons de livraisons :

COMPTEUR_B_02

Pour les autres modules, on prendra le compteur tel qu'il est défini actuellement sur les différents paramètres de lancement.

Voir aussi #CF SIT A1[1] et USE A3[10,12].

DATE_LIVRAISON_

Note spécifique C pour l'édition des AR

16,18 Type de la commande (CD2, CD1, etc.)

21 Edition de la date de livraison (O/N, O par défaut)

DIRECT_PLANNING_CFG

Note sur le site de production de l'entête de commande (ec_c1) associé à un OF et/ou du sous-devis dans le cas de la réservation de capacité (l2_site)

21,23 Code du paramètre de configuration de Direct Planning pour ce site (par exemple : DP3)

Par défaut : paramètre de configuration renseigné sur le paramètre de lancement du programme créant la demande.

Plus d'explications dans le paramètre #CF DP2.

_JDE_PARAM_ACHATS_

21,32 Centre de Coût magasin

33,40 Compte Comptable du site

MACHINE_

9,11 Type de machine (correspond au type de machine renseigné dans le code calcul MC, car.1 = S)

21,26 Code machine associé au couple site de production/type de machine


SLI Statut du lot industriel

Pas de paramétrage - on n'utilise que le code et le libellé.

Ce paramètre est utilisé par le programme de gestion des lots industriels.


SRC Secteur de la réclamation

Valeur alpha1

SRC A1[1,3]

Code du département de la réclamation (doit être associé à un paramètre de type DRC)

Permet d'initialiser le champ rod_departement de la table reclam_ori_defaut.

Valeur alpha 2

SRC A2[1]

Type de code source

C Client

F Fournisseur

I Interne

S Standard (par défaut)


SRE Statut représentant

Permet de préciser le statut du représentant (voir REP : alpha4[23,25])

Exemple : Chef de secteur, Directeur des ventes, etc.


SSE Code sous-secteur

Permet de définir les représentants associés à une société

Valeur alpha 1

SSE A1[1,3]

Numéro de représentant associé au sous-secteur


SSF Stade du produit semi-fini

Pas de paramétrage - on n'utilise que le code et le libellé.

Ce paramètre est utilisé par le programme de gestion des lots industriels.


SSL Sous-statut du lot industriel

Ce paramètre est utilisé par le programme de gestion des lots industriels.

Valeur alpha1

SSL A1[1,3]

Code statut du lot industriel rattaché (correspond à un paramètre de type SLI)


STC Structure du carton

Ce paramétrage est utilisé dans la gestion des compositions carton afin d'attribuer automatiquement la sous-famille de la composition en fonction de la structure du carton et du grammage de la composition.

Notes

S

2 à 9 Borne inférieure du grammage de la composition

10 à 17 Borne supérieure du grammage de la composition

18 à 20 Sous-famille de la composition commerciale

21 à 23 Sous-famille de la composition technique


STK Configuration des stocks par codes lancement

Valeur alpha 1

STK A1[1] | (O par défaut) Création d'un mouvement de stock sur la ligne de commande
STK A1[2] | (O par défaut) Création d'un mouvement de stock sur la ligne de bon de livraison possible
STK A1[3] | (O par défaut) Création d'un dossier de production pour la ligne de commande


STY Modèles de styles

Ce paramètre est opérationnel à partir de la V.4.1.0.2.

Il nécessite la version 2.30 de GENERO.

Il remplace les notes STYLE_XXX et FENETRE_MAXIMISEE des paramètres #CF 4JS et USE.

Les valeurs numériques et alpha ne sont pas utilisées.

Seules les notes sont utilisées.

Les notes sont créées dynamiquement par le programme d'aide à la saisie des notes de paramétrage, accessible par F8 dans la saisie d'un paramètre de type STY.

Bien que ces notes soient visibles dans l'écran standard de saisie des notes, il est recommandé d'utiliser de préférence le programme d'aide à la saisie.

Le programme d'aide à la saisie des notes de paramétrage a une présentation particulière lorsqu'il s'agit de styles (Figure 2).

Il possède sa propre fonction de test qui affiche un écran présentant un échantillon visuel de tout ce qui est susceptible de s'afficher dans les écrans VoluPack / VoluPrim.

  1. Accédez à la saisie des paramètres (Figure 1)

  2. Type STY, code DEF

  3. Faites F8 pour accéder à l'aide à la saisie des notes de paramétrage (Figure 2).

  4. Modifiez les paramètres de votre choix.

  5. Cliquez sur le bouton Tester pour afficher l'écran de test (Figure 3).


SUC Support de correspondance

Pas de paramétrage particulier


TAC Types d'action

Ce paramètre est opérationnel à partir de la V. 4.0.200.2

Il est destiné aux réclamations clients et aux non-conformités internes.

Ajout d’une nouvelle zone Type d’action en réclamation client (complément sur la gestions des actions)

Gestion des TSC par défaut en réclamation client et non-conformité interne.

Dans la saisie des notes sur les actions, il faut, sur la ligne de note, utiliser la fonction Détail, touche F8, pour saisir plusieurs lignes de notes.

Pas de paramétrage, seul le libellé est utilisé.

Exemples

TAC COR Action corrective

TAC CUR Action curatives

TAC MAI Action de maintenance

TAC PRE Action préventive

Créer le TIC REC pour les réclamations, ce code servira à restreindre les TSC visibles dans les réclamations.

Exemple de TSC portant sur les réclamations : TSC RE1

Dans les notes du TSC :

1 2 3 4 5 6

123456789012345678901234567890123456789012345678901234567890

TICREC

ZFRéponse requise 01O/N2 Réponse requise

ZHRéc. justifiée? 01O/N2 Réc. justifiée?

ZHIntersite ? 01O/N2 Intersite ?

Définir des valeurs pour les réclamations et non-conformités internes (par défaut 0000000C, 0000000I)

Saisie des réclamations : Dans le paramètre de lancement, restreindre les TSC aux seules réclamations : mettre -D3REC en alpha 1.

Visualisation des réclamations : Utilisation du TSC RCE_NU

Exemple

1 2 3 4 5 6

123456789012345678901234567890123456789012345678901234567890

V Réponse requise*TSC_RCE_NU_RE1_F*16**

V Type action*rac_type_action*3**

V libl type action*libl*rac*type*action*25**

Dans cet exemple, on utilise le TSC RCE_NU pour récupérer la zone F du TSC RE1 portant sur la réclamation (clé TSC : RCE_NU).

Edition VoluEdit des réclamations : Utilisation du TSC RCE

Exemple

1 2 3 4 5 6

123456789012345678901234567890123456789012345678901234567890

VE_VAR Réponse requise*TSC_RCE_RE1_C1**

Dans cet exemple, on utilise le TSC RCE pour récupérer la zone ic_char3_1 du TSC RE1 portant sur la réclamation (clé TSC : RCE)


TAP Type d'approvisionnement papier

Ce paramètre est utilisé dans le devis art graphique

Les codes sont figés.

S | Stock interne
C | Stock fournisseur
F | Fabrication
B | Fabristock
E | Externe (papier client)


TAR Code tarif

Ce code permet de définir des environnements de valorisation.

Exemples de codes

TAR NOR | Tarif de vente normal, utilisé dans la saisie de commandes
TAR #CE | Tarif de cession (utilisé dans la valorisation des matières premières dans le devis) Coût matière
TAR #CO | Coût opération
TAR #CT | Coût transformation

Valeur alpha 1

TAR A1[1,8] | Date de début de validité du code tarif sous la forme JJMMAAAA Si TODAY la date de début de validité est celle du jour
TAR A1[9,11] | Nombre de jours de validité de ce tarif
TAR A1[12] | Prise en compte de ce tarif au niveau des mises à jour depuis la fiche fournisseur (F30)
TAR A1[13] | B Mode Barème N Mode Normal (par défaut)
TAR A1[14] | Ce tarif n'est pas modifiable en saisie de commande (O/N, N par défaut). O Le tarif n'est pas modifiable. N Le tarif est modifiable.


TAV Types d'avoirs

Valeur alpha 1

TAV A1[1] | Prise en compte dans les statistiques (O/N)
TAV A1[2] | Mise à jour d'un mouvement de stock d'entrée normale (O/N)


TBR Types de bons de retour

Valeur alpha 1

TBR A1[1] | Gestion des demandes de reprise (O/N)
TBR A1[2] | Génération d'un avoir en automatique (O/N)
TBR A1[3] | Saisie du BL de référence (B/W/N)
TBR A1[4] | Contrôle de l'adresse de récupération par rapport à l'adresse de livraison du BL de référence (B/W/N)

Notes

#CC

Contrôles à effectuer

5, 22 Nom du champ à tester. 3 possibilités :

br1_site_prod

br1_transporteur

br1_date_creation

23Type de contrôle à effectuer

N Pas de contrôle

W Confirmation de la non saisie de la zone (non disponible pour br1_date_creation)

B Contrôle bloquant de la saisie (non disponible pour br1_date_creation)

I Interdit : Le champ n'est pas accessible en saisie (uniquement pour br1_date_creation)

24 Traçage de la zone (non géré actuellement)

25 Zéro significatif (pour les zones numérique uniquement)

Permet de spécifier si la valeur 0 est acceptée comme étant une valeur possible pour la zone.


TCD Types de commandes

Attention Aucune modification de ce paramétrage ne doit être effectuée sans consultation de Volume Software sous peine de dysfonctionnement grave.

Valeurs numériques

TCD N1 | Montant minimum de commande normale
TCD N2 | Montant minimum de commande de réassort

Valeur alpha 1

TCD A1[1] | O Autorisation commande de réassort N Interdiction commande de réassort
TCD A1[2] | O Autorisation création article en saisie N Interdiction création article en saisie-
TCD A1[3] | 1 Type de commande scolaire (PAP) 2 Type de commande papeterie (PAP) 3 Type de commande divers (PAP) 3 Type de commande publicité (PUB)
TCD A1[4] | (pour les commandes non réassort) A Edition automatique d'un bon de livraison sans sélection O Edition d'un bon de livraison avec sélection N Pas d'édition de bon de livraison
TCD A1[5] | O Mise à jour des sorties de stocks en confirmation de BL F Mise a jour des stocks en fiche suiveuse
TCD A1[6] | O Contrôle du stock en saisie de commande N Pas de contrôle du stock en saisie de commande
TCD A1[7] | (pour les commandes réassort) A Edition automatique d'un bon de livraison sans sélection O Edition d'un bon de livraison avec sélection N Pas d'édition de bon de livraison
TCD A1[8] | O Affichage du stock disponible N Pas d'affichage du stock disponible
TCD A1[9] | Edition d'un BL après expédition (O/N, O par défaut).SPECIFIQUE

Valeur alpha 2

TCD A2[1,15]

Types de commandes compatibles (par 3 caractères, 5 types possibles)

Valeur alpha 3

TCD A3[1,6] | Date limite de prise en compte des remises Temporaire (à saisir en jjmmaa)
TCD A3[7,9] | Code tarif
TCD A3[10,13] | Montant du port pour les commandes de réassort Exemple : 0025 (25 francs)
TCD A3[14,18] | Taux de l'escompte Exemple : 03.00 (5 %)
TCD A3[19,21] | Type de mouvement de stock de sortie réserve (TMV) Par défaut SOR
TCD A3[22,24] | Magasin de sortie (s0_rgt1)
TCD A3[25,30] | Emplacement de sortie (s0_rgt2)

Valeur alpha 4

TCD A4[1,45]

Type de ligne de produit pour la recherche des remises AD VALOREM (par 3 caractères, 15 Types possibles)

Notes

_COMPTE_CLIENT_TNT

21,26 Numéro de compte -


TCF Type de cadencement de fabrication

Voir la fiche d'installation

Valeurs numériques

TCF N1

Ordre de tri

Exemples

TCF GLO = 1 (global)

TCF IMP = 2 (impression)

TCF FAC = 3 (façonnage)

TCF COL = 4 (collage)

Valeur alpha 1

TCF A1[1,3]

Type de cadencement rattaché

IMP Impression

FAC Façonnage

GLO Globale (Impression + Façonnage, par défaut)

Valeur alpha 2

TCF A2[1,3] | Type de mouvement de stock pour l'entrée en stock de l'affiche (Aucun mouvement de stock ne sera créé si aucun type n'est paramétré).
TCF A2[4,6] | Type de mouvement de stock pour la sortie en stock de l'affiche (Aucun mouvement de stock ne sera créé si aucun type n'est paramétré).
TCF A2[7,9] | Type de mouvement de stock pour l'entrée en stock du produit fini.(Aucun mouvement de stock ne sera créé si aucun type n'est paramétré).
TCF A2[10,12] | Code de la première phase matière à prendre en compte
TCF A2[13,15] | Code de la dernière phase matière à prendre en compte
TCF A2[16,18] | Code de la première phase opération à prendre en compte
TCF A2[19,21] | Code de la dernière phase opération à prendre en compte
TCF A2[22,24] | Code de la première phase sous-traitance à prendre en compte
TCF A2[25,27] | Code de la dernière phase sous-traitance à prendre en compte
TCF A2[28] | Type pris en compte dans l'édition Preactor pour la partie Impression (O/N, O par défaut)
TCF A2[29] | Type pris en compte dans l'édition Preactor pour la partie Façonnage (O/N, O par défaut)
TCF A2[30,32] | Code LCO du nombre prévisionnel de cadencements
TCF A2[33] | Zone LCO du nombre prévisionnel de cadencements 1 Zone numérique 1 2 Zone numérique 2
TCF A2[34,36] | Type de mouvement de stock pour la sortie en stock des composants de l'ensemble Aucun mouvement de stock ne sera créé si aucun type n'est paramétré.
TCF A2[37,39] | Numéro de phase d'impression pour le calcul de la quantité d'OF. Par défaut : 60
TCF A2[40,42] | Dernier numéro de phase pour l'affiche pour la création des liens des ensembles collés Par défaut : 100


TCL Type de correspondance entre logiciels

Ce paramètre est utilisé par le programme G_correspondance.

Valeur alpha 1

TCL A1[1,2] | Type de données à faire correspondre 02 Code qualité carton 03 Code FEFCO / ECMA 04 Code machine
TCL A1[3,4] | Code logiciel externe 01 Artios CAD 02 Direct Planning
TCL A1[5] | Saisie des correspondances par site de production (O/N, N par défaut) Tableau de bord du multisite

Notes

_SUP_REQ_ACTUALISE | 21,60 Complément de sélection pour l'actualisation automatique des codes VoluPack Par défaut, tous les codes VoluPack non annulés sont récupérés afin que leurs codes correspondants pour le logiciel externe soient saisis. Table suivant le type de données : 2 mat 3 ecma
SUP_REQ_LISTE_SITE | Complément sur la table par02 pour l'affichage de la liste des sites possibles Tableau de bord du multisite Remarque : cette liste n'apparaît que si la saisie par site est activée et qu'aucun code site n'est paramétré par défaut sur le paramètre de lancement de la saisie des correspondances (voir ci-dessus)
TITRE_CODE_LOGICIEL | Titre de la colonne de saisie du code correspondant pour le logiciel externe Valeur par défaut suivant le code logiciel : 1 Code correspondant Artios
TITRE_CODE_VOLUME | Titre de la colonne pour le code VoluPack Valeur par défaut suivant le type de données : 2 Code qualité carton 3 Code FEFCO/ECMA
TITRE_FENETRE | Titre de la fenêtre de saisie Par défaut : Saisie des correspondances
TITRE_LIB_VOLUME | Titre de la colonne pour le libellé correspondant au code VoluPack Valeur par défaut suivant le type de données : 2 Désignation 3 Désignation


TCO Types de correspondants

Valeur alpha1

TCO A1[1,30]

Code fonction du contact pour interface SIDE TRADE


TCS Types de coûts supplémentaires

Pas de paramétrage.

On pourra par exemple utiliser les codes suivants :

SYS | Coût systématique
VAR | Coût variable
TEC | Elément technique


TCV Types de couvertures

Valeur alpha

TCV A1[1,15]

Code couverture à utiliser

Le code saisi doit figurer dans le fichier des matières


TDA Type de la demande d'achat

Ce paramètre est utilisé par dem_achat.

Valeur alpha 1

TDA A1[1,3]

Type de commande fournisseur associé.

Un type particulier de demande génère donc un type particulier de commande fournisseur.

Utilisé pour la génération de commande d'achat (gen_cdef) quand le module est lancé depuis la demande d'achat.

Ne pas confondre avec la note TABLE_ORIGINE_DEM_ACHAT (car.41 à 43) de gen_cdef.

TDA A1[4]

Cadencement de livraison (O/N, N par défaut)

Si ce paramètre est à O :

- Activation de la génération automatique de lignes de cadencement de livraison pour ce type de demande d'achat dans le programme de génération de commandes d'achat (gen_cdef)

- Activation de l'accès automatique à la saisie des cadencements de livraison lors de la saisie des lignes de commande d'achat dans le programme de saisie des commandes d'achat (cdef)

Cela revient à simuler la présence de l'option Oca dans ces 2 programmes pour les commandes liées à une demande d'achat de type correspondant.

Notes

SMAT1

7,60 Complément de sélection pour le produit dans le programme de saisie de demande d'achat (dem_achat)


TDD Types de dorures

Valeur alpha 1

TDD A1[1,3]

Code regroupement type de dorure

COU Couleur

BRO Bronze

AFR A froid

Valeur alpha 2

TDD A2[1,15]

Code matière du rouleau de dorure


TDE Types de devis

Certains codes sont figés :

STD | Standard Non supprimables Edition particulière, même les lignes à zéro sont éditées
NOR | Normal C'est votre devis
PRO | Production Non supprimables Devis utilisé uniquement pour la production Pas de contrôle lors de l'ouverture de dossier Pas de génération de prévu lors de la génération du dossier de production.

Les devis de type PRO et STD ne sont en aucun cas supprimés.

Valeur alpha 1

TDE A1[1,5] | Mot de passe associé à ce type de devis Exemple : Les devis STD qui constituent les références de votre entreprise peuvent être protégés par leur concepteur.
TDE A1[6] | Autorisation de suppression du devis par la procédure d'épuration automatique Autorisation de suppression du devis par l'action standard ACT013 de la sélection multiple (Control-K) O Suppression autorisée (valeur par défaut) N Suppression interdite
TDE A1[7] | Mode consultation si le mot de passe n'est pas donné par l'utilisateur


TDF Types de finition

Permet d'affecter des valeurs par défaut aux éléments d'imposition selon le type de finition.

Le type de ce paramètre est lu dans la note TYP_ZONE_TDF du paramètre de type TPR.

TDF A1[1] | Type de finition B brut de roto R rogné
TDF A1[2] | Type de reliure N Normale (par défaut) I Intégra D Demi-reliure


TDO Types de dos

Valeur alpha 1

TDO A1[1,15]

Code dos à utiliser. Le code saisi doit figurer dans le fichier des matières.

Valeur alpha 2

TDO A2[1,3]

Code catégorie de dos, ce code sert de dépendance dans l'opération de fabrication couverture.


TEN Types entités de fabrication

fi_ Toutes les zones de la table fle_imp

LCO_EN_ LCO sur entité

Paramétrage de la forme : LCO_EN_[code]_[zone]

La LCO peut être créée si celle-ci n'existe pas sur l'entité cible avec les valeurs de la LCO source.)

GAM_ Gamme/Phase sur entité

Paramétrage de la forme : GAM_[code]_[zone] où

[code] : Code phase

[zone] : Toutes les zones des tables fle_gam (ga_*), fle_mat (fm_*), fle_ope (fo_*)_fle_str (fs_*)

Remarques

" Le même code phase doit exister sur le sous-devis/entité cible (le numéro de phase peut être différent)

" Le report d'une modification de phase peut entraîner une mise à jour multiple (si présence de plusieurs formules) sur le sous-devis/entité cible.

Cette mise à jour multiple est indiquée via la présence d'une icône dans la colonne Mul. de l'écran de validation de mise à jour.

Car.39 = #CF DEG A4[37]

TEN Types entités de fabrication

Il s'agit des grands types de fabrication possibles.

La majeure partie de ce paramétrage est utilisée par le devis standard.

Les paramètres non utilisés par le devis standard sont dans la plage A1[3,30] (7 paramètres).

Précisions de fonctionnement (pour le devis standard) :

Dans la recherche de codes machines (par choix machine C ou par automatisme), le lien entre machine et outil n'est activé que si une machine au minimum est liée à l'outil utilisé. En effet, si pour l'outil sélectionné n'a aucune machine liée, toutes les machines seront prises en compte. De même, aucune vérification de lien machine/outil est effectué lorsque l'outil n'est pas saisi ou qu'il n'est pas à prendre en compte (entité FEUDEP par exemple).

Exemples de types d'entité de fabrication (ces exemples sont figés pour le programme devis.4ge) :

CAH | Cahier
PRE | Pré-presse
COU | Couvertures Les couvertures ne sont pas comptées comme un cahier sauf dans les phases : de piqûre (PIQ), d'encartage (ENC).
FEU | Feuilles. Les feuilles ne sont pas piquées.
DEP | Dépliants. Les dépliants ne sont pas piqués.
FAC | Façonnage

Valeurs numériques

Utilisées dans le cadre du remplacement du devis transformateur carton (devis_tc) par le devis multi-métiers (devis_standard).

1 | Prise de pince par défaut dans le sens laize
2 | Prise de pince par défaut dans le sens coupe

Valeur alpha 1

TEN A1[1]

Unité de mesure pour le format fini

C Centimètres

M Millimètres (valeur par défaut)

Attention : vérifiez aussi #CF DEG A4[16]

TEN A1[2]

Unité de mesure pour le format du papier

C Centimètres

M Millimètres (Valeur par défaut)

TEN A1[3,5]

Type du paramètre de la zone paramétrée (fi_zpar)

Non utilisé par le devis standard.

TEN A1[6,25]

Libellé de la zone paramétrée

Non utilisé par le devis standard.

TEN A1[26]

Paramétrage de la saisie de la zone fi_zpar

N Non obligatoire

W Warning si blanc

B Bloquant

Non utilisé par le devis standard.

TEN A1[27]

Doit-on effectuer des contrôles sur l'écran entité ?

Exemple : Contrôle du nombre de pages, de la saisie du format, etc.

Non utilisé par le devis standard. Utilisé dans devis_car

TEN A1[28]

Contrôle de saisie obligatoire de certaines zones (dossier de fabrication)

O Saisie obligatoire

N ou [blanc] Saisie facultative

Non utilisé par le devis standard.

TEN A1[29]

Contrôle de surface automatique à la validation d'une entité

Alerte en cas d'une perte de papier de plus de 25% ou en cas de format d'impression supérieur au format du papier

O Activation du contrôle

N Pas de contrôle (défaut)

Non utilisé par le devis standard.

TEN A1[30]

Type de fabrication pour PROSPER

1 CAHIER

2 COUVERTURE

3 ENCART

Non utilisé par le devis standard.

TEN A1[31,33]

Types d'entités (triés par ordre alpha)

AFF Affiche

COU Couverture

CVC Couverture pour cartonné (Reliure)

DEP Dépliant

ENC Encart non jeté

ENJ Encart jeté

ETB active la gestion de l'étiquette bobine dans VoluOptimix
Permet à VoluOptimix d'inverser les formats et le sens des fibres pour garder une représentation cohérente des données lorsqu'il s'agit de l'étiquette bobine.

ETF Active la gestion de l'étiquette feuille dans VoluOptimix
Permet à VoluOptimix d'inverser les formats et les doubles-coupes pour garder une représentation cohérente des données lorsqu'il s'agit de l'étiquette feuille.

FAC Façonnage (Remplace l'ancien TEN A2[20,22]

FEU Feuille

GAB Garde blanche

GAR Garde

INT Intérieur

JAQ Jaquette

LIA Liasse

TEN A1[34]

Nombre de volets par défaut (Devis standard : Feuillet / Dépliant)

TEN A1[35,37]

Nombre de pages par défaut (Nomenclature multi-niveaux et / ou Entité Feuillet / Dépliant)

TEN A1[38]

Accès à la saisie des folios lors de la saisie d'un devis (O/N, N par défaut)

TEN A1[39]

Accès à la saisie des folios lors de la saisie dune fiche de fabrication (O/N, N par défaut)

TEN A1[40]

Initialisation du format de tirage par le format de la machine

TEN A1[41]

Type de devis - Voir aussi #CF ATL A3[12]

B Bobine

C Carton ondulé

F Feuillet/dépliant

I Imprimerie

M Mécanique

R Reliure

T Continu

TEN A1[42,44]

Utilisation différente selon le type d'entité

Entité Feuillet/Dépliant (FEUDEP) :

Type de pli principal par défaut

Entités Boîte pliante (BOIPLI) et Etiquette feuille (ETIFEU) :

Type de pli par défaut pour la ligne automatique de décomposition de feuille
Le type de pli sera renseigné à la valeur ### si ce paramétrage n'est pas saisi.

Ce pli est pris d'office lors de l'optimisation d'une entité ETIFEU (car il n'existe pas de décomposition de la feuille de type CTRL-F).

TEN A1[45]

Type de contrôle du lien entre la machine et l'outil (si celui-ci est saisi)

N Pas de contrôle

W Contrôle non bloquant

B Contrôle bloquant

TEN A1[46]

Entité pouvant être optimisée (Entité Feuillet/Dépliant) (O/N, N par défaut)

TEN A1[47]

Type de papier

F Feuille

R Roto

TEN A1[48]

Calcul automatique du bord de rive (bord de rive = espace sens laize / 2)

O Calcul automatique

N Aucun calcul (par défaut)

TEN A1[49]

Recopie des machines lors de la recopie d'entité

O Les codes machines sont gardés lors de la recopie dune entité (par défaut)

N Les codes machines sont réinitialisés à vide lors de la recopie dune entité

TEN A1[50]

Contrôle automatique du format de tirage par rapport au format de papier saisi dans la machine

(le format de tirage doit être inférieur ou égal au format papier)

N Aucun contrôle

W Contrôle non bloquant (par défaut)

B Contrôle bloquant

Valeur alpha 2

TEN A2[1,8]

Numéro de devis par défaut pour ce type d'entité

TEN A2[9,10]

Numéro de sous-devis par défaut pour ce type d'entité

TEN A2[11,12]

Numéro d'entité par défaut (sous la forme 01) pour ce type d'entité

TEN A2[13]

Type de l'entité, remplace l'ancien paramétrage de type O/N.

N'est pas utilisé dans le devis multi-métiers mais dans les fonctions feuille.

R Réelle (par défaut). L'entité est prise en compte lors du calcul des poids des différents éléments.

F Fictive. L'entité est ignorée lors du calcul des poids des différents éléments.

G Globale (Façonnage). C'est sur cette entité que le façonnage sera calculé et que l'emballage sera positionné.

P Entité de pré-façonnage pour encart
Cette entité sera utilisée pour le façonnage des encarts dans le devis en cours.

TEN A2[14]

Autorisation de saisir par entité dans la fenêtre de décomposition des cahiers (O/N, N par défaut)

TEN A2[15]

Autorisation de saisir les codes supports dans l'écran Etiquettes bobines (O/N, N par défaut)

(code frontal, adhésif et dorsal)

TEN A2[16]

Autorisation d'accès aux zones de changements de plaques et de teintes en mono-référence

Uniquement pour l'entité Etiquette bobine.

T Les zones sont toujours accessibles en entité mono-référence

M Les zones sont accessibles mais un message d'avertissement apparaît si l'entité est en mono-référence et qu'une saisie est faite

N Les zones ne sont jamais accessibles en entité mono-référence (valeur par défaut)

TEN A2[17]

[Entité Feuillet/Dépliant]

Si un nombre de couleurs verso est saisi, initialiser automatiquement le code machine verso (si aucune machine verso saisie) avec le code machine recto.

O Machine verso = Machine recto (par défaut)

N Aucun automatisme

TEN A2[18]

[Entités Feuillet/Dépliant Etiquette Feuille]

Type de recherche de papier si le poids calculé du papier est inférieur à la quantité minimum pour la commande client (zone saisie dans l'écran d'approvisionnement F12 de la fiche matière)

N Aucune recherche de papier (par défaut)

C Recherche selon le seuil papier avec choix dans l'écran de recherche de matière optimisée

M Recherche selon le seuil papier avec la perte minimum

TEN A2[19]

Ouverture automatique de l'écran de saisie des LCO sur les entités

N Jamais (par défaut)

P Uniquement après la saisie du nombre de pages

V Uniquement à la validation de l'écran des entités

2 Ouverture systématique après le nombre de pages ainsi qu'à la validation

TEN A2[20,22]

Type de façonnage pour cette entité

PIQ Façonnage de piqûre

TEN A2[23]

Désactivation de l'automatisme de mise à jour de zones (Nombre de couleurs, pourcentage d'encrage, pourcentage de vernis et type de vernis) lors de la mise en place de la bascule (Indifférente, in8 ou in12).(O/N, N par défaut)

TEN A2[24]

Affichage d'un message d'avertissement si l'entité est définie comme mono-référence (Type dimposition = M) et que le nombre de références est supérieur à 1

N Aucun message d'avertissement

W Affichage d'un message non bloquant

B Affichage d'un message bloquant (valeur par défaut)

TEN A2[25]

Affichage d'un message d'avertissement si l'entité est définie comme multi-référence (Type dimposition = R, F ou H) et que le nombre de références est égal à 1

N Aucun message d'avertissement

W Affichage d'un message non bloquant

B Affichage d'un message bloquant (valeur par défaut)

TEN A2[26]

Méthode de réactualisation des zones liées à l'outil lors du passage sur le code outil

T Les zones sont toujours mises à jour.

N Les zones ne sont jamais mises à jour.

C Une demande de confirmation de mise à jour s'affiche si des différences ont été détectées entre la fiche outil et le devis.

M Les zones sont mises à jour seulement si le code outil est modifié (par défaut).

Voir la note _MAJ_ZONE_LIEE_OUTIL

TEN A2[27]

Méthode de réactualisation des zones liées au complexe lors du passage sur le code complexe

T Les zones sont toujours mises à jour.

N Les zones ne sont jamais mises à jour.

C Une demande de confirmation de mise à jour s'affiche si des différences ont été détectées entre la fiche complexe et le devis.

M Les zones sont mises à jour seulement si le code complexe est modifié (par défaut).

TEN A2[28]

Type d'optimisation de devis

I Devis optimisé pour l'imprimerie (Entité Feuillet/Dépliant)

P Devis optimisé par phase (note commençant par #G sur les phases)

M Activation des deux optimisations :
1 Optimisation du devis imprimerie
2 Optimisation du devis optimisé par phase

Voir aussi PHA A4[36]

TEN A2[29]

Inversion des zones de format papier

O Inversion des zones

Première zone : sens travers/sens des fibres

Deuxième zone : sens machine

N Aucune inversion de zone (par défaut)

Première zone : sens machine

Deuxième zone : sens travers/sens des fibres

Le TEN pris en compte pour cette inversion est celui qui est défini sur le TPR A4[ 8,10]

Attention : dans le cadre du contrôle des contraintes techniques pour les fournisseurs, ce paramètre est remplacé par la note INVERSION_FORMAT dans le devis multi-métiers.

TEN A2[30]

Calcul automatique lors de la validation de l'entité par la touche F9 ou F10

O L'entité est calculée lors de la validation par la touche F9 ou F10

N L'entité n'est pas calculée lors de la validation par la touche F9 ou F10 (par défaut)

R L'entité est calculée lors de la validation par la touche F9 uniquement (retour)

V L'entité est calculée lors de la validation par la touche F10 uniquement (validation)

T L'entité est calculée lors de la validation par la touche F9 ou F10, lorsque la gamme n'est pas renseignée (fle_imp.fi_code_gamme)

Uniquement pour une entité de type transformateur/carton (TRFCAR).

TEN A2[31]

Recalcul automatique lors de la validation de l'entité par la toucheF6

O L'entité est recalculée lors de la validation

N L'entité n'est pas recalculée lors de la validation (par défaut)

TEN A2[32]

Initialisation des zones Changement de plaques et Changement de teintes recto/verso de l'entité avec la somme des mêmes zones de la saisie multi-bande

O Recalcul et initialisation des zones ci-dessus à la sortie du multi-bande

N Aucune initialisation (par défaut)

TEN A2[33]

Gestion du multi-bande : (O/N, N par défaut)

A la validation de l'écran de saisie multi-bande, et si aucune ligne n'est renseignée dans l'écran de décomposition des cahiers, il sera créé automatiquement une ligne de cahier par bande saisie.

TEN A2[34]

Prise en charge des données massicot (O/N, N par défaut) (pour VoluOptimix)

Il faut créer une LCO MAS qui vient se mettre en automatique sur l'entité et récupère les données suivantes :

v1 : nombre de coupes

v2 : nombre de retournements

TEN A2[35]

Mise à jour automatique du nombre de poses de l'entité par la somme des nombres de poses saisies sur chaque ligne de référence multiple (O/N)

TEN A2[36]

Récupération de la qualité matière pour la génération du code papier

1 La qualité matière sera le code papier générique saisi sur l'entité (par défaut)

2 La qualité matière sera le code qualité renseigné sur le code papier générique saisi sur l'entité

TEN A2[37,39]

Code signature par défaut pour la création automatique du descriptif de roulage

(Type de paramètre : DT)

TEN A2[40]

La saisie du grammage pour VoluOptimix est facultative (O/N, N par défaut)

TEN A2[41]

Contrôle des opérations de finitions en ligne par rapport aux caractéristiques machines

N Pas de contrôle

W Avertissement si l'opération de finition n'est pas possible sur la machine

B Contrôle bloquant si l'opération de finition n'est pas possible sur la machine

TEN A2[42]

Limitation du nombre de formats de cahiers différents sur une même feuille pour tous les types de machines d'impression dans le cas des plis en sortie à plat (PLI A1[27] = F)

Valeurs possibles 1, 2, 3 (3 par défaut)

TEN A2[43]

Limitation du nombre de formats de cahiers différents sur une même feuille pour les rotatives dans le cas des plis pliés en ligne (PLI A1[27] = R)

Valeurs possibles 1, 2, 3 (3 par défaut)

TEN A2[44]

Dans le cas dune impression recto seul, possibilité d'exclure les machines de retiration, superposées ou les deux. Valeurs possibles N,R,S,2 (N par défaut)

TEN A2[45]

Possibilité d'interdire la saisie des plis complexes et manuels en type de pli principal (O/N, N par défaut)

TEN A2[46]

Accès interdit à la saisie du détail de la nomenclature multi-niveaux ( O/N, N par défaut)

TEN A2[47]

Optimisation du papier

O Dans l'optimisation, le papier n'est pas optimisé.

N L'optimisation du papier est active.

TEN A2[48]

Le nombre de poses est à rechercher sur la décomposition de la feuille (O/N/M, N par défaut)

O Le nombre de poses est recherché en priorité sur la première ligne de décomposition(1)

N Le nombre de poses est recherché sur l'entité (par défaut)

M Le nombre de poses est recherché en priorité sur la première ligne de décomposition(1) et la validation de la saisie de la décomposition met à jour le nombre de poses de l'entité.

(1) Permet de préciser que le nombre de poses doit être recherché sur la décomposition de la feuille (Control-F) plutôt que sur l'entité (utilisé pour le code calcul NP caractère 1 = N)

TEN A2[49]

Type d'entité compatible avec la recherche de décomposition en coming & going (O/N, O par défaut)

TEN A2[50,52]

Taux de marge minimum pour le code blocage automatique BLD A1[3,5] = 001

Le taux saisi sur le TSC BDM est prioritaire sur celui-ci.

TEN A2[53]

Désactiver le calcul du transport de l'entité courante si le métrage linéaire plancher calculé est égal à 0 (zéro) et si le prix du transport n'est pas forcé (O/N, N par défaut)

TEN A2[54]

Accès autorisé aux données relatives au format de pose et tirage lors de la saisie d'un numéro de forme (outil) non générique (O/N, N par défaut)

TEN A2[55]

Accès autorisé à la saisie du numéro de référence sur la décomposition des feuilles (O/N, N par défaut)

TEN A2[56]

Contrôler la cohérence de saisie du nombre de poses (le nombre de poses doit être identique sur chaque ligne)

N Aucun contrôle

W Contrôle en avertissement

B Contrôle bloquant

TEN A2[57]

Contrôler la cohérence de calcul de la dimension engagée (la dimension engagée doit être calculée)

N Aucun contrôle

W Contrôle en avertissement

B Contrôle bloquant

TEN A2[58]

Accès autorisé à la saisie du numéro de feuille sur la décomposition des feuilles

O Le numéro et le nombre de feuille sont saisissables

N Le numéro et le nombre de feuille ne sont pas saisissable (1 seule décomposition de feuille et nombre de feuilles calculé automatiquement) (par défaut)

TEN A2[59]

Nombre de poses entre le format de papier et le format de tirage calculé automatiquement

O Le nombre de poses est calculé (par défaut)

N Le nombre de poses est forcé à 1

TEN A2[60]

Saisie des lignes multiples d'impression

T Ouverture systématique de l'écran de saisie

C Ouverture de l'écran de saisie en création d'entité uniquement

E Ouverture automatique de l'écran si une ligne d'impression a déjà été saisie

O Saisie autorisée, pas d'ouverture automatique de l'écran de saisie

N Saisie interdite (par défaut)

Valeur alpha 3

TEN A3[1]

Réservé

TEN A3[2]

Type de recherche de devis dans la saisie des lignes d'offre de prix (offre_de_prix)

N Recherche normale (par défaut)

O Recherche des devis avec visualisation des variantes

V Recherche par la visualisation des devis

P Recherche des devis transformateur cartonnier avec visualisation des variantes

T Recherche des devis transformateur cartonnier

TEN A3[3]

Inversion des zones de dimensions longueur/largeur dans l'écran des références multiples

O Les zones longueur et largeur sont inversées à la saisie et à l'affichage.

N Les zones longueur et largeur ne sont inversées ni à la saisie, ni à l'affichage.

Par défaut : dépend du code écran en cours de l'entité

BOIPLI (Boîte pliante) : Les zones longueur et largeur ne sont inversées ni à la saisie, ni à l'affichage.

ETIFEU (Etiquette feuille) : Les zones longueur et largeur ne sont inversées ni à la saisie, ni à l'affichage.

TRFCAR (Transformateur carton) : Les zones longueur et largeur ne sont inversées ni à la saisie, ni à l'affichage.

[Autres codes écrans] : Les zones longueur et largeur sont inversées à la saisie et à l'affichage.

TEN A3[4]

Prise en compte des cahiers de ce type d'entité dans le calcul du nombre de cahiers total du sous-devis (O/N, O par défaut)

TEN A3[5]

Récupération automatique du code affiche (code produit de l'entité) à partir des références multiples saisies sur l'entité (O/N, N par défaut)

TEN A3[6]

Ouverture automatique de l'écran de saisie de la décomposition de la feuille

T Ouverture systématique

C Ouverture si aucune ligne de décomposition n'existe

I Ouverture si aucune ligne de décomposition n'existe ou s'il manque certaines informations sur les lignes existantes
(nombre de cahiers, nombre de pages et/ou code pli)

N Pas d'ouverture automatique

TEN A3[7]

L'entité est prise en compte dans le cumul des quantités pour le contrôle par rapport à la quantité totale du devis (O/N, O par défaut)

Voir aussi TPR A4[41] et USE A3[56]

TEN A3[8]

Recopie automatique des références d'entête sur la première entité

O Recopie systématique

C Recopie sur demande de confirmation

N Pas de recopie (par défaut)

Permettre, sur la première entité d'un sous-devis, de récupérer automatiquement toutes les références multiples de l'entête.

Remarques :

" La recopie des références d'entête sur la première entité se fait à la validation du champ Nombre de références (fle_imp.fi_nb_references)

" Les conditions suivantes doivent être vérifiées pour que la récupération soit possible :

o Activation du paramétrage de récupération sur le type d'entité (voir ci-dessous)

o Le nombre de références doit être saisi sur l'entité (fle_imp.fi_nb_references)

o Aucune référence ne doit être saisie sur la première entité

TEN A3[9]

Récupération du numéro d'entité de la ligne parente

O Oui (par défaut)

N Non (Génération d'une nouvelle entité) Obligatoire pour générer des entités à tous les niveaux.

C Demande de confirmation

TEN A3[10]

Automatisme de remplissage des champs de présence de quadrichromie et nombre de couleurs primaires selon le nombre de couleurs (O/N, O par défaut)

Permet de remplir automatiquement le champ de présence de quadrichromie (présence activée si le nombre de couleurs est supérieur à 4, présence désactivée dans le cas contraire) et sur le nombre de couleurs primaires (limité à 4 si le nombre de couleurs est supérieure à 4, nombre de couleurs dans le cas contraire).

TEN A3[11]

Remise à zéro des données du conditionnement suite à la modification de la qualité carton

O Remise à zéro systématique (par défaut)

C Remise à zéro sur confirmation

N Pas de remise à zéro (celle-ci est effectuée uniquement si le profil carton est modifié)

N.B. : Si le profil carton est modifié, la remise à zéro des données du conditionnement est systématique (pas de prise en compte de ce paramétrage).

TEN A3[12]

Prendre en compte le nombre de poses dans le calcul de la surface unitaire nette (O/N, N par défaut)

TEN A3[13]

Permettre de réinitialiser la gamme selon la modification du profil carton, lors de la modification du code qualité de l'entité transformateur/carton (TRFCAR)

O Remise à zéro systématique (par défaut)

C Remise à zéro sur confirmation

N Pas de remise à zéro (celle-ci est effectuée uniquement si le profil carton est modifié.)

N.B. : Si le profil carton est modifié, la remise à zéro de la gamme est systématique (pas de prise en compte de ce paramétrage).

TEN A3[14]

Calcul du format de tirage à partir des longueurs de filet à filet au retour de VoluOptimix (O/N, N par défaut)

Nécessite VoluOptimix version 1.4.3 (pour l'option de longueur de filet à filet en mètres).

• Format de tirage sens machine = Longueur filet à filet sens machine + blanc de côté gauche + blanc de côté droit

• Format de tirage sens travers = Longueur filet à filet sens travers + prise de pinces + fin de pression

Remarques :

• La valeur de la gamme couleur est également prise en compte et s'ajoute à l'une des 4 valeurs de pinces

• Ce calcul est effectué seulement si le format de tirage n'est pas forcé.

TEN A3[15]

Contrôle de la possibilité de basculer selon le nombre de couleurs

W Contrôle non bloquant (par défaut)

B Contrôle bloquant

C Demande de confirmation

N Pas de contrôle

Permet de contrôler la possibilité de basculer selon le nombre de couleurs recto/verso par rapport au nombre de couleurs gérées au maximum sur la machine d'impression.

Pour pouvoir basculer il faut que :

Nombre de couleurs maxi entre recto et verso + Nombre de couleurs différentes <= Nombre de couleurs maxi de la machine.

où

Si le nombre de couleurs maximum est sur le recto :

Nombre de couleurs différentes = Nombre de couleurs du verso – Nombre de couleurs communes entre le recto et le verso

Si le nombre de couleurs maximum est sur le verso :

Nombre de couleurs différentes = Nombre de couleurs du recto – Nombre de couleurs communes entre le recto et le verso

Remarque : Ce contrôle est obligatoirement activé sur le calcul du devis optimisé imprimerie.

TEN A3[16]

Initialiser le nombre de couleurs communes avec le minimum entre le nombre de couleurs recto et verso (si présence de couleurs au recto et au verso uniquement) (O/N, O par défaut)

TEN A3[17]

Mise à jour de la quantité des lignes de nomenclature associées à l'entité en cours de saisie

O Mise à jour systématique

N Aucune mise à jour (par défaut)

C Mise à jour sur confirmation

TEN A3[18]

Prendre en compte ce type d'entité dans le code calcul IM/I permettant de savoir si les entités avec impression sont identiques (présence de quadrichromie, même nombre de couleurs et même machine) (O/N, O par défaut)

Remarques :

• Les entités de façonnage sont automatiquement exclues : TEN A 1[31, 33] = FAC

• Ce paramétrage est également utilisé pour le calcul du lavage du devis optimisé imprimerie

TEN A3[19]

Type de calcul des gâches cumulatives dans la recherche optimisée par phase

S Simplifiée (par défaut)

Prise en compte uniquement des coefficients de poses des gâches cumulatives (lignes commençant par « FORMULE_COEFF_POSE » dans les notes des formules)

C Complète

Recalcul complet des gâches cumulatives pour chaque machine à prendre en compte.

ATTENTION : Cette méthode augmente significativement le temps de calcul.

TEN A3[20]

Association des codes produits entité et nomenclature

O Le code produit de la ligne de nomenclature est identique à celui de l'entité associée et vice-versa.

N Le code produit de la ligne de nomenclature peut être différent de celui de l'entité associée (par défaut).

TEN A3[21]

Initialiser le format de tirage avec le format papier si le papier saisi n'est pas générique

T Le format de tirage est systématiquement réinitialisé avec le format papier
Le forçage du format de tirage n'est pas modifié.

F Le format de tirage est systématiquement réinitialisé avec le format papier
Le forçage du format de tirage est activé.

L Le format de tirage est réinitialisé avec le format papier seulement s'il n'est pas forcé
Le forçage du format de tirage n'est pas modifié.

O Le format de tirage est réinitialisé avec le format papier seulement s'il n'est pas forcé
Le forçage du format de tirage est activé.

C Demande de confirmation

N Le format de tirage n'est pas réinitialisé avec le format papier (par défaut).

Permet d'initialiser le format de tirage avec le format papier si celui-ci n'est pas générique.

Le forçage du format de tirage peut également être activé selon le paramétrage (zone fle_imp.fi_ft_impo mis à la valeur O).

Remarques :

• L'initialisation du format de tirage est effectuée à la fin du chargement des zones liées à la modification du code papier (lors de la modification manuelle du code papier, de la sélection d'un papier via la recherche de matière optimisée, etc.)

• Ce fonctionnement est valable pour les types d'entité suivants :

o BOIPLI : Boîte pliante

o FEUDEP : Feuillet/Dépliant

o ETIFEU : Etiquette

o ETIBOB : Etiquette bobine

TEN A3[22]

Accès à l'entité à la validation de la ligne de nomenclature

T Toujours (Création et Modification)

C en Création uniquement

M en Modification uniquement

Q Demande de confirmation

N Non (par défaut)

Remarques

• La ligne de nomenclature doit être associée à un type d'entité.

• L'ouverture se fait à la validation du dernier champ saisissable et après la validation de la saisie du détail de référence
(si une référence est saisie sur la ligne).

TEN A3[23]

Ouverture de l'écran de saisie des pointages après la modification d'un élément technique sur les entités de type transformateur/carton (TRFCAR) (O/N, O par défaut)

TEN A3[24]

Contrôle du nombre de couleurs (O/N,O par défaut)

Actuellement, il existe sur plusieurs écrans du devis un contrôle vérifiant que le nombre de teintes additionné au nombre de couleurs primaires n'est pas supérieur au nombre de couleurs total.

TEN A3[25]

Accès à la saisie des références multiples pour ce type d'entité (O/N, O par défaut)

• Lorsque la saisie des références multiples est interdite au niveau du type d'entité, la colonne Référence de la nomenclature n'est ni initialisée en automatique, ni accessible pour les lignes associées à ce type d'entité.

• RAPPEL : La saisie des références multiples peut également être interdite au niveau du type de processus (TPR).
Ce dernier paramétrage est prioritaire à celui du TEN.

Valeur alpha 4

TEN A4[1,6]

Type et code du paramètre de lancement de la saisie de devis (pour la saisie d'offres de prix)

TEN A4[7,9]

Type d'écran pour la saisie des entités de devis standard

TEN A4[10]

Accès à l'écran de détail des couleurs après les champs couleur recto/verso

S (Systématique) : Ouverture systématique après le champ couleur (sans saisie)

T (Toujours) : Ouverture systématique après la saisie d'un champ couleur

C (Création) : Ouverture uniquement en création d'entité

N (Non) : Pas d'ouverture automatique

TEN A4[11]

Table à prendre en compte pour la recherche de matières consommées

M mat (par défaut)

F mat_format

2 les deux

TEN A4[12]

Mode de calcul pour la recherche de matière optimisée

N Normal (par défaut)

B Bobine. Toutes les informations liées au sens travers (coupe) seront ignorées.

F feuille. Les bobines seront ignorées

TEN A4[13]

Mode de vérification du stock pour la recherche de matière consommée

D Vérification par rapport au stock disponible (par défaut)

P Vérification par rapport au stock physique

N Pas de vérification par rapport au stock

TEN A4[14]

Mise à jour automatique du métrage linéaire lors de la recherche de tarif

(mise à jour à partir du résultat de la formule de calcul tarif)

O Mise à jour

N Pas de mise à jour (par défaut)

TEN A4[15]

En devis multi-références, avec entité multi-références ou entité mono-référence :

Accès à l'écran de saisie des références multiples après le champ de saisie du nombre de références

T Ouverture systématique après la saisie

C Ouverture uniquement en création d'entité

S Ouverture uniquement si aucune référence n'a été saisie sur l'entité

N Pas d'ouverture automatique

TPR A4[30], s'il existe, a priorité sur ce paramètre.

TEN A4[16]

Permettre, au retour de VoluOptimix, de réinitialiser le format papier avec le format de tirage.

Cette mécanique n'est accessible que pour les entités de type ETIBOB (étiquette bobine) et BOIPLI (boîte pliante).

Pour l'entité ETIBOB (étiquette bobine) :

Initialisation de la laize papier

0 Aucune initialisation de la laize papier

1 La laize papier est automatiquement initialisée par la laize de tirage (par défaut).

2 La laize papier est réinitialisée par la laize de tirage uniquement si cette dernière prend une valeur supérieure à la laize papier actuelle.

3 La laize papier est initialisée par la laize de tirage si elle est égale à 0.

Au retour de VoluOptimix (modification de la solution), pour les valeurs 1, 2 et 3 et si le papier est générique : La laize papier est automatiquement initialisée par la laize de tirage.

Pour l'entité BOIPLI (Boîte pliante), si le papier est générique uniquement :

Initialisation de la laize et de la coupe papier

0 Aucune initialisation de la laize papier
Aucune initialisation de la coupe papier

1 La laize papier est automatiquement initialisée par la laize de tirage.
La coupe papier est automatiquement initialisée par la coupe de tirage (par défaut).

2 La laize papier est réinitialisée par la laize de tirage uniquement si cette dernière prend une valeur supérieure à la laize papier actuelle.
La coupe papier est réinitialisée par la coupe de tirage uniquement si cette dernière prend une valeur supérieure à la coupe papier actuelle.

3 La laize papier est initialisée par la laize de tirage si elle est égale à 0.
La coupe papier est initialisée par la coupe de tirage si elle est égale à 0.

Au retour de VoluOptimix (modification de la solution), pour les valeurs 1, 2 et 3 et si le papier est générique :

La laize papier est automatiquement initialisée par la laize de tirage.

La coupe papier est automatiquement initialisée par la coupe de tirage.

TEN A4[17]

Format pris en compte lors de la recherche des solutions d'imposition via VoluOptimix.

O Format machine

N Format papier (valeur par défaut

E Eclatement du format papier

(transfert à VoluOptimix du Format papier + 10 éclatements)

ATTENTION : Il existe également des formats standard définis par les notes FORMAT_VOLUOPTIMIX.

Ces notes ne sont prises en compte que si le format de tirage n'est pas forcé.

VoluOptimix peut n'apporter aucune solution compte tenu du format unitaire de la pose.

TEN A4[18,32]

Code ECMA / FEFCO par défaut pour les entités feuillet / dépliant - (TEN A1[31,33] = DEP)

TEN A4[33]

Dans la nomenclature multi-niveaux du devis, activer l'unicité des libellés de ligne (O/N, N par défaut).

La désignation de l'entité et la désignation de la ligne de nomenclature doivent être identiques.

TEN A4[34]

Dans la saisie de la nomenclature multi-niveaux du devis, ne pas prendre en compte ce type d'entité pour la vérification du nombre de page des lignes saisies par rapport au devis (O/N, N par défaut).

Voir TPR, alpha4[15]

TEN A4[35]

Dans la nomenclature multi-niveaux du devis, initialiser automatiquement le format fini avec le format saisie sur l'entête de devis (O/N, N par défaut).

TEN A4[36,38]

Code de l'unité de quantité utilisée dans l'entité (utilisé pour le calcul des gâches cumulatives)

Voir aussi les notes sur les formules

TEN A4[39,41]

Type de paramètre de la zone paramétrable 2

TEN A4[42,44]

Type de paramètre de la zone paramétrable 3

TEN A4[45]

Dans la saisie de l'étiquette feuille, inverser les calculs.

O On s'appuie sur la base de l'étiquette pour calculer le format de tirage sens travers, et sur la hauteur de l'étiquette pour calculer le format sens machine.

N On s'appuie sur la base de l'étiquette pour calculer le format de tirage sens machine, et sur la hauteur de l'étiquette pour calculer le format sens travers (par défaut)

TEN A4[46]

Dans la saisie des entités, pouvoir accéder à la saisie de la ligne d'impression recto et/ou verso si aucune donnée couleur ou vernissage n'est saisie.

O On peut accéder à toute la ligne, même si aucune donnée couleur/vernissage n'est saisie

N Si aucune donnée de couleur ou de vernissage n'est saisie, la ligne d'impression recto et/ou verso n'est pas accessible (valeur par défaut)

TEN A4[47]

Contrôle automatique du format de tirage par rapport au format d'impression saisi dans la machine

Le format de tirage doit être inférieur ou égal au format impression maxi et supérieur ou égal au format impression mini

N Aucun contrôle

W Contrôle non bloquant (par défaut)

B Contrôle bloquant

TEN A4[48,50]

Code formule associée à la génération du papier

Par défaut, c'est le code formule paramétré sur la phase PAP (paramètre : PHA/PAP) qui est pris en compte.

Ce paramétrage permet de forcer un code formule par TEN différent de celui par défaut, à savoir celui paramétré sur la phase PHA/PAP, en zone A1[16,18].

Il est utilisé dans la fonction feuille de génération des papiers (calcul du devis)

TEN A4[51]

Recopie de la quantité de l'entité sans aucun recalcul

O On recopie la quantité de l'entité telle quelle

C Demande de confirmation

N On recalcule la quantité de l'entité à partir de la quantité du devis (par défaut)

TEN A4[52]

Active le réajustement de laize automatique (O/N, N par défaut)

TEN A4[53]

Récupération de la référence créée sur l'entête après la recopie de l'entité par défaut (O/N, N par défaut)

En devis mono-référence uniquement : permet de récupérer la référence créée sur l'entête lors de la création de l'entité par recopie de l'entité par défaut renseignée sur le paramètre TEN (remplissage manuel par l'utilisateur de la valeur du type d'entité).

Pour que cette récupération de référence fonctionne, il faut que les conditions suivantes soit réunies :

Le devis doit être mono-référence (l2_nb_references = 1)

L'entité en cours de création doit être mono-référence (fi_nb_references = 1)

Aucune référence existante sur l'entité source par défaut

TEN A4[54]

Ajout de 4 coupes au calage et au roulage du massicot (formules concernées OMAD50 et OMAD51)

(O/N, N par défaut)

TEN A4[55]

Activer la gestion du conditionnement (O/N, N par défaut)

Intégration du devis TC dans le devis multi-métiers

TEN A4[56]

Activer la gestion de la gamme standard (O/N, N par défaut)

Intégration du devis TC dans le devis multi-métiers

TEN A4[57]

Type d'entité avec présence de découpe (O/N, N par défaut)

Intégration du devis TC dans le devis multi-métiers

TEN A4[58]

Forçage de la saisie du coefficient de nomenclature

Intégration du devis TC dans le devis multi-métiers

(ouverture automatique de la fenêtre de saisie normalement accessible par la touche F7)

TEN A4[59]

Mise à jour de la zone fi_feu_pap_hg (nombre de feuilles papier hors gâche) par VoluOptimix (O/N, N par défaut)

TEN A4[60]

Nombre de décimales à saisir et/ou afficher pour ce type d'entité (0 à 3, 0 par défaut)

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes paramétrées sur TEN sont prioritaires sur celles du devis multi-métiers.

Ce fonctionnement est activé pour les entités et les zones suivantes :

Etiquette feuille (ETIFEU)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

Etiquette bobine (ETIBOB)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

code_frontal Code du support frontal

code_adhesif Code du support adhésif

code_frontal Code du support dorsal

Feuillet/Dépliant (FEUDEP)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

Transformateur carton (TRFCAR)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

Boîte pliante (BOIPLI)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

Saisie des LCO (SAILCO)

fi_prod_ent Code produit fini

fi_c_papier Code papier (support)

Voir aussi : #CF RMP

Notes triées

ACTIVATION_PHASE

Activation / désactivation de phase suivant la valeur d'un champ

21,38 Code de la zone. Voir plus bas la liste des zones disponibles.

39,41 Code de la phase à activer/désactiver

42,44 Code d'action à mettre en Oeuvre

(La comparaison se fait entre la valeur actuelle de la zone et la valeur paramétrée sur les caractères 45 à 60). Valeurs possibles

ACT | Activation si valeur égale
AC> | Activation si valeur supérieure
AC< | Activation si valeur inférieure
AC! | Activation si valeur différente
DES | Désactivation si valeur égale
DE> | Désactivation si valeur supérieure
DE< | Désactivation si valeur inférieure
DE! | Désactivation si valeur différente

45,60 Valeur à prendre en compte pour la comparaison

CALCUL_PRISE_PINCES

Initialisation des prises de pinces via des codes calcul

Dans la saisie de l'entité transformateur/carton (TRFCAR) du devis multi-métiers, permettre l'initialisation des prises de pince laize/coupe via des codes calcul.

Rappel :

Par défaut, les valeurs prises de pinces sont prises sur les valeurs numériques 1 et 2.

21,22 Code dépendance utilisé pour le calcul de la valeur de prise de pince sens laize

Exemple : TB

23,29 Paramétrage de la dépendance utilisé pour le calcul de la valeur de prise de pince sens laize

Exemple : P3

31,32 Code dépendance utilisé pour le calcul de la valeur de prise de pince sens coupe

Exemple : TB

33,39 Paramétrage de la dépendance utilisé pour le calcul de la valeur de prise de pince sens coupe

Exemple : P4

#CC

Contrôle des champs

Voir la page récapitulative

CODE_ECRAN_ENTITE

21,26 Code de l'écran spécifique d'entité - Voir aussi la note TITRE_ECRAN_ENTITE

BOIPLI Boîte pliante

ETIBOB Etiquette Bobine

ETIFEU Etiquette Feuille

FEUDEP Feuillet/Dépliant

PHOGRA Photogravure (voir les notes commençant par PHOTO)

SAILCO Saisie de LCO intégrée

TRFCAR Ecran du devis transformateur carton
Intégration du devis TC dans le devis multi-métiers

CODE_LIEN_TABLES

21,23 Code de lien à utiliser pour la recherche de liens entre les tables mat (outils) et mac0 (machines). Code utilisé dans la recherche d'outils. Correspond à un code paramètre de type #LI

CODE_PAR_CONF_SMC

Code paramètre de la configuration de la recherche optimisée des papiers

Par défaut, le code est SMC. voir TEN A4[11,12,13]

CODES_NTS_LIGIMP

21,59 Liste des codes paramètres de types de notes (NTS) saisissables sur les lignes d'impression multiple

Par défaut : les types de notes du programme sont utilisées (argument C sur le paramètre de lancement)

La table de notes utilisée est : notes

Le type de clé de notes est : 5 (notes.nn_type)

Soumis à permission

La clé est composée comme suit :

Devis - Sous-devis - Entité - 003 - N°Passage - N°Vernis

DDDDDDDD - SSS - EEE - 003 - PPP - VVV

CONSERVE_FORMAT_PAP

21 Conserver le format papier saisi sur écran ETIFEU (O/N, N par défaut)

CONTEXTE_DETAIL_COU

Accès contextuel à l'écran de détail de couleurs suivant la valeur dun champ.

21,38 Code de la zone. Voir plus bas la liste des zones disponibles.

39,44 Code d'action à mettre en oeuvre

La comparaison d'égalité se fait entre la valeur actuelle de la zone et la valeur paramétrée sur les caractères 45 à 60.

Valeurs possibles :

ACCES= Accès si valeur égale

ACCES> Accès si valeur supérieure

ACCES< Accès si valeur inférieure

ACCES! Accès si valeur différente

En réalité, seul le caractère 44 est pris en compte dans le programme.

Peu importent les 5 caractères qui précèdent.

45 60 Valeur à prendre en compte pour la comparaison d'égalité

CONTEXTE_LCO_NOM

21,59 Liste des codes LCO à afficher dans l'écran de nomenclature pour ce type d'entité

13 codes de 3 caractères par ligne

CONTEXTE_PHASE

Accès contextuel au détail dune phase suivant la valeur d'un champ.

21,38 Code de la zone. Voir plus bas la liste des zones disponibles.

39,41 Code de la phase

42,43 Type de phase

MA Matière

OP Opération

ST Sous-traitance

44 Code d'action à mettre en Oeuvre

La comparaison d'égalité se fait entre la valeur actuelle de la zone et la valeur paramétrée sur les caractères 45 à 60.

Valeurs possibles

= Accès si valeur égale

> Accès si valeur supérieure

< Accès si valeur inférieure

! Accès si valeur différente

45,60 Valeur à prendre en compte pour la comparaison d'égalité

CONTEXTE_TYPE_NOTE

Types de note selon le contexte

21,38 Nom du champ

39,41 Type de note associé au champ

Voir plus bas la liste des champs compatibles.

Remarques :

" Une ligne de note par couple champ/type de note

" Ce fonctionnement n'est valable dans l'immédiat que sur les entités de type boîte pliante (BOIPLI)

CONTROLES_PAPIER

Contrôle des informations papier (laize, grammage et épaisseur) dans l'entité étiquette bobine (ETIBOB)

21 Contrôle du grammage

N Aucun contrôle (par défaut)

W Contrôle non bloquant

B Contrôle bloquant

22 Contrôle de la laize

N Aucun contrôle (par défaut)

W Contrôle non bloquant

B Contrôle bloquant

23 Contrôle de l'épaisseur

N Aucun contrôle (par défaut)

W Contrôle non bloquant

B Contrôle bloquant

DESACTIVE_TRANSPORT

Permet de désactiver le calcul du transport sur une entité via la comparaison d'une valeur issue d'un code calcul

21,22 Code dépendance

23,29 Paramétrage de la dépendance

30 Type de retour du calcul

A Alphanumérique

N Numérique

31,33 Type d'opérateur de comparaison

DES Désactive le calcul du transport si la valeur issue du code calcul est égale à la valeur paramétrée ci-dessous

DE ! Désactive le calcul du transport si la valeur issue du code calcul est différente de la valeur paramétrée ci-dessous

DE< Désactive le calcul du transport si la valeur issue du code calcul est inférieure à la valeur paramétrée ci-dessous (Type de retour numérique uniquement)

DE> Désactive le calcul du transport si la valeur issue du code calcul est supérieure à la valeur paramétrée ci-dessous (Type de retour numérique uniquement)

34,48 Valeur à comparer au résultat du code calcul

DOCUMENT_PLI

Permet d'ouvrir un document Windows associé au code pli saisi sur la ligne de décomposition de la feuille (touche Control-W).

21,60 Chemin d'accès au document Windows associé au pli

Il est possible d'utiliser les caractères réservés suivants pour remplir le nom de fichier à l'exécution

?01 Réservé

?02 Code client

?03 Devis_Sous devis_Entité

?04 Code pli

Cette note est recherchée dans l'ordre de priorité suivant :

1. sur le code pli

2. sur le type d'entité (ici)

3. sur le paramètre de lancement de la saisie des devis

DOCUMENT_WIN_DEFAUT

21,60 Chemin d'accès Windows au fichier à ouvrir sur les champs de l'entête de devis autres que ceux réservés (code outil, numéro de plan CAO)

Il est possible d'utiliser les caractères réservés suivants pour remplir automatiquement le nom de fichier à l'exécution :

?02 Code client

?03 Devis_Sous-devis_Entité (sous la forme DDDDDDDD_SS_EE)

?04 Code Devis

?05 Code Produit

Remarque : Tous les types d'entités sont concernés par ce paramétrage.

La même note existe aussi sur le TPR.

DOCUMENT_WIN_IMAGE

21,60 Chemin d'accès Windows au fichier à ouvrir sur le champ image (CTRL-W).

Il est possible d'utiliser les caractères réservés suivants pour remplir automatiquement le nom de fichier à l'exécution :

?01 Code image

?02 Code client

?03 Devis_Sous devis_Entite

?04 Code Devis

?05 Code Produit

Exemple : C:\Mes Documents\Image_?01_?03.pdf

DOCUMENT_WIN_OUTIL

21,60 Chemin d'accès Windows au fichier à ouvrir sur le champ outil (par la touche CTRL-W).

Il est possible d'utiliser les caractères réservés suivants pour remplir automatiquement le nom de fichier à l'exécution :

?01 Code outil

?02 Code client

?03 Devis_Sous devis_Entite

?04 Code Devis

?05 Code Produit

Exemple : C:\Mes Documents\Outil_?01.pdf

EXCLURE_DEC_ENT_99

21 Exclure la décomposition associée au type d'entité de l'intégration des plis dans l'entité de façonnage 99 (O/N, N par défaut)

Cette note est prioritaires sur celle de PLI.

Elle est utilisée par le devis imprimerie feuille et rotative.

FORCE_RETOUR_AU_F10

21,26 Code écran sur lequel on ira au F10 en cours de saisie du tableau des LCO sur les entités de type SAILCO

FORMAT_VOLUOPTIMIX

21,29 Format sens travers par défaut pour VoluOptimix

31,39 Format sens machine par défaut pour VoluOptimix

Les formats sont des formats papier (non optimisables au sens VoluOptimix)

ou machine (optimisables au sens VoluOptimix) selon TEN A4[17].

FORMULE_QTE_INIT

Formule de calcul pour la quantité initiale

21,23 Code phase

24,26 Code formule

27 Type de formule

Permettre d'initialiser la quantité de départ pour le calcul des gâches cumulatives grâce à une formule de calcul paramétrable.

Par défaut, la quantité de départ est calculée comme suit :

Quantité initiale = Quantité lancée de l'entité X Coefficient de nombre de feuilles

FORMULE_QTE_INIT_REF

Permettre de calculer la quantité initiale de la première ligne liée à une référence multiple pour le calcul des gâches cumulatives (une formule équivalente permet actuellement de calcul la quantité initiale globale

21,23 Code phase

24,26 Code formule

27 Type de formule

FORMULE_RECH_TARIF

Cette note a été restructurée dans la V. 4.0.182.2

Permet, dans le calcul des éléments de façonnage :

- de sélectionner le numéro de formule pour le calcul du nombre de feuilles

- de sélectionner le numéro de formule pour le calcul du poids papier ainsi que le nombre de décimales à afficher dans l'entité du sous-devis

- de sélectionner le numéro de formule pour le calcul de la quantité à passer à la recherche de tarif

21,23 Code de formule pour la recherche du prix matière (le code phase est ###, le type de formule est M).

24 Numéro de formule V1 pour le calcul du nombre de feuilles

1 Formule QT/1 (par défaut)

3 Formule QT/3

5 Formule QT/5

7 Formule QT/7

9 Formule QT/9

25 Numéro de formule V2 pour le calcul de la quantité de recherche de tarif

La quantité de recherche de tarif est calculée avec deux décimales.

2 Formule QT/2 (par défaut)

4 Formule QT/4

6 Formule QT/6

8 Formule QT/8

0 Formule QT/10

26 Numéro de formule V2 pour le calcul du poids papier de l'entité

2 Formule QT/2 (par défaut)

4 Formule QT/4

6 Formule QT/6

8 Formule QT/8

0 Formule QT/10

Remarque : La quantité de recherche de tarif est calculée avec deux décimales

27 Arrondi à appliquer pour le calcul du poids papier de l'entité

0 Aucune décimale (par défaut)

1 Une décimale

2 Deux décimales

28 Recherche automatique de tarif suite à la modification du code qualité (fle_imp.fi_c_papier)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

29 Recherche automatique de tarif suite à la modification du grammage (fle_imp.fi_grammage)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

N.B. : Ce champ n'est pas disponible dans l'écran entité de type TRFCAR (Transformateur/Carton)

30 Recherche automatique de tarif suite à la modification de l'épaisseur (fle_imp.fi_epaisseur)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

N.B. : Ce champ n'est pas disponible dans l'écran entité de type TRFCAR (Transformateur/Carton)

31 Recherche automatique de tarif suite à la modification du code fournisseur (fle_imp.fi_fournisseur)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

32 Recherche automatique de tarif suite à la modification de la largeur du papier (fle_imp.fi_lar_papier)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

33 Recherche automatique de tarif suite à la modification de la longueur du papier (fle_imp.fi_lon_papier)

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

N.B. : Ce champ n'est pas disponible dans l'écran entité de type ETIBOB (Etiquette bobine)

FOR_RECH_TAR_FOU

Permet de paramétrer une recherche de tarif spécifique lors du calcul des éléments de façonnage dans le cas d'un fournisseur imposé.

Pour info : Les caractères 21 à 27 sont identiques à ceux de la note FORMULE_RECH_TARIF.

Permet, dans le calcul des éléments de façonnage :

- de sélectionner le numéro de formule pour le calcul du nombre de feuilles

- de sélectionner le numéro de formule pour le calcul du poids papier ainsi que le nombre de décimales à afficher dans l'entité du sous-devis

- de sélectionner le numéro de formule pour le calcul de la quantité à passer à la recherche de tarif

21,23 Code de formule pour la recherche du prix matière (le code phase est ###, le type de formule est M).

24 Numéro de formule V1 pour le calcul du nombre de feuilles

1 Formule QT/1 (par défaut)

3 Formule QT/3

5 Formule QT/5

7 Formule QT/7

9 Formule QT/9

25 Numéro de formule V2 pour le calcul de la quantité de recherche de tarif

La quantité de recherche de tarif est calculée avec deux décimales.

2 Formule QT/2 (par défaut)

4 Formule QT/4

6 Formule QT/6

8 Formule QT/8

0 Formule QT/10

26 Numéro de formule V2 pour le calcul du poids papier de l'entité

2 Formule QT/2 (par défaut)

4 Formule QT/4

6 Formule QT/6

8 Formule QT/8

0 Formule QT/10

Remarque : La quantité de recherche de tarif est calculée avec deux décimales

27 Arrondi à appliquer pour le calcul du poids papier de l'entité

0 Aucune décimale (par défaut)

1 Une décimale

2 Deux décimales

28 Recherche automatique de tarif si l'option fournisseur imposé est cochée (fle_imp.fi_fou_impose) et que le code fournisseur n'est pas renseigné

Ce champ n'est disponible que dans les écrans entités de type TRFCAR (Transformateur/Carton) et BOIPLI (Boîtes pliantes).

O Recherche systématique

C Recherche sur confirmation

N Pas de recherche (par défaut)

INFOS_PHASE_REF_

17,19 Type de phase pour l'éclatement des amalgames

Avec liaison dans l'écran des références multiples, avec gestion de duplication

(1 opération créée par référence indiquée comme étant à prendre en compte).)

BRA Braille

COL Collage

DEC Découpe

DOR Dorure

FEN Fenêtrage

FOU Foulage

GAU Gaufrage

HOL Hologramme

RAI Rainage

TRF Transfert/Poudrage

VIG Vignette

Sans liaison dans l'écran des références multiples, avec gestion de duplication

&&& Type de phase générique : la duplication des opérations se fait automatiquement avec toutes les références saisies sur l'entité (1 opération créée par référence existante sur l'entité)

21,23 Code phase associée. Voir A1[22]

INIT_LIGNES_IMP

21 Initialisation des lignes d'impression (O/N, O par défaut)

Voir aussi A2[60]

Dans le devis standard, dans le cadre du multi-impression, il est possible de saisir le détail des lignes d'impression.

Lors de la création du devis, ce détail s'initialise automatiquement avec les informations de l'impression recto puis verso de l'entité.

Dans certains cas, cette initialisation est très (trop) éloignée de la réalité des impressions : on peut donc de désactiver cette initialisation.

LIB_ENT_XXXXXXXXXX

-----------------------------

LIB_ENT_CONDITION

LIB_ENT_DECOUPE

LIB_ENT_DORURE

LIB_ENT_FOULAGE

LIB_ENT_GAUFRAGE

LIB_ENT_MANUEL

LIB_ENT_NUMEROTAGE

LIB_ENT_PERFO

LIB_ENT_PERSO

LIB_ENT_TRANSFERT

-----------------------------

LIB_ENT_ADHESIF

LIB_ENT_COMPLEXE

LIB_ENT_DORSAL

LIB_ENT_FRONTAL

Saisie des devis multi-métiers - Libellés des groupes

Libellés du groupe Finitions dans l'entité étiquette bobine

Libellé de la zone Conditionnement (fle_imp.fi_conditionnement) - Par défaut : Conditionnement

Libellé de la zone Découpe (fle_imp.fi_nb_decoupe) - Par défaut : Découpe

Libellé de la zone Dorure (fle_imp.fi_dorure) - Par défaut : Dorure

Libellé de la zone Foulage (fle_imp.fi_foulage) - Par défaut : Foulage

Libellé de la zone Gaufrage (fle_imp.fi_gaufrage) - Par défaut : Gaufrage

Libellé de la zone Opérations manuelles (fle_imp.fi_manuel) - Par défaut : Opé.manuelles

Libellé de la zone Numérotage (fle_imp.fi_numerotage) - Par défaut : Numérotage

Libellé de la zone Perforation (fle_imp.fi_perfo) - Par défaut : Perforation

Libellé de la zone Perso (fle_imp.fi_perso) - Par défaut : Autre

Libellé de la zone Transfert (fle_imp.fi_transfert) - Par défaut : Poudrage

Libellés du groupe Complexe dans l'entité étiquette bobine

Libellé de la zone Adhésif - Par défaut : Adhésif

Libellé du groupe Complexe - Par défaut : Complexe

Libellé de la zone Dorsal - Par défaut : Dorsal

Libellé de la zone Frontal - Par défaut : Frontal

LIB_FORMAT_TIRAGE

21,60 Libellé pour les zones Format de tirage

Par défaut : Format de tirage

Permet de paramétrer le libellé de la zone Format de tirage sur les écrans d'entité BOIPLI, ETIBOB, ETIFEU et FEUDEP.

Remarque : Ce paramétrage est aussi utilisé pour le titre du groupe et la zone de forçage du format de tirage.

LIB_GRP_SUPPORT

21,60 Titre du groupe de données de support

LIB_LIGIMP_PC_VERNIS

21,60 Libellé de la colonne Type de vernis

Par défaut : Type de vernis

Ce paramètre est recherché en priorité dans le TPI.

LIB_LIGIMP_VERNIS

21,60 Libellé de la colonne Pourcentage de vernissage

Par défaut : % Ve.

Ce paramètre est recherché en priorité dans le TPI.

LIB_NB_REFERENCES

21, 28 Libellé pour la zone de saisie Nb de références

LIBELLE_FEFCO_ECMA

21,30 Libellé d'affichage de la zone FEFCO / ECMA pour l'écran Boîte pliante / Etiquette feuille / Etiquette bobine (adhésive)

LIBELLE_TYPE_PLI

21,28 Libellé d'affichage de la zone type de pli principal pour l'écran Feuillet/Dépliant

LIB_TYPE_FEUILLET

21,32 Libellé pour la zone de saisie du nombre de volets/morceaux/feuillets/etc.

selon le type de feuillet (défini en alpha1[31,33])

Valeurs par défaut :

COU Nb de rabats

AFF Nb morceaux

LIA Nb feuillets

INT [blanc]

Autre : Nb de volets

LIGNE_NOTE_CARTON

Ajout d'une note libre sous le champ Désignation du papier dans la fenêtre d'entité boite pliante (BOIPLI)

21,23 Code paramètre du type de note à saisir dans l'entité boite pliante BOIPLI (doit correspondre à un paramètre de type NTS)

24 Réservé

25,60 Libellé à afficher avant la zone

LISTE_TEN_AUTORISES

21,59 Liste des nouveaux types d'entités autorisés en saisie pour le TEN de l'entité en cours de modification

13 codes TEN de 3 caractères par ligne

La permission MOD/FI_TYP_ENT permet de limiter la modification du type d'entité.

Par défaut : Les types d'entités (TEN) autorisés sont ceux paramétrés sur la note équivalente au niveau du type de processus.

MAJ_CHAMP

11,60 Définition du champ à mettre à jour sous la forme suivante :

[champ]*[libellé]*[création]*[valeur]*[mise à jour]* où

[champ] : Code du champ à mettre à jour (liste des champs)

[libellé] : Libellé à afficher dans l'écran de validation de mise à jour (optionnel)

[création] : Création de la LCO sur l'entité cible avec les valeurs de la LCO source si celle-ci n'existe pas.

[valeur] : Valeur fixe

[mise à jour] : Valider par défaut la mise à jour de ce champ dans l'écran de validation

Remarque : La ligne de paramétrage doit finir par un astérisque.

Voir la note MAJ_ENTITES_IDC

MAJ_ENTITES_DEVIS

21,26 Type et code du paramètre de la configuration de mise à jour d'entités d'un même sous-devis (#CF MED)

27 Limiter la mise à jour aux entités de même type (TEN) (O/N, O par défaut)

O La mise à jour ne s'effectuera que sur les entités du sous-devis dont le type est identique à celui de l'entité de référence.

N La mise à jour peut s'effectuer sur tous les types d'entités présents dans sur le sous-devis.

28 Inutilisé

29 Ouverture de l'écran de sélection des entités similaires trouvées

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs entités sont trouvées.

N Pas d'ouverture de l'écran (sélection automatique de toutes les entités trouvées)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (mise à jour systématique de tous les champs trouvés)

Voir la note _SUP_SQL_MAJ_ENTDEV

MAJ_ENTITES_FAB

21,26 Type et code du paramètre de la configuration de mise à jour d'entités de fabrication (#CF MEF)

27 Limiter la mise à jour aux entités de même type (TEN) (O/N, O par défaut)

O La mise à jour ne s'effectuera que sur les entités des sous-devis similaires dont le type est identique à celui de l'entité de référence.

N La mise à jour peut s'effectuer sur tous les types d'entités présents dans les sous-devis similaires trouvés.

28 Limiter la mise à jour des entités de fabrication au dernier sous-devis de fabrication associé à l'article

O La mise à jour ne s'effectuera que sur le dernier sous-devis de fabrication associé au produit de l'entité de départ (par défaut)

N La mise à jour s'effectue sur toutes les entités similaires à l'entité de départ (attention, cela peut entraîner une mise à jour d'un nombre important d'entités)

29 Ouverture de l'écran de sélection des entités de fabrication similaires trouvées

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs entités similaires sont trouvées

N Pas d'ouverture de l'écran (sélection automatique de l'entité de fabrication similaire la plus récente trouvée)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (mise à jour systématique de tous les champs trouvés)

Voir la note _SUP_SQL_MAJ_ENTFAB

MAJ_ENTITES_IDC

Permettre, au niveau d'un sous-devis commercial, de mettre à jour toutes les entités à partir du dernier numéro d'entité similaire trouvée pour chacune d'elles.

Remarques :

" Par défaut, on sélectionne le dernier devis créé pour le même client/même numéro de forme.

" Si aucun numéro de forme n'est saisi sur l'entité à mettre à jour, la récupération d'informations est annulée pour cette entité.

" La récupération des informations d'entités se fait à partir des entités commerciales ou de fabrication selon le type du devis en cours de saisie :

o Appel depuis un devis de fabrication (F ou R) : Récupération des informations d'entités de fabrication similaires.
Utilisation du paramétrage MAJ_ENTITES_IDF et _SUP_SQL_MAJ_ENTIDF

o Appel depuis un devis commercial (D) : Récupération des informations d'entités commerciales similaires.
Utilisation du paramétrage MAJ_ENTITES_IDC et _SUP_SQL_MAJ_ENTIDC

Paramétrage

21,26 Type et code du paramètre de configuration de mise à jour d'entités commerciales (#CF XXX)

27 Limiter la mise à jour aux entités de même type (TEN)

O La mise à jour ne s'effectuera que sur les entités des sous-devis similaires dont le type est identique à celui de l'entité de référence (par défaut)

N La mise à jour peut s'effectuer sur tous les types d'entités présents dans les sous-devis similaires trouvés

28 Inutilisé dans ce cas

29 Ouverture de l'écran de sélection des entités commerciales similaires trouvées

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs entités similaires sont trouvées

N Pas d'ouverture de l'écran (sélection automatique de l'entité commerciales similaire la plus récente trouvée)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (mise à jour systématique de tous les champs trouvés)

MAJ_ENTITES_IDF

Permettre, au niveau d'un sous-devis de fabrication, de mettre à jour toutes les entités à partir du dernier numéro d'entité similaire trouvé pour chacune d'elles.

Remarques

" Par défaut, on sélectionne le dernier devis créé pour le même client/même numéro de forme.

" Si aucun numéro de forme n'est saisi sur l'entité à mettre à jour, on sélectionne le devis renseigné sur l'affiche (mp_devis, mp_sdevis, mp_entite)

Paramétrage

21,26 Type et code du paramètre de configuration de mise à jour d'entités de fabrication (#CF MEF)

27 Limiter la mise à jour aux entités de même type (TEN)

O La mise à jour ne s'effectuera que sur les entités des sous-devis similaires dont le type est identique à celui de l'entité de référence (par défaut).

N La mise à jour peut s'effectuer sur tous les types d'entités présents dans les sous-devis similaires trouvés.

28 Limiter la mise à jour des entités de fabrication au dernier sous-devis de fabrication associé à l'article

O La mise à jour ne s'effectuera que sur le dernier sous-devis de fabrication associé au produit de l'entité de départ (par défaut)

N La mise à jour s'effectue sur toutes les entités similaires à l'entité de départ (attention, cela peut entraîner une mise à jour d'un nombre important d'entités)

29 Ouverture de l'écran de sélection des entités de fabrication similaires trouvées

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs entités similaires sont trouvées

N Pas d'ouverture de l'écran (sélection automatique de l'entité de fabrication similaire la plus récente trouvée)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (mise à jour systématique de tous les champs trouvés)

Voir la note _SUP_SQL_MAJ_ENTIDF ainsi que USE A3[53]

MAJ_ENTITES_VARQTE

Mise à jour d'informations des sous-devis et entités des variantes de quantité

Explications dans la note MAJ_SDEVIS_DEVIS du TPR

Voir aussi la note _SUP_SQL_MAJ_VARQTE ci-dessous

21,26 Type et code du paramètre de configuration de mise à jour de l'entité courante vers les autres sous-devis d'un même devis (variantes de quantité) (#CF MED)

27,28 Inutilisés

29 Ouverture de l'écran de sélection des entités à mettre à jour

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs sous-devis sont trouvés

N Pas d'ouverture de l'écran (sélection automatique de toutes les entités trouvées)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (sélection automatique de tous les champs trouvés)

MAJ_ZONES_DEF_OUTIL

21 Initialiser les zones par défaut à partir du code outil (voir liste ci-dessus)

O Les zones par défaut sont initialisées à partir du code outil (par défaut)

N Les zones par défaut ne sont pas initialisées.
L'initialisation à partir du code outil se fera uniquement sur les zones définies dans la note MAJ_ZONE_LIEE_OUTIL ci-dessous.

MAJ_ZONE_LIEE_OUTIL

Permettre d'initialiser des zones sur l'entité à partir de données saisies sur le code outil : fiche article ou informations complémentaires (TSC)

Voir aussi : TEN A2[26]

21,60 Paramétrage sous la forme [Zone cible]*[Zone source]*[Début]*[Fin]* avec :

[Zone cible] : Zone cible sur l'entité : une zone de la table fle_imp.

Par défaut, les zones suivantes sont mises à jour sur les entités boîte pliante (BOIPLI) et transformateur carton (TRFCAR) :

fi_lon_fini, fi_lar_fini, fi_hau_fini, fi_pli_dblc, fi_fini_dblc, fi_nb_poses, fi_lar_tir, fi_lon_tir, fi_lon_ouv, fi_lar_ouv

Voir le détail ici.

[Zone source] : Zone source sur le code outil : une zone de la table mat ou bien un TSC

[Début] : Caractère de début

[Fin] : Caractère de fin

Par défaut, le caractère de fin est égal au caractère de début si ce dernier est renseigné (idem si le caractère de fin est inférieur au caractère de début)

Exemples

MAJ_ZONE_LIEE_OUTIL fi_num_plan_cao*TSC_MP_AA_TU1_G*

Mettre à jour la zone d'entité fi_num_plan_cao (numéro d'étude) avec la valeur de la zone de 30 caractères du TSC TU1 saisie sur le code outil.

MAJ_ZONE_LIEE_OUTIL fi_num_plan_cao*mp_code*6*10*

Mettre à jour la zone d'entité fi_num_plan_cao (numéro d'étude) avec les caractères 6 à 10 du code outil.

MAJ_ZONE_LIEE_OUTIL fi_forcage_format*TSC_MP_AA_FOR_F*1*

Mettre à jour la zone d'entité fi_forcage_format (forçage du format ouvert) avec le premier caractère de la valeur de la première zone de 3 caractères de la TSC FOR saisie sur le code outil.

MASQUE_XXXXXXXXXX

MASQUE_CONDITION

MASQUE_FINITIONS

MASQUE_IMPRESSION

MASQUE_PRE_PRESSE

21 Masquer les groupes de champs

Masquer le groupe de champs Conditionnement (O/N, N par défaut)

Masquer le groupe de champs Finitions (O/N, N par défaut)

Masquer le groupe de champs Impression (O/N, N par défaut)

Masquer le groupe de champs Pré-presse (O/N, N par défaut)

MASQUE_NIVDET_LCO

21 Masquer l'onglet de saisie des LCO sur la saisie des lignes de nomenclature associées à ce type d'entité (O/N, N par défaut)

MODE_GESTION_DEF

21,23 Mode de gestion par défaut (type paramètre associé : .MG)

Uniquement pour le devis_standard (la même note existe sur le TPR, mais elle est réservée au devis_tc).

Intégration du devis TC dans le devis multi-métiers - GENERO uniquement

NATURE_TRANSPORT_

Initialisation de la nature de transport avec un code calcul

18 Type de transport

C Transport client

I Transport interne

21,22 Code dépendance

23,29 Paramétrage de la dépendance

OPE_OPE_

OPE_OPE_REP_RECTO

OPE_OPE_REP_VERSO

OPE_OPE_REF_AP_CAL

OPE_OPE_REF_AP_ROU

Prise en compte des changements de plaque en repiquages dans le devis optimisé et dans le devis manuel multi-métiers

9,20 REP_RECTO : Opération de changement de plaques en repiquage recto

REP_VERSO : Opération de changement de plaques en repiquage verso

REF_AP_CAL : Refente après impression/calage

REF_AP_ROU :Refente après impression/roulage

21,23 Code section

24,26 Code opération

27,29 Code sous-opération

30,32 Code difficulté

33,38 Code machine

39,48 Option sur l'optimisation de l'opération standard

40 Calcul du nombre de coupes (pour les refentes après impression) - Voir les formules OMAD50 et OMAD51
O Le nombre de coupes est calculé automatiquement et forcé à 1 si la valeur calculée est égal à 0.
N Le nombre de coupes est calculé automatiquement (par défaut)

Voir les formules de calcul suivantes :

O IMF 74

O IMF 75

M IMF 7

OPERAT_MARGE_AUTO

21,29 Triplet de l'opération standard de recherche de la marge commerciale automatique

Par défaut : MAR #MA COM

21,23 Code opération

24,26 Code section

27,29 Code sous-opération

OPT_OPE_

Paramétrage des codes opérations standards utilisés dans l'optimisation

21,23 Code section

24,26 Code opération

27,29 Code sous-opération

30,32 Code difficulté

33,38 Code machine

39,48 Option sur l'optimisation de l'opération standard

Voir le détail de cette note dans tableau séparé plus bas.

OUVERTURE_TEN_CALCUL

21,23 Code phase à calculer à l'ouverture de l'écran d'entité

PHOTO_INFOS_LCO_

Pour la photogravure (voir la note CODE_ECRAN_ENTITE avec le code PHOGRA)

17,19 Numéro de ligne (100 lignes maximum)

21,23 Code LCO saisi dans la colonne n°1

24,24 Zone LCO correspondante

26,28 Code LCO saisi dans la colonne n°2

29,29 Zone LCO correspondante

31,33 Code LCO saisi dans la colonne n°3

34,34 Zone LCO correspondante

36,38 Code LCO saisi dans la colonne n°4

39,39 Zone LCO correspondante

41,43 Code LCO saisi dans la colonne n°5

44,44 Zone LCO correspondante

46,48 Code LCO saisi dans la colonne n°6

49,49 Zone LCO correspondante

51,53 Code LCO saisi dans la colonne n°7

54,54 Zone LCO correspondante

56,58 Code LCO saisi dans la colonne n°8

59,59 Zone LCO correspondante

PHOTO_TITRE_COL_

Pour la photogravure

17, 19 Numéro de colonne (8 colonnes maximum)

21, 26 Titre de la colonne

PHOTO_TITRE_LIG_

Pour la photogravure

17,19 Numéro de ligne (100 lignes maximum)

21,40 Titre de la ligne

REC_MACHINE_

REC_MACHINE_ASS_COU

REC_MACHINE_ASSEMB

REC_MACHINE_BCO

REC_MACHINE_CASSAGE

REC_MACHINE_COLLE

REC_MACHINE_COUTUR

REC_MACHINE_COUV

REC_MACHINE_EMB_HL

REC_MACHINE_GARDE

REC_MACHINE_JAQUETTE

REC_MACHINE_MASSIC

REC_MACHINE_PIQURE

REC_MACHINE_PLIEUSE

REC_MACHINE_RECTO

REC_MACHINE_RELIURE

REC_MACHINE_VERSO

Formule de recherche automatique de machine - GENERO

21,23 Code phase (par défaut : #CM)

24,26 Code formule (par défaut : en fonction de la machine, voir tableau ci-dessous)

27 Afficher la fenêtre de sélection pour ce type de machine (O/N, O par défaut)
#CF OPT A1[22] est prioritaire.

machine d'assemblage + couture (formule par défaut ASC)

machine d'assemblage (formule par défaut ASS)

machine de brochure cousue (formule par défaut BCO)

machines de cassage (formule par défaut CAS)

machine recto (formule par défaut SCO)

machines de couture (formule par défaut COU)

couverturière (formule par défaut CVC)

machine d'emballage hors-ligne (formule par défaut EHL)

machines nécessaires au façonnage des gardes (formule par défaut GAR)

machines nécessaires au façonnage des jaquettes (formule par défaut JAQ)

massicoteuse (formule par défaut MAS)

machine encarteuse / piqueuse (formule par défaut : PIQ)

machine plieuse (formule par défaut PLI)

machine recto (formule par défaut IMR)

relieuse (formule par défaut REL)

machine verso (formule par défaut IMV)

REP_ETUDES_ARTIOS

Emplacement du répertoire (Windows) contenant les études ARTIOS

Cette note est prioritaire sur celle de G_devis_standard.

_SUP_REQ_ADHESIF

Complément de sélection pour la recherche de code de support adhésif

(Ex : and mp_code matches "XA*")

_SUP_REQ_FEFCO_ECMA

21,60 Complément de sélection pour la recherche des FEFCO / ECMA, selon le type d'entité

_SUP_REQ_PLI

Complément de sélection pour la recherche des plis dans l'optimisation

Dans l'optimisation, ce paramètre permet de sélectionner certains types de pli par type d'entité : cela évite d'avoir des types de plis feuillet pour un intérieur, par exemple.

Exemple : and p2_code != "CR"

_SUP_REQ_DORSAL

Complément de sélection pour la recherche de code de support dorsal

(Ex : and mp_code matches "XD*")

_SUP_REQ_FOURNISSEUR

Complément de sélection pour la recherche des fournisseurs (Entités)

_SUP_REQ_FRONTAL

Complément de sélection pour la recherche de code de support frontal

(Ex : and mp_code matches "XF*")

_SUP_REQ_GRAMMAGE

Complément de sélection pour la recherche de grammage

(Ex : and mpg_langue = "FR")

_SUP_REQ_MAC_IMP

Complément de sélection pour la recherche de machine d'impression

(Ex : and m0_ccout matches "F*")

_SUP_REQ_MAC_OUTIL

21,60 Complément de sélection pour la recherche des machines liées aux outils

La même note existe sur G_mat.

_SUP_REQ_MAC_VHL

21,60 Complément de sélection des machines de vernissage hors-ligne (table mac0)

_SUP_REQ_OUTIL

Complément de sélection pour la recherche d'outil

(Ex : and mp_mp = "O")

_SUP_REQ_PAPIER

Complément de sélection pour la recherche de code papier

(Ex : and mp_code matches "XP*")

_SUP_REQ_PROD_NOM

21,60 Complément de sélection sur le F7 des champs niv_composant et de_produit de la fenêtre de saisie de la nomenclature

Exemple

_SUP_REQ_PROD_NOM and mp_code like 'PF041%'

_SUP_REQ_RECH_LIEN

21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

_SUP_SQL_MAJ_ENTDEV

21,60 Complément de sélection des entités à mettre à jour (fle_imp)

Ce complément est utilisé par la note MAJ_ENTITES_DEVIS.

_SUP_SQL_MAJ_ENTFAB

21,60 Complément de sélection des sous-devis/entités à mettre à jour (fle_2 et/ou fle_imp)

Ce complément est utilisé par la note MAJ_ENTITES_FAB.

_SUP_SQL_MAJ_ENTIDC

21,60 Complément de sélection des entités commerciales similaires (fle_2 et/ou fle_imp)

_SUP_SQL_MAJ_ENTIDF

21,60 Complément de sélection des entités de fabrication similaires (fle_2 et/ou fle_imp)

_SUP_SQL_MAJ_VARQTE

21,60 Complément de sélection des entités à mettre à jour (fle_imp)

A utiliser en complément de la note MAJ_ENTITES_VARQTE ci-dessus.

_SUP_SQL_PROD_ENT

21,60 Complément de sélection sur la fiche matière (mat)

Le produit saisi sur l'entité devra exister dans la table mat en tenant compte de ce complément de recherche.

Exemple

and mp_code matches "AF*"

_SURF_MINI_MODE_REAP

21,30 Surface minimum en dessous de laquelle le mode de réapprovisionnement est automatiquement passé à S

Voir TSC 203 ( ic_num2)

TITRE_ECRAN_BANDES

Titre de l'écran multi-bandes

TITRE_ECRAN_DECOMPO

Titre de l'écran de saisie de la décomposition

TITRE_ECRAN_ENTITE

21,60 Titre de l'écran spécifique d'entité - Voir aussi la note CODE_ECRAN_ENTITE

TRT_MAC_DECOUPE

NON UTILISE

Pour chacun des 3 caractères, les valeurs possibles sont O, N (N par défaut)

21 Recherche automatique des machines de découpe

22 Si aucune machine n'est trouvée, afficher un message d'avertissement.

23 Si plusieurs machines sont trouvées, ouvrir l'écran de choix des machines

TRT_MAC_IMP_RECTO

Pour chacun des 3 caractères, les valeurs possibles sont O, N (N par défaut)

21 Recherche automatique des machines d'impression recto

22 Si aucune machine n'est trouvée, afficher un message d'avertissement.

23 Si plusieurs machines sont trouvées, ouvrir l'écran de choix des machines

TRT_MAC_IMP_VERSO

Pour chacun des 3 caractères, les valeurs possibles sont O, N (N par défaut)

21 Recherche automatique des machines d'impression verso

22 Si aucune machine n'est trouvée, afficher un message d'avertissement.

23 Si plusieurs machines sont trouvées, ouvrir l'écran de choix des machines

TRT_MAC_PLIAGE

NON UTILISE

Pour chacun des 3 caractères, les valeurs possibles sont O, N (N par défaut)

21 Recherche automatique des machines de pliage

22 Si aucune machine n'est trouvée, afficher un message d'avertissement.

23 Si plusieurs machines sont trouvées, ouvrir l'écran de choix des machines

TYPE_PALETTE_DEF

21,23 Type de palette par défaut (type paramètre associé : .TP)

Uniquement pour le devis_standard (la même note existe sur le TPR, mais elle est réservée au devis_tc).

Intégration du devis TC dans le devis multi-métiers - GENERO uniquement

USING_FORMAT_B_RIVE

21,33 Paramétrage du format d'affichage pour la zone de bord de rive (fi_bord_min)

Champ d'application du paramétrage : ETIBOB

USING_FORMAT_EPAIS

21,33 Paramétrage du format d'affichage pour la zone d'épaisseur du support (fi_epaisseur)

Champ d'application du paramétrage : ETIBOB

USING_FORMAT_ESPACE

Paramétrage des formats d'affichage pour les zones d'espace (fi_fini_dblc, fi_fini_dblc_min)

Champ d'application du paramétrage : ETIBOB

21,33 Format d'affichage de la zone d'espace entre étiquettes (sens laize)

34,46 Format d'affichage de la zone d'espace avance

USING_FORMAT_FINI

Paramétrage des formats d'affichage pour les zones de dimensions

Dans le devis multi-métiers, permet de paramétrer les formats d'affichage (using) pour les zones de dimensions des écrans de saisie des :

" Références multiples sur l'entité (REFLIG/ENTITE)

" Entité Boîte pliante (BOIPLI)

" Entité Etiquette bobine (ETIBOB)

" Entité Etiquette feuille (ETIFEU)

" Entité Feuillet/Dépliant (FEUDEP)

" Entité Transformateur carton (TRFCAR)

21,33 Format d'affichage de la zone de dimension de format fini A

34,46 Format d'affichage de la zone de dimension de format fini B

47,59 Format d'affichage de la zone de dimension de format fini H (non applicable aux étiquettes)

Ce paramétrage a priorité sur celui du TPR.

Si aucun format d'affichage n'est paramétré, le système utilise le format permettant l'affichage de la valeur maximum.

Exemple pour une zone décimale 8,2 : 999999.99

USING_FORMAT_OUVERT

Paramétrage des formats d'affichage pour les zones de dimensions

21,33 Format d'affichage de la zone de dimension de format ouvert (hors-tout) A

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR

34,46 Format d'affichage de la zone de dimension de format ouvert (hors-tout) B

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR

USING_FORMAT_PAPIER

Paramétrage des formats d'affichage pour les zones de dimensions

21,33 Format d'affichage de la zone de dimension de format papier A

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR, ETIBOB, ETIFEU

34,46 Format d'affichage de la zone de dimension de format papier B

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR, ETIFEU

USING_FORMAT_TIRAGE

Paramétrage des formats d'affichage pour les zones de dimensions

21,33 Format d'affichage de la zone de dimension de format de tirage A

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR

34,46 Format d'affichage de la zone de dimension de format de tirage B

Champ d'application du paramétrage : BOIPLI, FEUDEP, TRFCAR

VERIF_VAL_FORMULE

Permettre de lancer des vérifications après la saisie d'un champ.

21,38 Nom du champ après lequel faire un contrôle paramétré sur une formule.

Voir le paragraphe concerné dans le devis standard.

39,41 Code phase (de la formule de contrôle)

42,44 Code formule (de la formule de contrôle)

45 Type de contrôle

W Contrôle non bloquant

B Contrôle bloquant

N Pas de contrôle

Par défaut : on garde le fonctionnement actuel (Formule de contrôle, zone CAD/2, caractère 1).

Fin des notes triées

Zones actives pour les activations / désactivations de phases (notes ACTIVATION_PHASE)

Les zones sont triées par ordre alphabétique.

Un tableau similaire existe aussi pour les LCO.

Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
fi_accessoires | Présence d'accessoires | l | l |  | l | l
fi_cgt_r | Nombre de changements de plaque au recto | l | l | l | l |
fi_cgt_v | Nombre de changements de plaque au verso | l | l | l | l |
fi_cgt_r_r | Nombre de repiquages au recto |  | l |  |  |
fi_cgt_v_r | Nombre de repiquages au verso |  | l |  |  |
fi_cgt_teinte_r | Nombre de changements de teinte au recto | l | l | l | l |
fi_cgt_teinte_v | Nombre de changements de teinte au verso | l | l | l | l |
fi_collage | Présence de collage | l |  |  |  |
fi_conditionnement | Présence de conditionnement |  |  | l | l |
fi_contre_collage | Présence de contre-collage | l |  |  |  | l
fi_co_recto | Nombre de couleurs au recto | l | l | l | l |
fi_co_verso | Nombre de couleurs au verso | l | l | l | l |
fi_dorure | Présence de dorure | l | l | l | l |
fi_equerre | Présence d'équerrage/massicot | l | l |  |  | l
fi_fenetrage | Présence de fenêtrage | l |  |  |  |
fi_foulage | Présence de foulage |  | l | l | l |
fi_gaufrage | Présence de gaufrage | l | l | l | l |
fi_jonction | Présence de jonctionnement |  |  |  |  | l
fi_manuel | Présence d'opérations manuelles | l |  | l | l | l
fi_nb_decoupe | Présence de découpe | l | l | l | l |
fi_numerotage | Présence de numérotage |  | l | l | l |
fi_pap_stk | Mode de réapprovisionnement | l |  |  |  |
fi_perfo | Présence de perforation |  | l | l | l |
fi_perso | Autres (personnalisation) | l | l | l | l | l
fi_pliage_mach | Présence de pliage machine |  | l |  |  |
fi_pres_vernis_hl | Présence de vernis hors ligne |  | l |  | l |
fi_rainage | Présence de rainage |  | l |  |  |
fi_transfert | Présence de poudrage |  | l | l | l |
fi_type_pellic | Type de pelliculage | l | l | l | l |
fi_type_pre_presse | Type de pré-presse | l | l |  | l |
fi_type_verso | Type d'impression verso |  |  | l |  |
fi_vernis_hl | Type de vernis hors ligne | l |  | l | l |
fi_zpar | Type d'imposition | l |  |  |  |
outil_valide | Validité de l'outil | l |  | l | l | l
presence_outil | Présence de l'outil | l |  | l | l | l

Validité de l'outil (0 Qualité de l'outil non valide, 1 Qualité de l'outil valide)

Présence de l'outil (0 non saisi ou générique, 1 saisi et non générique)

Zones actives pour les phases contextuelles (notes CONTEXTE_PHASE)

Les zones sont triées par ordre alphabétique.

Un tableau similaire existe aussi pour les LCO.

Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU | TRFCAR
fi_accessoires | Présence d'accessoires | l | l |  |  | l
fi_bat | Présence de bon à tirer | l | l | l | l |
fi_cgt_r | Nombre de changements de plaque au recto | l | l | l | l |
fi_cgt_v | Nombre de changements de plaque au verso | l | l | l | l |
fi_cgt_r_r | Nombre de repiquage au recto |  | l |  |  |
fi_cgt_v_r | Nombre de repiquage au verso |  | l |  |  |
fi_cgt_teinte_r | Nombre de changements de teintes au recto | l | l | l | l |
fi_cgt_teinte_v | Nombre de changements de teintes au verso | l | l | l | l |
fi_collage | Présence de collage | l |  |  |  |
fi_contre_collage | Présence de contre-collage | l |  |  |  | l
fi_dorure | Présence de dorure | l | l | l | l |
fi_epreuve | Epreuve | l | l | l | l |
fi_equerre | Présence de massicot/équerrage | l | l |  |  | l
fi_fenetrage | Présence de fenêtrage | l |  |  |  |
fi_gaufrage | Présence de gaufrage | l | l | l | l |
fi_jonction | Présence de jonctionnement |  |  |  |  | l
fi_mac_forcee_r | Forçage de la machine recto | l | l | l | l |
fi_mac_forcee_v | Forçage de la machine verso | l | l | l | l |
fi_manuel | Présence d'opérations manuelles | l |  | l | l | l
fi_maquette | Maquette | l | l | l | l |
fi_nb_decoupe | Présence de découpe | l | l | l | l |
fi_ozalids | Nombre d'ozalids à fournir au client | l | l | l | l |
fi_pap_stk | Mode de réapprovisionnement | l |  |  |  |
fi_perso | Autres (personnalisation) | l | l | l | l | l
fi_photocompo | Photocomposition | l | l | l | l |
fi_photogravure | Photogravure | l | l | l | l |
fi_type_pellic | Type de pelliculage | l | l | l | l |
fi_type_pre_presse | Type de pré-presse | l | l | l | l |
fi_type_verso | Type d'impression verso |  |  | l |  |
fi_typons | Eléments fournis | l |  |  |  |
fi_vernis_hl | Type de vernis hors-ligne | l |  | l | l |
fi_zpar | Type d'imposition | l |  |  |  |

Zones actives pour l'ouverture contextuelle du détail couleurs (notes CONTEXTE_DETAIL_COU)

Les zones sont triées par ordre alphabétique.

Un tableau similaire existe aussi pour les LCO.

Zone | Libellé | BOIPLI | FEUDEP | ETIBOB | ETIFEU
fi_bascule | Type de bascule |  | l |  |
fi_cgt_r | Nombre de changement de plaques au recto | l | l | l | l
fi_cgt_teinte_r | Nombre de changement de teintes au recto | l | l | l | l
fi_cgt_teinte_v | Nombre de changement de teintes au verso | l | l | l | l
fi_cgt_v | Nombre de changement de plaques au verso | l | l | l | l
fi_co_recto | Nombre de couleurs recto | l | l | l | l
fi_co_verso | Nombre de couleurs verso | l | l | l | l
fi_enc_r | Coefficient d'encrage au recto | l | l | l | l
fi_enc_v | Coefficient d'encrage au verso | l | l | l | l
fi_mac_imp | Machine d'impression au recto | l | l | l | l
fi_mac_imp2 | Machine d'impression au verso | l | l | l | l
fi_nb_cl_commune | Nombre de couleurs communes entre le recto et le verso | l | l | l | l
fi_nb_teintes_r | Nombre de recherche de teintes au recto | l | l | l | l
fi_nb_teintes_v | Nombre de recherche de teintes au verso | l | l | l | l
fi_quadri_r | Présence de quadrichromie au recto | l | l | l | l
fi_type_vernis_r | Type de vernis au recto | l | l | l | l
fi_type_vernis_v | Type de vernis au verso | l | l | l | l
fi_type_verso | Type de verso |  |  | l |
fi_ve_recto | Coefficient de vernissage au recto | l | l | l | l
fi_ve_verso | Coefficient de vernissage au verso | l | l | l | l

Liste des opérations prises en compte dans les notes commençant par OPT_OPE_

Rappel du paramétrage de ces notes :

21,23 Code section

24,26 Code opération

27,29 Code sous-opération

30,32 Code difficulté

33,38 Code machine

39,48 Option sur l'optimisation de l'opération standard

Cette nouvelle option sera commune à toutes les opérations standards mais pour l'instant seules certaines opérations sont concernées.

Dans le tableau ci-dessous, cliquez sur les liens pour afficher le paramétrage.

Pour l'instant, seul le caractère 39 est utilisé. Les caractères 40 à 48 sont réservés à des extensions futures.

OPERATION | PHASE | Note |
Équerrage | Calage | OPT_OPE_EQUERRE_CAL |
 | Roulage | OPT_OPE_EQUERRE_ROU |
Impression | Calage | OPT_OPE_CAL_RECTO | OPT_OPE_CAL_VERSO
 | Changement de plaque | OPT_OPE_CHA_RECTO | OPT_OPE_CHA_VERSO
 | Lavage | OPT_OPE_LAV_RECTO | OPT_OPE_LAV_VERSO
 | Réglage | OPT_OPE_REG_RECTO | OPT_OPE_REG_VERSO
 | Roulage | OPT_OPE_ROU_RECTO | OPT_OPE_ROU_VERSO
 | Séchage | OPT_OPE_TPS_SECHAGE |
 | Recherche de teintes | OPT_OPE_REC_TEINTES |
Platine de découpe | Calage | OPT_OPE_PLATINE_CAL |
 | calage par poses | OPT_OPE_PLATINE_POS |
 | Roulage | OPT_OPE_PLATINE_ROU |
Pliage | Calage | OPT_OPE_PLIAGE_CAL |
 | Roulage | OPT_OPE_PLIAGE_ROU |
Pliage manuel |  | OPT_OPE_PLI_MANUEL |
Pré-presse | Copie de plaque CTP | OPT_OPE_CTP_RECTO | OPT_OPE_CTP_VERSO
 | Copie de plaque traditionnelle | OPT_OPE_PLA_RECTO | OPT_OPE_PLA_VERSO
 | Traceur CTP | OPT_OPE_TRACEUR |
Rainage / typo de la couverture | Calage | OPT_OPE_TYPO_CAL |
 | Roulage | OPT_OPE_TYPO_ROU |
Refente après impression | Calage | OPT_OPE_REF_AP_CAL |
 | Roulage | OPT_OPE_REF_AP_ROU | Car. 39 : La qté à refendre est le nombre de feuilles (équivalent à OMAD51 car.4)
Refente avant impression | Calage | OPT_OPE_REF_AV_CAL |
 | Roulage | OPT_OPE_REF_AV_ROU | Car. 39 : La qté à refendre est le nombre de feuilles (équivalent à OMAD51 car.4)
Refente avant impression rotative, tronçonnage de bobines |  | OPT_OPE_TRONCONNAGE |
Vernis | Calage | OPT_OPE_VHC_RECTO | OPT_OPE_VHC_VERSO
 | Lavage | OPT_OPE_VHL_RECTO | OPT_OPE_VHL_VERSO
 | Réglage | OPT_OPE_VHE_RECTO | OPT_OPE_VHE_VERSO
 | Roulage | OPT_OPE_VHR_RECTO | OPT_OPE_VHR_VERSO

Zones actives pour les Types de note selon le contexte (notes CONTEXTE_TYPE_NOTE)

Les zones sont triées par ordre alphabétique.

elements_fournis | Eléments fournis
fi_accessoires | Présence d'accessoires
fi_bat | Client au bon à rouler
fi_c_papier | Code papier
fi_cgt_r | Nombre de changements de plaques au recto
fi_cgt_teinte_r | Nombre de changements de teintes au recto
fi_cgt_teinte_v | Nombre de changements de teintes au verso
fi_cgt_v | Nombre de changements de plaques au verso
fi_co_recto | Nombre de couleurs recto
fi_co_verso | Nombre de couleurs verso
fi_collage | Présence de collage
fi_contre_collage | Présence de contre-collage
fi_couleur_pap | Couleur du support
fi_d_papier | Désignation du papier
fi_dorure | Présence de dorure
fi_ecma | Code ECMA
fi_enc_r | Pourcentage d'encrage au recto
fi_enc_v | Pourcentage d'encrage au verso
fi_epaisseur | Epaisseur du support
fi_epreuve | Epreuve
fi_equerre | Présence de massicot
fi_fenetrage | Présence de fenêtrage
fi_fini_dblc | Espacement des poses (Fonds perdus Y)
fi_forcage_format | Format ouvert forcé
fi_forcage_nbp | Forçage du nombre de poses
fi_fou_impose | Fournisseur imposé
fi_fournisseur | Code fournisseur
fi_ft_impo | Format de tirage imposé
fi_gaufrage | Présence de gaufrage
fi_grammage | Grammage du papier
fi_hau_fini | Hauteur unitaire de la boîte
fi_lar_fini | Largeur unitaire de la boîte
fi_lar_ouv | Largeur du format ouvert
fi_lar_tir | Format de tirage sens machine
fi_lon_fini | Longueur unitaire de la boîte
fi_lon_ouv | Longueur du format ouvert
fi_lon_tir | Format de tirage sens travers
fi_mac_forcee_r | Machine d'impression recto forcée
fi_mac_forcee_v | Machine d'impression verso forcée
fi_mac_imp | Machine d'impression recto
fi_mac_imp2 | Machine d'impression verso
fi_manuel | Présence d'opérations manuelles
fi_maquette | Maquette
fi_mode_tirage | Mode de tirage
fi_nb_cl_commune | Nombre de couleurs communes entre recto et verso
fi_nb_decoupe | Présence de découpe
fi_nb_poses | Nombre de poses
fi_nb_references | Nombre de références
fi_nb_teintes_r | Nombre de recherche de teintes au recto
fi_nb_teintes_v | Nombre de recherche de teintes au verso
fi_num_forme | Code outil
fi_num_plan_cao | Numéro d'étude
fi_ozalids | Nombre d'ozalids à fournir au client
fi_p_papier | Prix du papier
fi_pap_bloque | Prix du papier bloqué
fi_pap_stk | Mode de réapprovisionnement
fi_perso | Autre
fi_photocompo | Photocomposition
fi_photogravure | Photogravure
fi_pli_dblc | Espacement des poses (Fonds perdus X)
fi_quadri_r | Présence de quadrichromie au recto
fi_quadri_v | Présence de quadrichromie au verso
fi_resp_sens_pap | Respect du sens papier
fi_type_dimension | Nature des côtés
fi_type_imbric | Type d'imbrication
fi_type_pellic | Type de pelliculage
fi_type_pre_presse | Type de pré-presse
fi_type_vernis_r | Type de vernis recto
fi_type_vernis_v | Type de vernis verso
fi_ve_recto | Pourcentage de vernissage au recto
fi_ve_verso | Pourcentage de vernissage au verso
fi_vernis_hl | Type de vernis hors-ligne
fi_zpar | Type d'imposition
lm_ex_par_paq | Nombre d'exemplaires par paquet
lm_nb_cai | Nombre de caisses
lm_nb_pal | Nombre de palettes
lm_nb_paq | Nombre de paquets
lm_poids_cai | Poids de la caisse (en Kg)
lm_poids_pal | Poids de la palette (en Kg)
sai_format_1 | Largeur du papier
sai_format_2 | Longueur du papier


TES Type estampille

Valeur alpha 1

TES A1[1]

Blocage laboratoire (O/N, N par défaut)

Notes

CODE_QUALITE_DEVIS

21,23 Code qualité pour initialiser le code qualité des écrans d'architecture

La même note existe sur le paramètre FAM. Voir cette note pour plus d'explication.


TFA Type de frais

Valeur alpha 1

TFA A1[1]

Type d'application du type de frais

1 Chargement

2 Déchargement

X Autres

TFA A1[2]

Frais systématique ou facultatif

S Systématique (par défaut)

F facultatif

Les frais accessoires sont facultatifs. Lors de la valorisation des tarifs pour un affrètement, on demande pour chaque frais accessoire facultatif si on veut le prendre en compte.

Si oui, on enregistre le type de frais dans un TSC de l'affrètement dont on indique la racine dans #CF LOG alpha1[17,18].

Notes

Par défaut, lors du calcul du coût du transport dans la préparation des affrètements, tous les types de frais (TFA/xxx) sont pris en compte et l’utilisateur a une demande de confirmation s’il doit ou non l’inclure dans le calcul.

L’utilisateur pouvait avoir des demandes de confirmations inutiles.

Avec ce nouveau paramétrage, il est possible de conditionner l’application du tarif selon différents critères (département, pays, mode de transport, etc.)

CONTROLE_APPLI_DEP | Condition pour appliquer ce type de tarif par rapport au département. (note cumulative) 21,59 Codes paramètres DEP. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_PAY | Condition pour appliquer ce type de tarif par rapport au pays. (note cumulative) 21,59 Codes paramètres PAY. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_TRS | Condition pour appliquer ce type de tarif par rapport au type de transport. (note cumulative) 21,59 Codes paramètres TRS. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_TVE | Condition pour appliquer ce type de tarif par rapport au type de véhicule. (note cumulative) 21,59 Codes paramètres TVE. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_GEO | Condition pour appliquer ce type de tarif par rapport au secteur géographique. (note cumulative) 21,59 Codes paramètres GEO. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_POR | Condition pour appliquer ce type de tarif par rapport au type de port. (note cumulative) 21,59 Codes paramètres POR. Possibilité d'indiquer 13 codes de 3 caractères chacun.
CONTROLE_APPLI_CDZ | Condition pour appliquer ce type de tarif par rapport à la zone tarifaire. (note cumulative) 21,56 Possibilité d'indiquer 6 zones tarifaires de 6 caractères chacune.

Exemples

CONTROLE_APPLI_DEP 38

CONTROLE_APPLI_PAY FR

CONTROLE_APPLI_TRS CAM

CONTROLE_APPLI_TVE SR


TFE Type de façonnage d'encart

Ce paramètre est utilisé dans le devis optimisé.

Valeur alpha 1

TFE A1[1,3] | Type de façonnage d'encart (obligatoire) P-C Pré-piqué et collé machine P-P Pré-piqué et piqué C Collé machine sur un des cahiers A Assemblé P Encarté piqué (dépliant sur piqûre) P-M Pré-piqué et collé manuellement
TFE A1[4] | Type d'encart associé à ce type de façonnage R Type de façonnage spécifique à l'encart rapporté J Type de façonnage spécifique à l'encart jeté [blanc] Type de façonnage autorisé pour tout type d'encart (par défaut)
TFE A1[5 | Position de l'encart rapporté dans l'ouvrage C Centré (coming & going possible) autre Décentré (coming & going impossible)

Voir aussi

#LI | Liens entre les paramètres TPR et TFE #LI A3[1,18] Nom de la table mère : par02 #LI A3[19,21]Type de paramètre associé : TPR (Type de processus) #LI A4[1,18] Nom de la table fille: par02 #LI A4[19,21]Type de paramètre associé : TFE (Type de façonnage d'encart)
TPR | Note CODE_LIEN_TPR_TFE


TGB Types de gardes blanches

Valeur alpha 1

TGB A1[1,15]

Code garde blanche à utiliser

Le code saisi doit figurer dans le fichier des matières.

Valeur alpha 2

TGB A2[1,3]

Code indiquant le type de garde

Ce code sera utilisé comme dépendance pour l'opération de collage des gardes.

Exemples

ONG (gardes en onglet)

PLA (gardes à plat)


TGC Types de gardes couleurs

Valeur alpha 1

TGC A1[1,15] | Code garde couleur à utiliser Ce code doit évidemment figurer dans le fichier des matières
TGC A1[20] | Autorise la modification du code garde feuille

Valeur alpha 2

TGC A2[1,3]

Code indiquant le type de garde

Ce code sera utilisé comme dépendance pour l'opération de collage des gardes

Exemples

ONG (gardes en onglet)

PLA (gardes à plat)

Valeur alpha 3

TGC A3[1,60]

Si l'option 14 définie sur le paramètre #CFDRE est activée (recherche automatique du code garde couleur), les zones alpha 3 et 4 peuvent contenir un complément de requête.

Dans ce cas, il n'est plus nécessaire de remplir la valeur alpha 1 (étant donné que le code sera calculé automatiquement).

Valeur alpha 4

TGC A4[1,60]

Si l'option 14 définie sur le paramètre #CFDRE est activée (recherche automatique du code garde couleur), les zones alpha 3 et 4 peuvent contenir un complément de requête.

Dans ce cas, il n'est plus nécessaire de remplir la valeur alpha 1 (étant donné que le code sera calculé automatiquement).


TIC Types d'informations complémentaires

Le libellé court du paramètre apparaît dans le titre de la fenêtre de saisie des informations complémentaires.

Valeur alpha 1

TIC A1[1]

TIC modifiable par l'utilisateur (O/N, O par défaut)

TIC A1[2,3]

Gestion des compléments avec boutons dans la saisie des TSC.

Numéro d'indice du type d'information (poste) pour la saisie dans les informations complémentaires (TSC).

Saisir une valeur comprise entre 1 et 20, pas de valeur par défaut.

IMPORTANT : Chaque type d'information (poste) doit posséder un indice propre, le numéro d'indice influe sur l'ordre des boutons dans la saisie des informations complémentaires (TSC).

Valeur alpha 2

TIC A2[1,60]

Chemin de l'image à mettre en place sur le bouton correspondant au code type d'information (poste) sur la saisie des informations complémentaires (TSC)

Gestion des compléments avec boutons dans la saisie des TSC

Permet, dans la saisie des informations complémentaires (F20), de gérer des boutons de regroupement par poste (Type d'information complémentaire : TIC).

Remarques :

• Les boutons affichés sont conditionnés selon le principe habituel des TIC : argument -D, voir la rubrique « Généralités » de l'aide en ligne pour plus de détails
(Les boutons remplacent la sélection du TIC qui apparaissait jusque-là avant la saisie des TSC).

• Un TSC peut être associé à plusieurs boutons (20 boutons affichables au maximum).

• Les TSC autorisés pour tous les postes (TIC*) apparaissent dans les données générales (premier bouton Données).

• Si le paramétrage du poste est incorrect (numéro d'indice inexistant ou hors limites), les données de la TSC seront affichées dans les données générales (premier bouton Données).

• Les compléments par poste ne sont pas gérés dans le cadre des TSC contextuels (les boutons n'apparaissent pas et les données affichées peuvent concerner des postes différents).

• Paramétrage
TSC, notes commençant par TIC
TIC A1[2,3]
TIC A2[1,60]


TIM Types d'imposition

Ce paramètre est utilisé dans le code calcul IE (caractère 1 = 5) pour le devis standard.

Le code du paramètre est récupéré dans la zone fi_zpar.

Valeur alpha 1

TIM A1[1] | Type d'imposition M Mono-référence (par défaut) F Amalgame de formats R Amalgame de référence H Habillage. Attention, ce paramétrage conduit à définir des poses identiques pour toutes les références dans VoluOptimix. C Amalgame de cahiers; ne peut être utilisé qu'avec l'entité feuillet/dépliant.
TIM A1[2] | Contrôler le nombre de poses saisi sur l'entité par rapport au nombre total de poses saisi sur les références multiples B Contrôle bloquant W Contrôle non bloquant N Pas de contrôle (par défaut)
TIM A1[3] | Références tirées à la suite (O/N, N par défaut)
TIM A1[4] | Mise à jour automatique du nombre de références sur l'entité (O/N, O par défaut) Permet de ne pas mettre à jour le nombre de références sur l'entité. Remarque : La mise à jour du nombre de références sur l'entité dépend également du paramétrage déjà existant (A2[55] sur le devis multi-métiers).


TLC Type de ligne des commandes clients

Aucun paramétrage particulier


TLF Type de ligne des commandes fournisseurs

Aucun paramétrage particulier


TLI Tournée de livraison

Valeur alpha 1

TLI A1[1,3]

Super Zone.

Correspondance utilisée pour le transfert JDE. Voir les programmes tr_jde_cde et tr_jde_groupage

La valeur est obligatoire mais non contrôlée.


TMC Types de machines

Les types de machines sont figés par VOLUME à des fins d'amélioration de performance du système.

ASC | Chaîne d'assemblage + couture - Voir la note CODES_CONTROLE_FACO
ASS | Assembleuse - Voir la note CODES_CONTROLE_FACO
BCO | Brochure avec couture - Voir la note CODES_CONTROLE_FACO
BRO | Brocheuse
BSC | Brochure sans couture - Voir la note CODES_CONTROLE_FACO
CEL | Cellophaneuse
CHA | Chargement camion
COL | Colleuse
COM | Combiné
COP | Copie
COR | Décortiqueuse
COU | Couseuse - Voir la note CODES_CONTROLE_FACO
CVC | Montage de couverture pour cartonné - Voir la note CODES_CONTROLE_CVC
DEC | Découpeuse
DOR | Doreuse
EHL | Emballage hors-ligne
ENC | Encarteuse
FEU | Machine d'impression feuille
FOR | Machine pour fabrication des formes
GAU | Machine à gaufrage
HEL | Machine d'impression hélio
IMP | Machine d'impression
MAS | Massicot
MON | Montage
NUM | Numérotage
OND | Onduleuse
PAC | Presse à cercler
PCR | Plieuse/colleuse
PIQ | Piqueuse - Voir la note CODES_CONTROLE_FACO
PFA | Petit façonnage
PLA | Platine
PLI | Plieuse
RAI | Raineuse
REL | Reliure - Voir la note CODES_CONTROLE_FACO
ROT | Machine d'impression roto
SEP | Séparateur
SAM | Soudeuse plastique bord
SLO | Slotter
SOU | Soudeuse plastique pour assemblage

Valeurs numériques

TMC N1

Numéro d'ordre dans le processus de fabrication

Permettra un classement logique des machines dans certaines éditions statistiques

ATTENTION ! Pour le devis optimisé, les libellés alpha 1 , alpha 2 et alpha 3 sont figés selon le type de machine.

Valeur alpha 1

TMC A1[1,12] | libellé paramétré 1 - Sur la fiche machine : Valeur numérique 1
TMC A1[13,24] | libellé paramétré 2 - Sur la fiche machine : Valeur numérique 2
TMC A1[25,36] | libellé paramétré 3 - Sur la fiche machine : Valeur numérique 3
TMC A1[37,48] | libellé paramétré 4 - Sur la fiche machine : Valeur alpha 1

Valeur alpha 2

TMC A2[1,12] | libellé paramétré 5 - Sur la fiche machine : Valeur alpha 2
TMC A2[13,24] | libellé paramétré 6 - Sur la fiche machine : Valeur alpha 3
TMC A2[25,36] | libellé paramétré 7 - Sur la fiche machine : Valeur alpha 4
TMC A2[37,48] | libellé paramétré 8 - Sur la fiche machine : Valeur alpha 5
TMC A2[49,60] | libellé paramétré 9 - Sur la fiche machine : Valeur alpha 6

Valeur alpha 3

TMC A3[1,12] | libellé paramétré 10 (grammage par défaut) - Sur la fiche machine : Plage 1
TMC A3[13,24] | libellé paramétré 11 (épaisseur par défaut) - Sur la fiche machine : Plage 2
TMC A3[25,36] | libellé paramétré 12 - Sur la fiche machine : Plage 3

Valeur alpha 4

TMC A4[1] | Pour les contrôles machines dans le devis TC. Format à utiliser pour contrôle ouverture et poussée D Format découpe I Format impression P Format plaque (par défaut) U Format unitaire
TMC A4[2] | Pour les contrôles machines dans le devis TC. Sens du format pour contrôle ouverture et poussée dans le cas où la cannelure n'est pas inversée. 1 La laize correspond au sens travers (défaut) 2 La laize correspond au sens machine Pas de gestion de la cannelure inversée pour l'instant
TMC A4[3] | Edition des machines de ce type dans l'ordre d'exécution VoluEdit O Machine éditée (défaut) L Machine présente dans la variable liste des machines mais non éditée en détail R Machine éditée avec rupture sur le site de machine si machine de type Onduleuse N Machine ignorée
TMC A4[4] | Passage sur la machine similaire à celui de l'onduleuse (O/N, N par défaut)
TMC A4[5] | Passage sur la machine similaire à celui dune machine de découpe (O/N, N par défaut)
TMC A4[6] | Type de machine C Couverturière D Platine de découpe E Encarteuse - piqueuse F Impression Feuille M Massicot P Plieuse R Impression Rotative S Impression superposée
TMC A4[7] | Ecran des caractéristiques machines I Ecran des caractéristiques machines d'impression (par défaut) P Ecran des caractéristiques machines de pliage

Exemple

Pour le type de machine IMP (machine à imprimer), on a

valeur alpha 1 | G.Papier(F) G.Papier(V) Max.Groupes Plaq. encre
valeur alpha 2 | Pla. vernis Palette Vernis Retiration

Notes

C | Contrôle des possibilités machines (pour le devis onduleur) 2 à 4 Code contrôle de possibilité machine à effectuer. Voir le tableau. 5 à 8 Modes de contrôle Le mode expert est activé par l'option Oex. N Pas de contrôle W Warning B Bloquant (par défaut) 5 Contrôle en mode expert pour une architecture automatique 6 Contrôle en mode normal pour une architecture automatique 7 Contrôle en mode expert pour une architecture étudiée 8 Contrôle en mode normal pour une architecture étudiée 9,11 Type de remplacement DEC Le code contrôle paramétré des caractères 2 à 4 est remplacé par celui paramétré dans les caractères 10 à 12 si l'entité courante est une entité avec présence de découpe (voir ci-dessous) 12,14 Code contrôle de remplacement. Voir le tableau
CODE_LIEN_TABLES | 21, 23 Code de lien par défaut (type #LI) entre les tables machine (mac0) et pli (par02) Si aucun paramètre de lien n'est saisi (ou s'il est invalide), une fenêtre de sélection proposant les codes compatibles existants permettra de sélectionner le code de lien à utiliser. Cette note a priorité sur celle du programme de saisie des machines. Cette note a priorité sur la note LIEN_MACHINE_PLI du #CF DEG.
CODES_CONTROLE_CVC | Contrôles pour machine CVC (Couverture pour Cartonné) 21,23 Code contrôle à effectuer. Voir le tableau 24 Mode de contrôle en mode expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut) 25 Mode de contrôle en mode non expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut)
CODES_CONTROLE_FACO | Contrôle des contraintes du façonnage pour l'optimisation - Voir aussi USE A2[59] 21,23 Code contrôle à effectuer. Voir le tableau 24 Comportement pour ce code en mode expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut) 25 Comportement pour ce code en mode non expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut)
CODES_CONTROLE_MAS | Contrôles pour le massicot 21,23 Code contrôle à effectuer. Voir le tableau 24 Comportement pour ce code en mode expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut) 25 Comportement pour ce code en mode non expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut)
CODES_CONTROLE_PLI | Contrôles de faisabilité de pliage sur les machines de type couverturière - plieuse 21,23 Code contrôle à effectuer. Voir le tableau 24 Comportement pour ce code en mode expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut) 25 Comportement pour ce code en mode non expert N Pas de contrôle W Contrôle non bloquant B Contrôle bloquant (par défaut)
_SUP_REQ_RECH_LIEN | 21,60 Complément de sélection des code liens (table par02) dans le cas où le code lien n'est pas renseigné (voir note CODE_LIEN_TABLES)

Contrôle des possibilités machines (notes commençant par C)

Attention : tous les codes mentionnés dans ce tableau ne sont pas utilisables dans tous les devis.

Voir aussi les notes sur les gammes.

Code

Désignation

Contrôle effectué

001

Dimension sens ouverture minimum / maximum.

Sens ouverture = sens travers

Ouverture (définie en mm) comprise dans la plage Format papier sens travers minimum / maximum de la fiche machine.

Devis onduleurs

L'ouverture utilisée pour le contrôle correspond à l'ouverture des données techniques article / gamme / phase (TSC 510).

Ce contrôle ne doit pas être utilisé sur l'onduleuse ou l'extrudeuse.

Pas nécessaire, le nombre de poses est calculé en amont afin de ne pas dépasser le format maximum de la machine de découpe.

Voir le contrôle des mini/maxi ouverture/poussée pour une pose sur la machine.

Devis transformateurs

L'ouverture est définie par l'une des dimensions suivantes :

§ laize ou coupe découpe

§ laize ou coupe impression

§ laize ou coupe plaque

Le format à utiliser et le sens format sont paramétrés sur le type de machine.

Par défaut :

§ Type format = plaque

§ Dimension = laize

002

Dimension sens poussée

Poussée (en mm) comprise dans la plage Format papier sens machine mini / maxi de la fiche machine.

Devis onduleurs

La poussée est la poussée des données techniques article / gamme / phase (TSC 510).

Ne pas utiliser sur l'onduleuse ou l'extrudeuse.

Voir le contrôle des mini/maxi ouverture/poussée pour une pose sur la machine.

Devis transformateurs

Idem contrôle 001, sauf : Dimension par défaut = coupe.

003

Nombre maximum de couteaux dans le sens laize

Le nombre de couteaux est inférieur au nombre maximum de couteaux défini par la valeur numérique 1 de la fiche machine.

Le nombre de couteaux dans le sens laize est égal au nombre de couteaux issu des pointages dans le sens laize multiplié par le nombre de plaques dans le sens laize.

Valeur par défaut : le contrôle est OK.

Devis onduleurs

Les options onduleuse couteaux doivent être de la famille C.

Devis transformateurs : RAS

004

Nombre maximum de refouleurs dans le sens laize

Avec prise en compte des raines supplémentaires

Le nombre de refouleurs est inférieur au nombre maximum de refouleurs définis par la valeur numérique 2 de la fiche machine.

Le nombre de refouleurs dans le sens laize est égal au nombre de refouleurs issu des pointages sens laize multiplié par le nombre de plaques dans le sens laize.

Valeur par défaut : le contrôle est OK.

Devis onduleurs

Si cannelure inversée, le contrôle est toujours OK.

Les options onduleuse refouleurs doivent être de la famille R.

Devis transformateurs

Pas de gestion des cannelures inversées pour l'instant.

005

Distance mini entre 2 couteaux dans le sens laize

La distance minimum entre deux couteaux est comprise dans la plage 1 de la fiche machine.

La distance minimum entre deux couteaux est égale à la laize brute de l'architecture.

Valeur par défaut : le contrôle est OK

Devis onduleur

Les options onduleuse couteaux doivent être de la famille C.

Devis transformateurs : RAS

006

Distance mini. entre 2 refouleurs dans le sens laize

Avec prise en compte des raines supplémentaires

La distance minimum entre deux refouleurs est comprise dans la plage 2 de la fiche machine.

La distance minimum entre deux refouleurs est égale au pointage minimum de type refouleur dans le sens de la laize.

Valeur par défaut : le contrôle est OK.

Devis onduleurs

Si cannelure inversée, le contrôle est toujours OK.

Les options onduleuse refouleurs doivent être de la famille R.

Devis transformateurs

Pas de gestion des cannelures inversées pour l'instant.

007

Distance mini entre 3 refouleurs dans le sens laize

Devis onduleurs uniquement

La distance minimum entre trois refouleurs est comprise dans la plage 3 de la fiche machine. Si cannelure inversée, le contrôle est toujours OK.

Valeur par défaut : le contrôle est OK.

008

Options onduleuse autorisées

Devis onduleurs uniquement

La liste des options onduleuse autorisées est définie par les TSC 710 et 715 de la fiche machine.

Valeur par défaut : le contrôle n' est pas OK.

(Cf. Paramètre .00)

009

Contraintes impression autorisées

Devis onduleurs uniquement

La liste des contraintes d'impression autorisées est définie par les TSC 690 et suivants de la fiche machine.

Valeur par défaut : le contrôle n' est pas OK.

010

Cannelure inversée autorisée

Devis onduleurs uniquement

L'indicateur cannelure inversée autorisée est saisi dans la valeur alpha 4 de la fiche machine.

Valeur par défaut : Non autorisée

011

Patte extérieure autorisée

Devis onduleurs uniquement

L'indicateur "patte extérieure autorisée" est saisi dans la valeur alpha 6 de la fiche machine.

Valeur par défaut : Non autorisée

Attention : si pas de jonction, pas de patte. Voir aussi le paramètre .J3

012

Contrôle emballage mécanisé

Non utilisé

013

Longueur intérieure

Devis onduleurs et transformateurs

La longueur intérieure est comprise dans la plage 1 de la fiche machine. On rappellera que la longueur intérieure est égale à L.

Distance entre bras de pliage

Valeur par défaut : le contrôle est OK.

014

Largeur intérieure

Devis onduleurs et transformateurs

La largeur intérieure est comprise dans la plage 2 de la fiche machine. On rappellera que la largeur intérieure est égale à B.

Valeur par défaut : le contrôle est OK.

015

Longueur + largeur intérieur :

m0_min_1 & m0_max_1

Devis onduleurs et transformateurs

La longueur intérieure + la largeur intérieure est comprise dans la plage 3 de la fiche machine.

Cote de rapprochement plieuse.

Valeur par défaut : le contrôle est OK.

016

Hauteur intérieure :

m0_zpar1 et m0_zpar2

Devis onduleurs et transformateurs

La hauteur intérieure est supérieure ou égale à la valeur numérique 1 de la fiche machine et inférieure ou égale à la valeur numérique 2 saisie sur la fiche machine.

La hauteur intérieure est égale à H.

Valeur par défaut : le contrôle est OK.

017

Nombre maximum d'articles par colis et profil carton utilisé

Devis onduleurs uniquement

Les minima et maxima d'articles par colis sont définis par les TSC 650 à 664 de la fiche machine par profil carton.

Si le profil carton n'est pas autorisé, le contrôle n'est pas OK.

Utilisable pour un compteur éjecteur.

Valeur par défaut : le contrôle est OK.

018

Code jonctionnement autorisé

Devis onduleurs et transformateurs

La liste des codes de jonctionnement (collé, agrafé, etc..) autorisés est définie par :

les TSC 620 à 623, 62A à 62E pour les onduleurs

les TSC 620 & 621 de la fiche machine pour les transformateurs

Valeur par défaut : le contrôle n'est pas OK.

(Cf. Paramètre [.JE])

019

Taille de patte autorisée

Devis onduleurs et transformateurs

La liste des tailles de patte autorisées est définie par les TSC 630 à 631 de la fiche machine.

Valeur par défaut : le contrôle n'est pas OK.

020

Niveau d'ECT et profil carton utilisé

Devis onduleurs uniquement

Les valeurs minima du niveau d'ECT sont définis dans les TSC 650 à 664 de la fiche machine par profil carton.

Si le profil carton n'est pas autorisé, le contrôle n'est pas OK.

Si le profil carton est autorisé et que le niveau d'ECT est inférieur au niveau d'ECT minimum de la machine alors le contrôle n'est pas OK.

Valeur par défaut : le contrôle est OK.

021

Contrôle hauteur palette

Devis onduleurs uniquement

Le contrôle hauteur (maxi et mini) se fait sur le TSC 625.

022

Schéma de palettisation

Devis onduleurs uniquement

Les schémas de palettisation interdits sont saisis dans les TSC 645 à 649 de la machine. Si le schéma déterminé par le conditionnement apparaît dans les schémas interdits, le contrôle n'est pas OK.

Valeur par défaut : le contrôle est OK.

Remarque : le conditionnement est déterminé avant les contrôles. Il ne s'agit que d'un garde fou.

023

Position tenon

Devis onduleurs uniquement

Les codes position tenon AUTORISES sont saisis dans les TSC 720 à 721 de la machine. Si la position tenon apparaît dans les positions autorisées, le contrôle est OK, sinon il n'est pas OK.

024

Nombre maxi de morceaux

Devis onduleurs et transformateurs

Le nombre maximum de morceaux (caisse en 2 partie = 2 morceaux) est saisi dans le TSC 724 de la machine. Par défaut le contrôle st OK.

En architecture étudiée sans FEFCO, le contrôle est OK.

025

Qualités interdites

Par défaut, le contrôle est OK.

Devis onduleurs : Le code qualité produit est saisi sur l'écran architecture.

Les codes qualités interdits sont saisis sur les TSC 725 à 727.

Pour chaque TSC, on utilise les zones char3_1, char3_2 et char30.

Devis transformateurs :

Les qualités interdites sont contrôlées avec le code papier.

La liste des qualités interdites est saisie dans la zone ic_char30 des TSC 725 à 727.

Voir aussi le code contrôle 053.

026

Familles et sous-familles autorisées

Les couples famille / sous-famille autorisés sont saisis dans les TSC 730 à 741 de la machine.

Devis onduleurs : RAS

Devis transformateurs

On teste par rapport à la famille et la sous-famille de l'article "composant".

027

Couples (machine / assemblages) interdits

Devis onduleurs uniquement

La liste des couples (machine / assemblage) interdits est saisie sur la composition commerciale.

028

Nombre de poses maxi

Le nombre maximum de poses est saisi dans le TSC 745.

Devis onduleurs : RAS

Devis transformateurs

Le nombre de poses testé peut-être :

§ le nombre de poses découpe

§ le nombre de poses impression

§ le nombre de poses plaque

Cf. contrôle 001.

029

Distance mini entre 2 bandes

Devis onduleurs uniquement

Les distances minima entre 2 bandes par type de bande seront saisies dans les TSC 710 à 715 de la fiche machine

030

Longueur maximum de filet

Devis onduleurs uniquement

Vérifie si la longueur de filet (calculée ou saisie) est supérieure à la longueur maximum de filet exprimée en millimètres est saisie dans le TSC 745 de la fiche machine.

031

Nombre maximum de poses en remorque

Devis onduleurs uniquement

Le nombre maximum de poses en remorque est saisi dans le TSC 745 de la fiche machine.

032

Complexité découpe autorisée

Devis onduleurs uniquement

Les codes complexité découpe autorisés sont saisi dans les TSC 746 à 748 de la machine. Si la complexité découpe apparaît dans complexités autorisées, le contrôle est OK, sinon il n'est pas OK.

033

Sous-famille composition commerciale interdite

Devis onduleurs uniquement

La liste des sous-familles de composition commerciale (type produit pour le plastique) interdites est donnée par les TSC 760 et 761

034

Epaisseur qualité

Non utilisé ?

035

Nombre maximum de couteaux dans le sens coupe

Cf. contrôle 003

Devis transformateurs uniquement

Le nombre de couteaux est inférieur au nombre maximum de couteaux défini par la valeur numérique 1 de la fiche machine.

Le nombre de couteaux dans le sens coupe est égal au nombre de couteaux issu des pointages dans le sens coupe multiplié par le nombre de plaques dans le sens coupe.

Valeur par défaut : le contrôle est OK.

036

Nombre maximum de refouleurs dans le sens coupe

Cf. contrôle 004

Devis transformateurs uniquement

Le nombre de refouleurs est inférieur au nombre maximum de refouleurs définis par la valeur numérique 2 de la fiche la machine.

Le nombre de refouleurs dans le sens coupe est égal au nombre de refouleurs issu des pointages sens coupe multiplié par le nombre de plaques dans le sens coupe.

Valeur par défaut : le contrôle est OK.

Pas de gestion des cannelures inversées pour l'instant.

037

Distance min/max entre 2 couteaux dans le sens coupe

Cf. contrôle 005

Devis transformateurs uniquement

La distance minimum et maximum entre deux couteaux est comprise dans la plage 1 de la fiche machine. La distance minimum entre deux couteaux est égale à la coupe brute de l'architecture.

Valeur par défaut : le contrôle est OK.

038

Distance mini / maxi entre 2 refouleurs dans le sens coupe

Cf. contrôle 006

Devis transformateurs

La distance minimum et maximum entre deux refouleurs est comprise dans la plage 2 de la fiche machine. La distance minimum entre deux refouleurs est égale au pointage minimum de type refouleur dans le sens de la coupe.

Devis onduleurs

La distance minimum et maximum entre deux refouleurs est comprise dans la plage 1 de la fiche machine. La distance minimum entre deux refouleurs est égale au pointage minimum de type refouleur dans le sens de la coupe.

Valeur par défaut : le contrôle est OK.

Pas de gestion des cannelures inversées pour l'instant.

039

Nombre maximum d'outils dans le sens laize

Devis transformateurs uniquement

Le nombre d'outils est inférieur au nombre maximum d'outils défini par la valeur numérique 1 de la fiche machine.

Le nombre d'outils dans le sens laize est égal au nombre d'outils issu des pointages dans le sens laize multiplié par le nombre de plaques dans le sens laize.

Valeur par défaut : le contrôle est OK.

040

Distance min. entre 2 outils dans le sens laize

Devis transformateurs uniquement

La distance minimum entre deux outils est comprise dans la plage 2 de la fiche machine. La distance minimum entre deux outils est égale au pointage minimum dans le sens de la laize.

Valeur par défaut : le contrôle est OK.

041

Nombre maximum d'outils dans le sens coupe

Devis transformateurs uniquement

Le nombre d'outils est inférieur au nombre maximum d'outils défini par la valeur numérique 1 de la fiche machine.

Le nombre d'outils dans le sens coupe est égal au nombre d'outils issu des pointages dans le sens coupe multiplié par le nombre de plaques dans le sens coupe.

Valeur par défaut : le contrôle est OK.

042

Distance min. entre 2 outils dans le sens coupe

Devis transformateurs uniquement

La distance minimum entre deux outils est comprise dans la plage 2 de la fiche machine. La distance minimum entre deux outils est égale au pointage minimum dans le sens de la coupe.

Valeur par défaut : le contrôle est OK.

043

Contrôle du pli supplémentaire

Devis transformateurs uniquement

Vérification que l'ouverture est comprise entre l'ouverture minimum et l'ouverture maximum augmentée du pli supplémentaire (donnée spécifique 11 (U) du FEFCO)

Cette nouvelle contrainte machine permet de gérer le rainage supplémentaire.

043

Hauteur d'un panneau + hauteur du plus grand rabat

Devis onduleurs uniquement

La hauteur d'un panneau + celle du plus grand rabat est comprise entre les valeurs numériques 1 (minimum) et 2 (maximum) du TSC 635 de la machine.

Valeur par défaut : le contrôle est OK.

044

Profil carton interdit

Devis onduleurs uniquement

La liste des profils carton autorisés est définie par les TSC 637 et 639 (valeurs alpha) de la fiche machine.

Valeur par défaut : le contrôle est OK.

045

Largeur de la patte + largeur du panneau adjacent

Devis onduleurs uniquement

La largeur de la patte + celle du panneau adjacent est comprise entre les valeurs numérique 1 (minimum) et 2 (maximum) du TSC 636 de la machine.

Valeur par défaut : le contrôle est OK.

046

Types de consommables autorisés

Devis onduleurs uniquement

La liste des types de consommables autorisés est donnée par les TSC 770 à 772 de la fiche machine.

Valeur par défaut : le contrôle est OK.

Actif seulement si l' option Ocg est activée (gestion des consommables génériques)

047

Type de vernis autorisés

Devis onduleurs uniquement

La liste des types de vernis autorisés est donnée par les TSC 780 à 782 de la fiche machine.

Valeur par défaut : le contrôle est OK.

Actif seulement si le complément de select des vernis est paramétré.

048

Longueur + largeur intérieure

Devis onduleurs uniquement

Idem code contrôle 015 mais seulement pour le cas des plaques (un seul pointage dans le sens coupe)

Dans ce cas Longueur + largeur = Longueur uniquement.

Valeur par défaut : le contrôle est OK.

049

Palettiseur

Devis onduleurs uniquement

Contrôle les dimensions palettes par rapport au sens travers maxi du palettiseur. (contrôle avec ¼ de tour si le premier contrôle n'est pas bon).

Valeur par défaut : le contrôle est OK.

050

Contrôle de surface

Devis onduleurs uniquement

Contrôler la validité d'une machine par rapport à une plage de surface minimum / maximum autorisée.

Les surfaces mini et maxi sont stockées respectivement dans les zones numériques 1 et 2 du TSC 790.

051

Contrôle dimensions plaque dans les 2 sens

Devis transformateurs uniquement

Nouveau contrôle de possibilité machine qui permet de déterminer si les dimensions d'une plaque sont compatibles avec les dimensions mini / maxi de la machine

Ce contrôle teste la plaque dans les deux sens, laize/coupe puis coupe/laize.

051

Contrôle du format palette

Devis onduleurs uniquement

Permet de comparer le format palette du conditionnement avec une liste de formats palettes interdits saisis sur la machine en cours de contrôle.

052

Contrôle de la somme des 4 faces hors tenon

Devis onduleurs uniquement

Contrôle de la somme des faces hors tenon par rapport à des valeurs minimum/maximum saisies sur un TSC machine (TSC 637)

053

Qualités interdites des qualités matières des papiers

Devis transformateurs uniquement

Les codes qualités interdits sont contrôlés avec la qualité matière du papier si celle-ci est renseignée sinon avec le code papier.

La liste des qualités interdites est saisie dans la zone ic_char30 des TSC 72A à 72Z, 73A à 73Z et 74A à 74Z des machines.

Par défaut, le contrôle est OK.

Voir aussi le code contrôle 025.

Contrôle pour machines CVC (Couverture pour Cartonné) (notes CODES_CONTROLE_CVC)

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
 | Contrôle systématique |  |  | Le nombre de cahiers doit être supérieur à 1
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
002 | Contrôles sur le type de papier FAM A4[58] | C10 Char 3_2 |  | Contrôle sur possibilité d'utiliser un plein papier pelliculé (PPP)
 |  | C10 Char 30 |  | Contrôle sur la possibilité d'utiliser un papier toilé
 | Contrôles sur le type de reliure TDF A1[2] | C11 Char 3_1 |  | Contrôle sur la possibilité de façonner une reliure intégra
 |  | C11 Char 3_2 |  | Contrôle sur la possibilité de façonner une demi-reliure
003 | Contrôles sur la largeur | C13 Num 1 | C13 Num 2 | Contrôle sur la largeur
004 | Contrôles sur l'épaisseur | C14 Num 1 | C14 Num 2 | Contrôle sur l'épaisseur
005 | Contrôles sur le rembord, saisi dans la donnée calculée 6 (FEFCO/ECMA) | C15 Num 1 | C15 Num 2 | Contrôle sur le rembord
006 | Contrôles sur le grammage | C16 Num 1 | C16 Num 2 | Contrôle sur le grammage

Contrôle des contraintes de façonnage (notes CODES_CONTROLE_FACO)

Les contrôles de façonnage sont disponibles pour les machines suivantes :

ASC | Assemblage + couture
ASS | Assemblage
BCO | Brochure avec couture
BSC | Brochure sans couture
COU | Couture
EHL | Emballage hors-ligne
PIQ | Piqûre
REL | Reliure

Contraintes de façonnage pour l'assemblage + couture - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
001 | Dimensions | XXX – Num1 XXX – Num1 | XXX – Num2 XXX – Num2 | Contrôle sur la largeur du paquet Contrôle sur la hauteur du paquet
002 | Epaisseur | XXX – Num1 | XXX – Num2 | Contrôle sur l'épaisseur du paquet
003 | Poids | XXX – Num1 | XXX – Num2 | Contrôle sur le poids du paquet

Contraintes de façonnage pour l'assemblage (TMC ASS) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
 | Contrôle systématique |  |  | Le nombre de cahiers doit être supérieur à 1
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
002 | Nombre de postes | G02 Num 1 | G02 Num 2 | Contrôle sur le nombre de postes (permet d'exclure des machines)
003 | Margeur de cahier | A02 Num 1 | A02 Num 2 | Contrôle sur la largeur
 |  | A03 Num 1 | A03 Num 2 | Contrôle sur la hauteur

Contraintes de façonnage pour la brochure avec couture (TMC BCO) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
 | Contrôle systématique |  |  | Le nombre de cahiers doit être supérieur à 1
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
 |  | pas de mini | A01 Num 1 | Contrôle sur l'épaisseur
002 | Margeur de cahier | A02 Num 1 | A02 Num 2 | Contrôle sur la largeur
 |  | A03 Num 1 | A03 Num 2 | Contrôle sur la hauteur
 |  | A04 Num 1 | A04 Num 2 | Contrôle sur l'épaisseur du demi cahier
003 | Margeur de couverture | S01 Char 3_1 (O/N) |  | Contrôle de présence de margeur de couverture
 |  | A05 Num 1 | A05 Num 2 | Contrôle sur le grammage
 |  | A06 Num 1 | A06 Num 2 | Contrôle sur la largeur
 |  | A07 Num 1 | A07 Num 2 | Contrôle sur la hauteur
004 | Trilatéral - Façonnage en 1 pose | pas de mini | A08 Num 1 | Contrôle sur les rognes de tête/pied maximum
 |  | pas de mini | A08 Num 2 | Contrôle sur la rogne de barbe maximum
 |  | A09 Num 1 | A09 Num 2 | Contrôle sur la largeur finie
 |  | A10 Num 1 | A10 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | A11 Num 1 | Contrôle sur l'épaisseur maximum
 | Trilatéral - Façonnage en 2 poses | A12 Num 1 | A12 Num 2 | Contrôle sur la largeur finie
 |  | A13 Num 1 | A13 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | A14 Num 1 | Contrôle sur l'épaisseur maximum

Contraintes de façonnage pour la brochure sans couture (TMC BSC) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
 |  | pas de mini | S01 Num 1 | Contrôle sur l'épaisseur
002 | Margeur de cahier | S02 Num 1 | S02 Num 2 | Contrôle sur la largeur
 |  | S03 Num 1 | S03 Num 2 | Contrôle sur la hauteur (façonnage en 1 pose)
 |  | S04 Num 1 | S04 Num 2 | Contrôle sur la hauteur (façonnage > 1 pose)
003 | Margeur de couverture | S01 Char 3_1 (O/N) |  | Contrôle de présence du margeur de couverture
 |  | S05 Num 1 | S05 Num 2 | Contrôle sur le grammage
 |  | S06 Num 1 | S06 Num 2 | Contrôle sur la largeur
 |  | S07 Num 1 | S07 Num 2 | Contrôle sur la hauteur
004 | Trilatéral - Façonnage en 1 pose | pas de mini | S08 Num 1 | Contrôle sur les rognes de tête/pied
 |  | pas de mini | S08 Num 2 | Contrôle sur la rogne de barbe
 |  | S09 Num 1 | S09 Num 2 | Contrôle sur la largeur finie
 |  | S10 Num 1 | S10 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | S11 Num 1 | Contrôle sur l'épaisseur
 | Trilatéral - Façonnage en 2 poses | S12 Num 1 | S12 Num 2 | Contrôle sur la largeur finie
 |  | S13 Num 1 | S13 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | S14 Num 1 | Contrôle sur l'épaisseur

Contraintes de façonnage pour la couture (TMC COU) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
 | Contrôle systématique |  |  | Le nombre de cahiers doit être supérieur à 1
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
002 | Margeur de cahier | A02 Num 1 | A02 Num 2 | Contrôle sur la largeur
 |  | A03 Num 1 | A03 Num 2 | Contrôle sur la hauteur
 |  | A04 Num 1 | A04 Num 2 | Contrôle sur l'épaisseur du demi cahier

Contraintes de façonnage pour l'emballage hors-ligne (TMC EHL) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
001 | Dimensions | H01 – Num1 H02 – Num1 | H01 – Num2 H02 – Num2 | Contrôle sur la largeur du paquet Contrôle sur la hauteur du paquet
002 | Epaisseur | H03 – Num1 | H03 – Num2 | Contrôle sur l'épaisseur du paquet
003 | Poids | H04 – Num1 | H04 – Num2 | Contrôle sur le poids du paquet

Contraintes de façonnage pour la piqûre (TMC PIQ) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes. PHA A4[28] doit être = N
 |  | pas de mini | P01 Num 3 | Contrôle de l'épaisseur
002 | Margeur de cahier avec pinces (TSC P01 Char3_1 = P) | P02 Num 1 | P02 Num 2 | Contrôle sur la largeur côté dépassant
 |  | P03 Num 1 | P03 Num 2 | Contrôle sur la largeur face dépassant
 |  | P04 Num 1 | P04 Num 2 | Contrôle sur le dépassant
 | Margeur de cahier avec ventouses (TSC P01 Char3_1 = V) | P05 Num 1 | P05 Num 2 | Contrôle sur la largeur
 |  | P07 Num 1 | P07 Num 2 | Contrôle sur la hauteur (façonnage en 1 ex)
 |  | P08 Num 1 | P08 Num 2 | Contrôle sur la hauteur (façonnage > 1 ex)
003 | Margeur de couverture | P01 Char 3_2 (O/N) |  | Contrôle de présence du margeur de couverture
 |  | P11 Num 1 | P11 Num 2 | Contrôle sur le grammage
 |  | P12 Num 1 | P12 Num 2 | Contrôle sur la largeur
 |  | P13 Num 1 | P13 Num 2 | Contrôle sur la hauteur
 |  | P13 Char 3_1 (O/N) |  | Couverture sur 4 pages
004 | Trilatéral - Façonnage en 1 pose | P22 Num 1 | P22 Num 2 | Contrôle sur la largeur finie
 |  | pas de mini | P21 Num 1 | Contrôle sur les rognes tête/pied
 |  | pas de mini | P21 Num 1 | Contrôle sur la rogne de barbe
 |  | P23 Num 1 | P23 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | P26 Num 1 | Contrôle de l'épaisseur
 | Trilatéral - Façonnage en 2 poses | P27 Num 1 | P27 Num 2 | Contrôle sur les rognes tête / pied
 |  | P28 Num 1 | P28 Num 2 | Contrôle sur la rogne de barbe
 |  | P29 Num 1 | P29 Num 2 | Contrôle sur la largeur finie
 |  | P30 Num 1 | P30 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | P33 Num 1 | Contrôle de l'épaisseur
 |  | P34 Num 1 P34 Num 2 P35 Num 1 | pas de maxi | Contrôle sur les double-coupes selon l'épaisseur du bloc Si épaisseur > 4 et < 5 Si épaisseur > 3 et < 4 Si épaisseur < 3
 | Trilatéral - Façonnage en 3 poses | P36 Num 1 | P36 Num 2 | Contrôle sur la largeur finie
 |  | P37 Num 1 | P37 Num 2 | Contrôle sur la hauteur finie
 |  | pas de mini | P40 Num 1 | Contrôle de l'épaisseur
005 | Epaisseur maximum du cassage | pas de mini | P45 Num 1 | Contrôle de l'épaisseur du cassage

Contraintes de façonnage pour la reliure (TMC REL) - Note CODES_CONTROLE_FACO

Code contrôle |  | Code TSC associé |  | Désignation du contrôle
 |  | Minimum | Maximum
 | Contrôle systématique |  |  | Le nombre de cahiers doit être supérieur à 1
001 | Généralités | pas de mini | G01 Num 1 | Contrôle sur le nombre de postes
002 | Margeur de bloc |  |  |
 | Epaisseur du bloc : > 3 et <= 30 mm | R01 – Num 1 | R01 – Num 2 | Contrôle sur la hauteur
 |  | R04 – Num 1 | R04 – Num 2 | Contrôle sur la largeur
 | Epaisseur du bloc : > 30 et <= 40 mm | R02 – Num 1 | R02 – Num 2 | Contrôle sur la hauteur
 |  | R05 – Num 1 | R05 – Num 2 | Contrôle sur la largeur
 | Epaisseur du bloc : > 40 et <= 80 mm | R03 – Num 1 | R03 – Num 2 | Contrôle sur la hauteur
 |  | R06 – Num 1 | R06 – Num 2 | Contrôle sur la largeur
003 | Signet La présence de signet sera saisie sur la LCO : #SG – A (Entité de façonnage). La largeur du signet sera saisie sur la LCO : #SG – 1 (Entité de façonnage). | R07 – Num 1 | R07 – Num 2 | Contrôle sur la largeur du signet
 |  | pas de mini | R08 – Num 1 | Contrôle sur la largeur maximum du bloc rogné
004 | Tranchefil La présence de tranchefil sera saisie sur la LCO : #TR – A (Entité de façonnage). | R09 – Num 1 | R09 – Num 2 | Contrôle sur l'épaisseur

Contrôles pour le massicot (notes CODES_CONTROLE_MAS)

Code contrôle | Zone mac0 |  | Désignation du contrôle
 | Ouverture | Profondeur
001 | m0_zpar2 | m0_zpar3 | Contrôle pour la refente avant impression (Contrôle par rapport au format papier)
002 | m0_zpar2 | m0_zpar3 | Contrôle pour l'équerrage (Contrôle par rapport au format papier)
003 | m0_zpar2 | m0_zpar3 | Contrôle pour la refente après impression (Contrôle par rapport au format de tirage)

Contrôles de faisabilité de pliage sur les machines de type couverturière (notes CODES_CONTROLE_PLI)

Pour les couverturières (TMC A4[6] = C)

Code contrôle | Code TSC/ Zone mac0 |  | Désignation du contrôle
 | Minimum | Maximum
001 | C01 Char 3_1 (O/N) |  | Contrôle sur la possibilité de plier deux rabats de même côté
002 | C01 Num 1 | C01 Num 2 | Contrôle de la largeur de l'ouvrage en prenant compte le plus grand des rabats (gauche/droite)
003 | C02 Num 1 | C02 Num 2 | Contrôle de la largeur de l'ouvrage avec rabats pliés
004 | C03 Num 1 | C03 Num 2 | Contrôle des dimensions de rabats
005 | C04 Num 1 | C04 Num 2 | Contrôle sur la hauteur de l'ouvrage
006 | C05 Num 1 | C05 Num 2 | Contrôle du grammage
007 | m0_papmism | m0_papmasm | Contrôle sur le format engagé par rapport au sens machine
008 | m0_papmist | m0_papmast | Contrôle sur le format d'ouverture par rapport au sens travers

Remarque : Les contrôles de 001 à 004 ne sont effectués que s'il y a présence de rabats (gauche et/ou droite).

Pour les plieuses (TMC A4[6] = P)

Code contrôle | Zone mac0 |  | Désignation du contrôle
 | Minimum | Maximum
001 | m0_papmism | m0_papmasm | Contrôle sur le format engagé par rapport au sens machine
002 | m0_papmist | m0_papmast | Contrôle sur le format d'ouverture par rapport au sens travers
003 |  |  | Contrôle sur l'épaisseur L'épaisseur maximum sera paramétrée sur la zone n°14 des liens entre la table machine et paramètre PLI. Par conséquent, il faut paramétrer le libellé de la zone 14 dans le #LI.


TMG Types de mailing

Pas de paramétrage particulier


TMT Types de matières

Valeurs numériques

TMT N1 | Valeur minimum pouvant être saisie dans la zone quantité (en saisie de matières consommées)
TMT N2 | Valeur maximum pouvant être saisie dans la zone quantité (en saisie de matières consommées)

Valeur alpha 1

TMT A1[1] | [blanc] Quantité de type normal N Quantité de type normal G ou V Quantité de gâche variable F Quantité de gâche fixe I Quantité non intégrée dans le dossier
TMT A1[2] | [blanc] Montant intégré au dossier O Montant intégré au dossier N Montant non intégré au dossier
TMT A1[5] | [blanc] Cumule le coût matière réalisé (dans les encours) N Ne cumule pas le coût matière (dans les encours) O Cumule le coût matière réalisé (dans les encours)
TMT A1[6,7] | Position de ce type de déchet dans l'enregistrement PC-Topp (MI-DATA)
TMT A1[8,10] | Code famille de déchets (utilisé dans certaines statistiques spécifiques) Paramètre de type FDE
TMT A1[11,12] | Position de ce type de déchet dans l'enregistrement PC-Topp (MI-DATA) pour l'extrudeuse


TMV Types de mouvements de stock

Valeur alpha 1

TMV A1[1]

V pour inventaire

E pour Entrée

S pour Sortie

TMV A1[2]

R pour une réserve (alimente la zone stock en réserve du fichier matière)

N pour un mouvement normal (affecte les zones stock physique et stock en réserve du fichier matière)

C pour une commande fournisseur (alimente la zone stock en commande)

P pour une entrée prévisionnelle en stock (alimente la zone stock en commande). Utilisé par exemple pour une fabrication interne.

B pour une sortie besoin (alimente le zone stock en réserve)

TMV A1[3]

D On met automatiquement la date système dans la zone affectation

M On met automatiquement la date du mouvement dans la zone affectation

Ce paramétrage ne doit être utilisé que pour les inventaires

TMV A1[4]

Ce caractère permet de déterminer la nature du mouvement dans le programme c_mat.4ge

A Achat

C Consommation

I Mouvement ignoré du traitement

TMV A1[5]

Spécifique

Code opération (utilisé dans la visu des mouvements de stocks. Colonne tmv_code_operation)

TMV A1[6]

O Le mouvement est un mouvement de type retour marchandise
(utilisé dans la saisie des mouvements de stock avec l'option -Oql)

N Le mouvement est un mouvement normal

TMV A1[25,50]

Libellé qui sera automatiquement affiché dans la zone affectation

Ce paramétrage ne doit être utilisé que pour les inventaires.

Valeur alpha 2

TMV A2[1]

La zone affectation doit-elle être alimentée automatiquement si le numéro de dossier client est saisi ? (O/N)

Permet de remplir en auto la zone d'affectation en saisie des mouvements manuels.

Le paramètre de lancement stk0 doit comporter l'une des options suivantes : 01, 02, 03 ou 04.

TMV A2[2]

Le dossier de prix de revient doit-il être repositionné à recalculer ?

N NON

O OUI uniquement OF du type XXXXXXXX-1 (FB1)

T TOUT les OF du niveau le plus haut

A Recalcul si mouvement affecté, rien si non affecté

TMV A2[3]

Intégration dans fab2 des mouvements de stock E/S sur phase QTE ENT STO dans fab2 (elle doit avoir été créée dans fab1 lors de la génération). (Evite la double saisie STK0 et SJS)

(nécessite A2[2] = O ou T)

TMV A2[4,9]

Code opérateur par défaut utilisé pour l'intégration dans fab2 des mouvements de stock

TMV A2[10]

La zone affectation et/ou centre de coût peut être saisie (N/O, O par défaut)

N On ne peut jamais saisir un OF ou centre de coût

O On peut saisir un OF ou centre de coût
La règle de contrôle appliquée est définie par article dans la zone Données diverses paramètres numéro 23 et 24.

2 Il faut saisir un OF et un centre de coût

3 Il faut saisir un OF

4 Il faut saisir un centre de coût

TMV A2[11]

S'agit t-il d'un mouvement de Retour atelier ? (O/N)

TMV A2[12]

Type de sortie de bobines

1 Sortie pour consommation onduleuse
Saisie affectation (Heures-Minutes -Lanceur-Visa) et diamètre restant

2 Mise au rebut
Pas d'affectation et de diamètre restant

3 Retour fournisseur
Pas d'affectation et de diamètre restant

4 Transfert en stock
Pas d'affectation et de diamètre restant

5 Sortie pour pré-impression chez un sous-traitant
Pas d'affectation et de diamètre restant

6 Sortie pour consommation par OF
Affectation Numéro d'OF

7 Sortie pour consommation onduleuse / Pc-Topp
Saisie affectation (Heures-Minutes-Lanceur- code_programme-Pc-Topp) et diamètre restant

8 Mise au rebut partiel
Pas d'affectation mais saisie diamètre restant

9 Saisie de l'OF et du lanceur

D Découpe bobine

R Refente bobine

T Transfert en stock avec changement de code article
Pas d'affectation et de diamètre restant.
Note : se comporte comme le type 4 mais dans l'application Gestion de la sortie des bobines, une fenêtre s'ouvre pour demander un nouveau code bobine.

TMV A2[13]

Ce type de mouvement doit-il être comptabilisé dans le calcul de la charge pour le contrôle budgétaire? (O/N)

TMV A2[14]

Le message paramètre dans les notes du TMV est

M / (vide) Message (ok)

W Warning (O/N)

B Bloquant (impossible de sortir)

TMV A2[15,17]

TMV opposé. Utilisé dans le cas où on mouvemente une nomenclature. Il faut mouvementer les composants dans le sens inverse. (Exemple : si on fait une entrée sur le composé il faut sortir les composants).

TMV A2[18]

S'agit t-il d'un mouvement de régularisation ? (O/N, N par défaut)

Remarque Intervient dans le module de création automatique d'inventaire

TMV A2[19]

Doit-on éditer une étiquette pour ce type de mouvement de stock ? (O/N, N par défaut)

TMV A2[20,39]

Libellé qui sera édité sur l'étiquette

TMV A2[40]

Mouvement participant à la création du stock (O/N, O par défaut)

Intervient dans

- le module de calcul du FIFO

- la valorisation au PAMP

- la valorisation des stocks au dernier prix d'achat

TMV A2[41]

Mise à jour de la date de la dernière entrée ou de la date de la dernière sortie sur la fiche article à chaque mouvement. (O/N, O par défaut)

TMV A2[42]

Ce mouvement ne peut être utilisé qu'en automatique et on interdit son utilisation dans la saisie manuelle des mouvements (O/N, N par défaut)

TMV A2[43]

Edition d'un avis de réception à la validation du mouvement de stock (O/N, N par défaut)

TMV A2[44]

Gestion d'un prix de vente (O/N, N par défaut)

TMV A2[45]

Gestion d'une quantité client

N NON (par défaut)

1 Saisie de la quantité dans une fenêtre

2 Alimentation automatique de la quantité

3 Alimentation automatique de la quantité + Saisie de la quantité dans une fenêtre

TMV A2[46]

Attribution d'un bonus/malus en fonction de l'écart entre les quantités client et réelles (O/N, N par défaut)

TMV A2[47]

Edition d'un bon papier (spécifique) (O/N, N par défaut)

TMV A2[48]

Alimentation zone s0_libre du mouvement de stock

0 Remise à zéro

V Valeur du mouvement de stock
Valeur du mouvement de stock = Quantité du mouvement de stock * Prix du mouvement de stock * Coefficient de conversion de l'article

R laisse la valeur précédente

N Aucune gestion (par défaut)

Les valeurs 0, V et R sont actives si mp_param[30] = V.

TMV A2[49]

Alimentation zone s0_qteclient du mouvement de stock

0 Remise à zéro

Q Quantité du mouvement de stock

R On laisse la valeur précédente

N Aucune gestion (Par défaut)

TMV A2[50,60]

Autorise la ventilation de la quantité dans la visu des stocks

(Cf. aide visu stocks : champs qte_ventil_x)

Valeur alpha 3

TMV A3[1,5] | Mot de passe pour la modification du prix sur un mouvement normal
TMV A3[6] | Contrôle du lot sur mouvement de stock A Contrôle d'un lot affecté Peut être une commande client OU une commande fournisseur, mais la commande doit exister C Contrôle du lot par rapport à une commande client F Contrôle du lot par rapport à une commande fournisseur N Pas de contrôle du lot (blanc] On effectue le contrôle paramétré sur #CFSTK T Contrôle du lot par rapport à un code tiers avec ou sans adresse secondaire Voir le suivi des palettes consignées Le lot doit respecter l'un des formats décrits ci-dessous : CCCCCC CCCCCC-AAA avec CCCCCC = Code client sur 6 caractères et AAA = Code adresse secondaire sur 3 car.
TMV A3[7] | Prix du mouvement à zéro lors d'une entrée en stock N Non autorisé O Autorisé sans confirmation C Autorisé avec confirmation
TMV A3[8] | Saisie du numéro de dossier obligatoire (O/N)
TMV A3[9] | Prise en compte du mouvement dans le calcul du prix de revient O Mouvement pris en compte N Mouvement ignoré dans le calcul
TMV A3[10,12] | Type de mouvement de contrepartie de la sortie Ce type est forcément un mouvement d'entrée Utilisé dans le module de mouvements manuels codes à barres (UC)
TMV A3[13] | Mode de réapprovisionnement du stock C Commande d'achat négoce F Fabrication I Ignoré S Réapprovisionnement sur stock X Commande d'achat sous-traitée
TMV A3[14] | Etat du besoin matière A A traiter I Ignoré T Traité V Validé
TMV A3[15,22] | Centre de coût du type de mouvement de stock
TMV A3[23] | Saisie de l'affectation lors de la création du mouvement de stock (O/N) Voir la note LIB_SAI_AFFECTATION
TMV A3[24] | Modification possible de la date de mouvement par l'outil de gestion des mouvements prévisionnels (O/N, N par défaut)
TMV A3[25] | Contrôle du code de demande de validation de la transaction dans la saisie manuelle des mouvements de stock CAB N Pas de demande de validation (Valeur par défaut) 1 Demande de validation avec OUI par défaut 2 Demande de validation avec NON par défaut
TMV A3[26] | Saisie des notes après la création d'un mouvement de stock Utilisé par stk0 et G_maj_stk N Pas de saisie des notes F Saisie des notes facultative O Saisie des notes obligatoire En création, la valeur par défaut est N. En modification (CONTROL-N), la valeur par défaut est F.
TMV A3[27,29] | Type de mouvement de sortie normale pour régularisation d'inventaire - Obligatoire Utilisé par Interface mouvements de stock et d'inventaire partiel
TMV A3[30,32] | Type de mouvement d'entrée normale pour régularisation d'inventaire - Obligatoire Utilisé par Interface mouvements de stock et d'inventaire partiel
TMV A3[33] | Mise à jour de la quantité fabriquée (N/O, O par défaut) Utilisé dans la déclaration de production si la quantité saisie est négative et différente de -9999.

Notes

CONTROLE_ANNULATION | 21,23 Code contrôle 001 Vérification de l'existence d'un ordre de transport lié à ce mouvement de stock. La présence d'un ordre de transport lié interdit l'annulation du mouvement. 24 Type de contrôle N Pas de contrôle W Demande de confirmation B Contrôle bloquant
LIB_SAI_AFFECTATION | 21 à 25 Libellé de saisie de l'affectation. (Par défaut, Affectation :)
LIEUX_1_2_3 | Recherche hiérarchique des lieux de rangement dans la mise à jour des mouvements de stock sur les programmes de saisie manuelle (stk0) intégration des temps et matières (int_rtm) visualisation des mouvements de stocks (v_stk0) La recherche se fait : 1 sur le paramètre de lancement : soit globale, soit par type d'article (mp_mp : P, S, M, F &.) 2 sur la sous-famille de l'article 3 sur la famille de l'article 4 sur le type de mouvement de stock 5 sur l'article (champs mp_rgt1, mp_rgt2, mp_rgt3) 21,23 Lieu de rangement 1 (magasin) 25,27 Lieu de rangement 2 (Emplacement) 29,31 Lieu de rangement 3 (Emplacement)
M | Lignes de messages. 4 lignes sont autorisées ; la 1ère sera centrée dans la fenêtre.
MAJ_FLAG_INFO_C | Utilisé par le programme de génération des FAD à partir des mouvements de stock 21 Etat de mise à jour (F=Flag/D=Déflag) 22,24 Code du TSC à créer ou à mettre à jour 25 Type de clé du TSC 26,28 Valeur du flag/déflag 29,60 Clé du TSC
NUMERO_LOT_GENERIQ | 21,22 Radical permettant d’identifier les lots génériques (identique à la note RADICAL_LOT_GENERIQ du #CF-STK 23,28 Zone alphanumérique identifiant le lot générique associé à ce TMV 29,32 "001" Voir #CF STK A4[5]


TOL Tolérance de quantité

Exemple 1

- le client est en tolérance +10%

- la commande est de 76

- la livraison est de 85

- la quantité facturée est de 83,6 et le montant de 86,6xPU

ARRONDI_TOL_FAC >1

Quantité facturée 84

ARRONDI_TOL_FAC =1

Quantité facturée 84

ARRONDI_TOL_FAC <1

Quantité facturée 83

Exemple 2

- le client est en tolérance +10%

- la commande est de 75

- la livraison est de 85

- la quantité facturée est de 82,5 et le montant de 82,5xPU

ARRONDI_TOL_FAC >1

Quantité facturée 83

ARRONDI_TOL_FAC =1

Quantité facturée 82

ARRONDI_TOL_FAC <1

Quantité facturée 82

TOL Tolérance de quantité

Valeurs numériques

TOL N1 | Pourcentage de tolérance minimum (sous-production) 10.00 indique que l'on autorise une sous-production de 10 % de la quantité commandée. 0.00 indique que la quantité commandée doit être produite au minimum. La valeur null dans la zone numérique 1 désactive le contrôle de tolérance mini.
TOL N2 | Pourcentage de tolérance maximum (sur-production) 10.00 indique que l'on autorise une surproduction de 10 % de la quantité commandée. 0.00 indique que la quantité commandée doit être produite au maximum. La valeur null dans la zone numérique 2 désactive le contrôle de tolérance maxi

Valeur alpha 1

TOL A1[1]

Type de tolérance

N pas de contrôle

M contrôle sur le minimum livrable

S contrôle sur le maximum livrable

A contrôle sur le minimum et le maximum livrable

TOL A1[2,3]

Tolérance de surproduction PC Topp

Valeur de tolérance de surproduction envoyée à PC Topp

Correspond à la zone 14 du fichier OT-DATA

TOL A1[4]

Type de contrôle

N pas de contrôle

W warning

C Confirmation

B Bloquant (par défaut)

Lors de la saisie d'un BL, la fenêtre de picking affichera uniquement les palettes ayant une quantité inférieure ou égale à la tolérance de livraison si la tolérance àa un type de contrôle bloquant (TOL A1[4]=B). Si aucune palette n'est disponible et s'il y a des palettes ayant une quantité supérieure à la tolérance, une fenêtre de récapitulatif s'ouvrira.

TOL A1[5]

Limiter la quantité facturable à la quantité commandée + pourcentage maximum défini en TOL A1[6,11]

N On ne limite pas la quantité facturable du BL (par défaut)

O On limite la quantité facturable du BL à la quantité commandée + le pourcentage saisi dans les caractères suivants de 6 à 11 mais sans tenir compte des avoirs rattachés à la ligne de commande livrée

A On limite la quantité facturable du BL à la quantité commandée + le pourcentage saisi dans les caractères suivants de 6 à 11 ET en tenant compte des avoirs rattachés à la ligne de commande livrée.

TOL A1[6,11]

Pourcentage de facturation maximum (avec décimales, sous la forme 123.45)

Par défaut : Pourcentage de tolérance maximum défini sur la zone numérique 2

TOL A1[12,14]

Pourcentage objectif

Ex : 5 si on se fixe comme objectif de produire 105% de la quantité prévue.

Plus d'explication dans le #CF OMP

TOL A1[15]

Forçage du contrôle de la quantité livrée d'une ligne de cadencement de livraison par rapport à la quantité commandée de la ligne de commande (N/O, N par défaut)

Par défaut, le contrôle est fait par rapport à la quantité à livrer de la ligne de cadencement de livraison.

Ce contrôle est fait dans la saisie des bons de livraison.

Le même contrôle existe sur QAL A2[31] où il est prioritaire.

TOL A1[16,21]

Pourcentage nécessaire de quantité fabriquée par rapport à la quantité lancée pour la demande du solde de fabrication (999.99)

S'il n'est pas trouvé ici, il sera recherché sur qte_prod A4[1,6].

Notes

ARRONDI_TOL_FAC

Gérer la méthode de l'arrondi sur la tolérance de facturation

21 Méthode d'arrondi

> Arrondi supérieur

= Arrondi le plus proche

< Arrondi inférieur

22,30 Précision de l'arrondi (valeur décimale)

Cliquez ici pour afficher / masquer des exemples

OMP_TOL_QUANTITE_FAB

Gestion des pourcentages de quantités minimum, maximum et objectif à fabriquer

Si cette note n'est pas trouvée ici, elle sera recherchée sur le paramètre #CF OMP.

21,29 Quantité de début

30,38 Quantité de fin

39,44 Pourcentage mini de fabrication (+/- x%)

45,50 Pourcentage maxi de fabrication (+/- x%)

51,56 Pourcentage objectif de fabrication (+/- x%)

PCT_TOL_QTE_ENT_STK

Tolérances des quantités fabriquées sur tolérance de la ligne de FBI

Fonctionnalités

Dans la déclaration de production, lors de la validation de la saisie des quantités fabriquées :

• Permettre de contrôler la quantité produite par rapport à la quantité commandée via un pourcentage de dépassement paramétré sur la tolérance renseigné sur la ligne de commande FBI.
Si la quantité produite est supérieure à la quantité commandée plus le pourcentage de dépassement, permettre de demander la saisie d'un mot de passe. Si celui-ci est correctement renseigné, on enregistre dans le détail de traçabilité l'utilisateur associé.

• Permettre de contrôler la quantité produite par rapport à la quantité commandée via un pourcentage de fabrication nécessaire paramétré sur la tolérance renseigné sur la ligne de commande FBI
Si la quantité produite ne représente pas le pourcentage de la quantité lancée, permettre de demander la saisie d'un mot de passe. Si celui-ci est correctement renseigné, on enregistre dans le détail de traçabilité l'utilisateur associé.

Remarque : Ce fonctionnement existe actuellement (sans gestion de mot de passe) au niveau du paramètre de lancement de la déclaration de production :

• A2[30,34] : Pourcentage de dépassement de fabrication par rapport au commandé (99.99).
Si la quantité fabriquée dépasse la quantité commandée de ce pourcentage, alors demande de confirmation de la saisie.

• A2[35,39] : Pourcentage de fabrication nécessaire par rapport au lancé pour pouvoir solder (99.99).
Si la quantité fabriquée ne représente pas ce pourcentage de la quantité lancée, alors demande de confirmation de la saisie lors du solde de fabrication

Paramétrage

21,25 Pourcentage de dépassement de fabrication par rapport au commandé (99.99).
Si la quantité fabriquée dépasse la quantité commandée de ce pourcentage, alors demande de confirmation de la saisie + demande du mot de passe associé au code paramétré sur les caractères 26 à 28
Par défaut : valeur saisie sur le paramètre de lancement, A2[30,34]

26,28 Code mot de passe qui devra être saisi pour valider la saisie de la quantité produite dans le cadre d'un dépassement
Les utilisateurs associés seront recherchés dans les notes USE commençant par PWD_TOL_QTE_ENT_STK (caractères 21 à 23). S'il existe plusieurs utilisateurs associés à ce code mot de passe, une liste est présentée et l'utilisateur doit être sélectionné manuellement.

29 inutilisé

30,34 Pourcentage de fabrication nécessaire par rapport au lancé pour pouvoir solder (99.99).
Si la quantité fabriquée ne représente pas ce pourcentage de la quantité lancée, alors demande de confirmation de la saisie lors du solde de fabrication + demande du mot de passe associé au code paramétré sur les caractères 35 à 37.
Par défaut : valeur saisie sur le paramètre de lancement, A2[35,39]

35,37 Code mot de passe qui devra être saisi pour valider la saisie de la quantité produite dans le cadre d'un manque
Les utilisateurs associés seront recherchés dans les notes USE commençant par PWD_TOL_QTE_ENT_STK (caractères 25 à 27). S'il existe plusieurs utilisateurs associés à ce code mot de passe, une liste est présentée et l'utilisateur doit être sélectionné manuellement.

Exemples

Voir au bas de cette page.

TEXTE_TOL_LIGNE_BL

Sur chaque ligne de BL, on récupère la tolérance sur la ligne de commande correspondante (ou ligne de cadencement de livraison correspondante si elle existe) et on affiche le code, son libellé et un texte paramétrable.

21,60 Texte à afficher.

Si on veut afficher les quantités min et max, on doit paramétrer les mots clés suivants dans le texte : Q1 et Q2

TOLERANCE_QUANTITE

Permet de paramétrer des tolérances de quantités minimum/maximum selon des plages de quantités

21,33 Borne inférieure de la plage de quantité

34,46 Borne supérieure de la plage de quantité

47,52 Pourcentage de tolérance minimum

53,58 Pourcentage de tolérance maximum

Exemples

• Qté de 0 à 10000  % Tolérance mini : -5, % Tolérance maxi : 10

• Qté de 10001 à 100000  % Tolérance mini : -3, % Tolérance maxi : 8

• Qté de 100001 à 999999  % Tolérance mini : -1, % Tolérance maxi : 2

Remarques

• Les mêmes règles s'appliquent au calcul des quantités minimum (sous-production)/maximum (sur-production).
Voir l'aide en ligne pour plus de détails.

• Par défaut, si la quantité commandée courante n'est dans aucune des plages de quantités paramétrées, on prend les valeurs renseignées sur les zones numériques 1 et 2.

Exemples de paramétrage de la note PCT_TOL_QTE_ENT_

Exemple A - Soit une ligne de commande FBI 12200002-1, de quantité 10000, avec un code tolérance de quantité TOL 010

Paramétrage des notes du code tolérance TOL 010

1 2 3 4

1234567890123456789012345678901234567890

PCT_TOL_QTE_ENT_STK 00010P01 00095P01

Si la quantité fabriquée dépasse la quantité commandée de 10%, alors on demande confirmation à l'utilisateur.

Si la saisie est confirmée, on demande en plus la valeur du mot de passe PWD P01.

Si la quantité fabriquée ne représente pas 95% de la quantité lancée, alors on demande confirmation de la saisie lors du solde de fabrication.

Si la saisie est confirmée, on demande en plus la valeur du mot de passe PWD P01.

Si le mot de passe est correctement saisi, on recherche l'utilisateur associé à ce dernier, puis on enregistre un événement de traçabilité de détail sur la ligne de FBI en cours (uniquement si la traçabilité est activée sur la ligne de commande) :

Nom du champ : depassement_force ou manque_force

Valeur avant : Qté avant : aaaaa – Qté après : bbbbb (où aaaaa est la quantité avant la saisie et bbbbb la quantité après)

Valeur après : Dépassement forcé par : ccccc (ddd/eee) ou Manque forcé par : ccccc (ddd/eee)

(où ccccc est le nom de l'utilisateur associé au mot de passe saisi, ddd est USE et eee le code utilisateur.

Si l'utilisateur n'a pas pu être trouvé, ccccc sera [Utilisateur non trouvé], ddd sera PWD et eee le code mot de passe).

Paramétrage des notes du code tolérance USE U01

1 2 3

1234567890123456789012345678901

PWD_TOL_QTE_ENT_STK P01 P01

L'utilisateur USE U01 est associé au mot de passe PWD P01 :

• Pour le forçage du dépassement de quantité fabriquée

• Pour le forçage du manque de quantité fabriquée

Principe de fonctionnement de l'exemple A ci-dessus

1. Lors de la déclaration de production de la commande de fabrication 12200002-1, on saisit 10 palettes de 1 250.
Le pourcentage de tolérance de quantité pour le dépassement est de 10%, soit une quantité maximale de 10 000+10% = 11 000.

2. La quantité produite 12500 étant au-dessus de la quantité maximale tolérée, on demande confirmation à l'utilisateur.
L'utilisateur confirme la saisie, on demande alors la valeur du mot de passe PWD P01.

3. Le mot de passe est correctement saisi, on recherche alors tous les utilisateurs associés à celui-ci parmi les codes utilisateurs USE contenant la note PWD_TOL_QTE_ENT_STK. Il n'en existe qu'un : U01, on récupère son nom, par exemple : Utilisateur 001.

4. Si la traçabilité de la ligne de commande (cde2) est activée, on créé un enregistrement de détail sur la ligne de commande 12200002-1 :

a) te_nom_champ : depassement_force

b) te_valeur_avant : Qté avant : 0 – Qté après : 12500

c) te_valeur_apres : Dépassement forcé par : Utilisateur 001 (USE/U01)

Exemple B - Soit une ligne de commande FBI 12300002-1, de quantité 10000, avec un code tolérance de quantité TOL 020.

Paramétrage des notes du code tolérance TOL 020

1 2 3 4

1234567890123456789012345678901234567890

PCT_TOL_QTE_ENT_STK 00020P02

Si la quantité fabriquée dépasse la quantité commandée de 20%, alors on demande confirmation à l'utilisateur.

Si la saisie est confirmée, on demande en plus la valeur du mot de passe PWD P02.

Pas de contrôle lors de la mise en place du solde de fabrication.

Paramétrage des notes du code utilisateur USE U02

1 2 3

1234567890123456789012345678901

PWD_TOL_QTE_ENT_STK P02

L'utilisateur USE U02 est associé au mot de passe PWD P02 pour le forçage du dépassement de quantité fabriquée.

Paramétrage des notes du code utilisateur USE U03

1 2 3

1234567890123456789012345678901

PWD_TOL_QTE_ENT_STK P02

L'utilisateur USE U03 est associé au mot de passe PWD P02 pour le forçage du dépassement de quantité fabriquée.

Paramétrage des notes du code utilisateur USE U04

1 2 3

1234567890123456789012345678901

PWD_TOL_QTE_ENT_STK P02

L'utilisateur USE U04 est associé au mot de passe PWD P02 pour le forçage du dépassement de quantité fabriquée.

Principe de fonctionnement de l'exemple B ci-dessus

1. Lors de la déclaration de production de la commande de fabrication 12300002-1, on saisit 10 palettes de 1 250.
Le pourcentage de tolérance de quantité pour le dépassement est de 20%, soit une quantité maximale de 10 000+20% = 12 000.

2. La quantité produite 12 500 étant au-dessus de la quantité maximale tolérée, on demande confirmation à l'utilisateur.
L'utilisateur confirme la saisie, on demande alors la valeur du mot de passe PWD P02.

3. Le mot de passe est correctement saisi, on recherche alors tous les utilisateurs associés à celui-ci parmi les codes utilisateurs USE contenant la note PWD_TOL_QTE_ENT_STK. Il en existe trois : U02, U03 et U04.

4. Une fenêtre s'ouvre afin de sélectionner l'utilisateur ayant autorisé le forçage parmi les codes utilisateurs trouvés.
Une fois celui-ci sélectionné, on récupère son nom, par exemple si on a sélectionné le code U03 : Utilisateur 003.
Remarque : Si l'utilisateur n'est pas sélectionné dans la liste proposée, on demande confirmation à l'utilisateur.
Il est alors possible de modifier le paramétrage afin d'ajouter des utilisateurs associés au code mot de passe (PWD) en cours.
Une fois le paramétrage ajouté, il suffit de répondre Non à la demande de confirmation pour reconstruire la liste et la réafficher.

5. Si la traçabilité de la ligne de commande (cde2) est activée, on créé un enregistrement de détail sur la ligne de commande 12200002-1 :

a. te_nom_champ : depassement_force

b. te_valeur_avant : Qté avant : 0 – Qté après : 12500

c. te_valeur_apres : Dépassement forcé par : Utilisateur 003 (USE/U03)


TOP Top de facturation

TOP Top

Valeurs numériques

TOP N1 | Année en cours (Exemple 2004)
TOP N2 | Le mois en cours (Exemple 02)

Valeur alpha 1

TOP A1[1,10]

Date du top sous la forme JJ/MM/AAAA

(Exemple 28/02/2002)

TOP A1[11,13]

Nombre de jours maximum autorisés par rapport à la date de saisie pour donner une borne maximale à la date de saisie des stocks

Ne fonctionne que si l'option Ofp est positionnée sur le programme maj_stj.

Exemple : si vous mettez 30, l'utilisateur ne peut plus saisir une date supérieure de plus de 30 jours à aujourd'hui. (Permet d'éviter les erreurs de saisie du type 19/05/4004)

Paramètre utilisé en facturation - Gestion du Mois en Cours

Le code paramètre est paramétrable en facturation, ce qui permet de définir, par exemple, un TOP de facturation par site.

Tableau de bord du multisite

Lors de la première utilisation, ce paramètre doit être initialisé.

C'est par la suite l'opération de top de fin de mois qui viendra automatiquement incrémenter les valeurs du mois et de l'année en cours.

Si un mois est clôturé par erreur (malgré les différents contrôles et demandes de confirmation !), il est toujours possible de venir modifier les valeurs de ce paramètre.

Paramètre utilisé en facturation comptoir : TOP FAS (type et code figés)

Valeurs numériques 1 & 2 : année & mois de facturation

Paramètre utilisé en régénération de dossier : TOP RGD (type et code figés)

Permet la régénération en batch de tous les dossiers régénérables dont la date de fabrication prévue est supérieure ou égale à la date paramétrée.

Le TOP RGD est mis à jour manuellement à chaque mise à jour de taux horaires, de prix matière, ...

Paramètre utilisé en fin de mois : TOP FIN (type et code figés)

Permet d'interdire de créer, de modifier ou d'annuler

  • un mouvement de stock manuel

  • un mouvement de transfert de stock

  • une déclaration de production

  • une réception de commande fournisseur

  • une saisie de facture de sous-traitance

  • une livraison d'un article stocké

  • un contrôle de facture fournisseur

dont la date est inférieure ou égale à la date saisie.

Le TOP FIN est mis à jour manuellement.


TOU Code tournée

Valeur alpha 1

TOU A1[1,3] | Code tournée Correspondance utilisée pour le transfert des tiers JDE. La valeur est obligatoire mais non contrôlée.
TOU A1[4,6] | Code environnement matière par défaut pour le devis multi-métiers

Notes

VALIDITE_OFFRE

Durée de validité d'une offre de prix

Edition libellé spécifique sur PRX XXX

Exemple fin octobre


TPA Types de pages

Utilisé dans le devis arts graphiques pour déterminer les coûts de photogravure en fonction des différents types de page.


TPI Type de passage d'impression

Ce paramètre est utilisé dans le devis multi-métiers

Valeur alpha 1

TPI A1[1] | Face de passage R Recto (par défaut) V Verso 2 Recto/Verso
TPI A1[2] | Contrôler la saisie de la ligne d'impression : le nombre de couleurs ou le type de vernis doit être saisi (O/N, O par défaut)

Notes

#CC_

Contrôle des champs

Voir la page récapitulative

CODES_TIC_LIGIMP

21,59 Liste des codes paramètres de TIC saisissables sur les lignes d'impression multiple

Par défaut : Les types d'informations complémentaires du programme sont utilisés (argument –D sur le paramètre de lancement)

13 codes de 3 caractères par ligne

LIB_LIGIMP_PC_VERNIS

21,60 Libellé de la colonne Pourcentage de vernissage

Par défaut : % Ve.

Si cette note n'est pas trouvée ici, alors on ira la chercher sur le TEN.

_SUP_SQL_MACHINE

21,60 Complément de sélection pour la recherche du code machine (touche F7)

Ce complément de sélection est également utilisé pour la vérification du code machine saisi par l'utilisateur.

Par défaut : Complément de sélection des machines d'impression de l'entité, voir le type de paramètre TEN, note _SUP_REQ_MAC_IMP. Dans ce cas, le code machine saisi doit correspondre à une machine d'impression.

LIB_LIGIMP_VERNIS

21,60 Libellé de la colonne Type de vernis

Par défaut : Type de vernis

Si cette note n'est pas trouvée ici, alors on ira la chercher sur le TEN.

_SUP_SQL_VERNIS

21,60 Complément de sélection sur la table par02 pour le type de vernis

(liste déroulante et recherche par F7 sur la colonne Type de vernis)


TPP Type de pré-presse

Valeur alpha 1

TPP A1[1] | Type de pré-presse associé T Traditionnel P Computer to Plate F Computer to Film N Pas de pré-presse
TPP A1[2,7] | Code machine associée à ce type de pré-presse


TPR Types de processus

Dans la saisie des devis multi-métiers, permettre de paramétrer les valeurs et leurs libellés correspondant des champs de présence sur référence multiple.

Pour chacun de ces champs et pour chaque valeur possible du champ, il est possible d'associer :

• La valeur numérique associée (pour le code calcul RF)

• La prise en compte de cette valeur pour l'éclatement des amalgames

• Un libellé court (affiché dans la liste déroulante de la saisie des références multiples)

• Un libellé long (récupérable dans la visualisation des devis et dans les éditions VoluEdit)

Remarques :

Si le champ de présence n'a aucune valeur paramétrée, les valeurs possibles sont celles par défaut : Hors-ligne/en Ligne/Sous-traitée/Non

Le nombre de valeurs paramétrable n'est pas limité. Cependant, si la valeur numérique associée est utilisée (code calcul RF), le nombre de valeurs est limité à 10 (0 à 9)

La valeur par défaut lors de la création d'une nouvelle ligne de référence multiple est la valeur associée à la valeur numérique 0 (par défaut : Non)

Les libellés paramétrés pour chaque valeur possible sont accessibles dans les catalogues VoluEdit permettant d'éditer les références multiples (offre de prix et ordre d'exécution).

TPR Types de processus - Types de produits

Valeurs numériques

TPR N1 | Prise de pince LAIZE
TPR N2 | Prise de pince COUPE

Valeur alpha 1

TPR A1[1,8] | Numéro de devis par défaut à utiliser lors d'une recopie/génération
TPR A1[9,11] | Type du produit (figé) (saisie type obligatoire pour devis carton ondulé)
TPR A1[12,14] | Caractéristique du processus (utile pour regrouper des processus)
TPR A1[15,17] | Code du LCO-1 utilisé dans la recherche des gâches intermédiaires. Cette fonctionnalité est accessible uniquement sur la formule ### #AU.
TPR A1[18,20] | Code du LCO-2 utilisé dans la recherche des gâches intermédiaires. Cette fonctionnalité est accessible uniquement sur la formule ### #AU.
TPR A1[21,23] | Type de produit (utilisé pour l'optimisation) BCO Brochure cousu BLO Bloc BRO Brochure BSC Brochure sans couture CAR Carnet CCO Cartonné cousu (Reliure cousue) COR Collé rogné (anciennement ROG CSC Cartonné sans couture (Reliure collée) DEP Dépliant FEU Feuillet GAR Garde LIA Liasse PIQ Piqûre ROG Rogné
TPR A1[24,29] | Paramétrage de la gâche de finition (ex: ####GF) Si alpha1[45] du #CFDEG = P, code formule permettant de retrouver les dépendances par rapport à l'opération IMF IMF GF (par défaut ### #GF) Si alpha1[45] du #CFDEG = L, (pour lire les gâches sur une ligne LCO) : en 24 à 26 : code LCO où on lit les gâches en 27 : zone de la LCO où on lit la gâche fixe (1 ou 2) (la zone de la gâche variable est déduite)
TPR A1[30] | Gestion du conditionnement activée O/N (N par défaut)
TPR A1[31,33] | Code de la sous-famille pour la création automatique des articles du devis (devis feuilles sauf TC et DCO)
TPR A1[34,48] | Code de l'article par défaut pour la création automatique des articles du devis (devis feuilles sauf TC et DCO)
TPR A1[49] | En devis mono-référence, les ensembles sont situés sur les lignes de niveau 1 de la nomenclature (et non sur le devis) (O/N, N par défaut)
TPR A1[50] | Gestion des amalgames (O/N, N par défaut) Attention : réservé à l'imprimerie car génère des automatismes incompatible avec les autres métiers.

Valeur alpha 2

TPR A2[1]

Pour la recherche des gammes standard (devis_tc)

Recherche de gamme autorisée (O/N, N par défaut)

TPR A2[2]

Pour la recherche des gammes standard (devis_tc)

Type de produit nécessitant une découpe (O/N) (N par défaut)

Permet d'écarter les gammes ne gérant pas la découpe (Flag sur entête de gamme standard)

TPR A2[3]

Pour la génération des PF (devis_tc) Voir #CF GPF

Création du composant autorisée en génération automatique du PF (O/N, O par défaut)

TPR A2[4]

Pour la génération des PF (devis_tc) Voir #CF GPF

Ouverture automatique de la fenêtre de saisie du coefficient de nomenclature dans le devis TC

(O/N, N par défaut)

TPR A2[5]

Confirmation de la génération de la nomenclature (O/N)

La valeur par défaut dépend de #CF GPF, alpha2[3]

TPR A2[6]

Initialisation automatique de la quantité en création d'entité

O La quantité est initialisée automatiquement en prenant :

Quantité entité = Quantité du devis – Somme des quantités des entités précédentes

N Aucune initialisation automatique

TPR A2[7]

Type d'automatisme à mettre en oeuvre pour initialiser par défaut la zone de collage de la ligne de référence multiple

1 S'il existe une ligne de référence de même type (même code ECMA et mêmes dimensions), la ligne de référence de collage est initialisée avec la ligne de référence trouvée.

0 Aucune automatisme (par défaut)

TPR A2[8]

Saisie d'un devis de type PLV

O Devis de type PLV sans permission de saisie de nouvelles références (F14)

R Devis de type PLV avec permission de saisie de nouvelles références (F14)

N Pas de gestion PLV (par défaut) (ne doit pas être utilisé en gestion d'amalgame)

Les valeurs O ou R sont obligatoires pour gérer la nomenclature multi-niveaux dans la génération de produits.

Devis multi-métiers : Pour les valeurs O et R, la génération de la partie fixe est désactivée lors de la génération des tarifs des produits de premier niveau de la nomenclature PLV (#CF TAR A1[48]).

TPR A2[9]

Un seul sous-niveau est autorisé dans la saisie de nomenclature (O/N, N par défaut)

01

-01

TPR A2[10]

Habillage

H Habillage

N pas d'habillage (par défaut)

TPR A2[11]

Mise à jour du code produit de l'entité avec celui de la référence unique ( O/N, N par défaut)

TPR A2[12]

Cacher le bloc détail dans la saisie de la nomenclature multi-niveaux (O/N, N par défaut)

TPR A2[13]

Recalcul automatique du devis avant l'accès au récapitulatif des coûts (O/N, N par défaut)

TPR A2[14]

On cache le bloc des informations générales dans la saisie des références multiples (O/N, N par défaut)

TPR A2[15]

On cache le bloc des informations d'impression dans la saisie des références multiples (O/N, N par défaut)

TPR A2[16]

Création et/ou accès aux entités à partir de l'écran de saisie des références multiples d'entête (nouvel enchaînement des écrans pour les devis PLV) (O/N, N par défaut)

TPR A2[17]

Contrôle du devis ouvert pour les articles non génériques

N Pas de contrôle (par défaut)

C Demande de confirmation

W Contrôle non bloquant

B Contrôle bloquant (un produit associé à un devis ne pourra en aucun cas être saisi sur un autre devis que le sien)

TPR A2[18]

Reprise des valeurs des double-coupes de la première référence

O Systématiquement

C Sur confirmation uniquement

N Non (par défaut)

Permettre de définir la première référence saisie comme modèle pour les valeurs de double-coupes.

• Lors de la création d'une nouvelle référence, les valeurs de double-coupes peuvent automatiquement être reprises.

• Lors de la modification des valeurs des double-coupes de la première référence, ces valeurs peuvent être propagées à toutes les autres références.

TPR A2[19,21]

Critère de matrice associée à ce type de processus (doit correspondre à un paramètre de type #MA)

Par défaut : DEC

TPR A2[22]

Création d'une autre entité ? (O/N/I)

O Une fenêtre propose de créer une autre entité, avec le bouton Oui par défaut.

N Une fenêtre propose de créer une autre entité, avec le bouton Non par défaut.

I La fenêtre de proposition de création d'une autre entité ne s'affiche pas.

Ce paramètre est prioritaire sur celui de #CF DEG A1[16].

Selon le type de produit on peut indiquer si l'on souhaite que le devis soit mono entité ou plusieurs entités.

TPR A2[23]

Recopie automatique des désignations (O/N, N par défaut)

Dans la saisie du devis multi-métiers, permettre de recopier automatiquement :

• La désignation 1 de l'entête du sous-devis (fle_2.l2_desdev1)
dans la désignation des références multiples (fle_dec.de_designation).

• La désignation 2 de l'entête du sous-devis (fle_2.l2_desdev2)
dans la référence client des références multiples (fle_dec.de_ref_client).

• La désignation de la référence multiple (fle_dec.de_designation)
dans la désignation de l'entité associée à la référence (fle_imp.fi_d_entite).

IMPORTANT : La désignation de la référence est mise à jour uniquement si le produit associé de la référence est générique (mp_param[25] = O) et non temporaire (QA A1[38] = N).

Dans le cas contraire, la désignation de la référence est mise à jour avec la désignation du code produit saisi.

IMPORTANT : La zone cible est mise à jour uniquement si elle n'est pas renseignée (attention aux valeurs par défaut) ou si la valeur actuelle est identique à la valeur source précédente (avant modification).

TPR A2[24]

Dans la saisie des références multiples, recopie des notes de la référence précédente lors de la recopie (Control-G)

Lors de la création d'une nouvelle référence :

O Recopie systématique des notes

A Recopie systématique des notes

C Recopie des notes sur confirmation

N Pas de recopie des notes (par défaut)

Sur une référence existante :

O Recopie systématique des notes si aucune note n'existe sur la référence courante.
Si une note existe déjà, recopie des notes sur confirmation d'écrasement.

A Recopie des notes uniquement si aucune note n'existe sur la référence courante.

C Recopie des notes sur confirmation (ajout d'une information au message de confirmation si une note existe déjà)

N Pas de recopie des notes (par défaut)

Valeur alpha 3

TPR A3[1] | Ouverture automatique de la fenêtre de saisie du coefficient de nomenclature (devis_tc) O L' ouverture est automatique N Pas d'ouverture automatique [défaut]
TPR A3[2] | Type de recherche de devis dans la saisie des lignes d'offre de prix (offre_de_prix) N Recherche normale (par défaut) O Recherche des devis avec visualisation des variantes V Recherche par la visualisation des devis P Recherche des devis transformateur cartonnier avec visualisation des variantes T Recherche des devis transformateur cartonnier
TPR A3[3] | Méthode d'affichage de la fenêtre de résultat de la recherche d'entité - GENERO uniquement P Produit • Code produit • Quantité de l'entité I Imprimerie (par défaut) • Largeur • Longueur • Coût recto • Coût verso • Pages

Valeur alpha 4

TPR A4[1,6]

Type et code de paramètre de lancement de la saisie de devis (pour la saisie d'offres de prix).

TPR A4[7]

Type de saisie de devis dans la saisie des offres de prix nomenclaturées

O Le devis est unique pour toute la saisie (on prend le devis de la ligne d'entête)

N Les devis saisis sur les lignes peuvent être différents

TPR A4[8,10]

Code d'entité par défaut (correspond à un TEN par défaut)

TPR A4[11]

Gestion de la nomenclature multi-niveaux et ouverture automatique de la nomenclature après la saisie des quantités

C Ouverture en création uniquement, après la saisie de quantité

T Ouverture systématique, après la saisie de quantité

D Ouverture systématique, après la recopie d'un sous-devis

2 Ouverture systématique, après la recopie d'un sous-devis et après la saisie de quantités

N Pas de gestion de la nomenclature

O Gestion de nomenclature sans ouverture automatique

TPR A4[12]

Gestion des références multiples (Accès à l'écran) (O/N)

Ce paramètre est important pour les gâches cumulatives.

Pour l'imprimerie, la valeur doit être à N (gestion de la décomposition de la feuille en plusieurs cahiers).

TPR A4[13]

Ouverture automatique de la saisie du FEFCO / ECMA après le champ hauteur de l'écran de références multiples (O/N)

TPR A4[14]

Accès au détail de ligne pour un article non générique dans l'écran des références multiples (O/N)

TPR A4[15]

Cacher les lignes de totalisation dans l'écran de visualisation de détail des phases (accès par F18) (O/N/F/G)

O Toutes les lignes de totalisation sont cachées.

N Toutes les lignes de totalisation sont affichées (par défaut).

F Seules les lignes de totalisation type de formule, entité et générale sont affichées.

G Seules les lignes de totalisation entité et générale sont affichées.

TPR A4[16]

Ouverture automatique de la saisie des références multiples après la saisie de la quantité du devis

C En création uniquement

T Toujours

E Pas d'ouverture automatique, la saisie des informations FEFCO/Dimensions est possible au niveau des références d'entité.

N Jamais (par défaut)

2 Ouverture après la saisie de la nomenclature (si la saisie de nomenclature ne s'ouvre pas, la saisie des références multiples ne s'ouvrira pas non plus. Voir TPR A4[11]

TPR A4[17]

Dans la saisie de la nomenclature, activer la vérification du nombre de pages saisies au total par rapport au nombre de page sur le devis (O/N)

TPR A4[18]

L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E

TPR A4[19]

L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E

TPR A4[20]

L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E L I B R E

TPR A4[21]

Ouverture de l'écran des phases

O Pas d'ouverture de l'écran des phases après la saisie des entités

N Ouverture (par défaut)

TPR A4[22]

Recalcul automatique à la création d'une variante de quantité (O/N, N par défaut)

TPR A4[23]

Proratisation des quantités des références multiples si la quantité du devis ou d'une entité est modifiée

O La quantité des références multiples est toujours proratisée

N La quantité des références multiples n'est jamais proratisée

C Une demande de confirmation

D La quantité des références multiples n'est jamais proratisée si le devis courant fait l'objet d'une demande de modification. Dans le cas contraire, la quantité est toujours proratisée (équivalent à la valeur O).

M La quantité des références multiples n'est jamais proratisée si le devis est multi-références.
Si le devis est mono-référence ou sans référence, la quantité est toujours proratisée (équivalent à la valeur O).
De même, lors de la génération des variantes de quantités, la proratisation est effectuée.

TPR A4[24,29]

Type et code du paramètre de la configuration de génération des PF

Les type et code du paramètre de configuration de génération des PF sont récupérés dans l'ordre suivant :

1. TPR A4[24,29] (ici)

2. Devis standard, paramètre de lancement, A2[7,12]

3. par défaut, #CF GPF

TPR A4[30]

Ouverture automatique de la saisie des références multiples après la saisie du nombre de références dans l'écran des entités

Ce paramétrage, s'il existe, devient prioritaire sur TEN A4[15]

C En création uniquement

T Toujours

N Jamais (par défaut)

TPR A4[31]

Ouverture automatique de la saisie des LCO lors du premier calcul d'une entité (O/N, N par défaut)

TPR A4[32]

Gestion des références multiples en saisie de devis mono-référence (O/N, N par défaut)

TPR A4[33]

Ouverture automatique de la saisie des lignes complémentaires après la saisie de la nomenclature sur l'entête du devis (O/N, N par défaut)

TPR A4[34]

Le cassage est autorisé pour ce type de processus

La saisie du caractère O dans le valeur 1 de la ligne complémentaire #CA ne sera pas interdite.

TPR A4[35]

L'épaisseur du dos de l'ouvrage déterminée par l'optimisation est sauvegardée dans l'entité de type COU

TPR A4[36]

Mise à jour de la pagination et du format fini de l'entête à partir de la saisie faite sur l'écran entité (O/N)

TPR A4[37]

Sauvegarde du devis initial dans la nomenclature (O/N, O par défaut)

Pas de sauvegarde du devis initial dans la nomenclature : utile pour les feuillets, affiches

TPR A4[38]

Affichage du détail entité dans l'écran de saisie des marges (F21 : récapitulatif devis) (O/N, O par défaut)

Permet de ne pas afficher le détail d'entité sur l'écran de saisie des marges (Type, Nombre de pages, etc).

TPR A4[39]

Incrémentation des numéros de références lors de l'insertion automatique d'une nomenclature (O/N, N par défaut)

TPR A4[40]

: Type de regroupement pour la création automatique de la décomposition de l'entité 99 - Utilisé par devis.4ge

G Regroupement par grammage et code pli

P Regroupement par code pli

N Pas de regroupement (par défaut)

GENERO : Remise en place des codes produits d'origine (si renseignés)

T Les codes produits sont remis en place systématiquement

C Les codes produits sont remis en place si l'utilisateur donne confirmation (la demande de confirmation apparaît une seule fois, au premier produit concerné)

N Pas de remise en place des codes produits (par défaut)

TPR A4[41]

Contrôle des quantités à la validation du devis (via la touche F6)

N Pas de contrôle (par défaut)

E Contrôle des quantités de type devis/entités (voir ci-dessous, contrôle 1)

R Contrôle des quantités de type références (voir ci-dessous, contrôles 2 et 3)

2 Contrôle des quantités de type devis/entités et de type références (voir ci-dessous, contrôles 1, 2 et 3)

Permet de contrôler les différentes quantités d'un devis à la validation d'un devis (touche F6) :

Contrôle 1 : Contrôle de la somme des quantités des entités par rapport à la quantité totale du devis

Contrôle 2 : Contrôle de la somme des quantités des références d'entête du devis par rapport à la quantité totale du devis

Contrôle 3 : Contrôle de la somme des quantités des références sur les entités par rapport à leur quantité renseignée sur l'entête du devis

Voir aussi USE A3[56] et TEN A3[7]

TPR A4[42]

Accès à la saisie du détail des références multiples après la saisie du code article

C Accès en création à la saisie du libellé uniquement

T Accès systématique à la saisie du libellé uniquement

1 Accès en création à la saisie complète du détail

2 Accès systématique à la saisie complète du détail

N Pas d'accès au détail en automatique (par défaut)

TPR A4[43]

Lorsqu'un produit d'une ligne de référence multiple est modifié pour passer d'un code non générique à générique ou non encore généré, remettre en place les codes produits génériques d'origine sur les entités associées

O Les codes produits des entités associées sont modifiées systématiquement

C Les codes produits des entités associées sont modifiées sur confirmation

N Les codes produits des entités associées ne sont pas modifiés (par défaut)

TPR A4[44]

Permet de lancer le calcul de l'entête du devis à la validation de l'écran de saisie de la nomenclature (équivalent à la touche F11 sur la saisie de l'entête du devis).

N Pas de recalcul (par défaut)

D Recalcul systématique du devis complet

S Recalcul systématique du sous-devis courant

C Recalcul systématique avec demande de confirmation permettant de sélectionner si celui-ci concerne tous les sous-devis ou seulement le sous-devis courant (si le devis ne comporte qu'un seul sous-devis, aucune demande de confirmation n'apparaîtra)

TPR A4[45]

Saisie autorisée d'un numéro de référence sur une ligne de nomenclature de type Pdt (Produit) (O/N, O par défaut)

TPR A4[46]

Associer automatiquement toutes les références saisies au niveau de l'entête à l'entité réelle

Devis mono entité réelle uniquement

O Association systématique

C Association sur demande de confirmation

N Aucune association (par défaut)

Dans le devis multi-métiers, permet d'associer automatiquement toutes les références multiples saisies au niveau de l'entête sur l'entité réelle existante (hors entités de façonnage).

Remarques :

• L'association se fait à la validation de la saisie des références multiples au niveau de l'écran d'entête du devis multi-métiers.

• L'association n'est faite que si le sous-devis courant est mono entité réelle (les entités de façonnage/pré-façonnage ne sont pas prises en compte, voir le paramétrage TEN A1[31,33] et TEN A2[13].

TPR A4[47]

Action à accomplir lors de la recopie d'une ligne de nomenclature (Control-G)

G Génération systématique d'une nouvelle entité par recopie de l'entité par défaut renseignée sur le type d'entité
(TEN A2[1,12])

R Recopie systématique de l'entité d'origine

C Demande de confirmation : Génération, recopie ou association

N Non (Par défaut) - Association systématique à l'entité de la ligne d'origine

TPR A4[48]

Afficher l'écran récapitulatif des modifications apportées aux références multiples lors de la validation de la saisie de la nomenclature (O/N, O par défaut)

Remarque : Cet écran récapitulatif ne s'affiche pas lors de la création de la nomenclature.

TPR A4[49]

Méthode de proratisation des quantités des références multiples lorsqu'une même référence est associée à plusieurs entités

O On proratise systématiquement

C Demande de confirmation (par défaut)

N On ne proratise jamais

TPR A4[50,55]

Type et code du paramètre de configuration de l'intégration des produits finis

Les type et code du paramètre de configuration d'intégration des produits finis sont récupérés dans l'ordre suivant :

1. TPR A4[50,55] (ici)

2. Devis multi-métiers, paramètre de lancement, A2[13,18]

3. par défaut, #CF IPF

Notes triées

ACCES_ENTITE_LIGNOM

Type de ligne associé à une entité et accès automatique au détail de nomenclature

O Pour le type de ligne saisi, les colonnes Type d'entité et Génération sont accessibles.
L'accès au détail de la nomenclature se fait automatiquement à la validation du dernier champ.

N Pour le type de ligne saisi, les colonnes Type d'entité et Génération ne sont pas accessibles.
L'accès au détail de la nomenclature se fait manuellement.

I Le type de ligne n'est pas saisissable (il n'apparaîtra pas dans la liste).

Types paramétrables

21 pour les lignes de type E (Entité) (O/N/I, O par défaut)

22 pour les lignes de type V (Version) (O/N/I, N par défaut)

23 pour les lignes de type R (Repiquage) (O/N/I, N par défaut)

24 pour les lignes de type L (Roulage) (O/N/I, O par défaut)

25 pour les lignes de type D (Descriptive) (O/N/I, N par défaut)

26 pour les lignes de type P (Produit) (O/N/I, N par défaut)

60 Valeur par défaut dans le cas d'une création de ligne de nomenclature

E/V/R/L/D/P, pas de valeur par défaut

Voir la note TYPES_GENERE_LIGNOM

ACCES_TARIF_PRODUIT

Permet de visualiser les tarifs de produits dans le devis multi-métiers (via les écrans de récapitulatif de prix)

21 Type de saisie des tarifs :

2 Recherche sur les données techniques

3 Saisie simplifiée (code client devis) (par défaut)

4 Saisie simplifié (code fournisseur produit)

22 Produit source du tarif

E Les tarifs sont saisis sur les ensembles

P Les tarifs sont saisis sur les produits simples (par défaut)

23,28 Type et code du paramètre de configuration de saisie des tarifs

BLANC_BARBE

21,26 Valeur par défaut du blanc de barbe

BLANC_PIED

21,26 Valeur par défaut du blanc de pied

BLANC_PLI

21,26 Valeur par défaut du blanc de pli (grecquage)

BLANC_TETE

21,26 Valeur par défaut du blanc de tête

#CC

Contrôle des champs

Voir la page récapitulative

CODE_LIEN_TPR_TDF

21,23 Code lien entre tables (#LI) utilisé pour faire le lien entre le type de processus (TPR) et le type de finition (TDF)

Permet de définir les types de finition utilisables par le type de processus courant.

CODE_LIEN_TPR_TFE

21,23 Code paramètre de type #LI correspondant au lien entre les paramètres TPR et TFE

Si ce paramétrage n'est pas saisi, tous les types de façonnage d'encart seront autorisés pour ce type de processus.

CONFIG_PAR_CHAR_1

21 Source de la donnée à saisir dans la zone paramétrée alphanumérique 1

A Code article

L Libre (par défaut)

22 Si la source est un article (A) :

Type de recherche article

1 Recherche normale (par défaut)

2 Recherche sur les données techniques

3 Recherche papier

5 Recherche des produits sur fournisseur

Q Recherche qualité carton

T Recherche transformateur

Si la source est libre (par défaut) :

La recherche sur le champ est désactivée.

23 Saisie de la zone obligatoire (O/N, N par défaut)

Voir les notes LIB_ZONE_PAR_CHAR_1 et _SUP_SQL_PAR_CHAR_1.

DEPASSANT

21,26 Valeur par défaut du dépassant

DOCUMENT_WIN_DEFAUT

21,60 Chemin d'accès Windows au fichier à ouvrir sur les champs de l'entête de devis autres que ceux réservés (numéro de devis, numéro de sous-devis)

Il est possible d'utiliser les caractères réservés suivants pour remplir automatiquement le nom de fichier à l'exécution :

?02 : Code client

?03 : Devis_Sous-devis (sous la forme DDDDDDDD_SS)

La même note existe aussi sur le TEN.

FOR_POIDS_TRANSPORT

21 Méthode de recherche pour le calcul du poids du transport

T Recherche sur formule en utilisant le code calcul RT (Recherche données matières pour la formule de transport paramétrable, par défaut)

M Recherche sur formule en utilisant le code calcul RM (Recherche données matières pour la formule de transport paramétrable)

22,24 Code phase, correspond aux caractères 1 à 3 du code calcul RM/RT

25,27 Code formule, correspond aux caractères 4 à 6 du code calcul RM/RT

28 Rubrique, correspond au caractère 7 du code calcul RM/RT

Voir aussi

#CF DER A3[1,8]

UNI note FOR_POIDS_TRANSPORT

UNI A1[11,18]

LIB_DESIGNATION_1

21,60 Libellé de la désignation 1

LIB_DESIGNATION_2

21,60 Libellé de la désignation 2

LIBELLE_REFERENCES

21,60 Libellé de la zone de nombre de références

LIB_LIE_

Activation et libellé des références liées par finition

Voir les notes #CC_REFLIG dans le devis standard

9,20 Type de finition

BRAILLE Braille

DECOUPE Découpe

DORURE Dorure

FENETRAGE Fenêtrage

FOULAGE Foulage

GAUFRAGE Gaufrage

HOLOGRAMME Hologramme

RAINAGE Rainage

TRANSFERT Transfert/Poudrage

VIGNETTE Vignette

21 Activer la liaison des références par le type de finition concernée (O/N, N par défaut)

22,30 Libellé de la colonne (entête de tableau). Par défaut :

BRAILLE R.Bra.

DECOUPE R.Déc.

DORURE R.Dor.

FENETRAGE R.Fen.

FOULAGE R.Fou.

GAUFRAGE R.Gau.

HOLOGRAMME R.Hol.

RAINAGE R.Rai.

TRANSFERT R.Trf.

VIGNETTE R.Vig.

31,60 Commentaire de la colonne (texte affichée en bas à gauche de l'écran). Par défaut :

BRAILLE Numéro de référence liée par le braille

DECOUPE Numéro de référence liée par la découpe

DORURE Numéro de référence liée par la dorure

FENETRAGE Numéro de référence liée par le fenêtrage

FOULAGE Numéro de référence liée par le foulage

GAUFRAGE Numéro de référence liée par le gaufrage

HOLOGRAMME Numéro de référence liée par l'hologramme

RAINAGE Numéro de référence liée par le rainage

TRANSFERT Numéro de référence liée par le transfert/poudrage

VIGNETTE Numéro de référence liée par la vignette

LIB_REF_BRAILLE

21,60 Libellé pour la colonne Présence de braille dans l'écran des références multiples

Par défaut : Brai.

LIB_REF_COLLAGE

21,60 Titre de la colonne Collage. Par défaut : Collage

Voir exemple à la fin des notes

LIB_REF_COULEURS

21,60 Libellé des zones de saisie du nombre de couleurs (recto/verso)

Par défaut : Couleurs

LIB_REF_COULEURS_R

21,60 Libellé de la zone de saisie du nombre de couleur au recto

Par défaut : Recto

LIB_REF_COULEURS_V

21,60 Libellé de la zone de saisie du nombre de couleur au verso

Par défaut : Verso

LIB_REF_DEVELOPPE

21,60 Libellé des zones de saisie du format développé

Par défaut : Format développé

LIB_REF_DORURE

21,60 Titre de la colonne Dorure. Par défaut : Dorure

Voir exemple à la fin des notes

LIB_REF_ECMA

21,60 Libellé de la colonne ECMA dans la saisie des références multiples

Par défaut : Code ECMA

Voir exemple à la fin des notes

LIB_REF_ESPACE

21,60 Libellé des zones de saisie de l'espacement entre les poses (X/Y)

Par défaut : Espacement des poses

LIB_REF_ESPACE_X

21,60 Libellé de la zone de saisie de l'espacement en X entre les poses

Par défaut : X

LIB_REF_ESPACE_Y

21,60 Libellé de la zone de saisie de l'espacement en Y entre les poses

Par défaut : Y

LIB_REF_FENETRAGE

21,60 Titre de la colonne Fenêtrage. Par défaut : Fenêtrage

Voir exemple à la fin des notes

LIB_REF_FINITIONS

21,60 Libellé des zones de saisie de finitions

Par défaut : Finitions

Remarque : Ce libellé n'est accessible que dans l'écran de saisie de la nomenclature, partie inférieure dédiée aux références multiples

LIB_REF_FORMAT

21,60 Libellé des colonnes de format (Longueur, largeur et hauteur) dans la saisie des références multiples

Par défaut : L x B x H

Voir exemple à la fin des notes

LIB_REF_FOULAGE

21,60 Libellé pour la colonne Foulage dans l'écran des références multiples

LIB_REF_GAUFRAGE

21,60 Titre de la colonne Gaufrage. Par défaut : Gaufrage

Voir exemple à la fin des notes

LIB_REF_GENCOD

21,60 Libellé d'affichage pour la zone Gencod. Par défaut : GENCOD

LIB_REF_HOLOGRAMME

21,60 Libellé pour la colonne Présence d'hologramme dans l'écran des références multiples

Par défaut : Holo.

LIB_REF_IMBRICATION

21,60 Libellé de la zone de saisie du type d'imbrication

Par défaut : Type d'imbrication

LIB_REF_RAINAGE

21,60 Libellé pour la colonne Rainage dans l'écran des références multiples

LIB_REF_REF_CLIENT

21,60 Libellé d'affichage pour la zone Référence client. Par défaut : Référence

LIB_REF_TRANSFERT

21,60 Libellé pour la colonne Transfert / Poudrage dans l'écran des références multiples

LIB_REF_VIGNETTE

21,60 Libellé pour la colonne Présence de vignette dans l'écran des références multiples

Par défaut : Vign.

LIB_REF_ZONE_NUM6

LIB_REF_ZONE_NUM7

LIB_REF_ZONE_NUM8

LIB_REF_ZONE_NUM9

Titres de saisie pour les zones numériques paramétrables 6 à 9 (pas de valeur par défaut)

Important : Si ce titre n'est pas saisi, la zone n'est pas affichée.

Voir aussi :

devis standard, note #CC_REFDET, zones de_num6 à de_num9.

Code calcul RF (Références) : Caractère 1 = 6 à 9 et caractère 2 = [rien] ou S

LIB_VAL_

LIB_VAL_DORURE

LIB_VAL_GAUFRAGE

LIB_VAL_FENETRAGE

LIB_VAL_FOULAGE

LIB_VAL_RAINAGE

LIB_VAL_TRANSFERT

LIB_VAL_VIGNETTE

LIB_VAL_HOLOGRAMME

LIB_VAL_BRAILLE

Paramétrage des champs de présence sur référence multiple - Voir code calcul RF - Plus d'explications

Présence de dorure

Présence de gaufrage

Présence de fenêtrage

Présence de foulage

Présence de rainage

Présence de transfert/poudrage

Présence de vignette

Présence d'hologramme

Présence de braille

21 Valeur alphanumérique saisissable dans la zone

22 Valeur numérique associée (voir code calcul RF ci-dessous)

23 Cette valeur participe-t-elle à l'éclatement des amalgames ? (O/N, N par défaut)

Voir les notes commençant par INFOS_PHASE_REF_ dans le TEN.

Remarque : Les valeurs par défaut participant à l'éclatement des amalgames sont H (hors ligne) et L (en ligne).

24 Réservé

25 Réservé

26,35 Libellé court

36,60 Libellé long

LIB_ZONE_PAR_CHAR_1

Libellé de la zone paramétrée alphanumérique 1

Important : La saisie de ce libellé conditionne la présence du champ de saisie sur l'écran d'entête du devis.

Voir les notes CONFIG_PAR_CHAR_1 et _SUP_SQL_PAR_CHAR_1.

LIB_ZONE_PAR_CODE_1

Libellé de la zone paramétrée code 1

LIB_ZONE_PAR_CODE_2

Libellé de la zone paramétrée code 2

LIB_ZONE_PAR_NUM_1

Libellé de la zone paramétrée numérique 1

LIB_ZONE_PAR_NUM_2

Libellé de la zone paramétrée numérique 2

LIB_ZONE_PAR_NUM_3

Libellé de la zone paramétrée numérique 3

LISTE_TEN_AUTORISES

21,59 Liste des types d'entité autorisés pour ce type de processus

13 types d'entité paramétrables par ligne, sous la forme AAABBBCCC...MMM

LISTE_TPR_AUTORISES

Liste des nouveaux types de processus autorisés en saisie pour le TPR du devis en cours de modification

21,60 Dix zones de 4 caractères composés comme suit :

Caractères 1 à 3 Type de processus cible autorisé n°1

Caractère 4 Remplacement de l'entité de façonnage par celle associée au devis par défaut du TPR situé en A1[21,23]. VoirA1[1,8]

N Pas de remplacement (par défaut)

O Remplacement systématique

C Remplacement sur demande de confirmation

MAJ_REFMUL_DEVIS

Répercuter les informations liées à une ligne référence multiple

Permet de répercuter les informations liées à une ligne référence multiple :

• Sur les variantes de quantité

• Sur les autres références du sous-devis courant

Les informations pouvant être répercutées sont :

• Informations de la ligne de référence multiple (table fle_dec)

• Informations complémentaires liées à la ligne de référence multiple (TSC)

• Notes liées à la ligne de référence multiple (notes)

Remarque : La répercussion des informations peut être exécutée depuis la saisie des références multiples au niveau de l'entête de sous-devis ou de l'entité.

4 notes gèrent cette fonction :

MAJ_REFMUL_DEVIS

MAJ_REFMUL_VARQTE

_SUP_SQL_MAJ_REFDEV

_SUP_SQL_MAJ_VARQTE

21,26 Type et code du paramètre de configuration de mise à jour des références multiples d'un même sous-devis

27,28 Inutilisé

29 Ouverture de l'écran de sélection des références multiples à mettre à jour

O Ouverture systématique (par défaut)

P Ouverture de l'écran uniquement si plusieurs références multiples sont trouvées

N Pas d'ouverture de l'écran
(sélection automatique de toutes les références multiples trouvées sur le sous-devis ou sur l'entité courante)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique (par défaut)

N Pas d'ouverture de l'écran (sélection automatique de tous les champs trouvés)

MAJ_REFMUL_VARQTE

Répercuter les informations liées à une ligne référence multiple

Plus d'infos dans la note MAJ_REFMUL_DEVIS.

21,26 Type et code du paramètre de configuration de mise à jour des références multiples des variantes de quantités

27,28 Inutilisé

29 Ouverture de l'écran de sélection des références multiples à mettre à jour

O Ouverture systématique (par défaut)

P Ouverture de l'écran uniquement si plusieurs références multiples sont trouvées

N Pas d'ouverture de l'écran (sélection automatique de toutes les références multiples trouvées)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique (par défaut)

N Pas d'ouverture de l'écran (sélection automatique de tous les champs trouvés)

MAJ_SDEVIS_DEVIS

Mise à jour d'informations des sous-devis et entités des variantes de quantité

Permettre de reporter les informations saisies sur un sous-devis vers les autres sous-devis d'un même devis.

Permettre de reporter les informations saisies sur une entité vers les entités des autres sous-devis d'un même devis (variantes de quantité).

Remarques :

• L'action Mise à jour des sous-devis peut être limitée via la permission SOU_DEV_MAJ

• L'action Mise à jour des entités --> Variantes de quantité peut être limitée via la permission ENT_DEV_F29.

21,26 Type et code du paramètre de configuration de mise à jour des sous-devis d'un même devis (#CF MSD)

27 Limiter la mise à jour aux sous-devis de même type (TPR) (O/N, N par défaut)

28 Inutilisé

29 Ouverture de l'écran de sélection des sous-devis à mettre à jour

O Ouverture systématique de l'écran (par défaut)

P Ouverture de l'écran uniquement si plusieurs sous-devis sont trouvés

N Pas d'ouverture de l'écran (sélection automatique de tous les sous-devis trouvés)

30 Ouverture de l'écran de sélection des champs à mettre à jour

O Ouverture systématique de l'écran (par défaut)

N Pas d'ouverture de l'écran (sélection automatique de tous les champs trouvés)

Voir aussi la note SUP_SQL_MAJ_SDEDEV ci-dessous

MODE_GESTION_DEF

21,23 Mode de gestion par défaut (type paramètre associé : .MG)

Uniquement pour le devis_tc (la même note existe sur le TEN, mais elle est réservée au devis_standard).

PARAM_GENERER_CDE

21,26 Type et code du paramètre de configuration de transfert en commande (#CF TDC)

Cette note a priorité sur celle du paramètre de lancement du devis standard.

GENERO uniquement

PARAM_GEN_VERSIONS

21,26 Type et code du paramètre de la génération des versions de produits

Par défaut, les types et code du paramètre de configuration de la génération des versions de produits sont ceux de la configuration de la génération des produits finis, soit :

• TPR A4[24,29]

• Paramètre de lancement du devis, A2[49,54]

Par défaut : #CF GPF

Ce paramètre est utilisé dans le cadre de la gestion des versions de produit.

PARAM_REGENERE_PF

21,26 Type et code du paramètre de la configuration de (ré)génération batch des PF (accessible depuis le menu Fichier du devis multi-métier)

Nécessite la permission MEN/DEV_REGEN_PF

Les type et code du paramètre de configuration de (ré)génération batch des PF sont récupérés dans l'ordre suivant :

1. TPR note PARAM_REGENERE_PF (ici)

2. TPR A4[24,29]

3. Devis standard, paramètre de lancement, A2[49,54]

4. par défaut : #CF GPF

POURCENTAGE_TPR_xxx

Taux de marge à contrôler

xxx : code QVC ou autre

S'il l'on ne trouve pas le taux de marge sur le client du devis (par défaut TSC QVC sur client), on le recherche sur le TPR correspondant.

Exemple

POURCENTAGE_TPR_QVC 010.50

POURCENTAGE_TPR_MAC 025.30

#SPEC-PRV

Ces notes sont utilisées dans le prix de revient MI et GC.

10,11 Entité recherchée (99)

12,14 N° de ligne de la LCO

15 Code rubrique de LCO, 1, 2, M, S etc

20,49 Libellé d'édition

50,60 using d'édition

_SUP_REQ_FLE_TRA_LIV

21,60 Complément de sélection sur la table de livraisons du devis multi-métiers (fle_tra)

Exemple : ce paramétrage permettra de prendre seulement en compte les livraisons réellement valorisées.

_SUP_SQL_MAJ_REFDEV

Répercuter les informations liées à une ligne référence multiple

Plus d'infos dans la note MAJ_REFMUL_DEVIS.

21,60 Complément de sélection des références multiples à mettre à jour sur un même sous-devis (table fle_dec)

SUP_SQL_MAJ_SDEDEV

21,60 Complément de sélection des sous-devis à mettre à jour (fle_2)

A utiliser en complément de la note MAJ_SDEVIS_DEVIS ci-dessus.

_SUP_SQL_MAJ_VARQTE

Répercuter les informations liées à une ligne référence multiple

Plus d'infos dans la note MAJ_REFMUL_DEVIS.

21,60 Complément de sélection des références multiples à mettre à jour sur les variantes de quantité (table fle_dec)

_SUP_SQL_PAR_CHAR_1

21,60 Complément de sélection pour la recherche de la donnée à saisir dans la zone paramétrée alphanumérique 1

Important : Le mot-clé %CLIENT% sera remplacé automatiquement à l'exécution par le client du sous-devis courant.

Si la source est un article (A) :

Complément de sélection sur la table des articles (mat).

Exemple : and mp_cli = "%CLIENT%"

Si la source est libre (par défaut) :

La recherche est désactivée sur le champ.

Voir les notes LIB_ZONE_PAR_CHAR_1 et CONFIG_PAR_CHAR_1.

TITRE_ECRAN_ROULAGE

21,60 Titre de l'écran de saisie du descriptif de roulage

TITRE_SAI_NOTES_NIV

21,60 Titre de l'écran de saisie des notes dans la nomenclature multi-niveau

TITRE_SAI_NOTES_REF

21,60 Titre de l'écran de saisie des notes dans les références multiples

TITRE_SAI_NOTES_ROU

21,60 Titre de l'écran de saisie des notes du descriptif de roulage

TMC_CTL_OK_FACONNAGE

Paramétrage supprimé - Remplacé par les notes CODES_CONTROLE_FACO sur le TMC

21,60 Liste des types de machines de façonnage compatibles de 1 en 1 caractère.

Les caractères admis correspondent aux possibilités de saisie du caractère A4[6] des TMC

TSC_A_AFFICHER_REF

Permettre d'afficher, dans l'écran de saisie des références multiples, la valeur d'un TSC ainsi que le libellé qui lui est associé (désignation matière, libellé de paramètre, …)

21 Type de TSC à afficher

A TSC saisi sur le produit de la ligne de référence (par défaut)

D TSC saisi sur l'entête de devis

E TSC saisi sur l'entité ou sur l'entête de devis (suivant que l'écran des références est appelé depuis l'écran d'entité ou d'entête du devis)

R TSC saisi sur la ligne de référence multiple.

Rappel : L'option Otr sur le paramètre de lancement limite les TSC à ceux qui ont été saisis sur l'écran des références multiples de l'entête du devis.

22 Code TSC à afficher

25 Zone TSC

26 Inutilisé

27,41 Libellé à afficher devant la zone

Par défaut, on prend le libellé saisi sur la ligne de paramétrage TSC (notes commençant par Z*)

TYPE_PALETTE_DEF

21,23 Type de palette par défaut (type paramètre associé : .TP)

Uniquement pour le devis_tc (la même note existe sur le TEN, mais elle est réservée au devis_standard).

TYPES_GENERE_LIGNOM

Types de génération d'entité autorisés

21 Pour la valeur G (Génération)

O Valeur autorisée (par défaut)

I Valeur interdite

22 Pour la valeur C (Copie)

O Valeur autorisée (par défaut)

I Valeur interdite

23 Pour la valeur A (Association)

O Valeur autorisée (par défaut)

I Valeur interdite

60 Valeur par défaut dans le cas d'une création de ligne de nomenclature

G/C/A, pas de valeur par défaut

Voir la note ACCES_ENTITE_LIGNOM

TYP_ZONE_PAR_CODE_1

21,23 Type de paramètre à utiliser pour la zone paramétrée 1

Si la zone paramétrée 2 est utilisée avec la sous-famille, le type de paramètre doit obligatoirement être FAM

TYP_ZONE_PAR_CODE_2

21,23 Type de paramètre à utiliser pour la zone paramétrée 2

sfm (en minuscule, mot-clé réservé) : Sous-famille associé à la famille saisie en zone paramétrée 1

Remarque : La zone paramétrée 1 doit être paramétrée avec le type FAM

Voir la note TYC_DEFAUT_L2_ZPAR2 dans le #CF TDC

TYP_ZONE_TDF

21,23 Type de paramètre de la zone Type de finition (par défaut TDF)

USING_COEFF_NOM

21,60 Paramétrage du format d ‘affichage de la colonne Coefficient de nomenclature

AUTO : Mode automatique (format décidé par Genero)

Par défaut : ### ###& (Aucune décimale)

Types d'affichages possibles :

# : Pas d'affichage du 0 (zéro)

& : Affichage du 0 (zéro)

Exemples :

##&.&&&&&& > 1.080000

&&.&& > 02.50

USING_FORMAT_FINI

Paramétrage des formats d'affichage pour les zones de dimensions

Dans le devis multi-métiers, permet de paramétrer les formats d'affichage (using) pour les zones de dimensions des écrans de saisie des :

• Références multiples sur l'entête (REFLIG/ENTETE)

• Références multiples sur l'entité (REFLIG/ENTITE)

• Entité Boîte pliante (BOIPLI)

• Entité Etiquette bobine (ETIBOB)

• Entité Etiquette feuille (ETIFEU)

• Entité Feuillet/Dépliant (FEUDEP)

• Entité Transformateur carton (TRFCAR)

21,33 Format d'affichage de la zone de dimension de format fini A

34,46 Format d'affichage de la zone de dimension de format fini B

47,59 Format d'affichage de la zone de dimension de format fini H (non applicable aux étiquettes)

Le paramétrage du TEN est prioritaire, sauf pour REFLIG/ENTETE qui n'existe pas sur le TEN.

Si aucun format d'affichage n'est paramétré, le système utilise le format permettant l'affichage de la valeur maximum.

Exemple pour une zone décimale 8,2 : 999999.99

VE_DOC_CLI

21,60 Nom de modèle de document VoluEdit pour l'édition de l'offre de prix client

L'option Oec doit être positionnée dans voluedit_fle_cli.

VE_DOC_DOS

21,60 Nom du modèle pour éditer le dossier de fabrication avec le devis

L'option Oeo doit être positionnée dans voluedit_fle_cli.

VE_DOC_DET

21,60 Nom de modèle de document VoluEdit pour l'édition technique détaillée

L'option Oed doit être positionnée dans voluedit_fle_cli.

VE_DOC_SIM

21,60 Nom de modèle de document VoluEdit pour l'édition technique simplifiée

L'option Oes doit être positionnée dans voluedit_fle_cli.

Fin des notes triées

Exemple des notes LIB_REF_XXX


TQE Etape de fabrication

Pas de paramétrage


TRC Traitement de la réclamation

Valeurs numériques

TRC N1

Coût unitaire du traitement (ou forfaitaire si type de traitement = F)

Valeur alpha 1

TRC A1[1]

Type de traitement

T au temps (valeur par défaut)

Q à la quantité

F au forfait

U à l'unité

Valeur alpha 4

TRC A4[1,5]

Autorise la ventilation du temps dans la visualisation des réclamations client (5 caractères à O ou à N)


TRE Types de reliures

Libellé long

Catégorie de reliure/brochage

Valeur alpha 1

TRE A1[1,8]

Numéro de devis à recopier

Valeur alpha 2

TRE A2[1] | Si O, devis brochage, sinon devis reliure
TRE A2[2] | Accès au détail des gardes (O/N)
TRE A2[3] | Accès au détail signet / tranchefile (O/N)
TRE A2[4] | Accès au détail carton/dos (O/N)
TRE A2[5] | Accès au détail de la housse (O/N)
TRE A2[6] | Accès au détail titrage (O/N)
TRE A2[7] | Ne pas prendre en compte le montage de la couverture (N par défaut)
TRE A2[8] | Ne pas prendre en compte le transport (N par défaut)
TRE A2[9] | Prendre en compte le nombre total de cahiers dans le calcul des dépendances (N par défaut)
TRE A2[10] | Forcer le format rogné 0
TRE A2[11] | Ne pas prendre en compte la découpe feuille (N par défaut)
TRE A2[12] | Ne pas prendre en compte le pliage rabat (N par défaut)
TRE A2[13] | Ne pas prendre en compte le massicot trilatéral (N par défaut)


TRF Transfert de stock

Valeur alpha 1

TRF A1[1,3] | Type de mouvement de sortie (TMV)
TRF A1[5,7] | Type de mouvement d'entrée (TMV)
TRF A1[9] | Motif concernant les déchets Production/Fournisseur (P/F) Voir les notes MOTIF_DECHET_n dans maj_stk


TRM Terminal

Description générale d'un terminal

Canaux d'entrée | Permettent tous les comptages Matière en entrée et matière en sortie de machine
Canaux de sortie | Permettent le pilotage éventuel de périphériques (klaxon, etc.)

Code paramètre

Le numéro de terminal. Il correspond au numéro de terminal réel utilisé par le scrutateur

Valeur alpha 1

TRM A1[1] | Canal 00 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[2,4] | Canal 00 : Code du capteur (voir paramètre CAP)
TRM A1[5] | Canal 00 : Inutilisé
TRM A1[6] | Canal 01 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[7,9] | Canal 01 : Code du capteur (voir paramètre CAP)
TRM A1[10] | Canal 01 : Inutilisé
TRM A1[11] | Canal 02 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[12,14] | Canal 02 : Code du capteur (voir paramètre CAP)
TRM A1[15] | Canal 02 : Inutilisé
TRM A1[16] | Canal 03 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[17,19] | Canal 03 : Code du capteur (voir paramètre CAP)
TRM A1[20] | Canal 03 : Inutilisé
TRM A1[21] | Canal 04 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[22,24] | Canal 04 : Code du capteur (voir paramètre CAP)
TRM A1[25] | Canal 04 : Inutilisé
TRM A1[26] | Canal 05 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[27,29] | Canal 05 : Code du capteur (voir paramètre CAP)
TRM A1[30] | Canal 05 : Inutilisé
TRM A1[31] | Canal 06 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[32,34] | Canal 06 : Code du capteur (voir paramètre CAP)
TRM A1[35] | Canal 06 : Inutilisé
TRM A1[36] | Canal 07 : Capteur en entrée machine (E) ou en sortie machine (S)
TRM A1[37,39] | Canal 07 : Code du capteur (voir paramètre CAP)
TRM A1[40] | Canal 07 : Inutilisé

Valeur alpha 2

Canaux en sortie

Pas de paramétrage actuellement

Exemple

Le terminal 001 est équipé de 8 canaux d'entrée et de 8 canaux de sortie.

2 canaux d'entrée (00 et 01) sont connectés à 2 capteurs (C05 et C06) sur entrée machine.

1 canal d'entrée (03) est connecté à 1 capteur (C07) sur sortie machine.

0 10 20 30

!----+----!----+----!----+----!

Zone alpha 1 ---> EC05 EC06 SC07


TRS Types de transports

Permet avec le code transporteur d'utiliser la table des tarifs transporteurs (tro).

Valeur alpha 1

TRS A1[1] | O Edition d'un bon transporteur N Pas d'édition d'un bon transporteur (A gérer au niveau de chaque édition de bon de livraison)
TRS A1[2] | Code normalisé (CE) pour envoi DEB
TRS A1[3,4] | Code pour le transfert PC-Topp
TRS A1[5] | Type de transport. Edité sur BL R Route M Messagerie
TRS A1[6] | Code édité dans l'édition des expéditions
TRS A1[7] | Type de transport (utilisé dans le transfert SYLOGI) 1 Mer 2 Fer 3 Route 4 Aérien
TRS A1[8,10] | Correspondance JDE Voir les programmes tr_jde_cde et tr_groupage
TRS A1[11] | Valorisation du mode de transport O Oui (par défaut) N Non. Pas de valorisation. Dans ce cas, le coût est alors égal à zéro. L Location Si un tarif a un mode de transport de type location, alors les unités de coût de toutes ses lignes devront être forfaitaires avec une durée.
TRS A1[12] | Edition d'un ordre d'achat de transport (O/N, N par défaut)
TRS A1[13,18] | Code transporteur imposé pour les modes de transport sans valorisation
TRS A1[19,21] | Code magasin de départ par défaut (de type RG1) pour tarif location
TRS A1[22] | TRS ZZZ : Mode de transport de location Valorisation de ce mode de transport avec distance incluant le retour au point de départ (O/N, N par défaut) - Utilisé dans vehicules
TRS A1[23] | Lors du calcul du coût de l'itinéraire, rechercher le transporteur par défaut du ou des clients O récupère le code transporteur par défaut du client N on ne récupère pas le code transport par défaut (comme actuellement) (par défaut). Dans un affrètement, il peut y avoir différentes commandes de différents clients. Une fenêtre demande à l'utilisateur quel transporteur sera utilisé pour le calcul du coût. Si aucun transporteur n'est sélectionné (ou trouvé), alors le calcul se fera comme avant sinon il se fera avec celui ou ceux choisis par l'utilisateur.

Notes

CODE_TRS_EFFICIAL

21 Code moyen de transport


TRU Types de ruptures

Valeur alpha 1

Type de ruptures 2 acceptées pour la rupture

TRU A1[1] | Type rupture (P paramètre, C client)
TRU A1[2,4] | Code rupture
TRU A1[5] | Type rupture (P paramètre, C client)
TRU A1[6,8] | Code rupture, etc.

Exemple : CCLIPFAMPCAT

Remarque : Pour le type de rupture C, le code de rupture est CLI


TSC Trame de saisie complémentaire

ATTENTION : les codes TSC commençant par les caractères suivants sont réservés à Volume Software :

& ( ) # { [ ] } $ £ §

Voir la syntaxe d'appel des TSC

Voir les codes zones TSC

Voir la table info_c

Note sur le paramètre de lancement de tout programme utilisant la recopie de TSC

INFO_C_DEFAUT

21 Caractère indiquant s'il faut créer les TSC par défaut qui n'existent pas.

A Création des TSC par défaut (A comme Ajout)

[autres valeurs] Pas de création des TSC par défaut

Valeurs numériques

TSC N1

Ordre d'affichage de ce TSC par rapport aux autres. Un tri secondaire est effectué sur le code du TSC.

Valeur alpha 1

TSC A1[1,3] | Code paramètre WIN. Lancement d'un programme Windows
TSC A1[4] | Code zone info_c contenant le nom du document. (zone G par défaut)
TSC A1[5] | TSC copié lors de l'éclatement de l'amalgame (O/N, N par défaut) (touche F27 sur entité devis car)
TSC A1[6] | TSC copié lors de la copie de TSC sans sélection (O/N, O par défaut)
TSC A1[7] | Recopie du TSC lors de la recopie de devis O Le TSC est recopié [Valeur par défaut] N Le TSC n'est pas recopié Non géré dans le devis onduleur (source info à vérifier 16/06/2010 PM)

Valeur alpha 4

TSC A4[1,30]

Valeur à mettre dans la zone alphanumérique de 30 caractères lors de la création et/ou mise à jour automatique de l'information complémentaire via les visualisations (explications).

Notes NON TRIEES

ACCES_ZONE_

Paramétrer l'accès en consultation à toutes ou certaines zones de TSC, suivant un utilisateur ou un groupe d'utilisateurs

12 Code de la zone TSC sur laquelle l'accès paramétré s'applique (* pour toutes les zones)

21 Catégorie d'utilisateur concerné

U Utilisateur unique

Car.22,24 = Code utilisateur

G Groupe d'utilisateurs

Car.22,24 = Code groupe. Voir la note GROUPE_TSC du paramètre USE

* Tous les utilisateurs

Car.22,24 : non utilisés

22,24 En fonction du caractère 21

25 Type d'accès

M Accès en modification

C Accès en consultation uniquement

N Aucun accès - La zone n'est pas affichée dans le tableau de saisie des informations complémentaires.

Remarques :

• Par défaut, si aucun paramétrage n'existe pour le TSC, l'utilisateur et le groupe courant, la zone en cours de saisie est accessible en modification.

• Si un paramétrage définit qu'une zone TSC est accessible en modification pour l'utilisateur et/ou le groupe courant, ce dernier est prioritaire (les paramétrages d'accès en consultation seront ignorés pour l'utilisateur et/ou le groupe courant)

• Si l'utilisateur courant n'a pas accès en modification à toutes les zones du TSC en cours de saisie, celui-ci ne pourra pas supprimer le TSC.

• Ce paramétrage est valable sur les deux modes de saisie d'informations complémentaires (ancien et nouveau mode)

CONTEXTE_TSC

En savoir plus sur l'ouverture contextuelle des informations complémentaires (TSC)

Attention : il faut activer la nouvelle saisie des TSC pour utiliser cette fonctionnalité (so_options[29] = O)

Si vous êtes sous l'ancienne saisie, vous pouvez activer la nouvelle sur le lanceur uniquement en ajoutant la note INFO_C2.

21,40 Nom du champ où ouvrir la fenêtre de saisie contextuelle des TSC.

La liste des champs disponibles est en bas de cette page.

41 Réservé

42 Critère d'ouverture de la fenêtre

S Ouverture systématique après le champ (par défaut)

M Ouverture en cas de modification du champ

F Ouverture sur la frappe d'une touche dans le champ

V Ouverture si la valeur du champ est égale à la valeur paramétrée dans les caractères 45 à 60

2 Ouverture si les conditions M et V sont vérifiées

3 Ouverture si les conditions F et V sont vérifiées

D Ouverture si la valeur du champ est différente à la valeur paramétrée dans les caractères 45 à 60

4 Ouverture si les conditions M et D sont vérifiées

5 Ouverture si les conditions F et D sont vérifiées

43,44 Réservé

45,60 Si caractère 42 = V, 2 ou 3 : Valeur à comparer avec la valeur courante du champ.

Voir #CF DEG A4[55]

PARAM_LCT_PROG_

Depuis la saisie des TSC, on peut paramétrer le lancement de neuf programmes différents.

Le lancement sera effectué avec en paramètre le résultat de la zone ic_char30 en cours.

Le paramétrage se fait sur les TSC (lancements différents selon les besoins)

16 Numéro de l'action à lancer (1 à 9)

21,26 Type et code du paramètre de lancement

27,60 Libellé de l'action

Exemples

PARAM_LCT_PROG_1 #SAARTSaisie article

PARAM_LCT_PROG_2 #VILSIListe inventaire

PARAM_LCT_PROG_3 #VIESCETat stock

TYPE_ACC_VISU_MAT_1

CODE_ACC_VISU_MAT_1

21,23 Type de paramètre de lancement de la visualisation des matières à utiliser en tant que recherche d'article

21,23 Code de paramètre de lancement de la visualisation des matières à utiliser en tant que recherche d'article

ATTENTION : voir aussi #CF RMP

Les mêmes notes existent aussi au niveau de la LCO.

Par défaut, on prend le paramètre de lancement paramétré sur le paramètre de lancement du programme en cours d'utilisation (par exemple, la saisie des devis dans le cas d'une recherche faite sur une LCO)

VAL_MAJ_FLAG_INFO_C

Flag de suivi de création et modification

21,23 Valeur de départ (laisser cette zone à vide pour la création

24,26 Valeur d'arrivée (valeur du flag de suivi après mise à jour)

Permettre, lors de la mise en place d'un flag d'information complémentaire, de créer en plus un flag de suivi de création/modification.

Remarques :

• Le flag de suivi est enregistré dans la deuxième zone de 3 caractères (ic_char3_2)

• La valeur du flag de suivi est le résultat d'une comparaison entre une valeur de départ et une valeur d'arrivée

• Si la valeur de départ n'est pas trouvée dans le paramétrage, la valeur du flag de suivi n'est pas modifiée

• Les valeurs vides (null) et blanches ( ) sont considérées comme identiques (si le flag de suivi est réinitialisé manuellement par l'utilisateur à la valeur blanche, le système considérera que le TSC est en création)

• Plus de détail sur le fonctionnement du flag d'informations complémentaires

Exemples

VAL_MAJ_FLAG_INFO_C CRE

Si, lors de la mise en place du flag, la valeur actuelle est vide ou blanche (création), le flag de suivi est mis à jour avec la valeur CRE.

VAL_MAJ_FLAG_INFO_C CREMOD

Si, lors de la mise en place du flag, la valeur actuelle est égale à CRE, le flag de suivi est mis à jour avec la valeur MOD.

TIC

Permet d'indiquer pour quels TIC (Type d'Information Complémentaire) ce TSC est valide.

Exemples

TIC* Le TSC est valide pour tous les TIC.

Le TSC apparaîtra dans les données générales, bouton Données (et uniquement là).

TICCDE Le TSC est valide pour le TIC CDE.

Le TSC apparaîtra dans les données associées au bouton correspondant au TIC CDE.
(il n'apparaîtra pas dans les données générales).

TICDEV Le TSC est valide pour le TIC DEV.

TICFAB Le TSC est valide pour les TIC FAB.

Le TSC apparaîtra dans les données associées aux boutons correspondants aux TIC DEV et FAB.
(il n'apparaîtra pas dans les données générales).

Voir TIC A1[2,3] et TIC A2[1,60] pour la gestion des compléments avec boutons dans la saisie des TSC.

Z

Paramétrage des zones de saisie

2 Code de la zone

3,17 Libellé de saisie

18 Saisie obligatoire

N Non (par défaut)

W Message d'avertissement

B Message bloquant

19,20 Code de contrôle de la zone. Pas de contrôle par défaut

01 Contrôle existence sur la table des codes de paramètres (par02)

02 Contrôle existence sur la table des articles (recherche produit) (mat)

03 Contrôle existence sur la table des codes ECMA / FEFCO (ecma)

04 Contrôle existence sur la table des gammes standard (g_std_e)

05 Contrôle existence sur la table des machines (mac0)

06 Contrôle existence sur la table des articles (recherche données techniques) (mat)

07 Contrôle existence sur la table des articles (recherche papier) (mat)

08 Contrôle existence sur la sous-famille (sfm et par02)

09 Contrôle existence sur le tiers (cli)

10 Contrôle existence d'adresse secondaire (cli2)

21,23 Complément pour contrôle

01 Type du paramètre à lire. Exemple TVA

02 Type d'article. Exemples P, M, F

03 Inutilisé

04 Inutilisé

05 Type de machine. Exemples IMP, ROT

06 Inutilisé

07 Inutilisé

08 Code famille de la sous famille. Exemple PAP

09 Type de tiers. Exemples C, P, F

10 Type d'adresse secondaire

D Devis

A Accusé de réception

L Livraison

F Facturation

24 Code affichage (Module de saisie). Comment la zone est-elle est affichée ?

Z La zone est affichée (par défaut)

N Aucun affichage

C Le libellé court de la zone

(valable pour les codes de contrôle de zone 01 ou 08 avec un type paramètre valide)

L Le libellé de la zone. Exemple : libellé article si la zone concerne un article.

Dans le cas d'un code de contrôle 01 ou 08, il s'agit de l'affichage du libellé long.

2 Les 2 (La zone et son libellé)

25,39 using d'affichage pour les zones de type date ou numérique.

Longueur d'affichage pour les autres zones.

Valeurs par défaut :

Date dd/mm/yy

Numérique -------&.

Alpha 3 3

Alpha 30 30

40,41 Longueur d'affichage pour le libellé de la zone dans le cas où le

caractère 24 indique la présence d'un libellé. Valeur par défaut 40

42,56 Libellé d'affichage. C'est le libellé qui sera affiché dans le tableau d'affichage.

57,58 Code langue

59 Saisie en minuscules (O/N, N par défaut)

L'ordre d'apparition des zones dans les notes définit l'ordre dans lequel elles seront affichées dans le tableau d'affichage.

Les zones dont le code zone n'apparaît pas ne seront pas saisies.

#

Permet d'indiquer le libellé des questions dans le nouveau mode de saisie (so_options[29] = O)

2 Code de la zone

3 à 47 Texte de la question (45 caractères)

57 à 58 Code langue

Exemples

1) #FEntrez un code famille :

2) #A Entrez une date ---->

E-

Notes paramétrables pour les éditions standards et spécifiques non VoluEdit

Permet d'imprimer des lignes de commentaires sur certains documents, pour lesquels cette fonctionnalité est programmée.

3 à 5 Document

6 à 7 Numéro de ligne

8 Type de paramétrage

10 Code de la zone

ou # Texte figé (dans ce cas, le texte est dans les caractères 15 à 59)

11 Décision d'imprimer ou non une zone nulle, vide, ou à zéro

O On imprime quand même

N On n'imprime pas

S On n'imprime pas mais on mémorise la rubrique qui sera ajoutée devant la suivante.

Remarque : c'est la dernière rubrique qui décide du saut de ligne (caractère 60)

12 Densité de la police

0 10 cpi (pica)

2 12 cpi (élite)

7 17 cpi (condensé)

13 Style de la police

L Large

S Souligné

I Italique

14 Graisse de la police

G Gras

15 à 59 Texte. Uniquement si caractère 10 = #

Dans les autres cas, voir le découpage des caractères 15 à 59 ci-après.

15 à 16 Table de lecture de la rubrique

01 table paramètre

02 table article

09 table tiers

90 table des libellés étrangers

91 table notes sur article

17 à 39 Si caractères 15 à 16 < 91 : colonne de lecture

Si caractères 15 à 16 = 91 : numéro de ligne

40 à 42 Complément de clé pour la table

Si caractères 15 à 16 = 01 : type de paramètre

Si caractères 15 à 16 = 90 : C libellé étranger lié au client de la fiche matière

F libellé étranger lié au fournisseur de la fiche matière

Si caractères 15 à 16 = 91 : type de note

43 à 53 Format d'édition (using) d'une zone numérique ou date, ou longueur d'une zone caractères

54 à 59 Texte figé imprimé après la rubrique

60 Passage à la ligne suivante avant cette rubrique (O/N)

n'a aucun effet si cette rubrique est simplement mémorisée (caractère 11 = S)

V-

Notes paramétrables pour VoluEdit

3,5 Document (ACR)

6,7 Numéro de ligne

8 Numéro d'ordre d'apparition sur la ligne

9 Code zone (ABCDEFGH) du TSC à éditer ou # si texte fixe.

10 Code de la zone (du même TSC !) conditionnant l'impression : utilisé pour conditionner l'impression des zones texte.

11 Décision du mode d'édition de la zone :
O On imprime quand même
N On n'imprime pas
S On n'imprime pas mais on mémorise la rubrique qui sera ajoutée devant la suivante.

12,13 Condition (test effectué sur les caractères 54 à 60 par rapport à la zone définie par le caractère 10)
!= Différent
== Egal
>> Supérieur
<< Inférieur
>= Supérieur ou égal
<= Inférieur ou égal

15,53 Texte si caractère 9 = #

15,16 Table de lecture de la rubrique
01 table paramètre
02 table article
09 table tiers
90 table des libellés étrangers
91 table notes sur article

17,39 Si caractères 15 à 16 < 91 : colonne de la table concernée.
Si caractères 15 à 16 = 91 : numéro de ligne

40,42 Complément de clé pour la table
Si caractères 15 à 16 = 01 : type de paramètre
Si caractères 15 à 16 = 90 :
C libellé étranger lié au client de la fiche matière
F libellé étranger lié au fournisseur de la fiche matière
Si caractères 15 à 16 = 91 : type de note

43,53 Format d'édition (using) d'une zone numérique ou date, ou longueur d'une zone caractères

54,60 Texte figé : valeur de référence pour le conditionnement du texte/valeur à éditer.

Exemple

V-ACR01N# O TEST SA

V-ACR01OGCS>= 02mp_des 1.0

V-ACR02OGCS>= 02mp_poids <<<# 1.0

V-ACR02O# O>= Gr/m² 1.0

V-ACR02O# O>= Gr/m² 1.0

V-ACR02O# O>= Gr/m² 1.0

_ (undescore)

Permet d'afficher un commentaire sur l'écran de saisie des TSC

2 Code de la zone

3 à 30 Commentaire de la zone

S

Complément de sélection sur une zone de TSC en cas de recherche (F7) sur une zone

Cette note ne fonctionne que dans la saisie simplifiée des matières.

2 Code de la zone

4,60 Complément de sélection

Exemple : Complément de select sur la zone G (ic_char30) du code TSC : SG and mp_fam = ‘'PAP''

D

Possibilité de paramétrer une valeur par défaut des différentes zones du TSC

2 Code de la zone

3,32 Valeur par défaut de la zone

Pour les dates (zones A et B) : dans les caractères 3 à 10, indiquez la date par défaut au format JJMMAAAA

Pour les zones numériques (C, D, E) : dans les caractères 3 à 14, indiquez la valeur par défaut qui sera au format <<<<<<<&.&&&

Pour les zones alpha de 3 caractères (F, H) : dans les caractères 3 à 5, indiquez la valeur.

Pour la zone alpha de 30 caractères (G) : dans les caractères 3 à 32, indiquez la valeur.

Note CONTEXTE_TSC - Liste des champs disponibles

Retour à la note CONTEXTE_TSC

Champs disponibles sur l'écran des références multiples d'entité (table fle_dec)

Les champs sont triés par ordre alphabétique.

Champ | Type | Description
de_braille | A | Présence de braille
de_collage | N | Présence de collage
de_cs1 | A | Code statistique 1
de_cs2 | A | Code statistique 2
de_cs3 | A | Code statistique 3
de_cs4 | A | Code statistique 4
de_designation | A | Désignation
de_dorure | A | Présence de dorure
de_ecma | A | Code ECMA/FEFCO
de_fam | A | Code famille
de_fenetrage | A | Présence de fenêtrage
de_fini_dblc | N | Espacement des poses en X
de_forcage_format | A | Forçage du format
de_forcage_nbp | A | Forçage du nombre de poses
de_foulage | A | Présence de foulage
de_gaufrage | A | Présence de gaufrage
de_gencod | A | Code normalisé
de_hauteur | N | Hauteur
de_hologramme | A | Présence d'hologramme
de_nb_cou_recto | N | Nombre de couleurs recto
de_nb_cou_verso | N | Nombre de couleurs verso
de_nb_poses | N | Nombre de poses
de_nb_teintes_r | N | Nombre de recherche de teintes au recto
de_nb_teintes_v | N | Nombre de recherche de teintes au verso
de_nb_variantes | N | Nombre de variantes
de_pli_dblc | N | Espacement des poses en Y
de_produit | A | Code produit
de_quadri_r | A | Présence de quadrichromie au recto
de_quadri_v | A | Présence de quadrichromie au verso
de_quantite | N | Quantité
de_rainage | A | Présence de rainage
de_ref_client | A | Référence client
de_sens_pose | A | Respect du sens des poses
de_sfm | A | Code sous-famille
de_transfert | A | Présence de transfert/poudrage
de_type_imbric | A | Type d'imbrication
de_vignette | A | Présence de vignette
format_a | N | Format A (Longueur/Largeur selon paramétrage)
format_b | N | N Format B (Longueur/Largeur selon paramétrage

Champs disponibles sur l'écran des lignes d'impressions multiples (table fle_combi)

Les champs sont triés par ordre alphabétique.

Champ | Type | Description
fco_bascule | A | Présence de bascule
fco_cgt_r_rv | N | Nombre de repiquages
fco_cgt_rv | N | Nombre de changement de plaques
fco_cgt_teinte_rv | N | Nombre de changement de teintes
fco_couleur_rv | N | Nombre de couleurs
fco_enc_rv | N | Pourcentage d'encrage
fco_mac_forcee_rv | A | Code machine forcée
fco_mac_imp | A | Code machine
fco_nb_cl_commune | N | Nombre de couleurs communes entre recto et verso
fco_nb_teintes_rv | N | Nombre de recherche de teintes
fco_pr_rv | N | Nombre de couleurs primaires
fco_quadri_rv | A | Présence de quadrichromie
fco_recto_verso | A | Recto/Verso
fco_type_passage | A | Type de passage
fco_type_vernis_r | A | Type de vernis
fco_ve_recto | N | Pourcentage de vernissage

Champs disponibles sur l'écran d'entête (table fle_2)

Les champs sont triés par ordre alphabétique.

Champ | Type | Description
l2_adr_liv | A | Code adresse de livraison
l2_adresse | A | Code adresse d'envoi du devis
l2_agence | A | Code agence
l2_agence_com | A | Commission de l'agence
l2_agence_corres | A | Nom du correspondant de l'agence
l2_agence_titre | A | Titre de l'agence
l2_bareme | A | Code barème
l2_c_ma | N | Commission du représentant
l2_civilite | A | Code civilité du correspondant
l2_client | A | Code client
l2_code_prod | A | Code produit
l2_cop_ren | A | Copie/Renouvellement/Génération
l2_corres | A | Nom du correspondant
l2_dat_liv | A | Date de livraison
l2_date_dev | A | Date du devis
l2_delai_fab | A | Délai de fabrication
l2_desdev1 | A | Désignation 1
l2_desdev2 | A | Désignation 2
l2_dev_cop | A | Numéro du devis d'origine
l2_devise | A | Code devise
l2_deviseur | A | Code du deviseur
l2_etat | A | Etat du devis
l2_fabricant | A | Code du fabricant
l2_gestion_train | A | Gestion des trains
l2_lig_affaire | N | Ligne d'affaire
l2_motif | A | Motif de signature
l2_nb_liv | N | Nombre de livraisons
l2_nb_references | N | Nombre de références
l2_num_affaire | A | Numéro d'affaire
l2_qtedev | N | Quantité du sous-devis courant
l2_refcli | A | Référence client
l2_renouvellement | A | Renouvellement
l2_representant | A | Code représentant
l2_representatif | A | Devis représentatif (CA)
l2_sdev_cop | N | Numéro du sous-devis d'origine
l2_signature | A | Code du signataire
l2_site | A | Code site de production
l2_suiv | A | Suivi d'affaire
l2_taux_devise | N | Taux de devise
l2_tit_corres | A | Titre du correspondant
l2_transporteur | A | Code transporteur
l2_type_dev | A | Type de devis
l2_type_finition | A | Type de finition
l2_type_port | A | Type de port
l2_type_prix | A | Type de prix
l2_type_prod | A | Type de produit (TPR)
l2_type_transfert | A | Type de transfert en commande
l2_unite_du_plus | A | Code unité du 1000+
l2_validite_deb | A | Date de début de validité
l2_validite_fin | A | Date de fin de validité
l2_zchr1 | A | Zone paramétrée alphanumérique (15 car.)
l2_znum1 | N | Zone paramétrée numérique 1
l2_znum2 | N | Zone paramétrée numérique 2
l2_znum3 | N | Zone paramétrée numérique 3
l2_zpar1 | A | Zone paramétrée alphanumérique 1 (3 car.)
l2_zpar2 | A | Zone paramétrée alphanumérique 2 (3 car.)
qte_dev_2 | N | Quantité du sous-devis courant +1
qte_dev_3 | N | Quantité du sous-devis courant +2
qte_dev_4 | N | Quantité du sous-devis courant +3
qte_dev_5 | N | Quantité du sous-devis courant +4

Champ disponible pour la saisie des bons de réception

Champ | Type | Description
lf_qterec | N | Quantité réceptionnée - Voir brc A2[55] Attention, bien que préfixée lf_, cette zone n'appartient pas à la table cdf2.

Autres champs

Champ | Type | Description
VALIDE_CONFORMITE | O | Opération de contrôle
SBS_DEP_TPS | O | Lors du dépassement du temps prévu Voir l'option Ogd dans la saisie des temps atelier. Libellé : de l’opération de contrôle Car.42 = V
SBS_DEP_QTE | O | Lors du dépassement de la quantité lancée Voir l'option Ogd dans la saisie des temps atelier. Libellé : de l’opération de contrôle Car.42 = V
SBS_OPE_NON_PREVUE | O | Opération non prévue par validation Voir l'option Oon dans la saisie des temps atelier Libellé : de l’opération de contrôle Car.42 = V


TSC Codes zones

Codes zones TSC

A Date (1) - ic_date1

B Date (2) - ic_date2

C Numérique (1) - ic_num1

D Numérique (2) - ic_num2

E Numérique (3) - ic_num3

F Char3 (1) - ic_char3_1

G Char30 - ic_char30

H Char3 (2) - ic_char3_2

X Clé du TSC - ic_cle


TSC Syntaxe d'appel

A partir des programmes de visualisation, il est possible de récupérer des informations provenant des TSC.

Un TSC est caractérisé par 4 données :

1) le type de table (MP pour Matière Produit, EC pour Entête Commande, LC pour Ligne Commande, etc.)

2) l'origine (codée sur 2 caractères) (voir type de table)

3) le code du TSC proprement dit (sur 3 caractères)

4) le code zone du TSC (un TSC a 2 zones de date, 3 zones numériques et 3 zones caractères)

Il existe 3 syntaxes pour accéder à un TSC.

Syntaxe 1 : TSC_TypeTable_Origine_CodeTSC_CodeZone

C'est la syntaxe la plus simple : on va lire une information dans un TSC.

Syntaxe | Explication | Dans l'exemple ci-dessous
TSC | Mot-clé annonçant un TSC | TSC
TypeTable | Type de table (voir le tableau en bas de page) | MP (Matière Produit)
Origine | Origine (voir le tableau ci-dessous) | AA (code produit)
CodeTSC | Code du TSC | 220 (code TSC des spécifications de palettisation)
CodeZone | Code zone du TSC | H (2ème zone alphanumérique de 3 caractères)

Exemple

Nous voulons récupérer le code du schéma de palettisation du PF.

TSC_MP_AA_220_H

Syntaxe 2 : TSC_TSATypeTable_Origine_CodeTSC1_CodeTSC2_CodeZone

Utilisée uniquement dans les programmes de visualisation

On va lire un code article sur un TSC; sur le code article lu, on va ensuite accéder à un deuxième TSC pour y récupérer une valeur.

Syntaxe | Explication | Dans l'exemple ci-dessous
TSC | Mot-clé annonçant un TSC | TSC
TSA | Lecture d'un TSC d'un article pris depuis un TSC | TSA
TypeTable | Type de table (voir le tableau en bas de page) du premier TSC | LC (Ligne de Commande)
Origine | Origine (voir le tableau ci-dessous) du premier TSC | AA (code produit)
CodeTSC1 | Code du premier TSC | 203 (code TSC de la qualité carton) Sur ce TSC, on récupère le code article stocké dans la zone G (ic_char30). G est figé et codé "en dur".
CodeTSC2 | Code du deuxième TSC (TSC sur article) | 310 (code TSC de la composition carton) Ce TSC est lu sur le code article récupéré ci-dessus.
CodeZone | Code zone du deuxième TSC | F (1ère zone alphanumérique de 3 caractères)

Exemple

Nous voulons récupérer le profil carton stocké dans la zone zone F du TSC 310 de l'article correspondant à la qualité carton (stockée dans la zone G du TSC 203 sur produit de la ligne de commande).

TSC_TSALC_AA_203_310_F

Syntaxe 3 : TSC_xxx_TypeTable_Origine_CodeTSC_CodeZone

La syntaxe 3 comporte 2 variantes. La seule distinction entre les 2 variantes est la suivante :

- dans la variante 1 , on peut récupérer une valeur de la table par02.

- dans la variante 2 , on peut récupérer un libellé. Aller directement à la variante 2.

1) Syntaxe 3, variante 1 - Récupérer une valeur de la table par02 à partir d'un code paramètre stocké dans un TSC

TSC_xxx | Mot-clé annonçant un TSC sur lequel on va récupérer un libellé. Voir les possibilités ci-dessous.
TypeTable | Type de table (voir le tableau en bas de page)
Origine | Origine (voir le tableau ci-dessous)
CodeTSC | Code du TSC
CodeZone | Code zone du TSC

Récupérer une valeur de la table par02 à partir d'un code paramètre stocké dans un TSC - Table des possibilités :

Syntaxe | Valeur renvoyée
TSC_ZC1_TypeTable_Origine_CodeTSC_CodeZone | Valeur numérique 1 du par02 (p2_zc1)
TSC_ZC2_TypeTable_Origine_CodeTSC_CodeZone | Valeur numérique 2 du par02 (p2_zc2)
TSC_AL1_TypeTable_Origine_CodeTSC_CodeZone | Valeur alpha 1 du par02 (p2_alph)
TSC_COM_TypeTable_Origine_CodeTSC_CodeZone | Valeur alpha 2 du par02 (p2_com)
TSC_AL3_TypeTable_Origine_CodeTSC_CodeZone | Valeur alpha 3 du par02 (p2_alph3)
TSC_AL4_TypeTable_Origine_CodeTSC_CodeZone | Valeur alpha 4 du par02 (p2_alph4)
TSC_LIC_TypeTable_Origine_CodeTSC_CodeZone | Libellé court du par02 (p2_libc)
TSC_LIL_TypeTable_Origine_CodeTSC_CodeZone | Libellé long du par02 (p2_libl)

Comme le montre le tableau ci-dessus, on peut récupérer toutes les zones d'un enregistrement de la table par02, dont le code est stocké dans un TSC.

Le type de paramètre est indiqué dans note commençant par Z du TSC (voir le détail dans l'exemple ci-dessous)

Le code du paramètre est saisi et enregistré dans une des 3 zones alpha dans la table info_c.

Exemple

Dans cet exemple, on paramètre le TSC .O1 et on indique :

- qu'un code de paramètre sera stocké dans ce TSC,

- que l'existence du code paramètre saisie sera contrôlée,

comme le montre le détail de la note commençant par Z expliqué ici :

Caractère | Code | Signification
1 | Z | Note commençant par Z (paramétrage des zones de saisie)
2 | F | Zone ic_char3_1 (première zone alphanumérique de 3 caractères) C'est dans cette zone que l'on veut stocker le code paramètre qui sera saisi.
3,17 | Type forme : | Libellé de la zone lors de la saisie
18 | N | Saisie facultative
19,20 | 01 | L'existence du code de paramètre saisi sera contrôlée par rapport à la table des codes paramètres (par02).
21,23 | TFO | TFO est le type du paramètre utilisé pour le contrôle défini ci-dessus.
24 | 2 | On affiche la zone et le libellé.
25,29 | [rien] | Pas de format d'affichage particulier
40,41 | [rien] | Pas de longueur d'affichage particulière
42,56 | TYPE FORME | Libellé de la zone lors de l'affichage
57,58 | fr | Langue d'affichage
59 | [rien] | Pas de casse particulière

Dans ce tableau, les paramètres qui nous intéressent ici sont surlignés en jaune.

Si, lors de la saisie du TSC .O1, on a entré le code 924, alors la syntaxe TSC_LIL_MP_AA_.O1_F renverra FORMES 924.

2) Syntaxe 3, variante 2 - Récupérer un libellé à partir d'un code paramètre stocké dans un TSC [image] Retour à la variante 1

La syntaxe est la suivante: :

TSC_LIB_TypeTable_Origine_CodeTSC_CodeZone

TSC_LIB_TypeTable_Origine_CodeTSC_X

Si le CodeZone = X, il s'agit d'un cas particulier traité à la fin de ce chapitre.

Quels sont les libellés que l'on peut récupérer ?

Le libellé que l'on récupère dépend du type de contrôle de saisie que vous avez paramétré dans la note Z du TSC concerné, dans les caractères 19-20, repris ci-après :

Car.19-20 | Type de contrôle | Valeur du libellé
01 | Contrôle sur la fiche paramètre (par02) | Par défaut : p2_libl. Si car.24 = C : p2_libc
02 | Contrôle sur la fiche article (mat) | mp_des
03 | Contrôle du code ecma/fefco (ecma) | kma_desig
04 | Contrôle de la gamme standard (g_std_e) | ge_des_gamme
05 | Contrôle du code machine (mac0) | m0_desig
06 | Contrôle sur la fiche article (données techniques) (mat) | mp_des
07 | Contrôle sur la ficher article (papier) (mat) | mp_des
08 | Contrôle des sous-familles (sfmet (par02) | Par défaut : p2_libl. Si car.24 = C : p2_libc
09 | Contrôle sur la fiche tiers (cli) | cl_nom
10 | Contrôle existence d'adresse secondaire (cli2) | aucune valeur

Dans cet exemple, on paramètre le TSC 020 et on indique :

- qu'un code FEFCO sera stocké dans ce TSC,

- que l'existence du code FEFCO sera contrôlée,

comme le montre le détail de la note commençant par Z expliqué ici :

Caractère | Code | Signification
1 | Z | Note commençant par Z (paramétrage des zones de saisie)
2 | G | Zone ic_char3_30 (zone alphanumérique de 30 caractères) C'est dans cette zone que l'on veut stocker le code FEFCO qui sera saisi.
3,17 | Code Fefco : | Libellé de la zone lors de la saisie
18 | N | Saisie facultative
19,20 | 03 | L'existence du code FEFCO saisi sera contrôlée par rapport à la table des codes ECMA/FEFCO.
21,23 | [rien] |
24 | L | On affiche le libellé.
25,29 | [rien] | Pas de format d'affichage particulier
40,41 | [rien] | Pas de longueur d'affichage particulière
42,56 | Code Fefco : | Libellé de la zone lors de l'affichage
57,58 | [rien] | Langue d'affichage; par défaut, en français
59 | [rien] | Pas de casse particulière

Dans ce tableau, les paramètres qui nous intéressent ici sont surlignés en jaune.

Si, lors de la saisie du TSC 020, on a entré le code 201, alors la syntaxe TSC_LIB_MP_AA_020_G renverra CAISSE AMERICAINE A RABATS NORMAUX.

3) Syntaxe 3, variante 2 - Cas particulier où le code zone = X

La syntaxe est la suivante: :

TSC_LIB_TypeTable_Origine_CodeTSC_X

Cette syntaxe permet de récupérer le libellé long du par02 du TSC quelque soit le TypeTable et l'Origine.

Exemple

TSC_LIB_**_**_020_X renverra FEFCO DESSUS / DESSOUS.

Dans cet exemple, nous avons volontairement mis des astérisques en guise de TypeTable et Origine, car ces valeurs ne sont pas utilisées.

Cependant, vous devez indiquer des valeurs (autres que des astérisques) pour respecter la syntaxe.

Types de tables, triés par ordre alphabétique

Type de Table

Origine

Clé

Type de clé

B1

NU

Entête de BL

L

B2

NU

Ligne de BL

L

BR

EN

Entête de BR (p_bre.bre_bon)

Y

LI

Entête et ligne de BR (p_brd.brd_bon, "-", p_brd.brd_lig)

Y

CA

nn

Cascading pour les TSC dans les visualisations, avec la syntaxe suivante :

TSC_CA_nn_xxx_y

TSC_CA indique un TSC en cascade

nn indique le numéro de cascade (01 à 03)

xxx = Code TSC

y = Zone TSC à visualiser

Cascade 01

On prend d'abord le TSC sur la ligne de commande.

S'il n'existe pas, on le prend sur le triplet (article, gamme, numéro de phase).

S'il n'existe pas, on le prend sur le produit.

S'il n'existe pas, on le prend sur le client.

Cascade 02

On prend d'abord le TSC sur le couple Client de la commande + Adresse de livraison de la ligne de commande.

S'il n'existe pas, on le prend sur le couple Client de la commande + Adresse de livraison de l'entête de commande.

S'il n'existe pas, on le prend sur le Client de la commande (adresse principale).

Cascade 03

Identique à la cascade 01 sauf que la recherche se fait en amont sur le TSC 200 (code gamme) du code produit (variable p_mp).

Cascade P3 (pour les commandes clients)

Identique à la cascade 01 sauf que la recherche se fait en amont sur le TSC 200 (code gamme) du code PF (variable p_mp_pf).

CL

CL

p_cl.cl_code

F

C2

p_c2.c2_code, p_c2.c2_adr

F

FA

p_c2f.c2_code, p_c2f.c2_adr

F

LI

p_c2l.c2_code, p_c2l.c2_adr

F

CNI

7

cni_id_conteneur <VF>

Voir la note TYPE_TSC_PAP_BOBM dans voluedit_blv

7

CNP

7

cni_id_conteneur <VF>

Voir la note TYPE_TSC_PAP_BOBM dans voluedit_blv

7

DV

DD

gl_cle_devis, "-",

gl_cle_sous_devis using "<<&"

D

EC

CL

p_ec.ec_cli

F

NU

p_ec.ec_num

C

EV

[blanc]

Pour v_evt

01,19 Numéro de l'OF

20,22 SBS (en dur)

23,28 Numéro de phase

29,32 Numéro de ligne

5

F2

[blanc]

Pour v_fab2

01,19 Numéro de l'OF

20,22 Type de gamme

23,28 Numéro de phase

29,32 Numéro de ligne

5

FA

LI

Ligne de facture (p_fl.fl_fac-p_fl.fl_lfac using "<<<&")

0

NU

Entête de facture (p_fe.fe_fac)

1

FF

NU

Entête de facture fournisseur (p_ff0.ff0_piece)

2

LI

Ligne de facture fournisseur (p_ff1.ff1_piece – p_ff1.ff1_ligne_piece)

2

FI

AA

p_fi.fi_prod_ent

A

DD

P_fi.fi_devis, "-",p_fi.fi_sdevis, "/", p_fi.fi_entite

D

FS

NU

p_ge.ge_code_gamme

1

GAM

CG

p_ge.ge_code_gamme

G

GB

EN

Entête de groupage

I

LI

Ligne de groupage

I

L2

AA

p_l2.l2_code_prod

A

DD

p_l2.l2_devis, "-",

p_l2.l2_sdevis using "<<&"

D

LC

AA

p_lc.lc_prod

A

AD

D, p_lc.lc_prod[2,15]

A

AI

I, p_lc.lc_prod[2,15]

A

AK

A, p_lc.lc_prod[2,15]

A

AN

N, p_lc.lc_prod[2,15]

A

AY

Y, p_lc.lc_prod[2,15]

A

LI

p_ec.ec_cli, p_lc.lc_adl

F

NU

p_lc.lc_num, "-", p_lc.lc_lig using "<<<<"

C

LCN0

YY

p_lc.lc_prod

YY = Racine de l'article composant de la nomenclature de l'article

A

LF

AA

p_lf.lf_prod

A

AD

D, p_lf.lf_prod[2,15]

A

AI

I, p_lf.lf_prod[2,15]

A

AK

A, p_lf.lf_prod[2,15]

A

AN

N, p_lf.lf_prod[2,15]

A

AY

Y, p_lf.lf_prod[2,15]

A

NU

p_lf.lf_num, "-", p_lf.lf_lig using "<<<<"

E

M0

MA

p_m0.m0_machine

M

RA

p_m0.m0_coder (machine de rattachement)

M

MF

p_m0.m0_reference (machine de référence)

M

MP

AA

p_mp.mp_code

A

AD

D, p_mp.mp_code[2,15

A

AE

p_mp.mp_code

A

AI

I, p_mp.mp_code[2,15]

A

AK

A, p_mp.mp_code[2,15]

A

AN

N, p_mp.mp_code[2,15]

A

AY

Y, p_mp.mp_code[2,15]

A

CL

Code client de l'article (mp_cli)

A

FC

Code fournisseur chez le client de l'article (mp_foucli)

A

OU

p_mp_outil.mp_code

A

PA

CIC C24 de p_mp.mp_code

Possibilité de paramétrer les TSC de l'article palettisation de l'article.

Celui-ci est stocké dans un TSC de l'article.

Le code TSC et le numéro de la zone utilisés sont paramétrés sur le paramètre CIC C24 (A1[1,3] et A1[4]).

A

PD

D, p_mp_pf.mp_code[2,15]

A

PF

p_mp_pf.mp_code (correspond à l'article du la séquence du devis dans le programme v_don).

A

PI

I, p_mp_pf.mp_code[2,15]

A

PK

A, p_mp_pf.mp_code[2,15]

A

PN

N, p_mp_pf.mp_code[2,15]

A

PY

Y, p_mp_pf.mp_code[2,15]

A

QM

Qualité Matière

Clé = p_mp.mp_qualite_matiere

A

MPN0

YY

p_mp.mp_code

YY = Racine de l'article composant de la nomenclature de l'article

A

NC

AA

p_nc.nc_prod ou p_lc.lc_prod si nul

A

AD

D, p_nc.nc_prod[2,15] ou D, p_lc.nc_prod[2,15] si nul

A

AI

I, p_nc.nc_prod[2,15] ou I, p_lc.nc_prod[2,15] si nul

A

AK

A, p_nc.nc_prod[2,15] ou A, p_lc.nc_prod[2,15] si nul

A

AN

N, p_nc.nc_prod[2,15] ou N, p_lc.nc_prod[2,15] si nul

A

AY

Y, p_nc.nc_prod[2,15] ou Y, p_lc.nc_prod[2,15] si nul

A

NU

p_nc.nc_num, "-", p_nc.nc_lig using "<<<<<", "-", p_nc.nc_seq using "<<<<<"

C

NCN0

YY

p_nc.nc_prod

YY = Racine de l'article composant de la nomenclature de l'article

A

RCE

NU

p_rce.rce_num_rec

N

Types de clés

Type de clé | Classe de l'information liée à la clé | Zone
A | Article | Code article
B | Couple Article-Tiers | Couple Article - Client Caractères 1 à 15 : code article Caractères 16 à 21 : code client Caractères 22 à 24 : code adresse
C | Commande : Entête | Numéro de la Commande
 | Commande : Ligne | Numéro de la commande, "-", Numéro de ligne using "<<<<<"
 | Commande : Nomenclature | Numéro de la commande, "-" Numéro de ligne using "<<<<<", "-" Numéro de séquence "<<<<<"
D | Devis | Numéro de devis
 | Devis / sous-devis | Numéro de devis, "-", Numéro de sous-devis using "<<<"
 | Devis / sous-devis/entité | Numéro de devis, "-", Numéro de sous-devis using "<<<", "/" Numéro d'entité using "<<<"
 | Devis/sous-devis/entité-référence | Numéro de devis + "-" Numéro de sous-devis using "<<<" + "/" Numéro d'entité using "<<<" + "-"
 | Devis / sous-devis / entité / phase | Numéro de devis, "-", Numéro de sous-devis using "<<<", "/", Numéro d'entité using "<<<", "/", Numéro de phase using "&&&"
 | Devis / sous-devis / entité / phase-ligne roulage | Numéro de devis, "-", Numéro de sous-devis using "<<<", "/", Numéro d'entité using "<<<", "/", Numéro de phase using "&&&", "-", Numéro de ligne using +"<<"
E | Commande d'achat : entête | Numéro de la commande d'achat
 | Commande d'achat : ligne | Numéro de la commande, "-", Numéro de ligne using "<<<<<"
F | Tiers et adresses secondaires | Code tiers (TTTTTT) OU Code tiers et adresse secondaire (TTTTTTAAA)
G | Gamme standard | Code gamme standard
H | Historisation offre de vente carton ondulé | N° de devis, "-", N° d'offre, "-", Code article(Spécifique)
I | Ligne de groupage | Numéro du groupage, "-", Numéro de ligne du groupage using "<<<<<"
J | Lot expédition | N° de série du lot d'expédition
K | ECMA - FEFCO | Code ECMA - FEFCO
L | Livraison : entête | Numéro de bon de livraison
 | Livraison : ligne | Numéro de bon de livraison, "-" Numéro de ligne using "<<<<<"
M | Machine | Code machine
N | Non-conformité (réclamation) | Code réclamation
O | Ordre de fabrication | Ordre de fabrication
grand P | Variantes de production | code article, "-", N° de variante de production using "<<<"
petit p | PREACTOR | Numéro sous-of clipped, "/", Numéro d'opération
Q | Demande d'achat (entête) | N° de demande d'achat
 | Demande d'achat (ligne) | N° de demande d'achat, "-" N° de demande d'achat-N° de ligne
R | Préparation des groupages (entête) | Date de départ using "yyyymmdd", Code client, Code adresse de livraison, Code lieu de déstockage, Indice d'éclatement using "&&"
S | Estampille | Type d'estampille, Code estampille, Niveau estampille
T | Triplet (article, gamme, phase) | La codification de la clé est impérative : (ne jamais clipper les zones) Caractères 1 à 15 : code article Caractères 16 à 18 : code gamme Caractères 19 à 22 : N° de phase using "###&"
U | Demande d'achat (fournisseur) | Code fournisseur
grand V | Action VoluGold | Code tiers, "-", Numéro d'ordre action using "<<<<"
petit V | Réservé Volume |
W | Couple article - gamme | Caractères 1 à 15 : code article Caractères 16 à 21 : code gamme
X | Bon de réception des bobines: Entête | Article-gamme
Y | Bon de réception ou de retour des marchandises : Entête et Lignes | Entête : Numéro de bon de réception ou de retour des marchandises Ligne : Numéro de bon de réception ou de retour des marchandises, "-", Numéro de ligne using "<<<<"
Z | Pré-facture | N° de la facture (Spécifique)
$ | (dollar) Action | N° de série de l'action
0 | Facture client | N° de facture
1 | Facture de simulation |
2 | Facture fournisseur (entête) | N° de facture fournisseur
 | Facture fournisseur (lignes) | Numéro de facture fournisseur, "-", Numéro de ligne using "<<<<<"
3 | Autorisation SFAC | Code client Type d'autorisation Numéro d'autorisation SFAC (ou agrément)
4 | Mouvement de stock | Code produit-Numéro de mouvement de stock [s0_prod+C15|-|s0_num+<<<<<]
4 | Lignes d'impressions multiples (devis) | Numéro de devis ,"-" Numéro de sous-devis using "&&&" ,"-" Numéro d'entité using "&&&" ,"-" Numéro de type using "&&&" ,"-" Numéro de passage using "&&&" ,"-" Numéro de vernis using "&&&"
5 | Saisie des temps (table fab2) | 01,19 Numéro de l'OF 20,22 Type de gamme 23,28 Numéro de phase 29,32 Numéro de ligne
6 | Article-Lieu de rangement | 01,15 Code article 16,18 RGT1
7 | Conteneur (info ou produit) Voir la note TYPE_TSC_PAP_BOBM dans voluedit_blv | 01,23 ID conteneur

A propos du type 4

Il est utilisé par :

- Mouvement de stock

- Lignes d'impressions multiples

Pour les distinguer : Les informations sur les mouvements de stock ont 1 tiret en caractère 16, alors que celles sur lignes d'impressions multiples n'en ont pas :

Mouvement de stock | PPPPPPPPPPPPPPP-MMMMM
 | 1 2 1234567890123456789012345678
Lignes d'impressions multiples | DDDDDDDD-SSS-EEE-TTT-PPP-VVV


TSF Types de structures force de vente

Valeur alpha 1

TSF A1[1]

Utilisé dans le transfert des écritures dans ORIAC

Correspond au 1er caractère du champ dossier mouvement

(Zone 022 du fichier de transfert)

REP A4[26,28] > SFV A1[1,3] > TSF


TSI Types de signets

Valeur alpha

TSI A1[1,15]

Code signet à utiliser

Le code saisi doit figurer dans le fichier des matières.


TTA Types de tranchefiles

Valeur alpha

TTA A1[1,15]

Code tranchefile à utiliser

Le code saisi doit figurer dans le fichier des matières


Recherche de la phase dans l'intégration OSYS si elle n'est pas prévue au dossier.

Recherche dans la note C[40,42] du TTR si une phase est associée au code opération

Si oui et si elle correspond à la phase OSYS, on prend celle-ci.

Sinon, on recherche le code phase par défaut dans PHA A3[52,54] et le code opération du triplet (caractères 4, 5 et 6).

Si trouvé et si elle correspond à la phase OSYS, on prend celle-ci.

Sinon, anomalie, phase n'est pas créée.

TTR Type de travail

Attention les codes paramètres #P et #R sont réservés :

Le code #P | TTR par défaut pour opération de type P préparation (calage - réglage)
Le code #R | TTR par défaut pour opération de type R ou indéfini réalisation (roulage)

Valeurs numériques

TTR N1 | Valeur minimum pouvant être saisie dans la zone quantité (en saisie de temps)
TTR N2 | Valeur maximum pouvant être saisie dans la zone quantité (en saisie de temps)

Valeur alpha 1

TTR A1[1] | P ou R ou [espace]. En général, il faut laisser ce caractère à blanc. P préparation (calage - réglage) R réalisation (roulage) [par défaut] Pour le calcul du prix de revient, ce code intervient si l'opération n'est pas typée R ou P. C'est ce code qui est prioritaire sur le code saisi sur l'opération dans certains états statistiques.
TTR A1[2] | N temps non affectable au dossier [par défaut] D temps affectable au dossier Ce code concerne principalement le prix de revient. Il n'a aucune incidence sur les statistiques machine.
TTR A1[3] | Utilisé pour la saisie des quantités en calage. N Non Exemple : suite de calage Le nombre de calages à comptabiliser est égal à 1 quelque soit la quantité saisie. Q Le nombre de calages à comptabiliser est saisi dans la quantité réalisée.
TTR A1[4] | E Exclu (temps exclu de l'analyse d'activité par section ana_a) A Affectable (temps affectable à l'analyse d'activité) N Non affectable (temps non affectable à l'analyse budgétaire) Pour La liste des TTR, les choix possibles sont : 1 premier groupe 2 deuxième groupe différent de 1 et 2 = troisième groupe
TTR A1[5] | O Emploi hors machine (type 16) N Emploi machine
TTR A1[6] | C Supplément client A Supplément du erreur atelier N Normal
TTR A1[7] | Arrêt (O/N). Statistiques machines O le temps est utilisé pour valoriser les arrêts machines (si le caractère 11 le précise). Le temps saisi n'entre pas dans le temps de calage si l'arrêt a lieu sur un calage. Le temps saisi n'entre pas dans le temps de roulage si l'arrêt a lieu sur un roulage. La quantité saisie n'entre pas dans la quantité roulée si l'arrêt a lieu sur un roulage. Ventilation des arrêts machine Seuls les TTR dont A1[7] = O sont pris en compte dans l'état. Remarque : les temps d'arrêt sont ventilables en 3 catégories (voir A1[13, 14 et 15] Si un arrêt n'appartient à aucune des trois catégories, le temps sera cumulé au total des temps d'arrêt.
TTR A1[8] | Temps travaillé (O/N)
TTR A1[9] | Temps de calage à comptabiliser (O/N) Le temps est comptabilisé en calage s'il ne s'agit pas d'un arrêt et si on est en "préparation". Voir caractère 1. Si caractère 1 R et caractère 9 O alors on ne compte pas le temps en préparation.
TTR A1[10] | Temps de roulage à comptabiliser (O/N) Le temps est comptabilisé en roulage s'il ne s'agit pas d'un arrêt et si on est en "réalisation". Voir caractère 1.
TTR A1[11] | Temps d'arrêt a comptabiliser (O/N) (Il faut bien sur qu'il s'agisse d'un arrêt donc que le caractère 7 soit O)
TTR A1[12] | N Calage à ne pas comptabiliser dans stat4 O Calage à comptabiliser dans stat4 (1) Q Calage à comptabiliser dans stat4 (Ajoute: la quantité saisie)
TTR A1[13] | Temps d'arrêt 1 à comptabiliser (O/N) Ventilation des arrêts machines : Si ce caractère est à O et si le caractère 7 est à O, le temps est comptabilisé dans le premier type d'arrêt.
TTR A1[14] | Temps d'arrêt 2 à comptabiliser (O/N) Ventilation des arrêts machines : Si ce caractère est à O et si le caractère 7 est à O, le temps est comptabilisé dans le deuxième type d'arrêt.
TTR A1[15] | Temps d'arrêt 3 à comptabiliser (O/N) Ventilation des arrêts machines : Si ce caractère est à O et si le caractère 7 est à O, le temps est comptabilisé dans le troisième type d'arrêt.
TTR A1[16] | Temps pris en compte dans contrôle saisie journalière (O/N)
TTR A1[17] | Compatibilité ou incompatibilité (C/I) avec phase saisie Si C, il y aura contrôle de compatibilité avec le code opération saisi. Si I, il y aura contrôle d' incompatibilité avec le code opération saisi. Si [espace], il n'y aura aucun contrôle. Voir la note commençant par C.
TTR A1[18] | Prise en compte du TTR au niveau de l'édition du tableau détail travail (par salaire, par machine, etc.) du prix de revient (O/N)
TTR A1[19] | Le temps sera additionné ou non dans le temps réalisé pour le calcul de l'encours (O/N, O par défaut))
TTR A1[20] | Utilisé dans list_ttr.4ge (Récap liste des types de travail) 1 Première famille de TTR (En général PRODUCTIF) (dont le libellé est paramétré dans le paramètre de lancement du programme.) 2 Deuxième famille de TTR (En général IMPRODUCTIF) (dont le libellé est paramétré dans le paramètre de lancement du programme.)
TTR A1[21] | TTR suivi en cumul (Oui ou Non).
TTR A1[22] | Prise en compte du temps dans le programme Récapitulatif des temps de travail (sp_tps_sal)
TTR A1[23] | Contrôle de cohérence en saisie de temps P ce TTR ne pourra être saisi que sur une opération de préparation ou calage R ce TTR ne pourra être saisi que sur une opération de réalisation ou roulage Autre caractère : il n'y a pas de contrôle
TTR A1[24,26] | Code classe de TTR du TTR (Type paramètre de la classe de TTR : CTT)
TTR A1[27] | Prise en compte du temps dans le programme : Récapitulatif des temps par paramètre cde (ec_c1) et opération (programme : recsi ) Tableau de bord du multisite
TTR A1[28] | Contrôle de cadence ou du temps standard en saisie de temps (O/N, O par défaut)
TTR A1[29] | Aléa affectable à l'OF en cours ? (O/N, O par défaut) Si Non : aléa affecté à un OF spécial, défini en alpha 3 L'aléa est alors appelé Indirect d'atelier (géré par la remontée des temps et matières en atelier par terminaux d'atelier et capteurs.)
TTR A1[30] | Utilisé par le programme de statistiques de saisie des temps à rupture paramétrable (stat_fab2.4ge) L'utilisateur en déterminera le contenu pour créer des familles de TTR
TTR A1[31] | Contrôle la saisie multiple de lignes de temps sur une phase N Pas de contrôle B Contrôle bloquant W Warning
TTR A1[32] | Temps pris en compte dans le traitement de mise à jour de la répartition des temps de travail par fonction et centre de coût.
TTR A1[33] | Caractère libre Il est UNIQUEMENT utilisable dans les traitements spécifiques
TTR A1[34] | Le temps est-il imputable au "Temps d'ouverture" machine (O/N) ?
TTR A1[35] | Le temps est-il imputable au "Temps potentiel" machine (O/N) ?
TTR A1[36] | Le temps est-il imputable au "Temps planifié" machine (O/N) ?
TTR A1[37] | Le temps est-il imputable au "Temps brut de fonctionnement" machine (O/N) ?
TTR A1[38] | Le temps est-il imputable au "Temps net de fonctionnement" machine (O/N) ?
TTR A1[39] | Le temps est-il imputable au "Temps de marche" machine (O/N) ?
TTR A1[40] | Le temps est-il imputable au "Temps de production" machine (O/N) ?
TTR A1[41] | Le temps est-il imputable au "Temps utile" machine (O/N) ?
TTR A1[42] | Le temps est-il un temps réalisé pris en compte dans le chargement des calendriers (par le programme gp_ch) (O/N, N par défaut)
TTR A1[43] | Le temps est-il un temps réalisé interdisant l'annulation du cadencement de fabrication ? (O/N, O par défaut)

Valeur alpha 2

(Utilisée dans le programme de décompte des éléments de paie).

Chaque caractère correspond a un compteur. Vous devez répondre par O si le temps saisi doit alimenter le compteur correspondant et par N dans le cas contraire.

TTR A2[1] | Compteur 1 Réservé VOLUME. Temps dû
TTR A2[2] | Compteur 2
TTR A2[3] | Compteur 3
TTR A2[4] | Compteur 4
TTR A2[5] | Compteur 5
TTR A2[6] | Compteur 6
TTR A2[7] | Compteur 7
TTR A2[8] | Compteur 8
TTR A2[9] | Compteur 9
TTR A2[10] | Compteur 10
TTR A2[11] | Compteur 11
TTR A2[12] | Compteur 12
TTR A2[13] | Compteur 13
TTR A2[14] | Compteur 14
TTR A2[15] | Compteur 15
TTR A2[41] | Décompte de paie en temps (blanc ou T). Décompte de paie en quantité.
TTR A2[42] | Saisie des quantités et des rebuts pour ce TTR (O/N, O par défaut)
TTR A2[43] | Ouverture automatique de la fenêtre de saisie de notes (O/N, N par défaut) On peut maintenant ouvrir automatiquement une fenêtre de saisie d'une ligne de 60 caractères visant à alimenter la zone evt_note (note sur un événement) lors d'un changement de TTR sur un dossier.
TTR A2[44] | Saisie du nombre de palette et de la quantité par palette N Pas d'ouverture de la saisie (Valeur par défaut) O Ouverture de la saisie avec remontée automatique de la quantité produite E Ouverture de la saisie sans remontée automatique de la quantité produite (étiquettes seules donc] Voir aussi sbs note ETIQPROD_IMP

Valeur alpha 3

(Utilisée dans le programme de remontée des temps et matières)

Cette zone est utilisée lorsque le TTR correspond à un indirect d'atelier (Exemple : Manutention, Tonte de pelouse, etc.)

alpha1[29] = N.

TTR A3[1,10] | numéro de commande dédiée à cette activité.
TTR A3[12,15] | numéro de phase dédiée à cette activité.
TTR A3[16,19] | Code TTR AQUIVUS
TTR A3[20,24] | Numéro de phase du TTR saisi dans la zone de saisie de la phase ou de l'opération dans le module de saisie des temps atelier par code à barres (G_sbs) Obligatoire - 1 à 32500 Voir la note CREATION_AUTO_PHASES dans G_sbs.

Valeur alpha 4

TTR A4[1,3] | code famille d'arrêt (paramètre de type FAR) (utilisé dans certaines statistiques spécifiques)
TTR A4[4,15] | Code arrêt PC_TOPP (utilisé dans l'intégration MIDATA) Passage de 6 à 12 caractères

Notes

C

Ces lignes permettent d'effectuer un contrôle lors de la saisie des temps de production.

Elles sont en rapport avec TTR A1[17].

Elles permettent de définir avec quelles opérations le TTR est compatible (A1[17] = C) ou incompatible (A1[17] = I)

Sur les lignes, vous devez saisir par groupe de 9 caractères la liste des opérations compatibles ou incompatibles.

2,10 Code triplet de l'opération

40,42 Phase VoluPack associée à cette opération (ne concerne que l'interface avec OSYS - programme importe_osys - plus d'info)

3 exemples

(1) TTR C1P (calage 1 plaque)

A1[17] = C

Ce TTR ne peut être saisi que sur l'opération de calage machine.

Notes : CIMPIMFCAL

(2) Si un TTR peut être saisi sur toutes les opérations, A1[17] doit être à blanc.

(3) TTR AP (attente plaque)

A1[17] = C

Ce TTR peut être saisi sur l' opération de calage machine et de copie.

Notes : CIMPIMFCALLABCOPPLA

CODE_ARRET_XXX

Gestion des codes arrêts par sites, où XXX = code site (alpha3[13,15] dans fab_ond_integre)

21,26 Code arrêt PCTOPP

Tableau de bord du multisite

POUR_DEP_QTE

21,23 Pourcentage de tolérance pour le dépassement de la quantité lancée.

Nécessaire avec la note FEN_AUTO_NTS_QTE_D dans la saisie des temps ou le TSC contextuel.

Si 999, alors pas de contrôle.

Cette note est prioritaire sur celle de la saisie des temps.

POUR_DEP_TPS

21,23 Pourcentage de tolérance pour le dépassement du temps prévu.

Nécessaire avec la note FEN_AUTO_NTS_TPS_D dans la saisie des temps ou le TSC contextuel.

Si 999, alors pas de contrôle

Cette note est prioritaire sur celle de la saisie des temps.


TVA Taxe sur la valeur ajoutée

Modification des taux de TVA en 2014

Soit le code TVA OLD indiquant l'ancien taux.

Soit le code TVA NEW indiquant le nouveau taux.

1. Recopiez (dupliquez) TVA OLD en TVA NEW.

Dans TVA NEW, indiquez le nouveau taux (20 %).

2. Dans TVA OLD, indiquez le nouveau code à appliquer ainsi que la date de mise en vigueur :

A2[17,24] = 01012014 (date d'application de la nouvelle TVA)

A2[25,27] = NEW (nouveau code TVA à appliquer)

3. Dans le calcul des factures, pour une date ultérieure au 01/01/2014, l'ancien code TVA OLD (issu des commandes) sera automatiquement remplacé par TVA NEW.

4. A faire à partir du 1er janvier 2014 : Mettre à jour les fiches articles : remplacer le code TVA OLD par NEW.

Valeurs numériques 1 et 2 [image] Valeur alpha 1 [image] Valeur alpha 2 [image] Valeur alpha 3 [image] Valeur alpha 4 [image] Notes - Changement de taux

Valeurs numériques

TVA N1 | Pourcentage de TVA. Exemple : 20.6
TVA N2 | Pourcentage d'une taxe parafiscale

Valeur alpha 1

TVA A1[1,8] | Code comptable pour le transfert en compta de la TVA des factures clients (classe 4)
TVA A1[9,16] | Code comptable pour le transfert en compta de la taxe parafiscale des factures clients (classe 4)
TVA A1[17] | % ou [espace] La taxe parafiscale est en % M La taxe parafiscale est un montant par quantité
TVA A1[18,25] | Code comptable pour le transfert en compta de la TVA des factures fournisseurs (classe 4)
TVA A1[26,33] | Code comptable pour le transfert en compta de la taxe parafiscale des factures fournisseurs (classe 4)
TVA A1[34] | Type de TVA D TVA sur les débits (par défaut) E TVA sur les encaissements
TVA A1[35,42] | Code comptable pour le transfert en compta de la taxe parafiscale des factures clients en suspension de TVA (classe 4)
TVA A1[43,50] | Code comptable pour le transfert en compta de la taxe parafiscale des factures clients en intracommunautaire (classe 4)

Valeur alpha 2

TVA A2[1,8]

Taux de la taxe parafiscale fournisseur

TVA A2[9,16]

Code comptable pour le transfert en compta de la taxe parafiscale des factures clients en export
(classe 4)

TVA A2[17,24]

Date d'application du nouveau code TVA (JJMMAAAA)

TVA A2[25,27]

Nouveau code TVA

TVA A2[28,35]

Code comptable pour le transfert en compta de la taxe parafiscale des factures clients en exonération (classe 4)

TVA A2[36]

Code TVA pour transfert en compta REEL

TVA A2[37]

Mode exonération de la ligne de facture ou d'avoir et de la ligne de frais d'expédition

[espace] celui de la facture ou de l'avoir

N Taxable

O Export

S Suspension de taxe

I Intracommunautaire

E Exonération

Utilisé uniquement dans le transfert des factures / avoirs (tr_fcnn_vl et tr_fac_fou)

et la visualisation du transfert des factures / avoirs (v_tdv)

TVA A2[38,40]

Code de registre de taxe.

Ce numéro est obligatoire pour mettre à jour le fichier de registre de taxe.

TVA A2[41,48]

SAGE100 interface 2 : Compte comptable de TVA pour les avoirs

Le compte de TVA est différent s'il s'agit d'un avoir (cas de la Belgique)

TVA A2[49,52]

Code zone de TVA pour JDE. La valeur est obligatoire et contrôlée.

TVA A2[53,55]

Code environnement pour valorisation des matières dans la génération de dossier

TVA A2[56]

Ajout d'un droit de timbre à chaque facture calculée (O/N, N par défaut)

L'ajout d'un droit de timbre dépend aussi du client (cl_param[21]).

L'ajout d'un droit de timbre dépend aussi du TYC de la commande facturée (Voir TYC A1[21]) et du client (Voir caractère 21 de la zone de données diverses du client).

Le montant du droit de timbre est paramétré dans une note commençant par DROIT_DE_TIMBRE sur le paramètre #CF FAC.

TVA A2[57]

Ajout du montant de la taxe parafiscale à la base HT pour le calcul de la TVA (O/N, O par défaut)

TVA A2[58]

Code TVA à l'export (O/N, N par défaut)

TVA A2[59]

Catégorie associée au code TVA

Paramétrage libre - Voir BLO A1[3,5] = 036

Valeur alpha 3

TVA A3[1,8] | Code comptable VENTE FRANCE (classe 7) pour le transfert en compta des factures clients Attention, l'utilisation d'attribution de compte via le code TVA , suppose à ce jour (23/08/1995 ) de ne pas renseigner le code vente par défaut sur #CFTRF
TVA A3[9,16] | Code comptable VENTE EXPORT (classe 7) pour le transfert en compta des factures clients
TVA A3[17,24] | Code comptable VENTE SUSPENSION DE TAXE (classe 7) pour le transfert en compta des factures clients
TVA A3[25,32] | Code comptable VENTE INTRACOMMUNAUTAIRE (classe 7) pour le transfert en compta des factures clients
TVA A3[33,40] | Code comptable VENTE EXONEREE (classe 7) pour le transfert en compta des factures clients
TVA A3[41,43] | Code pays de la TVA. Ce code est utilisé dans le transfert des écritures en comptabilité.
TVA A3[44,57] | Numéro d'immatriculation TVA pour le pays d'appartenance de ce code TVA

Valeur alpha 4

TVA A4[1,8] | Code comptable ACHAT FRANCE (classe 6) pour le transfert en compta des factures fournisseurs
TVA A4[9,16] | Code comptable ACHAT EXPORT (classe 6) pour le transfert en compta des factures fournisseurs
TVA A4[17,24] | Code comptable ACHAT SUSPENSION DE TAXE (classe 6) pour le transfert en compta des factures fournisseurs
TVA A4[25,32] | Code comptable ACHAT INTRACOMMUNAUTAIRE (classe 6) pour le transfert en compta des factures fournisseurs
TVA A4[33,40] | Code comptable ACHAT EXONERE (classe 6) pour le transfert en compta des factures fournisseurs
TVA A4[41,48] | Code comptable pour le transfert en compta de la TVA des bons de réception Bons de réception : voir la page récapitulative dans le #CF TFB

Notes triées

Changement du taux de TVA

Utilisé par tr_fcnn_vl

Suite au changement de taux de TVA, le code et le compte TVA REEL dépendent du code TVA et du mode d'application de la TVA de la facture. Voir les lignes de notes commençant par COMPTE_TVA_ ci-dessous.

CODE_TVA_A

Code TVA lors du transfert en compta Sage 2 pour les avoirs

21,23 Code TVA pour le type N – Normal

24,26 Code TVA pour le type I – Intracommunautaire

27,29 Code TVA pour le type E – Exonération

30,32 Code TVA pour le type O – Export

Voir la note SAGE_100_PARAM_GEN sur le #CF TRF et sur le #CF TFF.

CODE_TVA_F

Code TVA lors du transfert en compta Sage 2 pour les factures

21,23 Code TVA pour le type N – Normal

24,26 Code TVA pour le type I – Intracommunautaire

27,29 Code TVA pour le type E – Exonération

30,32 Code TVA pour le type O – Export

COMPTE_BRC

Paramétrage du compte de vente pour les bons de réception

Bons de réception : voir la page récapitulative dans le #CF TFB

21,28 Compte de vente France

29,36 Compte de vente Export

37,44 Compte de vente Suspension de taxe

45,52 Compte de vente Intra-communautaire

53,60 Compte de vente Exonéré

COMPTE_CS1_

Paramétrage particulier pour Interface des ventes avec la comptabilité FININFOR

12,14 Code fabrication

16,18 Code site - Tableau de bord du multisite

21,30 Compte de vente

31,50 Libellé

51,60 Sous-compte

COMPTE_TVA_

12 Code fiscalité (N, O, S, I, E)

13 Code TVA 302

14,21 Compte

COMPTE_TVA_ACH_

16 Mode d'exonération de la facture d'achat - Uniquement pour COBYS

N Taxable

O Export

S Suspension de taxe

I Intracommunautaire

E Exonération

21,23 Code TVA pour le transfert en comptabilité des lignes HT des factures d'achat

24,31 Code comptable TVA pour le transfert en comptabilité des lignes TVA des factures d'achat (classe 4)

_COMPTE_VENTE_AVO

Paramétrage du compte de vente pour les avoirs.

Pour l'ordre de recherche du compte de vente pour les avoirs, voir cette page

_TAUX_TAXE_JDE_

Taux de Taxe

16 Type de Taxe (N, O, S, I, E)

21,30 : Taux de taxe Achats

31,40 : Taux de taxe Ventes

TRANSCO_SAP

21,23 Transcodification du Code TVA chez SAP

TVA_ACHAT_ECHEANCE

21,28 Racine du numéro de compte de TVA à échéance

TVA_AUTO_LIQUIDEE

Compte TVA auto-liquidée

De la même façon que pour la TVA Intracommunautaire (note TVA_INTRA_ACHAT), cette note permet de paramétrer des comptes de débit et de crédit pour la TVA auto-liquidée.

Ceci permet de générer les écritures d'auto-liquidation sur ces comptes lors d'un transfert de factures fournisseurs en comptabilité avec le programme tr_fac_fou

21,28 Compte de TVA auto-liquidéeDébit

29,36 Compte de TVA auto-liquidéeCrédit

TVA_INTRA_ACHAT

Compte TVA Intracommunautaire

21,28 Compte TVA Intracommunautaire Débit

29,36 Compte TVA Intracommunautaire Crédit


TVE Types de véhicules

Valeur alpha 1

TVE A1[1,12] | Immatriculation par défaut
TVE A1[13,15] | Code EDI du code véhicule pour fichier AVIEXP (par défaut TE) Nécessite l'option -Oce sur edi_cde_aviexp
TVE A1[16,18] | Correspondance JDE
TVE A1[19,20] | Type de camion Utilisé dans la note GENERE_CDE_ACH_TRSP de l'interface de préfacturation

Valeur alpha 2

TVE A2[1,10] | Longueur du camion (en millimètres)
TVE A2[11,20] | Largeur du camion. Obligatoire pour l'intégration des tarifs dans le devis (en millimètres)
TVE A2[21,30] | Hauteur du camion (en millimètres)
TVE A2[31,40] | Poids maximum du camion (en kilos)
TVE A2[41,50] | Volume maximum du camion (en M3)
TVE A2[51,60] | Métrage linéaire maximum. Obligatoire pour l'intégration des tarifs dans le devis (en mètres)


TYB Type de bordereau

Pas de paramétrage.

Seul le libellé est utilisé.


TYC Types de commandes client

Notes #CC du TYC.

ec_acc Acompte

ec_ada Adresse accusé de réception

ec_adf Adresse de facturation

ec_adl Adresse de livraison

ec_c1 Zone paramétrable

ec_cderat Commande de rattachement
S'il est masqué, il le sera et pour l'entête et pour les lignes de commandes.

ec_cli_final Code client final

ec_cli_final_adr Code adresse client final

ec_corres Correspondant

ec_cr Code remise

ec_ct Code tarif

ec_date_client Date client
S'il est masqué, il le sera et pour l'entête et pour les lignes de commandes.

ec_date_deb_val Date de début de validité

ec_date_fin_val Date de fin de validité

ec_devise Code de la devise
S'il est masqué, il le sera et pour l'entête et pour les lignes de commandes.

ec_ech Code échéance

ec_esc Montant escompte (%)

ec_exp Exportation

ec_gestion_train Gestion du train

ec_issue_de Commande issue de

ec_mgr Code mode de règlement

ec_ord Numéro d’offre.
N'est affiché / masquable que dans les lignes de commandes.

ec_pht Port taxable

ec_pnt Montant Port non taxable

ec_ref_liaison Référence de liaison

ec_ref_reg_fact Référence regroupement facture

ec_rem Montant remise (%)

ec_rep Code représentant

ec_suiv suivi d'affaire (cde1.ec_suiv)

ec_texte Commentaire libre
S'il est masqué, il le sera et pour l'entête et pour les lignes de commandes.

ec_titre Titre du correspondant

ec_tour Code tournée

ec_tport Type de port

ec_transp Code transporteur

ec_trep Taux de commission

ec_trsp Type de transport

ec_tvap Code TVA du port taxable

ec_tyc Type de commande client (à ne masquer qu’en consultation ou en transfert de devis en commande)
S'il est masqué, il le sera et pour l'entête et pour les lignes de commandes.

ec_type_liaison Type de liaison

lc_adf

lc_adl

lc_delcli

lc_deldep

lc_delfab

lc_delrep

lc_heure_cli_tard

lc_heure_cli_tot

lc_heure_dep_tard

lc_heure_dep_tot

lc_heure_fab_tard

lc_heure_fab_tot

lc_heure_rep_tard

lc_heure_rep_tot

lc_lieu_rgt1

lc_logistique

lc_motif_mod_date

lc_p1

lc_p2

lc_p3

lc_qualif_appel

lc_tolerance_liv

Pour le champ 3, vous DEVEZ obligatoirement renseigner le type de table pour contrôle.

Si vous ne souhaitez pas contrôler ce champ, mettez XXX mais ne laissez pas cette zone à blanc sinon le champ 3ne sera plus accessible dans la revue de contrat.

La commande d'achat doit avoir le site de la commande d'origine.

lf_cli avec le client de la commande initiale

lf_affect avec la valeur lc_cderat + lc_lcderat de la ligne de commande d'origine

le client livré de l'entête (ef_client_liv) et l'adresse secondaire de livraison (ef_adl) avec le client de la commande initiale et l'adresse secondaire de livraison de l'entête de la commande initiale (la FB2).

Retirer le correspondant actuel sur la commande d'achat (ef_corres et ef_titre) et mettre le correspondant du fournisseur (cl_corres, cl_titre)

1 2 3 4

1234567890123456789012345678901234567890

NEW_TYC_TRANSCDESITECIN009NCAR004O#CFTAR2N

La commande initiale est une commande de type FB2 que l'on veut sous-traiter, son TYC va passer de FB2 à CSA.

La commande générée sera de TYC CIN, et utilisera le compteur 009.

La commande initiale sera seulement mise à jour au niveau du TYC (passage de FB2 = CSA), pas de modification de ses mouvements de stocks.

La commande d'achat générée sera de TYC NCA, et utilisera le compteur 004.

Le prix de la ligne de commande générée sera le prix de cession de la commande d'origine.

La recherche de tarif pour la commande générée se fera avec #CFTAR.

On utilise la méthode 2 pour alimenter la commande d'achat.

On ne conserve pas le correspondant de la commande initiale.

TYC Types de commandes client

Valeur alpha 1 Valeur alpha 2 Valeur alpha 3 Valeur alpha 4 Notes

Attention

Aucune modification de ce paramétrage ne doit être effectuée sans consultation de Volume Software sous peine de dysfonctionnement grave.

Les TYC standards :

AVO - CD1 - CD2 - CD3 - CDA - CDI - CDP - CTR - FAD - FB1 - FB2 - FB3 - FBA - FBI - FBM - FBP - PRO - PRX - SIM

Valeur alpha 1

TYC A1[1]

Type de commande

F Facture (valeur par défaut)

A Avoir

TYC A1[2]

Contrôle du stock à la saisie de la commande

O Contrôle bloquant

W Contrôle non bloquant

N Pas de contrôle (valeur par défaut)

TYC A1[3]

Déduire ou augmenter le stock de la quantité commandée à la saisie de la commande

et créer un mouvement de stock :

O en sortie normale

R en sortie réserve

E en entrée normale

P en entrée prévisionnelle avec la quantité commandée (mise à jour de lc_nummvt)

B en sortie besoin

N Pas de mise à jour de stock (valeur par défaut) : autorise l'exploitation de alpha3[51] et alpha3[53].

TYC A1[4]

Prise en compte dans les statistiques du nombre de commandes clients et du CA en commande (O/N, O par défaut)

TYC A1[5]

Edition d'un accusé de réception

O Dépend de cl_param[3]

N/I Non (valeur par défaut)

ATTENTION : Effet non rétroactif

TYC A1[6]

Edition d'un ordre d'exécution

O Oui

N/I Non (valeur par défaut)

ATTENTION : Effet non rétroactif

TYC A1[7]

Plus de saisie de la facture de rattachement sur l'entête de commande.

La saisie de la facture de rattachement et de la ligne de la facture de rattachement est faite sur la ligne de commande.

Le client de la commande et le client de la facture de rattachement peuvent être différents.

Lors de la saisie d'une facture directe (FAD) ou d'un avoir (AVO), saisie de la facture de rattachement et de la ligne de la facture de rattachement

N Non (valeur par défaut)

Saisie de la facture de rattachement sur l'entête de commande et de la ligne de la facture de rattachement sur la ligne de commande (O/T/W)

Le client de la commande et le client de la facture de rattachement doivent être identiques.

O Oui pour les clients faisant l'objet d'un affacturage ( cl_param[10] = O ou F)

T Oui pour tous les clients quelque soit la valeur de cl_param[10]

W Avertissement

Saisie de la facture de rattachement et de la ligne de la facture de rattachement sur la ligne de commande (o/t/w)

Le client de la commande et le client de la facture de rattachement peuvent être différents.

o Oui pour les clients faisant l'objet d'un affacturage (cl_param[10] = O ou F)

t Oui pour tous les clients quelque soit la valeur de cl_param[10]

w Avertissement

TYC A1[8]

Génération de fab0

N Pas de génération

B Génération pour les commandes de type FAD

O Génération pour les articles synchrones et asynchrones des commandes de type FBx

S Génération pour les articles synchrones des commandes de type FBx

Le mode de réapprovisionnement est paramétré dans le A2[1] du REA du code réapprovisionnement de la fiche article (mp_reap).

Par défaut, les articles sont des articles synchrones.

TYC A1[9]

Autorisation de copie de commande (O/N, O par défaut)

TYC A1[10]

Passage du code prospect en code client dès la saisie de la commande (O/N, N par défaut)

TYC A1[11]

Saisie d'un bon de livraison (O/N, N par défaut)

TYC A1[12]

Contrôle du stock à la saisie du BL

O Contrôle bloquant

W Contrôle non bloquant

C Contrôle avec confirmation

N Pas de contrôle (valeur par défaut)

Remarque Possibilité de paramétrer le type de contrôle du stock (Caractère 14)

TYC A1[13]

Déduire le stock de la quantité livrée à la saisie du BL et créer un mouvement de stock

O en sortie normale

R en sortie réserve

N Pas de mise à jour de stock (valeur par défaut)

TYC A1[14]

Type de contrôle du stock à la saisie du BL

1 Sur le stock global de l'article

2 Sur le stock du lot de l'article

3 Sur le stock du mode de gestion de l'article, selon mp_param[17]

G Sur le stock global

L Sur le stock du lot

I ou 1 Sur le stock du lieu

B ou 2 Sur le stock du lot lieu

N Sur le stock du lot si c'est un article cartonnier (mp_param[29] égal à 1)

Sur le stock global si ce n'est pas un article cartonnier (valeur par défaut)

Remarque Ceci est effectif si le caractère 12 est différent de N

TYC A1[15]

Contrôle solde de la livraison par rapport au solde de la fabrication

N Pas de contrôle (par défaut)

B Contrôle bloquant

W Warning

Lors du solde de la livraison, on contrôle si la ligne de commande est soldée en fabrication

TYC A1[16]

Edition d'un BL (O/N, N par défaut)

TYC A1[17]

Déduire le stock de la quantité livrée à l'édition du BL et créer un mouvement de stock

O en sortie normale

N Pas de mise à jour de stock (valeur par défaut)

TYC A1[18]

Mise à jour du champ délai de réalisation en édition définitive des bons de livraison

P Date d'édition du BL à la première édition

D Date d'édition du BL à la dernière édition

p Date entête BL à la première édition

d Date entête BL à la dernière édition

TYC A1[19]

Prise en compte de ce type de commande dans le calcul du risque (O/N, O par défaut)

TYC A1[20]

Edition d'une facture (O/N, N par défaut)

TYC A1[21]

Ajout d'un droit de timbre à chaque facture calculée (O/N, N par défaut)

L'ajout d'un droit de timbre dépend aussi du code TVA de la facture (Voir TVA A2[56]) et du client (Voir cl_param[21]).

Le montant du droit de timbre est paramétré dans une note commençant par DROIT_DE_TIMBRE sur le paramètre #CF FAC.

TYC A1[22]

Recherche et suppression des lignes de cadencement du même contrat et du même article

N Pas de recherche et de suppression des lignes de cadencement

O Recherche et suppression des lignes de cadencement

W Recherche et suppression des lignes de cadencement avec message d'avertissement

C Recherche et suppression des lignes de cadencement avec demande de confirmation

TYC A1[23]

Saisie des cadencements de fabrication

Voir la fiche d'installation

O Oui, accès par la touche F35

A Automatique

N Non (par défaut)

TYC A1[24]

Le code article doit exister dans le fichier articles à la saisie de commande (O/N, N par défaut)

TYC A1[25]

Prise en compte des zones Longueur et Largeur (O/N, O par défaut)

TYC A1[26]

Ne pas déduire la quantité de l'avoir si la quantité n'a pas été retournée au client - Voir TYC A3[14]

O Force la quantité de la ligne de facture à 0.

N fonctionnement habituel (valeur par défaut)

TYC A1[27]

Edition des fiches de conformité (O/N, N par défaut)

TYC A1[28]

Génération du dossier

O On devra générer le dossier (valeur par défaut)

N Le dossier sera considéré comme déjà généré

TYC A1[29]

Lancement du dossier

O On devra lancer le dossier (valeur par défaut)

N Le dossier sera considéré comme déjà lancé

TYC A1[30]

Saisie du dossier de rattachement

O Rattachement par l'entête

L Rattachement par les lignes

N Non (valeur par défaut)

TYC A1[31]

Commande facturable

A Commande facturable (valeur par défaut)

Dans ce cas on contrôle au niveau inférieur (celui du client).

Si cl_param[13] = N, alors ligne commande non facturable

Si cl_param[13] = O, alors il faut contrôler encore à un niveau plus fin, celui de l'article

Si mp_param[39] = N, alors la ligne de commande n'est pas facturable

Si mp_param[39] = A ou I, alors la ligne de commande est facturable

N Commande non facturable

F Commande facturable

si mp_param[2] = O ou mp_param[3] = N, alors la ligne de commande n'est pas facturable.

TYC A1[32]

Ouverture de la fenêtre Données techniques 1

O/1 Ouverture après saisie prix vente (valeur par défaut)

2 Ouverture après saisie désignation

N Pas d'ouverture

TYC A1[33]

Ouverture de la fenêtre Données techniques 2

O/1 Ouverture après saisie prix vente (valeur par défaut)

2 Ouverture après saisie désignation

N Pas d'ouverture

TYC A1[34]

Génération de FBI en édition d'accusé de réception (O/N, N par défaut)

TYC A1[35]

Saisie du dossier de rattachement au niveau de la ligne de commande pour les articles facturables uniquement (gestion des frais) (O/N, N par défaut)

TYC A1[36]

Déduire ou augmenter le stock de la quantité lancée à la saisie de commande

et créer un mouvement de stock :

E en entrée normale

P en entrée prévisionnelle avec la quantité lancée (mise à jour lc_nummvt2)

B en sortie besoin

N Pas de mise à jour de stock (valeur par défaut) : autorise l'exploitation de alpha3[52] et alpha3[54].

TYC A1[37]

Première ligne de la commande de type FB1 livrable

N La 1ère ligne de la commande est livrable ou non suivant le paramétrage de l'article (valeur par défaut)

O La 1ère ligne de la commande est toujours non livrable quelque soit le paramétrage de l'article

Remarque Ce paramètre n'est valide que pour les commandes de type FB1 et concerne uniquement la première ligne de la commande.

TYC A1[38]

Type de numéro de lot (commande et stock)

C Le numéro de lot est égal au numéro du dossier de rattachement de la ligne de commande

L Le numéro de lot est égal au numéro du dossier de rattachement + numéro de ligne du dossier de rattachement de la ligne de commande (par défaut)

1 Le numéro de lot est égal au numéro de commande en cours

2 Le numéro de lot est égal au numéro de commande + numéro de ligne de commande en cours

Remarque sur le numéro de lot :

Si on souhaite utiliser le programme de déclaration de production (qte_prod) permettant l'entrée en stock par palette, il est obligatoire de mettre L ou 2.

TYC A1[39]

Autorisation de création d'une nouvelle ligne de commande lorsque l' entête de commande est soldée

N N'autorise pas la création d'une nouvelle ligne de commande lorsque l'entête de commande est soldée (valeur par défaut)

O Autorise la création d'une nouvelle ligne de commande lorsque l'entête de commande est soldée, en proposant (via une demande de confirmation) de désolder l'entête de commande

TYC A1[40]

Première ligne de la commande de type FB1 fabriquée

N La 1ère ligne de la commande n'est pas fabriquée

O La 1ère ligne de la commande est fabriquée (valeur par défaut)

Remarque Fonctionnement particulier dans les remontées de production bqf.

Ce paramètre n'est valide que pour les commandes de type FB1 et concerne uniquement la première ligne de la commande. Les autres lignes de la commande sont gérées par le caractère 41.

TYC A1[41]

Lignes autres que la première ligne de la commande de type FB1 fabriquées

N Les lignes autres que la première ligne de la commande ne sont pas fabriquées (valeur par défaut)

O Les lignes autres que la première ligne de la commande sont fabriquées

Remarque Fonctionnement particulier dans les remontées de production bqf.

Ce paramètre n'est valide que pour les commandes de type FB1 et concerne les lignes autres que la première ligne de la commande. La première ligne de la commande est gérée par le caractère 40.

TYC A1[42]

Alimentation de la table des événements

N Pas d'alimentation (valeur par défaut)

O Alimentation sans tenir compte du type d'action

A Alimentation en tenant compte du type d'action

TYC A1[43]

Ouverture fenêtre de saisie de la zone paramétrée de la ligne de commande (O/N, N par défaut)

Remarque Ce paramètre n'est valide que pour les commandes de type FBM.

Le type de paramètre de la zone paramétrée pour les commandes de type FBM est NI

(Nature d'intervention).

TYC A1[44]

Type de saisie de la fenêtre Données techniques 2

1 Saisie longueur, puis largeur (valeur par défaut)

2 Saisie largeur, puis longueur

TYC A1[45]

Ouverture de la saisie des TSC

O/1 Ouverture après saisie prix vente en création et en modification

2 Ouverture après saisie désignation en création et en modification

3 Ouverture après saisie prix vente en création seulement

4 Ouverture après saisie désignation en création seulement

N Pas d'ouverture (valeur par défaut)

TYC A1[46]

Autorisation de saisie d'appel de livraison (N/O)

N Appel de livraison non autorisé pour ce type de commande client (valeur par défaut)

O Appel de livraison autorisé pour ce type de commande client

TYC A1[47]

Rattachement automatique à la première ligne de commande

O Rattachement systématique : Toutes les lignes sont rattachées à la première ligne de commande.

F Rattachement uniquement pour les produits de type frais :

Les lignes concernant un produit de type frais sont rattachées à la première ligne de commande.

Les autres lignes sont rattachées à elles-mêmes.

N Pas de rattachement : Chaque ligne est rattachée à elle-même.

TYC A1[48]

Type de prix du mouvement de stock dans le cas d'une entrée prévisionnelle

C Le prix de la ligne de commande (valeur par défaut)

R Le prix de revient de la fiche article

A Le prix d'achat de la fiche article

0 C'est la génération du dossier qui viendra mettre à jour le prix de revient prévisionnel

TYC A1[49]

Calcul de la quantité du mouvement de stock par différence (O/N, N par défaut)

Si génération d'un mouvement de sortie réserve : OUI

Si génération d'un mouvement autre que sortie réserve : NON

E Pour les entrées uniquement

S Pour les sorties uniquement

Remarque A utiliser uniquement si génération d'un mouvement de sortie réserve (alpha1[3] R) ou d'entrée prévisionnelle (alpha1[3] ou alpha1[36] = P).

Pour que ce caractère soit pris en compte, il faut que l'option -Omd sSoit présente dans cde.

TYC A1[50]

Affichage de la ligne de commande 1 dans les notes groupées (O/N, O par défaut)

Utile dans le cas d'une FB1 lorsque l'on veut ignorer la ligne 1.

Valeur alpha 2

Paramétrage des types de mouvements de stock

TYC A2[1,3] | Sortie normale en saisie de commande et en édition d'AR
TYC A2[4,6] | Sortie réserve en saisie de commande et en édition d'AR
TYC A2[7,9] | Sortie normale en saisie de BL
TYC A2[10,12] | Sortie normale en édition de BL
TYC A2[13,15] | Entrée prévisionnelle en saisie de commande et en édition d'AR
TYC A2[16,18] | Entrée normale en saisie de commande et en édition d'AR
TYC A2[19,21] | Sortie réserve en saisie de BL
TYC A2[22,24] | Entrée normale en saisie de BL
TYC A2[25,27] | Entrée normale en édition de BL
TYC A2[28,30] | Entrée prévisionnelle sur lieu intermédiaire en saisie de commande et en édition d'AR voir alpha4[31] - alpha4[49] - alpha4[50] Est lu ici si non renseigné en alpha2[4,6] de QAL. Si non renseigné ici, est lu en alpha3[40,42] de #CF CDE
TYC A2[31,33] | Sortie besoin en saisie de commande
TYC A2[34,36] | Sortie Réserve. Consommation prévisionnelle en édition d'AR. Ce type de mouvement de stock est utilisé lors de la génération des mouvements de stock de la nomenclature (cde4) d'une commande de type FBI. Si non renseigné, le TMV utilisé est paramétré en alpha2[4,6]. Pour les commandes de type autre que FBI, le TMV utilisé est paramétré en alpha2[4,6].
TYC A2[37,39] | LIBRES - LIBRES - LIBRES - LIBRES - LIBRES - LIBRES - LIBRES - LIBRES
TYC A2[40,42] | Type d'entrée prévisionnelle sur lieu intermédiaire en saisie de BL
TYC A2[43] | Commande d'avoir sur bon de retour (O/N, N par défaut) Voir code blocage 43

Valeur alpha 3

TYC A3[1]

Ouverture fenêtre de saisie des OF du groupage de l'ordre de marche (ou de la ligne de la commande) (O/N, N par défaut)

TYC A3[2]

Contrôle si le stock physique du lot est égal à 0 lorsqu'on solde ou annule une commande ou une ligne de commande

N Pas de contrôle (valeur par défaut)

W Contrôle non bloquant avec message dans une fenêtre

B Contrôle bloquant avec message dans une fenêtre

Voir aussi les notes CONTROLE_STOCK_A et CONTROLE_STOCK_S qui permettent de faire la différence entre annulation et solde.

TYC A3[3]

Contrôle sur la commande de rattachement

Vérification que la commande n'est pas rattachée à elle-même

N Pas de contrôle (valeur par défaut)

O Contrôle bloquant avec message dans une fenêtre

Le contrôle est effectif dans la saisie des commandes et le transfert du devis en commande.

TYC A3[4]

Contrôle sur la commande de rattachement

Vérification que la commande n'est pas rattachée à une commande qui est elle-même rattachée à une autre commande (rattachement en chaîne)

N Pas de contrôle (valeur par défaut)

O Contrôle bloquant avec message dans une fenêtre

Le contrôle est effectif dans la saisie des commandes et le transfert du devis en commande.

TYC A3[5]

Génération entête fiche de fabrication pour la ligne 1 de la commande (O/N, N par défaut)

Attention ! Numéro de fiche de fabrication = numéro de commande.

Paramétrage à effectuer en amont afin d'éviter des conflits de numérotation.

TYC A3[6]

Génération de commande en saisie de commandes (O/N, N par défaut)

Ceci concerne uniquement les commandes de type CDA (commande d'appel)

Le type de la commande générée est indiqué dans alpha4[1,3] du TYC CDA.

La valeur à ajouter sur le numéro de la commande de type CDA pour obtenir le numéro de la commande générée est indiquée dans alpha4[4,9] du TYC CDA.

TYC A3[7]

Initialisation du numéro de la ligne de rattachement avec le numéro de la dernière ligne livrable de la commande

N Numéro de la ligne en cours (valeur par défaut)

O Initialisation avec le numéro de la dernière ligne livrable

Pour que ce caractère soit pris en compte, il faut que le alpha1[35] = à O.

Ceci est effectif uniquement en création de lignes.

TYC A3[8]

Copie de la ligne précédente en copie de ligne dans la saisie de commandes (CTRL-G)

N Non Saisie du numéro de la ligne à copier

Le numéro de la ligne à copier est initialisé avec le numéro de la ligne précédente (valeur par défaut)

O Oui Copie de la ligne précédente

TYC A3[9]

Pas d'ouverture de la fenêtre Saisie des dates de livraison si article facturable uniquement

N Ouverture de la fenêtre quelque soit l'article (valeur par défaut)

O Oui Pas d'ouverture de la fenêtre si article facturable uniquement

TYC A3[10]

Saisie uniquement la date de fin de fabrication prévue dans la fenêtre Saisie des dates de livraison
N Non Saisie des 3 dates (valeur par défaut)

Date de livraison souhaitée par le client

Date de livraison proposée et accusée

Date de fin de fabrication prévue

O Oui Saisie uniquement de la date de fin de fabrication prévue

TYC A3[11]

Ouverture de la saisie des refoulages - Voir aussi paramétrage suivant et alpha3[42]

O/1 Ouverture après saisie prix vente

2 Ouverture après saisie désignation

N Pas d'ouverture (valeur par défaut)

TYC A3[12]

Contrôle autorisation de modification de champs dans le cas où la remontée de la production sur le dossier a déjà commencé (O/N, N par défaut)

Les contrôles à effectuer pour déterminer si la remontée de la production sur le dossier a déjà commencé sont paramétrés dans la note commençant par CSP.

Les champs à interdire en modification dans le cas où la remontée de la production sur le dossier déjà commencé sont paramétrés dans la note commençant par CMC.

TYC A3[13]

Ouverture de la fenêtre Saisie des dates de livraison en modification de lignes de commande

O/1 Ouverture avant saisie Quantité (valeur par défaut)

2 Ouverture après saisie Remise

N Pas d'ouverture

TYC A3[14]

Prise en compte dans les statistiques du poids et de la surface en commande (O/N, N par défaut) - Voir TYC A1[26]

TYC A3[15]

Quantité lancée toujours identique à la quantité commandée (O/N, N par défaut)

O La quantité lancée est toujours identique à la quantité commandée.

N Ouverture systématique de la fenêtre

TYC A3[16]

Pas de demande de confirmation de la mise à jour de la quantité lancée

O Oui Mise à jour systématique de la quantité lancée

N Non Demande de confirmation (valeur par défaut)

J Jamais de mise à jour de la quantité lancée

TYC A3[17]

Pas de demande de confirmation de la mise à jour des fichiers de production

O Oui Mise à jour systématique des fichiers de production

N Non Demande de confirmation (valeur par défaut)

Voir la note REINIT_FLAG_GENERE

TYC A3[18]

Ouverture de la fenêtre Revue de contrat

2/O Ouverture après saisie du dernier champ de la ligne

1 Ouverture avant saisie du prix de vente

N Pas d'ouverture (valeur par défaut)

TYC A3[19]

Autorisation de remplacer le TYC dans la commande (O/N, N par défaut)

Remarque Les commandes de type Fabrication sont exclues automatiquement.

TYC A3[20]

Saisie du champs Lié (Type de liaison) sur l'entête de commande (O/N, N par défaut)

TYC A3[21]

Contrôle de la date de livraison proposée de la ligne de commande par rapport à un calendrier client/date livraison

N Pas de contrôle

W Contrôle avec warning

B Contrôle bloquant

TYC A3[22]

Lorsque l'adresse d'accusé de réception de commande est saisie à blanc dans l'entête de commande, doit-elle être prise en compte en tant qu' adresse principale pour la vérification du code de validité adresse ? (O/N, N par défaut)

TYC A3[23]

Lorsque l'adresse de livraison est saisie à blanc dans l'entête de commande, doit-elle être prise en compte en tant qu'adresse principale pour la vérification du code de validité adresse ? Ce flag est également utilisé dans la revue de contrat.

N pas de contrôle (par défaut)

O contrôle sur entête et lignes

E contrôle sur entête

L contrôle sur lignes (et lignes de cadencement si cadencement de livraison géré)

Selon différents paramétrage, on contrôle soit sur l'entête, soit sur les lignes de commandes, soit sur les deux.

Ce qui existe :

L'option Ole permet de vérifier l'adresse de livraison sur l'entête de commande et empêche l'accès à la zone adresse de livraison sur les lignes.

L'option société [19] permet d'utiliser les adresses de livraisons sur les lignes de commandes.

TYC A3[23] = O permet de vérifier la validité de l'adresse principale quand la zone adresse de livraison n'est pas renseignée.

Quand les deux derniers paramétrages sont actifs, on ne contrôle plus l'adresse de livraison sur l'entête de commande.

Cela peut poser problème quand l'adresse principale n'est qu'exclusivement une adresse de facturation.

On a donc ajouté les valeurs E et L.

TYC A3[24]

Lorsque l'adresse de facturation est saisie à blanc dans l'entête de commande, doit-elle être prise en compte en tant qu'adresse principale pour la vérification du code de validité adresse ? (O/N, N par défaut). Ce flag est également utilisé dans la revue de contrat.

TYC A3[25]

INUTILISE

TYC A3[26]

Edition d'une facture de simulation (uniquement pour type PRO ou rattachement) (O/N, N par défaut)

TYC A3[27]

Mode de calcul du délai moyen de transport pour les dates de départ (au + tôt/tard)

1 Le délai moyen de transport est égal à 0 jour

2 Le délai moyen de transport est pris

Soit dans la zone numérique paramétrée du client de la commande si 'adresse de livraison de la ligne de commande ou de la ligne de cadencement de livraison n'est pas saisie

Soit dans la zone numérique paramétrée de l'adresse de livraison de la ligne de commande ou de la ligne de cadencement de livraison

3 Le délai moyen de transport est égal à 1 jour

4 Le délai moyen de transport est pris sur le CIC N74 avec les clés suivantes

" Client + Adresse de la ligne de cadencement de livraison

" Client + Adresse de la ligne de commande

" Client seul

Voir revue de contrat

TYC A3[28]

Mode de calcul de la date de fin de fabrication au plus tard :

1 La date de fin de fabrication au plus tard est égale à la date départ au plus tard.

2 La date de fin de fabrication au plus tard est égale à la date départ au plus tard déduit du délai maximum des gammes de fabrication.
Le délai maximum des gammes de fabrication est pris :
- Soit dans la gamme saisie dans le TSC 200 de l'article de la ligne de commande si ce n'est pas un article appairé et une commande de type cartonnier
- Soit dans la gamme saisie dans le TSC 200 de la ligne de commande si ce n'est pas un article appairé et si c'est une commande de type cartonnier
Si la ligne de commande n'a pas de code gamme, le délai est pris dans le délai moyen de l'article de la ligne de commande si celui-ci est renseigné, sinon il est pris dans la gamme saisie dans le TSC 200 de l'article de la ligne de commande
- Soit dans la gamme saisie dans le TSC 200 des articles de la nomenclature de la ligne de commande si l'article de celle-ci est un article appairé (On prend le plus grand délai).

N La date de fin de fabrication au plus tard n'est pas modifiée (Valeur par défaut).

TYC A3[29]

Recalcul automatique du délai répondu (O/N, O par défaut)

TYC A3[30]

Saisie simplifiée des commandes et des livraisons de type TEXTILE (O/N, N par défaut)

TYC A3[31]

Type de contrôle du lot sur les mouvements de stocks

C Contrôle sur entête seule (valeur par défaut)

L Contrôle sur entête + ligne

TYC A3[32]

Contrôle du produit lors du contrôle du lot

W Contrôle non bloquant

B Contrôle bloquant

N Pas de contrôle (valeur par défaut)

TYC A3[33]

Revue de contrat : Saisie de la date de délai client (O/N)

TYC A3[34]

Revue de contrat : Saisie de la date de délai répondu (O/N)

TYC A3[35]

Revue de contrat : Saisie de la date de départ (O/N)

TYC A3[36]

Revue de contrat : Saisie de la date de délai de fabrication (O/N)

TYC A3[37]

Possibilité de saisir une quantité commandée négative (O/N, O par défaut)

TYC A3[38]

Événement flash

N Pas de création d'événement flash

O Création d'un événement flash intégrable en statistique (flash_jma)

I Création d'un événement flash non intégrable en statistique (flash_jma)

TYC A3[39]

Ligne de la commande de type FBI livrable

N La ligne de la commande est non livrable (valeur par défaut)

O La ligne de la commande est toujours livrable

Remarque Ce paramètre n'est valide que pour les commandes de type FBI.

Voir aussi TYC A3[59] et TYC A3[60]

TYC A3[40]

Contrôle Laize et coupe

N Il n'y a pas de contrôle

O Vérification par rapport au code machine (bloquant)

W Même contrôle mais non bloquant

Remarque Ce caractère n'est valable que sur FB2 et machine de type OND EXT

TYC A3[41]

Alimentation de la table risque_detail en commande (O/N, N par défaut)

Ce caractère n'est pris en compte QUE si le risque est pris en compte via le flash.

TYC A3[42]

Fenêtre de saisie des refoulages

Focus direct sur le type de raine sans saisie du tableau des refoulages (O/N, N par défaut)

TYC A3[43]

Recopie automatique de la revue de contrat de la ligne précédente (O/N, O par défaut)

TYC A3[44]

Commande de type Self Billing Invoice (O/N, N par défaut)

TYC A3[45]

Contrôle de l'unicité du champ Référence regroupement

Facture saisie sur l'entête de commande sur une commande (O/N, N par défaut)

TYC A3[46]

Contrôle de l'unicité du champ Référence regroupement

Facture saisie sur l'entête de commande sur une facture (O/N, N par défaut)

TYC A3[47,48]

Longueur maximum du champ Référence regroupement
Facture saisi sur l'entête de commande (1 à 15, 15 par défaut)

TYC A3[49]

Utilisation du TYC

M Manuelle (saisie de commande, etc.)

E Uniquement pour utilisation des messages de type EDI

T Dans tous les cas possibles (manuelle et EDI) (valeur par défaut)

TYC A3[50]

Contrôle la cohérence des coefficients de nomenclature des éléments de la ligne de commande avec ceux de la nomenclature de l'ensemble commandé à l'édition de l'AR

N Pas de contrôle (valeur par défaut)

W Affiche un message d'avertissement

C Demande une confirmation d'édition de la commande

B Interdit l'édition de la commande

Attention

Les 4 caractères suivants sont définis pour gérer les commandes de type FB2 (commande CD2 + FBI) et ne sont actifs que si les valeurs alpha1[3] et alpha1[36] sont à N. Toutes les mises à jour de stock sont faites en saisie de ligne de commande.

TYC A3[51] | Déduire ou augmenter le stock de la quantité commandée à la saisie de la commande et créer un mouvement de stock pour l' ensemble monté O en sortie normale R en sortie réserve E en entrée normale P en entrée prévisionnelle B en sortie besoin N Pas de mise à jour de stock (valeur par défaut)
TYC A3[52] | Déduire ou augmenter le stock de la quantité lancée à la saisie de la commande et créer un mouvement de stock pour l' ensemble monté E en entrée normale P en entrée prévisionnelle N Pas de mise à jour de stock (valeur par défaut)
TYC A3[53] | Déduire ou augmenter le stock de la quantité commandée à la saisie de la commande et créer un mouvement de stock pour les composants du PF O en sortie normale R en sortie réserve E en entrée normale P en entrée prévisionnelle B en sortie besoin N Pas de mise à jour de stock (valeur par défaut)
TYC A3[54] | Déduire ou augmenter le stock de la quantité lancée à la saisie de la commande et créer un mouvement de stock pour les composants du PF E en entrée normale P en entrée prévisionnelle N Pas de mise à jour de stock (valeur par défaut)

TYC A3[55]

Paramètre réservé Volume Software

TYC A3[56]

Ligne de la commande de type CDA livrable

N La ligne de la commande est toujours non livrable quelque soit le paramétrage de l'article (valeur par défaut).

O La ligne de la commande est livrable ou non suivant le paramétrage de l'article.

L La ligne de CDA n'est livrable que si le lieu intermédiaire est renseigné (fonctionnement similaire à A3[60] pour les FBI)

Ce paramètre n'est valide que pour les commandes de type CDA.

TYC A3[57]

Lieux de rangement des mouvements de stock générés avec la quantité lancée

A Lieux de rangement de l'article (valeur par défaut)

S Lieux de rangement du site de production de l'article - Tableau de bord du multisite
(le site de production est saisi dans la zone paramétrée de l'entête de la commande)

L Lieux de rangement de la référence de liaison de l'entête de commande

Remarque Ce paramètre n'est valide que si alpha1[36] ou alpha3[52] ou alpha3[54] = E ou P.

TYC A3[58]

Lieux de rangement des mouvements de stock générés avec la quantité commandée

A Lieux de rangement de l'article (valeur par défaut)

S Lieux de rangement du site de production de l'article - Tableau de bord du multisite
(le site de production est saisi dans la zone paramétrée de l'entête de la commande)

L Lieux de rangement de la référence de liaison de l'entête de commande

Remarque Ce paramètre n'est valide que si alpha1[3] ou alpha3[51] ou alpha3[53] = O, R, E ou P.

TYC A3[59]

Ligne de la commande de type FBI livrable

N La ligne de la commande est toujours non livrable (valeur par défaut)

O La ligne de la commande est livrable si l'article est relatif à un ensemble monté à l'extérieur (mp_param[22] de l'ensemble = E)

Dans le cas contraire, elle est non livrable.

Remarque Ce paramètre n'est valide que pour les commandes de type FBI.

Voir aussi TYC A3[39] et TYC A3[60].

TYC A3[60]

Ligne de la commande de type FBI livrable

N La ligne de la commande est toujours non livrable (valeur par défaut)

O La ligne de la commande est livrable si le lieu intermédiaire de la revue de contrat est saisi

S La ligne de la commande est systématiquement livrable

Dans le cas contraire, elle est non livrable.

Remarque Ce paramètre n'est valide que pour les commandes de type FBI.

Voir aussi TYC A3[39] et TYC A3[59].

Valeur alpha 4

TYC A4[1,3]

Type de la commande générée

Exemple CD1

Remarque A remplir uniquement si commande de type CDA et si alpha3[6] du TYC CDA = O.

TYC A4[4,9]

Valeur à ajouter sur le numéro de la commande de type CDA pour obtenir le numéro de la commande générée

Exemple 001000 Commande de type CDA 96071010

Commande générée 96072010

Remarque A remplir uniquement si commande de type CDA et si alpha3[6] du TYC CDA = O.

TYC A4[10,12]

Type de paramètre de l'estampille saisie dans la fenêtre des refoulages

TYC A4[13,15]

Type de commande de rattachement

Les types de commande de rattachement autorisés sont les suivants

AVO - CD1 - CD2 - CD3 - CDA - CDI - CDP - FAD (valeur par défaut) - FB1 - FB2 - FB3 - FBA - FBI - FBM - FBP - PRO - PRX - SIM

Remarque A remplir uniquement si le type de commande n'est pas un type de commande de rattachement.

TYC A4[16,19]

Nature du mouvement utilisé dans le transfert en comptabilité ORIAC

TYC A4[20,22]

Délai maximum des gammes de fabrication par défaut

Il s'agit d'un nombre d'heures si #CF-ATL A3[18] = H, sinon il s'agit d'un nombre de jours.

Remarque A remplir uniquement si TYC A3[28] = 2

TYC A4[23,25]

Code famille (prioritaire sur celui de l'article)

TYC A4[26,28]

Code sous-famille

TYC A4[29]

Événement marge contributive (O/N)

TYC A4[30]

Transfert du lieu de déstockage en génération de FBI pour les ensembles montés extérieur

O On doit transférer le lieu de déstockage du mouvement de stock sur la FBI.

N On ne transfère rien (par défaut).

1 On doit transférer le lieu intermédiaire de la ligne de commande d'origine.

TYC A4[31]

Création d'un mouvement d'entrée prévisionnelle en stock sur lieu intermédiaire de livraison

Le TMV est indiqué en alpha2[28,30].

P Entrée prévisionnelle

N Non (par défaut), indispensable si on veut utiliser alpha4[49] et alpha4[50].

Pour l'ensemble monté, le mouvement est généré lors de la saisie de la ligne de commande.

Pour les composants du PF, le mouvement est généré lors de l'édition de l'AR.

TYC A4[32]

Mise à jour des entrées prévisionnelles en modification de commande

F Le solde de la quantité est géré en fonction de la quantité fabriquée (valeur par défaut)

L Le solde de la quantité est géré en fonction de la quantité livrée (Idem les sorties)

Remarque Cette fonction est bien spécifique aux commandes de type CDR (Réapprovisionnement)

Les entrées sont faites lors de l'édition des BL définitifs alors que les sorties sont faites en saisie des BL (Aucune relation avec la production)

Remarque Cette option ne fonctionne que si le alpha1[49] = O ou E

TYC A4[33]

Doit-on interdire le recalcul automatique du port ? (O/N, N par défaut)

Dans le cas ou l'on ne l'interdit pas, c'est le paramétrage sur POR qui affinera cette notion de recalcul.

TYC A4[34]

Type du message de confirmation de solde de la commande ou de la ligne si il reste des BL provisoires.

W Message de confirmation (warning)

B Message bloquant

N Aucun message (par défaut)

TYC A4[35]

Recopie les informations disponibles sur la ligne de commande dans la table de cadencement de livraison prévisionnel (O/N, N par défaut)

TYC A4[36]

Force le code de la zone 6 (tolérance sur délai) dans le fichier transfert PC TOPP. (O/N, N par défaut)

Voir caractère 37 sur TYC rattachement uniquement

TYC A4[37]

Code de la zone 6 dans le fichier transfert PC TOPP

Pris en compte seulement si le caractère alpha4[36] est O

TYC A4[38]

Rattachement automatique de CD1 (O/N, N par défaut)

TYC A4[39]

Facture corrective (O/N, N par défaut)

TYC A4[40]

Proratisation de la valeur des mouvements de stock générés sur la nomenclature de la commande.

Voir alpha3[51,54]

V Proratisation par prix de vente fiche produit
N Pas de proratisation (par défaut)

TYC A4[41]

Le CTRL-G, en plus de copier la ligne, solde la ligne copiée (O/N, N par défaut)

TYC A4[42]

Génération des matières (cde5)

O ou [blanc] Génération des matières (prise en compte des options Osm, Oa5 et Og5)

N Pas de génération des matières (désactive les options Osm, Oa5 et Og5)

TYC A4[43]

Contrôle du nombre de ligne maxi pour un même code ensemble par commande

N Non. Pas de contrôle (par défaut)

1 Interdiction de saisir plus d'une ligne par commande

2 Interdiction de saisir deux lignes d'un même PF par commande

TYC A4[44]

Contrôle de la quantité fabriquée en annulation de commande (O/N, N par défaut)

TYC A4[45]

Contrôle de la quantité commandée.

En fonction du mode réapprovisionnement de l'article (si il est synchrone), on contrôle si la quantité commandée est supérieure à la quantité minimum de commande

N pas de contrôle

W message non bloquant

B message bloquant

TYC A4[46]

Contrôle si la commande contient des articles avec des modes de réapprovisionnement différents.

N pas de contrôle

W message non bloquant

B message bloquant

TYC A4[47]

Interdire l'opération de montage en production pour un type de commande de fabrication (O/N, N par défaut)

TYC A4[48]

Saisie des cadencements de livraison

O (accès par la touche F31)

A Automatique

N Non (par défaut)

Attention

Les 2 caractères suivants sont définis pour gérer les commandes de type FB2 (commande CD2 + FBI) et ne sont actifs que si alpha4[31] est à N. Toutes les mises à jour de stock sont faites en saisie de ligne de commande.

TYC A4[49] | Création d'un mouvement d'entrée prévisionnelle en stock sur le lieu intermédiaire de livraison pour l'ensemble monté. Le TMV est indiqué en alpha2[28,30]. P Entrée Prévisionnelle N Rien (Par défaut)
TYC A4[50] | Création d'un mouvement d'entrée prévisionnelle en stock sur le lieu intermédiaire de livraison pour les composants PF. Le TMV est indiqué en alpha2[28,30]. P Entrée Prévisionnelle N Rien (Par défaut)

TYC A4[51]

TYC de type sous-traitance (O/N, N par défaut)

TYC A4[52,53]

Correspondance JDE

TYC A4[54]

Générer le mouvement de sortie pour livraison prévue sur la date de départ (O/N, N par défaut)

TYC A4[55]

ontrôle des heures saisies sur la revue de contrat avec un calendrier client (O/N)

Les heures sont saisies sur la plage 4 des calendriers.

La saisie des heures est conditionnée par les options Osh et Och.

TYC A4[56]

Création d'un mouvement d'entrée prévisionnelle en stock sur le lieu intermédiaire de livraison sur BL

P Entrée Prévisionnelle

N Rien (Par défaut)

TYC A4[57]

Recherche du lieu de déstockage des commandes CD2 synchrone ou asynchrone

N Non (par défaut) : Le lieu par défaut est le lieu de la fiche article

O Oui (dans l'ordre suivant)

Asynchrone :

TSC LDE sur l'article :

ic_char3_1 : Lieu 1

ic_char30 : Lieu 2

TSC LDE sur le client :

ic_char3_1 : Lieu 1

ic_char30 : Lieu 2

Lieu du site de production de l'entête de commande - Tableau de bord du multisite

Lieu par défaut de l'article

Synchrone :

Lieu du site de production de l'entête de commande

Lieu par défaut de la fiche article

TYC A4[58]

Génération d'un mouvement de stock (alpha1[3]) en modification de ligne de commande si le lieu intermédiaire de la revue de contrat est renseigné (O/N, N par défaut)

Ce paramètre n'est valide que si l'option 41 (Nomenclature multi-niveaux) de la fiche société n'est pas activée et que la commande est de type FBI.

TYC A4[59]

Génération dun fichier ORDERS pour ce type de commande client (O/N, N par défaut)

TYC A4[60]

Création automatique d'un code blocage 012 sur les FBI multi-niveau (O/N, O par défaut)

Notes triées - Le tri ignore les _ et les #

ACCES_DATES_VALIDITE

Laccès aux zones date de validité était autorisé seulement pour les contrats (TYC CTR)

Cette note permet de rendre ces deux zones accessibles pour les commandes autres que les contrats.

Pas de paramétrage particulier, la seule présence de la note suffit.

#CA

Contrôle accès aux champs de saisie

5 à 22 Nom du champ. Les champ de l'entête sont actuellement :

ec_tour Code tournée/Top facturation

23 Type de contrôle

N Pas d'accès au champ

O Accès au champ

W Accès au champ avec validation par mot de passe de la modification du champ

24 à 26 Numéro mot de passe (paramètre PWD)

#CC

Attention, ne pas confondre

cette note avec la suivante !

Contrôle des champs de l'entête et de la revue de contrat

5,22 Nom du champ à contrôler

Cliquez ici pour afficher / masquer la liste des champs de l'entête de commande

Cliquez ici pour afficher / masquer la liste des champs de la revue de contrat

23 Type de contrôle

N Pas de contrôle

W Warning si champ non saisi

B Champ obligatoire

C consultation (champ visible non saisissable)

I Invisible (champ caché)

Attention ! Par défaut, un champ est visible et modifiable.

24 Zéro significatif en cas de champ numérique (O/N)

(dans le cas du champ ec_adl, mettre N)

25 Saisie de la valeur zéro

O Oui Le zéro est significatif

N Non Le zéro n'est pas significatif (considéré comme valeur nulle)

Ne doit être utilisé que pour les valeurs numériques

26 Forcer le masquage du champ en présence de lignes de cadencement (O/N, N par défaut).

O Le masquage du champ est forcé et le type de contrôle en caractère 23 est ignoré.

N Le masquage du champ n'est pas forcé.

#CC_

Attention, ne pas confondre cette

note avec la précédente !

Contrôles de champs dans la saisie des cadencements de fabrication

A la validation de la saisie des cadencements de fabrication, les colonnes concernées par un contrôle bloquant s'affichent sur fond rouge, et les colonnes concernées par un contrôle non bloquant s'affichent sur fond orange.

5,10 Code écran concerné où les contrôles seront effectués

SAICADF_LIG : Ecran de saisie des cadencements de fabrication par ligne de commande

SAICADF_ENT : Ecran de saisie des cadencements de fabrication par entités

21,38 Nom du champ sur lequel le contrôle s'effectue

SAICADF_LIG

cfl_date_cre Date de création (Date)

cfl_type_cad Type de cadencement de fabrication (Alphanumérique)

cfl_qtelan Quantité lancée (Numérique)

cfl_date_fin Date de fin de fabrication (Date)

cfl_statut_prod Statut de la ligne de cadencement de fabrication (Numérique)

cfl_valide Ligne validée (Alphanumérique)

SAICADF_ENT

cfe_date_cre Date de création (Date)

cfe_type_cad Type de cadencement de fabrication (Alphanumérique)

cfe_qtelan Quantité lancée (Numérique)

cfe_date_fin Date de fin de fabrication (Date)

cfe_valide Ligne validée (Alphanumérique)

39 Type de contrôle à effectuer

N Pas de contrôle (par défaut)

W Le champ doit être saisi (anomalie non bloquante)

B Le champ doit être saisi (anomalie bloquante)

I Le champ n'est pas accessible en saisie

40 Le zéro est-il significatif pour une zone numérique ?

O Le zéro est considéré comme une saisie correcte.

N Le zéro est considéré comme une saisie incorrecte (équivalent à aucune saisie) (par défaut).

CDE_PAR_REFERENCE

Gestion des commandes de fabrication par référence

21 Activer la gestion des commandes de fabrication par référence (O/N, N par défaut)

22,24 Type de commande de fabrication (TYC) <VF>

25,27 Type de commande de frais (TYC) <VF>

Important

- La présence de ces TYC active le fonctionnement décrit ci-dessous :
Dans la saisie des commandes avec gestion par référence, permet d'annuler automatiquement la commande commerciale (et les commandes de frais éventuelles) lorsque toutes les commandes de fabrication rattachées sont annulées.
Une demande de confirmation est posée à l'utilisateur lorsque celui-ci annule la dernière commande de fabrication.

- Ces deux types de commandes doivent correspondre à ceux paramétrés au niveau de la configuration du transfert du devis en commande (#CF TDC, note CDE_PAR_REFERENCE).

L'activation de cette option implique, dans la saisie des cadencements de fabrication :

" Le regroupement des cadencements de fabrication n'est pas accessible (celui-ci se fera sur les commandes de fabrication)

" La génération des cadencements de fabrication n'est pas accessible (celle-ci se fera sur les commandes de fabrication)

" A partir du moment où les commandes de fabrication existent, la modification de la commande commerciale n'est plus possible.

CGV

Conditions générales de vente

4 à 6 code langue

7 à 60 Conditions générales de vente

CHT

Précise les TYC autorisés pour le passage d'une PRX en commande.

4 à 60 TYC autorisés

Exemple

Vous êtes sur le TYC PRX , il n'existe pas de gestion de stock pour les CD2 et CD3.

Remarque CHTCD2CD3 Autorise le passage de PRX en CD2 ou CD3.

CMC

Champs à interdire en modification dans le cas où la remontée de la production sur le dossier est déjà commencée (O/N, N par défaut pour chacun des caractères suivants)

Caractère 4 Code article

Caractère 5 Quantité lancée

Caractère 6 Délai proposé au client

Caractère 7 Laize (largeur)

Caractère 8 Coupe (longueur)

Caractère 9 Les TSC de la ligne de commande

Caractère 10 Quantité commandée

Caractère 11 Délai répondu par le client

Caractère 12 Date de départ

Caractère 13 Tolérance de livraison (lc_tolerance_liv)

Caractère 14 Tolérance sur la quantité (lc_qualif_appel)

Caractère 15 Hauteur (lc_haut)

Caractère 16 Refoulage

Caractère 17 Délai de fabrication

CMR

Contrôle Modification Régénération OF

Caractère 4 Positionne les OF associés à régénérer si la Zone Paramétrable de l'entête de commande (ec_c1) est modifiée (O/N, N par défaut)

Caractère 5 Positionne les OF associés à régénérer si la zone Commentaire Libre de l'entête de commande (ec_texte) est modifiée (O/N, N par défaut)

Caractère 6 Activation du transfert PC-TOPP lors de la modification de la variable ec_ref (O/N, N par défaut)

Caractère 7 Activation du transfert PC-TOPP lors de la modification de la variable lc_p2 (O/N, N par défaut)

Caractère 8 Activation du transfert PC-TOPP lors de la modification de la variable lc_adl (O/N, N par défaut)

CNG

Cette note concerne les clients dont on ne génère pas de commande si commande de type CDA et si TYC CDA A3[6] = O

4 à 60 Clients dont on ne génère pas de commande

Exemple CNG#SOC Pas de génération de commande pour le client #SOC.

CODE_TOL_QTE_DEFAUT

Code tolérance de quantité (TOL) de la ligne de commande par défaut

Ce code doit correspondre à un type de paramètre TOL.

Remarques :

" En saisie de commande client, la note commençant par INIT_TOL_QAL_LIGNE est obligatoire pour initialiser le code tolérance de quantité de la ligne de commande.

" Si le code n'est pas renseigné ou s'il n'existe pas, le code tolérance de quantité de la ligne de commande est initialisé à blanc.

" Si la note n'existe pas, le code tolérance de quantité de la ligne de commande est initialisé avec celui du client.

COH_DATE_

Contrôle de cohérence des dates client, proposée, départ et fin de fabrication

10 à 12 Type de date à contrôler

CLI Client

PRO Proposé

DEP Départ

FAB Fin de fabrication

13 Type de contrôle

B Bloquant

W Warning

14 à 16 Type de date de référence

CLI Client

PRO Proposé

DEP Départ

FAB Fin de fabrication

ENR Date d'enregistrement

17 Opérateur de comparaison

1 date à contrôler < date référence

2 date à contrôler > date référence

3 date à contrôler <= date référence

4 date à contrôler >= date référence

18 à 20 Date de référence N° 2 (facultatif)

21 Opérateur de comparaison N° 2 (facultatif)

22 à 24 Date de référence N° 3 (facultatif)

25 Opérateur de comparaison N° 3 (facultatif)

26 à 28 Date de référence N° 4 (facultatif)

29 Opérateur de comparaison N° 4 (facultatif)

La date à contrôler est comparée tour à tour avec les différentes dates de références paramétrées.

Par paramétrage, vous pouvez contrôler chaque date par rapport aux 4 autres dates.

Exemple Date fin de fabrication <= Date de départ <= Date proposée

COH_DATE_PROBDEP4FAB4

COH_DATE_DEPBPRO3FAB4

COH_DATE_FABBPRO3DEP3

COMPTE_VENTE

Précise les numéros de compte de vente associés au TYC

13 à 20 Code comptable VENTE France pour transfert en comptabilité (classe 7) (spécifique K)

21 à 28 Code comptable VENTE export pour transfert en comptabilité (classe 7) (spécifique K)

29 à 36 Code comptable VENTE suspension de TVA pour transfert en comptabilité (classe 7) (spécifique K)

37 à 44 Code comptable VENTE intracommunautaire pour transfert en comptabilité (classe 7) (spécifique K)

45 à 52 Code comptable VENTE exonérée pour transfert en comptabilité (classe 7) (spécifique K)

CONTROLE_MVT_STOCK_A

21 Contrôle si le lot n'a pas de mouvements de stock normaux lorsqu'on annule une commande ou une ligne de commande

N Pas de contrôle (Valeur par défaut)

W Contrôle non bloquant avec message dans une fenêtre et demande de confirmation

B Contrôle bloquant avec message dans une fenêtre

CONTROLE_QTE_A_CAD

Contrôle de la quantité à cadencer

Interdiction de faire un appel de livraison si la quantité est supérieure à la quantité fabriquée ou réceptionnée soldée (selon le type de l'article).

21 Contrôle de la quantité pour un article fabriqué (O/N, N par défaut)

22 Contrôle de la quantité pour un article de négoce (O/N, N par défaut)

Voir aussi le code blocage 039.

CONTROLE_STOCK_A

21 Type de contrôle pour l'annulation dune ligne de commande

Permet de paramétrer séparément le type de contrôle pour le test stock > 0 pour lannulation d'une ligne de commande

En absence de paramétrage sur les notes, alors le contrôle effectué dépendra de TYC A3[2] comme auparavant.

CONTROLE_STOCK_S

21 Type de contrôle pour le solde d'une ligne de commande

Permet de paramétrer séparément le type de contrôle pour le test stock > 0 pour le solde d'une ligne de commande.

En absence de paramétrage sur les notes, alors le contrôle effectué dépendra de TYC A3[2] comme auparavant.

CREATION_ORDRE_TRANSPORT_INHIBEE

Permet d'inhiber la création d'ordre de transport pour un TYC donné

CSP

Contrôles à effectuer pour déterminer si la remontée de la production sur le dossier a déjà commencé

Dès qu'un des événements est à O, la production a débuté.

Caractère 4 Déclarations de production effectuées pour le dossier (O/N, N par défaut)

Caractère 5 Mouvements de stock affectés au dossier (O/N, N par défaut)

Caractère 6 Factures de sous-traitance affectées au dossier (O/N, N par défaut)

Caractère 7 Saisies des temps enregistrées sur le dossier (O/N, N par défaut)

Caractère 8 Saisies manuelles de consommations matières réalisées pour le dossier (O/N, N par défaut)

Caractère 9 Commandes d'achat affectées au dossier (O/N, N par défaut)

CTRL_CODE_CS_n

où n représente le code statistique (1 à 4)

21 Code statistique CSn obligatoire (O/N, N par défaut)

Cette note a priorité sur #CF CDE A3[50] et suivants.

Si cette note n'est pas saisie ici, on peut alors rendre cette saisie obligatoire par une note identique sur la famille du produit.

Si cette note n'est pas saisie sur la famille, on peut alors rendre cette saisie obligatoire par une note identique sur la famille/sous-famille du produit.

CTR_MONOLIGNE

Est-ce un contrat monoligne ? (O/N, N par défaut)

(Type de contrat CTR)

Pouvoir créer un contrat portant sur une seule référence, et livrer des articles différents pour ce même contrat.

Le contrat est monoligne. Il n'y pas de gestion d'appairage.

CTRL_PRES_OUTILLAGE

Contrôle de la présence de l'outillage pour la date de fabrication

N pas de contrôle (par défaut)

B Contrôle bloquant

C Confirmation

W Warning

CTRL_TOL_BLV_QTR_EC

21 Contrôle de tolérance sur la quantité en cours de transfert

O Contrôle de la tolérance sur la quantité en cours de transfert

N Contrôle actuel c'est-à-dire contrôle sur la quantité cumulée transférée (Par défaut.)

CTRL_UNICITE_DATE

21,60 Liste des dates sur lesquelles on souhaite effectuer le contrôle d'unicité

Lors d'une saisie de commande client, à la validation de la revue de contrat, on contrôle l'unicité d'une ligne de commande par rapport à la date de départ, de livraison ou de fabrication selon un ordre paramétrable en utilisant les mots-clés suivants, séparés par un astérisque :

depart : Date de départ (lc_deldep)

livraison : Date de livraison (lc_delrep)

fabrication : Date de fabrication (lc_delfab)

Dans le paramètre de lancement de la saisie des commandes clients, la note UNICITE_CDE_DAT_LIV permettant une tolérance en nombre de jours sur ce contrôle, est prise en compte.

IMPORTANT : Ne pas oublier le dernier astérisque pour que le dernier champ soit pris en compte.

Exemple

CTRL_UNICITE_DATE depart*livraison*fabrication*

Avec ce paramétrage, le contrôle sera effectué sur la 1ère date renseignée, en vérifiant dans cet ordre la date de départ, la date de livraison, puis la date de fabrication.

En l'absence de paramétrage, le contrôle est effectué par défaut sur la date de départ.

CTRL_VALID_OUTILLAGE

Contrôle de la validité de l'outillage

N pas de contrôle (par défaut)

B Contrôle bloquant

C Confirmation

W Warning

DATE_

Contrôle des dates client, proposée, départ et fin de fabrication

6,8 Type de date

Saisie de la revue de contrat (ligne de commande)

CLI Client

PRO Proposé

DEP Départ

FAB Fin de fabrication

FCF Saisie des cadencements de fabrication : Date de fin de cadencement de fabrication

Saisie des cadencements de livraison

DEM Demandée

LIV Livraison (accusée)

APP Appel

10 Type de contrôle

B Bloquant

W Warning

11,13 Nombre de jours en moins autorisé par rapport à la date du jour

14,16 Nombre de jours en plus autorisé par rapport à la date du jour

DECOMPOSITION_PRIX

Décomposition des prix activée pour ce type de commande (O/N, N par défaut) Plus d'info

La décomposition des prix est transférée à la commande et accessible via l'écran de détail des prix :

F7 sur la zone Prix de la ligne de commande.

DOSSIER_FABRICATION

Lors de la création d'une commande FBI (F17/Shift-F5), permet de créer automatiquement les dossiers de fabrication sur chaque ligne de commande créée

Lors de la création d'une ligne de commande, permet de créer automatiquement le dossier de fabrication associé.

21 Création automatique du dossier de fabrication à la création d'une ligne de commande

O Création systématique

C Création sur confirmation

N Pas de création (par défaut)

22 Réactualisation automatique une fois le dossier de fabrication créé

O Réactualisation systématique

C Réactualisation sur confirmation

N Pas de réactualisation (par défaut)

23,25 Type de devis du dossier de fabrication

Si celui-ci n'est pas paramétré, c'est le type du devis source qui sera pris en compte.

26,28 Code tarif du dossier de fabrication

Si celui-ci n'est pas paramétré, c'est le code tarif du devis source qui sera pris en compte.

Remarques :

" La création du dossier de fabrication peut se faire systématiquement ou sur confirmation.

" Le dossier de fabrication créé peut également être réactualisé (systématiquement ou sur confirmation).

" La génération automatique des codes blocages du devis multi-métiers n'est pas gérée.

" Le devis source utilisé est celui renseigné sur la ligne de commande ou à défaut celui de l'article saisi.

" Le dossier créé est : numéro de commande numéro de ligne de commande.

" Si un dossier portant le même numéro existe déjà, il n'est pas modifié (un message d'erreur apparaît).

DT1

Ces notes concernent les libellés de la fenêtre donnée technique 1 de la ligne de la commande

4 Code du champ

1 Champ lc_p1

2 Champ lc_p2

3 champ lc_p3 ( char15 )

5 à 24 Libellé du champ

25 Contrôle de saisie du champ

N Saisie facultative

W Warning

B Saisie obligatoire

26 à 28 Pour les champs 1 et 2 : Type de paramètre

Pour le champ 3 : Type de table pour contrôle, obligatoire. plus d'info

Le paramètre que vous indiquez ici va remplacer la valeur indiquée dans le #CF CDE A1[10,12].

AUT Référence client

CAR Qualité carton

CLI Client

DAT Date d'avenant

LIV Livraison

MAT matière

REF Référence de commande client

XXX Zone sans contrôle

.TL (TSC)

29 Autorisation de changement de TYC

N ou [espace] Pas d'autorisation

O Autorisation conditionnée par les notes de type CHT

Attention Ne pas mettre en Suvre ce paramétrage si présence de stock et /ou fabrication sur le nouveau TYC.

Exemple DT11Famille WFAM

Exemple DT12Sous-famille WSFM

Exemple DT13Cliché WMAT

Les libellés saisis remplaceront ceux saisis dans le paramètre #CF CDE.

DT1S

5 à 60 Supplément de requête pour la recherche sur le champ lc_p3 dans la fenêtre données techniques 1

Exemple DT1Sand mp_mp = O and mp_fam = CLI and mp_anu = N

DT2

Ces notes concernent les libellés de la fenêtre donnée technique 2 de la ligne de la commande

4 Code du champ

1 Champ longueur

2 Champ largeur

3 Champ hauteur

4 Champ poids

5 Champ prix client

5 à 24 Libellé du champ

25 Contrôle de saisie du champ

N Saisie facultative

W Warning

B Saisie obligatoire

Les libellés saisis remplaceront ceux saisis dans le paramètre #CF CDE.

Lorsque l'on veut modifier un seul libellé, il faut IMPERATIVEMENT les saisir tous.

FA

Lancement automatique des touches de fonction après validation de l'entête ou saisie du dernier champ de la ligne

Voir aussi, notamment, l'option Opr en saisie de commande client.

3 E entête L Ligne

4 à 6 Touche de Fonction

F12 Saisie des dates de livraisons

F16 Saisie des dates

F20 Saisie des informations complémentaires

F31 Saisie des cadencements de livraison

F35 Saisie des cadencements de fabrication

Voir la fiche d'installation

7 Lancement en création (O/N, N par défaut)

8 Lancement en modification (O/N, N par défaut)

FAX_MAIL_AR_SUR_TYC

21 Gestion du fax/mail autorisée pour cette échéance en saisie de commande (O/N, O par défaut)

Utilisé dans la saisie de commandes clients pour désactiver la gestion du fax/mail, même si l'option Oxm est positionnée.

La même note existe aussi sur l'échéance. Pas de hiérarchie.

FORCE_DATE_DEP_LIV

21 Forçage de la date de départ (O/N, N par défaut)

FORCE_ZONE_CDE2_TYC

21 Permet de forcer la valeur de certaines zones de cde2 (O/N, N par défaut)

Les zones concernées sont les suivantes :

- lc_poids (note METHODE_REMPL_POIDS)

- lc_unvent (note UNITE_VENTE)

Utilisable entre autres dans la papeterie

GENERATION_SANS_NOTE_DE_TRACE

Lors d'une génération automatique d'une FBI à partir d'une autre commande, le système crée systématiquement une ligne de note sur la commande d'origine.

Ce paramétrage a pour but d'empêcher la génération de lignes de note sur la commande d'origine.

GENERER_CDE_AVOIR

Automatiser la génération des factures correctives

On sélectionne une ligne de commande dans la facture, l'action génère crée une copie de la ligne en négative (Prix ou quantité négative)

Et une nouvelle ligne avec un nouveau prix ou une nouvelle quantité, cela dépendra du paramétrage

21 Recopie la ou les lignes de commandes en négatif pour faire un avoir. Obligatoire

P Modification du prix en négatif pour générer automatiquement l'avoir.

Q Modification de la quantité en négative pour générer automatiquement l'avoir.

22 Doit-on saisir une nouvelle quantité ? (O/N, N par défaut)

Attention : la quantité doit être supérieure à zéro.

23 Doit-on saisir un nouveau prix ? (O/N, N par défaut)

Attention : le prix doit être supérieur à zéro.

25 lc_prxcli sera initialisé par lc_prx et non à 0 (O/N, N par défaut)

A utiliser pour les commandes qui utilisent les options Oip et Otc.

GEN_SR_MP_CDE_TEX

Génération des sorties réserves et des entrées prévisionnelles des matières premières des commandes de type TEXTILE en saisie de commandes clients (O/N, N par défaut)

GESTION_AMALGAME

21 Gestion des amalgames pour ce type de commande

O Zone de saisie amalgame accessible

N Zone de saisie amalgame non accessible

22 Initialisation des zones Amalgame (O/N, N par défaut)

N Les zones Amalgame ne sont pas initialisées.

O Les zones Amalgame sont initialisées comme ci-dessous :

Si article acheté - mp_param[5] = A

Ligne d'amalgame = N

No de la ligne parente d'amalgame = 0 (zéro)

Si article fabriqué - mp_param[5] = F

1ère ligne de l'amalgame

Ligne d'amalgame = A

No de la ligne parente d'amalgame = Ligne de commande

Lignes suivantes de l'amalgame

Ligne d'amalgame = L

No de la ligne parente d'amalgame = Ligne de commande de l'amalgame

Remarque : Le caractère 21 doit être à O si le caractère 22 est à O.

INIT_DATLIV_AVEC_DEM

21 Initialisation de la date accusé avec la date de demande saisie par le client (O/N, N par défaut)

INIT_LIEU_DEST_CD1

21 Lieux intermédiaire et de destockage de la CD1

N (par défaut) : Le lieu intermédiaire de la CD1 est égal au lieu intermédiaire de la CDA et le lieu de destockage de la CD1 n'est pas initialisé avec le lieu intermédiaire de la CDA.

O : Le lieu intermédiaire de la CD1 est à blanc et le lieu de destockage de la CD1 est initialisé avec le lieu intermédiaire de la CDA.

INIT_TOL_QAL_LIGNE

Initialisation des tolérances

21 Initialisation du code tolérance quantité (TOL) de la ligne de commande en saisie de commandes clients avec celui du client
(O/N, O par défaut)

22 Initialisation du code tolérance délai (QAL) de la ligne de commande en saisie de commandes clients avec celui du client
(O/N, O par défaut)

LIBELLE_EC_C1

21,37 Libellé de la zone ec_c1 à afficher dans la saisie des commandes clients

MAJ_P1_2_3_AV_LG_PRC

21 Mise à jour de lc_p1, lc_p2 et lc_p3 de la ligne de commande courante avec ceux de la ligne de commande précédente (O/N, N par défaut)

Si création de ligne de commande et ligne de commande autre que la 1ère ligne.

MOTIF_MODIF_DATE_RC

Motif de modification

21 Affichage de la zone de saisie Motif de modification dans la revue de contrat (O/N, O par défaut)

22 Ouverture automatique de la sélection du motif de modification (MMD) lors de la modification manuelle d'une des 4 dates de revue de contrat (O/N, N par défaut)

23 Contrôle de saisie à effectuer sur le motif de modification de date en cas de modification manuelle d'une des 4 dates de revue de contrat

N Pas de contrôle

W Contrôle non bloquant

B Contrôle bloquant

MVT_EXT_CAD_ENS

Gérer les mouvements de stocks sur l'ensemble, si le produit est de type montage extérieur (O/N, N par défaut)

NEW_TYC_TRANSCDESITE

Transfert de commande sur un autre site

Sur le TYC de remplacement du TYC initial :

21,23 Code TYC pour la commande qui sera générée.

24,26 Numéro de compteur pour la commande qui sera générée.

27 Modification de la commande initiale (stock, &) (O/N, O par défaut)

28,30 Code TYF pour la commande d'achat qui sera générée.

31,33 Numéro de compteur pour la commande d'achat qui sera générée

34 Alimentation du prix de la commande par le prix de cession

35,40 Type et code du paramètre de recherche de tarif

41 Méthode d'alimentation de la commande d'achat

1 Méthode actuelle (par défaut)

2 Nouvelle méthode

42 Conserver le représentant de la commande initiale (O/N, N par défaut)

Voir aussi :

la note CREER_LIGNES_CDE dans le #CF TDC

les notes _SUP_REQ_TRSCDESITLF et _SUP_REQ_COPIE_CDE2 dans la saisie de commandes clients

SIT A4[40,42] et A4[43,45]

Tableau de bord du multisite

Exemple

OUV_AUTO_CDE_QUALIF

21 Ouverture automatique de l'écran de suivi de qualification/surveillance en création/modification de commande

(O/N, O par défaut)

PRIX_AUX_100_KG

Contrôle du prix aux 100 KG de la ligne de commande

16 Type de contrôle

B Bloquant

W Warning

C Confirmation

17 à 26 Borne inférieure de la fourchette de prix aux 100 KG en centimes et sans virgule

27 à 36 Borne supérieure de la fourchette de prix aux 100 KG en centimes et sans virgule

Exemple Fourchette de prix aux 100 KG comprise entre 2000 ¬ et 9000 ¬ avec un contrôle bloquant :

PRIX_AUX_100_KGB00000020000000003000

Remarques

Le poids de la ligne de commande est toujours exprimé en KG.

Le contrôle du prix est toujours fait sur un prix en devise société.

Si votre devise société est l'Euro et que vous saisissez une commande en Franc suisse, le prix sera converti en Euro avant de faire le contrôle.

PRIX_REVIENT_PLAQUE

Permettre de récupérer le prix de revient aux 1000 plaques à partir du devis ou de la qualité carton (prix aux 1000 m²)

21 Initialisation du prix de revient

N Le prix de revient de la ligne de commande n'est pas initialisé automatiquement (par défaut)

W Le prix de revient est initialisé automatiquement à partir du devis ou de la qualité carton.
Si aucun prix de revient n'a été trouvé, on affiche un message d'avertissement mais la saisie du produit générique plaque est autorisée.

B Le prix de revient est initialisé automatiquement à partir du devis ou de la qualité carton.
Si aucun prix de revient n'a été trouvé, on affiche un message d'avertissement et la saisie du produit générique plaque est interdite.

22,24 Code environnement pour la recherche des prix de cession de la qualité carton associée au produit générique plaque.

Principe de fonctionnement

  • En premier lieu, on recherche le devis pour le client et l'article générique plaque saisi sur la ligne de commande.
    Si le devis est trouvé, on récupère le prix de revient de l'offre validée (prix aux 1000 m²) pour initialiser le prix de revient de la ligne de commande (prix aux 1000 plaques)

  • Si le devis n'est pas trouvé, on recherche le prix de cession des tarifs pour l'environnement paramétré et la qualité carton associée à l'article générique plaque saisi sur la ligne de commande.
    Si le prix de cession est trouvé, on le récupère (prix aux 1000 m²) pour initialiser le prix de revient de la ligne de commande (prix aux 1000 plaques)

  • Si le prix de cession n'est pas trouvé, le prix de revient de la ligne de commande n'est pas initialisé.

Remarques :

" Le type de commande (TYC) doit être rattaché au type de commande cartonnier (FB2)

" La recherche de la qualité carton associée au produit générique plaque se fait via la note SUPREQQUACAR du #CF/CAR.

QUAL_APPEL_LIV_TDC

21,23 Type d'appel de livraison pour alimenter la table cde8

RCP_ACCES_ORIGINES

Dans la visualisation du récapitulatif des coûts de la saisie de ligne de commande (action Détail coûts, Control-Alt-Maj-F3), permet de visualiser plusieurs origines via l'affichage de boutons de sélection du code origine.

Remarques

• L'action Détail coût est accessible uniquement si les options payantes correspondantes sont activées (PRO 04 et CDE 13).

• Ce fonctionnement permettra par exemple d'afficher sur la ligne de commande de fabrication (FBI) les quatre origines possibles :

PRP Prix de revient prévisionnel (environnement prévisionnel)

PRR Prix de revient prévisionnel (environnement réel)

REV Prix de revient réel (environnement prévisionnel)

RER Prix de revient réel (environnement réel)

• Deux nouvelles permissions sont disponibles pour limiter l'accès aux origines du prix de revient :

TOU/CDE2_F39_REV Accès à la visualisation des coûts de l'origine REV

TOU/CDE2_F39_RER Accès à la visualisation des coûts de l'origine RER

21,59 Origines affichées dans le récapitulatif des coûts. 13 codes origines de 3 caractères par ligne.

Liste des origines disponibles :

PRP Prix de revient prévisionnel (environnement prévisionnel)

PRR Prix de revient prévisionnel (environnement réel)

REV Prix de revient réel (environnement prévisionnel)

RER Prix de revient réel (environnement réel)

CEV Prix commandé prévisionnel (environnement prévisionnel)

CER Prix commandé prévisionnel (environnement réel)

Voir la note RCP_LIB_ORIGINE_ ci-dessous.

Remarque : Le premier code origine paramétré est utilisé lors de l'ouverture de la fenêtre de visualisation du récapitulatif des coûts

Exemple

PRPREV

A l'ouverture, affichage des coûts du prix de revient prévisionnel

Affichage des coûts du prix de revient réel via un bouton

RCP_LIB_ORIGINE_

Voir aussi la note ci-dessus (RCP_ACCES_ORIGINES)

17,19 Code origine - Codes origines disponibles : PRP, PRR, REV, RER, CEV, CER

21,60 Libellé associé au code origine utilisé pour le bouton de sélection

Libellés par défaut selon le code origine

CEV Prix commandé prévisionnel (CEV)

CER Prix commandé réel (CER)

PRP Prix de revient prévisionnel (PRP)

PRR Prix de revient réel (PRR)

REV Prix de revient réel (REV)

RER Prix de revient réel (RER)

REAP_ASYNC_FORCE

21 Code réapprovisionnement synchrone (type REA) sur 1 seul caractère

En saisie de commande, force le code réapprovisionnement à asynchrone si celui de l'article est synchrone.

23,25 Code site de production (type SIT) (facultatif) Tableau de bord du multisite

REAP_SYNC_FORCE

En saisie de commande, force le code réapprovisionnement à synchrone si celui de l'article est asynchrone

21 Code réapprovisionnement synchrone (type REA)

RECOPIE_LIGNES_FAB

21 Saisie de la commande commerciale associée et recopie des lignes sélectionnées de celle-ci vers la commande de fabrication (O/N, N par défaut)

REINIT_FLAG_GENERE

21 Réinitialisation du flag de génération quand la quantité lancée d'une commande de fabrication passe de zéro à une quantité supérieure à zéro (fab0.f0_gener est réinitialisé à 0 : à générer)

Remarque : Paramétrage lié à la mise à jour des fichiers de production (voir A3[17])

SAI_CAD_AVT_SAI_QTE

21 Ouverture automatique de la fenêtre de saisie des cadencements avant la saisie de la quantité commandée (O/N, N par défaut)

Par défaut, la fenêtre s'ouvre après la saisie de la quantité commandée.

Il faut que TYC A4[48] = A (automatique)

_SUP_REQ_QAL_CADLIV

21,60 Complément de requête sur table par02 pour sélection du code QAL

SUP_REQ_CDE1_CAD_CTR

21,60 Supplément de requête sur la table cde1

Voir l'option Omq dans la saisie de commande client.

Exemples

SUP_REQ_CDE1_CAD_CTRand ec_tyc = "FB2"

SUP_REQ_CDE1_CAD_CTRand ec_type_liaison = "CTR"

SUP_REQ_CDE2_CAD_CTR

21,60 Supplément de requête sur la table cde2

Voir l'option Omq dans la saisie de commande client.

Exemple

SUP_REQ_CDE2_CAD_CTRand lc_prod matches "PS*"

SUP_REQ_CDE8_CAD_CTR

21,60 Supplément de requête sur la table cde8

Voir l'option Omq dans la saisie de commande client.

Exemple

SUP_REQ_CDE8_CAD_CTRand li_qua = "SAP"

_SUP_REQ_NOM_QTE

Sur la fenêtre de nomenclature, on peut maintenant consulter la quantité restante et la quantité en stock des lots FBI rattachés à l'article visualisé pour des commandes.

21,60 Complément de requête pour la recherche quantités restantes et quantité en stock pour chaque article dans la fenêtre de nomenclature. Tables utilisables : cde1 et stk0

Si cette note est absente, les deux zones Quantité restante et Quantité stock seront masquées.

Exemple de paramètre

_SUP_REQ_NOM_QTE and s0_typ ='FR'

_SUP_REQ_SELECT_COM

Complément de sélection sur la table des commandes (cde1) pour la recherche du numéro de commande commerciale associée à la commande de fabrication

TBDATA_AFFRET

21,23 Type de la commande client (TYC) rattachée dont on récupère le numéro d'affrètement dans la visualisation des états de fabrication

TBDATA_OF

21,23 Type de la commande client (TYC) rattachée dont on récupère le numéro d'OF dans la visualisation des états de fabrication.

TEXTILE_SUR_LIGNE_1

21 Saisie du détail textile autorisée sur la première ligne de commande (O/N, O par défaut)

Permet de désactiver la saisie du détail textile sur la première ligne de la commande de fabrication générée.

TITRE_FENETRE_CADLIV

21,60 Titre de la fenêtre des cadencements de livraison

TYC_OK_CORRECTION

21 Code O/N permettant d'interdire ou d'autoriser sur contrôle l'utilisation de certains TYC en correction de stock

O TYC à contrôler en correction de stock

N TYC interdit en correction de stock

Si la note est inexistante, ou le caractère 21 non renseigné, on ne fait pas le contrôle et la commande est autorisée en correction.


TYF Types de commandes fournisseur

Valeur alpha 1

TYF A1[1]

F pour Facture (par défaut)

A pour Avoir

TYF A1[2]

L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E

TYF A1[3]

Augmentation du stock à la saisie des commandes et création du mouvement entrée/commande

O Entrée normale

C Entrée en commande fournisseur

N Non (par défaut)

Ces valeurs prennent le pas sur celles définies au niveau du TMV

TYF A1[4]

Créer une sortie de stock automatique à la saisie des commandes fournisseurs si la commande est affectée à un dossier.

Création d'un mouvement sortie/commande (O/C/N, N par défaut)

TYF A1[5]

Edition d'un bon de commande (O/N, N par défaut)

TYF A1[6]

La commande est-elle à prendre en compte dans les statistiques (O/N, O par défaut)

TYF A1[7,10]

L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E

TYF A1[11]

Permet de créer directement des lignes soldées (O/N). Doit être à O

TYF A1[12]

Génération des sorties normales à la réception des achats (O/N, O par défaut)

TYF A1[13]

L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E

TYF A1[14]

Commande de marché (O/N, N par défaut))

TYF A1[15]

Commande de sous-traitance (O/N)

TYF A1[16,23]

L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E

TYF A1[24]

Le code produit doit-il exister dans le fichier matière pour saisir une commande (O/N, O par défaut)

TYF A1[25]

Prise en compte des zones longueur et largeur dans le calcul du prix unitaire (O/N, O par défaut)

TYF A1[26]

Permet de mettre à jour les stocks de la fiche article sans création de mouvement de stock (O/N, N par défaut)

TYF A1[27]

Affectation du numéro de lot

1 Numéro de commande fournisseur

2 Numéro de commande fournisseur + ligne

3 Numéro de commande fournisseur + ligne + ligne de cadencement (par défaut)

4 Numéro de commande de l'affectation + Ligne de l'affectation

5 Numéro du lot de la ligne de la commande d'affectation

Numéro du lot de la ligne de la commande d'affectation si affectation renseignée et numéro du lot de la ligne de la commande d'affectation renseigné

Numéro de commande de l'affectation + Ligne de l'affectation si affectation renseignée et numéro du lot de la ligne de la commande d'affectation non renseigné

Numéro de commande fournisseur + Ligne si affectation non renseignée

TYF A1[28,30]

Ce code permet de définir une trame d'édition type dans l'édition des commandes d'achat.

A gérer de manière spécifique au niveau de chaque édition.

TYF A1[31]

Saisie de la commande/ligne de rattachement (B/W/N)

B Saisie bloquante / obligatoire

W Saisie non bloquante / obligatoire

N Pas de saisie du rattachement (par défaut)

TYF A1[32]

Génération d'un fichier ORDERS ou autres (selon TSC ORD)

N pas de génération pour ce type de commande fournisseur

P génération pour création d'une FB2 (après intégration)

A génération pour création d'une CD2 (après intégration)

Utilisé par G_generer_edi_cde

TYF A1[33]

Type de commande fournisseur (B/P, B par défaut) - Facultatif

B Bobine

P Palette

Voir la fiche d'installation : pour les bobines pour les palettes

TYF A1[34,42]

Remarque pour les 3 paramètres suivants :

Permet de forcer les unités d'achat et utilisation ainsi que la formule de conversion à utiliser pour la saisie de la quantité commandée de la ligne de commande fournisseur.

Par défaut, ces informations sont récupérées sur l'article commandée.

Remarque : Ce paramétrage sera utilisé dans le cas où le produit saisi sur la ligne de commande fournisseur est générique et qu'il fait l'objet d'une génération d'un nouveau code produit, et que ces deux produits ont des unités différentes (dans ce cas, les unités à mettre en place sur le type de commande seront les unités du produit final généré).

TYF A1[34,36]

Code unité d'achat (doit correspondre à un code paramètre de type UNI)

Par défaut : code unité d'achat saisi sur le produit commandé (mat.mp_ua)

TYF A1[37,39]

Code unité de vente (doit correspondre à un code paramètre de type UNI)

Par défaut : code unité de vente saisi sur le produit commandé (mat.mp_uv)

TYF A1[40,42]

Code formule de conversion (doit correspondre à un code paramètre de type FOR)

Par défaut : code unité d'achat saisi sur le produit commandé (mat.mp_fconv)

Valeur alpha 2

Paramétrage des types de mouvements de stock

TYF A2[1,3] | Type d'entrée normale
TYF A2[4,6] | Type d'entrée en commande fournisseur
TYF A2[7,9] | Type de sortie normale
TYF A2[10,12] | Type de sortie en commande fournisseur
TYF A2[13] | Ouverture d'une fenêtre de saisie des OF du groupage de l'ordre de marché (ou de la ligne de la commande) O Oui (par défaut) N Pas de sortie normale effectuée
TYF A2[14] | Alimentation de fab5 depuis brc (O/N, N par défaut)
TYF A2[15,17] | TMV pour sortie normale. On retient seulement le code TMV, les paramètres liés sont ignorés (type de mouvement et état.
TYF A2[18,20] | Type de mouvement d'entrée en commande du TYF des bobines - Facultatif Exemple : BEC Voir la fiche d'installation

Valeur alpha 3

TYF A3[1] | Saisie du dossier d'affectation dans une fenêtre (O/N, pas de valeur par défaut) Si non renseigné, le système vérifiera la présence de l'option Osa sur cdef.
TYF A3[2] | Saisie d'une quantité dans plusieurs unités possibles (O/N, pas de valeur par défaut) Si non renseigné, le système vérifiera la présence de l'option Osp sur cdef.
TYF A3[3] | Interdiction de modifier les zones de longueur, largeur et poids lors de la saisie d'une nouvelle ligne de commande O = on interdit, N = on autorise. Pas de valeur par défaut. Ce paramètre a priorité sur l'option Oml de cdef.
TYF A3[4,10] | L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E
TYF A3[11] | Moment de saisie des refoulages - Voir aussi alpha3[42] 0 ou 1 Après le prix de vente 2 Après la désignation N Pas de saisie (par défaut)
TYF A3[12,30] | L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E
TYF A3[31] | Type de contrôle du lot sur les mouvements de stocks C Contrôle sur entête seule (valeur par défaut) L Contrôle sur entête + ligne
TYF A3[32] | Contrôle du produit lors du contrôle du lot W Contrôle non bloquant B Contrôle bloquant N Pas de contrôle (valeur par défaut)
TYF A3[33] | Type du contrôle à effectuer sur l'affectation. O L' affectation est un OF (valeur par défaut) C L' affectation est une commande T L'affectation est un code client
TYF A3[34,39] | Type et code du paramètre de configuration de recherche des tarifs Si non renseigné, on regarde dans cdef A3 [18,23]. En dernier recours, on prend #CF TAR.
TYF A3[40] | Contrôle de la laize et de la coupe O Contrôler par rapport au code machine N Pas de contrôle (par défaut)
TYF A3[41] | L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E - L I B R E
TYF A3[42] | Fenêtre de saisie des refoulages Focus direct sur le type de raine sans saisie du tableau des refoulages (O/N, N par défaut) Voir alpha3[11]
TYF A3[43] | Réintégration de la quantité dans les besoins matières N Non O Oui C Confirmation
TYF A3[44] | Recodification des articles (O/N, O par défaut) Utilisé dans G_cdef
TYF A3[45] | Saisie des cadencements de réception O Activer N Ne pas activer I Ignorer (par défaut) Ce paramétrage est prioritaire sur l'option Oca de la saisie des commande fournisseurs.
TYF A3[46,51] | Type et code du paramètre de configuration de la saisie des tarifs Sur l'écran de saisie des lignes de commandes fournisseur, l'action F6 permet d'accéder à la nouvelle saisie des tarifs.

Valeur alpha 4

TYF A4[10,12]

Type d'estampille nécessaire à la saisie des refoulages

Notes

Notes pour la recherche de matières par F7

TYPE_ACC_VISU_MAT_X

CODE_ACC_VISU_MAT_X

SMATn

TYPE_RECH_F7_MAT

Ces notes sont expliqués dans les généralités (notes communes à plusieurs programmes).

Les notes paramétrées sur TYF sont prioritaires sur celles du programme de saisie de commandes fournisseurs.

Autres notes

Les notes #F1, #F2, #F3 sont utilisées avec l'option -Ona dans cdef

Il peut exister plusieurs lignes pour un même type de note.

#F1 | 4 à 60 Ligne de note d'entête par défaut à recopier lors de la création d'une commande d'achat
#F2 | 4 à 60 Ligne de note de livraison par défaut à recopier lors de la création d'une commande d'achat
#F3 | 4 à 60 Ligne de note de facturation par défaut à recopier lors de la création d'une commande d'achat
BORNES_DONNEE_TEC_ | Contrôles des valeurs saisies par rapport à des bornes minimum/maximum 19 Numéro de donnée technique (1 à 4) 21,30 Valeur minimum (999999.999) 32,41 Valeur maximum (999999.999) Ce fonctionnement est valable pour les programmes suivants Saisie des commandes d'achat (cdef) Saisie des inventaires (inventaire) Saisie des devis multi-métiers (devis_standard) Saisie des matières (mat) Visualisation des besoins matières (v_cde_5) Le paramétrage de contrôle sera recherché dans l'ordre suivant 1. Famille de la qualité matière 2. Type de commande d'achat (saisie des commandes d'achat uniquement) 3. Paramètre de lancement du programme
#CC | Contrôler l'affichage et la saisie des champs 5,22 Nom du champ sur lequel le contrôle s'effectue. 23 Type de contrôle à effectuer : N pas de contrôle (par défaut) W le champ doit être saisi (non-bloquant) B le champ doit être saisi (bloquant) I le champ n'est pas accessible en saisie M le champ est masqué Si cette note n'est pas trouvée ici, elle sera recherchée dans la saisie des commandes fournisseurs. Voir en bas de cette page la liste des champs disponibles.
COLLECTIF_ACHAT | Numéro de compte collectif fournisseur 21,28 Compte général 29,36 Compte export (uniquement pour Sage ligne 1000) 37,44 Compte suspension (uniquement pour Sage ligne 1000) 45,52 Compte intracommunautaire (uniquement pour Sage ligne 1000) 53,60 Compte exonéré (uniquement pour Sage ligne 1000) Si cette note n'est pas trouvée ici, le paramétrage sera recherché sur la note COLLECTIF_FOURN. du #CF TFF.
COLLECTIF_BRC | Paramétrage du compte collectif pour les bons de réception Bons de réception : voir la page récapitulative dans le #CF TFB 21,28 Numéro de compte collectif fournisseur 29,36 Numéro de compte collectif fournisseur Export (uniquement pour Sage ligne 1000) 37,44 Numéro de compte collectif fournisseur Suspension (uniquement pour Sage ligne 1000). 45,52 Numéro de compte collectif fournisseur Intracommunautaire (uniquement pour Sage ligne 1000). 53,60 Numéro de compte collectif fournisseur Exonéré (uniquement pour Sage ligne 1000). Si le paramétrage spécifique BRC ne retourne aucune valeur, alors on regardera le paramétrage des achats.
CORRES_TYC_SAP | SPECIFIQUE
CTRL_CODE_CS_ | Contrôle de saisie des codes statistiques 14 Code statistique (1 à 4) 21 Code statistique obligatoire (O/N, N par défaut) Cette note a priorité sur #CF CDF A3[50 à 53]
F7_SUR_CODE_ARTICLE | Type de recherche du code article par F7 1 Recherche normale (par défaut) 2 Recherche sur les données techniques 3 Recherche spécifique papier 5 Recherche par fournisseur et libellé étranger. Q Recherche sur la qualité T Recherche orientée Transformateurs Cette note est prioritaire sur A3[24] du paramètre de lancement de la saisie des commandes fournisseurs.
FA | Permettre de lancer automatiquement des touches de fonctions après la validation de l'entête, du produit ou de la ligne de saisie de commande d'achat 3 Code d'écran E Ecran de saisie de l'entête de commande d'achat L Ecran de saisie des lignes de commande d'achat 4,6 Traitement de touche à exécuter F20 Ouverture de la saisie des informations complémentaires 7 Lancement en création (O/N, N par défaut) 8 Lancement en modification (O/N, N par défaut) 9,11 Position du lancement Pour le code d'écran E (Entête) : FIN : Lancement de la touche après la validation de l'entête de commande d'achat (par défaut) Pour le code d'écran L (Lignes) FIN : Lancement de la touche après la validation de la ligne de commande d'achat (par défaut) PRD : Lancement de la touche après la validation du produit
FORMAT_LARGEUR | 21,60 Format numérique à appliquer aux champs de largeur des écrans de commande d'achat
FORMAT_LONGUEUR | 21,60 Format numérique à appliquer aux champs de longueur des écrans de commande d'achat
FORMAT_MONTANT_CDF | 21,60 Format numérique à appliquer aux champs de montant des écrans de commande d'achat
FORMAT_POIDS | 21,60 Format numérique à appliquer aux champs de poids des écrans de commande d'achat
FORMAT_UNITE_ACHAT | 21,60 Format à utiliser pour les champs de quantité en unité d'achat (using)
FORMAT_UNITE_VENTE | 21,60 Format à utiliser pour les champs de quantité en unité de vente (using)
FORMULE_CONV_SURFACE | 21,22 N° de formule de conversion surface (1 par défaut) SI cette note n'est pas trouvée ici, elle est recherchée sur le paramètre de lancement de cdef.
FORMULE_CONV_TARIF | 21,22 N° de formule de conversion tarif (1 par défaut) SI cette note n'est pas trouvée ici, elle est recherchée sur le paramètre de lancement de cdef.
LIBELLE_TECHNIQUE_n | où n peut prendre les valeurs 1 à 4. 21,40 Libellé technique Si cette note n'est pas trouvée ici, elle est recherchée sur le paramètre de lancement de cdef ou de v_cde_5
LIB_SAISIE_LONG_LARG | 21 Inversion des libellés de la saisie largeur/longueur (O/N, N par défaut) Voir aussi la note SAISIE_LONG_LARG. Cette note est prioritaire sur celle du paramètre de lancement de la saisie des commandes fournisseurs. Exemple LIB_SAISIE_LONG_LARGO SAISIE_LONG_LARG O F7_SUR_CODE_ARTICLE 2 TYPE_ACC_VISU_MAT_2 #VI CODE_ACC_VISU_MAT_2 QUA
MACHINE_PAR_DEFAUT | 21,26 Code machine par défaut
NEW_CODE_VALID_BRC | 21,23 Code validité à mettre à jour sur l'article réceptionné Cette note est prioritaire sur la note NEW_CODE_VALIDITE du paramètre de lancement de brc.
NEW_CODE_VALID_CDF | 21,23 Code validité à mettre à jour sur l'article commandé
SAISIE_LONG_LARG | 21 Inversion de la saisie largeur/longueur (O/N, N par défaut) Voir aussi la note LIB_SAISIE_LONG_LARG. Cette note est prioritaire sur celle du paramètre de lancement de la saisie des commandes fournisseurs.
_SUP_MAJ_VALID_BRC | 21,60 Complément de requête sur la fiche matière. But : pouvoir modifier automatiquement la validité d'un article réceptionné. Voir la note NEW_CODE_VALID_BRC. Cette note est prioritaire sur la note _SUP_REQ_MAJ_VALID du paramètre de lancement de brc.
_SUP_MAJ_VALID_CDF | 21,60 Complément de requête sur la fiche matière. But : pouvoir modifier automatiquement la validité d'un article commandé. Voir la note NEW_CODE_VALID_CDF.
UNITE_TECHNIQUE_1 | 21,23 Unité à afficher pour la longueur
UNITE_TECHNIQUE_2 | 21,23 Unité à afficher pour la largeur
UNITE_TECHNIQUE_3 | 21,23 Unité à afficher pour le poids
UNITE_TECHNIQUE_4 | 21,23 Unité à afficher pour la zone paramétrée numérique (cdf2.lf_zpar_num1)

Liste des champs contrôlables dans la note #CC

La liste est triée par ordre alphabétique.

Pour chaque champ, les infos suivantes sont affichées :

Nom du champ

Libellé du champ

Circonstances du contrôle :

Entête : contrôles possibles au niveau de la saisie de l'entête.

Lignes : contrôles possibles au niveau de la saisie des lignes.

Interro : contrôles possibles au niveau de l'interrogation.

Valeurs autorisées: ce sont les codes indiqués dans la note #CC_ENTETE, à savoir :

N pas de contrôle (par défaut)

W le champ doit être saisi (non-bloquant)

B le champ doit être saisi (bloquant)

I le champ n'est pas accessible en saisie

M le champ est masqué

des_article Désignation article Lignes:M

ed_infos Informations Interro:M

ef_ach Code acheteur Entête:WBIM Interro:M

ef_ada Adresse d'envoi Entête:WBIM Interro:M

ef_adf Adresse de facturation Entête:WBIM

ef_adl Adresse de réception Entête:WBIM Interro:M

ef_adst Lieu de sous-traitance Entête:WBIM

ef_c1 Zone paramétrable Entête:WBIM Interro:M

ef_client_liv Client livré Entête:WBIM Interro:M

ef_corres Correspondant Entête:WBIM

ef_cours Taux devise Entête:WBIM

ef_cr Code remise Entête:WBIM

ef_ct Code tarif Entête:WBIM

ef_datc Date de la commande Entête:WBIM Interro:M Lignes:M

ef_devise Code devise Entête:WBIM Interro:M

ef_ech Code échéance Entête:WBIM Interro:M

ef_exp Exportation Entête:WBIM Interro:M

ef_fact Facture éditée Interro:M

ef_fou Code fournisseur Entête:WBIM Interro:M Lignes:M

ef_mrg Mode de règlement Entête:WBIM Interro:M

ef_num Numéro de commande Entête:WBIM Interro:M Lignes:M

ef_ref Référence commande Entête:WBIM Interro:M

ef_rem Remise globale Entête:WBIM Interro:M

ef_rgt Lieu de rangement Entête:WBIM

ef_signature Code signature Entête:WBIM Interro:M

ef_sold Commande soldée Interro:M

ef_titre Titre correspondant Entête:WBIM

ef_transport Type de transport Entête:WBIM

ef_tyc Type de commande Entête:WBIM Interro:M

lf_adl Adresse de réception Lignes:WBIM

lf_adst Adresse de sous-traitance Lignes:WBIM

lf_affect OF d'affectation Interro:M Lignes:WBIM

lf_annu Annulé Interro:M

lf_arc Code ARC Interro:M

lf_arc Code ARC Lignes:M

lf_cdc Centre de coût Interro:M Lignes:WBIM

lf_cderat Commande de rattachement Lignes:M

lf_certification Code certification Interro:M Lignes:WBIM

lf_cli Code client Lignes:WBIM

lf_colis Nombre de colis Lignes:WBIM

lf_cs1 Code statistique 1 de la ligne de commande fournisseur

lf_cs2 Code statistique 2 de la ligne de commande fournisseur

lf_cs3 Code statistique 3 de la ligne de commande fournisseur

lf_cs4 Code statistique 4 de la ligne de commande fournisseur

lf_date_arc Date ARC Interro:M

lf_date_arc Date ARC Lignes:M

lf_delai_demande Délai demandé Lignes:WBIM

lf_delfou Délai du fournisseur Interro:M Lignes:WBIM

lf_delrep Délai répondu Interro:M Lignes:M

lf_etatmar Etat de marche Lignes:WBIM

lf_fam Code famille Interro:M Lignes:WBIM

lf_forfait Forfait Lignes:WBIM

lf_larg Largeur Interro:M Lignes:WBIM

lf_lcderat Ligne de cde de rattachement Lignes:M

lf_lib Libellé du produit Interro:M

lf_lig Numéro de ligne Interro:M

lf_long Longueur Interro:M Lignes:WBIM

lf_poids Poids Lignes:WBIM

lf_prix fac Prix facturé Interro:M

lf_prixliv Prix unitaire d'achat réalisé Interro:M Lignes:M

lf_prod Code produit Interro:M

lf_prx Prix unitaire d'achat Interro:M

lf_qte_retour Quantité retournée Lignes:M

lf_qtecde Quantité commandée Interro:M

lf_qtefac Quantité facturée Interro:M

lf_qteliv Quantité réceptionnée Interro:M Lignes:M

lf_qtemar Quantité de marche Lignes:WBIM

lf_rem Remise Interro:M Lignes:WBIM

lf_rgt Lieu de rangement Lignes:WBIM

lf_sec_ana Code section analytique Interro:M Lignes:WBIM

lf_sfm Code sous-famille Interro:M Lignes:WBIM

lf_solde Solde Interro:M Lignes:M

lf_tva Code TVA Lignes:WBIM

lf_unacha Unité d'achat Lignes:M

lib_cdc Libellé centre de coût Lignes:M

lib_note1 Notes entête Entête:WBIM

lib_note2 Notes Livraison Entête:WBIM

lib_note3 Notes facturation Entête:WBIM

libelle Libellé Lignes:WBIM

mp_uv Unité de vente (article) Lignes:M

nom_client2 Nom du client Lignes:M

notes_entete Notes entête Interro:M

notes_ligne Notes Ligne Interro:M

prx Prix d'achat Lignes:WBIM

qtecde Quantité commandée Lignes:WBIM

sous_secteur Sous-secteur Lignes:M

stock_physique Stock physique Lignes:M

unite_achat Unité d'achat Lignes:M

unite_prix Unité de quantité d'achat Lignes:M


TYO Type d'offre de prix

Valeur alpha 1

TYO A1[1,3]

Type d'écran de saisie des lignes d'offres de prix :

LIG Ecran de saisie multi-lignes

NIV Ecran de saisie nomenclaturée

Valeur alpha 4

TYO A4[1,60]

Titre de l'écran des lignes d'offres de prix


TYS Types de section

Figé pour le contrôle budgétaire

PRI | Centre de coût principal
AUX | Centre de coût auxiliaire


UNA Unités d'achat

Pas de paramétrage. Seul le libellé est utilisé.

Voir le paramètre UNI.

Utilisé uniquement dans la recherche des tarifs fournisseurs (fonctions calctar et calunite).


UNI Codes unités

Ce paramètre a souvent été nommé à tort Unité de vente.

En réalité, il est utilisé aussi bien pour les unités d'achat que pour les unités de vente.

Le code unité peut être utilisé dans le fichier matière, les devis, les fiches opérations, les mouvements de stock, etc.

Valeurs numériques

UNI N1 | Cette valeur est utilisée par exemple pour spécifier l'unité de vente Exemple : Si on doit remettre un prix au 1000 sur un accusé de réception de commande, l'unité de transaction (dans la ligne de commande) peut être MIL et la valeur 1 du paramètre doit contenir 1000. Si cette valeur est à zéro, la saisie est forfaitaire
UNI N2 | Définit le nombre de décimales significatives apparaissant dans certaines éditions Exemple Si l'unité est la pièce, le nombre de décimales utiles est 0

Valeur alpha 1

UNI A1[1]

Pour la remontée des temps (art graphiques), le caractère 1 de la zone alpha 1 désigne la façon de calculer le nombre de produits fabriqués en fonction du nombre de tours machine.

F On roule des feuilles (et donc on fabrique plusieurs produits par tour machine)

U On roule un produit par tour

[blanc] On ne fabrique rien (Exemple Calage)

Exemple Unité T/H Tours à l'heure

Roulage impression

Valeur alpha 1 = F

A chaque tour, on fabrique nombre de poses unités

Unité HEU Heure

Tous les calages

Zone alpha 1 rien

On ne fabrique rien pendant un calage

UNI A1[2,4]

Formule de conversion (CEN, MIL, etc.)

UNI A1[5]

Ouverture (Oui ou Non) d'une fenêtre de saisie de prix unitaire dans la saisie de commande

UNI A1[6]

Dans l_gdf permet d'arrondir à l'unité la quantité du mouvement prévisionnel.

UNI A1[7]

Dans le devis imprimerie

K ou [espace] Prix au kilo

T Prix à la tonne

UNI A1[8]

O Unité au kilo (N par défaut)

UNI A1[9]

Unité d'utilisation pour le calcul du transport dans le devis et dans la logistique (voir aussi #CFDER A2[8])

A à la surface au sol

B au volume de la palette

C au nombre de palettes

D au nombre total de palettes du devis

F Recherche du poids sur une phase formule
La phase est paramétrée en #CFDER A3[2,4]

G Recherche du poids sur une phase formule. Pas de proratisation
La phase est paramétrée en #CFDER A3[2,4]
Générique (obligatoire pour unité forfaitaire) [19/11/2013 note de DVA : à vérifier]

K au kilomètre

M au mètre linéaire plancher
La largeur camion est paramétrée en #CFDER A2[27,30] uniquement si optimisation de la palettisation.

N au mètre linéaire plancher (entité courante uniquement) - Largeur du camion en #CFDER A2[27,30]

P au poids (par défaut)

V au volume

X Pas de calcul du transport

UNI A1[11]

Méthode de recherche pour le calcul du poids du transport

T Recherche sur formule en utilisant le code calcul RT
(Recherche données matières pour la formule de transport paramétrable, par défaut)

M Recherche sur formule en utilisant le code calcul RM
(Recherche données matières pour la formule de transport paramétrable)

Voir aussi

#CF DER A3[1,8]

TPR note FOR_POIDS_TRANSPORT

UNI note FOR_POIDS_TRANSPORT

UNI A1[12,14]

Code phase, correspond aux caractères 1 à 3 du code calcul RM/RT

UNI A1[15,17]

Code formule, correspond aux caractères 4 à 6 du code calcul RM/RT

UNI A1[18]

Rubrique, correspond au caractère 7 du code calcul RM/RT

UNI A1[19]

Périodicité du forfait

J journalier

M mensuel

N non (par défaut)

UNI A1[20]

Notion de camion complet (O/N, N par défaut)

La valorisation des transports peut maintenant s'appuyer sur des prix forfaitaires par camion complet.

A partir du pourcentage de tolérance sur le métrage maxi du type de véhicule (#CF LOG, valeur numérique 2), on détermine si le véhicule est complet ou non. S'il ne l'est pas, on ne retiendra pas les tarifs ayant une code unité de vente avec le nouveau paramétrage au camion complet.

UNI A1[21]

Ne pas afficher les décimales dans le CTRL-B (O/N, N par défaut)

O ne pas afficher les décimales

N afficher les décimales

UNI A1[22]

Unité de recherche pour la visualisation (ex : ML, KM ou PAL) (O/N)

Voir les notes INFO_V_TARIFS_TRANSP et TIT_V_TARIFS_TRANSP

UNI A1[23]

Proratisation du forfait en facturation (O/N, N par défaut)

Pour les unités forfait, celles dont la valeur numérique 1 = 0, indique si on facture au prorata de la quantité facturée ou pas.

L'option Ofr est prioritaire sur ce paramètre. Cette option existe dans les paramètres de lancement de:

v_fac Visualisation des factures

tr_fcnn_vl Transfert des factures clients en comptabilité

v_jdv Visualisation du journal des ventes

facn Calcul et édition des factures

Il existe 2 méthodes de calcul du forfait :

1. La 1ère facture est faite pour la totalité du forfait et ce quelle que soit la quantité.

Les factures suivantes sont à 0. (Méthode par défaut)

2. Le montant de chaque facture est proratisé en fonction de la quantité facturée.

• soit par une option du programme qui force le mode de gestion proratisé,

• soit par un paramétrage de l'unité du forfait.

L'option Ofr sur le paramètre de lancement du programme est prioritaire sur le paramétrage de l'unité.

Dans ce mode, lorsque la ligne de commande est soldée, c'est la quantité livrée qui sert de base au calcul du prorata.

Dans les 2 méthodes, le prix de vente de la ligne de facture est celui du forfait saisi sur la ligne de commande.

Valeur alpha 2

UNI A2[1,3] | Nombre de paquets par carton
UNI A2[4] | Unité à prendre en compte pour les commandes de plaques via le WEB
UNI A2[5] | Unité à prendre en compte pour les commandes de PF via le WEB
UNI A2[6] | Unité par défaut à prendre en compte pour les commandes via le WEB

Valeur alpha 4

UNI A4[1,10]

Cette zone contient le singulier du libellé de l'unité.

Tandis que la zone libellé court contient le pluriel.

Notes

CODE_UNI_EFFICIAL

21 Code unité de vente - SPECIFIQUE

CORRESP_EDI

21,23 Code correspondance pour génération / intégration fichier EDI de type ORDERS ou autres

Les codes correspondances associés au type UNI sont :

M2 au m²

%M2 au cent m²

MM2 au mille m²

UNI à l'unité

CEN au cent

MIL au mille

KG au Kg

%KG au 100 Kg

TON à la tonne

ML au mètre linéaire

%ML au 100 mètre linéaire

MML au 1000 mètre linéaire

FOR forfait

Si le code de type UNI à paramétrer est égal au code de correspondance ci-dessus, il n'est pas nécessaire de renseigner la ligne de note !

CORRES_UNA_SAP

SPECIFIQUE

FORMULE_CONV_YYY

Formule de conversion pour passer de l'unité XXX à l'unité YYY

où XXX représente le code de l'unité en cours.

FOR_POIDS_TRANSPORT

21,23 Type de processus

24 Méthode de recherche pour le calcul du poids du transport

T Recherche sur formule en utilisant le code calcul RT (Recherche données matières pour la formule de transport paramétrable, par défaut)

M Recherche sur formule en utilisant le code calcul RM
(Recherche données Matières pour la formule de transport paramétrable)

25,27 Code phase, correspond aux caractères 1 à 3 du code calcul RM/RT

28,30 Code formule, correspond aux caractères 4 à 6 du code calcul RM/RT

31 Rubrique, correspond au caractère 7 du code calcul RM/RT

Voir aussi

#CF DER A3[1,8]

TPR note FOR_POIDS_TRANSPORT

UNI A1[11,18]

INFO_V_TARIFS_TRANSP

Visualisation des tarifs transporteurs

21,22 Nombre total d'occurrences

23,29 Pas

30,36 Format du pas

37,39 Numéro de colonne servant de référence pour la colonne camion complet

Uniquement si A1[22] = O - Utilisé par v_tarifs_transp

LIB_PARAMETRABLE

Libellé de l'unité à afficher dans l'écran G_s_qte_conv

Il est possible d'y intégrer des champs de la table mat en encadrant le nom du champ par des [crochets].

On peut également appliquer un format aux champs numériques en faisant suivre le nom du champ du caractère ‘+' puis du format.

Exemple

LIB_PARAMETRABLE [mp_cond] de [mp_dt8+<<< <<&] [mp_ua]

TIT_V_TARIFS_TRANSP

Visualisation des tarifs transporteurs

21,60 Titre de la visu pour cette unité de référence

Uniquement si A1[22] = O - Utilisé par v_tarifs_transp

[Unité Quantité Poids]

21, 23 Unité de quantité correspondante du client

25, 27 Unité de poids correspondante du client

Le nom de cette note est paramétré dans la note commençant par NOTE_SUR_UV des programmes suivants :

edi_cde_aviexp

integrer_edi_cde

blv_galia_ed1


USE Utilisateurs

Permet de saisir un intervenant associé à une machine concernée par une qualification/surveillance.

Permet de saisir des notes dans la gestion des qualifications/surveillance :

• Sur un produit à qualifier/surveiller (clé de notes : numéro de commande, numéro de ligne de commande, code produit à qualifier/surveiller)

• Sur une machine associée au produit à qualifier/surveiller (clé de notes : numéro de commande, numéro de ligne de commande, code produit à qualifier/surveiller, code machine)

• Le type de clé de note est figé : £

• Le type de note est figé : NTS/MQS

• Le nombre de lignes de notes saisissable peut être limité via un paramétrage sur le paramètre NTS/MQS. Ce nombre de lignes maximum sera également utilisé dans l'édition de l'OF (par défaut : 10 lignes de notes sont édités sur 2 colonnes).

ATTENTION : Le nombre de lignes de l'édition d'OF passe de 130 à 150 lignes.

Voir aussi ATR, note ENVOI_DEST, car.24,26=%b%

white #FFFFFF

black #000000

darkGray #808080

gray #A9A9A9

lightGray #D3D3D3

darkBlue #00008B

blue #0000FF

lightBlue #ADD8E6

darkCyan #008B8B

cyan #00FFFF

lightCyan #E0FFFF

darkMagenta #8B008B

magenta #FF00FF

lightMagenta #FFC0FF

darkOlive #505000

olive #808000

lightOlive #AAAA44

darkGreen #008000

green #00FF00

lightGreen #00FFB0

darkTeal #005050

teal #008080

lightTeal #33CCCC

darkRed #8B0000

red #FF0000

lightRed #FF8080

darkOrange #FF8C00

orange #FFA500

lightOrange #FFCC00

darkYellow #AAAA00

yellow #FFFF00

lightYellow #FFFF99

white #FFFFFF

black #000000

darkGray #808080

gray #A9A9A9

lightGray #D3D3D3

darkBlue #00008B

blue #0000FF

lightBlue #ADD8E6

darkCyan #008B8B

cyan #00FFFF

lightCyan #E0FFFF

darkMagenta #8B008B

magenta #FF00FF

lightMagenta #FFC0FF

darkOlive #505000

olive #808000

lightOlive #AAAA44

darkGreen #008000

green #00FF00

lightGreen #00FFB0

darkTeal #005050

teal #008080

lightTeal #33CCCC

darkRed #8B0000

red #FF0000

lightRed #FF8080

darkOrange #FF8C00

orange #FFA500

lightOrange #FFCC00

darkYellow #AAAA00

yellow #FFFF00

lightYellow #FFFF99

USE Utilisateurs

Remarque Si le système ne trouve pas de paramètre USE correspondant au nom de login de l'utilisateur, alors il prend automatiquement la valeur USE DEF.

Libellé long

Nom et prénom de l'utilisateur

Libellé court

Nom et prénom abrégés de l'utilisateur

Valeur alpha 1

USE A1[1,8] | Nom de login de l'utilisateur (attention, ce nom doit être unique)
USE A1[9,11] | Code usine associé à l'utilisateur Utilisé pour initialiser le site de production de l'entête des BL ainsi que le site de production des frais d'expédition. Ne pas confondre avec A3[10,12]. Tableau de bord du multisite
USE A1[12,14] | Code langue associé à l'utilisateur Il s'agit du code normalisé ISO (en minuscules). Utilisé entre autres par #CF ATL alpha1[18]
USE A1[15,23] | à vérifier
USE A1[24] | Autorisation à la saisie simplifiée des paramètres [A VERIFIER]
USE A1[30,50] | Numéro de téléphone de l'utilisateur

Valeur alpha 2

USE A2[1]

Droit d'accès au control-Z

N non

O oui

R oui avec restriction

o oui sauf depuis le menu principal

r oui avec restriction sauf depuis le menu principal2

Restreint aux lignes de notes commençant par RUN)

USE A2[2]

Autorisation [!] (O/N)

USE A2[3]

Autorisation CONTROL-T (O/N)

USE A2[4]

Autorisation CONTROL-E (O/N)

USE A2[5]

Autorisation CONTROL-O (O/N) : Affichage du bouton Options du menu GENERO

USE A2[6]

Autorisation d'accès au paramétrage de lancement (O/N) :

Accès à la touche CONTROL-P en V.3.50

Visibilité du bouton Paramètres de la barre d'outils sous GENERO

USE A2[7]

Autorisation CONTROL-P du F7 (O/N)

USE A2[8]

Accès au devis en consultation seule (O/N)

USE A2[9]

Autorisation de créer le premier sous-devis (O/N)

USE A2[10]

Autorisation de créer les autres sous-devis (O/N)

N'agit pas sur le bouton Génération des variantes sur l'entête du devis.

Agit uniquement sur la saisie du numéro de sous-devis pour ne pas prendre le prochain et ainsi créer une nouvelle variante.

USE A2[11]

Accès aux entités autorisées (O/N)

USE A2[12]

Contrôle du deviseur sur le devis activé (O/N)

Attention, ce message met à jour automatiquement le code du deviseur

USE A2[13]

Modification manuelle du code deviseur (O/N)

USE A2[14]

Modification d'un sous-devis passé en sous-devis 99 (O/N)

USE A2[15]

Modification du premier sous-devis autorisée (O/N)

USE A2[16]

Modification des autres sous-devis autorise (O/N)

USE A2[17]

Autorisation d'annuler le premier sous-devis (O/N, N par défaut)

USE A2[18]

Autorisation d'annuler les autres sous-devis (O/N, N par défaut)

USE A2[19]

Autorisation d'utiliser les touches F6 de basculement de l'état de la ligne de commande client

(Facturable uniquement <--> Livrable et facturable)

USE A2[20]

Autorisation de modifier un article si son code de validité l'interdit. Voir QA A1[5]

(Autorisation si mot de passe sur code validité : QA A2[1-5], faire F6 sur le message pour débloquer, voir note QA N-)

USE A2[21]

Autorisation d'utiliser le CONTROL-E sur le menu (O/N, O par défaut)

Sous GENERO : visibilité du bouton Menu Tableau de la barre d'outils

USE A2[22]

Autorisation d'utiliser le F9 sur le menu (O/N, O par défaut)

USE A2[23]

Permet de saisir un code fournisseur dans une commande d'achat malgré l'interdiction paramétrée sur le code qualité du tiers.

Permet de saisir un code article sur une commande d'achat malgré l' interdiction paramétrée sur le code qualité de l'article.

O Autorisation de passer outre l'interdiction

N Pas d'autorisation (valeur par défaut)

USE A2[24]

Autorisation d'utiliser la saisie simplifiée des paramètres pour modifier un paramètre listé dans une recherche (touche F8 dans la fenêtre de résultat dans la recherche de paramètres).

USE A2[25]

Autorisation de modifier les gâches fixe et variable et l'unité de la gâche dans les détails matières utilisées et opérations à réaliser (O/N, O par défaut)

USE A2[26]

Autorisation de modifier la cadence, le temps standard et le code forçage dans le détail opérations à réaliser (O/N, O par défaut)

USE A2[27]

Autorisation de modification de l'état d'un devis (O/N, O par défaut)

Voir les notes MOD_ETAT_DEVIS_AUT et MOD_ETAT_DEVIS_INT

USE A2[28]

Permission d'accès à la saisie de la fiche article dans l'écran des références multiples du devis multi-métiers

Voir la note ACCES_MAT_REFERENCE dans le devis multi-métiers.

O Accès à la saisie de la fiche article

N Accès à la visualisation simplifiée de l'article (par défaut)

USE A2[29]

Touche d'accès à la demande de modification de commande activée (O/N, N par défaut )

Voir le devis multi-métier : option Odd et note ETAT_DEVIS_FAB_MOD

Voir aussi la saisie de commandes clients : note ETAT_DEVIS_MODIF

USE A2[30]

Autorisation Menu visu budgétaire (N/1/2/3/4/5/6/7)

N Non

1 Visualisation, Edition, Fichier

2 Visualisation, Edition

3 Visualisation, Fichier

4 Visualisation

5 Edition, Fichier

6 Edition

7 Fichier

USE A2[31]

Autorisation d'accès à la zone question de la nouvelle saisie des LCO (O/N, O par défaut)

USE A2[32]

Au DEL sur le premier menu, on demande confirmation avant de sortir (O/N, N par défaut)

USE A2[33]

Devis onduleur. Doit-on faire un contrôle sur les encres saisies dans l'écran couleur et celles saisies dans les TSC du triplet article /gamme /phase (O/N, N par défaut)

USE A2[34]

Devis onduleur.

Autorisation de modifier une offre 99 (O/N, N par défaut)

O autorisation

N on ne peut modifier l'offre 99, que si la validité du devis est différente de FAB

USE A2[35]

Droit de saisir les traitements sur la réclamation (O/N, N par défaut)

USE A2[36,38]

Code groupage pour recherche des imprimantes

USE A2[39]

Droit de modification du code de validation administration des ventes (O/N, O par défaut)

USE A2[40]

Droit de modification du code de validation production (O/N, O par défaut)

USE A2[41]

Droit de modification du code de validation logistique (O/N, O par défaut)

USE A2[42]

Autorisation de transférer des devis en commande dans le devis multi-métiers (O/N, N par défaut)

USE A2[43]

Autorisation d'accéder à la saisie de commande après un transfert de devis (O/N, N par défaut)

dans le devis Multi-Métiers.

USE A2[44,46]

Code paramètre du niveau hiérarchique du prix remis de l'écran de remise de prix du devis

Le type paramètre du niveau hiérarchique du prix remis est NHR

USE A2[47,49]

Code paramètre du niveau hiérarchique du prix négocié de l'écran de remise de prix du devis

Le type paramètre du niveau hiérarchique du prix remis est NHN

USE A2[50]

Gestion des zones prix de revient et marge standard de l'écran de remise des prix du devis onduleur

N les zones PR et marge standard ne sont pas visibles (par défaut)

O les zones PR et marge standard sont visibles mais non modifiables

M La zone PR est modifiable et la marge standard visible

USE A2[51]

Autorisation de désactiver la numérotation automatique des devis transformateurs.

On passe donc en numérotation manuelle.

USE A2[52]

Insertion (F1) autorisée dans le tableau des phases du devis (O/N, O par défaut)

Pour tous les devis qui utilisent l'écran des phases (devis multi-métiers, transformateurs, feuille, ...)

USE A2[53]

Suppression (F2) autorisée dans le tableau des phases (O/N, O par défaut)

Pour tous les devis qui utilisent l'écran des phases (devis multi-métiers, transformateurs, feuille, ...)

USE A2[54]

Activation / Désactivation (F14) autorisée dans le tableau des phases (O/N, O par défaut)

Pour tous les devis qui utilisent l'écran des phases (devis multi-métiers, transformateurs, feuille, ...)

USE A2[55]

Détail (F8) autorisé dans le tableau des phases

O Modification autorisé (par défaut)

N Non (F8 interdit)

C Consultation seule

Pour tous les devis qui utilisent l'écran des phases (devis multi-métiers, transformateurs, feuille, ...)

USE A2[56]

Autorisation de lancer la génération automatique des notes (O/N)

USE A2[57]

Demande la confirmation de sortie du devis tc (O/N, N par défaut)

USE A2[58]

Devis optimisé

O l'écran de paramétrage de l'optimisation apparaît.

N L'optimisation utilisera les paramètres par défaut.

USE A2[59]

Passage en mode expert dans le devis optimisé

O L'utilisateur pourra passer en mode expert dans le devis optimisé.

N Aucune possibilité pour l'utilisateur d'accéder au mode expert (TSC Par défaut).

Anciennement, ce paramètre permettait de cacher l'écran de sélection des machines.

Cette possibilité est maintenant offerte par #CF OPT A1[22].

USE A2[60]

Accéder en modification à la saisie des TSC si le devis est en consultation (O/N, N par défaut)

Valeur alpha 3

USE A3[1,3]

Code du terminal portable (type CAB)

USE A3[4,9]

Code employé habituel (table employé) (facultatif)

USE A3[10,12]

Code site de production d'appartenance de l'utilisateur

#CF SIT A1[1] = O (autorise la gestion par site de production)

Tableau de bord du multisite

Utilisations possibles :

  • Restreindre les différentes recherches faites par l'utilisateur en fonction de son site d'appartenance. Ne pas confondre avec A1[9,11]

  • Renseigner le code site de production créateur du devis et contrôler l'autorisation de l'utilisateur à accéder à un devis créé avec un autre code site de production que le sien.
    Voir la note MODIF_AUTORISEE_ ainsi que don A2[46,48].

  • Contrôler l'autorisation de l'utilisateur à accéder à une commande créée avec un autre code site de production que le sien.
    Voir la note MODIF_AUTORISEE_ ainsi que cde A4[18,20].

USE A3[13,15]

Code deviseur par défaut pour l'utilisateur

USE A3[16]

Réservé

USE A3[17,19]

Code signataire (SIG)

Voir BLF A1[3,5] = 004

USE A3[20,35]

L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S - L I B R E S

USE A3[36]

Interdire le lancement d'un même programme en simultané (O/N, O par défaut)

USE A3[37,38]

Nombre de programmes que l'on peut lancer en simultané

05 par défaut

USE A3[39]

Autorisation de modifier une réclamation client (O/N, N par défaut)

Autorise la modification de la réclamation à une personne autre que le rédacteur initial.

USE A3[40]

Droits d'accès à la personnalisation de la barre d'outils (boutons) GENERO (O/N, N par défaut)

USE A3[41,43]

Code du mot de passe pour la personnalisation de la barre d'outils GENERO (PWD)

USE A3[44,46]

Code représentant associé à l'utilisateur

Permet d'associer un code représentant à l'utilisateur actuel, afin de :

  • Limiter l'accès aux seuls devis créés par le représentant (ou sans code représentant)

  • Limiter la saisie du devis aux seuls tiers affectés au représentant (ou sans code représentant)

  • Limiter la saisie du devis aux seuls produits associés aux tiers affectés au représentant (ou sans code représentant sur le tiers, ou les produits sans code tiers associé)

  • Alimenter automatiquement le code représentant pour les devis en création/génération/copie

USE A3[47,49]

Code acheteur associé à l'utilisateur

USE A3[50]

Contrôle du changement de site d'appartenance lors de la modification du lieu de rangement 1

N Pas de contrôle (par défaut)

B Contrôle bloquant (modification du lieu interdite)

W Contrôle non bloquant (affichage d'un message d'avertissement)

C Contrôle avec demande de confirmation

Tableau de bord du multisite

USE A3[51]

Autorisation de saisie des valeurs validées des statuts de produit

Utilisé par G_genere_preactor

O L'utilisateur peut saisir les valeurs validées

N L'utilisateur ne peut pas saisir les valeurs validées (si la ligne correspond à une ligne déjà validée, l'utilisateur n'aura pas accès à la colonne de statut du produit)

Lors de la saisie d'une ligne de cadencement de fabrication, permettre, selon l'utilisateur, l'accès aux valeurs validées du statut du produit (nouveauté validée, réédition validée et modification validée).

USE A3[52]

Autorisation de créer plus de cadencements de fabrication que prévu sur le devis

O L'utilisateur peut créer des cadencements supplémentaires

C L'utilisateur peut créer des cadencements supplémentaires suite à la validation d'un message de confirmation

N L'utilisateur ne peut pas créer de cadencements supplémentaires (par défaut)

USE A3[53]

Autorisation de lancer la récupération des informations de fabrication sur le sous-devis (O/N, N par défaut)

Voir les notes MAJ_ENTITES_IDF et MAJ_ENTITES_IDC sur le paramètre TEN.

USE A3[54]

Réservé Volume Software

USE A3[55]

Autorisation d'accès à la fonction de réactualisation des images Artios dans le devis multi-métiers (O/N, N par défaut)

USE A3[56]

Activation des contrôles des quantités à la validation des devis multi-métiers

Voir TPR A4[41] et TEN A3[7]

N Pas de contrôle des quantités

W Contrôle non bloquant

B Contrôle bloquant (par défaut)

C Contrôle avec demande de confirmation

USE A3[57]

Autorisation pour accéder à la création/modification de catalogue (O, N, N par défaut)

Actuellement, pour les programme d'édition VoluEdit, tous les utilisateurs peuvent créer ou modifier un catalogue en cliquant soit dans la Toolbar, soit dans le TopMenu.

Maintenant, il faudra autoriser l'utilisateur pour qu'il puisse accéder à ce choix.

Sans paramétrage, l'icône catalogue n'est plus visible.

USE A3[58]

Blocage des fonctionnalités liées à la gestion des affiches (O/N, N par défaut)

Voir aussi genere_preactor A2[1]

USE A3[59]

L'utilisateur est un intervenant sur la gestion des qualifications/surveillance (O/N, N par défaut)

Plus d'info

Valeur alpha 4

USE A4[1,60]

Nom long de login de l'utilisateur, en minuscules - Facultatif

Notes triées

#CC_RECAP_DEVIS

Contrôle la modification de valeurs sur l'écran de récapitulatif du devis tc

Cette note est recherchée en priorité sur le paramètre USE.

Si elle n'est pas trouvée sur le paramètre USE, elle est recherchée dans le paramètre de lancement du devis_tc.

ACCES_ECRANS_DEVIS

Permet de paramétrer le mode d'accès aux différents écrans du devis onduleur

Pour chacun des écrans, les codes autorisés sont les suivants :

N Pas d'accès

C Accès en consultation

O Accès en modification

Par défaut, tous les écrans sont accessibles en modification.

21 Ecran 020 Offre

22 Ecran 030 Architecture automatique

23 Ecran 035 Architecture étudiée

24 Ecran 039 Consommables génériques

25 Ecran 040 Pointages

26 Ecran 045 Impression

27 Ecran 046 Pré-Impression

28 Ecran 047 Couleurs

29 Ecran 048 Conditionnement

30 Ecran 049 Accessoires

31 Ecran 050 Gamme de fabrication

32 Ecran 060 Liste des actions de service

33 Ecran 070 Détail

34 Ecran 080 Prix devis

ACHETEUR_CMD

21,23 Acheteur par défaut

Ce paramètre est utilisé par le programme de saisie de commandes fournisseurs.

Il existe aussi la note SIGNATAIRE_CMD pour le signataire par défaut.

AFFICHE_NO_MESSAGE

21 Affichage du numéro de message (msg_ident) dans les message (O/N, O par défaut)

AFFICHE_UNITE_QTE

21 Afficher l'unité de quantité sur les écrans suivants (O/N, N par défaut) :

- Saisie des bons de réception (voir la note FORMAT_QUANTITE)

- Visualisation des stocks disponibles

- Visualisation des stocks lots/lieux

ATR_CDE_ENVOI

Envoi de messages d'alerte de traçabilité

Il y aura autant de tâches qui seront exécutées en parallèle par le système que de lignes de type ATR_CDE_ENVOI paramétrées.

21, 59 Commande à exécuter - 2 possibilités : (1) Unix - (2) Windows

Les mots clés disponibles sont les suivants :

FIC Chemin complet du fichier contenant le message

AEM Adresse email du destinataire

R Répertoire Unix contenant le fichier généré

B Corps du message

D Destinataire

E Emetteur

O Objet

P Pièce jointe

1) Commande shell UNIX

Exemples

lp –dimp01 %FIC%

cp %FIC% ./user/tmp/pm/%FIC%

envoi_mail_unix %FIC% %AEM%

2) Commande windows

Exemple

blat.bat %R% %B% %D% %E% %O% %P%

60 Code envoi pour utilisation FAXMAIL (spoolfax) (facultatif pour les autres commandes)

M Mail

X FAX

W Script Windows

ATR_DEST

Envoi de messages d'alerte de traçabilité

Utile uniquement si utilisation de la solution VoluFaxMail

21, 60 Nom ou liste de noms devant figurer sur le message (pour fax principalement)

ATR_EMAIL

Envoi de messages d'alerte de traçabilité

Utile uniquement si utilisation de la solution VoluFaxMail

21, 60 Adresse e-mail du destinataire

ATR_FAX

Envoi de messages d'alerte de traçabilité

Utile uniquement si utilisation de la solution VoluFaxMail

21, 60 Numéro de fax du destinataire

ATR_MAIL

21,60 Adresse e-mail de l'émetteur

Utilisé par #LP pour une impression e-mail via AVM.

ATR_MSG_XXX

où XXX = code événement de type ATR

Envoi de messages d'alerte de traçabilité

21, 60 Paramétrage du message personnalisé pour ce destinataire

Ce message a priorité sur (et se paramètre de la manière que) le message par défaut décrit dans les notes ATR_MSG sur le paramètre de type ATR.

ATR_REP_ENVOI

21,60 Répertoire contenant le script windows

L:/Installation/Utilitaires/blat

AUTORISAT_ACC_TR_VAL

Notes d'autorisation d'accès au champ tr_val dans la saisie des tarifs standard ou simplifiée

L'autorisation d'accès dépend du couple code tarif-type de tarif.

Si la note n'est pas présente, l'accès est autorisé.

21,23 Code tarif (tr_tar de la table tar0 - Paramètre TAR). Obligatoire. Exemple #CE

24,26 Type tarif (tr_cat de la table tar0- Paramètre ETI ou autre). Obligatoire. Exemple STD

27 Permission (N/O). Obligatoire. Pas de valeur par défaut

N Accès non autorisé

O Accès autorisé

AUTORISAT_MOD_TR_VAL

Notes d'autorisation de modification du champ tr_val dans la saisie des tarifs standard ou simplifiée

L'autorisation de modification dépend du couple code tarif-type de tarif.

Si la note n'est pas présente, la modification est autorisée.

21,23 Code tarif (tr_tar de la table tar0 - Paramètre TAR). Obligatoire. Exemple #CE

24,26 Type tarif (tr_cat de la table tar0- Paramètre ETI ou autre). Obligatoire. Exemple STD

27 Permission (N/O). Obligatoire. Pas de valeur par défaut

N Modification non autorisée

O Modification autorisée

AUTORISE_CONTROL_J

21 Autorisation de la touche CONTROL-J (lancements de programmes) (O/N, N par défaut)

Si cette note n'est pas trouvée ici, elle sera recherchée sur le #CF ATL.

CHEMIN_GDC

Chemin d'installation du client graphique GENERO sur le poste client

Les \ doivent être doublés.

Exemple : c:\\program files\\fourjs\\gdc (c'est la valeur par défaut)

Si l'applicatif 3.50 est hébergé sur un serveur Windows, il faut saisir le chemin avec les noms courts et sans doubler les \.

Exemple : d:\progra~1\fourjs\gdc

Ce paramètre est utilisé par le programme lancement_pgm_genero

CHX_SOC_PROG_OUVERT

Accès à l'écran de sélection des sociétés lorsqu'un programme est ouvert

O Accès toujours autorisé

C Accès autorisé sur confirmation

N Accès interdit

Par défaut : Ce paramétrage est récupéré sur le #CF ATL.

DROIT_ACCES_CL_PARAM

Accès paramétrables des zones du cl_param

21,22 Numéro du cl_param (de 1 à 21)

23 Visibilité de la zone

O Zone visible et accessible (par défaut)

N Zone cachée

C Zone visible mais non accessible (consultation)

On peut contrôler l'accès à chaque zone du cl_param.

Par défaut, toutes les zones sont visibles et accessibles.

Le paramétrage est recherché en priorité sur le user (USE XXX où xxx est le code utilisateur).

Si au moins une ligne de paramétrage concernant l'accès aux zones du cl_param est trouvée, alors les permissions sont prises sur l'utilisateur.

Si aucun paramétrage n'est trouvé sur l'utilisateur, on va lire le paramétrage sur la configuration de la fiche tiers (#CF CLI ou autre).

Si vous paramétrez des notes à la fois sur le USE et sur le #CF CLI, seules celles du USE seront prises en compte.

DROIT_ACCES_M0_ACTIF

21 Accès à la zone N° ordre dans la saisie des machines (O/N, N par défaut)

DROIT_ACCES_M0_ORDRE

21 Accès à la zone Actif dans la saisie des machines (O/N, N par défaut)

DROIT_ACCES_MP_PARAM

Accès paramétrables des zones du mp_param

21,22 Numéro du mp_param (de 1 à 46)

23 Visibilité de la zone

O Zone visible et accessible (par défaut)

N Zone cachée

C Zone visible mais non accessible (consultation)

On peut contrôler l'accès à chaque zone du mp_param.

Par défaut, toutes les zones sont visibles et accessibles.

Le paramétrage est recherché en priorité sur le user (USE XXX où xxx est le code utilisateur).

Si au moins une ligne de paramétrage concernant l'accès aux zones du mp_param est trouvée, alors les permissions sont prises sur l'utilisateur.

Si aucun paramétrage n'est trouvé sur l'utilisateur, on va lire le paramétrage sur la configuration de la fiche matière (#CF MAT ou autre).

Si vous paramétrez des notes à la fois sur le USE et sur le #CF MAT, seules celles du USE seront prises en compte.

DROIT_ACCES_P2_ACTIF

21 Accès à la zone Actif dans la saisie des paramètres (O/N, N par défaut)

Voir la fiche d'installation des nouvelles zones de la table par02

DROIT_ACCES_P2_CLASS

21 Accès au groupe de saisie de la classe dans la saisie des paramètres (O/N, N par défaut)

Voir la fiche d'installation des nouvelles zones de la table par02

FABRICANT_DEV

21,23 Code fabricant par défaut pour la saisie du devis multi-métiers <VF>

GROUPE_TSC

Code d'appartenance de l'utilisateur à un groupe de saisie de TSC >

Une seule note GROUPE_TSC ar paramètre USE.

Exemples

DEV (Devis)

ASS (Assistantes)

Voir la note ACCES_ZONE_ sur le paramètre TSC

LCT_PROG_ANOMALIES

Dans la fenêtre de sélection des lancements de programmes (Control-J), affichage des lignes avec argument en anomalie ou non trouvé

T Avec affichage des lignes avec argument en anomalie ou non trouvé (par défaut)

N Avec affichage des lignes avec argument non trouvé uniquement

A Avec affichage des lignes avec argument en anomalie uniquement

X Sans affichage des lignes avec argument en anomalie ou non trouvé

Ce paramètre existe aussi au niveau du #CF ATL mais il est prioritaire ici.

LCT_MULTI_ANOMALIES

Dans la fenêtre de sélection des lancements multi-sélections (Control-K), affichage des lignes avec argument en anomalie ou non trouvé

T Avec affichage des lignes avec argument en anomalie ou non trouvé (par défaut)

N Avec affichage des lignes avec argument non trouvé uniquement

A Avec affichage des lignes avec argument en anomalie uniquement

X Sans affichage des lignes avec argument en anomalie ou non trouvé

Ce paramètre existe aussi au niveau du #CF ATL mais il est prioritaire ici.

MENU_XXXXXXXXXX

Les notes suivantes sont destinées au nouveau menu général.

Si ces notes ne sont pas trouvées ici, elle seront recherchées sur le #CF ATL.

Le nouveau menu général stocke l'arborescence dans des tables, en lieu et place des fichiers textes utilisés auparavant.

Un outil de conversion est lancé automatiquement à la mise à jour afin d'intégrer ces dits fichiers.

Le nouveau menu général se compose de trois modes :

• Le mode par défaut Visualisation est celui auquel tous les utilisateurs ont accès au démarrage, permettant d'exécuter des programmes et lignes de commandes système.

• Le mode Construction, accessible uniquement aux utilisateurs habilités (permission), permet de construire les menus des utilisateurs (chaque entrée au menu pouvant être habilitée pour un ou plusieurs groupes et/ou pour un ou plusieurs utilisateurs).

• Le mode Test, accessible uniquement à partir du mode Construction, permet de tester le menu pour chaque utilisateur.

Le nouveau menu général nécessite GENERO en version 2.30 minimum.

Les modalités de mise en oeuvre de ce menu sont décrite dans le document Nouveau menu général.

Paramétrage

Permissions pour le mode Construction : MEN_CONSTRUIRE / MEN_CRE_ENTREE / MEN_SUP_ENTREE

USE A1[12,14] Code langue normalisé ISO

USE note AUTORISE_CONTROL_J

MENU_BOUTONS_PERSO

21 Affichage des boutons personnalisés dans la barre des boutons du menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_DEPROTECTION

21 Autorisation d'accès à la fonction Déprotection des tables (Control-Shift-D) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_DP_FACEBOOK

21 Autorisation de lancement du navigateur pour l'accès à la page Facebook de Direct Planning (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_DP_SITE_WEB

21 Autorisation de lancement du navigateur pour l'accès au site Internet de Direct Planning (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_DP_TWITTER

21 Autorisation de lancement du navigateur pour l'accès à la page Twitter de Direct Planning (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_ENVELOPPE

21 Autorisation d'accès à la fonction Enveloppes projet (Control-Shift-E) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_EXTRANET_VF

21 Affichage d'un lien vers l'extranet dans le bloc supérieur du menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_LANGUE_DEFAUT

Code langue par défaut à utiliser pour les libellés des menus (et uniquement ceux-ci)

Par défaut : fr

IMPORTANT : Le code langue par défaut pour les autres libellés affichés dans VoluPack (actions, messages, etc.) reste le code langue secondaire (#CF ATL A1[37,38]).

Cette note est prioritaire sur celle du #CF ATL.

MENU_NOTES_ENVIRON

Permettre de saisir et d'afficher les notes société du menu général par environnement.

N La saisie (si autorisée) et l'affichage des notes se feront globalement pour cet utilisateur (par défaut).

O La saisie (si autorisée) et l'affichage des notes se feront par rapport à l'environnement courant pour cet utilisateur.

S La saisie (si autorisée) des notes se fera par sélection de l'environnement.
L'affichage des notes se fera par rapport à l'environnement courant pour cet utilisateur.

Cette note existe aussi sur le #CF ATL. Elle est prioritaire ici (sur le USE).

Remarques

• Les notes affichées sur le menu sont uniquement celles saisies sur l'environnement courant

• Le paramétrage d'autorisation de saisie des notes est indépendant du paramétrage décrit sur cette fiche (note MENU_NOTES_SOCIETE ci-dessous)

• L'environnement global (société) correspond au fonctionnement actuel (les notes saisies sont affichées pour tous les utilisateurs indépendamment de l'environnement)

• Rappel : L'environnement par défaut est l'environnement réel (n°0)

MENU_NOTES_SOCIETE

21 Autorisation d'accès à la fonction Notes société (Control-N) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_PARAMETRE

21 Autorisation d'accès à la fonction Paramétrage (Control-P) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

O L'accès au paramétrage est possible sur toutes les entrées du menu.
S'il s'agit d'une entrée liée à un paramètre de lancement, la saisie se fera sur celui-ci uniquement.
S'il s'agit d'un autre type d'entrée (dossier ou ligne de commande), la saisie sera libre.

N L'accès au paramétrage n'est possible que pour les entrées liées à un paramètre de lancement.
La saisie se fera sur celui-ci uniquement.

I L'accès au paramétrage est interdit dans tous les cas (le bouton n'est pas affiché)

MENU_PERMISSIONS

21 Autorisation d'accès à la fonction Gestion des permissions (Control-Shift-P) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_REQUETEUR

21 Autorisation d'accès à la fonction Requêteur (Control-Shift-R) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_SELECTION_USER

21 Autorisation d'accès à la fonction de sélection de l'utilisateur courant (O/N, N par défaut)

Permet de sélectionner l'utilisateur courant sur le menu général.

Remarques :

• Le paramétrage d'autorisation de sélection de l'utilisateur courant n'est lu que pour l'utilisateur d'origine (celui qui a démarré le menu VoluPack/VoluPrim).

• Une fois le choix de l'utilisateur validé, le menu se recharge afin d'afficher son propre menu :

o La sélection de l'utilisateur courant reste activée (même si le nouvel utilisateur courant n'est pas autorisé).

o Il est possible via le menu des actions de retourner immédiatement à l'utilisateur d'origine (voir ci-dessous).

o IMPORTANT : Tous les programmes sont exécutés avec les informations du nouvel utilisateur courant (selon les autorisations, permissions ou autre paramétrage spécifique, certains programmes peuvent donc ne pas être accessibles).

Cette note est également disponible dans le #CF ATL.

MENU_SUP_SQL_USER

21,60 Complément de sélection des utilisateurs pouvant être sélectionnés.

Ce paramétrage est lié à la note commençant par MENU_SELECTION_USER ci-dessus.

Cette note est également disponible dans le #CF ATL.

MENU_SYSTEME

21 Autorisation d'accès à la fonction Système (Control-Shift-S) sur le menu (O/N, N par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_TEMPS_BOUCLE

21,23 Nombre de secondes entre 2 vérifications des modifications apportées à la fenêtre du menu

Voir plus haut le paragraphe sur les notes commençant par MENU.

Par défaut : 60 secondes

Les vérifications effectuées concernent :

• Les messages à l'attention des utilisateurs
Dans ce cas, le nouveau message s'affiche automatiquement.

• Une modification de paramétrage d'un modèle de style (STY) ou de l'utilisateur courant (USE/xxx).
Dans ce cas, l'icône de rechargement du menu est modifié, indiquant que le rechargement doit être fait manuellement.

Remarques :

• Mettre 0 (zéro) pour désactiver ce fonctionnement.
a mise à jour devra alors être faite manuellement via le bouton de rechargement.

• Il s'agit ici d'un temps d'inactivité sur le menu. N.B. : Lorsque le menu est ouvert et que l'utilisateur est dans un autre programme que le menu, le système considère que le menu est inactif (la vérification des modifications est donc active).

MENU_VSW_EMAIL

21 Autorisation de lancement du client de messagerie pour créer un email à destination de Volume Software (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_VSW_FACEBOOK

21 Autorisation de lancement du navigateur pour l'accès à la page Facebook de Volume Software (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_VSW_SITE_WEB

21 Autorisation de lancement du navigateur pour l'accès au site Internet de Volume Software (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MENU_VSW_TWITTER

21 Autorisation de lancement du navigateur pour l'accès à la page Twitter de Volume Software (O/N, O par défaut)

Voir plus haut le paragraphe sur les notes commençant par MENU.

MOD_ETAT_DEVIS_AUT

Autorisation de modification de l'état d'un devis - Voir A2[27]

21,23 Code actuel d'état du devis

24,26 Nouveau code autorisé d'état du devis

MOD_ETAT_DEVIS_INT

Autorisation de modification de l'état d'un devis - Voir A2[27]

21,23 Code actuel d'état du devis

24,26 Nouveau code interdit d'état du devis

MOD_ETAT_DEVIS_xxx

Remarques

• Les modifications d'états non autorisées sont interdites par défaut.

• Les modifications d'états non interdites sont autorisées par défaut.

• Les modifications d'états interdites sont prioritaires par rapport aux modifications autorisées.

• Le code actuel paramétré peut être à blanc, il s'agit dans ce cas d'autoriser et/ou d'interdire une initialisation de l'état.

• Le nouveau code paramétré peut être à blanc, il s'agit dans ce cas d'autoriser et/ou d'interdire une réinitialisation de l'état.

• Par défaut, si aucune note n'est paramétrée (autorisations/interdictions), toutes les modifications sont autorisées.

Voir quelques exemples en bas de page.

MODIF_AUTORISEE_

Permettre de limiter l'accès aux devis d'un (ou plusieurs) site(s) aux seuls utilisateurs autorisés sur ce(s) site(s)

• Si cette note n'est pas créée, aucun contrôle n'est effectué, l'utilisateur peut accéder à tous les devis de tous les sites.

• Si au moins une note est créée, l'utilisateur ne peut accéder qu'aux devis ayant fait l'objet d'une création dans les sites pour lesquels il est autorisé.

• Si un devis n'a pas de site créateur, aucun contrôle n'est effectué, tous les utilisateurs peuvent y accéder.

• Un utilisateur est toujours autorisé à accéder à un devis créé dans son site de production d'appartenance.

Voir aussi A3[10,12]

17,19 Identifiant du programme appelant

DEV Saisie des devis

CDE Saisie des commandes clients

21,23 Code site de production créateur pour lequel l'utilisateur est autorisé à accéder au devis.

Doit correspondre à un paramètre de type SIT.

Une ligne de paramétrage par code site de production autorisé.

Voir exemples en bas de page.

Tableau de bord du multisite

NB_SESSIONS_VALIDES

21,23 Nombre de sessions autorisées en simultané. Par défaut 1

Mettre 'MAX' pour un nombre de sessions illimité.

Il existe actuellement plusieurs possibilités de paramétrage permettant de limiter le nombre de programmes lancés par un utilisateur (cf paramètre de type USE, caractère 36 et caractères 37 à 387 de la zone alpha 3).

Pour contourner ce contrôle, certains utilisateurs ont pris l'habitude de lancer plusieurs sessions. Le but de ce fonctionnement est donc de contrôler qu'un même utilisateur ne peut lancer qu'un certain nombre de menus (par défaut 1 seul).

Autres éléments techniques

PRIORITE A GENERO ACTIVEE

Active le lancement des programmes GENERO correspondants, s'ils existent

Attention : pour utiliser cette possibilité, il faut retirer cette note du paramètre #CF ATL.

PWD_TOL_QTE_ENT_STK

Tolérances des quantités fabriquées sur tolérance de la ligne de FBI

Plus de détails sur cette fonction dans la note PCT_TOL_QTE_ENT_STK du paramètre TOL.

21,23 Code mot de passe associé au contrôle de quantité produite : pourcentage de dépassement de fabrication par rapport au commandé
Ce code définit que l'utilisateur fait partie de la liste des utilisateurs pouvant forcer la quantité produite (dépassement) dans la déclaration de production

24 inutilisé

25,27 Code mot de passe associé au contrôle de quantité produite : pourcentage de manque de fabrication par rapport au commandé
Ce code définit que l'utilisateur fait partie de la liste des utilisateurs pouvant forcer la quantité produite (manque) dans la déclaration de production

REPBUD

Permet de paramétrer la liste des représentants pour lesquels l'utilisateur est autorisé à saisir le budget

7 à 9 Code du représentant pour lequel l'utilisateur peut saisir des lignes de budget

Vous pouvez indiquer autant de lignes REPBUD que vous le souhaitez

Exemples

REPBUDW35

REPBUDW78

Remarque : Vous pouvez indiquer REPBUD* si un utilisateur est autorisé à saisir pour n'importe quel représentant

RUN

4, 6 Code autorisé dans le Ctrl Z de l'utilisateur. Par exemple : USE CDE

Plusieurs notes commençant par RUN peuvent cohabiter.

Voir les paramètres de type RUN

Ces notes ne sont lues que si alpha2[1] = R.

S_

Complément de sélection par utilisateur

3,5 Type du paramètre de lancement de la visualisation sur laquelle s'applique le complément de sélection

6,8 Code du paramètre de lancement de la visualisation sur laquelle s'applique le complément de sélection

21,60 Complément de sélection à appliquer dans la visualisation

SECTEUR_ACHAT_AUT

21 à 60 Codes (00 à 99) du secteur achats autorisés.

Plusieurs codes (sur 2 caractères) peuvent êtres concaténés.

Exemple : 010608 autorise les secteurs 01, 06 et 08

Remarque : les autres codes secteurs sont alors interdits à l'utilisateur concerné.

SECTEUR_ACHAT_PDF

21 à 22 Code (00 à 99) du secteur achats par défaut

SIGNATAIRE_CMD

21,23 Signataire par défaut

Ce paramètre est utilisé par le programme de saisie de commandes fournisseurs.

Il existe aussi la note ACHETEUR_CMD pour l'acheteur par défaut.

SOLDE_DESOLDE

21 Autorisation de solder / désolder une ligne de commande

O Oui

N Non (par défaut)

W Warning

C Avec confirmation

22,26 Mot de passe si caractère 21 est égal à W

ATTENTION : il s'agit d'une note très spécifique qui n'est prise en compte que pour les commandes Calendrier

_SUP_ORDER_SOCIETE

21,60 Complément d'ordre de tri pour le choix des sociétés sur le menu VoluPack

Exemple _SUP_ORDER_SOCIETE order by so_code (ne pas oublier de rajouter le order by).

Cette note a priorité sur celle du #CF ATL.

_SUP_REQ_LIEU_RGT1

21,60 Complément de sélection sur par02, pour la restriction sur les lieux intermédiaires autorisés

Cette note vient en complément de celle du paramètre de lancement de blv et de bon_de_retour.

_SUP_REQ_LIEU_RGT_E

21,60 Complément de select sur la table lieu_rgt_e permettant de récupérer la liste des lieux autorisés

Permet de limiter les lieux utilisés dans les programmes concernant les stocks en fonction du user.

Cette note existe aussi dans les programmes stk0, v_stk0, maj_stk, s_bob, qte_prod où elle est prioritaire.

_SUP_REQ_SOCIETE

21,60 Complément de requête sur la table société

Permet, en fonction de l'utilisateur, de restreindre la liste de toutes les sociétés de la base.

Cela sert notamment lors de la recopie de produit inter-société.

_SUP_SQL_SITE

21,60 Complément de sélection sur la table des paramètres (par02, type de paramètre SIT) des sites d'appartenance autorisés pour l'utilisateur

Exemple

and p2_code in ('TOU','LYO')

Important : La présence de cette note conditionne l'affichage du bouton Site sur le menu VoluPack

Pour afficher le bouton de sélection dans le cas où l'utilisateur est autorisé pour tous les sites, ajouter le complément de sélection suivant : and 1=1

Tableau de bord du multisite

_SUP_SQL_SOCIETE

21,60 Complément de sélection pour le choix des sociétés sur le menu VoluPack

Cette note a priorité sur celle du #CF ATL.

TYP_AIDE_LIGNE

21,60 Type de l'aide en ligne (paramètre AID)

* (astérisque) signifie que l'on peut voir tous les types d'aide

Voir la page dédiée

TYPE_CONNECTION

21,26 Type de connexion

TSE si les clients graphiques sont sur un serveur Windows TSE

LOCALE si les clients graphiques sont installés sur le poste utilisateur (par défaut)

Cette note n'est pas utilisable sous GENERO.

Une session est actuellement définie selon 3 critères :

Présence du code société (Par défaut : Non)

Identifiant de l'utilisateur (par défaut, sur Windows : nom du compte ; sur Unix : Adresse IP du poste)

Version du runner (Par défaut : Non)

Je précise par défaut car il est possible de forcer ces valeurs en initialisant un code dans la zone p1_cat de l'enregistrement de par01 de type vsw (Rappel : Cet enregistrement contient le numéro de version de la base de données dans la zones p1_lib – Attention à ne pas perdre cette information).

Codification possible du p1_cat :

Caractère 1 : Prise en compte de la version du runner (uniquement pour tester des différences entre 2 environnements)

0 : Version du runner non prise en compte [valeur par défaut]

1 : Version du runner intégrée dans la clé session

Caractère 2 : Identifiant de l'utilisateur

0 : Adresse IP + Numéro du port GDC

1 : Adresse IP seule [valeur par défaut pour les serveurs Unix et Linux]

2 : Nom du compte utilisateur (login) [valeur par défaut pour les serveurs Windows]

3 : Numéro de session TSE

Caractère 3 : Prise en compte du code société (uniquement si multi-sociétés avec menus spécifiques par société)

0 : Le code société n'est pas pris en compte [valeur par défaut].

1 : Le code société est intégré dans la clé session.

Note | 21,23 | 24,26 | Explication
MOD_ETAT_DEVIS_AUT |  | DAC | L'utilisateur est autorisé à initialiser l'état du devis avec la valeur DAC (devis à calculer).
MOD_ETAT_DEVIS_AUT | DAC | DVD | L'utilisateur peut modifier l'état du devis de la valeur DAC (devis à calculer) à la valeur DVD (devis validé par le deviseur).
MOD_ETAT_DEVIS_INT | TRF |  | L'utilisateur ne peut pas réinitialiser l'état du devis si celui-ci est à la valeur TRF (devis transféré).

Exemples d'utilisation de la note MODIF_AUTORISEE_

L'utilisateur AAA appartient au site 001.

L'utilisateur BBB appartient au site 002.

L'utilisateur CCC appartient au site 003.

Sur l'utilisateur AAA, on crée 2 notes pour indiquer qu'il peut accéder aux devis créés pour les sites 002 et 004.

MODIF_AUTORISEE_DEV 002

MODIF_AUTORISEE_DEV 004

... et 2 autres notes pour indiquer qu'il peut accéder aux commandes créées pour les sites 002 et 004.

MODIF_AUTORISEE_CDE 002

MODIF_AUTORISEE_CDE 004

Sur l'utilisateur BBB, on crée une note pour indiquer qu'il peut accéder aux devis créés pour le site 001...

MODIF_AUTORISEE_DEV 001

... et une autre note pour indiquer qu'il peut accéder aux commandes créées pour le site 001.

MODIF_AUTORISEE_CDE 001

Sur l'utilisateur CCC, on crée une note pour indiquer qu'il peut accéder aux devis créés pour le site 005...

MODIF_AUTORISEE_DEV 005

... et une autre note pour indiquer qu'il peut accéder aux commandes créées pour le site 005.

MODIF_AUTORISEE_CDE 005

Résultats :

Utilisateur AAA

Devis ou cde | Site créateur | OK ? | Explication
09040001 | 001 | oui | Le site créateur est celui de l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040002 | 002 | oui | Le site créateur fait partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040003 | 003 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040004 | 004 | oui | Le site créateur fait partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040005 | 005 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.

Utilisateur BBB

Devis ou cde | Site créateur | OK ? | Explication
09040001 | 001 | oui | Le site créateur fait partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040002 | 002 | oui | Le site créateur est celui de l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040003 | 003 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040004 | 004 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040005 | 005 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.

Utilisateur CCC

Devis ou cde | Site créateur | OK ? | Explication
09040001 | 001 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040002 | 002 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040003 | 003 | oui | Le site créateur est celui de l'utilisateur, l'accès au devis et aux commandes est autorisé.
09040004 | 004 | non | Le site créateur ne fait pas partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est interdit.
09040005 | 005 | oui | Le site créateur fait partie de la liste des sites autorisés pour l'utilisateur, l'accès au devis et aux commandes est autorisé.

Notes pour les styles

A partir de la V.4.1.0.2 (GENERO 2.30), les notes suivantes sont périmées.

Pour accéder à l'aide à la saisie des paramètres de style :

  1. Allez dans la saisie des paramètres (par02)

  2. Type STY (ce type a été créé par Volume Software, il est donc dans votre base si vous avez fait la mise à jour).

  3. Code XXX (pour créer un modèle de style personnalisé pour cet utilisateur).

  4. Faites F8 pour accéder à la fenêtre d'aide à la saisie des notes de paramétrage

  5. Revenez sur l'utilisateur (USE) : créez une nouvelle note en tapant STYLE. (n'oubliez pas le point) et faites F8: la fenêtre d'aide à la saisie des notes de paramétrage vous permet alors d'affecter à cet utilisateur le style XXX que vous venez de créer.

FENETRE_MAXIMISEE | 21 Ouverture écran en mode plein écran (O/N, N par défaut) Il est nécessaire de réinitialiser le Client GDC la première fois. Nécessite un GDC 1.33.1n Cette note est prioritaire sur celle du #CF 4JS.
STYLE_COULEUR_FOND | 21,60 Couleur de fond. Ce paramètre a priorité sur celui de #CF 4JS Cliquez ici pour voir / masquer les codes couleurs disponibles.
STYLE_COULEUR_TEXTE | 21,60 Couleur de texte. Ce paramètre a priorité sur celui de #CF 4JS Cliquez ici pour voir / masquer les codes couleurs disponibles.
STYLE_COUL_LG_ACTIVE | 21,60 Couleur de la ligne active dans les tableaux. Ce paramètre a priorité sur celui de #CF 4JS La liste des couleurs prédéfinies et la règle de priorité sont les mêmes que pour la note STYLE_COULEUR_FOND
STYLE_FONT | 21,60 Nom de la police d'affichage. Si cette note n'est pas trouvée ici, elle est recherchée dans le #CF 4JS. Peuvent être utilisées toutes les polices du système qui héberge le GDC, en respectant minuscules et majuscules. Ex : Arial, Calibri, Times New Roman…
STYLE_FONTSIZE | 21,60 xxpt : Taille de la police demandée Si cette note n'est pas trouvée ici, elle est recherchée dans le #CF 4JS. La taille est exprimée en points, sur 2 caractères. Ex : 10pt, 09pt Exemple STYLE_FONTSIZE 10pt
STYLE_FONTSTYLE | 21,60 Style de la police d'affichage. Si cette note n'est pas trouvée ici, elle est recherchée dans le #CF 4JS. Les valeurs possibles sont les suivantes : light, normal, bold, demi-bold et black


UTR Unités tarif

Valeurs numériques

UTR N1

Nombre d'unités pour le tarif

Exemple : Si valeur 1 = 100 , le tarif est exprimé pour 100 unités.

Si zéro, c'est un forfait.


VAS Validité adresse secondaire

Contrôles :

O ou B Contrôle Bloquant

W Contrôle non bloquant (Warning)

N Pas de contrôle

Valeur alpha 1

VAS A1[1] | Adresse d'envoi de devis (O/B/W/N)
VAS A1[2] | Adresse d'envoi d'AR de commande (O/B/W)
VAS A1[3] | Adresse de livraison (O/B/W)
VAS A1[4] | Adresse de facturation (O/B/W)
VAS A1[5] | Contrôle du numéro de TVA (O/N) - Voir aussi PAY A1[39]
VAS A1[6,8] | Correspondance utilisée pour le transfert des tiers JDE Par défaut , il sera indiqué C pour client, V pour fournisseur.
VAS A1[9] | Correspondance utilisée pour le transfert des tiers JDE F Adresse de Livraison B Adresse de Facturation (valeur par défaut) X Les deux <ou> Type d'adresse pour interface SIDE TRADE
VAS A1[10,16] | Correspondance utilisée pour le transfert des tiers JDE. Valeur par défaut : B
VAS A1[17] | Saisie obligatoire du numéro d'ID TVA intracommunautaire (O/N, N par défaut) N'est utilisé que dans la saisie des adresses secondaires avec l'option -Oid
VAS A1[18] | Saisie du code établissement obligatoire dans le numéro d'identification TVA (O/N, O par défaut) Le même contrôle peut être paramétré au niveau du code pays (PAY A1[42]).

Valeur alpha 3

VAS A3[1,11] | Si cli contient l'option -Ocn, le paramétrage est lu ici, sinon il est lu dans #CF ATL alpha3[1,11].
VAS A3[1] | Numérotation automatique du code comptable CLIENT (O/N)
VAS A3[2,5] | Radical du code comptable par défaut (pour le client). Exemple : "411 "
VAS A3[6] | Numérotation automatique du code comptable FOURNISSEUR (O/N)
VAS A3[7,10] | Radical du code comptable par défaut (pour le fournisseur). Exemple : "401 "
VAS A3[11] | Affectation du code comptable lors du passage d'un Prospect en Client (O/N). Le code comptable affecte sera alors généré selon le mode de fonctionnement de celui du client. Exemple : Si client avec code comptable en auto, alors code en auto (Radical du client par défaut). Si client avec code comptable en manuel,

Notes

#CC

Contrôle des champs dans la fiche tiers


VED Codes deviseurs

Il est recommandé que le code deviseur corresponde aux 3 premiers caractères de son login.

Valeur alpha 1

VED A1[1,30]

Numéro de téléphone (+ poste, etc.)

Valeur alpha 2

VED A2[1,60]

Adresse email du deviseur


VEH Véhicules

Ce paramètre est utilisé par le programme de saisie des BL pour restreindre la liste des véhicules à ceux qui sont associés au site de production sélectionné.

En absence de paramétrage, le véhicule n'est associé à aucun site et apparaîtra dans la liste de sélection (F7) quel que soit le site de production saisi.

Tableau de bord du multisite

Libellé long : Numéro d'immatriculation (code véhicule)

Valeur alpha 2

1,3 | Code site de production N° 1
4,6 | Code site de production N° 2
7,9 | Code site de production N° 3
10,12 | Code site de production N° 4
13,15 | Code site de production N° 5
16,18 | Code site de production N° 6
19,21 | Code site de production N° 7
22,24 | Code site de production N° 8
25,27 | Code site de production N° 9
28,30 | Code site de production N° 10


VER Types de vernis

Valeurs numériques

1 |
2 |
3 | Coefficient de vernissage (pourcentage) Permet d'initialiser automatiquement les coefficients de vernissage recto et/ou verso lors de la saisie d'un code vernis.
4 |

Valeur alpha 1

VER A1[1] | Filtre de recherche par type de vernis H Vernis hors ligne (HL) L Vernis en ligne (L) S Vernis sous-traitance (ST) 1 Vernis hors ligne et/ou en ligne (HL+L) 2 Vernis en ligne et/ou sous-traitance (L+ST) 3 Vernis hors ligne et/ou sous-traitance (HL+ST) I Vernis non affiché dans la fenêtre de recherche (ignoré) [Autre] Vernis hors ligne, en ligne et/ou sous-traitance (HL+L+ST) ATTENTION : la valeur 2 utilisée auparavant a changé de signification (elle correspond maintenant à la valeur 1).
VER A1[2,16] | Code article correspondant
VER A1[17] | Type de vernis A Acrylique O Offset (par défaut) U UV
VER A1[18,20] | Nature de difficulté du vernis (NON par défaut : pas de vernis) Voir aussi SFM A1[7,9] et FAM A1[42,44]
VER A1[21] | Vernis simple ou multiple 1 Vernis simple (par défaut) 2 Vernis multiple (double)
VER A1[22,36] | Code article correspondant au deuxième verni
VER A1[37] | Type du second vernis A Acrylique O Offset (par défaut) U UV
VER A1[38,40] | Nature de difficulté du second vernis (NON par défaut : pas de second vernis) Voir aussi SFM A1[7,9] et FAM A1[42,44] (famille/sous-famille de l'article correspondant au second vernis)
VER A1[41,43] | Difficulté de la refente due au vernis. On classifie les vernis selon leur impact sur l'opération de refente ou de massicot.
VER A1[44,46] | Classe de devis pour le contrôle des minimums de grammage selon le type de vernis et la présence R°, V° et R°V°. On distingue principalement les classes de contrôle OFF-ACR-UV-REP
VER A1[47,49] | Nature de difficulté selon le type d'encre (pour formule figée OIMF68 et OIMF69)

Valeur alpha 2

VER A2[1,15] | Code plaque –code blanchet associé au vernis 1 Ces variables sont rendues disponibles dans le devis par le code calcul VA (VA7.., VA8.., VAF.. , VAG..)
VER A1[16,30] | Code plaque –code blanchet associé au vernis 2 Ces variables sont rendues disponibles dans le devis par le code calcul VA (VA7.., VA8.., VAF.. , VAG..)

Notes

_TYPE_DE_FINITION

21,23 Type de finition associé à ce vernis

Une ligne de note par type de finition associé à ce vernis

Si aucune note n'est présente, on considère que le vernis est autorisé pour tous les types de finition.


VRC Visa de conformité de la réclamation

Pas de paramétrage


WIN Lancement de programmes Windows

Valeur alpha 1

WIN A1[1,3]

Extension du document. Par exemple : doc (ne pas mettre le point)

WIN A1[4]

Attente de la fin d'exécution

W L'écran VoluPack est inaccessible tant que le document demandé est ouvert.

[blanc] Aucun attente, VoluPack est immédiatement accessible.

WIN A1[5]

L'option paramétrée dans la note OPTIONS_PROG doit être située avant le nom du document à l'exécution (O/N, N par défaut) Voir #RP

Exemple avec l'option paramétrée dans les notes /p

O programme.exe /p nom_du_document.ext

N programme.exe nom_du_document.ext /p

WIN A1[6]

Gestion des backslashes présents dans les arguments (1, 2, 3 ou 4)

Il est possible d'exécuter sous VoluPack des programmes Windows (exemple : mspaint.exe) en lui passant des arguments.

Généralement, ces arguments contiennent le caractère particulier \

Pour que le programme Windows reçoive cet argument correctement, il est nécessaire de modifier la chaîne paramétrée; mais après différents tests, il s'avère qu'il n'y a pas de solution uniques.

Le but de ce nouveau paramétrage est donc de proposer 4 méthodes imposées de gestion de ce caractère dans le cas où la méthode par défaut ne fonctionne pas :

Méthode 1 : On double le caractère à chaque fois qu'on le rencontre

Méthode 2 : On applique 2 fois la boucle de duplication du caractère (ce qui fait qu'on quadruple chaque occurrence du caractère)

Méthode 3 : On ajoute un \ avant chaque série présente du caractère

Méthode 4 : On ajoute un \ avant chaque série présente du caractère;
puis on double chaque occurrence du caractère.

WIN A1[7]

Pour la gestion d'envoi des mails par script

Le script est sur le serveur (O/N, N par défaut)

WIN A1[8]

Pour la gestion d'envoi des mails par script

Doit-on mettre des guillemets sur les arguments passés (O/N, O par défaut)

Valeur alpha 2

WIN A2[1,60]

Nom complet (avec chemin d'accès) du programme à exécuter Voir #RP

Attention, pour l'utilisation de Word et d'Excel, le nom du répertoire ne doit pas contenir de blanc ou d'espace.

Exemples

C:/Documents incorrects/ (pas d'espace ou de blanc)

C:/Documents_corrects/ OK

Valeur alpha 3

WIN A3[1,60]

Répertoire du document

On peut ajouter en variable %1 le code client et en variable %2 le code produit.

Mais si le nom réel du document est le contenu du TSC, alors, on ajoute un double "/" pour le séparer des variables %1 et %2

Exemples

Paramétrage 1 : Code article PF-001, client VSW, contenu TSC = blanc, type fichier = PDF

Le système ouvre un fichier PF-001.pdf contenu dans un répertoire qui est le nom du client :

D\images\VSW\PF-001.pdf

D:\images\%1\%2

Paramétrage 2 : Code article PF-001, client VSW, contenu TSC = CDC123 , type fichier = PDF

Le système ouvre un fichier CDC123.PDF qui est dans le répertoire client VSW et sous-répertoire PF-001 : d:\images\VSW\PF-001\CDC123.pdf

D:\images\%1\%2\\

Voir TSC A1[1,4]

Valeur alpha 4

WIN A4[1,60]

Uniquement si émulateur TUN et non 4Js :

echo "\033\033X\"

Notes

ARGUMENTS_SCRIPT

Paramètre d'envoi du script gestion des mails

21,23 Tag à passer au script (dépend du script) Exemple : -s, -t, …

25,60 Zone à passer au script (élément de la table envoi_fax_email

- Nom de zone entre crochets. Exemple : [efe_email_destinataire]
Lors de l'envoi, on passe en argument l'email du destinataire.

- [efe_objet] : on passe en argument le nom du fichier contenant l'objet entre 2 quotes.

- [pays_facturation] : langue de facturation (code langue de l'adresse de facturation sur l'entête de commande ou l‘entête de facture selon le type de document <VF>

Voir la gestion d'envoi de mails via des scripts.

DOCUMENT

21,60 Nom du document à ouvrir (sans extension, celle de la valeur alpha 1 sera automatiquement ajoutée).

ATTENTION : Cette ligne de note n'est prise en compte que s'il n'y a pas d'argument lors de l'appel du document (ce qui est le cas lors de l'appel direct par le menu).

Plusieurs lignes de notes sont possibles (si le nom du document est trop long), les lignes sont concaténées les unes aux autres (bien sûr elles doivent toutes commencer par DOCUMENT...)

Si le caractère 21 de cette note est % (pourcent), alors le programme demandera une saisie interactive dont la question sera le reste de la ligne de note concernée.

EXECUTABLE

21,60 Complément au chemin d'accès à l'exécutable paramétré dans la zone alpha 2 Voir #RP

Les 2 valeurs (zone alpha 2 et notes) seront concaténées.

OPTIONS_PROG

Options à ajouter au programme (passées à la ligne de commande à exécuter après l'extension) Voir #RP

Exemples

Programme | Code WIN | alpha1[1,3] | alpha2 | alpha3 | alpha4
PICVISU | PVI | des | picview -f | c:\demo\picador\ecma\ | echo "\033\033X\"
PICPARAM | PPA |  | picparam -e | d:\picador\ | echo "\033\033X\"
Calculatrice #CF ATL A1[1] | CLC |  | calc |  |
MaxLoad | MXL | exe | C:\Program Files\TOPSAPPS\Max2Demo\ |  |
MS-Word | WOR | doc | winword |  | echo "\033\033X\"
MS-Excel | XLS |  | D:\Program Files\Microsoft Office\Office\Excel.exe | E:\temp |


ZHx Zone historique du prix de revient

où x peut prendre la valeur alpha2[1] de pr_hi

Valeur alpha 1

ZHx A1[1,8]

Centre de coût

Il est utilisé dans l'édition des prix de revient pour la mise à jour de l'historique de type B

(contrôle budgétaire)(spécifique)


TSC #AF Affacturage

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Effective à partir du
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Code affacturage
G | ic_char30 |
H | ic_char3_2 | Type d'affacturage N pas d'affacturage O sans réédition de facture F avec réédition de facture


TSC #FR Commande de fabrication par référence

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.170.2

TSC de type F (clients)

Il est utilisé dans le cadre de la gestion des commandes de fabrication par référence.

Paramétrage figé :

ZFCde de frais ? N01.ON2 CREER CDE FRAISfr

Création d'une commande de frais indépendante pour ce code client lors de la création des commandes de fabrication par référence (O/N)


TSC #LG Transfert logistique

Ce TSC est opérationnel à partir de la V. 4.1.23.2

Il utilisé par la revue de contrat en saisie de commande client.

Il permet de définir dans la revue de contrat une valeur par défaut à la case Transfert logistique en fonction de l'article de la ligne de commande.

Si la valeur ic_char3_1 est à O, la case est cochée, si elle est à N, elle est décochée.

La valeur par défaut définie par le TSC est prioritaire : si ce TSC n'existe pas ou si la valeur du champ ic_char3_1 est différente de O ou N, alors ce sont les règles précédentes qui sont appliquées.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Valeur par défaut de la case Transfert logistique dans la revue de contrat. O cochée N décochée
G | ic_char30 |
H | ic_char3_2 |


TSC #VD Valeurs de débord pour le conditionnement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.195.2

Il est utilisé dans le cadre de l'optimisation du conditionnement du devis onduleur.

Voir aussi le TSC #VR

ic_num1 | Paramétrage de saisie de la valeur de dépassement (débord) autorisé dans le sens de la longueur
ic_num2 | Paramétrage de saisie de la valeur de dépassement (débord) autorisé dans le sens de la largeur
ic_char3_1 | Paramétrage d'enregistrement de la sélection des valeurs à prendre en compte (paramétrage optionnel) D Valeurs par défaut M Valeurs machine C Valeurs client F Valeurs forcées

Cette information complémentaire est utilisée à la fois :

• Pour la saisie des valeurs de débord pour un couple client/adresse secondaire ou principale

• Pour l'enregistrement des valeurs forcées de débords pour un produit fini (conditionnement)

• Pour l'enregistrement de la sélection des valeurs à prendre en compte pour un produit fini (conditionnement)


TSC #VE Informations de version

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.170.2

Il est utilisé dans le cadre de la gestion des versions de produit.

Cette information complémentaire est créée automatiquement lors de la génération des versions de produits finis : elle est créée sur le nouveau produit généré (nouvelle version) et contient le produit d'origine (obsolète), la date de création de la TSC ainsi qu'un numéro de version incrémental.

A | ic_date1 | Date de création du TSC
C | ic_num1 | Numéro de version incrémental (voir exemple ci-dessous)
G | ic_char30 | Code du produit obsolète d'origine ayant entraîné la création d'une nouvelle version

Exemple de création de version (ordre chronologique)

Produit obsolète | Nouveau produit (version) | Contenu du TSC #VE sur le nouveau produit
PS1 | PS2 | Code origine : PS1 N° version : 1
PS2 | PS3 | Code origine : PS2 N° version : 2
PS3 | PS4 | Code origine : PS3 N° version : 3
... | ... | ...


TSC #VN Informations de version

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.170.2

Il est utilisé dans le cadre de la gestion des versions de produit.

Cette information complémentaire est créée automatiquement lors de la génération des versions de produits finis : elle est créée sur le produit d'origine (obsolète) et contient le nouveau produit, la date de création de la TSC.

A | ic_date1 | Date de création du TSC
G | ic_char30 | Code du nouveau produit (nouvelle version)

Exemple de création de version (ordre chronologique)

Produit obsolète | Nouveau produit (version) | Contenu de la TSC/#VN sur le produit d'origine (obsolète)
PS1 | PS2 | Nouveau produit : PS2
PS2 | PS3 | Nouveau produit : PS3
PS3 | PS4 | Nouveau produit : PS4
... | ... | ...


TSC #VR Valeurs de retrait pour le conditionnement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.195.2

Il est utilisé dans le cadre de l'optimisation du conditionnement du devis onduleur.

Voir aussi le TSC #VD

ic_num1 | Paramétrage de saisie de la valeur de retrait maximum autorisé dans le sens de la longueur
ic_num2 | Paramétrage de saisie de la valeur de retrait maximum autorisé dans le sens de la largeur

Cette information complémentaire est utilisée à la fois :

• Pour la saisie des valeurs de retraits pour un couple client/adresse secondaire ou principale

• Pour l'enregistrement des valeurs forcées de retraits pour un produit fini (conditionnement)


TSC _CT Catégories de TVA interdites

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.199.2

Il est utilisé par le code blocage 036.

F | ic_char3_1 | Saisie de la zone alphanumérique 1 de 3 caractères (un seul caractère sera saisi) Catégorie de TVA interdite n°1 pour le client. Doit correspondre à une catégorie de TVA saisie sur le code TVA en A2[59].
G | ic_char30 | Saisie de la zone alphanumérique de 30 caractères (un seul caractère sera saisi) Catégorie de TVA interdite n°3 pour le client. Doit correspondre à une catégorie de TVA saisie sur le code TVA en A2[59].
H | ic_char3_2 | Saisie de la zone alphanumérique 2 de 3 caractères (un seul caractère sera saisi) Catégorie de TVA interdite n°2 pour le client. Doit correspondre à une catégorie de TVA saisie sur le code TVA en A2[59].


TSC _ET Modèles d'étiquette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 | Modèle étiquette
ic_char30 | Nom expéditeur


TSC _LI TSC LISA

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.195.

Il est utilisé dans le cadre de l'intégration des données des propriétaires.

Code TSC = _LI ou n'importe quel autre code défini dans la note MAJ_FLAG_INFO_C du paramètre de lancement.

ic_date1 | Date de la demande de transfert (flag)
ic_num1 | Heure de la demande de transfert (flag)
ic_date2 | Date de transfert (déflag)
ic_num2 | Heure de transfert (déflag)
ic_char3_1 | Valeur paramétrée du flag (Exemple : ATR comme A TRaiter, T comme Traité, etc.)
ic_char30 | Valeur fixe définie en A4[1,30] du TSC Cette zone optionnelle permet de faire des sélections rapides sur les informations complémentaires créées/mises à jour via ce fonctionnement (cette zone est indexée dans la base de données).


TSC _PR Client propriétaire

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.186.2

Voir les notes suivantes dans la gestion des expéditions des affrètements

RUN_EDIT_BL_PRP_DEF

RUN_EDIT_BL_PRP_PRO

RUN_REEDIT_BL_PRP_DEF

RUN_REEDIT_BL_PRP_PRO

ic_char3_1

Doit être renseigné sur le client livré pour qu'il soit considéré comme un propriétaire.


TSC _RC Récapitulatif des coûts

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC permet au programme de réactualisation batch du récapitulatif des coûts de connaître les lignes de commandes ayant fait l'objet de modifications afin de les régénérer.

Il est créé et mis à jour automatiquement lors de la création/modification de la ligne de commande.

Plus d'info dans les remarques en bas de la page consacrée au paramètre de configuration du récapitulatif des coûts.

ic_char3_1

Cette ligne de commande a-t-elle été modifiée ? (O/N)

Cette info est mise à jour automatiquement par le programme, ne pas la modifier !

O Les indicateurs de rentabilité client de cette ligne de commande doivent être calculés (Création) ou n'ont pas pu être calculés (Anomalie).

N Les indicateurs de rentabilité client de cette ligne de commande ont été calculés avec succès.

ic_char30

3 possibilités :

[Produit] : Pas d'offre L'offre de vente associée au produit n'a pas pu être retrouvée (méthode 1 et 2).
Les indicateurs n'ont pas pu être calculés pour cette ligne de commande (Anomalie).

Devis [Devis-Offre] : Anomalie L'offre de vente associée au produit n'est pas calculée (méthode 1) ou n'a pas pu être calculée jusqu'à son terme (méthode 2).
Les indicateurs n'ont pas pu être calculés pour cette ligne de commande (Anomalie).

Devis [Devis-Offre] : Ok L'offre de vente associée au produit est correctement calculée (méthode 1) ou a pu être calculée jusqu'à son terme (méthode 2).
Les indicateurs de rentabilité client de cette ligne de commande ont été calculés avec succès.

Cette info peut être mise à jour automatiquement :

en saisie de commande client, par le code BLOcage 035

dans le batch de réactualisation du récapitulatif des coûts (note CODE_BLOCAGE_RCP)


TSC _VP Variante de production

Ce TSC est opérationnel à partir de la V. 4.0.181.2

Il est utilisé par le programme de génération des dossiers de fabrication en automatique.

Voir le contexte dans la gestion des variantes techniques dans la solution onduleur.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char_30

Variante technique (Code produit)


TSC _VT Variante Technique

Ce TSC est opérationnel à partir de la V. 4.0.181.2

Il est utilisé par le devis onduleur.

Voir le contexte dans la gestion des variantes techniques dans la solution onduleur.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char3_1 | Article par défaut du site (O/N, N par défaut) - Tableau de bord du multisite
char_30 | Variante technique (Code produit)


TSC 045 Caractéristiques architecture

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe A (Article)

A | ic_date1 |
B | ic_date2 |
C | ic_num1 | Longueur filet par pose
D | ic_num2 | Longueur à scier par plaque
E | ic_num3 |
F | ic_char3_1 | Cannelure inversée (O/N)
G | ic_char30 | Emballage mécanisé (code qualité)
H | ic_char3_2 | Code du paramètre .CD


TSC 050 Caractéristiques des pattes

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe A (Article)

A | ic_date1 |
B | ic_date2 |
C | ic_num1 | Dimension de la patte de jonction
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Code du paramètre .JE
G | ic_char30 | Code du paramètre .J3
H | ic_char3_2 | Code du paramètre .J2


TSC 055 Prolongement patte

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe A (Article)

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Code du paramètre .J4
G | ic_char30 |
H | ic_char3_2 | Code du paramètre .J4


TSC 070 Fiche technique

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe A (Article)

C | ic_num1 | Laize nette architecture
D | ic_num2 | Coupe nette architecture
E | ic_num3 | Surface imposée
F | ic_char3_1 | Type d'entité
G | ic_char30 | N° fiche technique
H | ic_char3_2 | Type de produit


TSC 071 Numéro d'étude

Permet de stocker un numéro d'étude Picador.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe A (Article)

F | ic_char3_1 | Indice
G | ic_char30 | N° d'étude/image


TSC 08x Pointages refouleurs

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ces TSC existent déjà dans le devis transformateur.

Ils sont maintenant opérationnels pour le devis_ondu.

A cette occasion, leur nombre passe de 15 à 30.

TSC |  | num1 | num2 | num3
Laize | Coupe | char3_1 | char30 | char3_2
080 | 085 | 1 | 2 | 3
081 | 086 | 4 | 5 | 6
082 | 087 | 7 | 8 | 9
083 | 088 | 10 | 11 | 12
084 | 089 | 13 | 14 | 15
08A | 08F | 16 | 17 | 18
08B | 08G | 19 | 20 | 21
08C | 08H | 22 | 23 | 24
08D | 08I | 25 | 26 | 27
08E | 08J | 28 | 29 | 30

Comment lire ce tableau ?

Il y a 30 pointages (sur fond jaune) paramétrés sur 20 TSC (sur fond vert).

Exemple pour le pointage 14

La valeur du pointage 14 est stockée dans le champ num2 du TSC 084 (pour le sens laize) et du TSC 089 (pour le sens coupe).

Le type d'outil du pointage 14 est stocké dans le champ char30 du TSC 084 (pour le sens laize) et du TSC 089 (pour le sens coupe).


TSC 095 Type de refouleur

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Code type de refouleur. Paramètre de type .TR Voir aussi CP A1[14]
G | ic_char30 |
H | ic_char3_2 |


TSC 200 Gamme de fabrication

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Coût matière
ic_num2 | Coût opération
ic_num3 | Coût prévisionnel outillage
char3_1 | Gamme
char3_2 | Nombre de poses par découpe
char30 | Coût des clichés


TSC 201 Poids et surface unitaire bruts

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Poids unitaire brut
ic_num2 | Surface unitaire brute


TSC 202 Poids et surface unitaire nets

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Poids unitaire net
ic_num2 | Surface unitaire nette
ic_num3 | Poids déchet (renseigné automatiquement) - A VERIFIER


TSC 203 Qualité carton

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Dans le devis standard, version GENERO, on peut renseigner automatiquement le mode de réapprovisionnement à S (stock interne) quand la surface est inférieure à une surface paramétrée.

La surface se paramètre selon le mode de priorité suivant (du plus fin au plus large).

1 sur le couple Fournisseur/Qualité : TSC 203 ic_num2

2 sur la qualité : TSC 203 ic_num2

3 sur le fournisseur : TSC 203 ic_num2

4 sur le TEN : note _SURF_MINI_MODE_REAP

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 | Surface minimum en dessous de laquelle le mode de réapprovisionnement est automatiquement passé à S
E | ic_num3 |
F | ic_char3_1 |
G | ic_char30 | Qualité carton
H | ic_char3_2 |


TSC 20V

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Clé : Article - gamme

Type de clé : W


TSC 210 Spécifications de colisage

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Nombre d'articles par colis
ic_num2 | Nombre maximum de palettes dans un camion complet
ic_num3 | Nombre maximum de PF dans un camion complet
char3_1 | Code du type de colisage (.SC)
char3_2 | Critère d'optimisation du conditionnement M Mètre linéaire de plancher C [ou blanc] Coût (par défaut)


TSC 211 Localisation du papier

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char3_1

Localisation du papier - Voir CAS A2[7,8] = PP

I importé (par défaut)

L local


TSC 218 Dimensions de la palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Longueur de la palette (en mm)
ic_num2 | Largeur de la palette (en mm)
ic_num3 | Hauteur de bois de la palette (en mm)


TSC 220 Spécifications de palettisation

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

Enregistré sur le PF :

ic_num1 | Nombre d'articles conditionnés par palette
ic_num2 | Nombre de palettes utilisées par palette
ic_num3 | Nombre de gerbages
ic_char3_1 | Type de palette utilisée (.TP)
ic_char30 | Mode de gestion de la palette (.MG)
ic_char3_2 | Schéma de palettisation (.SP)

Enregistré sur l'ensemble :

ic_char3_2 | Camion complet (O/N)


TSC 223 Dimensions de la charge

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Longueur de la charge
ic_num2 | Largeur de la charge
ic_num3 | Hauteur de la charge
ic_char3_1 | Les piles ont été inversées pour rentrer dans le format d'encombrement de la palette (O/N)


TSC 224 Dépassement format palette (débord)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC client

ic_num1 | Dépassement dans la longueur
ic_num2 | Dépassement dans la largeur
ic_char3_1 | Dépassement autorisé (O/N)


TSC 225 Encombrement de palettisation

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Longueur d'encombrement de la charge (en mm)
ic_num2 | Largeur d'encombrement de la charge (en mm)
ic_num3 | Hauteur d'encombrement de la charge (en mm)


TSC 226 Format PF plié

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Longueur du PF plié (en mm)
ic_num2 | Largeur du PF plié (en mm)
ic_num3 | Epaisseur du PF plié (en mm)
ic_char3_1 | Forçage du format plié Cette zone est mise à O (Oui) si l'utilisateur modifie une des trois valeurs constituant le format plié (via la fenêtre prévue à cet effet).


TSC 227 à 229 Protections palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_char3_1 | Code 1,4,7 des protections palette (.PP)
ic_char30 | Code 2,5,8 des protections palette (.PP)
ic_char3_2 | Code 3,6,9 des protections palette (.PP)


TSC 230 Spécification de cerclage

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_char3_1 | Code du type de cerclage (.CE)
ic_char3_2 | Inversion palette (O/N) - utilisé dans gdf_ond (Transfert PCTOPP - OTDATA)


TSC 231

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est valable pour :

les bons de livraison (Type L)

les commandes livrées (Type C)

les produits livrés (Type A)

ic_char30

Code palette à sortir


TSC 239 Informations complémentaires conditionnement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé dans la rubrique Informations complémentaires de l'écran Complément Conditionnement dans le devis onduleur.

ic_char3_1 | Information complémentaire 1
ic_char30 | Information complémentaire 2
ic_char3_2 | Information complémentaire 3


TSC 241 Informations complémentaires conditionnement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé dans la rubrique Informations complémentaires de l'écran Complément Conditionnement dans le devis onduleur.

ic_char3_1 | Information complémentaire 4
ic_char30 | Information complémentaire 5
ic_char3_2 | Information complémentaire 6


TSC 23A à 23J Clients par type de palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Permettent de stocker jusqu'à 10 codes clients dans la zone ic_char30 pour une palette.

ic_char30

code client autorisé pour cette palette


TSC 23K Disposition palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1

Code IDP


TSC 250 Etiquetage palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Nombre d'étiquettes par palette
ic_num2 | Nombre d'étiquettes GALIA. Par défaut : 1
ic_char3_1 | Type des étiquettes palettes. Paramètre .ET
ic_char30 | Plan de palettisation
ic_char3_2 | Position des étiquettes sur la palette


TSC 255 Caisse témoin

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1 | Nombre de caisses témoins
ic_char3_1 | Position des caisses témoins sur la palette


TSC 270 Nomenclature douanière

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A-date1 | Date de dernière modification
C-num1 | Nombre total de documents sur la fiche de spécification
F-char3_1 | Indice PF
G-char30 | Nomenclature Douanière
H-char3_2 | Flag forçage FAM/SFM


TSC 280 Déclaration de production

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC permet d'autoriser ou non la procédure automatique de production par produit fini.

Cette information est accessible dans l'écran de détail PF (F22) disponible dans le devis.

ic_char3_1 (zone F)

Production multi-niveaux autorisée pour ce produit (O/N)


TSC 290 Spécifications de palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_char3_1 | Type de palette (.TP)
ic_char30 | Mode de gestion de la palette (.MG)


TSC 291 Lieu de rangement des palettes à sortir

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est valable pour le code palette (type A).

ic_char3_1 | Lieu de rangement 1 du code palette à sortir
ic_char30 | Lieu de rangement 2 du code palette à sortir


TSC 292 Lieu de rangement des palettes à entrer

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est valable pour le code palette (type A).

ic_char3_1 | Lieu de rangement 1 du code palette à entrer
ic_char30 | Lieu de rangement 2 du code palette à entrer


TSC 310 Composition carton

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Profil carton
G | ic_char30 | Code couleur
H | ic_char3_2 |


TSC 320 Code qualité spécifique

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char3_1 | Code Qualité Carton spécifique
char3_2 | Qualité saisissable uniquement en mode expert : O/N
char30 | Ancienne codification


TSC 33A à 33N

TSC 33A à 33N Estampilles

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Permettent de stocker 14 estampilles :

33A | Estampille 1
33B | Estampille 2
33C | Estampille 3
33D | Estampille 4
33E | Estampille 5
33F | Estampille 6
33G | Estampille 7
33H | Estampille 8
33I | Estampille 9
33J | Estampille 10
33K | Estampille 11
33L | Estampille 12
33M | Estampille 13
33N | Estampille 14

ic_char3_1 | Type d'estampille
ic_char30 | Libellé
ic_char3_2 | Critère


TSC 510 Ouverture, Poussée et Nombre de poses

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C | ic_num1 | Ouverture calculée ou coupe brute
D | ic_num2 | Poussée calculée ou laize brute
E | ic_num3 | Nombre de poses calculé


TSC 51C Ouverture / Poussée / Rotation

Ouverture et Poussée calculées majorées pour le plastique

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Clé : Triplet article-gamme-phase

A | ic_date1 |
B | ic_date2 |
C | ic_num1 | Ouverture / Laize
D | ic_num2 | Poussée / Coupe
E | ic_num3 |
F | ic_char3_1 | Code ROP de la rotation avant (à l'entrée) de la machine
G | ic_char30 |
H | ic_char3_2 | Code ROP de la rotation après (à la sortie) de la machine


TSC 600 Caractéristiques machine pour transferts OTDATA - MIDATA

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres par gdf_don

num1 | Coefficient de majoration de temps de passage (pour transfert OTDATA)
num2 | Priorité de la machine (pour transfert MIDATA)
num3 | Coefficient de majoration de temps de réglage (pour transfert OTDATA) Si le coefficient de réglage n'est pas renseigné, on l'initialise avec le coefficient de passage.
char_3_1 | La machine est transférée vers le système de planification (O/N, O par défaut)
char_30 | Code machine PCTOPP (pour transfert MIDATA)


TSC 606 Pondération capacité et charge machine

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

num1 | Coefficient de pondération de la capacité reçue
num2 | Coefficient de pondération de la charge reçue


TSC 60F Réception

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de type F (Tiers)

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 |
G | ic_char30 | Réception
H | ic_char3_2 | Réf. BL auto Si cette zone contient NGR, alors la référence BL sera automatiquement remplie par les 15 premiers caractères de la note de type .GR Cette fonctionnalité est utilisée par les programmes prep_cde_cab et blv.


TSC 60K Calcul de la cadence

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1

Coefficient multiplicateur du temps de passage pour le calcul de la cadence cible envoyé dans OT-DATA zone 100


TSC 625 Contrôle hauteur palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Hauteur maximum de la palette
ic_num2 | Hauteur minimum de la palette

Ce TSC est utilisé par le contrôle machine 021.


TSC 635 Contrôle sur la hauteur du panneau

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Valeur minimum du contrôle sur la hauteur du panneau + le rabat
ic_num2 | Valeur maximum du contrôle sur la hauteur du panneau + le rabat


TSC 636 Contrôle sur la hauteur du panneau

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Valeur minimum du contrôle sur la largeur du panneau + la patte
ic_num2 | Valeur maximum du contrôle sur la largeur du panneau + la patte


TSC 637 Contrôle sur la somme des faces hors tenon

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Valeur minimum du contrôle sur la somme des faces hors tenon
ic_num2 | Valeur maximum du contrôle sur la somme des faces hors tenon

Voir aussi le contrôle 052 sur la note commençant par C du paramètre TMC.


TSC 640 Spécification de colisage

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1

Spécification du type de colisage (.SC)


TSC 725 et suivants

Ce paragraphe porte sur les TSC suivants :

725 / 726 / 727

72A à 72Z

73A à 73Z

74A à 74Z

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Pour les onduleurs (code contrôle 025)

Le code qualité est vérifié par rapport au paramètre .CQ (3 caractères).

TSC 725 | ic_char3_1 | Code qualité interdit 1
 | ic_char30 | Code qualité interdit 2
 | ic_char3_2 | Code qualité interdit 3
TSC 726 | ic_char3_1 | Code qualité interdit 4
 | ic_char30 | Code qualité interdit 5
 | ic_char3_2 | Code qualité interdit 6
TSC 727 | ic_char3_1 | Code qualité interdit 7
 | ic_char30 | Code qualité interdit 8
 | ic_char3_2 | Code qualité interdit 9

Pour les transformateurs (code contrôle 025)

La qualité est vérifiée par rapport à la table des articles (15 caractères).

TSC 725 | ic_char30 | Qualité interdite 1
TSC 726 | ic_char30 | Qualité interdite 2
TSC 727 | ic_char30 | Qualité interdite 3

Pour les transformateurs (code contrôle 053)

La qualité est vérifiée par rapport à la table des articles (15 caractères).

TSC 72A | ic_char30 | Qualité interdite 1
TSC 72B | ic_char30 | Qualité interdite 2
TSC 72C | ic_char30 | Qualité interdite 3
TSC 72D | ic_char30 | Qualité interdite 4
TSC 72E | ic_char30 | Qualité interdite 5
TSC 72F | ic_char30 | Qualité interdite 6
TSC 72G | ic_char30 | Qualité interdite 7
TSC 72H | ic_char30 | Qualité interdite 8
TSC 72I | ic_char30 | Qualité interdite 9
TSC 72J | ic_char30 | Qualité interdite 10
TSC 72K | ic_char30 | Qualité interdite 11
TSC 72L | ic_char30 | Qualité interdite 12
TSC 72M | ic_char30 | Qualité interdite 13
TSC 72N | ic_char30 | Qualité interdite 14
TSC 72O | ic_char30 | Qualité interdite 15
TSC 72P | ic_char30 | Qualité interdite 16
TSC 72Q | ic_char30 | Qualité interdite 17
TSC 72R | ic_char30 | Qualité interdite 18
TSC 72S | ic_char30 | Qualité interdite 19
TSC 72T | ic_char30 | Qualité interdite 20
TSC 72U | ic_char30 | Qualité interdite 21
TSC 72V | ic_char30 | Qualité interdite 22
TSC 72W | ic_char30 | Qualité interdite 23
TSC 72X | ic_char30 | Qualité interdite 24
TSC 72Y | ic_char30 | Qualité interdite 25
TSC 72Z | ic_char30 | Qualité interdite 26
TSC 73A | ic_char30 | Qualité interdite 27
TSC 73B | ic_char30 | Qualité interdite 28
TSC 73C | ic_char30 | Qualité interdite 29
TSC 73D | ic_char30 | Qualité interdite 30
TSC 73E | ic_char30 | Qualité interdite 31
TSC 73F | ic_char30 | Qualité interdite 32
TSC 73G | ic_char30 | Qualité interdite 33
TSC 73H | ic_char30 | Qualité interdite 34
TSC 73I | ic_char30 | Qualité interdite 35
TSC 73J | ic_char30 | Qualité interdite 36
TSC 73K | ic_char30 | Qualité interdite 37
TSC 73L | ic_char30 | Qualité interdite 38
TSC 73M | ic_char30 | Qualité interdite 39
TSC 73N | ic_char30 | Qualité interdite 40
TSC 73O | ic_char30 | Qualité interdite 41
TSC 73P | ic_char30 | Qualité interdite 42
TSC 73Q | ic_char30 | Qualité interdite 43
TSC 73R | ic_char30 | Qualité interdite 44
TSC 73S | ic_char30 | Qualité interdite 45
TSC 73T | ic_char30 | Qualité interdite 46
TSC 73U | ic_char30 | Qualité interdite 47
TSC 73V | ic_char30 | Qualité interdite 48
TSC 73W | ic_char30 | Qualité interdite 49
TSC 73X | ic_char30 | Qualité interdite 50
TSC 73Y | ic_char30 | Qualité interdite 51
TSC 73Z | ic_char30 | Qualité interdite 52
TSC 74A | ic_char30 | Qualité interdite 53
TSC 74B | ic_char30 | Qualité interdite 54
TSC 74C | ic_char30 | Qualité interdite 55
TSC 74D | ic_char30 | Qualité interdite 56
TSC 74E | ic_char30 | Qualité interdite 57
TSC 74F | ic_char30 | Qualité interdite 58
TSC 74G | ic_char30 | Qualité interdite 59
TSC 74H | ic_char30 | Qualité interdite 60
TSC 74I | ic_char30 | Qualité interdite 61
TSC 74J | ic_char30 | Qualité interdite 62
TSC 74K | ic_char30 | Qualité interdite 63
TSC 74L | ic_char30 | Qualité interdite 64
TSC 74M | ic_char30 | Qualité interdite 65
TSC 74N | ic_char30 | Qualité interdite 66
TSC 74O | ic_char30 | Qualité interdite 67
TSC 74P | ic_char30 | Qualité interdite 68
TSC 74Q | ic_char30 | Qualité interdite 69
TSC 74R | ic_char30 | Qualité interdite 70
TSC 74S | ic_char30 | Qualité interdite 71
TSC 74T | ic_char30 | Qualité interdite 72
TSC 74U | ic_char30 | Qualité interdite 73
TSC 74V | ic_char30 | Qualité interdite 74
TSC 74W | ic_char30 | Qualité interdite 75
TSC 74X | ic_char30 | Qualité interdite 76
TSC 74Y | ic_char30 | Qualité interdite 77
TSC 74Z | ic_char30 | Qualité interdite 78


TSC A1C Adresse secondaire

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Il s'agit d'un TSC sur le code adresse du client ou sur le client.

Sur l'adresse secondaire : code attribué

Sur le client : dernier code attribué

Ce TSC est utilisé dans le cadre de la facturation Efficial.

ic_char3_1

Caractère de recodification (1 à 9, A à Z et a à z)


TSC APT Annulation de commande envoyée à PC-TOPP

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1

La valeur 1 indique qu'une annulation a été envoyée à PC-TOPP.

Génération des dossiers de fabrication

Les OF non annulés avec AR non édité suite code blocage ne sont pas régénérés.

L'option One permet de les régénérer en simulant l'annulation de ligne de commande.

Le TSC APT rattaché à la ligne de commande (Type C - Commande CD2 ou FB2) avec 1 dans la valeur numérique 1 est créé.

Il indique qu'une annulation a été envoyée à PC-TOPP.

Lors de l'envoi suivant, il permettra d'envoyer une création à PC-TOPP au lieu d'une modification lorsque la ligne de commande sera débloquée.

Le TSC APT sera alors supprimé.

Saisie des commandes clients

Le dossier de fabrication est mis à régénérer (f0_gener à 2) si :

un code blocage édition AR sur la ligne de commande est débloqué

l'AR n'a pas été édité

l'OF a été généré.

Voir paramètre BLO A4[22]

Edition des accusés de réception

Si l'option One est activée, le dossier de fabrication est mis à régénérer f0_gener à 2) si :

un code blocage édition AR sur la ligne de commande est bloqué

l'AR n'a pas été édité

l'OF a été généré

Voir paramètre BLO A4[22]

Voir aussi :

#CF CDE A3[37,38]


TSC BDM Blocage du devis multi-métiers

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Il s'agit d'un TSC sur le client du devis.

Ce TSC est utilisé dans le cadre des codes blocages automatiques et/ou manuels sur la saisie du devis multi-métiers sous GENERO.

ic_num1

Taux de marge pour le blocage de devis multi-métiers

Ce taux est prioritaire sur celui du TEN A2[50,52]


TSC BET Temps passé en bureau d'étude

Spécifique


TSC BLD Edition des lignes de détail palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char3_1 | O ou [espace] Edition des lignes de détail palette N Non-édition des lignes de détail palette
char3_2 | Edition de la date de la première palette

utilisé par blv_ed1


TSC BLP BL frais de Palettes

Ce TSC est opérationnel à partir de la V. 4.1.23.2

Il utilisé par blv_ed1 et facn.

Lors de l'édition de facture, on peut désormais éditer le numéro et la date du BL rattachés à une ligne de frais de palette.

Ces informations sont stockées dans le TSC BLP créé à cet effet lors de la génération du BL.

Ce TSC est rattaché à la ligne de commande de frais de palette générée automatiquement.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Date du BL
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 |
G | ic_char30 | N° de BL
H | ic_char3_2 |


TSC BQE Banque

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Permet d'éditer des notes bancaires de facturation différentes selon les clients.

Les notes sont saisies sur le paramètre BQE rattaché au client par le TSC BQE (sur adresse principale et/ou adresse de facturation).

Si aucune note bancaire n'est rattachée au client facturé, celles-ci sont prises sur le paramètre de lancement (notes TEXTE_VIR_BANQUE sur facn).

char3_1 | Code banque (BQE)
char3_2 | Flag pour différencier la banque associée au client. Spécifique


TSC Types de phases

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ces TSC sont saisis sur l'article référence multiple.

Il s'agit en fait de 9 TSC utilisés dans le devis multi-métiers :

TSC BRA Présence de braille

TSC DOR Présence de dorure

TSC FEN Présence de fenêtrage

TSC FOU Présence de foulage

TSC GAU Présence de gaufrage

TSC HOL Présence de hologramme

TSC RAI Présence de rainage

TSC TRF Présence de transfert/poudrage

TSC VIG Présence de vignette

Tous ces TSC utilisent la zone F - char3_1, à part le TSC FEN qui utilise la zone H - char3_2.

Pour chaque TSC, les valeurs possibles sont les suivantes :

H Hors-ligne

L en Ligne

S Sous-traitance

N Non


TSC BSD Bobine sens déroulement

Ce TSC est opérationnel à partir de la V.4.0.163.2

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Le numéro de bobine fournisseur transmis par le fichier EDI pour une intégration des bobines (module G_integrer_bobine) passe de 14 à 20 caractères.

Toutes les autres zones du fichier sont donc décalées.

Les tables edi_bobine et edi_rec_cond sont aussi modifiée en conséquence.

Dans l'intégration EDI des réceptions, ajout d'une nouvelle zone Sens du déroulement de la bobine (module G_integrer_edi_brc), ligne de type LIGCON, caractère 154. (contrôle lié au paramètres BSD)

Cette information sera stockée sur la bobine dans le TSC BSD.

char3_1

Type de paramètre (BSD)

Exemple de paramétrage

ZFSens DéroulmentN01BSDZ SENS DEROULMENT

123456789012345678901234567890123456789012345678901234567890

1 2 3 4 5 6


TSC CAC Confirmation d’affrètement client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Voir l'édition du document de confirmation d'affrètement client

char3_1

Client à avertir

I Indifférent (par défaut)

E Envoi du document

C Envoi du document nécessitant une confirmation du client

Clé : code client (avec ou sans code adresse)

Le TSC est alors recopié sur le groupage.

La zone char3_1 peut alors prendre 2 autres valeurs :

O (acceptation du client)

N (refus du client)

Clé : N° de groupage, /, n° étape


TSC CAL Adresses de livraison réservées CALDEL

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Libellé long : Adresse liv. EDI CALDEL

But

En saisie de commande, interdire une adresse de livraison réservée au traitement EDI.

En intégration EDI, interdire une adresse de livraison non réservée au traitement EDI.

char3_1

Adresse livraison réservée CALDEL (O/N, N par défaut)

Si non renseignée, valable pour tout traitement

Exemple

1 2 3 4 5

1234567890123456789012345678901234567890123456789012345678

ZFAdresse CALDEL N01O/N2


TSC CCA Compte collectif affacturage

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Type de clé : F (Tiers)

Ce TSC est opérationnel à partir de la V.4.1.41.3

Il fonctionne uniquement avec la comptabilité Sage ligne 1000.

Il est prioritaire sur la note COLLECT_AFFACTURAGE dans #CF TRF.

ic_char30

Compte collectif affacturage, sur 8 caractères


TSC CCL Compte collectif client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Type de clé : F (Tiers)

ic_char30

Compte collectif client, sur 8 caractères


TSC CDF Contraintes de délai fournisseur

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.173.2

ic_num1 | L'heure limite de passation de commande pour le fournisseur. Si l'heure de passation de commande est supérieure à cette heure limite, la commande ne sera prise en compte que le lendemain.
ic_num2 | Préavis de passation de commande (délai administratif lié au fournisseur) Nombre de jours dont le fournisseur a besoin pour prendre en compte la commande.
ic_num3 | Le délai fournisseur (fabrication + livraison)

Gestion des besoins

Génération de commandes depuis le devis multi-métiers

Gestion des contraintes techniques et délai

Fonctionnalités

Lors de la génération des besoins matières suite à un transfert de devis en commande à partir du devis multi-métiers, le choix automatique du fournisseur se fera en respectant certaines contraintes techniques et certaines contraintes de délai.

Cette nouvelle recherche ne se fera que pour les besoins gérés à partir de l'entité (voir ul_param[30]), et que si le fournisseur n'a pas été imposé dans le devis.

Algorithme de recherche du meilleur fournisseur

Application des contraintes générales

Un fournisseur bloqué achat via son code validité ne sera pas pris en compte lors de l'optimisation.

Un couple Fournisseur / Qualité exclut temporairement ne sera pas pris en compte.

Application des contraintes techniques

Les contraintes techniques limitent la liste des fournisseurs potentiels.

Application des contraintes de délai

A chaque fournisseur, on calcule son meilleur délai d'approvisionnement.

Choix du fournisseur

Si aucun fournisseur ne peut satisfaire techniquement la demande, il y a blocage de l'optimisation et l'utilisateur reprend la main.

Si un seul fournisseur peut satisfaire le délai, il est retenu quel que soit son tarif.

Si aucun fournisseur ne peut satisfaire le délai demandé, on retient le fournisseur qui propose le meilleur délai quel que soit son tarif.

Si plusieurs fournisseurs satisfont le délai, on retient le moins cher.

Rappel : l'option payante BAS 30 doit être activée.

Voir aussi : #CF SMC A1[37,42] et A1[43].


TSC CHC Chrono pour codification des produits du clients

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Type de clé : F (Tiers)

• Ce folioteur alphanumérique est utilisé dans le devis multi-métiers et dans le devis onduleur.

• Il est saisi sur la zone alphanumérique 1 de 3 caractères (info_c.ic_char3_1)

• Il est créé à A s'il n’existe pas et évolue automatiquement (A, B, …, AA, AB, etc.)

ic_char3_1

Prochain chrono


TSC CIV Version EDI INVOICE

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.203.2

Il a été créé dans le cadre de la V3 du fichier EDI INVOICE.

Voir la fiche d'installation EDI

La V3 est une évolution de la V1. L'unique différence est le code EDI du service à facturer, stocké sous forme de 5 caractères alphanumériques dans la zone 38 de FACENT (ENTête de FACture), et issu de la zone ic_char30 du TSC CIV.

Cette nouvelle version de fichier est maintenant compatible avec la V2.

Numéro de version EDI : voir #CF EDI A1[6,8]

Pour la V3, il est nécessaire d'ajouter au client le TSC CIV, qui contient le code EDI du service à facturer sur 5 caractères et le numéro de version du fichier.

Pour la majorité des clients (qui sont en V3), il suffit de mettre #CF EDI A1[6,8] = 003.

Sur chaque client, il créer le TSC CIV et renseigner le code EDI.

Pour les clients qui sont en V1, #CF EDI A1[6,8] = 001 ou [à blanc], le TSC CIV est inutile.

Pour les clients qui sont en V2, cette page est sans objet.

ic_num1 | Numéro de version. Les valeurs possibles sont 1,2 et 3.
ic_char30 | Code EDI du service à facturer (longueur 5 caractères) Obligatoire si numéro de version = 3 dans la zone ic_num1 ou dans #CF EDI A1[6,8] = 003.


TSC CL2 Info client facturation

Ce TSC est opérationnel à partir de la V. 4.1.1.2

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 (F)

Editer la date du BL (O/N)


TSC CLI Hauteur de palette maxi chez le client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_num1

Hauteur de palette maxi chez le client


TSC CLV Contrôle de livraison

Ce TSC est opérationnel à partir de la V. 4.1.26.2

Il utilisé par la saisie de commande client.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Faut-il effectuer le contrôle des livraisons pour ce client ? (O/N, O par défaut)
G | ic_char30 |
H | ic_char3_2 |


TSC CMI Contribution minimum des machines

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé dans l'édition du devis onduleur.

Edition de la contribution minimum des machines des phases de passage de la gamme des PF en EURO/Tonne dans l’édition technique des devis (Techn. 1) et l'édition du devis force de vente sous APPIC (Force vente).

Si le TSC CMI est paramétré, la contribution minimum des machines est éditée à la fin du tableau récapitulatif final.

ic_num1

Contribution minimum des machines


TSC CV1 / CV2 / CV3 Conducteur du véhicule

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Voir l'édition du document de confirmation d'affrètement client

Clé : N° de groupage

CV1 | ic_char30 | Nom du conducteur
CV2 | ic_char30 | Téléphone du conducteur
CV3 | ic_char30 | N° d'identification du conducteur


TSC D01 Margeur de couverture (largeur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Margeur de couverture (Contrôle par rapport au format ouvert de la couverture)

num1 | Largeur mini en mm
num2 | Largeur maxi en mm


TSC D02 Margeur de couverture (longueur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Margeur de couverture (Contrôle par rapport au format ouvert de la couverture)

num1 | Longueur mini en mm
num2 | Longueur maxi en mm


TSC D03 Margeur de cahier (largeur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Margeur de cahier (Contrôle par rapport au format fini de l'intérieur + rognes)

num1 | Largeur mini en mm
num2 | Largeur maxi en mm


TSC D04 Margeur de cahier (longueur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Margeur de cahier (Contrôle par rapport au format fini de l'intérieur + rognes)

num1 | Longueur mini en mm
num2 | Longueur maxi en mm


TSC D05 Trilatéral en ligne (largeur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Trilatéral en ligne (Contrôle par rapport au format fini de l'ouvrage)

num1 | Largeur mini en mm
num2 | Largeur maxi en mm


TSC D06 Trilatéral en ligne (longueur)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

Trilatéral en ligne (Contrôle par rapport au format fini de l'ouvrage)

num1 | Longueur mini en mm
num2 | Longueur maxi en mm
num3 | Rogne maxi éjectable


TSC D07 Piqûre - Couverture

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Devis optimisé

num1 | Epaisseur maxi de la piqûre (Contrôle par rapport à l'épaisseur de l'ouvrage)
num2 | Margeur de couverture (Contrôle par rapport au format ouvert de la couverture) Grammage maxi pour le pliage de la couverture (à saisir sur les plieuses)


TSC DKM Distance kilométrique

Ce TSC est référencé dans #CF LOG A1[40,42] pour v_groupage_bl (zone kilometrage) dans le cadre de l'interface de préfacturation.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Paramétrage

ic_num1

Distance kilométrique


TSC DS Date et délai standard de la ligne de commande

Ce TSC est opérationnel à partir de la V.4.1.3.2

Il est utilisé dans le cadre de l'analyse des délais de livraison (saisie de commande client)

TSC de type C (Ligne de commande)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Date standard (= date de la commande + nombre de jours du délai standard de l'article).
C | ic_num1 | Délai standard (correspond au délai standard de l'article selon la quantité)

Utilisation de ce TSC : Si la quantité commandée est comprise entre [ic_num1] et [ic_num2] ,alors le délai entre la prise de la commande client et la livraison chez le client sera de [ic_num3] jours.

Voir aussi les TSC DS1 / DS2 / DS3 / DS4 / DS5.

Exemple de paramétrage

TSC DS

TIC*

ZCDélai standard 2Délai standard

ZADate standard 2Date standard

TSC DS1 / TS2 / TS3

TIC*

ZCQte de B 2<<<<& Qte de

ZDà <<<<& à

ZEDélai B <<<<& Délai

Informations complémentaires de l'article

DS1 Qte de 0 à 200 Délai 15

DS2 Qte de 201 à 500 Délai 18

DS3 Qte de 500 à Délai 22

Quantité | Délai entre la prise de commande et la livraison chez le client
0 < Quantité <= 200 | 15 jours
201 < Quantité <= 500 | 18 jours
501 < Quantité | 22 jours

Paramétrage de la visu de commande

V Delais std*TSC_LC_NU_DS_C*3*<<&**

V Date std*TSC_LC_NU_DS_A*10*DD/MM/YYYY**

V Délai réalisé*delais_realise*4*<<<&**


TSC DSn Date et délai standard du produit

TSC DS1 / TSC DS2 / TSC DS3 / TSC DS4 / TSC DS5

Ce TSC est opérationnel à partir de la V.4.1.3.2

Il est utilisé dans le cadre de l'analyse des délais de livraison (saisie de commande client)

TSC de type A (Article)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C | ic_num1 | Qté de ... (borne inférieure)
D | ic_num2 | à... (borne supérieure) Par défaut : la borne supérieure est sans limite.
E | ic_num3 | Délai. Utilisé pour le calcul de date dans la revue de contrat.

Utilisation de ce TSC : Si la quantité commandée est comprise entre [ic_num1] et [ic_num2] ,alors le délai entre la prise de la commande client et la livraison chez le client sera de [ic_num3] jours.

Voir aussi le TSC DS.

Les exemples sont dans le TSC DS.


TSC EBE Edition des numéros d’affrètement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Notes

char 3_1

Edition des numéros d'affrètements (BE) dans l'édition des factures (O/N, N par défaut)


TSC EFF Efficial

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Type de clé : 0 (Ligne de facture client)

Ce TSC est utilisé dans le cadre de la facturation Efficial.

ic_num1 | Coût d'achat
ic_num2 | Coût de production


TSC EFP Edition Fiche Palette

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Notes

char 3_1

Fiche palette


TSC EPO Edition des Pochettes Oranges

Ce TSC spécifique LGR est opérationnel à partir de la V.4.1.7.2.

Il utilisé par la note MAJ_FLAG_INFO_C de voluedit_acr.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC de classe C (Commande)

A | ic_date1 | Date d'édition
B | ic_date2 |
C | ic_num1 | Heure d'édition
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Edité (O/N)
G | ic_char30 | Pochette Orange
H | ic_char3_2 |


TSC ERD Escompte et Remise Devis

Taux de frais financier et taux de remise renseigné sur TSC de la fiche client.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Taux de frais financier lié à l'escompte prise en compte par l'action de service %ED.
ic_num2 | Taux de remise correspondant à déduire du C.A.

Une valeur de 1% sera saisie 1.


TSC ESR Escompte saisi sur le client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1

Taux d'escompte


TSC ETA Etapes d'affrètement

Le nom de ce TSC ne'st pas figé. Il est paramétré en #CF LOG A1[3,5].

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Date d'arrivée
B | ic_date2 |
C | ic_num1 | N° d'étape départ
D | ic_num2 | N° d'étape arrivée
E | ic_num3 |
F | ic_char3_1 | Magasin de départ
G | ic_char30 | Nom du client de l'étape
H | ic_char3_2 | Lieu de destockage (magasin de destination)


TSC ETH Horaires des étapes d'affrètement

Le nom de ce TSC ne'st pas figé. Il est paramétré en #CF LOG A1[34,36]. Parfois nommé TSC HEU.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C-num1 | Heure de début
D-num2 | Heure de fin


TSC ETN Etiquette neutre

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1

O n'affiche pas le nom de la société émettrice

N affiche le nom de la société émettrice (valeur par défaut)


TSC FAV Fichier EDI TOSHIBA par visu des stocks

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 | EDI TOSHIBA à éditer (O/N)
ic_char_30 | Type et code du paramètre de la visu à utiliser (si EDI TOSHIBA et pas de paramétrage en char30, on prendra le paramétrage inscrit sur le paramètre de lancement de l'édition du BL)


TSC FCO Force de la composition

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Notes

char3_1

Force de la composition (.FC)


TSC FE1/FE2 Forçage des dates d'échéance

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé dans :

G_cde

G_voluedit_facn

G_v_fac

G_v_jdv

G_tr_fcnn_vl

G_KP_tf_oriac_n

G_KP_tp_oriac

 | TSC | Commande | Facture | Facture de simulation
Type de clé | FE1 | C | 0 (zéro) | 1 (un)
Clé | FE1 | N° de commande | N° de facture | N° de facture de simulation
Date 1 | FE1 | Date d'échéance 1
Numérique 1 | FE1 | Pourcentage d'échéance 1
Date 2 | FE1 | Date d'échéance 2
Numérique 2 | FE1 | Pourcentage d'échéance 2
Date 1 | FE2 | Date d'échéance 3
Numérique 1 | FE2 | Pourcentage d'échéance 3

Principe

Dans la chaîne commerciale, les dates et les montants d'échéance sont issus d'un calcul (fonction f_echeance).

La fonction de calcul utilise un code échéance, une date et un montant.

Maintenant, les dates et les pourcentages d'échéance peuvent être saisis (3 maxi).

Cette nouvelle fonctionnalité est activée par la présence des TSC FE1 et FE2 dans la table des paramètres (table par02).

Les 2 doivent être présents.

Fonctionnement

Saisie des commandes clients

La touche F36 - Saisie des échéances a été ajoutée.

Une permission a été mise sur cette touche (TOU - CDE1_F36).

Cette nouvelle touche permet de saisir de 1 à 3 dates et pourcentages d'échéance.

Calcul et édition des factures clients

Si les TSC FE1 et FE2 ne sont pas présents dans la table des paramètres (table par02), la rupture est faite sur le code échéance de la commande.

S'ils sont présents, la rupture est TOUJOURS faite sur les dates et les pourcentages d'échéance même si ceux-ci n'ont pas été saisis.

Avant, si 2 codes échéances donnaient 2 dates d'échéance identiques, le calcul déclenchait une rupture. Maintenant, le calcul ne déclenchera plus de rupture.

Le calcul contrôlera si les dates d'échéance saisies ne sont pas inférieures à la date de facturation.

Si c'est le cas, la commande sortira en anomalie et aucune commande de ce client ne sera facturée.

Les TSC FE1 et FE2 de la commande seront recopiés sur la facture.

Visualisation des factures clients

La touche F13 - Saisie des échéances a été ajoutée.

Une permission a été mise sur cette touche (TOU - VFAC_F13).

Cette nouvelle touche permet de saisir de 1 à 3 dates et pourcentages d'échéance.


TSC FOR Forçage des contraintes de conditionnement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé entre autres dans l'optimisation du conditionnement.

ic_char3_1

Forçage des contraintes de conditionnement (O/N)


TSC FS1 à FS9 Frais supplémentaires dans la logistique

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ces TSC sont utilisés par G_v_groupage_bl et G_exped_affretements

TSC | Libellé | Code | Coût
FS1 | Frais accessoire 1 | F-char3_1 | C-num1
 | Frais accessoire 2 | H-char3_2 | D-num2
 | Frais accessoire 3 | G-char30 | E-num3
FS2 | Frais accessoire 4 | F-char3_1 | C-num1
 | Frais accessoire 5 | H-char3_2 | D-num2
 | Frais accessoire 6 | G-char30 | E-num3
FS3 | Frais accessoire 7 | F-char3_1 | C-num1
 | Frais accessoire 8 | H-char3_2 | D-num2
 | Frais accessoire 9 | G-char30 | E-num3
FS4 | Frais accessoire 10 | F-char3_1 | C-num1
 | Frais accessoire 11 | H-char3_2 | D-num2
 | Frais accessoire 12 | G-char30 | E-num3
FS5 | Frais accessoire 13 | F-char3_1 | C-num1
 | Frais accessoire 14 | H-char3_2 | D-num2
 | Frais accessoire 15 | G-char30 | E-num3
FS6 | Frais accessoire 16 | F-char3_1 | C-num1
 | Frais accessoire 17 | H-char3_2 | D-num2
 | Frais accessoire 18 | G-char30 | E-num3
FS7 | Frais accessoire 19 | F-char3_1 | C-num1
 | Frais accessoire 20 | H-char3_2 | D-num2
 | Frais accessoire 21 | G-char30 | E-num3
FS8 | Frais accessoire 22 | F-char3_1 | C-num1
 | Frais accessoire 23 | H-char3_2 | D-num2
 | Frais accessoire 24 | G-char30 | E-num3
FS9 | Frais accessoire 25 | F-char3_1 | C-num1
 | Frais accessoire 26 | H-char3_2 | D-num2
 | Frais accessoire 27 | G-char30 | E-num3


TSC FSC Certification FSC / PEFC

Ce TSC est opérationnel à partir de la V.4.0.170.2 (21/09/2010)

TSC sur le couple Article/Code fournisseur

Ce TSC ne fonctionne que si la certification est C ou M (#CF ATL note MODE_CERTIFICATION).

On ne créera ce TSC que pour exclure ponctuellement un article de la norme.

Voir aussi le paramètre de type CRT.

FSC = Forest Stewardship Council (Association pour la Protection de la Forêt) (WikipédiA)

PEFC = Program for the Endorsement of Forest Certification (Programme de Reconnaissance des Certifications Forestières) (WikipédiA)

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | N'est plus utilisé.
G | ic_char30 |
H | ic_char3_2 | Cet article est exclu de la certification (O/N, N par défaut)


TSC FSL Facturation séparée d'une commande ou d'une ligne de commande

Ce TSC est opérationnel à partir de la V. 4.0.188.2.

Il est utilisé par les programmes de calcul et édition des factures (facn, voluedit_facn).

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Valeurs

ic_char3_1

Facturation déparée (O/N, N par défaut)


TSC FST Facturation des frais de stockage

Ce TSC est opérationnel à partir de la V. 4.0.182.2.

Il est utilisé par le programme de génération des FAD à partir des mouvements de stock.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Valeurs

ic_char3_1 | Mode de facturation des frais de stockage 1 = Facturation Autre = Pas de facturation
ic_char30 | Code article facturé - Obligatoire


TSC G01 Nombre de postes

Ce TSC est utilisé dans le devis optimisé.

Valeurs

ic_num1 | Nombre de postes (voir #CF OPT A1[45])
ic_char3_1 | Machine compatible avec la recherche de décomposition en coming & going (O/N, N par défaut)
ic_char30 | Informations diverses


TSC GCO Gencod

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisable à partir de la V. 4.0.182.2

Génération des dossiers de fabrication en automatique - Blocage si GENCOD absent sur certains produits

Si l'alimentation du fichier OTDATA est activée (Otp), le module peut contrôler si le GENCOD du produit est renseigné avant de générer ou de régénérer.

Le contrôle du GENCOD est paramétré sur ce TSC saisi sur le client.

Si le contrôle est paramétré et que le GENCOD du produit n'est pas renseigné, le dossier ne sera pas généré ou régénéré.

ic_char3_1

Gencod obligatoire ? (O/N, N par défaut)


TSC IAC Code adresse secondaire du client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.195.

Il est utilisé dans le cadre de l'intégration des données des propriétaires.

Type de clé = F

Clé = Code client et code adresse de livraison (CCCCCCAAA)

Code TSC = IAC ou n'importe quel autre code défini en A2[5,7] du paramètre de lancement.

ic_char30

Code client et code adresse de livraison du client final du propriétaire (CCCCCCAAA)


TSC ICL Code TSC client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V. 4.0.195.

Il est utilisé dans le cadre de l'intégration des données des propriétaires.

Type de clé = F

Clé = Code client (CCCCCC)

Code TSC = ICL ou n'importe quel autre code défini en A2[8,10] du paramètre de lancement.

ic_num1 | Longueur du chrono des produits à créer
ic_char30 | Racine des produits à créer

La somme des longueurs de la racine et du chrono des produits à créer ne doit pas être supérieure à 15 caractères.


TSC IMP Impayé

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 | Autorise la mise à jour du code qualité du tiers avec son code qualité d'origine lorsque ce dernier n'a plus d'impayés (à renseigner par l'utilisateur) (O/N)
ic_char3_2 | Sauvegarde code qualité (ne pas renseigner)

Voir int_cpt A3[1,3]


TSC INA Informations client acheteur

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 | Adresse secondaire du client acheteur
ic_char30 | Code client acheteur


TSC IND Quantité indivisible

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC sur article - utilisé dans G_qte_prod.

F char3_1

Quantité indivisible

O Oui - La quantité est indivisible. Il ne peut pas y avoir de décimales.

N Non - LA quantité est divisible (fractionnable). Il peut y avoir des décimales.


TSC INV EDI INVOICE

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

F char3_1

Génération de fichier INVOICE (attention, pas de contrôle de type O/N !)

O Oui

N Non

A Autre (Génération d'un fichier de type autre que INVOICE
Si le code est A, alors la zone char30 contient le nom de l'interface.

T Autorisation de générer un fichier INVOICE en prenant toutes les factures (y compris celles sans BL, les FAD, AVO, ...)

G char30

Nom de l'interface autre que INVOICE

3 possibilités : PCARD, INFACTO et OB10- Plus d'info dans facn.

H char3_2

On passe la facture comme étant éditée lors de la génération du message INVOICE (O/N, N par défaut).

Exemple

1 2 3 4 5

1234567890123456789012345678901234567890123456789012345678

ZFClient INVOICE W Z CLIENT INVOICE fr

ZGInterface N 2 INTERFACE fr

ZHFacture trans. W Z FACTURE TRANS. fr


TSC JDE Transfert commandes JDE / Intégration TBDATA

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Mise à jour du flag lc_transfert_trans de la ligne de commande dans le module d'intégration du suivi de production TBDATA

Le flag est mis à 2

- si la précédente date prévue est différente de la nouvelle date prévue,

- si la précédente date prévue est identique à la nouvelle date prévue et l'écart entre la précédente heure prévue et la nouvelle heure prévue est supérieur à l'écart paramétré dans la note commençant par ECART_MAX_HEURES_CDE du paramètre de lancement.

La date et l'heure prévues sont stockées dans les zones f1e_date_prevue et f1e_heure_prevue de l'enregistrement de type M (f1e_phase_etranger) de la table fab_1_etat.

Le flag est utilisé dans le module de transfert des commandes vers JDE.

Cette méthode ne fonctionne pas si la précédente date prévue est identique à la nouvelle date prévue et l'écart entre la précédente heure prévue et la nouvelle heure prévue est toujours inférieur à l'écart paramétré.

Dans la nouvelle méthode, le module de transfert des commandes vers JDE stocke la date et l'heure de fin de fabrication prévue du dernier transfert de la ligne de commande vers JDE dans le TSC JDE de la ligne de commande.

Le module d'intégration du suivi de production TBDATA récupère la date et l'heure de fin de fabrication prévue du dernier transfert de la ligne de commande vers JDE dans le TSC JDE de la ligne de commande.

Cette nouvelle méthode est activée par la présence du TSC JDE.

Ce TSC est utilisé dans :

Transfert des commandes vers JDE

Intégration du suivi de production TBDATA

Type de clé C

Clé : Commande, "-", Ligne using "<<<<<"

ic_date1 | Date de fin de fabrication prévue du dernier transfert de la ligne de commande vers JDE
ic_num1 | Heure de fin de fabrication prévue du dernier transfert de la ligne de commande vers JDE


TSC KC Coefficient de nomenclature

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Type de clé = A

ic_num1

Nombre de poses


TSC KQ Coefficient de composition

Ce TSC est référencé par le code calcul KQ du devis onduleur.

il est possible d'indiquer n'importe quelle (racine de) TSC.

Exemples

Racine indiquée dans le code calcul KQ : KQ, utilisation possible des TSC KQ1, KQ2, ..., QKA, KQB, ...

Racine utilisée dans le code calcul KQ : CDC, ce n'est plus une racine, mais le code complet du seul TSC utilisable.

L'utilisation d'une racine à un seul caractère est déconseillée en raison du risque important de confusion avec d'autres TSC ayant cette même racine.

Se reporter au fichier Excel référençant les TSC.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

num1 | Coefficient de la composition
char 3_1 | Code environnement matière (doit correspondre à un type paramètre ETI) - Optionnel


TSC LIC Lieu intermédiaire de commande

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est paramétré sur le CIC P76. Il peut porter un autre code que LIC.

Exemple

CIC P76

A1[1,3] = LIC

A1[4] = 1 : Zone F (ic_char3_1)

2 : Zone G (ic_char3_2)

La lecture du TSC se fait en cascade et dans l'ordre suivant :

- Article / Client

- Article

- Client / Adresse de livraison

- Client

Dès que le lieu intermédiaire est renseigné, la lecture du TSC en cascade s'arrête.

Cette initialisation est systématique quelque soit le type de commande.

Sur le TSC du lieu intermédiaire, la notion de TYC à initialiser a été ajoutée.

Les valeurs possibles sont :

1 Initialisation du lieu intermédiaire si commandes de type CDA
Le lieu intermédiaire des commandes des autres types n'est pas initialisé.

[Autres valeurs] Initialisation du lieu intermédiaire quelque soit le type de commande

num1 | TYC initialisé
char 3_1 | Lieu intermédiaire (RG1)


TSC M10 Mylar

TSC M10 à M90 Mylar

M10 Mylar 1

M20 Mylar 2

M30 Mylar 3

M40 Mylar 4

M50 Mylar 5

M60 Mylar 6

M70 Mylar 7

M80 Mylar 8

M90 Mylar 9

Ce TSC est utilisé dans la génération des dossiers de fabrication en automatique.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Raclé
G | ic_char30 | Code Mylar
H | ic_char3_2 | Tramé


TSC MAP Majoration papier

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé par le programme compo.

ic_num_1

Coefficient de majoration

Permet d'appliquer un coefficient de majoration sur le code papier.

Si pas de TSC sur le code papier, alors le coefficient par défaut est égal à 1.

Dans l'écran du Détail Coût Matière, le coefficient de majoration est directement multiplié au coefficient de gâche.

Effectivement, il n'y a pas de place pour afficher la valeur dans une nouvelle colonne.


TSC MAS Massicot

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé par le devis multi-métiers.

Il permet de prendre comme machine de massicot par défaut le code machine saisi dans la zone G.

Ce TSC sera saisi sur la machine plieuse du premier pli de la décomposition de la feuille, le code machine massicot n'est initialisé que s'il est à blanc dans les formules concernées (OMAD50/OMAD51).

char_30 (G)

Code machine de massicot par défaut


TSC MOC Modification de commande

Ce TSC est opérationnel à partir de la V. 4.1.16.2

Il utilisé par l'édition des AR de commande client. Voir l'option Odm.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Date de dernière modification
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 |
G | ic_char30 |
H | ic_char3_2 |


TSC MPV Mise à jour du prix de vente

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé par le programme de saisie de commande client.

date1 | Date de modification
num1 | Heure de modification
num2 | Prix avant
num3 | Prix après
char3_1 | Code mise à jour BLO Code blocage interdisant la mise à jour du prix de la ligne de commande LCK Commande bloquée par un autre poste MAJ Prix de la ligne de commande mis à jour IDE Prix de la ligne de commande identique au prix du fichier tarif ABS Prix du fichier tarif à 0
char30 | Opérateur


TSC MPT Modification des pointages

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est codé par défaut MPT ou tout autre code indiqué par la note TSC_MODIF_POINTAGES dans le devis multi-métiers et le devis transformateur.

ic_char3_1

Présence de pointage modifié manuellement (O/N)


TSC O01 Caractéristiques outil

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Attention, le code de ce TSC est O01 (lettre O, puis chiffres zéro un).

Ce TSC est utilisé par ASO A1[4].

num1 | Nombre maximum de passes pour l'outil
num2 | Nombre de passes réalisées (cumul)
num3 | Taux d'utilisation
char3_1 | Zone calculée (O si le calcul s'est bien déroulé, N sinon)


TSC OND Informations OTDATA

Voir gdf_don

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1 | Max. poses onduleuse (zone 015 du fichier OTDATA)
ic_num2 | Nombre de morceaux identiques (zone 068 du fichier OTDATA)
ic_char3_1 | Seulement 1 mariage sur l'onduleuse (zone 080 du fichier OTDATA)
ic_char3_2 | Composition impérative (O/N, N par défaut) (zone 062 du fichier OTDATA)


TSC ORD EDI ORDERS

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Libellé long : EDI ORDERS

Génération d'un fichier pour le fournisseur associé.

Il faut paramétrer ce TSC sur chaque fournisseur pour lequel on veut un fichier ORDERS ou SCAO

Notes sur le TSC

num1 | Nombre de lignes maximum autorisées pour une commande d'achat
char3_1 | Génération de fichier ORDERS ou autres (O/N, N par défaut)
char30 | Type de fichier EDI ORDERS (par défaut) ORDERS2 SCAO
char3_2 | Exclusion de l'édition papier (O/N, N pas défaut)


TSC P10 à P14 Spécifications étiquettes palettes

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC P10 Spécifications étiquette palette 1

TSC P11 Spécifications étiquette palette 2

TSC P12 Spécifications étiquette palette 3

TSC P13 Spécifications étiquette palette 4

TSC P14 Spécifications étiquette palette 5

ic_num1 | Nombre d'étiquettes différentes - Uniquement pour le TSC P10 La zone 81 (nombre d'étiquettes différentes par palette) du fichier OTDATA n'était pas renseignée jusqu'à présent. Cette zone permet désormais de la remplir. Si cette zone n'est pas renseignée, la zone 81 de l'OTDATA restera vide comme avant.
ic_char3_1 | Type d'étiquette
ic_char3_2 | Code emplacement


TSC PAL Hauteur maxi de la palette chez le client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_num1

Hauteur maxi de la palette chez le client


TSC PCD Gestion prix commande client

Ce TSC est opérationnel à partir de la V. 4.1.23.2

Il utilisé par le programme de saisie de commande client.

Lorsque la gestion d'un prix forcé est active, dès qu'un utilisateur saisit manuellement un prix, une boite de dialogue lui demande s'il souhaite bloquer le prix.

Si le prix est forcé et qu'un calcul automatique de prix tente de le modifier (changement de délai, etc.), une demande de confirmation sera demandée à l'utilisateur avant d'appliquer la modification.

Si l'utilisateur choisit le prix calculé, celui-ci ne sera plus considéré comme un prix forcé.

Remarque : si le code produit change alors que la ligne avait un prix forcé, ce dernier est annulé.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Prix forcé (O/N) Voir la note GST_PRIX_FORCE dans cde.
G | ic_char30 |
H | ic_char3_2 |


TSC PI1 Palettisation intermédiaire

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Permet de gérer des informations d'une palettisation intermédiaire.

Lorsque l'option Opi est positionnée, lors de la validation de la saisie du conditionnement, un écran palettisation intermédiaire apparaît.

Les informations saisies sont stockées sur ce TSC dont la clé est le code PF.

ic_num1 | Longueur palette
ic_num2 | Largeur palette
ic_num3 | Nombre d'articles sur la palette
ic_char3_1 | Type de palette
ic_char30 | Code palette
ic_char3_2 | Mode de gestion


TSC PIA Palette Incomplète Autorisée

Ce TSC est opérationnel à partir de la V. 4.0.181.2

Il est utilisé par le programme gdf_ondu2.

Ajout d'une nouvelle zone dans le fichier OTDATA

Zone 83.48 - Caractère 1617 : Palette incomplète acceptée

L'information est saisie dans la zone ic_char3_1 ou ic_char3_2 ou ic_char30 d'un TSC paramétrable.

Le code TSC et la zone de saisie sont indiqués dans le CIC P78.

Le caractère 1617 contiendra la valeur de la zone.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_charX

Palette incomplète autorisée (O/N)

Voir le CIC P78 qui indique :

en A1[1,3] : le code du TSC (PIA, par exemple) où est située la zone CIC

en A1[4], le numéro de la zone dans le record p_ic.*

A1[4] = 1 : on utilise la zone ic_char3_1

A1[4] = 2 : on utilise la zone ic_char3_2

A1[4] = 3 : on utilise la zone ic_char30


TSC PMI Pointages effet miroir

Ce TSC est utilisé dans gen_cdef.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

char3_1

Pointages effet miroir suite à traitement des besoins matières

N pas d’effet miroir

O effet miroir

I effet miroir après inversion des pointages

Lors de la génération des commandes fournisseurs, il est possible d'envoyer les pointages sur la ligne de commande en fonction du nombre de poses.

On veut aussi pouvoir inverser les pointages en fonction du nombre de poses pour avoir un effet miroir.

Cela se fera suite à la saisie d'une information sur le FEFCO (dans un TSC).

Exemple

Soit un devis avec les pointages suivant pour un FEFCO 200 :

Lors de la génération de la commande fournisseur suite au traitement du besoin lié à la commande générée à partir de ce devis, on stockes les pointages :

446-10-30-314 446-10-30-314 446-10-30-314 446-10-30-314

Avec l'effet miroir, on stockes les pointages :

446-10-30-314 314-30-10-446 446-10-30-314 314-30-10-446

19/04/2010 : On peut aussi inverser les pointages avant de faire l'effet miroir

Soit les pointages suivants en 2 poses : 154 – 103

L'effet miroir donnera : 154 – 103 -103 -154

Si on inverse les pointages avant, l'effet miroir donnera : 103 – 154 – 154 -103

L'option Opp doit être positionnée.


TSC PPV Pression de cerclage vertical

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1

Pression cerclage vertical (O/N) - utilisé dans gdf_ond (Transfert PCTOPP - OTDATA)


TSC PRC Prélèvement client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Prélèvement périodique sur Client

Type F

Clé = code client

A ic_date1 | INUTILISE
B ic_date2 | Date du dernier prélèvement
C ic_num1 | Délai de contrôle / livraison
D ic_num2 | Nombre de jours entre 2 prélèvements
E ic_num3 | INUTILISE
F ic_char3_1 | Type de prélèvement (NOR, SYS, PRO, N)
G ic_char30 | Type de contrôle
H ic_char3_2 | Niveau de contrôle

Ces valeurs sont modifiables sur F31 de la fiche tiers.

Pour que ce mode de fonctionnement soit valide, la date du dernier prélèvement ET le nombre de jours entre 2 prélèvements doivent être renseignés.

Voir aussi le TSC PRP.


TSC PRL Prélèvement

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Prélèvement commande.

Type de clé : Commande (entête ou ligne)

A ic_date1 | Date de référence (délai de fabrication de la commande)
C ic_num1 | Quantité à prélever
F ic_char3_1 | Commande prélevée (O/N)
G ic_char30 | Type de prélèvement (CLI/PF/EST/FOR/NON)


TSC PRP Prélèvement produit

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Prélèvement périodique sur Produit

Type P

Clé = code produit

A ic_date1 | INUTILISE
B ic_date2 | Date du dernier prélèvement
C ic_num1 | Délai de contrôle / livraison
D ic_num2 | Nombre de jours entre 2 prélèvements
E ic_num3 | INUTILISE
F ic_char3_1 | Type de prélèvement (NOR, SYS, PRO, N)
G ic_char30 | Type de contrôle
H ic_char3_2 | Niveau de contrôle

Ces valeurs sont modifiables sur F31 de la fiche produit.

Pour que ce mode de fonctionnement soit valide, la date du dernier prélèvement ET le nombre de jours entre 2 prélèvements doivent être renseignés.

Voir aussi le TSC PRC.


TSC PVT Prix de vente tarif

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est est paramétré dans facn A2[13,15].

ic_char3_1 | Type paramètre de configuration de la recherche du prix de vente dans les tarifs
ic_char30 | Recherche du prix de vente dans les tarifs
ic_char3_2 | Code paramètre de configuration de la recherche du prix de vente dans les tarifs

Le paramètre de configuration de la recherche du prix de vente dans les tarifs est similaire à #CF TAR mais il n'y a pas de valeur par défaut.


TSC QPC Quantité de palettes complètes

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC de type A est utilisé par le devis onduleur (options Oog , Opc et Ot1) et l'édition du devis onduleur (option Opc).

ic_num1 | Quantité de base de l'offre
ic_num2 | Quantité de palettes complètes de l'offre
ic_char3_1 | Information forcée (O/N, N par défaut)


TSC QRP Quantité de remise de prix

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

ic_char3_1 | Code remise de prix
ic_char3_2 | Affichage du grammage papier dans l'édition de la remise de prix


TSC QVC Qualité de vente client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé par le devis multi-métiers.

ic_num_1

Qualité de vente minimale à atteindre pour ce client.

Cette valeur est prioritaire à celle de la note _TIT_INDIC.

Voir aussi le code blocage du devis BLD A1[3,5] = 002.


TSC RAL Contrôle de livraison

Ce TSC est opérationnel à partir de la V. 4.1.26.2

Il utilisé par la saisie de commande client.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Code de l'adresse secondaire. S'il n'est pas renseigné, et qu'ic_char30 est renseigné, alors le regroupement se fait sur l'adresse principale du client.
G | ic_char30 | Code client. S'il n'est pas renseigné, l'adresse correspondante ne fait pas l'objet d'un regroupement d'adresses.
H | ic_char3_2 |


TSC RCL Regroupement Client

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V.4.0.206.2

Il est utilisé dans facn, option Ora.

TSC sur client facturé

A | ic_date1 |
B | ic_date2 |
C | ic_num1 |
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Regroupement des lignes de facture de la même référence (article) (O/N, N par défaut) L'option Ora doit être activée pour facn.
G | ic_char30 |
H | ic_char3_2 |


TSC RGP Regroupement de stocks sur articles

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est utilisé conjointement avec la note REGROUP_STOCK_ART

ic_char30

Regroupement de stocks sur articles


TSC SBL Paramètre de lancement de la saisie de BL

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce paramétrage permet le lancement de la saisie de BL depuis exped_affretements.

ic_char3_1 | Type de paramètre de lancement de la saisie de BL
ic_char3_2 | Code de paramètre de lancement de la saisie de BL

Fonctionnement en cascade : Lors de la génération de BL dans exped_affretement, on recherche d'abord les paramètres de lancement sur le TSC SBL dont la clé est :

code client, adresse de livraison

si non trouvé : code client

si non trouvé : le paramètre de lancement par défaut qui correspond à la note RUN_SAISIE_BL paramétrée sur le paramètre de lancement du programme exped_affretement.

ATTENTION : lors de la génération du BL, la numérotation du numéro BL (annuelle ou non) est conditionnée par le paramétrage du programme de saisie de BL qui est lancé après la génération.


TSC SDP Scénario de prix

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V.4.0.182.2

Il est utilisé dans le cadre de la décomposition des prix des éléments (revient/vente standard).

Cette fonctionnalité fait partie du devis multi-métiers : elle est donc documentée dans ce chapitre : Plus d'info

Ce TSC est recherché en priorité sur le sous-devis, puis sur le client du sous-devis.

ic_char3_1

Code scénario de la décomposition de prix


TSC SEB Solde EDI BRC

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Valeur numérique 1 | Tonnage camion complet | Si cette info n'est pas renseignée, elle est recherchée sur G_v_edi_brc dans la note POIDS_CAMION_COMPLET.
Valeur numérique 2 | Tonnage minimum en réception pour solde camion complet | Si cette info n'est pas renseignée, elle est recherchée sur G_v_edi_brc dans la note TONNAGE_MINI_COMPLET.
Valeur numérique 3 | Pourcentage de tonnage minimum réceptionné pour solde en camion incomplet | Si cette info n'est pas renseignée, elle est recherchée sur G_v_edi_brc dans la note POUR_MINI_POUR_SOLDE.

TSC SE1 Solde EDI BRC (suite)

Valeur numérique 1

Pourcentage maximum de livraison

Si cette info n'est pas renseignée, elle est recherchée sur G_v_edi_brc dans la note POUR_MAXI_LIVRAISON.


TSC SM1 Valeurs mini/maxi par défaut dans le sens machine

Ce TSC est opérationnel à partir de la V. 4.0.195.2

Il est utilisé par le devis onduleur, pour le contrôle des mini/maxi ouverture/poussée pour une pose sur la machine.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C | ic_num1 | Valeur minimum dans le sens poussée pour le contrôle machine 002, pour exactement une pose. Correspond au sens machine dans la saisie des machines.
D | ic_num2 | Valeur maximum dans le sens poussée pour le contrôle machine 002, pour exactement une pose. Correspond au sens machine dans la saisie des machines.


TSC ST1 Valeurs mini/maxi par défaut dans le sens travers

Ce TSC est opérationnel à partir de la V. 4.0.195.2

Il est utilisé par le devis onduleur, pour le contrôle des mini/maxi ouverture/poussée pour une pose sur la machine.

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C | ic_num1 | Valeur minimum dans le sens ouverture pour le contrôle machine 001, pour exactement une pose. Correspond au sens travers dans la saisie des machines.
D | ic_num2 | Valeur maximum dans le sens ouverture pour le contrôle machine 001, pour exactement une pose. Correspond au sens travers dans la saisie des machines.


TSC STR Sous-traitance

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 |
B | ic_date2 |
C | ic_num1 | Délai
D | ic_num2 |
E | ic_num3 |
F | ic_char3_1 | Retour magasin
G | ic_char30 | Code sous-traitant
H | ic_char3_2 |


TSC TFF Transfert de factures fournisseurs

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Utilisé dans G_tr_fac_fou - GENERO uniquement

ic_char30

Compte d'achat


TSC TJV Transfert du Journal de Ventes

Ce TSC est opérationnel à partir de la V.4.1.3.2

Il est utilisé dans le cadre de l'importation d'un ou des fichiers du fournisseur pour le rapprochement des factures

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

A | ic_date1 | Date de la demande
B | ic_date2 | Date de traitement
C | ic_num1 | Heure de la demande
D | ic_num2 | Heure de traitement
E | ic_num3 | inutilisé
F | ic_char3_1 | à traiter
G | ic_char30 | "JournalV"
H | ic_char3_2 | inutilisé


TSC TMT Types de matières

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

TSC sur produit de l'OF de la ligne.

char3_1

La zone char_1 initialise le type de matière

- Si la ligne est une ligne matière, dans la Saisie journalière par salarié

- Dans l'écran des remontées matières (Touche F6), dans la Saisie des temps par dossier


TSC TOF Type d'offre

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

F - char3_1 | Type d'offre A Délai annoncé S Stock F Délai fixe I Ignoré (client ignoré dans le calcul de la charge)
G - char30 | Origine du délai
H - char3_2 | Code


TSC TRS Gestion AVIEXP

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

C - num1 | Temps de transport
D - num2 | Heure fixe
F - char3_1 | Type de client O Gestion AVIEXP type Peugeot (avec CALDEL détaillé par palette) S Gestion AVIEXP type Renault (avec CALDEL sans détail palette) A Gestion AVIEXP seul (AVIEXP de base, sans CALDEL, sans étiquettes GALIA) E Le client souhaite uniquement les étiquettes GALIA, sans génération d21,60 AVIEXP N Pas de gestion AVIEXP (par défaut). Il n21,60 y aura pas de fichier AVIEXP géré pour le client.
G - char30 | Boite à lettres PSA
H - char3_2 | Contrôle présence de N° véhicule en saisie de BL (W, B, ...)

dans blv_ed1, si gestion AVIEXP (zone F <> N), on doit éditer un BL.

dans KP_blv_ed1, si client AVIEXP sans détail palette (zone F = S ou A)

insertion de l'étiquette dans la table etiqprod

insertion de notes de type EMB dans cde3.

dans blv, si gestion AVIEXP (zone F <> N), on teste la saisie du véhicule en fonction de la zone H.

dans blv, si gestion AVIEXP (zone F <> N), mise à jour du flag de gestion des notes de type EMB sur cde3

dans blv, si gestion AVIEXP PEUGEOT (zone F = O), il faut contrôler que l'on ne sort pas plus de palettes que d'emballages prévus.

Le nombre d'emballages prévus non expédiés pour la ligne de commande est donné par les notes de type EMB sur cde3.


TSC TVA Informations TVA

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

F - char3_1 | Fournisseur lié à un compte TVA à échéance sur facture (O/N, N par défaut)
H - char3_2 | Code TVA associé au client adresse secondaire


TSC VCA Visa du cariste

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Notes

char 3_1

Visa du cariste


TSC VCS Vecteur de Communication Simplifié

Aide générale sur les TSC

Syntaxe d'appel des TSC

Codes zones des TSC

Ce TSC est opérationnel à partir de la V.4.0.206.2

Il est utilisé dans #CF FAC.

TSC de type 0 (facture)

A | ic_date1 | inutilisé
B | ic_date2 | inutilisé
C | ic_num1 | inutilisé
D | ic_num2 | inutilisé
E | ic_num3 | inutilisé
F | ic_char3_1 | inutilisé
G | ic_char30 | Code VCS
H | ic_char3_2 | inutilisé


Généralités sur les packages

Les packages sont des ensembles de zones utilisés dans les programmes de visualisation.

Exemple : le package Tiers contient l'ensemble des champs de la table cli ainsi que les différents libellés.

Actuellement, ces champs sont répétés pour chaque aide de programme de visualisation, ce qui est source d'inconvénients :

- Redondance de l'information

- Mauvaise visibilité de l'aide des programmes de visualisation

- Risque d'oubli

Pour pallier ces inconvénients, nous allons petit à petit remplacer des chapitres entiers de l'aide des programmes de visualisation par des liens vers des chapitres partagés que sont les descriptions des packages.


Package "standard"

Contenu du package "standard", utilisable à partir de la V.4.1.38.2

Ce package est potentiellement utilisable dans toutes les visualisations.

Pour l'instant (15/07/2013), il n'est réellement utilisable que dans la visu des mouvements de stocks.

Il contient les zones suivantes :

std_num_lignes | Numéro de toutes les lignes dans la visu
std_num_lignes_detail | Numéro des lignes détails seulement
std_num_compteur | Numéro du compteur
std_date | Date du lancement de traitement
std_heure | Heure du lancement de traitement


Package action_evt

Contenu du package Actions - Evénements

1) Toutes les zones de la table action_evt

2) Les zones suivantes de la table action_evt (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ace_sit Libellé court du site de production

libl_ace_sit Libellé long du site de production

ace_cloture_par | Action clôturée par
ace_code | Code action / événement
ace_cree_par | Action créée par
ace_etape | Code étape
ace_gere_par | Action gérée par
ace_qual | Qualificatif de l'état
ace_sit | Site de production
ace_type | Type d'action / événement

3) Autres zones

lib_priorite libl_ace_priorite | Libellé de la priorité (ace_priorite)
lib_etat libl_ace_etat | Libellé de l'état (ace_etat)


Package affaire

Contenu du package Affaires

1) Toutes les zones de la table affaire

2) Les zones suivantes de la table affaire (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_af_scenario Libellé court du scénario

libl_af_scenario Libellé long du scénario

af_etape | Etape du scénario
af_etat | Etat de l'affaire
af_qualificatif | Qualificatif d'état
af_scenario | Code de scénario
af_suivi_par | Code de suivi

Particularités

Dans certaines visus (v_action_evt), on peut accéder au flux.

Le flux est stocké dans la zone ace_nom_flux de la table action_evt.

Faire précéder la zone de flu_.

Exemple

flu_af_num_affaire


Package b_rec_ret_d

Contenu du package Bons de Réception et de Retour (Lignes)

1) Toutes les zones de la table b_rec_ret_d

2) Les zones suivantes de la table b_rec_ret_d peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_brd_certification Libellé court de la certification

libl_brd_certification Libellé long de la certification

brd_certification

Code certification (FSC, PEFC)


Package b_rec_ret_e

Contenu du package Bons de Réception et de Retour (Entête)

1) Toutes les zones de la table table b_rec_ret_e

2) Les zones suivantes de la table b_rec_ret_e (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_bre_preparateur Libellé court du préparateur

libl_bre_preparateur Libellé long du préparateur

bre_devise | Code devise
bre_preparateur | Code préparateur
bre_site | Site de production

3) Autres zones

lib_bre_statut | Statut (provisoire, Définitif)
lib_bre_type_bon | Type de bon (C = Réception - T = Retour)


Package blv1

Contenu du package Bons de Livraison (Entête)

1) Toutes les zones de la table blv1

2) Les zones suivantes de la table blv1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_b1_sitp Libellé court du site de production

libl_b1_sitp Libellé long du site de production

b1_devise | Devise
b1_lieu_rgt1 | Lieu de rangement de niveau 1
b1_sitp | Site de production
b1_tport | Type de port
b1_trsp | Type de transport (Attention : pas de libellé long ! Seul le libellé court est disponible).
b1_tvae | TVA Emballage
b1_type_vehicule | Type de véhicule

3) Autres zones

nom_b1_cli | Nom du client
nom_b1_trans | Nom du transporteur
nom_b1_transitaire | Nom du transitaire

Attention : les zones commençant par b1_ ci-dessous ne sont pas des zones de la table blv1.

Elles sont issues de la zone b1_adrl (Adresse le livraison) qui, elle, figure dans la table blv1.

b1_adrl_adr1 | Ligne 1
b1_adrl_adr2 | Ligne 2
b1_adrl_codp | Code postal
b1_adrl_nom | Nom
b1_adrl_pays | Pays (+ libellé court et long)
b1_adrl_telcop | Télécopie
b1_adrl_telex | Télex
b1_adrl_telph1 | Téléphone 1
b1_adrl_telph2 | Téléphone 2
b1_adrl_ville | Ville


Package blv2

Contenu du package Bons de Livraison (Lignes)

1) Toutes les zones de la table blv2

2) Les zones suivantes de la table blv2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_b2_certification Libellé court de la certification

libl_b2_certification Libellé long de la certification

b2_certification

Certification FSC / PEFC

3) Autres zones

lib_b2_type_livraison

Libellé du type de livraison


Package bon_retour_cli_1

Contenu du package Bons de Retour Clients (Entête)

1) Toutes les zones de la table bon_retour_cli_1

2) Les zones suivantes de la table bon_retour_cli_1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_br1_site_prod Libellé court du site de production

libl_br1_site_prod Libellé long du site de production

br1_site_prod | Site de production
br1_type | Type de bon de retour
br1_type_vehicule | Type de véhicule


Package bon_retour_cli_2

Contenu du package Bons de Retour Clients (Lignes)

1) Toutes les zones de la table bon_retour_cli_2

2) Les zones suivantes de la table bon_retour_cli_2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_br2_rgt1 Libellé court du lieu de rangement 1

libl_br2_rgt1 Libellé long du lieu de rangement 1

br2_motif_retour | Motif du retour
br2_rgt1 | Lieu de rangement 1


Package ccout0

Contenu du package Centres de Coût

1) Toutes les zones de la table ccout0

2) Les zones suivantes de la table ccout0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_c0_uo Libellé court de l'unité d'oeuvre

libl_c0_uo Libellé long de l'unité d'oeuvre

c0_niveau | Code niveau du centre de coût
c0_type | Code type de section
c0_uo | Code unité d'oeuvre

3) Autres zones

des_c0_f_ou_v

Description des frais fixes ou variables


Package ccout1

Ce package est utilisable à partir de la V. 4.0.186.2

Contenu du package Taux Mensuels des Centres de Coût

1) Toutes les zones de la table ccout1

2) Les zones suivantes de la table ccout1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_c1_etiquette Libellé court de l'étiquette

libl_c1_etiquette Libellé long de l'étiquette

c1_etiquette | Étiquette du centre de coût
c1_utilisation | Utilisation du centre de coût

3) Autres zones

lib_c1_code

Code du centre de coût


Package cde_cad_fab

Contenu du package Cadencements de Fabrication

1) Toutes les zones de la table cde_cad_fab

2) Les zones suivantes de la table tar0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ccf_statut_prod Libellé court du statut du produit

libl_ccf_statut_prod Libellé long du statut du produit

ccf_statut_prod | Statut du produit
ccf_type_cad | Type de cadencement
ccf_type_enr | Type d'enregistrement (Attention : pas de libellé long ! Seul le libellé court est disponible).

3) Autres zones

Attention : certaines de ces zones sont préfixées ccf_, mais elles ne font pas partie de la table cde_cad_fab !

ccf_delai_avance | Délai avancé (comparé à ccf_dern_date_pla)
ccf_delai_recule | Délai reculé (comparé à ccf_dern_date_pla)
ccf_heure_deb_ordo | Heure de début de tâche ordonnancée (récupérée à partir de ccf_date_deb_ordo)
ccf_heure_fin_ordo | Heure de fin de tâche ordonnancée (récupérée à partir de ccf_date_fin_ordo)
des_ccf_prod | Désignation du code article


Package cde1

Contenu du package Commandes Clients (Entête)

1) Toutes les zones de la table cde1

2) Les zones suivantes de la table cde1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ec_rep Libellé court du représentant

libl_ec_rep Libellé long du représentant

ec_cr | Code remise
ec_ct | Code tarif
ec_devise | Code devise
ec_ech | Code échéance
ec_mrg | Code mode de règlement
ec_rep | Code représentant
ec_suiv | Code suivi d'affaire
ec_titre | Titre du correspondant attaché à la commande
ec_tour | Code tournée
ec_tport | Code type de port
ec_trsp | Mode de transport
ec_tvap | Code TVA sur le port
ec_tyc | Type de la commande
ec_type_liaison | Code type de liaison
ec_web_statut | Code statut pour les commandes web

3) Autres zones

mois_commande | Mois de la commande (récupéré à partir de ec_datc)
nom_ec_ada | Adresse de l'AR
nom_ec_cli | Nom du client
nom_ec_cli_final_adr | Adresse du client final
nom_ec_transp | Nom du transporteur
semaine_commande | Semaine de la commande (récupéré à partir de ec_datc)
ville_ec_ada | Ville de l'adresse de l'AR
ville_ec_adf | Ville de l'adresse de facturation
ville_ec_adl | Ville de l'adresse de livraison
ville_ec_cli_final_adr | Ville de l'adresse du client final
zc1_ec_tvap | Valeur numérique 1 du code TVA sur le port


Package cde2

Contenu du package Commandes Clients (Lignes)

1) Toutes les zones de la table cde2

2) Les zones suivantes de la table cde2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_lc_fam Libellé court de la famille

libl_lc_fam Libellé long de la famille

lc_bareme | Code barème
lc_certification | Code certification FSC / PEFC
lc_cs1 | Code statistique 1
lc_cs2 | Code statistique 2
lc_cs3 | Code statistique 3
lc_cs4 | Code statistique 4
lc_fam | Code famille
lc_lieu_rgt1 | Lieu de rangement 1
lc_motif_mod_date | Motif de modification de date de revue de contrat
lc_par_tyc | Code paramètre rattaché au type de commande
lc_priorite | Niveau de priorité de la commande
lc_qualif_appel | Qualificatif de l'appel de livraison
lc_repr | Code représentant
lc_sfm | Code sous-famille
lc_tolerance_liv | Code tolérance de livraison
lc_tva | Code TVA
lc_unvent | Unité de vente
lc_unvent_au | Unité de vente au plus ou au moins

3) Autres zones

le_lib_par1 | Libellé spécifique de l'article
le_libelle | Libellé étranger
le_libelle2 | Complément au libellé étranger
lib_lc_prod | Libellé du produit
lib_par1 | Libellé
montant_lc_marge | Montant de la marge
type_sfm_lc_sfm | Type de sous famille de la sous famille de la ligne de commande
ville_lc_adl | Ville de l'adresse de livraison
zc1_lc_tva | Valeur numérique 1 du code TVA
zc1_lc_unvent | Valeur numérique 1 de l'unité de vente
zc1_lc_unvent_au | Valeur numérique 1 de l'unité de vente au plus ou au moins
zc1_lc_tolerance_liv | Pourcentage de tolérance minimum associé à la quantité de base Remarque : Si la tolérance n'est pas gérée par quantité ou si la quantité de base n'est pas trouvée, il s'agit de la zone numérique 1 du paramètre TOL
zc2_lc_tolerance_liv | Pourcentage de tolérance maximum associé à la quantité de base Remarque : Si la tolérance n'est pas gérée par quantité ou si la quantité de base n'est pas trouvée, il s'agit de la zone numérique 2 du paramètre TOL
min_lc_tolerance_liv | Quantité minimum autorisée = Quantité de base à laquelle on retire le pourcentage de tolérance minimum (voir ci-dessus)
max_lc_tolerance_liv | Quantité maximum autorisée = Quantité de base à laquelle on ajoute le pourcentage de tolérance maximum (voir ci-dessus)
lib_lc_tolerance_liv | Libellé de plage de quantité Le libellé apparaît sous l'une des 4 formes suivantes : Quantités illimitées zc1_lc_tolerance_liv n'est pas renseignée. zc2_lc_tolerance_liv n'est pas renseignée. Quantité minimum : [min_lc_tolerance_liv] zc1_lc_tolerance_liv est renseignée. zc2_lc_tolerance_liv n'est pas renseignée. Quantité maximum : [max_lc_tolerance_liv] zc1_lc_tolerance_liv n'est pas renseignée. zc2_lc_tolerance_liv est renseignée. Plage de quantités : [min_lc_tolerance_liv] à [max_lc_tolerance_liv] zc1_lc_tolerance_liv est renseignée. zc2_lc_tolerance_liv est renseignée.

Attention : les zones commençant par lc_ ci-dessous ne sont pas des zones de la table cde2.

Elles sont issues de zones de la table cde2.

lc_delcli_aamm | Mois de livraison souhaité au format AAAAMM
lc_delcli_aass | Semaine de livraison souhaitée au format AAAASS
lc_deldep_aamm | Mois de départ au format AAAAMM
lc_deldep_aass | Semaine de départ au format AAAASS
lc_deldep_au_plus_tot | Date de départ au plus tôt
lc_delfab_aamm | Année de fin de fabrication au format AAAAMM
lc_delfab_aass | Semaine de fin de fabrication au format AAAASS
lc_delrea_aass | Semaine de réalisation
lc_delrep_aamm | Mois de livraison répondu prévu au format AAAAMM
lc_delrep_aass | Semaine de livraison répondue prévue au format AAAASS


Package cde4

Contenu du package Nomenclature ligne de commande

1) Toutes les zones de la table cde4

2) Les zones suivantes de la table ce4 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_nc_rgt1 Libellé court du lieu de rangement 1

libl_nc_rgt1 Libellé long du lieu de rangement 1

nc_rgt1

Lieu de rangement 1

3) Autres zones

des_nc_prod

Désignation de l’article


Package cde8

Contenu du package Cadencements de Livraison Prévisionnels

1) Toutes les zones de la table cde8

2) Les zones suivantes de la table cdf8 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_li_rgt Libellé court du lieu de rangement

libl_li_rgt Libellé long du lieu de rangement

li_civ_corres | Civilité du correspondant
li_etat | Etat
li_motif_qualif | Motif du qualificatif
li_pays | Pays
li_qua | Qualificatif d'appel
li_rgt | Lieu de rangement
li_tco_corres | Titre du correspondant
li_tolerance_liv | Tolérance de livraison

3) Autres zones

nom_li_transp | Nom du transporteur
zc1_li_tolerance_liv | Pourcentage de tolérance minimum associé à la quantité de base Remarque : Si la tolérance n'est pas gérée par quantité ou si la quantité de base n'est pas trouvée, il s'agit de la zone numérique 1 du paramètre TOL
zc2_li_tolerance_liv | Pourcentage de tolérance maximum associé à la quantité de base Remarque : Si la tolérance n'est pas gérée par quantité ou si la quantité de base n'est pas trouvée, il s'agit de la zone numérique 2 du paramètre TOL
min_li_tolerance_liv | Quantité minimum autorisée = Quantité de base à laquelle on retire le pourcentage de tolérance minimum (voir ci-dessus)
max_li_tolerance_liv | Quantité maximum autorisée = Quantité de base à laquelle on ajoute le pourcentage de tolérance maximum (voir ci-dessus)
lib_li_tolerance_liv | Libellé de plage de quantité Le libellé apparaît sous l'une des 4 formes suivantes : Quantités illimitées zc1_li_tolerance_liv n'est pas renseignée. zc2_li_tolerance_liv n'est pas renseignée. Quantité minimum : [min_li_tolerance_liv] zc1_li_tolerance_liv est renseignée. zc2_li_tolerance_liv n'est pas renseignée. Quantité maximum : [max_li_tolerance_liv] zc1_li_tolerance_liv n'est pas renseignée. zc2_li_tolerance_liv est renseignée. Plage de quantités : [min_li_tolerance_liv] à [max_li_tolerance_liv] zc1_li_tolerance_liv est renseignée. zc2_li_tolerance_liv est renseignée.

4) Zones cumulables et utilisables dans les formules de calcul

li_montant | Montant
li_poids | Poids
li_qte_en_retour | Quantité retournée
li_qte_liv_fact | Quantité livrée facturable
li_qte_liv_reel | Quantité livrée réelle
li_qteliv | Quantité commandée
li_qteliv_ini | Quantité d'appel initiale
li_surface | Surface


Package cde9_e

Ce package est disponible à partir de la V. 4.1.28.2

Contenu du package Commandes Papeterie (Entête)

Toutes les zones de la table cde9_e


Package cde9_l

Ce package est disponible à partir de la V. 4.1.28.2

Contenu du package Commandes Papeterie (Lignes)

Toutes les zones de la table cde9_l


Package cdf1

Contenu du package Commandes Fournisseurs (Entête)

1) Toutes les zones de la table cdf1

2) Les zones suivantes de la table cdf1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ef_rgt Libellé court du lieu de rangement

libl_ef_rgt Libellé long du lieu de rangement

ef_ach | Code acheteur
ef_cr | Code remise
ef_ct | Code tarif
ef_devise | Code devise
ef_ech | Code échéance
ef_mrg | Mode de règlement
ef_rgt | Lieu de rangement
ef_signature | Code signature
ef_titre | Titre du correspondant attaché à la commande
ef_transport | Type de transport
ef_tyc | Type de commande

3) Autres zones

nom_ef_client_liv | Nom du client livré
nom_ef_fou | Nom du fournisseur
ville_ef_ada | Ville de l'adresse d'envoi de la commande
ville_ef_adf | Ville de l'adresse de facturation
ville_ef_adl | Ville de l'adresse de réception de la marchandise
ville_ef_adst | Ville du lieu de sous-traitance chez le fournisseur


Package cdf2

Contenu du package Commandes Fournisseurs (Lignes)

1) Toutes les zones de la table cdf2

2) Les zones suivantes de la table cdf2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_lf_rgt Libellé court du lieu de rangement

libl_lf_rgt Libellé long du lieu de rangement

lf_fam | Code famille
lf_rgt | Code lieu de rangement
lf_sfm | Code sous-famille
lf_tva | Code TVA
lf_unacha | Code unité d'achat
lf_certification | Code certification (FSC, PEFC)

3) Autres zones

lib_lf_cdc | Libellé du centre de coût
nom_lf_cli | Nom du client
v1_lf_unacha | Valeur numérique de l'unité d'achat
ville_lf_adl | Ville de l'adresse de réception
ville_lf_adst | Ville de l'adresse de sous-traitance chez le fournisseur

Attention : les zones commençant par lf_ ci-dessous ne sont pas des zones de la table cdf2.

Elles sont issues de zones de la table cdf2.

lf_prxuu | PU d'achat dans l'unité d'utilisation
lf_prxuu_dev | PU d'achat en devise dans l'unité d'utilisation
lf_prxuu_euro | PU d'achat en euro dans l'unité d'utilisation


Package cdf4

Contenu du package Cadencements de Livraison Fournisseurs

1) Toutes les zones de la table cdf4

2) Les zones suivantes de la table cdf4 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ml_rgt Libellé court du lieu de rangement

libl_ml_rgt Libellé long du lieu de rangement

ml_rgt

Lieu de rangement

3) Autres zones

ville_ml_adl

Ville de l'adresse de réception


Package cli

Contenu du package Tiers

1) Toutes les zones de la table cli

2) Les zones suivantes de la table cli (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_cl_repr Libellé court du code représentant

libl_cl_repr Libellé long du code représentant

cl_act | Code secteur d'activité
cl_agrement | Code agrément
cl_cat | Code catégorie client
cl_certification | Code certification
cl_corres_civilite | Code civilité du correspondant
cl_dev | Code devise
cl_ech | Code échéance
cl_geo | Code secteur géographique
cl_incoterm | Code condition de port
cl_langue | Code langue
cl_mailing | Code type de mailing associé au client
cl_mrg | Code mode de règlement
cl_orig | Code origine
cl_pays | Code pays
cl_perf | Code périodicité de facturation
cl_perr | Code périodicité de relevés de factures
cl_qual | Code forme juridique
cl_qualif_appel | Code qualificatif de l'appel de livraison
cl_qualite | Code qualité du client
cl_rem | Code remise
cl_repr | Code représentant
cl_suiv | Code suivi d'affaire
cl_tar | Code tarif
cl_titre | Code titre du correspondant
cl_tolerance_liv | Code tolérance de livraison
cl_tour | Code tournée
cl_tournee_liv | Code tournée de livraison
cl_trsp | Code type de transport
cl_validite_adr | Code validité d'adresse

3) Données diverses

La zone cl_param peut être divisée en autant de paramètres pour obtenir le paramètre lui-même et son libellé.

cl_param_01 libl_cl_param_01 | Paramètre 1 des données diverses de la fiche tiers Libellé du paramètre 1
... |
cl_param_22 libl_cl_param_22 | Paramètre 22 des données diverses de la fiche tiers Libellé du paramètre 22

4) Autres zones

nom_cl_clifact | Nom du client facturé
nom_cl_cligr | Nom du client groupe
nom_cl_cligr2 | Nom du client commun au groupe
nom_cl_codef | Nom du client chez le fournisseur
nom_cl_groupe_risque | Nom du client utilisé pour le calcul du risque groupe
nom_cl_transp | Nom du transporteur

Particularités

Dans certaines visus (à recenser), toutes les zones figurant sur cette page peuvent être préfixées de f_ quand il s'agit du client final de la commande.


Package cli2

Contenu du package Adresses secondaires

1) Toutes les zones de la table cli2

2) Les zones suivantes de la table cli2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_c2_repr Libellé court du code représentant

libl_c2_repr Libellé long du code représentant

c2_corres_civilite | Code civilité du correspondant
c2_devise | Code devise
c2_ech | Code échéance
c2_geo | Code secteur géographique
c2_langue | Code langue
c2_mrg | Code mode de règlement
c2_pays | Code pays
c2_qual | Forme juridique
c2_qualif_appel | Code qualificatif appel de livraison
c2_repr | Code représentant
c2_titre | Code titre du correspondant
c2_tolerance_liv | Code tolérance de livraison
c2_tournee_liv | Code tournée de livraison
c2_tport | Code type de port
c2_trsp | Code type de transport
c2_validite_adr | Code validité adresse secondaire

Particularités

Dans certaines visus (à recenser), toutes les zones figurant sur cette page peuvent être préfixées de f_ quand il s'agit du client final de la commande.


Package conteneur_info

Contenu du package Informations sur les conteneurs

1) Toutes les zones de la table conteneur_info

2) Autres zones

date_cni_datim_creation heure_cni_datim_creation | Date de création du conteneur Heure de création du conteneur Ces zones sont extraites de la zone cni_datim_creation
date_cni_datim_sortie heure_cni_datim_sortie | Date de sortie du conteneur Heure de sortie du conteneur Ces zones sont extraites de la zone cni_datim_sortie


Package conteneur_prod_det

Ce package est utilisable à partir de la V. 4.1.26.2

Contenu du package Conteneurs (Détail)

1) Toutes les zones de la table conteneur_prod_det

2) Autres zones

presence_prod_det

Permet de savoir s'il y a un détail du conteneur.

S'il y a un détail, alors une étoile est affichée.


Package conteneur_produit

Contenu du package Description du contenu des conteneurs

Toutes les zones de la table conteneur_produit


Package corres

Contenu du package Correspondants

1) Toutes les zones de la table corres

2) Les zones suivantes de la table corres (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_co_tco Libellé court du titre du correspondant

libl_co_tco Libellé long du titre du correspondant

co_civilite | Civilité du correspondant
co_tco | Titre du correspondant


Package dem_achat_cad

Contenu du package Commandes d'Achat - Cadencements de livraison

1) Toutes les zones de la table dem_achat_cad

2) Autres zones

nom_dac_fou | Nom du fournisseur
ville_dac_adl | Ville de livraison


Package dem_achat_ent

Contenu du package Entêtes des commandes d'Achat

1) Toutes les zones de la table dem_achat_ent

2) Les zones suivantes de la table dem_achat_ent (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_dae_demandeur Libellé court du demandeur

libl_dae_demandeur Libellé long du demandeur

dae_ach | Code acheteur
dae_demandeur | Code demandeur
dae_etat | Code état de la demande d'achat
dae_service | Code type de service
dae_sign | Code signataire
dae_site | Code site du demandeur
dae_type | Code type de demande d'achat


Package dem_achat_fou

Contenu du package Commandes d'Achat - Fournisseurs rattachés

1) Toutes les zones de la table dem_achat_fou

2) Les zones suivantes de la table dem_achat_fou (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_daf_etat Libellé court de l'état

libl_daf_etat Libellé long de l'état

daf_etat | Code état
daf_motif | Code motif
daf_uni | Code unité de prix
daf_val_fou | Code validité fournisseur

3) Autres zones

nom_daf_fou | Nom du fournisseur
ville_daf_adr | Ville du fournisseur


Package dem_achat_lig

Contenu du package Lignes des commandes d'Achat

1) Toutes les zones de la table dem_achat_lig

2) Les zones suivantes de la table dem_achat_lig (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_dal_corres_fonc Libellé court de la fonction

libl_dal_corres_fonc Libellé long de la fonction

dal_corres_civ | Code civilité
dal_corres_fonc | Code fonction
dal_etat | Code état de la ligne
dal_port | Code type de port
dal_rgt1 | Code lieu de stockage
dal_tol_delai | Code tolérance délai
dal_tol_qte | Code tolérance quantité
dal_unacha | Code unité d'achat

3) Autres zones

lib_dal_origine | Libellé de l'origine
lib_dal_prod | Libellé du produit
nom_dal_liv_cli | Nom du tiers livré
ville_dal_liv_adr | Ville du tiers livré


Package edi_stk_bobine

Contenu du package Intégration EDI des bobines en stock

1) Toutes les zones de la table edi_stk_bobine

2) Les zones suivantes de la table edi_stk_bobine (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_eds_code_lanceur Libellé court du lanceur

libl_eds_code_lanceur Libellé long du lanceur

eds_code_lanceur

Code lanceur

3) Autres zones

des_bobine_int | Description de la bobine VoluPack
lib_eds_code_erreur | Libellé d'erreur lors du traitement de la sortie
lib_eds_statut | Libellé du statut

Attention : les zones commençant par eds_ ci-dessous ne sont pas des zones de la table edi_stk_bobine.

Elles sont issues de zones de la table edi_stk_bobine.

eds_date_sor | Date de sortie (provenance eds_date_heure_sor)
eds_heure_sor | Date de sortie (provenance eds_date_heure_sor)


Package ef_std

Ce package est utilisable à partir de la V. 4.0.186.2

Contenu du package Effectifs Standards

1) Toutes les zones de la table ef_std

2) Autres zones

desig_es_machine | Désignation de la machine
lib_es_ccout | Libellé du centre de coût


Package emp

Contenu du package Employés

1) Toutes les zones de la table emp

2) Les zones suivantes de la table emp (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_em_qual Libellé court de la qualification de l'employé

libl_em_qual Libellé long de la qualification de l'employé

em_den | Dénomination
em_cal | Calendrier
em_qual | Qualification de l'employé

3) Autres zones

lib_em_plage

Libellé de la faction


Package fac0

Contenu du package Factures Clients (Entête)

1) Toutes les zones de la table fac0

2) Les zones suivantes de la table fac0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_fe_mrg Libellé court du mode de règlement

libl_fe_mrg Libellé long du mode de règlement

fe_dev | Code devise
fe_ech | Code échéance
fe_mrg | Code mode de règlement

3) Autres zones

fer_mtt_reglement | Règlements de la facture (table fac0_reglement)
ville_fe_adf | Ville de l'adresse de facturation
ville_fe_adl | Ville de l'adresse de livraison


Package fac1

Contenu du package Factures Clients (Lignes)

1) Toutes les zones de la table fac1

2) Les zones suivantes de la table fac1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_fl_unvent Libellé court de l'unité de vente

libl_fl_unvent Libellé long de l'unité de vente

fl_ctva | Code TVA
fl_unvent | Unité de vente


Package facfou0

Contenu du package Factures Fournisseurs (Entête)

1) Toutes les zones de la table facfou0

2) Les zones suivantes de la table facfou0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ff0_mrg Libellé court du mode de règlement

libl_ff0_mrg Libellé long du mode de règlement

ff0_dev | Code devise
ff0_ech | Code échéance
ff0_mrg | Mode de règlement

3) Autres zones

nom_ff0_fou | Nom du fournisseur
ville_ff0_adf | Ville de l'dresse de facturation


Package facfou1

Contenu du package Factures Fournisseurs (Lignes)

1) Toutes les zones de la table facfou1

2) Les zones suivantes de la table facfou1 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ff1_fconv Libellé court de la formule de conversion

libl_ff1_fconv Libellé long de la formule de conversion

ff1_ctva | Code TVA
ff1_fconv | Code formule de conversion
ff1_unachat | Code unité d'achat

3) Autres zones

des_ff1_article | Désignation de l'article
lib_ff1_cdc | Libellé du centre de coût
lib_ff1_cle_repart | Libellé de la clé de répartition
zc1_ff1_ctva | Valeur numérique 1 du code TVA
zc1_ff1_unachat | Valeur numérique 1 du code unité d'achat


Package fle_2

Contenu du package Définition générale du devis

1) Toutes les zones de la table fle_2

2) Les zones suivantes de la table fle2 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_l2_devise Libellé court du statut de la devise

libl_l2_devise Libellé long du statut de la devise

l2_bareme | Code barème
l2_civilite | Code civilité
l2_devise | Code devise
l2_deviseur | Code deviseur
l2_env_matiere | Code d'environnement matière
l2_env_operation | Code d'environnement opération
l2_etat | Code état
l2_fabricant | Code fabricant
l2_motif | Code motif
l2_representant | Code représentant
l2_sce_calcul | Code scénario de calcul
l2_signature | Code signature
l2_site | Code site de production
l2_suiv | Code suivi d'affaire
l2_tit_corres | Code titre du correspondant
l2_type_dev | Code type de devis
l2_type_finition | Code type de finition
l2_type_port | Code type de port
l2_type_prix | Code type de remise de prix
l2_type_prod | Code type de produit

3) Autres zones

des_l2_code_prod | Description du produit
nom_l2_client | Nom du client
nom_l2_transporteur | Nom du transporteur
z1_l2_etat | Valeur numérique 1 du code état


Package fle_dec

Contenu du package Décomposition de la Feuille

1) Toutes les zones de la table fle_dec

2) Les zones suivantes de la table fle_dec (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_de_fam Libellé court du code famille

libl_de_fam Libellé long du code famille

de_cs1 | Code statistique 1
de_cs2 | Code statistique 2
de_cs3 | Code statistique 3
de_cs4 | Code statistique 4
de_fam | Famille
de_sfm | Sous-famille
de_typ_ent | Type d'entité
de_type_pli | Type de pli
de_type_pli1 | Type de pli 1
de_type_pli2 | Type de pli 2
de_type_pli3 | Type de pli 3
de_type_pli4 | Type de pli 4
de_type_pli5 | Type de pli 5

3) Autres zones

des_de_produit

Description du produit


Package fle_imp

Contenu du package Entités du Devis

1) Toutes les zones de la table fle_imp

2) Les zones suivantes de la table fle_imp (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_fi_fam Libellé court du code famille

libl_fi_fam Libellé long du code famille

fi_couleur_pap | Couleur du papier
fi_cs1 | Code statistique 1
fi_cs2 | Code statistique 2
fi_cs3 | Code statistique 3
fi_cs4 | Code statistique 4
fi_encart_fac | Type de façonnage pour l'encart
fi_fam | Famille
fi_sfm | Sous-famille
fi_sit | Site de production
fi_typ_ent | Type d'entité
fi_type_pellic | Type de pelliculage
fi_type_vernis_r | Type de vernis recto
fi_type_vernis_v | Type de vernis verso
fi_vernis_hl | Vernis hors-ligne

3) Autres zones

des_fi_c_papier | Description du papier ou carton
des_fi_prod_ent | Description du produit de l'entité
nom_fi_fournisseur | Nom du fournisseur


Package formules

Ce package est utilisable à partir de la V. 4.1.31.2

Contenu du package Formules

1) Toutes les zones de la table formules

2) Les zones suivantes de la table formules (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ul_phase Libellé court de la phase

libl_ul_phase Libellé long de la phase

ul_classe

ul_fab_sec

ul_lcom

ul_nature_frais

ul_nature_montant

ul_phase

ul_phase_ut

ul_sclasse

ul_sec

ul_ssf

ul_tarif_achat

ul_tarif_vente

ul_typmac

ul_uni_prod

3) Autres zones

lib_uldef_prod

4) Décomposition de la zone ul_param

ul_param_XX | où XX = 01 à 36
lib_ul_param_XX | Libellé de la valeur du paramètre

5) Codes, dépendances et autres

dep_code_calcul_v1_a dep_code_calcul_v1_b dep_code_calcul_v1_c dep_code_calcul_v1_d dep_code_calcul_v1_e dep_code_calcul_v1_f dep_code_calcul_v1_g dep_code_calcul_v1_h dep_code_calcul_v1_i dep_code_calcul_v1_j dep_code_calcul_v1_k dep_code_calcul_v1_l dep_code_calcul_v1_m dep_code_calcul_v1_n dep_code_calcul_v1_o | dep_param_calcul_v1_a dep_param_calcul_v1_b dep_param_calcul_v1_c dep_param_calcul_v1_d dep_param_calcul_v1_e dep_param_calcul_v1_f dep_param_calcul_v1_g dep_param_calcul_v1_h dep_param_calcul_v1_i dep_param_calcul_v1_j dep_param_calcul_v1_k dep_param_calcul_v1_l dep_param_calcul_v1_m dep_param_calcul_v1_n dep_param_calcul_v1_o
dep_code_calcul_v2_a dep_code_calcul_v2_b dep_code_calcul_v2_c dep_code_calcul_v2_d dep_code_calcul_v2_e dep_code_calcul_v2_f dep_code_calcul_v2_g dep_code_calcul_v2_h dep_code_calcul_v2_i dep_code_calcul_v2_j dep_code_calcul_v2_k dep_code_calcul_v2_l dep_code_calcul_v2_m dep_code_calcul_v2_n dep_code_calcul_v2_o | dep_param_calcul_v2_a dep_param_calcul_v2_b dep_param_calcul_v2_c dep_param_calcul_v2_d dep_param_calcul_v2_e dep_param_calcul_v2_f dep_param_calcul_v2_g dep_param_calcul_v2_h dep_param_calcul_v2_i dep_param_calcul_v2_j dep_param_calcul_v2_k dep_param_calcul_v2_l dep_param_calcul_v2_m dep_param_calcul_v2_n dep_param_calcul_v2_o
dep_code_alpha1 dep_code_alpha2 dep_code_alpha3 dep_code_alpha4 dep_code_cad dep_code_coeff dep_code_num1 dep_code_num2 dep_code_num3 dep_code_num4 dep_code_qte | dep_param_alpha1 dep_param_alpha2 dep_param_alpha3 dep_param_alpha4 dep_param_cad dep_param_coeff dep_param_num1 dep_param_num2 dep_param_num3 dep_param_num4 dep_param_qte
dep_cad_formule_1 dep_cad_formule_2 dep_dif dep_machine dep_n1_formule dep_n2_formule dep_n3_formule dep_n4_formule dep_par_mac_1 dep_par_mac_2 dep_v1_formule dep_v2_formule dep_v3_formule dep_v4_formule dep_v5_formule dep_v6_formule dep_v7_formule dep_v8_formule dep_v9_formule dep_v10_formule |


Package g_std_d

Contenu du package Gammes standard (Détail)

Toutes les zones de la table g_std_d


Package g_std_e

Contenu du package Gammes standard (Entête)

Toutes les zones de la table g_std_e


Package groupage_bl

Contenu du package Groupages de BL

Toutes les zones de la table groupage_bl


Package i_lposte

Contenu du package Libellés des Opérations

1) Toutes les zones de la table i_lposte

2) La zone ls-param peut être découpée en ls-param_01 à ls_param_20 pour accéder au détail des zones des données diverses des opérations.

3) Les zones suivantes de la table i_lposte (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ls_sec Libellé court de la section

libl_ls_sec Libellé long de la section

ls_formule | Code formule
ls_sec | Code section
ls_ttr | Code type de travail

4) Autres zones

des_ls_mac | Désignation de la machine
des_ls_type | Désignation du type (calage, roulage, ...)


Package i_postes

Contenu du package Opérations

1) Toutes les zones de la table i_postes

2) La zone ss-param peut être découpée en ss-param_01 à ss_param_20 pour accéder au détail des zones des données diverses des opérations.

3) Les zones suivantes de la table i_postes (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_ss_sec Libellé court de la section

libl_ss_sec Libellé long de la section

ss_dif | Code difficulté
ss_ff | Code type de frais
ss_formule_cad | Code formule cadence
ss_formule_tps | Code formule temps
ss_sec | Code section
ss_ttr | Code type de TTR
ss_ucad | Code unité de cadence
ss_uqte | Code unité quantité
ss_utilisation | Code utilisation

4) Autres zones

des_ss_cletarifaire | Description de la clé tarifaire
des_ss_mac | Description de la machine
ss_triplet | Triplet Section-Opération-Sous-opération (ss_sec-ss_ope-ss_sop) Commence par ss_, mais n'est pas une zone de la table i_postes.


Package kp_recap_tot

Contenu du package Récapitulatif des Coûts

1) Toutes les zones de la table kp_recap_tot

2) Les zones suivantes de la table kp_recap_tot (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_kp_to_user Libellé court du code utilisateur

libl_kp_to_user Libellé long du code utilisateur

kp_to_nhn | Niveau hiérarchique prix négocié
kp_to_nhr | Niveau hiérarchique prix remis
kp_to_user | Code utilisateur


Package lieu_rgt_d

Contenu du package Lieux de rangement (Détail)

Toutes les zones de la table lieu_rgt_d


Package lieu_rgt_e

Contenu du package Lieux de rangement (Entête)

1) Toutes les zones de la table lieu_rgt_e

2) Les zones suivantes de la table lieu_rgt_e (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_lre_rgt1 Libellé court du lieu de rangement 1

libl_lre_rgt1 Libellé long du lieu de rangement 1

lre_rgt1 | Lieu de rangement 1
lre_type | Type

3) Autres zones

libc_lre_ctrl_palettes

Contrôle nombre de palettes maxi


Package lot_industriel

Ce package est utilisable à partir de la V.4.1.26.2

Contenu du package Lots Industriels

Toutes les zones de la table lot_industriel


Package mac0

Contenu du package Machines

1) Toutes les zones de la table mac0

2) Les zones suivantes de la table mac0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_m0_sit_prod Libellé court du site de production

libl_m0_sit_prod Libellé long du site de production

m0_atelier | Code atelier
m0_ilot | Code îlot
m0_par_convert | Paramètre convertible
m0_sit_prod | Code du site de production
m0_typmac | Code du type de machine

3) Autres zones

des_m0_coder | Désignation de la machine de rattachement
des_m0_mac_vhl_ac | Désignation de la machine associée pour le vernis hors ligne acrylique
des_m0_mac_vhl_of | Désignation de la machine associée pour le vernis hors ligne offset
des_m0_mac_vhl_uv | Désignation de la machine associée pour le vernis hors ligne UV
des_m0_reference | Désignation de la machine de référence


Package mat

Contenu du package Articles - Matières - Produits

1) Toutes les zones de la table mat

2) La zone mp_param peut être découpée en mp-param_01 à mp_param_48 pour accéder au détail des zones des données diverses.

3) Les zones suivantes de la table mat (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_mp_fam Libellé court du code famille

libl_mp_fam Libellé long du code famille

mp_coul | Code couleur
mp_cs1 | Code statistique 1
mp_cs2 | Code statistique 2
mp_cs3 | Code statistique 3
mp_cs4 | Code statistique 4
mp_etat_bes | Code d'état du besoin
mp_fam | Code famille
mp_fconv | Code formule de conversion
mp_gestionnaire | Code gestionnaire
mp_libre | Code de zone libre
mp_qualite | Code qualité
mp_reap | Mode de réapprovisionnement
mp_sfm | Code sous-famille
mp_ua | Code unité d'achat
mp_uv | Code unité de vente

4) Autres zones

lib_le_libelle | Libellé spécifique 1 du client
lib_le_libelle2 | Libellé spécifique 2 du client
libfou_le_libelle | Libellé spécifique 1 du fournisseur
libfou_le_libelle2 | Libellé spécifique 2 du fournisseur
lib_mp_afnor_art | Libellé du code normalisé AFNOR
lib_mp_afnor_ecma | Libellé du code normalisé ECMA
lib_mp_cdc | Désignation du centre de coût d'affectation
lib_mp_code_origine | Désignation du produit générique d'origine
lib_mp_prod_generique | Désignation du produit générique
lib_mp_qualite_matiere | Désignation de la qualité matière
nom_abrege_mp_cli | Nom abrégé du client principal
nom_mp_cli | Nom du client principal
nom_mp_foucli | Nom du fournisseur principal
ref_produit | Référence produit du client
reffou_produit | Référence produit du fournisseur

Particularités

Dans certaines visus, on peut accéder à toutes les infos de la fiche matière d'un produit lu depuis un TSC.

On peut ramener jusqu'à 5 fiches matières différentes. Les zones doivent être préfixées de :

1_

2_

3_

4_

5_

Voir la note FTSC_

Dans certains programmes de visualisation (v_don, v_ond, v_odv) toutes les zones peuvent être préfixées de :

mp_pf_ : article référence du produit fini

mp_ref_ens_ article référence interne de l'emballage

mp_qua_car_ : Composition commerciale (qualité carton

mp_com_car_ : Composition technique

mp_pal : fiche article palette du devis

Ce préfixage ne fait pas partie du package, il est "en dur" dans les programmes concernés.


Package picking_palette

Contenu du package Picking de palette

1) Toutes les zones de la table picking_palette

2) Les zones suivantes de la table picking_palette (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_pp_rgt1 Libellé court du lieu de rangement 1

libl_pp_rgt1 Libellé long du lieu de rangement 1

pp_rgt1

Lieu de rangement 1


Package stk0

Contenu du package Mouvements de Stock

1) Toutes les zones de la table stk0

2) Les zones suivantes de la table stk0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_s0_site_prod Libellé court du site de production

libl_s0_site_prod Libellé long du site de production

s0_rgt1 | Code lieu de rangement niveau 1
s0_site_prod | Code site de production
s0_ssf | Code stade du produit semi-fini pour le lot industriel
s0_typ | Code type de mouvement

3) Autres zones

lib_s0_prod | Libellé du produit
nom_s0_cli | Nom du client
nom_s0_fou | Nom du fournisseur
ville_s0_adl | Ville de l'adresse de livraison


Package stk_rg

Ce package est opérationnel à partir de la V.4.1.39.2

Il est utilisé par la visu des matières.

Contenu du package Règles de gestion de stockage et de réapprovisionnement par lieu de rangement

1) Toutes les zones de la table stk_rg

2) Les zones suivantes de la table stk_rg0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_sr_rgt1d Libellé court du lieu de rangement de niveau 1

libl_sr_rgt1 Libellé long du lieu de rangement de niveau 1

sr_rgt1 | Lieu de rangement de niveau 1
sr_rgt1_tr | Lieu de rangement source de niveau 1


Package suiv_vehicules

Contenu du package Suivi des véhicules

1) Toutes les zones de la table suiv_vehicules

2) Les zones suivantes de la table suiv_vehicules (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_sv_type_passage Libellé court du type de passage

libl_sv_type_passage Libellé long du type de passage

sv_type_passage | Type de passage
sv_motif | Motif

3) Autres zones

nom_sv_transporteur

Nom du transporteur


Package tar0

Contenu du package Tarifs

1) Toutes les zones de la table tar0

2) Les zones suivantes de la table tar0 (triées par ordre alphabétique) peuvent être préfixées de :

- libc_ pour avoir le libellé court

- libl_ pour avoir le libellé long

Exemple

libc_tr_cat Libellé court du code catégorie

libl_tr_cat Libellé long du code catégorie

tr_cat | Code catégorie du client
tr_char | Variable paramétrable
tr_devise | Code devise
tr_devise_av_euro | Valeur avant passage à l'euro
tr_fam | Code famille
tr_sfm | Code sous-famille
tr_tar | Code tarif
tr_unite | Code unité de vente ou d'achat

3) Autres zones

des_tr_mat | Description de la matière / du produit / de l'article
libpar1_tr_mat | Libellé paramétrable 1
libelle2_tr_mat | Libellé paramétrable 2
libelle_tr_mat | Libellé paramétrable
nom_tr_adr | Adresse
nom_tr_cli | Nom du client
nom_tr_cli_final | Raison sociale du client final
nom_tr_cli_final_adr | Raison sociale de l’adresse du client final


cl_param Données diverses de la fiche tiers

Sous GENERO, il existe 2 modes de restriction aux données diverses des tiers :

1) L'option Opa peut interdire l'accès à l'ensemble des données diverses : elles sont consultables uniquement.

2) La note DROIT_ACCES_CL_PARAM permet de contrôler l'accès zone par zone.

Cette note est recherchée en priorité sur l'utilisateur puis sur le paramètre de configuration de la fiche tiers.

01

Taxe parafiscale

Détermine si la taxe parafiscale définie au niveau du code TVA doit être appliquée [O/N].

Voir aide en ligne sur le type de paramètre TVA.

02

Emballage inclus ou en surcoût

Sur l entête d'un BL, un montant d'emballage peut être saisi.

Ce montant pourra être :

S Facturé

I Inclus dans le prix de vente

03

Edition d'un AR

Si le type de commande autorise l'édition d'un AR de commande, il est possible via ce paramètre de supprimer cette possibilité pour un client donné.

O Edition d'un AR

N Pas d'édition d'AR

04

Cahier des charges

Détermine le type de cahier des charges associé au tiers. Non utilisé dans les traitements.

N Pas de cahier des charges

I Cahier des charges ISO

S Cahier des charges spécifique

05

Mode de facturation des articles facturables uniquement

Mode de facturation des articles facturables uniquement

Ce paramètre permet de gérer le déclenchement de la facturation des articles facturables uniquement sur tous types de commandes exceptés FAD et AVO, via la notion de commande de rattachement.

Il existe 3 modes de facturation :

P La commande de rattachement n'est pas utilisée pour la facturation
Une ligne de commande sur cet article sera facturée systématiquement lors de la prochaine facturation.

C Seule la commande (et non pas la ligne de commande) de rattachement est utilisée pour la facturation.
Une ligne de commande sur cet article sera facturée si la commande de rattachement associée à cette ligne comporte au moins une ligne livrable à facturer ou déjà facturée ou si toutes les lignes sont facturables uniquement.
Ce mode de fonctionnement permet de bloquer la facturation des articles facturables uniquement (Exemple Les frais de formes, les frais de clichés, les frais d'outillage, etc.) jusqu'à la facturation de la première livraison sur la commande de rattachement.

L La ligne de commande de rattachement est utilisée pour la facturation.
1er cas : Une ligne de commande est rattachée à elle-même.
Cette ligne de commande sera facturée selon le mode C décrit ci-dessus.
2ème cas : Une ligne de commande est rattachée à une autre ligne de commande.
Cette ligne de commande sur cet article sera facturée si la ligne de commande de rattachement associée à cette ligne est à facturer ou déjà facturée.
Ce mode de fonctionnement permet de bloquer la facturation des articles facturables uniquement (Exemple Les frais de formes, les frais de clichés, les frais d'outillage, etc.) jusqu'à la facturation de la première livraison sur la ligne de commande de rattachement.
Avec utilisation de ce mode de fonctionnement, une ouverture automatique d'une fenêtre de saisie de la commande de rattachement est souvent mise en œuvre (paramètre TYC).

R La ligne de commande de rattachement est utilisée pour la facturation (équivalent au paramètre existant L).
Si cette dernière n’est pas facturable, descente d’un niveau dans le rattachement : la ligne de commande rattachée à la ligne de commande de rattachement est utilisée pour la facturation.

Remarque

La commande de rattachement peut être saisie dans l'écran de détail des lignes de commande (accessible par F8 sur la ligne).

Un paramétrage d'ouverture automatique d'une fenêtre de saisie de la commande de rattachement peut être mise en œuvre sur demande (paramètre TYC).

Une ligne de commande est rattachée à elle-même par défaut.

06

Le client appartient-il au groupe ?

G Le client appartient au même groupe que la société #SOC

H Le client n'appartient pas au même groupe que la société #SOC (par défaut)

07

Client avec articles sujets à consignation ?

C Les articles vendus au client sont sujets à consignation

N Les articles vendus au client ne sont jamais sujets à consignation (par défaut)

08

Indicateur Camion complet

Il s'agit uniquement d'un indicateur permettant de définir si le client accepte ou non des camions incomplets.

Cet indicateur n'a aucune action dans les traitements standards.

O Camion complet obligatoire

N Camion complet facultatif (par défaut)

09

Regroupement de facturation

Ce code est lié à la zone Regroupement facturation de la fiche client.

La zone Regroupement facturation permet d'indiquer comment doivent être regroupés les BL et les commandes lors de la facturation.

Ce code permet d'indiquer si la notion de commande fait référence à l entête ou à la ligne de commande.

Remarque : Sert uniquement si la zone Regroupement facturation est à 1 ou à 3 (sans regroupement des commandes).

L Regroupement de facturation sur ligne de commande

C Regroupement de facturation sur entête de commande

10

Gestion de l'affacturage

N Pas d'affacturage pour ce client

O Affacturage pour ce client

F Idem O - Lors du transfert en comptabilité, la facture est automatiquement rééditée (gestion spécifique)

11

Transfert des lignes de BL en comptabilité ORIAC

Ce flag peut être utilisé dans un complément de requête.

N Pas de transfert en comptabilité

O Transfert en comptabilité

12

Suivi en statistiques

Remarque : Le suivi en statistiques n pporte aucun traitement en standard.

Utilisable hors spécifique uniquement comme un complément de sélection

N Pas de suivi en statistiques

O Suivi en statistiques

13

Le client est-il facturable ?

N Client non facturable

O Client facturable

14

BL multi commande ?

0 BL multi commande autorisé (Par défaut)

1 Une seule commande par BL autorisée

2 Une seule ligne de commande par BL autorisée, mais plusieurs lignes de BL possibles dans le cas des appairages, si elles concernent une ligne de commande dotée de plusieurs séquences.
(Exemple une ligne fond et une ligne couvercle sur le même BL)

3 Une seule séquence de ligne de commande par BL autorisée
Même dans le cas des appairages, seule une ligne de commande est autorisée sur le BL

15

Le client utilise-t-il les facturations Self Billing Invoice ?

N Le client ne l'utilise pas.

O Le client l'utilise.

16

Le client doit-il recevoir une réponse ORDRSP suite à commande EDI ?

O Oui

N Non (par défaut)

17

Gestion du port automatique en saisie de commande client

H Par tranche de montant HT (défaut)

P Par tranche de poids

18

Type d'édition des commandes d'achat

O Edition non valorisée des commandes d achat

N Edition valorisée des commandes d'achat (défaut)

19

Cumul des remises client et ligne de commande

O On cumule les deux remises client et ligne de commande

N Seule la remise de la ligne de commande est prise en compte (défaut)

20

Rupture facturation sur le point de livraison

O Oui (L'option Ota est interdite dans l'édition des factures.)

N Non

21

Droit de timbre

Utilisé dans le calcul des factures

L'ajout d'un droit de timbre dépend aussi :

du code TVA de la facture calculée (TVA A2[56])

du TYC de la commande facturée (Voir TYC A1[21])

Le montant du droit de timbre est paramétré dans une note commençant par DROIT_DE_TIMBRE sur le paramètre #CF FAC.

O Ajouter un droit de timbre à chaque facture calculée

N Ne pas ajouter un droit de timbre à chaque facture calculée

22

Regroupement facturation lignes produit et frais

Possibilité de regrouper lors du calcul de la facture les lignes frais avec les lignes produit.

G Le regroupement n'est activé que si #CF ATL A1[45] = O (Valeur par défaut).

N Le regroupement n'est jamais activé

O Le regroupement est toujours activé.

Ceci est valable si le client :

est en regroupement cdes/BL 2 (Avec regroupement de commandes - Sans regroupement de bons de livraison)

ou en regroupement cdes/BL 1 (Sans regroupement de commandes - Sans regroupement de bons de livraison) avec regroupement commande C (Sur entête de commande).

2 manières de paramétrer le regroupement :

1 - Le caractère 22 de la zone des données diverses du client est à O.

2 - Le caractère 22 de la zone des données diverses du client est à G et le A1[45] du #CF ATL est à O.


mp_param Données diverses de la fiche article

Sous GENERO, il existe 2 modes de restriction aux données diverses des articles :

1) L'option Opa peut interdire l'accès à l'ensemble des données diverses : elles sont consultables uniquement.

2) La note DROIT_ACCES_MP_PARAM permet de contrôler l'accès zone par zone.

Cette note est recherchée en priorité sur l'utilisateur puis sur le paramètre de configuration de la fiche article.

Voir aussi l'outil qui permet de mettre à jour les données diverses des articles.

01

Article variable / fixe

Dans le devis, et autres modules de valorisation le coût d'un article fixe sera imputé au coût fixe.

F Article fixe. Exemple : Outillage

V Article variable. Exemple : Matière première

02

Article facturable uniquement

Doit-on interdire la saisie d'un BL ? Fonctionne conjointement avec le caractère 3.

O Article facturable uniquement
Un article facturable uniquement ne donnera jamais lieu à la saisie d'un BL, quelque soit le type de commande employé.
Pour que cet article soit facturé, le caractère 3 doit être à N.
Attention : Les articles facturables uniquement matérialisent souvent une facturation de frais ou de prestation.
Cette facturation pourra être conditionnée à la livraison d'autres articles.
Ce mode de facturation des frais dépend du client. Voir cl_param[5]

N Article livrable et/ou facturable
Un article livrable et/ou facturable donnera lieu à la saisie d'un BL, quelque soit le type de commande employé.
Pour que cet article soit facturé, le caractère 3 doit être à N.

03

Article livrable uniquement

Doit-on interdire la facturation ? Fonctionne conjointement avec le caractère 2.

O Article livrable uniquement
Un article livrable uniquement ne donnera jamais lieu au calcul d'une facture, quelque soit le type de commande employé.
Pour que cet article soit livré, le caractère 2 doit être à N.

N Article livrable et/ou facturable
Un article livrable et/ou facturable donnera lieu au calcul d'une facture, quelque soit le type de commande employé.
Pour que cet article soit livré, le caractère 2 doit être à N.

02

et 03

Mode de livraison / facturation

mp_param(02) | mp_param(03) | Mode
N | N | Livrable et facturable
N | O | Livrable uniquement (non facturable)
O | N | Facturable uniquement (non livrable)
O | O | Non livrable et non facturable

04

Article commissionné

Permet d'inclure ou d'exclure un article de l'état des commissions

O Article commissionné

N Article non commissionné

05

Article fabriqué ou acheté

Un article est soit fabriqué, soit acheté. Un article fabriqué peut être nomenclaturé.

F Produit fabriqué

A Produit acheté

06

Remontée matière

M Remontée matière en manuel

A Remontée matière en automatique

07

Article référencé

A Article référencé

L Article non référencé
Pour les articles non référencés, un paramétrage de la saisie des commandes clients et fournisseurs déclenche l'ouverture automatique d'une fenêtre permettant la saisie du libellé de l'article sur la ligne de commande.

08

Article tenu en statistique

O Article tenu en statistique

N Article non tenu en statistique

09

Article en sortie magasin

O Article en sortie magasin

N L'article n'est pas en sortie magasin

10

Type d'article en valorisation

O Sous-traitance

N Normal

P Sous-traitance Port

A Action de service (indispensable pour le caractère 42)

F Frais de premier établissement

11

Taux de section

O Inclus dans le taux de section

N Non inclus dans le taux de section

12

Amalgame

O Amalgame

N Non amalgame

13

Lieu de génération

O Choix du lieu de génération

N Pas de choix du lieu de génération

14

Autorisation article gratuit

O Autorisation article gratuit

N Pas d'autorisation article gratuit

15

Réservé Volume Software

16

Réservé Volume Software

17

Mode de gestion de stock

Une société choisit lors de la phase d'installation un mode de gestion des stocks (en global, par lots, par lieux, par lots et lieux).

Via ce paramétrage? on autorise des règles de gestion propres à un article donné.

G Gestion du stock en global

L Gestion du stock par lots

I Gestion du stock par lieux

B Gestion du stock par lots et par lieux

1 Gestion du stock par lieux et par conditionnement

2 Gestion du stock par lieux, par lots et par conditionnement

18

Gestion des alertes

N Pas d'alerte

T Article à traiter

A Article en alerte

S Stock inférieur au stock de sécurité

M Stock supérieur au stock maximum

R Article en rupture

I Ignoré

19

Réservé à Volume Software

Ce paramètre permet de savoir si l'article est à jour dans la table stk_lot_lieu.

Il est utilisé dans le programme maj_stk_lot_lieu.

Ne pas modifier cette donnée sous peine de fausser la table stk_lot_lieu.

T L'article a été mouvementé depuis le dernier calcul, il faut donc le retraiter.

N L'article n'a pas été mouvementé depuis le dernier calcul, il est donc inutile de le re-traiter.

I L'article est ignoré.

20

Calcul des quantités en génération

L Calcul sur quantité toutes gâches incluses (les consommables sont calculés avec la quantité commandée).

C Calcul sur quantité commandée

D Quantité avec déchet onduleuse inclus

T Calcul sur quantité toutes gâches incluses hors quantité onduleuse uniquement pour les consommables.

21

Génération

M Article géré et mouvements de stock générés (par défaut)

P Article géré mais pas de mouvement de stock généré

I Article ignoré dans la génération de dossier

22

Gestion des appairages

E Ensemble monté à l'extérieur

N Article non appairé. Pas de nomenclature de commande.

O Ensemble appairé multi produits (non montés)
Un ensemble possédant plusieurs PF composants ou un seul PF utilisé plusieurs fois (coefficient de nomenclature >1)

P Ensemble appairé mono-produit. Un ensemble qui possède un seul composant.

M Ensemble appairé monté
Un ensemble possédant plusieurs PF composants, assemblés entre eux pour former un ensemble monté.

R Ensemble appairé non monté avec facturation sur l'article de référence.
L'article de référence est TOUJOURS le premier composant de la nomenclature et son coefficient de nomenclature est à 1.
Remarque Il s'agit d'un cas particulier des ensembles appairés multi produits.

23

Type d'affectation autorisée

En saisie de mouvement de stock, en saisie de commande d'achat et en saisie de facture de sous-traitance, on est susceptible d'indiquer une affectation via un OF ou un centre de coût.

L'affectation est soit un OF, soit un centre de coût et ceci en fonction du paramètre 24 choisi.

Cependant, on peut spécifier qu'une saisie affectée ne doit être réalisée pour un article que dans un seul de ces modules :

Saisie des mouvements de stock

Saisie des commandes d'achat

Saisie des factures de sous-traitance

Codification

I Indifférent (affectation libre)
On peut, pour cet article, saisir des éléments affectés dans chacun des modules décrits ci-dessus.

S Uniquement sur les mouvements de sortie de stock

A Uniquement sur les commandes d'achat

T Uniquement sur les factures de sous-traitance

Exemple : Pour un article paramétré en S, on ne pourra pas saisir de commande d'achat affectée, ni de facture de sous-traitance affectée.

24

Mode d'affectation autorisé

En saisie de mouvement de stock, en saisie de commande d'achat et en saisie de facture de sous-traitance, on est susceptible d'indiquer une affectation via un OF ou un centre de coût.

Ce paramètre permet de contrôler les modes d'affectation autorisés.

N Aucune affectation n'est obligatoire
Un OF ou un centre de coût peut être saisi, mais pas les deux
On peut ne rien saisir

I Indifférent
Un OF ou un centre de coût doit être saisi, mais pas les deux
Une des deux saisie est obligatoire

O Affectation sur OF
Un OF ou un centre de coût doit être saisi, mais pas les deux
Une des deux est obligatoire
On s'attend à une saisie sur un OF, donc un message d'avertissement apparaît dans le cas d'une saisie sur centre de coût.

F Affectation sur OF obligatoire
Un OF doit être saisi

C Affectation sur centre de coût
Un OF ou un centre de coût doit être saisi, mais pas les deux
Une des deux est obligatoire
On s'attend à une saisie sur un centre de coût, donc un message d'avertissement apparaît dans le cas d'une saisie sur un OF.

E Affectation sur centre de coût obligatoire
Un centre de coût doit être saisi

A Aucune affectation n'est autorisée

X Affectation non obligatoire sur OF et/ou centre de coût

Y Affectation obligatoire sur OF et/ou centre de coût

Z Affectation obligatoire sur OF et centre de coût

Remarque : Voir le caractère 23 définissant le type d'affectation autorisé

En saisie de mouvements de stock, bien qu'un des paramètres ci-dessus oblige à la saisie, un type de mouvement de stock particulier permet de passer outre et de pas effectuer cette saisie.

Cf paramétrage du type de mouvement de stock. : TMV alpha2[10]

25

Article générique ?

O Article générique [par défaut]
En saisie d'une ligne de commande client, on accède aux informations complémentaires de la ligne de la ligne de commande. Celles-ci sont initialisées avec les informations complémentaires de la fiche article lors du premier accès.

N Article non générique
En saisie d'une ligne de commande client, on accède aux informations complémentaires de l'article. Les informations complémentaires de la ligne de commande sont inexistantes pour ce type d'article.

26

Affectation de l'OF

0 Pas d'affectation

1 Sur tous les mouvements

2 Sur les sorties

3 Sur les entrées

27

Type affectation du centre de coût des mouvements de stock

Utilisé pour les affectations par défaut du centre de coût d'affectation.

0 Pas d'affectation par défaut du centre de coût sur les mouvements

1 Affectation par défaut du centre de coût sur entrées et sorties

2 Affectation par défaut du centre de coût sur sorties

3 Affectation par défaut du centre de coût sur entrées

28

Recherche auto du centre de coût d'affectation

N Pas d'automatisme

A Le centre de coût est celui de l'article avec contrôle

B Le centre de coût est celui de l'article par défaut (sans contrôle)

O Le centre de coût est celui de l'article représenté par le niveau 1 de l'OF d'affectation.

29

Libellé automatique de la ligne de commande client

N Pas d'automatisme

1 Le libellé de la ligne de commande est constitué automatiquement :
PLAQUE laize x coupe en qualité carton
laize : Saisie sur la ligne de commande
coupe : Saisie sur la ligne de commande
qualité carton : Déterminée par un TSC (Char30) de l'article commandé paramétré en #CF ATL A2[19,21]
Il est régénéré à chaque modification du code article commandé, de la laize ou de la coupe.
La qualité carton de l'article commandé est réputée non modifiable.

2 Le libellé de la ligne de commande est constitué automatiquement :
OM AAMMaaaa-bb LAIZE laize EN qualité carton
AAMM représente l'année (2 chiffres) et le mois (2 chiffres)
aaaa représente le n° d'ordre de marche (N° de commande de type FBA)
bb représente le n° de groupage (N° de la ligne de commande)
laize : saisie sur la ligne de commande
qualité carton : déterminée par un TSC (Char30) de l'article commandé paramétré en #CF ATL A2[27,29].
Il est régénéré à chaque modification du code article commandé ou de la laize.
La qualité carton de l'article commandé est réputée non modifiable.

3 Le libellé de la ligne de commande est remis automatiquement à blanc lors de la création de la ligne de commande.

4 Le libellé de la ligne de commande est constitué automatiquement :
PL laize x coupe REF
avec l'intitulé REF si la plaque est refoulée
Remarque : La fin du libellé (après le caractère [-]) est librement saisissable.

30

Mode de gestion de la zone libre du mouvement de stock

Concerne la zone s0_libre de la table des mouvements de stock

N Pas de gestion spécifique de la zone libre du mouvement de stock

U Saisie d'un poids unitaire dans la déclaration de production ou la déclaration d'achat
Le poids stocké est égal au poids unitaire saisi multiplié par la quantité saisie
Remarque : Le poids total est stocké dans la zone s0_libre de la table des mouvements de stock.

T Saisie d'un poids total dans la déclaration de production ou la déclaration d'achat
Le poids stocké est égal au poids total saisi
Remarque : Le poids total est stocké dans la zone s0_libre de la table des mouvements de stock.

C Le poids unitaire est issu de la zone poids de la ligne de commande client
Le poids stocké est égal au poids unitaire de la ligne de commande client multiplié par la quantité saisie.
Ceci est effectif, uniquement, dans la déclaration de production.
Remarque : Le poids total est stocké dans la zone s0_libre de la table des mouvements de stock.

V La valeur du mouvement de stock est issue d'un calcul.
La valeur du mouvement de stock stockée est égale à la quantité du mouvement de stock saisie multipliée par le prix du mouvement de stock saisi et par le coefficient de conversion de l'article.
Ceci est effectif, uniquement, dans la saisie des mouvements de stock et la visualisation des mouvements de stock.
Remarque : valeur du mouvement de stock est stockée dans la zone s0_libre de la table des mouvements de stock.

31

Mode de valorisation du prix de revient

A Valorisation au prix du mouvement
Remontée des mouvements de stock
C'est le prix du mouvement qui est utilisé pour valoriser la quantité du mouvement de stock.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

B Valorisation au prix de revient du mouvement
Remontée des mouvements de stock
C'est le prix du mouvement qui est utilisé pour valoriser la quantité du mouvement de stock. À la valeur calculée, on ajoute le pourcentage de frais et le pourcentage de perte.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture + pourcentage de frais + pourcentage de perte qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

C Valorisation au prix de vente du mouvement
Remontée des mouvements de stock
C'est le prix du mouvement qui est utilisé pour valoriser la quantité du mouvement de stock.
À la valeur calculée, on ajoute le pourcentage de frais, le pourcentage de perte et le pourcentage de marge.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture + pourcentage de frais + pourcentage de perte + pourcentage de marge qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

D Valorisation au prix d'achat moyen pondéré du lot
Remontée des mouvements de stock
C'est le prix d'achat moyen pondéré du lot qui est utilisé pour valoriser la quantité du mouvement de stock.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

E Valorisation au prix de revient du lot
Remontée des mouvements de stock
C'est le prix d'achat moyen pondéré du lot qui est utilisé pour valoriser la quantité du mouvement de stock.
À la valeur calculée, on ajoute le pourcentage de frais et le pourcentage de perte.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture + pourcentage de frais + pourcentage de perte qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

F Valorisation au prix de vente du lot
Remontée des mouvements de stock
C'est le prix d'achat moyen pondéré du lot qui est utilisé pour valoriser la quantité du mouvement de stock. À la valeur calculée, on ajoute le pourcentage de frais, le pourcentage de perte et le pourcentage de marge.
Remontée des factures d'achat
Ce sont le montant H.T et le port H.T de la facture + pourcentage de frais + pourcentage de perte + pourcentage de marge qui sont remontés dans le prix de revient.
Saisie manuelle
Le montant est à saisir
F6 dans la saisie des matières et des temps par dossier

G Valorisation au prix fichier selon le type de valorisation du stock de l'article
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Type valorisation N Stock non valorisé
Le prix est égal à 0
Type valorisation P Stock valorisé au PAMP
Le prix est égal au prix d'achat du fichier
Type valorisation D Stock valorisé au Dernier prix d'achat
Le prix est égal au prix d'achat du fichier
Type valorisation R Stock valorisé au Prix de revient
Le prix est égal au prix de revient du fichier
Type valorisation V Stock valorisé au Prix de vente
Le prix est égal au prix de vente du fichier

H Valorisation au prix recalculé selon le type de valorisation du stock de l'article en tenant compte de la valeur de son stock
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Le prix est égal à la valeur du stock divisée par le stock physique

I Valorisation au prix d'achat fichier de l'article
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Le prix est égal au prix d'achat du fichier

J Valorisation au prix d'achat recalculé de l'article en tenant compte du type de valorisation du stock et de la valeur de son stock
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Type valorisation N Stock non valorisé
Le prix est égal au prix d'achat du fichier
Type valorisation P Stock valorisé au PAMP
Le prix est égal à la valeur du stock divisée par le stock physique
Type valorisation D Stock valorisé au Dernier prix d'achat
Le prix est égal à la valeur du stock divisée par le stock physique
Type valorisation R Stock valorisé au Prix de revient
Le prix est égal à la valeur du stock divisée par le stock physique.
On soustrait le pourcentage de frais et le pourcentage de perte pour obtenir le prix d'achat
Type valorisation V Stock valorisé au Prix de vente
Le prix est égal à la valeur du stock divisée par le stock physique
On soustrait le pourcentage de frais, le pourcentage de perte et le pourcentage de marge pour obtenir le prix d'achat

K Valorisation au prix de revient fichier de l'article
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Le prix est égal au prix de revient du fichier

L Valorisation au prix de revient recalculé de l'article en tenant compte du type de valorisation du stock et de la valeur de son stock
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Type valorisation N Stock non valorisé
Le prix est égal au prix de revient du fichier
Type valorisation P Stock valorisé au PAMP
Le prix est égal à la valeur du stock divisée par le stock physique. On ajoute le pourcentage de frais et le pourcentage de perte pour obtenir le prix de revient
Type valorisation D Stock valorisé au dernier prix d'achat
Le prix est égal à la valeur du stock divisée par le stock physique. On ajoute le pourcentage de frais et le pourcentage de perte pour obtenir le prix de revient
Type valorisation R Stock valorisé au prix de revient
Le prix est égal à la valeur du stock divisée par le stock physique
Type valorisation V Stock valorisé au prix de vente
Le prix est égal à la valeur du stock divisée par le stock physique. On soustrait le pourcentage de marge pour obtenir le prix de revient.

M Valorisation au prix de vente fichier de l'article
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Le prix est égal au prix de vente du fichier

N Valorisation au prix de vente recalculé de l'article en tenant compte du type de valorisation du stock et de la valeur de son stock
Remontée des mouvements de stock
Remontée des factures d'achat
Saisie manuelle
Type valorisation N Stock non valorisé
Le prix est égal au prix de vente du fichier
Type valorisation P Stock valorisé au PAMP
Le prix est égal à la valeur du stock divisée par le stock physique.
On ajoute le pourcentage de frais, le pourcentage de perte et le pourcentage de marge pour obtenir le prix de vente.
Type valorisation D Stock valorisé au dernier prix d'achat
Le prix est égal à la valeur du stock divisée par le stock physique. On ajoute le pourcentage de frais, le pourcentage de perte et le pourcentage de marge pour obtenir le prix de vente
Type valorisation R Stock valorisé au prix de revient
Le prix est égal à la valeur du stock divisée par le stock physique. On ajoute le pourcentage de marge pour obtenir le prix de vente
Type valorisation V Stock valorisé au prix de vente
Le prix est égal à la valeur du stock divisée par le stock physique.

Remarque : Dans les saisies manuelles, si le mode de valorisation du prix de revient est égal à A, B, C, D, E ou F, la saisie se fera en quantité et en montant.
F6 dans la saisie des matières et des temps par dossier.
Dans les saisies manuelles, si le mode de valorisation du prix de revient est égal à G, H, I, J, K, L, M ou N, la saisie se fera en quantité seulement. Le montant sera calculé et affiché. Celui-ci est non modifiable.
F6 dans la saisie des matières et des temps par dossier

32

Appartenance de l'article à un client

O L'article appartient à un client

N L'article n'appartient pas à un client

33

Article Multi Impression

N Sans Ouverture automatique de la fenêtre <Données Techniques 1>

O Avec Ouverture automatique de la fenêtre <Données Techniques 1>

34

Article à transférer

O L'article est à transférer

N L'article n'est pas à transférer

35

Prise en compte de l'article dans les statistiques (stat2)

Q Prise en compte de la quantité uniquement

C Prise en compte du CA uniquement

2 Prise en compte de la quantité et du CA (par défaut)

N Article ignoré

36

Article de type acompte ou avance déjà versé

N L'article n'est pas de type acompte ou avance déjà versé

O L'article est de type acompte ou avance déjà versé

37

Contrôle des lieux 2 et 3

N L'article fait l'objet du contrôle sur lieux 2 et 3 (Valeur par défaut)

O L'article est exempt de contrôle sur lieux 2 et 3

38

Gestion des sorties de stock en déclaration de production

I L'article est ignoré en déclaration de production (Valeur par défaut)

P Les sorties sont gérées à la palette en déclaration de production (Exemple Palette, Coiffe)

C Les sorties sont gérées avec le coefficient de nomenclature en déclaration de production
(Exemple les encres)

D Les sorties réserves sont supprimées au solde de la fabrication avec création d'une entrée/sortie de quantité 1 (pour suivre les outillages, (Formes, clichés ...)).

S Les sorties réserves sont supprimées au solde de la fabrication.

X Permet de générer un mouvement de sortie de palette lors de l'édition définitive du BL
Le mouvement de sortie est généré sur :
1. le magasin saisi dans le TSC 291 sur le code palette
2. le magasin par défaut associé au code palette (zones mat.mp_rgt1 et mat.mp_rgt2)
Le client du mouvement de sortie est celui du BL.

Y Permet de générer un mouvement de transfert (entrée/sortie) lors de l'édition définitive du BL:

• Un mouvement de sortie de palette généré sur :

1. le magasin du picking

2. le magasin par défaut associé au code palette (zones mat.mp_rgt1 et mat.mp_rgt2)

Le client du mouvement de sortie est :

1. celui associé au lieu de rangement 1 trouvé ci-dessus (RG1 A1[14,22])

2. le client société par défaut (#SOC)

• Un mouvement d'entrée de palette généré sur :

1. le magasin saisi dans le TSC 292 sur le code palette

2. le magasin saisi dans le TSC 292 sur le couple client/adresse livraison

3. le magasin saisi dans le TSC 292 sur le client

4. le magasin intermédiaire (bon de transfert uniquement, zone bl1. b1_lieu_rgt1)

5. le magasin par défaut renseigné sur la configuration des BL (#CF BLV)

Pour un bon de livraison : Le client du mouvement d'entrée est celui du BL.

Pour un bon de transfert : Le client du mouvement d'entrée est :

1. celui associé au lieu intermédiaire du BL (RG1 A1[14,22]).

2. le client société par défaut (#SOC)

Remarque : La gestion P C D implique automatiquement la gestion du S.

C'est à dire que toutes les réserves seront supprimées lors du solde (c'est de la fabrication).

39

Indicateur A facturer sur la ligne de commande

Voir TYC A1[31]

40

Produit géré par palette

O Le produit est géré par palette - valeur par défaut

N Le produit n'est pas géré par palette

41

Produit soumis à la remise globale sur famille / sous-famille

O Le produit est soumis à cette remise.

N Le produit n'est pas soumis à cette remise.

42

Indicateur Inclus dans le prix de revient

Indicateur valable uniquement si l'article est une action de service (caractère 10 = A).

N Non inclus dans le prix de revient (valeur par défaut)

P Inclus dans le prix de revient prévisionnel

R Inclus dans le prix de revient réel

2 Inclus dans le prix de revient prévisionnel et réel

43

Autorisation de MAJ automatique de tarif

O La mise à jour automatique de tarif en saisie de ligne de commande est autorisée (valeur par défaut).

N La mise à jour automatique de tarif en saisie de ligne de commande n'est pas autorisée.

44

Article acheté faisant l'objet d'une déclaration de production

O Oui

N Non

45

Gestion multi-formats

O Oui

N Non (par défaut)

46

Type de conditionnement

Utilisé dans le module de correction de stock (maj_stk) et le picking du module de saisie des bons de livraison (blv).

P Palette (par défaut)

C Caisse. Tous les libellés Palette ou Colis sont remplacés par Caisse pour cet article.

B Bobine. Tous les libellés Palette ou Colis sont remplacés par Bobine pour cet article.

1 Caisse homogène sur palette

2 Caisse hétérogène sur palette

3 Bobine hétérogène sur palette

4 Film hétérogène sur palette

5 Bobine homogène sur palette

6 Film homogène sur palette

Voir le paramètre #CF CAB A1[3].

Voir aussi l'option Omp dans la déclaration de production.

Le paramétrage général du #CF CAB prime sur le paramétrage de l'article.

Rappel : #CF ATL A4[47] permet d'initialiser le type de conditionnement.

47

Cumul de la surface et du poids des accessoires sur l'ensemble

0 La surface et le poids des accessoires sont cumulés sur l'ensemble.

1 Seule la surface des accessoires est cumulée sur l'ensemble.

2 Seul le poids des accessoires est cumulé sur l'ensemble.

3 La surface et le poids des accessoires ne sont pas cumulés sur l'ensemble.

48

Article géré au lot industriel

O Oui

N Non (par défaut)


o0_param Données diverses des opérations

Voir aussi Opérations élémentaires et dépendances

01 | Type de remontée | T Remontée manuelle en Temps E Remontée automatique en Temps F Remontée manuelle en Euros R Remontée automatique en Euros
02 | Type de temps | 1 Temps forfaitaire M Temps unitaire
03 | Prix opération | O Oui N Non E Ajout effectif
04 | Prix machine | O/N
05 | Prix salarié | O/N
06 | Opération | O Sous-traitance N Normal T Transport
07 | Jours ouvrés | O Jours ouvrés uniquement N Tous les jours
08 | Comptage | O Comptage en entrée N Comptage en sortie
09 | Charge | O Charge sur l'opération M Charge sur la machine S Charge sur la section I Ignore
10 | Comptage semi-fini | O/N
11 | Frais de premier établissement | O/N
12 | Opération manuelle | O Oui - Pas de capteur machine N Non - Capteur machine activé
13 | Opération de découpe | D Opération de découpe N Non significatif
14 | Effectif supplémentaire inclus dans le taux de section | O Oui (par défaut) N Non Actuellement, n'est utilisé que dans des traitements spécifiques clients. Ce paramètre n'est pas utilisé dans le calcul des devis.
15 | Opération d'impression | I Opération d'impression N Non significatif
16 | Clé tarifaire | 1 Manuelle 2 SEC / OPE / SOP 3 SEC / OPE / SOP + N° d'ordre sur 4 4 SEC / OPE + Machine + N° d'ordre sur 3
17 | Opération de colisage | C Opération de colisage N Non significatif
18 | Opération de jonctionnement | J Opération de jonctionnement N Non significatif
19 | Gestion des quantités rebutées sur l'opération (saisie) | O/N, N par défaut
20 | Le TTR doit-il être saisi dans la saisie des temps atelier par code à barres | O/N, N par défaut


so_options Données diverses de la fiche société

01

Gestion des stocks par lot

O/N, N par défaut

02

Consultation des stocks matières

O/N, N par défaut

03

Gestion des libellés étrangers

O/N, N par défaut

04

Accès à la saisie du cours des devises

O/N, N par défaut

05

Gestion des stocks par lieu

O/N, N par défaut

06

Gestion de la table des correspondants par F13 en saisie des clients

O/N, N par défaut

07

Visualisation des quantités fabricables au niveau n+1, n+2, etc

O/N, N par défaut

08

Gestion de l'encours de crédit

O/N, N par défaut

09

Annulation physique des mouvements de stock dont l'état est différent de N

O/N, N par défaut

10

Statistiques CA de l'entreprise cumulées sur le client #SOC

O/N, N par défaut -

La mise à jour des statistiques du client #SOC peut être faite automatiquement dans la saisie des devis, des commandes et des affaires et dans le calcul des factures, si so_options[10] = O.

11

Informations complémentaires sur les articles

O/N, N par défaut

12

Informations complémentaires sur les commandes

O/N, N par défaut

13

Gestion des lieux multi niveaux

O/N, N par défaut

14

Utilisation des machines de référence

O/N, N par défaut

Ce caractère n'est utilisé qu'à des fins d'amélioration des temps de réponse.

15

Stock n+1 en saisie des commandes clients. Gestion des appairages

O/N, N par défaut

16

Mode de valorisation pour les opérations

N Fonctionnement actuel (Valeur par défaut)

C Valorisation par taux historisé sur centre de coût

H Valorisation par taux historisé sur opération, machine et employé

17

Mode de valorisation pour les machines

N Fonctionnement actuel (Valeur par défaut)

C Valorisation par taux historisé sur centre de coût

H Valorisation par taux historisé sur opération, machine et employé

18

Mode de valorisation pour les employés

N Fonctionnement actuel (Valeur par défaut)

C Valorisation par taux historisé sur centre de coût

H Valorisation par taux historisé sur opération, machine et employé

19

Gestion de l'adresse de livraison sur la ligne de commande

O/N, N par défaut

20

Contrôle de la cohérence des formules de conversion

N Contrôle de la cohérence (Valeur par défaut)

O Pas de contrôle de la cohérence. Excepté en saisie des articles

21

Valorisation du temps d'un responsable

N Le taux horaire salarié demeure une composante unique du coût (Valeur par défaut)

O Lors de la valorisation du temps d'un responsable, le taux horaire de la fiche employé (s'il entre dans la composition du coût, voir paramétrage opération - Car.5 = O) est multiplié par le nombre de personnes affectées en standard à l'opération.

22

Visualisation des écritures comptables des comptes clients. Comptabilité VALC uniquement

O/N, N par défaut

23

Mode d'annulation des sorties physiques de stock

N Pas de prise en compte du prix du mouvement de stock pour calculer la nouvelle valeur de stock même si celui-ci est renseigné (Valeur par défaut)

O Prise en compte du prix du mouvement de stock pour calculer la nouvelle valeur de stock si celui-ci est renseigné.

24

Mode de création des entrées physiques de stock

Concerne uniquement les entrées automatiques. Les entrées manuelles sont gérées avec le mode N.

N Si l'ancien stock physique est négatif, la nouvelle valeur de stock est égale au nouveau stock physique par le prix du mouvement d'entrée (Valeur par défaut).

O Si l'ancien stock physique est négatif, la nouvelle valeur de stock tient compte de l'ancienne valeur de stock négative.

25

Accès à la répartition des temps par individu, par fonction et par centre de coût

O/N, N par défaut

26

Contrôle d'existence des lieux 2 et 3

O/N, N par défaut

27

Gestion du poids net commandé (en kg) et de la surface nette commandée (en m2) dans les statistiques mensuelles client

O/N, N par défaut

28

Suppression du contrôle du lieu de rangement de niveau 3

O/N, N par défaut

29

Utilisation du nouveau mode de saisie des TSC

Dans le nouveau mode, on saisira une seule zone par ligne, avec la possibilité de paramétrer une question sur 45 caractères.

N Non - Valeur par défaut - ancien mode

O OUI - nouveau mode

ATTENTION Dans le paramètre de lancement, on peut créer les notes suivantes, qui forcent le mode de saisie des TSC :

INFO_C1, qui force l'ancien mode

INFO_C2, qui force le nouveau mode

La présence de ces notes interdit l'utilisation de la touche F21 (changement de mode d'affichage des TSC).

30

Gestion des frais d'expédition dans la gestion commerciale

O/N, N par défaut

31

Gestion de la suspension de TVA

O/N, N par défaut

32

Gestion des habilitations

O/N, N par défaut

33

Supprimer l'alimentation de la table lieu_rgt_d (détail)

N Mise à jour des stocks par lieu (Valeur par défaut)

O Pas de mise à jour des stocks par lieu

34

Gestion des devises et de l'EURO

N Pas de gestion des devises et de l'euro (Valeur par défaut)

D Gestion des devises

E Gestion de l'euro

2 Gestion des devises et de l'euro

35

Gestion de la consignation, de la mise à disposition, de la sous-traitance et de la cession à filiale dans les livraisons

O/N, N par défaut

36

Gestion du flash journalier

O/N

37

Gestion des adresses de facturations sur la ligne de commande

O/N

38

Gestion des événements pour les marges contributives

O/N

39

Gestion des prix au mille +

O/N

40

Gestion du stock détaillé par unité de conditionnement (nouvelles tables conteneur)

O/N

41

Gestion des nomenclatures multi niveaux

O/N

42

Gestion des bons de transfert

O/N

43

Gestion des cadencements de livraison avec stocks

O/N

44

Gestion des cadencements de fabrication

O/N, N par défaut


ul_param Données diverses de la fiche formule

Permettre de répartir les prix par référence pour les formules avec amalgame.

Principe de fonctionnement pour une formule répartie selon l'amalgame

Pour une formule de calage :

Pour chaque référence rattachée à la référence associée à la formule en cours de calcul :

PR référence = PR formule / Nombre de références rattachées

PV référence = PV formule / Nombre de références rattachées

Pour une formule de roulage :

Pour chaque référence rattachée à la référence associée à la formule en cours de calcul :

PR référence = PR formule X Quantité référence sur l'entité / Quantité totale des références rattachées

PV référence = PV formule X Quantité référence sur l'entité / Quantité totale des références rattachées

Remarques :

• Le rattachement se fait via la colonne Collage de la saisie des références multiples.

• Une référence est toujours au moins rattachée à elle-même.

• Si la référence associée à la formule de calcul n'est rattachée à aucune autre référence qu'elle-même, le calcul correspond à celui de la valeur ul_param[23] = R.

ul_param Données diverses de la fiche formule

01

Critère d'optimisation

Réservé

02

Participe à la valeur ajoutée

O/N

03

Recherche de prix dans le fichier tarif

Ce flag doit répondre aux questions suivantes, lorsque la zone Conf. tarif vente est renseignée sur la formule.

Quel tiers ?

Soit le client du devis

Soit le fournisseur indiqué au niveau de la formule

Quel doit être le prix de base ?

Soit le prix d'achat de la fiche article

Soit le prix de revient

Soit le prix de vente

Faut-il appliquer le coefficient de conversion sur le prix de base lorsqu'il s'agit du prix de vente ?

Faut-il appliquer les coefficients de frais et de perte ? si oui, où les rechercher ?

Table de vérité

Flag | Tiers | Prix de base | Appliquer Coef.Conv. ? | Coefficients de frais et de perte
C | Client | Prix de vente | Oui | Non
D | Client | Prix de vente | Non | Non
E | Client | Prix d'achat | Non | Non
F | Fournisseur | Prix de vente | Oui | Non
G | Fournisseur | Prix de vente | Non | Non
H | Fournisseur | Prix d'achat | Non | Non
I | Client | Prix de revient | Non | Non
J | Fournisseur | Prix de revient | Non | Fiche de l'article courant
K | Fournisseur | Prix de revient | Non | Fiche qualité matière associée à l'article courant

Ceci est valable dans

Les formules matières paramétrables

Les formules sous-traitance paramétrables

Les formules opérations paramétrables utilisant la clé tarifaire

En ce qui concerne les formules figées (matières et sous-traitance), la plupart ont leur propre mécanisme de recherche de tarif.

Précision sur le prix par défaut

Le prix par défaut a deux fonctions :

C'est le prix utilisé lorsque aucun tarif n'a été trouvé dans la grille.

C'est le prix de base utilisé lorsque les grilles de tarifs sont exprimées avec un coefficient ou un pourcentage.

Précision sur les coefficients de frais et de perte

Lorsque le tarif est trouvé (en valeur ou en ajout), on lui applique les frais et pertes de la fiche article.

ATTENTION Ceci est incompatible avec l'option Opm sur la fiche article, qui permet de saisir les frais et pertes en montant et non en pourcentage.

04

Application de la marge pour les formules matières et sous-traitance lorsque la marge n'est pas fixe.

F Fonctionnement standard : la marge est prise sur la fiche matière (par défaut)

C La marge est calculée à partir de codes calcul paramétré sur les notes.
Voir les notes CALCUL_MARGE sur la formule de calcul.

N La marge est mise à zéro

Remarque Les formules figées (notamment en sous-traitance) peuvent avoir leur propre fonctionnement.

05

Calcul de la formule

T La formule est calculée systématiquement

N La formule est calculée uniquement s'il s'agit d'un nouveau devis
G ou C sur le premier écran du devis

R La formule est calculée uniquement s'il s'agit d'un renouvellement
R sur le premier écran du devis

06

Prix matière à prendre en compte

Ce paramètre permet de calculer différemment le coût matière au niveau des formules matières ou sous-traitance paramétrables (### #AU)

S Fonctionnement standard selon paramétrage
Prix de revient fiche article
Recherche dans les tarifs

P On utilise le prix papier du devis
Formule papier/carton

B On utilise le prix papier du devis si celui-ci est bloqué ; sinon fonctionnement standard, et on met à jour le prix papier du devis
Formule papier/carton (formules matières uniquement)

F On utilise la valeur unitaire du stock (fiche article), uniquement si le devis est un devis de fabrication (99)

M Aucun automatisme : Le coût est entré manuellement.

X Fonctionnement standard (équivalent à S) sans le forçage du prix de revient matière par le prix du papier de l'entité si le code matière est identique au code papier
Cette valeur n'influe que pour les formules matières; dans les autres cas, cette valeur est strictement identique à la valeur S.

Validité des valeurs de ce flag /

Valeur | Valide en formule matière | Valide en formule str
S | Oui | Oui
P | Oui | Oui
B | Oui | Non
F | Oui | Oui
M | Oui | Oui

07

Ce paramètre permet d'ignorer les messages lorsque l'opération n'est pas trouvée

O On ignore les messages

N On n'ignore pas les messages

08

Flag utilisé pour des traitements spécifiques en génération personnalisée de notes

09

Positionne la zone état du détail matière, opération ou sous-traitance

A utiliser en spécifique en génération personnalisée de notes (caractère 8)

10

Flag utilisé pour des traitements spécifiques en génération personnalisée de notes

A utiliser en spécifique en génération personnalisée de notes (caractère 8)

11

Cumul de gâches

Permet de calculer sur la formule matière un cumul de gâches saisies sur les opérations et la sous-traitance de différentes phases.

Voir les notes commençant par CUMUL_GFO, CUMUL_GFS, CUMUL_GVO, CUMUL_GVS, sur la formule matière.

O Calcul de gâches cumulées sur la formule matière

N Pas de cumul de gâches (Valeur par défaut)

12

Permet de calculer la quantité de la formule OPERATION sans tenir compte de la gâche FIXE saisie sur l'opération

N On ne tient pas compte de la gâche fixe. (par défaut)

O On tient compte de la gâche fixe

Note : Jusqu'à la V. 4.0.186.2, la valeur par défaut était O.

13

Permet la recherche des tarifs dans l'unité d'achat de la matière

O On utilise le coefficient de conversion de la fiche article pour la recherche du tarif

N On n'utilise pas de coefficient de conversion

X Le coefficient de conversion n'est pas pris en compte (Coefficient = 1)

14

Permet d'indiquer si le champ fm_v1 ou fo_v1 doit être converti dans l'outil de bascule EURO

I Conversion non paramétrée (valeur par défaut)

N Pas de conversion

O Conversion

Pour que l'outil de bascule Euro (bascule_euro_fle_matope) puisse être lancé, ce caractère doit être différent de I pour toutes les formules matières et opérations.

15

Permet d'indiquer si le champ fm_v2 ou fo_v2 doit être converti dans l'outil de bascule EURO

I Conversion non paramétrée (valeur par défaut)

N Pas de conversion

O Conversion

Pour que l'outil de bascule Euro (bascule_euro_fle_matope) puisse être lancé, ce caractère doit être différent de I pour toutes les formules matières et opérations.

16

Permet d'indiquer si les champs fm_quantite et fm_tot_qte ou fo_quantite et fo_tot_qte doivent être convertis dans l'outil de bascule EURO

I Conversion non paramétrée (valeur par défaut)

N Pas de conversion

O Conversion

Pour que l'outil de bascule Euro (bascule_euro_fle_matope) puisse être lancé, ce caractère doit être différent de I pour toutes les formules matières et opérations.

17

Paramétrage de la génération des stocks sur formule

O Génération de la formule dans le dossier de production avec création des mouvements de stock

S Génération de la formule dans le dossier de production sans création des mouvements de stock

N Pas de génération de la formule dans le dossier de production

18

Quelle quantité doit être utilisée lors de la génération de l'OF ?

Pour les formules matières :

Q Quantité calculée de la formule (par défaut)

1 Valeur calculée 1 de la formule (v1)

2 Valeur calculée 2 de la formule (v2)

3 Permet de générer l'OF en tenant compte du coefficient de conversion dans le coût total de la matière

T Valeur calculée 3 de la formule (v3)

4 Valeur calculée 4 de la formule (v4)

5 Valeur calculée 5 de la formule (v5)

6 Valeur calculée 6 de la formule (v6)

7 Valeur calculée 7 de la formule (v7)

8 Valeur calculée 8 de la formule (v8)

9 Valeur calculée 9 de la formule (v9)

0 Valeur calculée 10 de la formule (v10)

U Quantité forcée à 1

Pour les formules opérations :

Q Quantité calculée de la formule (par défaut)

1 Valeur calculée 1 de la formule (v1)

2 Valeur calculée 2 de la formule (v2)

T Valeur calculée 3 de la formule (v3)

4 Valeur calculée 4 de la formule (v4)

5 Valeur calculée 5 de la formule (v5)

6 Valeur calculée 6 de la formule (v6)

7 Valeur calculée 7 de la formule (v7)

8 Valeur calculée 8 de la formule (v8)

9 Valeur calculée 9 de la formule (v9)

0 Valeur calculée 10 de la formule (v10)

U Quantité forcée à 1

Pour les formules sous-traitance :

Q Quantité calculée de la formule

1 Valeur calculée 1 de la formule (V1)

2 Valeur calculée 1 de la formule (V2)

T Valeur calculée 1 de la formule (V3)

4 Valeur calculée 1 de la formule (V4)

5 Valeur calculée 1 de la formule (V5)

6 Valeur calculée 1 de la formule (V6)

7 Valeur calculée 1 de la formule (V7)

8 Valeur calculée 1 de la formule (V8)

9 Valeur calculée 1 de la formule (V9)

0 Valeur calculée 1 de la formule (V10)

U Quantité forcée à 1 (par défaut)

19

Initialisation du prix de vente (VERIFIER)

1 à zéro si pas de clé tarifaire

2 avec valeur calculée anciennement si pas de clé tarifaire

20

Initialisation du prix de vente (VERIFIER)

1 à zéro si pas de tarif trouvé

2 avec valeur calculée anciennement si pas de tarif trouvé

21

Calcul de la formule de cadence

Voir le code calcul CC

1 Prise en compte des variables de cadences
(Accès par la touche F11 dans la saisie des formules) pour le calcul de la formule de cadence

2 Prise en compte des variables des codes v1
(Accès par la touche F9 dans la saisie des formules) pour le calcul de la formule de cadence

22

Prise en compte de la gâche selon une formule

D Gâche de finition prise dans les tables (article/opération) (Par défaut : fonctionnement inchangé)

O Gâche de finition saisie sur les données complémentaires

P Gâche de finition paramétrable sur la formule ### #GF

L Gâche de finition saisie sur le paramètre de type TPR

N Gâche de finition recherchée sur l'opération IMF-IMF-GF

F Gâche de finition recherchée sur les notes de la formule

Voir les notes GACHE_FIXE et GACHE_VARIABLE sur la formule

R Gâche de finition recherchée sur les notes de la formule quand le devis en cours est un devis de fabrication réel.
Gâche de finition prise dans les tables (article/opération) quand le devis en cours est un devis commercial ou de fabrication non réel
Voir les notes GACHE_FIXE_REEL et GACHE_VARIABLE_REEL sur la formule, et le code calcul TC.

Voir aussi #CF DEG alpha1[45]

23

Mise à jour des prix des lignes de références multiples

G Mise à jour globale (proratisation par rapport à la surface, par défaut)

R Mise à jour seulement pour le numéro de ligne de référence concernée.

A Mise à jour avec gestion de l'amalgame + d'info

Formule de calage : Répartition selon le nombre de références rattachées à la référence concernée (y compris celle-ci)

Formule de roulage : Répartition selon les quantités des références rattachées à la référence concernée (y compris celle-ci)

I Aucune mise à jour

24

Utilisation de la quantité paramétrée sur la formule pour les gâches cumulatives

O Les quantités sont calculées à partir du paramétrage de la formule.

N Les quantités sont calculées selon le fonctionnement des gâches cumulatives (par défaut).

25

Prise en compte de la formule dans le calcul des gâches cumulatives

O La formule est prise en compte (par défaut).

N La formule n'est pas prise en compte.

26

Récapitulatif des temps et cadence de la gamme

Désignation du temps et de la cadence de l'opération pour le calcul du temps total des opérations attachées à la phase.

O La formule est prise en compte (par défaut)

N ne prend en compte ni le temps de l'opération, ni la cadence

C désigne la cadence à prendre en compte, le temps est également pris en compte pour le cumul des temps de la phase.

27

Mode d'affichage des lignes de phases du devis standard (F18)

Permettre de ne pas afficher certaines lignes (formules) dans le tableau de visualisation du détail des phases

O La ligne est toujours affichée (par défaut).

N La ligne n'est jamais affichée.

Q La ligne est affichée si la quantité toute gâche est différente de 0 (zéro).

V La ligne est affichée si la valeur (montant et/ou frais) est différente de 0 (zéro).

1 La ligne est affichée si la condition Q ou V est vérifiée.

2 La ligne est affichée si les conditions Q et V sont vérifiées.

28

Permet de transférer la formule en dossier même si son prix est zéro

O Autorise le transfert de la formule en dossier si le prix est égal à zéro

N Interdit le transfert de la formule en dossier si le prix est égal à zéro

Q Autorise le transfert de la formule en dossier si la quantité est supérieure à zéro (quelque soit le prix)

29

Intégration unique lors de la génération du cadencement de fabrication

Voir la fiche d'installation

O La formule ne sera prise en compte et intégrée que lors de la génération du premier cadencement de fabrication

N La formule sera prise en compte pour tous les cadencements de fabrication (par défaut)

30

Génération de besoins matière

I Ignore - on ne génère pas de besoin matière.

A on génère un besoin sur la matière (fle_mat.fm_matiere)

E on génère un besoin sur le papier de l'entité (fle_imp.fi_c_papier)

et la quantité dépend de la formule (provient de fle_mat)

P on génère un besoin sur produit et quantité de l'entité (fle_imp.fi_prod_ent et fle_imp.fi_qteent)

31

Prise en compte de la gâche

0 Quantité totale – quantité de l'opération (soit le fonctionnement actuel)

F Gâche fixe de l'opération

V Gâche variable de l'opération

T Gâche fixe + gâche variable de l'opération

1 Valeur 1 de l'opération

2 Valeur 2 de l'opération

32

Ce paramètre permet d'utiliser les données de la formule matière au lieu des données de la fiche article (longueur, largeur, hauteur et poids)

O On utilise les données de la formule matière.

N On utilise les données de la fiche matière.

33

Multiplication de la gâche fixe par la quantité de la formule

O/N, N par défaut

34

Provenance de la donnée technique 1 de la table fab0 (f0_dt1)

#CF ATL A1[46] = O

Q Quantité calculée (Par défaut) (fm_quantite de la table fle_mat)

1 Valeur 1 de la formule (fm_v1 de la table fle_mat)

2 Valeur 2 de la formule (fm_v2 de la table fle_mat)

3 Valeur 3 de la formule (fm_v3 de la table fle_mat)

4 Valeur 4 de la formule (fm_v4 de la table fle_mat)

5 Valeur 5 de la formule (fm_v5 de la table fle_mat)

6 Valeur 6 de la formule (fm_v6 de la table fle_mat)

7 Valeur 7 de la formule (fm_v7 de la table fle_mat)

8 Valeur 8 de la formule (fm_v8 de la table fle_mat)

9 Valeur 9 de la formule (fm_v9 de la table fle_mat)

0 Valeur 10 de la formule (fm_v10 de la table fle_mat)

35

Provenance de la donnée technique 2 de la table fab0 (f0_dt2)

#CF ATL A1[46] = O

Quantité calculée (Par défaut) (fm_quantite de la table fle_mat)

1 Valeur 1 de la formule (fm_v1 de la table fle_mat)

2 Valeur 2 de la formule (fm_v2 de la table fle_mat)

3 Valeur 3 de la formule (fm_v3 de la table fle_mat)

4 Valeur 4 de la formule (fm_v4 de la table fle_mat)

5 Valeur 5 de la formule (fm_v5 de la table fle_mat)

6 Valeur 6 de la formule (fm_v6 de la table fle_mat)

7 Valeur 7 de la formule (fm_v7 de la table fle_mat)

8 Valeur 8 de la formule (fm_v8 de la table fle_mat)

9 Valeur 9 de la formule (fm_v9 de la table fle_mat)

0 Valeur 10 de la formule (fm_v10 de la table fle_mat)

36

Colonne total quantité paramétrable sur chaque formule

Provenance de la valeur de la colonne Total dans le détail des phases du devis multi-métiers (formules matières)

T Valeur ignorée (par défaut)

1 Valeur v1

2 Valeur v2

3 Valeur v3

4 Valeur v4

5 Valeur v5

6 Valeur v6

7 Valeur v7

8 Valeur v8

9 Valeur v9

10 Valeur v10

37

Formule à utiliser pour initialiser la zone fab1.f1_coef

N Pas d'initialisation (par défaut)

1 Formule de calcul fle_ope.fo_v1

2 Formule de calcul fle_ope.fo_v2

3 Formule de calcul fle_ope.fo_v3

4 Formule de calcul fle_ope.fo_v4

5 Formule de calcul fle_ope.fo_v5

6 Formule de calcul fle_ope.fo_v6

7 Formule de calcul fle_ope.fo_v7

8 Formule de calcul fle_ope.fo_v8

9 Formule de calcul fle_ope.fo_v9

0 Formule de calcul fle_ope.fo_v10

P Formule de calcul v1 obtenue à partir des gâches cumulatives paramétrées dans la note FORMULE_COEFF_POSE de la formule de l'opération en cours.


.C2 Complexité impression

Valeur numérique 1

Pourcentage d'encrage par défaut.

Valeur alpha 1

Caractères 1 à 15

code encre par défaut


.CB Catégorie de bureau

SPECIFIQUE

Valeur alpha 1

Caractère 1 | Bureau groupeur (O/N, N par défaut)
Caractère 2 | Suspension de TVA (O/N, N par défaut)


.CC Code commande

SPECIFIQUE

Valeur alpha 1

Caractère 1 | Non utilisé
Caractère 2 | Suspension de TVA (O/N, N par défaut)
Caractère 3 | Grand Jeu autorisé pour ce type de commande


.CD Complexité découpe

Le code est stocké dans le TSC 045 (ic_char3_2).

Valeur alpha 1

Caractère 1

Présence de forme de découpe (O/N)

Si A1[1] = O :

- Il y a un outil "forme de découpe"

- Il y a obligatoirement une machine de type "DECoupe" dans la gamme.

- Il permet l'automatisation du calcul du nombre de poses (sans imbrication) dans une architecture automatique.

- il a un impact sur la recherche automatique de gamme puisqu'il permet de ne sélectionner que les gammes ayant l'indicateur de découpe à O ou à I.

Caractères 2 à 3

Code produit pour le transfert PC-Topp

(Zone 009 de OT-DATA – Offset VoluPack : [71,73])

Caractères 5 à 9

Rogne à prendre en compte dans le sens travers

Voir #CF DKP note PINCES_SYSTEMATIQUES

Caractères 10 à 14

Rogne à prendre en compte dans le sens machine

Voir #CF DKP note PINCES_SYSTEMATIQUES

Valeur alpha 2

Caractères 1 à 15

Consommables


.CE Type de cerclage

Valeur alpha 1

.CE A1[1,3]

Code cerclage OMP.2

Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Layerstrappinginfo.

Plus d'explication dans le #CF OMP

[ou]

Code feuillard sur 2 caractères à envoyer au système PCTOPP

Caractères 1271 à 1272 de la zone 082 du fichier OTDATA

Notes

OTDATA_ROTATION | 21 Code rotation pour OTDATA - SPECIFIQUE
OTDATA_CERCLAGE | 21 Code programme de cerclage (0 à A) - SPECIFIQUE


.CG Groupabilité carton

Valeur alpha 1

Caractère 1 à 1

O si groupable

N si non groupable


.CI Contraintes d'impression

Valeur alpha 2

Caractères 1 à 3

Famille de contrainte d'impression
Exemple : PLA à plat


.CO Codes couleurs

Valeur alpha 1

Caractère 1 | O Présence de pré-impression N Pas de pré-impression (par défaut)
Caractère 2 | Couverture extérieure (O/N) (N par défaut)
Caractère 3 | Couverture intérieure (O/N) (N par défaut)


.CP Tarif client Prosper

[Néant]


.CQ Codes qualité

Valeur numérique 1

Délai LABO à prendre en compte dans le calcul des dates. Ne pas saisir de décimales

Valeur alpha 1

Caractère 1 | Code qualité pour le transfert PC-Topp
Caractères 2 à 4 | Code assurance qualité pour PC-Topp (Zone 020)
Caractères 5 à 10 | Code machine laboratoire pour PC-Topp
Caractère 11 | Blocage laboratoire (O/N, N par défaut)
Caractères 12 à 14 | Code blocage laboratoire (remplace le code par défaut LAB) Doit être défini en tant que blocage laboratoire dans le paramètre BLO.


.CR Complexité de réglage outil

Valeur alpha2

Caractères 1 à 15

Consommables


.DC Description des caisses

Valeur numérique 1

Poids en gramme de la caisse

Valeur numérique 2

Contenance en unité de colisage

Valeur alpha 1

Caractères 1 à 15

Code de stockage de la caisse.

Valeur alpha 2

Caractères 1 à 10

Type d'almanach contenu dans cette caisse

(On peut mettre plusieurs types dans cette zone)

Type 1 Peut contenir tous les almanachs (sauf ceux de type 3)

Type 2 Peut contenir tous les almanachs (sauf ceux de type 3)

mais certains almanachs vont obligatoirement dans cette caisse.

Type 3 Peut contenir qu'une seule sorte d'almanachs ; cela correspond au colis spécial


.DE Nombre d'exemplaires

Pour les éditions VoluEdit

Valeur alpha 1

Caractère 1 | O/N autorise l'édition de l'exemplaire ateliers
Caractère 2 | O/N autorise l'édition de l'exemplaire planning
Caractère 3 | O/N autorise l'édition de l'exemplaire expéditions
Caractère 11 | O/N autorise l'édition de la fiche auto - contrôle
Caractère 12 | O/N autorise l'édition de la fiche petit façonnage
Caractère 13 | O/N autorise l'édition du certificat de conformité
Caractère 14 | O/N autorise le lancement du programme CAO

Valeur alpha 2

Caractères 1 à 3

Nombre d'exemplaires de l'OF à éditer (voluedit_oex)


.EP Position des étiquettes

Valeurs numériques

1

Nombre d'étiquettes nécessaires

Valeur alpha 1

A1[1]

Type concerné pour la position sur la palette

E Position d'une étiquette

C Position d'une caisse témoin

2 (ou [blanc]) Position d'une étiquette et/ou caisse témoin (par défaut

Permettre de saisir dans l'écran de détail du conditionnement (touche F8 sur écran du conditionnement) la position de la caisse témoin et de l'étiquette sur la palette.

Remarques :

• L'accès au détail du conditionnement est autorisé dans les cas suivants :

o Si un des saisies des informations complémentaires du conditionnement sont paramétrées (notes CONDIT_INFO_COMP sur le paramètre de lancement de la saisie des devis onduleur),

o Si le type de paramètre .EP existe dans la base de données.

• La position de la caisse témoin sur la palette sera enregistrée dans l'information complémentaire TSC 255, zone ic_char3_1, sur le produit fini.

• La position de l'étiquette sur la palette sera enregistrée dans l'information complémentaire TSC 250, zone ic_char3_2, sur le produit fini.

• Les paramètres de positions d'étiquettes .EP peuvent concerner une étiquette et/ou une caisse témoin.
Par défaut, le code paramètre peut être saisi pour les deux.


.ET Type d'étiquette

Valeur alpha 1

Caractères 2 à 4

Code paramètre de modèle de document (Type paramètre MDO)


.FC Force de la composition

Valeurs numériques

1

Poids de la force de la composition


.FE France / Export

Valeur alpha 1

Caractères 1 à 10

Numéro de compte 411 pour le transfert en comptabilité


.FF Formule firme

Valeur alpha 1

Caractères 1 à 2 | Nombre de passages
Caractères 3 à 7 | Coefficient de roulage
Caractères 8 à 12 | Coefficient de calage


.HA Habillage

Code de l'habillage (utilisé par VoluOptimix)

Stocké dans le TSC 390 zone F.


.J2 Position patte

Le code est stocké dans le TSC 050 (zone ic_char3_2)

Valeur alpha 1

Caractère 1

O si positions 1/2T, 1/2F, etc

N sinon

Permet de déterminer la valeur de la dépendance pour le code calcul PS (pattes spéciales)

Valeur alpha 2

Caractère 1 | inutilisé
Caractère 2 | Position de la patte G Gauche D Droite (par défaut)


.J3 Patte intérieure / extérieure

Le code est stocké dans le TSC 050 (zone ic_char30)

Valeur alpha 1

Caractère 1 | Patte extérieure (O/N) Permet de déterminer la valeur de la dépendance pour le code calcul PS (pattes spéciales) Utilisé si contrôle machine 011 (voir TMC, notes commençant par C).
Caractères 2 à 4 | Position de la patte droite / gauche. Doit exister dans le paramètre .J2 Possibilité d'initialiser la position de la patte (paramètre .J2) dans l'écran Architecture du devis onduleur.


.J4 Prolongement patte

.J4 Prolongement patte dessus/ dessous

Le code est stocké dans le TSC 055 (ic_char3_1 / ic_char3_2)

Valeurs numériques

1

Valeur de la patte. Si pas de patte, saisir 0 (zéro)


.JE Type de jonction

Le code est stocké dans le TSC 050 (zone ic_char3_1)

Valeur alpha 1

Caractères 1 à 15

Consommables

Valeur alpha 2

Caractères 1 à 3 | Famille de jonction Utilisée par exemple pour la recherche de dépendance pour les contrôles de possibilité machine Exemples AG1 Agrafe de type 1 : Famille AGR AG2 Agrafe de type 2 : Famille AGR
Caractères 4 à 6 | Code de la dimension calculée pour calculer la longueur de la caisse conditionnée. Par défaut, on prend LPC. Permet, en fonction du mode d'assemblage, de spécifier des formules de calcul différentes. Cas, par exemple, des caisses jonctionnables livrées à plat.
Caractères 7 à 9 | Code de la dimension calculée pour calculer la largeur de la caisse conditionnée. Par défaut, on prend BPC. Permet, en fonction du mode d'assemblage, de spécifier des formules de calcul différentes. Cas, par exemple, des caisses jonctionnables livrées à plat.
Caractères 10 à 12 | Code de la dimension calculée pour calculer l'épaisseur de la caisse conditionnée. Par défaut, on prend EPA. Permet, en fonction du mode d'assemblage, de spécifier des formules de calcul différentes. Cas, par exemple, des caisses jonctionnables livrées à plat.

Valeur alpha 3

Caractère 1 | N Si le code jonction signifie Non jonctionné (ex. Livré à plat). S'applique par exemple au code paramètre NJ.
Caractère 2 | Ouverture automatique de l'écran des pointages (ECMA) après la saisie du champ jonction (O/N) pour ce code jonction dans le devis_tc (O/N, N par défaut)

Notes

TP | Taille de la patte 4,6 Code profil carton 7,9 Taille de la patte en mm
LPC Longueur caisse pliée BPC Largeur caisse pliée EPA Epaisseur caisse pliée | 4,6 Code profil carton 7,60 Formule de calcul


.LE Liste d'encartage

Zones alpha 1, alpha 2, alpha 3, alpha 4

De 2 caractères en 2 caractères, indiquez les départements composant la liste.

Attention, seuls les 30 premiers caractères de la zone alpha 4 sont pris en compte pour l'attribution des départements de la liste.

On peut ainsi indiquer au maximum 100 départements par liste.


.MG Mode de gestion palette

Valeur alpha 1

Caractère 1

Palette consignée (O/N, O par défaut)

Utilisé dans G_blv_ed1


.NC Natures de commande

Valeur alpha 1

Caractère 1

Type de produit

N Nouvel article

W Ancien

P Test

M Article modifié


.OI Options d'impression

Valeur numérique 1

Nombre de couleurs

Valeur alpha 1

Caractères 1 à 15

Code consommable

Valeur alpha 2

Caractère 1 à 3 | Type d'option Impression
Caractère 5 | O le référentiel pour le calcul de l'impression n'est plus la surface de la caisse mais la surface imprimée définie par
Caractères 6 à 8 | Type de flexo utilisé pour cette option impression - SPECIFIQUE FHD Flexo haute définition STD Flexo standard (blanc) Pas de gestion spécifique des flexos sur la fiche de spécification (par défaut)

Valeur alpha 3

Caractère 1 à 6

Valeur numérique
Utilisé dans devis_ondu
Le code du paramètre .OI doit correspondre au code d'option impression utilisé dans la formule de calcul.


.ON Oui/Non

Utilisé pour vérifier la réponse aux questions de type O/N (Oui / Non)


.OO Options onduleuse

Valeurs numériques

1 | Valeur par défaut de la zone numérique associée à l'option onduleuse
2 | Laize maximum autorisée pour cette option onduleuse

Valeur alpha 1

(Spécifique K)

Caractères 1 à 15

Code de l'article consommable associé

Caractères 16 à 18

Numéro de formule pour le calcul du coefficient de nomenclature

001 Coeff Nomenclature = Surface ondulée en m2 X Consommation (donnée Technique 2 fiche article) X taux de couverture (Valeur numérique de l'option onduleuse en %)
Prix tarif = Prix au Kilo

002 Coeff Nomenclature = Nombre de Bandes X coupe
Prix tarif = Prix au ML
Exemple : Bandes

003 Coeff Nomenclature = Surface extrudée en M2 X Pourcentage (donnée Technique 2 fiche article)
Prix tarif = Prix au M2
Exemple : Film de protection pour les plaque extrudées

004 Coeff Nomenclature = Surface ondulée en m2 X Consommation (donnée Technique 2 fiche article) X taux de couverture (Valeur numérique de l'option onduleuse en %)
La consommation est variable en fonction du profil carton, c'est à dire que la consommation est donnée par "face collée"
Prix tarif = Prix au Kilo
Exemple : Colle RH

005 Coeff Nomenclature = Nombre de Bandes X coupe brute de la plaque
Prix tarif = Prix au ML
Exemple : Bandes

006 Réservée aux protections palettes

007 Réservée aux protections palettes

008 Coefficient de nomenclature = Constante paramétrée / Nombre de PF par colis

009 Coefficient de nomenclature = (laize unitaire + longueur de débord (=constante paramétrée)) X Consommation (donnée Technique 2 fiche article) X coefficient (Valeur numérique de l'option onduleuse)

Caractères 19 à 24

Paramétrage de la formule pour le calcul du coefficient de nomenclature

Si numéro de formule = 009 : Valeur de la constante

Valeur numérique comprise entre 0 et 999999 ou

mp_dt1 à mp_dt8 : donnée technique du PF.

Exemples : 100 ou mp_dt3

Caractères 25 à 29

Rive à prendre en compte dans le sens travers (ouverture)

Voir la note LISTE_OO_POUR_RIVES dans #CF DKP

Caractères 30 à 34

Rive à prendre en compte dans le sens machine (poussée)

Voir la note LISTE_OO_POUR_RIVES dans #CF DKP

Caractère 35

Doit-on saisir la cote dans le tableau de saisie des options onduleuse (O/N, O par défaut)

Voir la note LISTE_OO_POUR_RIVES dans #CF DKP

Valeur alpha 2

Caractères 1 à 3 | Famille d'option onduleuse Exemple TSU Traitement de surface Cette famille est utilisée par le code calcul OO afin de réduire le nombre de dépendances. La famille R est réservée aux options de type "Refouleurs supplémentaires" La famille C est réservée aux options de type "Couteaux supplémentaires"
Caractères 4 à 13 | Coût moyen du cliché dans le cas d'une option de type "Impression"
Caractère 14 | Contrôle colle RH activé (O/N, N par défaut)
Caractère 15 | Qualité groupable (O/N, O par défaut)
Caractère 16 | Code pointage à transférer à OMP T bande d'arrachage R pour raine supplémentaire … Si ce code n'est pas saisi, le pointage ne sera pas transféré vers OMP. Si ce code a pour valeur G ou C, ce n'est pas un pointage, mais une option onduleuse (traitement de surface, Michelman par exemple) G Cette option sera inscrite dans le tag BoardGlue de l'onduleuse. C Cette option sera inscrite dans le tag BoardCoating de l'onduleuse.
Caractères 17 à 31 | Code option à transférer vers le système de planification, pour les types G et C


.PO Potentiel de marché

Voir aussi .TY

Valeurs numériques

1 | Borne inférieure pour la détermination de la typologie de marché dans la construction du suivi budgétaire
2 | Borne supérieure pour la détermination de la typologie de marché dans la construction du suivi budgétaire

Valeur alpha 1

Caractère 1 | Port indiqué (O/N, N par défaut)
Caractères 2 à 16 | Correspondance code potentiel client (codé sur 2 positions)


.PP Protection palette

Lors de la validation d'un article en saisie simplifiée, une protection palette peut être automatiquement créée.

Suite à la création d'une protection palette, le tarif calculé à partir des informations saisies sur l'article peut être automatiquement créé.

Valeur alpha 1

Caractères 1 à 15

Code de l'article consommable associé à la protection palette (coiffe supplémentaire)

Valeur alpha 2

Caractères 1 à 3

Famille de protection palette

Exemple : FEU Feuillards

[ou]

Code de traitement pour envoyer au système PCTOPP

FIL : on enverra OUI (pour film)

FI2 : on enverra RNF (Prioritaire)

Sinon on envoi NON

Caractère 4

Si cette zone est à O cette protection palette sera transférée à PC-TOPP (OT-DATA).

Caractère 5

Edition de ce type de protection dans le récapitulatif du BL (O/N, N par défaut)

Caractère 6

O/N : Affichage des protections palettes dans l'édition des OF (O/N, N par défaut)

Caractère 7

Affichage des protections palettes dans l'édition de la fiche produit (O/N, N par défaut)

Caractère 8

Ajout des protections palettes au nombre total de palettes dans l'édition des BL (O/N, N par défaut)

Caractères 9 à 11

Numéro de formule pour le calcul du coefficient de nomenclature

001 Réservée aux options onduleuses

002 Réservée aux options onduleuses

003 Coeff Nomenclature = Surface extrudée en M2 X Pourcentage (donnée technique 2 fiche article)
Prix tarif = Prix au M2
Exemple : Film de protection pour les plaques extrudées

004 Réservée aux options onduleuses

005 Réservée aux options onduleuses

006 Coeff Nomenclature = Constante paramétrée / Nombre de PF par palette
Voir caractères 12 à 17
Prix tarif = Prix à l'unité
Exemple : Coiffe

007 Coeff Nomenclature = Hauteur d'une pile / Distance entre chaque intercalaire / Nombre de PF par palette
Voir caractères 12 à 17
Prix tarif = Prix à l'unité
Exemple : Intercalaires

Ce numéro de formule est repris dans la note FORMULE_COEFNOM_DEF du #CF DKP.

Caractères 12 à 17

Paramétrage de la formule pour le calcul du coefficient de nomenclature

Si numéro de formule = 006 : Valeur de la constante
Valeur numérique comprise entre 0.99999 (.99999) et 999999

Si numéro de formule = 007 : Distance entre chaque intercalaire (en mm)
Valeur numérique comprise entre 0.99999 (.99999) et 999999

Caractère 18

Cette protection palette sera prise en compte dans le calcul du nombre de protection palette dans l'éditionVoluEdit des ordres de chargement (O/N, N par défaut)

Notes

OTDATA_BAND | 21 Programme de banderollage :0 à 7 - SPECIFIQUE
SUPREQPAL | 21,60 Complément de sélection sur la table mat pour la recherche des palettes


.RH Type de colle RH

Valeur alpha 1

Caractère 1

Type de contrôle colle RH (N / B / W / C, N par défaut)

Notes

N-

3,60 Message accompagnant le contrôle. 4 lignes sont autorisées.


.RV Recto / Verso

Pas de paramétrage particulier


.SC Type de colisage

Valeur numérique 1

Nombre de liens par colis

Valeur alpha 1

.SC A1[1] | Colisage O/N
.SC A1[2] | Calcul du conditionnement par rapport aux dimensions d’une caisse (O/N, N par défaut). Voir TSC 221 et TSC 22A.

Valeur alpha 2

.SC A2[1,15] | Code produit du suremballage rattaché au code colisage (Code de l'article consommable associé au code colisage)
.SC A2[16,18] | Code colisage OMP Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Bundlestrappinginfo. Plus d'explication dans le #CF OMP
.SC A2[19,21] | Numéro de formule pour le calcul du coefficient de nomenclature 008 : Coefficient de nomenclature = Constante paramétrée / Nombre de PF par colis Voir caractères 22 à 27 ci-dessous.
.SC A2[22,27] | Paramétrage de la formule pour le calcul du coefficient de nomenclature Si numéro de formule (caractères 19 à 21) = 008 : Valeur de la constante (valeur numérique comprise entre 0.99999 et 999999)


.SE Semaines particulières

Le #CF CHA donne la répartition générale par jour de la charge atelier.

Par exception, on précise une répartition différente pour une semaine particulière sur le paramètre .SE (cas des jours fériés par exemple).

Notes

POURC_OCCUP_JOUR

Permet de paramétrer le pourcentage de charge cumulée par jour

21 à 22 Jour de la semaine (LU, MA, ME, JE, VE, SA, DI)

25 à 29 Pourcentage de charge minimum

30 à 34 Pourcentage de charge maximum

Exemples

POURC_OCCUP_JOUR LU 0 20

POURC_OCCUP_JOUR MA 20 40

POURC_OCCUP_JOUR ME 40 60

POURC_OCCUP_JOUR JE 60 80

POURC_OCCUP_JOUR VE 80 100


.SF Sens des fibres

Choix possibles :

O libre (LIB)

N ou 1 Oblig. Parallèles (OBL)

3 imp flle libre etui (IFE)

4 imp etui libre ffle (IEL)

La valeur O, N, 1, 3 ou 4 est stocké dans le TSC 500 zone G.


.SP Schéma de palettisation

2 algorithmes : Onduleurs et Transformateurs

>>> Algorithme 1 : Devis onduleur

Valeurs numériques

1 | Nombre total de piles sur la palette
2 | Nombre de piles sur la largeur de la palette

Valeur alpha 1

Caractère 1 | Calculable (O/N)
Caractère 2 | P Piles en parallèle T Piles en tournant
Caractère 50 | Réservé VSW

Valeur alpha 3

Caractères 1 à 4 | Hauteur maximum du schéma de palettisation Utilisé pour l'optimisation du conditionnement dans le devis onduleur.
Caractères 5 à 8 | Hauteur optimisée du schéma de palettisation Utilisé pour l'optimisation du conditionnement dans le devis onduleur.
Caractère 9 | 1 Gerbage optimisé du schéma de palettisation (seule valeur autorisée et obligatoire) Utilisé pour l'optimisation du conditionnement dans le devis onduleur.

Valeur alpha 4

Caractères 1 à 60

Code schéma de palettisation standard pour affichage du schéma

Utilisé pour l'optimisation du conditionnement dans le devis onduleur.

Si aucune valeur n'est renseignée, alors le nom de l'image recherchée sera xxx(code du type .SP).png.

Si une valeur est renseignée, alors le nom de l'image recherchée sera A4.png.

>>> Algorithme 2 : Devis transformateur

Valeurs numériques

1 | Nombre total de piles sur la palette
2 | Coefficient de stabilité

Valeur alpha 1

Détail calcul encombrement sens 1

Caractères 1 à 2 | Nombre de piles dans leur sens longueur
Caractères 4 à 5 | Nombre de piles dans leur sens largeur
Caractères 7 à 10 | Espacement des piles
Caractères 12 à 13 | Nombre de piles dans leur sens longueur
Caractères 15 à 16 | Nombre de piles dans leur sens largeur
Caractères 18 à 21 | Espacement des piles

L'algorithme utilisera le maximum entre les 2 encombrements calculés.

Valeur alpha 2

Détail calcul encombrement sens 2

Caractères 1 à 2 | Nombre de piles dans leur sens longueur
Caractères 4 à 5 | Nombre de piles dans leur sens largeur
Caractères 7 à 10 | Espacement des piles
Caractères 12 à 13 | Nombre de piles dans leur sens longueur
Caractères 15 à 16 | Nombre de piles dans leur sens largeur
Caractères 18 à 21 | Espacement des piles

Les caractères 1 à 10 représentent la première possibilité de calcul de l'encombrement.

Les caractères 12 à 21 représentent la seconde possibilité de calcul de l'encombrement.

Notes communes aux 2 scénarios

IMG

21,60 Nom du fichier (Image)

Répertoire : par défaut celui de GDC avec les autres images.

Sinon, il est possible d'indiquer un chemin.

Exemple ./schema_palettisation/avec_palette/06E_1)

Note cumulative


.TC Type de coiffe

(Offre de vente)

Valeur numérique 1

Epaisseur de la coiffe (en mm)


.TL Type de ligne de commande

Valeur alpha 1

Caractère 1 | Prélèvement systématique O Oui N Non E Prélèvement si existence TSC sur article Le TSC est paramétré sur une zone de type char (ic_char3_1, ic_char3_2 ou ic_char30) du CIC C25.
Caractère 2 | Caractère numérique à transférer dans l'OTDATA PCTOPP en zone 078
Caractère 3 | X Caractère désignant l'interdiction du changement de qualité On remplit la zone 61 (position1102) avec la valeur saisie Valeurs possibles : X ou espace
Caractère 4 | Caractère à transférer dans OT-DATA PC-TOPP, zone 79 (offset 1234)


.TP Type de palette

Valeur alpha 1

.TP A1[1] | Palette spécifique client (O/N)
.TP A1[2) | Palette multi-client (O/N, N par défaut) Voir TSC 23A à 23J
.TP A1[3] | Type sans palette (O/N, N par défaut) Utilisé par le devis onduleur. Dans le cadre des devis sans palette (palette au format du produit fini), on renseigne automatiquement l'encombrement de la palette (et le code palette utilisé). Le conditionnement est calculé par rapport au PF.
.TP A1[4] | Edition de ce type de palette dans le récapitulatif du BL (O/N, N par défaut)
.TP A1[5] | Palette de type vrac (O/N, N par défaut) Dans l'édition technique du devis onduleur, on calcule le nombre de PF contenus dans un camion complet. On ne fait plus le calcul pour les palettes de type vrac.
.TP A1[6,8] | Type de palette OMP Si non paramétré, on prend le code VoluPack (p2_code) pour alimenter la zone Labeltype. Plus d'explication dans le #CF OMP


.TR Type de refouleur

Valeur alpha 1

1

(Spécifique) Type de refouleur : Zone 18 du transfert OT-DATA de PC-TOPP


.TS Traitement de surface

Valeur numérique 1

Dépendance pour le roulage découpe (DEC DEC ROU)

0 Cadence normale

1 Cadence réduite

Valeur numérique 2

Calcul de la consommation de vernis offset dans le devis

0 Pas de consommation de vernis offset

1 Consommation de vernis offset


.TY Typologie portefeuille

Voir aussi .PO

Valeurs numériques

1 | Borne inférieure pour la détermination de la typologie de portefeuille dans la construction du suivi budgétaire
2 | Borne supérieure pour la détermination de la typologie de portefeuille dans la construction du suivi budgétaire


.VE Vernis

Valeur alpha 1

Caractères 1 à 15

Code matière vernis rattaché au type de vernis


Codes calculs des devis

Permet de retourner une valeur booléenne (O/N, 1/0) et/ou un coefficient lorsqu'une ligne d'impression multiple est basculée (Valeurs = Oui, in8 ou in12)

Remarques :

Il y a présence de bascule si la valeur de bascule est :

• O : Oui

• 8 : bascule in8

• 1 : bascule in12

Il n'y a pas présence de bascule si la valeur de bascule est :

• N : Non

• E : Exclue

Soit :

- une fiche de conditionnement stockée sur le TSC 220 de la référence.

- sur cette fiche de conditionnement, le code caisse stocké sur le TSC CND.

La recherche du code caisse se paramètre de la façon suivante :

Note sur la formule de calcul : VAR_J 220G

Dans le détail de la formule : TC JCNDG

CODES CALCUL DES DEVIS

Cette documentation s'applique à tous les devis SAUF LES DEVIS ONDULEURS.

AM - Information amalgames

An - Chaînes alpha aux valeurs LCO

AS - Assemblage (Reliure)

C2 - Données d'une LCO avec delta par la donnée numérique 1 d'une autre

CA - Données complémentaires

CC - Calcul des formules de cadence

CD - Conditionnement

CF - Décomposition de la forme imprimante

CH - Nombre de cahiers

CI - Infos clients

CL - Nombre de couleurs

CN - Données complémentaires

CO - Coupe

CT - Coûts des phases (Matière / Opération / St / Frais)

DE - Décomposition de la forme imprimante (type de pli)

DI - Dimension

EN - Encre et vernis (détermination du poids en kg)

FC - Résultat d'une formule de calcul de feuille_calcul

FM - Façonnage multi-passages

FN - Finition

GI - Recherche gâches intermédiaires

GN Génération automatique de codes difficultés

IE - Informations entité

IF - Informations de fabrication

IM - Impression

LA - Laize

MA - Recherche infos matières

MC - Machine

MD - Mise à jour des gâches d'une opération sur une phase

MH - Infos machine

MI - Mitraillage

MJ - Mise à jour informations

MO - Montants

MP - Impression multi-passages

NP - Nombre de poses

OC - Opérations sur deux LCO

OP - Optimisation de placement

PA Papier

PC - Détermination des parcours

PF - Profil carton

PG - Paramètres généraux

PL - Informations plaques

PM - Liens entre machines et plis

PO - Calcul des Pointages

PR - Informations produit

PS - Cumul des quantités d'une phase sur les entités

PT - Cumul des quantités d'une phase sur une formule d'entités

QT - Quantités

QU - Qualité

RD - Recherche données opérations sur une phase

RF - Information référence multiple

RH Cumul des valeurs d'une entité

RM - Recherche données matières

RS - Recherche données sous-traitance

RT - Données matières pour la formule de transport paramétrable

RV - Recherche données sur phase courante

ST - Stockage

SU - Surfaces

TA - Infos provenant des tarifs

TB - Type de boîte et dimensions ECMA

TC - TSC

TI - Transport inter-sites

TP - Infos diverses devis (type de processus)

TS - Temps

TT - Temps total des opérations

VA - Valeur alphanumérique

VT - Variables de traitement

Facteur multiplicateur à appliquer au résultat

ATTENTION : NON VALABLE POUR TOUS LES CODES CALCULS !!!

Les codes calculs suivants n'appliquent pas le coefficient multiplicateur :

AS - MH - MI - OC - PS - RD - RH - RM - RS - RT - RV - TC - VT

D'autres codes utilisent les caractères 5 et 6 mais ne sont pas codés en dur pour désactiver le coefficient multiplicateur :

AM - C2 - CA - CL - CN - IE - MC - MD - TA - VA

Pour ces codes, il faut donc que #CF DEG alpha4[28] = O.

Si la zone est numérique, le caractère 6 du paramétrage permet de définir un facteur multiplicateur à appliquer au résultat.

Le caractère 5 permet d'indiquer s'il faut :

  • multiplier le résultat par le coefficient

  • diviser le résultat par le coefficient

  • ajouter le coefficient au résultat

  • soustraire le coefficient au résultat

Si le type est numérique :

Caractère 5 | * on multiplie le résultat par le coefficient (par défaut) / on divise le résultat par le coefficient + on ajoute le coefficient au résultat - on soustrait le coefficient au résultat < on arrondit au nombre entier le plus proche > on arrondit au nombre entier supérieur D on prend la partie décimale E on prend la valeur entière B on retourne un booléen (1 si >= 1, 0 si < 1) b on retourne un booléen (1 si > 1, 0 si <= 1) C on retourne un booléen (1 si <= 1, 0 si > 1) c on retourne un booléen (1 si < 1, 0 si >= 1)
Caractère 6 | 0 Coefficient 1 (par défaut) 1 Coefficient 10 2 Coefficient 100 3 coefficient 1 000 4 coefficient 10 000 5 coefficient 100 000 6 coefficient 1 000 000 7 coefficient 10 000 000 8 coefficient 100 000 000 9 coefficient 1 000 000 000

Si le type est alphanumérique :

Caractère 5

O on retourne un booléen (1 si O, 0 sinon)

N on retourne un booléen (1 si N, 0 sinon)

An - Chaînes alpha associées à la valeur LCO/A et LCO/B

Ce paragraphe regroupe les codes calcul suivants :

  1. Code calcul A1 : Chaîne alphanumérique 1 associée à la valeur LCO/A

  2. Code calcul B1 : Chaîne alphanumérique 1 associée à la valeur LCO/B

  3. Code calcul G1 : Chaîne alphanumérique 1 associée à la valeur LCO/G

  4. Code calcul H1 : Chaîne alphanumérique 1 associée à la valeur LCO/H

  5. Code calcul A2 : Chaîne alphanumérique 2 associée à la valeur LCO/A

  6. Code calcul B2 : Chaîne alphanumérique 2 associée à la valeur LCO/B

  7. Code calcul G2 : Chaîne alphanumérique 2 associée à la valeur LCO/G

  8. Code calcul H2 : Chaîne alphanumérique 2 associée à la valeur LCO/H

  9. Code calcul A3 : Chaîne alphanumérique 3 associée à la valeur LCO/A

  10. Code calcul B3 : Chaîne alphanumérique 3 associée à la valeur LCO/B

  11. Code calcul G3 : Chaîne alphanumérique 3 associée à la valeur LCO/G

  12. Code calcul H3 : Chaîne alphanumérique 3 associée à la valeur LCO/H

  13. Code calcul A4 : Chaîne alphanumérique 4 associée à la valeur LCO/A

  14. Code calcul B4 : Chaîne alphanumérique 4 associée à la valeur LCO/B

  15. Code calcul G4 : Chaîne alphanumérique 4 associée à la valeur LCO/G

  16. Code calcul H4 : Chaîne alphanumérique 4 associée à la valeur LCO/H

Caractère 1 à 3 | Code LCO
Caractère 4 à 5 | Numéro de caractère de début de chaîne (par défaut : 1)
Caractères 6 à 7 | Numéro de caractère de fin de chaîne (par défaut = caractère de début : récupération d'un seul caractère dans la zone])

Fonctionnalités

Permettre d'accéder au paramétrage (zones alpha 1, alpha 2, alpha 3 et alpha 4) associé aux valeurs des zones LCO/A (fc_a1) et LCO/B (fc_a2)

Le type de paramètre associé à la valeur est récupéré sur le paramétrage de la LCO en A1[1,6].

Exemples

LCO/EMF

Zone A (première zone de 3 caractères) associé au type de paramètre CND, valeur : HL

Zone B (deuxième zone de 3 caractères) associé au type de paramètre .ON, valeur : O

Exemples d'utilisation des codes calculs décrits ci-dessous:

A1/EMF1520 : Caractères 15 à 20 de la zone alpha 1 du paramètre CND/HL

A3/EMF18 : Caractère 18 de la zone alpha 3 du paramètre CND/HL

B1/EMF1 : Caractère 1 de la zone alpha 1 du paramètre .ON/O

B4/EMF2021 : Caractères 22 et 21 de la zone alpha 4 du paramètre .ON/O

AM - Informations amalgames

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

RETOUR NUMERIQUE

Caractères 1 et 2

Numéro de l'amalgame recherché

Si 00 : nombre d'amalgames saisis

Caractère 3

B Largeur de l'amalgame

C Recherche d'infos C sur le code ECMA de l'amalgame

caractères 4 à 6 : code TSC

caractère 7 : zone du TSC

E Infos code ECMA amalgames

caractère 4 = B : Type de boite

caractère 4 = M : Nombre de morceaux

H Hauteur de l'amalgame

K Information type de boite.

Caractère 4 = P : Code paramètre défini en alpha1[8,10] du code ECMA

Caractère 5 = 1 : Code défini position 8 à 10

Caractère 5 = 2 : Code défini position 11 à 13

Caractère 5 = 3 : Valeur 1 du KMA

Caractère 5 = 4 : Valeur 2 du KMA

Caractère 4 = D : Dimensions

Caractère 5 = 1 : Valeur de rp1

Caractère 5 = 2 : Valeur de rp2

Caractère 5 = 3 : Valeur de pp1

Caractère 5 = 4 : Valeur de pp2

Caractère 5 = 5 : Valeur de pp3

Caractère 5 = 6 : Valeur de pp4

Caractère 5 = 7 : Valeur de pc

Caractère 5 = 8 := Valeur de pp5

Caractère 5 = 9 : Valeur de pp6

Caractère 5 = O : Ouverture (Laize) -ST - Largeur étui

Caractère 5 = P : Poussée (Coupe) -SM - développé étui

L Longueur de l'amalgame

M Développe sens Machine

N Nombre de poses

P Pourcentage surface de l'amalgame

Q Quantité client sur amalgames

S Surface unitaire en cm2

T Développé sens Travers

Caractères 4 & 5

ATTENTION : UTILISATIONS DIFFERENTES DES CARACTERES 4 ET 5 !!!

Caractère 4

Voir caractère 3 = E

Voir caractère 3 = K

Caractère 5

Voir caractère 3 = K

Caractères 4 à 6

Voir caractère 3 = C

Caractère 7

Voir caractère 3 = C

AS - Assemblage (Reliure)

Cette formule ne peut pas utiliser le coefficient multiplicateur (bien que les caractères 5 et 6 ne soient pas utilisés...)

Retour numérique - actif seulement pour les opérations

Caractère 1 | Numéro du passage
Caractère 2 | 1 Nombre de postes 2 Nombre de jeux (multiples) 3 Nombre d'aides 4 Quantité assemblage

C2 - Données d'une LCO avec delta par la donnée numérique 1 d'une autre

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour alphanumérique

Le caractère 4 est utilisé autrement sur les autres codes calcul.

Sur les autres codes calcul, cette zone sert à rechercher une gâche intermédiaire.

On accède à la donnée alphanumérique d'une LCO. Cette valeur de LCO reprend la donnée [1 à 3] de la formule, plus la valeur [5,7]

Exemple C21006219

Je recherche la valeur 1 de la LCO 219. J'ajoute cette valeur (par ex. 3) à la LCO de base.(100 +3)= 103.

On utilise cette valeur et le caractère 4 pour retourner le code matière.

Caractères 1 à 3 | Code LCO de base
Caractère 4 | 1 Code section 2 Code opération ou phase 3 Code sous-opération 4 Code machine 5 Code difficulté 6 Code matière 7 Paramètre alpha 1 (3 caractères) 8 Paramètre alpha 2 (3 caractères) 9 Code famille du code matière A Code sous-famille du code matière B Code catégorie matière G Paramètre alphanumérique 3 (3 caractères) H Paramètre alphanumérique 4 (3 caractères)
Caractères 5 à 7 | Code de la LCO à ajouter

CA - Données complémentaires

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour alphanumérique

REMARQUE

Le caractère 4 est utilisé autrement sur les autres codes calcul.

Sur les autres codes calcul, cette zone sert à rechercher une gâche intermédiaire.

On accède à la donnée alphanumérique d'une LCO

Caractères 1 à 3

Code LCO

Caractère 4

1 Code section

2 Code opération ou phase

3 Code sous-opération

4 Code machine

5 Code difficulté

6 Code matière

7 Zone alphanumérique 1

Car.5 = A : A1[1,15] du paramètre saisi dans la zone

Car.5 = B : A2[1,15] du paramètre saisi dans la zone

Car.5 = D : A3[1,15] du paramètre saisi dans la zone

Car.5 = E : A4[1,15] du paramètre saisi dans la zone

8 Zone alphanumérique 2

Car.5 = A : A1[1,15] du paramètre saisi dans la zone

Car.5 = B : A2[1,15] du paramètre saisi dans la zone

Car.5 = D : A3[1,15] du paramètre saisi dans la zone

Car.5 = E : A4[1,15] du paramètre saisi dans la zone

9 Code famille du code matière - Ne plus utiliser : voir M

A Code sous-famille du code matière - Ne plus utiliser : voir M

B Code catégorie matière - Ne plus utiliser : voir M

F Code fournisseur

G Zone alphanumérique 3

Car.5 = A : A1[1,15] du paramètre saisi dans la zone

Car.5 = B : A2[1,15] du paramètre saisi dans la zone

Car.5 = D : A3[1,15] du paramètre saisi dans la zone

Car.5 = E : A4[1,15] du paramètre saisi dans la zone

H Zone alphanumérique 4

Car.5 = A : A1[1,15] du paramètre saisi dans la zone

Car.5 = B : A2[1,15] du paramètre saisi dans la zone

Car.5 = D : A3[1,15] du paramètre saisi dans la zone

Car.5 = E : A4[1,15] du paramètre saisi dans la zone

M Zone de la fiche matière

selon Caractère 5 :

A Code famille (mp_fam)

B Code sous-famille (mp_sfm)

C Code catégorie matière (mp_libre)

D Donnée technique alphanumérique 1 (mp_at1)

E Donnée technique alphanumérique 2 (mp_at2)

F Recherche du code fournisseur lu sur la fiche matière

Q Qualité matière (mp_qualite_matiere)

U Code unité d'achat (mp_ua)

Caractère 5

Utilisé si caractère 4 = 7 ou 8 ou G ou H ou M

Caractère 6

C Prise en compte des valeurs courantes saisies dans la LCO

V Prise en compte des valeurs de la LCO d'entité puis de la LCO d'entête si valeur non renseignée sur l'entité (cascade)

[autre] : Prise en compte des valeurs de la LCO d'entité ou de la LCO d'entête si LCO inexistante sur entité (par défaut)

CC - Calcul des formules de cadence

Activer la formule liée au code CAD (cadence) directement à partir des formules :

Si la première ligne de formule cadence (Formule Cad1 à l'écran) est renseignée, celle-ci sera prise en priorité.

Sinon, la formule prise en compte sera celle qui est paramétrée sur CAD A2[1,60] (fonctionnement actuel).

La deuxième ligne de formule cadence (Formule Cad2 à l'écran) ne sera prise en compte que si la première est renseignée.

Voir aussi ul_param[21].

Caractère 1 | 6 Valeur de la formule 1 7 Valeur de la formule 2 8 Valeur de la formule 1 * Valeur de la formule 2 9 Valeur de la formule 1 / Valeur de la formule 2 A Valeur de la formule 1 + Valeur de la formule 2 B Valeur de la formule 1 - Valeur de la formule 2 C Maximum entre la valeur de la formule 1 et la valeur de la formule 2 D Minimum entre la valeur de la formule 1 et la valeur de la formule 2
Caractère 2 | > Valeur arrondie au nombre entier le plus proche < Valeur arrondie au nombre entier supérieur D Partie décimale de la valeur E Partie entière de la valeur B Valeur booléenne Vrai si >= 1 Faux si < 1 b Valeur booléenne Vrai si > 1 Faux si <= 1 C Valeur booléenne Vrai si <= 1 Faux si > 1 c Valeur booléenne Vrai si < 1 Faux si >= 1

CD - Conditionnement

Retour numérique

Caractère 1

1 Nombre de palettes. Calcul et mise à jour du nombre de palettes.

2 Nombre de palettes. On va chercher la valeur déterminée plus haut

3 Nombre de palettes. On va chercher la valeur déterminée plus haut.

Ce nombre de palettes permettra de déterminer le nombre de palettes à mettre sous film.

4 On va chercher le code article paquet pour l'opération courante

sur le conditionnement correspondant.

5 On va chercher le nombre de paquets pour l'opération courante

sur le conditionnement correspondant.

6 Nombre d'exemplaires à emballer pour l'opération courante sur le conditionnement correspondant

7 On va chercher le nombre d' exemplaires par paquet pour l'opération courante

sur le conditionnement correspondant.

8 Code caisse de l'entité 9

9 Nombre de caisse de l'entité

A Nombre d'exemplaires par caisse de l'entité

B Code palette de l'entité

C Nombre d'exemplaires par palette de l'entité

D Nombre total de palettes du devis (du conditionnement, sans recalcul)

M Type de conditionnement à mettre à jour

Caractère 2 = 1 : Mise à jour des informations de paquets

Caractère 2 = 2 : Mise à jour des informations de caisses

Caractère 2 = 3 : Mise à jour des informations de palettes

Caractère 3 : Numéro de ligne dans la table fle_emb (1 par défaut)

Zone à mettre à jour (Paquet/Caisse/palettes) | Zone prise pour la mise à jour | Description de la zone
Code | fm_matiere | Code matière de la phase calculée
Poids | mp_poids | Poids de la matière de la phase calculée
Nombre | fm_v1 | Valeur V1 calculée pour la phase matière
Nombre d'exemplaires | fm_v2 | Valeur V2 calculée pour la phase matière

P Présence de conditionnement expert (F22, table fle_emb)

Caractère 2 :

N Retour numérique

Renvoie 1 si présence de conditionnement sur fle_emb

Renvoie 0 sinon

A Retour alphanumérique (par défaut)

Renvoie O si présence de conditionnement sur fle_emb

Renvoie N sinon

CF - Décomposition de la forme imprimante

Retour numérique

Caractère 1

1 Nombre de cahiers de la première ligne du CTRL-F

2 Nombre de pages de la première ligne du CTRL-F

3 Nombre de poses de la première ligne du CTRL-F

4 Nombres de poses au pliage minimum du devis

5 Nombres de poses au pliage de l'opération

6 Nombre de poses au pliage de la première ligne de décomposition (entité courante)

C Décomposition traitée en Coming & Going

Caractère 2 = A : Renvoie O/N (par défaut)

Caractère 2 = N : Renvoie 1/0 (1=O, 0=N)

P Présence de pliage de la première ligne de décomposition

Car.2 = A : Retour alphanumérique, renvoie O/N/R/L

O Présence de pliage sur plieuse dédiée

N Pas de présence de pliage

R Présence de refente seule

L Présence de pliage en ligne

Car.2 = N : Retour numérique, renvoie 1/0/2/3

1 Présence de pliage sur plieuse dédiée

0 Pas de présence de pliage

2 Présence de refente seule

3 Présence de pliage en ligne

CH - Nombre de cahiers

Retour numérique

Caractère 1

1 Nombre total de cahiers

2 Nombre de cahiers sur le passage courant

3 Nombre total d'encarts

4 Nombre d'encarts de type façonnage A et P-C

5 Nombre d'encarts jetés

6 Nombre d'encarts rapportés

7 Présence de pli difficile pour assembleuse et/ou assembleuse/couseuse

Car.2=E : Recherche de la présence sur l'entité courante uniquement

Car.2=[Autre] : Recherche de la présence sur le sous-devis courant (par défaut)

Car.3=A : Retour alphanumérique (O/N)

Car.3=N : Retour numérique (1/0) (par défaut)

CI - Infos clients

Retour numérique ou alpha

Caractère 1

1 Valeur numérique 1 du paramètre associé à la zone libre de la fiche client

Voir #CF CLI A1[31,33] - #CF CLI A3[16,18] - #CF CLI A3[34,36]

Car.2 = 1 ou [blanc] : Valeur numérique 1 du paramètre associé à la zone libre 1 de la fiche client du devis (cli.cl_zpar)

Car.2 = 2 : Valeur numérique 1 du paramètre associé à la zone libre 2 de la fiche client du devis (cli.cl_zpar2)

Car.2 = 3 : Valeur numérique 1 du paramètre associé à la zone libre 3 de la fiche client du devis (cli.cl_zpar3)

2 Valeur numérique 2 du paramètre associé à la zone libre de la fiche client

Voir #CF CLI A1[31,33] - #CF CLI A3[16,18] - #CF CLI A3[34,36]

Car.2 = 1 ou [blanc] : Valeur numérique 2 du paramètre associé à la zone libre 1 de la fiche client du devis (cli.cl_zpar)

Car.2 = 2 : Valeur numérique 2 du paramètre associé à la zone libre 2 de la fiche client du devis (cli.cl_zpar2)

Car.2 = 3 : Valeur numérique 2 du paramètre associé à la zone libre 3 de la fiche client du devis (cli.cl_zpar3)

3 Nombre de jours de crédit indiqué sur le code échéance habituel du client

Indiqué en valeur numérique 1 du code ECH.

Si caractère 2 = 2 : Prise en compte de la valeur numérique 2

4 Zone numérique paramétrable No 1

5 Tolérance livraison sur adresse principale (code alpha cl_tolerance_liv)

6 Tolérance livraison sur adresse secondaire (code alpha c2_tolerance_liv)

7 Présence de pli difficile pour assembleuse et/ou assembleuse/couseuse

Car.2 = E : Recherche de la présence sur l'entité courante uniquement

Car.2 = [Autre] : Recherche de la présence sur le sous-devis courant (par défaut)

Car.3 = A : Retour alphanumérique (O/N)

Car.3 = N : Retour numérique (1/0) (par défaut)

A Code tournée de livraison (cl_tournee_liv)

M Minimum de commande fournisseur

CL - Nombre de couleurs

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour numérique

Dans les lignes qui suivent, remplacer LCO par le code de la LCO.

1T Nombre de couleurs Recto + Verso (Typo)

1F Nombre de couleurs Recto + Verso (Flexo)

1O Nombre de couleurs Recto + Verso (Offset)

1S Nombre de couleurs Recto + Verso (Sérigraphie)

1P Nombre de couleurs Recto + Verso (Primaire)

2T Nombre de couleurs Recto (Typo)

2F Nombre de couleurs Recto (Flexo)

2O Nombre de couleurs Recto (Offset)

2S Nombre de couleurs Recto (Sérigraphie)

2P Nombre de couleurs Recto (Primaire)

2MLCO1 Nombre de couleurs Recto dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

2MLCO2 Nombre de couleurs Recto dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

2MLCO3 Nombre de couleurs Recto dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

2MLCO4 Nombre de couleurs Recto dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

21 Nombre de couleurs Recto du passage n°1

22 Nombre de couleurs Recto du passage n°2

23 Nombre de couleurs Recto du passage n°3

24 Nombre de couleurs Recto du passage n°4

25 Nombre de couleurs Recto du passage n°5

26 Nombre de couleurs Recto du passage n°6

27 Nombre de couleurs Recto du passage n°7

28 Nombre de couleurs Recto du passage n°8

29 Nombre de couleurs Recto du passage n°9

20 Nombre de couleurs Recto du passage n°10

2a Nombre de couleurs Recto du passage n°11

2b Nombre de couleurs Recto du passage n°12

2c Nombre de couleurs Recto du passage n°13

2d Nombre de couleurs Recto du passage n°14

2e Nombre de couleurs Recto du passage n°15

2f Nombre de couleurs Recto du passage n°16

2g Nombre de couleurs Recto du passage n°17

2h Nombre de couleurs Recto du passage n°18

2i Nombre de couleurs Recto du passage n°19

2j Nombre de couleurs Recto du passage n°20

3T Nombre de couleurs Verso (Typo)

3F Nombre de couleurs Verso (Flexo)

3O Nombre de couleurs Verso (Offset)

3S Nombre de couleurs Verso (Sérigraphie)

3P Nombre de couleurs Verso (Primaire)

3MLCO1 Nombre de couleurs Verso dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

3MLCO2 Nombre de couleurs Verso dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

3MLCO3 Nombre de couleurs Verso dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

3MLCO4 Nombre de couleurs Verso dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

4 Pourcentage d'encrage Recto + Verso

5MLCO1 Pourcentage d'encrage Recto dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

5MLCO2 Pourcentage d'encrage Recto dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

5MLCO3 Pourcentage d'encrage Recto dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

5MLCO4 Pourcentage d'encrage Recto dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

5T Pourcentage d'encrage Recto + Pourcentage de vernis Recto

51 Pourcentage d'encrage Recto du passage n°1

52 Pourcentage d'encrage Recto du passage n°2

53 Pourcentage d'encrage Recto du passage n°3

54 Pourcentage d'encrage Recto du passage n°4

55 Pourcentage d'encrage Recto du passage n°5

56 Pourcentage d'encrage Recto du passage n°6

57 Pourcentage d'encrage Recto du passage n°7

58 Pourcentage d'encrage Recto du passage n°8

59 Pourcentage d'encrage Recto du passage n°9

50 Pourcentage d'encrage Recto du passage n°10

5a Pourcentage d'encrage Recto du passage n°11

5b Pourcentage d'encrage Recto du passage n°12

5c Pourcentage d'encrage Recto du passage n°13

5d Pourcentage d'encrage Recto du passage n°14

5e Pourcentage d'encrage Recto du passage n°15

5f Pourcentage d'encrage Recto du passage n°16

5g Pourcentage d'encrage Recto du passage n°17

5h Pourcentage d'encrage Recto du passage n°18

5i Pourcentage d'encrage Recto du passage n°19

5j Pourcentage d'encrage Recto du passage n°20

6MLCO1 Pourcentage d'encrage Verso dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

6MLCO2 Pourcentage d'encrage Verso dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

6MLCO3 Pourcentage d'encrage Verso dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

6MLCO4 Pourcentage d'encrage Verso dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

6T Pourcentage d'encrage Verso + Pourcentage de vernis Verso

7 Pourcentage de vernissage Recto + Verso

8MLCO1 Pourcentage de vernissage Recto dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

8MLCO2 Pourcentage de vernissage Recto dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

8MLCO3 Pourcentage de vernissage Recto dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

8MLCO4 Pourcentage de vernissage Recto dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

81 Pourcentage de vernissage Recto du passage n°1

82 Pourcentage de vernissage Recto du passage n°2

83 Pourcentage de vernissage Recto du passage n°3

84 Pourcentage de vernissage Recto du passage n°4

85 Pourcentage de vernissage Recto du passage n°5

86 Pourcentage de vernissage Recto du passage n°6

87 Pourcentage de vernissage Recto du passage n°7

88 Pourcentage de vernissage Recto du passage n°8

89 Pourcentage de vernissage Recto du passage n°9

80 Pourcentage de vernissage Recto du passage n°10

8a Pourcentage de vernissage Recto du passage n°11

8b Pourcentage de vernissage Recto du passage n°12

8c Pourcentage de vernissage Recto du passage n°13

8d Pourcentage de vernissage Recto du passage n°14

8e Pourcentage de vernissage Recto du passage n°15

8f Pourcentage de vernissage Recto du passage n°16

8g Pourcentage de vernissage Recto du passage n°17

8h Pourcentage de vernissage Recto du passage n°18

8i Pourcentage de vernissage Recto du passage n°19

8j Pourcentage de vernissage Recto du passage n°20

9MLCO1 Pourcentage de vernissage Verso dans la zone numérique 1 de la LCO si machine forcée (fi_mac_forcee_* = M)

9MLCO2 Pourcentage de vernissage Verso dans la zone numérique 2 de la LCO si machine forcée (fi_mac_forcee_* = M)

9MLCO3 Pourcentage de vernissage Verso dans la zone numérique 3 de la LCO si machine forcée (fi_mac_forcee_* = M)

9MLCO4 Pourcentage de vernissage Verso dans la zone numérique 4 de la LCO si machine forcée (fi_mac_forcee_* = M)

A Nombre de couleurs primaires Recto + Verso

B1 Nombre de couleurs primaires Recto du passage n°1

B2 Nombre de couleurs primaires Recto du passage n°2

B3 Nombre de couleurs primaires Recto du passage n°3

B4 Nombre de couleurs primaires Recto du passage n°4

B5 Nombre de couleurs primaires Recto du passage n°5

B6 Nombre de couleurs primaires Recto du passage n°6

B7 Nombre de couleurs primaires Recto du passage n°7

B8 Nombre de couleurs primaires Recto du passage n°8

B9 Nombre de couleurs primaires Recto du passage n°9

B0 Nombre de couleurs primaires Recto du passage n°10

Ba Nombre de couleurs primaires Recto du passage n°11

Bb Nombre de couleurs primaires Recto du passage n°12

Bc Nombre de couleurs primaires Recto du passage n°13

Bd Nombre de couleurs primaires Recto du passage n°14

Be Nombre de couleurs primaires Recto du passage n°15

Bf Nombre de couleurs primaires Recto du passage n°16

Bg Nombre de couleurs primaires Recto du passage n°17

Bh Nombre de couleurs primaires Recto du passage n°18

Bi Nombre de couleurs primaires Recto du passage n°19

Bj Nombre de couleurs primaires Recto du passage n°20

C Nombre de couleurs primaires Verso

D Nombre de changements de plaque Recto + Verso

E Nombre de changements de plaques Recto

E1 Nombre de changements de plaques Recto du passage n°1

E2 Nombre de changements de plaques Recto du passage n°2

E3 Nombre de changements de plaques Recto du passage n°3

E4 Nombre de changements de plaques Recto du passage n°4

E5 Nombre de changements de plaques Recto du passage n°5

E6 Nombre de changements de plaques Recto du passage n°6

E7 Nombre de changements de plaques Recto du passage n°7

E8 Nombre de changements de plaques Recto du passage n°8

E9 Nombre de changements de plaques Recto du passage n°9

E0 Nombre de changements de plaques Recto du passage n°10

Ea Nombre de changements de plaques Recto du passage n°11

Eb Nombre de changements de plaques Recto du passage n°12

Ec Nombre de changements de plaques Recto du passage n°13

Ed Nombre de changements de plaques Recto du passage n°14

Ee Nombre de changements de plaques Recto du passage n°15

Ef Nombre de changements de plaques Recto du passage n°16

Eg Nombre de changements de plaques Recto du passage n°17

Eh Nombre de changements de plaques Recto du passage n°18

Ei Nombre de changements de plaques Recto du passage n°19

Ej Nombre de changements de plaques Recto du passage n°20

F Nombre de changements de plaque Verso

G Nombre de repiquages de plaque Recto + Verso

H1 Nombre de repiquages de plaque Recto du passage n°1

H2 Nombre de repiquages de plaque Recto du passage n°2

H3 Nombre de repiquages de plaque Recto du passage n°3

H4 Nombre de repiquages de plaque Recto du passage n°4

H5 Nombre de repiquages de plaque Recto du passage n°5

H6 Nombre de repiquages de plaque Recto du passage n°6

H7 Nombre de repiquages de plaque Recto du passage n°7

H8 Nombre de repiquages de plaque Recto du passage n°8

H9 Nombre de repiquages de plaque Recto du passage n°9

H0 Nombre de repiquages de plaque Recto du passage n°10

Ha Nombre de repiquages de plaque Recto du passage n°11

Hb Nombre de repiquages de plaque Recto du passage n°12

Hc Nombre de repiquages de plaque Recto du passage n°13

Hd Nombre de repiquages de plaque Recto du passage n°14

He Nombre de repiquages de plaque Recto du passage n°15

Hf Nombre de repiquages de plaque Recto du passage n°16

Hg Nombre de repiquages de plaque Recto du passage n°17

Hh Nombre de repiquages de plaque Recto du passage n°18

Hi Nombre de repiquages de plaque Recto du passage n°19

Hj Nombre de repiquages de plaque Recto du passage n°20

I Nombre de repiquages de plaque Verso

J Nombre de repiquages et changements de plaque Recto + Verso

K1 Nombre de repiquages et changements de plaque Recto du passage n°1

K2 Nombre de repiquages et changements de plaque Recto du passage n°2

K3 Nombre de repiquages et changements de plaque Recto du passage n°3

K4 Nombre de repiquages et changements de plaque Recto du passage n°4

K5 Nombre de repiquages et changements de plaque Recto du passage n°5

K6 Nombre de repiquages et changements de plaque Recto du passage n°6

K7 Nombre de repiquages et changements de plaque Recto du passage n°7

K8 Nombre de repiquages et changements de plaque Recto du passage n°8

K9 Nombre de repiquages et changements de plaque Recto du passage n°9

K0 Nombre de repiquages et changements de plaque Recto du passage n°10

Ka Nombre de repiquages et changements de plaque Recto du passage n°11

Kb Nombre de repiquages et changements de plaque Recto du passage n°12

Kc Nombre de repiquages et changements de plaque Recto du passage n°13

Kd Nombre de repiquages et changements de plaque Recto du passage n°14

Ke Nombre de repiquages et changements de plaque Recto du passage n°15

Kf Nombre de repiquages et changements de plaque Recto du passage n°16

Kg Nombre de repiquages et changements de plaque Recto du passage n°17

Kh Nombre de repiquages et changements de plaque Recto du passage n°18

Ki Nombre de repiquages et changements de plaque Recto du passage n°19

Kj Nombre de repiquages et changements de plaque Recto du passage n°20

L Nombre de repiquages et changements de plaque Verso

M Nombre de vernis Recto et Verso

N1 Nombre de couleurs et de vernis du passage n°1

N2 Nombre de couleurs et de vernis du passage n°2

N3 Nombre de couleurs et de vernis du passage n°3

N4 Nombre de couleurs et de vernis du passage n°4

N5 Nombre de couleurs et de vernis du passage n°5

N6 Nombre de couleurs et de vernis du passage n°6

N7 Nombre de couleurs et de vernis du passage n°7

N8 Nombre de couleurs et de vernis du passage n°8

N9 Nombre de couleurs et de vernis du passage n°9

N0 Nombre de couleurs et de vernis du passage n°10

Na Nombre de couleurs et de vernis du passage n°11

Nb Nombre de couleurs et de vernis du passage n°12

Nc Nombre de couleurs et de vernis du passage n°13

Nd Nombre de couleurs et de vernis du passage n°14

Ne Nombre de couleurs et de vernis du passage n°15

Nf Nombre de couleurs et de vernis du passage n°16

Ng Nombre de couleurs et de vernis du passage n°17

Nh Nombre de couleurs et de vernis du passage n°18

Ni Nombre de couleurs et de vernis du passage n°19

Nj Nombre de couleurs et de vernis du passage n°20

O1 Présence de vernis au Recto du passage n°1 (1/0)

O2 Présence de vernis au Recto du passage n°2 (1/0)

O3 Présence de vernis au Recto du passage n°3 (1/0)

O4 Présence de vernis au Recto du passage n°4 (1/0)

O5 Présence de vernis au Recto du passage n°5 (1/0)

O6 Présence de vernis au Recto du passage n°6 (1/0)

O7 Présence de vernis au Recto du passage n°7 (1/0)

O8 Présence de vernis au Recto du passage n°8 (1/0)

O9 Présence de vernis au Recto du passage n°9 (1/0)

O0 Présence de vernis au Recto du passage n°10 (1/0)

Oa Présence de vernis au Recto du passage n°11 (1/0)

Ob Présence de vernis au Recto du passage n°12 (1/0)

Oc Présence de vernis au Recto du passage n°13 (1/0)

Od Présence de vernis au Recto du passage n°14 (1/0)

Oe Présence de vernis au Recto du passage n°15 (1/0)

Of Présence de vernis au Recto du passage n°16 (1/0)

Og Présence de vernis au Recto du passage n°17 (1/0)

Oh Présence de vernis au Recto du passage n°18 (1/0)

Oi Présence de vernis au Recto du passage n°19 (1/0)

Oj Présence de vernis au Recto du passage n°20 (1/0)

P Présence de vernis au Verso (1/0)

QT Pré-presse traditionnel (1/0)

QP Pré-presse direct to Plate (1/0)

QF Pré-presse direct to film (1/0)

QN Pré-presse (1/0)

QA Renvoi le type de pré-presse (T/P/F/N)

RR Impression Quadri Recto (O/N)

RV Impression quadri verso (O/N)

RRN Impression Quadri Recto (1/0)

RVN Impression quadri verso (1/0

SR Nombre de changements de teinte au Recto

SV Nombre de changements de teinte au Verso

TR Nombre de recherches de teinte au Recto

TV Nombre de recherches de teinte au Verso

U Nombre de teintes identiques (fi_nb_cl_commune)

VR Type de vernis Recto

VV Type de vernis Verso

WR Nombre de passages machine Recto

WV Nombre de passages machine Verso

XALCO1 Code matière du premier vernis (VER A1[2,16]) saisi sur la zone fc_a1 de la LCO

XALCO2 Code matière du deuxième vernis (VER A1[22,36]) saisi sur la zone fc_a1 de la LCO

XBLCO1 Code matière du premier vernis (VER A1[2,16]) saisi sur la zone fc_a2 de la LCO

XBLCO2 Code matière du deuxième vernis (VER A1[22,36]) saisi sur la zone fc_a2 de la LCO

XGLCO1 Code matière du premier vernis (VER A1[2,16]) saisi sur la zone fc_a3 de la LCO

XGLCO2 Code matière du deuxième vernis (VER A1[22,36]) saisi sur la zone fc_a3 de la LCO

XHLCO1 Code matière du premier vernis (VER A1[2,16]) saisi sur la zone fc_a4 de la LCO

XHLCO2 Code matière du deuxième vernis (VER A1[22,36]) saisi sur la zone fc_a4 de la LCO

CN - Données complémentaires

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour numérique

Le caractère 4 est utilisé autrement sur les autres codes calcul.

Sur les autres codes calcul, cette zone sert à rechercher une gâche intermédiaire.

On accède à la donnée numérique d'une LCO

Caractères 1 à 3

Code LCO

Caractère 4

1 Valeur numérique 1

2 Valeur numérique 2

3 Valeur numérique 1 * Valeur numérique 2

4 Valeur numérique 4

5 Valeur numérique 3

A Hauteur du code matière

B Longueur du code matière

C Largeur du code matière

D Poids du code matière

E Donnée technique 1 du code matière

F Donnée technique 2 du code matière

G Donnée technique 3 du code matière

H Donnée technique 4 du code matière

I Donnée technique 5 du code matière

J Donnée technique 6 du code matière

K Donnée technique 7 du code matière

L Donnée technique 8 du code matière

M Valeur numérique 1 du code paramètre défini par la LCO A

N Valeur numérique 2 du code paramètre défini par la LCO A

O Valeur numérique 1 du code paramètre défini par la LCO B

P Valeur numérique 2 du code paramètre défini par la LCO B

Q Valeur numérique 1 du code paramètre défini par la famille de la matière

R Valeur numérique 2 du code paramètre défini par la famille de la matière

S Valeur numérique 3 conditionnée par la zone paramétrée m0_zc de la machine courante (formule opération uniquement)

T Valeur numérique 4 conditionnée par la zone paramétrée m0_zc de la machine courante (formule opération uniquement)

U Valeur numérique 1 du code paramètre défini par la LCO G

V Valeur numérique 2 du code paramètre défini par la LCO G

W Valeur numérique 1 du code paramètre défini par la LCO H

X Valeur numérique 2 du code paramètre défini par la LCO H

Y Valeur numérique 1 conditionnée par la zone paramétrée m0_zc de la machine courante. Valable sup. formule opération seulement.

Z Valeur numérique 2 conditionnée par la zone paramétrée m0_zc de la machine courante. Valable sup. formule opération seulement.

m Valeur numérique 3 du code paramètre défini par la LCO A

n Valeur numérique 4 du code paramètre défini par la LCO A

o Valeur numérique 3 du code paramètre défini par la LCO B

p Valeur numérique 4 du code paramètre défini par la LCO B

u Valeur numérique 3 du code paramètre défini par la LCO G

v Valeur numérique 4 du code paramètre défini par la LCO G

w Valeur numérique 3 du code paramètre défini par la LCO H

x Valeur numérique 4 du code paramètre défini par la

Caractère 5

C Prise en compte des valeurs courantes saisies dans la LCO

V Prise en compte des valeurs de la LCO d'entité puis de la LCO d'entête si valeur non renseignée sur l'entité (cascade)

[autre] Prise en compte des valeurs de la LCO d'entité ou de la LCO d'entête si LCO inexistante sur entité (par défaut)

Caractère 6

Retourne un booléen selon la valeur retournée

B Vrai si >= 1, Faux si < 1

b Vrai si > 1, Faux si <= 1

C Vrai si <= 1, Faux si > 1

c Vrai si < 1, Faux si >= 1

où Vrai = 1 et Faux = 0

CO - Coupe

Retour numérique

Caractère 1 | 1 Coupe unitaire 2 Coupe découpe 3 Coupe impression (fi_lon_tir) 4 Coupe plaque (fi_lon_papier) 5 Coupe découpe X nombre plaques découpe 6 Coupe impression X nombre plaques impression Mode de calcul : nb_poses_calcul = fi_nbp_larp_hauc X fi_nbp_haup_larc Si car 7 = # : (fi_qteent + gâche fixe et variable) / nb_poses_calcul Sinon : (fi_qteent + gâche fixe et variable) X nb_poses_calcul 7 Coupe plaque X nombre plaques initiales 8 Laize de tirage plaque (laize papier / nombre de poses SM)
Caractère 2 | Si caractère 1 = 4 ou 8 I On prend en compte l'inversion de poses (fle_imp.fi_poses_inverse) Si poses inversées, inversion des zones laize par coupe
Caractère 7 | # (dièse) on effectue une division dans le mode de calcul pour caractère 1 = 6. sinon, on effectue une multiplication dans le mode de calcul pour caractère 1 = 6.

CT - Coûts des phases (Matière / Opération / St / Frais)

Retour numérique

On totalise les coûts des phases précédentes.

Caractère 1 | M Retourne le coût matière O Retourne le coût opération S Retourne le coût de sous-traitance T Retourne le coût total F Retourne les frais
Caractère 2 | M On prend les informations en mémoire Autre On prend les informations dans la table fle_gam sur le disque (par défaut)

DE - Décomposition de la forme imprimante (type de pli)

Retour alphanumérique

Pas de paramétrage

Retourne decf[1].de_type_pli si nb_dec est différent de zéro.

DI - Dimension

Caractère 1

H Hauteur de la boîte

Caractère 2 :

C Hauteur du format fini de l'entité couverture COU (si elle existe)

T Hauteur du format fini de l'entité couverture cartonnée CVC (si elle existe)

J Hauteur du format fini de l'entité jaquette JAQ (si elle existe)

G Hauteur du format fini de l'entité gardes GAR (si elle existe)

L Hauteur du format fini de l'entité gardes blanches GAB (si elle existe)

L (la lettre L en majuscules) Longueur de la boîte

Caractère 2 :

C Longueur du format fini de l'entité couverture COU (si elle existe)

T Longueur du format fini de l'entité couverture cartonnée CVC (si elle existe)

J Longueur du format fini de l'entité jaquette JAQ (si elle existe)

G Longueur du format fini de l'entité gardes GAR (si elle existe)

L Longueur du format fini de l'entité gardes blanches GAB (si elle existe)

l (la lettre L en minuscules) Largeur de boîte

Caractère 2 :

C Largeur du format fini de l'entité couverture COU (si elle existe)

T Largeur du format fini de l'entité couverture cartonnée CVC (si elle existe)

J Largeur du format fini de l'entité jaquette JAQ (si elle existe)

G Largeur du format fini de l'entité gardes GAR (si elle existe)

L Largeur du format fini de l'entité gardes blanches GAB (si elle existe)

2 Maxi entre laize et coupe unitaire

3 Maxi entre laize et coupe découpe

4 Maxi entre laize et coupe impression

5 Maxi entre laize et coupe papier

6 Valeur calculée 1 (v1)

Caractère 2 :

3 On retourne la valeur calculée 3 (v3)

5 On retourne la valeur calculée 5 (v5)

7 On retourne la valeur calculée 7 (v7)

9 On retourne la valeur calculée 9 (v9)

7 Valeur calculée 2 (v2)

Caractère 2 :

4 On retourne la valeur calculée 4 (v4)

6 On retourne la valeur calculée 6 (v6)

8 On retourne la valeur calculée 8 (v8)

0 On retourne la valeur calculée 10 (v10)

8 Résultat de la valeur calculée 1 (v1) * valeur calculée 2 (v2) - Caractère 2 - Caractère 3

9 Résultat de la valeur calculée 1 (v1) / valeur calculée 2 (v2) - Caractère 2 - Caractère 3

A Résultat de la valeur calculée 1 (v1) + valeur calculée 2 (v2) - Caractère 2 - Caractère 3

B Résultat de la valeur calculée 1 (v1) - valeur calculée 2 (v2) - Caractère 2 - Caractère 3

C Maximum entre les valeurs calculées 1 (v1) et 2 (v2) - Caractère 2 - Caractère 3

D Minimum entre les valeurs calculées 1 (v1) et 2 (v2) - Caractère 2 - Caractère 3

E Largeur du format ouvert

Caractère 2 :

C Longueur du format ouvert de l'entité couverture COU (si elle existe)

T Longueur du format ouvert de l'entité couverture cartonnée CVC (si elle existe)

J Longueur du format ouvert de l'entité jaquette JAQ (si elle existe)

G Longueur du format ouvert de l'entité gardes GAR (si elle existe)

L Longueur du format ouvert de l'entité gardes blanches GAB (si elle existe)

B (Bascule/Retiration) : Si bascule in12, largeur image = 2 * largeur image + fonds perdus en Y

F Longueur du format ouvert

Caractère 2 :

C Epaisseur du dos de l'entité couverture COU (si elle existe, sinon épaisseur calculée)

T Epaisseur du dos de l'entité couverture cartonnée CVC (si elle existe, sinon épaisseur calculée)

J Epaisseur du dos de l'entité jaquette JAQ (si elle existe, sinon épaisseur calculée)

G Epaisseur du dos de l'entité gardes GAR (si elle existe, sinon épaisseur calculée)

L Epaisseur du dos de l'entité gardes blanches GAB (si elle existe, sinon épaisseur calculée)

B (Bascule/Retiration) : Si bascule in8, longueur image = 2 * longueur image + fonds perdus en X

G Mini entre laize et coupe impression

I Valeur 1 : Stockage du résultat dans la table des emballages en tant que nombre de palettes

Utilisable uniquement sur formule matière

J Epaisseur du dos calculée

Caractère 2 :

C Epaisseur du dos de l'entité couverture COU (si elle existe, sinon épaisseur calculée)

T Epaisseur du dos de l'entité couverture cartonnée CVC (si elle existe, sinon épaisseur calculée)

J Epaisseur du dos de l'entité jaquette JAQ (si elle existe, sinon épaisseur calculée)

G Epaisseur du dos de l'entité gardes GAR (si elle existe, sinon épaisseur calculée)

L Epaisseur du dos de l'entité gardes blanches GAB (si elle existe, sinon épaisseur calculée)

K Largeur bord de rive minimum (fle_imp.fi_bord_min)

M Largeur bord de rive maximum (fle_imp.fi_bord_max)

N Donnée numérique paramétrable selon type de devis.

Devis étiquette :

Caractère 2 :

1 fi_num1 Diamètre mandrin

2 fi_num2 Epaisseur

3 fi_num3 Diamètre

4 fi_num4 Nombre

5 fi_num5

6 fi_num6 Zone numérique 6

7 fi_num7 Zone numérique 7

8 fi_num8 Zone numérique 8

9 fi_num9 Zone numérique 9

O Espace avance minimum (fle_imp.fi_fini_dblc_min)

P Espace avance maximum (fle_imp.fi_fini_dblc_max)

Q Espace laize ou ECMA : Espacement des poses en X fle_imp.fi_fini_dblc)

R Epaisseur totale de l'ouvrage

S Epaisseur totale d'un paquet d'ouvrage

(épaisseur totale de l'ouvrage multipliée par la quantité d'ouvrages par paquet)

" Cas de l'emballage hors-ligne

La quantité d'ouvrages par paquet sera saisie sur la ligne complémentaire LCO paramétrée dans les caractères 2 à 4 (zone numérique 1), sur l'entité de façonnage ou sur l'entête de devis.

" Cas de l'emballage en ligne

La quantité d'ouvrages par paquet sera saisie sur le paramétrage du code paquet, lui-même saisi sur la ligne complémentaire LCO paramétrée dans les caractères 2 à 4 (zone alphanumérique 1) sur l'entité de façonnage ou sur l'entête de devis.

Car.2 à 4 : Code LCO pour la récupération du code paquet et de la quantité d'ouvrage.
Par défaut : EMF

T Espacement des poses en Y (fle_imp.fi_pli_dblc)

U Poids total de l'ouvrage

Voir caractères 2 à 4

Car.2 = G : Poids de l'ouvrage exprimé en grammes

Car.2 = K : Poids de l'ouvrage exprimé en kilogrammes (par défaut)

V valeur numérique de la table fle_ope - GENERO uniquement

Caractère 2 :

1 Valeur numérique 1 (fo_num_1)

2 Valeur numérique 2 (fo_num_2)

3 Valeur numérique 3 (fo_num_3)

4 Valeur numérique 4 (fo_num_4)

W Nombre d'ouvrages

Voir caractères 2 à 4

Caractères 2 à 4

Si caractère 1 = S ou W : Code LCO pour la récupération du code paquet et de la quantité d'ouvrage (par défaut : EMF)

Cas de l'emballage hors-ligne

La quantité d'ouvrages par paquet sera saisie sur la ligne complémentaire LCO paramétrée dans les caractères 2 à 4 (zone numérique 1), sur l'entité de façonnage ou sur l'entête de devis.

Cas de l'emballage en ligne

La quantité d'ouvrages par paquet sera saisie sur le paramétrage du code paquet, lui-même saisi sur la ligne complémentaire LCO paramétrée dans les caractères 2 à 4 (zone alphanumérique 1) sur l'entité de façonnage ou sur l'entête de devis.

Caractère 7

Q On multiplie le résultat par la quantité de l'entité (fi_qteent)

EN - Encre et vernis (détermination du poids en kg)

Retour numérique

Caractère 1 | 1 Surface totale imprimée gâches comprises Caractère 2 : 1 Encres recto + verso 2 Vernis recto + verso 2 Nature du vernis en ligne recto (simple/multiple/pas de vernis) 3 Nature du vernis en ligne verso (simple/multiple/pas de vernis) 4 Nature du vernis hors ligne recto (simple/multiple/pas de vernis) 5 Nature du vernis hors ligne verso (simple/multiple/pas de vernis) 6 Nature du vernis de sous-traitance recto (simple/multiple/pas de vernis) 7 Nature du vernis de sous-traitance verso (simple/multiple/pas de vernis) A Vernis en ligne recto Présence de type de vernis - Voir car. 2 et 3 B Vernis en ligne verso Présence de type de vernis - Voir car. 2 et 3 C Vernis hors ligne recto Présence de type de vernis - Voir car. 2 et 3 D Vernis hors ligne verso Présence de type de vernis - Voir car. 2 et 3 E Vernis sous-traitance recto Présence de type de vernis - Voir car. 2 et 3 F Vernis sous-traitance vernis Présence de type de vernis - Voir car. 2 et 3
Caractère 2 | Si caractère 1 = 2 à 7 : A Retour alphanumérique (renvoie S (Simple), M (Multiple), N (Pas de vernis)) N Retour numérique (renvoie 1 (Simple), 2 (Multiple), 0 (Pas de vernis)) Si caractère 1 = A à F : A Présence de vernis acrylique (O/N, 1/0) O Présence de vernis offset (O/N, 1/0) U Présence de vernis UV (O/N, 1/0) R Présence de vernis répulsif (O/N, 1/0)
Caractère 3 | Si caractère 1 = A à F : A Retour alphanumérique (O/N) N Retour numérique (1/0)

FC - Résultat d'une formule de calcul de feuille_calcul

Retour numérique

Caractère 1 | Type de clé de la formule : 1 devis sous-devis / entité 2 devis sous-devis 3 client
Caractères 2 à 4 | Code de la formule à rechercher dans feuille_calcul On recherche la première.

FM - Façonnage multi-passages

Caractère 1 | N Numéro de passage de l'opération courante D L'opération courante correspond-t-elle au dernier passage ? Si caractère 2 = A : Renvoie une valeur alphanumérique : O L'opération courante correspond au dernier passage. N L'opération courante ne correspond pas au dernier passage. Si caractère 2 = N : Renvoie une valeur numérique : 1 L'opération courante correspond au dernier passage. 0 L'opération courante ne correspond pas au dernier passage. C Type de couverture pour l'opération courante PAS Pas de couverture Ce type est renvoyé dans 2 cas : - Aucune entité de couverture n'a été saisie sur le devis courant. - Une entité de couverture a bien été saisie mais l'opération courante ne correspond pas au dernier passage. NOR Couverture normale RAJ Couverture avec rabat ajusté RAR Couverture avec retrait P Présence de couverture sur le sous-devis courant PAS Pas de couverture NOR Couverture normale RAJ Couverture avec rabat ajusté RAR Couverture avec retrait
Caractère 2 | Utilisé si caractère 1 = D, voir ci-dessus

FN - Finition

Caractère 1 | P Présence de pelliculage sur l'entité (H/S/N) F Nombre de faces concernées par le pelliculage (R/V/2) R Recto (retour numérique = 1) V Verso (retour numérique = 1) 2 Recto/Verso (retour numérique = 2) H Présence de vernis hors-ligne (O/N, 1/0) A Nombre de faces concernées par le vernis hors-ligne (R/V/2, 1/1/2) S Présence de vernis sous-traitance (O/N, 1/0) B Nombre de faces concernées par le vernis sous-traitance (R/V/2, 1/1/2)
Caractère 2 | Type de retour (suivant caractère 1) A Alphanumérique N Numérique Si caractère 1 = P A retourne H/S/N N retourne 1/2/0 Si caractère 1 =F, A ou B A retourne R/V/2 N retourne 1/1/2 Si caractère 1 = H ou S A retourne O/N N retourne 1/0
Caractère 3 | Si caractère 1 = H : R Présence de vernis hors-ligne recto (O/N, 1/0) V Présence de vernis hors-ligne verso (O/N, 1/0) [autre] Présence de vernis hors-ligne recto ou verso (O/N, 1/0) (par défaut)

GI - Recherche gâches intermédiaires

Retour numérique

Ce mode permet d'aller rechercher à partir d'une formule opération les gâches fixes et variables de 1 à 6 opérations.

On retourne donc une quantité toute gâche.

Caractère 1 | Nombre de recherches (6 maxi).
Caractère 2 | Q on appelle la formule RV. Il n'y a donc pas de recherche de gâche fixe et variable sur la première opération.

GN - Génération automatique de codes difficultés

Utilisé dans le cadre de l'optimisation du devis.

Retour alphanumérique

Caractère 1 | 1 Génération d'un code difficulté pour la piqûre Caractère 1 : Orientation de la page F Française I Italienne Caractère 2 : Type du format 3 Format A3 4 Format A4 5 Format A5 6 Format A6 Caractère 3 = Cassage (LCO #CA sur l'entête du devis) O Si la valeur alpha 1 du LCO #CA = O N Si la valeur alpha 1 du LCO #CA = N 2 Génération d'un code difficulté pour les brochures sans couture Caractère 1 : Orientation de la page à l'Italienne (I) ou à la Française (F) Caractère 2 : Type du format 3 Format A3 4 Format A4 5 Format A5 6 Format A6 Caractère 3 : blanc (inutilisé) 3 Génération d'un code difficulté sur 3 caractères Caractère 1 : Orientation de la page à l'Italienne (I) ou à la Française (F) Caractère 2 : Type du format 3 Format A3 4 Format A4 5 Format A5 6 Format A6 Caractère 3 : Présence d'emballage en ligne (L) ou hors ligne (H)
Caractères 2 à 4 | Code LCO pour la récupération de présence d'emballage en ligne (L) ou hors ligne (H) Par défaut : EMF

IE - Informations entité

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour numérique ou alphanumérique

Caractère 1

A Retourne le mode d'approvisionnement des plaques (fi_pap_stk)

Voir code calcul TP, paramètre 8.

Car.2 = F : retourne le code fournisseur de l'entité

B retourne le type d'impression verso (fi_type_verso) :

N Aucune impression verso

D Impression verso en délaminage

R Impression verso en retournement

C Retourne la présence de collage O/N (voir caractère 2)

D Retourne la présence de dorure O/N (voir caractère 2)

E Retourne la présence d'équerrage ou de massicot (fi_equerre) (voir caractère 2)

F Retourne le code forme

Car. 2 = Q Renvoie mp_qualite de la forme.

Car. 2 = U Renvoie O ou N selon alpha1[20] du paramètre de qualité de l'outil

alpha1[20] = O : Renvoie O

alpha1[20] = N : Renvoie N

Car. 2 = V Renvoie 1 ou 0 selon alpha1[20] du paramètre de qualité de l'outil

alpha1[20] = O : Renvoie 1

alpha1[20] = N : Renvoie 0

Car. 2 = O : Renvoie O ou N selon la présence d'outil dans le devis

outil saisi ET non générique : Renvoie O

outil non saisi OU générique : Renvoie N

Car. 2 = P : Renvoie 1 ou 0 selon la présence d'outil dans le devis

outil saisi ET non générique : Renvoie 1

outil non saisi OU générique : Renvoie 0

Autres cas : Renvoie la valeur de la zone (alphanumérique)

G Retourne la présence de gaufrage O/N (voir caractère 2)

H Retourne le numéro de plan ou d'étude

I Retourne la présence de foulage O/N (voir caractère 2)

J Retourne la présence de perforation N/H/L (voir caractère 2)

K Retourne la présence de découpe O/N (voir caractère 2)

L Retourne le type de pelliculage.

M Retourne la valeur numérique 1 du paramètre PEL (fi_type_pellic)

N Retourne la présence de numérotage O/N (voir caractère 2)

O Retourne la valeur numérique 2 du paramètre PEL (fi_type_pellic)

P Retourne le code produit de l'entité.

Q Retourne la présence fonds perdus O/N

Car. 2 = N : Retourne 0 si fi_fonds_perdus = N

Retourne 1 si fi_fonds_perdus = O

Car. 2 = V :Retourne 0 si fi_fonds_perdus = N

Retourne 1 si fi_fonds_perdus = L (en ligne)

Retourne 2 si fi_fonds_perdus = H (hors ligne)

Autres cas : Retourne la valeur de la zone (alphanumérique)

R Retourne le nombre de références (fi_nb_references).

Car.2 = E Retourne le nombre de références de l'entête (fle_2.l2_nb_references)

Car.2 = N Retourne le nombre de références de l'entité (fle_imp.fi_nb_references)

S Retourne le code gamme

T Présence d'un type d'entité

Caractères 2 à 4 : Type d'entité recherché (à blanc pour tous les types d'entités)

Caractère 5 : P (par défaut) renvoie O s'il y a des occurrences, sinon N.

N renvoie le nombre d'occurrences trouvées.

U Retourne la présence de conditionnement O/N (fi_conditionnement) (voir caractère 2)

V Retourne la présence de transfert O/N (fi_transfert) (voir caractère 2)

W Retourne la présence de personnalisation (Autres) O/N (fi_perso) (voir caractère 2)

X Retourne le numéro d'entité courant (fi_entite)

Car.2 = P : L'entité courante est-elle la première entité du sous-devis ? (O/N, 1/0)

Car.3 = N : Retourne 1 si l'entité courante est la première entité, sinon retourne 0

Car.3 = A : Retourne O si l'entité courante est la première entité, sinon retourne N (par défaut)

Y Retourne une information dépendant du caractère 2

Car 2 = 1 retourne fi_photocompo Car 2 = 2 retourne fi_photogravure Car 2 = 3 retourne fi_maquette | Si car 3 = N : retourne 2 si zone = S (Sous-traité) retourne 1 si zone = I (Interne) retourne 0 dans les autres cas Si car 3 <> N : retourne la valeur de la zone (alpha)
Car 2 = 4 retourne fi_epreuve Car 2 = 5 retourne fi_contre_collage Car 2 = 6 retourne fi_fenetrage Car 2 = 7 retourne fi_manuel Car 2 = 8 retourne fi_accessoires Car 2 = 9 retourne fi_optimisable | Si car 3 = N : retourne 1 si zone = O (Oui) retourne 0 dans les autres cas Si car 3 <> N : retourne la valeur de la zone (alpha)

Z Retourne la présence de rainage O/N (fi_rainage)

1 Retourne la comparaison entre le format de tirage et le format de papier

Caractère 2 = A Retourne O si le format de tirage est égal au format de papier, sinon N.

Caractère 2 = N Retourne 1 si le format de tirage est égal au format de papier, sinon 0.

2 Retourne la présence de bascule

Caractère 2 = A

Retourne N si fi_bascule = N(on), E(xclue) ou [null], O dans le cas contraire.

Caractère 2 = N

Retourne 0 si fi_bascule = N(on), E(xclue) ou [null], 1 dans le cas contraire.

Caractère 2 = X

Retourne 1 si bascule = N(on), E(xclue)

Retourne 2 si bascule = I(ndifférent), 1(2), 8

Autre cas : Retourne la valeur de la zone.

3 Retourne le nombre de volets/morceaux/feuillets/etc

Caractère 2 = J

Retourne la valeur du nombre de rainages (zone nb volets) de la première entité de type JAQ du devis (TEN A1[31,33] = JAQ)

Caractère 2 = blanc (par défaut)

Retourne la valeur du nombre de volets de l'entité courante.

4 Retourne le mode de tirage

Caractère 2= N

Retourne 1 si mode de tirage = N

Retourne 0 sinon

Caractère 2 = S

Retourne 1 si mode de tirage = S

Retourne 0 sinon

Caractère 2 = O

Retourne O si mode de tirage = S

Retourne N sinon

Autre cas : Retourne la valeur de la zone

5 Retourne le type d'imposition

Caractère 2 = M

Retourne 1 si type d'imposition = M

Retourne 0 sinon

Caractère 2 = F

Retourne 1 si type d'imposition = F

Retourne 0 sinon

Caractère 2 = R

Retourne 1 si type d'imposition = R

Retourne 0 sinon

Caractère 2 = H

Retourne 1 si type d'imposition = H

Retourne 0 sinon

Caractère 2 = C

Retourne la valeur de la zone fi_zpar

Caractère 2 = S

Prise en compte du type d'imposition TIM A1[3]

Retourne 1 si les références sont tirées à la suite, sinon retourne 0

Caractère 2 = P

Retourne TIM A1[3]

Caractère 2 = 1

Retourne la zone numérique 1 du paramètre TIM/(valeur de la zone fi_zpar)

Caractère 2 = 2

Retourne la zone numérique 2 du paramètre TIM/(valeur de la zone fi_zpar)

Autre cas : Retourne le type d'imposition :

paramètre TIM A1[1] (valeur de la zone fi_zpar)

6 Retourne le respect du sens papier

Car.2=N : Renvoie une valeur numérique

Renvoie 2 si la valeur de la zone est I (Indifférent)

Renvoie 1 si la valeur de la zone est O (Oui)

Renvoie 0 dans tous les autres cas (par défaut)

Car.2=A : Renvoie une valeur alphanumérique (par défaut)

Renvoie la valeur de la zone directement

Caractères 2 et 3

ATTENTION : UTILISATIONS DIFFERENTES DES CARACTERES 2 ET 3 !!!

Caractère 2

Pour les zones C D E G I J K N U V W Z (zones retournant une présence) :

Type de retour des zones de présence

N Renvoie une valeur numérique

Renvoie 0 si la zone de présence est égale à N (absence)

Renvoie 1 si la zone de présence est égale à O (présence)

V Renvoie une valeur numérique

Renvoie 0 si la zone de présence est égale à N (absence)

Renvoie 1 si la zone de présence est égale à L (présence en ligne)

Renvoie 2 si la zone de présence est égale à H (présence hors ligne)

Autres cas Renvoie la valeur de la zone (alphanumérique)

Caractère 3

Pour la zone Y uniquement :

A renvoie une valeur alphanumérique (en général : O ou N)

N renvoie une valeur numérique (en général, 0, 1 ou 2)

Caractères 2 à 4

Pour la zone T uniquement : Type d'entité

Caractère 5

Pour la zone T uniquement : P (par défaut) renvoie O/N, N renvoie le nombre d'occurrences

IF - Informations de fabrication

Caractère 1

J Récupération de la laize de matière consommée (fab3)

Utilisé dans les formules de conversion pour le calcul du prix de revient.

L Laize de la matière (f3_largeur)

IM - Impression

Retour numérique ou alphanumérique

Caractère 1

R Quantité recto

Si caractère 2 = V : On utilise la quantité verso en sortie pour la quantité recto en entrée.

V Quantité verso

B Selon type de bascule - Voir caractère 2

T Type d'impression (Roto/Feuille) - Voir caractère 2

G Entité générée automatiquement par le devis optimisé (par duplication)

Renvoie O/N ou 1/0 selon caractère3

M Entité générée automatiquement par le devis optimisé (par duplication) avec la même machine que l'entité d'origine.

Renvoie O/N ou 1/0 selon caractère3

I Entités avec impression identiques sur le sous-devis (présence de quadrichromie, même nombre de couleurs et même machine).

Renvoie O/N ou 1/0 selon caractère3

Remarques

• Les entités de façonnage sont automatiquement exclues (TEN A1[31,33] = FAC)

• Les entités à prendre en compte peuvent être limitées via TEN A3[18]

Caractère 2

Si caractère 1 = B

Si retour alphanumérique

O Retourne O si bascule de type O, sinon N

B Retourne O si bascule de type B, sinon N

C Retourne O si bascule de type C, sinon N

Si retour numérique

1 si bascule O

2 si bascule B

3 si bascule C

0 si bascule N ou différent de O, B ou C

Si caractère 1 = T

A (retour alphanumérique) renvoie R pour Roto ou F pour Feuille

N (retour numérique) renvoie 1 pour Roto ou 0 pour Feuille

Si caractère 1 = M ou I

Machine à prendre en compte

R Machine recto

V Machine verso

2 Machine recto et verso (par défaut)

Dans ce cas, le code machine doit être identique sur les toutes entités comparées, mais aussi entre le recto et le verso.

Caractère 3

Si caractère 1 = G, M ou I : Type de retour

A Retour alphanumérique de type O/N

N Retour numérique de type 1/0 (par défaut)

LA - Laize

Retour numérique

Caractère 1 | 1 Laize unitaire 2 Laize découpe 3 Laize impression (fi_lar_tir) 4 Laize plaque (fi_lar_papier) 5 Laize découpe * nombre de plaques de découpe Si caractère 3 = S : hors gâche, sinon gâche inclue 6 Laize impression * nombre de plaques d'impression Si caractère 3 = S : hors gâche, sinon gâche inclue Si caractère 7 est différent de # (dièse), on multiplie par le nombre de morceaux ECMA. 7 Laize plaque * nombre de plaques initial Si caractère 3 = S : hors gâche, sinon gâche inclue 8 Laize de tirage plaque (laize papier / nombre de poses SM)
Caractère 2 | Si caractère 1 = 4 ou 8 I On prend en compte l'inversion de poses (fle_imp.fi_poses_inverse) Si poses inversées, inversion des zones laize par coupe
Caractère 3 | S Sans gâche
Caractère 7 | Si # (dièse), on ne multiplie pas par le nombre de morceaux ECMA. Sinon, on multiplie par le nombre de morceaux ECMA.

MA - Recherche infos matières

Permet de retourner des valeurs avec les données de la matière saisie sur la formule matière ou à partir du code papier (carton) défini sur l'écran de l'entité.

Caractère 1

Pour des données numériques :

1 Donnée technique numérique 1

2 Donnée technique numérique 2

3 Donnée technique numérique 3

4 Donnée technique numérique 4

5 Donnée technique numérique 5

6 Donnée technique numérique 6

7 Donnée technique numérique 7

8 Donnée technique numérique 8

A Largeur définie sur la fiche matière

a Largeur définie sur la fiche matière pour le site de l'entité courante (mat_site.ms_lar)
Tableau de bord du multisite

B Longueur définie sur la fiche matière

b Longueur définie sur la fiche matière pour le site de l'entité courante (mat_site.ms_lon)
Tableau de bord du multisite

C Hauteur définie sur la fiche matière

c Hauteur définie sur la fiche matière pour le site de l'entité courante (mat_site.ms_hau)
Tableau de bord du multisite

D Poids défini sur la fiche matière

d Poids défini sur la fiche matière pour le site de l'entité courante (mat_site.ms_poids)
Tableau de bord du multisite

E Valeur numérique 1 du code famille de la matière

F Valeur numérique 2 du code famille de la matière

G Valeur numérique 1 du code sous-famille de la matière

H Valeur numérique 2 du code sous-famille de la matière

I Valeur numérique 1 de l'unité d'achat

J Quantité minimum pour commande client

K Prix de revient de la matière

L P.A.M.P. (mp_pamp / mp_sphy)

Pour des données alphanumériques :

M Code produit (mat.mp_code)

P Code statistique 1

Q Code statistique 2

R Code statistique 3

S Code statistique 4

T Code article de remplacement (mp_remp)

U Retourne le code fournisseur principal - GENERO uniquement

V Retourne la qualité matière de l'article choisi par le caractère 2

W Unité d'achat du produit

X Catégorie du code matière

Y Sous-famille du code matière

Z Famille du code matière

Caractère 2

Code produit à prendre en compte pour la recherche des informations matières

1 Produit de la formule courante (matière ou sous-traitance)

2 Qualité carton/papier de l'entité courante

3 Référence multiple associée à la formule courante

4 Produit par défaut de la formule

5 Forme de découpe de l'entité (fle_imp.fi_num_forme)

6 Qualité matière associé au code papier de l'entité (mat.mp_qualite_matiere de fle_imp.fi_c_papier)

7 Code produit saisi dans la zone paramétrée alphanumérique 1 (fle_2.l2_zchr1)

MC - Machine

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour alphanumérique

Caractère 1

1 Machine d'impression recto

2 Machine d'impression verso

ATTENTION : Le code machine renvoyé tient sur 6 caractères.

Utiliser cette dépendance avec la dépendance 4 seulement.

M Présence d'une machine manuelle

Caractère 2 :

1 Présence de machine manuelle sur le passage d'impression n°1

2 Présence de machine manuelle sur le passage d'impression n°2

3 Présence de machine manuelle sur le passage d'impression n°3

4 Présence de machine manuelle sur le passage d'impression n°4

5 Présence de machine manuelle sur le passage d'impression n°5

6 Présence de machine manuelle sur le passage d'impression n°6

7 Présence de machine manuelle sur le passage d'impression n°7

8 Présence de machine manuelle sur le passage d'impression n°8

9 Présence de machine manuelle sur le passage d'impression n°9

0 Présence de machine manuelle sur le passage d'impression n°10

R machine d'impression recto manuelle ?

Si machine forcée recto (fi_mac_forcee_r) = M, alors utilisation des caractères 3 à 5 contenant le code LCO de la machine.

Sinon machine d'impression recto

V machine d'impression verso manuelle ?

Si machine forcée verso (fi_mac_forcee_v) = M, alors utilisation des caractères 3 à 5 contenant le code LCO de la machine.

Sinon machine d'impression verso

F Présence d'une machine forcée

Caractère 2 :

1 Présence de machine forcée sur le passage d'impression n°1

2 Présence de machine forcée sur le passage d'impression n°2

3 Présence de machine forcée sur le passage d'impression n°3

4 Présence de machine forcée sur le passage d'impression n°4

5 Présence de machine forcée sur le passage d'impression n°5

6 Présence de machine forcée sur le passage d'impression n°6

7 Présence de machine forcée sur le passage d'impression n°7

8 Présence de machine forcée sur le passage d'impression n°8

9 Présence de machine forcée sur le passage d'impression n°9

0 Présence de machine forcée sur le passage d'impression n°10

R Machine d'impression recto forcée ?

Retourne la zone fi_mac_forcee_r

V Machine d'impression verso forcée ?

Retourne la zone fi_mac_forcee_v

Caractère 3 :

N Retourne 0/1/2 selon le forçage de la machine :

N (non) devient 0

O (oui) devient 1

S (sous-traitance) devient 2

S Retourne 0/1 selon le forçage de la machine (sous-traitance).

S (sous-traitance) devient 0.

Les autres valeurs deviennent 1.

P Machine associée au type de pré-presse

S Recherche de code machine selon le site

Caractère 2 : Code site à prendre en compte

1 Site de l'entité courante (fle_imp.fi_sit)

2 Site de l'entête du sous-devis courant (fle_2.l2_site)

C Cascade : Site de l'entité courante s'il est renseigné, site de l'entête du sous-devis courant sinon (par défaut)

Caractères 3 à 5 :

Type de machine à rechercher (le code machine sera récupéré sur les notes du paramétrage du site à prendre en compte commençant par MACHINE_ suivi de ces 3 caractères).

Caractère 2

En fonction du caractère 1

R Recto

V Verso

Caractères 3 à 5

Si caractère 1 = M : Code LCO contenant le code machine si machine forcée = M (manuelle)

Caractère 6

A Retourne O/N selon que la machine est manuelle ou non

Les caractères 3 à 5 sont alors ignorés.

O Machine manuelle

N Machine forcée ou automatique

N Retourne 0/1 selon que la machine est manuelle ou non

Les caractères 3 à 5 sont alors ignorés.

1 Machine manuelle

0 Machine forcée ou automatique

MD - Mise à jour des gâches d'une opération sur une phase

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour numérique

Ce mode permet de mettre à jour une valeur stockée sur une opération

Caractères 1 à 3 | Code opération (recherché avec le code formule dans fle_ope)
Caractères 4 à 6 | Code formule (recherché avec le code opération dans fle_ope)
Caractère 7 | 1 Mise à jour de la gâche fixe avec V1 ET mise à jour de la gâche variable (en %) avec V2 fo_cad_tps_b = G si fo_cad_tps_b = N fo_cad_tps_b = 2 si fo_cad_tps_b = C 2 Mise à jour de la cadence avec V1 fo_cad_tps_b = C si fo_cad_tps_b = N fo_cad_tps_b = 2 si fo_cad_tps_b = G 3 Mise à jour du temps de calage avec V1 fo_cad_tps_b = C si fo_cad_tps_b = N fo_cad_tps_b = 2 si fo_cad_tps_b = G

A NOTER

  • Si la V1 = 9999999, il n'y a pas de mise à jour de la formule et le code blocage fo_cad_tps_b est à N.

  • La gâche variable est exprimée en POURCENTAGE.

  • Ce code calcul devra être mis dans les dépendances.

  • La formule de mise à jour de l'opération ne doit pas être sur la même phase (prévoir une phase INI).

MH - Infos machine

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour numérique ou alphanumérique

Caractère 1

Quelle machine ?

1 Machine d'impression recto

2 Machine d'impression verso

3 Machine sur LCO (code LCO défini en car 3 à 5)

4 Machine sur opération (code formule défini en car 3 à 5)

5 Machine en cours de saisie sur LCO

Il s'agit ici de prendre comme code machine le code que l'on est en train de saisir dans une LCO.

Ce paramétrage est nécessaire dans le cas où l'on utilise la vérification de valeur par formule dans le devis standard.

En effet, le code 3 n'est pas suffisant, car si le contrôle se fait sur la saisie du code machine, la machine sur LCO n'est pas encore sauvegardée dans la base de donnée.

Le code 5 permet de prendre le code machine que l'on est en train de saisir, sans relire celui qui se trouve dans la base de donnée.

6 Machine sur LCO (= 3). Si non remplie, Machine d'impression recto (= 1)

7 Machine sur LCO (= 3). Si non remplie, Machine d'impression verso (= 2)

8 Machine recto pour le vernis hors-ligne (fle_combi)

9 Machine verso pour le vernis hors-ligne (fle_combi)

A Code machine du passage d'impression n°1

B Code machine du passage d'impression n°2

C Code machine du passage d'impression n°3

D Code machine du passage d'impression n°4

E Code machine du passage d'impression n°5

F Code machine du passage d'impression n°6

G Code machine du passage d'impression n°7

H Code machine du passage d'impression n°8

I Code machine du passage d'impression n°9

J Code machine du passage d'impression n°10

K Code machine de pliage de la première ligne de décomposition

Caractère 2

Quelle rubrique ?

0 La rubrique est paramétrée en caractère 7

1 Valeur numérique 1 - Gâche papier fixe

2 Valeur numérique 2 - Gâche papier variable

3 Valeur numérique 3 - Nombre de groupes Imp

4 Développement -(Roto)

5 Type de machine

6 Site de production - Tableau de bord du multisite

7 Atelier

A Retourne 1 si libelle a (m0_za) est égal au caractère 6, sinon 0.

Si caractère 6 non saisi, retourne la valeur de la zone.

B Retourne 1 si libelle b (m0_zb) est égal au caractère 6, sinon 0.

Si caractère 6 non saisi, retourne la valeur de la zone.

C Retourne 1 si libelle c (m0_zc) est égal au caractère 6, sinon 0.

Si caractère 6 non saisi, retourne la valeur de la zone.

D Valeur alphanumérique 1 (m0_zpar_a)

E Valeur alphanumérique 2 (m0_zpar_b)

F Valeur alphanumérique 3 (m0_zpar_c)

G Mini matière sens travers

H Maxi matière sens travers

I Mini matière sens machine

J Maxi matière sens machine

K Mini impression sens travers

L Maxi impression sens travers

M Mini impression sens machine

N Maxi impression sens machine

O Taux horaire de la machine (avec le code utilisation STD)

P Quantité roulée minimum

Q Quantité roulée maximum

R Surface unitaire minimum

S Surface unitaire maximum

T Surface totale minimum

U Surface totale maximum

V Temps de travail minimum

W Temps de travail maximum

X Nombre de couleurs minimum

Y Nombre de couleurs maximum

Z Valeur minimum de la 3ème plage paramétrable

# Valeur maximum de la 3ème plage paramétrable

Caractères 3 à 5

Code LCO si machine saisie sur LCO

Code formule si machine sur opération

Si non renseigné, opération courante

Caractère 6

Si le caractère 2 = A, B ou C : Valeur d'affectation

Si le caractère 2 = D, E ou F

P Ajout du type de pré-presse de l'entité à la valeur alphanumérique

Si type de pré-presse = P, on renvoie la valeur suivi de -P

Si type de pré-presse = F, on renvoie la valeur suivi de -F

Dans les autres cas, on renvoie la valeur sans ajout

Caractère 7

Complément du caractère 2 (Quelle rubrique ?)

Le caractère 7 n'est pris en compte que si le caractère 2 = 0.

1 Position de retiration

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

2 Groupes de vernis acrylique

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

3 Nombre de groupes de vernis UV

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

4 Nombre de numéroteurs

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

5 Coefficient réducteur de cadence pour la perforation

6 Coefficient réducteur de cadence pour le numérotage

7 Coefficient réducteur de cadence pour le rainage

A Participe à l'optimisation

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

B Machine convertible ?

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

C Vernis UV possible - SUPPRIME

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

D Perforation possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

E Rainage possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

F Découpe possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

G Pliage en ligne possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

H Gaufrage possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

I Foulage possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

J Dorure possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

K Poudrage possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

L Conditionnement en ligne possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

M Gommage possible

Si caractère 6 non saisi : retourne O/N

Si caractère 6 saisi : retourne 1/0

N Code machine associée pour le vernis acrylique hors ligne

O Code machine associée pour le vernis UV hors ligne

P Code machine associée pour le vernis offset hors ligne

Q Code machine (selon caractère 1)

R Valeur minimum de la 1ère plage paramétrable

S Valeur maximum de la 1ère plage paramétrable

T Valeur minimum de la 2ième plage paramétrable

U Valeur maximum de la 2ième plage paramétrable

MI - Mitraillage

Cette formule ne peut pas utiliser le coefficient multiplicateur (bien que les caractères 5 et 6 ne soient pas utilisés...).

Retour numérique

Actif seulement pour les opérations

Caractère 1 | C Coupe (par défaut) R Recoupe
Caractère 2 | O Slotter après mitraillage N Pas de slotter après mitraillage (par défaut)
Caractère 3 | A Nombre d'outils à caler B Poussée C Quantité passée D Nombre de plaques initial E Nombre de poses du sens (Coupe/Recoupe) Pas de valeur par défaut
Caractère 4 | M Mitraillage classique de caisses (par défaut) V Mitraillage avant impression P Mitraillage après impression

MJ - Mise à jour informations

Caractère 1

1 On met à jour le prix papier de l'entité fi_p_papier en fonction du caractère 3

Caractère 2 = B : Le prix est mis à jour puis il est bloqué (fi_pap_bloque = O)

Caractère 2 = [espace] : Le prix est mis à jour sans blocage.

2 On met à jour le poids papier fi_pds_pap avec le contenu de la valeur 2.

3 On met à jour le nombre de couleurs recto fi_co_recto avec le contenu de la valeur 1.

4 On met à jour le nombre de couleurs verso fi_co_verso avec le contenu de la valeur 2.

5 On met à jour la zone fi_bascule avec :

O si la valeur 1 est à 1

N sinon

Pas de mise à jour si la valeur 1 est à 999.

La zone fi_bascule correspond au jonctionnement sur le devis_tc.

6 On met à jour le nombre de tours gâche comprise recto fi_tours_gcr avec le contenu de la valeur 1.

7 On met à jour le nombre de feuilles fi_feu_pap avec la quantité totale fm_tot_qte/fo_tot_qte.

8 On met à jour le nombre de feuilles hors gâche fi_feu_pap_hg en fonction du caractère 2

9 On met à jour le nombre de feuilles hors gâche fi_feu_pap_hg avec la valeur 2

A On met à jour le poids papier hors gâche fi_pds_pap_hg en fonction du caractère 2

B On met à jour le poids papier hors gâche fi_pds_pap_hg avec la valeur 2

C On met à jour le nombre de recherches de teinte avec la valeur 1

Caractère 2 = R : Mise à jour du nombre de recherches de teintes recto

Caractère 2 = V : Mise à jour du nombre de recherches de teintes verso

D On met à jour le délai de fabrication avec le contenu de la valeur 2

Caractère 2 = F (c'est le seul cas envisagé).

E On met à jour l'épaisseur du support fi_epaisseur avec la valeur 1

F On met à jour la zone Présence de découpe (fle_imp.fi_nb_decoupe) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

Si valeur n = [autre], pas de mise à jour

G On met à jour la zone Présence d'accessoires de l'entité en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

H On met à jour la zone Présence de collage de l'entité en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

I On met à jour la zone Présence de dorure (fle_imp.fi_dorure) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

Si valeur n = [autre], pas de mise à jour

J On met à jour la zone Présence de gaufrage (fle_imp.fi_gaufrage) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

Si valeur n = [autre], pas de mise à jour

K On met à jour le pourcentage de la gâche fixe fi_gache_fix_fac en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

L On met à jour la laize fi_lar_papier avec la valeur 1

Pas de mise à jour si la valeur 1 est à 999.

M On met à jour la machine d'impression

Mises à jour sur l'entité courante (fle_imp)

R On met à jour le code machine d'impression recto de l'entité (fi_mac_imp)

V On met à jour le code machine d'impression verso de l'entité (fi_mac_imp2)

Mises à jour sur les lignes d'impressions multiples (fle_combi)

1 On met à jour le code machine d'impression du passage n°1 (fco_mac_imp)

2 On met à jour le code machine d'impression du passage n°2 (fco_mac_imp)

3 On met à jour le code machine d'impression du passage n°3 (fco_mac_imp)

4 On met à jour le code machine d'impression du passage n°4 (fco_mac_imp)

5 On met à jour le code machine d'impression du passage n°5 (fco_mac_imp)

6 On met à jour le code machine d'impression du passage n°6 (fco_mac_imp)

7 On met à jour le code machine d'impression du passage n°7 (fco_mac_imp)

8 On met à jour le code machine d'impression du passage n°8 (fco_mac_imp)

9 On met à jour le code machine d'impression du passage n°9 (fco_mac_imp)

0 On met à jour le code machine d'impression du passage n°10 (fco_mac_imp)

a On met à jour le code machine d'impression du passage n°11 (fco_mac_imp)

b On met à jour le code machine d'impression du passage n°12 (fco_mac_imp)

c On met à jour le code machine d'impression du passage n°13 (fco_mac_imp)

d On met à jour le code machine d'impression du passage n°14 (fco_mac_imp)

e On met à jour le code machine d'impression du passage n°15 (fco_mac_imp)

f On met à jour le code machine d'impression du passage n°16 (fco_mac_imp)

g On met à jour le code machine d'impression du passage n°17 (fco_mac_imp)

h On met à jour le code machine d'impression du passage n°18 (fco_mac_imp)

i On met à jour le code machine d'impression du passage n°19 (fco_mac_imp)

j On met à jour le code machine d'impression du passage n°20 (fco_mac_imp)

N On met à jour la zone Présence de contre-collage en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

O On met à jour le pourcentage de la gâche variable fi_gache_var_fac en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

P On met à jour le nombre de poses de_nb_poses avec le contenu de la valeur 1.

Le numéro de référence est stocké dans la valeur 2.

Q On met à jour le nombre de feuilles fi_feu_pap en fonction du caractère 2

R On met à jour le nombre de feuilles de_num9 avec le contenu de la valeur 1 en fonction du caractère 3

Caractère 2 = [blanc] : pour toutes les références de l'entité en cours.

Caractère 2 = E : pour toutes les réf. de l'entité avec le numéro d'entité = 0 : MàJ des références du devis.

S On met à jour le mode de réapprovisionnement selon la valeur 1

Si V1 = 0 : Mode de réapprovisionnement = S (Stock interne)

Si V1 = 1 : Mode de réapprovisionnement = C (A commander)

Si V1 = 2 : Mode de réapprovisionnement = F (Fabrication)

Si V1 = 3 : Mode de réapprovisionnement = B (Fabristock)

Si V1 = 4 : Mode de réapprovisionnement = E (Externe)

Si V1 = [autre] : Pas de mise à jour du mode de réapprovisionnement

T On met à jour le forçage de la gâche fi_gache_for_fac en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

U On met à jour la zone Présence de fenêtrage de l'entité en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = [autre], pas de mise à jour

V On met à jour la zone Forçage du prix de vente de la formule matière (fle_mat.fm_prix_bloque) en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur P (Prix de vente forcé)

Si valeur n = 2, on met à jour avec la valeur 2 (Prix de vente forcé + Gâche forcée)

Si valeur n = 3, on met à jour avec la valeur G (Gâche forcée)

Si valeur n = 0, on met à jour avec la valeur N (Aucun forçage)

Si valeur n = [autre], pas de mise à jour

W On met à jour la zone Forçage du prix de vente de la formule opération (fle_ope.fo_prix_bloque) en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Prix de vente forcé)

Si valeur n = 0, on met à jour avec la valeur N (Aucun forçage)

Si valeur n = [autre], pas de mise à jour

X On met à jour la zone Forçage de cadence/temps de la formule opération (fle_mat.fm_cad_tps_b) en fonction du caractère 2

Si valeur n = 1, on met à jour avec la valeur O (Cadence/Temps forcé)

Si valeur n = 2, on met à jour avec la valeur 2 (Cadence/Temps forcé + Gâche forcée)

Si valeur n = 3, on met à jour avec la valeur G (Gâche forcée)

Si valeur n = 4, on met à jour avec la valeur C (Cadence/Temps forcé) (idem n = 1)

Si valeur n = 0, on met à jour avec la valeur N (Aucun forçage)

Si valeur n = [autre], pas de mise à jour

a On met à jour la zone Présence de foulage (fle_imp.fi_foulage) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

b On met à jour la zone Présence de transfert/collage (fle_imp.fi_transfert) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

c On met à jour la zone Présence de numérotage (fle_imp.fi_numerotage) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

d On met à jour la zone Présence de perforation (fle_imp.fi_perfo) en fonction du caractère 2

Si valeur n = 0, on met à jour avec la valeur N (Non)

Si valeur n = 1, on met à jour avec la valeur O (Oui)

Si valeur n = 2, on met à jour avec la valeur L (En Ligne)

Si valeur n = 3, on met à jour avec la valeur H (Hors Ligne)

Si valeur n = 4, on met à jour avec la valeur S (Sous-traité(e))

e On met à jour la coupe fi_lon_papier en fonction du caractère 2
Pas de mise à jour si la valeur est à 999

Caractère 2

1 ou [blanc] Mise à jour du champ avec le contenu de la valeur 1 (par défaut)

2 Mise à jour du champ avec le contenu de la valeur 2

3 Mise à jour du champ avec le contenu de la valeur 3

4 Mise à jour du champ avec le contenu de la valeur 4

5 Mise à jour du champ avec le contenu de la valeur 5

6 Mise à jour du champ avec le contenu de la valeur 6

7 Mise à jour du champ avec le contenu de la valeur 7

8 Mise à jour du champ avec le contenu de la valeur 8

9 Mise à jour du champ avec le contenu de la valeur 9

0 Mise à jour du champ avec le contenu de la valeur 10

Caractère 3

Attention décalage ->

Attention décalage ->

Si caractère 1 = 1

1 Mise à jour avec le contenu de la valeur 1 (par défaut)

2 Mise à jour avec le contenu de la valeur 2

3 Mise à jour avec le prix de revient de la formule matière (fm_pr)

T Mise à jour avec le contenu de la valeur 3

4 Mise à jour avec le contenu de la valeur 4

5 Mise à jour avec le contenu de la valeur 5

6 Mise à jour avec le contenu de la valeur 6

7 Mise à jour avec le contenu de la valeur 7

8 Mise à jour avec le contenu de la valeur 8

9 Mise à jour avec le contenu de la valeur 9

0 Mise à jour avec le contenu de la valeur 10

Si caractère 1 = R : le caractère 3 fonctionne comme le caractère 2.

MO - Montants

Retour numérique

Caractère 1 | 1 Montant commande 2 Montant des opérations de la phase (voir car.5) 3 Montant des matières de la phase (voir car.5) 4 Montant de la sous-traitance de la phase (voir car.5) 5 Montant du transport Car.6 = I Montant total du transport interne de l'entité en cours Car.6 = C Montant total du transport client de l'entité en cours 6 Pourcentage de commission appliqué à ce devis 7 Montant des opérations, des matières, de la sous-traitance de la phase XXX (voir car.5)
Caractères 2 à 4 | Si caractère 1 = 2, 3 ou 4 : ode phase (sauf pour l' option 1) [Blanc] On cumule toutes les phases

MP - Impression multi-passages

Caractère 1

Type d'enregistrement

1 Vernis hors-ligne

2 Vernis sous-traitance

3 Lignes d'impression multiples

Car.4 = C : Nombre de couleurs

Car.6 = R : Nombre total de couleurs utilisées pour les passages recto

Car.6 = V : Nombre total de couleurs utilisées pour les passages verso

Car.6 = 2 : Nombre total de couleurs utilisées pour les passages recto/verso

Car.6 = [autre] Nombre de couleurs du numéro de passage (par défaut)

Pour les valeurs R, V et 2, les paramétrages du numéro de passage (car. 2 et 3) et du numéro de vernis (car. 5) ne sont pas pris en compte.

Car.4 = L : Présence de bascule infos

Car.6 = A Retourne O si présence de bascule, N sinon (retour alphanumérique)

Car.6 = N Retourne 1 si présence de bascule, 0 sinon (retour numérique)

Car.6 = X Retourne 2 si présence de bascule, 1 sinon (retour numérique)

Car.6 = [autre] Retourne la valeur de bascule (retour alpha) (par défaut)

Car.4 = V : Nombre total de vernis utilisés

Car.6 = R : Nombre total de vernis utilisés pour les passages recto

Car.6 = V : Nombre total de vernis utilisés pour les passages verso

Car.6 = [autre] : Nombre total de vernis utilisés (par défaut)

Car.5 = N° de vernis dans le passage saisi en car.2 et 3

(Si car.4 = V : optionnel. Sinon : 1 par défaut)

Caractères 2 et 3

Numéro de passage (optionnel si caractère 4 = V)

Caractère 4

1 Code vernis

Car.6 = a : Retourne la zone numérique 1 du paramètre VER correspondant au code vernis

Car.6 = b : Retourne la zone numérique 2 du paramètre VER correspondant au code vernis

Car.6 = c : Retourne la zone numérique 3 du paramètre VER correspondant au code vernis

Car.6 = d : Retourne la zone numérique 4 du paramètre VER correspondant au code vernis

2 Pourcentage de vernissage du recto

3 Code machine de vernissage recto

4 Code vernis du verso

5 Pourcentage de vernissage du verso

6 Code machine de vernissage du verso

7 Nombre de passages pour le recto

8 Nombre de passages pour le verso

9 Code fournisseur (vernis de sous-traitance)

A Type de passage d'impression (correspond à un paramètre de type TPI)

Car.6 = 1 Initialisation de la zone fo_a1 avec le type de passage

Car.6 = 2 Initialisation de la zone fo_a2 avec le type de passage

Car.6 = a : Retourne la zone numérique 1 du paramètre TPI correspondant au type de passage d'impression

Car.6 = b : Retourne la zone numérique 2 du paramètre TPI correspondant au type de passage d'impression

Car.6 = c : Retourne la zone numérique 3 du paramètre TPI correspondant au type de passage d'impression

Car.6 = d : Retourne la zone numérique 4 du paramètre TPI correspondant au type de passage d'impression

B Type de ligne

C Nombre de couleurs

D Pourcentage d'encrage

E Présence de quadrichromie

Si car. 1 = 3

Car.6=A Retourne O si présence de quadrichromie, N sinon (retour alphanumérique, par défaut)

Car.6=N Retourne 1 si présence de quadrichromie, 0 sinon (retour numérique)

F Nombre de recherche de teintes

G Nombre de changements de plaques

H Nombre de changements de teintes

I Machine d'impression

J Machine forcée

K Nombre de couleurs communes entre le recto et le verso

L Présence de bascule

Car.6 = " " : Retourne la bascule (O/1/8/E/N)

Car.6 = A : Retourne O si bascule = O/1/8, N sinon

Car.6 = N : Retourne 1 si bascule = O/1/8, 0 sinon

Car.6 = X : Retourne 2 si bascule = O/1/8, 1 sinon

M Nombre de couleurs primaires

N Nombre de repiquages

O Code article associé au vernis recto VER A1[2,16]

o Code article associé au deuxième vernis recto VER A1[22,36]

P Code article associé au vernis verso VER A1[2,16]

p Code article associé au deuxième vernis verso VER A1[22,36]

V Nombre total de vernis utilisés (si car.1 = 3)

Caractère 5

Numéro de vernis (par défaut : 1)

Caractère 6

Utilisé en fonction des caractères 1 et 4

NP - Nombre de poses

Retour numérique

Caractère 1

P Nombre de poses plaque

I Nombre de poses impression

D Nombre de poses découpe

R Rapport plaque / découpe

N Nombre de poses devis Impression/Carton

Renvoie selon paramétrage du TEN A2[48] le nombre de poses de la décomposition
(voir code calcul CF caractère 1 = 3)

C Nombre total de coupes

Caractère 2 = 1 : Refente avant impression

Caractère 4 = O : Ajout d'une coupe pour chacun des côtés dans le cas où le format du papier dépasse le format de tirage et que le format du papier dépasse le format matière maxi de la machine. Ces deux coupes correspondent à une mise au format.

Caractère 2 = 2 : Refente après impression (défaut)

Caractère 4 = O : Recherche du nombre de coupes sur la LCO MAS.
Si aucune valeur trouvée sur la LCO, on ramène le résultat par défaut.

Caractère 2 = 3 : Refente après pliage (multi-poses)

G Valeur de la poignée

La poignée est recherchée en priorité sur la LCO #PO (v1).

Si aucune poignée forcée sur LCO, alors :

Caractère 2 = O : La valeur de la poignée est recherchée via l'opération standard définie sur la formule MAS POI.
Si aucune valeur trouvée via l'opération standard, on ramène le résultat par défaut.
Rappel de paramétrage de formule MAS/POI :

Caractère 1 = O : Refente avant impression

Caractère 1 = N : Refente après impression (Défaut)

Caractère 2 = O : Equerrage

Caractère 2 = N : Paramètre prioritaire par rapport au caractère 1

Caractère 2 = N : Calcul standard de valeur de poignée (défaut)

Caractère 2

Si caractère 1 = P, I, D, R :

L Nombre de poses laize

C Nombre de poses coupe

* Nombre total de poses

Si caractère 1 = C :

1 Refente avant impression

2 Refente après impression (défaut)

Si caractère 1 = G :

O La valeur de la poignée est recherchée via l'opération standard définie sur la formule MAS POI

N Calcul standard de valeur de poignée (défaut)

Caractère 3

P Si le nombre de poses/ coupes est pair : 1, sinon 0

I Si le nombre de poses/ coupes est impair : 0, sinon 1

[espace] Pas de changement

Caractère 4

Si caractère 1 = C et caractère 2 = 1 :

O Ajout d'une coupe pour chacun des côtés dans le cas où le format du papier (uniquement si le papier n'est pas générique) dépasse le format de tirage.
Ces deux coupes correspondent à une mise au format.

D Ajout d'une coupe pour chacun des côtés dans le cas où le format du papier dépasse le format de tirage.

Si caractère 1 = C et caractère 2 = 2 :

O Recherche du nombre de coupe sur la LCO MAS.
Si aucune valeur trouvée sur la LCO, on ramène le résultat par défaut

OC - Opérations sur deux LCO

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Caractères 1 à 3

Code LCO qualifiant l'opérateur 1

Caractères 4 à 6

Code LCO qualifiant l'opérateur 2

Caractère 7

1 v1 LCO 1 + v1 LC0 2

2 v1 LCO 1 - v1 LC0 2

3 v1 LCO 1 * v1 LC0 2

4 v1 LCO 1 / v1 LC0 2

5 v1 LCO 1 + v2 LC0 2

6 v1 LCO 1 - v2 LC0 2

7 v1 LCO 1 * v2 LC0 2

8 v1 LCO 1 / v2 LC0 2

A v2 LCO 1 + v1 LC0 2

B v2 LCO 1 - v1 LC0 2

C v2 LCO 1 * v1 LC0 2

D v2 LCO 1 / v1 LC0 2

E v2 LCO 1 + v2 LC0 2

F v2 LCO 1 - v2 LC0 2

G v2 LCO 1 * v2 LC0 2

H v2 LCO 1 / v2 LC0 2

I Le + grand entre v1 LCO 1 et v1 LCO 2

J Le + grand entre v1 LCO 1 et v2 LCO 2

K Le + petit entre v1 LCO 1 et v1 LCO 2

L Le + petit entre v1 LCO 1 et v2 LCO 2

Les codes suivants retournent 1 si les valeurs des zones sont égales, 0 sinon :

M Valeur de la zone A de la LCO 1 = Valeur de la zone A de la LCO 2

N Valeur de la zone A de la LCO 1 = Valeur de la zone B de la LCO 2

P Valeur de la zone A de la LCO 1 = Valeur de la zone G de la LCO 2

Q Valeur de la zone A de la LCO 1 = Valeur de la zone H de la LCO 2

R Valeur de la zone B de la LCO 1 = Valeur de la zone A de la LCO 2

O Valeur de la zone B de la LCO 1 = Valeur de la zone B de la LCO 2

S Valeur de la zone B de la LCO 1 = Valeur de la zone G de la LCO 2

T Valeur de la zone B de la LCO 1 = Valeur de la zone H de la LCO 2

U Valeur de la zone G de la LCO 1 = Valeur de la zone A de la LCO 2

V Valeur de la zone G de la LCO 1 = Valeur de la zone B de la LCO 2

W Valeur de la zone G de la LCO 1 = Valeur de la zone G de la LCO 2

X Valeur de la zone G de la LCO 1 = Valeur de la zone H de la LCO 2

Y Valeur de la zone H de la LCO 1 = Valeur de la zone A de la LCO 2

Z Valeur de la zone H de la LCO 1 = Valeur de la zone B de la LCO 2

9 Valeur de la zone H de la LCO 1 = Valeur de la zone G de la LCO 2

0 Valeur de la zone H de la LCO 1 = Valeur de la zone H de la LCO 2

OP - Optimisation de placement

Retour numérique

Caractère 1 | 1 Recherche du nombre maxi de poses d'impression dans le format machine. On ne tient pas compte du sens des fibres (Sérigraphie). Vous devez saisir correctement les formats machine.
Caractère 2 | 1 On retourne le nombre de poses max. 2 Traitement particulier sérigraphie Si nombre de poses >=2, on est en demi-plaque. On retourne 0.5. Sinon, on retourne 1. Lecture de l'enregistrement opération de 1 à 10 pour récupérer le code machine, afin de rechercher son format. Saisir 01-02-...10

PA Papier

Retour alphanumérique

Caractère 1

1 Grammage saisi sur l'écran de l'entité

2 Epaisseur papier (mat.mp_hau)

Car.2 = E : Epaisseur saisie sur l'entité (fle_imp.fi_epaisseur)

3 Grammage de l'entité la plus forte en nombre de pages

4 Prix papier saisi sur l'écran de l'entité

5 Couleur du papier fle_imp.fi_couleur_pap

6 Poids papier hors gâche (fle_imp.fi_pds_pap_hg)

Car.2 = T : Poids papier toutes gâches comprises de l'entité (fle_imp.fi_pds_pap)

7 Nombre de feuilles papier hors gâche fi_feu_pap_hg

Car.2 = T : Somme des quantités de papier hors gâche toutes entités comprises sauf entité en cours

8 Gâche de façonnage fixe fi_gache_fix_fac

9 Gâche de façonnage variable fi_gache_var_fac

0 Gâche de façonnage forcée fi_gache_for_fac

G Code papier générique

Car.2 = A : Retour alphanumérique

Car.2 = N : Retour numérique

P Nature du papier (Feuille/Bobine/Cameron&)

Car.2 = A Retour alphanumérique (renvoie R (Roto), F (Feuille), K (Cameron), C (Carton), [Espace] (Autres))

Car.2 = N Retour numérique (renvoie 1 : Feuille, 2 : Roto, 0 : Autres)

PC - Détermination des parcours

Non standard (BL)

Retour numérique

Ce mode permet d'aller lire une opération particulière qui est définie par les valeurs b et c de V1 et retourne le nombre de cahiers à traiter.

L'opération qui précise les plages de parcours est définie par :

b de V1 (section/opération ) sans code calcul

c de V1 (sous-opération ) sans code calcul

Code difficulté = NOR, Machine = [blanc]

Les dépendances de cette opération sont celles de l'opération en cours.

Vous devez obligatoirement définir en quantité le code calcul PC

Caractère 1

1 Traite la plage numérique 2 de x à y

2 Traite la plage numérique 3

3 Traite la plage numérique 4

On définit ainsi des opérations élémentaires

FAC CAH PA1

FAC CAH PA2

FAC CAH PA3

et 3 formules pour traiter chacun des cas.

La valeur déterminée à partir de a, b, c est multipliée par le résultat de d (d peut ainsi contenir une quantité).

PF Profil carton

Le profil carton est saisi sur la LCO PC.

Caractère 1 | Numéro du papier (1, 2 ou 3)
Caractère 2 | A Type de cannelure Type de paramètre PC, valeur alpha 1 Caractère 20 : papier 1 Caractère 21 : papier 2 Caractère 22 : papier 3 V Coefficient de cannelure Type de paramètre CAN, valeur numérique 1

PG Paramètres généraux

Retour numérique

Caractère 1

1 Valeur du temps de séchage avant bascule (paramètre saisi dans #CFDEG note TPS_ATT_SECHAGE_BASC)

2 Indique si le cassage se fait sur casseuse ou en ligne

S'il y a cassage (LCO #CA valeur 1 = O sur l'entête du devis)

ET s'il y a au moins un pli dans la décomposition qui ne soit pas en ligne (PLI A1[27]=F),

alors le cassage se fera sur casseuse et non pas en ligne.

Valeurs de retour :

O cassage sur casseuse dédiée

N cassage en ligne (uniquement pour les rotatives)

PL - Informations plaques

Retour numérique

Caractères 1 et 2

(le caractère 2 est toujours à blanc)

1 Nombres de plaques (recto + verso)

2 Nombres de plaques (recto)

3 Nombres de plaques (verso)

4 Nombres de plaques (recto + verso) (sans les changements de plaque et repiquage)

5 Nombres de plaques (recto) (sans les changements de plaque et repiquage)

6 Nombres de plaques (verso) (sans les changements de plaque et repiquage)

7 .

Utilise le paramètre numérique 1 des machines d'impression recto/verso

comme nombre de films A4 que l'on peut tirer sur ces machines.

8 Nombres de plaques recto (avec changements de plaque et repiquage et vernis)

9 Nombres de plaques verso (avec changements de plaque et repiquage et vernis)

PM - Liens entre machines et plis

Ce code permet de récupérer les informations de lien entre un pli et une machine.

Caractère 1 | Récupération du code machine O Code machine de l'opération courante R Code machine recto de l'entité V Code machine verso de l'entité P Code machine (plieuse) de la première ligne de décomposition
Caractère 2 | Récupération du code pli O Code pli de l'opération courante (via le numéro de référence) P Code pli de la première ligne de décomposition
Caractères 3 et 4 | Récupération de la zone A Zone alpha 1 (lie_alpha1) B Zone alpha 2 (lie_alpha2) C Zone alpha 3 (lie_alpha3) 1 Zone numérique 1 (lie_num1) 2 Zone numérique 2 (lie_num2) 3 Zone numérique 3 (lie_num3) 4 Zone numérique 4 (lie_num4) 5 Zone numérique 5 (lie_num5) 6 Zone numérique 6 (lie_num6) 7 Zone numérique 7 (lie_num7) 8 Zone numérique 8 (lie_num8) 9 Zone numérique 9 (lie_num9) 10 Zone numérique 10 (lie_num10) 11 Zone numérique 11 (lie_num11) 12 Zone numérique 12 (lie_num12) 13 Zone numérique 13 (lie_num13) 14 Zone numérique 14 (lie_num14)

PO - Calcul des Pointages

Retour numérique

Caractère 1 | L Pointage longueur (coupe) (1-30) H Pointage hauteur (laize) (1-30) E Ecart entre pointages longueur (coupe) F Ecart entre pointages hauteur (laize) S Données spécifiques (1-12) C Données calculées (1- 9)
Caractère 2 | 1 Pointage 1 2 Pointage 2 3 Pointage 3 4 Pointage 4 5 Pointage 5 6 Pointage 6 7 Pointage 7 8 Pointage 8 9 Pointage 9 0 Pointage 10 a Pointage 11 b Pointage 12 c Pointage 13 d Pointage 14 e Pointage 15 f Pointage 16 g Pointage 17 h Pointage 18 i Pointage 19 j Pointage 20 k Pointage 21 l Pointage 22 m Pointage 23 n Pointage 24 o Pointage 25 p Pointage 26 q Pointage 27 r Pointage 28 s Pointage 29 t Pointage 30 G Le plus grand P Le plus petit N Le nombre2 Les pointages pris en compte pour G, P, N seront de type L, H, C et auront l'indicateur à contrôler positionné au niveau du paramètre CP en zone alpha1[2].
Caractère 3 | 1 Multiplié par la quantité hors gâche 2 Multiplié par la quantité toute gâche
Caractère 4 | On recherche les informations sur l'entité C couverture COU T couverture cartonnée CVC J jaquette JAQ G gardes GAR L gardes blanches GAB Si aucune entité n'est trouvée, le code calcul retourne la valeur 0 (zéro).

PR - Informations produit

Retour alphanumérique

Caractère 1

1 Type de finition

2 Famille produit devis

3 Sous-famille produit devis

4 Catégorie produit devis

5 Famille produit entité

6 Sous-famille produit entité

7 Catégorie produit entité

PS - Cumul des quantités d'une phase sur les entités

Retour numérique

Ce mode permet d'aller rechercher les valeurs stockées sur toutes les formules d'une phase.

Caractères 1 à 3

Code phase

Attention : on ne tient compte que de la première phase trouvée correspondant au code.

Caractère 4

1 On récupère la valeur numérique 1

2 On récupère la valeur numérique 2

3 On récupère la quantité hors gâche

4 On récupère la quantité toutes gâches

5 On récupère la gâche fixe

6 On récupère la gâche variable

7 On récupère le coût total

8 On récupère le coût unitaire

A On récupère la valeur calculée 3 (v3)

B On récupère la valeur calculée 4 (v4)

C On récupère la valeur calculée 5 (v5)

D On récupère la valeur calculée 6 (v6)

E On récupère la valeur calculée 7 (v7)

F On récupère la valeur calculée 8 (v8)

G On récupère la valeur calculée 9 (v9)

H On récupère la valeur calculée 10 (v10)

T On récupère le temps total (formule opération uniquement)

Caractère 5

Méthode de cumul des valeurs

T On cumule sur toutes les entités du devis sauf l'entité courante

E On cumule toutes les entités y compris celle en cours

C On cumule uniquement sur l'entité courante (voir aussi code calcul PT)

[blanc] On cumule sur les entités précédant numériquement l'entité en cours.

<OU>

Méthode de recherche des valeurs

m On recherche la valeur minimum dans la phase paramétrée

M On recherche la valeur maximum dans la phase paramétrée

Caractère 6

Si caractère 5 = T, E, C ou [blanc] :

A On cumule uniquement les formules dont le code matière est identique à celui de la formule matière en cours.

B On cumule uniquement les formules dont le code matière et les dimensions sont identiques à ceux de la formule matière en cours.

[blanc] On cumule systématiquement (par défaut)

Si caractère 5 = m ou M :

A On prend en compte uniquement les formules dont le code matière est identique à celui de la formule matière en cours.

B On prend en compte uniquement les formules dont le code matière et les dimensions sont identiques à ceux de la formule matière en cours.

[blanc] On prend en compte toutes les formules (par défaut)

Caractère 7

Types de formules à prendre en compte

M Formules matières uniquement (par défaut)

O Formules opérations uniquement

S Formules sous-traitance uniquement

T Toutes les formules de la phase (matières, opérations et sous-traitance)

PT - Cumul des quantités d'une phase sur une formule d'entités

Retour numérique

Ce code calcul permet d'aller rechercher les valeurs matières stockées sur toutes les formules d'une phase.

Caractères 1 à 3 | Code phase (et non pas numéro de phase) Attention : on sélectionne la première.
Caractère 4 | 1 On récupère la valeur numérique 1 2 On récupère la valeur numérique 2 3 On récupère la quantité hors gâche 4 On récupère la quantité toutes gâches 5 On récupère la gâche fixe 6 On récupère la gâche variable 7 On récupère le coût total 8 On récupère le coût unitaire A On récupère la valeur calculée 3 (v3) B On récupère la valeur calculée 4 (v4) C On récupère la valeur calculée 5 (v5) D On récupère la valeur calculée 6 (v6) E On récupère la valeur calculée 7 (v7) F On récupère la valeur calculée 8 (v8) G On récupère la valeur calculée 9 (v9) H On récupère la valeur calculée 10 (v10)
Caractères 5 à 7 | Code formule sur laquelle s'effectue la sélection Si non renseigné, alors on prend toutes les lignes sans distinction.

QT - Quantités

Caractères 1 et 2

Le symbole */ (multiplié ou divisé) est fonction du caractère 7.

0 Renvoie 0

1 Renvoie 1

2 Quantité de l'entité hors gâche
Si caractère 7 non blanc (a), on multiplie par le nombre de morceaux (table ECMA).

3 Quantité de l'entité gâche comprise
Si caractère 7 non blanc (a), on multiplie par le nombre de morceaux (table ECMA).

4 Nombre de plaques en découpe
Si caractère 3 = S : hors gâche, sinon gâche comprise
Si caractère 7 non blanc (a), on multiplie par le nombre de morceaux (table ECMA).

5 Nombre de plaques en impression
Si caractère 3 = S : hors gâche, sinon gâche comprise
Si caractère 7 non blanc (a), on multiplie par le nombre de morceaux (table ECMA).

6 Nombre de plaques initiales
Si caractère 3 = S : hors gâche, sinon gâche comprise
Si caractère 7 non blanc (a), on multiplie par le nombre de morceaux (table ECMA).

7 Nombre de morceaux (table ECMA)

8 Quantité entité gâche comprise * nombre passages impression

9 Quantité d'entité hors gâches */ valeur calculée définie en caractère 3
Caractère 3

10 Quantité entité hors gâche */ valeur 2

11 Quantité d'entité hors gâches */ (valeur calculée définie en caractère 3 * valeur calculée définie en caractère 5) - Caractère 3 - Caractère 5

12 Quantité d'entité gâches comprises */ valeur calculée définie en caractère 3
Caractère 3

13 Quantité entité gâche comprise */ valeur 2

14 Quantité d'entité gâches comprises */ (valeur calculée définie en caractère 3 * valeur calculée définie en caractère 5) - Caractère 3 - Caractère 5

15 Nombre total de pages de l'entité

16 Quantité devisée

17 Quantité d'entité gâches comprises */ maximum entre la valeur calculée définie en caractère 3 et la valeur calculée définie en caractère 5 - Caractère 3 - Caractère 5

18 Quantité d'entité gâches comprises */ minimum entre la valeur calculée définie en caractère 3 et la valeur calculée définie en caractère 5 - Caractère 3 - Caractère 5

19 Nombre de feuilles gâches comprises */ (valeur calculée définie en caractère 3 * valeur calculée définie en caractère 5) - Caractère 3 - Caractère 5

20 Nombre de feuilles gâches comprises * nombre de feuillets */ (valeur calculée définie en caractère 3 * valeur calculée définie en caractère 5) - Caractère 3 - Caractère 5

21 Nombre de plaques */ maximum entre la valeur calculée définie en caractère 5 et la valeur calculée définie en caractère 6 - Caractère 5 - Caractère 6

22 Nombre de plaques */ minimum entre la valeur calculée définie en caractère 5 et la valeur calculée définie en caractère 6 - Caractère 5 - Caractère 6

23 Nombre de bandes tronçonnées / Nombre de bandes

24 Nombre de bandes tronçonnées

25 Nombre de feuilles hors gâche

26 Nombre de feuilles hors gâche */ (valeur 1)

27 Nombre de feuilles après impression hors gâche

28 Nombre de feuilles après impression Hors Gâche + Gâche de finition

29 Nombre de tournées

30 Nombre de feuilles après impression Gâche Comprise

31 Nombre de feuilles après impression Gâche Comprise + Gâche de finition

32 Nombre de passages machine 1 (recto)

Car.3 = V : Prise en compte des vernis offset (un vernis offset compte comme une couleur)

33 Nombre de passages machine 2 (verso)

Car.3 = V : Prise en compte des vernis offset (un vernis offset compte comme une couleur)

34 Nombre d'ozalids

35 Nombre de typons

36 Nombre de tours hors gâche recto / nombre de passages */ (valeur 1)

37 Nombre de tours gâche comprise recto (fi_tours_gcr)

38 QT2 * IE3 (quantité hors gâche * nombre de volets)

39 QT3 * IE3 (quantité toutes gâches * nombre de volets)

40 Somme des quantités commandées de toutes les entités

41 Somme des quantités commandées des références de toutes les entités

42 Somme des quantités lancées de toutes les entité

43 Somme des quantités lancées des références de toutes les entités

44 Somme des quantités lancées des références de l'entité

45 Nombre de passages recto = Nombre de couleurs recto + 1 si présence de vernis offset sur le recto

46 Nombre de passages verso = Nombre de couleurs verso + 1 si présence de vernis offset sur le verso

Caractère 4

[espace] La quantité prise en compte est la quantité de l'entité.

L La quantité prise en compte est la quantité lancée de l'entité (par défaut).

La quantité lancée est la zone fi_qte_lancee de la table fle_imp, calculée lors de la saisie des références multiples (devis multi-métiers) multiplié par kma_nb_morceaux

Exemple

QT2  L (2 espaces)

Caractère 7

* (multiplié) (par défaut)

/ (divisé) La division n'est faite que si le diviseur est non nul. S'il est nul, le résultat est zéro.

(a) La condition est bien : si caractère 7 non blanc, on multiplie par le nombre de morceaux de la table ECMA.

Autrement dit, on multiplie même si le caractère 7 = / (divisé)...

gâche comprise : la gâche est appliquée ainsi :

(valeur sur laquelle on veut appliquer la gâche) X (1 + gâche variable / 100) + gâche fixe

Exemple avec la quantité de l'entité : let gl_dep_num = (sinull(p_fi.fi_qteent) * (1+gf_var/100) + gf_fixe)

QU - Qualité

Retour numérique ou alphanumérique

#CF ATL alpha2[17] | 1 Le profil carton est déterminé par la famille de l'article. [autres valeurs] Le profil carton est déterminé par la sous famille de l'article.
Caractère 1 | 1 Epaisseur du profil carton définie sur le paramètre PC, alpha 1[23,28] (numérique) [autres valeurs] On retourne le profil carton (alphanumérique)

Les profils cartons doivent être autorisés sur une machine.

Ils sont déterminés par les TSC 730 à 741 de la machine (zone F = famille, zone H = sous famille).

Le résultat lu est soit une sous famille, soit caractère *

RD - Recherche données opérations sur une phase

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Ce mode permet d'aller rechercher une valeur stockée sur une opération.

Caractères 1 à 3

Code opération

Caractères 4 à 6

Code formule

Caractère 7

1 On récupère la valeur numérique 1

2 On récupère la valeur numérique 2

3 On récupère la quantité hors gâche

4 On récupère la quantité toutes gâches

5 On récupère le temps total

6 On récupère le code plaque de la machine d'impression

7 On récupère le code plaque vernis de la machine d'impression

8 On récupère le temps réglage

9 On récupère la cadence standard

A On récupère la gâche fixe

B On récupère la gâche variable

C On récupère le montant total

c On récupère le coût horaire de l'opération (fle_ope.fo_ch)

D On récupère la zone paramétrable 3 de la machine d'impression

E On récupère la valeur calculée 3 (v3)

F On récupère la valeur calculée 4 (v4)

G On récupère la valeur calculée 5 (v5)

H On récupère la quantité hors gâches de l'opération (gâches cumulatives)

I On récupère la valeur numérique 1 de l'opération

J On récupère la valeur numérique 2 de l'opération

K On récupère la valeur numérique 3 de l'opération

L On récupère la valeur numérique 4 de l'opération

M On récupère le code machine

m Retourne 100 si le site de la machine de l'opération (mac0.m0_sit_prod) est égal au site de l'entité courante (fle_imp.fi_sit), 0 sinon.

N On récupère le numéro de passage de l'opération

O On récupère la valeur calculée 6 (v6)

P On récupère la valeur calculée 7 (v7)

Q On récupère la valeur calculée 8 (v8)

R On récupère la valeur calculée 9 (v9)

S On récupère la valeur calculée 10 (v10)

T On récupère la quantité toute gâches de l'opération (gâches cumulatives)

U On récupère la quantité hors gâche fixe de l'opération (gâches cumulatives)

V On récupère la quantité toutes gâches - la quantité hors gâche fixe de l'opération

(gâches cumulatives)

X On récupère la clé tarifaire

Z On récupère le code machine correspondant au code paramètre ADM alpha1[1,6]

Le code du paramètre est pris dans fo_tpsstd.

RF Information référence multiple

Caractère 1

A Quantité client

Caractère 2

A Somme des quantités client des lignes liées à la ligne en cours par le gaufrage

B Somme des quantités client des lignes liées à la ligne en cours par le braille

C Somme des quantités client des lignes liées à la ligne en cours par le collage

D Somme des quantités client des lignes liées à la ligne en cours par la découpe

F Somme des quantités client des lignes liées à la ligne en cours par le fenêtrage

G Quantité client gâche comprise

H Somme des quantités client des lignes liées à la ligne en cours par l'hologramme

L Somme des quantités client des lignes liées à la ligne en cours par le foulage

O Somme des quantités client des lignes liées à la ligne en cours par la dorure

R Somme des quantités client des lignes liées à la ligne en cours par le rainage

T Somme des quantités client des lignes liées à la ligne en cours par le transfert/poudrage

V Somme des quantités client des lignes liées à la ligne en cours par la vignette

[Autre] Quantité client (par défaut)

B Quantité lancée

Caractère 2

A Somme des quantités lancées des lignes liées à la ligne en cours par le gaufrage

B Somme des quantités lancées des lignes liées à la ligne en cours par le braille

C Somme des quantités lancées des lignes liées à la ligne en cours par le collage

D Somme des quantités lancées des lignes liées à la ligne en cours par la découpe

F Somme des quantités lancées des lignes liées à la ligne en cours par le fenêtrage

G Quantité lancée gâche comprise

H Somme des quantités lancées des lignes liées à la ligne en cours par l'hologramme

L Somme des quantités lancées des lignes liées à la ligne en cours par le foulage

O Somme des quantités lancées des lignes liées à la ligne en cours par la dorure

R Somme des quantités lancées des lignes liées à la ligne en cours par le rainage

T Somme des quantités lancées des lignes liées à la ligne en cours par le transfert/poudrage

V Somme des quantités lancées des lignes liées à la ligne en cours par la vignette

[Autre] Quantité lancée (par défaut)

C Code produit - Voir tableau ci-dessous

D Informations ECMA

Si caractère 2 = C : Code ECMA

Si caractère 2 = T : Type ECMA

Si caractère 2 = M : Nombre de morceaux

Si caractère 2 = P : Lecture du paramétrage ECMA

Si caractère 3 = 1 : Type de collage (A1[8,10])

Si caractère 3 = 2 : Zone libre (A1[11,13])

Si caractère 3 = 3 : Valeur 1

Si caractère 3 = 4 : Valeur 2

Si caractère 2 = D : Dimensions

Si caractère 3 = 1 : Valeur de z1

Si caractère 3 = 2 : Valeur de z2

Si caractère 3 = 3 : Valeur de z3

Si caractère 3 = 4 : Valeur de z4

Si caractère 3 = 5 : Valeur de z5

Si caractère 3 = 6 : Valeur de z6

Si caractère 3 = 7 : Valeur de z7

Si caractère 3 = 8 : Valeur de z8

Si caractère 3 = 9 : Valeur de z9

Si caractère 3 = A : Valeur de z10

Si caractère 3 = B : Valeur de z11

Si caractère 3 = C : Valeur de z12

Si caractère 2 = N : Code de difficulté de calage (ecma.kma_code_diff_cal)

Si caractère 2 = O : Code de difficulté de roulage (ecma.kma_code_diff_rou)

E Largeur (A)

F Longueur (B)

G Hauteur (H)

H Forçage du nombre de poses

I Nombre de poses

Caractère 2

B Somme des poses des lignes liées à la ligne en cours par le braille

C Somme des poses des lignes liées à la ligne en cours par le collage

D Somme des poses des lignes liées à la ligne en cours par la découpe

F Somme des poses des lignes liées à la ligne en cours par le fenêtrage

G Somme des poses des lignes liées à la ligne en cours par le gaufrage

H Somme des poses des lignes liées à la ligne en cours par l'hologramme

L Somme des poses des lignes liées à la ligne en cours par le foulage

O Somme des poses des lignes liées à la ligne en cours par la dorure

P Nombre de poses au pliage de la ligne de décomposition de feuille associée à la référence en cours

R Somme des poses des lignes liées à la ligne en cours par le rainage

T Somme des poses des lignes liées à la ligne en cours par le transfert/poudrage

V Somme des poses des lignes liées à la ligne en cours par la vignette

[Autre] Nombre de poses (par défaut)

J Pour le collage, ligne de référence liée

Caractère 2

B Numéro de référence liée par le braille

C Numéro de référence liée par le collage (par défaut)

D Numéro de référence liée par la découpe

F Numéro de référence liée par le fenêtrage

G Numéro de référence liée par le gaufrage

H Numéro de référence liée par l'hologramme

L Numéro de référence liée par le foulage

O Numéro de référence liée par la dorure

R Numéro de référence liée par le rainage

T Numéro de référence liée par le transfert/poudrage

V Numéro de référence liée par la vignette

K Présence de dorure - Voir tableau ci-dessous

L Présence de gaufrage - Voir tableau ci-dessous

M Présence de fenêtrage - Voir tableau ci-dessous

N Nombre de couleurs au recto

O Nombre de couleurs au verso

P Nombre de variantes

Q Nombre de poses de fle_dec pour la référence

Caractère 2 = T : Nombre de poses de fle_imp pour la référence
Si rien trouvé (0), on renvoie 1.

Caractère 2 = P : Cumul du nombre de poses des références multiples de l'entité dans le cadre du calcul du coefficient de poses
" Si le pliage est désactivé, on renvoie 1
" Si le pliage est activé, on renvoie le cumul du nombre de poses de la décomposition de la feuille de l'entité courante en ne prenant en compte que les lignes dont le type de pli est fait sur une plieuse.

R Numéro de référence liée à la formule courante

Car.2 = E : Numéro de la première référence associée à l'entité en cours

Car.2 =[Autre] : Numéro de référence associée à la formule en cours (par défaut)

S de_largeur_cahier

T de_hauteur_cahier

U de_surface

V de_pourcentage

W de_machine

X Forçage du format papier

Y Présence de foulage - Voir tableau ci-dessous

Z Présence de rainage - Voir tableau ci-dessous

1 Nombre de références d'une même ligne de collage

Caractère 2

B Nombre de référence liée à la ligne en cours par le braille

C Nombre de référence liée à la ligne en cours par le collage (par défaut)

D Nombre de référence liée à la ligne en cours par la découpe

F Nombre de référence liée à la ligne en cours par le fenêtrage

G Nombre de référence liée à la ligne en cours par le gaufrage

H Nombre de référence liée à la ligne en cours par l'hologramme

L Nombre de référence liée à la ligne en cours par le foulage

O Nombre de référence liée à la ligne en cours par la dorure

R Nombre de référence liée à la ligne en cours par le rainage

T Nombre de référence liée à la ligne en cours par le transfert/poudrage

V Nombre de référence liée à la ligne en cours par la vignette

2 Présence de transfert/poudrage (par défaut), vignette, hologramme ou braille (selon caractère 2) - Voir tableau ci-dessous

Caractère 2 = V Présence de vignette

Caractère 2 = H Présence d'hologramme

Caractère 2 = B Présence de braille

[autre] : Présence de transfert/Poudrage (par défaut)

3 Dimension engagée totale (dimension engagée + écart entre poses défini sur la machine, zone paramétrable numérique 1)

4 Nombre de cahiers

5 Non utilisée, semble-t-il

6 Valeur de la zone numérique paramétrable 6 de la référence liée à la formule courante

Car.2 = P : Somme (zone numérique 6 x nombre de poses) de l'entité courante

Car.2 = S : Somme des valeurs des zones numériques paramétrables 6 de l'entité courante

7 Valeur de la zone numérique paramétrable 7 de la référence liée à la formule courante

Car.2 = P : Somme (zone numérique 7 x nombre de poses) de l'entité courante

Car.2 = S : Somme des valeurs des zones numériques paramétrables 7 de l'entité courante

8 Valeur de la zone numérique paramétrable 8 de la référence liée à la formule courante

Car.2 = P : Somme (zone numérique 8 x nombre de poses) de l'entité courante

Car.2 = S : Somme des valeurs des zones numériques paramétrables 8 de l'entité courante

9 Valeur de la zone numérique paramétrable 9 de la référence liée à la formule courante

Car.2 = P : Somme (zone numérique 9 x nombre de poses) de l'entité courante

Car.2 = S : Somme des valeurs des zones numériques paramétrables 9 de l'entité courante

0 Calcul du poids de la référence multiple associée à la formule en cours de calcul

Car.2 = S : Somme des poids des références multiples de l'entité en cours de calcul

Car.2 = T : Somme des poids des références multiples du sous-devis en cours de calcul
Le grammage utilisé est celui de l'entité en cours.

Caractère 4

A Somme des quantités clients

B Somme des quantités lancées

Caractère 7

Numéro de la référence sur laquelle récupérer les informations

1 Numéro de la première référence saisie sur l'entité en cours

C Numéro de la référence associée à la formule en cours si elle existe
sinon, numéro de la première référence saisie sur l'entité en cours

[autre] Numéro de la référence associée à la formule en cours (par défaut)

Détail pour caractère 1 = C

Caractères |  |  |  | Résultat alphanumérique
1 | 2 | 3 | 4
C |  |  |  | Code produit de la référence liée à la formule courante
C | 1 |  |  | Code produit de la première référence de l'entité courante
C | S | 1 |  | Code statistique 1 de la référence liée à la formule courante
C | S | 2 |  | Code statistique 2 de la référence liée à la formule courante
C | S | 3 |  | Code statistique 3 de la référence liée à la formule courante
C | S | 4 |  | Code statistique 4 de la référence liée à la formule courante
C | S | 1 | 1 | Code statistique 1 de la première référence de l'entité courante
C | S | 2 | 1 | Code statistique 2 de la première référence de l'entité courante
C | S | 3 | 1 | Code statistique 3 de la première référence de l'entité courante
C | S | 4 | 1 | Code statistique 4 de la première référence de l'entité courante

Détail pour les dorure, gaufrage, fenêtrage, foulage, rainage...

Caractères |  |  |  |  |  | Résultat alphanumérique
1 | 2 | 3 | 4 | 5 | 6
K |  |  |  |  | A/N | Présence de dorure
K |  | x | C/P |  |  | Nombre de références/poses ayant la valeur x dans la zone de présence de dorure
K |  | H | C/P | E/S |  | Nombre de références/poses avec de la dorure hors-ligne
K |  | L | C/P | E/S |  | Nombre de références/poses avec de la dorure en ligne
K |  | S | C/P | E/S |  | Nombre de références/poses avec de la dorure sous-traitée
K |  | N | C/P | E/S |  | Nombre de références/poses sans dorure
1 | 2 | 3 | 4 | 5 | 6 |
L |  |  |  |  | A/N | Présence de gaufrage
L |  | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de gaufrage
L |  | H | C/P | E/S |  | Nombre de références/poses avec du gaufrage hors-ligne
L |  | L | C/P | E/S |  | Nombre de références/poses avec du gaufrage en ligne
L |  | S | C/P | E/S |  | Nombre de références/poses avec du gaufrage sous-traité
L |  | N | C/P | E/S |  | Nombre de références/poses sans gaufrage
1 | 2 | 3 | 4 | 5 | 6 |
M |  |  |  |  | A/N | Présence de fenêtrage
M |  | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de fenêtrage
M |  | H | C/P | E/S |  | Nombre de références/poses avec du fenêtrage hors-ligne
M |  | L | C/P | E/S |  | Nombre de références/poses avec du fenêtrage en ligne
M |  | S | C/P | E/S |  | Nombre de références/poses avec du fenêtrage sous-traité
M |  | N | C/P | E/S |  | Nombre de références/poses sans fenêtrage
1 | 2 | 3 | 4 | 5 | 6 |
Y |  |  |  |  | A/N | Présence de foulage
Y |  | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de foulage
Y |  | H | C/P | E/S |  | Nombre de références/poses avec du foulage hors-ligne
Y |  | L | C/P | E/S |  | Nombre de références/poses avec du foulage en ligne
Y |  | S | C/P | E/S |  | Nombre de références/poses avec du foulage sous-traité
Y |  | N | C/P | E/S |  | Nombre de références/poses sans foulage
1 | 2 | 3 | 4 | 5 | 6 |
Z |  |  |  |  | A/N | Présence de rainage
Z |  | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de rainage
Z |  | H | C/P | E/S |  | Nombre de références/poses avec du rainage hors-ligne
Z |  | L | C/P | E/S |  | Nombre de références/poses avec du rainage en ligne
Z |  | S | C/P | E/S |  | Nombre de références/poses avec du rainage sous-traité
Z |  | N | C/P | E/S |  | Nombre de références/poses sans rainage
1 | 2 | 3 | 4 | 5 | 6 |
2 |  |  |  |  | A/N | Présence de transfert/poudrage
2 |  | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de transfert/poudrage
2 |  | H | C/P | E/S |  | Nombre de références/poses avec du transfert/poudrage hors-ligne
2 |  | L | C/P | E/S |  | Nombre de références/poses avec du transfert/poudrage en ligne
2 |  | S | C/P | E/S |  | Nombre de références/poses avec du transfert/poudrage sous-traité
2 |  | N | C/P | E/S |  | Nombre de références/poses sans transfert/poudrage
1 | 2 | 3 | 4 | 5 | 6 |
2 | V |  |  |  | A/N | Présence de vignette
2 | V | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de vignette
2 | V | H | C/P | E/S |  | Nombre de références/poses avec une vignette hors-ligne
2 | V | L | C/P | E/S |  | Nombre de références/poses avec une vignette en ligne
2 | V | S | C/P | E/S |  | Nombre de références/poses avec une vignette sous-traitée
2 | V | N | C/P | E/S |  | Nombre de références/poses sans vignette
1 | 2 | 3 | 4 | 5 | 6 |
2 | H |  |  |  | A/N | Présence d'hologramme
2 | H | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence d'hologramme
2 | H | H | C/P | E/S |  | Nombre de références/poses avec un hologramme hors-ligne
2 | H | L | C/P | E/S |  | Nombre de références/poses avec un hologramme en ligne
2 | H | S | C/P | E/S |  | Nombre de références/poses avec un hologramme sous-traité
2 | H | N | C/P | E/S |  | Nombre de références/poses sans hologramme
1 | 2 | 3 | 4 | 5 | 6 |
2 | B |  |  |  | A/N | Présence de braille
2 | B | x | C/P | E/S |  | Nombre de références/poses ayant la valeur x dans la zone de présence de braille
2 | B | H | C/P | E/S |  | Nombre de références/poses avec du braille hors-ligne
2 | B | L | C/P | E/S |  | Nombre de références/poses avec du braille en ligne
2 | B | S | C/P | E/S |  | Nombre de références/poses avec du braille sous-traité
2 | B | N | C/P | E/S |  | Nombre de références/poses sans braille

Permet de :

" Retourner le nombre de poses total des références avec une présence spécifique sur le sous-devis ou sur l'entité courante

" Retourner le nombre de références avec une présence spécifique sur le sous-devis

" Retourner une valeur numérique pour une présence spécifique (N=0, L=1, H=2 et S=3)

Caractère 4 = C ou [blanc] : Nombre de références

Caractère 4 = P : Nombre de poses

Caractère 5 = E ou [blanc] : Nombre de références/poses sur l'entité courante

Caractère 5 = S : Nombre de références/poses sur le sous-devis courant

Caractère 6 = A ou [blanc] : retour alphanumérique (Hors-ligne/en Ligne/Sous-traitée/Non)

Caractère 6 = N : retour numérique (1=en Ligne/2=Hors-ligne/3=Sous-traitée/0=Non)

RH Cumul des valeurs d'une entité

Cette formule ne peut pas utiliser le coefficient multiplicateur (bien que les caractères 5 et 6 ne soient pas utilisés...).

Retour numérique

Les zones à cumuler doivent être dans la même unité !

Ce code permet de cumuler les valeurs stockées sur une entité.

Caractère 1 | 1 On cumule les valeurs numériques 1 2 On cumule les valeurs numériques 2 3 On cumule les quantités hors gâche 4 On cumule les quantités toutes gâches 5 On cumule les temps totaux 8 On cumule les temps de réglage 9 On cumule les cadences standards A On cumule les gâches fixes B On cumule les valeurs calculées 3 (v3) C On cumule les montants totaux D On cumule les valeurs calculées 4 (v4) E On cumule les valeurs calculées 5 (v5) F On cumule les valeurs calculées 6 (v6) G On cumule les valeurs calculées 7 (v7) H On cumule les quantités hors gâches (gâches cumulatives) I On cumule les valeurs calculées 8 (v8) J On cumule les valeurs calculées 9 (v9) K On cumule les valeurs calculées 10 (v10) T On cumule les quantités toute gâches (gâches cumulatives) U On cumule les quantités hors gâche fixe (gâches cumulatives) V On cumule les quantités toutes gâches - les quantités hors gâche fixe (gâches cumulatives)
Caractères 2 à 4 | Code opération, pour limiter le calcul à une opération
Caractères 5 à 7 | Code formule, pour limiter le calcul à une formule

RM - Recherche données matières

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Ce mode permet d'aller rechercher une valeur stockée dans une des matières.

Caractères 1 à 3 | Code phase. Attention : on sélectionne la première ! On teste si l'on est sur la phase courante. Si oui, on recherche dans le tableau enr[mat] les valeurs, sinon on recherche sur fle_mat.
Caractères 4 à 6 | Code formule
Caractère 7 | 1 On récupère la valeur numérique 1 2 On récupère la valeur numérique 2 3 On récupère la quantité hors gâche 4 On récupère la quantité toutes gâches 5 On récupère la gâche fixe 6 On récupère la gâche variable 7 On récupère le coût total 8 On récupère le coût unitaire 9 On récupère le montant des frais A On récupère le code matière B On récupère la longueur (fm_longueur) C On récupère la largeur (fm_largeur) D On récupère la hauteur (fm_hauteur) E On récupère le poids (fm_poids) F On récupère la valeur calculée 3 (v3) G On récupère la valeur calculée 4 (v4) H On récupère la valeur calculée 5 (v5) I On récupère la valeur calculée 6 (v6) J On récupère la valeur calculée 7 (v7) K On récupère la valeur calculée 8 (v8) L On récupère la valeur calculée 9 (v9) M On récupère la valeur calculée 10 (v10) X On récupère le code fournisseur

RS - Recherche données sous-traitance

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Ce mode permet d'aller rechercher une valeur stockée sur une des matières.

Caractères 1 à 3

Code phase. Seule la première phase trouvée est prise en compte.

Si la phase paramétrée est la phase courante, la recherche se fait dans le tableau de saisie courant, sinon la recherche se fait dans la table fle_str.

Caractères 4 à 6

Code formule

Caractère 7

1 On récupère la quantité

2 On récupère le prix de revient fixe

3 On récupère la marge fixe

4 On récupère le prix de vente fixe

5 On récupère le total fixe

6 On récupère le prix de revient variable

7 On récupère la marge variable

8 On récupère le prix de vente variable

9 On récupère le total variable

A On récupère le coût total

B On récupère les frais

C On récupère la valeur numérique 1 (fs_num_1)

D On récupère la valeur numérique 2 (fs_num_2)

E On récupère la valeur numérique 3 (fs_num_3)

F On récupère la valeur numérique 4 (fs_num_4)

H On récupère la quantité hors gâches de sous-traitance (gâches cumulatives)

I On récupère les frais fixes

J On récupère les frais variables

T On récupère la quantité toute gâches de sous-traitance (gâches cumulatives)

U On récupère la quantité hors gâche fixe de sous-traitance (gâches cumulatives)

V On récupère la quantité toute gâches - la quantité hors gâche fixe de sous-traitance

(gâches cumulatives)

X On récupère le code fournisseur

Y Zone alphanumérique de 30 caractères (ic_char30) rattachée au fournisseur

On va chercher la machine sur la zone alphanumérique de 30 caractères du TSC fournisseur avec code TSC = zone mp_libre du produit de sous-traitance.

Si la zone mp_libre n'est pas renseignée ou si le TSC est inexistant, on va chercher la machine sur la zone alphanumérique de 30 caractères du TSC fournisseur avec code TSC = code phase (par défaut).

Z Zone alphanumérique de 3 caractères n°1 (ic_char3_1) rattachée au fournisseur

On va chercher la zone ic_char3_1 du TSC fournisseur avec code TSC = zone mp_libre du produit de sous-traitance.

Si la zone mp_libre n'est pas renseignée ou si le TSC est inexistant, on va chercher la zone ic_char3_1 du TSC fournisseur avec code TSC = code phase (par défaut).

RT - Données matières pour la formule de transport paramétrable

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Ce mode permet d'aller rechercher une valeur stockée une des matières.

Caractères 1 à 3 | Code phase. Attention : on sélectionne la première ! On recherche sur fle_mat
Caractères 4 à 6 | Code formule
Caractère 7 | 1 On récupère la valeur numérique 1 2 On récupère la valeur numérique 2 3 On récupère la quantité hors gâche 4 On récupère la quantité toutes gâches 5 On récupère la gâche fixe 6 On récupère la gâche variable 7 On récupère le coût total B On récupère la longueur (fm_longueur) C On récupère la largeur (fm_largeur) D On récupère la hauteur (fm_hauteur) E On récupère la le poids (fm_poids) F On récupère la valeur calculée 3 (v3) G On récupère la valeur calculée 4 (v4) H On récupère la valeur calculée 5 (v5) I On récupère la valeur calculée 6 (v6) J On récupère la valeur calculée 7 (v7) K On récupère la valeur calculée 8 (v8) L On récupère la valeur calculée 9 (v9) M On récupère la valeur calculée 10 (v10)

RV - Recherche données sur phase courante

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour numérique

Ce mode permet d'aller rechercher une valeur stockée sur une des opérations de la phase courante.

Caractères 1 à 3

Code sous-opération

Caractères 4 à 6

Code formule

Si non renseigné, on sélectionne sur le code sous-opération uniquement (le premier trouvé).

Caractère 7

1 On récupère la valeur numérique 1

2 On récupère la valeur numérique 2

3 On récupère la quantité hors gâche

4 On récupère la quantité toutes gâches

5 On récupère le temps total

6 On récupère le code plaque de la machine d'impression

7 On récupère le code plaque vernis de la machine d'impression

8 On récupère le temps réglage

9 On récupère la cadence standard

A On récupère la gâche fixe

B On récupère la gâche variable

C On récupère le montant total

c On récupère le coût horaire de l'opération (fle_ope.fo_ch)

D On récupère la valeur numérique 1 (fs_num_1)

E On récupère la valeur numérique 2 (fs_num_2)

F On récupère la valeur numérique 3 (fs_num_3)

G On récupère la valeur numérique 4 (fs_num_4)

H On récupère la quantité hors gâches de l'opération (gâches cumulatives)

I Numéro de référence
Par défaut, le numéro de référence est celui de la formule où le code calcul est paramétré (on va chercher la phase/formule pour la même référence).

J On récupère la valeur calculée 3 (v3)

K On récupère la valeur calculée 4 (v4)

L On récupère la valeur calculée 5 (v5)

M On récupère le code machine

m Retourne 100 si le site de la machine de l'opération (mac0.m0_sit_prod) est égal au site de l'entité courante (fle_imp.fi_sit), 0 sinon.

N On récupère la valeur calculée 6 (v6)

O On récupère la valeur calculée 7 (v7)

P On récupère les frais des opérations

Q On récupère la valeur calculée 8 (v8)

R On récupère la valeur calculée 9 (v9)

S On récupère la valeur calculée 10 (v10)

T On récupère la quantité toute gâches de l'opération (gâches cumulatives)

U On récupère la quantité hors gâche fixe de l'opération (gâches cumulatives)

V On récupère la quantité toutes gâches - la quantité hors gâche fixe de l'opération
(gâches cumulatives)

X On récupère la clé tarifaire de l'opération élémentaire (ss_cletarifaire) liée à l'opération

Z On récupère le code machine correspondant au code paramètre ADM alpha1[1,6]
Le code du paramètre est pris dans fo_tpsstd.

ST - Stockage

Retour numérique

Caractère 1

1 Nombre de jours de stockage unitaire/100.

La valeur 1 doit contenir le nombre de livraisons.

La valeur 2 doit contenir le nombre maximum de jour de stockage.

SU - Surfaces

Retour numérique

Caractères 1 et 2

(cadrés à gauche)

1 Surface plaque brute en cm2

2 Surface imprimée unitaire en cm2

3 Surface refente brute en cm2

4 Surface de la boîte à plat en cm2

5 Surface totale nette en m2 (carton ondulé)

6 Surface totale brute en m2

7 Surface format rogne en cm2

8 Surface format rogne en m2

9 Surface format rogne en m2 * valeur 1

10 Surface format rogne en m2 * valeur 2

11 Surface totale brute en m2 gâche comprise

12 Surface totale imprimée en cm2 gâche comprise

Si car 7 = [blanc] : fi_qteent / (fi_nbp_larp_hauc * fi_nbp_haup_larc)

Sinon : fi_qteent * (fi_nbp_larp_hauc * fi_nbp_haup_larc)

13 Surface format rogné (en m²) * valeur calculée 3 (v3)

14 Surface format rogné (en m²) * valeur calculée 4 (v4)

15 Surface format rogné (en m²) * valeur calculée 5 (v5)

16 Surface format rogné (en m²) * valeur calculée 6 (v6)

17 Surface format rogné (en m²) * valeur calculée 7 (v7)

18 Surface format rogné (en m²) * valeur calculée 8 (v8)

19 Surface format rogné (en m²) * valeur calculée 9 (v9)

20 Surface format rogné (en m²) * valeur calculée 10 (v10)

Caractère 7

ATTENTION, 2 UTILISATIONS DIFFERENTES !

1) M On multiplie par le nombre de morceaux ECMA.

2) Utilisation particulière pour le caractère 12.

TA - Infos provenant des tarifs

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour alphanumérique

Il est impératif au niveau de la formule de placer les codes articles avant de faire la recherche des tarifs sur ces codes.

Pour une recherche en tarif , il est nécessaire de définir : un code article, une quantité, une configuration de recherche

Caractère 1

Origine du code article

a On récupère les caractères 03 à 09 de la zone ul_parv2.

b On récupère les caractères 12 à 18 de la zone ul_parv2.

c On récupère les caractères 21 à 27 de la zone ul_parv2.

d On récupère les caractères 30 à 36 de la zone ul_parv2.

e On récupère les caractères 39 à 45 de la zone ul_parv2.

f On récupère les caractères 48 à 54 de la zone ul_parv2.

g On récupère les caractères 57 à 63 de la zone ul_parv2.

h On récupère les caractères 66 à 72 de la zone ul_parv2.

i On récupère les caractères 75 à 81 de la zone ul_parv2.

j On récupère les caractères 84 à 90 de la zone ul_parv2.

m Code produit pris en compte pour la recherche de tarif

Si la formule en cours de calcul est une formule matière :

Code produit contenu dans la formule matière courante (fle_mat.fm_matiere)

Si la formule en cours de calcul est une formule sous-traitance :

Code produit contenu dans la formule sous-traitance courante (fle_str.fs_codeprod)

Remarque : Le code tiers pris en compte variera également selon le type de formule calculée.

Voir zone paramétré n°3 de la formule (ul_param) :

Si la formule en cours de calcul est une formule matière :

Code fournisseur contenu dans la formule matière courante (fle_mat.fm_fournisseur)

Si la formule en cours de calcul est une formule sous-traitance :

Code fournisseur contenu dans la formule sous-traitance courante (fle_str.fs_fournisseur)

Caractère 2

Quantité prise en compte :

Dans quelle zone récupère-t-on la valeur calculée ?

Indiquez une lettre comprise entre a et j.

Caractères 3 à 5

Code du paramètre de configuration de recherche des tarifs sur lequel on va récupérer les codes calculs dépendances en alpha1[30,39].

Voir aussi ul_param[3]

TB - Type de boîte et dimensions ECMA

Caractère 1

T Type de code ECMA

M Nombre de morceaux

P Code alpha1[8,10] sur code type ECMA

Si caractère 2 = 1 Code défini position 8 à 10

Si caractère 2 = 2 Code défini position 11 à 13

Si caractère 2 = 3 Valeur numérique 1 du code ECMA

Si caractère 2 = 4 Valeur numérique 2 du code ECMA

D Dimensions (cf. caractère 2)

Si caractère 2 = 1 Valeur de rp1

Si caractère 2 = 2 Valeur de rp2

Si caractère 2 = 3 Valeur de pp1

Si caractère 2 = 4 Valeur de pp2

Si caractère 2 = 5 Valeur de pp3

Si caractère 2 = 6 Valeur de pp4

Si caractère 2 = 7 Valeur de pc

Si caractère 2 = 8 Valeur de pp5

Si caractère 2 = 9 Valeur de pp6

Si caractère 2 = O Ouverture (laize)-ST - Largeur étui

Si caractère 2 = P Poussée (coupe)-SM - Développé étui

TC - TSC

Cette formule ne peut pas utiliser le coefficient multiplicateur.

Retour alphanumérique

Cette dépendance n'est valable que pour les opérations.

Caractère 1 (clé du TSC)

1 Client du devis

2 Produit devis

3 Produit entité

4 Papier entité

5 Machine impression 1

6 Machine impression 2

7 Machine de l'opération

8 Matière de la formule

9 Info. sous-devis

A Info. entité

B ECMA - FEFCO entité

C Recherche machine sur les LCO de la formule

D Matière saisie en sous-traitance

E Recherche matière sur les LCO de la formule

F Gamme standard sélectionnée

G Ligne de commande - réservé pour les commandes en mode barème.

H Fournisseur sur formule sous-traitance en cours

I Ligne de référence multiple liée à la matière, opération ou sous-traitance courante

J Ce code calcul permet d'aller recherche une valeur sur un TSC d'une matière dont le code est stocké sur un TSC d'une référence.
La clé est la valeur du TSC dont le code se trouve sur la note VAR_J de la formule (table formules2). Cliquez ici pour afficher / masquer l'exemple.

Fournisseur sur formule sous-traitance en cours

L Ligne de référence multiple liée à la matière, opération ou la sous-traitance de l'opération courante. Ligne de référence saisie sur le sous-devis avec les TSC saisie sur le sous-devis. Sinon c'est les TSC des références de l'entité.

M Machine de pliage du premier pli (fle_dec.de_machine)
Pour récupérer comme origine du TSC le code machine de pliage du premier pli défini sur la décomposition saisie sur l'entité.

N Machine de vernissage hors ligne recto (fle_combi/fco_mac_ve_recto)
Pour récupérer comme origine du TSC le code machine de vernissage hors-ligne recto saisi sur l'entité.

O Machine de vernissage hors ligne verso (fle_combi/fco_mac_ve_verso)
Pour récupérer comme origine du TSC le code machine de vernissage hors-ligne verso saisi sur l'entité.

P La clé est le numéro de forme de découpe de l'entité (fle_imp.fi_num_forme)

Q Machine d'impression multiple (fle_combi/fco_mac_imp, fco_type = 3)

Caractère 7 : Numéro de passage d'impression (1 à 9)

R Code qualité matière associé au papier de l'entité (mat.mp_qualite_matiere)

S Ligne d'impression multiple

Caractères 2 à 4

Code du TSC

pa1 Le code TSC correspond à la zone paramétrable alphanumérique 1 de l'entête du devis (fle_2.l2_zpar1)

pa2 Le code TSC correspond à la zone paramétrable alphanumérique 2 de l'entête du devis (fle_2.l2_zpar2)

Caractère 5

Code de la zone de stockage

C Numérique 1

D Numérique 2

E Numérique 3

F Char3 1

G Char30

H Char3 2

Caractère 6

Autres rubriques

1 Valeur numérique 1 de F ou H (F et G dans ce cas existent comme paramètres)

2 Valeur numérique 2 de F ou H (F et G dans ce cas existent comme paramètres)

3 A1[1,15] (F, G, H)

4 A2[1,15] (F, G, H)

5 A3[1,15] (F, G, H)

N Renvoie 0 si la valeur n'est pas saisie dans la zone du TSC
Renvoie 1 si la valeur est saisie dans la zone du TSC
Remarque : La valeur 0 (zéro) sur une zone numérique est considérée comme une valeur saisie.
La valeur [blanc] sur une zone alphanumérique n'est pas considérée comme une valeur saisie.

F Code famille de l'article associé à la zone G du TSC (mat.mp_fam)

S Code sous-famille de l'article associé à la zone G du TSC (mat.mp_sfm)

L Longueur de l'article associé à la zone G du TSC (mat.mp_lon)

l (petit L) Largeur de l'article associé à la zone G du TSC (mat.mp_lar)

H Hauteur de l'article associé à la zone G du TSC (mat.mp_hau)

P Poids de l'article associé à la zone G du TSC (mat.mp_poids)

Caractère 7

Si caractère 1 = Q ou S : Numéro de passage d'impression (1 à 9) (par défaut : 1)

Si caractère 1 = I et caractère 7 = P : Si la matière/opération/sous-traitance courante n'est pas liée à une ligne de référence multiple, prendre la première ligne de référence multiple de l'entité en cours.

TI - Transport inter-sites

But : Permettre de gérer le transport inter-sites dans le devis multi-métiers en utilisant la génération automatique de transport interne.

Tableau de bord du multisite

Paramétrage associé :

SIT A4[25,30]

Note CODE_LCO_SITES sur la formule

Code calcul TP, caractère 1 = A

Code calcul OC, caractère 7 = M, N ou O

Formules OMAD50 et OMAD51

Caractère 1

M Retourne un code massicot selon les règles suivantes :

  • Si ligne de pliage existante dans la décomposition : Code massicot associé à la première plieuse trouvée

  • Si aucune ligne de pliage : Code massicot associé au site de l'entité de façonnage globale

  • Si aucune ligne de pliage et aucune entité de façonnage globale : Code massicot associé au site de la machine d'impression recto

TP - Infos diverses devis (type de processus)

Retour alphanumérique

Caractère 1

1 Type d'entité (processus pour devis_dco)

2 TPR alpha1[12,14] du type d'entité (sur fi_typ_ent)

3 Type de devis

4 Marge sur devis

5 BAT

Si caractère 2 = N : S retourne 2, O retourne 1, N retourne 0

Si caractère 2 = A : Renvoie la valeur saisie (N/O/S)

Si caractère 2 = [autres valeurs] : S retourne 1, les autres valeurs retournent 0.

6 Concerne la zone paramétrée (fi_zpar)

Si caractère 2 = 1 Valeur de la zone paramétrée

Si caractère 2 = 2

Recherche du type de paramètre de la zone paramétrée dans TEN fi_typ_ent alpha1[3,5].

Puis récupération de la valeur numérique 1 du code de la zone paramétrée.

Si caractère 2 = 3

Recherche du type de paramètre de la zone paramétrée dans TEN fi_typ_ent alpha1[3,5].

Puis récupération de la valeur numérique 2 du code de la zone paramétrée.

7 Nombre de voyages (l2_nb_liv)

8 Origine du carton

retour : 0 Stock interne

retour : 1 A commander

retour : 2 Fabrication

retour : 3 Fabristock

retour : 4 Externe

9 Prix carton (papier) bloqué

retour : 0 NON

retour : 1 OUI

A Site de production - Tableau de bord du multisite

Caractère 2

[blanc] Retour = Site de production saisi sur l'entête du sous-devis (par défaut)

1 Retour = valeur numérique 1 du paramètre SIT

2 Retour = valeur numérique 2 du paramètre SIT

C Retour = Code du site de production indiqué.

E Retour = Site de production saisi sur l'entité

G Retour = Site de production associé à la gamme s'il existe (celui du sous-devis sinon)

L Lieu de rangement 1 associé au site de production (SIT A1[10,12])

Caractère 3

[blanc] : Site de production saisi sur l'entête du sous-devis (par défaut)

E Site de production saisi sur l'entité

G Site de production associé à la gamme s'il existe (celui du sous-devis sinon)

B Informations sur le type de processus

Car.2=C : Récupération du type de processus

Car.2=[Autre] : Récupération de la caractéristique du processus (TPR alpha1[12,14])

C fi_per_contour Périmètre de contour

D fi_num_ordo Numéro d'ordonnancement

E fi_ft_impo Format papier imposé ?

Si caractère 2 = N : S retourne 2, O retourne 1, N retourne 0

Si caractère 2 = A : Renvoie la valeur saisie (N/O/S)

Si caractère 2 = [autres valeurs] : S retourne 1, les autres valeurs retournent 0.

F Nombre de fabrications

G Durée du contrat (en jours)

H Devis correspondant à une commande de marché

Si caractère 2 = A : retourne O ou N

SI caractère 2 = N : retourne 1 ou 0

I Nombre de livraison

J Durée de paiement de la fiche client (ECH, valeur numérique 1)

K Renvoi d'une zone paramétrée numérique

Si caractère 2 = 1 renvoie la valeur de la zone paramétrée numérique 1

Si caractère 2 = 2 renvoie la valeur de la zone paramétrée numérique 2

Si caractère 2 = 3 renvoie la valeur de la zone paramétrée numérique 3

L Zone paramétrée alphanumérique

Car.2 = 1 : Valeur de la zone paramétrée alphanumérique1

Car.3 = 1 : Zone numérique 1 du paramètre correspondant à la zone paramétrable alphanumérique 1 du devis

Car.3 = 2 : Zone numérique 2 du paramètre correspondant à la zone paramétrable alphanumérique 1 du devis

Car.3 = [autre] : Valeur de la zone paramétrable alphanumérique 1 (par défaut)

Car.2 = 2 : Valeur de la zone paramétrée alphanumérique2

Car.3 = 1 : Zone numérique 1 du paramètre correspondant à la zone paramétrable alphanumérique 2 du devis (l2_zpar1)

Car.3 = 2 : Zone numérique 2 du paramètre correspondant à la zone paramétrable alphanumérique 2 du devis (l2_zpar2)

Car.3 = [autre] : Valeur de la zone paramétrable alphanumérique 1 (par défaut)

P Sous-devis courant intégré au chiffre d'affaire prévisionnel

Si caractère 2 = A : Renvoie O/N

Si caractère 2 = N : Renvoie 1/0 (1=O, 0=N)

R Sous-devis courant faisant l'objet d'un renouvellement ou d'un retirage

Si caractère 2 = A : Renvoie O/N

Si caractère 2 = N : Renvoie 1/0 (1=O, 0=N)

S Unité de remise de prix en numérique

T Gestion des trains de cadencements de fabrication

Si caractère 2 = N : le résultat est numérique (0 si l2_gestion_train = N ou 1 si l2_gestion_train = O)

Si caractère 2 = A : retourne O ou N

TS - Temps

Retour numérique

Actif seulement pour les opérations

Pour une phase donnée

Caractère 1

1 Temps de l'opération précédente (sur la même phase)

Car.2 = N : Temps de la première opération précédente trouvée où le temps est renseigné (la valeur peut être zéro)

Car.2 = 0 (zéro) : Temps de la première opération précédente trouvée où le temps est renseigné et différent de zéro

Remarque : On ramène 0 (zéro) si aucun temps n'est trouvé.

2 Temps des opérations précédentes (sur la même phase)

TT - Temps total des opérations

Retour numérique

Caractère 1

1 Temps total des opérations (sauf opérations de la phase courante)

2 Temps total des opérations (sur opérations de la phase courante) (pour les matières)

3 Temps total de l'opération précédente (sur la même phase)

Car.2=N : Temps de la première opération précédente trouvée où le temps est renseigné (la valeur peut être zéro)

Car.2=0 (zéro) : Temps de la première opération précédente trouvée où le temps est renseigné et différent de zéro

Remarque : On ramène 0 (zéro) si aucun temps n'est trouvé.

4 Temps totaux des opérations précédentes (sur la même phase)

VA - Valeur alphanumérique

Le coefficient multiplicateur doit être désactivé : #CF DEG alpha4[28] = O.

Retour alphanumérique

Caractère 1

1 Valeur alphanumérique 1

2 Valeur alphanumérique 2

3 fi_zpar Zone paramétrée TEN donne le type de la zone paramétrée en alpha1[3,5]

4 fi_zpar2 - Zone paramétrée 2 CND - Devis étiquette : Type Fac

5 fi_zpar3 - Zone paramétrée 3 ENR - Devis étiquette : Sens Enr

6 fi_sit - Site de production SIT - Tableau de bord du multisite

7 fi_type_vernis_r - Type de vernis recto VER

8 fi_type_vernis_v - Type de vernis verso VER

9 fi_type_pellic - Type de pelliculage PEL

A fi_vernis_hl - Code de vernis hors ligne VER

B Zone alphanumérique courante - vérification par comparaison de valeurs de zones, paramétrées depuis des formule

Voir le paragraphe concerné dans le devis standard.

C Zone numérique courante - vérification par comparaison de valeurs de zones, paramétrées depuis des formule

Voir le paragraphe concerné dans le devis standard.

D Type du premier pli saisi dans la décomposition (ligne 1 de fle_dec)

E Type de finition (l2_type_finition)

F fco_type_vernis_r Code de vernis recto hors-ligne (VER) (fle_combi)

G fco_type_vernis_v Code de vernis verso hors-ligne (VER) (fle_combi)

H Type de vernis sous-traitance recto (VER)

I Type de vernis sous-traitance verso (VER)

J Environnement opération (fle_2.l2_env_operation)

K Environnement matière (fle_2.l2_env_matiere)

L Code de difficulté de calage associé au code ECMA de l'entité courante

M Code de difficulté de roulage associé au code ECMA de l'entité courante

N Code de difficulté de calage associé au code ECMA de la ligne de référence associée à la formule courante

O Code de difficulté de roulage associé au code ECMA de la ligne de référence associée à la formule courante)

P Code deviseur (fle_2.l2_deviseur, paramètre de type VED)

Q Code signataire (fle_2.l2_signature, paramètre de type SIG)

R Code utilisateur VoluPack courant (paramètre de type USE)

S Site de production de l'entête du devis (fle_2.l2_site) - Tableau de bord du multisite

T Code de suivi d'affaire (fle_2.l2_suiv, paramètre de type FAB)

X Constante saisie sur les caractères 2 à 7. Valeur alphanumérique

Y Constante saisie sur les caractères 2 à 7. Valeur numérique

Z Type de processus du sous-devis courant (TPR, fle_2.l2_type_prod)

@ Type de l'entité courante (TEN, fle_imp.fi_typ_ent)

Caractère 2

Zone du paramètre associé à prendre en compte

1 Valeur numérique 1

2 Valeur numérique 2

3 Valeur numérique 3

4 Valeur numérique 4

A Valeur alpha 1

B Valeur alpha 2

C Valeur alpha 3

D Valeur alpha 4

Caractères 3,4

Caractères de début des zones alpha (si car.2 = A, B, C ou D)

Caractères 5,6

Caractères de fin des zones alpha (si car.2 = A, B, C ou D)

VT - Variables de Traitements

Caractère 1

1 Le pli principal de l'entité courante est-il réalisé sur une plieuse (O/N, 1/0) ?

Dans le cas d'une entité de type couverture (a), on va vérifier le type de pliage/façonnage utilisé pour le pli couverture (b).

Dans tous les autres cas, le pli est obligatoirement réalisé sur une plieuse.

Rappels :

(a) TEN A1[31,33] = COU

(b) PLI A1[16] (devis de type BSC/BCO)

PLI A1[50] (devis de type PIQ)

Le pli est réalisé sur une plieuse si ce caractère est égal à P.

Car.3=M : Le pli est-il réalisé sur un margeur de couverture ? (O/N, 1/0) (voir car.2)

Car.3=[Autre] : Le pli est-il réalisé sur une plieuse ? (O/N, 1/0) (voir car.2)

2 L'entité courante nécessite-elle une refente avant pelliculage ou refente avec vernis de sous-traitance ?

Présence de pelliculage 1 face avec bascule in8/in12

Présence de vernis sous-traitance 1 face avec bascule in8/in12

3 Présence de machine roto ou superposée avec bascule ? (O/N, 1/0)

4 Présence de bascule OU machine roto OU superposée avec bascule ? (O/N, 1/0)

5 Présence du code phase paramétré sur le devis courant (O/N, 1/0)

6 Présence du code phase paramétré sur l'entité courante (O/N, 1/0)

7 Présence de dossier de fabrication (O/N, 1/0)2

8 Les machines d'impression recto et verso sont-elles identiques ?

D Le calcul se fait sur le devis standard

E Nature de difficulté selon le type d'encre

Car.3=R : Type d'encre recto (par défaut)

Car.3=V : Type d'encre verso

L Présence d'une valeur saisie sur une LCO

Car.2 : A ou N, voir plus bas dans le tableau

Car.3 à 5 : Code LCO

Car.6 : Zone LCO

Car.7 : Signification du 0 (zéro)

O Le zéro est une valeur significative (Valeur saisie = 0, renvoie O/1)

N Le zéro n'est pas une valeur significative (Valeur saisie = 0, renvoie N/0) (par défaut)

P Nature de difficulté selon le type de papier

V Nature de difficulté selon le type de vernis

Car.3=R : Type de vernis recto (par défaut)

Car.3=V : Type de vernis verso

Car.4=L : Vernis en ligne (par défaut)

Car.4=H : Vernis hors ligne

Car.4=S : Vernis de sous-traitance

Caractère 2

Type de retour pour les variables booléennes (si car.1 = 1, 2, 3, 4, 5, 6, 7, L)

A Alphanumérique (O/N)

N Numérique (1/0) (par défaut)

Caractères 3 à 5

Si caractère 1 = 5, 6 : Code phase à rechercher dans le devis et/ou l'entité

Si caractère 1 = L, code LCO

Caractère 6

Si caractère 1 = L, zone LCO

Caractère 7

Si caractère 1 = L :

Signification du zéro :

O Le zéro est une valeur significative (valeur saisie = 0 : renvoie O/1).

N Le zéro n'est pas une valeur significative (valeur saisie = 0 : renvoie N/0) (par défaut).


M####AM Formule standard (somme des temps de la phase)

Calcul d'amortissement

Quantité = Somme des temps de la phase courante

Prix de revient = taux horaire paramétré sur la machine dans les infos complémentaires

Formulation

Caractères 1 à 3

Code TSC à utiliser pour rechercher le taux horaire d'amortissement.

Le taux sera saisi dans la valeur numérique 1 du TSC (ic_num1)

Le TSC sera attaché à la machine.


M####AU Formule paramétrable (recherche matière)

La quatrième dépendance alphanumérique permet de rechercher automatiquement le code matière.


M####C1 Formule standard (nombre d'exemplaires par paquet)

Quantité = Quantité devisée (entité) / valeur 1 (saisie)

Possibilité de définir un arrondi à appliquer sur la quantité du résultat.

On peut définir la précision de l'arrondi.

Si la zone paramétrage est vide, aucun arrondi n'est appliqué.

Paramétrage

Caractère 1 | S arrondi supérieur I arrondi inférieur
Caractères 2 à 15 | précision de l'arrondi
Caractères 16 à 18 | Paramétrage de la zone valeur 2 POI : Valeur 2 = poids devise / quantité devisée * valeur 1

Quantité | Inf/Sup | Précision | Résultat
1.273 | I | 0.01 | 1.27
1.273 | S | 0.01 | 1.28
1.273 | I | 0.1 | 1.2
1.273 | S | 0.1 | 1.3
-1.273 | I | 0.1 | -1.3
-1.273 | S | 0.1 | -1.2
13.125892 | I | 0.00001 | 13.12589
1548.25 | I | 1 | 1548
1548.25 | S | 1 | 1549
1548.25 | I | 10 | 1540
1548.25 | S | 10 | 1550
1525954 | I | 10000 | 1520000
1525954 | S | 10000 | 1530000

Exemples d'utilisation

Nombre d'exemplaires par caisse, palette, paquet, ...

valeur 1 saisie par l'utilisateur = nombre d'exemplaire par colis

valeur 2 calculée automatiquement = poids théorique du colis


M####C2 Formule standard (calcul poids)

Quantité = Valeur 1 * format tirage * grammage (---> Poids)

Phase CTR (Contre Collage recto) | Format + 10 mm
Phase CTV (Contre Collage verso) | Format + 5 mm

Paramétrage

Caractère 1

O Nouveau mode de calcul : le nombre de feuilles est égal à : p_fi.fi_feu_pap + valeur 2 (gâche)

sinon c'est l'ancien mode de calcul : le nombre de feuilles est présent dans la valeur 1.

Remarque : si la valeur 2 est vide, c'est que l'on doit être dans l'ancien mode.


M####C3 Formule standard

Quantité = Valeur 1 * Valeur 2 * grammage du papier saisi sur la ligne.


M####C4 Formule standard

Quantité = Valeur 1 X Valeur 2 X Quantité entité

Paramétrage

Caractère 1 | 1 quantité = V1 2 quantité = V2 [blanc] quantité = V1 X V2 X quantité = 1
Caractère 2 | 1 la valeur précédente est multipliée par la quantité de l'entité hors gâche. 2 la valeur précédente est multipliée par la quantité de l'entité gâche comprise. 3 la valeur précédente est la quantité hors gâche. 4 la valeur précédente est la quantité gâche comprise.


M####E1 Calcul particulier du coût encre

Utilisation d'un tarif aux 100 M2 en fonction du nombre de couleurs (ROL).

Cette formule s'appuie sur la même logique de paramétrage que ### #AU.

Les particularités sont les suivantes :

Le coût de la matière est recherché sur le fichier tarif.

Le code matière est défini sur une LCO (paramétrage a de V2).

Le nombre de couleurs est défini sur une LCO (paramétrage a de V1).

Ce nombre de couleurs est utilisé dans la recherche du tarif. (Représente la quantité dans le tarif).

Les autres données de V1 (b,c,e,f,g,h,i,j) sont libres.

La quantité est déterminée par la formulation de V1.

Exemple :

Valeur 1 | a | CN | 3011
 | b | CN | 3012
 | c | CN | 3013
 | d | QT | 3
Valeur 2 | a | CA | LC06

Quantité d'encre | ( d / nb de poses) * ( b / 100) * ( longueur impression) * ( largeur impression) / 100 000 000
Traduction | a b / c 100 / * e * f * 100000000 /


M####QH Formule standard

M####QH Calcul matière (Forfait quantité hors gâche)

Cette formule peut être saisie sur n'importe quelle phase.

Elle évite l'utilisation de la touche F8 lorsqu'on désire saisir une quantité de matière.

Celle-ci doit alors être saisie sur le tableau des phases dans la colonne matière qui est alors affichée en vert.

Le code matière doit être saisi manuellement sur l'écran détail dans le cas ou il n'est pas alimenté automatiquement.

La quantité hors gâche de matière doit être saisie sur l'écran détail de la phase.

Attention, il s'agit de la quantité HORS GACHES.

Les gâches saisies au niveau du fichier matière sont ajoutées à la quantité saisie.

Exemple d'utilisation :

Conception de maquette : il n'y a pas de calcul automatique possible.

On peut se contenter d'indiquer le nombre de maquettes à réaliser.

Le coût unitaire de celle-ci étant donné par le fichier matière / produit.


M####QT Formule standard

M####QT Calcul matière (Forfait quantité gâche incluse)

Cette formule peut être saisie sur n'importe quelle phase.

Elle évite l'utilisation de la touche F8 lorsqu'on désire saisir une quantité de matière.

Celle-ci doit alors être saisie sur le tableau des phases dans la colonne matière qui est alors affichée en vert.

Le code matière doit être saisi manuellement sur l'écran détail, dans le cas où il n'est pas alimenté automatiquement.

La quantité toute gâche de matière doit être saisie sur le tableau des phases. Il s'agit de la quantité TOTALE.

Les gâches attachées à la matière ne pas sont pas prises en compte.

PARTICULARITE de TRAITEMENT

Lorsqu'on utilise la notion de formule à utiliser, on duplique la formule pour faire apparaître une formule standard (contrainte informatique).

Exemple :

AID -#04 : On précise que cette formule utilise la ### #04. On crée la ### #04.


M####S1 Formule standard concernant des surfaces

Paramétrage

Caractère 1 | 1 La quantité est la surface de tirage en M2 (par défaut). 2 La quantité est la surface de tirage en M2 x Quantité de l'entité. 3 La quantité est la surface de tirage en M2 x Nombre de tournées. Ce paramétrage, avec celui du caractère 2, permet d'établir le coût de matière pour l'OPTI-COPY (Epreuves).
Caractère 2 | Valeur de 0 à 9 (0 par défaut) Cette valeur définit un seuil qui permet de prendre en compte le calcul de la surface en M2 x Nombre de tournées (voir caractère 1). Ce seuil est la quantité maxi de couleurs entre recto et verso.


M####SI Longueur diagonale format rogné

Cette formule peut être utilisée sur toutes les phases

Quantité = diagonale format rogne * quantité de l'entité (hors gâche)

Paramétrage

Caractère 1 | O on prend la quantité gâche comprise.
Caractères 2 à 3 | dimension à ajouter à la diagonale.


M####ST Calculs en tous genres

Cette formule peut être saisie sur n'importe quelle phase.

Formule standard. Elle multiplie le prix unitaire de la matière saisie par la quantité de matière saisie.

Elle permet de pallier les cas atypiques. C'est en fait une formule de calcul dont on se sert comme une machine à calculer.

Attention, les gâches éventuellement attachées à la matière saisie sont ajoutées à la quantité saisie.

Exemple d'utilisation

Le client veut un élastique sur 250 des produits.

Comment le calculer en automatique ?

Matière = ELASTIQUE (par exemple)

Quantité = 250

Le fichier matière / produit donne le prix de l'élastique = 0.10F.

Coût total : 250*0.10 = 25 Francs.


M990.06

Cette formule est dérivée de M####ST


MCAR1 Calcul carton

Formule utilisable uniquement en carton ondulé.

CODE CARTON | Le code carton est recherché sur l'écran de détail technique de l'entité. Il est inutile d'essayer de le modifier lors du calcul de cette formule.
PRIX | Le prix du carton est donné au Kg.
POIDS | Poids hors gâche = Quantité de boite * surface unitaire * grammage carton. Si le caractère 2 de la zone Paramétrage = O, on divise ce poids par le nombre de poses (à mettre systématiquement).
GACHES | Les gâches de finition sont appliquées si le caractère 1 de la zone Paramétrage = O. Il est possible d'appliquer une gâche supplémentaire saisie dans une LCO. valeur numérique 1 = gâche fixe valeur numérique 2 = gâche variable Le code LCO doit être renseigné sur la formule.

Paramétrage

Caractère 1 | O on applique les gâches de finition
Caractère 2 | O on divise le poids par le nombre de poses


MCAR2 Calcul carton

La formule MCAR15 est tirée de la formule MCAR2.

Formule utilisable uniquement en carton ondulé.

Le code carton est recherché sur l'écran de détail technique de l'entité.

La quantité est une surface, exprimée en m2, cent m2 ou 1000 m2 selon l'unité d'achat (coefficient).

Elle tient compte des gâches standard et peut prendre en compte une gâche supplémentaire, saisie dans les LCO.

Le code LCO doit alors être indiqué sur la formule.

Le prix du carton est donné au M2 ou aux 100 M2 selon l'unité d'achat.

Le pourcentage de valeur de perte est lu dans les notes commençant par VAL_MAX_PERTE dans la formule.

Calcul du nombre de plaques nécessaires

Quantité de l'entité X nombre de morceaux ECMA) / nombre de poses + gâche

le stockage se fera dans fm_v1 si ul_param[18] = 1

le stockage se fera dans fm_v2 si ul_param[18] = 2

Sinon on ne calcule pas.

Paramétrage

Caractère 1 | N La quantité de carton doit être saisie manuellement (en feuilles).
Caractère 2 | O On applique le coefficient de conversion à la gâche de finition fixe. La gâche fixe est exprimée en nombre de plaques et on la convertit en m2.
Caractère 3 | P On effectue le calcul avec une quantité de précision supérieure (5 chiffres après la virgule).
Caractère 4 | O L'unité de quantité (fm_unite dans fle_mat) est égale au code unité d'achat (mp_ua dans mat).
Caractère 5 | H on calcule la quantité en plaques hors gâche
Caractère 6 | Mode de calcul de la quantité matière L Calcul de la quantité en mètres linéaires V Calcul de la quantité en volume S Calcul de la quantité en surface (par défaut)


MCAR3 Calcul carton

Le code carton est recherché sur l'écran de détail technique de l'entité.

Il est inutile d'essayer de le modifier lors du calcul de cette formule.

Le prix du carton est donné au M2.

Quantité en feuilles

Quantité devisée / nombre de poses + gâche de finition ramené aux feuilles dans le format commandé.

Ajout gâche d'impression (formule O IMF #C6 dans la table fle_ope).

Ajout gâche matière

Calcul surface

Recherche de la laize standard et de l'indice dans la fiche complémentaire (Code #LF)

Surface = nombre de feuilles * laize facturée (standard) * indice * coupe

Recherche du tarif

Tarif recherché sur

Code tarif T1

Code carton

Surface totale

Date de calcul


MCAR4 Calcul Encre

Le code encre est saisi sur le détail de la phase.

La donnée technique 1 du code encre fournit la consommation en grammes/m2 pour 1 couleur.

La valeur 1 précise le coefficient d'encrage.

Poids encre = Quantité de plaques imprimées * Surface plaque imprimée * Coefficient d'encrage * Conso en G/M2 pour 1 couleur

Cette formule est plus destinée aux cartonniers où l'on considère que les couleurs sont juxtaposées.

(On ne multiplie pas la consommation par le nombre de couleurs).


MCAR5 Calcul Colle

Le code colle est saisi sur le détail de la phase.

La donnée technique 1 du code colle fournit la consommation en grammes/m2.

Poids de la colle = Quantité de boites collées * Hauteur de la boite * Talon de la boite (k) * consommation en G/M2


MCAR6 Calcul Agrafe

Le code matière est saisi sur le détail de la phase.

La donnée technique 1 précise la densité d'éléments (1 agrafe tous les mp_dt1 mm).

Nombre d'agrafes = ( Hauteur boite / mp_dt1) x Quantité entité


MCAR7 Calcul Bande adhésive

Le code matière est saisi sur le détail de la phase.

Quantité = Hauteur boite x Quantité de l'entité


MCAR8 Calcul du cerclage

Le code produit du fil de cerclage doit être indiqué dans le détail de la phase.

Le nombre de palettes doit être calculé par l'intermédiaire de la formule ### #AU.

Le cubage palette est indiqué dans la donnée technique 2 sur la fiche article palette.

Nombre de mètres de cerclage = Nombre de palettes * longueur de cerclage par palette

Longueur de cerclage par palette = 4 * (cubage palette / surface unitaire) * largeur palette

Paramétrage

Caractère 1

C on effectue un cerclage en croix.

On compte en plus par matière : 2 * ( cubage palette / surface unitaire ) * longueur palette


MCAR9 Calcul film pour emballer

On compte un nombre de mètres carrés à utiliser par palette.

La consommation en mètres carrés de film par palette est indiquée dans la donnée technique 2 de la fiche matière de la palette.

Quantité = Consommation par palette * nombre de palettes

La mise sous film est fonction de la sous-famille du carton.

Si alpha1[15] = O, on réalise une mise sous film.

Si alpha1[15] = N, on ne réalise pas de mise sous film.

Paramétrage

Caractère 1

O la mise sous film sera forcée (quelque soit la sous-famille).


MCAR10 Calcul colle affiche

Dans la valeur 1, on doit trouver la largeur de l'affiche en cm.

Dans la valeur 2, on doit trouver la hauteur de l'affiche en cm.

Le code produit colle doit être indiqué dans le détail des phases.

La consommation au mètre carré se trouve dans la donnée technique 1 de la fiche matière colle.

Quantité de colle en KG

Quantité de l'entité * surface affiche * consommation au m²


MCAR11 Formule standard

Quantité = Quantité devisée (entité) / valeur 1 (saisie)

Possibilité de définir un arrondi à appliquer sur la quantité du résultat.

On peut définir la précision de l'arrondi.

Si la zone paramétrage est vide, aucun arrondi n'est appliqué.

Paramétrage

Caractère 1 | S arrondi supérieur I arrondi inférieur
Caractères 2 à 15 | précision de l'arrondi
Caractère 16 | O On multiplie la quantité obtenue précédemment par la largeur en mètres du format unitaire
Caractères 17 à 18 | Permet de saisir un coefficient multiplicateur

Quantité | Inf/Sup | Précision | Résultat
1.273 | I | 0.01 | 1.27
1.273 | S | 0.01 | 1.28
1.273 | I | 0.1 | 1.2
1.273 | S | 0.1 | 1.3
-1.273 | I | 0.1 | -1.3
-1.273 | S | 0.1 | -1.2
13.125892 | I | 0.00001 | 13.12589
1548.25 | I | 1 | 1548
1548.25 | S | 1 | 1549
1548.25 | I | 10 | 1540
1548.25 | S | 10 | 1550
1525954 | I | 10000 | 1520000
1525954 | S | 10000 | 1530000


MCAR12 Calcul plats carton reliure

Paramétrage

Caractères 1 à 2

Valeur à ajouter à la hauteur du carton (en mm)

Largeur carton = Largeur du produit fini (fi_lar_fini de la table fle_imp)

Hauteur carton = Longueur du produit fini (fi_lon_fini de la table fle_imp)

Poids carton = Largeur X Hauteur X (Poids de la fiche matière / 1000) X Quantité devisée (fi_qteent de la table fle_imp) X 2

(on multiplie par 2 car il y a deux plats par ouvrage).


MCAR13 Calcul carton dos reliure

Paramétrage

Caractères 1 & 2 | Valeur à ajouter à la hauteur du dos.
Caractères 3 à 5 | Code de la LCO contenant l'épaisseur du bloc dans la valeur 2.

La hauteur du dos est prise dans fi_lon_fini (longueur produit fini).

La largeur du dos est prise dans fc_v2.

Le poids du dos est calculé de la façon suivante :

(poids dos = largeur dos X hauteur dos X (poids de la fiche matière / 1000) X quantité devisée) / d

Si l'unité de mesure pour le format fini est en millimètres, d = 1.000.000, sinon d = 10.000


MCAR14 Formule spécifique W

Cette fonction retourne le poids carton en KG si le prix d'achat est au KG, et un nombre de feuilles si le prix d'achat est à la feuille.

Elle tient compte des gâches fixe et variable saisies sur LCO (LCO GAC).

Formules de calcul

Soit les valeurs suivantes :

QN = Quantité d'étuis commandés / Nombre de poses

LL = Largeur de plaque commandée X Longueur de plaque commandée / 1 000 000

GRAM = Grammage / 1000

GV = 1 + gâche variable / 100

GF = gâche fixe

Les dimensions de la plaque sont en mm, le grammage en g/m2.

Formule pour nombre de feuilles

QN X GV + GF

Formule pour poids en Kg

QN X LL X GRAM X GV + GF

Cette formule tient également compte du nombre de morceaux (différent du nombre de poses et du nombre de morceaux sur fiche ECMA).

On divise la largeur commandée par la largeur de tirage : la valeur entière donne le nombre de morceaux en largeur.

Idem pour la longueur.


MCAR15 Calcul carton

Formule tirée de la MCAR2

Formule utilisable uniquement en carton ondulé.

Quantité = nombre de plaques nécessaires.

V1 = surface exprimée en M².

V2 = surface exprimée en Mille M².

ATTENTION : bornes des tarifs exprimées en M², Tarifs exprimés au MILLE M².

Paramétrage

Caractère 1 | N La quantité de carton doit être saisie manuellement (en feuilles).
Caractère 2 | O On applique le coefficient de conversion à la gâche de finition fixe. La gâche fixe est exprimée en nombre de plaques et on la convertit en m2.
Caractère 3 | P On effectue le calcul avec une quantité de précision supérieure (5 chiffres après la virgule).
Caractère 4 | inutilisé
Caractère 5 | H on calcule la quantité en plaques hors gâche


MCCO1 Contre Collage simple

Il s'agit de calculer la quantité de carton nécessaire au contre collage simple.

Le code du carton est saisi dans l'écran détail matière.

La quantité de base de carton est égale à :

Quantité devisée / Nombre de poses / Nombre de feuilles tirage dans le format papier (ou carton).

On ramène donc à une quantité de carton exprimée en nombre de feuilles dans le format du papier ou carton commandé.

Les gâches de finition sont inclues dans les gâches matière.

De plus, le nombre total de feuilles calculé est ramené à l'unité de conditionnement supérieure (si paramétrage spécifique mis en place).

Le nombre de feuilles nécessaires à cette opération est comptabilisé en gâche fixe.


MCCO2 Contre Collage (Triplage)

Il s'agit de calculer la quantité de carton intermédiaire de triplage.

Le code du carton est saisi dans l'écran détail matière.

La quantité de base de carton est égale à :

Quantité devisée / 2 / Nombre de poses / Nombre de feuilles tirage dans le format papier (ou carton).

Une gâche fixe (exprimée en nombre de feuilles) et une gâche variable peuvent évidemment être attribuées à la matière première dans le fichier matière / produit. (Les gâches de finition sont ajoutées aux gâches matière).

On ramène donc à une quantité de carton exprimée en nombre de feuilles dans le format du papier ou carton commandé.

De plus, le nombre total de feuilles calculé est ramené à l'unité de conditionnement supérieure (si paramétrage spécifique mis en place).

Le nombre de feuilles nécessaires à cette opération est comptabilisé en gâche fixe.


MCCO3 Contre Collage simple

Calcul strictement identique à MCCO1.

La formule étant différente, on peut y associer des codes lignes complémentaires différents et donc des cartons de contre-collage différents (pour le triplage)


MCCO4 Contre Collage (triplage)

Calcul strictement identique à MCCO2.

La formule étant différente, on peut y associer des codes lignes complémentaires différents et donc des cartons de contre-collage différents (pour le triplage).


MCEL1 Cellophanage

Il s'agit de calculer le coût de la matière utilisée pour le cellophanage.

Le code de la matière est saisi sur l'écran détail matière.

Le format de la fenêtre est saisi dans le détail matière (valeurs 1 et 2) en millimètres.

La quantité de base du calcul est la suivante :

Quantité devisée * surface de la fenêtre * poids au mètre carré de la matière utilisée

Le poids au mètre carré est saisi dans la zone grammage du fichier matière/produit.

Une gâche fixe (exprimée en kilogrammes) et une gâche variable peuvent évidemment être attribuées à la matière première dans le fichier matière/produit.

Si la matière est tarifée, le prix de revient est recherché dans le fichier tarif :

Plage de recherche = plage de laize de la matière. (La laize étant saisie dans la valeur 2 du détail matière).

Si le tarif n'est pas trouvé, ou si la matière n'est pas tarifée, le prix de revient utilisé est celui du fichier matière.


MDEFAUT Formule standard

Cette formule est appliquée si le code formule est égal à #ST (comme standard).

Le code matière saisi sur l'écran détail matière est lu.

La quantité totale de matière est calculée en fonction de la quantité hors gâche saisie et des gâches fixes et variables contenues dans l'enregistrement matière.

Enfin, le prix de revient et la marge de la matière première permettent de calculer le prix total de la matière.


MDOR1 Dorure

Le nombre de feuilles à dorer est calculé de la façon suivante :

Quantité à dorer calculée dans la formule opération O DOR 2.

La largeur et l'avance permettent de calculer la surface à dorer.

Largeur et avance sont saisies en mm.

Le prix de la matière est donné en m2.

La quantité de matière consommée (or, argent, hologramme) est égale au nombre de modules à dorer par la surface du module à dorer.

La gâche fixe éventuellement attachée à la matière dans le fichier matière/produit doit être exprimée en mètres carrés.

Le code matière peut être différent selon que l'on applique de l'or, de l'argent ou un hologramme.


MEMC1 Emballage caisses

Le code caisse doit être saisi manuellement sur l'écran détail matières utilisées.

Le poids maximum de la caisse est lu dans la donnée technique 2 du fichier matière/produit.

Il est affiché dans la valeur 1 du tableau détail matière.

Le calcul du nombre de caisses est automatique :

Nombre de caisses = Poids devisé / Poids maxi caisse

L'arrondi est fait à l'unité supérieure.

Tous les poids sont exprimés en Kg.

Le poids devisé peut être :

Le poids d'une entité si la phase est saisie sur une entité de fabrication.

Le poids total (total des entités) si la phase est saisie sur l'entité 99.

Le fichier matière contient un prix à la caisse.

La gâche fixe liée à la caisse est exprimée en nombre de caisses.


MEME1 Mise sous étui

La quantité d'étuis est égale à la quantité devisée.

Le code matière (code pochette ou tout autre emballage à l'unité) donne le prix unitaire.

On ajoute évidemment à cette quantité de base les gâches éventuellement saisies au niveau du fichier matières.


MEMF2 Emballage paquet film

Le code paquet est saisi manuellement sur l'écran détail matière.

Une fois le code paquet déterminé, le calcul se fait au poids, tous les poids étant exprimés en Kg.

Le poids maximum du paquet est saisi dans la donnée technique 2 du fichier matière/produit.


MEMM1 Emballage sortie machine

Emballage à plat sortie machine d'impression (1).

Le code palette est attaché à la machine d'impression.

Dans le cas où l'emballage est saisi sur l'entité 99, c'est la machine de l'entité 1 qui définit le code de la palette à utiliser.

Une fois le code palette déterminé, le calcul se fait au poids, tous les poids étant exprimés en Kg.

Le poids maximum de la palette est saisi dans la donnée technique 2 du fichier matière/produit.


MEMM2 Emballage sortie machine

Emballage à plat sortie machine d'impression (2).

Le code palette est saisi manuellement sur l'écran détail matière.

Une fois le code palette déterminé, le calcul se fait au poids, tous les poids étant exprimés en Kg.

Le poids maximum de la palette est saisi dans la donnée technique 2 du fichier matière/produit.


MEMP1 Emballage palettes

Le code palette est saisi manuellement sur l'écran détail matière.

Une fois le code palette déterminé, le calcul se fait au poids, tous les poids étant exprimés en Kg.

Le poids maximum de la palette est saisi dans la donnée technique 2 du fichier matière/produit.

Elle est indiquée dans la valeur 1 de la formule de calcul.


MGAR1 Calcul du papier pour les gardes blanches

Le code papier est saisi en cm.

Le format est indiqué sur la fiche papier (largeur x longueur) (Attention : inversion sur fiche papier !).

Le format fini du document est saisi sur l'écran des données techniques.

On calcule le nombre de morceaux contenus dans la feuille.

Deux gardes sont comptées par ouvrage.

La quantité est le nombre de feuilles roulées gâches comprises.

Paramétrage

Caractères 1 à 2

Valeur en mm de la rogne en cours de découpe


MIMF1 Calcul encre recto

Le code encre est saisi manuellement sur l'écran détail matière.

Le calcul s'effectue uniquement si on a saisi un pourcentage d'encrage et un nombre de couleurs au recto.

Calcul du poids de l'encre :

La consommation d'encre est donnée par la donnée technique 1 du fichier matière en grammes/m2.

Poids encre =Surface feuille de papier roulée * Coef. d'encrage * Consommation au m2 * Nombre de tours recto

Le fichier matière contient un prix d'encre au Kg.

Remarque : L'encre n'est comptabilisée qu'au premier passage.

Paramétrage

Caractère 1

O Le code matière encre est forcé par une information complémentaire saisie sur la machine d'impression recto.

Le type d'information complémentaire est défini comme suit :

E11 : code TSC encre pour 1 couleur dont 1 couleur primaire

E21 : code TSC encre pour 2 couleurs dont 1 couleur primaire


MIMF2 Calcul vernis

Calcul du vernis pour l'impression recto.

Le code vernis est saisi manuellement.

Le calcul s'effectue uniquement si on a saisi un pourcentage de vernissage recto.

Calcul du poids de vernis

La consommation de vernis est donnée par la donnée technique 1 du fichier matière en grammes/m2.

Poids vernis = Surf. feuille roulée * Coef. vernis * Conso. au m2 * Nb de tournées * Nb de feuilles passées au recto.

Le fichier matière contient un prix de vernis au Kg.


MIMF3 Calcul encre verso

Calcul de l'encre pour l'impression verso.

Le code encre est saisi manuellement.

Le calcul s'effectue uniquement si on a saisi un pourcentage d'encrage et un nombre de couleurs au verso.

Calcul du poids de l'encre :

La consommation d'encre est donnée par la donnée technique 1 du fichier matière en grammes/m2.

Poids encre = Surf. feuille roulée * Coef. encrage * Conso au m2 * Nb de tournées * Nb de feuilles passées au verso.

Le fichier matière contient un prix d'encre au Kg.

Remarque : L'encre n'est comptabilisée qu'au premier passage.

Paramétrage

Caractère 1

O Le code matière encre est forcé par une information complémentaire saisie sur la machine d'impression verso.

Le type d'information complémentaire est défini comme suit :

E11 : code TSC encre pour 1 couleur dont 1 couleur primaire

E21 : code TSC encre pour 2 couleurs dont 1 couleur primaire


MIMF4 Calcul vernis verso

Calcul du vernis pour l'impression verso.

Le code vernis est saisi manuellement.

Le calcul s'effectue uniquement si on a saisi un pourcentage de vernissage verso.

Calcul du poids de vernis

La consommation de vernis est donnée par la donnée technique 1 du fichier matière en grammes/m2.

Poids vernis = Surf. feuille roulée * Coef. vernis * Conso au m2 * Nb tournées * Nb de feuilles passées au verso.

Le fichier matière contient un prix de vernis au Kg.


MIMF5 Calcul du papier

Le code papier est saisi sur le premier écran technique du devis. Il est donc inutile de le ressaisir.

Toutes les quantités de papier sont exprimées en feuilles dans le format à commander.

Le calcul du papier sur une entité se référant à une autre entité (même travail sur autre entité), il part d'une quantité de base nulle.

La quantité de base pour le calcul prend en compte les gâches de finition définies dans l'opération IMF IMF GF.

A cette quantité de base est ajoutée la gâche liée à la machine (gâche de démarrage) ainsi bien entendu que la gâche liée directement au papier.

S'il y a deux machines, les gâches liées à chaque machine sont comptées (sauf dans le cas d'une retiration).

A cette quantité est ajoutée la gâche papier liée aux changements de plaques.

L'opération IMF IMF GCP difficulté NOR donne pour chaque machine le nombre de feuilles gâchés pour chaque changement de plaque.

S'il y a bascule, les gâches ne sont comptées qu'une fois !!!

S'il y a plusieurs tournées, les gâches sont comptées à chaque tournée. (Par exemple, gâche de démarrage machine).

Si le papier est conditionné, le calcul se fait en arrondissant à l'unité de conditionnement supérieure.

Tarif papier

Sans paramètre particulier, le prix affiché correspond au prix de revient du fichier article.

Par paramétrage, on peut effectuer une recherche dans le fichier tarif.

La recherche est effectuée lors du calcul en fonction des éléments suivants :

  • Code tarif (Roto ou Feuille)

  • Code papier

  • Code appro (Fabrication, stock, commande, Fabristock)

  • Tonnage

  • Date d'application.


MIMF6 Calcul encre recto + verso

Le code encre est saisi manuellement sur l'écran détail matière.

Le calcul s'effectue uniquement si on a saisi un pourcentage d'encrage et un nombre de couleurs au recto/verso.

Calcul du poids de l'encre

La consommation d'encre est donnée par la donnée technique 1 du fichier matière en grammes/m2.

Elle peut également être indiquée dans le fichier des barèmes en indiquant : Code encre + sous-famille papier

La consommation saisie est donnée pour 1 couleur pour 100% d'encrage.

Exemple

Code Produit ENQFE : Encre Quadri Feuille

Famille PAP : Papier

Sous-Famille CBS : Couché brillant sans chlore

Poids encre = Surf. feuille roulée * Coef. d'encrage * Conso au m2 * Nb de tours R° + V° * Nb total de couleurs

Le fichier matière contient un prix d'encre au Kg.


MIMF7 Calcul du papier adapté pour le Multibande

IMPORTANT

En Multibande , il faut obligatoirement paramétrer le code formule dans la formule par défaut de la phase (PHA alpha1[16,18]).

Le code papier est saisi sur le premier écran technique du devis. Il est donc inutile de le ressaisir.

Toutes les quantités de papier sont exprimées en feuilles dans le format à commander.

Le calcul du papier sur une entité se référant à une autre entité (Même travail sur autre entité), il part d'une quantité de base nulle.

La quantité de base pour le calcul est égale au nombre de tours de base calculé par les formules OIMF26 et OIMF27.

Cette quantité de base inclut la gâche de finition.

Gâche variable

Gâche variable de roulage

Gâche variable liée au papier

Gâche fixe

Gâche fixe liée au papier (fiche article)

Gâche fixe de roulage (Formules OIMF26 et OIMF27)

Gâche fixe de réglage (Formules OIMF16 et OIMF17)

Gâche fixe de calage (Formules OIMF18 et OIMF19)

Gâche fixe de changement (Formules OIMF22 et OIMF23)

S'il y a bascule, les gâches ne sont comptées qu'une fois !!!

Si le papier est conditionné, le calcul se fait en arrondissant à l'unité de conditionnement supérieure.

Tarif papier

Sans paramètre particulier, le prix affiché correspond au prix de revient du fichier article.

Par paramétrage, on peut effectuer une recherche dans le fichier tarif.

La recherche est effectuée lors du calcul en fonction de :

  • Code tarif (Roto ou Feuille)

  • Code papier

  • Code appro (Fabrication, stock, commande, Fabristock)

  • Tonnage

  • Date d'application.

Paramétrage

Caractère 1 |
Caractère 2 | O en ROTO, on utilise en plus une gâche variable propre à chaque machine. Cette gâche n'affecte pas le nombre de tours. Elle correspond donc à du papier qui n'est pas roulé.(macule + bifteck + bobineau). Ceci correspond à l'incapacité de la machine à utiliser la totalité de la bobine. Ce coefficient, sous la forme d'un pourcentage, peut être saisi au niveau du fichier machine dans la zone paramétrée 2 sur le fichier machine.
Caractère 3 |
Caractère 4 | O on tient compte de la gâche de pliage des opérations utilisant les formules O PLI 1 et O PLI 3 pour la gâche fixe, O PLI 2 et O PLI 4 pour la gâche variable.
Caractère 5 | O Utilisation de l'unité d'achat dans le calcul du total poids_feu correspond à la transformation de la quantité en Kg
Caractère 6 | O On ajoute la gâche fixe de façonnage
Caractère 7 | La gâche fixe de bascule est ajoutée à la gâche fixe
Caractères 8 à 10 | Code formule de l'opération qui correspond à la gâche de bascule
Caractère 11 | La gâche fixe de pliage est appliqué à tous les cahiers et plus seulement au premier
Caractère 12 | O La recherche du tarif est normalisée (#CFTAR). Le code tarif utilisé sera défini dans TEN, note FORMULE_RECH_TARIF
Caractère 13 | O La recherche de la gâche fixe est adaptée au devis standard pour les valeurs suivantes : Gâche fixe de réglage (Formules OIMF50 et OIMF51) Gâche fixe calage (Formules OIMF52 et OIMF53) Gâche fixe de changement de plaques (Formules OIMF54 et OIMF55) Gâche fixe de changement de plaques en repiquage (Formules OIMF74 et OIMF75)


MIMF8 Calcul papier (roto + feuille)

Cette formule est issue de la formule MIMF7.

Ajout de recherche de papier supplémentaire dans la phase PAS et les formules .08 .09 .10 .11 .12 .13

Soustraction des quantités trouvées de la quantité de base du papier principal.

Mise à jour de la quantité totale sur l'entité.

Ces formules sont paramétrables et vont rechercher le code papier sur une LCO attachée, LCO sur laquelle on saisit :

  • soit la valeur 1 pour une quantité en nombre de feuilles,

  • soit la valeur 2 pour un poids (bobines).

Ces valeurs alimentent les valeurs 1 et 2 des formules concernées et la quantité déduite et la valeur maxi.


MMAR1 Calcul des plaques Recto

La plaque est liée à la machine recto (fichier machine).

Le calcul du nombre de plaques prend en compte :

  • Le nombre de couleurs

  • Le nombre de changements de plaques

  • Le fait que le travail soit ou non basculable.

En roto, toutes les plaques sont comptées au recto.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

Paramétrage

Caractère 1

M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.


MMAR2 Calcul des plaques Verso

La plaque est liée à la machine verso (fichier machine).

Le calcul du nombre de plaques prend en compte :

  • Le nombre de couleurs

  • Le nombre de changements de plaques

  • Le fait que le travail soit ou non basculable.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

En roto, toutes les plaques sont comptées au recto.

Paramétrage

Caractère 1

M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.


MMAR3 Plaques vernis recto

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour un vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.

Paramétrage

Caractère 1

M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.


MMAR4 Plaques vernis verso

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour un vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.

Paramétrage

Caractère 1

M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.


MMON1 Montage films

Le nombre de pages à monter est saisi dans la valeur 1.

Le code du film utilisé est saisi dans le code matière.

C'est le code film qui prend en compte les formats du film.

Le prix du film est un prix remis à la page.


MMON2 Photogravure (calcul des films)

Voir la formule MPHO2


MMON3 Calcul des plaques Recto

Voir la formule MPLA1


MMON4 Calcul des plaques Verso

Voir la formule MPLA2


MMON5 Plaques vernis recto

Voir la formule MPLA3


MMON6 Plaques vernis verso

Voir la formule MPLA4


MPAP5 Calcul du papier

Le code papier est saisi sur le premier écran technique du devis. Il est donc inutile de le ressaisir.

Toutes les quantités de papier sont exprimées en feuille dans le format à commander.

Le calcul du papier sur une entité se référant à une autre entité (même travail sur autre entité), il part d'une quantité de base nulle.

La quantité de base pour le calcul prend en compte les gâches de finition définies dans l'opération IMF IMF GF.

A cette quantité de base est ajoutée la gâche liée à la machine (gâche de démarrage) ainsi bien entendu que la gâche liée directement au papier.

S'il y a deux machines, les gâches liées à chaque machine sont comptées (sauf dans le cas d'une retiration).

A cette quantité est ajoutée la gâche papier liée aux changements de plaques.

L'opération IMF IMF GCP difficulté NOR donne pour chaque machine le nombre de feuilles gâchées pour chaque changement de plaque.

S'il y a bascule, les gâches ne sont comptées qu'une fois !!!

S'il y a plusieurs tournées, les gâches sont comptées à chaque tournée (par exemple, gâche de démarrage machine).

Si le papier est conditionné, le calcul se fait en arrondissant à l'unité de conditionnement supérieure.

Tarif papier

Sans paramètre particulier, le prix affiché correspond au prix de revient du fichier article.

Par paramétrage, on peut effectuer une recherche dans le fichier tarif.

La recherche est effectuée lors du calcul en fonction des éléments suivants :

  • Code tarif (Roto ou Feuille)

  • Code papier

  • Code approvisionnement (Fabrication, stock, commande, Fabristock)

  • Tonnage

  • Date d'application


MPAP50 Calcul du papier pour des gardes blanches (non imprimées)

Le code papier est saisi sur le premier écran technique du devis. Il est donc inutile de le ressaisir.

Toutes les quantités de papier sont exprimées en feuilles dans le format à commander.

La quantité de base pour le calcul prend en compte les gâches de finition définies.

Cette quantité de base est divisée par le nombre de poses.


MPEL1 Pelliculage

Pelliculage interne. Le calcul est fait sur la base d'un prix au m2.

Le code film est saisi dans le code matière.

La largeur du dos est saisie en valeur1 en mm.

La largeur du rempli est saisie en valeur2 en mm.

Calcul de la surface à pelliculer

Surface = (hauteur + 2 * rempli) * (2 * (largeur + rempli) + dos)

Le format de base est le format fini.


MPEL2 Pelliculage

On part du nombre total de feuilles et du format du papier acheté.

Le prix de la matière est indiqué au m2.

Si un tarif est saisi, c'est le prix tarif qui est pris en compte.

Le tarif inclut la notion de plage de quantité.


MPHO1 Photogravure

Le code matière définit le type de la photogravure. (SIMILI, TRAIT, ...)

La zone (racine carrée de la surface) à photograver doit être saisie sur l'écran détail matières.

On renseigne également la quantité d'opérations (Nombre de similis, nombre de traits etc. ...).

Exemple

10 TRAITS Zone 6

Code matière : TRAITS

Quantité : 10

Zone : 6

La formule de calcul scrute le fichier tarif pour déterminer le prix de photogravure en fonction du type de photogravure et de la zone.

Fichier tarif

Code matière/produit : Type de photogravure

Plage : Zone

Exemple

TRAITS

zone 1 à 6 : 30 Frs le TRAIT

zone 7 à 10 : 28 Frs le TRAIT

etc. ...


MPHO2 Photogravure (calcul des films)

S'il s'agit d'un renouvellement, on ne compte pas de film.

S'il y a assez de typons fournis, on ne compte pas de film.

Le calcul du film est fait par mètre carré et par couleur.

Le prix indiqué dans le fichier matière est donc un prix par mètre carré et par couleur.

La surface est calculée sur la base du format tirage.


MPHO3 Calcul film pour photogravure

Pas de calcul si renouvellement.

Le format fini de l'ouvrage permet de déterminer la surface finie de l'ouvrage.

Cette surface permet ensuite de déterminer automatiquement le code du film à utiliser (plage de surface) de la façon suivante :

Paramètre #DE Tous les codes paramètres doivent commencer par F.

Code paramètre | Zone alpha | Valeur 1 | Valeur 2
 | Code du film | Borne inf. | Borne sup.
F01 | code film 1 | 0 | 432 cm2
F02 | code film 2 | 432.1 | 540
Etc… |  |  |

Une fois le code du film déterminé, le format de celui-ci est indiqué en clair.

Calcul du nombre de films

Nombre de films = (nb total de page / 2 ) * (nb coul recto + nb coul verso + nb vernis recto + nb vernis verso)


MPLA1 Calcul des plaques Recto

Ce paragraphe était initialement dans MMON3. Or, la fonction fl_mmon3 pointe vers fl_mpla1.

La plaque est liée à la machine recto (fichier machine). Le calcul du nombre de plaques prend en compte :

  • Le nombre de couleurs

  • Le nombre de changements de plaques

  • Le fait que le travail soit ou non basculable.

En roto, toutes les plaques sont comptées au recto.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

Paramétrage

Caractère 1 | M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.
Caractère 2 |
Caractère 3 |
Caractère 4 |
Caractère 5 | O Ajout d'un nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires


MPLA2 Calcul des plaques Verso

La plaque est liée à la machine verso (fichier machine).

Le calcul du nombre de plaques prend en compte :

Le nombre de couleurs

Le nombre de changements de plaques

Le fait que le travail soit ou non basculable.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

En roto, toutes les plaques sont comptées au recto.

Paramétrage

Caractère 1 | M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases. On peut ainsi utiliser des plaques différentes pour une même machine, selon la nature du travail.
Caractère 2 | M la quantité représente alors une surface en mètres carrés. Cette surface est obtenue en multipliant le nombre de plaques par la surface de tirage. valeur 1 : nombre de plaques verso valeur 2 : surface en m2 Ce paramétrage permet de calculer un coût matière pour les machines de type OPTY-COPY
Caractère 3 | Nombre de couleurs verso au-delà duquel l'opération est comptée. Exemple : On fait certaines épreuves au-delà de 2 couleurs uniquement. Si présence de bascule, on ignore ce paramètre en verso.
Caractère 4 | O Ne remet pas à blanc le code plaque si la formule ne se calcule pas. N Remet à blanc le code plaque si la formule ne se calcule pas (par défaut , correspond au mode de fonctionnement normal ).
Caractère 5 | O Ajout d'un nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires

Gestion du type de prépresse. Pas de paramétrage.

type de prépresse | Résultat
N | La plaque n'est pas copiée
T | Fonctionnement traditionnel
P | On ajoute au code plaque –P , il faut donc créer ce type de plaque
F | On ajoute au code plaque -F , il faut donc créer ce type de plaque


MPLA3 Plaques vernis recto

Voir aussi #CF DEG A4[43]

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour un vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.

Paramétrage

Caractère 1 | M le code plaque n'est plus cherche sur la machine. Il doit être saisi dans la code matière du détail des phases.
Caractère 2 | M la quantité représente alors une surface en mètres carrés. Cette surface est obtenue en multipliant le nombre de plaques par la surface de tirage. valeur 1 : nombre de plaques valeur 2 : surface en m2
Caractère 3 | O S'il y a bascule, on ne répartit pas la plaque.


MPLA4 Plaques vernis verso

Voir aussi #CF DEG A4[43]

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour une vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.

Paramétrage

Caractère 1 | M le code plaque n'est plus cherché sur la machine. Il doit être saisi dans le code matière du détail des phases.
Caractère 2 | M la quantité représente alors une surface en mètres carrés. Cette surface est obtenue en multipliant le nombre de plaques par la surface de tirage. valeur 1 : nombre de plaques valeur 2 : surface en m2
Caractère 3 | O S'il y a bascule, on ne répartit pas la plaque.


MPLA5 Plaques vernis sur machine séparée

Cette formule concerne les vernis sur machine séparée (non en ligne).

Elle s'appuie sur les infos complémentaires suivantes :

  • Vernis Recto/Verso (valeur numérique 1)

  • Coefficient d'encrage (valeur numérique 2)

  • La machine de la ligne complémentaire

  • Si présence de vernis (1 = recto ou verso , 2 = Recto + Verso)

Le nombre de plaques est égal au nombre de tournées x Valeur 1 si le coefficient d'encrage est < à 100 %.

Le nombre de plaques = 1 si coefficient d'encrage = 1.

La plaque est recherchée sur la machine par défaut (plaque vernis).


MPLA50 Calcul des plaques recto - devis standard

La plaque est liée à la machine recto (fichier machine).

Le calcul du nombre de plaques prend en compte :

Le nombre de couleurs

Le nombre de changements de plaques

Le nombre de repiquages

Le fait que le travail soit ou non basculable.

En roto, toutes les plaques sont comptées au recto.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

Gestion du type de prépresse. Pas de paramétrage.

N La plaque n'est pas copiée

T Fonctionnement traditionnel

P On ajoute au code plaque -P , il faut donc créer ce type de plaque

F On ajoute au code plaque -F , il faut donc créer ce type de plaque


MPLA51 Calcul des plaques verso - devis standard

La plaque est liée à la machine verso (fichier machine).

Le calcul du nombre de plaques prend en compte :

Le nombre de couleurs

Le nombre de changements de plaques

Le nombre de repiquages

Le fait que le travail soit ou non basculable.

En roto, toutes les plaques sont comptées au recto.

Exemple : pour 1/2 tournée 4 couleurs, la formule calcule 2 plaques pour le recto et 2 plaques pour le verso.

Gestion du type de prépresse. Pas de paramétrage.

N La plaque n'est pas copiée

T Fonctionnement traditionnel

P On ajoute au code plaque -P , il faut donc créer ce type de plaque

F On ajoute au code plaque -F , il faut donc créer ce type de plaque


MPLA52 Plaques vernis recto - devis standard

Voir aussi #CF DEG A4[43]

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour un vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.


MPLA53 Plaques vernis verso - devis standard

Voir aussi #CF DEG A4[43]

Le code plaque est automatique et lié à la machine.

S'il s'agit d'un vernis à plat, c'est la plaque encre qui est utilisée, sinon on prend la plaque vernis.

En effet, on considère pour une vernis à plat, que le prix de la plaque est très voisin du prix d'une plaque encre.

S'il y a bascule, on répartit la plaque au recto et au verso.

Pour un vernis à plat, on compte UNE plaque.

Pour un vernis avec réserve, on compte une plaque par tournée.


MTRA1 Transport

Calcul du transport au poids sans notion de destination.

Le code produit saisi (par exemple TRANSPORT) donne le prix au kilogramme du transport.


MVER1 Vernis hors machine d'impression

Le calcul est fait sur la base d'un prix au m2.

Le code vernis est saisi dans le code matière.

La largeur du dos est saisie en valeur1 en mm.

La largeur du rempli est saisie en valeur2 en mm.

Calcul de la surface à vernir

Surface = (hauteur + 2 * rempli) * (2 * (largeur + rempli) + dos)

La surface est calculée sur la base du format fini.

La quantité est calculée sur la base de la quantité devisée.


MVER2 Vernis hors machine d'impression

Le calcul est fait sur la base d'un prix au m2.

Le code vernis est saisi dans le code matière.

Calcul de la surface à vernir

Surface = (hauteur + 2 * rempli) * (2 * (largeur + rempli) + dos)

La surface est calculée sur la base du format du papier commandé.

La quantité est calculée sur la base de la quantité totale de feuilles (gâche comprise).


MVER3 Calcul vernis sur machine spéciale

Valeur 1 = encrage saisi par le deviseur

Valeur 2 = coefficient multiplicateur (1 si recto, 1 si verso, 2 si recto/verso)

Recherche de la consommation (en gramme au m2) dans le fichier tarif par :

  • Code vernis

  • Sous-famille du papier imprimé

Calcul du poids de vernis : largeur * hauteur (ft tirage) * Nb. de tours recto (hors gâche) * encrage / 100 * coef. * conso / 1000


O####AC Aide en calage

Cette formule est indépendante de la phase.

Le temps de l'opération est égal à la somme des temps de CALAGE de la phase précédente.

La quantité d'opération est forcée à 1 si elle n'est pas saisie.

Il n'y a pas de dépendance.


O####AR Aide en roulage

Cette formule est indépendante de la phase.

Le temps de l'opération est égal à la somme des temps de ROULAGE de la phase précédente.

La quantité d'opération est forcée à 1 si elle n'est pas saisie.

Il n'y a pas de dépendance.

Paramétrage

Caractère 1

M on recherche le temps de roulage des opérations précédentes (sur la même phase).

P ou [blanc] on recherche le temps de roulage sur la phase précédente.


O####AU Formule paramétrable

Les dépendances sont paramétrables via les zones Formulation et Paramétrage de la table des formules.

On peut mettre en œuvre jusqu'à 8 dépendances :

Dépendances

Zone alpha 1 | 3 caractères
Zone alpha 2 | 3 caractères
Zone alpha 3 | 3 caractères
Zone alpha 4 | 15 caractères
Plage numérique 1 | de ... à
Plage numérique 2 | de ... à
Plage numérique 3 | de ... à
Plage numérique 4 | de ... à

D'autre part, il est possible de définir une machine par défaut ainsi qu'un code de difficulté.

De plus, il est possible de rechercher un code machine par calcul en initialisant les caractères 52 à 60 de la formule.


O####BA Formules standard

Quantité = 1 si bascule et 0 sinon.

Machine : Première machine d'impression

Dépendances

Plage 1 | nombre de tours hors gâche
Plage 2 | quantité devisée de l'entité


O####C1 Roulage standard

Quantité = Nombre de feuilles dans le format commandé. (+ gâches de finition)

Dépendances

Zone 1 | Sous-famille carton
Plage 1 | Surface en M2 de la feuille commandée


O####C2 Roulage standard

Utilisée dans O ### #C2 et O ### #C9

Quantité = Nombre de feuilles dans le format tirage. (+ gâches de finition)

Dépendances

Zone 1 | Sous-famille carton
Plage 1 | Surface en M2 du format de tirage.


O####C3 Roulage standard

Quantité = Nombre de feuilles dans le format tirage. (+ gâches de finition)

Dépendances

Zone 1 | Sous-famille carton
Zone 2 | Nombre total de couleurs (sans vernis)
Plage 1 | Sens travers en mm
Plage 2 | Sens machine en mm
Plage 3 | Nombre de poses


O####C4 Roulage standard

Quantité = Nombre de feuilles dans le format tirage. (+ gâches de finition)

Dépendances

Zone 1 | Sous-famille carton
Plage 1 | Sens travers en mm
 | Sens machine en mm
 | Nombre de poses


O####C5 Roulage standard

Quantité = quantité de l'entité

Dépendances

Zone 1 | Sous-famille carton
Plage 1 | Longueur hors tout en mm
Plage 2 | Largeur hors tout en mm


O####C6 Roulage standard

Quantité = Nombre de feuilles dans le format tirage. (+ gâches de finition)

Dépendances

Zone 2 | Nombre de couleurs (+ vernis)
Plage 1 | Surface en M2 du format de tirage.
Plage 2 | Plage de grammage.
Plage 3 | Quantité passée.


O####C7 Calage standard

Quantité = 1

Dépendances

Zone 1 | Sous-famille carton
Zone 2 | Nombre total de couleurs (avec vernis)
Plage3 | Nombre de poses


O####C8 Formule standard

Quantité d'opérations = valeur 1 * valeur 2

Dépendances

Plage 1 | quantité d'opérations
Plage 2 | valeur 1
Plage 3 | valeur 2


O####C9 Roulage standard

Utilisée dans O ### #C2

Quantité = Nombre de feuilles dans le format tirage. (+ gâches de finition)

Dépendances

Zone 1 | Sous-famille carton
Plage 1 | Surface en M2 du format de tirage.


O####NP Formules standard

Quantité = Nombre de pages de l'entité

Dépendances

Plage 1 | nombre de pages de l'entité
Plage 2 | quantité devisée de l'entité


O####P1 Présence de vernis

Caractère 1 | Présence ou non d'un vernis machine recto (O/N). Si vernis au recto, la quantité est égale à 1. La machine est la machine d'impression recto. La zone valeur 1 fera apparaître le nombre de kits recto. Permet de calculer ou non un coût de montage de kit de vernis.
Caractère 2 | Présence ou non d'un vernis machine verso (O/N) Si vernis au verso, la quantité est égale à 1. La machine est la machine d'impression verso. La zone valeur 2 fera apparaître le nombre de kits verso. Permet de calculer ou non un coût de montage de kit de vernis. On peut avoir du vernis en verso uniquement

Remarque : On peut définir une seule formule pour la présence des kits vernis.

La machine est alors la machine recto.

Le calcul s'effectue de la manière suivante :

Recto

On compte une présence si le vernis recto est > 0.

Verso

On compte une présence si la machine recto est différente de la machine verso et si le vernis verso est > 0.

OU la machine recto est égale à la machine verso et si le verni verso est > 0 et le verni recto n'existe pas.


O####PD Poids de papier de l'entité

Cette formule retourne le poids de papier de l'entité.

Paramétrage

Caractère 1 | H le poids de papier est exprimé HORS GACHE. Pour les autres cas, le poids est exprimé TOUTES GACHES.
Caractère 2 | I on utilise la première machine d'impression. Dans le cas contraire , la machine sera saisie.
Caractère 3 | T en multibande, on prend uniquement le poids des bandes tronçonnées.

La quantité est exprimée en KG.

Sur l'entité 99, cette formule renvoie la somme des poids de toutes les entités.

Attention : cette formule n'est valide que pour le devis Feuille et elle ne tient pas compte du poids du papier de contre collage.


O####Q1 Calage standard

Le nombre de calages peut être saisi dans la zone Quantité.

Il est forcé à 1 s'il n'est pas saisi.

Dépendance

Plage 1

quantité devisée


O####QD Formule standard

Cette formule est indépendante de la phase.

La quantité est égale à la quantité devisée hors gâche.

Le coût horaire pris en compte est recherché au niveau de la table des opérations à partir du code défini sur l'écran détail opérations.

Dépendance

Plage 1

quantité d'opérations à réaliser

Paramétrage

Caractère 1 | O Quantité de base = quantité devisée + gâches fixe et variable de finition. N Quantité de base = quantité devisée
Caractère 2 | Permet de figer un coefficient multiplicateur de la quantité. Exemple : 2 pour comptabiliser des opérations sur des gardes dans les phases de reliure.
Caractère 3 | O Permet de prendre en compte un coefficient multiplicateur saisi sur l'opération dans la valeur 1. Le coefficient s'applique sur la quantité. Exemple : on met la moitié des exemplaires sous élastique. On saisira 0.5 dans la valeur 1. N Pas de coefficient multiplicateur.


O####QE Refente après impression (avant pliage)

Cette formule retourne un nombre total d'élément à massicoter égal au : Nombre de feuilles * nb d'éléments de la feuille imprimée

Le nombre de feuilles prend en compte la gâche de finition.

Le nombre d'éléments de la feuille est défini à partir de la décomposition de la feuille imprimée.

Exemple : Décomposition de 2 cahiers de 6 pages en 4 poses + 3 cahiers de 8 pages en 1 pose

Nombre de morceaux = 2(cahiers) * 4(poses) + 3(cahiers) * 1(pose) = 11 éléments (ici 11 cahiers)

La cadence définie au niveau de l'opération est exprimée en nombre d'éléments coupés à l'heure.

Dépendances

Plage 1 | grammage
Plage 2 | nombre d'éléments de la feuille à massicoter

ATTENTION

  • Actuellement, cette formule n'est valide que pour le devis Feuille.

  • Sur l'entité 99, on totalise le nombre d'éléments des différentes entités.
    Dans ce cas, la dépendance Grammage doit être inhibée.

  • Prochainement, cette formule disposera également de la dépendance Fonds Perdus (Plage 3 ).


O####SC Formules standard (devis ondulé)

O####SC Formules standard (devis ondule)

Quantité = 1

Dépendances

Alpha 1 | Sous-famille Carton
Plage 1 | Surface unitaire (en cm2) (Surface hors tout)
Plage 2 | Surface totale (en m2)
Plage 3 | Quantité devisée
Plage 4 | Nombre de couleurs


O####SQ Formules standard (devis ondulé)

Quantité = Quantité devisée

Dépendances

Alpha 1 | Sous-famille Carton
Plage 1 | Surface unitaire (en cm2) (Surface hors tout)
Plage 2 | Surface totale (en m2)
Plage 3 | Quantité devisée
Plage 4 | Nombre de couleurs


O####ST

Cette formule peut être saisie sur n'importe quelle phase.

L'opérateur saisit un code opération et une quantité d'opérations à réaliser.

La cadence ou le temps standard lié à l'opération permet de calculer le temps opératoire et donc le coût global de l'opération.

Dépendance

Plage 1

quantité d'opérations saisies

Elle permet de pallier les cas atypiques.

C'est en fait une formule de calcul dont on se sert comme une machine à calculer.

Attention, les gâches éventuellement attachées à l'opération saisie sont ajoutées à la quantité saisie.

Exemple d'utilisation

Pose d'élastiques sur 250 exemplaires.

On pose 500 élastiques à l'heure.

L'opérateur saisit l'opération et la quantité de 250.

La formule va calculer : 250 / 500 = 0.5 heure à 150 F/H soit un coût global de 75 F.


O####T1 Formule standard

Le temps total de l'opération est saisi sur le tableau des phases.

Le coût horaire pris en compte est recherché au niveau de la table des opérations à partir du code défini sur l'écran détail opérations et d'une des machines d'impression.

Dépendance

quantité devisée

Paramétrage

Caractère 1

Numéro de la machine d'impression à utiliser.

1 Machine 1 (par défaut)

2 Machine 2


O####TT Formule standard

Cette formule est indépendante de la phase.

Le temps total de l'opération est saisi sur le tableau des phases.

Le coût horaire pris en compte est recherché au niveau de la table des opérations à partir du code défini sur l'écran détail opérations.

Pour rappel, au code opération peut être associé un code de difficulté et une machine mais en aucune façon à une dépendance.

Exemple d'utilisation

Conception d'une maquette.

Bien souvent, il est fort difficile de calculer en automatique le coût d'une maquette.

Par contre, le deviseur averti est capable d'estimer le temps nécessaire à la conception.

PARTICULARITE de TRAITEMENT

Lorsqu'on utilise la notion de formule à utiliser, on duplique (contrainte informatique) la formule pour faire apparaître une formule standard .

Exemple : AID -#04 : On précise que cette formule utilise la ### #04 (que l'on crée).


O1PO1 Frais fixes d'imposition recto

Il s'agit de la préparation de l'imposition recto.

L'opération est donnée par feuille et par couleur.

Les vernis avec réserve sont considères comme des couleurs.

Les frais fixes d'imposition ne sont pas comptés pour un vernis à plat.


O1PO2 Frais variables d'imposition recto

Il s'agit des frais d'imposition pure (hors préparation).

L'opération est donnée par page, par cote, par feuille et par couleur.

Dépendance

Plage 1

Nombre de couleurs

Exemple avec 4 couleurs non basculables, 1 vernis, 8 pages à la feuille, 3 tournées :

Nombre de frais variables = 3 * (4 + 1) * 8 = 120 / 2 (car on traite le recto et le verso séparément)

Soit 60 frais variables d'imposition au recto.

Remarques

  • La machine est forcée par la machine d'impression recto.

  • On tient compte des changements de plaques (version).

  • On ne tient pas compte des repiquages (voir paramétrage).

  • Si la tournée calculée est < à 1 , on prend 1.

Paramétrage

Caractère 1 | O On ne force pas la machine d'impression. La machine est celle saisie sur l'opération.
Caractère 2 | O On tient compte des repiquages de la même façon que les changements de version.


O1PO3 Frais d'ozalids supplémentaires

Il s'agit de calculer les frais dus aux ozalids supplémentaires.

L'opération est donnée par ozalid supplémentaire, par feuille et par couleur.

La quantité prise en compte lors du calcul est :

(Nombre total d'ozalids - 1) * Nombre de feuilles * Nombre de couleurs

Si les couleurs sont basculables et si moins de 1 feuille le nombre de couleurs pris en compte est le nombre maximum entre couleurs recto et verso.

Remarques

  • On compte les changements de plaques recto (version)

  • On ignore les repiquages

  • La machine est forcée par la machine d'impression recto

Paramétrage

Caractère 1

N ou [blanc] la formule fonctionne comme indiqué ci-dessus.

O La machine utilisée n'est pas forcée avec la machine d'impression.

La dépendance alpha 4 est la machine d'impression


O1PO4 Frais fixes d'imposition verso

Il s'agit de la préparation de l'imposition verso.

L'opération est donnée par feuille et par couleur.

Les vernis avec réserve sont considérés comme des couleurs.

Les frais fixes d'imposition ne sont pas comptés pour un vernis à plat.


O1PO5 Frais variables d'imposition verso

Il s'agit des frais d'imposition pure (hors préparation).

L'opération est donnée par page, par cote, par feuille et par couleur.

Dépendance

Plage 1

Nombre de couleurs

Exemple pour 4 couleurs non basculables, 1 vernis, 8 pages à la feuille, 3 tournées

Nombre de frais variables = 3 * (4 + 1) * 8 = 120 / 2 (car on traite le recto et le verso séparément)

Soit 60 frais variables d'imposition au verso

Paramétrage

Caractère 1 | O On ne force pas la machine d'impression. La machine est celle saisie sur l'opération.
Caractère 2 | O On tient compte des repiquages de la même façon que les changements de version.


O1PO6 Frais pour ozalids supplémentaires

Il s'agit de calculer les frais dus aux ozalids supplémentaires.

L'opération est donnée par ozalid supplémentaire, par feuille et par couleur.

La quantité prise en compte lors du calcul est : (Nbre total d'ozalids - 1) * Nbre de feuilles * Nbre de couleurs

Si les couleurs sont basculables et si moins de 1 feuille, le nombre de couleurs pris en compte est le nombre maximum entre couleurs recto et verso.

Remarques

  • On compte les changements de plaques verso (version).

  • On ignore les repiquages.

  • La machine est forcée par la machine d'impression verso.

Paramétrage

Caractère 1

N ou [blanc] la formule fonctionne comme indiqué ci-dessus.

O La machine utilisée n'est pas forcée avec la machine d'impression.

La dépendance alpha 4 est la machine d'impression.


OACM1 Calage assembleuse colleuse

La machine assemble, colle et rogne le produit.

Le nombre total de cahiers à assembler est affiché dans la valeur 1.

Attention, la couverture n'est pas comptée dans les cahiers à assembler puisqu'elle sera collée après l'assemblage.

Si une parcorisation est nécessaire, un message vous en avertit.

Le temps de calage est dépendant du nombre de cahiers à assembler. (Plage 1)

Dans tous les cas, on compte 1 calage.


OACM2 Assemblage/collage

La machine assemble, colle et rogne le produit.

Le nombre total de cahiers à assembler est affiché dans la valeur 1.

Attention, la couverture n'est pas comptée dans les cahiers à assembler puisqu'elle sera collée après l'assemblage.

Si une parcorisation est nécessaire, un message vous en avertit.

Dépendances Cadence de roulage

Plage 1 | nombre de cahiers à assembler
Plages 2 et 3 | format rogné (en mm)
Plage 4 | surface du format rogné (en cm2)

Si le type de façonnage est saisi (paramètre TFA sur l'écran de détail entête), la cadence dépend du type de façonnage (zone alpha 1).

On roule la quantité devisée, à laquelle bien entendu on ajoute les gâches liées à l'opération.


OACM3 Calage assemblage/collage en parcorisation

La machine assemble, colle et rogne le produit.

Le nombre total de cahiers à assembler est saisi dans la valeur 1.

Si une parcorisation est à nouveau nécessaire, un message vous en avertit.

Le temps de calage est dépendant du nombre de cahiers à assembler (plage 1).

Dans tous les cas, on compte 1 calage.


OACM4 Assemblage/collage en parcorisation

La machine assemble, colle et rogne le produit.

Le nombre total de cahiers à assembler est saisi dans la valeur 1.

Si une parcorisation est à nouveau nécessaire, un message vous en avertit.

Dépendances Cadence de roulage

Plage 1 | nombre de cahiers à assembler
Plages 2 et 3 | format rogné (en mm)
Plage 4 | surface du format rogné (en cm2)

Si le type de façonnage est saisi (paramètre TFA sur l'écran de détail entité), la cadence dépend du type de façonnage (zone alpha 1).

On roule la quantité devisée, à laquelle bien entendu on ajoute les gâches liées à l'opération.


OASS1 Calage assembleuse

Le nombre total de cahiers à assembler est affiché dans la valeur 1.

Attention, la couverture n'est pas comptée dans les cahiers à assembler puisqu'elle sera collée après l'assemblage.

Si une parcorisation est nécessaire, un message vous en avertit.

Le temps de calage dépend du nombre de cahiers à assembler (plage).

Dans tous les cas, on compte 1 calage.


OASS2 Roulage assemblage

Le nombre total de cahiers à assembler est affiché dans la valeur 1.

Attention, la couverture n'est pas comptée dans les cahiers à assembler puisqu'elle sera collée après l'assemblage.

Si une parcorisation est nécessaire, un message vous en avertit.

Le cadence de roulage dépend du nombre de cahiers à assembler (plage 1).

On roule la quantité devisée, à laquelle bien entendu on ajoute les gâches liées à l'opération.


OASS3 Calage assemblage en parcorisation

Le nombre total de cahiers à assembler est saisi dans la valeur 1.

Si une parcorisation est à nouveau nécessaire, un message vous en avertit.

Le temps de calage dépend du nombre de cahiers à assembler (plage 1).

Dans tous les cas, on compte 1 calage.


OASS4 Roulage assemblage en parcorisation

Le nombre total de cahiers à assembler est saisi dans la valeur 1.

Si une parcorisation est à nouveau nécessaire, un message vous en avertit.

La cadence de roulage dépend du nombre de cahiers à assembler (plage 1).

On roule la quantité devisée, à laquelle bien entendu on ajoute les gâches liées à l'opération.


OASS6 Roulage assemblage

Le nombre total de cahiers à assembler est affiché dans la valeur 1.

Attention, la couverture n'est pas comptée dans les cahiers à assembler puisqu'elle sera collée après l'assemblage.

La couverture est détectée par le type d'entité : COU.

Si la couverture doit être intégrée dans le nombre de cahiers à assembler, il faut la considérer comme un cahier normal.

La cadence de roulage est dépendante du nombre de cahiers assembler (plage 1).

Quantité roulée = quantité devisée * nombre de cahiers à assembler


OASS8 Roulage assemblage liasses

Le nombre total de feuillets à assembler est affiché dans la valeur 1.

La valeur 2 permet de saisir un nombre de poses d'assemblage.

La cadence de roulage est dépendante du nombre de feuillets à assembler. (Plage 1)

Quantité roulée = quantité devisée * nombre de feuillets à assembler / nombre de poses


OCAS1 Calage casseuse

Pas de dépendance.


OCAS2 Cassage

Le fichier des opérations donne un nombre d'exemplaires cassés à l'heure.

Remarque : L'épaisseur de l'entité est calculée en prenant en compte le nombre de pages, le grammage, la main du papier de l'entité.

La main du papier dépend de la sous-famille du papier.

La valeur 1 indique le coefficient.

Celui-ci est à 1 si non saisi. Il peut être à 0.5 (par ex.) si on ne casse que la moitié des entités.

Dépendances

Epaisseur de l'ouvrage

Quantité à casser


OCEL1 Calage cellophaneuse

On compte 1 calage dans tous les cas.

Le temps de calage dépend de la surface du produit à cellophaner.

La surface est exprimée en CM2.


OCEL2 Cellophanage

La cadence est donnée en mètres linéaires à l'heure.

On peut évidemment inclure une gâche à cette opération.

Dépendances

Plage 1 | Surface exprimée en cm2
Plage 2 | Grammage
Plage 3 | Quantité devisée hors gâche


OCM1 Calage collage/massicotage

1 calage est compté dans tous les cas. Il n'y a pas de dépendance de calcul.


OCM2 Collage/massicotage

On colle la quantité devisée.

Dépendances

Alpha 1 | Type de façonnage (si type zone paramétrée TFA)
Plage 1 | Nombre de cahiers
Plage 2 | Largeur format rogné (en mm)
Plage 3 | Hauteur format rogné (en mm)
Plage 4 | Surface (en cm2) du format rogné


OCOL1 Calage collage

On compte 1 calage dans tous les cas.

Le temps de calage dépend du type de boite à coller et de la surface en CM2 de cette boite.


OCOL2 Collage

La cadence de l'opération est donnée en mètres linéaires à l'heure.

Il y a une dépendance sur le type de boite à coller.

La quantité de base est égale à la quantité devisée.


OCOL4 Collage

La cadence de l'opération est donnée en nombre de boites collées à l'heure.

Dépendances

Alpha 1 | Type de boite
Plage 1 | Laize en mm
Plage 2 | Coupe en mm
Plage 3 | Quantité devisée en mm
Plage 4 | Grammage

La quantité de base est égale à la quantité devisée.


OCOM1 Composition au 1000 de signes

Cette formule nécessite la saisie du nombre de 1000 de signes sur l'écran détail opérations.

La cadence définie au niveau de l'opération est exprimée en nombre de 1000 de signes à l'heure.

Il y a une dépendance de calcul sur le nombre de milles de signes (plage 1).

Exemple : 2500 signes ----> 2,5 mille de signes.


OCOU1 Calage couseuse

On compte 1 calage dans tous les cas.

Dépendances du temps de calage

Plage 1 | largeur du format fini
Plage 2 | longueur du format fini (en mm)
Plage 3 | nombre de cahiers
Plage 4 | surface du format rogné (en cm2)


OCOU2 Couture

Dépendances de la cadence

Plage 1 | largeur du format fini
Plage 2 | longueur du format fini (en mm)
Plage 3 | nombre de cahiers
Plage 4 | surface du format rogné (en cm2)

La quantité de base pour le calcul est égale à : Quantité devisée * Nombre de cahiers

La cadence est indiquée en nombre de cahiers cousus à l'heure.

L'opération dépendant du nombre de cahiers, le point blanc n'a pas lieu d'intervenir dans le calcul.


ODEC1 Calage découpe

Il s'agit d'un calage supplémentaire pour la découpe sur la machine d'impression 1.

Le temps de calage dépend de la machine d'impression.


ODEC3 Calage découpe

Il s'agit d'un calage supplémentaire pour la découpe sur la machine d'impression 2.

Le temps de calage dépend de la machine d'impression.


ODEC5 Calage découpe

Le nombre de poses découpe est saisi dans la valeur 1.

Le temps de calage dépend du type de boite et du nombre de poses de découpe.


ODEC6 Découpe

Le nombre de poses découpe doit être saisi dans la valeur 1.

Dépendances

Grammage

Quantité de feuilles à découper

Nombre de poses

Remarque : Il est possible de préciser au niveau du code de difficulté la notion de la présence ou non de décorticage machine.

Attention, s'il y a contre collage, il est possible de saisir le grammage à prendre en compte dans les lignes complémentaires

(Code ligne = GRA - Valeur 1 = grammage après contre collage).


ODEC7 Préparation de la forme

C'est un temps par pose.

Dépendances

Type ECMA (Code paramètre KMA)

Surface hors tout de la boite en CM2

Nombre de poses

La quantité est égale à 1 (un calage).

Cette formule peut représenter :

  • un temps global pour toutes les opérations de préparation de la forme

  • un élément de la préparation, à savoir :

  1. Pose du caoutchouc éjecteur

  2. Pose de la contrepartie

  3. Préparation planche d'injection

Rappel : Il est possible d'intégrer une dépendance supplémentaire à partir de la rubrique code difficulté.

A titre d'exemple, le code de difficulté est utilisé pour préciser la présence ou non de décorticage machine donc présence ou non de la phase 3.


ODEP2 Dépouillage

Dépendances

Grammage

Nombre de modèles (saisi en valeur 1)

Surface de la boite en CM2

La quantité de base pour le calcul est la quantité devisée.


ODOR1 Calage dorure

On compte 1 calage.

Il n'y a pas de dépendance.


ODOR2 Dorure

Il n'y a pas de dépendance de calcul.

Le nombre de poses dorure doit être saisi dans la valeur 1.


OEMC1 Mise sous caisse

Cette formule est associée à la formule M EMC 1 qui doit donc obligatoirement figurer dans le tableau matière.

Le code de la caisse donne le poids maximum de cette caisse.

En fonction de ce poids maximum, on calcule le nombre de caisses nécessaires.

Dépendance

Nombre de caisses


OEME1 Mise sous étui

Il n'y a aucune dépendance sur cette opération.

La quantité de base est égale à la quantité devisée.


OEMF1 Mise sous paquet film

Le nombre d'exemplaires par paquet est saisi dans la valeur 1.

Dépendance : Nombre de paquets

Exemple

10 000 Exemplaire à emballer par paquet de 100

(10 000 / 100) = 100 Paquets à 50 paquet/heure

(100 / 50) = 2 Heures à 150 F

300 Francs.


OEMF2 Mise sous paquet

Cette formule est associée à la formule M EMF 2 qui doit donc obligatoirement figurer dans le tableau matière.

Le code du paquet donne le poids maximum du paquet.

En fonction de ce poids maximum, on calcule le nombre de paquets nécessaires.

Dépendance : Nombre de paquets

Exemple

10 500 Exemplaires Poids unitaire 50 g.

Code paquet film FI-12 Poids maxi 10 Kg.

(10 500 * 0.050) = 525 Kg.

(525 / 10 ) = 52.5 soit 53 paquets

53 paquets à 10 paquets à l'heure = 5.3 heures

5.3 heure à 100 francs l'heure = 530 Francs.


OEMP1 Mise sous palette

Cette formule est associée à la formule M EMP 1 qui doit donc obligatoirement figurer dans le tableau matière.

Le code de la palette donne le poids maximum de cette palette.

En fonction de ce poids maximum, on calcule le nombre de palettes nécessaires.

Dépendance : Nombre de palette.

Exemple

10 500 Exemplaires Poids unitaire 50 g.

Code caisse CA-12 Poids maxi 10 Kg.

(10 500 * 0.050) = 525 Kg.

(525 / 10 ) = 52.5 soit 53 palettes

53 caisses à 10 palettes à l'heure = 5.3 heures

5.3 heure à 100 francs l'heure = 530 Francs.


OEMU1 Mise sous étui

Aucune dépendance.

La quantité de base est la quantité devisée.

Exemple

10 000 Exemplaires

2500 Exemplaires à l'heure

(10 000 / 2500) = 4 heures

(4 * 150f/h) = 600 Francs


OENC1 Calage encarteuse

Le temps de calage de l'encarteuse dépend du nombre de cahiers (plage 1).


OENC2 Encartage

On encarte la quantité devisée.

La cadence de roulage dépend du nombre de cahiers.

Paramétrage

Caractère 1 |
Caractère 2 |
Caractère 3 | Activation de la deuxième dépendance pour la recherche de l'opération de "roulage encartage" en y initialisant la quantité roulée (O/N)
Caractère 4 | Activation de la troisième dépendance pour la recherche de l'opération de "roulage encartage" en y initialisant le nombre de cahiers de plus de 48 pages (O/N)


OEQU1 Calage équerrage

Pour des raisons de chronologie de calcul, cette phase doit être placée après la phase d'impression.

En effet, on tient compte du nombre de feuilles achetées pour l'opération de roulage (gâche comprise) qui est calculée à la phase d'impression.

Cette formule est liée à la rubrique Eq. de l'écran de saisie des données techniques.

N On ignore le calage.

O ou un chiffre : On comptabilise le calage.

Elle nécessite la saisie d'un code machine (massicot).

Il n'y a pas de génération de phase, elle doit être saisie dans la gamme opératoire.


OEQU2 Equerrage

Pour des raisons de chronologie de calcul, cette phase doit être placée après la phase d'impression.

En effet, on tient compte du nombre de feuilles achetées (gâches comprise) qui est calculée à la phase d'impression.

Cette formule est liée à la rubrique Eq. de l'écran de saisie des données techniques.

N On ignore le calage.

O ou un chiffre : On comptabilise le calage.

Elle nécessite la saisie d'un code machine (massicot).

Il n'y a pas de génération de phase, elle doit être saisie dans la gamme opératoire.

La cadence définie au niveau de l'opération est exprimée en Nombre de feuilles coupées à l'heure.

Cette opération prend en compte les dépendances :- Plage 1 : Grammage papier (ou carton)

Calcul du nombre de feuilles à couper : Il est égal à : Nombre de feuilles gâche comprise * Nombre de coupes

Si vous répondez O à la rubrique Eq., on prend 4 coupes par défaut.

Sinon on prend en compte le nombre de coupes saisi.

Exemple

Grammage = 80

Nombre de feuilles achetées = 12 000

Nombre de coupes = 4

Cadence pour un 80 g/m2 = 3 000

Temps calculé = (12 000 * 4) / 6 000

Soit : 8 Heures


OEQU3 Roulage équerrage

Pour des raisons de chronologie de calcul, cette phase doit être placée après la phase d'impression.

En effet, on tient compte du nombre de feuilles achetées (gâches comprise) qui est calculée à la phase d'impression.

Cette formule est liée à la rubrique Eq. de l'écran de saisie des données techniques.

N On ignore le calage.

O ou un chiffre : On comptabilise le calage.

Elle nécessite la saisie d'un code machine (massicot).

Il n'y a pas de génération de phase, elle doit être saisie dans la gamme opératoire.

La cadence définie au niveau de l'opération est exprimée en Nombre de feuilles coupées à l'heure.

Dépendances

Plage 1 | Grammage papier (ou carton)
Plage 2 | Nombre de coupes

Calcul du nombre de feuilles à couper : Il est égal à : Nombre de feuilles gâche comprise

Si vous répondez O à la rubrique Eq., on prend 4 coupes par défaut.

Sinon, on prend en compte le nombre de coupes saisi.

C'est l'opération qui précise la cadence en fonction du nombre de coupes par feuille à effectuer.

Exemple

Grammage = 80

Nombre de feuilles achetées = 12 000

Nombre de coupes = 4

Cadence pour un 80 g/m2 et 4 coupes = 1 500

Temps calculé = 12 000 / 1 500

Soit : 8 Heures


OFOR1 Préparation de la forme

Dépendances Temps par pose

Type ECMA (Code paramètre KMA)

Surfacehors tout de la boite en CM2.

Nombre de poses

La quantité est égale à 1 (un calage).

Cette formule peut représenter :

  • un temps global pour toutes les opérations de préparation de la forme

  • un élément de la préparation, à savoir :

  1. Pose du caoutchouc éjecteur

  2. Pose de la contrepartie

  3. Préparation planche d'injection

Rappel : Il est possible d'intégrer une dépendance supplémentaire à partir de la rubrique code difficulté.

A titre d'exemple, le code de difficulté est utilisé pour préciser la présence ou non de décorticage machine donc présence ou non de la phase 3.


OGAR1 Calcul de la refente papier pour les gardes blanches

On doit calculer la quantité de feuilles à couper.

Le format est indiqué sur la fiche papier (largeur x longueur) (Attention, inversion sur fiche papier !).

Le format fini du document est saisi sur l'écran des données techniques.

On calcule le nombre de morceaux contenus dans la feuille.

Deux gardes sont comptées par ouvrage.

La quantité est le nombre de feuilles roulées gâches comprises.

Paramétrage

Caractères 1 à 2 | Valeur en mm de la rogne en cours de découpe
Caractères 3 à 5 | Formule matière où l'on précise le code papier sur la même phase (normalement M GAR 1 )


OGAR50 Collage des gardes

La particularité de cette formule est de trouver directement la quantité de gardes sur l'entité concernée (TEN A1[31,33] = GAR ou GAB).

Elle sera donc saisie directement sur l'entité de façonnage.

Dépendance

Plage 1 : Quantité de gardes à coller

Quantité : Quantité de gardes à coller plus la gâche de façonnage.


OGAU1 Calage gaufrage

On comptabilise un calage.

Il n'y a pas de dépendance.


OGAU2 Gaufrage

Le nombre de pauses gaufrage doit être saisi dans la valeur 1.


OIMF1 Lavages recto ou machine 1

Le nombre de lavages est égal à : nombre de couleurs total - nombre de couleurs primaires.

S'il y a un vernis, on compte un calage de plus.

Le temps de lavage est donné par machine et par lavage.


OIMF2 Calage des plaques recto ou machine 1

Le temps de calage est donné par machine et par plaque à caler.

Dépendance

Plage 1

Quantité devisée (entité)


OIMF3 Lavages verso ou machine 2

Le nombre de lavages est égal à : nombre de couleurs total - nombre de couleurs primaires.

Si on a les mêmes machines au recto et au verso, on considère que les couleurs primaires recto et verso sont les mêmes et par conséquent on ne compte qu'une fois le lavage de chaque couleur primaire.

S'il y a un vernis au verso et pas de vernis au recto, on compte un calage de plus.

(S'il y a vernis au recto et au verso, on ne fera qu'un lavage du groupe vernis.)

Le temps de lavage est donné par machine et par lavage.


OIMF4 Calage des plaques verso ou machine 2

Utilisée dans O IMF 2

Le temps de calage est donné par machine et par plaque à caler.

Dépendance

Plage 1

Quantité devisée (entité)


OIMF5 Roulage recto ou première machine

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage recto (ou machine 1)

  • Le temps de roulage recto et donc le coût du roulage recto (ou machine 1)

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Quantité devisée * Nombre de tournées

Cartonnage : Nombre de tours hors gâche = Quantité devisée / Nombre de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Elle dépend de

Zone alpha 1 | Type entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur).
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Cette opération dépend de

Plage 1

Grammage papier

Plage 2

Plage de quantité

La quantité prise en compte pour déterminer la bonne plage est égale au nombre de tours hors gâche calculé.

Un paramétrage spécial permet de multiplier cette quantité par 2 dans le cas d'une bascule, ce qui correspond peut-être plus à la réalité.

Plage 3

Quantité devisée (entité)

Elle détermine :

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)


OIMF6 Roulage verso ou deuxième machine

Remarque : En retiration, le calcul n'est pas effectué.

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage verso (ou machine 2)

  • Le temps de roulage verso et donc le coût du roulage verso. (ou machine 2)

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Quantité devisée * Nombre de tournées

Cartonnage : Nombre de tours hors gâche = Quantité devisée / Nombre de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Elle dépend de

Zone alpha 1 | Type entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur ...)
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Cette opération dépend de

Plage 1 | Grammage papier
Plage 2 | Nombre de tours
Plage 3 | Quantité devisée

Elle détermine :

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)


OIMF7 Calage des plaques recto ou machine 1

Note de DVA : ne figure pas dans le répertoire ffle : périmé ?

Utilisée dans O IMF 2.

Le temps de calage est donné par machine et par plaque à caler.

Dépendance

Plage 1

Quantité devisée (entité)


OIMF8 Calage des plaques verso ou machine 2

Note de DVA : ne figure pas dans le répertoire ffle : périmé ?

Utilisée dans O IMF 2.

Le temps de calage est donné par machine et par plaque à caler.

Dépendance

Plage 1

Quantité devisée (entité)


OIMF9 Roulage recto ou première machine

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage recto (ou machine 1)

  • Le temps de roulage recto et donc le coût du roulage recto. (ou machine 1)

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Quantité devisée * Nombre de tournées

Cartonnage : Nombre de tours hors gâche = Quantité devisée / Nombre de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Elle dépend de

Zone alpha 1 | Type entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur ...)
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Cette opération dépend de

Plage 1 | Grammage papier
Plage 2 | Encrage
Plage 3 | Quantité devisée

Elle détermine :

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

  • Le prix du mille de tours

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)


OIMF10 Roulage verso ou deuxième machine

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage verso (ou machine 2)

  • Le temps de roulage verso et donc le coût du roulage verso (ou machine 2).

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Qte devisée * Nb de tournées

Cartonnage : Nombre de tours hors gâche = Qte devisée / Nb de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Dépendances

Alpha 1 | Type d'entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur).
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Dépendances

Plage 1 | Grammage papier
Plage 2 | Encrage
Plage 3 | Quantité devisée

Elle détermine :

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

  • Le prix du mille de tours

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Remarque : Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)


OIMF11 Bon à tirer client

Il s'agit du surcoût dû à la présence du client au bon à tirer.

Cette formule permet de déterminer automatiquement le temps passe au bon à tirer en fonction de la machine d'impression.

Le temps calculé est pris en compte uniquement si vous avez décidé de comptabiliser un surcoût BAT en saisissant un S dans la zone BAT de définition des données techniques.

Aucune dépendance de calcul.


OIMF12 Lavage machine recto

Cette formule permet de prendre en compte un nombre de lavages :

  • Faciles (saisi dans la valeur 1)

  • Normaux (saisi dans la valeur 2)

  • Difficiles (par déduction)

On calcule un temps total de lavage puis tout est ramené à un lavage normal dont le temps unitaire est recalculé.


OIMF13 Lavage machine verso

Le nombre total de lavages est égal au nombre de couleurs verso - le nombre de couleurs primaires verso.

Cette formule permet de prendre en compte un nombre de lavages :

  • Faciles (saisi dans la valeur 1)

  • Difficiles (saisi dans la valeur 2)

  • Normaux (par déduction)

On calcule un temps total de lavage puis tout est ramené à un lavage normal dont le temps unitaire est recalculé.


OIMF14 Calage machine recto

Cette formule permet de prendre en compte un nombre de calages

  • Faciles (saisi dans la valeur 1)

  • Difficiles (saisi dans la valeur 2)

  • Normaux (par déduction)

On calcule un temps total de lavage puis tout est ramené à un lavage normal dont le temps unitaire est recalculé.


OIMF15 Calage machine verso

Cette formule permet de prendre en compte un nombre de calages

  • Faciles (saisi dans la valeur 1)

  • Difficiles (saisi dans la valeur 2)

  • Normaux (par déduction)

On calcule un temps total de lavage puis tout est ramené à un lavage normal dont le temps unitaire est recalculé.


OIMF16 Mise au format Recto ou machine 1

Voir aussi #CF DEG A4[43]

Calcul feuille

On comptabilise automatiquement une mise au format pour le recto (ou machine 1).

Calcul roto

On comptabilise automatiquement une mise au format.

Dépendances

Alpha 1 | Nombre de pages Si roto = nombre de pages de la 1ère ligne du CTRL-F Si roto multibande et caractère 2 = O, on somme le nombre de pages sur toutes les lignes.
Alpha 2 | Conditionnée. Voir paramétrage de la formule
Alpha 3 | Conditionnée. Voir paramétrage de la formule
Alpha 4 | Conditionnée. Voir paramétrage de la formule
Plage 1 | Largeur format fini (en mm)
Plage 2 | Hauteur format fini (en mm)
Plage 3 | Nombre de tours hors gâche

Paramétrage

Caractère 1 | O le code difficulté n'est pas forcé pour la formule Sinon, il peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques.
Caractère 2 | O Si multibande la dépendance nombre de pages est égale à la somme des nombres de pages saisis par CTRL-F
Caractère 3 | O Dépendance alpha 2 = catégorie du produit de l'entité.
Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4


OIMF17 Mise au format Verso ou machine 2

Voir aussi #CF DEG A4[43]

On comptabilise une mise au format verso (ou machine 2), si la machine verso (ou 2) est différente de la machine recto (ou 1).

Pas de dépendance.

En roto, pas de mise au format verso.

La gâche fixe saisie sur l'opération de réglage correspond à la quantité de feuilles nécessaires au réglage.

Dépendances

Alpha 1 |
Alpha 2 | O le code difficulté n'est pas forcé pour la formule Sinon, il peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques.
Alpha 3 | Conditionnée. Voir paramétrage de la formule
Alpha 4 | Conditionnée. Voir paramétrage de la formule
Plage 1 |
Plage 2 |
Plage 3 | Nombre de tours hors gâche

Paramétrage

Caractère 1 |
Caractère 2 |
Caractère 3 |
Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4


OIMF18 Calage des plaques recto ou machine 1

Voir aussi #CF DEG A4[43]

Calcul feuille

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Dépendance

Plage 1

Nombre de plaques à caler

Calcul roto

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler (recto + verso).

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Dépendances

Alpha 1 | Nombre de pages
Alpha 3 | Conditionnée
Plage 1 | Nombre de plaques à caler.
Plage 2 | Largeur format fini (en mm) (1ere Zone du format fini)
Plage 3 | Hauteur format fini (en mm) (2eme Zone du format fini)
Plage 4 | Nombre de tournées

La gâche fixe saisie sur l'opération de calage correspond à la quantité de feuilles nécessaires à chaque calage.

Paramétrage

Caractère 1 | O le code difficulté n'est pas forcé pour la formule Sinon, il peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques.
Caractère 2 | O si on est en multibande, la dépendance nombre de pages est égale à la somme des nombres de pages saisis sur le control F
Caractère 3 |
Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4
Caractère 6 | O Plage 2 = Epaisseur papier (fiche article) N Plage 2 = Largeur format fini (défaut) G Plage 2 = grammage du papier
Caractère 7 | O Gestion du type de prépresse. N ou [blanc] pas de gestion du type de prépresse Si gestion du prépresse, le type de prépresse devient la dépendance alpha2. Prévoir les dépendances T, P, F, N
Caractère 8 |
Caractère 9 | Ajout du nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires (O/N)


OIMF19 Calage des plaques verso ou machine 2

Voir aussi #CF DEG A4[43]

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Dépendance

Plage 1

Nombre de plaques à caler

En roto, tout est compté au recto.

La gâche fixe saisie sur l'opération de calage correspond à la quantité de feuilles nécessaires à chaque calage.

Paramétrage

Caractère 1 |
Caractère 2 | O le code difficulté n'est pas forcé pour la formule. Sinon, le code difficulté peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques
Caractère 3 |
Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4
Caractère 6 | O Plage 2 : Epaisseur papier (fiche article) N Plage 2 : Largeur format fini (défaut)
Caractère 7 | O Gestion du type de prépresse N ou [espace] pas de gestion du type de prépresse Si gestion du prépresse, le type de prépresse devient la dépendance alpha2. Prévoir les dépendances T, P, F, N
Caractère 8 |
Caractère 9 | Ajout du nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires (O/N)


OIMF20 Lavage recto ou machine 1

Le nombre de lavages est saisi dans la zone nombre de couleurs primaires recto.

Pas de dépendance.


OIMF21 Lavage verso ou machine 2

Le nombre de lavages est saisi dans la zone nombre de couleurs primaires verso.

Pas de dépendance.


OIMF22 Calage des changements de plaque machine 1

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto.

La gâche fixe saisie sur l'opération de changement correspond à la quantité de feuilles nécessaires à chaque changement.

Paramétrage

caractère 1 | Mode de calcul du nombre de changements de plaques. N ou rien : Nb de changements = nb de changements de plaques + Nb de repiquages C : Nb de changements = nb de changements de plaques R : Nb de changements = Nb de repiquages
Caractère 2 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4


OIMF23 Calage des changements de plaque machine 2

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto.

La gâche fixe saisie sur l'opération de changement correspond à la quantité de feuilles nécessaires à chaque changement.

Paramétrage

Caractère 2

O Dépendance alpha 4 = demi laize (O/N)

N Pas de dépendance alpha 4


OIMF24 Lavages recto ou machine 1

Roto

Nombre de lavages = 2 * nombre de groupes - nombre total de couleurs primaires.

Feuille

Si machine recto différente machine verso :

Nombre de lavages recto = nombre de groupes - nombre de couleurs primaires au recto

Si machine recto = machine verso :

Nombre de lavages = nombre de groupes – mini (nombre de couleurs primaires)

On considère que les couleurs primaires au recto et au verso sont identiques.

Paramétrage

Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4


OIMF25 Lavages verso ou machine 2

Roto

Nombre de lavages = 0 (voir O IMF 24)

Feuille

Si machine recto différente machine verso :

Nombre de lavages verso = nombre de groupes - nombre de couleurs primaires au verso

Si machine recto = machine verso

Nombre de lavages = 0 (voir O IMF 24)

Paramétrage

Caractère 4 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 5 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4


OIMF26 Roulage roto ou recto feuille

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage recto (ou machine 1)

  • Le temps de roulage recto et donc le coût du roulage recto. (ou machine 1)

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille / roto :

Nombre de tours hors gâche = Qte devisée * Nb de tournées / Nombre de poses maxi saisi sur la décomposition

Cartonnage

Nombre de tours hors gâche = Qte devisée / Nb de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Elle dépend de

Zone alpha 1 | Type entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur).
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Cette opération dépend de

Alpha 1 | Nombre de pages de la 1ère ligne du CTRL-F Si pliage Roto (1 seul type de cahier existe sur le CTRL-F). Si Multibande -Somme de toutes les lignes du CTRL-F (Caractère 3 formule = O)
Alpha 3 | Conditionnée
Plage 1 | Largeur en mm du format fini
Plage 2 | Hauteur en mm du format fini
Plage 3 | Grammage si caractère 6 formule = C on remplace le grammage par le nombre de couleurs (R+V). si caractère 6 formule = R on remplace le grammage par le nombre de couleurs (R).
Plage 4 | Nombre de tours La quantité prise en compte pour déterminer la bonne plage est égale au nombre de tours hors gâche calculé. (Nombre de tours * nombre de tournées si caractère 5 formule = O)

Elle détermine

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

La gâche fixe est comptée pour chaque tournée.

Attention : La gâche fixe est roulée !!!

Remarque : Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)

Exemple

a = Nombre de tours hors gâche

b = Gâche variable de finition

c = Gâche fixe de finition

d = Gâche variable de roulage

e = Gâche fixe de roulage

Nombre de tours hors gâche = a * (1 + b/100) + c = F

Nombre de bonnes feuilles à sortir

F + (1 + d/100) + e : Nombre total de tours à effectuer

En règle générale, la gâche fixe de roulage est égale à 0.

Les gâches fixes sont déjà vendues dans les opérations de réglage et de calage.

Paramétrage

Caractère 1 | V on tient compte de la gâche variable verso. La gâche variable verso est appliquée sur la quantité recto.
Caractère 2 | O le code difficulté n'est pas forcé pour la formule. Sinon, il peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques.
Caractère 3 | O si on est en multibande, la dépendance nombre de pages est égale à la somme des nombres de pages saisis sur le control F
Caractère 4 | O la dépendance alphanumérique 2 est la famille du produit de l'entête. P la dépendance alphanumérique 2 est la nature de la famille de papier.
Caractère 7 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 16 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4
Caractère 17 | O Plage 2 : Epaisseur papier (fiche article) N Plage 2 : Hauteur format fini (défaut)
Caractère 18 | Comment la gâche fixe est-elle exprimée ? O en nombre d'exemplaires N en nombre de feuilles [Valeur par défaut]


OIMF27 Roulage verso

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

  • Le nombre de tours à effectuer pour le roulage recto (ou machine 1)

  • Le temps de roulage recto et donc le coût du roulage recto (ou machine 1)

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille

Nombre de tours hors gâche = Qte devisée * Nb de tournées / Nombre de poses maxi saisi sur la décomposition

Cartonnage

Nombre de tours hors gâche = Qte devisée / Nb de poses

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

  • Une gâche FIXE de finition

  • Une gâche VARIABLE de finition

Elle dépend de

Zone alpha 1 | Type entité (Il y a plus de gâche de finition sur une couverture que sur un cahier d'intérieur ...)
Plage 1 | Quantité devisée
Plage 2 | Quantité roulée

Eventuellement, un code de difficulté spécial peut être paramétré.

Cadence et gâche de roulage

Cette opération dépend de

Alpha 1 | Nombre de pages
Plage 1 | Largeur en mm du format fini
Plage 2 | Hauteur en mm du format fini
Plage 3 | Grammage si caractère 6 formule = C on remplace le grammage par le nombre de couleurs (R+V) si caractère 6 formule = V on remplace le grammage par le nombre de couleurs (V)
Plage 4 | Nombre de tours La quantité prise en compte pour déterminer la bonne plage est égale au nombre de tours hors gâche calculé. (Nombre de tours * nombre de tournées si caractère 5 formule = O)

Elle détermine

  • La cadence machine (en nombre de tours à l'heure)

  • Le coût horaire de l'opération

  • La gâche fixe de roulage (exprimée en nombre de tours)

  • La gâche variable de roulage

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Remarque : Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...).

Paramétrage

Caractère 2 | O le code difficulté n'est pas forcé pour la formule. Sinon, le code difficulté peut être forcé si vous avez accès à sa saisie sur l'écran des données techniques.
Caractère 3 | O si on est en multibande, la dépendance nombre de pages est égale à la somme des nombres de pages saisis sur le control F
Caractère 4 | O la dépendance alpha 2 est la famille du produit de l'entité P la dépendance alpha 2 est la nature de la famille de papier
Caractère 6 | C on remplace le grammage par le nombre de couleurs (R+V) V on remplace le grammage par le nombre de couleurs (V)
Caractère 7 | O Dépendance alpha 3 = présence vernis machine (O/N) N Pas de dépendance alpha 3
Caractère 16 | O Dépendance alpha 4 = demi laize (O/N) N Pas de dépendance alpha 4
Caractère 17 | O Plage 2 : Epaisseur papier (fiche article) N Plage 2 : Hauteur format fini (défaut)
Caractère 18 | Comment la gâche fixe est-elle exprimée ? O en nombre d'exemplaires N en nombre de feuilles [Valeur par défaut]


OIMF28 Lavages recto ou machine 1

Opération : quantité = Selon le caractère 1 de la zone de paramétrage

Une dépendance numérique sur le nombre de lavages dans tous les cas (quelque soit le paramétrage mis en œuvre)

Paramétrage

Caractère 1 | 1 ou [espace] Quantité = 1 lavage T Quantité = Tous les lavages
Caractère 2 | Ajout d'un lavage si présence de vernis (O/N)

En machine Feuille

Si machine recto différente de machine verso :

Nombre de lavages recto = Nombre de groupes - Nombre de couleurs primaires au recto

Si machine recto = machine verso :

Nombre lavages = maxi (Nombre couleurs recto - Nombre couleurs primaires recto, Nombre couleurs verso - Nombre couleurs primaires verso)

En roto simple

Remarque : Le paramétrage machine Noire oui/non se paramètre sur le fichier machine zone tout en bas à droite.

Mettre O ou N

Machine Noire

Nombre de lavages recto : nombre de couleurs recto - nombre de couleurs primaires recto

Si le nombre de couleurs primaires recto est > 0, alors on ajoute le nombre de couleurs primaires recto -1 au nombre de lavages recto.

Nombre de lavages verso : idem recto mais en prenant les couleurs sur le verso

Nombre de lavages = maxi (nombre de lavages recto, nombre de lavages verso)

Machine Quadri

Nombre de lavages recto = nombre de couleurs recto - nombre de couleurs primaires recto

Nombre de lavages verso = nombre de couleurs verso - nombre de couleurs primaires verso

Nombre de lavage = maxi (nombre de lavages recto, nombre de lavages verso)

En multibande

Pour chaque bande, on va faire le calcul du nombre de lavages , en prenant le nombre de couleurs au niveau du tableau des multibandes.

Machine Noire

Pour chaque bande idem roto simple

Le nombre de lavages est égal à la somme des lavages de chaque bande.

Machine Quadri

Première bande : idem calcul roto simple

Deuxième bande :

soit x = nombre maximum de couleurs entre le recto et le verso

soit y = nombre maximum de couleurs primaires entre le recto et le verso

si x < 3 : le nombre de lavages pour la deuxième bande est égal à x

sinon le nombre de lavages pour la deuxième bande est égal à x-y

Le cas Quadri.3 bandes et plus n'est pas prévu, car il n'y a pas beaucoup de machines permettant ce fonctionnement sur le marché.

Le nombre de lavages est égal à la somme des lavages de chaque bande.


OIMF29 Lavages verso ou machine 2

Opération : quantité = Selon le paramétrage (caractère 1)

Une dépendance numérique sur le nombre de lavages dans tous les cas (quelque soit le caractère 1).

Paramétrage

Caractère 1 | 1 ou [espace] Quantité = 1 lavage T Quantité = Tous les lavages
Caractère 2 | Ajout d'un lavage si présence de vernis (O/N)

Roto

Nombre de lavages = 0 (voir O IMF 28)

Feuille

Si machine recto différente de machine verso :

Nombre de lavages verso = nombre de couleurs verso - nombre de couleurs primaires verso

Si machine recto = machine verso :

Nombre de lavages = 0 (voir O IMF 28)


OIMF30 Calage des plaques recto ou machine 1

Voir aussi #CF DEG A4[43]

Calcul feuille

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Dépendance

Plage 1

Nombre de plaques à caler.

Calcul roto

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.(recto + verso).

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Dépendances

Alpha 1 | Nombre de pages
Plage 1 | Nombre de plaques à caler.
Plage 2 | Largeur format fini (en mm) (1ere Zone du format fini)
Plage 3 | Hauteur format fini (en mm) (2eme Zone du format fini)
Plage 4 | Nombre de tours / Tournée

Paramétrage

Caractère 2

O le code difficulté n'est pas forcé pour la formule.

Sinon, il peut être force si vous avez accès à sa saisie sur l'écran des données techniques.

La gâche fixe saisie sur l'opération de calage correspond à la quantité de feuilles nécessaires à chaque calage.

Ces feuilles ne seront pas roulées.


OIMF31 Attente de séchage

Uniquement en bascule.

Concerne des petits tirages, d'où la dépendance sur la quantité roulée au recto.

Un temps de séchage est comptabilisé.

La machine est la machine recto.

Dépendance

Plage 1

Quantité roulée au recto


OIMF50 Réglage recto - devis standard

Calcul feuille : On comptabilise automatiquement un réglage pour le recto.

Calcul roto : On comptabilise automatiquement un réglage.

Dépendances

A1 Type de pli (roto uniquement)

A2 Nature de difficulté selon le type de vernis

N1 Nombre de couleurs

N2 Nombre de groupes utilisés par la machine


OIMF51 Réglage verso - devis standard

Calcul feuille : On comptabilise un réglage verso , si la machine verso est différente de la machine recto.

Calcul roto : Pas de réglage verso.

La gâche fixe saisie sur l'opération de réglage correspond à la quantité de feuilles nécessaires au réglage.

La quantité correspond au nombre de feuilles différents dans une même décomposition.

Dépendances

A1 non utilisé

A2 Nature de difficulté selon le type de vernis

N1 Nombre de couleurs

N2 Nombre de groupes utilisés par la machine


OIMF52 Calage des plaques recto - devis standard

Voir aussi #CF DEG A4[43]

Dépendances

Les dépendances sont les mêmes pour la feuille et la roto. Elles doivent être regroupées en pied comme en dessous.

A1 Type de pli

A2 Nature de difficulté selon le type de vernis (recto/verso, en ligne/hors-ligne)

A3 Nature de difficulté selon le type d'encre (recto/verso, le code encre doit être saisi)

A4 Nature de difficulté selon le type de papier

N1 Nombre de plaques à caler

N2 Nombre de tournées

N3 Nombre de couleurs

N4 Nombre de groupes

Caractère 1

Quantité utilisée (idem caractère 39 de la note OPT_OPE_CAL_RECTO sur le TEN)

O La quantité correspond au nombre de plaques recto.

N (par défaut) La quantité correspond au nombre de calages recto.

Calcul feuille

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Calcul roto

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler (recto + verso).

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.


OIMF53 Calage des plaques verso - devis standard

Voir aussi #CF DEG A4[43]

Dépendances

Les dépendances sont les mêmes pour la feuille et la roto. Elles doivent être regroupées en pied comme en dessous.

A1 Type de pli

A2 Nature de difficulté selon le type de vernis (recto/verso, en ligne/hors-ligne)

A3 Nature de difficulté selon le type d'encre (recto/verso, le code encre doit être saisi)

A4 Nature de difficulté selon le type de papier

N1 Nombre de plaques à caler

N2 Nombre de tournées

N3 Nombre de couleurs

N4 Nombre de groupes

Caractère 1

Quantité utilisée (idem caractère 39 de la note OPT_OPE_CAL_VERSO sur le TEN)

O La quantité correspond au nombre de plaques verso.

N (par défaut) La quantité correspond au nombre de calages verso.

Calcul feuille

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.

Calcul roto

En roto, tout est compté au recto.

La gâche fixe saisie sur l'opération de calage correspond à la quantité de feuilles nécessaires à chaque calage.


OIMF54 Calage des changements de plaque recto - devis standard

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto.

La gâche fixe saisie sur l'opération de changement correspond à la quantité de feuilles nécessaires à chaque changement.

Paramétrage

Caractère 1

Ce paramètre est obligatoire pour un fonctionnement correct pour la boîte pliante, l'étiquette feuille et l'étiquette bobine.

O Le nombre de changement de plaques n'est pas multiplié par le nombre de feuilles de la décomposition.

N par défaut.


OIMF55 Calage des changements de plaque verso - devis standard

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto.

La gâche fixe saisie sur l'opération de changement correspond à la quantité de feuilles nécessaires à chaque changement.


OIMF56 Lavages recto - devis standard

Roto

Nombre de lavages = Nombre de teintes recto + Nombre de teintes verso

Feuille

Si machine recto différente machine verso : Nombre de lavages recto = Nombres de teintes recto

Si machine recto = machine verso : Nombre de lavages = maxi (teintes recto, teintes verso)

On considère que les couleurs primaires au recto et au verso sont identiques.

Caractère 1

O Les groupes utilisés pour les teintes du recto et inutilisés sont lavés.

N (par défaut) Seuls les groupes utilisés pour les teintes du recto sont lavés.


OIMF57 Lavages verso - devis standard

Roto

Nombre de lavages = 0 (voir O IMF 56)

Feuille

Si machine recto différente machine verso : Nombre de lavages verso = Nombre de teintes verso

Si machine recto = machine verso : Nombre de lavages = 0 (voir O IMF 56)

Caractère 1

O Les groupes utilisés pour les teintes du verso et inutilisés sont lavés.

N (par défaut) Seuls les groupes utilisés pour les teintes du verso sont lavés.


OIMF58 Roulage roto ou recto feuille - devis standard

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

Le nombre de tours à effectuer pour le roulage recto

Le temps de roulage recto et donc le coût du roulage recto.

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille / roto : Nombre de tours hors gâche = Qte devisée * Nb de tournées / Nombre de poses maxi saisi sur la décomposition

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

Une gâche FIXE de finition

Une gâche VARIABLE de finition

Paramétrage

Caractère 1

Type de vernis

O Le type de vernis est pris sur VER A1[17].

N Type de vernis offset (par défaut)

Caractère 2

Nombre de couleurs

O Le nombre de couleurs est celui saisi dans l'entité (recto ou verso).

N Le nombre de couleurs est limité par le nombre de couleurs maximum défini sur la machine d'impression (si le nombre de couleurs saisi dans l'entité est supérieur à celui saisi sur la machine, c'est ce dernier qui est pris en compte dans la recherche d'opération standard) (par défaut).

Attention : Le nombre de couleurs est positionné sur l'écran des caractéristiques de la machine (m0_nb_cou_max) et non la rubrique paramétrable Nb de groupes de la machine.

Dépendances

Alpha 1 : Type de pli

Alpha 2 : Nature de difficulté selon le type de vernis (recto/verso, en ligne/hors-ligne)

Alpha 3 : Nature de difficulté selon le type d'encre (recto/verso, le code encre doit être saisi)

Alpha 4 : Nature de difficulté selon le type de papier

Plage 1 : Grammage

Plage 2 : Nombre de tours

Plage 3 : Nombre de couleurs recto (nombre de groupes utilisés)

Plage 4 : Coefficient d'encrage recto

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

La gâche fixe est comptée pour chaque tournée.

Attention : La gâche fixe est roulée !!!

Remarque : Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...)

Exemple

a = Nombre de tours hors gâche

b = Gâche variable de finition

c = Gâche fixe de finition

d = Gâche variable de roulage

e = Gâche fixe de roulage

Nombre de tours hors gâche = a * (1 + b/100) + c = F

Nombre de bonnes feuilles à sortir

F + (1 + d/100) + e : Nombre total de tours à effectuer

En règle générale, la gâche fixe de roulage est égale à 0.

Les gâches fixes sont déjà vendues dans les opérations de réglage et de calage.


OIMF59 Roulage verso - devis standard

La machine a été saisie sur l'écran de définition des données techniques.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

Le nombre de tours à effectuer pour le roulage verso

Le temps de roulage verso et donc le coût du roulage verso

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Qte devisée * Nb de tournées / Nombre de poses maxi saisi sur la décomposition

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

La gâche de finition est donnée par une pseudo-opération (IMF IMF GF) dont le but est de déterminer :

Une gâche FIXE de finition

Une gâche VARIABLE de finition

Paramétrage

Caractère 1 | Type de vernis O Le type de vernis est pris sur VER A1[17]. N Type de vernis offset (par défaut)
Caractère 2 | Nombre de couleurs O Le nombre de couleurs est celui saisi dans l'entité (recto ou verso). N Le nombre de couleurs est limité par le nombre de couleurs maximum défini sur la machine d'impression (si le nombre de couleurs saisi dans l'entité est supérieur à celui saisi sur la machine, c'est ce dernier qui est pris en compte dans la recherche d'opération standard) (par défaut).

Dépendances

Alpha 1 : Type de pli

Alpha 2 : Nature de difficulté selon le type de vernis (recto/verso, en ligne/hors-ligne)

Alpha 3 : Nature de difficulté selon le type d'encre (recto/verso, le code encre doit être saisi)

Alpha 4 : Nature de difficulté selon le type de papier

Plage 1 : Grammage

Plage 2 : Nombre de tours

Plage 3 : Nombre de couleurs verso (nombre de groupes utilisés)

Plage 4 : Coefficient d'encrage verso

Elle détermine

La cadence machine (en nombre de tours à l'heure)

Le coût horaire de l'opération

La gâche fixe de roulage (exprimée en nombre de tours)

La gâche variable de roulage

Nombre de tours gâche comprise

Il est égal au nombre de tours hors gâche auquel on applique le taux de gâche variable de l'opération et la gâche fixe.

Remarque : Par un paramétrage spécial, un coefficient pondérateur peut être appliqué à la gâche fixe à chaque passage.

(La gâche fixe du deuxième passage étant en général inférieure à la gâche du premier, etc. ...).


OIMF60 Réglage vernis hors ligne recto - devis standard

La quantité correspond au nombre de feuilles de la décomposition.

Mêmes dépendances que OIMF50


OIMF61 Réglage vernis hors ligne verso - devis standard

La quantité correspond au nombre de feuilles de la décomposition.

Mêmes dépendances que OIMF51


OIMF62 Calage des plaques vernis recto - devis standard

Mêmes dépendances que OIMF52

Paramétrage

Caractère 1

Quantité utilisée (idem caractère 39 de la note OPT_OPE_VHC_RECTO sur le TEN)

O La quantité correspond au nombre de plaques recto

N (par défaut) La quantité correspond au nombre de calages recto.

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.

Attention, les changements de plaques ne seront pas intégrés dans le nombre total de plaques.


OIMF63 Calage des plaques vernis verso - devis standard

Mêmes dépendances que OIMF53

Paramétrage

Caractère 1

Quantité utilisée (idem caractère 39 de la note OPT_OPE_VHC_VERSO sur le TEN)

O La quantité correspond au nombre de plaques verso

N (par défaut) La quantité correspond au nombre de calages verso.

On compte 1 calage de plaque par tournée.

La valeur 1 fait apparaître le nombre de plaques à caler.


OIMF66 Lavages vernis recto - devis standard

On compte 1 lavage de plaque.

Pas de dépendance


OIMF67 Lavages vernis verso - devis standard

On compte 1 lavage de plaque.

Pas de dépendance


OIMF68 Roulage recto vernis- devis standard

La machine a été saisie sur l'écran de saisie du détail du vernis hors ligne.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

Le nombre de tours à effectuer pour le roulage recto

Le temps de roulage recto et donc le coût du roulage recto.

Calcul du nombre de tours hors gâche à effectuer

Nombre de tours hors gâche = Quantité devisée * Nombre de tournées / Nombre de poses maxi saisi sur la décomposition

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

Même dépendances que OIMF58


OIMF69 Roulage verso vernis - devis standard

La machine a été saisie sur l'écran de saisie du détail du vernis hors ligne.

Il est donc tout à fait inutile de la modifier sur l'écran de calcul de cette formule.

Il s'agit de déterminer :

Le nombre de tours à effectuer pour le roulage verso

Le temps de roulage verso et donc le coût du roulage verso

Calcul du nombre de tours hors gâche à effectuer

Imprimerie feuille : Nombre de tours hors gâche = Quantité devisée * Nombre de tournées / Nombre de poses maxi saisi sur la décomposition

Gâche de finition

A cette quantité de base calculée doit être ajoutée la gâche de finition prévue (qui est exprimée en nombre de feuilles roulées).

Même dépendances que OIMF59


OIMF70 Temps de séchage avant bascule

Anciennement, il portait le code OIMF60.

Limitation

Cette formule est active uniquement pour une impression feuille basculée.

L'opération doit être saisie après le roulage impression pour obtenir un temps de roulage correct.

Dépendances

Aucune

Fonctionnement

Si le temps de séchage avant bascule (paramètre défini dans #CFDEG note TPS_ATT_SECHAGE_BASC) est supérieur au temps de roulage, la différence entre les deux sera traitée.

Voir la note TPS_ATT_SECHAGE_BASC sur #CF DEG


OIMF74 Changement de plaques en repiquage recto

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto.

Paramétrage

Caractère 1

O Le nombre de changements de plaques en repiquage n'est pas multiplié par le nombre de feuilles de la décomposition.

N Le nombre de changements de plaques en repiquage est multiplié par le nombre de feuilles de la décomposition (par défaut).


OIMF75 Changement de plaques en repiquage verso

On compte 1 calage de plaque par changement de plaque.

La valeur 1 fait apparaître le nombre de changements de plaques.

En roto, toutes les plaques sont comptées au recto (voir OIMF74).

Pas de paramétrage


OMAD1 Calage Massicotage droit

Si le code massicot est saisi, on compte un calage.

Dépendance

Plage1

nombre de coupes (saisi manuellement)


OMAD2 Coupe Massicot droit

Le nombre de coupes est saisi dans la valeur 1.

Il y a une dépendance sur le grammage.

Le format à massicoter est le format tirage.

La cadence est donnée en nombre de coupes à l'heure.

Exemple :

10 000 feuilles format tirage

4 coupes

40 000 coupes à effectuer


OMAD3 Coupe massicot droit

Le calcul est classique mis à part que le nombre de coupes est calculé.

On considère que le nombre de coupes est égal au nombre de cahiers composant la feuille.


OMAD4 Calage Massicotage droit

On compte un calage si : il y a bascule et il y a vernis ou pelliculage.

Pour faire de vernis ou le pelliculage, il faut couper la feuille en deux dans le cas d'une bascule.

Attention, cette formule doit être calculée après les phases VER et PEL.

Dépendance

Plage 1

Nombre de coupes


OMAD5 Massicotage droit

On compte un massicotage si : il y a bascule et il y a vernis ou pelliculage.

Pour faire de vernis ou le pelliculage, il faut couper la feuille en deux dans le cas d'une bascule.

Attention, cette formule doit être calculée après les phases VER et PEL.

Dépendances

Grammage

Nombre de coupes

Nombre de feuilles

La cadence donne un nombre de feuilles coupées à l'heure.

Paramétrage

Caractère 1

N ou [blanc] la formule fonctionne comme indiqué ci-dessus.

P on compte le massicotage s'il y a bascule et vernis.

V


OMAD6 Massicotage droit (O MAD 6 = O MAD 9)

On compte un massicotage si le nombre de coupes est saisi.

Le nombre de coupes est saisi manuellement

Dépendances

Grammage

Nombre de coupes

Nombre de feuilles

La cadence donne un nombre de feuilles coupées à l'heure.

La valeur 1 indique le nombre de coupes. Il est saisi manuellement.

La valeur 2 indique un coefficient multiplicateur pour le calcul de la quantité à refendre.


OMAD7 Voir OREF1

Voir OREF1


OMAD9 Massicotage droit (O MAD 6 = O MAD 9)

On compte un massicotage si le nombre de coupes est saisi.

Le nombre de coupes est saisi manuellement.

Dépendances

Grammage

Nombre de coupes

Nombre de feuilles

La cadence donne un nombre de feuilles coupées à l'heure.

La valeur 1 indique le nombre de coupes. Il est saisi manuellement.

La valeur 2 indique un coefficient multiplicateur pour le calcul de la quantité à refendre.


OMAD50 Calage Massicotage droit - devis standard

Le système recherche le code massicot selon les règles suivantes :

  1. Si une ligne de pliage existe dans la décomposition, on retourne le code massicot associé à la première plieuse trouvée (TSC MAS sur le code plieuse)

  2. Si aucune ligne de pliage n’existe, on retourne le code massicot associé au site de l’entité de façonnage.

  3. Si aucune ligne de pliage n'existe et qu'aucune entité de façonnage globale n'existe sur le sous-devis, on retourne le code massicot associé au site de la machine d'impression recto.

Remarque : Fonctionnement similaire au code calcul TI/M

Dépendances

N1 nombre de coupes (calculé automatiquement ou forcé selon le caractère 4)

A1 Présence de vernis UV (O/N)

Paramétrage

Caractère 1 | O il s'agit d'un refente avant impression N il s'agit d'une refente après impression. (par défaut)
Caractère 2 | Equerrage (O/N, N par défaut) Ce caractère est prioritaire sur le caractère 1
Caractère 3 | O ajout d'une coupe pour chacun des côtés dans le cas où le format du papier dépasse le format de tirage. Ces 2 coupes correspondent à une mise au format. N (par défaut) : aucune action.
Caractère 4 | Permettre de forcer le nombre de coupes dans le calcul de la formule de calage massicot après impression Le nombre de coupes est saisi dans la valeur 1 de la LCO MAS. O Le nombre de coupes est forcé par la valeur 1 de la LCO MAS. N Le nombre de coupes est calculé automatiquement (par défaut). 1 Le nombre de coupes est calculé automatiquement et forcé à 1 si la valeur calculée est égale à 0.


OMAD51 Coupe Massicotage droit - devis standard

Le système recherche le code massicot selon les règles suivantes :

  1. Si une ligne de pliage existe dans la décomposition, on retourne le code massicot associé à la première plieuse trouvée (TSC MAS sur le code plieuse)

  2. Si aucune ligne de pliage n’existe, on retourne le code massicot associé au site de l’entité de façonnage.

  3. Si aucune ligne de pliage n'existe et qu'aucune entité de façonnage globale n'existe sur le sous-devis, on retourne le code massicot associé au site de la machine d'impression recto.

Remarque : Fonctionnement similaire au code calcul TI/M

Dépendances

Pour la refente avant et après impression :

N1 Nombre de coupes (calculé automatiquement ou forcé selon caractère 6)

N2 Grammage

N3 Nombre de feuilles à massicoter

A1 Présence de doubles coupes (O/N)

A2 Présence de vernis UV (O/N)

Pour l'équerrage :

N1 Grammage

A1 N

A2 Nature de difficulté selon le type de vernis (Recto/Verso, En Ligne/Hors ligne)

Le nombre de coupes a été fixée arbitrairement à 4.

Paramétrage

Caractère 1

O Refente avant impression

N Refente après impression (par défaut).

Caractère 2

O Équerrage

N Ce caractère est prioritaire sur le caractère 1 (par défaut).

L'équerrage ne sera activé que dans le cas où la feuille est basculée in12 et que le papier n'est pas à refendre avant impression.

Caractère 3

Ce caractère est actif dans le cas d'une refente avant impression

O Ajout d'une coupe pour chacun des côtés dans le cas où le format du papier dépasse le format de tirage.
Ces deux coupes correspondent à une mise au format.

N Aucune action (par défaut)

Caractère 4

Ce caractère définit la quantité qui est calculée.

O La quantité correspondra au nombre de feuilles à massicoter.

Soit le nombre de feuilles toute gâche pour la refente avant impression et l'équerrage

Soit le nombre de feuilles hors gâche de roulage pour la refente après impression

N La quantité correspondra à une nombre de descentes de lame (par défaut).

Caractère 5

Permettre de récupérer la valeur de la poignée dans la cadence de l'opération dont le triplet est saisi dans la formule MAS POI O. La valeur de la poignée peut être également forcé en saisissant la valeur 1 de la LCO #PO.

O La poignée est recherchée dans la cadence de l'opération standard définie dans la formule MAS POI O, avec les dépendances suivantes :

Plage 1 : Grammage

Plage 2 : Quantité de feuilles à massicoter

N La poignée est calculée automatiquement

Caractère 6

Permettre de forcer le nombre de coupes dans le calcul de la formule de roulage massicot après impression

Le nombre de coupes est saisi dans la valeur 1 de la LCO MAS.

O Le nombre de coupes est forcé par la valeur 1 de la LCO MAS.

N Le nombre de coupes est calculé automatiquement (par défaut).

1 Le nombre de coupes est calculé automatiquement et forcé à 1 si la valeur calculée est égale à 0


OMAD52 Calage refente du papier destiné à des gardes blanches (non imprimées)

Dépendance

Plage 1 : nombre de coupes (calculé automatiquement à partir du nombre de poses)

La quantité est égale à 1.


OMAD53 Refente du papier destiné à des gardes blanches (non imprimées)

Dépendance

Plage 1 : nombre de coupes (calculé automatiquement)

La quantité est égale au nombre de feuilles calculé par la formule MPAP50.


OMAR1 Création originaux machine à répéter

Le nombre d'originaux est saisi dans la valeur 1.

Le temps de création des originaux dépend du nombre de couleurs.

S'il s'agit d'un renouvellement, il n'y a pas d'originaux à créer.

Remarque : Dans le cas d'amalgame, le nombre de couleurs peut être différent selon les références.

Il est alors possible de saisir dans le tableau complémentaire lié au devis le nombre de couleurs par référence dans les lignes dont le code commence par #R (Valeur 1).

Si le résultat trouve est nul, on prend le nombre de couleurs total saisi sur l'entité.


OMAR2 Programmation machine à répéter

Quantité d'opérations = nombre de poses.

Il n'y a pas de dépendance de calcul.

La quantité d'opérations est forcée à 0 dans le cas d'un renouvellement.


OMAR3 Préparation machine à répéter

On compte 1 calage pour la machine à répéter.

Dépendance

alpha 1

R si renouvellement


OMAR4 Copie machine à répéter

Les vernis à plat ne donnent pas lieu à une copie.

Dépendance

alpha 1

R si renouvellement


OMON1 Montage

La valeur 1 doit contenir le nombre de pages à monter.

La zone alpha 1 doit contenir le type de page.

L'opération dépend du type de page.


OMON2 Création des originaux

Valeur 1 = nombre de modèles à monter.

L'opération dépend du nombre de couleurs saisi au niveau de l'entité.


OMON3 Fabrication des films

S'il s'agit d'un renouvellement, on ne compte pas de montage.

Si on a au moins autant de typons qu'il y a de poses à réaliser, on ne compte pas de montage.

On n'utilise jamais le ou les typons de base sauf si le nombre de typons est égal ou supérieur au nombre de poses.

La valeur 1 contient le nombre de films à monter. (nombre de poses * nombre de couleurs).

L'opération dépend du nombre total de plaques.


OMON4 Préparation montage manuel

S'il s'agit d'un renouvellement de travail, on ne compte pas de préparation.


OMON5 Montage manuel

S'il s'agit d'un renouvellement de travail, on ne compte pas de montage.

Seuls les couleurs et les vernis non à plat donnent lieu à un montage manuel.


OMON6 Calage plaques recto ou machine 1

Un temps par plaque recto.

Pas de dépendance particulière.

En roto, toutes les plaques sont comptées au recto.


OMON7 Calage plaques verso ou machine 2

Un temps par plaque verso.

Pas de dépendance particulière.

En roto, toutes les plaques sont comptées au recto.


OMON8 Tracé

On compte toujours 1 seul tracé.

Dépendance

Plage 1

Nombre de pages. Permet d'atteindre des temps différents.

Calcul du nombre de pages

Si la décomposition de la feuille imprimée fait apparaître une décomposition en un seul type de cahier (1 ligne dans le tableau), on fait un tracé correspondant à : Nombre de cahiers * Nombre de pages * Nombre de poses

Exemple :

On imprime 4 * 4 pages en 1 pose

On fait un trace 16 pages

On imprime 4 * 4 pages en 4 poses

On fait un trace 64 pages

Si la décomposition fait apparaître plusieurs types de cahiers, on fait un tracé correspondant au nombre total de pages.

Exemple :

On imprime 4 * 4 pages en 1 pose

2 * 8 pages en 1 pose

On fait un tracé 32 pages

En bascule, on multiplie par deux le nombre de pages.

Il n'y a pas de trace pour les changements de plaques.

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.

Paramétrage

Caractère 1 | O on ne traite pas le cas d'une feuille simple (une feuille où il existe une seule ligne dans la décomposition de la feuille imprimée).
Caractère 2 | O on divise le nombre de pages par tournée par 2.
Caractère 3 | O on divise le nombre de pages par tournée par le nombre de bandes.
Caractère 4 | O en bascule, on ne multiplie pas par 2 le nombre de pages.
Caractère 5 | Gestion du type de prépresse P on prend en compte le calcul si le type prépresse = P direct to Plate F on prend en compte le calcul si le type prépresse = F direct to Film T ou [blanc] on prend en compte le calcul si type prépresse.= T traditionnel N on retourne zéro quelque soit le paramétrage de la formule ! pas de prépresse


OMON9 Montage

On compte 1 montage par page et par couleur.

Dépendances

Plage 1 | Nombre de pages
Plage 2 | Nombre de couleurs primaires (total)
Plage 3 | Nombre de couleurs (total)

Le temps de l'opération est donné par page et par couleur.

Si la décomposition de la feuille imprimée fait apparaître une décomposition en un seul type de cahier (1 ligne dans le tableau), on fait un montage correspondant à : Nombre de cahiers * Nombre de pages * Nombre de poses

Exemple :

On imprime 4 * 4 pages en 1 pose

On monte 16 pages

On imprime 4 * 4 pages en 4 poses

On monte 64 pages

Si la décomposition fait apparaître plusieurs types de cahiers, on fait un tracé correspondant au nombre total de pages.

Exemple :

On imprime 4 * 4 pages en 1 pose

2 * 8 pages en 1 pose

On monte 32 pages

Le nombre de films à monter est égal à : Nombre de couleurs * nombre de pages * nombre de tournées

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.

La valeur 2 permet la saisie d'un coefficient multiplicateur de la quantité (prise en compte du nombre de copies).


OMON10 Ozalids

On compte x (saisi sur écran technique) jeux d'ozalids par tournée.

Dépendance

Plage 1

Nombre de pages

Si la décomposition de la feuille imprimée fait apparaître une décomposition en un seul type de cahier (1 ligne dans le tableau), on fait un ozalid correspondant à : Nombre de cahiers * Nombre de pages / Nombre de poses

Exemple :

On imprime 4 * 4 pages en 1 pose

On fait un ozalid 16 pages

On imprime 4 * 4 pages en 4 poses

On fait un ozalid 4 pages

Si la décomposition fait apparaître plusieurs types de cahiers, on fait un ozalid correspondant au nombre total de pages.

Exemple :

On imprime 4 * 4 pages en 1 pose

2 * 8 pages en 1 pose

On fait un ozalid 32 pages

On n'automatise pas le calcul des ozalids pour les changements de plaques ou les repiquages.

Si un temps supplémentaire doit être comptabilisé, on augmentera le nombre d'ozalids sur l'écran technique.

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.


OMON11 Montage pour repiquage

On compte x montages pour repiquage (saisi sur écran technique).

Dépendance

Plage 1

Nombre de pages. (Idem O MON 9)

Le nombre de pages pour repiquage est toujours fixé à 1.

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.

La valeur 2 permet la saisie d'un coefficient multiplicateur de la quantité (prise en compte du nombre de copies).


OMON12 Montage pour changement complet (version)

Le nombre de changements de version est saisi sur l'écran des données techniques.

Le nombre de films à monter est égal à :

Nombre de changements (recto + verso) * Nombre total de Pages / Nombre de tournées arrondi à la valeur > / 2

1 tournée = 1

1.25 tournée = 2

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération (plage 1).

La valeur 2 permet la saisie d'un coefficient multiplicateur de la quantité (prise en compte du nombre de copies).

Comment est calculée cette valeur ?

Si la décomposition de la feuille imprimée fait apparaître une décomposition en un seul type de cahier (1 ligne dans le tableau), on fait un montage correspondant à : Nombre de cahiers * Nombre de pages / Nombre de poses

Exemple :

On imprime 4 * 4 pages en 1 pose

On monte 16 pages

On imprime 4 * 4 pages en 4 poses

On monte 4 pages (On ignore le nombre de poses).

Si la décomposition fait apparaître plusieurs types de cahiers, on fait un tracé correspondant au nombre total de pages.

Exemple :

On imprime 4 * 4 pages en 1 pose

2 * 8 pages en 1 pose

On monte 32 pages


OMON13 Montage film Recto

Paramétrage

Caractère 1 | V Montage pour les versions (changement de plaques)
Caractère 2 | [blanc] On ne distingue pas l'original des autres 1 On ne traite que l'original 2 On ne traite que les suivants
Caractère 3 | O ou [blanc] on prend en compte les tournées. N on ignore les tournées. Utile pour le coût du montage des versions , par cohérence avec le calcul du nombre de plaques pour version.
Caractère 4 | On comptabilise tout le montage au recto si bascule.
Caractère 5 | Gestion du type de prépresse P on prend en compte le calcul si le type prépresse = P direct to Plate F on prend en compte le calcul si le type prépresse = F direct to Film T ou [blanc] on prend en compte le calcul si type prépresse.= T Traditionnel Si le type de prépresse = N (pas de pré-presse), on retourne zéro quelque soit le paramétrage de la formule.

La quantité est le nombre de films à monter.

Dépendances

Plage 1 | Nombre de pages.
Plage 2 | Nombre de couleurs primaires recto
Plage 3 | Nombre de couleurs recto

Remarque sur la dépendance : en multibande, le nombre de couleurs recto est égal au nombre de couleurs recto divisé par le nombre de bandes.

Idem pour les couleurs primaires.

Le temps de l'opération est par film à monter.

On fait un tracé correspondant au nombre total de pages.

Le nombre de films à monter est égal à :

Nombre de couleurs * nombre de pages * nombre de poses * nombre de tournées / 2

Cette formule doit fonctionner avec la formule MON14 (d'ou le /2).

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.

Montage film pour changement de version complète - Recto

Paramétrage

Caractère 1

V C'est une variante de la formule précédente.

On recherche le nombre de films à monter pour un changement de version.

Le nombre de changements de version est saisi sur l'écran des données techniques.

Cette valeur est du ressort du deviseur.

Elle doit tenir compte du nombre de couleurs pour lesquelles la version doit être faite.

Exemple : 3 versions, sur 2 couleurs, vous devez saisir 6 changements de plaques.

Le nombre de films à monter est égal à :

Nombre de versions * nombre de pages * nombre de poses * nombre de tournées / 2

Cette formule a son équivalent en verso (OMON14 - paramètre V).

Calcul du Montage Original - Caractère 2 de la zone Paramètre

On souhaite valoriser différemment le montage de l'original du montage des autres films lorsque l'on est en MULTIPOSES.

La première pose correspond au montage de l'original.

Les suivantes utilisent la machine à répéter à un coût et une cadence différentes.

Exemple :

LAB MON ORI - 1 - Montage Original

LAB MON MAR - 2 - Machine à répéter


OMON14 Montage film Verso

Paramétrage

Caractère 1 | V Montage pour les versions (changement de plaques)
Caractère 2 | Calcul du montage original [blanc] On ne distingue pas l'original des autres 1 On ne traite que l'original 2 On ne traite que les suivants
Caractère 3 | O ou [blanc] on prend en compte les tournées N on ignore les tournées Utile pour le coût du montage des versions, par cohérence avec le calcul du nombre de plaques pour version.
Caractère 4 | Libre
Caractère 5 | Gestion du type de pré-presse T ou [blanc] traditionnel. on prend en compte le calcul si type prépresse.= T P direct to Plate. on prend en compte le calcul si le type prépresse = P F direct to Film. on prend en compte le calcul si le type prépresse = F N pas de prépresse. On retourne zéro quelque soit le paramétrage de la formule

La quantité est le nombre de films à monter.

Dépendances

Plage 1 | Nombre de pages
Plage 2 | Nombre de couleurs primaires verso
Plage 3 | Nombre de couleurs verso

Remarque sur la dépendance : en multibande, le nombre de couleurs verso est égal au nombre de couleurs verso divisé par le nombre de bandes.

Idem pour les couleurs primaires

Le temps de l'opération est par film à monter..

On fait un tracé correspondant au nombre total de pages.

Le nombre de films à monter est égal à :

Nombre de couleurs * nombre de pages * nombre de poses * nombre de tournées / 2

Cette formule doit être active avec la formule OMON13 (d'ou le /2).

La valeur 1 fait apparaître le nombre de pages pris en compte pour la recherche de l'opération.

Montage film pour changement de version complète - Verso

C'est une variante de la formule précédente.

On recherche le nombre de films à monter pour un changement de version.

Le nombre de changements de version est saisi sur l'écran des données techniques.

Cette valeur est du ressort du deviseur.

Elle doit tenir compte du nombre de couleurs pour lesquelles la version doit être faite.

Exemple : 3 versions, sur 2 couleurs, vous devez saisir 6 changements de plaques.

Le nombre de films à monter est égal à :

Nombre de versions * nombre de pages * nombre de poses * nombre de tournées / 2

Cette formule a son équivalent en recto (OMON13 - paramètre V)

Calcul du Montage Original - Caractère 2 de la zone Paramètre

On souhaite valoriser différemment le montage de l'original du montage des autres films lorsque l'on est en MULTIPOSES.

La première pose correspond au montage de l'original.

Les suivantes utilisent la machine à répéter à un coût et une cadence différentes.

Exemples :

LAB MON ORI - 1 - Montage Original

LAB MON MAR - 2 - Machine à répéter


ONUM1 Numérotage sur machine d'impression 1

Il s'agit d'un calage supplémentaire pour le numérotage sur la machine d'impression 1.

Le temps de calage dépend de la machine d'impression.


ONUM3 Numérotage sur machine d'impression 2

Il s'agit d'un calage supplémentaire pour le numérotage sur la machine d'impression 2.

Le temps de calage dépend de la machine d'impression.


ONUM5 Calage numérotage sur machine spéciale

Le temps de calage dépend de la machine choisie.


ONUM6 Numérotage sur machine spéciale

Dépendance de l'opération

Plage 1 | Nombre de feuillets
Plage 2 | Quantité de roulage

Calcul du nombre de feuillets

Si le nombre de feuillets n'est pas saisi, il est calculé par la formule suivante :

Quantité devisée sur entité / Quantité devisée sur le devis

Calcul du nombre de poses

Si le nombre de poses n'est pas saisi, il sera calculé en fonction du format maxi de la machine de numérotage

(format maxi machine / format tirage).

Quantité de roulage : Quantité devisée devis * Nombre de feuillets / Nombre de poses


OOZA1 Réalisation des Ozalids recto

Remarque : Il existe les formules O-1PO-3 ,O-1PO-6, O-MON-10 si cette formule ne convient pas.

Le nombre de jeux d'ozalids est saisi sur l'écran des données techniques.

On produit également des épreuves (ozalids) pour les changements de version et les plaques de retirage.

La quantité d'ozalids recto est égale à :

(Nombre de tournées + Nombre de changements de version recto + Nombre de repiquages recto) par le nombre de jeux.

Il existe une dépendance sur le nombre de couleurs recto.

Dans le cas d'une bascule, la dépendance est le nombre maxi de couleurs entre recto et verso.

Paramétrage

Caractère1 | Nombre de jeux à ne pas compter. Par défaut = 0 On comptabilisera alors un coût pour les jeux supplémentaires d'ozalids.
Caractères 2 | On tient compte de la machine définie sur la formule (O/N) Si non, on utilise la machine recto. Si O, les caractères 3 à 8 fournissent le code machine.
Caractères 3 à 8 | Code machine utilisée si le caractère 3 est positionné à O.


OOZA2 Réalisation des Ozalids verso

Remarque : Il existe les formules O-1PO-6, O-MON-10 si cette formule ne convient pas.

Le nombre de jeux d'ozalids est saisi sur l'écran des données techniques.

On produit également des épreuves (ozalids) pour les changements de version et les plaques de retirage.

La quantité d'ozalids verso est égale à :

(Nombre de tournées + Nombre de changements de version verso + Nombre de repiquages verso) par le nombre de jeux.

Il existe une dépendance sur le nombre de couleurs verso.

Dans le cas d'une bascule, on ne compte rien au verso.

Paramétrage

Caractère 1 | Nombre de jeux à ne pas compter. Par défaut = 0 On comptabilisera alors un coût pour les jeux supplémentaires d'ozalids.
Caractère 2 | On tient compte de la machine définie sur la formule (O/N) Si non, on utilise la machine verso. Si O, les caractères 3 à 8 fournissent le code machine
Caractère 3 à 8 | Code machine utilisée si le caractère 3 est positionné à O.


OPEL1 Calcul pelliculage à la surface

On part de la quantité devisée, du format rognée de l'ouvrage.

L'épaisseur du dos et la largeur des remplis doivent être saisis.

Le prix de la matière est donné en Frs/m2.


OPER1 Perforation

Il s'agit d'un calage supplémentaire pour la perforation sur la machine d'impression 1.


OPER3 Perforation

Il s'agit d'un calage supplémentaire pour la perforation sur la machine d'impression 2.

Le temps de calage dépend de la machine d'impression.


OPHO1 Photogravure

Le nombre de modèles doit être saisi sur le tableau détail opérations. Il est égal à 1 par défaut.

Le temps par modèle est donné par l'opération qui tient compte du nombre total de couleurs saisi sur l'entité.


OPHO2 Photogravure

En automatique, la valeur 1 contient le nombre de films à faire.

La quantité est égale au nombre de pages.

La cadence est donnée en nombre de films fabriques par heure. Elle dépend du nombre total de couleurs.


OPHO3 Photogravure fonction de la surface de la page

On calcule le nombre d'opérations en fonction du nombre de pages et du nombre de couleurs.

(Quantité = Nombre de pages * Nombre de couleurs)

L'opération est donnée en nombre de films à l'heure.

Il y a une dépendance sur la surface de la page.

Cette formule permet de calculer les films avec leur négatif.

La valeur 2 permet la saisie d'un coefficient multiplicateur de la quantité (prise en compte du nombre de copies).


OPHO4 Photogravure - Création des originaux

Si des typons sont fournis par le client, on ne fait pas d'originaux.

Le nombre de modèles est saisi dans la valeur 1.

L'opération est donnée par original à créer.

Elle dépend du nombre total de couleurs.

AMALGAME

Attention, dans le cas d'un amalgame, le nombre de couleurs étant égal au nombre total de couleurs, si une référence est en 2 couleurs et une autre en 4 couleurs, on indiquera dans l'entité 4 couleurs.

Pourtant, dans ce cas précis, il y aura 4 + 2 originaux à créer, d'où l'erreur.

Il est donc possible de saisir, dans le tableau complémentaire, le nombre de couleurs de chaque référence et ainsi d'éviter ce désagrément !!!

Paramétrage des lignes complémentaires

Type paramètre | LCO
Code paramètre | doit commencer par #R
Zone alpha 1 | à partir du caractère 10 : NNNNONNNN
Zone alpha 2 | Nombre de couleurs

Ces lignes complémentaires doivent être saisies sur le premier écran du devis en postulat de départ.


OPHO5 Calcul film pour photogravure

Pas de calcul si renouvellement.

Attention, cette formule travaille SANS DUPLI.

Tous les films seront créés comme l'original.

Calcul du nombre de films :

Nombre de films = (nombre total de pages / 2 ) * (nombre de couleurs recto + nombre de couleurs verso)

L'opération est donnée par film.

Dépendance

Plage 1

Surface finie de l'ouvrage (en cm2)


OPIQ1 Calage piqueuse

Le nombre de cahiers à piquer est automatique. (Voir O PIQ 3 pour saisie manuelle).

1 calage avec 1 temps et 1 taux horaire.

Dépendances

Plage 1 | Nombre de cahiers
Plage 2 | Largeur (en mm) du produit fini
Plage 3 | Longueur (en mm) du produit fini

Remarque : Le nombre de poses piqûre est géré via le code de difficulté.


OPIQ2 Piqûre

Le nombre de cahiers à piquer est automatique. (voir O PIQ 4 pour la même formule automatique).

Quantité piquée = Quantité devisée.

Dépendances

Valeur alpha 1 | Nombre de poses
Plage 1 | Nombre de cahiers
Plage 2 | Largeur (en mm) du produit fini
Plage 3 | Longueur (en mm) du produit fini
Plage 4 | Quantité piquée

Remarque : Le nombre de poses piqûre est géré via le code de difficulté.


OPIQ3 Calage piqueuse

Le nombre de cahiers à piquer est saisi manuellement. (voir O PIQ 1 pour la même formule automatique).

1 calage avec 1 temps et 1 taux horaire.

Dépendances

Plage 1 | Nombre de cahiers
Plage 2 | Largeur (en mm) du produit fini
Plage 3 | Longueur (en mm) du produit fini

Remarque : Le nombre de poses piqûre est géré via le code de difficulté.


OPIQ4 Piqûre

Le nombre de cahiers à piquer est saisi manuellement. (voir O PIQ 2 pour la même formule automatique).

Quantité piquée = Quantité devisée.

Dépendances

Valeur alpha 1 | Nombre de poses
Plage 1 | Nombre de cahiers
Plage 2 | Largeur (en mm) du produit fini
Plage 3 | Longueur (en mm) du produit fini
Plage 4 | Quantité piquée

Remarque : Le nombre de poses piqûre est géré via le code de difficulté.


OPLA1 Calage plaques recto ou machine 1

Un temps par plaque recto.

Pas de dépendance particulière.

En roto, toutes les plaques sont comptées au recto.

Paramétrage

Caractère 1 | N ou [blanc] La machine utilisée est la machine d'impression. Attention aux statistiques de production. O La machine d'impression est utilisée en tant que dépendance alpha4.
Caractère 2 | O Gestion du type de prépresse N ou [blanc] pas de gestion du type de prépresse Si gestion du prépresse, le type de prépresse devient la dépendance alpha1. Prévoir les dépendances T, P, F, N
Caractère 3 |
Caractère 4 |
Caractère 5 | Ajout d'un nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires (O/N)
Caractère 6 | La machine d'impression verso est utilisée en dépendance alpha 4 (O/N, N par défaut)


OPLA2 Calage plaques verso ou machine 2

Un temps par plaque verso.

Pas de dépendance particulière.

En roto, toutes les plaques sont comptées au recto.

Paramétrage

Caractère 1 | N ou [espace] La machine utilisée est la machine d'impression. Attention aux statistiques de production. O La machine d'impression est utilisée en tant que dépendance alpha4.
Caractère 2 | O Gestion du type de prépresse. N ou [blanc] pas de gestion du type de prépresse Si gestion du prépresse, le type de prépresse devient la dépendance alpha1. Prévoir les dépendances T, P, F, N
Caractère 3 |
Caractère 4 |
Caractère 5 | Ajout d'un nombre de plaques supplémentaires en cas de dépassement d'un nombre de tours maximum défini sur chaque machine d'impression dans les informations complémentaires (O/N)


OPLA3 Temps supplémentaire de copie de plaques recto

Lors de la copie de plaque, un temps supplémentaire est compté quand il existe plusieurs poses à dupliquer.

On compte autant de temps supplémentaires que de nombre de poses -1 saisi dans la décomposition de la feuille imprimée.

Pas de dépendance particulière.

En roto, tous ces temps supplémentaires sont comptés au recto.

Paramétrage

Caractère 1

N ou [blanc] La machine utilisée est la machine d'impression. Attention aux statistiques de production.

O La machine d'impression est utilisée en tant que dépendance alpha4.

La valeur 2 permet la saisie d'un coefficient diviseur de la quantité (prise en compte du nombre de copies).


OPLA4 Temps supplémentaire de copie de plaques au verso

Lors de la copie de plaque, un temps supplémentaire est compté quand il existe plusieurs poses à dupliquer.

On compte autant de temps supplémentaires que de nombre de poses -1 saisi dans la décomposition de la feuille imprimée.

Pas de dépendance particulière.

En roto, tous ces temps supplémentaires sont comptés au recto.

Paramétrage

Caractère 1

N ou [blanc] La machine utilisée est la machine d'impression. Attention aux statistiques de production.

O La machine d'impression est utilisée en tant que dépendance alpha4.

La valeur 2 permet la saisie d'un coefficient diviseur de la quantité (prise en compte du nombre de copies).


OPLA5 Perforation + Mise en repérage Recto

On compte un temps par page à monter (1 temps par page et par couleur).

Le nombre de pages est égal au nombre de pages de l'entité / 2 par le nombre de couleurs recto.

On ignore le nombre de poses car la machine duplique.

Dépendance

Nombre de couleurs. recto

Remarque sur la dépendance :

En multibande, la valeur de la dépendance est égale à la somme des couleurs recto de chaque bande divisée par le nombre de bandes.

En multibande, chaque ligne de la décomposition de la feuille donne un nombre de pages.

Chaque ligne est attachée à une bande : on obtient le nombre de couleurs.


OPLA6 Exposition plaque Formule adaptée pour le multibande

Le châssis se déplace à différents endroits de la plaque et à chaque déplacement, on isole partiellement la plaque (de la surface du châssis).

Quantité = Nombre de pages de la feuille imprimée / 2 * Nombre de tournées * Nombre de poses * Nombre de couleurs

Dépendances

longueur format fini

largeur format fini

Remarques :

En multibandes, chaque ligne de la décomposition de la feuille donne un nombre de pages.

Chaque ligne est attachée à une bande : on obtient le nombre de couleurs.

En bascule, le nombre de couleurs est égal au max.(Nombre de couleur recto, Nombre de couleurs verso).

Paramétrage

Caractère 1

N ou [blanc] La machine utilisée est la machine d'impression. Attention aux statistiques de production.

O La machine d'impression est utilisée en tant que dépendance alpha4.


OPLA7 Perforation + Mise en repérage Verso

On compte un temps par page à monter (1 temps par page et par couleur).

Le nombre de pages est égal au nombre de pages de l'entité / 2 par le nombre de couleurs verso.

On ignore le nombre de poses car la machine duplique.

Dépendance

Nombre de couleurs. verso

Remarque sur la dépendance :

En multibandes, la valeur de la dépendance est égale à la somme des couleurs verso de chaque bande divisée par le nombre de bandes.

En multibandes, chaque ligne de la décomposition de la feuille donne un nombre de pages.

Chaque ligne est attachée à une bande : on obtient le nombre de couleurs.


OPLA8 Copie plaque pour vernis sur machine séparée

Cette formule concerne les vernis sur machine séparée (non en ligne).

Elle s'appuie sur les infos complémentaires suivantes :

Vernis Recto/Verso (valeur numérique 1)

Coefficient d'encrage (valeur numérique 2)

La machine de la ligne complémentaire

Si présence de vernis (1 = recto ou verso , 2 = Recto + Verso)

Le nombre de copies plaques est égal au nombre de tournées x Valeur 1 si le coefficient d'encrage est < à 100 %.

Le nombre de copies plaques = 0 si coefficient d'encrage = 100.

Il n'existe pas de dépendance.


OPLA50 Copie plaques recto - devis standard

Un temps par plaque recto.

Dépendances

Alpha 1 : Type de pré-presse

Plage 1 : Nombre de plaques

En roto, toutes les plaques sont comptées au recto.


OPLA51 Copie plaques verso - devis standard

Un temps par plaque verso.

Dépendances

Alpha 1 : Type de pré-presse

Plage 1 : Nombre de plaques

En roto, toutes les plaques sont comptées au recto.


OPLA52 Traceur - devis standard

On compte un traceur par tournée.

Dépendances

Plage 1 : nombre de pages

Si la décomposition fait apparaître plusieurs types de cahiers, on fait un traceur correspondant au nombre total de pages.


OPLI1 Calage pliage

Les opérations de pliage sont générées automatiquement en fonction des types de pli saisis sur la décomposition de la feuille.

Dépendances

A1 | Type de pli. PLI A1[37,39] si paramétré, sinon Type de pli saisi
N1 | Nombre de pages
N2 | Grammage du papier utilisé
N3 | Nombre de poses pliage


OPLI2 Pliage (Roulage)

Les opérations de pliage sont générées automatiquement en fonction des types de pli saisis sur la décomposition de la feuille.

Dépendances

A1 | Type de pli. PLI A1[40,42], sinon Type de pli saisi
N1 | Nombre de pages
N2 | Quantité à plier
N3 | Grammage du papier utilisé
N4 | Longueur engagée


OPLI3 Calage plieuse

Dépendances

Type de pli (génération auto)

Nombre de poses pliage


OPLI4 Coef = Nombre de poses pliées à la feuille.


OPLI50 Calage plieuse

OPLI50 Calage plieuse - devis standard

Dépendances

Alpha 1 : type de pli

Plage 1 : Nombre de poses au pliage

Plage 2 : Grammage

Plage 3 : Dimension engagée

Valeur alpha 1

Difficulté du pli défini sur le code pli (PLI A1[37,39]) ou par défaut le code pli.


OPLI51 Pliage

Dépendances

Alpha 1 : type de pli

Plage 1 : Nombre de poses au pliage

Plage 2 : Grammage

Plage 3 : Dimension engagée

Plage 4 : Quantité pliée (Nombre d'exemplaires ou métrage linéaire selon le paramétrage)

Unité de mesure :

Forçage par la note NUM4_NB_EXEMPLAIRES sur la formule : Nombre d'exemplaires pliés (paramétrage prioritaire)

#CF DEG A4[37] = O : Nombre d'exemplaires pliés

#CF DEG A4[37] = N : Métrage linéaire

Valeur alpha 1

Difficulté du pli pour le roulage défini sur le code pli (PLI A1[40,42]) ou par défaut le code pli.


ORAI1 Rainage

Il s'agit d'un temps de calage supplémentaire dans la phase impression.

Ce temps est attaché à la PREMIERE machine d'impression.


ORAI3 Rainage

Il s'agit d'un temps de calage supplémentaire dans la phase impression.

Ce temps est attaché à la DEUXIEME machine d'impression.


ORAI5 Calage rainage sur machine spéciale

Le temps de calage dépend de la machine choisie.


ORAI6 Rainage sur machine spéciale

Dépendance de l'opération

Plage 1 | Grammage
Plage 2 | Quantité de roulage

Calcul du nombre de coupes

Si le nombre de coupes n'est pas saisi, il sera calculé en fonction du format maxi de la machine de numérotage.

(format maxi machine / format tirage)

Quantité de roulage : Quantité devisée devis * Nombre de coupes / Nombre de poses


ORAI7 Rainage sur machine spéciale

Dépendance de l'opération

Plage 1 | Grammage
Plage 2 | Quantité de roulage

On tient compte du nombre de tours Gâche de finition incluse.


OREF1 Refente

Pour des raisons de chronologie de calcul, cette phase doit être placée après la phase d'impression.

En effet, on tient compte du nombre de feuilles achetées (gâches comprise) qui est calculé à la phase d'impression.

Cette formule est liée à la rubrique définissant le nombre de formes imprimantes dans le format papier.

Cette formule est prise en compte lorsqu'il y a plus d'une forme imprimante dans le format papier.

Elle nécessite la saisie d'un code machine (massicot).

Il n'y a pas de génération de phase, elle doit être saisie dans la gamme opératoire.

Dépendance

Plage 1

Nombre de coupes


OREF10 Refente

Il s'agit des coupes intermédiaires.

Le nombre de coupes est saisi manuellement.

Le nombre de poignées est saisi manuellement.

L'opération dépend du grammage, du nombre de coupes à effectuer et de la surface du papier acheté en cm2.

La surface correspond à la surface de la feuille commandée divisée par le nombre de poses dans le format papier.

Le conditionnement du papier permet de déterminer le nombre de paquets à couper (qui sera indiqué dans la valeur 2).

La quantité de base est égale à la quantité devisée.

Exemple

10 000 feuilles de papier.

Papier conditionné par 250 feuilles

On compte 8 coupes à la feuille

On comte 9 poignées

(10 000 * 9) / 250 * 8 = 2880 coupes


OREF2 Refente

Il s'agit d'une refente avant impression (Le papier ou le carton doit être refendu avant l'impression).

Attention, pour des raisons de chronologie de calcul du devis, la phase REF doit être placée après la phase impression.

Le nombre de coupes est égal au nombre de formes imprimantes dans le format papier moins 1.

Le grammage du papier (ou carton) fait varier la cadence de coupe du massicot (dépendance de l'opération en plage 1).

Le nombre de feuille à couper est égal au nombre de feuilles calculé dans la phase impression (multiplié par le nombre de coupes).

La cadence de l'opération est donnée en nombre de feuilles coupées à l'heure.

Dépendance de l'opération

Plage 1


OREF3 Refente

Cette formule nécessite la saisie du nombre de coupes au niveau du détail opération.

Si on ne saisit pas le nombre de coupes, on ne comptabilise pas de calage.

Dépendances

Plage 1 | grammage
Plage 2 | nombre de coupes


OREF4 Refente après impression

Cette formule nécessite la saisie du nombre de coupes au niveau du détail opération.

Elle nécessite la saisie d'un code machine (massicot).

La cadence définie au niveau de l'opération est exprimée en nombre de feuilles coupées à l'heure.

Cette opération prend en compte les dépendances

Plage 1 | Grammage papier (ou carton)
Plage 2 | Nombre de coupes

Calcul du nombre de feuilles à couper :

Il est égal à : Nombre de feuilles gâche comprise

C'est l'opération qui précise la cadence en fonction du nombre de coupes par feuille à effectuer.

Exemple :

Grammage = 80

Nombre de feuilles achetées = 12 000

Nombre de coupes = 4

Cadence pour un 80 g/m2 et 4 coupes = 1 500

Temps calculé = 12 000 / 1 500

Soit : 8 Heures

Le grammage pris en compte peut être forcé dans le tableau complémentaire (après contre collage, par exemple).


OREF6 Refente

Il s'agit de la refente avant impression.

Le nombre de coupes est saisi manuellement.

L'opération dépend du grammage, du nombre de coupes à effectuer et de la surface du papier acheté en cm2.

La surface correspond à la surface de la feuille commandée.

Le conditionnement du papier permet de déterminer le nombre de paquets à couper (qui sera indiqué dans la valeur 2).

Exemple :

10 000 feuilles de papier.

Le format tirage est 21 x 29.7

Papier conditionné par 250 feuilles

Le format du papier est 70 x 100

On compte 8 coupes à la feuille

10 000 / 250 * 8 = 320 coupes


OREF8 Refente

Il s'agit de la refente après impression.

Le nombre de coupes est saisi manuellement.

L'opération dépend du grammage, du nombre de coupes à effectuer et de la surface du papier acheté en cm2.

La surface correspond à la surface de la feuille commandée divisé par le nombre de poses dans le format papier.

Le conditionnement du papier permet de déterminer le nombre de paquets à couper (qui sera indiqué dans la valeur 2).

La quantité de base est égale à la quantité devisée * par le nombre de formes imprimante dans le format papier.

Exemple :

10 000 feuilles de papier.

Le format tirage est 21 x 29.7

Papier conditionné par 250 feuilles

Le format du papier est 70 x 100

On compte 8 coupes à la feuille

Soit 9 coupes à la feuille

(10 000 * 9) / 250 * 8 = 2880 coupes


OROG2 Rogne 3 faces

Dépendance de l'opération

Plage 1 | Grammage
Plage 2 | Quantité de roulage

Calcul du nombre de coupes : Le nombre de coupes est fixé à 3.

Quantité de roulage : Quantité devisée devis * Nombre de coupes / Nombre de poses


OROG3 Rogne 3 faces (Trilatéral)

Le fichier des opérations donne un nombre de poignées à l'heure.

Calcul du nombre de poignées :

Hauteur de coupe du trilatéral / Epaisseur de l'entité = Nombre maxi d'entités par poignée

L'épaisseur de l'entité est calculée en prenant en compte le nombre de pages, le grammage, la main du papier de l'entité.

La main du papier dépend de la sous-famille du papier.

Le nombre d'entités est arrondi au 5 inférieur.

Quantité devisée * coefficient / Nombre d'entités par poignée = Nombre de poignées

La valeur 1 indique le coefficient.

Ce coefficient . est à 1 si pas saisi. Il peut être à 0.5 (par ex.) si on ne coupe que la moitié des entités.

Dépendance

Nombre de poignées

Paramétrage

Caractère 1

O sur les caractères 2 et 3, on spécifie la valeur de l'arrondi (1 si on ne veut pas d'arrondi).

Par défaut, l'arrondi est égal à 5.


ORT1 Recherche de teinte

L'opération indique un temps par teinte à rechercher.

Nombre de teintes à rechercher = nombre total de couleurs - nombre de couleurs primaires

Il n'y a pas de dépendances.

Paramétrage

Caractère 1 | R on comptabilise uniquement la recherche sur la machine recto. V on comptabilise uniquement la recherche sur la machine verso.
Caractère 2 | R on force la machine avec la machine d'impression recto. V on force la machine avec la machine d'impression verso.


S####AU Formule paramétrable

La quatrième dépendance alphanumérique permet de rechercher automatiquement le code matière.


S####MA Formule effectuant une recherche dans le tarif.

Paramétrage

Caractères 1 à 3 | Code tarif La recherche utilise le tiers, le code produit, les dates d'applications et la quantité. On ramène les gâches fixes et marges de la fiche produit.
Caractère 4 | Quantité prise en compte 1 ou [blanc] Quantité saisie 2 Quantité de l'entité 3 Quantité du devis


S####Q1 Formule standard

Cette formule peut être saisie sur n'importe quelle phase de sous-traitance.

Elle met automatiquement à 1 la quantité de produits sous-traités.

Exemple d'utilisation :

Sous-traitance de la forme de découpe. On va sous-traiter le fabrication d'une forme de découpe.

Sous-traitance composition


S####QF Formule standard

Cette formule peut être saisie sur n'importe quelle phase.

La quantité sous-traitée est forcée au nombre de feuilles roulées hors gâche auquel on ajoute les gâches de finition.


S####QP Formule standard

Cette formule peut être saisie sur n'importe quelle phase.

La quantité sous-traitée est forcée au poids papier devisé.

Paramétrage

Caractère 1 | O Utilisation du fichier tarif pour la recherche du prix unitaire N Le prix unitaire est le prix de l'article
Caractères 2 à 4 | Code tarif pour la recherche du prix
Caractère 5 | Le code fournisseur intervient-il dans la recherche du tarif (O/N)


S####QT Formule standard

Cette formule peut être saisie sur n'importe quelle phase.

La quantité sous-traitée est forcée à la quantité devisée.

Exemple d'utilisation :

On sous-traite le pelliculage de couvertures de bandes dessinées.

La quantité de couvertures à faire sous-traiter est égale à la quantité devisée.

On sous-traite l'emballage unitaire de produit.

La quantité de produit à emballer est égale à la quantité devisée.


S####ST

Cette formule peut être utilisée sur toutes les phases.

Elle ne fait que calculer le total de la sous-traitance.

La quantité de produits sous-traités doit être saisie.


SBRO1 Sous-traitance brochage (Liasses et carnets)

Coût fixe

Le coût fixe est donné par l'opération STR BRO CAL.

Cette opération doit être saisie sans machine.

Le code difficulté doit être égal à NOR.

Dépendance de l'opération

Plage 1

Nombre de postes

Coût variable

Le coût variable est donné par l'opération STR BRO ROU.

Cette opération doit être saisie sans machine.

Le code difficulté doit être égal à NOR.

Dépendances de l'opération

Plage 1 | Nombre de postes
Plage 2 | Quantité devisée

Calcul du nombre de postes

(Pour les liasses et carnets)

Nombre de postes = Quantité devisée entité / Quantité devisée devis

Calcul de la quantité

Quantité = quantité devisée (devis)


SPEL1 Pelliculage

Le calcul est fait sur le format fini de l'ouvrage.

Surface calculée = longueur * 2 * largeur

La surface est exprimée en m2.

Le code produit donne le prix du pelliculage au m2.


SPEL2 Pelliculage

La base de calcul est le format de la feuille imprimée.

On part du nombre de feuilles hors gâche + gâche de finition.

La surface est exprimée en m2.

Le prix au m2 est recherché dans le fichier tarif

(plage = surface totale à pelliculer, c'est à dire surface unitaire de la feuille de format tirage * nombre de feuilles).

Tarif fonction de : fournisseur, code article, plage de surface, date d'application.

Paramétrage

Caractère 1

Comment la gâche fixe de façonnage est-elle calculée ?

O en nombre d'exemplaires

N en nombre de feuilles [Valeur par défaut]


SPEL3 Pelliculage

Le calcul est fait au m2.

Le prix du pelliculage doit donc être donné (par le code matière saisi) en francs par mètre carré.

La surface est calculée sur la base de la feuille de papier (ou carton) commandée.

La quantité de base est la quantité de feuilles hors gâche à laquelle on applique les gâches de finition.

Si le paramètre P/V (pelliculage/vernis) est saisi sur le détail de l'entité, il doit préciser :

Caractère 1

0 si pas de pelliculage

1 si pelliculage recto

2 si pelliculage recto/verso


SPEL4 Pelliculage

La base de calcul est le format de la feuille imprimée.

On part du nombre de feuilles hors gâche + gâche de finition.

La surface est exprimée en m2.

Le prix au m2 est recherché dans le fichier tarif (plage = surface de la feuille imprimée).


SPLA2

Notes sur la formule

LCOPRXFLI | Permet de rechercher un prix sur une LCO paramétrable 10, 12 Code de la LCO contenant le prix.
LCOQTEFLI | Permet de soustraire au prix trouvé une valeur dépendante du nombre de couleur 10, 11 Nombre de couleurs 12, 17 Seuil du prix pour détermination si on applique la valeur inférieure ou la valeur supérieure à la règle de calcul 18, 23 Valeur inférieure 24, 29 Valeur supérieure


SSQF

Paramétrage

Caractère 1

Comment la gâche fixe de façonnage est-elle calculée ?

O en nombre d'exemplaires

N en nombre de feuilles [Valeur par défaut]


SVER1 Calcul du vernis en sous-traitance

C'est un calcul à la surface.

La base de calcul de la surface est le format ouvert ou le format hors tout de l'ouvrage.

Le code produit saisi donne le prix du pelliculage au mètre carré.

Les gâches de finition sont ajoutées aux gâches standard.


SVER2 Calcul du vernis en sous-traitance

Le calcul est fait au m2.

Le prix du vernis doit donc être donné (par le code matière saisi) en francs par mètre carré.

La surface est calculée sur la base de la feuille de papier (ou carton) commandée.

La quantité de base est la quantité de feuilles hors gâche à laquelle on applique les gâches de finition.

Si le paramètre P/V (Pelliculage/vernis) est saisi sur le détail de l'entité, il doit préciser :

Caractère 2

0 si pas de vernis

1 si vernis recto

2 si vernis recto/verso

Les gâches de finition sont ajoutées aux gâches standard.


SVER3 Calcul du vernis en sous-traitance

Le calcul est fait au m2.

Le prix du vernis doit donc être donné (par le code matière saisi) en francs par mètre carré.

La surface est calculée sur la base du format de tirage


SVER4 Vernis

La base de calcul est le format de la feuille imprimée.

On part du nombre de feuilles hors gâche + gâche de finition.

La surface est exprimée en m2.

Le prix au m2 est recherché dans le fichier tarif.

(plage = surface totale à vernir, c'est à dire surface unitaire de la feuille de format tirage * nombre de feuilles)

Tarif fonction de : fournisseur, code article, plage de surface, date d'application.

Paramétrage

Caractère 1 | Comment la gâche fixe de façonnage est-elle calculée ? O en nombre d'exemplaires N en nombre de feuilles [Valeur par défaut]
Caractère 8 | O Les gâches sont exprimées en exemplaires et pas en nombre de feuilles
Caractère 9 | O La recherche du tarif se fait selon la recherche standard et non plus la recherche simplifiée Le code tarif est saisi dans la zone "Code tarif achat" de la formule


Papeterie

Cette page recense les paramètres utilisés pour la papeterie.

Devis onduleur | Commandes clients | Bons de livraison
Production |  |

(1) Indique que ce paramètre n'est pas réservé à la papeterie mais qu'il a été créé à cette occasion.

Devis onduleur

don Option Odp | Saisie simplifiée des devis papeterie |
don note DP_CREER_DEVIS_ENV | Lors de la création d'une nouvelle référence papeterie, créer automatiquement les demandes clients dans les autres environnements que celui en cours |
don note DP_REFEMBCLI_DEFAUT | Référence emballage client par défaut |
don note DP_VISU_DEVIS_ENV | Ouvrir la visualisation des demandes client associées à la nouvelle référence papeterie créée |
don note _SUP_SQL_CLIENT | Complément de sélection des clients autorisés pour la saisie des devis | (1)
don note _SUP_SQL_NUM_DEMCLI | Complément de sélection pour la recherche des numéros de demandes client | (1)
#CF DKP note ACTIVER_PAPETERIE | Activation du mode papeterie pour la saisie des devis onduleurs |
voluedit_devis_ondu option Odp | Edition d'offre de prix pour devis papeterie |

Commandes clients

table cde9_e | Entêtes des commandes clients pour la papeterie |
table cde9_l | Lignes des commandes clients pour la papeterie |
cde option Op1 | Écran dédié de la saisie de commande papeterie |
cde note PAP_INIT_DTECH | Initialisation des données techniques par rapport à la dernière commande client/produit standard |
cde note PAP_RECOP_ELT_TECH | Recopie des éléments techniques à chaque ligne d'une même découpe |
cde note PAP_D_MANDRIN_MERE | Diamètre du mandrin mère |
cde note PAP_TOL_BOB_MERE | Tolérance de découpe du mandrin mère |
cde note LIB_DET | Libellé de description de chaque ligne de découpe |
cde note SAISIE_ADL | Saisie de l'adresse de livraison par ligne de découpe |
cde note ACR_SLIG_DEC | Type et code du paramètre de lancement de l'édition des AR |
v_cdem Option Op1 | Visualisation des commandes en mode papeterie Accès aux packages cde9_e et cde9_l En marge des tables cde1 et cde2, il est désormais possible de lancer des actions (Ctrl K) en utilisant les données issues des tables cde9_e et cde9_l. |
voluedit_acr argument -N_DEC | Passage en argument d'un numéro de commande papeterie et d'un numéro de ligne de découpe |
voluedit_acr option Op1 | Accusé de réception pour la papeterie |
voluedit_acr option Ord | Lors de l'édition/réédition, les lignes de découpe sont regroupées. |
voluedit_acr option O9e | L'édition de l'AR portera uniquement sur la présentation (table cde9_e) |
QRP A1[2] | L'utilisateur peut modifier l'unité par défaut (O/N, N par défaut) |
QRP A1[3,4] | Unité par défaut pour la bobine |
QRP A1[5,6] | Unité par défaut pour le papier |
#CF ATL note MODE_PAPETERIE | Mode papeterie (O/N, N par défaut) |
Note METHODE_REMPL_POIDS | Méthode pour remplir la zone lc_poids en saisie de commande La recherche du paramétrage se fait dans l'ordre suivant : 1-Code statistique 1 (uniquement le CS1) 2-Famille – sous-famille 3-Famille La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire. | (1)
Note UNITE_VENTE | Permet d'initialiser la zone lc_unvent en saisie de commande. La recherche du paramétrage se fait dans l'ordre suivant : 1-Code statistique 1 (uniquement le CS1) 2-Famille – sous-famille 3-Famille La présence de la note FORCE_ZONE_CDE2_TYC sur le TYC est obligatoire. | (1)
TYC note FORCE_ZONE_CDE2_TYC | Permet de forcer la valeur de certaines zones de cde2 (O/N, N par défaut) | (1)

Livraisons

blv option Op3 | BL en mode papeterie |
voluedit_blv option Op3 | BL en mode papeterie (donne accès à la liste du colisage) |
voluedit_blv note TYPE_TSC_PAP_BOBM | Code TSC contenant la bobine mère |
FAM note MODIF_POIDS_BLV | L'utilisateur peut modifier le poids de la ligne du bon de livraison (O/N, N par défaut) | (1)

Production

volupalette option Op1 | Option papeterie
volupalette notes COUPE et LAIZE | Indices de début et de fin
volupalette note TYPE_EVENEMENT | Indices de début et de fin pour le code événement
qte_prod option Op1 | Option papeterie
#CF CAB note _USING_CONTENEUR | Using du code conteneur


Code comptable du client

Ceci est une ébauche de fiche d'installation.

Pour l'instant, elle se borne à recenser le paramétrage existant.

La racine du code comptable est contenue dans la fiche par défaut du client, du prospect ou du fournisseur (colonne cl_cpt)

Si code comptable sur le prospect par défaut initialisation du code à la création de la fiche.

Dans la fiche société, il faut paramétrer le type de compta pour que le code comptable de la fiche tiers soit alimenté en automatique.

#CF ATL | #CF ATL A2[45] | Contrôle champ identifiant comptable sur adresses secondaires N Pas de saisie (par défaut) 1 Saisie non contrôlée 2 Saisie contrôlée avec rapatriement des infos de la fiche client en création uniquement
 | #CF ATL A2[47] | Cadrage du code client dans le code comptable G gauche et seul D Radical + code client (par défaut)
 | #CF ATL A3[1] | Numérotation automatique du code comptable CLIENT (O/N)
 | #CF ATL A3[2,5] | Radical du code comptable CLIENT par défaut (exemple 411)
 | #CF ATL A3[6] | Numérotation automatique du code comptable FOURNISSEUR (O/N)
 | #CF ATL A3[7,10] | Radical du code comptable FOURNISSEUR par défaut (exemple 401)
 | #CF ATL A3[11] | Affectation du code comptable lors du passage d'un Prospect en Client Le code comptable affecté sera alors généré selon le mode de fonctionnement de celui du client.
 | #CF ATL A3[59] | Pouvoir saisir le code comptable de la fiche tiers en minuscule (O/N, N par défaut)
 | #CF ATL A4[52] | Caractère de début du code CLIENT à recopier lors de la création du code comptable
 | #CF ATL A4[53] | Caractère de fin du code CLIENT à recopier lors de la création du code comptable
 | #CF ATL A4[59] | Caractère de début du code FOURNISSEUR à recopier lors de la création du code comptable
 | #CF ATL A4[60] | Caractère de fin du code FOURNISSEUR à recopier lors de la création du code comptable
VAS | VAS A3[1] | Numérotation automatique du code comptable CLIENT (O/N)
 | VAS A3[2,5] | Radical du code comptable par défaut (pour le client). Exemple : 411
 | VAS A3[6] | Numérotation automatique du code comptable FOURNISSEUR (O/N)
 | VAS A3[7,10] | Radical du code comptable par défaut (pour le fournisseur). Exemple : 401
 | VAS A3[11] | Affectation du code comptable lors du passage d'un Prospect en Client (O/N) Le code comptable affecté sera alors généré selon le mode de fonctionnement de celui du client.
#CF CLI | A2[1,60] | Code 8 = Code comptable
cli | Occ | Permet de saisir un même code comptable pour plusieurs clients différents
 | Ocn | Affichage et numérotation du code comptable en fonction du code adresse validité (VAS)
 | Oic | Désactive la génération automatique du code comptable
 | Omi | Interdiction de modifier le code comptable si celui-ci est géré automatiquement lors de la création
 | Orc | Concatène le code client avec le radical comptable
cde | Ocb | Concatène le code client avec le radical comptable
int_cpt | Occ | Recherche du code client à partir de son code comptable (uniquement si type de fichier = 1)
#CF TRF | PARAM_SAGE_1000 | Paramétrage du radical de compte de tiers et du type de nature (FAC/AVO) 21,23 Radical à ajouter au compte comptable client (exemples : C , 411 ..) 24 Type de Nature de Pièce
v_jdv | Orde de tri | 7 = Code comptable client
ed_traites | Occ | Désactive l'édition du code comptable client


Nouvelles zones dans la table des paramètres

Ces nouvelles zones s'inscrivent dans le cadre de la mise en place d'un squelette pour l'installation chez un nouveau client.

Nouvelles zones dans la table par02 :

p2_ordre : critère d'ordre

p2_classe : gestion de classe (paramètre de type CLR)

p2_sclasse : gestion de sous-classe (paramètre de type SCL)

p2_zc3 : zone numérique 3

p2_zc4 : zone numérique 4

p2_actif : paramètre actif O/N (ce code sert principalement dans les visualisations)

Les zones Classe, Sous-classe et Ordre sont regroupées dans un même cadre au niveau de la saisie des paramètres.

Un paramètre permet de rendre ce cadre accessible ou non.

La zone Actif est accessible également par paramétrage.

Par défaut, ces zones ne sont pas accessibles.

Elles peuvent être paramétrées dans la saisie simplifiée des paramètres .

Elles peuvent être utilisées comme critère de recherche dans la visualisation des paramètres.

Dans cette visualisation, toutes ces zones (sauf le code Actif) sont disponibles en critère de tri.

Le paramètre de type #LI permet d'établir une relation hiérarchique entre la classe et la sous-classe (table liens_tables).

Paramétrage

Paramètre | Paramétrage | Exemple | Explication
CLR | Classes | CLR CLA | On crée une classe, par exemple CLA
SCL | Sous-classes | CLS SOU | On crée une sous-classe, par exemple SOU
#CF ATL | Note LIEN_CLASSE_SCLASSE | LIEN_CLASSE_SCLASSE LCS | On nomme le lien LCS qui sera défini ci-dessous.
#LI | Lien entre classes et sous-classes | # LI LCS : A1[4] = O A2 = Lien entre classe et sous-classe A3[1,18] = par02 - A3[19,21] = CLR A4[1,18] = par02 - A4[19,21] = SCL | On crée et on définit le lien LCS : La saisie du détail du lien est possible. Titre de la fenêtre de saisie Nom de la table mère Nom de la table fille
USE | Notes DROIT_ACCES_P2_ACTIF et DROIT_ACCES_P2_CLASS | DROIT_ACCES_P2_ACTIFO DROIT_ACCES_P2_CLASSO | Accès aux zones Classe, Sous-classe et Ordre. Accès à la zone Actif
Saisie simplifiée des paramètres | Nouveau type de contrôle 02 : Recherche et contrôle par rapport à la table liens_tables Saisie du type paramètre de classe Le type de lien est paramétré sur le #CF ATL. | C_fr*Ordre*p2_ordre***** C_fr*Actif ?*p2_actif***** C_fr*Classe*p2_classe**N*01*CLR* C_fr*Sous-classe*p2_sclasse**N*02*CLR* | Saisie de la zone Ordre Saisie de la zone Actif ? Saisie de la Classe avec interrogation par F7 et test d'existence (01) sur le paramètre de type CLR. Saisie de la Sous-classe avec et test d'existence (02) d'existence dans la table liens_tables pour le paramètre de type CLR.


Réception des bobines par codes à barres

Cette nouvelle gestion remplace les programmes suivants :

brc

r_bob

s_bob

e_bob

g_bob (programme désactivé - non documenté)

recep_cde_cab

Cette gestion est accessible à partir de la V. 4.0.91.2.

La réception des palettes par codes à barres reprend le même principe de fonctionnement.

1/2 - Principe de fonctionnement

Saisie des commandes fournisseurs (G_cdef)

A la saisie de la ligne d'achat, 3 possibilités :

- Calcul du nombre de bobines à recevoir et création de celles-ci (valeur par défaut)

- Calcul du nombre de bobines à recevoir, création de celles-ci et édition des étiquettes

- Pas de création de bobines ni d'édition des étiquettes

Edition VoluEdit des commandes fournisseurs (G_voluedit_edicf)

Edition des bobines créées lors de la saisie de la commande fournisseur

Réception des bobines fournisseurs par code-barres (G_recep_bob_cab)

2 écrans de saisie

1er écran

Numéro de bon de réception

Numéro du bon de réception (BRU)

FIN : Fin de la saisie

F8 : Changement du type de réception

Entrée : Création d'un nouveau bon de réception

99999999 : Modification d'un bon de réception créé précédemment

Code fournisseur

Code fournisseur du bon de réception

Réf. BL. Fournisseur

Référence fournisseur du bon de réception

2ème écran

Numéro bobine

Numéro de la bobine réceptionnée

FPB : Fin provisoire du bon de réception

FDB : Fin définitive du bon de réception

F8 : Aide à la saisie du CAB de la bobine

F9 : Saisie des différents CAB pour construire le CAB de la bobine

Laize bobine

Laize de la bobine réceptionnée

Poids bobine (si #CF ATL A1[22] = 1 ou blanc)

Poids de la bobine réceptionnée

Longueur bobine (si #CF ATL A1[22] = 2)

Longueur de la bobine réceptionnée

Ecran de saisie des différents CAB

Titre du CAB

FIN : Fin de la saisie

Saisie des sorties et des entrées de bobines par code-barres (G_s_e_bob_cab)

Consommation des bobines (A3[1] = S)

Numéro OF

Numéro de l'OF concerné par la consommation

FIN : Fin de la saisie

Numéro bobine

Numéro de la bobine consommée

FCO : Fin de consommation de l'OF

F8 : Aide à la saisie du CAB de la bobine consommée

Réintégration des bobines (A3[1] = E)

Numéro OF

Numéro de l'OF concerné par la réintégration

FIN : Fin de la saisie

Numéro bobine

Numéro de la bobine à réintégrer

FRO : Fin de réintégration de l'OF

F8 : Aide à la saisie du CAB de la bobine à réintégrer

Diamètre ou Poids

Diamètre ou poids restant de la bobine à réintégrer

0 si totalité

Transfert des bobines (A3[1] = T)

Magasin de consommation

Magasin concerné par le transfert

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro bobine

Numéro de la bobine à transférer

FTB : Fin de transfert sur le magasin de consommation

F8 : Aide à la saisie du CAB de la bobine à transférer

Consommation des bobines (A3[1] = C)

Numéro OF

Numéro de l'OF concerné par la consommation

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro bobine

Numéro de la bobine consommée

FCO : Fin de consommation de l'OF

F8 : Aide à la saisie du CAB de la bobine consommée

Diamètre ou Poids

Diamètre ou poids consommé de la bobine consommée

0 si totalité

Réintégration des bobines (A3[1] = R)

Magasin de stockage

Magasin concerné par la réintégration

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro bobine

Numéro de la bobine à réintégrer

FRB : Fin de réintégration sur le magasin de stockage

F8 : Aide à la saisie du CAB de la bobine à réintégrer

Diamètre ou Poids

Diamètre ou poids restant de la bobine à réintégrer

0 si totalité

2/2 - Paramétrage

Saisie des commandes fournisseurs - G_cdef

Obp | Réception prévisionnelle des bobines
Oeb | Edition des étiquettes de bobine - Nécessite l'option Obp
Oec | Message de confirmation avant l'édition des étiquettes de bobine - Nécessite l'option Obp
Oen | Edition d'une étiquette neutre - Nécessite l'option Obp
Oi1 | Choix de l'imprimante étiquette demandé qu'une fois - Nécessite l'option Obp
Ove | Edition VoluEdit des étiquettes de bobine - Nécessite l'option Obp
CONFIG_RECEP_BOBINE | 21,26 Type et code paramètre de la configuration de la réception des bobines - Facultatif - #CF BOB par défaut
ETIQBOBINE_IMP | 21,23 Imprimante pour édition automatique des étiquettes de bobine 24 Demande de choix de l'imprimante des étiquettes ou imprimante automatique N Demande (Valeur par défaut) O Automatique

Edition VoluEdit des commandes fournisseurs - G_voluedit_edicf

Obp | Réception prévisionnelle des bobines - Option Ove obligatoire
A4[3] | Activation des titres du groupe Bobine ligne de commande (O/N, N par défaut)
CONFIG_RECEP_BOBINE | 21,26 Type et code paramètre de la configuration de la réception des bobines - Facultatif - #CF BOB par défaut

Ajout du groupe Bobine ligne de commande dans le groupe Ligne commande.

Réception de bobine fournisseur par saisie codes à barres

G_recep_bob_cab

Même programme pour les palettes

Saisie par codes à barres des sorties et des entrées de bobines

G_s_e_bob_cab

Même programme pour les palettes

Configuration de la réception des bobines

#CF BOB ou autre

Nouveau paramètre de configuration

Configuration de la saisie des commandes fournisseurs

#CF CDF A1[29,31]

Type de mouvement d'entrée en commande par défaut des bobines - Facultatif

ENT par défaut

Exemple : BEC

Type de commande fournisseur

TYF A1[33] | Type de commande fournisseur (B=Bobine, par défaut / P=Palette) - Facultatif
TYF A2[18,20] | Type de mouvement d'entrée en commande du TYF des bobines - Facultatif Exemple : BEC

Préparateur

PRP A1[1,3]

Code utilisateur

Le login (USE A1[1,8]) donne le code utilisateur (code du paramètre USE).

Le code utilisateur (PRP A1[1,3]) donne le code préparateur (code du paramètre PRP).


Réception des palettes par codes à barres

Cette gestion est accessible à partir de la V.4.0.170.2

Elle reprend le même principe de fonctionnement que la Réception des bobines par codes à barres.

1/2 - Principe de fonctionnement

Réception des palettes fournisseurs par code-barres (G_recep_bob_cab)

2 écrans de saisie

1er écran

Numéro bon réception

Numéro du bon de réception (BRC)

FIN : Fin de la saisie

F8 : Changement du type de réception

Entrée : Création d'un nouveau bon de réception

99999999 : Modification d'un bon de réception créé précédemment

Code fournisseur

Code fournisseur du bon de réception

Réf. BL. Fournisseur

Référence fournisseur du bon de réception

2ème écran

CAB étiquette

CAB de l'étiquette de la palette réceptionnée

FPB : Fin provisoire du bon de réception

FDB : Fin définitive du bon de réception

F9 : Saisie des différents CAB

Quantité

Quantité du papier réceptionné

Poids

Poids du papier réceptionné

Laize

Laize du papier réceptionné

Coupe

Coupe du papier réceptionné

Ecran de saisie des différents CAB

Titre du CAB

FIN : Fin de la saisie

Saisie des sorties et des entrées de palettes par code-barres (G_s_e_bob_cab)

Transfert des palettes (A3[1] = T)

Magasin de consommation

Magasin concerné par le transfert

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro palette

Numéro de la palette à transférer

FTB : Fin de transfert sur le magasin de consommation

F8 : Aide à la saisie du CAB de la palette à transférer

Consommation des palette (A3[1] = C)

Numéro OF

Numéro de l'OF concerné par la consommation

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro palette

Numéro de la palette consommée

FCO : Fin de consommation de l'OF

F8 : Aide à la saisie du CAB de la palette consommée

Quantité

Quantité consommée de la palette consommée

0 si totalité

Réintégration des palettes (A3[1] = R)

Magasin de stockage

Magasin concerné par la réintégration

FIN : Fin de la saisie

F8 : Changement du type de saisie des sorties et des entrées

Numéro palette

Numéro de la palette à réintégrer

FRB : Fin de réintégration sur le magasin de stockage

F8 : Aide à la saisie du CAB de la palette à réintégrer

Quantité

Diamètre ou poids restant de la palette à réintégrer

0 si totalité

2/2 - Paramétrage

Réception de palette fournisseur par saisie codes- barres

G_recep_bob_cab

Même programme que pour les bobines

Saisie par codes-barres des sorties et des entrées de palettes

G_s_e_bob_cab

Même programme que pour les bobines

Configuration de la réception des palettes

#CF PAL ou autre

Nouveau paramètre de configuration

Type de commande fournisseur

TYF A1[33]

Type de commande fournisseur (B=Bobine, par défaut / P=Palette) - Facultatif

Préparateur

PRP A1[1,3]

Code utilisateur

Le login (USE A1[1,8]) donne le code utilisateur (code du paramètre USE).

Le code utilisateur (PRP A1[1,3]) donne le code préparateur (code du paramètre PRP).


Autorisations - Permissions - Options

Ce chapitre n'est pas réellement une fiche d'installation mais plutôt un tableau de bord de la terminologie employée.

Les options

Le programme gestion_options est essentiellement destiné à Volume Software pour renseigner les options de votre application.

Les options indiquent vos droits d'accès à telle ou telle fonctionnalité de VoluPack / VoluPrim.

Les options sont étroitement liées aux termes de votre contrat / licence.

Attention : ces options n'ont rien à voir avec les options de fonctionnement (-Oxx) du paramètre de lancement des programmes.

Les permissions

1 Le programme permis permet à l'administrateur de définir qui a le droit de faire quoi, au moyen d'une table des codes actions.

Les codes actions sont au nombre de 7 :

ACC | Accès aux champs
CMA | Création / Modification / Annulation d'enregistrements
MEN | Accès aux fonctions
MOD | Modification des champs
ONG | Onglets
TOU | Touches
WIN | Applications Windows

Les codes actions sont divisés en arguments. Chaque argument définit une permission pour une action bien précise au sein d'un programme.

Exemple 1

La permission ACC CL_CRED définit le droit d'accès à la zone Montant d'autorisation du crédit (dans la fiche client).

Dans cet exemple, ACC est l'un des 7 codes actions, tandis que ACC CL_CRED est l'argument qui définit le droit d'accès à cette zone.

Exemple 2

La permission TOU BLV1_CTRL_F définit le droit d'accès à la touche Ctrl F dans l'entête du BL.

Dans cet exemple, TOU est l'un des 7 codes actions, tandis que BLV1_CTRL_F est l'argument qui définit la permission d'utiliser cette touche.

Pour chaque action particulière, vous pouvez indiquer les droits via le programme permis :

  • Le type d'identification : la permission que vous définissez est-elle valable pour un groupe, un utilisateur ou par défaut (tout le monde) ?

  • Le code : si la permission est valable pour un groupe ou un utilisateur, indiquez le code de ce groupe ou de cet utilisateur.

  • Le type et le code du paramètre de lancement du programme concerné.

  • Le code action : l'un des 7 codes ci-dessus.

  • L'argument : l'action précise faisant l'objet de la permission.

  • La permission : vous pouvez accorder la permission, la refuser, ou la soumettre à un mot de passe.

  • Le mot de passe : dans le cas où la permission est assujettie à un mot de passe, indiquez ici le mot de passe qui sera requis.

  • Enfin, pour chaque permission, la touche Ctrl N vous permet de saisir des notes, un genre de mémo pour vous, administrateur.

Au départ, les permissions ne sont accordées à personne : il vous appartient donc de les attribuer à chacun en fonction de ses prérogatives.

Si vous n'accordez aucune permission, personne ne pourra rien faire !

Vous pouvez accorder une permission à tout un groupe, tout en la supprimant pour un utilisateur de ce groupe : le système prend toujours en compte le niveau le plus fin.

Les permissions sont enregistrées dans la table permissions.

2 En marge de la gestion des permissions, le paramètre USE définit, lui aussi, des permissions et des autorisations pour des actions bien particulières.

3 Pour chaque paramètre de lancement de programme, on peut aussi indiquer des droits d'exécution par utilisateur, ou par groupe, ou pour tout le monde.

Ces droits ce définissent au moyen des notes

ACCES_OUI pour indiquer que l'accès est permis

ACCES_NON pour indiquer que l'accès est interdit

ACCES_PWD pour indiquer que l'accès est subordonné à la saisie d'un mot de passe.

Ces notes sont suivies du login de l'utilisateur, ou du nom du groupe, ou du mot GLOBAL (tout le monde)

Les mots de passe sont enregistrés dans le paramètre PWD.

Plus d'information ici.

4 Enfin, plusieurs programmes permettent de contrôler finement la saisie des champs. Plus de détails ici.

Les modifications de champs sont enregistrées dans la traçabilité. Plus de détails ici.

Les autorisations

A partir des programmes de visualisation, l'utilisateur peut déclencher certaines actions par le biais des touches de fonction.

Là encore, ces actions peuvent être contrôlées par des autorisations.

Ces autorisations sont contrôlées au moyen de la valeur alpha 4 des programmes de visualisation concernés et éventuellement par des notes commençant par AUTORISE_TOUCHE.

Voir un exemple dans la visualisation des commandes clients : dans la valeur alpha 4 - dans les notes.


Gestion des palettes box

Suggestion d'un de nos clients, le 16/12/2008.

ATTENTION - il s'agit d'une ébauche de documentation qui sera mise en forme ultérieurement.

Cette gestion est utilisée pour les palettes bois consignées ou en location.

La palette bois doit être suivi en stock :

mp_param[17] = I

mp_param[38] = X

les lieux de rangements 1 et 2 doivent être renseignés ou utiliser le TSC 291.

Ajouter le TSC 231 :

sur le BL

sinon sur la cde

sinon sur le produit livré

sinon sur nom0

Définir en #CF BLV A1[41,43] le TMV correspondant à la sortie de stock.

Gérer les régularisations de stock par G_stk0.


Paramétrage des factures proforma

Paramétrage d'un code échéance PRO ECH A2[5] = O (Oui).

Il faut que le TYC PRO existe, mais il n'est pas utilisé. TYC A3[26] = O.

Paramétrer une entrée au menu : Facture PROFORMA : voluedit_facn, option Opo

Le modèle VoluEdit doit gérer le top facturation = 1 pour le titre FACTURE PROFORMA.

Fonctionnement :

On ouvre en modification la commande client sur laquelle on souhaite faire une facture proforma :

1°) Noter le code actuel du code échéance

2°) Le remplacer par le code ech PRO

3°) Valider la commande

4°) Facturer cette commande avec le menu facture proforma (menu spécifique #ED PRO ci dessus)

5°) Remodifier immédiatement le code échéance de cette commande

Déroulé :

3°) Valider la commande

4°) Facturer cette commande avec le menu facture proforma (menu spécifique #ED PRO ci dessus)

Edition de la facture proforma

5°) Remodifier immédiatement le code échéance de cette commande

1°) Noter le code actuel du code échéance

2°) Le remplacer par le code échéance PRO


Cadencements de fabrication

Pré-requis : devis standard sous GENERO

Permettre de saisie des cadencements de fabrications sur les lignes de commandes.

Permettre de générer automatiquement des cadencements de fabrication lors du transfert de devis en commande.

Point 1 : Transfert du devis en commande

Point 2 : Saisie des cadencements (depuis ligne de commande ou transfert devis)

Point 3 : Edition des AR

Point 4 : Visualisation des commandes

Point 5 : Déclaration d'entrée en stock

Point 6 : Transfert vers système de planification (voir étude Preactor)

Point 7 : Edition des OF (voluedit_oex_tc)

Paramétrage

cde

A4[23] Type de contrôle d'autorisation de modification du prix de la ligne de commande

A4[59] Accès en consultation seule à la saisie des cadencements

note S_F2_CONF_CAD_FAB Complément de requête sur la table cde_cad_fab permettant de conditionner la demande de confirmation de suppression des cadencements de fabrication à la présence des lignes respectant ce critère

note PAR_LCT_GEN_CAD_FAB Type et code du paramètre de lancement de la génération des cadencements de fabrication

note _SUP_REQ_CDE_CAD_FAB Supplément de requête sur la table cde_cad_fab

note _SUP_REQ_CCF_DATE Complément de sélection sur la table cde_cad_fab permettant d'ouvrir automatiquement la saisie de suivi des dates à la validation de chaque ligne.

note _SUP_REQ_ES_CAD_FAB Supplément de requête des entrées de stock des cadencements

note _SUP_REQ_SS_CAD_FAB Supplément de requête des sorties de stock des cadencements de fabrication

#CF ATL

Note GESTION_TRAIN_CADFAB Gestion des trains de cadencements de fabrication

#CF CDE

note LCO_NB_CAD_FAB_PREV Code LCO sur première entité de devis où sera saisi le nombre de cadencements de fabrication prévu

note TSC_NB_CAD_FAB_PREV Code TSC sur ligne de commande où sera recopié le nombre de cadencements de fabrication prévus renseigné sur le devis transféré en commande

note TSC_NB_CAD_FAB_REEL Code TSC sur ligne de commande où sera renseigné automatiquement le nombre de cadencements de fabrication créés réellement

#CF GPF

A2[23] et A2[24]. Notes CODIF et REMPLIR_ZONE pour la création des affiches

#CF MEF

A1[7,12] Type et code paramètre de lancement de la régénération des cadencements de fabrication

#CF TDC

A1[46] Accès au champ de génération de cadencement et valeur par défaut

A3[54,56] Type de cadencement par défaut pour les articles non montés pour la création des lignes lorsque la commande n'est pas cadencée en fabrication (correspond au type de paramètre TCF)

A3[57,59] Type de cadencement par défaut pour les articles montés pour la création des lignes lorsque la commande n'est pas cadencée en fabrication (correspond au type de paramètre TCF)

Paragraphe dédié à la gestion des commandes de fabrication par référence

#CF TRA

Traçabilité sur la table cde_cad_fab

Code calcul TP

Caractère 1 = T : Gestion des trains de cadencements de fabrication

dos_fab

Option Ocf Gestion des cadencements de fabrication activée

en_co

Option Ofb Prise en compte des cadencements de fabrication

epr0

Option Ogc Edition par cadencement

FAM

A1[46,48] Type de cadencement de fabrication de la famille

genere_cad_fab

Génération des cadencements de fabrication

genere_preactor

note _SUP_REQ_CDE_CAD_FAB Complément de sélection sur la table des cadencements de fabrication pour limiter le nombre d'OF à générer

integration_preactor

Option Ofr Activer la gestion des sous-devis de fabrication réels

Note ACT_CAD_NON_VALIDE Actions paramétrables à réaliser sur les cadencements non validés

note SCE_CAD_NON_VALIDE Code scénario de calcul à mettre en place sur le sous-devis de fabrication réel lié au cadencement non validé en cours d’intégration

l_gdf

Option OC Permet de générer l'ordre de fabrication global lors de la génération des cadencements de fabrication

Permissions

ACCès aux champs et MODifications de champs : Toutes les autorisations commençant par CCF_

TOUches de fonction : F_SAI_CADF_F2 (Annuler une ligne de cadencement) et F_SAI_CADF_F14 (Solder une ligne de cadencement)

PHA

A2[27] Exclusion de la phase du calcul selon l’appartenance à un type de cadencement

qte_prod

Permet de déclarer des entrées en production suivant un cadencement de fabrication

On gère soit les PF soit les affiches (option Olc ou Oec)

Incompatible avec un montage ou un mitraillage

Options Oec et Olc

A3[51] Contrôle du solde de la ligne de cadencement de fabrication d'une affiche

Notes _SUP_REQ_CAD_FAB_E et _SUP_REQ_CAD_FAB_L

Note _SUP_REQ_CAD_FAB_RES Complément de recherche (sur stk0) des mouvements prévisionnels de réserve à annuler lors du solde du cadencement de fabrication

Mise à jour des quantités fabriquées dans la table cde_cad_fab pour certains types de cadencement.

Exemple : pour l'entrée en stock d’affiche de type GLO, on veut aussi mettre à jour la quantité fabriquée pour le type IMP et pour les produits le type GLO.

Notes

MVT_CCF_LOG_E_E

MVT_CCF_LOG_E_L

MVT_CCF_LOG_L_E

MVT_CCF_LOG_L_L

so_options

so_options[44] Gestion des cadencements de fabrication

TCF

Type de Cadencement de Fabrication

TTR

A1[43] Le temps est-il un temps réalisé interdisant l'annulation du cadencement de fabrication ?

TYC

A1[23] Saisie des cadencements de fabrication (Oui/Non/Automatique)

note #CC Contrôle de champs dans la saisie des cadencements de fabrication

note CDE_PAR_REFERENCE Activation de la gestion des commandes de fabrication par référence

note DATE_FCF Saisie des cadencements de fabrication (Date de fin de cadencement de fabrication)

note FA Caractères 4 à 6 : Nouvelle touche de fonction F35 pour la saisie des cadencements de fabrication

ul_param

ul_param[29] Permettre d'intégrer une opération uniquement sur la génération du premier cadencement de fabrication.

USE

A3[51] Autorisation de saisie des valeurs validées des statuts de produits

A3[52] Autorisation de créer plus de cadencements de fabrication que prévu sur le devis

valst

Option Ocf Recherche le prix de vente du lot sur la ligne de commande associée au code produit mouvementé

Notes SUP_REQ_QTE_FAB_CAD

SUP_REQ_QTE_LAN_CAD

SUP_REQ_QTE_LIV_CAD

Colonnes d'édition DJ Quantité lancée du cadencement de fabrication

DK Quantité fabriquée du cadencement de fabrication

DL Quantité livrée du cadencement de fabrication

v_cdem

Option Ocf Accès aux informations de cadencements de fabrication

Option Ogt Gestion des trains de cadencements de fabrication

Option Oi9 Limite la sélection aux commandes ayant des cadencements de fabrication

note AUTORISE_TOUCHE_F57 Autorisation d'accès à la saisie des cadencements de fabrication

note LCT_MULTI_CONFIG pour la gestion des trains des trains de cadencements de fabrication (en conjonction avec le paramètre #RP)

note PAR_LCT_GEN_CAD_FAB Type et code du paramètre de lancement de la génération des cadencements de fabrication

note _SUP_REQ_ES_CAD_FAB Complément de requête des entrées de stock des cadencements de fabrication

note _SUP_REQ_NB_CCF_ Complément de sélection sur la table cde_cad_fab concernant le nombre de cadencements

note _SUP_REQ_SS_CAD_FAB Complément de requête des sorties de stock des cadencements de fabrication

Zones des cadencements de fabrication

v_fab1

Option Opq Proratisation des quantités avec le cadencement de fabrication

v_stk0

Option Opq Proratiser les consommations prévues en fonction de la qté lancée des cadencements de fabrication

voluedit_oex_tc

Option Opc Une page par cadencement de fabrication de type E

Option Osc Un saut de page par type de cadencement de fabrication de type E et type de cadencement (GLO, IMP, FAC, …)

Note _SUP_REQ_CCF_E Complément de requête pour les cadencements de fabrication de type E

Table cde_cad_fab

Table etiqprod : zone etp_lig_cad_fab

Le statut du produit (ccf_statut_prod) peut prendre les valeurs suivantes :

0 Nouv. (Nouveauté)

1 Nouv. val. (Nouveauté validée)

2 Rééd. (Réédition)

3 Rééd. val. (Réédition validée)

4 Mod. (Modification)

5 Mod. val. (Modification validée)


Cadencements de livraison

Présentation | En pratique | Mise en oeuvre
Récapitulatif | Autres paramètres |

Présentation

Le cadencement de livraison définit, pour une ligne de commande, les différentes dates de livraison.

Par extension, il couvre des lieux de livraison et des types de livraison différents (mise à disposition, livraison, consignation, ...)

L'écran de cadencement des livraisons (appelé par la touche F31) gère désormais les stocks.

Cet écran peut être ouvert manuellement (touche F31) ou automatiquement lors de la saisie de la ligne de commande.

La quantité totale des cadencements doit être égale à la quantité de la ligne de commande.

Il est possible de générer automatiquement une ligne de cadencement à l'image de la ligne de commande.

L'utilisateur pourra ensuite revenir sur cette ligne pour effectuer des appels successifs.

L'utilisateur a aussi la possibilité de définir un calendrier prévisionnel des livraisons, lors de la saisie de la ligne de commande ou ultérieurement.

Dans ce cas, il pourra par la suite revenir sur ce calendrier pour y apporter toute modification nécessaire, tant sur les dates que sur les quantités ou encore sur les lieux et types de livraison.

A partir de l'écran des cadencements de livraison, la touche F26 permet d'effectuer les appels de livraison successifs.

Chaque appel fait l'objet d'une ligne de cadencement et génère les mouvements de stocks appropriés, de même que la livraison correspondante (sorties réservées, entrées prévisionnelles, sorties normales, entrées normales).

Les livraisons se font par ligne de cadencement.

A tout instant, le tableau des cadencements affiche l'historique des appels avec le détail par appel et le récapitulatif.

Chaque service concerné (Administration des ventes, Production, Logistique) peut intervenir en donnant son feu vert ou en opposant son veto ou encore en modifiant certaines données d'un appel de livraison (quantité, délai, ...) : dans ce cas, les autres services en sont visuellement prévenus en consultant le détail d'un appel de livraison.

Ces codes de validité peuvent faire l'objet d'autorisations par utilisateur.

En pratique

  • La nouvelle saisie des cadencements de livraisons se fait en fonction du TYC de la commande et sur l'option société [43].

  • Elle fait l'objet d'une option payante : CDE 5.

  • Elle n'est pas compatible avec les affrètements.

  • La table cde8 a été complétée afin de permettre cette nouvelle gestion.

Mise en oeuvre chronologique du paramétrage

A -Activation

Fiche société : Option 43 = O (Oui)

Activer la clé CDE 5.

B - Types de mouvements de stocks

Créez les types des mouvements de stock qui seront mis à jour en saisie de commande et en saisie de BL.

Ces TMV seront recherchés dans l'ordre de priorité suivant :

  1. Dans le qualificatif de l'appel de livraison (QAL)

  2. Dans le type de commande client (TYC)

  3. Dans la configuration des commandes clients (#CF CDE)

Déterminez maintenant le niveau de mise à jour des mouvements de stock et choisissez le paramétrage approprié dans le tableau suivant :

Paramétrage des types de mouvements | QAL | TYC | #CF CDE
Sortie réserve | alpha2[1,3] | alpha2[4,6] | alpha1[26,28]
Entrée prévisionnelle sur le lieu intermédiaire | alpha2[4,6] | alpha2[28,30] | alpha3[40,42]
Sortie normale | alpha2[7,9] | alpha2[7,9] | alpha1[23,25]
Entrée normale sur le lieu intermédiaire | alpha2[10,12] | alpha2[22,24] | alpha1[36,38]

C - Saisie de commandes clients

1/ Codes QAL

Créez le code SAP avec le paramétrage suivant (code utilisé pour la ligne initiale des appels de livraison) :

alpha1[3] (Qualificatif de l'appel de livraison) = S

alpha1[4] (Interdiction de livrer une commande sur appel) = B

Créez le code APP avec le paramétrage suivant (chaque appel sera créé avec ce code) :

alpha1[3] (Qualificatif de l'appel de livraison) = A

alpha1[4] (Interdiction de livrer une commande sur appel) = [espace]

2/ Paramètre de lancement de la saisie de commande (cde) :

La note QUALIFICATIF_APPEL doit pointer vers un code QAL (par exemple, APP) qui sera utilisé suite à un appel de livraison par F26 pour générer une nouvelle ligne (avec la quantité appelée) dans le tableau des cadencements livraison.

Si vous voulez gérer les codes de validation par les 3 services (administration des ventes, production, logistique), créez une note commençant par _CODES_VALID_APL_ où ces 3 codes sont à N, ce qui forcera chacun de ces 3 services à mettre O sur chaque ligne de cadencement de livraison pour donner son feu vert. (Dans ce cas, n'oubliez pas d'attribuer à chaque utilisateur le droit de modifier les codes qui le concernent, dans les valeurs alpha2[39,41] du paramètre USE).

3/ Paramétrage du TYC :

Activation des cadencements de livraison :

Si vous ne voulez pas de cadencement de livraison, alpha4[48] = N.

Si vous voulez une ouverture automatique de la fenêtre des cadencements de livraison, alpha4[48] = A.
Utilisé en général pour indiquer des livraisons prévisionnelles dès la saisie de la ligne de commande.

Si vous voulez une ouverture manuelle (par F31) de la fenêtre des cadencements de livraison, alpha4[48] = O.
Utilisé en général quand vous ne voulez pas indiquer des livraisons prévisionnelles lors de la saisie de commande.
Dans ce cas, alpha4[35] doit être à O pour recopier les informations de la ligne de commande dans la table de cadencement de livraison prévisionnel : une ligne de cadencement est automatiquement créée par ligne de commande.
Si alpha4[35] est à N, aucune ligne de nomenclature ne sera créée automatiquement.

Mise à jour des mouvements de stock :

alpha3[51] = alpha3[53] = R (Création d'une sortie réserve pour la quantité commandée). Nécessite que alpha1[3] = N.

alpha3[52] = alpha3[54] = P (Création d'une entrée prévisionnelle pour la quantité lancée). Nécessite que alpha1[36] = N.

Génération de mouvements de stock :

a/ entrée prévisionnelle sur le lieu intermédiaire de la revue de contrat

> de la ligne de commande

> des lignes de nomenclature de la ligne de commande

b/ entrée prévisionnelle sur le lieu intermédiaire du cadencement de livraison

> des cadencements de livraison rattachés à la ligne de commande

> des cadencements de livraison rattachés aux lignes de nomenclature de la ligne de commande

Ces générations sont soumises aux conditions suivantes :

pour l'ensemble monté : alpha4[49] = P (entrée Prévisionnelle),

pour les composants du PF : alpha4[50] = P (entrée Prévisionnelle).

Paramétrez les types de mouvements en fonction du tableau des TMV.

D - Saisie de BL

Pas de paramétrage particulier.

La saisie d'un BL entraîne les mouvements de stock suivants :

> création d'une sortie normale

> création d'une entrée normale

Si la ligne de cadencement de livraison est non soldée et a un reliquat :

> mise à jour de la sortie réserve

> mise à jour de l'entrée prévisionnelle

Pour ces 4 TMV, vous devez donc compléter les codes QAL ou le TYC ou le #CF CDE en fonction du tableau des TMV :

Récapitulatif du paramétrage

société | Gestion des cadencements de livraisons avec stocks. Option 43 = O (Oui), puis activer la clé.
USE | Droit de modification du code de validation Administration des ventes (O/N). alpha2[39] Droit de modification du code de validation Production (O/N). alpha2[40] Droit de modification du code de validation Logistique (O/N). alpha2[41]
cde | Option Ocl : Synchronisation du cadencement de livraison avec la revue de contrat
 | Option -Oqd : Saisie du qualificatif de l'appel de livraison dans la fenêtre de saisie des dates de livraison. Uniquement sur les lignes de commande
 | alpha4[1] Mode d'accès aux cadencements de livraison
 | alpha4[36] Permet de vérifier la cohérence des dates demandée, proposée et de départ ainsi que le code de tolérance de livraison entre la revue de contrat et la première ligne de cadencement de livraison non annulée (et non soldée, selon paramétrage)
 | alpha4[55] Saisie obligatoire de la date alpha4[56] Saisie obligatoire de la quantité
 | Note _CODES_VALID_APL_ : 21 Code de validation Administration des ventes par défaut (O/N) 22 Code de validation Production par défaut (O/N) 23 Code de validation Logistique par défaut (O/N)
 | Note _INTER_SAISIE_CP_VIL : Saisie du code postal et de la ville dans la fenêtre de cadencement de livraison
 | Note QUALIFICATIF_APPEL : Code QAL utilisé suite à un appel de livraison par F26 pour générer une nouvelle ligne dans le tableau des cadencements livraison
TYC | Saisie des cadencements de livraisons. alpha4[48] peut prendre les valeurs suivantes : O (accès "manuel" par la touche F31) A Automatique N Non (par défaut)
 | alpha4[35] Recopie les informations disponibles sur la ligne de commande dans la table de cadencement de livraison prévisionnel (O/N, N par défaut)
 | Notes commençant par FA pour ouverture automatique de la fenêtre de cadencements de livraison.
 | Pour chaque ligne de commande, on génère un mouvement d'entrée prévisionnelle sur le lieu intermédiaire de livraison de la revue de contrat > de la ligne de commande > des lignes de nomenclature de la ligne de commande Le TMV est indiqué en alpha2[28,30]. Cette génération est soumise à condition : pour l'ensemble monté, alpha4[49] doit être = P (entrée Prévisionnelle). pour les composants du PF, alpha4[50] doit être = P (entrée Prévisionnelle). Les mises à jour de stock sont faites en saisie de la ligne de commande. Attention : alpha4[31] doit impérativement être = N. La valeur par défaut des caractères 49 et 50 est N (aucun mouvement ne sera créé).
QAL | alpha1[3] Qualificatif de l'appel de livraison : S Ligne initiale de l'appel de livraison A Ligne de l'appel de livraison [espace] Ce n'est pas un appel de livraison
 | alpha1[4] Interdiction de livrer une commande sur appel : N Aucun contrôle B Contrôle bloquant W Contrôle non bloquant
#CF TDC | Transfert du devis en commande

Autres paramètres

facn | Option -Orc : Rupture facturation sur la ligne de cadencement de livraison
voluedit_acr | Pour paramétrer l'ordre d'apparition des groupes multi-lignes sous la ligne de commande : Notes commençant par ORDRE_GROUPE_LIGCDE
v_cdem | Option -Oli Permet la visualisation des lignes de cadencement de livraison sans utiliser le tri.
 | alpha4[31] Touche F31 pour la visualisation des cadencements de livraison
 | Visibilité de la table cde8
 | En visu de commande, la "dévalidation" d'un cadencement ouvre une fenêtre de saisie du motif et de la date (option Omq). Le caractère obligatoire de cette date est indiqué sur le motif (nouveau type de paramètre MQA). Nouvelles zones de cde8 : li_motif_qualif et li_date_motif.
tr_l_devis | Option -OC Mise en place de la recopie des cadencements des livraisons lors de la recopie inter-société des lignes de commandes
importation_prophee_cde_cli | Note NOM_FICHIER_CDE_QTE


Outillage

Lien de outil vers lieu de rangement | Lien de lieu de rangement vers outil
#LI O/L | #LI L/O
A1[1,3] = L/O | [à blanc]
A3[1,18] = mat | A3[1,18] = lieu_rgt_e
A4[1,18] = lieu_rgt_e | A4[1,18] = mat

Lien de outil vers machines | Lien de machines vers outil
#LI O/M | #LI M/O
A1[1,3] = M/O | [à blanc]
A3[1,18] = mat | A3[1,18] = mac0
A4[1,18] = mac0 | A4[1,18] = mat

Outillage

Il existe un guide de mise en route, version Word (au format PDF), intitulé Outillage GENERO.

Ce document indique les premiers pas à faire pour la mise en place de l'outillage.

Cette fiche est récente : si vous constatez des oublis, ou pour toute remarque, envoyez-moi un mail !

Paramétrage de premier niveau

Etapes minimum pour la mise en place. Suivre cette chronologie dans la mesure du possible.

Gestion des permissions MEN ASO_CRE MEN ASO_MOD MEN ASO_ANN | Autorisation de créer une action de suivi d'outillage manuelle ou automatique Autorisation de modifier une action de suivi d'outillage manuelle ou automatique Autorisation de supprimer une action de suivi d'outillage manuelle ou automatique
Définir les actions de suivi | ASO (Action de Suivi d'Outillage), paramètre de saisie
Créer les lieux de rangement | EMP, types d'emplacement à définir avant de créer les lieux avec le programme lieu_rgt
Permettre le rattachement des outils à des lieux de rangements (emplacements) (Ce rattachement se fait à partir de la saisie des outils). Remarque : Il existe un autre type de lien, voir plus bas. | #LI, paramètre de liens entre les tables mat et table lieu_rgt_e Vous devez définir 2 liens : le lien initial et son lien réciproque. Voir exemple #CF OUT A1[4,6] pour indiquer le lien initial.
Saisie des outils (enregistrés dans la table mat) La saisie des outils se fait par le programme de saisie des articles / matières / produits (programme mat) | Option Oss pour accéder directement à la saisie simplifiée des outils Option Oo3 pour autoriser la saisie des outillages Option Ogo pour gérer les lieux de rangement (emplacements) des outils Option Otl pour gérer les liens entre les outils et les lieux de rangement Note CREER_ACTION_AUTO pour générer une action de suivi à chaque création d'outil RG1 A1[50] pour gérer le lieu de rangement de niveau 3 et contrôler son existence par rapport au lieu de niveau 1, et ce sans tenir compte de so_options[28].
Gestion des actions de suivi d'outillage Les actions sont enregistrées dans la table action_mat | Programme exclusivement GENERO : G_gestion_outils

Paramétrage de deuxième niveau

Vous pouvez ignorer certaines de ces étapes. Il n'y a pas de chronologie particulière.

Vérifier le type d'outillage au niveau de la famille et de la sous-famille associée

FAM A3[55] et SFM A1[49]

Dans le devis onduleur, contrôler les machines de la gamme et les outillages susceptibles d'être utilisés

#LI, paramètre de liens entre les tables mat et mac0

Vous devez définir 2 liens : le lien initial et son lien réciproque. Voir exemple

don, notes CTRL_OUTIL_MACHINE et LIEN_OUTIL_MACHINE

En saisie de commande client, contrôler que l'outillage nécessaire est disponible.

Si l'outillage est présent en stock, on regarde si une sortie est prévue d'ici la date d'utilisation : si oui, il sera indisponible à la date prévue.

Si l'outillage est absent en stock, on regarde si une entrée est prévue d'ici la date d'utilisation : si oui, il sera disponible à la date prévue.

TYC, notes CTRL_PRES_OUTILLAGE et CTRL_VALID_OUTILLAGE

cde, notes TMV_ENT_OUTILLAGE et TMV_SOR_OUTILLAGE

En saisie de commande client, lors du calcul de la charge, vérifier la disponibilité des outillages. Ajout d'un complément de recherche sur stk0

cde, notes _SUP_REQ_STK0_OUT_E et _SUP_REQ_STK0_OUT_S

Générer en automatique des actions de suivi d'outillage :

- après la génération des dossiers de fabrication :

pour les imprimeurs/transformateurs (l_gdf)

pour les autres (gdf_don)

- au solde de la fabrication (qte_prod)

- au solde de la fabrication (outil 73)

- au solde de la fabrication (touche F38 dans v_cdem)

Rappel : Note CREER_ACTION_AUTO pour générer une ASO à chaque création d'outil

l_gdf A2[26,28]

gdf_don A4[4,6]

qte_prod A3[48,50]

outil_73_solde_fab A2[27,29]

v_cdem notes ACTION_OUTIL_AUTO, TYP_MVT_STK_SOLD_ENT et TYP_MVT_STK_SOLD_SOR

Gérer la traçabilité pour la table action_mat

#CF TRA note TRACABILITE_TABLE

Envoyer des alertes par fax / email lors de la création d'un événement de traçabilité

ATR, note ENVOI_DEST

FAB, notes commençant par ATR

Visualisation des matières

v_mat

Envoyer à PC-TOPP la disponibilité des outillages via le fichier AV-DATA

Nouveau programme : interface_avdata

Intégration du suivi de production - Interface TBDATA

int_tbdata

Vérifier les liens articles/emplacements

outil_liens_article_emplacement

Paramétrage à classer

Les paramètres qui suivent restent à classer

mp_param[01], mp_param[38]

NTS type Q (Action de suivi d'outillage)

mat option Orf et note _SUP_REQ_OUTIL

v_triplet


Saisir le code client #SOC (et éventuellement le code adresse secondaire)

Vous pouvez rattacher le calendrier jusqu’au 31/12/2099; cela évitera de le faire tous les ans...

Saisir #SOC

Saisir éventuellement les dates de début et de fin et valider.

Cela permet de vérifier que les samedis, dimanches et jours fériés ne sont présents dans le calendrier.

Calendrier

Cette page regroupe 2 documentations :

A) La plus récente : Génération du calendrier générique sur #SOC pour le calcul des dates dans la revue de contrat <PC, le 28/01/2013>

B) Une partie plus ancienne et plus générique sur les calendriers Employés et Clients

A) Génération du calendrier générique sur #SOC pour le calcul des dates dans la revue de contrat

A1. Paramétrage nécessaire

#CF ATL A2[36,41] = #SOC

#CF ATL A3[51,56] = #SOC

TYC A3[27] Délai moyen du transport

1 le délai transport est égal à 0 jour

2 le délai transport est variable selon le client (zone paramétrée sur la fiche client (cl_zparnum)

3 le délai transport est égal à 1 jour

4 le délai transport est variable selon le client (CIC N74)

TYC A3[28] = 1 la date de fabrication = date de départ

Saisie des dates dans la revue de contrat

TYC A3[34] = O : Date répondu

TYC A3[35] = O : Date de départ (obligatoire pour le calcul avec le calendrier)

TYC A3[36] = O : Date de fabrication

Cliquez sur les liens suivants pour afficher les copies d'écran correspondantes.

1> Saisie du calendrier

2> Génération du calendrier générique (a faire pour chaque année)

3> Rattachement du calendrier #SOC

4> Contrôle du calendrier

B) calendriers Employés et Clients

Paramétrage

Utilisation

Objectif - Historique

Il existe 2 sortes de calendriers.

Initialement, ce module a été créé pour définir les plages d'activité théoriques journalières des employés.

Une plage d'activité est constituée d'une heure de début et d'une heure de fin.

Le temps dû journalier est ainsi calculé automatiquement.

Le programme a ensuite été adapté aux clients.

Dans ce cas, il est utilisé pour contrôler qu'une livraison se fasse bien dans les créneaux horaires du client.

Cette adaptation a nécessité la mise en place d'un paramétrage particulier dans cal_emp), en A2[48].

Les 2 types de calendriers partagent les mêmes tables : cal_emp et cal_emp_rat.

Principe de fonctionnement du calendrier Employés

  • On construit des calendriers standards, dits Génériques.

  • Pour chaque employé, on peut créer des liens de rattachement à plusieurs calendriers génériques pour plusieurs périodes calendaires.

  • On peut ensuite gérer les cas particuliers, en définissant un calendrier d'exceptions propre à chaque employé.
    Ce calendrier d'exceptions par employé contient les dates (et les plages d'activité) pour lesquelles l'employé ne respecte pas les plages d'activité indiquées par un calendrier générique.

  • On peut à tout moment, pour un employé, consulter une période du calendrier global, formé par les liens de rattachement aux calendriers génériques et par le calendrier d'exception.

Paramétrage

#CF ATL A2[36,41] Code calendrier générique utilisé dans la saisie des commandes clients. Exemple : #SOC

TYC A3[27] Mode de calcul de la date de départ au plus tard (pour le délai)

TYC A3[28] Mode de calcul de la date de fin de fabrication au plus tard (pour le délai)

blv A2[37,39] Nombre de jours en moins pour la recherche du calendrier par rapport à la date du BL
(Visualisation du calendrier client / adresse de livraison (F11))

blv A2[40,42] Nombre de jours en plus pour la recherche du calendrier par rapport à la date du BL
(Visualisation du calendrier client / adresse de livraison (F11))

Paramètres de lancement du programme cal_emp :

Type et code de paramètre #SA CAE ou #SA CAC

Libellé long Calendrier Employé ou Calendrier Client

Valeur A1 cal_emp.4ge

Exemple 1 (calendrier Employé)

Valeur numérique 1 0 (par défaut, la sélection du calendrier proposé commence à la date du jour)

Valeur numérique 2 365 (par défaut, la sélection du calendrier proposé finit un an plus tard)

Valeur A1 cal_emp.4ge (pas d'option à par défaut, gestion en heures – centièmes)

Valeur A2 08.50 12.50 14.00 18.00
2 plages horaires de 8 heures 30 à 12 heures 30 et de 14 heures à 18 heures.

A2[48] n'est pas renseigné, il s'agit donc par défaut d'un calendrier Employé.

Exemple 2 (Calendrier Client)

Valeur numérique 1 -1 (par défaut, la sélection du calendrier proposé commence la veille).

Valeur numérique 2 60 (par défaut, la sélection du calendrier proposé finit 2 mois plus tard).

Valeur A1 cal_emp.4ge –Ohm (gestion en heures – minutes)

Valeur A2 08.00 10.00 10.30 12.30 14.00 18.00 18.30 20.00C

4 plages horaires de 8 heures à 10 heures, 10 heures 30 à 12 heures 30, 14 heures à 18 heures et 18 heures 30 à 20 heures.

A2[48] = C indique qu'il s'agit d'un calendrier Client.

Conseil : Créez 2 entrées dans le menu :

- une pour le calendrier Employé, avec A2[48] = E

- autre pour le calendrier Client, avec A2[48] = C

Utilisation

  1. Création du calendrier générique

  2. Rattachement d'un Employé ou Client à un calendrier générique

  3. Gestion des exceptions

  4. Calendrier global

Lancez le programme cal_emp.

Le menu fait référence aux Employés ou aux Clients selon le paramétrage de A2[48].

Sauf exception mentionnée le cas échéant, la seule différence entre les 2 gestions est dans le contrôle :

Si vous êtes dans un calendrier Employé, le code calendrier doit correspondre à un code Employé existant.

Si vous êtes dans un calendrier Client, le code calendrier doit correspondre à un code Client existant.

1 - Création du calendrier générique

Dans le 1er menu, choisissez Générique (Construction d'un calendrier générique).

2 possibilités selon que vous voulez gérer Œ automatiquement (recommandé) ou  manuellement votre calendrier :

Œ Dans le 2ème menu, choisissez Génère pour générer automatiquement le calendrier générique.

Code calendrier : Entrez le code du calendrier générique (par exemple #SOC)

Date de début : Acceptez la date proposée (selon valeur numérique 1) ou indiquez une autre date.

Date de fin : Acceptez la date proposée (selon valeur numérique 2) ou indiquez une autre date.

Type semaine : T pour Toutes, P pour les semaines Paires, I pour les semaines Impaires
En général, indiquez T. Les autres valeurs sont dédiées à la génération de calendriers de type Equipe.

Plages 1, 2, 3, 4 Acceptez les plages horaires proposées (voir valeur alpha 2) et / ou changez de plages.

A l'extrémité de la ligne, le total du temps dû est affiché.

Génération :Pour chacun des 7 jours de la semaine, indiquez s'il est travaillé (O) ou non (N).

La première partie de la saisie est terminée, validez par F10.

Sauf les jours : Indiquez les jours fériés (ils ne doivent pas être générés).

La deuxième partie de la saisie est terminée, validez par F10.

La génération du calendrier générique est terminée, vous pouvez :

- passer à l'étape  pour vérifier le résultat

- aller directement au rattachement d'un Employé ou Client à un calendrier générique

Remarque La génération n'efface pas au préalable toutes les dates existantes dans la plage de dates sélectionnée.

Ainsi, si vous voulez régénérer un calendrier avec par exemple des horaires différentes le vendredi, vous devez effectuer les 3 opérations suivantes :

1 - Annulation de la plage de dates concernée (Menu : option Annule)

2 - Génération des horaires de lundi, mardi, mercredi, jeudi (mettre N pour le vendredi, samedi et dimanche)

3 – Génération des horaires de vendredi (mettre N pour les autres jours).

 Dans le 2ème menu, choisissez Crée / modifie pour gérer manuellement le calendrier générique.

Code calendrier : Entrez le code du calendrier générique (par exemple #SOC)

Date de début : Acceptez la date proposée (selon valeur numérique 1) ou indiquez une autre date.

Date de fin : Acceptez la date proposée (selon valeur numérique 2) ou indiquez une autre date.

Dès que la date de fin est renseignée, le tableau des plages horaires par jour s'affiche :

- Soit le tableau est déjà rempli parce qu'il a été généré automatiquement (voir Œ) ou manuellement.

- Soit la première ligne est la seule à être proposée, il ne vous reste plus qu'à compléter le tableau.

Remarque Si le calendrier a déjà été généré (automatiquement ou manuellement), le tableau est affiché selon la plage de dates indiquée en haut de la fenêtre.

Autrement dit, il est possible que le tableau affiché ne représente pas la totalité du calendrier généré si vous avez laissé telle quelle la plage de dates proposée alors que, lors de la génération, vous aviez indiqué une plage de dates plus large que celle proposée.

Dans ce cas, indiquez une plage de dates plus large pour être sûr de voir la totalité du calendrier, quitte à indiquer une plage de date volontairement exagérée : cette action sera sans effet sur le contenu du calendrier.

Dans les 2 cas, vous pouvez mettre à jour ce tableau des plages horaires (modification, suppression, ajout de lignes).

Plages 1, 2, 3, 4 Acceptez les plages horaires proposées (voir valeur alpha 2) et / ou changez de plages.

A l'extrémité de la ligne, le total du temps dû est affiché.

Recommencez l'opération pour chaque jour de la plage de dates.

Lorsque vous avez fini de remplir le tableau, validez par F10.

2 – Rattachement d'un Employé ou Client à un calendrier générique

Dans le 1er menu, choisissez Client (ou Employé selon le cas).

Dans le 2ème menu, choisissez Rattachement pour rattacher le calendrier Client #SOC au calendrier générique #SOC.

Dans le 3ème menu, choisissez Crée / Modifie.

Une grille de saisie vous permet de rattacher des plages de dates (en général, 1 plage = 1 année calendaire) à des calendriers génériques.

L'opération peut être répétée pour des clients ou des employés particuliers, mais vous devez la faire au moins pour le client ou l'employé #SOC.

3 – Gestion des exceptions

Les exceptions peuvent porter sur :

- des modifications d'horaires sur un ou plusieurs jours

- des jours supplémentaires

Il n'est pas possible de supprimer un jour, dans les exceptions.

Cependant, vous pouvez effacer toutes les plages horaires d'un jour, ceci revient à déclarer le jour concerné comme jour exceptionnel non travaillé.

Rappel : s'il s'agit d'un jour férié, vous avez intérêt à le déclarer dans la génération automatique des calendriers génériques.

Dans le 1er menu, choisissez Client (ou Employé selon le cas).

Dans le 2ème menu, choisissez Exceptions.

Dans le 3ème menu, choisissez :

- Crée / Modifie pour gérer un petit nombre d'exceptions

- Génère pour gérer un grand nombre d'exceptions ou des exceptions répétitives.

La gestion d'un calendrier d'exceptions est basé sur le même principe que celle du calendrier générique, à savoir :

- Saisie d'un code calendrier et d'une plage de dates

- Saisie des jours de la semaine concernés et des jours exclus (pour la génération automatique)

- Saisie des plages horaires

4 – Calendrier global

Cet outil permet de visualiser le calendrier Employé ou Client issu :

- des règles de rattachement aux calendriers génériques (lorsqu'elles existent)

- du calendrier exceptions (lorsqu'il existe).

Dans le 1er menu, choisissez Client (ou Employé selon le cas).

Dans le 2ème menu, choisissez Calendrier global.

Entrez le code calendrier et la plage de dates.

Dans ce tableau, la colonne lien :

- est vide si l'information correspondante vient du calendrier d'exceptions

- comporte le code du calendrier générique auquel l'employé (ou le client) est rattaché ce jour-là.

Dans ce tableau, toute modification de plages pour une ligne liée à un calendrier générique :

- entraîne l'annulation de ce lien

- transforme la ligne en élément du calendrier exceptions


Mise à disposition, consignation, sous-traitance, cession à filiale

Paramétrage | Types de livraison (tableau) | Types de livraison (graphique)
Fonctionnement | Procédure |

Paramétrage

so_options[35]

= O (Gestion de la consignation, de la mise à disposition, de la sous-traitance et de la cession à filiale dans les livraisons)

Conseil : avant l'activation, la zone type de livraison (b2_type_livraison) du fichier des lignes de bon de livraison (blv2) doit être initialisée à 1.

Requête SQL : update blv2 set b2_type_livraison = 1

Voir les différents types de livraison ci-dessous.

ATTENTION : cette option est incompatible avec la gestion des bons de transfert qui exige que so_options[35] = N.

RG1 alpha1[12]

Type de lieu de rangement ou de magasin

Voir exemples ci dessous

RG1 alpha1[14,19]

Code du tiers du lieu de rangement ou du magasin de mise à disposition

Voir exemples ci-dessous

RG1 alpha1[20,22]

Code de l'adresse de livraison du tiers du lieu de rangement ou du magasin de mise à disposition

Voir exemples ci-dessous

TYC alpha1[3]

= R Génération d'une sortie réserve à la saisie de la commande

TYC alpha1[13]

= O Génération d'une sortie normale à la saisie du BL

TYC alpha2

Paramétrage des types de mouvements de stocks

Voir la remarque ci-dessous

#CF BLV notes MVT_TYPE_LIV_

Pour exclure dans v_stk0 les mouvements correspondant aux BL de MAD et de sous-traitance.

ATTENTION : ce paramétrage ne prendra effet que sur les nouveaux BL saisis.

Voir les différents types de livraison ci-dessous.

#CF BLV alpha1[13,15]

Type de mouvement de stock de sortie normale en saisie de bon de livraison

Voir la remarque ci-dessous

#CF BLV alpha1[29,31]

Type de mouvement de stock d'entrée normale en saisie de bon de livraison

Voir la remarque ci-dessous

blv -Oat

Alimentation automatique de l'adresse temporaire sur un magasin de sous-traitance.

blv -Ocd

Cette option NE DOIT PAS être positionnée.

blv -Omr

Suppression de la fenêtre de confirmation de modification du lieu intermédiaire

En l'absence de cette option, si le lieu intermédiaire de la ligne de commande (fenêtre de revue de contrat) est différent de celui de l'entête du bon de livraison, et que le BL n'a pas été édité en définitif, et que le BL ne contient pas de lignes détail non annulées, un message d'avertissement propose de mettre à jour le lieu intermédiaire du BL avec celui de la ligne de commande.

Sinon, pas de mise à jour du lieu intermédiaire du BL avec celui de la ligne de commande.

blv -Or1 & -Or2

Mise à jour des sorties réserves

blv alpha3[19]

Contrôle du lieu intermédiaire

blv_ed1 -Omc

Edition ou réédition des documents de mise en consignation

blv_ed1 alpha2[14,25]

Type et code des paramètres de lancement de l'édition / réédition des documents de mise en consignation

v_cdem

Quantité livrée ventilée par type de livraison

Par des formules de calcul (notes commençant par _CALC et _VAR), on peut obtenir sur le même état toutes les valeurs possibles concernant les quantités livrées. Exemples :

- Pour obtenir la quantité mise à disposition, faire la somme de qteliv_type_002 et qteliv_type_004

- Pour obtenir la quantité livrée réellement, faire la somme de qteliv_type_003 et qteliv_type_005

Voir les différents types de livraison ci-dessous.

v_stk0 notes S

Pour exclure certains types de mouvements (donc les mouvements correspondant à certains types de BL) de la visu des stocks

Par exemple : S and s0_typ != "ETT" : on exclut les mouvements des BL d'entrée en sous-traitance

(à condition que le TMV ETT corresponde effectivement au type de livraison 14 dans le paramètre #CF BLV)

Remarque sur le TMV

Le type de mouvement est recherché en priorité sur le paramètre TYC.

Si non trouvé, alors il est recherché sur #CF BLV.

Si non trouvé, alors on prend par défaut SOR pour une sortie de stock ou ENT pour une entrée en stock.

Exemples de paramétrage de RG1

Type / Code | Libellé | RG1 A1[12] | RG1 A1[14,19] | RG1 A1[20,22]
RG1 PRO | Lieu de rangement ou magasin de production | 1 |  |
RG1 MDU | Lieu de rangement ou magasin de mise à disposition usine | 2 | [espace] ou #SOC | [espace] ou ADL
RG1 MDC | Lieu de rangement ou magasin de mise à disposition client | 2 | [Nom du client] | [espace] ou ADL
RG1 CON | Lieu de rangement ou magasin de consignation client | 3 |  |
RG1 ST | Lieu de rangement ou magasin de sous-traitance | 4 |  |
RG1 CES | Lieu de rangement ou magasin de cession à filiale | 5 |  |

Types de livraison

Les différents types de livraison sont les suivants. Ils sont stockés dans la zone b2_type_livraison :

On les retrouve dans :

#CF BLV notes MVT_TYPE_LIV_, caractères 14 à 16

v_cdem zones qteliv_type_nnn où nnn est le type de livraison.

Voir aussi #CF ATL A3[57]

O = Oui, case vide = Non

Type | Objet | Livrable | MAJ stock réserve | Factu-rable | MAJ entrée normale
1 | Livraison client depuis Usine | O | O | O |
2 | Entrée mise à disposition client depuis Usine | O | O | O | O
3 | Sortie mise à disposition client vers Client |  |  |  |
4 | Entrée mise à disposition usine depuis Usine |  | O | O | O
5 | Sortie mise à disposition usine vers Client | O |  |  |
6 | Entrée consignation depuis Usine | O | O |  | O
7 | Sortie consignation vers Client |  |  | O |
8 | Entrée sous-traitance depuis Usine |  |  |  | O
9 | Sortie sous-traitance vers Client | O | O | O |
10 | Retour Usine depuis sous-traitance |  |  |  | O
11 | Livraison filiale depuis Usine | O | O |  |
12 | Entrée mise à disposition client depuis sous-traitance | O | O | O | O
13 | Entrée consignation depuis sous-traitance | O | O |  | O
14 | Entrée sous-traitance depuis sous-traitance |  |  |  | O
15 | Fabrication sous-traitance |  |  |  |
16 | Entrée mise à disposition client depuis consignation | O | O | O | O
17 | Entrée mise à disposition usine depuis consignation |  |  | O | O
101 | Fabrication sous-traitance | (Type de livraison particulier)

Représentation graphique des types de livraison

Pointez sur un lieu avec la souris pour afficher une bulle d'aide. Cliquez sur la zone pour afficher plus d'infos sur RG1.

Les types de livraison

Fonctionnement

Dans la saisie des entêtes de bons de livraison, un champ Magasin a été ajouté et correspond au magasin de destination de la marchandise.

Le magasin de destination de la marchandise sur l'entête du BL ne doit pas être saisi lorsque le destinataire est le client.

Dans la saisie des lignes de BL, vous indiquerez le magasin d'origine de la marchandise.

9 cas peuvent se présenter :

1) Vente normale - Une étape :

  1. La marchandise est sortie du magasin de production pour être livrée au client.
    Magasin entête non renseigné. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat

2) Mise à disposition client - Deux étapes :

  1. La marchandise est sortie du magasin de production pour être stockée dans un magasin de mise à disposition client.
    Magasin entête = Magasin mise à disposition client. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat et génération d'une entrée normale sur le magasin de mise à disposition client

  2. La marchandise est sortie du magasin de mise à disposition client par le client à chaque fois qu' il aura besoin de cette marchandise.
    Magasin entête non renseigné. Magasin ligne = Magasin mise à disposition client
    La marchandise sortie ne fera pas l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Génération d'une sortie normale sur le magasin de mise à disposition client

3) Mise à disposition usine - Deux étapes :

  1. La marchandise est sortie du magasin de production pour être stockée dans un magasin de mise à disposition usine.
    Magasin entête = Magasin mise à disposition usine. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une facturation, mais pas d' une livraison.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat et génération d'une entrée normale sur le magasin de mise à disposition usine

  2. La marchandise est sortie du magasin de mise à disposition usine pour être livrée au client à chaque fois qu'il aura besoin de cette marchandise.
    Magasin entête non renseigné. Magasin ligne = Magasin mise à disposition usine
    La marchandise sortie fera l'objet d'une livraison à chaque fois que le client aura pris de celle-ci.
    Mouvement généré :     Génération d'une sortie normale sur le magasin de mise à disposition usine

4) Consignation client - Deux étapes :

  1. La marchandise est sortie du magasin de production pour être stockée dans un magasin de consignation client.
    Magasin entête = Magasin consignation client. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat et génération d'une entrée normale sur le magasin de consignation

  2. La marchandise est sortie du magasin de consignation client par le client à chaque fois qu'il aura besoin de cette marchandise.
    Magasin entête non renseigné. Magasin ligne = Magasin consignation client
    La marchandise fera l'objet d'une facturation à chaque fois que le client aura pris de celle-ci.
    Mouvement généré :     Génération d'une sortie normale sur le magasin de consignation

5) Sous-traitance : La marchandise, une fois traitée par un sous-traitant, est directement livrée au client par celui-ci. Deux étapes :

  1. La marchandise est sortie du magasin de production pour être traitée par un sous-traitant.
    Magasin entête = Magasin sous-traitance. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat et génération d'une entrée normale sur le magasin de sous-traitance

  2. La marchandise est sortie du magasin de sous-traitance pour être livrée au client à chaque fois qu'il aura besoin de cette marchandise.
    Magasin entête non renseigné. Magasin ligne = Magasin sous-traitance
    La marchandise sortie fera l'objet d'une facturation à chaque fois que le client aura pris de la marchandise.
    Mouvement généré :     Génération d'une sortie normale sur le magasin de sous-traitance

6) Sous-traitance : La marchandise, une fois produite par un sous-traitant, est directement livrée au client par celui-ci. - Deux étapes :

  1. La marchandise est produite par un sous-traitant.
    La marchandise produite ne fera pas l'objet d'une livraison et d' une facturation.
    Cette étape ne fera pas l'objet de la saisie d'un BL.
    Mouvement généré :     Génération d'une entrée normale sur le magasin de sous-traitance

  2. La marchandise est sortie du magasin de sous-traitance pour être livrée au client à chaque fois qu'il aura besoin de cette marchandise.
    Magasin entête non renseigné. Magasin ligne = Magasin sous-traitance
    La marchandise sortie fera l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Génération d'une sortie normale sur le magasin de sous-traitance

7) Sous-traitance : La marchandise revient, une fois traitée par un sous-traitant. - Trois étapes :

  1. a) La marchandise est sortie du magasin de production pour être stockée dans un magasin de sous-traitance.
    Magasin entête = Magasin sous-traitance. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transfert de stock du magasin de production vers le magasin de sous-traitance

  2. La marchandise est sortie du magasin de sous-traitance pour être stockée dans le magasin de production.
    Magasin entête = Magasin production. Magasin ligne = Magasin sous-traitance
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transfert de stock du magasin de sous-traitance vers le magasin de production

  3. La marchandise est sortie du magasin de production pour être livrée au client.
    Magasin entête non renseigné. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat

8) Sous-traitance : La marchandise revient, une fois produite par un sous-traitant. - Trois étapes :

  1. La marchandise est produite par le sous-traitant.
    La marchandise produite ne fera pas l'objet d'une livraison et d' une facturation.
    Cette étape ne fera pas l'objet de la saisie d'un BL.
    Mouvement généré :     Génération d'une entrée normale sur le magasin de sous-traitance

  2. La marchandise est sortie du magasin de sous-traitance pour être stockée dans le magasin de production.
    Magasin entête = Magasin production. Magasin ligne = Magasin sous-traitance
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transfert de stock du magasin de sous-traitance vers le magasin de production

  3. La marchandise est sortie du magasin de production pour être livrée au client.
    Magasin entête non renseigné. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison et d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat

9) Cession à filiale - Une étape :

  1. La marchandise est sortie du magasin de production pour être livrée au client filiale.
    Magasin entête = Magasin cession à filiale. Magasin ligne = Magasin production
    La marchandise sortie fera l'objet d'une livraison, mais pas d'une facturation.
    Mouvement généré :     Transformation de la sortie réserve générée sur le magasin de production en sortie normale avec gestion du reliquat

Procédure (pour la mise à disposition)

1) Saisie de la commande

Saisir MAD comme lieu de rangement dans la fenêtre de la revue de contrat ("Lieu intermédiaire"), pour spécifier qu'il s'agit d'une mise à disposition.

Indiquer pour les articles le lieu de stockage par défaut (F8 sur la fiche article). Exemple pour la suite : MPF

ATTENTION : si aucun lieu n'est spécifié sur la fiche article, il faudra faire F22 sur la ligne de commande pour préciser le lieu de la sortie réserve (sinon la sortie réserve ne sera imputée à aucun lieu).

Mouvement généré : Sortie réserve sur le lieu de rangement défini par défaut sur la fiche article (ici MPF), sauf si lieu modifié sur la ligne de commande par F22.

2) Déclaration de Production

Mouvement généré : Entrée normale sur le lieu de rangement de la fiche article (MPF), sauf si on modifie le lieu en saisie de production.

3) BL d'entrée en MAD (facturable)

Saisir MAD comme lieu de rangement sur l'entête du BL (correspond au lieu de destination pour le mouvement d'entrée), MPF sur les lignes (correspond au lieu de provenance pour le mouvement de sortie).

Mouvements générés :

- Sortie normale de MPF

- Entrée normale sur MAD

- Annulation du mouvement de sortie réserve sur MPF (+ gestion reliquats)

4) Facture du BL d'entrée en MAD

5) BL de sortie de MAD (non facturable)

- Ne pas saisir de lieu de rangement sur l'entête.

- Faire F22 sur les lignes (ouverture fenêtre de déstockage) pour préciser d'où on prend la marchandise (ici MAD).

Remarque : pour éviter de faire F22 pour saisir ce lieu, il est possible de paramétrer l'ouverture automatique de cette fenêtre, en positionnant blv alpha2[18] à O. De plus, TYC alpha1[13] de la commande doit être différent de N.

Si l'ouverture automatique de cette fenêtre perturbe la saisie des BL autres que ceux de sortie de MAD, vous pouvez créer une entrée au menu spécialement pour la saisie des BL de sortie de MAD.

- Répondre NON au message "Le code magasin du BL est différent de celui de la ligne de commande. Voulez-vous mettre à jour le code magasin du BL ?" (sinon le lieu du BL serait écrasé par celui de la ligne de commande, ce qui empêcherait le programme de rendre le BL non facturable.)

Mouvement généré : Sortie normale de MAD

Remarque

En visualisation ou en saisie de commande, en faisant CONTROL-F sur la ligne de commande, on peut visualiser les différents BL et factures liés à la ligne de commande

De plus, le libellé du type de livraison est affiché en clair dans le CONTROL-F). Ainsi on peut distinguer par exemple les BL d'entrée en MAD et les BL de sortie de MAD, et il est aussi spécifié que ces derniers sont NON FACTURABLES.


Nomenclature multi-niveaux

Sommaire de l' étude

1 -. Objet de l'étude

2 - Principe général

3 - Détail de fonctionnement

3.1 - Nomenclature multi-niveaux

3.1.1 - Définition de la nomenclature

3.1.2 - Mode de réapprovisionnement des produits

3.1.3 - Gestion des coefficients de nomenclature

3.1.4 - Valorisation des produits

3.1.5 - Edition du devis

3.1.6 - Visualisation de la nomenclature

3.1.7 - Saisie de commande

3.1.8 - Création automatique des FBI

3.2 - Gestion des mouvements prévisionnels et des besoins

3.2.1 - Livraisons prévisionnelles

3.2.2 - Fabrications prévisionnelles

3.2.3 - Consommations prévisionnelles

3.2.4 - Gestion des mouvements de produits achetés

3.2.5 - Analyse des besoins

3.2.6 - Exemple de chaîne de besoins

3.3 - Autres points

3.3.1 - Déclaration de production ou de montage

1. Objet de l'étude

Cette étude a pour objet de :

  • Définir les modifications à apporter au devis onduleur pour intégrer la possibilité de saisir des nomenclatures multi-niveaux

  • Intégrer ces différents niveaux dans la gestion des mouvements prévisionnels

2. Principe général

Un produit à nomenclature multi-niveaux est un assemblage de produits semi-finis eux même pouvant être assemblés à partir d'autres produits semis finis, et ainsi de suite jusqu'à la matière première.

Chaque niveau intermédiaire correspond donc à une opération de montage ou d'assemblage. A partir du moment où des produits sont livrés séparément, ils constituent un ensemble dit "appairé" et ne nécessitent pas de niveau intermédiaire supérieur.

Pour qu'un produit fabriqué puisse être utilisé en tant que composant d'un autre produit, il doit au préalable avoir fait l'objet d'un devis.

3. Détail de fonctionnement

3.1 Nomenclatures multi-niveaux

3.1.1 Définition de la nomenclature

Un produit nomenclaturé sur plusieurs niveaux se décompose en plusieurs produits semis finis (niveau intermédiaire), chacun d'eux pouvant par ailleurs être commandé et/ou livré en tant que produit fini.

Pour enregistrer cette nomenclature dans VoluPack, chaque niveau intermédiaire de la nomenclature fait l'objet d'un devis pour pouvoir être utilisé, soit en tant que produit fini, soit en tant que produit semi-fini.

Exemple : une caisse à casiers montés est composée d'une caisse et d'un croisillon lui-même composé de 2 plaques échancrées, chacune pouvant être utilisée dans d' autres formats de croisillons.

On va donc d'abord définir chacune des plaques échancrées, ensuite définir le croisillon, puis définir la caisse (puisqu'elle peut être vendue séparément), et enfin l'ensemble caisse + casiers.

Devis 1 : Plaques échancrées N°1: R121 -> P121

Devis 2 : Plaques échancrées N°2: R122 -> P122

Devis 3 : Croisillons montés : R12 -> P12 (montage de éléments inférieurs) -> P121 et P122

Devis 4 : Caisses : R11 -> P11

Devis 5 : Caisses montées avec les casiers : R1 -> P1 (montage des éléments inférieurs) -> P11 et P12

Pour définir ces différents niveaux intermédiaires, il suffit de définir un seul niveau supplémentaire de nomenclature, et de préciser dans le devis à quel niveau supérieur un élément peut être rattaché.

La génération de la nomenclature reflète alors le niveau de rattachement des produits entre eux.

Exemple :

Devis | Ensemble | Séquence devis | Séquence de rattachement | Produit | Commentaires
1 | R121 | 10 |  | P121 |
2 | R122 | 10 |  | P122 |
3 | R12 | 10 |  | P12 |
 |  | 20 | 10 | P121 | P121 est rattaché à la séquence 10, donc est composant de P12
 |  | 30 | 10 | P122 | P122 est rattaché à la séquence 10, donc est composant de P12
4 | R11 | 10 |  | P11 |
5 | R1 | 10 |  | P1 |
 |  | 20 | 10 | P11 | P11 est rattaché à la séquence 10, donc est composant de P1
 |  | 30 | 10 | P12 | P12 est rattaché à la séquence 10, donc est composant de P1

Si les casiers ne sont pas montés dans la caisse, il n'est pas nécessaire de définir un devis pour le produit P1.

A la rigueur, si on veut définir l'ensemble appairé caisse et casiers, il suffira de faire le devis suivant:

Devis | Ensemble | Séquence devis | Séquence de rattachement | Produit | Commentaires
6 | R2 | 10 |  | P11 |
 |  | 20 |  | P12 |
 |  | 30 | 20 | P121 | P121 est rattaché à la séquence 20, donc est composant de P12
 |  | 40 | 20 | P122 | P122 est rattaché à la séquence 20, donc est composant de P12

A partir du moment où on définit un produit sur un niveau intermédiaire, celui ci est nécessairement monté et de type "E" (avec suivi des éléments en stock).

Enchaînement des écrans : L' enchaînement des écrans (architecture, conditionnement, gamme) pour les produits de premier niveaux reste identique au fonctionnement actuel.

Il n'est pas nécessaire d'afficher les écrans d'architecture, de conditionnement et de gamme pour les produits de second niveau puisqu'ils ont déjà été définis dans un autre devis. Par contre, ces écrans peuvent être appelés, en consultation uniquement, par le "navigateur écrans" lorsqu' on le souhaite.

Passage en 99 : Le passage en 99 permet de transformer une offre de vente en devis FAB (pouvant être fabriqué), et d'attribuer les codes produits définitifs pour la référence commerciale (commandable) et les références techniques (fabricable) de premier niveau.

Il s'agit du mécanisme actuel qui permet de forcer le code produit.

Dans le cas du multi-niveau, ce mécanisme n'est possible que si les éléments de second niveau sont déjà en 99, et a fortiori ne modifie pas la codification des éléments de second niveau.

Le passage en 99 propose aujourd'hui une codification pour la référence commerciale et permet de la modifier.

Une fois acceptée, cette codification est reportée sur les produits finis.

A faire : Sur option, une fenêtre permet de saisir un code pour la référence commerciale. Une fois celle-ci validée, une fenêtre s'ouvre pour chaque produit fini de premier niveau et permet de saisir un code pour chacun d'eux.

Un test est fait sur non existence des codes saisis.

Aucune codification n'est proposée ni pour la référence commerciale, ni pour les produits finis.

3.1.2 Mode de réapprovisionnement des produits

Chaque produit fini ou semi-fini peut être

  • un produit fabriqué synchrone

  • un produit fabriqué asynchrone

  • un produit acheté (négoce)

Les composants d'un produit fabriqué peuvent être synchrones et / ou asynchrones et / ou achetés.

Un produit acheté, quant à lui, ne peut pas avoir de composants.

3.1.3 Gestion des coefficients de nomenclature

La quantité nécessaire d'un composant est le produit de la quantité devisée par le coefficient des différents liens de nomenclature.

Exemple : Une référence R est composé d'un produit P1 (coefficient de nomenclature = 1) lui même composé de 2 produits P11 (coef = 1) et P12 (coef = 2) lui même composé de P121 (coef = 3 ) et P122 (coef = 2).

Pour 1000 R devisé, on aura donc un besoin de :

- 1000 P1

- 1000 P11

- 2000 P12 (= 1000 * 2)

- 6000 P121 (= 1000 * 2 * 3)

- 4000 P122 (= 1000 * 2 * 2)

3.1.4 Valorisation des produits

La valorisation des éléments du devis peut être différente selon que l'élément est un produit fini ou de premier niveau (sans séquence de rattachement), ou qu'il est un produit semi-fini ou de second niveau (avec séquence de rattachement).

Pour un produit de premier niveau, la valorisation tient compte des postes de coûts propres au produit (matières et accessoires, opérations, actions de service), mais aussi des coûts d'utilisation des produits de second niveau qui le composent.

Les produits de second niveau interviennent dans le coût du produit fini en tant que matière au même titre que les accessoires, et sont valorisés selon un prix "de cession" pré-défini.

Détermination du prix de cession des produits

- Pour un produit acheté, le prix de cession est calculé sur la base du prix d'achat, et saisi manuellement dans le tarif du produit (déjà valable aujourd'hui pour les accessoires).

- Pour les produits transformés, le prix de cession est calculé sur la base de la valorisation de ce produit dans son devis créateur : matières et accessoires (hors matériaux d'emballage : palettes, coiffes, etc&), opérations et certaines actions de service (l'aS de transport par exemple ne doit pas être prise en compte dans le calcul du prix de cession).

Le prix de cession est généré automatiquement dans la phase de calcul du devis pour tous les produits de premier niveau et est enregistré dans les tarifs du produit.

Un produit de second niveau ne peut pas être défini en même temps, c'est à dire dans le même devis que le produit de premier niveau auquel il appartient, car il n'a pas encore de prix de cession.

3.1.5 Edition du devis

La décomposition des éditions du devis reste la même qu'aujourd'hui, à savoir une ou deux pages (suivant les éditions) par élément de premier niveau, et une page récapitulative éventuelle.

Aucune édition n'est prévue pour les produits de second niveau.

Par contre, les produits de second niveau apparaissent dans la liste des matières de chacun des produits de premier niveau avec leur prix de cession et leur coefficient de nomenclature.

Cette modification n'est faite que sur l'édition technique 1

3.1.6 Visualisation de la nomenclature

Une nouvelle fonction permet, à partir de n'importe quel produit sur lequel on est placé, de visualiser la nomenclature descendante à partir de ce produit.

Exemple de représentation

P1 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

1x P11 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

3x P12 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

2x P121 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

5x P122 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Cette fonction peut être appelée à partir de :

- la ligne de commande (cde2),

- la ligne de nomenclature (cde4),

- la visu des commande (v_cdem),

- profil de stock (v_prostk),

- la fiche article (mat)

- tableau des lignes de devis (don_020)

- la visu des devis (v_don)

- la ligne de bl (blv2)

3.1.7 Saisie de commande

La saisie de commande de type CD* (commande commerciale) se fait comme aujourd'hui sur la référence commerciale.

La fonction F15 actuelle sur la ligne de commande permet de visualiser la nomenclature de premier niveau.

La saisie d' une fabrication interne (FBI) peut se faire sur un produit à n'importe quel niveau de la nomenclature.

Cela nécessite de pouvoir gérer les nomenclatures sur les FBI, et a fortiori de pouvoir les visualiser par la fonction F15.

Les modifications éventuelles à apporter aux documents commerciaux (AR, BL et factures) ne sont pas prises en compte dans cette étude, et seront étudiées au cas par cas par la suite.

Toute la gestion de la charge atelier (liée à PC-Topp) ne fait pas partie de cette étude.

Le fonctionnement actuel ne devra cependant pas être impacté, et devra continuer à analyser la charge (lorsque l'option est activée) sur le premier niveau de la nomenclature.

3.1.8 Création automatique des FBI

En saisie de commande commerciale (CD2 / CDA), la création automatique de FBI se fait comme aujourd'hui à l'édition de l'accusé de Réception (AR) pour tous les produits synchrones.

Une boucle est mise en place dans le traitement pour vérifier si, au niveau de chaque FBI créée, il existe un niveau de nomenclature inférieure et pour créer si besoin (si les produits sont synchrones) les FBI concernées.

La boucle s' arrête donc au premier produit non synchrone.

Nomenclatures | Réappro | Commande
R1 |  | CD2 (R1)
>P1 | Synchrone | FBI (P1)
>P11 | Asynchrone | Pas de FBI : on n'analyse pas le niveau inférieur
>P111 | Asynchrone |
>P112 | Négoce |
>P12 | Négoce | Pas de FBI
>P13 | Synchrone | FBI (P13) : on analyse le niveau inférieur
>P131 | Asynchrone | Pas de FBI
>P132 | Négoce | Pas de FBI

En saisie de fabrication interne (FBI), la création automatique se fait par le lancement de façon transparente d'une édition "virtuelle" de l'aR de la FBI.

Cette méthode permet de conserver tous les mécanismes déjà existant dans l'aR.

La boucle de création des FBI "filles" se lance de la même façon que lors de l'édition de l'aR des CD2.

A noter que le produit de la ligne de FBI peut être asynchrone (ce qui est généralement le cas en renouvellement de stock), et que ses composants peuvent être synchrones. Dans ce cas, il faut donc analyser la nomenclature du produit de la FBI pour savoir si d'autres FBI doivent être créés.

Alimentation des champs de la FBI et code blocage : L'insertion des enregistrements relatifs aux FBI se fait de la même façon qu'aujourd'hui. Le champ libellé (ec_texte) des FBI créées automatiquement est alimenté par le texte "Suite à commande TYC N° 99999999" où les chaînes TYC et 99999999 sont le type et le N° de la commande directement à l'origine de la FBI concernée.

A noter cependant, que dans la boucle de création automatique des FBI, il n'est pas possible de préciser de façon automatique, pour chaque FBI créée, une date de fin de fabrication cohérente compte tenu des différentes phases de production de chacun des éléments de la nomenclature.

Il est donc décidé que la date de fin de fabrication de chaque FBI est la même que celle de la première commande saisie.

Par contre, les FBI créées automatiquement à partir de FBI sont dotées d'un code blocage qui permet de les identifier et de les modifier en conséquence.

Ce code blocage a pour incidence d'empêcher la création des mouvements prévisionnels liés à la FBI concernée, mais n'empêche pas la création automatique de FBI "filles". Il bloque aussi les envois à PC-Topp.

Ce code blocage ne peut être activé que sur les FBI créées automatiquement à partir d' une FBI.

En effet, celles directement créées à partir d'une CD2 / CDA suivent le fonctionnement actuel et n'ont pas besoin d'être bloquées.

Une liste (v_cdem) permet d'identifier les FBI bloquées et de leur modifier la date de fin de fabrication (par la fonction F21) et de la débloquer (par la revue de contrat).

La validation de la FBI débloquée lance de nouveau la boucle décrite ci-dessus qui génère les mouvements prévisionnels correspondants.

Gestion des modifications : Toutes les modifications (hormis la date de fin de fabrication) de la commande mère sont reportées en conséquence et de manière automatique sur toutes les FBI générées. La date de fin de fabrication, quant à elle, n'est reportée que sur les FBI "filles" n'ayant pas le code blocage décrit ci-dessus, ou sur les FBI ayant le code blocage mais à l'état bloqué.

En effet, si le code est à l'état débloqué, cela signifie que la date a été modifiée et / ou validée manuellement, et donc qu'elle ne peut être remodifiée que manuellement.

3.2 Gestion des mouvements prévisionnels et des besoins

A quelque niveau que ce soit de la nomenclature, les mouvements prévisionnels sont gérés si les produits sont gérés en stock.

Tous les mouvements prévisionnels, qu'il s'agisse de sorties ou d'entrées, sont rattachées au lot "chapeau", c'est à dire à la commande mère saisie manuellement.

Rappel : à partir du moment où on solde une opération (fabrication, livraison), tous les mouvements prévisionnels (reliquats) à un niveau égal ou inférieur, encore présents et rattachés au lot, sont eux même soldés.

3.2.1 Livraisons prévisionnelles

Seuls les éléments livrables de premier niveau peuvent être associés à un mouvement de livraison prévisionnelle.

Rappel : sont considérés comme livrables les commandes de type commercial (CD2, CD1), et les FBI ayant un lieu intermédiaire.

3.2.2 Fabrications prévisionnelles

A chaque FBI générée correspond un mouvement de fabrication prévisionnelle.

3.2.3 Consommations prévisionnelles

Chaque génération de FBI génère une consommation prévisionnelle (sortie réserve) de ses composants de premier niveau.

Ces besoins seront couverts soit par le stock existant s'il est suffisant, soit par la création de FBI qui génèrera à son tour des besoins pour les niveaux inférieurs, soit par des achats.

La génération de consommation prévisionnelle doit descendre jusqu'aux matières premières de la composition.

Rappel de la nomenclature d'un PF :

PF

> Composition commerciale avec n0_qte = surface unitaire brute

> Composition technique

> Matière 1 avec n0_qte = % de matière dans la compo (si Opl)

avec n0_qte = coefficient d'ondulation des papiers

> &..

3.2.4 Gestion des mouvements de produits achetés

Pour tous les produits achetés, il est nécessaire de suivre les différents mouvements prévisionnels et réels.

Les mouvements de consommation prévisionnelle sont gérés de manière automatique (voir paragraphe ci-dessus).

Les mouvements d'entrées prévisionnelles devront par contre être gérés manuellement dans la mesure où aucun interface avec le système externe n'existe.

A Réceptions prévisionnelles

Le module de gestion des mouvements prévisionnels (maj_stk_prev) peut être utilisé pour saisir les réceptions prévisionnelles une fois que la commande d' achat a été créée dans le système externe.

Cet outil doit bien sûr permettre la saisie d'un produit acheté de type matière par exemple.

B Réceptions réelles

Une nouvelle fonction du module de gestion des mouvements prévisionnels (voir copie d'écran ci-dessous) permet de transformer le mouvement d'entrée prévisionnelle en entrée réelle.

Cette fonction appelle un écran pour saisir la date de réception, le type de mouvement, la quantité et si la réception est soldée ou non.

Transformation de mouvements prévisionnels en mouvements réels
Mouvement d' origine : [Code article] [TMV] [Date du mvt] [Quantité] [Lieu1]-[Lieu2]
Date | Type de mvt | Lieu 1 | Lieu 2 | Nb Palette | Qte /Pal. | Qte Totale
99/99/9999 | EN |  |  |  |  |
 |  |  |  | Quantité totale |  |

A la validation, une question est posée pour savoir si la transformation est totale ou partielle.

Si la transformation est totale, le mouvement prévisionnel est annulé.

Si la transformation est partielle, le mouvement prévisionnel reste mais la quantité est décrémentée de la quantité totale des mouvements réels saisis.

Si l'article est géré en vrac ou si le magasin est géré en vrac, on saisit la quantité totale.

Sinon on saisit le nombre de palette et la quantité par palette.

Un test est fait pour ne pouvoir transformer un mouvement d'entrée qu'en mouvement d'entrée, et idem pour les mouvement de sorties.

C Consommations réelles

La transformation des consommations prévisionnelles en consommations réelles peut se faire de la même façon que pour les réceptions réelles via la nouvelle fonction (décrite ci-dessus) dans le module de gestion des mouvements prévisionnels.

Transformation de mouvements prévisionnels en mouvement réel
Mouvement d' origine : [Code article] [TMV] [Date du mvt] [Quantité] [Lieu1]-[Lieu2]
Date | Type de mvt | Lieu 1 | Lieu 2 | Nb Palette | Qte /Pal. | Qte Totale
99/99/9999 | SN |  |  |  |  |
 |  |  |  | Quantité totale |  |

Une autre méthode existe, et permet lors de la déclaration de production du produit auquel ce composant est rattaché de consommer de manière automatique, (mais aussi théorique), en fonction du coefficient de nomenclature.

3.2.5 Analyse des besoins

L'état de profil de stock permet de visualiser pour chaque produit suivi en stock quand les ruptures prévisionnelles surviendront.

Une fonction déjà existante permet de générer depuis ce module les FBI nécessaires et de créer ainsi les mouvements prévisionnels de fabrication et de consommation.

Par réactualisation de l'état après génération, on distingue aussitôt les ruptures que ces nouvelles données ont provoquées.

Et on recommence jusqu'à épuisement des ruptures.

3.2.6 Exemple de chaîne de besoins

Nomenclatures | S/A/N | Cde | Mouvements prévisionnels |  |  | Analyse profil de stock | Mvt Prév. |  | Analyse Stock
 |  |  | Livr. | Fab. | Conso |  | F/A | Conso |
R1 |  | CD2 (R1) | P1 |  |  |  |  |  |
>P1 | S | FBI (P1) |  | P1 |  |  |  |  |
>P11 | A | Pas de FBI |  |  | P11 | Stock insuf. : FBI (P11) | P11 |  |
>P111 | A |  |  |  | - |  |  | P111 | Stock suf.
>P112 | N |  |  |  | - |  |  | P112 | Stock suf.
>P12 | N | Pas de FBI |  |  | P12 | Stock insuf. : Cde d'achat | P12 |  |
>P13 | S | FBI (P13) |  | P13 | P13 |  |  |  |
>P131 | A | Pas de FBI |  |  | P131 | Stock Suffisant |  |  |
>P132 | N | Pas de FBI |  |  | P131 | Stock Suffisant |  |  |

3.3 Autres points

3.3.1 Déclaration de production ou de montage

Dans cette nouvelle configuration des ensembles, il est à noter que dorénavant, on dispose d'une FBI de montage, c'est à dire d'une FBI saisie ou générée sur un ensemble monté.

La déclaration de production ou de montage sur cette FBI doit alimenter le stock du produit de la FBI (et non plus comme aujourd'hui de l'ensemble "R" auquel il est rattaché).

D'autre part, comme vu plus haut, il existe 2 types d'ensembles montés : Ceux pour lesquels on gère les composants en stock et ceux pour lesquels on ne gère pas les composants en stock.

Et pour chacun de ces types de montage correspond un module de montage différent.

Pour faciliter la saisie des utilisateurs, ces modules seront "coiffés" d' un interface de saisie du N° d'oF.

En fonction du type de montage du produit de la ligne de FBI, s'ouvrira alors le module correspondant.

Génération des livraisons et des entrées prévisionnelles de / vers le sous-traitant.

Configuration générale Atlas | #CF ATL alpha3[35,49] Lieux de rangement 1, 2, 3 par défaut de la société
Site de production | SIT A1[10,24] Lieux de rangement 1, 2, 3 par défaut du site de production
Type de commande CD2 | alpha1[3] = R Sortie Réserve (Livraison prévisionnelle) alpha1[36] = P alpha2[4,6] = Type de sortie réserve (Livraison prévisionnelle) alpha2[13,15] = [blanc] alpha2[28,30] = Type d'entrée prévisionnelle sur le lieu intermédiaire alpha2[34,36] = [blanc] alpha4[31] = P Entrée Prévisionnelle sur le lieu intermédiaire
Type de commande FBI | alpha1[3] = R Sortie Réserve sur le lieu intermédiaire alpha1[36] = P Entrée Prévisionnelle (Fabrication prévisionnelle) alpha2[4,6] = Type de sortie réserve sur le lieu intermédiaire alpha2[13,15] = Type d'entrée prévisionnelle (Fabrication prévisionnelle) alpha2[28,30] = Type d'entrée prévisionnelle sur le lieu intermédiaire alpha2[34,36] = Type de consommation prévisionnelle (Sortie réserve) en édition d'aR alpha4[31] = P Entrée Prévisionnelle sur le lieu intermédiaire

maj_stk_prev

La touche F9 est autorisée si :

  • loption a été activée pour le type de mouvement (-Oep pour une entrée ou -Osp pour une sortie)

  • le module est en mode modification (pas d'option -Oco)

  • la ligne n'est pas vierge

  • la ligne n'est pas nouvelle

  • la ligne n'a pas été modifiée

  • la ligne n'a pas été annulée

  • l'article existe

  • le curseur est sur le 1er champ de la ligne

Dans la fenêtre de saisie des mouvements réels :

  • si le lieu de rangement est géré en vrac ou si le lieu de rangement est géré à la palette et l'article en vrac, le nombre de palettes et la quantité par palette ne seront pas accessibles et la quantité totale sera saisie.

  • si le lieu de rangement et l'article sont gérés à la palette, le nombre de palettes et la quantité par palette seront saisis et la quantité totale sera calculée et affichée, mais non modifiable.

Au F10, si la quantité totale réelle est inférieure à la quantité prévisionnelle du mouvement, l'opérateur indiquera si le reliquat doit être généré ou non.

Une ligne transformée est identifiée par un T dans le 1er champ de la ligne. Elle ne peut pas être modifiée ou annulée.

Dans la création des mouvements prévisionnels (touche F1), il est possible de ne pas contrôler le lot en création de mouvement prévisionnel pour les articles achetés :

  • Si l'option -Opc n'est pas paramétrée, le numéro de commande client et la ligne de commande client sont obligatoires, doivent exister et ne pas être annulés.

  • Si l'option -Opc est paramétrée et que l'article est un article fabriqué, le numéro de commande client et la ligne de commande client sont obligatoires, doivent exister et ne pas être annulés.

Si l'option -Opc est paramétrée et que l'article est un article acheté, le numéro de commande client est obligatoire, mais il n'est pas contrôlé et la ligne de commande client n'est pas obligatoire et contrôlée.

Si la ligne de commande client est saisie, le lot est de la forme CCCCCCCC-LLL.

Si la ligne de commande client n'est pas saisie, le lot est de la forme CCCCCCCC.

Types de mouvement par défaut : alpha2[13,15] & alpha2[16,18]

Voir aussi mp_param[40] et RG1 alpha1[33]

Nomenclature multi-niveaux et besoins de produits semi-finis

Présentation

Etude

Paramétrage

Fiches d'évolution

Présentation

La gestion des nomenclatures multi-niveaux s'applique aux onduleurs uniquement.

Jusqu'à présent, on était limité à un seul niveau de nomenclature dans le devis onduleur (référence commerciale et produit fini).

Il est maintenant possible de développer une nomenclature à N niveaux, chaque niveau pouvant être considéré comme une référence commerciale indépendante, et pouvant être intégré dans plusieurs nomenclatures distinctes.

Les fonctionnalités couvertes comprennent entre autres :

  • La visualisation des besoins prévisionnels (semi-finis et matières premières)

  • Génération automatique d'ordres de fabrication en cascade

Etude

Cliquez ici pour afficher / masquer l'étude

Paramétrage

Gestion des options

Option payante PRO-2

Société

L'option 41 de la fiche société doit être positionnée à O après avoir saisi la clé de l' option, sinon vous ne pourrez plus accéder au programme de saisie des options.

Devis onduleur

alpha2[26] = 5

Note CONFIG_PRIX_CESSION

Note _SUP_REQ_COMPOSANTS

Configuration de la saisie des tarifs

Configuration du prix de cession alpha3[28,30]

notes _DATE_DEBUT, _DATE_FIN, _BORNE_INF, _BORNE_SUP

Action de service

alpha3[2] = N (Exclusion du prix de cession)

Visu de la nomenclature multi-niveaux

Aucun paramétrage spécifique à mettre en oeuvre.

Le complément de requête utilisé pour l'affichage des accessoires est pris sur les notes SUPREQACC du #CF CAR.

L'accès à la fenêtre de visu se fait par la touche F3 (ou la touche F30 dans v_cdem).

Saisie des commandes clients :

Actualisation des FBI multi-niveaux

Les FBI générées lors de l'édition de l'AR à partir de la nomenclature de la ligne de commande (Table cde4) doivent être actualisées si la ligne de commande a été modifiée ou annulée.

Toutes les FBI générées et rattachées à la ligne de commande sont actualisées.

Seule la date de fin de fabrication n'est pas actualisée si la FBI générée n'a pas de code blocage de type 012 ou a un code blocage de type 012 avec un état bloqué.

L'entrée prévisionnelle de la FBI générée est créée si elle n'a pas de code blocage de type 012 ou a un code blocage de type 012 avec un état débloqué.

Le flag AR à éditer de la commande modifiée ou annulée est remis à O et celle-ci est éditée systématiquement afin de remettre à jour les stocks lorsqu'on quitte la saisie des lignes (DEL ou F10) à condition qu'une des lignes de la commande ait été actualisée.

Si la touche F10 est utilisée pour sortir de l'écran des lignes de commande et que l'option -Oau est positionnée, l'édition de l'aR se déclenchera automatiquement (pas de demande de confirmation) ou après une demande de confirmation selon alpha4[2].

ATTENTION, si la touche DEL est utilisée pour sortir de l'écran des lignes de commande, l'édition de lAR ne se déclenchera pas !

Positionner l'option -Oaf pour que la modification ou l'annulation d'une ligne de commande réactualise les FBI.

L'autorisation de création des FBI manuelles sur des produits nomenclaturés est conditionnée par l'option -Opf :

- Si elle est présente, la création n'est pas possible.

- Si elle est absente, la création est possible.

Types de notes Revue de contrat : alpha3[53,58]

Note EDITION_AR_FBI

Saisie des commandes clients

Option -Ovn pour contrôler la validité des produits finis

_SUP_REQ_NOM_VALID : Complément de requête sur nom0

Edition des AR :

Génération des FBI multi-niveaux

Les FBI générées lors de l'édition de lAR à partir de la nomenclature de la ligne de commande (Table cde4) peuvent elles-mêmes générer d'autres FBI si le produit de la FBI générée est synchrone et a une nomenclature (Tables nom0 et nom1).

Pas de limitation du nombre de niveaux.

La génération s'arrête si le produit est asynchrone ou n'a pas de nomenclature.

Le numéro du mouvement de l'entrée prévisionnelle de la ligne de commande n'est plus stocké dans le champ lc_nummvt mais dans le champ lc_nummvt2.

Chaque génération de FBI génère une consommation prévisionnelle (sortie réserve) de ses composants de premier niveau. Ces besoins seront couverts :

soit par le stock existant sil est suffisant,

soit par la création de FBI qui à son tour génèrera des besoins pour les niveaux inférieurs,

soit par des achats.

Positionner l'option -Ola pour que l'édition d'une commande annulée ou d'une ligne de commande annulée remette à jour les FBI.

Positionner l'option -Omf pour que l'édition d'une commande modifiée ou d'une ligne de commande remette à jour les FBI.

alpha3[10,12] Type de note historique de la revue de contrat

alpha3[13,15] Code blocage FBI multi-niveaux

Type de commande FBI

alpha1[3] = R

alpha1[5] = O pour que l'édition d' une FBI manuelle génère les FBI filles.

alpha1[36] = P

alpha1[38] = C ou L

alpha2[4,6]

alpha2[13,15]

alpha3[27 et 28] = N pour que la date de fin de fabrication soit alimentée.

note REAP_SYNC_FORCE (Attention : utiliser cette note avec prudence !)

Configuration des commandes clients

alpha3[37,38]

Code blocage auto FBI multi-niveaux

alpha1[1] = A

alpha1[3,5] = 012

alpha2[1] = O

alpha2[5] = O

alpha2[10] = O

Configuration carton

Note SUPREQPF

v_prostk Visu des profils de stock

Lors de la génération dune commande de fabrication (FBI) sur un produit, il faut également générer une FBI pour tous les composants semi-finis de type synchrone, sans génération de mouvements de stock prévisionnels, mais avec un code blocage spécifique (012).

Notes commençant par ACCES_CDE_TYC_

qte_prod Déclaration de production

Après la saisie de l'OF, il est possible de passer directement en déclaration de production ou de montage.

Option -Opd

v_edi_cde Visualisation des messages EDI de commande et génération de commande

OPTION_CDE_TYC_ Paramètres des options de lancement de cde en fonction du TYC : option vn

Autres fonctionnalités liées à la nomenclature multi-niveaux :

Gestion de la sous-traitance dans les commandes clients

Transformation d' un mouvement prévisionnel en un ou plusieurs mouvements réels (normaux) avec gestion du reliquat (touche F9)


Revue de contrat

Sommaire

Principales étapes :

Mise en place de la revue de contrat

Activation de la revue de contrat

Paramètre de blocage

Définition d'un contrôle de blocage dans une revue de contrat.

Récapitulatif du paramétrage

Voir aussi : Gestion du risque client.

A propos des dates (demandée / proposée / départ / fin de fabrication)

La date demandée est la date demandée par le client. Il n'y a pas de calcul automatique de cette date.

La date proposée est la date proposée au client, par l'usine. C'est la date "rendu client".

La date départ est la date à laquelle la marchandise doit partir de l'usine pour satisfaire la date proposée.

Elle est calculée automatiquement par la formule : date départ = date proposée - délai de route (voir TYC A3[27])

Pour le calcul de cette date, on prend en compte 2 calendriers :

celui du transporteur (#CF ATL A2[36,41] ou calendrier du transporteur ou calendrier #SOC)

celui du service expédition de l'usine (#CF ATL A1[25,30] ou calendrier #SOC).

La date de fin de fabrication est la date à laquelle la production doit être terminée pour satisfaire la date de départ.

Elle est calculée en prenant un compte un délai de sécurité (issu de la gamme, d'un éventuel délai labo, d'un éventuel délai lié aux prélèvements qualité, issu du CIC NA3).

Elle prend en compte le calendrier usine #SOC.

Mise en place de la revue de contrat

Pour des raisons techniques, les codes blocages de revue de contrat sont stockés dans des TSC.

Afin de ne pas provoquer de conflits entre les divers TSC déjà existant au sein des systèmes informatiques, il est nécessaire de paramétrer les deux caractères qui formeront la racine de ces TSC.

Ces caractères sont stockés dans #CF CDE alpha3[37,38].

Activation de la revue de contrat

L'activation de la revue de contrat est propre à un type de commande.

Pour activer une revue de contrat sur un type de commande, il faut que alpha3[18] du TYC concerné prenne l'une des valeurs O (oui), 1 ou 2.

Une revue de contrat permet de saisir les données techniques et les dates de livraison.

Dans ces conditions, les fenêtres dédiées à la saisie de ces informations ne sont plus nécessaires.

Pour désactiver la fenêtre de saisie des données techniques, il faut que TYC alpha1[32] et [33] soient à N.

Pour désactiver la saisie des dates de livraisons, il faut modifier le paramètre de lancement du programme de saisie de commande.

Avant de faire cette modification, assurez-vous que ce paramètre ne permet de saisir que des commandes ayant activé la revue de contrat.

La désactivation de cette fenêtre de saisie se fait en retirant l'option -Ode du paramètre de lancement.

De plus, la revue de contrat s'appuie sur deux types de notes qu'il vous faut paramétrer.

Ces deux types de notes sont définis dans le paramètre de lancement de la saisie des commandes : alpha3[53,58].

Exemple

alpha 3[53,55] = RC (Type de notes de revue de contrat)

alpha3[56,58] = RCH (Type de notes d'historique de revue de contrat)

Ces types de notes doivent exister, il faut les créer avec le paramètre de type NTS.

Exemple

Type | Code | Libellé long
NTS | RC | Revue de contrat
NTS | RCH | Historique revue contrat

Paramètre de blocage

Il existe deux types de contrôle de blocage applicables aux revues de contrat :

  • Les contrôles automatiques

  • Les contrôles manuels

Dans les deux cas, la définition des contrôles se fait de la même manière mais l'activation est différente.

Pour activer un contrôle automatique, il faut ajouter une ligne de notes dans le paramètre de lancement du programme de saisie de la commande. Cette ligne de notes doit avoir les caractéristiques suivantes :

CBACONXXX

Contrôle lors de la saisie des lignes de commandes

CBAFBIXXX

  • Contrôle lors de la saisie des lignes de commandes et

  • Vérification que les FBI générées n'ont pas été modifiées manuellement, ce qui rend leur mise à jour en automatique impossible

où XXX = Code du contrôle à activer

Un contrôle manuel n' a pas besoin d'être activé, il vous suffira de le spécifier dans la fenêtre de revue de contrat.

Définition d'un contrôle de blocage dans une revue de contrat

Cette définition se fait dans un paramètre de type BLO que l'on créera avec les valeurs suivantes :

alpha1[1]

M Contrôle de blocage manuel

A Contrôle de blocage automatique

Nécessite une ligne de note commençant par CBA pour être activé.

alpha1[2]

Uniquement pour les contrôles manuels. Etat d'origine du contrôle de blocage.

0 Si pas d'intervention de l'utilisateur, le contrôle sera considéré comme non bloqué.

1 Si pas d'intervention de l'utilisateur, le contrôle sera considéré comme bloqué.

alpha1[3,5]

Uniquement pour les contrôles automatiques. Type de contrôle à effectuer.

000

Contrôle si les FBI associées à la ligne de commande ont été modifiées manuellement, ce qui rend leur mise à jour en automatique impossible.

001

Contrôle si le prix de vente est à 0.

002

Contrôle la validité du prix de vente par rapport au prix de revient prévisionnel de la fiche article. Le prix de vente doit être :

  • supérieur au prix de revient - X%. X est défini en alpha3[31,34],

  • inférieur au prix de revient + Y%. Y est défini en alpha3[35,38].

003

Contrôle de l'en-cours client.

004

Contrôle de la capacité de la machine disponible.

alpha1[6,8]

Code du mot de passe permettant de débloquer un contrôle

Le mot de passe associé est défini dans le paramètre associé de type PWD.

alpha1[9,11]

Statut du code blocage automatique à sa création. DEBloqué ou BLOqué (valeur par défaut)

alpha1[12]

Si ce code blocage est positionné, empêche-t-il la réouverture de la fenêtre de revue de contrat en fin de ligne de commande ? (O/N, N par défaut).

A partir du moment où un des codes blocages détecté a pour valeur N, la fenêtre de revue de contrat se rouvrira. VoluFiche

alpha2[1]

Uniquement si contrôle manuel. Blocage des AR de commande (O/N)

alpha2[2]

Uniquement si contrôle manuel. Blocage de la production (O/N)

alpha2[3]

Uniquement si contrôle manuel. Blocage saisie des bons de livraison (O/N)

alpha2[4]

Uniquement si contrôle manuel. Blocage calcul de factures (O/N)

alpha2[5]

Uniquement si contrôle manuel. Blocage réservation de capacité (O/N)

alpha3[1]

Uniquement si contrôle automatique.

On effectue le contrôle si la quantité commandée a été modifiée (O/N)

alpha3[2]

Uniquement si contrôle automatique.

On effectue le contrôle si le prix de vente a été modifié (O/N)

alpha3[3]

Uniquement si contrôle automatique.

On effectue le contrôle si la date de fin de fabrication prévue a été modifiée (O/N)

alpha3[31,34]

Uniquement si contrôle automatique. Valeur de X à utiliser pour le contrôle de type 002

alpha3[35,38]

Uniquement si contrôle automatique. Valeur de Y à utiliser pour le contrôle de type 002

alpha4[9,11]

Contrôle du prix de vente pour un article négoce. VoluFiche

Récapitulatif du paramétrage

#CF CDE alpha3[37,38]

Racine du code TSC de stockage des codes blocages de la revue de contrat

TYC alpha1[32] et [33]

Pour désactiver l'affichage des 2 fenêtres des données techniques (inutile car redondant), mettre ces 2 valeurs à N. Vérifier aussi mp_param[33] qui doit être également à N.

TYC alpha2[28,30]

Type d'entrée prévisionnelle sur lieu intermédiaire en saisie de commande et en édition d'AR

TYC alpha3[18]

Ouverture de la fenêtre Revue de contrat

TYC alpha3[43]

Recopie automatique de la revue de contrat de la ligne précédente

TYC alpha3[60]

La ligne de commande de type FBI est-elle livrable ?

O La ligne de la commande est livrable si le lieu intermédiaire de la revue de contrat est saisi.

TYC alpha4[31]

Création d'un mouvement d'entrée prévisionnelle en stock sur lieu intermédiaire de livraison

TYC alpha4[49]

Création d'un mouvement d'entrée prévisionnelle en stock sur le lieu intermédiaire de livraison pour l'ensemble monté. VoluFiche

TYC alpha4[50]

Création d'un mouvement d'entrée prévisionnelle en stock sur le lieu intermédiaire de livraison pour les composants PF. VoluFiche

QAL alpha2[4,6]

Type de mouvement de stock d'entrée prévisionnelle sur lieu intermédiaire en saisie de commande client. VoluFiche

BLO

Paramétrage détaillé, voir tableau ci-dessus.

MDB

(motifs de déblocage)

La note CODES_BLOCAGE_ASS permet de définir les codes blocage associés.

Dans la revue de contrat, lorsque l'on débloque la commande par la touche F6, on peut ne proposer que les motifs de déblocage dont le code blocage a été spécifié dans les notes.

Ü En l'absence de paramétrage, on propose tous les motifs de déblocage existants.

Ü S'il existe un paramétrage sur tous les motifs de déblocage mais que le code blocage recherché n' en fait pas partie, alors on passe directement la commande à l'état DEBloqué sans proposer la liste des motifs.

QA alpha1[8] et [10]

Code blocage raison planning et commerciale pour PC-Topp

QT alpha1[6]

Code blocage raison commerciale pour PC-Topp

Le code blocage indiqué sur la qualité tiers est prioritaire sur le code blocage indiqué dans la note CBACON (laquelle reste indispensable pour déclencher le calcul du risque).

Autrement dit, le code blocage qui peut apparaître en bas de la fenêtre de la revue de contrat sera :

le code blocage de la qualité tiers s'il existe,

<OU>

le code blocage de la note CBACON qui doit exister dans tous les cas.

CIC

Les CIC codés à partir de P03 indiquent les codes blocage de la revue de contrat.

cde option -Ode

Pour désactiver la saisie des dates de livraisons (inutile car redondante), retirer cette option.

cde option -Olg

Liste des groupages concernant une ligne de commande. VoluFiche

cde option -Osh

Possibilité de saisir les heures liées aux quatre dates de la revue de contrat

cde alpha3[53,58]

Type de notes de l'écran et de l'historique de revue de contrat

cde alpha4[36]

Permet de vérifier la cohérence des dates demandée, proposée et de départ ainsi que le code de tolérance de livraison entre la revue de contrat et la première ligne de cadencement de livraison non annulée (et selon le paramétrage non soldée).

cde notes CBA

Les notes commençant par CBA définissent les codes blocage.

cde notes VISU_PLANIFICATION

Permettre l'accès à la visualisation de l'état en production depuis les commandes

(revue de contrat et interrogation)

acr option -Otg

Majoration de la quantité lancée en génération des FBI (pour les onduleurs)

Prend en compte la tolérance quantitative de la revue de contrat

acr alpha3[10,12]

Type de note historique de la revue de contrat

acr note TYPE_NOTE_RC

21 à 23 Type de note de la revue de contrat - SPECIFIQUE

acr note TYPE_LIAISON_CTR

21 à 23 Code paramètre du type de liaison contrat

blv option -Omm

Mise à jour du magasin du mouvement de livraison prévisionnel. VoluFiche

blv option -Opn

La transformation des entrées prévisionnelles en entrées normales est faite si le lieu intermédiaire de l'entête du bon de livraison est identique à celui de la revue de contrat.

blv option -Or1

Si on n'a pas saisi de lieu intermédiaire sur la ligne de commande (Fenêtre revue de contrat), la livraison est considérée comme une vente normale afin de déclencher la mise à jour des sorties réserves.

blv option -Or2

La mise à jour des sorties réserves ne dépend pas du type de livraison, mais du fait que le lieu de la sortie réserve soit identique au lieu de la sortie normale .VoluFiche

v_cdem

Tri possible sur le lieu de rangement 1 : ordre de tri N° 49 (c_lieu_rgt1)

Si lc_lieu_rgt1 (le lieu de rangement 1 de la ligne de commande, dans la fenêtre revue de contrat) est alimenté, l'adresse de livraison est alimentée avec le code client et le code adresse de livraison de celui-ci (RG1 alpha1[14,19] et RG1 alpha1[20,22]), sinon avec le code client et le code adresse de livraison de la ligne de commande (lc_adl).

Pour visualiser les commandes bloquées, notamment suite à un contrôle de l'encours client. Option -Ocb dans v_cdem.


Risque client

Paramètres utilisés | Paramétrage | Utilisation
BLO | Société | Saisie des tiers
QT | Code blocage | Saisie des commandes clients
#CF SFA | Saisie de commande | Visualisation des commandes bloquées
#CF FLA | Qualité tiers | Mise à jour de la qualité Tiers : voir #CF SFA
 | Gestion multisite |
 | Amélioration des performances |
 | Majoration de la quantité commandée |
Table risque_detail | Gestion de la table risque_detail |

Qu'est-ce que le risque client ?

Schématiquement, on peut définir le risque client de la façon suivante :

Un montant d'autorisation est défini pour un client.

Le risque est calculé comme indiqué ci-dessous.

Historique comptable

+ Factures non transférées

+ Carnet de commande

-------------------------------------

= Encours

è

Encours > Autorisation : blocage

Encours » Autorisation : avertissement

Encours < Autorisation : feu vert

Le contrôle du risque est disponible dans les modules suivants :

  • Devis

  • Commande client

  • Commande fournisseur

  • Bon de livraison

PARAMETRAGE

Fiche société

Gestion de l'encours de crédit : so_options[8] = O

Code blocage automatique

Créez un (ou plusieurs) paramètre(s) de type BLO, code FIN (comme FINancier) ou autres codes à votre convenance.

alpha1[1] A (comme Automatique)

alpha1[2] [espace]

alpha1[3,5] 003 (Contrôle de l'encours client)

alpha1[6,8] Code du mot de passe de déblocage (défini en paramètre de type PWD)

alpha1[9,11] BLO (Statut du code blocage automatique lors de sa création)

alpha1[12]

alpha2 Niveaux de blocage (ARC, Production, BL, Facture, …)

alpha3 Options qui déclenchent l'activation du blocage automatique

Saisie de commande

Sur le paramètre de lancement de cde, créez une note de type CBA (Code Blocage Automatique) comme suit :

Caractères 1 à 3 CBA

Caractères 4 à 6 CON (comme CONtrôle)

Caractères 7 à 9 FIN (comme FINancier) (ou autre code à votre convenance)

Cette note n'est suivie d'aucun paramètre.

Autrement dit, si vous voulez créer plusieurs codes, il faut créer autant de notes commençant par CBA.

Qualité tiers

Créez des codes qualité tiers

Exemples

Code | Libellé | Valeur alpha 1 1234567890123 | Note(s)
OKO | Ok manuel, OK suite au calcul | OOOO N CP | Pas de notes particulières
OKW | Ok manuel, Warning suite au calcul | WWWW WFIWCP | Note indiquant le risque potentiel
OKB | Ok manuel, Bloquant suite au calcul | BBBB BFIBCP | Note indiquant le blocage

Dans ces exemples, nous avons créé 3 codes qui partent tous du principe de base selon lequel le client ne pose pas de problème d'impayé (d'où le libellé « OK manuel »).

En revanche, suite au calcul du risque, la situation peut changer :

  • Soit il n'y a toujours pas de problème (OK suite au calcul, code OKO)

  • Soit le client a commencé à utiliser le montant de l'autorisation (Warning suite au calcul, code OKW)

  • Soit le client a carrément dépassé le montant de l'autorisation (Blocage suite au calcul, code OKB)

Si vous le souhaitez, le code qualité tiers, renseigné dans le 1er écran de la fiche tiers, peut être mis à jour automatiquement en fonction du résultat du calcul du risque.

Pour activer cette fonctionnalité, #CF SFA alpha2[24] doit être à O (OUI). Voici ce qui se passera alors :

Soit le risque = Historique comptable
+ Factures non transférées
+ Carnet de commande
– Montant de l'autorisation (saisi dans la fiche client)

  • Si le risque est négatif ou nul, le 3ème caractère de la qualité tiers sera mis à jour avec un code OK paramétré sur #CF SFA. Plus d'info ici

  • Si le risque ne dépasse pas (Montant de l'autorisation * % d'écart accepté), le 3ème caractère de la qualité tiers sera mis à jour avec un code WARNING paramétré sur #CF SFA.

  • Si le risque dépasse (Montant de l'autorisation * % d'écart accepté), le 3ème caractère de la qualité tiers sera mis à jour avec un code BLOQUANT paramétré sur #CF SFA.

  • Le % d'écart accepté représente le risque que VOUS prenez par rapport au montant de l'autorisation qui, lui, est couvert par la SFAC.

Ainsi, par exemple, le code qualité tiers du client peut passer de OKO à OKW si le client utilise tout ou partie de son autorisation, voire OKB s'il dépasse le montant de l'autorisation.

A l'inverse, le code peut repasser de OKW (ou OKB) à OKO si le client a réglé tout ou partie des factures en cours ou encore si le montant de son autorisation a été augmenté.

Les codes blocages FIW et FIB indiqués dans les exemples ci-dessus en alpha1[8,10] sont des copies conformes du code FIN indiqué en exemple de la note CBACONFIN sur le paramètre de lancement de cde. Seule la 3ème lettre (N) du code FIN a été substituée respectivement par W (Warning) et B (Bloquant).

Ü Ü Ü Le code blocage indiqué sur la qualité tiers est prioritaire sur le code blocage indiqué dans la note CBACON (laquelle reste indispensable pour déclencher le calcul du risque).

Autrement dit, le code blocage qui peut apparaître en bas de la fenêtre de la revue de contrat sera :

 le code blocage de la qualité tiers s'il existe,

<OU>

‚ le code blocage de la note CBACON qui doit exister dans tous les cas.

Gestion multisite

Option payante BAS-16

Permet de différencier les encours et assurance crédit par site de production et site d'agrément.

Voir aussi la fiche sur la gestion des sites de production.

cli alpha3[2,4] Site de production par défaut

#CF SIT alpha1[1] = O Gestion multisite
alpha1[3] = Activation de la gestion du risque client par site (O/N, N par défaut)
Permet d'activer / désactiver la gestion du risque client par site sans remettre en cause tout le paramétrage effectué.

#CF SFA alpha2[28] = O Alimentation de la table RISQUE_DETAIL en commande via flash
alpha2[29] = O Alimentation de la table RISQUE_DETAIL en facturation via flash
alpha2[30] = O F18 sur fiche client à partir de la table RISQUE_DETAIL
alpha2[60] = N Utilisation du nouveau module de calcul de l'assurance crédit

SIT alpha4[1,3] Code du site d'agrément rattaché au site de production

int_cpt Nouvelle zone Site de production pour les fichiers de type 1

Amélioration des performances

L'ancienne méthode de calcul du risque est relativement lente car elle recalcule systématiquement toutes les composantes de calcul. La table risque_detail n'est pas employée.

La nouvelle méthode de calcul du risque est plus rapide car elle exploite la table risque_detail.

La table risque_detail est alimentée en batch (par exemple la nuit), sur la base du flash, via le programme risque_detail.

En outre, le programme risque_detail est capable d'appeler le programme int_cpt afin d'intégrer les éléments de la comptabilité.

Le paramétrage suivant doit être mis en œuvre :

so_options[36] Gestion du flash journalier = O ou N.
Si vous ne gérez pas le flash journalier, vous pouvez régler ce paramètre sur N tout en profitant du flash uniquement pour la gestion du risque client. Dans ce cas, vous devez quand même créer le paramètre #CF FLA avec une note d'imputation par défaut comme suit :
Caractères 1 à 9 DEF_IMPUT
Caractères 15 & 16 99 (flash générique)
Caractères 17 à 19 FAM
Caractère 25 * (toutes familles confondues)
Caractère 28 * (toutes sous-familles confondues)

#CF SFA alpha2[28] = O (Oui) pour alimenter la table risque_detail en commande
alpha2[29] = O (Oui) pour alimenter la table risque_detail en facturation
alpha2[30] = O (Oui) pour que la touche F18 affiche le risque en se basant sur la table risque_detail (sinon on recalcule tout à chaque fois)
alpha2[15] (type de risque) doit être renseigné.
alpha2[16] (type d'édition) doit être renseigné.

TYC Le TYC des commandes concernées doit être paramétré pour alimenter la table risque_detail :
TYC alpha3[41] doit être à O (Oui).

Attention à distinguer les CDA des CD1

TYC alpha3[41] = O (oui) pour la CDA

TYC alpha3[41] = N (non) pour la CD1

risque_detail Créez un paramètre de lancement comme suit :
Type #BA, code CRD
alpha1 : risque_detail.4ge –B
alpha2 : #BA IC

int_cpt Créez un paramètre de lancement comme suit :
Type #BA, code IC
alpha1 : int_cpt.4ge –Ord
Consultez l'aide sur ce programme pour les autres paramètres, notamment pour le descriptif du fichier importé.

Majoration de la quantité commandée

Il est possible de majorer la quantité commandée lors du calcul du risque par tranche de

  • surface commandée

  • poids commandé

  • quantité commandée

Principe :

de 0 M² à 500 M² Majoration de 35 %

de 501 M² à 5.000 M² Majoration de 20 %

Les tranches et les pourcentages de majoration associés sont paramétrés dans des TSC sur le client ou sur le client #SOC (tolérance métier).

  • La borne inférieure se paramètre en ic_num1.

  • La borne supérieure se paramètre en ic_num2.

  • La valeur du pourcentage se paramètre en ic_num3.

Le paramétrage se fait en alpha2[19,23] de #CF SFA :

alpha2[19] Recherche du pourcentage de tolérance sur le client (O/N, N par défaut)

alpha2[20] Recherche du pourcentage de tolérance sur le client #SOC (O/N, N par défaut)

alpha2[21,22] Racine info_c tolérance métier (les 2 premiers caractères) (exemple : TQ, Tolérance Quantité)

alpha2[23] Unité utilisée pour la tolérance
S Surface
P Poids
Q Quantité (par défaut)

Gestion de la table risque_detail

La table risque_detail contient 3 types d'enregistrements :

CDE Carnet de commandes

FAC Factures de la comptabilité

FNT Factures non transférées

int_cpt.4ge –Ord | Alimente la table avec les infos des programmes de compta (FAC) | à
risque_detail.4ge | En mode batch (-B) recalcule toute la table pour tous les clients. A lancer une fois par jour si pas de remontée de la compta (int_cpt) crée CDE et FNT sans option crée FAC si #CF SFA alpha2[12] = O et alpha2[34] = O | à
cde.4ge | Alimente la table (CDE) au fur et à mesure de la saisie des commandes si #CF SFA alpha2[28] = O et TYC alpha3[41] = O. | à
facn.4ge | Alimente la table lors du calcul des factures Détruit les types CDE pour créer les types FNT #CF SFA alpha2[29] = O | à
Touche F18 | Affiche le tableau de situation du client (carnet de commande, autorisation, facture non transférées) Si #CF SFA alpha2[30] = O, utilise risque_detail ; sinon, utilise cde1/cde2/fac1/fac2/histo/echeance | ß
Code blocage 003 | Si paramétré, en saisie de commande | ß
risque_detail.4ge | Supprime de la table les enregistrements FNT lors du transfert vers la compta si #CF SFA alpha2[29] = O | ß

UTILISATION

Saisie des tiers

  • Le code qualité tiers est renseigné dans le 1er écran de la fiche tiers.

  • Le code groupe pour le calcul du risque groupe est renseigné dans l'écran Détail (F8) : il s'agit de la 2ème zone Codes groupement. Ce code permet de regrouper des clients dans le calcul du risque.
    L'encours de tous les clients du groupe + l'encours du client référencé comme groupe seront pris en compte dans le calcul (si #CF SFA alpha2[13] = O).

  • Le montant de l'autorisation, alias Crédit accordé, est renseigné dans l'écran Détail (F8) : on peut entrer directement un montant ou faire F7, ce qui ouvre la même fenêtre que quand on fait F19.

  • F19 permet d'accéder à la fenêtre de saisie des montants d'autorisation de crédit.
    On distingue les autorisations Permanentes, Temporaires et Supplémentaires.
    ATTENTION : une autorisation temporaire avec une date de fin éloignée (par exemple 31/12/2100) est très pénalisante.
    Voir aussi #CF SFA alpha2[25,27] pour le paramétrage des colonnes Montant et Dépassement.

  • F18 affiche l'encours du client (état du risque commercial).

  • Les notes commençant par #QT seront affichées à la suite des notes saisies sur le paramètre QT lorsqu'un message d'avertissement ou de blocage sera affiché suite au calcul du risque.

Saisie des commandes clients

F18 affiche l'encours du client (état du risque commercial).

Le contrôle de l'encours se fait à chaque saisie de ligne de commande.

En cas de dépassement de l'encours, un code blocage peut être automatiquement positionné.

Le cheminement de la commande dans la chaîne commerciale pourra aussi être stoppé.

Le calcul du risque se fait sur la revue de contrat, et propose en automatique un blocage si l'encours client est supérieur au montant autorisé.

Lorsque la revue de contrat est renseignée avant la saisie du prix de vente, le calcul du risque se fera en fin de ligne.

Lorsque le code blocage est activé (bloquant ou warning), la revue de contrat est de nouveau affichée.

Visualisation des commandes bloquées

Pour visualiser les commandes bloquées, notamment suite à un contrôle de l'encours client. Option -Ocb dans v_cdem.


Transferts en comptabilité

Cette documentation est essentiellement orientée SAGE 100 mais elle peut être consultée pour tout autre type de comptabilité.

Cette documentation ne présente que les aspects techniques du transfert.

Pour les aspects comptables, veuillez consulter le QuestionnaireTransfertFactures avant l'installation du transfert.

Transfert des factures clients en comptabilité

Saisie des sociétés | Code comptabilité = J (Sage 100) Paramétrez systématiquement le code du journal des ventes (JDV) le code du journal d'achats (JDA) même si vous ne les utilisez pas. Mettez 001 dans la rubrique BD, sauf s'il s'agit d'une comptabilité Volume ou AMI. Dans ces 2 cas, mettez le nom de la base de donnée, c'est à dire le nom du fichier ayant pour extension DBS. Cliquez ici pour afficher / masquer une copie d'écran
#CF TRF | Indiquez le nom du fichier de transfert dans la note FICH_TRAN. Pour Sage 100, indiquez le numéro de dossier correspondant au nom du fichier MAE dans la note L1 qui doit figurer en première position des notes. Indiquez les paramètres généraux dans la note SAGE_100_PARAM_GEN

L'ordre de recherche du compte de vente est le suivant :

  1. Fiche article (zone mp_cptv) puis en ajoutant une des valeurs suivantes pour obtenir les autres numéros de compte :
    #CF TRF : Valeurs numériques 1 & 2, A3[1,8], A4[17,24]

  2. Sur les codes statistiques 1, 2, 3 et 4, dans la note COMPTE_VENTE

  3. Sur la sous-famille, en A2[13 et suivants]

  4. Sur la famille, dans les notes commençant par TVAxyyyzzz,
    où x représente V pour Vente ou C pour Avoir (voir explication plus bas), yyy représente le code TVA et zzz représente le code catégorie de client.

  5. Sur la famille, en A1[1 et suivants]

  6. Sur la TVA, en A3[1 et suivants]

  7. Sur le #CF TRF A1[1,8] puis en ajoutant une des valeurs suivantes pour obtenir les autres numéros de compte :
    #CF TRF : Valeurs numériques 1 & 2, A3[1,8], A4[17,24]

Quand le compte de vente a été trouvé, on peut déterminer :

le compte HT sur les encaissements, si TVA A1[34] = E : au compte de vente, on ajoute la valeur indiquée dans #CF TRF A3[9,16]

un autre compte de vente : au compte de vente, on ajoute la valeur indiquée dans CAT valeur numérique 2

Quand le compte de vente Avoir est différent du compte de vente Facture...

La note _COMPTE_VENTE_AVO permet de paramétrer un compte de vente (classe 7) spécifique si c'est un avoir.

Ceci permet de distinguer le compte de vente Facture (dont l'ordre de recherche est expliqué ci-dessus) et le compte de vente Avoir.

Si la note _COMPTE_VENTE_AVO n'est pas paramétrée, alors le système prendra le compte de vente dont l'ordre de recherche est expliqué ci-dessus.

Attention, cette note est précédée d'un caractère _ (underscore).

21,28 Compte de Vente France

29,36 Compte de Vente Export

37,44 Compte de Vente Suspension de Taxe

45,52 Compte de Vente Intracommunautaire

53,61 Compte de Vente Exonéré

Contrairement au compte de vente Facture, le compte de vente Avoir se paramètre uniquement dans la note _COMPTE_VENTE_AVO dont l'ordre de recherche suit la même logique, à savoir :

  1. Sur les codes statistiques 1, 2, 3 et 4

  2. Sur la sous-famille

  3. Sur la famille

  4. Sur la TVA

  5. Sur le #CF TRF


EDI Fiche d'installation

(Par message, on entend : données transmises par EDI. Exemple : une ligne de BL, de facture, de commande, ...)

EDI

Définition (extraite de WikipédiA)

Autre site de vulgarisation de l'EDI : guidescomparatifs.com

Principe

L'EDI permet à des systèmes hétérogènes de communiquer entre eux, via un traducteur.

Cette communication a pour but principal la dématérialisation des documents papiers (commandes, AR, BL, factures, ...)

La traduction est gérée :

- soit en interne via l'achat d'un traducteur

- soit en externe, par un prestataire spécialisé

La traduction nécessite un protocole d'échange entre les différents tiers, y compris les traducteurs.

Un tiers dialogue avec l'ensemble de ses partenaires via un seul fichier de sortie.

Les partenaires reçoivent des messages de différentes origines via un seul canal.

Cliquez ici pour afficher / masquer un organigramme de communication via traducteur.

Au niveau de VoluPack

Dans VoluPack, un certain nombre de programmes peuvent intégrer ou générer des messages en provenance / à destination d'autres applications.

Ces programmes interviennent au niveau :

- des commandes d'achat

- des commandes clients

- des encours et des inventaires

- des livraisons

- de la facturation

L'avantage de la solution VoluPack est que vous pouvez directement échanger des données avec d'autres tiers.

Les 5 grands pôles de l'EDI dans VoluPack

Comme le montre l'organigramme ci-dessus, les échanges EDI se font à 5 niveaux:

  1. La gestion des commandes d'achat

  2. La gestion des commandes clients

  3. La gestion des encours et des inventaires

  4. La gestion des livraisons

  5. La gestion de la facturation

1) La gestion des commandes d'achat

La commande d'achat est générée à partir :

A) d'une commande fournisseur

B) d'une commande client

1A - à partir d'une commande fournisseur

Programme de saisie : cdef

cdef A4[1,6] indique le paramètre de lancement de l'édition (programme edicf).

edicf lance le programme de génération EDI des commandes d'achat, via la note GENERER_EDI_ORDERS.

Le programme de génération EDI des commandes d'achat, generer_edi_cde, crée le fichier ORDERS à destination du fournisseur.

1B -à partir d'une commande client

Programme de saisie : cde

cde A3[22,27] indique le paramètre de lancement de l'édition des AR (programme acr).

acr lance le programme de génération EDI des commandes d'achat, via la note GENERER_EDI_ORDERS.

Le programme de génération EDI des commandes d'achat, generer_edi_cde, crée le fichier ORDERS à destination du fournisseur.

Cliquez ici pour afficher / masquer l'organigramme ORDERS.

2) La gestion des commandes clients

Pré-requis

Identifier les tiers EDI :

Notes de type EDI sur les tiers

Ces notes permettent d'identifier un tiers comme étant un tiers EDI (dans la table cli3)

Le paramètre NTS EDI doit exister.

La recherche des notes EDI sur les notes du tiers (cli3) nécessite la pose d'un index sur cli3 (cc_com).

La ligne de commentaires (zone cc_com dans cli3) doit être structurée ainsi : (info vérifiée le 12/10/2011)

1,19 Identifiant EDI du tiers

20,23 Code magasin du point de livraison

24,40 Point de déchargement du client

Identifier les articles EDI : libellé étranger

Identifier les types de commandes

TYC A3[49] Ce TYC peut être utilisé pour des commandes Manuelles / EDI / Toutes.

Mécanisme

3 étapes principales :

A) Gestion des messages entrants (les prévisions, les commandes, les appels)

B) Visualisation des messages reçus (la visu déclenche la génération de commandes)

C) Gestion des messages sortants (AR)

2A - Gestion des messages entrants

Le programme integrer_edi_cde importe :

les prévisions et demandes de livraison (DELFOR et DELINS) en provenance du client

les commandes et les appels de livraison (CALDEL et ORDERS) en provenance du client

2B - Visualisation des messages reçus

Le programme v_edi_cde_delfor visualise les prévisions et demandes de livraison (DELFOR et DELINS)

Le programme v_edi_cde visualise les commandes et les appels de livraison (CALDEL et ORDERS)

Ces 2 programmes génèrent des commandes à partir de la table edi_cde.

2C - Gestion des messages sortants (AR)

cde A3[22,27] indique le paramètre de lancement de l'édition des AR (programme acr).

acr lance le programme de génération des messages sortants (AR) pour tous les clients dont cl_param[16] = O.

Le programme de génération des messages sortants, edi_cde_rep_cli, crée le fichier ORDRSP à destination du client.

3) La gestion des encours et des inventaires

3A - Encours et inventaires

maj_stk_lot_lieu A2[10,15] indique le paramètre de lancement de l'édition du programme generation_invrpt_wiprpt.

Le programme generation_invrpt_wiprpt génère 2 fichiers à destination du client:

le fichier des encours (WIPRPT)

le fichier des inventaires (INVRPT)

Cette gestion peut s'inscrire dans le cadre d'une GPA (Gestion Partagée d'Approvisionnement)

3B - Bons de réception

Le programme G_integrer_edi_brc permet d'intégrer un fichier au format AVIEXP contenant des bons de réceptions dans les tables edi_rec et edi_rec_cond.

Le programme G_v_edi_brc permet de visualiser et de générer les bons de réception intégrés.

Ces 2 programmes n'existent qu'en environnement GENERO.

4) La gestion des livraisons

4A - Paramétrage du client livré

Le fichier AVIEXP n'est généré que pour les clients pour qui la zone F du TSC TRS est différente de N (Non).

Différents modes de gestion peuvent être instaurés :

- suivant que l'AVIEXP fait suite à un message CALDEL ou non,

- suivant que le client impose une gestion des numéros de lots (palettes).

4B - Génération du fichier AVIEXP

Programme de saisie des BL : blv

blv A2[19,24] ou A2[47,52] indique le paramètre de lancement du programme d'édition des BL (programme (programme blv_ed1).

blv_ed1 option Oep permet de lancer la génération du programme edi_cde_aviexp (voir ci-dessous).

4C - Enchaînement des éditions et génération AVIEXP

La génération d'un message AVIEXP est généralement liée à l'édition d'étiquettes palettes et d'un BL GALIA.

L'enchaînement peut se faire par exemple de la façon suivante :

  • L'édition provisoire du BL déclenche l'édition des étiquettes palettes.

  • L'édition définitive du BL déclenche l'édition du BL GALIA.

  • L'édition du BL GALIA déclenche la génération du fichier AVIEXP.

Cet enchaînement peut être standard pour tous les clients AVIEXP du site, mais peut aussi être paramétré par client livré (voir option Oep dans blv_ed1)

Le paramétrage et l'enchaînement sont décrits ci-après :

A - Edition des étiquettes GALIA sur édition provisoire

Lancé manuellement - pas d'enchaînement.

Programme Type et code paramètre Libellé long | blv_ed1 #ED BLP Edition bon de chargement
Option -P | Edition provisoire des bons de livraison
Option Oet | Edition des étiquettes spécifiques
Note IMPRIMANTE_ETIQ_PAL | 21,23 Code #LP de l'imprimante utilisée pour l'impression des étiquettes GALIA (la première imprimante sera utilisée)

B - Edition des BL GALIA sur édition définitive standard

Lancé manuellement - enchaînement possible vers un autre programme

Programme Type et code paramètre Libellé long | blv_ed1 #ED BLV Edition BL
Option Oes | Edition spécifique GALIA
Option Oep | Lancement d'un programme externe pour chaque BL édité
A2[30,35] | Type et code du paramètre de lancement du programme d'édition de BL à lancer : par exemple #ED BLG (voir tableau suivant) Uniquement si l'on n'utilise pas la note PGM_RUN_PROG_CLI
Note PGM_RUN_PROG_CLI | Paramétrage du programme à lancer pour chaque BL par client / adresse de livraison Uniquement si l'on n'utilise pas alpha2[30,35]

C - Edition des BL GALIA

Lancé par chaînage - enchaînement possible vers un autre programme

Programme Type et code paramètre Libellé long | blv_galia_ed1 #ED BLG BL GALIA
Option -X[n] | où n est le code de l'imprimante utilisée pour l'édition spécifique GALIA
Option -W[xxx] | où xxx est le numéro d'imprimante utilisée pour l'édition spécifique GALIA
Option Obp | Pas de sélection des BL édités en provisoire
Option Obn | Pas de sélection des BL non édités
Option Oep | Lancement d'un programme externe pour chaque BL édité
alpha2[30,35] | Type et code du paramètre de lancement du programme de transfert AVIEXP à lancer : par exemple #TR EXP (voir le programme edi_cde_aviexp) Uniquement si l'on n'utilise pas la note PGM_RUN_PROG_CLI
Note PGM_RUN_PROG_CLI | Paramétrage du programme à lancer pour chaque BL par client / adresse de livraison Uniquement si l'on n'utilise pas alpha2[30,35]

La mise en place des options Obp et Obn permet de ne pas faire de test sur le champ b1_edit, et ainsi imprimer les bons de livraison préalablement édités en définitif dans l'édition standard des BL.

5) La gestion de la facturation

Programme de saisie : facn

facn option Oin active la génération de fichiers INVOICE.

facn notes FIC_XXXXXXX, FIC_LOCK_INVOICE, FIC_LOCK, FIC_LOCK_VS et FIC_ANOMALIE pour le paramétrage du fichier à générer.

Créer le TSC INV - La clé est constituée du code client et du code adresse.

Voir aussi le TSC CIV qui permet de gérer la version 3 du fichier EDI INVOICE (ajout du code EDI du service à facturer)

Créer le #CF EDI

Voir aussi

TSC CAL Adresse de livraison réservée CALDEL

TSC ORD EDI ORDERS

TSC FAV Fichier EDI TOSHIBA par visu des stocks

Principe de fonctionnement des verrous (locks)

tables edi_cde, edi_rec, edi_rec_cond

qte _prod A3[13,27] : Lieux 1-2-3 de déstockage (pour le montage des PF) (Spécifique)

Attention, il existe un TSC EDI qui n'a rien à voir avec l'EDI !

Récapitulatif des formats de fichiers

Commandes fournisseurs

V1 ORDERS ETU_EDI_format fichiers EDI ORDERS

V5 ORDERS ETU_EDI_format fichiers EDI ORDERS

Prévisions - Commandes - Appels

V1 ORDERS ETU_EDI_format fichiers EDI ORDERS

V2 DELFOR ETU_EDI_format fichiers EDI DELFOR

V3 DELINS ETU_EDI_format fichiers EDI DELINS

V4 CALDEL ETU_EDI_format fichiers EDI CALDEL

V5 ORDERS ETU_EDI_format fichiers EDI ORDERS

Idem V1 avec nouvelles zones :

Zone paramétrée 3 (CDELIG 73)

Code lieu de facturation (CDELIG 74)

Lieu de facturation (CDELIG 75)

V6 CALDEL ETU_EDI_format fichiers EDI CALDEL

Idem V4 avec nouvelle zone :

N° de l'identifiant transport (CDEENT 34)

V7 CALDEL ETU_EDI_format fichiers EDI CALDEL

Idem V6 avec nouvelles zones :

Qualifiant date (CDELIG 20)

Code de routage de l'UM (CDELIG 21)

V8 CALDEL ETU_EDI_format fichiers EDI CALDEL

Idem V7 avec nouvelles zones

Date début enlèvement (CDELIG 22)

Heure d'enlèvement au plus tôt (CDELIG 23)

Date fin enlèvement (CDELIG 24)

Heure d'enlèvement au plus tard (CDELIG 25)

Réponses clients (AR)

ORDRSP V1 ETU_EDI_format fichiers EDI ORDRSP

ORDRSP V2 ETU_EDI_format fichiers EDI ORDRSP

Encours et inventaires

WIPRPT ETU_EDI_format fichiers EDI WIPRPT

INVRPT ETU_EDI_format fichiers EDI INVRPT

Avis d'expédition

AVIEXP V1 ETU_EDI_format fichiers EDI AVIEXP

AVIEXP V2 ETU_EDI_format fichiers EDI AVIEXP

AVIEXP V3 ETU_EDI_format fichiers EDI AVIEXP

AVIEXP V4 ETU_EDI_format fichiers EDI AVIEXP

AVIEXP V5 ETU_EDI_format fichiers EDI AVIEXP

Factures

INVOIC ETU_EDI_format fichiers EDI INVOIC


Logistique

Logistique aval

Il existe également une documentation fonctionnelle sur la gestion des ordres de transport :

OrdresTransport.pdf qui figure sur votre CD de mise à jour.

La logistique aval peut être découpée en 3 domaines distincts.

  • Les tarifs

  • La préparation des affrètements

  • Les expéditions

En bas de page : autres paramètres liés à la logistique.

Les tarifs

zones_tarif_affret | Zones tarifaires et affrètements PAY A1[16,18] Code ISO du pays PAY A1[36] Pays utilisant l'équivalent du code INSEE pour les communes françaises PAY A1[38] Longueur du code département dans le code postal (0 à 8) Pour la gestion des tarifs par comtés, régions, ... : #CF CLI A4[1,10] Libellé de la zone paramétrée adresse qui apparaît sur la fiche client #CF CLI A4[11,13] Type du paramètre de la zone paramétrée adresse (réservé aux comtés, régions, ...)
grilles_pour | Grilles de pourcentage
tarifs_transporteur | 1) Saisie des transporteurs avec les 2 TSC suivants : TSC TVx (Types de véhicules autorisés) où TV représente la racine, paramétrée en #CF LOG A1[6,7], et x représente un caractère libre. Sur chaque TSC, on peut indiquer jusqu'à 3 types de véhicules dans les zones alpha F, G, H. TSC MCT Mode de valorisation du transport (utilisé dans la simulation de transport) Clé = code transporteur Zone C (numérique 1) = 1 (au plus cher), 2 (au plus loin), 3 (au jalonnement) ou 4 (au lot) 2) Saisie des tarifs transporteurs TFA A1[1] Type d'application du type de frais (1 Chargement, 2 Déchargement, X Autres) #CF TRA : traçabilité sur les tables ordre_transport tarif_transp_ent, tarif_transp_acc, tarif_transp_lig, tarif_transp_pla RG1 A1[41,43] Code de regroupement du magasin de départ utilisé pour les tarifs transporteurs
tarif_transp_export | Export des tarifs transporteurs
tarif_transp_import | Import des tarifs transporteurs
geocodage_cli | Géocodage client - gestion du distancier cli option Ogc #CF WSL Configuration Way Server PAY A2[1,3] Code pays utilisé par LOXANE (Way Server)
simul_transport | Simulation de transport TSC MCT saisi sur le transporteur (voir ci-dessus dans les tarifs transporteur) #CF WSL Configuration Way Server UNI A1[9] = Unité d'utilisation pour le calcul du transport UNI A1[19] Périodicité du forfait J = Journalier, M = mensuel, N = non (par défaut) UNI A1[20] Notion de camion complet TRS A1[11] = Valorisation du coût de transport (O/N, L = Location) TRS A1[19,21] Code magasin de départ par défaut (de type RG1) pour tarif location

Devis onduleur

Intégration du tarif transport dans le devis onduleur

Permet d'intégrer dans le devis le coût du transport calculé via la fonction de simulation des coûts de transport et le logiciel Way Server (calcul de la distance entre le lieu de chargement et le lieu de livraison).

L'appel à ce calcul se fait par une nouvelle action de service à paramétrer.

L'opération élémentaire rattachée à cette action de service doit avoir une cadence égale à 1 et un taux horaire du centre de coût associé égal à 1.

Créer une action de service AS TRO (Transport optimisé) avec les notes suivantes commençant par C :

CDK - CPOI - CSUR - CMLK - CNPK - CMT - CTV. Pas de paramétrage sur ces notes.

Cliquez ici pour afficher / masquer une copie d'écran.

Nouveau code calcul CT (Coût transport)

Caractéristique d'action de service donnant la distance kilométrique : DK

Caractéristique d'action de service donnant le mode de transport : MT

Caractéristique d'action de service donnant le type de véhicule : TV

Cliquez ici pour afficher / masquer des copies d'écran.

Créer les caractéristiques actions de service (CAS) correspondant aux notes AS TRO créées.

CAS DK - Distance kilométrique

CAS A2[1,3] | NUM | Valeur numérique
CAS A2[7,8] | DK | code calcul de la valeur de la caractéristique
CAS A2[16] | 1 | Valeur par défaut

CAS POI Poids

CAS A2[1,3] | NUM | Valeur numérique
CAS A2[7,8] | TS | TSC
CAS A2[9] | X | Produit fini
CAS A2[10,12] | 202 | Code du TSC
CAS A2[13] | C | Code zone du TSC
CAS A2[14] | M | Résultat = Résultat X quantité commandée / 1000
CAS A2[16] | 1 | Valeur par défaut

CAS SUR Surface

CAS A2[1,3] | NUM | Valeur numérique
CAS A2[7,8] | TS | TSC
CAS A2[9] | X | Produit fini
CAS A2[10,12] | 202 | Code du TSC
CAS A2[13] | D | Code zone du TSC
CAS A2[14] | Q | Résultat = Résultat X quantité commandée
CAS A2[16] | 1 | Valeur par défaut

CAS MLK Métrage linéaire

CAS A2[1,3] | NUM | Valeur numérique
CAS A2[7,8] | ML | Mètres linéaires de plancher du camion
CAS A2[9,12] | 2400 | Largeur du camion (en millimètres)
CAS A2[16] | 1 | Valeur par défaut

CAS NPK Nombre de palettes

CAS A2[1,3] | NUM | Valeur numérique
CAS A2[7,8] | NP | Nombre de [ce qui est paramétré en A2[9]) pour un PF
CAS A2[9] | Y | il s'agit de palettes
CAS A2[16] | 1 | Valeur par défaut

CAS MT Mode de transport

CAS A2[1,3] | ALP | Valeur alpha
CAS A2[4,6] | TRS | Type de transport (si nécessaire)
CAS A2[7,9] |  | Code calcul qui retourne la valeur de la caractéristique
CAS A2[16,18] | CAM | Code utilisé par défaut (exemple : CAM Camion)

CAS TV Type de véhicule

CAS A2[1,3] | ALP | Valeur alpha
CAS A2[4,6] | TVE | Type de véhicule (si nécessaire)
CAS A2[7,9] |  | Code calcul qui retourne la valeur de la caractéristique
CAS A2[16,18] | SR | Code utilisé par défaut (exemple : SR Semi-Remorque)

La préparation des affrètements

Commandes clients

cde A4[31] Contrôle de la présence de groupage en cas de modification de la ligne de commande.

cde A4[57] Message indiquant qu'il existe un affrètement pour la même date et la même

destination que celles de la ligne de commande en cours (à la création).

#CF LOG Configuration logistique - utilisé dans cde, v_cdem et acr

#CF LOG A1[1] Logistique activée (O/N, N par défaut)

#CF LOG A1[2] Type d'annulation de l'ordre de transport (L/P, P par défaut)

#CF LOG N1 Largeur du camion pour le calcul du métrage linéaire restant à livrer de la commande

#CF LOG Note SUP_REQ_G_STD_D Supplément de requête sur la table des gammes standard

pour la recherche de la dernière machine de la gamme.

prep_affret - GENERO

Préparation des affrètements

#CF LOG N2 Pourcentage de tolérance sur le métrage maxi type de véhicule

#CF LOG A1[3,5] Code TSC pour l'ordre des étapes

#CF LOG A1[8,10] Type de notes affrètement

#CF LOG A1[11,13] Type de notes annulation affrètement

#CF LOG A1[17,18] Racine du code TSC des frais accessoires facultatifs utilisé pour un affrètement donné

#CF LOG A1[19,21] Type de notes historisation de la valorisation d'un affrètement

#CF LOG A1[22] Code contrôle pour vérification qu'un affrètement ne dépasse pas la

capacité maximum (métrage linéaire) du type de véhicule sélectionné

#CF WSL A4[2] Forçage de la valorisation des transport au plus loin (O/N, N par défaut)

TFA A1[2] Frais systématique (S) ou facultatif (F)

TRS A1[11] Valorisation du transport (O/N, O par défaut)

TRS A1[13,18] Code transporteur imposé pour les modes de transport sans valorisation

RTA A1[1] Réponse du transporteur (O/N, O par défaut)

BLO A2[11] Blocage envoi commande pour l'affrètement (O/N, N par défaut)

CIC à créer sur le client :

CIC PTV Type de véhicule

CIC C22 Palette à reprendre

CIC NHD Heure de début de livraison

CIC NHF Heure de fin de livraison

edition_ordre_achat_transport

Edition de l'ordre d'achat de transport

Déclenchée par les modules de préparation des affrètements et d'expédition des affrètements

#CF LOG A1[14,16] Type de notes d'édition des ordres d'achat de transport

PRP A1[6,11] Code tiers associé au préparateur

TRS A1[12] Edition d'un ordre d'achat de transport (O/N, N par défaut)

interface_sddata

Interface SD DATA (PC-TOPP)

maj_stk_lot_lieu

Nécessaire pour la mise à jour de la table stk_lot_lieu, pour la consultation et la mise à jour d'indicateurs dans la préparation des affrètements.

Doit être exécuté à intervalles réguliers (cron).

Les expéditions

exped_affretements

Gestion des expéditions des affrètements

#CF LOG Configuration logistique

Livraisons

Saisie des BL

blv Option Ofa

Ouverture automatique de la fenêtre du picking si la quantité livrée est à zéro

De plus, le nombre de colis ou de palettes de la ligne du BL est alimenté par le nombre de palettes du picking à la validation de celui-ci.

blv Option Ogi

Lorsqu'un BL est rattaché à un numéro de groupage présent dans la table groupage_bl, il est interdit de le créer, le modifier ou l'annuler dans le programme standard de saisie des BL (blv).

Cette option permet d'éviter la mise à jour d'un BL qui a été créé par le module de gestion des expéditions des affrètements.

blv Option Ow0 (zéro) : Avertissement si quantité livrée à 0

blv Notes NUM_AFFRET_AUTORISE - Limiter les numéros d'affrètements saisissables en création de BL

Edition des BL

blv_ed1 Option Ogi : Lorsqu'un BL est rattaché à un numéro de groupage présent dans la table groupage_bl, il est interdit de l'éditer dans le programme standard d'édition des BL (blv_ed1).

Cette option permet d'éviter l'édition d'un BL qui a été créé par le module de gestion des expéditions des affrètements.

Visualisation des groupages de livraison

v_groupage_bl alpha2[45] Edition de la liste des stocks par lieux

v_groupage_bl alpha4[13] Touche F13 - Gestion des expéditions de l'affrètement (ou du groupage)

v_groupage_bl note _SUP_REQ_LIEUX Supplément de requête pour recherche des stocks par lieux sur stk0

v_groupage_bl note RUN_GES_EXPED_AFFRET Type et code de par. de lancement exped_affretements

interface_prefac

Option payante LIV 3

Interface de préfacturation - Génération de 2 fichiers de transfert pour la compta (entête & lignes)

PAY A1[40] Pays faisant partie de la CEE (O/N)

#CF LOG A1[19,21] Type de notes d'historisation de la valorisation

Autres paramètres

Tables impliquées

Zones modifiées en commande qui entraînent une modification de l'ordre de transport

TSC ETA

QA A1[24] Permet de bloquer un ordre de transport (interdiction de l'affréter) en fonction de la validité de l'article.

Gestion des options :

EFE 07 Ordre achat transport

EVE 17 Ordre achat transport

LIV 03 Gestion des tarifs de transport

Tables impliquées

zones_tarif_affret | Zones tarifaires ou affrètements
zones_affret_vois | Zones affrètements voisines
grilles_pour | Grilles de pourcentage
tarif_transp_acc | Tarifs transporteur frais accessoire
tarif_transp_ent | Tarifs transporteur
tarif_transp_lig | Tarifs transporteur ligne
tarif_transp_pla | Tarifs transporteur plage de tarif
ordre_transport | Ordres de transport
cli_distance | Distance kilométrique entre l'adresse client et un magasin
groupage_bl | Zone gb_etat_affret 0 Affrètement en cours 1 Affrètement validé 2 Affrètement validé et envoyé 3 Affrètement confirmé 4 Affrètement annulé 5 Affrètement expédié provisoire 6 Affrètement expédié définitif 7 Affrètement valorisé 8 Affrètement soldé 9 Affrètement refusé
cli | cl_latitude et cl_longitude pour le géocodage. zone cl_transitaire
cli2 | c2_latitude et c2_longitude pour le géocodage. zone c2_transitaire

Zones modifiées en commande qui entraînent une modification de l'ordre de transport

Table | Zone | Désignation
cde1 | ec_cli | Code client
cde1 | ec_trsp | Mode de transport
cde1 | ec_tport | Type de port
cde1 | ec_ada | Code adresse accusé de réception
cde2 | lc_nummvt | Numéro de mouvement de stock engendré
cde2 | lc_adl | Code adresse livraison
cde2 | lc_prod | Code produit
cde2 | lc_delrep | Date de livraison proposée et accusée (calculée ou manuelle)
cde2 | lc_qtecde | Quantité commandée
cde2 | lc_lieu_rgt1 | Numéro de lieu de rangement niveau 1
cde2 | lc_qualif_appel | Qualificatif appel de livraison (QAL)
cde2 | lc_tolerance_liv | Code tolérance de livraison (TOL)
cde2 | lc_delcli | Date de livraison souhaitée
cde2 | lc_deldep | Date de départ au client
cde2 | lc_heure_cli_tot | Heure client proposée au plus tôt
cde2 | lc_heure_cli_tard | Heure client proposée au plus tard
cde2 | lc_heure_rep_tot | Heure de livraison proposée au plus tôt
cde2 | lc_heure_rep_tard | Heure de livraison proposée au plus tard
cde2 | lc_delfab | Date de fin de fabrication (calculée ou manuelle)
cde2 | lc_heure_fab_tot | Heure de fin fabrication au plus tôt
cde2 | lc_heure_fab_tard | Heure de fin fabrication au plus tard
cde2 | lc_heure_dep_tot | Heure de départ proposée au plus tôt
cde2 | lc_heure_dep_tard | Heure de départ proposée au plus tard
cde4 | nc_nummvt | Numéro de mouvement de stock
cde4 | nc_qtecde | Quantité commandée
cde4 | nc_prod | Code produit
cde4 | nc_numfbi | Numéro de FBI
cde4 | nc_rgt1 | Magasin de départ (ou s0_rgt1 sur livraison prévisionnelle de la ligne de commande)
info_c |  | Informations complémentaires de la ligne ou séquence de ligne de commande (par exemple : les informations de palettisation)


Gestion des achats


Multisite

#CF SIT

SIT

Paramétrage

Zones concernées dans les tables

Document d'étude

PARAMETRAGE

2 approches de recherche du paramétrage :

1) par thème (ci-dessous)

2) par ordre alphabétique

1) Paramètres par thème

Fichiers de base

Devis

Commandes clients

Stocks

Achats

Production

Livraisons

Retours clients, Réclamations, Non-conformités internes

Facturation

Transfert en comptabilité

Besoins matières

Autres

Voir aussi la fiche d'installation du risque client : paragraphe sur la gestion multisite.

Fichiers de base

#CFCLI Tiers | #CF CLI A1[16,30] Libellé de la zone libre 1 (cl_zpar dans la table cli). VERIFIER
#CFTAR - Recherche de tarif | #CF TAR A1[45,48] Recherche avec le site de production #CF TAR A2[27] Recherche avec le site de production Note _INFO_TR_SIT Alimentation des zones utilisées pour la recherche des tarifs
#CFTA1 - Saisie de tarif | #CF TA1 A3[57] Saisir des tarifs en fonction du site de production #CF TA1 A3[58] La zone site (tr_site) est obligatoire (O/N, N par défaut)
#CFRMP - Recherche d'article | #CF RMP A1[40] Méthode de recherche de produit par site de production
cli Saisie des tiers | Option Ods Désactivation des contrôles liés au site de production rattaché à l'utilisateur courant A3[2,4] Site de production pris par défaut pour le risque client
mat Saisie des articles | Option Ogs Active la gestion de la fiche matière en fonction du site de production
mat, v_mat, voluedit_fiche_produit | La zone mp_site_prod permet un complément de sélection sur la fiche matière. Saisie des articles : permettre de saisir des formats plaques selon le code site
v_mat Visu des articles | Note _SITE_PROD_POUR_CDEF Site de production par défaut Option Oda et note C_FAM_ART_DES_SIT : Le lieu de déstockage dans la nomenclature de commande est celui indiqué dans la fiche article en lieu et place de celui paramétré dans SIT.
v_mat Visu des articles | Note SUP_REQ_RG1_SITE_USE Limiter le traitement aux lieux de rangement du site de l'utilisateur
compo Gestion des compositions | note CODE_SITE_DEF Code site
prospect | Paramètre utilisé : MRA (Mode réalisation dans suivi date (lieu, site)
#CF GPF Génération de PF | Note PARAM_SAISIE_TARIF : Type et code paramètre de configuration de saisie des tarifs pour l'initialisation de la zone Site.

Devis

#CFDEG Config générale du devis | #CF DEG A4[51] Recherche automatique de la plieuse selon le code pli/site de production de l'entité Note LIB_SITE_PRODUCTION Libellé pour la zone Site de production (l2_site) sur l'entête
#CFDER Récapitulatif du devis | #CF DER A2[33] = 3 : Pour le calcul du transport, initialisation de l'origine avec le code site renseigné sur l'entité s'il est saisi, sinon avec le code site renseigné sur l'entête.
TSC _VT Variante Technique | Pour le devis Onduleur : char3_1 = Article par défaut du site (O/N, N par défaut)
CAN Type de cannelure | Note COEF_OND_SIT_ Coefficient d'ondulation par site Note CAN_ML_SIT_ Cannelure au mètre linéaire par site
CAS Caractéristiques des actions de service | CAS A2[7,8] = SI (code calcul SI)
FAB Suivi d'affaire | FAB A4[16,18] Site
USE paramètres utilisateur | USE A3[10,12] Voir plus bas dans la section "Autres"
Codes calcul | Code calcul MA Recherche informations matière - Récupération des formats plaque selon le site de l'entité. Car.1 = a,b,c ou d Code calcul MH Infos machine - Car.2 = 6 Code calcul TI Transport inter-sites Code calcul TP Type de processus - Car.1 = A Code calcul VA Valeur alphanumérique - Car.1 = 6 ou S
ecma Saisie et édition des codes FEFCO / ECMA | A2[6,8] Code site de production par défaut pour l'interface ArtiosCAD
Formules | OMAD50 Calage Massicotage droit OMAD51 Coupe Massicotage droit
formules de calcul | note CODE_LCO_SITES Code LCO des sites d'origine et de destination du transport interne de sous-traitance
devis_standard Devis multi-métiers | Option Ost Site de production sur entité devis feuille A3[1,3] Site de production par défaut de l'entête de devis _SUP_REQ_SIT_CAL_CES Code de la zone indiquant le site à prendre en compte
devis_tc Devis transformateur | A2[16,18] Site de production
don Devis onduleur | Option Olg : Affine la recherche des codes gamme en fonction du site de production A2[46,48] : Site de production associé à cette saisie de devis A2[58] : Choix du site en fonction de la gamme note _SUP_REQ_COMPO Affine la recherche des codes composition en fonction du site de production
devis imprimerie feuille / rotative | Ost Gestion du site de production (fle_2 et fle_imp)
l_dev Liste des devis | Option Ost Gestion du site de production
g_std Saisie des gammes standard | Colonnes paramétrables pour l'édition : colonnes 8 et suivantes

Commandes clients

Le code du site de production de l'article est saisi dans la zone paramétrable de l'entête de la commande (ec_c1).

On peut indiquer une lettre en caractère 3 ou 5 d'un compteur numérique afin de faire une différenciation entre les sites (cde et facn) (reconnaissance du site en fonction de la lettre dans le compteur).

#CFCDE

Config. commandes clients

#CF CDE A1[1,3] = SIT Type du paramètre de la zone ec_c1

#CFSSC

Note SSC_CODE_SITE Code site à prendre en compte par la génération de commande, s'il n'est pas renseigné par le programme appelant

TYC

Type de commande client

TYC A3[57] = S Les lieux de rangement des mouvements de stock générés avec la quantité lancée sont les lieux de rangement du site de production de l'article.

TYC A3[58] = S Les lieux de rangement des mouvements de stock générés avec la quantité commandée sont les lieux de rangement du site de production de l'article.

TYC A4[51] TYC de type sous-traitance

TYC A4[57] Recherche du lieu de déstockage des commandes CD2 synchrones ou asynchrones

TYC note commençant par CMR Car.4 = O : Positionne les OF associés à régénérer si le site de production de l'article est modifié.

TYC note NEW_TYC_TRANSCDESITE : Transfert de commande sur un autre site

TYC note REAP_ASYNC_FORCE Force le code réapprovisionnement à asynchrone s'il est synchrone.

USE Paramètres utilisateur

USE A3[10,12] Voir plus bas dans la section "Autres"

cde

Saisie des commandes clients

Option Oec Le lieu de niveau 1 pour les mouvements de stock est le site de production saisi en entête et non celui de la fiche article

Option Osa Recherche le site de production en priorité sur la produit via son lieu de rangement.

Option Ozp A la création, recopie du contenu de la zone paramétrée du fichier client dans la zone paramétrée de l'entête de commande. (cl_zpar dans ec_c1) VERIFIER

A4[18,20] Site de production par défaut

A4[35] Contrôle de la similitude des sites de production de l'entête de commande et du produit commandé

A4[37,39] Site de production pris par défaut pour le risque client

note CONTROLE_C1_ZPAR Type de contrôle entre la zone ec_c1 de l'entête et la zone cl_zpar du client

note TITRE_ENTETE_EC1 Libellé du site de production

Option Oda et note C_FAM_ART_DES_SIT : Le lieu de déstockage dans la nomenclature de commande est celui indiqué dans la fiche article en lieu et place de celui paramétré dans SIT.

acr Edition des AR

Option Ost Active la sous-traitance du produit entre sites

note TYPE_NOTE_CLI3 Types de notes sur adresse secondaire ou principale sur site de production à éditer

v_cdem

Visu des commandes clients

valeur numérique 2 Numéro du compteur de commande fournisseur VERIFIER

note CHGT_SITE_STR_CDE Transfert d'une commande d'un site de production vers un site de sous-traitance

notes EDAR et RDAR Edition/Réédition de l'AR suite à F21 : un lanceur par site

note RUNCDE Modifier une commande par F21 : un lanceur par site et par TYC

note RUN_VISU_CD1 Lancement de la visualisation des commandes clients pour les commandes de type CD1 à partir des commandes de type CDA : un lanceur par site

note RUN_VISU_TYPE_RATT Paramétrer le type de visu cible sur le F34 : un lanceur par site et par TYC

Note SSC_CODE_SITE Code site à prendre en compte par la génération de commande, s'il n'est pas renseigné par le programme appelant

note TITRE_ENTETE_EC1 Libellé du site de production

edi_cde_aviexp

Génération des messages EDI d'avis d'expédition

A3[1] = 4

Numéro de version = 4 pour la prise en compte du site de production et autres nouvelles zones.

integrer_edi_cde

Intégration EDI

Zones de l'entête de commande : site de production

Option Ogd : voir sur place

v_edi_cde

Visu des messages EDI

Ordre de tri N° 11 Tri par site de production (sit_pro)

Notes ACCES_AR_TYC, ACCES_CDE_TYC_ et COMPTEUR_TYC_

Note C_FAM_ART_DES_SIT et option da dans la note OPTION_CDE_TYC_ : Recherche du lieu de déstockage en commande EDI

v_cde_marche Visu des commandes de marché

Notes EDAR / RDAR

Note RUNCDE

Note RUN_VISU_TYPE_RATT

Note SSC_CODE_SITE Code site à prendre en compte par la génération de commande, s'il n'est pas renseigné par le programme appelant

Stocks

Lorsqu'on est en multisite, à la création des mouvements de stocks prévisionnels en saisie de commande (EP, SR) le lieu de rangement est recherché sur le site de l'entête de commande.

La zone du site de production n'existe pas sur les mouvements de stock.

En interrogation par F7 sur les lieux de stockage, on n'affiche que les lieux du site de production.

RG1 Lieu de rangement 1 | RG1 A1[1,6] Code du transporteur utilisé dans la fonction de calcul du port par site de production RG1 A1[29,31] Code site d'appartenance
USE Paramètres utilisateur | USE A3[50] Mode de contrôle du changement de site d'appartenance lors de la modification du lieu de rangement 1
maj_stk Saisie des corrections de stocks | Option Osl N'afficher que les mouvements de stocks dont le lieu de rangement 1 correspond au site de production de l'utilisateur.
trf_stk Transformation des mouvements prévisionnels en mouvements normaux | Option Oc1 On ne traite que les mouvements de stock associés à une commande client, dont la zone paramétrable (ec_c1) est égale à la valeur paramétrée en A2[1,3]. A2[1,3] Valeur de la zone paramétrée de l'entête de commande
valst valorisation des stocks | Note SUP_REQ_RG1_SITE_USE pour limiter le traitement aux lieux de rangement du site de l'utilisateur qui lance la valorisation (O/N, N par défaut). Option Ots Effectuer le tri en priorité sur le code site rattaché au magasin Colonne EH : Code site rattaché au magasin
#CF STK | Note SUP_REQ_RG1_SITE_USE Limiter le traitement aux lieux de rangement du site de l'utilisateur
v_prostk | Note SUP_REQ_RG1_SITE_USE Limiter le traitement aux lieux de rangement du site de l'utilisateur
alerte | Note _SITE_PROD_POUR_CDEF Site de production par défaut pour les commandes d’achat à générer

Achats

#CFCDF Commandes fournisseurs | #CF CDF A1[1,3] = SIT Type du paramètre de la zone ef_c1 A4[1,26] Libellé pour remplacer l'expression Site de production
cdef Saisie des commandes fournisseur | Option Oie - Initialisation de zones à partir du paramétrage du site de production Option Oia - Initialisation de l'adresse de livraison par défaut selon le code site A3[25,27] Site de production par défaut
gen_cdef Génération des commandes fournisseurs | Option Oie Initialisation de zones à partir du paramétrage du site de production note _SUP_REQ_SITE Complément de requête sur site, voir explications dans le contexte.
gen_cdef Génération des commandes fournisseurs | Option Oif Initialisation de l'adresse de facturation selon le site
brc Bons de réception / retour | Option Oie Initialisation de zones à partir du paramétrage du site de production Note INIT_FAM_LIEUX : Si le mode d'initialisation de la famille est 2, les lieux de rangement seront initialisés avec ceux du site de production (idem option Oie). Note _SUP_REQ_SITE Complément de requête sur le site de production
v_edi_brc Génération des BR à partir de la visu EDI | Option Oie Initialisation des lieux de rangement 1 et 2 du mouvement d'entrée en stock avec les lieux du site de la commande
edicf Edition des commandes fournisseurs | note TYPE_NOTE_CLI3_SIT Types de notes sur adresse de site de production du client à éditer
generer_edi_cde Génération des messages EDI de commandes d'achat (ORDERS) | A3[11] Infos supplémentaires dans les fichiers de trace (ajout site, numéro et ligne de commande)
DEM Demandeur | DEM A1[1,3] Code site du demandeur

Production

TTR Type de travail | TTR A1[27] Prise en compte du temps dans le programme recsi (Récapitulatif des temps par paramètre commande (ec_c1) et opération Note CODE_ARRET_ Gestion des codes arrêts par sites
#CFATL Config générale | #CF ATL A4[49] Type de paramètre Origine pour la saisie et le calcul du transport #CF ATL note INFO_SITE_XXX Gestion de la sous-traitance entre sites #CF ATL note SITES_XXX_YYY Gestion de la sous-traitance entre sites
lot_industriel | Gestion des lots industriels internes ou fournisseurs (utilise USE A1[9,11])
oex Edition Ordres exécution | Option Osm Saut de page si changement de site dans la liste des machines Note CODE_SITE_EDITION
gdf_don Génération de dossiers onduleurs | Option Ony Active la numérotation annuelle pour le compteur de FB2 Option Ost Active la sous-traitance des plaques A2[34,36] Code du site de production, pour restreindre la génération de dossier aux OF de ce site. A4[2] Contrôle si le code site de la gamme est compatible avec le site de production de la FBI. Note COMPTEUR_TYC_FB2 Numéro de compteur
l_gdf Génération de dossiers imprimerie | Note DIRECT_PLANNING_CFG : MULTISITE_ENTITE Paramétrage figé indiquant que pour un même OF, les sites de production des entités peuvent avoir des configurations d'interface DirectPlanning différentes. Lors de la génération d'un OF multi-site, une demande est générée pour chaque configuration différente associée au site de production.
#CF DP2 ou autre selon note DIRECT_PLANNING_CFG du paramètre de type SIT | Note CFG_EXCLU_SITE_ENT : Mode d'exclusion des entités selon leur site de production
qte_prod Déclaration de production | A3[47] Contrôle du numéro d'OF saisi par rapport au complément de requête _SUP_REQ_CTRL_SITE Le message est personnalisable dans la note MESSAGE_CTRL_SITE.
pr_as_don Calcul des actions de service | A2[34,36]: Site de production
integration_tgvdata ILO | Interface permettant d'intégrer le fichier TGVDATA fourni par PC TOPP dans la table charge_ilot. A2[1,3] Code site Utilise le paramètre ILO A1[2,4] Code site
tr_groupage Intégration de fichiers d'ordres de chargement | Structure d'une ligne. Zone 08 = Site
interface_fab_1_etat Intégration du suivi de production OMP | Note LIMITE_TYPE_AU_SITE -Limiter certains types de machines à certains sites
int_tbdata Intégration du suivi de production TBDATA | Note LIMITE_TYPE_AU_SITE - Limiter certains types de machines à certains sites
directplanning Interface Direct Planning | Note DIRECT_PLANNING_CFG : voir sur place
fab_ond_integre Interface MIDATA | A3[13,15] Code du site de production pour une gestion des codes arrêts par site. A3[19] Limiter la recherche de la correspondance des machines PCTOPP/VSW au site paramétré.
sai_etiqprod | Option Ose Initialiser l'adresse de la société émettrice avec le site de production de l'utilisateur

Livraisons

USE Paramètres utilisateur | USE A1[9,11] Code usine associé à l'utilisateur, pour initialiser le site de production de l'entête des BL ainsi que le site de production des frais d'expédition. Ne pas confondre avec USE A3[10,12].
VEH Véhicules | Association Véhicules - Sites de production, utilisé dans la saisie des BL
#CFBLV Config des BL | #CF BLV A1[1,3] = SIT Type du paramètre de la zone Site de production sur l'entête de bon de livraison (b1_sitp) #CF BLV A2[4,30] Texte du libellé Site production. Par défaut : libellé long du par01 de SIT
edition_ordre_achat_transport | A2[1,3] Code site de production
edi_affret_cli_men Edition des affrètements pour infos client | A2[1,4] Code site
blv Saisie des BL | A3[25,27]Site par défaut A3[40] Mode de contrôle de saisie du site de production Note _SUP_REQ_SITE_PICK pour contrôler le site du picking
blv_ed1 Edition des BL | Note TYPE_NOTE_CLI3_SIT Types de notes sur adresse secondaire ou principale sur site de production à éditer (SPECIFIQUE)
gen_auto_blv Génération automatique des BL | Option Osp La zone site de production (sitp) est initialisée par la zone ec_c1. Sinon, elle est initialisée par USE A1[9,11]
v_jbl Visu du journal des BL | Visu du journal des BL Ordre de tri : Site de production (b1_sitp) Note LIBELLE_SIT_PROD Texte du libellé Site production. Par défaut : libellé long du par01 de SIT
deb Génération du fichier des déclarations d'échanges de biens | A2[1,3] Code site
voluedit_ordre_achat_transport Edition des ordres d'achat de transport | A2[1,3] Code site de production

Retours clients, Réclamations, Non-conformités internes

La gestion des retours clients fait l'objet dune documentation utilisateur :

M:/Documentation d'installation et d'évolution/13-Gestion des livraisons/INS_LB_Bon de retour_Gestion des retours clients_Mode d'emploi.doc

MOR Motif de retour | Note LIEUX_SITE_ Code du site de production
bon_de_retour Gestion des bons de retour clients | A2[13,15] Code site de production Note _SUP_REQ_SITE Complément de requête sur le site de production
bon_de_retour_avo Gestion des bons de retour clients | Note _SUP_REQ_SITE Complément de requête sur le site de production
reclam_cli_saisie nci_saisie | Note GESTION_SITE Gestion du site à partir de la commande (C) ou d'un paramètre (P) Note SITE_DEFAUT Valeur du site par défaut Note CONTROL_SITE Mode de contrôle du site

Facturation

On peut indiquer une lettre en caractère 3 ou 5 d'un compteur numérique afin de faire une différenciation entre les sites (cde et facn)(reconnaissance du site en fonction de la lettre dans le compteur).

#CFFAC Configuration du calcul des factures | #CF FAC A1[6] = A Mise à jour de la table des statistiques de facturation #CF FAC A1[7] = A Mise à jour de la table des statistiques des commissions
facf Contrôle des factures fournisseurs | Option Oss Permet de saisir un site lorsque la facture est saisie sans bon de réception A2[23,25] Code site du menu A2[26] Contrôle si le code site de la commande d'achat est identique au code site du menu
facn Calcul et édition des factures | Option Otp Tri paramétré sur site de production de l'entête de commande (zone ec_c1) note TYPE_NOTE_CLI3_SIT Types de notes sur adresse secondaire ou principale sur site de production
TOP Top de facturation | TOP Paramètre utilisé en facturation - Gestion du Mois en Cours Le code paramètre est paramétrable en facturation, ce qui permet de définir, par exemple, un TOP de facturation par site.
efficial_phase_1 Facturation Efficial | A2[1] Code site

Transfert en comptabilité

Le transfert des factures fournisseurs en comptabilité est assuré par le programme tr_fac_fou.

Le transfert des factures clients en comptabilité est assuré par le programme tr_fcnn_vl.

SIT Site de production | SIT A3[21,23] Code site pour le transfert en comptabilité SAGE 500 (uniquement SAGE 500 ?)
SFM Sous-famille | Note TRF (ou tout autre code référencé par la note CONFIG_TRANSFERT Tenir compte du site pour l'attribution des comptes de ventes
TVA | Note COMPTE_CS1_ Paramétrage particulier pour Interface des ventes avec la comptabilité FININFOR
#CFTFF Transfert des factures fournisseurs dans la comptabilité | Note SAGE_500_PARAM_GEN Caractères 21,22 = 02 Code journal du site de production (SIT A3[15,20]) Celui-ci est saisi sur l'entête de la commande Caractères 23,24 = 02 Le code site entre dans la composition du code analytique spécifique.
#CTFRF Transfert des factures clients dans la comptabilité | Note SAGE_500_PARAM_GEN Caractères 21,22 = 02 Code journal du site de production (SIT A3[15,20]) Celui-ci est saisi sur l'entête de la commande Caractères 23,24 = 02 Le code site entre dans la composition du code analytique spécifique. note _JDE_PARAM_ Car.21,25 Code société JDE. Il sera utilisé si la commande n'a pas de site note SAP_PARAM_GEN_SITE Car21,23 Code du site
int_cpt Intégration des écritures comptables SAP Format SAP | Intégration du fichier des écritures comptables de l'interface SAP Encours Clients dans les tables histo, echean et risque_detail (int_cpt A2[1] = 0) Caractères 11 à 14 du fichier à intégrer : Domaine d'activité (SAP) = Site (VSW)
tr_jd_achats Transfert des achats vers JDE | Note _CODE_SOCIETE_JDE Code Société JDE, utilisé si la commande n'a pas de site. Note _COMPTE_COMPTA_SITE Compte comptable du site, utilisé si la commande n'a pas de site.
tr_cli_jde Transfert des tiers vers la compta JDE | Note _CODE_SOCIETE_JDE Code société JDE du site Note _CODE_SITE_DUPLIQUE Code SITE à dupliquer

Besoins matières

#CF SMC

Note SUP_REQ_RG1_SITE_USE pour ne prendre que les lieux de rangement dont le site est celui du USE qui lance la recherche de plaques

Autres

SFV Structure force de vente

SFV A1[4,6] Code site d'appartenance de la SFV

#CFVMC Configuration de Volume Media Center

#CF VMC A1[3] Gestion de l'interface ArtiosCAD par site activée

vmc_test Test VMC

A2[16,18] Code site de production par défaut pour l'interface ArtiosCAD

USE Paramètres utilisateur

USE A1[9,11] Code usine associé à l'utilisateur

USE A3[10,12]Filtre les données de la fiche client (saisie, modification, interrogation) en fonction du site de production.

USE A3[50] Contrôle du changement de site d'appartenance lors de la modification du lieu de rangement 1

Note MODIF_AUTORISEE_

Note _SUP_SQL_SITE Complément de sélection sur la table des paramètres des sites d'appartenance autorisés pour l'utilisateur

#CFAPP Paramétrage des éditions APPIC

#CF APP A1[3] = O Recherche du nombre d'exemplaires société à partir du code client et du code adresse saisis dans la zone A1 du paramètre SIT

note NB_COPIES_SIT_ Nombre de copies par site

correspondance entre VP et logiciels externes

A2[4,6] Code site par défaut

Visualisations

Note _SUP_REQ_SITE Restreindre la recherche en fonction du site associé à l'utilisateur

Editions VoluEdit

Note _SUP_REQ_SITE Restreindre la recherche en fonction du site associé à l'utilisateur

Cette note est disponible dans les éditions suivantes :

voluedit_blv / voluedit_bon_retour / voluedit_ebrc / voluedit_edicf / voluedit_fle_cli / voluedit_oex / voluedit_oex_tc

Note VE_SIT_SOR Choix de l'imprimante par site

Note LCT_EDT_ dans le programme d'édition des enregistrements présents dans la table canal_comm

envoi_fax_email

note EDI_typ_mod_sit Paramétrage des types de document et des modes d'envoi par site

TCL Type correspondance entre logiciels

TCL A1[5] Saisie des correspondances par site de production

Note SUP_REQ_LISTE_SITE Complément sur la table par02 pour l'affichage de la liste des sites possibles

2) Paramètres par ordre alphabétique

Le tableau suivant est découpé en 3 catégories de paramètres :

Catégorie | Paramètre | Thème
Paramètres de configuration | #CF APP | Autres
 | #CF ATL | Production
 | #CF BLV | Livraisons
 | #CF CDE | Commandes clients
 | #CF CDF | Achats
 | #CF CLI | Fichiers de base
 | #CF DEG | Devis
 | #CF DER | Devis
 | #CF FAC | Facturation
 | #CF RMP | Fichiers de base
 | #CF SIT | Tous
 | #CF STK | Mouvements de stocks
 | #CF SMC | Matières consommées
 | #CF TA1 | Fichiers de base
 | #CF TAR | Fichiers de base
 | #CF TFF | Transfert en comptabilité
 | #CF TRF | Transfert en comptabilité
 | #CF VMC | Autres
Paramètres de saisie | CAN | Devis
 | CAS | Devis
 | DEM | Achats
 | FAB | Devis
 | ILO | Production
 | MOR | Retours clients
 | RG1 | Stocks
 | SFV | Autres
 | SIT | Transfert en comptabilité
 | TCL | Autres
 | TOP | Facturation
 | TTR | Production
 | TVA | Transfert en comptabilité
 | TYC | Commandes clients
 | USE | Devis / Commandes clients / Stocks / Production / Livraisons / Autres
 | VEH | Livraisons
Paramètres de lancement | acr | Commandes clients
 | blv | Livraisons
 | blv_ed1 | Livraisons
 | bon_de_retour | Retours clients
 | bon_de_retour_avo | Retours clients
 | brc | Achats
 | cde | Commandes clients
 | cdef | Achats
 | cli | Fichiers de base
 | compo | Fichiers de base
 | correspondance | Autres
 | deb | Livraisons
 | devis | Devis
 | devis_standard | Devis
 | devis_tc | Devis
 | directplanning | Production
 | don | Devis
 | ecma | Devis
 | edi_affret_cli_men | Livraisons
 | edi_cde_aviexp | Commandes clients
 | edicf | Achats
 | edition_ordre_achat_transport | Livraisons
 | efficial_phase_1 | Facturation
 | envoi_fax_email | Autres
 | fab_ond_integre | Production
 | facf | Facturation
 | facn | Facturation
 | formules | Devis
 | g_std | Devis
 | gdf_don | Production
 | gen_auto_blv | Livraisons
 | gen_cdef | Achats
 | generer_edi_cde | Achats
 | int_cpt | Transfert en comptabilité
 | int_tbdata | Production
 | integration_tgvdata | Production
 | integrer_edi_cde | Commandes clients
 | interface_fab_1_etat | Production
 | l_dev | Devis
 | lot_industriel | Production
 | maj_stk | Stocks
 | mat | Fichiers de base
 | oex | Production
 | pr_as_don | Production
 | prospect | Fichiers de base
 | qte_prod | Production
 | tr_cli_jde | Transfert en comptabilité
 | tr_groupage | Production
 | tr_jd_achats | Transfert en comptabilité
 | tr_ventes | Transfert en comptabilité
 | trf_stk | Stocks
 | v_cdem | Commandes clients
 | v_cde_marche | Commandes clients
 | v_edi_brc | Achats
 | v_edi_cde | Commandes clients
 | v_jbl | Livraisons
 | v_mat | Fichiers de base
 | v_prostk | Stocks
 | Visualisations | Toutes
 | vmc_test | Autres
 | voluedit_* | Toutes
 | voluedit_fiche_produit | Fichiers de base
 | voluedit_ordre_achat_transport | Livraisons
Autres | TSC_VT | Devis
 | Codes calculs | Devis
 | Formules de calcul | Devis

Zones correspondant au site de production dans les différentes tables

Table | Zone | Libellé
action_evt | ace_sit | Site de production
blv1 | b1_sitp | Zone paramétrable 1, utilisable pour le site de production
bon_retour_cli_1 | br1_site_prod | Site de production
b_rec_ret_e | bre_site | Site de production
cab_production | cb_site | Site de production
cde1 | ec_c1 | Zone paramétrable, voir #CF CDE A1[1,3]
cdf1 | ef_c1 | Zone paramétrable, voir #CF CDF A1[1,3]
cli5 | c5_site_agrement | Code site d'agrément (pour assurance crédit)
correspondance | cor_code_site | Site de production
crmk_site | toutes les zones | Site pour le cube ReflexClient
crmk_sta_com_fac | cod_zone_param_c1 cod_site cod_site_cli | Code zone paramétrée ec_c1, utilisable pour le site de production Site de production Site de production client
dem_achat_ent | dae_site | Site du demandeur
ec_dtg | tg_transfert | Date de transfert du devis sur un autre site
edi_cde | edc_c1 | Site de production
envoi_fax_email | efe_site_prod | Site de production
fle_2 | l2_site | Site de production
fle_imp | fi_sit | Site de production
fle_nom | fno_site | Site de production
fle_tra | ft_destination | Site de destination
g_std_e | ge_site | Site de la gamme
groupage_bl | gb_site_prod | Site de production
kp_demcli | kp_de_site | Site de production
lot_industriel | lin_site_prod | Site de production
mac0 | m0_sit_prod | Site de production
mat | mp_site_prod | Site de production
mat_site | toutes les zones | Lieux de rangement par site
mat_var_prod | mva_site_prod | Site de production
risque_detail | rid_site_prod | Site de production
sta_com | sta_site sta_lsite | Site du représentant de l'entête de commande Site du représentant de la ligne de commande
stk0 | s0_site_prod | Site de production
stk0_periode | spe_site | Site de production
str_com | str_site | Code site de la structure FDV
tar0 | tr_site | Site de production

Document d'étude

1. Objet de l'étude

2. Principes

2.1. Rappel sur la gestion multi-sociétés

2.2. Principe de la gestion multisite

3. Détail de fonctionnement

3.1. Gestion des menus

3.2. Gestion des paramètres

3.3. Gestions des clients

3.4. Gestions des fichiers de base

3.5. Gestions du devis

3.6. Gestions des commandes clients

3.7. Gestion de la production

3.8. Gestions des stocks

3.9. Gestions des livraisons

3.10. Gestions des facturations

1/Objet de l'étude

Cette étude a pour objet de définir les différentes modalités de fonctionnement dune gestion multisite.

2/Principes

2-1/Rappel sur la gestion multi-sociétés

La gestion multi sociétés implique une séparation totale des données de chacune des sociétés.

Toutes les données de base (client, fichiers techniques, produits) sont propres à chacune des sociétés.

Cela permet donc de garder des spécificités, mais nécessite une duplication des données communes.

De même, toute la gestion commerciale, de production et de stock est propre à chaque société.

Seul un outil extérieur permet de consolider les données des 2 sociétés.

2-2/Principe de la gestion multisite

La gestion multisite implique un partage total de toutes les données Volupack.

Cela nécessite une homogénéisation à tous les niveaux.

Cela commence par la mise en commun de toutes les données de bases : le fichier client, les fichiers techniques (matières et accessoires, compositions, codes FEFCO, tarifs, etc), ainsi que toutes les listes de paramètres de gestion (représentants, modes de règlement, familles / sous familles, etc).

Seules les machines et les gammes peuvent être rattachées à un site.

La gestion commerciale par contre, même si elle alimente les mêmes tables (ce qui facilite les consolidations), peut être suivie par site, dans la mesure où une commande est toujours rattachée à un seul site.

3/Détail de fonctionnement

3-1/Gestion des menus

Les menus sont communs à tous les sites.

Ils peuvent être dupliqués avec des paramètres de lancement enrichis d'un complément de requête pour en restreindre l'utilisation à un site.

Ces menus peuvent ensuite être rattachés à des groupes d'utilisateurs.

3-2/Gestion des paramètres

Hormis les lieux de rangement qui peuvent être rattachés à un site, tous les paramètres sont communs à tous les sites.

Cela implique une homogénéisation des listes de paramètres.

Exemple : Un représentant est commun à tous les sites, et reçoit la même commission quel que soit le site.

De la même façon, les familles et les sous familles sont communes à tous les sites, quelles soient commerciales ou techniques.

3-3/Gestions des clients

Le fichier client est unique. Cela signifie que les modes de gestion du client pour l'ensemble des sites doivent être harmonisés.

Par exemple, un client n'aura qu'une seule condition de paiement, qu'un seul représentant.

Des distinctions peuvent être envisagées au niveau des adresses secondaires.

Un site peut être affecté par défaut à un client.

Sur paramétrage, ce site est automatiquement repris sur l'entête de commande.

3-4/Gestions des fichiers de base

Là encore, les fichiers de base sont uniques pour l'ensemble des sites.

Ceci implique une uniformisation de toutes les données techniques, en particulier des codes FEFCO avec leurs majorations, des profils cannelure et de leur coefficient d'ondulation, des compositions carton, etc.

Pour les machines, un rattachement au site existe pour chacune d'elles.

Les gammes, quant à elles, sont soit mono-site si les machines qui la composent sont du même site, sinon elles sont multisite.

Onduleurs

Pour les matières, hors composition, c'est à dire les accessoires, les encres, les palettes, etc, chacune d'elles peut être rattachée à un ou plusieurs sites via la table mat_site (fonction F25 sur le fichier matière).

Transformateurs

Pour les matières, hors composition, c'est à dire les accessoires, les encres, les palettes, etc, chacune d'elles peut être rattachée à un ou plusieurs sites via la table mat_site si la matière ou le produit est sur plusieurs sites.

Dans le cas contraire, le code site est sur la fiche matière / produit.

Une matière dont le rattachement na pas été défini peut être utilisée sur tous les sites.

A noter que les prix de cession de chaque matière est unique pour l' ensemble des sites.

3-5/Gestions du devis

Le devis, dont le fonctionnement est basé su un certain nombre de valeurs par défaut, peut faire l'objet de différentes entrées au menu pour justement gérer les paramètres par site.

L'élément important du devis dans la gestion multisite est le lieu de rangement par défaut du devis, sur lequel est paramétré le site de rattachement.

Cette information conditionne certains traitements comme la recherche de la gamme, par exemple.

Sans lieu par défaut, le devis recherche la meilleure gamme de l'ensemble des sites.

Si le lieu est précisé, la recherche de gamme se fera uniquement sur le site associé à ce lieu.

Onduleurs

De la même façon, un contrôle est fait sur le site d'appartenance des composants utilisés dans le devis.

Transformateurs

Pas de contrôle

La génération des produits via le devis initialise un lieu de rangement par défaut sur les articles, rattachement avec le site de production.

A noter pour les articles multisite, les tarifs sont communs à l' ensemble des sites.

3-6/Gestions des commandes clients

Les commandes sont obligatoirement associées à un site de production.

Le site peut être :

  • initialisé par le site rattaché au client sil existe,

  • ou bien avoir une valeur par défaut (il est alors nécessaire de définir un entrée au menu par site),

  • ou bien saisi manuellement sur l'entête de la commande.

Un contrôle peut être fait entre le site de la commande et le site rattaché au client.

Par contre, aucun contrôle n'existe entre le site de la commande et celui du produit commandé.

3-7/Gestion de la production

Onduleurs

La FBI générée comporte le site de la commande commerciale.

Le module de génération du prix de revient, qui gère aussi les envois de données au système de planification (Pc-Topp), ne traite que les FBI d'un site.

Les retours des données d'atelier, obligatoirement rattachés à une FBI, sont donc liés au site de la FBI.

Transformateurs

On prend le site de la commande.

3-8/Gestions des stocks

Les stocks sont gérés par magasin, eux même rattachés à un site.

Aucune notion de site n'est présente sur les mouvements de stocks.

Si un lieu de stockage est partagé par 2 sites de production, il peut être nécessaire, pour suivre les valorisations de stock par site, de créer 2 magasins fictifs pour le même lieu de stockage.

3-9/Gestions des livraisons

Les livraisons sont toujours au départ d'un et d'un seul site à la fois.

Le site de départ peut être saisi sur l'entête du BL, ou être paramétré par défaut.

Un paramétrage par entrée au menu permet de restreindre l'affichage du stock à un site donné.

Un contrôle peut être effectué entre le site du BL et le site rattaché au client.

3-10/Gestions des facturations

La facturation peut être commune à l'ensemble des sites.

Un paramétrage permet de faire un tri des factures par site de production de l'entête de commande.

Mais elle peut aussi être lancée indépendamment site par site.

Un paramétrage permet de ne sélectionner que les commandes à facturer pour un site.

Cela nécessite bien entendu une entrée au menu par site avec des paramètres de lancement différents.

Attention à la gestion des chronos de factures.

De même, la gestion des TOP de fin de mois peut être effectuée par site.


Les mouvements de stock


Organigramme Transformateur : cas 1

  • Proposition (devis)

  • Commande client

  • Approvisionnement

  • Réception matière

  • Fabrication

  • Livraison

  • Facturation


Organigramme Transformateur : cas 2

Le client passe une commande de marché (contrat).

Produits pris sur stock de PF

Le transformateur gère ses seuils mini et d'alerte afin que le client puisse être livré immédiatement sur simple appel.


Organigramme Transformateur : cas 3

Le client passe un contrat.

Ce type de commande engage le client sur un produit, un tarif et une quantité sur une période.

A chaque appel de livraison du client, le transformateur décide ou non de fabriquer en fonction de son stock.

La livraison au client n'est donc pas forcément immédiate.


Format AGRESSO

Ligne TTC de la facture ou de l'avoir

Ligne TTC des acomptes et avances

Ligne contrepartie des acomptes et avances

Ligne HT (Produits, Remise, Escompte, Port, Emballage et Frais d'expédition)

Ligne TVA (Uniquement pour les produits et les frais d'expédition)

Ligne TTC de la facture ou de l'avoir

Structure du fichier

N° | Champ | de | à | Nb car
01 | Code société VOLUME | 001 | 003 | 03
02 | Type de ligne | 004 | 004 | 01
03 | Numéro de pièce | 005 | 012 | 08
04 | Date de pièce | 013 | 022 | 10
05 | Numéro de compte | 023 | 030 | 08
06 | Montant en devise | 031 | 043 | 13
07 | Code Débit/Crédit | 044 | 044 | 01
08 | Date d'échéance | 045 | 054 | 10
09 | Code mode de règlement | 055 | 057 | 03
10 | Code journal | 058 | 059 | 02
11 | Première commande-ligne | 060 | 068 | 09
12 | Code client VOLUME | 069 | 074 | 06
13 | Code représentant | 075 | 077 | 03
14 | Libre | 078 | 080 | 03
15 | Code devise | 081 | 083 | 03
16 | Centre dominant | 084 | 086 | 03
17 | Code client VOLUME | 087 | 092 | 06
18 | Code représentant | 093 | 095 | 03
19 | Libre | 096 | 126 | 31

Descriptif des zones du fichier

N° | Champ | Détails
01 | Code société VOLUME | Code société de la facture ou de l'avoir
02 | Type de ligne | Toujours C
03 | Numéro de pièce | Numéro de la facture ou de l'avoir
04 | Date de pièce | Date de la facture ou de l'avoir sous la forme dd/mm/yyyy
05 | Numéro de compte | Compte comptable du client
06 | Montant en devise | Montant TTC en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&
07 | Code Débit/Crédit | D = Débit, C = Crédit
08 | Date d'échéance | Date de la première échéance de la facture ou de l'avoir sous la forme dd/mm/yyyy
09 | Code mode de règlement | Code mode de règlement de la facture ou de l'avoir
10 | Code journal | Les 2 premiers du code journal paramétré sur la fiche société
11 | Première commande-ligne | Numéro de commande et ligne de commande de la première ligne de la facture ou de l'avoir 01-08 Numéro de commande 09-09 Ligne de commande
12 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
13 | Code représentant | Code représentant de la ligne de commande
14 | Libre | Blanc
15 | Code devise | Code devise de la facture ou de l'avoir
16 | Centre dominant | Centre dominant de la ligne de commande
17 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
18 | Code représentant | Code représentant de la ligne de commande
19 | Libre | Blanc

Ligne TTC des acomptes et avances

Structure du fichier

N° | Champ | de | à | Nb car
01 | Code société VOLUME | 001 | 003 | 03
02 | Type de ligne | 004 | 004 | 01
03 | Numéro de pièce | 005 | 012 | 08
04 | Date de pièce | 013 | 022 | 10
05 | Numéro de compte | 023 | 030 | 08
06 | Montant en devise | 031 | 043 | 13
07 | Code Débit/Crédit | 044 | 044 | 01
08 | Date d'échéance | 045 | 054 | 10
09 | Code mode de règlement | 055 | 057 | 03
10 | Code journal | 058 | 059 | 02
11 | Commande-Ligne | 060 | 068 | 09
12 | Code client VOLUME | 069 | 074 | 06
13 | Code représentant | 075 | 077 | 03
14 | Libre | 078 | 080 | 03
15 | Code devise | 081 | 083 | 03
16 | Centre dominant | 084 | 086 | 03
17 | Code client VOLUME | 087 | 092 | 06
18 | Code représentant | 093 | 095 | 03
19 | Libre | 096 | 126 | 31

Descriptif des zones du fichier

N° | Champ | Détails
01 | Code société VOLUME | Code société de la facture ou de l'avoir
02 | Type de ligne | Toujours C
03 | Numéro de pièce | Numéro de la facture ou de l'avoir
04 | Date de pièce | Date de la facture ou de l'avoir sous la forme dd/mm/yyyy
05 | Numéro de compte | Compte comptable du client
06 | Montant en devise | Prix en devise de la ligne de commande d'acompte et d'avance sous la forme &&&&&&&&&&&&&
07 | Code Débit/Crédit | D = Débit, C = Crédit
08 | Date d'échéance | Date de la première échéance de la facture ou de l'avoir sous la forme dd/mm/yyyy
09 | Code mode de règlement | Code mode de règlement de la facture ou de l'avoir
10 | Code journal | Les 2 premiers du code journal paramétré sur la fiche société
11 | Commande-Ligne | Numéro de commande et ligne de commande d'acompte et d'avance 01-08 Numéro de commande 09-09 Ligne de commande
12 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
13 | Code représentant | Code représentant de la ligne de commande
14 | Libre | Blanc
15 | Code devise | Code devise de la facture ou de l'avoir
16 | Centre dominant | Centre dominant de la ligne de commande
17 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
18 | Code représentant | Code représentant de la ligne de commande
19 | Libre | Blanc

Ligne contrepartie des acomptes et avances

Structure du fichier

N° | Champ | de | à | Nb car
01 | Code société VOLUME | 001 | 003 | 03
02 | Type de ligne | 004 | 004 | 01
03 | Numéro de pièce | 005 | 012 | 08
04 | Date de pièce | 013 | 022 | 10
05 | Numéro de compte | 023 | 030 | 08
06 | Montant en devise | 031 | 043 | 13
07 | Code Débit/Crédit | 044 | 044 | 01
08 | Date d'échéance | 045 | 054 | 10
09 | Code mode de règlement | 055 | 057 | 03
10 | Code journal | 058 | 059 | 02
11 | Commande-Ligne | 060 | 068 | 09
12 | Sous-famille | 069 | 071 | 03
13 | Type de commande de rattachement | 072 | 074 | 03
14 | Code j transférable | 075 | 075 | 01
15 | Code TVA | 076 | 078 | 03
16 | Libre | 079 | 080 | 02
17 | Code devise | 081 | 083 | 03
18 | Centre dominant | 084 | 086 | 03
19 | Code client VOLUME | 087 | 092 | 06
20 | Code représentant | 093 | 095 | 03
21 | Quantité | 096 | 105 | 10
22 | Libre | 106 | 126 | 21

Descriptif des zones du fichier

N° | Champ | Détails
01 | Code société VOLUME | Code société de la facture ou de l'avoir
02 | Type de ligne | Toujours A
03 | Numéro de pièce | Numéro de la facture ou de l'avoir
04 | Date de pièce | Date de la facture ou de l'avoir sous la forme dd/mm/yyyy
05 | Numéro de compte | Compte comptable de l'article avance et acompte
06 | Montant en devise | Prix en devise de la ligne de commande d'acompte et d'avance sous la forme &&&&&&&&&&&&&
07 | Code Débit/Crédit | D = Débit, C = Crédit
08 | Date d'échéance | Date de la première échéance de la facture ou de l'avoir sous la forme dd/mm/yyyy
09 | Code mode de règlement | Code mode de règlement de la facture ou de l'avoir
10 | Code journal | Les 2 premiers du code journal paramétré sur la fiche société
11 | Commande-Ligne | Numéro de commande et ligne de commande d'acompte et d'avance 01-08 Numéro de commande 09-09 Ligne de commande
12 | Sous-famille | Code sous-famille de la ligne de commande
13 | Type de commande de rattachement | Type de commande de la commande
14 | Code j transférable | mp_param[34] de l'article de la ligne de la facture ou de l'avoir
15 | Code TVA | Code TVA de la ligne de la facture ou de l'avoir
16 | Libre | Blanc
17 | Code devise | Code devise de la facture ou de l'avoir
18 | Centre dominant | Centre dominant de la ligne de commande
19 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
20 | Code représentant | Code représentant de la ligne de commande
21 | Quantité | Toujours 0000000001
22 | Libre | Blanc

Ligne HT (Produits, Remise, Escompte, Port, Emballage et Frais d'expédition)

Structure du fichier

N° | Champ | de | à | Nb car
01 | Code société VOLUME | 001 | 003 | 03
02 | Type de ligne | 004 | 004 | 01
03 | Numéro de pièce | 005 | 012 | 08
04 | Date de pièce | 013 | 022 | 10
05 | Numéro de compte | 023 | 030 | 08
06 | Montant en devise | 031 | 043 | 13
07 | Code Débit/Crédit | 044 | 044 | 01
08 | Date d'échéance | 045 | 054 | 10
09 | Code mode de règlement | 055 | 057 | 03
10 | Code journal | 058 | 059 | 02
11 | Première commande-ligne | 060 | 068 | 09
12 | Sous-famille | 069 | 071 | 03
13 | Type de commande de rattachement | 072 | 074 | 03
14 | Code j transférable | 075 | 075 | 01
15 | Code TVA | 076 | 078 | 03
16 | Libre | 079 | 080 | 02
17 | Code devise | 081 | 083 | 03
18 | Centre dominant | 084 | 086 | 03
19 | Code client VOLUME | 087 | 092 | 06
20 | Code représentant | 093 | 095 | 03
21 | Quantité | 096 | 105 | 10
22 | Libre | 106 | 126 | 21

Descriptif des zones du fichier

N° | Champ | Détails
01 | Code société VOLUME | Code société de la facture ou de l'avoir
02 | Type de ligne | Toujours P
03 | Numéro de pièce | Numéro de la facture ou de l'avoir
04 | Date de pièce | Date de la facture ou de l'avoir sous la forme dd/mm/yyyy
05 | Numéro de compte | Compte comptable du HT (Produits, Remise, Escompte, Port, Emballage et Frais d'expédition)
06 | Montant en devise | Montant HT en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&
07 | Code Débit/Crédit | D = Débit, C = Crédit
08 | Date d'échéance | Date de la première échéance de la facture ou de l'avoir sous la forme dd/mm/yyyy
09 | Code mode de règlement | Code mode de règlement de la facture ou de l'avoir
10 | Code journal | Les 2 premiers du code journal paramétré sur la fiche société
11 | Première commande-ligne | N° de commande et ligne de commande de la première ligne de la facture ou de l'avoir 01-08 Numéro de commande 09-09 Ligne de commande
12 | Sous-famille | Code sous-famille de la ligne de commande
13 | Type de commande de rattachement | Type de commande de la commande
14 | Code j transférable | mp_param[34] de l'article de la ligne de la facture ou de l'avoir
15 | Code TVA | Code TVA de la ligne de la facture ou de l'avoir
16 | Libre | Blanc
17 | Code devise | Code devise de la facture ou de l'avoir
18 | Centre dominant | Centre dominant de la ligne de commande
19 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
20 | Code représentant | Code représentant de la ligne de commande
21 | Quantité | Les lignes de produits Quantité facturée de la ligne de la facture ou de l'avoir Les lignes de frais d'expédition Quantité facturée de la ligne de la facture ou de l'avoir rattachée à la ligne de frais d'expédition Lignes de remise, d'escompte, de port et d'emballage Toujours 0000000001
22 | Libre | Blanc

Ligne TVA (Uniquement pour les produits et les frais d'expédition)

Structure du fichier

N° | Champ | de | à | Nb car
01 | Code société VOLUME | 001 | 003 | 03
02 | Type de ligne | 004 | 004 | 01
03 | Numéro de pièce | 005 | 012 | 08
04 | Date de pièce | 013 | 022 | 10
05 | Numéro de compte | 023 | 030 | 08
06 | Montant en devise | 031 | 043 | 13
07 | Code Débit/Crédit | 044 | 044 | 01
08 | Date d'échéance | 045 | 054 | 10
09 | Code mode de règlement | 055 | 057 | 03
10 | Code journal | 058 | 059 | 02
11 | Première commande-ligne | 060 | 068 | 09
12 | Sous-famille | 069 | 071 | 03
13 | Type de commande de rattachement | 072 | 074 | 03
14 | Code j transférable | 075 | 075 | 01
15 | Code TVA | 076 | 078 | 03
16 | Libre | 079 | 080 | 02
17 | Code devise | 081 | 083 | 03
18 | Centre dominant | 084 | 086 | 03
19 | Code client VOLUME | 087 | 092 | 06
20 | Code représentant | 093 | 095 | 03
21 | Quantité | 096 | 105 | 10
22 | Numéro de compte de la ligne HT | 106 | 113 | 08
23 | Montant en devise de la ligne HT | 114 | 126 | 13

Descriptif des zones du fichier

N° | Champ | Détails
01 | Code société VOLUME | Code société de la facture ou de l'avoir
02 | Type de ligne | Toujours T
03 | Numéro de pièce | Numéro de la facture ou de l'avoir
04 | Date de pièce | Date de la facture ou de l'avoir sous la forme dd/mm/yyyy
05 | Numéro de compte | Compte comptable de la TVA
06 | Montant en devise | Montant TVA en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&
07 | Code Débit/Crédit | D = Débit, C = Crédit
08 | Date d'échéance | Date de la première échéance de la facture ou de l'avoir sous la forme dd/mm/yyyy
09 | Code mode de règlement | Code mode de règlement de la facture ou de l'avoir
10 | Code journal | Les 2 premiers du code journal paramétré sur la fiche société
11 | Première commande-ligne | N° de commande et ligne de commande de la première ligne de la facture ou de l'avoir 01-08 Numéro de commande 09-09 Ligne de commande
12 | Sous-famille | Code sous-famille de la ligne de commande
13 | Type de commande de rattachement | Type de commande de la commande
14 | Code j transférable | mp_param[34] de la ligne de la facture ou de l'avoir
15 | Code TVA | Code TVA de la ligne de la facture ou de l'avoir
16 | Libre | Blanc
17 | Code devise | Code devise de la facture ou de l'avoir
18 | Centre dominant | Centre dominant de la ligne de commande
19 | Code client VOLUME | Code client VOLUME de la facture ou de l'avoir
20 | Code représentant | Code représentant de la ligne de commande
21 | Quantité | Quantité facturée de la ligne HT
22 | Numéro de compte de la ligne HT | Compte comptable de la ligne HT
23 | Montant en devise de la ligne HT | Montant HT remises et escompte déduits en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&


Format ALTAI

Transfert des factures de ventes vers la comptabilité ALTAI

Descriptif du fichier généré

Ligne Ecriture (TTC-TVA-HT-REM-ESC)

01 – Type d'enregistrement (A)

02 – Numéro de séquence

03 – Date de facture

04 – Sous-compte

05 – Contrepartie

06 – Numéro de facture

07 – Débit / Crédit

08 – Montant en euros

09 – Numéro de facture

10 – Vide

11 – Vide

12 – Raison sociale du client

13 – Numéro de facture

14 – Vide

15 – Vide

16 – Vide

17 – Code devise de VoluPack

18 – Libellé devise

19 – Montant en devises

20 – Montant en euros

21 – E

Ligne TVA

01 – Type d'enregistrement (I)

02 – Date de facture

03 – Montant de la base TVA en euros

04 – Pourcentage de la TVA

05 – Montant de la TVA en euros

06 – 0 (Zéro)

07 – 0 (Zéro)

08 – Numéro de facture

09 – Sous-compte

10 – Numéro de TVA du client

11 – Type de l'opération (Code soumission TVA de Volupack)

1 si ventes en Espagne (N, E, S)

2 si ventes intracommunautaires (I)

3 si exportations (O)

12 – Montant de la base TVA en euros

13 – Montant de la TVA en euros

14 – 0 (Zéro)

15 – Montant TTC de la facture en euros

16 – Montant TTC de la facture en euros

Ligne Tiers

01 – Type d'enregistrement (C)

02 – Sous-compte

03 – Numéro de TVA du client

04 – Raison sociale du client

05 – Vide

06 – Adresses rues 1 et 2

07 – Vide

08 – Vide

09 – Vide

10 – Vide

11 – Code postal

12 – Ville

13 – Province

14 – Téléphone 1

15 – Téléphone 2

16 – Fax 1

17 – Fax 2

18 – Contact

19 – Libellé secteur d'activité

20 – Code pays facturé

21 – Date de création du client

22 – Forme de paiement (Mode de règlement de VoluPack)

23 – Taxe d'égalisation (N)

24 – Compte du tiers

25 – Adresse email

26 – 0 (Zéro)

27 – Type de l'opération (Code soumission TVA de Volupack)

1 si ventes en Espagne (N, E, S)

2 si ventes intracommunautaires (I)

3 si exportations (O)

Ligne Echéance

01 – Type d'enregistrement (E)

Un enregistrement par date d'échéance

02 – Date d'échéance

03 – Numéro de facture

04 – Date de facture

05 – Numéro d'ordre

1 si première échéance

2 si deuxième échéance

3 si troisième échéance

06 – Numéro de facture

07 – 0 (Zéro)

08 – Traite acceptée (S)

09 – Traite domiciliée (N)

10 – Montant TTC de l'échéance en euros

11 – Compte du tiers

12 – Vide

13 – Vide

14 – Vide

15 – Vide

16 – Vide

17 – Vide

18 – Code banque

19 – Code guichet

20 – Clé de contrôle

21 – Numéro de compte bancaire client

22 – Vide

23 – E

24 – Montant TTC de l'échéance en euros

25 – Code devise de VoluPack

26 – Montant TTC de l'échéance en devises

27 – Vide


Format CCMX

Utilisé dans tr_cli_ccmx (Transfert des tiers vers la comptabilité CCMX)

S'il n'y a pas de séparateur, la colonne Position doit être ignorée.

Nom champ | Type | Taille maxi | Position | Commentaire
Compte | Texte | 9 | 001,009 |
Compte collectif | Texte | 9 | 010,018 |
Intitulé | Texte | 25 | 019,043 |
Intitulé long | Texte | 60 | 044,103 |
Devise | Texte | 3 | 104,106 | Il s'agit de la devise de tenue du compte. (cf DEV)
Mode de règlement | Num | 2 | 107,108 | cf MRG
Echéance durée | Num | 2 | 109,110 | (1)
Echéance position | Num | 2 | 111,112 | (2)
Nom du tiers | Texte | 32 | 113,144 |
Adresse ligne 1 | Texte | 32 | 145,176 |
Adresse ligne 2 | Texte | 32 | 177,208 |
Adresse ligne 3 | Texte | 32 | 209,240 | inutilisé
Ville | Texte | 25 | 241,265 |
Code postal | Texte | 5 | 266,270 |
Code pays | Num | 2 | 271,272 | Norme ISO (cf PAY)
Téléphone | Texte | 15 | 273,287 |
Fax | Texte | 15 | 288,302 |
Email | Texte | 255 | 303,557 |
Nom banque | Texte | 20 | 558,577 |
Code banque | Texte | 5 | 578,582 |
Code guichet | Texte | 5 | 583,587 |
N° de compte | Texte | 11 | 588,598 |
Clé RIB | Texte | 2 | 599,600 |

(1) Echéance durée : Permet de préciser le délai de règlement en nombre de jours (ex : 30jours, 45, 90).

Si absence de délai dans le cas d'un règlement à réception de facture, indiquez 0.

(2) Echéance position : Permet de préciser le jour de règlement en utilisant les codes suivants :

0 = début de mois

99 = fin de mois

1 à 30, pour les jours correspondants, ex : le 10, le 15, le 20

33 = date de comptabilisation

La combinaison des deux éléments (échéance durée / échéance position) détermine la date de l échéance.

Exemple : pour un client réglant à 30 jours fin de mois : Echéance durée = 30 et Echéance Position = 99


Format COBYS

Fichier comptable [image] Fichier tiers

Structure du fichier comptable (factures clients et factures fournisseurs)

01 | 001-003 | 03 caractères | Code société
02 | 004-009 | 06 caractères | Numéro de compte général
03 | 010-013 | 04 caractères | Exercice
04 | 014-016 | 03 caractères | Période
05 | 017-019 | 03 caractères | Code journal
06 | 020-023 | 04 caractères | Année de pièce
07 | 024-025 | 02 caractères | Mois de pièce
08 | 026-027 | 02 caractères | Jour de pièce
09 | 028-028 | 01 caractère | Auxiliaire
10 | 029-038 | 10 caractères | Numéro de tiers
11 | 039-044 | 06 caractères | Centre d'imputation analytique
12 | 045-050 | 06 caractères | Numéro de dossier
13 | 051-053 | 03 caractères | Code devise
14 | 054-054 | 01 caractère | Type période
15 | 055-057 | 03 caractères | Nature de pièce
16 | 058-087 | 30 caractères | Libellé de la pièce
17 | 088-107 | 20 caractères | Référence de pièce
18 | 108-108 | 01 caractère | Sens d'écriture
19 | 109-122 | 14 caractères | Montant en devise
20 | 123-126 | 04 caractères | Année d'échéance
21 | 127-128 | 02 caractères | Mois d'échéance
22 | 129-130 | 02 caractères | Jour d'échéance
23 | 131-132 | 02 caractères | Mode de règlement
24 | 133-140 | 08 caractères | Numéro de dossier
25 | 141-143 | 03 caractères | Code TVA

Descriptif des zones du fichier pour le transfert des factures clients

Descriptif des zones du fichier pour le transfert des factures fournisseurs

Descriptif des zones du fichier pour le transfert des factures clients (factures de vente) (tr_fcnn_vl)

01 Code société

Code de la société

02 Numéro de compte général

Compte Collectif Client pour la ligne TTC :

= Compte collectif client de la facture ou de l'avoir paramétré dans la zone ic_char30 du TSC CCL du client

= Compte collectif client de la facture ou de l'avoir paramétré dans les notes commençant par COLLECTIF_CLIENT du paramètre #CF TRF si non renseigné

Compte Vente pour les lignes HT articles

Compte TVA pour les lignes TVA

Compte Port pour les ports taxables ou non taxables

Compte Remise pour la remise

Compte Escompte pour l'escompte

etc.…

03 Exercice

Année de la date de facture ou d'avoir sous la forme AAAA

04 Période

Mois de la date de facture ou d'avoir sous la forme MM suivi d'un zéro

05 Code journal

Code journal du régime fiscal de la facture ou de l'avoir paramétré dans les notes commençant par CODESJOURNAUX: du paramètre #CF TRF

Code journal de la fiche société si non renseigné

06 Année de pièce

Année de la date de facture ou d'avoir sous la forme AAAA

07 Mois de pièce

Mois de la date de facture ou d'avoir sous la forme MM

08 Jour de pièce

Jour de la date de facture ou d'avoir sous la forme JJ

09 Auxiliaire

C pour la ligne TTC
Blanc pour les autres lignes

10 Numéro de tiers

Code client VoluPack / VoluPrim pour la ligne TTC
Blanc pour les autres lignes

11 Centre d'imputation analytique

Blanc

12 Numéro de dossier

Blanc

13 Code devise

Code ISO de la devise de la facture ou de l'avoir
= DEV alpha1[1,3] du code devise de la facture ou de l'avoir
Code devise de la facture ou de l'avoir si non renseigné

14 Type période

Toujours C

15 Nature de pièce

FAC Facture
AVO Avoir

16 Libellé de la pièce

Numéro de facture ou d'avoir

17 Référence de pièce

Nom du client de la facture ou de l'avoir

18 Sens d'écriture

D Débit
C Crédit

19 Montant en devise

Montant en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&&
Montant non signé et en centimes

20 Année d'échéance

Année de la première date d'échéance sous la forme AAAA pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

21 Mois d'échéance

Mois de la première date d'échéance sous la forme MM pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

22 Jour d'échéance

Jour de la première date d'échéance sous la forme JJ pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

23 Mode de règlement

Mode de règlement de la facture ou de l'avoir pour la ligne TTC
Blanc pour les autres lignes
= MRG alpha1[1,3] du mode de règlement de la facture ou de l'avoir
Mode de règlement de la facture ou de l'avoir si non renseigné

Descriptif des zones du fichier pour le transfert des factures fournisseurs (factures d'achat) (tr_fac_fou)

01 Code société

Code de la société

02 Numéro de compte général

Compte Collectif Fournisseur pour la ligne TTC

= Compte collectif fournisseur de la facture ou de l'avoir paramétré dans la zone ic_char30 du TSC CFO du fournisseur

= Compte collectif fournisseur de la facture ou de l'avoir paramétré dans les notes commençant par COLLECTIF_FOURN. du paramètre #CF TFF si non renseigné

Compte Achat pour les lignes HT articles

Compte TVA pour les lignes TVA

Compte TVA paramétré dans les notes commençant par COMPTE_TVA_ACH_ du code TVA de la ligne de facture ou d'avoir.

Les notes sont suivies du mode d'exonération de la facture ou de l' avoir.

TVA alpha1[18,25] du code TVA de la ligne de facture ou d'avoir si non renseigné.

#CF TFFalpha1[17,24] si toujours non renseigné.

Compte Port pour les ports taxables ou non taxables

Compte Remise pour la remise

Compte Escompte pour l'escompte

Compte Ecart entre le montant calculé et montant facturé

etc.…

03 Exercice

Année de la date de facture ou d'avoir sous la forme AAAA

04 Période

Mois de la date de facture ou d'avoir sous la forme MM suivi d'un zéro

05 Code journal

Code journal du régime fiscal de la facture ou de l'avoir paramétré dans les notes commençant par CODESJOURNAUX du paramètre CF TFF
Code journal de la fiche société si non renseigné

06 Année de pièce

Année de la date de facture ou d'avoir sous la forme AAAA

07 Mois de pièce

Mois de la date de facture ou d'avoir sous la forme MM

08 Jour de pièce

Jour de la date de facture ou d'avoir sous la forme JJ

09 Auxiliaire

F pour la ligne TTC
Blanc pour les autres lignes

10 Numéro de tiers

Code fournisseur VoluPack / VoluPrim pour la ligne TTC
Blanc pour les autres lignes

11 Centre d'imputation analytique

Blanc

12 Numéro de dossier

Blanc

13 Code devise

Code ISO de la devise de la facture ou de l'avoir
= DEV, alpha1[1,3] du code devise de la facture ou de l'avoir
Code devise de la facture ou de l'avoir si non renseigné

14 Type période

Toujours C

15 Nature de pièce

FAC = Facture
AVO = Avoir

16 Libellé de la pièce

Numéro de facture ou d'avoir

17 Référence de pièce

Référence de la facture ou de l'avoir

18 Sens d'écriture

D = Débit
C = Crédit

19 Montant en devise

Montant en devise de la facture ou de l'avoir sous la forme &&&&&&&&&&&&&&
Montant non signé et en centimes

20 Année d'échéance

Année de la première date d'échéance sous la forme AAAA pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

21 Mois d'échéance

Mois de la première date d'échéance sous la forme MM pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

22 Jour d'échéance

Jour de la première date d'échéance sous la forme JJ pour la ligne TTC
Blanc pour les autres lignes
Pas d'échéances multiples

23 Mode de règlement

Mode de règlement de la facture ou de l'avoir pour la ligne TTC
Blanc pour les autres lignes
= MRG, alpha1[1,3] du mode de règlement de la facture ou de l'avoir
Mode de règlement de la facture ou de l'avoir si non renseigné

24 Numéro de dossier

Les 8 premiers caractères de l'affectation de la ligne de commande

25 Code TVA

Code TVA paramétré dans les notes commençant par COMPTE_TVA_ACH_ du code TVA de la ligne de facture ou d'avoir.

Les notes sont suivies du mode d'exonération de la facture ou de l' avoir.

TVA alpha2[38,40] du code TVA de la ligne de facture ou d'avoir si non renseigné.

Structure du fichier tiers

01 | 001-003 | 03 caractères | Société
02 | 004-004 | 01 caractère | Auxiliaire
03 | 005-014 | 10 caractères | Numéro de tiers
04 | 015-044 | 30 caractères | Libellé long du tiers
05 | 045-054 | 10 caractères | Libellé court du tiers
06 | 055-074 | 20 caractères | Mot directeur du tiers
07 | 075-078 | 04 caractères | Année début activité
08 | 079-080 | 02 caractères | Mois début activité
09 | 081-082 | 02 caractères | Mode de règlement
10 | 083-085 | 03 caractères | Calcul échéance
11 | 086-086 | 01 caractère | Régime TVA
12 | 087-087 | 01 caractère | Edition relevé
13 | 088-088 | 01 caractère | Edition traite
14 | 089-091 | 03 caractères | Code devise ISO
15 | 092-100 | 09 caractères | Numéro de SIREN
16 | 101-105 | 05 caractères | Numéro de SIRET
17 | 106-110 | 05 caractères | Type de société
18 | 111-112 | 02 caractères | Numéro domiciliation du tiers
19 | 113-117 | 05 caractères | RIB Code banque
20 | 118-122 | 05 caractères | RIB Code guichet
21 | 123-133 | 11 caractères | RIB Numéro de compte
22 | 134-135 | 02 caractères | RIB Clé de contrôle
23 | 136-159 | 24 caractères | Bénéficiaire
24 | 160-183 | 24 caractères | Libellé guichet
25 | 184-203 | 20 caractères | Libellé banque
26 | 204-205 | 02 caractères | Numéro adresse du tiers
27 | 206-237 | 32 caractères | Raison sociale
28 | 238-269 | 32 caractères | Adresse rue
29 | 270-274 | 05 caractères | Code postal
30 | 275-300 | 26 caractères | Adresse ville
31 | 301-303 | 03 caractères | Code pays ISO
32 | 304-304 | 01 caractère | Code langue ISO
33 | 305-336 | 32 caractères | Adresse lieu-dit
34 | 337-351 | 15 caractères | Numéro de téléphone
35 | 352-361 | 10 caractères | Numéro de télex
36 | 362-381 | 20 caractères | Nom de l'interlocuteur
37 | 382-396 | 15 caractères | Numéro de télécopie

Descriptif des zones du fichier pour le transfert des tiers (tr_cli_cpt)

ATTENTION, chaque enregistrement doit se terminer par un CR+LF

01 Société | Toujours 007
02 Auxiliaire | C Client
 | F Fournisseur
03 Numéro de tiers | Le code tiers Volume
04 Libellé long du tiers | Le nom du tiers
05 Libellé court du tiers | TSC à paramétrer (EX : NAB)
06 Mot directeur du tiers | TSC à paramétrer (EX : MDI)
07 Année début activité | L'année de la date du jour sur 4 caractères sous la forme &&&&
08 Mois début activité | Le mois de la date du jour sur 2 caractères sous la forme &&
09 Mode de règlement | Mode de règlement correspondant en comptabilité = alpha1[1,2] du paramètre MRG du mode règlement Si non renseigné, il est initialisé avec le mode de règlement
10 Calcul échéance | Code échéance correspondant en comptabilité = alpha3[5,7] du paramètre ECH du code échéance Si non renseigné, il est initialisé avec le code échéance
11 Régime TVA | Le code soumission TVA
12 Edition relevé | Le code édition relevé
13 Edition traite | Le code édition traite
14 Code devise ISO | Code ISO de la devise = alpha1[1,3] du paramètre DEV du code devise Si non renseigné, il est initialisé avec le code devise
15 Numéro de SIREN | Les caractères 5 à 13 du code SIRET
16 Numéro de SIRET | Les caractères 14 à 18 du code SIRET
17 Type de société | Le code qualificatif
18 Numéro domiciliation du tiers | Chrono sur 2 caractères sous la forme &&
19 RIB Code banque | Les caractères 1 à 5 du RIB
20 RIB Code guichet | Les caractères 6 à 10 du RIB
21 RIB Numéro de compte | Les caractères 11 à 21 du RIB
22 RIB Clé de contrôle | Les caractères 22 à 23 du RIB
23 Bénéficiaire | Le nom du tiers
24 Libellé guichet | La 1ère domiciliation bancaire
25 Libellé banque | La 2ème domiciliation bancaire
26 Numéro adresse du tiers | Chrono sur 2 caractères sous la forme &&
27 Raison sociale | Le nom du tiers
28 Adresse rue | La 1ère ligne de l'adresse
29 Code postal | Le code postal de l'adresse
30 Adresse ville | La ville de l'adresse
31 Code pays ISO | Code ISO du pays = alpha1[16,18] du paramètre PAY du code pays Si non renseigné, il est initialisé avec le code pays
32 Code langue ISO | Code ISO de la langue = alpha1[2] du paramètre LAN du code langue Si non renseigné, il est initialisé avec le code langue
33 Adresse lieu-dit | La 2ème ligne de l'adresse
34 Numéro de téléphone | Le 1er numéro de téléphone
35 Numéro de télex | Le numéro de télex
36 Nom de l'interlocuteur | Le nom du correspondant
37 Numéro de télécopie | Le numéro de télécopie

Paramétrage pour le transfert des tiers

F valeur_constante*3*007*

F cl_cpf*1*

F cl_code*6*

F ablanc*4*

F cl_nom*30*

F TSC_CL_CL_NAB_G*10*

F TSC_CL_CL_MDI_G*20*

F today*4*yyyy*

F today*2*mm*

F mrg_compta_cl_mrg*2*

F ech_compta_cl_ech*3*

F cl_exp*1*

F cl_rel*1*

F cl_edit*1*

F code_iso_cl_dev*3*

F siret_code_siren*9*

F siret_code_etablissement*5*

F cl_qual*3*

F ablanc*2*

F numero_adresse_tiers*2*&&*

F rib_code_banque*5*

F rib_code_guichet*5*

F rib_numero_compte*11*

F rib_cle*2*

F cl_nom*24*

F cl_domb1*20*

F ablanc*4*

F cl_domb*20*

F numero_adresse_tiers*2*&&*

F cl_nom*30*

F ablanc*2*

F cl_adr1*30*

F ablanc*2*

F cl_codp*5*

F cl_vil*25*

F ablanc*1*

F code_iso_cl_pays*3*

F code_iso_cl_langue*1*

F cl_adr2*30*

F ablanc*2*

F cl_telph1*15*

F cl_telex*10*

F cl_corres*20*

F cl_telcop*15*


Format COTRE

Structure du fichier des commandes d'achat

structure du fichier des mouvements de stock

Structure du fichier des commandes d'achat

01 | 001-008 | 08 caractères | Date du transfert
02 | 009-014 | 06 caractères | Heure du transfert
03 | 015-022 | 08 caractères | Numéro commande
04 | 023-025 | 03 caractères | Ligne commande
05 | 026-033 | 08 caractères | Date de commande
06 | 034-039 | 06 caractères | Code fournisseur
07 | 040-054 | 15 caractères | Montant de la ligne de commande
08 | 055-094 | 40 caractères | Libellé de la ligne de commande
09 | 095-114 | 20 caractères | Code marché ou contrat
10 | 115-124 | 10 caractères | Compte budgétaire ou comptable
11 | 125-128 | 04 caractères | Code section
12 | 129-136 | 08 caractères | Date de livraison prévue de la ligne de commande
13 | 137-145 | 09 caractères | Numéro et ligne de commande client
14 | 146-147 | 02 caractères | Code TVA
15 | 148-148 | 01 caractère | Code état de la ligne
16 | 149-156 | 08 caractères | Date de livraison réelle de la ligne de commande
17 | 157-157 | 01 caractère | Article stocké
18 | 158-172 | 15 caractères | Quantité commandée de la ligne de commande
19 | 173-187 | 15 caractères | Quantité réceptionnée de la ligne de commande
20 | 188-195 | 08 caractères | Code opération
21 | 196-215 | 20 caractères | Nom du fournisseur
22 | 216-220 | 05 caractères | Taux TVA

Descriptif des zones du fichier des commandes d'achat

01

Date du transfert

Date système du jour du transfert sous la forme yyyyddmm

02

Heure du transfert

Heure système du jour du transfert sous la forme hhmmss

03

Numéro commande

Numéro de la commande

04

Ligne commande

Ligne de la commande sous la forme &&&

05

Date de commande

Date de la commande sous la forme yyyyddmm

06

Code fournisseur

Code fournisseur de la commande

07

Montant de la ligne de commande

Montant en devise société de la ligne de commande sous la forme &&&&&&&&&&&&.&& si commande de type FAC (TYC alpha1[1] ¹ A)

Montant en devise société de la ligne de commande sous la forme -&&&&&&&&&&&.&& si commande de type AVO (TYC alpha1[1] = A)

08

Libellé de la ligne de commande

Libellé de la ligne de commande

09

Code marché ou contrat

Blanc

10

Compte budgétaire ou comptable

Compte Achat

11

Code section

Centre de coût de la ligne de commande si renseigné

SSTK si non renseigné et article suivi en stock

NSTK si non renseigné et article non suivi en stock

12

Date de livraison prévue de la ligne de commande

Date de livraison prévue de la ligne de commande sous la forme yyyyddmm

13

Numéro et ligne de commande client

Les caractères 1 à 8 de l'affectation de la ligne de commande suivis du caractère 10 de cette même zone

999999999 si non renseigné

14

Code TVA

Les caractères 2 et 3 du code TVA de la ligne de commande

15

Code état de la ligne

A si la ligne de commande est annulée

C si la ligne de commande est créée et non modifiée et non réceptionnée

M si la ligne de commande est créée et modifiée et non réceptionnée

P si la ligne de commande a fait l'objet d'une réception et si la quantité totale réceptionnée est inférieure à la quantité commandée et si elle n'est pas soldée

T si la ligne de commande a fait l'objet d'une réception et si la quantité totale réceptionnée est inférieure à la quantité commandée et si elle est soldée

T si la ligne de commande a fait l'objet d'une réception et si la quantité totale réceptionnée est supérieure ou égale à la quantité commandée

16

Date de livraison réelle de la ligne de commande

Date de livraison réelle de la ligne de commande sous la forme yyyyddmm

17

Article stocké

Article suivi en stock (O/N)

18

Quantité commandée de la ligne de commande

Quantité commandée de la ligne de commande sous la forme &&&&&&&&&&&.&&& si commande de type FAC (TYC alpha1[1] ¹ A)

Quantité commandée de la ligne de commande sous la forme -&&&&&&&&&&.&&& si commande de type AVO (TYC alpha1[1] = A)

19

Quantité réceptionnée de la ligne de commande

Quantité réceptionnée de la ligne de commande sous la forme &&&&&&&&&&&.&&& si commande de type FAC (TYC alpha1[1] ¹ A)

Quantité réceptionnée de la ligne de commande sous la forme -&&&&&&&&&&.&&& si commande de type AVO (TYC alpha1[1] = A)

20

Code opération

Les 8 premiers caractères de la valeur alpha 30 du TSC code opération saisi sur l'entête de commande

21

Nom du fournisseur

Les 20 premiers caractères du nom du fournisseur

22

Taux TVA

Taux TVA de la ligne de commande

Structure du fichier des mouvements de stock

01 | 01-04 | 04 caractères | Année
02 | 05-06 | 02 caractères | Mois
03 | 07-10 | 04 caractères | Affectation analytique section
04 | 11-19 | 09 caractères | Affectation analytique commande client
05 | 20-29 | 10 caractères | Compte comptable analytique
06 | 30-48 | 19 caractères | Montant
07 | 49-60 | 12 caractères | Quantité
08 | 61-69 | 09 caractères | Prix unitaire
09 | 70-84 | 15 caractères | Code article
10 | 85-87 | 03 caractères | Unité de stockage ou de vente
11 | 88-90 | 03 caractères | Type de mouvement
12 | 91-96 | 06 caractères | Taux de gestion

Descriptif des zones du fichier des mouvements de stock

Année | Année du mouvement de stock
Mois | Mois du mouvement de stock
Affectation analytique section | 4 premiers caractères du centre de coût du mouvement de stock A blanc si les 4 premiers caractères du centre de coût du mouvement de stock ne sont pas renseignés.
Affectation analytique commande client | Numéro et ligne de commande de la zone affectation du mouvement de stock Neuf 9 si la zone affectation du mouvement de stock n'est pas renseignée ou renseignée avec autre chose qu'un numéro d'oF Le numéro de ligne est à 9 si celui-ci n'est pas compris entre 1 et 9
Compte comptable analytique | Compte comptable analytique sur 10 caractères Compte achat de la fiche article complété par des 0 #CF TFF alpha1[1,8] complétés par des 0 si le compte d'achat de la fiche article n'est pas renseigné A blanc si le compte achat de la fiche article et #CF TFF alpha1[1,8] non renseignés
Montant | Montant signé en moins si mouvement de type entrée Montant signé en plus si mouvement de type sortie Le point décimal est remplacé par une virgule
Quantité | Quantité signée en moins si mouvement de type entrée Quantité signée en plus si mouvement de type sortie Le point décimal est remplacé par une virgule
Prix unitaire | Prix du mouvement de stock si mouvement de type entrée Prix d'achat moyen pondéré de la fiche article si mouvement de type sortie Le point décimal est remplacé par une virgule
Code article | Code article du mouvement de stock
Unité de stockage ou de vente | Unité de vente de la fiche article
Type de mouvement | Type du mouvement de stock
Taux de gestion | Pourcentage de frais de la fiche article Le point décimal est remplacé par une virgule


Format Gondardennes

Format utilisé dans generer_edi_cde

Le fichier doit se nommer CGWCDE.TXT

Peu importent les majuscules et les minuscules.

Respecter les espaces et les extensions du fichier, etc.

Un seul fichier par message

Le séparateur est le point-virgule.

Paramétrer les options Ons et Orm dans generer_edi_cde.

Paramètre nécessaire : TSC ORD

Zone | Description | Type | Long. | Remarques | VSW
C0CCLI | Votre numéro de client | Alpha | 4 | Votre code client vous sera fourni par notre service commercial | idem type SCAO
C0LREE | Zone réservée au client | Alpha | 20 | Zone libre réservée au client mais qui ne sera pas intégrée dans notre application | idem type SCAO
C0LREF | Votre référence entête et/ou ligne | Alpha | 20 | Zone importante qui marque l'unicité de votre commande | idem type SCAO
C0CADR | Code adresse de livraison | Alpha | 3 | Zone à blanc si votre adresse de livraison est votre adresse principale. Si vous avez plusieurs adresses de livraison, indiquez le code de livraison souhaité pour cette commande. Ces codes vous seront fournis par notre service commercial. | A prendre sur les notes de type EDI du client livré
C0QUA1 | Qualité 1 | Alpha | 4 | Indiquez le code qualité international. Valeurs possibles : G, F, E, B, C, GF, GE, EF, EE, BE, CB, G SF, F SF,B SF, E SF, C SF | Profil carton de la qualité matière <VF> En fonction de generer_edi_cde A3[12] : 1 - Cette zone est alimentée par le code paramétré dans la note CODE_QUALITE_INTER de FAM si #CF ATL A2[17]] = 1 SFM si #CF ATL A2[17]] = 2 (Valeur par défaut) 2 - Cette zone est alimentée par le code paramétré dans la note CODE_QUALITE_INTER de SFM
C0QUA2 | Qualité 2 | Alpha | 4 | Indiquer notre code article | Libellé étranger du produit commandé <VF> En fonction de generer_edi_cde A3[13] : 1 - Cette zone est alimentée par le libellé étranger de la qualité matière (Valeur par défaut). 2 - Cette zone est alimentée par le mp_at1 du produit acheté.
C0DDEL | Date de livraison | Num | 8 0 | Date de livraison sous la forme JJMMAAAA | idem type SCAO
C0QFLZ | Laize | Num | 5 0 | Zone obligatoire | idem type SCAO
C0QFLG | Longueur | Num | 5 0 | Zone obligatoire | idem type SCAO
C0QCDE | Quantité | Num | 7 0 | Zone obligatoire | idem type SCAO
C0CCON | Code conditionnement | Alpha | 1 | P =Palette B =Balle R =Rouleau | idem type SCAO
C0VUNI | Prix Franco | Num | 9 2 | Zone facultative (Prix au mille m2) Exemples : Pour 200 € mettre 20000. Pour 352,40 € mettre 35240. | idem type SCAO
C0QR01 | Refouleur 1 | Num | 4 0 |  | idem type SCAO
C0QR02 | Refouleur 2
C0QR03 | Refouleur 3
C0QR04 | Refouleur 4
C0QR05 | Refouleur 5
C0QR06 | Refouleur 6
C0QR07 | Refouleur 7
C0QR08 | Refouleur 8
C0QR09 | Refouleur 9
C0QR10 | Refouleur 10
C0QR11 | Refouleur 11
C0QR12 | Refouleur 12
C0QR13 | Refouleur 13
C0QR14 | Refouleur 14
C0QR15 | Refouleur 15
C0QR16 | Refouleur 16
C0QR17 | Refouleur 17
C0QR18 | Refouleur 18
C0QR19 | Refouleur 19
C0QR20 | Refouleur 20
C0QR21 | Refouleur 21
C0QR22 | Refouleur 22
C0QR23 | Refouleur 23
C0QR24 | Refouleur 24
C0COMM | Zone commentaire | Alpha | 180 |  | idem type SCAO


Format LD Compta

Fichier comptable [image] Fichier tiers

Structure du fichier comptable

01 | 001-001 | 01 caractère | Type d'enregistrement
02 | 002-003 | 02 caractères | Code journal
03 | 004-011 | 08 caractères | Numéro écriture
04 | 012-018 | 07 caractères | Numéro pièce
05 | 019-026 | 08 caractères | Date pièce
06 | 027-051 | 25 caractères | Libellé
07 | 052-059 | 08 caractères | Date échéance
08 | 060-060 | 01 caractère | Code nature pièce
09 | 061-062 | 02 caractères | Racine compte collectif
10 | 063-077 | 15 caractères | Montant en francs ou euros (devise société)
11 | 078-078 | 01 caractère | Code Débit/Crédit
12 | 079-084 | 06 caractères | Compte général
13 | 085-092 | 08 caractères | Date comptable
14 | 093-095 | 03 caractères | Code lettrage
15 | 096-103 | 08 caractères | Date lettrage
16 | 104-111 | 08 caractères | Compte auxiliaire
17 | 112-112 | 01 caractère | Code nature tiers
18 | 113-118 | 06 caractères | Section analytique
19 | 119-120 | 02 caractères | Code trésorerie
20 | 121-121 | 01 caractère | Numéro relance
21 | 122-129 | 08 caractères | Date valeur
22 | 130-139 | 10 caractères | Référence document
23 | 140-143 | 04 caractères | Code affaire
24 | 144-147 | 04 caractères | Numéro séquence analytique
25 | 148-162 | 15 caractères | Montant en devises
26 | 163-165 | 03 caractères | Code devise ISO
27 | 166-176 | 11 caractères | Taux de la devise

Descriptif des zones du fichier pour le transfert des factures clients (factures de vente) (tr_fcnn_vl)

ATTENTION, chaque enregistrement doit se terminer par un CR+LF

01 Type d'enregistrement | Toujours E
02 Code journal | Les 2 premiers caractères du code journal paramétré sur la fiche société
03 Numéro écriture | Numéro d'ordre unique sous la forme b&&&&&&& (b = Blanc) Celui-ci est remis à 1 à chaque transfert
04 Numéro pièce | Les caractères 2 à 8 du numéro de facture ou d'avoir Le 1er caractère du numéro de facture ou d'avoir est enlevé (Il est toujours à 0)
05 Date pièce | Date de la facture ou de l'avoir sous la forme yyyymmdd
06 Libellé | Libellé de la facture ou de l'avoir sous la forme 01-07 Les caractères 2 à 8 du numéro de facture ou d'avoir 08 Blanc 09-10 CL 11 Blanc 12-16 Les caractères 3 à 7 du compte comptable du client 17 Blanc 18-25 Les 8 premiers caractères du nom du client
07 Date échéance | Première date d'échéance sous la forme yyyymmdd pour la ligne TTC Blanc pour les autres lignes Pas d'échéances multiples
08 Code nature pièce | F Facture A Avoir
09 Racine compte collectif | Blanc
10 Montant en francs ou euros (Devise société) | Blanc
11 Code Débit/Crédit | D Débit C Crédit
12 Compte général | Compte Collectif Client pour la ligne TTC Compte Vente pour les lignes HT articles Compte TVA pour les lignes TVA Compte Port pour les ports taxables ou non taxables Compte Remise pour la remise Compte Escompte pour l'escompte etc.…
13 Date comptable | Date de la facture ou de l'avoir sous la forme yyyymmdd
14 Code lettrage | Blanc
15 Date lettrage | Blanc
16 Compte auxiliaire | Compte comptable du client pour la ligne TTC Blanc pour les autres lignes
17 Code nature tiers | C pour la ligne TTC Blanc pour les autres lignes
18 Section analytique | Blanc
19 Code trésorerie | Blanc
20 Numéro relance | Blanc
21 Date valeur | Blanc
22 Référence document | Blanc
23 Code affaire | Blanc
24 Numéro séquence analytique | Blanc
25 Montant en devises | Montant en devises de la facture ou de l'avoir sous la forme b&&&&&&&&&&&.&& (b = Blanc)
26 Code devise ISO | Code ISO de la devise de la facture ou de l'avoir
 | = alpha1[1,3] du paramètre DEV du code devise de la facture ou de l'avoir
27 Taux de la devise | Taux de la devise de la facture ou de l'avoir par rapport à l'eURO sous la forme b&&.&&&&&&& (b = Blanc) Facultatif pour les devises IN Obligatoire pour les devises OUT

Structure du fichier tiers

01 | 001-001 | 01 caractère | Type d'enregistrement
02 | 002-009 | 08 caractères | Numéro de tiers
03 | 010-019 | 10 caractères | Nom condensé
04 | 020-023 | 04 caractères | Titre
05 | 024-048 | 25 caractères | Raison sociale
06 | 049-080 | 32 caractères | Adresse Ligne 1
07 | 081-112 | 32 caractères | Adresse Ligne 2
08 | 113-117 | 05 caractères | Adresse Code postal
09 | 118-143 | 26 caractères | Adresse Ville
10 | 144-158 | 15 caractères | Adresse Pays
11 | 159-173 | 15 caractères | Numéro de téléphone
12 | 174-188 | 15 caractères | Numéro de télex
13 | 189-203 | 15 caractères | Numéro de télécopie
14 | 204-228 | 25 caractères | Nom de l'interlocuteur
15 | 229-248 | 20 caractères | Commentaire
16 | 249-262 | 14 caractères | Numéro de Siret
17 | 263-263 | 01 caractère | RIB principal
18 | 264-288 | 25 caractères | Domiciliation bancaire
19 | 289-293 | 05 caractères | RIB Code banque
20 | 294-298 | 05 caractères | RIB code guichet
21 | 299-309 | 11 caractères | RIB Numéro de compte
22 | 310-311 | 02 caractères | RIB Clé de contrôle
23 | 312-313 | 02 caractères | Mode de paiement
24 | 314-317 | 04 caractères | Délai de paiement
25 | 318-320 | 03 caractères | Jour de paiement
26 | 321-321 | 01 caractère | Report à fin de mois
27 | 322-322 | 01 caractère | Solvabilité
28 | 323-335 | 13 caractères | Plafond de crédit
29 | 336-348 | 13 caractères | En-cours financier
30 | 349-352 | 04 caractères | Code représentant
31 | 353-377 | 25 caractères | Nom Prénom représentant
32 | 378-392 | 15 caractères | Téléphone représentant
33 | 393-393 | 01 caractère | Groupe de relance
34 | 394-394 | 01 caractère | Compte lettrable
35 | 395-396 | 02 caractères | Code activité
36 | 397-399 | 03 caractères | Code devise ISO
37 | 400-400 | 01 caractère | Groupe de trésorerie
38 | 401-408 | 08 caractères | Numéro de fournisseur à payer
39 | 409-410 | 02 caractères | Banque de paiement

Descriptif des zones du fichier pour le transfert des tiers (tr_cli_cpt)

ATTENTION, chaque enregistrement doit se terminer par un CR+LF

01 Type d'enregistrement | C Client F Fournisseur
02 Numéro de tiers | Les 8 premiers caractères du code comptable
03 Nom condensé | Les 10 premiers caractères du nom
04 Titre | Le code qualificatif
05 Raison sociale | Les 25 premiers caractères du nom
06 Adresse Ligne 1 | La 1ère ligne de l'adresse
07 Adresse Ligne 2 | La 2ème ligne de l'adresse
08 Adresse Code postal | Le code postal de l'adresse
09 Adresse Ville | La ville de l'adresse
10 Adresse Pays | Le libellé court ou long du paramètre PAY du code pays de l'adresse
11 Numéro de téléphone | Le 1er numéro de téléphone
12 Numéro de télex | Le numéro de télex
13 Numéro de télécopie | Le numéro de télécopie
14 Nom de l'interlocuteur | Le nom du correspondant
15 – Commentaire | A blanc
16 Numéro de Siret | Les caractères 5 à 18 du code SIRET
17 RIB principal | Toujours P
18 Domiciliation bancaire | La 1ère domiciliation bancaire
19 RIB Code banque | Les caractères 1 à 5 du RIB
20 RIB code guichet | Les caractères 6 à 10 du RIB
21 RIB Numéro de compte | Les caractères 11 à 21 du RIB
22 RIB Clé de contrôle | Les caractères 22 à 23 du RIB
23 Mode de paiement | Mode de règlement correspondant en comptabilité = alpha1[1,2] du paramètre MRG du mode règlement Si non renseigné, il est initialisé avec le mode de règlement
24 Délai de paiement | Nb de jours à ajouter à la date de calcul (30 jours fin de mois, 60 jours nets, …) (valeur numérique 1 du paramètre ECH du code échéance)
25 Jour de paiement | Jour de l'échéance (Le 10, le 20, le 30, …) (valeur numérique 2 du paramètre ECH du code échéance) Si la valeur est supérieure à 31, elle est remise à 0.
26 Report à fin de mois | Fin de mois ou non (30 jours fin de mois le 10, 60 jours le 10, 90 jours nets, …) M il s'agit de jours fin de mois si alpha1[3] du paramètre ECH du code échéance = F ou si alpha1[3] du paramètre ECH du code échéance = [blanc] et valeur numérique 2 du paramètre ECH du code échéance > 31 [blanc] il s'agit de jours nets si alpha1[3] du paramètre ECH du code échéance = [blanc] et valeur numérique 2 du paramètre ECH du code échéance < 32
27 Solvabilité | A blanc
28 Plafond de crédit | A zéro sous la forme b000000000.00 (b = Blanc)
29 En-cours financier | A zéro sous la forme b000000000.00 (b = Blanc)
30 Code représentant | Si client : = Code représentant Si fournisseur : = à blanc
31 Nom Prénom représentant | Si client : = Le libellé court ou long du paramètre REP du code représentant Si fournisseur : = à blanc
32 Téléphone représentant | Si client : = alpha2[1,15] du paramètre REP du code représentant Si fournisseur : = à blanc
33 Groupe de relance | A blanc
34 Compte lettrable | A blanc
35 Code activité | A blanc
36 Code devise ISO | Code ISO de la devise alpha1[1,3] du paramètre DEV du code devise Si non renseigné, il est initialisé avec le code devise
37 Groupe de trésorerie | A blanc
38 Numéro de fournisseur à payer | A blanc
39 Banque de paiement | A blanc

Paramétrage pour le transfert des tiers

F cl_cpf*1*

F cl_cpt*8*

F cl_nom*10*

F cl_qual*3*

F ablanc*1*

F cl_nom*25*

F cl_adr1*30*

F ablanc*2*

F cl_adr2*30*

F ablanc*2*

F cl_codp*5*

F cl_vil*25*

F ablanc*1*

F libc_cl_pays*10*

F ablanc*5*

F cl_telph1*15*

F cl_telex*10*

F ablanc*5*

F cl_telcop*15*

F cl_corres*25*

F ablanc*20*

F siret_code_siren*9*

F siret_code_etablissement*5*

F valeur_constante*1*P*

F cl_domb1*20*

F ablanc*5*

F rib_code_banque*5*

F rib_code_guichet*5*

F rib_numero_compte*11*

F rib_cle*2*

F mrg_compta_cl_mrg*2*

F nombre_jours_cl_ech*4*&&&&*

F jour_cl_ech*3*&&&*

F fin_mois_cl_ech*1*

F ablanc*1*

F ablanc*1*

F valeur_constante*12*000000000.00*

F ablanc*1*

F valeur_constante*12*000000000.00*

F cl_repr*3*

F ablanc*1*

F libl_cl_repr*25*

F telephone_cl_repr*15*

F ablanc*1*

F ablanc*1*

F ablanc*2*

F code_iso_cl_dev*3*

F ablanc*1*

F ablanc*8*

F ablanc*2*


Format MAGIC

Transfert des factures de vente vers la comptabilité MAGIC (GENERO uniquement)

Colonne | Contenu de la colonne | Nb de positions | Alignement | Commentaires VSW
1 | Code journal des ventes = VT | 02 | G | Valeur fixe : VT
2 | Vide | 01 |  |
3 | N° de la pièce | 06 | D | N° de transaction par jour (5)
4 | Vide | 01 |  |
5 | N° de ligne | 03 | D | N° de ligne de la transaction
6 | Vide | 02 |  |
7 | La journée | 02 | D | Jour de la facture
8 | Vide | 01 |  |
9 | Compte Comptable | 08 | G | Voir liste ci-après (1)
10 | Vide | 01 |  |
11 | Code tiers | 06 | G | Code comptable du tiers (4)
12 | Montant | 12 | D | Montant correspond au compte
13 | Vide | 01 |  |
14 | D (débit) ou C (crédit) | 01 |  | (2)
15 | Vide | 01 |  |
16 | Libellé de la ligne | 30 | G | (3)
17 | Vide | 01 |  |
18 | N° de la facture | 09 | G | N° de facture/Avoir (4)
19 | Vide | 01 |  |
20 | Désignation du client | 50 | G | Nom du client (4)

(1) Listes des Comptes comptables :

470 : montant TTC de la facture

547100 : montant de la TVA

547500 : montant du timbre fiscal

710100 : Montant HT Plaques

710101 : Montant HT intercalaires

712100 : Montant HT Caisse

712101 : Montant HT Barquette

712102 : Montant HT Cornières

(2) Débit / Crédit

Pour les factures, D pour le montant TT, et C pour les montants de TVA et HT

Pour les avoirs, C pour le montant TT, et D pour les montants de TVA et HT

(3) Libellé de la ligne

FACTURE N° / AVOIR N° : pour les enregistrements des comptes 470

TVA DU JJ/MM/AA : pour les enregistrements des comptes 547100, suivi de la date du document

TIMB.F. DU JJ/MM/AA : pour les enregistrements des comptes 547500, suivi de la date du document

VENTES DU JJ/MM/AA : pour les enregistrements factures des comptes 71, suivi de la date du document

AVOIRS DU JJ/MM/AA : pour les enregistrements avoirs des comptes 71, suivi de la date du document

(4) ces zones ne sont renseignées que pour les enregistrements des comptes 470.

(5) Règle de détermination du N° de pièce : un numéro séquentiel commençant par 1 du 1er jour de facturation


Format SAGE 100

L'import des écritures Sage permet de récupérer un fichier issu des applications Sage sous DOS ou Windows contenant des écritures comptables et analytiques.

L'extension du fichier importé est .PNM. Sa structure est la suivante :

Libellés de zone ou de champs | Pos | Long | Commentaire
1. Code journal | 1 | 3 |
2. Date de pièce | 4 | 6 | JJMMAA
3. Type de pièce | 10 | 2 | FC; AC; RC; FF; AF; RF; OD
4. Compte général | 12 | 13 |
5. Type de compte (1) | 25 | 1 | G ou Blanc ou Général, A : Analytique, X : Auxiliaire
6. Compte auxiliaire ou section analytique | 26 | 13 |
7. Référence de l'écriture (2) | 39 | 13 |
8. Libellé de l'écriture | 52 | 25 |
9. Mode de paiement (3) | 77 | 1 | E : Espèce; C : Chèque; T : Traite; U : Carte bleue; L : LCR; V : Virement; P : Prélèvement; S: Aucun
10. Date d'échéance | 78 | 6 | JJMMAA
11. Sens | 84 | 1 | D : Débit; C : Crédit; M : Mixte
12. Montant de l'écriture en monnaie de tenue de compte | 85 | 20 |
13. Type d'écriture | 105 | 1 | N : Normale; A : A-Nouveau; S : Simulation
14. N° pièce | 106 | 7 | Cadré à droite
15. Zone réservée | 113 | 26 | Non utilisé. Variable selon les produits.
16. Code ISO de la monnaie de tenue de compte (4) | 139 | 3 |
17. Montant en devise (4) | 142 | 20 |
18. Code ISO de la devise de l'écriture (4) | 162 | 3 |
19. Plan/Axe analytique (5) | 165 | 10 | Numéro du Plan analytique dans la comptabilité L100. Zone alphanumérique cadrée à gauche.
20. Section analytique (5) | 175 | 25 | Non utilisé. Uniquement si le logiciel destinataire gère les sections sur plus de 13 caractères.

(1) Type de compte

Une ligne de mouvement dont le Type de compte est X peut être éventuellement suivie de une ou plusieurs autres lignes dont le Type de compte est E (= lignes d'échéance). Ces lignes E et X doivent avoir :

• le même numéro d'écriture,

• le même compte général,

• le même compte tiers,

• le même code journal,

• la même période contenue dans Date de pièce.

L'égalité Somme des montants des lignes E = Montant ligne X doit être vérifiée lors de la vérification de l'équilibre des journaux.

Dans le cas de l'existence de ces lignes (1) Type de compte :

Une ligne de mouvement dont le Type de compte est X peut être éventuellement suivie de une ou plusieurs autres lignes dont le Type de compte est E (= lignes d'échéance). Ces lignes E et X doivent avoir :

• le même numéro d'écriture,

• le même compte général,

• le même compte tiers,

• le même code journal,

• la même période contenue dans Date de pièce.

L'égalité 'Somme des montants des lignes E = Montant ligne X doit être vérifiée lors de la vérification de l'équilibre des journaux.

Dans le cas de l'existence de ces lignes E, la ligne X ne sera pas importée, les lignes E relatives à cette ligne X seront toutes importées.

(2) Référence pièce

Selon l'option Conserver la référence pièce d'origine de la fenêtre d'import,

• Non cochée : le contenu de la zone Référence pièce est stockée dans la zone Numéro de pièce du dossier comptable.
La référence pièce est alors à blanc.

• Cochée : la zone Référence pièce est stockée dans la zone correspondante du dossier comptable.
Le Numéro de pièce est alors automatiquement incrémenté selon l'option de numérotation du journal.

(3) Mode de règlement

Le mode de règlement est comparé au 1er caractère des intitulés de modes de règlement. Si ce code n'existe pas ou blanc, le mode de règlement est alors Aucun.

(4) Zones Devise

Lorsque ces zones sont renseignées, elles sont reportées au niveau de la ligne d'écriture importée afin de conserver une trace de la devise de transaction.

(5) Zones Analytiques

Exemple chiffré :

Le jeu d'essai C_bijou comporte 2 plans Activité et Produit. Soit une facture d'achats marchandises de 100,00 € répartie de la manière suivante :

Activité 922LY3 D 50,00

922ME3 D 50,00

Produit 9301AR D 60,00

9311AR D 20,00

9321AR D 20,00

N° compte | Type | Compte tiers ou analytique | Sens | Montant | Plan | Section
601020 | G |  | D | 100,00 |  |
601020 | A | 922LY3 | D | 50,00 | 1 |
601020 | A | 922ME3 | D | 50,00 | 1 |
601020 | A | 9301AR | D | 60,00 | 2 |
601020 | A | 9311AR | D | 20,00 | 2 |
601020 | A | 9321AR | D | 20,00 | 2 |
4456620 | G |  | D | 19,60 |  |
401000 | X | JASER | C | 119,60 |  |


Format SAGE 500

01 | 001-006 | 06 caractères | Code journal
02 | 007-022 | 16 caractères | Numéro de compte
03 | 023-023 | 01 caractère | Sens de l'écriture D Débit C Crédit
04 | 024-038 | 15 caractères | Montant en devise société
05 | 039-041 | 03 caractères | Code ISO de la devise société
06 | 042-081 | 40 caractères | Libellé de l'écriture
07 | 082-089 | 08 caractères | Date de l'écriture
08 | 090-105 | 16 caractères | Numéro de l'écriture
09 | 106-121 | 16 caractères | Centre axe 1
10 | 122-129 | 08 caractères | Date d'échéance
11 | 130-135 | 06 caractères | Nature de l'écriture FAC Facture AVO Avoir
12 | 136-138 | 03 caractères | Code ISO de la devise de l'écriture Toujours renseigné même si la devise de l'écriture est identique à la devise société
13 | 139-153 | 15 caractères | Montant en devise de l'écriture Toujours renseigné même si la devise de l'écriture est identique à la devise société
14 | 154-168 | 15 caractères | Quantité (toujours à 00000000000.000)
15 | 169-184 | 16 caractères | Centre axe 2
16 | 185-200 | 16 caractères | Centre axe 3 (non renseigné)
17 | 201-216 | 16 caractères | Centre axe 4 (non renseigné)
18 | 217-232 | 16 caractères | Centre axe 5 (non renseigné)
19 | 233-234 | 2 caractères | Jour de la pièce (uniquement sur modèle 2)
20 | 235-242 | 8 caractères | Document (uniquement sur modèle 2)
21 | 243-243 | 1 caractère | Code BAP_GZZ (uniquement sur modèle 2) (toujours égal à O)
22 | 244-246 | 3 caractères | Code INTRA (uniquement sur modèle 2) Oui si client groupement Non dans le cas contraire


Format Sage 1000 ou générique

Avant-propos

Le mode 2 pour l'interface avec Sage ligne 1000 est en train de devenir un standard utilisable avec toutes les comptabilités.

En effet, dans le mode 2, vous pouvez paramétrer l'ordre des colonnes à votre convenance.

Par conséquent, tout paramétrage indiqué comme étant réservé à Sage 1000, peut être utilisé pour d'autres comptabilités.

Y compris la zone so_compta qui doit être à 1.

Mode 2 : Vous devez mettre la note MODE_FIC_SAGE_1000 à 2, dans #CF TFF et dans #CF TRF.

Ceci est impératif, car, par défaut, le mode est à 1 (ordre des colonnes imposé et figé).

Ce format est utilisable à partir de la V.4.1.41.2

Fichier d'interface Sage ligne 1000 pour

Transfert des factures fournisseurs en comptabilité (tr_fac_fou avec #CF TFF)

Transfert des factures clients en comptabilité (tr_fcnn_vl avec #CF TRF)

Pour Sage 1000, la zone so_compta doit être à 1.

Colonnes disponibles en mode 2 du fichier de transfert de la ligne 1000 de Sage

La note MODE_FIC_SAGE_1000 est paramétrée à 2, dans #CF TFF et dans #CF TRF.

Dans le mode 2, vous paramétrez l'ordre des colonnes à votre convenance.

Ces colonnes sont utilisables avec la note CHAMP_FICHIER, voir exemples plus bas.

Les colonnes sont triées par ordre alphabétique.

AXE_ANAL | Axe analytique
BON_A_PAYER | Uniquement pour les achats : OUI si c'est dans la tolérance; NON si ce n'est pas dans la tolérance
CODE_CLI_DO | Code client de l'entête de commande
CODE_COMPTABLE | Correspond au code comptable zone fe_cpt (disponible au niveau des ventes, pas au niveau des achats)
CODE_ETAB | Code site (soit ec_c1 soit ef_c1)
CODE_JOURNAL | Code journal
CODE_TIERS | Code tiers facturé
COMPTE | Compte collectif
CPT_TVA | Compte TVA (selon si avoir ou facture)
DATE_COMPTABLE |
DATE_ECHEANCE | Date d'échéance de la facture
DATE_PIECE | Date de la facture
DEVISE | Code ISO de la devise (A1[1,3] du type paramètre DEV)
LIB_PIECE | Libellé de la pièce
MODE_MRG | Mode de règlement (A1[1,3] du type paramètre MRG)
MODE_TVA | Mode de TVA (TVA A2[37]) N Normal O Export S Suspension de TVA I Intracommunautaire E Exonéré
MONTANT_DEVISE | Montant de la facture en devise
MONTANT_EURO | Montant de la facture en euro
NUM_FACTURE | Numéro de facture pour les ventes Numéro de facture du fournisseur pour les achats
NUM_PROFORMA | Numéro de la facture proforma lié à la facture finale (uniquement pour les ventes) Le code échéance de la facture doit indiquer si celle-ci est de type pro-forma (ECH A2[5]).
SEC_ANAL | Section analytique
SENS | Sens de la transaction (Crédit ou Débit)
TYPE_CPT |
TYPE_PIECE | Type de pièce (avoir ou facture)
VAL_DEF_xx | où xx est un nombre compris entre 01 et 99. Nécessite la présence de la note VAL_DEF_xx dans le #CF TRF.
ZONE_LIBRE | Première ligne de note de type NTS soit sur l'entête de commande, soit sur la ligne de commande

Exemple pour le transfert des factures d'achat (factures fournisseurs)

#CF TFF - Paramétrage général

A4[15,16] = Ba

A4[39,40] =

1 2 3 4

1234567890123456789012345678901234567890

AXE_ANALYTIQUE AXE

CODE_JOURNAL_1000 ACH

CODE_TYPE_PIECE AF FF

CODESJOURNAUX TAXEXPSUSINTEXO

COLLECTIF_FOURN.40100000

MODE_FIC_SAGE_1000 2

SEPARATEUR ;

TOL_BON_A_PAYER 10

TYPE_LIB_PIECE 1

ZONE_LIBRE_1 ACH LF

#CF TFF - Paramétrage de l'ordre des champs

1 2 3 4

1234567890123456789012345678901234567890123

CHAMP_FICHIER TYPE_CPT 001

CHAMP_FICHIER CODE_ETAB 002

CHAMP_FICHIER BON_A_PAYER 003

CHAMP_FICHIER CODE_JOURNAL 004

CHAMP_FICHIER NUM_FACTURE 005

CHAMP_FICHIER DATE_PIECE 006

CHAMP_FICHIER DATE_COMPTABLE 007

CHAMP_FICHIER DATE_ECHEANCE 008

CHAMP_FICHIER COMPTE 009

CHAMP_FICHIER SENS 010

CHAMP_FICHIER MONTANT_DEVISE 011

CHAMP_FICHIER DEVISE 012

CHAMP_FICHIER AXE_ANAL 013

CHAMP_FICHIER SEC_ANAL 014

CHAMP_FICHIER CODE_TIERS 015

CHAMP_FICHIER LIB_PIECE 016

CHAMP_FICHIER TYPE_PIECE 017

CHAMP_FICHIER MODE_MRG 018

CHAMP_FICHIER CPT_TVA 019

CHAMP_FICHIER MONTANT_EURO 020

CHAMP_FICHIER MODE_TVA 021

CHAMP_FICHIER CODE_CLI_DO 022

CHAMP_FICHIER ZONE_LIBRE 023

Exemple pour le transfert des factures clients

#CF TRF - Paramétrage général

A4[15,16] =

A4[49,50] =

1 2 3 4

1234567890123456789012345678901234567890

AXE_ANALYTIQUE AXE

CODE_JOURNAL_1000 VEN

COD_SECT_ANAL_S1000 7000

COLLECTIF_CLIENT4100000

MODE_FIC_SAGE_1000 2

PARAM_SAGE_1000 C 2

SEPARATEUR |

TYPE_LIB_PIECE 1

ZONE_LIBRE_1 ACH LC

#CF TRF - Paramétrage de l'ordre des champs

1 2 3 4

1234567890123456789012345678901234567890123

CHAMP_FICHIER TYPE_CPT 001

CHAMP_FICHIER CODE_ETAB 002

CHAMP_FICHIER BON_A_PAYER 003

CHAMP_FICHIER CODE_JOURNAL 004

CHAMP_FICHIER NUM_FACTURE 005

CHAMP_FICHIER DATE_PIECE 006

CHAMP_FICHIER DATE_COMPTABLE 007

CHAMP_FICHIER DATE_ECHEANCE 008

CHAMP_FICHIER COMPTE 009

CHAMP_FICHIER SENS 010

CHAMP_FICHIER MONTANT_DEVISE 011

CHAMP_FICHIER DEVISE 012

CHAMP_FICHIER AXE_ANAL 013

CHAMP_FICHIER SEC_ANAL 014

CHAMP_FICHIER CODE_TIERS 015

CHAMP_FICHIER LIB_PIECE 016

CHAMP_FICHIER TYPE_PIECE 017

CHAMP_FICHIER MODE_MRG 018

CHAMP_FICHIER CPT_TVA 019

CHAMP_FICHIER MONTANT_EURO 020

CHAMP_FICHIER MODE_TVA 021

CHAMP_FICHIER CODE_CLI_DO 022

CHAMP_FICHIER ZONE_LIBRE 023

Ordre des colonnes en mode 1 du fichier de transfert de la ligne 1000 de Sage

Le mode 1 est réservé à Sage 1000 et ne peut pas être utilisé avec d'autres comptabilités.

La note MODE_FIC_SAGE_1000 est paramétrée à 1, dans #CF TFF et dans #CF TRF.

Dans le mode 1, l'ordre des colonnes est figé comme suit :

Transfert facture client

Code journal

Compte fournisseur

Si le numéro de compte fournisseur est vide alors 401 + 5 premiers caractères du code fournisseur VoluPack sinon numéro de compte fournisseur.

Sens de la transaction (Débit ou Crédit)

Montant en devise

Code ISO de la devise

Libelle de l’écriture

Date d’écriture

Numéro de pièce (Numéro de facture VoluPack/VoluPrim)

Section analytique = blanc

Date d’échéance

Nature de la pièce

Quantité = 0

Centre Axe 2 = blanc

Centre Axe 3 = blanc

Centre Axe 4 = blanc

Centre Axe 5 = blanc

Document = blanc

BAP = blanc

Intra = blanc

Mode règlement

Compte collectif

Flag affacturage

Transfert facture fournisseur

Code journal

Numéro de compte = blanc

Sens de la transaction (Débit ou Crédit)

Montant en devise

Code ISO de la devise

Libellé

Date d’écriture

Numéro de pièce (Numéro de facture VoluPack/VoluPrim)

Section analytique = blanc

Date d’échéance

Nature de la pièce

Ecart contrôle (montant)

Quantité = 0

Centre Axe 2 = blanc

Centre Axe 3 = blanc

Centre Axe 4 = blanc

Centre Axe 5 = blanc

Document = blanc

BAP = blanc

Intra = blanc

Mode règlement

Compte écart collectif

Flag affacturage


Format SAP

Intégration du fichier des écritures comptables de l'interface SAP Encours Clients dans les tables histo, echean et risque_detail.

Paramétrage

int_cpt A2[1] = 0

int_cpt A2[12] = 1 ou 2

Détail du fichier à intégrer

Car. début

Car. fin

Objet

Notes

001

010

Numéro de client dans le système commercial

Le N° de client est le N° transmis dans l'interface Efficial.

Si ce N° a été "dénaturé" lors de l'interface pour répondre aux contraintes des spécifications Efficial, il doit être reconstitué à l'intégration de l'encours.

Exemple

Le N° de client envoyé à Efficial est cl_code[2,5]+"00".

Pour retrouver le code client à l'intégration de l'encours, il faudra prendre les 4 premiers caractères de la zone "N° de client", les faire précéder et suivre d'un zéro.

011

014

Domaine d'activité

Codification SAP des usines

Besoin d'une table de correspondance

Le domaine d'activité correspond au code site.

Tableau de bord du multisite

Il doit être unique dans le fichier.

015

044

Agent responsable du client

Non traité lors de l'intégration

045

059

Encours 1er mois

Ensemble des PNS à échoir 31 à 60 jours après l'interface, regroupés par client et par domaine d'activité

Ce montant en euros correspond à l'encours non échu à échéance de 30 jours après la date de l'interface.

060

074

Encours 2ème mois

Ensemble des PNS à échoir 31 à 60 jours après l'interface, regroupés par client et par domaine d'activité

Ce montant en euros correspond à l'encours non échu à échéance de 60 jours après la date de l'interface.

075

089

Encours 3ème mois

Ensemble des PNS à échoir 61 à 90 jours après l'interface, regroupés par client et par domaine d'activité

Ce montant en euros correspond à l'encours non échu à échéance de 90 jours après la date de l'interface.

090

104

Encours 4ème mois

Ensemble des PNS à échoir plus de 90 jours après l'interface, regroupés par client et par domaine d'activité

Ce montant en euros correspond à l'encours non échu à échéance de plus 90 jours après la date de l'interface.

105

119

Documents échus et impayés

Ensemble des PNS échus à la date de l'interface, regroupés par client

et par domaine d'activité

Ce montant en euros correspond au total des impayés.

120

134

Encours total

Mois1+Mois2+Mois3+Mois4

Ne comprend pas les documents échus et impayés.

Ce montant en euros correspond au total de l'encours non échu.

Particularités du fichier à intégrer

Les montants sont au format &&&&&&&&&&&.&&-

Si le montant est signé, le signe est dans la dernière position du montant.

Règles d'intégration du fichier

Le fichier est intégré dans les tables histo et echean de VoluPack.

La table histo représente un encours par N° de pièce, ou dans une gestion d'encours cumulé, l'encours global pour le client.

Dans ce cas, le N° de pièce est un N° géré en automatique par le programme d'intégration.

Colonne | Type | Description | Commentaire
ino_inscr | integer | Numéro interne de l'écriture | N° auto
creference | char(10) | Référence externe de l'écriture | N° auto
inoligne | integer | Numéro de ligne de l'écriture | 1
xdate | date | Date de l'écriture | Today (représente la date d'intégration)
cjournal | char(2) | Code journal | Blanc
ccompte | char(8) | Numéro de compte client | Zone (1) du fichier d'interface recomposé suivant les règles de l'interface Efficial
csens | char(1) | Code sens de l'écriture | D si montant > 0 C si montant < 0
dmontant | decimal(13,2) | Montant de l'écriture | Somme des zones (8) et (9)
csection | char(3) | Code section | Blanc
clib_auto | char(3) | Code libelle automatique | FAC si montant > 0 AVO si montant < 0
clib_complet | char(27) | Complément libellé | Blanc
lettrage | char(3) | Code lettrage | Blanc
Soc | char(3) | Code société | Code société

La table echean représente l'encours par date d'échéance.

L'enregistrement reçu par client est donc scindé en plusieurs enregistrements dans la table echean.

Les dates d'échéances sont calculées comme suit :

Pour la zone 4, la date d'échéance = date d'intégration du fichier + 30 jours

Pour la zone 5, la date d'échéance = date d'intégration du fichier + 60 jours

Pour la zone 6, la date d'échéance = date d'intégration du fichier + 90 jours

Pour la zone 7, la date d'échéance = date d'intégration du fichier + 120 jours

Pour la zone 8, la date d'échéance = date d'intégration du fichier

Colonne | Type | Description | Commentaire
inum | integer | Numéro interne de l'écriture | histo. ino_inscr
inoligne | integer | Numéro de ligne de l'écriture | histo.inoligne
ccompte | char(8) | Numéro de compte client | histo.ccompte
cmod_paie | char(3) | Mode de paiement | blanc
xechea | date | Date d'échéance | Date calculée (voir ci-dessus)
dmontant | decimal(13,2) | Montant de l'échéance | Montant correspondant à l'échéance
ctoplet | char(1) | Code de la dernière lettre de relance | Blanc
xderlet | date | Date de la dernière lettre de relance | Blanc
iref | integer | Numéro de référence de la dernière lettre de relance | Blanc
Soc | char(3) | Code société | Code société


Saisie simplifiée des notes

Ligne de titre principale - Elle peut contenir :

• Le type de note (NTS) actuellement sélectionné (dans le cas des notes groupées, le message contiendra également la liste des types de notes associés).

• Un message d'anomalie si une erreur de paramétrage est détectée sur le type de note

Ligne de titre secondaire

Elle peut contenir un message d'avertissement si les notes actuellement affichées sont celles par défaut.

Boutons des types de notes

Cliquez sur l'un des 20 boutons pour afficher et/ou saisir les notes du type associé (NTS).

Boutons "Autres types de notes"

Cliquez sur ce bouton pour sélectionner un type de note (NTS) non représenté par l'un des 20 boutons.

Ligne d'information

Elle peut contenir le nombre de lignes saisissables au maximum dans le cas d'un type de note avec saisie limitée (NTS A1[7,9]).

Ligne de titre principale : contient le type de note principal (celui déclaré comme type de notes groupées)

Ligne de titre secondaire : contient le type de note associé à la ligne sélectionnée

Lignes de séparations : contiennent les libellés des types de notes composant les notes groupées.

Ces lignes de séparation sont figées et non modifiables.

L'insertion effectuée sur une de ces lignes concerne le type de note précédent. Exemple : l'insertion sur la ligne de séparation de type FRA (Frais de photogravure) insère une ligne de type AFN). L'insertion sur la première ligne de séparation n'est pas accessible.

Le message ci-dessous apparaît :

• Si un seul type de note est paramétré sur l'option –C du paramètre de lancement du programme et que celui-ci n'existe pas comme paramètre de type NTS

• Si le type de notes est celui par défaut (###).

L'icône ci-dessous apparaît si les notes groupées ne sont pas correctement paramétrées sur le type de notes associé au bouton (notes commençant par NOTES_GROUPEES sur le paramètre de lancement du programme ou GRP sur le type de notes (NTS) associé au bouton).

Le message ci-dessous apparaît si on clique sur le bouton associé à un type de notes groupées mal paramétrées.

Le message ci-dessous apparaît si les notes actuellement affichées sont celles par défaut (présentes sur le paramètre de type NTS).

Ce message disparaît si une modification est apportée (insertion/suppression de ligne, modification du contenu).

Le message de confirmation ci-dessous apparaît si l’utilisateur valide la saisie de notes par défaut sans avoir fait la moindre modification (NTS A1[12] = C ou blanc).

Le message ci-dessous apparaît si le type de notes est paramétré en saisie limitée (NTS A1[7,9]).

Le nombre de lignes saisissables au maximum est indiqué dans le message.

Le premier clic sur cette action définit le début du bloc à copier en mémoire.

L'action F12 (Coller) n'est pas accessible.

Le deuxième clic sur cette action définit la fin du bloc à copier en mémoire.

L'action F12 (Coller) devient accessible.

L'action F12 (Coller) reste accessible tant que le bloc est en mémoire.

Si l'utilisateur clique de nouveau sur l'action F11 (Copier), l'action est alors désactivée.

A la validation de la saisie (touche Entrée), le code 001 est remplacé par les notes saisies sur le paramètre CAU correspondant :

Remarques :

• Les lignes de notes sont insérées automatiquement (les lignes suivantes sont décalées vers le bas).

• Si la saisie est limitée sur le type de note en cours (NTS A1[7,9]), l'insertion se fait tant que le nombre de lignes maximum n'est pas atteint (le remplissage se fait dans l'ordre inverse de saisie dans les notes du paramétrage CAU).

• Le remplissage ne se fait que si la ligne de note comporte 3 caractères ou moins (correspondant à un type de paramètre CAU).
Dans l'exemple ci-dessus, la saisie de la ligne de note 001ABC ou 001 ABC n'aurait pas donné lieu à une insertion des commentaires automatiques.

Saisie simplifiée des notes

Cette fonctionnalité est accessible à partir de la V. 4.0.200.2

Fonctionnalité

Cette nouvelle saisie permet de gérer la saisie des notes de tous les programmes VoluPack de la même façon (articles, commande, devis, etc.), via un écran commun.

VERIFIER Dans certains cas, une option doit être positionnée pour que cette saisie soit possible (par exemple, dans cde, l'option Ong doit être activée).

Remarques

• ATTENTION : Pour le moment, cette nouvelle saisie est activée uniquement pour les notes sur les articles (mat3).
Une fois le fonctionnement validé, celle-ci sera répercutée dans tous les programmes VoluPack.

• Cette nouvelle saisie gère les tables de notes suivantes :

mat3 : Notes sur les articles

cli3 : Notes sur les tiers

cde3 : Notes sur les commandes clients

blv3 : Notes sur les bons de livraison

cdf3 : Notes sur les commandes fournisseurs

formules2 : Notes sur les formules

note_ldev : Notes sur les devis/demandes client

notes : Notes générales

• Les tables utilisées et méthodes d'enregistrements restent inchangées.

• Par défaut, cette nouvelle saisie présente la liste des types de notes accessibles sous la forme de boutons (voir annexe 1 : nouveau mode).
Ce fonctionnement peut être désactivé afin de revenir à la présentation standard : sélection du type de note puis ouverture des notes
(voir annexe 2 : ancien mode)

• Cette nouvelle saisie gère également la saisie des notes groupées. Celle-ci est activée lorsque :

Le type de note est GRP. Dans ce cas, la liste des types de notes à inclure sera renseignée sur le paramètre de lancement du programme en cours

Le type de note est défini comme étant Notes groupées. Dans ce cas, la liste des types de notes à inclure sera renseignée sur le paramètre du type de note sélectionné (NTS).

• Ce paragraphe comporte 5 annexes présentant les fonctionnalités :

1. Description de l'écran (nouveau mode de sélection)

2. Description des écrans (ancien mode de sélection)

3. Description des messages possibles

4. Description des actions possibles

5. Fonctionnement des commentaires automatiques

Paramétrage

Tout programme

Type de note spécifique : NTS GRP

Il suffit de déclarer ce type de note dans n'importe quel programme pour activer la saisie des notes groupées.

La liste des types de notes à inclure est alors définie sur la note NOTES_GROUPEES (voir ci-dessous) du paramètre de lancement du programme concerné.

La note NOTES_GROUPEES peut être paramétrée dans tout programme disposant d'une saisie de notes.

21,23 Type de note à inclure dans la saisie des notes groupées, lorsque NTS GRP est déclaré (voir ci-dessus).

NTS xxx

(où xxx représente un type de notes groupées)

A1[2] = G Il s'agit d'un type de notes groupées.

Sinon Il ne s'agit pas d'un type de notes groupées (par défaut).

Note commençant par GRP

4,60 Liste des types de notes à inclure dans la saisie des notes groupées
19 codes de 3 caractères par ligne de note (doit correspondre à un type de paramètre NTS)

NTS yyy

(où yyy représente un type de notes)

Valeur numérique 2

Ancien mode de sélection : Numéro d'indice permettant d'afficher les types de notes dans l'ordre désiré dans l'écran de sélection

Nouveau mode de sélection : Numéro d'indice permettant d'afficher les boutons de sélection des types de notes dans l'ordre désiré dans l'écran de saisie des notes (20 boutons de sélection au maximum)

A1[7,9] Nombre de lignes saisissables au maximum pour ce type de note

Par défaut : 0 (pas de limitation)

Ce fonctionnement est également valable pour les notes groupées.

A1[10,11] (Nouveau mode de sélection uniquement)

Numéro d'indice permettant d'afficher les boutons de sélection des types de notes dans l'ordre désiré dans l'écran de saisie des notes (20 boutons de sélection au maximum)
Par défaut : ce numéro d'indice est pris sur la valeur numérique 2

A1[12] Méthode d'enregistrement des notes par défaut si aucune modification n'est effectuée

O Les notes par défaut sont systématiquement enregistrés (qu'elles soient modifiées ou non)

N Les notes par défaut non modifiées ne sont jamais enregistrées (elles doivent faire l'objet d'une modification pour être enregistrées)

C Demande de confirmation si les notes par défaut n'ont pas été modifiées (si elles ont fait l'objet d'une modification, elles seront enregistrées sans demande de confirmation) (par défaut)

A2[1,60] Nouveau mode de sélection uniquement :

Chemin de l'image à mettre en place sur le bouton correspondant au type de notes sur la saisie des notes

Par défaut : l'image est celle habituellement utilisée pour l'action de saisie des notes

Aucune ligne de note présente pour ce type

Au moins une ligne de note présente pour ce type

Erreur de paramétrage sur les notes groupées (voir annexe 3)

Remarque

Si une image est paramétrée sur au moins un type de note (donc un bouton de sélection), les images de présence de notes s'afficheront à droite des boutons de sélection.

Par exemple :

Aucune ligne de note présente pour ce type

Au moins une ligne de note présente pour ce type

Note sans nom :

1,60 Ligne de note par défaut qui sera recopiée lors de l'appel à la saisie des notes, si aucune note n'existe pour ce type.

Remarques :

• Les autres notes du NTS (celles qui ont un nom) ne sont pas prises en compte comme lignes de notes par défaut.

• Les notes par défaut ne sont pas prises en compte dans la saisie des notes groupées.

#CF NTS A1[1]

Activation du nouveau mode de sélection des types de notes (par boutons) (O/N, O par défaut)

CAU zzz

(où zzz représente un code de commentaire automatique)

Note sans nom :

1,60 Ligne de note automatique qui sera insérée lors de la saisie du code paramètre CAU/xxx dans la saisie des notes (voir annexe 5)

Remarque : Dans le cas d'un type de note avec saisie limitée, il est possible que les lignes automatiques ne puissent pas être insérées entièrement.

Annexes

Annexe 1 - Description de l'écran (nouveau mode de sélection)

Saisie des notes

Saisie des notes groupées (exemple : Notes de type GRP composées des notes de type FAC, AFN, FRA et HIS)

Sélection d'un type de note non présent dans les boutons (Bouton Autres types de notes)

Saisie en modification des notes d'un type non présent dans les boutons (exemple : note de type OAT)

Annexe 2 - Description des écrans (ancien mode de sélection)

Sélection du type de note

Saisie des notes en modification (exemple : note de type FRA)

Saisie des notes groupées (exemple : Notes de type GRP composées des notes de type FAC, AFN, FRA et HIS) :

Annexe 3 - Description des messages possibles

Attention ! Le type de note n'est pas renseigné ou inexistant.

Erreur de paramétrage dans les notes groupées

Type de notes groupées mal paramétrées

Les notes actuellement affichées sont celles par défaut.

Valider la saisie de notes par défaut sans modification

Nombre de lignes maximum en saisie limitée

Annexe 4 - Description des actions possibles

Action F8 (Aide saisie) : Aide à la saisie d'une ligne de note de paramétrage sous la forme 20 + 40 caractères

Action F9 (Saisie par caractères) : Aide à la saisie d'une ligne de note de caractère par caractère

Action F11 (Copier) / Etape 1 : Sélection du début de bloc à copier

Action F11 (Copier) / Etape 2 : Sélection de la fin de bloc à copier

Action F12 (Coller) : Collage du bloc des lignes copiées en mémoire

Annexe 5 - Fonctionnement des commentaires automatiques

Lignes de notes sur le paramètre de commentaire automatique CAU/001

Saisie du code 001 sur une ligne de note


Aide

Cette fonctionnalité est accessible à partir de la V.4.0.181.2

Pouvoir accéder à une aide en ligne, expliquant le fonctionnement du module ou de l'écran.

Paramétrage

Tous programmes : note NOM_AIDE_LIGNE | 21,60 Nom du document sur le module (sans espace) Exemple aide_saisie_article.docx
WIN AID | Paramètre de type WIN à créer - Pas de paramétrage particulier Libellé long : Envoi aide en ligne Libellé court : Aide ligne
#CF ATL notes REP_AIDE_LIGNE SUF_AIDE_LIGNE | 21,60 Répertoire où se situe l'aide en ligne 21,25 Suffixe du nom du document dans le cas où celui-ci est construit Exemples .docx, .pdf, ...
USE note TYP_AIDE_LIGNE | 21,60 Type de l'aide en ligne (paramètre AID) * (astérisque) signifie que l'on peut voir tous les types d'aide
AID Nouveau paramètre | A1[1,5] = Suffixe du nom du document dans le cas où celui-ci est construit Exemples .docx, .pdf, ...

Utilisation

[En cours de formatage]

Le nom du document à afficher se construit de la manière suivante :

Répertoire général (cf note REP_AIDE_LIGNE du #CF ATL)

Code langue de l'utilisateur (FR, ANG, ..) (cf paramétrage langue sur type USE + paramètre type LAN)

Le type d'aide définit sur le user (cf note TYP_AIDE_LIGNE sur type USE)

(si le type d'aide est *, une grille de sélection sera proposée)

Le nom final du document est en fait le nom de l'écran (ici G_compo_1)

On peut paramétrer un nom de document pour le module, cf note NOM_AID_LIGNE sur paramètre de lancement)

Dans ce cas, l'accès à l'aide posera la question de savoir quel document on veut consulter, celui du module ou celui de l'écran.

Dans le cas où l'on consulte le document relatif à l'écran (le nom est construit), on lui attribuera comme suffixe celui paramétré sur le type d'aide (AID), si rien de saisie, on prendra celui sur le #CF ATL

Exemple :

Paramètre WIN AID

#CF ATL

USE xxxx

Module composition

Paramètre AID

Aide en ligne

Message : comme on a paramétré sur le USE * dans le type d'aide, on propose une recherche :

On choisit ADM

Si OUI on accèdera au document

D:/temp/aide/FR/ADM/G_compo_1.docx

(D:/temp/aide provient du #CF ATL

FR code langue de l'utilisateur

ADM choix du type d'aide

G_compo_1 nom de l'écran

.docx suffixe sur le type ADM)

Si NON on accèdera au document

D:/temp/aide/FR/ADM/aide_compo.docx

(D:/temp/aide provient du #CF ATL

FR code langue de l'utilisateur

ADM choix du type d'aide

aide_compo.docx provient de la note du paramètre de lancement NOM_AIDE_LIGNE

)


Dans le cas particulier des AR, il arrive souvent qu'une modification de la commande repositionne l'AR à éditer (pour gérer les répercussions des modifications dans les FBI par exemple).

Dans ce cas, lors de la nouvelle édition de l'AR, le système valide automatiquement l'envoi de la commande par Fax/Mail (paramétrage mis en œuvre pour l'édition - fonctionnement voulu à la première édition).

Dans le cas d'une réédition de l'AR, le système ouvre la fenêtre Fax/Mail pour permettre à l'utilisateur de revalider (si voulu) un nouvel envoi de la commande au client.

Reste un 3ième cas géré par ce développement, on fait une nouvelle édition de l'AR pour mettre à jour les données des commandes rattachées, on souhaite se comporter comme en réédition.

Ce développement a été fait pour tous les programmes d'édition; il n'est pas spécifique à l'édition des AR.

Fax-Mail

Ce chapitre recense les notes utilisées dans la gestion Fax/Mail.

Ces notes peuvent être paramétrées sur le paramètre de lancement de tous les modules faisant appel à la fonction de gestion du Fax-Email.

Types de documents

Les types de document sont marqués xxx dans les notes PREFIX_DOCUMENT_xxx, CLE_DOCUMENT_xxx, PREFIX_OBJET_xxx, CLE_OBJET_xxx.

ACR | Accusé de réception de commande client
ATR | non géré
BLV | Bon de livraison
CDF ou CDA | Commande fournisseur ou Commande d'achat
DEA | Demande d'achat
DEV | Devis
FAC | Facture
MLG | non géré
NCI | Non-conformité interne
OAT | Ordre d'achat de transport
OEX | Ordre d'expédition
RCL | Réclamation client ou fournisseur

Notes propres à certains programmes

EMETTEUR_FAX_EMAIL

21,26 Type et code du paramètre de l'expéditeur du fax/email. Utilisable dans

blv - dem_achat - exped_affretements - facn - nci_saisie - cdef - - gen_cdef - prep_affret - reclam_cli_saisie - devis_ondu

Notes figurant dans le module f_gestionfaxemail

MAJ_CORRESPONDANT

21 Mise à jour des données des correspondants

N Pas de mise à jour

O Mise à jour automatique

W Mise à jour avec message d'avertissement

C Mise à jour avec demande de confirmation (par défaut)

22 Mise à jour des données de l'expéditeur (si différent du destinataire)

N Pas de mise à jour

O Mise à jour automatique

W Mise à jour avec message d'avertissement

C Mise à jour avec demande de confirmation

Par défaut, ce sera l'identique du caractère 21

OBJET_DOCUMENT

21,23 Type de document

25,60 Objet du document pour le fax/mail

Exemple : Veuillez recevoir ci-joint votre réclamation client

TITRE_DOCUMENT

21,23 Type de document

25,60 Titre du document pour la fenêtre de gestion du fax/mail.

Celui-ci sera suivi de la mention N° et de la clé du document.

VALID_FAXMAIL_EDIT

21 Edition automatique (O/N, N par défaut) - Option Oxm obligatoire

O Lors de l'édition du document papier, les fax / mails correspondants seront déclarés comme étant à envoyer sans demande de confirmation.

N Lors de l'édition du document papier, l'utilisateur devra confirmer les fax / mails correspondants pour qu'ils passent au statut à envoyer.

VALID_FAXMAIL_REEDIT

21 Réédition automatique (O/N, N par défaut) - Option Oxm obligatoire

O Lors de la réédition du document papier, les fax / mails correspondants seront déclarés comme étant à renvoyer sans demande de confirmation.

N Lors de la réédition du document papier, l'utilisateur devra confirmer les fax / mails correspondants pour qu'ils passent au statut à renvoyer.

VALID_FAXMAIL_VALID

21 Edition automatique (O/N, N par défaut) - Option Oxm obligatoire - Explications

O Lors de l'édition du document papier, si les fax / mails correspondants sont déjà validés, ils seront déclarés comme étant à envoyer sans demande de confirmation.

N Lors de l'édition du document papier, si les fax / mails correspondants sont déjà validés, l'utilisateur devra les confirmer pour qu'ils passent au statut à envoyer.

Notes permettant de nommer les pièces jointes et de construire l'objet du mail

Ces notes peuvent être paramétrées

- sur le paramètre de lancement du programme d'envoi de fax / mail.

- sur le paramètre de lancement de l'édition VoluEdit

La pièce jointe est nommée par l'outil de gestion fax/email, et porte un nom (comme PSP00KLZ9XSPL0.pdf) qui peut rendre méfiant le destinataire du mail.

Pour pallier cet inconvénient, ces notes permettent de nommer la pièce jointe dans VoluPack.

Le nom de la pièce jointe se compose d'un préfixe (note PREFIX_DOCUMENT_xxx) suivi de la clé (note CLE_DOCUMENT_xxx).

Le préfixe est défini sur le paramètre de lancement de l'édition VoluEdit.

Il peut aussi être défini de façon générale sur le paramètre #CF ATL, pour l'ensemble des éditions.

Il est possible de remplacer la clé du document par une zone codifiée.

Par exemple, pour les envois d'accusé de réception, le client final préfère voir sa pièce jointe codifiée avec sa référence à lui.

Exemples

Veuillez trouver ci-joint l'accusé de réception N° xxxxxxxx

Veuillez trouver ci-joint le devis N° xxxxxxxx

Il est possible de paramétrer le texte sur le paramètre de lancement de la saisie de commande, de devis, … (écran à partir duquel on ouvrira la fenêtre de gestion des mails)

Le paramétrage se fait avec la note OBJET_DOCUMENT (voir plus haut).

Exemple

OBJET_DOCUMENT DEV Voici le document %CLE% qui sera remis.

DEV représente un des types de document, il se positionne en caractères 21 à 23.

Le code %CLE% sera remplacé par le numéro du document; si ce code est omis dans le texte, le numéro de document sera automatiquement inséré en fin de texte.

On peut aussi paramétrer le texte et des variables représentants des zones de tables (à l'identique de ce qui est fait pour la gestion des pièces jointes).

Le paramétrage (notes PREFIX_OBJET_xxx et CLE_OBJET_xxx) ne se fait pas sur le module qui génère l'enregistrement mail (car quasiment aucune donnée n'est saisie à ce moment), mais sur le lanceur de l'édition qui envoie le document vers le mail.

Remarque : dans la gestion des fax/mails, l'objet affiché est celui actuel, et ne représente pas forcément l'objet qui sera construit en final.

PREFIX_DOCUMENT_xxx

où xxx représente le type de document.

21,60 Préfixe du nom de la pièce jointe à construire.

Si cette note ne figure pas dans le paramètre de lancement de l'édition VoluEdit, elle sera recherchée dans le #CF ATL.

CLE_DOCUMENT_xxx

où xxx représente le type de document.

21,60 Codification des zones permettant de remplacer la clé du document par défaut

Type ACR Toutes les zones de cde1 sont disponibles.

Type BLV Toutes les zones de blv1 sont disponibles.

Type CDF ou CDA Toutes les zones de cdf1 sont disponibles.

Type DEV Toutes les zones de fle_2 sont disponibles. (Réservé aux devis multi-métiers et transformateur)

Type FAC Toutes les zones de fac0 sont disponibles.

Type OAT Toutes les zones de groupage_bl sont disponibles.

Type OEX Toutes les zones de cde1 et cde2 sont disponibles. (Réservé aux éditions voluedit_oex)

Type RCL Toutes les zones de reclamation sont disponibles.

Le caractère | (pipe) est le caractère de séparation de colonne.

Exemple

CLE_DOCUMENT_ACR ec_c1|-|ec_ref

Sera traduit par la valeur de ec_c1, - et la valeur de ec_ref soit

USI-ma_commande_personnelle

Remarque : les espaces seront remplacés par des _ (souligné).

On peut ajouter un using derrière la colonne. Il faut l'indiquer par le signe +

Exemple lc_lig+<<&

Fonctionne aussi pour les éditions VoluEdit sans utilisation de fax/mail (pour une imprimante de type PDF avec enregistrement automatique).

Si cette note ne figure pas dans le paramètre de lancement de l'édition VoluEdit, elle sera recherchée dans le #CF ATL.

PREFIX_OBJET_xxx

où xxx représente le type de document.

21,60 Préfixe de l'objet

CLE_OBJET_xxx

où xxx représente le type de document.

21,60 Zones de données à remplacer par leur valeur

Exemple

l2_devis| étui : | des_l2_code_prod

les zones l2_devis et des_l2_code_prod seront remplacées dans l'objet du mail par leurs valeurs.


Flag d'informations complémentaires

Ce paramétrage est opérationnel à partir de la V. 4.0.163.2

Il est utilisé par les programmes suivants :

Visualisation des tiers

Visualisation des articles

Visualisation des commandes clients

Génération des dossiers de fabrication

Visualisation des groupages

Visualisation du journal des BL

Visualisation du journal des ventes

Génération des factures d'avoir à partir des mouvements de stock

Edition VoluEdit des accusés de réception de commande client

But

Permettre de créer et/ou de modifier automatiquement des informations complémentaires sur un ou plusieurs éléments de chaque ligne de visualisation sélectionnée (article, qualité matière, client, fournisseur, adresse secondaire, commande, etc.)

Remarques

• Les informations complémentaires sont créées/mises à jour pour toutes les lignes sélectionnées dans la visualisation.

• Le paramétrage peut être défini
- soit directement sur le paramètre de lancement de la visualisation,
- soit sur un paramètre de configuration (permettant ainsi l'utilisation d'une même configuration pour plusieurs visualisations).

• Le type de clé ainsi que la clé sont définis sur le paramétrage.
Ce paramétrage est construit à partir des zones disponibles dans les visualisations.

Paramètre de configuration de la gestion des stocks

#CF STK A4[4]

Utilisation de la gestion des flag/deflag (O/N, N par défaut)

Notes sur le paramètre de lancement de chacun des programmes concernés (voir la liste en haut de page)

CF_MAJ_FLAG_INFO_C | 21,26 Type et code du paramètre de configuration de la mise à jour de flag d'informations complémentaires
MAJ_FLAG_INFO_C | 21,60 Paramétrage de création/mise à jour d’information complémentaire via les visualisations. Important : Si un paramètre de configuration est défini (note CF_MAJ_FLAG_INFO_C), celui-ci sera prioritaire. Le détail du paramétrage est indiqué ci-dessous.

Note sur le paramètre défini dans la note CF_MAJ_FLAG_INFO_C

MAJ_FLAG_INFO_C

21 Etat de mise à jour

F Flag (demande de transfert)

D Déflag (transfert)

22,24 Code du TSC à créer/mettre à jour

25 Type de clé de TSC

26,28 Valeur de flag/déflag (zone ic_char3_1)

29,60 Paramétrage de construction de la clé de TSC, encadré par des crochets [ ]

Ce paramétrage peut être complété sur les lignes suivantes, à partir du caractère 21 (voir annexe pour des exemples)

La façon de construire la clé doit correspondre au type de clé.

Exemples

Pour un type de clé C (commande)

[ec_num]

[lc_num|-|lc_lig+<<<<<]

Pour un type de clé A (article)

[lc_prod]

etc.

>>>>>>>>>>>>>>>> Voir aussi la note VAL_MAJ_FLAG_INFO_C sur le TSC

Paramétrage du TSC à mettre à jour (le TSC indiqué en caractères 22,24 de la note MAJ_FLAG_INFO_C)

A | ic_date1 | Date de la demande de transfert (flag)
C | ic_num1 | Heure de la demande de transfert (flag)
B | ic_date2 | Date de transfert (déflag)
D | ic_num2 | Heure de transfert (déflag)
F | ic_char3_1 | Valeur paramétrée du flag (exemple : ATR comme A TRaiter, T comme Traité, etc.)
G | ic_char30 | Valeur fixe définie en A4[1,30] du TSC. Cette zone optionnelle permet de faire des sélections rapides sur les informations complémentaires créées/mises à jour via ce fonctionnement (cette zone est indexée dans la base de données).

Exemples

MAJ_FLAG_INFO_C F_LIFA [cl_code]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur le tiers (adresse principale)

Le type de clé du TSC est F et la clé est Code client.

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LIFA [c2_code+C6|c2_adr]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur le tiers (adresses secondaires)

Le type de clé du TSC est F et la clé est Code client-Code adresse secondaire.

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LIAA [mp_code]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur l'article

Le type de clé du TSC est A et la clé est Code article.

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LIAA [mp_qualite_matiere]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la qualité matière rattachée à l'article

Le type de clé du TSC est A et la clé est Code qualité matière rattachée à l'article.

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LICA [lc_num|-|lc_lig+<<<<<]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la ligne de commande

Le type de clé du TSC est C et la clé est Numéro de commande-Ligne de commande (avec le format <<<<<).

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LICA [nc_num|-|nc_lig+<<<<<|-|nc_seq

MAJ_FLAG_INFO_C +<<<<<]

(Paramétrage sur 2 lignes, commençant en position 21 sur ligne 2).

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la séquence de commande

Le type de clé du TSC est C et la clé est Numéro de commande-Ligne de commande-ligne de commande (avec les formats <<<<<).

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C D_LIATRA[lc_prod]

Déflag (transfert)

Création/Mise à jour du TSC/_LI sur le produit de la ligne de commande

Le type de clé du TSC est A et la clé est Code produit de la ligne de commande.

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur TRA.

MAJ_FLAG_INFO_C F_LICA [lc_num|-|lc_lig+<<<<<]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la ligne de commande (OF)

Le type de clé du TSC est C et la clé est Numéro de commande-Ligne de commande (avec le format <<<<<).

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LICA [lc_cderat|-|lc_lcderat+<<<<<]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la ligne de commande rattachée

Le type de clé du TSC est C et la clé est Numéro de commande rattachée-Ligne de commande rattachée (avec le format <<<<<).

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.

MAJ_FLAG_INFO_C F_LICA [nc_num|-|nc_lig+<<<<<|-|nc_seq

MAJ_FLAG_INFO_C +<<<<<]

Flag (demande de transfert)

Création/Mise à jour du TSC/_LI sur la séquence de commande

Le type de clé du TSC est C et la clé est Numéro de commande-Ligne de commande-Ligne de commande (avec les formats <<<<<).

La première zone alphanumérique de 3 caractères sera renseignée avec la valeur A.


Accès à la GED

Permet d'accéder à la GED par l'appel d'un runprog de type WIN.

Notes

Les notes sont construites de la façon suivante :

PARAM_LCT_GED_xxx

(où xxx représente le type de document)

21,23 Type du paramètre (WIN)

24,26 Code du paramètre (ACH - ACR - BE - BL - FAC - FS - OF)

27,36 Préfixe du document (à mettre sur chaque type de GED) (uniquement dans f_visblfac_new (touche CTRL-F))

Note | Document | Accès à la GED depuis | Source
PARAM_LCT_GED_ACH | Commande d'achat | Accusés de réception Achats | f_visblfac_new
PARAM_LCT_GED_ARC | Accusé de réception | Interrogation et saisie de commande Visu de commande | cde / v_cdem f_visblfac_new
PARAM_LCT_GED_BE | Bordereau d'expédition | Expédition d'affrètement (entête) | exped_affretements
PARAM_LCT_GED_BL | Bon de livraison | Expédition d'affrètement (lignes) Visu BL/Factures | exped_affretements f_visblfac_new
PARAM_LCT_GED_FAC | Facture | Visu BL/Factures | f_visblfac_new
PARAM_LCT_GED_FS | Fiche suiveuse | Fiche matière Devis Nomenclature commande | mat don f_visunomenclature
PARAM_LCT_GED_OF | Ordre de fabrication | Nomenclature commande Saisie extrudeuse Saisie rapport transfo Saisie laboratoire | f_visunomenclature fab_ond_saisie sjs labo


: Dans ce deuxième cas, étant donné que le contrôle est fait par rapport à l'article par défaut, ce paramétrage sera effectif quelque soit le paramètre de lancement par lequel on exécute le programme de saisie des articles.

Si l'on veut que le contrôle soit différent selon le paramètre de lancement, on ne créera pas une note de type #CC sur l'article 000000000000000, mais on créera plusieurs entrées au menu, et, pour chaque entrée, on paramètrera une note commençant par #CC sur le paramètre de lancement du programme de saisie des articles (mat).

Contrôle de la saisie des champs - Généralités (notes #CC)

La saisie des champs peut être contrôlée à différents niveaux dans les applications VoluPack / VoluPrim.

Les niveaux de contrôle sont parfois hiérarchisés (pour la fiche article et la fiche tiers) : on recherche d'abord les contrôles au niveau le plus fin pour terminer par le niveau le plus large.

Par exemple, pour les articles, on recherche les contrôles dans cet ordre de priorité :

- sur la famille

- si non trouvé : sur l'article par défaut de la famille

- si non trouvé : sur l'article par défaut du type d'article

- si non trouvé : sur l'article par défaut

- si non trouvé : sur le paramètre de lancement du programme de saisie des articles

- si non trouvé : pas de contrôle sur ce champ

Selon le niveau de contrôle, le paramétrage se fera via des notes commençant par #CC ou via des notes de type #CC.

Exemple pour rendre obligatoire le code AFNOR dans la saisie des articles :

A) Si l'on veut que ce contrôle ne porte que sur les articles appartenant à telle famille, on créera, sur la famille concernée, une note commençant par #CC :
#CC mp_afnor          B
Bien entendu, cette ligne de note pourra être répétée autant de fois que de familles concernées, s'il y en a plusieurs.

B) Si l'on veut que ce contrôle porte globalement sur tous les articles, on créera, sur l'article par défaut (000000000000000), une note de type #CC (NTS #CC), sur laquelle on indiquera le paramétrage suivant, à partir du premier caractère :
mp_afnor          B
En savoir plus

Liste des programmes permettant des contrôles de champs :

Fiche tiers | 3 niveaux
Fiche article | 5 niveaux
Compositions | compo
Devis multi-métiers | devis_standard
Commandes clients | TYC (ATTENTION ! Il y a des notes #CC et #CC_)
Génération de produits finis | #CF GPF
Aide à la saisie des groupages | aide_saisie_groupages
Bons de livraison | blv
Factures fournisseurs | facf
Bons de retour | TBR


Gestion des ensembles montés à l'extérieur

Ce paramétrage vaut uniquement pour les onduleurs.

Paramétrage

TYC CD2 A4[30] = O (oui) : Permet d'initialiser le lieu de destination des FBI générées comme étant le lieu de départ de la livraison de l'ensemble.

TYC FBI A1[3] = R Générer le mouvement de livraison prévue de l'usine vers le magasin de montage

TYC FBI A1[36] = P Générer le mouvement de fabrication prévue dans l'usine

TYC FBI A2[4,6] = LP Type du mouvement de livraison prévue de l'usine vers le magasin de montage

TYC FBI A2[7,9] = TS Type du mouvement de stock de sortie de l'usine généré par le BL de transfert

TYC FBI A2[13,15] = FP Type du mouvement de fabrication prévue dans l'usine

TYC FBI A2[22,24] = TE Type du mouvement de stock d'entrée dans le magasin de montage généré par le BL de transfert

TYC FBI A3[59] = O Permet la livraison des FBI générées à partir d'un ensemble monté extérieur

TYC FBI A3[60] = O Permet la livraison des FBI générées avec un magasin de montage

RG1 MAG A1[12] = 1 Permet de spécifier que le magasin MAG correspond à l'usine et qu'il n'est pas un magasin de sous-traitance.

RG1 MAG A1[12] = 4 Permet de spécifier que le magasin MON (magasin de montage) est un magasin de sous-traitance.

Procédure à suivre

1. Saisir la commande commerciale sur l'ensemble monté à l'extérieur

a. Si le magasin de montage n'est pas celui spécifié sur l'ensemble, on peut le modifier par l'action Lieu rangement (Shift + F10)

b. Il NE faut PAS saisir le lieu intermédiaire de la revue de contrat sauf si vous souhaitez déplacer le stock de l'ensemble monté avant de livrer le client.

2. Editer l'AR de la commande pour générer les FBI

3. Générer les OF de production

4. Saisir la production des éléments de l'ensemble sur chaque FBI

5. Livrer chaque élément nécessaire au montage sur le magasin via la gestion des affrètements

6. Saisir le montage sur le magasin extérieur

7. Livrer le client à partir du magasin via la gestion des affrètements


Paramétrage de la saisie simplifiée d'articles

Exemple 1

CODIF_ART*mp_fam*

CODIF_ART*mp_sfm*

CODIF_ART*folio**99*3*

Le code article sera composé :

- du code famille

- du code sous-famille

- d'un compteur à 3 chiffres

La racine étant de longueur variable (99), le compteur vient immédiatement après la racine.

Si le code famille est AB et que le code sous-famille est CDE, les articles que vous pourrez créer porteront les codes ABCDE001 à ABCDE999.

Exemple 2

CODIF_ART*mp_fam*

CODIF_ART*mp_sfm*

CODIF_ART*folio**6*3*

Le code article sera composé :

- du code famille

- du code sous-famille

- d'un compteur à 3 chiffres

La racine étant de longueur fixe (6), elle est complétée par des 0 à sa droite si elle fait moins de 6 caractères.

La racine est donc ABCDE0. Le compteur vient à la suite de cette racine.

Si le code famille est AB et que le code sous-famille est CDE, les articles que vous pourrez créer porteront les codes ABCDE0001 à ABCDE0999.

Exemple 3

CODIF_ART*mp_mp*

CODIF_ART*valeur*-*

CODIF_ART*mp_fam*

CODIF_ART*valeur*/*

CODIF_ART*folio**99*4*

Le code article sera composé :

du type d'article suivi d'un tiret

du code famille suivi d'une barre de fraction

d'un compteur à 4 chiffres

Si le type d'article est P et que code famille est AB, les articles que vous pourrez créer porteront les codes P-AB/0001 à P-AB/9999.

Exemple 4

CODIF_ART*valeur*PS* Valeur fixe : PS

CODIF_ART*mp_cli**2*6* Caractères 2 à 6 du code client saisi

CODIF_ART*valeur*-* Valeur fixe : -

CODIF_ART*folio**99*7* Folioteur de 7 caractères, avec racine de longueur variable

Si le code client est C31301, le code produit construit sera PS31301-0000001

Exemple 5

CODIF_ART*valeur*PS*

CODIF_ART*mp_cli**2*6*

CODIF_ART*valeur*-*

CODIF_ART*mp_cs1**1*1*

CODIF_ART*valeur*-*

CODIF_ART*folio**99*5*

Si le code client est C31301 et le code statistique 1 est 41, le code produit construit sera PS31301-4-00001

Exemple 6

CODIF_ART*valeur*PS* Valeur fixe : PS

CODIF_ART*mp_foucli**2*6* Caractères 2 à 6 du code fournisseur chez le client saisi

CODIF_ART*valeur*-* Valeur fixe : -

CODIF_ART*TSC_MP_FC_CS2_F**** Valeur de la zone F du TSC CS2 saisi sur le code fournisseur chez le client du produit

CODIF_ART*valeur*-* Valeur fixe : -

CODIF_ART*folio**99*3* Folioteur de 3 caractères, avec racine de longueur variable

Résultat

Si le code fournisseur chez le client est F07471 et la première zone alphanumérique du TSC CS2 saisi sur ce dernier contient la valeur AGH, le code produit construit sera PS07471-AGH-001.

Fin des exemples

Construction d'une désignation de la forme : PALETTE [Longueur] X [Largeur]

CODIF_DES*valeur*PALETTE*1* | Valeur PALETTE suivie d'un espace
CODIF_DES*mp_lon****<<<<&* | Longueur sous la forme 99999 calée à gauche
CODIF_DES*valeur**1* | Espace
CODIF_DES*valeur*X*1* | Valeur X suivie d'un espace
CODIF_DES*mp_lar****<<<<&* | Largeur sous la forme 99999 calée à gauche
CODIF_DES*TSC_MP_AA_290_F****<<<<&* | Zone F (ic_char3_1) du TSC 290 saisie sur l'article en cours

Remarque - Les lignes suivantes :

CODIF_DES*valeur**1* | Espace
CODIF_DES*valeur*X*1* | Valeur X suivie d'un espace

peuvent aussi s'écrire :

CODIF_DES*valeur* X*1*

Espace suivi de la valeur X suivie d'un espace

Permettre d'afficher et de saisir les libellés étrangers (référence client, libellés spécifiques 1 et 2) du client (mat.mp_cli) ou fournisseur principal (mat.mp_foucli) du produit en cours de saisie (selon l'option –Oef).

IMPORTANT : Seul le libellé étranger du client ou fournisseur principal est saisissable.

Le code langue est récupéré sur la fiche du client ou fournisseur principal.

Pour saisir des libellés étrangers pour une autre langue ou pour un autre fournisseur ou client, utiliser la fonction habituelle (F24).

Remarque : L'utilisation des libellés étrangers dans le tableau de détail est incompatible avec l'ouverture automatique de la saisie des libellés étrangers (Note FAMF24 sur le paramétrage de la famille (FAM) du produit en cours de saisie).

1. COL_ART*Grammage du complexe :*mp_poids****

2. COL_ART*Couleur :*TSC_FRO_F*COU***

3. COL_ART*Laize exacte possible:*TSC_FRO_H*O/N***

4. COL_ART*Conditionnement :*mp_cond****

5. COL_ART*Nbre de pages du cahier *TSC_B01_C**<<<<&*CAH*

Les numéros 1 à 5 précédant ces notes ne sont là qu'à titre de renvoi pour les explications qui suivent.

NE PAS les mettre sur vos lignes de notes !!!

Explications des exemples :

  1. On veut renseigner le grammage dans la zone mp_poids de la table mat.

  2. On veut renseigner la couleur dans la zone F du TSC FRO.
    La saisie assistée par F7 et les contrôles de saisie sont possibles, par rapport au paramètre de type COU.

  3. On veut indiquer, dans la zone H du TSC FRO, si la laize exacte est possible.
    La réponse est de type O/N (Oui / Non, affiché en clair).

  4. On veut renseigner le conditionnement dans la zone mp_cond de la table mat.
    La saisie assistée par F7 et les contrôles de saisie sont possibles, par rapport au paramètre de type CND, bien que ce type ne soit pas paramétré ici. Voir le § sur les contrôles automatiques.

  5. On veut renseigner le nombre de pages du cahier dans la zone C du TSC B01.Le format est précisé : <<<<&.
    Il s'agit d'un complément de saisie.

Contrôles automatiques

Certaines zones de la table mat sont automatiquement contrôlées :

Zone | Paramètre | Zone | Paramètre
mp_cond | CND | mp_reap | REA
mp_coul | COU | mp_rgt1 | RG1
mp_etat_bes | EBM | mp_tva | TVA
mp_fconv | FOR | mp_ua | UNI
mp_fconv2 | FOR | mp_uv | UNI
mp_gestionnaire | GES | mp_uvente | UNI
mp_qualite | QA |  |

D'autres zones prennent automatiquement le libellé correspondant :

Zone | Libellé
mp_afnor | des_mat(valeur)
mp_cdc | lib_ccout(valeur)
mp_cli | nom_cli(valeur)
mp_foucli | nom_cli(valeur)
mp_qualite_matiere | des_mat(valeur)
mp_remp | des_mat(valeur)
mp_suistk | Article (non) suivi en stock
mp_tval | P Valorisé au PAMP D Valorisé au dernier PA R Valorisé au prix de revient B Valorisé au prix de vente [blanc] Non valorisé

Paramétrage de la saisie simplifiée d'articles

Plus d'information sur l'utilisation et le paramétrage de la saisie simplifiée d'articles dans le document suivant : Fiche Article.pdf

Les notes commençant par CODIF_ART* et COL_ART* sont recherchées en priorité dans l'ordre suivant :

  1. au niveau de la sous-famille hiérarchique rattachée à la famille de type FAM

  2. au niveau de la sous-famille de type SFM

  3. au niveau de la famille de type FAM

  4. au niveau du paramètre de lancement du programme mat

Cet ordre de priorité de recherche vaut pour l'ensemble des notes.

Autrement dit, l'existence d'une seule note à un niveau suffit à arrêter la recherche.

Exemple : s'il existe des notes dans la sous-famille et dans la famille, seules celles de la sous-famille seront exploitées, celles de la famille seront ignorées.

Les notes commençant par #CC sont recherchées uniquement dans le paramètre où les notes CODIF_ART* et COL_ART* ont été trouvées et lues.

CODIF_ART*

L'option -Oaa doit être positionnée dans le paramètre de lancement du programme mat.

11 à 60 Codification de l'article pour la création du code en automatique.

La codification se fait sur 5 champs. Chaque champ doit être suivi d'un astérisque.

Définition des 5 champs :

1) Zones possibles :

mp_cli Code client principal

mp_code Code article

mp_cs1 Code statistique 1

mp_cs2 Code statistique 2

mp_cs3 Code statistique 3

mp_cs4 Code statistique 4

mp_date Date de création

mp_fam Famille

mp_foucli Code fournisseur chez le client

mp_mp Type d'article

mp_poids Poids (grammage) - utilisable avec using en position 5

mp_qualite_matiere Code qualité matière

mp_sfm Sous-famille

mp_z1 Zone libre alphanumérique de 15 car

mp_z2 Zone libre alphanumérique de 1 car.

mp_z3 Zone libre alphanumérique de 5 car.

mp_z4 Zone libre alphanumérique de 3 car.

mp_z5 Zone libre alphanumérique de 3 car

TSC_* Valeur d'un TSC, en utilisant la syntaxe habituelle (syntaxe 1)

le mot folio : le code contiendra un compteur (numérotation automatique).

le mot valeur : le code contiendra une valeur fixe (indiquée dans le champ 2).

2) Valeur fixe, si le champ 1 = valeur

3) Si champ 1 = folio : Longueur de la racine nécessaire au folioteur (99 pour une racine de longueur variable)
Si champ 1 = une zone surlignée : Caractère de début à prendre en compte

4) Si champ 1 = folio : Longueur du compteur
Si champ 1 = une zone surlignée : Caractère de fin à prendre en compte

5) Using paramétrable (exemple : <<<&)

Cliquez ici pour afficher / masquer les exemples.

Paramètres nécessaires : dans les paramètres FAM, SFM, sous-famille hiérarchique, CS1, CS2, CS3, CS4,

la note VALEUR_CODIF_ART se construit ainsi :

21,23 Valeur à mettre en place dans la codification du code article, en lieu et place du code paramètre

ATTENTION : La valeur forcée doit respecter les contraintes de la codification du code article (si dans la codification, on ne prend que le caractère 1 du code paramètre, la valeur forcée doit être composée de 1 caractère également).

Exemple de paramétrage sur le code statistique 1 de code 41(CS1/41)

Le paramétrage de codification décrit précédemment est utilisé.

VALEUR_CODIF_ART X

Lorsqu'un article est créé avec le code statistique 1 41, la valeur mise en place dans la codification de l'article sera X (et non 4).

Exemple de résultat avec le paramétrage de codification décrit précédemment (exemple 5) :

Si le code client est C31301 et le code statistique 1 est 41, le code produit construit sera :

PS31301-A-00001

ATTENTION ! Rappel : la taille maximale du code article est de 15 caractères.

CODIF_DES*

CODIF_DE2*

Création d'un nouvel article à partir de la recopie d'un article par défaut.

On peut construire automatiquement les désignations de l'article (mat.mp_des et mat.mp_des2) à partir des valeurs saisies.

Remarques :

• Les désignations sont créées automatiquement à la validation de l'article.

• Lorsque le paramétrage de construction automatique des désignations est activé, aucun contrôle de champ (#CC) n'est effectué sur les désignations.

Paramétrage du programme de saisie des articles :

Option Oss

Note CODE_ARTICLE_DEFAUT

11,60 Construction de la désignation pour la création en automatique

Champs séparés par des astérisques

1) Zones possibles :

• Toutes les zones de la fiche article

• Valeur d’une information complémentaire (TSC) suivant la syntaxe 1

• Mot-clé valeur : valeur fixe indiquée dans le champ 2)

2) Valeur fixe, si le champ 1) contient le mot-clé valeur

3) Si le champ 1) contient le mot clé valeur : Nombre d'espaces à insérer après la valeur

Si le champ 1) contient une autre valeur : Caractère de début à prendre en compte

4) Caractère de fin à prendre en compte

5) Using paramétrable

Cliquez ici pour afficher / masquer des exemples

Voir aussi

Création automatique de protections palettes et de tarifs

Saisie simplifiée des tarifs par plages de quantités

COL_ART*

L'option -Oss peut être positionnée dans le paramètre de lancement du programme mat.

Dans ce cas, les utilisateurs accèdent directement à la saisie simplifiée.

En absence de cette option, les utilisateurs accèdent d'abord à la saisie standard, puis à la saisie simplifiée en cliquant le bouton Saisie simplifiée dans la barre de menu en haut de la fenêtre.

9,60 Colonnes à afficher dans le tableau de saisie

Chacun des 6 champs doit être suivi d'un astérisque.

1) Libellé de la question

2) Zones possibles :

mp_* toutes les zones de la table mat

TSC_[code TSC]_[zone TSC] Information complémentaire

Les 3 zones suivantes concernent l'accès aux libellés étrangers du client ou fournisseur principal

le_libpar1 Référence chez le client ou fournisseur principal, dans la langue par défaut de ce dernier

le_libelle Libellé spécifique 1 du client ou fournisseur principal, dans la langue par défaut de ce dernier

le_libelle2 Libellé spécifique 2 du client ou fournisseur principal, dans la langue par défaut de ce dernier

3) Type de paramètre associé à la zone (pour aide et contrôle de la saisie)

Si zone = mp_param, inutilisé.

4) Format (using)

Si zone = mp_param, numéro de la donnée diverse

5) Code complément

6) Code langue à employer

Cliquez ici pour afficher / masquer des exemples.

Cliquez ici pour afficher / masquer les contrôles automatiques

Précision

Les sous-familles peuvent être enregistrées de 2 manières différentes :

  • Si vous avez peu de sous-familles, enregistrez-les comme paramètres de type SFM : ces sous-familles sont indépendantes et peuvent être rattachées à n'importe quelle famille.

  • Si vous avez un grand nombre de sous-familles et / ou que vous voulez les organiser par familles, vous pouvez les enregistrer dans leurs familles respectives.
    Comment ? Dans la saisie des paramètres, lorsqu'une famille (type FAM) est affichée à l'écran, un appui sur la touche F6 affiche un tableau dans lequel vous pouvez saisir des sous-familles.
    Dans ce cas, ces sous-familles appartiennent à cette famille uniquement (ce qui ne vous empêche pas de créer des sous-familles identiques sous d'autres familles).


Obligatoire si architecture automatique


Obligatoire si architecture étudiée


Obligatoire si présence de découpe


Obligatoire si présence de jonction


#CF GPF Annexe MAJ mat

Zones de la table mat (marquées d'un X) qui peuvent être mises à jour dans la génération de produits finis.

Ce tableau a été créé le 14/11/2003 - Surveiller les éventuelles évolutions de la table à partir de cette date.

Ce tableau est trié par ordre alphabétique de noms de zones.

mp_abc | X | Classement A/B/C
mp_affect | X | OF d'affectation par défaut
mp_afnor | X | Code normalisé
mp_alerte | X | Seuil d'alerte
mp_ana | X | Code analytique
mp_anu |  | Annulé (forcément à N)
mp_at1 | X | Donnée technique alpha 1
mp_at2 | X | Donnée technique alpha 2
mp_cdc | X | Centre de coût d'affectation par défaut
mp_cfrais | X | Taux de frais
mp_cli | X | Code client (principal)
mp_code |  | Code article (créé par CODIF_ART_)
mp_coefdiv_ffix | X | Coefficient diviseur de frais fixes
mp_cond | X | Code conditionnement
mp_controle | X | Code contrôle de qualité
mp_coul | X | Code couleur
mp_cperte | X | Taux de perte
mp_cpta | X | Compte d'achat
mp_cptv | X | Compte de vente
mp_cs1 |  | Code statistique 1
mp_cs2 |  | Code statistique 2
mp_cs3 |  | Code statistique 3
mp_cs4 |  | Code statistique 4
mp_date |  | Date de création
mp_delmoy | X | Délai moyen d'approvisionnement Fournisseur ou Fabrication
mp_derent |  | Date de dernière entrée en stock
mp_derinv |  | Date de dernier inventaire
mp_dermvt |  | Date dernier mouvement
mp_dersor |  | Date de dernière sortie de stock
mp_des | X | Désignation article
mp_devis |  | N° du devis générateur (automatique)
mp_dt1 | X | Donnée technique numérique 1
mp_dt2 | X | Donnée technique numérique 2
mp_dt3 | X | Donnée technique numérique 3
mp_dt4 | X | Donnée technique numérique 4
mp_dt5 | X | Donnée technique numérique 5
mp_dt6 | X | Donnée technique numérique 6
mp_dt7 | X | Donnée technique numérique 7
mp_dt8 | X | Donnée technique numérique 8
mp_entite |  | N° de l'entité génératrice (automatique)
mp_etat_bes |  | Etat des besoins matières
mp_fam | X | Code famille
mp_fconv | X | Code formule de conversion
mp_fconv2 | X | Formule de conversion
mp_foucli | X | Code fournisseur principal
mp_gencod | X | Code du GENCOD
mp_gestionnaire | X | Code gestionnaire
mp_hau | X | Hauteur
mp_itf14 | X | Code ITF14
mp_lar | X | Largeur
mp_libre | X | Zone libre (Utiliser comme Catégorie de produit)
mp_lon | X | Longueur
mp_marg | X | Taux de marge
mp_minfou | X | Minimum commande fournisseur (ou de fabrication)
mp_mp | X | Type article
mp_ndm |  | Numéro de dernier mouvement de stock
mp_pa | X | Prix d'achat
mp_pamp |  | Valeur du stock en prix d'achat moyen pondéré
mp_param | X | Paramétrage matière / produit
mp_poids | X | Poids
mp_pr | X | Prix de revient
mp_pr_fixe | X | Prix de revient fixe
mp_prod_generique | X | Article générique
mp_pv | X | Prix de vente
mp_pv2 | X | Prix de vente dans l'unité d'utilisation
mp_qteeco | X | Quantité économique de commande ou de fabrication
mp_qtemini_cdeclt |  | Quantité minimum pour commande client
mp_qualite | X | Qualificatif de l'article / Valide ou non valide
mp_qualite_matiere | X | Code qualité matière
mp_reap | X | Code réapprovisionnement (REA)
mp_remp | X | Code produit de remplacement
mp_rgt1 | X | Première zone de rangement
mp_rgt2 | X | Deuxième zone de rangement
mp_rgt3 | X | Troisième zone de rangement
mp_sbes |  | Besoins
mp_scdef |  | Stock en commande fournisseur et fabrication
mp_sdevis |  | N° du sous-devis générateur (automatique)
mp_sdisp |  | Stock disponible
mp_sfm | X | Code sous-famille
mp_site_prod |  | Site de production Tableau de bord du multisite
mp_smaxi | X | Stock maxi
mp_smini | X | Stock mini
mp_soc |  | Code société (automatiquement renseigné)
mp_sphy |  | Stock physique
mp_sres |  | Stock réservé
mp_ssim |  | Stock issu d'une simulation
mp_suistk |  | Suivi en stock (O/N)
mp_tva | X | Code TVA
mp_tval | X | Type de valorisation
mp_ua | X | Code unité d'achat
mp_uv | X | Code unité de vente
mp_uvente | X | Code 2ème unité de vente (spécifique)
mp_z1 | X | Zone libre
mp_z2 | X | Zone libre
mp_z3 | X | Zone libre
mp_z4 | X | Zone libre
mp_z5 | X | Zone libre


#CF GPF Champs mp mg

  • Les champs commençant par mp_ sont des champs de la table mat relatifs au produit de référence.

  • Les champs commençant par mg_ sont des champs de la table mat relatifs à la matière générique de l'entité du devis.


#CF TRA - Particularités de la traçabilité sur les formules

Les tables formules et formules2 sont systématiquement tracées en détail, même si aucun paramétrage ne l'indique.

Afin de faciliter la lecture de la traçabilité, certaines zones dans la table formule sont retraduites. Voir le tableau ci-dessous.

Zone dans la traçabilité | Zone correspondante dans la table | Caractères |  | Désignation
 |  | Déb. | Fin
ul_code_calc_v1_a | ul_parv1 | 1 | 9 | Code calcul et paramétrage V1, caractère a
ul_code_calc_v1_b | ul_parv1 | 10 | 18 | Code calcul et paramétrage V1, caractère b
ul_code_calc_v1_c | ul_parv1 | 19 | 27 | Code calcul et paramétrage V1, caractère c
ul_code_calc_v1_d | ul_parv1 | 28 | 36 | Code calcul et paramétrage V1, caractère d
ul_code_calc_v1_e | ul_parv1 | 37 | 45 | Code calcul et paramétrage V1, caractère e
ul_code_calc_v1_f | ul_parv1 | 46 | 54 | Code calcul et paramétrage V1, caractère f
ul_code_calc_v1_g | ul_parv1 | 55 | 63 | Code calcul et paramétrage V1, caractère g
ul_code_calc_v1_h | ul_parv1 | 64 | 72 | Code calcul et paramétrage V1, caractère h
ul_code_calc_v1_i | ul_parv1 | 73 | 81 | Code calcul et paramétrage V1, caractère i
ul_code_calc_v1_j | ul_parv1 | 82 | 90 | Code calcul et paramétrage V1, caractère j
ul_code_calc_v1_k | ul_par_cc_v1 | 1 | 9 | Code calcul et paramétrage V1, caractère k
ul_code_calc_v1_l | ul_par_cc_v1 | 10 | 18 | Code calcul et paramétrage V1, caractère l
ul_code_calc_v1_m | ul_par_cc_v1 | 19 | 27 | Code calcul et paramétrage V1, caractère m
ul_code_calc_v1_n | ul_par_cc_v1 | 28 | 36 | Code calcul et paramétrage V1, caractère n
ul_code_calc_v1_o | ul_par_cc_v1 | 37 | 45 | Code calcul et paramétrage V1, caractère o
ul_formule_v1 | ul_parv1 | 91 | 150 | Formule de quantité QT/1
ul_formule_v2 | ul_parv2 | 91 | 150 | Formule de quantité QT/2
ul_formule_v3 | ul_formules_v1 | 1 | 60 | Formule de quantité QT/3
ul_formule_v4 | ul_formules_v2 | 1 | 60 | Formule de quantité QT/4
ul_formule_v5 | ul_formules_v1 | 61 | 120 | Formule de quantité QT/5
ul_formule_v6 | ul_formules_v2 | 61 | 120 | Formule de quantité QT/6
ul_formule_v7 | ul_formules_v1 | 121 | 180 | Formule de quantité QT/7
ul_formule_v8 | ul_formules_v2 | 121 | 180 | Formule de quantité QT/8
ul_formule_v9 | ul_formules_v1 | 181 | 240 | Formule de quantité QT/9
ul_formule_v10 | ul_formules_v2 | 181 | 240 | Formule de quantité QT/10
ul_code_calc_v2_a | ul_parv2 | 1 | 9 | Code calcul et paramétrage V2, caractère a
ul_code_calc_v2_b | ul_parv2 | 10 | 18 | Code calcul et paramétrage V2, caractère b
ul_code_calc_v2_c | ul_parv2 | 19 | 27 | Code calcul et paramétrage V2, caractère c
ul_code_calc_v2_d | ul_parv2 | 28 | 36 | Code calcul et paramétrage V2, caractère d
ul_code_calc_v2_e | ul_parv2 | 37 | 45 | Code calcul et paramétrage V2, caractère e
ul_code_calc_v2_f | ul_parv2 | 46 | 54 | Code calcul et paramétrage V2, caractère f
ul_code_calc_v2_g | ul_parv2 | 55 | 63 | Code calcul et paramétrage V2, caractère g
ul_code_calc_v2_h | ul_parv2 | 64 | 72 | Code calcul et paramétrage V2, caractère h
ul_code_calc_v2_i | ul_parv2 | 73 | 81 | Code calcul et paramétrage V2, caractère i
ul_code_calc_v2_j | ul_parv2 | 82 | 90 | Code calcul et paramétrage V2, caractère j
ul_code_calc_v2_k | ul_par_cc_v2 | 1 | 9 | Code calcul et paramétrage V2, caractère k
ul_code_calc_v2_l | ul_par_cc_v2 | 10 | 18 | Code calcul et paramétrage V2, caractère l
ul_code_calc_v2_m | ul_par_cc_v2 | 19 | 27 | Code calcul et paramétrage V2, caractère m
ul_code_calc_v2_n | ul_par_cc_v2 | 28 | 36 | Code calcul et paramétrage V2, caractère n
ul_code_calc_v2_o | ul_par_cc_v2 | 37 | 45 | Code calcul et paramétrage V2, caractère o
ul_code_cadence_a | ul_parcad | 1 | 9 | Code calcul et paramétrage de cadence, caractère a
ul_code_cadence_b | ul_parcad | 10 | 18 | Code calcul et paramétrage de cadence, caractère b
ul_code_cadence_c | ul_parcad | 19 | 27 | Code calcul et paramétrage de cadence, caractère c
ul_code_cadence_d | ul_parcad | 28 | 36 | Code calcul et paramétrage de cadence, caractère d
ul_code_cadence_e | ul_parcad | 37 | 45 | Code calcul et paramétrage de cadence, caractère e
ul_code_cadence_f | ul_parcad | 46 | 54 | Code calcul et paramétrage de cadence, caractère f
ul_code_cadence_g | ul_parcad | 55 | 63 | Code calcul et paramétrage de cadence, caractère g
ul_code_cadence_h | ul_parcad | 64 | 72 | Code calcul et paramétrage de cadence, caractère h
ul_code_cadence_i | ul_parcad | 73 | 81 | Code calcul et paramétrage de cadence, caractère i
ul_code_cadence_j | ul_parcad | 82 | 90 | Code calcul et paramétrage de cadence, caractère j
ul_par_dep_alp_1 | ul_interprete | 1 | 9 | Dépendance alphanumérique 1
ul_par_dep_alp_2 | ul_interprete | 10 | 18 | Dépendance alphanumérique 2
ul_par_dep_alp_3 | ul_interprete | 19 | 27 | Dépendance alphanumérique 3
ul_par_dep_alp_4 | ul_interprete | 28 | 36 | Dépendance alphanumérique 4
ul_par_dep_num_1 | ul_interprete | 37 | 45 | Dépendance numérique 1
ul_par_dep_num_2 | ul_interprete | 46 | 54 | Dépendance numérique 2
ul_par_dep_num_3 | ul_libelle | 1 | 9 | Dépendance numérique 3
ul_par_dep_num_4 | ul_libelle | 10 | 18 | Dépendance numérique 4
ul_par_dep_qte | ul_libelle | 31 | 42 | Dépendance de quantité
ul_code_machine | ul_libelle | 43 | 48 | Code machine
ul_diff_machine | ul_libelle | 49 | 51 | Code difficulté associé à la machine
ul_par_dep_mac | ul_libelle | 52 | 60 | Code calcul et paramétrage de recherche de la machine


KSC Complément de paramétrage

Ce paramètre est opérationnel à partir de la V. 4.0.191.2

Il est utilisé par la note LCT_MULTI_COMPL_ du paramètre #RP.

Tous les scénarios existants à ce jour sont soumis à autorisation.

Permission de type MEN, mot clé : ACT00n (n représentant les codes actions de 1 à 7)

Valeur alpha 1

KSC A1[1] | Lors de la mise à jour du code produit, doit-on mettre à jour le code ensemble (O/N, N par défaut) (recherche dans la nomenclature avec un complément de requête paramétrable dans les notes)
KSC A1[2] | Doit-on ajouter un commentaire ? (O/N, N par défaut) Le commentaire peut-être paramétré dans les notes, sinon, on saisira un ligne de commentaire lors du traitement.
KSC A1[3,5] | Type de note dans la table mat3 pour le commentaire. Si non renseigné, devra être saisi lors du traitement.
KSC A1[6,8] | Position dans la table mat3 du commentaire à insérer. nn : numéro de ligne à partir duquel on insère (1, 2, …) (sert pour les commentaires formatés) FIN (par défaut) : on insère à la fin des notes existantes
KSC A1[9] | Type de formatage du commentaire. Aucun par défaut Un seul type de formatage est géré à ce jour. 1 La note est composée du libellé court de l'utilisateur, de la date et du commentaire. Exemple !----------!--------!--------------------------------------! ! Qui ? ! Date ! Commentaire ! !----------!--------!--------------------------------------!

Notes

CODE_ET_TYPE_APPLI | 21,26 Type et code du paramètre du lancement
COMMENTAIRE | 21,60 Commentaire qui sera inséré dans la table mat3 Si rien de paramétré, une saisie sera demandée.
CREER_BL | 21,26 Type et code paramètre pour la saisie de BL
_SUP_REQ_NOM0_ENS | 21,60 Supplément de requête sur la recherche du code ensemble dans la nomenclature (table nom0)
_SUP_REQ_RECH_QUAL | 21,60 Lors de la recherche du code qualité à utiliser pour le remplacement, on peut ajouter un complément de requête sur la table par02 afin d'en éliminer certains.

Exemple

1) Dans la visu des produits, créer les notes suivantes :

_CSEL

LCT_MULTI_TITRE_01 Modification qualité

LCT_MULTI_IMAGE_01 g_couleur

LCT_MULTI_PARAM_01 ACT001[mp_code]

LCT_MULTI_COMPL_01 001

2) Créer le paramètre KSC 001 (conformément à la note LCT_MULTI_COMPL_01 001 ci-dessus) :

Libellé long : Scénario 001 MAJ qualité

KSC A1[1] = O (mise à jour des ensembles associés)

KSC A1[2] = O (ajout d'une note)

KSC A1[3,5] = HIS (de type HIS)

KSC A1[6,8] = 4 (insertion de la note en ligne 4)

KSC A1[9] = 1 (formatage de type 1)

Notes du paramètre KSC 001 :

_SUP_REQ_RECH_QUAL and p2_code not in ("FAB")

_SUP_REQ_NOM0_ENS and n0_pcse like "R%"

COMMENTAIRE Passage de la validité de

COMMENTAIRE DEV (devis) à INA (inactif)

3) Résultat pour un PF (2 actions menées successivement, commentaires saisis) :

Consultation des notes fiche matière de type HIS :

!----------!--------!--------------------------------------!

! Qui ? ! Date ! Commentaire !

!----------!--------!--------------------------------------!

!BRAC Jean !10/05/11! Passage DEV --> BLO !

!BRAC Jean !11/05/11! Passage PF ABC* en DEV !


ccdd_di_2

Code calcul DI

Valeurs du caractère 2 si caractère 1 = 8, 9, A, B, C ou D

1 On prend comme première valeur la valeur calculée 1 (v1) (par défaut)

2 On prend comme première valeur la valeur calculée 2 (v2)

3 On prend comme première valeur la valeur calculée 3 (v3)

4 On prend comme première valeur la valeur calculée 4 (v4)

5 On prend comme première valeur la valeur calculée 5 (v5)

6 On prend comme première valeur la valeur calculée 6 (v6)

7 On prend comme première valeur la valeur calculée 7 (v7)

8 On prend comme première valeur la valeur calculée 8 (v8)

9 On prend comme première valeur la valeur calculée 9 (v9)

0 On prend comme première valeur la valeur calculée 10 (v10)


ccdd_di_3

Code calcul DI

Valeurs du caractère 3 si caractère 1 = 8, 9, A, B, C ou D

1 On prend comme deuxième valeur la valeur calculée 1 (v1)

2 On prend comme deuxième valeur la valeur calculée 2 (v2) (par défaut)

3 On prend comme deuxième valeur la valeur calculée 3 (v3)

4 On prend comme deuxième valeur la valeur calculée 4 (v4)

5 On prend comme deuxième valeur la valeur calculée 5 (v5)

6 On prend comme deuxième valeur la valeur calculée 6 (v6)

7 On prend comme deuxième valeur la valeur calculée 7 (v7)

8 On prend comme deuxième valeur la valeur calculée 8 (v8)

9 On prend comme deuxième valeur la valeur calculée 9 (v9)

0 On prend comme deuxième valeur la valeur calculée 10 (v10)


ccdd_qt_3_1

Code calcul QT

Valeurs du caractère 3 si caractères 1 et 2 = 9 ou 12

[espace] On prend comme diviseur la valeur calculée 1 (v1)

2 On prend comme diviseur la valeur calculée 2 (v2)

3 On prend comme diviseur la valeur calculée 3 (v3)

4 On prend comme diviseur la valeur calculée 4 (v4)

5 On prend comme diviseur la valeur calculée 5 (v5)

6 On prend comme diviseur la valeur calculée 6 (v6)

7 On prend comme diviseur la valeur calculée 7 (v7)

8 On prend comme diviseur la valeur calculée 8 (v8)

9 On prend comme diviseur la valeur calculée 9 (v9)

0 On prend comme diviseur la valeur calculée 10 (v10)


ccdd_qt_3_2

Code calcul QT

Valeurs du caractère 3 si caractères 1 et 2 =11, 14, 17, 18, 19 ou 20

1 On prend comme diviseur la valeur calculée 1 (v1) (par défaut)

2 On prend comme diviseur la valeur calculée 2 (v2)

3 On prend comme diviseur la valeur calculée 3 (v3)

4 On prend comme diviseur la valeur calculée 4 (v4)

5 On prend comme diviseur la valeur calculée 5 (v5)

6 On prend comme diviseur la valeur calculée 6 (v6)

7 On prend comme diviseur la valeur calculée 7 (v7)

8 On prend comme diviseur la valeur calculée 8 (v8)

9 On prend comme diviseur la valeur calculée 9 (v9)

0 On prend comme diviseur la valeur calculée 10 (v10)


ccdd_qt_5_1

Code calcul QT

Valeurs du caractère 5 si caractères 1 et 2 =11, 14, 17, 18, 19 ou 20

1 On prend comme diviseur la valeur calculée 1 (v1)

2 On prend comme diviseur la valeur calculée 2 (v2) (par défaut)

3 On prend comme diviseur la valeur calculée 3 (v3)

4 On prend comme diviseur la valeur calculée 4 (v4)

5 On prend comme diviseur la valeur calculée 5 (v5)

6 On prend comme diviseur la valeur calculée 6 (v6)

7 On prend comme diviseur la valeur calculée 7 (v7)

8 On prend comme diviseur la valeur calculée 8 (v8)

9 On prend comme diviseur la valeur calculée 9 (v9)

0 On prend comme diviseur la valeur calculée 10 (v10)


ccdd_qt_5_2

Code calcul QT

Valeurs du caractère 5 si caractères 1 et 2 =21 ou 22

1 On prend comme diviseur la valeur calculée 1 (v1) (par défaut)

2 On prend comme diviseur la valeur calculée 2 (v2)

3 On prend comme diviseur la valeur calculée 3 (v3)

4 On prend comme diviseur la valeur calculée 4 (v4)

5 On prend comme diviseur la valeur calculée 5 (v5)

6 On prend comme diviseur la valeur calculée 6 (v6)

7 On prend comme diviseur la valeur calculée 7 (v7)

8 On prend comme diviseur la valeur calculée 8 (v8)

9 On prend comme diviseur la valeur calculée 9 (v9)

0 On prend comme diviseur la valeur calculée 10 (v10)


ccdd_qt_6

Code calcul QT

Valeurs du caractère 6 si caractères 1 et 2 =21 ou 22

1 On prend comme diviseur la valeur calculée 1 (v1)

2 On prend comme diviseur la valeur calculée 2 (v2) (par défaut)

3 On prend comme diviseur la valeur calculée 3 (v3)

4 On prend comme diviseur la valeur calculée 4 (v4)

5 On prend comme diviseur la valeur calculée 5 (v5)

6 On prend comme diviseur la valeur calculée 6 (v6)

7 On prend comme diviseur la valeur calculée 7 (v7)

8 On prend comme diviseur la valeur calculée 8 (v8)

9 On prend comme diviseur la valeur calculée 9 (v9)

0 On prend comme diviseur la valeur calculée 10 (v10)


Affichage de tarifs

Cet ensemble de notes permet d'afficher sur chaque ligne de visualisation divers tarifs que l'on peut paramétrer librement.

Initialement dédié à la visualisation d'articles.

Utilisation étendue à la visualisation des stocks par lots / lieux.

Dans toutes ces notes, XX peut être remplacé par les valeurs comprises entre 01 et 99.

On peut ensuite utiliser les variables TAR_XX.

_TAR_XX_CONFIG | 21,26 Type et code du paramètre de recherche de tarifs - Obligatoire 28 Valeur retenue par la recherche de tarifs M Valeur maximale m Valeur minimale D Dernier trouvé P Premier trouvé V Valeur par défaut mini (m) Y Maxi (M) + mini (m) / 2
_TAR_XX_CODE_TAR | 21,23 Code du tarif recherché - Obligatoire
_TAR_XX_TIERS | 21,60 Tiers du tarif recherché - Obligatoire Valeurs possibles : mp_cli (client de l'article) mp_foucli (fournisseur de l'article) code d'un client existant
_TAR_XX_DATE | 21,60 Date du tarif recherché - Obligatoire
_TAR_XX_QTE | 21,60 Quantité du tarif recherché - Obligatoire Valeurs possibles : mp_qteeco (Quantité économique de commande ou de fabrication) quantité brute
_TAR_XX_COMP_SEL | 21,60 Complément de sélection pour la recherche de tarif
_TAR_XX_SITE | 21,60 Site à utiliser pour la recherche de tarif Valeurs possibles : use_site (site de l'utilisateur) code d'un site existant
_TAR_XX_DEFAUT | 21,60 Valeur par défaut affichée si la recherche de tarif retourne une valeur nulle : mp_pa (Prix d'achat de l'article) mp_pv (Prix de vente de l'article) mp_pr (Prix de revient de l'article)


Aide à la saisie des OF

Aide de type 1

Utilisé dans le suivi de production simplifié où il y a par dossier une ligne de commande et une entité de fabrication (soit un OF à un niveau seulement)

Ajoute en automatique -1/1 au numéro passé en paramètre.

Le traitement n'est effectué que s'il ne figure aucun tiret, aucun slash et aucun point dans ledit numéro.

Ce type d'aide ajoute également les zéros manquants dans le numéro.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1/1
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1/1
91050001-1 | 91050001-1

Aide de type 2

Ajoute en automatique les zéros manquants.

Ce paramétrage doit être utilisé dans toutes les saisies de numérotation. (let numero = aide_of(numero, 2))

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1/1
91050001-1 | 91050001-1

Aide de type 3

Ajoute en automatique les zéros manquants et -1 (s'il n'y a pas de -2 par exemple)

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1
91050001-1 | 91050001-1
910500012 | 91050001-2
91051-2 | 91050001-2

Aide de type 4

Ajoute en automatique les zéros manquants, le tiret manquant et le slash manquant.

Attention, il ne doit y avoir qu'un chiffre entre le tiret et le slash.

On met un slash avant le dernier chiffre saisi et un tiret avant l'avant dernier chiffre saisi.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050000-1/3
9105123 | 91050001-2/3

Aide de type 5

Ajoute en automatique des zéros devant le numéro.

Aide de type 6

La saisie se fait sur la référence de la commande + le numéro de ligne.

La recherche est forcée avec le client #SOC.

Exemples

Numéro saisi | Numéro retourné
1755.9703-1 | 97040001-1/3

Aide de type 7

Ajoute en automatique les zéros manquants et -1.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1/99
91051-1 | 91050001-1/99
91050001 | 91050001-1/99
91050001-1 | 91050001-1/99

Aide de type 8

Ajoute 0 devant le numéro de ligne et éventuellement du tiret si celui-ci est manquant.

Exemples

Numéro saisi | Numéro retourné
051028691 | 05102869-001
05102869-1 | 05102869-001
05102869-01 | 05102869-001


Codes calcul des schémas de calcul

Les codes calcul suivants sont reconnus pour les barèmes au niveau de la ligne de commande client. Voir les caractères 10 à 18 dans la note COR du paramètre DPC.

DI Dimension

EL Elément technique

QT Quantité

TC TSC

Facteur multiplicateur à appliquer au résultat

Non valable pour tous les codes calcul

Le caractère 5 indique l'opération à effectuer.

Type | Caractère 5 | Opération
Numérique | * ou [espace] | On multiplie le résultat par le coefficient
Numérique | / | On divise le résultat par le coefficient
Numérique | + | On ajoute le coefficient au résultat
Numérique | - | On soustrait le coefficient au résultat
Numérique | < | On arrondit à l'entier le plus proche
Numérique | > | On arrondit à l'entier supérieur
Numérique | D | On prend la partie décimale
Numérique | E | On prend la valeur entière
Numérique | B | On retourne un Booléen (1 si >=1) (0 si <1)
Numérique | b | On retourne un Booléen (1 si >1) (0 si <=1)
Numérique | C | On retourne un Booléen (1 si <=1) (0 si >1)
Numérique | c | On retourne un Booléen (1 si <1) (0 si >=1)
Alphanumérique | O | On retourne un Booléen (1 si = "O") (0 sinon)
Alphanumérique | N | On retourne un Booléen (1 si = "N") (0 sinon)

Le caractère 6 permet de définir un facteur multiplicateur à appliquer au résultat, si la zone est numérique.

Caractère 6 | Coefficient
0 ou [espace] | 1
1 | 10
2 | 100
3 | 1000

Code calcul DI - Dimension

RETOUR NUMERIQUE

Caractère 1

H Hauteur de la ligne de commande

L Longueur de la ligne de commande

l Largeur de la ligne de commande

A Hauteur de l'article de la ligne de commande

B Longueur de l'article de la ligne de commande

C Largeur de l'article de la ligne de commande

1 Valeur 1

2 Valeur 2

3 Valeur 1 * Valeur 2

4 Valeur 1 / Valeur 2

5 Valeur 1 + Valeur 2

6 Valeur 1 - Valeur 2

7 Maxi (Valeur 1, Valeur 2)

8 Mini (Valeur 1, Valeur 2)

Code calcul EL - Elément technique

Caractères 1 à 3

Code de l'élément technique (Exemple MA)

Caractères 4 à 6

Code du détail de prix DPC (Exemple IRT)

Si non renseigné : DPC courant

Caractère 7

Type de la zone retournée

RETOUR NUMERIQUE

[espace] Valeur de l'élément technique si type de zone de l'élément technique à N

A Hauteur du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

B Longueur du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

C Largeur du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

D Poids du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

E Donnée technique 1 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

F Donnée technique 2 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

G Donnée technique 3 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

H Donnée technique 4 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

I Donnée technique 5 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

J Donnée technique 6 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

K Donnée technique 7 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

L Donnée technique 8 du code matière si type de contrôle de l'élément technique à 02 ou 06 ou 07 (Code article)

M Valeur numérique 1 du code paramètre si type de contrôle de l'élément technique à 01 (Code paramètre)

N Valeur numérique 2 du code paramètre si type de contrôle de l'élément technique à 01 (Code paramètre)

RETOUR ALPHANUMERIQUE

[espace]Valeur de l'élément technique si type de zone de l'élément technique à A

Code calcul QT - Quantité

RETOUR NUMERIQUE

Caractères 1 et 2

0 0

1 1

2 Quantité commandée

3 Quantité lancée

B Quantité détail de prix

Code calcul TC - TSC

Caractère 1 | Type du TSC 1 Client de la commande 2 Article de la ligne de commande
Caractères 2 à 4 | Code TSC
Caractère 5 | Code de la zone de stockage C Valeur numérique 1 D Valeur numérique 2 E Valeur numérique 3 F Char3-1 (voir car.6 si numérique) G Char30 (voir car.6 si numérique) H Char3-2 (voir car.6 si numérique)
Caractère 6 | Autres rubriques 1 Valeur numérique 1 si car.5 = F, G ou H (F, G et H dans ce cas existent comme paramètres) 2 Valeur numérique 2 si car.5 = F, G ou H (F, G et H dans ce cas existent comme paramètres)


Contrôle des champs dans la fiche article

Voir aussi : page récapitulative sur les contrôles de champs.

Le contrôle des champs est paramétrable à 4 niveaux, définis ci-dessous par ordre de priorité :

Niveau | Note commençant par #CC ou notes de type #CC | Exemple
A | sur les notes commençant par #CC sur la famille | On recherche les notes commençant par #CC sur le paramètre FAM CAI (pour les caisses).
B | sur les notes de type #CC sur l'article par défaut de la famille | On recherche les notes de type #CC sur l'article 000000000000CAI (pour les caisses).
C | sur les notes de type #CC sur l'article par défaut du type d'article | On recherche les notes de type #CC sur l'article 00000000000000P pour les produits finis, 00000000000000M pour les matières, etc.
D | sur les notes de type #CC sur l'article par défaut | On recherche les notes de type #CC sur l'article 000000000000000.

ATTENTION : Pour la saisie simplifiée, les notes commençant par #CC sont recherchées uniquement dans le paramètre où les notes CODIF_ART* et COL_ART* ont été trouvées et lues.

Selon qu'il s'agit de notes commençant par #CC (niveaux A/E) ou de notes de type #CC (niveaux B/C/D), la position des paramètres change comme l'indique le tableau ci-après :

Position des paramètres

Objet

Niveau A

Niveaux B/C/D

5,22

1,18

Tous les champs de la table mat. (Exemple : mp_code, mp_fam, etc ...)

23

19

Type de contrôle de saisie :

N Pas de contrôle (par défaut)

W Warning (avertissement non bloquant si la zone n'est pas saisie)

B Bloquant (saisie obligatoire)

I Interdit (on ne doit rien saisir dans ce champ)

V Avertissement si valeur modifiée (l'ancienne valeur est restaurée) (uniquement en saisie simplifiée)

C Consultation (le curseur ne passe pas sur le champ)

M Masquer (Le champ et son label ne sont pas affichés)
Mis en place uniquement pour les champs de quantité de stock de l’onglet général.

24

20

Génération d'une trace dans la table evt_trans pour le transfert en comptabilité (trace type T).

O Toute modification de ce champ (ou création pour le champ mp_code) entraîne une trace. La valeur O est imposée.

N On ne garde aucune trace des modifications de ce champ (valeur par défaut).

25

21

Valeur zéro significative - uniquement pour les valeurs numériques

O Oui. Le zéro est significatif

N Non. Le zéro n'est pas significatif (considéré comme valeur nulle) (par défaut)


Contrôle des champs dans le devis multi-métiers

Contrôle de la saisie des champs dans le devis multi-métiers

Voir aussi : page récapitulative sur les contrôles de champs.

Evolution de la V. 4.1.41.2 au 18/09/2013

Dans le devis multi-métiers, les notes #CC permettant de contrôler, interdire ou masquer des champs, peuvent désormais être paramétrées au niveau des paramètres TPI, TEN et TPRI.

Sur les divers écrans du programme devis_standard, la gestion des champs dépendra donc :

- des types de passage d'impression (TPI),

- des types d'entités (TEN),

- des types de processus/produits (TPR).

Si des notes #CC sont saisies sur un même champ à plusieurs endroits, la priorité se fera dans l'ordre suivant :

1. Paramètre TPI (plus haute priorité)

2. Paramètre TEN

3. Paramètre TPR

4. Paramètre de lancement du devis multi-métiers (plus basse priorité)

A noter que pour l'écran d'entête, seuls les #CC saisis dans les notes du paramètre de lancement et/ou du paramètre TPR (si connu) sont pris en compte étant donné que les types d'entité et de passage d'impression ne sont pas encore connus.

Notes

#CC

Paramétrage du contrôle de la saisie des champs

5,10 Code écran où les contrôles seront effectués

BOIPLI Entité boite pliante

ENTETE Ecran de saisie de l'entête du devis (premier écran)

ENTITE Ecran de saisie des informations générales de l'entité (deuxième écran, partie supérieure)

ETIBOB Entité étiquette bobine

FEUDEP Entité feuillet/dépliant

FLE_MAR Ecran de saisie du tableau des marges

FLE_REC Ecran du récapitulatif de prix

LIGIMP Saisie des lignes multiples d'impression

NIVDET Détail de saisie de la nomenclature

NIVLIG Tableau de saisie de la nomenclature

NIVREF Onglet de saisie des références multiples de la saisie de la nomenclature

REFDET Détail de saisie des références multiples (partie inférieure)

REFLIG Tableau de saisie des références multiples (partie supérieure)

SAILCO Entité de saisie des LCO

TRFCAR Ecran de saisie des informations techniques de l'entité transformateur cartonnier (2ème écran, partie inférieure)

VARIANTES Ecran de saisie des variantes de quantité/qualité

VARLIG Nouvel écran de récapitulatif des prix

21,38 Nom du champ sur lequel le contrôle s'effectue (voir la liste sous ce tableau)

et/ou Nom du champ sur lequel mettre en place la valeur par défaut

39 Type de contrôle à effectuer

N Pas de contrôle (par défaut)

W Le champ doit être saisi (anomalie non bloquante)

B Le champ doit être saisi (anomalie bloquante)

I Le champ n'est pas accessible en saisie

M Le champ est masqué

40 Le zéro est-il significatif pour une zone numérique ?

O Le zéro est considéré comme une saisie correcte.

N Le zéro est considéré comme une saisie incorrecte (équivalent à aucune saisie) (par défaut).

41,60 Valeur par défaut à mettre en place sur le champ

Inutilisé si code écran = VARLIG.

Uniquement si les 3 conditions suivantes sont réunies :

- on est en saisie des lignes d'impression multiple (LIGIMP),

- on est en création,

- le champ ne contient aucune valeur.

Liste des champs compatibles

fco_bascule Présence de bascule

fco_cgt_r_rv Nombre de repiquages

fco_cgt_rv Nombre de changements de plaques

fco_cgt_teinte_rv Nombre de changements de teintes

fco_couleur_rv Nombre de couleurs

fco_enc_rv Pourcentage d'encrage

fco_mac_forcee_rv Présence de machine forcée

fco_mac_imp Code machine d'impression

fco_nb_cl_commune Nombre de couleurs communes

fco_nb_teintes_rv Nombre de recherche de teintes

fco_pr_rv Nombre de couleurs primaires

fco_quadri_rv Présence de quadrichromie

fco_recto_verso Recto/Verso

fco_type_vernis_r Type de vernis

fco_ve_recto Pourcentage de vernissage

vernis_multiple Présence de vernis multiple

Liste des champs contrôlables dans la note #CC_

Les écrans et les champs sont triés par ordre alphabétique.

BOIPLI - ENTETE - ENTITE - ETIBOB - FEUDEP - LIGIMP - NIVDET - NIVLIG - NIVREF - REFDET - REFLIG - SAILCO - TRFCAR - VARLIG

BOIPLI

Nom du champ | Désignation | Type de données
fi_accessoires | Présence d'accessoires | Alphanumérique
fi_bat | Présence du client au bon à tirer | Alphanumérique
fi_c_papier | Code papier | Alphanumérique
fi_cgt_r | Nombre de changements de plaque au recto | Numérique
fi_cgt_teinte_r | Nombre de changements de teintes au recto | Numérique
fi_cgt_teinte_v | Nombre de changements de teintes au verso | Numérique
fi_cgt_v | Nombre de changements de plaque au verso | Numérique
fi_co_recto | Nombre de couleurs au recto | Numérique
fi_co_verso | Nombre de couleurs au verso | Numérique
fi_collage | Présence de collage | Alphanumérique
fi_contre_collage | Présence de contre-collage | Alphanumérique
fi_couleur_pap | Couleur du papier | Alphanumérique
fi_d_papier | Désignation du papier | Alphanumérique
fi_dorure | Présence de dorure | Alphanumérique
fi_ecma | Code ECMA/FEFCO | Alphanumérique
fi_enc_r | Pourcentage d'encrage au recto | Numérique
fi_enc_v | Pourcentage d'encrage au verso | Numérique
fi_epaisseur | Epaisseur du papier | Numérique
fi_epreuve | Epreuve | Alphanumérique
fi_equerre | Présence d'équerrage du papier | Alphanumérique
fi_fenetrage | Présence de fenêtrage | Alphanumérique
fi_fini_dblc | Espacement des poses en X | Numérique
fi_forcage_format | Format ouvert forcé | Alphanumérique
fi_forcage_nbp | Nombre de poses forcées | Alphanumérique
fi_fou_impose | Fournisseur imposé | Alphanumérique
fi_fournisseur | Code fournisseur | Alphanumérique
fi_ft_impo | Format papier imposé | Alphanumérique
fi_gaufrage | Présence de gaufrage | Alphanumérique
fi_grammage | Grammage du papier | Numérique
fi_hau_fini | Hauteur du produit fini | Numérique
fi_lar_fini | Largeur du produit fini | Numérique
fi_lar_ouv | Largeur du produit ouvert | Numérique
fi_lar_papier | Largeur du format du papier | Numérique
fi_lar_tir | Largeur du format de tirage | Numérique
fi_lon_fini | Longueur du produit fini | Numérique
fi_lon_ouv | Longueur du produit ouvert | Numérique
fi_lon_papier | Longueur du format du papier | Numérique
fi_lon_tir | Longueur du format de tirage | Numérique
fi_mac_forcee_r | Machine d'impression recto forcée | Alphanumérique
fi_mac_forcee_v | Machine d'impression verso forcée | Alphanumérique
fi_mac_imp | Machine d'impression au recto | Alphanumérique
fi_mac_imp2 | Machine d'impression au verso | Alphanumérique
fi_manuel | Présence d'opérations manuelles | Alphanumérique
fi_maquette | Maquette | Alphanumérique
fi_mode_tirage | Mode de tirage | Alphanumérique
fi_nb_cl_commune | Nombre de couleurs communes entre le recto et le verso | Numérique
fi_nb_decoupe | Présence de découpe | Alphanumérique
fi_nb_poses | Nombre de poses | Numérique
fi_nb_references | Nombre de références | Numérique
fi_nb_teintes_r | Nombre de recherche de teintes au recto | Numérique
fi_nb_teintes_v | Nombre de recherche de teintes au verso | Numérique
fi_num_forme | Numéro d'outil | Alphanumérique
fi_num_plan_cao | Numéro de plan CAO | Alphanumérique
fi_ozalids | Nombre d'ozalids à fournir au client | Alphanumérique
fi_p_papier | Prix du papier | Numérique
fi_pap_bloque | Format papier bloqué | Alphanumérique
fi_pap_stk | Mode de réapprovisionnement | Alphanumérique
fi_pelliculage | Présence de pelliculage | Alphanumérique
fi_perso | Présence de personnalisation | Alphanumérique
fi_photocompo | Photocomposition | Alphanumérique
fi_photogravure | Photogravure | Alphanumérique
fi_pli_dblc | Espacement des poses en Y | Numérique
fi_pres_vernis_hl | Présence de vernis hors-ligne | Alphanumérique
fi_quadri_r | Présence de quadrichromie au recto | Alphanumérique
fi_quadri_v | Présence de quadrichromie au verso | Alphanumérique
fi_resp_sens_pap | Respect du sens papier | Alphanumérique
fi_type_dimension | Côtes extérieures/intérieures | Alphanumérique
fi_type_imbric | Type d'imbrication | Alphanumérique
fi_type_pellic | Type de pelliculage | Alphanumérique
fi_type_pre_presse | Type de pré-presse | Alphanumérique
fi_type_vernis_r | Type de vernis au recto | Alphanumérique
fi_type_vernis_v | Type de vernis au verso | Alphanumérique
fi_ve_recto | Pourcentage de vernissage au recto | Numérique
fi_ve_verso | Pourcentage de vernissage au verso | Numérique
fi_vernis_hl | Présence de vernis hors-ligne | Alphanumérique
fi_zpar | Zone paramétrée 1 | Alphanumérique
lm_ex_par_paq | Nombre d'exemplaires par paquet | Numérique
lm_nb_cai | Nombre de caisses | Numérique
lm_nb_pal | Nombre de palettes | Numérique
lm_nb_paq | Nombre de paquets | Numérique
lm_poids_cai | Poids d'une caisse | Numérique
lm_poids_pal | Poids d'une palette | Numérique

ENTETE

Nom du champ | Désignation | Type de données
l2_adr_liv | Code adresse de livraison | Alphanumérique
l2_adresse | Code adresse | Alphanumérique
l2_agence | Code agence | Alphanumérique
l2_agence_com | Taux de l'agence | Numérique
l2_agence_corres | Nom du correspondant d'agence | Alphanumérique
l2_agence_titre | Titre d'agence | Alphanumérique
l2_bareme | Code tarif | Alphanumérique
l2_c_ma | Taux du représentant | Numérique
l2_civilite | Code civilité du correspondant | Alphanumérique
l2_client | Code client [champ non masquable] | Alphanumérique
l2_code_prod | Code produit | Alphanumérique
l2_cop_ren | Mode de création du devis | Alphanumérique
l2_corres | Nom du correspondant | Alphanumérique
l2_dat_liv | Date de livraison | Date
l2_date_dev | Date du devis | Date
l2_desdev1 | Désignation (ligne 1) | Alphanumérique
l2_desdev2 | Désignation (ligne 2) | Alphanumérique
l2_dev_cop | Numéro de devis à copier | Alphanumérique
l2_devise | Code devise | Alphanumérique
l2_deviseur | Deviseur | Alphanumérique
l2_etat | Etat du devis | Alphanumérique
l2_fabricant | Fabricant | Alphanumérique
l2_lig_affaire | Numéro de ligne d'affaire | Numérique
l2_motif | Qualificatif | Alphanumérique
l2_nb_liv | Nombre de livraisons | Numérique
l2_nb_references | Nombre de références [champ non masquable] | Numérique
l2_num_affaire | Numéro d'affaire | Alphanumérique
l2_qtedev | Quantité du devis [champ non masquable] | Numérique
l2_refcli | Référence client | Alphanumérique
l2_renouvellement | Renouvellement | Alphanumérique
l2_representant | Code représentant | Alphanumérique
l2_representatif | Intégration au CA prévisionnel | Alphanumérique
l2_sdev_cop | Numéro de sous-devis à copier | Numérique
l2_signature | Signataire | Alphanumérique
l2_site | Site de production | Alphanumérique
l2_suiv | Suivi d'affaire | Alphanumérique
l2_taux_devise | Taux de devise | Numérique
l2_tit_corres | Titre du correspondant | Alphanumérique
l2_transporteur | Code transporteur | Alphanumérique
l2_type_dev | Type du devis | Alphanumérique
l2_type_finition | Type de finition | Alphanumérique
l2_type_port | Type de port | Alphanumérique
l2_type_prix | Type de remise de prix | Alphanumérique
l2_type_prod | Type de processus [champ non masquable] | Alphanumérique
l2_type_transfert | Type de transfert en commande | Alphanumérique
l2_unite_du_plus | Unité du plus | Alphanumérique
l2_validite_deb | Date de début de validité | Date
l2_validite_fin | Date de fin de validité | Date
l2_znum1 | Zone paramétrée numérique 1 | Numérique
l2_znum2 | Zone paramétrée numérique 2 | Numérique
l2_znum3 | Zone paramétrée numérique 3 | Numérique
l2_zpar1 | Zone paramétrée 1 | Alphanumérique
l2_zpar2 | Zone paramétrée 2 | Alphanumérique

ENTITE

Nom du champ | Désignation | Type de données
fi_d_entite | Désignation de l'entité | Alphanumérique
fi_entcop | Numéro d'entité à recopier | Numérique
fi_m_trav | Même travail que l'entité X | Numérique
fi_optimisable (1) | Entité optimisable | Alphanumérique
fi_prod_ent | Code produit d'entité | Alphanumérique
fi_qteent (1) | Quantité de l'entité | Numérique
fi_sit | Site de production | Alphanumérique
fi_typ_ent | Type d'entité | Alphanumérique

(1) Champs inaccessibles dans l'écran d'entité Transformateur Carton

ETIBOB

Nom du champ | Désignation | Type de données
fi_bat | Présence du client au bon à tirer | Alphanumérique
fi_bord_min | Rive minimum | Numérique
fi_c_papier | Code papier | Alphanumérique
fi_cgt_r | Nombre de changements de plaque au recto | Numérique
fi_cgt_teinte_r | Nombre de changements de teintes au recto | Numérique
fi_cgt_teinte_v | Nombre de changements de teintes au verso | Numérique
fi_cgt_v | Nombre de changements de plaque au verso | Numérique
fi_co_recto | Nombre de couleurs au recto | Numérique
fi_co_verso | Nombre de couleurs au verso | Numérique
fi_conditionnement | Présence de conditionnement | Alphanumérique
fi_couleur_pap | Couleur du papier | Alphanumérique
fi_d_papier | Désignation du papier | Alphanumérique
fi_dorure | Présence de dorure | Alphanumérique
fi_ecma | Code ECMA/FEFCO | Alphanumérique
fi_enc_r | Pourcentage d'encrage au recto | Numérique
fi_enc_v | Pourcentage d'encrage au verso | Numérique
fi_epaisseur | Epaisseur du papier | Numérique
fi_epreuve | Epreuve | Alphanumérique
fi_fini_dblc | Espace entre étiquettes | Numérique
fi_fini_dblc_min | Espace avance minimum | Numérique
fi_forcage_nbp | Nombre de poses forcées | Alphanumérique
fi_fou_impose | Fournisseur imposé | Alphanumérique
fi_foulage | Présence de foulage | Alphanumérique
fi_fournisseur | Code fournisseur | Alphanumérique
fi_ft_impo | Format papier imposé | Alphanumérique
fi_gaufrage | Présence de gaufrage | Alphanumérique
fi_grammage | Grammage du papier | Numérique
fi_lar_fini | Largeur du produit fini | Numérique
fi_lar_papier | Largeur du format du papier | Numérique
fi_lar_tir | Largeur du format de tirage | Numérique
fi_lon_fini | Longueur du produit fini | Numérique
fi_lon_tir | Longueur du format de tirage | Numérique
fi_mac_forcee_r | Machine d'impression recto forcée | Alphanumérique
fi_mac_forcee_v | Machine d'impression verso forcée | Alphanumérique
fi_mac_imp | Machine d'impression au recto | Alphanumérique
fi_mac_imp2 | Machine d'impression au verso | Alphanumérique
fi_manuel | Présence d'opérations manuelles | Alphanumérique
fi_maquette | Maquette | Alphanumérique
fi_mode_tirage | Mode de tirage | Alphanumérique
fi_nb_cl_commune | Nombre de couleurs communes entre le recto et le verso | Numérique
fi_nb_decoupe | Présence de découpe | Alphanumérique
fi_nb_references | Nombre de références | Numérique
fi_nb_teintes_r | Nombre de recherche de teintes au recto | Numérique
fi_nb_teintes_v | Nombre de recherche de teintes au verso | Numérique
fi_nbp_haup_larc | Nombre de poses sens travers | Numérique
fi_nbp_larp_hauc | Nombre de poses sens machine | Numérique
fi_num1 | Diamètre de mandrin intérieur | Numérique
fi_num2 | Diamètre de mandrin extérieur | Numérique
fi_num3 | Diamètre de la bobine | Numérique
fi_num4 | Nombre d'étiquettes | Numérique
fi_num5 | Nombre de mètres linéaires | Numérique
fi_num_forme | Numéro de forme de découpe | Alphanumérique
fi_num_plan_cao | Numéro de plan CAO | Alphanumérique
fi_numerotage | Présence de numérotage | Alphanumérique
fi_ozalids | Nombre d'ozalids à fournir au client | Alphanumérique
fi_p_papier | Prix du papier | Numérique
fi_pap_bloque | Format papier bloqué | Alphanumérique
fi_pap_stk | Mode de réapprovisionnement | Alphanumérique
fi_perfo | Présence de perforation | Alphanumérique
fi_perso | Présence de personnalisation | Alphanumérique
fi_photocompo | Photocomposition | Alphanumérique
fi_photogravure | Photogravure | Alphanumérique
fi_quadri_r | Présence de quadrichromie au recto | Alphanumérique
fi_quadri_v | Présence de quadrichromie au verso | Alphanumérique
fi_tours_gcr | Métrage | Numérique
fi_transfert | Présence de poudrage | Alphanumérique
fi_type_imbric | Type d'imbrication | Alphanumérique
fi_type_pellic | Type de pelliculage | Alphanumérique
fi_type_pre_presse | Type de pré-presse | Alphanumérique
fi_type_vernis_r | Type de vernis au recto | Alphanumérique
fi_type_vernis_v | Type de vernis au verso | Alphanumérique
fi_type_verso | Type de verso | Alphanumérique
fi_ve_recto | Pourcentage de vernissage au recto | Numérique
fi_ve_verso | Pourcentage de vernissage au verso | Numérique
fi_vernis_hl | Type de vernis hors ligne | Alphanumérique
fi_zpar | Zone paramétrée 1 | Alphanumérique
fi_zpar2 | Type de conditionnement | Alphanumérique
fi_zpar3 | Sens d'enroulement | Alphanumérique

FEUDEP

Nom du champ | Désignation | Type de données
fi_accessoires | Présence d'accessoires | Alphanumérique
fi_bascule | Présence de bascule | Alphanumérique
fi_bat | Présence du client au bon à tirer | Alphanumérique
fi_c_papier | Code papier | Alphanumérique
fi_cgt_r | Nombre de changements de plaque au recto | Numérique
fi_cgt_r_r | Nombre de repiquages au recto | Numérique
fi_cgt_teinte_r | Nombre de changements de teintes au recto | Numérique
fi_cgt_teinte_v | Nombre de changements de teintes au verso | Numérique
fi_cgt_v | Nombre de changements de plaque au verso | Numérique
fi_cgt_v_r | Nombre de repiquages au verso | Numérique
fi_co_recto | Nombre de couleurs au recto | Numérique
fi_co_verso | Nombre de couleurs au verso | Numérique
fi_couleur_pap | Couleur du papier | Alphanumérique
fi_d_papier | Désignation du papier | Alphanumérique
fi_dorure | Présence de dorure | Alphanumérique
fi_enc_r | Pourcentage d'encrage au recto | Numérique
fi_enc_v | Pourcentage d'encrage au verso | Numérique
fi_encart | Type d'encart | Alphanumérique
fi_encart_fac | Type de façonnage de l'encart | Alphanumérique
fi_entite_fac | Numéro de l'entité de façonnage associée | Numérique
fi_epaisseur | Epaisseur du papier | Numérique
fi_epreuve | Epreuve | Alphanumérique
fi_equerre | Présence d'équerrage du papier | Alphanumérique
fi_faces_pellic | Nombre de faces concernées par le pelliculage | Alphanumérique
fi_fonds_perdus | Présence de fonds perdus | Alphanumérique
fi_forcage_format | Format ouvert forcé | Alphanumérique
fi_forcage_nbp | Nombre de poses forcées | Alphanumérique
fi_fou_impose | Fournisseur imposé | Alphanumérique
fi_foulage | Présence de foulage | Alphanumérique
fi_fournisseur | Code fournisseur | Alphanumérique
fi_ft_impo | Format papier imposé | Alphanumérique
fi_ft_pap_bloque | Format du papier bloqué | Alphanumérique
fi_gache_fix_fac | Gâche de façonnage fixe | Numérique
fi_gache_for_fac | Gâche de façonnage forcée | Numérique
fi_gache_var_fac | Gâche de façonnage variable | Numérique
fi_gaufrage | Présence de gaufrage | Alphanumérique
fi_grammage | Grammage du papier | Numérique
fi_hau_fini | Hauteur du produit fini | Numérique
fi_lar_fini | Largeur du produit fini | Numérique
fi_lar_ouv | Largeur du produit ouvert | Numérique
fi_lar_papier | Largeur du format du papier | Numérique
fi_lar_tir | Largeur du format de tirage | Numérique
fi_lon_fini | Longueur du produit fini | Numérique
fi_lon_ouv | Longueur du produit ouvert | Numérique
fi_lon_papier | Longueur du format du papier | Numérique
fi_lon_tir | Longueur du format de tirage | Numérique
fi_mac_forcee_r | Machine d'impression recto forcée | Alphanumérique
fi_mac_forcee_v | Machine d'impression verso forcée | Alphanumérique
fi_mac_imp | Machine d'impression au recto | Alphanumérique
fi_mac_imp2 | Machine d'impression au verso | Alphanumérique
fi_maquette | Maquette | Alphanumérique
fi_mode_tirage | Mode de tirage | Alphanumérique
fi_nb_cl_commune | Nombre de couleurs communes entre le recto et le verso | Numérique
fi_nb_decoupe | Présence de découpe | Alphanumérique
fi_nb_references | Nombre de références | Numérique
fi_nb_teintes_r | Nombre de recherche de teintes au recto | Numérique
fi_nb_teintes_v | Nombre de recherche de teintes au verso | Numérique
fi_nb_volets | Nombre de volets | Numérique
fi_nbp_haup_larc | Nombre de poses sens travers | Numérique
fi_nbp_larp_hauc | Nombre de poses sens machine | Numérique
fi_numerotage | Présence de numérotage | Alphanumérique
fi_ozalids | Nombre d'ozalids à fournir au client | Alphanumérique
fi_p_papier | Prix du papier | Numérique
fi_pap_bloque | Format papier bloqué | Alphanumérique
fi_pap_stk | Mode de réapprovisionnement | Alphanumérique
fi_pelliculage | Présence de pelliculage | Alphanumérique
fi_perfo | Présence de perforation | Alphanumérique
fi_perso | Présence de personnalisation | Alphanumérique
fi_photocompo | Photocomposition | Alphanumérique
fi_photogravure | Photogravure | Alphanumérique
fi_pliage_mach | Présence de pliage | Alphanumérique
fi_pr_recto | Nombre de couleurs primaires au recto | Numérique
fi_pr_verso | Nombre de couleurs primaires au verso | Numérique
fi_pres_vernis_hl | Présence de vernis hors-ligne | Alphanumérique
fi_quadri_r | Présence de quadrichromie au recto | Alphanumérique
fi_quadri_v | Présence de quadrichromie au verso | Alphanumérique
fi_rainage | Présence de rainage | Alphanumérique
fi_resp_sens_pap | Respect du sens papier | Alphanumérique
fi_tot_page | Nombre total de pages | Numérique
fi_transfert | Présence de poudrage | Alphanumérique
fi_type_pellic | Type de pelliculage | Alphanumérique
fi_type_pellic | Pelliculage | Alphanumérique
fi_type_pre_presse | Type de pré-presse | Alphanumérique
fi_type_vernis_r | Type de vernis au recto | Alphanumérique
fi_type_vernis_v | Type de vernis au verso | Alphanumérique
fi_ve_recto | Pourcentage de vernissage au recto | Numérique
fi_ve_verso | Pourcentage de vernissage au verso | Numérique
fi_zpar | Zone paramétrée 1 | Alphanumérique
lm_ex_par_paq | Nombre d'exemplaires par paquet | Numérique
lm_nb_cai | Nombre de caisses | Numérique
lm_nb_pal | Nombre de palettes | Numérique
lm_nb_paq | Nombre de paquets | Numérique
lm_poids_cai | Poids d'une caisse | Numérique
lm_poids_pal | Poids d'une palette | Numérique
type_pli | Type de pli principal (décomposition des feuilles) | Alphanumérique

LIGIMP

Nom du champ | Désignation | Type de données
fco_bascule | Présence de bascule |
fco_cgt_r_rv | Nombre de repiquages au recto/verso |
fco_cgt_rv | Nombre de changements de plaques au recto/verso |
fco_cgt_teinte_rv | Nombre de changements de teintes au recto/verso |
fco_couleur_rv | Nombre de couleurs au recto/verso |
fco_enc_rv | Pourcentage d'encrage au recto/verso |
fco_mac_forcee_rv | Présence de machine forcée au recto/verso |
fco_mac_imp | Code machine recto/verso |
fco_nb_cl_commune | Nombre de couleurs communes entre recto/verso |
fco_nb_teintes_rv | Nombre de recherches de teintes au recto/verso |
fco_pr_rv | Nombre de couleurs primaires au recto/verso |
fco_quadri_rv | Présence de quadrichromie au recto/verso |
fco_recto_verso | Recto/Verso/Les deux |
fco_type_passage | Type de passage |
fco_type_vernis_r | Type de vernis au recto/verso |
fco_ve_recto | Pourcentage de vernissage au recto/verso |
vernis_multiple (O/N) |  |

NIVDET

det_notes | Première ligne de note
fco_type_vernis_r | Type de vernis hors-ligne au recto
fco_type_vernis_v | Type de vernis hors-ligne au recto
fco_ve_recto | Coefficient de vernissage hors-ligne au recto
fco_ve_verso | Coefficient de vernissage hors-ligne au recto
fi_cgt_r | Nombre de changements de plaques au recto
fi_cgt_teinte_r | Nombre de changement de teintes au recto
fi_cgt_teinte_v | Nombre de changement de teintes au recto
fi_cgt_v | Nombre de changements de plaques au recto
fi_co_recto | Nombre de couleurs au recto
fi_co_verso | Nombre de couleurs au recto
fi_d_entite | Désignation de l'entité
fi_enc_r | Coefficient d'encrage au recto
fi_enc_v | Coefficient d'encrage au recto
fi_grammage | Grammage
fi_nb_cl_commune | Nombre de couleurs communes entre recto et verso
fi_nb_teintes_r | Nombre de recherches de teintes au recto
fi_nb_teintes_v | Nombre de recherches de teintes au recto
fi_optimisable | Entité associée optimisable
fi_pap_stk | Mode de réapprovisionnement
fi_pr_recto | Nombre de couleurs primaires au recto
fi_pr_verso | Nombre de couleurs primaires au recto
fi_quadri_r | Présence de quadrichromie au recto
fi_quadri_v | Présence de quadrichromie au recto
fi_type_pellic | Type de pelliculage
fi_type_vernis_r | Type de vernis en ligne au recto
fi_type_vernis_v | Type de vernis en ligne au recto
fi_ve_recto | Coefficient de vernissage en ligne au recto
fi_ve_verso | Coefficient de vernissage en ligne au recto
fno_bascule | Type de bascule
fno_c_papier | Code papier/qualité
fno_encart | Présence d'encart de façonnage
fno_encart_fac | Type d'encart de façonnage
fno_entite_fac | Numéro d'entité de façonnage d'encart associée
fno_nb_page | Nombre de pages
fno_nb_repiquage | Nombres de repiquages
fno_nb_version | Nombre de versions
fno_num6 | Longueur finie
fno_num7 | Largeur finie
fno_num8 | Hauteur finie
fno_resp_sens_pap | Respect du sens papier

NIVLIG

Nom du champ | Désignation | Type de données
niv_amalgame | Amalgame |
niv_designation | Désignation de la ligne de nomenclature |
niv_edition | Edition |
niv_entite | Numéro d'entité associée |
niv_ligne_dec | Numéro de la ligne de décomposition associée |
niv_reference | Numéro de référence |
niv_ref_commune | Référence commune |

NIVREF

Nom du champ | Désignation | Type de données
de_braille | Présence de braille | Alphanumérique
de_collage | Présence de collage | Alphanumérique
de_cs1 de_cs2 de_cs3 de_cs4 | Code statistiques 1 à 4 | Alphanumérique
de_designation | Désignation | Alphanumérique
de_dorure | Présence de dorure | Alphanumérique
de_ecma | Code ECMA/FEFCO | Alphanumérique
de_fam | Code famille | Alphanumérique
de_fenetrage | Présence de fenêtrage | Alphanumérique
de_fini_dblc | Espacement des poses en X | Numérique
de_forcage_nbp | Forçage du nombre de poses | Alphanumérique
de_foulage | Présence de foulage | Alphanumérique
de_gaufrage | Présence de gaufrage | Alphanumérique
de_gencod | Gencod | Alphanumérique
de_hauteur | H | Numérique
de_hologramme | Présence d'hologramme | Alphanumérique
de_nb_cou_recto | Nombre de couleurs au recto | Numérique
de_nb_cou_verso | Nombre de couleurs au verso | Numérique
de_nb_poses | Nombre de poses | Numérique
de_pli_dblc | Espacement des poses en Y | Numérique
de_produit | Code produit | Alphanumérique
de_quantite | Quantité de la référence | Numérique
de_rainage | Présence de rainage | Alphanumérique
de_ref_client | Référence client | Alphanumérique
de_sfm | Code sous-famille | Alphanumérique
de_transfert | Présence de transfert/poudrage | Alphanumérique
de_type_imbric | Type d'imbrication | Alphanumérique
de_vignette | Présence de vignette | Alphanumérique
format_a format_b | A B | Numérique Numérique

REFDET

Nom du champ | Désignation | Type de données
de_cs1 | Code statistique 1 | Alphanumérique
de_cs2 | Code statistique 2 | Alphanumérique
de_cs3 | Code statistique 3 | Alphanumérique
de_cs4 | Code statistique 4 | Alphanumérique
de_designation | Désignation de la ligne de référence multiple | Alphanumérique
de_fam | Code famille | Alphanumérique
de_fini_dblc | Espacement des poses en X | Numérique
de_forcage_format | Forçage du format de cahier | Alphanumérique
de_gencod | Gencod | Alphanumérique
de_nb_cou_recto | Nombre de couleurs au recto | Numérique
de_nb_cou_verso | Nombre de couleurs au verso | Numérique
de_nb_teintes_r | Nombre de recherche de teintes au recto | Numérique
de_nb_teintes_v | Nombre de recherche de teintes au verso | Numérique
de_nb_variantes | Nombre de variantes | Numérique
de_num6 | Zone numérique paramétrable 6 | Numérique
de_num7 | Zone numérique paramétrable 7 | Numérique
de_num8 | Zone numérique paramétrable 8 | Numérique
de_num9 | Zone numérique paramétrable 9 | Numérique
de_pli_dblc | Espacement des poses en Y | Numérique
de_quadri_r | Présence de quadrichromie au recto | Alphanumérique
de_quadri_v | Présence de quadrichromie au verso | Alphanumérique
de_ref_client | Référence client | Alphanumérique
de_sens_pose | Respect du sens des poses | Alphanumérique
de_sfm | Code sous-famille | Alphanumérique
de_type_imbric | Type d'imbrication | Alphanumérique
ligne_note | Ligne de note | Alphanumérique

REFLIG

Les champs de_ref_xxx sont masqués par défaut et nécessitent une activation pour être affichés.

Voir la note LIB_LIE_ dans le TPR.

Voir le code calcul RF.

Nom du champ | Désignation | Type de données
de_braille de_ref_braille | Présence de braille Numéro de référence liée par le braille | Alphanumérique
de_collage | Présence de collage | Alphanumérique
de_ref_decoupe | Numéro de référence liée par la découpe |
de_dorure de_ref_dorure | Présence de dorure Numéro de référence liée par la dorure | Alphanumérique
de_fenetrage de_ref_fenetrage | Présence de fenêtrage Numéro de référence liée par le fenêtrage | Alphanumérique
de_forcage_nbp | Forçage du nombre de poses | Alphanumérique
de_foulage de_ref_foulage | Présence de foulage Numéro de référence liée par le foulage | Alphanumérique
de_gaufrage de_ref_gaufrage | Présence de gaufrage Numéro de référence liée par le gaufrage | Alphanumérique
de_hologramme de_ref_hologramme | Présence d'hologramme Numéro de référence liée par l'hologramme | Alphanumérique
de_nb_poses | Nombre de poses | Alphanumérique
de_rainage de_ref_rainage | Présence de rainage Numéro de référence liée par le rainage | Alphanumérique
de_transfert de_ref_transfert | Présence de poudrage Numéro de référence liée par le transfert/poudrage | Alphanumérique
de_vignette de_ref_vignette | Présence de vignette Numéro de référence liée par la vignette | Alphanumérique

SAILCO

Nom du champ | Désignation | Type de données
fi_zpar | Zone paramétrée 1 | Alphanumérique
fi_nb_references | Nombre de références | Numérique

TRFCAR

Nom du champ | Désignation | Type de données
fi_accessoires | Présence d'accessoires | Alphanumérique
fi_jonction | Présence de jonctionnement | Alphanumérique
fi_c_papier | Code qualité | Alphanumérique
fi_co_recto | Nombre de couleurs au recto | Numérique
fi_contre_collage | Présence de contre-collage | Alphanumérique
fi_coupe_dec | Coupe de découpe | Numérique
fi_d_papier | Désignation de la qualité | Alphanumérique
fi_ecma | Code FEFCO / ECMA | Alphanumérique
fi_equerre | Présence de colisage | Alphanumérique
fi_forcage_format | Forçage du format ouvert | Alphanumérique
fi_fou_impose | Fournisseur imposé | Alphanumérique
fi_fournisseur | Code fournisseur | Alphanumérique
fi_hau_fini | Hauteur unitaire de la boîte | Numérique
fi_laize_dec | Laize de découpe | Numérique
fi_lar_fini | Largeur unitaire de la boîte | Numérique
fi_lar_ouv | Largeur du format ouvert | Numérique
fi_lar_papier | Laize plaque | Numérique
fi_lar_tir | Laize d'impression | Numérique
fi_lon_fini | Longueur unitaire de la boîte | Numérique
fi_lon_ouv | Longueur du format ouvert | Numérique
fi_lon_papier | Coupe plaque | Numérique
fi_lon_tir | Coupe d'impression | Numérique
fi_manuel | Présence d'opérations manuelles | Alphanumérique
fi_nb_references | Nombre de références | Numérique
fi_nbp_haup_hauc | Nombre de poses de découpe (Coupe) | Numérique
fi_nbp_haup_larc | Nombre de poses d'impression (Coupe) | Numérique
fi_nbp_larp_hauc | Nombre de poses d'impression (Laize) | Numérique
fi_nbp_larp_larc | Nombre de poses de découpe (Laize) | Numérique
fi_num_forme | Numéro d'outil | Alphanumérique
fi_num_plan_cao | Numéro de plan CAO | Alphanumérique
fi_p_papier | Prix du papier | Numérique
fi_pap_bloque | Prix du papier forcé | Alphanumérique
fi_pap_stk | Mode de réapprovisionnement | Alphanumérique
fi_perso | Présence d'opérations autres | Alphanumérique
fi_pose_sm | Nombre de poses plaque (Coupe) | Numérique
fi_pose_st | Nombre de poses plaque (Laize) | Numérique
fi_qteent | Quantité de l'entité | Numérique
fi_tot_page | Coefficient de nomenclature | Numérique
fi_type_jonction | Type de jonctionnement | Alphanumérique
fi_zpar | Zone paramétrée 1 | Alphanumérique

VARLIG

Nom du champ | Désignation | Applicable sur les lignes |  | Masquable
 |  | Sous-devis | Groupe de marges
prx_mpl_negocie | Prix négocié à l’unité du plus | O | N | O
prx_mpl_remis | Marge sur le prix remis à l’unité du plus | O | N | O
prx_mpl_revient | Prix de revient à l’unité du plus |  |  | O
prx_mpl_vente | Prix de vente à l’unité du plus |  |  | O
prx_qrp_marge_neg | Marge sur le prix négocié | O | N | O
prx_qrp_marge_rem | Marge sur le prix remis | O | N | O
prx_qrp_negocie | Prix négocié | O | N | O
prx_qrp_pourcent | % total par rapport au prix remis |  |  | O
prx_qrp_remis | Prix remis | O | N | O
prx_qrp_revient | Prix de revient |  |  | O
prx_qrp_vente | Prix remis |  |  | O
prx_tot_dt_fixe | Partie fixe du prix de revient |  |  | O
prx_tot_marge | Marge | N | O | O
prx_tot_masse | Masse de marge |  |  | O
prx_tot_mt_cde | Montant de commande | O | N | O
prx_tot_pourcent | % total par rapport au prix de vente |  |  | O
prx_tot_revient | Prix de revient |  |  | O
prx_tot_vente | Prix de vente | N | O | O


Saisie des temps - Opérations de contrôle et de maintenance

Les fonctionnalité décrites dans cette page s'appliquent aux 3 programmes de saisie des temps :

dp0 Saisie des temps par dossier ou OF

sbs Saisie des temps atelier par codes barres

sjs Saisie journalière par salarié

A la fin de la saisie des temps, une fenêtre peut s'ouvrir selon le contexte.

L'utilisateur devra remplir des champs pour indiquer si le produit fabriqué est conforme ou non.

Cette fenêtre correspond à la saisie standard des TSC.

Cette dernière sera pré-chargée d'un ou plusieurs TSC selon le paramétrage.

Cette fenêtre s'ouvre selon l'ordre des conditions suivantes :

- couple machine / opération

- machine

- opération

- type de travail (TTR)

Pour la saisie des temps atelier par codes-barres (sbs), une nouvelle action a été ajoutée.

A tout moment, après avoir saisi son code salarié puis l'action CTRL (nom de la nouvelle action par défaut mais paramétrable), l'opérateur peut saisir la conformité ou non du produit via l'ouverture de la fenêtre de la saisie standard des TSC.

La visu v_fab2 permet maintenant de lire le contenu des TSC.

Le paramétrage peut être défini de manière générale dans le #CF ATL pour les 3 programmes de saisie des temps.

Il peut aussi être défini par application (dans le paramètre de lancement de chacun des 3 programmes).

Lorsqu'il est défini à la fois dans le #CF ATL et dans le paramètre de lancement d'une application, c'est ce dernier qui est prioritaire.

Les opérations de contrôle et de maintenance dans la saisie des temps atelier par codes-barres sont créées avec un TTR de type OCQ.

Cela permet de les exclure dans les programmes de statistiques.

Paramétrage des programmes de saisie des temps

Note | Disponible dans --> | dp0 | sbs | sjs | #CFATL
S_CTL | 7,11 Contrôle de conformité (par défaut CTRL) à chaque action de contrôle de conformité (CTRL), l'application ajoutera une ligne d'enregistrement dans la table evt même si le salarié roule sans s'arrêter (fin provisoire, etc.) |  | O |  |
TSC_CONFORMITE | 21 Activation de l'affichage de la fenêtre (O/N) 22 Initialise la fenêtre d'affichage par les TSC par défaut (O/N) Sinon il est impératif que les TSC existent pour l'affichage de la fenêtre. | O | O | O | O
CLE_CONFORMITE | 21,26 Nom de la machine fictive ayant les TSC. Si cette clé n'est pas renseignée, l'application prendra par défaut la machine 000000. | O | O | O | O

Autres paramètres

v_fab2 | Type table : F2 – Type clé (origine) : 5
v_evt | Type table : EV – Type clé (origine) : 5
sp_tps_sal | Note SUP_FAB2
TTR de type OCQ | A1[2] = A1[3] = A1[5] = A1[7] = A1[9] = A1[10] = A1[11] = A1[18] = A1[19] = N A1[8] = O
TSC note CONTEXTE_TSC | 21,40 Nom du champ : VALIDE_CONFORMITE Type O Libellé : Opération de contrôle 42 V 45,60 Les 4 cas de figure suivants sont possibles : Couple machine/opération : MMMMMM_OOOOOOOOO 45,50 : code machine 51 : _ 52,60 : code opération Machine : 45,50 : code machine Opération : 45,53 : code opération Type de Travail : 45,47 : code TTR Il faut activer la nouvelle saisie des TSC pour utiliser cette fonctionnalité. Si vous êtes sous l’ancienne saisie, vous pouvez activer la nouvelle sur le lanceur uniquement en ajoutant la note INFO_C2. Suite à des contraintes techniques, il est nécessaire d'associer les TSC à une machine fictive. C'est pour cela qu'il est prévu dans le paramétrage d'indiquer un nom de machine fictive. Ces TSC sont de type 5 et correspondent à des TSC de la table fab2. La clé qui les définit est sous la forme suivante : 1,19 Numéro de l'OF 20,22 Type de gamme 23,28 Numéro de phase 29,32 Numéro de ligne


Fonction retournant une zone

Cette fonction est principalement appelée par les programmes de transferts en comptabilité.

But de la fonction : renvoyer le contenu d'une zone d'une table

Il faut donc indiquer à cette fonction :

- la table concernée (caractère 1)

- la zone de la table concernée (caractère 2)

Le caractère 1 peut prendre les valeurs suivantes :

A Table cli

B Table mat

C Table cde1 et Table cde2

D Table cdf1 et Table cdf2

E Table par02

F Table blv1

G Table info_c sur tiers

Clé = code tiers + adresse de facturation (si elle existe)

Dans ce cas, le caractère 2 est le code zone TSC (à l'exception du code X).

Le caractère 2 peut prendre les valeurs suivantes :

Table cli (caractère 1 = A)

A Type de tiers (P, C ou F)

B Forme juridique

C Code pays

D Code langue

E Code devise

F Secteur géographique

G Catégorie client

H Secteur d'activité

I Code origine

J Mode règlement

K Code échéance

L Zone paramètre
M Code représentant

N Code APE

O Code tarif

P Code remise

Q Code tournée

R Périodicité facture

S Périodicité relevé

T Code adresse devis

U Code adresse accuses de réception

V Code adresse bons de livraison

W Code adresse facturation

X Code qualité

Y Code INCOTERM

Z Code INSEE

a Code client groupe

b Non utilisé

c Zone paramètre 2

d Zone paramètre 3

e Code titre correspondant

f Zone paramètre numérique

Table mat (caractère 1 = B)

A Type d'article (M, P, F, S ou X)

B Code famille

C Code sous-famille

D Zone libre

E Lieu de rangement niveau 1

F Lieu de rangement niveau 2

G Lieu de rangement niveau 3

H Code conditionnement

I Code couleur

J Code unité d'achat

K Code unité de vente

L Code unité de vente (FABRICAL)

M Code formule de conversion

N Code formule de conversion 2

O Code TVA

P Code classement

Q Code contrôle de qualité

R Code réapprovisionnement

S Code fournisseur principal

T Code client principal

U Code qualité

V Zone paramétrée 2

W Zone paramétrée 3

X Zone paramétrée 4

Y Zone paramétrée 5

Z Code gestionnaire

a Code analytique

b Code statistique 1

c Code statistique 2

d Code statistique 3

e Code statistique 4

Table cde1 (caractère 1 = C)

A Code client

B Type de commande

C Zone paramétrée

D Code adresse accuse de réception

E Code adresse facturation

F Code adresse livraison

G Mode de règlement

H Code échéance

I Code TVA port

J Type de port

K Mode de transport

L Code transporteur

M Code tournée

N Code tarif

O Code remise

P Code suivi d'affaire

Q Code représentant

R Code titre correspondant

Table cde2 (caractère 1 = C)

S Code famille

T Code sous-famille

U Code représentant

V Zone paramétrée 1

W Zone paramétrée 2

X Code unité de vente

Y Code TVA

Z Code adresse livraison

a Paramètre associé au TYC

b Qualification de l'appel

c Code statistique 1

d Code statistique 2

e Code statistique 3

f Code statistique 4

Table cdf1 (caractère 1 = D)

A Code fournisseur

B Type de la commande

C Zone paramétrée de l'entête de la commande

D Code d'adresse de livraison

E Code du lieu de rangement

F Code de l'adresse de sous-traitance

G Code du transporteur

H Code d'adresse de facturation

I Mode de règlement

J Code échéance

K Code tarif

L Code remise

M Code devise

N Code de l'acheteur

O Code du signataire

W Code de l'adresse d'envoi de la commande

Table cdf2 (caractère 1 = D)

P Code famille

Q Code sous-famille

R Code de l'unité d'achat

S Code TVA

T Code de l'adresse de livraison

U Code du lieu de rangement

V Code de l'adresse de sous-traitance

a Code statistique 1

b Code statistique 2

c Code statistique 3

d Code statistique 4

Table par02 (caractère 1 = E)

A alpha1[16,21] sous famille (SFM) de la ligne de commande

B alpha1[16,21] sous famille (SFM) du produit

C alpha4[30,35] famille (FAM) de la ligne de commande

D alpha4[30,35] famille (FAM) du produit

E Note sur paramètre CS1 avec le code cs1 de la fiche article

F Note sur paramètre CS2 avec le code cs2 de la fiche article

G Note sur paramètre CS3 avec le code cs2 de la fiche article

H Note sur paramètre CS4 avec le code cs3 de la fiche article

I Note sur paramètre CS1 avec le code cs1 de la ligne de commande

J Note sur paramètre CS2 avec le code cs2 de la ligne de commande

K Note sur paramètre CS3 avec le code cs2 de la ligne de commande

L Note sur paramètre CS4 avec le code cs3 de la ligne de commande

M Note sur paramètre FAM avec le code FAM de la fiche article

N Note sur paramètre FAM avec le code FAM de la ligne de commande d'achat

Table blv1 (caractère 1 = F)

A Code du client

B Code de la zone paramétrée

C Code du type de port

D Code de la TVA sur le port

E Code du type de transport

F Code du transporteur

G Code de l'adresse de livraison

H Code de l'adresse de facturation

I Code de la TVA sur l'emballage

J Code du type de véhicule

K Si on facture un BL, la zone contient le code de la zone paramétrée de l'entête du BL, sinon elle contient le code de la zone paramétrée de l' entête de commande.


Gestion par codes à barres

Cette page regroupe des paramètres communs aux programmes gérant les codes à barres :

  • prep_cde_cab - Préparation de commande par codes barres

  • localisation_stock - Localisation de stock

  • tran_empl_cab - Transfert d'emplacement de palettes

  • mvt_manuel_cab - Mouvements manuels de palettes

  • regularisation_stock_cab - Régularisation de la quantité informatique en stock

  • change_etat_pal_cab - Changement d'état d'une palette

  • saisie_inventaire_cab - Saisie des inventaires par codes à barres

Options

Ote

Saisie en mode Terminal Embarqué

La saisie des expéditions se fait en mode Terminal Embarqué avec un écran de saisie spécifique.

Il reprend toutes les fonctionnalités existantes en mode Terminal Piéton.

Affichage des formes en style cab_te. Le style cab_te est dans le fichier genero.defaut/styles.4st

Notes

_STYLE_CAB

Nom du style

Par défaut :

si terminal piéton, le style est cab (pas d'option –Ote)

si terminal embarqué, le style est cab_te (option –Ote)

Le style se trouve dans le fichier genero.defaut.styles.4st

à titre d'exemple :

<Style name="Window.cab" >

<StyleAttribute value="modal" name="windowType" />

<StyleAttribute value="normal" name="border" />

<StyleAttribute value="none" name="actionPanelPosition" />

<StyleAttribute value="none" name="ringMenuPosition" />

<StyleAttribute value="none" name="toolBarPosition" />

<StyleAttribute value="none" name="topMenuPosition" />

<StyleAttribute value="none" name="startMenuPosition" />

<StyleAttribute value="none" name="statusBarType" />

<StyleAttribute value="sans-serif" name="fontFamily" />

<StyleAttribute value="center" name="position" />

<StyleAttribute value="no" name="windowSystemMenu" />

</Style>

<Style name="Window.cab_te" >

<StyleAttribute value="modal" name="windowType" />

<StyleAttribute value="normal" name="border" />

<StyleAttribute value="none" name="actionPanelPosition" />

<StyleAttribute value="none" name="ringMenuPosition" />

<StyleAttribute value="none" name="toolBarPosition" />

<StyleAttribute value="none" name="topMenuPosition" />

<StyleAttribute value="none" name="startMenuPosition" />

<StyleAttribute value="none" name="statusBarType" />

<StyleAttribute value="Courier" name="fontFamily" />

<StyleAttribute value="center" name="position" />

<StyleAttribute value="bold" name="fontWeight" />

<StyleAttribute name="fontSize" value="11pt" />

<StyleAttribute value="no" name="windowSystemMenu" />

</Style>


Identifiants des écrans CAB

Chaque écran CAB a son propre identifiant.

Les programmes concernés sont les suivants :

change_etat_pal_cab

edi_etiqprod

localisation_stock

mvt_manuel_cab

prep_cde_cab

qte_prod

recep_cde_cab

regularisation_stock_cab

saisie_inventaire_cab

tran_empl_cab

change_etat_pal_cab_8_20 | z001
etiqprod_cab_transformateur_8_20 | z002
etiqprod_cab_8_20 | z003
localisation_stock_detail_palette_8_20 | z004
localisation_stock_detail_pal_lot_8_20 | z005
localisation_stock_8_20 | z006
mvt_manuel_cab_8_20 | z007
mvt_manuel_cab_8_20_2 | z008
prep_cde_cab_8_20_1 | z009
prep_cde_cab_8_20_2 | z010
prep_cde_cab_8_20_3 | z011
prep_cde_cab_8_20_4 | z012
prep_cde_cab_8_20_5 | z013
prep_cde_cab_8_20_6 | z014
prep_cde_cab_8_20_7 | z015
qte_art_pal_exp_8_20 | z016
qte_prod_cab_transformateur_8_20 | z017
qte_prod_cab_8_20 | z018
recep_cde_cab_8_20_1 | z019
recep_cde_cab_8_20_2 | z020
recep_cde_cab_8_20_3 | z021
recep_cde_cab_8_20_4 | z022
recep_cde_cab_8_20_5 | z023
regularisation_stock_cab_8_20 | z024
regularisation_stock_cab_8_20_2 | z025
saisie_cab_8_20 | z026
sai_inv_cab_8_20_1 | z027
sai_inv_cab_8_20_2 | z028
sai_inv_cab_8_20_3 | z029
sai_inv_cab_8_20_4 | z030
tran_empl_cab_8_20 | z031
tran_empl_cab_8_20_2 | z032
w_change_etat_pal_cab_f9_8_20 | z033
w_etiqprod_f8_seq_8_20 | z034
w_etiqprod_f8_8_20 | z035
w_localisation_stock_f8_22_8_20 | z036
w_localisation_stock_f8_8_20 | z037
w_localisation_stock_f9_8_20 | z038
w_mvt_manuel_cab_f9_8_20 | z039
w_mvt_man_f8_8_20 | z040
w_mvt_man_22_f8_8_20 | z041
w_prep_cde_f8_22_8_20_3 | z042
w_prep_cde_f8_8_20_1 | z043
w_prep_cde_f8_8_20_2 | z044
w_prep_cde_f8_8_20_3 | z045
w_prep_cde_f9_8_20_4 | z046
w_qte_prod_f8_seq_8_20 | z047
w_qte_prod_f8_8_20 | z048
w_recep_cde_f8_8_20_1 | z049
w_recep_cde_f8_8_20_2 | z050
w_regul_stock_cab_f8_22_8_20 | z051
w_regul_stock_cab_f8_8_20 | z052
w_regul_stock_cab_f9_8_20 | z053
w_saisie_inv_cab_f9_8_20 | z054
w_saisie_inv_f8_8_20 | z055
w_saisie_inv_22_f8_8_20 | z056
w_sai_ligcde2_8_20 | z057
w_sai_ligcde_8_20 | z058
w_tran_empl_cab_f9_8_20 | z059
w_tran_empl_f8_8_20 | z060
w_tran_empl_22_f8_8_20 | z061


Principe de fonctionnement des verrous (locks)

FIC_LOCK_ORDRSP

FIC_LOCK_GROUPAGE

FIC_LOCK_EDI

FIC_LOCK_INVOICE

FIC_LOCK_AVIEXP

FIC_LOCK_CARTEC

FIC_LOCK_PCTOPP

FIC_LOCK_SDDATA

FIC_LOCK_INVRPT

FIC_LOCK_WIPRPT

etc...

Principe de fonctionnement des verrous (locks)

Dans plusieurs programmes,

on génère des fichiers à destination d'une autre application,

on lit des fichiers en provenance d'une autre application.

Pour éviter que plusieurs programmes n'accèdent simultanément à un même fichier, le système (VoluPack ou procédure externe) va positionner un verrou pendant toute la durée du traitement, puis supprimer ce verrou en finale.

Ces verrous sont en fait des fichiers dont le nom et le chemin d'accès sont définis dans des notes.

Il en existe 3 :

Fichier | créé / supprimé par | But
FIC_LOCK | Volume Software / Procédure externe | Verrouillage général
FIC_LOCK_VS | Volume Software | interdit à la procédure externe d'utiliser le fichier
FIC_LOCK_ORDERS ou autres | Procédure externe | interdit à VoluPack d'écrire dans le fichier ORDERS (ou autre)

Algorithme simplifié

Si LOCK existe alors

Le transfert est déjà en cours

On sort du programme

Sinon

Création du fichier LOCK

Si LOCK_ORDERS existe alors

Le fichier est en cours d'utilisation par la procédure externe

On attend le tour suivant

Création du fichier LOCK_VS

Alimentation du fichier ORDERS

Suppression LOCK_VS

Suppression LOCK

Lancement éventuel du shell


Notes sur le correspondant destinataire de l'envoi fax/email

Ces notes sont accessibles dans la saisie des correspondants (F13) dans la fiche tiers (cli).

TYPE_ENVOI_DOCUMENT

21,23 Type de document

Exemples

DEA (Demande d'achat

FAC (Facture)

ACR (Accusé de réception)

etc.

25,27 Type d'envoi pour ce correspondant

FAX Envoi par fax

MEL Envoi par email

F+M Envoi par fax et email

N Pas d'envoi en automatique


Opérations élémentaires et dépendances

Dans les dépendances des opérations élémentaires, il est possible de mettre * pour signifier que la recherche d'une opération est indépendante de la dépendance en question.

Il n'est cependant pas possible de composer une valeur de dépendance incluant des caractères de remplacement.

Autrement dit, pour une opération utilisant, par exemple, un TEN comme dépendance et pour laquelle on veut dire : tous les TEN qui commencent par P se rattachent à la même opération, on doit pouvoir mettre dans la dépendance concernée P* au lieu de mettre une liste complète PAN, PET,PEG, PIT, PAT,…

De même, si on souhaite dire : tous les TEN qui commencent par P et finissent par T sont rattachés à la même opération élémentaire, on mettra : P ?T au lieu de la liste PAT, PET, PIT ,…

On utilisera donc la convention suivante :

Le caractère * pour substituer 1 à n caractères

Exemple

P* au lieu de la liste PAT, PET, PIT, PAN, PEG

*T au lieu de la liste PET, PAT, PIT

Le caractère ? pour substituer 1 seul caractère

Exemple

?E ? au lieu de la liste PET, PEG

PA* ou PA ? au lieu de la liste PAT, PAN

Attention, cette technique ne peut être utilisée que pour les dépendances ss_z1, ss_z2 et ss_z3.

Ce point est très utile en particulier pour la gestion des codes difficultés composés du devis optimisé (exemple : piqûre où le code difficulté est composé de 3 caractères :

orientation (F ou I)

type de format (3, 4 ou 5)

cassage en ligne (O ou N)

ce qui peut donner 2x3x2 soit 12 valeurs de la dépendance au lieu de 2 par exemple, si on ne souhaite prendre en compte que l'orientation.


Accès à un fichier Excel

Lorsque vous cliquez sur l'un des fichiers suivants, le fichier est ouvert sous Microsoft Excel©.

Une fois le fichier ouvert sous Excel, veillez à bien sélectionner l'onglet correspondant à la version que vous utilisez.

Le fichier peut éventuellement être modifié et sauvegardé en local.

En aucun cas, le fichier original n'est modifiable.


EDI Définition

EDI

L'EDI, Echange de Données Informatisé ou en version originale Electronic Data Interchange, est le terme générique définissant un échange d'informations automatiques entre deux entités à l'aide de messages standardisés, de machine à machine.

L'EDI a été conçu à l'origine dans l'optique du "zéro papier" et afin d'automatiser le traitement de l'information : disposer rapidement d'une information exhaustive et fiable.

Dans la pratique, l'EDI permet de réduire notablement les interventions humaines dans le traitement de l'information, et donc de le rendre effectivement plus rapide et plus fiable.


EDIFACT

EDIFACT : Electronic Data Interchange For Administration, Commerce and Transport

C'est une norme des Nations Unies décrivant des modalités techniques pour l'échange de données informatisé (EDI) dans différents secteurs industriels.

EDIFACT définit à la fois une syntaxe et un contenu pour les messages EDI.

La norme générale est adaptée par des organismes de normalisation nationaux et sectoriels, afin de mieux prendre en compte les besoins de chaque branche d'activité.

En France, on peut en particulier citer les normes GENCOD (Grande distribution), INOVERT (Transport), ODETTE (Automobile) et ETEBAC (Banque).

L'ISO a adopté EDIFACT par la norme ISO 9735.


BesoinMatiere

Besoins Matières

#CF SMC Matières consommées

v_cde_5 Visu des besoins matières


Instructions

Survolez l'organigramme avec la souris : lorsque le pointeur change de forme, une bulle d'aide s'affiche. Cliquez sur le lien pour atteindre le paramétrage concerné.

Pour afficher l'organigramme dans toute sa largeur, vous pouvez Masquer le sommaire (bouton en haut à gauche) et agrandir la fenêtre.

Pour ré-afficher le sommaire, cliquez simplement sur le bouton Afficher (en haut à gauche).


Etat des alertes - Fonctionnement du tri

Numéro d'ordre du tri par | Valeur alpha 2 | Valeur par défaut
gestionnaire | A2[11] | 1
article | A2[12] | 4
lieu de rangement | A2[13] | 3
date de première alerte | A2[14] | 2
famille | A2[38] | 5
sous-famille | A2[39] | 6
catégorie de produit | A2[40] | 7
code client de la fiche article | A2[45] | 8

Si on laisse les valeurs par défaut, on aura un tri par :

gestionnaire

date de première alerte

lieu de rangement

article

famille

sous-famille

catégorie de produit

code client de la fiche article

IMPORTANT :

Si vous souhaitez mettre en place un autre ordre de tri,

vous devez renseigner les 8 valeurs alpha,

même si certains des tris ne vous intéressent pas.


Aide à la saisie dans une numérotation

Aide à la saisie dans une numérotation f_aideof

Type d'aide 1

Utilisé dans le suivi de production simplifié où il y a par dossier une ligne de commande et une entité de fabrication (soit un OF à un niveau seulement).

Ajoute en automatique -1/1 au numéro passé en paramètre.

Le traitement n'est effectué que s'il ne figure aucun tiret, aucun slash et aucun point dans ledit numéro.

Ce type d'aide ajoute également les zéros manquants dans le numéro.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1/1
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1/1
91050001-1 | 91050001-1

Type d'aide 2

Ajoute en automatique les zéros manquants.

Ce paramétrage doit être utilisée dans toutes les saisies de numérotation.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1/1
91050001-1 | 91050001-1

Type d'aide 3

Ajoute en automatique les zéros manquants et -1 (s'il n'y a pas de -2 par exemple).

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1
91051-1/1 | 91050001-1/1
91051-1 | 91050001-1
91050001 | 91050001-1
91050001-1 | 91050001-1
910500012 | 91050001-2
91051-2 | 91050001-2

Type d'aide 4

Ajoute en automatique les zéros manquants, le tiret manquant et le slash manquant.

Attention, il ne doit y avoir qu'un chiffre entre le tiret et le slash.

On met un slash avant le dernier chiffre saisi et un tiret avant l'avant dernier chiffre saisi.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050000-1/3
9105123 | 91050001-2/3

Type d'aide 5

Ajoute en automatique des zéros devant le numéro.

Type d'aide 6

La saisie se fait sur la référence de la commande + le numéro de ligne.

La recherche est forcée avec le client #SOC

Exemple

Numéro saisi | Numéro retourné
1755.9703-1 | 97040001-1/3

Type d'aide 7

Ajoute en automatique les zéros manquant et -1.

Exemples

Numéro saisi | Numéro retourné
91053 | 91050003-1/99
91051-1 | 91050001-1/99
91050001 | 91050001-1/99
91050001-1 | 91050001-1/99


Visualisation des informations du client final

Les zones suivantes sont accessibles à partir des programmes de visualisation :

codp_ec_cli_final_adr | Code postal correspondant à l'adresse du client final de la commande (principale ou secondaire)
ec_cli_final | Code du client final de la commande
ec_cli_final_adr | Adresse secondaire du client final de la commande
libc_pays_ec_cli_final_adr | Libellé court du pays (PAY) correspondant à l'adresse du client final de la commande (principale ou secondaire)
libl_pays_ec_cli_final_adr | Libellé long du pays (PAY) correspondant à l'adresse du client final de la commande (principale ou secondaire)
nom_ec_cli_final | Nom du client final de la commande
nom_ec_cli_final_adr | Nom correspondant à l'adresse secondaire du client final de la commande
pays_ec_cli_final_adr | Pays correspondant à l'adresse du client final de la commande (principale ou secondaire)
ville_ec_cli_final_adr | Ville correspondante à l'adresse du client final de la commande (principale ou secondaire)

Les programmes de visualisation concernés sont les suivants (par ordre alphabétique) :

v_action_mat

v_bonprep

v_cde_5

v_cde_marche

v_cdem

v_edi_cde

v_edi_cde_delfor

v_fab1

v_fac

v_groupage_bl

v_jbl

v_jdv

v_mat

v_odv

v_palchep

v_prostk

v_reclamation

v_sbi

v_stk0

v_stk_lot_lieu

v_tracabilite


Génération de fichiers

ace_annule

ace_cde_lig

ace_cde_lig_lab

ace_cde_num

ace_cde_num_lab

ace_cle

ace_cloture_par

ace_code

ace_contact_vsw

ace_cree_par

ace_date_cloture

ace_date_echeance

ace_date_prev

ace_etape

ace_etat

ace_fichier

ace_gere_par

ace_groupe

ace_int_ext

ace_lig_affaire

ace_ligne

ace_mp_code

ace_nom_flux

ace_num_affaire

ace_num_devis

ace_num_entite

ace_num_sdevis

ace_objet

ace_priorite

ace_qual

ace_serial

ace_sit

ace_soc

ace_tiers

ace_type

af_annule

af_client

af_cloture

af_date_cloture

af_date_creation

af_date_qual

af_designation

af_etape

af_etat

af_lig_affaire

af_num_affaire

af_produit

af_qualificatif

af_scenario

af_suivi_par

af_type_enr

brd_annu

brd_article

brd_bon

brd_cde

brd_certification

brd_date_tx_change

brd_lig

brd_ligcad

brd_ligcde

brd_litige

brd_nummvt

brd_nummvts

brd_prix

brd_prix_dev

brd_prix_euro

brd_qte_ua

brd_quantite

brd_rappro

brd_ref_bl_four

brd_soc

brd_solde

bre_annu

bre_bon

bre_date_bon

bre_date_deb_recp

bre_date_fin_recp

bre_devise

bre_four

bre_heur_deb_recp

bre_heur_fin_recp

bre_preparateur

bre_site

bre_soc

bre_statut

bre_type_bon

b1_adrf

b1_adrl

b1_annu

b1_blv

b1_blv_cab

b1_cembal

b1_cembal_dev

b1_cembal_euro

b1_cli

b1_col

b1_com

b1_date_chargem

b1_datl

b1_devise

b1_edit

b1_embal

b1_heure_depart

b1_lieu_rgt1

b1_montant

b1_montant_dev

b1_montant_euro

b1_no_groupage

b1_ordre_chargt

b1_pht

b1_pht_dev

b1_pht_euro

b1_poids

b1_poids_brut_tr

b1_ref

b1_sitp

b1_tadr

b1_tport

b1_trans

b1_transfert_trans

b1_transitaire

b1_trsp

b1_tvae

b1_tvap

b1_type_vehicule

b1_vehicule

b2_afacturer

b2_annu

b2_blv

b2_cde

b2_cession

b2_excolis

b2_fact

b2_lig

b2_ligcad

b2_ligcde

b2_ligne_a_epurer

b2_ligseq

b2_maj_deb

b2_montant

b2_nbcolis

b2_nummvt

b2_nummvt3

b2_poids

b2_qte

b2_qteliv

b2_solde

b2_surface

b2_type_livraison

b2_volupilot_ok

br1_adr_recup_liv

br1_annule

br1_bon_edit

br1_client

br1_date_creation

br1_date_valid

br1_numero

br1_numero_bl

br1_ref

br1_reprise_edit

br1_site_prod

br1_soc

br1_statut

br1_transporteur

br1_type

br1_type_vehicule

br1_vehicule

br2_annule

br2_avoir_a_gen

br2_avoir_genere

br2_cad_cde

br2_lig_avoir

br2_lig_cde

br2_lig_fac_assoc

br2_ligne

br2_motif_retour

br2_nb_palette

br2_num_avoir

br2_num_cde

br2_num_fac_assoc

br2_num_mvt_stk

br2_num_reclam

br2_numero

br2_ordre_reclam

br2_qte_palette

br2_qte_totale

br2_rgt1

br2_rgt2

br2_seq_cde

br2_soc

ec_acc

ec_acc_dev

ec_acc_euro

ec_ada

ec_adf

ec_adl

ec_afacturer

ec_annu

ec_ar

ec_bl

ec_c1

ec_cderat

ec_cli

ec_cli_final

ec_cli_final_adr

ec_conf

ec_corres

ec_cr

ec_ct

ec_datc

ec_date

ec_date_client

ec_date_deb_val

ec_date_fin_val

ec_devise

ec_ech

ec_esc

ec_exp

ec_fab

ec_fabricant

ec_fact

ec_fadavo

ec_gestion_train

ec_issue_de

ec_mrg

ec_num

ec_oe

ec_ord

ec_pht

ec_pht_dev

ec_pht_euro

ec_pnt

ec_pnt_dev

ec_pnt_euro

ec_poids

ec_portf

ec_pro

ec_prx

ec_ref

ec_ref_2

ec_ref_liaison

ec_ref_reg_fact

ec_rem

ec_rep

ec_rstafa

ec_sold

ec_suiv

ec_texte

ec_titre

ec_tour

ec_tport

ec_transp

ec_trep

ec_trsp

ec_tvap

ec_tyc

ec_type_liaison

ec_web_statut

lc_adf

lc_adl

lc_afacturer

lc_amalgame

lc_annu

lc_bareme

lc_cderat

lc_colis

lc_com

lc_cs1

lc_cs2

lc_cs3

lc_cs4

lc_date_gener

lc_date_regener

lc_date_solde

lc_date_solde_fab

lc_datim_creation

lc_delcli

lc_deldep

lc_delfab

lc_delrea

lc_delrep

lc_dev

lc_entite

lc_exclus_risque

lc_facrat

lc_fam

lc_gen_bl_auto

lc_gen_dos_fab

lc_haut

lc_heure_cli_tard

lc_heure_cli_tot

lc_heure_dep_tard

lc_heure_dep_tot

lc_heure_fab_tard

lc_heure_fab_tot

lc_heure_rep_tard

lc_heure_rep_tot

lc_larg

lc_lcderat

lc_lfacrat

lc_lib

lc_lieu_rgt1

lc_lig

lc_lig_affaire

lc_lig_amalgame

lc_lig_contrat

lc_ligne_a_epurer

lc_logistique

lc_long

lc_lot

lc_maj_dpl

lc_maj_reflex

lc_marge

lc_motif_mod_date

lc_mpl_prx_ini

lc_mpl_prx_ini_dev

lc_mpl_prx_ini_eur

lc_mpl_qte_ini

lc_num

lc_num_affaire

lc_num_contrat

lc_nummvt

lc_nummvt2

lc_nummvt3

lc_p1

lc_p2

lc_p3

lc_par_tyc

lc_poids

lc_priorite

lc_prixnet

lc_prod

lc_prx

lc_prx_au_moins

lc_prx_au_plus

lc_prx_cessi

lc_prx_cessi_dev

lc_prx_cessi_eur

lc_prx_dev

lc_prx_euro

lc_prx_moins_dev

lc_prx_moins_euro

lc_prx_plus_dev

lc_prx_plus_euro

lc_prx_rev_uni

lc_prx_revient

lc_prx_rvt_dev

lc_prx_rvt_euro

lc_prx_rvt_r_euro

lc_prx_rvt_reel

lc_prxcli

lc_prxcli_dev

lc_prxcli_euro

lc_qte_contrat

lc_qte_en_retour

lc_qteafa

lc_qtecde

lc_qtefab

lc_qtefac

lc_qtelan

lc_qteliv

lc_qteliv_reelle

lc_qualif_appel

lc_ref_prod_cli

lc_rem

lc_repr

lc_rstafa

lc_rstbl

lc_rstfab

lc_rstfac

lc_sbi

lc_sdev

lc_sfm

lc_solde

lc_surface

lc_tolerance_liv

lc_transfert_trans

lc_tva

lc_unvent

lc_unvent_au

lc_var_prod

lc_variante

lc_volupilot_ok

nc_coef_nom

nc_lig

nc_ligfbi

nc_num

nc_numfbi

nc_nummvt

nc_nummvt2

nc_nummvt3

nc_prod

nc_qte_contrat

nc_qte_en_retour

nc_qtecde

nc_qtefab

nc_qteliv

nc_qteliv_non_val

nc_qteliv_reelle

nc_qteliv_val

nc_reap

nc_rgt1

nc_rgt2

nc_rgt3

nc_rstfab

nc_seq

nc_seq_rat

nc_solde

uc_ada

uc_adf

uc_annul

uc_article_fab

uc_coupe_brute

uc_coupe_dec

uc_coupe_imp

uc_coupe_nette

uc_coupe_uni

uc_date_creation

uc_date_dispo

uc_date_plus_tard

uc_ds1

uc_ds10

uc_ds11

uc_ds12

uc_ds2

uc_ds3

uc_ds4

uc_ds5

uc_ds6

uc_ds7

uc_ds8

uc_ds9

uc_etat

uc_fournisseur

uc_hauteur

uc_laize_brute

uc_laize_dec

uc_laize_imp

uc_laize_nette

uc_laize_uni

uc_largeur

uc_lig

uc_lig_mat

uc_longueur

uc_mat_util

uc_nb_pos_coupe

uc_nb_pos_laize

uc_num

uc_num_stk

uc_poids

uc_pos_coupe_imp

uc_pos_coupe_nette

uc_pos_laize_imp

uc_pos_laize_nette

uc_prix_ua

uc_profil_carton

uc_qte_cde

uc_qte_util

uc_qualite_carton

uc_refoule

uc_rogne_coupe_dec

uc_rogne_coupe_imp

uc_rogne_coupe_net

uc_rogne_laize_dec

uc_rogne_laize_imp

uc_rogne_laize_net

uc_seq_ensemble

uc_surf_brute

uc_surf_brute_cde

uc_surf_brute_tot

uc_surf_dec

uc_surf_imp

uc_surf_nette

uc_surf_nette_tot

uc_surf_uni

uc_tiers_liv

uc_tiers_liv_adr

uc_ua

li_adr

li_adr1

li_adr2

li_adr3

li_adr_fac

li_annu

li_appel_traite

li_civ_corres

li_conf

li_cpos

li_date_appel

li_date_dem

li_date_depart

li_date_etat

li_date_motif

li_date_solde

li_datliv

li_etat

li_lig

li_lig_cad

li_mode_saisie

li_montant

li_motif_qualif

li_nom

li_nom_corres

li_num

li_num_mvt

li_num_mvt3

li_pays

li_poids

li_qte_en_retour

li_qte_liv_fact

li_qte_liv_reel

li_qteliv

li_qteliv_ini

li_qua

li_ref_cli

li_rgt

li_seq

li_soc

li_solde

li_surface

li_tco_corres

li_tolerance_liv

li_transp

li_type

li_type_liv

li_valid_adv

li_valid_log

li_valid_prod

li_ville

acp_en_code_tol

acp_en_code_tva

acp_en_cs1

acp_en_cs2

acp_en_cs3

acp_en_cs4

acp_en_date_modif

acp_en_num_cde

acp_en_pres_qua

acp_en_prix

acp_en_qte_tot

acp_en_qte_tot_m2

acp_en_qte_tot_ml

acp_en_remise

acp_en_soc

acp_en_unite

acp_lg_adl

acp_lg_annu

acp_lg_code_cond

acp_lg_coef

acp_lg_delrep

acp_lg_diam_bob

acp_lg_diam_mand

acp_lg_largeur

acp_lg_lig

acp_lg_lig_cde

acp_lg_lig_fbi

acp_lg_longueur

acp_lg_num_cde

acp_lg_num_decoupe

acp_lg_num_fbi

acp_lg_qte_lig

acp_lg_qte_m2_lig

acp_lg_qte_ml_lig

acp_lg_quantite

acp_lg_quantite_m2

acp_lg_quantite_ml

acp_lg_soc

ef_ach

ef_ada

ef_adf

ef_adl

ef_adst

ef_annu

ef_ar

ef_bl

ef_c1

ef_client_liv

ef_corres

ef_cours

ef_cr

ef_ct

ef_datc

ef_datfac

ef_datim_creation

ef_datim_der_trans

ef_datim_modif

ef_datim_trans_ini

ef_devise

ef_ech

ef_exp

ef_fact

ef_fou

ef_mrg

ef_nofac

ef_num

ef_ref

ef_rem

ef_rgt

ef_sec_ana

ef_signature

ef_sold

ef_titre

ef_transport

ef_tyc

lf_adl

lf_adst

lf_affect

lf_annu

lf_arc

lf_cdc

lf_cderat

lf_certification

lf_cli

lf_colis

lf_cs1

lf_cs2

lf_cs3

lf_cs4

lf_date_arc

lf_datim_creation

lf_datim_modif

lf_datim_trans

lf_delai_demande

lf_delfou

lf_delrep

lf_etatmar

lf_fam

lf_forfait

lf_larg

lf_lcderat

lf_lib

lf_lig

lf_long

lf_maj_reflex

lf_num

lf_nummvt

lf_nummvts

lf_poids

lf_prix_fac

lf_prix_fac_dev

lf_prix_fac_euro

lf_prix_init

lf_prix_init_dev

lf_prix_init_euro

lf_prixliv

lf_prixliv_dev

lf_prixliv_euro

lf_prixvente

lf_prixvente_dev

lf_prixvente_euro

lf_prod

lf_prx

lf_prx_dev

lf_prx_euro

lf_qte_init

lf_qte_retour

lf_qtecde

lf_qtefac

lf_qteliv

lf_qtemar

lf_rem

lf_rgt

lf_rstbl

lf_sec_ana

lf_sfm

lf_solde

lf_statut_edi

lf_tolerance_liv

lf_transfert_edi

lf_tva

lf_unacha

lf_zpar_num1

cl_ach_aff

cl_act

cl_adr1

cl_adr2

cl_adr3

cl_adra

cl_adrb

cl_adrd

cl_adrf

cl_agrement

cl_annul

cl_ape

cl_cat

cl_certification

cl_clifact

cl_cligr

cl_cligr2

cl_code

cl_code_bic

cl_code_domb1

cl_codef

cl_codp

cl_corres

cl_corres_civilite

cl_cpf

cl_cpt

cl_cred

cl_dat_cr

cl_dateannu

cl_delai_consigne

cl_dev

cl_documents

cl_domb

cl_domb1

cl_domb2

cl_ech

cl_edit

cl_email

cl_esc

cl_exp

cl_facp

cl_geo

cl_groupe_risque

cl_iban

cl_id_societe

cl_incoterm

cl_insee

cl_langue

cl_latitude

cl_livp

cl_longitude

cl_mailing

cl_marge

cl_minf

cl_mrg

cl_nbfac

cl_nom

cl_nom_abrege

cl_orig

cl_param

cl_pays

cl_perf

cl_perr

cl_pla_franco_port

cl_port_dest

cl_prca

cl_qual

cl_qualif_appel

cl_qualite

cl_regbl

cl_rel

cl_rem

cl_remg

cl_reml

cl_repr

cl_rib

cl_seuila

cl_siret

cl_site_web

cl_suiv

cl_tar

cl_telcop

cl_telex

cl_telph1

cl_telph2

cl_titre

cl_tolerance_liv

cl_tour

cl_tournee_liv

cl_trac

cl_transitaire

cl_transp

cl_trsp

cl_tx_commission

cl_valbl

cl_validite_adr

cl_vil

cl_zpar

cl_zpar2

cl_zpar3

cl_zpar_adresse

cl_zparnum

c2_adr

c2_adr1

c2_adr2

c2_adr3

c2_annul

c2_code

c2_code_bic

c2_code_domb1

c2_codp

c2_corres

c2_corres_civilite

c2_cpt

c2_devise

c2_domb1

c2_domb2

c2_ech

c2_email

c2_exp

c2_geo

c2_iban

c2_id_etablissem

c2_ident_cpta_aux

c2_insee

c2_langue

c2_latitude

c2_longitude

c2_mrg

c2_nom

c2_pays

c2_port_dest

c2_qual

c2_qualif_appel

c2_reml

c2_repr

c2_rib

c2_siret

c2_telcop

c2_telex

c2_telph1

c2_telph2

c2_titre

c2_tolerance_liv

c2_tournee_liv

c2_tport

c2_transitaire

c2_transp

c2_trsp

c2_tx_commission

c2_validite_adr

c2_vil

c2_zpar_adresse

c2_zparnum

co_civilite

co_code

co_code_adresse

co_code_associe

co_email

co_fax_achat

co_fax_ar

co_fax_bl

co_fax_devis

co_id_contact

co_id_contact_ori

co_id_contact_vsw

co_initiales

co_langue

co_nom

co_prenom

co_tco

co_telcop

co_telph

co_telph_mobile

co_type

co_type_associe

dae_ach

dae_annu

dae_copie

dae_date_dem

dae_delrep

dae_delrep_com

dae_demandeur

dae_edit

dae_etat

dae_num

dae_ref

dae_service

dae_sign

dae_site

dae_type

kma_actif

kma_anul

kma_classe

kma_code

kma_code_diff_cal

kma_code_diff_rou

kma_codenor

kma_coupe_dd

kma_coupe_dmm

kma_coupe_dmp

kma_coupe_gc

kma_coupe_mc

kma_coupe_pc

kma_coupe_tc

kma_coupe_z1

kma_coupe_z2

kma_coupe_z3

kma_desig

kma_laize_dd

kma_laize_dmm

kma_laize_dmp

kma_laize_gc

kma_laize_mc

kma_laize_pc

kma_laize_tc

kma_laize_z1

kma_laize_z2

kma_laize_z3

kma_libnor

kma_maxhau

kma_maxlar

kma_maxlon

kma_minhau

kma_minlar

kma_minlon

kma_nb_morceaux

kma_ordre

kma_pc

kma_pp1

kma_pp2

kma_pp3

kma_pp4

kma_pp5

kma_pp6

kma_rp1

kma_rp2

kma_sclasse

kma_sm

kma_soc

kma_st

kma_surf

kma_type

em_adr1

em_adr2

em_anul

em_cal

em_ch

em_chv

em_code

em_codp

em_cu

em_den

em_fonction

em_libre

em_machine

em_marge

em_matric

em_nom

em_of

em_phase

em_plage

em_prenom

em_qual

em_section

em_soc

em_tel

em_tpsdu

em_ttr

em_type

em_ville

efe_adresse_dest

efe_adresse_exp

efe_civilite_dest

efe_civilite_exp

efe_cle_document

efe_client_dest

efe_client_exp

efe_code_exp

efe_comp_par_lanct

efe_comp_select

efe_date_autorise

efe_date_differe

efe_date_envoi

efe_date_reenvoi

efe_email_dest

efe_email_exp

efe_fax_dest

efe_fax_exp

efe_flag_autorise

efe_langue

efe_modele_doc

efe_nom_dest

efe_nom_exp

efe_num_lig_dest

efe_objet

efe_piece_jointe

efe_site_prod

efe_soc

efe_societe_dest

efe_societe_exp

efe_statut_envoi

efe_type_document

efe_type_envoi

efe_type_exp

f0_acalc

f0_amalgame

f0_anu

f0_capteur

f0_capteur_s

f0_cde

f0_cli

f0_clos

f0_cmn

f0_cmp

f0_cmr

f0_coef_nom

f0_cp

f0_cp_react

f0_cpn

f0_cpp

f0_cpr

f0_cr

f0_crn

f0_crp

f0_crr

f0_datde

f0_date

f0_datfc

f0_delp

f0_delr

f0_dt1

f0_dt2

f0_edite

f0_gener

f0_gp

f0_gp_f

f0_gr

f0_gr_f

f0_hau

f0_hdp

f0_hfp

f0_lance

f0_larg

f0_lig

f0_long

f0_marq

f0_nummvt

f0_of

f0_phase

f0_poids

f0_prix_uni

f0_prod

f0_qtel

f0_qtel_up

f0_qter

f0_qter_up

f0_regroupement

f0_rep

f0_sim

f0_soc

f0_tri

f0_typga

f0_uni_prod

f0_user

fe_adf

fe_adl

fe_cession

fe_cli

fe_cours_dev

fe_cpt

fe_date

fe_date_reglement

fe_dev

fe_ech

fe_fac

fe_faccli

fe_fadavo

fe_ident_cpta_aux

fe_maj_deb

fe_maj_reflex

fe_maj_vp

fe_mrg

fe_pourc_reglement

fe_siret

fe_soc

fe_transfert_ext

fl_bareme

fl_bl

fl_cde

fl_ctva

fl_esc_ec

fl_fac

fl_fedit

fl_ht

fl_ht_au

fl_ht_au_dev

fl_ht_au_euro

fl_ht_dev

fl_ht_euro

fl_lbl

fl_lcad

fl_lcde

fl_lfac

fl_maj

fl_poids

fl_prxvent

fl_prxvent_au

fl_prxvent_au_dev

fl_prxvent_au_euro

fl_prxvent_dev

fl_prxvent_euro

fl_qte

fl_qte_au

fl_rel

fl_rem

fl_rem_ec

fl_soc

fl_surface

fl_tedit

fl_trait

fl_tva

fl_unvent

fl_unvent_au

fp_af

fp_base

fp_base_dev

fp_base_euro

fp_date

fp_datech

fp_enr

fp_fac

fp_mont

fp_mont_dev

fp_mont_euro

fp_soc

fp_taux

fp_traeff

fp_transf

fp_user

ff0_adf

ff0_compte

ff0_controle

ff0_controle_dev

ff0_controle_euro

ff0_cours_dev

ff0_date_compta

ff0_date_creation

ff0_date_echeance

ff0_date_piece

ff0_dev

ff0_ech

ff0_fac_rapprochee

ff0_fadavo

ff0_fou

ff0_frais

ff0_frais_appr

ff0_frais_appr_aff

ff0_frais_appr_fac

ff0_frais_dev

ff0_frais_euro

ff0_mode_tva

ff0_mrg

ff0_piece

ff0_reference

ff0_soc

ff0_transfere

ff1_affect

ff1_article

ff1_bon

ff1_cdc

ff1_cde

ff1_cle_repart

ff1_compte_achat

ff1_ctva

ff1_esc

ff1_fconv

ff1_frais

ff1_frais_dev

ff1_frais_euro

ff1_ht

ff1_ht_dev

ff1_ht_euro

ff1_ligbon

ff1_ligcad

ff1_ligcde

ff1_ligne_piece

ff1_maj

ff1_no_fac_ratt

ff1_piece

ff1_poids

ff1_prix

ff1_prix_dev

ff1_prix_euro

ff1_qte_ua

ff1_quantite

ff1_rem

ff1_rem_gen

ff1_sec_ana

ff1_soc

ff1_surface

ff1_tva

ff1_unachat

l2_a_calculer

l2_adr_liv

l2_adresse

l2_agence

l2_agence_com

l2_agence_corres

l2_agence_titre

l2_anul

l2_bareme

l2_c_ma

l2_c_mon

l2_c_pv

l2_cde_marche

l2_civilite

l2_client

l2_code_prod

l2_cop_ren

l2_corres

l2_dat_liv

l2_date_cde

l2_date_deb_marche

l2_date_dec

l2_date_dev

l2_date_edi

l2_date_fax

l2_date_fin_marche

l2_date_rem

l2_delai_fab

l2_desdev1

l2_desdev2

l2_dev_cop

l2_dev_fab

l2_devis

l2_devise

l2_deviseur

l2_dossier

l2_edit_offre

l2_env_matiere

l2_env_operation

l2_etat

l2_etat_avancement

l2_etude

l2_fabricant

l2_frais

l2_frais_1

l2_frais_1

l2_frais_1_negocie

l2_frais_1_negocie

l2_frais_1_pr

l2_frais_1_pv

l2_frais_2

l2_frais_2

l2_frais_2_negocie

l2_frais_2_negocie

l2_frais_2_pr

l2_frais_2_pv

l2_frais_3

l2_frais_3_negocie

l2_frais_3_pr

l2_frais_3_pv

l2_frais_4

l2_frais_4_negocie

l2_frais_4_pr

l2_frais_4_pv

l2_frais_5

l2_frais_5_negocie

l2_frais_5_pr

l2_frais_5_pv

l2_gestion_train

l2_lig_affaire

l2_m_1_ma

l2_m_1_pr

l2_m_1_pv

l2_m_2_ma

l2_m_2_pr

l2_m_2_pv

l2_m_f_ma

l2_m_f_pr

l2_m_f_pv

l2_m_ma

l2_m_ma_bloque

l2_m_pr

l2_m_pv

l2_m_t_ma

l2_m_t_pr

l2_m_t_pv

l2_m_v_ma

l2_m_v_pr

l2_m_v_pv

l2_maj_reflex

l2_mil

l2_mille_negocie

l2_mode_expert

l2_motif

l2_mpl_milmoins

l2_mpl_milplus

l2_mpl_prx_ini

l2_mpl_qte_ini

l2_nb_fab_marche

l2_nb_liv

l2_nb_references

l2_num_affaire

l2_num_cahier

l2_num_conception

l2_num_forme

l2_num_plan_cao

l2_o_1_ma

l2_o_1_pr

l2_o_1_pv

l2_o_2_ma

l2_o_2_pr

l2_o_2_pv

l2_o_f_ma

l2_o_f_pr

l2_o_f_pv

l2_o_t_ma

l2_o_t_pr

l2_o_t_pv

l2_o_v_ma

l2_o_v_pr

l2_o_v_pv

l2_p_ma

l2_p_pr

l2_p_pr_f

l2_p_pv

l2_pour

l2_prix_negocie

l2_px_ma

l2_px_pr

l2_px_pv

l2_qte_lancee

l2_qtedev

l2_refcli

l2_remis

l2_remis_devise

l2_renouvellement

l2_representant

l2_representatif

l2_s_f_ma

l2_s_f_pr

l2_s_f_pv

l2_s_v_ma

l2_s_v_pr

l2_s_v_pv

l2_sce_calcul

l2_sdev_cop

l2_sdevis

l2_signature

l2_site

l2_suiv

l2_taux_devise

l2_tit_corres

l2_tol_maxi

l2_tol_mini

l2_transporteur

l2_type_dev

l2_type_finition

l2_type_port

l2_type_prix

l2_type_prod

l2_type_transfert

l2_unite_du_plus

l2_validite_deb

l2_validite_fin

l2_z1

l2_z2

l2_zchr1

l2_znum1

l2_znum2

l2_znum3

l2_zpar1

l2_zpar2

fc_a1

fc_a2

fc_a3

fc_a4

fc_devis

fc_dif

fc_entite

fc_fournisseur

fc_lcom

fc_ligne

fc_machine

fc_matiere

fc_ope

fc_sdevis

fc_sec

fc_sop

fc_type

fc_v1

fc_v2

fc_v3

fc_v4

fco_bascule

fco_cgt_r_rv

fco_cgt_rv

fco_cgt_teinte_rv

fco_couleur_rv

fco_devis

fco_enc_rv

fco_entite

fco_fournisseur

fco_mac_forcee_rv

fco_mac_imp

fco_mac_ve_recto

fco_mac_ve_verso

fco_nb_cl_commune

fco_nb_teintes_rv

fco_num_pass

fco_num_vernis

fco_pr_rv

fco_quadri_rv

fco_recto_verso

fco_sdevis

fco_type

fco_type_passage

fco_type_vernis_r

fco_type_vernis_v

fco_ve_recto

fco_ve_verso

de_bascule

de_braille

de_code_papier

de_collage

de_cs1

de_cs2

de_cs3

de_cs4

de_designation

de_devis

de_dorure

de_ecma

de_entite

de_fam

de_fenetrage

de_fini_dblc

de_forcage_format

de_forcage_nbp

de_foulage

de_gaufrage

de_gencod

de_grammage

de_hauteur

de_hauteur_cahier

de_hologramme

de_largeur

de_largeur_cahier

de_ligne

de_ligne_auto

de_longueur

de_machine

de_nb_cah

de_nb_cou_recto

de_nb_cou_verso

de_nb_feuille

de_nb_page

de_nb_pos_pliage

de_nb_poses

de_nb_teintes_r

de_nb_teintes_v

de_nb_variantes

de_num6

de_num7

de_num8

de_num9

de_num_ba

de_num_feuille

de_num_planche

de_num_reference

de_per_contour

de_pli_dblc

de_pourcentage

de_pres_depassant

de_produit

de_qte_lancee

de_quadri_r

de_quadri_v

de_quantite

de_rainage

de_ref_client

de_ref_decoupe

de_ref_dorure

de_ref_gaufrage

de_sdevis

de_sens_pose

de_sfm

de_surface

de_transfert

de_typ_ent

de_type_decoupe

de_type_imbric

de_type_pli

de_type_pli1

de_type_pli2

de_type_pli3

de_type_pli4

de_type_pli5

de_vignette

de_z1

de_z10

de_z11

de_z12

de_z2

de_z3

de_z4

de_z5

de_z6

de_z7

de_z8

de_z9

flf_devis

flf_nature_frais

flf_num_reference

flf_px_negocie

flf_px_remis

flf_px_revient

flf_px_vente

flf_sdevis

ga_devis

ga_entite

ga_frais

ga_mat

ga_note

ga_num_ordo

ga_numphase

ga_ope

ga_option

ga_phase

ga_saisie

ga_sdevis

ga_soc

ga_tot_mat

ga_tot_ope

ga_tot_str

ga_total

fi_1000_rou

fi_accessoires

fi_anul

fi_bascule

fi_bat

fi_blanc_barbe

fi_blanc_droite

fi_blanc_gauche

fi_blanc_pied

fi_blanc_pli

fi_blanc_tete

fi_blancs_forces

fi_bord_max

fi_bord_min

fi_c_papier

fi_calage_1

fi_calage_s

fi_cassage_mach

fi_cgt_r

fi_cgt_r_r

fi_cgt_teinte_r

fi_cgt_teinte_v

fi_cgt_v

fi_cgt_v_r

fi_co_recto

fi_co_verso

fi_code_gamme

fi_collage

fi_conditionnement

fi_contre_collage

fi_couleur_pap

fi_coupe_dec

fi_coupe_plaq_net

fi_cs1

fi_cs2

fi_cs3

fi_cs4

fi_d_entite

fi_d_papier

fi_depassant

fi_devis

fi_dorure

fi_ecma

fi_enc_r

fi_enc_v

fi_encart

fi_encart_fac

fi_entcop

fi_entite

fi_entite_fac

fi_epaisseur

fi_epaisseur

fi_equerre

fi_faces_pellic

fi_faces_pellic

fi_fam

fi_fenetrage

fi_feu_pap

fi_feu_pap_hg

fi_fin_pression

fi_fini_dblc

fi_fini_dblc_max

fi_fini_dblc_min

fi_fini_par1

fi_fini_par2

fi_fonds_perdus

fi_forcage_format

fi_forcage_nbp

fi_fou_impose

fi_foulage

fi_fournisseur

fi_ft_impo

fi_ft_pap_bloque

fi_gache_fix_fac

fi_gache_for_fac

fi_gache_var_fac

fi_gaufrage

fi_grammage

fi_grattage

fi_hau_fini

fi_laize_dec

fi_laize_plaq_net

fi_lar_fini

fi_lar_ouv

fi_lar_papier

fi_lar_tir

fi_lon_fini

fi_lon_ouv

fi_lon_papier

fi_lon_tir

fi_m_trav

fi_mac_forcee_r

fi_mac_forcee_v

fi_mac_imp

fi_mac_imp2

fi_manuel

fi_mode_tirage

fi_nb_cl_commune

fi_nb_cl_fle_r

fi_nb_cl_fle_v

fi_nb_cl_off_r

fi_nb_cl_off_v

fi_nb_cl_ser_r

fi_nb_cl_ser_v

fi_nb_cl_typ_r

fi_nb_cl_typ_v

fi_nb_decoupe

fi_nb_feu

fi_nb_poses

fi_nb_qte_port

fi_nb_references

fi_nb_teintes_r

fi_nb_teintes_v

fi_nb_volets

fi_nbp_haup_hauc

fi_nbp_haup_larc

fi_nbp_larp_hauc

fi_nbp_larp_larc

fi_num1

fi_num2

fi_num3

fi_num4

fi_num5

fi_num6

fi_num7

fi_num8

fi_num9

fi_num_forme

fi_num_ordo

fi_num_plan_cao

fi_numerotage

fi_optimisable

fi_ozalids

fi_p_papier

fi_page_feu

fi_pap_bloque

fi_pap_stk

fi_pds_pap

fi_pds_pap_hg

fi_pelliculage

fi_per_contour

fi_perfo

fi_perso

fi_pli_dblc

fi_pli_par1

fi_pli_par2

fi_pliage_mach

fi_pos_reperes

fi_pose_sm

fi_pose_st

fi_poses_inverse

fi_pr_port_fixe

fi_pr_port_var

fi_pr_recto

fi_pr_verso

fi_pres_vernis_hl

fi_pres_vernis_st

fi_prise_pinces

fi_prod_ent

fi_px_mar

fi_px_pr

fi_px_pr_fixe

fi_px_pr_var

fi_px_pv

fi_qte_lancee

fi_qteent

fi_quadri_r

fi_quadri_v

fi_rainage

fi_remis

fi_remis_devise

fi_reperes

fi_resp_sens_pap

fi_resp_sens_pose

fi_sdevis

fi_sfm

fi_sit

fi_tot_page

fi_tours_fxr

fi_tours_fxv

fi_tours_gcr

fi_tours_gcv

fi_tours_hgr

fi_tours_hgv

fi_transfert

fi_typ_ent

fi_type

fi_type_dimension

fi_type_imbric

fi_type_pellic

fi_type_pre_presse

fi_type_vernis_r

fi_type_vernis_v

fi_type_verso

fi_typons

fi_ve_recto

fi_ve_verso

fi_vernis_hl

fi_z1

fi_z2

fi_z3

fi_z4

fi_z5

fi_z6

fi_z7

fi_z8

fi_z9

fi_z10

fi_z11

fi_z12

fi_zpar

fi_zpar2

fi_zpar3

fm_a1

fm_devis

fm_entite

fm_etat

fm_formule

fm_fournisseur

fm_frais

fm_fv

fm_g_f

fm_g_v

fm_hauteur

fm_largeur

fm_lie_a_ref

fm_ligne

fm_longueur

fm_marge

fm_matiere

fm_num_reference

fm_numphase

fm_poids

fm_pr

fm_prix_bloque

fm_pv

fm_qte_forcee

fm_quantite

fm_quantite_fix

fm_quantite_var

fm_sdevis

fm_soc

fm_tot_qte

fm_total

fm_type_ligne

fm_unite

fm_unite_gache

fm_v1

fm_v10

fm_v2

fm_v3

fm_v4

fm_v5

fm_v6

fm_v7

fm_v8

fm_v9

fno_amalg

fno_bascule

fno_c_papier

fno_composant

fno_descriptif

fno_designation

fno_devis

fno_edition

fno_entite

fno_feuille_dec

fno_gache_fac

fno_gache_fix

fno_gache_var

fno_generation

fno_libelle_chgt

fno_libelle_pms

fno_ligne

fno_ligne_dec

fno_ligne_parent

fno_nb_page

fno_nb_repiquage

fno_nb_version

fno_niveau

fno_num6

fno_num7

fno_num8

fno_num9

fno_num_amalg

fno_num_cahier

fno_px_negocie

fno_px_pr

fno_px_pr_fix

fno_px_pr_var

fno_px_pv

fno_px_remis

fno_quantite

fno_reference

fno_resp_sens_pap

fno_sdevis

fno_sequence

fno_site

fno_tours_engage

fno_tours_utile

fno_type_bascule

fno_type_ligne

fno_type_nom

fno_type_pli

fo_a1

fo_a2

fo_cad_tps_b

fo_cadence

fo_ch

fo_coefficient

fo_devis

fo_dif

fo_effectif

fo_entite

fo_etat

fo_formule

fo_fournisseur

fo_frais

fo_fv

fo_g_f

fo_g_v

fo_lie_a_ref

fo_ligne

fo_ligne_dec

fo_ligne_pos

fo_machine

fo_marge

fo_nb_poses

fo_num_1

fo_num_2

fo_num_3

fo_num_4

fo_num_ordo

fo_num_passage

fo_num_reference

fo_numphase

fo_ope

fo_prix_bloque

fo_pv

fo_qte_forcee

fo_quantite

fo_quantite_hg

fo_quantite_hgf

fo_quantite_tgc

fo_sdevis

fo_sec

fo_serial

fo_soc

fo_sop

fo_tot_qte

fo_tot_tps

fo_total

fo_tpsstd

fo_type_ligne

fo_unicad

fo_unite

fo_unite_gache

fo_v1

fo_v10

fo_v2

fo_v3

fo_v4

fo_v5

fo_v6

fo_v7

fo_v8

fo_v9

fs_codeprod

fs_coefficient

fs_devis

fs_entite

fs_etat

fs_formule

fs_fournisseur

fs_frais

fs_frais_f

fs_frais_v

fs_gache_fix

fs_gache_var

fs_lib1

fs_lib2

fs_lie_a_ref

fs_ligne

fs_ma_f

fs_ma_v

fs_num_1

fs_num_2

fs_num_3

fs_num_4

fs_num_ordo

fs_num_reference

fs_numphase

fs_pr_f

fs_pr_v

fs_prix_bloque

fs_pv_f

fs_pv_v

fs_qte_forcee

fs_quantite

fs_quantite_fix

fs_quantite_hg

fs_quantite_hgf

fs_quantite_tgc

fs_quantite_var

fs_sdevis

fs_soc

fs_total

fs_total_f

fs_total_v

fs_type_ligne

fs_uniprix

fs_unite_cad

fs_unite_gache

fs_v1

fs_v10

fs_v2

fs_v3

fs_v4

fs_v5

fs_v6

fs_v7

fs_v8

fs_v9

ul_actif

ul_cc_frais

ul_cc_montant

ul_classe

ul_cp_frais

ul_cp_montant

ul_defprod

ul_desig

ul_diffparam

ul_dpl_cod_regroup

ul_dpl_exclure

ul_dpl_mod_rupt

ul_dpl_qte_retenue

ul_edition

ul_fab_cod_regroup

ul_fab_ope

ul_fab_qte_retenue

ul_fab_sec

ul_fab_sop

ul_for_coeff_1

ul_formule

ul_formule_cad_1

ul_formule_cad_2

ul_formule_num_1

ul_formule_num_2

ul_formule_num_3

ul_formule_num_4

ul_formule_ut

ul_formules_v1

ul_formules_v2

ul_interprete

ul_lcom

ul_lib1

ul_lib10

ul_lib11

ul_lib12

ul_lib2

ul_lib3

ul_lib4

ul_lib5

ul_lib6

ul_lib7

ul_lib8

ul_lib9

ul_lib_cad_1

ul_lib_cad_2

ul_lib_cad_3

ul_lib_cad_4

ul_lib_num_1

ul_lib_num_2

ul_lib_num_3

ul_lib_num_4

ul_libelle

ul_nature_frais

ul_nature_montant

ul_ope

ul_ordre

ul_par_cc_v1

ul_par_cc_v2

ul_par_coeff

ul_param

ul_param_cc

ul_parcad

ul_parv1

ul_parv2

ul_pc_frais

ul_pc_montant

ul_phase

ul_phase_ut

ul_quoi

ul_sclasse

ul_sec

ul_soc

ul_sop

ul_ssf

ul_tarif_achat

ul_tarif_vente

ul_typ1

ul_typ2

ul_typmac

ul_uni_prod

gb_adl

gb_annul

gb_blv

gb_cariste

gb_cde

gb_code_client

gb_code_tarif

gb_cout_charg_prev

gb_cout_lot

gb_cout_reel

gb_date_crea_aff

gb_date_dbt_chgt

gb_date_dem_trsft

gb_date_dep_usine

gb_date_fin_chgt

gb_date_pres_dem

gb_date_pres_reel

gb_date_rep_trans

gb_date_valid_def

gb_devise_cout

gb_env_tarif

gb_etat_affret

gb_forcage_cout

gb_frais_suppl

gb_groupage_edite

gb_heure_crea_aff

gb_heure_dbt_chgt

gb_heure_dem_trsft

gb_heure_dep_usine

gb_heure_fin_chgt

gb_heure_pres_dem

gb_heure_pres_reel

gb_heure_rep_trans

gb_km_prev

gb_lieu_rgt1

gb_ligblv

gb_ligcad

gb_ligcde

gb_ligne_groupage

gb_ligseq

gb_mag_depart

gb_metr_lin_lot

gb_metr_lineaire

gb_metr_reel

gb_nb_pal_prev

gb_no_groupage

gb_poids_prev

gb_preparateur

gb_qte_fact_cout

gb_qte_prev

gb_qte_reelle

gb_quai

gb_reponse_trans

gb_site_prod

gb_solde_prev

gb_statut

gb_tport

gb_trans

gb_transfert_1

gb_transfert_2

gb_trsp

gb_type_vehicule

gb_unite_fact_cout

gb_vehicule

gb_vehicule_prev

gb_zone_tarifaire

hp_a1

hp_annule

hp_c1

hp_cde

hp_cl2

hp_client

hp_cs1

hp_cs2

hp_cs3

hp_cs4

hp_d1

hp_date

hp_date_enr

hp_datecde

hp_dep

hp_fam

hp_lcde

hp_libelle

hp_lig_fac

hp_num_fac

hp_produit

hp_ref

hp_repr

hp_seq

hp_sfm

hp_soc

hp_type

hp_var_prod

hp_z1

hp_z2

hp_z3

hp_z4

hp_z5

hp_z6

hp_z7

hp_z8

hp_z9

hp_z10

hp_z11

hp_z12

hp_z13

hp_z14

hp_z15

ss_anul

ss_cadence

ss_ch

ss_cletarifaire

ss_cortps

ss_dif

ss_ff

ss_formule_cad

ss_fourmule_tps

ss_g_fix

ss_g_var

ss_i1

ss_i2

ss_i3

ss_i4

ss_mac

ss_march

ss_marps

ss_num

ss_ope

ss_param

ss_persup

ss_pvch

ss_pvps

ss_s1

ss_s2

ss_s3

ss_sec

ss_secana

ss_soc

ss_sop

ss_tps

ss_tri

ss_ttr

ss_txps

ss_ucad

ss_uqte

ss_utilisation

ss_z1

ss_z2

ss_z3

ss_z4

kp_de_cam_rempli

kp_de_ccliliv

kp_de_cclipdo

kp_de_cdev

kp_de_cmotdeccli

kp_de_crempri

kp_de_crep

kp_de_crepcli

kp_de_ctypcorcli

kp_de_ddemcli

kp_de_drepcli

kp_de_env_mat

kp_de_env_ope

kp_de_kcom

kp_de_kparmaroff

kp_de_kprifid

kp_de_ldemcli

kp_de_lnomcorcli

kp_de_lrefembcli

kp_de_lvotrefdem

kp_de_mprivenneg

kp_de_ndemcli

kp_de_noffven

kp_de_noffvenhis

kp_de_nrefembcli

kp_de_ntelcorcli

kp_de_qrefembdem

kp_de_qrefembdem2

kp_de_qrefembdem3

kp_de_qrefembdem4

kp_de_qrefembdem5

kp_de_qrefembdem6

kp_de_site

kp_de_soc

kp_de_tport

kp_of_cser

kp_of_ddebvaloff

kp_of_dfinvaloff

kp_of_ndemcli

kp_of_noffven

kp_of_nrefembkp

kp_of_qrefemboff

kp_of_qtealiv

kp_of_soc

le_client

le_langue

le_libelle

le_libelle2

le_libpar1

le_prod

lin_annule

lin_article

lin_controleur

lin_date_cloture

lin_date_controle

lin_date_creation

lin_deb_valid

lin_fin_valid

lin_fournisseur

lin_litige

lin_lot_indus

lin_ref_four

lin_site_prod

lin_soc

lin_sous_statut

lin_statut

lin_type_enr

m0_actif

m0_anul

m0_atelier

m0_ccout

m0_cdt_en_ligne

m0_coder

m0_coef_mino_num

m0_coef_mino_perfo

m0_coef_mino_rain

m0_convertible

m0_decoupe

m0_desig

m0_developp

m0_dorure

m0_epama

m0_epami

m0_fict

m0_fin_pression

m0_foulage

m0_gaufrage

m0_gommage

m0_grama

m0_grami

m0_ilot

m0_impmasm

m0_impmast

m0_impmism

m0_impmist

m0_mac_vhl_ac

m0_mac_vhl_of

m0_mac_vhl_uv

m0_machine

m0_max_1

m0_min_1

m0_nb_cou_max

m0_nb_cou_min

m0_nb_gp_vernis_uv

m0_nb_numero

m0_optimisation

m0_ordre

m0_papmast

m0_papmism

m0_papmist

m0_par_convert

m0_perfo

m0_pli_en_ligne

m0_poudrage

m0_ppmasm

m0_ppmast

m0_ppmism

m0_ppmist

m0_qte_rou_max

m0_qte_rou_min

m0_rainage

m0_ralentisseur

m0_reference

m0_retiration

m0_sit_prod

m0_soc

m0_surf_tot_max

m0_surf_tot_min

m0_surf_uni_max

m0_surf_uni_min

m0_temps_max

m0_temps_min

m0_typmac

m0_vernis_acr

m0_vernis_off

m0_vernis_uv

m0_za

m0_zb

m0_zc

m0_zpar1

m0_zpar2

m0_zpar3

m0_zpar_a

m0_zpar_b

m0_zpar_c

Accès aux différents articles du devis onduleur :

mp_coiffe

mp_com_car

mp_pal

mp_pap_pre

mp_pf

mp_qua_car

mp_ref_arc

mp_ref_imp

mp_ref_kp

mp_ref_pre

mp_abc

mp_affect

mp_afnor

mp_alerte

mp_ana

mp_anu

mp_at1

mp_at2

mp_cdc

mp_certification

mp_cfrais

mp_cli

mp_code

mp_code_origine

mp_coefdiv_ffix

mp_cond

mp_controle

mp_coul

mp_cperte

mp_cpta

mp_cptv

mp_cs1

mp_cs2

mp_cs3

mp_cs4

mp_dat_deb_valid

mp_dat_fin_valid

mp_date

mp_delmoy

mp_derent

mp_derinv

mp_dermvt

mp_dersor

mp_des

mp_des2

mp_devis

mp_dt1

mp_dt2

mp_dt3

mp_dt4

mp_dt5

mp_dt6

mp_dt7

mp_dt8

mp_entite

mp_etat_bes

mp_fam

mp_fconv

mp_fconv2

mp_foucli

mp_gencod

mp_gestionnaire

mp_hau

mp_itf14

mp_lar

mp_libre

mp_lon

mp_marg

mp_minfou

mp_mp

mp_multi_lieux

mp_ndm

mp_pa

mp_pamp

mp_param

mp_poids

mp_pr

mp_pr_fixe

mp_prod_generique

mp_pv

mp_pv2

mp_qteeco

mp_qtemini_cdeclt

mp_qualite

mp_qualite_matiere

mp_reap

mp_remp

mp_rgt1

mp_rgt2

mp_rgt3

mp_sbes

mp_scdef

mp_sdevis

mp_sdisp

mp_sfm

mp_site_prod

mp_smaxi

mp_smini

mp_sphy

mp_sres

mp_ssim

mp_suistk

mp_tva

mp_tval

mp_ua

mp_uv

mp_uvente

mp_z1

mp_z2

mp_z3

mp_z4

mp_z5

Matière générique servant à générer l'article.

mg_abc

mg_affect

mg_afnor

mg_alerte

mg_ana

mg_anu

mg_at1

mg_at2

mg_cdc

mg_cfrais

mg_cli

mg_code

mg_code_origine

mg_coefdiv_ffix

mg_cond

mg_controle

mg_coul

mg_cperte

mg_cpta

mg_cptv

mg_cs1

mg_cs2

mg_cs3

mg_cs4

mg_dat_deb_valid

mg_dat_fin_valid

mg_date

mg_delmoy

mg_derent

mg_derinv

mg_dermvt

mg_dersor

mg_des

mg_des2

mg_devis

mg_dt1

mg_dt2

mg_dt3

mg_dt4

mg_dt5

mg_dt6

mg_dt7

mg_dt8

mg_entite

mg_etat_bes

mg_fam

mg_fconv

mg_fconv2

mg_foucli

mg_gencod

mg_gestionnaire

mg_hau

mg_itf14

mg_lar

mg_libre

mg_lon

mg_marg

mg_minfou

mg_mp

mg_multi_lieux

mg_ndm

mg_pa

mg_pamp

mg_param

mg_poids

mg_pr

mg_pr_fixe

mg_prod_generique

mg_pv

mg_pv2

mg_qteeco

mg_qtemini_cdeclt

mg_qualite

mg_qualite_matiere

mg_reap

mg_remp

mg_rgt1

mg_rgt2

mg_rgt3

mg_sbes

mg_scdef

mg_sdevis

mg_sdisp

mg_sfm

mg_site_prod

mg_smaxi

mg_smini

mg_sphy

mg_sres

mg_ssim

mg_suistk

mg_tva

mg_tval

mg_ua

mg_uv

mg_uvente

mg_z1

mg_z2

mg_z3

mg_z4

mg_z5

p2_aanu

p2_actif

p2_alph

p2_alph3

p2_alph4

p2_amod

p2_anul

p2_classe

p2_code

p2_com

p2_libc

p2_libl

p2_ordre

p2_sclasse

p2_soc

p2_type

p2_zc1

p2_zc2

p2_zc3

p2_zc4

so_adr1

so_adr2

so_ape

so_bd

so_cle

so_code

so_codp

so_com1

so_com2

so_compta

so_d_exe

so_date_fin_valid

so_devise

so_domb

so_etiq

so_f_exe

so_id_entreprise

so_insee

so_jda

so_jdv

so_jur

so_langue

so_options

so_passe

so_pays

so_rais

so_rcs

so_sign

so_siret

so_tel

so_telcop

so_telex

so_vil

s0_adl

s0_affect

s0_anu

s0_brc

s0_cdc

s0_cde

s0_cdefou

s0_classe_mvt_vsw

s0_cli

s0_conteneur_actif

s0_date_deb

s0_date_fin

s0_datm

s0_employe

s0_es

s0_etat

s0_etat_bes

s0_fou

s0_frais

s0_id_cont_transf

s0_id_conteneur

s0_integre

s0_libre

s0_ligcad

s0_ligcde

s0_lot

s0_lot_indus

s0_num

s0_prix

s0_prod

s0_qte

s0_qte_unite_2

s0_qteclient

s0_reap

s0_rgt1

s0_rgt2

s0_rgt3

s0_site_prod

s0_soc

s0_ssf

s0_stkres

s0_typ

sl_article

sl_date1

sl_date2

sl_date3

sl_date4

sl_date_actualis

sl_fam

sl_heure_actualis

sl_lot

sl_mode_de_suivi

sl_nb_pal_phys

sl_poids_brut

sl_poids_net

sl_qte_disp

sl_qte_ent_prev

sl_qte_pal_phys

sl_qte_phys

sl_qte_sor_res

sl_rgt1

sl_rgt2

sl_rgt3

sl_sfm

sl_soc

sl_suivi_palette

sl_surf_brut

sl_surf_net

sl_transfert_cube

sl_valeur

tr_adr

tr_ajout_pr_fixe

tr_anu

tr_bascule_euro

tr_binf

tr_bsup

tr_cat

tr_char

tr_cle

tr_cli

tr_commentaire

tr_datd

tr_datf

tr_devise

tr_devise_av_euro

tr_fam

tr_feuille_bobine

tr_fixe

tr_mat

tr_note_1

tr_note_2

tr_num_binf

tr_num_bsup

tr_prixnet

tr_sfm

tr_site

tr_tar

tr_unite

tr_va

tr_val

tr_val2

tr_val_av_euro

Génération de fichiers

Les notes suivantes sont utilisables dans plusieurs visualisations.

Toutes les visualisations n'ont pas toutes les notes. Voici un tableau récapitulatif.

 | v_cdem | v_jbl | v_jdv | v_lieu_rgt | v_mat | v_stk0 | v_suivi_vehicules | v_tar0
TEXT_LIBRE_1_V_T_F |  | X | X | X | X | X | X | X
FIN_FIC_1_T_F |  | X | X |  |  | X |  |
SEP_VISU_TYPE_F_CHAR | X | X | X | X | X | X | X | X
TITRE_VISU_TYPE_F | X | X | X | X | X | X | X | X
CLIPPED_LIGNE_EF |  |  | X | X | X | X | X | X

Notes

TEXT_LIBRE_1_V_T_F | Texte libre qui sera mis en première ligne. En mode fichier uniquement Dans le texte libre, pour faire apparaître des données des tables, il faut entourer le nom du champ avec des %. Exemple : %so_sai% (so_sai étant un champ de la table soc). Les noms de zones disponibles sont indiqués sous ce tableau. Zones communes : – date – heure au format hh :mm – cpt1 compteur. Celui-ci s'incrément depuis la zone numérique 1 du paramètre de lancement. – espace*α où α est un nombre entier (exemple : %espace*10% créera 10 espaces) Exemple : Extraction du %date% à %heure% Pour imposer une longueur et un format de champ : %nomchamp*longueurchamp*format% Exemples %so_sai*40% la zone prendra 40 caractères dans le fichier %so_sai*[2,40]% la zone prendra du caractère 2 à 40. %cpt1*3*&&&% le compteur sera sur trois caractères avec un format suivant : 001, 002, etc. Remarque : le format n'est pas obligatoire sauf pour les numériques, dates, etc.
FIN_FIC_1_T_F | Texte libre qui sera mis en fin de fichier. En mode fichier uniquement Même syntaxe que la note TEXT_LIBRE_1_V_T_F
CLIPPED_LIGNE_EF | 21 Supprime les blancs de droite après chaque champ dans les textes libres (O/N, O par défaut)
SEP_VISU_TYPE_F_CHAR | 21 N'encadrer que les colonnes de type alphanumériques (mode fichier) Cette note permet aussi de clipper toutes les zones alphanumériques (on n'a pas forcément alors une taille fixe pour la zone). Cette note ne positionne pas le dernier séparateur en fin de ligne.
TITRE_VISU_TYPE_F | 21 Insertion d'une ligne comportant les titres de chaque colonne (mode fichier) (O/N, N par défaut)

Noms de zones disponibles, triés par ordre alphabétique de tables puis de zones

Table action_evt - Zones disponibles

Table affaire - Zones disponibles

Table b_rec_ret_d - Zones disponibles

Table b_rec_ret_e - Zones disponibles

Table blv1 - Zones disponibles

Table blv2 - Zones disponibles

Table bon_retour_cli_1 - Zones disponibles

Table bon_retour_cli_2 - Zones disponibles

Table cde1 - Zones disponibles

Table cde2 - Zones disponibles

Table cde4 - Zones disponibles

Table cde5 - Zones disponibles

Table cde8 - Zones disponibles

Table cde9_e - Zones disponibles

Table cde9_l - Zones disponibles

Table cdf1 - Zones disponibles

Table cdf2 - Zones disponibles

Table cli - Zones disponibles

Table cli2 - Zones disponibles

Table corres - Zones disponibles

Table dem_achat_ent - Zones disponibles

Table ecma - Zones disponibles

Table emp - Zones disponibles

Table envoi_fax_email - Zones disponibles

Table fab0 - Zones disponibles

Table fac0 - Zones disponibles

Table fac1 - Zones disponibles

Table fac2 - Zones disponibles

Table facfou0 - Zones disponibles

Table facfou1 - Zones disponibles

Table fle_2 - Zones disponibles

Table fle_com - Zones disponibles

Table fle_combi - Zones disponibles

Table fle_dec - Zones disponibles

Table fle_frais - Zones disponibles

Table fle_gam - Zones disponibles

Table fle_imp - Zones disponibles

Table fle_mat - Zones disponibles

Table fle_nom - Zones disponibles

Table fle_ope - Zones disponibles

Table fle_str - Zones disponibles

Table formules - Zones disponibles

Table groupage_bl - Zones disponibles

Table hist_pr - Zones disponibles

Table i_postes - Zones disponibles

Table kp_demcli - Zones disponibles

Table kp_offre - Zones disponibles

Table lib_etr - Zones disponibles

Table lot_industriel - Zones disponibles

Table mac0 - Zones disponibles

Table mat - Zones disponibles

Table mat_gen - Zones disponibles

Table par02 - Zones disponibles

Table soc - Zones disponibles

Table stk0 - Zones disponibles

Table stk_lot_lieu - Zones disponibles

Table tar0 - Zones disponibles