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1. Overview
Direct Planning is a scheduling software designed for the industry, project management and service. 
Choosing the right edition for your sector provides an efficient management of various resources such 
as machines (in Industry mode), rooms (in Service mode) or employees (in Project mode).

Direct Planning’s interface includes a Gantt visualisation which allows to view quickly and clearly the 
scheduled jobs.

In addition to supporting data imports and exports from/to your information system (ERP, CAPE), Direct 
Planning can also work independently, notably for calculating setting times and work rates.

This documentation will allow you to familiarise yourself with Direct Planning, starting with its instal-
lation and the discovery of our demonstration schedules. We will then discover Direct Planning’s key 
principles and see how to create schedules and plan jobs with Direct Planning. Last, we will explain how 
to interface your ERP with Direct Planning and address Direct Planning’s main administrative tasks.

This documentation is aimed primarily at new users of Direct Planning. If you already know Direct 
Planning and wish to discover the new features included in our last update, we invite you to read the 
following page: http://www.directplanning.com/en/news/news-product�

To help you navigate through this documentation, the sections specifically dedicated to the administration 
and useful tips are highlighted in the following boxes:

AdministrAtion 

The sections reserved to the Direct Planning administrator are displayed in this box.

our Advice 

Our useful tips are displayed in this box.

http://www.directplanning.com/en/news/news-product
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2. Installing and exploring Direct Planning

2.1. Installing Direct Planning
To view the technical requirements for installing Direct Planning, please see the FAQ available on Direct 
Planning website at http://www.directplanning.com/en/faq/�

2.1.1. Setup architectures

There are 3 architectures available for installing Direct Planning, which you will choose depending on 
your infrastructure and/or your needs.

Minimalist architecture

  
Schedule

Planning manager station

Direct
Planning

 Benefits:

• No server required

our Advice 

Keep this configuration for environments which have a very limited number of users (2 or 3 maximum).

Direct Planning is installed on the 

planning manager station.

The planning database is hosted 

on this station.

The planning manager has a fast 

station (Core i5 class CPU and 

at least 4-8  GB RAM) preferably 

equipped with two screens. 

Direct Planning is installed on each 

user station.

Users access the schedule hosted 

on the planner station.

Caution: The planning manager 

station must be running to ensure 

the availability of the schedule to 

other users.

Each backup of the schedule cre-

ates a time-stamped backup copy 

hosted in a shared folder on a serv-

er of the company.

If the planning manager station 

crashes, the last backup copy re-

stores the planning without infor-

mation loss.

   

User stations

Direct
Planning

Direct
Planning

Direct
Planning



Centralisation of backups in a 
shared folder

*.DPL2

http://www.directplanning.com/en/faq/
http://www.directplanning.com/fr/faq
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Dedicated server architecture



Centralisation of backups in a 
shared folder

*.DPL2   

User stations

Direct
Planning

Direct
Planning

Direct
Planning

Planning 
manager


Planning

Server* dedicated to the 
planning database

* physical or virtual

 
Direct

Planning

 Benefits:

• Scalable architecture
• Schedule available even if the planning manager station is 

powered off�

Direct Planning is installed on a 

physical or virtual dedicated serv-

er�

The planning database is hosted 

on this server.

It is best that this server and users 

share the same site (shorter access 

times).

 

Direct Planning is installed on each 

user station (in “lightweight” mode). 

Users access the schedule hosted 

on the dedicated server.

The planning manager has a fast 

station (Core i5 class CPU and 

at least 4-8 GB RAM) preferably 

equipped with two screens.

Each backup of the schedule cre-

ates a time-stamped backup copy 

hosted in a shared folder on a serv-

er of the company.

If the database server crashes, 

the last backup copy restores the 

schedule without information loss.
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Centralisation of backups in a 
shared folder

*.DPL2   

User stations

Direct
Planning

 

TSE server* dedicated to the 
planning database

Direct
Planning * physical or virtual


Planning

Dedicated TSE server architecture

Direct Planning is installed on a 

physical or virtual dedicated TSE 

server�

The planning database is hosted 

on this server.

It is best that this server and users 

share the same site (shorter access 

times).

 

Direct Planning is not installed on 

user stations: Users access the 

schedule using a “remote desktop” 

connection or via a “published ap-

plication”.

Each backup of the schedule cre-

ates a time-stamped backup copy 

hosted in a shared folder on a serv-

er of the company.

If the database server crashes, 

the last backup copy restores the 

schedule without information loss.

 Benefits:

• Scalable architecture
• Schedule available even if the planning manager station is 

powered off�
• Easier monitoring of updates (only 1 centralised installation 

of Direct Planning to update + the planning manager station, 
where appropriate).

our Advice 

You can still install Direct Planning locally on the planning manager station (powerful station and short-
er response times).

Planning 
manager
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2.1.2. Schedule types
According to the needs related to your activity, Direct Planning comes in 3 editions: Service, Project and 
Industry.

Service mode

You have simple requirements: for example, you will implement a schedule for booking rooms, vehi-
cles, appointments or vacations.

Choose the Service mode, suitable for service activities.
Numerous elements, data and colours can be customised to adapt Direct Planning to your business.

Project mode

You need to manage successions of jobs as well as planned and actual durations?

The Project mode is suitable for schedules requiring links between various jobs: for example for build-
ing projects, deploying IT resources or monitoring marketing milestones.

Industry mode

You need to manage quantities, setting times and work rates?

Direct Planning is also particularly suited for the industrial sector: it supports linear or complex routes 
subject to time constraints (earliest start and latest end).
Its integrated manual planning assistance respects automatically these constraints.
The Industry mode is particularly well suited for SMIs looking to plan and track their production with the 
best levels of accuracy.
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2.1.3. 2.1.3. Comparative table of offers by features

Type of schedule authorised according to offer Service Project Industry

Creation of a Service schedule   

Creation of a Project schedule   

Creation of an Industry schedule   

Features Service Project Industry

Login/password-protected access   

Customisable data depending on your business   

Customised screens by user   

Customisable visual indicators   

Lockable job   

Multiple planning alerts   

Calendar by resource/machine   

Customisable data lists   

Export to Excel/OpenOffice   

Import/Export of data with an ERP   

Links between jobs/operational routes   

Time constraints (earliest start, latest end)   

Planning assistance with respect of constraints   

Tracking of planned/actual times   

Job progress status   

Workload histogram   

Production operations based on machines   

Production technical data   

Setting times and work rates defined by machine/operation   

Automatic calculation of the jobs operational durations   

Production declaration by the machine operator   

Production declaration through dialogue with the ERP   
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2.2. Discovering our demonstration schedules
To access our demonstration schedules, open Direct Planning and follow these steps:

1. Click on File > Open a demonstration schedule�

2. Select An Industry-type demonstration schedule 
and click on Next�

3. Choose option 1 - Generic for industry and click 
on Open this schedule. Enter your login and 
password and click on OK.  

The following window opens:
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The Direct Planning window consists of 6 main areas:

1 Menu bar/Toolbar: gives access to all Direct Planning functions, grouped by thematic tabs.

2 Time scale: used to find your way in the schedule and place your jobs where you want.

3
Projection: defines what is displayed in the schedule lines.
In the context of a shop floor, the projection usually displays the machines grouped by sections.

4 The schedule itself. It is the workspace where your jobs are organised.

5
Status bar: shows the name of the schedule, its location, the current user, the access type and 
the view currently displayed.

6 The floating alert window gives an holistic view of job alerts.

The following sections discuss in details each of these areas.

1

6

5

4

3

2
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2.2.1. The menu bar and toolbar

At the very top, the typical icons used in all applications:

In the middle, the menu itself:

Open a schedule

Open a recent item

Save schedule

Cancel/Redo last action

Print preview

Print schedule

◄  The File menu opens a drop-down menu containing the 
most used commands.

▼ The other menus open their own toolbar, like the Data menu 
below:
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2.2.2. The time scale

The time scale is used to find your way in the schedule and place your jobs where you want.

Sample time scale (your schedule time scale may look different than the one below, which has an aver-
age zoom level). Changing the zoom level changes the colour of the time scale:

A When hovering over the time scale, the pointer looks like this: 

B
At the same time, a tooltip displays the week, date and time matching the cursor position in 
the schedule.

C
Moreover, a vertical line across the schedule follows the cursor movements to help you posi-
tion jobs accurately.

 

To benefit from the best balance between amount and readability of information displayed, the time 
scale can be stretched or contracted.
To do this, left-click and read the tool tip:

It shows the size of the scale, 100 %. This is the size of the scale currently displayed.
Move the cursor to the right (or press the + key of the keypad) to stretch the scale (values greater than 
100 %).
Move the cursor to the left (or press the - key of the keypad) to contract the scale (values lower than 
100 %).

{Time scale
A

C

B
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The objective is to find the best balance between amount and readability of information displayed:

The more you stretch, the less information displayed but more readable.
The more you contract, the more information displayed but less readable.

our Advice 

You can hide certain parts of the time scale, such as the weekends. See section 4.3.11., Creating display 
modes,for more information.

Note
Resizing the time scale is a temporary action: the adjustment is not saved.

Time scale values are defined by the administrators in the display modes. When selecting other display 
modes, you can have other time scales.
The scaling is purely visual, without any impact on the arrangement of jobs in the schedule.

On the schedule main screen, press F3 and F4 to toggle between the time scales configured by the ad-
ministrator:

It is also possible to right-click on the time scale to choose between these preconfigured scales:

◄ This context menu also offers the ability to navigate 
to the date of your choice or return to the current date.
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Planning zoom

You can zoom in and out of the schedule by holding the Ctrl key while using the mouse wheel.
This can also be performed by changing the overall zooming level, to the right of the Home toolbar:

Used alone, the mouse wheel makes a vertical scroll in the schedule. It has no effect of the schedule fits 
the height of the window.
While holding the Alt key, the mouse wheel makes a horizontal scroll in the schedule.
While holding the Ctrl key, the mouse wheel zooms in and out of the schedule (variation of the“Overall 
zoom”).

Note
The zoom percentage can be forced in the configuration of display modes.
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2.2.3. The projection

Display modes (defined by the administrator) allow the creation of projections for each and every user.

The projection of a schedule is displayed vertically, on the left side of the Direct Planning window.

• The planning manager will choose a display mode offering a projection with machines grouped by 
sections, well-suited for machine scheduling.

• The sales rep will prefer a display mode offering a projection with orders grouped by customers: 
this projection allows him to view the all orders placed by a customer if the latter enquired about 
the status of his orders.

• Other users will see the schedule differently with display modes implementing different projections.

To select a projection, go to the Display menu and open the list of display modes:

Right-clicking on a section opens the following context menu:

The projection by sections 
and machines is usually the 
most suitable for the planning 
manager ►

The “Milling” section

The machines in 
the “Milling” section

The jobs “to schedule” for 
“Milling machine 2”.

This is also where new jobs are imported 
from an ERP.

◄ These functions are explained in section 5, Scheduling 
with Direct Planning, of this documentation.
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Right-clicking on a machine opens the following context menu:

◄ These functions are explained in section 5, Scheduling 
with Direct Planning, of this documentation.
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2.2.4. The schedule

The planning space fills the major part of the screen.
It is the workspace where your jobs are organised.
Each rectangle represents an activity planned on a machine at a given time.
In Direct Planning, we use the generic term “Job”.
  

Illustration Designation

A Job not started

B
Job started (without progress status): 
yellow bar above the job.

C

Job started (with progress status): the blue 
bar shows the progress of the job, when 
produced quantities are declared in Direct 
Planning.

D

C

IJ

E

F

G

A

B

H
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Illustration Designation

D
Job completed: content, progress status 
and flags greyed out.

E Alert message on a job.

F Flag on a job.

G
The padlock indicates that the job is 
locked.

H
Setting duration is identified by a black 
proportional bar under the job. 

I
Tooltip: pops up when hovering over a 
job.

J Idle area.

When there are routes, the schedule also shows the links between jobs for the selected jobs (more 
information about links and routes in section 5.4, Creating routes):

◄ Route highlighted (the other jobs are 
greyed out).
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CONFIGURABLE
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PROCESS
INFORMATION

FLAGSENTITIES
(Customer, WO, etc.)

CONFIGURABLE
AREAS

ENTITIES

CONFIGURABLE
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FLAGS

CONFIGURABLE
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PROC. INFO.

3. Understanding Direct Planning’s core notions

3.1. Overall diagram
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3.2. Key terms

The following table defines the key terms used in the diagram above.
See our glossary in Annex B to get a reference list of terms used in Direct Planning

Term Definition

Compatible machines Based on your business rules and data, Direct Planning can tell 
whether or not a job can be moved to another machine. Moving a 
job to an incompatible machine displays a warning.

Configurable areas Certain standard data in Direct Planning (machines, jobs, mul-
ti-status flags, entities and Process Information) can be comple-
mented by configurable areas which are customisable according 
to your needs.

Entities Entities are data lists which evolve with your activity (Sales repre-
sentatives, Customers, Orders,…). 

Entities must first be configured according to your needs, allowing 
to benefit from a list for each data.

Flags Flags are coloured and sometimes hatched bullets located above 
and/or on the right of jobs.
They serve the same purpose as paper clips and other stickers put 
on traditional wall schedules.

Jobs A job represents an occupation or activity at a given time, for a 
given resource.

Links The succession of jobs within a route is materialised by links 
(coloured arrows).

Machines Machines are the foundation of the Industry planning.  Please 
note that in Project and Service modes, machines are replaced by 
resources (e.g. rooms, employees, etc.).

Operations Your machines perform operations (e.g. this machine makes 
die-cutting, that machine makes bonding, etc.).

Process information Process Information is technical data whose display is limited to 
certain machines.

Reference data Reference designates data lists represented by a code, a desig-
nation and a colour. (e.g. lists of sales representatives, product 
families, cutting dies, colours, etc.).

Sections Sections are groups of machines.

Working units Working units express the unit of measure for your machines. 

Examples: panels, sheets, kilograms, copies, linear feet.
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4. Creating a schedule
4.1. Key steps
Our creation guide is based on the Industry schedule, as it is the most comprehensive mode. Click on 
each step to access the corresponding section.

4.1.1. Creating a blank schedule

To create a new schedule, you must connect to the machine which will host it. Any newly created sched-
ule will be saved in a local database on the machine running Direct Planning.

Then, other stations can remotely access or modify this schedule.

AdministrAtion 

To enter configurable areas for your machines, click on Configuration > General configuration. 

Follow the steps below to create a blank schedule:

1. Creating a 
blank schedule

2. Creating 
sections

3. Creating 
machines

4. Configuring 
technical elements

5. Configuring reference 
data

6. Configuring 
entities

7. Configuring 
Process Info.

8. Creating 
operations

9. Attaching 
operations/ machines

10. Configuring 
programmable formulas

11. Creating display 
modes 12. Creating users 13. Creating 

configurable lists 14. Saving the schedule

1. Launch Direct Planning and click on 
File  > New to open the schedule 
creation wizard.

Select your planning type.

Click on Next�

2. Choose your template in the list of 
preconfigured schedules.

 
 Since you are creating a schedule from 

scratch, select Blank schedule - No pre-
configured item�
Click on Next�
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3. Name your new schedule.
 

Give it a self-explanatory name.
Users will see this name when opening 
the schedule.
Click on Next�

When you click on Finish, the new schedule opens:

We are now going to configure this schedule.

4. Your planning is ready for use.

It is loaded in memory but not yet saved 
on your machine.

After clicking on Finish, save it on your 
machine
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4.1.2. Creating sections

Before creating machines, we are first going to create sections to group them. Click on Data > Sections:

Enter a code and a designation for your new section, and give it a colour:

 Default colour

 Selection in the picker pallet

Click on Save and Next to create other sections or Save and Close to return to the list of sections. In our 
example, we created 3 sections: Printing, Die-cutting and Gluing:

Change the associated colours

 
Search for jobs related to all machines of this section

 
Display the list of machines for this section

Click on New to open the section creation 
window:

◄ In addition to being able to print, export 
and add/modify/delete sections, you can:
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4.1.3. Creating machines

our Advice 

When you create machines, start by defining configurable areas. Use these to customise the informa-
tion related to your machines.

AdministrAtion 

To enter configurable areas for your machines, click on Configuration > General configuration:

The Machines menu offers the possibility to set a maximum of 10 configurable areas, which will be 
available when creating machines:

In the example above, we set the first configurable area by giving it a designation (Max cross dimensions 
and selecting a type (Integer) in the drop-down menu. Consequently, when adding a machine (Data > 
Machines tab), we will be able to enter the Max cross dimensions as additional data:

From this screen, you can also enable the automatic attribution of colours when creating machines/
sections/working units/operations.
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To continue and create your machines, click on Data > Machines:

Note that the Max cross dimensions previously configured as Configurable area 1 is displayed as a col-
umn in the list of machines. When you have created your machines, you will then be able to sort them 
by ascending (or descending) Max cross dimensions accepted.

You can choose the columns to display in this window by right-clicking on the header of any column.

Click on New to create a new machine.

our Advice 

We strongly advise you to chack the box Enable automatic calculation of durations for this machine to 
have Direct Planning calculate durations. Note that this function is entirely compatible with the import 
of data from an ERP.

◄ The machine creation/modification window consists of 

3 parts:

• Enter the machine identification information (code and 

designation) in the upper part and pair the machine 

with a section and a colour.

• Under the Technical data area, enter the working unit 

of quantity to produce (e.g. sheets, boxes or cases), 

as well as the default operation (where appropriate). 

When Direct Planning calculates durations, it is also 

required to enter the working unit of operative quantity 

(quantity processed by the machine) as well as the 

working unit in which the work rate, the average setting 

time, the average work rate and the average variable 

waste will be expressed.

• Data contained in the Additional data area depend on 

the configurable areas set.
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When you are done creating sections, click on Close. Your newly created sections now appear on the 
left of the Gantt:

These sections are still empty. We are now going to allocate machines to them.



31

Direct Planning 3.4 Creating a schedule : Creating machines

This way, we created 8 machines (distributed in 3 sections):

Upon validation, they also appear on the left side of the Gantt:

our Advice 

When creating machines (or other data such as operations, entities, etc…) sharing common characteristics, 
save time by creating new machines from existing ones: Right-click on the machine to duplicate in the 
list of machines and select Duplicate…
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Considerations on working units

Why indicate the working unit of quantity to produce when entering machines?

1. This creates a first level of compatibility. In the schedule, moving a job towards a machine with a 
different working unit of quantity to produce displays a warning. We will see that operations offer a 
second level of compatibility.

2. This can be leveraged to specify the average setting time and the average work rate, already dis-
cussed.

Direct Planning includes a list of standard working units which can be displayed/modified using the 
Data > Working units menu:

◄ This screen allows the creation/modification/
deletion of working units.

After selecting a working unit, you can also 
click on Jobs, Machines and Opérations to 
display the associated elements.
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4.1.4. Configuring technical elements

our Advice 

The configuration of technical items below is provided for reference only. Version 3.1 introduced ref-
erence data which bring more flexibility. Therefore, we advise you to favour them over technical ele-
ments.

Technical elements are characteristics of your machines. In the corrugated cardboard sector, it can be 
the number of colours, the type of corrugation or the type of bonding. These characteristics are used to 
determine the setting time and the work rate.

AdministrAtion 

The configuration of technical elements is performed by clicking on Configuration > Technical elements 
in the ribbon:

Below, we created the Colours technical element, to which a code and a designation were assigned 
automatically (while remaining editable manually):

The configured technical elements are displayed under the Data tab:
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Click on the Colours technical element to add elements:

Technical elements will then be selected when creating jobs.

Because some technical elements may not apply to certain machines, you can deselect those that are 
not relevant when creating individual machines. In the example, the number of colours applies to print-
ing machines but not to die-cutting machines:

▲ PRNT machine with technical element Colours active

▲ CUTT machine with technical element Colours inactive
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4.1.5. Configuring reference data

Reference data designates data lists represented by a code, a designation and a colour. These can list 
sales reps, product families, cutting-dies, colours, etc.

Reference data is used to set a type for the many fields that Direct Planning enables to customise (in 
addition to the traditional types: integer, text, date, etc.).

Reference data then impacts multiple levels:

1. Inform: Windows can be configured to display this data.

2. Colour: jobs can be coloured according to specific reference data. For instance, colours can discrim-
inate cutting-dies.

3. Affect programmable formulas defining setting times and work rates.

AdministrAtion 

The configuration of reference data is performed by clicking on Configuration > Reference data:

We are going to create Cutting-die reference data:



36

Direct Planning 3.4 Creating a schedule : Configuring reference data

User can access the reference data configured above under the Data > Reference data tab of the rib-
bon:

Creation of cutting-dies via the Data > Reference data > Cutting-die menu:

AdministrAtion 

Data type Cutting-die is now available in the configurable areas. This allows to enrich job information 
with the related configurable area (Configurable area 1):

Reference data Cutting-die now appears in the job additional information (together with the other con-
figurable areas entered on the previous screen):
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4.1.6. Configuring entities

Entities are data lists which evolve with your activity (Customers, Orders, Products, Projects, …).
Configuring entities provides lists for each individual data.
Entities can be automatically imported from an ERP (unlike other technical data whose list is supposed 
to be finite and which don’t evolve much over time).

AdministrAtion 

The configuration of entities is performed via the Configuration > Entities menu:

We are going to configure the following entities: Customer, Product and WO. Each entity features 
specific data:
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On the right, links display automatically the higher tier entity. For example, in the job details, entering 
the WO automatically populates the associated product and customer, without any retyping.

our Advice 

Links are hierarchical. You can see that WOs are linked with products, themselves linked with custom-
ers. Accordingly, it is better to enter entities by hierarchical order: Customer, Product and finally WO. 
However, make sure to unselect the link with the customer when dealing with generic products.

Entities are available under the Data > Entities tab:

This process is repeated for each Customer entity:

◄ Click on the entity to inform.

▼ The available fields are those previously configured.
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When creating the next entities (Products), these can be linked with Customers:

Finally, entering a WO offers the possibility to select the related product, which automatically populates 
the Customer field:
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4.1.7. Configuring Process Information

Process Information designates a data structure which extends the customisation features offered in 
Direct Planning. It refers to technical data which need to appear on specific machines only. The detailed 
technical information provided is therefore limited to the machines where it is relevant.

AdministrAtion 

The configuration of Process Information is performed under the Configuration > Process Information 
tab:

We are now going to configure Process Information related to milling:

In the example above, Process Information build upon standard configurable areas (integer, check box) 
as well as upon a custom type originating from reference data (Type of milling).

This Process Information can now be applied to milling machines. In the list of machines (Data  > 
Machines menu), select each affected machine and click on Modify. The new Process Information tab 
allows to select the newly created Process Information:

▲ Milling Process Information now applies to machine U1.
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Each Process Information can include a maximum of 10 individual technical information. If this is not 
enough, multiple Process Informations can be created for a single machine. The purpose is to provide 
the planning manager with useful information to inform planning decisions.
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4.1.8. Creating operations

The creation of operations must answer the following question:

What are the operations supported by our machines?

The creation of operations is performed via the Data > Operations menu:

Defining operations requires to specify a code, a designation and the working unit of quantity to produce.
The colour is also important, for instance to colour jobs sharing the same working unit in the schedule.

In the example above, the Standard milling operation uses the Units working unit.

As discussed in the next section, defining operations will allow the association of operations and 
machines.
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4.1.9. Attaching operations to machines

Why attach an operation to a machine?

There are 2 good reasons to do it:

1. After the definition of working units, this creates a second level of compatibility. In the schedule, 
moving a job towards a machine which is incompatible with the operation displays a warning.

2. This can be leveraged to force the average setting time and the average work rate.

To be attached to a machine, the operation must share the same working unit.

In the machine list, you can see the associated operations at any time by clicking on the button 
�

The Machines/Operations association can be refined by clicking on Data > Operations and machines 
in the ribbon:

◄  In our example, the working unit 
Units was attached during the creation 
of the U1 machine. The working unit 
Units was also attached during the 
creation of the Standard milling 
operation.

Machine and operation share the same 
working unit. We can now specify that 
the Standard milling operation is the 
default operation of the U1 machine 
(using the modify button in the machine 
list).
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This screen offers 2 major functions:

1. Creating machine families compatible with each other. These machines share the same working 
unit as the operation. In the schedule, moving a job to an incompatible machine displays a warning.

2. Manually forcing the average setting time and the average work rate, or calculating these values 
automatically:
• At the operation/machine pair level
• At the operation/machine pair level, with one element involved
• At the operation/machine pair level, with two elements involved

Note
You can also refine the calculation of setting times and work rates by defining programmable formulas.
For more information about programmable formulas, see next section, Configuring programmable 
formulas�

Follow these steps to create families of machines compatible with each other:

1. Select an operation in Zone A (the Printing operation in this example). 
Zone B displays the selected operation as well as the associated working unit. 
Zone D displays the machines compatible with each other (same working unit, same operation).

2. Using the mouse, drag machines from Zone D and drop them on a family in Zone C (family 1 is cre-
ated by default, you can rename it and create other families, see below).

As an alternative, you can select a machine in D and click on  .
You can also do the opposite: Select a machine in C and click on �

A Operations

B Selected operation 
and attached 
working unit

C Machines grouped 
by family

D Available 
machines

E Setting time for 
selected machine

F Work rate of the 
selected machine

A
B

C D

E F
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The following actions are also available:

Action Button

Create a new family of machines

Rename a family

Delete a family

Modify a machine
 (or double-click on it)
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Setting duration and work rate by machine/operation pair

Zone E allows to force a setting time for this operation/machine pair.
Zone F allows to force an average work rate for this operation/machine pair.

 To force a setting time, you must first check the  box.

Different options are now available:

• Forcing a fixed setting time which will take priority over the value defined at the machine level (0:25 
in the example above).

• Forcing a setting time affected by one or two technical elements, as in the following example:

This example uses the Finishing > Finishing complexity Process Information, based on the Finishing 
complexity reference data. When dealing with a simple milling operation, the setting time remains un-
changed (same as the default setting time: 0:45). However, when dealing with medium and high levels 
of complexity, setting times respectively increase to 0:55 and 1:10.

 To force a work rate, you must first check the  box.

FE
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Different options are now available:
 
• Forcing a fixed work rate which will take priority over the value defined at the machine record level.
• Forcing a variable work rate depending on the quantity:

In this example, the Finishing machine  1 processes 1,200  pages/hour for the first 500  pages, then 
1,400 pages/hour for the next 500, and so on.
This configuration reflects the increasing machine work rate when processing large series.
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4.1.10. Configuring programmable formulas

AdministrAtion 

Programmable formulas are available under the Configuration tab:

As these icons indicate, programmable formulas affect 5 areas:

1. Formulas modifying setting times according to technical data and precedence criteria. This allows to 
base setting times on business rules.

2. Formulas modifying work rates according to technical data. Here again, you can include your busi-
ness rules in the definition of your work rates.

3. Formulas applying conditional colours to planning tickets in order to transmit specific information.
4. Formulas creating conditional designations displayed on planning tickets. For example to customise 

the designation according to the machine.
5. Formulas based on technical constraints, to account for incompatibilities between machines.

A single programmable formula can include multiple rules.

Note
Because programmable formulas use the Visual Basic language, you must have in-house staff with 
minimal programming skills.
Please feel free to contact our support team for assistance in building these formulas.
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Setting duration

The setting time of a machine depends on the operation it executes, on technical data and on the pre-
vious operation in the schedule. Indeed, tool assembly and disassembly times are an important part of 
the setting time. In order to minimize setting times, the planning manager will often seek to group jobs 
sharing technical, thereby limiting technical changes on the machine.

In addition to standard mechanisms already implemented in Direct Planning, you can now build your 
own rules for altering setting times. Although this advanced feature requires minimal programming 
skills, DP includes assistance tools to help you. For instance, turnkey functions are included to inform 
whether technical data differs between the current job and the previous.

When moving jobs, setting times are recalculated in real time to account for precedence. The black bar 
below the job materialises the setting time so the efficiency of the scheduling can be assessed visually. 
And with the same colour for common technical items (or tools), you can visualise groups of jobs (more 
information about groups of jobs in section 5.8, Optimising planning times�

AdministrAtion 

Configuration > Setting duration menu

The list of existing programmable formulas opens. Please note that a programmable formula can only 
be deleted if it is not in use. Click on New to create a programmable formula:

▼ In this example, the programmable formula will use 
the previous job information to calculate the setting 
time (the ““Milling tool no.” set as configurable area 3 of 
Process Information 1).

Therefore, if the current job of a machine uses the same 
milling tool as the previous job, the setting time will be 
reduced by 30 min.
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The Test button is available to verify the validity of your syntax, confirmed by the message Code of 
formula is valid�
The Configurations button gives access to the schedule data without closing the window.
All new programmable formulas are enabled by default. Uncheck the box  to disable 
them.
To create a programmable formula, various objects, variables and functions are available. Furthermore, 
Direct Planning includes a set of Visual Basic standard keywords. Because this language features 
hundreds of keywords, only those relevant keywords for standard formulas are provided here.

When your programmable formula is created, go to the Data > Operations and machines menu to 
attach it to one or more machines:

Machine work rates

Programmable formulas offer the ability to describe in details machine work rate values depending on 
technical data, or to simply alter the work rate values already entered in Direct Planning.

For example, you can introduce work rate modification coefficients based on length ranges of the ele-
ment to produce. This reflects the decrease in work rate for the smaller elements which are less stable 
when processed.

You can also introduce multiplying (or dividing) work rate coefficients based on certain technical data.

The underlying principle is the same as for for setting times.

◄  The Milling set-up 
programmable formula is 
now attached to the Usinex 1 
machine.

Click on  to choose among 
the programmable formulas 
you created or on  to modify 
the selected formula.
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AdministrAtion 

Configuration > Machine work rate menu

The following programmable formula allows the definition of the machine work rate:

This programmable formula defines a work rate coefficient based on Configurable area 3 (Finishing 
complexity) for Process Information 3 (Finishing). Please note that a coefficient below 1 decreases the 
work rate (conversely, a coefficient above 1 translates into an increase).

Conditional colouring

As standard, Direct Planning already offers the ability to colour all or part of the schedule tickets through 
various mechanisms. Again, you can write your own colouring rules to convey the most visually relevant 
information to the planning manager.
For instance, for a numeric technical data (length, width, etc.), colouring rules can be created for each 
range of values.
The underlying principle is the same as for setting times and work rates.

AdministrAtion 

Configuration > Conditional colorization menu

This programmable formula results in a conditional colouring:

This formula is used to apply the same ticket colour to all jobs sharing the same tool (3rd line in the next 
screenshot):
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We will see in the dedicated section that conditional colouring can help you optimise planning times�

The administrator has access to this colouring in the configuration of display modes. Users can also 
select it under the Display > Colour by tab.

This is a basic example of conditional colouring. For numeric technical elements (such as lengths and 
widths), these rules can also apply to ranges of values, and job colours can depend on days ahead/be-
hind against deadlines.

Conditional designations

While Direct Planning can display configurable information on each line of a schedule ticket, you can go 
further by fully customising the displayed designations via specific rules written in Visual Basic.

This way, you can build flexible designations to display the most relevant technical data depending on 
the machine hosting the ticket. Combined with Process Information, this offers a sharp customisation 
of the information displayed in the schedule.

The underlying principle is the same as for setting times, work rates and conditional colouring.

AdministrAtion 

Configuration > Conditional designations menu

This programmable formula generates conditional designations:

This formula customises the display of tools in the schedule according to the Milling ("’milling tool”) or 
Finishing (“finishing tool”) section:
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If the job is placed in a processing section, the ticket displays the type of processing:

Technical constraints

The purpose of Technical constraints programmable formulas is to offer custom controls over ma-
chine compatibility. These controls are performed when the planning manager moves a job from a 
machine to another. This ensures the compatibility of technical data between the job moved and the 
destination machine.

AdministrAtion 

Configuration > Technical constraints menu

This is a Technical constraints programmable formula:

This programmable formula indicates the max. opening supported by the machine. The “MessageErreur 
=” variable allows the definition of a custom message informing the planning manager about the source 
of the incompatibility encountered while moving the job to an incompatible machine (see screenshot 
next page).



54

Direct Planning 3.4 Creating a schedule : Configuring programmable formulas

If the planning manager ignores this message, an alert still appears on the affected job:
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4.1.11. Creating display modes

This original function offers the ability to define as many display modes as you want depending on the 
profile and viewing needs of each user.
The display mode can be changed under the Display tab.
It can also be configured by default per user.

our Advice 

While the creation of display modes is optional because Direct Planning opens with the default display 
mode (which cannot be modified or deleted), it is nonetheless recommended. When your own display 
modes are defined, you will have to disable the default display mode (see section 4.3.12 Creating users).

AdministrAtion 

The configuration of display modes is available under the Configuration > Display modes  tab:

When clicking on New, the display mode creation window opens, with 5 tabs: 

• Schedule display
• Job display
• Flag display
• Time scale
• Display restrictions

The following sections discuss in depth each of these tabs. Therefore, they are reserved to the Direct 
Planning administrator.
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Schedule display

This first pane is used to modify the overall display of the schedule, including the projection section:

   

By default, sorting is made on the sequence number, which is the configuration order of your elements 
(Section/Machine in this example) and that you can change by clicking on the green arrows in the top-
left corner:

Sequence number
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In the schedule display, you can also configure the time scale:

These options enable to set the default time scale (1 to 5) of the display, as well as the default global 
zoom level.

Compacting the time scale saves space on the schedule by not displaying weekends when they are not 
worked.

Secondary graduations make it easier to consult the schedule thanks to grey vertical maker lines.

Finally, this tab offers the ability to customise the aspect of inactivity areas. Inactivity areas are regular 
or occasional periods during which the resource or machine does not operate (outside working time, 
weekend, hardware servicing periods, public holidays, vacancy, sick leave, machine maintenance, …):
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Job display

This second pane offers the ability to change the aspect of jobs in the schedule.

The configuration above gives jobs the following aspect:
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Flag display

This tab offers the ability to select the visible flags in your display.

Flags are coloured and sometimes hatched bullets located above and/or on the right of jobs. They ena-
ble the planning manager to view instantly the different job status.

They serve the same purpose as paper clips and other stickers put on traditional wall schedules.

To create a flag, go to the General configuration of Direct Planning: 

Choose the type of flag to create, horizontal (left) or vertical (right), and click on <Inactive flag>�
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As suggested by the window above, there are 3 types of flags: indicative, multi-status and multi-status, 
awaiting item receipt. Let’s look more closely at each of these flags:

◄ Indicative flag, the simplest case as an indicative flag is 
a two-state flag: Active or inactive. You can think of it as a 
raised or lowered flag, or an On/Off switch.

In the example opposite, the flag is shown when active 
and hidden when inactive. It is also possible to display 
inactive flags, in which case you can choose the colour by 
selecting the Colour of inactive flag line.

In case of flag modification, the Scope of flag lets you 
choose whether this modification applies only to the cur-
rent job or to all jobs sharing the same entity.
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See section 5.2, Creating jobs manually, to see how flags are used at the job level.

◄ Multi-status flag: a multi-status flag can have up to 
5 states. Designation, colour and motive can be defined 
for each status.

When creating of modifying jobs, users can enable or 
disable the flag for each job. As with indicative flags, in-
active flags can be shown or hidden.
When the flag is active, you can define a colour and a 
subject for each of the 5  available states (you do not 
have to use them all).

◄ Multi-status, awaiting item receipt flag: While showing 
similar characteristics as those described previously, this 
flag adds the notion of item receipt.

Unlike the other flags which are strictly indicative, this 
flag introduces a strong constraint for the job earliest 
start date.

The earliest start date constraint applies to the job on 
which the flag was activated. Because of that, the notion 
of scope does not exist for this flag.

If the planned date has come and the tool has not been 
received, an alert message will indicate the delayed re-
ceipt.
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Time scale

This tab offers the ability to define the different zoom levels associated to this display mode.

Start by modifying the zoom level of scale 1.
Higher magnification will display a smaller time span, which is useful when planning short jobs (less 
than an hour).
Conversely, smaller magnification will display a larger time span.

Scale 2 is the result of a multiplying factor applied to scale 1.
The same applies to each other time scale, which is the result of a multiplying factor applied to the pre-
vious scale.
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Display restrictions

This last pane is used to filter the jobs displayed by the current display mode.

In the upper part, a range (date and time) can be defined through selection in the calendar or in relation 
to the current date. For example, it is possible to display only the jobs located 90 days before and after 
the current date.

our Advice 

It is strongly recommended to configure the current display mode to ignore the jobs older than 2 weeks. 
This will optimise the time required to load the schedule. However, display modes can be created (via 
duplication) for elapsed periods, for logging purposes. 

At the centre of this screen, you can choose the default display mode of jobs “to schedule”. As a remind-
er, jobs to schedule are jobs which need to appear on the schedule without being set to a specific date.

Finally, the lower part of the tab allows the schedule to display only the jobs attached to specific ma-
chines/sections. This allows to show some users only the machines/resources relevant to them:

◄  Jobs to schedule are displayed on a special 
line in the schedule, under the actual planning 
line, in a different colour and with the machine 
name followed by the [*] character
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◄ This schedule will address the needs of operators working 
only with milling machines. Indeed, their schedule will not be 
cluttered with data related to other sections.

Refining this filter can be performed by clicking on Machines. 
For instance, if an operator only works on milling machine 
#1, the planning manager can limit the scope of his display to 
show only this machine.
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4.1.12. Creating users

User management is performed via the List of users menu.

AdministrAtion 

This menu is available from the ribbon, under the Configuration > Users tab

Because no user have yet been created, this list is still empty except for you, the administrator. Click on 
New to create users:

The first tab User allows to enter basic information about the user. It consists of 4 zones.

� �

� �
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� User credentials: Identifier (automatic and non-editable), Login (required and non-editable), Surname 
(required and editable), Forename (optional and editable), Email (optional and editable) and Active 
user (checked and editable).

� User password (required and editable).

� Direct Planning access level:

• Super-user (admin): Always created automatically for any new schedule, it cannot be deleted. It 
is strongly recommended to modify the associated default password (admin) when creating the 
schedule.
He has all privileges (�), and none of them can be waived from him.
Only he can grant the same rights to another user.

• Users with Access for modification rights can schedule jobs and modify the schedule.
Their privileges (�) are those granted by the administrator.

• Users with Access for restricted modification rights have no privileges (�).
It typically designates a production operator reporting a progress status to the planning manager 
or an operator updating certain flags after receiving material or tools.

This type of access allows to:
- Update the declaration of production (performed quantity and duration)
- Modify flags
- Create user alerts in job details (Declaration of production tab)
- Modify job description and configurable areas

Among other things, it does not allow to modify:
- Anything regarding the placement of jobs in the schedule
- The planned quantity and duration
- Technical elements

Caution: Creating users with access for restricted modification requires to enable the automatic 
import function in the Configuration > General configuration > Automatic import menu.

� Privileges granted to users (see above).
• Configure schedule: allows users to access the Configuration tab, notably to manage users.

• Use scheduling: the scheduling function is no longer maintained. The corresponding privilege is 
therefore outdated and will be removed from the next version of Direct Planning.

• Manage technical data: unchecking this box allows users to view (but NOT modify) the resources 
(project mode), sections/machines, working units.
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• Manage calendars: unchecking this box allows users to view (but NOT modify) the characteristics 
of calendars (standard days, standard weeks, machine operating times). More information about 
these notions in section 5.5 Managing calendars�

• Manage entities: unchecking this box allows users to view (but NOT modify) entities.

The second tab, User options allows the definition of opening and positioning options in the schedule. 
Users can modify these setting under File > User options > For this schedule�

The third tab, Allowed display modes allows to select the display modes available to selected users. 
This option is useful to display only the relevant sections/machines.

Similarly, the User configurable lists tab is used to filter the lists of jobs available to users. In the same 
fashion, the objective is to select the relevant lists to their usage. More information about configurable 
lists in the next section.

When you are done creating/modifying users, click on Save and close�
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4.1.13. Creating configurable lists

Configurable lists let you define lists of jobs.
You can configure lists customised for each user, and save these lists for future usage.

AdministrAtion 

Configurable lists can be created/modified by clicking on Configuration  > Configurable lists in the 
ribbon:

Lists can be viewed on screen, printed or exported to Excel.

The criteria tab is available to select the most common job filters (time-related criteria, sections/ma-
chines, jobs in alert, etc.).

◄ In this example, the list Milling plan-
ning is created to include only the jobs 
performed by machines belonging to 
the milling section. 
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If you wish to create lists based on more advanced criteria, click on the Advanced criteria tab:

The Advanced criteria tab allows to create more refined selections from any data used in your schedule.
Your selection can include 10 different data from your base.

Use the Options to define the sorting order as well as the pagination:

Finally, the Result tab opens automatically when you click on Display list. It displays all jobs matching 
your search criteria:

� �

◄ In this example, the new custom list is 
based on 3 criteria: The Customer code, 
the Product code and the Operation 
designation.

To this end, first select the type (�) and 
value (�) of each filter.

◄  The left side of the window allows 
you define 3  hierarchical sorting crite-
ria.

The right side relates only to printing, 
allowing to define the page break cri-
terion. You can also request a subtotal 
(by machine here) as well as an overall 
total, for all data which can be totalled.  
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Of course, configurable lists can be customised. For instance, you can:

- Add/Delete columns: right-click on a column header to display the field selector. Check the fields 
required in the list and uncheck the others. Keep in mind that quick filters in column headers are not 
saved.

- Move columns: just drag the column to move by clicking on its header and dropping it on its destina-
tion. It will position itself to the right of the destination column.

- Resize columns: click on the column separator and move the mouse to the left or right.
You can also double-click on the column separator to make the column width automatically fit the con-
tent.
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- Resize window: resize the window as you would do for any Windows window.

- Save your list: save the list by clicking on the floppy disk on the top left corner of the screen.

Under the Home > Search and lists (Ctrl+F) tab, users may leverage the lists that you created (when 
authorised in the user configuration).
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4.1.14. Saving the schedule
Different scenarios (detailed below) may occur:

• You are saving a schedule for the first time, a wizard guides you
• You are saving an existing schedule in an export file
• You are saving an existing schedule while also creating a template

Scenario 1: You are saving a schedule for the first time

If your planning was just created (that is, if it was never saved), the Save and Save as commands from 
the File menu open the same wizard:

Note
As an alternative to the Save command in the File menu, you can use the traditional Windows shortcuts: 
The floppy disk (toolbar) and the Ctrl+S key combination.

To save your planning for the first time, select Save schedule.

You will then be prompted to select the computer hosting the schedule database:
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our Advice 

There is no right or wrong choice regarding the location of the schedule database. See our section 
about architectures to know which solution is the most suited to your environment.

In this example, the schedule database is hosted on the computer in use. Accordingly, On my computer 
is selected. The next window prompts you to create a new local schedule or overwrite an existing local 
schedule:

Because the schedule is being created, select Create a new, local schedule (only option available, we 
will discuss the other option when addressing the opening of a DPL2 export file). You are then prompted 
to name your schedule (by default, it is the name assigned when creating the schedule):

Enter the administrator password again:
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Click on Next to confirm and save the schedule:

The local computer network name as well as the schedule identifier display.

This way, you can provide this information to users who want to access it remotely:
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Scenario 2: Saving an export file

The export file (.dpl2) creation function offers the ability to save the current schedule in a “portable” file, 
that you can archive or send to a third party. This file bears the “DPL2” extension.

To create an export file, click on File > Save as
Then select Create an export file for this schedule (.DPL2).

Click on  to specify the path and name of the export file.
By default, the path is the one from the last export and the file is named after the schedule.
The  button is used to display the folder contents:

The indications provided at the previous step are reminded for information.

The export is complete.
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Scenario 3: Creating a schedule template

Creating a schedule template offers the opportunity to create other schedules based on this template.
Schedule templates are similar to the templates available in your word processing software.

Saving a template from an opened schedule also saves certain data, including:

• The whole configuration (the administrator is the only user kept)
• Resources and resource families (Project and Service modes)
• Sections, machines and technical data (Industry mode)
• Calendars (all modes)

Each schedule template is saved in a MDPL2 file.
It is a “portable” file which can easily be copied, sent, etc.

Note
Users, entities and jobs are not saved in templates.

our Advice 

If you still wish to keep certain data in your model, there is an alternative: Instead of using a model, save 
your schedule under a different name. In the new schedule, delete everything that you do not want to 
keep (users, jobs, …).

Follow these steps to create a schedule template:

To create an export file, click on File > Save as

Then select Create a template from this schedule (.MDPL2)

Click on  to specify the path and name of the export file.
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By default, the path is the one from the last export and the file is named after the schedule.
The  button is used to display the folder contents:

The indications provided at the previous step are reminded for information.

The template is now saved.
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5. Scheduling with Direct Planning

5.1. Scheduling via an interface with an ERP
In order to avoid entering the same information over and over again, Direct Planning can automatically 
import data originating from your information system (ERP, CAPE, Excel®, …) if they comply with the 
expected CSV format.
This way, technical elements, entities (orders, customers, etc.), jobs and links can be created automati-
cally in the schedule.

AdministrAtion 

This automatic import function is activated in the General configuration of Direct Planning, under the 
Configuration tab:

When you activate the automatic import, you choose the folder containing your CSV import files.

More information about the interfacing features included in Direct Planning in section 6, Interfacing your 
ERP with Direct Planning�
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5.2. Creating jobs manually
2 different methods can be used to create jobs manually:

1. In the Edit menu, click on 
2. Place the cursor on a free area of the schedule, on the same line as the machine which will run the 

job. Right-click to open the context menu.
Select 

Both methods open the job details screen, except that the second pre-populates the Section and 
Machine fields with those on which you right-clicked.

The job details window can be divided in 3 panes:

1. General information on job
2. Date and duration information
3. Other information depending on the selected tab

While the first and second panes are always displayed, the contents of the third depend on the 
selected tab. These 3 panes are further explained in the 3 following chapters.

1
2

3
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5.2.1. Job header information

Job identifier: The window header shows the identifier of job No. x. It is a sequence number which is 
automatically assigned by Direct Planning. It cannot be modified.

Below, the machine performing the job is selected via the  button (this zone is pre-populated if your 
job is created via the context menu in the schedule). The machine section is automatically entered. Note 
that clicking on the  button next to the machine code opens the corresponding machine.

Optionally, a job description can then be entered, providing a quick way to identify jobs when the 
configuration of display modes is set to show this description.

The selected operation is the one attached by default to your machine (if any). At this stage, Direct 
Planning can check the compatibility between machines and operations (as defined under Data  > 
Operations and machines) 

Then, enter the produced and wasted quantities (retrieved by default on the machine record), which 
automatically populates operative quantities excluding waste and including variable waste.

When a machine is selected, it is possible to display only compatible operations (and vice versa) by 
clicking on :
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5.2.2. Sundry information, dates and durations

Use the top check boxes to answer different questions about the job:

• Is the job scheduled or to schedule?
• Is the job subject to a flag?

If so, clicking on the  icon opens the window for choosing the flag to display:

• Is the job started? If so, you can click in the progress bar to modify its progress: 

• Is the job completed?
• Is the job locked? (job cannot be moved, modified or deleted by users)

our Advice 

Use locked jobs only when they really make sense (for example if a visit of your shop floor is planned 
with a customer). Indeed, the propagation of locked jobs may adversely impact your schedule by limit-
ing your ability to move jobs.

The next zones, in the blue box, affect the actual (temporal) scheduling of your job.
As reflected by these 3 columns, jobs are divided in 3 phases: start, duration and end.

Planning: date and time chosen for the start of the job in the schedule.

Earliest: earliest start date and time (not editable in this screen, see 
Time constraints in the next section).

This data reflects the setting and running durations calculated by Direct 
Planning.
In our example, this data displays on a yellow background (not editable 
fields) because we checked the Enable automatic calculation of dura-
tions for this machine on the machine record.
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If you did not check this box, you can enter durations in these fields.

Even if you activated the automated calculation of durations by Direct Planning, you can force durations 
by checking the corresponding box.

reminder  

The automated calculation of durations is retrieved, from the most general to the most precise:
1. Simple mode: on the machine record
2. Intermediary mode: on the Operations/Machines pair
3. Expert mode: on programmable formulas

Resizing a job with the mouse

The end time can be modified directly in the schedule, when the job is not selected. To do so, place your 
mouse cursor on the right edge of the job. The cursor turns into an arrow:

This action is like forcing the job running duration.

Planning: date and time automatically calculated depending on the job 
start and duration.
Modifying this value is like forcing the running duration of the job

Latest: latest start date and time (not modifiable in this screen, see Time 
constraints paragraph in the next section).

◄ When you move the cursor, the job end time and duration 
refresh dynamically in this informative box.
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5.2.3. Other information on the job

The arrows located at the bottom of the window allow to navigate through jobs via the same screen:

The information displayed below rely heavily on the configuration of your schedule. We are going to 
focus on each of the available tabs.

Information

• Information on this job: when you check this box, the right side shows the fields corresponding 
to the configurable areas set by the administrator at the job level (Configuration  > General 
configuration > Jobs: configurable areas).
For the example above:

• The following lines display the entities generated during the schedule creation. Click on  to select 
an entity and on  to modify it (where appropriate).
When an entity is selected, the right pane displays additional information entered by the administrator 
for this entity (Configuration > Entities):

Navigation through jobs of the route

Navigation through jobs of the machine
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• Finally, the Informations process box allows to display information that are specific to the job being 
created (Configuration > Process Information). In our example, the process information type of 
milling, milling complexity or milling tool no. are only relevant for the Printing operation:

Technical elements

The Technical elements tab displays only if the administrator created these elements (Configuration > 
Technical elements). As a reminder, technical elements are additional characteristics of your machines. 
In the corrugated cardboard sector, these may be the number of colours, the type of corrugation or the 
type of bonding:

reminder  

• The administrator configures the technical elements depending on the users needs
• Users populate technical elements (Data > Technical elements) 
• Applicable technical elements can be specified in the machine record
• Technical elements may impact setting time and work rate (Data > Operations and machines)

Flags

As with technical elements, the Flags tab displays only if flags are set.

Usable flags are displayed under this tab. To enable/disable a flag, check the corresponding box or 
click directly on it.
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Time constraints

This tab lists all time constraints which can affect a job.
Constraints can:

• Be forced manually by you;
• Result from a route (sequence of jobs in a given order);
• Be forced by a flag (receipt of an element required to start a job).

You can only enter the dates that you wish to force.
The other dates are displayed as a reminder (on a yellow background) but cannot be modified.

The screen is divided in 2 parts: earliest start, latest end (for job/route).
Each part indicates the constraints at the job level and at the route level.

Latest end: dates and times forced manually

Production imperatives may require you to force manually the latest end date.
Use this screen to force a date which will be automatically respected if planning assistance is active. The 
latest end date must be forced on the last job of the route (positioned by the ERP interface).

If the latest end date that you force is more restrictive than the current date, an alert warns you that the 
job is now overdue.

◄  Check the corresponding box and enter a 
date directly or use the date and time entry 
tools.
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Latest end: constraint forced by downstream jobs

If the job belongs to a route, Direct Planning automatically calculates the latest end date (forced by 
downstream jobs).
This date, calculated by Direct Planning, is reminded here but cannot be modified.

From the latest end date forced manually and by downstream jobs, Direct Planning picks the most 
restrictive and displays it in the bold field Latest end date of job�

Earliest start: date and time forced manually

Production imperatives may require you to force manually an earliest start date.
Use this screen to force a date which will be automatically respected if planning assistance is active.

When you force an earliest start date, the job start date adjusts in order to respect this constraint.
Besides, if this constraint applies in the future, saving it automatically moves the job to that date with-
out moving jobs located to its right, thus avoiding gaps in the schedule.

Earliest start: constraint forced by upstream jobs

If the job belongs to a route, Direct Planning automatically calculates the earliest start date (forced by 
upstream jobs).
This date, calculated by Direct Planning, is reminded here but cannot be modified.

◄  In the example, the manual constraint (typ-
ically to honour a customer order in time or 
free a machine) is more restrictive than the con-
straint imposed by the downstream jobs.

Logically, this more restrictive date is chosen as 
Latest end date of job�

◄  Check the corresponding box and enter a 
date directly or use the date and time entry 
tools.
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Earliest start: constraint forced by a flag

The multi-status, awaiting item receipt flags are used to indicate the status of an element to order, or-
dered or received. As long as the element is not received, its receipt date represents a constraint which 
is reminded here.

From these 3 constraints (forced manually, by upstream jobs and by flags), Direct Planning picks the 
most restrictive (i.e. the latest) and displays it in the bold field Earliest start date of job�

The Alert field displays a warning if the job is placed before its earliest start date:

This alert can only be encountered when planning assistance is not active. Indeed, it ensures the auto-
matic respect of the restrictive constraints posed by the earliest start dates.

Route constraints

In the lower part, the fields dedicated to the earliest start date and latest end date of the route are 
displayed for information, they cannot be modified.
The earliest start date of the route always refers to the earliest start date of the first job of the route.
Inversely, the latest end date of the route always refers to the latest end date of the last job of the 
route.

◄ In this example, the start date of job is forced 
on February 17.
However, a tool receipt waiting flag indicates 
that this job cannot start before the next day.

This last constraint being more restrictive, it is 
chosen by Direct Planning as Earliest start date 
of job�

◄  Conversely,  keeping this tool receipt con-
straint on May 16 adds a more restrictive forced 
earliest start date, set the next day.

Notice that the manually forced constraint be-
ing more restrictive, it is chosen Direct Planning 
as Earliest start date of job�
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Declaration of production

Production can be monitored at various levels:

Level 1 Monitoring of started and completed jobs only.
Via right-click on a job: Progress status > Start/Complete jobs.

Level 2 Level 1 + Indication of the production actual start date.
Accordingly, the job will be moved to reflect reality on the ground.

Level 3 Level 2 + Input of produced quantities.

Level 4 Level 3 + Input of production times�
Useful when discrepancies may appear between expected and performed values, 
which is notably the case for very long jobs.

The screen capture above shows the Declaration of production tab for a job not started: the right side 
of the screen (Result) only shows the expected values.

our Advice 

This screen relies heavily on the working unit of quantity to produce, so make sure that this value is 
properly configured under the Technical data section of the machine record.

To start the declaration of production, click on Started on:

This screen is made of two big panes: Declaration of production times and quantity and Result�
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Let’s see in details the contents of each pane.

Here, you simply declare that the job is started, at a certain date and time. For the start date and time, 
the system offers the date and time initially scheduled. You can change them if needed. Click on Follow-
ing to place the job right after the end of the last started job of the day.

This box only displays if you activate the entry of times. You can enter times by durations (with 
automated calculation of the end time, above left) or by end time (with automated calculation of 
durations, above right).

Setting

When you modify the duration of the performed setting, Direct Planning refreshes the total updated 
duration of the job in the right pane (Result).

• As long as performed values are below or equal to expected values, and setting is not complete, 
the updated setting is capped at the expected values.
Indicating that setting is finished aligns the updated setting with performed values.

• As soon as performed values exceed the expectations, the updated setting aligns with performed 
values, whether or not the setting is completed.

Running (entry of times by duration)

When you modify the performed running duration, Direct Planning:

• Recalculates the performed work rate in the right pane (Result);
• Refreshes the total updated duration in the right pane (Result) depending on the method chosen 

for calculating the remaining duration.

Downtimes

You can indicate machine downtimes, whatever the cause.
These will be subtracted from updated setting and running times.
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End of work (entry of times by end time)

Specify the running end date and time. Direct Planning automatically determines the performed run-
ning time, taking into account the performed setting time and the downtimes.

This last zone focuses on the produced quantity.
If the working unit of quantity to produce is entered on the machine, you can already declare the total 
produced quantity and, if applicable, the non-compliant quantity. Direct Planning then deduces the 
compliant quantity and the progress.

our Advice 

When creating jobs, leave this zone empty: the performed quantity will be specified later, when modi-
fying jobs.

The performed quantity can exceed the quantity to produce, in which case the progress percentage 
reaches 100%. As an alternative to manual input, you can click in the progress bar to set the performed 
percentage. Direct Planning will refresh quantities.
This alternative is the only possibility offered when there is no working unit defined on the machine.

If the job is complete, check the Production completed box. The progress status automatically reaches 
100%. Finished jobs are greyed out in the schedule.

You can declare the production as completed even if the produced quantity differs from the expected 
quantity.

The upper part of the Result pane displays a number of indicators related to production, displayed as 
a reminder but not modifiable. These indicators are refreshed when modifying production parameters.
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Notice that the calculation of the remaining duration can use the theoretical work rate configured by 
default or the actual work rate calculated for the ongoing production, whose background colour reflects 
discrepancies between with the expected and performed work rates:

This zone allows the operator to notice the planning manager of an alert regarding a production issue.
Checking the Alert the schedule manager box allows the creation of an alert for all to see, including the 
planning manager. This alert obeys the same rules as the other alerts.

◄ Performed work rate ≤ 60 %: weak performance.

◄ Performed work rate ≤ 80 %: improvable performance.

◄ Performed work rate ≤ 120 %: good performance.

◄ Performed work rate > 120 %: excellent performance.
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Alerts

The screen capture above shows a job with 2 alerts:

• A user-created manual alert (in purple)
• An system-generated automatic alert (in red)

The alert counter on a job is displayed in the tab title.

To clear an alert, click the cross displayed on the right. Cleared alerts (if any) can be displayed by clicking 
on the corresponding box. Cleared alerts are added to the list of alerts, in white. You find the date and 
time they were cleared, as well as a check mark:

Click on the check mark to cancel the alert clearance:

Manual alerts can be enriched with notes by clicking on Create notes, which opens the following win-
dow:

When notes have been set to complement the alert, the Create notes button turns into Display notes 
and the corresponding icon turns yellow:
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See section 5.10, Alerts, for more information about alerts.

Notes

This last tab is used to enter notes on a job. When notes have been entered, the tab turns yellow to 
catch your attention in the job details.
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5.3. Manipulating jobs
Manipulating jobs covers multiple aspects which will be described in the following subsections.

5.3.1. Selecting jobs

All you have to do is click on a job to select it.
The selected job then shows against a dark grey background similar to the following example:

Various methods allow the selection of multiple jobs:

• Using the mouse, draw a rectangle over the jobs to include in your selection. All jobs included (even 
partially) in this rectangle will be selected.

• Hold the Ctrl key while clicking on the appropriate jobs.
• To select a range of jobs, click on the first and last jobs of the range while holding the Shift key.
• Right-click on a job and select Widen selection to select multiple jobs sharing characteristics (same 

route, same entity, same machine after the current job).

To cancel a selection, select another job or click on a free area of the schedule, or start any other action 
such as for instance selecting an element in a menu.

5.3.2. Moving jobs
Unless locked, you can move any job in the schedule. 
One of Direct Planning’s strengths lies in the intuitive scheduling management it offers.
The drag-and-drop method reflects this ease of use.

Note
The final result may slightly differ from what you asked: indeed, when planning assistance is active, 
Direct Planning tries to optimise the schedule according to the chosen automations.
Likewise, Direct Planning can modify (or even reject) moving operations if the related jobs belong to a 
route which impose constraints on them.

Several types of movements are possible:
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Move a job to a free slot, without changing machine

When you release the mouse, without any active adjustment, the job is moved to your chosen location 
(the blue rectangle), leaving a gap at its original location (which can be filled via adjustment, see sec-
tion 5.6. Planning assistance) ▼

You can also perform this action by selecting a job and right-clicking at its destination. Then, you just 
have to select Move selection here�

Move a job to an occupied slot, without changing machine

The moved job is placed right after the destination job. Because left adjustment is active, the gap is 
filled ▼

This simply comes down to modifying the sequence of jobs. Without adjustment, the gap is not filled.
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Moving a group of jobs to an occupied slot without changing machine

If the selected jobs are grouped, they will remain grouped at the drop location:

If the selected jobs are not grouped, the movement will automatically group them against the left-most 
selected job. This is a very useful action to position and gather multiple jobs, with a single drag-and-
drop operation:

The context menu Cluster jobs of selection also groups all selected jobs against the left-most selected 
job, which is particularly useful to gather jobs remote from each other.
For “long distance” displacements, simply select your jobs and without dragging them, go to the drop 
location, right-click on the schedule background, and select Move selection here in the context menu. 
This replaces the “cut/paste” (Ctrl+X) function which was little used in Industry and Project modes be-
cause it broke links.

Moving a job on a compatible machine

To move quickly a job to a compatible machine, right-click on the job to move, select Move on a com-
patible machine and select the appropriate machine:

▲
The compatible machines proposed in the sub-menu are those gathered in the same family in the 
Data > Operations and machines menu.

◄ The current machine is greyed 
out.
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If you move a job to a compatible machine (on another line), Direct Planning behaves the same as for a 
movement on the same machine:

With automatic calculation of job duration enabled, Direct Machine can recalculate automatically the 
job duration while taking into account setting times and work rates specific to this destination machine.

Moving a job to an incompatible machine

When you move a job to an incompatible machine, Direct Planning displays the following warning (which 
can be customised with programmable formulas to reflect your business constraints):

If you confirm (OK button), the job will be moved as per your request, but you are responsible for 
verifying the job details.
You can also click on OK and modify job to confirm. This opens the details of the moved job, to check 
and modify it if needed.
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5.3.3. Duplicating jobs

Duplicating a job creates a new job which can be left untouched or modified. This allows the quick cre-
ation of similar jobs. When duplication is completed, you can modify the newly created job (if needed).

Note
The requested duplication may be influenced by the adjustment to the left or right configured under 
the under the Planning assistance tab.

5.3.4. Copying/pasting jobs
The simplest and quickest method for copying/pasting jobs in Direct Planning is to use usual Windows 
shortcuts (Ctrl+C to copy, Ctrl+V to paste).

our Advice 

The copy/paste functions offer a quick way to create new jobs with similar characteristics: instead of 
creating new jobs from scratch, it may be helpful to use the copy/paste function from existing jobs. You 
only have to make small modifications to the new job, if necessary.

Because pasting a job is like creating a job, the original time constraints apply.

Besides, the machine compatibility check is also performed when you paste a job.

5.3.5. Subdividing jobs
Internal organisation may require you to subdivide jobs, that is to say split them in 2 parts distributed 
as desired.

For example, delivery constraints may require you to produce part of the quantity immediately to de-
liver it as soon as possible, and postpone the production of the remainder at a later date. Or you can 
offload an overloaded machine by assigning all or part of the workload to another machine. Subdivided 
jobs can be subdivided again. Direct Planning keeps existing links and transmits them the to the result-

◄ Use the job context menu to 
choose where the job should be 
duplicated: at a predetermined 
fixed interval (upper part) or ac-
cording to an input value (lower 
part).
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ing job.

In the schedule, right-click on a job to open the context menu.
Select Subdivide job:

The upper part of this window provides you with information on the current job before separation. You 
cannot modify this data. However, you can choose whether the new jobs will both run on the same 
machine or if they will be paralleled on two different machines. A graphic representation helps you get 
an idea of the result.

A cursor is then available to adjust quantities for each job (by default, Direct Planning splits the job in 
half). Moving this cursor updates the expected quantity for each job. If you do not wish to use the cur-
sor, you can enter directly the quantity to produce in these fields.
While Direct Planning calculates setting and running times in this example, you can force these values 
manually by checking the corresponding boxes. You can also set the progress of the first job.
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5.3.6. Postponing jobs

You may have to postpone a job for different reasons like waiting the receipt of an item, various haz-
ards, etc. After selecting the affected job, right-click to open the context menu:

Note
The requested postponement may be influenced by the adjustment to the left or right configured 
under the under the Planning assistance tab.

5.3.7. Deleting jobs
On a selection of jobs, click on Delete. Another (quicker) way is to press the Del key. You will be asked 
to confirm.

The Ctrl+Z combination is available to cancel any unintentional deletion. Conversely, the Ctrl+Y com-
bination can be used to restore a deletion. You can also use the quick tools  at the top of the 
screen.

5.3.8. Accessing the jobs details

Previously covered when discussing how to create jobs manually, the job details window is the dash-
board containing all job-related information.

To access it, select a job and click on Job detail in the ribbon, under the Edit tab. You can also right-click 
on the job and select Modify job, or simply double-click on the job in the schedule.

5.3.9. Scheduling/Unscheduling jobs

In the Gantt, a job to schedule appears on a special line.

This line has 2 functions:

◄ Use the job context menu to 
choose when the job should be 
postponed: at a predetermined 
fixed interval (upper part) or ac-
cording to an input value (lower 
part).
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1. Following an import, it contains all jobs coming from the ERP: any imported job in Direct Planning is 
set “to schedule”.

2. It is used to place jobs pending scheduling in order not to forget them.

This line only displays when there are jobs to schedule and when the Display jobs to schedule option 
is checked in the Display menu:

It is located under the actual schedule line, in a different colour and with the machine name followed by 
the [*] character, as in the following screen capture:

Various methods are available to schedule a job placed on the “to schedule” line:

1. Right-click on a job to schedule and select Schedule > Schedule jobs (this menu can also be used to 
schedule the whole route to which the job belongs):

2. Move the jobs using the mouse.
3. Under the Edit tab, use the Schedule menu to toggle jobs between scheduled and to schedule lines 

in the schedule.

5.3.10. Locking jobs

You can quickly lock/unlock a job via right-click Lock/Unlock on a job, via the Edit > Lock/Unlock menu 
or in the job details.
A locked job cannot be modified or moved.
When moving a job makes another job collide with a locked job, the job conflicting with the locked job 
is unscheduled. This avoids the job being thrown too far down the schedule if several locked jobs follow 
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each other.

Please note that an alert is automatically generated on the unscheduled job: 

And a warning screen appears before the job is unscheduled:

◄ In the opposite example, the objective is to 
move the first job (in green) after the second 
job (170105). Normally, this would shift jobs 
170105 and 170104 to the right (left adjust-
ment).

Because the last job is locked, this operation 
will unschedule the 170104 job colliding with 
it.
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5.4. Creating routes
Direct Planning allows the creation of links between jobs. Routes can be defined as sets of jobs which 
must be performed in a specific chronological order. A route implies the respect of time constraints. A 
route contains a number of jobs which can belong to one or more machines.

5.4.1. Creating routes quickly

To create simple links, select two jobs to connect, right-click on one of them and select Link selected 
jobs to each other:

This mode is completed by the Link creation mode which is more exhaustive and allows to create 
more complex links.

5.4.2. Link creation mode
This mode can be accessed via the Edit > Link creation (Ctrl+I) tab.

Switching to Link creation mode turns the pointer of your mouse into a pencil: 

This pencil allows to “draw” links between jobs, by moving it from a job to the other.

When releasing the mouse, the link creation window displays to configure the gap between jobs:
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Two options display when linking two jobs:

1. Link with shift of minimal length (above): this option option is recommended when the jobs must 
not overlap. Setting the Minimum duration of shift field to 0:00 h makes the destination job start right 
after the source job.

2. Link with overlapping of maximal length:

This option allows to handle job overlapping. In our example, the destination job can start 10 minutes 
before the end of the source job (zone C). Otherwise, see it the other way, thinking that you have to wait 
3h26 after the setting of the source job (zone A) before starting the destination job (which boils down 
to the same thing).

In both cases, Direct Planning relies on the P running time and recalculates A from C or C from A.
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To modify/delete a link, the quickest method is to right-click on it and choose the associated option:

5.4.3. Visual appearance of links

Trail

Links are materialised by lines which can take 3 different aspects depending on the case:

Appearance Type Description

Solid line Exact chaining

Dotted line Gap

Dotted line and dots Overlapping

Colour of links

The administrator can configure the display mode to have colour links reflect the progress of the route. 
Link colours are based on the following rules:

Colour Type of link

Link whose upstream job is complete

Link whose upstream job is started

Link within a route in which there is one or more started or completed job

Link within a route with no started job
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Examples:

Link visibility

It is possible to display only the direct links for the selected job. The inbound and outbound links for the 
selected job will be the only links displayed.
To this end, check the Only display direct links box under the Display tab of the ribbon:

In both cases, job C is selected: whether or not Only display direct links option is checked, Direct 
Planning displays or hides link between jobs A and B.

◄ No job of the route has started: all links 
are displayed in blue�

◄  Job  A has started: the A-B link are dis-
played in orange�

The B-C link displays in green to indicate that 
a job of the route has started.

◄ Job A is complete: the A-B link is displayed 
in red�

The B-C link displays in green to indicate that 
a job of the route has started (in this case it 
is completed).



107

Direct Planning 3.4 Scheduling with Direct Planning : Creating routes

5.4.4. Manipulating routes

When moving a job belonging to a route, the other jobs of the route may also be moved depending on 
the route constraints:

Select the different jobs of the route to preview their location after movement (materialised by blue 
rectangles):

◄ In this example, the first job (A) of the route 
is moved to make it start at 12:00.

▼ Notice below that because jobs  B and C 
are scheduled to start right after job A, they 
are also moved.
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5.4.5. Route deadlines
In the schedule, deadlines are materialised by vertical lines. They are displayed for jobs, routes and 
groups of jobs.
In the schedule, when you select a job, its deadlines display as vertical dotted lines (in green for the ear-
liest start date and in orange for the latest end date). If the job belongs to a route, its deadlines display 
as vertical dotted lines (in green for the earliest start date and in orange for the latest end date), as in 
the following example:

Job deadlines
Route deadlines



109

Direct Planning 3.4 Scheduling with Direct Planning : Managing calendars

5.5. Managing calendars
The calendar is used to define the following periods, for each machine:

• Regular activity periods
• Exceptional activity periods (occasional work overloads, extra opening days, etc.)
• Regular inactivity periods (periods outside working hours, periods of equipment maintenance, etc.)
• Occasional and planned inactivity periods (public holidays, vacations, etc.)
• Occasional and unplanned inactivity periods (sick leaves, machine downtime, etc.)

5.5.1. Standard days
The definition of standard days is required to create a calendar. You must create at lease one standard 
day to indicate your machine operating hours.

Standard days are available by clicking on Calendars > Standard days in the ribbon:

A standard day is defined by a designation and some shifts:

Click on New to create a new standard day.

Enter a designation for this standard day and define a work shift. By default, no box is checked, which 
is why Direct Planning displays Non-working day�
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Clicking on a shift opens a zone to enter the corresponding times as well as break periods, when appro-
priate:

Multiple shifts can be checked for the same standard day:

Click on Save and close to return to the list of standard days. Note that certain standard days are shown 
in blue in this list. These are preconfigured system standard days that you cannot delete but for which 
you can change the designation.

Click on Use cases to display standard weeks leveraging the selected standard day:

This screen is not only informative: selecting a standard week allows to modifying it by clicking on the 
Modify button at the top right hand corner.

More information about standard weeks in the next section.

◄  When  you  enter  the  working 
hours  for  the shift, Direct Planning 
automatically  calculates  the  corre-
sponding duration.
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5.5.2. Standard weeks

Standard weeks follow the same principles as standard days: whereas standard days break down into 
working hours, standard weeks break down into standard days.

You can access standard weeks by clicking on Calendars > Standard weeks in the ribbon:

When you click on this button, you get the list of standard weeks configured for the schedule:

Click on New to create a new standard week:

◄  After choosing a designation and 
a colour for the week, you assign a 
standard day to each day of the week.

Click on  to pick from the list of 
standard days and on  to view the 
details of the standard day.
If you wish to create a day without 
creating a standard day, click on Specific 
time slot. You can create specific 
working hours from a standard day if 
you select it beforehand.

The  button gives 
access to the configuration of standard 
days.
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By default (if you do not check anything), the week day is a non-working day (similar to the Closing 
standard day in our example).

Colour of a standard week

Colours play an important role in the visual identification of weeks in a calendar. A colour is automati-
cally proposed by default for each standard week. You can modify the colour of the week conventionally 
or click on the colour square corresponding to each day of the week.
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5.5.3. General view of calendars

After defining at least one standard day and one standard week, you can define your calendars.

The general view of calendars is available by clicking on Calendars > Overview of calendars:

This screen is still empty because no calendars have been yet created. The quick action icons in the 
upper-right corner give access to the configuration of standard days/weeks and public holidays. Follow 
these steps to configure the new calendar:

1. Selection of the new calendar scope: 

You can refine the selection of scope by clicking on Period selection:

2. Selection of machines governed by the calendar:

When this is configured, the selected machines are the only ones displayed in table column headers.

◄ Use this screen to narrow the display of the 
calendar.
In this example, the calendar will only display 
the second semester for the year 2018: weeks 
26 to 52.
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our Advice 

You do not have to filter the list of machines: you may as well leave them all displayed, even if they are 
governed by different calendars. When creating calendars, you will have the option to do this by select-
ing the concerned machines beforehand.

3. Now that the “When” and “What” questions are answered, we can start to fill the calendar with an 
annual standard week, which will be discussed in more details in the next section.
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5.5.4. Annual standard week
The annual standard week: defines the reference standard week used throughout the year. You will be 
able to add exceptions at a later stage.

First select the weeks/machines governed by the annual standard week (the selected cells are shown 
in blue):

• You can click on a column to select a machine and all the weeks of the calendar.
• You can “draw” a rectangle with your mouse to select the machines/weeks of your choice.
• You can select all machines and all weeks by right-clicking in the calendar and choosing Select all 

cells�

When your selection is made, click on the  button, in the lower part, on the Annual standard week 
line.

The annual standard week selection window opens, listing the standard weeks previously configured.

Select a standard week, which will populate the selected cells:

This sequence of tasks is shown below:

Selection of all calendar 
weeks for the Usinex  1 
machine

Opening of the annual 
standard week selection 
screen.

Selection of the annual 
standard week.
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To delete an annual standard week from the calendar, selected the concerned weeks and click on the 
icon circled below:

For the sake of readability, this documentation offers a narrow view of the calendar. However, you 
should adopt an holistic vision, in particular to benefit from the colours associated to standard days/
weeks:

Annual standard week 
applied to the Usinex  1 
machine
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5.5.5. Weekly standard week

You can force weeks (which are different from the annual standard week) for certain machines.
In a way, this action is like managing exceptions.
To do this, you must first select the concerned weeks and machines before choosing a week:

2 methods offer the ability to can force a weekly standard week:

Method 1: by clicking at the bottom of the screen on the Weekly standard week line, in a similar way 
as for configuring the annual standard week:

Method 2: by right clicking on the selected week, and choosing Edit standard week:

The weekly standard week Closure displays in W1 for machines Usinex 1 and Usinex 2:

◄ Usinex 1 and Usinex 2 machines 
are currently subject  to  the annual 
standard  week  previously  config-
ured (2x8).

Let's  assign  them  the  Closure 
standard week  for  the 1st week of 
the calendar year.
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reminder  

As a general rule, remember that the right-click always opens a context menu with the most common 
actions.
Right-click to view the available choices! Try on a selection of weeks/machines, on a column header (that 
is the name of a machine), on a week, etc.

To modify a weekly standard week for a single machine, a rapid method is to double-click on the corre-
sponding cell, displaying the standard weeks available in a dropdown list:

In the same way as to delete an annual standard week, click on the icon circled below to delete a weekly 
standard week:
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5.5.6. Displaying week details

To display the details of the selected week, right click on the concerned week and click on Show details�

This detailed view provides you with 2 choices:

1. Force one or more days within this week (exception at the level of the day).
2. Force the working hours for a specific day (exception at the level of the working hours for a day).

Two cases may occur: 

• Your selection covers a single week, the 7 days are displayed in details. You can modify the dates of 
your choice. If you modify one of these days, your modification will only affect that very day, unique 
in the year. :

• Your selection straddles multiple identical weeks. If you modify any of the 7 days, Monday for exam-
ple, your modification will apply to all Mondays of your selection.

To force an exceptional day within the week, click on the  icon in the line of the affected day and 
select the standard day of your choice. The new standard day displays in the detailed view:

In the example above, an exceptional day is configured on the Friday. Visually, this exceptional day 
stands out from the others with its yellow background. In the calendar, the week displays in bold to 
indicate that it contains an exception:

To force exceptional working hours within the week, click on the  icon in the line of the affected day 
and select the hours of your choice. The new standard hours display in the detailed view:
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In the example above, an exceptional day is configured on the Thursday. Visually, this exceptional day 
stands out from the others thanks to its pink background. Similar as when we impose a standard day, 
the week displays in bold to indicate that it contains an exception.

The  icon only shows the hours for the selected day.

Whether the change affects days or hours, a warning informs you that the week was modified:

At the bottom right of the window, a caption reminds the status of standard days according to their 
typography:

Another caption is also available at the top right of the window, when clicking on the  icon:

◄ You can move this window where you want in the 
general view of calendars.
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5.5.7. Copying/pasting/deleting in the calendar

These operations mimic Windows standard functions, briefly reminded below:
Before any copy, you must select a cell or a range of cells to copy.
After selecting cells, the following operations are available:

• Copy/paste selection: use Windows standard Ctrl+C/Ctrl+V shortcuts to copy/paste jobs quickly in 
your calendar. Otherwise, these actions are also available from the context menu on a cell.

• Copy selection to machine: if your selection covers only one machine, you can copy it to one or more 
other machines. Select the weeks and choose Copy selection to machine in the context menu:

This will make an exact copy of weeks

• Paste selection with options: this special paste function is available to choose the elements to paste:

• Copy/paste the whole calendar of a machine: click on a column header to select the whole calendar 
of a machine. In the context menu, select Copy calendar or Copy calendar to machine. Then click 

 right-click
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on the column header corresponding to the destination machine and click on Paste calendar or 
select directly the destination machine after clicking on Copy calendar to machine�

Deleting calendar elements

Different options are available to delete calendar elements. The simplest way is to select the desired 
weeks/machines and press the Del key. This action only lets you delete the weekly standard weeks or 
the exceptional days/hours applied to the selection:

Checking these two options resets the week to the annual standard week.

Completely deleting a calendar

To delete the annual standard week of a machine and clear its calendar, right-click on the column head-
er and choose Delete annual standard week > < No imposed standard week >. You will be asked to 
confirm.

   This operation cannot be cancelled!
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5.5.8. Displaying the list of calendars

Click on List of calendars under the Calendars tab of the ribbon to view the list of calendars:

The list of calendars displays all the calendars configured for each machine of your schedule. To view the 
calendar of a machine, select a machine and click on Machine calendar, thereby opening its Detailed 
view (see next section).

The list of calendars also enables you to view the Calendar of condensed time scale. This calendar 
defines the periods which will be hidden when selecting the Compact time scale option, under the 
Display tab.

This screen allows the definition of non working hours shared by all your machines, which need not be 
displayed. Therefore, the calendar of condensed time scale affects your company as a whole. The con-
densed time scale is configured the same way as standard calendars.

Note
Breaks affecting day shifts are hidden by the condensed time scale.
This preserves the existing behaviour when switching from Direct Planning 1 to a newer version of 
Direct Planning. Indeed, in this case, old working hours are all converted to day shifts, regardless of 
the actual hours.
On the other hand, breaks affecting Morning, Afternoon and Night shifts are not hidden�
This avoids having to create standard days and standard weeks dedicated to the condensed time scale.
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5.5.9. Detailed view
The detailed view offers an overall picture of a calendar (for a machine).
Each line of the table represents a week, whereas each column represents one of the 7 days of the 
week.
The background colour is directly linked with the colour of the standard week:

The upper part displays: 

• The year of the calendar (A);
• The affected machine (B);
• The configured annual standard week (that you can modify, delete or copy to another machine) (C);
• The standard shortcut icons (D); and
• The calendar itself (E).

The lower part of the screen displays functions similar to those of the general view, with the ability to 
configure weekly standard weeks and exceptional standard days.
Graphic indications, summarised at the bottom right in the caption, are the same as in the general view. 

B

E

A

C
D
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5.5.10. Management of public holidays

Use this function to select public holidays for all or part of your machines.
It is available under the Calendars > Management of public holidays tab:

Follow these steps to add public holidays to your calendar:

1. Check that the year displayed is the current year. If needed, use left and right arrows to display the 
desired year or type it.

2. Select the relevant calendars. As a reminder, one machine = one calendar.
3. Then select the public holidays in the list.

Above the list of public holidays, check that your country is displayed.
If needed, open the dropdown list to change it.
The background colour of days reflects their nature:
• Yellow background: official public holidays, checked by default
• Grey background: public holidays affecting only a portion of the territory, unchecked by default
• White background: informal public holidays, unchecked by default

4. On the right, select Add selected public holidays  to add them to the calendars of the related ma-
chines.

Note
The list of public holidays is not static: click on Customize this list to import, export, create, modify and 
delete public holidays.
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5.5.11. Tools

The toolbox is available under the Calendar > Tools tab:

Follow the displayed sequence for batch processing:

0. Check that the year displayed is the current year.
1. Select the relevant calendars
2. Select an action to perform on the selected calendars
3. Enter the information required by the selected action:

Modify yearly standard week.        Modify weekly standard week.

This menu offers the Batch processing to make mass actions on all or part of your calen-
dars (modification or deletion of annual standard weeks, weekly standard weeks or stand-
ard days):
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Modify standard day.         Delete calendar for this year.

Delete a weekly standard week.                                Delete a standard day.
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5.6. Planning assistance
Planning assistance encompasses a set of powerful tools to optimise the schedule while also respecting 
time constraints.
When planning assistance is active, Direct Planning applies the following rules to all jobs located within 
its scope.

• Respect of route constraints: Within a route, Direct Planning automatically moves all jobs positioned 
downstream of the moved job in order to respect the precedence constraints. The respect of these 
constraints can also take into account the duration of gaps and overlaps.

• Jobs which started prematurely are automatically moved to start in time.

To enable planning assistance, click on Planning assistance in the ribbon and on the Planning assis-
tance button:

Direct Planning offers 3 adjustment options:

5.6.1. Planning assistance without adjustment
If you select this option, moving the job leave a gap behind it, which is not filled automatically. Similarly, 
the moved job is not automatically placed against the previous or following job:

Before

After

If the job belongs to a route, the movement also affects the other routed jobs on the same principles.



129

Direct Planning 3.4 Scheduling with Direct Planning : Planning assistance

5.6.2. Planning assistance with adjustment
Adjustment to the left

Adjustment at the earliest (to the left) is used to perform each job as soon as possible.
When active, unjustified gaps between 2 jobs of the same machine are shrunk in order to compact the 
schedule.
The following illustrates this:

Before

After

Adjustment to the right

Adjustment to the right follows the same principle: jobs are moved as late as possible while also 
respecting time constraints.

AdministrAtion 

The administrator can define the behaviour of adjustment to the left/right in General configuration > 
Planning assistance in order to avoid jobs being thrown too far down the schedule.

Screen captures shown on the next page are derived from this screen.

◄ If you choose 05:00 as beginning of the day and 
limit the left adjustment to the day, then jobs will be 
pushed leftwards to 05:00.
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In the period covered by planning assistance, you can limit the adjustment of jobs at the earliest and 
latest. In both cases, you can limit the adjustment to the dates configured by the administrator (see next 
section), to the day or to the week.
These last two cases ensure you that a job will not leave the day or the week in which you affected it.

Boundaries

To function, the planning assistance module needs boundaries defining the time scope of its opera-
tions. Therefore, the planning manager has to define these boundaries.
The planning assistance module will only process jobs included in this frame: jobs placed in the distant 
future will not be affected by planning assistance.

Moreover, we just saw that within this time frame, the administrator can limit the earliest/latest adjust-
ment of jobs to the day or week. Without losing the optimisation offered by the adjustment of jobs, this 
will ensure you that a job will not leave the day or week to which you assigned it.

To define the boundaries of planning assistance, click on Planning assistance > Set limit dates in the 
ribbon:
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5.6.3. Movement with grouping
When moving jobs, users can ask for the jobs of the route to be grouped. This function is available un-
der the Planning assistance tab of the ribbon:

To move a job with route grouping, move the route while holding the Alt key.
In the following example, the movement with grouping is activated for All jobs of the route:

When moving job B (to the right or left) while holding Alt, the upstream (A) and downstream (C) jobs are 
moved as closed as possible to job B:

The grouping can also be performed without movement, by right clicking on the job and selecting Gath-
er the jobs of the route�
You can also do it for all routes of a machine via the context menu of that machine. This grouping is 
particularly relevant for schedules which do not benefit from planning assistance. Uncontrolled inputs 
can lead to route inconsistencies which need rectification (for example when activating planning assis-
tance).

At the machine level, the grouping of jobs is performed to Fix route inconsistencies, allowing also to 
enter the scope of grouping by typing start and end dates:

◄ Clicking on these options does not perform the actual movement 
but defines which jobs will remain grouped after the movement.

◄  Jobs belonging to the 
same route are grouped af-
ter a slight shift of job  B to 
the left.
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5.6.4. Workload histogram

The workload histogram is used to analyse the workload and the capacity by machine and section. You 
have different possibilities to access it:

 ◄ Planning assistance tab in the ribbon

Right-click on a section ►   

Right-click on a machine ► 
Result:

Right clicking on the histogram allows to copy/save/print the image.

The left of screen contains two tabs to configure the histogram: Building and Selection:
◄ Workload: displays the machine workload (in blue on the graph)

Workload to schedule: displays the workload to plan (in orange on the 
graph). The workload to schedule can only be displayed if the workload 
is also requested. The scheduled overload is also displayed (in red on 
the graph).

Availability: displays the machine idle time (in green on the graph).

Capacity: displays the total capacity of the machine (the green back-
ground on the graph).

Opposite to this information, check the Values box to display data with 
its respective values.

Choose the Time scale of the histogram by checking the corresponding 
button, as well as the period it covers.
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When you change the configuration of the histogram, do not forget to click on the Refresh button at the 
top left to update the graph.
In addition to the traditional buttons for previewing and printing the histogram, this area can also be 
used to perform an Excel export of the histogram in various formats:

Note
Whatever the format, the histogram is exported as data and not as a graph.

◄ Check one of the three buttons according to your choice:

All for an histogram encompassing all machines

Section/Machine to select the sections/machines included in the 
histogram.

Below, use the Add a histogram by section and Add a histogram 
by resource boxes to add histograms for each section/machine, in 
addition to the overall histogram (which will display at the bottom 
of the list) 
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5.7. Planning with lists
This function is available from the ribbon, under the Home > Schedule via a list tab:

It is also available from various context menus (e.g. on the name of the machine to the left of the 
schedule) or by selecting a job and pressing Ctrl+P.

Planning with lists offers the ability to schedule jobs via vertical drag and drops in a special list, 
complementing the Gantt chart already used:

On the left, this window features a few standard columns which cannot be modified. On the right, 
columns can customised for this shop floor section (by right-clicking the column header). This way, 
technical data helpful to job scheduling can be displayed as columns.

For any section, the background colour of columns End and Lckd (Locked) can be customised to reflect 
for instance important technical data for this section. You may also colour another column of your 
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choice. In the example above, colouring by milling tool optimises the schedule through grouping of jobs 
sharing the same tool.

In these lists, you can select one or more jobs and place them where you want via drag and drop. 
A coloured line indicates whether the job being moved is placed before (green) or after (red) the 
destination job:

The lower part of this screen displays the jobs to schedule for this machine:

In that zone, the U1 and U2 buttons represent the machine codes. They are used to toggle between 
machines, both in the list of scheduled jobs or jobs to schedule.

Clicking in the table also selects the job in the Gantt and conversely (please note that in the example 
below, jobs are greyed out for readability purposes and not because of a processing by Direct Planning):

Double-clicking in the list centres the Gantt by focusing on that job.

In the list, a column of green pictograms shows whether jobs are grouped in the schedule or separated 
by gaps.

Jobs grouped

Jobs not grouped

This list is not designed to be opened all the time because managing both the list and the Gantt inevitably 
extends response times.
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5.8. Optimising planning times
As discussed, planning assistance can group jobs belonging to a route. This section covers a slightly dif-
ferent topic: grouping jobs sharing technical characteristics in order to optimise setting times. First, the 
planning manager wants to be able to identify quickly these jobs and, second, to group them in order 
to optimise times.

Let’s take the example of jobs requiring specific tools whose changes result in time losses.

AdministrAtion 

To optimise this schedule, let’s first create a formula reflecting the fact that the setting time is reduced 
when the same tool is used for the previous job (Configuration > Setting time):

Then, the last line of tickets is configured to have its colour reflect the tool number (Configuration > 
Display modes):

This results in the following display (before optimisation):

The planning manager now has to group jobs sharing the same colour in order to shorten setting times, 
materialised below by the black bottom bar:

our Advice 

To tailor the configuration to your business needs, please contact the Volume Software team.
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5.9. Searching jobs

5.9.1. Search

Multiple methods can be used to find jobs quickly. The typical way is to access the Home tab of the rib-
bon and click on Search and lists:

The first tab allows the entry of basic search criteria (for example by setting time boundaries in the 
upper part).
It also offers the ability to select different job filters based on their status (Option zone), their type (Only 
see zone) or the machine which they depend on (Only search on machines zone).
If you do not set any criteria before clicking on Display list, Direct Planning will display all scheduled 
jobs.
If basic criteria are not sufficient, you can refine your search by clicking on the Advanced criteria tab.

◄ This button is split in 2:
Upper part: opens the search screen
Lower part: opens the list selection/creation screen (if you have the required permis-
sions)
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� Choose a first filter

� Choose a second filter refining the first

To customise the result window, click on the Options tab.

��

◄ The left side of this window offers the ability to define 
the sorting order of the results, with the possibility to 
apply an ascending or descending order for each of the 
3 hierarchical levels.

The right side of the window offers the ability to define 
the printing options for the list of results: page break 
and total/subtotal printing ▼
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To display the list of jobs matching your criteria, click on Display list. The list of matching jobs displays 
under the Result tab:

From this search result window, multiple actions are available:

• Use the filters located above the column headers.
• Select the job by double-clicking on the corresponding line.
• Access quickly common actions by right-clicking on a job.
• Highlight found jobs by clicking Highlight at the bottom of the window.
• Filter found jobs by clicking the Filter button at the bottom of the window, or use the Filter this 

value function via right-click on a cell to quickly add/delete a filter.

If possible and set in the options, a counter displays the column totals.

Quick search

To find jobs quickly, right-click on a machine/section and select the Search on this machine/section 
action. This opens the window above and displays by default all jobs scheduled for this machine/section.
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5.9.2. Current route

From the Home tab of the ribbon, the Current route button (Ctrl+ G) opens a small window which can 
be moved anywhere. This window can be minimized by clicking See less or by double-clicking on the 
header:

When selecting a job in the schedule, this window displays all jobs belonging to the same route.

The Highlight button allows to highlight instantly all jobs of the route (see section 5.9.4, Filter and High-
lighting for more information):

◄ Double-click in this table to browse through the schedule and 
access quickly the jobs belonging to the route:
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In this table, use the context menu to modify a job or change quickly its progress status:
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5.9.3. Locator

From the Home tab of the ribbon, the Locator (Ctrl+ L) button opens a window dedicated to quick 
search. This window can be minimized by clicking See less or by double-clicking on the header:

Use the “Search” tab to define your most used search criteria (e.g.: File number, Tool number, Special 
technical data, etc.). In addition to more traditional input methods, use the Selected job button to pop-
ulate a criterion automatically based on the job currently selected, avoiding keyboard inputs:

The Result button executes that search and displays the list of resulting jobs. The columns in this list 
can be customized by right clicking on the header:

▲ Selection of a reference job

▲  Selection of the Processing complexity as the 
search criterion, then click on Selected job to 
choose a reference job.

Filter on the Form code of the selected job ►
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Use the Highlight button to spotlight all found jobs found (more information about highlighting in the 
next section):

◄ From this list, double-click to navigate quickly to the job, or right-click to 
modify this job (via the Job detail option) ▼
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5.9.4. Filter and Highlighting

These two options are available under the Home tab of the ribbon:

Use the filter and highlighting functions to isolate/spotlight certain jobs depending on their characteristics. 
First select in the dropdown list the common feature that you wish to highlight. Then click on a job to 
isolate/spotlight the other jobs sharing that feature:

In the example above, the filter is applied to the customer. The jobs attached to the same customer are 
the only ones displayed in the Gantt: all the others are hidden. Click again on the filter button to cancel 
the filter.

The example below illustrates highlighted jobs meeting the same criteria as the filter above. Highlighted 
jobs are the same colour and, unlike the filter function, jobs which do not meet the criteria are not 
hidden but greyed out:

When the highlight is based on data such as machines or operations, the highlight colour is the one 
chosen by the administrator for the involved machine or operation.

Shared by both functions, the navigation buttons can be used to browse through filtered/highlighted 
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jobs.

Note
The filtering and highlighting function can be combined. However, the highlighting functions available 
via the Current route and Locator options are mutually exclusive: you must first disable one to enable 
the other.
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5.10. Alerts
5.10.1. Configuring alerts

AdministrAtion 

Alerts are configured via the Configuration > General configuration > Alerts tab:

Use this window to select events which will trigger an alert, as well as the colour of the corresponding 
alert.
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5.10.2. 5.10.2. Viewing alerts in the schedule

Gantt

AdministrAtion 

Reminder: to enable/disable alerts in the schedule and choose the line on which they will appear in the 
ticket, click on Configuration > Display modes > Job display:

Depending on the schedule zoom level, it is fairly common for the alert to be displayed incompletely on 
the ticket (as in the example above). To display the alert message in full without opening the job details 
window, place your cursor on the job. The popping tooltip recaps the characteristics of the job, includ-
ing alerts, preceded by (!) :

If the job is subject to multiple alerts, the number of additional alerts displays at the end of the alert:

Again, you just have to place your cursor on the job to view the list of associated alerts:
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Alert window

In addition to displaying alerts on jobs in the Gantt, you can display all alerts by clicking on Display > 
Alerts (Ctrl+W) in the ribbon:

This opens the list of jobs with alerts, at the left of the projection:

5.10.3. Creating alerts

Direct Planning automatically creates a number of alerts, including those about time constraints and 
machine incompatibilities.

As stated in the section discussing the jobs details screen, users can also create manual alerts via the 
Alerts tab.

◄ In the upper part of the List of jobs with alerts, you 
can:

• Minimize the window
• Push the window to the right or left of the screen
• Filter the displayed alerts
• Display the list on another screen

Each box represents a job with alerts. The nature of 
alerts depends on their background colour, as config-
ured by the administrator.

To clear an alert, you just have to click on the corre-
sponding red cross.
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5.10.4. Clearing alerts

Alerts can be cleared from the List of jobs with alerts but other methods are available:

• In the job details window, Alerts tab
• By clicking on Display > Alerts > Clear alerts in the ribbon. Use this window to clear all alerts affect-

ing jobs scheduled before a given date (the current date by default)

If alerts have been cleared accidentally, click in the ribbon on Display  > Alerts > Rebuild alerts to 
regenerate them.
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ERP (*) DIRECT PLANNING

Standard import
Sending of schedule modification instruction

Standard export
Scheduling information sent back to ERP (*)

ERP

DIRECT PLANNING

Transmission of planned deadlines to the ERP

MES

Transmission of the production progress status

Transmission of planning modifications to the MES

Standard import

Standard export

Standard import

Standard export

WO Creation/Modification in the schedule

6. Interfacing an ERP with Direct Planning

AdministrAtion 

This section is fully reserved to the Direct Planning administrator.

6.1. Summary diagram
Overview

(*) ERP, CAPE, Excel

Example in the industry sector: ERP+MES 



152

Direct Planning 3.4 Interfacing an ERP with Direct Planning : Summary diagram

6.1.1. Principles

An application managing jobs can send information to your schedule. The imported data can come 
from an ERP, a spreadsheet such as Microsoft Excel© or any other application generating data in CSV 
format.
The CSV format is one of the most widespread: data is recorded in a text file and separated by semicolons 
(more information below).

In addition to this import function, Direct Planning can transfer planning data to another application 
able to receive data in the CSV format or in the format of your choice via development of a plugin 
(following a study). You can use the export functionality without configuring the import beforehand.
Using the import and export functions together allow Direct Planning to send the external software 
scheduling information for previously imported jobs.
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6.2. Importing data
As discussed, a third party application (e.g. ERP, CAPE, specific program or Excel macro) can generate 
instructions for Direct Planning. These CSV files can be automatically integrated to the schedule when 
they are placed in an import directory. To avoid disrupting the existing planning, imported jobs are 
assigned the “to schedule” status.

6.2.1. Direct Planning import capabilities

Direct Planning can import the following data:

• Reference data (DREF1 to DREF999)
• Entities (ENT1 to ENT10)
• Jobs with flags (TASK)
• Process Information (TASK-IP1 to TASK-IP999)
• Links (LINK)
• Technical elements (TEC1 to TEC20)
• Memos (MEMO)

6.2.2. The CSV file

The imported data is contained in a csv file containing instructions for updating the schedule in Direct 
Planning.

Name and location of file

The file name must comply with the import_xxx.csv format and that file must be located in the folder 
configured by the administrator (Configuration > General configuration > Automatic import).
The import folder is scanned each time Direct Planning is started, and then every 2 minutes. Furthermore, 
the planning manager can occasionally perform “on demand” imports when visual alerts indicate that 
a new file is ready for import.

Structure

The file data is saved in a text file and semicolon-separated.
In a file to import, each line forms a record and must end by a carriage return and line feed (CR LF).
Below is an example of instruction to import in Direct Planning:

ENT1;4;CM;CR0549;CREATIVE TECH;Chateaubriant;44110;;BROCHARD Sébastien;+33 (0)2 36 45 78 

99;s.brochard@creativetech.fr;;DEL;;\\SERVER\CLIENT\CR0549;RANDOM;;;;;;;;;

Lines starting with # will be ignored to avoid the import of certain lines, without deleting them from the 
file, especially for test purposes.
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The order of lines in the file to import does not matter.
The program automatically sorts the data in the right order before importing it.

You will find sample import files in your Direct Planning installation folder.

Exclusive locks

An external application writes import files while Direct Planning reads them. If these two actions happen 
simultaneously, there is a conflict. Direct Planning preserves data integrity thanks to a lock management 
which secures the imports:

• When reading an import file, Direct Planning creates the directplanning_read.lck lock file in the 
import folder.

  The external application must not attempt to write the file if this lock exists.

• When writing to the import file, the external application must create the external_write.lck lock file 
in the import folder.

  Direct Planning will not attempt to read the file of this lock exists.

Note
This management is available but optional.
If you know that the generation of import files is never performed when Direct Planning is being used 
(for example at night), this security feature is optional.

External ID (or ERP ID)

Jobs originating from an third party application (like an ERP) have an external identifier.
This identifier is assigned by the third party application for jobs created via import.
Its purpose is to allow the third party application to recognise a job it previously transferred to Direct 
Planning. For convenience, we will call it the external ID.

WARNING
The external ID must never contain the hash sign (#).

When a job is created in Direct Planning, its external ID is set to 0 (zero) and hidden.
The external ID is unique. It can be modified during the import in Direct Planning.
The identifiers are displayed in the job details window, via double-click in the schedule (see next page).
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6.2.3. Data import formats

Formats and Direct Planning versions

Format version Direct Planning version

4 Since Direct Planning 3.1

3 Direct Planning 3.0

2 Direct Planning 2.*

In creation, the required zones are specified in the Comments column.

Direct Planning ID
ERP ID



156

Direct Planning 3.4 Interfacing an ERP with Direct Planning : Importing entities

Importing entities

No. Designation Format Comments

1 Data type alpha Possible values: from ENT1 to ENT10

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha C (Creation)

CM (Creation when the entity does not exist, 

Modification if it already exists). In entity creation, the 

@ sign can be used to force a zone, following the @

ZONE format. However, if the entity already exists, this 

character indicates that the specified zone must not 

be modified.

Required

4 Identifier alpha Job identifier for the ERP

Required

5 Designation alpha

6 Configurable area 1 alpha Configurable areas are typed.

If the value transmitted in the import file does not 

match the type of zone, it will be ignored (e.g. an “ABC” 

string exported to a zone set as numeric).

7 Configurable area 2 alpha

8 Configurable area 3 alpha

9 Configurable area 4 alpha

10 Configurable area 5 alpha

11 Configurable area 6 alpha

12 Configurable area 7 alpha

13 Configurable area 8 alpha

14 Configurable area 9 alpha

15 Configurable area 10 alpha

16 Colour alpha 3 methods are available to express the colour:

RGB: (3 comma-separated values)

Html name

The RANDOM keyword can be used to set a random 

colour when creating technical elements
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No. Designation Format Comments

17 Identifier of linked entity 1 alpha

Links between entities are optional.

When links are included in the import file, the 

presence of linked entities is checked.

18 Identifier of linked entity 2 alpha

19 Identifier of linked entity 3 alpha

20 Identifier of linked entity 4 alpha

21 Identifier of linked entity 5 alpha

22 Identifier of linked entity 6 alpha

23 Identifier of linked entity 7 alpha

24 Identifier of linked entity 8 alpha

25 Identifier of linked entity 9 alpha

Notes:

• There can be no link for entity 1 which sits at the top of the hierarchy.

• Entity links are always created “upwards”: for instance, if entities 2 and 3 are linked, the link must be 
declared from entity 3 to entity 2, and not the opposite.

• Links must respect the hierarchy: for example, if entity 3 is linked with entity 2 and entity 2 is linked 
with entity 1, then entity 3 must also be linked with entity 1.

• There can be no duplicate, neither in the identifier nor in the designation of entities.

• If a duplicate is found in the identifier of an entity, a warning message is generated. This situation 
can be normal when importing a job attached to an existing customer: the customer is reimported 
with the new job, triggering a normal warning message.

• If there is a duplicate in the designation of an entity (different identifier but identical designation), 
the import will add the identifier in parentheses after the description.

Example of instruction to import an entity (in creation/modification):

ENT2;4;CM;PA0001;AUTOM-Z/528;AUT;WB9752;16072;92.5 x 49 x 93.5;;;;;;;RANDOM;CR0549;;;;;;;;
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Importing reference data

Reserved to the Industry mode.

No. Designation Format Comments

1 Data type alpha Possible values: from DREF1 to DREF999

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha C (Creation)

CM (Creation when the reference data does not exist, 

Modification if it already exists)

Required

4 Identifier of the reference data alpha Required

5 Designation of the reference data alpha

6 Colour alpha 3 methods are available to express the colour:

RGB: (3 comma-separated values)

Html name

The RANDOM keyword can be used to set a random 

colour when creating reference data. If CM: not 

modified

Notes:

• There can be no duplicate, neither in the identifier nor in the designation of reference data.

• If a duplicate is found in the identifier of reference data, a warning message is generated. This 
situation can be normal when importing a job with existing reference data: the reference data is 
reimported with the new job, triggering a normal warning message.

• If there is a duplicate in the designation of reference data (different identifier but identical 
designation), then the import will add the identifier in parentheses after the description.

Example of instruction to import reference data (in creation, designation in green):

DREF1;4;C-NOERROR;0;Nouveauté;RANDOM
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Importing jobs

No. Designation
Mode

Comments
I P S

01 Data type    Value: TASK
Format: alpha
Required

02 Version of import format    Values: 4
Format: alpha
Required

03 Action    Action code
Format: alpha
Required

04 Unique external identifier 
for this job (ERP ID)

   Your unique identifier for this job, or the Direct Planning 
identifier.
Normally, this is where you indicate your unique identifier 
for this job. Instead of your identifier, you can specify the 
Direct Planning identifier preceded by the hash sign (#).
Format: alpha
Required

05 Move selection down    Format: alpha

06 Identifier of resource    Format: alpha
When creating a job, use the @ character to pre-position 
the job on the specified resource. If the job already exists, it 
indicates that this resource must not be modified.
Required

07 Operation identifier    If it is #DEF, the job operation will be initialised to the 
machine default operation.
If blank, content is forced to blank.
Format: alpha

08 Start date and time    The start or end time must be indicated, but not both.
If none is entered, the start date is forced to the current 
date and time.
Format: datetime*

09 End date and time   

*Datetime formats available:
• DD.MM.YYYY hh:mm (with a space between the year and time)
• DD/MM/YYYY hh:mm (with a space between the year and time)
• DD.MM.YYYY
• DD/MM/YYYY
• “NOW”: conversion to the date and time of the import

10 Planned quantity    Format: quantity

11 Percentage of variable 
waste

   Only one decimal taken into account
Format: 3 or 3.0 for 3% of variable waste
Format: decimal

12 Number of WU to produce 
per operative WU

   The number of working units of quantity to produce 
contained in a working unit of operative quantity.
e.g. the number of posters (representing the quantity 
recorded in production) per sheet (representing the 
quantity processed by the machine). 
By default: 1�

13 Number of work rate WU 
per operative WU

   The number of working units for entering the work rate 
contained in a working unit of operative quantity.
E.g. the linear footage (unit in which is entered the machine 
work rate) for a sheet (representing the quantity processed 
by the machine).
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No. Designation
Mode

Comments
I P S

14 Performed quantity    Will be entered only if the ERP is to force the performed 
quantity. Forcing this value will automatically calculate the 
progress percentage.
Format: quantity

15 Non-compliant quantity    Non-compliant product quantity
Format: quantity

16 Progress percentage    Value: from 0 to 100.  
Not to be entered if the performed quantity is specified. 
If the planned quantity is entered, this value will allow the 
calculation of the performed quantity.
Format: integer

17 Forced transition time    Should be entered when forcing a transition duration (be 
careful, 0 is a value). 
Otherwise, leave it blank.
The value must be ignored if management of transition 
times is not enabled in the schedule.
Format: duration**

** Durations can be expressed in two ways:
• An integer indicating the number of minutes (e.g. 120)
• A number of hours and a number of minutes separated by the character “:” (e.g. 7:50)

18 Forced planned setting 
duration

   To be entered when forcing the planned setting duration. 
Leaving it blank will make DP calculate setting duration.
Format: duration

19 Performed setting duration    Should be entered when the ERP is aware of the performed 
setting duration.
Format: duration

20 Performed durations of 
setting downtime

   Durations of downtime incurred by setting
Format: duration

21 Completed setting    Allows to indicate that the setting is complete.
O/N or Y/N or 0/1
Format: O/N

22 Industry: Forced planned 
running duration

   Industry mode: to be entered when forcing the planned 
running duration.
Leaving it blank will make Direct Planning calculate running 
duration.
Format: duration
Required in Project and Service modes

Service: Duration

Project: Planned duration

23 Industry mode: Performed 
running duration
Project mode: Performed 
duration

   To be entered when the ERP is aware of the performed 
running duration.
Format: duration

24 Duration of downtime    Should be entered when the ERP is aware of the downtime 
durations during running.
Format: duration

25 Earliest start date and 
time***

   Format: datetime

26 Latest end date and 
time***

  

*** In Industry and Project modes: if the format imported to this field is a short format (DD/MM/YYYY), the program will 
automatically set the default time configured.
Otherwise, the imported time is used even if it is 00h00.
If the field Earliest start date is not populated, it will be initialised by Direct Planning to the date of the import.
Of course, the Latest end date field is left blank if the expected element is not received.
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No. Designation
Mode

Comments
I P S

27 Manual alert message    Used to force a manual alert message on the job.
Format: alpha

28 Actual start date of job    Format: datetime

29 Actual end date of job    Format: datetime

30 Started job    If value is O and field 28 is empty, the job current start date 
is used.
Format: O/N

31 Completed job    If value is O and field 32 = 0, field 29 is ignored.
The job current end date is used.
If value is O and field 32 = 1, field 29 is ignored.
The calculation of end date is based on the performed 
durations.
If value is O and field 32 = 2, field 29 is required. The 
performed running duration is calculated automatically.
Format: O/N

32 Method of time entry    0=none / 1=by performed duration / 2=by end date
Format: integer

33 ID of entity 1    alpha

34 ID of entity 2   

35 ID of entity 3   

36 ID of entity 4   

37 ID of entity 5   

38 ID of entity 6   

39 ID of entity 7   

40 ID of entity 8   

41 ID of entity 9   

42 ID of entity 10   

43 Configurable area 1    alpha

44 Configurable area 2   

45 Configurable area 3   

46 Configurable area 4   

47 Configurable area 5   

48 Configurable area 6   

49 Configurable area 7   

50 Configurable area 8   

51 Configurable area 9   

52 Configurable area 10   
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No. Designation
Mode

Comments
I P S

53 ID of technical element 1    alpha

54 ID of technical element 2   

55 ID of technical element 3   

56 ID of technical element 4   

57 ID of technical element 5   

58 ID of technical element 6   

59 ID of technical element 7   

60 ID of technical element 8   

61 ID of technical element 9   

62 ID of technical element 10   

63 ID of technical element 11   

64 ID of technical element 12   

65 ID of technical element 13   

66 ID of technical element 14   

67 ID of technical element 15   

68 ID of technical element 16   

69 ID of technical element 17   

60 ID of technical element 18   

71 ID of technical element 19   

72 ID of technical element 20   

Flag 1

73 Status    Values: 0 to 5
Format: num

If this zone is not populated, the zero value is set by default, meaning that the flag is inactive.
When dealing with an indicative flag, this zone accepts values 0 (inactive) or 1 (active).
When dealing with-a multi-status flag, this zone accepts values ranging from 0 (inactive) to 5.

74 Planned date of receipt***    Applies only to Waiting for element receipt flags
Format: datetime***

*** In Industry and Project modes: if the format imported to this field is a short format (DD/MM/YYYY), the program will 
automatically set the default time configured.
Otherwise, the imported time is used even if it is 00h00.

75 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

76 Configurable area 1   

77 Configurable area 2   

78 Configurable area 3   

79 Configurable area 4   
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No. Designation
Mode

Comments
I P S

80 Configurable area 5   

81 Configurable area 6   

82 Configurable area 7   

83 Configurable area 8   

84 Configurable area 9   

85 Configurable area 10   

Flag 2

86 Status    Values: 0 to 5
Format: num

87 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

88 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

89
▼
98

Configurable area 1

Configurable area 10

  

Flag 3

99 Status    Values: 0 to 5
Format: num

100 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

101 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

102
▼
111

Configurable area 1

Configurable area 10

  

Flag 4

112 Status    Values: 0 to 5
Format: num

113 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

114 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

115
▼
124

Configurable area 1

Configurable area 10

  

Flag 5
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No. Designation
Mode

Comments
I P S

125 Status    Values: 0 to 5
Format: num

126 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

127 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

128
▼
137

Configurable area 1

Configurable area 10

  

Flag 6

138 Status    Values: 0 to 5
Format: num

139 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

140 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

141
▼
150

Configurable area 1

Configurable area 10

  

Flag 7

151 Status    Values: 0 to 5
Format: num

152 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

153 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

154
▼
163

Configurable area 1

Configurable area 10

  

Flag 8

164 Status    Values: 0 to 5
Format: num

165 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

166 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

167
▼
176

Configurable area 1

Configurable area 10
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No. Designation
Mode

Comments
I P S

Flag 9

177 Status    Values: 0 to 5
Format: num

178 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

179 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

180
▼
189

Configurable area 1

Configurable area 10

  

Flag 10

190 Status    Values: 0 to 5
Format: num

191 Planned date of receipt    Applies only to Waiting for element receipt flags
Format: datetime

192 Actual date of receipt    Only for Waiting for receipt types of flags. Will only be 
taken into account if the status of the flag corresponds to a 
received element.
Format: datetime

193
▼
202

Configurable area 1

Configurable area 10
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Action codes

Action code Description

C Creation of a job

CM CM (Creation when the job does not exist, Modification if it already exists).

M Job modification

M-PLAN Job modification with assigning of the “to schedule” status.

This allows the external software to decide what will be the impact of a modification on the 

schedule status: this way, after an import, jobs scheduled in Direct Planning can take the to 

schedule status because of significant changes which took place in the external software.

S Job deletion

our Advice 

Each action code can be completed by -NOWARNING and -NOERROR extensions to prevent, respectively, 
the display of a warning or error message. It is recommended to reserve these extensions to the deletion 
action (S), when deleting an element to replace it (like in the “cancel and replace” example of the next 
section). 

 Job modifications (CM, M, M-PLAN)

1. The 4 first zones are required as they form the key used to formally identify a job and the action 
to perform. These zones are the following: 01-Data type 02-Version of the import format 03-Action 
04-External unique identifier (ERP) for this job. 

2. The zones which must not be modified must contain the @ sign.

3. Zones 08 and 09 (start and end date and time) can only be modified if you assign the job the to 
schedule status (action code M-PLAN above).

4. The zones requiring modification must contain the new value. If a zone is empty, this means that its 
content is deleted.

5. To modify a job based its Direct Planning internal ID, and not on its external ID, you must put a hash 
sign (#) at the beginning of zone 04 (external ID) in the import file on a line where the action code = 
M (Modification). For example, indicating #120 modifies the job with Direct Planning internal ID 120. 
This is useful to modify jobs created in Direct Planning.

6. You can also modify the external ID. Indeed, for a job created by Direct Planning and not yet attached 
to an external ID, the ERP ID is zero. An external ID can then be assigned to the job by preceding it 
with the | (pipe) character. Examples: #120|ABC to find the job with internal ID 120 and assign it the 
external ID ABC, or TUV|ABC to modify the job with external ID TUV and change it to ABC.
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7. When modifying a job which has an external ID and which was split into multiple jobs, the modifi-
cations apply to all the subdivided jobs (the modification of the duration is the only one forbidden).

Example of instruction to import a job in creation/modification with the “@” character:

TASK;4;CM;180021;Laser cutting;@MAC1;

This instructions specifies that the job designation must always contain “Laser cutting”, whether the 
job exists or not. Entering the character @ before MAC1 indicates that if the job is created, it is pre-
positioned on the MAC1 machine. However, if the job already exists, @ indicates that this zone (the 
machine code) must not be modified. This way, if the planning manager had moved this job to another 
machine, its positioning is preserved.

 Job deletions (S)

1. Deleting a linked job also deletes the links, without deleting the other linked jobs.

2. You can put an asterisk as a wildcard in zone 04 (external ID). For example, indicating 05116001-1-* 
deletes all jobs whose external ID begins with 05116001-1-. This interesting feature allows the ERP 
(e.g. VoluPack) to perform a simple cancel and replace type of regeneration. This can be used to 
delete all operations attached to a WO, and then recreate the WO.
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Importing Process Information

No. Designation Format Comments

1 Data type alpha Possible values: from TASK-IP1 to TASK-IP999

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha CM (Creation Modification): in Process Information 

creation, the @ character can be used to force a zone, 

following the @ZONE format. However, if Process 

Information already exists, this character indicates 

that the specified zone must not be modified.

M (Modification)

S (Deletion)

Required

4 ERP ID alpha Job identifier for the ERP

Required

5 Configurable area 1 alpha Configurable areas are typed.

If the value transmitted in the import file does not 

match the type of zone, it will be ignored (e.g. an “ABC” 

string exported to a zone set as numeric).

6 Configurable area 2 alpha

7 Configurable area 3 alpha

8 Configurable area 4 alpha

9 Configurable area 5 alpha

10 Configurable area 6 alpha

11 Configurable area 7 alpha

12 Configurable area 8 alpha

13 Configurable area 9 alpha

14 Configurable area 10 alpha

Like the job import, the Process Information import is based on the ERP ID or the Direct
Planning. Normally, this is where you indicate your unique identifier for this job. Instead of your identifier, 
you can specify the Direct Planning identifier preceded by the hash sign (#).

reminder  

The hash sign (#) must never be appear in your ERP identifier.

A warning message will be logged in the journal if a Process Information is not active for this machine.
Deleting a job also deletes the associated Process Information.

Example of instruction to import Process info (in creation/modification, ERP ID in green):

TASK-IP1;4;CM;17030187-1-1-1-0/020;EP07075;1300;948;XPC0010;300;2;230;;;
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Importing technical elements

reminder  

To harness the full potential of Direct Planning, you better use Reference data, introduced in version 3.1 
instead of technical elements.

No. Designation Format Comments

1 Data type alpha Possible values: from TEC1 to TEC20

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha C (Creation)

CM (Creation when the technical element does not 

exist, Modification if it already exists)

Required

4 Identifier of technical element alpha Required

5 Designation of technical element alpha

6 Colour alpha 3 methods are available to express the colour:

RGB: (3 comma-separated values)

Html name

The RANDOM keyword can be used to set a random 

colour when creating technical elements

Observations:

• There can be no duplicate, neither in the identifier nor in the designation of technical elements.

• If a duplicate is found in the identifier of a technical element, a warning message is generated. This 
situation can be normal when importing a job with an existing technical element: the technical ele-
ment is reimported with the new job, triggering a normal warning message.

• If there is a duplicate in the designation of a technical element (different identifier but identical 
designation), then the import will add the identifier in parentheses after the description.
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Importing links

No. Designation Format Comments

1 Data type alpha Value: LINK

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha C (Creation)

M (Modification)

S (Deletion)

Required

4 External unique ID for the source job alpha Job identifier for the ERP

Required

5 External unique ID for the destination job alpha Required

6 Link duration Num 0 for a simple end - start link.

n If n > 0: link with n minutes gap.

If n < 0: link with n minutes overlap.

Required

 Link modifications (M)

1. The 5 first zones are required as they form the key used to formally identify the link and action to 
perform.

2. Consequently, field 6 (Link duration) is the only one modifiable.

3. If field 6 contains the @ symbol, this means that nothing is modified.

 Link deletions (S)

1. Deleting a link does not delete the linked jobs.

2. Deleting a link does not delete the other links of the route.

Example of instruction to import a link (in creation, source and target jobs in green):

LINK;4;C-NOWARNING;17030187-1-1-1-0/020;17030187-1-1-1-0/030;0
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Importing memos

Memos contain user comments.

No. Designation Format Comments

1 Data type alpha Value: MEMO

Required

2 Version of import format alpha Value: 4

Required

3 Action alpha CM (Creation when the memo does not exist, 

Modification if it already exists)

Required

4 Job external identifier (ERP ID) alpha

5 Direct Planning internal identifier Num

6 Login of Direct Planning user alpha If internal identifier of DP user does not exist

7 Comment text alpha To create a line break: \\r

Semicolons are replaced by commas.

Double quotes are doubled.

8 State of the alert linked to the comment

9 Date of comment modification datetime

10 Date of comment comment alert datetime
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Colour codes

Html name RGB code Html name RGB code Html name RGB code
AliceBlue 240,248,255 GhostWhite 248,248,255 NavajoWhite 255,222,173
AntiqueWhite 250,235,215 Gold 255,215,0 Navy 0,0,128
Aqua 0,255,255 GoldenRod 218,165,32 OldLace 253,245,230
Aquamarine 127,255,212 Gray 190,190,190 Olive 128,128,0
Azure 240,255,255 Green 0,128,0 OliveDrab 107,142,35
Beige 245,245,220 GreenYellow 173,255,47 Orange 255,165,0
Bisque 255,228,196 HoneyDew 240,255,240 OrangeRed 255,69,0
Black 0,0,0 HotPink 255,105,180 Orchid 218,112,214
BlanchedAlmond 255,235,205 IndianRed 205,92,92 PaleGoldenRod 238,232,170
Blue 0,0,255 Indigo 75,0,130 PaleGreen 152,251,152
BlueViolet 138,43,226 Ivory 255,255,240 PaleTurquoise 175,238,238
Brown 165,42,42 Khaki 240,230,140 PaleVioletRed 219,112,147
BurlyWood 222,184,135 Lavender 230,230,250 PapayaWhip 255,239,213
CadetBlue 95,158,160 LavenderBlush 255,240,245 PeachPuff 255,218,185
Chartreuse 127,255,0 LawnGreen 124,252,0 Peru 205,133,63
Chocolate 210,105,30 LemonChiffon 255,250,205 Pink 255,192,203
Coral 255,127,80 LightBlue 173,216,230 Plum 221,160,221
CornflowerBlue 100,149,237 LightCoral 240,128,128 PowderBlue 176,224,230
Cornsilk 255,248,220 LightCyan 224,255,255 Purple 128,0,128
Crimson 237,164,61 LightGoldenRodYellow 250,250,210 Red 255,0,0
Cyan 0,255,255 LightGreen 144,238,144 RosyBrown 188,143,143
DarkBlue 0,0,139 LightGrey 211,211,211 RoyalBlue 65,105,225
DarkCyan 0,139,139 LightPink 255,182,193 SaddleBrown 139,69,19
DarkGoldenRod 184,134,11 LightSalmon 255,160,122 Salmon 250,128,114
DarkGray 167,167,167 LightSeaGreen 32,178,170 SandyBrown 244,164,96
DarkGreen 0,100,0 LightSkyBlue 135,206,250 SeaGreen 46,139,87
DarkKhaki 189,183,107 LightSlateBlue 132,112,255 SeaShell 255,245,238
DarkMagenta 139,0,139 LightSlateGray 119,136,153 Sienna 160,82,45
DarkOliveGreen 85,107,47 LightSteelBlue 176,196,222 Silver 192,192,192
Darkorange 255,140,0 LightYellow 255,255,224 SkyBlue 135,206,235
DarkOrchid 153,50,204 Lime 0,255,0 SlateBlue 106,90,205
DarkRed 139,0,0 LimeGreen 50,205,50 SlateGray 112,128,144
DarkSalmon 233,150,122 Linen 250,240,230 Snow 255,250,250
DarkSeaGreen 143,188,143 Magenta 255,0,255 SpringGreen 0,255,127
DarkSlateBlue 72,61,139 Maroon 128,0,0 SteelBlue 70,130,180
DarkSlateGray 47,79,79 MediumAquaMarine 102,205,170 Tan 210,180,140
DarkTurquoise 0,206,209 MediumBlue 0,0,205 Teal 0,128,128
DarkViolet 148,0,211 MediumOrchid 186,85,211 Thistle 216,191,216
DeepPink 255,20,147 MediumPurple 147,112,219 Tomato 255,99,71
DeepSkyBlue 0,191,255 MediumSeaGreen 60,179,113 Turquoise 64,224,208
DimGray 105,105,105 MediumSlateBlue 123,104,238 Violet 238,130,238
DodgerBlue 30,144,255 MediumSpringGreen 0,250,154 VioletRed 208,32,144
Feldspar 209,146,117 MediumTurquoise 72,209,204 Wheat 245,222,179
FireBrick 178,34,34 MediumVioletRed 199,21,133 White 255,255,255
FloralWhite 255,250,240 MidnightBlue 25,25,112 WhiteSmoke 245,245,245
ForestGreen 34,139,34 MintCream 245,255,250 Yellow 255,255,0
Fuchsia 255,0,255 MistyRose 255,228,225 YellowGreen 154,205,50
Gainsboro 220,220,220 Moccasin 255,228,181



173

Direct Planning 3.4 Interfacing an ERP with Direct Planning : Importing data

6.2.4. Examples of use

 The WO data changed in the ERP

“Cancel and replace” import

(Instructions are truncated for readability purposes)

The first four lines (dark green) create entities 1, 2, 3 and 4 (customer, product…) via CM action.
The next four lines (light green) create Reference data 12, 13, 14 and 15 (product, type…) via CM action.

The first line (red) deletes all the WO phases via the S action (with NOERROR extension).
Phases (Printing > Cutting > Gluing) are then recreated (green) via the C action.
Corresponding Process Information (blue) is created or, as appropriate, modified via the CM action.
Finally, the links between WO phases (orange) are created via the C action.

Import in “creation/modification”

(Instructions are truncated for readability purposes)

In the example above, the WO is not deleted. Phases are imported via the CM action, meaning they are 
created if they do not exist or modified if they do.
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6.2.5. Course of import and logging

reminder  

To set the import folder, click on Configuration > General configuration > Automatic import�

Assuming that the import file is D:\DirectPlanning\import_001.csv

The import makes the following transactions:

• Creation of a time-stamped history folder, for example: D:\DirectPlanning\

histo\2018.02.01-12:00.

• Saving of the schedule before import, as a dpl2 file in this folder.
• Actual achievement of the import.
• Creation of import detailed logs: D:\DirectPlanning\histo\journal.log and D:\

DirectPlanning\journal.log�
• Each import file is moved to the time-stamped folder and the .ok extension is added if all records 

were processed successfully. Example: D:\DirectPlanning\ histo\import_001.csv.ok
• Each import file is moved to the time-stamped folder and the .err extension is added if there is at 

least one record in error in this file. Example: D:\DirectPlanning\histo\import_001.csv.err
• The scheduled is backed up after import, provided that no error was encountered during import 

and the automatic backup was not disabled.

These transactions are performed for reasons of security (to avoid a file being imported more than 
once) and traceability (to maintain a history of the different imports and their outcome).

Note
Logging of the schedule can quickly saturate disk space.
Remember the check how the automatic purge of imports is configured (Configuration  > General 
configuration > Automatic import)
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6.2.6. Import result

3 scenarios may arise:

Resuming procedure

Following import, when closing the schedule without saving, 2 scenarios are possible:

1. Make the corrections in the program generating the files to import, regenerate the files to import 
and relaunch the import.

2. Put the affected files back in the import folder, delete the .err extension, directly edit the corresponding 
.csv files you relaunch the import.

◄ No error encountered.

◄ The encountered errors do not necessarily 
require to resume the import.

◄ The encountered errors require to resume the 
import.
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6.3. Exporting data
As discussed earlier, Direct Planning can generate files for third party applications (such as an ERP, 
CAPE, specific program or Excel macro).
Direct Planning exports jobs (with attached flags), links and optionally the daily and weekly workload.

The export is automatically generated each time the schedule is saved.

To configure the export, click on Configuration > General configuration >  Automatic export:

Characteristics of exported files

• CSV format
• Placed in the export folder configured in the screen above (Configuration >  General configuration > 

Automatic export)
• Contain all the modifications made since the last backup.
Named:
- export_task.csv for jobs in the v1 format.
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- export_task_v2.csv for jobs in the v2 format.
- export_link.csv for links in the v1 format (there is no v2 format for links).
- export_calendar_day.csv for calendars and the daily workload.
- export_calendar_week.csv for the weekly workload.

Note
The colon replaces the semicolon in all text zones of the exported file.
The formatted notes are exported as plain text, without formatting and carriage returns. These are 
replaced by the character string %/% (percent slash percent).
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6.3.1. Data export formats

Exporting Process Information

No. Designation Format Comments

1 Data type alpha Possible values: from TASK-IP

2 Version of export format alpha Value: 4

3 Direct Planning identifier for this job alpha

4 Process Information number Num

5 Configurable area 1 alpha

6 Configurable area 2 alpha

7 Configurable area 3 alpha

8 Configurable area 4 alpha

9 Configurable area 5 alpha

10 Configurable area 6 alpha

11 Configurable area 7 alpha

12 Configurable area 8 alpha

13 Configurable area 9 alpha

14 Configurable area 10 alpha
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Exporting jobs

No. Designation Comments

01 Data type Value: TASK or TITLE
Format: alpha

02 Version of import format Values: 4
Format: alpha

03 ERP unique identifier for this job The purpose of this zone is to allow the third party application to 
recognise a job it previously transferred to Direct Planning via the 
import function.
For imported jobs, it contains the number assigned by the external 
software.
For jobs created in Direct Planning, it is set to 0 (zero) unless you give 
it a value during import. When a job is subdivided, the 2 resulting jobs 
are identified by #1 and #2 suffixes.
Format: alpha

04 Direct Planning unique identifier for this 
job

This zone contains the unique internal number assigned by Direct 
Planning.
Format: alpha

05 Date of update Format: datetime

06 Job name Format: alpha

07 Identifier of resource Format: alpha

08 Designation of resource Format: alpha

09 Operation identifier Format: alpha

10 Operation designation Format: alpha

11 Working unit identifier Format: alpha

12 Working unit designation Format: alpha

13 Start date and time Format: datetime***

14 End date and time Format: datetime***

15 Entered earliest start date and time Format: datetime***

16 Earliest start date and time derived from 
flags (with element receipt constraint)

Format: datetime***

17 Earliest start date and time forced by 
upstream jobs of route

Format: datetime***

18 Actual earliest start date and time Format: datetime***

19 Earliest start date and time of route Format: datetime***

20 Latest end date and time entered Format: datetime***

21 Latest end date and time forced by 
downstream jobs of route

Format: datetime***

22 Actual latest end date and time Format: datetime***

23 Latest end date and time of route Format: datetime***

*** Datetime columns use the DD.MM.YYYY hh:mm format (with a space between the year and time).

24 Declared start date and time of job

25 Declared end date and time of job

26 Former start date and time of job
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No. Designation Comments

27 Former end date and time of job

28 Method of time entry

29 Planned quantity Format: quantity

30 Percentage of variable waste Format: decimal

31 Nbr of WU to produce per operative WU Format: decimal

32 Nbr of work rate WU per operative WU Format: decimal

33 Performed quantity

34 Non-compliant quantity

35 Started job

36 Completed job

37 Progress percentage Value: from 0 to 100
Format: num

38 Transition duration Format: duration

39 Planned setting duration Format: duration

40 Performed setting duration Format: duration

41 Performed duration of setting stops

42 Setting completed? Format: O/N

43 Scheduled setting duration Format: duration

44 Planned running duration Format: duration

45 Performed running duration Format: duration

46 Duration of downtime Format: duration

47 Scheduled running duration Format: duration

48 Total planned duration Format: duration

49 Total performed duration Format: duration

50 Total scheduled duration (ex-transition 

times)

Format: duration

51 Total scheduled duration including 

transition times

Format: duration

52 Locked job Value: O/N
Format: alpha

53 Job to schedule Value: O/N
Format: alpha

54 Job alert code 0: No positioning alert
1: The job starts too early.
2: Job may end too late.
3: Job ends too late.
Format: num
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No. Designation Comments

55 Cycle alert code 0: No cycle
1: The job is part of a cycle which is applies on the route of this job
2: The job is caught in a cycle. A job in cycle on the resource blocks the 
job and prevents its movement.
The job does not actually belong to the cycle.
3: Impossible movement
Format: num

56 Alert code of multi-status flag pending 

element receipt

0: No flag in alert
1: At least one Element not received flag in alert
Format: num

57 Manual alert code 0: No manual alert
1: Manual alert positioned
Format: num

58 Manual alert message Format: alpha

59 Identifier of entity 1 Format: alpha

60 Designation of entity 1 Format: alpha

61 Identifier of entity 2 Format: alpha

62 Designation of entity 2 Format: alpha

63 Identifier of entity 3 Format: alpha

64 Designation of entity 3 Format: alpha

65 Identifier of entity 4 Format: alpha

66 Designation of entity 4 Format: alpha

67 Identifier of entity 5 Format: alpha

68 Designation of entity 5 Format: alpha

69 Identifier of entity 6 Format: alpha

70 Designation of entity 6 Format: alpha

71 Identifier of entity 7 Format: alpha

72 Designation of entity 7 Format: alpha

73 Identifier of entity 8 Format: alpha

74 Designation of entity 8 Format: alpha

75 Identifier of entity 9 Format: alpha

76 Designation of entity 9 Format: alpha

77 Identifier of entity 10 Format: alpha

78 Designation of entity 10 Format: alpha

79 Free zone 1 Format: alpha

80 Free zone 2 Format: alpha

81 Free zone 3 Format: alpha

82 Free zone 4 Format: alpha

83 Free zone 5 Format: alpha

84 Free zone 6 Format: alpha

85 Free zone 7 Format: alpha

86 Free zone 8 Format: alpha

87 Free zone 9 Format: alpha
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No. Designation Comments

88 Free zone 10 Format: alpha

No. Designation Comments

89 Identifier of technical element 1 Format: alpha

90 Designation of technical element 1 Format: alpha

91 Identifier of technical element 2 Format: alpha

92 Designation of technical element 2 Format: alpha

93 Identifier of technical element 3 Format: alpha

94 Designation of technical element 3 Format: alpha

95 Identifier of technical element 4 Format: alpha

96 Designation of technical element 4 Format: alpha

97 Identifier of technical element 5 Format: alpha

98 Designation of technical element 5 Format: alpha

99 Identifier of technical element 6 Format: alpha

100 Designation of technical element 6 Format: alpha

101 Identifier of technical element 7 Format: alpha

102 Designation of technical element 7 Format: alpha

103 Identifier of technical element 8 Format: alpha

104 Designation of technical element 8 Format: alpha

105 Identifier of technical element 9 Format: alpha

106 Designation of technical element 9 Format: alpha

107 Identifier of technical element 10 Format: alpha

108 Designation of technical element 10 Format: alpha

109 Identifier of technical element 11 Format: alpha

110 Designation of technical element 11 Format: alpha

111 Identifier of technical element 12 Format: alpha

112 Designation of technical element 12 Format: alpha

113 Identifier of technical element 13 Format: alpha

114 Designation of technical element 13 Format: alpha

115 Identifier of technical element 14 Format: alpha

116 Designation of technical element 14 Format: alpha

117 Identifier of technical element 15 Format: alpha

118 Designation of technical element 15 Format: alpha

119 Identifier of technical element 16 Format: alpha

120 Designation of technical element 16 Format: alpha

121 Identifier of technical element 17 Format: alpha

122 Designation of technical element 17 Format: alpha

123 Identifier of technical element 18 Format: alpha

124 Designation of technical element 18 Format: alpha
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No. Designation Comments

125 Identifier of technical element 19 Format: alpha

126 Designation of technical element 19 Format: alpha

127 Identifier of technical element 20 Format: alpha

128 Designation of technical element 20 Format: alpha

Exporting flags

No. Designation Comments

Flag 1

129 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

130 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

131 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

132 Planned date of receipt Format: datetime***

133 Actual date of receipt Format: datetime***

*** Datetime columns use the DD.MM.YYYY hh:mm format (with a space between the year and time).

134 Configurable area 1 Format: alpha

135 Configurable area 2 Format: alpha

136 Configurable area 3 Format: alpha

137 Configurable area 4 Format: alpha

138 Configurable area 5 Format: alpha

139 Configurable area 6 Format: alpha

140 Configurable area 7 Format: alpha

141 Configurable area 8 Format: alpha

142 Configurable area 9 Format: alpha

143 Configurable area 10 Format: alpha

Flag 2
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No. Designation Comments

144 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

145 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

146 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

147 Planned date of receipt Format: datetime

148 Actual date of receipt Format: datetime

149
▼
158

Configurable area 1

Configurable area 10

Format: alpha

Flag 3

159 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

160 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

161 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

162 Planned date of receipt Format: datetime

163 Actual date of receipt Format: datetime

164
▼
173

Configurable area 1

Configurable area 10

Format: alpha

Flag 4

174 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num
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No. Designation Comments

175 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

176 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

177 Planned date of receipt Format: datetime

178 Actual date of receipt Format: datetime

179
▼
188

Configurable area 1

Configurable area 10

Format: alpha

Flag 5

189 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

190 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

191 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

192 Planned date of receipt Format: datetime

193 Actual date of receipt Format: datetime

194
▼
203

Configurable area 1

Configurable area 10

Format: alpha

Flag 6

204 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

205 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

206 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

207 Planned date of receipt Format: datetime

208 Actual date of receipt Format: datetime
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No. Designation Comments

209
▼
218

Configurable area 1

Configurable area 10

Format: alpha

Flag 7

219 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

220 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

221 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

222 Planned date of receipt Format: datetime

223 Actual date of receipt Format: datetime

224
▼
233

Configurable area 1

Configurable area 10

Format: alpha

Flag 8

234 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

235 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

236 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

237 Planned date of receipt Format: datetime

238 Actual date of receipt Format: datetime

239
▼
248

Configurable area 1

Configurable area 10

Format: alpha

Flag 9
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No. Designation Comments

249 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

250 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

251 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

252 Planned date of receipt Format: datetime

253 Actual date of receipt Format: datetime

254
▼
263

Configurable area 1

Configurable area 10

Format: alpha

Flag 10

264 Status Values:
-1: Unconfigured flag
 0: Inactive flag
 1: Active indicative flag or multi-status flag with status 1
 2: Multi-status flag with status 2
 3: Multi-status flag with status 3
 4: Multi-status flag with status 4
 5: Multi-status flag with status 5
Format: num

265 Status of receipt
(For
Waiting for element receipt flags)

0: The flag is not a Waiting for element receipt flag
1: Waiting for element receipt
2: Received element
Format: num

266 Alert code on this flag 0: No alert on this flag
1: Expired planned receipt date for a waiting for element receipt flag.

267 Planned date of receipt Format: datetime

268 Actual date of receipt Format: datetime

269
▼
278

Configurable area 1

Configurable area 10

Format: alpha
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Exporting links

No. Designation Comments

1 Data type Value: LINK (or TITLE)
Format: alpha

2 Version of export format Value: 4
Format: alpha

3 Direct Planning identifier of source job Format: alpha

4 Direct Planning identifier of destination 

job

Format: alpha

5 External identifier of source job Format: alpha

6 External identifier of destination job Format: alpha

7 Link duration Format: num

Exporting memos

No. Designation Comments

1 Data type Value: LINK (or TITLE)
Format: alpha

2 Version of export format Value: 4
Format: alpha

3 External identifier of job (ERP ID) Format: alpha

4 Direct Planning internal identifier Format: alpha

5 Login of Direct Planning user Format: alpha

6 Comment text To create a line break: \\r
Semicolons are replaced by commas.
Double quotes are doubled.

7 State of alert linked to comment

8 Comment modification date

9 Comment alert date
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Calendars and daily workload

The exported file contains only one type of record: the hours worked by day and by resource (DAILY). 
17 fields exported, translating into 16 semicolons.

The first line of the exported file is a header line to ease the identification of columns (data type = TITLE).

No. Designation Comments

1 Data type Value: DAILY (or TITLE)
Format: alpha

2 Version of export format Value: 1
Format: alpha

3 Date Format: dd/mm/yyyy

4 Direct Planning identifier of the resource Format: alpha

5 Work capacity for this resource at this date In minutes
Format: num

6 Actual workload for this resource at this date In minutes
Format: num

7 Workload percentage for this resource at this date = zone 6/zone 5 X 100
Format: num

8 Range start 1 00:00 as start time means midnight of the day.

00:00 as end time means midnight of the next day.

Start and date time not entered: unused time range

Format: hh:mm

9 Range end 1

10 Range start 2

11 Range end 2

12 Range start 3

13 Range end 3

14 Range start 4

15 Range end 4

16 Range start 5

17 Range end 5

Warning
If you open the export_calendar_day.csv file in Microsoft Excel and the software is configured to not 
display zero values, confusion may arise as 00:00 values no longer appear, mixing up 24 hour and zero 
hour work capacity cases!
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Weekly workload

This file indicates the workload and work capacity by week and by resource.
The exported file contains only one type of record: the hours worked by week and by resource (WEEKLY). 
8 fields exported, translating into 7 semicolons.

No. Designation Comments

1 Data type Value: WEEKLY (or TITLE)
Format: alpha

2 Version of export format Value: 1
Format: alpha

3 Week number Format: num

4 Week start date Format: dd/mm/yyyy

5 Direct Planning identifier of the resource Format: alpha

6 Work capacity of this resource for this week In minutes
Format: num

7 Actual workload of this resource for this week In minutes
Format: num

8 Workload percentage of this resource for this week = zone 7/zone 6 X 100
Format: num

Note
The week spreads from Monday to Sunday.
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7. Administration

AdministrAtion 

This section is, by definition, fully dedicated to the Direct Planning administrator.

7.1. Managing your schedule backups
Configuration > General configuration > Backup copies

Backup copies are made in the DPL2 format.

What is the DPL2 format?

Schedules are saved in a SQL Server database.
Therefore, they are not materialised by files which can be copied in the explorer or with a backup 
management tool.
However, each schedule can be exported in a DPL2 file which can be copied or saved with any Windows-
based tool.

Local backup

Direct Planning’s automatic backup provides basic security.
It is performed every hour, even when users do not purposely perform the backup. Should an incident 
occur, this allows the recovery of a recent backup copy.
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The backup is performed in the following folder:
C:\Users\[utilisateur]\AppData\Roaming\Volume Software\DirectPlanning 2\
backup

Click on                                                                       to reach this folder directly. 

Centralised (network) backup

Further security is provided by saving your schedule on another machine, in a shared and centralised 
folder. To do this, check the corresponding box and specify the backup folder by clicking on the  icon 
on the right.
This folder centralises all backups performed by all computers.
It can integrate with the overall framework of backup procedure in your enterprise.
Click on                                                                             to check that you have writing permissions in this folder.

Backup purge

Finally, you can request the automatic purge of outdated backups by checking the corresponding box. 
The age of backups can be configured: 60 days by default.

Backup summary

In this table:

• Manual backups are those purposely launched by users.
• Automatic backups are those automatically launched by Direct Planning.
• Critical backups are those performed automatically when a crash occurs. They allow the recovery of 

crucial information. You can also send it to us for diagnostic purposes.

Backup Local folder Centralisation folder
(where appropriate)

Manual [Schedule name].[Num].backup.dpl2 [Schedule name].[Num].backup.dpl2

[Schedule name].[Num].backup.[date].dpl2

Automatic [Schedule name].[Num].autosave.dpl2 [Schedule name].autosave.[date].dpl2

Critical [Schedule name].autosave-error.[date].dpl2

[Num] shows the database number, to differentiate different bases sharing the same schedule name.

[date] indicates that the file is time-stamped in the YYYY.MM.DD-hh.mm.ss format.
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Opening DPL2 files

A dedicated tool can be used to display, and eventually modify, the contents of DPL2 files. This tool is 
located in the Direct Planning install directory and is named DPL2_File_Viewer.exe It is reserved for the 
administrator. This tool should be used with extreme caution when modifying DPL2 files.

our Advice 

It is essential to backup the DPL2 file before making any change.
A DPL2 file may be modified upon agreement with Volume Software maintenance staff. 

Start the DPL2_File_Viewer.exe program and open the DPL2 file by clicking on , and Charger (Load):

2  methods are available to view the tables in your .DPL2 file: by selecting a table in the dropdown 
list Table visualisée (Table displayed) or by clicking on the tables displayed above the columns (SYS_
REGISTRE, LISTE_PARAMETRABLE, etc.).

The table and column denominations are internal names used in the database.

Clicking on a column header column sorts the display. To change a piece of data, click a first time in the 
concerned cell. Then click a second time to switch to printing mode.

When you are done with your modifications, click on the Enregistrer (Save) button.
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7.2. Administering databases
Use the File > Administration menu to administer Direct Planning databases.

 ▲ The first time you access the administration module, you must create a password which will be 
requested on each access.

You can change it later.

Warning
This password is separate from the user password of the administrator.

After entering your password, the list of bases displays:

To delete a base, select the base to delete in the list on the left and click on Delete base after checking 
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the corresponding box.

To access the actual administration, choose the database to administer and click on Database 
administration. The following screen opens:

The General tab provides an overview of the base.

The Sessions tab display the history of sessions for the schedule:

  
Double-click on a session to display its details:

The Base info tab offers detailed information about your database (files, data types, sizes, etc.):
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The Table info tab provides information about the tables included in your base (table names, number 
of records, allocated space, etc.):

Finally, use the Maintenance tab allow to perform various operations on the database:

Note regarding the Delete access lock option: a lock prevents 2 computers from modifying simultaneously 
the same schedule. Normally, this lock is released when closing the schedule.
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When Direct Planning is unexpectedly closed, this lock is not released and prevents any modification 
of the schedule. To solve this problem, check the corresponding box and click on Delete access lock�

Warning
Do not try to delete this lock if other people are working on this base, in which case this lock is com-
pletely justified.
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7.3. Licenses
Since version 3, Direct Planning relies on a named license manager, which ensures more freedom in the 
distribution of licenses between the different user stations.
This named license manager is called Volume Licence Administration (VLA)�

30 days trial version

Upon first installation on your station, Direct Planning runs in trial version valid for 30 days.
The trial version is identical to the full offer, without operational limitations.
When the trial period expires, or before if you wish, you can purchase Direct Planning. To do this, please 
contact Volume Software by calling (+00.33) 02.47.66.47.20 or email us at info@directplanning.com.
Contacting Volume Software also gives you the opportunity the extend the trial period.

Registering the Direct Planning license

After the first start, Direct Planning is in trial version, valid for 30 days from the installation date.
This screen acts as a reminder each time you start Direct Planning and the software is not registered.
You can also display this screen by selecting About in the “? “ menu.

Click on Request a licence by email to send us an email containing the information required to grant 
you a license.
Otherwise, click on License entry to open the following window, containing your station key:

◄  When the 30  day trial expires, 
running your software requires a 
license.

Click on License entry or Request a 
license by email to activate Direct 
Planning.

Direct Planning can be activated by 
entering a local activation key or by 
connecting to license server (see next 
pages).
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Entering an activation key

Write down or copy your station key, and transmit it to Volume Software to obtain an activation key. 
When you receive your activation key, click on New license… to enter it manually or paste it:
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Connecting to a license server (in the context of a Server license)

Volume Licence Administration (VLA) must first be installed and configured (please refer to the 
documentation of this product).

Click on Connect to the named license server:

Save and Quit: you are now registered.
Once registered, another click selecting About in the “?” menu shows that your accreditation is renewed 
for a period of one month:

◄ Click on         to search for the Named 
licence  server  file.  Two  buttons  can 
also  be  used  to  check  the  validity  of 
the selected file as well as the license 
for the Machine/Login pair.
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This means that you can stay 30 days without connecting to the server. Beyond this period, you can still 
launch Direct Planning 5 times. Each launch is accompanied by a warning message with a countdown. 
When the countdown is over, you must connect to the server to regain your accreditation.
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7.4. Plugins
Direct Planning includes a plugin manager. Plugins are specific programs which can be called by Direct 
Planning via various triggers such as each backup, each loading, every x minutes, etc.

They are for instance used to generate exchange files towards your ERP, in the native format expected 
by this ERP.

The list of plugins is available by clicking on Configuration > Plugins in the ribbon:

Double-click on a plugin (or click on Modify) to access its detailed information:

While writing plugins is currently reserved to the Direct Planning team, third party developers may also 
be able to contribute to them in the future. Our development team will be happy to assist you with your 
project.

▲  This configuration window is specific to 
the selected plugin.
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Annex A: Keyboard shortcuts

Common quick actions

Call to documentation

Refresh display

Go down the time scale

Go up the time scale

Hide/Show the ribbon (full screen)

About window

  +    /  
Time scale 1, 2, etc.

Common quick actions with Ctrl

  +  
Select all jobs

  +  
Copy

  +  
Paste

  +  
Save

  +  
Search

  +  
Current route

  +  
Locator

  +  
Schedule via a list

  +  
Cancel

  +  
Redo
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  +  
Open the list for entity 1 to 10 (0 for the tenth)

  +  
Selection mode

  +  
Link creation mode

  +  
Enable/Disable highlighting

  +  Mouse wheel  Zoom in

  +  Mouse wheel  Zoom out

  +  
Trace mode

Job on the same criterion, navigation with CTRL (highlighting)

  +  
First job

  +  
Previous job

  +  
Next job

  +  
Last job

Horizontal scroll in the schedule

  or  
Time scroll from a quarter of a screen

  +  Mouse wheel  Time scroll to the future

  +  Mouse wheel  Time scroll to the past

  +   or 
Time scroll from a whole screen

Go to start date of planning assistance

Go to end date of planning assistance

  +  
Go to first job of the machine (if a job is selected)
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  +  
Go to last job

 or 
Go to current date

  +   or 
Go to selected job

Vertical scroll in the schedule

Mouse wheel  or  Vertical scroll in the schedule

Move up in schedule

Move down in schedule

Quick access to tabs

  +  
Show/Hide File menu

  +  
Home menu

  +  
Display menu

  +  
Edit menu

  +  
Planning assistance menu

  +  
Status menu

  +  
Data menu

  +  
Configuration menu
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Annex B: Glossary

Term Definition

Alerts Alerts are messages used to draw attention on specific activities, 
for example if a job ends after the latest end date (retained by 
Direct Planning).

Calculation of running times Running times can be forced or calculated depending on the 
quantity to produce and the work rate. The latter can be indicat-
ed on the machine but it also possible to go beyond, for instance 
by configuring complex formulas which take your business con-
straints into account.

Calculation of setting times Setting times can be forced or calculated according to your busi-
ness rules. For instance, DP can consider the time needed to 
change tools and reduce automatically the setting time of the cur-
rent job uses the same tools as the previous job.

Calendars Calendars allow the definition of machine-specific periods of ac-
tivity/inactivity, regular or exceptional.

Compatible machines Based on your business rules and data, Direct Planning can tell 
whether or not a job can be moved to another machine. Moving a 
job to an incompatible machine displays a warning.

Configurable areas Certain standard data in Direct Planning (machines, jobs, mul-
ti-status flags, entities and Process Information) can be comple-
mented by configurable areas which are customisable according 
to your needs. 

Configurable lists Configurable lists are used to create custom lists tailored to us-
er-specific needs. Each list can be exported to Excel with a single 
click.

Constraints Jobs can be subject to different constraints:
• Strong constraints: earliest start date and links between jobs 

attached to the same route.
• Objective constraints: latest end date.

Declaration of production The declaration of production updates the observed quantities 
and durations. It can be input manually or imported from an ERP/
MES.

Display modes Display modes are used to customise how jobs are displayed and 
coloured in the schedule. They also define time scales and display 
restrictions.

Earliest start/Latest end date When a job/route is selected, its time boundaries are displayed as 
vertical lines (solid or dotted):
• Earliest start date: green dotted line (job), green line (route)
• Latest end date: orange dotted line (job), orange line (route)



207

Direct Planning 3.4 Annex B: Glossary 

Term Definition

Entities Entities are data lists which evolve with your activity (Sales repre-
sentatives, Customers, Orders,…). 
Entities must first be configured according to your needs, provid-
ing a list for each piece of data.

ERP export Direct Planning can return planning data to another application 
able to receive data in the CSV format.

ERP import An application managing jobs can send information to your sched-
ule via Direct Planning’s import function.

Flags Flags are coloured and sometimes hatched bullets located above 
and/or on the right of jobs.

They serve the same purpose as paper clips and other stickers put 
on traditional wall schedules.

Jobs A job represents an occupation or activity at a given time, for a 
given resource.

Jobs to schedule As the name implies, jobs to schedule are jobs that you want to 
see on your schedule without setting them to a specific date.

Links The succession of jobs within a route is materialised by links 
(coloured arrows).

Locked jobs Identified by a lock icon, locked jobs cannot be modified or moved.

Machines Machines are the foundation of the Industry planning.  Please 
note that in Project and Service modes, machines are replaced by 
resources (e.g. rooms, employees, etc.).

Operations Your machines perform operations. 

Examples: this machine makes die-cutting, that machine makes 
bonding, etc.

Planning assistance Planning assistance encompasses a set of powerful tools (adjust-
ment of jobs to the left or right, workload histograms) to optimise 
the schedule.

Plugins Plugins are specific programs that Direct Planning can call with 
triggers.

Process information Process Information is technical data whose display is limited to 
certain machines.

Production route A set of jobs which must be performed in a specific chronological 
order is called a route. A route implies the respect of time con-
straints.

Progress status Direct Planning allows to view the progress status of unfinished 
jobs, materialised by a blue bar, at a glance.
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Term Definition

Reference data Reference data are data lists represented by a code, a designation 
and a colour.
Examples: lists of sales representatives, product families, cutting 
dies, colours, etc.

Sections Sections are groups of machines.

Technical data Technical data are essential components for calculating setting 
times and work rate. They can be quantitative (e.g. dimensions) or 
qualitative (e.g. material types). 

Time scale The time scale is the time axis of the schedule.

Working units Working units express the unit of measure for your machines. 

Examples: panels, sheets, kilograms, copies, linear feet.

Workload histogram The workload histogram is used to analyse workload and capacity 
by machine and section.
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